Oracle CX

Understanding Import and Export Management for CX Sales and B2B Service

22B
# Oracle CX

Understanding Import and Export Management for CX

Sales and B2B Service

## Contents

### Get Help

<table>
<thead>
<tr>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>i</td>
</tr>
</tbody>
</table>

### 1 About This Guide

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Audience and Scope</td>
<td>1</td>
</tr>
<tr>
<td>Related Guides</td>
<td>1</td>
</tr>
</tbody>
</table>

### 2 Overview of Import Management

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>About Import Management Documentation</td>
<td>3</td>
</tr>
<tr>
<td>Data Import Options</td>
<td>3</td>
</tr>
<tr>
<td>Overview of Import Process</td>
<td>8</td>
</tr>
<tr>
<td>File-Size Limits for Import</td>
<td>10</td>
</tr>
<tr>
<td>How You Use Alternate Keys to Import Records</td>
<td>11</td>
</tr>
<tr>
<td>Overview of Oracle WebCenter Content Document Transfer Utility</td>
<td>18</td>
</tr>
</tbody>
</table>

### 3 Get Started with Import

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Import Data</td>
<td>21</td>
</tr>
<tr>
<td>Import Attachments</td>
<td>27</td>
</tr>
<tr>
<td>Delete Attachments</td>
<td>30</td>
</tr>
<tr>
<td>Import Notes</td>
<td>32</td>
</tr>
<tr>
<td>Delete Notes</td>
<td>33</td>
</tr>
<tr>
<td>Manage Hierarchical Import Templates</td>
<td>34</td>
</tr>
<tr>
<td>Example of Importing Contracts Using Hierarchical Import</td>
<td>35</td>
</tr>
<tr>
<td>Import Dynamic Flexfields</td>
<td>36</td>
</tr>
<tr>
<td>Generate the Diagnostics Log for Import</td>
<td>37</td>
</tr>
<tr>
<td>Import Data with Special Characters</td>
<td>37</td>
</tr>
<tr>
<td>Roles Required for Import and Export Management</td>
<td>40</td>
</tr>
</tbody>
</table>

### 4 Import Queues

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Overview of Import Queues</td>
<td>53</td>
</tr>
<tr>
<td>How You Monitor Your Import Activities</td>
<td>54</td>
</tr>
<tr>
<td>How You Monitor Import Activities Using REST APIs</td>
<td>56</td>
</tr>
</tbody>
</table>
## 5 Manage Import Mappings
- How You Map Import Fields .......................... 61
- Create Import Mappings .............................. 62
- Manage Import Mappings ............................ 63
- Import Mappings ............................ 65

## 6 Manage Import Objects
- How You Manage Import Objects ................. 67
- Use Import Object Templates to Import Data .. 68

## 7 Import Custom Objects
- How You Import Custom Objects ................. 71
- Import Custom Object Data .......................... 72
- Update Custom Object Data ........................... 76
- Delete Custom Object Data ............................ 78

## 8 Import Your Data
- Import Account Data ................................ 79
- Import Your Account Contact Data ............... 86
- Import Your Action Data ............................... 91
- Import Your Action Attribute Data ............... 94
- Import Your Action Condition Data ............... 98
- Import Your Action Plan Data ....................... 101
- Import Your Action Plan Action Data ............. 104
- Import Your Action Plan Action Relation Data .. 107
- Import Your Activity Data ............................ 110
- Import Your Activity Assignee Data ............... 128
- Import Your Activity Contact Data ............... 133
- Import Your Activity Objective Data .............. 138
- Import Your Additional Name Data ............... 143
- Import Your Additional Identifier Data .......... 147
- Import Your Address Data ............................ 152
- Import Your Address Locale Data ................. 158
- Import Your Address Purpose Data ............... 161
- Import Asset Data ................................... 165
- Import Your Asset Contact Data .................. 170
- Import Your Asset Resource Data ................. 173
Import Your Assignment Rule Candidate Data  ....................................................................................................... 175
Import Your Assignment Rule Condition Data .................................................................................................. 178
Import Your Assignment Rule Data .................................................................................................................. 181
Import Your Assignment Rule Set Data .................................................................................................................. 183
Import Your Associated Project Data .................................................................................................................. 186
Import Your Attachment Data ............................................................................................................................................. 189
Import Your Bill Plan and Revenue Plan Data .............................................................................................................. 192
Import Your Billing Control Data ............................................................................................................................................. 196
Import Your Business Plan Data ............................................................................................................................................. 199
Import Your Business Plan SWOT Data ..................................................................................................................... 202
Import Your Business Plan Team Data ....................................................................................................................... 206
Import Your Campaign Data ................................................................................................................................................. 209
Import Your Campaign Member Data ............................................................................................................................ 211
Import Your Case Data ............................................................................................................................................................. 214
Import Your Case Contact Data ............................................................................................................................................... 218
Import Your Case Household Data ............................................................................................................................................. 221
Import Your Case Message Data .................................................................................................................................................. 224
Import Your Case Opportunity Data ............................................................................................................................................. 227
Import Your Case Resource Data .................................................................................................................................................. 229
Import Your Category Data .......................................................................................................................................................... 232
Import Your Classification Data ................................................................................................................................................. 235
Import Your Classification Code Data ............................................................................................................................... 240
Import Your Competitor Data ..................................................................................................................................................... 243
Import Contact Data ................................................................................................................................................................. 245
Import Your Contact Member Data ............................................................................................................................................. 251
Import Your Contact Point Data .................................................................................................................................................. 254
Import Your Contest Data .......................................................................................................................................................... 259
Import Your Contest Resources Data ............................................................................................................................................. 262
Import Your Contract Bill Line Data ............................................................................................................................................. 264
Import Your Contract Charge Data .................................................................................................................................................. 267
Import Your Contract Charge Component Data ..................................................................................................................... 270
Import Your Contract Covered Assets Data ......................................................................................................................... 272
Import Your Contract Header Data .................................................................................................................................................. 275
Import Your Contract Header Descriptive Flexfield Data ............................................................................................... 280
Import Your Contract Header Translation Data ..................................................................................................................... 283
Import Your Contract Line Data .................................................................................................................................................. 285
Import Your Contract Line Descriptive Flexfield Data ................................................................................................. 289
Import Your Contract Line Internal Attribute Data 291
Import Your Contract Line Sales Credit Data 295
Import Your Contract Line Translation Data 297
Import Your Contract Manual Adjustments Data 300
Import Your Contract Party Data 303
Import Your Contract Party Contact Data 306
Import Your Contract Party Descriptive Flexfield Data 309
Import Your Contract Party Contact Descriptive Flexfield Data 311
Import Your Contract Pricing Terms Data 314
Import Your Contract Related Document Data 317
Import Your Contract Sales Credit Data 320
Import Your Conversation Data 323
Import Your Conversation Message Data 326
Import Your Conversation Message Recipient Data 328
Import Your Conversation Reference Data 331
Import Country Structure Data 334
Import Your Deal Product Data 339
Import Your Deal Registration Data 344
Import Your Deal Resource Data 348
Import Your Eligibility Rule Data 351
Import Geography Data 355
Import Your Goal Data 361
Import Your Goal Participant Data 364
Import Your Hierarchy Data 367
Import Your Hierarchy Member Data 370
Import Your Household Data 374
Import Your Hub Source System Reference Data 378
Import Your Incentive Compensation Participants 382
Import Your Incentive Participant Goal Data 384
Import Your Incentive Rule Assignment Data 387
Import Your Incentive Rule Attribute Values Data 393
Import Your Incentive Rules Data 396
Import Your Incentive Transaction Data 400
Import Your Interaction Data 405
Import Your Interaction Reference Data 409
Import Your Marketing Development Funds (MDF) Budget Data 412
Import Your MDF Budget Countries Data 415
Import Your MDF Budget Team Data 418
Import Your MDF Claim Data 420
Import Your MDF Claim Settlement Data 424
Import Your MDF Claim Team Data 427
Import Your MDF Request Data 430
Import Your MDF Request Team Data 434
Import Your Message Data 436
Import Your Nonduplicate Data 440
Import Your Opportunity Data 443
Import Your Opportunity Competitor Data 446
Import Your Opportunity Contact Data 449
Import Your Opportunity Deal Data 452
Import Your Opportunity Lead Data 455
Import Your Opportunity Partner Data 457
Import Opportunity Revenue Data 460
Import Your Opportunity Source Data 471
Import Your Opportunity Team Member Data 474
Import Your Organization Data 477
Import Your Overflow Queue Resource Data 481
Import Your Partner Data 484
Import Your Partner Account Resource Data 488
Import Your Partner Address Data 491
Import Your Partner Certification Data 494
Import Your Partner Contact Data 497
Import Your Partner Focus Area Data 501
Import Your Partner Geography Served Data 503
Import Your Partner Program Country Data 506
Import Your Partner Program Tier Data 509
Import Your Partner Type Data 511
Import Your Person Data 514
Import Your Price Book Header Data 518
Import Your Price Book Line Data 522
Import Your Product Data 525
Import Your Product Group Data 530
Import Your Product Group Item Data 535
Import Your Product Group Relation Setup Data 539
Import Your Program Benefit Detail Data 542
Import Your Program Enrollments Data
Import Your Promotion Data
Import Your Queue Data
Import Your Queue Resource Data
Import Your Queue Resource Team Data
Import Your Relationship Data
Import Your Resolution Link Data
Import Your Resolution Link Member Data
Import Resource Data
Import Your Resource Capacity Data
Import Your Sales Lead Data
Import Your Sales Lead Contact Data
Import Your Sales Lead Product Data
Import Your Sales Lead Resource Data
Import Your Sales Objective Data
Import Your Sales Promotion Data
Import Your Sales Resource Period Quota Data
Import Your Sales Resource Quota Data
Import Your Sales Team Member Data
Import Your Sales Territory Data
Import Your Sales Territory Coverage Data
Import Your Sales Territory Line of Business Data
Import Your Sales Territory Period Quota Data
Import Your Sales Territory Quota Data
Import Your Sales Territory Resource Data
Import Your Self-Service Role Data
Import Your Service Request Data
Import Your Service Request Contact Data
Import Your Service Request Message Communication Data
Import Your Service Request Reference Data
Import Your Service Request Resource Data
Import Your SmartText Data
Import Your SmartText Folder Data
Import Your SmartText User Variable Data
Import Your Source System Reference Data
Import Your Subscription Data
Import Your Subscription Bill Adjustment Data
Import Your Subscription Charge Adjustment Data 717
Import Your Subscription Charge Tier Data 720
Import Your Subscription Contact Data 723
Import Your Subscription Covered Bill Line Data 726
Import Your Subscription Covered Level Data 730
Import Your Subscription Covered Level Charge Data 735
Import Your Subscription Party Data 738
Import Your Subscription Product Data 741
Import Your Subscription Product Bill Line Data 749
Import Your Subscription Product Charge Data 753
Import Your Subscription Product Sales Credit Data 757
Import Your Subscription Sales Credit Data 760
Import Your Template Data 763
Import Your Template Action Data 765
Import Territory Geographies Data 768
Import Management Post Processing for Accounts and Contacts 773

9 Import Data Using External Data Loader Client 777
Overview of External Data Loader Client 777
How You Download and Install the External Data Loader Client 777
How You Use the External Data Loader Client 779
Import Job Statuses 780
Command-Line Parameters 780

10 Overview of Export Management 787
About Export Management 787
How You Manage Export Objects 788
Export Queues 791

11 Export Your Data 793
Export Data 793
How You Monitor Export Activity 798
How You Monitor Export Activities Using REST APIs 799
Export Attachments 801

12 Round-Trip Export-Import 803
Round-Trip Feature 803
Oracle CX
Understanding Import and Export Management for CX
Sales and B2B Service

Export and Import Account Data between CX Sales and B2B Service Instances Using the Round-Trip Feature 804

13 Best Practices and Troubleshooting 805

- Best Practices for High Volume Data Import 805
- Potential Issues When Opening CSV Files in Excel 808
- Best Practices for Round-Trip Export and Import 809
Get Help

There are a number of ways to learn more about your product and interact with Oracle and other users.

Get Help in the Applications
Use help icons Help icon to access help in the application. If you don't see any help icons on your page, click your user image or name in the global header and select Show Help Icons.

Get Support
You can get support at My Oracle Support. For accessible support, visit Oracle Accessibility Learning and Support.

Get Training
Increase your knowledge of Oracle Cloud by taking courses at Oracle University.

Join Our Community
Use Cloud Customer Connect to get information from industry experts at Oracle and in the partner community. You can join forums to connect with other customers, post questions, suggest ideas for product enhancements, and watch events.

Learn About Accessibility
For information about Oracle's commitment to accessibility, visit the Oracle Accessibility Program. Videos included in this guide are provided as a media alternative for text-based topics also available in this guide.

Share Your Feedback
We welcome your feedback about Oracle Applications user assistance. If you need clarification, find an error, or just want to tell us what you found helpful, we'd like to hear from you.

You can email your feedback to oracle_fusion_applications_help_ww_grp@oracle.com.

Thanks for helping us improve our user assistance!
1 About This Guide

Audience and Scope

If you import and export business data in CX Sales and B2B Service, then this guide is for you.

Note: Oracle has discontinued the File-Based Data Import and Export support for CX Sales and B2B Service Objects with the 20D Update. We strongly recommend that you move to the new Import and Export Management application (available from Navigator > Tools > Import Management/Export Management) to continue importing and exporting your data. As you migrate to the new framework, make sure you upgrade both manual processes and automated or scheduled processes. Note that data maps aren’t portable between frameworks and must be recreated as a one-time activity.

Before getting started, make sure your company’s CX Sales and B2B Service is up and running at a basic level. You can find these details in the use case contained in the Getting Started with Your Sales Implementation guide.

To set up and work with the additional features of CX Sales and B2B Service, see CX Sales and B2B Service documentation on Oracle Help Center at https://docs.oracle.com.

Related Guides

You can refer to the following related guides to understand more about the tasks covered in this guide.

<table>
<thead>
<tr>
<th>Title</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Oracle Applications Cloud Configuring Applications Using Application Composer</td>
<td>Provides information on how sales administrators and implementors can make application changes using the available configuration toolset.</td>
</tr>
<tr>
<td>Getting Started with Your Sales Implementation</td>
<td>Provides you with the concepts and procedures you need to implement a sales automation solution.</td>
</tr>
<tr>
<td>Implementing Customer Data Management for CX Sales and B2B Service</td>
<td>Provides conceptual information and procedures needed to implement customer data management-specific components and features of your application.</td>
</tr>
<tr>
<td>Implementing Sales</td>
<td>Provides conceptual information and procedures used to implement sales application components and features.</td>
</tr>
<tr>
<td>Using Sales</td>
<td>Provides information about performing day-to-day tasks in your sales applications... If you’re a sales person, sales manager, or any other sales user, then this guide is for you.</td>
</tr>
<tr>
<td>Title</td>
<td>Description</td>
</tr>
<tr>
<td>-------</td>
<td>-------------</td>
</tr>
<tr>
<td>Using Customer Data Management for CX Sales and B2B Service</td>
<td>Provides information about managing customer information and customer data quality. If you’re an end user of the customer data management functionality such as customer data steward and data steward manager, then this guide is for you.</td>
</tr>
</tbody>
</table>

**Related Topics**

- [Oracle Help Center](#)
2 Overview of Import Management

About Import Management Documentation

This topic provides an overview of the types of help available for importing data into Oracle Applications Cloud using Import Management.

You can get the information about import from the following:

  - Explore the latest critical reference content supporting CX Sales and B2B Service.
  - Download PDF versions of guides, find links to reference materials and white papers, and search for specific topics.
  - Browse import data topics on the Administer tab that provide key import information.

To understand what attributes are available for import for each object, start by searching help using the keywords Import Your <Object Name> Data. For example, to get help on importing accounts, enter Import Your Account Data.

Data Import Options

You can import your data from an external application into Oracle Applications Cloud in several different ways, including using public web services.

Which import method you use depends on the type of data you're importing, the volume of data, and technical requirements. If you're integrating one cloud service with other cloud services, then you must use additional import methods as described in the appropriate guides.

When you're importing data for a particular object, you must make sure that any prerequisite objects already exist in the application. For example, if you're importing contacts for an account, then the account must already exist in the application. If one import job depends on the contents of another import job, then complete the prerequisite job before starting the dependent job. For example, if you're importing both accounts and opportunities, then import accounts before importing opportunities.

The following table lists the import methods and references to further information.

<table>
<thead>
<tr>
<th>Import Method</th>
<th>Description</th>
<th>When to Use</th>
<th>How to Access</th>
<th>For More Information</th>
</tr>
</thead>
<tbody>
<tr>
<td>Quick Import Excel Macros</td>
<td>You can use the import macros to speed up and simplify the import of up</td>
<td>These are best to import data in your initial deployment.</td>
<td>You can download the Excel macros and any required mapping files from the</td>
<td>The chapters in the Getting Started with Your Sales Implementation</td>
</tr>
</tbody>
</table>
## Overview of Import Management

<table>
<thead>
<tr>
<th>Import Method</th>
<th>Description</th>
<th>When to Use</th>
<th>How to Access</th>
<th>For More Information</th>
</tr>
</thead>
</table>
| Import Management | Improves definition, error handling, and performance for importing flat files (.CSV). For example, Import Management has drag and drop mapping capabilities and validates the first ten records in your data file before you import to ensure the data meets the import constraints of the various attributes. Import Management is available for importing data for the following application objects and their child objects:  
  - Access Groups  
  - Account  
  - Action  
  - Action Plan  
  - Activity  
  - Address  
  - Asset  
  - Attachment | The macros are targeted to the simple proof of concept sales automation use case covered in the Importing Sales Users chapter of the Getting Started with Your Sales Implementation guide. For example, the import macros assume that you’re importing account, contact, and lead records for one country at a time. The macros generate log files with information about the File Import job, and these log files can also serve as a learning tool for more complex import. | Click **Import Management** in the Navigator. | See the Understanding Import and Export Management guide for instructions on using the import. |
<table>
<thead>
<tr>
<th>Import Method</th>
<th>Description</th>
<th>When to Use</th>
<th>How to Access</th>
<th>For More Information</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Business Plan</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Campaign</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Case</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Classification</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Classification Code</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Competitor</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Consumer</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Contact</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Contract</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Contests</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Country Structure</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Deal Registration</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Hierarchy</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Hierarchy Member</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Household</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Hub Source System Reference</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Incentive Rule Assignments</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Incentive Rule Attribute Values</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Incentive Rules</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Incentive Transaction</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Interaction</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>MDF Budget</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>MDF Claim</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>MDF Request</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Note</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Objective</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Opportunity</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Organization</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Partner</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Partner Program</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Person</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Price Book Header</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Product</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Product Group</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Program Enrollment</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Promotion</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Queue</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Import Method</td>
<td>Description</td>
<td>When to Use</td>
<td>How to Access</td>
<td>For More Information</td>
</tr>
<tr>
<td>-------------------------------</td>
<td>-----------------------------------------------------------------------------</td>
<td>----------------------------------------------------------------------------</td>
<td>----------------------------------------------------------------------------</td>
<td>-----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td></td>
<td>• Relationship&lt;br&gt;- Resource&lt;br&gt;- Resource Capacity&lt;br&gt;- Sales Lead&lt;br&gt;- Sales Order&lt;br&gt;- Sales Territory&lt;br&gt;- Sales Territory Quota&lt;br&gt;- Self-Service Role&lt;br&gt;- Service Request&lt;br&gt;- Standard Text&lt;br&gt;- Standard Text Folder&lt;br&gt;- Standard Text User Variable&lt;br&gt;- Subscription&lt;br&gt;- Template&lt;br&gt;- Template Action&lt;br&gt;- Territory Geographies&lt;br&gt;- Any additional objects you create</td>
<td>Use this method for importing very large data files for the objects supported by Import Management.</td>
<td>You can download the client from Oracle Support Document 23252491 (External Data Loader Client) on My Oracle Support.</td>
<td>Instructions for using the client are available in the document and in the client itself. The chapter Import Data Using External Data Loader Client in the guide Understanding Import and Export Management for CX Sales and B2B Service provides information about using the External Data Loader Client.</td>
</tr>
<tr>
<td>External Data Loader Client</td>
<td>Command-line tool that's used to import high-volume flat source data files into CX Sales and B2B Service. This tool splits a large data file into multiple smaller files to adhere to import volume limits, and enables the tracking of import status. The client supports the same objects as Import Management.</td>
<td>Use this import method for importing very large data files for the objects supported by Import Management.</td>
<td>You can download the client from Oracle Support Document 23252491 (External Data Loader Client) on My Oracle Support.</td>
<td>Instructions for using the client are available in the document and in the client itself. The chapter Import Data Using External Data Loader Client in the guide Understanding Import and Export Management for CX Sales and B2B Service provides information about using the External Data Loader Client.</td>
</tr>
<tr>
<td>Web Services</td>
<td>Web services are available for external client applications to start and monitor import jobs. You can manage Import Management jobs using REST web services, and File Import jobs using SOAP web services.</td>
<td>Use web services to manage import jobs to import directly from an external application.</td>
<td>Public APIs are available for both the Import Management/REST services and the File Import/SOAP services. The following REST APIs are available for import: • Import Activities • Import Activity Maps • Import Export Objects Metadata</td>
<td>For REST API documentation, see the REST API for CX Sales and B2B Service guide. For SOAP API documentation, see the SOAP Web Services for CX Sales and B2B Service guide.</td>
</tr>
</tbody>
</table>
## Overview of Import Management

<table>
<thead>
<tr>
<th>Import Method</th>
<th>Description</th>
<th>When to Use</th>
<th>How to Access</th>
<th>For More Information</th>
</tr>
</thead>
</table>
| High-Volume Import  | The high-volume import mode is designed to import millions of records at once. This mode doesn't trigger any custom logic configured through the application composer. This option is available for the following objects and their child objects:  
- Account  
- Asset  
- Classification Code  
- Contact  
- Contract  
- Contract Line  
- Country Structure  
- Custom Object (custom top level objects and custom child objects)  
- Geography  
- Hierarchy  
- Hierarchy Member  
- Household  
- Hub Source System Reference  
- Incentive Transaction  
- Organization  
- Person  
- Sales Territory Quota  
- Territory Geographies | Use this import mode for importing very large number of records for the objects supported. | You can access High-Volume Import either using REST services or using External Data Loader Client.  
When importing using REST, set the "High-volume" attribute to enable this mode of import.  
When importing using the External Data Loader Client, set the command-line parameter "-high-volume" to enable this mode of import. | For REST API documentation, see the REST API for CX Sales and B2B Service guide.  
The chapter Import Data Using External Data Loader Client in the guide Understanding Import and Export Management for CX Sales and B2B Service provides information about using the External Data Loader Client. |

**Note:** Object work flows can't be invoked using Import Management.

The following figure provides an architectural overview of the different import methods:

- File Import uses the SOA architecture to import data into Oracle CX Sales.
- Quick Import uses the REST Web services to import data into Oracle CX Sales. When you import data using the quick import Excel macros, you're creating an import activity in Import Management using the REST web services. The macro import creates the same import activity and uses the same mapping as you do when you initiate the import from the application. You can monitor each import in the macro or in the application itself.
• Both Import Management and the External Data Loader Client use the same scheduled processes for import. When you import very large files using the client, the REST APIs create multiple processes to respect the Import Management file size limit.

• To import from an external application, use the SOAP and REST web services directly.

Import Options and Flow

Related Topics

Overview of Import Process

This topic provides an overview of the components used to import data.
Import Process Flow
The following figure explains the various stages in the import process:

1. Evaluate your import data.
2. Identify the relevant import objects.
3. Map your data to the import objects.
4. Create an import activity.
5. Verify the import results.
Import Objects and Import Queue
You can find details about the attributes such as data type, length, and user key information for each object on the Import Objects tab. You can download the template for each import object by clicking the Download icon. You can create a mapping either while creating an import or separately using the Import Objects tab. On the Import Object Details page, click the Display Name link for the object to navigate to the Manage Mapping page. On this page, you can create a new import mapping, upload a map, or manage an existing mapping.

The Import Queue tab lets you view the imports that are in various statuses, such as active, completed, or unsuccessful. You can further drill down into an import activity by clicking the import name link to view the status details.

Application Composer and Custom Extensions
If you create additional attributes on an object in Application Composer, then these extensions are available for import and export once you publish your sandbox.

File-Size Limits for Import
You can import a maximum of 50,000 records per data file. This limit is applicable for files imported using the User Interface and the REST service (low-volume). The size of the data file can’t exceed 250 MB.

You can submit multiple jobs at one time. However, the application processes only 10 jobs at a time. All other jobs are queued and executed as and when the previous jobs complete.

**Note:** If you’re using the importActivities REST service to submit jobs (also known as ‘import activities’), then each job can contain up to 20 CSV files in the request payload. This means that 10 jobs, each with 20 CSV files of 50,000 records, can instruct the application to process up to one million records at a time.

To import much higher volumes of data, you must use the External Data Loader Client (EDLC). EDLC accepts files with more than 50,000 records. It breaks these larger files into smaller pieces of 50,000 each and imports them. Using the high-volume mode of EDLC, you can split and import in pieces of 500,000 records each.

Here are the file and record limits for Import Management:

<table>
<thead>
<tr>
<th>Import Channel and Mode</th>
<th>Maximum Number of Files per job Submission</th>
<th>Maximum Records Processed in a Single Submission</th>
</tr>
</thead>
<tbody>
<tr>
<td>User Interface (low-volume)</td>
<td>1 file (50k records)</td>
<td>50k records</td>
</tr>
<tr>
<td>REST Service (low-volume)</td>
<td>50k records per file</td>
<td>Unlimited (Must be manually split by the user into 50k record files)</td>
</tr>
<tr>
<td>EDLC (low-volume)</td>
<td>50k records per file</td>
<td>Unlimited (EDLC splits into 50k record files by default, and submits in a single REST call.)</td>
</tr>
<tr>
<td>User Interface (high-volume)</td>
<td>1 file (500k records)</td>
<td>Unlimited (Must be manually split by the user into 500k record files)</td>
</tr>
</tbody>
</table>
Overview of Import Management

### Import Channel and Mode

<table>
<thead>
<tr>
<th>Import Channel and Mode</th>
<th>Maximum Number of Files per job Submission</th>
<th>Maximum Records Processed in a Single Submission</th>
</tr>
</thead>
<tbody>
<tr>
<td>REST Service (high-volume)</td>
<td>500k records per file</td>
<td>Unlimited (Must be manually split by the user into 500k record files)</td>
</tr>
<tr>
<td>EDLC (high-volume)</td>
<td>500k records per file</td>
<td>Unlimited (EDLC splits into 200k record files by default, and submits in a single REST call.)</td>
</tr>
</tbody>
</table>

**Note:** Oracle recommends that you use EDLC (high-volume) import for the supported objects and that you limit the job to 2 million records with 20 files per job (around 100k records per CSV file). If you plan to run parallel import batches, Oracle recommends that you run a maximum of 10 parallel batches. User performance will vary based on your data and configuration. The recommendation of 10 parallel batches of 100 K records is a tip to get you started. You need to explore and identify the configuration that best suits your organization’s requirements.

**Note:** Ensure that purge and imports aren't running in parallel for the same object at the same time.

### How You Use Alternate Keys to Import Records

Alternate keys help you uniquely identify object records, so that you can create, update, delete, and manage relationships. This helps you import and build relationships to other objects, without the need to know the system-generated primary keys of each record.

Use of known alternate keys also eliminates the need to requery and remap data.

Here are some examples of Alternate Keys:

- **Public Unique Identifier (PUID)** - supports the ability to define an auto-generated sequence number.
- **Original System/Original System Reference (OS/OSR)** - consists of two fields:
  - Original System - refers to the source system from which the record was sourced. Administrator must configure this field.
  - Original System Reference - refers to the unique identifier for the record in the source system.
- **Email Address** - the email address value of a record can be used on some objects (such as Employee Resource) to identify a record.

The keys resolve in the following order of precedence:

1. **Primary Key (PK)**
2. **Public Unique Identifier (PUID)**
3. **OS/OSR (if applicable)**
4. **Any other alternate keys (PUID must be the first alternate key in the order of precedence if more than one alternate key is supported)**

Here is the use case supported in Import Management, high-volume import mode, and External Data Loader Client:
**What You're Trying to do**  |  **How to do it**
---|---
Update a value on a record  |  - Refer to the record using object-specific Primary Key(s) or using object specific PUID(s). For example, `LeadId(PK)` and `ResourceId(PK)` or `LeadNumber(PUID)` and `PartyNumber(PUID)`
  - Refer to the record only by one of its defined AK values
  - Refer to the record only by one of its defined OS/OSR values

When performing updates using Import Management, if you have multiple rows in the source CSV file, each using the same PK or PUID values, then the records in your source file may not be processed in the order in which they're listed.

**Scenarios for Creating, Updating, and Deleting Records**

Scenario A shows the different ways of creating, updating, and deleting records using different combinations of keys with account object as an example. The following image and tables highlight the use cases for this scenario:
### Scenario A for alternate key import

<table>
<thead>
<tr>
<th>Column</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>PartyId</td>
<td>Primary key. Value comes from system-generated document sequence number. Never null.</td>
</tr>
<tr>
<td>PartyNumber</td>
<td>PUID. When record is created value is either passed in or system-generated. Never null.</td>
</tr>
<tr>
<td>SourceSystem</td>
<td>Source system name. Can be null. (Only a limited number of objects support OS/OSR construct)</td>
</tr>
<tr>
<td>SourceSystemReferenceValue</td>
<td>Source system reference. Can be null. (Only a limited number of objects support OS/OSR construct)</td>
</tr>
<tr>
<td>Use Case</td>
<td>Source file contents</td>
</tr>
<tr>
<td>-------------------------------------------------------------------------</td>
<td>--------------------------------------------------------------------------------------</td>
</tr>
</tbody>
</table>
| Create a record, pass in PUID on primary object                         | PartyNumber: CA4139
              CEOName: John Smyth                                                               | A record created        | 98769 (system-generated) | CA4139        | N/A         | N/A         | John Smyth   |
| Create a record, without passing PUID value on primary object           | CEOName: John Smyth                                                                  | A record created        | 98770 (system-generated) | CA4140 (system-generated) | N/A         | N/A         | John Smyth   |
| Create a record, pass in OS/OSR on primary object                       | SourceSystem: Siebel CRM
            SourceSystemReferenceValue: 3-0007
              CEOName: John Smyth                                                               | A record created        | 98771 (system-generated) | CF380A (system-generated) | Siebel CRM  | 3-0007      | John Smyth   |
| Update data attribute on existing record, using PK to identify the record| PartyId : 98769
              CEOName: Soloman                                                                 | Record updated           | 98769             | N/A           | N/A         | N/A         | Soloman      |
| Update data attribute on existing record, using OS/OSR to identify the record| SourceSystem: Siebel CRM
            SourceSystemReferenceValue: 3-0007
              CEOName: Soloman                                                                 | Record updated           | 98771             | N/A           | Siebel CRM  | 3-0007      | Soloman      |
| Delete existing record, using PK to identify the record                | PartyId : 98769                                                                    | Record deleted          | 98769           | N/A           | N/A         | N/A         |              |
| Delete existing record, using PUID to identify the record              | PartyNumber : CA4140                                                                | Record deleted          | 98770           | CA4140        | N/A         | N/A         |              |
Oracle CX
Understanding Import and Export Management for CX
Sales and B2B Service

Chapter 2
Overview of Import Management

<table>
<thead>
<tr>
<th>Use Case</th>
<th>Source file contents</th>
<th>Description</th>
<th>PK</th>
<th>PUID</th>
<th>OS</th>
<th>OSR</th>
<th>Non-key Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>Delete existing record,</td>
<td>SourceSystem: Siebel</td>
<td>Record deleted</td>
<td>98771</td>
<td>N/A</td>
<td>Siebel</td>
<td>3-0007</td>
<td>N/A</td>
</tr>
<tr>
<td>using OS/OSR to identify</td>
<td>CRM</td>
<td></td>
<td></td>
<td></td>
<td>CRM</td>
<td></td>
<td></td>
</tr>
<tr>
<td>the record</td>
<td>SourceSystemRef: 3-0007</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Scenario B shows the different ways of creating child records, updating and deleting relationship to the parent record. Here account is the parent and address is the child object. The following image and tables highlight the use cases for this scenario:

Scenario B for alternate key import

![Diagram showing the process of importing and managing records](Diagram.png)
## Overview of Import Management

<table>
<thead>
<tr>
<th>Column</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>PartyId</td>
<td>Primary key. Value comes from system-generated document sequence number. Never null.</td>
</tr>
<tr>
<td>PartyNumber</td>
<td>PUID. When record is created value is either passed in or system-generated. Never null.</td>
</tr>
<tr>
<td>SourceSystem</td>
<td>Source system name. Can be null.</td>
</tr>
<tr>
<td>CEOName</td>
<td>This is a non-key data attribute on the object. Can be null.</td>
</tr>
<tr>
<td>PartyId</td>
<td>Foreign key to the parent record. This value contains the PK of the record in the parent object.</td>
</tr>
<tr>
<td>PartyNumber</td>
<td>Foreign key to the parent record. This value contains the PUID of the record in the parent object.</td>
</tr>
<tr>
<td>AddressNumber</td>
<td>This value contains the PUID of the record in the child object.</td>
</tr>
<tr>
<td>PartySourceSystem</td>
<td>Source system value of the parent object.</td>
</tr>
<tr>
<td>PartySourceSystemReferenceValue</td>
<td>Source system reference value of the parent object.</td>
</tr>
</tbody>
</table>

### Use Case

<table>
<thead>
<tr>
<th>Use Case</th>
<th>Source file contents</th>
<th>Description</th>
<th>PK</th>
<th>PUID</th>
<th>Parent PUID</th>
<th>Parent OS</th>
<th>Parent OSR</th>
<th>OS</th>
<th>OSR</th>
<th>Non-key Data</th>
<th>Foreign Key</th>
</tr>
</thead>
<tbody>
<tr>
<td>Create a child record, pass in custom PUID and parent object PK value</td>
<td>PartyNumber CA2700</td>
<td>A child record is created, relationship to parent is established through PK</td>
<td>5001</td>
<td>CA2700</td>
<td>N/A</td>
<td>N/A</td>
<td>N/A</td>
<td>N/A</td>
<td>N/A</td>
<td>N/A</td>
<td>Rhode</td>
</tr>
<tr>
<td>Create a child record, pass in parent object PUID value</td>
<td>CEOName: Rhode</td>
<td>A child record is created, relationship to parent is established through PUID</td>
<td>5002</td>
<td>system-generated</td>
<td>CA2700</td>
<td>N/A</td>
<td>N/A</td>
<td>N/A</td>
<td>N/A</td>
<td>N/A</td>
<td>Rhode</td>
</tr>
<tr>
<td>Update the relationship to point to</td>
<td>PartyNumber CA2700</td>
<td>Existing child record updated</td>
<td>5001</td>
<td>CA2700</td>
<td>N/A</td>
<td>N/A</td>
<td>N/A</td>
<td>N/A</td>
<td>N/A</td>
<td>N/A</td>
<td>Rhode</td>
</tr>
</tbody>
</table>
### Use Case: Creating a Child Record, Pass in Parent Object OS/OSR Value

<table>
<thead>
<tr>
<th>Use Case</th>
<th>Source file contents</th>
<th>Description</th>
<th>PK</th>
<th>PUID</th>
<th>Parent PUID</th>
<th>Parent OS</th>
<th>Parent OSR</th>
<th>OS</th>
<th>OSR</th>
<th>Non-key Data</th>
<th>Foreign Key</th>
</tr>
</thead>
<tbody>
<tr>
<td>A child record, pass in parent object OS/OSR value</td>
<td>PartySource System: Siebel CRM PartySourceReferenceValue: 3-0001 SourceSystem: Siebel CRM SourceSystemReferenceValue: 3-9001</td>
<td>A child record is created, relationship to parent is established through OS/OSR</td>
<td>CA2701</td>
<td>N/A</td>
<td>Siebel CRM</td>
<td>3-0001</td>
<td>Siebel CRM</td>
<td>3-9001</td>
<td>N/A</td>
<td>N/A</td>
<td>N/A</td>
</tr>
</tbody>
</table>

### Use Case: Creating a Child Record, Pass in Parent Object PUID Value

<table>
<thead>
<tr>
<th>Use Case</th>
<th>Source file contents</th>
<th>Description</th>
<th>PK</th>
<th>PUID</th>
<th>Parent PUID</th>
<th>Parent OS</th>
<th>Parent OSR</th>
<th>OS</th>
<th>OSR</th>
<th>Non-key Data</th>
<th>Foreign Key</th>
</tr>
</thead>
<tbody>
<tr>
<td>A child record, pass in parent object PUID value</td>
<td>PartyNumber: CDRM-2001</td>
<td>A child record is created, relationship to parent is established through Parent PUID</td>
<td>CA2702</td>
<td>CDRM-200</td>
<td>N/A</td>
<td>N/A</td>
<td>Siebel CRM</td>
<td>3-9002</td>
<td>N/A</td>
<td>N/A</td>
<td>N/A</td>
</tr>
</tbody>
</table>

### Use Case: Creating a Child Record, Pass in Parent Object Foreign Key Value

<table>
<thead>
<tr>
<th>Use Case</th>
<th>Source file contents</th>
<th>Description</th>
<th>PK</th>
<th>PUID</th>
<th>Parent PUID</th>
<th>Parent OS</th>
<th>Parent OSR</th>
<th>OS</th>
<th>OSR</th>
<th>Non-key Data</th>
<th>Foreign Key</th>
</tr>
</thead>
<tbody>
<tr>
<td>A child record, pass in parent object foreign key value</td>
<td>PartyId: 1234</td>
<td>A child record is created, relationship to parent is established through foreign key</td>
<td>CA2703</td>
<td>N/A</td>
<td>N/A</td>
<td>N/A</td>
<td>Siebel CRM</td>
<td>3-9003</td>
<td>N/A</td>
<td>1234</td>
<td>17</td>
</tr>
</tbody>
</table>

### Use Case: Delete the Relationship to the Parent

<table>
<thead>
<tr>
<th>Use Case</th>
<th>Source file contents</th>
<th>Description</th>
<th>PK</th>
<th>PUID</th>
<th>Parent PUID</th>
<th>Parent OS</th>
<th>Parent OSR</th>
<th>OS</th>
<th>OSR</th>
<th>Non-key Data</th>
<th>Foreign Key</th>
</tr>
</thead>
<tbody>
<tr>
<td>Delete the relationship to the parent</td>
<td>PartyId: 5002</td>
<td>ERROR - child record should not exist stand alone. Must have relationship to a parent. (Address object is an exception to this.)</td>
<td>N/A</td>
<td>N/A</td>
<td>N/A</td>
<td>N/A</td>
<td>N/A</td>
<td>N/A</td>
<td>N/A</td>
<td>N/A</td>
<td>N/A</td>
</tr>
</tbody>
</table>
Overview of Import Management

<table>
<thead>
<tr>
<th>Use Case</th>
<th>Source file contents</th>
<th>Description</th>
<th>PK</th>
<th>PUID</th>
<th>Parent PUID</th>
<th>Parent OS</th>
<th>Parent OSR</th>
<th>OS</th>
<th>OSR</th>
<th>Non-key Data</th>
<th>Foreign Key</th>
</tr>
</thead>
<tbody>
<tr>
<td>Delete child record using PUID to identify the record</td>
<td>AddressNumber: CDRM-9001</td>
<td>Delete a child record using the PUID of the record</td>
<td>N/A</td>
<td>CDRM-900</td>
<td>N/A</td>
<td>N/A</td>
<td>N/A</td>
<td>N/A</td>
<td>N/A</td>
<td>N/A</td>
<td></td>
</tr>
<tr>
<td>Delete child record using OS/OSR to identify the record</td>
<td>SourceSystem: Siebel CRM SourceSystemReferenceValue: 3-0007</td>
<td>Delete a child record using OS and OSR</td>
<td>N/A</td>
<td>N/A</td>
<td>N/A</td>
<td>N/A</td>
<td>N/A</td>
<td>N/A</td>
<td>Siebel CRM</td>
<td>3-0007</td>
<td>N/A</td>
</tr>
<tr>
<td>Delete child record using primary key</td>
<td>AddressId: 9898989</td>
<td>Delete a child record using primary key</td>
<td>9898989</td>
<td>N/A</td>
<td>N/A</td>
<td>N/A</td>
<td>N/A</td>
<td>N/A</td>
<td>N/A</td>
<td>N/A</td>
<td></td>
</tr>
</tbody>
</table>

Overview of Oracle WebCenter Content Document Transfer Utility

The WebCenter Content Document Transfer Utility is a set of command line interface tools that provide capabilities to import and export content from a local system to the Oracle WebCenter Content Server.

The tool has the following components:

- The DownloadTool is used to retrieve a content item from Oracle WebCenter Content Server and save its contents to a local file.
- The UploadTool is used to create a new content item in Oracle WebCenter Content Server based on contents streamed from a local file.
- The SearchTool is used to locate content items within Oracle WebCenter Content Server matching specific query criteria.
- The StorageTool is used for migrating applicable Oracle WebCenter Content Server documents from the server’s file system to secure file storage within the Oracle Database.

You can find the details of using each tool, along with sample commands, in the Readme html file downloaded as part of the tool.
Variants of the Utility

Two forms of the transfer utilities exist:

- The transfer utility based on Remote Intradoc Client (RIDC), (oracle.ucm.fa_client) which is a feature-set Java library that encapsulates Oracle WebCenter Content RIDC and uses standard HTTPS to communicate with the Oracle WebCenter Content server. Tools belonging to the RIDC-based transfer utility begin with the package oracle.ucm.client, such as oracle.ucm.client.UploadTool. This utility has no additional library dependencies. The feature-set Java library that bundles the RIDC-based transfer utility repackages the RIDC classes and leverages the HTTP client provided by the Java Virtual Machine (JVM).

- The generic soap-based transfer utility (oracle.ucm.fa_genericclient) which requires the Java Required Files (JRF) web service supporting libraries and uses Java API for XML Web Services (JAX/WS) over HTTPS to communicate with the Oracle WebCenter Content server. Tools belonging to the generic soap-based transfer utility begin with the package oracle.ucm.idcws.client, such as oracle.ucm.idcws.client.UploadTool. This utility has dependencies on the JRF JAX/WS web service client stack and Oracle Web Services Manager (WSM). The stack in turn also looks for Middleware Platform Security and Audit Framework configuration files and libraries, and logs warnings if these are unavailable.

Downloading the Tool

You can download the Oracle WebCenter Content Document Transfer Utility by navigating to the My Oracle Support (support.oracle.com) document Oracle WebCenter Content Document Transfer Utility Readme (document ID 1624063.1). Once downloaded, you can run the tool by navigating to the ridc folder after extraction.

Command Documentation

Documentation for the tools is contained in the root directory of the tool download ZIP in a file named "WebCenter Content Document Transfer Utility Readme.html". This documentation describes various program options available, along with requirements such as Java version and supporting libraries required. A change log is included as well.
3 Get Started with Import

Import Data

Use Import Management from the Tools work area, to import data from text files. You can create, update, or delete records through import.

Use this topic as a guide to importing data. The import options and other details differ by the type of data that you’re importing. Before importing, understand how the data in your file maps to the attributes in Oracle Applications Cloud and what values are expected in the import file. The data records in the CSV source file may not be processed in the listed order. To learn how to monitor the status of your import, see the topic How You Monitor Your Import Activities in the Related Topics section.

**Note:** Don’t submit duplicate import jobs for the same import object as they create duplicate object records.

To help you get started, you can use the example import object templates described in the related topics.

Import Data from a File

To import data:

1. Click **Tools > Import Management**.
2. On the **Manage Imports** page, click the **Create Import Activity** button.
3. On the **Enter Import Options** page provide values for each field as shown in the following table:

<table>
<thead>
<tr>
<th>Field</th>
<th>Description of the value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>Name of the import.</td>
</tr>
<tr>
<td>Object</td>
<td>Object that you’re importing.</td>
</tr>
<tr>
<td></td>
<td>If you can’t find your object, then search for it by clicking the <strong>Search</strong> link. In the <strong>Search and Select</strong> dialog box, enter the object name in the <strong>Object</strong> text box and click the <strong>Search</strong> button. Select your object from the result list and click <strong>OK</strong>.</td>
</tr>
<tr>
<td></td>
<td>You can also use the advanced search option by clicking the <strong>Advanced</strong> button. Here you can search based on various filter criteria such as object name, Attachment supported, creation date, and so on.</td>
</tr>
<tr>
<td></td>
<td>If the object you’re importing isn’t listed then verify if you have the roles and privileges required to import the object. For information on the roles, see the topic Roles Required for Import and Export Management referenced in the Related Topics section.</td>
</tr>
</tbody>
</table>
### Field Description of the value

<table>
<thead>
<tr>
<th>Field</th>
<th>Description of the value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Attachment Object</td>
<td>To import an attachment for an existing object record in the database select the Attachments object from the Object drop-down list. Next select the object from the Attachment Object drop-down list. For more details on importing attachments, review the topic Import Attachments.</td>
</tr>
<tr>
<td>File Name</td>
<td>Browse and select a text file in CSV format. The first row of the source file is treated as the header row. Provide a file name within 40 characters.</td>
</tr>
<tr>
<td>Import Object Hierarchy</td>
<td>To import a hierarchy of objects, such as child and grandchild objects, click on the Import Object Hierarchy link after you upload the source file for the parent object. Next select the Enabled check box for the child object you want to import, and select the related source file.</td>
</tr>
</tbody>
</table>

### Note:

If your source file has more than 50,000 records, then you must manually split the file into several smaller files with less than 50,000 records each. The file import page only permits 50,000 records for each import job. Alternatively, you can use the External Cloud Data Loader Client, which can accept files with more than 50,000 records. See the My Oracle Support (support.oracle.com) document External Data Loader Client (document ID 2325249.1) for more information about this tool.

4. Optionally, to set additional import configurations, click the Advanced Options section. Here you can configure settings under Source File, Import Options, or Create Schedule sections.

a. In the Source File and Import Options regions, some of the options in the following table might not be available depending on the object that you're importing:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Import Mode</td>
<td>You can specify whether you want to create and update records or update them only.</td>
</tr>
<tr>
<td></td>
<td>- <strong>Update and create records</strong> - a new record is created if a matching record isn’t found. This is the default option.</td>
</tr>
<tr>
<td></td>
<td>- <strong>Create records</strong> - all the records in the file are new records which have to be created. If there are any existing matching records, then they’re marked as errors.</td>
</tr>
<tr>
<td></td>
<td>- <strong>Delete records</strong> - all the records in the file are deleted.</td>
</tr>
<tr>
<td>Enable High-Volume Import</td>
<td>The high-volume import mode is designed to import millions of records at once. This mode doesn’t trigger any custom logic configured through the application composer. For a list of supported objects, see the topic Data Import Options.</td>
</tr>
<tr>
<td></td>
<td>By default, this mode is enabled for the supported objects.</td>
</tr>
<tr>
<td>Option</td>
<td>Description</td>
</tr>
<tr>
<td>-----------------------------</td>
<td>-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Note:</td>
<td>If ZCA_FILE_IMPORT_ENABLE_CUSTOM_BUSINESS_LOGIC is set to “Yes”, then you won’t be able to use High Volume import.</td>
</tr>
<tr>
<td>Enable Survivorship</td>
<td>Survivorship on update is available for Account, Organization, Contact, and Person. The check box is visible if the attribute survivorship is configured on the objects. You can use high-volume import mode, only when the survivorship configuration uses only Source Confidence. You can’t use the high-volume import mode when Data Quality Rules are enabled.</td>
</tr>
<tr>
<td>Notification email</td>
<td>The email of the individual who receives import processing notifications. The user submitting the import receives an email notification automatically. To have more than one email recipient, separate the email addresses with a semicolon. If you don’t want to receive the notification, then set the profile option ORA_ZCA_IMPEXP_ENABLE_EMAIL_NOTIFY to ‘N’ at user level.</td>
</tr>
<tr>
<td>Enable Custom Business Logic</td>
<td>If you select this check box, then any custom triggers and validations configured for the object are enabled. This may affect import performance, because of configurations. Hence, disable this option for better performance. To enable this check box by default, set the profile option ZCA_FILE_IMPORT_ENABLE_CUSTOM_BUSINESS_LOGIC to ‘Yes’ by navigating to the Manage Administrator Profile Values task. Note: If ZCA_FILE_IMPORT_ENABLE_CUSTOM_BUSINESS_LOGIC is set to “Yes”, then you won’t be able to use High Volume import. Note: This selection has no effect on events and object workflows, and is applicable only on triggers and validations.</td>
</tr>
<tr>
<td>Delimiter</td>
<td>If your file doesn’t use a comma to separate values, then select the correct delimiter in the <strong>Delimiter</strong> drop-down list. Possible values are:</td>
</tr>
<tr>
<td></td>
<td>- Caret Symbol</td>
</tr>
<tr>
<td></td>
<td>- Closing Curly Bracket</td>
</tr>
<tr>
<td></td>
<td>- Closing Parenthesis</td>
</tr>
<tr>
<td></td>
<td>- Closing Square Bracket</td>
</tr>
<tr>
<td></td>
<td>- Colon</td>
</tr>
<tr>
<td>Option</td>
<td>Description</td>
</tr>
<tr>
<td>---------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>- Comma</td>
<td></td>
</tr>
<tr>
<td>- Exclamatory Mark</td>
<td></td>
</tr>
<tr>
<td>- Minus</td>
<td></td>
</tr>
<tr>
<td>- Opening Curly Bracket</td>
<td></td>
</tr>
<tr>
<td>- Opening Parenthesis</td>
<td></td>
</tr>
<tr>
<td>- Opening Square Bracket</td>
<td></td>
</tr>
<tr>
<td>- Pipe Symbol</td>
<td></td>
</tr>
<tr>
<td>- Plus</td>
<td></td>
</tr>
<tr>
<td>- Question Mark</td>
<td></td>
</tr>
<tr>
<td>- Semi-Colon</td>
<td></td>
</tr>
<tr>
<td>- Star Symbol</td>
<td></td>
</tr>
<tr>
<td>- Tilde Symbol</td>
<td></td>
</tr>
<tr>
<td>Decimal Separator</td>
<td>The decimal separator used in your import file.</td>
</tr>
<tr>
<td>Date Format</td>
<td>The format of the date fields in your file.</td>
</tr>
<tr>
<td>Time Stamp Format</td>
<td>The format of the time fields in your file.</td>
</tr>
<tr>
<td>File Encoding</td>
<td>The format in which your source file is encoded. The possible values are:</td>
</tr>
<tr>
<td></td>
<td>- Chinese Simplified - GB, CP936</td>
</tr>
<tr>
<td></td>
<td>- Chinese Traditional - CP950</td>
</tr>
<tr>
<td></td>
<td>- Eastern European - Win, CP1250</td>
</tr>
<tr>
<td></td>
<td>- Greek - MS Windows, CP932</td>
</tr>
<tr>
<td></td>
<td>- Japanese - Shift- JIS, CP932</td>
</tr>
<tr>
<td></td>
<td>- Unicode - UTF-16</td>
</tr>
<tr>
<td></td>
<td>- Unicode- UTF-16BE, Mac, Unix</td>
</tr>
<tr>
<td></td>
<td>- Unicode - UTF-16LE, MS Windows</td>
</tr>
<tr>
<td></td>
<td>- Unicode - UTF-8</td>
</tr>
<tr>
<td></td>
<td>- Western European - Win, CP1252</td>
</tr>
<tr>
<td><strong>Note:</strong></td>
<td>The above mentioned encoding formats are the only ones supported. Importing file with any other format, such as ANSI, will cause unexpected characters to be imported.</td>
</tr>
</tbody>
</table>

b. In the **Create Schedule** region, schedule the import to run immediately or at a future date. If you select a future date, then provide the date and time to start the import.

5. **Click Next.** The **Map Fields** page shows the first row of the data from your source file. By default, the application tries to automatically map each of the source file columns to the appropriate target object attribute.
If some of the columns in your file couldn’t be mapped, then drag the target attribute onto the **Attribute Display Name** column under the **Source File** region.

The data in unmapped columns aren't imported.

You can save your import map by clicking on **Save As** in the Create Import Activity page. You can use the saved map for future imports. You can view your saved maps by clicking on the **Import Mapping** dropdown in the Create Import Activity page.

Also, you can select and then edit your saved maps for the specific objects in the Import Objects page.

6. You select a predefined mapping from the list of available mappings under the **Import Mapping** drop-down list. If you’re reusing an import mapping, then both the source and target columns are already populated.

Leave the **Attribute Display Name** field blank for any column that you don’t want to import.

Click **Validate Data** to check the field mapping.

7. In the case of hierarchical import, you can see the mapping information for child objects in the subsequent tabs. Note that data validation isn’t done for these objects.

8. Click **Next**. On the **Review and Submit** page, review the import activity configuration. If you had not run the prevalidation on the **Map Fields** page, then you get a notification message to run the validation process. You can view any unmapped columns of parent or child objects on this page.

9. Click **Validate Data** to check the data in your source file. Validation errors, if any, are displayed on the Mapping Validation screen. If you get warnings about unmapped columns, then you can ignore these columns, and proceed to submit the import job. Validations are for informational purposes and applicable only for low-volume imports.

**Note:** In import activity with single CSV hierarchical records, explicit validation from the mapping UI isn't supported. For example, while importing the sales territory object, if there are matching values for the attributes ParentUniqueTerritoryNumber and UniqueTerritoryNumber, then validation isn't supported.

**Note:** During the import validation process on the Mapping page, the following custom triggers aren't supported:

- After Changes Posted to Database
- Before Delete in Database
- Before Insert in Database
- Before Update in Database
- Before Rollback

10. Click **Submit** to queue the import.

   Note that business events aren’t fired when using Import Management.
Automating and Scheduling Import Jobs

You can automate import jobs using the import REST services. The import REST services let you manage import activities, manage activity maps, and export object metadata. You can use an external scheduler that uses these REST services to run recurring import jobs, create and run import activities, manage maps, and review object metadata.

You can use the Oracle WebCenter Content Document Transfer Utility to manage the import files used by the scheduler. You can download the Oracle WebCenter Content Document Transfer Utility by navigating to the My Oracle Support (support.oracle.com) document Oracle WebCenter Content Document Transfer Utility Readme (document ID 1624063.1). Once downloaded, you can run the tool by navigating to the ridc folder after extraction.

For detailed instructions on automating and scheduling file import using REST API, see Oracle CX Sales and B2B Service: Automating and Scheduling File Import Activity Using REST API (Doc ID 2308691.1) article on My Oracle Support (support.oracle.com).

Set Up Event Notifications for Resources

In file-based data import, the sendcredentialsEmailFlag attribute allowed the import to specify the notification setting for each employee resource. You can do this in Import Management using the User Category option but this applies to all resources in a single import.

To set up notifications for all events:

1. Navigate to **Tools > Security Console** on the home page.
2. Click the **User Categories** tab.
3. Click DEFAULT. Click the **Notifications** tab.
4. Click the **Edit** button. If you want to turn on all notifications, then select the **Enable Notifications** check box under the Notification Preferences heading.
5. Click the **Save** button.
6. Click the **Done** button.

To set up notifications for a specific event:

1. Navigate to **Tools > Security Console** on the home page.
2. Click the **User Categories** tab.
3. Click DEFAULT. Click the **Notifications** tab.
4. Click the **Edit** button.
5. If you want to turn on a specific event notifications, click the template for the desired event.
6. On the **Template Information** page, select the **Enabled** check box and click **Save and Close**.
7. Click the **Save** button.
8. Click the **Done** button.

Import FCLs and DCLs

You must pass #NULL value for the FCL field in order to nullify a value for an FCL using Import Management.

Here is an example to nullify TargetGlobalPJDetailFlag1_c field:

<table>
<thead>
<tr>
<th>PartyId</th>
<th>TargetGlobalPJDetailFlag1_c</th>
</tr>
</thead>
<tbody>
<tr>
<td>1000000001527765</td>
<td>#NULL</td>
</tr>
</tbody>
</table>
Related Topics
- Import Attachments
- How You Monitor Your Import Activities
- How You Map Import Fields
- Data Import Options
- Roles Required for Import and Export Management

Import Attachments

You can import attachments associated with any supported object.

Supported Objects and File Types
The following objects support importing attachments:

- Account
- Activity
- Asset
- Business Plan
- Contact
- Custom Object
- Deal Registration
- Household
- Message
- Objective
- Opportunity
- Opportunity Revenue
- Partner
- Partner Program
- Product
- Sales Lead
- Sales Lead Product
- Service Request

The following file types are supported for attachment files:

- CSV
- DOC
- DOCX
- JPG
How to Create ZIP File

To import an attachment, you must create a ZIP file that contains the source data file and optionally one or more attachment files. Make sure you always name the source file as 'Attachment.CSV'. You must mention each of the attachment file names in the Attachment.CSV file. The Attachment.zip file has the structure shown in the following image:
Here are the examples for the attachment.csv file shown in purple box in the image above:

<table>
<thead>
<tr>
<th>Pk1Value</th>
<th>ObjectPuid</th>
<th>FileName</th>
<th>Url</th>
</tr>
</thead>
<tbody>
<tr>
<td>100100004247330</td>
<td></td>
<td></td>
<td><a href="http://www.yahoo.com">http://www.yahoo.com</a></td>
</tr>
<tr>
<td>100100004247330</td>
<td></td>
<td>Clouds.jpg</td>
<td></td>
</tr>
<tr>
<td>100100004247330</td>
<td></td>
<td>Taxdocs.docx</td>
<td></td>
</tr>
<tr>
<td>CDRM_6493</td>
<td></td>
<td></td>
<td><a href="http://www.google.com">http://www.google.com</a></td>
</tr>
</tbody>
</table>
Pk1Value | ObjectPuid | FileName | Url |
<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>CDRM_6493</td>
<td>Holidays.pdf</td>
<td></td>
</tr>
</tbody>
</table>

Pk1Value and ObjectPuid column values uniquely identify an existing object record. FileName indicates the name of attachment files. Url indicates the value of URL attachment to import.

**Note:** The attachment ZIP file name can include characters such as parenthesis (), ampersand (&), dots (.), and apostrophe (’) only.

An attachment can only be associated with an existing record of the object. A single record can be associated with multiple attachments by having multiple rows in the CSV file. You can import any number of attachments in an import job, but the ZIP file should not exceed 250 MB in size.

**Note:** A record in the CSV file can't have values for both FileName and Url columns. You can pass either the Primary key or the PUID for an object record. If you pass both Primary key and PUID values, then Primary key will be considered and PUID will be ignored.

### How to Import Attachments

To import attachments:

1. Click **Tools > Import Management**.
2. On the **Manage Imports** page, click **Create Import Activity**.
3. On the Enter Import Options page, enter a name for your import. From the **Object** drop-down list select **Attachment**.
4. In the **Attachment Object** drop-down list that appears, select the object associated with the attachment.
5. Select the ZIP file that you created in the previous section.
6. Click **Next**. On the **Map Fields** page, click the **Apply** button next to the **Import Mapping** drop-down list to map the source and target attributes automatically.
7. Click **Next** to navigate to the **Review and Submit** page.

Review the import activity configuration and click **Submit** to activate the import. The **Manage Imports** page shows the status of the submitted import. The topic Import Data in the related topics section contains more details about the import process.

**Related Topics**

- Import Data

## Delete Attachments

This topic shows how to delete attachments using Import Management. You can delete attachments associated with any supported object.
Before You Start

To delete attachments during an import activity, you need the source object ID (either the parent public unique identifier or the primary key).

Steps to Retrieve the Source Object IDs

- Run a GET query on the source object (with valid filter criteria) to obtain the correct source object keys (such as public unique identifier, primary key and so on). For example, you can retrieve PartyNumber and Party ID of the account object using GET query on the account object.
- Alternatively you can submit an export activity using Export Management on the source object (with valid filter criteria) to obtain the correct Source object keys.

Delete Attachments Using Import Management

To delete attachments using Import Management:

1. Create an import activity as described in the topic Import Data.
2. Enter a name for your import. In the Object drop-down list select Attachment.
3. In the Attachment Object drop-down list, select the object associated with the attachment.
4. Select the ZIP file that contains the attachment files and the source data file with the object records information for which you want to delete the attachment.
5. Click Advanced Options and under the Import Options section, select Delete records from the Import Mode drop-down list.
6. The ZIP file must contain at least a file named Attachment.CSV, and optionally one or more attachment files. The Attachment. CSV file has the following format:

<table>
<thead>
<tr>
<th>Pk1Value</th>
<th>ObjectPuid</th>
<th>FileName</th>
</tr>
</thead>
<tbody>
<tr>
<td>300100111735265</td>
<td>N/A</td>
<td>ReadMe.txt</td>
</tr>
<tr>
<td>N/A</td>
<td>CDRM_L1011</td>
<td>N/A</td>
</tr>
<tr>
<td>300100111735265</td>
<td>N/A</td>
<td>N/A</td>
</tr>
<tr>
<td>N/A</td>
<td>CDRM_L1212</td>
<td>Template.txt</td>
</tr>
</tbody>
</table>

Pk1Value and ObjectPuid column values uniquely identify an existing object record. FileName indicates the name of attachment files to delete during the import.

You can associate an attachment only with an existing object record. A single record can be associated with multiple attachments by having multiple rows in the CSV file. There's no limit on the number of attachments that can be deleted in a single import job. However, the size of the attachment ZIP file can't exceed 250 MB.

**Note:** You can pass either the Primary key or the Public Unique Identifier, but not both for an object record.
7. Click Next and map the source and target attributes.
8. Click Next to navigate to the Review and Submit page. Review the import activity configuration and click Submit to activate the import. You can view the status of the submitted import on the Manage Imports page.

Related Topics
- Import Data
- Import Attachments

Import Notes

This topic shows how to import notes using the Import Management feature. You can attach a note to an existing object record.

Types of Notes
Note can be one of the following types:
- GENERAL
- REFERENCE
- SPECIAL

Before You Start
Before importing the note, make sure to import the object record to attach the note. You can import an object, such as Sales Lead, using Import Management. See the topic Import Data for the details on importing. After the import completes, note the primary key and PUID of the record created using the success log file.

How You Import the Note
You're set to import the note and associate with the object record. Use the following steps to import notes using Import Management.

1. Click Tools > Import Management.
2. On the Manage Imports page, click the Create Import Activity button. On the Enter Import Options page, enter a name for your import. In the Object drop-down list select Note.
3. In the Note Object drop-down list that appears, select the object to associate with the note, such as Sales Lead.
4. Create the note CSV file in the following format.

<table>
<thead>
<tr>
<th>ObjectPuid or SourceObjectId</th>
<th>NoteTxt</th>
<th>NoteTypeCode</th>
</tr>
</thead>
<tbody>
<tr>
<td>CDRM_82807 or 300100181729328</td>
<td>A sample note text</td>
<td>SPECIAL</td>
</tr>
</tbody>
</table>
You must provide either ObjectPuid or SourceObjectId in the source file, but not both.

ObjectPuid - The public unique identifier of the object. In case of Sales Lead, this refers to the LeadNumber value.

SourceObjectId - The primary key of the object. For Sales Lead, this refers to the LeadID value.

NoteTxt - The note entry.

NoteTypeCode - The category of the note. The possible values are GENERAL, REFERENCE, and SPECIAL.

5. Browse the source CSV file and create the import activity.

6. Review the import activity configuration and click submit to activate the import. The Manage Imports page shows the status of the submitted import.

---

## Delete Notes

This topic shows how to delete notes using Import Management.

To delete notes:

1. Create an import activity as described in the topic Import Data.
2. Enter a name for your import. In the Object drop-down list, select Note.
3. In the Note Object drop-down list, select the object associated with the note.
4. Create your source file as per following table:

<table>
<thead>
<tr>
<th>NoteId</th>
<th>NoteTxt</th>
</tr>
</thead>
<tbody>
<tr>
<td>300100177503663</td>
<td>Note Text</td>
</tr>
</tbody>
</table>

Here NoteId uniquely identifies the note record, and NoteTxt is the text associated.

5. Click Advanced Options and under the Import Options section, select Delete records from the Import Mode drop-down list. Click Next.

6. On the Map Fields page, map the source and target attributes.

7. Click Next to navigate to the Review and Submit page. Review the import activity configuration and click Submit to activate the import. You can view the status of the submitted import on the Manage Imports page.

**Note:** You can use the same method to update a note. However, select the Import Mode 'Update and create records'.

---

**Related Topics**

- Import Data

---

33
Manage Hierarchical Import Templates

Hierarchical import templates contain import object hierarchy and advanced import job configurations that you can reuse every time you create an import.

Hierarchical import template is a CSV file that contains information about the import activity such as import object name, object hierarchy details, and advanced import configurations. This topic describes the various options to manage these templates.

Why use Hierarchical Import Templates

Templates have the following benefits:

- They are useful while creating hierarchical imports. You can reuse the template file every time you create an import with the same object hierarchy and import configuration.
- You can easily migrate the templates from one environment to another.
- Administrators can create a set of templates that can then be downloaded and reused at multiple sites.

Create Hierarchical Import Template

To create a template file:

1. Navigate to Tools > Import Management > Import Configuration > Manage Template > Create Template.
2. On the Create Template page, provide the template summary information such as name, object details, and the description.
3. Select the import object from the Object drop-down list and click the Import Object Hierarchy link to select the object hierarchy. Select the Enabled check box for each object to import. You can select the child objects under the parent hierarchy only after selecting parent object.
4. Select the advanced options for your import and click Save and Close.

Upload Hierarchical Import Template

You can upload the templates to use them across environments. For example, you might want to download the template from one environment, and upload to another environment.

You can upload a template file in CSV format using the Upload Template button on the Manage Template page.

Edit Hierarchical Import Template

To edit an existing template:

1. On the Manage Template page, click the template number link for the template to edit.
2. On the Template Summary page, you can change the object in the hierarchy by selecting the Enabled check box.
3. After making any desired changes on the page, click Save and Close.
Copy, Download, or Delete a Hierarchical Import Template

To copy, download, or delete a template:

1. On the Manage Template page, click the template number link for the required template.
2. On the Template Summary page, under the Actions menu, you can find the options to copy, download, or delete your template file.
3. If you want to copy a template, click Copy Template. A copy of the currently selected template is created and the template name is prefixed with the text ‘Copy of’. Make any required changes to the template name, description, and advanced import options. Click Save and Close.
4. To download a template file, click the Download Template option from the Actions menu. You can save the file as a CSV file to your directory.
5. To delete a template, click the Delete Template option from the Actions menu. Only the user who created the template can delete it.

Import Using Hierarchical Import Template Files

To create an import activity using a template file:

1. Navigate to Tools > Import Management > Import from Template.
2. The Template Summary section shows the list of available templates for use, along with the top-level import object. When you select a template, the Hierarchy Objects section shows the object hierarchy for the template.
3. Select your template and click Continue with Template. On the Enter Import Options page, your object hierarchy is preselected and the advanced import configurations are already selected for you. If required, you can change these configurations for your import.
4. Upload the CSV files for your selected objects and click Next.
5. Provide the mapping information for your import on the Map Fields page.
6. Review your import details on the Review and Submit page, and submit. For more details on creating an import, see the topics Example of Importing Contracts Using Hierarchical Import and Import Data.

Related Topics
- Import Data
- Example of Importing Contracts Using Hierarchical Import

Example of Importing Contracts Using Hierarchical Import

You can use Import Management to import objects with complex hierarchies and relationships, such as Territories, Contracts, and Subscriptions. The hierarchical import feature helps you to import a hierarchy of objects.

You can set up a parent-child hierarchy of objects, define the CSV files to import for each hierarchy node, start, track, and monitor the status of the overall import job. This example explains how to import Contracts hierarchical data using hierarchical import. Following is the schematic of object hierarchy:

- Contract
  - Contract Line
Import Contracts Data
To import the Contract object, its children Contract Line and Contract Party objects, and the Contract Party Contact grandchild object using hierarchical import:

1. Click **Tools > Import Management > Create Import Activity**.
2. On the **Enter Import Options** page, select the parent Contract object, enter the import name, and select the source CSV file for Contract object. For more information about creating an import, see the topic Import Data.
3. Click the **Import Object Hierarchy** link. Now you can see the object hierarchy for Contract, showing the child and grandchild objects. Select the **Enabled** check box for the objects you want to import. For this example, select the check boxes for Contract Line, Contract Party, and the Contract Party Contact objects in that order.
4. Select the CSV file for each of these objects and click **Next**.
5. On the **Map Fields** page, the application tries to automatically map the target attributes to the source file attributes for each object. For the attributes that couldn't be mapped, you should map manually by clicking the **Save As** button. You can see the mapping information for child objects on the subsequent tabs. After mapping each object attribute, click **Next**.
6. After reviewing the import information on the **Review and Submit** page, submit the import.
7. On the **Manage Imports** page, you can see the status of import for parent, child, and grandchild objects in the form of tree structure.
8. You can verify your contracts after import completes by navigating to **Contract Management > Contracts**.

**Related Topics**
- Import Data

Import Dynamic Flexfields
A flexfield is a flexible data field that your organization can configure according to your business needs. Dynamic Flexfields (DFF) capture additional business information such as the name of the company's owner.

DFF's data are stored in the attributes. These are fixed set of custom fields and can be of data type VARCHAR2, NUMBER, DATE, or TIMESTAMP.

For more information on DFFs see the chapter Flexfields in the guides Oracle Applications Cloud Configuring and Extending Applications (http://www.oracle.com/pls/topic/lookup?ctx=cloud&id=OAEXT) and Oracle CX Sales Implementing Incentive Compensation (http://www.oracle.com/pls/topic/lookup?ctx=cloud&id=OAWIC) available on the Help Center.

**Objects Supporting the DFF Import**
The objects that support the DFF fields are:

- Contract (child object is Contract Header Descriptive Flexfield)
- Contract Line (child object is Contract Line Descriptive Flexfield)
- Contract Party (child object is Contract Party Descriptive Flexfield)
- Contract Party Contact (child object is Contract Party Contact Flexfield)
How you Register new Objects for DFF Support

Follow these steps to register any new object for DFF support:

1. In the Navigator, click **Tools > Import Management**.
2. On the **Manage Imports** page, click the **Create Import Activity** button.
3. Create an import by selecting the Contract object from the drop-down list. For more information on creating an import, see the topic Import Data.
4. Once the import completes, create another import by selecting the Contract Header Descriptive Flexfield child object from the drop-down list.
5. In the source CSV file, include the ContractPuid header attribute and provide the value you entered for the parent object import. For each DFF field, provide its Table Column name in the header. Select the source CSV file and click **Next**.
6. Click Next to go to the **Map Fields** page. Here you can see only the AttributeNames and not the DFF attribute labels. Map the attributes and click Next. Submit the import on the **Review and Submit** page.
7. To verify your contracts after import completes, navigate to **Contract Management > Contracts**.

| Note: | Only high-volume import supports importing DFF fields. |

**Related Topics**
- Import Data
- Flexfield Components
- Overview of Flexfields

Generate the Diagnostics Log for Import

The diagnostic log files provide complete information about an import job and its errors. If you have errors in your import job, then provide the diagnostic logs to technical support to help them resolve the issue.

You can generate the diagnostic logs by clicking the Generate button. You can then attach the log files (in ZIP format) to the Service Request (SR). This helps technical support to resolve the issues.

To generate the diagnostic logs for an import:

1. Click **Tools > Import Management**.
2. On the **Manage Imports** page, click the **Name** link for your import that has failed.
3. On the **Import Status** page, click the **Generate Diagnostics** button in the **Action** menu to generate the diagnostics files.

See the Import Attachments section for the link to download the generated files. Click Download under the Actions column to download the file. For more information about the files, click on the details icon.

Import Data with Special Characters

You need to format the data, if your import file includes special characters. Follow the methods described in this topic to ensure that source data is properly parsed and imported by CX Sales and B2B Service.
Build the CSV File

To build your CSV file for importing data:

1. Click **Tools > Import Management > Import Objects**.
2. On the Import Object Details page, click the Download icon to save the CSV template file for your object to your desktop.
3. You can edit the file to include only those fields that you import. For more information on using the import object template, see the topic Use Import Object Templates to Import Data.

Enter Data in the CSV File

After creating the CSV file, you must enter the data to be imported. Some of the special characters are quotation marks ("), and a comma (,). You must prefix the special characters with quotation marks ("'). This list shows the different formats in which the input data can be entered for the Lead object CSV file and how it's interpreted due to the presence of special characters. LeadName and LeadNumber are the header fields for the file.

This table lists five Lead records of a CSV file, each with the LeadName first, followed by the LeadNumber (120, 121, and so on).

<table>
<thead>
<tr>
<th>LeadName</th>
<th>LeadNumber</th>
</tr>
</thead>
<tbody>
<tr>
<td>Mark Twain lead</td>
<td>120</td>
</tr>
<tr>
<td>&quot;Twain &quot;secondary&quot; lead&quot;</td>
<td>121</td>
</tr>
<tr>
<td>Twain, Mark</td>
<td>122</td>
</tr>
<tr>
<td>Twain, Mark &quot;Spring 2015&quot; lead</td>
<td>123</td>
</tr>
<tr>
<td>&quot;Twain &quot;Fall 2014&quot; lead</td>
<td>124</td>
</tr>
</tbody>
</table>

You can use escape characters for the Lead Name source data records, as shown in this table.

<table>
<thead>
<tr>
<th>Row Number</th>
<th>Source Data for LeadName</th>
<th>How LeadName is Written to Database if no Escape Characters are Added</th>
<th>Data with Escape Characters to Preserve Original Data</th>
<th>How LeadName is Written to Database When Escape Characters are Included</th>
<th>Comment Regarding Escape Characters</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Mark Twain lead</td>
<td>Mark Twain lead</td>
<td>Not applicable</td>
<td>Not applicable</td>
<td>No escape characters are needed as the source data contains no special characters.</td>
</tr>
<tr>
<td>2</td>
<td>&quot;Twain &quot;secondary&quot; lead&quot;</td>
<td>&quot;Twain secondary&quot; lead&quot;</td>
<td>&quot;Twain &quot;secondary&quot; lead&quot;</td>
<td>&quot;Twain &quot;secondary&quot; lead&quot;</td>
<td>The two series of three quotation mark each:</td>
</tr>
</tbody>
</table>
### Get Started with Import

<table>
<thead>
<tr>
<th>Row Number</th>
<th>Source Data for LeadName</th>
<th>How LeadName is Written to Database if no Escape Characters are Added</th>
<th>Data with Escape Characters to Preserve Original Data</th>
<th>How LeadName is Written to Database When Escape Characters are Included</th>
<th>Comment Regarding Escape Characters</th>
</tr>
</thead>
<tbody>
<tr>
<td>3</td>
<td>Twain, Mark</td>
<td>Twain</td>
<td>&quot;Twain, Mark&quot;,122</td>
<td>Twain, Mark</td>
<td>Double quotation mark is required to surround the field entry, as a comma is in the source data. No additional escape character is required to precede the comma.</td>
</tr>
<tr>
<td>4</td>
<td>Twain, Mark “Spring 2015” lead</td>
<td>Twain</td>
<td>&quot;Twain, Mark &quot;&quot;Spring 2015&quot;&quot; lead&quot;,123</td>
<td>Twain, Mark “Spring 2015” lead</td>
<td>A double quotation mark is required to surround the field entry, as at least one special character is present in the source data. Every double quotation mark in the source data requires a double quotation mark escape character. No additional escape character is required to precede the comma.</td>
</tr>
<tr>
<td>5</td>
<td>&quot;Twain “Fall 2014” lead&quot;</td>
<td>Twain Fall 2014 lead</td>
<td>&quot;&quot;&quot;&quot;Twain &quot;&quot;&quot;&quot;Fall 2014&quot;&quot;&quot;&quot; lead&quot;,124</td>
<td>&quot;Twain “Fall 2014” lead&quot;</td>
<td>Although the missing end quotation mark in the source data is likely a typo, the source data must be written as it appears. Enter three double quotation marks at the beginning, but only a single (surrounding) double quotation mark at the end.</td>
</tr>
</tbody>
</table>

- If the source data contains at least one special character, the field of source data must be entered in double quotation marks in the CSV file.
• If the data for a field contains separator such as a comma (,), you must enclose the content within two double quotation marks.
• If the first field has a special character at the beginning but not any matching special character at the end, the content of the second field will also be considered as part of the first field, and the second field is blank. You must provide a matching escape character.
• If you don't precede the special characters by an escape character, the import process may write incorrect data for a field, or incorrectly write data to the subsequent fields.

When you import files with special characters, the special characters are converted into unreadable characters. You can resolve the issues by saving the import file in UTF-8 format. To save a file in UTF-8 format:

• Choose File->Save as from the menu.
• In the 'Save as type' drop down > select 'Text (Tab delimited) (*.txt)'
• Select 'Web Options' in the 'Tools'
• Select the 'Encoding' tab.
• In the 'Save this document as:' drop down, select 'Unicode (UTF-8)''
• Click Save

Related Topics
• Use Import Object Templates to Import Data
• Import Data

Roles Required for Import and Export Management

You require certain duties and roles to perform activities related to import and export management. Oracle ships several OOTB roles with access to Import and Export data from CX Sales. You can select and use administrator level roles as needed.

You can get additional information about the duties and roles in the Security Reference for CX Sales and B2B Service guide.

Enhanced Data Privacy

You can only view import and export jobs that you submitted. You can't view the import and export jobs and associated data files submitted by other users. However, you can still view import jobs as part of the management reporting hierarchy. Managers can view their directs' imports and exports.

Administrators can configure this by setting the profile option ORA_ZCA_IMPEXP_RESTRICT_USERACCESS to Y by navigating to Setup and Maintenance > Search > Manage Administrator Profile Values task Search for the profile option code.

Roles for Import and Export

This table lists the set of roles required to import and export top-level objects. The values in brackets are the role codes. In the case of multiple roles listed, you need any one of the mentioned roles.
Note: You can import or export a child-level object if you have the role applicable to the parent object.

<table>
<thead>
<tr>
<th>Object Name</th>
<th>Recommended Role for Import and Export (Code)</th>
<th>Administrator Level Roles (Code)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Access Groups</td>
<td>Customer Relationship Management Application Administrator (ORA_ZCA_CUSTOMER_RELATIONSHIP_MANAGEMENT_APPLICATION_ADMINISTRATOR_JOB)</td>
<td>Customer Relationship Management Application Administrator (ORA_ZCA_CUSTOMER_RELATIONSHIP_MANAGEMENT_APPLICATION_ADMINISTRATOR_JOB)</td>
</tr>
<tr>
<td>Account</td>
<td>Trading Community Import Batch Management (ORA_MANAGE_TRADING_COMMUNITYIMPORT_BATCH_DUTY)</td>
<td>Sales Administrator (ORA_ZBS_SALES_ADMINISTRATOR_JOB)</td>
</tr>
<tr>
<td>Action</td>
<td>Internal Service Request Administrator (ORA_SVC_INTERNAL_HELPDESK_ADMINISTRATION)</td>
<td>Service Request Administrator (ORA_SVC_SR_ADMINISTRATOR)</td>
</tr>
<tr>
<td>Action Plan</td>
<td>Service Request Administrator (ORA_SVC_SR_ADMINISTRATOR)</td>
<td>Service Request Administrator (ORA_SVC_SR_ADMINISTRATOR)</td>
</tr>
<tr>
<td></td>
<td>Internal Service Request Administration (ORA_SVC_INTERNAL_HELPDESK_ADMINISTRATION)</td>
<td>Internal Service Request Administration (ORA_SVC_INTERNAL_HELPDESK_ADMINISTRATION)</td>
</tr>
<tr>
<td></td>
<td>HR Help Desk Administration (ORA_SVC_HELPDESK_ADMINISTRATION)</td>
<td>HR Help Desk Administration (ORA_SVC_HELPDESK_ADMINISTRATION)</td>
</tr>
<tr>
<td>Activity</td>
<td>Sales Administrator (ORA_ZBS_SALES_ADMINISTRATOR_JOB), Sales Manager (ORA_ZBS_SALES_MANAGER_JOB), Sales Representative (ORA_ZBS_SALES_REPRESENTATIVE_JOB), Channel Administrator (ORA_ZPM_CHANNEL_ADMINISTRATOR_JOB), Channel Operations Manager (ORA_ZPM_CHANNEL_OPERATIONS_MANAGER_JOB), Marketing Operations Manager (ORA_MKT_MARKETING_OPERATIONS_MANAGER_JOB), Channel Partner Portal Administrator (ORA_ZPM_CHANNEL_PARTNER_PORTAL_ADMINISTRATOR_JOB), Customer Relationship Management Application Administrator (ORA_ZCA_CUSTOMER_RELATIONSHIP_MANAGEMENT_APPLICATION_ADMINISTRATOR_JOB)</td>
<td>Sales Administrator (ORA_ZBS_SALES_ADMINISTRATOR_JOB) Customer Relationship Management Application Administrator (ORA_ZCA_CUSTOMER_RELATIONSHIP_MANAGEMENT_APPLICATION_ADMINISTRATOR_JOB),</td>
</tr>
<tr>
<td>Asset</td>
<td>Customer Relationship Management Application Administrator (ORA_ZCA_CUSTOMER_RELATIONSHIP_MANAGEMENT_APPLICATION_ADMINISTRATOR_JOB)</td>
<td>Customer Relationship Management Application Administrator (ORA_ZCA_CUSTOMER_RELATIONSHIP_MANAGEMENT_APPLICATION_ADMINISTRATOR_JOB), Sales Administrator (ORA_ZBS_SALES_ADMINISTRATOR_JOB)</td>
</tr>
<tr>
<td>Attachments</td>
<td>FUSION_APPS_CRM_ESS_APPID, FUSION_APPS_CRM_ODI_APPID, FUSION_APPS_CRM_SOA_APPID, Trading Community Import Batch</td>
<td>Customer Contract Administrator(ORA_OKC_CUSTOMER_CONTRACT_ADMINISTRATOR_JOB), Opportunity Administration (ORA_</td>
</tr>
<tr>
<td>Object Name</td>
<td>Recommended Role for Import and Export (Code)</td>
<td>Administrator Level Roles (Code)</td>
</tr>
<tr>
<td>-------------</td>
<td>---------------------------------------------</td>
<td>-----------------------------------</td>
</tr>
<tr>
<td>Management</td>
<td>(ORA_MANAGE_TRADING_COMMUNITY_IMPORT_BATCH_DUTY)</td>
<td>MOO_OPPORTUNITY_ADMINISTRATION_DUTY, Enterprise Contract Administrator (ORA_OKC_ENTERPRISE_CONTRACT_ADMINISTRATOR_JOB), Supplier Contract Administrator (ORA_OKC_SUPPLIER_CONTRACT_ADMINISTRATOR_JOB), HR Help Desk Administration (ORA_SVC_HELPDESK_ADMINISTRATION), Sales Administrator (ORA_ZBS_SALES_ADMINISTRATOR_JOB), Channel Administrator (ORA_ZPM_CHANNEL_ADMINISTRATOR_JOB), Customer Relationship Management Application Administrator (ORA_ZCA_CUSTOMER_RELATIONSHIP_MANAGEMENT_APPLICATION_ADMINISTRATOR_JOB)</td>
</tr>
<tr>
<td>Sales Lead Processing</td>
<td>(ORA_MKL_SALES_LEAD_PROCESSING_DUTY)</td>
<td></td>
</tr>
<tr>
<td>Corporate Marketing Manager</td>
<td>(ORA_MKT_CORPORATE_MARKETING_MANAGER_JOB)</td>
<td></td>
</tr>
<tr>
<td>Marketing Analyst</td>
<td>(ORA_MKT_MARKETING_ANALYST_JOB)</td>
<td></td>
</tr>
<tr>
<td>Marketing Manager</td>
<td>(ORA_MKT_MARKETING_MANAGER_JOB)</td>
<td></td>
</tr>
<tr>
<td>Marketing Operations Manager</td>
<td>(ORA_MKT_MARKETING_OPERATIONS_MANAGER_JOB)</td>
<td></td>
</tr>
<tr>
<td>Marketing VP</td>
<td>(ORA_MKT_MARKETING_VP_JOB)</td>
<td></td>
</tr>
<tr>
<td>Opportunity Administration</td>
<td>(ORA_MOO_OPPORTUNITY_ADMINISTRATION_DUTY)</td>
<td></td>
</tr>
<tr>
<td>Customer Contract Administrator</td>
<td>(ORA_OKC_CUSTOMER_CONTRACT_ADMINISTRATOR_JOB)</td>
<td></td>
</tr>
<tr>
<td>Customer Contract Manager</td>
<td>(ORA_OKC_CUSTOMER_CONTRACT_MANAGER_JOB)</td>
<td></td>
</tr>
<tr>
<td>Enterprise Contract Administrator</td>
<td>(ORA_OKC_ENTERPRISE_CONTRACT_ADMINISTRATOR_JOB)</td>
<td></td>
</tr>
<tr>
<td>Enterprise Contract Manager</td>
<td>(ORA_OKC_ENTERPRISE_CONTRACT_MANAGER_JOB)</td>
<td></td>
</tr>
<tr>
<td>Supplier Contract Administrator</td>
<td>(ORA_OKC_SUPPLIER_CONTRACT_ADMINISTRATOR_JOB)</td>
<td></td>
</tr>
<tr>
<td>Supplier Contract Manager</td>
<td>(ORA_OKC_SUPPLIER_CONTRACT_MANAGER_JOB)</td>
<td></td>
</tr>
<tr>
<td>Subscription Specialist</td>
<td>(ORA_OSS_SUBSCRIPTION_SPECIALIST_JOB)</td>
<td></td>
</tr>
<tr>
<td>Sales Catalog Administrator</td>
<td>(ORA_QSC_SALES_CATALOG_ADMINISTRATOR_JOB)</td>
<td></td>
</tr>
<tr>
<td>HR Help Desk Administration</td>
<td>(ORA_SVC_HELPDESK_ADMINISTRATION)</td>
<td></td>
</tr>
<tr>
<td>Service Request Administrator</td>
<td>(ORA_SVC_SR_ADMINISTRATOR)</td>
<td></td>
</tr>
<tr>
<td>Sales Administrator</td>
<td>(ORA_ZBS_SALES_ADMINISTRATOR_JOB)</td>
<td></td>
</tr>
<tr>
<td>Sales Manager</td>
<td>(ORA_ZBS_SALES_MANAGER_JOB)</td>
<td></td>
</tr>
<tr>
<td>Object Name</td>
<td>Recommended Role for Import and Export (Code)</td>
<td>Administrator Level Roles (Code)</td>
</tr>
<tr>
<td>---------------------</td>
<td>-------------------------------------------------------------------------------------------------------------</td>
<td>--------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td></td>
<td>Sales Representative (ORA_ZBS_SALES_REPRESENTATIVE_JOB)</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Customer Relationship Management Application Administrator (ORA_ZCA_CUSTOMER_RELATIONSHIP_MANAGEMENT_APPLICATION_ADMINISTRATOR_JOB)</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Channel Account Manager (ORA_ZPM_CHANNEL_ACCOUNT_MANAGER_JOB)</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Channel Administrator (ORA_ZPM_CHANNEL_ADMINISTRATOR_JOB)</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Channel Operations Manager (ORA_ZPM_CHANNEL_OPERATIONS_MANAGER_JOB)</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Channel Partner Manager (ORA_ZPM_CHANNEL_PARTNER_MANAGER_JOB)</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Channel Partner Portal Administrator (ORA_ZPM_CHANNEL_PARTNER_PORTAL_ADMINISTRATOR_JOB)</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Channel Sales Director (ORA_ZPM_CHANNEL_SALES_DIRECTOR_JOB)</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Channel Sales Manager (ORA_ZPM_CHANNEL_SALES_MANAGER_JOB)</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Sales Analyst (ORA_ZSP_SALES_ANALYST_JOB)</td>
<td></td>
</tr>
<tr>
<td>Business Plan</td>
<td>Sales Administrator (ORA_ZBS_SALES_ADMINISTRATOR_JOB)</td>
<td>Sales Administrator (ORA_ZBS_SALES_ADMINISTRATOR_JOB)</td>
</tr>
<tr>
<td>Campaign</td>
<td>Sales Administrator (ORA_ZBS_SALES_ADMINISTRATOR_JOB)</td>
<td>Sales Administrator (ORA_ZBS_SALES_ADMINISTRATOR_JOB)</td>
</tr>
<tr>
<td>Case</td>
<td>Service Request Administrator (ORA_SVC_SR_ADMINISTRATOR), HR Help Desk Administration (ORA_SVC_HELPDESK_ADMINISTRATION), Internal Service Request Administration (ORA_SVC_INTERNAL_HELPDESK_ADMINISTRATION)</td>
<td>Service Request Administrator (ORA_SVC_SR_ADMINISTRATOR), HR Help Desk Administration (ORA_SVC_HELPDESK_ADMINISTRATION), Internal Service Request Administration (ORA_SVC_INTERNAL_HELPDESK_ADMINISTRATION)</td>
</tr>
<tr>
<td>Classification Code</td>
<td>Trading Community Import Batch Management (ORA_MANAGE_TRADING_COMMUNITY_IMPORT_BATCH_DUTY)</td>
<td>Sales Administrator (ORA_ZBS_SALES_ADMINISTRATOR_JOB)</td>
</tr>
<tr>
<td>Competitor</td>
<td>Sales Administrator (ORA_ZBS_SALES_ADMINISTRATOR_JOB)</td>
<td>Sales Administrator (ORA_ZBS_SALES_ADMINISTRATOR_JOB)</td>
</tr>
<tr>
<td>Consumer</td>
<td>Trading Community Import Batch Management (ORA_MANAGE_TRADING_COMMUNITY_IMPORT_BATCH_DUTY)</td>
<td>Trading Community Import Batch Management (ORA_MANAGE_TRADING_COMMUNITY_IMPORT_BATCH_DUTY)</td>
</tr>
<tr>
<td>Object Name</td>
<td>Recommended Role for Import and Export (Code)</td>
<td>Administrator Level Roles (Code)</td>
</tr>
<tr>
<td>-----------------</td>
<td>---------------------------------------------------------------------------------------------------------------</td>
<td>---------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Contact</td>
<td>Trading Community Import Batch Management (ORA_MANAGE_TRADING_COMMUNITY_IMPORT_BATCH_DUTY)</td>
<td>Sales Administrator (ORA_ZBS_SALES_ADMINISTRATOR_JOB)</td>
</tr>
<tr>
<td>Contract</td>
<td>Customer Contract Administrator (ORA_OKC_CUSTOMER_CONTRACT_ADMINISTRATOR_JOB), Customer Contract Manager (ORA_OKC_CUSTOMER_CONTRACT_Manager_JOB), Enterprise Contract Administrator (ORA_OKC_ENTERPRISE_CONTRACT_ADMINISTRATOR_JOB), Enterprise Contract Manager (ORA_OKC_ENTERPRISE_CONTRACT_Manager_JOB), Supplier Contract Administrator (ORA_OKC_SUPPLIER_CONTRACT_ADMINISTRATOR_JOB), Supplier Contract Manager (ORA_OKC_SUPPLIER_CONTRACT_Manager_JOB)</td>
<td>Customer Contract Administrator (ORA_OKC_CUSTOMER_CONTRACT_ADMINISTRATOR_JOB), Customer Contract Manager (ORA_OKC_CUSTOMER_CONTRACT_Manager_JOB), Enterprise Contract Administrator (ORA_OKC_ENTERPRISE_CONTRACT_ADMINISTRATOR_JOB), Enterprise Contract Manager (ORA_OKC_ENTERPRISE_CONTRACT_Manager_JOB), Supplier Contract Administrator (ORA_OKC_SUPPLIER_CONTRACT_ADMINISTRATOR_JOB), Supplier Contract Manager (ORA_OKC_SUPPLIER_CONTRACT_Manager_JOB)</td>
</tr>
<tr>
<td>Contests</td>
<td>Sales Administrator (ORA_ZBS_SALES_ADMINISTRATOR_JOB)</td>
<td>Sales Administrator (ORA_ZBS_SALES_ADMINISTRATOR_JOB)</td>
</tr>
<tr>
<td>Country Structure</td>
<td>Geography Administration (ORA_GEO_ADMIN_DUTY)</td>
<td>Geography Administration (ORA_GEO_ADMIN_DUTY)</td>
</tr>
<tr>
<td>Custom Object</td>
<td>Custom Objects Administration (ORA_CRM_EXTN_ROLE), Customer Relationship Management Application Administrator (ORA_ZCA_CUSTOMER_RELATIONSHIP_MANAGEMENT_APPLICATION_ADMINISTRATOR_JOB), Sales Administrator (ORA_ZBS_SALES_ADMINISTRATOR_JOB)</td>
<td>Custom Objects Administration (ORA_CRM_EXTN_ROLE), Customer Relationship Management Application Administrator (ORA_ZCA_CUSTOMER_RELATIONSHIP_MANAGEMENT_APPLICATION_ADMINISTRATOR_JOB)</td>
</tr>
<tr>
<td>Deal Registration</td>
<td>Sales Administrator (ORA_ZBS_SALES_ADMINISTRATOR_JOB), Channel Operations Manager (ORA_ZPM_CHANNEL_OPERATIONS_MANAGER_JOB)</td>
<td>Sales Administrator (ORA_ZBS_SALES_ADMINISTRATOR_JOB), Channel Operations Manager (ORA_ZPM_CHANNEL_OPERATIONS_MANAGER_JOB)</td>
</tr>
<tr>
<td>Duplicate Resolution Request</td>
<td>ORA_ZCH_DATA_STEWARD_MANAGER</td>
<td>ORA_ZCH_DATA_STEWARD_MANAGER</td>
</tr>
<tr>
<td>Event</td>
<td>Sales Administrator (ORA_ZBS_SALES_ADMINISTRATOR_JOB)</td>
<td>Sales Administrator (ORA_ZBS_SALES_ADMINISTRATOR_JOB)</td>
</tr>
<tr>
<td>Event Team Member</td>
<td>Sales Administrator (ORA_ZBS_SALES_ADMINISTRATOR_JOB)</td>
<td>Sales Administrator (ORA_ZBS_SALES_ADMINISTRATOR_JOB)</td>
</tr>
<tr>
<td>Geography</td>
<td>Geography Administration (ORA_GEO_ADMIN_DUTY)</td>
<td>Geography Administration (ORA_GEO_ADMIN_DUTY)</td>
</tr>
<tr>
<td>Goals</td>
<td>Sales Administrator (ORA_ZBS_SALES_ADMINISTRATOR_JOB)</td>
<td>Sales Administrator (ORA_ZBS_SALES_ADMINISTRATOR_JOB)</td>
</tr>
</tbody>
</table>
### Recommended Role for Import and Export

<table>
<thead>
<tr>
<th>Object Name</th>
<th>Role for Import and Export</th>
<th>Administrator Level Roles</th>
</tr>
</thead>
<tbody>
<tr>
<td>Hierarchy</td>
<td>Trading Community Import Batch Management (ORA_MANAGE_TRADING_COMMUNITY_IMPORT_BATCH_DUTY)</td>
<td>Sales Administrator (ORA_ZBS_SALES_ADMINISTRATOR_JOB)</td>
</tr>
<tr>
<td>Hierarchy Member</td>
<td>Trading Community Import Batch Management (ORA_MANAGE_TRADING_COMMUNITY_IMPORT_BATCH_DUTY)</td>
<td>Trading Community Import Batch Management (ORA_MANAGE_TRADING_COMMUNITY_IMPORT_BATCH_DUTY)</td>
</tr>
<tr>
<td>Household</td>
<td>Sales Administrator (ORA_ZBS_SALES_ADMINISTRATOR_JOB)</td>
<td>Sales Administrator (ORA_ZBS_SALES_ADMINISTRATOR_JOB)</td>
</tr>
<tr>
<td>Hub Source System Reference</td>
<td>Trading Community Import Batch Management (ORA_MANAGE_TRADING_COMMUNITY_IMPORT_BATCH_DUTY)</td>
<td>Trading Community Import Batch Management (ORA_MANAGE_TRADING_COMMUNITY_IMPORT_BATCH_DUTY)</td>
</tr>
<tr>
<td>Incentive Rule Assignments</td>
<td>Incentive Compensation Analyst (ORA_CN_INCENTIVE_COMPENSATION_ANALYST_JOB), Incentive Compensation Integration Specialist (ORA_CN_INCENTIVE_COMPENSATION_INTEGRATION_SPECIALIST_JOB), Incentive Compensation Manager (ORA_CN_INCENTIVE_COMPENSATION_MANAGER_JOB), Incentive Compensation Plan Administrator (ORA_CN_INCENTIVE_COMPENSATION_PLAN_ADMINISTRATOR_JOB), Customer Relationship Management Application Administrator (ORA_ZCA_CUSTOMER_RELATIONSHIP_MANAGEMENT_APPLICATION_ADMINISTRATOR_JOB)</td>
<td>Incentive Compensation Analyst (ORA_CN_INCENTIVE_COMPENSATION_ANALYST_JOB), Incentive Compensation Integration Specialist (ORA_CN_INCENTIVE_COMPENSATION_INTEGRATION_SPECIALIST_JOB), Incentive Compensation Manager (ORA_CN_INCENTIVE_COMPENSATION_MANAGER_JOB), Incentive Compensation Plan Administrator (ORA_CN_INCENTIVE_COMPENSATION_PLAN_ADMINISTRATOR_JOB), Customer Relationship Management Application Administrator (ORA_ZCA_CUSTOMER_RELATIONSHIP_MANAGEMENT_APPLICATION_ADMINISTRATOR_JOB)</td>
</tr>
<tr>
<td>Incentive Rule Attribute Values</td>
<td>Incentive Compensation Analyst (ORA_CN_INCENTIVE_COMPENSATION_ANALYST_JOB), Incentive Compensation Integration Specialist (ORA_CN_INCENTIVE_COMPENSATION_INTEGRATION_SPECIALIST_JOB), Incentive Compensation Manager (ORA_CN_INCENTIVE_COMPENSATION_MANAGER_JOB), Incentive Compensation Plan Administrator (ORA_CN_INCENTIVE_COMPENSATION_PLAN_ADMINISTRATOR_JOB), Customer Relationship Management Application Administrator (ORA_ZCA_CUSTOMER_RELATIONSHIP_MANAGEMENT_APPLICATION_ADMINISTRATOR_JOB)</td>
<td>Incentive Compensation Analyst (ORA_CN_INCENTIVE_COMPENSATION_ANALYST_JOB), Incentive Compensation Integration Specialist (ORA_CN_INCENTIVE_COMPENSATION_INTEGRATION_SPECIALIST_JOB), Incentive Compensation Manager (ORA_CN_INCENTIVE_COMPENSATION_MANAGER_JOB), Incentive Compensation Plan Administrator (ORA_CN_INCENTIVE_COMPENSATION_PLAN_ADMINISTRATOR_JOB), Customer Relationship Management Application Administrator (ORA_ZCA_CUSTOMER_RELATIONSHIP_MANAGEMENT_APPLICATION_ADMINISTRATOR_JOB)</td>
</tr>
<tr>
<td>Incentive Rules</td>
<td>Incentive Compensation Analyst (ORA_CN_INCENTIVE_COMPENSATION_ANALYST_JOB), Incentive Compensation Integration Specialist (ORA_CN_INCENTIVE_COMPENSATION_INTEGRATION_SPECIALIST_JOB), Incentive Compensation Manager (ORA_CN_INCENTIVE_COMPENSATION_MANAGER_JOB), Incentive Compensation Plan Administrator (ORA_CN_INCENTIVE_COMPENSATION_PLAN_ADMINISTRATOR_JOB), Customer Relationship Management</td>
<td>Incentive Compensation Analyst (ORA_CN_INCENTIVE_COMPENSATION_ANALYST_JOB), Incentive Compensation Integration Specialist (ORA_CN_INCENTIVE_COMPENSATION_INTEGRATION_SPECIALIST_JOB), Incentive Compensation Manager (ORA_CN_INCENTIVE_COMPENSATION_MANAGER_JOB), Incentive Compensation Plan Administrator (ORA_CN_INCENTIVE_COMPENSATION_PLAN_ADMINISTRATOR_JOB), Customer Relationship Management</td>
</tr>
<tr>
<td>Object Name</td>
<td>Recommended Role for Import and Export (Code)</td>
<td>Administrator Level Roles (Code)</td>
</tr>
<tr>
<td>-------------</td>
<td>-----------------------------------------------</td>
<td>----------------------------------</td>
</tr>
<tr>
<td></td>
<td>Application Administrator (ORA_ZCA_CUSTOMER_RELATIONSHIP_MANAGEMENT_APPLICATION_ADMINISTRATOR_JOB)</td>
<td>Application Administrator (ORA_ZCA_CUSTOMER_RELATIONSHIP_MANAGEMENT_APPLICATION_ADMINISTRATOR_JOB)</td>
</tr>
<tr>
<td>Incentive Transaction</td>
<td>Incentive Compensation Analyst (ORA_CN_INCENTIVE_COMPENSATION_ANALYST_JOB), Incentive Compensation Integration Specialist (ORA_CN_INCENTIVE_COMPENSATION_INTEGRATION_SPECIALIST_JOB), Incentive Compensation Manager (ORA_CN_INCENTIVE_COMPENSATION_MANAGER_JOB), Incentive Compensation Plan Administrator (ORA_CN_INCENTIVE_COMPENSATION_PLAN_ADMINISTRATOR_JOB), Customer Relationship Management Application Administrator (ORA_ZCA_CUSTOMER_RELATIONSHIP_MANAGEMENT_APPLICATION_ADMINISTRATOR_JOB)</td>
<td>Incentive Compensation Plan Administrator (ORA_CN_INCENTIVE_COMPENSATION_PLAN_ADMINISTRATOR_JOB), Customer Relationship Management Application Administrator (ORA_ZCA_CUSTOMER_RELATIONSHIP_MANAGEMENT_APPLICATION_ADMINISTRATOR_JOB)</td>
</tr>
<tr>
<td>Interaction</td>
<td>Service Request Administrator (ORA_SVC_SR_ADMINISTRATOR), HR Help Desk Administration (ORA_SVC_HELPDESK_ADMINISTRATION), Internal Service Request Administration (ORA_SVC_INTERNAL_HELPDESK_ADMINISTRATION)</td>
<td>Service Request Administrator (ORA_SVC_SR_ADMINISTRATOR), HR Help Desk Administration (ORA_SVC_HELPDESK_ADMINISTRATION), Internal Service Request Administration (ORA_SVC_INTERNAL_HELPDESK_ADMINISTRATION)</td>
</tr>
<tr>
<td>Kpi</td>
<td>Sales Administrator (ORA_ZBS_SALES_ADMINISTRATOR_JOB)</td>
<td>Sales Administrator (ORA_ZBS_SALES_ADMINISTRATOR_JOB)</td>
</tr>
<tr>
<td>MDF Budget</td>
<td>Sales Administrator (ORA_ZBS_SALES_ADMINISTRATOR_JOB), Channel Operations Manager (ORA_ZPM_CHANNEL_OPERATIONS_MANAGER_JOB), Marketing Operations Manager (ORA_MKT_MARKETING_OPERATIONS_MANAGER_JOB)</td>
<td>Sales Administrator (ORA_ZBS_SALES_ADMINISTRATOR_JOB), Channel Operations Manager (ORA_ZPM_CHANNEL_OPERATIONS_MANAGER_JOB)</td>
</tr>
<tr>
<td>MDF Claim</td>
<td>Sales Administrator (ORA_ZBS_SALES_ADMINISTRATOR_JOB), Channel Operations Manager (ORA_ZPM_CHANNEL_OPERATIONS_MANAGER_JOB), Marketing Operations Manager (ORA_MKT_MARKETING_OPERATIONS_MANAGER_JOB)</td>
<td>Sales Administrator (ORA_ZBS_SALES_ADMINISTRATOR_JOB), Channel Operations Manager (ORA_ZPM_CHANNEL_OPERATIONS_MANAGER_JOB)</td>
</tr>
<tr>
<td>MDF Request</td>
<td>Sales Administrator (ORA_ZBS_SALES_ADMINISTRATOR_JOB), Channel Operations Manager (ORA_ZPM_CHANNEL_OPERATIONS_MANAGER_JOB), Marketing Operations Manager (ORA_MKT_MARKETING_OPERATIONS_MANAGER_JOB)</td>
<td>Sales Administrator (ORA_ZBS_SALES_ADMINISTRATOR_JOB), Channel Operations Manager (ORA_ZPM_CHANNEL_OPERATIONS_MANAGER_JOB)</td>
</tr>
<tr>
<td>Note</td>
<td>Sales Administrator (ORA_ZBS_SALES_ADMINISTRATOR_JOB), Sales Manager (ORA_ZBS_SALES_MANAGER_JOB), Sales Representative (ORA_ZBS_SALES_REPRESENTATIVE_JOB), Marketing</td>
<td>Sales Administrator (ORA_ZBS_SALES_ADMINISTRATOR_JOB), Customer Relationship Management Application Administrator (ORA_ZCA_CUSTOMER_RELATIONSHIP_MANAGEMENT_APPLICATION_ADMINISTRATOR_JOB)</td>
</tr>
<tr>
<td>Object Name</td>
<td>Recommended Role for Import and Export (Code)</td>
<td>Administrator Level Roles (Code)</td>
</tr>
<tr>
<td>-------------------</td>
<td>---------------------------------------------------------------------------------------------------------------</td>
<td>--------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Operations Manager</td>
<td>(ORA_MKT_MARKETING_OPERATIONS_MANAGER_JOB), Customer Relationship Management Application Administrator (ORA_ZCA_CUSTOMER_RELATIONSHIP_MANAGEMENT_APPLICATION_ADMINISTRATOR_JOB), FUSION_APPS_CRM_ESS_APPID, FUSION_APPS_CRM_ODI_APPID, FUSION_APPS_CRM_SOA_APPID</td>
<td>MANAGEMENT_APPLICATION_ADMINISTRATOR_JOB)</td>
</tr>
<tr>
<td>Objective</td>
<td>Sales Administrator (ORA_ZBS_SALES_ADMINISTRATOR_JOB)</td>
<td>Sales Administrator (ORA_ZBS_SALES_ADMINISTRATOR_JOB)</td>
</tr>
<tr>
<td>Opportunity</td>
<td>Opportunity Administration (ORA_MOO_OPPORTUNITY_ADMINISTRATION_DUTY), Sales Administrator (ORA_ZBS_SALES_ADMINISTRATOR_JOB), FUSION_APPS_CRM_ESS_APPID, FUSION_APPS_CRM_ODI_APPID, FUSION_APPS_CRM_SOA_APPID</td>
<td>Opportunity Administration (ORA_MOO_OPPORTUNITY_ADMINISTRATION_DUTY), Sales Administrator (ORA_ZBS_SALES_ADMINISTRATOR_JOB)</td>
</tr>
<tr>
<td>Organization</td>
<td>Trading Community Import Batch Management (ORA_MANAGE_TRADING_COMMUNITY_IMPORT_BATCH_DUTY)</td>
<td>Sales Administrator (ORA_ZBS_SALES_ADMINISTRATOR_JOB)</td>
</tr>
<tr>
<td>Partner</td>
<td>Sales Administrator (ORA_ZBS_SALES_ADMINISTRATOR_JOB), Channel Operations Manager (ORA_ZPM_CHANNEL_OPERATIONS_MANAGER_JOB)</td>
<td>Sales Administrator (ORA_ZBS_SALES_ADMINISTRATOR_JOB), Channel Operations Manager (ORA_ZPM_CHANNEL_OPERATIONS_MANAGER_JOB)</td>
</tr>
<tr>
<td>Partner Programs</td>
<td>Channel Operations Manager (ORA_ZPM_CHANNEL_OPERATIONS_MANAGER_JOB)</td>
<td>Channel Operations Manager (ORA_ZPM_CHANNEL_OPERATIONS_MANAGER_JOB)</td>
</tr>
<tr>
<td>Person</td>
<td>Trading Community Import Batch Management (ORA_MANAGE_TRADING_COMMUNITY_IMPORT_BATCH_DUTY)</td>
<td>Sales Administrator (ORA_ZBS_SALES_ADMINISTRATOR_JOB)</td>
</tr>
<tr>
<td>Price Book Header</td>
<td>Sales Administrator (ZBS_SALES_ADMINISTRATOR_JOB)</td>
<td>Sales Administrator (ZBS_SALES_ADMINISTRATOR_JOB)</td>
</tr>
<tr>
<td>Product</td>
<td>Sales Administrator (ZBS_SALES_ADMINISTRATOR_JOB)</td>
<td>Sales Administrator (ZBS_SALES_ADMINISTRATOR_JOB)</td>
</tr>
<tr>
<td>Product Group</td>
<td>Sales Catalog Administrator (ORA_QSC_SALES_CATALOG_ADMINISTRATOR_JOB), Sales Administrator (ORA_ZBS_SALES_ADMINISTRATOR_JOB)</td>
<td>Sales Administrator (ORA_ZBS_SALES_ADMINISTRATOR_JOB)</td>
</tr>
<tr>
<td>Program Enrollments</td>
<td>Channel Operations Manager (ORA_ZPM_CHANNEL_OPERATIONS_MANAGER_JOB)</td>
<td>Channel Operations Manager (ORA_ZPM_CHANNEL_OPERATIONS_MANAGER_JOB)</td>
</tr>
<tr>
<td>Object Name</td>
<td>Recommended Role for Import and Export (Code)</td>
<td>Administrator Level Roles (Code)</td>
</tr>
<tr>
<td>----------------------</td>
<td>------------------------------------------------------------------------------------</td>
<td>---------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Promotion</td>
<td>Loyalty Program Administrator (ORA_LOY_LOYALTY_PROGRAM_ADMINISTRATOR_JOB)</td>
<td>Loyalty Program Administrator (ORA_LOY_LOYALTY_PROGRAM_ADMINISTRATOR_JOB)</td>
</tr>
<tr>
<td>Queue</td>
<td>Service Request Administrator (ORA_SVC_SR_ADMINISTRATOR), HR Help Desk Administration(ORA_SVC_HELPDESK_ADMINISTRATION), Internal Service Request Administration (ORA_SVC_INTERNAL_HELPDESK_ADMINISTRATION)</td>
<td>Service Request Administrator (ORA_SVC_SR_ADMINISTRATOR), HR Help Desk Administration(ORA_SVC_HELPDESK_ADMINISTRATION), Internal Service Request Administration (ORA_SVC_INTERNAL_HELPDESK_ADMINISTRATION)</td>
</tr>
<tr>
<td>Quote and Order</td>
<td>Sales Administrator (ORA_ZBS_SALES_ADMINISTRATOR_JOB)</td>
<td>Sales Administrator (ORA_ZBS_SALES_ADMINISTRATOR_JOB)</td>
</tr>
<tr>
<td>Resource</td>
<td>Sales Administrator (ORA_ZBS_SALES_ADMINISTRATOR_JOB)</td>
<td>Sales Administrator (ORA_ZBS_SALES_ADMINISTRATOR_JOB)</td>
</tr>
<tr>
<td>Resource Capacity</td>
<td>Service Request Administrator (ORA_SVC_SR_ADMINISTRATOR), HR Help Desk Administration(ORA_SVC_HELPDESK_ADMINISTRATION), Internal Service Request Administration (ORA_SVC_INTERNAL_HELPDESK_ADMINISTRATION)</td>
<td>Service Request Administrator (ORA_SVC_SR_ADMINISTRATOR), HR Help Desk Administration(ORA_SVC_HELPDESK_ADMINISTRATION), Internal Service Request Administration (ORA_SVC_INTERNAL_HELPDESK_ADMINISTRATION)</td>
</tr>
<tr>
<td>Sales Lead</td>
<td>Marketing Analyst (ORA_MKT_MARKETING_ANALYST_JOB), Sales Administrator (ORA_ZBS_SALES_ADMINISTRATOR_JOB), Marketing Manager (ORA_MKT_MARKETING_MANAGER_JOB), Sales Lead Processing (ORA_MKL_SALES_LEAD_PROCESSING_DUTY), Marketing Operations Manager (ORA_MKT_MARKETING_OPERATIONS_MANAGER_JOB), Corporate Marketing Manager (ORA_MKT_CORPORATE_MARKETING_MANAGER_JOB), Marketing VP (ORA_MKT_MARKETING_VP_JOB), Sales Analyst (ORA_ZSP_SALES_ANALYST_JOB), FUSION_APPS_CRM_ODI_APPID, FUSION_APPS_CRM_SOA_APPID, FUSION_APPS_CRM_ESS_APPID</td>
<td>Sales Administrator (ORA_ZBS_SALES_ADMINISTRATOR_JOB), Sales Lead Processing (ORA_MKL_SALES_LEAD_PROCESSING_DUTY)</td>
</tr>
<tr>
<td>Sales Territory</td>
<td>Customer Relationship Management Application Administrator (ORA_ZCA_CUSTOMER_RELATIONSHIP_MANAGEMENT_APPLICATION_ADMINISTRATOR_JOB), Sales Administrator (ORA_ZBS_SALES_ADMINISTRATOR_JOB), Territory Management Administration (ORA_MOT_TERRITORY_MANAGEMENT_ADMINISTRATION_DUTY), Sales Manager (ORA_ZBS_SALES_MANAGER_JOB), Sales Restricted User (ORA_ZBS_SALES_RESTRICTED_USER_JOB), Sales VP (ORA_ZBS_SALES_VP_JOB), Channel Account Manager (ORA_ZPM_CHANNEL_ACCOUNT_MANAGER_JOB), Channel Operations Manager (ORA_ZPM_CHANNEL_OPERATIONS_MANAGER_JOB), Channel Partner Manager (ORA_ZPM_CHANNEL_PARTNER_MANAGER_JOB),</td>
<td>Customer Relationship Management Application Administrator (ORA_ZCA_CUSTOMER_RELATIONSHIP_MANAGEMENT_APPLICATION_ADMINISTRATOR_JOB), Sales Administrator (ORA_ZBS_SALES_ADMINISTRATOR_JOB), Territory Management Administration (ORA_MOT_TERRITORY_MANAGEMENT_ADMINISTRATION_DUTY),</td>
</tr>
</tbody>
</table>
### Recommended Role for Import and Export (Code)

<table>
<thead>
<tr>
<th>Object Name</th>
<th>Recommended Role for Import and Export (Code)</th>
<th>Administrator Level Roles (Code)</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Sales Territory Quota</strong></td>
<td>Customer Relationship Management Application Administrator (ORA_ZCA_CUSTOMER_RELATIONSHIP_MANAGEMENT_</td>
<td>Customer Relationship Management Application Administrator (ORA_ZCA_CUSTOMER_RELATIONSHIP_</td>
</tr>
<tr>
<td></td>
<td>APPLICATION_ADMINISTRATOR_JOB), Sales Administrator (ORA_ZBS_SALES_ADMINISTRATOR_JOB), Territory Management</td>
<td>MANAGEMENT_ADMINISTRATION_JOB), Sales Administrator (ORA_ZBS_SALES_ADMINISTRATOR_JOB), Territory</td>
</tr>
<tr>
<td></td>
<td>Administration (ORA_MOT_TERRITORY_MANAGEMENT_ADMINISTRATION_DUTY), Sales Manager (ORA_ZBS_SALES_MANAGER_</td>
<td>Management Administration (ORA_MOT_TERRITORY_MANAGEMENT_ADMINISTRATION_DUTY)</td>
</tr>
<tr>
<td></td>
<td>JOB), Sales Restricted User (ORA_ZBS_SALES_RESTRICTED_USER_JOB), Sales VP (ORA_ZBS_SALES_VP_JOB), Channel</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Account Manager (ORA_ZPM_CHANNEL_ACCOUNT_MANAGER_JOB), Channel Operations Manager (ORA_ZPM_CHANNEL_</td>
<td></td>
</tr>
<tr>
<td></td>
<td>OPERATIONS_MANAGER_JOB), Channel Partner Manager (ORA_ZPM_CHANNEL_PARTNER_MANAGER_JOB), Channel Sales</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Director (ORA_ZPM_CHANNEL_SALES_DIRECTOR_JOB), Channel Sales Manager (ORA_ZPM_CHANNEL_SALES_MANAGER_JOB)</td>
<td></td>
</tr>
<tr>
<td><strong>Self Service Role</strong></td>
<td>Service Request Administrator (ORA_SVC_SR_ADMINISTRATOR)</td>
<td>Service Request Administrator (ORA_SVC_SR_ADMINISTRATOR)</td>
</tr>
<tr>
<td><strong>Service Request</strong></td>
<td>Service Request Administrator (ORA_SVC_SR_ADMINISTRATOR), HR Help Desk Service Request Management (ORA_SVC_</td>
<td>Service Request Administrator (ORA_SVC_SR_ADMINISTRATOR), HR Help Desk Service Request Management (ORA_SVC_HELPDESK_SR_MANAGEMENT)</td>
</tr>
<tr>
<td></td>
<td>HELPDESK_SR_MANAGEMENT), HR Help Desk Analysis (ORA_SVC_HELPDESK_ANALYSIS), HR Help Desk Administration</td>
<td></td>
</tr>
<tr>
<td></td>
<td>(ORA_SVC_HELPDESK_ADMINISTRATION)</td>
<td></td>
</tr>
<tr>
<td><strong>Standard Text</strong></td>
<td>Service Request Administrator (ORA_SVC_SR_ADMINISTRATOR), HR Help Desk Service Request Management (ORA_SVC_</td>
<td>Service Request Administrator (ORA_SVC_SR_ADMINISTRATOR), HR Help Desk Service Request Management (ORA_SVC_HELPDESK_SR_MANAGEMENT), Internal Service Request Administration (ORA_SVC_INTERNAL_HELPDESK_ADMINISTRATION)</td>
</tr>
<tr>
<td></td>
<td>HELPDESK_SR_MANAGEMENT), HR Help Desk Analysis (ORA_SVC_HELPDESK_ANALYSIS), HR Help Desk Administration (ORA_</td>
<td></td>
</tr>
<tr>
<td></td>
<td>SVC_HELPDESK_ADMINISTRATION), Internal Service Request Administration (ORA_SVC_INTERNAL_HELPDESK_</td>
<td></td>
</tr>
<tr>
<td></td>
<td>ADMINISTRATION), Internal Service Request Analysis (ORA_SVC_INTERNAL_HELPDESK_ANALYSIS), Internal Service</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Request Management (ORA_SVC_INTERNAL_HELPDESK_SR_MANAGEMENT), Service Request Channel User (ORA_SVC_SR_</td>
<td></td>
</tr>
<tr>
<td></td>
<td>CHANNEL_USER), Service Request Power User (ORA_SVC_SR_POWER_USER), Service Request Troubleshooter (ORA_SVC_</td>
<td></td>
</tr>
<tr>
<td></td>
<td>SVC_SR_TROUBLESHOOTER)</td>
<td></td>
</tr>
<tr>
<td>Object Name</td>
<td>Recommended Role for Import and Export (Code)</td>
<td>Administrator Level Roles (Code)</td>
</tr>
<tr>
<td>-----------------------------</td>
<td>--------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Standard Text Folder</td>
<td>Service Request Administrator (ORA_SVC_SR_ADMINISTRATOR), HR Help Desk Service Request Management (ORA_SVC_HELPDESK_SR_MANAGEMENT), HR Help Desk Analysis (ORA_SVC_HELPDESK_ANALYSIS), HR Help Desk Administration (ORA_SVC_HELPDESK_ADMINISTRATION), Internal Service Request Administration (ORA_SVC_INTERNAL_HELPDESK_ADMINISTRATION), Internal Service Request Analysis (ORA_SVC_INTERNAL_HELPDESK_ANALYSIS), Internal Service Request Management (ORA_SVC_INTERNAL_HELPERDESK_SR_MANAGEMENT), Service Request Channel User (ORA_SVC_SR_CHANNEL_USER), Service Request Power User (ORA_SVC_SR_POWER_USER), Service Request Troubleshooter (ORA_SVC_SR_TROUBLESHOOTER)</td>
<td>Service Request Administrator (ORA_SVC_SR_ADMINISTRATOR), HR Help Desk Service Request Management (ORA_SVC_HELPDESK_SR_MANAGEMENT), Internal Service Request Administration (ORA_SVC_INTERNAL_HELPDESK_ADMINISTRATION)</td>
</tr>
<tr>
<td>Standard Text User Variables</td>
<td>Service Request Administrator (ORA_SVC_SR_ADMINISTRATOR), HR Help Desk Service Request Management (ORA_SVC_HELPDESK_SR_MANAGEMENT), HR Help Desk Analysis (ORA_SVC_HELPDESK_ANALYSIS), HR Help Desk Administration (ORA_SVC_HELPDESK_ADMINISTRATION), Internal Service Request Administration (ORA_SVC_INTERNAL_HELPDESK_ADMINISTRATION), Internal Service Request Analysis (ORA_SVC_INTERNAL_HELPDESK_ANALYSIS), Internal Service Request Management (ORA_SVC_INTERNAL_HELPERDESK_SR_MANAGEMENT), Service Request Channel User (ORA_SVC_SR_CHANNEL_USER), Service Request Power User (ORA_SVC_SR_POWER_USER), Service Request Troubleshooter (ORA_SVC_SR_TROUBLESHOOTER)</td>
<td>Service Request Administrator (ORA_SVC_SR_ADMINISTRATOR), HR Help Desk Service Request Management (ORA_SVC_HELPDESK_SR_MANAGEMENT), Internal Service Request Administration (ORA_SVC_INTERNAL_HELPDESK_ADMINISTRATION)</td>
</tr>
<tr>
<td>Subscription</td>
<td>Subscription Specialist (ORA_OSS_SUBSCRIPTION_SPECIALIST_JOB)</td>
<td>Subscription Specialist (ORA_OSS_SUBSCRIPTION_SPECIALIST_JOB)</td>
</tr>
<tr>
<td>Subscription Service Charge Mappings</td>
<td>Subscription Specialist (ORA_OSS_SUBSCRIPTION_SPECIALIST_JOB)</td>
<td>Subscription Specialist (ORA_OSS_SUBSCRIPTION_SPECIALIST_JOB)</td>
</tr>
<tr>
<td>Subscription Usage Event</td>
<td>Subscription Specialist (ORA_OSS_SUBSCRIPTION_SPECIALIST_JOB)</td>
<td>Subscription Specialist (ORA_OSS_SUBSCRIPTION_SPECIALIST_JOB)</td>
</tr>
<tr>
<td>Template</td>
<td>Service Request Administrator (ORA_SVC_SR_ADMINISTRATOR), HR Help Desk Administration (ORA_SVC_HELPDESK_ADMINISTRATION), Internal Service Request Administration (ORA_SVC_INTERNAL_HELPDESK_ADMINISTRATION)</td>
<td>Service Request Administrator (ORA_SVC_SR_ADMINISTRATOR), HR Help Desk Administration (ORA_SVC_HELPDESK_ADMINISTRATION), Internal Service Request Administration (ORA_SVC_INTERNAL_HELPDESK_ADMINISTRATION)</td>
</tr>
<tr>
<td>Object Name</td>
<td>Recommended Role for Import and Export (Code)</td>
<td>Administrator Level Roles (Code)</td>
</tr>
<tr>
<td>---------------------</td>
<td>------------------------------------------------------------------</td>
<td>-----------------------------------------------------</td>
</tr>
<tr>
<td>Territory Geographies</td>
<td>Geography Administration (ORA_GEO_ADMIN_DUTY)</td>
<td>Geography Administration (ORA_GEO_ADMIN_DUTY)</td>
</tr>
<tr>
<td>Vehicles</td>
<td>Sales Administrator (ORA_ZBS_SALES_ADMINISTRATOR_JOB)</td>
<td>Sales Administrator (ORA_ZBS_SALES_ADMINISTRATOR_JOB)</td>
</tr>
</tbody>
</table>
4 Import Queues

Overview of Import Queues

The Manage Imports page of the Import Queue tab shows the following four types of import queues as infotiles:

- All Imports: This infotile displays the count of active, completed, and unsuccessful imports submitted by all users. Click on this infotile to see a list of all import jobs.
- Active Imports: This infotile displays the count of all import jobs submitted that are either in progress or in queued status. Click on this infotile to see a list of active import jobs.
- My Completed Imports: This infotile displays the count of imports submitted by the current user that are completed (either successful or failed with warnings or errors). Click on this infotile to see a list of completed import jobs created by the current user.
- Unsuccessful Imports: This infotile displays the count of unsuccessful imports submitted by all users. Click on this infotile to see a list of unsuccessful import jobs. These are the imports which couldn't complete because of application error in the import flow.

Import Activities Details

Click on the infotiles to see the following details about the import job:

<table>
<thead>
<tr>
<th>Column</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>The name of the import job.</td>
</tr>
<tr>
<td>File Name</td>
<td>The name of the source file.</td>
</tr>
<tr>
<td>Object</td>
<td>The object imported.</td>
</tr>
<tr>
<td>Status</td>
<td>The status of the import job. For more information about the statuses, see the topic How You Monitor Your Import Activities in the related topics section.</td>
</tr>
</tbody>
</table>
| Cancel Job           | Click the close icon to cancel an active import, if it's running for a long time. Only the user who submitted the import job or an administrator can cancel the job. Once you cancel an import job, you can't restart or resume it. Canceling the import job commits the data processed till that point and leaves the application in a clean state. A partial import may occur depending on the actual stage of the import, when the cancel option is selected. You can manually generate the reports for any processed records from the import status page.  

**Note:** You can't cancel a high-volume import job. |
| Estimated Completion Time | The date and time when the import job is expected to be completed. |
### Import Queues

<table>
<thead>
<tr>
<th>Column</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Start Time</td>
<td>The start date and time of the import.</td>
</tr>
<tr>
<td>Next Scheduled Date</td>
<td>The date and time when the import job is scheduled to run.</td>
</tr>
<tr>
<td>End Time</td>
<td>The end date and time of the import.</td>
</tr>
<tr>
<td>Submitted By</td>
<td>The user who submitted the import.</td>
</tr>
<tr>
<td>Rank</td>
<td>The rank associated with the paused job. The job with the highest rank is executed from the job queue. Possible values are integers such as 1, 2, and so on with 1 being the highest.</td>
</tr>
</tbody>
</table>

You can filter the list by clicking on any of these columns.

**Related Topics**
- How You Monitor Your Import Activities

### How You Monitor Your Import Activities

You can monitor imports that were scheduled to run, have completed successfully, or have failed with errors. For each import, you can view the details and make the necessary updates for any failed records that you want to import again.

You can view the list of imports from the **Manage Imports** page of the Import Queue tab. To view the status of an import job click the link in the import's Name column. The **Import Status** page shows the status of the most recently executed instance of the import. The **Import Status** page contains the following sections:

- Status Bar
- Details
- Import Attachments

**Status Bar**

The status bar shows the progress of the import in a graphical format. It shows the following stages during the import process:

- Import activity queued: The import request is queued for processing, and is waiting to begin execution.
- Preparing data for import: The data from the source file are being loaded in the temporary staging table for further processing.
- Importing data: The data from the source file are being validated and loaded in the target tables.
- Completing import activity: The import data have been loaded in the target tables, and cleanup tasks, such as the generation of log files, are in progress.
- Completed with errors: The import has completed with errors.
• Successful: The import has completed successfully.
• Completed with warnings: The import has completed with warnings.
• Canceled: The import was canceled by the user.
• Unsuccessful: The import was unsuccessful.

Hovering your mouse over the progress bar shows the status on the number of records imported.

**Note:** If the job is in the same status for a long time, then generate a diagnostic log as described in the topic Generate the Diagnostics Log for Import in Related Topics section. When you raise a service request, attach the diagnostic log files to help technical support to resolve the issue.

### Activity and Record Details

The **Activity Details** section shows the name of the import, import activity identifier, object name, and the name of the user who submitted the import. The section on date and time displays the start and end times, estimated completion time, and the time taken to complete the import.

The **Record Details** section displays the number of import records in each stage of processing. The various status details are summarized in the following table:

<table>
<thead>
<tr>
<th>File Processing Summary Information</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Records Read From File</td>
<td>The number of records read from the source file. Clicking the link for the number of records lets you download the spreadsheet file with the records.</td>
</tr>
<tr>
<td>Records Loaded Successfully</td>
<td>The number of import object records that were imported to the application destination tables.</td>
</tr>
<tr>
<td>Records With Errors Reported</td>
<td>The number of records that failed with errors when importing data from the interface tables to the destination tables. You can view the error details in the Exception and Error files attached to the process. Clicking the link for the number of records lets you download the spreadsheet file with the error records.</td>
</tr>
<tr>
<td>Records With Warnings</td>
<td>The number of records that were uploaded with warnings when importing data from the interface tables to the destination application tables. Clicking the link for the number of records lets you download the spreadsheet file with the warning records.</td>
</tr>
<tr>
<td>Unprocessed</td>
<td>The number of records that weren’t processed.</td>
</tr>
</tbody>
</table>

Clicking on the Advanced Options section shows the advanced configuration options that you had selected when creating the import activity.

The rejected file records don’t contain the error message when import job ends in unsuccessful status.

**Note:** In the files that are generated after the completion of an import activity, all error message values are enclosed within double quotation marks. The use of double quotation marks improves the format of the log files by ensuring that the error messages containing commas aren’t treated as multiple values.
Detailed Import Status

The Detailed Import Status page shows the status of the different steps in the import activity. You can navigate to this page by selecting View Detailed Import Status from the Actions menu on the Status page. For each step, this page shows the individual sub tasks of the import process. This information helps the technical support team to fix any issues during the import.

Purge Import Data

You can purge your import data after your import job is complete. You can purge the data either manually or automatically based on the parameters set:

- Manually purge data: You can manually purge data by running the job Purge Import Data. Import Management triggers the auto-scheduled process that purges all data that’s older than 30 days. You can set the number of data in the profile option ZCA_IMPORT_PURGING_DURATION. The default value is 30.
- Automatically purge data: You can configure Import Management to automatically purge data using the ZCA_IMPORT_PURGE_ON_JOBCOMPLETION profile option. You can set this profile option to Y to purge import data after the job is run. The default value is Y. This purges all interface table entries for all objects except for objects that are registered as 'ObjectPostProcess'.

Alternately, you can set the ZCA_IMPORT_PURGE_FROM_UI profile option to Y to display purge option in the Import Object Details page. This lets you purge import data from the Import Object Details page.

Import Attachments

The Import Attachments section lists the files associated with this import in a table. The Actions column lets you either download the file or view more details. Success log file isn't generated after the import job is completed successfully. To generate success logs for even successfully completed jobs, set the profile option ZCA_IMPORT_SUPPRESS_SUCCESSLOG_GENERATION to 'No'. You can download the following files from this section:

- Process Log: Click Action > Generate Log.
- Diagnostics Log file: Click Action > Generate Diagnostics.
- Map file: Click the Download link to download the import activity map file in CSV format.
- Source CSV file used for the import.
- Exception files that include a row for each record that failed. All the errors for that row are concatenated and displayed in the Error Message column of the file.
- Error file that includes all the errors for each record that failed validation.

Related Topics

- Import Data
- Generate the Diagnostics Log for Import

How You Monitor Import Activities Using REST APIs

You can receive import completion notification through REST resource. This avoids the need to keep checking the import status.
To receive import completion notification through REST service, you must define the REST service endpoint in Application Composer. You can configure and register your REST endpoint to receive notification whenever your import job completes.

Register an External REST Endpoint in Application Composer

To register an endpoint for notification:

1. Create and enter into a sandbox by navigating to Configuration > Sandboxes > Create Sandbox.
2. Navigate to Configuration > Application Composer > Web Services. Note that this option is available only when you're inside the sandbox.
3. You can edit the existing endpoints, or create a new endpoint such as ExternalEndPoint1, by clicking the Create icon.
4. Enter the name of the endpoint and the URL, and select the authentication scheme. For example, your URL can be in the format https://servername/ic/api/integration/v1/connections/cbveTest.
5. Select and configure the POST method by clicking the check box for POST. Currently only POST method is supported for the Import Notification feature.
6. Select and provide the code samples for the request and response payloads. Following is the sample for request and response payloads:

   ```
   {
       "items": [],
       "count": 0,
       "hasMore": false,
       "limit": 25,
       "offset": 0,
       "links": [{
           "rel": "self",
           "href": "https://servername/ic/api/integration/v1/connections/cbveTest",
           "name": "ExternalEndPoint1",
           "kind": "collection"
       }]
   }
   ```
7. Click Save and Close.
8. After making the changes, publish the sandbox to commit your changes.

Validate the Endpoint

You can validate the REST endpoint to ensure that your REST web service configuration in Web Services in Application Composer is correct and the import process can call the endpoint successfully. To validate your REST endpoint and set an endpoint as default:

1. Navigate to Tools > Import Management > Import Configuration > REST Notification.
2. Here, select REST Notification as the notification type, and select the endpoint you registered from the Notification Endpoint drop-down list. In our example, select ExternalEndPoint1.
3. To make this connection as the default one while creating import jobs, select the Set as default check box.
4. To validate, click the Payload Details section, and click the Validate REST Endpoint button. If your endpoint is valid, then you see one of the following response statuses in the Response text box:
   - 200
   - 201
   - 202
   - 204
Create the Import Activity and Monitor the Status

1. Navigate to Tools > Import Management > Create Import Activity.
2. Create the import activity, enter the name, and select the object and source file.
3. Click the Advanced Options section and select the notification endpoint ExternalEndPoint1 from the Notification Endpoint drop-down list. If you don't want to receive the notification, then select a blank value in the drop-down list.
4. Click Next and map the attributes on the Map Fields page. Review the configurations and submit the job. For more information on creating an import activity, see the topic Import Data.
5. Once you submit the import, you can monitor the status by accessing the configured endpoint.
6. Alternatively, you can verify whether the notification is submitted by downloading the log files. The last entry in the file indicates the status of notification.

Import Notification in REST and External Data Loader Client (EDLC)

You can use the EDLC command listResthooks to get the list of resources registered in Application Composer. For example,

```
java -jar oscdata loader.jar listResthooks -username importuser -target-url https://mypod.oracle.com
```

You can then use the notification endpoint to get the import notification with the following command:

```
```

You can use the RestNotification attribute to specify your notification endpoint while creating your import activity using REST. For example, you can use the following sample payload to create your import activity:

```
{
"Name": "RESTImportActivity",
"ObjectCode": "Account",
"HighVolume": "YES",
"Activate": "YES",
"RestNotification": "ExternalEndPoint1",
"DataFiles": [
{
"InputFileContentId": "UCMFA00012159"
}
]
}
```

The following table describes the behavior when you don't provide the REST notification endpoint in REST and EDLC.

<table>
<thead>
<tr>
<th>REST Notification Value</th>
<th>Endpoint Used for Import Job</th>
<th>REST Notification Behavior</th>
</tr>
</thead>
<tbody>
<tr>
<td>null</td>
<td>Default endpoint is selected</td>
<td>REST Notification is sent to the default REST endpoint.</td>
</tr>
<tr>
<td>REST notification not passed</td>
<td>Default endpoint is selected</td>
<td>REST Notification is sent to the default REST endpoint.</td>
</tr>
<tr>
<td>&quot;&quot;</td>
<td>No REST endpoint is selected</td>
<td>No REST Notification is sent.</td>
</tr>
<tr>
<td>REST Notification Value</td>
<td>Endpoint Used for Import Job</td>
<td>REST Notification Behavior</td>
</tr>
<tr>
<td>------------------------</td>
<td>------------------------------</td>
<td>--------------------------</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
5 Manage Import Mappings

How You Map Import Fields

After entering the import options, map the fields in the source file to the corresponding target attributes.

You can do these in the section:

- Automatic Mapping
- Map Fields
- Save the Import Mapping

Automatic Mapping

The automatic mapping feature maps the source file columns to the target attribute columns. The application automatically saves the mapping created under the name **Automatic Mapping** and lists it in the **Import Mapping** drop-down list.

For an import file attribute to get automatically mapped, the column header for the attribute in the import file should either be same as the Attribute Name, or the Attribute Display Name. You can view the Attribute Name and Attribute Display Name in the **Import Objects** tab.

You can download the import object templates from the Import Objects tab, and use them to create the source CSV file for your import. The templates have prepopulated column headers that ensure that the attributes are automatically mapped.

You can override a column mapping, by dragging target attributes from **Target Attributes** section to the **Attribute Name** field of the **Source File** section. If you modify the mapping, then you must save the mapping with a different name. Once you provide the name, the date and year time stamp is appended to the mapping name. The newly created mapping appears in the **Import Mapping** drop-down list. To apply the automatic mapping instead of your custom mapping, select Automatic Mapping from the **Import Mapping** drop-down list and click **Apply**.

Map the Fields

The Map Fields section can be subdivided into source file columns and target attribute columns. The source column header value is derived from the source file.

The following table outlines the source columns.

<table>
<thead>
<tr>
<th>Source Column</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Column Header</td>
<td>Represents the column header for the text files.</td>
</tr>
<tr>
<td>Example Value</td>
<td>Values are derived from the first source file saved with the predefined mapping. If you didn't select a predefined mapping, then the example values are taken from the first data row in the source file selected in the first step of the Import Activity definition.</td>
</tr>
<tr>
<td>Attribute Name</td>
<td>Represents the target attribute that's to be mapped to the source column.</td>
</tr>
</tbody>
</table>
Source Column | Description
---|---

The following table outlines the target columns.

<table>
<thead>
<tr>
<th>Target Column</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Target Attribute</td>
<td>The attribute name that represents the corresponding table column for the object.</td>
</tr>
<tr>
<td>Required</td>
<td>Indicates whether the target attribute is a required or a user key. Required indicates that the key is mandatory while creating a new record. User key indicates that the key is mandatory while updating an existing record.</td>
</tr>
</tbody>
</table>

Save the Import Mapping

You can use automatic mapping to map the source file attributes to target attributes as described in the previous section. If you want to map additional attributes or override existing mappings, then click **Save As** and save your custom map. The name of a mapping file must be unique for the object.

For more information on how to import your data, see the object-specific import topics in the chapter Import Your Data. These topics are titled Import Your <Object-Name> Data. They provide the following information about importing data:

- How to map your source data to Oracle Applications Cloud object attributes. This way the import process would know where to insert each of the information bits.
- Required attributes and validations for the object.
- How to create the source CSV file with the data you want to import.
- How to kick off an import activity.
- How to check the import results to know if the import went well.

**Related Topics**

- Import Data

Create Import Mappings

An import mapping lets you quickly map your source object attributes to the object attributes in CX Sales and B2B Service. You must be an administrator or setup user to create import mappings.

You can create an import mapping in one of the following two ways:

- Create an import mapping manually.
- Generate the import map from the sample source file.
Create Maps Manually

1. Click **Tools > Import Management > Import Objects**.
2. Click the Account link under the **Display Name** column to create a mapping for the Account object.
3. On the **Manage Mapping** page, click the **Create Import Mapping** button.
4. On the **Edit Import Mapping** page, enter the name of the mapping, and provide a description for the mapping. The **Target Attributes** section displays the attributes of the Account object that should map to the source file columns. Check the **Required** column to see if the attribute is required or is a user key.
5. In the **Source File** section, click the **Add Column** button to insert a column to the mapping file.
6. To create the mapping column for the Organization Name attribute, drag and drop the Organization Name attribute from **Target Attributes** section to the **Attribute Display Name** column under the **Source File** section.
7. Provide the column header name, such as organization name and an example value, such as Green Corp. Follow the steps 5 to 7 to add any additional mapping columns.
8. Click the **Save and Close** button to save the mapping.

To edit or download the mapping file, click the mapping number link for your mapping on the Manage Mapping page. On the Edit Import Mapping page, click **Download Map** from the Actions menu.

Generate Maps from the Source File

1. Click **Tools > Import Management > Import Objects**.
2. Click the Account link under the **Display Name** column to create a mapping for the Account object.
3. On the **Manage Mapping** page, click the **Create Import Mapping** button.
4. On the **Edit Import Mapping** page, enter name of the mapping, select the object such as Account, and provide a description for the mapping. The **Target Attributes** section displays the attributes of the Account object that should map to the source file columns. Also, check the **Required** column to see if the attribute is required or is a user key.
5. From the **Actions** menu under **Source File** section, click **Select Source File**.
6. In the **Source File** dialog box, choose the CSV file that should be the source for your mapping file. This creates the mapping file based on the column header and example values in the source file.
7. Click **Save and Close** button. And we’re done.

For more information on how to import your data, see the object-specific import topics in the chapter Import Your Data. These topics are titled Import Your <object-name> Data. They provide the following information about importing data:

- How to map your source data to Oracle Applications Cloud object attributes. This way the import process would know where to insert each of the information bits.
- Required attributes and validations for the object.
- How to create the source CSV file with the data you want to import.
- How to kick off an import activity.
- How to check the import results to know if the import went well.

Manage Import Mappings

Import Mappings map your source data to the fields in the Oracle Applications database. You can reuse existing mappings by editing them. Also, you can download an existing import mapping from one Oracle application instance and upload the mapping into another Oracle application instance.
Copy and Modify a Mapping

To copy or modify a mapping:

1. Click **Tools > Import Management > Import Objects.**
2. In the **Import Object Details** section, choose the Object name for which you need the template.
   Click the link under **Display Name** column to get to the Manage Mapping page.
3. Click the link under the **Mapping Number** column.
4. On the **Edit Import Mapping** page, select the **Copy Import Mapping** option from the **Actions** menu. Edit the mapping by dragging the target attributes to the **Attribute Display Name** field under **Source File** section.
5. Add more attributes by clicking the **Add Column** button.
6. Once done, give a name for the mapping and click **Save**.

   If you don’t want the mapping that you see on the list, select **Delete Import Mapping** from the **Actions** menu.

Download the Map File

To download a map file:

1. Click **Tools > Import Management > Import Objects.**
2. In the **Import Object Details** section, click the Object name link for which you need the template.
3. Click the link under the **Mapping Number** column for the required mapping.
4. On the **Edit Import Mapping** page, select **Download Map** from the **Actions** menu.

   When prompted, save the file to a location.

Upload the Map File

To upload a map file:

1. Click **Tools > Import Management > Import Objects.**
2. In the **Import Object Details** section, click the Object name link for which you need the template.
3. On the **Manage Mapping** page, click the **Upload Map** button. Select a map file and click **OK**.
4. On the **Edit Import Mapping** page, give a name and save the mapping.

Download the Import Object Templates

Import Templates give you an idea about the object attributes. Most attributes in the templates include example values that help you know what value to provide in the import file. To download an import object template:

1. Click **Tools > Import Management > Import Objects.**
2. In the **Import Object Details** section, click the Object name link for which you need the template.
3. On the **Manage Mapping** page, click the link in the **Mapping Number** column for the required mapping.
4. On the **Edit Import Mapping** page, select **Download Template** option from the **Actions** menu.

For more information on how to import your data, see the object-specific import topics in the chapter **Import Your Data.** These topics are titled **Import Your <Object-Name> Data.** They provide the following information about importing data:

- How to map your source data to Oracle Applications Cloud object attributes. This way the import process would know where to insert each of the information bits.
Import Mappings

Click Tools Import Management Import Objects. Click the Object link to navigate to the Manage Mapping page.

You can create a mapping by clicking the Create Import Mapping button. For more details about creating a mapping, refer to the topic Create Import Mappings. Click the mapping you created to navigate to the Edit Import Mapping page where you can edit your mapping.

The Edit Import Mapping page contains the following sections:
- Source File
- Target Attributes

Source File
Here are the details related to columns provided in the source file:

<table>
<thead>
<tr>
<th>Source Column</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Column Header</td>
<td>The column name expected in the source file.</td>
</tr>
<tr>
<td>Example Value</td>
<td>Values from the first data row in the source file.</td>
</tr>
<tr>
<td>Attribute Display Name</td>
<td>Represents the target attribute that's to be mapped to the source column.</td>
</tr>
<tr>
<td>Select Source File</td>
<td>Use this button from the Action menu to import mapping from a source file.</td>
</tr>
<tr>
<td>Delete Column</td>
<td>Use this button from the Action menu to delete a column from the mapping file. This option is enabled only when at least one column is added to the Source File section.</td>
</tr>
</tbody>
</table>

Target Attributes
Here are the details related to corresponding attributes in the target application table:

<table>
<thead>
<tr>
<th>Target Attributes</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Target Attribute</td>
<td>The attribute name that represents the corresponding table column for the object.</td>
</tr>
<tr>
<td>Target Attributes</td>
<td>Description</td>
</tr>
<tr>
<td>-------------------</td>
<td>-------------</td>
</tr>
<tr>
<td>Required</td>
<td>Indicates whether the target attribute is a user key or a required key.</td>
</tr>
<tr>
<td>Default Value</td>
<td>Default value for the attribute if any.</td>
</tr>
<tr>
<td>Description</td>
<td>Provides a brief description of the attribute.</td>
</tr>
</tbody>
</table>

For more information on how to import your data, see the object-specific import topics in the chapter Import Your Data. These topics are titled Import Your <Object-Name> Data. They provide the following information about importing data:

- How to map your source data to Oracle Applications Cloud object attributes. This way the import process would know where to insert each of the information bits.
- Required attributes and validations for the object.
- How to create the source CSV file with the data you want to import.
- How to kick off an import activity.
- How to check the import results to know if the import went well.

**Related Topics**
- Import Data
- Create Import Mappings
6 Manage Import Objects

How You Manage Import Objects

Import Objects correlate with the tables in Oracle Applications. Understand import objects and their attributes to manage the data that you want to import.

Import Object Details

Click **Tools > Import Management > Import Objects**. To see the details of an import object, select it on the Import Object Details page. Here are the details that you see about each importable object.

<table>
<thead>
<tr>
<th>Column</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Display Name</td>
<td>The object as it's called in the User Interface.</td>
</tr>
<tr>
<td>Language Independent Code</td>
<td>The internal name of the object.</td>
</tr>
<tr>
<td>Parent Object</td>
<td>The parent object of the selected object. If there are multiple parents for an object, they're shown separated by comma.</td>
</tr>
<tr>
<td>View Hierarchy</td>
<td>Clicking on the View Hierarchy icon shows the hierarchy between the parent and child objects in a graphical format.</td>
</tr>
<tr>
<td>User Key</td>
<td>The attribute or the group of attributes that's used to uniquely identify a record.</td>
</tr>
<tr>
<td>Required Attributes</td>
<td>The attribute or the group of attributes for which values are required to create a record. These can't be NULL when updating a record.</td>
</tr>
<tr>
<td>Description</td>
<td>A short description of the object.</td>
</tr>
<tr>
<td>Download</td>
<td>Link to download the import object template files for each object and its child objects.</td>
</tr>
</tbody>
</table>

Target Attributes

Here are the details that you see for each target attribute.

<table>
<thead>
<tr>
<th>Column</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Display Name</td>
<td>Name of the target attribute in the User Interface.</td>
</tr>
<tr>
<td>Attribute Name</td>
<td>Internal or field name of the attribute.</td>
</tr>
</tbody>
</table>
Use Import Object Templates to Import Data

You can download an import object template for an object, such as account, and use it as a source file to import data. Templates make it easy for you to use the automapping feature.

For automapping to work, the column headers in the source file must match the names of the columns (attributes) of the objects imported. The column headers shown in the first row of the downloadable templates are the same as the column names of the corresponding objects. Therefore, building source files from the templates allows the automapping process.

For example, if your source file has a column "URL" then it's mapped to the Account URL column. However if your source file's column header is "Website", then automapping fails and you should map manually.

Download the Import Object Templates

To download an import object template:

1. Click Tools > Import Management > Import Objects.
2. On the Manage Import Objects page, click the Download icon for the object, such as account, for which you want to download the template.

The next section explains the procedure to update the template to import data.

Populate the Import Object Templates

Extract the contents of the ZIP file to a folder. The extracted folder contains the template text files for each of the parent and child objects. The readme text file within the folder contains instructions on how to use the template files to create source file for importing data. Here are the steps to import data using the downloaded template:

1. Open the CSV template file for the object you want to import.
   The file for each object contains two rows. The first row contains all the column names in a format that's compatible with the automatic mapping functionality. The second row contains the display names as shown on the import mapping user interface.

<table>
<thead>
<tr>
<th>Column</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Required</td>
<td>Indicates whether the attribute is mandatory or not.</td>
</tr>
<tr>
<td>Default Value</td>
<td>The default value for the attribute, if any.</td>
</tr>
<tr>
<td>Type</td>
<td>Data type of the target attribute.</td>
</tr>
<tr>
<td>Length</td>
<td>Maximum allowed length for the target attribute values.</td>
</tr>
<tr>
<td>Description</td>
<td>A short description of the target attribute.</td>
</tr>
</tbody>
</table>
2. Before populating the CSV template file with the data to be imported, delete the display name values in the second row, and populate the columns with the data to import.

3. Use the updated file as the source when you’re creating an import activity on the import user interface. For more details on the import process, see the topic Import Data in the related links section.

The automatic mapping functionality maps all the columns automatically. You can see both the mapped column names and the corresponding column names in your language on the Map Fields page.

For more information on how to import your data, see the object-specific import topics in the chapter Import Your Data. These topics are titled Import Your <Object-Name> Data. They provide the following information about importing data:

- How to map your source data to Oracle Applications Cloud object attributes. This way the import process would know where to insert each of the information bits.
- Required attributes and validations for the object.
- How to create the source CSV file with the data you want to import.
- How to kick off an import activity.
- How to check the import results to know if the import went well.

Related Topics
- Import Data
7 Import Custom Objects

How You Import Custom Objects

This topic describes how to enable the import of custom objects. Before you can import and export data for custom objects created with Application Composer, you must ensure that the required object artifacts have been generated.

Object artifacts are required to register your extensions and make them available for importing. When you publish your sandbox after your configurations, artifacts are automatically generated and the custom objects are available for import and export. With a single publishing, you can generate configurations for CRM, ERP, and SCM cloud applications.

How you Enable Import of Custom Objects

To enable the import of custom object data:

1. Create a sandbox and add configurations to the objects.
2. Publish the sandbox.
3. Artifact generation is triggered automatically as part of the sandbox publish. Artifacts are generated for objects that are changed inside sandbox only.
4. You can monitor the artifact generation status on the Generate Import and Export Artifacts tab by navigating to Tools > Import Management > Import Configuration. You can perform this only once you’re outside the sandbox.

After the artifact is generated, you’re ready to import. If some artifacts aren't generated automatically, then you have to manually generate them using the Generate button. To download the diagnostics log of the artifact generation, click the Generate button under the Diagnostics tab, and then click the link under the Attachments column. Note that you must import the custom child objects only after importing the parent object.

You can update the profile option ORA_ZCA_IMPORT_EXPORT_QUEUE_SIZE to specify the size of import and export queues for dynamic queue configurations. The possible values are LOW, MEDIUM, HIGH, and FIXED. After updating the profile option, you must generate the artifacts for the changes to reflect.

If you have configured security in the Application Composer for create, update, or delete scenario, then such validations aren't honored by high-volume imports. Validations are applicable only for low-volume imports.

Relationships Between Custom Objects

Parent object resources expose the child objects of top-level custom objects. For objects to interact with one another, relationships must be created between them. The related objects can be either standard or custom objects. For example, if you want attributes from the Employee object to be available in the Trouble Ticket object workspace, a relationship must be defined between the Employee object and the Trouble Ticket object.

You can use Application Composer to create relationships between objects. Using Application Composer, you can create two types of relationships:

- Parent-child: When you define a parent-child relationship, the link to the child object is included in the parent object description. A child object doesn't have its own workspace, and the child object's records are deleted if the parent object record is deleted.
• Reference: When you define a reference relationship, the primary key of the source object is included as a foreign key in the description of the target object.

Intersection Objects

Use Application Composer to create many-to-many relationships between custom objects. In this case, you create an intersection object that references the source and target objects. For example, consider two object resources, Trouble Ticket and Resource, related by a many-to-many reference relationship, with the Assignment resource as the intersection object. In such a case, the following applies:

• The Assignment resource has Trouble Ticket as the source object and Resources as the target object. The objects Trouble Ticket and Resources have many-to-many relationships.
• The Assignment resource is the child resource of both Trouble Ticket and Resources.

How you Import Record Name Values

By default, the Record Name field is automatically generated and is updated using automatic sequence. The value you provide in the source file is ignored. If automatic record-name generation is disabled in the Application Composer, then you must provide the value in the source file and this value is imported. However, high-volume import doesn't support automatic generation of Record Name field; you must provide the Record Name value in the source file.

Specify the RecordNumber Attribute

When defining your custom object in Application Composer, RecordNumber field is always unique. The import activity uses RecordNumber as the user key to resolve the record in the target database.

When you modify the PUID (RecordNumber) make sure you follow by Application Composer guidelines, to prevent recordNumber collisions with the existing database sequence. This is applicable for both high-volume import and import using REST service. For more information on how to prevent conflict in PUID, see the topic Custom Object Public Unique IDs in the related topics section.

Support of Record Name Attribute

You can update custom object records by using the Record Name attribute to identify records. To enable this, you must set the profile option ORA_ZCA_IMPORT_ENABLE_RECORDNAME_SUPPORT to Y. By default this profile option has a value N. If you use the Record Name attribute to update records, the following order of precedence is used to identify the records:

1. ID (PK)
2. RecordNumber (PUID)
3. RecordName (AlternatePUID)

However, you can't update the Recordname attribute value.

Related Topics

Import Custom Object Data

You can import custom object data into CX Sales and B2B Service. Before importing custom data, create the parent and child custom objects for the data you want to import.
In this example, we will create a parent object (CustomOrder) and a child object (CustomOrderItem) with the required fields and then import data for these objects.

Create the Parent and Child Objects
To create parent and child custom objects:

1. Navigate to Application Composer.
2. Click the Custom Objects icon on the Overview screen.
3. Click the Create New Object icon to bring up the Create Custom Object window. Note that your environment must be in an active sandbox to perform this action.
4. Enter the value CustomOrder for Display Label. The other fields are automatically filled, which creates the parent custom object CustomOrder.
5. Create the custom fields by clicking the Fields option under the CustomOrder object. Enter the display names OrderName and OrderCount for the fields.
6. Click the CustomOrder icon on the side pane. On the Overview page, click the Create Child Object button to create the child object CustomOrderItem.
7. Create the custom fields ItemName andItemCount.
8. After creating the custom objects, publish and sign out from the sandbox.

Import Data for Parent Custom Object
To import data for parent custom objects only, follow these steps:

1. Create the CSV file using the following table:

<table>
<thead>
<tr>
<th>RecordName</th>
<th>OrderName</th>
<th>OrderCount</th>
</tr>
</thead>
<tbody>
<tr>
<td>CustomOrder1</td>
<td>01-A1-inventory</td>
<td>2000</td>
</tr>
<tr>
<td>CustomOrder2</td>
<td>02-B3-inventory</td>
<td>3000</td>
</tr>
</tbody>
</table>

2. Click Tools > Import Management.
3. On the Manage Imports page, click the Create Import Activity button to create an import activity InsertCustomObject. For more information about creating an import, see the topic Import Data mentioned in Related Topics section.
4. On the Create Import Activity page, provide the file name InsertCustomObject and select the custom object CustomOrder from the Object drop-down list. Browse the CSV file that you created in step 1. Click Next.
5. On the mapping page, map the attributes as shown in the following table:

<table>
<thead>
<tr>
<th>Column Header</th>
<th>Example Value</th>
<th>Attribute Display Name</th>
</tr>
</thead>
<tbody>
<tr>
<td>RecordName</td>
<td>CustomOrder1</td>
<td>CustomOrder Name</td>
</tr>
<tr>
<td>OrderName</td>
<td>01-A1-inventory</td>
<td>OrderName</td>
</tr>
<tr>
<td>OrderCount</td>
<td>2000</td>
<td>OrderCount</td>
</tr>
</tbody>
</table>
6. Review and activate the import activity.

Note: If there are any mandatory fields in the custom object, then they must be included in the CSV file and a value must be provided for all records when performing an import. The required values must be mapped on the mapping page. In this example, OrderName is a mandatory attribute.

Import Multiple Child Records for an Existing Parent Record
After importing the parent record you can import data for child records associated with the parent record. To import data for multiple child records for an existing parent custom object, follow these steps:

1. Create the CSV file using the following table.

<table>
<thead>
<tr>
<th>RecordName</th>
<th>CustomOrder_Id_c</th>
<th>ItemName</th>
<th>ItemCount</th>
</tr>
</thead>
<tbody>
<tr>
<td>CustomOrder1_Item1</td>
<td>300100035820958</td>
<td>Electronics</td>
<td>150</td>
</tr>
<tr>
<td>CustomOrder1_Item2</td>
<td>300100035820958</td>
<td>Stationery</td>
<td>200</td>
</tr>
<tr>
<td>CustomOrder1_Item3</td>
<td>300100035820958</td>
<td>Computer Accessories</td>
<td>500</td>
</tr>
</tbody>
</table>

Note: You can import the custom child of an object using the ParentRecordName attribute also.

2. Click Tools > Import Management.
3. On the Manage Imports page, click the Create Import Activity button to create an import activity InsertCustomObject. For more information about creating an import, see the topic Import Data mentioned in Related Topics section.
4. On the Create Import Activity page, provide the file name InsertCustomObject and select the custom object CustomOrderItem from the Object drop-down list. Browse the CSV file that you created in step 1. Click Next.
5. On the mapping page, map the attributes as shown in the following table.

<table>
<thead>
<tr>
<th>Column Header</th>
<th>Example Value</th>
<th>Attribute Display Name</th>
</tr>
</thead>
<tbody>
<tr>
<td>RecordName</td>
<td>CustomOrder1_Item1</td>
<td>CustomOrderItem Name</td>
</tr>
<tr>
<td>CustomOrder_Id_c</td>
<td>300100035820958</td>
<td>CustomOrder_Id_c</td>
</tr>
<tr>
<td>ItemName</td>
<td>Electronics</td>
<td>ItemName</td>
</tr>
<tr>
<td>ItemCount</td>
<td>150</td>
<td>ItemCount</td>
</tr>
</tbody>
</table>

6. Review and activate the import activity.
Chapter 7
Import Custom Objects

Import Multiple Child Records with Different Parent Records

After importing the parent record you can import data for child records of the parent record. The Parent Record Object Key values will be different depending on which parent record the child records are being imported for. To import data for multiple child records with different parent object records, follow these steps:

1. Create the CSV file using the following table.

<table>
<thead>
<tr>
<th>RecordName</th>
<th>CustomOrder_Id_c</th>
<th>ItemName</th>
<th>ItemCount</th>
</tr>
</thead>
<tbody>
<tr>
<td>CustomOrder1_Item1</td>
<td>300100035820958</td>
<td>Switches</td>
<td>50</td>
</tr>
<tr>
<td>CustomOrder1_Item2</td>
<td>300100035820958</td>
<td>Sockets</td>
<td>100</td>
</tr>
<tr>
<td>CustomOrder1_Item3</td>
<td>300100035820958</td>
<td>Regulators</td>
<td>50</td>
</tr>
<tr>
<td>CustomOrder2_Item1</td>
<td>300100035820960</td>
<td>Pencils</td>
<td>50</td>
</tr>
<tr>
<td>CustomOrder2_Item2</td>
<td>300100035820960</td>
<td>Sharpener</td>
<td>100</td>
</tr>
<tr>
<td>CustomOrder2_Item3</td>
<td>300100035820960</td>
<td>Eraser</td>
<td>50</td>
</tr>
</tbody>
</table>

**Note:** You can import the custom child of an object using the ParentRecordName attribute also.

2. Click **Tools > Import Management**.
3. On the Manage Imports page, click the Create Import Activity button to create an import activity InsertCustomObject. For more information about creating an import, see the topic Import Data mentioned in the Related Topics section.
4. On the Create Import Activity page, provide the file name InsertCustomObject and select the custom object CustomOrderItem from the Object drop-down list. Browse the CSV file that you created in step 1. Click **Next**.
5. On the mapping page, map the attributes as shown in the following table.

<table>
<thead>
<tr>
<th>Column Header</th>
<th>Example Value</th>
<th>Attribute Display Name</th>
</tr>
</thead>
<tbody>
<tr>
<td>RecordName</td>
<td>CustomOrder1_Item1</td>
<td>CustomOrderItem Name</td>
</tr>
<tr>
<td>CustomOrder_Id_c</td>
<td>300100035820958</td>
<td>CustomOrder_Id_c</td>
</tr>
<tr>
<td>ItemName</td>
<td>Electronics</td>
<td>ItemName</td>
</tr>
<tr>
<td>ItemCount</td>
<td>150</td>
<td>ItemCount</td>
</tr>
</tbody>
</table>
6. Review and activate the import activity.

High Volume Import of Custom Objects

You can now use auditing functionality while performing high-volume import of custom objects. You can control base table auditing by setting the profile option ORA_ZCA_IMPORT_ENABLE_AUDIT_HIGHVOLUME to Yes. The default value is No.

1. To enable base table auditing, go to Setup and Maintenance.
2. Search for Manage Administrator Profile Values Profile Option code: ORA_ZCA_IMPORT_ENABLE_AUDIT_HIGHVOLUME.
3. Set it to Yes, then Save.

Related Topics
- Import Data

Update Custom Object Data

This example shows how to update custom object data in CX Sales and B2B Service.

Update Only Parent Records

To create the parent and child custom objects, review the topic Import Custom Object Data referenced in the Related Topics section. Perform the following steps to update only the parent records:

1. Create the CSV file based on the following table:

<table>
<thead>
<tr>
<th>ID</th>
<th>RecordName</th>
<th>OrderName</th>
<th>OrderCount</th>
</tr>
</thead>
<tbody>
<tr>
<td>300100035820958</td>
<td>CustomOrder1</td>
<td>01-A1-inventory</td>
<td>90000</td>
</tr>
<tr>
<td>300100035820960</td>
<td>CustomOrder2</td>
<td>01-A1-inventory</td>
<td>70000</td>
</tr>
</tbody>
</table>

2. Click Tools > Import Management.
3. On the Manage Imports page, click the Create Import Activity button to create an import activity UpdateCustomObject. For more information about creating an import, see the topic Import Data mentioned in the Related Topics section.
4. On the Create Import Activity page, provide the file name UpdateCustomObject and select the custom object CustomOrder from the Object drop-down list. Browse the CSV file that you created in step 1. Click Next.
5. On the mapping page, map the attributes as shown in the following table.

<table>
<thead>
<tr>
<th>Column Header</th>
<th>Example Value</th>
<th>Attribute Display Name</th>
</tr>
</thead>
<tbody>
<tr>
<td>ID</td>
<td>300100035820958</td>
<td>Record ID</td>
</tr>
</tbody>
</table>
### Import Custom Objects

**Chapter 7**

**Import Custom Objects**

**Column Header** | **Example Value** | **Attribute Display Name**
--- | --- | ---
RecordName | CustomOrder1 | CustomOrder Name
OrderName | 01-A1-inventory | OrderName
OrderCount | 90000 | OrderCount

6. Review and activate the import activity.

**Note:** The Parent Record Object Key should be taken from the log file generated by the parent insert import job.

**Update Only Child Records**

To create the parent and child custom objects, review the topic Import Custom Object Data referenced in the Related Topics section. Perform the following steps to update only the child records.

1. Create the CSV file using the following table.

<table>
<thead>
<tr>
<th>ID</th>
<th>RecordName</th>
<th>ItemName</th>
<th>ItemCount</th>
</tr>
</thead>
<tbody>
<tr>
<td>300100035821118</td>
<td>CustomOrder1_Item1</td>
<td>Switches</td>
<td>2500</td>
</tr>
<tr>
<td>300100035821120</td>
<td>CustomOrder1_Item2</td>
<td>Sockets</td>
<td>1000</td>
</tr>
</tbody>
</table>

2. Click **Tools > Import Management**.

3. On the Manage Imports page, click the **Create Import Activity** button to create an import activity `UpdateCustomObject`.

4. On the Create Import Activity page, provide the file name `UpdateCustomObject` and select the custom object `CustomOrderItem` from the **Object** drop-down list. Browse the CSV file that you created in step 1. Click **Next**.

5. On the mapping page, map the attributes as shown in the following table.

<table>
<thead>
<tr>
<th>Column Header</th>
<th>Example Value</th>
<th>Attribute Display Name</th>
</tr>
</thead>
<tbody>
<tr>
<td>ID</td>
<td>300100035821118</td>
<td>Record ID</td>
</tr>
<tr>
<td>RecordName</td>
<td>CustomOrder1_Item1</td>
<td>CustomOrder Name</td>
</tr>
<tr>
<td>ItemName</td>
<td>Switches</td>
<td>ItemName</td>
</tr>
<tr>
<td>ItemCount</td>
<td>2500</td>
<td>ItemCount</td>
</tr>
</tbody>
</table>
6. Review and activate the import activity.

Related Topics

Delete Custom Object Data

This example shows how to delete custom object data in CX Sales and B2B Service.

Perform the following steps to delete the custom object records:

1. Create the CSV file based on the following table:

<table>
<thead>
<tr>
<th>ID</th>
<th>RecordName</th>
</tr>
</thead>
<tbody>
<tr>
<td>300100035820958</td>
<td>CustomOrder1</td>
</tr>
<tr>
<td>300100035820960</td>
<td>CustomOrder2</td>
</tr>
</tbody>
</table>

Note that you can delete a record using the Public Unique Identifier (PUID) key also.

2. Click **Tools > Import Management**.

3. On the **Manage Imports** page, click the **Create Import Activity** button to start creating an import activity.

4. On the **Create Import Activity** page, enter the import activity name and select the custom object from the **Object** drop-down list. Browse the CSV file that you created in step 1. In the **Advanced Options** section, select the Import Mode as 'Delete records'. Click **Next**.

5. On the **Map Fields** page, map the attributes as shown in the following table.

<table>
<thead>
<tr>
<th>Column Header</th>
<th>Example Value</th>
<th>Attribute Display Name</th>
</tr>
</thead>
<tbody>
<tr>
<td>ID</td>
<td>300100035820958</td>
<td>Record ID</td>
</tr>
<tr>
<td>RecordName</td>
<td>CustomOrder1</td>
<td>CustomOrder Name</td>
</tr>
</tbody>
</table>

6. Review and submit the import activity.
8 Import Your Data

Import Account Data

Import Your Account Data

You can use Import Management to create, update, or delete your account data.

You can import account records using these steps:

1. Map your source account data to Oracle Applications Cloud object attributes. This way the import process would know where to insert each of the information bits.
2. Create the source CSV file with the account data you want to import.
4. Check the import results to know if the import went well.

How You Map Your Source Data to Target Object Attributes

You import account data into Oracle Applications Cloud from a CSV file containing your source data that's mapped to target Oracle Applications Cloud object attributes.

You need to do the following before creating the .csv file for data import:

- Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
- Ensure prerequisite steps are complete, such as understanding what attributes are required for importing your objects.
- Understand your options for uniquely identifying the records.
- Ensure parent records exist before importing child records.
- Identify the target object attributes that are required in the .csv file for a successful import.

Note: You can enable automatic territory-based assignment after sales accounts are imported. You can enable this feature by turning the profile option ZCA_BATCH_ASSIGN_ON_BULK_IMPORT ON. If the profile option is disabled, then you must manually run a batch assignment or assign each sales account individually.

To better manage your account information, the account object has the following child objects:

- Address
- Classification
- Relationship
- Sales Team Member

Note: You can’t set an attribute value to NULL in high-volume import (import management with the option Enable High-Volume Import selected). However, when updating a record, you can change an attribute value from NOT NULL to NULL.
If you're importing account records with attributes specific to the parent account object or along with single child record details (like phone, email, address, and so on), then you can include the child record details in the same .csv file for account object. However, if you're importing multiple records of any child object, then you must create multiple .csv files to import - one for each child which has multiple records that you're importing. For example, if you're importing 5 emails, 5 phones, and 5 addresses for an account, then you must create three import files - one for Account object, one for Contact Point object (phone and email), and one for Address object. There are separate help topics describing how to import each of these child objects. For more information, see the related topics section.

**Note:** High-volume import for accounts now supports hierarchy management and generation.

**Before You Start**

You must do some basic checks before starting your import. For example, make sure that:

- You have completed all the prerequisites for importing each attribute in your source data. For example, when using source system reference information to identify your account records, the source system of the account object should be enabled for parties using the Manage Trading Community Source Systems task.
- You have all parent records in place before importing child records. For example, when importing the address of an account, ensure the account exists.

**Select a Unique Identifier for Your Records**

All records must be unique in the application. You can use one of these to identify records:

- Public unique identifiers: If you're creating records, then you can provide an easily understandable public unique identifier. These are, usually, denoted with 'Number' and visible in the business object's UI. PUID attributes are usually named <object> Number. If you're updating a record with a Number attribute, then use the Number attribute to identify the record. For account object, the attribute is PartyNumber and shows up in the UI as Party Number. For more information about public unique identifiers, see the topic "How You Use Alternate Keys to Import Records" in Related Topics section.
- Source system and source system reference: Source system is an identifier for the external system, and source system reference is a unique identifier within the external system. If you're importing new accounts or are updating accounts that have source system reference data, then provide the source system and source system reference values. For account object, these are SourceSystem and SourceSystemReferenceValue and show up as Party Source System and Party Source System Reference Value in the UI.

**Review Required Attributes and Validations for Account Object**

To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Make sure that you provide valid values for these attributes so that they pass import validations inbuilt into the application.

This table lists the required attributes for account records, prerequisite setup tasks and specific validations, if any:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Tasks or Import Validations</th>
<th>Creating an Account Record</th>
<th>Updating an Existing Account Record</th>
<th>Deleting an Existing Account Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>SourceSystem</td>
<td>The source system for the sales account.</td>
<td>Know the source system.</td>
<td>Conditionally Required</td>
<td>Conditionally Required</td>
<td>Conditionally Required</td>
</tr>
</tbody>
</table>
### Attribute Table

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Tasks or Import Validations</th>
<th>Creating an Account Record</th>
<th>Updating an Existing Account Record</th>
<th>Deleting an Existing Account Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>SourceSystemReferenceValue</td>
<td>The reference number or text representing the source system unique ID for the party (account or contact) to which the sales profile belongs.</td>
<td>To view source systems, use the Manage Trading Community Source System task.</td>
<td>To identify an account record, use one of these:</td>
<td>To identify an account record, use one of these:</td>
<td>To identify an account record, use one of these:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• SourceSystem and SourceSystemReferenceValue</td>
<td>• SourceSystem and SourceSystemReferenceValue</td>
<td>• SourceSystem and SourceSystemReferenceValue</td>
<td>• SourceSystem and SourceSystemReferenceValue</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• PartyNumber</td>
<td>• PartyNumber</td>
<td>• PartyNumber</td>
<td>• PartyNumber</td>
</tr>
<tr>
<td>PartyNumber</td>
<td>The public unique identifier of the party.</td>
<td>Know the source system reference value.</td>
<td>Conditionally Required</td>
<td>Conditionally Required</td>
<td>Conditionally Required</td>
</tr>
<tr>
<td></td>
<td></td>
<td>To view the source systems reference, use the Manage Trading Community Source System task.</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>OrganizationName</td>
<td>The name of the party of the Organization party type.</td>
<td>Organization names are listed in the Resource Directory.</td>
<td>Required</td>
<td>Conditionally Required</td>
<td>Conditionally Required</td>
</tr>
<tr>
<td>OwnerPartyId</td>
<td>The identifier of the account owner.</td>
<td>This attribute is required only in import management, but optional in high-volume import.</td>
<td>Required</td>
<td>Not Required</td>
<td>Not Required</td>
</tr>
</tbody>
</table>

**Note:** Provide a valid value for the **DataFox Company ID** import attribute to integrate DataFox with CX Sales and B2B Service.

**Note:** When deleting or updating accounts, you must ensure that the account related to the party number provided has the Sales Account usage. If you provide the party number of an account that doesn't have the Sales Account usage, then the relationships for that account are also deleted. For example, if you provide the party number ORA17292 that doesn't have a Sales Account usage, then the related partners, contacts, and so on are also deleted.

For the extension child objects of account, RecordName field isn't unique. Hence you can't update the records only by passing RecordName.
You can use the profile option ORA_HZ_IMPORT_MULTI_ADDRESS_TYPE to control how address types are entered. By default this profile option is set to Yes, so you can enter multiple address types, during high-volume import of Account, Contact, and Household objects. You can disable this profile option to improve the import performance. When you set this profile option to No, you can enter only a single address type.

**Note:** When importing accounts or legal entities, you can retrieve duplicates using the Customer Data Management Duplicates LOV only if you have licensed the data quality functionality. Once licensed, you must rebuild the keys for your matching configuration using the Manage Enterprise Data Quality Matching Configurations task. After the keys are rebuilt, the matching functionality uses the settings in the match configuration to identify duplicates.

Go to **Navigator > Tools > Import Management > Import Objects** to see all the attributes of the account object. The page also lists attribute information like type, length, description, and so on.

**Create the Source CSV File**

You include the data that you want to import into CX Sales and B2B Service in a source CSV file. You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to **Navigator > Tools > Import Management > Import Objects**.
2. Select the **Account** object in the table and click **Download**.

You can now edit the downloaded file and provide valid values for the required attributes.

Providing the ZIP and Country Code values in the import CSV file won’t automatically populate the State/County/City fields. Values for these fields should be separately provided in the import file.

**Note:** For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.

**Create the Import Activity**

After you have the CSV file ready, create an import activity to import the account information. To create an import activity:

1. Go to **Navigator > Tools > Import Management > Import Queue**.
2. Click **Create Import Activity** in the **Manage Imports** page.
3. In the **Enter Import Options** page, provide a name for the import activity, and select Account from the **Object** drop-down list.
4. Select the CSV file in the **File Name** field, and click **Next**.
5. You would see that the source and target attributes are automatically mapped in the **Map Fields** page. Review and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking **Validate Data**. Click **Next**.
7. Review the import details on the **Review and Submit** page, and click **Submit** when you’re ready.

**Review the Import Results**

Check if your import succeeded on the **Manage Imports** page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to **Navigator > Tools > Import Management > Import Queue**.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed. You can drill down on the import activity to go to the Import Status page which provides the status details of the import activity.

**Note:** After importing your data successfully, you need to run a couple of post processing jobs for duplicate identification, duplicate resolution, and account assignment. For more information on import management post processing jobs, see the topic: Import Management Post Processing for Accounts and Contacts.

When importing accounts using high-volume import, you can now load the account hierarchy data. Use the following attributes to import accounts using high-volume import:

- ParentAccountPartyId
- ParentAccountPartyNumber
- ParentAccountSourceSystem
- ParentAccountSourceSystemReferenceValue

**Note:** This is available only for low volume data and should not be used for high volume data.

You can load account hierarchy data. To load the account hierarchy data:

1. Load the account data without providing values for the parent attributes mentioned above.
2. Load the account hierarchy using the Hierarchy and Hierarchy Member import objects.

**Related Topics**
- Import Data
- How You Use Alternate Keys to Import Records
- Potential Issues When Opening CSV Files in Excel
- How You Enable Automatic Account Assignment

**Example of Adding or Updating Primary Contact**

You can add or update the primary contact of an account using import management. Before adding or updating the primary account, ensure that the contact exists.

**Select a Unique Identifier for Your Records**

All records must be unique in the application. You can add or update a primary contact by submitting any one or more of the unique identifiers.

List of Account Identifiers:

- PartyId
- PartyNumber
- SourceSystem and SourceSystemReferenceValue
List of Contact Identifiers:

- PrimaryContactPartyId
- PrimaryContactPartyNumber
- PrimaryContactSourceSystem and PrimaryContactSourceSystemReferenceValue

To add or update the primary contact of an account, you must create a source file (CSV) and import it using import management. Below table lists the attributes using Party ID and Primary Contact Party ID as identifier:

<table>
<thead>
<tr>
<th>Attribute Name</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>PartyId</td>
<td>300100545540269</td>
</tr>
<tr>
<td>PrimaryContactPartyId</td>
<td>300100545059765</td>
</tr>
</tbody>
</table>

Create the Import Activity

After you have the CSV file ready, create an import activity to import the account information. To create an import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Account from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results

Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed. You can drill down on the import activity to go to the Import Status page which provides the status details of the import activity.

Related Topics

- Import Data
- How You Use Alternate Keys to Import Records
- Potential Issues When Opening CSV Files in Excel
- How You Enable Automatic Account Assignment
Example of Changing or Assigning Owner of an Account

You can change or assign the owner of an account using import management. Before changing or assigning the owner, ensure that the account exists and the owner is an active or valid resource.

Select a Unique Identifier for Your Records

All records must be unique in the application. You can change or assign the owner of an account by submitting any one or more of the unique identifiers.

List of Account Identifiers:

- PartyId
- PartyNumber
- SourceSystem and SourceSystemReferenceValue

List of Owner Identifiers:

- OwnerPartyId
- OwnerPartyNumber
- OwnerSourceSystem and OwnerSourceSystemReferenceValue

To change owner of an account, you must create a source file (CSV) and import it using import management. Below table lists the attributes using Party ID and Owner Party ID as identifier:

<table>
<thead>
<tr>
<th>Attribute Name</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>PartyId</td>
<td>300100545540596</td>
</tr>
<tr>
<td>OwnerPartyId</td>
<td>300100545540269</td>
</tr>
</tbody>
</table>

Create the Import Activity

After you have the CSV file ready, create an import activity to import the account information. To create an import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Contact from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.
Review the Import Results

Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed. You can drill down on the import activity to go to the Import Status page which provides the status details of the import activity.

Related Topics
- Import Data
- How You Use Alternate Keys to Import Records
- Potential Issues When Opening CSV Files in Excel
- How You Enable Automatic Account Assignment

Import Your Account Contact Data

You can use Import Management to create, update, or delete Account Contact records as child under Account object. This automatically also creates relationship record, associating referenced contact and account which can be viewed under relationship child object.

To import Account Contact records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes

To import your Account Contact data into Oracle Applications Cloud, you need to populate a CSV file with your source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

- Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
- Ensure prerequisite setups are done, if applicable.
- Understand your options for uniquely identifying the records.
- Ensure parent records exist before importing child records.
- Identify the target object attributes that are required in the CSV file for a successful import.
Before You Start

You must do some basic checks before starting your import. For example, make sure that:

- You have completed all the prerequisites for importing each attribute in your source data.
- You have all parent or referenced records in place before importing child records.

Select a Unique Identifier for Your Records

All records must be unique in the application. You can import account contact object by submitting any one or more of the conditionally required attributes. You can provide a combination of Account and Contact identifiers for create and update. Alternatively for Update scenario, you can provide the primary unique identifier or one of the relationship identifiers.

List of Contact Identifiers:

- ContactPartyId
- ContactPartyNumber
- ContactSourceSystem and ContactSourceSystemReferenceValue

List of Account Identifiers:

- AccountPartyId
- AccountPartyNumber
- AccountSourceSystem and AccountSourceSystemReferenceValue

List of Relationship Identifier:

- RelationshipRecId
- RelationshipSourceSystem and RelationshipSourceSystemReferenceValue

Primary unique identifier: AccountContactId is the primary unique identifier which is auto generated. You can use this identifier to update account contact record.

Required Attributes and Validations for Account Contact Object

To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure that you provide valid values for the attributes. This table lists the required attributes for importing new Account Contact records, required attributes for updating Account Contact records, prerequisite setup tasks for the attributes, and specific validations, if any, for Account Contact import:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/Import Validations</th>
<th>Creating an Account Contact Record</th>
<th>Updating an Existing Account Contact Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>AccountContactId</td>
<td>The unique identifier of the account contact which is system generated.</td>
<td>Should be a valid value which exists in the application</td>
<td>Not Applicable</td>
<td>Conditionally Required</td>
</tr>
<tr>
<td>Attribute</td>
<td>Description</td>
<td>Prerequisite Setup Task/Import Validations</td>
<td>Creating an Account Contact Record</td>
<td>Updating an Existing Account Contact Record</td>
</tr>
<tr>
<td>--------------------</td>
<td>------------------------------------------------------------------------------</td>
<td>-------------------------------------------</td>
<td>-----------------------------------</td>
<td>-----------------------------------------------</td>
</tr>
<tr>
<td>RelationshipRecId</td>
<td>Alternate unique identifier for the account contact which is system generated.</td>
<td>Should be a valid value which exists in the application</td>
<td>Not Applicable</td>
<td>Conditionally required</td>
</tr>
<tr>
<td>ContactPartyId</td>
<td>The primary key identifier of the subject in this relationship. Either one of ContactPartyId, ContactPartyNumber, or a combination of ContactSourceSystem and ContactSourceSystemRefere is used to identify the subject party of the relationship.</td>
<td>The contact must exist</td>
<td>Conditionally Required Provide a value along with Account identifier to uniquely identify referenced account and contact records to create account contact record</td>
<td>Conditionally Required Provide a value along with Account identifier to uniquely identify account contact record for update</td>
</tr>
<tr>
<td>ContactPartyNumber</td>
<td>The public key identifier for the Contact party of the relationship. Either one of ContactPartyId, ContactPartyNumber, or a combination of ContactSourceSystem and ContactSourceSystemRefere is used to identify the Contact party of the relationship.</td>
<td>The contact must exist</td>
<td>Conditionally Required Provide a value along with Account identifier to uniquely identify referenced account and contact records to create account contact record</td>
<td>Conditionally Required Provide a value along with Account identifier to uniquely identify account contact record for update</td>
</tr>
<tr>
<td>ContactSourceSystem</td>
<td>The name of external source system for the subject party in the relationship, which are defined by an administrator as part of system setup. To be used in combination of ContactSourceSystemRefere</td>
<td>The value for this attribute should be predefined using the setup task Manage Trading Community Source Systems</td>
<td>Conditionally Required Provide a value along with ContactSourceSystemReferenceValue for uniquely identifying a contact record Additionally, provide an Account Identifier</td>
<td>Conditionally Required Provide a value along with ContactSourceSystemReferenceValue for uniquely identifying a contact record Additionally, provide an Account Identifier</td>
</tr>
<tr>
<td>ContactSourceSystemReferenceValue</td>
<td>The identifier for the subject party in the relationship from external source system. To be used in combination with ContactSourceSystem.</td>
<td>The System Source Reference value should exists for the Contact</td>
<td>Conditionally Required Provide a value along with ContactSourceSystem for uniquely identifying a contact record Additionally, provide an account identifier</td>
<td>Conditionally Required Provide a value along with ContactSourceSystem for uniquely identifying a contact record Additionally, provide an account identifier</td>
</tr>
<tr>
<td>AccountPartyId</td>
<td>The primary key identifier of the object in this relationship. Either one of AccountPartyId, AccountPartyNumber, or combination of AccountSourceSystem and AccountSourceSystemRefere is used to identify the</td>
<td>The System Source Reference value should exists for the Contact</td>
<td>Conditionally Required Provide a value along with Contact identifier to uniquely identify referenced account and contact records to create account contact record</td>
<td>Conditionally Required Provide a value along with Contact identifier to uniquely identify account contact record for update</td>
</tr>
<tr>
<td>Attribute</td>
<td>Description</td>
<td>Prerequisite Setup Task/Import Validations</td>
<td>Creating an Account Contact Record</td>
<td>Updating an Existing Account Contact Record</td>
</tr>
<tr>
<td>-------------------------------</td>
<td>-----------------------------------------------------------------------------</td>
<td>-----------------------------------------------------------------------------------------------------------</td>
<td>----------------------------------------------------------------------------------------------------</td>
<td>----------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>AccountPartyNumber</td>
<td>The public unique identification number for the object party of the relationship Either one of AccountPartyId, AccountPartyNumber or combination of AccountSourceSystem and AccountSourceSystemReferenceValue is used to identify the Account party of the relationship.</td>
<td>No Validation</td>
<td>Conditionally Required Provide a value along with Contact identifier to uniquely identify referenced account and contact records to create account contact record</td>
<td>Conditionally Required Provide a value along with Contact identifier to uniquely identify account contact record for update</td>
</tr>
<tr>
<td>AccountSourceSystem</td>
<td>The name of external source system for the subject party in the relationship, which are defined by an administrator as part of system setup. To be used in combination with AccountSourceSystemReferenceValue.</td>
<td>The value for this attribute should be predefined using the setup task Manage Trading Community Source Systems</td>
<td>Conditionally Required Provide a value along with AccountSourceSystem for uniquely identifying an account record Additionally, provide a contact identifier</td>
<td>Conditionally Required Provide a value along with AccountSourceSystemReferenceValue for uniquely identifying an account record Additionally, provide a contact identifier</td>
</tr>
<tr>
<td>AccountSourceSystemReferenceValue</td>
<td>The name of external source system for the subject party in the relationship, which are defined by an administrator as part of system setup. To be used in combination with AccountSourceSystem.</td>
<td></td>
<td>Conditionally Required Provide a value along with AccountSourceSystem for uniquely identifying an account record Additionally, provide a contact identifier</td>
<td></td>
</tr>
<tr>
<td>RelationshipSourceSystem</td>
<td>The name of external source system for the relationship record, which are defined by an administrator as part of system setup. To be used in combination with RelationshipSourceSystemReferenceValue.</td>
<td>The value for this attribute should be predefined using the setup task Manage Trading Community Source Systems</td>
<td>Optionally Required</td>
<td></td>
</tr>
<tr>
<td>RelationshipSourceSystemReferenceValue</td>
<td>The name of external source system for the relationship record, which are defined by an administrator as part of system setup. To be used in combination with RelationshipSourceSystem.</td>
<td>The Source System Reference value should exist for the Contact</td>
<td>Optionally Required</td>
<td></td>
</tr>
</tbody>
</table>


You can view the Account Contact object and its attributes in the Manage Import Objects page of the Import Management flow. You can find attribute information like type, length, description, and so on, on this page.

Create the Source CSV File
You include the data that you want to import into CX Sales and B2B Service in a source CSV file. You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator > Tools > Import Management > Import Objects.
2. Select the Account Contact object in the table and click Download.
You can now edit the downloaded file and provide valid values for the required attributes.

Note: For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Account Contact from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed. You can drill down on the import activity to go to the Import Status page which provides the status details of the import activity.

Related Topics
- Import Data
- Potential Issues When Opening CSV Files in Excel
- How You Use Alternate Keys to Import Records
Import Your Action Data

You can use the import functionality to create, update, or delete your action data.

You can import action records using these steps:

1. Map your source data to Oracle Applications Cloud object attributes. This way the import process would know where to insert each of the information bits.
2. Create the source CSV file with the action data you want to import.
4. Check the import results to know if the import went well.

How You Map Your Source Data to Target Object Attributes

You import action data into Oracle Applications Cloud from a CSV file containing your source data that’s mapped to target Oracle Applications Cloud object attributes.

Before you create the source data file, you should:

- Know how your source data attributes map to the target object attributes in Oracle Applications Cloud. Match each column from the source file to an attribute in the action import object.
- Finish all prerequisite steps, such as understanding what attributes are required for importing your objects.
- Know how you can uniquely identify the records.
- Check the target object attributes required in the CSV file for a successful import.

To better manage your action information, the action object has the following child objects:

- Action Attribute
- Action Condition

If you want to import only a few records, then you can create a single CSV file for all action attributes. However if you want to import a large number of records, then you may decide to create multiple CSV files, one for each of the action child objects. Note that you must have imported the CSV file for action object successfully before trying to import the CSV files for the child objects. There are separate help topics describing how to import each of these child objects. For more information, see the related topics section.

Before You Start

You must do some basic checks before starting your import. For example, make sure that:

- You have completed all the prerequisites for importing each attribute in your source data.
- You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records

All records must be unique in the application. You can use one of these to identify records:

- Public unique identifiers: If you’re creating records, then you can provide an easily understandable public unique identifier. These are, usually, denoted with ‘Number’ and visible in the business object's UI. PUID
attributes are usually named `<object>` Number. If you’re updating a record with a Number attribute, then use the Number attribute to identify the record. For more information about public unique identifiers, see the topic "How You Use Alternate Keys to Import Records" in Related Topics section.

- Source system and source system reference: Source system is an identifier for the external system, and source system reference is a unique identifier within the external system. If you’re importing new actions or are updating actions that have source system reference data, then provide the source system and source system reference values.

### Required Attributes and Validations for Action Object

To import data successfully into Oracle Applications Cloud, your .csv file must include the required attributes. Make sure that you provide valid values for these attributes so that they pass import validations inbuilt into the application.

This table lists the required attributes for action records, prerequisite setup tasks and specific validations, if any:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/Import Validations</th>
<th>Creating an Action record</th>
<th>Updating an Existing Action record</th>
</tr>
</thead>
<tbody>
<tr>
<td>Action</td>
<td>The name of the action that's associated with an action plan template or action plan instance.</td>
<td>None</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td>Action Id</td>
<td>The unique Id of the existing Action record in the Oracle Fusion destination table.</td>
<td>Identify the Action ID value by exporting the Action object. To export, navigate to Tools &gt; Export Management &gt; Create Export Activity.</td>
<td>Required</td>
<td>A value is required if you're updating an existing Action and you're not providing the Action Number. The Action ID is autogenerate in Oracle Fusion applications, if you don't specify a value.</td>
</tr>
<tr>
<td>ActionNumber</td>
<td>The unique ID for the existing Action record in the Oracle Fusion destination table.</td>
<td>None</td>
<td>Optional</td>
<td>A value is required if you're updating an existing Action and you're not providing the Action Id.</td>
</tr>
<tr>
<td>Parent Entity Name</td>
<td>The entity name of the object for which the action can be used in an action plan.</td>
<td>None</td>
<td>Conditionally required</td>
<td>Conditionally required</td>
</tr>
<tr>
<td>Duration</td>
<td>The estimated time to complete the action.</td>
<td>None</td>
<td>Required</td>
<td>Required</td>
</tr>
<tr>
<td>Duration Unit</td>
<td>The unit of measurement for lead time.</td>
<td>None</td>
<td>Required</td>
<td>Required</td>
</tr>
</tbody>
</table>

---

Oracle CX
Understanding Import and Export Management for CX
Sales and B2B Service

Chapter 8
Import Your Data
### Attribute | Description | Prerequisite Setup Task/Import Validations | Creating an Action record | Updating an Existing Action record
--- | --- | --- | --- | ---
Object Entity Name | Entity name of the object on which the action is based. | None | Conditionally required | Conditionally required

- Creating an Action record:
  - A value is required only when you're inserting an object entity name.
  - However, a value isn't required when you delete or update an existing object entity name.

- Updating an Existing Action record:
  - A value is required only when you're inserting an object entity name.
  - However, a value isn't required when you delete or update an existing object entity name.

Original System Reference | Specifies the original system reference if this record was imported. | Identify the original system and system reference values from your source system that were imported when you imported the resource. | Optional | Optional

Object Entity Type | The entity type of the object on which the action is based. | The valid values are ServiceRequest, Task, and Appointment. | Required | Not required

- A value is required only when you're inserting an object entity type. However, a value isn't required when you delete or update an existing object entity type.

Visibility | Indicates the visibility level of the action. | If you intend to specify a value, select a value from the list of valid values in the lookup type ORA_SVC_AP_VISIBILITY_CD. | Required | Not required

Go to Navigator > Tools > Import Management > Import Objects, to see all the attributes of the action object. The page also lists attribute information like type, length, description, and so on.

### Create the Source CSV File
You include the data that you want to import into CX Sales and B2B Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator > Tools > Import Management > Import Objects.
2. Select the Action object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

**Note:** For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.
Create the Import Activity

After you have the CSV file ready, create an import activity to import the action information. To create an import activity:

1. Go to **Navigator > Tools > Import Management > Import Queue.**
2. On the **Manage Imports** page, click **Create Import Action.**
3. In the **Create Import Activity: Enter Import Options** page, provide a name for the import activity, and select **Action** from the **Object** drop-down list.
4. Select the CSV file in the **File Name** field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the **Map Fields** page. Review and edit the mappings if required.

   **Note:** Click **Validate Data** to validate the mapping of the source file for unmapped columns and to check for data format issues.

6. Check the file for unmapped columns or data format issues by clicking **Validate Data.** Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you’re ready.

Review the Import Results

Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to **Navigator > Tools > Import Management > Import Queue.**
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed. You can drill down on the import activity to go to the Import Status page which provides the status details of the import activity.

**Related Topics**

- **How You Use Alternate Keys to Import Records**
- **Potential Issues When Opening CSV Files in Excel**

Import Your Action Attribute Data

You can use the import functionality to create, update, or delete action attribute data.

You can import action attribute records using these steps:

1. Map your source data to Oracle Applications Cloud object attributes. This way the import process would know where to insert each of the information bits.
2. Create the source CSV file with the action condition data you want to import.
4. Check the import results to know if the import went well.
How You Map Your Source Data to Target Object Attributes

You import action attribute data into Oracle Applications Cloud from a CSV file containing your source data that's mapped to target Oracle Applications Cloud object attributes.

Before you create the source data file, you should:

- Know how your source data attributes map to the target object attributes in Oracle Applications Cloud. Match each column from the source file to an attribute in the action import object.
- Finish all prerequisite steps, such as understanding what attributes are required for importing your objects.
- Know how you can uniquely identify the records.
- Check the target object attributes required in the CSV file for a successful import.

If you want to import only a few records, then you can create a single CSV file for all action conditions. However if you want to import a large number of records, then you may decide to create multiple CSV files, one for each of the action child objects. Note that you must have imported the CSV file for action object successfully before trying to import the CSV files for the child objects. There are separate help topics describing how to import each of these child objects. For more information, see the related topics section.

Before You Start

You must do some basic checks before starting your import. For example, make sure that:

- You have completed all the prerequisites for importing each attribute in your source data.
- You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records

All records must be unique in the application. You can use one of these to identify records:

- Public unique identifiers: If you're creating records, then you can provide an easily understandable public unique identifier. These are, usually, denoted with 'Number' and visible in the business object's UI. PUID attributes are usually named <object> Number. If you're updating a record with a Number attribute, then use the Number attribute to identify the record. For more information about public unique identifiers, see the topic "How You Use Alternate Keys to Import Records" in Related Topics section.

- Source system and source system reference: Source system is an identifier for the external system, and source system reference is a unique identifier within the external system. If you're importing new actions or are updating actions that have source system reference data, then provide the source system and source system reference values.

Required Attributes and Validations for Action Attribute Object

To import data successfully into Oracle Applications Cloud, your .csv file must include the required attributes. Ensure that you provide valid values for the attributes.

This table lists the required attributes for action attribute records, prerequisite setup tasks and specific validations, if any:
<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/Import Validations</th>
<th>Creating an Action Attribute record</th>
<th>Updating an Existing Action Attribute record</th>
</tr>
</thead>
<tbody>
<tr>
<td>Action Attribute Id</td>
<td>The unique Id of the existing Action Attribute record in the Oracle Fusion destination table.</td>
<td>Identify the Action Attribute ID value by exporting the Action object by navigating to <strong>Tools &gt; Export Management &gt; Create Export Activity</strong>.</td>
<td>Not required</td>
<td>A value is required if you're updating an existing Action attribute and you're not providing the Action source system (original system)</td>
</tr>
<tr>
<td>Action Code</td>
<td>Indicates the operation to be performed on a row, such as insert, update, and so on</td>
<td>If a value isn't provided, records are matched to determine if a record is updated (if it already exists) or inserted (if it doesn't exist).</td>
<td>Not required</td>
<td>A value is required, if you're deleting an action attribute.</td>
</tr>
<tr>
<td>ActionId</td>
<td>Specifies the foreign key that references the Action ID to which the action is assigned.</td>
<td>Identify the Action ID value by exporting the Action object by navigating to <strong>Tools &gt; Export Management &gt; Create Export Activity</strong>.</td>
<td>Not required</td>
<td>A value is required, if you're updating an existing Action Id and you're not providing the Action Id source system code and reference Action OSR.</td>
</tr>
<tr>
<td>ActionOSR</td>
<td>Specifies the action original system reference, if the record was imported.</td>
<td>Identify the original system and system reference values from your source system which were imported when you imported the resource.</td>
<td>Required</td>
<td>A value is required if you're updating an existing Action Id record and you're not providing the record's unique ID (<strong>ActionId</strong>)</td>
</tr>
<tr>
<td>AttributeName</td>
<td>Attribute from the entity object of the associated action.</td>
<td>None</td>
<td>Not Required</td>
<td>Not Required</td>
</tr>
<tr>
<td>AttributeValue</td>
<td>The value to be set on the Action attribute.</td>
<td>None</td>
<td>Not Required</td>
<td>Not Required</td>
</tr>
<tr>
<td>AttributeValueContextCd</td>
<td>The context of how the attribute value should be interpreted (for example, as an attribute of the parent action’s object, an attribute of the parent action, or a custom value).</td>
<td>The valid values provided by the lookup type <strong>ORA_SVC_AP_CONTEXT_CD</strong>.</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td>Deleted</td>
<td>Indicates whether the service request is to be deleted. If the value is Y, then the service request is deleted. The default value is N.</td>
<td>None</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>ErrorMessage</td>
<td>This column displays the error messages, if any.</td>
<td>None</td>
<td>Not required</td>
<td>Not required</td>
</tr>
</tbody>
</table>
You can view the Action Attribute object along with all its child objects and attributes in the Manage Import Objects page of the Import Management flow. You can find attribute information like type, length, description, and so on, on this page.

Create the Source CSV File
You include the data that you want to import into CX Sales and B2B Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator > Tools > Import Management > Import Objects.
2. Select the Action Attribute object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note: For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the action attribute information. To create an import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Create Import Activity: Enter Import Options page, provide a name for the import activity, and select Action Attribute from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

**Review the Import Results**

Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to **Navigator > Tools > Import Management > Import Queue**.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed. You can drill down on the import activity to go to the Import Status page which provides the status details of the import activity.

**Related Topics**
- Import Your Action Data
- How You Use Alternate Keys to Import Records
- Potential Issues When Opening CSV Files in Excel

**Import Your Action Condition Data**

You can use the import functionality to create, update, or delete your action condition data.

You can import action condition records using these steps:

1. Map your source data to Oracle Applications Cloud object attributes. This way the import process would know where to insert each of the information bits.
2. Create the source CSV file with the action condition data you want to import.
4. Check the import results to know if the import went well.

**How You Map Your Source Data to Target Object Attributes**

You import action condition data into Oracle Applications Cloud from a CSV file containing your source data that's mapped to target Oracle Applications Cloud object attributes.

Before you create the source data file, you should:

- Know how your source data attributes map to the target object attributes in Oracle Applications Cloud. Match each column from the source file to an attribute in the action import object.
- Finish all prerequisite steps, such as understanding what attributes are required for importing your objects.
- Know how you can uniquely identify the records.
- Check the target object attributes required in the CSV file for a successful import.

If you want to import only a few records, then you can create a single CSV file for all action conditions. However if you want to import a large number of records, then you may decide to create multiple CSV files, one for each of the action child objects. Note that you must have imported the CSV file for action object successfully before trying to import the CSV files for the child objects. There are separate help topics describing how to import each of these child objects. For more information, see the related topics section.
Before You Start
You must do some basic checks before starting your import. For example, make sure that:

- You have completed all the prerequisites for importing each attribute in your source data.
- You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
All records must be unique in the application. You can use one of these to identify records:

The preferred option to uniquely identify an object record is through the Internal ID.

If you’re identifying a record that already exists in Oracle Applications Cloud, then you can use the internal ID of the record, a system-generated unique identifier attributes with "id" in the attribute name are typically internal IDs. You can determine the internal ID of a record by exporting Oracle Applications Cloud object data, or by doing a transactional database query. Using an internal ID typically provides better performance and reduces the import duration. For the Action Condition Object, the attributes are Action ConditionId and ActionId:

Required Attributes and Validations for Action Condition Object
To import data successfully into Oracle Applications Cloud, your .csv file must include the required attributes. Ensure that you provide valid values for the attributes.

This table lists the required attributes for action condition records, prerequisite setup tasks and specific validations, if any:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/ Import Validations</th>
<th>Creating an Action Condition record</th>
<th>Updating an Existing Action Condition record</th>
</tr>
</thead>
<tbody>
<tr>
<td>ActionCode</td>
<td>Indicates the operation to be performed on a row, such as insert, update, and so on</td>
<td>If a value isn’t provided, records are matched to determine if a record is updated (if it already exists) or inserted (if it doesn’t exist).</td>
<td>Not required</td>
<td>A value is required, if you’re deleting an action condition.</td>
</tr>
<tr>
<td>Action ConditionId</td>
<td>The unique Id of the existing Action Condition record in the Oracle Fusion destination table.</td>
<td>Identify the Action Condition ID value by exporting the Action object. To export, navigate to <strong>Tools &gt; Export Management &gt; Create Export Activity</strong>.</td>
<td>Not required</td>
<td>A value is required if you’re updating an existing Action Condition attribute and you’re not providing the Action source system (original system)</td>
</tr>
<tr>
<td>Action Id</td>
<td>Specifies the foreign key that references the Action ID to which the action is assigned.</td>
<td>Identify the Action ID value by exporting the Action object. To export, navigate to <strong>Tools &gt; Export Management &gt; Create Export Activity</strong>.</td>
<td>Not required</td>
<td>A value is required, if you’re updating an existing Action Id and you’re not providing the Action Id source system code and reference Action OSR.</td>
</tr>
</tbody>
</table>
Create the Source CSV File
You include the data that you want to import into CX Sales and B2B Service in a source CSV file. You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator > Tools > Import Management > Import Objects.
2. Select the Action Condition object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note: For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the action condition information. To create an import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Create Import Activity: Enter Import Options page, provide a name for the import activity, and select Action Condition from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you’re ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed. You can drill down on the import activity to go to the Import Status page which provides the status details of the import activity.

Related Topics

- Import Your Action Data
- How You Use Alternate Keys to Import Records
- Potential Issues When Opening CSV Files in Excel

Import Your Action Plan Data

You can use Import Management to create or update Action Plan records.

To import Action Plan records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes

To import your Action Plan data into Oracle Applications Cloud, you need to populate a CSV file with your source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

- Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
- Ensure prerequisite setups are done, if applicable.
- Understand your options for uniquely identifying the records.
- Ensure parent records exist before importing child records.
- Identify the target object attributes that are required in the CSV file for a successful import.

Before You Start

You must do some basic checks before starting your import. For example, make sure that:

- You have completed all the prerequisites for importing each attribute in your source data.
- You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records

All records must be unique in the application. You can use one of these to identify records:

- Public unique identifiers: If you’re creating records, then you can provide an easily understandable public unique identifier. These are, usually, denoted with 'Number' and visible in the business object's UI. PUID
attributes are usually named `<object> Number`. If you’re updating a record with a Number attribute, then use the Number attribute to identify the record. For more information about public unique identifiers, see the topic "How You Use Alternate Keys to Import Records" in Related Topics section.

- Source system and source system reference: Source system is an identifier for the external system, and source system reference is a unique identifier within the external system. If you’re importing new action plans or are updating action plans that have source system reference data, then provide the source system and source system reference values.

### Required Attributes and Validations for Action Plan Object

To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure that you provide valid values for the attributes. This table lists the required attributes for importing new Action Plan records, required attributes for updating Action Plan records, prerequisite setup tasks for the attributes, and specific validations, if any, for Action Plan import:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/ Import Validations</th>
<th>Creating a Action Plan Record</th>
<th>Updating an Existing Action Plan Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>ActionPlanId</td>
<td>The unique identifier of the action plan.</td>
<td>A valid primary key for the action plan record in the destination system is required. Either the ActionPlanNumber or the ActionPlanId is required. If both are present, then the ActionPlanId is preferred.</td>
<td>Not Required</td>
<td>Optional</td>
</tr>
<tr>
<td>CalendarId</td>
<td>The calendar identifier associated with the action plan.</td>
<td>A valid calendar record in the destination system.</td>
<td>Required</td>
<td>Not Required</td>
</tr>
<tr>
<td>ObjectEntityName</td>
<td>The parent entity object name of the action plan.</td>
<td>A valid value from the ORA_SVC_AP_OBJ_ENTITY_NAME lookup in the destination system.</td>
<td>Required</td>
<td>Not Required</td>
</tr>
<tr>
<td>ObjectId</td>
<td>The object identifier of the action plan.</td>
<td>A valid primary key for the parent record in the destination system.</td>
<td>Required</td>
<td>Not Required</td>
</tr>
<tr>
<td>StatusCd</td>
<td>The status of the action plan.</td>
<td>A valid value from the ORA_SVC_AP_PROCESS_CD lookup in the destination system.</td>
<td>Optional</td>
<td>Optional</td>
</tr>
<tr>
<td>TemplateNumber</td>
<td>The reference number of the action plan template.</td>
<td>A valid PUID for action plan template row in the destination system. It is optional if the action plan is created without an action plan template.</td>
<td>Optional</td>
<td>Not Required</td>
</tr>
</tbody>
</table>
You can view the Action Plan object along with all its child objects and attributes in the Manage Import Objects page of the Import Management flow. You can find attribute information like type, length, description, and so on, on this page.

Create the Source CSV File
You include the data that you want to import into CX Sales and B2B Service in a source CSV file.
You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator > Tools > Import Management > Import Objects.
2. Select the Action Plan object in the table and click Download.
You can now edit the downloaded file and provide valid values for the required attributes.

*Note:* For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the information. To create an import activity:

2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Action Plan from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
   You would see that the source and target attributes are automatically mapped in the Map Fields page. Review and edit the mappings if required.
5. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
6. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed. You can drill down on the import activity to go to the Import Status page which provides the status details of the import activity.
Import Your Data

Related Topics
- Potential Issues When Opening CSV Files in Excel
- How You Use Alternate Keys to Import Records
- Import Data

Import Your Action Plan Action Data

You can use Import Management to create or update Action Plan Action records.

To import Action Plan Action records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes

To import your Action Plan Action data into Oracle Applications Cloud, you need to populate a CSV file with your source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

- Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
- Ensure prerequisite setups are done, if applicable.
- Understand your options for uniquely identifying the records.
- Ensure parent records exist before importing child records.
- Identify the target object attributes that are required in the CSV file for a successful import.

Before You Start

You must do some basic checks before starting your import. For example, make sure that:

- You have completed all the prerequisites for importing each attribute in your source data.
- You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records

All records must be unique in the application. You can use one of these to identify records:

- Public unique identifiers: If you're creating records, then you can provide an easily understandable public unique identifier. These are, usually, denoted with 'Number' and visible in the business object's UI. PUID attributes are usually named `<object> Number`. If you're updating a record with a Number attribute, then use the Number attribute to identify the record. For more information about public unique identifiers, see the topic "How You Use Alternate Keys to Import Records" in Related Topics section.
• Source system and source system reference: Source system is an identifier for the external system, and source system reference is a unique identifier within the external system. If you’re importing new action plan actions or are updating action plan actions that have source system reference data, then provide the source system and source system reference values.

## Required Attributes and Validations for Action Plan Action Object

To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure that you provide valid values for the attributes. This table lists the required attributes for importing new Action Plan Action records, required attributes for updating Action Plan Action records, prerequisite setup tasks for the attributes, and specific validations, if any, for Action Plan Action import:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/ Import Validations</th>
<th>Creating a Action Plan Action Record</th>
<th>Updating an Existing Action Plan Action Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>SkipFlag</td>
<td>Contains the values, Y or N. If Y is used, then the action for the action plan is skipped. If N is used, then the action for the action plan isn't skipped.</td>
<td>The default value is ‘N’.</td>
<td>Optional</td>
<td>Optional</td>
</tr>
<tr>
<td>TemplateNumber</td>
<td>The reference number of the action plan template.</td>
<td>A valid PUID for action plan template row in the destination system. It is optional if the action plan is created without an action plan template.</td>
<td>Optional</td>
<td>Not Required</td>
</tr>
<tr>
<td>ActionId</td>
<td>The unique identifier of the action.</td>
<td>A valid action Id in the destination system.</td>
<td>Optional</td>
<td>Not Required</td>
</tr>
<tr>
<td>ActionNumber</td>
<td>The reference number of the action.</td>
<td>A valid PUID action value in the destination system. Either the ActionId or the ActionNumber is required. If both are present, then the ActionId is preferred.</td>
<td>Required</td>
<td>Not Required</td>
</tr>
<tr>
<td>ActionPlanActionId</td>
<td>The action identifier of the action plan.</td>
<td>A valid primary key for the action plan action record in the destination system is required. Either the ActionPlanActionId or the ActionPlanActionNumber is required. If both are present, then the ActionPlanActionId is preferred.</td>
<td>Not Required</td>
<td>Optional</td>
</tr>
<tr>
<td>DeletedFlag</td>
<td>Contains the values, Yes or No. If Yes is used, then the action in the action plan is deleted. If No is used, then the action in the action plan isn't deleted.</td>
<td>A valid value from the YES_NO lookup.</td>
<td>Optional</td>
<td>Optional</td>
</tr>
</tbody>
</table>
### Attribute Descriptions

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/ Import Validations</th>
<th>Creating a Action Plan Action Record</th>
<th>Updating an Existing Action Plan Action Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>MandatoryFlag</td>
<td>Contains the values, Yes or No. If Yes is used, then the action in the action plan is mandatory. If No is used, then the action in the action plan isn't mandatory.</td>
<td>A valid value from the YES_NO lookup.</td>
<td>Optional</td>
<td>Optional</td>
</tr>
<tr>
<td>ActionPlanNumber</td>
<td>The reference number of the action plan.</td>
<td>A valid PUID for the action plan row in the destination system.</td>
<td>Required</td>
<td>Not Required</td>
</tr>
<tr>
<td>ActionPlanId</td>
<td>The unique identifier of the action plan.</td>
<td>A valid primary key for the action plan record in the destination system is required. Either the ActionPlanNumber or the ActionPlanId is required. If both are present, then the ActionPlanId is preferred.</td>
<td>Optional</td>
<td>Not Required</td>
</tr>
<tr>
<td>ActionPlanActionNumber</td>
<td>The reference number of the action plan action object.</td>
<td>A valid action plan action PUID in the destination system.</td>
<td>Optional</td>
<td>Required</td>
</tr>
</tbody>
</table>

You can view the Action Plan Action object along with all its child objects and attributes in the Manage Import Objects page of the Import Management flow. You can find attribute information like type, length, description, and so on, on this page.

### Create the Source CSV File

You include the data that you want to import into CX Sales and B2B Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to **Navigator > Tools > Import Management > Import Objects**.
2. Select the **Action Plan Action** object in the table and click **Download**.

You can now edit the downloaded file and provide valid values for the required attributes.

**Note:** For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.
Create the Import Activity

After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to **Navigator > Tools > Import Management > Import Action Plan Action**.
2. Click **Create Import Activity** in the **Manage Imports** page.
3. In the **Enter Import Options** page, provide a name for the import activity, and select Action Plan Action from the Object drop-down list.
4. Select the CSV file in the **File Name** field, and click **Next**. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review and edit the mappings if required.
5. Check the file for unmapped columns or data format issues by clicking **Validate Data**. Click **Next**.
6. Review the import details on the **Review and Submit** page, and click **Submit** when you're ready.

Review the Import Results

Check if your import succeeded on the **Manage Imports** page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to **Navigator > Tools > Import Management > Import Action Plan Action**.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the **Status** column for the import activity. The import is successful if the status displays as **Completed**. You can drill down on the import activity to go to the **Import Status** page which provides the status details of the import activity.

Related Topics

- Potential Issues When Opening CSV Files in Excel
- How You Use Alternate Keys to Import Records
- Import Data

Import Your Action Plan Action Relation Data

You can use Import Management to create or update Action Plan Action Relation records.

To import Action Plan Action Relation records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes

To import your Action Plan Action Relation data into Oracle Applications Cloud, you need to populate a CSV file with your source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

- Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
Import Your Data

• Ensure prerequisite setups are done, if applicable.
• Understand your options for uniquely identifying the records.
• Ensure parent records exist before importing child records.
• Identify the target object attributes that are required in the CSV file for a successful import.

Before You Start

You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.
• You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records

All records must be unique in the application. You can use one of these to identify records:

• Public unique identifiers: If you’re creating records, then you can provide an easily understandable public unique identifier. These are, usually, denoted with ‘Number’ and visible in the business object’s UI. PUID attributes are usually named <object> Number. If you’re updating a record with a Number attribute, then use the Number attribute to identify the record. For more information about public unique identifiers, see the topic “How You Use Alternate Keys to Import Records” in Related Topics section.
• Source system and source system reference: Source system is an identifier for the external system, and source system reference is a unique identifier within the external system. If you’re importing new action plan action relations or are updating action plan action relations that have source system reference data, then provide the source system and source system reference values.

Required Attributes and Validations for Action Plan Action Relation Object

To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure that you provide valid values for the attributes. This table lists the required attributes for importing new Action Plan Action Relation records, required attributes for updating Action Plan Action Relation records, prerequisite setup tasks for the attributes, and specific validations, if any, for Action Plan Action Relation import:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/Import Validations</th>
<th>Creating a Action Plan Action Relation Record</th>
<th>Updating an Existing Action Plan Action Relation Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>DeletedFlag</td>
<td>Contains the values, Yes or No. If Yes is used, then the dependency record is deleted. If No is used, then the then the dependency record isn’t deleted.</td>
<td>A valid value from the YES_NO lookup.</td>
<td>Optional</td>
<td>Optional</td>
</tr>
<tr>
<td>RelationId</td>
<td>The relation identifier between actions in an action plan.</td>
<td>A valid primary key for the action plan action relation record in the destination system is required.</td>
<td>Not Required</td>
<td>Required</td>
</tr>
</tbody>
</table>
### Create the Source CSV File

You include the data that you want to import into CX Sales and B2B Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to **Navigator > Tools > Import Management > Import Objects**.
2. Select the **Action Plan Action Relation** object in the table and click **Download**.

You can now edit the downloaded file and provide valid values for the required attributes.
Create the Import Activity
After you have the CSV file ready, create an import activity to import the information. To create an import activity:

2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Action Plan Action Relation from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
   You would see that the source and target attributes are automatically mapped in the Map Fields page. Review and edit the mappings if required.
5. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
6. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed. You can drill down on the import activity to go to the Import Status page which provides the status details of the import activity.

Related Topics
- Potential Issues When Opening CSV Files in Excel
- How You Use Alternate Keys to Import Records

Import Your Activity Data
You can use Import Management to create, update, or delete your activity data.

You can import activity records using these steps:

1. Map your source activity data to Oracle Applications Cloud object attributes. This way the import process would know where to insert each of the information bits.
2. Create the source CSV file with the activity data you want to import.
4. Check the import results to know if the import went well.
How You Map Your Source Data to Target Object Attributes

You import activity data into Oracle Applications Cloud from a CSV file containing your source data that's mapped to target Oracle Applications Cloud object attributes.

You must do the following before creating the .csv file for data import:

- Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
- Ensure prerequisite steps are complete, such as understanding what attributes are required for importing your objects.
- Understand your options for uniquely identifying the records.
- Ensure parent records exist before importing child records.
- Identify the target object attributes that are required in the .csv file for a successful import.

To better manage your activity information, the activity object has the following child objects:

- Activity Assignee
- Activity Contact
- Activity Objectives

If you want to import only a few records, then you can create a single CSV file for all activity attributes. However if you want to import a large number of records, then you may decide to create multiple CSV files, one for each of the activity child objects. Note that you must have imported the CSV file for activity object successfully before trying to import the CSV files for the child objects. There are separate help topics describing how to import each of these child objects. For more information, see the related topics section.

Before You Start

You must do some basic checks before starting your import. For example, make sure that:

- You have completed all the prerequisites for importing each attribute in your source data.
- You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records

All records must be unique in the application. You can use one of these to identify records:

- Public unique identifiers: If you're creating records, then you can provide an easily understandable public unique identifier. These are, usually, denoted with 'Number' and visible in the business object's UI. PUID attributes are usually named <object> Number. If you're updating a record with a Number attribute, then use the Number attribute to identify the record. For more information about public unique identifiers, see the topic "How You Use Alternate Keys to Import Records" in Related Topics section.
- Source system and source system reference: Source system is an identifier for the external system, and source system reference is a unique identifier within the external system. If you're importing new activities or are updating activities that have source system reference data, then provide the source system and source system reference values.
Required Attributes and Validations for Activity Object

To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Make sure that you provide valid values for these attributes so that they pass import validations inbuilt into the application.

This table lists the required attributes for activity records, prerequisite setup tasks and specific validations, if any:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/Import Validations</th>
<th>Creating an Activity record</th>
<th>Updating an Existing Activity record</th>
</tr>
</thead>
<tbody>
<tr>
<td>AccountId</td>
<td>The internal identifier of the account associated with the activity. Examples of account are: customer, organization, person, partner.</td>
<td>The party must exist. You can determine the PartyId of the party by exporting the Party object. To export, navigate to Tools &gt; Export Management &gt; Create Export Activity</td>
<td>Not Required</td>
<td>If during update, you associate the activity with an account party, then you must provide either the internal ID, such as AccountId, or the public unique value, such as AccountPartyNumber, or the combination of original system and original system reference, such as AccountOrigSystem and OsrAccountId.</td>
</tr>
<tr>
<td>AccountOrigSystem</td>
<td>The code representing the source system for the account associated with the activity.</td>
<td>The party must exist. Identify the source system code that was used when you imported the party in a prior batch.</td>
<td>Not Required</td>
<td>If during update, you associate the activity with an account party, then you must provide either the internal ID, such as AccountId, or the public unique value, such as AccountPartyNumber, or the combination of original system and original system reference, such as AccountOrigSystem and OsrAccountId.</td>
</tr>
<tr>
<td>AccountPartyNumber</td>
<td>The public unique identifier of the account associated with the activity.</td>
<td>The party must exist and be a valid party unique identifier</td>
<td>Not Required</td>
<td>If during update, you associate the activity with an account party, then you must provide either the internal ID, such as AccountId, or the public unique value, such as AccountPartyNumber, or the combination of original system and original system reference, such as AccountOrigSystem and OsrAccountId.</td>
</tr>
<tr>
<td>ActionCode</td>
<td>Indicates explicitly the operation to be performed on a row: INSERT to create a new record in the destination tables, UPDATE to update an existing record in the destination table,</td>
<td>The valid values are INSERT, UPDATE, and DELETE. If not provided, record matching is used to determine whether a record is updated (if it already exists)</td>
<td>Not Required</td>
<td>To delete a record, you must provide the value as DELETE. It is optional to provide values for insert and update as the framework internally decides the action as.</td>
</tr>
</tbody>
</table>
## Attribute | Description | Prerequisite Setup Task/Import Validations | Creating an Activity record | Updating an Existing Activity record
--- | --- | --- | --- | ---
DELETE to delete the record. | exists) or inserted (if it doesn’t exist). | | INSERT if it’s a new record or UPDATE if it’s an existing record. | 
ActivityEndDate | The date and time when an appointment ends or the time when a task is completed. | This must be a valid date and should not be less than the ActivityStartDate. | A value is required if you’re creating a new activity having ActivityFunctionCode as APPOINTMENT. | Optional
ActivityFunctionCode | Identifies the activity as an appointment or a task. This attribute is for internal use only and the value is set based on the user’s navigation to the activity. | Valid values are APPOINTMENT, TASK, and CALLREPORT. Lookup type used is ZMM_ACTIVITY_FUNCTION_TYPE_CD. | A value is required while creating an activity. | Not Required
ActivityId | The internal identifier of the activity. | Automatically generated by the import process if creating a new activity record. | | 
ActivityNumber | The public unique identifier of the activity. Indicates a default system-generated number for the activity. | If a value is provided while creating a new activity, the value must be unique. For update, you can determine the existing unique value of the object by exporting the Activity object. To export, navigate to Tools > Export Management > Create Export Activity. The table ZMM_ACTY_ACTIVITIES with column ACTIVITY_NUMBER holds the existing value. | Required | A value is required if you’re updating an existing activity and you’re not providing other values to identify the activity record. To update or delete an existing activity you must choose one of the following options to identify the record:  
• The unique ID for the record (ActivityId)  
• The activity number (ActivityNumber)  
• The source system code and reference (OrigEntityNumber and OrigEntityCode)
<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/ Import Validations</th>
<th>Creating an Activity record</th>
<th>Updating an Existing Activity record</th>
</tr>
</thead>
<tbody>
<tr>
<td>ActivityStartDate</td>
<td>The starting date and time of an appointment or a task. The default value for an appointment is null. The default value for a task is the date and time at which the task is created.</td>
<td>If no value is provided, the corresponding value from Activity production table is used.</td>
<td>A value is required if you're creating a new activity having ActivityFunctionCode as APPOINTMENT.</td>
<td>Optional</td>
</tr>
<tr>
<td>ActivityTypeCode</td>
<td>The channel through which communication has taken place.</td>
<td>If no value is provided, the corresponding value from Activity production table is used. If the ActivityFunctionCode is 'APPOINTMENT' and the action is 'INSERT' then the default value is set to 'MEETING'.</td>
<td>If no value is provided, the corresponding value is used from the Activity production table. If the ActivityFunctionCode is APPOINTMENT and the action is INSERT, the default value is set to MEETING.</td>
<td>Optional</td>
</tr>
<tr>
<td>CampaignId</td>
<td>The internal identifier of the related campaign.</td>
<td>You can determine the public unique value of the object by exporting the object.</td>
<td>When creating an Activity, if you associate the Activity with a campaign, then you must provide either the internal ID, such as CampaignId, or the public unique value, such as CampaignNumber.</td>
<td>When updating an Activity, if you associate the Activity with a campaign, then you must provide either the internal ID, such as CampaignId, or the public unique value, such as CampaignNumber.</td>
</tr>
<tr>
<td>CampaignNumber</td>
<td>The public unique identifier of the related campaign.</td>
<td>You can determine the public unique value of the object by exporting the object.</td>
<td>When creating an Activity, if you associate the Activity with a campaign, then you must provide either the internal ID, such as CampaignId, or the public unique value, such as CampaignNumber.</td>
<td>When updating an Activity, if you associate the Activity with a campaign, then you must provide either the internal ID, such as CampaignId, or the public unique value, such as CampaignNumber.</td>
</tr>
<tr>
<td>ClaimCode</td>
<td>The public unique identifier for claim.</td>
<td>You can determine the public unique value of the object by exporting the object.</td>
<td>When creating an Activity, if you associate the Activity with a claim, provide either the internal ID, such as claim ID, or the public unique value, such as claim code. Ensure that this is a valid claim code from MKT_BDT_CLAIMS.</td>
<td>Optional. Ensure that this is a valid claim code from MKT_BDT_CLAIMS.</td>
</tr>
<tr>
<td>ClaimId</td>
<td>The internal identifier of the claim.</td>
<td>You can determine the public unique value of the object by exporting the object.</td>
<td>When creating an activity, if you associate the activity with a claim, then you must provide either the internal ID, such as claim ID, or the public unique value, such as ClaimId.</td>
<td>Optional. Ensure that this is a valid claim ID from the MKT_BDT_CLAIMS table.</td>
</tr>
<tr>
<td>Attribute</td>
<td>Description</td>
<td>Prerequisite Setup Task/ Import Validations</td>
<td>Creating an Activity record</td>
<td>Updating an Existing Activity record</td>
</tr>
<tr>
<td>--------------------</td>
<td>------------------------------------------------------------------------------</td>
<td>-------------------------------------------------------------------------------------------------------------</td>
<td>-------------------------------------------------------------------------------------------------</td>
<td>--------------------------------------</td>
</tr>
<tr>
<td>CorpCurrencyCode</td>
<td>The corporate currency used by the activity.</td>
<td>If no value is provided, the corresponding value from Activity production table is used.</td>
<td>If no value is provided, the corresponding value is used from the Assignee production table.</td>
<td>If no value is provided, the corresponding value is used from the Assignee production table.</td>
</tr>
<tr>
<td>CurcyConvRateType</td>
<td>The rate of currency conversion for an activity.</td>
<td>If no value is provided, the corresponding value from Activity production table is used.</td>
<td>If no value is provided, the corresponding value is used from the Assignee production table.</td>
<td>If no value is provided, the corresponding value is used from the Assignee production table.</td>
</tr>
<tr>
<td>CurrencyCode</td>
<td>The corporate currency used by the activity.</td>
<td>If no value is provided, the corresponding value from Activity production table is used.</td>
<td>If no value is provided, the corresponding value is used from the Assignee production table.</td>
<td>If no value is provided, the corresponding value is used from the Assignee production table.</td>
</tr>
<tr>
<td>CustomerAccountId</td>
<td>The internal identifier of the customer account related to the activity. It is the sales activity identifier from ZCA_SALES_ACCOUNTS table.</td>
<td>If no value is provided, the corresponding value from Activity production table is used.</td>
<td>The internal identifier of the customer account related to the activity. It is the sales account identifier from ZCA_SALES_ACCOUNTS table.</td>
<td>This should be a valid sales account identifier from the ZCA_SALES_ACCOUNTS table.</td>
</tr>
<tr>
<td>DealId</td>
<td>The internal identifier of the related deal registration.</td>
<td>You can determine the public unique value of the object.</td>
<td>Optional</td>
<td>Optional</td>
</tr>
<tr>
<td>DealNumber</td>
<td>The public unique identifier of the deal associated with the activity. The identifier can also be generated from an external source.</td>
<td>You can determine the public unique value of the object.</td>
<td>Optional</td>
<td>Optional</td>
</tr>
<tr>
<td>DelegatorId</td>
<td>The internal identifier of the activity resource that delegated activity ownership to another resource.</td>
<td>The party must exist. You can determine the PartyId of the party by exporting the Party object.</td>
<td>Optional</td>
<td>Optional</td>
</tr>
</tbody>
</table>

To export, navigate to Tools > Export Management > Create Export Activity.

Optional
When creating an activity, if you associate the activity with a deal, you must provide either the internal ID, such as DealId, or the public unique value, such as DealNumber.
<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/Import Validations</th>
<th>Creating an Activity record</th>
<th>Updating an Existing Activity record</th>
</tr>
</thead>
<tbody>
<tr>
<td>DelegatorOrigSystem</td>
<td>The source system reference to the delegator of original system identifier.</td>
<td>Management &gt; Create Export Activity.</td>
<td>To export, navigate to Tools &gt; Export Management &gt; Create Export Activity.</td>
<td>To export, navigate to Tools &gt; Export Management &gt; Create Export Activity.</td>
</tr>
<tr>
<td>DirectionCode</td>
<td>The direction options for an activity. The options are inbound, outbound, or optional. The default value is null.</td>
<td>If no value is provided, the corresponding value from Activity production table is used.</td>
<td>This should be a valid lookup code corresponding to ZMM_ACTIVITY_DIRECTION from fnd_lookups.</td>
<td>This should be a valid lookup code corresponding to ZMM_ACTIVITY_DIRECTION from fnd_lookups.</td>
</tr>
<tr>
<td>DueDate</td>
<td>The date the activity is due to be completed.</td>
<td>If no value is provided, the corresponding value from Activity production table is used.</td>
<td>This should be a valid date.</td>
<td>This should be a valid date.</td>
</tr>
<tr>
<td>Duration</td>
<td>The actual duration of the activity in the appropriate unit of measure.</td>
<td>If no value is provided, then the corresponding value from Activity production table is used.</td>
<td>This is a derived field. Any value provided is ignored.</td>
<td>This is a derived field. Any value provided is ignored.</td>
</tr>
<tr>
<td>EnrollmentId</td>
<td>The internal identifier of the related program enrollment.</td>
<td>You can determine the public unique value of the object by exporting the object.</td>
<td>When creating an activity, if you associate the activity with a program enrollment, then you must provide either the internal ID, such as EnrollmentId, or the public unique value, such as EnrollmentNumber. This must be a valid value in the ZPM_PROGRAM_ENROLLMENTS table.</td>
<td>If during update, you associate the activity with a program enrollment, then you must provide either the internal ID, such as EnrollmentId, or the public unique value, such as EnrollmentNumber.</td>
</tr>
<tr>
<td>EnrollmentNumber</td>
<td>The public unique identifier of the related program enrollment.</td>
<td>You can determine the public unique value of the object by exporting the object.</td>
<td>When creating an activity, if you associate the activity with a program enrollment, then you must provide either the internal ID, such as EnrollmentId, or the public unique value, such as EnrollmentNumber. This must be a valid value in the ZPM_PROGRAM_ENROLLMENTS table.</td>
<td>If during update, you associate the activity with a program enrollment, then you must provide either the internal ID, such as EnrollmentId, or the public unique value, such as EnrollmentNumber.</td>
</tr>
</tbody>
</table>
### Attribute | Description | Prerequisite Setup Task/Import Validations | Creating an Activity record | Updating an Existing Activity record
--- | --- | --- | --- | ---
FundRequestCode | The foreign key to FUND_REQUEST_CODE of the MKT_BDT_FUND_REQUESTS table. | You can determine the public unique value of the object by exporting the object. To export, navigate to Tools > Export Management > Create Export Activity. | When creating an activity, if you associate the activity with a fund request, you must provide either the internal ID, such as FundRequestId, or the public unique value, such as FundRequestCode. This must be a valid value in the MKT_BDT_FUND_REQUESTS table. | When updating an activity, if you associate the activity with a fund request, you must provide either the internal ID, such as FundRequestId, or the public unique value, such as FundRequestCode. This must be a valid value in the MKT_BDT_FUND_REQUESTS table. |
FundRequestId | The internal identifier of the fund request. | You can determine the public unique value of the object by exporting the object. To export, navigate to Tools > Export Management > Create Export Activity. | When creating an activity, if you associate the activity with a fund request, you must provide either the internal ID, such as FundRequestId, or the public unique value, such as FundRequestCode. This must be a valid value in the MKT_BDT_FUND_REQUESTS table. | When updating an activity, if you associate the activity with a fund request, you must provide either the internal ID, such as FundRequestId, or the public unique value, such as FundRequestCode. This must be a valid value in the MKT_BDT_FUND_REQUESTS table. |
LeadId | The internal identifier of the related lead. | You can determine the public unique value of the object by exporting the object. To export, navigate to Tools > Export Management > Create Export Activity. | When creating an activity, if you associate the activity with a lead, then you must provide either the internal ID, such as LeadId, or the public unique value, such as LeadNumber. It must be a valid value in the MKL_LM_LEADS table. | If during update, you associate the activity with a lead, then you must provide either the internal ID, such as LeadId, or the public unique value, such as LeadNumber. |
LeadNumber | The public unique identifier of the related lead. | You can determine the public unique value of the object by exporting the object. To export, navigate to Tools > Export Management > Create Export Activity. | When creating an activity, if you associate the activity with a lead, then you must provide either the internal ID, such as LeadId, or the public unique value, such as LeadNumber. It must be a valid value in the MKL_LM_LEADS table. | If during update, you associate the activity with a lead, then you must provide either the internal ID, such as LeadId, or the public unique value, such as LeadNumber. |
ObjectiveId | The internal identifier of the objective. | You can determine the public unique value of the object by exporting the object. To export, navigate to Tools > Export Management > Create Export Activity. | When creating an activity, if you associate the activity with a sales objective, you must provide either the internal ID, such as ObjectiveId, or the public unique value, such as ObjectiveNumber. It must be a valid value in the ZCA_OBJECTIVES table. | When updating an activity, if you associate the activity with a sales objective, you must provide either the internal ID, such as ObjectiveId, or the public unique value, such as ObjectiveNumber. It must be a valid value in the ZCA_OBJECTIVES table. |
<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/Import Validations</th>
<th>Creating an Activity record</th>
<th>Updating an Existing Activity record</th>
</tr>
</thead>
<tbody>
<tr>
<td>ObjectiveNumber</td>
<td>The public unique identifier of the related objective.</td>
<td>You can determine the public unique value of the object by exporting the object.</td>
<td>When creating an activity, if you associate the activity with a sales objective, you must provide either the internal ID, such as ObjectiveId, or the public unique value, such as ObjectiveNumber. It must be a valid value in the ZCA_OBJECTIVES table.</td>
<td>When updating an activity, if you associate the activity with a sales objective, you must provide either the internal ID, such as ObjectiveId, or the public unique value, such as ObjectiveNumber. It must be a valid value in the ZCA_OBJECTIVES table.</td>
</tr>
<tr>
<td>OpportunityId</td>
<td>The internal identifier of the related opportunity.</td>
<td>You can determine the public unique value of the object by exporting the object.</td>
<td>When creating an activity, if you associate the activity with an opportunity, you must provide either the internal ID, such as OpportunityId, or the public unique value, such as OpportunityNumber. This must be a valid value in the MOO_OPTY table.</td>
<td>If during update, you associate the activity with an opportunity, then you must provide either the internal ID, such as OpportunityId, or the public unique value, such as OpportunityNumber.</td>
</tr>
<tr>
<td>OpportunityNumber</td>
<td>The internal identifier of the related opportunity.</td>
<td>You can determine the public unique value of the object by exporting the object.</td>
<td>When creating an activity, if you associate the activity with an opportunity, you must provide either the internal ID, such as OpportunityId, or the public unique value, such as OpportunityNumber. This must be a valid value in the MOO_OPTY table.</td>
<td>If during update, you associate the activity with an opportunity, then you must provide either the internal ID, such as OpportunityId, or the public unique value, such as OpportunityNumber.</td>
</tr>
<tr>
<td>OrigEntityCode</td>
<td>The code indicating the original source of the record.</td>
<td>Valid values for upgraded records are TASK, APPOINTMENT, or INTERACTION.</td>
<td>Valid values for upgraded records are TASK, APPOINTMENT, or INTERACTION.</td>
<td>One of the following must be provided while updating an activity:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>If the record was created in the Activity Management component, the value is ACTIVITY.</td>
<td>If the record was created in the Activity Management component, the value is ACTIVITY.</td>
<td>• ActivityId</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>• ActivityNumber</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>• Combination of OrigEntityNumber and OrigEntityCode</td>
</tr>
<tr>
<td>OrigEntityNumber</td>
<td>The original unique identifier of the existing task, appointment, or interaction in the source system.</td>
<td>If the internal action code is &quot;INSERT&quot; and OrigEntityNumber and ActivityNumber are NULL, then it's defaulted to the provided value. If no value is provided, the corresponding value from Activity production table is used.</td>
<td>If the internal action code is &quot;INSERT&quot; and OrigEntityNumber and ActivityNumber are NULL, it's defaulted to the provided value.</td>
<td>One of the following must be provided while updating an activity:</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>• ActivityId</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>• ActivityNumber</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>• Combination of OrigEntityNumber and OrigEntityCode</td>
</tr>
<tr>
<td>Attribute</td>
<td>Description</td>
<td>Prerequisite Setup Task/Import Validations</td>
<td>Creating an Activity record</td>
<td>Updating an Existing Activity record</td>
</tr>
<tr>
<td>-------------------</td>
<td>-----------------------------------------------------------------------------</td>
<td>-----------------------------------------------------------------------------------------------------------</td>
<td>-----------------------------</td>
<td>---------------------------------------</td>
</tr>
<tr>
<td>OsrAccountId</td>
<td>The internal identifier (reference number or text) of the account party in the original source system.</td>
<td>The party must exist. You can determine the Original System Reference for the party by exporting the Party object. To export, navigate to <strong>Tools &gt; Export Management &gt; Create Export Activity</strong>.</td>
<td>Optional</td>
<td>If during update, you associate the activity with an account party, then you must provide either the internal ID, such as AccountId, or the public unique value, such as AccountPartyNumber, or the combination of original system and original system reference, such as AccountOrigSystem and OsrAccountId.</td>
</tr>
<tr>
<td>OsrDelegatorId</td>
<td>The source system reference to the Delegator ID.</td>
<td>The party must exist. You can determine the Original System Reference for the party by exporting the Party object. To export, navigate to <strong>Tools &gt; Export Management &gt; Create Export Activity</strong>.</td>
<td>Optional</td>
<td>The party must exist. You can determine the Original System Reference for the party by exporting the Party object. To export, navigate to <strong>Tools &gt; Export Management &gt; Create Export Activity</strong>.</td>
</tr>
<tr>
<td>OsrOwnerId</td>
<td>The internal identifier (reference number or text) of the person who owns the activity in the original source system.</td>
<td>The party must exist. You can determine the Original System Reference for the party by exporting the Party object. To export, navigate to <strong>Tools &gt; Export Management &gt; Create Export Activity</strong>.</td>
<td>One of the following must be provided while creating an activity: • OwnerId • OwnerResourceNumber • Combination of OwnerOrigSystem and OsrOwnerId</td>
<td>The party must exist. You can determine the Original System Reference for the party by exporting the Party object. To export, navigate to <strong>Tools &gt; Export Management &gt; Create Export Activity</strong>.</td>
</tr>
<tr>
<td>OsrPrimaryContactId</td>
<td>The internal identifier (reference number or text) of the contact party in the original source system.</td>
<td>The party must exist. You can determine the Original System Reference for the party by exporting the Party object. To export, navigate to <strong>Tools &gt; Export Management &gt; Create Export Activity</strong>.</td>
<td>Optional</td>
<td>When updating an activity, if you associate the activity with a contact party, then you must provide either the internal ID, such as PrimaryContactId, or the public unique value, such as PrimaryContactPartyNumber, or the combination of original system and original system reference, such as PrimaryContactOrigSystem and OsrPrimaryContactId.</td>
</tr>
<tr>
<td>OsrReferenceCustomerId</td>
<td>The internal identifier (reference number or text)</td>
<td>The party must exist. You can determine the Original System Reference for the party by exporting the Party object. To export, navigate to <strong>Tools &gt; Export Management &gt; Create Export Activity</strong>.</td>
<td>When creating an activity, you associate the</td>
<td>When updating an activity, if you associate the</td>
</tr>
<tr>
<td>Attribute</td>
<td>Description</td>
<td>Prerequisite Setup Task/Import Validations</td>
<td>Creating an Activity record</td>
<td>Updating an Existing Activity record</td>
</tr>
<tr>
<td>--------------------</td>
<td>------------------------------------------------------------------</td>
<td>-----------------------------------------------------------------------------------------------------------</td>
<td>-----------------------------------------------------------------------------------------------</td>
<td>---------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td></td>
<td>of the customer in the original source system.</td>
<td>System Reference for the party by exporting the Party object.</td>
<td>activity with a referenced customer party, then you must provide either the internal ID, such as ReferenceCustomerId, or the public unique value, such as RefCustPartyNumber, or the combination of original system and original system reference, such as RefCustOrigSystem and OsrReferenceCustomerId.</td>
<td>activity with a referenced customer party, then you must provide either the internal ID, such as ReferenceCustomerId, or the public unique value, such as RefCustPartyNumber, or the combination of original system and original system reference, such as RefCustOrigSystem and OsrReferenceCustomerId.</td>
</tr>
<tr>
<td>OutlookFlag</td>
<td>Indicates whether the activity is created in Outlook. If the value is Y, then the activity is created in Outlook and synchronized.</td>
<td>If no value is provided, the corresponding value from Activity production table is used. If the ActivityFunctionCode is 'APPOINTMENT' and the Action is 'INSERT' then the value is set to 'N'.</td>
<td>If the ActivityFunctionCode is APPOINTMENT and the action is INSERT, the value is set to N. Possible values are Y and N.</td>
<td>Optional Possible values are Y and N.</td>
</tr>
<tr>
<td>OwnerId</td>
<td>The internal identifier of the activity owner. The owner has to be an existing party (person) in system.</td>
<td>The party must exist. You can determine the PartyId of a person by exporting the Party object.</td>
<td>Provide one of the following while creating an activity:</td>
<td>Provide one of the following while updating an activity:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>To export, navigate to Tools &gt; Export Management &gt; Create Export Activity.</td>
<td>(OwnerId, OwnerResourceId, or a combination of OwnerOrigSystem and OsrOwnerId)</td>
<td>(OwnerId, OwnerResourceId, or a combination of OwnerOrigSystem and OsrOwnerId)</td>
</tr>
<tr>
<td>OwnerOrigSystem</td>
<td>The code representing the source system for the party (person) who owns the activity.</td>
<td>The party must exist. You can determine the PartyId of a person by exporting the Party object.</td>
<td>Provide one of the following while creating an activity:</td>
<td>Provide one of the following while updating an activity:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>To export, navigate to Tools &gt; Export Management &gt; Create Export Activity.</td>
<td>(OwnerId, OwnerResourceId, or a combination of OwnerOrigSystem and OsrOwnerId)</td>
<td>(OwnerId, OwnerResourceId, or a combination of OwnerOrigSystem and OsrOwnerId)</td>
</tr>
<tr>
<td>OwnerResourceNumber</td>
<td>The public unique identifier of the party (person) who owns the activity.</td>
<td>The party must exist. You can determine the PartyId of a person by exporting the Party object.</td>
<td>Provide one of the following while creating an activity:</td>
<td>Provide one of the following while updating an activity:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>To export, navigate to Tools &gt; Export Management &gt; Create Export Activity.</td>
<td>(OwnerId, OwnerResourceId, or a combination of OwnerOrigSystem and OsrOwnerId)</td>
<td>(OwnerId, OwnerResourceId, or a combination of OwnerOrigSystem and OsrOwnerId)</td>
</tr>
<tr>
<td>Attribute</td>
<td>Description</td>
<td>Prerequisite Setup Task/Import Validations</td>
<td>Creating an Activity record</td>
<td>Updating an Existing Activity record</td>
</tr>
<tr>
<td>---------------------------</td>
<td>-----------------------------------------------------------------------------</td>
<td>-----------------------------------------------------------------------------------------------------------</td>
<td>----------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
</tbody>
</table>
| ParentActivityId          | The related activity identifier and only applicable if the record is a follow up activity. | Conditionally Required only for follow-up activity. One of the following options to identify the parent record must be provided:  
  • The unique ID for the ParentActivityId.  
  • The parent activity number (ParentActivityNumber)  
  • The source system code and source reference code (ParentOrigEntityNumber and ParentOrigEntityCode) | A value is required if you’re creating a follow-up activity. While creating an activity, choose one of the following options to identify the record:  
  • The unique ID for the ParentActivityId.  
  • The parent activity number (ParentActivityNumber)  
  • The source system code and source reference code (ParentOrigEntityNumber and ParentOrigEntityCode) | Optional  
  While updating an activity, choose one of the following options to identify the record:  
  • The unique ID for the ParentActivityId.  
  • The parent activity number (ParentActivityNumber).  
  • The source system code and source reference code (ParentOrigEntityNumber and ParentOrigEntityCode). |
| ParentActivityNumber      | The public unique identifier of the related activity and only applicable if the record is a follow up activity. | Conditionally Required only for follow-up activity. One of the following options to identify the parent record must be provided:  
  • The unique ID for the record (ParentActivityId)  
  • The parent activity number (ParentActivityNumber)  
  • The source system code and source reference code (ParentOrigEntityNumber and ParentOrigEntityCode) | A value is required if you’re creating a follow-up activity. While creating an activity, choose one of the following options to identify the record:  
  • The unique ID for the record (ParentActivityId)  
  • The parent activity number (ParentActivityNumber)  
  • The source system code and source reference code (ParentOrigEntityNumber and ParentOrigEntityCode) | Optional  
  While updating an activity, choose one of the following options to identify the record:  
  • The unique ID for the record (ParentActivityId).  
  • The parent activity number (ParentActivityNumber).  
  • The source system code and source reference code (ParentOrigEntityNumber and ParentOrigEntityCode). |
| ParentOrigEntityCode      | The source of the activity record that indicating whether it’s coming from Task entity, Interaction entity, or Appointment entity. | Conditionally Required only for follow-up activity. One of the following options to identify the parent record must be provided:  
  • The unique ID for the record (ParentActivityId)  
  • The parent activity number (ParentActivityNumber)  
  • The source system code and source reference code (ParentOrigEntityNumber and ParentOrigEntityCode) | A value is required if you’re creating a follow-up activity. While creating an activity, choose one of the following options to identify the record:  
  • The unique ID for the record (ParentActivityId)  
  • The parent activity number (ParentActivityNumber)  
  • The source system code and source reference code (ParentOrigEntityNumber and ParentOrigEntityCode) | Optional  
  While updating an activity, choose one of the following options to identify the record:  
  • The unique ID for the record (ParentActivityId).  
  • The parent activity number (ParentActivityNumber).  
  • The source system code and source reference code (ParentOrigEntityNumber and ParentOrigEntityCode). |
<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/Import Validations</th>
<th>Creating an Activity record</th>
<th>Updating an Existing Activity record</th>
</tr>
</thead>
</table>
| ParentOrigEntityNumber    | The entity number of the parent entity in the original system to which the activity is related | Conditionally Required only for follow-up activity. One of the following options to identify the parent record must be provided:  
- The unique ID for the record (ParentActivityId)  
- The parent activity number (ParentActivityNumber)  
- The source system code and source reference code (ParentOrigEntityNumber and ParentOrigEntityCode) | A value is required if you're creating a follow-up activity. While creating an activity, choose one of the following options to identify the record:  
- The unique ID for the record (ParentActivityId)  
- The parent activity number (ParentActivityNumber)  
- The source system code and source reference code (ParentOrigEntityNumber and ParentOrigEntityCode) | Optional  
While updating an activity, choose one of the following options to identify the record:  
- The unique ID for the record (ParentActivityId)  
- The parent activity number (ParentActivityNumber)  
- The source system code and source reference code (ParentOrigEntityNumber and ParentOrigEntityCode) |
| PartnerProgramId          | The internal identifier of the related partner program.                      | You can determine the public unique value of the object by exporting the object.  
To export, navigate to Tools > Export Management > Create Export Activity.  
For partner programs, export the Program Enrollments object. | When creating an activity, if you associate the activity with a partner program, you must provide either the internal ID, such as PartnerProgramId, or the public unique value, such as PartnerProgramNumber. | When updating an activity, if you associate the activity with a partner program, you must provide either the internal ID, such as PartnerProgramId, or the public unique value, such as PartnerProgramNumber. |
| PartnerProgramNumber      | The public unique identifier of the related partner program.                | You can determine the public unique value of the object by exporting the object.  
To export, navigate to Tools > Export Management > Create Export Activity.  
For Partner programs, export the Program Enrollments object. | When creating an activity, if you associate the activity with a partner program, then you must provide either the internal ID, such as PartnerProgramId, or the public unique value, such as PartnerProgramNumber. | When updating an activity, if you associate the activity with a partner program, then you must provide either the internal ID, such as PartnerProgramId, or the public unique value, such as PartnerProgramNumber. |
| PrimaryContactId          | The internal identifier of the activity contact.                             | The party must exist. You can determine the PartyId of the party by exporting the Party object.          | Optional  
When creating an activity, if you associate the activity with a contact party, then you must provide either the internal ID, such as PrimaryContactId, or the | When updating an activity, if you associate the activity with a contact party, then you must provide either the internal ID, such as PrimaryContactId, or the |
<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/ Import Validations</th>
<th>Creating an Activity record</th>
<th>Updating an Existing Activity record</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td>To export, navigate to Tools &gt; Export Management &gt; Create Export Activity. If no value is provided, the</td>
<td>the internal ID, such as PrimaryContactId, or the public unique value, such as PrimaryContactPartyNumber or the combination of original system and original system reference, such as PrimaryContactOrigSystem and OsrPrimaryContactId.</td>
<td>public unique value, such as PrimaryContactPartyNumber, or the combination of original system and original system reference, such as PrimaryContactOrigSystem and OsrPrimaryContactId.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>corresponding value from Activity production table is used.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>PrimaryContactOrigSystem</td>
<td>The code representing the source system for the activity contact.</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>The party must exist. Identify the source system code that was used when you imported the party in a prior</td>
<td>Optional</td>
<td>When updating an activity, if you associate the activity with a contact party, then you must provide either the internal ID, such as PrimaryContactId, or the public unique value, such as PrimaryContactPartyNumber, or the combination of original system and original system reference, such as PrimaryContactOrigSystem and OsrPrimaryContactId.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>batch. You can determine existing source system codes and create new ones. Navigate to the following in the</td>
<td>When creating an activity, if you associate the activity with a contact party, then you must provide either the internal ID, such as PrimaryContactId, or the public unique value, such as PrimaryContactPartyNumber, or the combination of original system and original system reference, such as PrimaryContactOrigSystem and OsrPrimaryContactId.</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>Setup and Maintenance work area:</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Offering: Sales</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Functional Area: Data Import and Export</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Task: Manage Trading Community Source Systems</td>
<td></td>
<td></td>
</tr>
<tr>
<td>PrimaryContactPartyNumber</td>
<td>The public unique identifier of the activity contact.</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>The party must exist. You can determine the PartyNumber of a party by exporting either the Person object or</td>
<td>Optional</td>
<td>When updating an activity, if you associate the activity with a contact party, then you must provide either the internal ID, such as PrimaryContactId, or the public unique value, such as PrimaryContactPartyNumber, or the combination of original system and original system reference, such as PrimaryContactOrigSystem and OsrPrimaryContactId.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>the Organization object.</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>To export, navigate to Tools &gt; Export Management &gt; Create Export Activity.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>PriorityCode</td>
<td>The priority of the activity. The default value is 2. The possible values are 1, 2, 3.</td>
<td>If no value is provided, the corresponding value from Activity production table is used.</td>
<td>Not required</td>
<td>When updating an activity, if you must modify the priority of an Activity, provide a valid value for PriorityCode.</td>
</tr>
<tr>
<td>PrivateFlag</td>
<td>Indicates whether the activity is private.</td>
<td></td>
<td>Optional</td>
<td>When updating an activity, if you must mark an</td>
</tr>
<tr>
<td></td>
<td></td>
<td>If no value is provided, the corresponding value from Activity production table is used.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Attribute</td>
<td>Description</td>
<td>Prerequisite Setup Task/Import Validations</td>
<td>Creating an Activity record</td>
<td>Updating an Existing Activity record</td>
</tr>
<tr>
<td>------------------------</td>
<td>-----------------------------------------------------------------------------</td>
<td>--------------------------------------------</td>
<td>-----------------------------------------------------------------------------------------------</td>
<td>--------------------------------------</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Activity production table is used.</td>
<td></td>
</tr>
</tbody>
</table>
| RecurSerOrigEntityNumber| The entity number of the recurring appointment in the original system, to which this activity is related | If no value is provided, the corresponding value from Activity production table is used.      | A value is required if you're creating a recurring activity (appointment). While creating an activity, choose one of the following options to identify the record:  
  • The unique ID for the record (RecurSeriesId)  
  • The recurring series activity number (RecurSeriesActivityNumber)  
  • The entity number of the recurring appointment in the original system, to which this activity is related (RecurSerOrigEntityNumber) | Optional                             |
| RecurSeriesActivityNumb| The activity number of an instance of a series.                             | If no value is provided, the corresponding value from Activity production table is used.      | A value is required if you're creating a recurring activity (appointment). While creating an activity, choose one of the following options to identify the record:  
  • The unique ID for the record (RecurSeriesId)  
  • The recurring series activity number (RecurSeriesActivityNumber)  
  • The entity number of the recurring appointment in the original system, to which this activity is related (RecurSerOrigEntityNumber) | Optional                             |
| RecurSeriesId          | The internal identifier for the series that links instances of a series together. | If no value is provided, the corresponding value from Activity production table is used.      | A value is required if you're creating a recurring activity (appointment). While creating an activity, choose one of the following options to identify the record:  
  • The unique ID for the record (RecurSeriesId) | Optional                             |
<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/ Import Validations</th>
<th>Creating an Activity record</th>
<th>Updating an Existing Activity record</th>
</tr>
</thead>
<tbody>
<tr>
<td>RecurWeekday</td>
<td>The activity that recurs on every weekday such as Monday to Sunday, Weekday, Weekend, and so on.</td>
<td>If no value is provided, the corresponding value from Activity production table is used.</td>
<td>Conditionally required for a weekly recurring appointment. Must be a valid value from ZMM_ACTIVITY_RECUR_DAYWEEK_CD lookup.</td>
<td>Conditionally required for a weekly recurring appointment. Must be a valid value from ZMM_ACTIVITY_RECUR_DAYWEEK_CD lookup.</td>
</tr>
<tr>
<td>RefCustOrigSystem</td>
<td>The source system code for the reference customer.</td>
<td>The party must exist. Identify the source system code that was used when you imported the party in a prior batch. You can determine existing source system codes and create new ones. Navigate to the following in the Setup and Maintenance work area:</td>
<td>The party must exist. Identify the source system code that was used when you imported the party in a prior batch. You can determine existing source system codes and create new ones. Navigate to the following in the Setup and Maintenance work area:</td>
<td>When updating an activity, if you associate the activity with a referenced customer party, then you must provide either the internal ID, such as ReferenceCustomerId, or the public unique value, such as RefCustPartyNumber, or the combination of original system and original system reference, such as RefCustOrigSystem and OsrReferenceCustomerId.</td>
</tr>
<tr>
<td>RefCustPartyNumber</td>
<td>The public unique identifier of the reference customer who’s associated with the activity.</td>
<td>The party must exist. Identify the source system code that was used when you imported the party in a prior batch. You can determine existing source system codes and create new ones. Navigate to the following in the Setup and Maintenance work area:</td>
<td>The party must exist. Identify the source system code that was used when you imported the party in a prior batch. You can determine existing source system codes and create new ones. Navigate to the following in the Setup and Maintenance work area:</td>
<td>When updating an activity, if you associate the activity with a referenced customer party, then you must provide either the internal ID, such as ReferenceCustomerId, or the public unique value, such as RefCustPartyNumber, or the combination of original system and original system reference, such as RefCustOrigSystem and OsrReferenceCustomerId.</td>
</tr>
</tbody>
</table>
## Attribute | Description | Prerequisite Setup Task/ Import Validations | Creating an Activity record | Updating an Existing Activity record
--- | --- | --- | --- | ---
ReferenceCustomerId | The internal identifier of the reference customer who's associated with the activity. | - Task: Manage Trading Community Source Systems | The party must exist. Identify the source system code that was used when you imported the party in a prior batch. You can determine existing source system codes and create new ones. | When updating an activity, if you associate the activity with a referenced customer party, then you must provide either the internal ID, such as ReferenceCustomerId, or the public unique value, such as RefCustPartyNumber, or the combination of original system and original system reference, such as RefCustOrigSystem and OsrReferenceCustomerId.

SrId | The foreign key to SR_ID in the SVC_SERVICE_REQUESTS table. | You can determine the public unique value of this object by exporting the object. To export, navigate to Tools > Export Management > Create Export Activity. | When creating an activity, if you associate the activity with a service request, then you must provide either the internal ID, such as SrId, or the public unique value, such as SrNumber. This must be a valid value in SVC_SERVICE_REQUESTS. | When updating an activity, if you associate the activity with a service request, then you must provide either the internal ID, such as SrId, or the public unique value, such as SrNumber. This must be a valid value in SVC_SERVICE_REQUESTS.

SrNumber | The foreign key to SR_NUMBER in the SVC_SERVICE_REQUESTS table. | You can determine the public unique value of this object by exporting the object. To export, navigate to Tools > Export Management > Create Export Activity. | When creating an activity, if you associate the activity with a service request, then you must provide either the internal ID, such as SrId, or the public unique value, such as SrNumber. This must be a valid value in SVC_SERVICE_REQUESTS. | When updating an activity, if you associate the activity with a service request, then you must provide either the internal ID, such as SrId, or the public unique value, such as SrNumber. This must be a valid value in SVC_SERVICE_REQUESTS.

StatusCode | The status of the activity. The default value is Not Started. | If no value is provided, the default is NOT_STARTED. The lookup Type used is ZMM_ACTIVITY_STATUS_CD. | If no value is provided, the default is NOT_STARTED. The lookup Type used is ZMM_ACTIVITY_STATUS_CD. | Optional

Subject | The unique subject, name, or title of the activity. | No validation | A value is required if you're creating a new activity. | Not Required

Go to Navigator > Tools > Import Management > Import Objects, to see all the attributes of the activity object. The page also lists attribute information like type, length, description, and so on.

Create the Source CSV File
You include the data that you want to import into CX Sales and B2B Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator > Tools > Import Management > Import Objects.
2. Select the Activity object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note: For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the activity information. To create an import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Activity from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the **Status** column for the import activity. The import is successful if the status displays as **Completed**. You can drill down on the import activity to go to the **Import Status** page which provides the status details of the import activity.

**Related Topics**
- Import Data
- How You Use Alternate Keys to Import Records
- Potential Issues When Opening CSV Files in Excel

## Import Your Activity Assignee Data

You can use Import Management to create, update, or delete your activity assignee data.

You can import activity assignee records using these steps:

1. Map your source activity assignee data to Oracle Applications Cloud object attributes. This way the import process would know where to insert each of the information bits.
2. Create the source CSV file with the activity assignee data you want to import.
4. Check the import results to know if the import went well.

### How You Map Your Source Data to Target Object Attributes

You import activity assignee data into Oracle Applications Cloud from a CSV file containing your source data that's mapped to target Oracle Applications Cloud object attributes.

You need to do the following before creating the .csv file for data import:

- Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
- Ensure prerequisite steps are complete, such as understanding what attributes are required for importing your objects.
- Understand your options for uniquely identifying the records.
- Ensure parent records exist before importing child records.
- Identify the target object attributes that are required in the .csv file for a successful import.

If you want to import only a few records, then you can create a single CSV file for all activity assignee attributes. However if you want to import a large number of records, then you may decide to create multiple CSV files, one for each of the activity assignee child objects. Note that you must have imported the CSV file for activity assignee object successfully before trying to import the CSV files for the child objects. There are separate help topics describing how to import each of these child objects. For more information, see the related topics section.

### Before You Start

You must do some basic checks before starting your import. For example, make sure that:

- You have completed all the prerequisites for importing each attribute in your source data.
• You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records

All records must be unique in the application. You can use one of these to identify records:

• Public unique identifiers: If you're creating records, then you can provide an easily understandable public unique identifier. These are, usually, denoted with 'Number' and visible in the business object's UI. PUID attributes are usually named <object> Number. If you're updating a record with a Number attribute, then use the Number attribute to identify the record. For more information about public unique identifiers, see the topic "How You Use Alternate Keys to Import Records" in Related Topics section.

• Source system and source system reference: Source system is an identifier for the external system, and source system reference is a unique identifier within the external system. If you're importing new accounts or are updating accounts that have source system reference data, then provide the source system and source system reference values.

Required Attributes and Validations for Activity Assignee Object

To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Make sure that you provide valid values for these attributes so that they pass import validations inbuilt into the application.

This table lists the required attributes for activity assignee records, prerequisite setup tasks and specific validations, if any:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/Import Validations</th>
<th>Creating an Activity Assignee record</th>
<th>Updating an Existing Activity Assignee record</th>
</tr>
</thead>
</table>
| ActivityId    | The internal identifier of the activity to which the assignee is associated. | Automatically generated by the import process if creating a new activity record. | Optional | A value is required if you're updating an existing activity and you're not providing other values to identify the activity record. To update an existing activity, choose one of the following options to identify the record:  
  • The unique ID for the record (ActivityId)  
  • The activity number (ActivityNumber)  
  • The source system code and reference (OrigEntityNumber and OrigEntityCode) |
<p>| ActivityNumber| The public unique identifier of the activity to which the assignee is associated | If a value is provided while creating a new activity, the value must be unique. For update, you can determine the existing unique value of the object by exporting the Activity object. | A value is required if you're creating a new activity. | A value is required if you're updating an existing activity and you're not providing other values to identify the activity record. To update an existing activity, choose one of the |</p>
<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/Import Validations</th>
<th>Creating an Activity Assignee record</th>
<th>Updating an Existing Activity Assignee record</th>
</tr>
</thead>
</table>
| AssigneeId            | The internal identifier of the HZ_PARTY record having PARTY_USAGE as Resource.                                                                                                                                                                                                                                                                                                                                | Navigate to the following in the Setup and Maintenance work area:  
  - Offering: Sales  
  - Functional Area: Data Import and Export  
  - Task: Schedule Export Processes  
The table ZMM_ACTY_ACTIVITIES with column ACTIVITY_NUMBER holds the existing value.                                                                                                                                                                                                                                                                                                      | If no value is provided, the corresponding value from Assignee production table is used.                                                                                                                                                                                                                                                                                                               | A value is required if you’re associating a new assignee to an activity.  
  One of the following must be provided while creating an assignee:  
  - AssigneeId  
  - AssigneeResourceNumber  
  - Combination of AssigneeOrigSystem and OsrAssigneeId  
  To update or delete an existing activity assignee you must choose one of the following options to identify the record:  
  - The unique ID for the record (ActivityId)  
  - The activity number (ActivityNumber)  
  - The source system code and reference (OrigEntityNumber and OrigEntityCode)                                                                                             |
| AssigneeOrigSystem    | The source system reference to the assigned resource organization.                                                                                                                                                                                                                                                                                                                                    | None                                                                                                                                                                                                                                                                                                                                                                           | A value is required if you’re associating a new assignee to an activity.  
  One of the following must be provided while creating an assignee:  
  - AssigneeId  
  - AssigneeResourceNumber  
  - Combination of AssigneeOrigSystem and OsrAssigneeId                                                                                                                   | Not Required                                                                                                                                                                                                                                                                                                                                                                                                                                       |
| AssigneeResourceNumber| The resource number associated with an assignee.                                                                                                                                                                                                                                                                                                                                                  | None                                                                                                                                                                                                                                                                                                                                                                           | A value is required if you’re associating a new assignee to an activity.  
  One of the following must be provided while creating an assignee:  
  - AssigneeId                                                                                                           | Not Required                                                                                                                                                                                                                                                                                                                                                                                                                                       |
<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/Import Validations</th>
<th>Creating an Activity Assignee record</th>
<th>Updating an Existing Activity Assignee record</th>
</tr>
</thead>
</table>
| OrigEntityCode  | The code indicating the original source of the activity the activity to which the assignee is associated. | Valid values for upgraded records are TASK, APPOINTMENT, or INTERACTION.  
If the record was created in the Activity Management component, the value is ACTIVITY. | Valid values for upgraded records are TASK, APPOINTMENT, or INTERACTION.  
If the record was created in the Activity Management component, the value is ACTIVITY. | A value is required if you're updating or deleting an existing activity and you're not providing other values to identify the activity record.  
To update or delete an existing activity you must choose one of the following options to identify the record:  
• The unique ID for the record (ActivityId)  
• The activity number (ActivityNumber)  
• The source system code and reference (OrigEntityNumber and OrigEntityCode) |
| OrigEntityNumber | The original unique identifier of the existing task, appointment, or interaction in the source system. | If the internal action code is 'INSERT' and OrigEntityNumber and ActivityNumber are NULL then it will be defaulted to the provided value. If no value is provided, the corresponding value from Assignee production table is used. | If the internal action code is 'INSERT' and OrigEntityNumber and ActivityNumber are NULL, the value will be set to the value provided by the user. If no value is provided, the corresponding value is used from the Assignee production table. | A value is required if you're updating or deleting an existing activity and you're not providing other values to identify the activity record.  
To update or delete an existing activity you must choose one of the following options to identify the record:  
• The unique ID for the record (ActivityId)  
• The activity number (ActivityNumber)  
• The source system code and reference (OrigEntityNumber and OrigEntityCode) |
| OsrAssigneeId   | The source system reference of the assignee.                               | The party must exist. You can determine the Original System Reference for the party by exporting the Party object. | A value is required if you're associating a new assignee to an activity. One of the following must be provided while creating an assignee:  
• AssigneeId | Not Required |
Go to Navigator > Tools > Import Management > Import Objects, to see all the attributes of the activity assignee object. The page also lists attribute information like type, length, description, and so on.

Create the Source CSV File
You include the data that you want to import into CX Sales and B2B Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator > Tools > Import Management > Import Objects.
2. Select the Activity Assignee object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note: For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the activity assignee information. To create an import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Activity Assignee from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the **Status** column for the import activity. The import is successful if the status displays as **Completed**. You can drill down on the import activity to go to the **Import Status** page which provides the status details of the import activity.

**Related Topics**
- Import Data
- How You Use Alternate Keys to Import Records
- Potential Issues When Opening CSV Files in Excel

### Import Your Activity Contact Data

You can use Import Management to create, update, or delete your activity contact data.

You can import activity contact records using these steps:

1. Map your source activity contact data to Oracle Applications Cloud object attributes. This way the import process would know where to insert each of the information bits.
2. Create the source CSV file with the activity contact data you want to import.
4. Check the import results to know if the import went well.

### How You Map Your Source Data to Target Object Attributes

You import activity contact data into Oracle Applications Cloud from a CSV file containing your source data that's mapped to target Oracle Applications Cloud object attributes.

You need to do the following before creating the .csv file for data import:

- Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
- Ensure prerequisite steps are complete, such as understanding what attributes are required for importing your objects.
- Understand your options for uniquely identifying the records.
- Ensure parent records exist before importing child records.
- Identify the target object attributes that are required in the .csv file for a successful import

### Before You Start

You must do some basic checks before starting your import. For example, make sure that:

- You have completed all the prerequisites for importing each attribute in your source data.
- You have all parent records in place before importing child records.

### Select a Unique Identifier for Your Records
All records must be unique in the application. You can use one of these to identify records:

- **Public unique identifiers**: If you’re creating records, then you can provide an easily understandable public unique identifier. These are, usually, denoted with ‘Number’ and visible in the business object’s UI. PUID attributes are usually named <object> Number. If you’re updating a record with a Number attribute, then use the Number attribute to identify the record. For more information about public unique identifiers, see the topic "How You Use Alternate Keys to Import Records" in Related Topics section.

- **Source system and source system reference**: Source system is an identifier for the external system, and source system reference is a unique identifier within the external system. If you’re importing new activity contacts or are updating activity contacts that have source system reference data, then provide the source system and source system reference values.

### Required Attributes and Validations for Activity Contact Object

To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Make sure that you provide valid values for these attributes so that they pass import validations inbuilt into the application.

This table lists the required attributes for activity contact records, prerequisite setup tasks and specific validations, if any:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/Import Validations</th>
<th>Creating an Activity Contact record</th>
<th>Updating an Existing Activity Contact record</th>
</tr>
</thead>
<tbody>
<tr>
<td>ActivityId</td>
<td>The internal identifier of the activity to which the contact is associated.</td>
<td>Automatically generated by the import process if creating a new activity record.</td>
<td>The value is generated automatically by the import process if creating a new activity record.</td>
<td>A value is required if you’re updating an existing activity and you’re not providing other values to identify the activity record.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>To update an existing activity, choose one of the following options to identify the record:</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>• The unique ID for the record (ActivityId).</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>• The activity number (ActivityNumber).</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>• The source system code and reference (OrigEntityNumber and OrigEntityCode).</td>
</tr>
<tr>
<td>ActivityNumber</td>
<td>The public unique identifier of the activity to which the contact is associated</td>
<td>If a value is provided while creating a new activity, the value must be unique. For update, you can determine the existing unique value of the object by exporting the Activity object. Navigate to the following in the Setup and Maintenance work area: • Offering: Sales</td>
<td>A value is required if you’re creating a new activity.</td>
<td>A value is required if you’re updating an existing activity and you’re not providing other values to identify the activity record.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>To update an existing activity, choose one of the following options to identify the record:</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>• The unique ID for the record (ActivityId).</td>
</tr>
<tr>
<td>Attribute</td>
<td>Description</td>
<td>Prerequisite Setup Task/Import Validations</td>
<td>Creating an Activity Contact record</td>
<td>Updating an Existing Activity Contact record</td>
</tr>
<tr>
<td>--------------------</td>
<td>------------------------------------------------------------------------------</td>
<td>------------------------------------------------------------------------------------------------------------</td>
<td>------------------------------------------------------------------------------------------------------</td>
<td>-------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>ContactId</td>
<td>The party of type person who's involved with this appointment.</td>
<td>If no value is provided, the corresponding value from the Contacts production table is used.</td>
<td>A value is required if you're associating a new contact to an activity. One of the following must be provided while creating a contact:</td>
<td>To update or delete an existing activity contact, select one of the following options to identify the record:</td>
</tr>
</tbody>
</table>
|                    |                                                                              | • Functional Area: Data Import and Export  
  • Task: Schedule Export Processes  
  The table ZMM_ACTY_ACTIVITIES with column ACTIVITY_NUMBER holds the existing value. | • ContactId  
  • ContactPartyNumber  
  • Combination of ContactOrigSystem and OsrContactId | • The activity number (ActivityNumber).  
  • The source system code and reference (OrigEntityNumber and OrigEntityCode). |
| ContactOrigSystem  | The source system for the activity with which the contact is associated.     | No Validation                                                                                               | A value is required if you're associating a new contact to an activity. One of the following must be provided while creating a contact: | Not Required                                                                                               |
|                    |                                                                              |                                                                                                             | • ContactId  
  • ContactPartyNumber  
  • Combination of ContactOrigSystem and OsrContactId |                                                                                                             |
<p>| ContactPartyNumber | The party number of the contact.                                             | This must be a valid party in the HZ_PARTIES table.                                                        | A value is required if you're associating a new contact to an activity. One of the following must be provided while creating a contact: | This must be a valid party in the HZ_PARTIES table                                                          |</p>
<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/Import Validations</th>
<th>Creating an Activity Contact record</th>
<th>Updating an Existing Activity Contact record</th>
</tr>
</thead>
<tbody>
<tr>
<td>CorpCurrencyCode</td>
<td>The corporate currency used by the activity to which the contact is associated.</td>
<td>If no value is provided, the corresponding value from the Contacts production table is used.</td>
<td>If no value is provided, the corresponding value is used from the Contacts production table.</td>
<td>If no value is provided, the corresponding value is used from the Contacts production table.</td>
</tr>
<tr>
<td>OrigEntityCode</td>
<td>The code indicating the original source of the activity the activity to which the contact is associated.</td>
<td>Valid values for upgraded records are TASK, APPOINTMENT, or INTERACTION.</td>
<td>Valid values for upgraded records are TASK, APPOINTMENT, or INTERACTION.</td>
<td>A value is required if you're updating or deleting an existing activity and you're not providing other values to identify the activity record.</td>
</tr>
<tr>
<td>Note:</td>
<td>If the record was created in the Activity Management component, the value is ACTIVITY.</td>
<td></td>
<td>Note: If the record was created in the Activity Management component, the value is ACTIVITY.</td>
<td>To update or delete an existing activity you must choose one of the following options to identify the record:</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>- The unique ID for the record (ActivityId).</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>- The activity number (ActivityNumber).</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>- The source system code and reference (OrigEntityNumber and OrigEntityCode).</td>
</tr>
<tr>
<td>OrigEntityNumber</td>
<td>The ID that identifies the entity record in the original system.</td>
<td>If the internal action code is 'INSERT' and OrigEntityNumber and ActivityNumber are NULL then it will be defaulted to the provided value. If no value is provided, the corresponding value from Contacts production table is used.</td>
<td>If the internal action code is 'INSERT' and OrigEntityNumber and ActivityNumber are NULL, the value will be set to the value provided by the user. If no value is provided, the corresponding value is used from the Contacts production table.</td>
<td>A value is required if you're updating or deleting an existing activity and you're not providing other values to identify the activity record.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>To update or delete an existing activity you must choose one of the following options to identify the record:</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>- The unique ID for the record (ActivityId).</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>- The activity number (ActivityNumber).</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>- The source system code and reference (OrigEntityNumber and OrigEntityCode).</td>
</tr>
<tr>
<td>OsrContactId</td>
<td>The source system reference of the contact.</td>
<td>The contact must exist in system. You can determine the original system reference for the Contact by exporting the Contacts object.</td>
<td>A value is required if you're associating a new contact to an activity. One of the following must be provided while creating an assignee:</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- ContactId</td>
<td>The contact must exist in system. You can determine the original system reference for the Contact by exporting the Contacts object.</td>
</tr>
</tbody>
</table>
Oracle CX
Understanding Import and Export Management for CX
Sales and B2B Service

Chapter 8
Import Your Data

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/Import Validations</th>
<th>Creating an Activity Contact record</th>
<th>Updating an Existing Activity Contact record</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td>Navigate to the following in the Setup and Maintenance work area:</td>
<td>• ContactPartyNumber</td>
<td>Navigate to the following in the Setup and Maintenance work area:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Offering: Sales</td>
<td>• Combination of ContactOrigSystem and OsrContactId</td>
<td>• Offering: Sales</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Functional Area: Data Import and Export</td>
<td></td>
<td>• Functional Area: Data Import and Export</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Task: Schedule Export Processes</td>
<td></td>
<td>• Task: Schedule Export Processes</td>
</tr>
<tr>
<td>OsrContactOrgId</td>
<td>The source system reference to the contact organization. It is used to update the RELATIONSHIP_ID in the interface table (ZMM_IMP_ACTY_CONTACTS) based on HZ_PARTIES.</td>
<td>This must be a valid organization type in the HZ_PARTIES table.</td>
<td>This must be a valid organization type in the HZ_PARTIES table.</td>
<td>This must be a valid organization type in the HZ_PARTIES table.</td>
</tr>
</tbody>
</table>

Go to Navigator > Tools > Import Management > Import Objects, to see all the attributes of the activity contact object. The page also lists attribute information like type, length, description, and so on.

Create the Source CSV File
You include the data that you want to import into CX Sales and B2B Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator > Tools > Import Management > Import Objects.
2. Select the Activity Contact object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

**Note:** For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the activity contact information. To create an import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Activity Contact from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you’re ready.
Review the Import Results

Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed. You can drill down on the import activity to go to the Import Status page which provides the status details of the import activity.

Related Topics
- Import Data
- Potential Issues When Opening CSV Files in Excel
- How You Use Alternate Keys to Import Records

Import Your Activity Objective Data

You can use Import Management to create, update, or delete your activity objective data.

You can import activity objective records using these steps:

1. Map your source activity objective data to Oracle Applications Cloud object attributes. This way the import process would know where to insert each of the information bits.
2. Create the source CSV file with the activity objective data you want to import.
4. Check the import results to know if the import went well.

How You Map Your Source Data to Target Object Attributes

You import activity objective data into Oracle Applications Cloud from a CSV file containing your source data that's mapped to target Oracle Applications Cloud object attributes.

You need to do the following before creating the .csv file for data import:

- Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
- Ensure prerequisite steps are complete, such as understanding what attributes are required for importing your objects.
- Understand your options for uniquely identifying the records.
- Ensure parent records exist before importing child records.
- Identify the target object attributes that are required in the .csv file for a successful import.

If you want to import only a few records, then you can create a single CSV file for all activity objective attributes. However if you want to import a large number of records, then you may decide to create multiple CSV files, one for each of the activity objective child objects. Note that you must have imported the CSV file for activity objective object successfully before trying to import the CSV files for the child objects. There are separate help topics describing how to import each of these child objects. For more information, see the related topics section.
Before You Start

You must do some basic checks before starting your import. For example, make sure that:

- You have completed all the prerequisites for importing each attribute in your source data.
- You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records

All records must be unique in the application. You can use one of these to identify records:

- Public unique identifiers: If you're creating records, then you can provide an easily understandable public unique identifier. These are, usually, denoted with ‘Number’ and visible in the business object’s UI. PUID attributes are usually named <object> Number. If you're updating a record with a Number attribute, then use the Number attribute to identify the record. For more information about public unique identifiers, see the topic “How You Use Alternate Keys to Import Records” in Related Topics section.
- Source system and source system reference: Source system is an identifier for the external system, and source system reference is a unique identifier within the external system. If you're importing new activity objectives or are updating activity objectives that have source system reference data, then provide the source system and source system reference values.

Required Attributes and Validations for Activity Objective Object

To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Make sure that you provide valid values for these attributes so that they pass import validations inbuilt into the application.

This table lists the required attributes for activity objective records, prerequisite setup tasks and specific validations, if any:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/Import Validations</th>
<th>Creating an Activity Objective record</th>
<th>Updating an Existing Activity Objective record</th>
</tr>
</thead>
<tbody>
<tr>
<td>ActionCode</td>
<td>Indicates explicitly the operation to be performed on a row: INSERT to create a new record in the destination tables, UPDATE to update an existing record in the destination table, DELETE to delete the record.</td>
<td>If value isn't provided, record matching is used to determine whether a record is updated (if it already exists) or inserted (if it doesn't exist). The valid values are INSERT, UPDATE, and DELETE.</td>
<td>Optional</td>
<td>To delete a record, you must provide the value as DELETE. It is optional to provide values for insert and update as the framework internally decides the action as INSERT if it’s a new record or UPDATE if it’s an existing record.</td>
</tr>
<tr>
<td>ActivityId</td>
<td>The internal identifier of the activity to which the Objective is associated.</td>
<td>Automatically generated by the import process if creating a new activity record.</td>
<td>A value is required if you're updating or deleting an existing activity and you're not providing other values to identify the activity record. To update or delete an existing activity you must choose one of the following</td>
<td>A value is required if you're updating or deleting an existing activity and you're not providing other values to identify the activity record. To update or delete an existing activity you must choose one of the following</td>
</tr>
<tr>
<td>Attribute</td>
<td>Description</td>
<td>Prerequisite Setup Task/Import Validations</td>
<td>Creating an Activity Objective record</td>
<td>Updating an Existing Activity Objective record</td>
</tr>
<tr>
<td>-----------------</td>
<td>-----------------------------------------------------------------------------</td>
<td>----------------------------------------------------------------------------------------------------------</td>
<td>--------------------------------------------------------------------------------------------------------</td>
<td>---------------------------------------------------------------------------------------------------------------</td>
</tr>
</tbody>
</table>
| **ActivityNumber** | The public unique identifier of the activity to which the Objective is associated | If a value is provided while creating a new activity, the value must be unique. For update, you can determine the existing unique value of the object by exporting the Activity object. Navigate to the following in the Setup and Maintenance work area:  
- Offering: Sales  
- Functional Area: Data Import and Export  
- Task: Schedule Export Processes  
The table ZMM_ACTY_ACTIVITIES with column ACTIVITY_NUMBER holds the existing value. | A value is required if you’re:  
- Creating an activity  
- Updating or deleting an existing activity and you’re not providing other values to identify the activity record.  
To update or delete an existing activity you must choose one of the following options to identify the record:  
- The unique ID for the record (ActivityId).  
- The activity number (ActivityNumber).  
- The source system code and reference (OrigEntityNumber and OrigEntityCode). | A value is required if you’re updating an existing activity and you’re not providing other values to identify the activity record. To update or delete an existing activity you must choose one of the following options to identify the record:  
- The unique ID for the record (ActivityId).  
- The activity number (ActivityNumber).  
- The source system code and reference (OrigEntityNumber and OrigEntityCode). |
<p>| <strong>ObjectiveCode</strong> | The set of predefined objectives defined by the administrator | A value is required if you’re associating a new objective to an activity and you’re not providing other values to identify | A value is required if you’re associating a new objective to an activity and you’re not providing other values to identify | A value is required if you’re associating a new objective to an activity and you’re not providing other values to identify |</p>
<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/Import Validations</th>
<th>Creating an Activity Objective record</th>
<th>Updating an Existing Activity Objective record</th>
</tr>
</thead>
</table>
| ObjectiveFreefmtText | The objective in free form text as provided by the user.                    | a value is required if you're associating a new objective to an activity and you're not providing other values to identify the objective record. You must choose one of the following options to identify the objective record:  
  - ObjectiveId  
  - Combination of ActivityId and (ObjectiveCode or ObjectiveFreefmtText) | a value is required if you're associating a new objective to an activity and you're not providing other values to identify the objective record. You must choose one of the following options to identify the objective record:  
  - ObjectiveId  
  - Combination of ActivityId and (ObjectiveCode or ObjectiveFreefmtText) | a value is required if you're associating a new objective to an activity and you're not providing other values to identify the objective record. You must choose one of the following options to identify the objective record:  
  - ObjectiveId  
  - Combination of ActivityId and (ObjectiveCode or ObjectiveFreefmtText) |
| ObjectiveId         | The internal identifier of the objective associated with the activity.       | if no value is provided, the corresponding value from the Objectives production table is used.             | a value is required if you're associating a new objective to an activity and you're not providing other values to identify the objective record. You must choose one of the following options to identify the objective record:  
  - ObjectiveId  
  - Combination of ActivityId and (ObjectiveCode or ObjectiveFreefmtText) | a value is required if you're associating a new objective to an activity and you're not providing other values to identify the objective record. You must choose one of the following options to identify the objective record:  
  - ObjectiveId  
  - Combination of ActivityId and (ObjectiveCode or ObjectiveFreefmtText) |
| OrigEntityCode      | The code indicating the original source of the activity the activity to which the Objective is associated. | Valid values for upgraded records are TASK, APPOINTMENT, or INTERACTION.                                  | Valid values for upgraded records are TASK, APPOINTMENT, or INTERACTION.                                  | Valid values for upgraded records are TASK, APPOINTMENT, or INTERACTION.                                      |
|                    |                                                                              | if the record was created in the Activity Management component, the value is ACTIVITY.                    | If the record was created in the Activity Management component, the value is ACTIVITY.                    | If the record was created in the Activity Management component, the value is ACTIVITY.                      |
| OrigEntityNumber    | The original unique identifier of the existing task, appointment, or...       | Valid values for upgraded records are TASK, APPOINTMENT, or INTERACTION.                                  | Valid values for upgraded records are TASK, APPOINTMENT, or INTERACTION.                                  | Valid values for upgraded records are TASK, APPOINTMENT, or INTERACTION.                                      |
# Create the Source CSV File

You include the data that you want to import into CX Sales and B2B Service in a source CSV file. You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to **Navigator > Tools > Import Management > Import Objects**.
2. Select the **Activity Objective** object in the table and click **Download**.

You can now edit the downloaded file and provide valid values for the required attributes.

**Note:** For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.

# Create the Import Activity

After you have the CSV file ready, create an import activity to import the activity objective information. To create an import activity:

1. Go to **Navigator > Tools > Import Management > Import Queue**.
2. Click **Create Import Activity** in the **Manage Imports** page.
3. In the **Enter Import Options** page, provide a name for the import activity, and select Activity Objective from the **Object** drop-down list.
4. Select the CSV file in the **File Name** field, and click **Next**.
5. You would see that the source and target attributes are automatically mapped in the **Map Fields** page. Review and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking **Validate Data**. Click **Next**.
7. Review the import details on the **Review and Submit** page, and click **Submit** when you're ready.

# Review the Import Results

Check if your import succeeded on the **Manage Imports** page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to **Navigator > Tools > Import Management > Import Queue**.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the **Status** column for the import activity. The import is successful if the status displays as **Completed**. You can drill down on the import activity to go to the **Import Status** page which provides the status details of the import activity.

---

### Attribute Table

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/Import Validations</th>
<th>Creating an Activity Objective record</th>
<th>Updating an Existing Activity Objective record</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>interaction in the source system.</td>
<td>If the record was created in the Activity Management component, the value is ACTIVITY</td>
<td>If the record was created in the Activity Management component, the value is ACTIVITY</td>
<td>If the record was created in the Activity Management component, the value is ACTIVITY</td>
</tr>
</tbody>
</table>

Go to **Navigator > Tools > Import Management > Import Objects**, to see all the attributes of the activity objective object. The page also lists attribute information like type, length, description, and so on.
Import Your Additional Name Data

Use this topic to import Additional Name data into Oracle Applications Cloud. You can use the import functionality to create, update, or delete Additional Name records.

To import Additional Name records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Object Attributes

To import your Additional Name data into Oracle Applications Cloud, you must populate a .csv file with your source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

- Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
- Ensure prerequisite setups are done, if applicable.
- Understand your options for uniquely identifying the records.
- Ensure parent records exist before importing child records.
- Identify the target object attributes that are required in the CSV file for a successful import.

Before You Start

You need to set certain options for some attributes in the application before you can populate them. When importing a child record, ensure that its parent record exists in the database.

Select a Unique Identifier for Your Records

To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the import process to uniquely identify the records. The file import process uses the attribute values to automatically map your source data to the target object attributes in Oracle Applications Cloud.

The preferred option to uniquely identify an object record is through the Internal ID. If you're identifying a record that already exists in Oracle Applications Cloud, then you can use the internal ID of the record, a system-generated unique identifier. Attributes with "id" in the attribute name are typically internal IDs. You can determine the internal ID of a record by exporting Oracle Applications Cloud object data, or by doing a transactional database query. Using an internal ID typically provides better performance and reduces the import duration. For the Additional Name object, the attributes are NameID and RegistryID.
Required Attributes and Validations

To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure that you provide valid values for the attributes. The following table lists the required attributes for importing new Additional Name records, required attributes for updating Additional Name records, prerequisite setup tasks for the attributes, and specific validations, if any, for Additional Name import:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/Import Validations</th>
<th>Creating an Additional Name Record</th>
<th>Updating an Existing Additional Name Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>NameId</td>
<td>Unique identifier of the address record as the primary key</td>
<td>No Validation</td>
<td>Not required</td>
<td>Optional</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Either the NameId or a combination of Source System and Source System Reference can be passed.</td>
</tr>
<tr>
<td>StatusFlag</td>
<td>The status of the additional name</td>
<td>Defaults to Y during creation.</td>
<td>Not required</td>
<td>To inactivate an existing active Additional Name record, provide the value as &quot;N&quot;.</td>
</tr>
<tr>
<td>NameType</td>
<td>Additional Name Type</td>
<td>This must be a valid name type. The name types can be managed in Manage Name Types.</td>
<td>Required</td>
<td>If you don't provide the primary key, provide the existing additional name type.</td>
</tr>
<tr>
<td>PartyNumber</td>
<td>The public unique identifier of the party record to which the Additional Name is associated.</td>
<td>The party number should exist.</td>
<td>Conditionally required</td>
<td>Not required</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Provide reference information to identify the existing party. The reference information can be:</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• PartyId (internal ID)</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• PartySourceSystem and PartySourceSystemReference (source system code and source system reference values) provided when importing the organization profile</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• Party Number (public unique identifier for an organization profile)</td>
<td></td>
</tr>
<tr>
<td>PartySourceSystem</td>
<td>The code representing the source system for the party (account, contact, household, or legal entity) to which the Additional name belongs.</td>
<td>Identify the source system code that was used when you imported the party in a prior batch, or identify the source system code that you will use when importing the party in</td>
<td>Conditionally required</td>
<td>Not required</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Provide one of the following:</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• PartyId (internal ID)</td>
<td></td>
</tr>
</tbody>
</table>
## Attribute Import and Export Management for CX Sales and B2B Service

### Chapter 8

**Import Your Data**

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/Import Validations</th>
<th>Creating an Additional Name Record</th>
<th>Updating an Existing Additional Name Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>Attribute</td>
<td>Description</td>
<td>Prerequisite Setup Task/Import Validations</td>
<td>Creating an Additional Name Record</td>
<td>Updating an Existing Additional Name Record</td>
</tr>
<tr>
<td>Attribute</td>
<td>Description</td>
<td>Prerequisite Setup Task/Import Validations</td>
<td>Creating an Additional Name Record</td>
<td>Updating an Existing Additional Name Record</td>
</tr>
<tr>
<td>Attribute</td>
<td>Description</td>
<td>Prerequisite Setup Task/Import Validations</td>
<td>Creating an Additional Name Record</td>
<td>Updating an Existing Additional Name Record</td>
</tr>
<tr>
<td>Attribute</td>
<td>Description</td>
<td>Prerequisite Setup Task/Import Validations</td>
<td>Creating an Additional Name Record</td>
<td>Updating an Existing Additional Name Record</td>
</tr>
<tr>
<td>Attribute</td>
<td>Description</td>
<td>Prerequisite Setup Task/Import Validations</td>
<td>Creating an Additional Name Record</td>
<td>Updating an Existing Additional Name Record</td>
</tr>
</tbody>
</table>

### PartySourceSystemReference

The reference number or text representing the source system unique ID for the party (account, contact, household, or legal entity) to which the Additional Name belongs.

Identify the reference value from your source system that was used when you imported the party in a prior batch, or identify the source system reference that you will use when importing the party in the same batch as this Additional Name.

Conditionally required

Provide one of the following:

- **PartyId (internal ID)**
- **PartySourceSystem and PartySourceSystemReference** (source system code and source system reference values) provided when importing the organization profile
- **Party Number (public unique identifier for an organization profile)**

Not required

### PartyId

The unique identifier as primary key of the party record to which the additional name is associated.

Identify the party ID value by exporting the relevant Party object such as Account, Contact, and so on.

Conditionally required

Provide one of the following:

- **PartyId (internal ID)**
- **PartySourceSystem and PartySourceSystemReference** (source system code and source system reference values) provided when importing the organization profile
- **Party Number (public unique identifier for an organization profile)**

Not required

### SourceSystem

Name of external source system of the account, contact or household

The source system should exist.

Optional

Not required
You can view the Additional Name object and attributes in the Manage Import Objects page of the Import Management flow. You can find attribute information like type, length, description, and so on, on this page.

Create the Source CSV File

The CSV file is provided as input to the file-based data import process. You must populate the CSV file with the data you want to import into Oracle Applications Cloud.

You can either create a CSV file on your own or use templates available in preexisting mappings. To download a template, do the following:

1. In the Navigator, under Tools, click Import Management.
2. Click Import Objects tab to open the Import Object Details page.
3. Select the object you’re interested in the Import Object Details page and click the Download icon next to that object name.
4. Save the template CSV file to a location on your desktop.

You must edit the template CSV file and provide valid values for the required attributes. You can attach different types of files, giving each file a specific description.
Create the Import Activity

To import data into Oracle Applications Cloud, you need to create an import activity and provide the CSV file as an input to the activity.

To create an import activity, do the following:

1. In the Navigator, under Tools, click Import Management.
2. On the Manage Imports page, click Create Import Activity.
3. In the Create Import Activity: Enter Import Options page, provide a name for the import activity, and select Additional Name from the Object drop-down list.
4. In File Name, browse and upload the required .CSV file, and click Next.
5. In the Create Import Activity: Map Fields page edit the attribute mappings if required, and click Next.
   
   Note: Click Validate Data to validate the mapping of the source file for unmapped columns and to check for data format issues.

6. In the Create Import Activity: Review and Submit page, click Submit.

Review the Import Results

You can review the import results by checking for the import activity in the Manage Import Activity page. A file import activity is said to be successful when its status displays as Completed. To check the status of the import activity, do as follows:

1. In the Navigator, under Tools, click Import Management.
2. On the Manage Imports page, search for the import activity that you created using one of the search criteria, such as status, name, object, and so on.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed. The other valid values for the import activity status are Queued for import, Preparing data for import, Importing data, Completed with errors, and Unsuccessful.

Note: On this page you can also quickly view the number and status of all active imports, completed imports, and unsuccessful imports that have been submitted.

Related Topics

- Import Data

Import Your Additional Identifier Data

You can use Import Management to create or update Additional Identifier records.

To import Additional Identifier records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.
How You Map Your Source Data to Object Attributes

To import your Additional Identifier data into Oracle Applications Cloud, you must populate a .csv file with your source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

- Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
- Ensure prerequisite setups are done, if applicable.
- Understand your options for uniquely identifying the records.
- Ensure parent records exist before importing child records.
- Identify the target object attributes that are required in the CSV file for a successful import.

Before You Start

You must do some basic checks before starting your import. For example, make sure that:

- You have completed all the prerequisites for importing each attribute in your source data.
- You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records

To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the import process to uniquely identify the records. The file import process uses the attribute values to automatically map your source data to the target object attributes in Oracle Applications Cloud.

The preferred options to uniquely identify an object record are as follows:

- Internal ID: If you're identifying a record that already exists in Oracle Applications Cloud, then you can use the internal ID of the record, a system-generated unique identifier Attributes with "id" in the attribute name are typically internal IDs. Use this option only if you're updating Additional Identifiers. You can determine the internal ID of a record by exporting Oracle Applications Cloud object data, or by doing a transactional database query. Using an internal ID typically provides better performance and reduces the import duration. For the Additional Identifier object, the attributes are PartyIdentifierID and PartyID.

- Public unique identifiers: If you're creating new records, then you can provide a user-friendly public unique identifier (attributes denoted with 'Number' and usually visible in the business object's UI). If you update a record for which you have previously provided a Number attribute, or for which a Number attribute is visible in the object’s UI, you can use the Number attribute to identify the record. For the Additional Identifier object, the attribute is PartyNumber.

Required Attributes and Validations for the Additional Identifier Object

To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure that you provide valid values for the attributes. The following table lists the required attributes for importing new Additional Identifier records, required attributes for updating Additional Identifier records, prerequisite setup tasks for the attributes, and specific validations, if any, for Additional Identifier import:
<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/ Import Validations</th>
<th>Creating a Additional Identifier Record</th>
<th>Updating an Existing Additional Identifier Record</th>
</tr>
</thead>
</table>
| PartySourceSystem               | The code representing the source system for the party (account, contact, household, or legal entity) to which the Additional identifier belongs | Identify the source system code that was used when you imported the party in a prior batch, or identify the source system code that you will use when importing the party in the same batch as this Additional identifier. | Conditionally required Provide reference information to identify the existing party. The reference information can be:  
  • PartyId (internal ID)  
  • PartySourceSystem and PartySourceSystemReference (source system code and source system reference values) provided when importing the organization profile  
  • Party Number (public unique identifier for an organization profile) | Not required                                                                         |
| PartySourceSystemReferenceValue | The reference number or text representing the source system unique ID for the party (account, contact, household, or legal entity) to which the Additional identifier belongs. | Identify the reference value from your source system that was used when you imported the party in a prior batch, or identify the source system reference that you will use when importing the party in the same batch as this Additional identifier. | Conditionally required Provide reference information to identify the existing party. The reference information can be:  
  • PartyId (internal ID)  
  • PartySourceSystem and PartySourceSystemReference (source system code and source system reference values) provided when importing the organization profile  
  • Party Number (public unique identifier for an organization profile) | Not required                                                                         |
| PartyIdentifierID               | Unique identifier of the additional identifier of the party                  | No validation                               | Not required                                                                                           | Required                                           |
| StatusCode                      | The status of the additional identifier                                     | Not required                                | Not required                                                                                           | To inactivate existing active Additional Name record, provide the value as N. |
### Attribute Details

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/Import Validations</th>
<th>Creating a Additional Identifier Record</th>
<th>Updating an Existing Additional Identifier Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>PartyIdentifierType</td>
<td>The type of the Additional Identifier import</td>
<td>The Identifier Type must exist. You can manage additional types using the Manage Additional Name Types task.</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td>PartyIdentifierValue</td>
<td>Value to be imported for the Identifier Type</td>
<td>Mandatory field</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td>PartyNumber</td>
<td>The public unique identifier of the party record to which the Additional identifier is associated.</td>
<td>The party number should exist.</td>
<td>Conditionally required</td>
<td>Not required</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Provide reference information to identify the existing party. The reference information can be:</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>• PartyId (internal ID)</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>• PartySourceSystem and PartySourceSystemReference (source system code and source system reference values) provided when importing the organization profile</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Party Number (public unique identifier for an organization profile)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>PartyID</td>
<td>The unique identifier as primary key of the party record to which the additional identifier is associated.</td>
<td>Identify the party ID value by exporting the relevant Party object such as Account, Contact, and so on.</td>
<td>Conditionally required</td>
<td>Not required</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Provide reference information to identify the existing party. The reference information can be:</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>• PartyId (internal ID)</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>• PartySourceSystem and PartySourceSystemReference (source system code and source system reference values) provided when importing the organization profile</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Party Number (public unique identifier for an organization profile)</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
## Import Your Data

### Attribute | Description | Prerequisite Setup Task/Import Validations | Creating a Additional Identifier Record | Updating an Existing Additional Identifier Record
--- | --- | --- | --- | ---
SourceSystem | Name of external source system of the account, contact or household with which the Additional identifier is associated. | The source system should exist. You can manage source systems from the Manage Source Systems task. | Optional If the source of your data is a third party or external system, and you intend to import updates to previously imported records from the same system, provide the original source system and source system reference values. | Not required
SourceSystemReferenceValue | Specifies the identifier in the original source system. | The combination of Source System and Source System Reference Value should be unique. | Optional If the source of your data is a third party or external system, and you intend to import updates to previously imported records from the same system, provide the original source system and source system reference values. | Not required

You can view the Additional Identifier object and attributes in the Manage Import Objects page of the Import Management flow. You can find attribute information like type, length, description, and so on, on this page.

### Create the Source CSV File

You include the data that you want to import into CX Sales and B2B Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator > Tools > Import Management > Import Objects.
2. Select the Additional Identifier object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

**Note:** For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.

### Create the Import Activity

After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Additional Identifier from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. The source and target attributes are automatically mapped in the Map Fields page. Review and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you’re ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed. You can drill down on the import activity to go to the Import Status page which provides the status details of the import activity.

Related Topics
• Potential Issues When Opening CSV Files in Excel
• Import Data

Import Your Address Data
You can use the import functionality to create, update, or delete address records.

You can import address records using these steps:

1. Map your source data to Oracle Applications Cloud object attributes. This way the import process would know where to insert each of the information bits.
2. Create the source CSV file with the address data you want to import.
4. Check the import results to know if the import went well.

How You Map Your Source Data to Target Object Attributes
You import address data into Oracle Applications Cloud from a CSV file containing your source data that’s mapped to target Oracle Applications Cloud object attributes.

Before you create the source data file, you should:

- Know how your source data attributes map to the target object attributes in Oracle Applications Cloud. Match each column from the source file to an attribute in the address import object.
- Finish all prerequisite steps, such as understanding what attributes are required for importing your objects.
- Know how you can uniquely identify the records.
- Check the target object attributes required in the CSV file for a successful import.
- Ensure that you don’t insert duplicate addresses while importing, to avoid redundant data.

If you want to import only a few records, then you can create a single CSV file for all address attributes. However if you want to import a large number of records, then you may decide to create multiple CSV files, one for each of the address
child objects. Note that you must have imported the CSV file for address object successfully before trying to import the CSV files for the child objects. There are separate help topics describing how to import each of these child objects.

Before You Start

You must do some basic checks before starting your import. For example, make sure that:

- You have completed all the prerequisites for importing each attribute in your source data.
- You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records

All records must be unique in the application. You can use one of these to identify records:

- Public unique identifiers: If you’re creating records, then you can provide an easily understandable public unique identifier. These are, usually, denoted with ‘Number’ and visible in the business object’s UI. PUID attributes are usually named <object> Number. If you’re updating a record with a Number attribute, then use the Number attribute to identify the record. For more information about public unique identifiers, see the topic “How You Use Alternate Keys to Import Records” in Related Topics section.

- Source system and source system reference: Source system is an identifier for the external system, and source system reference is a unique identifier within the external system. If you’re importing new address or are updating address that have source system reference data, then provide the source system and source system reference values.

Required Attributes and Validations for Address Object

To import data successfully into Oracle Applications Cloud, your .CSV file must include the required attributes. Ensure that you provide valid values for the attributes.

This table lists the required attributes for address records, prerequisite setup tasks and specific validations, if any:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/ Import Validations</th>
<th>Creating an Address record</th>
<th>Updating an Existing Address record</th>
</tr>
</thead>
<tbody>
<tr>
<td>PartyId</td>
<td>The internal ID for the party (account, contact, household, or legal entity) to which the address belongs</td>
<td>Identify the party ID value by exporting the relevant Party object such as Account, Contact, and so on.</td>
<td>Conditionally Required Provide reference information to identify the existing party. The reference information can be: - PartyId (internal ID) - PartySourceSystem and PartySourceSystemReference (source system code and source system reference values) provided when importing the organization profile. - Party Number (public unique identifier)</td>
<td>Conditionally Required Provide reference information to identify the existing party. The reference information can be: - PartyId (internal ID) - PartySourceSystem and PartySourceSystemReference (source system code and source system reference values) provided when importing the organization profile. - Party Number (public unique identifier)</td>
</tr>
<tr>
<td>Attribute</td>
<td>Description</td>
<td>Prerequisite Setup Task/ Import Validations</td>
<td>Creating an Address record</td>
<td>Updating an Existing Address record</td>
</tr>
<tr>
<td>----------------------------</td>
<td>------------------------------------------------------------------------------</td>
<td>--------------------------------------------</td>
<td>---------------------------------------------------------------------------------------------</td>
<td>--------------------------------------</td>
</tr>
</tbody>
</table>
| PartyNumber                | The code representing the source system for the party (account, contact, household, or legal entity) to which the address belongs. | Identify the party ID value by exporting the relevant Party object such as Account, Contact, and so on. | Conditionally Required Provide reference information to identify the existing party. The reference information can be:  
  - PartyId (internal ID)  
  - PartySourceSystem and PartySourceSystemReference (source system code and source system reference values) provided when importing the organization profile.  
  - Party Number (public unique identifier for an organization profile), which is PARTY_SITE_ NUMBER for address | Conditionally Required Provide reference information to identify the existing party. The reference information can be:  
  - PartyId (internal ID)  
  - PartySourceSystem and PartySourceSystemReference (source system code and source system reference values) provided when importing the organization profile.  
  - Party Number (public unique identifier for an organization profile), which is PARTY_SITE_ NUMBER for address |
| PartySourceSystem          | The code representing the source system for the party (account, contact, household, or legal entity) to which the address belongs. | Identify the source system code that was used when you imported the party in a prior batch, or identify the source system code that you will use when importing the party in the same batch as this address | Conditionally Required Provide reference information to identify the existing party. The reference information can be:  
  - PartyId (internal ID)  
  - PartySourceSystem and PartySourceSystemReference (source system code and source system reference values) provided when importing the organization profile.  
  - Party Number (public unique identifier for an organization profile), which is PARTY_SITE_ NUMBER for address | Conditionally Required Provide reference information to identify the existing party. The reference information can be:  
  - PartyId (internal ID)  
  - PartySourceSystem and PartySourceSystemReference (source system code and source system reference values) provided when importing the organization profile.  
  - Party Number (public unique identifier for an organization profile), which is PARTY_SITE_ NUMBER for address |
<p>| PartySourceSystemReference | The reference number or text representing the source system unique ID          | Identify the reference value from your source system that was used when you imported the party | Conditionally Required                                                             | Conditionally Required                                                             |</p>
<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/Import Validations</th>
<th>Creating an Address record</th>
<th>Updating an Existing Address record</th>
</tr>
</thead>
<tbody>
<tr>
<td>PrimaryFlag</td>
<td>Identifies the primary address for the parent party record.</td>
<td>Only one of the child records can be Primary.</td>
<td>Optional</td>
<td>Optional</td>
</tr>
<tr>
<td>Status</td>
<td>Indicates the current status of the address record.</td>
<td>Not required</td>
<td>Not required</td>
<td>Optional</td>
</tr>
<tr>
<td>AddressId</td>
<td>Unique identifier of the address record as primary key.</td>
<td>No validation</td>
<td>Not required</td>
<td>Optional</td>
</tr>
<tr>
<td>Country</td>
<td>The country code component of the postal address.</td>
<td>Identify valid country codes.</td>
<td>Required</td>
<td>Not required.</td>
</tr>
<tr>
<td>LocationId</td>
<td>The unique ID for the existing location record in the destination table.</td>
<td>Identify the LOCATION_ID for an existing location by exporting the Location object.</td>
<td>Optional</td>
<td>Optional</td>
</tr>
<tr>
<td>StartDateActive</td>
<td>The date on which the address becomes valid.</td>
<td>No validation</td>
<td>This is a PUID for Address. If a value is passed, it will be</td>
<td>The Address record can be updated by passing the Address Number.</td>
</tr>
</tbody>
</table>
Understanding Import and Export Management for CX
Sales and B2B Service

### Import Your Data

#### Attribute

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/Import Validations</th>
<th>Creating an Address record</th>
<th>Updating an Existing Address record</th>
</tr>
</thead>
<tbody>
<tr>
<td>AddressNumber</td>
<td>The address internal unique identifier that's internally generated when creating an address</td>
<td>None</td>
<td>This is a PUID for Address. If a value is passed, it will be imported. Otherwise, it will be auto-generated.</td>
<td>The Address record can be updated by passing the Address Number.</td>
</tr>
<tr>
<td>SourceSystem</td>
<td>Name of external source system of the account, contact or household with which the address is associated.</td>
<td>The source system should exist. You can manage source systems from the Manage Source Systems task.</td>
<td>Optional</td>
<td>Not required</td>
</tr>
<tr>
<td>SourceSystemReferenceValue</td>
<td>Specifies the identifier in the original source system</td>
<td>Combination of Source System and Source System Reference Value should be unique.</td>
<td>Optional</td>
<td>Not required</td>
</tr>
<tr>
<td>DoNotValidateFlag</td>
<td>Option to indicate that a specific location isn't eligible for address validation</td>
<td>No validation</td>
<td>Optional</td>
<td>Optional</td>
</tr>
<tr>
<td>DunsNumberC</td>
<td>A unique nine-digit identification number assigned to business entities by Dun and Bradstreet</td>
<td>No validation</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>PartySiteName</td>
<td>User defined name for the site</td>
<td>No validation</td>
<td>Not required</td>
<td>Not required</td>
</tr>
</tbody>
</table>

Go to Navigator > Tools > Import Management > Import Objects, to see all the attributes of the address object. The page also lists attribute information like type, length, description, and so on.

### Create the Source CSV File

You include the data that you want to import into CX Sales and B2B Service in a source CSV file.
You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator > Tools > Import Management > Import Objects.
2. Select the Address object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Providing the ZIP and Country Code values in the import CSV file will not automatically populate the State/County/City fields. Values for these fields should be separately provided in the import file.

**Note:** For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity

After you have the CSV file ready, create an import activity to import the address information. To create an import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. On the Manage Imports page, click Create Import Activity.
3. In the Create Import Activity: Enter Import Options page, provide a name for the import activity, and select Address from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you’re ready.

Review the Import Results

Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed. You can drill down on the import activity to go to the Import Status page which provides the status details of the import activity.

**Note:** After importing data successfully, you need to run the following scheduled processes:

1. Validate Geographies of Addresses against Master Geographies: This job helps you validate an address against master geography data and generates geography naming references. For more information about the Validate Geographies of Addresses against Master Geographies post processing job, see the section "Validate Geographies of Addresses against Master Geographies" in the Understanding Scheduled Processes guide.
2. Populate Location Latitude and Longitude Information: This job helps you select and geocode newly created or updated addresses at regular time intervals. For more information about the Populate Location Latitude and Longitude Information post processing job, see the section "Populate Location Latitude and Longitude Information" in the Understanding Scheduled Processes guide.
Related Topics

• How You Use Alternate Keys to Import Records
• Potential Issues When Opening CSV Files in Excel

Import Your Address Locale Data

You can use Import Management to create, update, or delete your address locale data.

You can import address locale records using these steps:

1. Map your source address locale data to Oracle Applications Cloud object attributes. This way the import process would know where to insert each of the information bits.
2. Create the source CSV file with the address locale data you want to import.
4. Check the import results to know if the import went well.

How You Map Your Source Data to Target Object Attributes

You import address locale data into Oracle Applications Cloud from a CSV file with your source data that’s mapped to target object attributes.

Before you create the source data file, you should:

• Know how your source data attributes map to the target object attributes in Oracle Applications Cloud. Match each column from the source file to an attribute in the address locale import object.
• Finish all prerequisite steps, such as understanding what attributes are required for importing your objects.
• Know how you can uniquely identify the records.
• Check the target object attributes required in the CSV file for a successful import.

Before You Start

You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for each attribute in your source data.
• You have all the parent records in place before importing child records. For example, when importing the address locale, ensure the address exists.

Select a Unique Identifier for Your Records

All records must be unique in the application. You can use one of these to identify records:

• Public unique identifiers: If you’re creating records, then you can provide an easily understandable public unique identifier. These are, usually, denoted with ‘Number’ and visible in the business object's UI. PUID attributes are usually named <object> Number. If you’re updating a record with a Number attribute, then use the Number attribute to identify the record. For more information about public unique identifiers, see the topic "How You Use Alternate Keys to Import Records" in Related Topics section.
Source system and source system reference: Source system is an identifier for the external system, and source system reference is a unique identifier within the external system.

### Required Attributes and Validations for Address Locale Object

To import data into Oracle Applications Cloud, your CSV file must include the required attributes. Make sure that you provide valid values for these attributes so that they pass import validations inbuilt into the application. This table lists the required attributes for address locale records, prerequisite setup tasks for the attributes, and specific validations, if any.

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/ Import Validations</th>
<th>Creating an Address Locale Record</th>
<th>Updating an Existing Address Locale Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>LocationId</td>
<td>Location ID</td>
<td>To obtain a list of all locations, export the address object.</td>
<td>Conditionally required</td>
<td>Conditionally required</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>To create address locale record, one of the following is required:</td>
<td>To update an existing address locale record, one of the following is required:</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• Combination of SiteSourceSystem and SiteSourceSystemReference</td>
<td>• Combination of SiteSourceSystem and SiteSourceSystemReference</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• AddressNumber</td>
<td>• AddressNumber</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• LocationId</td>
<td>• LocationId</td>
</tr>
<tr>
<td>LocationLocaleId</td>
<td>Address Locale ID. The unique ID for the existing address locale record.</td>
<td>N/A</td>
<td>Not required</td>
<td>If available, you can provide this to update other attributes</td>
</tr>
<tr>
<td>AddressNumber</td>
<td>Party site number of the address locale.</td>
<td>To obtain a list of all address IDs and address numbers, export the address object.</td>
<td>Conditionally required</td>
<td>Conditionally required</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>To create address locale record, one of the following is required:</td>
<td>To update an existing address locale record, one of the following is required:</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• Combination of SiteSourceSystem and SiteSourceSystemReference</td>
<td>• Combination of SiteSourceSystem and SiteSourceSystemReference</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• AddressNumber</td>
<td>• AddressNumber</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• LocationId</td>
<td>• LocationId</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• LocationLocaleId</td>
<td>• LocationLocaleId</td>
</tr>
<tr>
<td>SiteSourceSystem</td>
<td>Source system of the address</td>
<td>Know the source system. To view source systems, use the Manage Trading Community Source System task.</td>
<td>Conditionally required</td>
<td>Conditionally required</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>To create address locale record, one of the following is required:</td>
<td>To update an existing address locale record, one of the following is required:</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• Combination of SiteSourceSystem and SiteSourceSystemReference</td>
<td>• Combination of SiteSourceSystem and SiteSourceSystemReference</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• AddressNumber</td>
<td>• AddressNumber</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• LocationId</td>
<td>• LocationId</td>
</tr>
</tbody>
</table>
Go to **Navigator > Tools > Import Management > Import Objects**, to see all the attributes of the address locale object. The page also lists attribute information like type, length, description, and so on.

### Create the Source CSV File

You include the data you want to import into Oracle Applications Cloud in a CSV file.

You can use the templates available in the Import Object Details page to create the source CSV file. To download a template:

1. Go to **Navigator > Tools > Import Management > Import Objects**.
2. Select the Address Locale object in the table and click **Download**.

You can now edit the downloaded file and provide valid values for the required attributes.

**Note:** For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.

### Create the Import Activity

After you have the CSV file ready, create an import activity to import the address locale information.

To create an import activity:

1. Go to **Navigator > Tools > Import Management > Import Queue**.
2. Click **Create Import Activity** button on the **Manage Imports** page.
3. In the **Enter Import Options** page, provide a name for the import activity, and select Address Locale from the **Object** drop-down list.
4. Select the CSV file in the **File Name**, field, and click **Next**.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review and edit the mappings if required. Click Next.

6. Check the file for unmapped columns or data format issues by clicking Validate Data.

7. Review the import details on the Review and Submit page and click Submit when you're ready.

**Review the Import Results**

Check if your import succeeded on the Manage Import Activity page. This page has the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click All Imports and search for the import activity that you created earlier. The Import Status column shows the status of the import activity.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed. You can drill down on the import activity to go to the Import Status page which provides the status details of the import activity.

**Related Topics**

- How You Use Alternate Keys to Import Records
- Potential Issues When Opening CSV Files in Excel

**Import Your Address Purpose Data**

You can use the import functionality to create or update Address Purpose records.

You can import Address Purpose records using these steps:

1. Map your source data to Oracle Applications Cloud object attributes. This way the import process would know where to insert each of the information bits.
2. Create the source CSV file with the Address Purpose data you want to import.
4. Check the import results to know if the import went well.

**How You Map Your Source Data to Target Object Attributes**

You import Address Purpose data into Oracle Applications Cloud from a CSV file containing your source data that's mapped to target Oracle Applications Cloud object attributes.

Before you create the source data file, you should:

- Know how your source data attributes map to the target object attributes in Oracle Applications Cloud. Match each column from the source file to an attribute in the Address Purpose import object.
- Finish all prerequisite steps, such as understanding what attributes are required for importing your objects.
- Know how you can uniquely identify the records.
- Check the target object attributes required in the CSV file for a successful import.
- Ensure that you don't insert duplicate Address Purposes while importing, to avoid redundant data.
If you want to import only a few records, then you can create a single CSV file for all Address Purpose attributes. However, if you want to import a large number of records, then you may decide to create multiple CSV files, one for each of the Address Purpose child objects. Note that you must have imported the CSV file for Address Purpose object successfully before trying to import the CSV files for the child objects. There are separate help topics describing how to import each of these child objects.

**Before You Start**

You must do some basic checks before starting your import. For example, make sure that:

- You have completed all the prerequisites for importing each attribute in your source data.
- You have all parent records in place before importing child records.

**Select a Unique Identifier for Your Records**

All records must be unique in the application. You can use one of these to identify records:

- Public unique identifiers: If you're creating records, then you can provide an easily understandable public unique identifier. These are, usually, denoted with 'Number' and visible in the business object's UI. PUID attributes are usually named `<object> Number`. If you're updating a record with a Number attribute, then use the Number attribute to identify the record. For more information about public unique identifiers, see the topic "How You Use Alternate Keys to Import Records" in Related Topics section.

- Source system and source system reference: Source system is an identifier for the external system, and source system reference is a unique identifier within the external system. If you're importing a new Address Purpose or are updating Address Purpose records that have source system reference data, then provide the source system and source system reference values.

**Required Attributes and Validations for Address Purpose Object**

To import data successfully into Oracle Applications Cloud, your .CSV file must include the required attributes. Ensure that you provide valid values for the attributes.

This table lists the required attributes for Address Purpose records, prerequisite setup tasks and specific validations, if any:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/ Import Validations</th>
<th>Creating an Address Purpose record</th>
<th>Updating an Existing Address Purpose record</th>
</tr>
</thead>
<tbody>
<tr>
<td>SiteSourceSystem</td>
<td>The name of the external source system for the Address record to which the Address Purpose is associated.</td>
<td>A combination of a valid SiteSourceSystem and SiteSourceSystemReference, which are already imported.</td>
<td>Either the AddressId, Address Number or the combination of SiteSourceSystem and SiteSourceSystemReference is required.</td>
<td>Not required</td>
</tr>
<tr>
<td>SiteSourceSystemReference</td>
<td>The identifier of the source system for the address record to which the Address Purpose is associated.</td>
<td>A combination of a valid SiteSourceSystem and SiteSourceSystemReference, which are already imported.</td>
<td>Either the AddressId, Address Number or the combination of SiteSourceSystem and SiteSourceSystemReference is required.</td>
<td>Not required</td>
</tr>
<tr>
<td>Attribute</td>
<td>Description</td>
<td>Prerequisite Setup Task/Import Validations</td>
<td>Creating an Address Purpose record</td>
<td>Updating an Existing Address Purpose record</td>
</tr>
<tr>
<td>----------------------</td>
<td>------------------------------------------------------------------------------</td>
<td>-------------------------------------------</td>
<td>-----------------------------------</td>
<td>---------------------------------------------</td>
</tr>
<tr>
<td>PrimaryPerType</td>
<td>This specifies the record that's imported as the primary key for a site use type. Specify Y for a record to set the specified site use type as the primary key.</td>
<td>Y, N, or NULL Enter Y or N. Alternatively, don't enter any value. The default value is N.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>AddressPurposeId</td>
<td>The primary key of the Address Purpose record</td>
<td>No validation</td>
<td>Not required</td>
<td>Conditionally Required To identify an address purpose record, use one of these:</td>
</tr>
<tr>
<td>Purpose</td>
<td>The site codes such as SHIP_TO and BILL_TO that identify the Address Purpose</td>
<td>The values are validated against the Lookup values for Site use codes.</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td>StartDate</td>
<td>The start date of the Address Purpose</td>
<td>The date can't be earlier than the Address start date.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>EndDate</td>
<td>The end date of the Address Purpose</td>
<td>This date can't be later than the Address end date.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>AddressId</td>
<td>The primary key of the Address record</td>
<td>No validation</td>
<td>Either the AddressId, Address Number or the combination of SiteSourceSystem and SiteSourceSystemReference is required.</td>
<td>Not required</td>
</tr>
<tr>
<td>AddressNumber</td>
<td>The public unique identifier of the address</td>
<td>Valid Address Number (Party Site Number)</td>
<td>Either the AddressId, Address Number or the combination of SiteSourceSystem and SiteSourceSystemReference is required.</td>
<td>Not required</td>
</tr>
<tr>
<td>SourceSystem</td>
<td>Name of external source system of the address purpose for the address that's associated with the account, contact, or household.</td>
<td>The source system should exist. You can manage source systems from the Manage Source Systems task.</td>
<td>Optional</td>
<td>Conditionally Required To identify an address purpose record, use one of these:</td>
</tr>
</tbody>
</table>
Create the Source CSV File
You include the data that you want to import into CX Sales and B2B Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator > Tools > Import Management > Import Objects.
2. Select the Address Purpose object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/Import Validations</th>
<th>Creating an Address Purpose record</th>
<th>Updating an Existing Address Purpose record</th>
</tr>
</thead>
<tbody>
<tr>
<td>SourceSystemReferenceValue</td>
<td>Specifies the identifier in the original source system for the Address Purpose record.</td>
<td>The combination of Source System and Source System Reference Value should be unique.</td>
<td>Optional</td>
<td>Conditionally Required</td>
</tr>
<tr>
<td></td>
<td></td>
<td>If your data source is a third party or external system, and you intend to import updates to previously imported records from the same system, provide the original source system and source system reference values.</td>
<td>To identify an address purpose record, use one of these:</td>
<td>- SourceSystem and SourceSystemReferenceValue</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>- AddressPurposeId</td>
</tr>
</tbody>
</table>

Go to Navigator > Tools > Import Management > Import Objects, to see all the attributes of the Address Purpose object. The page also lists attribute information like type, length, description, and so on.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the Address Purpose information. To create an import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. On the Manage Imports page, click Create Import Activity.
3. In the Create Import Activity: Enter Import Options page, provide a name for the import activity, and select Address Purpose from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you’re ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to Go to Navigator > Tools > Import Management > Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed. You can drill down on the import activity to go to the Import Status page which provides the status details of the import activity.

Related Topics
- How You Use Alternate Keys to Import Records
- Potential Issues When Opening CSV Files in Excel

Import Asset Data

Import Your Asset Data

You can use the Import Management to create, update, or delete asset records.

You can import asset records using these steps:

1. Map your source asset data to Oracle Applications Cloud object attributes. This way the import process would know where to insert each of the information bits.
2. Create the source CSV file with the asset data you want to import.
4. Check the import results to know if the import went well.

How You Map Your Source Data to Target Object Attributes

To import your asset data into Oracle Applications Cloud, you must populate a .csv file with your source data and map that source data to target object attributes in Oracle Applications Cloud.

You must do the following before creating the .csv file for data import:

- Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
- Ensure prerequisite steps are complete, such as understanding what attributes are required for importing your objects.
- Understand your options for uniquely identifying the records.
- Ensure parent records exist before importing child records.
- Identify the target object attributes that are required in the .csv file for a successful import.

To better manage your asset information, the asset object has the following child objects:

- Asset Contact
- Asset Resource

If you want to import only a few records, then you can create a single CSV file for all asset attributes. However if you want to import a large number of records, then you may decide to create multiple CSV files, one for each of the asset child objects. Note that you must have imported the CSV file for asset object successfully before trying to import the CSV files for the child objects. There are separate help topics describing how to import each of these child objects. For more information, see the related topics section.
Before You Start

You must do some basic checks before starting your import. For example, make sure that:

- You have completed all the prerequisites for importing each attribute in your source data.
- You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records

All records must be unique in the application. You can use one of these to identify records:

- Public unique identifiers: If you’re creating records, then you can provide an easily understandable public unique identifier. These are, usually, denoted with ‘Number’ and visible in the business object’s UI. PUID attributes are usually named `<object> Number`. If you’re updating a record with a Number attribute, then use the Number attribute to identify the record. For more information about public unique identifiers, see the topic "How You Use Alternate Keys to Import Records" in Related Topics section.

- Source system and source system reference: Source system is an identifier for the external system, and source system reference is a unique identifier within the external system. If you’re importing new assets or are updating assets that have source system reference data, then provide the source system and source system reference values.

Required Attributes and Validations for Asset Object

To import data successfully into Oracle Applications Cloud, your .csv file must include the required attributes. Ensure that you provide valid values for the attributes.

This table lists the required attributes for asset records, prerequisite setup tasks and specific validations, if any:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/Import Validations</th>
<th>Creating an Asset record</th>
<th>Updating an Existing Asset record</th>
</tr>
</thead>
<tbody>
<tr>
<td>AssetNumber</td>
<td>The unique ID for the existing asset record in the destination table.</td>
<td>None</td>
<td>Required</td>
<td>Required</td>
</tr>
<tr>
<td>AssetOrigSystem</td>
<td>A source system code that identifies the original source system of the asset.</td>
<td>None</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>AssetOrigSystemReference</td>
<td>A source system reference that’s the unique ID of the asset in your legacy or external system.</td>
<td>None</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>CustomerId</td>
<td>The unique ID for the existing customer party record in the destination table.</td>
<td>The party must exist.</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td>AccountSourceSystem</td>
<td>Specifies the account source system.</td>
<td>You must enter a valid source system and source</td>
<td>Not required</td>
<td>Not required</td>
</tr>
</tbody>
</table>
Go to Navigator > Tools > Import Management > Import Objects, to see all the attributes of the asset object. The page also lists attribute information like type, length, description, and so on.

Create the Source CSV File

You include the data that you want to import into CX Sales and B2B Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator > Tools > Import Management > Import Objects.
2. Select the Asset object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note: For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity

After you have the CSV file ready, create an import activity to import the asset information. To create an import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Asset from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

**Review the Import Results**

Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed. You can drill down on the import activity to go to the Import Status page which provides the status details of the import activity.

**Related Topics**
- Import Your Asset Contact Data
- Potential Issues When Opening CSV Files in Excel
- How You Use Alternate Keys to Import Records
- Import Your Asset Resource Data

**Example of Updating the Status of an Asset**

You can change the status of an asset by updating its end-date and setting the status to 'EXPIRED'. To update an asset, your source file must include the values that let the import process identify the existing records.

**Before You Begin**

The scenario in this example assumes that the following prerequisites have already been set up.

- Assets must exist in the application.
- User accounts are set up for the already existing assets.
- Appropriate business units are set up using the Manage Business Unit task.

To find the business unit, navigate to the following in the Setup and Maintenance work area:

- Offering: Sales
  - Function Area: Data Import and Export
  - Task: Manage Business Units

- Appropriate legal entities are set up using the Manage Legal Entities task. To find the legal entity, navigate to the following in the Setup and Maintenance work area:

  - Offering: Sales
    - Function Area: Data Import and Export
    - Task: Manage Legal Entities
Scenario
In this scenario, AssetNumber for the given asset is 782400089. Note the name of this asset, say ‘Green Server 5000’. You must create a source file (CSV) with the attributes and import it using import management as shown in this table.

<table>
<thead>
<tr>
<th>Attribute Name</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>AssetNumber</td>
<td>782400089</td>
</tr>
<tr>
<td>EndDate</td>
<td>6/1/2005</td>
</tr>
<tr>
<td>StatusCode</td>
<td>'EXPIRED'</td>
</tr>
</tbody>
</table>

You can import the source data file as explained below:

1. Navigate to Tools > Import Management.
2. Click Create Import Activity on the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Assets from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. The source and target attributes are automatically mapped in the Map Fields page. Review and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
   \[Note: Validation errors, if any, are displayed on the Mapping Validation screen. If you get warnings about unmapped columns, then you can ignore these columns and proceed to submit the import job. Validations are for informational purposes and applicable only for low-volume imports.\]
7. Review the import details on the Review and Submit page, and click Submit when you're ready.
8. You can navigate to Workspace and search for the asset name 'Green Server 5000' to verify the updated status.

Example of Updating the Owner Name of an Asset

You can change the owner name of an asset. To update an asset, your source file must include the values that let the import process identify the existing records.

Before You Begin

The scenario in this example assumes that the following prerequisites have already been set up.

- Assets must exist in the application.
- User accounts are set up for the already existing assets.
- Appropriate business units are set up using the Manage Business Unit task.
  To find the business unit, navigate to the following in the Setup and Maintenance work area:
  \[Offering: Sales\]
Scenario

In this scenario, AssetNumber for the given asset is 782400089. Note the name of this asset, say ‘Green Server 5000’. You must create a source file (CSV) with the attributes and import it using import management as shown in this table.

<table>
<thead>
<tr>
<th>Attribute Name</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>AssetNumber</td>
<td>782400089</td>
</tr>
<tr>
<td>AccountNameTransientForLOV</td>
<td>FSACCOUNT (DENVER, US)</td>
</tr>
</tbody>
</table>

You can import the source data file as explained below:

1. Navigate to Tools > Import Management.
2. Click Create Import Activity on the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Assets from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. The source and target attributes are automatically mapped in the Map Fields page. Review and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you’re ready.
8. You can navigate to Workspace and search for the asset name ‘Green Server 5000’, to verify the updated owner name.

Import Your Asset Contact Data

You can use Import Management to create, update, or delete your asset contact data.
You can import asset contact records using these steps:

1. Map your source asset contact data to Oracle Applications Cloud object attributes. This way the import process would know where to insert each of the information bits.
2. Create the source CSV file with the asset contact data you want to import.
4. Check the import results to know if the import went well.

How You Map Your Source Data to Target Object Attributes

You import asset contact data into Oracle Applications Cloud from a CSV file with your source data that's mapped to target object attributes.

Before you create the source data file, you should:

- Know how your source data attributes map to the target object attributes in Oracle Applications Cloud. Match each column from the source file to an attribute in the asset import object.
- Finish all prerequisite steps, such as understanding what attributes are required for importing your objects.
- Know how you can uniquely identify the records.
- Check the target object attributes required in the CSV file for a successful import.

Before You Start

You must do some basic checks before starting your import. For example, make sure that:

- You have completed all the prerequisites for each attribute in your source data. For example, when using source system reference information to identify your asset records, the source system of the asset object should be enabled for parties in the Manage Trading Community Source Systems task.
- You have all the parent records in place before importing child records. For example, when importing the asset contact, ensure the asset exists.

Select a Unique Identifier for Your Records

All records must be unique in the application. You can use one of these to identify records:

- Public unique identifiers: If you're creating records, then you can provide an easily understandable public unique identifier. These are, usually, denoted with 'Number' and visible in the business object's UI. PUID attributes are usually named <object> Number. If you're updating a record with a Number attribute, then use the Number attribute to identify the record. For asset object, the attribute is AssetNumber and shows up in the UI as Asset Number. For more information about public unique identifiers, see the topic "How You Use Alternate Keys to Import Records" in Related Topics section.
- Source system and source system reference: Source system is an identifier for the external system, and source system reference is a unique identifier within the external system. If you're importing new accounts or are updating accounts that have source system reference data, then provide the source system and source system reference values.

Required Attributes and Validations for Asset Contact Object

To import data into Oracle Applications Cloud, your CSV file must include the required attributes. Make sure that you provide valid values for these attributes so that they pass import validations inbuilt into the application. This table lists
the required attributes for asset contact records, prerequisite setup tasks for the attributes, and specific validations, if any.

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/Import Validations</th>
<th>Creating an Asset Contact record</th>
<th>Updating an Existing Asset Contact record</th>
</tr>
</thead>
<tbody>
<tr>
<td>ContactPartyId</td>
<td>Unique party identifier representing a contact.</td>
<td>The party must exist.</td>
<td>Required</td>
<td>Required</td>
</tr>
<tr>
<td>AssetId</td>
<td>The unique ID for the existing asset record in the destination table.</td>
<td>An asset record with the Asset ID should exist.</td>
<td>Conditionally required when you don’t provide the Asset Number.</td>
<td>Conditionally required when you don’t provide the Asset Number.</td>
</tr>
<tr>
<td>AssetNumber</td>
<td>The unique ID for the existing asset record in the destination table.</td>
<td>An asset record with the Asset Number should exist.</td>
<td>Conditionally required when you don’t provide the Asset ID.</td>
<td>Conditionally required when you don’t provide the Asset ID.</td>
</tr>
</tbody>
</table>

Go to Navigator > Tools > Import Management > Import Objects, to see all the attributes of the account object. The page also lists attribute information like type, length, description, and so on.

Create the Source CSV File
You include the data you want to import into Oracle Applications Cloud in a CSV file.

You can use the templates available in the Import Object Details page to create the source CSV file. To download a template:

1. Go to Navigator > Tools > Import Management > Import Objects.
2. Select the Asset Contact object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

<table>
<thead>
<tr>
<th>AssetNumber</th>
<th>ContactPartyId</th>
<th>ContactFunctionCode</th>
</tr>
</thead>
<tbody>
<tr>
<td>900546</td>
<td>300000018487543</td>
<td>ORA_ZCM_ASSET_MANAGER</td>
</tr>
<tr>
<td>900604</td>
<td>300000018487544</td>
<td>ORA_ZCM_MAINTENANCE_ENGINEEER</td>
</tr>
</tbody>
</table>

Note: For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the asset information.

To create an import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click Create Import Activity button on the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Asset Contact from the Object drop-down list.
4. Select the CSV file in the File Name, field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review and edit the mappings if required. Click Next.
6. Check the file for unmapped columns or data format issues by clicking Validate Data.
7. Review the import details on the Review and Submit page and click Submit when you’re ready.

Review the Import Results

Check if your import succeeded on the Manage Import Activity page. This page has the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click All Imports and search for the import activity that you created earlier. The Import Status column shows the status of the import activity.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed. You can drill down on the import activity to go to the Import Status page which provides the status details of the import activity.

Import Your Asset Resource Data

You can use Import Management to create, update, or delete your Asset Resource data.

To import asset resource records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (.csv) file for import.
3. Create the import activity.
4. Review the import activity.

How You Map Your Source Data to Target Object Attributes

You import Asset Resource data into Oracle Applications Cloud from a CSV file containing your source data that's mapped to target Oracle Applications Cloud object attributes.

You must do the following before creating the .csv file for data import:

- Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
- Ensure prerequisite steps are complete, such as understanding what attributes are required for importing your objects.
- Understand your options for uniquely identifying the records.
- Ensure parent records exist before importing child records.
- Identify the target object attributes that are required in the .csv file for a successful import.

To better manage your Asset Resource information, the Asset Resource object has the following child objects:

- Address
Oracle CX
Understanding Import and Export Management for CX
Sales and B2B Service

Chapter 8
Import Your Data

• Classification
• Relationship
• Sales Team Member

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.
• You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
All records must be unique in the application. You can use one of these to identify records:

• Public unique identifiers: If you’re creating records, then you can provide an easily understandable public unique identifier. These are, usually, denoted with ‘Number’ and visible in the business object’s UI. PUID attributes are usually named <object> Number. If you’re updating a record with a Number attribute, then use the Number attribute to identify the record. For more information about public unique identifiers, see the topic "How You Use Alternate Keys to Import Records" in Related Topics section.
• Source system and source system reference: Source system is an identifier for the external system, and source system reference is a unique identifier within the external system. If you’re importing new Asset Resources or are updating Asset Resources that have source system reference data, then provide the source system and source system reference values.

Required Attributes and Validations for the Asset Resource Object
To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Make sure that you provide valid values for these attributes so that they pass import validations inbuilt into the application.

This table lists the required attributes for Asset Resource records, prerequisite setup tasks and specific validations, if any:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/ Import Validations</th>
<th>Creating an Asset Resource record</th>
<th>Updating an Existing Asset Resource record</th>
</tr>
</thead>
<tbody>
<tr>
<td>AssetId</td>
<td>The unique ID for the existing asset record in the destination table.</td>
<td>An asset record with the Asset ID should exist</td>
<td>Conditionally required when you don’t provide the Asset Number</td>
<td>Conditionally required when you don’t provide the Asset Number</td>
</tr>
<tr>
<td>AssetNumber</td>
<td>The unique ID for the existing asset record in the destination table.</td>
<td>An asset record with the Asset Number should exist</td>
<td>Conditionally required when you don’t provide the Asset ID</td>
<td>Conditionally required when you don’t provide the Asset ID</td>
</tr>
<tr>
<td>Resource Party ID</td>
<td>Unique party identifier representing a resource</td>
<td>The party must exist.</td>
<td>Required</td>
<td>Required</td>
</tr>
</tbody>
</table>

Go to Navigator > Tools > Import Management > Import Objects, to see all the attributes of the Asset Resource object. The page also lists attribute information like type, length, description, and so on.
Create the Source CSV File
You include the data that you want to import into CX Sales and B2B Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigation > Tools > Import Management > Import Objects.
2. Select the Asset Resource object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

**Note:** For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the Asset Resource information. To create an import activity:

2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Asset Resource from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed. You can drill down on the import activity to go to the Import Status page which provides the status details of the import activity.

**Related Topics**
- Import Data
- Potential Issues When Opening CSV Files in Excel
- How You Use Alternate Keys to Import Records

Import Your Assignment Rule Candidate Data
You can use Import Management to create, update, or delete your assignment rule candidate data.
You can import assignment rule candidate records using these steps:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes

You import assignment rule candidate data into Oracle Applications Cloud from a CSV file containing your source data that's mapped to target Oracle Applications Cloud object attributes.

You need to do the following before creating the .csv file for data import:

- Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
- Ensure prerequisite steps are complete, such as understanding what attributes are required for importing your objects.
- Understand your options for uniquely identifying the records.
- Ensure parent records exist before importing child records.
- Identify the target object attributes that are required in the .csv file for a successful import.

Before You Start

You must do some basic checks before starting your import. For example, make sure that:

- You have completed all the prerequisites for importing each attribute in your source data.
- You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records

All records must be unique in the application. You can use one of these to identify records:

- Public unique identifiers: If you're creating records, then you can provide an easily understandable public unique identifier. These are, usually, denoted with 'Number' and visible in the business object's UI. PUID attributes are usually named <object> Number. If you're updating a record with a Number attribute, then use the Number attribute to identify the record. For more information about public unique identifiers, see the topic "How You Use Alternate Keys to Import Records" in Related Topics section.
- Source system and source system reference: Source system is an identifier for the external system, and source system reference is a unique identifier within the external system. If you're importing new action plans or are updating action plans that have source system reference data, then provide the source system and source system reference values.

Review Required Attributes and Validations for Assignment Rule Candidate Object

To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Make sure that you provide valid values for these attributes so that they pass import validations inbuilt into the application.

This table lists the required attributes for assignment rule candidate records, prerequisite setup tasks and specific validations, if any:
Chapter 8
Import Your Data

Review Required Attributes and Validations for Assignment Rule Candidate Object

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Tasks or Import Validations</th>
<th>Creating an Assignment Rule Candidate Record</th>
<th>Updating an Existing Assignment Rule Candidate Record</th>
<th>Deleting an Existing Assignment Rule Candidate Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>RuleNumber</td>
<td>The alternate identifier of the assignment rule.</td>
<td>None</td>
<td>Required</td>
<td>Not Required</td>
<td>Not Required</td>
</tr>
<tr>
<td>CandidateObjectPUID</td>
<td>The alternate identifier of the candidate object.</td>
<td>Validate the PUID/ID exist in the system for corresponding candidate object.</td>
<td>Conditionally Required. Provide value if CandidateObjectId isn't provided.</td>
<td>Not Required</td>
<td>Not Required</td>
</tr>
<tr>
<td>CandidateObjectId</td>
<td>The unique identifier of the candidate object.</td>
<td>Validate the PUID/ID exist in the system for corresponding candidate object.</td>
<td>Conditionally Required. Provide value if CandidateObjectPUID isn't provided.</td>
<td>Not Required</td>
<td>Not Required</td>
</tr>
<tr>
<td>RuleCandidateNumber</td>
<td>The identifier of the assignment rule candidate.</td>
<td>None</td>
<td>Not Required</td>
<td>Required</td>
<td>Required</td>
</tr>
</tbody>
</table>

You can view the Assignment Rule Candidate object along with all its attributes in the Manage Import Objects page of the Import Management flow. You can find attribute information like type, length, description, and so on, on this page.

Create the Source CSV File
You include the data that you want to import into CX Sales and B2B Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator > Tools > Import Management > Import Objects.
2. Select the Assignment Rule Candidate object in the table and click Download.

Note: For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the assignment rule candidate information. To create an import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Assignment Rule Candidate from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.
Review the Import Results

Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed. You can drill down on the import activity to go to the Import Status page which provides the status details of the import activity.

Related Topics
- Import Data
- How You Use Alternate Keys to Import Records
- Potential Issues When Opening CSV Files in Excel

Import Your Assignment Rule Condition Data

You can use Import Management to create, update, or delete your assignment rule condition data.

You can import assignment rule condition records using these steps:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes

You import assignment rule condition data into Oracle Applications Cloud from a CSV file containing your source data that's mapped to target Oracle Applications Cloud object attributes.

You need to do the following before creating the .csv file for data import:

- Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
- Ensure prerequisite steps are complete, such as understanding what attributes are required for importing your objects.
- Understand your options for uniquely identifying the records.
- Ensure parent records exist before importing child records.
- Identify the target object attributes that are required in the .csv file for a successful import.

Before You Start

You must do some basic checks before starting your import. For example, make sure that:

- You have completed all the prerequisites for importing each attribute in your source data.
- You have all parent records in place before importing child records.
Select a Unique Identifier for Your Records

All records must be unique in the application. You can use one of these to identify records:

- **Public unique identifiers**: If you’re creating records, then you can provide an easily understandable public unique identifier. These are, usually, denoted with ‘Number’ and visible in the business object’s UI. PUID attributes are usually named `<object> Number`. If you’re updating a record with a Number attribute, then use the Number attribute to identify the record. For more information about public unique identifiers, see the topic "How You Use Alternate Keys to Import Records" in Related Topics section.

- **Source system and source system reference**: Source system is an identifier for the external system, and source system reference is a unique identifier within the external system. If you’re importing new action plans or are updating action plans that have source system reference data, then provide the source system and source system reference values.

Review Required Attributes and Validations for Assignment Rule Condition Object

To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Make sure that you provide valid values for these attributes so that they pass import validations inbuilt into the application.

This table lists the required attributes for assignment rule condition records, prerequisite setup tasks and specific validations, if any:

### Review Required Attributes and Validations for Assignment Rule Condition Object

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Tasks or Import Validations</th>
<th>Creating an Assignment Rule Condition Record</th>
<th>Updating an Existing Assignment Rule Condition Record</th>
<th>Deleting an Existing Assignment Rule Condition Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>RuleNumber</td>
<td>The alternate identifier of the rule.</td>
<td>None</td>
<td>Required</td>
<td>Not Required</td>
<td>Not Required</td>
</tr>
<tr>
<td>RuleConditionNumber</td>
<td>The alternate identifier of the rule condition.</td>
<td>None</td>
<td>Required</td>
<td>Required</td>
<td>Required</td>
</tr>
<tr>
<td>Object</td>
<td>The object on which the condition rule will apply, such as Accounts, Opportunities, Lead, Deals, and Partner Account.</td>
<td>The object must correspond to the given rule.</td>
<td>Conditionally Required. Provide value if ObjectCode isn’t provided.</td>
<td>Not Required</td>
<td>Not Required</td>
</tr>
<tr>
<td>ObjectCode</td>
<td>The code of the object.</td>
<td>The object must correspond to the given rule.</td>
<td>Conditionally Required. Provide value if ObjectCode isn’t provided.</td>
<td>Not Required</td>
<td>Not Required</td>
</tr>
<tr>
<td>ObjectAttributeName</td>
<td>The attributes of the object.</td>
<td>The attribute must correspond to the given object and registered in assignment metadata.</td>
<td>Conditionally Required. Provide value if ObjectAttributeName isn’t provided.</td>
<td>Not Required</td>
<td>Not Required</td>
</tr>
<tr>
<td>ObjectAttributeCode</td>
<td>The code of the attributes of the objects.</td>
<td>The attribute must correspond to the given object</td>
<td>Conditionally Required. Provide value if ObjectAttributeCode isn’t provided.</td>
<td>Not Required</td>
<td>Not Required</td>
</tr>
</tbody>
</table>
### Attribute List

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Tasks or Import Validations</th>
<th>Creating an Assignment Rule Condition Record</th>
<th>Updating an Existing Assignment Rule Condition Record</th>
<th>Deleting an Existing Assignment Rule Condition Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>Operator</td>
<td>The operation values according to which the rules would apply such as Equals, Start with, and so on.</td>
<td>The right operator must be passed on the attribute type. Validate the operator if matching object is passed.</td>
<td>Required</td>
<td>Not Required</td>
<td>Not Required</td>
</tr>
<tr>
<td>Value</td>
<td>The value to which the operation would match.</td>
<td>None</td>
<td>Conditionally Required. Not Mandatory in case the operator value is Is not blank or you’re using Matching Object.</td>
<td>Not Required</td>
<td>Not Required</td>
</tr>
</tbody>
</table>

You can view the Assignment Rule Condition object along with all its child objects and attributes in the Manage Import Objects page of the Import Management flow. You can find attribute information like type, length, description, and so on, on this page.

### Create the Source CSV File

You include the data that you want to import into CX Sales and B2B Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator > Tools > Import Management > Import Objects.
2. Select the Assignment Rule condition object in the table and click Download.

Note: For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.

### Create the Import Activity

After you have the CSV file ready, create an import activity to import the assignment rule condition information. To create an import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Assignment Rule Condition from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you’re ready.
Review the Import Results

Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed. You can drill down on the import activity to go to the Import Status page which provides the status details of the import activity.

Related Topics

- Import Data
- How You Use Alternate Keys to Import Records
- Potential Issues When Opening CSV Files in Excel

Import Your Assignment Rule Data

You can use Import Management to create, update, or delete your assignment rule data.

You can import assignment rule records using these steps:

- Map your source data to Oracle Applications Cloud object attributes.
- Create source Comma Separated Values (CSV) file for import.
- Create the import activity.
- Review the import results.

How You Map Your Source Data to Target Object Attributes

You import assignment rule data into Oracle Applications Cloud from a CSV file containing your source data that's mapped to target Oracle Applications Cloud object attributes.

You need to do the following before creating the .csv file for data import:

- Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
- Ensure prerequisite steps are complete, such as understanding what attributes are required for importing your objects.
- Understand your options for uniquely identifying the records.
- Ensure parent records exist before importing child records.
- Identify the target object attributes that are required in the .csv file for a successful import

Before You Start

You must do some basic checks before starting your import. For example, make sure that:

- You have completed all the prerequisites for importing each attribute in your source data.
• You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records

All records must be unique in the application. You can use one of these to identify records:

• Public unique identifiers: If you're creating records, then you can provide an easily understandable public unique identifier. These are, usually, denoted with 'Number' and visible in the business object's UI. PUID attributes are usually named <object> Number. If you're updating a record with a Number attribute, then use the Number attribute to identify the record. For more information about public unique identifiers, see the topic "How You Use Alternate Keys to Import Records" in Related Topics section.

• Source system and source system reference: Source system is an identifier for the external system, and source system reference is a unique identifier within the external system. If you're importing new action plans or are updating action plans that have source system reference data, then provide the source system and source system reference values.

Review Required Attributes and Validations for Assignment Rule Object

To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Make sure that you provide valid values for these attributes so that they pass import validations inbuilt into the application.

This table lists the required attributes for assignment rule records, prerequisite setup tasks and specific validations, if any:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Tasks or Import Validations</th>
<th>Creating an Assignment Rule Record</th>
<th>Updating an Existing Assignment Rule Record</th>
<th>Deleting an Existing Assignment Rule Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>RuleSetNumber</td>
<td>The alternate identifier of the assignment rule set.</td>
<td>None</td>
<td>Required</td>
<td>Not Required</td>
<td>Not Required</td>
</tr>
<tr>
<td>RuleName</td>
<td>The name of the assignment rule.</td>
<td>A valid name must begin with a letter. The remaining characters in the name can be an alphanumeric character, a single space, colon (:), dash (-), period (.), slash (/), or underscore (_).</td>
<td>Required</td>
<td>Not Required</td>
<td>Not Required</td>
</tr>
<tr>
<td>RuleNumber</td>
<td>The alternate identifier of the assignment rule.</td>
<td>None</td>
<td>Not Required</td>
<td>Required</td>
<td>Required</td>
</tr>
</tbody>
</table>

You can view the Assignment Rule Set object along with all its child objects and attributes in the Manage Import Objects page of the Import Management flow. You can find attribute information like type, length, description, and so on, on this page.

Create the Source CSV File

You include the data that you want to import into CX Sales and B2B Service in a source CSV file.
You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator > Tools > Import Management > Import Objects.
2. Select the Assignment Rule Set object in the table and click Download.

**Note:** For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.

### Create the Import Activity

After you have the CSV file ready, create an import activity to import the assignment rule set information. To create an import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Assignment Rule Set from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you’re ready.

### Review the Import Results

Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed. You can drill down on the import activity to go to the Import Status page which provides the status details of the import activity.

**Related Topics**

- Import Data
- How You Use Alternate Keys to Import Records
- Potential Issues When Opening CSV Files in Excel

### Import Your Assignment Rule Set Data

You can use Import Management to create, update, and delete your assignment rule set data.

You can import assignment rule set records using these steps:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes

You import assignment rule set data into Oracle Applications Cloud from a CSV file containing your source data that's mapped to target Oracle Applications Cloud object attributes.

You need to do the following before creating the .csv file for data import:

- Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
- Ensure prerequisite steps are complete, such as understanding what attributes are required for importing your objects.
- Understand your options for uniquely identifying the records.
- Ensure parent records exist before importing child records.
- Identify the target object attributes that are required in the .csv file for a successful import.

Before You Start

You must do some basic checks before starting your import. For example, make sure that:

- You have completed all the prerequisites for importing each attribute in your source data.
- You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records

All records must be unique in the application. You can use one of these to identify records:

- Public unique identifiers: If you're creating records, then you can provide an easily understandable public unique identifier. These are, usually, denoted with ‘Number’ and visible in the business object's UI. PUID attributes are usually named <object> Number. If you're updating a record with a Number attribute, then use the Number attribute to identify the record. For more information about public unique identifiers, see the topic "How You Use Alternate Keys to Import Records" in Related Topics section.
- Source system and source system reference: Source system is an identifier for the external system, and source system reference is a unique identifier within the external system. If you're importing new action plans or are updating action plans that have source system reference data, then provide the source system and source system reference values.

Review Required Attributes and Validations for Assignment Rule Set Object

To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Make sure that you provide valid values for these attributes so that they pass import validations inbuilt into the application.

This table lists the required attributes for assignment rule set records, prerequisite setup tasks and specific validations, if any:
**Review Required Attributes and Validations for Assignment Rule Set Object**

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Tasks or Import Validations</th>
<th>Creating an Assignment Rule Set Record</th>
<th>Updating an Existing Assignment Rule Set Record</th>
<th>Deleting an Existing Assignment Rule Set Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>Application</td>
<td>The name of the application.</td>
<td>The application should be one of the following: Lead Management, Sales and Partner Center, Customer Center, Object Sharing, Service.</td>
<td>Required</td>
<td>Not Required</td>
<td>Not Required</td>
</tr>
<tr>
<td>Category</td>
<td>The display name of the rule category.</td>
<td>It should belong to the passed application or code will be given preference.</td>
<td>Conditionally Required. Provide value if CategoryCode isn't provided.</td>
<td>Not Required</td>
<td>Not Required</td>
</tr>
<tr>
<td>CategoryCode</td>
<td>The code of the rule category.</td>
<td>It should belong to the passed application or code will be given preference.</td>
<td>Conditionally Required. Provide value if Category isn't provided.</td>
<td>Not Required</td>
<td>Not Required</td>
</tr>
<tr>
<td>RuleSetNumber</td>
<td>The alternate identifier of the assignment rule set.</td>
<td>None</td>
<td>Not Required</td>
<td>Required</td>
<td>Required</td>
</tr>
<tr>
<td>RuleSetName</td>
<td>The name of the assignment rule set.</td>
<td>A valid name must begin with a letter. The remaining characters in the name can be an alphanumeric character, a single space, colon (:), dash (-), period (.), slash (/), or underscore (_). It must be unique for a particular application.</td>
<td>Required</td>
<td>Not Required</td>
<td>Not Required</td>
</tr>
</tbody>
</table>

You can view the Assignment Rule Set object along with all its child objects and attributes in the Manage Import Objects page of the Import Management flow. You can find attribute information like type, length, description, and so on, on this page.

**Create the Source CSV File**

You include the data that you want to import into CX Sales and B2B Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator > Tools > Import Management > Import Objects.
2. Select the Assignment Rule Set object in the table and click Download.

**Note:** For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.
Create the Import Activity

After you have the CSV file ready, create an import activity to import the assignment rule set information. To create an import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Assignment Rule Set from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you’re ready.

Review the Import Results

Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed. You can drill down on the import activity to go to the Import Status page which provides the status details of the import activity.

Related Topics

- Import Data
- How You Use Alternate Keys to Import Records
- Potential Issues When Opening CSV Files in Excel

Import Your Associated Project Data

You can use Import Management to create or update associated projects records.

To import associated project records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Object Attributes

To import your associated projects data into Oracle Applications Cloud, you must populate a CSV file with your source data and map that source data to target object attributes in Oracle Applications Cloud.
You need to do the following before creating the CSV file for data import:

- Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
- Ensure prerequisite setups are done, if applicable.
- Understand your options for uniquely identifying the records.
- Ensure parent records exist before importing child records.
- Identify the target object attributes that are required in the CSV file for a successful import.

Before You Start
You must do some basic checks before starting your import. For example:

- Complete all the prerequisites for importing each attribute in your source data.
- Have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the import process to uniquely identify the records. The file import process uses the attribute values to automatically map your source data to the target object attributes in Oracle Applications Cloud.

The preferred option to uniquely identify an object record is through the public unique identifier. If you’re creating new records, then you can provide a user-friendly public unique identifier (attributes denoted with 'Number' and usually visible in the business object’s UI). If you update a record for which you have previously provided a Number attribute, or for which a Number attribute is visible in the object’s UI, you can use the Number attribute to identify the record. For the associated project object, the attribute is LinePUID.

Required Attributes and Validations for the Associated Project Object
To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure that you provide valid values for the attributes. The following table lists the required attributes for importing new associated project records, prerequisite setup tasks for the attributes, and specific validations, if any, for associated project import:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/Import Validations</th>
<th>Creating an Associated Project Record</th>
<th>Updating an Existing Associated Project Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>LinePuid</td>
<td>The unique PUID that identifies the contract line.</td>
<td>This must be a valid contract line PUID.</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td>ExtSource</td>
<td>The external source of the associated project information.</td>
<td>This must be a unique combination of external source and key.</td>
<td>Required</td>
<td>Required</td>
</tr>
<tr>
<td>ExtKey</td>
<td>The external key of the associated project information.</td>
<td>This must be a unique combination of external source and key.</td>
<td>Required</td>
<td>Required</td>
</tr>
</tbody>
</table>
You can view the associated project object and attributes in the Manage Import Objects page of the Import Management flow. You can find attribute information like type, length, description, and so on, on this page.

### Create the Source CSV File

You include the data that you want to import into CX Sales and B2B Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to **Navigator > Tools > Import Management > Import Objects**.
2. Select the **Associated Project** object in the table and click **Download**.

You can now edit the downloaded file and provide valid values for the required attributes.

**Note:** For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.

### Create the Import Activity

After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to **Navigator > Tools > Import Management > Import Queue**.
2. Click **Create Import Activity** in the **Manage Imports** page.
3. In the **Enter Import Options** page, provide a name for the import activity, and select Associated Project from the **Object** drop-down list.
4. Select the CSV file in the **File Name** field, and click **Next**.
5. The source and target attributes are automatically mapped in the **Map Fields** page. Review and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking **Validate Data**. Click **Next**.
7. Review the import details on the **Review and Submit** page, and click **Submit** when you're ready.
Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed. You can drill down on the import activity to go to the Import Status page which provides the status details of the import activity.

Related Topics
- Potential Issues When Opening CSV Files in Excel
- Import Data

Import Your Attachment Data
You can use Import Management to create, update, or delete Attachment records.

You can import attachment records using these steps:

1. Map your source attachment data to Oracle Applications Cloud object attributes. This way the import process would know where to insert each of the information bits.
2. Create the source CSV file with the attachment data you want to import.
4. Check the import results to know if the import went well.

How You Map Your Source Data to Target Object Attributes
You import attachment data into Oracle Applications Cloud from a CSV file containing your source data that's mapped to target Oracle Applications Cloud object attributes.

Before you create the source data file, you should:

- Know how your source data attributes map to the target object attributes in Oracle Applications Cloud. Match each column from the source file to an attribute in the attachment import object.
- Finish all prerequisite steps, such as understanding what attributes are required for importing your objects.
- Know how you can uniquely identify the records.
- Check the target object attributes required in the CSV file for a successful import.

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

- You have completed all the prerequisites for importing each attribute in your source data.
- You have all parent records in place before importing child records.
Select a Unique Identifier for Your Records

All records must be unique in the application. You can use one of these to identify records:

- **Public unique identifiers:** If you're creating records, then you can provide an easily understandable public unique identifier. These are, usually, denoted with 'Number' and visible in the business object's UI. PUID attributes are usually named <object> Number. If you're updating a record with a Number attribute, then use the Number attribute to identify the record. For attachment object, the attribute is PartyNumber and shows up in the UI as Party Number. For more information about public unique identifiers, see the topic "How You Use Alternate Keys to Import Records" in Related Topics section.

- **Source system and source system reference:** Source system is an identifier for the external system, and source system reference is a unique identifier within the external system. If you're importing new attachments or are updating attachments that have source system reference data, then provide the source system and source system reference values. For attachment object, these are SourceSystem and SourceSystemReferenceValue and show up as Party Source System and Party Source System Reference Value in the UI.

Required Attributes and Validations for Attachment Object

To import data successfully into Oracle Applications Cloud, your .csv file must include the required attributes. Ensure that you provide valid values for the attributes.

This table lists the required attributes for attachment records, prerequisite setup tasks and specific validations, if any:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/ Import Validations</th>
<th>Creating an Attachment record</th>
<th>Updating an Existing Attachment record</th>
</tr>
</thead>
<tbody>
<tr>
<td>PKIValue</td>
<td>This is the primary key of the record to which the attachment is being associated.</td>
<td>When creating or updating attachments, the parent record to which the attachment is associated must exist in the database.</td>
<td>Either PKIValue or PUID is mandatory.</td>
<td>Either PKIValue or PUID is mandatory.</td>
</tr>
<tr>
<td>ObjectPUID</td>
<td>This is the public unique identifier of the record to which the attachment is being associated.</td>
<td>When creating or updating attachments, the parent record to which the attachment is associated must exist in the database.</td>
<td>Either PKIValue or PUID is mandatory.</td>
<td>Either PKIValue or PUID is mandatory.</td>
</tr>
<tr>
<td>Category</td>
<td>Category to which the attachment belongs. If you don't specify a value, the default is considered. For example, the default attachment category for lead is MKL_LEAD_CATEGORY. A source system reference that's the unique ID of the Attachment in your legacy or external system.</td>
<td>If passing the category, it should be a valid category for that object.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>Description</td>
<td>A brief description of the attachment.</td>
<td>This can be any string of specified length.</td>
<td>Not Required</td>
<td>Not required</td>
</tr>
</tbody>
</table>
### Chapter 8
Import Your Data

#### Attribute | Description | Prerequisite Setup Task/Import Validations | Creating an Attachment record | Updating an Existing Attachment record
---|---|---|---|---
FileName | Name of the attachment file in which the attachment is stored. | This can be any string of specified length. | Either the File name or the URL is mandatory. | Either the File name or the URL is mandatory. |
PK2 Value | This is the primary key of the record to which the attachment is being associated. | This is useful when the object has a composite primary key. | This is useful when the object has a composite primary key. | This is useful when the object has a composite primary key. |
PK3 Value | This is the primary key of the record to which the attachment is being associated. | This is useful when the object has a composite primary key. | This is useful when the object has a composite primary key. | This is useful when the object has a composite primary key. |
PK4 Value | This is the primary key of the record to which the attachment is being associated. | This is useful when the object has a composite primary key. | This is useful when the object has a composite primary key. | This is useful when the object has a composite primary key. |
PK5 Value | This is the primary key of the record to which the attachment is being associated. | This is useful when the object has a composite primary key. | This is useful when the object has a composite primary key. | This is useful when the object has a composite primary key. |
URL | If the attachment type is url, this specifies the url. | The URL format is validated. | Either the file name or the URL is mandatory. | Either the file name or the URL is mandatory. |

For more information on importing an attachment, see the topic Import Attachments in the related links section.

Go to Navigator > Tools > Import Management > Import Objects, to see all the attributes of the attachment object. The page also lists attribute information like type, length, description, and so on.

### Create the Source CSV File
You include the data that you want to import into CX Sales and B2B Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator > Tools > Import Management > Import Objects.
2. Select the Attachment object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

**Note:** For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.
Create the Import Activity

After you have the CSV file ready, create an import activity to import the attachment information. To create an import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Attachment from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results

Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed. You can drill down on the import activity to go to the Import Status page which provides the status details of the import activity.

Related Topics

- Import Data
- Potential Issues When Opening CSV Files in Excel
- How You Use Alternate Keys to Import Records
- Import Attachments

Import Your Bill Plan and Revenue Plan Data

You can use Import Management to create or update bill plan and revenue plan records.

To import bill plan and revenue plan records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Object Attributes

To import your bill plan and revenue plan data into Oracle Applications Cloud, you must populate a CSV file with your source data and map that source data to target object attributes in Oracle Applications Cloud.
You need to do the following before creating the CSV file for data import:

- Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
- Ensure prerequisite setups are done, if applicable.
- Understand your options for uniquely identifying the records.
- Ensure parent records exist before importing child records.
- Identify the target object attributes that are required in the CSV file for a successful import.

**Before You Start**

You must do some basic checks before starting your import. For example:

- Complete all the prerequisites for importing each attribute in your source data.
- Have all parent records in place before importing child records.

**Select a Unique Identifier for Your Records**

To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the import process to uniquely identify the records. The file import process uses the attribute values to automatically map your source data to the target object attributes in Oracle Applications Cloud.

The preferred option to uniquely identify an object record is through the public unique identifier. If you’re creating new records, then you can provide a user-friendly public unique identifier (attributes denoted with ‘Number’ and usually visible in the business object’s UI). If you update a record for which you have previously provided a Number attribute, or for which a Number attribute is visible in the object’s UI, you can use the Number attribute to identify the record. For the bill plan and revenue plan object, the attribute is ContractPuid.

**Required Attributes and Validations for the Bill Plan and Revenue Plan Object**

To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure that you provide valid values for the attributes. The following table lists the required attributes for importing new bill plan and revenue plan records, prerequisite setup tasks for the attributes, and specific validations, if any, for bill plan and revenue plan import:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/Import Validations</th>
<th>Creating a Bill Plan and Revenue Plan Record</th>
<th>Updating an Existing Bill Plan and Revenue Plan Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>ContractPuid</td>
<td>The PUID of the contract for which the bill plan or revenue plan is being created or updated.</td>
<td>This must be a valid contract PUID.</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td>ExtSource</td>
<td>The external source of the bill or revenue plan.</td>
<td>This must be a valid combination of external source and key.</td>
<td>Required</td>
<td>Required</td>
</tr>
<tr>
<td>Attribute</td>
<td>Description</td>
<td>Prerequisite Setup Task/Import Validations</td>
<td>Creating a Bill Plan and Revenue Plan Record</td>
<td>Updating an Existing Bill Plan and Revenue Plan Record</td>
</tr>
<tr>
<td>----------------</td>
<td>--------------------------------------------------</td>
<td>---------------------------------------------------------------------------------</td>
<td>---------------------------------------------</td>
<td>------------------------------------------------------</td>
</tr>
<tr>
<td>ExtKey</td>
<td>The external key of the bill or revenue plan.</td>
<td>This must be a unique combination of external source and key.</td>
<td>Required</td>
<td>Required</td>
</tr>
<tr>
<td>BillPlanName</td>
<td>The bill or revenue plan name.</td>
<td>N/A</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td>BillMethodId</td>
<td>The bill or revenue method ID.</td>
<td>This must be a valid bill method ID.</td>
<td>Required if bill method name isn't passed.</td>
<td>Not required</td>
</tr>
<tr>
<td>BillMethodName</td>
<td>The bill or revenue method name.</td>
<td>This must be a valid bill method name.</td>
<td>Required if bill method ID isn't passed.</td>
<td>Not required</td>
</tr>
<tr>
<td>BillToCustAcctId</td>
<td>The bill-to customer account ID of the bill plan.</td>
<td>This must be a valid customer account ID.</td>
<td>Required if customer account name isn't passed.</td>
<td>Not required</td>
</tr>
<tr>
<td>BillToCustAcctNumber</td>
<td>The bill-to customer account number of the bill plan.</td>
<td>This must be a valid customer account number.</td>
<td>Required if customer account ID isn't passed.</td>
<td>Not required</td>
</tr>
<tr>
<td>BillToContactId</td>
<td>The bill-to contact ID of the bill plan.</td>
<td>This must be a valid contact ID.</td>
<td>Required if contact name isn't passed.</td>
<td>Not required</td>
</tr>
<tr>
<td>BillToContactName</td>
<td>The bill-to contact name of the bill plan.</td>
<td>This must be a valid contact name.</td>
<td>Required if contact ID isn't passed.</td>
<td>Not required</td>
</tr>
<tr>
<td>BillToSiteUseId</td>
<td>The bill-to site use ID of the bill plan.</td>
<td>This must be a valid party site use ID.</td>
<td>Required if party site use location isn't passed.</td>
<td>Not required</td>
</tr>
<tr>
<td>BillToSiteUseLocation</td>
<td>The bill-to site use location of the bill plan.</td>
<td>This must be a valid party site use location.</td>
<td>Required if party site use ID isn't passed.</td>
<td>Not required</td>
</tr>
<tr>
<td>InvoiceCurrencyOptCode</td>
<td>The billing currency type code of the bill plan.</td>
<td>This must be a valid currency type code.</td>
<td>Required if the currency type name isn't passed.</td>
<td>Not required</td>
</tr>
<tr>
<td>InvCurrOptMeaning</td>
<td>The billing currency type name of the bill plan.</td>
<td>This must be a valid currency type name.</td>
<td>Required if the currency type code isn't passed.</td>
<td>Not required</td>
</tr>
<tr>
<td>BillingCycleId</td>
<td>The billing cycle ID of the bill plan.</td>
<td>This must be a valid billing cycle ID.</td>
<td>Required if the billing cycle name isn't passed.</td>
<td>Not required</td>
</tr>
<tr>
<td>BillingCycleName</td>
<td>The billing cycle name of the bill plan.</td>
<td>This must be a valid billing cycle name.</td>
<td>Required if the billing cycle ID isn't passed.</td>
<td>Not required</td>
</tr>
<tr>
<td>PaymentTermId</td>
<td>The payment terms ID.</td>
<td>This must be a valid payment terms ID.</td>
<td>Required if the payment terms name isn't passed.</td>
<td>Not required</td>
</tr>
<tr>
<td>Attribute</td>
<td>Description</td>
<td>Prerequisite Setup Task/ Import Validations</td>
<td>Creating a Bill Plan and Revenue Plan Record</td>
<td>Updating an Existing Bill Plan and Revenue Plan Record</td>
</tr>
<tr>
<td>-------------------</td>
<td>------------------------------------</td>
<td>----------------------------------------------------------------------------------------------------------</td>
<td>---------------------------------------------</td>
<td>-------------------------------------------------------</td>
</tr>
<tr>
<td>PaymentTermName</td>
<td>The payment terms name.</td>
<td>This must be a valid payment terms name.</td>
<td>Required if the payment terms ID isn’t passed.</td>
<td>Not required</td>
</tr>
<tr>
<td>BillSetNum</td>
<td>The bill set of the bill plan.</td>
<td>N/A</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td>LaborInvoiceFormatId</td>
<td>The labor format ID of the bill plan.</td>
<td>This must be a valid labor format ID.</td>
<td>Required if the labor format name isn’t passed.</td>
<td>Not required</td>
</tr>
<tr>
<td>LaborInvoiceFormatName</td>
<td>The labor format name of the bill plan.</td>
<td>This must be a valid labor format name.</td>
<td>Required if the labor format ID isn’t passed.</td>
<td>Not required</td>
</tr>
<tr>
<td>NlInvoiceFormatId</td>
<td>The nonlabor format ID of the bill plan.</td>
<td>This must be a valid nonlabor format ID.</td>
<td>Required if the nonlabor format name isn’t passed.</td>
<td>Not required</td>
</tr>
<tr>
<td>NlInvoiceFormatName</td>
<td>The nonlabor format name of the bill plan.</td>
<td>This must be a valid nonlabor format name.</td>
<td>Required if the nonlabor format ID isn’t passed.</td>
<td>Not required</td>
</tr>
<tr>
<td>EventsInvoiceFormatId</td>
<td>The event format ID of the bill plan.</td>
<td>This must be a valid event format ID.</td>
<td>Required if the event format name isn’t passed.</td>
<td>Not required</td>
</tr>
<tr>
<td>EventsInvoiceFormatName</td>
<td>The event format name of the bill plan.</td>
<td>This must be a valid event format name.</td>
<td>Required if the event format ID isn’t passed.</td>
<td>Not required</td>
</tr>
</tbody>
</table>

You can view the bill plan and revenue plan object and attributes in the Manage Import Objects page of the Import Management flow. You can find attribute information like type, length, description, and so on, on this page.

Create the Source CSV File
You include the data that you want to import into CX Sales and B2B Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator > Tools > Import Management > Import Objects.
2. Select the Bill Plan and Revenue Plan object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

**Note:** For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click **Create Import Activity** in the **Manage Imports** page.
3. In the **Enter Import Options** page, provide a name for the import activity, and select Bill Plan and Revenue Plan from the **Object** drop-down list.
4. Select the CSV file in the **File Name** field, and click **Next**.
5. The source and target attributes are automatically mapped in the **Map Fields** page. Review and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking **Validate Data**. Click **Next**.
7. Review the import details on the **Review and Submit** page, and click **Submit** when you're ready.

**Review the Import Results**

Check if your import succeeded on the **Manage Imports** page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to **Navigator > Tools > Import Management > Import Queue**.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the **Status** column for the import activity. The import is successful if the status displays as **Completed**. You can drill down on the import activity to go to the **Import Status** page which provides the status details of the import activity.

**Related Topics**

- Potential Issues When Opening CSV Files in Excel
- Import Data

**Import Your Billing Control Data**

You can use Import Management to create or update billing control records.

To import billing control records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

**How You Map Your Source Data to Object Attributes**

To import your billing control data into Oracle Applications Cloud, you must populate a CSV file with your source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

- Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
- Ensure prerequisite setups are done, if applicable.
- Understand your options for uniquely identifying the records.
- Ensure parent records exist before importing child records.
- Identify the target object attributes that are required in the CSV file for a successful import.
Before You Start
You must do some basic checks before starting your import. For example:

- Complete all the prerequisites for importing each attribute in your source data.
- Have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the import process to uniquely identify the records. The file import process uses the attribute values to automatically map your source data to the target object attributes in Oracle Applications Cloud.

The preferred option to uniquely identify an object record is through the public unique identifier. If you’re creating new records, then you can provide a user-friendly public unique identifier (attributes denoted with 'Number' and usually visible in the business object’s UI). If you update a record for which you have previously provided a Number attribute, or for which a Number attribute is visible in the object's UI, you can use the Number attribute to identify the record. For the billing control object, the attribute is ContractPuid.

Required Attributes and Validations for the Billing Control Object
To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure that you provide valid values for the attributes. The following table lists the required attributes for importing new billing control records, prerequisite setup tasks for the attributes, and specific validations, if any, for billing control import:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/ Import Validations</th>
<th>Creating a Billing Control Record</th>
<th>Updating an Existing Billing Control Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>ContractPuid</td>
<td>The PUID of the contract with which the billing control is being associated.</td>
<td>This must be a valid contract PUID.</td>
<td>Required if the contract line PUID isn't passed.</td>
<td>Not required</td>
</tr>
<tr>
<td>LinePuid</td>
<td>The PUID of the contract line with which the billing control is being associated.</td>
<td>This must be a valid contract line PUID.</td>
<td>Required if the contract PUID isn't passed.</td>
<td>Not required</td>
</tr>
<tr>
<td>ExtSource</td>
<td>The external source of the billing control.</td>
<td>This must be a unique combination of external source and external key.</td>
<td>Required</td>
<td>Required</td>
</tr>
<tr>
<td>ExtKey</td>
<td>The external key of the billing control.</td>
<td>This must be a unique combination of external source and external key.</td>
<td>Required</td>
<td>Required</td>
</tr>
<tr>
<td>RbsElementId</td>
<td>The ID of the billing control element.</td>
<td>This must be a valid element ID.</td>
<td>Required if element name isn't passed.</td>
<td>Not required</td>
</tr>
<tr>
<td>RbsElementAlias</td>
<td>The name of the billing control element.</td>
<td>This must be a valid element name.</td>
<td>Required if element ID isn't passed.</td>
<td>Not required</td>
</tr>
</tbody>
</table>
You can view the billing control object and attributes in the Manage Import Objects page of the Import Management flow. You can find attribute information like type, length, description, and so on, on this page.

Create the Source CSV File
You include the data that you want to import into CX Sales and B2B Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator > Tools > Import Management > Import Objects.
2. Select the Billing Control object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

**Note:** For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Billing Control from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. The source and target attributes are automatically mapped in the Map Fields page. Review and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed. You can drill down on the import activity to go to the Import Status page which provides the status details of the import activity.

**Related Topics**
- Potential Issues When Opening CSV Files in Excel
- Import Data
Import Your Business Plan Data

You can use Import Management to create, update, or delete your business plan data.

You can import business plan records using these steps:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (.csv) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes

To import your Business Plan data into Oracle Applications Cloud, you need to populate a CSV file with your source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the .CSV file for data import:

- Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
- Ensure prerequisite steps are complete, such as understanding what attributes are required for importing your objects.
- Understand your options for uniquely identifying the records.
- Ensure parent records exist before importing child records.
- Identify the target object attributes that are required in the .CSV file for a successful import.

Before You Start

You must do some basic checks before starting your import. For example, make sure that:

- You have completed all the prerequisites for importing each attribute in your source data.
- You have all parent records in place before importing child records. For example, when importing the address of an account, ensure the account exists.

Select a Unique Identifier for Your Records

To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the import process to uniquely identify the records. The file import process uses the attribute values to automatically map your source data to the target object attributes in Oracle Applications Cloud.

The preferred options to uniquely identify an object record are as follows:

- **Internal ID**: If you’re identifying a record that already exists in Oracle Applications Cloud, then you can use the internal ID of the record, a system-generated unique identifier. Attributes with "ID" in the attribute name are typically internal IDs. You can determine the internal ID of a record by exporting Oracle Applications Cloud object data, or by doing a transactional database query. Using an internal ID typically provides better performance and reduces the import duration. For the Business Plan object, this attribute is BusinessPlanId.
- **Public unique identifiers**: If you’re creating new records, then you can provide a user-friendly public unique identifier (attributes denoted with ‘Number’ and usually visible in the business object’s UI). If you update a
Review Required Attributes and Validations for Business Plan Object

To import data successfully into Oracle Applications Cloud, your .CSV file must include the required attributes. Ensure that you provide valid values for the attributes.

The following table lists the required attributes for importing new Business Plan records, required attributes for updating Business Plan records, prerequisite setup tasks for the attributes, and specific validations, if any, for Business Plan import:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Data Type</th>
<th>Data Length</th>
<th>Prerequisite Setup Task/ Import Validations</th>
<th>Creating a Business Plan record</th>
<th>Updating an Existing Business Plan record</th>
</tr>
</thead>
<tbody>
<tr>
<td>BusinessPlanId</td>
<td>Unique Identifier</td>
<td>Long</td>
<td>18</td>
<td>None</td>
<td>Not required</td>
<td>Required</td>
</tr>
<tr>
<td>BusinessPlanNumber</td>
<td>Public Unique Identifier</td>
<td>String</td>
<td>64</td>
<td>None</td>
<td>Not required</td>
<td>A value is required either for BusinessPlanId or for BusinessPlanNumber.</td>
</tr>
<tr>
<td>PeriodTypeCode</td>
<td>Period Type such as Year, Quarter, or Period</td>
<td>String</td>
<td>30</td>
<td>Use the Manage Calendar Profile Option task to set a value for ZCA_COMMON_CALENDAR.</td>
<td>Required</td>
<td>Not Required</td>
</tr>
<tr>
<td>StatusCode</td>
<td>Status of the BusinessPlan such as ORA_DRAFT, ORA_APPROVED</td>
<td>String</td>
<td>30</td>
<td>None</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td>PeriodEndDisplayName</td>
<td>End Period Display Name</td>
<td>String</td>
<td>60</td>
<td>None</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td>PeriodStartDisplayName</td>
<td>Start Period Display Name</td>
<td>String</td>
<td>60</td>
<td>None</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td>Name</td>
<td>Unique name of the business plan</td>
<td>String</td>
<td>60</td>
<td>Enter a unique value.</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td>BusinessPlanClassCode</td>
<td>Class of the business plan such as Account or Partner</td>
<td>String</td>
<td>20</td>
<td>Navigate to the following in the Setup and Maintenance Work area:</td>
<td>Required</td>
<td>Not required</td>
</tr>
</tbody>
</table>
### Create the Source CSV File

You include the data that you want to import into CX Sales and B2B Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to **Navigator > Tools > Import Management > Import Objects**.
2. Select the **Contact** object in the table and click **Download**.

You can now edit the downloaded file and provide valid values for the required attributes.

---

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Data Type</th>
<th>Data Length</th>
<th>Prerequisite Setup Task/ Import Validations</th>
<th>Creating a Business Plan record</th>
<th>Updating an Existing Business Plan record</th>
</tr>
</thead>
<tbody>
<tr>
<td>PartnerId</td>
<td>Internal identifier of the Partner</td>
<td>Long</td>
<td>18</td>
<td>Enter the PartnerId if you select the BusinessPlanClassCode as PARTNER. A value is required, if you don't specify the PartnerNumber.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>PartnerNumber</td>
<td>Public unique identifier of the Partner</td>
<td>String</td>
<td>30</td>
<td>Enter the PartnerId if you select the BusinessPlanClassCode as PARTNER. A value is required, if you don't specify the PartnerId.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>CustomerId</td>
<td>Internal identifier of the Account</td>
<td>Long</td>
<td>18</td>
<td>Enter the PartnerId if you select the BusinessPlanClassCode as PARTNER. A value is required, if you don't specify the CustomerNumber.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>CustomerNumber</td>
<td>Public unique identifier of the Account</td>
<td>String</td>
<td>30</td>
<td>Enter the CustomerId or the CustomerNumber, if you select the BusinessPlanClassCode as ACCOUNT. A value is required, if you don't specify the CustomerId.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
</tbody>
</table>

You can view the Business Plan object along with all its child objects and attributes in the **Manage Import Objects** page of the **Import Management** flow. You can find attribute information like type, length, description, and so on, on this page.
Create the Import Activity

To import data into Oracle Applications Cloud, you need to create an import activity and provide the CSV file as an input to the activity.

To create an import activity, do the following:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Business Plan from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you’re ready.

Review the Import Results

Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed. You can drill down on the import activity to go to the Import Status page which provides the status details of the import activity.

Related Topics
• Import Data

Import Your Business Plan SWOT Data

You can use Import Management to create, update, or delete your business plan SWOT data.

To import Business Plan SWOT records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (.csv) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes

To import your Business Plan SWOT data into Oracle Applications Cloud, you need to populate a CSV file with your source data and map that source data to target object attributes in Oracle Applications Cloud.
You need to do the following before creating the .CSV file for data import:

- Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
- Ensure prerequisite steps are complete, such as understanding what attributes are required for importing your objects.
- Understand your options for uniquely identifying the records.
- Ensure parent records exist before importing child records.
- Identify the target object attributes that are required in the .CSV file for a successful import.

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

- You have completed all the prerequisites for importing each attribute in your source data.
- You have all parent records in place before importing child records. For example, when importing the address of an account, ensure the account exists.

Select a Unique Identifier for Your Records
To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the import process to uniquely identify the records. The file import process uses the attribute values to automatically map your source data to the target object attributes in Oracle Applications Cloud.

The preferred options to uniquely identify an object record are as follows:

- **Internal ID**: If you're identifying a record that already exists in Oracle Applications Cloud, then you can use the internal ID of the record, a system-generated unique identifier. Attributes with "ID" in the attribute name are typically internal IDs. You can determine the internal ID of a record by exporting Oracle Applications Cloud object data, or by doing a transactional database query. Using an internal ID typically provides better performance and reduces the import duration. For the Business Plan SWOT object, this attribute is SWOTId.

- **Public unique identifiers**: If you're creating new records, then you can provide a user-friendly public unique identifier (attributes denoted with 'Number' and usually visible in the business object's UI). If you update a record for which you have previously provided a Number attribute, or for which a Number attribute is visible in the object's UI, you can use the Number attribute to identify the record. For the BusinessPlan SWOT object, the attribute is SWOTNumber.

Required Attributes and Validations for Business Plan SWOT Object
To import data successfully into Oracle Applications Cloud, your .CSV file must include the required attributes. Ensure that you provide valid values for the attributes.

The following table lists the required attributes for importing new Business Plan SWOT records, required attributes for updating Business Plan SWOT records, prerequisite setup tasks for the attributes, and specific validations, if any, for Business Plan SWOT import:
### Attribute Description Data Type Data Length Prerequisite Setup Task/ Import Validations Creating a Business Plan SWOT Record Updating an Existing Business Plan SWOT Record

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Data Type</th>
<th>Data Length</th>
<th>Prerequisite Setup Task/ Import Validations</th>
<th>Creating a Business Plan SWOT Record</th>
<th>Updating an Existing Business Plan SWOT Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>SWOTTypeCode</td>
<td>Identifies one of the four seeded and not extensible SWOT type codes:</td>
<td>String</td>
<td>30</td>
<td>None</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td>SWOTDescription</td>
<td>A brief description of the SWOT types</td>
<td>String</td>
<td>2000</td>
<td>None</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td>SWOTId</td>
<td>Unique identifier of the SWOT</td>
<td>Long</td>
<td>18</td>
<td>None</td>
<td>Not required</td>
<td>Required</td>
</tr>
<tr>
<td>SWOTNumber</td>
<td>A unique number that identifies the SWOT record</td>
<td>String</td>
<td>64</td>
<td>None</td>
<td>Not required</td>
<td>Either the SWOTNumber or the SWOTId is required to update the records.</td>
</tr>
<tr>
<td>BusinessPlanId</td>
<td>The primary key of the parent record</td>
<td>Long</td>
<td>18</td>
<td>None</td>
<td>A value is required to define to which business plan this child record of the SWOT belongs.</td>
<td>Not required.</td>
</tr>
<tr>
<td>BusinessPlanNumber</td>
<td>A unique number that identifies the business plan</td>
<td>String</td>
<td>64</td>
<td>None</td>
<td>A value is required either for the BusinessPlanId or for the BusinessPlanNumber</td>
<td>Not required.</td>
</tr>
</tbody>
</table>

You can view the Business Plan SWOT object along with all its child objects and attributes in the Manage Import Objects page of the Import Management flow. You can find attribute information like type, length, description, and so on, on this page.

### Create the Source CSV File

The .CSV file is provided as input to the file-based data import process. You must populate the .CSV file with the data you want to import into Oracle Applications Cloud.

You can either create a CSV file on your own or use templates available in preexisting mappings. To download a template, do the following:

1. In the Navigator, under Tools, click Import Management.
2. Click Import Objects tab to open the Import Object Details page.
3. Select the object you’re interested in the Import Object Details page and click the Download icon next to that object name.

4. Save the template CSV file to a location on your desktop.

You must edit the template CSV file and provide valid values for the required attributes. You can attach different types of files, giving each file a specific description.

<table>
<thead>
<tr>
<th>Description</th>
<th>SWOTTypeCode</th>
<th>BusinessPlanNumber</th>
</tr>
</thead>
<tbody>
<tr>
<td>swot description</td>
<td>THREAT</td>
<td>myBP_0173</td>
</tr>
</tbody>
</table>

### Create the Import Activity

To import data into Oracle Applications Cloud, you need to create an import activity and provide the CSV file as an input to the activity.

To create an import activity, do the following:

1. In the Navigator, under Tools, click Import Management.
2. On the Manage Imports page, click Create Import Activity.
3. In the Create Import Activity: Enter Import Options page, provide a name for the import activity, and select Business Plan SWOT from the Object drop-down list.
4. In File Name, browse and upload the required .CSV file, and click Next.
5. In the Create Import Activity: Map Fields page edit the attribute mappings if required, and click Next.

**Note:** Click Validate Data to validate the mapping of the source file for unmapped columns and to check for data format issues.

6. In the Create Import Activity: Review and Submit page, click Submit.

### Review the Import Results

You can review the import results by checking for the import activity in the Manage Import Activity page. A file import activity is said to be successful when its status displays as Completed. To check the status of the import activity, do as follows:

1. In the Navigator, under Tools, click Import Management.
2. On the Manage Imports page, search for the import activity that you created using one of the search criteria, such as status, name, object, and so on.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed. The other valid values for the import activity status are Queued for import, Preparing data for import, Importing data, Completed with errors, and Unsuccessful.

**Note:** On this page you can also quickly view the number and status of all active imports, completed imports, and unsuccessful imports that have been submitted.

*Related Topics*

- Import Data
Import Your Business Plan Team Data

Use this topic to import Business Plan Team data into Oracle Applications Cloud. You can use the import functionality to create or update Business Plan Team records.

To import Business Plan Team records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (.csv) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes

To import your Business Plan Team data into Oracle Applications Cloud, you need to populate a CSV file with your source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the .CSV file for data import:

- Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
- Ensure prerequisite steps are complete, such as understanding what attributes are required for importing your objects.
- Understand your options for uniquely identifying the records.
- Ensure parent records exist before importing child records.
- Identify the target object attributes that are required in the .CSV file for a successful import.

Before You Start

You need to set certain options for some attributes in the application before you can populate them. When importing a child record, ensure that its parent record exists in the database.

Select a Unique Identifier for Your Records

To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the import process to uniquely identify the records. The file import process uses the attribute values to automatically map your source data to the target object attributes in Oracle Applications Cloud.

The preferred options to uniquely identify an object record are as follows:

- **Internal ID**: If you’re identifying a record that already exists in Oracle Applications Cloud, then you can use the internal ID of the record, a system-generated unique identifier. Attributes with "ID" in the attribute name are typically internal IDs. You can determine the internal ID of a record by exporting Oracle Applications Cloud object data, or by doing a transactional database query. Using an internal ID typically provides better performance and reduces the import duration. For the Business Plan Team object, this attribute is BusinessPlanResourceId.

- **Public unique identifiers**: If you’re creating new records, then you can provide a user-friendly public unique identifier (attributes denoted with 'Number' and usually visible in the business object's UI). If you update a record for which you have previously provided a Number attribute, or for which a Number attribute is visible in
the object’s UI, you can use the Number attribute to identify the record. For the Business Plan Team object, the attribute is BusinessPlanResourceNumber.

### Required Attributes and Validations

To import data successfully into Oracle Applications Cloud, your .CSV file must include the required attributes. Ensure that you provide valid values for the attributes.

The following table lists the required attributes for importing new Business Plan Team records, required attributes for updating Business Plan Team records, prerequisite setup tasks for the attributes, and specific validations, if any, for Business Plan Team import:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Data Type</th>
<th>Data Length</th>
<th>Prerequisite Setup Task/Import Validations</th>
<th>Creating a Business Plan Team Record</th>
<th>Updating an Existing Business Plan Team Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>Resourceld</td>
<td>Specifies the resource added to the business team plan</td>
<td>Long</td>
<td>18</td>
<td>None</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td>BusinessPlanId</td>
<td>Specifies the parent record ID for which this child record is being created</td>
<td>Long</td>
<td>18</td>
<td>None</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td>BusinessPlanResource</td>
<td>A unique number that identifies the business plan</td>
<td>String</td>
<td>230</td>
<td>None</td>
<td>Not required</td>
<td>Required</td>
</tr>
<tr>
<td>ResourceNumber</td>
<td>A unique identifier that identifies the resource (team member) number</td>
<td>String</td>
<td>30</td>
<td>None</td>
<td>Not required</td>
<td></td>
</tr>
<tr>
<td>BusinessPlanResourceId</td>
<td>The unique identifier of the business plan</td>
<td>Long</td>
<td>18</td>
<td>None</td>
<td>Not required</td>
<td>Either the BusinessPlanResourceId or the BusinessPlanResourceNumber is required to update the records.</td>
</tr>
<tr>
<td>BusinessPlanNumber</td>
<td>A unique number that identifies the business plan</td>
<td>String</td>
<td>64</td>
<td>None</td>
<td>Not required</td>
<td>Either the BusinessPlanResourceId or the BusinessPlanResourceNumber is required to create the records.</td>
</tr>
</tbody>
</table>
You can view the Business Plan Team object along with all its child objects and attributes in the Manage Import Objects page of the Import Management flow. You can find attribute information like type, length, description, and so on, on this page.

Create the Source CSV File

The .CSV file is provided as input to the file-based data import process. You must populate the .CSV file with the data you want to import into Oracle Applications Cloud.

You can either create a CSV file on your own or use templates available in preexisting mappings. To download a template, do the following:

1. In the Navigator, under Tools, click Import Management.
2. Click Import Objects tab to open the Import Object Details page.
3. Select the object you're interested in the Import Object Details page and click the Download icon next to that object name.
4. Save the template CSV file to a location on your desktop.

You must edit the template CSV file and provide valid values for the required attributes. You can attach different types of files, giving each file a specific description.

<table>
<thead>
<tr>
<th>MemberFunctionCode</th>
<th>Resourceld</th>
<th>BusinessPlanNumber</th>
</tr>
</thead>
<tbody>
<tr>
<td>ORA_BUS_DEVELOPMENT</td>
<td>100010032635399</td>
<td>myBP_0173</td>
</tr>
</tbody>
</table>

Create the Import Activity

To import data into Oracle Applications Cloud, you need to create an import activity and provide the CSV file as an input to the activity.

To create an import activity, do the following:

1. In the Navigator, under Tools, click Import Management.
2. On the Manage Imports page, click Create Import Activity.
3. In the Create Import Activity: Enter Import Options page, provide a name for the import activity, and select Business Plan Team from the Object drop-down list.
4. In File Name, browse and upload the required .CSV file, and click Next.
5. In the Create Import Activity: Map Fields page edit the attribute mappings if required, and click Next.
   Note: Click Validate Data to validate the mapping of the source file for unmapped columns and to check for data format issues.
6. In the Create Import Activity: Review and Submit page, click Submit.

Review the Import Results

You can review the import results by checking for the import activity in the Manage Import Activity page. A file import activity is said to be successful when its status displays as Completed. To check the status of the import activity, do as follows:

1. In the Navigator, under Tools, click Import Management.
2. On the Manage Imports page, search for the import activity that you created using one of the search criteria, such as status, name, object, and so on.

3. Check the Status column for the import activity. The import is successful if the status displays as Completed. The other valid values for the import activity status are Queued for import, Preparing data for import, Importing data, Completed with errors, and Unsuccessful.

**Note:** On this page you can also quickly view the number and status of all active imports, completed imports, and unsuccessful imports that have been submitted.

### Import Your Campaign Data

You can use Import Management to create or update Campaign records.

To import Campaign records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

### How You Map Your Source Data to Target Object Attributes

To import your Campaign data into Oracle Applications Cloud, you need to populate a CSV file with your source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

- Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
- Ensure prerequisite setups are done, if applicable.
- Understand your options for uniquely identifying the records.
- Ensure parent records exist before importing child records.
- Identify the target object attributes that are required in the CSV file for a successful import.

### Before You Start

You must do some basic checks before starting your import. For example, make sure that:

- You have completed all the prerequisites for importing each attribute in your source data.
- You have all parent records in place before importing child records.

### Select a Unique Identifier for Your Records

All records must be unique in the application. If you’re creating records, then you can provide an easily understandable public unique identifier. These are, usually, denoted with ‘Number’ and visible in the business object’s UI. PUID attributes
are usually named <object> Number. If you're updating a record with a Number attribute, then use the Number attribute to identify the record. For more information about public unique identifiers, see the topic "How You Use Alternate Keys to Import Records" in Related Topics section.

Required Attributes and Validations for Campaign Object

To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure that you provide valid values for the attributes. This table lists the required attributes for importing new Campaign records, required attributes for updating Campaign records, prerequisite setup tasks for the attributes, and specific validations, if any, for Campaign import:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/Import Validations</th>
<th>Creating a Campaign Record</th>
<th>Updating an Existing Campaign Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>CreatedByModule</td>
<td>The module used to create the campaign.</td>
<td>By default, Web Service module is used to create the campaign.</td>
<td>Not Required</td>
<td>Not Required</td>
</tr>
<tr>
<td>OwnerId</td>
<td>The unique identifier of the campaign owner.</td>
<td>The party must exist. Export the Party object to determine the PartyId of a person.</td>
<td>Not Required</td>
<td>Not Required</td>
</tr>
<tr>
<td>OwnerPartyName</td>
<td>The party name of the owner.</td>
<td>The party must exist. Export the Party object to determine the PartyName of a person.</td>
<td>Not Required</td>
<td>Not Required</td>
</tr>
<tr>
<td>OwnerPartyNumber</td>
<td>The party number of the owner.</td>
<td>The party must exist. Export the Party object to determine the PartyNumber of a person.</td>
<td>Not Required</td>
<td>Not Required</td>
</tr>
<tr>
<td>ParentCampaignNumber</td>
<td>The public unique identifier of the parent campaign.</td>
<td>Export the Campaign records to identify the CampaignNumber of the parent campaign.</td>
<td>Not Required</td>
<td>Not Required</td>
</tr>
<tr>
<td>Status</td>
<td>The status of the campaign.</td>
<td>The default value is Draft.</td>
<td>Not Required</td>
<td>Not Required</td>
</tr>
<tr>
<td>CampaignId</td>
<td>The unique identifier of the campaign.</td>
<td>No validation</td>
<td>Not Required</td>
<td>Either CampaignId or CampaignNumber is required.</td>
</tr>
<tr>
<td>CampaignName</td>
<td>The name of the campaign.</td>
<td>No validation</td>
<td>Required</td>
<td>Not Required</td>
</tr>
<tr>
<td>CampaignNumber</td>
<td>The PUID of the campaign.</td>
<td>No validation</td>
<td>Not Required</td>
<td>Required</td>
</tr>
</tbody>
</table>

You can view the Campaign object along with all its child objects and attributes in the Manage Import Objects page of the Import Management flow. You can find attribute information like type, length, description, and so on, on this page.
Create the Source CSV File
You include the data that you want to import into CX Sales and B2B Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator > Tools > Import Management > Import Objects.
2. Select the Campaign object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note: For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Campaign from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
   You would see that the source and target attributes are automatically mapped in the Map Fields page. Review and edit the mappings if required.
5. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
6. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed. You can drill down on the import activity to go to the Import Status page which provides the status details of the import activity.

Related Topics
- Potential Issues When Opening CSV Files in Excel
- How You Use Alternate Keys to Import Records
- Import Data

Import Your Campaign Member Data
You can use Import Management to create or update Campaign Member records.
To import Campaign Member records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes

To import your Campaign Member data into Oracle Applications Cloud, you need to populate a CSV file with your source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

- Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
- Ensure prerequisite setups are done, if applicable.
- Understand your options for uniquely identifying the records.
- Ensure parent records exist before importing child records.
- Identify the target object attributes that are required in the CSV file for a successful import.

Before You Start

You must do some basic checks before starting your import. For example, make sure that:

- You have completed all the prerequisites for importing each attribute in your source data.
- You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records

All records must be unique in the application. If you’re creating records, then you can provide an easily understandable public unique identifier. These are, usually, denoted with ‘Number’ and visible in the business object’s UI. PUID attributes are usually named <object> Number. If you’re updating a record with a Number attribute, then use the Number attribute to identify the record. For more information about public unique identifiers, see the topic “How You Use Alternate Keys to Import Records” in Related Topics section.

Required Attributes and Validations for Campaign Member Object

To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure that you provide valid values for the attributes. This table lists the required attributes for importing new Campaign Member records, required attributes for updating Campaign Member records, prerequisite setup tasks for the attributes, and specific validations, if any, for Campaign Member import:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/Import Validations</th>
<th>Creating a Campaign Member Record</th>
<th>Updating an Existing Campaign Member Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>CampaignMemberId</td>
<td>The primary key of the campaign member.</td>
<td>No Validation</td>
<td>Required Auto-generated</td>
<td>Either CampaignMemberId or CampaignMemberNumber is required.</td>
</tr>
<tr>
<td>Attribute</td>
<td>Description</td>
<td>Prerequisite Setup Task/Import Validations</td>
<td>Creating a Campaign Member Record</td>
<td>Updating an Existing Campaign Member Record</td>
</tr>
<tr>
<td>-------------------------------</td>
<td>-----------------------------------------------------------------------------</td>
<td>----------------------------------------------------------------------------------------------------------</td>
<td>-----------------------------------</td>
<td>--------------------------------------------</td>
</tr>
<tr>
<td>CreatedByModule</td>
<td>The module used to create the campaign member.</td>
<td>No Validation</td>
<td>Not Required</td>
<td>Not Required</td>
</tr>
<tr>
<td>CampaignCampaignNumber</td>
<td>The Campaign PUID associated with the campaign member row.</td>
<td>Identify the Campaign Number by exporting the Campaign objects.</td>
<td>Not Required</td>
<td>Not Required</td>
</tr>
<tr>
<td>MemberResponseDate</td>
<td>The date when the campaign member responded to the campaign.</td>
<td>No Validation</td>
<td>Required</td>
<td>Required</td>
</tr>
<tr>
<td>ContactPartyNumber</td>
<td>The contact party number of the campaign member.</td>
<td>Identify the Party Number for Contact by exporting the Contact party associated with the campaign member. Either provide the Lead Number or Contact Number value.</td>
<td>Required</td>
<td>Required</td>
</tr>
<tr>
<td>LeadLeadNumber</td>
<td>The lead number for the campaign member.</td>
<td>Identify the Party Number for Lead by exporting the Lead party associated with the campaign member. Either provide the LeadNumber or the Contact Number.</td>
<td>Required</td>
<td>Required</td>
</tr>
<tr>
<td>CampaignId</td>
<td>The unique identifier of the campaign.</td>
<td>Identify the Campaign Id by exporting the Campaign objects.</td>
<td>Required</td>
<td>Required</td>
</tr>
<tr>
<td>CampaignNumber</td>
<td>The PUID of the campaign.</td>
<td>Identify the Campaign Number by exporting the Campaign objects.</td>
<td>Not Required</td>
<td>Not Required</td>
</tr>
<tr>
<td>CampaignMemberNumber</td>
<td>The PUID of the campaign member.</td>
<td>No Validation</td>
<td>Not Required</td>
<td>Required</td>
</tr>
</tbody>
</table>

You can view the Campaign Member object along with all its child objects and attributes in the Manage Import Objects page of the Import Management flow. You can find attribute information like type, length, description, and so on, on this page.

**Create the Source CSV File**

You include the data that you want to import into CX Sales and B2B Service in a source CSV file.
You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to **Navigator > Tools > Import Management > Import Objects**.
2. Select the **Campaign Member** object in the table and click **Download**.

You can now edit the downloaded file and provide valid values for the required attributes.

**Note:** For help in populating the CSV file and to avoid any issues in entering values, see the topic **Potential Issues When Opening CSV Files With Excel** in Related Topics section.

### Create the Import Activity

After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to **Navigator > Tools > Import Management > Import Queue**.
2. Click **Create Import Activity** in the **Manage Imports** page.
3. In the **Enter Import Options** page, provide a name for the import activity, and select Campaign Member from the **Object** drop-down list.
4. Select the CSV file in the **File Name** field, and click **Next**.
   - You would see that the source and target attributes are automatically mapped in the **Map Fields** page. Review and edit the mappings if required.
5. Check the file for unmapped columns or data format issues by clicking **Validate Data**. Click **Next**.
6. Review the import details on the **Review and Submit** page, and click **Submit** when you're ready.

### Review the Import Results

Check if your import succeeded on the **Manage Imports** page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to **Navigator > Tools > Import Management > Import Queue**.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the **Status** column for the import activity. The import is successful if the status displays as **Completed**. You can drill down on the import activity to go to the **Import Status** page which provides the status details of the import activity.

**Related Topics**

- Potential Issues When Opening CSV Files in Excel
- How You Use Alternate Keys to Import Records
- Import Data

### Import Your Case Data

You can use Import Management to create update, or delete Case records.

To import Case records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes

To import your Case data into Oracle Applications Cloud, you need to populate a CSV file with your source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

- Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
- Ensure prerequisite setups are done, if applicable.
- Understand your options for uniquely identifying the records.
- Ensure parent records exist before importing child records.
- Identify the target object attributes that are required in the CSV file for a successful import.

Before You Start

You must do some basic checks before starting your import. For example, make sure that:

- You have completed all the prerequisites for importing each attribute in your source data.
- You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records

All records must be unique in the application. You can use one of these to identify records:

- Public unique identifiers: If you’re creating records, then you can provide an easily understandable public unique identifier. These are, usually, denoted with ‘Number’ and visible in the business object’s UI. PUID attributes are usually named <object> Number. If you’re updating a record with a Number attribute, then use the Number attribute to identify the record. For more information about public unique identifiers, see the topic "How You Use Alternate Keys to Import Records" in Related Topics section.
- Source system and source system reference: Source system is an identifier for the external system, and source system reference is a unique identifier within the external system. If you’re importing new cases or are updating cases that have source system reference data, then provide the source system and source system reference values.

Required Attributes and Validations for Case Object

To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure that you provide valid values for the attributes. This table lists the required attributes for importing new Case records, required attributes for updating Case records, prerequisite setup tasks for the attributes, and specific validations, if any, for Case import:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/ Import Validations</th>
<th>Creating a Case Record</th>
<th>Updating an Existing Case Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>Caseld</td>
<td>Indicates the case identifier</td>
<td>A valid primary key in the destination system. Either the CaseNumber or the</td>
<td>Not required</td>
<td>Optional</td>
</tr>
<tr>
<td></td>
<td></td>
<td>CaseNumber may be used. Either the CaseNumber or the</td>
<td>This is auto generated.</td>
<td></td>
</tr>
<tr>
<td>Attribute</td>
<td>Description</td>
<td>Prerequisite Setup Task/Import Validations</td>
<td>Creating a Case Record</td>
<td>Updating an Existing Case Record</td>
</tr>
<tr>
<td>----------------------------</td>
<td>------------------------------------</td>
<td>-------------------------------------------</td>
<td>------------------------</td>
<td>----------------------------------</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Caseld should be entered. If both are entered, the Caseld is preferred.</td>
<td></td>
<td>Either the CaseNumber or the Caseld is required.</td>
</tr>
<tr>
<td>StatusTypeCd</td>
<td>Indicates the status type of the case</td>
<td>A valid value is required.</td>
<td>Optional</td>
<td>Optional</td>
</tr>
<tr>
<td></td>
<td></td>
<td>The default value is ORA_SVC_ACTIVE.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>StripeCd</td>
<td>Indicates the stripe code for the case</td>
<td>A valid value is required.</td>
<td>Optional</td>
<td>Not required</td>
</tr>
<tr>
<td></td>
<td></td>
<td>The Lookup code that indicates the stripe code such as CRM, HCM, or PRM</td>
<td></td>
<td></td>
</tr>
<tr>
<td>StatusCd</td>
<td>Indicates the status of the case</td>
<td>A valid value is required.</td>
<td>Optional</td>
<td>Optional</td>
</tr>
<tr>
<td></td>
<td></td>
<td>The default value is ORA_SVC_NEW.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>PrimaryContactPartyNumber</td>
<td>The alternate key of the case primary contact</td>
<td>A valid PUID for the PrimaryContactPartyNumber in the destination system</td>
<td>Optional</td>
<td>Optional</td>
</tr>
<tr>
<td>PrimaryHouseholdPartyName</td>
<td>Indicates the name of the case primary household</td>
<td>A valid unique name in the destination system</td>
<td>Optional</td>
<td>Optional</td>
</tr>
<tr>
<td>PrimaryHouseholdPartyNumber</td>
<td>The alternate key of the case primary household</td>
<td>A valid PUID for the PrimaryHouseholdPartyNumber in the destination system</td>
<td>Optional</td>
<td>Optional</td>
</tr>
<tr>
<td>QueueName</td>
<td>The name of the queue associated with the case</td>
<td>A valid unique name in the destination system</td>
<td>Optional</td>
<td>Optional</td>
</tr>
<tr>
<td>QueueNumber</td>
<td>The alternate key of the queue associated to the case</td>
<td>A valid unique name in the destination system</td>
<td>Optional</td>
<td>Optional</td>
</tr>
<tr>
<td>ReportedByPartyNumber</td>
<td>The alternate key of the user who reported the case</td>
<td>A valid PUID for ReportedByPartyNumber in the destination system</td>
<td>Optional</td>
<td>Optional</td>
</tr>
<tr>
<td>LastUpdatedByPartyNumber</td>
<td>The alternate key of the user who last updated the case</td>
<td>A valid unique name in the destination system</td>
<td>Optional</td>
<td>Not required</td>
</tr>
<tr>
<td>Title</td>
<td>Indicates the title of the case</td>
<td>No validation</td>
<td>Required</td>
<td>Optional</td>
</tr>
</tbody>
</table>
You can view the Case object along with all its child objects and attributes in the Manage Import Objects page of the Import Management flow. You can find attribute information like type, length, description, and so on, on this page.

Create the Source CSV File
You include the data that you want to import into CX Sales and B2B Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator > Tools > Import Management > Import Objects.
2. Select the Case object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

**Note:** For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.
Create the Import Activity

After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Case from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you’re ready.

Review the Import Results

Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.
   You can drill down on the import activity to go to the Import Status page which provides the status details of the import activity.

Related Topics

- Potential Issues When Opening CSV Files in Excel
- How You Use Alternate Keys to Import Records
- Import Data

Import Your Case Contact Data

You can use Import Management to create update, or delete Case Contact records.

To import Case Contact records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes

To import your Case Contact data into Oracle Applications Cloud, you need to populate a CSV file with your source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

- Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
• Ensure prerequisite setups are done, if applicable.
• Understand your options for uniquely identifying the records.
• Ensure parent records exist before importing child records.
• Identify the target object attributes that are required in the CSV file for a successful import.

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.
• You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
All records must be unique in the application. You can use one of these to identify records:

• Public unique identifiers: If you’re creating records, then you can provide an easily understandable public unique identifier. These are, usually, denoted with ‘Number’ and visible in the business object’s UI. PUID attributes are usually named <object> Number. If you’re updating a record with a Number attribute, then use the Number attribute to identify the record. For more information about public unique identifiers, see the topic "How You Use Alternate Keys to Import Records" in Related Topics section.
• Source system and source system reference: Source system is an identifier for the external system, and source system reference is a unique identifier within the external system. If you’re importing new Case Contacts or are updating Case Contacts that have source system reference data, then provide the source system and source system reference values.

Required Attributes and Validations for Case Contact Object
To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure that you provide valid values for the attributes. This table lists the required attributes for importing new Case Contact records, required attributes for updating Case Contact records, prerequisite setup tasks for the attributes, and specific validations, if any, for Case Contact import:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/Import Validations</th>
<th>Creating a Case Contact Record</th>
<th>Updating an Existing Case Contact Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>CaseContactId</td>
<td>Indicates the case contact identifier</td>
<td>A valid Id for the CaseContact row in the destination system</td>
<td>Not required</td>
<td>Required</td>
</tr>
<tr>
<td>PartyId</td>
<td>Indicates the PartyId of the contact</td>
<td>A valid PUID for the PartyId in the destination system</td>
<td>Required</td>
<td>Required</td>
</tr>
<tr>
<td>ContactPartyNumber</td>
<td>Indicates the party number of the contact</td>
<td>A valid PUID for the ContactPartyNumber in the destination system</td>
<td>Required</td>
<td>Required</td>
</tr>
</tbody>
</table>
### Attribute | Description | Prerequisite Setup Task/Import Validations | Creating a Case Contact Record | Updating an Existing Case Contact Record
---|---|---|---|---
| | | | | |
| | | | | |
| PartyName | Indicates the party Id of the contact | A valid PUID for the PartyName in the destination system | Required | Required
| | | | | |
| CaseId | Indicates the case to which this contact is associated | A valid CaseId in the destination system | Not required | Not required
| | | | | |
| CaseNumber | Indicates the case number to which this contact is associated | A valid CaseNumber in the destination system | Not required | Not required

You can view the Case Contact object along with all its child objects and attributes in the Manage Import Objects page of the Import Management flow. You can find attribute information like type, length, description, and so on, on this page.

### Create the Source CSV File

You include the data that you want to import into CX Sales and B2B Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to **Navigator > Tools > Import Management > Import Objects**.
2. Select the **Case Contact** object in the table and click **Download**.

You can now edit the downloaded file and provide valid values for the required attributes.

**Note:** For help in populating the CSV file and to avoid any issues in entering values, see the topic **Potential Issues When Opening CSV Files With Excel** in Related Topics section.

### Create the Import Activity

After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to **Navigator > Tools > Import Management > Import Queue**.
2. Click **Create Import Activity** in the Manage Imports page.
3. In the **Enter Import Options** page, provide a name for the import activity, and select Case Contact from the **Object** drop-down list.
4. Select the CSV file in the **File Name** field, and click **Next**.
5. You would see that the source and target attributes are automatically mapped in the **Map Fields** page. Review and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

**Review the Import Results**

Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed. You can drill down on the import activity to go to the Import Status page which provides the status details of the import activity.

**Related Topics**
- Potential Issues When Opening CSV Files in Excel
- How You Use Alternate Keys to Import Records
- Import Data

**Import Your Case Household Data**

You can use Import Management to create update, or delete Case Household records.

To import Case Household records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

**How You Map Your Source Data to Target Object Attributes**

To import your Case Household data into Oracle Applications Cloud, you need to populate a CSV file with your source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

- Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
- Ensure prerequisite setups are done, if applicable.
- Understand your options for uniquely identifying the records.
- Ensure parent records exist before importing child records.
- Identify the target object attributes that are required in the CSV file for a successful import.

**Before You Start**

You must do some basic checks before starting your import. For example, make sure that:

- You have completed all the prerequisites for importing each attribute in your source data.
Select a Unique Identifier for Your Records

All records must be unique in the application. You can use one of these to identify records:

- Public unique identifiers: If you’re creating records, then you can provide an easily understandable public unique identifier. These are, usually, denoted with ‘Number’ and visible in the business object’s UI. PUID attributes are usually named <object> Number. If you’re updating a record with a Number attribute, then use the Number attribute to identify the record. For more information about public unique identifiers, see the topic "How You Use Alternate Keys to Import Records" in Related Topics section.

- Source system and source system reference: Source system is an identifier for the external system, and source system reference is a unique identifier within the external system. If you’re importing new Case Households or are updating Case Households that have source system reference data, then provide the source system and source system reference values.

Required Attributes and Validations for Case Household Object

To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure that you provide valid values for the attributes. This table lists the required attributes for importing new Case Household records, required attributes for updating Case Household records, prerequisite setup tasks for the attributes, and specific validations, if any, for Case Household import:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/ Import Validations</th>
<th>Creating a Case Household Record</th>
<th>Updating an Existing Case Household Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>CaseHouseholdId</td>
<td>Indicates the case household identifier</td>
<td>A valid Id for the CaseHousehold row in the destination system</td>
<td>Not required</td>
<td>Required</td>
</tr>
<tr>
<td>PartyId</td>
<td>Indicates the PartyId of the household</td>
<td>A valid PUID for the PartyId in the destination system</td>
<td>Required</td>
<td>Required</td>
</tr>
<tr>
<td></td>
<td></td>
<td>A valid value is required either for the PartyId or the HouseholdPartyNumber in the destination system</td>
<td></td>
<td>A valid value is required either for the PartyId or the HouseholdPartyNumber in the destination system</td>
</tr>
<tr>
<td>HouseholdPartyNumber</td>
<td>Indicates the party number of the household</td>
<td>A valid PUID for the HouseholdPartyNumber in the destination system</td>
<td>Required</td>
<td>Required</td>
</tr>
<tr>
<td></td>
<td></td>
<td>A valid value is required either for the PartyId or the HouseholdPartyNumber in the destination system</td>
<td></td>
<td>A valid value is required either for the PartyId or the HouseholdPartyNumber in the destination system</td>
</tr>
<tr>
<td>HouseholdName</td>
<td>Indicates the name of the household</td>
<td>A valid unique HouseholdName in the destination system</td>
<td>Required</td>
<td>Required</td>
</tr>
<tr>
<td></td>
<td></td>
<td>A valid value is required either for the PartyId or the HouseholdName in the destination system. If both values exist, the PartyId is considered.</td>
<td></td>
<td>A valid value is required either for the PartyId or the HouseholdName in the destination system. If both values exist, the PartyId is considered.</td>
</tr>
</tbody>
</table>
You can view the Case Household object along with all its child objects and attributes in the Manage Import Objects page of the Import Management flow. You can find attribute information like type, length, description, and so on, on this page.

Create the Source CSV File
You include the data that you want to import into CX Sales and B2B Service in a source CSV file. You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator > Tools > Import Management > Import Objects.
2. Select the Case Household object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note: For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Case Household from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you’re ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the **Status** column for the import activity. The import is successful if the status displays as **Completed**. You can drill down on the import activity to go to the **Import Status** page which provides the status details of the import activity.

**Related Topics**
- Potential Issues When Opening CSV Files in Excel
- How You Use Alternate Keys to Import Records
- Import Data

## Import Your Case Message Data

You can use Import Management to create update, or delete Case Message records.

To import Case Message records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

### How You Map Your Source Data to Target Object Attributes

To import your Case Message data into Oracle Applications Cloud, you need to populate a CSV file with your source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

- Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
- Ensure prerequisite setups are done, if applicable.
- Understand your options for uniquely identifying the records.
- Ensure parent records exist before importing child records.
- Identify the target object attributes that are required in the CSV file for a successful import.

### Before You Start

You must do some basic checks before starting your import. For example, make sure that:

- You have completed all the prerequisites for importing each attribute in your source data.
- You have all parent records in place before importing child records.

### Select a Unique Identifier for Your Records

All records must be unique in the application. You can use one of these to identify records:

- Public unique identifiers: If you're creating records, then you can provide an easily understandable public unique identifier. These are, usually, denoted with ‘Number’ and visible in the business object's UI. PUID attributes are usually named `<object> Number`. If you're updating a record with a Number attribute, then use
the Number attribute to identify the record. For more information about public unique identifiers, see the topic "How You Use Alternate Keys to Import Records" in Related Topics section.

- Source system and source system reference: Source system is an identifier for the external system, and source system reference is a unique identifier within the external system. If you're importing new Case Messages or are updating Case Messages that have source system reference data, then provide the source system and source system reference values.

Required Attributes and Validations for Case Message Object
To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure that you provide valid values for the attributes. This table lists the required attributes for importing new Case Message records, required attributes for updating Case Message records, prerequisite setup tasks for the attributes, and specific validations, if any, for Case Message import:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/Import Validations</th>
<th>Creating a Case Message Record</th>
<th>Updating an Existing Case Message Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>LastEditedDate</td>
<td>Indicates the last edited date of the message for the case</td>
<td>No validation</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>MessageId</td>
<td>Indicates the case message identifier</td>
<td>A valid Id for the MessageId row in the destination system</td>
<td>Not required</td>
<td>Required</td>
</tr>
<tr>
<td>MessageTypeCd</td>
<td>Lookup code that indicates the type of message</td>
<td>A valid unique MessageTypeCd in the destination system</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td>OriginationDate</td>
<td>Indicates the date on which the message was posted</td>
<td>No validation</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>PostedByPartyNumber</td>
<td>Indicates the party number of the user who posted the message</td>
<td>A valid PUID for the PostedByPartyNumber in the destination system</td>
<td>Optional</td>
<td>Optional</td>
</tr>
<tr>
<td>RichTextFlag</td>
<td>Indicates whether the message content is in rich text format (Y or N)</td>
<td>A valid value from the lookup Y_N</td>
<td>Required</td>
<td>Optional</td>
</tr>
<tr>
<td>VisibilityCd</td>
<td>Lookup code that indicates the visibility of a message</td>
<td>A valid value in the destination system</td>
<td>Optional</td>
<td>Not required</td>
</tr>
<tr>
<td>StatusCd</td>
<td>Lookup code that indicates the status of the message</td>
<td>A valid value in the destination system</td>
<td>Required</td>
<td>Optional</td>
</tr>
<tr>
<td>Caseld</td>
<td>Indicates the case to which this message is associated</td>
<td>A valid Caseld in the destination system</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>Attribute</td>
<td>Description</td>
<td>Prerequisite Setup Task/Import Validations</td>
<td>Creating a Case Message Record</td>
<td>Updating an Existing Case Message Record</td>
</tr>
<tr>
<td>---------------</td>
<td>--------------------------------------------------</td>
<td>-----------------------------------------------------------------------</td>
<td>-----------------------------</td>
<td>----------------------------------------</td>
</tr>
<tr>
<td>CaseNumber</td>
<td>Indicates the case number to which this message is associated</td>
<td>A valid CaseNumber in the destination system</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>MessageNumber</td>
<td>Indicates the reference number of the message ID</td>
<td>A valid MessageNumber in the destination system</td>
<td>Not required</td>
<td>Not required</td>
</tr>
</tbody>
</table>

You can view the Case Message object along with all its child objects and attributes in the Manage Import Objects page of the Import Management flow. You can find attribute information like type, length, description, and so on, on this page.

### Create the Source CSV File

You include the data that you want to import into CX Sales and B2B Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to **Navigator > Tools > Import Management > Import Objects**.
2. Select the **Case Message** object in the table and click **Download**.

You can now edit the downloaded file and provide valid values for the required attributes.

**Note:** For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.

### Create the Import Activity

After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to **Navigator > Tools > Import Management > Import Queue**.
2. Click **Create Import Activity** in the Manage Imports page.
3. In the **Enter Import Options** page, provide a name for the import activity, and select Case Message from the **Object** drop-down list.
4. Select the CSV file in the **File Name** field, and click **Next**.
5. You would see that the source and target attributes are automatically mapped in the **Map Fields** page. Review and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking **Validate Data**. Click **Next**.
7. Review the import details on the **Review and Submit** page, and click **Submit** when you're ready.

### Review the Import Results

Check if your import succeeded on the **Manage Imports** page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to **Navigator > Tools > Import Management > Import Queue**.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the **Status** column for the import activity. The import is successful if the status displays as **Completed**. You can drill down on the import activity to go to the **Import Status** page which provides the status details of the import activity.
Import Your Case Opportunity Data

You can use Import Management to create update, or delete Case Opportunity records.

To import Case Opportunity records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes

To import your Case Opportunity data into Oracle Applications Cloud, you need to populate a CSV file with your source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

- Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
- Ensure prerequisite setups are done, if applicable.
- Understand your options for uniquely identifying the records.
- Ensure parent records exist before importing child records.
- Identify the target object attributes that are required in the CSV file for a successful import.

Before You Start

You must do some basic checks before starting your import. For example, make sure that:

- You have completed all the prerequisites for importing each attribute in your source data.
- You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records

All records must be unique in the application. You can use one of these to identify records:

- Public unique identifiers: If you're creating records, then you can provide an easily understandable public unique identifier. These are, usually, denoted with 'Number' and visible in the business object's UI. PUID attributes are usually named <object> Number. If you're updating a record with a Number attribute, then use the Number attribute to identify the record. For more information about public unique identifiers, see the topic "How You Use Alternate Keys to Import Records" in Related Topics section.
• Source system and source system reference: Source system is an identifier for the external system, and source system reference is a unique identifier within the external system. If you're importing new Case Opportunities or are updating Case Opportunities that have source system reference data, then provide the source system and source system reference values.

Required Attributes and Validations for Case Opportunity Object

To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure that you provide valid values for the attributes. This table lists the required attributes for importing new Case Opportunity records, required attributes for updating Case Opportunity records, prerequisite setup tasks for the attributes, and specific validations, if any, for Case Opportunity import:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/Import Validations</th>
<th>Creating a Case Opportunity Record</th>
<th>Updating an Existing Case Opportunity Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>CaseOpportunityId</td>
<td>Indicates the case opportunity identifier</td>
<td>A valid identifier for the CaseOpportunityId row in the destination system</td>
<td>Not required</td>
<td>Required</td>
</tr>
<tr>
<td>OptyId</td>
<td>Indicates the opportunity associated with the case</td>
<td>A valid PUID for the OptyId in the destination system</td>
<td>Required</td>
<td>Required</td>
</tr>
<tr>
<td>OptyNumber</td>
<td>Indicates the opportunity number of the case opportunity</td>
<td>A valid PUID is required for OptyNumber in the destination system</td>
<td>Required</td>
<td>Required</td>
</tr>
<tr>
<td>CaseNumber</td>
<td>Indicates the case number to which this case opportunity is associated</td>
<td>A valid CaseNumber in the destination system</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>CaseId</td>
<td>Indicates the case to which this case opportunity is associated</td>
<td>A valid CaseId in the destination system</td>
<td>Not required</td>
<td>Not required</td>
</tr>
</tbody>
</table>

You can view the Case Opportunity object along with all its child objects and attributes in the Manage Import Objects page of the Import Management flow. You can find attribute information like type, length, description, and so on, on this page.

Create the Source CSV File

You include the data that you want to import into CX Sales and B2B Service in a source CSV file.
You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator > Tools > Import Management > Import Objects.
2. Select the Case Opportunity object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note: For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity

After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Case Opportunity from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you’re ready.

Review the Import Results

Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed. You can drill down on the import activity to go to the Import Status page which provides the status details of the import activity.

Related Topics

- Potential Issues When Opening CSV Files in Excel
- How You Use Alternate Keys to Import Records
- Import Data

Import Your Case Resource Data

You can use Import Management to create update, or delete Case Resource records.

To import Case Resource records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes

To import your Case Resource data into Oracle Applications Cloud, you need to populate a CSV file with your source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

- Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
- Ensure prerequisite setups are done, if applicable.
- Understand your options for uniquely identifying the records.
- Ensure parent records exist before importing child records.
- Identify the target object attributes that are required in the CSV file for a successful import.

Before You Start

You must do some basic checks before starting your import. For example, make sure that:

- You have completed all the prerequisites for importing each attribute in your source data.
- You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records

All records must be unique in the application. You can use one of these to identify records:

- Public unique identifiers: If you're creating records, then you can provide an easily understandable public unique identifier. These are, usually, denoted with 'Number' and visible in the business object's UI. PUID attributes are usually named `<object> Number`. If you're updating a record with a Number attribute, then use the Number attribute to identify the record. For more information about public unique identifiers, see the topic "How You Use Alternate Keys to Import Records" in Related Topics section.
- Source system and source system reference: Source system is an identifier for the external system, and source system reference is a unique identifier within the external system. If you're importing new Case Resources or are updating Case Resources that have source system reference data, then provide the source system and source system reference values.

Required Attributes and Validations for Case Resource Object

To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure that you provide valid values for the attributes. This table lists the required attributes for importing new Case Resource records, required attributes for updating Case Resource records, prerequisite setup tasks for the attributes, and specific validations, if any, for Case Resource import:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/ Import Validations</th>
<th>Creating a Case Resource Record</th>
<th>Updating an Existing Case Resource Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>CaseResourceId</td>
<td>Indicates the case resource identifier</td>
<td>A valid identifier for the CaseOpportunityId row in the destination system</td>
<td>Not required</td>
<td>Required</td>
</tr>
</tbody>
</table>
### Attribute Description Prerequisite Setup Task/ Import Validations Creating a Case Resource Record Updating an Existing Case Resource Record

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/ Import Validations</th>
<th>Creating a Case Resource Record</th>
<th>Updating an Existing Case Resource Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>PartyId</td>
<td>Indicates the party identifier of the resource</td>
<td>A valid PUID for PartyId in the destination system</td>
<td>Required</td>
<td>Required</td>
</tr>
<tr>
<td></td>
<td></td>
<td>A valid value is required either for the PartyId or the ResourcePartyNumber in the destination system. If both values are present, the PartyId is considered.</td>
<td></td>
<td>A valid value is required either for the PartyId or the ResourcePartyNumber in the destination system. If both values are present, the PartyId is considered.</td>
</tr>
<tr>
<td>ResourcePartyNumber</td>
<td>Indicates the party number of the resource</td>
<td>A valid PUID for the ResourcePartyNumber in the destination system</td>
<td>Required</td>
<td>Required</td>
</tr>
<tr>
<td></td>
<td></td>
<td>A valid value is required either for the PartyId or the ResourcePartyNumber in the destination system. If both values are present, the PartyId is considered.</td>
<td></td>
<td>A valid value is required either for the PartyId or the ResourcePartyNumber in the destination system. If both values are present, the PartyId is considered.</td>
</tr>
<tr>
<td>ResourceName</td>
<td>Indicates the name of the resource</td>
<td>A valid unique ResourceName in the destination system</td>
<td>Required</td>
<td>Required</td>
</tr>
<tr>
<td></td>
<td></td>
<td>A valid value is required either for the PartyId or the ResourcePartyNumber in the destination system. If both values are present, the PartyId is considered.</td>
<td></td>
<td>A valid value is required either for the PartyId or the ResourcePartyNumber in the destination system. If both values are present, the PartyId is considered.</td>
</tr>
<tr>
<td>CaseId</td>
<td>Indicates the case to which this resource is associated</td>
<td>A valid CaseId in the destination system</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>CaseNumber</td>
<td>Indicates the case number of the case to which the resource is associated</td>
<td>A valid CaseNumber in the destination system</td>
<td>Not required</td>
<td>Not required</td>
</tr>
</tbody>
</table>

You can view the Case Resource object along with all its child objects and attributes in the Manage Import Objects page of the Import Management flow. You can find attribute information like type, length, description, and so on, on this page.

### Create the Source CSV File

You include the data that you want to import into CX Sales and B2B Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to **Navigator > Tools > Import Management > Import Objects**.
2. Select the **Case Resource** object in the table and click **Download**.

You can now edit the downloaded file and provide valid values for the required attributes.

**Note:** For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.
Create the Import Activity

After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Case Resource from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results

Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed. You can drill down on the import activity to go to the Import Status page which provides the status details of the import activity.

Related Topics

• Potential Issues When Opening CSV Files in Excel
• How You Use Alternate Keys to Import Records
• Import Data

Import Your Category Data

You can use Import Management to create, update, or delete your category data.

You can import category records using these steps:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes

You import category data into Oracle Applications Cloud from a CSV file containing your source data that's mapped to target Oracle Applications Cloud object attributes.

You need to do the following before creating the .csv file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
• Ensure prerequisite steps are complete, such as understanding what attributes are required for importing your objects.
• Understand your options for uniquely identifying the records.
• Ensure parent records exist before importing child records.
• Identify the target object attributes that are required in the .csv file for a successful import.

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.
• You have all parent records in place before importing child records.

Review Required Attributes and Validations for Category Object
To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Make sure that you provide valid values for these attributes so that they pass import validations inbuilt into the application.

This table lists the required attributes for category records, prerequisite setup tasks and specific validations, if any:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Tasks or Import Validations</th>
<th>Creating a Category Record</th>
<th>Updating an Existing Category Record</th>
<th>Deleting an Existing Category Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>CategoryId</td>
<td>The unique identifier of the category, an auto generated number and primary key for this table.</td>
<td>Must be a valid CategoryId when updating a category.</td>
<td>Not Required</td>
<td>Conditionally Required. Provide value if CategoryCode isn't provided.</td>
<td>Conditionally Required. Provide value if CategoryId isn't provided.</td>
</tr>
<tr>
<td>CategoryCode</td>
<td>The public unique identifier of the category.</td>
<td>Must follow the following format: &lt;CategoryShortName&gt;-&lt;StripeCd&gt;-&lt;BUOrgId&gt;</td>
<td>Not Required</td>
<td>Conditionally Required. Provide value if CategoryId isn't provided.</td>
<td>Conditionally Required. Provide value if CategoryId isn't provided.</td>
</tr>
<tr>
<td>CategoryName</td>
<td>The name of the category. This field is displayed in the service request UI.</td>
<td>None</td>
<td>Required</td>
<td>Not Required</td>
<td>Not Required</td>
</tr>
<tr>
<td>CategoryShortName</td>
<td>A short code for the category.</td>
<td>Only integers, uppercase characters, and underscores are allowed. The combination of CategoryShortName, StripeCd, BUOrgId must be unique.</td>
<td>Required</td>
<td>Not Required</td>
<td>Not Required</td>
</tr>
<tr>
<td>StripeCd</td>
<td>The application stripe of the category.</td>
<td>Must be one of the following values: ORA_SVC_CRM, ORA_SVC_HCM, ORA_SVC_HRHD, ORA_SVC_ISR.</td>
<td>Conditionally Required. Provide value if you don't want the default value of ORA_SVC_CRM.</td>
<td>Not Required</td>
<td>Not Required</td>
</tr>
</tbody>
</table>
### Attribute Description

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Tasks or Import Validations</th>
<th>Creating a Category Record</th>
<th>Updating an Existing Category Record</th>
<th>Deleting an Existing Category Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>BUOrgId</td>
<td>The unique identifier of the business unit associated with the category.</td>
<td>Manage Business Units under Setup and Maintenance.</td>
<td>Required</td>
<td>Not Required</td>
<td>Not Required</td>
</tr>
<tr>
<td>ParentCategoryId</td>
<td>The unique identifier of the parent category.</td>
<td>Parent category must exist in the application.</td>
<td>Conditionally Required. Provide value if importing a child category and ParentCategoryCode isn't provided.</td>
<td>Not Required</td>
<td>Not Required</td>
</tr>
<tr>
<td>ParentCategoryCode</td>
<td>The public unique identifier of the parent category.</td>
<td>Parent category must exist in the application. You must follow the following format: &lt;ParentCategoryShortName&gt;-&lt;StripeCd&gt;-&lt;BUOrgId&gt;</td>
<td>Conditionally Required. Provide value if importing a child category and ParentCategoryCode isn't provided.</td>
<td>Not Required</td>
<td>Not Required</td>
</tr>
</tbody>
</table>

You can view the Category object along with all its child objects and attributes in the Manage Import Objects page of the Import Management flow. You can find attribute information like type, length, description, and so on, on this page.

**Note:**

1. If you’re importing child categories, you have to make sure that the parent category already exists in the application.
2. When importing child categories, you must provide the ParentCategoryCode field in the following format: `<ParentCategoryShortName>-<StripeCd>-<BUOrgId>`
3. If you want to import category name for non primary languages, you must change the session language before importing. You can change the session language by navigating to Settings and Actions > Set Preferences > Language and Changing the Value for the Current Session.

### Create the Source CSV File

You include the data that you want to import into CX Sales and B2B Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator > Tools > Import Management > Import Objects.
2. Select the Category object in the table and click Download.

**Note:** For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.
Create the Import Activity

After you have the CSV file ready, create an import activity to import the category information. To create an import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Category from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you’re ready.

Review the Import Results

Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.
   You can drill down on the import activity to go to the Import Status page which provides the status details of the import activity.

Related Topics
- Import Data
- How You Use Alternate Keys to Import Records
- Potential Issues When Opening CSV Files in Excel

Import Your Classification Data

You can use Import Management to create, update, or delete your classification data.

You can import classification records using these steps:

1. Map your source classification data to Oracle Applications Cloud object attributes. This way the import process would know where to insert each of the information bits.
2. Create the source CSV file with the classification data you want to import.
4. Check the import results to know if the import went well.

How You Map Your Source Data to Target Object Attributes

You import classification data into Oracle Applications Cloud from a CSV file containing your source data that’s mapped to target Oracle Applications Cloud object attributes.
You must do the following before creating the .csv file for data import:

- Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
- Ensure prerequisite steps are complete, such as understanding what attributes are required for importing your objects.
- Understand your options for uniquely identifying the records.
- Ensure parent records exist before importing child records.
- Identify the target object attributes that are required in the .csv file for a successful import.

If you want to import only a few records, then you can create a single CSV file for all classification attributes. However, if you want to import a large number of records, then you may decide to create multiple CSV files, one for each of the classification child objects. Note that you must have imported the CSV file for classification object successfully before trying to import the CSV files for the child objects. There are separate help topics describing how to import each of these child objects. For more information, see the related topics section.

Before You Start

You must do some basic checks before starting your import. For example, make sure that:

- You have completed all the prerequisites for importing each attribute in your source data.
- You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records

All records must be unique in the application. You can use one of these to identify records:

- Public unique identifiers: If you’re creating records, then you can provide an easily understandable public unique identifier. These are, usually, denoted with ‘Number’ and visible in the business object’s UI. PUID attributes are usually named <object> Number. If you’re updating a record with a Number attribute, then use the Number attribute to identify the record. For more information about public unique identifiers, see the topic “How You Use Alternate Keys to Import Records” in Related Topics section.
- Source system and source system reference: Source system is an identifier for the external system, and source system reference is a unique identifier within the external system. If you’re importing new classifications or are updating classifications that have source system reference data, then provide the source system and source system reference values.

Required Attributes and Validations for Classification Object

To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Make sure that you provide valid values for these attributes so that they pass import validations inbuilt into the application.

This table lists the required attributes for classification records, prerequisite setup tasks and specific validations, if any:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/Import Validations</th>
<th>Creating a Classification Record</th>
<th>Updating an Existing Classification Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>PartySourceSystem</td>
<td>The code representing the source system for the party(account, contact,</td>
<td>Identify the source system code that was used when you imported the party in</td>
<td>Conditionally required</td>
<td>Optional</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

236
<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/ Import Validations</th>
<th>Creating a Classification Record</th>
<th>Updating an Existing Classification Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>party_source_system_reference</td>
<td>The reference number or text representing the source system unique ID for the party (account, contact, household, or legal entity) to which the classification belongs.</td>
<td>Identify the reference value from your source system that was used when you imported the party in a prior batch, or identify the source system reference that you will use when importing the party in the same batch as this classification.</td>
<td>Conditionally Required Provide reference information to identify the existing party. The reference information can be:</td>
<td>Optional</td>
</tr>
<tr>
<td>primary_flag</td>
<td>Identifies primary classification for the parent party record.</td>
<td>Only one of the child records can be Primary.</td>
<td>Optional</td>
<td>Optional Pass Y to set Primary and N to reset an existing primary record.</td>
</tr>
<tr>
<td>code_assignment_id</td>
<td>The unique identifier for the customer classification assignment.</td>
<td>It should be a valid existing value.</td>
<td>Not required</td>
<td>Either the Code assignment Id or a combination of Source System and Source System Reference is required.</td>
</tr>
<tr>
<td>class_category</td>
<td>The classification category name</td>
<td>The class category must exist. You can manage class categories from the Manage Class Categories task.</td>
<td>Required</td>
<td>Not Required</td>
</tr>
<tr>
<td>Attribute</td>
<td>Description</td>
<td>Prerequisite Setup Task/ Import Validations</td>
<td>Creating a Classification Record</td>
<td>Updating an Existing Classification Record</td>
</tr>
<tr>
<td>--------------------</td>
<td>--------------------------------------------------------------------------------------------------------</td>
<td>------------------------------------------------------------------------------------------------------------</td>
<td>--------------------------------------------------------------------------------------------------</td>
<td>--------------------------------------------</td>
</tr>
<tr>
<td>ClassCode</td>
<td>The classification code, within the classification category, assigned to the party.</td>
<td>The value must be a valid code for the classification category. You can only assign one code if the</td>
<td>Conditionally required A value is required if creating a new classification association record.</td>
<td>Not Required</td>
</tr>
<tr>
<td></td>
<td></td>
<td>category definition isn't enabled for multiple code assignments to a party within the same category.</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>The code assignment must not already exist within the same time period. You can obtain classification codes</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>for a classification category.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>StartDateActive</td>
<td>The date on which the classification becomes valid.</td>
<td>This should be a valid date.</td>
<td>This defaults to the current date.</td>
<td>Not required</td>
</tr>
<tr>
<td>PartyId</td>
<td>The internal ID for the party (account, contact, household, or legal entity) to which the address</td>
<td>Identify the party ID value by exporting the relevant Party object such as Account, Contact, and so on.</td>
<td>Conditionally required Provide reference information to identify the existing party. The reference</td>
<td>Not required</td>
</tr>
<tr>
<td></td>
<td>belongs</td>
<td></td>
<td>information can be:</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• PartyId (internal ID)</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• PartySourceSystem and PartySourceSystemRef system code and source system reference values</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>provided when importing the organization profile.</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• Party Number (public unique identifier for an organization profile)</td>
<td></td>
</tr>
<tr>
<td>PartyNumber</td>
<td>The public unique identifier of the party record to which the classification category</td>
<td>The party number must exist.</td>
<td>Conditionally Required Provide reference information to identify the existing party. The reference</td>
<td>Not required</td>
</tr>
<tr>
<td></td>
<td>and classification code are associated.</td>
<td></td>
<td>information can be:</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• PartyId (internal ID)</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• PartySourceSystem and PartySourceSystemRef system code and source system reference values</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>provided when importing the organization profile.</td>
<td></td>
</tr>
</tbody>
</table>
### Attribute and Prerequisite Setup Task/Import Validations

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/Import Validations</th>
<th>Creating a Classification Record</th>
<th>Updating an Existing Classification Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>EndDateActive</td>
<td>The date on which the classification code is no longer valid.</td>
<td>This should be a valid date.</td>
<td>Optional</td>
<td>Not required</td>
</tr>
<tr>
<td>SourceSystem</td>
<td>Name of external source system of the account, contact or household with which the address is associated.</td>
<td>The source system should exist.</td>
<td>Optional</td>
<td>Not required</td>
</tr>
<tr>
<td>SourceSystemReferenceValue</td>
<td>Specifies the identifier in the original source system.</td>
<td>The combination of Source System and Source System Reference Value should be unique.</td>
<td>Optional</td>
<td>Not required</td>
</tr>
</tbody>
</table>

Go to **Navigator > Tools > Import Management > Import Objects**, to see all the attributes of the classification object. The page also lists attribute information like type, length, description, and so on.

### Create the Source CSV File

You include the data that you want to import into CX Sales and B2B Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to **Navigator > Tools > Import Management > Import Objects**.
2. Select the **Classification** object in the table and click **Download**.

You can now edit the downloaded file and provide valid values for the required attributes.

**Note:** For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.
Create the Import Activity

After you have the CSV file ready, create an import activity to import the classification information. To create an import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Classification from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results

Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed. You can drill down on the import activity to go to the Import Status page which provides the status details of the import activity.

Related Topics

- Potential Issues When Opening CSV Files in Excel
- How You Use Alternate Keys to Import Records
- Import Data

Import Your Classification Code Data

You can use Import Management to create or update Classification Code records.

To import Classification Code records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Object Attributes

To import your Classification Code data into Oracle Applications Cloud, you must populate a .csv file with your source data and map that source data to target object attributes in Oracle Applications Cloud.
You need to do the following before creating the CSV file for data import:

- Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
- Ensure prerequisite setups are done, if applicable.
- Understand your options for uniquely identifying the records.
- Ensure parent records exist before importing child records.
- Identify the target object attributes that are required in the CSV file for a successful import.

Before You Start
You must do some basic checks before starting your import. For example:

- Complete all the prerequisites for importing each attribute in your source data.
- Have all parent records in place before importing child records.

Required Attributes and Validations for the Classification Code Object
To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure that you provide valid values for the attributes. The following table lists the required attributes for importing new Classification Code records, prerequisite setup tasks for the attributes, and specific validations, if any, for Classification Code import:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/Import Validations</th>
<th>Creating a Classification Code Record</th>
<th>Updating an Existing Classification Code Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>ClassCategory</td>
<td>User-defined classification category</td>
<td>No validation</td>
<td>Required</td>
<td>You can't update the ClassCategory. However, it's required to identify the existing data.</td>
</tr>
<tr>
<td>ClassCode</td>
<td>User defined class codes for the user defined class category</td>
<td>No validation</td>
<td>Required</td>
<td>You can't update the ClassCode. However, it's required to identify the existing data.</td>
</tr>
<tr>
<td>Description</td>
<td>Brief description of the classification code</td>
<td>No validation</td>
<td>Required</td>
<td>Required</td>
</tr>
<tr>
<td>Meaning</td>
<td>The meaning of the classification code</td>
<td>No validation</td>
<td>Required</td>
<td>Required</td>
</tr>
<tr>
<td>ModifyHierarchy</td>
<td>Option to indicate if the parent and child hierarchies of the classification codes are to be modified</td>
<td>No validation</td>
<td>Optional</td>
<td>Not required</td>
</tr>
<tr>
<td>ParentClassCode</td>
<td>If there is a hierarchy set between the classification codes, then provide the parent classification</td>
<td>User-defined ClassCategory via the &quot;Manage Classification Categories&quot; UI.</td>
<td>Optional</td>
<td>Not required</td>
</tr>
</tbody>
</table>
Attribute | Description | Prerequisite Setup Task/Import Validations | Creating a Classification Code Record | Updating an Existing Classification Code Record
---|---|---|---|---
| | code to which the child classification code belongs. | | | |

You can view the Classification Code object and attributes in the Manage Import Objects page of the Import Management flow. You can find attribute information like type, length, description, and so on, on this page.

### Create the Source CSV File

You include the data that you want to import into CX Sales and B2B Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to **Navigator > Tools > Import Management > Import Objects**.
2. Select the **Classification Code** object in the table and click **Download**.

You can now edit the downloaded file and provide valid values for the required attributes.

**Note:** For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.

### Create the Import Activity

After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to **Navigator > Tools > Import Management > Import Queue**.
2. Click **Create Import Activity** in the **Manage Imports** page.
3. In the **Enter Import Options** page, provide a name for the import activity, and select Classification Code from the **Object** drop-down list.
4. Select the CSV file in the **File Name** field, and click **Next**.
5. The source and target attributes are automatically mapped in the **Map Fields** page. Review and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking **Validate Data**. Click **Next**.
7. Review the import details on the **Review and Submit** page, and click **Submit** when you’re ready.

### Review the Import Results

Check if your import succeeded on the **Manage Imports** page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to **Navigator > Tools > Import Management > Import Queue**.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the **Status** column for the import activity. The import is successful if the status displays as **Completed**. You can drill down on the import activity to go to the **Import Status** page which provides the status details of the import activity.
Import Your Competitor Data

You can use Import Management to create or update Competitor records.

To import Competitor records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Object Attributes

To import your Competitor data into Oracle Applications Cloud, you must populate a .csv file with your source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

- Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
- Ensure prerequisite setups are done, if applicable.
- Understand your options for uniquely identifying the records.
- Ensure parent records exist before importing child records.
- Identify the target object attributes that are required in the CSV file for a successful import.

Before You Start

You must do some basic checks before starting your import. For example:

- Complete all the prerequisites for importing each attribute in your source data.
- Have all parent records in place before importing child records.

Select a Unique Identifier for Your Records

To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the import process to uniquely identify the records. The file import process uses the attribute values to automatically map your source data to the target object attributes in Oracle Applications Cloud.

If you're identifying a record that already exists in Oracle Applications Cloud, then you can use the internal ID of the record, a system-generated unique identifier attributes with "ID" in the attribute name are typically internal IDs. You can determine the internal ID of a record by exporting Oracle Applications Cloud object data, or by doing a transactional database query. Using an internal ID typically provides better performance and reduces the import duration. For the Competitor object, the attributes are Party Id and Registry Id.
Required Attributes and Validations for the Competitor Object

To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure that you provide valid values for the attributes. The following table lists the required attributes for importing new Competitor records, prerequisite setup tasks for the attributes, and specific validations, if any, for Competitor import:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/Import Validations</th>
<th>Creating a Competitor Record</th>
<th>Updating an Existing Competitor Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>Organization Name</td>
<td>Competitor Name - The name that identifies the competitor object</td>
<td>Not Applicable</td>
<td>Required</td>
<td>Conditionally Required</td>
</tr>
<tr>
<td>Name</td>
<td>Competitor Name - The name that identifies the competitor object</td>
<td>Not Applicable</td>
<td>Conditionally Required</td>
<td>Conditionally Required</td>
</tr>
<tr>
<td>Party Type</td>
<td>Competitor Party Type - Type of party record</td>
<td>Not Applicable</td>
<td>Conditionally Required</td>
<td>Do not provide a value.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Party ID</td>
<td>PartyId - The unique ID for the existing competitor record.</td>
<td>A list of all party IDs is obtained by exporting the Competitor object.</td>
<td>Do not provide a value.</td>
<td>Required</td>
</tr>
<tr>
<td>Registry ID</td>
<td>Registry ID (PartyNumber) - The public unique identifier of the Competitor.</td>
<td>Not Applicable</td>
<td>Do not provide a value.</td>
<td>Conditionally Required</td>
</tr>
</tbody>
</table>

You can view the Competitor object and attributes in the Manage Import Objects page of the Import Management flow. You can find attribute information like type, length, description, and so on, on this page.

Create the Source CSV File

You include the data that you want to import into CX Sales and B2B Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator > Tools > Import Management > Import Objects.
2. Select the Competitor object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

**Note:** For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.
Create the Import Activity

After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to **Navigator > Tools > Import Management > Import Queue**.
2. Click **Create Import Activity** in the **Manage Imports** page.
3. In the **Enter Import Options** page, provide a name for the import activity, and select Competitor from the **Object** drop-down list.
4. Select the CSV file in the **File Name** field, and click **Next**.
5. The source and target attributes are automatically mapped in the **Map Fields** page. Review and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking **Validate Data**. Click **Next**.
7. Review the import details on the **Review and Submit** page, and click **Submit** when you're ready.

Review the Import Results

Check if your import succeeded on the **Manage Imports** page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to **Navigator > Tools > Import Management > Import Queue**.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the **Status** column for the import activity. The import is successful if the status displays as **Completed**. You can drill down on the import activity to go to the **Import Status** page which provides the status details of the import activity.

Related Topics

- Potential Issues When Opening CSV Files in Excel
- Import Data

Import Contact Data

Import Your Contact Data

You can use the Import Management to create, update, or delete contact records.

You can import contact records using these steps:

1. Map your source contact data to Oracle Applications Cloud object attributes. This way the import process would know where to insert each of the information bits.
2. Create the source CSV file with the contact data you want to import.
4. Check the import results to know if the import went well.

How You Map Your Source Data to Target Object Attributes

To import your contact data into Oracle Applications Cloud, you must populate a .csv file with your source data and map that source data to target object attributes in Oracle Applications Cloud.
You must do the following before creating the .csv file for data import:

- Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
- Ensure prerequisite steps are complete, such as understanding what attributes are required for importing your objects.
- Understand your options for uniquely identifying the records.
- Ensure parent records exist before importing child records.
- Identify the target object attributes that are required in the .csv file for a successful import.

To better manage your contact information, the contact object has the following child objects:

- Address
- Classification
- Relationship
- Sales Team Member

**Note:** You can't set an attribute value to NULL in optimized import (standard import with the option **Enable High-Volume Import** selected). However, when updating a record, you can change an attribute value from NOT NULL to NULL.

If you want to import only a few records, then you can create a single CSV file for all contact attributes. However if you want to import a large number of records, then you may decide to create multiple CSV files, one for each of the contact child objects. Note that you must have imported the CSV file for contact object successfully before trying to import the CSV files for the child objects. There are separate help topics describing how to import each of these child objects. For more information, see the related topics section.

**Before You Start**

You must do some basic checks before starting your import. For example, make sure that:

- You have completed all the prerequisites for importing each attribute in your source data.
- You have all parent records in place before importing child records.

**Select a Unique Identifier for Your Records**

All records must be unique in the application. You can use one of these to identify records:

- Public unique identifiers: If you're creating records, then you can provide an easily understandable public unique identifier. These are, usually, denoted with 'Number' and visible in the business object's UI. PUID attributes are usually named `<object> Number`. If you're updating a record with a Number attribute, then use the Number attribute to identify the record. For more information about public unique identifiers, see the topic "How You Use Alternate Keys to Import Records" in Related Topics section.

- Source system and source system reference: Source system is an identifier for the external system, and source system reference is a unique identifier within the external system. If you're importing new contacts or are updating contacts that have source system reference data, then provide the source system and source system reference values.
### Required Attributes and Validations for the Contact Object

To import data successfully into Oracle Applications Cloud, your `.csv` file must include the required attributes. Ensure that you provide valid values for the attributes.

This table lists the required attributes for contact records, prerequisite setup tasks and specific validations, if any:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task or Import Validations</th>
<th>Creating a Contact Record</th>
<th>Updating an Existing Contact Record</th>
<th>Deleting an Existing Contact Record</th>
</tr>
</thead>
</table>
| **SourceSystem**     | The code representing the source system for the contact.                    | Identify the source system or configure source systems either by using the Manage Trading Community Source System task, or by importing the source system information into Oracle Applications Cloud using the Source System Reference import object. | Conditionally Required For uniquely identifying a contact record, provide one of the following reference information:  
  - SourceSystem and SourceSystemReferenceValue  
  - PartyNumber | Conditionally Required For uniquely identifying a contact record, provide one of the following reference information:  
  - SourceSystem and SourceSystemReferenceValue  
  - PartyNumber | Conditionally Required For uniquely identifying a contact record, provide one of the following reference information:  
  - SourceSystem and SourceSystemReferenceValue  
  - PartyNumber |
| **SourceSystemReferenceValue** | The reference number or text representing the source system unique ID for the contact. | Identify the source system or configure source systems either by using the Manage Trading Community Source System task, or by importing the source system information into Oracle Applications Cloud using the Source System Reference import object. | Conditionally Required For uniquely identifying a contact record, provide one of the following reference information:  
  - SourceSystem and SourceSystemReferenceValue  
  - PartyNumber | Conditionally Required For uniquely identifying a contact record, provide one of the following reference information:  
  - SourceSystem and SourceSystemReferenceValue  
  - PartyNumber | Conditionally Required For uniquely identifying a contact record, provide one of the following reference information:  
  - SourceSystem and SourceSystemReferenceValue  
  - PartyNumber |
| **PartyNumber**      | The public unique identifier of the contact.                                | No prerequisite tasks                          | Conditionally Required     | Conditionally Required              | Conditionally Required              |
| **FirstName**        | First name of a person party.                                              | No prerequisite tasks                          | Required                   | Not required                        | Not required                        |
| **LastName**         | Last name of a person party.                                               | No prerequisite tasks                          | Required                   | Not required                        | Not required                        |

**Note:** For the **Time Zone** import attribute, specify the time zone of the contact to know the preferred time to call or send e-mail to the contact.
You can use the profile option ORA_HZ_IMPORT_MULTI_ADDRESS_TYPE to control how address types are entered. By default this profile option is set to Yes, so you can enter multiple address types, during high-volume import of Account, Contact, and Household objects. You can disable this profile option to improve the import performance. When you set this profile option to No, you can enter only a single address type.

Go to Navigator > Tools > Import Management > Import Objects, to see all the attributes of the contact object. The page also lists attribute information like type, length, description, and so on.

Create the Source CSV File
You include the data that you want to import into CX Sales and B2B Service in a source CSV file. You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator > Tools > Import Management > Import Objects.
2. Select the Contact object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Providing the ZIP and Country Code values in the import CSV file won’t automatically populate the State/County/City fields. Values for these fields should be separately provided in the import file.

Note: For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the contact information. To create an import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Contact from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed. You can drill down on the import activity to go to the Import Status page which provides the status details of the import activity.

Note: After importing your data successfully, you need to run a couple of post processing jobs for duplicate identification, duplicate resolution, and account assignment. For more information on import management post processing jobs, see the topic: Import Management Post Processing for Accounts and Contacts.
Example of Adding or Updating Primary Account

You can add or update the primary account of a contact using import management. Before adding or updating the primary account, ensure that the account exists.

Select a Unique Identifier for Your Records

All records must be unique in the application. You can add or update a primary account by submitting any one or more of the unique identifiers.

List of Contact Identifiers:

- PartyId
- PartyNumber
- SourceSystem and SourceSystemReferenceValue

List of Account Identifiers:

- PrimaryAccountPartyId
- PrimaryAccountPartyNumber
- PrimaryAccountSourceSystem and PrimaryAccountSourceSystemReferenceValue

To add or update the primary account of a contact, you must create a source file (CSV) and import it using import management. Below table lists the attributes using Party ID and Account Party ID as identifier:

<table>
<thead>
<tr>
<th>Attribute Name</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>PartyId</td>
<td>300100545540596</td>
</tr>
<tr>
<td>PrimaryAccountPartyId</td>
<td>300100545540269</td>
</tr>
</tbody>
</table>

Create the Import Activity

After you have the CSV file ready, create an import activity to import the account information. To create an import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Contact from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review and edit the mappings if required.

6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.

7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results

Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed. You can drill down on the import activity to go to the Import Status page which provides the status details of the import activity.

Related Topics
- Import Data
- How You Use Alternate Keys to Import Records
- Potential Issues When Opening CSV Files in Excel
- How You Enable Automatic Account Assignment

Example of Changing or Assigning Owner of a Contact

You can change or assign the owner of a contact using import management. Before changing or assigning the owner, ensure that the contact exists and the owner is an active or valid resource.

Select a Unique Identifier for Your Records

All records must be unique in the application. You can change or assign a primary account by submitting any one or more of the unique identifiers.

List of Contact Identifiers:
- PartyId
- PartyNumber
- SourceSystem and SourceSystemReferenceValue

List of Owner Identifiers:
- OwnerPartyId
- OwnerPartyNumber
- OwnerSourceSystem and OwnerSourceSystemReferenceValue

To change owner of a contact, you must create a source file (CSV) and import it using import management. Below table lists the attributes using Party ID and Owner Party ID as identifier:
Create the Import Activity

After you have the CSV file ready, create an import activity to import the account information. To create an import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Contact from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results

Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed. You can drill down on the import activity to go to the Import Status page which provides the status details of the import activity.

Related Topics

- Import Data
- How You Use Alternate Keys to Import Records
- Potential Issues When Opening CSV Files in Excel
- How You Enable Automatic Account Assignment

Import Your Contact Member Data

You can use the Import Management to create, update, or delete contact member records.

You can import contact member records using these steps:

1. Map your source contact member data to Oracle Applications Cloud object attributes. This way the import process would know where to insert each of the information bits.
2. Create the source CSV file with the contact member data you want to import.
4. Check the import results to know if the import went well.

How You Map Your Source Data to Target Object Attributes

To import your contact member data into Oracle Applications Cloud, you must populate a .csv file with your source data and map that source data to target object attributes in Oracle Applications Cloud.

You must do the following before creating the .csv file for data import:

- Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
- Ensure prerequisite steps are complete, such as understanding what attributes are required for importing your objects.
- Understand your options for uniquely identifying the records.
- Ensure parent records exist before importing child records.
- Identify the target object attributes that are required in the .csv file for a successful import.

Before You Start

You must do some basic checks before starting your import. For example, make sure that:

- You have completed all the prerequisites for importing each attribute in your source data.
- You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records

All records must be unique in the application. You can use one of these to identify records:

- Public unique identifiers: If you’re creating records, then you can provide an easily understandable public unique identifier. These are, usually, denoted with ‘Number’ and visible in the business object's UI. PUID attributes are usually named <object> Number. If you’re updating a record with a Number attribute, then use the Number attribute to identify the record. For more information about public unique identifiers, see the topic "How You Use Alternate Keys to Import Records" in Related Topics section.
- Source system and source system reference: Source system is an identifier for the external system, and source system reference is a unique identifier within the external system. If you’re importing new contact members or are updating contact members that have source system reference data, then provide the source system and source system reference values.

Required Attributes and Validations for Contact Member Object

To import data successfully into Oracle Applications Cloud, your .csv file must include the required attributes. Ensure that you provide valid values for the attributes.

This table lists the required attributes for contact member records, prerequisite setup tasks and specific validations, if any:
## Attribute | Description | Prerequisite Setup Task/Import Validations | Creating a Contact Member record | Updating an Existing Contact Member record
--- | --- | --- | --- | ---
MemberId | The unique ID for the existing member record in the Oracle Fusion destination table. | The unique Id for the existing account Id record in the Oracle Fusion destination table. | Not required | Conditionally required

- A value is required if you're updating an existing Member ID and you're not providing the Service Request ID and Party ID.

PartyId | The unique ID for the existing party record in the Oracle Fusion destination table. | Do not provide a value if creating a new party in the same import batch as this additional party name. If you provide the value for an existing party, the value must exist in the HZ_PARTIES table, column PARTY_ID. You can obtain the PARTY_ID for an existing party by exporting the Party object. To export, navigate to Tools > Export Management > Create Export Activity. | Not required | Not required

Relationship Type Code | Indicates relationship with the contact, such as ALTERNATE, FOLLOWER, or THIRD_PARTY. | If providing a value, the value must exist in the FND_LOOKUP table with LOOKUP_TYPE='ORA_SVC_CONTACT_REL_TYPE_CD'. | Required | Required

Service Request ID | Indicates the service request Id to which the contact member belongs. | No validation | Not required | Conditionally required

- A value is required if you're updating an existing contact and you're not providing the Service Request ID.

SRNumber | The unique number used to identify a service request. You can configure the service request number to a format that's best suitable to your organizational requirements. | No validation | Conditionally required

- A value is required if you're updating an existing record and you're not providing the Service Request ID.

- A value is required if you're updating an existing record and you're not providing the Service Request ID.

---

Go to Navigator > Tools > Import Management > Import Objects, to see all the attributes of the contact member object. The page also lists attribute information like type, length, description, and so on.

### Create the Source CSV File

You include the data that you want to import into CX Sales and B2B Service in a source CSV file.
Chapter 8
Import Your Data

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator > Tools > Import Management > Import Objects.
2. Select the Contact Member object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

**Note:** For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity

After you have the CSV file ready, create an import activity to import the contact member information. To create an import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Contact Member from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you’re ready.

Review the Import Results

Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed. You can drill down on the import activity to go to the Import Status page which provides the status details of the import activity.

**Related Topics**
- Potential Issues When Opening CSV Files in Excel
- How You Use Alternate Keys to Import Records
- Import Data

Import Your Contact Point Data

You can use Import Management to create update, or delete Contact Point records.

To import Contact Point records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
How You Map Your Source Data to Target Object Attributes

To import your Contact Point data into Oracle Applications Cloud, you need to populate a CSV file with your source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

- Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
- Ensure prerequisite setups are done, if applicable.
- Understand your options for uniquely identifying the records.
- Ensure parent records exist before importing child records.
- Identify the target object attributes that are required in the CSV file for a successful import.
- Ensure that you don't insert duplicate addresses while importing, to avoid redundant data.

Before You Start

You must do some basic checks before starting your import. For example, make sure that:

- You have completed all the prerequisites for importing each attribute in your source data.
- You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records

All records must be unique in the application. You can use one of these to identify records:

- Public unique identifiers: If you're creating records, then you can provide an easily understandable public unique identifier. These are, usually, denoted with 'Number' and visible in the business object’s UI. PUID attributes are usually named <object> Number. If you're updating a record with a Number attribute, then use the Number attribute to identify the record. For more information about public unique identifiers, see the topic "How You Use Alternate Keys to Import Records" in Related Topics section.
- Source system and source system reference: Source system is an identifier for the external system, and source system reference is a unique identifier within the external system. If you're importing new contacts or are updating contacts that have source system reference data, then provide the source system and source system reference values.

Required Attributes and Validations for Contact Point Object

To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure that you provide valid values for the attributes. This table lists the required attributes for importing new Contact Point records, required attributes for updating Contact Point records, prerequisite setup tasks for the attributes, and specific validations, if any, for Contact Point import:
<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/Import Validations</th>
<th>Creating a Contact Point Record</th>
<th>Updating an Existing Contact Point Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>ContactPointType</td>
<td>Type of the contact point that's imported or updated</td>
<td>This has to be a lookup_code in HZ_LOOKUPS with a lookup_type as COMMUNICATION_TYPE</td>
<td>Provide one of these values: • EMAIL, if the email address is to be imported. • INSTANT_MESSAGING, if the instant messenger address is to be imported. • WEB, if the URL is to be imported. • PHONE, if the phone number is to be imported.</td>
<td>Not required</td>
</tr>
<tr>
<td>PartyId</td>
<td>The internal ID for the party to which the contact point belongs</td>
<td>No validation</td>
<td>Provide one of the following : • PartyId • Party Number • A combination of Party Source System and Party Source System Reference Value</td>
<td>Not required</td>
</tr>
<tr>
<td>PartyNumber</td>
<td>Specifies the PUID of the party</td>
<td>No validation</td>
<td>Provide one of the following : • PartyId • Party Number • A combination of Party Source System and Party Source System Reference Value</td>
<td>Not required</td>
</tr>
<tr>
<td>PartySourceSystem</td>
<td>Specifies the original source system of the party</td>
<td>This has to be in HZ_ORIG_SYSTEMS_B with the status &quot;A&quot;.</td>
<td>Provide one of the following : • PartyId • Party Number • A combination of Party Source System and Party Source System Reference Value</td>
<td>Not required</td>
</tr>
<tr>
<td>PartySourceSystemReference</td>
<td>Specifies the party's source system reference in the original source system</td>
<td>No validation</td>
<td>Provide one of the following : • PartyId • Party Number • A combination of Party Source System and Party Source System Reference Value</td>
<td>Not required</td>
</tr>
</tbody>
</table>
### Import Your Data

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/Import Validations</th>
<th>Creating a Contact Point Record</th>
<th>Updating an Existing Contact Point Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>SourceSystem</td>
<td>Specifies the original source system name</td>
<td>This has to be in HZ_ORIG_SYSTEMS_B with the status “A”.</td>
<td>Provide a valid value.</td>
<td>Not required</td>
</tr>
<tr>
<td>SourceSystemReferenceValue</td>
<td>Specifies the identifier in the original source system</td>
<td>No validation</td>
<td>Provide a valid value.</td>
<td>Not required</td>
</tr>
<tr>
<td>ContactPointId</td>
<td>System generated unique identifier. This is the primary key.</td>
<td>No validation</td>
<td>Not required</td>
<td>If you can export the existing contact point, provide this primary key to identify the record for further updates.</td>
</tr>
<tr>
<td>Status</td>
<td>The status of the contact point.</td>
<td>Not required</td>
<td>Not required</td>
<td>To inactivate the existing active contact point record, provide the value “N”.</td>
</tr>
<tr>
<td>DoContactPreferenceFlag</td>
<td>Add or update a contact’s preference to receive e-mail or phone calls on the contact, account or household contact points. This attribute identifies if a contact has made a choice to be contacted.</td>
<td>Don’t set both this attribute and DoNotContactPreferenceFlag to Y simultaneously. Set either this attribute or DoNotContactPreferenceFlag to “Y”. These are non-mandatory values. However, you can set both this attribute and DoNotContactPreferenceFlag to “N”.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>DoNotContactPreferenceFlag</td>
<td>Add or update a contact’s preference not to receive e-mail or phone calls on the contact, account or household contact points. This attribute identifies if a contact has made no choice to be contacted.</td>
<td>Don’t set both this attribute and DoContactPreferenceFlag to Y simultaneously. Set either this attribute or DoContactPreferenceFlag to “Y”. These are non-mandatory values. However, you can set both this attribute and DoContactPreferenceFlag to “N”.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
</tbody>
</table>
### Attribute

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/Import Validations</th>
<th>Creating a Contact Point Record</th>
<th>Updating an Existing Contact Point Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>DoNotContactReason</td>
<td>Add or update the reason for a contact not to receive e-mail or phone calls on the contact, account or household contact points.</td>
<td>This is used for DoNotContactPreferenceFlag. It is a non-mandatory field.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
</tbody>
</table>

You can view the Contact Point object along with all its child objects and attributes in the Manage Import Objects page of the Import Management flow. You can find attribute information like type, length, description, and so on, on this page.

### Create the Source CSV File

You include the data that you want to import into CX Sales and B2B Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to **Navigator > Tools > Import Management > Import Objects**.
2. Select the **Contact Point** object in the table and click **Download**.

You can now edit the downloaded file and provide valid values for the required attributes.

**Note:** For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.

### Create the Import Activity

After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to **Navigator > Tools > Import Management > Import Queue**.
2. Click **Create Import Activity** in the **Manage Imports** page.
3. In the **Enter Import Options** page, provide a name for the import activity, and select Contact Point from the **Object** drop-down list.
4. Select the CSV file in the **File Name** field, and click **Next**.
5. You would see that the source and target attributes are automatically mapped in the **Map Fields** page. Review and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking **Validate Data**. Click **Next**.
7. Review the import details on the **Review and Submit** page, and click **Submit** when you're ready.

### Review the Import Results

Check if your import succeeded on the **Manage Imports** page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to **Navigator > Tools > Import Management > Import Queue**.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the **Status** column for the import activity. The import is successful if the status displays as **Completed**. You can drill down on the import activity to go to the **Import Status** page which provides the status details of the import activity.
Import Your Contest Data

You can use Import Management to create update, or delete Contest records.

To import Contest records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes

To import your Contest data into Oracle Applications Cloud, you need to populate a CSV file with your source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

- Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
- Ensure prerequisite setups are done, if applicable.
- Understand your options for uniquely identifying the records.
- Ensure parent records exist before importing child records.
- Identify the target object attributes that are required in the CSV file for a successful import.

Before You Start

You must do some basic checks before starting your import. For example, make sure that:

- You have completed all the prerequisites for importing each attribute in your source data.
- You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records

All records must be unique in the application. You can use one of these to identify records:

- Public unique identifiers: If you're creating records, then you can provide an easily understandable public unique identifier. These are, usually, denoted with 'Number' and visible in the business object's UI. PUID attributes are usually named <object> Number. If you're updating a record with a Number attribute, then use the Number attribute to identify the record. For more information about public unique identifiers, see the topic "How You Use Alternate Keys to Import Records" in Related Topics section.
• Source system and source system reference: Source system is an identifier for the external system, and source system reference is a unique identifier within the external system. If you’re importing new contests or are updating contests that have source system reference data, then provide the source system and source system reference values.

Required Attributes and Validations for Contest Object

To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure that you provide valid values for the attributes. This table lists the required attributes for importing new Contest records, required attributes for updating Contest records, prerequisite setup tasks for the attributes, and specific validations, if any, for Contest import:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/Import Validations</th>
<th>Creating a Contest Record</th>
<th>Updating an Existing Contest Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>ContestId</td>
<td>The unique identifier of the contest</td>
<td>No validation</td>
<td>Not required</td>
<td>Conditionally required</td>
</tr>
<tr>
<td></td>
<td>This is auto generated.</td>
<td></td>
<td></td>
<td>Either the ContestId or the ContestNumber is required.</td>
</tr>
<tr>
<td>ContestName</td>
<td>The name of the contest</td>
<td>No validation</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td>OwnerId</td>
<td>The unique identifier of a valid employee resource who owns and manages the contest</td>
<td>The resource should exist.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td></td>
<td>This is auto defaulted to creator.</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>StartDate</td>
<td>The start date of the contest</td>
<td>Current date and time or a future date</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td>EndDate</td>
<td>The end date of the contest</td>
<td>This must be later than the start date.</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td>KPIId</td>
<td>The unique identifier of the KPI selected for the contest</td>
<td>The KPI record should exist.</td>
<td>Either the KPIId or the KPINumber is required</td>
<td>Not required</td>
</tr>
<tr>
<td>OwnerNumber</td>
<td>The unique alternate identifier of the resource who owns and manages the contest</td>
<td>The resource should exist.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td></td>
<td>This is auto defaulted to creator.</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>KPINumber</td>
<td>The unique alternate identifier of the KPI selected for the contest</td>
<td>The KPI record should exist.</td>
<td>Either the KPIId or the KPINumber is required</td>
<td>Not required</td>
</tr>
<tr>
<td>ContestNumber</td>
<td>The unique alternate identifier for the contest</td>
<td>No validation</td>
<td>Not required</td>
<td>Conditionally required</td>
</tr>
<tr>
<td></td>
<td>This is auto generated.</td>
<td></td>
<td></td>
<td>Either the ContestId or the ContestNumber is required.</td>
</tr>
</tbody>
</table>
You can view the Contest object along with all its child objects and attributes in the Manage Import Objects page of the Import Management flow. You can find attribute information like type, length, description, and so on, on this page.

Create the Source CSV File
You include the data that you want to import into CX Sales and B2B Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator > Tools > Import Management > Import Objects.
2. Select the Contest object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

**Note:** For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Contest from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed. You can drill down on the import activity to go to the Import Status page which provides the status details of the import activity.

Related Topics
- Potential Issues When Opening CSV Files in Excel
- How You Use Alternate Keys to Import Records
- Import Data
Import Your Contest Resources Data

You can use Import Management to create, update, or delete Contest Resources records.

To import Contest Resources records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes

To import your Contest Resources data into Oracle Applications Cloud, you need to populate a CSV file with your source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

- Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
- Ensure prerequisite setups are done, if applicable.
- Understand your options for uniquely identifying the records.
- Ensure parent records exist before importing child records.
- Identify the target object attributes that are required in the CSV file for a successful import.

Before You Start

You must do some basic checks before starting your import. For example, make sure that:

- You have completed all the prerequisites for importing each attribute in your source data.
- You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records

All records must be unique in the application. You can use one of these to identify records:

- Public unique identifiers: If you're creating records, then you can provide an easily understandable public unique identifier. These are, usually, denoted with 'Number' and visible in the business object's UI. PUID attributes are usually named <object> Number. If you're updating a record with a Number attribute, then use the Number attribute to identify the record. For more information about public unique identifiers, see the topic "How You Use Alternate Keys to Import Records" in Related Topics section.
- Source system and source system reference: Source system is an identifier for the external system, and source system reference is a unique identifier within the external system. If you're importing new contest resources or are updating contest resources that have source system reference data, then provide the source system and source system reference values.
Required Attributes and Validations for Contest Resources Object

To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure that you provide valid values for the attributes. This table lists the required attributes for importing new Contest Resources records, required attributes for updating Contest Resources records, prerequisite setup tasks for the attributes, and specific validations, if any, for Contest Resources import:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/Import Validations</th>
<th>Creating a Contest Resources Record</th>
<th>Updating an Existing Contest Resources Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>ContestResourceId</td>
<td>The unique identifier of the contest resource</td>
<td>No validation</td>
<td>Not required</td>
<td>Conditionally required</td>
</tr>
<tr>
<td>ResourceId</td>
<td>The unique identifier of the resource associated with the contest</td>
<td>The resource should exist.</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td>ResourceNumber</td>
<td>The unique alternate identifier of the resource associated with the contest</td>
<td>The resource should exist.</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td>ContestId</td>
<td>The unique identifier of the contest</td>
<td>The contest should exist.</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td>ContestNumber</td>
<td>The unique alternate identifier for the contest</td>
<td>The contest should exist.</td>
<td>Required</td>
<td>Not required</td>
</tr>
</tbody>
</table>

You can view the Contest Resources object along with all its child objects and attributes in the Manage Import Objects page of the Import Management flow. You can find attribute information like type, length, description, and so on, on this page.

Create the Source CSV File

You include the data that you want to import into CX Sales and B2B Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to **Navigator > Tools > Import Management > Import Objects**.
2. Select the **Contest Resources** object in the table and click **Download**.

You can now edit the downloaded file and provide valid values for the required attributes.

**Note:** For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.

### Create the Import Activity

After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to **Navigator > Tools > Import Management > Import Queue**.
2. Click **Create Import Activity** in the Manage Imports page.
3. In the **Enter Import Options** page, provide a name for the import activity, and select Contest Resources from the Object drop-down list.
4. Select the CSV file in the File Name field, and click **Next**.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking **Validate Data**. Click **Next**.
7. Review the import details on the **Review and Submit** page, and click **Submit** when you're ready.

### Review the Import Results

Check if your import succeeded on the **Manage Imports** page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to **Navigator > Tools > Import Management > Import Queue**.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the **Status** column for the import activity. The import is successful if the status displays as **Completed**. You can drill down on the import activity to go to the **Import Status** page which provides the status details of the import activity.

**Related Topics**

- Potential Issues When Opening CSV Files in Excel
- How You Use Alternate Keys to Import Records
- Import Data

### Import Your Contract Bill Line Data

You can use Import Management to create or update Contract Bill Line records.

To import Contract Bill Line records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.
How You Map Your Source Data to Object Attributes

To import your Contract Bill Line data into Oracle Applications Cloud, you must populate a .csv file with your source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

- Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
- Ensure prerequisite setups are done, if applicable.
- Understand your options for uniquely identifying the records.
- Ensure parent records exist before importing child records.
- Identify the target object attributes that are required in the CSV file for a successful import.

Before You Start

You must do some basic checks before starting your import. For example:

- Complete all the prerequisites for importing each attribute in your source data.
- Have all parent records in place before importing child records.

Select a Unique Identifier for Your Records

To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the import process to uniquely identify the records. The file import process uses the attribute values to automatically map your source data to the target object attributes in Oracle Applications Cloud.

The preferred option to uniquely identify an object record is through the public unique identifier. If you're creating new records, then you can provide a user-friendly public unique identifier (attributes denoted with ‘Number’ and usually visible in the business object's UI). If you update a record for which you have previously provided a Number attribute, or for which a Number attribute is visible in the object's UI, you can use the Number attribute to identify the record. For the Contract Bill Line object, the attributes are LinePUID and SequenceNumber.

Required Attributes and Validations for the Contract Bill Line Object

To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure that you provide valid values for the attributes. The following table lists the required attributes for importing new Contract Bill Line records, prerequisite setup tasks for the attributes, and specific validations, if any, for Contract Bill Line import:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/ Import Validations</th>
<th>Creating a Contract Bill Line Record</th>
<th>Updating an Existing Contract Bill Line Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>LinePUID</td>
<td>The unique PUID that identifies the contract line</td>
<td>This must be a valid PUID.</td>
<td>A value is required if the covered asset external source and external key aren't specified.</td>
<td>Not required</td>
</tr>
<tr>
<td>SequenceNumber</td>
<td>The sequence number of the contract bill line</td>
<td>No validation</td>
<td>Required</td>
<td>Not required</td>
</tr>
</tbody>
</table>
**Import Your Data**

You can view the Contract Bill Line object and attributes in the Manage Import Objects page of the Import Management flow. You can find attribute information like type, length, description, and so on, on this page.

## Create the Source CSV File

You include the data that you want to import into CX Sales and B2B Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to **Navigator > Tools > Import Management > Import Objects.**

### Attribute | Description | Prerequisite Setup Task/Import Validations | Creating a Contract Bill Line Record | Updating an Existing Contract Bill Line Record
---|---|---|---|---
ChargeDefinitionCode | The charge definition code | This must be a valid charge definition code defined in the contract pricing. | A value is required if the charge definition isn’t passed. | Not required |
ChargePeriod | The charge period | No validation | Required | Not required |
ChargeDefinition | The charge definition | This must be a valid charge definition defined in the contract pricing. | A value is required if the charge definition code isn’t passed. | Not required |
ExtSource | The external source of the bill line | This must be a unique external source across all bill lines. | Required | Required |
ExtKey | The external key of the bill line | This must be a unique external key across all bill lines. | Required | Required |
CoveredAssetExtSource | The external source of the covered asset | This must be a valid covered asset external source. | A value is required if the line PUID isn’t passed. | Not required |
CoveredAssetExtKey | The external key of the covered asset | This must be a valid covered asset external key. | A value is required if the line PUID isn’t passed. | Not required |
DateToInterface | The date to interface | No validation | Required | Not required |
DateBilledFrom | The date from which the contract bill line becomes effective. | No validation | Required | Not required |
DateBilledTo | The date till which the contract bill line is effective | No validation | Required | Not required |
RecurringFlag | The option indicating if this line is recurring | The valid values are Yes or No. | Required | Not required |
2. Select the **Contract Bill Line** object in the table and click **Download**.

You can now edit the downloaded file and provide valid values for the required attributes.

---

**Note:** For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.

---

### Create the Import Activity

After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to **Navigator > Tools > Import Management > Import Queue.**
2. Click **Create Import Activity** in the **Manage Imports** page.
3. In the **Enter Import Options** page, provide a name for the import activity, and select Contract Bill Line from the **Object** drop-down list.
4. Select the CSV file in the **File Name** field, and click **Next.**
5. The source and target attributes are automatically mapped in the **Map Fields** page. Review and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking **Validate Data.** Click **Next.**
7. Review the import details on the **Review and Submit** page, and click **Submit** when you're ready.

---

### Review the Import Results

Check if your import succeeded on the **Manage Imports** page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to **Navigator > Tools > Import Management > Import Queue.**
2. Click All Imports and search for the import activity that you created earlier.
3. Check the **Status** column for the import activity. The import is successful if the status displays as **Completed.**

You can drill down on the import activity to go to the **Import Status** page which provides the status details of the import activity.

---

**Related Topics**

- Potential Issues When Opening CSV Files in Excel
- Import Data

---

### Import Your Contract Charge Data

You can use Import Management to create or update Contract Charge records.

To import Contract Charge records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.
How You Map Your Source Data to Object Attributes

To import your Contract Charge data into Oracle Applications Cloud, you must populate a .csv file with your source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

- Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
- Ensure prerequisite setups are done, if applicable.
- Understand your options for uniquely identifying the records.
- Ensure parent records exist before importing child records.
- Identify the target object attributes that are required in the CSV file for a successful import.

Before You Start

You must do some basic checks before starting your import. For example:

- Complete all the prerequisites for importing each attribute in your source data.
- Have all parent records in place before importing child records.

Select a Unique Identifier for Your Records

To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the import process to uniquely identify the records. The file import process uses the attribute values to automatically map your source data to the target object attributes in Oracle Applications Cloud.

The preferred option to uniquely identify an object record is through the public unique identifier. If you're creating new records, then you can provide a user-friendly public unique identifier (attributes denoted with 'Number' and usually visible in the business object's UI). If you update a record for which you have previously provided a Number attribute, or for which a Number attribute is visible in the object's UI, you can use the Number attribute to identify the record. For the Contract Charge object, the attribute is LinePUID.

Required Attributes and Validations for the Contract Charge Object

To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure that you provide valid values for the attributes. The following table lists the required attributes for importing new Contract Charge records, prerequisite setup tasks for the attributes, and specific validations, if any, for Contract Charge import:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/Import Validations</th>
<th>Creating a Contract Charge Record</th>
<th>Updating an Existing Contract Charge Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>LinePUID</td>
<td>The PUID of the contract line</td>
<td>This must be a valid line PUID.</td>
<td>A value is required if the charge is associated with a contract line.</td>
<td>Required</td>
</tr>
<tr>
<td>CoveredAssetExtSource</td>
<td>The external source of the covered asset</td>
<td>This must be a valid covered asset external source.</td>
<td>A value is required if the charge is associated with a covered asset.</td>
<td>Required</td>
</tr>
</tbody>
</table>
### Attribute Description Prerequisite Setup Task/Import Validations Creating a Contract Charge Record Updating an Existing Contract Charge Record

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/Import Validations</th>
<th>Creating a Contract Charge Record</th>
<th>Updating an Existing Contract Charge Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>CoveredAssetExtKey</td>
<td>The external key of the covered asset</td>
<td>This must be a valid covered asset external key.</td>
<td>A value is required if the charge is associated with a covered asset.</td>
<td>Required</td>
</tr>
<tr>
<td>ChargeDefinitionCode</td>
<td>The charge definition code</td>
<td>This must be a valid charge definition code defined in contract pricing.</td>
<td>A value is required if the charge definition name isn't passed.</td>
<td>Not required</td>
</tr>
<tr>
<td>ChargeDefinition</td>
<td>The charge definition name</td>
<td>This must be a valid charge definition name defined in contract pricing.</td>
<td>A value is required if the charge definition code isn't passed.</td>
<td>Not required</td>
</tr>
<tr>
<td>PricePeriodicityCode</td>
<td>The price periodicity code</td>
<td>This must be a valid price periodicity code.</td>
<td>A value is required if the price periodicity name isn't passed.</td>
<td>Not required</td>
</tr>
<tr>
<td>PricePeriodicity</td>
<td>The price periodicity name</td>
<td>This must be a valid price periodicity name.</td>
<td>A value is required if the price periodicity code isn't passed.</td>
<td>Not required</td>
</tr>
<tr>
<td>ExtSource</td>
<td>The external source of the charge</td>
<td>This must be a unique value across the Charge table.</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td>ExtKey</td>
<td>The external key of the charge</td>
<td>This must be a unique value across the Charge table.</td>
<td>Required</td>
<td>Not required</td>
</tr>
</tbody>
</table>

You can view the Contract Charge object and attributes in the Manage Import Objects page of the Import Management flow. You can find attribute information like type, length, description, and so on, on this page.

### Create the Source CSV File

You include the data that you want to import into CX Sales and B2B Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to **Navigator > Tools > Import Management > Import Objects**.
2. Select the **Contract Charge** object in the table and click **Download**.

You can now edit the downloaded file and provide valid values for the required attributes.

**Note:** For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.
Create the Import Activity

After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Contract Charge from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. The source and target attributes are automatically mapped in the Map Fields page. Review and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results

Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed. You can drill down on the import activity to go to the Import Status page which provides the status details of the import activity.

Related Topics

- Potential Issues When Opening CSV Files in Excel
- Import Data

Import Your Contract Charge Component Data

You can use Import Management to create or update Contract Charge Component records.

To import Contract Charge Component records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Object Attributes

To import your Contract Charge Component data into Oracle Applications Cloud, you must populate a .csv file with your source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

- Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
- Ensure prerequisite setups are done, if applicable.
• Understand your options for uniquely identifying the records.
• Ensure parent records exist before importing child records.
• Identify the target object attributes that are required in the CSV file for a successful import.

Before You Start
You must do some basic checks before starting your import. For example:

• Complete all the prerequisites for importing each attribute in your source data.
• Have all parent records in place before importing child records.

Required Attributes and Validations for the Contract Charge Component Object
To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure that you provide valid values for the attributes. The following table lists the required attributes for importing new Contract Charge Component records, prerequisite setup tasks for the attributes, and specific validations, if any, for Contract Charge Component import:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/Import Validations</th>
<th>Creating a Contract Charge Component Record</th>
<th>Updating an Existing Contract Charge Component Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>ExtSource</td>
<td>The external source of the charge component</td>
<td>This must be a unique value across the Charge Components table.</td>
<td>Required</td>
<td>Required</td>
</tr>
<tr>
<td>ExtKey</td>
<td>The external key of the charge component</td>
<td>This must be a unique value across the Charge Components table.</td>
<td>Required</td>
<td>Required</td>
</tr>
<tr>
<td>ContractChargeExtSource</td>
<td>The external source of the charge</td>
<td>This must be a valid charge external source.</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td>ContractChargeExtKey</td>
<td>The external key of the charge</td>
<td>This must be a valid charge external key.</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td>HeaderCurrencyUnitPrice</td>
<td>The unit price of the charge</td>
<td>No validation</td>
<td>Required</td>
<td>Not required</td>
</tr>
</tbody>
</table>

You can view the Contract Charge Component object and attributes in the Manage Import Objects page of the Import Management flow. You can find attribute information like type, length, description, and so on, on this page.

Create the Source CSV File
You include the data that you want to import into CX Sales and B2B Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to **Navigator > Tools > Import Management > Import Objects.**
Select the **Contract Charge Component** object in the table and click **Download**.

You can now edit the downloaded file and provide valid values for the required attributes.

**Note:** For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.

### Create the Import Activity

After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to **Navigator > Tools > Import Management > Import Queue**.
2. Click **Create Import Activity** in the **Manage Imports** page.
3. In the **Enter Import Options** page, provide a name for the import activity, and select **Contract Charge Component** from the **Object** drop-down list.
4. Select the CSV file in the **File Name** field, and click **Next**.
5. The source and target attributes are automatically mapped in the **Map Fields** page. Review and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking **Validate Data**. Click **Next**.
7. Review the import details on the **Review and Submit** page, and click **Submit** when you're ready.

### Review the Import Results

Check if your import succeeded on the **Manage Imports** page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to **Navigator > Tools > Import Management > Import Queue**.
2. Click **All Imports** and search for the import activity that you created earlier.
3. Check the **Status** column for the import activity. The import is successful if the status displays as **Completed**. You can drill down on the import activity to go to the **Import Status** page which provides the status details of the import activity.

**Related Topics**
- Potential Issues When Opening CSV Files in Excel
- Import Data

### Import Your Contract Covered Assets Data

You can use Import Management to create or update Contract Covered Assets records.

To import Contract Covered Assets records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.
How You Map Your Source Data to Object Attributes

To import your Contract Covered Assets data into Oracle Applications Cloud, you must populate a .csv file with your source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

- Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
- Ensure prerequisite setups are done, if applicable.
- Understand your options for uniquely identifying the records.
- Ensure parent records exist before importing child records.
- Identify the target object attributes that are required in the CSV file for a successful import.

Before You Start

You must do some basic checks before starting your import. For example:

- Complete all the prerequisites for importing each attribute in your source data.
- Have all parent records in place before importing child records.

Select a Unique Identifier for Your Records

To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the import process to uniquely identify the records. The file import process uses the attribute values to automatically map your source data to the target object attributes in Oracle Applications Cloud.

The preferred options to uniquely identify an object record are as follows:

- Internal ID: If you're identifying a record that already exists in Oracle Applications Cloud, then you can use the internal ID of the record, a system-generated unique identifier Attributes with "id" in the attribute name are typically internal IDs. You can determine the internal ID of a record by exporting Oracle Applications Cloud object data, or by doing a transactional database query. Using an internal ID typically provides better performance and reduces the import duration. For the Contract Covered Assets object, this attribute is AssetId.
- Public unique identifiers: If you're creating new records, then you can provide a user-friendly public unique identifier (attributes denoted with 'Number' and usually visible in the business object's UI). If you update a record for which you have previously provided a Number attribute, or for which a Number attribute is visible in the object's UI, you can use the Number attribute to identify the record. For the Contract Covered Assets object, the attributes are LinePUID and LineNumber.

Required Attributes and Validations for the Contract Covered Assets Object

To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure that you provide valid values for the attributes. The following table lists the required attributes for importing new Contract Covered Assets records, prerequisite setup tasks for the attributes, and specific validations, if any, for Contract Covered Assets import:
<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/Import Validations</th>
<th>Creating a Contract Covered Assets Record</th>
<th>Updating an Existing Contract Covered Assets Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>LinePuid</td>
<td>The PUID of the contract line</td>
<td>This must be a valid line PUID.</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td>EndDate</td>
<td>The end date of the covered asset</td>
<td>No validation</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>ExtKey</td>
<td>The external key of the covered asset</td>
<td>This must be a unique external key across all covered assets.</td>
<td>Required</td>
<td>Required</td>
</tr>
<tr>
<td>ExtSource</td>
<td>The external source of the covered asset</td>
<td>This must be a unique external source across all covered assets.</td>
<td>Required</td>
<td>Required</td>
</tr>
<tr>
<td>LineNumber</td>
<td>The line number of the covered asset</td>
<td>No validation</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td>PriceUom</td>
<td>The price unit of measure</td>
<td>This must be a valid price UOM.</td>
<td>A value is required if the priceUomCode isn't passed.</td>
<td>Not required</td>
</tr>
<tr>
<td>PriceUomCode</td>
<td>The price unit of measure code</td>
<td>This must be a valid price UOM code.</td>
<td>A value is required if the priceUom isn't passed.</td>
<td>Not required</td>
</tr>
<tr>
<td>Quantity</td>
<td>The contract covered assets quantity</td>
<td>No validation</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td>StartDate</td>
<td>The date on which the contract covered asset begins</td>
<td>No validation</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td>Status</td>
<td>The status of the contract covered asset</td>
<td>This must be a valid status.</td>
<td>A value is required if the status code isn't passed.</td>
<td>Not required</td>
</tr>
<tr>
<td>StatusCode</td>
<td>The status code of the contract covered asset</td>
<td>This must be a valid status code.</td>
<td>A value is required if the status isn't passed.</td>
<td>Not required</td>
</tr>
<tr>
<td>AssetId</td>
<td>The unique identifier of the asset</td>
<td>This must be a valid asset ID.</td>
<td>A value is required if the asset name isn't passed.</td>
<td>Not required</td>
</tr>
<tr>
<td>AssetName</td>
<td>The name of the asset</td>
<td>This must be a valid asset name.</td>
<td>A value is required if the asset ID isn't passed.</td>
<td>Not required</td>
</tr>
</tbody>
</table>

You can view the Contract Covered Assets object and attributes in the Manage Import Objects page of the Import Management flow. You can find attribute information like type, length, description, and so on, on this page.
Create the Source CSV File

You include the data that you want to import into CX Sales and B2B Service in a source CSV file. You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator > Tools > Import Management > Import Objects.
2. Select the Contract Covered Assets object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

**Note:** For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity

After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Contract Covered Assets from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. The source and target attributes are automatically mapped in the Map Fields page. Review and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results

Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed. You can drill down on the import activity to go to the Import Status page which provides the status details of the import activity.

**Related Topics**
- Potential Issues When Opening CSV Files in Excel
- Import Data

Import Your Contract Header Data

You can use Import Management to create or update Contract Header records.
To import Contract Header records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Object Attributes

To import your Contract Header data into Oracle Applications Cloud, you must populate a .csv file with your source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

- Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
- Ensure prerequisite setups are done, if applicable.
- Understand your options for uniquely identifying the records.
- Ensure parent records exist before importing child records.
- Identify the target object attributes that are required in the CSV file for a successful import.

Before You Start

You must do some basic checks before starting your import. For example:

- Complete all the prerequisites for importing each attribute in your source data.
- Have all parent records in place before importing child records.

Select a Unique Identifier for Your Records

To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the import process to uniquely identify the records. The file import process uses the attribute values to automatically map your source data to the target object attributes in Oracle Applications Cloud.

If you're identifying a record that already exists in Oracle Applications Cloud, then you can use the internal ID of the record, a system-generated unique identifier attributes with "ID" in the attribute name are typically internal IDs. You can determine the internal ID of a record by exporting Oracle Applications Cloud object data, or by doing a transactional database query. Using an internal ID typically provides better performance and reduces the import duration. For the Contract Header object, the attributes are Contract Id and Id.

Required Attributes and Validations for the Contract Header Object

To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure that you provide valid values for the attributes. The following table lists the required attributes for importing new Contract Header records, prerequisite setup tasks for the attributes, and specific validations, if any, for Contract Header import:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/Import Validations</th>
<th>Creating a Contract Header Record</th>
<th>Updating an Existing Contract Header Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>ContractNumber</td>
<td>The number that identifies the Contract Header.</td>
<td>No validation</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td>Attribute</td>
<td>Description</td>
<td>Prerequisite Setup Task/Import Validations</td>
<td>Creating a Contract Header Record</td>
<td>Updating an Existing Contract Header Record</td>
</tr>
<tr>
<td>-----------------</td>
<td>------------------------------------------------------------------------------</td>
<td>----------------------------------------------------------------------------------------------------------</td>
<td>----------------------------------</td>
<td>---------------------------------------------</td>
</tr>
<tr>
<td>ContractPuid</td>
<td>The unique PUID that identifies the Contract Header.</td>
<td>This number identifier must be unique across Contract Headers of all types.</td>
<td>Required</td>
<td>Required</td>
</tr>
<tr>
<td>ContractTypId</td>
<td>The unique ID of the Contract Header type.</td>
<td>You can determine and manage Contract Header types. You can determine and manage Contract Header types.</td>
<td>Required if Contract HeaderTyp isn't entered.</td>
<td>Not required</td>
</tr>
<tr>
<td>ContractTypeName</td>
<td>The name of the Contract Header type. The Contract Header type sets various properties for the Contract Header such as the type of permitted Contract Header lines, party roles, Contract Header validation checks, and the Contract Header acceptance and signature requirements.</td>
<td>You can determine and manage Contract Header types. You can determine and manage Contract Header types.</td>
<td>Required if Contract HeaderTyp isn't entered.</td>
<td>Not required</td>
</tr>
<tr>
<td>Currency</td>
<td>The name of the currency in which Contract Header amounts are entered.</td>
<td>This must be a valid currency.</td>
<td>Required if CurrencyCode isn't entered</td>
<td>Not required</td>
</tr>
<tr>
<td>CurrencyCode</td>
<td>The code of the currency in which Contract Header amounts are entered.</td>
<td>This must be a valid currency.</td>
<td>Required if Currency isn't entered</td>
<td>Not required</td>
</tr>
<tr>
<td>InvOrganizationId</td>
<td>The unique Id representing the item master organization</td>
<td>This must be a valid ORGANIZATION_ID from the HR_ALL_ORGANIZATION_UNITS_F table.</td>
<td>Required if the InvOrgName isn't entered</td>
<td>Not required</td>
</tr>
<tr>
<td>InvOrgName</td>
<td>The name representing the item master organization.</td>
<td>This must be a valid ORGANIZATION_ID from the HR_ALL_ORGANIZATION_UNITS_F table.</td>
<td>Required if the InvOrganizationId isn't entered</td>
<td>Not required</td>
</tr>
</tbody>
</table>
## Attribute | Description | Prerequisite Setup Task/ Import Validations | Creating a Contract Header Record | Updating an Existing Contract Header Record
--- | --- | --- | --- | ---
LegalEntityId | The unique Id of the legal entity to which the Contract Header belongs. | This must be a valid record as per GL_LEDGER_LE_V. | Required if the LegalEntityName isn't entered. | Not required
LegalEntityName | The name of the legal entity to which the Contract Header belongs. | This must be a valid record as per GL_LEDGER_LE_V. | Required if the LegalEntityId isn't entered. | Not required
OrgId | The unique Id of the business unit to which the Contract Header belongs. | This must be a valid business unit Id. | Required if the OrgName isn't entered | Not required
OrgName | The name of the business unit to which the Contract Header belongs. | This must be a valid business unit name. | Required if the OrgId isn't entered. | Not required
StartDate | The date on which the Contract Header comes into effect. | No validation | Required | Not required
StsCode | The code of the Contract Header status. Examples are ACTIVE, DRAFT, CLOSED, and CANCELED. | Navigate to the following in Setup and Maintenance:  - Offering: Sales  - Functional Area: Sales  - Task: Manage Standard Lookups  Search for the Contract Statuses lookup.  Activating a draft contract, and one-time import of closed, canceled, and active contracts is supported. You can't update the contract status from active to any other status. Also, you can't update a contract once it is active.  You can't import contracts in EXPIRED status directly in the system. You must import the contracts with ACTIVE status and then update contract status to EXPIRED. | Required | Not required

The attribute **GeneratedInvoiceStatus** must have one of the following values.

- D for Draft
- S for Submitted for approval
Create the Source CSV File

You include the data that you want to import into CX Sales and B2B Service in a source CSV file. You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator > Tools > Import Management > Import Objects.
2. Select the Contract Header object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

**Note:** For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.

When you import contracts using the contract type column with the contract numbering method set as Automatic, you can leave the ContractNumber column blank in the CSV file for the application to generate the contract numbers automatically. You can also enter the contract number manually when you don't want the application to assign the contract numbering automatically.

When the contract type has the contract numbering method set as Manual, you can't leave the contract number blank. If the contract number is left blank, then the application generates an error.

To activate a contract while importing, provide the value 'ACTIVE' for the StsCode attribute. This will also activate the lines added to the contract.

To import contracts that are closed, canceled, or on hold, you must first import the contract with all required import files, and then re-import the contract import file with the following information:

- Closed contracts: You must include Status (the status will be Closed), Close reason code, CloseReasonSetCode, Termination Date.
- On-Hold Contracts: You must include Status (the status will be Hold), Hold Reason Code, Hold reason Set Code, Hold Until Date.
- Canceled contracts: You must include Status (the status will be Canceled), Cancel Reason, Cancel reason set code, Cancel date.

Create the Import Activity

After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Contract Header from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. The source and target attributes are automatically mapped in the Map Fields page. Review and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

### Review the Import Results

Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed. You can drill down on the import activity to go to the Import Status page which provides the status details of the import activity.

### Related Topics
- Potential Issues When Opening CSV Files in Excel
- Import Data

### Import Your Contract Header Descriptive Flexfield Data

You can use Import Management to create or update Contract Header Descriptive Flexfield records.

To import Contract Header Descriptive Flexfield records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

### How You Map Your Source Data to Object Attributes

To import your Contract Header Descriptive Flexfield data into Oracle Applications Cloud, you must populate a .csv file with your source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

- Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
- Ensure prerequisite setups are done, if applicable.
- Understand your options for uniquely identifying the records.
- Ensure parent records exist before importing child records.
- Identify the target object attributes that are required in the CSV file for a successful import.

### Before You Start

You must do some basic checks before starting your import. For example:

- Complete all the prerequisites for importing each attribute in your source data.
- Have all parent records in place before importing child records.
Select a Unique Identifier for Your Records

To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the import process to uniquely identify the records. The file import process uses the attribute values to automatically map your source data to the target object attributes in Oracle Applications Cloud.

The preferred options to uniquely identify an object record are as follows:

- **Internal ID**: If you're identifying a record that already exists in Oracle Applications Cloud, then you can use the internal ID of the record, a system-generated unique identifier attributes with "ID" in the attribute name are typically internal IDs. You can determine the internal ID of a record by exporting Oracle Applications Cloud object data, or by doing a transactional database query. Using an internal ID typically provides better performance and reduces the import duration. For the Contract Header Descriptive Flexfield object, the attribute is Contract Id.

- **Public unique identifiers**: If you’re creating new records, then you can provide a user-friendly public unique identifier (attributes denoted with ‘Number’ and usually visible in the business object’s UI). If you update a record for which you have previously provided a Number attribute, or for which a Number attribute is visible in the object’s UI, you can use the Number attribute to identify the record. For the Contract Header Descriptive Flexfield object, the attribute is Contract PUID.

Required Attributes and Validations for the Contract Header Descriptive Flexfield Object

To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure that you provide valid values for the attributes. The following table lists the required attributes for importing new Contract Header Descriptive Flexfield records, prerequisite setup tasks for the attributes, and specific validations, if any, for Contract Header Descriptive Flexfield import:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/ Import Validations</th>
<th>Creating a Contract Header Descriptive Flexfield Record</th>
<th>Updating an Existing Contract Header Descriptive Flexfield Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>ContractId</td>
<td>The Id of the contract.</td>
<td>This must be a valid contract Id.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>ContractPuid</td>
<td>The unique PUID that identifies the contract.</td>
<td>This must be a valid contract PUID.</td>
<td>Required</td>
<td>Required</td>
</tr>
<tr>
<td>AttributeCategory</td>
<td>Attribute category of the descriptive flexfield</td>
<td>No validation</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>Attribute1</td>
<td>Attribute 1 of the descriptive flexfield</td>
<td>No validation</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td>Attribute2</td>
<td>Attribute 2 of the descriptive flexfield</td>
<td>No validation</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>Attribute3</td>
<td>Attribute 3 of the descriptive flexfield</td>
<td>No validation</td>
<td>Not required</td>
<td>Not required</td>
</tr>
</tbody>
</table>
Create the Source CSV File

You include the data that you want to import into CX Sales and B2B Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator > Tools > Import Management > Import Objects.
2. Select the Contract Header Descriptive Flexfield object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note: For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity

After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Contract Header Descriptive Flexfield from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. The source and target attributes are automatically mapped in the Map Fields page. Review and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you’re ready.

Review the Import Results

Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the **Status** column for the import activity. The import is successful if the status displays as **Completed**. You can drill down on the import activity to go to the **Import Status** page which provides the status details of the import activity.

**Related Topics**
- Potential Issues When Opening CSV Files in Excel
- Import Data

### Import Your Contract Header Translation Data

You can use the import functionality to create, update, or delete your contract header translation data.

You can import contract header translation records using these steps:

1. Map your source data to Oracle Applications Cloud object attributes. This way the import process would know where to insert each of the information bits.
2. Create the source CSV file with the contract header translation data you want to import.
4. Check the import results to know if the import went well.

### How You Map Your Source Data to Target Object Attributes

You import contract header translation data into Oracle Applications Cloud from a CSV file containing your source data that’s mapped to target Oracle Applications Cloud object attributes.

Before you create the source data file, you should:

- Know how your source data attributes map to the target object attributes in Oracle Applications Cloud. Match each column from the source file to an attribute in the contract header translation import object.
- Finish all prerequisite steps, such as understanding what attributes are required for importing your objects.
- Know how you can uniquely identify the records.
- Check the target object attributes required in the CSV file for a successful import.

If you want to import only a few records, then you can create a single CSV file for all contract header translation attributes. However if you want to import a large number of records, then you may decide to create multiple CSV files, one for each of the contract header translation child objects. Note that you must have imported the CSV file for contract header translation object successfully before trying to import the CSV files for the child objects. There are separate help topics describing how to import each of these child objects. For more information, see the related topics section.

### Before You Start

You must do some basic checks before starting your import. For example, make sure that:

- You have completed all the prerequisites for importing each attribute in your source data.
- You have all parent records in place before importing child records.
Select a Unique Identifier for Your Records

All records must be unique in the application. You can use one of these to identify records:

- Public unique identifiers: If you're creating records, then you can provide an easily understandable public unique identifier. These are, usually, denoted with 'Number' and visible in the business object's UI. PUID attributes are usually named <object> Number. If you're updating a record with a Number attribute, then use the Number attribute to identify the record. For more information about public unique identifiers, see the topic "How You Use Alternate Keys to Import Records" in Related Topics section.

- Source system and source system reference: Source system is an identifier for the external system, and source system reference is a unique identifier within the external system. If you're importing new contract header translation or are updating contract header translation that have source system reference data, then provide the source system and source system reference values.

Required Attributes and Validations for Contract Header Translation Object

To import data successfully into Oracle Applications Cloud, your .csv file must include the required attributes. Make sure that you provide valid values for these attributes so that they pass import validations inbuilt into the application.

This table lists the required attributes for contract header translation records, prerequisite setup tasks and specific validations, if any:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/ Import Validations</th>
<th>Creating a Contract Header Translation record</th>
<th>Updating an Existing Contract Header Translation record</th>
</tr>
</thead>
<tbody>
<tr>
<td>ContractPuid</td>
<td>The PUID of the contract for which the translation information is captured.</td>
<td>Must be a valid contract PUID.</td>
<td>Required</td>
<td>Required</td>
</tr>
<tr>
<td>Lang</td>
<td>The language of the translation.</td>
<td>Must be a valid language.</td>
<td>Required</td>
<td>Required</td>
</tr>
</tbody>
</table>

Go to Navigator > Tools > Import Management > Import Objects, to see all the attributes of the contract header translation object. The page also lists attribute information like type, length, description, and so on.

Create the Source CSV File

You include the data that you want to import into CX Sales and B2B Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator > Tools > Import Management > Import Objects.
2. Select the Contract Header Translation object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note: For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.
Create the Import Activity

After you have the CSV file ready, create an import activity to import the contract header translation information. To create an import activity:

1. Go to **Navigator** > **Tools** > **Import Management** > **Import Queue**.
2. On the **Manage Imports** page, click **Create Import Activity**.
3. In the **Create Import Activity: Enter Import Options** page, provide a name for the import activity, and select **Contract Header Translation** from the **Object** drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review and edit the mappings if required.
   - **Note**: Click **Validate Data** to validate the mapping of the source file for unmapped columns and to check for data format issues.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you’re ready.

Review the Import Results

Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to **Navigator** > **Tools** > **Import Management** > **Import Queue**.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed. You can drill down on the import activity to go to the Import Status page which provides the status details of the import activity.

**Related Topics**
- How You Use Alternate Keys to Import Records
- Potential Issues When Opening CSV Files in Excel

Import Your Contract Line Data

You can use Import Management to create or update Contract Line records.

To import Contract Line records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Object Attributes

To import your Contract Line data into Oracle Applications Cloud, you must populate a .csv file with your source data and map that source data to target object attributes in Oracle Applications Cloud.
You need to do the following before creating the CSV file for data import:

- Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
- Ensure prerequisite setups are done, if applicable.
- Understand your options for uniquely identifying the records.
- Ensure parent records exist before importing child records.
- Identify the target object attributes that are required in the CSV file for a successful import.

Before You Start
You must do some basic checks before starting your import. For example:

- Complete all the prerequisites for importing each attribute in your source data.
- Have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the import process to uniquely identify the records. The file import process uses the attribute values to automatically map your source data to the target object attributes in Oracle Applications Cloud.

The preferred options to uniquely identify an object record are as follows:

- **Internal ID**: If you’re identifying a record that already exists in Oracle Applications Cloud, then you can use the internal ID of the record, a system-generated unique identifier attributes with “ID” in the attribute name are typically internal IDs. You can determine the internal ID of a record by exporting Oracle Applications Cloud object data, or by doing a transactional database query. Using an internal ID typically provides better performance and reduces the import duration. For the Contract Line object, the attributes are Line Id and Id.

- **Public unique identifiers**: If you’re creating new records, then you can provide a user-friendly public unique identifier (attributes denoted with ‘Number’ and usually visible in the business object’s UI). If you update a record for which you have previously provided a Number attribute, or for which a Number attribute is visible in the object’s UI, you can use the Number attribute to identify the record. For the Contract Line object, the attribute is Line PUID.

Required Attributes and Validations for the Contract Line Object
To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure that you provide valid values for the attributes. The following table lists the required attributes for importing new Contract Line records, prerequisite setup tasks for the attributes, and specific validations, if any, for Contract Line import:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/Import Validations</th>
<th>Creating a Contract Line Record</th>
<th>Updating an Existing Contract Line Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>ContractPuid</td>
<td>The unique PUID that identifies the contract</td>
<td>No validation</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td>ItemName</td>
<td>The item name for an item type of line</td>
<td>This must be a valid inventory item.</td>
<td>Required for an item type of line</td>
<td>Not required</td>
</tr>
<tr>
<td>Attribute</td>
<td>Description</td>
<td>Prerequisite Setup Task/Import Validations</td>
<td>Creating a Contract Line Record</td>
<td>Updating an Existing Contract Line Record</td>
</tr>
<tr>
<td>--------------------</td>
<td>-------------------------------------------------</td>
<td>-------------------------------------------</td>
<td>---------------------------------</td>
<td>------------------------------------------</td>
</tr>
<tr>
<td>ItemNameTxt</td>
<td>The item name for a free form type of line</td>
<td>No validation</td>
<td>Required for a free form type of line</td>
<td>Not required</td>
</tr>
<tr>
<td>ItemQuantity</td>
<td>The line quantity.</td>
<td>No validation</td>
<td>Required for an item type of line</td>
<td>Not required</td>
</tr>
<tr>
<td>LineAmount</td>
<td>The line amount.</td>
<td>No validation</td>
<td>Required for a free form type of line</td>
<td>Not required</td>
</tr>
<tr>
<td>LineNumber</td>
<td>The number of the contract line.</td>
<td>This must be a unique number within a contract.</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td>LinePuid</td>
<td>The unique PUID that identifies the contract line.</td>
<td>This must be a unique PUID across all contract line records.</td>
<td>Required</td>
<td>Required</td>
</tr>
<tr>
<td>LineStatus</td>
<td>The line status</td>
<td>This must be one of Active, Draft, Closed, or Canceled.</td>
<td>Required if StsCode isn't entered</td>
<td>Not required</td>
</tr>
<tr>
<td>LineTypeId</td>
<td>The Id that represents the line type.</td>
<td>This must be valid as per OKC_CONTRACT_TYPE_LINES.</td>
<td>Required if LineTypeName isn't entered</td>
<td>Not required</td>
</tr>
<tr>
<td>LineTypeName</td>
<td>The name of the line type.</td>
<td>This must be valid as per OKC_CONTRACT_TYPE_LINES.</td>
<td>Required if LineTypeId isn't entered</td>
<td>Not required</td>
</tr>
<tr>
<td>StartDate</td>
<td>The date from which the contract line becomes effective.</td>
<td>No validation</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td>StsCode</td>
<td>The code that represents the line status</td>
<td>This must be one of ACTIVE, DRAFT, CLOSED, or CANCELED</td>
<td>Required if LineStatus isn't entered</td>
<td>Not required</td>
</tr>
<tr>
<td>UnitOfMeasure</td>
<td>The unit of measure of the contract line.</td>
<td>This must be a valid unit of measure in INV_UNITS_OF_MEASURE_TLUNIT_OF_MEASURE.</td>
<td>Required if the UOMCode isn't entered</td>
<td>Not required</td>
</tr>
<tr>
<td>UnitPrice</td>
<td>The unit price of the line.</td>
<td>No validation</td>
<td>Required for an item type of line</td>
<td>Not required</td>
</tr>
<tr>
<td>UOMCode</td>
<td>The UOM code of the contract line.</td>
<td>This must be a valid unit of measure in INV_UNITS_OF_MEASURE_BUOM_CODE.</td>
<td>Required if the UnitOfMeasure isn't entered</td>
<td>Not required</td>
</tr>
</tbody>
</table>
You can view the Contract Line object and attributes in the Manage Import Objects page of the Import Management flow. You can find attribute information like type, length, description, and so on, on this page.

Create the Source CSV File
You include the data that you want to import into CX Sales and B2B Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator > Tools > Import Management > Import Objects.
2. Select the Contract Line object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

| Note: For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section. |

Create the Import Activity
After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Contract Line from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. The source and target attributes are automatically mapped in the Map Fields page. Review and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed. You can drill down on the import activity to go to the Import Status page which provides the status details of the import activity.

Related Topics
• Potential Issues When Opening CSV Files in Excel
• Import Data
Import Your Contract Line Descriptive Flexfield Data

You can use Import Management to create or update Contract Line Descriptive Flexfield records.

To import Contract Line Descriptive Flexfield records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Object Attributes

To import your Contract Line Descriptive Flexfield data into Oracle Applications Cloud, you must populate a .csv file with your source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

- Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
- Ensure prerequisite setups are done, if applicable.
- Understand your options for uniquely identifying the records.
- Ensure parent records exist before importing child records.
- Identify the target object attributes that are required in the CSV file for a successful import.

Before You Start

You must do some basic checks before starting your import. For example:

- Complete all the prerequisites for importing each attribute in your source data.
- Have all parent records in place before importing child records.

Select a Unique Identifier for Your Records

To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the import process to uniquely identify the records. The file import process uses the attribute values to automatically map your source data to the target object attributes in Oracle Applications Cloud.

The preferred options to uniquely identify an object record are as follows:

- **Internal ID**: If you're identifying a record that already exists in Oracle Applications Cloud, then you can use the internal ID of the record, a system-generated unique identifier attributes with "ID" in the attribute name are typically internal IDs. You can determine the internal ID of a record by exporting Oracle Applications Cloud object data, or by doing a transactional database query. Using an internal ID typically provides better performance and reduces the import duration. For the Contract Line Descriptive Flexfield object, the attribute is Line Id.

- **Public unique identifiers**: If you're creating new records, then you can provide a user-friendly public unique identifier (attributes denoted with 'Number' and usually visible in the business object's UI). If you update a record for which you have previously provided a Number attribute, or for which a Number attribute is visible.
in the object’s UI, you can use the Number attribute to identify the record. For the Contract Line Descriptive Flexfield object, the attribute is Line PUID.

Required Attributes and Validations for the Contract Line Descriptive Flexfield Object

To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure that you provide valid values for the attributes. The following table lists the required attributes for importing new Contract Line Descriptive Flexfield records, prerequisite setup tasks for the attributes, and specific validations, if any, for Contract Line Descriptive Flexfield import:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/Import Validations</th>
<th>Creating a Contract Line Descriptive Flexfield Record</th>
<th>Updating an Existing Contract Line Descriptive Flexfield Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>LineId</td>
<td>The Id of the contract line.</td>
<td>This must be a valid contract line Id.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>LinePuid</td>
<td>The unique PUID that identifies the contract line.</td>
<td>This must be a valid contract line PUID.</td>
<td>Required</td>
<td>Required</td>
</tr>
<tr>
<td>AttributeCategory</td>
<td>Attribute category of the descriptive flexfield</td>
<td>No validation</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>Attribute1</td>
<td>Attribute 1 of the descriptive flexfield</td>
<td>No validation</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td>Attribute2</td>
<td>Attribute 2 of the descriptive flexfield</td>
<td>No validation</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>Attribute3</td>
<td>Attribute 3 of the descriptive flexfield</td>
<td>No validation</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>Attribute4</td>
<td>Attribute 4 of the descriptive flexfield</td>
<td>No validation</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>Attribute5</td>
<td>Attribute 5 of the descriptive flexfield</td>
<td>No validation</td>
<td>Not required</td>
<td>Not required</td>
</tr>
</tbody>
</table>

You can view the Contract Line Descriptive Flexfield object and attributes in the Manage Import Objects page of the Import Management flow. You can find attribute information like type, length, description, and so on, on this page.

Create the Source CSV File

You include the data that you want to import into CX Sales and B2B Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator > Tools > Import Management > Import Objects.
2. Select the **Contract Line Descriptive Flexfield** object in the table and click **Download**.

You can now edit the downloaded file and provide valid values for the required attributes.

**Note:** For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.

### Create the Import Activity

After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to **Navigator > Tools > Import Management > Import Queue**.
2. Click **Create Import Activity** in the **Manage Imports** page.
3. In the **Enter Import Options** page, provide a name for the import activity, and select Contract Line Descriptive Flexfield from the **Object** drop-down list.
4. Select the CSV file in the **File Name** field, and click **Next**.
5. The source and target attributes are automatically mapped in the **Map Fields** page. Review and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking **Validate Data**. Click **Next**.
7. Review the import details on the **Review and Submit** page, and click **Submit** when you're ready.

### Review the Import Results

Check if your import succeeded on the **Manage Imports** page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to **Navigator > Tools > Import Management > Import Queue**.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the **Status** column for the import activity. The import is successful if the status displays as **Completed**. You can drill down on the import activity to go to the **Import Status** page which provides the status details of the import activity.

**Related Topics**

- Potential Issues When Opening CSV Files in Excel
- Import Data

### Import Your Contract Line Internal Attribute Data

You can use Import Management to create or update contract line internal attribute records.

To import contract line internal attribute records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.
How You Map Your Source Data to Object Attributes

To import your contract line internal attribute data into Oracle Applications Cloud, you must populate a CSV file with your source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

- Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
- Ensure prerequisite setups are done, if applicable.
- Understand your options for uniquely identifying the records.
- Ensure parent records exist before importing child records.
- Identify the target object attributes that are required in the CSV file for a successful import.

Before You Start

You must do some basic checks before starting your import. For example:

- Complete all the prerequisites for importing each attribute in your source data.
- Have all parent records in place before importing child records.

Select a Unique Identifier for Your Records

To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the import process to uniquely identify the records. The file import process uses the attribute values to automatically map your source data to the target object attributes in Oracle Applications Cloud.

The preferred option to uniquely identify an object record is through the public unique identifier. If you’re creating new records, then you can provide a user-friendly public unique identifier (attributes denoted with ‘Number’ and usually visible in the business object’s UI). If you update a record for which you have previously provided a Number attribute, or for which a Number attribute is visible in the object’s UI, you can use the Number attribute to identify the record. For the contract line internal attribute object, the attribute is LinePuid.

Required Attributes and Validations for the Contract Line Internal Attribute Object

To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure that you provide valid values for the attributes. The following table lists the required attributes for importing new contract line internal attribute records, prerequisite setup tasks for the attributes, and specific validations, if any, for contract line internal attribute import:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/ Import Validations</th>
<th>Creating a Contract Line Internal Attribute Record</th>
<th>Updating an Existing Contract Line Internal Attribute Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>LinePuid</td>
<td>The PUID of the contract line for which the internal attributes are captured.</td>
<td>This must be a valid contract line PUID.</td>
<td>Required</td>
<td>Not required</td>
</tr>
</tbody>
</table>
### Attribute Details

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/Import Validations</th>
<th>Creating a Contract Line Internal Attribute Record</th>
<th>Updating an Existing Contract Line Internal Attribute Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>ExtSource</td>
<td>The external source of the contract line internal attribute information.</td>
<td>This must be a unique combination of external source and key.</td>
<td>Required</td>
<td>Required</td>
</tr>
<tr>
<td>ExtKey</td>
<td>The external key of the contract line internal attribute information.</td>
<td>This must be a unique combination of external source and key.</td>
<td>Required</td>
<td>Required</td>
</tr>
<tr>
<td>ProviderBusinessUnitId</td>
<td>The provider business unit ID. This is applicable for inter-company contract.</td>
<td>This must be a valid business unit ID.</td>
<td>Required if a business unit name isn't passed.</td>
<td>Not required</td>
</tr>
<tr>
<td>ProviderBuName</td>
<td>The provider business unit name. This is applicable for inter-company contract.</td>
<td>This must be a valid business unit name.</td>
<td>Required if a business unit ID isn't passed.</td>
<td>Not required</td>
</tr>
<tr>
<td>RcvrBusinessUnitId</td>
<td>The receiver business unit ID. This is applicable for inter-company contract.</td>
<td>This must be a valid business unit ID.</td>
<td>Required if a business unit name isn't passed.</td>
<td>Not required</td>
</tr>
<tr>
<td>RcvrBuName</td>
<td>The receiver business unit name. This is applicable for inter-company contract.</td>
<td>This must be a valid business unit name.</td>
<td>Required if a business unit ID isn't passed.</td>
<td>Not required</td>
</tr>
<tr>
<td>ReceiverProjectId</td>
<td>The receiver project ID. This is applicable for inter-company and inter-project contracts.</td>
<td>This must be a valid project ID.</td>
<td>Required if a project number isn't passed.</td>
<td>Not required</td>
</tr>
<tr>
<td>ReceiverProjectNumber</td>
<td>The receiver project number. This is applicable for inter-company and inter-project contracts.</td>
<td>This must be a valid project number.</td>
<td>Required if a project ID isn't passed.</td>
<td>Not required</td>
</tr>
<tr>
<td>ReceiverTaskId</td>
<td>The receiver task ID. This is applicable for inter-company and inter-project contracts.</td>
<td>This must be a valid task ID.</td>
<td>Required if a task number isn't passed.</td>
<td>Not required</td>
</tr>
<tr>
<td>ReceiverTaskNumber</td>
<td>The receiver task number. This is applicable for inter-company and inter-project contracts.</td>
<td>This must be a valid task number.</td>
<td>Required if a task ID isn't passed.</td>
<td>Not required</td>
</tr>
</tbody>
</table>
You can view the contract line internal attribute object and attributes in the Manage Import Objects page of the Import Management flow. You can find attribute information like type, length, description, and so on, on this page.

Create the Source CSV File
You include the data that you want to import into CX Sales and B2B Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator > Tools > Import Management > Import Objects.
2. Select the Contract Line Internal Attribute object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note: For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Contract Line Internal Attribute from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. The source and target attributes are automatically mapped in the Map Fields page. Review and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed. You can drill down on the import activity to go to the Import Status page which provides the status details of the import activity.

Related Topics
- Potential Issues When Opening CSV Files in Excel
- Import Data
Import Your Contract Line Sales Credit Data

You can use Import Management to create or update Contract Line Sales Credit records.

To import Contract Line Sales Credit records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Object Attributes

To import your Contract Line Sales Credit data into Oracle Applications Cloud, you must populate a .csv file with your source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

- Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
- Ensure prerequisite setups are done, if applicable.
- Understand your options for uniquely identifying the records.
- Ensure parent records exist before importing child records.
- Identify the target object attributes that are required in the CSV file for a successful import.

Before You Start

You must do some basic checks before starting your import. For example:

- Complete all the prerequisites for importing each attribute in your source data.
- Have all parent records in place before importing child records.

Select a Unique Identifier for Your Records

To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the import process to uniquely identify the records. The file import process uses the attribute values to automatically map your source data to the target object attributes in Oracle Applications Cloud.

The preferred options to uniquely identify an object record are as follows:

- **Internal ID**: If you're identifying a record that already exists in Oracle Applications Cloud, then you can use the internal ID of the record, a system-generated unique identifier attributes with "ID" in the attribute name are typically internal IDs. You can determine the internal ID of a record by exporting Oracle Applications Cloud object data, or by doing a transactional database query. Using an internal ID typically provides better performance and reduces the import duration. For the Contract Line Sales Credit object, the attribute is Id.
- **Public unique identifiers**: If you're creating new records, then you can provide a user-friendly public unique identifier (attributes denoted with ‘Number’ and usually visible in the business object's UI). If you update a record for which you have previously provided a Number attribute, or for which a Number attribute is visible
in the object’s UI, you can use the Number attribute to identify the record. For the Contract Line Sales Credit object, the attributes are Sales Credit PUID and Line PUID.

**Required Attributes and Validations for the Contract Line Sales Credit Object**

To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure that you provide valid values for the attributes. The following table lists the required attributes for importing new Contract Line Sales Credit records, prerequisite setup tasks for the attributes, and specific validations, if any, for Contract Line Sales Credit import:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/Import Validations</th>
<th>Creating a Contract Line Sales Credit Record</th>
<th>Updating an Existing Contract Line Sales Credit Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>LinePuid</td>
<td>The unique PUID that identifies the contract line</td>
<td>This must be a valid contract line PUID.</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td>SalesCreditPuid</td>
<td>The unique ID that identifies a sales credit record</td>
<td>This must be a unique PUID for all sales credit records.</td>
<td>Required</td>
<td>Required</td>
</tr>
<tr>
<td>Percent</td>
<td>The percent credit obtained by a sales person</td>
<td>This must be less than or equal to 100%.</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td>SalesrepId</td>
<td>The unique identifier for a sales person</td>
<td>This must be a valid sales person.</td>
<td>Required if SalesrepName isn’t entered.</td>
<td>Not required</td>
</tr>
<tr>
<td>SalesrepName</td>
<td>The name that identifies the sales person</td>
<td>This must be a valid sales person.</td>
<td>Required if SalesrepId isn’t entered.</td>
<td>Not required</td>
</tr>
<tr>
<td>SalesCreditTypeld</td>
<td>The unique identifier for the sales credit type</td>
<td>To manage your sales credit types:</td>
<td>Required if SalesCreditTypeld isn’t entered</td>
<td>Not required</td>
</tr>
<tr>
<td>SalesCreditType</td>
<td>The name that identifies the sales credit type</td>
<td>To manage your sales credit types:</td>
<td>Required if SalesCreditTypeld isn’t entered</td>
<td>Not required</td>
</tr>
</tbody>
</table>

You can view the Contract Line Sales Credit object and attributes in the Manage Import Objects page of the Import Management flow. You can find attribute information like type, length, description, and so on, on this page.
Create the Source CSV File
You include the data that you want to import into CX Sales and B2B Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator > Tools > Import Management > Import Objects.
2. Select the Contract Line Sales Credit object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note: For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Contract Line Sales Credit from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. The source and target attributes are automatically mapped in the Map Fields page. Review and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you’re ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed. You can drill down on the import activity to go to the Import Status page which provides the status details of the import activity.

Related Topics
- Potential Issues When Opening CSV Files in Excel
- Import Data

Import Your Contract Line Translation Data
You can use the import functionality to create, update, or delete your contract line translation data.
You can import contract line translation records using these steps:

1. Map your source data to Oracle Applications Cloud object attributes. This way the import process would know where to insert each of the information bits.
2. Create the source CSV file with the contract line translation data you want to import.
4. Check the import results to know if the import went well.

How You Map Your Source Data to Target Object Attributes

You import contract line translation data into Oracle Applications Cloud from a CSV file containing your source data that’s mapped to target Oracle Applications Cloud object attributes.

Before you create the source data file, you should:

- Know how your source data attributes map to the target object attributes in Oracle Applications Cloud. Match each column from the source file to an attribute in the contract line translation import object.
- Finish all prerequisite steps, such as understanding what attributes are required for importing your objects.
- Know how you can uniquely identify the records.
- Check the target object attributes required in the CSV file for a successful import.

If you want to import only a few records, then you can create a single CSV file for all contract line translation attributes. However if you want to import a large number of records, then you may decide to create multiple CSV files, one for each of the contract line translation child objects.

Before You Start

You must do some basic checks before starting your import. For example, make sure that:

- You have completed all the prerequisites for importing each attribute in your source data.
- You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records

All records must be unique in the application. You can use one of these to identify records:

- Public unique identifiers: If you're creating records, then you can provide an easily understandable public unique identifier. These are, usually, denoted with 'Number' and visible in the business object's UI. PUID attributes are usually named <object> Number. If you're updating a record with a Number attribute, then use the Number attribute to identify the record. For more information about public unique identifiers, see the topic "How You Use Alternate Keys to Import Records" in Related Topics section.
- Source system and source system reference: Source system is an identifier for the external system, and source system reference is a unique identifier within the external system. If you're importing new contract line translation or are updating contract line translation that have source system reference data, then provide the source system and source system reference values.

Required Attributes and Validations for Contract Line Translation Object

To import data successfully into Oracle Applications Cloud, your .csv file must include the required attributes. Make sure that you provide valid values for these attributes so that they pass import validations inbuilt into the application.
This table lists the required attributes for contract line translation records, prerequisite setup tasks and specific validations, if any:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/Import Validations</th>
<th>Creating a Contract Line Translation record</th>
<th>Updating an Existing Contract Line Translation record</th>
</tr>
</thead>
<tbody>
<tr>
<td>LinePuid</td>
<td>The PUID of the contract line for which the translation information is captured.</td>
<td>Must be a valid contract PUID.</td>
<td>Required</td>
<td>Required</td>
</tr>
<tr>
<td>Lang</td>
<td>The language in which the translation is captured.</td>
<td>Must be a valid language.</td>
<td>Required</td>
<td>Required</td>
</tr>
</tbody>
</table>

Go to Navigator > Tools > Import Management > Import Objects, to see all the attributes of the contract line translation object. The page also lists attribute information like type, length, description, and so on.

Create the Source CSV File

You include the data that you want to import into CX Sales and B2B Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator > Tools > Import Management > Import Objects.
2. Select the Contract Line Translation object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

**Note:** For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity

After you have the CSV file ready, create an import activity to import the contract line translation information. To create an import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. On the Manage Imports page, click Create Import Activity.
3. In the Create Import Activity: Enter Import Options page, provide a name for the import activity, and select Contract Line Translation from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review and edit the mappings if required.

   **Note:** Click Validate Data to validate the mapping of the source file for unmapped columns and to check for data format issues.

6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you’re ready.
Review the Import Results

Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.
   You can drill down on the import activity to go to the Import Status page which provides the status details of the import activity.

Related Topics

- How You Use Alternate Keys to Import Records
- Potential Issues When Opening CSV Files in Excel

Import Your Contract Manual Adjustments Data

You can use Import Management to create or update Contract Manual Adjustments records.

To import Contract Manual Adjustments records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Object Attributes

To import your Contract Manual Adjustments data into Oracle Applications Cloud, you must populate a .csv file with your source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

- Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
- Ensure prerequisite setups are done, if applicable.
- Understand your options for uniquely identifying the records.
- Ensure parent records exist before importing child records.
- Identify the target object attributes that are required in the CSV file for a successful import.

Before You Start

You must do some basic checks before starting your import. For example:

- Complete all the prerequisites for importing each attribute in your source data.
- Have all parent records in place before importing child records.
Select a Unique Identifier for Your Records

To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the import process to uniquely identify the records. The file import process uses the attribute values to automatically map your source data to the target object attributes in Oracle Applications Cloud.

The preferred option to uniquely identify an object record is through the public unique identifier. If you’re creating new records, then you can provide a user-friendly public unique identifier (attributes denoted with ‘Number’ and usually visible in the business object’s UI). If you update a record for which you have previously provided a Number attribute, or for which a Number attribute is visible in the object’s UI, you can use the Number attribute to identify the record. For the Contract Manual Adjustments object, the attribute is SequenceNumber.

Required Attributes and Validations for the Contract Manual Adjustments Object

To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure that you provide valid values for the attributes. The following table lists the required attributes for importing new Contract Manual Adjustments records, prerequisite setup tasks for the attributes, and specific validations, if any, for Contract Manual Adjustments import:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/Import Validations</th>
<th>Creating a Contract Manual Adjustments Record</th>
<th>Updating an Existing Contract Manual Adjustments Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>ExtSource</td>
<td>The external source identifying a manual adjustment</td>
<td>This must be a unique value across the Adjustments table.</td>
<td>Required</td>
<td>Required</td>
</tr>
<tr>
<td>ExtKey</td>
<td>The external key identifying a manual adjustment</td>
<td>This must be a unique value across the Adjustments table.</td>
<td>Required</td>
<td>Required</td>
</tr>
<tr>
<td>ChargeExtSource</td>
<td>The external source of a charge</td>
<td>This must be a valid charge external source.</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td>ChargeExtKey</td>
<td>The external key of the charge</td>
<td>This must be a valid charge external key.</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td>SequenceNumber</td>
<td>The sequence number of the adjustment</td>
<td>No validation</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>AdjustmentTypeCode</td>
<td>The adjustment type code</td>
<td>This must be a valid adjustment code.</td>
<td>A value is required if the adjustment type isn’t passed.</td>
<td>Not required</td>
</tr>
<tr>
<td>AdjustmentType</td>
<td>The adjustment type</td>
<td>This must be a valid adjustment name.</td>
<td>A value is required if the adjustment type code isn’t passed.</td>
<td>Not required</td>
</tr>
<tr>
<td>AdjustmentValue</td>
<td>The adjustment value</td>
<td>No validation</td>
<td>Required</td>
<td>Not required</td>
</tr>
</tbody>
</table>
You can view the Contract Manual Adjustments object and attributes in the Manage Import Objects page of the Import Management flow. You can find attribute information like type, length, description, and so on, on this page.

Create the Source CSV File
You include the data that you want to import into CX Sales and B2B Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator > Tools > Import Management > Import Objects.

You can now edit the downloaded file and provide valid values for the required attributes.

Note: For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Contract Manual Adjustments from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. The source and target attributes are automatically mapped in the Map Fields page. Review and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.
Review the Import Results

Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed. You can drill down on the import activity to go to the Import Status page which provides the status details of the import activity.

Related Topics

- Potential Issues When Opening CSV Files in Excel
- Import Data

Import Your Contract Party Data

You can use Import Management to create or update Contract Party records.

To import Contract Party records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Object Attributes

To import your Contract Party data into Oracle Applications Cloud, you must populate a .csv file with your source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

- Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
- Ensure prerequisite setups are done, if applicable.
- Understand your options for uniquely identifying the records.
- Ensure parent records exist before importing child records.
- Identify the target object attributes that are required in the CSV file for a successful import.

Before You Start

You must do some basic checks before starting your import. For example:

- Complete all the prerequisites for importing each attribute in your source data.
- Have all parent records in place before importing child records.
Select a Unique Identifier for Your Records

To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the import process to uniquely identify the records. The file import process uses the attribute values to automatically map your source data to the target object attributes in Oracle Applications Cloud.

The preferred options to uniquely identify an object record are as follows:

- **Internal ID:** If you're identifying a record that already exists in Oracle Applications Cloud, then you can use the internal ID of the record, a system-generated unique identifier attributes with "ID" in the attribute name are typically internal IDs. You can determine the internal ID of a record by exporting Oracle Applications Cloud object data, or by doing a transactional database query. Using an internal ID typically provides better performance and reduces the import duration. For the Contract Party object, the attributes are Id and Party Id.

- **Public unique identifiers:** If you're creating new records, then you can provide a user-friendly public unique identifier (attributes denoted with 'Number' and usually visible in the business object's UI). If you update a record for which you have previously provided a Number attribute, or for which a Number attribute is visible in the object's UI, you can use the Number attribute to identify the record. For the Contract Party object, the attributes are Party Number, Party Role PUID, and Contract PUID.

Required Attributes and Validations for the Contract Party Object

To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure that you provide valid values for the attributes. The following table lists the required attributes for importing new Contract Party records, prerequisite setup tasks for the attributes, and specific validations, if any, for Contract Party import:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/Import Validations</th>
<th>Creating a Contract Party Record</th>
<th>Updating an Existing Contract Party Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>ContractPuid</td>
<td>The unique PUID that identifies the contract</td>
<td>This must be a valid Contract PUID.</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td>PartyRolePuid</td>
<td>The unique identifier for the party record</td>
<td>This must be a unique PUID for all contract party records.</td>
<td>Required</td>
<td>Required</td>
</tr>
<tr>
<td>PartyRoleCode</td>
<td>The code that represents a party role</td>
<td>This must be a valid party role code defined for the contract type.</td>
<td>Required if the Role isn't entered.</td>
<td>Not required</td>
</tr>
<tr>
<td>Role</td>
<td>The name that represents a party role</td>
<td>This must be a valid party role defined for the contract type.</td>
<td>Required if the PartyRoleCode isn't entered.</td>
<td>Not required</td>
</tr>
<tr>
<td>PartyId</td>
<td>The unique identifier for a party</td>
<td>This must be a valid party - HZ_PARTIES.</td>
<td>Required if PartyName isn't entered or if there is more than one party with the same party name.</td>
<td>Not required</td>
</tr>
<tr>
<td>PartyName</td>
<td>The name that represents a party</td>
<td>This must be a valid and unique party name - HZ_PARTIES. If there is</td>
<td>Required if PartyId isn't entered</td>
<td>Not required</td>
</tr>
</tbody>
</table>
Attribute | Description | Prerequisite Setup Task/Import Validations | Creating a Contract Party Record | Updating an Existing Contract Party Record
--- | --- | --- | --- | ---

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/Import Validations</th>
<th>Creating a Contract Party Record</th>
<th>Updating an Existing Contract Party Record</th>
</tr>
</thead>
</table>

You can view the Contract Party object and attributes in the Manage Import Objects page of the Import Management flow. You can find attribute information like type, length, description, and so on, on this page.

Create the Source CSV File
You include the data that you want to import into CX Sales and B2B Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator > Tools > Import Management > Import Objects.
2. Select the Contract Party object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

**Note:** For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Contract Party from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. The source and target attributes are automatically mapped in the Map Fields page. Review and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed. You can drill down on the import activity to go to the Import Status page which provides the status details of the import activity.
Import Your Contract Party Contact Data

You can use Import Management to create or update Contract Party Contact records.

To import Contract Party Contact records, perform the following tasks:
1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Object Attributes

To import your Contract Party Contact data into Oracle Applications Cloud, you must populate a .csv file with your source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:
- Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
- Ensure prerequisite setups are done, if applicable.
- Understand your options for uniquely identifying the records.
- Ensure parent records exist before importing child records.
- Identify the target object attributes that are required in the CSV file for a successful import.

Before You Start

You must do some basic checks before starting your import. For example:
- Complete all the prerequisites for importing each attribute in your source data.
- Have all parent records in place before importing child records.

Select a Unique Identifier for Your Records

To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the import process to uniquely identify the records. The file import process uses the attribute values to automatically map your source data to the target object attributes in Oracle Applications Cloud.

The preferred options to uniquely identify an object record are as follows:

- **Internal ID**: If you're identifying a record that already exists in Oracle Applications Cloud, then you can use the internal ID of the record, a system-generated unique identifier attributes with "ID" in the attribute name are typically internal IDs. You can determine the internal ID of a record by exporting Oracle Applications Cloud object data, or by doing a transactional database query. Using an internal ID typically provides better...
performance and reduces the import duration. For the Contract Party Contact object, the attributes are Id and Contact Id.

- **Public unique identifiers**: If you’re creating new records, then you can provide a user-friendly public unique identifier (attributes denoted with ‘Number’ and usually visible in the business object’s UI). If you update a record for which you have previously provided a Number attribute, or for which a Number attribute is visible in the object’s UI, you can use the Number attribute to identify the record. For the Contract Party Contact object, the attribute is Contact PUID.

### Required Attributes and Validations for the Contract Party Contact Object

To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure that you provide valid values for the attributes. The following table lists the required attributes for importing new Contract Party Contact records, prerequisite setup tasks for the attributes, and specific validations, if any, for Contract Party Contact import:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/Import Validations</th>
<th>Creating a Contract Party Contact Record</th>
<th>Updating an Existing Contract Party Contact Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>PartyRolePuid</td>
<td>The unique identifier of the party record.</td>
<td>No validation</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td>ContactPuid</td>
<td>The unique identifier of the party contact record.</td>
<td>No validation</td>
<td>Required</td>
<td>Required</td>
</tr>
<tr>
<td>ContactRoleCode</td>
<td>The role played by the contact in this contract.</td>
<td>OKC_PARTY_CONTACT_SOURCES.CONTACT_ROLE_CODE</td>
<td>Required if the role isn’t entered</td>
<td>Required</td>
</tr>
<tr>
<td>Role</td>
<td>The name of the role played by the contact in this contract.</td>
<td>No validation</td>
<td>Required if ContactRoleCode isn’t entered</td>
<td>Not required</td>
</tr>
<tr>
<td>ContactId</td>
<td>The unique identifier of the contract party contact.</td>
<td>HZ_RELATIONSHIPS</td>
<td>Required if PartyContactName isn’t entered</td>
<td>Not required</td>
</tr>
<tr>
<td>PartyContactName</td>
<td>The name of the contract party contact.</td>
<td>Valid name as per HZ_PARTIES record</td>
<td>Required if ContactId isn’t entered</td>
<td>Not required</td>
</tr>
<tr>
<td>OwnerYn</td>
<td>Indicates whether the contact is a contract owner</td>
<td>The values must be either YES or NO.</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td>AccessLevel</td>
<td>The access level of a team member.</td>
<td>This must be one among FULL, READ, or NO_ACCESS.</td>
<td>Required if AccessLevelName isn’t entered</td>
<td>Not required</td>
</tr>
<tr>
<td>AccessLevelName</td>
<td>The access level of a team member.</td>
<td>This must be one among Full, Read, or No Access.</td>
<td>Required if AccessLevel isn’t entered</td>
<td>Not required</td>
</tr>
</tbody>
</table>
You can view the Contract Party Contact object and attributes in the Manage Import Objects page of the Import Management flow. You can find attribute information like type, length, description, and so on, on this page.

**Note:** Prior to the 20B release, the logged in user was getting defaulted as the contract owner for a contract automatically. From the 20B release, the logged in user won’t get defaulted automatically when you import the contract header. You need to specify the contract owner information in the Contract Party Contact CSV file and import it.

Create the Source CSV File

You include the data that you want to import into CX Sales and B2B Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to **Navigator > Tools > Import Management > Import Objects**.
2. Select the **Contract Party Contact** object in the table and click **Download**.

You can now edit the downloaded file and provide valid values for the required attributes.

**Note:** For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity

After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to **Navigator > Tools > Import Management > Import Queue**.
2. Click **Create Import Activity** in the **Manage Imports** page.
3. In the **Enter Import Options** page, provide a name for the import activity, and select Contract Party Contact from the **Object** drop-down list.
4. Select the CSV file in the **File Name** field, and click **Next**.
5. The source and target attributes are automatically mapped in the **Map Fields** page. Review and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking **Validate Data**. Click **Next**.
7. Review the import details on the **Review and Submit** page, and click **Submit** when you’re ready.

Review the Import Results

Check if your import succeeded on the **Manage Imports** page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to **Navigator > Tools > Import Management > Import Queue**.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the **Status** column for the import activity. The import is successful if the status displays as **Completed**. You can drill down on the import activity to go to the **Import Status** page which provides the status details of the import activity.

**Related Topics**

- Potential Issues When Opening CSV Files in Excel
- Import Data
Import Your Contract Party Descriptive Flexfield Data

You can use Import Management to create or update Contract Party Descriptive Flexfield records.

To import Contract Party Descriptive Flexfield records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes

To import your Contract Party Descriptive Flexfield data into Oracle Applications Cloud, you need to populate a CSV file with your source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

- Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
- Ensure prerequisite setups are done, if applicable.
- Understand your options for uniquely identifying the records.
- Ensure parent records exist before importing child records.
- Identify the target object attributes that are required in the CSV file for a successful import.
- Ensure that you don't insert duplicate addresses while importing, to avoid redundant data.

Before You Start

You must do some basic checks before starting your import. For example, make sure that:

- You have completed all the prerequisites for importing each attribute in your source data.
- You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records

All records must be unique in the application. You can use one of these to identify records:

- Public unique identifiers: If you're creating records, then you can provide an easily understandable public unique identifier. These are, usually, denoted with 'Number' and visible in the business object's UI. PUID attributes are usually named <object> Number. If you're updating a record with a Number attribute, then use the Number attribute to identify the record. For more information about public unique identifiers, see the topic "How You Use Alternate Keys to Import Records" in Related Topics section.
- Source system and source system reference: Source system is an identifier for the external system, and source system reference is a unique identifier within the external system. If you're importing new contacts or are updating contacts that have source system reference data, then provide the source system and source system reference values.
Required Attributes and Validations for Contract Party Descriptive Flexfield Object

To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure that you provide valid values for the attributes. This table lists the required attributes for importing new Contract Party Descriptive Flexfield records, required attributes for updating Contract Party Descriptive Flexfield records, prerequisite setup tasks for the attributes, and specific validations, if any, for Contract Party Descriptive Flexfield import:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/Import Validations</th>
<th>Creating a Contract Party Descriptive Flexfield Record</th>
<th>Updating an Existing Contract Party Descriptive Flexfield Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>Id</td>
<td>The unique identifier of the contract party record.</td>
<td>This must be a valid contract party Id.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>PartyRolePuid</td>
<td>The unique PUID that identifies the contract party record.</td>
<td>This must be a valid contract party PUID.</td>
<td>Required</td>
<td>Required</td>
</tr>
<tr>
<td>AttributeCategory</td>
<td>Attribute category of the descriptive flexfield</td>
<td>No validation</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>Attribute1</td>
<td>Attribute 1 of the descriptive flexfield</td>
<td>No validation</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td>Attribute2</td>
<td>Attribute 2 of the descriptive flexfield</td>
<td>No validation</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>Attribute3</td>
<td>Attribute 3 of the descriptive flexfield</td>
<td>No validation</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>Attribute4</td>
<td>Attribute 4 of the descriptive flexfield</td>
<td>No validation</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>Attribute5</td>
<td>Attribute 5 of the descriptive flexfield</td>
<td>No validation</td>
<td>Not required</td>
<td>Not required</td>
</tr>
</tbody>
</table>

You can view the Contract Party Descriptive Flexfield object along with all its child objects and attributes in the Manage Import Objects page of the Import Management flow. You can find attribute information like type, length, description, and so on, on this page.

Create the Source CSV File

You include the data that you want to import into CX Sales and B2B Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator > Tools > Import Management > Import Objects.
2. Select the Contract Party Descriptive Flexfield object in the table and click Download.
You can now edit the downloaded file and provide valid values for the required attributes.

**Note:** For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.

### Create the Import Activity

After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to **Navigator** > **Tools** > **Import Management** > **Import Queue**.
2. Click **Create Import Activity** in the **Manage Imports** page.
3. In the **Enter Import Options** page, provide a name for the import activity, and select Contract Party Descriptive Flexfield from the **Object** drop-down list.
4. Select the CSV file in the **File Name** field, and click **Next**.
5. You would see that the source and target attributes are automatically mapped in the **Map Fields** page. Review and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking **Validate Data**. Click **Next**.
7. Review the import details on the **Review and Submit** page, and click **Submit** when you're ready.

### Review the Import Results

Check if your import succeeded on the **Manage Imports** page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to **Navigator** > **Tools** > **Import Management** > **Import Queue**.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the **Status** column for the import activity. The import is successful if the status displays as **Completed**. You can drill down on the import activity to go to the **Import Status** page which provides the status details of the import activity.

**Related Topics**

- Potential Issues When Opening CSV Files in Excel
- How You Use Alternate Keys to Import Records
- Import Data

### Import Your Contract Party Contact Descriptive Flexfield Data

You can use Import Management to create or update Contract Party Contact Descriptive Flexfield records.

To import Contract Party Contact Descriptive Flexfield records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.
How You Map Your Source Data to Target Object Attributes
To import your Contract Party Contact Descriptive Flexfield data into Oracle Applications Cloud, you need to populate a CSV file with your source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

- Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
- Ensure prerequisite setups are done, if applicable.
- Understand your options for uniquely identifying the records.
- Ensure parent records exist before importing child records.
- Identify the target object attributes that are required in the CSV file for a successful import.
- Ensure that you don’t insert duplicate addresses while importing, to avoid redundant data.

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

- You have completed all the prerequisites for importing each attribute in your source data.
- You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
All records must be unique in the application. You can use one of these to identify records:

- Public unique identifiers: If you’re creating records, then you can provide an easily understandable public unique identifier. These are, usually, denoted with ‘Number’ and visible in the business object’s UI. PUID attributes are usually named <object> Number. If you’re updating a record with a Number attribute, then use the Number attribute to identify the record. For more information about public unique identifiers, see the topic "How You Use Alternate Keys to Import Records" in Related Topics section.
- Source system and source system reference: Source system is an identifier for the external system, and source system reference is a unique identifier within the external system. If you’re importing new contacts or are updating contacts that have source system reference data, then provide the source system and source system reference values.

Required Attributes and Validations for Contract Party Contact Descriptive Flexfield Object
To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure that you provide valid values for the attributes. This table lists the required attributes for importing new Contract Party Contact Descriptive Flexfield records, required attributes for updating Contract Party Contact Descriptive Flexfield records, prerequisite setup tasks for the attributes, and specific validations, if any, for Contract Party Contact Descriptive Flexfield import:
### Create the Source CSV File

You include the data that you want to import into CX Sales and B2B Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to **Navigator > Tools > Import Management > Import Objects**.
2. Select the **Contract Party Contact Descriptive Flexfield** object in the table and click **Download**.

You can now edit the downloaded file and provide valid values for the required attributes.

**Note:** For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.
Create the Import Activity

After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Contract Party Contact Descriptive Flexfield from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you’re ready.

Review the Import Results

Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed. You can drill down on the import activity to go to the Import Status page which provides the status details of the import activity.

Related Topics
- Potential Issues When Opening CSV Files in Excel
- How You Use Alternate Keys to Import Records
- Import Data

Import Your Contract Pricing Terms Data

You can use Import Management to create or update Contract Pricing Term records.

To import Contract Pricing Term records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Object Attributes

To import your Contract Pricing Terms data into Oracle Applications Cloud, you must populate a .csv file with your source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

- Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
• Ensure prerequisite setups are done, if applicable.
• Understand your options for uniquely identifying the records.
• Ensure parent records exist before importing child records.
• Identify the target object attributes that are required in the CSV file for a successful import.

Before You Start
You must do some basic checks before starting your import. For example:

• Complete all the prerequisites for importing each attribute in your source data.
• Have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the import process to uniquely identify the records. The file import process uses the attribute values to automatically map your source data to the target object attributes in Oracle Applications Cloud.

The preferred option to uniquely identify an object record is through the public unique identifiers. If you’re creating new records, then you can provide a user-friendly public unique identifier (attributes denoted with 'Number' and usually visible in the business object’s UI). If you update a record for which you have previously provided a Number attribute, or for which a Number attribute is visible in the object’s UI, you can use the Number attribute to identify the record. For the Contract Pricing Terms object, the attributes are Line PUID and Pricing Terms PUID.

Required Attributes and Validations for the Contract Pricing Terms Object
To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure that you provide valid values for the attributes. The following table lists the required attributes for importing new Contract Pricing Terms records, prerequisite setup tasks for the attributes, and specific validations, if any, for Contract Pricing Terms import:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/ Import Validations</th>
<th>Creating a Contract Pricing Terms Record</th>
<th>Updating an Existing Contract Pricing Terms Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>AdjustmentAmount</td>
<td>The adjustment amount of a pricing term</td>
<td>No validation</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>AdjustmentType</td>
<td>The type of adjustment</td>
<td>To manage your adjustments:</td>
<td>Required if AdjustmentTypeCode isn't entered</td>
<td>Not required</td>
</tr>
<tr>
<td></td>
<td></td>
<td>1. In Setup and Maintenance, go to the Manage Standard Lookups task.</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>2. Search for Contract Price Adjustment Types lookup.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>AdjustmentTypeCode</td>
<td>The code that represents the type of adjustment</td>
<td>To manage your adjustments:</td>
<td>Required if AdjustmentType isn't entered</td>
<td>Not required</td>
</tr>
</tbody>
</table>
### Create the Source CSV File

You include the data that you want to import into CX Sales and B2B Service in a source CSV file. You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator > Tools > Import Management > Import Objects.
2. Select the Contract Pricing Terms object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

**Note:** For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.

### Create the Import Activity

After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Contract Pricing Terms from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. The source and target attributes are automatically mapped in the Map Fields page. Review and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed. You can drill down on the import activity to go to the Import Status page which provides the status details of the import activity.

Related Topics
- Potential Issues When Opening CSV Files in Excel
- Import Data

Import Your Contract Related Document Data
You can use Import Management to create or update Contract Related Document records.

To import Contract Related Document records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Object Attributes
To import your Contract Related Document data into Oracle Applications Cloud, you must populate a .csv file with your source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

- Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
- Ensure prerequisite setups are done, if applicable.
- Understand your options for uniquely identifying the records.
- Ensure parent records exist before importing child records.
- Identify the target object attributes that are required in the CSV file for a successful import.

Before You Start
You must do some basic checks before starting your import. For example:

- Complete all the prerequisites for importing each attribute in your source data.
- Have all parent records in place before importing child records.
Select a Unique Identifier for Your Records

To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the import process to uniquely identify the records. The file import process uses the attribute values to automatically map your source data to the target object attributes in Oracle Applications Cloud.

The preferred options to uniquely identify an object record are as follows:

- **Internal ID**: If you’re identifying a record that already exists in Oracle Applications Cloud, then you can use the internal ID of the record, a system-generated unique identifier attributes with "ID" in the attribute name are typically internal IDs. You can determine the internal ID of a record by exporting Oracle Applications Cloud object data, or by doing a transactional database query. Using an internal ID typically provides better performance and reduces the import duration. For the Contract Related Document object, the attributes are Id, Contract Id, and Related Contract Id.

- **Public unique identifiers**: If you’re creating new records, then you can provide a user-friendly public unique identifier (attributes denoted with 'Number' and usually visible in the business object's UI). If you update a record for which you have previously provided a Number attribute, or for which a Number attribute is visible in the object’s UI, you can use the Number attribute to identify the record. For the Contract Related Document object, the attributes are Related Object PUID, Contract PUID, and RelatedContractPUID.

### Required Attributes and Validations for the Contract Related Document Object

To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure that you provide valid values for the attributes. The following table lists the required attributes for importing new Contract Related Document records, prerequisite setup tasks for the attributes, and specific validations, if any, for Contract Related Document import:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/Import Validations</th>
<th>Creating a Contract Related Document Record</th>
<th>Updating an Existing Contract Related Document Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>RelObjPuid</td>
<td>Unique PUID of the related contract record.</td>
<td>No validation</td>
<td>Required</td>
<td>Required</td>
</tr>
<tr>
<td>ContractPuid</td>
<td>The PUID of the source contract.</td>
<td>This must be a valid source contract PUID.</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td>RelatedContractPuid</td>
<td>The PUID of the target contract.</td>
<td>This must be a valid target contract PUID.</td>
<td>Required</td>
<td>Not required</td>
</tr>
</tbody>
</table>
| RelationshipCode  | The code that represents the relationship between the two contracts | You can manage the relationships. Navigate to the following in the Setup and Maintenance work area:  
  - Offering: Sales  
  - Functional Area: Data Import and Export | Required if Relationship isn't entered | Not required                                      |
To import your data, you need to create a Contract Related Document object in the Setup and Maintenance area. The name that represents the relationship between the two contracts can be managed from the Manage Contract Relationship Types task. Required if RelationshipCode isn’t entered.

You can view the Contract Related Document object and attributes in the Manage Import Objects page of the Import Management flow. You can find attribute information like type, length, description, and so on, on this page.

### Create the Source CSV File

You include the data that you want to import into CX Sales and B2B Service in a source CSV file. You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator > Tools > Import Management > Import Objects.
2. Select the Contract Related Document object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

**Note:** For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.

### Create the Import Activity

After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Contract Related Document from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. The source and target attributes are automatically mapped in the Map Fields page. Review and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you’re ready.
Review the Import Results

Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed. You can drill down on the import activity to go to the Import Status page which provides the status details of the import activity.

Related Topics
- Potential Issues When Opening CSV Files in Excel
- Import Data

Import Your Contract Sales Credit Data

You can use Import Management to create or update Contract Sales Credit records.

To import Contract Sales Credit records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Object Attributes

To import your Contract Sales Credit data into Oracle Applications Cloud, you must populate a .csv file with your source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

- Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
- Ensure prerequisite setups are done, if applicable.
- Understand your options for uniquely identifying the records.
- Ensure parent records exist before importing child records.
- Identify the target object attributes that are required in the CSV file for a successful import.

Before You Start

You must do some basic checks before starting your import. For example:

- Complete all the prerequisites for importing each attribute in your source data.
- Have all parent records in place before importing child records.
Select a Unique Identifier for Your Records

To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the import process to uniquely identify the records. The file import process uses the attribute values to automatically map your source data to the target object attributes in Oracle Applications Cloud.

The preferred options to uniquely identify an object record are as follows:

- **Internal ID**: If you’re identifying a record that already exists in Oracle Applications Cloud, then you can use the internal ID of the record, a system-generated unique identifier attributes with "ID" in the attribute name are typically internal IDs. You can determine the internal ID of a record by exporting Oracle Applications Cloud object data, or by doing a transactional database query. Using an internal ID typically provides better performance and reduces the import duration. For the Contract Sales Credit object, the attribute is Id.

- **Public unique identifiers**: If you’re creating new records, then you can provide a user-friendly public unique identifier (attributes denoted with ‘Number’ and usually visible in the business object's UI). If you update a record for which you have previously provided a Number attribute, or for which a Number attribute is visible in the object's UI, you can use the Number attribute to identify the record. For the Contract Sales Credit object, the attributes are Sales Credit PUID and Contract PUID.

### Required Attributes and Validations for the Contract Sales Credit Object

To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure that you provide valid values for the attributes. The following table lists the required attributes for importing new Contract Sales Credit records, prerequisite setup tasks for the attributes, and specific validations, if any, for Contract Sales Credit import:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/Import Validations</th>
<th>Creating a Contract Sales Credit Record</th>
<th>Updating an Existing Contract Sales Credit Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>ContractPuid</td>
<td>The unique PUID that identifies the contract</td>
<td>This must be a valid contract PUID.</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td>SalesCreditPuid</td>
<td>The unique Id that identifies a sales credit record</td>
<td>This must be a unique PUID for all sales credit records.</td>
<td>Required</td>
<td>Required</td>
</tr>
<tr>
<td>Percent</td>
<td>The percent credit obtained by a sales person</td>
<td>This must be less than or equal to 100%.</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td>SalesrepId</td>
<td>The Id that identifies the sales person</td>
<td>This must be a valid sales person.</td>
<td>Required if the SalesrepName isn’t entered</td>
<td>Not required</td>
</tr>
<tr>
<td>SalesrepName</td>
<td>The name that identifies the sales person</td>
<td>This must be a valid sales person.</td>
<td>Required if the SalesrepId isn’t entered</td>
<td>Not required</td>
</tr>
<tr>
<td>SalesCreditTypeld</td>
<td>The unique identifier for the sales credit type</td>
<td>To manage your sales credit types:</td>
<td>Required if SalesCreditType isn’t entered</td>
<td>Not required</td>
</tr>
</tbody>
</table>

1. In Setup and Maintenance, go to
**Create the Source CSV File**

You include the data that you want to import into CX Sales and B2B Service in a source CSV file. You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to **Navigator > Tools > Import Management > Import Objects.**
2. Select the **Contract Sales Credit** object in the table and click **Download.**

You can now edit the downloaded file and provide valid values for the required attributes.

**Note:** For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.

**Create the Import Activity**

After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to **Navigator > Tools > Import Management > Import Queue.**
2. Click **Create Import Activity** in the **Manage Imports** page.
3. In the **Enter Import Options** page, provide a name for the import activity, and select Contract Sales Credit from the **Object** drop-down list.
4. Select the CSV file in the **File Name** field, and click **Next.**
5. The source and target attributes are automatically mapped in the **Map Fields** page. Review and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking **Validate Data.** Click **Next.**
7. Review the import details on the **Review and Submit** page, and click **Submit** when you're ready.
Import Your Data

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed. You can drill down on the import activity to go to the Import Status page which provides the status details of the import activity.

Related Topics
- Potential Issues When Opening CSV Files in Excel
- Import Data

Import Your Conversation Data
You can use Import Management to create, update, or delete Conversation records.

To import Conversation records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes
To import your Conversation data into Oracle Applications Cloud, you need to populate a CSV file with your source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

- Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
- Ensure prerequisite setups are done, if applicable.
- Understand your options for uniquely identifying the records.
- Identify the target object attributes that are required in the CSV file for a successful import.

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

- You have completed all the prerequisites for importing each attribute in your source data.

Select a Unique Identifier for Your Records
All records must be unique in the application. If you're creating records, then you can provide an easily understandable public unique identifier. These are, usually, denoted with 'Number' and visible in the business object's UI. PUID attributes
are usually named <object> Number. If you're updating a record with a Number attribute, then use the Number attribute to identify the record. For more information about public unique identifiers, see the topic "How You Use Alternate Keys to Import Records" in Related Topics section.

Required Attributes and Validations for Conversation Object

To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure that you provide valid values for the attributes. This table lists the required attributes for importing new Conversation records, required attributes for updating Conversation records, prerequisite setup tasks for the attributes, and specific validations, if any, for Conversation import:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/ Import Validations</th>
<th>Creating a Conversation Record</th>
<th>Updating an Existing Conversation Record</th>
<th>Deleting an Existing Conversation Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>ConversationId</td>
<td>The unique identifier of the conversation.</td>
<td>Must be a valid ConversationId when updating a conversation.</td>
<td>Not Required</td>
<td>Conditionally Required. Provide value if the ConversationNumber isn't provided.</td>
<td>Conditionally Required. Provide value if the ConversationNumber isn't provided.</td>
</tr>
<tr>
<td>ConversationNumber</td>
<td>The public unique identifier of the conversation.</td>
<td>Must be a valid ConversationNumber when updating a conversation.</td>
<td>Not Required</td>
<td>Conditionally Required. Provide value if the ConversationId isn't provided.</td>
<td>Conditionally Required. Provide value if the ConversationId isn't provided.</td>
</tr>
<tr>
<td>StripeCd</td>
<td>The application stripe of the conversation.</td>
<td>None</td>
<td>Not Required</td>
<td>Not Required</td>
<td>Not Required</td>
</tr>
<tr>
<td>ConversationStatusCd</td>
<td>The status of the conversation.</td>
<td>Must be a valid conversation status.</td>
<td>Not Required</td>
<td>Not Required</td>
<td>Not Required</td>
</tr>
<tr>
<td>PrimaryMessageNumber</td>
<td>The public unique identifier of the primary message in the conversation.</td>
<td>None</td>
<td>Not Required</td>
<td>Not Required</td>
<td>Not Required</td>
</tr>
<tr>
<td>BUOrgId</td>
<td>The identifier of the business unit.</td>
<td>None</td>
<td>Not Required</td>
<td>Not Required</td>
<td>Not Required</td>
</tr>
</tbody>
</table>

You can view the Conversation object along with all its child objects and attributes in the Manage Import Objects page of the Import Management flow. You can find attribute information like type, length, description, and so on, on this page.
Create the Source CSV File

You include the data that you want to import into CX Sales and B2B Service in a source CSV file. You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator > Tools > Import Management > Import Objects.
2. Select the Conversation object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

| Note: | For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section. |

Create the Import Activity

After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Conversation from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.

You would see that the source and target attributes are automatically mapped in the Map Fields page. Review and edit the mappings if required.

5. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
6. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results

Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed. You can drill down on the import activity to go to the Import Status page which provides the status details of the import activity.

Related Topics

- Potential Issues When Opening CSV Files in Excel
- How You Use Alternate Keys to Import Records
- Import Data
Import Your Conversation Message Data

You can use Import Management to create, update, or delete Conversation Message records.

To import Conversation Message records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes

To import your Conversation Message data into Oracle Applications Cloud, you need to populate a CSV file with your source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

- Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
- Ensure prerequisite setups are done, if applicable.
- Understand your options for uniquely identifying the records.
- Identify the target object attributes that are required in the CSV file for a successful import.

Before You Start

You must do some basic checks before starting your import. For example, make sure that:

- You have completed all the prerequisites for importing each attribute in your source data.

Select a Unique Identifier for Your Records

All records must be unique in the application. If you’re creating records, then you can provide an easily understandable public unique identifier. These are, usually, denoted with ‘Number’ and visible in the business object’s UI. PUID attributes are usually named <object> Number. If you’re updating a record with a Number attribute, then use the Number attribute to identify the record. For more information about public unique identifiers, see the topic "How You Use Alternate Keys to Import Records" in Related Topics section.

Required Attributes and Validations for Conversation Message Object

To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure that you provide valid values for the attributes. This table lists the required attributes for importing new Conversation Message records, required attributes for updating Conversation Message records, prerequisite setup tasks for the attributes, and specific validations, if any, for Conversation Message import:
<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/ Import Validations</th>
<th>Creating a Conversation Message Record</th>
<th>Updating an Existing Conversation Message Record</th>
<th>Deleting an Existing Conversation Message Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>MessageId</td>
<td>The unique identifier of the conversation message.</td>
<td>Must be a valid MessageId when updating a conversation message.</td>
<td>Not Required</td>
<td>Conditionally Required. Provide value if the MessageId isn't provided.</td>
<td>Conditionally Required. Provide value if the MessageId isn't provided.</td>
</tr>
<tr>
<td>MessageNumber</td>
<td>The public unique identifier of the conversation message.</td>
<td>Must be a valid MessageNumber when updating a conversation message.</td>
<td>Not Required</td>
<td>Conditionally Required. Provide value if the MessageId isn't provided.</td>
<td>Conditionally Required. Provide value if the MessageId isn't provided.</td>
</tr>
<tr>
<td>ParentMessageNumber</td>
<td>The public unique identifier of the parent message.</td>
<td>Must be a valid message number.</td>
<td>Not Required</td>
<td>Not Required</td>
<td>Not Required</td>
</tr>
<tr>
<td>MessageStatusCd</td>
<td>The status of the conversation message.</td>
<td>Valid values are: ORA_SVC_DRAFT, ORA_SVC_COMMITTED, ORA_SVC_CORRECTED.</td>
<td>Not Required. If not passed, it will be defaulted to ORA_SVC_COMMITTED.</td>
<td>Not Required</td>
<td>Not Required</td>
</tr>
<tr>
<td>MessageTypeCd</td>
<td>The type of the conversation message.</td>
<td>Valid values are: ORA_SVC_INBOUND, ORA_SVC_OUTBOUND, ORA_SVC_NOTE, ORA_SVC_SYSTEM_REPLY, ORA_SVC_SYSTEM_NOTE, ORA_SVC_INTERNAL_COLLABORATION.</td>
<td>Required</td>
<td>Not Required</td>
<td>Not Required</td>
</tr>
<tr>
<td>MessageContent</td>
<td>The content of the message.</td>
<td>It must by passes in base 64 encoded value.</td>
<td>Required</td>
<td>Not Required</td>
<td>Not Required</td>
</tr>
<tr>
<td>InboundStatusCd</td>
<td>The status of the message if the conversation message is an inbound message.</td>
<td>Valid values are: ORA_SVC_NEW, ORA_SVC_REPLIED.</td>
<td>Not Required. If not passed, it will be defaulted to ORA_SVC_NEW.</td>
<td>Not Required</td>
<td>Not Required</td>
</tr>
</tbody>
</table>

You can view the Conversation Message object along with all its child objects and attributes in the Manage Import Objects page of the Import Management flow. You can find attribute information like type, length, description, and so on, on this page.

**Create the Source CSV File**

You include the data that you want to import into CX Sales and B2B Service in a source CSV file.
You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator > Tools > Import Management > Import Objects.
2. Select the Conversation Message object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

**Note:** For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.

### Create the Import Activity

After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Conversation Message from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
   - You would see that the source and target attributes are automatically mapped in the Map Fields page. Review and edit the mappings if required.
5. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
6. Review the import details on the Review and Submit page, and click Submit when you're ready.

### Review the Import Results

Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed. You can drill down on the import activity to go to the Import Status page which provides the status details of the import activity.

**Related Topics**

- Potential Issues When Opening CSV Files in Excel
- How You Use Alternate Keys to Import Records
- Import Data

## Import Your Conversation Message Recipient Data

You can use Import Management to create, update, or delete Conversation Message Recipient records.

To import Conversation Message Recipient records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes

To import your Conversation Message Recipient data into Oracle Applications Cloud, you need to populate a CSV file with your source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

- Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
- Ensure prerequisite setups are done, if applicable.
- Understand your options for uniquely identifying the records.
- Identify the target object attributes that are required in the CSV file for a successful import.
- Ensure parent records exist before importing child records.

Before You Start

You must do some basic checks before starting your import. For example, make sure that:

- You have completed all the prerequisites for importing each attribute in your source data.
- You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records

All records must be unique in the application. If you’re creating records, then you can provide an easily understandable public unique identifier. These are, usually, denoted with ‘Number’ and visible in the business object’s UI. PUID attributes are usually named <object> Number. If you’re updating a record with a Number attribute, then use the Number attribute to identify the record. For more information about public unique identifiers, see the topic “How You Use Alternate Keys to Import Records” in Related Topics section.

Required Attributes and Validations for Conversation Message Recipient Object

To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure that you provide valid values for the attributes. This table lists the required attributes for importing new Conversation Message Recipient records, required attributes for updating Conversation Message Recipient records, prerequisite setup tasks for the attributes, and specific validations, if any, for Conversation Message Recipient import:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/ Import Validations</th>
<th>Creating a Conversation Message Recipient Record</th>
<th>Updating an Existing Conversation Message Recipient Record</th>
<th>Deleting an Existing Conversation Message Recipient Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>MessagesId</td>
<td>The unique identifier of the message.</td>
<td>Must be a valid Conversation Message Identifier.</td>
<td>Conditionally Required. Provide value if the MessagesNumber isn't provided.</td>
<td>Not Required</td>
<td>Not Required</td>
</tr>
<tr>
<td>Attribute</td>
<td>Description</td>
<td>Prerequisite Setup Task/ Import Validations</td>
<td>Creating a Conversation Message Recipient Record</td>
<td>Updating an Existing Conversation Message Recipient Record</td>
<td>Deleting an Existing Conversation Message Recipient Record</td>
</tr>
<tr>
<td>----------------------</td>
<td>------------------------------</td>
<td>---------------------------------------------</td>
<td>--------------------------------------------------</td>
<td>----------------------------------------------------------</td>
<td>----------------------------------------------------------</td>
</tr>
<tr>
<td>MessagesNumber</td>
<td>The public unique identifier of the message.</td>
<td>Must be a valid Conversation Message PUID.</td>
<td>Conditionally Required. Provide value if the MessagesId isn't provided.</td>
<td>Not Required</td>
<td>Not Required</td>
</tr>
<tr>
<td>RecipientId</td>
<td>The unique identifier of the message recipient record.</td>
<td>Must be a valid RecipientId when updating a message recipient.</td>
<td>Not Required</td>
<td>Conditionally Required. Provide value if the RecipientNumber isn't provided.</td>
<td>Conditionally Required. Provide value if the RecipientId isn't provided.</td>
</tr>
<tr>
<td>RecipientNumber</td>
<td>The public unique identifier of the message recipient record.</td>
<td>Must be a valid RecipientNumber when updating a message recipient.</td>
<td>Not Required</td>
<td>Conditionally Required. Provide value if the RecipientId isn't provided.</td>
<td>Conditionally Required. Provide value if the RecipientId isn't provided.</td>
</tr>
<tr>
<td>RecipientPartyId</td>
<td>The party identifier of the message recipient.</td>
<td>Must be a valid party identifier.</td>
<td>Not Required</td>
<td>Not Required</td>
<td>Not Required</td>
</tr>
<tr>
<td>RecipientPartyNumber</td>
<td>The public unique identifier of the message recipient.</td>
<td>Must be a valid Party PUID.</td>
<td>Not Required</td>
<td>Not Required</td>
<td>Not Required</td>
</tr>
<tr>
<td>RecipientTypeCd</td>
<td>The type of the message recipient, such as TO, CC, BCC.</td>
<td>Valid values are: ORA_SVC_BCC, ORA_SVC_CC, ORA_SVC_FROM, ORA_SVC_TO.</td>
<td>Not Required. If not passed, it will be defaulted to ORA_SVC_TO.</td>
<td>Not Required</td>
<td>Not Required</td>
</tr>
<tr>
<td>FreeFormAddress</td>
<td>The free form address of the recipient such as email address.</td>
<td>None</td>
<td>Not Required. Recommend to pass one of RecipientPartyId, RecipientPartyNumber, or FreeFormAddress.</td>
<td>Not Required</td>
<td>Not Required</td>
</tr>
</tbody>
</table>

You can view the Conversation Message Recipient object and its attributes in the Manage Import Objects page of the Import Management flow. You can find attribute information like type, length, description, and so on, on this page.

Create the Source CSV File
You include the data that you want to import into CX Sales and B2B Service in a source CSV file.
You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to **Navigator > Tools > Import Management > Import Objects**.
2. Select the **Conversation Message Recipient** object in the table and click **Download**.

You can now edit the downloaded file and provide valid values for the required attributes.

**Note:** For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.

### Create the Import Activity

After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to **Navigator > Tools > Import Management > Import Queue**.
2. Click **Create Import Activity** in the Manage Imports page.
3. In the **Enter Import Options** page, provide a name for the import activity, and select Conversation Message Recipient from the Object drop-down list.
4. Select the CSV file in the **File Name** field, and click **Next**.
   - You would see that the source and target attributes are automatically mapped in the **Map Fields** page. Review and edit the mappings if required.
5. Check the file for unmapped columns or data format issues by clicking **Validate Data**. Click **Next**.
6. Review the import details on the **Review and Submit** page, and click **Submit** when you're ready.

### Review the Import Results

Check if your import succeeded on the **Manage Imports** page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to **Navigator > Tools > Import Management > Import Queue**.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the **Status** column for the import activity. The import is successful if the status displays as **Completed**.
   - You can drill down on the import activity to go to the **Import Status** page which provides the status details of the import activity.

**Related Topics**
- Potential Issues When Opening CSV Files in Excel
- How You Use Alternate Keys to Import Records
- Import Data

### Import Your Conversation Reference Data

You can use Import Management to create, update, or delete Conversation Reference records. To import Conversation Reference records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes

To import your Conversation Reference data into Oracle Applications Cloud, you need to populate a CSV file with your source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

- Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
- Ensure prerequisite setups are done, if applicable.
- Understand your options for uniquely identifying the records.
- Identify the target object attributes that are required in the CSV file for a successful import.
- Ensure parent records exist before importing child records.

Before You Start

You must do some basic checks before starting your import. For example, make sure that:

- You have completed all the prerequisites for importing each attribute in your source data.
- Ensure parent records exist before importing child records.

Select a Unique Identifier for Your Records

All records must be unique in the application. If you’re creating records, then you can provide an easily understandable public unique identifier. These are, usually, denoted with 'Number' and visible in the business object’s UI. PUID attributes are usually named <object> Number. If you're updating a record with a Number attribute, then use the Number attribute to identify the record. For more information about public unique identifiers, see the topic "How You Use Alternate Keys to Import Records" in Related Topics section.

Required Attributes and Validations for Conversation Reference Object

To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure that you provide valid values for the attributes. This table lists the required attributes for importing new Conversation Reference records, required attributes for updating Conversation Reference records, prerequisite setup tasks for the attributes, and specific validations, if any, for Conversation Reference import:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/ Import Validations</th>
<th>Creating a Conversation Reference Record</th>
<th>Updating an Existing Conversation Reference Record</th>
<th>Deleting an Existing Conversation Reference Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>ReferenceId</td>
<td>The unique identifier of the conversation reference.</td>
<td>Must be a valid ReferenceId when updating a conversation reference.</td>
<td>Not Required</td>
<td>Conditionally Required. Provide value if the ReferenceNumber isn't provided.</td>
<td>Conditionally Required. Provide value if the ReferenceNumber isn't provided.</td>
</tr>
<tr>
<td>ReferenceNumber</td>
<td>The public unique identifier of the</td>
<td>Must be a valid ReferenceNumber when updating</td>
<td>Not Required</td>
<td>Conditionally Required. Provide value if the</td>
<td>Conditionally Required. Provide value if the</td>
</tr>
</tbody>
</table>

332
## Create the Source CSV File

You include the data that you want to import into CX Sales and B2B Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to **Navigator > Tools > Import Management > Import Objects**.
2. Select the **Conversation Reference** object in the table and click **Download**.
You can now edit the downloaded file and provide valid values for the required attributes.

**Note:** For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.

### Create the Import Activity

After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to **Navigator > Tools > Import Management > Import Queue**.
2. Click **Create Import Activity** in the **Manage Imports** page.
3. In the **Enter Import Options** page, provide a name for the import activity, and select Conversation Reference from the **Object** drop-down list.
4. Select the CSV file in the **File Name** field, and click **Next**.
   
   You would see that the source and target attributes are automatically mapped in the **Map Fields** page. Review and edit the mappings if required.
5. Check the file for unmapped columns or data format issues by clicking **Validate Data**. Click **Next**.
6. Review the import details on the **Review and Submit** page, and click **Submit** when you're ready.

### Review the Import Results

Check if your import succeeded on the **Manage Imports** page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to **Navigator > Tools > Import Management > Import Queue**.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the **Status** column for the import activity. The import is successful if the status displays as **Completed**.
   
   You can drill down on the import activity to go to the **Import Status** page which provides the status details of the import activity.

**Related Topics**

- Potential Issues When Opening CSV Files in Excel
- How You Use Alternate Keys to Import Records
- Import Data

### Import Country Structure Data

#### Import Your Country Structure Data

You can use Import Management to create Country Structure records. It is recommended you use Import Management only if you're importing high-volume third-party data.

If you're importing licensed data from one of our vendors, then you can create the country structure by navigating to **Setup and Maintenance > Manage Geographies Task** page.
To import Country Structure records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

**How You Map Your Source Data to Target Object Attributes**

To import your Country Structure data into Oracle Applications Cloud, you need to populate a CSV file with your source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

- Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
- Identify the target object attributes that are required in the CSV file for a successful import.

**Required Attributes and Validations for Country Structure Object**

To import data successfully into Oracle Applications Cloud, your CSV file must include values for the required attributes. This table lists the required attributes for importing new Country Structure records, prerequisite setup tasks for the attributes, and specific validations, if any, for Country Structure import:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/ Import Validations</th>
<th>Creating a Country Structure Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>CountryCode</td>
<td>The code for the country for which the country structure is applicable.</td>
<td>The GeographyType has to be “Country” and the LevelNumber has to be “1” for a country.</td>
<td>Yes</td>
</tr>
<tr>
<td></td>
<td></td>
<td>You can’t pass different country codes when importing a record.</td>
<td></td>
</tr>
<tr>
<td>GeographyType</td>
<td>Geopolitical divisions such as Country, State, City, and so on. For example, for US the different geography types would be State, County, City, and Postal Code. For India, the different geography types would be State, District, City, and Postal Code. For Mexico, it would be State, Municipality, Locality, and Postal Code.</td>
<td>The country has to be present.</td>
<td>Yes</td>
</tr>
<tr>
<td>LevelNumber</td>
<td>You need these to create parent-child relationships between geography types for your country. The values can be 1, 2, 3, and so on.</td>
<td>To define a country, you must specify the LevelNumber as 1.</td>
<td>Yes</td>
</tr>
</tbody>
</table>

You can view the Country Structure object and its attributes in the Manage Import Objects page of the Import Management flow. You can find attribute information like type, length, description, and so on, on the Manage Import Objects page. You can view the list of valid values for country codes in the UI by navigating to the Manage Geographies task and searching with % as the Country Code value. For more information on Geographies, see Overview of Geographies, Geographic Entities, and Locations in the Related Topics section.
Understanding Import and Export Management for CX
Sales and B2B Service

Chapter 8
Import Your Data

Create the Source CSV File
You include the data that you want to import into Oracle Applications Cloud in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator > Tools > Import Management > Import Objects.
2. Select the Country Structure object in the table and click Download.

You can now edit the downloaded file and provide values for the required attributes.

Note: For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Country Structure from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review and edit the mappings if required.
6. Click Validate Data to check the file for unmapped columns or data format issues. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed. You can drill down on the import activity to go to the Import Status page which provides the status details of the import activity. Here, you can download and review the successfully imported user data records, the mapping details used for import activity, and the data file that you provided in CSV format.

Note:
Note the following:

- The import job will fail if you try to load any already existing country structure. Delete the existing country structure in the UI in Manage Geographies Tasks and import again.
- You can't load additional lower geography structure levels for an existing country structure while importing geography country structure. You can add additional geography levels in the UI for an existing country structure in the Manage Geographies task page.
Example of Importing Country Structure Data

You use the country structure of a country to define which geography types are part of the country and how the geography types are hierarchically related within the country.

For example, you can create geography types called State, City, and Postal Code. Then you can rank the State geography type as the highest level within the country, the City as the second level, and the Postal Code as the lowest level within the country structure.

To add a country structure using import management, your source file must contain information about the country to which the country structure belongs. You can view the list of valid values for country codes in the UI by navigating to the Manage Geographies task and searching with % as the Country Code value. You also need to specify the level at which the geography types need to be placed. By default, all countries are at Level 1. You create the country structure by increasing the level number as you go down the country structure. You place the geography types such as states, provinces, and so on at Level 2, districts or counties at Level 3, and so on. To add a country structure, your source file must include the values that let the import process identify the existing records.

Sample Input CSV File
You include the data that you want to import into CX Sales and B2B Service in a source CSV file. Here is a sample input CSV file for country as US.

<table>
<thead>
<tr>
<th>CountryCode</th>
<th>LevelNumber</th>
<th>GeographyType</th>
</tr>
</thead>
<tbody>
<tr>
<td>US</td>
<td>1</td>
<td>COUNTRY</td>
</tr>
<tr>
<td>US</td>
<td>2</td>
<td>STATE</td>
</tr>
<tr>
<td>US</td>
<td>3</td>
<td>COUNTY</td>
</tr>
<tr>
<td>US</td>
<td>4</td>
<td>CITY</td>
</tr>
<tr>
<td>US</td>
<td>5</td>
<td>POSTAL CODE</td>
</tr>
</tbody>
</table>

Here is another input CSV file for importing the country structure for India.

<table>
<thead>
<tr>
<th>CountryCode</th>
<th>LevelNumber</th>
<th>GeographyType</th>
</tr>
</thead>
<tbody>
<tr>
<td>IN</td>
<td>1</td>
<td>COUNTRY</td>
</tr>
</tbody>
</table>
### Import Your Data

In case you want to import the country structure for Mexico, your input CSV file would look like this:

<table>
<thead>
<tr>
<th>CountryCode</th>
<th>LevelNumber</th>
<th>GeographyType</th>
</tr>
</thead>
<tbody>
<tr>
<td>IN</td>
<td>2</td>
<td>STATE</td>
</tr>
<tr>
<td>IN</td>
<td>3</td>
<td>DISTRICT</td>
</tr>
<tr>
<td>IN</td>
<td>4</td>
<td>CITY</td>
</tr>
<tr>
<td>IN</td>
<td>5</td>
<td>POSTAL CODE</td>
</tr>
</tbody>
</table>

In this example, we are importing the Country Structure for US. You must create a source file (CSV) file with the attributes as shown in this table and import it using Import Management.

<table>
<thead>
<tr>
<th>Attribute Name</th>
<th>Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>CountryCode</td>
<td>US</td>
<td>The code for the country for which the country structure is applicable.</td>
</tr>
<tr>
<td>LevelNumber</td>
<td>1</td>
<td>The level number of the geography in the hierarchy. For example, Country is at Level 1 (Top level) and State (California) is at Level 2. You need these to create parent-child relationships between geography types for your country.</td>
</tr>
<tr>
<td>GeographyType</td>
<td>COUNTRY</td>
<td>Geopolitical divisions such as Country, State, City, and so on. For example, for US the different geography types would be State, County, City, and Postal Code. For India, the different geography types would be State, District, City, and Postal Code. For Mexico,</td>
</tr>
</tbody>
</table>
Oracle CX
Understanding Import and Export Management for CX
Sales and B2B Service

Chapter 8
Import Your Data

Create an import activity to import the information. To create an import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Country Structure from the Object drop-down list.

   **Note:** In the Advanced Options section, the option Enable High-Volume Import is selected by default. This mode is designed to import millions of records at once.

4. Select the CSV file in the File Name field, and click Next.
5. The source and target attributes are automatically mapped in the Map Fields page. Review and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit.

Import Your Deal Product Data

You can use Import Management to create, update, or delete your deal product data.

To import Deal Product records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (.csv) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes

To import your Deal Product data into Oracle Applications Cloud, you need to populate a CSV file with your source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the .CSV file for data import:

- Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
- Ensure prerequisite steps are complete, such as understanding what attributes are required for importing your objects.
- Understand your options for uniquely identifying the records.
- Ensure parent records exist before importing child records.
- Identify the target object attributes that are required in the .CSV file for a successful import.
Before You Start

You must do some basic checks before starting your import. For example, make sure that:

- You have completed all the prerequisites for importing each attribute in your source data.
- You have all parent records in place before importing child records. For example, when importing the address of an account, ensure the account exists.

Select a Unique Identifier for Your Records

To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the import process to uniquely identify the records. The file import process uses the attribute values to automatically map your source data to the target object attributes in Oracle Applications Cloud.

The preferred options to uniquely identify an object record are as follows:

- **Internal ID:** If you're identifying a record that already exists in Oracle Applications Cloud, then you can use the internal ID of the record, a system-generated unique identifier. Attributes with "id" in the attribute name are typically internal IDs. You can determine the internal ID of a record by exporting Oracle Applications Cloud object data, or by doing a transactional database query. Using an internal ID typically provides better performance and reduces the import duration. For the Deal Product object, this attribute is DealProdId.

- **Public unique identifiers:** If you're creating new records, then you can provide a user-friendly public unique identifier (attributes denoted with 'Number' and usually visible in the business object's UI). If you update a record for which you have previously provided a Number attribute, or for which a Number attribute is visible in the object's UI, you can use the Number attribute to identify the record. For the Deal Product object, the attribute is DealProdNumber.

Review Required Attributes and Validations for Deal Product Object

To import data successfully into Oracle Applications Cloud, your .CSV file must include the required attributes. Ensure that you provide valid values for the attributes.

The following table lists the required attributes for importing new Deal Product records, required attributes for updating Deal Product records, prerequisite setup tasks for the attributes, and specific validations, if any, for Deal Product import:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Data Type</th>
<th>Data Length</th>
<th>Prerequisite Setup Task/Import Validations</th>
<th>Creating a Deal Product record</th>
<th>Updating an Existing Deal Product record</th>
</tr>
</thead>
<tbody>
<tr>
<td>DealNumber</td>
<td>The public unique identifier value for the deal.</td>
<td>Text</td>
<td>30</td>
<td>You can obtain the Deal Number for an existing deal registration from the Deal Registration work area.</td>
<td>Conditionally required</td>
<td>Conditionally required</td>
</tr>
<tr>
<td>DealId</td>
<td>The unique ID for the existing deal record in the destination table.</td>
<td>Number</td>
<td>18</td>
<td>The deal must exist.</td>
<td>Conditionally required</td>
<td>Conditionally required</td>
</tr>
</tbody>
</table>

<p>| DealId    | Provide either the DealId or the DealNumber to identify the deal. | Provide either the DealId or the DealNumber to identify the deal. |</p>
<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Data Type</th>
<th>Data Length</th>
<th>Prerequisite Setup Task/Import Validations</th>
<th>Creating a Deal Product record</th>
<th>Updating an Existing Deal Product record</th>
</tr>
</thead>
<tbody>
<tr>
<td>DealProdNumber</td>
<td>The relationship between the deal registration and the deal product.</td>
<td>Text</td>
<td>30</td>
<td>You can obtain the DealProductNumber for an existing deal registration product from the Deal Registration work area.</td>
<td>DealNumber to identify the deal.</td>
<td>DealNumber to identify the deal.</td>
</tr>
<tr>
<td>ProductGroupNumber</td>
<td>The public unique identifier value for the deal registration product group.</td>
<td></td>
<td></td>
<td>You can obtain the ItemNumber for an existing deal registration product from the Deal Registration work area.</td>
<td>Conditionally required</td>
<td>Conditionally required</td>
</tr>
<tr>
<td>DealProdId</td>
<td>The unique ID for the existing deal product record in the destination table.</td>
<td>Number</td>
<td>18</td>
<td>The deal product must exist.</td>
<td>Not required</td>
<td>Conditionally required</td>
</tr>
<tr>
<td>ItemNumber</td>
<td>The public unique identifier value for the deal registration product item.</td>
<td>Text</td>
<td>30</td>
<td>You can obtain the ItemNumber for an existing deal registration product from the Deal Registration work area.</td>
<td>Conditionally required</td>
<td>Conditionally required</td>
</tr>
<tr>
<td>InventoryItemId</td>
<td>The unique ID for the existing sales catalog product</td>
<td>Number</td>
<td>18</td>
<td>You can determine the InventoryItemId by exporting the</td>
<td>Conditionally required</td>
<td>Conditionally required</td>
</tr>
<tr>
<td>Attribute</td>
<td>Description</td>
<td>Data Type</td>
<td>Data Length</td>
<td>Prerequisite Setup Task/Import Validations</td>
<td>Creating a Deal Product record</td>
<td>Updating an Existing Deal Product record</td>
</tr>
<tr>
<td>----------------</td>
<td>-----------------------------------------------------------------------------</td>
<td>-----------</td>
<td>-------------</td>
<td>-----------------------------------------------------------------------------------------------------------</td>
<td>-------------------------------------------------------------------------------------------------</td>
<td>------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>(item) record in the destination table.</td>
<td></td>
<td></td>
<td></td>
<td>Product Group Products object. Navigate to the following in the Setup and Maintenance work area:</td>
<td>When you import a new deal registration product item (as opposed to a product group), then you must provide either the ItemNumber or the InventoryItemId.</td>
<td>When you update deal registration product item (as opposed to a product group), then you must provide either ItemNumber or InventoryItemId.</td>
</tr>
<tr>
<td>ProductGroupId</td>
<td>Unique Product Group ID defined in sales product catalog.</td>
<td>Number</td>
<td>18</td>
<td>You can determine the ProdGroupId by exporting the Product Group Products object. Navigate to the following in the Setup and Maintenance work area:</td>
<td>Conditionally required</td>
<td>Conditionally required</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>• Offering: Sales</td>
<td>When you import a new deal registration product item (as opposed to a product group), then you must provide either the ItemNumber or the InventoryItemId.</td>
<td>When you update deal registration product item (as opposed to a product group), then you must provide either ItemNumber or InventoryItemId.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>• Functional Area: Data Import and Export</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>• Task: Schedule Export Processes</td>
<td></td>
<td></td>
</tr>
<tr>
<td>UomCode</td>
<td>Specifies the Unit of measure</td>
<td>Number</td>
<td>None</td>
<td>You can determine the units of measure. Navigate to the following in the Setup and Maintenance work area:</td>
<td>Conditionally required</td>
<td>Not required</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>• Offering: Financials</td>
<td>A value is required when you import a new deal registration that's associated with product (Items).</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>• Functional Area: Items</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>• Task: Manage Units of</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
### Import Your Data

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Data Type</th>
<th>Data Length</th>
<th>Prerequisite Setup Task/Import Validations</th>
<th>Creating a Deal Product record</th>
<th>Updating an Existing Deal Product record</th>
</tr>
</thead>
<tbody>
<tr>
<td>RegisteredPrice</td>
<td>The value for the price of the product item associated to the deal registration.</td>
<td>Number</td>
<td>None</td>
<td>You can obtain the RegisteredPrice for an existing deal registration using the Deal Registration work area.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
</tbody>
</table>
| InvOrgId    | The unique ID for the existing product item organization's record in the destination table. | Number    | 18          | You can determine the InvOrgId by exporting the Product Group Products object. Navigate to the following in the Setup and Maintenance work area:  
  - Offering: Sales  
  - Functional Area: Data Import and Export  
  - Task: Schedule Export Processes | Conditionally required | Conditionally required |

You can view the Deal Product object along with all its child objects and attributes in the Manage Import Objects page of the Import Management flow. You can find attribute information like type, length, description, and so on, on this page.

### Create the Source CSV File

You include the data that you want to import into CX Sales and B2B Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator > Tools > Import Management > Import Objects.
2. Select the Deal Product object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

**Note:** For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.
Create the Import Activity
To import data into Oracle Applications Cloud, you need to create an import activity and provide the CSV file as an input to the activity.

To create an import activity, do the following:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Deal Product from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you’re ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed. You can drill down on the import activity to go to the Import Status page which provides the status details of the import activity.

Related Topics
- Import Data

Import Your Deal Registration Data
You can use import management to create or update Deal Registration records.

To import Deal Registration records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes
To import your Deal Registration data into Oracle Applications Cloud, you need to populate a CSV file with your source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

- Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
• Ensure prerequisite setups are done, if applicable.
• Understand your options for uniquely identifying the records.
• Ensure parent records exist before importing child records.
• Identify the target object attributes that are required in the CSV file for a successful import.

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.
• You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the import process to uniquely identify the records. The file import process uses the attribute values to automatically map your source data to the target object attributes in Oracle Applications Cloud.

The preferred options to uniquely identify an object record are as follows:

• Internal ID: If you're identifying a record that already exists in Oracle Applications Cloud, then you can use the internal ID of the record, a system-generated unique identifier Attributes with "id" in the attribute name are typically internal IDs. Use this option only if you're updating Deal Registrations. You can determine the internal ID of a record by exporting Oracle Applications Cloud object data, or by doing a transactional database query. Using an internal ID typically provides better performance and reduces the import duration. For the Deal Registration object, the attribute is DealID.

• Public unique identifiers: If you're creating new records, then you can provide a user-friendly public unique identifier (attributes denoted with 'Number' and usually visible in the business object's UI). If you update a record for which you have previously provided a Number attribute, or for which a Number attribute is visible in the object's UI, you can use the Number attribute to identify the record. For the Deal Registration object, the attributes are:
  ◦ AccountPartyNumber
  ◦ ContactPartyNumber
  ◦ OwnerPartyNumber
  ◦ MatchedAccountPartyNumber
  ◦ MatchedContactPartyNumber
  ◦ OptyNumber
  ◦ LeadNumber
  ◦ PartnerCompanyNumber
  ◦ ProgramEnrollmentNumber
  ◦ DealNumber
## Required Attributes and Validations for Deal Registration Object

To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure that you provide valid values for the attributes. This table lists the required attributes for importing new Deal Registration records, required attributes for updating Deal Registration records, prerequisite setup tasks for the attributes, and specific validations, if any, for Deal Registration import:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/ Import Validations</th>
<th>Creating a Deal Registration Record</th>
<th>Updating an Existing Deal Registration Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>AccountPartyNumber</td>
<td>The public unique identifier of account party on the deal registration</td>
<td>None</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td>ContactPartyNumber</td>
<td>The public unique identifier of contact party on the deal registration</td>
<td>None</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td>OwnerPartyNumber</td>
<td>The public unique identifier of owner party on the deal registration</td>
<td>None</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td>MatchedAccountPartyNumber</td>
<td>The public unique identifier of the matched account party on the deal registration</td>
<td>The deal registration should have the status “Approved”.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>MatchedContactPartyNumber</td>
<td>The public unique identifier of the matched contact party on the deal registration</td>
<td>The deal registration should have the status “Approved”.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>OptyNumber</td>
<td>The public unique identifier of the opportunity associated with the deal registration</td>
<td>The deal registration should have the status “Approved”.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>LeadNumber</td>
<td>The public unique identifier of the lead associated with the deal registration.</td>
<td>The deal registration should have an associated lead.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>PartnerCompanyNumber</td>
<td>The unique identifier of the partner associated with the deal registration</td>
<td>None</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td>ProgramEnrollmentNumber</td>
<td>The unique identifier of the partner program enrollment in the context of the deal registration</td>
<td>The partner associated with the deal registration should be enrolled in a program.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>DealID</td>
<td>The unique identifier of the deal registration.</td>
<td>None</td>
<td>Required</td>
<td>Required</td>
</tr>
</tbody>
</table>
Create the Source CSV File

You include the data that you want to import into CX Sales and B2B Service in a source CSV file. You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator > Tools > Import Management > Import Objects.
2. Select the Deal Registration object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

**Note:** For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity

After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Deal Registration from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results

Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed. You can drill down on the import activity to go to the Import Status page which provides the status details of the import activity.
Import Your Deal Resource Data

You can use the Import Management to create, update, or delete deal resource records.

To import Deal Resource records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (.csv) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes

To import your Deal Resource data into Oracle Applications Cloud, you must populate a CSV file with your source data and map that source data to target object attributes in Oracle Applications Cloud.

You must do the following before creating the .CSV file for data import:

- Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
- Ensure prerequisite steps are complete, such as understanding what attributes are required for importing your objects.
- Understand your options for uniquely identifying the records.
- Ensure parent records exist before importing child records.
- Identify the target object attributes that are required in the .CSV file for a successful import.

Before You Begin

You must do some basic checks before starting your import. For example, make sure that:

- You have completed all the prerequisites for importing each attribute in your source data.
- You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records

To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the import process to uniquely identify the records. The file import process uses the attribute values to automatically map your source data to the target object attributes in Oracle Applications Cloud.

The preferred options to uniquely identify an object record are as follows:

- **Internal ID**: If you're identifying a record that already exists in Oracle Applications Cloud, then you can use the internal ID of the record, a system-generated unique identifier. Attributes with "id" in the attribute name are typically internal IDs. You can determine the internal ID of a record by exporting Oracle Applications...
Oracle CX
Understanding Import and Export Management for CX
Sales and B2B Service

Chapter 8
Import Your Data

Cloud object data, or by doing a transactional database query. Using an internal ID typically provides better
performance and reduces the import duration. For the Deal Resource object, this attribute is DealResourceCld.

- **Public unique identifiers**: If you’re creating records, then you can provide a user-friendly public unique
  identifier (attributes denoted with ‘Number’ and usually visible in the business object’s UI). If you update a
  record for which you have previously provided a Number attribute, or for which a Number attribute is visible
  in the object’s UI, you can use the Number attribute to identify the record. For the Deal Resource object, the
  attribute is DealResourceNumber.

### Required Attributes and Validations for Deal Resource Object

To import data successfully into Oracle Applications Cloud, your .CSV file must include the required attributes. Ensure
that you provide valid values for the attributes.

The following table lists the required attributes for importing new Deal Resource records, required attributes for
updating Deal Resource records, prerequisite setup tasks for the attributes, and specific validations, if any, forDeal
Resource import:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Data Type</th>
<th>Data Length</th>
<th>Prerequisite Setup Task/Import Validations</th>
<th>Creating a Deal Resource record</th>
<th>Updating an Existing Deal Resource record</th>
</tr>
</thead>
<tbody>
<tr>
<td>DealId</td>
<td>The unique ID for the existing deal record in the destination table.</td>
<td>Number</td>
<td>18</td>
<td>The deal must exist.</td>
<td>Conditionally required</td>
<td>Conditionally required</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Provide either the DealId or the DealNumber to identify the deal.</td>
<td></td>
<td>Provide either the DealId or the DealNumber to identify the deal.</td>
</tr>
<tr>
<td>DealNumber</td>
<td>The public unique identifier value for the deal.</td>
<td>Text</td>
<td>30</td>
<td>You can obtain the Deal Number for an existing deal registration from the Deal Registration work area.</td>
<td>Conditionally required</td>
<td>Conditionally required</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Provide either the DealId or the DealNumber to identify the deal.</td>
<td></td>
<td>Provide either the DealId or the DealNumber to identify the deal.</td>
</tr>
<tr>
<td>DealResourceNumb</td>
<td>The unique identifier for the relationship between the resource and the deal registration.</td>
<td>Number</td>
<td>18</td>
<td>You can obtain the DealResourceNumb for an existing deal registration product from the Deal Registration work area.</td>
<td>Required</td>
<td>Conditionally required</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Provide either the DealResourceCld or the DealResourceNumber to identify the resource.</td>
<td></td>
<td>Provide either the DealResourceCld or the DealResourceNumber to identify the resource.</td>
</tr>
<tr>
<td>DealResourceCld</td>
<td>The unique ID for the existing deal product record in the destination table.</td>
<td>Number</td>
<td>18</td>
<td>The deal resource must exist.</td>
<td>Not required</td>
<td>Conditionally required</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>You must provide either the DealResourceCld or the DealResourceNumber</td>
<td></td>
<td>Provide either the DealResourceCld or the DealResourceNumber to identify the resource.</td>
</tr>
</tbody>
</table>
### Attribute | Description | Data Type | Data Length | Prerequisite Setup Task/Import Validations | Creating a Deal Resource record | Updating an Existing Deal Resource record
--- | --- | --- | --- | --- | --- | ---

**ResourcePartyNumber**  
The public unique identifier value for the resource party record.  
Number | 18 | You can obtain the ResourcePartyNumber for a resource associated with an existing deal registration from the Deal Registration work area. |  | Conditionally required |  
You must provide one of the following to identify the resource:  
- ResourcePartyNumber  
- ResourcePartyId  

**ResourcePartyId**  
The unique ID for the existing deal resource record in the destination table.  
Number | 18 | The resource must exist. |  | Conditionally required |  
Provide either the ResourcePartyNumber or the ResourcePartyId to identify the resource.  

---

You can view the Deal Resource object along with all its child objects and attributes in the Manage Import Objects page of the Import Management flow. You can find attribute information like type, length, description, and so on, on this page.

### Create the Source CSV File

You include the data that you want to import into CX Sales and B2B Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to **Navigator > Tools > Import Management > Import Objects**.
2. Select the **Deal Resource** object in the table and click **Download**.

You can now edit the downloaded file and provide valid values for the required attributes.

**Note:** For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.
Create the Import Activity

After you have the CSV file ready, create an import activity. To create an import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Deal Resource from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results

Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed. You can drill down on the import activity to go to the Import Status page which provides the status details of the import activity.

Related Topics

- Potential Issues When Opening CSV Files in Excel
- Import Data

Import Your Eligibility Rule Data

You can use the Import Management to create or update Eligibility Rule records.

To import Eligibility Rule records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (.csv) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes

To import your Eligibility Rule data into Oracle Applications Cloud, you need to populate a CSV file with your source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the .CSV file for data import:

- Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
Before You Start

You must do some basic checks before starting your import. For example, make sure that:

- You have completed all the prerequisites for importing each attribute in your source data.
- You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records

To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the import process to uniquely identify the records. The file import process uses the attribute values to automatically map your source data to the target object attributes in Oracle Applications Cloud.

The preferred options for uniquely identifying an object record are as follows:

- **Internal ID:** If you’re identifying a record that already exists in Oracle Applications Cloud, then you can use the internal ID of the record, a system-generated unique identifier Attributes with "id" in the attribute name are typically internal IDs. You can determine the internal ID of a record by exporting Oracle Applications Cloud object data, or by doing a transactional database query. Using an internal ID typically provides better performance and reduces the import duration. For the Eligibility Rule object, this attribute is EligibilityRuleId.

- **Public unique identifiers:** If you’re creating new records, then you can provide a user-friendly public unique identifier (attributes denoted with 'Number' and usually visible in the business object’s UI). If you update a record for which you have previously provided a Number attribute, or for which a Number attribute is visible in the object’s UI, you can use the Number attribute to identify the record. For the Eligibility Rule Item object, the attributes are ParPGReferenceNumber, ItemNumber, and GeographyCode.

Required Attributes and Validations for Eligibility Rule Object

To import data successfully into Oracle Applications Cloud, your .CSV file must include the required attributes. Ensure that you provide valid values for the attributes.

The following table lists the required attributes for importing new Eligibility Rule records, required attributes for updating Eligibility Rule records, prerequisite setup tasks for the attributes, and specific validations, if any, for Eligibility Rule import:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Data Type</th>
<th>Data Length</th>
<th>Prerequisite Setup Task/Import Validations</th>
<th>Creating a Eligibility Rule Record</th>
<th>Updating an Existing Eligibility Rule Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>EligibilityRuleId</td>
<td>Autogenerated Id to update the record.</td>
<td>Long</td>
<td>18</td>
<td>No validation</td>
<td>Not Required</td>
<td>Required</td>
</tr>
</tbody>
</table>
### Attribute Description Data Type Data Length Prerequisite Setup Task/ Import Validations Creating a Eligibility Rule Record Updating an Existing Eligibility Rule Record

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Data Type</th>
<th>Data Length</th>
<th>Prerequisite Setup Task/ Import Validations</th>
<th>Creating a Eligibility Rule Record</th>
<th>Updating an Existing Eligibility Rule Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>RuleType</td>
<td>This can have only two values - AVAILABLE and NOTAVAILABLE.</td>
<td>String</td>
<td>30</td>
<td>No validation</td>
<td>Required</td>
<td>Not Required</td>
</tr>
<tr>
<td>StartDate</td>
<td>The start date of the eligibility rule</td>
<td>Date Time</td>
<td></td>
<td>The StartDate can't be greater than the EndDate</td>
<td>Not Required</td>
<td>Not Required</td>
</tr>
<tr>
<td>EndDate</td>
<td>The end date of the eligibility rule</td>
<td>Date Time</td>
<td></td>
<td>No validation</td>
<td>Not Required</td>
<td>Not Required</td>
</tr>
<tr>
<td>ProductNumber</td>
<td>Product number against which this eligibility rule is created or updated</td>
<td>String</td>
<td>300</td>
<td>No validation</td>
<td>Required</td>
<td>Required</td>
</tr>
<tr>
<td>ProdGroupId</td>
<td>Required if creating a new eligibility rule using the Internal ID</td>
<td>Long</td>
<td>18</td>
<td>No validation</td>
<td>Required</td>
<td>Not Required</td>
</tr>
<tr>
<td>ParPGReferenceNumber</td>
<td>Required if creating or updating an existing eligibility rule using the PUID</td>
<td>String</td>
<td>50</td>
<td>No validation</td>
<td>Required</td>
<td>Required</td>
</tr>
<tr>
<td>InventoryItemId</td>
<td>Required if creating a new eligibility rule using the Internal ID</td>
<td>Long</td>
<td>18</td>
<td>No validation</td>
<td>Required</td>
<td>Not Required</td>
</tr>
<tr>
<td>InvOrgId</td>
<td>Required if creating a new eligibility rule using the Internal ID</td>
<td>Long</td>
<td>18</td>
<td>No validation</td>
<td>Required</td>
<td>Not Required</td>
</tr>
<tr>
<td>GeographyId</td>
<td>Required if creating a new eligibility rule using the Internal ID</td>
<td>Long</td>
<td>18</td>
<td>There can't be more than one eligibility rule for the same country.</td>
<td>Required</td>
<td>Not Required</td>
</tr>
<tr>
<td>CountryName</td>
<td>Specify value to update the country for an existing eligibility rule using the PUID.</td>
<td>String</td>
<td></td>
<td>No validation</td>
<td>Not Required</td>
<td>Not Required</td>
</tr>
</tbody>
</table>
Import Your Data

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Data Type</th>
<th>Data Length</th>
<th>Prerequisite Setup Task/Import Validations</th>
<th>Creating an Existing Eligibility Rule Record</th>
<th>Updating an Existing Eligibility Rule Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>GeographyCode</td>
<td>Required if creating or updating an existing eligibility rule using the PUID.</td>
<td>String</td>
<td></td>
<td>Required</td>
<td>Required</td>
<td>Required</td>
</tr>
</tbody>
</table>

You can view the Eligibility Rule object along with all its child objects and attributes in the Manage Import Objects page of the Import Management flow. You can find attribute information like type, length, description, and so on, on this page.

Create the Source CSV File

You include the data that you want to import into CX Sales and B2B Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator > Tools > Import Management > Import Objects.
2. Select the Eligibility Rule object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note: For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity

After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Eligibility Rule from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.
Review the Import Results

Check if your import succeeded on the **Manage Imports** page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to **Navigator > Tools > Import Management > Import Queue**.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the **Status** column for the import activity. The import is successful if the status displays as **Completed**. You can drill down on the import activity to go to the **Import Status** page which provides the status details of the import activity.

**Related Topics**
- Potential Issues When Opening CSV Files in Excel
- Import Data

Import Geography Data

### Import Your Geography Data

You can use Import Management to create Geography records. You can also add alternate name or code to existing geographies with import. For more information see Example of Importing Geography Data in the Related Topics section.

To import Geography records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

#### How You Map Your Source Data to Object Attributes

To import your Geography data into Oracle Applications Cloud, you must populate a .csv file with your source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

- Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
- Create Country Structure before importing Geography data. For information on how to create Country Structure, see Import Your Country Structure and Example of Importing Country Structure in Related Topics Section.
- Identify the target object attributes that are required in the CSV file for a successful import as mentioned in the table Required Attributes and Validations for the Geography Object below.
Before You Start
You must do some basic checks before starting your import. For example, make sure that:

- You have completed all the prerequisites for importing each attribute in your source data such as creating a country structure.

Required Attributes and Validations for the Geography Object
To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure that you provide values for the attributes. The following table lists the required attributes for importing new Geography records, prerequisite setup tasks for the attributes, and specific validations, if any, for Geography import:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/ Import Validations</th>
<th>Creating a Geography Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>CountryCode</td>
<td>The code of the country to which the geography belongs.</td>
<td>This is validated against the country structure to check if the structure is defined for this country.</td>
<td>Required</td>
</tr>
<tr>
<td>PrimaryGeographyName</td>
<td>The primary name of the geography.</td>
<td>This is validated against the name of country if geography type is 'Country' or LevelNumber is 1.</td>
<td>Required</td>
</tr>
<tr>
<td>RecordTypeCode</td>
<td>The record type code that represents the intent of the import data. The values are:</td>
<td>No Validation</td>
<td>Required</td>
</tr>
<tr>
<td></td>
<td>- 0 - indicates the geography that already exists in the base table.</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>- 1 - indicates the intent to create a new geography.</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>- 2 - indicates the intent to add an alternate identifying name or code to an existing geography.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>LevelNumber</td>
<td>The level number of the geography in the hierarchy. For example, Country is at Level 1 and State (California) is at Level 2.</td>
<td>The level should exist in the country structure.</td>
<td>Required</td>
</tr>
<tr>
<td>SourceID</td>
<td>The source ID for the geography, along with the parent source ID is used to identify the geography parent and child relationship within the source file data and the interface table data.</td>
<td>None</td>
<td>Required</td>
</tr>
<tr>
<td>ParentSourceID</td>
<td>The parent source ID for the geography, along with the source ID is used to identify the geography’s parent and child</td>
<td>None</td>
<td>Required</td>
</tr>
</tbody>
</table>
Understanding Import and Export Management for CX
Sales and B2B Service

Chapter 8
Import Your Data

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/ Import Validations</th>
<th>Creating a Geography Record</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td>relationship with records within the source file data. This should be null for the country record, as Country is at the top of the hierarchy.</td>
<td></td>
</tr>
</tbody>
</table>

You can view the Geography object and attributes in the Manage Import Objects page of the Import Management flow. You can find attribute information like type, length, description, and so on, on this Manage Import Objects page.

**Note:** Keep a note of the following:
- You can't update geographies via import.
- Before adding a new alternate name, make sure that the alternate name does not exist with the same value for any other geography name.
- You can enable high-volume import for the Geography import object in the Manage Import Objects page.
- PrimaryGeographyCodeType and PrimaryGeographyCode can't be added after PrimaryGeographyName is created via import. You must create them together. Alternatively, you can add primaryGeographyCodeType and PrimaryGeographyCode from the UI after the import is complete.

Create the Source CSV File

You include the data that you want to import into CX Sales and B2B Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to **Navigator** > **Tools** > **Import Management** > **Import Objects**.
2. Select the Geography object in the table and click **Download**.

You can now edit the downloaded file and provide valid values for the required attributes.

**Note:** For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity

After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to **Navigator** > **Tools** > **Import Management** > **Import Queue**.
2. Click **Create Import Activity** in the **Manage Imports** page.
3. In the **Enter Import Options** page, provide a name for the import activity, and select Geography from the **Object** drop-down list.
4. Select the CSV file in the **File Name** field, and click **Next**.
5. The source and target attributes are automatically mapped in the Map Fields page. Review and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed. You can drill down on the import activity to go to the Import Status page which provides the status details of the import activity.

Note: Geography names aren’t translatable and are always displayed in the same language in which they were loaded irrespective of the language of the signed in user. If you need different options of display, you can use the alternative names option.

Related Topics
- Potential Issues When Opening CSV Files in Excel
- Import Your Country Structure Data
- Import Data
- Example of Importing Country Structure Data
- Example of Importing Geography Data

Example of Importing Geography Data
This example demonstrates how to import data using Import Management. In this example, you have a source file containing geography data that you want to import into the application to make the geography data available for real time address validation and tax purposes.

A geography is any region with a boundary around it, regardless of its size. It might be a state, a country, a city, a county, or a ward.

Summary of the Tasks
You perform the following steps to create an import activity and activate the import:

1. Determine what information is in the source file.
2. Create and schedule the import activity.

Before You Start
1. You use the country structure of a country to define which geography types are part of the country. For more information about an example of importing a country structure, see the topic "Example of Importing Country Structure Data".
2. Ensure that Source ID values are unique for each row of data within a single import.
3. Ensure that all the parents of a child geography are included in your data file so that the child geography can be added. For example, if you originally imported US, CA, and San Francisco, and now you want to import the city of San Jose in CA, then your data file must include US, CA, and San Jose.

4. Check that your source data file has the correct values for the geography data that you have already loaded. For example, if your initial import included the value US for country and CA as state, and in a subsequent import you have California as a state, then your geography import creates two state records (CA and California) in the application data, with the US as the country parent.

**Determine the Information in the Source File**

The source geography data files must include a unique Source ID value for each row of data and Parent Source ID value for the parent of that row of data. You include the data that you want to import into CX Sales and B2B Service in a source CSV file. A sample input CSV file for country as US is shown in this table.

<table>
<thead>
<tr>
<th>RecordTypeCode</th>
<th>PrimaryGeography</th>
<th>CountryCode</th>
<th>LevelNumber</th>
<th>SourceId</th>
<th>ParentSourceId</th>
<th>LanguageCode</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>United States</td>
<td>US</td>
<td>1</td>
<td>1</td>
<td>&lt;blank&gt;</td>
<td>US</td>
</tr>
<tr>
<td>1</td>
<td>California</td>
<td>US</td>
<td>2</td>
<td>11</td>
<td>1</td>
<td>US</td>
</tr>
<tr>
<td>1</td>
<td>San Mateo</td>
<td>US</td>
<td>3</td>
<td>111</td>
<td>11</td>
<td>US</td>
</tr>
<tr>
<td>1</td>
<td>Redwood City</td>
<td>US</td>
<td>4</td>
<td>1111</td>
<td>11</td>
<td>US</td>
</tr>
<tr>
<td>1</td>
<td>94065</td>
<td>US</td>
<td>5</td>
<td>11111</td>
<td>111</td>
<td>US</td>
</tr>
</tbody>
</table>

Here is a sample CSV file to import geographies with alternate name and code for country India:

<table>
<thead>
<tr>
<th>RecordType</th>
<th>PrimaryGeography</th>
<th>CountryCode</th>
<th>LevelNumber</th>
<th>SourceId</th>
<th>ParentSourceId</th>
<th>IdentifierType</th>
<th>IdentifierSubType</th>
<th>IdentifierValue</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>India</td>
<td>IN</td>
<td>1</td>
<td>1</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>1</td>
<td>Karnataka</td>
<td>IN</td>
<td>2</td>
<td>2</td>
<td>1</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>1</td>
<td>Bengaluru</td>
<td>IN</td>
<td>3</td>
<td>3</td>
<td>2</td>
<td>NAME</td>
<td>Standard_Name</td>
<td>Bangalore</td>
</tr>
<tr>
<td>2</td>
<td>Bengaluru</td>
<td>IN</td>
<td>3</td>
<td>3</td>
<td>2</td>
<td>NAME</td>
<td>Standard_Name</td>
<td>Bangalore</td>
</tr>
<tr>
<td>1</td>
<td>Whitefield</td>
<td>IN</td>
<td>4</td>
<td>4</td>
<td>3</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>1</td>
<td>560066</td>
<td>IN</td>
<td>5</td>
<td>5</td>
<td>4</td>
<td>CODE</td>
<td>ISO_COUNTRY_CODE</td>
<td>91</td>
</tr>
<tr>
<td>2</td>
<td>560066</td>
<td>IN</td>
<td>5</td>
<td>5</td>
<td>4</td>
<td>CODE</td>
<td>ISO_COUNTRY_CODE</td>
<td>91</td>
</tr>
</tbody>
</table>
Note:  Note the following:

- The hierarchy is modeled in the CSV file using the SourceId and ParentSourceId. The ParentSourceId for the Country Record (level Number 1) is always null.
- If defining an alternate name (RecordTypeCode = 2) for any level below the country (LevelNumber >1), ensure that the Sourceld and ParentSourceld columns match the values for the original record respectively.
- You can't update geographies via import.
- Before adding a new alternate name, make sure that the alternate name doesn't exist with the same value for any other geography name. You can check the existing values for alternate names in the Manage Geographies task page under Hierarchy Defined.
- You can find the list of IdentifierSubTypes in Manage Geography Lookups page in the UI.
- PrimaryGeographyCodeType and PrimaryGeographyCode can't be added after PrimaryGeographyName is created via import. You must create them together. Alternatively, you can add PrimaryGeographyCodeType and PrimaryGeographyCode from the UI after the import is complete.

You must create a source file (CSV) file with the attributes and import it using import management as shown in this table.

<table>
<thead>
<tr>
<th>Attribute Name</th>
<th>Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>RecordTypeCode</td>
<td>1</td>
<td>The record type code that represents the intent of the import data. The values are:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• 0 - indicates the geography that already exists in the base table.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• 1 - indicates the intent to create a new geography.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• 2 - indicates the intent to add an alternate identifying name or code to an existing geography.</td>
</tr>
<tr>
<td>PrimaryGeographyName</td>
<td>India</td>
<td>This is the primary geography name. This will be marked as the primary name for the Geography and also displayed in the Manage Geographies Page.</td>
</tr>
<tr>
<td>CountryCode</td>
<td>IN</td>
<td>This indicates the Country Code for the country for which you're importing data.</td>
</tr>
</tbody>
</table>
### Import Your Data

#### Attribute Name | Value | Description
--- | --- | ---
LevelNumber | 2 | The level number of the geography in the hierarchy. For example, Country is at Level 1 and State (California) is at Level 2.
SourceId | 2 | The source ID for the geography, along with the parent source ID is used to identify the geography parent and child relationship within the source file data and the interface table data.
ParentSourceId | 1 | The parent source ID for the geography, along with the source ID is used to identify the geography's parent and child relationship with records within the source file data. This should be null for the country record, as Country is at the top of the hierarchy.
IdentifierType | Name | The type of the identifier. It can be either Name or Code.
IdentifierSubtype | Standard_Name or Standard_Code | The IdentifierSubtype can be Standard_Name or Secondary_Name. The default value is Standard_Name.
IdentifierValue | Bangalore | The value of the identifier.

You can create an import activity, enter the import details, and schedule the import.

1. Go to **Navigator > Tools > Import Management > Import Queue**.
2. Click **Create Import Activity** in the **Manage Imports** page.
3. In the **Enter Import Options** page, provide a name for the import activity, and select **Geography** from the Object drop-down list.
   
   **Note:** In the **Advanced Options** section, the option **Enable High-Volume Import** is selected by default. This mode is designed to import millions of records at once.
4. Select the CSV file in the **File Name** field, and click **Next**.
5. The source and target attributes are automatically mapped in the **Map Fields** page. Review and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking **Validate Data**. Click **Next**.
7. Review the import details on the **Review and Submit** page, and click **Submit**.

### Import Your Goal Data

You can use Import Management to create update, or delete Goal records.
To import Goal records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes

To import your Goal data into Oracle Applications Cloud, you need to populate a CSV file with your source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

- Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
- Ensure prerequisite setups are done, if applicable.
- Understand your options for uniquely identifying the records.
- Ensure parent records exist before importing child records.
- Identify the target object attributes that are required in the CSV file for a successful import.

Before You Start

You must do some basic checks before starting your import. For example, make sure that:

- You have completed all the prerequisites for importing each attribute in your source data.
- You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records

All records must be unique in the application. You can use one of these to identify records:

- Public unique identifiers: If you’re creating records, then you can provide an easily understandable public unique identifier. These are, usually, denoted with ‘Number’ and visible in the business object’s UI. PUID attributes are usually named <object> Number. If you’re updating a record with a Number attribute, then use the Number attribute to identify the record. For more information about public unique identifiers, see the topic "How You Use Alternate Keys to Import Records" in Related Topics section.
- Source system and source system reference: Source system is an identifier for the external system, and source system reference is a unique identifier within the external system. If you’re importing new goals or are updating goals that have source system reference data, then provide the source system and source system reference values.

Required Attributes and Validations for Goal Object

To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure that you provide valid values for the attributes. This table lists the required attributes for importing new Goal records, required attributes for updating Goal records, prerequisite setup tasks for the attributes, and specific validations, if any, for Goal import:
<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/Import Validations</th>
<th>Creating a Goal Record</th>
<th>Updating an Existing Goal Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>GoalId</td>
<td>The unique identifier of the goal</td>
<td>No validation</td>
<td>Not required</td>
<td>Conditionally required</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>This is auto generated.</td>
<td>Either the GoalId or the GoalNumber is required.</td>
</tr>
<tr>
<td>OwnerNumber</td>
<td>The unique alternate identifier of the resource who owns and manages the goal</td>
<td>The resource should exist.</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>This is auto defaulted to creator.</td>
<td></td>
</tr>
<tr>
<td>KPINumber</td>
<td>The unique alternate identifier of the KPI selected for the goal</td>
<td>The KPI should exist.</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Either the KPIId or the KPINumber is required.</td>
<td></td>
</tr>
<tr>
<td>GoalName</td>
<td>The name of the goal</td>
<td>No validation</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td>OwnerId</td>
<td>The unique identifier of a valid employee resource who owns and manages the goal</td>
<td>The resource must exist.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>This is auto defaulted to creator.</td>
<td></td>
</tr>
<tr>
<td>KPIId</td>
<td>The unique identifier of the KPI selected for the goal</td>
<td>The KPI record should exist.</td>
<td>Either the KPIId or the KPINumber is required.</td>
<td>Not required</td>
</tr>
<tr>
<td>StartDate</td>
<td>The start date of the goal</td>
<td>The current date and time or a future date</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td>EndDate</td>
<td>The end date of the contest</td>
<td>This must be later than the start date.</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td>Frequency</td>
<td>The interval of repetition of the goal such as daily, weekly, monthly, and so on</td>
<td>This must be a valid lookup code value from the lookupType ORA_ZCA_GOAL_FREQUENCY.</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td>GoalNumber</td>
<td>The unique alternate identifier for the goal</td>
<td>No validation</td>
<td>Not required</td>
<td>Conditionally required</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>This is auto generated.</td>
<td>Either the GoalId or the GoalNumber is required.</td>
</tr>
</tbody>
</table>

You can view the Goal object along with all its child objects and attributes in the Manage Import Objects page of the Import Management flow. You can find attribute information like type, length, description, and so on, on this page.

Create the Source CSV File
You include the data that you want to import into CX Sales and B2B Service in a source CSV file.
You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to **Navigator > Tools > Import Management > Import Objects**.
2. Select the **Goal** object in the table and click **Download**.

You can now edit the downloaded file and provide valid values for the required attributes.

**Note:** For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.

### Create the Import Activity

After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to **Navigator > Tools > Import Management > Import Queue**.
2. Click **Create Import Activity** in the **Manage Imports** page.
3. In the **Enter Import Options** page, provide a name for the import activity, and select **Goal** from the **Object** drop-down list.
4. Select the CSV file in the **File Name** field, and click **Next**.
5. You would see that the source and target attributes are automatically mapped in the **Map Fields** page. Review and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking **Validate Data**. Click **Next**.
7. Review the import details on the **Review and Submit** page, and click **Submit** when you're ready.

### Review the Import Results

Check if your import succeeded on the **Manage Imports** page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to **Navigator > Tools > Import Management > Import Queue**.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the **Status** column for the import activity. The import is successful if the status displays as **Completed**. You can drill down on the import activity to go to the **Import Status** page which provides the status details of the import activity.

**Related Topics**

- Potential Issues When Opening CSV Files in Excel
- How You Use Alternate Keys to Import Records
- Import Data

### Import Your Goal Participant Data

You can use Import Management to create update, or delete Goal Participant records.

To import Goal Participant records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes

To import your Goal Participant data into Oracle Applications Cloud, you need to populate a CSV file with your source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

- Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
- Ensure prerequisite setups are done, if applicable.
- Understand your options for uniquely identifying the records.
- Ensure parent records exist before importing child records.
- Identify the target object attributes that are required in the CSV file for a successful import.

Before You Start

You must do some basic checks before starting your import. For example, make sure that:

- You have completed all the prerequisites for importing each attribute in your source data.
- You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records

All records must be unique in the application. You can use one of these to identify records:

- Public unique identifiers: If you're creating records, then you can provide an easily understandable public unique identifier. These are, usually, denoted with ‘Number’ and visible in the business object’s UI. PUID attributes are usually named <object> Number. If you're updating a record with a Number attribute, then use the Number attribute to identify the record. For more information about public unique identifiers, see the topic "How You Use Alternate Keys to Import Records" in Related Topics section.
- Source system and source system reference: Source system is an identifier for the external system, and source system reference is a unique identifier within the external system. If you're importing new goal participants or are updating goal participants that have source system reference data, then provide the source system and source system reference values.

Required Attributes and Validations for Goal Participant Object

To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure that you provide valid values for the attributes. This table lists the required attributes for importing new Goal Participant records, required attributes for updating Goal Participant records, prerequisite setup tasks for the attributes, and specific validations, if any, for Goal Participant import:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/ Import Validations</th>
<th>Creating a Goal Participant Record</th>
<th>Updating an Existing Goal Participant Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>GoalParticipantId</td>
<td>The unique identifier of the goal participant</td>
<td>No validation</td>
<td>Not required</td>
<td>Conditionally required</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>This is auto generated.</td>
<td>A value is required if the composite key isn’t required.</td>
</tr>
</tbody>
</table>
### Create the Source CSV File

You include the data that you want to import into CX Sales and B2B Service in a source CSV file. You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to **Navigator > Tools > Import Management > Import Objects**.
2. Select the **Goal Participant** object in the table and click **Download**.

You can now edit the downloaded file and provide valid values for the required attributes.

---

**Note:** For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.
Create the Import Activity

After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to **Navigator > Tools > Import Management > Import Queue.**
2. Click **Create Import Activity** in the **Manage Imports** page.
3. In the **Enter Import Options** page, provide a name for the import activity, and select Goal Participant from the **Object** drop-down list.
4. Select the CSV file in the **File Name** field, and click **Next.**
5. You would see that the source and target attributes are automatically mapped in the **Map Fields** page. Review and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking **Validate Data.** Click **Next.**
7. Review the import details on the **Review and Submit** page, and click **Submit** when you’re ready.

Review the Import Results

Check if your import succeeded on the **Manage Imports** page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to **Navigator > Tools > Import Management > Import Queue.**
2. Click All Imports and search for the import activity that you created earlier.
3. Check the **Status** column for the import activity. The import is successful if the status displays as **Completed.** You can drill down on the import activity to go to the **Import Status** page which provides the status details of the import activity.

Related Topics
- Potential Issues When Opening CSV Files in Excel
- How You Use Alternate Keys to Import Records
- Import Data

Import Your Hierarchy Data

You can use the import functionality to create or update Hierarchy records.

The hierarchies supported are:
- Customer hierarchy
- Dun and Bradstreet hierarchy
- Trading Community Party hierarchy

To import Hierarchy records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (.csv) file for import.
3. Create the import activity.
4. Review the import results.
How You Map Your Source Data to Target Object Attributes

To import your Hierarchy data into Oracle Applications Cloud, you need to populate a CSV file with your source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the .CSV file for data import:

- Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
- Ensure prerequisite steps are complete, such as understanding what attributes are required for importing your objects.
- Understand your options for uniquely identifying the records.
- Ensure parent records exist before importing child records.
- Identify the target object attributes that are required in the .CSV file for a successful import.

Before You Start

You must do some basic checks before starting your import. For example, make sure that:

- You have completed all the prerequisites for importing each attribute in your source data.
- You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records

To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the import process to uniquely identify the records. The file import process uses the attribute values to automatically map your source data to the target object attributes in Oracle Applications Cloud.

The preferred option to uniquely identifying an object record is the Internal ID. If you're identifying a record that already exists in Oracle Applications Cloud, then you can use the internal ID of the record, a system-generated unique identifier. Attributes with "ID" in the attribute name are typically internal IDs. Use this option only if you're updating Hierarchies. You can determine the internal ID of a record by exporting Oracle Applications Cloud object data, or by doing a transactional database query. Using an internal ID typically provides better performance and reduces the import duration. For the Hierarchy object, the attributes are TreeStructureCode, TreeCode, TreeName, and TreeVersionName.

Required Attributes and Validations for Hierarchy Object

To import data successfully into Oracle Applications Cloud, your .CSV file must include the required attributes. Ensure that you provide valid values for the attributes.

The following table lists the required attributes for importing new Hierarchy records, required attributes for updating Hierarchy records, prerequisite setup tasks for the attributes, and specific validations, if any, for Hierarchy import:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Data Type</th>
<th>Data Length</th>
<th>Prerequisite Setup Task/Import Validations</th>
<th>Creating a Hierarchy Record</th>
<th>Updating an Existing Hierarchy Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>TreeStructureCode</td>
<td>Unique identifier for a tree structure.</td>
<td>Varchar2</td>
<td>30</td>
<td>Seeded data needs to be present.</td>
<td>Required</td>
<td>Required</td>
</tr>
</tbody>
</table>
Create the Source CSV File

The .CSV file is provided as input to the file-based data import process. You must populate the .CSV file with the data you want to import into Oracle Applications Cloud.

You can either create a CSV file on your own or use templates available in preexisting mappings. To download a template, do the following:

1. Go to Navigator > Tools > Import Management > Import Objects.
2. Select the Hierarchy object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note: For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity

To import data into Oracle Applications Cloud, you need to create an import activity and provide the CSV file as an input to the activity.
To create an import activity, do the following:

1. In the Navigator, under Tools, click Import Management.
2. In the Manage Imports page, click Create Import Activity.
3. In the Create Import Activity: Enter Import Options page, provide a name for the import activity, and select Hierarchy from the Object drop-down list.
4. In File Name, browse and upload the required .CSV file, and click Next.
5. In the Create Import Activity: Map Fields page edit the attribute mappings if required, and click Next.

Note: Click Validate Data to validate the mapping of the source file for unmapped columns and to check for data format issues.

6. In the Create Import Activity: Review and Submit page, click Submit.

Note: Initiate the Tree Flattening Service manually. Do one of the following:
   o From the navigator, select Scheduled Processes. In the Schedule New Process dialog, search for Party Hierarchy Generation and click OK.
   o From Setup and Maintenance, search and run the Trading Community Party Hierarchy Generation task.

Review the Import Results

You can review the import results by checking for the import activity in the Manage Import Activity page. A file import activity is said to be successful when its status displays as Completed. To check the status of the import activity, do as follows:

1. In the Navigator, under Tools, click Import Management.
2. On the Manage Imports page, search for the import activity that you created using one of the search criteria, such as status, name, object, and so on.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed. The other valid values for the import activity status are Queued for import, Preparing data for import, Importing data, Completed with errors, and Unsuccessful.

Note: On this page you can also quickly view the number and status of all active imports, completed imports, and unsuccessful imports that have been submitted.

Related Topics
- Potential Issues When Opening CSV Files in Excel
- Import Data

Import Your Hierarchy Member Data

You can use the import functionality to create or update Hierarchy Member records.
To import Hierarchy Member records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (.csv) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes

To import your Hierarchy Member data into Oracle Applications Cloud, you need to populate a CSV file with your source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the .CSV file for data import:

- Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
- Ensure prerequisite steps are complete, such as understanding what attributes are required for importing your objects.
- Understand your options for uniquely identifying the records.
- Ensure parent records exist before importing child records.
- Identify the target object attributes that are required in the .CSV file for a successful import.

Before You Start

You must do some basic checks before starting your import. For example, make sure that:

- You have completed all the prerequisites for importing each attribute in your source data.
- You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records

To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the import process to uniquely identify the records. The file import process uses the attribute values to automatically map your source data to the target object attributes in Oracle Applications Cloud.

The preferred option to uniquely identify an object record is through the Public unique identifiers. If you're creating new records, then you can provide a user-friendly public unique identifier (attributes denoted with 'Number' and usually visible in the business object's UI). If you update a record for which you have previously provided a Number attribute, or for which a Number attribute is visible in the object's UI, you can use the Number attribute to identify the record. For the Hierarchy Member object, the attributes are:

- TreeStructureCode
- TreeCode
- PartyNumber
- ParentPartyNumber
- AsofDate

Required Attributes and Validations for Hierarchy Member Object

To import data successfully into Oracle Applications Cloud, your .CSV file must include the required attributes. Ensure that you provide valid values for the attributes.
The following table lists the required attributes for importing new Hierarchy Member records, required attributes for updating Hierarchy Member records, prerequisite setup tasks for the attributes, and specific validations, if any, for Hierarchy Member import:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Data Type</th>
<th>Data Length</th>
<th>Prerequisite Setup Task/Import Validations</th>
<th>Creating a Hierarchy Member Record</th>
<th>Updating an Existing Hierarchy Member Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>TreeStructureCode</td>
<td>Unique identifier for a tree structure.</td>
<td>Varchar2</td>
<td>30</td>
<td>Seeded data needs to be present.</td>
<td>Required</td>
<td>Required</td>
</tr>
<tr>
<td>TreeCode</td>
<td>User defined identifier for the tree code.</td>
<td>Varchar2</td>
<td>30</td>
<td>No validation</td>
<td>Required</td>
<td>Required</td>
</tr>
<tr>
<td>PartySourceSystem</td>
<td>Original System Id for the party.</td>
<td></td>
<td></td>
<td>An account needs to exist.</td>
<td>Required</td>
<td>Required</td>
</tr>
<tr>
<td>PartySourceSystemReference</td>
<td>Original System Reference for the party.</td>
<td></td>
<td></td>
<td>An account needs to exist.</td>
<td>Required</td>
<td>Optional</td>
</tr>
<tr>
<td>PartyId</td>
<td>Unique Id for the Party.</td>
<td>Number</td>
<td>18</td>
<td>An account needs to exist.</td>
<td>Required</td>
<td>Required</td>
</tr>
<tr>
<td>ParentPartyId</td>
<td>Unique Id for the Parent Party.</td>
<td>Number</td>
<td>18</td>
<td>An account needs to exist.</td>
<td>Required</td>
<td>Required</td>
</tr>
<tr>
<td>ParentPartySourceSystem</td>
<td>Original System Id for the parent party.</td>
<td>Varchar2</td>
<td>30</td>
<td>An account needs to exist.</td>
<td>Required</td>
<td>Optional</td>
</tr>
<tr>
<td>ParentPartySourceSystemReference</td>
<td>Original System Id for the parent party.</td>
<td>Varchar2</td>
<td>240</td>
<td>An account needs to exist.</td>
<td>Required</td>
<td>Optional</td>
</tr>
<tr>
<td>LabelShortName</td>
<td>Label Name based on the position in the tree hierarchy with respect to the child.</td>
<td>Varchar2</td>
<td>80</td>
<td>Seeded data has to exist.</td>
<td>Required</td>
<td>Optional</td>
</tr>
<tr>
<td>PartyNumber</td>
<td>Unique identification number for this party.</td>
<td>Varchar2</td>
<td>30</td>
<td>An account needs to exist.</td>
<td>Required</td>
<td>Optional</td>
</tr>
<tr>
<td>ParentPartyNumber</td>
<td>Unique identification number for this parent party.</td>
<td>Varchar2</td>
<td>30</td>
<td>An account needs to exist.</td>
<td>Required</td>
<td>Optional</td>
</tr>
</tbody>
</table>
Create the Source CSV File

The .CSV file is provided as input to the file-based data import process. You must populate the .CSV file with the data you want to import into Oracle Applications Cloud.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator > Tools > Import Management > Import Objects.
2. Select the Hierarchy Member object in the table and click Download.

You must edit the template CSV file and provide valid values for the required attributes. You can attach different types of files, giving each file a specific description.

You can now edit the downloaded file and provide valid values for the required attributes.

**Note:** For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity

To import data into Oracle Applications Cloud, you need to create an import activity and provide the CSV file as an input to the activity.

To create an import activity, do the following:

1. In the Navigator, under Tools, click Import Management.
2. On the Manage Imports page, click Create Import Activity.
3. In the Create Import Activity: Enter Import Options page, provide a name for the import activity, and select Hierarchy Member from the Object drop-down list.
4. In File Name, browse and upload the required .CSV file, and click Next.
5. In the Create Import Activity: Map Fields page edit the attribute mappings if required, and click Next.

**Note:** Click Validate Data to validate the mapping of the source file for unmapped columns and to check for data format issues.
6. In the **Create Import Activity: Review and Submit** page, click **Submit**.

   **Note:** Initiate the Tree Flattening Service manually. Do one of the following:
   - From the navigator, select **Scheduled Processes**. In the Schedule New Process dialog, search for **Party Hierarchy Generation** and click **OK**.
   - From Setup and Maintenance, search and run the Trading Community Party Hierarchy Generation task.

### Review the Import Results

Check if your import succeeded on the **Manage Imports** page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to **Navigator > Tools > Import Management > Import Queue**.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the **Status** column for the import activity. The import is successful if the status displays as **Completed**. You can drill down on the import activity to go to the **Import Status** page which provides the status details of the import activity.

**Related Topics**
- Potential Issues When Opening CSV Files in Excel
- Import Data

### Import Your Household Data

You can use Import Management to create or update Household records.

To import Household records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (.csv) file for import.
3. Create the import activity.
4. Review the import results.

#### How You Map Your Source Data to Target Object Attributes

To import your Household data into Oracle Applications Cloud, you need to populate a CSV file with your source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the .CSV file for data import:

- Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
- Ensure prerequisite steps are complete, such as understanding what attributes are required for importing your objects.
- Understand your options for uniquely identifying the records.
- Ensure parent records exist before importing child records.
• Identify the target object attributes that are required in the .CSV file for a successful import.

**Note:** You can’t set an attribute value to NULL in optimized import (standard import with the option Enable High-Volume Import selected). However, when updating a record, you can change an attribute value from NOT NULL to NULL.

**Before You Start**
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.
• You have all parent records in place before importing child records.

**Select a Unique Identifier for Your Records**
To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the import process to uniquely identify the records. The file import process uses the attribute values to automatically map your source data to the target object attributes in Oracle Applications Cloud.

The preferred options to uniquely identify an object record are as follows:

• **Internal ID**: If you’re identifying a record that already exists in Oracle Applications Cloud, then you can use the internal ID of the record, a system-generated unique identifier. Attributes with "ID" in the attribute name are typically internal IDs. Use this option only if you’re updating Households. You can determine the internal ID of a record by exporting Oracle Applications Cloud object data, or by doing a transactional database query. Using an internal ID typically provides better performance and reduces the import duration. For the Household object, the attributes are OwnerPartyId and PartyId.

• **Public unique identifiers**: If you’re creating new records, then you can provide a user-friendly public unique identifier (attributes denoted with ‘Number’ and usually visible in the business object’s UI). If you update a record for which you have previously provided a Number attribute, or for which a Number attribute is visible in the object’s UI, you can use the Number attribute to identify the record. For the Household object, the attribute is PartyNumber.

**Required Attributes and Validations for Household Object**
To import data successfully into Oracle Applications Cloud, your .CSV file must include the required attributes. Ensure that you provide valid values for the attributes.

The following table lists the required attributes for importing new Household records, required attributes for updating Household records, prerequisite setup tasks for the attributes, and specific validations, if any, for Household import:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Data Type</th>
<th>Data Length</th>
<th>Prerequisite Setup Task/Import Validations</th>
<th>Creating a Household Record</th>
<th>Updating an Existing Household Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>SourceSystem</td>
<td>The code representing the source system for the household</td>
<td>String</td>
<td>30</td>
<td>Identify the source system or configure source systems either by using the Manage Trading</td>
<td>Optional</td>
<td>Required</td>
</tr>
</tbody>
</table>
## Import Your Data

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Data Type</th>
<th>Data Length</th>
<th>Prerequisite Setup Task/ Import Validations</th>
<th>Creating a Household Record</th>
<th>Updating an Existing Household Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>SourceSystemReference</td>
<td>The reference number or text representing the source system unique ID for the household</td>
<td>String</td>
<td>240</td>
<td>Identify the source system or configure source systems either by using the Manage Trading Community Source System task, or by importing the source system information into Oracle Applications Cloud using the Source System Reference import object.</td>
<td>Optional</td>
<td>Required</td>
</tr>
<tr>
<td>PartyNumber</td>
<td>The public unique identifier of the party.</td>
<td>String</td>
<td>30</td>
<td>Identify the party number value by exporting the Household object.</td>
<td>Optional</td>
<td>Required</td>
</tr>
<tr>
<td>PartyId</td>
<td>The public unique identifier of the party</td>
<td>Long</td>
<td>18</td>
<td>Identify the party number value by exporting the Household object.</td>
<td>Optional</td>
<td>Required</td>
</tr>
<tr>
<td>Name</td>
<td>The name of the household</td>
<td>String</td>
<td>360</td>
<td>Identify the organization name of the resource by navigating to the Resource Directory.</td>
<td>Required</td>
<td>Conditionally required</td>
</tr>
<tr>
<td>OwnerPartyId</td>
<td>Indicates the party ID of the resource who’s designated as the owner of the household</td>
<td>Long</td>
<td>18</td>
<td>None.</td>
<td>Conditionally required</td>
<td>Conditionally required</td>
</tr>
</tbody>
</table>

You can use the profile option `ORA_HZ_IMPORT_MULTIADDRESS_TYPE` to control how address types are entered. By default this profile option is set to Yes, so you can enter multiple address types, during high-volume import of Account.
Contact, and Household objects. You can disable this profile option to improve the import performance. When you set this profile option to No, you can enter only a single address type.

You can view the Household object along with all its child objects and attributes in the Manage Import Objects page of the Import Management flow. You can find attribute information like type, length, description, and so on, on this page.

Create the Source CSV File
You include the data that you want to import into CX Sales and B2B Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator > Tools > Import Management > Import Objects.
2. Select the Household object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

**Note:** For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Household from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed. You can drill down on the import activity to go to the Import Status page which provides the status details of the import activity.

**Related Topics**
- Potential Issues When Opening CSV Files in Excel
- Import Data
Import Your Hub Source System Reference Data

You can use Import Management to create or update Hub Source System Reference records.

To import Hub Source System Reference records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes

To import your Hub Source System Reference data into Oracle Applications Cloud, you need to populate a CSV file with your source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

- Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
- Ensure prerequisite setups are done, if applicable.
- Understand your options for uniquely identifying the records.
- Ensure parent records exist before importing child records.
- Identify the target object attributes that are required in the CSV file for a successful import.
- Ensure that you don’t insert duplicate addresses while importing, to avoid redundant data.

Before You Start

You must do some basic checks before starting your import. For example, make sure that:

- You have completed all the prerequisites for importing each attribute in your source data.
- You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records

All records must be unique in the application. You can use one of these to identify records:

- Public unique identifiers: If you’re creating records, then you can provide an easily understandable public unique identifier. These are, usually, denoted with ‘Number’ and visible in the business object’s UI. PUID attributes are usually named <object> Number. If you’re updating a record with a Number attribute, then use the Number attribute to identify the record. For more information about public unique identifiers, see the topic "How You Use Alternate Keys to Import Records" in Related Topics section.
- Source system and source system reference: Source system is an identifier for the external system, and source system reference is a unique identifier within the external system. If you’re importing new hub source system reference records or are updating hub source system reference records that have source system reference data, then provide the source system and source system reference values.
Required Attributes and Validations for Hub Source System Reference Object

To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure that you provide valid values for the attributes. This table lists the required attributes for importing new Hub Source System Reference records, required attributes for updating Hub Source System Reference records, prerequisite setup tasks for the attributes, and specific validations, if any, for Hub Source System Reference import:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/ Import Validations</th>
<th>Creating a Hub Source System Reference Record</th>
<th>Updating an Existing Hub Source System Reference Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>OwnerEntityId</td>
<td>Internal identifier or primary key of a record that exists in the OSC table</td>
<td>If provided, it has to be an active primary key value from the table name provided for the OwnerEntityObject.</td>
<td>If you export data from the OSC table provided for the OwnerEntityObject, provide the primary key data to this attribute. If you can't provide this data, provide valid values for the combination of ExistingSourceSystem and ExistingSourceSystemReference.</td>
<td>Not required</td>
</tr>
<tr>
<td>StartDateActive</td>
<td>The date on which the hub source system reference becomes valid.</td>
<td>If provided, this date should be earlier than the end date. If you don't specify a date, this defaults to the current date.</td>
<td>Optional</td>
<td>Optional</td>
</tr>
<tr>
<td>EndDateActive</td>
<td>The date on which the hub source system reference is no longer valid.</td>
<td>If provided, this date should be later than the start date. If you don't specify a date, this defaults to 12/31/4712.</td>
<td>Optional</td>
<td>Optional</td>
</tr>
<tr>
<td>SourceSystem</td>
<td>Specifies the original source system name</td>
<td>This has to be present in the HZ_ORIG_SYSTEMS_B table with the status &quot;A&quot;.</td>
<td>Provide a valid value.</td>
<td>Conditionally required.</td>
</tr>
<tr>
<td>SourceSystemReferenceValue</td>
<td>Specifies the original source system reference text or number in the original source system</td>
<td>No validation</td>
<td>Provide a valid value.</td>
<td>Conditionally required.</td>
</tr>
</tbody>
</table>

12/31/4712 represents December 31, 9712, which is a placeholder date for the purpose of this example.
<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/Import Validations</th>
<th>Creating a Hub Source System Reference Record</th>
<th>Updating an Existing Hub Source System Reference Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>OwnerEntityObject</td>
<td>Specifies the OSC table in which the record exists</td>
<td>This has to be a valid lookup code in the lookup type ORA_ZCH_OWNER_ENTITY_OBJECT.</td>
<td>Provide a valid value.</td>
<td>Conditionally required.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Provide one of the following:</td>
<td>Provide one of the following:</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• SourceSystemReferenceId</td>
<td>• SourceSystemReferenceId</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• A combination of SourceSystem, SourceSystemReference and OwnerEntityObject</td>
<td>• A combination of SourceSystem, SourceSystemReference and OwnerEntityObject</td>
</tr>
<tr>
<td>SourceSystemReferenceId</td>
<td>Specifies the source system reference identifier. This is a primary key.</td>
<td>If provided, this has to be an active primary key value from the table HZ_ORIG_SYS_REFERENCES.</td>
<td>Not required</td>
<td>Conditionally required.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Provide one of the following:</td>
<td>Provide one of the following:</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• SourceSystemReferenceId</td>
<td>• SourceSystemReferenceId</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• A combination of SourceSystem, SourceSystemReference and OwnerEntityObject</td>
<td>• A combination of SourceSystem, SourceSystemReference and OwnerEntityObject</td>
</tr>
<tr>
<td>ExistingSourceSystem</td>
<td>Specifies the original source system name of data that exists in Oracle Engagement Cloud</td>
<td>This has to be present in the HZ_ORIG_SYSTEMS_B table with status &quot;A&quot;.</td>
<td>If you can't provide the OwnerEntityID, provide a combination of ExistingSourceSystem and ExistingSourceSystemReference values. Export the Source System Reference repository to obtain this value.</td>
<td>Not required</td>
</tr>
<tr>
<td>ExistingSourceSystemReference</td>
<td>Specifies the original source system reference of data that exists in Oracle Engagement Cloud</td>
<td>No validation</td>
<td>If you can't provide the OwnerEntityID, provide a combination of ExistingSourceSystem and ExistingSourceSystemReference values. Export the Source System Reference repository to obtain this value.</td>
<td>Not required</td>
</tr>
</tbody>
</table>

You can view the Hub Source System Reference object along with all its child objects and attributes in the Manage Import Objects page of the Import Management flow. You can find attribute information like type, length, description, and so on, on this page.
Note: A lookup type ORA_ZCH_OWNER_ENTITY_OBJECT is now available. You can now use this lookup without specifying the underlying physical tables, when providing input data in the CSV import file. When you migrate from File-Based Data Import to Optimized or Import Management, the underlying physical tables are secured to external parties.

Create the Source CSV File
You include the data that you want to import into CX Sales and B2B Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator > Tools > Import Management > Import Objects.
2. Select the Hub Source System Reference object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note: For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Hub Source System Reference from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed. You can drill down on the import activity to go to the Import Status page which provides the status details of the import activity.

Related Topics
- Potential Issues When Opening CSV Files in Excel
- How You Use Alternate Keys to Import Records
- Import Data
Import Your Incentive Compensation Participants

You can use the import management functionality to create or update Incentive Compensation Participants. You can specify the exact parties you want to import as participants.

You can import Incentive Participants using these steps:

1. Map your source data to Oracle Applications Cloud object attributes. This way the import process would know where to insert each of the information bits.
2. Create the source CSV file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes

You import Incentive Participants into Oracle Applications Cloud from a CSV file containing your source data that's mapped to target Oracle Applications Cloud object attributes.

Before you create the source data file, you should:

- Know how your source data attributes map to the target object attributes in Oracle Applications Cloud. Match each column from the source file to an attribute in the Incentive Participants import object.
- Finish all prerequisite steps, such as understanding what attributes are required for importing your objects.
- Know how you can uniquely identify the records.
- Check the target object attributes required in the CSV file for a successful import.
- Ensure that you don’t insert duplicate Incentive Participants while importing, to avoid redundant data.

Before You Start

You must do some basic checks before starting your import. For example, make sure that:

- You have completed all the prerequisites for importing each attribute in your source data.
- You have all parent records in place before importing child records.

Required Attributes and Validations for Incentive Participants Object

To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure that you provide valid values for the attributes.

This table lists the required attributes for Incentive Participants, prerequisite setup tasks and specific validations, if any:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/Import Validations</th>
<th>Creating an Incentive Participant</th>
<th>Updating an Existing Incentive Participant</th>
</tr>
</thead>
<tbody>
<tr>
<td>PartyNumber</td>
<td>The party number of the participant. This is used to find the party that's to be imported as a participant.</td>
<td>The PartyNumber must match an existing party.</td>
<td>Required</td>
<td>Required</td>
</tr>
</tbody>
</table>
## Chapter 8

### Import Your Data

#### Go to Navigator > Tools > Import Management > Import Objects, to see all the attributes of the Incentive Participants object. The page also lists attribute information like type, length, description, and so on.

**Note:** You can’t update participant detail records through import after the initial creation. You can update them by creating a new import, via the UI, or through a REST call.

#### Create the Source CSV File

You include the data that you want to import into CX Sales and B2B Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator > Tools > Import Management > Import Objects.
2. Select the Incentive Participants object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

**Note:** For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.

#### Create the Import Activity

After you have the CSV file ready, create an import activity to import the Incentive Participants information. To create an import activity:

1. Go to Navigator > Tools > Import Management > Import Incentive Participants.
2. On the Manage Imports page, click Create Import Activity.
3. In the Create Import Activity: Enter Import Options page, provide a name for the import activity, and select Incentive Participants from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
Review the import details on the Review and Submit page, and click Submit when you’re ready.

Review the Import Results

Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to Go to Navigator > Tools > Import Management > Import Incentive Participants.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed. You can drill down on the import activity to go to the Import Status page which provides the status details of the import activity.

Related Topics
- How You Use Alternate Keys to Import Records
- Potential Issues When Opening CSV Files in Excel

Import Your Incentive Participant Goal Data

You can use Import Management to update Incentive Participant Goal records.

To import Incentive Participant Goal records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes

To import your Incentive Participant Goal data into Oracle Applications Cloud, you need to populate a CSV file with your source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

- Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
- Ensure prerequisite setups are done, if applicable.
- Understand your options for uniquely identifying the records.
- Identify the target object attributes that are required in the CSV file for a successful import.

Before You Start

You must do some basic checks before starting your import. For example, make sure that:

- You have completed all the prerequisites for importing each attribute in your source data.
Required Attributes and Validations for Incentive Participant Goal Object

To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure that you provide valid values for the attributes. This table lists the required attributes for updating Incentive Participant Goal records, prerequisite setup tasks for the attributes, and specific validations, if any, for Incentive Participant Goal import:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/ Import Validations</th>
<th>Updating an Existing Participant Goal Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>ParticipantName</td>
<td>This is the full name of the participant as stored in HZ_Parties.</td>
<td>Must match unique participant in business unit. If not unique additional identifiers can be provided.</td>
<td>Required. If duplicate participant names are found in the Business Unit, you will need to provide Party Number or Participant Identifier to uniquely identify the participant.</td>
</tr>
<tr>
<td>BusinessUnit</td>
<td>The name of the Oracle Incentive Compensation business unit.</td>
<td>None</td>
<td>Required unless OrgId is provided.</td>
</tr>
<tr>
<td>OrgId</td>
<td>The unique numeric identifier for the Oracle Fusion Incentive Compensation business unit.</td>
<td>A valid OrgId.</td>
<td>Required unless BusinessUnit is provided.</td>
</tr>
<tr>
<td>ParticipantId</td>
<td>The unique identifier of the participant.</td>
<td>None</td>
<td>Provide value to uniquely identify participant.</td>
</tr>
<tr>
<td>PartyNumber</td>
<td>The unique alternate identifier for the participant.</td>
<td>The PartyNumber must match a participant for the given BU.</td>
<td>Conditionally Required. Provide value to uniquely identify participant.</td>
</tr>
<tr>
<td>EmailAddress</td>
<td>The email address associated with the participant.</td>
<td>None</td>
<td>Conditionally Required. Provide value to uniquely identify participant.</td>
</tr>
<tr>
<td>HrPersonNumber</td>
<td>Typically the HR person number of the participant.</td>
<td>None</td>
<td>Conditionally Required. Provide value to uniquely identify participant.</td>
</tr>
<tr>
<td>MeasureName</td>
<td>The name of the performance measure for which goals are being assigned.</td>
<td>Must match a performance measure in BU and be assigned to specified participant.</td>
<td>Required unless FormulaID provided.</td>
</tr>
<tr>
<td>StartDate</td>
<td>Start date of the period for which the goals are being updated.</td>
<td>Must match start date of valid calendar period.</td>
<td>Required unless Period provided.</td>
</tr>
<tr>
<td>EndDate</td>
<td>End date of the period for which the goals are being updated.</td>
<td>Must match end date of valid calendar period.</td>
<td>Required unless Period provided.</td>
</tr>
<tr>
<td>PeriodName</td>
<td>The name of the calendar period for which goals are being updated.</td>
<td>Must be a valid period in calendar for specified business unit.</td>
<td>Required unless Start &amp; End Date are provided.</td>
</tr>
<tr>
<td>Target</td>
<td>The period target the user wishes to set for the participant.</td>
<td>None</td>
<td>Required</td>
</tr>
<tr>
<td>UpdateAllOccurences</td>
<td>Indicates if specified goal value should be updated for all plans</td>
<td>Valid values are Y, N, or left blank.</td>
<td>Optional. Defaulted to N if left blank.</td>
</tr>
</tbody>
</table>
### Attribute | Description | Prerequisite Setup Task/ Import Validations | Updating an Existing Participant Goal Record
--- | --- | --- | ---
EnforceAssignment  | Indicates if goal updates should be restricted only to periods for which the participant was assigned to a specific compensation plan. | Valid values are Y, N, or left blank. | Optional. Defaulted to Y if left blank. |
PlanName  | Name of the specific compensation plan where the goal is being updated. | None | Optional. Required when UpdateAllOccurrences is set to N and unless plan ID is provided. |
CompPlanId  | Unique numeric identifier of the compensation plan where the goal is being updated. | None | Optional |
CompPlanName  | Name of the specific plan component where the goal is being updated. | None | Conditionally Required. Required when UpdateAllOccurrences is set to N or Plan Component ID isn't provided. |
PlanComponentId  | Unique numeric identifier of the plan component where the goal is being updated. | None | Optional |
FormulaId  | Unique numeric identifier of the performance measure for which goals are being updated. | Must match a performance measure in BU and be assigned to specified participant. | Optional |

You can view the Incentive Participant Goal object along with all its child objects and attributes in the Manage Import Objects page of the Import Management flow. You can find attribute information like type, length, description, and so on, on this page.

**Note:**
- Goals are set at the performance measure level for a specific period and participant. Sometimes, performance measures are reused in different plan components and plans. When setting goals you have the option to set different goals for a performance measure based on the associated plan or plan component. When using Update All Occurrences with the value Y, the goal will be loaded for all instances of where the performance measure is used for that participant. If it is set to N, you can specify the specific plan or plan component you wish to assign the goal to.
- The Enforce Assignment attribute can be set to Y or N. If left blank it will default to Y.

### Create the Source CSV File
You include the data that you want to import into CX Sales and B2B Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator > Tools > Import Management > Import Objects.
2. Select the Participant Goal object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.
Create the Import Activity

After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Incentive Participant Goal from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you’re ready.

Review the Import Results

Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed. You can drill down on the import activity to go to the Import Status page which provides the status details of the import activity.

Related Topics

- Import Data
- How You Use Alternate Keys to Import Records
- Potential Issues When Opening CSV Files in Excel

Import Your Incentive Rule Assignment Data

You can use the import functionality to create, update, or delete Incentive Rule Assignment records.

You can import Incentive Rule Assignment records using these steps:

1. Map your source data to Oracle Applications Cloud object attributes. This way the import process would know where to insert each of the information bits.
2. Create the source CSV file with the Incentive Rule Assignment data you want to import.
4. Check the import results to know if the import went well.
How You Map Your Source Data to Target Object Attributes

You import Incentive Rule Assignment data into Oracle Applications Cloud from a CSV file containing your source data that’s mapped to target Oracle Applications Cloud object attributes.

Before you create the source data file, you should:

- Know how your source data attributes map to the target object attributes in Oracle Applications Cloud. Match each column from the source file to an attribute in the Incentive Rule Assignment import object.
- Finish all prerequisite steps, such as understanding what attributes are required for importing your objects.
- Know how you can uniquely identify the records.
- Check the target object attributes required in the CSV file for a successful import.
- Ensure that you don’t insert duplicate Incentive Rule Assignments while importing, to avoid redundant data.

If you want to import only a few records, then you can create a single CSV file for all Incentive Rule Assignment attributes.

Before You Start

You must do some basic checks before starting your import. For example, make sure that:

- You have completed all the prerequisites for importing each attribute in your source data.
- You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records

All records must be unique in the application. You can use the public unique identifier to identify records. If you’re creating records, then you can provide an easily understandable public unique identifier. These are, usually, denoted with 'Number' and visible in the business object’s UI. PUID attributes are usually named <object> Number. If you’re updating a record with a Number attribute, then use the Number attribute to identify the record. For more information about public unique identifiers, see the topic "How You Use Alternate Keys to Import Records" in Related Topics section.

Required Attributes and Validations for Incentive Rule Assignment Object

To import data successfully into Oracle Applications Cloud, your .CSV file must include the required attributes. Ensure that you provide valid values for the attributes.

This table lists the required attributes for Incentive Rule Assignment records, prerequisite setup tasks and specific validations, if any:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/ Import Validations</th>
<th>Creating an Incentive Rule Assignment record</th>
<th>Updating an Existing Incentive Rule Assignment record</th>
<th>Deleting an Existing Incentive Rule Assignment record</th>
</tr>
</thead>
<tbody>
<tr>
<td>RuleNumber</td>
<td>PUID of the rule</td>
<td>The RuleNumber should exist.</td>
<td>A value is required if the Name isn’t provided.</td>
<td>A value is required if the Name isn’t provided.</td>
<td>A value is required if the Name isn’t provided.</td>
</tr>
<tr>
<td>Name</td>
<td>Name of the rule</td>
<td>The Rule name should exist.</td>
<td>A value is required if the RuleNumber isn’t provided.</td>
<td>A value is required if the RuleNumber isn’t provided.</td>
<td>A value is required if the RuleNumber isn’t provided.</td>
</tr>
<tr>
<td>Attribute</td>
<td>Description</td>
<td>Prerequisite Setup Task/ Import Validations</td>
<td>Creating an Incentive Rule Assignment record</td>
<td>Updating an Existing Incentive Rule Assignment record</td>
<td>Deleting an Existing Incentive Rule Assignment record</td>
</tr>
<tr>
<td>-----------------------</td>
<td>------------------------------------------------------------------------------</td>
<td>------------------------------------------------------------------------</td>
<td>---------------------------------------------</td>
<td>----------------------------------------------------</td>
<td>------------------------------------------------------</td>
</tr>
<tr>
<td>AssignedObjectType</td>
<td>The type of the object assigned to the rule.</td>
<td>A value is required only when importing credit rules. Values can be INDIVIDUAL or PARTICIPANT_ON_TXN.</td>
<td>Optional</td>
<td>Optional</td>
<td>Optional</td>
</tr>
<tr>
<td>AssignedObjectId</td>
<td>The unique internal identifier of the object being assigned to the rule.</td>
<td>This is validated against the corresponding object depending on the type of rule assignment being imported.</td>
<td>Provide one of the following:</td>
<td>Provide one of the following:</td>
<td>Provide one of the following:</td>
</tr>
<tr>
<td></td>
<td>• For credit, rollup and team rules, the object is participant.</td>
<td>• AssignedObjectId</td>
<td>• AssignedObjectId</td>
<td>• AssignedObjectId</td>
<td>• AssignedObjectId</td>
</tr>
<tr>
<td></td>
<td>• For classification rules, the object is credit category.</td>
<td>• AssignedObjectName</td>
<td>• AssignedObjectName</td>
<td>• AssignedObjectName</td>
<td>• AssignedObjectName</td>
</tr>
<tr>
<td></td>
<td>• For Participant assignment rules, the object is role.</td>
<td>• EmailAddress</td>
<td>• EmailAddress</td>
<td>• EmailAddress</td>
<td>• EmailAddress</td>
</tr>
<tr>
<td></td>
<td>• For analyst hierarchy, the object is analyst.</td>
<td>• HrPrimaryWorkerNumber</td>
<td>• HrPrimaryWorkerNumber</td>
<td>• HrPrimaryWorkerNumber</td>
<td>• HrPrimaryWorkerNumber</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• HrPersonNumber</td>
<td>• HrPersonNumber</td>
<td>• PartyNumber</td>
<td>• PartyNumber</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• PartyNumber</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>EmailAddress</td>
<td>The Email address of the participant. This is applicable only when the object is a participant.</td>
<td>This is validated against the participant's email address.</td>
<td>Provide one of the following:</td>
<td>Provide one of the following:</td>
<td>Provide one of the following:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• AssignedObjectId</td>
<td>• AssignedObjectId</td>
<td>• AssignedObjectId</td>
<td>• AssignedObjectId</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• AssignedObjectName</td>
<td>• AssignedObjectName</td>
<td>• AssignedObjectName</td>
<td>• AssignedObjectName</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• EmailAddress</td>
<td>• EmailAddress</td>
<td>• EmailAddress</td>
<td>• EmailAddress</td>
</tr>
<tr>
<td>Attribute</td>
<td>Description</td>
<td>Prerequisite Setup Task/ Import Validations</td>
<td>Creating an Incentive Rule Assignment record</td>
<td>Updating an Existing Incentive Rule Assignment record</td>
<td>Deleting an Existing Incentive Rule Assignment record</td>
</tr>
<tr>
<td>---------------------------</td>
<td>------------------------------------</td>
<td>-------------------------------------------------------------------------------------------------------------</td>
<td>-------------------------------------------------------------------------------------------------------------</td>
<td>------------------------------------------------------------------------------------------------------------------------</td>
<td>------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>HrPrimaryWorkerNumber</td>
<td>The Worker Number of the participant. This is applicable only when the object is a participant.</td>
<td>This is validated against the worker number of the participant.</td>
<td>Provide one of the following:</td>
<td>Provide one of the following:</td>
<td>Provide one of the following:</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• AssignedObjectId</td>
<td>• AssignedObjectId</td>
<td>• AssignedObjectId</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• AssignedObjectName</td>
<td>• AssignedObjectName</td>
<td>• AssignedObjectName</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• EmailAddress</td>
<td>• EmailAddress</td>
<td>• EmailAddress</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• HrPrimaryWorkerNumber</td>
<td>• HrPrimaryWorkerNumber</td>
<td>• HrPrimaryWorkerNumber</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• HrPersonNumber</td>
<td>• HrPersonNumber</td>
<td>• HrPersonNumber</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• PartyNumber</td>
<td>• PartyNumber</td>
<td>• PartyNumber</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>EmailAddress,</td>
<td>EmailAddress,</td>
<td>EmailAddress,</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>HrPrimaryWorkerNumber, HrPersonNumber, and PartyNumber are only valid for participants.</td>
<td>HrPrimaryWorkerNumber, HrPersonNumber, and PartyNumber are only valid for participants.</td>
<td>HrPrimaryWorkerNumber, HrPersonNumber, and PartyNumber are only valid for participants.</td>
</tr>
<tr>
<td>HrPersonNumber</td>
<td>The Person Number of the participant. This is applicable only when the object is a participant.</td>
<td>This is validated against the person number of the participant.</td>
<td>Provide one of the following:</td>
<td>Provide one of the following:</td>
<td>Provide one of the following:</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• AssignedObjectId</td>
<td>• AssignedObjectId</td>
<td>• AssignedObjectId</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• AssignedObjectName</td>
<td>• AssignedObjectName</td>
<td>• AssignedObjectName</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• EmailAddress</td>
<td>• EmailAddress</td>
<td>• EmailAddress</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• HrPrimaryWorkerNumber</td>
<td>• HrPrimaryWorkerNumber</td>
<td>• HrPrimaryWorkerNumber</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• HrPersonNumber</td>
<td>• HrPersonNumber</td>
<td>• HrPersonNumber</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• PartyNumber</td>
<td>• PartyNumber</td>
<td>• PartyNumber</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>When the object is a participant, provide one among EmailAddress, HrPrimaryWorkerNumber, HrPersonNumber, or PartyNumber.</td>
<td>When the object is a participant, provide one among EmailAddress, HrPrimaryWorkerNumber, HrPersonNumber, or PartyNumber.</td>
<td>When the object is a participant, provide one among EmailAddress, HrPrimaryWorkerNumber, HrPersonNumber, or PartyNumber.</td>
</tr>
<tr>
<td>PartyNumber</td>
<td>The Party Number of the participant. This is applicable only when the object is a participant.</td>
<td>This is validated against the party number of the participant.</td>
<td>Provide one of the following:</td>
<td>Provide one of the following:</td>
<td>Provide one of the following:</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• AssignedObjectId</td>
<td>• AssignedObjectId</td>
<td>• AssignedObjectId</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• AssignedObjectName</td>
<td>• AssignedObjectName</td>
<td>• AssignedObjectName</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• EmailAddress</td>
<td>• EmailAddress</td>
<td>• EmailAddress</td>
</tr>
</tbody>
</table>
### Attribute | Description | Prerequisite Setup Task/ Import Validations | Creating an Incentive Rule Assignment record | Updating an Existing Incentive Rule Assignment record | Deleting an Existing Incentive Rule Assignment record
--- | --- | --- | --- | --- | ---
StartDate | The start date of the rule assignment, if applicable to the object. | None | Required | Required | Required
EndDate | The end date of the rule assignment, if applicable to the object. | None | Optional | Optional | Optional
SplitPct | The percentage split applicable to the participant assigned to the credit rule. | None | Required for credit rules | Optional | Optional
RevenueType | The revenue type applicable to the participant assigned to the credit or rollup rule. | The valid values are the lookup codes setup for lookup type CN_RS_REVENUE_TYPE. This is applicable only to credit and rollup rules. | Required for credit and rollup rules. | Optional | Optional
RollupFlag | Option to determine if direct credit should be rolled up to every individual on parent rules. This is applicable only to credit rules. | The valid values are Y and N. | Required for credit rules | Optional | Optional
SummaryFlag | Option to determine if credits should be summarized. This is applicable to direct credit and rollup rules. | The valid values are Y and N. | Required for credit and rollup rules. | Optional | Optional
GroupMemberCreditFlag | Option to determine if the member gets credit from any direct credit receivers in group or child groups. This is applicable to rollup rules. | The valid values are Y and N. | Required for rollup and hierarchy analyst rules | Optional | Optional
### Understanding Import and Export Management for CX Sales and B2B Service

#### Chapter 8

**Import Your Data**

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/ Import Validations</th>
<th>Creating an Incentive Rule Assignment record</th>
<th>Updating an Existing Incentive Rule Assignment record</th>
<th>Deleting an Existing Incentive Rule Assignment record</th>
</tr>
</thead>
<tbody>
<tr>
<td>RuleAssignmentId</td>
<td>The unique internal identifier of the Rule Assignment record.</td>
<td>This validates against the Rule Assignment table when you update and delete incentive rule assignment records.</td>
<td>Leave this blank.</td>
<td>Optional</td>
<td>Optional</td>
</tr>
<tr>
<td>ActionCode</td>
<td>Indicates explicitly the operation to be performed on a row:</td>
<td>The value can be blank, UPDATE, or DELETE.</td>
<td>Optional</td>
<td>Required</td>
<td>Required</td>
</tr>
<tr>
<td></td>
<td>• INSERT to create a new record in the destination tables</td>
<td></td>
<td></td>
<td>Enter the value as UPDATE.</td>
<td>Enter the value as DELETE.</td>
</tr>
<tr>
<td></td>
<td>• UPDATE to update an existing record in the destination table</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>• DELETE to delete the record.</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Go to **Navigator > Tools > Import Management > Import Objects**, to see all the attributes of the Incentive Rule Assignment object. The page also lists attribute information like type, length, description, and so on.

### Create the Source CSV File

You include the data that you want to import into CX Sales and B2B Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to **Navigator > Tools > Import Management > Import Objects**.
2. Select the Incentive Rule Assignment object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

**Note:** For help in populating the CSV file and to avoid any issues in entering values, see the topic **Potential Issues When Opening CSV Files With Excel** in Related Topics section.

### Create the Import Activity

After you have the CSV file ready, create an import activity to import the Incentive Rule Assignment information. To create an import activity:

1. Go to **Navigator > Tools > Import Management > Import Incentive Rule Assignment**.
2. On the **Manage Imports** page, click **Create Import Activity**.
3. In the **Create Import Activity: Enter Import Options** page, provide a name for the import activity, and select **Incentive Rule Assignment** from the **Object** drop-down list.
4. Select the CSV file in the File Name field, and click Next.

5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review and edit the mappings if required.

6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.

7. Review the import details on the Review and Submit page, and click Submit when you’re ready.

**Review the Import Results**

Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to Go to Navigator > Tools > Import Management > Import Incentive Rule Assignment.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed. You can drill down on the import activity to go to the Import Status page which provides the status details of the import activity.

**Related Topics**

- How You Use Alternate Keys to Import Records
- Potential Issues When Opening CSV Files in Excel

**Import Your Incentive Rule Attribute Values Data**

You can use the import functionality to create or delete Incentive Rule Attribute Value records.

You can import Incentive Rule Attribute Value records using these steps:

1. Map your source data to Oracle Applications Cloud object attributes. This way the import process would know where to insert each of the information bits.
2. Create the source CSV file with the Incentive Rule Attribute Value data you want to import.
4. Check the import results to know if the import went well.

**How You Map Your Source Data to Target Object Attributes**

You import Incentive Rule Attribute Value data into Oracle Applications Cloud from a CSV file containing your source data that’s mapped to target Oracle Applications Cloud object attributes.

Before you create the source data file, you should:

- Know how your source data attributes map to the target object attributes in Oracle Applications Cloud. Match each column from the source file to an attribute in the Incentive Rule Attribute Values import object.
- Finish all prerequisite steps, such as understanding what attributes are required for importing your objects.
- Know how you can uniquely identify the records.
- Check the target object attributes required in the CSV file for a successful import.
- Ensure that you don’t insert duplicate Incentive Rule Attribute Values while importing, to avoid redundant data.
If you want to import only a few records, then you can create a single CSV file for all Incentive Rule Attribute Values attributes. However if you want to import a large number of records, then you may decide to create multiple CSV files, one for each of the Incentive Rule Attribute Value child objects. Note that you must have imported the CSV file for Incentive Rule Attribute Values object successfully before trying to import the CSV files for the child objects. There are separate help topics describing how to import each of these child objects.

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

- You have completed all the prerequisites for importing each attribute in your source data.
- You have all parent records in place before importing child records.

Required Attributes and Validations for Incentive Rule Attribute Values Object
To import data successfully into Oracle Applications Cloud, your .CSV file must include the required attributes. Ensure that you provide valid values for the attributes.

This table lists the required attributes for Incentive Rule Attribute Value records, prerequisite setup tasks and specific validations, if any:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/ Import Validations</th>
<th>Creating an Incentive Rule Attribute Value record</th>
<th>Deleting an Existing Incentive Rule Attribute Value record</th>
</tr>
</thead>
<tbody>
<tr>
<td>RuleNumber</td>
<td>PUID of the rule</td>
<td>The rule number should exist.</td>
<td>A value is required, if the Name isn't provided.</td>
<td>A value is required, if the Name isn't provided.</td>
</tr>
<tr>
<td>Name</td>
<td>Name of the rule</td>
<td>The rule name should exist.</td>
<td>A value is required if the RuleNumber isn't provided.</td>
<td>A value is required if the RuleNumber isn't provided.</td>
</tr>
<tr>
<td>AttributeName</td>
<td>Name of the qualifier</td>
<td>The attribute should have been setup as a qualifier in the Manage Custom Qualifier setup task.</td>
<td>Required</td>
<td>Required</td>
</tr>
<tr>
<td>OperatorName</td>
<td>Name of the operator</td>
<td>This is validated for operators that are enabled while setting up the attribute as a qualifier in the Manage Custom Qualifier setup task.</td>
<td>Required</td>
<td>Required if deleting a value. Not Required if deleting the qualifier.</td>
</tr>
<tr>
<td>LowValueChar</td>
<td>Qualifying attribute value</td>
<td>This is validated for the value set, if defined during setup in the Manage Incentive DFF setup task.</td>
<td>Required</td>
<td>Required if deleting a value. Not Required if deleting the qualifier.</td>
</tr>
<tr>
<td>HighValueChar</td>
<td>Indicates a higher range of qualifying attribute value if the operator is “Between”</td>
<td>This is validated for the value set, if defined during setup in the Manage Incentive DFF setup task.</td>
<td>Required if the OperatorName is “Between”</td>
<td>Required if the OperatorName is “Between”</td>
</tr>
</tbody>
</table>
Create the Source CSV File

You include the data that you want to import into CX Sales and B2B Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator > Tools > Import Management > Import Objects.
2. Select the Incentive Rule Attribute Values object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note: For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity

After you have the CSV file ready, create an import activity to import the Incentive Rule Attribute Values information. To create an import activity:

1. Go to Navigator > Tools > Import Management > Import Incentive Rule Attribute Values.
2. On the Manage Imports page, click Create Import Activity.
3. In the Create Import Activity: Enter Import Options page, provide a name for the import activity, and select Incentive Rule Attribute Values from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results

Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to Navigator > Tools > Import Management > Import Incentive Rule Attribute Values.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed. You can drill down on the import activity to go to the Import Status page which provides the status details of the import activity.

Related Topics
- How You Use Alternate Keys to Import Records
- Potential Issues When Opening CSV Files in Excel

Import Your Incentive Rules Data

You can use the import functionality to create or update Incentive Rule records.

You can import Incentive Rule records using these steps:

1. Map your source data to Oracle Applications Cloud object attributes. This way the import process would know where to insert each of the information bits.
2. Create the source CSV file with the Incentive Rule data you want to import.
4. Check the import results to know if the import went well.

How You Map Your Source Data to Target Object Attributes

You import Incentive Rule data into Oracle Applications Cloud from a CSV file containing your source data that's mapped to target Oracle Applications Cloud object attributes.

Before you create the source data file, you should:

- Know how your source data attributes map to the target object attributes in Oracle Applications Cloud. Match each column from the source file to an attribute in the Incentive Rules import object.
- Finish all prerequisite steps, such as understanding what attributes are required for importing your objects.
- Know how you can uniquely identify the records.
- Check the target object attributes required in the CSV file for a successful import.
- Ensure that you don’t insert duplicate Incentive Rules while importing, to avoid redundant data.

If you want to import only a few records, then you can create a single CSV file for all Incentive Rules attributes. However if you want to import a large number of records, then you may decide to create multiple CSV files, one for each of the...
Incentive Rule child objects. Note that you must have imported the CSV file for Incentive Rules object successfully before trying to import the CSV files for the child objects. There are separate help topics describing how to import each of these child objects.

**Before You Start**

You must do some basic checks before starting your import. For example, make sure that:

- You have completed all the prerequisites for importing each attribute in your source data.
- You have all parent records in place before importing child records.

**Select a Unique Identifier for Your Records**

All records must be unique in the application. You can use the public unique identifier to identify records. If you're creating records, then you can provide an easily understandable public unique identifier. These are, usually, denoted with 'Number' and visible in the business object’s UI. PUID attributes are usually named <object> Number. If you're updating a record with a Number attribute, then use the Number attribute to identify the record. For more information about public unique identifiers, see the topic "How You Use Alternate Keys to Import Records" in Related Topics section.

**Required Attributes and Validations for Incentive Rules Object**

To import data successfully into Oracle Applications Cloud, your .CSV file must include the required attributes. Ensure that you provide valid values for the attributes.

This table lists the required attributes for Incentive Rule records, prerequisite setup tasks and specific validations, if any:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/ Import Validations</th>
<th>Creating an Incentive Rule record</th>
<th>Updating an Existing Incentive Rule record</th>
<th>Deleting an Existing Incentive Rule record</th>
</tr>
</thead>
</table>
| OrgName   | The name of the business unit                  | To find the business unit, navigate to the following in the Setup and Maintenance work area:  
  - Offering: Sales  
  - Function Area: Data Import and Export  
  - Task: Manage Business Units  
  In the Search results area, search for the name and select the name that's displayed. | Required | Required | Required |

397
<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/ Import Validations</th>
<th>Creating an Incentive Rule record</th>
<th>Updating an Existing Incentive Rule record</th>
<th>Deleting an Existing Incentive Rule record</th>
</tr>
</thead>
<tbody>
<tr>
<td>UsageName</td>
<td>Indicates the incentive rule usage</td>
<td>The valid values are:</td>
<td>Required</td>
<td>Required</td>
<td>Required</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Crediting</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Rollup Hierarchy</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Classification</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Participant Assignments</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Team</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Analyst Hierarchy</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>RuleNumber</td>
<td>PUID of the rule</td>
<td>None</td>
<td>Optional</td>
<td>A value is required if the Name isn't provided.</td>
<td>A value is required if the Name isn't provided.</td>
</tr>
<tr>
<td>Name</td>
<td>The name of the rule</td>
<td>None</td>
<td>Required</td>
<td>A value is required if the RuleNumber isn't provided.</td>
<td>A value is required if the RuleNumber isn't provided.</td>
</tr>
<tr>
<td>Description</td>
<td>A brief description of the rule</td>
<td>None</td>
<td>Optional</td>
<td>Optional</td>
<td>Optional</td>
</tr>
<tr>
<td>StartDate</td>
<td>The start date of the rule</td>
<td>This must be in the open period.</td>
<td>Required</td>
<td>Optional</td>
<td>Optional</td>
</tr>
<tr>
<td>EndDate</td>
<td>The end date of the rule</td>
<td>This must be in the open period.</td>
<td>Required</td>
<td>Optional</td>
<td>Optional</td>
</tr>
<tr>
<td>EnabledFlag</td>
<td>Option to either enable or disable the rule</td>
<td>Y or N</td>
<td>Optional</td>
<td>Optional</td>
<td>Optional</td>
</tr>
<tr>
<td>Rank</td>
<td>The rank of the rule</td>
<td>None</td>
<td>Optional</td>
<td>Optional</td>
<td>Optional</td>
</tr>
<tr>
<td>NumWinners</td>
<td>The number of winners for this rule.</td>
<td>None</td>
<td>Optional</td>
<td>Optional</td>
<td>Optional</td>
</tr>
</tbody>
</table>

**Note:**
Export the results to a spreadsheet. Use this information to identify and assign the business unit values to the data you're preparing.
### Import Your Data

#### Attribute | Description | Prerequisite Setup Task/ Import Validations | Creating an Incentive Rule record | Updating an Existing Incentive Rule record | Deleting an Existing Incentive Rule record
---|---|---|---|---|---
ParentRuleNumber | The rule number of the parent rule. | This must be an existing rule number or a rule number that's created in the same file. | Optional for the topmost rule in the hierarchy | Optional | Optional
ParentName | The rule name of the parent rule. | This must be an existing rule name or a rule name that's created in the same file. | Optional for the topmost rule, if the rule has no parent in the hierarchy | Optional | Optional
ActionCode | Indicates explicitly the operation to be performed on a row: • INSERT to create a new record in the destination tables • UPDATE to update an existing record in the destination table • DELETE to delete the record. | The value can be blank or one of the following: • UPDATE • DELETE • DELETE HIERARCHY | Optional | Optional | Required

Note: For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.
Create the Import Activity

After you have the CSV file ready, create an import activity to import the Incentive Rules information. To create an import activity:

1. Go to **Navigator > Tools > Import Management > Import Incentive Rules.**
2. On the **Manage Imports** page, click **Create Import Activity.**
3. In the **Create Import Activity: Enter Import Options** page, provide a name for the import activity, and select **Incentive Rules** from the **Object** drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you’re ready.

Review the Import Results

Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to Go to **Navigator > Tools > Import Management > Import Incentive Rules.**
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed. You can drill down on the import activity to go to the Import Status page which provides the status details of the import activity.

Related Topics

- How You Use Alternate Keys to Import Records
- Potential Issues When Opening CSV Files in Excel

Import Your Incentive Transaction Data

You can use the import functionality to create or update Incentive Transaction records.

To import Incentive Transaction records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (.csv) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes

To import your Incentive Transaction data into Oracle Applications Cloud, you need to populate a CSV file with your source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the .CSV file for data import:

- Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
Import Your Data

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

- You have completed all the prerequisites for importing each attribute in your source data.
- You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the import process to uniquely identify the records. The file import process uses the attribute values to automatically map your source data to the target object attributes in Oracle Applications Cloud.

The preferred option to uniquely identifying an object record is through the Internal ID. If you're identifying a record that already exists in Oracle Applications Cloud, then you can use the internal ID of the record, a system-generated unique identifier. Attributes with "id" in the attribute name are typically internal IDs. Use this option only if you're updating Incentive Transactions. You can determine the internal ID of a record by exporting Oracle Applications Cloud object data, or by doing a transactional database query. Using an internal ID typically provides better performance and reduces the import duration. For the Incentive Transaction object, the attributes are Transaction Number and Transaction Type.

Required Attributes and Validations for Incentive Transaction Object
To import data successfully into Oracle Applications Cloud, your .CSV file must include the required attributes. Ensure that you provide valid values for the attributes.

The following table lists the required attributes for importing new Incentive Transaction records, required attributes for updating Incentive Transaction records, prerequisite setup tasks for the attributes, and specific validations, if any, for Incentive Transaction import:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Data Type</th>
<th>Data Length</th>
<th>Prerequisite Setup Task/Import Validations</th>
<th>Creating a Incentive Transaction Record</th>
<th>Updating an Existing Incentive Transaction Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>Business Unit</td>
<td>Name of the business unit</td>
<td>Varchar2</td>
<td>240</td>
<td>To find the business unit:</td>
<td>Required</td>
<td>Required</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>1. Navigate to Setup and Maintenance.</td>
<td>A value is required either for the Business Unit or the Business Unit Id.</td>
<td>A value is required either for the Business Unit or the Business Unit Id.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>2. Navigate to the Manage Business Units task.</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>3. In the Search results region, search for</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Attribute</td>
<td>Description</td>
<td>Data Type</td>
<td>Data Length</td>
<td>Prerequisite Setup Task/Import Validations</td>
<td>Creating a New Incentive Transaction Record</td>
<td>Updating an Existing Incentive Transaction Record</td>
</tr>
<tr>
<td>---------------------</td>
<td>------------------------------------------------------------------------------</td>
<td>-----------</td>
<td>-------------</td>
<td>--------------------------------------------</td>
<td>---------------------------------------------</td>
<td>-----------------------------------------------</td>
</tr>
<tr>
<td>Business Unit ID</td>
<td>Unique numeric identifier for the Oracle Fusion Incentive Compensation business unit.</td>
<td>Number</td>
<td>18</td>
<td>the name and select the name that's displayed.</td>
<td>Required</td>
<td>Required</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Note: You can export the results to a spreadsheet and use this information to identify and assign the Business Unit values to the data that you're preparing.</td>
<td>Required</td>
<td>Required</td>
</tr>
<tr>
<td>Event Date</td>
<td>When the transaction triggers an incentive event associated with the row, for example,</td>
<td>Date</td>
<td></td>
<td>The period must be open before you can collect the transaction into the application.</td>
<td>Required</td>
<td>Required</td>
</tr>
</tbody>
</table>
### Understanding Import and Export Management for CX Sales and B2B Service

#### Chapter 8

**Import Your Data**

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Data Type</th>
<th>Data Length</th>
<th>Prerequisite Setup Task/Import Validations</th>
<th>Creating a Incentive Transaction Record</th>
<th>Updating an Existing Incentive Transaction Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>Transaction Amount</td>
<td>The transaction amount to be evaluated by the credit and earning processes.</td>
<td>Number</td>
<td></td>
<td>If providing a monetary amount, the amount should be in the currency of the source application.</td>
<td>Required</td>
<td>Required</td>
</tr>
<tr>
<td>Transaction Number</td>
<td>Unique transaction identifier used in the source application. The combination of Source Transaction Number and Transaction Type values must be unique, and is validated during the Collect Transactions process.</td>
<td>Varchar2</td>
<td>30</td>
<td>Map an identifier that end users recognize and can search. For example, map your source invoice number and invoice line number to this field.</td>
<td>Required</td>
<td>Required</td>
</tr>
<tr>
<td>Transaction Type</td>
<td>Defines the type of the transaction. Predefined transaction types are CLAWBACK, CUSTOMER_SATISFACTION, GRP, INVOICE, ITD, MANUAL, ORDER, PAYMENT, and RAM_ADJUSTMENT.</td>
<td>Varchar2</td>
<td>30</td>
<td>The value must be a valid lookup code for lookup type CN_TP_TRANSACTION_TYPE. To define your own transaction types: 1. In Setup and Maintenance, go to the Manage Incentive Compensation Lookups task. 2. Search for CN_TP_TRANSACTION_TYPE. 3. Add your transaction types.</td>
<td>Required</td>
<td>Required</td>
</tr>
</tbody>
</table>

You can view the Incentive Transaction object along with all its child objects and attributes in the Manage Import Objects page of the Import Management flow. You can find attribute information like type, length, description, and so on, on this page.
Create the Source CSV File

You include the data that you want to import into CX Sales and B2B Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator > Tools > Import Management > Import Objects.
2. Select the Incentive Transaction object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note: For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity

After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Incentive Transaction from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results

You can review the import results by checking for the import activity in the Manage Import Activity page. A file import activity is said to be successful when its status displays as Completed. To check the status of the import activity, do as follows:

1. In the Navigator, under Tools, click Import Management.
2. On the Manage Imports page, search for the import activity that you created using one of the search criteria, such as status, name, object, and so on.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed. The other valid values for the import activity status are Queued for import, Preparing data for import, Importing data, Completed with errors, and Unsuccessful.

Note: On this page you can also quickly view the number and status of all active imports, completed imports, and unsuccessful imports that have been submitted.

Related Topics

- Potential Issues When Opening CSV Files in Excel
- Import Data
Import Your Interaction Data

You can use the Import Management to create or update Interaction records.

To import Interaction records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (.csv) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes

To import your Interaction data into Oracle Applications Cloud, you need to populate a CSV file with your source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the .CSV file for data import:

- Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
- Ensure prerequisite steps are complete, such as understanding what attributes are required for importing your objects.
- Understand your options for uniquely identifying the records.
- Ensure parent records exist before importing child records.
- Identify the target object attributes that are required in the .csv file for a successful import.

Before You Start

You must do some basic checks before starting your import. For example, make sure that:

- You have completed all the prerequisites for importing each attribute in your source data.
- You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records

To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the import process to uniquely identify the records. The file import process uses the attribute values to automatically map your source data to the target object attributes in Oracle Applications Cloud.

The preferred options to uniquely identify an object record are as follows:

- **Internal ID**: If you're identifying a record that already exists in Oracle Applications Cloud, then you can use the internal ID of the record, a system-generated unique identifier. Attributes with "id" in the attribute name are typically internal IDs. You can determine the internal ID of a record by exporting Oracle Applications Cloud object data, or by doing a transactional database query. Using an internal ID typically provides better performance and reduces the import duration. For the Interaction object, this attribute is InteractionId:

- **Public unique identifiers**: If you're creating new records, then you can provide a user-friendly public unique identifier (attributes denoted with 'Number' and usually visible in the business object's UI). If you update a record for which you have previously provided a Number attribute, or for which a Number attribute is visible in
the object’s UI, you can use the Number attribute to identify the record. For the Interaction object, the attribute is InteractionNumber.

## Required Attributes and Validations for Interaction Object

To import data successfully into Oracle Applications Cloud, your `.csv` file must include the required attributes. Ensure that you provide valid values for the attributes.

The following table lists the required attributes for importing new Interaction records, required attributes for updating Interaction records, prerequisite setup tasks for the attributes, and specific validations, if any, for Interaction import:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Data Type</th>
<th>Data Length</th>
<th>Prerequisite Setup Task/Import Validations</th>
<th>Creating an Interaction Record</th>
<th>Updating an Existing Interaction Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>InteractionId</td>
<td>The unique identifier of the interaction</td>
<td>Long</td>
<td>18</td>
<td>None</td>
<td>Not required</td>
<td>Required</td>
</tr>
<tr>
<td>InteractionNumber</td>
<td>The Public Unique Identifier of the interaction</td>
<td>Varchar</td>
<td>30</td>
<td>None</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>ChannelId</td>
<td>The unique identifier of the interaction channel</td>
<td>Long</td>
<td>18</td>
<td>The referenced record must exist.</td>
<td>Required</td>
<td>Not Required</td>
</tr>
<tr>
<td>StripeCd</td>
<td>The code indicating the stripe of the interaction. A list of valid values is defined in the lookup ORA_SVC_STRIPE_CD.</td>
<td>Varchar2</td>
<td>30</td>
<td>None</td>
<td>Not required</td>
<td>Required</td>
</tr>
<tr>
<td>StatusCd</td>
<td>The current status of the interaction. Interactions are either in the ORA_SVC_OPEN or ORA_SVC_CLOSED status.</td>
<td>Varchar</td>
<td>30</td>
<td>Default “ORA_SVC_OPEN”</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>DirectionCd</td>
<td>The code indicating whether the interaction is inbound or outbound. The default value is ORA_SVC_INBOUND, indicating inbound interactions. The value is ORA_SVC_INBOUND.</td>
<td>Varchar</td>
<td>30</td>
<td>Default “ORA_SVC_INBOUND”</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>Attribute</td>
<td>Description</td>
<td>Data Type</td>
<td>Data Length</td>
<td>Prerequisite Setup Task/ Import Validations</td>
<td>Creating an Interaction Record</td>
<td>Updating an Existing Interaction Record</td>
</tr>
<tr>
<td>----------------------</td>
<td>-----------------------------------------------------------------------------</td>
<td>-----------</td>
<td>-------------</td>
<td>---------------------------------------------</td>
<td>-------------------------------</td>
<td>--------------------------------------------</td>
</tr>
<tr>
<td>ParentInteractionId</td>
<td>The unique identifier of the parent interaction.</td>
<td>Long</td>
<td>18</td>
<td>The referenced record must exist, if included.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>Description</td>
<td>The brief description of the interaction</td>
<td>Long</td>
<td>1000</td>
<td>None</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>AccountPartyId</td>
<td>The unique identifier of the account associated with the interaction</td>
<td>Long</td>
<td>18</td>
<td>The referenced record must exist, if included.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>ContactPartyId</td>
<td>The unique identifier of the contact associated with the interaction</td>
<td>Long</td>
<td>18</td>
<td>The referenced record must exist, if included.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>OwnerResourceId</td>
<td>The unique identifier of the owner of the interaction</td>
<td>Long</td>
<td>18</td>
<td>The referenced record must exist, if included.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>MediaItemId</td>
<td>The unique identifier for the media item</td>
<td>Long</td>
<td>18</td>
<td>The referenced record must exist, if included.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>StartTime</td>
<td>The time when the interaction becomes active</td>
<td>Date Time</td>
<td>None</td>
<td>None</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td>EndTime</td>
<td>The time when the interaction becomes inactive</td>
<td>Date Time</td>
<td>None</td>
<td>None</td>
<td>A value is required if the status is &quot;ORA_SVC_CLOSED&quot;.</td>
<td>Not required</td>
</tr>
<tr>
<td>OriginalSystemRefer</td>
<td>The system reference used by the interaction</td>
<td>Varchar</td>
<td>255</td>
<td>None</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>SubStatusCd</td>
<td>The code indicating the sub-status of the interaction. A list of valid values is defined</td>
<td>Varchar</td>
<td>30</td>
<td>None</td>
<td>Not required</td>
<td>Not required</td>
</tr>
</tbody>
</table>
### Create the Source CSV File

You include the data that you want to import into CX Sales and B2B Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to **Navigator > Tools > Import Management > Import Objects**.
2. Select the **Interaction** object in the table and click **Download**.

You can now edit the downloaded file and provide valid values for the required attributes.

**Note:** For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.

### Create the Import Activity

After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to **Navigator > Tools > Import Management > Import Queue**.
2. Click **Create Import Activity** in the Manage Imports page.
3. In the **Enter Import Options** page, provide a name for the import activity, and select Interaction from the **Object** drop-down list.
4. Select the CSV file in the **File Name** field, and click **Next**.
5. You would see that the source and target attributes are automatically mapped in the **Map Fields** page. Review and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking **Validate Data**. Click **Next**.
7. Review the import details on the **Review and Submit** page, and click **Submit** when you’re ready.

### Review the Import Results

Check if your import succeeded on the **Manage Imports** page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to **Navigator > Tools > Import Management > Import Queue**.

---

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Data Type</th>
<th>Data Length</th>
<th>Prerequisite Setup Task/ Import Validations</th>
<th>Creating an Interaction Record</th>
<th>Updating an Existing Interaction Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>QueueId</td>
<td>The unique identifier of the interaction queue</td>
<td>Long</td>
<td>18</td>
<td>The referenced record must exist, if included.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>AgentHTTPSessionId</td>
<td>The HTTP session Id of the agent</td>
<td>Varchar</td>
<td>100</td>
<td>None</td>
<td>Not required</td>
<td>Not required</td>
</tr>
</tbody>
</table>
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.
   You can drill down on the import activity to go to the Import Status page which provides the status details of the import activity.

Related Topics
- Potential Issues When Opening CSV Files in Excel
- Import Data

Import Your Interaction Reference Data

You can use Import Management to create Interaction Reference records.

To import Interaction Reference records, perform the following tasks:
1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes

To import your Interaction Reference data into Oracle Applications Cloud, you need to populate a CSV file with your source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:
- Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
- Ensure prerequisite setups are done, if applicable.
- Understand your options for uniquely identifying the records.
- Ensure parent records exist before importing child records.
- Identify the target object attributes that are required in the CSV file for a successful import.

Before You Start

You must do some basic checks before starting your import. For example, make sure that:
- You have completed all the prerequisites for importing each attribute in your source data.
- You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records

All records must be unique in the application. You can use one of these to identify records:
- Public unique identifiers: If you’re creating records, then you can provide an easily understandable public unique identifier. These are, usually, denoted with ‘Number’ and visible in the business object's UI. PUID
attributes are usually named <object> Number. For more information about public unique identifiers, see the topic "How You Use Alternate Keys to Import Records" in Related Topics section.

- Source system and source system reference: Source system is an identifier for the external system, and source system reference is a unique identifier within the external system. If you're importing new interaction references that have source system reference data, then provide the source system and source system reference values.

### Required Attributes and Validations for Interaction Reference Object

To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure that you provide valid values for the attributes. This table lists the required attributes for importing new Interaction Reference records, prerequisite setup tasks for the attributes, and specific validations, if any, for Interaction Reference import:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task / Import Validations</th>
<th>Creating a Interaction Reference Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>ReferenceId</td>
<td>The unique identifier of the interaction reference.</td>
<td>No validation</td>
<td>Required</td>
</tr>
<tr>
<td>ObjectTypeCd</td>
<td>The code that indicates the object type present in the interaction reference.</td>
<td>If a service request interaction reference (ObjectId) is imported, then both the interaction and the service request records must exist before the import process. Valid values: SVC_SERVICE_REQUESTS, SVC_CHATS, MOO_OPTY, MKL_LM_LEADS, ZMM_ACTY_ACTIVITIES, SVC_WORK_ORDERS</td>
<td>Required</td>
</tr>
<tr>
<td>ObjectId</td>
<td>The unique identifier of the object associated with the interaction reference.</td>
<td>If a service request interaction reference (ObjectId) is imported, then both the interaction and the service request records must exist before the import process. Either the ObjectId or the ObjectNumber is required. If both are present, then the ObjectId is preferred.</td>
<td>Either the ObjectId or the ObjectNumber is required. If both are present, then the ObjectId is preferred.</td>
</tr>
<tr>
<td>InteractionId</td>
<td>The unique identifier of the interaction.</td>
<td>An interaction record must exist before an interaction reference can be created/imported.</td>
<td>Either the InteractionId or the InteractionNumber is required. If both are present, then the InteractionId is preferred.</td>
</tr>
<tr>
<td>InteractionNumber</td>
<td>The public unique identifier of the interaction.</td>
<td>No validation</td>
<td>Either the InteractionId or the InteractionNumber is required. If both are present, then the InteractionId is preferred.</td>
</tr>
<tr>
<td>ObjectNumber</td>
<td>The public unique identifier of the object associated with the interaction reference.</td>
<td>If a service request interaction reference (ObjectId) is imported, then both the interaction and the service request records must exist before the import process. Either the ObjectId or the ObjectNumber is required. If both are present, then the ObjectId is preferred.</td>
<td>Either the ObjectId or the ObjectNumber is required. If both are present, then the ObjectId is preferred.</td>
</tr>
</tbody>
</table>
Chapter 8
Import Your Data

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/ Import Validations</th>
<th>Creating a Interaction Reference Record</th>
</tr>
</thead>
</table>

**Note:** Update operation isn’t supported for interaction reference records.

You can view the Interaction Reference object along with all its child objects and attributes in the Manage Import Objects page of the Import Management flow. You can find attribute information like type, length, description, and so on, on this page.

Create the Source CSV File
You include the data that you want to import into CX Sales and B2B Service in a source CSV file.
You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator > Tools > Import Management > Import Objects.
2. Select the Interaction Reference object in the table and click Download.
You can now edit the downloaded file and provide valid values for the required attributes.

**Note:** For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the information. To create an import activity:

2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Interaction Reference from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
   You would see that the source and target attributes are automatically mapped in the Map Fields page. Review and edit the mappings if required.
5. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
6. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed. You can drill down on the import activity to go to the Import Status page which provides the status details of the import activity.
Import Your Marketing Development Funds (MDF) Budget Data

You can use import management to create or update MDF Budget records.

To import MDF Budget records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes

To import your Marketing Development Funds (MDF) Budget data into Oracle Applications Cloud, you need to populate a CSV file with your source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

- Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
- Ensure prerequisite setups are done, if applicable.
- Understand your options for uniquely identifying the records.
- Ensure parent records exist before importing child records.
- Identify the target object attributes that are required in the CSV file for a successful import.

Before You Start

You must do some basic checks before starting your import. For example, make sure that:

- You have completed all the prerequisites for importing each attribute in your source data.
- You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records

To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the import process to uniquely identify the records. The file import process uses the attribute values to automatically map your source data to the target object attributes in Oracle Applications Cloud.
The preferred options to uniquely identify an object record are as follows:

- **Internal ID**: If you’re identifying a record that already exists in Oracle Applications Cloud, then you can use the internal ID of the record, a system-generated unique identifier. Attributes with “id” in the attribute name are typically internal IDs. Use this option only if you’re updating MDF Budgets. You can determine the internal ID of a record by exporting Oracle Applications Cloud object data, or by doing a transactional database query. Using an internal ID typically provides better performance and reduces the import duration. For the MDF Budget object, the attributes are Budget Id and Owner Id.

- **Public unique identifiers**: If you’re creating new records, then you can provide a user-friendly public unique identifier (attributes denoted with ‘Number’ and usually visible in the business object’s UI). If you update a record for which you have previously provided a Number attribute, or for which a Number attribute is visible in the object’s UI, you can use the Number attribute to identify the record. For the MDF Budget object, the attributes are Owner Party Number and Company Party Number.

### Required Attributes and Validations for MDF Budget Object

To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure that you provide valid values for the attributes. This table lists the required attributes for importing new MDF Budget records, required attributes for updating MDF Budget records, prerequisite setup tasks for the attributes, and specific validations, if any, for MDF Budget import:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/ Import Validations</th>
<th>Creating a MDF Budget Record</th>
<th>Updating an Existing MDF Budget Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>BudgetID</td>
<td>System generated unique identifier.</td>
<td>None</td>
<td>Not required</td>
<td>Required</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>MDF budgets can be imported if they're in the following status: Draft, Active, or Inactive.</td>
<td></td>
</tr>
<tr>
<td>Start Date</td>
<td>The date after which the MDF budget can be activated any time.</td>
<td>If provided, this must be before the end date.</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td>Claim Deadline</td>
<td>Specifies the date by which claims should be submitted.</td>
<td>If provided, this must be equal to or greater than the end date.</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td>Request Deadline</td>
<td>Specifies the date by which fund requests should be submitted.</td>
<td>If provided, this must be between the start date and the end date.</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td>OwnerID</td>
<td>Identifies the owner of the MDF budget</td>
<td>None</td>
<td>Required</td>
<td>Required</td>
</tr>
<tr>
<td>Owner</td>
<td>Identifies the owner name of the MDF budget</td>
<td>None</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>Partner</td>
<td>Identifies the partner associated with the MDF budget</td>
<td>This is applicable only when the MDF budget type</td>
<td>Not required</td>
<td>Not required</td>
</tr>
</tbody>
</table>
### Attribute List

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/ Import Validations</th>
<th>Creating a MDF Budget Record</th>
<th>Updating an Existing MDF Budget Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>OwnerPartyNumber</td>
<td>Identifies the owner's party number of the MDF budget</td>
<td>None</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>PartnerCompanyNumber</td>
<td>The unique identifier of the partner associated with the MDF Budget</td>
<td>This is applicable only when the MDF budget type is &quot;Discretionary- Single Partner&quot;.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>Name</td>
<td>Specifies the name of the MDF budget.</td>
<td>None</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td>Currency</td>
<td>Specifies the transaction currency for MDF budget amounts</td>
<td>If providing a value, the value must exist in the CURRENCY_CODE column of the FND_CURRENCIES_VL table. You can view valid currency codes. Navigate to the following in the Setup and Maintenance work area:</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td>Initial Amount</td>
<td>Specifies the initial amount allocated to the MDF budget.</td>
<td>None</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td>Status</td>
<td>Current status for the Budget such as Draft, Active, or Inactive.</td>
<td>None</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td>Code</td>
<td>Unique identifier of an MDF budget.</td>
<td>None</td>
<td>Conditionally required, if you're providing a budget name for a new MDF budget.</td>
<td>Required if updating an existing budget and you aren't providing the unique Id of the MDF budget.</td>
</tr>
</tbody>
</table>

You can view the MDF Budget object along with all its child objects and attributes in the Manage Import Objects page of the Import Management flow. You can find attribute information like type, length, description, and so on, on this page.

### Create the Source CSV File

You include the data that you want to import into CX Sales and B2B Service in a source CSV file.
You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to **Navigator > Tools > Import Management > Import Objects**.
2. Select the **MDF Budget** object in the table and click **Download**.

You can now edit the downloaded file and provide valid values for the required attributes.

**Note:** For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity

After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to **Navigator > Tools > Import Management > Import Queue**.
2. Click **Create Import Activity** in the **Manage Imports** page.
3. In the **Enter Import Options** page, provide a name for the import activity, and select MDF Budget from the **Object** drop-down list.
4. Select the CSV file in the **File Name** field, and click **Next**.
5. You would see that the source and target attributes are automatically mapped in the **Map Fields** page. Review and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking **Validate Data**. Click **Next**.
7. Review the import details on the **Review and Submit** page, and click **Submit** when you're ready.

Review the Import Results

Check if your import succeeded on the **Manage Imports** page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to **Navigator > Tools > Import Management > Import Queue**.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the **Status** column for the import activity. The import is successful if the status displays as **Completed**. You can drill down on the import activity to go to the **Import Status** page which provides the status details of the import activity.

**Related Topics**
- Potential Issues When Opening CSV Files in Excel
- Import Data

Import Your MDF Budget Countries Data

You can use import management to create or update MDF Budget Countries records.

To import MDF Budget Countries records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
How You Map Your Source Data to Target Object Attributes

To import your MDF Budget Countries data into Oracle Applications Cloud, you need to populate a CSV file with your source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

- Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
- Ensure prerequisite setups are done, if applicable.
- Understand your options for uniquely identifying the records.
- Ensure parent records exist before importing child records.
- Identify the target object attributes that are required in the CSV file for a successful import.

Before You Start

You must do some basic checks before starting your import. For example, make sure that:

- You have completed all the prerequisites for importing each attribute in your source data.
- You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records

To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the import process to uniquely identify the records. The file import process uses the attribute values to automatically map your source data to the target object attributes in Oracle Applications Cloud.

The preferred option to uniquely identify an object record is through the Internal ID. If you're identifying a record that already exists in Oracle Applications Cloud, then you can use the internal ID of the record, a system-generated unique identifier. Attributes with "id" in the attribute name are typically internal IDs. Use this option only if you're updating MDF Budget Countries. You can determine the internal ID of a record by exporting Oracle Applications Cloud object data, or by doing a transactional database query. Using an internal ID typically provides better performance and reduces the import duration. For the MDF Budget Countries object, the attribute is BudgetCountryID.

Required Attributes and Validations for MDF Budget Countries Object

To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure that you provide valid values for the attributes. This table lists the required attributes for importing new MDF Budget Countries records, required attributes for updating MDF Budget Countries records, prerequisite setup tasks for the attributes, and specific validations, if any, for MDF Budget Countries import:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/ Import Validations</th>
<th>Creating a MDF Budget Countries Record</th>
<th>Updating an Existing MDF Budget Countries Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>Budget CountryID</td>
<td>Specifies the budget country associated with the MDF budget</td>
<td>None</td>
<td>Required</td>
<td>A value is required, if changing from one country to another and the country code isn't provided.</td>
</tr>
</tbody>
</table>

416
Create the Source CSV File

You include the data that you want to import into CX Sales and B2B Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator > Tools > Import Management > Import Objects.
2. Select the MDF Budget Countries object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

**Note:** For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity

After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select MDF Budget Countries from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results

Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the **Status** column for the import activity. The import is successful if the status displays as **Completed**. You can drill down on the import activity to go to the **Import Status** page which provides the status details of the import activity.

**Related Topics**
- Potential Issues When Opening CSV Files in Excel
- Import Data

**Import Your MDF Budget Team Data**

You can use import management to create or update MDF Budget Team records.

To import MDF Budget Team records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

**How You Map Your Source Data to Target Object Attributes**

To import your MDF Budget Team data into Oracle Applications Cloud, you need to populate a CSV file with your source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

- Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
- Ensure prerequisite setups are done, if applicable.
- Understand your options for uniquely identifying the records.
- Ensure parent records exist before importing child records.
- Identify the target object attributes that are required in the CSV file for a successful import.

**Before You Start**

You must do some basic checks before starting your import. For example, make sure that:

- You have completed all the prerequisites for importing each attribute in your source data.
- You have all parent records in place before importing child records.

**Select a Unique Identifier for Your Records**

To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the import process to uniquely identify the records. The file import process uses the attribute values to automatically map your source data to the target object attributes in Oracle Applications Cloud.
The preferred options to uniquely identify an object record are as follows:

- **Internal ID**: If you're identifying a record that already exists in Oracle Applications Cloud, then you can use the internal ID of the record, a system-generated unique identifier. Attributes with "id" in the attribute name are typically internal IDs. Use this option only if you're updating MDF Budget Teams. You can determine the internal ID of a record by exporting Oracle Applications Cloud object data, or by doing a transactional database query. Using an internal ID typically provides better performance and reduces the import duration. For the MDF Budget Team object, the attributes are Budget Team Id and Budget Id.

- **Public unique identifiers**: If you're creating new records, then you can provide a user-friendly public unique identifier (attributes denoted with 'Number' and usually visible in the business object’s UI). If you update a record for which you have previously provided a Number attribute, or for which a Number attribute is visible in the object’s UI, you can use the Number attribute to identify the record. For the MDF Budget Team object, the attribute is Resource Party Number.

## Required Attributes and Validations for MDF Budget Team Object

To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure that you provide valid values for the attributes. This table lists the required attributes for importing new MDF Budget Team records, required attributes for updating MDF Budget Team records, prerequisite setup tasks for the attributes, and specific validations, if any, for MDF Budget Team import:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/Import Validations</th>
<th>Creating a MDF Budget Team Record</th>
<th>Updating an Existing MDF Budget Team Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>Budget Team ID</td>
<td>This is a system generated unique identifier to identify the MDF budget team.</td>
<td>None</td>
<td>Required</td>
<td>Required</td>
</tr>
<tr>
<td>Resource Party Number</td>
<td>Identifies the budget team resource</td>
<td>None</td>
<td>Required</td>
<td>Required</td>
</tr>
<tr>
<td>Code</td>
<td>Unique identifier of an MDF budget</td>
<td>None</td>
<td>Required</td>
<td>Required</td>
</tr>
<tr>
<td>Budget ID</td>
<td>Specifies the MDF budget to which the budget team is associated</td>
<td>None</td>
<td>Not required</td>
<td>Required</td>
</tr>
</tbody>
</table>

You can view the MDF Budget Team object along with all its child objects and attributes in the Manage Import Objects page of the Import Management flow. You can find attribute information like type, length, description, and so on, on this page.

## Create the Source CSV File

You include the data that you want to import into CX Sales and B2B Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to **Navigator > Tools > Import Management > Import Objects**.
2. Select the **MDF Budget Team** object in the table and click **Download**.
You can now edit the downloaded file and provide valid values for the required attributes.

**Note:** For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.

**Create the Import Activity**

After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to **Navigator > Tools > Import Management > Import Queue.**
2. Click **Create Import Activity** in the **Manage Imports** page.
3. In the **Enter Import Options** page, provide a name for the import activity, and select MDF Budget Team from the **Object** drop-down list.
4. Select the CSV file in the **File Name** field, and click **Next.**
5. You would see that the source and target attributes are automatically mapped in the **Map Fields** page. Review and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking **Validate Data.** Click **Next.**
7. Review the import details on the **Review and Submit** page, and click **Submit** when you're ready.

**Review the Import Results**

Check if your import succeeded on the **Manage Imports** page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to **Navigator > Tools > Import Management > Import Queue.**
2. Click All Imports and search for the import activity that you created earlier.
3. Check the **Status** column for the import activity. The import is successful if the status displays as **Completed.**
   You can drill down on the import activity to go to the **Import Status** page which provides the status details of the import activity.

**Import Your MDF Claim Data**

You can use import management to create or update MDF Claim records.

To import MDF Claim records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.
How You Map Your Source Data to Target Object Attributes

To import your MDF Claim data into Oracle Applications Cloud, you need to populate a CSV file with your source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

- Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
- Ensure prerequisite setups are done, if applicable.
- Understand your options for uniquely identifying the records.
- Ensure parent records exist before importing child records.
- Identify the target object attributes that are required in the CSV file for a successful import.

Before You Start

You must do some basic checks before starting your import. For example, make sure that:

- You have completed all the prerequisites for importing each attribute in your source data.
- You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records

To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the import process to uniquely identify the records. The file import process uses the attribute values to automatically map your source data to the target object attributes in Oracle Applications Cloud.

The preferred options to uniquely identify an object record are as follows:

- Internal ID: If you're identifying a record that already exists in Oracle Applications Cloud, then you can use the internal ID of the record, a system-generated unique identifier Attributes with "id" in the attribute name are typically internal IDs. Use this option only if you're updating MDF Claims. You can determine the internal ID of a record by exporting Oracle Applications Cloud object data, or by doing a transactional database query. Using an internal ID typically provides better performance and reduces the import duration. For the MDF Claim object, the attributes are Claim ID, Fund Request ID, and Owner ID.

- Public unique identifiers: If you're creating new records, then you can provide a user-friendly public unique identifier (attributes denoted with ‘Number’ and usually visible in the business object’s UI). If you update a record for which you have previously provided a Number attribute, or for which a Number attribute is visible in the object’s UI, you can use the Number attribute to identify the record. For the MDF Claim object, the attribute is Owner Party Number.

Required Attributes and Validations for MDF Claim Object

To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure that you provide valid values for the attributes. This table lists the required attributes for importing new MDF Claim records, required attributes for updating MDF Claim records, prerequisite setup tasks for the attributes, and specific validations, if any, for MDF Claim import:
<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/Import Validations</th>
<th>Creating a MDF Claim Record</th>
<th>Updating an Existing MDF Claim Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>Claim ID</td>
<td>This is a system generated unique identifier to identify the MDF Claim.</td>
<td>This is automatically derived from the import process when you import a new MDF claim.</td>
<td>Not required</td>
<td>A value is required if you're not providing an identifier for the MDF claim.</td>
</tr>
<tr>
<td>Fund Request Code</td>
<td>Unique fund request identifier</td>
<td>If provided, the Status Code of the FundRequestCode must be either Approved or Terminated.</td>
<td>A value is required when importing a new MDF claim and you're not providing the unique identifier of the request.</td>
<td>Not required</td>
</tr>
<tr>
<td>Owner Party Number</td>
<td>A unique public identifier for the owner number</td>
<td>None</td>
<td>Conditionally required</td>
<td>Conditionally required when updating the owner of an MDF claim, provide either the Owner ID or the Owner Party Number.</td>
</tr>
<tr>
<td>Budget</td>
<td>Identifies the MDF budget associated with the claim</td>
<td>None</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>Fund Request ID</td>
<td>Identifies the fund request to which the MDF claim is associated</td>
<td>If provided, the Status Code of the fund request ID must be Approved or Terminated.</td>
<td>A value is required when importing a new MDF claim with any Status Code.</td>
<td>Not required</td>
</tr>
<tr>
<td>Name</td>
<td>Identifies the name of the MDF claim</td>
<td>None</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td>Currency</td>
<td>The code that represents the currency for the MDF claim</td>
<td>None</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>Requested Amount</td>
<td>Specifies the amount for the MDF claim</td>
<td>None</td>
<td>Required</td>
<td>A value is required when updating the requested amount of an MDF claim with Status Code Draft or Returned.</td>
</tr>
<tr>
<td>MDF Request</td>
<td>Specifies the name for the fund request</td>
<td>None</td>
<td>A value is required when importing a new MDF claim.</td>
<td>Not required</td>
</tr>
<tr>
<td>Owner ID</td>
<td>Identifies the owner for the MDF claim</td>
<td>None</td>
<td>Conditionally required</td>
<td>Conditionally required when updating the owner of an MDF claim, provide either the Owner ID or the Owner Party Number.</td>
</tr>
<tr>
<td>Owner</td>
<td>Identifies the owner of the MDF claim</td>
<td>None</td>
<td>Required</td>
<td>Not required</td>
</tr>
</tbody>
</table>
You can view the MDF Claim object along with all its child objects and attributes in the Manage Import Objects page of the Import Management flow. You can find attribute information like type, length, description, and so on, on this page.

**Note:** When you create a record in the "Draft" status, it can't be moved directly to a terminal status such as "Approved", "Rejected", "Terminated", "Withdrawn" or "Returned". It should be converted from the "Draft" status to the OOTB defined status "Pending Approval" before it can be moved to a terminal status. You can create a record in any status except "Pending Approval".

### Create the Source CSV File

You include the data that you want to import into CX Sales and B2B Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to **Navigator > Tools > Import Management > Import Objects**.
2. Select the **MDF Claim** object in the table and click **Download**.

You can now edit the downloaded file and provide valid values for the required attributes.

**Note:** For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.

### Create the Import Activity

After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to **Navigator > Tools > Import Management > Import Queue**.
2. Click **Create Import Activity** in the **Manage Imports** page.
Chapter 8
Import Your Data

3. In the **Enter Import Options** page, provide a name for the import activity, and select MDF Claim from the **Object** drop-down list.
4. Select the CSV file in the **File Name** field, and click **Next**.
5. You would see that the source and target attributes are automatically mapped in the **Map Fields** page. Review and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking **Validate Data**. Click **Next**.
7. Review the import details on the **Review and Submit** page, and click **Submit** when you're ready.

Review the Import Results

Check if your import succeeded on the **Manage Imports** page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to **Navigator** > **Tools** > **Import Management** > **Import Queue**.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the **Status** column for the import activity. The import is successful if the status displays as **Completed**. You can drill down on the import activity to go to the **Import Status** page which provides the status details of the import activity.

Related Topics
- Potential Issues When Opening CSV Files in Excel
- Import Data

Import Your MDF Claim Settlement Data

You can use import management to create or update MDF Claim Settlement records.

To import MDF Claim Settlement records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes

To import your MDF Claim Settlement data into Oracle Applications Cloud, you need to populate a CSV file with your source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

- Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
- Ensure prerequisite setups are done, if applicable.
- Understand your options for uniquely identifying the records.
- Ensure parent records exist before importing child records.
- Identify the target object attributes that are required in the CSV file for a successful import.
Before You Start
You must do some basic checks before starting your import. For example, make sure that:

- You have completed all the prerequisites for importing each attribute in your source data.
- You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the import process to uniquely identify the records. The file import process uses the attribute values to automatically map your source data to the target object attributes in Oracle Applications Cloud.

The preferred options to uniquely identify an object record are as follows:

- Internal ID: If you're identifying a record that already exists in Oracle Applications Cloud, then you can use the internal ID of the record, a system-generated unique identifier Attributes with "id" in the attribute name are typically internal IDs. Use this option only if you're updating MDF Claim Settlements. You can determine the internal ID of a record by exporting Oracle Applications Cloud object data, or by doing a transactional database query. Using an internal ID typically provides better performance and reduces the import duration. For the MDF Claim Settlement object, the attributes are Claim Settlement ID and Claim ID.

- Public unique identifiers: If you're creating new records, then you can provide a user-friendly public unique identifier (attributes denoted with 'Number' and usually visible in the business object's UI). If you update a record for which you have previously provided a Number attribute, or for which a Number attribute is visible in the object’s UI, you can use the Number attribute to identify the record. For the MDF Claim Settlement object, the attribute is ClaimSettlementCode.

Required Attributes and Validations for MDF Claim Settlement Object
To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure that you provide valid values for the attributes. This table lists the required attributes for importing new MDF Claim Settlement records, required attributes for updating MDF Claim Settlement records, prerequisite setup tasks for the attributes, and specific validations, if any, for MDF Claim Settlement import:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/Import Validations</th>
<th>Creating a MDF Claim Settlement Record</th>
<th>Updating an Existing MDF Claim Settlement Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>Claim Settlement ID</td>
<td>System generated unique claim settlement identifier</td>
<td>This is automatically derived from the import process when importing a new MDF claim settlement.</td>
<td>Not required</td>
<td>A value is required if you're not providing another identifier for the MDF claim settlement.</td>
</tr>
<tr>
<td>Type</td>
<td>Specifies the type of transaction for the MDF claim settlement</td>
<td>None</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td>Accounting Type</td>
<td>Specifies the type of MDF claim settlement - Credit or Debit. This is for reference only, as the MDF claim settlements doesn’t have</td>
<td>This is derived when the payment type is selected. Accounting Type = Credit if Payment Type is Payment.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
</tbody>
</table>
### Attribute Description

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/Import Validations</th>
<th>Creating a MDF Claim Settlement Record</th>
<th>Updating an Existing MDF Claim Settlement Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>Status</td>
<td>Specifies the current status of the MDF claim settlement</td>
<td>The default value is Incomplete.</td>
<td>Required</td>
<td>Not required</td>
</tr>
</tbody>
</table>
| Currency                   | Transaction currency for the claim amount         | If providing a value, the value must exist in the CURRENCY_CODE column of the FND_CURRENCIES_VL table. You can view the valid currency codes. Navigate to the following in the Setup and Maintenance work area:  
  - Offering: Sales  
  - Functional Area: Data Import and Export  
  - Task: Manage Currencies | A value is required when importing a new MDF claim with any Status Code. | A value is required when updating an MDF claim with Status Code Draft or Returned. |
| Amount                     | Specifies the amount being settled in the MDF claim settlement | This amount can’t exceed the outstanding claim liability.                                                 | Required                               | A value is required if updating an existing MDF claim settlement with the Status Code Incomplete. |
| Claim ID                   | System generated unique identifier                | If provided, the Status Code must be either Approved or Terminated.                                       | A value is required when importing an MDF claim settlement with any Status Code. | Not required                                      |
| Claim Code                 | Specifies a unique claim identifier               | If provided, the Status Code of the Claim Code must be either Approved or Terminated.                     | A value is required when importing a new MDF claim settlement and you’re not providing the unique identifier of the MDF claim. | Not required                                      |
| Claim Settlement Code      | Specifies the unique identifier for MDF claim settlements | None                                                                                                       | Not required                           | A value is required if updating an existing MDF claim settlement and you’re not providing any other identifier for the MDF claim settlement. |

You can view the MDF Claim Settlement object along with all its child objects and attributes in the Manage Import Objects page of the Import Management flow. You can find attribute information like type, length, description, and so on, on this page.
Create the Source CSV File
You include the data that you want to import into CX Sales and B2B Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator > Tools > Import Management > Import Objects.
2. Select the MDF Claim Settlement object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note: For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select MDF Claim Settlement from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed. You can drill down on the import activity to go to the Import Status page which provides the status details of the import activity.

Related Topics
- Potential Issues When Opening CSV Files in Excel
- Import Data

Import Your MDF Claim Team Data
You can use import management to create or update MDF Claim Team records.
To import MDF Claim Team records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes

To import your MDF Claim Team data into Oracle Applications Cloud, you need to populate a CSV file with your source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

- Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
- Ensure prerequisite setups are done, if applicable.
- Understand your options for uniquely identifying the records.
- Ensure parent records exist before importing child records.
- Identify the target object attributes that are required in the CSV file for a successful import.

Before You Start

You must do some basic checks before starting your import. For example, make sure that:

- You have completed all the prerequisites for importing each attribute in your source data.
- You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records

To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the import process to uniquely identify the records. The file import process uses the attribute values to automatically map your source data to the target object attributes in Oracle Applications Cloud.

The preferred options to uniquely identify an object record are as follows:

- Internal ID: If you're identifying a record that already exists in Oracle Applications Cloud, then you can use the internal ID of the record, a system-generated unique identifier. Attributes with "id" in the attribute name are typically internal IDs. Use this option only if you're updating MDF Claim Teams. You can determine the internal ID of a record by exporting Oracle Applications Cloud object data, or by doing a transactional database query. Using an internal ID typically provides better performance and reduces the import duration. For the MDF Claim Team object, the attributes are Claim Resource ID, Resource ID, and Claim ID.

- Public unique identifiers: If you're creating new records, then you can provide a user-friendly public unique identifier (attributes denoted with 'Number' and usually visible in the business object's UI). If you update a record for which you have previously provided a Number attribute, or for which a Number attribute is visible in the object's UI, you can use the Number attribute to identify the record. For the MDF Claim Team object, the attribute is Resource Party Number.

Required Attributes and Validations for MDF Claim Team Object

To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure that you provide valid values for the attributes. This table lists the required attributes for importing new MDF Claim
Team records, required attributes for updating MDF Claim Team records, prerequisite setup tasks for the attributes, and specific validations, if any, for MDF Claim Team import:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/ Import Validations</th>
<th>Creating a MDF Claim Team Record</th>
<th>Updating an Existing MDF Claim Team Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>Resource Party Number</td>
<td>Identifies the resource for the MDF claim team</td>
<td>None</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>Claim Resource ID</td>
<td>System generated unique identifier</td>
<td>None</td>
<td>Not required</td>
<td>Optional or conditionally required</td>
</tr>
<tr>
<td>Resource ID</td>
<td>Specifies the resource added to the MDF claim team</td>
<td>None</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td>Code</td>
<td>Specifies a unique claim identifier</td>
<td>None</td>
<td>A value is required if you’re not providing the unique ID of the request.</td>
<td>A value is required if you’re not providing the unique ID of the request.</td>
</tr>
<tr>
<td>Claim ID</td>
<td>System generated unique identifier</td>
<td>None</td>
<td>Required</td>
<td>Not required</td>
</tr>
</tbody>
</table>

You can view the MDF Claim Team object along with all its child objects and attributes in the Manage Import Objects page of the Import Management flow. You can find attribute information like type, length, description, and so on, on this page.

Create the Source CSV File

You include the data that you want to import into CX Sales and B2B Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to **Navigator > Tools > Import Management > Import Objects**.
2. Select the **MDF Claim Team** object in the table and click **Download**.

You can now edit the downloaded file and provide valid values for the required attributes.

**Note:** For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity

After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to **Navigator > Tools > Import Management > Import Queue**.
2. Click **Create Import Activity** in the **Manage Imports** page.
3. In the **Enter Import Options** page, provide a name for the import activity, and select MDF Claim Team from the **Object** drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you’re ready.

Review the Import Results

Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed. You can drill down on the import activity to go to the Import Status page which provides the status details of the import activity.

Related Topics

• Potential Issues When Opening CSV Files in Excel
• Import Data

Import Your MDF Request Data

You can use import management to create or update MDF Request records.

To import MDF Request records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes

To import your MDF Request data into Oracle Applications Cloud, you need to populate a CSV file with your source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
• Ensure prerequisite setups are done, if applicable.
• Understand your options for uniquely identifying the records.
• Ensure parent records exist before importing child records.
• Identify the target object attributes that are required in the CSV file for a successful import.
Before You Start

You must do some basic checks before starting your import. For example, make sure that:

- You have completed all the prerequisites for importing each attribute in your source data.
- You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records

To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the import process to uniquely identify the records. The file import process uses the attribute values to automatically map your source data to the target object attributes in Oracle Applications Cloud.

The preferred options to uniquely identify an object record are as follows:

- Internal ID: If you're identifying a record that already exists in Oracle Applications Cloud, then you can use the internal ID of the record, a system-generated unique identifier. Attributes with "id" in the attribute name are typically internal IDs. Use this option only if you're updating MDF Requests. You can determine the internal ID of a record by exporting Oracle Applications Cloud object data, or by doing a transactional database query. Using an internal ID typically provides better performance and reduces the import duration. For the MDF Request object, the attributes are Fund Request ID, Partner ID, and Owner ID.

- Public unique identifiers: If you're creating new records, then you can provide a user-friendly public unique identifier (attributes denoted with 'Number' and usually visible in the business object's UI). If you update a record for which you have previously provided a Number attribute, or for which a Number attribute is visible in the object's UI, you can use the Number attribute to identify the record. For the MDF Request object, the attributes are Owner Party Number and Partner Company Number.

Required Attributes and Validations for MDF Request Object

To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure that you provide valid values for the attributes. This table lists the required attributes for importing new MDF Request records, required attributes for updating MDF Request records, prerequisite setup tasks for the attributes, and specific validations, if any, for MDF Request import:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/Import Validations</th>
<th>Creating a MDF Request Record</th>
<th>Updating an Existing MDF Request Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>Fund Request ID</td>
<td>System generated unique fund request identifier</td>
<td>This is automatically derived from the import process when importing a new MDF request.</td>
<td>Not required</td>
<td>Required</td>
</tr>
<tr>
<td>Owner Party Number</td>
<td>A unique public identifier for the owner party number</td>
<td>None</td>
<td>A value is required for a new MDF request with any Status Code.</td>
<td>Required</td>
</tr>
<tr>
<td>Partner Company Number</td>
<td>A unique public identifier for the partner company number</td>
<td>None</td>
<td>A value is required for a new MDF request with any Status Code.</td>
<td>A value is required, when updating the partner of an MDF request in the Draft Status Code.</td>
</tr>
</tbody>
</table>
### Attribute

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/Import Validations</th>
<th>Creating a MDF Request Record</th>
<th>Updating an Existing MDF Request Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>Specifies the name of the fund request</td>
<td>None</td>
<td>A value is required when importing a new MDF request.</td>
<td>Not required</td>
</tr>
</tbody>
</table>
| Currency       | Specifies the transaction currency for MDF request amounts | If providing a value, the value must exist in the CURRENCY_CODE column of the FND_CURRENCIES_VL table. You can view valid currency codes. Navigate to the following in the Setup and Maintenance work area:  
  - Offering: Sales  
  - Functional Area: Data Import and Export  
  - Task: Manage Currencies | A value is required when importing a new request with any Status Code.                                  | A value is required when updating a request with Status Code Draft or Returned.              |
| Requested Amount | Specifies the amount requested by the MDF request | None                                                                                                     | Required                                                                                     |                                                                                  |
| Partner        | Identifies the partner associated with the MDF request | None                                                                                                     | Not required                                                                                 | Not required                                                                   |
| Partner ID     | Identifies the partner for the MDF request       | None                                                                                                     | A value is required for a new MDF request with any Status Code.                              | A value is required when you're updating the partner of an MDF request in the Draft Status Code. |
| Owner ID       | Identifies the owner for the MDF request         | None                                                                                                     | A value is required for a new MDF request with any Status Code.                              | Required                                                                        |
| Owner          | Identifies the owner of the MDF request          | None                                                                                                     | Not required                                                                                 |                                                                                  |
| Code           | Unique MDF fund request identifier               | None                                                                                                     | Conditionally required if you're providing a request name for a new MDF budget.              | A value is required if you're updating an existing MDF request and you're not providing the unique MDF request ID. |

You can view the MDF Request object along with all its child objects and attributes in the Manage Import Objects page of the Import Management flow. You can find attribute information like type, length, description, and so on, on this page.
Create the Source CSV File

You include the data that you want to import into CX Sales and B2B Service in a source CSV file. You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator > Tools > Import Management > Import Objects.
2. Select the MDF Request object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note: For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity

After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select MDF Request from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results

Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed. You can drill down on the import activity to go to the Import Status page which provides the status details of the import activity.

Related Topics
- Potential Issues When Opening CSV Files in Excel
- Import Data
Import Your MDF Request Team Data

You can use import management to create or update MDF Request Team records.

To import MDF Request Team records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes

To import your MDF Request Team data into Oracle Applications Cloud, you need to populate a CSV file with your source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

- Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
- Ensure prerequisite setups are done, if applicable.
- Understand your options for uniquely identifying the records.
- Ensure parent records exist before importing child records.
- Identify the target object attributes that are required in the CSV file for a successful import.

Before You Start

You must do some basic checks before starting your import. For example, make sure that:

- You have completed all the prerequisites for importing each attribute in your source data.
- You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records

To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the import process to uniquely identify the records. The file import process uses the attribute values to automatically map your source data to the target object attributes in Oracle Applications Cloud.

The preferred options to uniquely identify an object record are as follows:

- Internal ID: If you're identifying a record that already exists in Oracle Applications Cloud, then you can use the internal ID of the record, a system-generated unique identifier. Attributes with "id" in the attribute name are typically internal IDs. Use this option only if you're updating MDF Request Teams. You can determine the internal ID of a record by exporting Oracle Applications Cloud object data, or by doing a transactional database query. Using an internal ID typically provides better performance and reduces the import duration. For the MDF Request Team object, the attributes are MDF Request Resource ID, Resource ID, and Fund Request ID.
- Public unique identifiers: If you're creating new records, then you can provide a user-friendly public unique identifier (attributes denoted with 'Number' and usually visible in the business object's UI). If you update a record for which you have previously provided a Number attribute, or for which a Number attribute is visible in
the object’s UI, you can use the Number attribute to identify the record. For the MDF Request Team object, the attribute is Resource Party Number.

Required Attributes and Validations for MDF Request Team Object

To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure that you provide valid values for the attributes. This table lists the required attributes for importing new MDF Request Team records, required attributes for updating MDF Request Team records, prerequisite setup tasks for the attributes, and specific validations, if any, for MDF Request Team import:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/Import Validations</th>
<th>Creating a MDF Request Team Record</th>
<th>Updating an Existing MDF Request Team Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>MDF Request Resource ID</td>
<td>Specifies the unique fund request identifier in the MDF request team</td>
<td>None</td>
<td>Not required</td>
<td>Optional or Conditionally required</td>
</tr>
<tr>
<td>Resource ID</td>
<td>Specifies the resource added to the MDF request team</td>
<td>None</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td>Resource Party Number</td>
<td>The public unique identifier of the resource party</td>
<td>If providing a value and creating or updating a team resource, the value must exist.</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td>Code</td>
<td>Unique MDF fund request identifier</td>
<td>None</td>
<td>A value is required if you’re not providing the unique ID of the MDF request.</td>
<td>A value is required if you’re not providing the unique ID of the MDF request.</td>
</tr>
<tr>
<td>Fund Request ID</td>
<td>System generated unique fund request identifier</td>
<td>None</td>
<td>A value is required if you’re adding a new member to the MDF request team</td>
<td>Not required</td>
</tr>
</tbody>
</table>

You can view the MDF Request Team object along with all its child objects and attributes in the Manage Import Objects page of the Import Management flow. You can find attribute information like type, length, description, and so on, on this page.

Create the Source CSV File

You include the data that you want to import into CX Sales and B2B Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator > Tools > Import Management > Import Objects.
2. Select the MDF Request Team object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

**Note:** For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.
Create the Import Activity

After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select MDF Request Team from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results

Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed. You can drill down on the import activity to go to the Import Status page which provides the status details of the import activity.

Related Topics

- Potential Issues When Opening CSV Files in Excel
- Import Data

Import Your Message Data

You can use the Import Management to create, update, or delete service request message records.

You can import message records using these steps:

1. Map your source message data to Oracle Applications Cloud object attributes. This way the import process would know where to insert each of the information bits.
2. Create the source CSV file with the message data you want to import.
4. Check the import results to know if the import went well.

How You Map Your Source Data to Target Object Attributes

To import your message data into Oracle Applications Cloud, you must populate a .csv file with your source data and map that source data to target object attributes in Oracle Applications Cloud.

You must do the following before creating the .csv file for data import:

- Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
• Ensure prerequisite steps are complete, such as understanding what attributes are required for importing your objects.
• Understand your options for uniquely identifying the records.
• Ensure parent records exist before importing child records.
• Identify the target object attributes that are required in the .csv file for a successful import

Before You Start

You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.
• You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records

All records must be unique in the application. You can use one of these to identify records:

• Public unique identifiers: If you’re creating records, then you can provide an easily understandable public unique identifier. These are, usually, denoted with ‘Number’ and visible in the business object’s UI. PUID attributes are usually named <object> Number. If you’re updating a record with a Number attribute, then use the Number attribute to identify the record. For more information about public unique identifiers, see the topic "How You Use Alternate Keys to Import Records" in Related Topics section.
• Source system and source system reference: Source system is an identifier for the external system, and source system reference is a unique identifier within the external system. If you’re importing new messages or are updating messages that have source system reference data, then provide the source system and source system reference values.

Required Attributes and Validations for Message Object

To import data successfully into Oracle Applications Cloud, your .csv file must include the required attributes. Ensure that you provide valid values for the attributes.

This table lists the required attributes for message records, prerequisite setup tasks and specific validations, if any:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/Import Validations</th>
<th>Creating a Message record</th>
<th>Updating an Existing Message record</th>
</tr>
</thead>
<tbody>
<tr>
<td>Message Content</td>
<td>Content of the message that's not an attachment.</td>
<td>None</td>
<td>Required</td>
<td>Required</td>
</tr>
<tr>
<td>Message Type Code</td>
<td>Indicates the type of message. If providing a</td>
<td>If providing a value, it must be one of the following:</td>
<td>Required</td>
<td>Required</td>
</tr>
<tr>
<td></td>
<td>value, it must be one of the following:</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>• ORA_SVC_CUSTOMER_ENTRY</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>• ORA_SVC_RESPONSE</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>• ORA_SVC_INTERNAL_NOTE</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

437
<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/Import Validations</th>
<th>Creating a Message record</th>
<th>Updating an Existing Message record</th>
</tr>
</thead>
<tbody>
<tr>
<td>Object ID</td>
<td>ID of the object (such as Note, Defect, Other SR) referencing the service request or referenced by the service request.</td>
<td>No validation</td>
<td>Do not pass if the Message Type Code = ORA_SVC_INTERNAL_NOTE</td>
<td>Do not pass if the Message Type Code = ORA_SVC_INTERNAL_NOTE</td>
</tr>
<tr>
<td>Object Type Code</td>
<td>Lookup code that indicates the object type based on the OBJECT_ID table, such as SVC_SR_MESSAGES.</td>
<td>No validation</td>
<td>Do not pass if the Message Type Code = ORA_SVC_INTERNAL_NOTE</td>
<td>Do not pass if the Message Type Code = ORA_SVC_INTERNAL_NOTE</td>
</tr>
<tr>
<td>Posted By ID</td>
<td>The Party Id of the person who posted the message. This person can be an internal resource or a customer contact.</td>
<td>No Validation</td>
<td>Not required</td>
<td>Conditionally required A value is required if you’re updating an existing posted By ID and you’re not providing the party Id which is obtained from the table HZ_IMP_PARTIES_T.</td>
</tr>
<tr>
<td>Service Request ID</td>
<td>Specifies the service request to which the message belongs.</td>
<td>No validation</td>
<td>Not required</td>
<td>Conditionally required A value is required if you’re updating an existing record and you’re not providing the Service Request ID.</td>
</tr>
<tr>
<td>SR Number</td>
<td>The unique number used to identify a service request. You can configure the service request number to a format that’s best suitable to your organizational requirements.</td>
<td>No validation</td>
<td>Conditionally required A value is required if you’re updating an existing record and you’re not providing the Service Request ID.</td>
<td>Conditionally required A value is required if you’re updating an existing record and you’re not providing the Service Request ID.</td>
</tr>
<tr>
<td>Status Code</td>
<td>Indicates the status of the message, such as DRAFT, COMMITTED, and CORRECTED.</td>
<td>If providing a value, it must be one of the following: · ORA_SVC_DRAFT · ORA_SVC_COMMITTERD · ORA_SVC_CORRECTED</td>
<td>Required</td>
<td>Required</td>
</tr>
<tr>
<td>Attribute</td>
<td>Description</td>
<td>Prerequisite Setup Task/Import Validations</td>
<td>Creating a Message record</td>
<td>Updating an Existing Message record</td>
</tr>
<tr>
<td>-----------------------------------------</td>
<td>--------------------------------------------------</td>
<td>--------------------------------------------</td>
<td>----------------------------------------------------------------</td>
<td>--------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Notification Processing Status Code</td>
<td>The notification processing status code.</td>
<td>No validation</td>
<td>Do not pass if the Message Type Code = ORA_SVC_INTERNAL_NOTE</td>
<td>Do not pass if the Message Type Code = ORA_SVC_INTERNAL_NOTE</td>
</tr>
<tr>
<td>Notification Retry Count</td>
<td>The notification retry count.</td>
<td>No Validation</td>
<td>Do not pass if the Message Type Code = ORA_SVC_INTERNAL_NOTE</td>
<td>Do not pass if the Message Type Code = ORA_SVC_INTERNAL_NOTE</td>
</tr>
</tbody>
</table>

Go to Navigator > Tools > Import Management > Import Objects, to see all the attributes of the message object. The page also lists attribute information like type, length, description, and so on.

Create the Source CSV File

You include the data that you want to import into CX Sales and B2B Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator > Tools > Import Management > Import Objects.
2. Select the Message object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

**Note:** For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity

After you have the CSV file ready, create an import activity to import the message information. To create an import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Message from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results

Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
Check the Status column for the import activity. The import is successful if the status displays as Completed. You can drill down on the import activity to go to the Import Status page which provides the status details of the import activity.

Related Topics
- Potential Issues When Opening CSV Files in Excel
- How You Use Alternate Keys to Import Records
- Import Data

Import Your Nonduplicate Data

You can use the import functionality to create or update Nonduplicate records.

To import Nonduplicate records, perform the following tasks:
1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (.csv) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes

To import your Nonduplicate data into Oracle Applications Cloud, you need to populate a CSV file with your source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the .CSV file for data import:
- Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
- Ensure prerequisite steps are complete, such as understanding what attributes are required for importing your objects.
- Understand your options for uniquely identifying the records.
- Ensure parent records exist before importing child records.
- Identify the target object attributes that are required in the .CSV file for a successful import.

Before You Start

You must do some basic checks before starting your import. For example, make sure that:
- You have completed all the prerequisites for importing each attribute in your source data.
- You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records

To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the import process to uniquely identify the records. The file import process uses the attribute values to automatically map your source data to the target object attributes in Oracle Applications Cloud.
The preferred option to uniquely identifying an object record is through the internal ID. If you're identifying a record that already exists in Oracle Applications Cloud, then you can use the internal ID of the record, a system-generated unique identifier. Attributes with "id" in the attribute name are typically internal IDs. Use this option only if you're updating Nonduplicates. You can determine the internal ID of a record by exporting Oracle Applications Cloud object data, or by doing a transactional database query. Using an internal ID typically provides better performance and reduces the import duration. For the Nonduplicate object, the attribute is NonduplicateId.

### Required Attributes and Validations for Nonduplicate Object

To import data successfully into Oracle Applications Cloud, your .CSV file must include the required attributes. Ensure that you provide valid values for the attributes.

The following table lists the required attributes for importing new Nonduplicate records, required attributes for updating Nonduplicate records, prerequisite setup tasks for the attributes, and specific validations, if any, for Nonduplicate import:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Data Type</th>
<th>Data Length</th>
<th>Prerequisite Setup Task/ Import Validations</th>
<th>Creating a Nonduplicate Record</th>
<th>Updating an Existing Nonduplicate Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>NonDuplicateId</td>
<td>The unique identifier of the non-duplicate record.</td>
<td>Long</td>
<td>18</td>
<td>No validation</td>
<td>Conditionally Required</td>
<td>Required</td>
</tr>
<tr>
<td>NonDuplicatePartyId</td>
<td>The internal unique identifier of the party associated with the non-duplicate record.</td>
<td>Long</td>
<td>18</td>
<td>No validation</td>
<td>Conditionally Required</td>
<td>You can't update the Nonduplicate.</td>
</tr>
<tr>
<td>NonDuplicatePartyNumber</td>
<td>The alternate key identifier of the party associated with the non-duplicate record.</td>
<td>String</td>
<td></td>
<td>The NonDuplicatePartyId is evaluated when you don't provide a value for the NonDuplicatePartyId.</td>
<td>Conditionally Required</td>
<td>You can't update the Nonduplicate.</td>
</tr>
<tr>
<td>MasterPartyId</td>
<td>The unique identifier of the master party associated with the non-duplicate record.</td>
<td>Long</td>
<td>18</td>
<td>No validation</td>
<td>Conditionally Required</td>
<td>You can't update the Nonduplicate.</td>
</tr>
<tr>
<td>MasterPartyNumber</td>
<td>The alternate key identifier of the master party associated with the non-duplicate record.</td>
<td>String</td>
<td></td>
<td>The MasterPartyNumber is evaluated when you don't provide a value for the MasterPartyId.</td>
<td>Conditionally Required</td>
<td>You can't update the Nonduplicate.</td>
</tr>
</tbody>
</table>
### Create the Source CSV File

You include the data that you want to import into CX Sales and B2B Service in a source CSV file. You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to **Navigator > Tools > Import Management > Import Objects.**
2. Select the **Nonduplicate** object in the table and click **Download.**

You can now edit the downloaded file and provide valid values for the required attributes.

**Note:** For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.

### Create the Import Activity

After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to **Navigator > Tools > Import Management > Import Queue.**
2. Click **Create Import Activity** in the Manage Imports page.
3. In the **Enter Import Options** page, provide a name for the import activity, and select Nonduplicate from the **Object** drop-down list.
4. Select the CSV file in the **File Name** field, and click **Next.**
5. You would see that the source and target attributes are automatically mapped in the **Map Fields** page. Review and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking **Validate Data.** Click **Next.**
7. Review the import details on the **Review and Submit** page, and click **Submit** when you’re ready.
Review the Import Results

Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed. You can drill down on the import activity to go to the Import Status page which provides the status details of the import activity.

Related Topics
- Potential Issues When Opening CSV Files in Excel
- Import Data

Import Your Opportunity Data

You can use the Import Management to create, update, or delete opportunity records.

You can import opportunity records using these steps:

1. Map your source opportunity data to Oracle Applications Cloud object attributes. This way the import process would know where to insert each of the information bits.
2. Create the source CSV file with the opportunity data you want to import.
4. Check the import results to know if the import went well.

How You Map Your Source Data to Target Object Attributes

To import your opportunity data into Oracle Applications Cloud, you must populate a .csv file with your source data and map that source data to target object attributes in Oracle Applications Cloud.

You must do the following before creating the .csv file for data import:

- Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
- Ensure prerequisite steps are complete, such as understanding what attributes are required for importing your objects.
- Understand your options for uniquely identifying the records.
- Ensure parent records exist before importing child records.
- Identify the target object attributes that are required in the .csv file for a successful import

To better manage your opportunity information, the opportunity object has the following child objects:

- Opportunity Competitor
- Opportunity Contact
- Opportunity Lead
• Opportunity Partner
• Opportunity Revenue
• Opportunity Source
• Opportunity Team Member

If you want to import only a few records, then you can create a single CSV file for all opportunity attributes. However if you want to import a large number of records, then you may decide to create multiple CSV files, one for each of the opportunity child objects. Note that you must have imported the CSV file for opportunity object successfully before trying to import the CSV files for the child objects. There are separate help topics describing how to import each of these child objects. For more information, see the related topics section.

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.
• You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
All records must be unique in the application. You can use one of these to identify records:

• Public unique identifiers: If you're creating records, then you can provide an easily understandable public unique identifier. These are, usually, denoted with 'Number' and visible in the business object's UI. PUID attributes are usually named <object> Number. If you're updating a record with a Number attribute, then use the Number attribute to identify the record. For more information about public unique identifiers, see the topic "How You Use Alternate Keys to Import Records" in Related Topics section.
• Source system and source system reference: Source system is an identifier for the external system, and source system reference is a unique identifier within the external system. If you're importing new opportunities or are updating opportunities that have source system reference data, then provide the source system and source system reference values.

Required Attributes and Validations for Opportunity Object
To import data successfully into Oracle Applications Cloud, your .csv file must include the required attributes. Ensure that you provide valid values for the attributes.

This table lists the required attributes for opportunity records, prerequisite setup tasks and specific validations, if any:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Tasks or Import Validations</th>
<th>Creating an Opportunity Record</th>
<th>Updating an Existing Opportunity Record</th>
<th>Deleting an Existing Opportunity Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>Business Unit ID</td>
<td>The business unit that owns the opportunity transaction. If a value isn't provided, then the business unit ID is set to a default value based on the signed in user details.</td>
<td>Not applicable</td>
<td>Required</td>
<td>Do not provide</td>
<td>Do not provide</td>
</tr>
<tr>
<td>Attribute</td>
<td>Description</td>
<td>Prerequisite Setup</td>
<td>Creating an Opportunity Record</td>
<td>Updating an Existing Opportunity Record</td>
<td>Deleting an Existing Opportunity Record</td>
</tr>
<tr>
<td>-----------------</td>
<td>------------------------------------------------------------------------------</td>
<td>---------------------------------------------------</td>
<td>---------------------------------</td>
<td>----------------------------------------</td>
<td>----------------------------------------</td>
</tr>
<tr>
<td>Name</td>
<td>Opportunity Name - The name that identifies the opportunity.</td>
<td>Not applicable.</td>
<td>Required</td>
<td>Required</td>
<td>The attribute is neither required nor conditionally required.</td>
</tr>
<tr>
<td>OptyId</td>
<td>Opportunity ID - The unique ID for the existing opportunity record in the destination table.</td>
<td>You can obtain the OptyID for an existing opportunity by exporting the Opportunity object by navigating to the following in the Setup and Maintenance work area:</td>
<td>Conditionally Required Either OptyId or OptyNumber is required.</td>
<td>Conditionally Required</td>
<td>Conditionally Required</td>
</tr>
<tr>
<td>OptyNumber</td>
<td>The public unique identifier of the opportunity.</td>
<td>Not applicable.</td>
<td>Conditionally Required Either OptyId or OptyNumber is required.</td>
<td>Do not provide.</td>
<td>Conditionally Required</td>
</tr>
</tbody>
</table>

**Note:** The profile options MOO_CLOSE_COMP_REQD and MOO_CLOSE_WINLOSS_REQD can be configured to enforce the Competitor and Winloss Reason Code to be required if the Status is closed.

Go to **Navigator > Tools > Import Management > Import Objects**, to see all the attributes of the opportunity object. The page also lists attribute information like type, length, description, and so on.

### Create the Source CSV File
You include the data that you want to import into CX Sales and B2B Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to **Navigator > Tools > Import Management > Import Objects**.
2. Select the **Opportunity** object in the table and click **Download**.

You can now edit the downloaded file and provide valid values for the required attributes.

**Note:** For help in populating the CSV file and to avoid any issues in entering values, see the topic **Potential Issues When Opening CSV Files With Excel** in Related Topics section.
Create the Import Activity
After you have the CSV file ready, create an import activity to import the opportunity information. To create an import activity:

1. Go to **Navigator > Tools > Import Management > Import Queue.**
2. Click **Create Import Activity** in the **Manage Imports** page.
3. In the **Enter Import Options** page, provide a name for the import activity, and select Opportunity from the **Object** drop-down list.
4. Select the CSV file in the **File Name** field, and click **Next.**
5. You would see that the source and target attributes are automatically mapped in the **Map Fields** page. Review and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking **Validate Data.** Click **Next.**
7. Review the import details on the **Review and Submit** page, and click **Submit** when you’re ready.

Review the Import Results
Check if your import succeeded on the **Manage Imports** page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to **Navigator > Tools > Import Management > Import Queue.**
2. Click All Imports and search for the import activity that you created earlier.
3. Check the **Status** column for the import activity. The import is successful if the status displays as **Completed.**
   You can drill down on the import activity to go to the **Import Status** page which provides the status details of the import activity.

Related Topics

Import Your Opportunity Competitor Data
You can use the Import Management to create, update, or delete opportunity competitor records.

You can import opportunity competitor records using these steps:

1. Map your source opportunity competitor data to Oracle Applications Cloud object attributes. This way the import process would know where to insert each of the information bits.
2. Create the source CSV file with the opportunity competitor data you want to import.
4. Check the import results to know if the import went well.

How You Map Your Source Data to Target Object Attributes
To import your opportunity competitor data into Oracle Applications Cloud, you must populate a .csv file with your source data and map that source data to target object attributes in Oracle Applications Cloud.

You must do the following before creating the .csv file for data import:

- Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
- Ensure prerequisite steps are complete, such as understanding what attributes are required for importing your objects.
• Understand your options for uniquely identifying the records.
• Ensure parent records exist before importing child records.
• Identify the target object attributes that are required in the .csv file for a successful import

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.
• You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
All records must be unique in the application. You can use one of these to identify records:

• Public unique identifiers: If you’re creating records, then you can provide an easily understandable public unique identifier. These are, usually, denoted with 'Number' and visible in the business object's UI. PUID attributes are usually named <object> Number. If you’re updating a record with a Number attribute, then use the Number attribute to identify the record. For more information about public unique identifiers, see the topic “How You Use Alternate Keys to Import Records” in Related Topics section.
• Source system and source system reference: Source system is an identifier for the external system, and source system reference is a unique identifier within the external system. If you’re importing new opportunity competitors or are updating opportunity competitors that have source system reference data, then provide the source system and source system reference values.

Required Attributes and Validations for Opportunity Competitor Object
To import data successfully into Oracle Applications Cloud, your .csv file must include the required attributes. Ensure that you provide valid values for the attributes.

This table lists the required attributes for opportunity competitor records, prerequisite setup tasks and specific validations, if any:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Tasks or Import Validations</th>
<th>Creating an Opportunity Competitor Record</th>
<th>Updating an Existing Opportunity Competitor Record</th>
<th>Deleting an Existing Opportunity Competitor Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>OptyCompetitorId</td>
<td>The unique identifier for Competitors of the Opportunity, that's generated by the application.</td>
<td>Not Applicable</td>
<td>Do not provide</td>
<td>Conditionally Required</td>
<td>Conditionally Required</td>
</tr>
<tr>
<td>OptyId</td>
<td>The unique ID for the existing opportunity record in the destination table.</td>
<td>You can obtain the OptyId for an existing opportunity by exporting the Opportunity object by navigating to the following in the Setup and Maintenance work area:</td>
<td>Conditionally Required</td>
<td>Conditionally Required</td>
<td>Conditionally Required</td>
</tr>
</tbody>
</table>

447
Table: Attribute Setup

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup</th>
<th>Creating an Opportunity Competitor Record</th>
<th>Updating an Existing Opportunity Competitor Record</th>
<th>Deleting an Existing Opportunity Competitor Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>OptyNumber</td>
<td>The public unique identifier of the opportunity.</td>
<td>Not applicable.</td>
<td>Conditionally Required</td>
<td>Conditionally Required</td>
<td>Conditionally Required</td>
</tr>
<tr>
<td>CmptPartyId</td>
<td>The party identifier with competitor party usage.</td>
<td>Not applicable.</td>
<td>Required</td>
<td>Do not provide.</td>
<td>Do not provide.</td>
</tr>
</tbody>
</table>

Go to Navigator > Tools > Import Management > Import Objects, to see all the attributes of the opportunity competitor object. The page also lists attribute information like type, length, description, and so on.

Create the Source CSV File
You include the data that you want to import into CX Sales and B2B Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator > Tools > Import Management > Import Objects.
2. Select the Opportunity Competitor object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

**Note:** For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the opportunity competitor information. To create an import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Opportunity Competitor from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.
Review the Import Results

Check if your import succeeded on the **Manage Imports** page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to **Navigator > Tools > Import Management > Import Queue**.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the **Status** column for the import activity. The import is successful if the status displays as **Completed**. You can drill down on the import activity to go to the **Import Status** page which provides the status details of the import activity.

**Related Topics**
- Import Data
- Potential Issues When Opening CSV Files in Excel
- How You Use Alternate Keys to Import Records
- Update Existing Setup Data

Import Your Opportunity Contact Data

You can use the Import Management to create, update, or delete opportunity contact records.

You can import opportunity contact records using these steps:

1. Map your source opportunity contact data to Oracle Applications Cloud object attributes. This way the import process would know where to insert each of the information bits.
2. Create the source CSV file with the opportunity contact data you want to import.
4. Check the import results to know if the import went well.

How You Map Your Source Data to Target Object Attributes

To import your opportunity contact data into Oracle Applications Cloud, you must populate a .csv file with your source data and map that source data to target object attributes in Oracle Applications Cloud.

You must do the following before creating the .csv file for data import:

- Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
- Ensure prerequisite steps are complete, such as understanding what attributes are required for importing your objects.
- Understand your options for uniquely identifying the records.
- Ensure parent records exist before importing child records.
- Identify the target object attributes that are required in the .csv file for a successful import.
Before You Start

You must do some basic checks before starting your import. For example, make sure that:

- You have completed all the prerequisites for importing each attribute in your source data.
- You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records

All records must be unique in the application. You can use one of these to identify records:

- Public unique identifiers: If you’re creating records, then you can provide an easily understandable public unique identifier. These are, usually, denoted with ‘Number’ and visible in the business object’s UI. PUID attributes are usually named `<object> Number`. If you’re updating a record with a Number attribute, then use the Number attribute to identify the record. For more information about public unique identifiers, see the topic "How You Use Alternate Keys to Import Records" in Related Topics section.
- Source system and source system reference: Source system is an identifier for the external system, and source system reference is a unique identifier within the external system. If you’re importing new opportunity contacts or are updating opportunity contacts that have source system reference data, then provide the source system and source system reference values.

Required Attributes and Validations for Opportunity Contact Object

To import data successfully into Oracle Applications Cloud, your .csv file must include the required attributes. Ensure that you provide valid values for the attributes.

This table lists the required attributes for opportunity contact records, prerequisite setup tasks and specific validations, if any:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Tasks or Import Validations</th>
<th>Creating an Opportunity Contact Record</th>
<th>Updating an Existing Opportunity Contact Record</th>
<th>Deleting an Existing Opportunity Contact Record</th>
</tr>
</thead>
</table>
| OptyId      | The unique ID for the existing opportunity record in the destination table. | You can obtain the OptyID for an existing opportunity by exporting the Opportunity object by navigating to the following in the Setup and Maintenance work area:  
- Offering: Sales  
- Functional Area: Data Import and Export  
- Task: Schedule Export Processes | Conditionally Required  
Either OptyId or OptyNumber is required.  
You can use TargetPartyID to associate the Account if you’re assigning Account Contact as the Primary Contact of Opportunity. | Conditionally Required | Conditionally Required |
| OptyNumber  | The public unique identifier of the opportunity.                          | Not applicable.                                                                                             | Conditionally Required                                                                                   | Conditionally Required                                                                 | Conditionally Required                                                                 |

450
Understanding Import and Export Management for CX
Sales and B2B Service

Chapter 8

Import Your Data

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Tasks or Import Validations</th>
<th>Creating an Opportunity Contact Record</th>
<th>Updating an Existing Opportunity Contact Record</th>
<th>Deleting an Existing Opportunity Contact Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>PERPartyId</td>
<td>The party identifier of the contact associated with the opportunity.</td>
<td>Not applicable</td>
<td>Required</td>
<td>Required</td>
<td>Required</td>
</tr>
</tbody>
</table>

Either OptyId or OptyNumber is required.

Go to **Navigator > Tools > Import Management > Import Objects** page, to see all the attributes of the opportunity contact object. The page also lists attribute information like type, length, description, and so on.

Create the Source CSV File

You include the data that you want to import into CX Sales and B2B Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to **Navigator > Tools > Import Management > Import Objects**.
2. Select the **Opportunity Contact** object in the table and click **Download**.

You can now edit the downloaded file and provide valid values for the required attributes.

**Note:** For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity

After you have the CSV file ready, create an import activity to import the opportunity contact information. To create an import activity:

1. Go to **Navigator > Tools > Import Management > Import Queue**.
2. Click **Create Import Activity** in the **Manage Imports** page.
3. In the **Enter Import Options** page, provide a name for the import activity, and select Opportunity Contact from the **Object** drop-down list.
4. Select the CSV file in the **File Name** field, and click **Next**.
5. You would see that the source and target attributes are automatically mapped in the **Map Fields** page. Review and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking **Validate Data**. Click **Next**.
7. Review the import details on the **Review and Submit** page, and click **Submit** when you're ready.

Review the Import Results

Check if your import succeeded on the **Manage Imports** page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to **Navigator > Tools > Import Management > Import Queue**.
2. Click All Imports and search for the import activity that you created earlier.
Check the Status column for the import activity. The import is successful if the status displays as Completed. You can drill down on the import activity to go to the Import Status page which provides the status details of the import activity.

**Related Topics**
- Import Data
- Potential Issues When Opening CSV Files in Excel
- How You Use Alternate Keys to Import Records
- Update Existing Setup Data

### Import Your Opportunity Deal Data

You can use Import Management to create update, or delete Opportunity Deal records.

To import Opportunity Deal records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

### How You Map Your Source Data to Target Object Attributes

To import your Opportunity Deal data into Oracle Applications Cloud, you need to populate a CSV file with your source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

- Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
- Ensure prerequisite setups are done, if applicable.
- Understand your options for uniquely identifying the records.
- Ensure parent records exist before importing child records.
- Identify the target object attributes that are required in the CSV file for a successful import.

### Before You Start

You must do some basic checks before starting your import. For example, make sure that:

- You have completed all the prerequisites for importing each attribute in your source data.
- You have all parent records in place before importing child records.

### Select a Unique Identifier for Your Records

All records must be unique in the application. You can use one of these to identify records:

- Public unique identifiers: If you’re creating records, then you can provide an easily understandable public unique identifier. These are, usually, denoted with ‘Number’ and visible in the business object's UI. PUID
attributes are usually named `<object>` Number. If you’re updating a record with a Number attribute, then use the Number attribute to identify the record. For more information about public unique identifiers, see the topic "How You Use Alternate Keys to Import Records" in Related Topics section.

- Source system and source system reference: Source system is an identifier for the external system, and source system reference is a unique identifier within the external system. If you’re importing new Opportunity Deals or are updating Opportunity Deals that have source system reference data, then provide the source system and source system reference values.

Required Attributes and Validations for Opportunity Deal Object

To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure that you provide valid values for the attributes. This table lists the required attributes for importing new Opportunity Deal records, required attributes for updating Opportunity Deal records, prerequisite setup tasks for the attributes, and specific validations, if any, for Opportunity Deal import:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/ Import Validations</th>
<th>Creating a Opportunity Deal Record</th>
<th>Updating an Existing Opportunity Deal Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>DealId</td>
<td>The unique identifier for the existing deal record in the destination table</td>
<td>You can obtain the Deal Number for an existing deal registration from the Deal Registration work area.</td>
<td>Conditionally required</td>
<td>Conditionally required</td>
</tr>
<tr>
<td>DealNumber</td>
<td>The unique identifier value of the deal</td>
<td>No validation</td>
<td>Conditionally required</td>
<td>Conditionally required</td>
</tr>
<tr>
<td>OptyDealId</td>
<td>The unique identifier of the opportunity deal</td>
<td>No validation</td>
<td>Conditionally required</td>
<td>Conditionally required</td>
</tr>
<tr>
<td>OptyId</td>
<td>The unique identifier for the existing opportunity record in the destination table</td>
<td>You can obtain the OptyID for an existing opportunity by exporting the Opportunity object by navigating to the following in the Setup and Maintenance work area:</td>
<td>Conditionally required</td>
<td>Conditionally required</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Offering: Sales</td>
<td>A value is required either for the OptyId or the OptyNumber.</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Functional Area: Data Import and Export</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Task: Schedule Export Processes</td>
<td></td>
<td></td>
</tr>
<tr>
<td>OptyNumber</td>
<td>The public unique identifier value of the opportunity</td>
<td>No validation</td>
<td>Conditionally required</td>
<td>Conditionally required</td>
</tr>
</tbody>
</table>
You can view the Opportunity Deal object along with all its child objects and attributes in the Manage Import Objects page of the Import Management flow. You can find attribute information like type, length, description, and so on, on this page.

Create the Source CSV File

You include the data that you want to import into CX Sales and B2B Service in a source CSV file. You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to **Navigator > Tools > Import Management > Import Objects**.
2. Select the **Opportunity Deal** object in the table and click **Download**.

You can now edit the downloaded file and provide valid values for the required attributes.

**Note:** For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity

After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to **Navigator > Tools > Import Management > Import Queue**.
2. Click **Create Import Activity** in the **Manage Imports** page.
3. In the **Enter Import Options** page, provide a name for the import activity, and select Opportunity Deal from the **Object** drop-down list.
4. Select the CSV file in the **File Name** field, and click **Next**.
5. You would see that the source and target attributes are automatically mapped in the **Map Fields** page. Review and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking **Validate Data**. Click **Next**.
7. Review the import details on the **Review and Submit** page, and click **Submit** when you're ready.

Review the Import Results

Check if your import succeeded on the **Manage Imports** page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to **Navigator > Tools > Import Management > Import Queue**.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the **Status** column for the import activity. The import is successful if the status displays as **Completed**. You can drill down on the import activity to go to the **Import Status** page which provides the status details of the import activity.

**Related Topics**

- Potential Issues When Opening CSV Files in Excel
- How You Use Alternate Keys to Import Records
- Import Data
Import Your Opportunity Lead Data

You can use the Import Management to create, update, or delete opportunity lead records.

You can import opportunity lead records using these steps:

1. Map your source opportunity lead data to Oracle Applications Cloud object attributes. This way the import process would know where to insert each of the information bits.
2. Create the source CSV file with the opportunity lead data you want to import.
4. Check the import results to know if the import went well.

How You Map Your Source Data to Target Object Attributes

To import your opportunity lead data into Oracle Applications Cloud, you must populate a .csv file with your source data and map that source data to target object attributes in Oracle Applications Cloud.

You must do the following before creating the .csv file for data import:

- Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
- Ensure prerequisite steps are complete, such as understanding what attributes are required for importing your objects.
- Understand your options for uniquely identifying the records.
- Ensure parent records exist before importing child records.
- Identify the target object attributes that are required in the .csv file for a successful import

Before You Start

You must do some basic checks before starting your import. For example, make sure that:

- You have completed all the prerequisites for importing each attribute in your source data.
- You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records

All records must be unique in the application. You can use one of these to identify records:

- Public unique identifiers: If you’re creating records, then you can provide an easily understandable public unique identifier. These are, usually, denoted with 'Number' and visible in the business object's UI. PUID attributes are usually named <object> Number. If you’re updating a record with a Number attribute, then use the Number attribute to identify the record. For more information about public unique identifiers, see the topic "How You Use Alternate Keys to Import Records" in Related Topics section.
- Source system and source system reference: Source system is an identifier for the external system, and source system reference is a unique identifier within the external system. If you’re importing new opportunity leads or are updating opportunity leads that have source system reference data, then provide the source system and source system reference values.
Required Attributes and Validations for Opportunity Lead Object

To import data successfully into Oracle Applications Cloud, your .csv file must include the required attributes. Ensure that you provide valid values for the attributes.

This table lists the required attributes for opportunity lead records, prerequisite setup tasks and specific validations, if any:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Tasks or Import Validations</th>
<th>Creating an Opportunity Lead Record</th>
<th>Updating an Existing Opportunity Lead Record</th>
<th>Deleting an Existing Opportunity Lead Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>OptyLeadId</td>
<td>The unique identifier of the opportunity lead.</td>
<td>Not applicable</td>
<td>Conditionally Required</td>
<td>Conditionally Required</td>
<td>Conditionally Required</td>
</tr>
</tbody>
</table>
| OptyId       | The unique ID for the existing opportunity record in the destination table.  | You can obtain the OptyID for an existing opportunity by exporting the Opportunity object by navigating to the following in the Setup and Maintenance work area:  
- Offering: Sales  
- Functional Area: Data Import and Export  
- Task: Schedule Export Processes | Conditionally Required  
Either OptyId or OptyNumber is required. | Conditionally Required                      | Conditionally Required                      |
| OptyNumber   | The opportunity's public unique identifier value.                            | Not applicable                                | Conditionally Required            | Conditionally Required                      | Conditionally Required                      |
| LeadNumber   | The lead's unique identifier value.                                          | You can obtain the Lead Number for an existing lead registration using the Lead registration work area. | Required                         | The attribute is neither required nor conditionally required. | Conditionally required.  
To identify the existing lead relationship record, provide either the record ID (OptyLeadId), or provide the lead number (LeadNumber) and the opportunity's record ID (OptyId), or provide the lead number (LeadNumber) and the opportunity number (OptyNumber). |
Go to Navigator > Tools > Import Management > Import Objects, to see all the attributes of the opportunity lead object. The page also lists attribute information like type, length, description, and so on.

Create the Source CSV File
You include the data that you want to import into CX Sales and B2B Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator > Tools > Import Management > Import Objects.
2. Select the Opportunity Lead object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

**Note:** For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the opportunity lead information. To create an import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Opportunity Lead from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed. You can drill down on the import activity to go to the Import Status page which provides the status details of the import activity.

**Related Topics**

**Import Your Opportunity Partner Data**
You can use the Import Management to create, update, or delete opportunity partner records.
You can import opportunity partner records using these steps:

1. Map your source opportunity partner data to Oracle Applications Cloud object attributes. This way the import process would know where to insert each of the information bits.
2. Create the source CSV file with the opportunity partner data you want to import.
4. Check the import results to know if the import went well.

How You Map Your Source Data to Target Object Attributes

To import your opportunity partner data into Oracle Applications Cloud, you must populate a .csv file with your source data and map that source data to target object attributes in Oracle Applications Cloud.

You must do the following before creating the .csv file for data import:

- Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
- Ensure prerequisite steps are complete, such as understanding what attributes are required for importing your objects.
- Understand your options for uniquely identifying the records.
- Ensure parent records exist before importing child records.
- Identify the target object attributes that are required in the .csv file for a successful import

Before You Start

You must do some basic checks before starting your import. For example, make sure that:

- You have completed all the prerequisites for importing each attribute in your source data.
- You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records

All records must be unique in the application. You can use one of these to identify records:

- Public unique identifiers: If you're creating records, then you can provide an easily understandable public unique identifier. These are, usually, denoted with 'Number' and visible in the business object's UI. PUID attributes are usually named <object> Number. If you're updating a record with a Number attribute, then use the Number attribute to identify the record. For more information about public unique identifiers, see the topic "How You Use Alternate Keys to Import Records" in Related Topics section.
- Source system and source system reference: Source system is an identifier for the external system, and source system reference is a unique identifier within the external system. If you're importing new opportunity partners or are updating opportunity partners that have source system reference data, then provide the source system and source system reference values.

Required Attributes and Validations for Opportunity Partner Object

To import data successfully into Oracle Applications Cloud, your .csv file must include the required attributes. Ensure that you provide valid values for the attributes.

This table lists the required attributes for opportunity partner records, prerequisite setup tasks and specific validations, if any:
### Attribute | Description | Prerequisite Setup Tasks or Import Validations | Creating an Opportunity Partner Record | Updating an Existing Opportunity Partner Record | Deleting an Existing Opportunity Partner Record
---|---|---|---|---|---
PartOrgPartyId | The party identifier of a partner. | Not applicable | Required | Required | Required
OptyId | The unique ID for the existing opportunity record in the destination table. | | | | 
| You can obtain the OptyId for an existing opportunity by exporting the Opportunity object by navigating to the following in the Setup and Maintenance work area: | | | Conditionally Required | Conditionally Required | Conditionally Required
| • Offering: Sales | | Either OptyId or OptyNumber is required. | | | Conditionally Required
| • Functional Area: Data Import and Export | | | | |
| • Task: Schedule Export Processes | | | | |
OptyNumber | The public unique identifier of the opportunity. | Not applicable. | Conditionally Required | Conditionally Required | Conditionally Required
| Either OptyId or OptyNumber is required. | | | |

Go to Navigator > Tools > Import Management > Import Objects, to see all the attributes of the opportunity partner object. The page also lists attribute information like type, length, description, and so on.

### Create the Source CSV File
You include the data that you want to import into CX Sales and B2B Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator > Tools > Import Management > Import Objects.
2. Select the Opportunity Partner object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

**Note:** For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.

### Create the Import Activity
After you have the CSV file ready, create an import activity to import the opportunity partner information. To create an import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Opportunity Partner from the Object drop-down list.

4. Select the CSV file in the File Name field, and click Next.

5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review and edit the mappings if required.

6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.

7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results

Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed. You can drill down on the import activity to go to the Import Status page which provides the status details of the import activity.

Related Topics

- Import Data
- Potential Issues When Opening CSV Files in Excel
- How You Use Alternate Keys to Import Records
- Update Existing Setup Data

Import Opportunity Revenue Data

Import Your Opportunity Revenue Data

You can use the Import Management to create, update, or delete opportunity revenue records.

You can import opportunity revenue records using these steps:

1. Map your source opportunity revenue data to Oracle Applications Cloud object attributes. This way the import process would know where to insert each of the information bits.
2. Create the source CSV file with the opportunity revenue data you want to import.
4. Check the import results to know if the import went well.

How You Map Your Source Data to Target Object Attributes

To import your opportunity revenue data into Oracle Applications Cloud, you must populate a .csv file with your source data and map that source data to target object attributes in Oracle Applications Cloud.

You must do the following before creating the .csv file for data import:

- Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
• Ensure prerequisite steps are complete, such as understanding what attributes are required for importing your objects.
• Understand your options for uniquely identifying the records.
• Ensure parent records exist before importing child records.
• Identify the target object attributes that are required in the .csv file for a successful import.

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.
• You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
All records must be unique in the application. You can use one of these to identify records:

• Public unique identifiers: If you’re creating records, then you can provide an easily understandable public unique identifier. These are, usually, denoted with ‘Number’ and visible in the business object’s UI. PUID attributes are usually named <object> Number. If you’re updating a record with a Number attribute, then use the Number attribute to identify the record. For more information about public unique identifiers, see the topic "How You Use Alternate Keys to Import Records" in Related Topics section.
• Source system and source system reference: Source system is an identifier for the external system, and source system reference is a unique identifier within the external system. If you’re importing new opportunity revenues or are updating opportunity revenues that have source system reference data, then provide the source system and source system reference values.

Required Attributes and Validations for Opportunity Revenue Object
To import data successfully into Oracle Applications Cloud, your .csv file must include the required attributes. Ensure that you provide valid values for the attributes.

This table lists the required attributes for opportunity revenue records, prerequisite setup tasks and specific validations, if any:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Tasks or Import Validations</th>
<th>Creating an Opportunity Revenue Record</th>
<th>Updating an Existing Opportunity Revenue Record</th>
<th>Deleting an Existing Opportunity Revenue Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>RevnId</td>
<td>The unique identifier of the summary revenue for this Opportunity.</td>
<td>Not applicable</td>
<td>Not Required</td>
<td>Conditionally Required</td>
<td>Conditionally Required</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Either RevnNumber or RevnId must be passed for identifying a record of Opportunity revenue. If both are passed then only the RevnId field is checked. Not passing either of these results in error.</td>
<td>Either RevnNumber or RevnId must be passed for identifying a record of Opportunity revenue. If both are passed then only the RevnId field is checked. Not passing either of these results in error.</td>
</tr>
<tr>
<td>Attribute</td>
<td>Description</td>
<td>Prerequisite Setup Tasks or Import Validations</td>
<td>Creating an Opportunity Revenue Record</td>
<td>Updating an Existing Opportunity Revenue Record</td>
<td>Deleting an Existing Opportunity Revenue Record</td>
</tr>
<tr>
<td>-----------------</td>
<td>------------------------------------------------------------------------------</td>
<td>---------------------------------------------------------------------------------------------------------------</td>
<td>---------------------------------------</td>
<td>-----------------------------------------------</td>
<td>-----------------------------------------------</td>
</tr>
<tr>
<td>OptyId</td>
<td>The unique ID for the existing opportunity record in the destination table.</td>
<td>You can obtain the OptyID for an existing opportunity by exporting the Opportunity object by navigating to the following in the Setup and Maintenance work area:</td>
<td>Conditionally Required Either OptyId or OptyNumber is required.</td>
<td>Conditionally Required</td>
<td>Conditionally Required</td>
</tr>
</tbody>
</table>
|                 |                                                                              | • Offering: Sales  
• Functional Area: Data Import and Export  
• Task: Schedule Export Processes                                                                                      |                                            |                                |                                |
| OptyNumber      | The public unique identifier of the opportunity.                             | Not applicable.                                                                                               | Conditionally Required Either OptyId or OptyNumber is required. | Conditionally Required | Conditionally Required |
| RevnNumber      | Revenue Number - The opportunity revenue's unique identifier value.          | Identify the Revenue Number for an existing opportunity revenue using the Revenue Management work area and by exporting the Revenue object by navigating to the following in the Setup and Maintenance work area:                                                                 | Not Required | Conditionally Required Either RevnNumber or Revnld must be passed for identifying a record of Opportunity revenue. If both are passed then only the Revnld field is checked. Not passing either of these results in error. | Conditionally Required Either RevnNumber or Revnld must be passed for identifying a record of Opportunity revenue. If both are passed then only the Revnld field is checked. Not passing either of these results in error. |
|                 |                                                                              | • Offering: Sales  
• Functional Area: Data Import and Export  
• Task: Schedule Export Processes                                                                                      |                                            |                                |                                |
| BUOrgId         | The unique identifier of the business unit.                                  | Not applicable                                                                                               | Required | Do not provide | Do not provide |
| RevnAmountCurycyCode | Currency - The code that represents the currency of the opportunity amount. | You can view valid currency codes by navigating to the following in the Setup and Maintenance work area:                                                                 | Required | The attribute is neither required nor conditionally required. | The attribute is neither required nor conditionally required. |
|                 |                                                                              | • Offering: Sales                                                                                             |                                            |                                |                                |
Create the Source CSV File

You include the data that you want to import into CX Sales and B2B Service in a source CSV file. You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator > Tools > Import Management > Import Objects.
2. Select the Opportunity Revenue object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note: For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.

Note: When you add a product or a product group, a separate line will be added in the opportunity revenue. However, you can't add both the product and the product group simultaneously. You need to use separate requests to add multiple products and product groups.

Create the Import Activity

After you have the CSV file ready, create an import activity to import the opportunity revenue information. To create an import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Opportunity Revenue from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.
Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed. You can drill down on the import activity to go to the Import Status page which provides the status details of the import activity.

Related Topics
- Import Data
- Potential Issues When Opening CSV Files in Excel
- How You Use Alternate Keys to Import Records
- Update Existing Setup Data

Example of Importing Split Revenue Lines
You can use import management to create, update, and delete split revenue lines. Split revenue lines is a type of revenue which is also known as Sales Credit.

There are two types of split revenue known as Revenue Sales Credit and Overlay Sales Credit. For more information on Split Revenue Lines or Sales Credit see Best Practices for Sales Credit in the Related Topics section.

How You Map Your Source Data to Target Object Attributes
To import your split revenue lines data into Oracle Applications Cloud, you must populate a .csv file with your source data and map that source data to target object attributes in Oracle Applications Cloud.

You must do the following before creating the .csv file for data import:

- Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
- Ensure prerequisite steps are complete, such as understanding what attributes are required for importing your objects.
- Understand your options for uniquely identifying the records.
- Ensure parent records exist before importing child records.
- Identify the target object attributes that are required in the .csv file for a successful import.

Select a Unique Identifier for Your Records
All records must be unique in the application. You can use one of these to identify records:

- Public unique identifiers: If you're creating records, then you can provide an easily understandable public unique identifier. These are, usually, denoted with 'Number' and visible in the business object's UI. PUID attributes are usually named <object> Number. If you're updating a record with a Number attribute, then use the Number attribute to identify the record. For more information about public unique identifiers, see the topic "How You Use Alternate Keys to Import Records" in Related Topics section.
- Source system and source system reference: Source system is an identifier for the external system, and source system reference is a unique identifier within the external system. If you’re importing new opportunity revenues or are updating opportunity revenues that have source system reference data, then provide the source system and source system reference values.

Required Attributes and Validations for Importing Opportunity Split Revenue Lines Data

To import data successfully into Oracle Applications Cloud, your .csv file must include the required attributes. Ensure that you provide valid values for the attributes.

This table lists the required attributes for split revenue lines records, prerequisite setup tasks and specific validations, if any:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Tasks or Import Validations</th>
<th>Creating a Split Revenue Line Record</th>
<th>Updating a Split Revenue Line Record</th>
<th>Deleting a Split Revenue Line Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>RevnId</td>
<td>The unique identifier of the summary revenue for this Opportunity.</td>
<td>Not applicable</td>
<td>Not Required</td>
<td>Conditionally Required</td>
<td>Conditionally Required</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Either RevnNumber or RevnId must be passed for identifying a record of Opportunity revenue. If both are passed then only the RevnId field is checked. Not passing either of these results in error.</td>
<td>Either RevnNumber or RevnId must be passed for identifying a record of Opportunity revenue. If both are passed then only the RevnId field is checked. Not passing either of these results in error.</td>
</tr>
</tbody>
</table>
| OptyId      | The unique ID for the existing opportunity record in the destination table. | You can obtain the OptyID for an existing opportunity by exporting the Opportunity object by navigating to the following in the Setup and Maintenance work area:  
  - Offering: Sales  
  - Functional Area: Data Import and Export  
  - Task: Schedule Export Processes | Conditionally Required  
  Either OptyId or OptyNumber is required. | Not Required | Not Required |
<p>| OptyNumber  | The public unique identifier of the opportunity.                            | Not applicable                                 | Conditionally Required              | Not Required                        | Not Required                        |
| RevnNumber  | Revenue Number - The opportunity                                            | Identify the Revenue Number for an existing opportunity | Not Required                        | Conditionally Required              | Conditionally Required              |</p>
<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Tasks or Import Validations</th>
<th>Creating a Split Revenue Line Record</th>
<th>Updating a Split Revenue Line Record</th>
<th>Deleting a Split Revenue Line Record</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>revenue’s unique identifier value.</td>
<td>revenue using the Revenue Management work area and by exporting the Revenue object by navigating to the following in the Setup and Maintenance work area:</td>
<td>Either RevnNumber or RevnId must be passed for identifying a record of Opportunity revenue. If both are passed then only the RevnId field is checked. Not passing either of these results in error.</td>
<td>Either RevnNumber or RevnId must be passed for identifying a record of Opportunity revenue. If both are passed then only the RevnId field is checked. Not passing either of these results in error.</td>
<td>Either RevnNumber or RevnId must be passed for identifying a record of Opportunity revenue. If both are passed then only the RevnId field is checked. Not passing either of these results in error.</td>
</tr>
<tr>
<td>SplitParentRevnId</td>
<td>The unique identifier of the split parent revenue.</td>
<td>Must be a valid Revenue ID</td>
<td>Required</td>
<td>Not Required</td>
<td>Not Required</td>
</tr>
<tr>
<td>ResourcePartyId</td>
<td>The identifier of the resource associated with the child split revenue.</td>
<td>It must be a valid Resource ID</td>
<td>Required</td>
<td>Not Required</td>
<td>Not Required</td>
</tr>
<tr>
<td>SalesCreditTypeCode</td>
<td>The code indicating the type of the sales credit, such as quota or non-quota. A list of valid values is defined in the lookup MOO_SALES_CREDIT_TYPE.</td>
<td>None</td>
<td>Required</td>
<td>Not Required</td>
<td>Not Required</td>
</tr>
<tr>
<td>SplitTypeCode</td>
<td>The code indicating the Split type of the Revenue, such as ParentSplit or ChildSplit.</td>
<td>Must be a valid value as per Lookup MOO_REVN_SPLIT_TYPE.</td>
<td>Required</td>
<td>Not Required</td>
<td>Not Required</td>
</tr>
<tr>
<td>ProductGroupId</td>
<td>The unique identifier of the product group.</td>
<td>None</td>
<td>Required</td>
<td>Not Required</td>
<td>Not Required</td>
</tr>
</tbody>
</table>
Note: Note the following:

• You can't create revenue lines and split revenue line in a single import. You must create a revenue line first and then a split revenue line. You can also create split revenue lines on an existing revenue line.

• Ensure that the commit size is set to a higher value before running imports for a split revenue line. It should be more than the maximum number of split children that are present for any given revenue. Also, you must enable the profile ZCA_STANADR_IMPORT_COMMIT_SIZE.

• To delete a revenue sales credit, you need to update the split percentage of the record to be deleted to 0% and then delete in a separate request. You can't update and delete using a single .csv file.

• To delete an overlay sales credit, you must provide value for either RevnNumber or RevnId for identifying a record of Opportunity Revenue. If both are passed then only the RevnId field is checked. Not passing either of these results in error.

• While passing split lines in .csv, parent split line always has to be added after all child splits to satisfy 100% split percent validation.

• You should provide value for SplitPercent while importing, otherwise an amount with 0 will be created.

Sample Input CSV File

You include the data that you want to import into CX Sales and B2B Service in a source CSV file. Here is a sample .csv file to import split revenue line data:

<table>
<thead>
<tr>
<th>OptyNumber</th>
<th>ProdGroupId</th>
<th>ResourcePartyId</th>
<th>SalesCreditTypeCode</th>
<th>SplitPercent</th>
<th>SplitParentRevnId</th>
</tr>
</thead>
<tbody>
<tr>
<td>CDRM_121495</td>
<td>100000011628005</td>
<td>100010032635399</td>
<td>QUOTA</td>
<td>50</td>
<td>300100541953926</td>
</tr>
<tr>
<td>CDRM_121495</td>
<td>100000011628005</td>
<td>100010025532672</td>
<td>QUOTA</td>
<td>50</td>
<td>300100541953926</td>
</tr>
</tbody>
</table>

Create the Import Activity

After you have the CSV file ready, create an import activity. To create an import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Opportunity Revenue from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the **Map Fields** page. Review and edit the mappings if required.

6. Check the file for unmapped columns or data format issues by clicking **Validate Data**. Click **Next**.

7. Review the import details on the **Review and Submit** page, and click **Submit** when you're ready.

**Related Topics**
- Import Data
- Potential Issues When Opening CSV Files in Excel
- How You Use Alternate Keys to Import Records
- Best Practices for Sales Credits

**Example of Importing Recurring Revenue Data**

You can use import management to create, update, and delete recurring revenue data. Recurring schedules in opportunities enables you to enter and track opportunity products or product groups that are part of a subscription business model.

For more information see Overview of Recurring Opportunity Products in the Related Topics section.

**How You Map Your Source Data to Target Object Attributes**

To import your recurring revenue data into Oracle Applications Cloud, you must populate a .csv file with your source data and map that source data to target object attributes in Oracle Applications Cloud.

You must do the following before creating the .csv file for data import:

- Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
- Ensure prerequisite steps are complete, such as understanding what attributes are required for importing your objects.
- Understand your options for uniquely identifying the records.
- Ensure parent records exist before importing child records.
- Identify the target object attributes that are required in the .csv file for a successful import.

**Select a Unique Identifier for Your Records**

All records must be unique in the application. You can use one of these to identify records:

- Public unique identifiers: If you’re creating records, then you can provide an easily understandable public unique identifier. These are, usually, denoted with ‘Number’ and visible in the business object's UI. PUID attributes are usually named <object> Number. If you're updating a record with a Number attribute, then use the Number attribute to identify the record. For more information about public unique identifiers, see the topic "How You Use Alternate Keys to Import Records" in Related Topics section.
- Source system and source system reference: Source system is an identifier for the external system, and source system reference is a unique identifier within the external system. If you’re importing new opportunity revenues or are updating opportunity revenues that have source system reference data, then provide the source system and source system reference values.
**Required Attributes and Validations for Importing Recurring Revenue Data**

To import data successfully into Oracle Applications Cloud, your .csv file must include the required attributes. Ensure that you provide valid values for the attributes.

This table lists the required attributes for recurring revenue data records, prerequisite setup tasks and specific validations, if any:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Tasks or Import Validations</th>
<th>Creating a Recurring Revenue Record</th>
<th>Updating a Recurring Revenue Record</th>
<th>Deleting a Recurring Revenue Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>RevnId</td>
<td>The unique identifier of the summary revenue for this Opportunity.</td>
<td>Not applicable</td>
<td>Conditionally Required</td>
<td>Conditionally Required</td>
<td>Conditionally Required</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Either RevnNumber or RevnId must be passed for identifying a record of Opportunity revenue. If both are passed then only the RevnId field is checked. Not passing either of these results in error.</td>
<td>Either RevnNumber or RevnId must be passed for identifying a record of Opportunity revenue. If both are passed then only the RevnId field is checked. Not passing either of these results in error.</td>
<td>Either RevnNumber or RevnId must be passed for identifying a record of Opportunity revenue. If both are passed then only the RevnId field is checked. Not passing either of these results in error.</td>
</tr>
</tbody>
</table>
| OptyId      | The unique identifier for the existing opportunity record in the destination table. | You can obtain the OptyId for an existing opportunity by exporting the Opportunity object by navigating to the following in the Setup and Maintenance work area:  
  • Offering: Sales  
  • Functional Area: Data Import and Export  
  • Task: Schedule Export Processes | Conditionally Required  
  Either OptyId or OptyNumber is required. | Not Required | Not Required |
| OptyNumber  | The public unique identifier of the opportunity.                             | Not applicable                                | Conditionally Required  
  Either OptyId or OptyNumber is required. | Not Required | Not Required |
| RevnNumber  | The alternate unique identifier of the revenue.                              | Identify the Revenue Number for an existing opportunity revenue using the Revenue Management work area and by exporting the Revenue object by navigating to the following in the Setup and | Conditionally Required  
  Either RevnNumber or RevnId must be passed for identifying a record of Opportunity revenue. If both are passed then only the RevnId field is checked. Not passing | Conditionally Required  
  Either RevnNumber or RevnId must be passed for identifying a record of Opportunity revenue. If both are passed then only the RevnId field is checked. Not passing | Conditionally Required  
  Either RevnNumber or RevnId must be passed for identifying a record of Opportunity revenue. If both are passed then only the RevnId field is checked. Not passing |
<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Tasks or Import Validations</th>
<th>Creating a Recurring Revenue Record</th>
<th>Updating a Recurring Revenue Record</th>
<th>Deleting a Recurring Revenue Record</th>
</tr>
</thead>
</table>
|                  | Maintenance work area:                                                      | • Offering: Sales  
• Functional Area: Data Import and Export  
• Task: Schedule Export Processes                                                                 | either of these results in error.   | either of these results in error.   | either of these results in error.   |
| RecurFrequencyCode| The code that indicates the frequency of recurrence for the child revenue.   | A list of valid values is defined in the lookup MOO_RECURRING_FREQUENCY.                                      | Required                           | Not Required                       | Not Required                       |
| RecurNumberPeriods| The number of times the child revenue should recur.                         | None                                                                                                        | Conditionally Required Either RecurNumberPeriods or RecurEndDate is required | Not Required                       | Not Required                       |
| RecurEndDate      | The date when the child revenue recurrence ends.                            | None                                                                                                        | Conditionally Required Either RecurNumberPeriods or RecurEndDate is required | Not Required                       | Not Required                       |
| RecurStartDate    | The date when the recurrence starts.                                        | None                                                                                                        | Conditionally Required Either RecurStartDate or EffectiveDate is required | Not Required                       | Not Required                       |
| EffectiveDate     | The date when the child revenue closes.                                     | None                                                                                                        | Conditionally Required Either RecurStartDate or EffectiveDate is required | Not Required                       | Not Required                       |
| ScheduleAction    | The transient attribute. Need to pass a value to indicate the action to be taken on recurring schedule such as ADD and DELETE. | None                                                                                                        | Required                           | Not Required                       | Required                           |

470
Sample Input CSV File
You include the data that you want to import into CX Sales and B2B Service in a source CSV file. Here is a sample .csv file to import recurring revenue data:

<table>
<thead>
<tr>
<th>OptyNumber</th>
<th>RevnId</th>
<th>RecurFrequencyCode</th>
<th>RecurNumberPeriods</th>
<th>EffectiveDate</th>
<th>ScheduleAction</th>
</tr>
</thead>
<tbody>
<tr>
<td>CDRM_123532</td>
<td>300100546223965</td>
<td>MONTHLY</td>
<td>3</td>
<td>12/25/2021</td>
<td>ADD</td>
</tr>
</tbody>
</table>

Create the Import Activity
After you have the CSV file ready, create an import activity. To create an import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Opportunity Revenue from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you’re ready.

Related Topics
- Import Data
- Potential Issues When Opening CSV Files in Excel
- How You Use Alternate Keys to Import Records
- Overview of Recurring Opportunity Products

Import Your Opportunity Source Data
You can use the Import Management to create, update, or delete opportunity source records.

You can import opportunity source records using these steps:

1. Map your source opportunity source data to Oracle Applications Cloud object attributes. This way the import process would know where to insert each of the information bits.
2. Create the source CSV file with the opportunity source data you want to import.
4. Check the import results to know if the import went well.

How You Map Your Source Data to Target Object Attributes
To import your opportunity source data into Oracle Applications Cloud, you must populate a .csv file with your source data and map that source data to target object attributes in Oracle Applications Cloud.
You must do the following before creating the .csv file for data import:

- Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
- Ensure prerequisite steps are complete, such as understanding what attributes are required for importing your objects.
- Understand your options for uniquely identifying the records.
- Ensure parent records exist before importing child records.
- Identify the target object attributes that are required in the .csv file for a successful import.

Before You Start

You must do some basic checks before starting your import. For example, make sure that:

- You have completed all the prerequisites for importing each attribute in your source data.
- You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records

All records must be unique in the application. You can use one of these to identify records:

- Public unique identifiers: If you're creating records, then you can provide an easily understandable public unique identifier. These are, usually, denoted with 'Number' and visible in the business object's UI. PUID attributes are usually named `<object> Number`. If you're updating a record with a Number attribute, then use the Number attribute to identify the record. For more information about public unique identifiers, see the topic "How You Use Alternate Keys to Import Records" in Related Topics section.
- Source system and source system reference: Source system is an identifier for the external system, and source system reference is a unique identifier within the external system. If you're importing new opportunity sources or are updating opportunity sources that have source system reference data, then provide the source system and source system reference values.

Required Attributes and Validations Opportunity Source Object

To import data successfully into Oracle Applications Cloud, your .csv file must include the required attributes. Ensure that you provide valid values for the attributes.

This table lists the required attributes for opportunity source records, prerequisite setup tasks and specific validations, if any:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Tasks or Import Validations</th>
<th>Creating an Opportunity Source Record</th>
<th>Updating an Existing Opportunity Source Record</th>
<th>Deleting an Existing Opportunity Source Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>OptySrcId</td>
<td>The unique ID for the existing campaign source code relationship record in the destination table.</td>
<td>Identify the ID for an existing campaign source code relationship by exporting the Opportunity Source object by navigating to the following in the Setup and</td>
<td>The attribute is neither required nor conditionally required.</td>
<td>The attribute is neither required nor conditionally required.</td>
<td>Conditionally required.</td>
</tr>
</tbody>
</table>
### Attribute | Description | Prerequisite Setup Tasks or Import Validations | Creating an Opportunity Source Record | Updating an Existing Opportunity Source Record | Deleting an Existing Opportunity Source Record
--- | --- | --- | --- | --- | ---
| | | Maintenance work area: | | | |
| | | • Offering: Sales | | | |
| | | • Functional Area: Data Import and Export | | | |
| | | • Task: Schedule Export Processes | | | |
| OptyId | The unique ID for the existing opportunity record in the destination table. | You can obtain the OptyId for an existing opportunity by exporting the Opportunity object by navigating to the following in the Setup and Maintenance work area: | Conditionally Required | Conditionally Required | Conditionally Required |
| | | • Offering: Sales | | | |
| | | • Functional Area: Data Import and Export | | | |
| | | • Task: Schedule Export Processes | | | |
| OptyNumber | The public unique identifier of the opportunity. | Not applicable. | Conditionally Required | Conditionally Required | Conditionally Required |

Go to Navigator > Tools > Import Management > Import Objects, to see all the attributes of the opportunity source object. The page also lists attribute information like type, length, description, and so on.

### Create the Source CSV File
You include the data that you want to import into CX Sales and B2B Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator > Tools > Import Management > Import Objects.
2. Select the Opportunity Source object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

**Note:** For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.
Create the Import Activity

After you have the CSV file ready, create an import activity to import the opportunity source information. To create an import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Opportunity Source from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results

Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.
   You can drill down on the import activity to go to the Import Status page which provides the status details of the import activity.

Related Topics

Import Your Opportunity Team Member Data

You can use the Import Management to create, update, or delete opportunity team member records.

You can import opportunity team member records using these steps:

1. Map your source opportunity team member data to Oracle Applications Cloud object attributes. This way the import process would know where to insert each of the information bits.
2. Create the source CSV file with the opportunity team member data you want to import.
4. Check the import results to know if the import went well.

How You Map Your Source Data to Target Object Attributes

To import your opportunity team member data into Oracle Applications Cloud, you must populate a .csv file with your source data and map that source data to target object attributes in Oracle Applications Cloud.

You must do the following before creating the .csv file for data import:

- Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
- Ensure prerequisite steps are complete, such as understanding what attributes are required for importing your objects.
Oracle CX
Understanding Import and Export Management for CX
Sales and B2B Service

Chapter 8
Import Your Data

• Understand your options for uniquely identifying the records.
• Ensure parent records exist before importing child records.
• Identify the target object attributes that are required in the .csv file for a successful import

Before You Start

You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.
• You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records

All records must be unique in the application. You can use one of these to identify records:

• Public unique identifiers: If you’re creating records, then you can provide an easily understandable public unique identifier. These are, usually, denoted with 'Number' and visible in the business object’s UI. PUID attributes are usually named <object> Number. If you’re updating a record with a Number attribute, then use the Number attribute to identify the record. For more information about public unique identifiers, see the topic "How You Use Alternate Keys to Import Records" in Related Topics section.
• Source system and source system reference: Source system is an identifier for the external system, and source system reference is a unique identifier within the external system. If you’re importing new opportunity team members or are updating opportunity team members that have source system reference data, then provide the source system and source system reference values.

Required Attributes and Validations for Opportunity Team Member Object

To import data successfully into Oracle Applications Cloud, your .csv file must include the required attributes. Ensure that you provide valid values for the attributes.

This table lists the required attributes for opportunity team member records, prerequisite setup tasks and specific validations, if any:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Tasks or Import Validations</th>
<th>Creating an Opportunity Team Member Record</th>
<th>Updating an Existing Opportunity Team Member Record</th>
<th>Deleting an Existing Opportunity Team Member Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>OptyResourceId</td>
<td>The unique identifier for the opportunity resource.</td>
<td>Not applicable.</td>
<td>Required</td>
<td>Conditionally Required</td>
<td>Conditionally Required</td>
</tr>
<tr>
<td>OptyId</td>
<td>The unique ID for the existing opportunity record in the destination table.</td>
<td>You can obtain the OptyId for an existing opportunity by exporting the Opportunity object by navigating to the following in the Setup and Maintenance work area: • Offering: Sales</td>
<td>Conditionally Required Either OptyId or OptyNumber is required.</td>
<td>Conditionally Required</td>
<td>Conditionally Required</td>
</tr>
</tbody>
</table>
### Attribute | Description | Prerequisite Setup Tasks or Import Validations | Creating an Opportunity Team Member Record | Updating an Existing Opportunity Team Member Record | Deleting an Existing Opportunity Team Member Record
--- | --- | --- | --- | --- | ---
OptyNumber | The public unique identifier of the opportunity. | Not applicable. | Conditionally Required Either OptyId or OptyNumber is required. | Conditionally Required | Conditionally Required
ResourceId | The unique party ID for the existing Account Team Member record. | Identify the resource ID value by exporting the resource object by navigating to the following in the Setup and Maintenance work area: | The attribute is neither required nor conditionally required. | To identify the party, provide either the record ID (PartnerAccountId) or both the source system code and reference values that you provided when importing the party in a prior import batch (PartyOrigSystem and PartyOrigSystemRef). | The attribute is neither required nor conditionally required.

Go to **Navigator** > **Tools** > **Import Management** > **Import Objects**, to see all the attributes of the opportunity team member object. The page also lists attribute information like type, length, description, and so on.

### Create the Source CSV File

You include the data that you want to import into CX Sales and B2B Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to **Navigator** > **Tools** > **Import Management** > **Import Objects**.
2. Select the **Opportunity Team Member** object in the table and click **Download**.

You can now edit the downloaded file and provide valid values for the required attributes.

**Note:** For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.

### Create the Import Activity

After you have the CSV file ready, create an import activity to import the opportunity team member information. To create an import activity:

1. Go to **Navigator** > **Tools** > **Import Management** > **Import Queue**.
2. Click **Create Import Activity** in the **Manage Imports** page.
3. In the **Enter Import Options** page, provide a name for the import activity, and select Opportunity Team Member from the **Object** drop-down list.
4. Select the CSV file in the **File Name** field, and click **Next**.
5. You would see that the source and target attributes are automatically mapped in the **Map Fields** page. Review and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking **Validate Data**. Click **Next**.
7. Review the import details on the **Review and Submit** page, and click **Submit** when you're ready.

**Review the Import Results**

Check if your import succeeded on the **Manage Imports** page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to **Navigator > Tools > Import Management > Import Queue**.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the **Status** column for the import activity. The import is successful if the status displays as **Completed**. You can drill down on the import activity to go to the **Import Status** page which provides the status details of the import activity.

**Related Topics**

- Import Data
- Potential Issues When Opening CSV Files in Excel
- How You Use Alternate Keys to Import Records
- Update Existing Setup Data

**Import Your Organization Data**

You can use Import Management to create or update Organization records.

To import Organization records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

**How You Map Your Source Data to Target Object Attributes**

To import your Organization data into Oracle Applications Cloud, you need to populate a CSV file with your source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

- Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
- Ensure prerequisite setups are done, if applicable.
- Understand your options for uniquely identifying the records.
- Ensure parent records exist before importing child records.
Import Your Data

Before You Start

You must do some basic checks before starting your import. For example, make sure that:

- You have completed all the prerequisites for importing each attribute in your source data.
- You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records

All records must be unique in the application. You can use one of these to identify records:

- Public unique identifiers: If you’re creating records, then you can provide an easily understandable public unique identifier. These are, usually, denoted with ‘Number’ and visible in the business object’s UI. PUID attributes are usually named <object> Number. If you’re updating a record with a Number attribute, then use the Number attribute to identify the record. For more information about public unique identifiers, see the topic "How You Use Alternate Keys to Import Records" in Related Topics section.
- Source system and source system reference: Source system is an identifier for the external system, and source system reference is a unique identifier within the external system. If you’re importing new organizations or are updating organizations that have source system reference data, then provide the source system and source system reference values.

Required Attributes and Validations for Organization Object

To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure that you provide valid values for the attributes. This table lists the required attributes for importing new Organization records, required attributes for updating Organization records, prerequisite setup tasks for the attributes, and specific validations, if any, for Organization import:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/Import Validations</th>
<th>Creating an Organization Record</th>
<th>Updating an Existing Organization Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>SourceSystem</td>
<td>The original source system name</td>
<td>Know the source system.</td>
<td>Conditionally Required</td>
<td>Conditionally Required</td>
</tr>
<tr>
<td></td>
<td></td>
<td>To view source systems, use the Manage Trading Community Source System task.</td>
<td>To identify an organization record, use one of these:</td>
<td>To identify an organization record, use one of these:</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• Combination of SourceSystem and SourceSystemReference</td>
<td>• Combination of SourceSystem and SourceSystemReferenceValue</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• PartyNumber</td>
<td>• PartyNumber</td>
</tr>
<tr>
<td>SourceSystemReferenceValue</td>
<td>The identifier in the original source system</td>
<td>Know the source system reference value.</td>
<td>Conditionally Required</td>
<td>Conditionally Required</td>
</tr>
<tr>
<td></td>
<td></td>
<td>To view the source systems reference, use the Manage Trading Community Source System task.</td>
<td>To identify an organization record, use one of these:</td>
<td>To identify an organization record, use one of these:</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• Combination of SourceSystem and SourceSystemReference</td>
<td>• Combination of SourceSystem and SourceSystemReferenceValue</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• PartyNumber</td>
<td>• PartyNumber</td>
</tr>
<tr>
<td>Attribute</td>
<td>Description</td>
<td>Prerequisite Setup Task/Import Validations</td>
<td>Creating an Organization Record</td>
<td>Updating an Existing Organization Record</td>
</tr>
<tr>
<td>--------------------</td>
<td>-----------------------------------------------------------------------------</td>
<td>-------------------------------------------------------------------------------------------------------------</td>
<td>------------------------------------------</td>
<td>------------------------------------------</td>
</tr>
<tr>
<td>PartyNumber</td>
<td>The public unique identifier of the party.</td>
<td>Know party number. To obtain a list of all party IDs and party numbers, export the Party object.</td>
<td>Conditionally Required</td>
<td>Conditionally Required</td>
</tr>
<tr>
<td>OrganizationName</td>
<td>The name of the party of the Organization party type.</td>
<td>The organization names are listed in the Resource Directory.</td>
<td>Required</td>
<td>Conditionally Required</td>
</tr>
<tr>
<td>PartyUsageCode</td>
<td>Specifies the party usage code to which the organization is associated</td>
<td>This should be an active value in the HZ_PARTY_USAGES_B table.</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td>CleanlinessScore</td>
<td>The overall score for the account or contact record for the category Cleanliness</td>
<td>No validation</td>
<td>Optional</td>
<td>Optional</td>
</tr>
<tr>
<td>CompletenessScore</td>
<td>The overall score for the account or contact record for the category Completeness</td>
<td>No validation</td>
<td>Optional</td>
<td>Optional</td>
</tr>
<tr>
<td>DataConfidenceScore</td>
<td>The overall data confidence score that indicates the level of data quality for a record</td>
<td>No validation</td>
<td>Optional</td>
<td>Optional</td>
</tr>
<tr>
<td>DatafoxCompanyId</td>
<td>A unique identifier for the &quot;Datafox&quot; company</td>
<td>No validation</td>
<td>Optional</td>
<td>Optional</td>
</tr>
<tr>
<td>DuplicateIndicator</td>
<td>Signifies the duplicate status of the record that’s determined as follows:</td>
<td>No validation</td>
<td>Optional</td>
<td>Optional</td>
</tr>
<tr>
<td></td>
<td>• A null value indicates that the record isn’t a duplicate or hasn’t been evaluated.</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>• The record can also have one of 2 other values - DUPE (record is a duplicate) or LINK (record is linked to another record).</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>DuplicateScore</td>
<td>The overall score for the account or contact record for the category Duplicate</td>
<td>No validation</td>
<td>Optional</td>
<td>Optional</td>
</tr>
<tr>
<td>Attribute</td>
<td>Description</td>
<td>Prerequisite Setup Task/Import Validations</td>
<td>Creating an Organization Record</td>
<td>Updating an Existing Organization Record</td>
</tr>
<tr>
<td>-------------------</td>
<td>-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
<td>-------------------------------------------</td>
<td>---------------------------------</td>
<td>--------------------------------------------</td>
</tr>
<tr>
<td>EnquiryDuns</td>
<td>A unique identifier used to query the Dun and Bradstreet data. If the location is a branch, in some countries the &quot;DUNS&quot; number of the headquarters is used to run the query. Otherwise, the &quot;DUNS&quot; number is considered.</td>
<td>No validation</td>
<td>Optional</td>
<td>Optional</td>
</tr>
<tr>
<td>EnrichmentScore</td>
<td>The overall score for the account or contact record for the category <em>Enrichment</em></td>
<td>No validation</td>
<td>Optional</td>
<td>Optional</td>
</tr>
<tr>
<td>LastScoreUpdateDate</td>
<td>The date and time at which this record was updated by the source system in the last update source system column</td>
<td>No validation</td>
<td>Optional</td>
<td>Optional</td>
</tr>
<tr>
<td>RecencyScore</td>
<td>The overall score for the account or contact record for the category <em>Recency</em></td>
<td>No validation</td>
<td>Optional</td>
<td>Optional</td>
</tr>
<tr>
<td>ThirdPartyFlag</td>
<td>This option tracks if a party has a direct relationship with the organization using Oracle receivables or through a third party supplier. The value Y denotes third party relationship, while the value N denotes direct relationship. If Oracle Service is installed, the Third Party field in the Customers window is mandatory.</td>
<td>No validation</td>
<td>Optional</td>
<td>Optional</td>
</tr>
<tr>
<td>ValidatedFlag</td>
<td>Indicates if the party was validated. The value Y denotes a validated party, while the value N denotes a party that's not validated.</td>
<td>No validation</td>
<td>Optional</td>
<td>Optional</td>
</tr>
<tr>
<td>ValidityScore</td>
<td>The overall score for the account or contact record for the category <em>Validity</em></td>
<td>No validation</td>
<td>Optional</td>
<td>Optional</td>
</tr>
</tbody>
</table>

You can view the Organization object along with all its child objects and attributes in the Manage Import Objects page of the Import Management flow. You can find attribute information like type, length, description, and so on, on this page.
Create the Source CSV File

You include the data that you want to import into CX Sales and B2B Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator > Tools > Import Management > Import Objects.
2. Select the Organization object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note: For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity

After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Organization from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results

Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed. You can drill down on the import activity to go to the Import Status page which provides the status details of the import activity.

Related Topics
- Potential Issues When Opening CSV Files in Excel
- How You Use Alternate Keys to Import Records
- Import Data

Import Your Overflow Queue Resource Data

You can use Import Management to create or update Overflow Queue Resource records.
To import Overflow Queue Resource records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes

To import your Overflow Queue Resource data into Oracle Applications Cloud, you need to populate a CSV file with your source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

- Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
- Ensure prerequisite setups are done, if applicable.
- Understand your options for uniquely identifying the records.
- Ensure parent records exist before importing child records.
- Identify the target object attributes that are required in the CSV file for a successful import.

Before You Start

You must do some basic checks before starting your import. For example, make sure that:

- You have completed all the prerequisites for importing each attribute in your source data.
- You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records

All records must be unique in the application. You can use one of these to identify records:

- Public unique identifiers: If you're creating records, then you can provide an easily understandable public unique identifier. These are, usually, denoted with 'Number' and visible in the business object's UI. PUID attributes are usually named <object> Number. If you're updating a record with a Number attribute, then use the Number attribute to identify the record. For more information about public unique identifiers, see the topic "How You Use Alternate Keys to Import Records" in Related Topics section.
- Source system and source system reference: Source system is an identifier for the external system, and source system reference is a unique identifier within the external system. If you're importing new overflow queue resources or are updating overflow queue resources that have source system reference data, then provide the source system and source system reference values.

Required Attributes and Validations for Overflow Queue Resource Object

To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure that you provide valid values for the attributes. This table lists the required attributes for importing new Overflow Queue Resource records, required attributes for updating Overflow Queue Resource records, prerequisite setup tasks for the attributes, and specific validations, if any, for Overflow Queue Resource import:
<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/Import Validations</th>
<th>Creating a Overflow Queue Resource Record</th>
<th>Updating an Existing Overflow Queue Resource Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>QueueResourceId</td>
<td>The unique identifier of the overflow queue resource.</td>
<td>No Validation</td>
<td>Not Required</td>
<td>Not Required</td>
</tr>
<tr>
<td>ObjectId</td>
<td>The unique identifier of the overflow queue added as a queue resource.</td>
<td>The queue should exist.</td>
<td>Conditionally Required</td>
<td>Not Required</td>
</tr>
<tr>
<td>OverflowQueueNumber</td>
<td>The public unique identifier of the overflow queue associated with the queue.</td>
<td>The queue should exist.</td>
<td>Conditionally Required</td>
<td>Not Required</td>
</tr>
<tr>
<td>Queueld</td>
<td>The unique identifier of the queue.</td>
<td>The queue should exist.</td>
<td>Conditionally Required</td>
<td>Not Required</td>
</tr>
<tr>
<td>QueueNumber</td>
<td>The public unique identifier of the queue to which the resource is associated.</td>
<td>The queue should exist.</td>
<td>Conditionally Required</td>
<td>Not Required</td>
</tr>
<tr>
<td>EnabledFlag</td>
<td>Contains the values, True or False. If True, then the queue resource member is enabled. If False, then the queue resource member isn't enabled. The default value is True.</td>
<td>No Validation</td>
<td>Not Required</td>
<td>Not Required</td>
</tr>
<tr>
<td>Priority</td>
<td>The priority of the overflow queue resource.</td>
<td>No Validation</td>
<td>Not Required</td>
<td>Not Required</td>
</tr>
</tbody>
</table>

You can view the Overflow Queue Resource object along with all its child objects and attributes in the Manage Import Objects page of the Import Management flow. You can find attribute information like type, length, description, and so on, on this page.

Create the Source CSV File
You include the data that you want to import into CX Sales and B2B Service in a source CSV file.
You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator > Tools > Import Management > Import Objects.
2. Select the **Overflow Queue Resource** object in the table and click **Download**.

You can now edit the downloaded file and provide valid values for the required attributes.

**Note:** For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity

After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to **Navigator > Tools > Import Management > Import Overflow Queue Resource**.
2. Click **Create Import Activity** in the **Manage Imports** page.
3. In the **Enter Import Options** page, provide a name for the import activity, and select Overflow Queue Resource from the **Object** drop-down list.
4. Select the CSV file in the **File Name** field, and click **Next**.
   
   You would see that the source and target attributes are automatically mapped in the **Map Fields** page. Review and edit the mappings if required.
5. Check the file for unmapped columns or data format issues by clicking **Validate Data**. Click **Next**.
6. Review the import details on the **Review and Submit** page, and click **Submit** when you’re ready.

Review the Import Results

Check if your import succeeded on the **Manage Imports** page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to **Navigator > Tools > Import Management > Import Overflow Queue Resource**.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the **Status** column for the import activity. The import is successful if the status displays as **Completed**.
   
   You can drill down on the import activity to go to the **Import Status** page which provides the status details of the import activity.

**Related Topics**

- Potential Issues When Opening CSV Files in Excel
- How You Use Alternate Keys to Import Records
- Import Data

Import Your Partner Data

You can use the Import Management to create or update Partner records.

To import Partner records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (.csv) file for import.
3. Create the import activity.
4. Review the import results.
How You Map Your Source Data to Target Object Attributes

To import your Partner data into Oracle Applications Cloud, you need to populate a CSV file with your source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the .CSV file for data import:

- Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
- Ensure prerequisite steps are complete, such as understanding what attributes are required for importing your objects.
- Understand your options for uniquely identifying the records.
- Ensure parent records exist before importing child records.
- Identify the target object attributes that are required in the .CSV file for a successful import.

Before You Start

You must do some basic checks before starting your import. For example, make sure that:

- You have completed all the prerequisites for importing each attribute in your source data.
- You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records

To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the import process to uniquely identify the records. The file import process uses the attribute values to automatically map your source data to the target object attributes in Oracle Applications Cloud.

The preferred options to uniquely identify an object record are as follows:

- **Internal ID**: If you’re identifying a record that already exists in Oracle Applications Cloud, then you can use the internal ID of the record, a system-generated unique identifier Attributes with "id" in the attribute name are typically internal IDs. You can determine the internal ID of a record by exporting Oracle Applications Cloud object data, or by doing a transactional database query. Using an internal ID typically provides better performance and reduces the import duration. For the Partner object, this attribute is PartyId:

- **Public unique identifiers**: If you’re creating new records, then you can provide a user-friendly public unique identifier (attributes denoted with 'Number' and usually visible in the business object’s UI). If you update a record for which you have previously provided a Number attribute, or for which a Number attribute is visible in the object’s UI, you can use the Number attribute to identify the record. For the Partner object, the attribute is CompanyNumber.

Required Attributes and Validations for Partner Object

To import data successfully into Oracle Applications Cloud, your .CSV file must include the required attributes. Ensure that you provide valid values for the attributes.

To update the status of a partner, create an import by providing values for the attributes PartyId, Status, and CompanyNumber in the CSV file.

This table lists the required attributes for importing new Partner records, required attributes for updating Partner records, prerequisite setup tasks for the attributes, and specific validations, if any, for Partner import:
<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Data Type</th>
<th>Data Length</th>
<th>Prerequisite Setup Task/Import Validations</th>
<th>Creating a Partner Record</th>
<th>Updating an Existing Partner Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>OrganizationName</td>
<td>The name of the organization</td>
<td>Text</td>
<td>360</td>
<td>The value is required if creating a new organization.</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td>AddressLineOne</td>
<td>The first line of the postal address</td>
<td>Text</td>
<td>240</td>
<td>No validation</td>
<td>Required</td>
<td>Not required</td>
</tr>
</tbody>
</table>
| Country           | The country code of the postal address                                      | Text      | 2           | If providing a value, the value must exist in the FND_TERRITORIES_B table. You can view valid country codes. Navigate to the following in the Setup and Maintenance work area:  
  • Offering: Sales  
  • Functional Area: Data Import and Export  
  • Task: Manage Territories | Required                  | Not Required                     |
| PartyId           | The unique ID for the existing partner organization's party record in the destination table | Number    | 18          | Identify the PARTY_ID for an existing partner party by exporting the Partner Profile object. Navigate to the following in the Setup and Maintenance work area:  
  • Offering: Sales  
  • Functional Area: Data Import and Export  
  • Task: Manage Bulk Data Export, Schedule Export Processes | Not required | A value is required either for PartyId or CompanyNumber. |
Create the Source CSV File

You include the data that you want to import into CX Sales and B2B Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator > Tools > Import Management > Import Objects.
2. Select the Partner object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

You can specify the required role while creating the first partner contact for a partner. Also, once the first partner contact has been created, you can update the role for this partner contact.

**Note:** For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity

To import data into Oracle Applications Cloud, you need to create an import activity and provide the CSV file as an input to the activity.

To create an import activity, do the following:

1. In the Navigator, under Tools, click Import Management.
2. On the Manage Imports page, click Create Import Activity.
3. In the Create Import Activity: Enter Import Options page, provide a name for the import activity, and select Partner from the Object drop-down list.
In File Name, browse and upload the required .CSV file, and click Next.

5. In the Create Import Activity: Map Fields page edit the attribute mappings if required, and click Next.
   
   **Note:** Click Validate Data to validate the mapping of the source file for unmapped columns and to check for data format issues.

6. In the Create Import Activity: Review and Submit page, click Submit.

Review the Import Results

You can review the import results by checking for the import activity in the Manage Import Activity page. A file import activity is said to be successful when its status displays as Completed. To check the status of the import activity, do as follows:

1. In the Navigator, under Tools, click Import Management.
2. On the Manage Imports page, search for the import activity that you created using one of the search criteria, such as status, name, object, and so on.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed. The other valid values for the import activity status are Queued for import, Preparing data for import, Importing data, Completed with errors, and Unsuccessful.

   **Note:** On this page you can also quickly view the number and status of all active imports, completed imports, and unsuccessful imports that have been submitted.

Related Topics

- Potential Issues When Opening CSV Files in Excel
- Import Data

Import Your Partner Account Resource Data

You can use the import functionality to create or update Partner Account Resource records.

You can import Partner Account Resource records using these steps:

1. Map your source data to Oracle Applications Cloud object attributes. This way the import process would know where to insert each of the information bits.
2. Create the source CSV file with the Partner Account Resource data you want to import.
4. Check the import results to know if the import went well.

How You Map Your Source Data to Target Object Attributes

You import Partner Account Resource data into Oracle Applications Cloud from a CSV file containing your source data that’s mapped to target Oracle Applications Cloud object attributes.

Before you create the source data file, you should:

- Know how your source data attributes map to the target object attributes in Oracle Applications Cloud. Match each column from the source file to an attribute in the Partner Account Resource import object.
Import Your Data

Before You Start

You must do some basic checks before starting your import. For example, make sure that:

- You have completed all the prerequisites for importing each attribute in your source data.
- You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records

All records must be unique in the application. You can use one of these to identify records:

- **Public unique identifiers**: If you're creating records, then you can provide an easily understandable public unique identifier. These are, usually, denoted with 'Number' and visible in the business object's UI. PUID attributes are usually named `<object> Number`. If you're updating a record with a Number attribute, then use the Number attribute to identify the record. For more information about public unique identifiers, see the topic "How You Use Alternate Keys to Import Records" in Related Topics section.

- **Source system and source system reference**: Source system is an identifier for the external system, and source system reference is a unique identifier within the external system. If you're importing new Partner Account Resource or are updating Partner Account Resource that have source system reference data, then provide the source system and source system reference values.

Required Attributes and Validations for Partner Account Resource Object

To import data successfully into Oracle Applications Cloud, your .CSV file must include the required attributes. Ensure that you provide valid values for the attributes.

This table lists the required attributes for Partner Account Resource records, prerequisite setup tasks and specific validations, if any:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/ Import Validations</th>
<th>Creating a Partner Account Resource record</th>
<th>Updating an Existing Partner Account Resource record</th>
</tr>
</thead>
<tbody>
<tr>
<td>AccessLevelCode</td>
<td>The attribute that determines the access type (namely, Edit, Full Access, View Only) granted to the resource.</td>
<td>A value is required when adding a new resource to the team.</td>
<td>Not Required</td>
<td>Not required</td>
</tr>
</tbody>
</table>
Go to Navigator > Tools > Import Management > Import Objects, to see all the attributes of the Partner Account Resource object. The page also lists attribute information like type, length, description, and so on.

Create the Source CSV File
You include the data that you want to import into CX Sales and B2B Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator > Tools > Import Management > Import Objects.
2. Select the Partner Account Resource object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

**Note:** For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the Partner Account Resource information. To create an import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. On the Manage Imports page, click Create Import Activity.
3. In the Create Import Activity: Enter Import Options page, provide a name for the import activity, and select Partner Account Resource from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

**Note:** To access and submit the import activities for Partner Contact, the user must be assigned the job roles of the Channel operations manager.

### Review the Import Results

Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to Go to **Navigator > Tools > Import Management > Import Queue**.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed. You can drill down on the import activity to go to the Import Status page which provides the status details of the import activity.

**Related Topics**
- How You Use Alternate Keys to Import Records
- Potential Issues When Opening CSV Files in Excel

### Import Your Partner Address Data

You can use the import functionality to create or update Partner Address records.

You can import Partner Address records using these steps:

1. Map your source data to Oracle Applications Cloud object attributes. This way the import process would know where to insert each of the information bits.
2. Create the source CSV file with the Partner Address data you want to import.
4. Check the import results to know if the import went well.

### How You Map Your Source Data to Target Object Attributes

You import Partner Address data into Oracle Applications Cloud from a CSV file containing your source data that's mapped to target Oracle Applications Cloud object attributes.

Before you create the source data file, you should:

- Know how your source data attributes map to the target object attributes in Oracle Applications Cloud. Match each column from the source file to an attribute in the Partner Address import object.
- Finish all prerequisite steps, such as understanding what attributes are required for importing your objects.
- Know how you can uniquely identify the records.
Import Your Data

• Check the target object attributes required in the CSV file for a successful import.
• Ensure that you don’t insert duplicate Partner Address while importing, to avoid redundant data.

If you want to import only a few records, then you can create a single CSV file for all Partner Address attributes. However, if you want to import a large number of records, then you may decide to create multiple CSV files, one for each of the Partner Address child objects. Note that you must have imported the CSV file for Partner Address object successfully before trying to import the CSV files for the child objects. There are separate help topics describing how to import each of these child objects.

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.
• You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
All records must be unique in the application. You can use one of these to identify records:

• Public unique identifiers: If you’re creating records, then you can provide an easily understandable public unique identifier. These are, usually, denoted with ‘Number’ and visible in the business object’s UI. PUID attributes are usually named <object> Number. If you’re updating a record with a Number attribute, then use the Number attribute to identify the record. For more information about public unique identifiers, see the topic ”How You Use Alternate Keys to Import Records” in Related Topics section.
• Source system and source system reference: Source system is an identifier for the external system, and source system reference is a unique identifier within the external system. If you’re importing new Partner Address or are updating Partner Address that have source system reference data, then provide the source system and source system reference values.

Required Attributes and Validations for Partner Address Object
To import data successfully into Oracle Applications Cloud, your .CSV file must include the required attributes. Ensure that you provide valid values for the attributes.

This table lists the required attributes for Partner Address records, prerequisite setup tasks and specific validations, if any:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/ Import Validations</th>
<th>Creating an Partner Address record</th>
<th>Updating an Existing Partner Address record</th>
</tr>
</thead>
<tbody>
<tr>
<td>LocationId</td>
<td>The internal ID for the location.</td>
<td>No validation</td>
<td>Not Required</td>
<td>Not Required</td>
</tr>
<tr>
<td>PrimaryFlag</td>
<td>The attribute indicates the primary address of the partner.</td>
<td>No validation</td>
<td>Required. If not passed, the default value, ‘N’ is used.</td>
<td>Not Required</td>
</tr>
<tr>
<td>Country</td>
<td>The country of the specified partner address.</td>
<td>No validation</td>
<td>Not Required</td>
<td>Not Required</td>
</tr>
</tbody>
</table>
Chapter 8
Import Your Data

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/Import Validations</th>
<th>Creating an Partner Address record</th>
<th>Updating an Existing Partner Address record</th>
</tr>
</thead>
<tbody>
<tr>
<td>AddressId</td>
<td>The primary key for the Partner Address record.</td>
<td>No validation</td>
<td>Auto-generated</td>
<td>Required</td>
</tr>
<tr>
<td>PartyId</td>
<td>The party ID of the partner company.</td>
<td>Either the PartyId or the CompanyNumber is required.</td>
<td>Required</td>
<td>Not Required</td>
</tr>
<tr>
<td>CompanyNumber</td>
<td>The company number of the partner company.</td>
<td>Either the PartyId or the CompanyNumber is required.</td>
<td>Required</td>
<td>Not Required</td>
</tr>
<tr>
<td>AddressNumber</td>
<td>The PUID of the address object.</td>
<td>No validation</td>
<td>This is auto-generated or can be passed while creating a record.</td>
<td>Either the AddressNumber or the AddressId is required.</td>
</tr>
</tbody>
</table>

Go to Navigator > Tools > Import Management > Import Objects, to see all the attributes of the Partner Address object. The page also lists attribute information like type, length, description, and so on.

Create the Source CSV File
You include the data that you want to import into CX Sales and B2B Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator > Tools > Import Management > Import Objects.
2. Select the Partner Address object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

**Note:** For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the Partner Address information. To create an import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. On the Manage Imports page, click Create Import Activity.
3. In the Create Import Activity: Enter Import Options page, provide a name for the import activity, and select Partner Address from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you’re ready.
Note: To access and submit the import activities for Partner Contact, the user must be assigned the job roles of the Channel operations manager.

### Review the Import Results

Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to Go to Navigator > Tools > Import Management > Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed. You can drill down on the import activity to go to the Import Status page which provides the status details of the import activity.

**Related Topics**

- How You Use Alternate Keys to Import Records
- Potential Issues When Opening CSV Files in Excel

### Import Your Partner Certification Data

You can use the import functionality to create Partner Certification records.

You can import Partner Certification records using these steps:

1. Map your source data to Oracle Applications Cloud object attributes. This way the import process would know where to insert each of the information bits.
2. Create the source CSV file with the Partner Certification data you want to import.
4. Check the import results to know if the import went well.

### How You Map Your Source Data to Target Object Attributes

You import Partner Certification data into Oracle Applications Cloud from a CSV file containing your source data that’s mapped to target Oracle Applications Cloud object attributes.

Before you create the source data file, you should:

- Know how your source data attributes map to the target object attributes in Oracle Applications Cloud. Match each column from the source file to an attribute in the Partner Certification import object.
- Finish all prerequisite steps, such as understanding what attributes are required for importing your objects.
- Know how you can uniquely identify the records.
- Check the target object attributes required in the CSV file for a successful import.
- Ensure that you don’t insert duplicate Partner Certification records while importing, to avoid redundant data.

If you want to import only a few records, then you can create a single CSV file for all Partner Certification attributes. However if you want to import a large number of records, then you may decide to create multiple CSV files, one for each of the Partner Certification child objects. Note that you must have imported the CSV file for Partner Certification object...
Import Your Data

Before You Start

You must do some basic checks before starting your import. For example, make sure that:

- You have completed all the prerequisites for importing each attribute in your source data.
- You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records

All records must be unique in the application. You can use one of these to identify records:

- Public unique identifiers: If you're creating records, then you can provide an easily understandable public unique identifier. These are, usually, denoted with 'Number' and visible in the business object's UI. PUID attributes are usually named <object> Number. For more information about public unique identifiers, see the topic "How You Use Alternate Keys to Import Records" in Related Topics section.
- Source system and source system reference: Source system is an identifier for the external system, and source system reference is a unique identifier within the external system. If you're importing a new Partner Certification record that has a source system reference data, then provide the source system and source system reference values.

Required Attributes and Validations for Partner Certification Object

To import data successfully into Oracle Applications Cloud, your .CSV file must include the required attributes. Ensure that you provide valid values for the attributes.

This table lists the required attributes for Partner Certification records, prerequisite setup tasks and specific validations, if any:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task / Import Validations</th>
<th>Creating a Partner Certification record</th>
</tr>
</thead>
<tbody>
<tr>
<td>CertificationCode</td>
<td>The code for the certification.</td>
<td>No Validation</td>
<td>Required</td>
</tr>
<tr>
<td>PartnerMultiValLovId</td>
<td>The primary key for the partner certification record.</td>
<td>No Validation</td>
<td>Auto-generated</td>
</tr>
<tr>
<td>PartnerCompanyNumber</td>
<td>The company number of the partner.</td>
<td>No Validation</td>
<td>Required</td>
</tr>
</tbody>
</table>

**Note:** The Update operation isn't supported for Partner Certification records.

Go to Navigator > Tools > Import Management > Import Objects, to see all the attributes of the Partner Certification object. The page also lists attribute information like type, length, description, and so on.
Create the Source CSV File

You include the data that you want to import into CX Sales and B2B Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator > Tools > Import Management > Import Objects.
2. Select the Partner Certification object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note: For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity

After you have the CSV file ready, create an import activity to import the Partner Certification information. To create an import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. On the Manage Imports page, click Create Import Activity.
3. In the Create Import Activity: Enter Import Options page, provide a name for the import activity, and select Partner Certification from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you’re ready.

Note: To access and submit the import activities for Partner Contact, the user must be assigned the job roles of the Channel operations manager.

Review the Import Results

Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to Go to Navigator > Tools > Import Management > Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed. You can drill down on the import activity to go to the Import Status page which provides the status details of the import activity.

Related Topics

- How You Use Alternate Keys to Import Records
- Potential Issues When Opening CSV Files in Excel
Import Your Partner Contact Data

Use this topic to import Partner Contact data into Oracle Applications Cloud. You can use the Import Management to create or update Partner Contact records.

To import Partner Contact records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (.csv) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes

To import your Partner Contact data into Oracle Applications Cloud, you need to populate a CSV file with your source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the .CSV file for data import:

- Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
- Ensure prerequisite steps are complete, such as understanding what attributes are required for importing your objects.
- Understand your options for uniquely identifying the records.
- Ensure parent records exist before importing child records.
- Identify the target object attributes that are required in the .CSV file for a successful import.

Before You Start

You must do some basic checks before starting your import. For example, make sure that:

- You have completed all the prerequisites for importing each attribute in your source data.
- You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records

To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the import process to uniquely identify the records. The file import process uses the attribute values to automatically map your source data to the target object attributes in Oracle Applications Cloud.

The preferred options to uniquely identify an object record are as follows:

- **Internal ID:** If you're identifying a record that already exists in Oracle Applications Cloud, then you can use the internal ID of the record, a system-generated unique identifier. Attributes with "id" in the attribute name are typically internal IDs. You can determine the internal ID of a record by exporting Oracle Applications Cloud object data, or by doing a transactional database query. Using an internal ID typically provides better performance and reduces the import duration. For the Partner Contact object, this attribute is PartyId.
- **Public unique identifiers:** If you're creating new records, then you can provide a user-friendly public unique identifier (attributes denoted with 'Number' and usually visible in the business object's UI). If you update a
record for which you have previously provided a Number attribute, or for which a Number attribute is visible in the object’s UI, you can use the Number attribute to identify the record. For the Partner Contact object, the attribute is PartyNumber.

### Required Attributes and Validations for Partner Contact Object

To import data successfully into Oracle Applications Cloud, your .CSV file must include the required attributes. Ensure that you provide valid values for the attributes.

This table lists the required attributes for importing new Partner Contact records, required attributes for updating Partner Contact records, prerequisite setup tasks for the attributes, and specific validations, if any, for Partner Contact import:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Data Type</th>
<th>Data Length</th>
<th>Prerequisite Setup Task/ Import Validations</th>
<th>Creating a Partner Contact record</th>
<th>Updating an Existing Partner Contact record</th>
</tr>
</thead>
<tbody>
<tr>
<td>FirstName</td>
<td>The first name of the person</td>
<td>Text</td>
<td>150</td>
<td>A value is required if creating a new person party.</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td>LastName</td>
<td>The last name of the person</td>
<td>Text</td>
<td>150</td>
<td>A value is required if creating a new person party.</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td>EmailAddress</td>
<td>The Email address of the partner contact</td>
<td>Text</td>
<td>320</td>
<td>While importing the partner contacts which have the createUserAccount attribute set to ‘Y’, the username value must be unique. If the username attribute isn’t set, then the email address value should be unique.</td>
<td>Required</td>
<td>Not Required</td>
</tr>
<tr>
<td>CompanyNumber</td>
<td>The company number of the partner</td>
<td>Text</td>
<td>30</td>
<td>The value must exist in the column COMPANY_NUMBER of the ZPM_PARTNER_PROFILES table. Identify the COMPANY_NUMBER for an existing partner by exporting the Partner Profile object. Navigate to the following in the Setup and Maintenance work area:</td>
<td>A value is required either for CompanyNumber or PartnerPartyId.</td>
<td>Not Required</td>
</tr>
<tr>
<td>Attribute</td>
<td>Description</td>
<td>Data Type</td>
<td>Data Length</td>
<td>Prerequisite Setup Task/Import Validations</td>
<td>Creating a Partner Contact record</td>
<td>Updating an Existing Partner Contact record</td>
</tr>
<tr>
<td>-----------------</td>
<td>------------------------------------------------------------------------------</td>
<td>-----------</td>
<td>-------------</td>
<td>-------------------------------------------------------------------------------------------------------------</td>
<td>-----------------------------------</td>
<td>--------------------------------------------</td>
</tr>
<tr>
<td>PartyNumber</td>
<td>The party number of the contact</td>
<td>Text</td>
<td>30</td>
<td>The PartyNumber must be unique when you're creating a new record and the value needs to be the same as that of a valid partner contact, when you're updating an existing record.</td>
<td>A value is optionally required when creating a record.</td>
<td>A value is required either for PartyNumber or PartyId when updating a record.</td>
</tr>
<tr>
<td>PartnerPartyId</td>
<td>The unique ID for the existing partner organization's party record in the destination table</td>
<td>Number</td>
<td>18</td>
<td>Identify the PARTY_ID for an existing partner party by exporting the Partner Profile object. Navigate to the following in the Setup and Maintenance work area:</td>
<td>A value is required either for CompanyNumber or PartnerPartyId when creating a record.</td>
<td>Not required</td>
</tr>
<tr>
<td>PrimaryFlag</td>
<td>Indicates if the partner contact is a primary contact</td>
<td>String</td>
<td>1</td>
<td>Set this attribute for a partner contact, if the corresponding partner doesn't</td>
<td>Required</td>
<td>Not required</td>
</tr>
</tbody>
</table>
### Note: When importing partner contacts, use the CompanyNumber attribute. Don’t use the PartnerCompanyNumber attribute.

You can view the Partner Contact object along with all its child objects and attributes in the Manage Import Objects page of the Import Management flow. You can find attribute information like type, length, description, and so on, on this page.

#### Create the Source CSV File

You include the data that you want to import into CX Sales and B2B Service in a source CSV file. You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator > Tools > Import Management > Import Objects.
2. Select the Partner Contact object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

#### Note: For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.

#### Create the Import Activity

To import data into Oracle Applications Cloud, you need to create an import activity and provide the CSV file as an input to the activity.

To create an import activity, do the following:

1. In the Navigator, under Tools, click Import Management.
2. On the Manage Imports page, click Create Import Activity.
3. In the Create Import Activity: Enter Import Options page, provide a name for the import activity, and select Partner Contact from the Object drop-down list.
4. In File Name, browse and upload the required .CSV file, and click Next.
5. In the Create Import Activity: Map Fields page edit the attribute mappings if required, and click Next.

   **Note:** Click Validate Data to validate the mapping of the source file for unmapped columns and to check for data format issues.

6. In the Create Import Activity: Review and Submit page, click Submit.

   **Note:** To access and submit the import activities for Partner Contact, the user must be assigned the job roles of the Channel operations manager.
Review the Import Results

Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed. You can drill down on the import activity to go to the Import Status page which provides the status details of the import activity.

Related Topics
- Potential Issues When Opening CSV Files in Excel
- Import Data

Import Your Partner Focus Area Data

You can use the import functionality to create Partner Focus Area records.

You can import Partner Focus Area records using these steps:

1. Map your source data to Oracle Applications Cloud object attributes. This way the import process would know where to insert each of the information bits.
2. Create the source CSV file with the Partner Focus Area data you want to import.
4. Check the import results to know if the import went well.

How You Map Your Source Data to Target Object Attributes

You import Partner Focus Area data into Oracle Applications Cloud from a CSV file containing your source data that's mapped to target Oracle Applications Cloud object attributes.

Before you create the source data file, you should:

- Know how your source data attributes map to the target object attributes in Oracle Applications Cloud. Match each column from the source file to an attribute in the Partner Focus Area import object.
- Finish all prerequisite steps, such as understanding what attributes are required for importing your objects.
- Know how you can uniquely identify the records.
- Check the target object attributes required in the CSV file for a successful import.
- Ensure that you don't insert duplicate Partner Focus Area records while importing, to avoid redundant data.

If you want to import only a few records, then you can create a single CSV file for all Partner Focus Area attributes. However if you want to import a large number of records, then you may decide to create multiple CSV files, one for each of the Partner Focus Area child objects. Note that you must have imported the CSV file for Partner Focus Area object successfully before trying to import the CSV files for the child objects. There are separate help topics describing how to import each of these child objects.
Before You Start
You must do some basic checks before starting your import. For example, make sure that:

- You have completed all the prerequisites for importing each attribute in your source data.
- You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
All records must be unique in the application. You can use one of these to identify records:

- Public unique identifiers: If you’re creating records, then you can provide an easily understandable public unique identifier. These are, usually, denoted with ‘Number’ and visible in the business object’s UI. PUID attributes are usually named <object> Number. For more information about public unique identifiers, see the topic “How You Use Alternate Keys to Import Records” in Related Topics section.
- Source system and source system reference: Source system is an identifier for the external system, and source system reference is a unique identifier within the external system. If you’re importing a new Partner Focus Area record that has a source system reference data, then provide the source system and source system reference values.

Required Attributes and Validations for Partner Focus Area Object
To import data successfully into Oracle Applications Cloud, your .CSV file must include the required attributes. Ensure that you provide valid values for the attributes.

This table lists the required attributes for Partner Focus Area records, prerequisite setup tasks and specific validations, if any:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/ Import Validations</th>
<th>Creating a Partner Focus Area record</th>
</tr>
</thead>
<tbody>
<tr>
<td>ProductName</td>
<td>The name of the specialty product.</td>
<td>No Validation</td>
<td>Either the ProductId or the ProductName is required.</td>
</tr>
<tr>
<td>PartnerDimMembersId</td>
<td>The primary key of the partner focus area record.</td>
<td>No Validation</td>
<td>Auto-generated</td>
</tr>
<tr>
<td>CompanyNumber</td>
<td>The company number of the partner company.</td>
<td>No Validation</td>
<td>Required</td>
</tr>
</tbody>
</table>

**Note:** The Update operation isn’t supported for Partner Focus Area records.

Go to **Navigator > Tools > Import Management > Import Objects**, to see all the attributes of the Partner Focus Area object. The page also lists attribute information like type, length, description, and so on.

Create the Source CSV File
You include the data that you want to import into CX Sales and B2B Service in a source CSV file.
You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to **Navigator > Tools > Import Management > Import Objects**.
2. Select the Partner Focus Area object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

**Note:** For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.

**Create the Import Activity**

After you have the CSV file ready, create an import activity to import the Partner Focus Area information. To create an import activity:

1. Go to **Navigator > Tools > Import Management > Import Queue**.
2. On the **Manage Imports** page, click **Create Import Activity**.
3. In the **Create Import Activity: Enter Import Options** page, provide a name for the import activity, and select **Partner Focus Area** from the **Object** drop-down list.
4. Select the CSV file in the **File Name** field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the **Map Fields** page. Review and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking **Validate Data**. Click Next.
7. Review the import details on the **Review and Submit** page, and click **Submit** when you're ready.

**Note:** To access and submit the import activities for Partner Contact, the user must be assigned the job roles of the Channel operations manager.

**Review the Import Results**

Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to **Navigator > Tools > Import Management > Import Queue**.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the **Status** column for the import activity. The import is successful if the status displays as Completed. You can drill down on the import activity to go to the **Import Status** page which provides the status details of the import activity.

**Related Topics**

- How You Use Alternate Keys to Import Records
- Potential Issues When Opening CSV Files in Excel

**Import Your Partner Geography Served Data**

You can use the import functionality to create Partner Geography Served records.
You can import Partner Geography Served records using these steps:

1. Map your source data to Oracle Applications Cloud object attributes. This way the import process would know where to insert each of the information bits.
2. Create the source CSV file with the Partner Geography Served data you want to import.
4. Check the import results to know if the import went well.

How You Map Your Source Data to Target Object Attributes

You import Partner Geography Served data into Oracle Applications Cloud from a CSV file containing your source data that's mapped to target Oracle Applications Cloud object attributes.

Before you create the source data file, you should:

- Know how your source data attributes map to the target object attributes in Oracle Applications Cloud. Match each column from the source file to an attribute in the Partner Geography Served import object.
- Finish all prerequisite steps, such as understanding what attributes are required for importing your objects.
- Know how you can uniquely identify the records.
- Check the target object attributes required in the CSV file for a successful import.
- Ensure that you don’t insert duplicate Partner Geography Served records while importing, to avoid redundant data.

If you want to import only a few records, then you can create a single CSV file for all Partner Geography Served attributes. However if you want to import a large number of records, then you may decide to create multiple CSV files, one for each of the Partner Geography Served child objects. Note that you must have imported the CSV file for Partner Geography Served object successfully before trying to import the CSV files for the child objects. There are separate help topics describing how to import each of these child objects.

Before You Start

You must do some basic checks before starting your import. For example, make sure that:

- You have completed all the prerequisites for importing each attribute in your source data.
- You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records

All records must be unique in the application. You can use one of these to identify records:

- Public unique identifiers: If you're creating records, then you can provide an easily understandable public unique identifier. These are, usually, denoted with 'Number' and visible in the business object's UI. PUID attributes are usually named `<object> Number`. For more information about public unique identifiers, see the topic "How You Use Alternate Keys to Import Records" in Related Topics section.
- Source system and source system reference: Source system is an identifier for the external system, and source system reference is a unique identifier within the external system. If you're importing a new Partner Geography Served record that has a source system reference data, then provide the source system and source system reference values.
Required Attributes and Validations for Partner Geography Served Object

To import data successfully into Oracle Applications Cloud, your .CSV file must include the required attributes. Ensure that you provide valid values for the attributes.

This table lists the required attributes for Partner Geography Served records, prerequisite setup tasks and specific validations, if any:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task / Import Validations</th>
<th>Creating a Partner Geography Served record</th>
</tr>
</thead>
<tbody>
<tr>
<td>PartnerDimMembersId</td>
<td>The primary key for the Partner Geography Served record.</td>
<td>No Validation</td>
<td>Auto-generated</td>
</tr>
<tr>
<td>GeographyName</td>
<td>The name of the geography where the partner is located.</td>
<td>No Validation</td>
<td>Either the GeographyName or the GeographyId is required.</td>
</tr>
<tr>
<td>OwnerId</td>
<td>The party ID of the partner.</td>
<td>No Validation</td>
<td>Either the Owner ID or the CompanyNumber is required.</td>
</tr>
<tr>
<td>CompanyNumber</td>
<td>The company number of the partner.</td>
<td>No Validation</td>
<td>Either the Owner ID or the CompanyNumber is required.</td>
</tr>
</tbody>
</table>

**Note:** The Update operation isn’t supported for Partner Geography Served records.

Go to Navigator > Tools > Import Management > Import Objects, to see all the attributes of the Partner Geography Served object. The page also lists attribute information like type, length, description, and so on.

### Create the Source CSV File

You include the data that you want to import into CX Sales and B2B Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator > Tools > Import Management > Import Objects.
2. Select the Partner Geography Served object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

**Note:** For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.

### Create the Import Activity

After you have the CSV file ready, create an import activity to import the Partner Geography Served information. To create an import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. On the Manage Imports page, click Create Import Activity.
3. In the **Create Import Activity: Enter Import Options** page, provide a name for the import activity, and select **Partner Geography Served** from the **Object** drop-down list.

4. Select the CSV file in the File Name field, and click Next.

5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review and edit the mappings if required.

6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.

7. Review the import details on the Review and Submit page, and click Submit when you’re ready.

**Note:** To access and submit the import activities for Partner Contact, the user must be assigned the job roles of the Channel operations manager.

### Review the Import Results

Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to Go to **Navigator > Tools > Import Management > Import Queue**.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed. You can drill down on the import activity to go to the Import Status page which provides the status details of the import activity.

**Related Topics**

- How You Use Alternate Keys to Import Records
- Potential Issues When Opening CSV Files in Excel

### Import Your Partner Program Country Data

You can use the Import Management functionality to create or update Partner Program Country records.

To import Partner Program Country records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (.csv) file for import.
3. Create the import activity.
4. Review the import results.

**How You Map Your Source Data to Target Object Attributes**

To import your Partner Program Country data into Oracle Applications Cloud, you need to populate a CSV file with your source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the .CSV file for data import:

- Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
- Ensure prerequisite steps are complete, such as understanding what attributes are required for importing your objects.
- Understand your options for uniquely identifying the records.
• Ensure parent records exist before importing child records.
• Identify the target object attributes that are required in the .CSV file for a successful import.

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.
• You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the import process to uniquely identify the records. The file import process uses the attribute values to automatically map your source data to the target object attributes in Oracle Applications Cloud.

The preferred options to uniquely identify an object record is through the Internal ID. If you're identifying a record that already exists in Oracle Applications Cloud, then you can use the internal ID of the record, a system-generated unique identifier. Attributes with "ID" in the attribute name are typically internal IDs. You can determine the internal ID of a record by exporting Oracle Applications Cloud object data, or by doing a transactional database query. Using an internal ID typically provides better performance and reduces the import duration. For the Partner Program Country object, this attribute is ProgramCountryId.

Required Attributes and Validations for Partner Program Country Object
To import data successfully into Oracle Applications Cloud, your .CSV file must include the required attributes. Ensure that you provide valid values for the attributes.

This table lists the required attributes for importing new Partner Program Country records, required attributes for updating Partner Program Country records, prerequisite setup tasks for the attributes, and specific validations, if any, for Partner Program Country import:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Data Type</th>
<th>Data Length</th>
<th>Prerequisite Setup Task/Import Validations</th>
<th>Creating a Partner Program Country record</th>
<th>Updating an Existing Partner Program Country record</th>
</tr>
</thead>
<tbody>
<tr>
<td>ProgramCountryID</td>
<td>The unique identifier of the program country</td>
<td>Integer</td>
<td>18</td>
<td>None</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>CountryCode</td>
<td>The public unique identifier value for the country associated with the partner program</td>
<td>String</td>
<td>2</td>
<td>None.</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td>PartnerProgramID</td>
<td>Unique identifier for the partner program</td>
<td>Integer</td>
<td>18</td>
<td>None</td>
<td>A value is required if the program number isn't specified.</td>
<td>Not required</td>
</tr>
</tbody>
</table>
### Program Number

**Description:** A unique number generated for each program

**Data Type:** Varchar2

**Data Length:** 30

**Prerequisite Setup Task/ Import Validations:** None

**Creating a Partner Program Country record:** A value is required if the partner program ID isn't specified.

**Updating an Existing Partner Program Country record:** Not required

You can view the Partner Program Country object along with all its child objects and attributes in the Manage Import Objects page of the Import Management flow. You can find attribute information like type, length, description, and so on, on this page.

### Create the Source CSV File

You include the data that you want to import into CX Sales and B2B Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to **Navigator > Tools > Import Management > Import Objects**.
2. Select the **Partner Program Country** object in the table and click **Download**.

You can now edit the downloaded file and provide valid values for the required attributes.

**Note:** For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.

### Create the Import Activity

To import data into Oracle Applications Cloud, you need to create an import activity and provide the CSV file as an input to the activity.

To create an import activity, do the following:

1. In the Navigator, under **Tools**, click **Import Management**.
2. On the **Manage Imports** page, click **Create Import Activity**.
3. In the **Create Import Activity: Enter Import Options** page, provide a name for the import activity, and select **Partner Program Country** from the **Object** drop-down list.
4. In **File Name**, browse and upload the required .CSV file, and click **Next**.
5. In the **Create Import Activity: Map Fields** page edit the attribute mappings if required, and click **Next**.

   **Note:** Click **Validate Data** to validate the mapping of the source file for unmapped columns and to check for data format issues.

6. In the **Create Import Activity: Review and Submit** page, click **Submit**.

### Review the Import Results

Check if your import succeeded on the **Manage Imports** page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to **Navigator > Tools > Import Management > Import Queue**.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the **Status** column for the import activity. The import is successful if the status displays as **Completed**. You can drill down on the import activity to go to the **Import Status** page which provides the status details of the import activity.

**Related Topics**
- Potential Issues When Opening CSV Files in Excel
- Import Data

## Import Your Partner Program Tier Data

You can use the Import Management functionality to create, update, or delete Partner Program Tier records.

To import Partner Program Tier records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (.csv) file for import.
3. Create the import activity.
4. Review the import results.

### How You Map Your Source Data to Target Object Attributes

To import your Partner Program Tier data into Oracle Applications Cloud, you need to populate a CSV file with your source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the .CSV file for data import:

- Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
- Ensure prerequisite steps are complete, such as understanding what attributes are required for importing your objects.
- Understand your options for uniquely identifying the records.
- Ensure parent records exist before importing child records.
- Identify the target object attributes that are required in the .csv file for a successful import.

### Before You Start

You must do some basic checks before starting your import. For example, make sure that:

- You have completed all the prerequisites for importing each attribute in your source data.
- You have all parent records in place before importing child records.

### Select a Unique Identifier for Your Records

To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the import process to uniquely identify the records. The file import process uses the attribute values to automatically map your source data to the target object attributes in Oracle Applications Cloud.
The preferred option to uniquely identify an object record is through the internal ID. If you’re identifying a record that already exists in Oracle Applications Cloud, then you can use the internal ID of the record, a system-generated unique identifier. Attributes with "ID" in the attribute name are typically internal IDs. You can determine the internal ID of a record by exporting Oracle Applications Cloud object data, or by doing a transactional database query. Using an internal ID typically provides better performance and reduces the import duration. For the Partner Program Tier object, this attribute is ProgramTierId.

Required Attributes and Validations for Partner Program Tier Object

To import data successfully into Oracle Applications Cloud, your .csv file must include the required attributes. Ensure that you provide valid values for the attributes.

This table lists the required attributes for importing new Partner Program Tier records, required attributes for updating Partner Program Tier records, prerequisite setup tasks for the attributes, and specific validations, if any, for Partner Program Tier import:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Data Type</th>
<th>Data Length</th>
<th>Prerequisite Setup Task/Import Validations</th>
<th>Creating an Partner Program Tier record</th>
<th>Updating an Existing Partner Program Tier record</th>
</tr>
</thead>
<tbody>
<tr>
<td>ProgramTierId</td>
<td>The unique identifier of the program tier</td>
<td>Integer</td>
<td>18</td>
<td>None</td>
<td>Not required</td>
<td>Required</td>
</tr>
<tr>
<td>TierId</td>
<td>The unique identifier of the partner tier</td>
<td>Integer</td>
<td>18</td>
<td>None</td>
<td>Required</td>
<td>Required</td>
</tr>
<tr>
<td>PartnerProgramID</td>
<td>Unique identifier and primary key for the partner program</td>
<td>Integer</td>
<td>18</td>
<td>None.</td>
<td>A value is required if the program number isn’t specified.</td>
<td>Not Required</td>
</tr>
<tr>
<td>ProgramNumber</td>
<td>A unique number generated for each partner program</td>
<td>Varchar2</td>
<td>30</td>
<td>None</td>
<td>A value is required if the partner program ID isn’t specified.</td>
<td>Not required</td>
</tr>
</tbody>
</table>

You can view the Partner Program Tier object along with all its child objects and attributes in the Manage Import Objects page of the Import Management flow. You can find attribute information like type, length, description, and so on, on this page.

Create the Source CSV File

You include the data that you want to import into CX Sales and B2B Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator > Tools > Import Management > Import Objects.
2. Select the Partner Program Tier object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.
Create the Import Activity

To import data into Oracle Applications Cloud, you need to create an import activity and provide the CSV file as an input to the activity.

To create an import activity, do the following:

1. In the Navigator, under **Tools**, click **Import Management**.
2. On the **Manage Imports** page, click **Create Import Activity**.
3. In the **Create Import Activity: Enter Import Options** page, provide a name for the import activity, and select **Partner Program Tier** from the **Object** drop-down list.
4. In **File Name**, browse and upload the required .CSV file, and click **Next**.
5. In the **Create Import Activity: Map Fields** page edit the attribute mappings if required, and click **Next**.
   - **Note:** Click **Validate Data** to validate the mapping of the source file for unmapped columns and to check for data format issues.
6. In the **Create Import Activity: Review and Submit** page, click **Submit**.

Review the Import Results

Check if your import succeeded on the **Manage Imports** page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to **Navigator** > **Tools** > **Import Management** > **Import Queue**.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the **Status** column for the import activity. The import is successful if the status displays as **Completed**. You can drill down on the import activity to go to the **Import Status** page which provides the status details of the import activity.

**Related Topics**
- Potential Issues When Opening CSV Files in Excel
- Import Data

Import Your Partner Type Data

You can use the import functionality to create Partner Type records.

You can import Partner Type records using these steps:

1. Map your source data to Oracle Applications Cloud object attributes. This way the import process would know where to insert each of the information bits.
2. Create the source CSV file with the Partner Type data you want to import.
4. Check the import results to know if the import went well.
How You Map Your Source Data to Target Object Attributes

You import Partner Type data into Oracle Applications Cloud from a CSV file containing your source data that's mapped to target Oracle Applications Cloud object attributes.

Before you create the source data file, you should:

- Know how your source data attributes map to the target object attributes in Oracle Applications Cloud. Match each column from the source file to an attribute in the Partner Type import object.
- Finish all prerequisite steps, such as understanding what attributes are required for importing your objects.
- Know how you can uniquely identify the records.
- Check the target object attributes required in the CSV file for a successful import.
- Ensure that you don't insert duplicate Partner Type records while importing, to avoid redundant data.

If you want to import only a few records, then you can create a single CSV file for all Partner Type attributes. However if you want to import a large number of records, then you may decide to create multiple CSV files, one for each of the Partner Type child objects. Note that you must have imported the CSV file for Partner Type object successfully before trying to import the CSV files for the child objects. There are separate help topics describing how to import each of these child objects.

Before You Start

You must do some basic checks before starting your import. For example, make sure that:

- You have completed all the prerequisites for importing each attribute in your source data.
- You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records

All records must be unique in the application. You can use one of these to identify records:

- Public unique identifiers: If you’re creating records, then you can provide an easily understandable public unique identifier. These are, usually, denoted with ‘Number’ and visible in the business object’s UI. PUID attributes are usually named <object> Number. For more information about public unique identifiers, see the topic "How You Use Alternate Keys to Import Records" in Related Topics section.
- Source system and source system reference: Source system is an identifier for the external system, and source system reference is a unique identifier within the external system. If you’re importing a new Partner Type record that has a source system reference data, then provide the source system and source system reference values.

Required Attributes and Validations for Partner Type Object

To import data successfully into Oracle Applications Cloud, your .CSV file must include the required attributes. Ensure that you provide valid values for the attributes.

This table lists the required attributes for Partner Type records, prerequisite setup tasks and specific validations, if any:
### Attribute | Description | Prerequisite Setup Task/ Import Validations | Creating a Partner Type record
--- | --- | --- | ---
IntegrationId | This is an internal attribute and should not be used. | No Validation | Not Required
PartnerTypeName | The partner type assigned to the partner. | No Validation | Either the PartnerTypeName or the PartnerTypeCode is required.
PartnerDimMembersId | The primary key of the Partner Type object. | No Validation | Auto-generated
PartnerCompanyNumber | The company number of the partner. | No Validation | Required

**Note:** The Update operation isn’t supported for Partner Type records.

Go to Navigator > Tools > Import Management > Import Objects, to see all the attributes of the Partner Type object. The page also lists attribute information like type, length, description, and so on.

### Create the Source CSV File
You include the data that you want to import into CX Sales and B2B Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator > Tools > Import Management > Import Objects.
2. Select the Partner Type object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

**Note:** For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.

### Create the Import Activity
After you have the CSV file ready, create an import activity to import the Partner Type information. To create an import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. On the Manage Imports page, click Create Import Activity.
3. In the Create Import Activity: Enter Import Options page, provide a name for the import activity, and select Partner Type from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you’re ready.
Review the Import Results

Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to Go to Navigator > Tools > Import Management > Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed. You can drill down on the import activity to go to the Import Status page which provides the status details of the import activity.

**Related Topics**
- How You Use Alternate Keys to Import Records
- Potential Issues When Opening CSV Files in Excel
- Import Data

**Import Your Person Data**

You can use the import functionality to create or update Person records.

You can import Person records using these steps:

1. Map your source data to Oracle Applications Cloud object attributes. This way the import process would know where to insert each of the information bits.
2. Create the source CSV file with the Person data you want to import.
4. Check the import results to know if the import went well.

**How You Map Your Source Data to Target Object Attributes**

You import Person data into Oracle Applications Cloud from a CSV file containing your source data that's mapped to target Oracle Applications Cloud object attributes.

Before you create the source data file, you should:

- Know how your source data attributes map to the target object attributes in Oracle Applications Cloud. Match each column from the source file to an attribute in the Person import object.
- Finish all prerequisite steps, such as understanding what attributes are required for importing your objects.
- Know how you can uniquely identify the records.
- Check the target object attributes required in the CSV file for a successful import.
- Ensure that you don't insert duplicate Person while importing, to avoid redundant data.
Before You Start

You must do some basic checks before starting your import. For example, make sure that:

- You have completed all the prerequisites for importing each attribute in your source data.
- You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records

All records must be unique in the application. You can use one of these to identify records:

- Public unique identifiers: You can pass the PUID when creating Person records. If the PUID isn't passed, it will be auto generated. You can optionally provide the PUID when creating Person records. If you're updating records, then you can provide an easily understandable public unique identifier. These are, usually, denoted with 'Number' and visible in the business object's UI. PUID attributes are usually named <object> Number. If you're updating a record with a Number attribute, then use the Number attribute to identify the record. For more information about public unique identifiers, see the topic "How You Use Alternate Keys to Import Records" in Related Topics section.
- Source system and source system reference: Source system is an identifier for the external system, and source system reference is a unique identifier within the external system. If you're importing new Persons or are updating Persons that have source system reference data, then provide the source system and source system reference values.

Required Attributes and Validations for Person Object

To import data successfully into Oracle Applications Cloud, your .CSV file must include the required attributes. Ensure that you provide valid values for the attributes.

This table lists the required attributes for Person records, prerequisite setup tasks and specific validations, if any:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/Import Validations</th>
<th>Creating a Person record</th>
<th>Updating an Existing Person record</th>
</tr>
</thead>
<tbody>
<tr>
<td>PartyId</td>
<td>The internal ID for the Person type party</td>
<td>When updating the record, this should already exist.</td>
<td>Not required</td>
<td>Conditionally required. To identify a person record, use one of these:</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>• Combination of SourceSystem and SourceSystemReferenceValue</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>• PartyNumber</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>• PartyId</td>
</tr>
<tr>
<td>Country</td>
<td>The country code of the postal address</td>
<td>Identify valid country codes using the Setup and Maintenance, Manage Territories task.</td>
<td>Conditionally required. A value is required only when you're creating an address for the Person record.</td>
<td>The attribute is neither required nor conditionally required.</td>
</tr>
<tr>
<td>AddressNumber</td>
<td>The internal unique identifier that's internally</td>
<td>No validation</td>
<td>This is a PUID for Address. If a value is passed, it will be pass the AddressNumber.</td>
<td></td>
</tr>
<tr>
<td>Attribute</td>
<td>Description</td>
<td>Prerequisite Setup Task/Import Validations</td>
<td>Creating a Person record</td>
<td>Updating an Existing Person record</td>
</tr>
<tr>
<td>-------------------</td>
<td>------------------------------------------------------------------------------</td>
<td>---------------------------------------------</td>
<td>--------------------------------------------------------------------------------------------</td>
<td>-----------------------------------</td>
</tr>
<tr>
<td></td>
<td>generated when creating an address</td>
<td></td>
<td>imported. Otherwise, it will be auto-generated.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>OrganizationPartyNumber The party number of the organization to which the</td>
<td>This should already exist.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td></td>
<td>person is related</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>DeceasedFlag The option that indicates whether the person imported is</td>
<td>Y or N</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td></td>
<td>deceased</td>
<td>The default value is N.</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>PartyNumber The unique identifier of the party</td>
<td>Know the party number. To obtain a list of</td>
<td>This is a PUID for Person. If a value is passed, it will be imported. Otherwise, it will</td>
<td>Conditionally required</td>
</tr>
<tr>
<td></td>
<td></td>
<td>all party IDs and party numbers, export the</td>
<td>be auto-generated.</td>
<td>To identify a person record, use one of these:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Person object.</td>
<td></td>
<td>• Combination of SourceSystem and</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>SourceSystemReferenceValue</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>• PartyNumber</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>• PartyId</td>
</tr>
<tr>
<td></td>
<td>FirstName The first name of the person</td>
<td>No validation</td>
<td>Required. A value is required for the FirstName, MiddleName, or LastName.</td>
<td>Not required</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>MiddleName The middle name of the person</td>
<td>No validation</td>
<td>Required. A value is required for the FirstName, MiddleName, or LastName.</td>
<td>Not required</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>LastName The last name of the person</td>
<td>No validation</td>
<td>Required. A value is required for the FirstName, MiddleName, or LastName.</td>
<td>Not required</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>PartyUsageCode Specifies the party usage code to which the person is</td>
<td>Select one of the following values:</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td></td>
<td>associated</td>
<td>• EXTERNAL_PAYEE</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>• CONTACT</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>• PAYMENT_ISSUING_AUTHORITY</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>• PARTY_OF_INTEREST</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>• VIRTUAL_ASSISTANT</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>• FS_TECH</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

You can assign a limited set of unrestricted party usages through the Person import object. To create persons of other types, use
Understanding Import and Export Management for CX Sales and B2B Service

Chapter 8
Import Your Data

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/Import Validations</th>
<th>Creating a Person record</th>
<th>Updating an Existing Person record</th>
</tr>
</thead>
<tbody>
<tr>
<td>SourceSystem</td>
<td>The original source system name</td>
<td>Know the source system. To view source systems, use the Manage Trading Community Source System task.</td>
<td>Conditionally required To identify a person record, use one of these:</td>
<td>Conditionally required To identify a person record, use one of these:</td>
</tr>
<tr>
<td>SourceSystemReferenceValue</td>
<td>The identifier in the original source system</td>
<td>Know the source system reference value. To view source system reference, use the Manage Trading Community Source System task.</td>
<td>Conditionally required To identify a person record, use one of these:</td>
<td>Conditionally required To identify a person record, use one of these:</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- Combination of SourceSystem and SourceSystemReferenceValue</td>
<td>- Combination of SourceSystem and SourceSystemReferenceValue</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- PartyNumber</td>
<td>- PartyNumber</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>- PartyId</td>
</tr>
</tbody>
</table>

Go to Navigator > Tools > Import Management > Import Objects, to see all the attributes of the Person object. The page also lists attribute information like type, length, description, and so on.

Create the Source CSV File
You include the data that you want to import into CX Sales and B2B Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator > Tools > Import Management > Import Objects.
2. Select the Person object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

*Note:* For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the Person information. To create an import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. On the Manage Imports page, click Create Import Activity.
3. In the **Create Import Activity: Enter Import Options** page, provide a name for the import activity, and select **Person** from the **Object** drop-down list.

4. Select the CSV file in the File Name field, and click Next.

5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review and edit the mappings if required.

6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.

7. Review the import details on the Review and Submit page, and click Submit when you’re ready.

**Review the Import Results**

Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to **Navigator > Tools > Import Management > Import Queue**.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed. You can drill down on the import activity to go to the Import Status page which provides the status details of the import activity.

**Related Topics**

- How You Use Alternate Keys to Import Records
- Potential Issues When Opening CSV Files in Excel
- Why can’t I see the people I just imported?

**Import Your Price Book Header Data**

You can use the Import Management functionality to create or update Price Book Header records.

To import Price Book Header records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (.csv) file for import.
3. Create the import activity.
4. Review the import results.

**How You Map Your Source Data to Target Object Attributes**

To import your Price Book Header data into Oracle Applications Cloud, you need to populate a CSV file with your source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the .CSV file for data import:

- Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
- Ensure prerequisite steps are complete, such as understanding what attributes are required for importing your objects.
- Understand your options for uniquely identifying the records.
• Ensure parent records exist before importing child records.
• Identify the target object attributes that are required in the .CSV file for a successful import.

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.
• You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the import process to uniquely identify the records. The file import process uses the attribute values to automatically map your source data to the target object attributes in Oracle Applications Cloud.

The preferred options for uniquely identifying an object record are as follows:

• Internal ID: If you're identifying a record that already exists in Oracle Applications Cloud, then you can use the internal ID of the record, a system-generated unique identifier Attributes with "id" in the attribute name are typically internal IDs. You can determine the internal ID of a record by exporting Oracle Applications Cloud object data, or by doing a transactional database query. Using an internal ID typically provides better performance and reduces the import duration. For the Price Book Header object, this attribute is PriceBookId.

• Public unique identifiers: If you're creating new records, then you can provide a user-friendly public unique identifier (attributes denoted with ‘Number’ and usually visible in the business object's UI). If you update a record for which you have previously provided a Number attribute, or for which a Number attribute is visible in the object's UI, you can use the Number attribute to identify the record. For the Price Book Header object, the attribute is PricebookCode.

Required Attributes and Validations for Price Book Header Object
To import data successfully into Oracle Applications Cloud, your .CSV file must include the required attributes. Ensure that you provide valid values for the attributes.

This table lists the required attributes for importing new Price Book Header records, required attributes for updating Price Book Header records, prerequisite setup tasks for the attributes, and specific validations, if any, for Price Book Header import:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Data Type</th>
<th>Data Length</th>
<th>Prerequisite Setup Task/Import Validations</th>
<th>Creating a Price Book Header Record</th>
<th>Updating an Existing Price Book Header Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>CurrencyCode</td>
<td>Specifies the currency associated with the price book header</td>
<td>String</td>
<td>15</td>
<td>LOV validation for the existing currency code</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td>Name</td>
<td>Specifies the name of the price book header</td>
<td>String</td>
<td>150</td>
<td>Enter a unique value.</td>
<td>Required</td>
<td>You can update the Price book header only if it’s in the DRAFT status.</td>
</tr>
</tbody>
</table>
### Attribute Description Data Type Data Length Prerequisite Setup Task/ Import Validations Creating a Price Book Header Record Updating an Existing Price Book Header Record

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Data Type</th>
<th>Data Length</th>
<th>Prerequisite Setup Task/ Import Validations</th>
<th>Creating a Price Book Header Record</th>
<th>Updating an Existing Price Book Header Record</th>
</tr>
</thead>
</table>
| StatusCode         | Specifies the pre-defined code used to indicate the status                  | String    | 30          | When creating a record, the valid values are DRAFT or ACTIVE. When updating a record, the changes acceptable are:  
- DRAFT to ACTIVE  
- ACTIVE to EXPIRED  
- EXPIRED to ACTIVE | Defaults to DRAFT                                                          | Optional                           |
| PricebookId        | A unique identifier for the price book                                       | Long      | 18          | The value is auto generated.                | The value is auto generated.        | Required                                       |
| PricebookCode      | The code indicating the price book                                           | String    | 80          | Setup the on prefix and radix. Navigate to the following in the Setup and Maintenance work area:  
- Offering: Sales  
- Functional Area: Data Import and Export  
- Task: Manage Public Unique Identifier Sequence Generation | The value is auto generated. You can also enter a value.         | Required                                       |
| Description        | A brief description of the price book                                        | String    | 1999        | No validation                              | Not required                        | Optional                                       |
| HeaderExternalKey  | Specifies the external Keys to identify the price book header               | String    | 120         | The combination of HeaderExternalKey and HeaderExternalSource has to be unique. | Default Value                       | Optional                                       |
| HeaderExternalSource | Specifies the external source keys to identify the price book header       | String    | 120         | The combination of HeaderExternalKey and HeaderExternalSource has to be unique. | Default Value                       | Optional                                       |
Create the Source CSV File
You include the data that you want to import into CX Sales and B2B Service in a source CSV file.
You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator > Tools > Import Management > Import Objects.
2. Select the Price Book Header object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note: For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
To import data into Oracle Applications Cloud, you need to create an import activity and provide the CSV file as an input to the activity.
To create an import activity, do the following:

1. In the Navigator, under Tools, click Import Management.
2. On the Manage Imports page, click Create Import Activity.
3. In the Create Import Activity: Enter Import Options page, provide a name for the import activity, and select Price Book Header from the Object drop-down list.
4. In File Name, browse and upload the required .CSV file, and click Next.
5. In the Create Import Activity: Map Fields page edit the attribute mappings if required, and click Next.

Note: Click Validate Data to validate the mapping of the source file for unmapped columns and to check for data format issues.
6. In the Create Import Activity: Review and Submit page, click Submit.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the **Status** column for the import activity. The import is successful if the status displays as **Completed**. You can drill down on the import activity to go to the **Import Status** page which provides the status details of the import activity.

**Related Topics**
- Potential Issues When Opening CSV Files in Excel
- Import Data

**Import Your Price Book Line Data**

You can use the Import Management functionality to create or update Price Book Line records.

To import Price Book Line records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (.csv) file for import.
3. Create the import activity.
4. Review the import results.

**How You Map Your Source Data to Target Object Attributes**

To import your Price Book Line data into Oracle Applications Cloud, you need to populate a CSV file with your source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the .CSV file for data import:

- Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
- Ensure prerequisite steps are complete, such as understanding what attributes are required for importing your objects.
- Understand your options for uniquely identifying the records.
- Ensure parent records exist before importing child records.
- Identify the target object attributes that are required in the .CSV file for a successful import.

**Before You Start**

You must do some basic checks before starting your import. For example, make sure that:

- You have completed all the prerequisites for importing each attribute in your source data.
- You have all parent records in place before importing child records.

**Select a Unique Identifier for Your Records**

To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the import process to uniquely identify the records. The file import process uses the attribute values to automatically map your source data to the target object attributes in Oracle Applications Cloud.
Understanding Import and Export Management for CX
Sales and B2B Service

Chapter 8
Import Your Data

The preferred options for uniquely identifying an object record are as follows:

- Internal ID: If you're identifying a record that already exists in Oracle Applications Cloud, then you can use the internal ID of the record, a system-generated unique identifier Attributes with "id" in the attribute name are typically internal IDs. You can determine the internal ID of a record by exporting Oracle Applications Cloud object data, or by doing a transactional database query. Using an internal ID typically provides better performance and reduces the import duration. For the Price Book Line object, this attributes are InvItemId, InvOrgId, PricebookId and PricebookItemId.

- Public unique identifiers: If you're creating new records, then you can provide a user-friendly public unique identifier (attributes denoted with 'Number' and usually visible in the business object's UI). If you update a record for which you have previously provided a Number attribute, or for which a Number attribute is visible in the object's UI, you can use the Number attribute to identify the record. For the Price Book Line object, the attributes are ItemNumber and PricebookCode.

### Required Attributes and Validations for Price Book Line Object

To import data successfully into Oracle Applications Cloud, your .CSV file must include the required attributes. Ensure that you provide valid values for the attributes.

This table lists the required attributes for importing new Price Book Line records, required attributes for updating Price Book Line records, prerequisite setup tasks for the attributes, and specific validations, if any, for Price Book Line import:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Data Type</th>
<th>Data Length</th>
<th>Prerequisite Setup Task/ Import Validations</th>
<th>Creating a Price Book Line Record</th>
<th>Updating an Existing Price Book Line Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>InvItemld</td>
<td>The internal identifier of the item or the product for which the list price is specified.</td>
<td>Long</td>
<td>18</td>
<td>Ensure that the data used is part of the BASE usage catalog hierarchy.</td>
<td>A value is required if the primary key is used.</td>
<td>Not required</td>
</tr>
<tr>
<td>PriceUOMCode</td>
<td>The internal code of the unit of measure in which the item or the product is priced.</td>
<td>String</td>
<td>30</td>
<td>This is validated for the applicable UOM for the item used.</td>
<td>Required</td>
<td>Optional</td>
</tr>
<tr>
<td>ItemNumber</td>
<td>The number of the item for which the list price is specified.</td>
<td>String</td>
<td>300</td>
<td>Ensure that the data used is part of the BASE usage catalog hierarchy.</td>
<td>A value is required if the PUID is used.</td>
<td>A value is required if the PUID is used.</td>
</tr>
<tr>
<td>PricebookItemld</td>
<td>The internal identifier of the price book item.</td>
<td>Long</td>
<td>18</td>
<td>This is auto generated.</td>
<td>A value is auto generated.</td>
<td>A value is required if the primary key is used.</td>
</tr>
<tr>
<td>PricebookId</td>
<td>The internal identifier of the price book which is the parent of this price book line.</td>
<td>Long</td>
<td>18</td>
<td>Parent record primary key</td>
<td>A value is required, if the primary key is used.</td>
<td>Not required</td>
</tr>
<tr>
<td>Attribute</td>
<td>Description</td>
<td>Data Type</td>
<td>Data Length</td>
<td>Prerequisite Setup Task/ Import Validations</td>
<td>Creating a Price Book Line Record</td>
<td>Updating an Existing Price Book Line Record</td>
</tr>
<tr>
<td>----------------------</td>
<td>------------------------------------------------------------------------------</td>
<td>-----------</td>
<td>-------------</td>
<td>-------------------------------------------------------------------------------------------------------------</td>
<td>---------------------------------------------------</td>
<td>--------------------------------------------</td>
</tr>
<tr>
<td>PricebookCode</td>
<td>The unique identifier of the price book</td>
<td>String</td>
<td>80</td>
<td>Parent record PUID if the PUID is used.</td>
<td>A value is required if the PUID is used.</td>
<td>A value is required if the PUID is used.</td>
</tr>
<tr>
<td>ListPrice</td>
<td>The list price of the item or the product referred in the inventory item ID</td>
<td>BigDecimal</td>
<td></td>
<td>Ensure that this value is greater than zero for price books either in &quot;ACTIVE&quot; or &quot;EXPIRED&quot; status.</td>
<td>A value is required, if the price book is either in the &quot;ACTIVE&quot; or &quot;EXPIRED&quot; status.</td>
<td>Optional</td>
</tr>
<tr>
<td>ItemExternalSource</td>
<td>The external key and source key from the source system are used to uniquely identify and update or delete the price book line</td>
<td>String</td>
<td>120</td>
<td>Ensure that the combination of ItemExternalSource and ItemExternalKey is unique.</td>
<td>Not required</td>
<td>Optional</td>
</tr>
<tr>
<td>ItemDescription</td>
<td>A brief description of the price book item</td>
<td>String</td>
<td></td>
<td>No validation</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>InvOrgId</td>
<td>The unique identifier of the inventory organization</td>
<td>Long</td>
<td>18</td>
<td>Validate for the applicable organization ID for the selected item.</td>
<td>A value is required, if the primary key is used.</td>
<td>Not required</td>
</tr>
<tr>
<td>CurrencyCode</td>
<td>Specifies the currency associated with the price book header</td>
<td>String</td>
<td>15</td>
<td>Validate for the existing currency code.</td>
<td>Not required</td>
<td>Optional</td>
</tr>
<tr>
<td>ItemExternalKey</td>
<td>The external key and source key from the source system are used to uniquely identify a price book which is the parent of this price book line</td>
<td>String</td>
<td>120</td>
<td>Ensure that the combination of ItemExternalSource and ItemExternalKey is unique.</td>
<td>Not required</td>
<td>Optional</td>
</tr>
</tbody>
</table>

You can view the Price Book Line object along with all its child objects and attributes in the Manage Import Objects page of the Import Management flow. You can find attribute information like type, length, description, and so on, on this page.

Create the Source CSV File

You include the data that you want to import into CX Sales and B2B Service in a source CSV file.
You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to **Navigator > Tools > Import Management > Import Objects**.
2. Select the **Price Book Line** object in the table and click **Download**.

You can now edit the downloaded file and provide valid values for the required attributes.

**Note:** For help in populating the CSV file and to avoid any issues in entering values, see the topic **Potential Issues When Opening CSV Files With Excel** in Related Topics section.

### Create the Import Activity

To import data into Oracle Applications Cloud, you need to create an import activity and provide the CSV file as an input to the activity.

To create an import activity, do the following:

1. In the Navigator, under **Tools**, click **Import Management**.
2. On the **Manage Imports** page, click **Create Import Activity**.
3. In the **Enter Import Options** page, provide a name for the import activity, and select **Price Book Line** from the **Object** drop-down list.
4. In **File Name**, browse and upload the required .CSV file, and click **Next**.
5. In the **Map Fields** page edit the attribute mappings if required, and click **Next**.

**Note:** Click **Validate Data** to validate the mapping of the source file for unmapped columns and to check for data format issues.

6. In the **Create Import Activity: Review and Submit** page, click **Submit**.

### Review the Import Results

Check if your import succeeded on the **Manage Imports** page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to **Navigator > Tools > Import Management > Import Queue**.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the **Status** column for the import activity. The import is successful if the status displays as **Completed**. You can drill down on the import activity to go to the **Import Status** page which provides the status details of the import activity.

**Related Topics**

- Potential Issues When Opening CSV Files in Excel
- Import Data

### Import Your Product Data

You can use the Import Management functionality to create or update Product records.
To import Product records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (.csv) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes

To import your Product data into Oracle Applications Cloud, you need to populate a CSV file with your source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the .CSV file for data import:

- Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
- Ensure prerequisite steps are complete, such as understanding what attributes are required for importing your objects.
- Understand your options for uniquely identifying the records.
- Ensure parent records exist before importing child records.
- Identify the target object attributes that are required in the .CSV file for a successful import.

Before You Start

You must do some basic checks before starting your import. For example, make sure that:

- You have completed all the prerequisites for importing each attribute in your source data.
- You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records

To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the import process to uniquely identify the records. The file import process uses the attribute values to automatically map your source data to the target object attributes in Oracle Applications Cloud.

The preferred options to uniquely identify an object record are as follows:

- **Internal ID**: If you’re identifying a record that already exists in Oracle Applications Cloud, then you can use the internal ID of the record, a system-generated unique identifier. Attributes with "id" in the attribute name are typically internal IDs. You can determine the internal ID of a record by exporting Oracle Applications Cloud object data, or by doing a transactional database query. Using an internal ID typically provides better performance and reduces the import duration. For the Product object, the attributes are OrganizationId and InventoryItemld.

- **Public unique identifiers**: If you’re creating new records, then you can provide a user-friendly public unique identifier (attributes denoted with ‘Number’ and usually visible in the business object’s UI). If you update a record for which you have previously provided a Number attribute, or for which a Number attribute is visible in the object’s UI, you can use the Number attribute to identify the record. For the Product object, the attribute is ItemNumber.
Required Attributes and Validations for Product Object

To import data successfully into Oracle Applications Cloud, your .CSV file must include the required attributes. Ensure that you provide valid values for the attributes.

This table lists the required attributes for importing new Product records, required attributes for updating Product records, prerequisite setup tasks for the attributes, and specific validations, if any, for Product import:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Data Type</th>
<th>Data Length</th>
<th>Prerequisite Setup Task/ Import Validations</th>
<th>Creating a Product Record</th>
<th>Updating an Existing Product Record</th>
</tr>
</thead>
</table>
| OrganizationId  | A value that uniquely identifies the organization | Long      | 18          | • SCM setup to create a master inventory organization  
• Auto populates with value setup for “Sales Products Item Organization” under manage product group profile options | Don’t specify a value. The value is auto populated. | Not required |
<p>| Name            | Name of the product                              | String    | 240         | No validation                                | Required                  | Required                             |
| DefaultUOMCode  | The default unit of measure (UOM) code for the product | String    | 3           | SCM setup to UOM, mandatory for creating products. This is a standard DCL field. | Required                  | Not required                         |
| DefaultUOM      | The default unit of measure (UOM) for the product | String    | 25          | Either the UOMCode or the UOM is mandatory. It is validated against the UOM DCL. | Required only when the Default UOMCode isn't specified | Not required |
| ProductType     | Specifies the Sales Product Type                 | String    | 80          | No validation                                | Not required              | Not required                         |
| EligibleToSell  | Indicates whether the item can be sold           | String    | 80          | No validation                                | Not required              | Not required                         |</p>
<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Data Type</th>
<th>Data Length</th>
<th>Prerequisite Setup Task/Import Validations</th>
<th>Creating a Product Record</th>
<th>Updating an Existing Product Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>InventoryItemId</td>
<td>A unique identifier for the inventory item</td>
<td>Long</td>
<td>18</td>
<td>No validation</td>
<td>Don't specify a value. The value is auto populated.</td>
<td>Required</td>
</tr>
<tr>
<td>ItemNumber</td>
<td>Unique system generated ID of the product</td>
<td>String</td>
<td>300</td>
<td>This has to be unique. If you don't specify a value, it will be auto generated. You can’t update this value.</td>
<td>Required</td>
<td>Required</td>
</tr>
<tr>
<td>ItemCatalogGroupId</td>
<td>A unique value that provides metadata common to all items that share the category</td>
<td>Long</td>
<td>18</td>
<td>No validation</td>
<td>Not required</td>
<td>Optional</td>
</tr>
<tr>
<td>Description</td>
<td>Brief description of the product</td>
<td>String</td>
<td>4000</td>
<td>No validation</td>
<td>Not required</td>
<td>Optional</td>
</tr>
<tr>
<td>ProductTypeCode</td>
<td>Specifies the code of the product type</td>
<td>String</td>
<td>30</td>
<td>Select a value from the drop down list.</td>
<td>Not required</td>
<td>Optional</td>
</tr>
<tr>
<td>SalesProductLookup</td>
<td>The lookup type for the sales product type</td>
<td>String</td>
<td>80</td>
<td>No validation</td>
<td>Not required</td>
<td>Optional</td>
</tr>
<tr>
<td>ModelConfigAttributes</td>
<td>Model attributes</td>
<td>String</td>
<td>4000</td>
<td>No validation</td>
<td>Not required</td>
<td>Optional</td>
</tr>
<tr>
<td>ModelName</td>
<td>Name of the model</td>
<td>String</td>
<td>1000</td>
<td>No validation</td>
<td>Not required</td>
<td>Optional</td>
</tr>
<tr>
<td>InventoryItemStatusCode</td>
<td>Specifies the status code of the inventory item</td>
<td>String</td>
<td>10</td>
<td>Defaults to Active status</td>
<td>Required</td>
<td>Optional</td>
</tr>
<tr>
<td>EligibleToSellFlag</td>
<td>Indicates whether the item can be sold</td>
<td>String</td>
<td>1</td>
<td>This can be either Y or N.</td>
<td>Required</td>
<td>Optional</td>
</tr>
<tr>
<td>EligibleForService</td>
<td>Indicates whether the item is enabled for service</td>
<td>String</td>
<td></td>
<td>This can be Y only when the sales product type is either empty or has any of the following values:</td>
<td>Not required</td>
<td>Optional</td>
</tr>
</tbody>
</table>
**Attribute** | **Description** | **Data Type** | **Data Length** | **Prerequisite Setup Task/Import Validations** | **Creating a Product Record** | **Updating an Existing Product Record**
---|---|---|---|---|---|---
AttachmentEntityName | Name of the attachment entity | String | | | No validation | Not required | Optional
CSSEnabled | Enable Customer Self-Service | String | 1 | This can be either Y or N. | Not required | Optional

You can view the Product object along with all its child objects and attributes in the Manage Import Objects page of the Import Management flow. You can find attribute information like type, length, description, and so on, on this page.

**Create the Source CSV File**

You include the data that you want to import into CX Sales and B2B Service in a source CSV file. You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator > Tools > Import Management > Import Objects.
2. Select the Product object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

**Note:** For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.

**Create the Import Activity**

To import data into Oracle Applications Cloud, you need to create an import activity and provide the CSV file as an input to the activity.

To create an import activity, do the following:

1. In the Navigator, under Tools, click Import Management.
2. On the Manage Imports page, click Create Import Activity.
3. In the Create Import Activity: Enter Import Options page, provide a name for the import activity, and select Product from the Object drop-down list.
4. In File Name, browse and upload the required .CSV file, and click Next.
5. In the Create Import Activity: Map Fields page edit the attribute mappings if required, and click Next.

   **Note:** Click Validate Data to validate the mapping of the source file for unmapped columns and to check for data format issues.

6. In the Create Import Activity: Review and Submit page, click Submit.

**Review the Import Results**

Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed. You can drill down on the import activity to go to the Import Status page which provides the status details of the import activity.

**Related Topics**

- Potential Issues When Opening CSV Files in Excel
- Import Data

**Import Your Product Group Data**

You can use the import functionality to create or update Product Group records.

To import Product Group records:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (.csv) file for import.
3. Create the import activity.
4. Review the import results.

**How You Map Your Source Data to Target Object Attributes**

To import Product Group data into Oracle Applications Cloud, you need to populate a CSV file with your source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the .CSV file for data import:

- Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
- Ensure prerequisite steps are complete, such as understanding what attributes are required for importing your objects.
- Understand your options for uniquely identifying the records.
- Ensure parent records exist before importing child records.
- Identify the target object attributes that are required in the .CSV file for a successful import.
Before You Start

You need to set certain options for some attributes in the application before you can populate them. When importing a child record, ensure that its parent record exists in the database.

Select a Unique Identifier for Your Records

To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the import process to uniquely identify the records. The file import process uses the attribute values to automatically map your source data to the target object attributes in Oracle Applications Cloud.

The preferred options to uniquely identify an object record are as follows:

- **Internal ID**: If you're identifying a record that already exists in Oracle Applications Cloud, then you can use the internal ID of the record, a system-generated unique identifier. Attributes with "id" in the attribute name are typically internal IDs. You can determine the internal ID of a record by exporting Oracle Applications Cloud object data, or by doing a transactional database query. Using an internal ID typically provides better performance and reduces the import duration. For the Product Group object, this attribute is ProdGroupId.

- **Public unique identifiers**: If you're creating new records, then you can provide a user-friendly public unique identifier (attributes denoted with 'Number' and usually visible in the business object's UI). If you update a record for which you have previously provided a Number attribute, or for which a Number attribute is visible in the object's UI, you can use the Number attribute to identify the record. For the Product Group object, the attribute is ProductGroupReferenceNumber.

Required Attributes and Validations

To import data successfully into Oracle Applications Cloud, your .CSV file must include the required attributes. Ensure that you provide valid values for the attributes.

This table lists the required attributes for importing new Product Group records, required attributes for updating Product Group records, prerequisite setup tasks for the attributes, and specific validations, if any, for Product Group import:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Data Type</th>
<th>Data Length</th>
<th>Prerequisite Setup Task/ Import Validations</th>
<th>Creating a Product Group Record</th>
<th>Updating an Existing Product Group Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>ProdGrpDetailsId</td>
<td>The unique identifier of the product group details.</td>
<td>Long</td>
<td>18</td>
<td>No validation</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>StartDate</td>
<td>The date and time from when the product group is available in the catalog.</td>
<td>Time stamp</td>
<td></td>
<td>The start date can't be later than the end date.</td>
<td>Not required</td>
<td>Optional</td>
</tr>
<tr>
<td>EndDate</td>
<td>The date and time when the product group is no longer available in the catalog.</td>
<td>Time stamp</td>
<td></td>
<td>The end date has to be later than the start date.</td>
<td>Not required</td>
<td>Optional</td>
</tr>
<tr>
<td>Attribute</td>
<td>Description</td>
<td>Data Type</td>
<td>Data Length</td>
<td>Prerequisite Setup Task/Import Validations</td>
<td>Creating a Product Group Record</td>
<td>Updating an Existing Product Group Record</td>
</tr>
<tr>
<td>--------------------------</td>
<td>------------------------------------------------------------------------------</td>
<td>-----------</td>
<td>-------------</td>
<td>-------------------------------------------</td>
<td>---------------------------------</td>
<td>-------------------------------------------</td>
</tr>
<tr>
<td>InternalName</td>
<td>The product group's unique name</td>
<td>String</td>
<td>150</td>
<td>Enter a unique name.</td>
<td>Required</td>
<td>This can't be updated.</td>
</tr>
<tr>
<td>ProdGroupName</td>
<td>The product group name displayed in the catalog.</td>
<td>String</td>
<td>250</td>
<td>No validation</td>
<td>Required</td>
<td>Optional</td>
</tr>
<tr>
<td>ActiveFlag</td>
<td>Indicates whether the product group is active or inactive.</td>
<td>String</td>
<td>1</td>
<td>Enter either Y or N.</td>
<td>Defaults to Y</td>
<td>Optional</td>
</tr>
<tr>
<td>AllowDuplicateContentFlag</td>
<td>Indicates whether products or product groups are allowed to be added to the product group hierarchy more than once.</td>
<td>String</td>
<td>Required</td>
<td>Optional</td>
<td>Defaults to N</td>
<td>Optional</td>
</tr>
<tr>
<td>ProdGroupId</td>
<td>Unique identifier of the product group</td>
<td>Long</td>
<td>18</td>
<td>No validation</td>
<td>A value is auto generated.</td>
<td>Required</td>
</tr>
<tr>
<td>ProductGroupReferenceNumber</td>
<td>The unique value used to identify the product group.</td>
<td>String</td>
<td>50</td>
<td>Setup the on prefix and radix. Navigate to the following in the Setup and Maintenance work area:</td>
<td>A value is auto generated. You can also enter a value.</td>
<td>Required</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>• Offering: Sales</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>• Functional Area: Data Import and Export</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>• Task: Manage Public Unique Identifier Sequence Generation</td>
<td></td>
<td></td>
</tr>
<tr>
<td>RevenueRoleCode</td>
<td>The code indicating the revenue role associated with the product group. For example, Sales revenue line set or</td>
<td>String</td>
<td>30</td>
<td>FCL validated against MOO_REVENUE_ROLE lookup</td>
<td>Not required</td>
<td>Optional</td>
</tr>
<tr>
<td>Attribute</td>
<td>Description</td>
<td>Data Type</td>
<td>Data Length</td>
<td>Prerequisite Setup Task/Import Validations</td>
<td>Creating a Product Group Record</td>
<td>Updating an Existing Product Group Record</td>
</tr>
<tr>
<td>--------------------</td>
<td>-----------------------------------------------------------------------------</td>
<td>-----------</td>
<td>-------------</td>
<td>--------------------------------------------</td>
<td>---------------------------------</td>
<td>------------------------------------------</td>
</tr>
<tr>
<td>RevenueCategoryCode</td>
<td>The code indicating the revenue category associated with the product group. For example, Software, Maintenance, Service, Training, Hardware, or Back Maintenance.</td>
<td>String</td>
<td>30</td>
<td>FCL validated against MOO_REVN_CATEGORY lookup</td>
<td>Not required</td>
<td>Optional</td>
</tr>
</tbody>
</table>
| AllowSelectionFlag | Indicates whether the product group is available for selection              | String    | 1           | Enter either Y or N. The import operation fails, if updating a record results in:  
  - Circular hierarchy  
  - Parent product group with allow duplicate N and child with Y.  
  - Hierarchy with allow duplicate N results in repeated child/products. | Defaults to Y                       | Optional                                  |
| ModelName          | Unique name of the model                                                    | String    | 1000        | No validation                              | Not required                     | Optional                                  |
| ModelConfigAttributes| Model attributes                                                            | String    | 4000        | No validation                              | Not required                     | Optional                                  |
| ProdGroupDescription| Brief description of the product group                                      | String    | 1000        | No validation                              | Not required                     | Optional                                  |
| UsageRootFlag      | Indicates whether the product group is the root product group in a hierarchy.| String    | 1           | Enter either Y or N.                        | Defaults to N                    | Optional                                  |
Create the Source CSV File

You provide the .CSV file as input during the file-based data import process. You must populate the .CSV file with the data you want to import into Oracle Applications Cloud.

You can either create a CSV file on your own or use templates available in preexisting mappings. To download a template:

1. In the Navigator, under Tools, click Import Management.
2. Click Import Objects tab to open the Import Object Details page.
3. Select the object you’re interested in the Import Object Details page and click the Download icon next to that object name.
4. Save the template CSV file to a location on your desktop.

| Note: To import the product group successfully, you should split the import file into Group, Subgroup, and Item. |

You must edit the template CSV file and provide valid values for the required attributes. You can attach different types of files, giving each file a specific description.

Create the Import Activity

To import data into Oracle Applications Cloud, you need to create an import activity and provide the CSV file as an input to the activity.

To create an import activity:

1. In the Navigator, under Tools, click Import Management.
2. On the Manage Imports page, click Create Import Activity.
3. In the Create Import Activity: Enter Import Options page, provide a name for the import activity, and select Product Group from the Object drop-down list.
4. In File Name, browse and upload the required .CSV file, and click Next.
5. In the Create Import Activity: Map Fields page edit the attribute mappings if required, and click Next.
   
   **Note:** Click Validate Data to validate the mapping of the source file for unmapped columns and to check for data format issues.

6. In the Create Import Activity: Review and Submit page, click Submit.

**Review the Import Results**

You can review the import results by checking for the import activity in the Manage Import Activity page. A file import activity is said to be successful when its status displays as Completed. To check the status of the import activity, do as follows:

1. In the Navigator, under Tools, click Import Management.
2. On the Manage Imports page, search for the import activity that you created using one of the search criteria, such as status, name, object, and so on.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed. The other valid values for the import activity status are Queued for import, Preparing data for import, Importing data, Completed with errors, and Unsuccessful.

**Note:** On this page you can also quickly view the number and status of all active imports, completed imports, and unsuccessful imports that have been submitted.

**Related Topics**
- Import Data

**Import Your Product Group Item Data**

You can use the Import Management functionality to create or update Product Group Item records.

To import Product Group Item records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (.csv) file for import.
3. Create the import activity.
4. Review the import results.

**How You Map Your Source Data to Target Object Attributes**

To import your Product Group Item data into Oracle Applications Cloud, you need to populate a CSV file with your source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the .CSV file for data import:

- Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
- Ensure prerequisite steps are complete, such as understanding what attributes are required for importing your objects.
- Understand your options for uniquely identifying the records.
• Ensure parent records exist before importing child records.
• Identify the target object attributes that are required in the .CSV file for a successful import.

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.
• You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the import process to uniquely identify the records. The file import process uses the attribute values to automatically map your source data to the target object attributes in Oracle Applications Cloud.

The preferred options to uniquely identify an object record are as follows:

• **Internal ID**: If you're identifying a record that already exists in Oracle Applications Cloud, then you can use the internal ID of the record, a system-generated unique identifier Attributes with "id" in the attribute name are typically internal IDs. You can determine the internal ID of a record by exporting Oracle Applications Cloud object data, or by doing a transactional database query. Using an internal ID typically provides better performance and reduces the import duration. For the Product Group Item object, the attributes are InventoryItemld, InvOrgId, and ProdGroupld, when creating a product group item and ProdGroupItemsId, when updating a product group item.

• **Public unique identifiers**: If you're creating new records, then you can provide a user-friendly public unique identifier (attributes denoted with ‘Number’ and usually visible in the business object's UI). If you update a record for which you have previously provided a Number attribute, or for which a Number attribute is visible in the object's UI, you can use the Number attribute to identify the record. For the Product Group Item object, the attributes are ParPGReferenceNumber and ProductNumber.

Required Attributes and Validations for Product Group Item Object
To import data successfully into Oracle Applications Cloud, your .CSV file must include the required attributes. Ensure that you provide valid values for the attributes.

This table lists the required attributes for importing new Product Group Item records, required attributes for updating Product Group Item records, prerequisite setup tasks for the attributes, and specific validations, if any, for Product Group Item import:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Data Type</th>
<th>Data Length</th>
<th>Prerequisite Setup Task/ Import Validations</th>
<th>Creating a Product Group Item Record</th>
<th>Updating an Existing Product Group Item Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>ActiveFlag</td>
<td>Indicates whether the product group item is active or inactive.</td>
<td>String</td>
<td>1</td>
<td>Enter either Y or N.</td>
<td>Defaults to Y</td>
<td>Optional</td>
</tr>
</tbody>
</table>

536
<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Data Type</th>
<th>Data Length</th>
<th>Prerequisite Setup Task/ Import Validations</th>
<th>Creating a Product Group Item Record</th>
<th>Updating an Existing Product Group Item Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>StartDate</td>
<td>The date and time when the product group item is available in the catalog.</td>
<td>Time stamp</td>
<td></td>
<td>Start date can’t be later than the end date.</td>
<td>Not required</td>
<td>Optional</td>
</tr>
<tr>
<td>InventoryItemId</td>
<td>A unique identifier for the inventory item</td>
<td>Long</td>
<td>18</td>
<td>No validation</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td>InvOrgId</td>
<td>The unique identifier of the inventory organization</td>
<td>Long</td>
<td>18</td>
<td>No validation</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td>EndDate</td>
<td>The date and time after which the product group item is no longer available in the catalog.</td>
<td>Time stamp</td>
<td></td>
<td>Start date can’t be later than the end date.</td>
<td>Not Required</td>
<td>Optional</td>
</tr>
<tr>
<td>ProductNumber</td>
<td>The product number/code of the product</td>
<td>String</td>
<td>300</td>
<td>No validation</td>
<td>Required if importing the record using the PUID</td>
<td>Required if updating the record using the PUID</td>
</tr>
<tr>
<td>ProdGroupItemsId</td>
<td>Unique identifier for a product group item</td>
<td>Long</td>
<td>18</td>
<td>No validation</td>
<td>Auto generated</td>
<td>Required if updating the record using the ID</td>
</tr>
<tr>
<td>ProdGroupId</td>
<td>Unique identifier for a product group</td>
<td>Long</td>
<td>18</td>
<td>No validation</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td>ParPGReferenceNum</td>
<td>The unique value used to identify the product group.</td>
<td>String</td>
<td>50</td>
<td>No validation</td>
<td>Required if importing the record using the PUID</td>
<td>Required if updating the record using PUID</td>
</tr>
<tr>
<td>DisplayOrderNum</td>
<td>Number indicating the order in which this product group is displayed in the sales catalog.</td>
<td>Long</td>
<td>18</td>
<td>No validation</td>
<td>Not Required</td>
<td>Optional</td>
</tr>
</tbody>
</table>

You can view the Product Group Item object along with all its child objects and attributes in the Manage Import Objects page of the Import Management flow. You can find attribute information like type, length, description, and so on, on this page.
Create the Source CSV File

You include the data that you want to import into CX Sales and B2B Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator > Tools > Import Management > Import Objects.
2. Select the Product Group Item object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note: For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity

To import data into Oracle Applications Cloud, you need to create an import activity and provide the CSV file as an input to the activity.

To create an import activity, do the following:

1. In the Navigator, under Tools, click Import Management.
2. On the Manage Imports page, click Create Import Activity.
3. In the Create Import Activity: Enter Import Options page, provide a name for the import activity, and select Product Group Item from the Object drop-down list.
4. In File Name, browse and upload the required .CSV file, and click Next.
5. In the Create Import Activity: Map Fields page edit the attribute mappings if required, and click Next.
6. In the Create Import Activity: Review and Submit page, click Submit.

Note: Click Validate Data to validate the mapping of the source file for unmapped columns and to check for data format issues.

Review the Import Results

Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed. You can drill down on the import activity to go to the Import Status page which provides the status details of the import activity.

Related Topics
- Potential Issues When Opening CSV Files in Excel
- Import Data
Import Your Product Group Relation Setup Data

You can use the Import Management functionality to create or update Product Group Relation Setup records.

To import Product Group Relation Setup records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (.csv) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes

To import your Product Group Relation Setup data into Oracle Applications Cloud, you need to populate a CSV file with your source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the .CSV file for data import:

- Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
- Ensure prerequisite steps are complete, such as understanding what attributes are required for importing your objects.
- Understand your options for uniquely identifying the records.
- Ensure parent records exist before importing child records.
- Identify the target object attributes that are required in the .CSV file for a successful import.

Before You Start

You must do some basic checks before starting your import. For example, make sure that:

- You have completed all the prerequisites for importing each attribute in your source data.
- You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records

To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the import process to uniquely identify the records. The file import process uses the attribute values to automatically map your source data to the target object attributes in Oracle Applications Cloud.

The preferred options to uniquely identify an object record are as follows:

- **Internal ID**: If you’re identifying a record that already exists in Oracle Applications Cloud, then you can use the internal ID of the record, a system-generated unique identifier Attributes with "id" in the attribute name are typically internal IDs. You can determine the internal ID of a record by exporting Oracle Applications Cloud object data, or by doing a transactional database query. Using an internal ID typically provides better performance and reduces the import duration. For the Product Group Relation Setup object, the attributes are RelProdGroupId and ProdGroupRelationshipId, when creating a Product Group Relation Setup record and ProdGroupRelationshipId when updating a Product Group Relation Setup record.
• **Public unique identifiers**: If you're creating new records, then you can provide a user-friendly public unique identifier (attributes denoted with ‘Number’ and usually visible in the business object’s UI). If you update a record for which you have previously provided a Number attribute, or for which a Number attribute is visible in the object’s UI, you can use the Number attribute to identify the record. For the Product Group Relation Setup object, the attributes are PGDetailsReferenceNumber and ParPGReferenceNumber.

### Required Attributes and Validations for Product Group Relation Setup Object

To import data successfully into Oracle Applications Cloud, your .CSV file must include the required attributes. Ensure that you provide valid values for the attributes.

This table lists the required attributes for importing new Product Group Relation Setup records, required attributes for updating Product Group Relation Setup records, prerequisite setup tasks for the attributes, and specific validations, if any, for Product Group Relation Setup import:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Data Type</th>
<th>Data Length</th>
<th>Prerequisite Setup Task/Import Validations</th>
<th>Creating a Product Group Relation Setup Record</th>
<th>Updating an Existing Product Group Relation Setup Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>ActiveFlag</td>
<td>Indicates whether the product group is active or inactive.</td>
<td>String</td>
<td>1</td>
<td>Enter either Y or N.</td>
<td>Defaults to Y</td>
<td>Optional</td>
</tr>
<tr>
<td>RelProdGroupId</td>
<td>A unique identifier of the Product group relationship</td>
<td>Long</td>
<td>18</td>
<td>This is auto generated.</td>
<td>Required</td>
<td>Not Required</td>
</tr>
<tr>
<td>StartDate</td>
<td>The date and time when the product group relation is available in the catalog.</td>
<td>Time stamp</td>
<td></td>
<td>The start date can’t be later than the end date.</td>
<td>Not Required</td>
<td>Optional</td>
</tr>
<tr>
<td>EndDate</td>
<td>The date and time when the product group relation is no longer available in the catalog.</td>
<td>Time stamp</td>
<td></td>
<td>The start date can’t be later than the end date.</td>
<td>Not Required</td>
<td>Optional</td>
</tr>
<tr>
<td>PGDetailsReference</td>
<td>The unique value used to identify the product group.</td>
<td>String</td>
<td>50</td>
<td>No validation</td>
<td>Required</td>
<td>Required</td>
</tr>
<tr>
<td>ProdGroupRelations</td>
<td>A unique identifier of the product group relation</td>
<td>Long</td>
<td>18</td>
<td>No validation</td>
<td>Not Required</td>
<td>Required</td>
</tr>
</tbody>
</table>
Oracle CX
Understanding Import and Export Management for CX
Sales and B2B Service

Chapter 8
Import Your Data

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Data Type</th>
<th>Data Length</th>
<th>Prerequisite Setup Task/Import Validations</th>
<th>Creating a Product Group Relation Setup Record</th>
<th>Updating an Existing Product Group Relation Setup Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>ProdGroupId</td>
<td>A unique identifier of the product group</td>
<td>Long</td>
<td>18</td>
<td>No validation</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td>ParPGReferenceNum</td>
<td>The unique value used to identify the product group.</td>
<td>String</td>
<td>50</td>
<td>No validation</td>
<td>Required</td>
<td>Required</td>
</tr>
<tr>
<td>DisplayOrderNum</td>
<td>Number indicating the order in which this product group relation is displayed in the sales catalog.</td>
<td>Long</td>
<td>18</td>
<td>No validation</td>
<td>Not Required</td>
<td>Optional</td>
</tr>
</tbody>
</table>

You can view the Product Group Relation Setup object along with all its child objects and attributes in the Manage Import Objects page of the Import Management flow. You can find attribute information like type, length, description, and so on, on this page.

Create the Source CSV File
You include the data that you want to import into CX Sales and B2B Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator > Tools > Import Management > Import Objects.
2. Select the Product Group Relation Setup object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

**Note:** For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
To import data into Oracle Applications Cloud, you need to create an import activity and provide the CSV file as an input to the activity.

To create an import activity, do the following:

1. In the Navigator, under Tools, click Import Management.
2. On the Manage Imports page, click Create Import Activity.
3. In the Create Import Activity: Enter Import Options page, provide a name for the import activity, and select Product Group Relation Setup from the Object drop-down list.
4. In File Name, browse and upload the required .CSV file, and click Next.
5. In the **Create Import Activity: Map Fields** page edit the attribute mappings if required, and click **Next**.

   **Note:** Click **Validate Data** to validate the mapping of the source file for unmapped columns and to check for data format issues.

6. In the **Create Import Activity: Review and Submit** page, click **Submit**.

### Review the Import Results

Check if your import succeeded on the **Manage Imports** page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to **Navigator > Tools > Import Management > Import Queue**.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the **Status** column for the import activity. The import is successful if the status displays as **Completed**. You can drill down on the import activity to go to the **Import Status** page which provides the status details of the import activity.

### Related Topics
- Potential Issues When Opening CSV Files in Excel
- Import Data

### Import Your Program Benefit Detail Data

You can use the Import Management to create, update, or delete Program Benefit Details records.

To import Program Benefit Detail records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (.csv) file for import.
3. Create the import activity.
4. Review the import results.

### How You Map Your Source Data to Target Object Attributes

To import your Program Benefit Detail data into Oracle Applications Cloud, you need to populate a CSV file with your source data and map that source data to target object attributes in Oracle Applications Cloud.

You must do the following before creating the .CSV file for data import:

- Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
- Ensure prerequisite steps are complete, such as understanding what attributes are required for importing your objects.
- Understand your options for uniquely identifying the records.
- Ensure parent records exist before importing child records.
- Identify the target object attributes that are required in the .csv file for a successful import.
Before You Start
You must do some basic checks before starting your import. For example, make sure that:

- You have completed all the prerequisites for importing each attribute in your source data.
- You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the import process to uniquely identify the records. The file import process uses the attribute values to automatically map your source data to the target object attributes in Oracle Applications Cloud.

The preferred option to uniquely identify an object record is through the internal ID. If you're identifying a record that already exists in Oracle Applications Cloud, then you can use the internal ID of the record, a system-generated unique identifier. Attributes with "ID" in the attribute name are typically internal IDs. You can determine the internal ID of a record by exporting Oracle Applications Cloud object data, or by doing a transactional database query. Using an internal ID typically provides better performance and reduces the import duration. For the Program Benefit Detail object, this attribute is ProgramBenefitDetailID.

Required Attributes and Validations for Program Benefit Detail Object
To import data successfully into Oracle Applications Cloud, your .csv file must include the required attributes. Ensure that you provide valid values for the attributes.

This table lists the required attributes for importing new Program Benefit Detail records, required attributes for updating Program Benefit Detail records, prerequisite setup tasks for the attributes, and specific validations, if any, for Program Benefit Detail import:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Data Type</th>
<th>Data Length</th>
<th>Prerequisite Setup Task/Import Validations</th>
<th>Creating an Program Benefit Detail record</th>
<th>Updating an Existing Program Benefit Detail record</th>
</tr>
</thead>
<tbody>
<tr>
<td>ProgramBenefitDetailID</td>
<td>The system-generated unique identifier for the partner program benefit</td>
<td>Integer</td>
<td>18</td>
<td>None</td>
<td>Not required</td>
<td>Required</td>
</tr>
<tr>
<td>ProgramBenefitID</td>
<td>The unique identifier for the benefit</td>
<td>Integer</td>
<td>18</td>
<td>None</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td>Name</td>
<td>A unique name for the partner program benefit</td>
<td>Varchar2</td>
<td>155</td>
<td>None</td>
<td>A value is required if the program benefit ID isn’t specified.</td>
<td>Not Required</td>
</tr>
<tr>
<td>PartnerProgramID</td>
<td>The primary key and unique identifier for the partner program</td>
<td>Integer</td>
<td>18</td>
<td>None</td>
<td>A value is required if the program number isn’t specified.</td>
<td>Not required</td>
</tr>
</tbody>
</table>
Create the Source CSV File

You include the data that you want to import into CX Sales and B2B Service in a source CSV file. You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator > Tools > Import Management > Import Objects.
2. Select the Program Benefit Detail object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

**Note:** For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity

To create an import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Program Benefit Detail from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results

Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the **Status** column for the import activity. The import is successful if the status displays as **Completed**. You can drill down on the import activity to go to the **Import Status** page which provides the status details of the import activity.

**Related Topics**
- Potential Issues When Opening CSV Files in Excel
- Import Data

## Import Your Program Enrollments Data

You can use Import Management to create or update Program Enrollment records.

To import Program Enrollment records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (.csv) file for import.
3. Create the import activity.
4. Review the import results.

### How You Map Your Source Data to Target Object Attributes

To import your Program Enrollment data into Oracle Applications Cloud, you must populate a CSV file with your source data and map that source data to target object attributes in Oracle Applications Cloud.

You must do the following before creating the .CSV file for data import:

- Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
- Ensure prerequisite steps are complete, such as understanding what attributes are required for importing your objects.
- Understand your options for uniquely identifying the records.
- Ensure parent records exist before importing child records.
- Identify the target object attributes that are required in the .CSV file for a successful import.

### Before You Start

You must do some basic checks before starting your import. For example, make sure that:

- You have completed all the prerequisites for importing each attribute in your source data.
- You have all parent records in place before importing child records.

### Select a Unique Identifier for Your Records

To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the import process to uniquely identify the records. The file import process uses the attribute values to automatically map your source data to the target object attributes in Oracle Applications Cloud.
The preferred options to uniquely identify an object record are as follows:

- **Internal ID**: If you’re identifying a record that already exists in Oracle Applications Cloud, then you can use the internal ID of the record, a system-generated unique identifier. Attributes with “id” in the attribute name are typically internal IDs. You can determine the internal ID of a record by exporting Oracle Applications Cloud object data, or by doing a transactional database query. Using an internal ID typically provides better performance and reduces the import duration. For the Program Enrollment object, this attribute is ProgramEnrollmentId.

- **Public unique identifiers**: If you’re creating new records, then you can provide a user-friendly public unique identifier (attributes denoted with ‘Number’ and usually visible in the business object’s UI). If you update a record for which you have previously provided a Number attribute, or for which a Number attribute is visible in the object’s UI, you can use the Number attribute to identify the record. For the Program Enrollment object, the attribute is EnrollmentNumber.

### Required Attributes and Validations for Program Enrollment Object

To import data successfully into Oracle Applications Cloud, your .CSV file must include the required attributes. Ensure that you provide valid values for the attributes.

This table lists the required attributes for importing new Program Enrollment records, required attributes for updating Program Enrollment records, prerequisite setup tasks for the attributes, and specific validations, if any, for Program Enrollment import:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/Import Validations</th>
<th>Creating a Program Enrollment record</th>
<th>Updating an Existing Program Enrollment record</th>
</tr>
</thead>
<tbody>
<tr>
<td>ProgramEnrollmentId</td>
<td>The unique ID for the existing program enrollment record.</td>
<td>None.</td>
<td>Not required</td>
<td>A value is required if the enrollment number isn't specified.</td>
</tr>
<tr>
<td>PartnerPartyId</td>
<td>The internal ID to identify a partner</td>
<td>The partner can’t be in the Perspective or Rejected status.</td>
<td>A value is required if the partner company number isn’t specified.</td>
<td>Not required</td>
</tr>
<tr>
<td>PartnerProgramId</td>
<td>The internal ID to identify a program</td>
<td>The program needs to be in the Published status.</td>
<td>A value is required if the program number isn’t specified.</td>
<td>Not Required</td>
</tr>
<tr>
<td>ProgramNumber</td>
<td>The public unique identifier to identify a program</td>
<td>The program needs to be in the Published status.</td>
<td>A value is required if the partner program ID isn’t specified.</td>
<td>Not required</td>
</tr>
<tr>
<td>PartnerCompanyNumber</td>
<td>The public unique identifier to identify a partner</td>
<td>The partner can’t be in the Perspective or Rejected status.</td>
<td>A value is required if the partner party ID isn’t specified.</td>
<td>Not required</td>
</tr>
<tr>
<td>EnrollmentNumber</td>
<td>The public unique identifier to identify an enrollment</td>
<td>None</td>
<td>Not required</td>
<td>A value is required if the program enrollment ID isn’t specified.</td>
</tr>
</tbody>
</table>
You can view the Program Enrollment object along with all its child objects and attributes in the Manage Import Objects page of the Import Management flow. You can find attribute information like type, length, description, and so on, on this page.

Create the Source CSV File

You include the data that you want to import into CX Sales and B2B Service in a source CSV file. You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator > Tools > Import Management > Import Objects.
2. Select the Program Enrollment object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

**Note:** For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity

To import data into Oracle Applications Cloud, you need to create an import activity and provide the CSV file as an input to the activity.

To create an import activity, do the following:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Program Enrollment from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results

Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed. You can drill down on the import activity to go to the Import Status page which provides the status details of the import activity.

**Related Topics**

- Potential Issues When Opening CSV Files in Excel
- Import Data
Import Your Promotion Data

You can use Import Management to create or update Promotion records.

To import Promotion records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes

To import your Promotion data into Oracle Applications Cloud, you need to populate a CSV file with your source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

- Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
- Ensure prerequisite setups are done, if applicable.
- Understand your options for uniquely identifying the records.
- Ensure parent records exist before importing child records.
- Identify the target object attributes that are required in the CSV file for a successful import.

Before You Start

You must do some basic checks before starting your import. For example, make sure that:

- You have completed all the prerequisites for importing each attribute in your source data.
- You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records

All records must be unique in the application. You can use one of these to identify records:

- Public unique identifiers: If you’re creating records, then you can provide an easily understandable public unique identifier. These are, usually, denoted with ‘Number’ and visible in the business object’s UI. PUID attributes are usually named <object> Number. If you’re updating a record with a Number attribute, then use the Number attribute to identify the record. For more information about public unique identifiers, see the topic "How You Use Alternate Keys to Import Records" in Related Topics section.
- Source system and source system reference: Source system is an identifier for the external system, and source system reference is a unique identifier within the external system. If you’re importing new Promotions or are updating Promotions that have source system reference data, then provide the source system and source system reference values.
**Required Attributes and Validations for Promotion Object**

To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure that you provide valid values for the attributes. This table lists the required attributes for importing new Promotion records, required attributes for updating Promotion records, prerequisite setup tasks for the attributes, and specific validations, if any, for Promotion import:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/Import Validations</th>
<th>Creating a Promotion Record</th>
<th>Updating an Existing Promotion Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>SalesPromotionId</td>
<td>The unique identifier of the promotion record</td>
<td>No validation</td>
<td>Not applicable</td>
<td>Not applicable</td>
</tr>
<tr>
<td>SalesPromotionCode</td>
<td>The promotion code applicable to the promotion</td>
<td>No validation</td>
<td>Optional</td>
<td>Optional</td>
</tr>
</tbody>
</table>
| StatusCode      | The status of the promotion record                               | Navigate to the following in Setup and Maintenance:  
  • Offering: Sales  
  • Functional Area: Sales  
  • Task: Manage  
    Standard Lookups  
  Search for the Promotion Status lookup.  
  Validation based on lookup type Promotion Adjustment Types | Required | Required                  |
| AdjustmentTypeCode | The type of promotion adjustment                               | Validation based on lookup type Promotion Adjustment Types | Required | Required                  |
| Name            | The name of the promotion                                        | No validation                              | Required                    | Required                             |

You can view the Promotion object along with all its child objects and attributes in the Manage Import Objects page of the Import Management flow. You can find attribute information like type, length, description, and so on, on this page.

**Create the Source CSV File**

You include the data that you want to import into CX Sales and B2B Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to **Navigator > Tools > Import Management > Import Objects**.
2. Select the **Promotion** object in the table and click **Download**.

You can now edit the downloaded file and provide valid values for the required attributes.

**Note:** For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.
Create the Import Activity

After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Promotion from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results

Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed. You can drill down on the import activity to go to the Import Status page which provides the status details of the import activity.

Related Topics
- Potential Issues When Opening CSV Files in Excel
- How You Use Alternate Keys to Import Records
- Import Data

Import Your Queue Data

You can use Import Management to create or update Queue records.

To import Queue records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes

To import your Queue data into Oracle Applications Cloud, you need to populate a CSV file with your source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

- Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
• Ensure prerequisite setups are done, if applicable.
• Understand your options for uniquely identifying the records.
• Ensure parent records exist before importing child records.
• Identify the target object attributes that are required in the CSV file for a successful import.

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.
• You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
All records must be unique in the application. You can use one of these to identify records:

• Public unique identifiers: If you’re creating records, then you can provide an easily understandable public unique identifier. These are, usually, denoted with ‘Number’ and visible in the business object’s UI. PUID attributes are usually named <object> Number. If you’re updating a record with a Number attribute, then use the Number attribute to identify the record. For more information about public unique identifiers, see the topic "How You Use Alternate Keys to Import Records" in Related Topics section.

• Source system and source system reference: Source system is an identifier for the external system, and source system reference is a unique identifier within the external system. If you’re importing new queues or are updating queues that have source system reference data, then provide the source system and source system reference values.

Required Attributes and Validations for Queue Object
To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure that you provide valid values for the attributes. This table lists the required attributes for importing new Queue records, required attributes for updating Queue records, prerequisite setup tasks for the attributes, and specific validations, if any, for Queue import:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/Import Validations</th>
<th>Creating a Queue Record</th>
<th>Updating an Existing Queue Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>QueueId</td>
<td>The unique identifier of the queue.</td>
<td>No Validation</td>
<td>Not Required</td>
<td>Conditionally Required</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Either the QueueId or the QueueNumber is required.</td>
</tr>
<tr>
<td>QueueName</td>
<td>The name of the queue.</td>
<td>No Validation</td>
<td>Required</td>
<td>Not Required</td>
</tr>
<tr>
<td>EnabledFlag</td>
<td>Contains the values, True or False. If True, the queue is enabled. If False, the queue isn't enabled. The default value is True.</td>
<td>No Validation</td>
<td>Not Required</td>
<td>Not Required</td>
</tr>
</tbody>
</table>
### Attribute Description Prerequisite Setup Task/Import Validations Creating a Queue Record Updating an Existing Queue Record

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/Import Validations</th>
<th>Creating a Queue Record</th>
<th>Updating an Existing Queue Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>ExternalFlag</td>
<td>Indicates whether the automatic agent assignment on the queue is handled by Omnichannel Routing or by a third-party routing system.</td>
<td>No Validation</td>
<td>Not Required</td>
<td>Not Required</td>
</tr>
<tr>
<td>StripeCd</td>
<td>The lookup code that defines the stripe code such as CRM or HCM.</td>
<td>No Validation</td>
<td>Not Required</td>
<td>Not Required</td>
</tr>
<tr>
<td>AutoRoutingFlag</td>
<td>Contains the values, True or False. If True, then the queue supports automated routing. If False, then the queue supports manual routing. The default value is False.</td>
<td>No Validation</td>
<td>Not Required</td>
<td>Not Required</td>
</tr>
<tr>
<td>OverflowEnabledFlag</td>
<td>Indicates whether the Overflow feature is enabled in the queue.</td>
<td>No Validation</td>
<td>Not Required</td>
<td>Not Required</td>
</tr>
<tr>
<td>OwnerPartyId</td>
<td>The unique identifier of the user (resource) to whom any service requests in the queue are assigned. The user is responsible for further service request assignment and scheduling.</td>
<td>The party should exist.</td>
<td>Conditionally Required</td>
<td>Conditionally Required</td>
</tr>
<tr>
<td>OwnerPartyNumber</td>
<td>The public unique identifier of the user (resource) to whom any service requests in the queue are assigned. The user is responsible for further service request assignment and scheduling.</td>
<td>The party should exist.</td>
<td>Conditionally Required</td>
<td>Conditionally Required</td>
</tr>
<tr>
<td>QueueNumber</td>
<td>The public unique identifier of the queue.</td>
<td>No Validation</td>
<td>Not Required</td>
<td>Conditionally Required</td>
</tr>
</tbody>
</table>

You can view the Queue object along with all its child objects and attributes in the Manage Import Objects page of the Import Management flow. You can find attribute information like type, length, description, and so on, on this page.

### Create the Source CSV File
You include the data that you want to import into CX Sales and B2B Service in a source CSV file.
You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator > Tools > Import Management > Import Objects.
2. Select the Queue object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

**Note:** For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity

After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Queue from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
   - You would see that the source and target attributes are automatically mapped in the Map Fields page. Review and edit the mappings if required.
5. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
6. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results

Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed. You can drill down on the import activity to go to the Import Status page which provides the status details of the import activity.

**Related Topics**

- Potential Issues When Opening CSV Files in Excel
- How You Use Alternate Keys to Import Records
- Import Data

Import Your Queue Resource Data

You can use Import Management to create or update Queue Resource records.

To import Queue Resource records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes

To import your Queue Resource data into Oracle Applications Cloud, you need to populate a CSV file with your source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

- Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
- Ensure prerequisite setups are done, if applicable.
- Understand your options for uniquely identifying the records.
- Ensure parent records exist before importing child records.
- Identify the target object attributes that are required in the CSV file for a successful import.

Before You Start

You must do some basic checks before starting your import. For example, make sure that:

- You have completed all the prerequisites for importing each attribute in your source data.
- You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records

All records must be unique in the application. You can use one of these to identify records:

- Public unique identifiers: If you’re creating records, then you can provide an easily understandable public unique identifier. These are, usually, denoted with ‘Number’ and visible in the business object’s UI. PUID attributes are usually named `<object> Number`. If you’re updating a record with a Number attribute, then use the Number attribute to identify the record. For more information about public unique identifiers, see the topic “How You Use Alternate Keys to Import Records” in Related Topics section.
- Source system and source system reference: Source system is an identifier for the external system, and source system reference is a unique identifier within the external system. If you’re importing new queue resources or are updating queue resources that have source system reference data, then provide the source system and source system reference values.

Required Attributes and Validations for Queue Resource Object

To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure that you provide valid values for the attributes. This table lists the required attributes for importing new Queue Resource records, required attributes for updating Queue Resource records, prerequisite setup tasks for the attributes, and specific validations, if any, for Queue Resource import:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/Import Validations</th>
<th>Creating a Queue Resource Record</th>
<th>Updating an Existing Queue Resource Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>QueueResourceId</td>
<td>The unique identifier of the queue resource member.</td>
<td>No Validation</td>
<td>Not Required</td>
<td>Required</td>
</tr>
</tbody>
</table>
### Create the Source CSV File

You include the data that you want to import into CX Sales and B2B Service in a source CSV file. You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to **Navigator > Tools > Import Management > Import Objects**.
2. Select the **Queue Resource** object in the table and click **Download**.

You can now edit the downloaded file and provide valid values for the required attributes.

**Note:** For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.
Create the Import Activity

After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator > Tools > Import Management > Import Queue Resource.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Queue Resource from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
   You would see that the source and target attributes are automatically mapped in the Map Fields page. Review and edit the mappings if required.
5. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
6. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results

Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to Navigator > Tools > Import Management > Import Queue Resource.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed. You can drill down on the import activity to go to the Import Status page which provides the status details of the import activity.

Related Topics

- Potential Issues When Opening CSV Files in Excel
- How You Use Alternate Keys to Import Records
- Import Data

Import Your Queue Resource Team Data

You can use Import Management to create or update Queue Resource Team records.

To import Queue Resource Team records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes

To import your Queue Resource Team data into Oracle Applications Cloud, you need to populate a CSV file with your source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

- Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
• Ensure prerequisite setups are done, if applicable.
• Understand your options for uniquely identifying the records.
• Ensure parent records exist before importing child records.
• Identify the target object attributes that are required in the CSV file for a successful import.

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.
• You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
All records must be unique in the application. You can use one of these to identify records:

• Public unique identifiers: If you’re creating records, then you can provide an easily understandable public unique identifier. These are, usually, denoted with ‘Number’ and visible in the business object’s UI. PUID attributes are usually named <object> Number. If you’re updating a record with a Number attribute, then use the Number attribute to identify the record. For more information about public unique identifiers, see the topic "How You Use Alternate Keys to Import Records" in Related Topics section.

• Source system and source system reference: Source system is an identifier for the external system, and source system reference is a unique identifier within the external system. If you’re importing new queue resource teams or are updating queue resource teams that have source system reference data, then provide the source system and source system reference values.

Required Attributes and Validations for Queue Resource Team Object
To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure that you provide valid values for the attributes. This table lists the required attributes for importing new Queue Resource Team records, required attributes for updating Queue Resource Team records, prerequisite setup tasks for the attributes, and specific validations, if any, for Queue Resource Team import:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/Import Validations</th>
<th>Creating a Queue Resource Team Record</th>
<th>Updating an Existing Queue Resource Team Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>QueueResourceId</td>
<td>The unique identifier of the queue resource team.</td>
<td>No Validation</td>
<td>Not Required</td>
<td>Not Required</td>
</tr>
<tr>
<td>ObjectId</td>
<td>The unique identifier of the resource team added as a queue resource member.</td>
<td>The team should exist.</td>
<td>Conditionally Required Either the ObjectId or the TeamNumber is required.</td>
<td>Not Required</td>
</tr>
<tr>
<td>TeamNumber</td>
<td>The public unique identifier of the queue resource team.</td>
<td>The team should exist.</td>
<td>Conditionally Required Either the ObjectId or the TeamNumber is required.</td>
<td>Not Required</td>
</tr>
</tbody>
</table>
Import Your Data

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/ Import Validations</th>
<th>Creating a Queue Resource Team Record</th>
<th>Updating an Existing Queue Resource Team Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>QueueId</td>
<td>The unique identifier of the queue.</td>
<td>The queue should exist.</td>
<td>Conditionally Required</td>
<td>Not Required</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Either the QueueId or the QueueNumber is required.</td>
<td></td>
</tr>
<tr>
<td>QueueNumber</td>
<td>The public unique identifier of the queue to which the resource is associated.</td>
<td>The queue should exist.</td>
<td>Conditionally Required</td>
<td>Not Required</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Either the QueueId or the QueueNumber is required.</td>
<td></td>
</tr>
<tr>
<td>EnabledFlag</td>
<td>Contains the values, True or False. If True, then the queue resource member is enabled. If False, then the queue resource member isn't enabled. The default value is True.</td>
<td>No Validation</td>
<td>Not Required</td>
<td>Not Required</td>
</tr>
</tbody>
</table>

You can view the Queue Resource Team object along with all its child objects and attributes in the Manage Import Objects page of the Import Management flow. You can find attribute information like type, length, description, and so on, on this page.

Create the Source CSV File

You include the data that you want to import into CX Sales and B2B Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator > Tools > Import Management > Import Objects.
2. Select the Queue Resource Team object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

**Note:** For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity

After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator > Tools > Import Management > Import Queue Resource Team.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Queue Resource Team from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.

You would see that the source and target attributes are automatically mapped in the Map Fields page. Review and edit the mappings if required.
5. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
6. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to Navigator > Tools > Import Management > Import Queue Resource Team.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed. You can drill down on the import activity to go to the Import Status page which provides the status details of the import activity.

Related Topics
• Potential Issues When Opening CSV Files in Excel
• How You Use Alternate Keys to Import Records
• Import Data

Import Your Relationship Data
You can use the Import Management to create or update Relationship records.

You can import Relationship records using these steps:

1. Map your source relationship data to Oracle Applications Cloud object attributes. This way the import process would know where to insert each of the information bits.
2. Create the source CSV file with the relationship data you want to import.
4. Check the import results to know if the import went well.

How You Map Your Source Data to Target Object Attributes
To import your Relationship data into Oracle Applications Cloud, you must populate a .csv file with your source data and map that source data to target object attributes in Oracle Applications Cloud.

You must do the following before creating the .csv file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
• Ensure prerequisite steps are complete, such as understanding what attributes are required for importing your objects.
• Understand your options for uniquely identifying the records.
• Ensure parent records exist before importing child records.
• Identify the target object attributes that are required in the .csv file for a successful import.
Before You Start
You must do some basic checks before starting your import. For example, make sure that:

- You have completed all the prerequisites for importing each attribute in your source data.
- You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
All records must be unique in the application. You can use one of these to identify records:

- Public unique identifiers: If you’re creating records, then you can provide an easily understandable public unique identifier. These are, usually, denoted with ‘Number’ and visible in the business object’s UI. PUID attributes are usually named <object> Number. If you’re updating a record with a Number attribute, then use the Number attribute to identify the record. For more information about public unique identifiers, see the topic “How You Use Alternate Keys to Import Records” in Related Topics section.
- Source system and source system reference: Source system is an identifier for the external system, and source system reference is a unique identifier within the external system. If you’re importing new relationships or are updating relationships that have source system reference data, then provide the source system and source system reference values.

Required Attributes and Validations for Relationship Object
To import data successfully into Oracle Applications Cloud, your .csv file must include the required attributes. Ensure that you provide valid values for the attributes.

This table lists the required attributes for relationship records, prerequisite setup tasks and specific validations, if any:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/Import Validations</th>
<th>Creating a Relationship record</th>
<th>Updating an Existing Relationship record</th>
</tr>
</thead>
<tbody>
<tr>
<td>RelationshipRecId</td>
<td>The unique ID for the existing Relationship record in the destination table.</td>
<td>None</td>
<td>Don't provide a value.</td>
<td>Conditionally required</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Either the RelationshipRecId or a combination of RelationshipSourceSystem and RelationshipSourceSystemReferenceValue is required.</td>
</tr>
<tr>
<td>SubjectPartyId</td>
<td>The primary key identifier of the subject in this relationship.</td>
<td>The party must exist.</td>
<td></td>
<td>Optional</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Either one of SubjectPartyId, SubjectPartyNumber, and a combination of SubjectSourceSystem and SubjectSourceSystemReferenceValue is used to identify the subject party of the relationship.</td>
</tr>
<tr>
<td>Attribute</td>
<td>Description</td>
<td>Prerequisite Setup Task/Import Validations</td>
<td>Creating a Relationship record</td>
<td>Updating an Existing Relationship record</td>
</tr>
<tr>
<td>-----------------</td>
<td>------------------------------------------------------------------------------</td>
<td>-----------------------------------------------------------------------------------------------------------</td>
<td>-------------------------------</td>
<td>------------------------------------------</td>
</tr>
<tr>
<td>RelationshipType</td>
<td>The relationship type name. For example, CUSTOMER_SUPPLIER. A list of valid relationship types is defined in the lookup HZ_RELATIONSHIP_TYPE. The unique ID for the existing customer party record in the destination table.</td>
<td>The party must exist.</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td>RelationshipCode</td>
<td>Indicates whether this is a forward or a backward relationship code.</td>
<td>A list of valid relationship codes is defined in the lookup PARTY_RELATIONS_TYPE.</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td>StartDate</td>
<td>The date when the relationship was created.</td>
<td>This should be a valid date.</td>
<td>Optional</td>
<td>Not required</td>
</tr>
<tr>
<td>EndDate</td>
<td>The date when the relationship ends.</td>
<td>This should be a valid date.</td>
<td>Optional</td>
<td>Optional</td>
</tr>
<tr>
<td>SubjectType</td>
<td>Subject type of the relationship type.</td>
<td>This should be a valid party type.</td>
<td>Optional</td>
<td>Not required</td>
</tr>
<tr>
<td>ObjectType</td>
<td>Object type of the relationship type.</td>
<td>This should be a valid party type.</td>
<td>Optional</td>
<td>Not required</td>
</tr>
<tr>
<td>ObjectPartyId</td>
<td>The primary key identifier of the object in this relationship.</td>
<td>The party must exist.</td>
<td>Optional</td>
<td>Optional</td>
</tr>
<tr>
<td>SubjectPartyNumber</td>
<td>Unique identification number for the subject of relationship</td>
<td>No validation</td>
<td>Either the SubjectPartyId or the SubjectPartyNumber is required.</td>
<td>Either the SubjectPartyId or SubjectPartyNumber, or the combination of SubjectSourceSystem and SubjectSourceSystemReferenceValue is required.</td>
</tr>
<tr>
<td>ObjectPartyNumber</td>
<td>Unique identification number for the object of the relationship</td>
<td>The party must exist.</td>
<td>Either one of ObjectPartyId, ObjectPartyNumber, and combination of ObjectSourceSystem and ObjectSourceSystemReferenceValue is used to identify the object party of the relationship.</td>
<td>Optional</td>
</tr>
</tbody>
</table>
### Oracle CX
Understanding Import and Export Management for CX
Sales and B2B Service

#### Chapter 8
Import Your Data

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/ Import Validations</th>
<th>Creating a Relationship record</th>
<th>Updating an Existing Relationship record</th>
</tr>
</thead>
<tbody>
<tr>
<td>SubjectSourceSystem</td>
<td>Original System ID for the Subject of the Relationship</td>
<td>The source system should exist.</td>
<td>Conditionally required</td>
<td>Conditionally required</td>
</tr>
<tr>
<td></td>
<td></td>
<td>You can manage source systems from the Manage Source Systems task.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>SubjectSourceSystemReferenceValue</td>
<td>Original System Reference for the Subject of the Relationship</td>
<td>No validation</td>
<td>Conditionally Required</td>
<td>Conditionally Required</td>
</tr>
<tr>
<td></td>
<td></td>
<td>If the source of your data is a third party or external system, and you intend to import updates to previously imported records from the same system, provide the original source system and source system reference values.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>ObjectSourceSystem</td>
<td>Original System ID for the Object of the Relationship</td>
<td>No validation</td>
<td>Conditionally required</td>
<td>Conditionally required</td>
</tr>
<tr>
<td>ObjectSourceSystemReferenceValue</td>
<td>Original System Reference for the Object of the Relationship</td>
<td>No validation</td>
<td>Conditionally required</td>
<td>Conditionally required</td>
</tr>
<tr>
<td>RelationshipSourceSystem</td>
<td>Original system of this relationship</td>
<td>The party must exist.</td>
<td>Optional</td>
<td>Either the RelationshipRecId or a combination of RelationshipSourceSystem and RelationshipSourceSystemReferenceValue is required.</td>
</tr>
<tr>
<td>RelationshipSourceSystemReferenceValue</td>
<td>Original system reference of this relationship</td>
<td>It should be a unique value for a source system.</td>
<td>Optional</td>
<td>Either the RelationshipRecId or a combination of RelationshipSourceSystem and RelationshipSourceSystemReferenceValue is required.</td>
</tr>
</tbody>
</table>
Go to Navigator > Tools > Import Management > Import Objects, to see all the attributes of the relationship object. The page also lists attribute information like type, length, description, and so on.

Create the Source CSV File

You include the data that you want to import into CX Sales and B2B Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator > Tools > Import Management > Import Objects.
2. Select the Relationship object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

**Note:** For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity

After you have the CSV file ready, create an import activity to import the relationship information. To create an import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Relationship from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results

Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed. You can drill down on the import activity to go to the Import Status page which provides the status details of the import activity.

**Related Topics**

- Potential Issues When Opening CSV Files in Excel
- How You Use Alternate Keys to Import Records
- Import Data
Import Your Resolution Link Data

You can use the import functionality to create or update Resolution Link records.

To import Resolution Link records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (.csv) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes

To import your Resolution Link data into Oracle Applications Cloud, you need to populate a CSV file with your source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the .CSV file for data import:

- Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
- Ensure prerequisite steps are complete, such as understanding what attributes are required for importing your objects.
- Understand your options for uniquely identifying the records.
- Ensure parent records exist before importing child records.
- Identify the target object attributes that are required in the .CSV file for a successful import.

Before You Start

You must do some basic checks before starting your import. For example, make sure that:

- You have completed all the prerequisites for importing each attribute in your source data.
- You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records

To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the import process to uniquely identify the records. The file import process uses the attribute values to automatically map your source data to the target object attributes in Oracle Applications Cloud.

The preferred option to uniquely identifying an object record are as follows:

- Internal ID: If you’re identifying a record that already exists in Oracle Applications Cloud, then you can use the internal ID of the record, a system-generated unique identifier. Attributes with “id” in the attribute name are typically internal IDs. Use this option only if you’re updating Resolution Links. You can determine the internal ID of a record by exporting Oracle Applications Cloud object data, or by doing a transactional database query. Using an internal ID typically provides better performance and reduces the import duration. For the Resolution Link object, the attribute is LinkId.

- Public unique identifiers: If you’re creating new records, then you can provide a user-friendly public unique identifier (attributes denoted with ‘Number’ and usually visible in the business object’s UI). If you update a
record for which you have previously provided a Number attribute, or for which a Number attribute is visible in the object's UI, you can use the Number attribute to identify the record. For the Resolution Link object, the attribute is LinkNumber.

Required Attributes and Validations for Resolution Link Object

To import data successfully into Oracle Applications Cloud, your .CSV file must include the required attributes. Ensure that you provide valid values for the attributes.

This table lists the required attributes for importing new Resolution Link records, required attributes for updating Resolution Link records, prerequisite setup tasks for the attributes, and specific validations, if any, for Resolution Link import:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Data Type</th>
<th>Data Length</th>
<th>Prerequisite Setup Task/ Import Validations</th>
<th>Creating a Resolution Link Record</th>
<th>Updating an Existing Resolution Link Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>Link Number</td>
<td>The unique identifier of the link.</td>
<td>String</td>
<td></td>
<td>Optional</td>
<td>Optional</td>
<td>Required</td>
</tr>
<tr>
<td></td>
<td>If you don't provide a value, the LinkId is considered by default.</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Link Status</td>
<td>The status of a link. The list of accepted values are A (active) and I (inactive).</td>
<td>String</td>
<td></td>
<td>You can't create an inactive link</td>
<td>Optional</td>
<td>Optional Update the status to I to delete a link.</td>
</tr>
<tr>
<td>PartyType</td>
<td>The party type that defines whether the party is an organization, a person, a contact or any other user-defined party type.</td>
<td>String</td>
<td></td>
<td>No validation</td>
<td>Required</td>
<td>You can't update the resolution link.</td>
</tr>
</tbody>
</table>

You can view the Resolution Link object along with all its child objects and attributes in the Manage Import Objects page of the Import Management flow. You can find attribute information like type, length, description, and so on, on this page.

Create the Source CSV File

The .CSV file is provided as input to the file-based data import process. You must populate the .CSV file with the data you want to import into Oracle Applications Cloud.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator > Tools > Import Management > Import Objects.
2. Select the Resolution Link object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.
Note: For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity

To import data into Oracle Applications Cloud, you need to create an import activity and provide the CSV file as an input to the activity.

To create an import activity, do the following:

1. In the Navigator, under Tools, click Import Management.
2. On the Manage Imports page, click Create Import Activity.
3. In the Create Import Activity: Enter Import Options page, provide a name for the import activity, and select Resolution Link from the Object drop-down list.
4. In File Name, browse and upload the required .CSV file, and click Next.
5. In the Create Import Activity: Map Fields page edit the attribute mappings if required, and click Next.
6. Note: Click Validate Data to validate the mapping of the source file for unmapped columns and to check for data format issues.
7. In the Create Import Activity: Review and Submit page, click Submit.

Review the Import Results

You can review the import results by checking for the import activity in the Manage Import Activity page. A file import activity is said to be successful when its status displays as Completed. To check the status of the import activity, do as follows:

1. In the Navigator, under Tools, click Import Management.
2. On the Manage Imports page, search for the import activity that you created using one of the search criteria, such as status, name, object, and so on.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed. The other valid values for the import activity status are Queued for import, Preparing data for import, Importing data, Completed with errors, and Unsuccessful.

Note: On this page you can also quickly view the number and status of all active imports, completed imports, and unsuccessful imports that have been submitted.

Related Topics
- Potential Issues When Opening CSV Files in Excel
- Import Data

Import Your Resolution Link Member Data

You can use the import functionality to create or update Resolution Link Member records.
To import Resolution Link Member records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (.csv) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes

To import your Resolution Link Member data into Oracle Applications Cloud, you need to populate a CSV file with your source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the .CSV file for data import:

- Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
- Ensure prerequisite steps are complete, such as understanding what attributes are required for importing your objects.
- Understand your options for uniquely identifying the records.
- Ensure parent records exist before importing child records.
- Identify the target object attributes that are required in the .CSV file for a successful import.

Before You Start

You must do some basic checks before starting your import. For example, make sure that:

- You have completed all the prerequisites for importing each attribute in your source data.
- You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records

To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the import process to uniquely identify the records. The file import process uses the attribute values to automatically map your source data to the target object attributes in Oracle Applications Cloud.

The preferred option to uniquely identifying an object record is through the public unique identifier. If you’re creating new records, then you can provide a user-friendly public unique identifier (attributes denoted with ‘Number’ and usually visible in the business object’s UI). If you update a record for which you have previously provided a Number attribute, or for which a Number attribute is visible in the object’s UI, you can use the Number attribute to identify the record. For the Resolution Link Member object, the attributes are LinkNumber and PartyNumber.

Required Attributes and Validations for Resolution Link Member Object

To import data successfully into Oracle Applications Cloud, your .CSV file must include the required attributes. Ensure that you provide valid values for the attributes.

This table lists the required attributes for importing new Resolution Link records, required attributes for updating Resolution Link Member records, prerequisite setup tasks for the attributes, and specific validations, if any, for Resolution Link Member import:
### Attribute Table

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Data Type</th>
<th>Data Length</th>
<th>Prerequisite Setup Task/Import Validations</th>
<th>Creating a Resolution Link Member Record</th>
<th>Updating an Existing Resolution Link Member Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>Link Number</td>
<td>The unique identifier of the link.</td>
<td>String</td>
<td></td>
<td>No validation</td>
<td>Required</td>
<td>Required</td>
</tr>
<tr>
<td>PartyId</td>
<td>The unique internal identifier of a link member.</td>
<td>Long</td>
<td>18</td>
<td>Either the PartyId or the PartyNumber is required to uniquely identify the link member record with which the link is associated.</td>
<td>Conditionally Required</td>
<td>Don’t use when updating a resolution link member.</td>
</tr>
<tr>
<td>PartyNumber</td>
<td>The unique identifier of a link member.</td>
<td>String</td>
<td></td>
<td>No validation</td>
<td>Required</td>
<td>You can’t update the resolution link.</td>
</tr>
<tr>
<td>MemberStatus</td>
<td>The status of a link member. The list of accepted values are A (active) and I (inactive).</td>
<td>String</td>
<td></td>
<td>You can’t create an inactive link member.</td>
<td>Optional</td>
<td>Optional. Update to I to remove the link member.</td>
</tr>
<tr>
<td>MasterFlag</td>
<td>The master member of the link.</td>
<td>String</td>
<td></td>
<td>The accepted values are Y or N.</td>
<td>Required</td>
<td>Optional. Update to Y to change the master.</td>
</tr>
</tbody>
</table>

You can view the Resolution Link Member object along with all its child objects and attributes in the Manage Import Objects page of the Import Management flow. You can find attribute information like type, length, description, and so on, on this page.

### Create the Source CSV File

You include the data that you want to import into CX Sales and B2B Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to **Navigator > Tools > Import Management > Import Objects**.
2. Select the **Resolution Link Member** object in the table and click **Download**.

You can now edit the downloaded file and provide valid values for the required attributes.

**Note:** For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.
Create the Import Activity

To import data into Oracle Applications Cloud, you need to create an import activity and provide the CSV file as an input to the activity.

To create an import activity, do the following:

1. In the Navigator, under **Tools**, click **Import Management**.
2. On the **Manage Imports** page, click **Create Import Activity**.
3. In the **Create Import Activity: Enter Import Options** page, provide a name for the import activity, and select **Resolution Link Member** from the **Object** drop-down list.
4. In **File Name**, browse and upload the required .CSV file, and click **Next**.
5. In the **Create Import Activity: Map Fields** page edit the attribute mappings if required, and click **Next**.
   
   **Note:** Click **Validate Data** to validate the mapping of the source file for unmapped columns and to check for data format issues.

6. In the **Create Import Activity: Review and Submit** page, click **Submit**.

Review the Import Results

You can review the import results by checking for the import activity in the **Manage Import Activity** page. A file import activity is said to be successful when its status displays as **Completed**. To check the status of the import activity, do as follows:

1. In the Navigator, under **Tools**, click **Import Management**.
2. On the **Manage Imports** page, search for the import activity that you created using one of the search criteria, such as status, name, object, and so on.
3. Check the **Status** column for the import activity. The import is successful if the status displays as **Completed**. The other valid values for the import activity status are **Queued for import, Preparing data for import, Importing data, Completed with errors**, and **Unsuccessful**.

   **Note:** On this page you can also quickly view the number and status of all active imports, completed imports, and unsuccessful imports that have been submitted.

Related Topics

- Potential Issues When Opening CSV Files in Excel
- Import Data

Import Resource Data

Import Your Resource Data

You can use import management to create or update resource records.
To import resource records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Object Attributes

To import your resource data into Oracle Applications Cloud, you must populate a .csv file with your source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

- Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
- Ensure prerequisite setups are done, if applicable.
- Understand your options for uniquely identifying the records.
- Ensure parent records exist before importing child records.
- Identify the target object attributes that are required in the CSV file for a successful import.

Before You Start

You must do some basic checks before starting your import. For example:

- Complete all the prerequisites for importing each attribute in your source data.
- Have all parent records in place before importing child records.
- Use the Manage Business Unit task to set up appropriate business units.
- Use the Manage Legal Entity task to set up appropriate legal entities.
- Use the Manage Resource Roles task to define resource roles. Sales Administrator role is required to load the resource data.

Select a Unique Identifier for Your Records

To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the import process to uniquely identify the records. The file import process uses the attribute values to automatically map your source data to the target object attributes in Oracle Applications Cloud.

The preferred option to uniquely identify an object record is through the public unique identifier. If you're creating new records, then you can provide a user-friendly public unique identifier (Party Number). If you update a record for which you have previously provided a Number attribute, or for which a Number attribute is visible in the object's UI, you can use the Number attribute to identify the record. For the resource object, the attribute is ResourcePartyNumber.

Required Attributes and Validations for the Resource Object

To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure that you provide valid values for the attributes. When you create a new resource, associated employee records are also created. For more information about creating resources for existing employee records, see the topic "Example of Adding Resource Profile to Existing Employees". The following table lists the required attributes for importing new resource records, required attributes for updating resource records, prerequisite setup tasks for the attributes, and specific validations, if any, for resource import:
<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/Import Validations</th>
<th>Creating a Resource Record</th>
<th>Updating an Existing Resource Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>FirstName</td>
<td>The first name of the resource.</td>
<td>No validation</td>
<td>Required</td>
<td>Pass the party number as the key.</td>
</tr>
<tr>
<td>LastName</td>
<td>The last name of the resource.</td>
<td>No validation</td>
<td>Required</td>
<td>Pass the party number as the key.</td>
</tr>
<tr>
<td>BusinessUnit</td>
<td>The name of the business unit associated with the resource.</td>
<td>It should be a valid existing value.</td>
<td>Required</td>
<td>Not updatable</td>
</tr>
<tr>
<td>LegalEntity</td>
<td>The name of the legal entity associated with the resource.</td>
<td>It should be a valid existing value.</td>
<td>Required</td>
<td>Not updatable</td>
</tr>
<tr>
<td>ResourcePartyNumber</td>
<td>The public unique identifier (PUID) of the resource party.</td>
<td>This should be unique.</td>
<td>Conditionally required</td>
<td>Required</td>
</tr>
<tr>
<td></td>
<td>This is also known as Registry Id.</td>
<td></td>
<td>This is auto-generated.</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>However, you can provide</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>a value to replace the auto-</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>generated value when</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>creating the resource</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>record.</td>
<td></td>
</tr>
<tr>
<td>ResourceEmail</td>
<td>The email address of the resource</td>
<td>The email address must be unique.</td>
<td>Required</td>
<td>Pass the party number as the key.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Specify the email Id when creating the</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>resource.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>IndividualRoleCode</td>
<td>The code that represents the resource role assigned to the resource.</td>
<td>A resource can have only one individual</td>
<td>Conditionally required</td>
<td>Pass the party number as the key.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>role code assigned for a given date range.</td>
<td>A value is required when</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>You define and review resource role</td>
<td>creating a standalone</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>types and codes using the Manage Resource</td>
<td>resource.</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>Roles task.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Username</td>
<td>The user account name of the resource used to login to the application.</td>
<td>The user name has to be unique.</td>
<td>Optional</td>
<td>Not Updatable</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>ResourceOrgRoleCode</td>
<td>The code indicating the role of the resource in association with organization</td>
<td>One organization membership role is</td>
<td>Conditionally required</td>
<td>Pass the party number as the key.</td>
</tr>
<tr>
<td></td>
<td>membership. For example, SALES_REPRESENTATIVE, SALES_MANAGER, and so on.</td>
<td>allowed for a given date range.</td>
<td>A value is required when</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>creating a resource as a</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>part of the resource</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>hierarchy.</td>
<td></td>
</tr>
<tr>
<td>RawWorkPhoneNumber</td>
<td>The work phone number of the resource</td>
<td>No validation</td>
<td>Optional</td>
<td>Optional</td>
</tr>
</tbody>
</table>
### Import Your Data

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/Import Validations</th>
<th>Creating a Resource Record</th>
<th>Updating an Existing Resource Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>WorkPhoneCountryCode</td>
<td>The work phone country code of the resource</td>
<td>Enter a value when you specify the RawWorkPhoneNumber.</td>
<td>Conditionally required</td>
<td>Conditionally required</td>
</tr>
<tr>
<td></td>
<td></td>
<td><strong>Note:</strong> When providing a value for the RawWorkPhoneNumber, ensure that you also provide a value for the WorkPhoneCountryCode. If you don't enter a valid WorkPhoneCountryCode, the format of the RawWorkPhoneNumber will be inaccurate.</td>
<td>A value is required when you provide the RawWorkPhoneNumber.</td>
<td>A value is required when you provide the RawWorkPhoneNumber.</td>
</tr>
<tr>
<td>RawMobilePhoneNumber</td>
<td>The mobile phone number of the resource</td>
<td>No validation</td>
<td>Optional</td>
<td>Optional</td>
</tr>
<tr>
<td>MobilePhoneCountryCode</td>
<td>The mobile phone country code of the resource</td>
<td>Enter a value when you specify the RawMobilePhoneNumber.</td>
<td>Conditionally required</td>
<td>Conditionally required</td>
</tr>
<tr>
<td></td>
<td></td>
<td>A value is required when you provide the RawMobilePhoneNumber.</td>
<td></td>
<td>A value is required when you provide the RawMobilePhoneNumber.</td>
</tr>
<tr>
<td>RawFaxNumber</td>
<td>The fax number of the resource</td>
<td>No validation</td>
<td>Optional</td>
<td>Optional</td>
</tr>
<tr>
<td>FaxCountryCode</td>
<td>The fax country code of the resource</td>
<td>Enter a value when you specify the RawFaxNumber.</td>
<td>Conditionally required</td>
<td>Conditionally required</td>
</tr>
<tr>
<td></td>
<td></td>
<td>A value is required when you provide the RawFaxNumber.</td>
<td></td>
<td>A value is required when you provide the RawFaxNumber.</td>
</tr>
</tbody>
</table>

You can view the resource object and attributes in the Manage Import Objects page of the Import Management flow. You can find attribute information like type, length, description, and so on, on this page.

The following role codes are now available in Import Management.

- **ResourceOrgRoleCode** - Specifies the role that the resource plays as part of the hierarchy in the organization.
- **IndividualRoleCode** - Specifies the role assigned to the individual resources. You can also assign additional roles to the resource in the hierarchy to provide additional privileges to the resource.

You should not use a Resource Users import in Import Management or REST on an environment with full blown HCM Services implementation. In such cases, Import Management or REST must be used only to convert existing HR workers as resources. This is because, Resource Users REST API only supports vary basic attributes of the HR person/worker. It doesn't support Oracle Human Capital Management (HCM) custom attributes defined on HR Person/Worker.
Note: Note the following:

- To identify a party number for a resource, you may use File Export, Resource User REST, or resource directory
  user interface.

  For more information about exporting data, see the topic "Export Data" in the "Related Topics" section.

- In File-based Data Import, resource can be imported to load (create/update) HR workers (Employees
  and Contingent Workers) without any resource related attributes. However, this isn't possible in Import
  Management.

- You can't create a standalone worker using this feature. To create a standalone worker, use the HCM Data
  Loader. For more information about creating a standalone worker, see the Oracle Global Human Resources
  Cloud Getting Started with Your HR Implementation guide.

- You can speed up import of up to 5,000 records at a time by using Microsoft Excel macros provided by Oracle.
  The macros validate your data entries, provide lists of values, and automatically populate constant values. After
  you enter your data, click a button in the macro to import data. Download the Excel macros from the Oracle CX
  Sales: Getting Started with Your Sales Implementation: Import Macros (Document ID 2229503.1) article on My
  Oracle Support.

- Loading of only worker attributes isn't supported.

- Resource Team memberships aren't supported.

- Automatic re-parenting of the child organizations or direct employees when a manager leaves the resource
  organization isn't supported.

Note: Move all reporting resources and child organizations to a different organization, when the organization

membership of the current manager is ended either due to the movement of the manager to a different organization

or the termination of the manager.

Create the Source CSV File

You include the data that you want to import into CX Sales and B2B Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator > Tools > Import Management > Import Objects.
2. Select the Resource object in the table and click Download.
You can now edit the downloaded file and provide valid values for the required attributes.

**Note:** For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.

### Create the Import Activity

After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to **Navigator > Tools > Import Management > Import Queue.**
2. Click **Create Import Activity** in the **Manage Imports** page.
3. In the **Enter Import Options** page, provide a name for the import activity, and select Resource from the **Object** drop-down list.
4. Select the CSV file in the **File Name** field, and click **Next**.
5. The source and target attributes are automatically mapped in the **Map Fields** page. Review and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking **Validate Data**. Click **Next**.
7. Review the import details on the **Review and Submit** page, and click **Submit** when you're ready.

### Review the Import Results

Check if your import succeeded on the **Manage Imports** page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to **Navigator > Tools > Import Management > Import Queue.**
2. Click All Imports and search for the import activity that you created earlier.
3. Check the **Status** column for the import activity. The import is successful if the status displays as **Completed**. You can drill down on the import activity to go to the **Import Status** page which provides the status details of the import activity.

You must run the following scheduled processes after creating or updating a resource:

1. **Reporting Hierarchy Generation:** This job updates the reporting hierarchy in accordance with the changes in internal resource hierarchy. The resource's reporting manager isn't updated unless you run this scheduled process. Run this scheduled process after you make any changes to the hierarchy such as changing the manager or the organization.

   For more information about the **Reporting Hierarchy Generation** scheduled process, see the section "Reporting Hierarchy Generation" in the **Understanding Scheduled Processes** guide.

2. **Update Person Search Keywords:** The After Batch Load parameter should be set to Y before you run the update person search keywords schedule process. If you run this scheduled process, you can search the person in the Manage Users UI. The application searches for keyword values in these attributes of a person's records such as person name, user name, primary email, primary phone, work location, and so on. Run this scheduled process when you create a new resource.

   For more information about updating person search keywords, see the section "How You Update Person Search Keywords" in the **Oracle Talent Management Cloud Implementing Talent Management Base** guide.

3. **Send Pending LDAP Requests:** This job processes the pending LDAP requests to provision the user accounts and roles. You can specify the parameters User Type and Batch Size with this job. You must specify User Type (usually select All); if you leave it as blank, then this process won't process any requests. If you don't set Batch Size, the default will be A for automatic, which is 1/10th of the total requests number. You can specify a number for batch size to instruct the process to group that number of requests together for single batch process. If you
want the process to pick up the FAULTED requests from previous run, you can set Batch Size as AF. Run this scheduled process when you create a new resource along with the user account.

4. Synchronize User GUID: This job synchronizes the user GUID of users including employees and contingent workers.

For more information about the Synchronize User GUID scheduled process, see the section "Synchronize User GUID" in the Understanding Scheduled Processes guide.

Related Topics
- Export Data
- Import Data

Example of Creating a Standalone Resource

You can import resource data from an external data source into CX Sales and B2B Service using Import Management. You must create or import resources before you can associate them with resource organizations.

Before You Begin

The scenario in this example assumes that the following prerequisites have already been set up.

1. Employees must exist in the application.
2. User accounts and email IDs are set up for the already existing employees.
3. Appropriate business units are set up using the Manage Business Unit task.

To find the business unit, navigate to the following in the Setup and Maintenance work area:
- Offering: Sales
- Function Area: Data Import and Export
- Task: Manage Business Units

4. Appropriate legal entities are set up using the Manage Legal Entities task.

To find the legal entity, navigate to the following in the Setup and Maintenance work area:
- Offering: Sales
- Function Area: Data Import and Export
- Task: Manage Legal Entities

Scenario

In this scenario, Lina John is created as a SALES_REPRESENTATIVE. You must create a source file (CSV) with the attributes and import it using import management as shown in this table.

<table>
<thead>
<tr>
<th>Attribute Name</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>FirstName</td>
<td>Lina</td>
</tr>
</tbody>
</table>
Understanding Import and Export Management for CX Sales and B2B Service

Chapter 8
Import Your Data

Attribute Name | Value
--- | ---
LastName | John
UserName | LINA.JOHN@VISION.COM
ResourceEmail | lina.john@vision.com
BusinessUnit | Vision Corporation Enterprise
LegalEntity | Vision Corporation
IndividualRoleCode | SALES_REPRESENTATIVE

Note: To create a Sales Manager, specify SALES_MANAGER for the Individual Role Code attribute.

You can import the source data file.

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Resource from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. The source and target attributes are automatically mapped in the Map Fields page. Review and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.

Note: Validation errors, if any, are displayed on the Mapping Validation screen. If you get warnings about unmapped columns, then you can ignore these columns and proceed to submit the import job. Validations are for informational purposes and applicable only for low-volume imports.

7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Example of Creating a Sales Representative in a Resource Organization

You can use import management to create resources as a sales representative and add them to the resource hierarchy. You need to specify additional information such as ResourceManagerEmail or ResourceParentOrganizationName to create a sales representative as a standalone resource.

Before You Begin
The scenario in this example assumes that the following prerequisites have already been set up.

1. Appropriate business units are set up using the Manage Business Unit task.
2. Appropriate legal entities are set up using the Manage Legal Entity task.
3. Email Ids and user names should be unique.

Scenario

In this scenario, Bob Frank is created as a resource with the role SALES_REPRESENTATIVE. You must create a source file (CSV) with the attributes and import it using import management as shown in this table.

<table>
<thead>
<tr>
<th>Attribute Name</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>FirstName</td>
<td>Bob</td>
</tr>
<tr>
<td>LastName</td>
<td>Frank</td>
</tr>
<tr>
<td>UserName</td>
<td><a href="mailto:BOB.FRANK@VISION.COM">BOB.FRANK@VISION.COM</a></td>
</tr>
<tr>
<td>ResourceEmail</td>
<td><a href="mailto:bob.frank@vision.com">bob.frank@vision.com</a></td>
</tr>
<tr>
<td>BusinessUnit</td>
<td>Vision Corporation Enterprise</td>
</tr>
<tr>
<td>LegalEntity</td>
<td>Vision Corporation</td>
</tr>
<tr>
<td>ResourceOrgRoleCode</td>
<td>SALES_REPRESENTATIVE</td>
</tr>
<tr>
<td>ResourceManagerEmail</td>
<td><a href="mailto:charlotte.edwards@vision.com">charlotte.edwards@vision.com</a></td>
</tr>
<tr>
<td>ResourceParentOrganizationName</td>
<td>Global HQ</td>
</tr>
</tbody>
</table>

**Note:** Providing the user name is optional. If you don't provide the user name, the application will generate the user name by default. Provide values either for the ResourceManagerEmail or the ResourceParentOrganizationName attribute. If neither of these is provided, then the resource is associated with the root resource organization as parent organization.

When you're creating a new resource user, the CreateUserAccountFlag controls the user account creation for the resource. The default value for CreateUserAccountFlag is Y. If you don't want the user account to be created, then you can set the attribute CreateUserAccountFlag to 'N'.

You can import the source data file.

1. Go to **Navigator > Tools > Import Management > Import Queue.**
2. Click **Create Import Activity** in the **Manage Imports** page.
3. In the **Enter Import Options** page, provide a name for the import activity, and select Resource from the **Object** drop-down list.
4. Select the CSV file in the **File Name** field, and click **Next.**
5. The source and target attributes are automatically mapped in the **Map Fields** page. Review and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking **Validate Data.** Click **Next.**
Note: Validation errors, if any, are displayed on the Mapping Validation screen. If you get warnings about unmapped columns, then you can ignore these columns and proceed to submit the import job. Validations are for informational purposes and applicable only for low-volume imports.

7. Review the import details on the Review and Submit page, and click Submit when you’re ready.

To enable or disable notifications for resources, see the section Set Up Event Notifications for Resources in the topic Import Data.

You must run the following scheduled processes after creating the sales representative in the resource organization:

1. Reporting Hierarchy Generation: This job re-generates the resource reporting hierarchy when there is a change in the organization hierarchy. For more information about the Reporting Hierarchy Generation scheduled process, see the section "Reporting Hierarchy Generation" in the Understanding Scheduled Processes guide.

2. Send Pending LDAP Requests: This job processes the pending LDAP requests to provision the user accounts and roles. You can specify the parameters User Type and Batch Size with this job. You must specify User Type (usually select All); if you leave it as blank, then this process won’t process any requests. If you don’t set Batch Size, the default will be A for automatic, which is 1/10th of the total requests number. You can specify a number for batch size to instruct the process to group that number of requests together for single batch process. If you want the process to pick up the FAUL TED requests from previous run, you can set Batch Size as AF. Run this scheduled process when you create a new resource along with the user account.

Related Topics
- Import Data

Example of Creating a Sales Manager in an Existing or New Resource Organization

In this example, you create a sales manager using import management and add them to the resource hierarchy. You can create a new organization or use an existing organization which doesn't have a manager.

Before You Begin

The scenario in this example assumes that the following prerequisites have already been set up.

1. User accounts and e-mail IDs should be unique.
2. Appropriate business units are set up using the Manage Business Unit task.
   - To find the business unit, navigate to the following in the Setup and Maintenance work area:
     - Offering: Sales
     - Function Area: Data Import and Export
     - Task: Manage Business Units
3. Appropriate legal entities are set up using the Manage Legal Entities task.
   - To find the legal entity, navigate to the following in the Setup and Maintenance work area:
     - Offering: Sales
     - Function Area: Data Import and Export
- Task: Manage Legal Entities

Scenario

In this scenario, you create Tom Johnson as a manager of the resource organization North American Sales in the resource parent organization Global HQ. He is created as a resource with the role of SALES_MANAGER. You must create a source file (CSV) with the attributes and import it using import management as shown in this table.

<table>
<thead>
<tr>
<th>Attribute Name</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>FirstName</td>
<td>Tom</td>
</tr>
<tr>
<td>LastName</td>
<td>Johnson</td>
</tr>
<tr>
<td>UserName</td>
<td><a href="mailto:TOM.JOHNSON@VISION.COM">TOM.JOHNSON@VISION.COM</a></td>
</tr>
<tr>
<td>Email</td>
<td><a href="mailto:tom.johnson@vision.com">tom.johnson@vision.com</a></td>
</tr>
<tr>
<td>BusinessUnit</td>
<td>Vision Corporation Enterprise</td>
</tr>
<tr>
<td>LegalEntity</td>
<td>Vision Corporation</td>
</tr>
<tr>
<td>ResourceOrgRoleCode</td>
<td>SALES_MANAGER</td>
</tr>
<tr>
<td>ResourceParentOrganizationName</td>
<td>Global HQ</td>
</tr>
<tr>
<td>ResourceOrganizationName</td>
<td>North American Sales</td>
</tr>
</tbody>
</table>

**Note:** Providing the user name is optional. If you don't provide the user name, the application will generate the user name by default. Provide values either for the ResourceManagerEmail or the ResourceParentOrganizationName attribute. If neither of these is provided, then the resource is associated with the root resource organization as parent organization.

The following figure shows the resource Tom Johnson created as a sales manager in the hierarchy.
To create a top resource in an existing resource organization, you must use the TopResourceFlag attribute in import management and REST services. This attribute indicates that the resource is a top resource, and is used by the Sales Setup Assistant.

You can import the source data file.

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Resource from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. The source and target attributes are automatically mapped in the Map Fields page. Review and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
Chapter 8
Import Your Data

Note: Validation errors, if any, are displayed on the Mapping Validation screen. If you get warnings about unmapped columns, then you can ignore these columns and proceed to submit the import job. Validations are for informational purposes and applicable only for low-volume imports.

7. Review the import details on the Review and Submit page, and click Submit when you're ready.

You must run the following scheduled processes after creating the sales manager:

1. Reporting Hierarchy Generation: This job re-generates the resource reporting hierarchy when there is a change in the organization hierarchy. For more information about the Reporting Hierarchy Generation scheduled process see the section "Reporting Hierarchy Generation" in the Understanding Scheduled Processes guide.
2. Send Pending LDAP Requests: This job processes the pending LDAP requests to provision the user accounts and roles. You can specify the parameters User Type and Batch Size with this job. You must specify User Type (usually select All); if you leave it as blank, then this process won't process any requests. If you don't set Batch Size, the default will be A for automatic, which is 1/10th of the total requests number. You can specify a number for batch size to instruct the process to group that number of requests together for single batch process. If you want the process to pick up the FAULTED requests from previous run, you can set Batch Size as AF. Run this scheduled process when you create a new resource along with the user account.

Examples of Adding a Resource to Existing Employees

You can add a resource to existing employees using import management. You can identify specific employees or contingent workers in Oracle Human Capital Management (HCM) as resources in CX Sales and B2B Service.

You can specify details about a resource using the Resource target import object. This target object saves information about a resource and allows import of the resource's information, such as resource organization membership and user account details. After you have identified these new resources, you can assign them to organizations and teams, as needed.

Scenario

Tory Griffiet is an employee in Oracle Human Capital Management (HCM) and doesn't have any associated resource information.

In this scenario, Troy Griffiet who's an employee in Oracle Human Capital Management (HCM) is identified to be a resource in CX Sales and B2B Service. Troy is converted to a SALES_REPRESENTATIVE under Ross Hayes. The reporting hierarchy and organization details of Ross Hayes before Troy Griffiet is moved under him are as shown in this image:

To identify Troy as a resource in CX Sales and B2B Service, you must create a source file (CSV) file with the attributes and import it using import management as shown in this table.
You can import the source data file.

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Resource from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. The source and target attributes are automatically mapped in the Map Fields page. Review and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.

   **Note:** Validation errors, if any, are displayed on the Mapping Validation screen. If you get warnings about unmapped columns, then you can ignore these columns and proceed to submit the import job. Validations are for informational purposes and applicable only for low-volume imports.

7. Review the import details on the Review and Submit page, and click Submit when you're ready.

You run the scheduled process Reporting Hierarchy Generation to re-generate the resource reporting hierarchy when there is a change in the organization hierarchy. For more information about the Reporting Hierarchy Generation scheduled process, see the section "Reporting Hierarchy Generation" in the Understanding Scheduled Processes guide.

Tory Griffiet is now converted from an employee in HCM to a resource in CX Sales and B2B Service and all the resource information is populated.

The reporting hierarchy and organization details of Ross Hayes after Troy has been moved under him are shown in this image:

![Reporting Manager Hierarchy: VPSales2_OrgAug](image)

**Scenario**

You can convert an employee to a manager resource and add that employee to the hierarchy. You must create a source CSV file with the attributes and import it using file-based import, as shown in this table.

<table>
<thead>
<tr>
<th>Attribute Name</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>ResourcePartyNumber</td>
<td>Conta765976</td>
</tr>
<tr>
<td>ResourceOrgRoleCode</td>
<td>SALES_REPRESENTATIVE</td>
</tr>
<tr>
<td>ResourceParentOrganizationName</td>
<td>VPSales2_OrgAug</td>
</tr>
</tbody>
</table>
### Scenario

You can convert a resource without adding it to the hierarchy. You must create a source CSV file with the attributes and import it using file-based import, as shown in this table.

<table>
<thead>
<tr>
<th>Attribute Name</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>ResourcePartyNumber</td>
<td>Conta765976</td>
</tr>
<tr>
<td>ResourceOrgRoleCode</td>
<td>SALES_MANAGER</td>
</tr>
<tr>
<td>ResourceOrganizationName</td>
<td>JSmithOrg</td>
</tr>
<tr>
<td>ResourceParentOrganizationName</td>
<td>Global HQ</td>
</tr>
</tbody>
</table>

### Examples of Changing a Resource from Manager to a Non-Manager Role

You can make role-change related updates to a resource by changing the resource information such as resource role code and resource role type code. Before you change a manager to a non-manager role, move the employees reporting to this manager to a different manager.

These scenarios illustrate the various role-change related updates you can make to a resource.

- Sales Manager changed to Sales Representative under the same manager.
- Sales Manager changed to Sales Representative under a different manager.

### Sales Manager Changed to Sales Representative under the Same Manager

Geriant Jones is a Sales Manager reporting to Charlotte Edwards. The reporting hierarchy and organization details of Geriant Jones are as shown in this image:
In this scenario, Geriant’s role is changed to Sales Representative under Charlotte Edwards, without any change in the reporting hierarchy. Move employees reporting to Geriant Jones to Geriant Jones' parent organization. In this example, move Ed Joyce under Charlotte Edwards as salesperson before demoting Geriant Jones.

To change Geriant Jones' role to Sales Representative, you must create a source file (CSV) with the attributes listed in this table and import it using import management. You can use either ResourceParentOrganizationName or ResourceManagerEmail for Organization or Manager-related changes.

<table>
<thead>
<tr>
<th>Attribute Name</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>ResourcePartyNumber</td>
<td>conta765976</td>
</tr>
<tr>
<td>ResourceManagerEmail</td>
<td><a href="mailto:charlotte.edwards@vision.com">charlotte.edwards@vision.com</a></td>
</tr>
<tr>
<td>ResourceOrgRoleCode</td>
<td>SALES_REPRESENTATIVE</td>
</tr>
<tr>
<td>ResourceParentOrganizationName</td>
<td>SVP2VisionCorpEntSales_Org</td>
</tr>
</tbody>
</table>

You can import the source data file.

1. Go to **Navigator > Tools > Import Management > Import Queue**.
2. Click **Create Import Activity** in the **Manage Imports** page.
3. In the **Enter Import Options** page, provide a name for the import activity, and select Resource from the **Object** drop-down list.
4. Select the CSV file in the **File Name** field, and click **Next**.
5. The source and target attributes are automatically mapped in the **Map Fields** page. Review and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking **Validate Data**. Click **Next**.

   **Note:** Validation errors, if any, are displayed on the Mapping Validation screen. If you get warnings about unmapped columns, then you can ignore these columns and proceed to submit the import job. Validations are for informational purposes and applicable only for low-volume imports.

7. Review the import details on the **Review and Submit** page, and click **Submit** when you’re ready.

After your import runs successfully, send the pending LDAP user update requests:

1. In the Navigator, click **Scheduled Processes**.
2. In the Scheduled Processes page, click **Schedule New Process**.
3. In the Schedule New Process dialog box, from the Name drop-down list, search for Send Pending LDAP Requests.
4. From the search results, select Send Pending LDAP Requests and click OK.
5. In the Process Details dialog box, click Submit.
6. In the Confirmation dialog box, click OK.
7. Click Close.
8. In the Scheduled Processes page, click the Refresh icon.
9. Verify if the status of the process has completed successfully.

You run the scheduled process Reporting Hierarchy Generation to re-generate the resource reporting hierarchy when there is a change in the organization hierarchy. For more information about the Reporting Hierarchy Generation scheduled process see the section "Reporting Hierarchy Generation" in the Understanding Scheduled Processes guide.

The reporting hierarchy and organization details of Geriant Jones after his role has been changed from SALES_MANAGER to SALES_REPRESENTATIVE are as follows:

**Note:** The sales representatives reporting to the manager being demoted should be moved under their manager's manager or another manager. In this scenario, Ed Joyce who was reporting to Geriant should be moved under Charlotte Edwards who was Edward's manager, as shown in this image.

Sales Manager Changed to Sales Representative under a Different Manager

Darren Gough is a Sales Manager reporting to Andrew Flintoff. The reporting hierarchy and organization details of Darren Gough are as shown in this image:

In this scenario, Darren's role is changed to a Sales Representative and would be reporting to Charlotte Edwards, a different manager. To change role of Darren Gough from Sales Manager to Sales Representative under Charlotte
Edwards, you must create a source file (CSV) with the attributes listed in the following table and import it using import management. You can use either ResourceParentOrganizationName or ResourceManagerEmail for Organization or Manager-related changes.

<table>
<thead>
<tr>
<th>Attribute Name</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>ResourcePartyNumber</td>
<td>Conta765976</td>
</tr>
<tr>
<td>ResourceOrgManagerEmail</td>
<td><a href="mailto:charlotte.edwards@vision.com">charlotte.edwards@vision.com</a></td>
</tr>
<tr>
<td>ResourceOrgRoleCode</td>
<td>SALES_REPRESENTATIVE</td>
</tr>
<tr>
<td>ResourceParentOrganizationName</td>
<td>SVP2VisionCorpEntSales_Org</td>
</tr>
</tbody>
</table>

You can import the source data file

1. Go to **Navigator > Tools > Import Management > Import Queue**.
2. Click **Create Import Activity** in the **Manage Imports** page.
3. In the **Enter Import Options** page, provide a name for the import activity, and select Resource from the **Object** drop-down list.
4. Select the CSV file in the **File Name** field, and click **Next**.
5. The source and target attributes are automatically mapped in the **Map Fields** page. Review and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking **Validate Data**. Click **Next**.

**Note:** Validation errors, if any, are displayed on the Mapping Validation screen. If you get warnings about unmapped columns, then you can ignore these columns and proceed to submit the import job. Validations are for informational purposes and applicable only for low-volume imports.

7. Review the import details on the **Review and Submit** page, and click **Submit** when you’re ready.

After your import runs successfully, send the pending LDAP user update requests:

1. In the Navigator, click **Scheduled Processes**.
2. In the Scheduled Processes page, click **Schedule New Process**.
3. In the Schedule New Process dialog box, from the **Name** drop-down list, search for Send Pending LDAP Requests.
4. From the search results, select **Send Pending LDAP Requests** and click **OK**.
5. In the Process Details dialog box, click **Submit**.
6. In the Confirmation dialog box, click **OK**.
7. Click **Close**.
8. In the Scheduled Processes page, click the **Refresh** icon.
9. Verify if the status of the process has completed successfully.

You run the scheduled process **Reporting Hierarchy Generation** to re-generate the resource reporting hierarchy when there is a change in the organization hierarchy. For more information about the **Reporting Hierarchy Generation** scheduled process, see the section "Reporting Hierarchy Generation" in the **Understanding Scheduled Processes** guide.
Before demoting the manager, the sales representatives reporting to the manager being demoted should be moved under their manager’s manager or another manager. In this scenario, before Darren's demotion to a different manager, Rosalie Birch who was reporting to Darren should be moved under Andrew Flintoff who was Darren's manager as shown in this image.

The reporting hierarchy and organization details of Darren Gough after his role has been changed from SALES_MANAGER to SALES_REPRESENTATIVE under Charlotte Edwards are as follows:

---

**Examples of Changing a Resource from Non-Manager to a Manager Role**

You can make role-change related updates to a resource by changing the resource information such as resource role code and resource role type code. The scenarios herein illustrate the different role-change related updates you can make to a resource.

- Sales Representative role changed to Sales Manager under the same manager
- Sales Representative role changed to Sales Manager under a different manager

**Sales Representative Role Changed to Sales Manager under the Same Manager**

Shea Lynn is a Sales Representative reporting to Braun Travis. The reporting hierarchy and organization details of Shea Lynn are as shown in this image:
In this scenario, Shea’s role is changed to a Sales Manager reporting to Braun Travis, without any change in the reporting hierarchy. To change the role of Shea Lynn to Sales Manager, you must create a source file (CSV) with the attributes and import it, as explained in this table.

<table>
<thead>
<tr>
<th>Attribute Name</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>ResourcePartyNumber</td>
<td>Conta504976</td>
</tr>
<tr>
<td>ResourceOrgRoleCode</td>
<td>SALES_MANAGER</td>
</tr>
<tr>
<td>ResourceOrganization</td>
<td>Mgr4Vision_Org</td>
</tr>
<tr>
<td>ResourceParentOrganizationName</td>
<td>Mgr1Vision_Org</td>
</tr>
</tbody>
</table>

You can import the source data file.

1. Go to **Navigator > Tools > Import Management > Import Queue**.
2. Click **Create Import Activity** in the **Manage Imports** page.
3. In the **Enter Import Options** page, provide a name for the import activity, and select Resource from the **Object** drop-down list.
4. Select the CSV file in the **File Name** field, and click **Next**.
5. The source and target attributes are automatically mapped in the **Map Fields** page. Review and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking **Validate Data**. Click **Next**.

   **Note:** Validation errors, if any, are displayed on the Mapping Validation screen. If you get warnings about unmapped columns, then you can ignore these columns and proceed to submit the import job. Validations are for informational purposes and applicable only for low-volume imports.

7. Review the import details on the **Review and Submit** page, and click **Submit** when you’re ready.

You run the scheduled process **Reporting Hierarchy Generation** to re-generate the resource reporting hierarchy when there is a change in the organization hierarchy. For more information about the **Reporting Hierarchy Generation** scheduled process, see the section “Reporting Hierarchy Generation” in the **Understanding Scheduled Processes** guide.

After your import runs successfully, send the pending LDAP user update requests:

1. In the Navigator, click **Scheduled Processes**.
2. In the Scheduled Processes page, click **Schedule New Process**.
3. In the Schedule New Process dialog box, from the **Name** drop-down list, search for **Send Pending LDAP Requests**.
4. From the search results, select **Send Pending LDAP Requests** and click **OK**.
5. In the Process Details dialog box, click **Submit**.
6. In the Confirmation dialog box, click **OK**.
7. Click **Close**.
8. In the Scheduled Processes page, click the **Refresh** icon.
9. Verify if the status of the process has completed successfully.

The reporting hierarchy and organization details of Shea Lynn after her role has been changed from **SALES_REPRESENTATIVE** to **SALES_MANAGER** as shown in this image:

![Reporting Manager Hierarchy: Mgr1Vision_Org](image1)

Sales Representative Role Changed to Sales Manager under a Different Manager

Vang Duffy is a Sales Representative reporting to Braun Travis. The reporting hierarchy and organization details of Vang Duffy are shown in this image:

![Reporting Manager Hierarchy: Mgr1Vision_Org](image2)

In this scenario, Vang's role is changed to a Sales Manager and would be reporting to Ewing Yu, a different manager. To change Vang Duffy's role to Sales Manager under Ewing Yu, you must create a source file (CSV) with the following attributes and import it, as explained in this table.

<table>
<thead>
<tr>
<th>Attribute Name</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>ResourcePartyNumber</td>
<td>Conta504976</td>
</tr>
<tr>
<td>ResourceOrgRoleCode</td>
<td>SALES_MANAGER</td>
</tr>
</tbody>
</table>
### Attribute Name | Value
--- | ---
ResourceOrganization | Mgr4Vision_Org
ResourceParentOrganizationName | Mgr3Vision_Org
ResourceOrgManagerEmail | ewing.yu@vision.com

You can import the source data file.

1. Go to **Navigator > Tools > Import Management > Import Queue**.
2. Click **Create Import Activity** in the **Manage Imports** page.
3. In the **Enter Import Options** page, provide a name for the import activity, and select Resource from the **Object** drop-down list.
4. Select the CSV file in the **File Name** field, and click **Next**.
5. The source and target attributes are automatically mapped in the **Map Fields** page. Review and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking **Validate Data**. Click **Next**.

**Note:** Validation errors, if any, are displayed on the Mapping Validation screen. If you get warnings about unmapped columns, then you can ignore these columns and proceed to submit the import job. Validations are for informational purposes and applicable only for low-volume imports.

7. Review the import details on the **Review and Submit** page, and click **Submit** when you're ready.

You run the scheduled process **Reporting Hierarchy Generation** to re-generate the resource reporting hierarchy when there is a change in the organization hierarchy. For more information about the **Reporting Hierarchy Generation** scheduled process, see the section "Reporting Hierarchy Generation" in the **Understanding Scheduled Processes** guide.

After your import runs successfully, send the pending LDAP user update requests:

1. In the Navigator, click **Scheduled Processes**.
2. In the Scheduled Processes page, click **Schedule New Process**.
3. In the Schedule New Process dialog box, from the **Name** drop-down list, search for Send Pending LDAP Requests.
4. From the search results, select **Send Pending LDAP Requests** and click **OK**.
5. In the Process Details dialog box, click **Submit**.
6. In the Confirmation dialog box, click **OK**.
7. Click **Close**.
8. In the Scheduled Processes page, click the **Refresh** icon.
9. Verify if the status of the process has completed successfully.

The reporting hierarchy and organization details of Vang Duffy after his role has been changed from **SALES_REPRESENTATIVE** to **SALES_MANAGER** under Ewing Yu are as follows:
Examples of Disabling or Reenabling User Accounts

You can disable or reenable user accounts using import management. User accounts enable the user to sign in to CX Sales and B2B Service.

When you run the resource import to upload users or enter users in the Manage Users UI, users are created in CX Sales and B2B Service. User accounts for these users are created and maintained in a Lightweight Directory Access Protocol (LDAP) directory local to CX Sales and B2B Service by Oracle Identity Management (OIM). You can't delete the user account. However, you can disable or suspend the user account when an employee leaves your company. When you disable the user account, it prevents the user from being able to sign in to CX Sales and B2B Service. As a result, the user's access to all the associated transaction objects, such as sales territories, leads, opportunities, and so on, are also disabled.

Note: You may want to transfer these transaction objects to another resource user. For information about initiating mass transfer, see the section "Records Transfer Between Users" in the Implementing Sales guide.

Disabling the user account doesn't mean the termination of the employee work relationship or end dating of the resource. When an employee's work relationships are terminated and the employee has no roles, the employee's user account is suspended automatically. If the employee is subsequently rehired, the suspended account is automatically re-enabled. When an employee is re-hired, depending on availability, you might get the same user account. For example, an employee Rob Smith has the email id rob.smith@vision.com before leaving the organization. When he's re-hired, his email id is rob.x.smith@vision.com. You can enable or disable user accounts using import management.

These scenarios illustrate the various user account related updates you can make to a resource:

- Disabling User Account
- Reenabling User Account

Disable the User Account

Pat Tyme is a Sales Director who's an employee at Vision Corporation Enterprise. To view the user information for Pat:

1. Navigate to the following in the Setup and Maintenance work area:
   - Offering: Sales
   - Functional Area: Users and Security
   - Task: Manage Users
2. Search for Pat Tyme. The user account status of Pat Tyme appears in the active status.

In this scenario, Pat Tyme has moved to another organization and all the user accounts must be disabled. To disable the user account for Pat Tyme, you must create a source file (CSV) with the attributes listed in this table and import it using import management.

<table>
<thead>
<tr>
<th>Attribute Name</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>ResourcePartyNumber</td>
<td>Conta765976</td>
</tr>
<tr>
<td>UserStatus</td>
<td>S</td>
</tr>
</tbody>
</table>

You can import the source data file.

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Resource from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. The source and target attributes are automatically mapped in the Map Fields page. Review and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.

**Note:** Validation errors, if any, are displayed on the Mapping Validation screen. If you get warnings about unmapped columns, then you can ignore these columns and proceed to submit the import job. Validations are for informational purposes and applicable only for low-volume imports.

7. Review the import details on the Review and Submit page, and click Submit when you're ready.

After your import runs successfully, send the pending LDAP user update requests:

1. In the Navigator, click Scheduled Processes.
3. In the Schedule New Process dialog box, from the Name drop-down list, search for Send Pending LDAP Requests.
4. From the search results, select Send Pending LDAP Requests and click OK.
5. In the Process Details dialog box, click Submit.
6. In the Confirmation dialog box, click OK.
7. Click Close.
8. In the Scheduled Processes page, click the Refresh icon.
9. Verify if the status of the process has completed successfully.

As Pat Tyme's user account has been disabled, he won't be able to sign in to CX Sales and B2B Service. However, you can verify if Pat's user account is disabled.

1. Go to Navigator, Tools, Import Management, Import Queue.
2. In the Navigator, select My Team and User and Roles.
3. Search for Pat Tyme.

The user account status of Pat Tyme appears in the inactive status.
Reenable the User Account

Ellis Gibson is a Sales Representative who's an employee at Vision Corporation Enterprise. To view the user information for Ellis:

1. Go to Navigator, Tools, Import Management, Import Queue.
2. Go to Navigator, My Team, User and Roles.
3. Search for Ellis Gibson.

The user account status of Ellis Gibson appears in the inactive status.

In this scenario, Ellis Gibson has recently joined Vision Corporation Enterprise and he doesn’t have a user account. To enable the user account for Ellis Gibson, you must create a source file (CSV) with the attributes listed in this table and import it using import management.

<table>
<thead>
<tr>
<th>Attribute Name</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>ResourcePartyNumber</td>
<td>Conta765976</td>
</tr>
<tr>
<td>UserStatus</td>
<td>A</td>
</tr>
</tbody>
</table>

You can import the source data file.

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Resource from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. The source and target attributes are automatically mapped in the Map Fields page. Review and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.

**Note:** Validation errors, if any, are displayed on the Mapping Validation screen. If you get warnings about unmapped columns, then you can ignore these columns and proceed to submit the import job. Validations are for informational purposes and applicable only for low-volume imports.

7. Review the import details on the Review and Submit page, and click Submit when you’re ready.

After your import runs successfully, send the pending LDAP user update requests:

1. In the Navigator, click Scheduled Processes.
3. In the Schedule New Process dialog box, from the Name drop-down list, search for Send Pending LDAP Requests.
4. From the search results, select Send Pending LDAP Requests and click OK.
5. In the Process Details dialog box, click Submit.
6. In the Confirmation dialog box, click OK and Close.
7. In the Scheduled Processes page, click the Refresh icon.
8. Verify if the status of the process has completed successfully.
As Ellis Gibson's user account has been enabled, he can sign in to CX Sales and B2B Service. Alternatively, you can also verify if Ellis Gibson's user account is enabled.

1. Go to Navigator, Tools, Import Management, Import Queue.
2. Go to Navigator, My Team, User and Roles.
3. Search for Ellis Gibson.

The user account status of Ellis appears in the active status.

Related Topics
- Export Data

Examples of Making Manager Transfer Related Updates

You can transfer a sales representative or sales manager from the existing manager to a new manager using import management. This new manager might either already exist in the application or be a newly created manager.

You can transfer the resource by changing the resource information such as manager e-mail address or parent organization name.

The following scenarios illustrate the various manager transfer related updates to a resource.

- Transfer of Sales Representative from the Existing Manager to a Different Manager
- Transfer of Sales Manager from the Existing VP to a Different VP (With the Entire Organization)

Transfer of Sales Representative from the Existing Manager to a Different Manager

Wu Orozco is a Sales Representative reporting to Frank Gibbs. The reporting hierarchy and organization details of Wu Orozco are as shown in this image:

In this scenario, Wu is transferred from Frank Gibbs to a different manager, Li Yu, who's already existing in the application. To transfer Wu Orozco from Frank to Li Yu, you must create a source file (CSV) with the attributes and import it using import management as shown in this table.
You can import the source data file.

1. Go to **Navigator > Tools > Import Management > Import Queue**.
2. Click **Create Import Activity** in the **Manage Imports** page.
3. In the **Enter Import Options** page, provide a name for the import activity, and select **Resource** from the **Object** drop-down list.
4. Select the CSV file in the **File Name** field, and click **Next**.
5. The source and target attributes are automatically mapped in the **Map Fields** page. Review and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking **Validate Data**. Click **Next**.

   **Note:** Validation errors, if any, are displayed on the Mapping Validation screen. If you get warnings about unmapped columns, then you can ignore these columns and proceed to submit the import job. Validations are for informational purposes and applicable only for low-volume imports.

7. Review the import details on the **Review and Submit** page, and click **Submit** when you're ready.

You run the scheduled process **Reporting Hierarchy Generation** to re-generate the resource reporting hierarchy when there is a change in the organization hierarchy. For more information about the **Reporting Hierarchy Generation** scheduled process, see the section "Reporting Hierarchy Generation" in the **Understanding Scheduled Processes** guide.

The reporting hierarchy and organization details of Wu Orozco after he has been transferred from Frank Gibbs to Li Yu are as shown in this image:
Transfer of Sales Manager from the Existing VP to a Different VP (With the Entire Organization)

Marsh Tyler is a Sales Manager reporting to Tim May. The reporting hierarchy and organization details of Marsh Tyler are as shown in this image:

![Reporting Manager Hierarchy: CEOVisionSalesMarketing_Org](image)

In this scenario, Marsh Tyler is a sales manager and is transferred with his entire organization from Tim May to Pena Schwartz. Pena Schwartz is another vice-president already existing in the application. When Marsh Tyler is transferred, by default, his entire organization moves with him. Therefore, Noble Hooper who reports to Marsh Tyler is also moved along with Marsh. To transfer Marsh from Tim May to Pena Schwartz, you must create a source file (CSV) with the attributes and import it using import management as shown in this table. Provide a value either for the ResourceOrgManagerEmail or the ResourceParentOrganizationName attribute.

<table>
<thead>
<tr>
<th>Attribute Name</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>ResourcePartyNumber</td>
<td>Conta765976</td>
</tr>
<tr>
<td>ResourceOrgManagerEmail</td>
<td><a href="mailto:pena.schwartz@vision.com">pena.schwartz@vision.com</a></td>
</tr>
<tr>
<td>ResourceParentOrganizationName</td>
<td>SVP2VisionSalesMarketing_Org</td>
</tr>
</tbody>
</table>

You can import the source data file.

1. Go to **Navigator** > **Tools** > **Import Management** > **Import Queue**.
2. Click **Create Import Activity** in the **Manage Imports** page.
3. In the **Enter Import Options** page, provide a name for the import activity, and select Resource from the **Object** drop-down list.
4. Select the CSV file in the **File Name** field, and click **Next**.
5. The source and target attributes are automatically mapped in the **Map Fields** page. Review and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking **Validate Data**. Click **Next**.

   **Note:** Validation errors, if any, are displayed on the Mapping Validation screen. If you get warnings about unmapped columns, then you can ignore these columns and proceed to submit the import job. Validations are for informational purposes and applicable only for low-volume imports.

7. Review the import details on the **Review and Submit** page, and click **Submit** when you're ready.

You run the scheduled process **Reporting Hierarchy Generation** to re-generate the resource reporting hierarchy when there is a change in the organization hierarchy. For more information about the **Reporting Hierarchy Generation** scheduled process, see the section "Reporting Hierarchy Generation" in the **Understanding Scheduled Processes** guide.

The reporting hierarchy and organization details of Marsh Tyler after he has been transferred from Tim May to Pena Schwartz are as follows:

   **Note:** The sales representatives reporting to the manager being transferred are moved along with the manager. In this scenario, Noble Hooper who reports to Marsh Tyler is transferred along with Marsh from Tim May to Pena Schwartz as shown in this image.

---

**Examples of Making Resource Role Related Updates**

You can make resource role related updates to a resource by changing the resource information such as resource role code.

The following scenarios illustrate the various resource role related updates you can make to a resource.

- The resource is part of the hierarchy.
- The resource isn’t part of the hierarchy.

You can also add a standalone (non-manager or manager) resource to a hierarchy.
Resource is a part of the Hierarchy

Cox Parker is a Sales Representative reporting to Ross Hayes. The reporting hierarchy, organization, and role details of Cox Parker are displayed as shown in this image:

![Reporting Manager Hierarchy: VPSales2_OrgAug](image)

In this scenario, Cox's role is changed from Sales Representative to Sales Administrator within the same organization. To change the role of Cox Parker to Sales Administrator, you must create a source file (CSV) with the attributes and import it using import management as shown in this table.

<table>
<thead>
<tr>
<th>Attribute Name</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>ResourcePartyNumber</td>
<td>Conta504976</td>
</tr>
<tr>
<td>ResourceOrgRoleCode</td>
<td>SALES_ADMINISTRATOR</td>
</tr>
</tbody>
</table>

**Note:** You can obtain the ResourcePartyNumber either from the Resource Directory or through Data Export. For information about obtaining the ResourcePartyNumber either from the Resource Directory or through Data Export, see the topic "Obtaining the ResourcePartyNumber for a Resource".

**Note:** If you specify a value for the ResourceOrgRoleCode attribute, you don’t need to specify a value for the IndividualRoleCode attribute.

You can import the source data file.

1. Go to **Navigator > Tools > Import Management > Import Queue**.
2. Click **Create Import Activity** in the **Manage Imports** page.
3. In the **Enter Import Options** page, provide a name for the import activity, and select Resource from the **Object** drop-down list.
4. Select the CSV file in the **File Name** field, and click **Next**.
5. The source and target attributes are automatically mapped in the **Map Fields** page. Review and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking **Validate Data**. Click **Next**.
   **Note:** Validation errors, if any, are displayed on the Mapping Validation screen. If you get warnings about unmapped columns, then you can ignore these columns and proceed to submit the import job. Validations are for informational purposes and applicable only for low-volume imports.
7. Review the import details on the **Review and Submit** page, and click **Submit** when you're ready.
After your import runs successfully, send the pending LDAP user update requests:

1. In the Navigator, click **Scheduled Processes**.
2. In the Scheduled Processes page, click **Schedule New Process**.
3. In the Schedule New Process dialog box, from the **Name** drop-down list, search for Send Pending LDAP Requests.
4. From the search results, select **Send Pending LDAP Requests** and click **OK**.
5. In the Process Details dialog box, click **Submit**.
6. In the Confirmation dialog box, click **OK**.
7. Click **Close**.
8. In the Scheduled Processes page, click the **Refresh** icon.
9. Verify if the status of the process has completed successfully.

You run the scheduled process **Reporting Hierarchy Generation** to re-generate the resource reporting hierarchy when there is a change in the organization hierarchy. For more information about the **Reporting Hierarchy Generation** scheduled process, see the section "Reporting Hierarchy Generation" in the *Understanding Scheduled Processes* guide.

The details of Cox Parker after the role change update from SALES_REPRESENTATIVE to SALES_ADMINISTRATOR are displayed as shown in this image:

![Reporting Manager Hierarchy: VPSales2_OrgAug](image)

**Employee Resource isn't part of the Hierarchy**

Pat Tyme is a Sales Manager who's not part of the hierarchy.

In this scenario, Pat's role is changed from Sales Manager to Sales Director. To change Pat's role to Sales Director, you must create a source file (CSV) with the attributes and import it using import management as shown in this table.

<table>
<thead>
<tr>
<th>Attribute Name</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>ResourcePartyNumber</td>
<td>Conta765976</td>
</tr>
<tr>
<td>IndividualRoleCode</td>
<td>SALES_DIRECTOR</td>
</tr>
</tbody>
</table>

**Note:** This scenario assumes that the user is assigned one IndividualRoleCode.

You can import the source data file.

1. Go to **Navigator > Tools > Import Management > Import Queue**.
2. Click **Create Import Activity** in the **Manage Imports** page.
3. In the **Enter Import Options** page, provide a name for the import activity, and select **Resource** from the **Object** drop-down list.

4. Select the CSV file in the **File Name** field, and click **Next**.

5. The source and target attributes are automatically mapped in the **Map Fields** page. Review and edit the mappings if required.

6. Check the file for unmapped columns or data format issues by clicking **Validate Data**. Click **Next**.

   **Note:** Validation errors, if any, are displayed on the Mapping Validation screen. If you get warnings about unmapped columns, then you can ignore these columns and proceed to submit the import job. Validations are for informational purposes and applicable only for low-volume imports.

7. Review the import details on the **Review and Submit** page, and click **Submit** when you're ready.

After your import runs successfully, send the pending LDAP user update requests:

1. In the Navigator, click **Scheduled Processes**.

2. In the Scheduled Processes page, click **Schedule New Process**.

3. In the Schedule New Process dialog box, from the **Name** drop-down list, search for **Send Pending LDAP Requests**.

4. From the search results, select **Send Pending LDAP Requests** and click **OK**.

5. In the Process Details dialog box, click **Submit**.

6. In the Confirmation dialog box, click **OK**.

7. Click **Close**.

8. In the Scheduled Processes page, click the **Refresh** icon.

9. Verify if the status of the process has completed successfully.

### Adding a Standalone Resource to a Hierarchy

You can add a standalone resource (non-manager or manager) to a hierarchy. To add a resource to the hierarchy, you must create a source CSV file with the attributes and import it using import management, as shown in this table.

<table>
<thead>
<tr>
<th>Attribute Name</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>ResourcePartyNumber</td>
<td>Conta765976</td>
</tr>
<tr>
<td>ResourceOrgManagerEmail</td>
<td><a href="mailto:charlotte.edwards@vision.com">charlotte.edwards@vision.com</a></td>
</tr>
<tr>
<td>ResourceParentOrganizationName</td>
<td>Global HQ</td>
</tr>
<tr>
<td>ResourceOrganizationName</td>
<td>JsmithOrg</td>
</tr>
<tr>
<td></td>
<td>(Optional)</td>
</tr>
</tbody>
</table>

You run the scheduled process **Reporting Hierarchy Generation** to re-generate the resource reporting hierarchy when there is a change in the organization hierarchy. For more information about the **Reporting Hierarchy Generation** scheduled process see the section "Reporting Hierarchy Generation" in the Understanding Scheduled Processes guide.

**Note:** Provide values for the ResourcePartyNumber, ResourceOrgManagerEmail, and ResourceParentOrganizationName attributes when adding a non-manager resource to the hierarchy. Optionally, provide a value for the ResourceOrganizationName attribute when adding a manager resource to the hierarchy.
Examples of Making Resource End-Dating Related Updates

You can end-date a resource when a worker leaves your enterprise, using import management. This example illustrates what happens when you end date a Sales Representative and a Sales Manager.

When a worker leaves your enterprise, you terminate them. When you terminate a worker, the person type of the worker record changes to ex-employee or ex-contingent worker and the associated resource usage is end-dated. However, the records of the ex-employee or ex-contingent worker remain in the database and you can reinstate or rehire the ex-employee or ex-contingent worker later to create a new period of service. You can also end date a resource, if you want to end all the assignments that are associated with the resource.

**Note:** You may want to transfer the transaction objects related to end-dated resources to another resource.

These scenarios illustrate the various end-dating changes you can make to a resource.

- End-dating a Sales Representative
- End-dating a Sales Manager

**End-Dating a Sales Representative**

Allen King is a Sales Representative reporting to Pat Tyme. The reporting hierarchy and organization details of Allen King are displayed in this image:

In this scenario, Allen King resigns from Vision Corporation and his resource assignment is end-dated. To end-date Allen, you must create and import a source file (CSV) with the attributes listed in this table using import management.

**Note:** When Allen King is end-dated, all the transaction objects owned by him, such as sales territories, leads, opportunities, and so on, may need to be manually transferred to his manager or another resource.

<table>
<thead>
<tr>
<th>Attribute Name</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>ResourcePartyNumber</td>
<td>Conta765976</td>
</tr>
</tbody>
</table>
You can import the source data file from the Import Management work area. Then, create mappings between the attributes in your source data file and the attributes in CX Sales and B2B Service using the values given in the table.

The reporting hierarchy and organization details after Allen King is removed from Pat Tyme’s organization are displayed in this image:

End-Dating a Sales Manager

Nelon Pascal is a Sales Manager reporting to Jane Reifer. The reporting hierarchy and organization details of Nelom Pascal are displayed in this image:

In this scenario, Nelom Pascal is a sales manager who has two sales representatives, Neya Pali and Carlton Baugh, reporting to him. Nelom Pascal resigns from Vision Corporation and his resource assignment is end-dated. If the salespeople in the resource organization have any transactions assigned to them, then these are available once another manager assumes the vacant resource organization membership as manager. Before Nelom’s resource assignment is end dated, Oracle recommends that you move his reports to a different manager such as Nelom’s manager, Jane Reifer. However, if you want to move Nelom’s reports to another manager, then you must provide additional rows in your source file (CSV) for the reports and specify all the mandatory attributes. To end date Nelom Pascal, you must create a source file (CSV) with the attributes and import it using import management as listed in this table.
You can import the source data file from the Import Management work area.

You can import the source data file.

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Resource from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. The source and target attributes are automatically mapped in the Map Fields page. Review and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.

   **Note:** Validation errors, if any, are displayed on the Mapping Validation screen. If you get warnings about unmapped columns, then you can ignore these columns and proceed to submit the import job. Validations are for informational purposes and applicable only for low-volume imports.

7. Review the import details on the Review and Submit page, and click Submit when you're ready.

After your import runs successfully, send the pending LDAP user update requests:

1. In the Navigator, click Scheduled Processes.
3. In the Schedule New Process dialog box, from the Name drop-down list, search for Send Pending LDAP Requests.
4. From the search results, select Send Pending LDAP Requests and click OK.
5. In the Process Details dialog box, click Submit.
6. In the Confirmation dialog box, click OK.
7. Click Close.
8. In the Scheduled Processes page, click the Refresh icon.
9. Verify if the status of the process has completed successfully.

   **Note:** Before you run the Send Pending LDAP Requests schedule process, you need to run the "Autoprovision Roles for All Users" schedule process with 'Process Generated Role Requests' parameter to NO to avoid performance issues.

You run the scheduled process Reporting Hierarchy Generation to re-generate the resource reporting hierarchy when there is a change in the organization hierarchy. For more information about the Reporting Hierarchy Generation scheduled process, see the section "Reporting Hierarchy Generation" in the Understanding Scheduled Processes guide.

The reporting hierarchy and organization details after Nelon Pascal is removed from Jane Reifer's organization are as shown in this image.
Examples of Updating Employee Information

You can update a resource by changing the resource information such as first name, last name, and email address. You can also update a resource with additional information such as fax number, phone number, middle name, and so on.

Update the Last Name of a Resource

Vang Duffy is a Sales Manager in CX Sales and B2B Service. You can view the resource details of Vang Duffy from the Resource Directory. From the Navigator, click Resource Directory and search for Vang Duffy in the Search section, his resource details appears as shown in this image.

The reporting hierarchy and organization details of Vang Duffy are as follows:
In this scenario, Vang Duffy changes his name to Vang Smith. To update Vang's last name, you must use the Resource Party Number and Last Name attributes in your source file. To update Vang's last name from Duffy to Smith, create a source file (CSV) with these attributes and import it using import management.

<table>
<thead>
<tr>
<th>Attribute Name</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>ResourcePartyNumber</td>
<td>Conta765976</td>
</tr>
<tr>
<td>LastName</td>
<td>Smith</td>
</tr>
</tbody>
</table>

You can import the source data file.

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Resource from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. The source and target attributes are automatically mapped in the Map Fields page. Review and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.

**Note:** Validation errors, if any, are displayed on the Mapping Validation screen. If you get warnings about unmapped columns, then you can ignore these columns and proceed to submit the import job. Validations are for informational purposes and applicable only for low-volume imports.

7. Review the import details on the Review and Submit page, and click Submit when you're ready.

After running the import file, navigate to Resource Directory and search for Vang in the Search section. The resource details of Vang after the last name is updated appear as shown in this image:

![Resource: Vang Smith](image)

Also, note that Vang's last name is updated in the reporting hierarchy.
Update the Email Address of a Resource


In this scenario, Rina Nash changes her name to Rina Pinto Jacob after marriage. Rina not only wants to change her last name, but also wants to update her email ID and middle name.

To update Rina's last name, email address, and middle name, you must create a source file (CSV) with these attributes and import it using import management. However, in this scenario, to update Rina's email ID, you must provide the email address in your CSV file.

<table>
<thead>
<tr>
<th>Attribute Name</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>ResourcePartyNumber</td>
<td>Conta765976</td>
</tr>
<tr>
<td>ResourceEmail</td>
<td><a href="mailto:rina.jacob@vision.com">rina.jacob@vision.com</a></td>
</tr>
</tbody>
</table>

You can import the source data file.

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Resource from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. The source and target attributes are automatically mapped in the Map Fields page. Review and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.

**Note:** Validation errors, if any, are displayed on the Mapping Validation screen. If you get warnings about unmapped columns, then you can ignore these columns and proceed to submit the import job. Validations are for informational purposes and applicable only for low-volume imports.

7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Rina's email address will be updated and visible in the resource pages, such as the resource directory.

Update the Phone Number of a Resource

In this scenario, Rina Nash changes her name to Rina Pinto Jacob after marriage. Rina not only wants to change her last name, but also wants to update her work phone number and middle name.

To update Rina's last name, work phone number, and middle name, you must create a source file (CSV) with these attributes and import it using import management. However, in this scenario, to update Rina's phone number, you must provide the work phone country code and work phone number in your CSV file.

<table>
<thead>
<tr>
<th>Attribute Name</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>ResourcePartyNumber</td>
<td>Conta765976</td>
</tr>
<tr>
<td>WorkPhoneCountryCode</td>
<td>+1</td>
</tr>
<tr>
<td>RawWorkPhoneNumber</td>
<td>510-599-7487</td>
</tr>
</tbody>
</table>

You can import the source data file.

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Resource from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. The source and target attributes are automatically mapped in the Map Fields page. Review and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
   **Note:** Validation errors, if any, are displayed on the Mapping Validation screen. If you get warnings about unmapped columns, then you can ignore these columns and proceed to submit the import job. Validations are for informational purposes and applicable only for low-volume imports.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Rina's email address is updated and visible in the resource pages, such as the resource directory.

**Obtain the ResourcePartyNumber for a Resource**

You can obtain the ResourcePartyNumber for a resource either from the Resource Directory or through data export.

To obtain the ResourcePartyNumber for a resource from the Resource directory:

1. From the Navigator, click Resource Directory.
2. From the Search drop-down list, select one of the following:
   - First Name
Import Your Data

3. Click Search.

The Registry ID is displayed in the search results.

Alternatively, you can obtain the ResourcePartyNumber for a resource through Data Export. Export data using the **Export Management** option from the **Tools** work area. For information about exporting data, see the topic Export Data.

**Related Topics**
- Export Data

Import Your Resource Capacity Data

You can use Import Management to create, delete, or update Resource Capacity records.

To import Resource Capacity records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (.csv) file for import.
3. Create the import activity.
4. Review the import results.

**How You Map Your Source Data to Target Object Attributes**

To import your Resource Capacity data into Oracle Applications Cloud, you need to populate a CSV file with your source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the .CSV file for data import:

- Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
- Ensure prerequisite steps are complete, such as understanding what attributes are required for importing your objects.
- Understand your options for uniquely identifying the records.
- Ensure parent records exist before importing child records.
- Identify the target object attributes that are required in the .CSV file for a successful import.

**Before You Start**

You must do some basic checks before starting your import. For example, make sure that:

- You have completed all the prerequisites for importing each attribute in your source data.
- You have all parent records in place before importing child records.
Select a Unique Identifier for Your Records

To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the import process to uniquely identify the records. The file import process uses the attribute values to automatically map your source data to the target object attributes in Oracle Applications Cloud.

The preferred options to uniquely identify an object record are as follows:

- **Internal ID**: If you’re identifying a record that already exists in Oracle Applications Cloud, then you can use the internal ID of the record, a system-generated unique identifier. Attributes with "id" in the attribute name are typically internal IDs. You can determine the internal ID of a record by exporting Oracle Applications Cloud object data, or by doing a transactional database query. Using an internal ID typically provides better performance and reduces the import duration. For the Resource Capacity object, these attributes are CapacityId and PartyId.

- **Public unique identifiers**: If you’re creating new records, then you can provide a user-friendly public unique identifier (attributes denoted with ‘Number’ and usually visible in the business object’s UI). If you update a record for which you have previously provided a Number attribute, or for which a Number attribute is visible in the object’s UI, you can use the Number attribute to identify the record. For the Resource Capacity object, the attribute is CapacityNumber.

Required Attributes and Validations for Resource Capacity Object

To import data successfully into Oracle Applications Cloud, your .CSV file must include the required attributes. Ensure that you provide valid values for the attributes.

The following table lists the required attributes for importing new Resource Capacity records, required attributes for updating Resource Capacity records, prerequisite setup tasks for the attributes, and specific validations, if any, for Resource Capacity import:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Data Type</th>
<th>Data Length</th>
<th>Prerequisite Setup Task/Import Validations</th>
<th>Creating a Resource Capacity record</th>
<th>Updating an Existing Resource Capacity record</th>
</tr>
</thead>
<tbody>
<tr>
<td>CapacityId</td>
<td>The unique resource capacity identifier.</td>
<td>Integer</td>
<td>18</td>
<td>None</td>
<td>Not required</td>
<td>Required</td>
</tr>
<tr>
<td>CapacityNumber</td>
<td>The public unique identifier for resource capacities</td>
<td>String</td>
<td>30</td>
<td>Default Expression</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>ChannelTypeCd</td>
<td>The channel type that can be used by a resource</td>
<td>String</td>
<td>30</td>
<td>Expected values include:</td>
<td>Required</td>
<td>Not Required</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>- ORA_SVC_CHAT</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>- ORA_SVC_NONE</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>- ORA_SVC_VIDEO</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
### Attribute

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Data Type</th>
<th>Data Length</th>
<th>Prerequisite Setup Task/ Import Validations</th>
<th>Creating a Resource Capacity record</th>
<th>Updating an Existing Resource Capacity record</th>
</tr>
</thead>
<tbody>
<tr>
<td>ObjectTypeCd</td>
<td>The object type to which a resource can be assigned</td>
<td>String</td>
<td>30</td>
<td>This can be null. The only allowed value is “SVC_SERVICE_REQUESTS”.</td>
<td>Not required.</td>
<td>Not required</td>
</tr>
<tr>
<td>MaximumCapacity</td>
<td>The maximum capacity for a resource in a channel type and object type</td>
<td>Integer</td>
<td>5</td>
<td>This value must be greater than or equal to zero.</td>
<td>Required.</td>
<td>Not required</td>
</tr>
<tr>
<td>PartyId</td>
<td>The resource unique identifier</td>
<td>Integer</td>
<td>18</td>
<td>This can be null. If a value is provided, the Resource Party Id must exist.</td>
<td>Not required.</td>
<td>Not required</td>
</tr>
</tbody>
</table>

You can view the Resource Capacity object along with all its child objects and attributes in the **Manage Import Objects** page of the **Import Management** flow. You can find attribute information like type, length, description, and so on, on this page.

### Create the Source CSV File

You include the data that you want to import into CX Sales and B2B Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to **Navigator > Tools > Import Management > Import Objects**.
2. Select the **Resource Capacities** object in the table and click **Download**.

You can now edit the downloaded file and provide valid values for the required attributes.

**Note:** For help in populating the CSV file and to avoid any issues in entering values, see the topic **Potential Issues When Opening CSV Files With Excel** in Related Topics section.

### Create the Import Activity

To import data into Oracle Applications Cloud, you need to create an import activity and provide the CSV file as an input to the activity.

To create an import activity, do the following:

1. In the Navigator, under **Tools**, click **Import Management**.
2. On the **Manage Imports** page, click **Create Import Activity**.
3. In the **Create Import Activity: Enter Import Options** page, provide a name for the import activity, and select **Resource Capacity** from the **Object** drop-down list.
4. In **File Name**, browse and upload the required .CSV file, and click **Next**.
5. In the **Create Import Activity: Map Fields** page edit the attribute mappings if required, and click **Next**.
  
**Note:** Click **Validate Data** to validate the mapping of the source file for unmapped columns and to check for data format issues.
6. In the **Create Import Activity: Review and Submit** page, click **Submit**.

### Review the Import Results

You can review the import results by checking for the import activity in the **Manage Import Activity** page. A file import activity is said to be successful when its status displays as **Completed**. To check the status of the import activity, do as follows:

1. In the Navigator, under **Tools**, click **Import Management**.
2. On the **Manage Imports** page, search for the import activity that you created using one of the search criteria, such as status, name, object, and so on.
3. Check the **Status** column for the import activity. The import is successful if the status displays as **Completed**. The other valid values for the import activity status are **Queued for import**, **Preparing data for import**, **Importing data**, **Completed with errors**, and **Unsuccessful**.

**Note:** On this page you can also quickly view the number and status of all active imports, completed imports, and unsuccessful imports that have been submitted.

### Related Topics
- Potential Issues When Opening CSV Files in Excel
- Import Data

### Import Your Sales Lead Data

Use this topic to import Sales Lead data into Oracle Applications Cloud. You can use the import functionality to create, update, or delete Sales Lead records.

To import Sales Lead records, perform the following tasks:

1. Map your source sales lead data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

Use the Contact time zone field to save the preferred time zone of a contact pursued on your sales lead. The contact time zone is based on the contact address and helps you know the preferred time to call or email a prospect or customer. You can also use the functional "who" columns to save the record history of a sales lead. The columns let you accurately report on sales leads that are imported from other systems.

Other sales lead management features help to align marketing and sales objectives from sales lead generation to sales lead execution. Sales Lead information is generated from a variety of sources and obtained from:

- A company's existing contacts
Sales campaigns

All sales leads then undergo the qualification and assessment process and are qualified either manually by a salesperson or automatically based on predefined rules. Finally, qualified sales leads are converted into opportunities.

How You Map Your Source Data to Target Object Attributes

To import your sales lead data into Oracle Applications Cloud, you must populate a .csv file with your source data and map that source data to target object attributes in Oracle Applications Cloud.

You must do the following before creating the .csv file for data import:

- Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
- Ensure prerequisite steps are complete, such as understanding what attributes are required for importing your objects.
- Understand your options for uniquely identifying the records.
- Ensure parent records exist before importing child records.
- Identify the target object attributes that are required in the .csv file for a successful import.

To better manage your sales lead information, the sales lead object has the following child objects:

- Sales Lead Contact
- Sales Lead Product
- Sales Lead Resource

If you want to import only a few records, then you can create a single CSV file for all sales lead attributes. However if you want to import a large number of records, then you may decide to create multiple CSV files, one for each of the sales lead child objects. Note that you must have imported the CSV file for sales lead object successfully before trying to import the CSV files for the child objects. There are separate help topics describing how to import each of these child objects. For more information, see the related topics section.

Before You Start

You must do some basic checks before starting your import. For example, make sure that:

- You have completed all the prerequisites for importing each attribute in your source data.
- You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records

To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the import process to uniquely identify the records. The file import process uses the attribute values to automatically map your source data to the target object attributes in Oracle Applications Cloud.

The preferred options to uniquely identify an object record are as follows:

- Internal ID: If you're identifying a record that already exists in Oracle Applications Cloud, then you can use the internal ID of the record, a system-generated unique identifier. Attributes with "id" in the attribute name are typically internal IDs. You can determine the internal ID of a record by exporting Oracle Applications Cloud object data, or by doing a transactional database query. Using an internal ID typically provides better performance and reduces the import duration. For the Sales Lead object, this attribute is LeadId.
• Public unique identifiers: If you’re creating new records, then you can provide a user-friendly public unique identifier (attributes denoted with ‘Number’ and usually visible in the business object’s UI). If you update a record for which you have previously provided a Number attribute, or for which a Number attribute is visible in the object’s UI, you can use the Number attribute to identify the record. For the Sales Lead object, the attribute is LeadNumber.

### Required Attributes and Validations for Sales Lead Object

To import data successfully into Oracle Applications Cloud, your .csv file must include the required attributes. Ensure that you provide valid values for the attributes.

This table lists the required attributes for importing new Sales Lead records, required attributes for updating Sales Lead records, prerequisite setup tasks for the attributes, and specific validations, if any, for Sales Lead import:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/ Import Validations</th>
<th>Creating a Sales Lead record</th>
<th>Updating an Existing Sales Lead record</th>
</tr>
</thead>
<tbody>
<tr>
<td>AcceptedDate</td>
<td>The date the recommended lead generated by the Sales Prediction engine was accepted by a sales person or lead qualifier to pursue</td>
<td>No validation</td>
<td>A value is required if you specify the value for LeadAcceptedFlag as Y.</td>
<td>Not required</td>
</tr>
<tr>
<td>ActionCode</td>
<td>Indicates explicitly the operation to be performed on a row: INSERT to create a new record in the destination tables, UPDATE to update an existing record in the destination table, DELETE to delete the record.</td>
<td>If no value is provided, the record is updated if it already exists. Else, it’s inserted</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>ConvertedTm</td>
<td>The date when the lead was converted to an opportunity</td>
<td>No validation</td>
<td>A value is required if you specify the value for Lead StatusCd as CONVERTED.</td>
<td>Not required</td>
</tr>
<tr>
<td>LeadName</td>
<td>The name that identifies the lead</td>
<td>No validation</td>
<td>A value is required if you’re creating a new lead.</td>
<td>Not required</td>
</tr>
<tr>
<td>LeadNumber</td>
<td>The Lead’s public unique identifier value</td>
<td>If providing a value to update an existing lead, the value must exist in the column LEAD_NUMBER of the MKL_LM_LEADS table.</td>
<td>If providing a value and creating a new lead, the value must be unique.</td>
<td>A value is required, if updating an existing lead and you’re not providing the unique ID of the lead (ObjectKey)</td>
</tr>
<tr>
<td>ObjectKey</td>
<td>The unique ID for the existing lead record in the destination table</td>
<td>Automatically generated by the import process if creating new record. If updating an existing record and providing the LEAD_NUMBER, the import process defaults the LEAD_ ID.</td>
<td>Do not provide a value if creating a new lead.</td>
<td>A value is required, if updating an existing lead and you’re not providing the LeadNumber.</td>
</tr>
</tbody>
</table>
### Attribute | Description | Prerequisite Setup Task/Import Validations | Creating a Sales Lead record | Updating an Existing Sales Lead record
--- | --- | --- | --- | ---
**OwnerId** | The unique ID for the existing resource party in the destination table. The owner must also be an internal resource included as a member of the lead's sales team | If providing a value, the value must exist in the column PARTY_ID of the HZ_PARTIES table. The value must also exist in the column PARTY_ID of the JTF_RS_RESOURCE_PROFILES table. The identified party must be assigned as a sales team resource for the existing lead or included in the resources imported in the same batch as this record. | A value is required, if creating a new lead and you don't provide the owner's source system code and reference (OwnerOrigSystem and OwnerOrigSystemReference). | Not required |
**QualifiedDate** | The date when the lead was qualified | No validation | A value is required, if you optionally provide the lead status (StatusCd) value as QUALIFIED, indicating that the lead is qualified. | Not required |
**RejectedTm** | The date when the lead was rejected | No validation | A value is required, if you optionally provide the lead registration status (ApprovalStatus) value as REJECTED, indicating that the lead is rejected. | Not required |
**RetiredTm** | The date when the lead was retired | No validation | A value is required, if you optionally provide the lead lead status (StatusCd) value as RETIRED, indicating that the lead is retired. | Not required |

Go to **Navigator > Tools > Import Management > Import Objects**, to see all the attributes of the sales lead object. The page also lists attribute information like type, length, description, and so on.

### Create the Source CSV File

You include the data that you want to import into CX Sales and B2B Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to **Navigator > Tools > Import Management > Import Objects**.
2. Select the **Sales Lead** object in the table and click **Download**.

You can now edit the downloaded file and provide valid values for the required attributes.

**Note:** For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.
Create the Import Activity

After you have the CSV file ready, create an import activity to import the sales lead information. To create an import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Sales Lead from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you’re ready.

Review the Import Results

Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed. You can drill down on the import activity to go to the Import Status page which provides the status details of the import activity.

Related Topics

- Potential Issues When Opening CSV Files in Excel
- How You Use Alternate Keys to Import Records
- Import Data

Import Your Sales Lead Contact Data

You can use the Import Management to create, update, or delete sales lead contact records.

You can import sales lead contact records using these steps:

1. Map your source sales lead contact data to Oracle Applications Cloud object attributes. This way the import process would know where to insert each of the information bits.
2. Create the source CSV file with the sales lead contact data you want to import.
4. Check the import results to know if the import went well.

How You Map Your Source Data to Target Object Attributes

To import your sales lead contact data into Oracle Applications Cloud, you must populate a .csv file with your source data and map that source data to target object attributes in Oracle Applications Cloud.
You must do the following before creating the .csv file for data import:

- Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
- Ensure prerequisite steps are complete, such as understanding what attributes are required for importing your objects.
- Understand your options for uniquely identifying the records.
- Ensure parent records exist before importing child records.
- Identify the target object attributes that are required in the .csv file for a successful import.

**Before You Start**
You must do some basic checks before starting your import. For example, make sure that:

- You have completed all the prerequisites for importing each attribute in your source data.
- You have all parent records in place before importing child records.

**Select a Unique Identifier for Your Records**
All records must be unique in the application. You can use one of these to identify records:

- **Public unique identifiers:** If you’re creating records, then you can provide an easily understandable public unique identifier. These are, usually, denoted with ‘Number’ and visible in the business object’s UI. PUID attributes are usually named `<object> Number`. If you’re updating a record with a Number attribute, then use the Number attribute to identify the record. For more information about public unique identifiers, see the topic "How You Use Alternate Keys to Import Records" in Related Topics section.
- **Source system and source system reference:** Source system is an identifier for the external system, and source system reference is a unique identifier within the external system. If you’re importing new sales lead contacts or are updating sales lead contacts that have source system reference data, then provide the source system and source system reference values.

**Required Attributes and Validations for Sales Lead Contact Object**
To import data successfully into Oracle Applications Cloud, your .csv file must include the required attributes. Ensure that you provide valid values for the attributes.

This table lists the required attributes for sales lead contact records, prerequisite setup tasks and specific validations, if any:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/Import Validations</th>
<th>Creating a Sales Lead Contact record</th>
<th>Updating an Existing Sales Lead Contact record</th>
</tr>
</thead>
<tbody>
<tr>
<td>LeadOrigSystem</td>
<td>The code that identifies the original source system for the sales lead</td>
<td>If providing a value and importing a new sales lead in the same import as this lead contact association, the value must be part of a unique combination of the source system reference (LeadOrigSystemReference) and the source system code.</td>
<td>Conditionally required, when the lead is created in the same batch as adding a new lead contact.</td>
<td>Not required</td>
</tr>
<tr>
<td>Attribute</td>
<td>Description</td>
<td>Prerequisite Setup Task/Import Validations</td>
<td>Creating a Sales Lead Contact record</td>
<td>Updating an Existing Sales Lead Contact record</td>
</tr>
<tr>
<td>-----------------------------</td>
<td>-----------------------------------------------------------------------------</td>
<td>-----------------------------------------------------------------------------------------------------------</td>
<td>-------------------------------------------------------------------------------------------------------</td>
<td>-----------------------------------------------</td>
</tr>
<tr>
<td></td>
<td></td>
<td>(LeadOrigSystem) in the MKT_IMP_LEADS_T table.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>LeadOrigSystemReference</td>
<td>The ID that identifies the original source system reference for the sales lead</td>
<td>If providing a value and importing a new sales lead in the same import as this lead contact association, the value must be part of a unique combination of the source system reference (LeadOrigSystemReference) and the source system code (LeadOrigSystem) in the MKT_IMP_LEADS_T table.</td>
<td>Conditionally required, when the lead is created in the same batch as adding a new lead contact</td>
<td>Not required</td>
</tr>
<tr>
<td>LeadId</td>
<td>The unique ID for the existing lead record in the destination table</td>
<td>The value provided must match the value in the LEAD_ID column of the MKL_LM_LEADS table.</td>
<td>Conditionally required, when the lead is created in a different batch as adding a new lead contact.</td>
<td>Not required</td>
</tr>
<tr>
<td>PartyOrigSystem</td>
<td>The code that identifies the original source system for the contact</td>
<td>If providing a value, the combination of source system reference (PartyOrigSystemReference) and source system code (PartyOrigSystem) must exist in the columns ORIG_SYSTEM_REFERENCE and ORIG_SYSTEM of the HZ_ORIG_SYS_REFERENCES table.</td>
<td>Conditionally required, when you don’t provide the contact’s party ID (PartyId)</td>
<td>Conditionally required, when you don’t provide the unique ID for the record (LeadTcMembersId) or the contact’s party ID (PartyId)</td>
</tr>
<tr>
<td>PartyOrigSystemReference</td>
<td>The ID that identifies the original source system reference for the contact</td>
<td>If providing a value, the combination of source system reference (PartyOrigSystemReference) and source system code (PartyOrigSystem) must exist in the columns ORIG_SYSTEM_REFERENCE and ORIG_SYSTEM of the HZ_ORIG_SYS_REFERENCES table.</td>
<td>Conditionally required when you don’t provide the contact’s party ID</td>
<td>Conditionally required when you don’t provide the unique ID for the record (LeadTcMembersId) or the contact’s party ID (PartyId)</td>
</tr>
<tr>
<td>PartyId</td>
<td>The unique ID for the existing contact’s party record in the destination table</td>
<td>The value provided must match the value in the PARTY_ID column of the HZ_PARTIES table.</td>
<td>Conditionally required when you don’t provide the contact’s source system and source system reference</td>
<td>Conditionally required when you don’t provide the contact’s source system and source system reference</td>
</tr>
<tr>
<td>PrimaryFlag</td>
<td>Specifies whether the provided contact is a primary contact on the sales lead</td>
<td>The value must be either Y or N.</td>
<td>Conditionally required, as at least one contact for a lead has this value set to Y.</td>
<td>Conditionally required, as at least one contact for a lead has this value set to Y.</td>
</tr>
</tbody>
</table>

---

617
Go to Navigator > Tools > Import Management > Import Objects, to see all the attributes of the sales lead contact object. The page also lists attribute information like type, length, description, and so on.

Create the Source CSV File
You include the data that you want to import into CX Sales and B2B Service in a source CSV file.
You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator > Tools > Import Management > Import Objects.
2. Select the Sales Lead Contact object in the table and click Download.
You can now edit the downloaded file and provide valid values for the required attributes.

**Note:** For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the sales lead contact information. To create an import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Sales Lead Contact from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed. You can drill down on the import activity to go to the Import Status page which provides the status details of the import activity.

**Related Topics**
- Potential Issues When Opening CSV Files in Excel
- How You Use Alternate Keys to Import Records
- Import Data
Import Your Sales Lead Product Data

You can use the Import Management to create, update, or delete sales lead product records.

You can import sales lead product records using these steps:

1. Map your source sales lead product data to Oracle Applications Cloud object attributes. This way the import process would know where to insert each of the information bits.
2. Create the source CSV file with the sales lead product data you want to import.
4. Check the import results to know if the import went well.

How You Map Your Source Data to Target Object Attributes

To import your sales lead product data into Oracle Applications Cloud, you must populate a .csv file with your source data and map that source data to target object attributes in Oracle Applications Cloud.

You must do the following before creating the .csv file for data import:

- Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
- Ensure prerequisite steps are complete, such as understanding what attributes are required for importing your objects.
- Understand your options for uniquely identifying the records.
- Ensure parent records exist before importing child records.
- Identify the target object attributes that are required in the .csv file for a successful import.

Before You Start

You must do some basic checks before starting your import. For example, make sure that:

- You have completed all the prerequisites for importing each attribute in your source data.
- You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records

All records must be unique in the application. You can use one of these to identify records:

- Public unique identifiers: If you’re creating records, then you can provide an easily understandable public unique identifier. These are, usually, denoted with ‘Number’ and visible in the business object’s UI. PUID attributes are usually named <object> Number. If you’re updating a record with a Number attribute, then use the Number attribute to identify the record. For more information about public unique identifiers, see the topic "How You Use Alternate Keys to Import Records" in Related Topics section.
- Source system and source system reference: Source system is an identifier for the external system, and source system reference is a unique identifier within the external system. If you’re importing new sales lead products or are updating sales lead products that have source system reference data, then provide the source system and source system reference values.
Required Attributes and Validations for Sales Lead Product Object

To import data successfully into Oracle Applications Cloud, your .csv file must include the required attributes. Ensure that you provide valid values for the attributes.

This table lists the required attributes for sales lead product records, prerequisite setup tasks and specific validations, if any:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/Import Validations</th>
<th>Creating a Sales Lead Product record</th>
<th>Updating an Existing Sales Lead Product record</th>
</tr>
</thead>
<tbody>
<tr>
<td>ItemId</td>
<td>The unique ID for the existing sales catalog product (item) record in the destination table</td>
<td>The value provided must match the value in the INVENTORY_ITEM_ID column of the EGP_SYSTEM_ITEMS_B table.</td>
<td>Conditionally required, when you don’t provide the ProductName and ProductGroupId/ProductGroupName</td>
<td>Conditionally required, when you don’t provide the ProductName and ProductGroupId/ProductGroupName</td>
</tr>
<tr>
<td>ItemNumber</td>
<td>The unique ID for the existing sales catalog product (item number) record in the destination table</td>
<td>The value provided must match the value in the ITEM_NUMBER column of the EGP_SYSTEM_ITEMS_B table.</td>
<td>Conditionally required, when you don’t provide the ProductName and ProductGroupId/ProductGroupName</td>
<td>Conditionally required, when you don’t provide the ProductName and ProductGroupId/ProductGroupName</td>
</tr>
<tr>
<td>LeadNumber</td>
<td>Leads Public Unique Identifier value</td>
<td>The value provided must match the value in the LEAD_NUMBER column of the MKL_LM_LEADS table.</td>
<td>Conditionally required, when you don’t provide the LeadId</td>
<td>Conditionally required, when you don’t provide the LeadId</td>
</tr>
<tr>
<td>PrimaryFlag</td>
<td>Indicates whether the product or product group is the primary product of interest for the lead</td>
<td>The value must be either Y or N.</td>
<td>Conditionally required, as at least one product or product group for a lead has this value set to Y</td>
<td>Conditionally required, as at least one product or product group for a lead has this value set to Y</td>
</tr>
<tr>
<td>ProductGroupName</td>
<td>Internal name for the sales catalog product group</td>
<td>The value provided must match the value in the INTERNAL_NAME column of the QSC_PROD_GROUPS_B table.</td>
<td>Conditionally required, when you don’t provide the ProductGroupId/ProductName</td>
<td>Conditionally required, when you don’t provide the ProductGroupId/ProductName</td>
</tr>
<tr>
<td>ProductGroupId</td>
<td>The unique ID for the existing product group record in the destination table</td>
<td>The value provided must match the value in the PROD_GROUP_ID column of the QSC_PROD_GROUPS_B table.</td>
<td>Conditionally required, when you don’t provide the ProductGroupName and ItemId/ProductName</td>
<td>Conditionally required, when you don’t provide the ProductGroupName and ItemId/ProductName</td>
</tr>
<tr>
<td>ProductGroupName</td>
<td>The internal name for the sales catalog product group</td>
<td>The value provided must match the value in the INTERNAL_NAME column of the QSC_PROD_GROUPS_B table.</td>
<td>Conditionally required, when you don’t provide the ProductGroupId/ProductName</td>
<td>Conditionally required, when you don’t provide the ProductGroupId/ProductName</td>
</tr>
<tr>
<td>ProductName</td>
<td>The internal name for the sales catalog product</td>
<td>The value provided must be defined for the sales catalog specified for the QSC_SALES_PRODUCTS_</td>
<td>Conditionally required, when you don’t provide the ItemId</td>
<td>Conditionally required, when you don’t provide the ItemId</td>
</tr>
</tbody>
</table>
Go to Navigator > Tools > Import Management > Import Objects, to see all the attributes of the sales lead product object. The page also lists attribute information like type, length, description, and so on.

**Create the Source CSV File**

You include the data that you want to import into CX Sales and B2B Service in a source CSV file. You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator > Tools > Import Management > Import Objects.
2. Select the Sales Lead Product object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

**Note:** For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.

**Create the Import Activity**

After you have the CSV file ready, create an import activity to import the sales lead product information. To create an import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Sales Lead Product from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

**Review the Import Results**

Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed. You can drill down on the import activity to go to the Import Status page which provides the status details of the import activity.
**Import Your Sales Lead Resource Data**

You can use the Import Management to create, update, or delete sales lead resource records.

You can import sales lead resource records using these steps:

1. Map your source sales lead resource data to Oracle Applications Cloud object attributes. This way the import process would know where to insert each of the information bits.
2. Create the source CSV file with the sales lead resource data you want to import.
4. Check the import results to know if the import went well.

**How You Map Your Source Data to Target Object Attributes**

To import your sales lead resource data into Oracle Applications Cloud, you must populate a .csv file with your source data and map that source data to target object attributes in Oracle Applications Cloud.

You must do the following before creating the .csv file for data import:

- Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
- Ensure prerequisite steps are complete, such as understanding what attributes are required for importing your objects.
- Understand your options for uniquely identifying the records.
- Ensure parent records exist before importing child records.
- Identify the target object attributes that are required in the .csv file for a successful import.

**Before You Start**

You must do some basic checks before starting your import. For example, make sure that:

- You have completed all the prerequisites for importing each attribute in your source data.
- You have all parent records in place before importing child records.

**Select a Unique Identifier for Your Records**

All records must be unique in the application. You can use one of these to identify records:

- Public unique identifiers: If you’re creating records, then you can provide an easily understandable public unique identifier. These are, usually, denoted with ‘Number’ and visible in the business object’s UI. PUID attributes are usually named `<object> Number`. If you’re updating a record with a Number attribute, then use...
the Number attribute to identify the record. For more information about public unique identifiers, see the topic "How You Use Alternate Keys to Import Records" in Related Topics section.

- Source system and source system reference: Source system is an identifier for the external system, and source system reference is a unique identifier within the external system. If you're importing new sales lead resources or are updating sales lead resources that have source system reference data, then provide the source system and source system reference values.

### Required Attributes and Validations for Sales Lead Resource Object

To import data successfully into Oracle Applications Cloud, your .csv file must include the required attributes. Ensure that you provide valid values for the attributes.

This table lists the required attributes for sales lead resource records, prerequisite setup tasks and specific validations, if any:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/ Import Validations</th>
<th>Creating a Sales Lead Resource record</th>
<th>Updating an Existing Sales Lead Resource record</th>
</tr>
</thead>
<tbody>
<tr>
<td>LeadId</td>
<td>The unique ID for the existing lead record in the destination table</td>
<td>The value provided must match the value in the LEAD_ID column of the MKL_LM_LEADS table.</td>
<td>Conditionally required, when you don't provide the LeadNumber</td>
<td>Conditionally required, when you don't provide the LeadNumber</td>
</tr>
<tr>
<td>LeadNumber</td>
<td>The Lead's Public Unique Identifier value</td>
<td>The value provided must match the value in the LEAD_NUMBER column of the MKL_LM_LEADS table.</td>
<td>Conditionally required, when you don't provide the LeadId</td>
<td>Conditionally required, when you don't provide the LeadId</td>
</tr>
<tr>
<td>LeadOrigSystem</td>
<td>The code that identifies the original source system for the sales lead</td>
<td>If providing a value and importing a new sales lead in the same import as this lead resource association, the value must be part of a unique combination of the source system reference (LeadOrigSystemReference) and the source system code (LeadOrigSystem) in the MKT_IMP_LEADS_T table.</td>
<td>Conditionally required, when the lead is created in the same batch as adding a new team member</td>
<td>Not required</td>
</tr>
<tr>
<td>LeadOrigSystemReference</td>
<td>The ID that identifies the original source system reference for the sales lead</td>
<td>If providing a value and importing a new sales lead in the same import as this lead resource association, the value must be part of a unique combination of the source system reference (LeadOrigSystemReference) and the source system code (LeadOrigSystem) in the MKT_IMP_LEADS_T table.</td>
<td>Conditionally required, when the lead is created in the same batch as adding a new team member</td>
<td>Not required</td>
</tr>
<tr>
<td>LeadResourceId</td>
<td>The unique ID for the existing sales team member (resource)</td>
<td>Automatically generated by the import process</td>
<td>Automatically generated by the import process if creating a new record</td>
<td>Required</td>
</tr>
</tbody>
</table>
## Attribute

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/Import Validations</th>
<th>Creating a Sales Lead Resource record</th>
<th>Updating an Existing Sales Lead Resource record</th>
</tr>
</thead>
<tbody>
<tr>
<td>ResourceId</td>
<td>The unique ID for the existing resource's party record in the destination table</td>
<td>Provided value must match with PARTY_ID column of HZ_PARTIES table.</td>
<td>Conditionally required, when you don't provide the resource's source system and source system reference or the resource's user name.</td>
<td>Conditionally required, when you don't provide the unique ID for the record or the resource's source system and source system reference.</td>
</tr>
<tr>
<td>ResourceOrigSys</td>
<td>The source system code that identifies the original source system of the lead sales team members party</td>
<td>If providing a value, the combination of source system reference (ResourceOrigSysRef) and source system code (ResourceOrigSys) must exist in the columns ORIG_SYSTEM_REFERENCE and ORIG_SYSTEM of the HZ_ORIG_SYS_REFERENCES table.</td>
<td>Conditionally required, when you don't provide the resource's party ID (ResourceId)</td>
<td>Conditionally required, when you don't provide the unique ID for the record (LeadResourceId) or the resource's party ID (ResourceId)</td>
</tr>
<tr>
<td>ResourceOrigSysRef</td>
<td>The ID that identifies the lead sales team member's party in your legacy or external system</td>
<td>If providing a value, the combination of source system reference (ResourceOrigSysRef) and source system code (ResourceOrigSys) must exist in the columns ORIG_SYSTEM_REFERENCE and ORIG_SYSTEM of the HZ_ORIG_SYS_REFERENCES table.</td>
<td>Conditionally required, when you don't provide the resource's party ID (ResourceId)</td>
<td>Conditionally required, when you don't provide the unique ID for the record (LeadResourceId) or the resource's party ID (ResourceId)</td>
</tr>
<tr>
<td>UserName</td>
<td>The resources application user name.</td>
<td>No validation</td>
<td>Conditionally required, when you don't provide the resource's source system and source system reference or the resource's unique ID</td>
<td>Not required</td>
</tr>
<tr>
<td>PrimaryFlag</td>
<td>Indicates whether the resource is the Owner of the lead</td>
<td>The value must be either Y or N.</td>
<td>Conditionally required, as at least one contact for a lead has this value set to Y</td>
<td>Conditionally required, as at least one contact for a lead has this value set to Y</td>
</tr>
</tbody>
</table>

Go to Navigator > Tools > Import Management > Import Objects, to see all the attributes of the sales lead resource object. The page also lists attribute information like type, length, description, and so on.

### Create the Source CSV File

You include the data that you want to import into CX Sales and B2B Service in a source CSV file.
You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator > Tools > Import Management > Import Objects.
2. Select the Sales Lead Resource object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

**Note:** For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.

### Create the Import Activity

After you have the CSV file ready, create an import activity to import the sales lead resource information. To create an import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Sales Lead Resource from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

### Review the Import Results

Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed. You can drill down on the import activity to go to the Import Status page which provides the status details of the import activity.

### Related Topics

- Potential Issues When Opening CSV Files in Excel
- How You Use Alternate Keys to Import Records
- Import Data

### Import Your Sales Objective Data

You can use the Import Management to create or update Sales Objective records.

To import Sales Objective records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (.csv) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes

To import your Sales Objective data into Oracle Applications Cloud, you need to populate a CSV file with your source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the .CSV file for data import:

- Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
- Ensure prerequisite steps are complete, such as understanding what attributes are required for importing your objects.
- Understand your options for uniquely identifying the records.
- Ensure parent records exist before importing child records.
- Identify the target object attributes that are required in the .CSV file for a successful import.

Before You Start

You must do some basic checks before starting your import. For example, make sure that:

- You have completed all the prerequisites for importing each attribute in your source data.
- You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records

To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the import process to uniquely identify the records. The file import process uses the attribute values to automatically map your source data to the target object attributes in Oracle Applications Cloud.

The preferred options to uniquely identify an object record are as follows:

- **Internal ID**: If you’re identifying a record that already exists in Oracle Applications Cloud, then you can use the internal ID of the record, a system-generated unique identifier. Attributes with "id" in the attribute name are typically internal IDs. You can determine the internal ID of a record by exporting Oracle Applications Cloud object data, or by doing a transactional database query. Using an internal ID typically provides better performance and reduces the import duration. For the Sales Objective object, this attribute is ObjectiveId:

- **Public unique identifiers**: If you’re creating new records, then you can provide a user-friendly public unique identifier (attributes denoted with ‘Number’ and usually visible in the business object’s UI). If you update a record for which you have previously provided a Number attribute, or for which a Number attribute is visible in the object’s UI, you can use the Number attribute to identify the record. For the Sales Objective object, the attribute is ObjectiveNumber.

Required Attributes and Validations for Sales Objective Object

To import data successfully into Oracle Applications Cloud, your .CSV file must include the required attributes. Ensure that you provide valid values for the attributes.

This table lists the required attributes for importing new Sales Objective records, required attributes for updating Sales Objective records, prerequisite setup tasks for the attributes, and specific validations, if any, for Sales Objective import:
<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Data Type</th>
<th>Data Length</th>
<th>Prerequisite</th>
<th>Creating a Sales Objective record</th>
<th>Updating an Existing Sales Objective record</th>
</tr>
</thead>
<tbody>
<tr>
<td>ObjectiveTypeCode</td>
<td>Stores the type of the objective</td>
<td>String</td>
<td>30</td>
<td>Required</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td>PeriodTypeCode</td>
<td>Specifies the type of period such as quarter or year</td>
<td>String</td>
<td>30</td>
<td>Required</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td>Name</td>
<td>Objective Name</td>
<td>String</td>
<td>60</td>
<td>No validation</td>
<td>Required</td>
<td>Not Required</td>
</tr>
<tr>
<td>StartDisplayPeriodName</td>
<td>Objective Start Period Display Name</td>
<td>String</td>
<td>60</td>
<td>No validation</td>
<td>Required</td>
<td>Not Required</td>
</tr>
<tr>
<td>EndDisplayPeriodName</td>
<td>Objective End Period Display Name</td>
<td>String</td>
<td>60</td>
<td>No validation</td>
<td>Required</td>
<td>Not Required</td>
</tr>
<tr>
<td>ObjectiveId</td>
<td>Internal unique identifier</td>
<td>Long</td>
<td>18</td>
<td>No validation</td>
<td>Not required</td>
<td>A value is required, if you don't provide the PUID.</td>
</tr>
<tr>
<td>ObjectiveNumber</td>
<td>Public unique identifier</td>
<td>String</td>
<td>64</td>
<td>No validation</td>
<td>Not required</td>
<td>A value is required, if you don't provide the ObjectiveID.</td>
</tr>
</tbody>
</table>

You can view the Sales Objective object along with all its child objects and attributes in the Manage Import Objects page of the Import Management flow. You can find attribute information like type, length, description, and so on, on this page.
Chapter 8
Import Your Data

Create the Source CSV File

You include the data that you want to import into Oracle Application Cloud in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator > Tools > Import Management > Import Objects.
2. Select the Sales Objective object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

**Note:** For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity

To import data into Oracle Application Cloud, you need to create an import activity and provide the CSV file as an input to the activity.

To create an import activity, do the following:

1. In the Navigator, under Tools, click Import Management.
2. On the Manage Imports page, click Create Import Activity.
3. In the Create Import Activity: Enter Import Options page, provide a name for the import activity, and select Objective from the Object drop-down list.
4. In File Name, browse and upload the required .CSV file, and click Next.
5. In the Create Import Activity: Map Fields page, edit the attribute mappings if required, and click Next.
   **Note:** Click Validate Data to validate the mapping of the source file for unmapped columns and to check for data format issues.
6. In the Create Import Activity: Review and Submit page, click Submit.

Review the Import Results

You can review the import results by checking for the import activity in the Manage Import Activity page. A file import activity is said to be successful when its status displays as Completed. To check the status of the import activity, do as follows:

1. In the Navigator, under Tools, click Import Management.
2. On the Manage Imports page, search for the import activity that you created using one of the search criteria, such as status, name, object, and so on.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed. The other valid values for the import activity status are Queued for import, Preparing data for import, Importing data, Completed with errors, and Unsuccessful.

**Note:** On this page you can also quickly view the number and status of all active imports, completed imports, and unsuccessful imports that have been submitted.
Related Topics
  • Potential Issues When Opening CSV Files in Excel
  • Import Data

Import Your Sales Promotion Data

You can use the Import Management to create or update Sales Promotion records.

To import Sales Promotion records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (.csv) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes

To import your Sales Promotion Setup data into Oracle Applications Cloud, you need to populate a CSV file with your source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the .CSV file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
• Ensure prerequisite steps are complete, such as understanding what attributes are required for importing your objects.
• Understand your options for uniquely identifying the records.
• Ensure parent records exist before importing child records.
• Identify the target object attributes that are required in the .CSV file for a successful import.

Before You Start

You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.
• You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records

To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the import process to uniquely identify the records. The file import process uses the attribute values to automatically map your source data to the target object attributes in Oracle Applications Cloud.

The preferred options to uniquely identify an object record are as follows:

• **Internal ID**: If you’re identifying a record that already exists in Oracle Applications Cloud, then you can use the internal ID of the record, a system-generated unique identifier attributes with "ID" in the attribute name are typically internal IDs. You can determine the internal ID of a record by exporting Oracle Applications
Cloud object data, or by doing a transactional database query. Using an internal ID typically provides better performance and reduces the import duration. For the Promotion object, this attribute is SalesPromotionId.

- **Public unique identifiers**: If you’re creating new records, then you can provide a user-friendly public unique identifier (attributes denoted with ‘Number’ and usually visible in the business object’s UI). If you update a record for which you have previously provided a Number attribute, or for which a Number attribute is visible in the object’s UI, you can use the Number attribute to identify the record. For the Promotion object, the attribute is SalesPromotionCode.

## Required Attributes and Validations for Sales Promotion Object

To import data successfully into Oracle Applications Cloud, your .CSV file must include the required attributes. Ensure that you provide valid values for the attributes.

This table lists the required attributes for importing new Sales Promotion records, required attributes for updating Sales Promotion records, prerequisite setup tasks for the attributes, and specific validations, if any, for Sales Promotion import:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Data Type</th>
<th>Data Length</th>
<th>Prerequisite Setup Task/Import Validations</th>
<th>Creating a Sales Promotion Record</th>
<th>Updating an Existing Sales Promotion Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>StatusCode</td>
<td>A unique identifier for the current status of the sales promotion</td>
<td>String</td>
<td>30</td>
<td>Accepts either ACTIVE or INACTIVE</td>
<td>This defaults to Active status.</td>
<td>Optional</td>
</tr>
<tr>
<td>AdjustmentTypeCode</td>
<td>Abbreviation that identifies the type of manual price adjustment</td>
<td>String</td>
<td>30</td>
<td>Accepts either LNDISCPERC or LNDISCAMT</td>
<td>This defaults to LNDISCPERC.</td>
<td>Optional</td>
</tr>
<tr>
<td>SalesPromotionId</td>
<td>The unique identifier of the sales promotion</td>
<td>Long</td>
<td>18</td>
<td>No validation</td>
<td>This is auto generated.</td>
<td>Required</td>
</tr>
<tr>
<td>Name</td>
<td>The name of the sales promotion</td>
<td>String</td>
<td>150</td>
<td>Enter a unique value.</td>
<td>Required</td>
<td>Optional</td>
</tr>
<tr>
<td>SalesPromotionCode</td>
<td>The code indicating the type of the sales promotion. This value is generated when a sales promotion is created.</td>
<td>String</td>
<td>80</td>
<td>No validation</td>
<td>This is auto generated.</td>
<td>Required</td>
</tr>
<tr>
<td>AdjustmentBasisCode</td>
<td>The code indicating the basis of the sales promotion adjustment when the adjustment</td>
<td>String</td>
<td>30</td>
<td>Accepts either LISTPRICE or NETPRICE</td>
<td>Defaults to LISTPRICE.</td>
<td>Optional</td>
</tr>
</tbody>
</table>
### Attribute | Description | Data Type | Data Length | Prerequisite Setup Task/Import Validations | Creating a Sales Promotion Record | Updating an Existing Sales Promotion Record
---|---|---|---|---|---|---
Description | A brief description of the sales promotion | String | 1999 | No validation | Not required | Optional
StartDate | The date and time at which the sales promotion is available | Date | | Start date can’t be later than the end date. | Not required | Optional
EndDate | The date and time up to which the sales promotion is available | Date | | Start date can’t be later than the end date. | Not required | Optional
AdjustmentValue | The value of the sales promotion adjustment | BigDecimal | | A value is mandatory if the status is set to ACTIVE. | A value is required if the status is Active. | Optional
CurrencyCode | The currency code of the sales promotion adjustment when the adjustment type is “Amount” | String | 15 | A value is mandatory if the AdjustmentTypeCode is LNDISCAMT. | A value is required if the AdjustmentTypeCode is LNDISCAMT. | Optional

You can view the Promotion object along with all its child objects and attributes in the **Manage Import Objects** page of the **Import Management** flow. You can find attribute information like type, length, description, and so on, on this page.

### Create the Source CSV File
You include the data that you want to import into CX Sales and B2B Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to **Navigator > Tools > Import Management > Import Objects**.
2. Select the **Sales Promotion** object in the table and click **Download**.

You can now edit the downloaded file and provide valid values for the required attributes.

**Note:** For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.
Create the Import Activity

To import data into Oracle Applications Cloud, you need to create an import activity and provide the CSV file as an input to the activity.

To create an import activity, do the following:

1. In the Navigator, under **Tools**, click **Import Management**.
2. On the **Manage Imports** page, click **Create Import Activity**.
3. In the **Create Import Activity: Enter Import Options** page, provide a name for the import activity, and select **Promotion** from the **Object** drop-down list.
4. In **File Name**, browse and upload the required .CSV file, and click **Next**.
5. In the **Create Import Activity: Map Fields** page, edit the attribute mappings if required, and click **Next**.
   
   **Note:** Click **Validate Data** to validate the mapping of the source file for unmapped columns and to check for data format issues.

6. In the **Create Import Activity: Review and Submit** page, click **Submit**.

Review the Import Results

Check if your import succeeded on the **Manage Imports** page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to **Navigator > Tools > Import Management > Import Queue**.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the **Status** column for the import activity. The import is successful if the status displays as **Completed**. You can drill down on the import activity to go to the **Import Status** page which provides the status details of the import activity.

Related Topics

- Potential Issues When Opening CSV Files in Excel
- Import Data

Import Your Sales Resource Period Quota Data

You can use the import functionality to create or update Sales Resource Period Quota records.

You can import Sales Resource Period Quota records using these steps:

1. Map your source data to Oracle Applications Cloud object attributes. This way the import process would know where to insert each of the information bits.
2. Create the source CSV file with the Sales Resource Period Quota data you want to import.
4. Check the import results to know if the import went well.

How You Map Your Source Data to Target Object Attributes

You import Sales Resource Period Quota data into Oracle Applications Cloud from a CSV file containing your source data that's mapped to target Oracle Applications Cloud object attributes.
Before you create the source data file, you should:

- Know how your source data attributes map to the target object attributes in Oracle Applications Cloud. Match each column from the source file to an attribute in the Sales Resource Period Quota import object.
- Finish all prerequisite steps, such as understanding what attributes are required for importing your objects.
- Know how you can uniquely identify the records.
- Check the target object attributes required in the CSV file for a successful import.
- Ensure that you don't insert duplicate Sales Resource Period Quota while importing, to avoid redundant data.

**Before You Start**

You must do some basic checks before starting your import. For example, make sure that:

- You have completed all the prerequisites for importing each attribute in your source data.
- You have all parent records in place before importing child records.

**Select a Unique Identifier for Your Records**

All records must be unique in the application. You can use one of these to identify records:

- Public unique identifiers: You can't create Sales Resource Period Quota records. If you're updating records, then you can provide an easily understandable public unique identifier. These are, usually, denoted with 'Number' and visible in the business object's UI. PUID attributes are usually named <object> Number. If you're updating a record with a Number attribute, then use the Number attribute to identify the record. For more information about public unique identifiers, see the topic "How You Use Alternate Keys to Import Records" in Related Topics section.
- Source system and source system reference: Source system is an identifier for the external system, and source system reference is a unique identifier within the external system. If you're importing new Sales Resource Period Quotas or are updating Sales Resource Period Quotas that have source system reference data, then provide the source system and source system reference values.

**Required Attributes and Validations for Sales Resource Period Quota Object**

To import data successfully into Oracle Applications Cloud, your .CSV file must include the required attributes. Ensure that you provide valid values for the attributes.

This table lists the required attributes for Sales Resource Period Quota records, prerequisite setup tasks and specific validations, if any:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/ Import Validations</th>
<th>Creating a Sales Resource Period Quota record</th>
<th>Updating an Existing Sales Resource Period Quota record</th>
<th>Deleting an Existing Sales Resource Period Quota record</th>
</tr>
</thead>
<tbody>
<tr>
<td>QuotaPlanName</td>
<td>Name of the Quota Plan</td>
<td>Quota plan has to be in Active status and tracked. The territory should be non-excluded and not published.</td>
<td>Required</td>
<td>Required</td>
<td>Required</td>
</tr>
<tr>
<td>Attribute</td>
<td>Description</td>
<td>Prerequisite Setup Task/ Import Validations</td>
<td>Creating a Sales Resource Period Quota record</td>
<td>Updating an Existing Sales Resource Period Quota record</td>
<td>Deleting an Existing Sales Resource Period Quota record</td>
</tr>
<tr>
<td>-------------------------</td>
<td>-----------------------------------------------------------------------------</td>
<td>----------------------------------------------</td>
<td>-----------------------------------------------</td>
<td>--------------------------------------------------------</td>
<td>--------------------------------------------------------</td>
</tr>
<tr>
<td>TerritoryNumber</td>
<td>Territory number for which data is imported</td>
<td>Required</td>
<td>Required</td>
<td>Required</td>
<td>Required</td>
</tr>
<tr>
<td>GoalNumber</td>
<td>The public unique identifier of the goal</td>
<td>Required</td>
<td>Required</td>
<td>Required</td>
<td>Required</td>
</tr>
<tr>
<td>PeriodName</td>
<td>The period for which data is imported</td>
<td>Not applicable</td>
<td>Not applicable</td>
<td>Not updatable</td>
<td>Not required</td>
</tr>
<tr>
<td>ResourcePeriodQuota</td>
<td>The quota value to be imported</td>
<td>Not applicable</td>
<td>This is updatable, if the Territory Quota is in &quot;Not Published&quot; status.</td>
<td>Not required</td>
<td></td>
</tr>
<tr>
<td>ResourceEmail</td>
<td>This is the territory resource's email address for which you need to set the quota.</td>
<td>Required</td>
<td>Required</td>
<td>Required</td>
<td>Required</td>
</tr>
</tbody>
</table>

Go to **Navigator > Tools > Import Management > Import Objects**, to see all the attributes of the Sales Resource Period Quota object. The page also lists attribute information like type, length, description, and so on.

**Create the Source CSV File**

You include the data that you want to import into CX Sales and B2B Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to **Navigator > Tools > Import Management > Import Objects**.
2. Select the Sales Resource Period Quota object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

**Note:** For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.
Create the Import Activity

After you have the CSV file ready, create an import activity to import the Sales Resource Period Quota information. To create an import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. On the Manage Imports page, click Create Import Activity.
3. In the Create Import Activity: Enter Import Options page, provide a name for the import activity, and select Sales Resource Period Quota from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results

Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed. You can drill down on the import activity to go to the Import Status page which provides the status details of the import activity.

Related Topics

• How You Use Alternate Keys to Import Records
• Potential Issues When Opening CSV Files in Excel
• Import Data

Import Your Sales Resource Quota Data

You can use the import functionality to create or update Sales Resource Quota records.

You can import Sales Resource Quota records using these steps:

1. Map your source data to Oracle Applications Cloud object attributes. This way the import process would know where to insert each of the information bits.
2. Create the source CSV file with the Sales Resource Quota data you want to import.
4. Check the import results to know if the import went well.

How You Map Your Source Data to Target Object Attributes

You import Sales Resource Quota data into Oracle Applications Cloud from a CSV file containing your source data that's mapped to target Oracle Applications Cloud object attributes.
Before you create the source data file, you should:

- Know how your source data attributes map to the target object attributes in Oracle Applications Cloud. Match each column from the source file to an attribute in the Sales Resource Quota import object.
- Finish all prerequisite steps, such as understanding what attributes are required for importing your objects.
- Know how you can uniquely identify the records.
- Check the target object attributes required in the CSV file for a successful import.
- Ensure that you don’t insert duplicate Sales Resource Quota while importing, to avoid redundant data.

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

- You have completed all the prerequisites for importing each attribute in your source data.
- You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
All records must be unique in the application. You can use one of these to identify records:

- Public unique identifiers: You can't create Sales Resource Quota records. If you're updating records, then you can provide an easily understandable public unique identifier. These are, usually, denoted with 'Number' and visible in the business object’s UI. PUID attributes are usually named <object> Number. If you’re updating a record with a Number attribute, then use the Number attribute to identify the record. For more information about public unique identifiers, see the topic "How You Use Alternate Keys to Import Records" in Related Topics section.
- Source system and source system reference: Source system is an identifier for the external system, and source system reference is a unique identifier within the external system. If you're importing new Sales Resource Quotas or are updating Sales Resource Quotas that have source system reference data, then provide the source system and source system reference values.

Required Attributes and Validations for Sales Resource Quota Object
To import data successfully into Oracle Applications Cloud, your .CSV file must include the required attributes. Ensure that you provide valid values for the attributes.

This table lists the required attributes for Sales Resource Quota records, prerequisite setup tasks and specific validations, if any:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task / Import Validations</th>
<th>Creating a Sales Resource Quota record</th>
<th>Updating an Existing Sales Resource Quota record</th>
<th>Deleting an Existing Sales Resource Quota record</th>
</tr>
</thead>
<tbody>
<tr>
<td>QuotaPlanName</td>
<td>Name of the Quota Plan</td>
<td>Quota plan has to be in Active status and tracked. The</td>
<td>Required</td>
<td>Required</td>
<td>Required</td>
</tr>
</tbody>
</table>
### Create the Source CSV File

You include the data that you want to import into CX Sales and B2B Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to **Navigator > Tools > Import Management > Import Objects**.
2. Select the Sales Resource Quota object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

**Note:** For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.

---

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/ Import Validations</th>
<th>Creating a Sales Resource Quota record</th>
<th>Updating an Existing Sales Resource Quota record</th>
<th>Deleting an Existing Sales Resource Quota record</th>
</tr>
</thead>
<tbody>
<tr>
<td>TerritoryNumber</td>
<td>Territory number for which data is imported</td>
<td>The territory must exist. It must be non-excluded and not published.</td>
<td>Note: When you create a Sales Resource Quota record, the corresponding Sales Resource Period quota record also gets created.</td>
<td></td>
<td>Note: When you delete a Sales Resource Quota record, the corresponding Sales Resource Period quota record also gets deleted.</td>
</tr>
<tr>
<td>GoalNumber</td>
<td>The public unique identifier of the goal</td>
<td>When creating a sales resource quota record, the goal should be in Active status.</td>
<td>Required</td>
<td>Required</td>
<td>Required</td>
</tr>
<tr>
<td>ResourceQuota</td>
<td>Quota value to be imported for a territory resource</td>
<td>This must be greater than or equal to zero.</td>
<td>This can't be created for the owner with Sales Revenue Goal (GOAL_1000).</td>
<td>This can't be deleted for the owner with Sales Revenue Goal (GOAL_1000).</td>
<td>Not required</td>
</tr>
<tr>
<td>ResourceEmail</td>
<td>This is the territory resource's email address for which you need to set the quota.</td>
<td>It should be a valid email address of the territory resource.</td>
<td>Required</td>
<td>Required</td>
<td>Required</td>
</tr>
</tbody>
</table>

Go to **Navigator > Tools > Import Management > Import Objects**, to see all the attributes of the Sales Resource Quota object. The page also lists attribute information like type, length, description, and so on.
Create the Import Activity

After you have the CSV file ready, create an import activity to import the Sales Resource Quota information. To create an import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. On the Manage Imports page, click Create Import Activity.
3. In the Create Import Activity: Enter Import Options page, provide a name for the import activity, and select Sales Resource Quota from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you’re ready.

Review the Import Results

Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed. You can drill down on the import activity to go to the Import Status page which provides the status details of the import activity.

Related Topics
- How You Use Alternate Keys to Import Records
- Potential Issues When Opening CSV Files in Excel

Import Your Sales Team Member Data

You can use Import Management to create or update sales team member records.

You can import sales team member records using these steps:

1. Map your source data to Oracle Applications Cloud object attributes. This way the import process would know where to insert each of the information bits.
2. Create the source CSV file with the sales team member data you want to import.
4. Check the import results to know if the import went well.

How You Map Your Source Data to Target Object Attributes

You import sales team member data into Oracle Applications Cloud from a CSV file containing your source data that’s mapped to target Oracle Applications Cloud object attributes.
Oracle CX
Understanding Import and Export Management for CX
Sales and B2B Service

Chapter 8
Import Your Data

Before you create the source data file, you should:

- Know how your source data attributes map to the target object attributes in Oracle Applications Cloud. Match each column from the source file to an attribute in the sales team member import object.
- Finish all prerequisite steps, such as understanding what attributes are required for importing your objects.
- Know how you can uniquely identify the records.
- Check the target object attributes required in the CSV file for a successful import.
- Ensure that you don’t insert duplicate sales team member while importing, to avoid redundant data.

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

- You have completed all the prerequisites for importing each attribute in your source data.
- You have all parent records in place before importing child records. Also ensure that the parent records, such as accounts, are in active status.

Select a Unique Identifier for Your Records
All records must be unique in the application. You can use one of these to identify records:

- Public unique identifiers: If you’re creating records, then you can provide an easily understandable public unique identifier. These are, usually, denoted with ‘Number’ and visible in the business object’s UI. PUID attributes are usually named <object> Number. If you’re updating a record with a Number attribute, then use the Number attribute to identify the record. For more information about public unique identifiers, see the topic "How You Use Alternate Keys to Import Records" in Related Topics section.
- Source system and source system reference: Source system is an identifier for the external system, and source system reference is a unique identifier within the external system. If you’re importing new Sales Team Members or are updating Sales Team Members that have source system reference data, then provide the source system and source system reference values.

Required Attributes and Validations for Sales Team Member Object
To import data successfully into Oracle Applications Cloud, your .CSV file must include the required attributes. Ensure that you provide valid values for the attributes.

This table lists the required attributes for sales team member records, prerequisite setup tasks and specific validations, if any:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/Import Validations</th>
<th>Creating a Sales Team Member record</th>
<th>Updating an Existing Sales Team Member record</th>
</tr>
</thead>
<tbody>
<tr>
<td>TeamMemberId</td>
<td>Sales Team Member ID. This is the primary key.</td>
<td>N/A</td>
<td>N/A</td>
<td>If available, provide this to update other attributes.</td>
</tr>
<tr>
<td>SalesProfileID</td>
<td>Sales Profile ID</td>
<td>Active SalesProfileID to have been created already.</td>
<td>Conditionally required To be provided if none of the following are available: Conditionally required To be provided if TeamMemberID isn't available. To be provided</td>
<td></td>
</tr>
</tbody>
</table>
### Attribute

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/Import Validations</th>
<th>Creating a Sales Team Member record</th>
<th>Updating an Existing Sales Team Member record</th>
</tr>
</thead>
<tbody>
<tr>
<td>PartyID</td>
<td>Sales Account ID</td>
<td>N/A</td>
<td>Conditionally required To be provided if SalesProfileID isn't available.</td>
<td>Conditionally required To be provided if TeamMemberID or SalesProfileID isn't available. To be provided along with ResourceID or ResourcePartyNumber or ResourceEmailAddress.</td>
</tr>
<tr>
<td>PartySourceSystem</td>
<td>Party source system of the Sales account</td>
<td>N/A</td>
<td>Conditionally required To be provided if SalesProfileID isn't available. To be provided along with PartySourceSystemReference.</td>
<td>Conditionally required To be provided if TeamMemberID or SalesProfileID or PartyID isn't available. To be provided along with ResourceID or ResourcePartyNumber or ResourceEmailAddress.</td>
</tr>
<tr>
<td>PartySourceSystemReference</td>
<td>Party source system reference of the Sales account</td>
<td>N/A</td>
<td>Conditionally required To be provided if SalesProfileID isn't available. To be provided with PartySourceSystem.</td>
<td>Conditionally required To be provided if TeamMemberID or SalesProfileID or PartyID isn't available. To be provided along with ResourceID or ResourcePartyNumber or ResourceEmailAddress.</td>
</tr>
<tr>
<td>PartyNumber</td>
<td>Party number of the sales account/PUID</td>
<td>N/A</td>
<td>Conditionally required To be provided if SalesProfileID isn't available.</td>
<td>Conditionally required To be provided if TeamMemberID or SalesProfileID or PartyID isn't available. To be provided along with ResourceID or ResourcePartyNumber or ResourceEmailAddress.</td>
</tr>
<tr>
<td>ResourceID</td>
<td>Resource identifier</td>
<td>Active ResourceID to have been created already.</td>
<td>Conditionally required To be provided if ResourcePartyNumber or ResourceEmailAddress isn't available.</td>
<td>Conditionally required To be provided if TeamMemberID isn't available. To be provided along with SalesProfileID.</td>
</tr>
</tbody>
</table>
### Chapter 8
Import Your Data

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/Import Validations</th>
<th>Creating a Sales Team Member record</th>
<th>Updating an Existing Sales Team Member record</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>or PartyID or PartyNumber or PartySourceSystem along with PartySourceSystemReference.</td>
</tr>
<tr>
<td>ResourcePartyNumber</td>
<td>Resource party number/PUID</td>
<td>N/A</td>
<td>Conditionally required To be provided if ResourceID isn't available.</td>
<td>Conditionally required To be provided if TeamMemberID or ResourceID isn't available. To be provided along with SalesProfileID or PartyID or PartyNumber or PartySourceSystem along with PartySourceSystemReference.</td>
</tr>
<tr>
<td>ResourceEmailAddress</td>
<td>Resource email address</td>
<td>N/A</td>
<td>Conditionally required To be provided if ResourceID isn't available.</td>
<td>Conditionally required To be provided if TeamMemberID or ResourceID or ResourcePartyNumber isn't available. To be provided along with SalesProfileID or PartyID or PartyNumber or PartySourceSystem along with PartySourceSystemReference.</td>
</tr>
</tbody>
</table>

Go to **Navigator > Tools > Import Management > Import Objects**, to see all the attributes of the sales team member object. The page also lists attribute information like type, length, description, and so on.

### Create the Source CSV File

You include the data that you want to import into CX Sales and B2B Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to **Navigator > Tools > Import Management > Import Objects**.
2. Select the sales team member object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

**Note:** For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.
Create the Import Activity

After you have the CSV file ready, create an import activity to import the sales team member information. To create an import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. On the Manage Imports page, click Create Import Activity.
3. In the Create Import Activity: Enter Import Options page, provide a name for the import activity, and select Sales Team Member from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you’re ready.

Review the Import Results

Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to Go to Navigator > Tools > Import Management > Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed. You can drill down on the import activity to go to the Import Status page which provides the status details of the import activity.

Related Topics
- How You Use Alternate Keys to Import Records
- Potential Issues When Opening CSV Files in Excel

Import Your Sales Territory Data

You can use Import Management to create, update or delete Sales Territory records.

To import Sales Territory records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Object Attributes

To import your Sales Territory data into Oracle Applications Cloud, you must populate a .csv file with your source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

- Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
• Ensure prerequisite setups are done, if applicable.
• Understand your options for uniquely identifying the records.
• Ensure parent records exist before importing child records.
  ◦ When creating a territory, the sales territory import file must be imported before importing the sales territory resource, sales territory coverage, or sales territory line of business import files.
• Identify the target object attributes that are required in the CSV file for a successful import.

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.
• You have all parent records in place before importing child records.
• You have created a proposal in the Classic Territories pages, if you want to update territories as part of a proposal. Optionally, you can add territories to update the proposal.

Select a Unique Identifier for Your Records
To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the import process to uniquely identify the records. The file import process uses the attribute values to automatically map your source data to the target object attributes in Oracle Applications Cloud.

The preferred option to uniquely identify an object record is through the Public unique identifier. If you're creating new records, then you can provide a user-friendly public unique identifier (attributes denoted with 'Number' and usually visible in the business object's UI). If you update a record for which you have previously provided a Number attribute, or for which a Number attribute is visible in the object's UI, you can use the Number attribute to identify the record. For the Sales Territory object, the attributes are UniqueTerritoryNumber, ProposalNumber and OwnerResourceNumber.

Required Attributes and Validations for the Sales Territory Object
To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure that you provide valid values for the attributes. The following table lists the required attributes for importing new Sales Territory records, required attributes for updating Sales Territory records, required attributes for deleting Sales Territory records, prerequisite setup tasks for the attributes, and specific validations, if any, for Sales Territory import:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Data Type</th>
<th>Prerequisite Setup Task/Import Validations</th>
<th>Creating a Sales Territory Record</th>
<th>Updating a Sales Territory Record</th>
<th>Deleting an Existing Sales Territory Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>UniqueTerritoryNumber</td>
<td>The public unique identifier number of the territory</td>
<td>Text</td>
<td>Not applicable</td>
<td>Optional</td>
<td>Required</td>
<td>Required</td>
</tr>
<tr>
<td>ProposalNumber</td>
<td>The public unique identifier number of the proposal</td>
<td>Text</td>
<td>Not applicable</td>
<td>A value is required if you're creating a territory that's part of a proposal.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
</tbody>
</table>
### Create the Source CSV File

You include the data that you want to import into CX Sales and B2B Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to **Navigator > Tools > Import Management > Import Objects**.
2. Select the **Sales Territory** object in the table and click **Download**.
You can now edit the downloaded file and provide valid values for the required attributes.

**Note:** For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.

### Create the Import Activity

After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to **Navigator > Tools > Import Management > Import Queue**.
2. Click **Create Import Activity** in the **Manage Imports** page.
3. In the **Enter Import Options** page, provide a name for the import activity, and select Sales Territory from the **Object** drop-down list.
4. Select the CSV file in the **File Name** field, and click **Next**.
5. You would see that the source and target attributes are automatically mapped in the **Map Fields** page. Review and edit the mappings if required.
   - The ParentUniqueTerritoryNumber isn't automatically mapped to the Parent Unique Territory Number. Use the **Save As** option to create a mapping, name the mapping, and map the Parent Unique Territory Number target attribute to the Source File ParentUniqueTerritoryNumber Attribute, by dragging the target attribute to the Attribute Display Name. Select and apply this new import mapping in the Map Fields page of a future sales territory import activity.
6. Check the file for unmapped columns or data format issues by clicking **Validate Data**. Click **Next**.
7. Review the import details on the **Review and Submit** page, and click **Submit** when you're ready.

### Review the Import Results

Check if your import succeeded on the **Manage Imports** page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to **Navigator > Tools > Import Management > Import Queue**.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the **Status** column for the import activity. The import is successful if the status displays as **Completed**. You can drill down on the import activity to go to the **Import Status** page which provides the status details of the import activity.

**Related Topics**
- Potential Issues When Opening CSV Files in Excel
- Import Data

### Import Your Sales Territory Coverage Data

You can use Import Management to create or delete Sales Territory Coverage records.

To import Sales Territory Coverage records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
How You Map Your Source Data to Object Attributes

To import your Sales Territory Coverage data into Oracle Applications Cloud, you must populate a .csv file with your source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

- Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
- Ensure prerequisite setups are done, if applicable.
- Understand your options for uniquely identifying the records.
- Ensure parent records exist before importing child records.
  - When creating a territory, the sales territory import file must be imported before importing the sales territory resource, sales territory coverage or sales territory line of business import files.
- Identify the target object attributes that are required in the CSV file for a successful import.

Before You Start

You must do some basic checks before starting your import. For example, make sure that:

- You have completed all the prerequisites for importing each attribute in your source data.
- You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records

To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the import process to uniquely identify the records. The file import process uses the attribute values to automatically map your source data to the target object attributes in Oracle Applications Cloud.

The preferred option to uniquely identify an object record is through the Public unique identifier. If you’re creating new records, then you can provide the appropriate user-friendly public unique identifiers (attributes denoted with ‘Number’ and usually visible in the business object’s UI). For the Sales Territory Coverage object, the attributes are UniqueTerritoryNumber, CoverageTypeCode and DimensionCode. If you delete a sales territory resource record, you can use a combination of the UniqueTerritoryNumber and CoverageNumber attributes to identify the record. Oracle recommends that you don’t update the Sales Territory Coverage object. For example, to update the AddressCity of the Address (DimensionCode) coverage record, delete the record and create a new record with the correct AddressCity value.

Required Attributes and Validations for Sales Territory Coverage Object

To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure that you provide valid values for the attributes. The following table lists the required attributes for importing new Sales Territory Coverage records, required attributes for deleting Sales Territory Coverage records, prerequisite setup tasks for the attributes, and specific validations, if any, for Sales Territory Coverage import:
## Attribute Table

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Data Type</th>
<th>Prerequisite Setup Task/ Import Validations</th>
<th>Creating a Sales Territory Coverage Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>UniqueTerritoryNumber</td>
<td>The public unique identifier number of the territory</td>
<td>Text</td>
<td>Not applicable</td>
<td>Required</td>
</tr>
<tr>
<td>CoverageNumber</td>
<td>The public unique identifier number of the territory coverage</td>
<td>Text</td>
<td>Not applicable</td>
<td>Don't provide a value.</td>
</tr>
<tr>
<td>CoverageTypeCode</td>
<td>The code of the territory coverage type</td>
<td>Text</td>
<td>Not applicable</td>
<td>Required Values are REGULAR, INCLUSION, and EXCLUSION</td>
</tr>
<tr>
<td>TerrDimensionCode</td>
<td>The code of the dimension</td>
<td>Text</td>
<td>Not applicable</td>
<td>Required if passing the related dimension member information. The values are:</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>• Acct</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>• AcTyp</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>• Addr</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>• Aux1</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>• Aux2</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>• Aux3</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>• Bunit</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>• CSize</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>• Geo</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>• Indst</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>• Prtnr</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>• Prod</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>• OrgTp</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>• Schnl</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>don't provide a value, if creating a dimensional coverage of Any (for every dimension including Address)</td>
</tr>
</tbody>
</table>

Depending on the dimension coverage there may be additional required attributes for importing new Sales Territory Coverage records. The following tables list the required attributes for importing new Sales Territory Coverage records, prerequisite setup tasks for the attributes, and specific validations, if any, for Sales Territory Coverage import:

If the DimensionCode = Acct
<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Data Type</th>
<th>Prerequisite Setup Task/Import Validations</th>
<th>Creating a Sales Territory Coverage Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>RegistryID</td>
<td>The public unique identifier number of the account</td>
<td>Text</td>
<td>Not applicable</td>
<td>Either the RegistryID or the OriginalReference is Required.</td>
</tr>
<tr>
<td>OriginalReference</td>
<td>The original system / original system reference of the account.</td>
<td>Text</td>
<td>Not applicable</td>
<td>Either the RegistryID or the OriginalReference is Required.</td>
</tr>
<tr>
<td>CoverageType</td>
<td>The type of the sales territory coverage.</td>
<td>Text</td>
<td>Not applicable</td>
<td>Either the value INCLUSION or EXCLUSION is Required.</td>
</tr>
<tr>
<td>IncludeHierarchyFlg</td>
<td>An indicator of whether the account hierarchy is included.</td>
<td>Text</td>
<td>Not applicable</td>
<td>Optional. Applicable values Y or N.</td>
</tr>
</tbody>
</table>

**Note:** During import, the application attempts to lookup the account using RegistryID, but if not found it uses OriginalReference. If values for both RegistryID and OriginalReference are passed, then the RegistryID is used first.

If the DimensionCode = Geo

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Data Type</th>
<th>Prerequisite Setup Task/Import Validations</th>
<th>Creating a Sales Territory Coverage Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>GeographyName</td>
<td>The geography name including the hierarchy</td>
<td>Text</td>
<td>Not applicable</td>
<td>Required</td>
</tr>
<tr>
<td>GeographyHighName</td>
<td>The upper level of the geography name range including the hierarchy</td>
<td>Text</td>
<td>Not applicable</td>
<td>Required only if defining a range of geography dimension members</td>
</tr>
</tbody>
</table>

If the DimensionCode = Addr

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Data Type</th>
<th>Prerequisite Setup Task/Import Validations</th>
<th>Creating a Sales Territory Coverage Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>AddressCountry</td>
<td>The code of the address country</td>
<td>Text</td>
<td>Not applicable</td>
<td>Required</td>
</tr>
<tr>
<td>AddressState</td>
<td>The address state</td>
<td>Text</td>
<td>Not applicable</td>
<td>Optional</td>
</tr>
<tr>
<td>AddressProvince</td>
<td>The address province</td>
<td>Text</td>
<td>Not applicable</td>
<td>Optional</td>
</tr>
<tr>
<td>AddressCounty</td>
<td>The address county</td>
<td>Text</td>
<td>Not applicable</td>
<td>Optional</td>
</tr>
</tbody>
</table>
### Import Your Data

#### Attribute Description Data Type Prerequisite Setup Task/Import Validations Creating a Sales Territory Coverage Record

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Data Type</th>
<th>Prerequisite Setup Task/Import Validations</th>
<th>Creating a Sales Territory Coverage Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>AddressCity</td>
<td>The address city</td>
<td>Text</td>
<td>Not applicable</td>
<td>Optional</td>
</tr>
<tr>
<td>AddressPostalCode</td>
<td>The address postal code</td>
<td>Text</td>
<td>Not applicable</td>
<td>Optional</td>
</tr>
<tr>
<td>AddressElementAttribute1</td>
<td>The additional address element 1</td>
<td>Text</td>
<td>Not applicable</td>
<td>Optional</td>
</tr>
<tr>
<td>AddressElementAttribute2</td>
<td>The additional address element 2</td>
<td>Text</td>
<td>Not applicable</td>
<td>Optional</td>
</tr>
<tr>
<td>AddressElementAttribute3</td>
<td>The additional address element 3</td>
<td>Text</td>
<td>Not applicable</td>
<td>Optional</td>
</tr>
<tr>
<td>AddressElementAttribute4</td>
<td>The additional address element 4</td>
<td>Text</td>
<td>Not applicable</td>
<td>Optional</td>
</tr>
<tr>
<td>AddressElementAttribute5</td>
<td>The additional address element 5</td>
<td>Text</td>
<td>Not applicable</td>
<td>Optional</td>
</tr>
</tbody>
</table>

If the DimensionCode = OrgTp

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Data Type</th>
<th>Prerequisite Setup Task/Import Validations</th>
<th>Creating a Sales Territory Coverage Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>OrganizationTypeCode</td>
<td>The code of the organization type</td>
<td>Text</td>
<td>Not applicable</td>
<td>Required</td>
</tr>
</tbody>
</table>

If the DimensionCode = Indst

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Data Type</th>
<th>Prerequisite Setup Task/Import Validations</th>
<th>Creating a Sales Territory Coverage Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>IndustryCode</td>
<td>The code of the industry</td>
<td>Text</td>
<td>Not applicable</td>
<td>Required</td>
</tr>
</tbody>
</table>

If the DimensionCode = Csize

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Data Type</th>
<th>Prerequisite Setup Task/Import Validations</th>
<th>Creating a Sales Territory Coverage Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>CustomerSizeCode</td>
<td>The code of the customer size</td>
<td>Text</td>
<td>Not applicable</td>
<td>Required</td>
</tr>
</tbody>
</table>
If the DimensionCode = AcTyp

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Data Type</th>
<th>Prerequisite Setup Task/Import Validations</th>
<th>Creating a Sales Territory Coverage Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>AccountTypeCode</td>
<td>The named account code</td>
<td>Text</td>
<td>Not applicable</td>
<td>Required</td>
</tr>
</tbody>
</table>

If the DimensionCode = Prod

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Data Type</th>
<th>Prerequisite Setup Task/Import Validations</th>
<th>Creating a Sales Territory Coverage Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>ProductGroupNumber</td>
<td>The public unique identifier number of the product group</td>
<td>Text</td>
<td>Not applicable</td>
<td>Required if creating a sales territory coverage for a product group</td>
</tr>
<tr>
<td>ItemNumber</td>
<td>The public unique identifier number of the item</td>
<td>Text</td>
<td>Not applicable</td>
<td>Required if creating a sales territory coverage for an item</td>
</tr>
<tr>
<td>InventoryOrgId</td>
<td>The identifier of the inventory organization</td>
<td>Number</td>
<td>Not applicable</td>
<td>Required if creating a sales territory coverage for an item, but only when the value is different from the default inventory organization identifier specified in the profile option QSC_SALES_PRODUCTS_INVENTORY_ORG_ID.</td>
</tr>
</tbody>
</table>

If the DimensionCode = BUnit

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Data Type</th>
<th>Prerequisite Setup Task/Import Validations</th>
<th>Creating a Sales Territory Coverage Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>BusinessUnitName</td>
<td>The name of the business unit</td>
<td>Text</td>
<td>Not applicable</td>
<td>Required</td>
</tr>
</tbody>
</table>

If the DimensionCode = Aux1

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Data Type</th>
<th>Prerequisite Setup Task/Import Validations</th>
<th>Creating a Sales Territory Coverage Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>Auxiliary1Code</td>
<td>The code of the auxiliary classification 1</td>
<td>Text</td>
<td>Not applicable</td>
<td>Required</td>
</tr>
</tbody>
</table>

If the DimensionCode = Aux2
Oracle CX
Understanding Import and Export Management for CX
Sales and B2B Service

Chapter 8
Import Your Data

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Data Type</th>
<th>Prerequisite Setup Task/ Import Validations</th>
<th>Creating a Sales Territory Coverage Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>Auxiliary2Code</td>
<td>The code of the auxiliary classification 2</td>
<td>Text</td>
<td>Not applicable</td>
<td>Required</td>
</tr>
</tbody>
</table>

If the DimensionCode = Aux3

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Data Type</th>
<th>Prerequisite Setup Task/ Import Validations</th>
<th>Creating a Sales Territory Coverage Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>Auxiliary3Code</td>
<td>The code of the auxiliary classification 3</td>
<td>Text</td>
<td>Not applicable</td>
<td>Required</td>
</tr>
</tbody>
</table>

If the DimensionCode = Schnl

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Data Type</th>
<th>Prerequisite Setup Task/ Import Validations</th>
<th>Creating a Sales Territory Coverage Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>SalesChannelCode</td>
<td>The code of the sales channel</td>
<td>Text</td>
<td>Not applicable</td>
<td>Required</td>
</tr>
<tr>
<td>SubSalesChannelCode</td>
<td>The code of the sub sales channel</td>
<td>Text</td>
<td>Not applicable</td>
<td>Optional</td>
</tr>
</tbody>
</table>

If the DimensionCode = Prtnr

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Data Type</th>
<th>Prerequisite Setup Task/ Import Validations</th>
<th>Creating a Sales Territory Coverage Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>PartnerNumber</td>
<td>The public unique identifier number (or company number) of the partner</td>
<td>Text</td>
<td>Not applicable</td>
<td>Required</td>
</tr>
</tbody>
</table>

You can view the Sales Territory Coverage object and attributes in the Manage Import Objects page of the Import Management flow. You can find attribute information like type, length, description, and so on, on this page.

Required Attributes and Validations for Deleting Sales Territory Coverage Object

You can delete a sales territory coverage record using Unique Territory Number, Dimension Code and other attributes or Unique Territory Number and Coverage Number.

Delete a Sales Territory Coverage using Attribute and Dimension Code

A Sales Territory Coverage record can be deleted using the following fields:

- Unique territory number (UniqueTerritoryNumber): The public unique identifier number of the territory
• Coverage type code (CoverageTypeCode): The coverage type code. Possible values are REGULAR, INCLUSION, or EXCLUSION

• Dimension code (TerrDimensionCode): The possible values are listed in the table below:

### Dimension Field(s)

<table>
<thead>
<tr>
<th>Dimension</th>
<th>Dimension Code</th>
<th>Dimension Field</th>
</tr>
</thead>
<tbody>
<tr>
<td>Sales Channel</td>
<td></td>
<td>Either SalesChannelCode or SubSalesChannelCode</td>
</tr>
<tr>
<td>Product</td>
<td>Prod</td>
<td>ProductGroupNumber or ProductGroupId OR ItemNumber or InventoryItemId</td>
</tr>
<tr>
<td>Account Type</td>
<td>AccTp</td>
<td>AccountTypeCode</td>
</tr>
<tr>
<td>Address</td>
<td>Addr</td>
<td>AddressCountry and (optionally) one or more of the following:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• AddressState</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• AddressProvince</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• AddressCounty</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• AddressCity</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• AddressPostalCode</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• AddressElementAttribute1</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• AddressElementAttribute2</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• AddressElementAttribute3</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• AddressElementAttribute4</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• AddressElementAttribute5</td>
</tr>
<tr>
<td>Auxiliary 3</td>
<td>Aux3</td>
<td>Auxiliary3Code</td>
</tr>
<tr>
<td>Auxiliary 1</td>
<td>Aux1</td>
<td>Auxiliary1Code</td>
</tr>
<tr>
<td>Auxiliary 2</td>
<td>Aux2</td>
<td>Auxiliary2Code</td>
</tr>
<tr>
<td>Business Unit</td>
<td>BUnit</td>
<td>BusinessUnitName or BusinessUnitId</td>
</tr>
<tr>
<td>Customer Size</td>
<td>CSize</td>
<td>CustomerSizeCode</td>
</tr>
<tr>
<td>Geography</td>
<td>Geo</td>
<td>GeographyId or GeographyName (the full path needs to be provided e.g. &gt;United States&gt;CA or <del>Global</del>North America)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>For Geo ranges, also provide</td>
</tr>
<tr>
<td></td>
<td></td>
<td>GeographyHighId or GeoHighName - the full path needs to be provided (optional)</td>
</tr>
<tr>
<td>Industry</td>
<td>Indst</td>
<td>IndustryCode</td>
</tr>
</tbody>
</table>
### Import Your Data

#### Dimension, Dimension Code, and Dimension Field

<table>
<thead>
<tr>
<th>Dimension</th>
<th>Dimension Code</th>
<th>Dimension Field</th>
</tr>
</thead>
<tbody>
<tr>
<td>Organization Size</td>
<td>OrgTp</td>
<td>OrganizationTypeCode</td>
</tr>
<tr>
<td>Partner</td>
<td>Prtnr</td>
<td>PartnerNumber or PartnerId</td>
</tr>
<tr>
<td>Account</td>
<td>Acct</td>
<td>RegistryId or OriginalReference or AccountId</td>
</tr>
</tbody>
</table>

#### Delete a Sales Territory Coverage using Unique Territory Number and Coverage Number

A Sales Territory Coverage record can be deleted using the Unique Territory Number and Coverage Number.

**Required Attributes to Delete a Sales Territory Coverage**

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Data Type</th>
<th>Prerequisite Setup Task/Import Validations</th>
<th>Deleting an Existing Sales Territory Coverage Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>UniqueTerritoryNumber</td>
<td>The public unique identifier number of the territory.</td>
<td>Text</td>
<td>Not applicable</td>
<td>Required</td>
</tr>
<tr>
<td>CoverageNumber</td>
<td>The public unique identifier number of the territory coverage.</td>
<td>Text</td>
<td>Not applicable</td>
<td>Required</td>
</tr>
</tbody>
</table>

#### Create the Source CSV File

You include the data that you want to import into CX Sales and B2B Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator > Tools > Import Management > Import Objects.
2. Select the Standard Text object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

**Note:** For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.

#### Create the Import Activity

After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Sales Territory Coverage from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. Under Advanced options, select the Import Mode as Create records or Delete Records.
6. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review and edit the mappings if required.
7. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
8. Review the import details on the **Review and Submit** page, and click **Submit** when you’re ready.

### Review the Import Results

Check if your import succeeded on the **Manage Imports** page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to **Navigator > Tools > Import Management > Import Queue**.
2. Click **All Imports** and search for the import activity that you created earlier.
3. Check the **Status** column for the import activity. The import is successful if the status displays as **Completed**. You can drill down on the import activity to go to the **Import Status** page which provides the status details of the import activity.

**Related Topics**
- Potential Issues When Opening CSV Files in Excel
- Import Data
- Remove Customer Inclusions Using Import Management
- Add Customer Inclusions Using Import Management

### Import Your Sales Territory Line of Business Data

You can use Import Management to create or delete Sales Territory Line of Business records.

To import Sales Territory Line of Business records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

### How You Map Your Source Data to Object Attributes

To import your Sales Territory Line of Business data into Oracle Applications Cloud, you must populate a .csv file with your source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

- Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
- Ensure prerequisite setups are done, if applicable.
- Understand your options for uniquely identifying the records.
- Ensure parent records exist before importing child records.
  - When creating a territory, the sales territory import file must be imported before importing the sales territory resource, sales territory coverage, or sales territory line of business import files.
- Identify the target object attributes that are required in the CSV file for a successful import.
Before You Start

You must do some basic checks before starting your import. For example, make sure that:

- You have completed all the prerequisites for importing each attribute in your source data.
- You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records

To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the import process to uniquely identify the records. The file import process uses the attribute values to automatically map your source data to the target object attributes in Oracle Applications Cloud.

The preferred option for uniquely identifying an object record is through the Public unique identifier. If you’re creating new records, then you can provide the appropriate user-friendly public unique identifiers (attributes denoted with ‘Number’ and usually visible in the business object’s UI). For the Sales Territory Line of Business object, the attributes are UniqueTerritoryNumber and LobCode. If you delete a sales territory line of business record, you can use a combination of the UniqueTerritoryNumber and LobCode attributes to identify the appropriate record.

Required Attributes and Validations for Sales Territory Line of Business Object

To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure that you provide valid values for the attributes. The following table lists the required attributes for importing new Sales Territory Line of Business records, required attributes for deleting Sales Territory Line of Business records, prerequisite setup tasks for the attributes, and specific validations, if any, for Sales Territory Line of Business import:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Data Type</th>
<th>Prerequisite Setup Task/ Import Validations</th>
<th>Creating a Sales Territory Line of Business Record</th>
<th>Deleting an Existing Sales Territory Line of Business Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>UniqueTerritoryNumber</td>
<td>The public unique identifier number of the territory</td>
<td>Text</td>
<td>Not applicable</td>
<td>Required</td>
<td>Required</td>
</tr>
<tr>
<td>LobCode</td>
<td>The code of the line of business.</td>
<td>Text</td>
<td>Not applicable</td>
<td>Required</td>
<td>Required</td>
</tr>
</tbody>
</table>

You can view the Sales Territory Line of Business object and attributes in the Manage Import Objects page of the Import Management flow. You can find attribute information like type, length, description, and so on, on this page.

Create the Source CSV File

You include the data that you want to import into CX Sales and B2B Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to **Navigator > Tools > Import Management > Import Objects**.
2. Select the **Sales Territory Line of Business** object in the table and click **Download**.

You can now edit the downloaded file and provide valid values for the required attributes.
Create the Import Activity

After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Sales Territory Line of Business from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. Under Advanced options, select the Import Mode as Create records or Delete Records.
6. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review and edit the mappings if required.
7. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
8. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results

Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed. You can drill down on the import activity to go to the Import Status page which provides the status details of the import activity.

Related Topics

- Potential Issues When Opening CSV Files in Excel
- Import Data

Import Your Sales Territory Period Quota Data

You can use the import functionality to create or update Sales Territory Period Quota records.

You can import Sales Territory Period Quota records using these steps:

1. Map your source data to Oracle Applications Cloud object attributes. This way the import process would know where to insert each of the information bits.
2. Create the source CSV file with the Sales Territory Period Quota data you want to import.
4. Check the import results to know if the import went well.
How You Map Your Source Data to Target Object Attributes

You import Sales Territory Period Quota data into Oracle Applications Cloud from a CSV file containing your source data that's mapped to target Oracle Applications Cloud object attributes.

Before you create the source data file, you should:

- Know how your source data attributes map to the target object attributes in Oracle Applications Cloud. Match each column from the source file to an attribute in the Sales Territory Period Quota import object.
- Finish all prerequisite steps, such as understanding what attributes are required for importing your objects.
- Know how you can uniquely identify the records.
- Check the target object attributes required in the CSV file for a successful import.
- Ensure that you don't insert duplicate Sales Territory Period Quota while importing, to avoid redundant data.

If you want to import only a few records, then you can create a single CSV file for all Sales Territory Period Quota attributes. However if you want to import a large number of records, then you may decide to create multiple CSV files, one for each of the Sales Territory Period Quota child objects.

Before You Start

You must do some basic checks before starting your import. For example, make sure that:

- You have completed all the prerequisites for importing each attribute in your source data.
- You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records

All records must be unique in the application. You can use one of these to identify records:

- Public unique identifiers: You can’t create Sales Territory Period Quota records. If you’re updating records, then you can provide an easily understandable public unique identifier. These are, usually, denoted with ‘Number’ and visible in the business object’s UI. PUID attributes are usually named <object> Number. If you’re updating a record with a Number attribute, then use the Number attribute to identify the record. For more information about public unique identifiers, see the topic "How You Use Alternate Keys to Import Records" in Related Topics section.
- Source system and source system reference: Source system is an identifier for the external system, and source system reference is a unique identifier within the external system. If you’re importing new Sales Territory Period Quotas or are updating Sales Territory Period Quotas that have source system reference data, then provide the source system and source system reference values.

Required Attributes and Validations for Sales Territory Period Quota Object

To import data successfully into Oracle Applications Cloud, your .CSV file must include the required attributes. Ensure that you provide valid values for the attributes.

This table lists the required attributes for Sales Territory Period Quota records, prerequisite setup tasks and specific validations, if any:
### Attribute Description Prerequisite Setup Task/ Import Validations Creating a Sales Territory Period Quota record Updating an Existing Sales Territory Period Quota record

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/ Import Validations</th>
<th>Creating a Sales Territory Period Quota record</th>
<th>Updating an Existing Sales Territory Period Quota record</th>
</tr>
</thead>
<tbody>
<tr>
<td>QuotaPlanName</td>
<td>Name of the Quota Plan</td>
<td>Quota plan has to be in Active status and tracked.</td>
<td>Not applicable</td>
<td>Not updatable</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>You can't create a Sales Territory Period Quota record.</td>
<td></td>
</tr>
<tr>
<td>TerritoryNumber</td>
<td>Territory number for which the period data is imported</td>
<td>The territory must exist and be non-excluded.</td>
<td>Not applicable</td>
<td>Not updatable</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>You can't create a Sales Territory Period Quota record.</td>
<td></td>
</tr>
<tr>
<td>PeriodName</td>
<td>Period for which data is imported</td>
<td>The calendar setup for the year.</td>
<td>Not applicable</td>
<td>Not updatable</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>You can't create a Sales Territory Period Quota record.</td>
<td></td>
</tr>
<tr>
<td>TerritoryPeriodQuota</td>
<td>Quota value to be imported</td>
<td>Enter a positive number.</td>
<td>Not applicable</td>
<td>This is updatable, if the Territory Quota is in &quot;Not Published&quot; status.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>You can't create a Sales Territory Period Quota record.</td>
<td></td>
</tr>
</tbody>
</table>

Go to Navigator > Tools > Import Management > Import Objects, to see all the attributes of the Sales Territory Period Quota object. The page also lists attribute information like type, length, description, and so on.

### Create the Source CSV File

You include the data that you want to import into CX Sales and B2B Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator > Tools > Import Management > Import Objects.
2. Select the Sales Territory Period Quota object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

**Note:** For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.

### Create the Import Activity

After you have the CSV file ready, create an import activity to import the Sales Territory Period Quota information. To create an import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. On the Manage Imports page, click Create Import Activity.
3. In the Create Import Activity: Enter Import Options page, provide a name for the import activity, and select Sales Territory Period Quota from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results

Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed. You can drill down on the import activity to go to the Import Status page which provides the status details of the import activity.

Related Topics
- How You Use Alternate Keys to Import Records
- Potential Issues When Opening CSV Files in Excel
- Import Data

Import Your Sales Territory Quota Data

You can use the import functionality to create or update Sales Territory Quota records.

You can import Sales Territory Quota records using these steps:

1. Map your source data to Oracle Applications Cloud object attributes. This way the import process would know where to insert each of the information bits.
2. Create the source CSV file with the Sales Territory Quota data you want to import.
4. Check the import results to know if the import went well.

How You Map Your Source Data to Target Object Attributes

You import Sales Territory Quota data into Oracle Applications Cloud from a CSV file containing your source data that's mapped to target Oracle Applications Cloud object attributes.

Before you create the source data file, you should:

- Know how your source data attributes map to the target object attributes in Oracle Applications Cloud. Match each column from the source file to an attribute in the Sales Territory Quota import object.
- Finish all prerequisite steps, such as understanding what attributes are required for importing your objects.
- Know how you can uniquely identify the records.
- Check the target object attributes required in the CSV file for a successful import.
- Ensure that you don't insert duplicate Sales Territory Quota records while importing, to avoid redundant data.
If you want to import only a few records, then you can create a single CSV file for all Sales Territory Quota attributes. However if you want to import a large number of records, then you may decide to create multiple CSV files, one for each of the Sales Territory Quota child objects. Note that you must have imported the CSV file for Sales Territory Quota object successfully before trying to import the CSV files for the child objects. There are separate help topics describing how to import each of these child objects.

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

- You have completed all the prerequisites for importing each attribute in your source data.
- You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
All records must be unique in the application. You can use one of these to identify records:

- Public unique identifiers: You can’t create Sales Territory Quota records. If you’re updating records, then you can provide an easily understandable public unique identifier. These are, usually, denoted with ‘Number’ and visible in the business object’s UI. PUID attributes are usually named <object> Number. If you’re updating a record with a Number attribute, then use the Number attribute to identify the record. For more information about public unique identifiers, see the topic “How You Use Alternate Keys to Import Records” in Related Topics section.

- Source system and source system reference: Source system is an identifier for the external system, and source system reference is a unique identifier within the external system. If you’re importing new Sales Territory Quotas or are updating Sales Territory Quotas that have source system reference data, then provide the source system and source system reference values.

Required Attributes and Validations for Sales Territory Quota Object
To import data successfully into Oracle Applications Cloud, your .CSV file must include the required attributes. Ensure that you provide valid values for the attributes.

This table lists the required attributes for Sales Territory Quota records, prerequisite setup tasks and specific validations, if any:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/Import Validations</th>
<th>Creating a Sales Territory Quota record</th>
<th>Updating an Existing Sales Territory Quota record</th>
</tr>
</thead>
<tbody>
<tr>
<td>QuotaPlanName</td>
<td>Name of the Quota Plan</td>
<td>Quota plan must be in Active status and tracked.</td>
<td>Not applicable</td>
<td>Not updatable</td>
</tr>
<tr>
<td></td>
<td></td>
<td>You can’t create a Sales Territory Quota record.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>TerritoryNumber</td>
<td>Territory number for which data is imported</td>
<td>The territory must exist and be non-excluded.</td>
<td>Not applicable</td>
<td>Not updatable</td>
</tr>
<tr>
<td></td>
<td></td>
<td>You can’t create a Sales Territory Quota record.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>TerritoryQuota</td>
<td>Quota value to be imported</td>
<td>Enter a positive number.</td>
<td>Not applicable</td>
<td>This is updatable, if the Territory Quota is in “Not Published” status.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/Import Validations</th>
<th>Creating a Sales Territory Quota record</th>
<th>Updating an Existing Sales Territory Quota record</th>
</tr>
</thead>
<tbody>
<tr>
<td>QuotaPlanName</td>
<td>Name of the Quota Plan</td>
<td>Quota plan must be in Active status and tracked.</td>
<td>Not applicable</td>
<td>Not updatable</td>
</tr>
<tr>
<td></td>
<td></td>
<td>You can’t create a Sales Territory Quota record.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>TerritoryNumber</td>
<td>Territory number for which data is imported</td>
<td>The territory must exist and be non-excluded.</td>
<td>Not applicable</td>
<td>Not updatable</td>
</tr>
<tr>
<td></td>
<td></td>
<td>You can’t create a Sales Territory Quota record.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>TerritoryQuota</td>
<td>Quota value to be imported</td>
<td>Enter a positive number.</td>
<td>Not applicable</td>
<td>This is updatable, if the Territory Quota is in “Not Published” status.</td>
</tr>
</tbody>
</table>
Attribute | Description | Prerequisite Setup Task/Import Validations | Creating a Sales Territory Quota record | Updating an Existing Sales Territory Quota record
--- | --- | --- | --- | ---

Go to Navigator > Tools > Import Management > Import Objects, to see all the attributes of the Sales Territory Quota object. The page also lists attribute information like type, length, description, and so on.

Create the Source CSV File
You include the data that you want to import into CX Sales and B2B Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator > Tools > Import Management > Import Objects.
2. Select the Sales Territory Quota object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note: For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the Sales Territory Quota information. To create an import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. On the Manage Imports page, click Create Import Activity.
3. In the Create Import Activity: Enter Import Options page, provide a name for the import activity, and select Sales Territory Quota from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you’re ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed. You can drill down on the import activity to go to the Import Status page which provides the status details of the import activity.
Import Your Sales Territory Resource Data

You can use Import Management to create or delete Sales Territory Resource records.

To import Sales Territory Resource records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Object Attributes

To import your Sales Territory Resource data into Oracle Applications Cloud, you must populate a .csv file with your source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

- Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
- Ensure prerequisite setups are done, if applicable.
- Understand your options for uniquely identifying the records.
- Ensure parent records exist before importing child records.
  - When creating a territory, the sales territory import file must be imported before importing the sales territory resource, sales territory coverage, or sales territory line of business import files.
- Identify the target object attributes that are required in the CSV file for a successful import.

Before You Start

You must do some basic checks before starting your import. For example, make sure that:

- You have completed all the prerequisites for importing each attribute in your source data.
- You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records

To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the import process to uniquely identify the records. The file import process uses the attribute values to automatically map your source data to the target object attributes in Oracle Applications Cloud.

The preferred option to uniquely identify an object record is through the Public unique identifier. If you're creating new records, then you can provide the appropriate user-friendly public unique identifiers (attributes denoted with
‘Number’ and usually visible in the business object’s UI). For the Sales Territory Resource object, the attributes are UniqueTerritoryNumber and ResourcePartyNumber. If you delete a sales territory resource record, you can use a combination of the UniqueTerritoryNumber and ResourcePartyNumber attributes to identify the appropriate record. Oracle recommends that you don’t update the Sales Territory Resource object. For example, to update the FunctionCode of the record; instead delete the record and then create a new record with the correct FunctionCode value.

Required Attributes and Validations for the Sales Territory Resource Object

To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure that you provide valid values for the attributes. The following table lists the required attributes for importing new Sales Territory Resource records, required attributes for deleting Sales Territory Resource records, prerequisite setup tasks for the attributes, and specific validations, if any, for Sales Territory Resource import:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Data Type</th>
<th>Prerequisite Setup Task/ Import Validations</th>
<th>Creating a Sales Territory Resource Record</th>
<th>Deleting an Existing Sales Territory Resource Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>UniqueTerritoryNumber</td>
<td>The public unique identifier number of the territory</td>
<td>Text</td>
<td>Not applicable</td>
<td>Required</td>
<td>Required</td>
</tr>
<tr>
<td>ResourcePartyNumber</td>
<td>The public unique identifier number of the resource</td>
<td>Text</td>
<td>Not applicable</td>
<td>Required</td>
<td>Required</td>
</tr>
<tr>
<td>FunctionCode</td>
<td>The code of the function (or role) of the territory member</td>
<td>Text</td>
<td>Not applicable</td>
<td>Optional.</td>
<td>Don't provide a value.</td>
</tr>
<tr>
<td>AdministratorFlag</td>
<td>An indicator of whether the territory member is a delegated administrator for the territory</td>
<td>Text</td>
<td>Not applicable</td>
<td>Optional.</td>
<td>Don't provide a value.</td>
</tr>
<tr>
<td>ManageForecastFlag</td>
<td>An indicator of whether the territory member is the forecasting delegate</td>
<td>Text</td>
<td>Not applicable</td>
<td>Optional.</td>
<td>Don't provide a value.</td>
</tr>
</tbody>
</table>

You can view the Sales Territory Resource object and attributes in the Manage Import Objects page of the Import Management flow. You can find attribute information like type, length, description, and so on, on this page.
Create the Source CSV File
You include the data that you want to import into CX Sales and B2B Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to **Navigator > Tools > Import Management > Import Objects**.
2. Select the **Sales Territory Resource** object in the table and click **Download**.

You can now edit the downloaded file and provide valid values for the required attributes.

**Note:** For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to **Navigator > Tools > Import Management > Import Queue**.
2. Click **Create Import Activity** in the **Manage Imports** page.
3. In the **Enter Import Options** page, provide a name for the import activity, and select Sales Territory Resource from the **Object** drop-down list.
4. Select the CSV file in the **File Name** field, and click **Next**.
5. Under **Advanced** options, select the **Import Mode** as Create records or Delete Records.
6. You would see that the source and target attributes are automatically mapped in the **Map Fields** page. Review and edit the mappings if required.
   - The ResourcePartyNumber isn't automatically mapped to the Resource Registry ID. Use the **Save As** option to create a mapping, name the mapping and map the Resource Registry ID target attribute to the Source File ResourcePartyNumber attribute, by dragging the target attribute to the Attribute Display Name. Select and apply this new import mapping in the Map Fields page of a future sales territory resource import activity.
7. Check the file for unmapped columns or data format issues by clicking **Validate Data**. Click **Next**.
8. Review the import details on the **Review and Submit** page, and click **Submit** when you're ready.

Review the Import Results
Check if your import succeeded on the **Manage Imports** page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to **Navigator > Tools > Import Management > Import Queue**.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the **Status** column for the import activity. The import is successful if the status displays as **Completed**. You can drill down on the import activity to go to the **Import Status** page which provides the status details of the import activity.

**Related Topics**
- Potential Issues When Opening CSV Files in Excel
- Import Data
**Import Your Self-Service Role Data**

You can use Import Management to create self-service users and can also use it to delete existing self-service users or grant them additional roles.

To import Self-Service users, perform the following tasks:

1. Map your source data to Self-Service Role object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

**How You Map Your Source Data to Target Object Attributes**

To import your Self-Service Role data into Oracle Applications Cloud, you need to populate a CSV file with your source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

- Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
- Ensure prerequisite setups are done, if applicable.
- Understand your options for uniquely identifying the records.
- Ensure parent records exist before importing child records.
- Identify the target object attributes that are required in the CSV file for a successful import.

**Before You Start**

You must do some basic checks before starting your import. For example, make sure that:

- You have completed all the prerequisites for importing each attribute in your source data.
- You have all parent records in place before importing child records.

**Select a Unique Identifier for Your Records**

All records must be unique in the application. If you’re creating records, then you can provide an easily understandable public unique identifier. These are, usually, denoted with ‘Number’ and visible in the business object’s UI. PUID attributes are usually named `<object> Number`. For more information about public unique identifiers, see the topic "How You Use Alternate Keys to Import Records" in Related Topics section.

**Required Attributes and Validations for Self-Service Role Object**

To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure that you provide valid values for the attributes. This table lists the required attributes for importing new Self-Service Role records, prerequisite setup tasks for the attributes, and specific validations, if any, for Self-Service Role import:
<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/Import Validations</th>
<th>Creating a Self-Service Role Record</th>
<th>Deleting an Existing Self-Service Role Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>ContactPartyId</td>
<td>The party ID of the contact record of the self-service user associated with the role.</td>
<td>The contact must exist.</td>
<td>Provide a valid value if the ContactPartyNumber isn't specified.</td>
<td>Not Required</td>
</tr>
<tr>
<td>RequestTypeCd</td>
<td>The code that indicates the Registration Request type. The list of accepted values is defined in the ORA_SVC_CSS_REQ_TYPE_CD lookup type.</td>
<td>No Validation</td>
<td>Provide one of the following values:</td>
<td>Not Required</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• ORA_CSS_REQ_TYPE_CONTACT</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• ORA_CSS_REQ_TYPE_CONSUMER</td>
<td></td>
</tr>
<tr>
<td>RelationshipTypeCd</td>
<td>The code that indicates the role type. The list of accepted values is defined in the ORA_SVC_CSS_REL_TYPE_CD lookup type. The following values can be assigned:</td>
<td>No Validation</td>
<td>Provide one or more of the following values:</td>
<td>Not Required</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• ORA_CSS_USER: Corresponds to the Digital Customer Service User role.</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• ORA_CSS_ACC_MGR: Corresponds to the Digital Customer Service Account Manager role.</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>• ORA_CSS_ACC_ADMIN: Corresponds to the Digital Customer Service Account Administrator role.</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Multiple roles can be assigned to a user and must be concatenated with the character, '&amp;'.</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>For example, ORA_CSS_USER&amp;ORA_CSS_ACC_ADMIN</td>
<td></td>
</tr>
<tr>
<td>ContactPartyNumber</td>
<td>The party number of the contact record of the self-service user associated with the role.</td>
<td>The contact must exist.</td>
<td>Provide a valid value if the ContactPartyId isn't specified.</td>
<td>Not Required</td>
</tr>
<tr>
<td>AccountPartyNumber</td>
<td>The party number of the account of the self-service user associated with the role.</td>
<td>An account must exist.</td>
<td>Provide a valid value if the AccountPartyId isn't specified.</td>
<td>Not Required</td>
</tr>
</tbody>
</table>
### Attribute | Description | Prerequisite Setup Task/Import Validations | Creating a Self-Service Role Record | Deleting an Existing Self-Service Role Record
--- | --- | --- | --- | ---
RoleId | The unique identifier of the self-service user role. | A user role must exist. | The RoleId should not be provided. | Required
LoginId | The login Id of the self-service user associated with the role. If the SVC_CSS_IMP_SIGN_IN_ATTR_NAME profile option is set, then the LoginId is optional. | Login ID should be unique to each user. | Provide a valid value if the SVC_CSS_IMP_SIGN_IN_ATTR_NAME profile option isn’t set. | Not Required
AccountPartyId | The party ID of the account of the self-service user associated with the role. | An account must exist. | Provide a valid value if the AccountPartyNumber isn’t specified. | Not Required

**Note:** You can only create and delete self-service role records. You can’t update self-service role records.

You can view the Self-Service Role object along with all its child objects and attributes in the Manage Import Objects page of the Import Management flow. You can find attribute information like type, length, description, and so on, on this page.

### Create the Source CSV File
You include the data that you want to import into CX Sales and B2B Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to **Navigator > Tools > Import Management > Import Objects**.
2. Select the **Self-Service Role** object in the table and click **Download**.

You can now edit the downloaded file and provide valid values for the required attributes.

Consider the following points:

- Role Id should be removed.
- Either the contact party ID or the contact party number is required.
- Either the account party ID or the account party number is required.

**Examples**

- Example 1: Party ID is used for creating self-service users
  ```
  AccountPartyId, ContactPartyId, RelationshipTypeCd, RequestTypeCd
  300100110957452, 300100156316610, ORA_CSS_USER & ORA_CSS_ACC_ADMIN, ORA_CSS_REQ_TYPE_CONTACT
  ```

- Example 2: Party Number is used for creating self-service users
  ```
  AccountPartyNumber, ContactPartyNumber, RelationshipTypeCd, RequestTypeCd
  ```
Create the Import Activity

After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to **Navigator > Tools > Import Management > Import Self-Service Role.**
2. Click **Create Import Activity** in the **Manage Imports** page.
3. In the **Enter Import Options** page, provide a name for the import activity, and select Self-Service Role from the **Object** drop-down list.
4. Select the CSV file in the **File Name** field, and click **Next.**
   
   You would see that the source and target attributes are automatically mapped in the **Map Fields** page. Review and edit the mappings if required.
5. Check the file for unmapped columns or data format issues by clicking **Validate Data.** Click **Next.**
6. Review the import details on the **Review and Submit** page, and click **Submit** when you're ready.

Review the Import Results

Check if your import succeeded on the **Manage Imports** page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to **Navigator > Tools > Import Management > Import Self-Service Role.**
2. Click All Imports and search for the import activity that you created earlier.
3. Check the **Status** column for the import activity. The import is successful if the status displays as **Completed.**
   You can drill down on the import activity to go to the **Import Status** page which provides the status details of the import activity.

---

**Note:** For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.
Import Your Data

Related Topics
- Potential Issues When Opening CSV Files in Excel
- How You Use Alternate Keys to Import Records
- Import Data

Import Your Service Request Data

You can use the Import Management to create, update, or delete service request records.

You can import service request records using these steps:

1. Map your source service request data to Oracle Applications Cloud object attributes. This way the import process would know where to insert each of the information bits.
2. Create the source CSV file with the service request data you want to import.
4. Check the import results to know if the import went well.

How You Map Your Source Data to Target Object Attributes

To import your service request data into Oracle Applications Cloud, you must populate a .csv file with your source data and map that source data to target object attributes in Oracle Applications Cloud.

You must do the following before creating the .csv file for data import:

- Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
- Ensure prerequisite steps are complete, such as understanding what attributes are required for importing your objects.
- Understand your options for uniquely identifying the records.
- Ensure parent records exist before importing child records.
- Identify the target object attributes that are required in the .csv file for a successful import.

To better manage your service request information, the service request object has the following child object:

- Service Request Reference

If you want to import only a few records, then you can create a single CSV file for all service request attributes. However if you want to import a large number of records, then you may decide to create multiple CSV files, one for each of the service request child objects. Note that you must have imported the CSV file for service request object successfully before trying to import the CSV files for the child objects. There are separate help topics describing how to import each of these child objects. For more information, see the related topics section.

Before You Start

You must do some basic checks before starting your import. For example, make sure that:

- You have completed all the prerequisites for importing each attribute in your source data.
- You have all parent records in place before importing child records.
Select a Unique Identifier for Your Records

All records must be unique in the application. You can use one of these to identify records:

- **Public unique identifiers**: If you’re creating records, then you can provide an easily understandable public unique identifier. These are, usually, denoted with ‘Number’ and visible in the business object’s UI. PUID attributes are usually named <object> Number. If you’re updating a record with a Number attribute, then use the Number attribute to identify the record. For more information about public unique identifiers, see the topic “How You Use Alternate Keys to Import Records” in Related Topics section.

- **Source system and source system reference**: Source system is an identifier for the external system, and source system reference is a unique identifier within the external system. If you’re importing new service requests or are updating service requests that have source system reference data, then provide the source system and source system reference values.

**Required Attributes and Validations for Service Request Object**

To import data successfully into Oracle Applications Cloud, your .csv file must include the required attributes. Ensure that you provide valid values for the attributes.

This table lists the required attributes for service request records, prerequisite setup tasks and specific validations, if any:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/ Import Validations</th>
<th>Creating a Service Request record</th>
<th>Updating an Existing Service Request record</th>
</tr>
</thead>
</table>
| Account ID  | The unique Id for the existing account Id record in the Oracle Fusion destination table. | Do not provide a value if creating a new service request. If updating an existing service request, the value must exist in the SVC_SERVICE_REQUESTS table, column ACCOUNT_PARTY_ID. | Not required | Conditionally required  
|             |                                                                             |                                             |                                  | A value is required if you're updating an existing Account ID. |
| AssetID     | The unique internal ID for the existing service request record.              | Do not provide a value if creating a new service request. If updating an existing service request, the value must exist in the ZCA_ASSET table, column ASSET_ID. | Not required | Conditionally required  
|             |                                                                             |                                             |                                  | A value is required if you're updating an existing service request for this service request. |
| Business Unit | The unique ID of the business unit name associated with the service request. | No validation                             | Required                         | Required                                    |
| Category ID | Unique ID of a means of grouping service objects to enable easy identification and downstream reporting. | If providing a value, the value must exist in the table SVC_SR_CATEGORIES (CATEGORY_ID). | Not required | Conditionally required  
<p>|             |                                                                             |                                             |                                  | A value is required if you're updating an existing Category ID for this service request. |</p>
<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/ Import Validations</th>
<th>Creating a Service Request record</th>
<th>Updating an Existing Service Request record</th>
</tr>
</thead>
<tbody>
<tr>
<td>Inventory Item ID</td>
<td>The unique internal Id for the existing sales catalog product (item) record.</td>
<td>If providing a value, the value must exist in the EGP_SYSTEM_ITEMS_B table, column INVENTORY_ITEM_ID. The identified product must be defined for the sales catalog (QSC_PROD_GRP_ITEMS_TREE_V view). You can obtain the InventoryItemId for an existing product (item) by exporting the Product Group Products object. Navigate to the following in the Setup and Maintenance work area: • Offering: Sales • Functional Area: Data Import and Export • Task: Manage Bulk Data Export, Schedule Export Processes You can add products (items) to the sales catalog. Navigate to the following in the Setup and Maintenance work area: • Offering: Sales • Functional Area: Data Import and Export • Task: Manage Product Groups</td>
<td>Conditionally required A value is required if you're creating a new item inventory.</td>
<td>Conditionally required A value is required if you're updating an item inventory and you're not providing the product's ID (InventoryItemId).</td>
</tr>
<tr>
<td>Inventory Organization ID</td>
<td>The unique internal Id for the existing product item organization's record in the destination table.</td>
<td>If providing a value, the value must exist in the EGP_SYSTEM_ITEMS_B table, column ORGANIZATION_ID. The identified item organization must be the same organization defined for profile QSC_SALES_PRODUCTS_INVENTORY_ORG_ID. You can view the profile value. Navigate to the following in the Setup and Maintenance work area: • Offering: Sales • Functional Area: Data Import and Export • Task: Product Groups Profile Option Values</td>
<td>Conditionally required A value is required if you're creating a new item inventory.</td>
<td>Conditionally required A value is required if you're updating an item inventory and you're not providing the product's ID (InventoryItemId).</td>
</tr>
<tr>
<td>Attribute</td>
<td>Description</td>
<td>Prerequisite Setup Task/Import Validations</td>
<td>Creating a Service Request record</td>
<td>Updating an Existing Service Request record</td>
</tr>
<tr>
<td>------------------------</td>
<td>------------------------------------------------------------------------------</td>
<td>-------------------------------------------------------------------------------------------------------------</td>
<td>----------------------------------</td>
<td>--------------------------------------------</td>
</tr>
</tbody>
</table>
| Partner Account Party ID| Foreign key that references HZ_PARTIES (PARTY_ID).                          | Do not provide a value if creating a new partner account in the same import batch as this additional party name. If you provide the value for an existing party, the value must exist in the HZ_PARTIES table, column PARTY_ID. You can obtain the PARTY_ID for an existing party by exporting the Party object. Navigate to the following in the Setup and Maintenance work area:  
  - Offering: Sales  
  - Functional Area: Data Import and Export  
  - Task: Manage Bulk Data Export, Schedule Export Processes | Not required | Conditionally required  
  A value is required if you're updating an existing Partner Account for this service request. |
| PartyID                | The unique ID for the existing party record in the Oracle Fusion destination table. | Do not provide a value if creating a new party in the same import batch as this additional party name. If you provide the value for an existing party, the value must exist in the HZ_PARTIES table, column PARTY_ID. You can obtain the PARTY_ID for an existing party by exporting the Party object. Navigate to the following in the Setup and Maintenance work area:  
  - Offering: Sales | Not required | Conditionally required  
  A value is required if you're updating an existing party ID and you're not providing the party ID. |
<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/Import Validations</th>
<th>Creating a Service Request record</th>
<th>Updating an Existing Service Request record</th>
</tr>
</thead>
</table>
| Primary Contact ID   | The initial reported by contact and ongoing primary customer contact of the service request. | • Functional Area: Data Import and Export  
• Task: Manage Bulk Data Export, Schedule Export Processes                                                                 | Not required                      | Conditionally required  
A value is required if you're updating an existing Primary Contact ID for this service request. |
| Reference Number     | The unique number used to identify a service request. You can configure the service request number to a format that's best suitable to your organizational requirements. | No validation                                                                       | Not required                      | Conditionally required  
A value is required if you're updating an existing reported by record and you're not providing the service request ID. |
| Service Request ID   | The unique Id for the existing Service Request record in the Oracle Fusion destination table. | No validation                                                                       | Not required                      | Conditionally required  
A value is required if you're updating an existing Service Request Id and you’re not providing the Service Request Number. |

Go to **Navigator > Tools > Import Management > Import Objects**, to see all the attributes of the service request object. The page also lists attribute information like type, length, description, and so on.

**Note:** When importing closed SRs, the ClosedDate and LastResolvedDate are set to the current date (instead of the dates in the import file) if there is an update to the status or description of the SR. As a workaround, you can import the SRs again to take the ClosedDate and LastResolvedDate from the import file.
Create the Source CSV File

You include the data that you want to import into CX Sales and B2B Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator > Tools > Import Management > Import Objects.
2. Select the Service Request object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

**Note:** For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity

After you have the CSV file ready, create an import activity to import the service request information. To create an import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Service Request from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results

Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed. You can drill down on the import activity to go to the Import Status page which provides the status details of the import activity.

**Related Topics**

- Potential Issues When Opening CSV Files in Excel
- How You Use Alternate Keys to Import Records
- Import Data

Import Your Service Request Contact Data

You can use Import Management to create or update Service Request Contact records.
To import Service Request Contact records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes

To import your Service Request Contact data into Oracle Applications Cloud, you need to populate a CSV file with your source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

- Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
- Ensure prerequisite setups are done, if applicable.
- Understand your options for uniquely identifying the records.
- Ensure parent records exist before importing child records.
- Identify the target object attributes that are required in the CSV file for a successful import.

Before You Start

You must do some basic checks before starting your import. For example, make sure that:

- You have completed all the prerequisites for importing each attribute in your source data.
- You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records

All records must be unique in the application. You can use one of these to identify records:

- Public unique identifiers: If you’re creating records, then you can provide an easily understandable public unique identifier. These are, usually, denoted with ‘Number’ and visible in the business object’s UI. PUID attributes are usually named <object> Number. If you’re updating a record with a Number attribute, then use the Number attribute to identify the record. For more information about public unique identifiers, see the topic “How You Use Alternate Keys to Import Records” in Related Topics section.
- Source system and source system reference: Source system is an identifier for the external system, and source system reference is a unique identifier within the external system. If you’re importing new service request contacts or are updating service request contacts that have source system reference data, then provide the source system and source system reference values.

Required Attributes and Validations for Service Request Contact Object

To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure that you provide valid values for the attributes. This table lists the required attributes for importing new Service Request Contact records, required attributes for updating Service Request Contact records, prerequisite setup tasks for the attributes, and specific validations, if any, for Service Request Contact import:
<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/ Import Validations</th>
<th>Creating a Service Request Contact Record</th>
<th>Updating an Existing Service Request Contact Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>MemberId</td>
<td>The unique ID for the Service Request (SR) Contact record in the Service Request Contact object.</td>
<td>Auto-generated</td>
<td>Not Required</td>
<td>Conditionally required</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>While updating the SR contact record, if the SRId and either one of the PartyID or ContactPartyNumber aren't provided, then the MemberId is required.</td>
</tr>
<tr>
<td>PartyId</td>
<td>The unique party identifier of the contact.</td>
<td>Conditionally required</td>
<td>A value is required if a new contact is added to a service request, and the Contact Party Number (public unique identifier of the contact) isn't provided.</td>
<td>Conditionally required</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>A value is required if an SR contact record is updated, and the Contact Party Number isn't provided.</td>
</tr>
<tr>
<td>ContactPartyNumber</td>
<td>The public unique identifier of the contact.</td>
<td>Conditionally required</td>
<td>A value is required if a new contact is added to a service request, and the Party Id isn't provided.</td>
<td>Conditionally required</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>A value is required if an SR contact record is updated, and the Party Id isn't provided.</td>
</tr>
<tr>
<td>ContactPartyName</td>
<td>The name of the contact.</td>
<td>No Validation</td>
<td>Not Required</td>
<td>Not Required</td>
</tr>
<tr>
<td>SrId</td>
<td>The service request to which the contact is associated.</td>
<td>Conditionally required</td>
<td>A value is required if an SR contact record and the SR Number isn't provided.</td>
<td>Conditionally required</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>A value is required if an existing SR contact record is updated, and the SR Number isn't provided.</td>
</tr>
<tr>
<td>SrNumber</td>
<td>The public unique identifier of a service request.</td>
<td>No Validation</td>
<td>Conditionally required</td>
<td>Conditionally required</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>A value is required if an SR contact record is created and the SRId isn't provided.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>A value is required if an existing SR contact record is updated and the SRId isn't provided.</td>
</tr>
</tbody>
</table>

You can view the Service Request Contact object along with all its child objects and attributes in the Manage Import Objects page of the Import Management flow. You can find attribute information like type, length, description, and so on, on this page.
Create the Source CSV File
You include the data that you want to import into CX Sales and B2B Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator > Tools > Import Management > Import Objects.
2. Select the Service Request Contact object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

**Note:** For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator > Tools > Import Management > Import Service Request Contact.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Service Request Contact from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.

    You would see that the source and target attributes are automatically mapped in the Map Fields page. Review and edit the mappings if required.
5. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
6. Review the import details on the Review and Submit page, and click Submit when you’re ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to Navigator > Tools > Import Management > Import Service Request Contact.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed. You can drill down on the import activity to go to the Import Status page which provides the status details of the import activity.

**Related Topics**
- Potential Issues When Opening CSV Files in Excel
- How You Use Alternate Keys to Import Records
- Import Data
Import Your Service Request Message Communication Data

You can use the Import Management to create Service Request (SR) message communication records.

You can import message communication records using these steps:

1. Map your source message data to Oracle Applications Cloud object attributes. This way the import process would know where to insert each of the information bits.
2. Create the source CSV file with the message communication data you want to import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes

To import your message communication data into Oracle Applications Cloud, you must populate a .csv file with your source data and map that source data to target object attributes in Oracle Applications Cloud.

You must do the following before creating the .csv file for data import:

- Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
- Ensure prerequisite steps are complete, such as understanding what attributes are required for importing your objects.
- Understand your options for uniquely identifying the records.
- Ensure parent records exist before importing child records.
- Identify the target object attributes that are required in the .csv file for a successful import

Before You Start

You must do some basic checks before starting your import. For example, make sure that:

- You have completed all the prerequisites for importing each attribute in your source data.
- You have all parent records in place before importing child records. Make sure that you have imported SR and SR Messages before importing the message communication records.

Select a Unique Identifier for Your Records

All records must be unique in the application. You can use one of these to identify records:

- Public unique identifiers: If you’re creating records, then you can provide an easily understandable public unique identifier. These are, usually, denoted with ‘Number’ and visible in the business object’s UI. PUID attributes are usually named <object> Number. If you’re updating a record with a Number attribute, then use the Number attribute to identify the record. For more information about public unique identifiers, see the topic ”How You Use Alternate Keys to Import Records" in Related Topics section.
**Required Attributes and Validations for Message Object**

To import data successfully into Oracle Applications Cloud, your .csv file must include the required attributes. Ensure that you provide valid values for the attributes.

This table lists the required attributes for message communication records, prerequisite setup tasks and specific validations, if any:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task / Import Validations</th>
<th>Creating a Message Communication record</th>
</tr>
</thead>
<tbody>
<tr>
<td>MessageNumber</td>
<td>The public unique identifier of the service request message.</td>
<td>None</td>
<td>Conditionally Required. Either pass value for MessageNumber of ObjectId.</td>
</tr>
<tr>
<td>ChannelId</td>
<td>The unique identifier of the channel.</td>
<td>None</td>
<td>Required</td>
</tr>
<tr>
<td>Object ID</td>
<td>ID of the object (such as Note, Defect, Other SR) referencing the service request or referenced by the service request.</td>
<td>No validation</td>
<td>Conditionally required. Provide value for either ChannelId or ChannelShortName.</td>
</tr>
<tr>
<td>ChannelShortName</td>
<td>The public unique identifier of the channel.</td>
<td>No validation</td>
<td>Conditionally required. Provide value for either ChannelId or ChannelShortName.</td>
</tr>
<tr>
<td>PartyId</td>
<td>The unique party identifier of the person being communicated with.</td>
<td>No Validation</td>
<td>Conditionally required. Either pass PartyId or PartyNumber if you want to capture the message recipient or sender.</td>
</tr>
<tr>
<td>PartyNumber</td>
<td>The public unique identifier of the contact associated with the service request message.</td>
<td>No validation</td>
<td>Conditionally required. Either pass PartyId or PartyNumber if you want to capture the message recipient or sender.</td>
</tr>
<tr>
<td>PartyViaEndPoint</td>
<td>The endpoint used to communicate with the customer contact. For example Primarily used for Email.</td>
<td>No validation</td>
<td>Conditionally required. Provide value if you want to capture the email address of the message recipient.</td>
</tr>
<tr>
<td>RoutingCd</td>
<td>The code indicating how the message was routed through the endpoint.</td>
<td>No Validation</td>
<td>Conditionally required if you want to capture the sender or recipient of the message. Valid values are: ORA_SVC_BCC, ORA_SVC_CC, ORA_SVC_FROM, ORA_SVC_TO</td>
</tr>
<tr>
<td>ObjectId</td>
<td>The unique identifier of the object.</td>
<td>No validation</td>
<td>Conditionally Required. Either pass value for MessageNumber of ObjectId.</td>
</tr>
</tbody>
</table>
Go to Navigator > Tools > Import Management > Import Objects, to see all the attributes of the message communication object. The page also lists attribute information like type, length, description, and so on.

Create the Source CSV File
You include the data that you want to import into CX Sales and B2B Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator > Tools > Import Management > Import Objects.
2. Select the Service Request Message Communication object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note: For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the message communication information. To create an import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Service Request Message Communication from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed. You can drill down on the import activity to go to the Import Status page which provides the status details of the import activity.

Related Topics
- Potential Issues When Opening CSV Files in Excel
- How You Use Alternate Keys to Import Records
- Import Data
Import Your Service Request Reference Data

You can use the Import Management to create, update, or delete service request reference records.

You can import service request reference records using these steps:

1. Map your source service request reference data to Oracle Applications Cloud object attributes. This way the import process would know where to insert each of the information bits.
2. Create the source CSV file with the service request reference data you want to import.
4. Check the import results to know if the import went well.

How You Map Your Source Data to Target Object Attributes

To import your service request reference data into Oracle Applications Cloud, you must populate a .csv file with your source data and map that source data to target object attributes in Oracle Applications Cloud.

You must do the following before creating the .csv file for data import:

- Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
- Ensure prerequisite steps are complete, such as understanding what attributes are required for importing your objects.
- Understand your options for uniquely identifying the records.
- Ensure parent records exist before importing child records.
- Identify the target object attributes that are required in the .csv file for a successful import.

Before You Start

You must do some basic checks before starting your import. For example, make sure that:

- You have completed all the prerequisites for importing each attribute in your source data.
- You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records

All records must be unique in the application. You can use one of these to identify records:

- Public unique identifiers: If you're creating records, then you can provide an easily understandable public unique identifier. These are, usually, denoted with 'Number' and visible in the business object's UI. PUID attributes are usually named <object> Number. If you're updating a record with a Number attribute, then use the Number attribute to identify the record. For more information about public unique identifiers, see the topic "How You Use Alternate Keys to Import Records" in Related Topics section.
- Source system and source system reference: Source system is an identifier for the external system, and source system reference is a unique identifier within the external system. If you're importing new service request references or are updating service request references that have source system reference data, then provide the source system and source system reference values.
Required Attributes and Validations for Service Request Reference Object

To import data successfully into Oracle Applications Cloud, your .csv file must include the required attributes. Ensure that you provide valid values for the attributes.

This table lists the required attributes for service request reference records, prerequisite setup tasks and specific validations, if any:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/ Import Validations</th>
<th>Creating a Service Request Reference record</th>
<th>Updating an Existing Service Request Reference record</th>
</tr>
</thead>
<tbody>
<tr>
<td>Article ID</td>
<td>References CSO_CONTENT_TEXT (ANSWER_ID) which uniquely identifies the specific version of the article.</td>
<td>If the article Id is empty, the object Id must have a value.</td>
<td>Conditionally required</td>
<td>Conditionally required</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>A value is required if you're creating a new reference Id record.</td>
<td>A value is required if you're updating an existing reference Id record and you're not providing the record's unique ID (ReferenceId).</td>
</tr>
<tr>
<td>Article Locale</td>
<td>Specifies locale of the document, such as en_US.</td>
<td>No validation</td>
<td>Conditionally required</td>
<td>Conditionally required</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>A value is required if you're creating a new reference Id record.</td>
<td>A value is required if you're updating an existing reference Id record and you're not providing the record's unique Id (ReferenceId).</td>
</tr>
<tr>
<td>Object ID</td>
<td>Id of the object (such as Note, Defect, Other SR) referencing the service request or referenced by the service request.</td>
<td>If the object Id is empty, the article Id must have a value.</td>
<td>Conditionally required</td>
<td>Conditionally required</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>A value is required if you're creating a new reference Id record.</td>
<td>A value is required if you're updating an existing reference Id record and you're not providing the record's unique Id (ReferenceId).</td>
</tr>
<tr>
<td>Object Type</td>
<td>Indicates the type of object (such as Note, Article, Defect, Other SR) in reference to SR_ID.</td>
<td>If providing a value, it must be ORA_SVC_ARTICLE.</td>
<td>Conditionally required</td>
<td>Conditionally required</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>A value is required if you're creating a new reference Id record.</td>
<td>A value is required if you're updating an existing reference Id record and you're not providing the record's unique Id (ReferenceId).</td>
</tr>
<tr>
<td>Reference ID</td>
<td>Unique Id for reference</td>
<td>No validation</td>
<td>Not required</td>
<td>Conditionally required</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>A value is required if you're updating an existing reference Id and you're not providing the object Id (objectid) or (article Id, object type code and article locale), or (Article Id, Object Type and Article Locale).</td>
<td></td>
</tr>
</tbody>
</table>
Understanding Import and Export Management for CX Sales and B2B Service

Chapter 8
Import Your Data

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/Import Validations</th>
<th>Creating a Service Request Reference record</th>
<th>Updating an Existing Service Request Reference record</th>
</tr>
</thead>
<tbody>
<tr>
<td>Relation Type</td>
<td>Indicates the type of relationship (for example, Related SR).</td>
<td>No validation</td>
<td>Required</td>
<td>Required</td>
</tr>
<tr>
<td>Service Request ID</td>
<td>Service request to which the reference belongs.</td>
<td>No validation</td>
<td>Not required</td>
<td>Conditionally required</td>
</tr>
<tr>
<td>SR Number</td>
<td>The unique number used to identify a service request. You can configure the service request number to a format that's best suitable to your organizational requirements.</td>
<td>No validation</td>
<td>Conditionally required</td>
<td>Conditionally required</td>
</tr>
<tr>
<td>Title</td>
<td>If an article or note is linked to the service request, this is the title of the article.</td>
<td>No validation</td>
<td>Required</td>
<td>Required</td>
</tr>
</tbody>
</table>

Go to Navigator > Tools > Import Management > Import Objects, to see all the attributes of the service request reference object. The page also lists attribute information like type, length, description, and so on.

Create the Source CSV File

You include the data that you want to import into CX Sales and B2B Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator > Tools > Import Management > Import Objects.
2. Select the Service Request Reference object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

**Note:** For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity

After you have the CSV file ready, create an import activity to import the service request reference information. To create an import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click Create Import Activity in the Manage Imports page.
In the **Enter Import Options** page, provide a name for the import activity, and select Service Request Reference from the **Object** drop-down list.

4. Select the CSV file in the **File Name** field, and click **Next**.

5. You would see that the source and target attributes are automatically mapped in the **Map Fields** page. Review and edit the mappings if required.

6. Check the file for unmapped columns or data format issues by clicking **Validate Data**. Click **Next**.

7. Review the import details on the **Review and Submit** page, and click **Submit** when you’re ready.

**Review the Import Results**

Check if your import succeeded on the **Manage Imports** page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to **Navigator > Tools > Import Management > Import Queue**.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the **Status** column for the import activity. The import is successful if the status displays as **Completed**. You can drill down on the import activity to go to the **Import Status** page which provides the status details of the import activity.

**Related Topics**

- Potential Issues When Opening CSV Files in Excel
- How You Use Alternate Keys to Import Records
- Import Data

**Import Your Service Request Resource Data**

You can use the Import Management to create or update service request resource records.

You can import service request resource records using these steps:

1. Map your source service request resource data to Oracle Applications Cloud object attributes. This way the import process would know where to insert each of the information bits.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Check the import results.

**How You Map Your Source Data to Target Object Attributes**

To import your service request resource data into Oracle Applications Cloud, you must populate a .csv file with your source data and map that source data to target object attributes in Oracle Applications Cloud.

You must do the following before creating the .csv file for data import:

- Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
- Ensure prerequisite steps are done, if applicable.
- Understand your options for uniquely identifying the records.
- Ensure parent records exist before importing child records.
- Identify the target object attributes that are required in the .csv file for a successful import.
Before You Start

You must do some basic checks before starting your import. For example, make sure that:

- You have completed all the prerequisites for importing each attribute in your source data.
- You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records

All records must be unique in the application. You can use one of these to identify records:

- Internal ID: If you're identifying a record that already exists in Oracle Applications Cloud, then you can use the internal ID of the record, a system-generated unique identifier Attributes with "id" in the attribute name are typically internal IDs. You can determine the internal ID of a record by exporting Oracle Applications Cloud object data, or by doing a transactional database query. Using an internal ID typically provides better performance and reduces the import duration. For the Service Request Resource object, the attributes are MemberID, ServiceRequestID, and ServiceRequestTeamMemberResourceId.

- Public unique identifiers: If you're creating new records, then you can provide a user-friendly public unique identifier (attributes denoted with 'Number' and usually visible in the business object's UI). If you update a record for which you have previously provided a Number attribute, or for which a Number attribute is visible in the object's UI, you can use the Number attribute to identify the record. For the Service Request Resource object, the attributes are ResourceNumber and ServiceRequestNumber.

Required Attributes and Validations for Service Request Resource Object

To import data successfully into Oracle Applications Cloud, your .csv file must include the required attributes. Ensure that you provide valid values for the attributes.

This table lists the required attributes for importing new Service Request Resource records, required attributes for updating Service Request Resource records, prerequisite setup tasks for the attributes, and specific validations, if any for Service Request Resource import:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/ Import Validations</th>
<th>Creating a Service Request Resource record</th>
<th>Updating an Existing Service Request Resource record</th>
</tr>
</thead>
<tbody>
<tr>
<td>Member ID</td>
<td>The unique ID for the existing member record in the Oracle Fusion destination table.</td>
<td>This is auto generated.</td>
<td>Not required</td>
<td>Conditionally required</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>A value is required if you're updating an existing Member ID and you're not providing the Service Request Id and Party Id (PartyId and Srid).</td>
</tr>
<tr>
<td>ResourceNumber</td>
<td>Unique resource number that identifies the party Id.</td>
<td>If providing a value to update an existing service request resource, the value must exist in the HZ_PARTIES table, column PARTY_NUMBER.</td>
<td>Conditionally required</td>
<td>Conditionally required</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>A value is required if you're adding a new resource to a service request or updating an existing service request resource record and you're</td>
</tr>
</tbody>
</table>

ORACLE
### Attribute Table

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/Import Validations</th>
<th>Creating a Service Request Resource record</th>
<th>Updating an Existing Service Request Resource record</th>
</tr>
</thead>
<tbody>
<tr>
<td>Service Request ID</td>
<td>Specifies the service request to which the service request resource member belongs.</td>
<td>No validation</td>
<td>Conditionally required</td>
<td>Conditionally required</td>
</tr>
<tr>
<td>Service Request Team Member Resource ID</td>
<td>The unique Id of the resource being added/updated to the service request team.</td>
<td>If providing a value to update an existing account, the value must exist in the HZ_PARTIES table, column PARTY_ID.</td>
<td>Conditionally required</td>
<td>Conditionally required</td>
</tr>
<tr>
<td>Name</td>
<td>The name of the resource added as the service request resource member.</td>
<td>No validation</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>Service Request Number</td>
<td>The unique number used to identify a service request. You can configure the service request number to a format that’s best suitable to your organizational requirements.</td>
<td>No validation</td>
<td>Conditionally required</td>
<td>Conditionally required</td>
</tr>
<tr>
<td>Assigned To</td>
<td>Specifies the resource to which the service request is assigned.</td>
<td>No validation</td>
<td>Not required</td>
<td>Not required</td>
</tr>
</tbody>
</table>

You can view the Service Request Resource object along with all its child objects and attributes in the Manage Import Objects page of the Import Management flow. You can find attribute information like type, length, description, and so on, on this page.

### Create the Source CSV File

You include the data that you want to import into CX Sales and B2B Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to **Navigator > Tools > Import Management > Import Objects**.
2. Select the **Service Request Resource** object in the table and click **Download**.

You can now edit the downloaded file and provide valid values for the required attributes.

**Note:** For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.

### Create the Import Activity

After you have the CSV file ready, create an import activity to import the service request resource information. To create an import activity:

1. Go to **Navigator > Tools > Import Management > Import Queue**.
2. Click **Create Import Activity** in the Manage Imports page.
3. In the **Enter Import Options** page, provide a name for the import activity, and select Service Request Resource from the **Object** drop-down list.
4. Select the CSV file in the **File Name** field, and click **Next**.
5. You would see that the source and target attributes are automatically mapped in the **Map Fields** page. Review and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking **Validate Data**. Click **Next**.
7. Review the import details on the **Review and Submit** page, and click **Submit** when you're ready.

### Review the Import Results

Check if your import succeeded on the **Manage Imports** page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to **Navigator > Tools > Import Management > Import Queue**.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the **Status** column for the import activity. The import is successful if the status displays as **Completed**. You can drill down on the import activity to go to the **Import Status** page which provides the status details of the import activity.

**Related Topics**

- Potential Issues When Opening CSV Files in Excel
- How You Use Alternate Keys to Import Records
- Import Data

### Import Your SmartText Data

You can use Import Management to create, update, or delete SmartText records.

To import SmartText records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.
How You Map Your Source Data to Object Attributes

To import your SmartText data into Oracle Applications Cloud, you must populate a .csv file with your source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

- Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
- Ensure any prerequisite setups are completed.
- Understand your options for uniquely identifying the records.
- Ensure parent records exist before importing child records.
- Identify the target object attributes that are required in the CSV file for a successful import.

Before You Start

You must do some basic checks before starting your import. For example, make sure that:

- You have completed all the prerequisites for importing each attribute in your source data.
- You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records

To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the import process to uniquely identify the records. The file import process uses the attribute values to automatically map your source data to the target object attributes in Oracle Applications Cloud.

The preferred options for uniquely identifying an object record are as follows:

- Internal ID: If you're identifying a record that already exists in Oracle Applications Cloud, then you can use the internal ID of the record, a system-generated unique identifier. Attributes with "Id" in the attribute name are typically internal IDs. You can determine the internal ID of a record by exporting Oracle Applications Cloud object data, or by doing a transactional database query. Using an internal ID typically provides better performance and reduces the import duration. For the SmartText object, this attribute is StdTxtId.

- Public unique identifiers: If you are creating new records, then you can provide a user-friendly public unique identifier (PUID) which is an attribute denoted with 'Number'. For the SmartText object, the attribute is StdTxtUniqueNumber. If you update a record for which you have previously provided a StdTxtUniqueNumber, you can use the StdTxtUniqueNumber attribute to identify the record.

Required Attributes and Validations for SmartText Object

To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure that you provide valid values for the attributes. This table lists the required attributes for importing new SmartText records, required attributes for updating SmartText records, prerequisite setup tasks for the attributes, and specific validations, if any, for SmartText import:
<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Data Type</th>
<th>Data Length</th>
<th>Prerequisite Setup Task/Import Validations</th>
<th>Creating a Smart Text Record</th>
<th>Updating an Existing Smart Text Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>StdTxtId</td>
<td>The unique Id for the existing SmartText record in the Oracle Fusion destination table.</td>
<td>Number</td>
<td>18</td>
<td>No Validation</td>
<td>Not required</td>
<td>Conditionally required</td>
</tr>
</tbody>
</table>
| StdtxtName      | Name of the SmartText                                                      | Varchar   | 50          | Validation is performed for the creation of a SmartText to ensure the following combination of values doesn't exist:  
  - StdtxtName  
  - Registry ID  
  - Domain  
  - StripeCd  
  - BuOrgId | Required | Not required |
| StdTxtUniqueNumber | The public unique identifier (PUID) used to identify a SmartText. You can configure the standard text unique number to a format that is most suitable to the need of your organization. | Varchar   | 30          | Validation performed for the creation of a smarttext, ensuring the smart text unique number isn't already in use. | Not required | Conditionally required. A value is required if you’re updating an existing SmartText and you’re not providing the SmartText Identifier (StdTxtId). |
| StripeCd       | The stripe to which this SmartText is associated                           | Varchar   | 30          | A value is defaulted based on the application context. However, if a value is populated, validation is performed against the list of valid values in the lookup type ORA_SVC_STRIPE_CD. | Not Required | Not required |
| HtmlFlag        | A Y/N value indicating if the                                               | Varchar   | 1           | A default value of "N" is provided. If a | Not required | Not required |

**Adding Data**

To add data, you must have the appropriate permissions to create or update SmartText records in the Oracle Fusion destination table. The fields marked as required must be populated to ensure that the SmartText record is valid.

**Validating Data**

When creating a SmartText record, validation is performed to ensure that the SmartText name is unique within the organization's domain. This validation is performed against the following fields:

- StdtxtName
- Registry ID
- Domain
- StripeCd
- BuOrgId

For updating an existing SmartText record, validation is performed to ensure that the SmartText unique number is unique and hasn't already been assigned to another record.
### Attribute | Description | Data Type | Data Length | Prerequisite Setup Task/ Import Validations | Creating a Smart Text Record | Updating an Existing Smart Text Record
--- | --- | --- | --- | --- | --- | ---
SmartText contains HTML. | | | | value is populated, validation is performed against the list of valid values in the lookup type YES_NO. | The value “N” is defaulted, if no value is provided. | |
Scope | Indicates if the SmartText is private or public | Varchar | 20 | A default value of “ORA_SVC_USER” is provided. If a value is populated, validation is performed against the list of valid values in the lookup type YES_NO. | Not required | Not required
Domain | Specifies the domain to which the SmartText is assigned | Varchar | 30 | No default value is provided. If a value is populated, validation is performed against the list of valid values in the lookup type YES_NO. | Not required | Not required
Object | Specifies the business object to which the SmartText is associated. | Varchar | 150 | No default value is provided. The value provided should be a value of the VIEW_OBJECT_CODE from the SVC_STD_TXT_OBJECTS table. For instance, ServiceRequestVO. | Required | Not required
StartDate | Allows you to specify a date when the SmartText is valid. | Date | | The system date is used, if no value is specified. | Not required | Not required
EnabledFlag | Specifies if the SmartText is available for use. | Varchar | 1 | A default value of “Y” is provided. If a value is populated, validation is performed against the list of valid values in the lookup type YES_NO. | Not required | Not required
<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Data Type</th>
<th>Data Length</th>
<th>Prerequisite Setup Task/Import Validations</th>
<th>Creating a Smart Text Record</th>
<th>Updating an Existing Smart Text Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>UserPartyId</td>
<td>The foreign key value to the Parties table</td>
<td>Number</td>
<td>18</td>
<td>Import any new parties into the database.</td>
<td>Conventionally Required. If the Scope is set to ORA_SVC_USER, either the UserPartyId or the Registry ID is required.</td>
<td>Not required</td>
</tr>
<tr>
<td>Registry ID</td>
<td>This is the public unique identifier of the user assigned to this private SmartText.</td>
<td>Varchar</td>
<td>30</td>
<td>Import any new parties into the database.</td>
<td>Conventionally Required. If the Scope is set to ORA_SVC_USER, either the UserPartyId or the Registry ID is required.</td>
<td>Not required</td>
</tr>
<tr>
<td>Folder ID</td>
<td>The foreign key value to the SmartText folders table</td>
<td>Number</td>
<td>18</td>
<td>Import any new SmartText folders into the database.</td>
<td>Conventionally Required. If the Scope is set to ORA_SVC_GLOBAL, either the Folder ID or the FolderUniqueNumber is required.</td>
<td>Not required</td>
</tr>
<tr>
<td>FolderUniqueNumb</td>
<td>This is the public unique identifier of the user assigned to the folder of this SmartText.</td>
<td>Varchar</td>
<td>30</td>
<td>Import any new SmartText folders into the database.</td>
<td>Conventionally Required. If the Scope is set to ORA_SVC_GLOBAL, either the Folder ID or the FolderUniqueNumber is required.</td>
<td>Not required</td>
</tr>
<tr>
<td>BuOrgId</td>
<td>This is the business unit organization Id. If multiple business unit support is enabled using the HZ_ENABLE_MULTIPLE_BU_CRM profile option, this value will allow segregation of data accordingly.</td>
<td>Number</td>
<td>18</td>
<td>No Validation</td>
<td>Not Required A value is defaulted based on the application context.</td>
<td>Not Required</td>
</tr>
</tbody>
</table>
Create the Source CSV File

You include the data that you want to import into CX Sales and B2B Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to **Navigator > Tools > Import Management > Import Objects**.
2. Select the **StandardText** object in the table and click **Download**.

You can now edit the downloaded file and provide valid values for the required attributes.

**Note:** For help in populating the CSV file and to avoid any issues in entering values, see the topic **Potential Issues When Opening CSV Files With Excel** in Related Topics section.

Create the Import Activity

After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to **Navigator > Tools > Import Management > Import Queue**.
2. Click **Create Import Activity** in the **Manage Imports** page.
3. In the **Enter Import Options** page, provide a name for the import activity, and select **StandardText** from the **Object** drop-down list.
4. Select the CSV file in the **File Name** field, and click **Next**.
5. You will see that the source and target attributes are automatically mapped in the **Map Fields** page. Review and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking **Validate Data**. Click **Next**.
7. Review the import details on the **Review and Submit** page, and click **Submit** to complete the request.
Review the Import Results

Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed. You can drill down on the import activity to go to the Import Status page which provides the status details of the import activity.

Related Topics
- Potential Issues When Opening CSV Files in Excel
- Import Data

Import Your SmartText Folder Data

You can use Import Management to create or update SmartText Folder records.

To import SmartText Folder records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Object Attributes

To import your SmartText Folder data into Oracle Applications Cloud, you must populate a .csv file with your source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

- Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
- Ensure any prerequisite setups are completed.
- Understand your options for uniquely identifying the records.
- Ensure parent records exist before importing child records.
- Identify the target object attributes that are required in the CSV file for a successful import.

Before You Start

You must do some basic checks before starting your import. For example, make sure that:

- You have completed all the prerequisites for importing each attribute in your source data.
- You have all parent records in place before importing child records.
Select a Unique Identifier for Your Records

To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the import process to uniquely identify the records. The file import process uses the attribute values to automatically map your source data to the target object attributes in Oracle Applications Cloud.

The preferred options for uniquely identifying an object record are as follows:

- **Internal ID:** If you're identifying a record that already exists in Oracle Applications Cloud, then you can use the internal ID of the record, a system-generated unique identifier. Attributes with "Id" in the attribute name are typically internal IDs. You can determine the internal ID of a record by exporting Oracle Applications Cloud object data, or by doing a transactional database query. Using an internal ID typically provides better performance and reduces the import duration. For the StandardTextFolder object, this attribute is Folder ID.

- **Public unique identifiers:** If you are creating new records, then you can provide a user-friendly public unique identifier (PUID) which is an attribute denoted with 'Number'. For the SmartText object, the attribute is FolderUniqueNumber. If you update a record for which you have previously provided a FolderUniqueNumber, you can use the FolderUniqueNumber attribute to identify the record.

### Required Attributes and Validations for SmartText Folder Object

To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure that you provide valid values for the attributes. This table lists the required attributes for importing new SmartText Folder records, required attributes for updating SmartText Folder records, prerequisite setup tasks for the attributes, and specific validations, if any, for SmartText Folder import:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Data Type</th>
<th>Data Length</th>
<th>Prerequisite Setup Task/ Import Validations</th>
<th>Creating a SmartText Folder Record</th>
<th>Updating an Existing SmartText Folder Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>FolderId</td>
<td>The unique Id for the existing SmartText Folder record in the Oracle Fusion destination table.</td>
<td>Number</td>
<td>18</td>
<td>No Validation</td>
<td>Not required</td>
<td>Conditionally required</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>A value is required if you're updating an existing SmartText Folder and you're not providing the Folder Unique Number.</td>
</tr>
<tr>
<td>ParentId</td>
<td>The Folder ID of the parent folder</td>
<td>Number</td>
<td>18</td>
<td>No Validation</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>If populated, this can be used instead of ParentFolderUniqueNumber</td>
</tr>
<tr>
<td>Name</td>
<td>Name of the SmartText Folder</td>
<td>Varchar</td>
<td>50</td>
<td>Validation is performed for the creation of a SmartText folder to ensure the following</td>
<td>Required</td>
<td>Not required</td>
</tr>
</tbody>
</table>

694
### Attribute Description Data Type Data Length Prerequisite Setup Task/ Import Validations Creating a SmartText Folder Record Updating an Existing SmartText Folder Record

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Data Type</th>
<th>Data Length</th>
<th>Prerequisite Setup Task/ Import Validations</th>
<th>Creating a SmartText Folder Record</th>
<th>Updating an Existing SmartText Folder Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>FolderUniqueNumber</td>
<td>The unique number used to identify a SmartText folder. You can configure the folder unique number to a format that's best suitable to your organizational requirements.</td>
<td>Varchar</td>
<td>30</td>
<td>Validation is performed for the creation of a SmartText folder, ensuring the folder unique number isn't already in use.</td>
<td>Not required</td>
<td>Conditionally required</td>
</tr>
<tr>
<td>ParentFolderUniqueNumber</td>
<td>The unique number used to identify a Parent SmartText Folder.</td>
<td>Varchar</td>
<td>30</td>
<td>Validation is performed for the creation of a SmartText Folder, ensuring the Parent SmartText Folder unique number is a valid Folder Unique Name.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>StripeCd</td>
<td>The stripe to which this SmartText folder is associated</td>
<td>Varchar</td>
<td>30</td>
<td>A value is defaulted based on the application context. However, if a value is populated, validation is performed against the list of valid values in the lookup type ORA_SVC_STRIPE_CD.</td>
<td>Not Required</td>
<td>Not required</td>
</tr>
<tr>
<td>Domain</td>
<td>Specifies the domain to which the SmartText folder is assigned</td>
<td>Varchar</td>
<td>30</td>
<td>No default value is provided. If a value is populated, validation is performed against the list of valid values in the</td>
<td>Not required</td>
<td>Not required</td>
</tr>
</tbody>
</table>
You can view the StandardTextFolder object and attributes in the Manage Import Objects page of the Import Management flow. You can find attribute information like type, length, and description on this page.

### Create the Source CSV File

You include the data that you want to import into CX Sales and B2B Service in a source CSV file. You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator > Tools > Import Management > Import Objects.
2. Select the StandardTextFolder object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

**Note:** For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.

### Create the Import Activity

After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select StandardTextFolder from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit to complete the request.
Review the Import Results

Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed. You can drill down on the import activity to go to the Import Status page which provides the status details of the import activity.

Related Topics
- Potential Issues When Opening CSV Files in Excel
- Import Data

Import Your SmartText User Variable Data

You can use Import Management to create, update, or delete SmartText User Variable records.

To import SmartText User Variable records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Object Attributes

To import your SmartText User Variable data into Oracle Applications Cloud, you must populate a .csv file with your source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

- Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
- Ensure any prerequisite setups are completed.
- Understand your options for uniquely identifying the records.
- Ensure parent records exist before importing child records.
- Identify the target object attributes that are required in the CSV file for a successful import.

Before You Start

You must do some basic checks before starting your import. For example, make sure that:

- You have completed all the prerequisites for importing each attribute in your source data.
- You have all parent records in place before importing child records.
Select a Unique Identifier for Your Records

To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the import process to uniquely identify the records. The file import process uses the attribute values to automatically map your source data to the target object attributes in Oracle Applications Cloud.

The preferred options for uniquely identifying an object record are as follows:

- **Internal ID:** If you're identifying a record that already exists in Oracle Applications Cloud, then you can use the internal ID of the record, a system-generated unique identifier. Attributes with "Id" in the attribute name are typically internal IDs. You can determine the internal ID of a record by exporting Oracle Applications Cloud object data, or by doing a transactional database query. Using an internal ID typically provides better performance and reduces the import duration. For the SmartText User Variable object, this attributes is **VariableId**.

- **Public unique identifiers:** If you are creating new records, then you can provide a user-friendly public unique identifier (PUID) which is an attribute denoted with 'Number'. For the SmartText object, the attribute is **VariableUniqueNumber**. If you update a record for which you have previously provided a **VariableUniqueNumber**, you can use the **VariableUniqueNumber** attribute to identify the record.

### Required Attributes and Validations for SmartText User Variable Object

To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure that you provide valid values for the attributes. This table lists the required attributes for importing new SmartText User Variable records, required attributes for updating SmartText User Variable records, prerequisite setup tasks for the attributes, and specific validations, if any, for SmartText User Variable import:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Data Type</th>
<th>Data Length</th>
<th>Prerequisite Setup Task/Import Validations</th>
<th>Creating a SmartText User Variable Record</th>
<th>Updating an Existing SmartText User Variable Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>VariableId</td>
<td>The unique Id for the existing SmartText User Variable record in the Oracle Fusion destination table.</td>
<td>Number</td>
<td>18</td>
<td>No Validation</td>
<td>Not required</td>
<td>Conditionally required</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>A value is required if you’re updating an existing SmartText User Variable and you’re not providing the Variable Unique Number.</td>
</tr>
</tbody>
</table>
| Variable       | Name of the SmartText User Variable                                         | Varchar   | 50          | Validation is performed for the creation of a SmartText user variable to ensure the following combination of values doesn’t exist:  
  - Variable  
  - Context  | Required                                                                 | Not required |
## Attribute Table

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Data Type</th>
<th>Data Length</th>
<th>Prerequisite Setup Task/Import Validations</th>
<th>Creating a SmartText User Variable Record</th>
<th>Updating an Existing SmartText User Variable Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>VariableUniqueNumber</td>
<td>The unique number used to identify a SmartText user variable. You can configure the variable unique number to a format that’s best suitable to your organizational requirements.</td>
<td>Varchar</td>
<td>30</td>
<td>Validation performed for the creation of a SmartText user variable, ensuring the SmartText user variable unique number isn’t already in use.</td>
<td>Not required</td>
<td>Conditionally required. A value is required if you’re updating an existing SmartText User Variable and you’re not providing the SmartText User Variable Identifier (VariableId).</td>
</tr>
<tr>
<td>StripeCd</td>
<td>The stripe to which this SmartText user variable is associated.</td>
<td>Varchar</td>
<td>30</td>
<td>A value is defaulted based on the application context. However, if a value is populated, validation is performed against the list of valid values in the lookup type ORA_SVC_STRIPE_CD.</td>
<td>Not Required</td>
<td>Not required</td>
</tr>
<tr>
<td>Object</td>
<td>Specifies the business object to which the SmartText user variable is associated.</td>
<td>Varchar</td>
<td>30</td>
<td>No default value is provided. The value provided should be a value of the VIEW_OBJECT_CODE from the SVC_STD_TXT_OBJECTS table. For instance, ServiceRequestVO.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>Context</td>
<td>Specifies the context to which the SmartText user variable is associated.</td>
<td>Varchar</td>
<td>50</td>
<td>A default value of ORA_SVC_SR is provided. However, if a value is populated, validation is performed against the list of valid values in the lookup type ORA_SVC_STDTXT_TYPE_CD.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
</tbody>
</table>
You can view the StandardTextUserVariable object and attributes in the Manage Import Objects page of the Import Management flow. You can find attribute information like type, length, and description on this page.

### Create the Source CSV File

You include the data that you want to import into CX Sales and B2B Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to **Navigator > Tools > Import Management > Import Objects**.
2. Select the **StandardTextUserVariable** object in the table and click **Download**.

You can now edit the downloaded file and provide valid values for the required attributes.

**Note:** For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.

### Create the Import Activity

After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to **Navigator > Tools > Import Management > Import Queue**.
2. Click **Create Import Activity** in the **Manage Imports** page.
3. In the **Enter Import Options** page, provide a name for the import activity, and select **StandardTextUserVariable** from the **Object** drop-down list.
4. Select the CSV file in the **File Name** field, and click **Next**.
5. You would see that the source and target attributes are automatically mapped in the **Map Fields** page. Review and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking **Validate Data**. Click **Next**.
7. Review the import details on the **Review and Submit** page, and click **Submit** to complete the request.

### Review the Import Results

Check if your import succeeded on the **Manage Imports** page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to **Navigator > Tools > Import Management > Import Queue**.
2. Click All Imports and search for the import activity that you created earlier.

3. Check the **Status** column for the import activity. The import is successful if the status displays as **Completed**. You can drill down on the import activity to go to the **Import Status** page which provides the status details of the import activity.

---

**Related Topics**
- Potential Issues When Opening CSV Files in Excel
- Import Data

### Import Your Source System Reference Data

You can use Import Management to create or update Source System Reference records.

To import Source System Reference records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

### How You Map Your Source Data to Target Object Attributes

To import your Source System Reference data into Oracle Applications Cloud, you need to populate a CSV file with your source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

- Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
- Ensure prerequisite setups are done, if applicable.
- Understand your options for uniquely identifying the records.
- Ensure parent records exist before importing child records.
- Identify the target object attributes that are required in the CSV file for a successful import.

### Before You Start

You must do some basic checks before starting your import. For example, make sure that:

- You have completed all the prerequisites for importing each attribute in your source data.
- You have all parent records in place before importing child records.

### Select a Unique Identifier for Your Records

To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the import process to uniquely identify the records. The file import process uses the attribute values to automatically map your source data to the target object attributes in Oracle Applications Cloud.
The preferred options for uniquely identifying an object record are as follows:

- **Internal ID:** If you’re identifying a record that already exists in Oracle Applications Cloud, then you can use the internal ID of the record, a system-generated unique identifier. Attributes with "id" in the attribute name are typically internal IDs. Use this option only if you’re updating Source System References. You can determine the internal ID of a record by exporting Oracle Applications Cloud object data, or by doing a transactional database query. Using an internal ID typically provides better performance and reduces the import duration. For the Source System Reference object, the attributes are SourceSystemReferenceId and PartyId.

- **Public unique identifiers:** If you’re creating new records, then you can provide a user-friendly public unique identifier (attributes denoted with ‘Number’ and usually visible in the business object’s UI). If you update a record for which you have previously provided a Number attribute, or for which a Number attribute is visible in the object’s UI, you can use the Number attribute to identify the record. For the Source System Reference object, the attribute is PartyNumber.

### Required Attributes and Validations for Source System Reference Object

To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure that you provide valid values for the attributes. This table lists the required attributes for importing new Source System Reference records, required attributes for updating Source System Reference records, prerequisite setup tasks for the attributes, and specific validations, if any, for Source System Reference import:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Data Type</th>
<th>Data Length</th>
<th>Prerequisite Setup Task/Import Validations</th>
<th>Creating a Source System Reference Record</th>
<th>Updating an Existing Source System Reference Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>SourceSystemReferenceId</td>
<td>Source system reference identifier. This is a primary key.</td>
<td>Number</td>
<td>18</td>
<td>No validation</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>SourceSystem</td>
<td>Original source system name</td>
<td>Varchar</td>
<td>30</td>
<td>This has to be in HZ_ORIG_SYSTEMS_B with status &quot;A&quot;.</td>
<td>Provide a valid value.</td>
<td>Not required</td>
</tr>
<tr>
<td>SourceSystemReferenceValue</td>
<td>Identifier in the original source system.</td>
<td>Varchar</td>
<td>255</td>
<td>No validation</td>
<td>Provide a valid value.</td>
<td>Not required</td>
</tr>
<tr>
<td>Status</td>
<td>Denotes either ACTIVE or INACTIVE</td>
<td>Varchar</td>
<td>1</td>
<td>No validation</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>StartDate</td>
<td>Start date of the source system reference in the source system.</td>
<td>Date</td>
<td></td>
<td>No validation</td>
<td>If you don’t provide a value, it defaults to the current date.</td>
<td>Not required</td>
</tr>
<tr>
<td>Attribute</td>
<td>Description</td>
<td>Data Type</td>
<td>Data Length</td>
<td>Prerequisite Setup Task/ Import Validations</td>
<td>Creating a Source System Reference Record</td>
<td>Updating an Existing Source System Reference Record</td>
</tr>
<tr>
<td>----------------------------</td>
<td>------------------------------------------------------------------------------</td>
<td>-----------</td>
<td>-------------</td>
<td>---------------------------------------------</td>
<td>---------------------------------------------</td>
<td>--------------------------------------------------</td>
</tr>
<tr>
<td>EndDate</td>
<td>End date of the source system reference in the source system.</td>
<td>Date</td>
<td></td>
<td>No validation</td>
<td>If you don't provide a value, it defaults to 12/31/4712.</td>
<td>Not required</td>
</tr>
<tr>
<td>PartyId</td>
<td>Party identifier to which the source system reference is associated</td>
<td>Number</td>
<td>18</td>
<td>No validation</td>
<td>Provide one of the following :</td>
<td>Not required</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>• PartyId</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>• Party Number</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>• A combination of Party Source System and Party Source System Reference Value</td>
<td></td>
</tr>
<tr>
<td>PartyNumber</td>
<td>Party's PUID to which the source system reference is associated</td>
<td>Varchar</td>
<td>30</td>
<td>No validation</td>
<td>Provide one of the following :</td>
<td>Not required</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>• PartyId</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>• Party Number</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>• A combination of Party Source System and Party Source System Reference Value</td>
<td></td>
</tr>
<tr>
<td>Party Source System</td>
<td>Specifies the original source system of the party</td>
<td>Varchar</td>
<td>30</td>
<td>No validation</td>
<td>Provide one of the following :</td>
<td>Not required</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>• PartyId</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>• Party Number</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>• A combination of Party Source System and Party Source System Reference Value</td>
<td></td>
</tr>
<tr>
<td>Party Source System Reference Value</td>
<td>Specifies the party's source system reference</td>
<td>Varchar</td>
<td>255</td>
<td>No validation</td>
<td>Provide one of the following :</td>
<td>Not required</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>• PartyId</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>• Party Number</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>• A combination of Party Source System and Party Source System Reference Value</td>
<td></td>
</tr>
</tbody>
</table>
Import Your Data

### Attribute | Description | Data Type | Data Length | Prerequisite Setup Task/Import Validations | Creating a Source System Reference Record | Updating an Existing Source System Reference Record
--- | --- | --- | --- | --- | --- | ---
| | in the original source system | | | | | |

You can view the Source System Reference object along with all its child objects and attributes in the Manage Import Objects page of the Import Management flow. You can find attribute information like type, length, description, and so on, on this page.

**Note:** To directly update the `SourceSystemReferenceValue` field, you must use the `SourceSystemReferenceId` as the record identifier.

### Create the Source CSV File

You include the data that you want to import into CX Sales and B2B Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to **Navigator > Tools > Import Management > Import Objects**.
2. Select the **Source System Reference** object in the table and click **Download**.

You can now edit the downloaded file and provide valid values for the required attributes.

**Note:** For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.

### Create the Import Activity

After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to **Navigator > Tools > Import Management > Import Queue**.
2. Click **Create Import Activity** in the **Manage Imports** page.
3. In the **Enter Import Options** page, provide a name for the import activity, and select **Source System Reference** from the **Object** drop-down list.
4. Select the CSV file in the **File Name** field, and click **Next**.
5. You would see that the source and target attributes are automatically mapped in the **Map Fields** page. Review and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking **Validate Data**. Click **Next**.
7. Review the import details on the **Review and Submit** page, and click **Submit** when you're ready.
You can use the following steps to inactivate origin system and origin system reference for the source system reference object:

1. Create a source CSV file with values for the attributes SourceSystem, SourceSystemReferenceValue, and SourceSystemReferenceId. You can find the values for these attributes by exporting the source system reference object records using Export Management.
2. Create an import activity using the object Source System and the import mode Delete records.
3. If required, map the attributes on the Map Fields page, and submit the import activity.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed. You can drill down on the import activity to go to the Import Status page which provides the status details of the import activity.

Related Topics
• Potential Issues When Opening CSV Files in Excel
• Import Data

Import Your Subscription Data
You can use import management to create or update Subscription records.

To import Subscription records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes
To import your Subscription data into Oracle Applications Cloud, you need to populate a CSV file with your source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
• Ensure prerequisite setups are done, if applicable.
• Understand your options for uniquely identifying the records.
• Ensure parent records exist before importing child records.
• Identify the target object attributes that are required in the CSV file for a successful import.
Before You Start

You must do some basic checks before starting your import. For example, make sure that:

- You have completed all the prerequisites for importing each attribute in your source data.
- You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records

To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the import process to uniquely identify the records. The file import process uses the attribute values to automatically map your source data to the target object attributes in Oracle Applications Cloud.

The preferred option for uniquely identifying an object record is through the Public unique identifier. If you’re creating new records, then you can provide a user-friendly public unique identifier (attributes denoted with ‘Number’ and usually visible in the business object’s UI). If you update a record for which you have previously provided a Number attribute, or for which a Number attribute is visible in the object’s UI, you can use the Number attribute to identify the record. For the Subscription object, the attributes are SubscriptionNumber, ExemptCertificateNumber, and BillToAccountNumber.

Required Attributes and Validations for Subscription Object

To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure that you provide valid values for the attributes. This table lists the required attributes for importing new Subscription records, required attributes for updating Subscription records, prerequisite setup tasks for the attributes, and specific validations, if any, for Subscription import:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/Import Validations</th>
<th>Creating a Subscription Record</th>
<th>Updating an Existing Subscription Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>ChargeDefinition</td>
<td>The definition that indicates the purpose of the charge.</td>
<td>This must be setup in Fusion Pricing.</td>
<td>Required</td>
<td>Not Required</td>
</tr>
<tr>
<td>DefinitionOrganizationId</td>
<td>The item master organization</td>
<td>This must be a valid ORGANIZATION_ID from the HR_ALL_ORGANIZATION_UNITS_F table.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>PartialPeriodType</td>
<td>The partial period type. The values might be actual or fixed.</td>
<td>Lookup: ORA_OSS_PERIOD_TYPE</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>PartialPeriodStart</td>
<td>The partial period start. The values might be calendar or service.</td>
<td>Lookup: ORA_OSS_PERIOD_START</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>SubscriptionId</td>
<td>The subscription ID</td>
<td>This is automatically generated when the record is created.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>Attribute</td>
<td>Description</td>
<td>Prerequisite Setup Task/ Import Validations</td>
<td>Creating a Subscription Record</td>
<td>Updating an Existing Subscription Record</td>
</tr>
<tr>
<td>------------------------</td>
<td>---------------------------------------</td>
<td>----------------------------------------------------------------------------------</td>
<td>-------------------------------</td>
<td>------------------------------------------</td>
</tr>
<tr>
<td>BusinessUnitId</td>
<td>The business unit ID</td>
<td>This must be a valid business unit ID.</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td>LegalEntityId</td>
<td>The legal entity ID</td>
<td>This must be a valid value record as per GL_LEDGER_LE_V.</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td>SubscriptionProfileId</td>
<td>The subscription profile ID</td>
<td>This must be a valid subscription profile ID - OSS_SUBSCRIPTION_PROFILE.</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td>PrimaryPartyId</td>
<td>The primary party ID</td>
<td>Lookup: HZ_PARTIES</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td>Currency</td>
<td>The subscription currency.</td>
<td>This must be a valid currency.</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td>Status</td>
<td>The subscription status</td>
<td>This must be ORA_DRAFT or ORA_ACTIVE.</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td>AccountingRuleId</td>
<td>The accounting rule ID</td>
<td>RA_RULES.RULE_ID where TYPE in 'A','ACC_DUR', 'PP_DUR', 'PP_DUR_PP', or 'PP_DR_PP'</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>TransactionTypeName</td>
<td>The accounts receivables transaction type name</td>
<td>This must be a valid transaction type name as per the RA_CUST_TRX_TYPES_ALL table.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>BillToAccountId</td>
<td>The bill-to account ID</td>
<td>HZ_CUST_ACCOUNTS.CUST_ACCOUNT_ID</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td>BillToSiteUseId</td>
<td>The bill-to site use ID</td>
<td>HZ_CUST_SITE_USES_ALL.SITE_USE_ID</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td>SubscriptionNumber</td>
<td>The subscription number</td>
<td>This must be a unique number. It can be an alphanumeric value. This serves as the PUID for the subscription.</td>
<td>Required</td>
<td>Required</td>
</tr>
<tr>
<td>ShipToPartySiteId</td>
<td>The ship-to part site ID</td>
<td>HZ_CUST_SITE_USES_ALL.SITE_USE_ID</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>ShipToSite</td>
<td>The ship-to site</td>
<td>HZ_CUST_SITE_USES_ALL.SITE_USE_ID</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>Attribute</td>
<td>Description</td>
<td>Prerequisite Setup Task/Import Validations</td>
<td>Creating a Subscription Record</td>
<td>Updating an Existing Subscription Record</td>
</tr>
<tr>
<td>---------------------------</td>
<td>---------------------------</td>
<td>-----------------------------------------------------------------------------------------------------------</td>
<td>-------------------------------</td>
<td>-----------------------------------------</td>
</tr>
<tr>
<td>PaymentMethod</td>
<td>The payment method</td>
<td>This must be ORA_PURCHASE_ORDER or ORA_WIRE.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>PaymentMethodName</td>
<td>The payment method name</td>
<td>This must be Purchase Order or Wire.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>PaymentTermsName</td>
<td>The payment terms name</td>
<td>RA_TERMS_VL.NAME</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>TaxClassificationCode</td>
<td>The tax classification code</td>
<td>LOOKUP_TYPE: ZX_OUTPUT_CLASSIFICATIONS</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>TaxClassificationMeaning</td>
<td>The tax classification meaning</td>
<td>LOOKUP_TYPE: ZX_OUTPUT_CLASSIFICATIONS</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>ExemptCertificateNumber</td>
<td>The tax exempt certificate number</td>
<td>ZX_EXEMPTIONS_V.EXEMPT_CERTIFICATE_NUMBER</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>ExemptReason</td>
<td>The tax exempt reason code</td>
<td>LOOKUP_TYPE: ZX_EXEMPTION_CONTROL</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>ExemptReasonMeaning</td>
<td>The tax exempt reason meaning</td>
<td>LOOKUP_TYPE: ZX_EXEMPTION_CONTROL</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>TaxExemptionHandling</td>
<td>The tax exemption handling code</td>
<td>LOOKUP_TYPE: ZX_EXEMPTION_CONTROL</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>TaxExemptionHandlingName</td>
<td>The tax exemption handling name</td>
<td>LOOKUP_TYPE: ZX_EXEMPTION_CONTROL</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>DocumentFiscalClassification</td>
<td>The document fiscal classification</td>
<td>ZX_FC_DOCUMENT_FISCAL_V.CLASSIFICATION_CODE</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>CustomerAcceptance</td>
<td>The customer acceptance</td>
<td>Lookup: ORA_OSS_CUST_ACCEPTANCE - Values REQUIRED OR NOTREQUIRED</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>InternalApproval</td>
<td>The internal approval</td>
<td>Lookup: ORA_OSS_INT_APPROVAL_OPTIONS</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>LayoutTemplate</td>
<td>The layout template</td>
<td>This must be a valid layout template setup in the BI publisher.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>Attribute</td>
<td>Description</td>
<td>Prerequisite Setup Task/Import Validations</td>
<td>Creating a Subscription Record</td>
<td>Updating an Existing Subscription Record</td>
</tr>
<tr>
<td>--------------------------</td>
<td>--------------------------------------</td>
<td>------------------------------------------</td>
<td>--------------------------------</td>
<td>------------------------------------------</td>
</tr>
<tr>
<td>CommunicationChannel</td>
<td>The communication channel</td>
<td>Lookup: ORA_OSS_COMM_CHANNEL - Values EMAIL, OFFLINE, ONLINE, CUSTOM</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>PrimarySalesPerson</td>
<td>The primary sales person</td>
<td>This must be a valid sales person.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>NegotiationLanguage</td>
<td>The negotiation language</td>
<td>fnd_languages_v1.LANGUAGE_CODE</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>QuoteToContactId</td>
<td>The contact ID to which renewal quote is sent to</td>
<td>This must be a valid contact ID.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>EnableRenewalRemindersFlg</td>
<td>Check box for the enable renewal reminders</td>
<td>Y or N</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>RenewalProcess</td>
<td>Renewal Process</td>
<td>Lookup: ORA_OSS_RENEWAL_TYPE</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>CurrencyConversionRate</td>
<td>The currency conversion rate</td>
<td>This must be valid as per GL_DAILY_CONVERSION_TYPES.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>CurrencyConversionRateType</td>
<td>The currency conversion rate type</td>
<td>This must be valid as per GL_DAILY_CONVERSION_TYPES.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>Duration</td>
<td>The subscription duration</td>
<td>This must be an integer.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>Period</td>
<td>The subscription period</td>
<td>This must be a valid value from OSS_TIME_CODE_UNITS.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>EndDate</td>
<td>The end date of the subscription</td>
<td>This date must be equal to or later than the start date.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>CloseReason</td>
<td>The close reason</td>
<td>Lookup: ORA_OSS_CLOSE_REASONS</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>BusinessUnitName</td>
<td>The business unit name</td>
<td>This must be a valid business unit name.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>LegalEntityName</td>
<td>The legal entity name</td>
<td>This must be valid as per the GL_LEDGER_LE_V table.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>Attribute</td>
<td>Description</td>
<td>Prerequisite Setup Task/ Import Validations</td>
<td>Creating a Subscription Record</td>
<td>Updating an Existing Subscription Record</td>
</tr>
<tr>
<td>-----------------------------------</td>
<td>--------------------------------------------------</td>
<td>-----------------------------------------------------------------------------------------------------------</td>
<td>-------------------------------</td>
<td>------------------------------------------</td>
</tr>
<tr>
<td>SubscriptionProfileName</td>
<td>The subscription profile name</td>
<td>This must be a valid subscription profile name. OSS_SUBSCRIPTION_PROFILE</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>PrimaryPartyName</td>
<td>The primary party name</td>
<td>This must be a valid party name.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>CurrencyName</td>
<td>The name of the subscription currency.</td>
<td>This must be a valid currency name.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>RenewalSubscriptionProfileId</td>
<td>The renewal subscription profile ID</td>
<td>This must be a valid subscription profile ID - OSS_SUBSCRIPTION_PROFILE</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>DefaultLanguage</td>
<td>The default language</td>
<td>fnl_languages_v1.LANGUAGE_CODE</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>GenerateBillingSchedule</td>
<td>The check box for generating the billing schedule</td>
<td>Must be Y or N</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>TransactionType</td>
<td>The accounts receivables transaction type</td>
<td>This must be a valid transaction type as per the RA_CUST_TRX_TYPES_ALL table.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>PricingSystem</td>
<td>The pricing system</td>
<td>ORA_OSS_FUSION, ORA_OSS_THIRD_PARTY</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>RenewalCustomerAcceptance</td>
<td>The renewal customer acceptance</td>
<td>This must either be REQUIRED or NOTREQUIRED.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>RenewalInternalApproval</td>
<td>The renewal internal approval</td>
<td>This must either be REQUIRED or NOTREQUIRED.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>RenewalPriceAdjustmentBasis</td>
<td>The renewal price adjustment basis</td>
<td>Lookup: ORA_OSS_RNWLPRICE_AD.Value - ORA_NETPRICE</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>RenewalPriceAdjustmentPercent</td>
<td>The renewal price adjustment percentage</td>
<td>This must be a positive integer.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>RenewalPriceAdjustmentType</td>
<td>The renewal price adjustment type</td>
<td>Lookup: ORA_OSS_RNWLPRICE_AD.Values - ORA_MARKUP</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>Attribute</td>
<td>Description</td>
<td>Prerequisite Setup Task/Import Validations</td>
<td>Creating a Subscription Record</td>
<td>Updating an Existing Subscription Record</td>
</tr>
<tr>
<td>--------------------</td>
<td>--------------------------------------------------</td>
<td>-------------------------------------------</td>
<td>-------------------------------</td>
<td>-----------------------------------------</td>
</tr>
<tr>
<td>UsageCapture</td>
<td>The usage capture mode for the subscription</td>
<td>ORA_FUSION, ORA_THIRD_PARTY</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>ClosedDate</td>
<td>The date on which the subscription was closed</td>
<td></td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>CloseCreditMethod</td>
<td>The close credit method</td>
<td></td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>CancelReason</td>
<td>The reason for canceling the subscription</td>
<td></td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>CanceledDate</td>
<td>The date on which the subscription was canceled</td>
<td></td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>BillService</td>
<td>The bill service code</td>
<td></td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>BillServiceName</td>
<td>The bill service option</td>
<td></td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>InvoicingRuleId</td>
<td>The invoicing rule ID</td>
<td>RA_RULES.RULE_ID where TYPE =&quot;I&quot;</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>InvoicingRuleName</td>
<td>The invoicing rule name</td>
<td>RA_RULES.NAME where TYPE =&quot;I&quot;</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>BillingDateCode</td>
<td>The billing date code</td>
<td></td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>BillingDateName</td>
<td>The billing date name</td>
<td></td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>BillingFrequency</td>
<td>The billing frequency code</td>
<td>oss_time_code_units.user_uom_code</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>BillingFrequencyName</td>
<td>The billing frequency name</td>
<td>oss_time_code_units.user_uom_code</td>
<td>Not required</td>
<td>Not required</td>
</tr>
</tbody>
</table>
Understanding Import and Export Management for CX
Sales and B2B Service

Chapter 8
Import Your Data

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/Import Validations</th>
<th>Creating a Subscription Record</th>
<th>Updating an Existing Subscription Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>AccountingRuleName</td>
<td>The accounting rule name</td>
<td>RA_RULES.NAME where TYPE in ('A','ACC_DUR','PP_DR_ALL','PP_DR_PP')</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>BillingSystem</td>
<td>The billing system</td>
<td>Lookup: ORA_OSS_BILLING_SYSTEM</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>BillToAccountNumber</td>
<td>The bill-to account number</td>
<td>HZ_CUST_ACCOUNTS.ACCOUNT_NUMBER</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>BillToAccountDescription</td>
<td>The bill-to account description</td>
<td>Lookup: HZ_CUST_ACCOUNTS</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>BillToAddress</td>
<td>The bill-to address</td>
<td>Lookup: HZ_CUST_SITEUSES_ALL</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>ShipToParty</td>
<td>The ship-to party</td>
<td>Lookup: HZ_PARTIES</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>ShipToPartyName</td>
<td>The ship-to party name</td>
<td>Lookup: HZ_PARTIES</td>
<td>Not required</td>
<td>Not required</td>
</tr>
</tbody>
</table>

You can view the Subscription object along with all its child objects and attributes in the Manage Import Objects page of the Import Management flow. You can find attribute information like type, length, description, and so on, on this page.

Note the following:

- To generate the billing schedule based on your pricing, set the GenerateBillingSchedule option to Yes and re-import the Subscription.csv file after all files have been imported. Also, to activate your subscription, you need to re-import the Subscription.csv file after importing all required files.
- You can DELETE records for Subscription management while in DRAFT status.
- To create an included warranty, you need to set the value of WarrantyYN to Y. Included warranty can be imported only if the subscription is in Active status.
- To import subscription contracts and supporting documents see Import Your Attachment Data in the Related Topics section. The codes for attachment categories are OSS_SUBSCRIPTION_AGREEMENT for supporting documents and OSS_SUPPORTING_DOCUMENTS for subscription primary contract attachment.

Create the Source CSV File

You include the data that you want to import into CX Sales and B2B Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator > Tools > Import Management > Import Objects.
2. Select the Subscription object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.
Create the Import Activity
After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Subscription from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed. You can drill down on the import activity to go to the Import Status page which provides the status details of the import activity.

Related Topics
- Potential Issues When Opening CSV Files in Excel
- Import Data
- Import Your Attachment Data
You need to do the following before creating the CSV file for data import:

- Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
- Ensure prerequisite setups are done, if applicable.
- Understand your options for uniquely identifying the records.
- Ensure parent records exist before importing child records.
- Identify the target object attributes that are required in the CSV file for a successful import.

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

- You have completed all the prerequisites for importing each attribute in your source data.
- You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the import process to uniquely identify the records. The file import process uses the attribute values to automatically map your source data to the target object attributes in Oracle Applications Cloud.

The preferred option for uniquely identifying an object record is through the Public unique identifier. If you’re creating new records, then you can provide a user-friendly public unique identifier (attributes denoted with ‘Number’ and usually visible in the business object’s UI). If you update a record for which you have previously provided a Number attribute, or for which a Number attribute is visible in the object’s UI, you can use the Number attribute to identify the record. For the Subscription Bill Adjustment object, the attribute is SequenceNumber.

Required Attributes and Validations for Subscription Bill Adjustment Object
To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure that you provide valid values for the attributes. This table lists the required attributes for importing new Subscription Bill Adjustment records, required attributes for updating Subscription Bill Adjustment records, prerequisite setup tasks for the attributes, and specific validations, if any, for Subscription Bill Adjustment import:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/Import Validations</th>
<th>Creating a Subscription Bill Adjustment Record</th>
<th>Updating an Existing Subscription Bill Adjustment Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>BillAdjustmentId</td>
<td>The bill adjustment ID</td>
<td>Do not pass any value.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>AdjustmentValue</td>
<td>The adjustment value</td>
<td>This must be a positive number.</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td>AdjustmentType</td>
<td>The adjustment type</td>
<td>ORA_DISCOUNT_AMOUNT, ORA_DISCOUNT_PERCENT, ORA_MARKUP_AMOUNT, ORA_MARKUP_PERCENT, ORA_PRICE_OVERRIDE</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td>Attribute</td>
<td>Description</td>
<td>Prerequisite Setup Task/Import Validations</td>
<td>Creating a Subscription Bill Adjustment Record</td>
<td>Updating an Existing Subscription Bill Adjustment Record</td>
</tr>
<tr>
<td>----------------------------</td>
<td>------------------------------------------</td>
<td>------------------------------------------------------------------</td>
<td>-----------------------------------------------</td>
<td>--------------------------------------------------------</td>
</tr>
<tr>
<td>AdjustmentBasis</td>
<td>The adjustment basis</td>
<td>ORA_LIST_PRICE, ORA_NET_PRICE</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td>SequenceNumber</td>
<td>The adjustment sequence number</td>
<td>This must be a unique bill adjustment sequence number.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>AutoAdjustmentFlag</td>
<td>Option indicating whether the subscription bill should be auto adjusted</td>
<td>Y or N</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td>BillLineId</td>
<td>The bill line ID</td>
<td>Do not pass any value.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>BillLinePuid</td>
<td>The bill line PUID</td>
<td>This must be a valid bill line PUID.</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td>BillAdjustmentPuid</td>
<td>The bill line PUID</td>
<td>This must be a valid bill line PUID.</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td>SubscriptionId</td>
<td>The subscription ID</td>
<td>Do not pass any value.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>SubscriptionProductId</td>
<td>The subscription product ID</td>
<td>Do not pass any value.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>ChargeAdjustmentId</td>
<td>The charge adjustment ID</td>
<td>Do not pass any value.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>Effectivity</td>
<td>The effectivity of the subscription bill adjustment</td>
<td>Do not pass any value.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>NumberOfPeriods</td>
<td>The number of periods of adjustment</td>
<td>Do not pass any value.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>PeriodFrom</td>
<td>The period from when the subscription bill adjustment starts</td>
<td>Do not pass any value.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>PeriodUntil</td>
<td>The period till when the subscription bill adjustment is valid</td>
<td>Do not pass any value.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>CurrencyCode</td>
<td>The currency code</td>
<td>Do not pass any value.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>BasisEnableFlag</td>
<td>Option for basis enablement</td>
<td>Do not pass any value.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
</tbody>
</table>
You can view the Subscription Bill Adjustment object along with all its child objects and attributes in the Manage Import Objects page of the Import Management flow. You can find attribute information like type, length, description, and so on, on this page.

Create the Source CSV File

You include the data that you want to import into CX Sales and B2B Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator > Tools > Import Management > Import Objects.
2. Select the Subscription Bill Adjustment object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

**Note:** For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity

After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Subscription Bill Adjustment from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results

Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed. You can drill down on the import activity to go to the Import Status page which provides the status details of the import activity.

**Related Topics**

- Potential Issues When Opening CSV Files in Excel
- Import Data
Import Your Subscription Charge Adjustment Data

You can use import management to create or update Subscription Charge Adjustment records.

To import Subscription Charge Adjustment records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes

To import your Subscription Charge Adjustment data into Oracle Applications Cloud, you need to populate a CSV file with your source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

- Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
- Ensure prerequisite setups are done, if applicable.
- Understand your options for uniquely identifying the records.
- Ensure parent records exist before importing child records.
- Identify the target object attributes that are required in the CSV file for a successful import.

Before You Start

You must do some basic checks before starting your import. For example, make sure that:

- You have completed all the prerequisites for importing each attribute in your source data.
- You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records

To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the import process to uniquely identify the records. The file import process uses the attribute values to automatically map your source data to the target object attributes in Oracle Applications Cloud.

The preferred option for uniquely identifying an object record is through the Public unique identifier. If you’re creating new records, then you can provide a user-friendly public unique identifier (attributes denoted with ‘Number’ and usually visible in the business object’s UI). If you update a record for which you have previously provided a Number attribute, or for which a Number attribute is visible in the object’s UI, you can use the Number attribute to identify the record. For the Subscription Charge Adjustment object, the attribute is SequenceNumber.
Required Attributes and Validations for Subscription Charge Adjustment Object

To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure that you provide valid values for the attributes. This table lists the required attributes for importing new Subscription Charge Adjustment records, required attributes for updating Subscription Charge Adjustment records, prerequisite setup tasks for the attributes, and specific validations, if any, for Subscription Charge Adjustment import:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/Import Validations</th>
<th>Creating a Subscription Charge Adjustment Record</th>
<th>Updating an Existing Subscription Charge Adjustment Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>ChargeAdjustmentId</td>
<td>The charge adjustment ID</td>
<td>Do not pass any value.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>ChargePuid</td>
<td>The charge PUID</td>
<td>This must be a valid charge PUID.</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td>ChargeId</td>
<td>The charge ID</td>
<td>Do not pass any value.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>ChargeAdjustmentPuid</td>
<td>The charge adjustment PUID</td>
<td>This must be a unique charge adjustment PUID.</td>
<td>Required</td>
<td>Required</td>
</tr>
<tr>
<td>PeriodFrom</td>
<td>The period from which the subscription charge adjustment is valid</td>
<td>This must be a valid billing period.</td>
<td>A value is required when the charge type is RECURRING and effectivity is ORA_SPECIFIC_PERIODS.</td>
<td>Not required</td>
</tr>
<tr>
<td>PeriodUntil</td>
<td>The period till which the subscription charge adjustment is valid</td>
<td>This must be a valid billing period. It must be greater than or equal to the value in PeriodFrom.</td>
<td>A value is required when the charge type is RECURRING and effectivity is ORA_SPECIFIC_PERIODS.</td>
<td>Not required</td>
</tr>
<tr>
<td>AdjustmentType</td>
<td>The adjustment type</td>
<td>ORA_DISCOUNT_AMOUNT, ORA_DISCOUNT_PERCENT, ORA_MARKUP_AMOUNT, ORA_MARKUP_PERCENT, ORA_PRICE_OVERRIDE</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td>AdjustmentValue</td>
<td>The adjustment value</td>
<td>This must be a positive number.</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td>AdjustmentBasis</td>
<td>The adjustment basis</td>
<td>ORA_LIST_PRICE, ORA_NET_PRICE</td>
<td>A value is required when the adjustment type is discount percent or markup percent</td>
<td>Not required</td>
</tr>
<tr>
<td>SequenceNumber</td>
<td>The sequence number</td>
<td>This must be a unique charge adjustment sequence number.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>SubscriptionId</td>
<td>The subscription ID</td>
<td>Do not pass any value.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
</tbody>
</table>
### Attribute | Description | Prerequisite Setup Task/Import Validations | Creating a Subscription Charge Adjustment Record | Updating an Existing Subscription Charge Adjustment Record
---|---|---|---|---
SubscriptionProductld | The subscription product ID | Do not pass any value. | Not required | Not required
AutoAdjustmentFlag | Option for auto adjustment | Y or N | Not required | Not required
Effectivity | The effectiveness of the subscription charge adjustment | ORA_ALL_TERM, ORA_PERIODS BEFORE_END_DT, ORA_PERIODS AFTER_START_DT, ORA_SPECIFIC_PERIODS | A value is required when the charge type is RECURRING. | Not required
NumberOfPeriods | The number of periods | This must be a positive integer. | A value is required when the charge type is RECURRING and effectivity is ORA_PERIODS AFTER_START_DT or ORA_PERIODS BEFORE_END_DT. | Not required

You can view the Subscription Charge Adjustment object along with all its child objects and attributes in the Manage Import Objects page of the Import Management flow. You can find attribute information like type, length, description, and so on, on this page.

### Create the Source CSV File
You include the data that you want to import into CX Sales and B2B Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator > Tools > Import Management > Import Objects.
2. Select the Subscription Charge Adjustment object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

**Note:** For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.

### Create the Import Activity
After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Subscription Charge Adjustment from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.

7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed. You can drill down on the import activity to go to the Import Status page which provides the status details of the import activity.

Related Topics
• Potential Issues When Opening CSV Files in Excel
• Import Data

Import Your Subscription Charge Tier Data
You can use import management to create or update Subscription Charge Tier records.

To import Subscription Charge Tier records, perform the following tasks:
1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes
To import your Subscription Charge Tier data into Oracle Applications Cloud, you need to populate a CSV file with your source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
• Ensure prerequisite setups are done, if applicable.
• Understand your options for uniquely identifying the records.
• Ensure parent records exist before importing child records.
• Identify the target object attributes that are required in the CSV file for a successful import.

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.
• You have all parent records in place before importing child records.
Select a Unique Identifier for Your Records

To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the import process to uniquely identify the records. The file import process uses the attribute values to automatically map your source data to the target object attributes in Oracle Applications Cloud.

The preferred option for uniquely identifying an object record is through the Public unique identifier. If you’re creating new records, then you can provide a user-friendly public unique identifier (attributes denoted with ‘Number’ and usually visible in the business object’s UI). If you update a record for which you have previously provided a Number attribute, or for which a Number attribute is visible in the object’s UI, you can use the Number attribute to identify the record. For the Subscription Charge Tier object, the attribute is SequenceNumber.

Required Attributes and Validations for Subscription Charge Tier Object

To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure that you provide valid values for the attributes. This table lists the required attributes for importing new Subscription Charge Tier records, required attributes for updating Subscription Charge Tier records, prerequisite setup tasks for the attributes, and specific validations, if any, for Subscription Charge Tier import:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/ Import Validations</th>
<th>Creating a Subscription Charge Tier Record</th>
<th>Updating an Existing Subscription Charge Tier Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>SequenceNumber</td>
<td>The sequence number of the charge tier</td>
<td>This must be a unique sequence number for the charge tier.</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td>TierFrom</td>
<td>The tier from</td>
<td>This must be a positive integer.</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td>ListPrice</td>
<td>List price for the subscription charge tier</td>
<td>This must be a positive integer.</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td>PriceFormat</td>
<td>The price format</td>
<td>Lookup: ORA_OSS_PRICE_FORMAT</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td>ChargeTierId</td>
<td>The charge tier ID</td>
<td>Do not pass any value.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>ChargePuid</td>
<td>The charge PUID</td>
<td>This must be a valid charge PUID.</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td>ChargeId</td>
<td>The charge ID</td>
<td>Do not pass any value.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>ChargeTierPuid</td>
<td>The charge tier PUID</td>
<td>This must be a unique charge tier PUID.</td>
<td>A value is auto generated when a record is created.</td>
<td>Required</td>
</tr>
<tr>
<td>SubscriptionId</td>
<td>The Subscription ID</td>
<td>Do not pass any value.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>SubscriptionProductid</td>
<td>The subscription product ID</td>
<td>Do not pass any value.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
</tbody>
</table>
### Attribute Table

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/Import Validations</th>
<th>Creating a Subscription Charge Tier Record</th>
<th>Updating an Existing Subscription Charge Tier Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>TierTo</td>
<td>The tier to</td>
<td>This must be greater than or equal to the value in tier from.</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td>Blocksize</td>
<td>The block size</td>
<td>This must be a positive number or null.</td>
<td>Required</td>
<td>Not required</td>
</tr>
</tbody>
</table>

You can view the Subscription Charge Tier object along with all its child objects and attributes in the Manage Import Objects page of the Import Management flow. You can find attribute information like type, length, description, and so on, on this page.

### Create the Source CSV File

You include the data that you want to import into CX Sales and B2B Service in a source CSV file. You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator > Tools > Import Management > Import Objects.
2. Select the Subscription Charge Tier object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

**Note:** For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.

### Create the Import Activity

After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Subscription Charge Tier from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

### Review the Import Results

Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the **Status** column for the import activity. The import is successful if the status displays as **Completed**. You can drill down on the import activity to go to the **Import Status** page which provides the status details of the import activity.

**Related Topics**
- Potential Issues When Opening CSV Files in Excel
- Import Data

## Import Your Subscription Contact Data

You can use import management to create or update Subscription Contact records.

To import Subscription Contact records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

### How You Map Your Source Data to Target Object Attributes

To import your Subscription Contact data into Oracle Applications Cloud, you need to populate a CSV file with your source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

- Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
- Ensure prerequisite setups are done, if applicable.
- Understand your options for uniquely identifying the records.
- Ensure parent records exist before importing child records.
- Identify the target object attributes that are required in the CSV file for a successful import.

### Before You Start

You must do some basic checks before starting your import. For example, make sure that:

- You have completed all the prerequisites for importing each attribute in your source data.
- You have all parent records in place before importing child records.

### Select a Unique Identifier for Your Records

To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the import process to uniquely identify the records. The file import process uses the attribute values to automatically map your source data to the target object attributes in Oracle Applications Cloud.

The preferred option for uniquely identifying an object record is through the Public unique identifier. If you're creating new records, then you can provide a user-friendly public unique identifier (attributes denoted with 'Number' and usually visible in the business object's UI). If you update a record for which you have previously provided a Number attribute, or
for which a Number attribute is visible in the object's UI, you can use the Number attribute to identify the record. For the Subscription Contact object, the attributes are ContactPuid and PartyPuid.

### Required Attributes and Validations for Subscription Contact Object

To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure that you provide valid values for the attributes. This table lists the required attributes for importing new Subscription Contact records, required attributes for updating Subscription Contact records, prerequisite setup tasks for the attributes, and specific validations, if any, for Subscription Contact import:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/ Import Validations</th>
<th>Creating a Subscription Contact Record</th>
<th>Updating an Existing Subscription Contact Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>SubscriptionContactId</td>
<td>Identifier of the subscription contact record</td>
<td>Do not pass any value. This value is auto generated.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>ContactPuid</td>
<td>PUID of the subscription contact record</td>
<td>This must be a unique contact PUID.</td>
<td>Required</td>
<td>Required</td>
</tr>
<tr>
<td>SubscriptionId</td>
<td>Identifier of the subscription</td>
<td>Do not pass any value.</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td>SubscriptionPartyId</td>
<td>Identifier of the subscription party</td>
<td>Do not pass any value.</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td>PartyPuid</td>
<td>PUID of the subscription party</td>
<td>This must be a valid party PUID.</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td>PartyId</td>
<td>Identifier of the party</td>
<td>Do not pass any value.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>ContactId</td>
<td>Identifier of the contact</td>
<td>HZ_RELATIONSHIPS for external contacts, JTF_RS_RESOURCE_PROFILES for internal contacts</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td>ContactRole</td>
<td>Role played by the contact</td>
<td>Lookup: ORA_OSS_PARTY_CONTACT_ROLES</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td>StartDate</td>
<td>Start date of the subscription contact</td>
<td>Do not pass any value.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>EndDate</td>
<td>End date of the subscription contact</td>
<td>Do not pass any value.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>AccessLevel</td>
<td>Access level</td>
<td>Do not pass any value.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>BillingOwnerFlag</td>
<td>Option for Billing owner</td>
<td>Y or N</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>Attribute</td>
<td>Description</td>
<td>Prerequisite Setup Task/Import Validations</td>
<td>Creating a Subscription Contact Record</td>
<td>Updating an Existing Subscription Contact Record</td>
</tr>
<tr>
<td>---------------</td>
<td>-------------------</td>
<td>--------------------------------------------</td>
<td>----------------------------------------</td>
<td>--------------------------------------------------</td>
</tr>
<tr>
<td>InternalFlag</td>
<td>Internal option</td>
<td>Y or N</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>ContactName</td>
<td>Contact name</td>
<td>Do not pass any value</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>ContactEmail</td>
<td>Email address of the contact</td>
<td>Do not pass any value</td>
<td>Not required</td>
<td>Not required</td>
</tr>
</tbody>
</table>

You can view the Subscription Contact object along with all its child objects and attributes in the Manage Import Objects page of the Import Management flow. You can find attribute information like type, length, description, and so on, on this page.

### Create the Source CSV File
You include the data that you want to import into CX Sales and B2B Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to **Navigator > Tools > Import Management > Import Objects**.
2. Select the **Subscription Contact** object in the table and click **Download**.

You can now edit the downloaded file and provide valid values for the required attributes.

**Note:** For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.

### Create the Import Activity
After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to **Navigator > Tools > Import Management > Import Queue**.
2. Click **Create Import Activity** in the **Manage Imports** page.
3. In the **Enter Import Options** page, provide a name for the import activity, and select Subscription Contact from the **Object** drop-down list.
4. Select the CSV file in the **File Name** field, and click **Next**.
5. You would see that the source and target attributes are automatically mapped in the **Map Fields** page. Review and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking **Validate Data**. Click **Next**.
7. Review the import details on the **Review and Submit** page, and click **Submit** when you're ready.

### Review the Import Results
Check if your import succeeded on the **Manage Imports** page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to **Navigator > Tools > Import Management > Import Queue**.
2. Click All Imports and search for the import activity that you created earlier.
Check the Status column for the import activity. The import is successful if the status displays as Completed. You can drill down on the import activity to go to the Import Status page which provides the status details of the import activity.

Related Topics
- Potential Issues When Opening CSV Files in Excel
- Import Data

Import Your Subscription Covered Bill Line Data

You can use import management to create or update Subscription Covered Bill Line records.

To import Subscription Covered Bill Line records, perform the following tasks:
1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes

To import your Subscription Covered Bill Line data into Oracle Applications Cloud, you need to populate a CSV file with your source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:
- Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
- Ensure prerequisite setups are done, if applicable.
- Understand your options for uniquely identifying the records.
- Ensure parent records exist before importing child records.
- Identify the target object attributes that are required in the CSV file for a successful import.

Before You Start

You must do some basic checks before starting your import. For example, make sure that:
- You have completed all the prerequisites for importing each attribute in your source data.
- You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records

To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the import process to uniquely identify the records. The file import process uses the attribute values to automatically map your source data to the target object attributes in Oracle Applications Cloud.

The preferred option for uniquely identifying an object record is through the Public unique identifier. If you’re creating new records, then you can provide a user-friendly public unique identifier (attributes denoted with 'Number’ and usually visible in the business object’s UI). If you update a record for which you have previously provided a Number attribute, or
for which a Number attribute is visible in the object's UI, you can use the Number attribute to identify the record. For the Subscription Covered Bill Line object, the attributes are:

- CoveredLevelPuid
- BillLinePuid
- TransactionNumber
- NewCreditMemoPUID

### Required Attributes and Validations for Subscription Covered Bill Line Object

To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure that you provide valid values for the attributes. This table lists the required attributes for importing new Subscription Covered Bill Line records, required attributes for updating Subscription Covered Bill Line records, prerequisite setup tasks for the attributes, and specific validations, if any, for Subscription Covered Bill Line import:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/ Import Validations</th>
<th>Creating a Subscription Covered Bill Line Record</th>
<th>Updating an Existing Subscription Covered Bill Line Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>BillLineId</td>
<td>The bill line ID</td>
<td>Do not pass any value</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>BillingPeriod</td>
<td>The billing period</td>
<td>This must be a positive number and unique for the product.</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td>DateToInterface</td>
<td>The date to interface</td>
<td>This must be a valid date.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>DateBilledFrom</td>
<td>The date from which the billing starts</td>
<td>This must be a valid date.</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td>DateBilledTo</td>
<td>The date up to which the billing is valid</td>
<td>This must be a valid date.</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td>RecurringFlag</td>
<td>Option indicating whether this line is recurring</td>
<td>Y or N</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td>InterfacedFlag</td>
<td>Option indicating whether the bill line is interfaced</td>
<td>Y or N</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td>CoveredLevelId</td>
<td>The covered level ID</td>
<td>Do not pass any value</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>CoveredLevelPuid</td>
<td>The covered level PUID</td>
<td>This must be a valid covered level PUID.</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td>BillLinePuid</td>
<td>The bill line PUID</td>
<td>This must be a unique bill line PUID.</td>
<td>Required</td>
<td>Required</td>
</tr>
</tbody>
</table>
## Import Your Data

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/Import Validations</th>
<th>Creating a Subscription Covered Bill Line Record</th>
<th>Updating an Existing Subscription Covered Bill Line Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>SubscriptionId</td>
<td>The subscription ID</td>
<td>Do not pass any value.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>SubscriptionProductId</td>
<td>The subscription product ID</td>
<td>Do not pass any value.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>ChargeId</td>
<td>The charge ID</td>
<td>This must be a valid charge ID.</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td>Amount</td>
<td>The amount</td>
<td>This must be a positive number.</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td>UsageFlag</td>
<td>Option indicating whether the line is a usage line</td>
<td>Y or N</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td>UsageAcquiredFlag</td>
<td>Option indicating whether the usage has been acquired</td>
<td>Y or N</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>UsagePricedFlag</td>
<td>Option indicating whether usage line has been priced</td>
<td>Y or N</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>TransactionClass</td>
<td>The transaction class</td>
<td>This must be INV for invoice and CM for credit memo.</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td>TransactionTax</td>
<td>The transaction tax</td>
<td>This must be a positive number.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>TransactionAmount</td>
<td>The transaction amount</td>
<td>This must be a positive number.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>InvoiceBillLineId</td>
<td>The invoice bill line ID</td>
<td>Do not pass any value.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>UsageCaptureDate</td>
<td>The usage capture date</td>
<td>This must be a valid date.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>UsageQuantity</td>
<td>The usage quantity</td>
<td>This must be a positive number.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>ChargePeriod</td>
<td>The charge period</td>
<td>This must be a valid charge period.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>PricingError</td>
<td>The pricing error</td>
<td>Do not pass any value.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>ListPrice</td>
<td>The list price</td>
<td>This must be a positive number when</td>
<td>Required</td>
<td>Not required</td>
</tr>
</tbody>
</table>
## Create the Source CSV File

You include the data that you want to import into CX Sales and B2B Service in a source CSV file. You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to **Navigator > Tools > Import Management > Import Objects**.
2. Select the **Subscription Covered Bill Line** object in the table and click **Download**.

You can now edit the downloaded file and provide valid values for the required attributes.

**Note:** For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.

## Create the Import Activity

After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to **Navigator > Tools > Import Management > Import Queue**.
2. Click **Create Import Activity** in the **Manage Imports** page.
3. In the **Enter Import Options** page, provide a name for the import activity, and select Subscription Covered Bill Line from the **Object** drop-down list.

4. Select the CSV file in the **File Name** field, and click **Next**.

5. You would see that the source and target attributes are automatically mapped in the **Map Fields** page. Review and edit the mappings if required.

6. Check the file for unmapped columns or data format issues by clicking **Validate Data**. Click **Next**.

7. Review the import details on the **Review and Submit** page, and click **Submit** when you’re ready.

**Review the Import Results**

Check if your import succeeded on the **Manage Imports** page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to **Navigator** > **Tools** > **Import Management** > **Import Queue**.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the **Status** column for the import activity. The import is successful if the status displays as **Completed**. You can drill down on the import activity to go to the **Import Status** page which provides the status details of the import activity.

**Related Topics**

- Potential Issues When Opening CSV Files in Excel
- Import Data

**Import Your Subscription Covered Level Data**

You can use import management to create or update Subscription Covered Level records.

To import Subscription Covered Level records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

**How You Map Your Source Data to Object Attributes**

To import your Subscription Covered Level data into Oracle Applications Cloud, you must populate a CSV file with your source data and map that source data to target object attributes in Oracle Applications Cloud.

You must do the following before creating the CSV file for data import:

- Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud
- Ensure prerequisite setups are done, if applicable
- Understand your options for uniquely identifying the records
- Ensure parent records exist before importing child records
- Identify the target object attributes that are required in the CSV file for a successful import
Before You Start
You must do some basic checks before starting your import. For example, make sure that:

- You have completed all the prerequisites for importing each attribute in your source data.
- You have all parent records in place before importing child records.

Select a Unique Identifier For Your Records
To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the import process to uniquely identify the records. The file import process uses the attribute values to automatically map your source data to the target object attributes in Oracle Applications Cloud.

The preferred option for uniquely identifying an object record is through the Public unique identifier. If you’re creating records, then you can provide a user-friendly public unique identifier (attributes denoted with 'Number' and usually visible in the business object’s UI). If you update a record for which you have previously provided a Number attribute, or for which a Number attribute is visible in the object’s UI, you can use the Number attribute to identify the record. For the Subscription Covered Level object, the attributes are SubscriptionProductPuid and CoveredLevelPuid.

Required Attributes and Validations for Subscription Covered Level Object
To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure that you provide valid values for the attributes. The following table lists the required attributes for importing new Subscription Level records, required attributes for updating Subscription Covered Level records, prerequisite setup tasks for the attributes, and specific validations, if any, for Subscription Covered Level import:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/ Import Validations</th>
<th>Creating a Subscription Covered Level record</th>
<th>Updating an Existing Subscription Covered Level record</th>
</tr>
</thead>
<tbody>
<tr>
<td>Type</td>
<td>The type</td>
<td>ORA_OSS_COVERED_LEVEL</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td>StartDate</td>
<td>The start date</td>
<td>This must be later than or equal to the subscription product start date.</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td>CoveredLevelId</td>
<td>The covered level ID</td>
<td>Do not pass any value. This is auto generated.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>Quantity</td>
<td>The quantity</td>
<td>This must be a positive integer.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>SubscriptionProductPuid</td>
<td>The subscription product PUID</td>
<td>This must be a valid subscription product PUID.</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td>SubscriptionProductId</td>
<td>The subscription product ID</td>
<td>This is auto generated when a record is created.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>SubscriptionId</td>
<td>The subscription ID</td>
<td>Do not pass any value.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>Attribute</td>
<td>Description</td>
<td>Prerequisite Setup Task/Import Validations</td>
<td>Creating a Subscription Covered Level record</td>
<td>Updating an Existing Subscription Covered Level record</td>
</tr>
<tr>
<td>--------------------------</td>
<td>------------------------------------</td>
<td>----------------------------------------------------------------------------------</td>
<td>-----------------------------------------------</td>
<td>------------------------------------------------------</td>
</tr>
<tr>
<td>CoveredLevelPuid</td>
<td>The covered level PUID</td>
<td>This must be a unique PUID.</td>
<td>Required</td>
<td>Required</td>
</tr>
<tr>
<td>LineNumber</td>
<td>The line number</td>
<td>This must not be duplicate</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td>InventoryItemId</td>
<td>The inventory item ID</td>
<td>EGP_SYSTEM_ITEMS_B.INVENTORY_ITEM_ID</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td>AssetId</td>
<td>The asset ID</td>
<td>CSE_ASSETS_VL.ASSET_ID</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>AssetName</td>
<td>The asset name</td>
<td>CSE_ASSETS_VL.ASSET_NUMBER</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>AssetSerialNumber</td>
<td>The asset serial number</td>
<td>CSE_ASSETS_VL_SERIAL_NUMBER</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>ProductName</td>
<td>The product name</td>
<td>Do not pass any value.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>TypeName</td>
<td>The type name</td>
<td>ORA_OSS_COVERED_LEVEL</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>ItemUnitOfMeasure</td>
<td>The item unit of measure</td>
<td>INV_UNITS_OF_MEASURE_B.UOM_CODE</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>TotalContractValue</td>
<td>The total contract value</td>
<td>Do not pass any value.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>GenerateBillingSchedule</td>
<td>The generate billing schedule indicator</td>
<td>Must be Y or N</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>EndDate</td>
<td>The end date</td>
<td>This must be earlier than the end date of the subscription product.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>Duration</td>
<td>The duration</td>
<td>This must be a positive integer.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>Period</td>
<td>The period</td>
<td>This must be a valid value from OSS_TIME_CODE_UNITS.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>Status</td>
<td>The status</td>
<td>This must be ORA_D.DRAFT</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>Attribute</td>
<td>Description</td>
<td>Prerequisite Setup Task/ Import Validations</td>
<td>Creating a Subscription Covered Level record</td>
<td>Updating an Existing Subscription Covered Level record</td>
</tr>
<tr>
<td>-------------------------</td>
<td>---------------------------</td>
<td>------------------------------------------------------------------------------------------------------------</td>
<td>----------------------------------------------</td>
<td>------------------------------------------------------</td>
</tr>
<tr>
<td>SuspendedDate</td>
<td>The date of suspension</td>
<td>This must be between the start date and end date of the subscription product.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>StatusName</td>
<td>The status meaning</td>
<td>Draft</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>PriceUnitOfMeasure</td>
<td>The price unit of measure</td>
<td>INV_UNITS_OF_MEASURE_VL.UOM_CODE</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>PriceUnitOfMeasureName</td>
<td>The price unit of measure meaning</td>
<td>INV_UNITS_OF_MEASURE_VL.UNIT_OF_MEASURE</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>PriceListId</td>
<td>The price list ID</td>
<td>Do not pass any value.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>PricingError</td>
<td>The pricing error</td>
<td>Do not pass any value.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>TaxAmount</td>
<td>The tax amount</td>
<td>Do not pass any value.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>CancelReason</td>
<td>The cancel reason</td>
<td>This must be a valid reason. Lookup: ORA_OSS_CANCEL_REASONS</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>CanceledDate</td>
<td>The canceled date</td>
<td>This must be between the start date and end date.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>CanceledAmount</td>
<td>The canceled amount</td>
<td>Do not pass any value.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>ClosedDate</td>
<td>The closed date</td>
<td>This must be later than the start date.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>CloseReason</td>
<td>The close reason</td>
<td>Lookup: ORA_OSS_CLOSE_REASONS</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>ClosedAmount</td>
<td>The closed amount</td>
<td>Do not pass any value.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>ReturnCreditMethod</td>
<td>The return credit method</td>
<td>Lookup: ORA_OSS_CLOSE_CREDIT_METHOD</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>SuppressedCreditAmount</td>
<td>The suppressed credit amount</td>
<td>Do not pass any value.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>InvoicedAmount</td>
<td>The invoiced amount</td>
<td>Do not pass any value.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>CreditedAmount</td>
<td>The credited amount</td>
<td>Do not pass any value.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
</tbody>
</table>
### Attribute Description Prerequisite Setup Task/ Import Validations Creating a Subscription Covered Level record Updating an Existing Subscription Covered Level record

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/ Import Validations</th>
<th>Creating a Subscription Covered Level record</th>
<th>Updating an Existing Subscription Covered Level record</th>
</tr>
</thead>
<tbody>
<tr>
<td>RenewedDate</td>
<td>The renewed date</td>
<td>Do not pass any value.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>RenewalType</td>
<td>The renewal type</td>
<td>Lookup: ORA_OSS_RENEWAL_ACTION</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>CurrencyCode</td>
<td>The currency code</td>
<td>Do not pass any value.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>PutOnHoldFlag</td>
<td>Indicates whether the covered level is put on hold</td>
<td>Y or N</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>RemoveHoldFlag</td>
<td>Indicates whether the hold is removed</td>
<td>Y or N</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>SuspendCreditMethod</td>
<td>The suspend credit method</td>
<td>Lookup: ORA_OSS_CLOSE_CREDIT_METHOD</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>SuspendReason</td>
<td>The suspend reason</td>
<td>Lookup: ORA_OSS_CLOSE_REASONS</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>TaxError</td>
<td>The tax error</td>
<td>Do not pass any value.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
</tbody>
</table>

You can view the Subscription Covered Level object along with all its child objects and attributes in the Manage Import Objects page of the Import Management flow. You can find attribute information like type, length, description, and so on, on this page.

#### Create the Source CSV File

You include the data that you want to import into CX Sales and B2B Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to **Navigator > Tools > Import Management > Import Objects**.
2. Select the Subscription Covered Level object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

**Note:** For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.

#### Create the Import Activity

After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to **Navigator > Tools > Import Management > Import Queue**.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Subscription Covered Level from the Object drop-down list.
4. Select the CSV file in the File Name field and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed. You can drill down on the import activity to go to the Import Status page, which provides the status details of the import activity.

Import Your Subscription Covered Level Charge Data
You can use import management to create or update Subscription Covered Level Charge records.

To import Subscription Covered Level Charge records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Object Attributes
To import your Subscription Covered Level Charge data into Oracle Applications Cloud, you must populate a CSV file with your source data and map that source data to target object attributes in Oracle Applications Cloud.

You must do the following before creating the CSV file for data import:

- Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud
- Ensure prerequisite setups are done, if applicable
- Understand your options for uniquely identifying the records
- Ensure parent records exist before importing child records
- Identify the target object attributes that are required in the CSV file for a successful import

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

- You have completed all the prerequisites for importing each attribute in your source data.
- You have all parent records in place before importing child records.
Select a Unique Identifier For Your Records

To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the import process to uniquely identify the records. The file import process uses the attribute values to automatically map your source data to the target object attributes in Oracle Applications Cloud.

The preferred option for uniquely identifying an object record is through the Public unique identifier. If you're creating records, then you can provide a user-friendly public unique identifier (attributes denoted with 'Number' and usually visible in the business object's UI). If you update a record for which you have previously provided a Number attribute, or for which a Number attribute is visible in the object's UI, you can use the Number attribute to identify the record. For the Subscription Covered Level Charge object, the attributes are CoveredLevelPuid, PrePaymentNumber and SequenceNumber.

Required Attributes and Validations for Subscription Covered Level Charge Object

To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure that you provide valid values for the attributes. The following table lists the required attributes for importing new Subscription Level records, required attributes for updating Subscription Covered Level Charge records, prerequisite setup tasks for the attributes, and specific validations, if any, for Subscription Covered Level Charge import:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/Import Validations</th>
<th>Creating a Subscription Covered Level Charge record</th>
<th>Updating an Existing Subscription Covered Level Charge record</th>
</tr>
</thead>
<tbody>
<tr>
<td>PriceType</td>
<td>The price type</td>
<td>RECURRING or ONE_TIME</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td>Chargeld</td>
<td>The charge ID</td>
<td>Do not pass any value.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>CoveredLevelPuid</td>
<td>The covered level PUID</td>
<td>This must be a valid covered level PUID.</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td>CoveredLevelId</td>
<td>The covered level ID</td>
<td>Do not pass any value.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>ChargePuid</td>
<td>The charge PUID</td>
<td>This must be a unique charge PUID.</td>
<td>Required</td>
<td>Required</td>
</tr>
<tr>
<td>BillLineld</td>
<td>The bill line ID</td>
<td>Do not pass any value.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>PricePeriodicity</td>
<td>The price periodicity</td>
<td>This must be a valid value from oss_time_code_units.</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td>RollupFlag</td>
<td>The option indicating whether charges should be rolled up</td>
<td>Y or N</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>SequenceNumber</td>
<td>The sequence number</td>
<td>This must be a positive number.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
</tbody>
</table>
### Create the Source CSV File

You include the data that you want to import into Sales and B2B Service in a source CSV file.

---

You can view the Subscription Covered Level Charge object along with all its child objects and attributes in the Manage Import Objects page of the Import Management flow. You can find attribute information like type, length, description, and so on, on this page.
You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to **Navigator > Tools > Import Management > Import Objects**.
2. Select the Subscription Covered Level Charge object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

**Note:** For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.

### Create the Import Activity

After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to **Navigator > Tools > Import Management > Import Queue**.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Subscription Covered Level Charge from the Object drop-down list.
4. Select the CSV file in the File Name field and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page and click Submit when you're ready.

### Review the Import Results

Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to **Navigator > Tools > Import Management > Import Queue**.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed. You can drill down on the import activity to go to the Import Status page, which provides the status details of the import activity.

### Import Your Subscription Party Data

You can use import management to create or update Subscription Party records.

To import Subscription Party records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

**How You Map Your Source Data to Target Object Attributes**

To import your Subscription Party data into Oracle Applications Cloud, you need to populate a CSV file with your source data and map that source data to target object attributes in Oracle Applications Cloud.
You need to do the following before creating the CSV file for data import:

- Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
- Ensure prerequisite setups are done, if applicable.
- Understand your options for uniquely identifying the records.
- Ensure parent records exist before importing child records.
- Identify the target object attributes that are required in the CSV file for a successful import.

Before You Start

You must do some basic checks before starting your import. For example, make sure that:

- You have completed all the prerequisites for importing each attribute in your source data.
- You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records

To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the import process to uniquely identify the records. The file import process uses the attribute values to automatically map your source data to the target object attributes in Oracle Applications Cloud.

The preferred option for uniquely identifying an object record is through the Public unique identifier. If you're creating new records, then you can provide a user-friendly public unique identifier (attributes denoted with 'Number' and usually visible in the business object's UI). If you update a record for which you have previously provided a Number attribute, or for which a Number attribute is visible in the object's UI, you can use the Number attribute to identify the record. For the Subscription Party object, the attributes are SubscriptionPartyPUID, SubscriptionNumber, and PartyNumber.

Required Attributes and Validations for Subscription Party Object

To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure that you provide valid values for the attributes. This table lists the required attributes for importing new Subscription Party records, required attributes for updating Subscription Party records, prerequisite setup tasks for the attributes, and specific validations, if any, for Subscription Party import:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/Import Validations</th>
<th>Creating a Subscription Party Record</th>
<th>Updating an Existing Subscription Party Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>SubscriptionPartyId</td>
<td>Identifier of the subscription party record</td>
<td>Do not pass any value. This is autogenerated.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>PartyPuid</td>
<td>PUID of the subscription party record</td>
<td>This must be a unique party PUID.</td>
<td>Required</td>
<td>Required</td>
</tr>
<tr>
<td>SubscriptionId</td>
<td>Subscription ID</td>
<td>Do not pass any value.</td>
<td>Conditionally required</td>
<td>Not required</td>
</tr>
<tr>
<td>SubscriptionNumber</td>
<td>Subscription Number</td>
<td>This must be a valid subscription number.</td>
<td>Conditionally required</td>
<td>Not required</td>
</tr>
<tr>
<td>Attribute</td>
<td>Description</td>
<td>Prerequisite Setup Task/ Import Validations</td>
<td>Creating a Subscription Party Record</td>
<td>Updating an Existing Subscription Party Record</td>
</tr>
<tr>
<td>-----------------</td>
<td>-------------------</td>
<td>-------------------------------------------------------------------------------------------------------------</td>
<td>--------------------------------------</td>
<td>-----------------------------------------------</td>
</tr>
<tr>
<td>PartyId</td>
<td>Party ID</td>
<td>This must be a valid party - HZ_PARTIES</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td>PartyName</td>
<td>Name of the party</td>
<td>This must be a valid party name - HZ_PARTIES</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>PartyNumber</td>
<td>Number of the party</td>
<td>This must be a valid party number - HZ_PARTIES</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>PartyRole</td>
<td>Role of the party</td>
<td>Lookup: ORA_OSS_PARTY_ROLES</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td>PrimaryFlag</td>
<td>Check box indicating whether this party is primary</td>
<td>Value must be Y or N</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td>InternalFlag</td>
<td>Check box indicating whether this party is internal</td>
<td>Value must be Y or N</td>
<td>Required</td>
<td>Not required</td>
</tr>
</tbody>
</table>

You can view the Subscription Party object along with all its child objects and attributes in the Manage Import Objects page of the Import Management flow. You can find attribute information like type, length, description, and so on, on this page.

### Create the Source CSV File
You include the data that you want to import into CX Sales and B2B Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator > Tools > Import Management > Import Objects.
2. Select the Subscription Party object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

**Note:** For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.

### Create the Import Activity
After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Subscription Party from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review and edit the mappings if required.

6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.

7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results

Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed.

You can drill down on the import activity to go to the Import Status page which provides the status details of the import activity.

Related Topics
- Potential Issues When Opening CSV Files in Excel
- Import Data

Import Your Subscription Product Data

You can use import management to create or update Subscription Product records.

To import Subscription Product records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes

To import your Subscription Product data into Oracle Applications Cloud, you need to populate a CSV file with your source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

- Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
- Ensure prerequisite setups are done, if applicable.
- Understand your options for uniquely identifying the records.
- Ensure parent records exist before importing child records.
- Identify the target object attributes that are required in the CSV file for a successful import.
Before You Start
You must do some basic checks before starting your import. For example, make sure that:

- You have completed all the prerequisites for importing each attribute in your source data.
- You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records

To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the import process to uniquely identify the records. The file import process uses the attribute values to automatically map your source data to the target object attributes in Oracle Applications Cloud.

The preferred option for uniquely identifying an object record is through the Public unique identifier. If you're creating new records, then you can provide a user-friendly public unique identifier (attributes denoted with ‘Number’ and usually visible in the business object’s UI). If you update a record for which you have previously provided a Number attribute, or for which a Number attribute is visible in the object’s UI, you can use the Number attribute to identify the record. For the Subscription Product object, the attributes are:

- LineNumber
- SubscriptionProductPuid
- BillToAccountNumber
- ExemptCertificateNumber

Required Attributes and Validations for Subscription Product Object

To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure that you provide valid values for the attributes. This table lists the required attributes for importing new Subscription Product records, required attributes for updating Subscription Product records, prerequisite setup tasks for the attributes, and specific validations, if any, for Subscription Product import:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/Import Validations</th>
<th>Creating a Subscription Product Record</th>
<th>Updating an Existing Subscription Product Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>LineNumber</td>
<td>The line number</td>
<td>This must not be duplicate within a subscription.</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td>DefinitionOrganizationId</td>
<td>The item master organization</td>
<td>This must be a valid ORGANIZATION_ID from the HR_ALL_ORGANIZATION_UNITS_F table.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>InventoryItemID</td>
<td>The inventory item ID</td>
<td>EGP_SYSTEM_ITEMS_B.INVENTORY_ITEM_ID</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td>StartDate</td>
<td>The start date of the subscription</td>
<td>This must be later than or equal to the subscription start date.</td>
<td>Required</td>
<td>Not required</td>
</tr>
</tbody>
</table>
### Chapter 8
Import Your Data

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/Import Validations</th>
<th>Creating a Subscription Product Record</th>
<th>Updating an Existing Subscription Product Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>Currency</td>
<td>The subscription product currency</td>
<td>Do not pass any value.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>InvoicingRuleId</td>
<td>The invoicing rule ID</td>
<td>RA_RULES.RULE_ID where TYPE = 'I'</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>BillingFrequency</td>
<td>The billing frequency</td>
<td>oss_time_code_units.user_uom_code</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>AccountingRuleId</td>
<td>The accounting rule ID</td>
<td>RA_RULES.RULE_ID where TYPE in ('A', 'ACC_DUR', 'PP_DR_ALL', 'PP_DR_PP')</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>TransactionTypeName</td>
<td>The transaction type name</td>
<td>This must be a valid transaction type name per RA_CUST_TRX_TYPES_ALL table.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>BillToAccountId</td>
<td>The bill-to account ID</td>
<td>HZ_CUST_ACCOUNTS.CUST_ACCOUNT_ID</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>BillToSiteUseId</td>
<td>The bill-to site use ID</td>
<td>HZ_CUST_SITE_USES_ALL.SITE_USE_ID</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>PaymentTermsId</td>
<td>The payment terms ID</td>
<td>RA_TERMS_VL.TERM_ID</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>SubscriptionProductId</td>
<td>The subscription product ID</td>
<td>This is auto generated when a record is created.</td>
<td>Not required</td>
<td>Required</td>
</tr>
<tr>
<td>Status</td>
<td>The subscription product status</td>
<td>This must be ORA_DRAFT.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>SubscriptionId</td>
<td>The subscription ID</td>
<td>Do not pass any value.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>SubscriptionNumber</td>
<td>The subscription number</td>
<td>This must be a valid and existing subscription number.</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td>SubscriptionProductPuid</td>
<td>The subscription product PUID</td>
<td>This must be a unique subscription product PUID.</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td>EnablePricingTermsFlag</td>
<td>Option indicating whether the pricing terms are enabled</td>
<td>Y or N</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>Attribute</td>
<td>Description</td>
<td>Prerequisite Setup Task/Import Validations</td>
<td>Creating a Subscription Product Record</td>
<td>Updating an Existing Subscription Product Record</td>
</tr>
<tr>
<td>--------------------------</td>
<td>------------------------------------------------------------------------------</td>
<td>-------------------------------------------</td>
<td>----------------------------------------</td>
<td>--------------------------------------------------</td>
</tr>
<tr>
<td>SummarizedBillingFlag</td>
<td>Option indicating whether billing is summarized at covered product level</td>
<td>Y or N</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>InterfaceOffsetDays</td>
<td>The interface offset days</td>
<td>This must be a number.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>CoverageName</td>
<td>The coverage name</td>
<td>OSS_COVERAGE_HEADERS.COVERAGE_HEADER_ID</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>SuspendReason</td>
<td>The suspend reason</td>
<td>Lookup: ORA_OSS_CLOSE REASONS</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>SuspendedDate</td>
<td>The date of suspension</td>
<td>This must be between the start date and end date.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>SuspendCreditMethod</td>
<td>The suspend credit method</td>
<td>Lookup: ORA_OSS_CLOSE_CREDIT_METHOD</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>ResumeDate</td>
<td>The date of resumption of a suspended subscription</td>
<td>This must be a valid date.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>ResumeDuration</td>
<td>The duration for which the suspended subscription isn't resumed</td>
<td>This must be a positive integer.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>ResumePeriod</td>
<td>The period for which the suspended subscription isn't resumed</td>
<td>This must be a valid value from OSS_TIME_CODE_UNITS.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>AutoExtendFlag</td>
<td>Option indicating whether the subscription should be auto extended</td>
<td>Y or N</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>ChurnProbability</td>
<td>The churn probability of the subscription product</td>
<td>Do not pass any value.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>InvoicedAmount</td>
<td>The invoiced amount</td>
<td>Do not pass any value.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>CreditedAmount</td>
<td>The credited amount</td>
<td>Do not pass any value.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>CanceledAmount</td>
<td>The canceled amount</td>
<td>Do not pass any value.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>ClosedAmount</td>
<td>The closed amount</td>
<td>Do not pass any value.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
</tbody>
</table>
### Attribute | Description | Prerequisite Setup Task/Import Validations | Creating a Subscription Product Record | Updating an Existing Subscription Product Record
---|---|---|---|---
LineNumber | The line number | This must not be duplicate within a subscription. | Required | Not required
Duration | The duration | This must be a positive integer. | Not required | Not required
Period | The subscription product period | This must be a valid value from OSS_TIME_CODE_UNITS. | Not required | Not required
GenerateBillingSchedule | Option indicating whether billing schedule is to be generated | Must be Y or N | Not required | Not required
PriceListName | The price list name | Do not pass any value. | Not required | Not required
PricingTermsPricingMethod | The pricing terms pricing method | ORA_MARKUP_AMOUNT, ORA_MARKUP_PERCENT, ORA_REPRICE | Not required | Not required
PricingTermsPeriod | The pricing terms period | This must be a valid value from OSS_TIME_CODE_UNITS. | Not required | Not required
PricingTermsDuration | The pricing terms duration | This must be a positive integer. | Not required | Not required
PricingTermsAdjustmentPCT | The pricing terms adjustment | This must be a positive integer. Lookup: | Not required | Not required
AmendCreditMethod | The amend credit method | ORA_OSS_CLOSE_CREDIT_METHOD | Not required | Not required
AmendCreditMethodName | The amend credit method name | Lookup: ORA_OSS_CLOSE_CREDIT_METHOD | Not required | Not required
AmendEffectiveDate | The amend effective date | This date must be between the start and the end dates. | Not required | Not required
AmendReason | The amend reason | Lookup: ORA_OSS_CLOSE_REASONS | Not required | Not required
AmendReasonName | The amend reason name | Lookup: ORA_OSS_CLOSE_REASONS | Not required | Not required
SalesProductType | The sales product type | SUBSCRIPTION, COVERAGE | Not required | Not required
<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/Import Validations</th>
<th>Creating a Subscription Product Record</th>
<th>Updating an Existing Subscription Product Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>ItemUnitOfMeasure</td>
<td>The item unit of measure</td>
<td>INV_UNITS_OF_MEASURE_BUOM_CODE</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>ProductName</td>
<td>The product name</td>
<td>This must be a valid item description.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>Quantity</td>
<td>The quantity</td>
<td>This must be a positive integer.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>CloseReason</td>
<td>The reason why the product was closed</td>
<td>Lookup: ORA_OSS_CLOSE_REASONS</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>CloseCreditMethod</td>
<td>The close credit method</td>
<td>Lookup: ORA_OSS_CLOSE_CREDIT_METHOD</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>CancelReason</td>
<td>The reason why the product was canceled</td>
<td>This must be a valid reason. Lookup: ORA_OSSCANCEL_REASONS</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>ClosedDate</td>
<td>The date on which the product was closed</td>
<td>This must be later than the start date.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>CanceledDate</td>
<td>The date on which the product was canceled</td>
<td>This must be between the start and end dates.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>RenewedDate</td>
<td>The date on which the product was renewed</td>
<td>Do not pass any value.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>PriceListId</td>
<td>The price list ID</td>
<td>Do not pass any value.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>UnitPrice</td>
<td>The unit price</td>
<td>This must be a positive integer.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>InvoicingRuleName</td>
<td>The invoice rule name.</td>
<td>RA_RULES.NAME where TYPE = 'I'</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>BillingFrequencyName</td>
<td>The billing frequency name</td>
<td>oss_time_code_units.base_uom_code</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>AccountingRuleName</td>
<td>The accounting rule name</td>
<td>RA_RULES.NAME where TYPE in ('A','ACC_DUR','PP_DR_ALL','PP_DR_PP')</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>Attribute</td>
<td>Description</td>
<td>Prerequisite Setup Task/Import Validations</td>
<td>Creating a Subscription Product Record</td>
<td>Updating an Existing Subscription Product Record</td>
</tr>
<tr>
<td>----------------------------</td>
<td>--------------------------------------------------</td>
<td>--------------------------------------------------------------------------------</td>
<td>----------------------------------------</td>
<td>---------------------------------------------</td>
</tr>
<tr>
<td>BillToAccountNumber</td>
<td>The bill-to account number</td>
<td>HZ_CUST_ACCOUNTS.ACCOUNT_NUMBER</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>BillToAccountDescription</td>
<td>The bill-to account description</td>
<td>HZ_CUST_ACCOUNTS</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>BillToAddress</td>
<td>The bill-to address</td>
<td>Lookup: HZ_CUST_SITEUSES_ALL</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>ShipToPartyId</td>
<td>The ship-to party ID</td>
<td>Lookup: HZ_PARTIES</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>ShipToPartyName</td>
<td>The ship-to party name</td>
<td>Lookup: HZ_PARTIES</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>ShipToPartySiteId</td>
<td>The ship-to party site ID</td>
<td>Lookup: HZ_CUST_SITEUSES_ALL</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>ShipToPartySiteName</td>
<td>The ship-to party site name</td>
<td>Lookup: HZ_CUST_SITEUSES_ALL</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>PaymentMethod</td>
<td>The payment method ID</td>
<td>This must be ORA_PURCHASE_ORDER or ORA_WIRE.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>PaymentMethodName</td>
<td>The payment method name</td>
<td>This must be Purchase Order or Wire.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>PaymentTermsName</td>
<td>The payment terms name</td>
<td>RA_TERMS_VL.NAME</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>TaxExemptionHandling</td>
<td>The tax exemption handling</td>
<td>LOOKUP_TYPE: ZX_EXEMPTION_CONTROL</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>TaxExemptionHandlingName</td>
<td>The tax exemption handling name</td>
<td>LOOKUP_TYPE: ZX_EXEMPTION_CONTROL</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>ExemptCertificateNumber</td>
<td>The exempt certificate number</td>
<td>ZX_EXEMPTIONS_V.EXEMPT_CERTIFICATE_NUMBER</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>ExemptReason</td>
<td>The exempt reason</td>
<td>LOOKUP_TYPE: ZX_EXEMPTION_CONTROL</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>OutputTaxClassification</td>
<td>The output tax classification</td>
<td>LOOKUP_TYPE: ZX_OUTPUT_CLASSIFICATIONS</td>
<td>Not required</td>
<td>Not required</td>
</tr>
</tbody>
</table>
### Attribute Setup

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/Import Validations</th>
<th>Creating a Subscription Product Record</th>
<th>Updating an Existing Subscription Product Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>TaxError</td>
<td>The tax error</td>
<td>Do not pass any value.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>CoverageScheduleId</td>
<td>The coverage schedule ID</td>
<td>Do not pass any value.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>RenewalType</td>
<td>The renewal type</td>
<td>Lookup: ORA_OSS_RENEWAL_ACTION</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>BillingDateCode</td>
<td>The billing date code</td>
<td>ORA_DAY, ORA_OFFSET, ORA_PERIOD_END, ORA_PERIOD_START</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>BillingDateName</td>
<td>The billing date name</td>
<td>Day, Offset, Period end, Period start</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>TotalContractValue</td>
<td>The total contract value</td>
<td>Do not pass any value.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>EstimatedTax</td>
<td>Estimated Tax</td>
<td>Do not pass any value.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>PricingError</td>
<td>The pricing error</td>
<td>Do not pass any value.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
</tbody>
</table>

**Note:** To generate the billing schedule based on your pricing, set the `GenerateBillingSchedule` option to Yes and re-import the Subscription.csv file after all files have been imported. You should not provide the `GenerateBillingSchedule` option in the Subscription Product CSV file but only in the Subscription CSV file.

You can view the Subscription Product object along with all its child objects and attributes in the Manage Import Objects page of the Import Management flow. You can find attribute information like type, length, description, and so on, on this page.

### Create the Source CSV File

You include the data that you want to import into CX Sales and B2B Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to **Navigator > Tools > Import Management > Import Objects.**
2. Select the **Subscription Product** object in the table and click **Download**.

You can now edit the downloaded file and provide valid values for the required attributes.

**Note:** For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.
Create the Import Activity

After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Subscription Product from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results

Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed. You can drill down on the import activity to go to the Import Status page which provides the status details of the import activity.

Import Your Subscription Product Bill Line Data

You can use import management to create or update Subscription Product Bill records.

To import Subscription Product Bill records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes

To import your Subscription Product Bill data into Oracle Applications Cloud, you need to populate a CSV file with your source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

- Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
- Ensure prerequisite setups are done, if applicable.
- Understand your options for uniquely identifying the records.
- Ensure parent records exist before importing child records.
- Identify the target object attributes that are required in the CSV file for a successful import.
Before You Start
You must do some basic checks before starting your import. For example, make sure that:

- You have completed all the prerequisites for importing each attribute in your source data.
- You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the import process to uniquely identify the records. The file import process uses the attribute values to automatically map your source data to the target object attributes in Oracle Applications Cloud.

The preferred option for uniquely identifying an object record is through the Public unique identifier. If you’re creating new records, then you can provide a user-friendly public unique identifier (attributes denoted with ‘Number’ and usually visible in the business object’s UI). If you update a record for which you have previously provided a Number attribute, or for which a Number attribute is visible in the object’s UI, you can use the Number attribute to identify the record. For the Subscription Product Bill object, the attributes are CoveredLevelPuid, PrePaymentNumber and SequenceNumber.

Required Attributes and Validations for Subscription Product Bill Object
To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure that you provide valid values for the attributes. This table lists the required attributes for importing new Subscription Product Bill records, required attributes for updating Subscription Product Bill records, prerequisite setup tasks for the attributes, and specific validations, if any, for Subscription Product Bill import:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/Import Validations</th>
<th>Creating a Subscription Product Bill Record</th>
<th>Updating an Existing Subscription Product Bill Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>DateBilledTo</td>
<td>The date up to which the subscription product is billed</td>
<td>This must be a valid date.</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td>RecurringFlag</td>
<td>Option indicating whether this line is recurring</td>
<td>Y or N</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td>BillingPeriod</td>
<td>The billing period</td>
<td>This must be a positive number and unique for the product.</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td>DateToInterface</td>
<td>The date to interface</td>
<td>This must be a valid date.</td>
<td>Not Required</td>
<td>Not required</td>
</tr>
<tr>
<td>DateBilledFrom</td>
<td>The date from which the subscription product is billed</td>
<td>This must be a valid date.</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td>BillLineId</td>
<td>The bill line ID</td>
<td>Do not pass any value.</td>
<td>Not Required</td>
<td>Not required</td>
</tr>
<tr>
<td>Attribute</td>
<td>Description</td>
<td>Prerequisite Setup Task/Import Validations</td>
<td>Creating a Subscription Product Bill Record</td>
<td>Updating an Existing Subscription Product Bill Record</td>
</tr>
<tr>
<td>--------------------</td>
<td>--------------------------------------------------</td>
<td>--------------------------------------------</td>
<td>---------------------------------------------</td>
<td>-----------------------------------------------------</td>
</tr>
<tr>
<td>InterfacedFlag</td>
<td>Option indicating whether the bill line is interfaced</td>
<td>Y or N</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td>SubscriptionProductPuid</td>
<td>The subscription product PUID</td>
<td>This must be a valid subscription product PUID.</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td>SubscriptionId</td>
<td>The subscription ID</td>
<td>Do not pass any value.</td>
<td>Not Required</td>
<td>Not required</td>
</tr>
<tr>
<td>SubscriptionProductId</td>
<td>The subscription product ID</td>
<td>Do not pass any value.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>BillLinePuid</td>
<td>The bill line PUID</td>
<td>This must be a unique bill line PUID.</td>
<td>Required</td>
<td>Required</td>
</tr>
<tr>
<td>Amount</td>
<td>The amount</td>
<td>This must be a positive number.</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td>UsageFlag</td>
<td>Option indicating whether the line is a usage line</td>
<td>Y or N</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td>UsageAcquiredFlag</td>
<td>Option indicating whether the usage has been acquired</td>
<td>Y or N</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>UsagePricedFlag</td>
<td>Option indicating whether usage line has been priced</td>
<td>Y or N</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>TransactionClass</td>
<td>The transaction class</td>
<td>This must be INV for invoice and CM for credit memo.</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td>TransactionTax</td>
<td>The transaction tax</td>
<td>This must be a positive number.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>TransactionAmount</td>
<td>The transaction amount</td>
<td>This must be a positive number.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>InvoiceBillLineId</td>
<td>The invoice bill line ID</td>
<td>Do not pass any value.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>UsageCaptureDate</td>
<td>The usage capture date</td>
<td>This must be a valid date.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>UsageQuantity</td>
<td>The usage quantity</td>
<td>This must be a positive number.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>ChargePeriod</td>
<td>The charge period</td>
<td>This must be a valid charge period.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
</tbody>
</table>
## Attribute | Description | Prerequisite Setup Task/Import Validations | Creating a Subscription Product Bill Record | Updating an Existing Subscription Product Bill Record
--- | --- | --- | --- | ---
PricingError | The pricing error | Do not pass any value. | Not required | Not required
ListPrice | The list price | This must be a positive number when TransactionClass is INV and a number when it's CM. | Required | Not required
RevenueLineId | The revenue line ID | Do not pass any value. | Not required | Not required
TransactionClassMeaning | The meaning of transaction class lookup | Invoice or Credit Memo | Not required | Not required
InvoiceDate | The invoice date | This must be a valid date. | Not required | Not required
NewCreditMemoPUID | The credit memo PUID | Do not pass any value. | Not required | Not required
CreditMemoAmount | The credit memo amount | Do not pass any value. | Not required | Not required
CreditMemoFlag | The credit memo option | Do not pass any value. | Not required | Not required
CreditMemoReason | The credit memo reason | Do not pass any value. | Not required | Not required
CustomerTrxTypeSequenceId | The customer transaction type sequence ID | This must be a number. | Not required | Not required
CoveredLevelId | The covered level ID | Do not pass any value. | Not required | Not required
ChargeId | The charge ID | This must be a valid charge ID. | Required | Not required

You can view the Subscription Product Bill object along with all its child objects and attributes in the Manage Import Objects page of the Import Management flow. You can find attribute information like type, length, description, and so on, on this page.

### Create the Source CSV File

You include the data that you want to import into CX Sales and B2B Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to **Navigator > Tools > Import Management > Import Objects**.
2. Select the **Subscription Product Bill** object in the table and click **Download**.

You can now edit the downloaded file and provide valid values for the required attributes.
Create the Import Activity

After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Subscription Product Bill from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you’re ready.

Review the Import Results

Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed. You can drill down on the import activity to go to the Import Status page which provides the status details of the import activity.

Related Topics

- Potential Issues When Opening CSV Files in Excel
- Import Data

Import Your Subscription Product Charge Data

You can use import management to create or update Subscription Product Charge records.

To import Subscription Product Charge records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes

To import your Subscription Product Charge data into Oracle Applications Cloud, you need to populate a CSV file with your source data and map that source data to target object attributes in Oracle Applications Cloud.
You need to do the following before creating the CSV file for data import:

- Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
- Ensure prerequisite setups are done, if applicable.
- Understand your options for uniquely identifying the records.
- Ensure parent records exist before importing child records.
- Identify the target object attributes that are required in the CSV file for a successful import.

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

- You have completed all the prerequisites for importing each attribute in your source data.
- You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the import process to uniquely identify the records. The file import process uses the attribute values to automatically map your source data to the target object attributes in Oracle Applications Cloud.

The preferred option for uniquely identifying an object record is through the Public unique identifier. If you’re creating new records, then you can provide a user-friendly public unique identifier (attributes denoted with ‘Number’ and usually visible in the business object’s UI). If you update a record for which you have previously provided a Number attribute, or for which a Number attribute is visible in the object’s UI, you can use the Number attribute to identify the record. For the Subscription Product Charge object, the attributes are SubscriptionProductPuid, ChargePuid, and SequenceNumber.

Required Attributes and Validations for Subscription Product Charge Object
To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure that you provide valid values for the attributes. This table lists the required attributes for importing new Subscription Product Charge records, required attributes for updating Subscription Product Charge records, prerequisite setup tasks for the attributes, and specific validations, if any, for Subscription Product Charge import:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/Import Validations</th>
<th>Creating a Subscription Product Charge Record</th>
<th>Updating an Existing Subscription Product Charge Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>PriceType</td>
<td>The price type</td>
<td>RECURREN or ONE_TIME</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td>Chargeld</td>
<td>The charge ID</td>
<td>Do not pass any value.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>SubscriptionProductPuid</td>
<td>The subscription product PUID</td>
<td>This must be a valid subscription product PUID.</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td>SubscriptionId</td>
<td>The subscription ID</td>
<td>Do not pass any value.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>Attribute</td>
<td>Description</td>
<td>Prerequisite Setup Task/ Import Validations</td>
<td>Creating a Subscription Product Charge Record</td>
<td>Updating an Existing Subscription Product Charge Record</td>
</tr>
<tr>
<td>-----------------------</td>
<td>--------------------------------------------------</td>
<td>---------------------------------------------</td>
<td>-----------------------------------------------</td>
<td>-------------------------------------------------------</td>
</tr>
<tr>
<td>SubscriptionProductId</td>
<td>The subscription product ID</td>
<td>Do not pass any value.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>ChargePuid</td>
<td>The charge PUID</td>
<td>This must be a unique charge PUID.</td>
<td>Required</td>
<td>Required</td>
</tr>
<tr>
<td>BillLineld</td>
<td>The bill line ID</td>
<td>Do not pass any value.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>CoveredLevelId</td>
<td>The covered level ID</td>
<td>Do not pass any value.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>PricePeriodicity</td>
<td>The price periodicity</td>
<td>This must be a valid value from oss_time_code_units.</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td>RollupFlag</td>
<td>The option indicating whether charges should be rolled up</td>
<td>Y or N</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>SequenceNumber</td>
<td>The sequence number</td>
<td>This must be a positive number.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>UnitListPrice</td>
<td>The unit list price</td>
<td>This must be a valid number.</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td>Allowance</td>
<td>The allowance</td>
<td>Do not pass any value.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>BlockSize</td>
<td>The block size</td>
<td>This must be a positive number.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>TieredFlag</td>
<td>Option indicating whether the charge has tiers</td>
<td>Y or N</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td>TierType</td>
<td>The tier type</td>
<td>Do not pass any value.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>Generate Billing Schedule</td>
<td>The option to generate the billing schedule</td>
<td>Y or N</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>UsagePriceLockFlag</td>
<td>Option indicating whether the usage price is locked</td>
<td>Do not pass any value.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>PricePeriodicityName</td>
<td>The price periodicity name</td>
<td>Do not pass any value.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>MeterDefinitionId</td>
<td>The meter definition ID</td>
<td>This must be a valid meter definition ID.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
</tbody>
</table>
Import Your Data

### Attribute Description

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/ Import Validations</th>
<th>Creating a Subscription Product Charge Record</th>
<th>Updating an Existing Subscription Product Charge Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>Meterld</td>
<td>The meter ID</td>
<td>This must be a valid meter ID.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>InitialMeterReadingId</td>
<td>The initial meter reading ID</td>
<td>This must be a valid meter reading ID.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>AggregationMethod</td>
<td>The aggregation method</td>
<td>This must be a valid aggregation method.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
</tbody>
</table>

**Note:** To generate the billing schedule based on your pricing, set the `GenerateBillingSchedule` option to Yes and re-import the Subscription.csv file after all files have been imported.

You can view the Subscription Product Charge object along with all its child objects and attributes in the Manage Import Objects page of the Import Management flow. You can find attribute information like type, length, description, and so on, on this page.

### Create the Source CSV File

You include the data that you want to import into CX Sales and B2B Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to **Navigator > Tools > Import Management > Import Objects**.
2. Select the **Subscription Product Charge** object in the table and click **Download**.

You can now edit the downloaded file and provide valid values for the required attributes.

**Note:** For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.

### Create the Import Activity

After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to **Navigator > Tools > Import Management > Import Queue**.
2. Click **Create Import Activity** in the **Manage Imports** page.
3. In the **Enter Import Options** page, provide a name for the import activity, and select **Subscription Product Charge** from the **Object** drop-down list.
4. Select the CSV file in the **File Name** field, and click **Next**.
5. You would see that the source and target attributes are automatically mapped in the **Map Fields** page. Review and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking **Validate Data**. Click **Next**.
7. Review the import details on the **Review and Submit** page, and click **Submit** when you’re ready.
Review the Import Results

Check if your import succeeded on the **Manage Imports** page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to **Navigator > Tools > Import Management > Import Queue**.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the **Status** column for the import activity. The import is successful if the status displays as **Completed**. You can drill down on the import activity to go to the **Import Status** page which provides the status details of the import activity.

**Related Topics**
- Potential Issues When Opening CSV Files in Excel
- Import Data

Import Your Subscription Product Sales Credit Data

You can use import management to create or update Subscription Product Sales Credit records.

To import Subscription Product Sales Credit records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

**How You Map Your Source Data to Target Object Attributes**

To import your Subscription Product Sales Credit data into Oracle Applications Cloud, you need to populate a CSV file with your source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

- Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
- Ensure prerequisite setups are done, if applicable.
- Understand your options for uniquely identifying the records.
- Ensure parent records exist before importing child records.
- Identify the target object attributes that are required in the CSV file for a successful import.

**Before You Start**

You must do some basic checks before starting your import. For example, make sure that:

- You have completed all the prerequisites for importing each attribute in your source data.
- You have all parent records in place before importing child records.
Select a Unique Identifier for Your Records

To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the import process to uniquely identify the records. The file import process uses the attribute values to automatically map your source data to the target object attributes in Oracle Applications Cloud.

The preferred option for uniquely identifying an object record is through the Public unique identifier. If you’re creating new records, then you can provide a user-friendly public unique identifier (attributes denoted with ‘Number’ and usually visible in the business object’s UI). If you update a record for which you have previously provided a Number attribute, or for which a Number attribute is visible in the object’s UI, you can use the Number attribute to identify the record. For the Subscription Product Sales Credit object, the attribute is SubscriptionProductPuid.

Required Attributes and Validations for Subscription Product Sales Credit Object

To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure that you provide valid values for the attributes. This table lists the required attributes for importing new Subscription Product Sales Credit records, required attributes for updating Subscription Product Sales Credit records, prerequisite setup tasks for the attributes, and specific validations, if any, for Subscription Product Sales Credit import:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/Import Validations</th>
<th>Creating a Subscription Product Sales Credit Record</th>
<th>Updating an Existing Subscription Product Sales Credit Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>SalesCreditId</td>
<td>Internal ID of the sales credit record</td>
<td>Do not pass any value.</td>
<td>Do not pass any value. This will be auto-created.</td>
<td>Not required</td>
</tr>
<tr>
<td>SalesCreditPuid</td>
<td>PUID of the sales credit record</td>
<td>Enter a unique PUID.</td>
<td>Required</td>
<td>Required</td>
</tr>
<tr>
<td>SubscriptionProductPuid</td>
<td>PUID of the subscription product for which this sales credit is being created or updated.</td>
<td>This must be a valid subscription number.</td>
<td>A value is required if you’re creating a sales credit for a subscription.</td>
<td>Not required</td>
</tr>
<tr>
<td>SubscriptionProductId</td>
<td>ID of the subscription product</td>
<td>Do not pass any value.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>SubscriptionId</td>
<td>ID of the subscription</td>
<td>Do not pass any value.</td>
<td>Not required</td>
<td>Not required</td>
</tr>
<tr>
<td>SalesCreditTypeId</td>
<td>Sales credit type ID</td>
<td>This must be a valid value as per the sales quota lookup.</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td>SalesrepId</td>
<td>Sales representative ID</td>
<td>This must be a valid sales person ID.</td>
<td>Conditionally required A value is required if the SalesPerson isn’t entered.</td>
<td>Not required</td>
</tr>
</tbody>
</table>
### Create the Source CSV File

You include the data that you want to import into CX Sales and B2B Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to **Navigator > Tools > Import Management > Import Objects**.
2. Select the **Subscription Product Sales Credit** object in the table and click **Download**.

You can now edit the downloaded file and provide valid values for the required attributes.

**Note:** For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.

### Create the Import Activity

After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to **Navigator > Tools > Import Management > Import Queue**.
2. Click **Create Import Activity** in the Manage Imports page.
3. In the **Enter Import Options** page, provide a name for the import activity, and select Subscription Product Sales Credit from the **Object** drop-down list.
4. Select the CSV file in the **File Name** field, and click **Next**.
5. You would see that the source and target attributes are automatically mapped in the **Map Fields** page. Review and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking **Validate Data**. Click **Next**.
7. Review the import details on the **Review and Submit** page, and click **Submit** when you're ready.
Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed. You can drill down on the import activity to go to the Import Status page which provides the status details of the import activity.

Related Topics
• Potential Issues When Opening CSV Files in Excel
• Import Data

Import Your Subscription Sales Credit Data
You can use import management to create or update Subscription Sales Credit records.

To import Subscription Sales Credit records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Target Object Attributes
To import your Subscription Sales Credit data into Oracle Applications Cloud, you need to populate a CSV file with your source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
• Ensure prerequisite setups are done, if applicable.
• Understand your options for uniquely identifying the records.
• Ensure parent records exist before importing child records.
• Identify the target object attributes that are required in the CSV file for a successful import.

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.
• You have all parent records in place before importing child records.
Select a Unique Identifier for Your Records

To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the import process to uniquely identify the records. The file import process uses the attribute values to automatically map your source data to the target object attributes in Oracle Applications Cloud.

The preferred option for uniquely identifying an object record is through the Public unique identifier. If you're creating new records, then you can provide a user-friendly public unique identifier (attributes denoted with 'Number' and usually visible in the business object’s UI). If you update a record for which you have previously provided a Number attribute, or for which a Number attribute is visible in the object’s UI, you can use the Number attribute to identify the record. For the Subscription Sales Credit object, the attributes are SalesCreditPUID and SubscriptionNumber.

Required Attributes and Validations for Subscription Sales Credit Object

To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure that you provide valid values for the attributes. This table lists the required attributes for importing new Subscription Sales Credit records, required attributes for updating Subscription Sales Credit records, prerequisite setup tasks for the attributes, and specific validations, if any, for Subscription Sales Credit import:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/ Import Validations</th>
<th>Creating a Subscription Sales Credit Record</th>
<th>Updating an Existing Subscription Sales Credit Record</th>
</tr>
</thead>
<tbody>
<tr>
<td>SalesCreditPuid</td>
<td>PUID of the sales credit record</td>
<td>Enter a unique PUID.</td>
<td>Required</td>
<td>Required</td>
</tr>
<tr>
<td>SubscriptionNumber</td>
<td>Subscription number</td>
<td>This must be a valid subscription number.</td>
<td>A value is required if you’re creating a sales credit for subscription.</td>
<td>Not required</td>
</tr>
<tr>
<td>SubscriptionId</td>
<td>Subscription ID</td>
<td>This must be a valid subscription ID.</td>
<td>A value isn’t required if the subscription number is entered.</td>
<td>Not required</td>
</tr>
<tr>
<td>SubscriptionProductID</td>
<td>Subscription product ID</td>
<td>Do not use this column</td>
<td>Do not use this column</td>
<td>Not required</td>
</tr>
<tr>
<td>SalesrepId</td>
<td>Sales representative ID</td>
<td>This must be a valid sales person ID.</td>
<td>Conditionally required</td>
<td>Not required</td>
</tr>
<tr>
<td>SalesPerson</td>
<td>Sales person name</td>
<td>This must be a valid sales person name.</td>
<td>Conditionally required</td>
<td>Not required</td>
</tr>
<tr>
<td>SalesCreditTypeld</td>
<td>Sales credit type ID</td>
<td>This must be a valid value as per the sales quota lookup.</td>
<td>Required</td>
<td>Not required</td>
</tr>
</tbody>
</table>
Create the Source CSV File

You include the data that you want to import into CX Sales and B2B Service in a source CSV file. You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator > Tools > Import Management > Import Objects.
2. Select the Subscription Sales Credit object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

**Note:** For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity

After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Subscription Sales Credit from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results

Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed. You can drill down on the import activity to go to the Import Status page which provides the status details of the import activity.
Related Topics

- Potential Issues When Opening CSV Files in Excel
- Import Data

Import Your Template Data

You can use the Import Management to create, update, or delete template records.

You can import template records using these steps:

1. Map your source template data to Oracle Applications Cloud object attributes. This way the import process would know where to insert each of the information bits.
2. Create the source CSV file with the template data you want to import.
4. Check the import results to know if the import went well.

How You Map Your Source Data to Target Object Attributes

To import your template data into Oracle Applications Cloud, you must populate a .csv file with your source data and map that source data to target object attributes in Oracle Applications Cloud.

You must do the following before creating the .csv file for data import:

- Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
- Ensure prerequisite steps are complete, such as understanding what attributes are required for importing your objects.
- Understand your options for uniquely identifying the records.
- Ensure parent records exist before importing child records.
- Identify the target object attributes that are required in the .csv file for a successful import.

To better manage your template information, the template object has the following child object:

- Template Action

If you want to import only a few records, then you can create a single CSV file for all template attributes. However if you want to import a large number of records, then you may decide to create multiple CSV files, one for each of the template child objects. Note that you must have imported the CSV file for template object successfully before trying to import the CSV files for the child objects. There are separate help topics describing how to import each of these child objects. For more information, see the related topics section.

Before You Start

You must do some basic checks before starting your import. For example, make sure that:

- You have completed all the prerequisites for importing each attribute in your source data.
- You have all parent records in place before importing child records.
Select a Unique Identifier for Your Records

All records must be unique in the application. You can use one of these to identify records:

- **Public unique identifiers**: If you’re creating records, then you can provide an easily understandable public unique identifier. These are, usually, denoted with ‘Number’ and visible in the business object’s UI. PUID attributes are usually named `<object> Number`. If you’re updating a record with a Number attribute, then use the Number attribute to identify the record. For more information about public unique identifiers, see the topic "How You Use Alternate Keys to Import Records" in Related Topics section.

- **Source system and source system reference**: Source system is an identifier for the external system, and source system reference is a unique identifier within the external system. If you’re importing new templates or are updating templates that have source system reference data, then provide the source system and source system reference values.

Required Attributes and Validations for Template Object

To import data successfully into Oracle Applications Cloud, your .csv file must include the required attributes. Ensure that you provide valid values for the attributes.

This table lists the required attributes for template records, prerequisite setup tasks and specific validations, if any:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Description</th>
<th>Prerequisite Setup Task/Import Validations</th>
<th>Creating a Template record</th>
<th>Updating an Existing Template record</th>
</tr>
</thead>
<tbody>
<tr>
<td>Calendar</td>
<td>The unique Id of the existing Calendar record in the Oracle Fusion destination table.</td>
<td>Provide a valid Calendar ID.</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td>Template</td>
<td>Name of the Template.</td>
<td>None</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td>Context</td>
<td>Indicates the context of the Template. Currently, the context of the template is always 'Service Request'.</td>
<td>The Valid Value is ServiceRequest.</td>
<td>Required</td>
<td>Not required</td>
</tr>
<tr>
<td>Template Id</td>
<td>The unique Id of the Template record in the Oracle Fusion destination table.</td>
<td>None</td>
<td>Not required</td>
<td>A value is required if you're updating an existing Template and you're not providing the Template Number</td>
</tr>
<tr>
<td>TemplateNumber</td>
<td>Specifies the original system reference (Template Unique Id), if the record was imported</td>
<td>None</td>
<td>Not required</td>
<td>A value is required if you're updating an existing Template and you're not providing the Template ID</td>
</tr>
</tbody>
</table>

Go to **Navigator > Tools > Import Management > Import Objects**, to see all the attributes of the template object. The page also lists attribute information like type, length, description, and so on.
Create the Source CSV File
You include the data that you want to import into CX Sales and B2B Service in a source CSV file.

You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator > Tools > Import Management > Import Objects.
2. Select the Template object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

**Note:** For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity
After you have the CSV file ready, create an import activity to import the template information. To create an import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Template from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. You would see that the source and target attributes are automatically mapped in the Map Fields page. Review and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you're ready.

Review the Import Results
Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed. You can drill down on the import activity to go to the Import Status page which provides the status details of the import activity.

**Related Topics**
- Potential Issues When Opening CSV Files in Excel
- How You Use Alternate Keys to Import Records
- Import Data

Import Your Template Action Data
You can use the Import Management to create, update, or delete template action records.
You can import template action records using these steps:

1. Map your source template action data to Oracle Applications Cloud object attributes. This way the import process would know where to insert each of the information bits.
2. Create the source CSV file with the template action data you want to import.
4. Check the import results to know if the import went well.

How You Map Your Source Data to Target Object Attributes

To import your template action data into Oracle Applications Cloud, you must populate a .csv file with your source data and map that source data to target object attributes in Oracle Applications Cloud.

You must do the following before creating the .csv file for data import:

- Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
- Ensure prerequisite steps are complete, such as understanding what attributes are required for importing your objects.
- Understand your options for uniquely identifying the records.
- Ensure parent records exist before importing child records.
- Identify the target object attributes that are required in the .csv file for a successful import.

Before You Start

You must do some basic checks before starting your import. For example, make sure that:

- You have completed all the prerequisites for importing each attribute in your source data.
- You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records

All records must be unique in the application. You can use one of these to identify records:

- Public unique identifiers: If you're creating records, then you can provide an easily understandable public unique identifier. These are, usually, denoted with 'Number' and visible in the business object's UI. PUID attributes are usually named <object> Number. If you're updating a record with a Number attribute, then use the Number attribute to identify the record. For more information about public unique identifiers, see the topic "How You Use Alternate Keys to Import Records" in Related Topics section.
- Source system and source system reference: Source system is an identifier for the external system, and source system reference is a unique identifier within the external system. If you're importing new template actions or are updating template actions that have source system reference data, then provide the source system and source system reference values.

Required Attributes and Validations for Template Action Object

To import data successfully into Oracle Applications Cloud, your .csv file must include the required attributes. Ensure that you provide valid values for the attributes.

This table lists the required attributes for template action records, prerequisite setup tasks and specific validations, if any:
### Attribute | Description | Prerequisite Setup Task/ Import Validations | Creating a Template Action record | Updating an Existing Template Action record
--- | --- | --- | --- | ---
Action Id | Specifies the foreign key that references the Action ID to which the action is assigned | Identify the Action ID value by exporting the Action object for the actions marked as "ORA_SVC_CUSTOMER_VISIBLE". Navigate to the following in the Setup and Maintenance work area: - Offering: Sales - Functional Area: Data Import and Export - Task: Manage Bulk Data Export, Schedule Export Processes | Required | Not required
Template Action Id | Specifies the unique Id of the Template Action record in the Oracle Fusion destination table | None | Not required | A value is required if you're updating an existing Template Action and you're not providing the Template Number.
Template Id | Specifies the foreign key that references the Template ID to which the action is assigned | Identify the Template ID value by exporting the Template object. Navigate to the following in the Setup and Maintenance work area: - Offering: Sales - Functional Area: Data Import and Export - Task: Manage Bulk Data Export, Schedule Export Processes | Required | Not required
TemplateNumber | Specify a value for this attribute to add a new record for templateAction. To update the templateAction, specify a value for the templateActionID attribute | None | Not required | A value is required if you're updating an existing Template and you're not providing the Template Action ID.

Go to **Navigator > Tools > Import Management > Import Objects**, to see all the attributes of the template action object. The page also lists attribute information like type, length, description, and so on.

### Create the Source CSV File
You include the data that you want to import into CX Sales and B2B Service in a source CSV file.
You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to **Navigator > Tools > Import Management > Import Objects**.
2. Select the **Template Action** object in the table and click **Download**.

You can now edit the downloaded file and provide valid values for the required attributes.

**Note:** For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.

### Create the Import Activity

After you have the CSV file ready, create an import activity to import the template action information. To create an import activity:

1. Go to **Navigator > Tools > Import Management > Import Queue**.
2. Click **Create Import Activity** in the **Manage Imports** page.
3. In the **Enter Import Options** page, provide a name for the import activity, and select Template Action from the **Object** drop-down list.
4. Select the CSV file in the **File Name** field, and click **Next**.
5. You would see that the source and target attributes are automatically mapped in the **Map Fields** page. Review and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking **Validate Data**. Click **Next**.
7. Review the import details on the **Review and Submit** page, and click **Submit** when you’re ready.

### Review the Import Results

Check if your import succeeded on the **Manage Imports** page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to **Navigator > Tools > Import Management > Import Queue**.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the **Status** column for the import activity. The import is successful if the status displays as **Completed**. You can drill down on the import activity to go to the **Import Status** page which provides the status details of the import activity.

**Related Topics**
- Potential Issues When Opening CSV Files in Excel
- How You Use Alternate Keys to Import Records
- Import Data

### Import Territory Geographies Data

### Import Your Territory Geographies Data

You can use Import Management to create or update Territory Geographies records.
To import Territory Geographies records, perform the following tasks:

1. Map your source data to Oracle Applications Cloud object attributes.
2. Create source Comma Separated Values (CSV) file for import.
3. Create the import activity.
4. Review the import results.

How You Map Your Source Data to Object Attributes
To import your Territory Geographies data into Oracle Applications Cloud, you must populate a .csv file with your source data and map that source data to target object attributes in Oracle Applications Cloud.

You need to do the following before creating the CSV file for data import:

• Identify how your source data attributes map to the target object attributes in Oracle Applications Cloud.
• Ensure prerequisite setups are done, if applicable.
• Understand your options for uniquely identifying the records.
• Ensure parent records exist before importing child records.
• Identify the target object attributes that are required in the CSV file for a successful import.

Before You Start
You must do some basic checks before starting your import. For example, make sure that:

• You have completed all the prerequisites for importing each attribute in your source data.
• You have all parent records in place before importing child records.

Select a Unique Identifier for Your Records
To import data into Oracle Applications Cloud, your CSV file must include some specific attributes that enable the import process to uniquely identify the records. The file import process uses the attribute values to automatically map your source data to the target object attributes in Oracle Applications Cloud.

The preferred options to uniquely identify an object record are as follows:

• Internal ID: If you're identifying a record that already exists in Oracle Applications Cloud, then you can use the internal ID of the record, a system-generated unique identifier. Attributes with “id” in the attribute name are typically internal IDs. Use this option only if you're updating Geographies. You can determine the internal ID of a record by exporting Oracle Applications Cloud object data, or by doing a transactional database query. Using an internal ID typically provides better performance and reduces the import duration. For the Territory Geographies object, the attributes are Batch Id and Interface Row Id.

• Public unique identifiers: If you're creating new records, then you can provide a user-friendly public unique identifier (attributes denoted with ‘Number’ and usually visible in the business object’s UI). If you update a record for which you have previously provided a Number attribute, or for which a Number attribute is visible in the object’s UI, you can use the Number attribute to identify the record. For the Territory Geographies object, the attribute is Import Activity Identifier.

Required Attributes and Validations for the Territory Geographies Object
To import data successfully into Oracle Applications Cloud, your CSV file must include the required attributes. Ensure that you provide valid values for the attributes. The following table lists the required attributes for importing new Territory Geographies records, prerequisite setup tasks for the attributes, and specific validations, if any, for Territory Geographies import:
Create the Source CSV File

You include the data that you want to import into CX Sales and B2B Service in a source CSV file. You can use the templates available in the Import Objects UI page to create the source CSV file. To download a template:

1. Go to Navigator > Tools > Import Management > Import Objects.
2. Select the Territory Geographies object in the table and click Download.

You can now edit the downloaded file and provide valid values for the required attributes.

Note: For help in populating the CSV file and to avoid any issues in entering values, see the topic Potential Issues When Opening CSV Files With Excel in Related Topics section.

Create the Import Activity

After you have the CSV file ready, create an import activity to import the information. To create an import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click Create Import Activity in the Manage Imports page.
3. In the Enter Import Options page, provide a name for the import activity, and select Territory Geographies from the Object drop-down list.
4. Select the CSV file in the File Name field, and click Next.
5. The source and target attributes are automatically mapped in the Map Fields page. Review and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking Validate Data. Click Next.
7. Review the import details on the Review and Submit page, and click Submit when you’re ready.

Review the Import Results

Check if your import succeeded on the Manage Imports page. This page shows the status of all active, completed, and unsuccessful imports. To check the status of the import activity:

1. Go to Navigator > Tools > Import Management > Import Queue.
2. Click All Imports and search for the import activity that you created earlier.
3. Check the Status column for the import activity. The import is successful if the status displays as Completed. You can drill down on the import activity to go to the Import Status page which provides the status details of the import activity.
Example of Importing Territory Geography Data

This example demonstrates how you can import data using Import Management. In this example, you have a source file containing territory geography data that you want to import into the application.

A territory is an area of responsibility of a salesperson over a set of sales accounts. A territory can be based on various dimensions, such as the geography, product, organization type, industry, business size, account, account type, and sales channel dimension. The territory geography defines the boundaries of a territory according to the selected dimensions, such as Europe, USA, or Asia. Dimensions are attributes that define jurisdictional boundaries of territories. You can use geography dimensions to define territories by country or postal code, based on Territory Geographies. You must create or import territory geographies before they can be used in territory definitions.

Summary of the Tasks
You perform the following steps to create an import activity and activate the import.

1. Determine what information is in the source file.
2. Create and schedule the import activity.

Before You Start

1. You use the country structure of a country to define which geography types are part of the country. For more information about an example of importing a country structure, see the topic "Example of Importing Country Structure Data".
2. Ensure that the combination of the Source ID and Parent Source ID values is unique for each row of data within a single import. However, your source data files don’t need to have the same Source ID and Parent Source ID values as your previously imported geography data. If the geography structure levels and the parents for each geography value are the same, then the changed IDs will not affect the import. For example, when importing a country, which is the upper node, and its state, you may provide the following values:
   - Data for a country: SOURCE_ID = 1; PARENT_ID = (NULL). The PARENT_ID is null because the country is the upper level of the territory geography hierarchy and has no parent.
   - Data for a province: SOURCE_ID = 2; PARENT_ID = 1 (the source ID of the country)

Determine the Information in the Source File
You include the data that you want to import into CX Sales and B2B Service in a source CSV file. A sample input CSV file is shown below.

<table>
<thead>
<tr>
<th>GeographyOrZone</th>
<th>LanguageCode</th>
<th>SourceId</th>
<th>ParentSourceId</th>
<th>GeographyOrZone</th>
<th>ZoneCode</th>
<th>CountryName</th>
<th>GeoParentName1</th>
</tr>
</thead>
<tbody>
<tr>
<td>GLOBAL</td>
<td>US</td>
<td>1</td>
<td></td>
<td>GLOBAL</td>
<td>GBL</td>
<td>USA</td>
<td>United States</td>
</tr>
<tr>
<td>North America</td>
<td>US</td>
<td>2</td>
<td>1</td>
<td>COUNTRY</td>
<td></td>
<td>Canada</td>
<td></td>
</tr>
</tbody>
</table>
### Note:

- The hierarchy is modeled in the CSV file using the SourceId and ParentSourceId. The ParentSourceId for the Country Record (level Number 1) is always null.
- If defining an alternate name (RecordTypeCode = 2) for the country, ensure that the ParentSourceId is the same as the SourceId for the Country record (RecordTypeCode=0) and the SourceId is a unique number.
- If defining an alternate name (RecordTypeCode = 2) for any level below the country (LevelNumber >1), ensure that the SourceId and ParentSourceId columns match the values for the original record respectively.

You must create a source file (CSV) file with the attributes and import it using import management as shown in this table.

<table>
<thead>
<tr>
<th>Attribute Name</th>
<th>Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>GeographyOrZoneName</td>
<td>GLOBAL</td>
<td>The primary name of the geography or zone.</td>
</tr>
<tr>
<td>LanguageCode</td>
<td>US</td>
<td>The unique language code of the country to which the territory geography belongs. The default value is US.</td>
</tr>
<tr>
<td>SourceId</td>
<td>1</td>
<td>The source ID for the territory geography, along with the parent source ID, is used to identify the territory geography's parent/child relationship within the source file data and subsequent interface table data.</td>
</tr>
<tr>
<td>ParentSourceId</td>
<td>11</td>
<td>The parent source ID for the geography, along with the source ID is used to identify the geography's parent and child relationship with records within the source file data. This should be null for the country record, as Country is at the top of the hierarchy.</td>
</tr>
<tr>
<td>GeographyOrZoneType</td>
<td>COUNTRY</td>
<td>The type of the geography or zone.</td>
</tr>
<tr>
<td>ZoneCode</td>
<td>GBL</td>
<td>A unique user-defined code of the zone to which the territory geography belongs. It's used only for zones.</td>
</tr>
<tr>
<td>CountryName</td>
<td>USA</td>
<td>The name of the country for that geography. It's used only for master geographies.</td>
</tr>
</tbody>
</table>
You can create an import activity, enter the import details, and schedule the import. To create an import activity:

1. Go to **Navigator > Tools > Import Management > Import Queue**.
2. Click **Create Import Activity** in the **Manage Imports** page.
3. In the **Enter Import Options** page, provide a name for the import activity, and select **Territory Geographies** from the Object drop-down list.
   
   **Note:** In the **Advanced Options** section, the option **Enable High-Volume Import** is selected by default. This mode is designed to import millions of records at once.

4. Select the CSV file in the **File Name** field, and click **Next**.
5. The source and target attributes are automatically mapped in the **Map Fields** page. Review and edit the mappings if required.
6. Check the file for unmapped columns or data format issues by clicking **Validate Data**. Click **Next**.
7. Review the import details on the **Review and Submit** page, and click **Submit**.

**Related Topics**
- Export Data

### Import Management Post Processing for Accounts and Contacts

### Import Management Post Processing Jobs

After importing your data successfully, you must run a couple of post processing jobs for duplicate identification, duplicate resolution, and account assignment.

### Import Management Post Processing Job for Deduplication

After you import your account and contact data, verify if the imported data contains any duplicates. Alternatively, you must also check if your imported data has any duplicates in the database. Therefore, after you import, it’s a good idea to run duplicate identification batches, and if any duplicates are found resolve them either by creating resolution requests to merge or link them.
Identify Duplicates
You can identify duplicates from the duplicate identification work area. To run duplicate identification batches, navigate to the Duplicate Identification work area as follows: Navigator > Customer Data Management > Duplicate Identification. Refer to the following topics linked from the related topic section for details on how to perform this task:

- Create Duplicate Identification Batches and Define Subset Rules
- Considerations for Creating Duplicate Identification Batches
- How You Manage Duplicate Sets

Resolve Duplicates
You can resolve duplicates from the duplicate resolution work area. To resolve duplicates, navigate to the Duplicate Resolution work area as follows - Navigator > Customer Data Management > Duplicate Resolution. Refer to the following topics linked from the related topic section for details on how to perform this task:

- Processing Duplicate Resolution Requests: Worked Example
- Considerations for Selecting the Duplicate Resolution Request Type
- Override System Mapping

Import Management Post Processing Job for Account Assignment
You can schedule and run the Request Account Assignments scheduled process using the Scheduled Processes page. You must have the Run Sales Party Batch Assignment privilege to define and run account batch assignment. You can access the Scheduled Processes page as follows: Navigator > Tools > Scheduled Processes. Refer to the following topic linked from the related topic section for details on how to perform this task:

- Account Assignment Scheduled Processes

Related Topics
- Create Duplicate Identification Batches and Define Subset Rules
- Schedule Account Assignment

How You Enable Automatic Account Assignment
You can enable automatic account assignment after importing data using import management, and setting the respective Profile Options for Account Assignment.

You can configure the following profile options:

- Sales Account Automatic Assignment on Import Enabled (ZCA_BATCH_ASSIGN_ON_BULK_IMPORT) - Enable automatic territory based assignment after sales accounts are imported. If disabled, manually run a batch assignment or assign each sales account individually. The default option is No.
- Sales Account Automatic Assignment on Create Enabled (ZCA_SA_AUTO_ASSIGN_ON_CREATE) - Enable automatic territory based assignment processing after a sales account is created. This Profile is set to Yes for Import Management for Sales Account Assignment.
• Sales Account Automatic Assignment on Update Enabled (ZCA_SA_AUTO_ASSIGN_ON_UPDATE) - Enable automatic territory based assignment processing after a sales account is updated. This Profile is set to Yes for Import Management for Sales Account Assignment.
Import Data Using External Data Loader Client

Overview of External Data Loader Client

This topic provides an overview of the External Data Loader Client.

The External Data Loader Client is a command-line tool that breaks a large data file into smaller importable data files. This improves the performance of large-volume imports. You can also queue the multiple file import activities required to import a large data set, in a single action instead of manually or programmatically triggering multiple import activities.

How You Download and Install the External Data Loader Client

This topic shows how to download and install the External Data Loader Client.

Here are the steps involved in this process:

1. Download and Install the Client
2. Set up Credentials

Before You Start

Ensure that your computer has Java version 1.8 installed.

Ensure that your Operating System is one of these:

- Microsoft Windows 7
- Microsoft Windows 8
- Microsoft Windows 10

Ensure that your Operating System is one of these.

Required Privileges

To download the client, you must have access to My Oracle Support (support.oracle.com). To use the tool to import data into CX Sales and B2B Service you must be able to access REST services and import data for the objects.

Prerequisite Steps

The Data Loader client doesn't require any specific configuration within CX Sales and B2B Service. However, you must create an import map before using it. The client passes a mapping number value when submitting an import request. You can't create a new import mapping from the Data Loader Client application.
Download and Install the Client

You can download the client from My Oracle Support (Doc ID 2325249.1).

The download contains a ZIP file, with sub-folders. Save the ZIP file to a directory in which the full file path contains no white spaces. You must extract all of the files to a folder on your computer.

Note: When executing the client from the command line the application uses the name oscdataloader.jar. For example,

```
> java -jar oscdataloader.jar -h
```

Set up Credentials

You can install and use the client for automated imports while hiding the credentials that are used with the help of the Credential Store. The Credential Wallet holds one set of user credentials (user name and password pair). To save your credentials use the `savepassword` command,

```
> java -jar oscdataloader.jar savepassword -username John.Doe
```

Enter your password:

```
>
```

You are prompted to enter the password for the specified user name value. This password is masked so that it can’t be viewed in the command window. You can then use the tool to submit or retrieve the status or log files for an import by only providing the user name value. This protects the password of the integration user by preventing other users from viewing the password either on the command line (by scrolling back through recently executed commands, viewing the password in the scheduling utility, or opening a configuration file containing the password value.

You can get the options for each command, by using the option `-h` for that command. For example, the following command lists the options available for the submit command.

```
> java -jar oscdataloader.jar submit -h
```

Use the Configuration File

The default configuration file is oscdataloader.config located in the config folder. This is used for all imports, unless otherwise mentioned. You can use another configuration file using the `-config` parameter.

```
> java -jar oscdataloader.jar listimports -config c:\test\configfile.txt
```

The configuration file should have all parameters, with each line of the file containing a key-value pair. For example:

```
import-name=Testing
input-file=c:\\testing\\testing.csv
mapping-number=888100111272708
target-url=https://mypod.oracle.com
object=Account
username=john.doe
```
How You Use the External Data Loader Client

This topic describes how to use the External Data Loader Client tool.

You can use the tool to split a source file into multiple smaller files for upload and then import. This lets you import large files that exceed the import size limits. You can split a CSV file in one of two ways:

- Independently - the specified CSV file can be split based on selected parameters and no import is performed
- As part of import - the specified CSV file is split and then each of the resulting files is uploaded and then imported

The following steps are involved in using the tool:

- Submit Import Jobs
- Review Status of Import Jobs
- Retrieve Log Files

Submit Import Jobs

The submit operation, takes the source single CSV file, splits the file into smaller files (if necessary), uploads those files to the Webcenter Content Repository and then imports the files. When executing the client from the command line, you must provide the URL of the pod to run the import, the user credentials for authentication, the import object name, the import map number, and the import source file name.

```
```

If multiple import activities are created due to splitting of files, then import activity name values are the same. The file name values are suffixed with a count value. For example, if the source file Account.csv is split into two files, then file name values are called Account_1.csv and Account_2.csv.

You can retrieve the list of imports that have recently run on a server using the listimports command. For example,

```
> java -jar oscdataloader.jar listimports -target-url https://mypod.oracle.com -username importuser
```

lists the imports as a table in the command window. An example of the output would contain the following information:

<table>
<thead>
<tr>
<th>Identifier</th>
<th>Name</th>
<th>Object</th>
<th>Attachment Object</th>
<th>Start Time</th>
<th>End Time</th>
<th>Status</th>
<th>Submitted By</th>
<th>Activate</th>
</tr>
</thead>
<tbody>
<tr>
<td>0123456789012</td>
<td>Account Import 20170410</td>
<td>Account</td>
<td>N/A</td>
<td>20170410 14:56T05:00</td>
<td>20170410 16:56T05:00</td>
<td>Completed</td>
<td>John.Doe</td>
<td>Yes</td>
</tr>
<tr>
<td>7878787878787</td>
<td>Opportunity Sync</td>
<td>Opportunity</td>
<td>N/A</td>
<td>20170411 17:06T05:00</td>
<td>20170411 20:06T05:00</td>
<td>Completed with errors</td>
<td>John.Doe</td>
<td>Yes</td>
</tr>
</tbody>
</table>

**Note:** You should place the import source files in local folders while using EDLC. Remotely mounted files might cause performance issues.
Review Status of Import Jobs

To get the status of an import activity, enter the identifier value of the import on the command line. For example:

```
> java -jar oscdataloader.jar getlogs -target-url https://mypod.oracle.com -username importuser -log-type Exception -import-activity 012345678912345
```

This command displays the detailed status of the matching import request (if no matching request is found, then an error is displayed). An example of the output contains the following information:

<table>
<thead>
<tr>
<th>Object</th>
<th>Attachment Object</th>
<th>Status</th>
<th>Start Time</th>
<th>End Time</th>
<th>Number of File Splits</th>
<th>Records Read</th>
<th>Successfully Loaded</th>
<th>Errors Reported</th>
<th>Warnings Reported</th>
</tr>
</thead>
<tbody>
<tr>
<td>Account</td>
<td>N/A</td>
<td>Completed</td>
<td>20170410 14:56T05:00</td>
<td>20170410 17:36T05:00</td>
<td>2</td>
<td>50,000</td>
<td>49,950</td>
<td>50</td>
<td>0</td>
</tr>
</tbody>
</table>

Retrieve Log Files

You can get the log files generated by an import activity using the `getlogs` command. For example,

```
> java -jar oscdataloader.jar getlogs -target-url https://mypod.oracle.com -username importuser -log-type Exception -import-activity 012345678912345
```

Log files retrieved by the `getlogs` command are stored in the `importlogs` folder by default. Log file of the External Data Loader Client is stored in the `oscdataloaderlogs` folder.

Import Job Statuses

The import job status indicates the status of the import job performed.

The import job can have one of these statuses:

- Completed - all batches have completed.
- Completed with Errors - one or more batches have completed with errors.
- In Progress - one or more batches are currently in progress.
- Unsuccessful - one or more batches are unsuccessful.
- Completed with Warnings - one or more batches have completed with warnings.

Command-Line Parameters

This topic describes the available command-line parameters for External Data Loader Client.

You can use the help option to see a list of all the commands that are available. For example, the following command lists all the command-line options.

```
> java -jar oscdataloader.jar help
```
You can get the options for each command, by using the option -h for that command. For example, the following command lists the options available for the submit command.

```java
> java -jar oscdataloader.jar submit -h
```

If you're using a proxy server while importing using the EDLC, then you must specify the proxy parameters in the command-line call. The following example shows how:

```java
java -Dhttps.proxyHost=host_name -Dhttps.proxyPort=80 -jar
oscdataloader.jar listobjects -target-url https://<your_pod> -u importuser -w
```

Here are the command-line parameters.

<table>
<thead>
<tr>
<th>Command and Options (Preceded by Hyphen)</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>config</td>
<td>The path where the configuration file is located.</td>
</tr>
<tr>
<td>-desc</td>
<td>The description of the import job submitted.</td>
</tr>
<tr>
<td>-delimiter</td>
<td>The delimiter used in your source file. The default value is COMMA_DELIMITER. Possible values are:</td>
</tr>
<tr>
<td></td>
<td>- COMMA_DELIMITER: Indicates the comma delimiter</td>
</tr>
<tr>
<td></td>
<td>- OTHER_CARET: Indicates the caret symbol delimiter</td>
</tr>
<tr>
<td></td>
<td>- OTHER_COLON: Indicates the colon delimiter</td>
</tr>
<tr>
<td></td>
<td>- OTHER_CLOSING_CURLY_BRACKET: Indicates the closing curly bracket delimiter</td>
</tr>
<tr>
<td></td>
<td>- OTHER_CLOSING_PARENTHESIS: Indicates the closing parenthesis delimiter</td>
</tr>
<tr>
<td></td>
<td>- OTHER_CLOSING_SQUARE_BRACKET: Indicates the closing square bracket delimiter</td>
</tr>
<tr>
<td></td>
<td>- OTHER_EXCLAMATORY: Indicates the exclamatory mark delimiter</td>
</tr>
<tr>
<td></td>
<td>- OTHER_MINUS: Indicates the minus delimiter</td>
</tr>
<tr>
<td></td>
<td>- OTHER_OPENING_CURLY_BRACKET: Indicates the opening curly bracket delimiter</td>
</tr>
<tr>
<td></td>
<td>- OTHER_OPENING_PARENTHESIS: Indicates the opening parenthesis delimiter</td>
</tr>
<tr>
<td></td>
<td>- OTHER_OPENING_SQUARE_BRACKET: Indicates the opening square bracket delimiter</td>
</tr>
<tr>
<td></td>
<td>- OTHER_PIPE: Indicates the pipe delimiter</td>
</tr>
<tr>
<td></td>
<td>- OTHER_PLUS: Indicates the plus delimiter</td>
</tr>
<tr>
<td></td>
<td>- OTHER_QUESTION_MARK: Indicates the question mark delimiter</td>
</tr>
<tr>
<td></td>
<td>- OTHER_STAR: Indicates the star symbol delimiter</td>
</tr>
<tr>
<td></td>
<td>- OTHER_TILDE: Indicates the tilde symbol delimiter</td>
</tr>
<tr>
<td></td>
<td>- SEMI_COLON_DELIMITER: Indicates the semicolon delimiter</td>
</tr>
<tr>
<td>-df</td>
<td>The date format that's used in your source CSV file. The default value is ORA_ZCA_US_FORMAT. Possible values are:</td>
</tr>
<tr>
<td></td>
<td>- ORA_ZCA_EUROPE_FORMAT: EU - YYYY/MM/DD</td>
</tr>
<tr>
<td></td>
<td>- ORA_ZCA_ISO8601_FORMAT: ISO 8601 - YYYY-MM-DD</td>
</tr>
<tr>
<td></td>
<td>- ORA_ZCA_UK_CANADA_FORMAT: UK/Canada - DD/MM/YYYY</td>
</tr>
<tr>
<td>Command and Options (Preceded by Hyphen)</td>
<td>Description</td>
</tr>
<tr>
<td>----------------------------------------</td>
<td>-------------</td>
</tr>
<tr>
<td>-ds</td>
<td>The decimal separator is used in your source file. The default value is Period (.). Possible values are:</td>
</tr>
<tr>
<td></td>
<td>• , (Comma)</td>
</tr>
<tr>
<td></td>
<td>• . (Period)</td>
</tr>
<tr>
<td>-ecl</td>
<td>Enable or disable custom business logic for the import job. The default value is false. Possible values are:</td>
</tr>
<tr>
<td></td>
<td>• true</td>
</tr>
<tr>
<td></td>
<td>• false</td>
</tr>
<tr>
<td>-encoding</td>
<td>The source file encoding. Possible values are:</td>
</tr>
<tr>
<td></td>
<td>• ORA_ZCA_UTF8_ENCODING</td>
</tr>
<tr>
<td></td>
<td>• ORA_ZCA_UTF16_ENCODING</td>
</tr>
<tr>
<td></td>
<td>• ORA_ZCA_UTF16BE_ENCODING</td>
</tr>
<tr>
<td></td>
<td>• ORA_ZCA_UTF16LE_ENCODING</td>
</tr>
<tr>
<td></td>
<td>• UTF8</td>
</tr>
<tr>
<td>-export</td>
<td>Download the exported attachment files from the content management server to your local directory. For example,</td>
</tr>
<tr>
<td></td>
<td>java -jar oscdataloader.jar export -object Attachments -export-id 300100189790029 -target-url https://&lt;your_pod&gt; -output-path &quot;C:\MyAttachments&quot;</td>
</tr>
<tr>
<td></td>
<td>Make sure that the directory you provide as output path already exists with read and write permissions for the user performing the export.</td>
</tr>
<tr>
<td>getlogs</td>
<td>Get log files of an import activity.</td>
</tr>
<tr>
<td>-help</td>
<td>Display help text containing possible commands.</td>
</tr>
<tr>
<td>help</td>
<td>Show the usage message.</td>
</tr>
<tr>
<td>-high-volume</td>
<td>Activate high-volume import for supported objects. By default, this option is set to true for all the supported objects. To use low-volume import, set this option to false. For example,</td>
</tr>
<tr>
<td></td>
<td>&gt; java -jar oscdataloader.jar submit -high-volume false -input-file Account.csv -import-name &quot;Account Import&quot; -object Account</td>
</tr>
<tr>
<td>-import-activity (required)</td>
<td>The import activity identifier of the job. This is used to track the status of the import job.</td>
</tr>
<tr>
<td>-import -name</td>
<td>The name of the import job.</td>
</tr>
<tr>
<td>-input -file (required)</td>
<td>The name of source CSV file. Provide a file name within 40 characters.</td>
</tr>
<tr>
<td>Command and Options (Preceded by Hyphen)</td>
<td>Description</td>
</tr>
<tr>
<td>-----------------------------------------</td>
<td>-------------</td>
</tr>
<tr>
<td><code>-latest</code></td>
<td>Indicates that the import jobs should be sorted by the latest creation date, when used with the <code>listimports</code> command. If this parameter isn’t used, then the import jobs are listed sorted by the oldest creation date. For example,</td>
</tr>
<tr>
<td></td>
<td><code>&gt; java -jar oscdataloader.jar listimports -target-url https://mypod.oracle.com -username importuser -latest</code></td>
</tr>
<tr>
<td></td>
<td>lists the imports sorted by the latest creation date. This parameter can take the value true or false. A value of true indicates that the imports are sorted by the latest creation date. By default, this parameter has the value false.</td>
</tr>
<tr>
<td><code>--limit</code></td>
<td>The number of import jobs to be listed by the <code>listimports</code> command. It can have possible values ranging from 1 to 500. Default value is 25. For example,</td>
</tr>
<tr>
<td></td>
<td><code>&gt; java -jar oscdataloader.jar listimports -target-url https://mypod.oracle.com -username importuser --limit 100</code></td>
</tr>
<tr>
<td></td>
<td>lists the first 100 import jobs.</td>
</tr>
<tr>
<td><code>listimports</code></td>
<td>Get the list of import activities. You can get the list sorted by latest creation date by using the parameter <code>latest</code>.</td>
</tr>
<tr>
<td><code>listobjects</code></td>
<td>List the objects supported by External Data Loader Client.</td>
</tr>
<tr>
<td><code>--log-type</code> (required)</td>
<td>Specify the type of log file to generate. Possible values are Exception, Error, Diagnostic, and All.</td>
</tr>
<tr>
<td><code>--mapping-number</code> (required)</td>
<td>The mapping number.</td>
</tr>
<tr>
<td><code>--mode</code></td>
<td>The import mode which is to be used for the import job. The default mode is CREATE_RECORD. Possible values are:</td>
</tr>
<tr>
<td></td>
<td>• CREATE_ONLY: Create records</td>
</tr>
<tr>
<td></td>
<td>• CREATE_RECORD: Update and create records</td>
</tr>
<tr>
<td></td>
<td>• DELETE_RECORD: Delete records</td>
</tr>
<tr>
<td></td>
<td>• UPDATE_RECORD: Update records</td>
</tr>
<tr>
<td><code>--nemail</code></td>
<td>The email address to which the import job status would be sent.</td>
</tr>
<tr>
<td><code>--object</code> (required)</td>
<td>The object to import.</td>
</tr>
<tr>
<td><code>--offset</code></td>
<td>The import offset.</td>
</tr>
<tr>
<td><code>-s</code></td>
<td>The mode of scheduling the import job which determines whether the import job executes immediately or at a future date. The default value is ONE_TIME_IMMEDIATE. Possible values are:</td>
</tr>
<tr>
<td></td>
<td>• ONE_TIME_IMMEDIATE: Immediate</td>
</tr>
<tr>
<td></td>
<td>• ONE_TIME_SCHEDULE: Future</td>
</tr>
<tr>
<td><code>savepassword</code></td>
<td>Save credential in credential store wallet.</td>
</tr>
<tr>
<td>Command and Options (Preceded by Hyphen)</td>
<td>Description</td>
</tr>
<tr>
<td>----------------------------------------</td>
<td>-------------</td>
</tr>
<tr>
<td>split</td>
<td>Split the import data file into multiple smaller files. The Split Size parameter is used to configure the split size that's used by EDLC. You can use either a low-volume split size or a high-volume split size.</td>
</tr>
</tbody>
</table>

You can use the split records option to use low-volume split. Low-volume split has a default split size value of 50000 records. You can either set the default split size using the profile option ORA_ZCA_IMPORT_LOW_VOLUME_CHUNK_SIZE, or specify the split size using the split records command. Possible values are 10k, 20k, 30k, 40k, and 50k.

Example command:

```
> java -jar oscdataloader.jar submit -input-file Account.csv -import-name "Account Import" -object Account -mapping-number 123565 -split-records 30000
```

You can use the high volume split option to use high-volume split. High-volume split has a default split size value of 200000 records. You can either set the default split size using the profile option ORA_ZCA_IMPORT_HIGH_VOLUME_CHUNK_SIZE, or specify the split size using the split records command. Possible values are 100k, 200k, 300k, 400k, and 500k.

Example command:

```
> java -jar oscdataloader.jar submit -input-file Account.csv -import-name "Account Import" -object Account -mapping-number 123565 -high-volume-split-records 200000
```

Note:
You can use this parameter when the default values slow down the performance or if an optimum size is recommended for the data pattern being imported. This parameter is provided to reduce the number of records that need to split for each EDLC job.

- st | Scheduled future time stamp for an import activity job.

status | Retrieve the status of the specified import.

submit | Submit file import request in CX Sales and B2B Service.

-target-url (required) | The environment against which the command is run.

-tsfsf | The time stamp format used in your source file. The default value is ORA_ZCA_US_FORMAT. Possible values are:

- ORA_ZCA_CANADA_FORMAT: Canada - DD/MM/YYYY hh:mm:ss PM
- ORA_ZCA_EUROPE_FORMAT: EU - YYYY/MM/DD 24:mm:ss
- ORA_ZCA_ISO8601_FORMAT: ISO 8601 - YYYY-MM-DDThh:mm:ss.sss+/hh:mm
- ORA_ZCA_UK_FORMAT: UK - DD/MM/YYYY 24:mm:ss

-username (required) | Specify the user name of the user running the command.
<table>
<thead>
<tr>
<th>Command and Options (Preceded by Hyphen)</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>-wallet</td>
<td>The Credential Store that holds one set of user credentials (user name and password pair).</td>
</tr>
</tbody>
</table>
10 Overview of Export Management

About Export Management

You can use Export Management to move data out of Oracle Applications Cloud in the form of CSV files.

To export data, you start by creating an export activity. As part of the export activity, you select a parent object and its relevant child objects. You also must define filters on these objects to specify the records you want to export.

Scenarios for Export

You may want to export data in the following scenarios:

- You might want to move data out of Oracle Applications Cloud into another application. To perform this activity you have to export the data into a ZIP file and import the exported data into the target application.
- You might want to format the data as per your requirements.
- You may want to identify the unique identifiers of an object such as Party ID or Party Number. You can use this information to update an object record.

You can schedule an export either immediately or at a future date. If you schedule it for a future date, then provide the start date and time while defining the export activity.

**Note:** Currently recurring export isn't supported. You can however use the Export REST resource to schedule recurring export activities through REST API. For more information see REST API for CX Sales and B2B Service.

Using Export Filters

You can define the conditions for the records to export in the export filter. The exported data sets contain only those records that match the specified filter criteria on the parent/child object. It is recommended that you use multiple filters to reduce the number of records to export.

You can create a filter by navigating to Tools > Export Management > Export Objects and clicking on the Display Name link for the export object. On the Manage Filters page, click the Create Filter button to create a filter. On the Script Edit page, enter the filter name, filter parameters, and the order by clause if required. You can reuse an existing filter by selecting a value from the Existing Filters drop-down list. Once you're done with your changes, click Validate Script and then click Save and Close to save your new filter. You can also create a filter while creating an export activity, on the Map Fields page.

You can delete a filter on the Manage Filters page, by clicking the delete icon for your filter under the Delete Filter column. Note that you can delete only the filters created by you and those that aren't used in an active export job.

Split Export Data

There are no limits to file size for exporting data. However, you can split the exported data set based on a split size. You can enable split from the UI by checking the Enable Split check box in the set up page and select the split size. The default is 100k. You can specify the split size in multiples of 100k records, ranging from 100k to 1000k. Each CSV file can
contain a maximum of 50k records. Hence, the exported data will be split into two CSV files after 50k records. The CSV files will then be zipped together and exported.

For example, if an export job fetches 300k records and split is enabled with a split size of 200k, then 2 export ZIP files will be generated. The first one will contain a total of 200k records which will be divided into 4 CSV files each with 50k records. The second ZIP file will contain a total of 100k records which will be divided into 2 CSV files each with 50k records.

Related Topics
- Export Data
- How You Monitor Export Activity

How You Manage Export Objects

Export objects correlate with tables in Oracle Applications Cloud. Understand export objects and their attributes to manage the data that you want to export.

Supported Objects
You can export these objects and their child objects using Export Management:

- Access Groups
- Account
- Action
- Action Plan
- Activity
- Asset
- Assignment Rule Candidate
- Assignment Rule Condition
- Assignment Rule
- Assignment Rule Set
- Business Plan
- Campaign
- Case
- Competitor
- Contact
- Contract
- Contests
- Deal Registration
- Duplicate Resolution Request
- Geographies*
Chapter 10

Overview of Export Management

• Goals
• Household
• HRHelpDeskRequest
• Hub Source System Reference
• Inbound Message
• Incentive Rule Assignments
• Incentive Rule Attribute Values
• Incentive Rules
• Incentive Transaction
• Interaction
• KPI
• MDF Budget
• MDF Claim
• MDF Request
• Nonduplicate
• Note
• Objective
• Opportunity
• Organization
• Partner
• Partner Programs
• Price Book Header
• Product
• Product Group
• Program Enrollments
• Promotion
• Queue
• Relationship
• Resolution Link
• Resolution Request
• Resource
• Resource Capacity
• Sales Lead
• Sales Orders
• Sales Territory
• Sales Territory Quota
• Self-Service Role
• Service Request
• Standard Lookups
Overview of Export Management

- Standard Text
- Standard Text Folder
- Standard Text User Variable
- Subscription
- Template
- Territory Geographies
- Transaction
- Trees

Note: Legal Note: By exporting the Geographies data from the Oracle environment to Your environment, You agree that (a) oracle is granting You only a restricted right to download the exported Geographies data specifically for Your use with the Oracle Fusion services, (b) the Geographies data may not be used, transferred, or uploaded for any other purposes; and (c) except for the restricted right granted in (a), all provisions of the Oracle Cloud Services Agreement (CSA) or Schedule C, as applicable to You, remain in full force and effect, including specifically section 3.4 thereof.

Export Object Details

Click Tools > Export Management > Export Objects. To see the details of an export object, select it on the Export Object Details page. Here are the details that you see about each exportable object:

<table>
<thead>
<tr>
<th>Column</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Display Name</td>
<td>The object as it's called in the User Interface.</td>
</tr>
<tr>
<td>Language Independent Code</td>
<td>The internal name of the object.</td>
</tr>
<tr>
<td>Parent Object</td>
<td>The parent object of the selected object. If there are multiple parents for an object, they’re shown separated by comma.</td>
</tr>
<tr>
<td>View Hierarchy</td>
<td>Clicking on the View Hierarchy icon shows the hierarchy between the parent and child objects in a graphical format.</td>
</tr>
<tr>
<td>User Key</td>
<td>The attribute or the group of attributes that's used to uniquely identify a record.</td>
</tr>
<tr>
<td>Required Attributes</td>
<td>The attribute or the group of attributes for which values are required to create a record. These can't be NULL when updating a record.</td>
</tr>
</tbody>
</table>

Target Attributes

Here are the details that you see for each target attribute:

<table>
<thead>
<tr>
<th>Column</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Display Name</td>
<td>Name of the target attribute in the User Interface.</td>
</tr>
</tbody>
</table>
### Export Inactive and Merged Data

You can now export inactive and merged accounts, contacts, households, organizations, and persons using export management. You don’t need to rely on Data Model Queries to fetch the deleted or merged records anymore.

**Note:** To export inactive records you need to explicitly add the condition to the criteria, or else only the active records will be exported. For example, I for Inactive and M for merged. All associated Child records (active or inactive) will be exported irrespective of their status, if no criteria is added.

### Export Queues

This topic describes the different infotiles displayed on the Manage Exports page of the Export Queue tab.

#### Export Queue

The following infotiles are displayed on the **Manage Exports** page:

- **All Exports**: This infotile displays the count of active, completed, and unsuccessful exports submitted by all users. Click to see the exports created by all the users and in all possible statuses.
- **Active Exports**: This infotile displays the count of exports submitted by all users that are either in progress or in queued status. Click to see the active exports created by all the users.
- **My Completed Exports**: This infotile displays the count of exports submitted by the current user that are either successful or failed with warnings or errors. Click to see the completed exports created by the current user.
- **Unsuccessful Exports**: This infotile displays the count of unsuccessful exports submitted by all users. Click to see the unsuccessful exports created by all users.
Note: The export activity records appear in the queue for thirty days, after which they’re removed. The exported ZIP files and diagnostic files are removed from the server on the 7th day of the export.

Export Details
You can view more details about the exports on clicking the infotiles. The following details about the export are displayed:

<table>
<thead>
<tr>
<th>Column</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>The name of the export job. Click to go to the Export Status page.</td>
</tr>
<tr>
<td>Object</td>
<td>The object exported.</td>
</tr>
<tr>
<td>Status</td>
<td>The status of the export job. For more information about the statuses, see the topic How You Monitor Export Activity in the related topics section.</td>
</tr>
<tr>
<td>Start Time</td>
<td>The start date and time of the export.</td>
</tr>
<tr>
<td>End Time</td>
<td>The end date and time of the export.</td>
</tr>
<tr>
<td>Submitted By</td>
<td>The user who submitted the export.</td>
</tr>
<tr>
<td>Exported data file</td>
<td>The link to download the exported data file in ZIP format.</td>
</tr>
</tbody>
</table>

You can filter the export using any of the columns in the preceding table. You must select the filter value from the Search drop-down list and enter the criteria in the adjacent text box.

Related Topics
Export Your Data

Export Data

This topic shows you how to export data using the Export Management option from the Tools work area.

To export data:

1. Click **Tools > Export Management**.
2. On the Manage Exports page, click the Create Export Activity button.
3. On the Enter Export Options page, enter values for each of the following fields:

<table>
<thead>
<tr>
<th>Field</th>
<th>Description of the value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>The name of the export activity.</td>
</tr>
<tr>
<td>Object</td>
<td>The object to export. You must select the parent or child object from the drop-down list. If you can't find an object in the drop-down list, then click the Search link. In the Search and Select dialog box, enter the object name in the Object text box and click the Search button. Select your object from the result list and click OK. You can also use the advanced search option by clicking the Advanced button. Here you can search based on various filter criteria such as object name, attachment supported, creation date, and so on.</td>
</tr>
<tr>
<td>Description</td>
<td>The optional description of the export activity.</td>
</tr>
<tr>
<td>File Name</td>
<td>The name of the export file to generate in ZIP format. This field is populated based on the object and date time stamp.</td>
</tr>
</tbody>
</table>

Note:

If the object you're exporting isn't listed then verify if you have the roles and privileges required to export the object. For information on the roles, see the topic Roles Required for Import and Export Management referenced in the Related Topics section.

The object must not include any field with display name length greater than 120 characters. Your export job may fail if it includes a field with display name length greater than 120 characters.
Field | Description of the value
--- | ---
Export Attachments | Select to export the attachments related to the object. This option is enabled only if the selected object supports attachments.

4. Optionally to set additional export configurations, click the Advanced Options section. Here you can configure settings in the Output File, Export Options, or Create Schedule sections.

- Following are the options in the Output File and Export Options regions:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
<th>Default Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Delimiter</td>
<td>If your file doesn’t use a comma to separate values, then select the correct delimiter in the <strong>Delimiter</strong> drop-down list. Possible values are:</td>
<td>Comma</td>
</tr>
<tr>
<td></td>
<td>- Caret Symbol</td>
<td></td>
</tr>
<tr>
<td></td>
<td>- Closing Curly Bracket</td>
<td></td>
</tr>
<tr>
<td></td>
<td>- Closing Parenthesis</td>
<td></td>
</tr>
<tr>
<td></td>
<td>- Closing Square Bracket</td>
<td></td>
</tr>
<tr>
<td></td>
<td>- Colon</td>
<td></td>
</tr>
<tr>
<td></td>
<td>- Comma</td>
<td></td>
</tr>
<tr>
<td></td>
<td>- Exclamatory Mark</td>
<td></td>
</tr>
<tr>
<td></td>
<td>- Minus</td>
<td></td>
</tr>
<tr>
<td></td>
<td>- Opening Curly Bracket</td>
<td></td>
</tr>
<tr>
<td></td>
<td>- Opening Parenthesis</td>
<td></td>
</tr>
<tr>
<td></td>
<td>- Opening Square Bracket</td>
<td></td>
</tr>
<tr>
<td></td>
<td>- Pipe Symbol</td>
<td></td>
</tr>
<tr>
<td></td>
<td>- Plus</td>
<td></td>
</tr>
<tr>
<td></td>
<td>- Question Mark</td>
<td></td>
</tr>
<tr>
<td></td>
<td>- Semi-Colon</td>
<td></td>
</tr>
<tr>
<td></td>
<td>- Star Symbol</td>
<td></td>
</tr>
<tr>
<td></td>
<td>- Tilde Symbol</td>
<td></td>
</tr>
<tr>
<td>Escape Special Characters</td>
<td>If selected, then RFC4180 format is used, and quotes are escaped with another set of quotes.</td>
<td>Deselected</td>
</tr>
<tr>
<td>Decimal Separator</td>
<td>The decimal separator used in your export file. Possible values are Comma and Period.</td>
<td>Period</td>
</tr>
<tr>
<td>Date Format</td>
<td>The format of the date fields in your file. Possible values are:</td>
<td>US - MM/DD/YYYY</td>
</tr>
<tr>
<td>Option</td>
<td>Description</td>
<td>Default Value</td>
</tr>
<tr>
<td>------------------------</td>
<td>-----------------------------------------------------------------------------</td>
<td>-------------------------------------------------------------------------------</td>
</tr>
<tr>
<td><strong>Time Stamp Format</strong></td>
<td>The format of time fields in your file. Possible values are:</td>
<td>US - MM/DD/YYYY hh:mm:ss PM</td>
</tr>
<tr>
<td></td>
<td>EU - YYYY/MM/DD</td>
<td></td>
</tr>
<tr>
<td></td>
<td>ISO 8601 - YYYY-MM-DD</td>
<td></td>
</tr>
<tr>
<td></td>
<td>UK/Canada - DD/MM/YYYY</td>
<td></td>
</tr>
<tr>
<td></td>
<td>US - MM/DD/YYYY</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Canada - DD/MM/YYYY hh:mm:ss PM</td>
<td></td>
</tr>
<tr>
<td></td>
<td>EU - YYYY/MM/DD 24:mm:ss</td>
<td></td>
</tr>
<tr>
<td></td>
<td>ISO 8601 - YYYY-MM-DDT hh:mm:ss sss+/-hh:mm</td>
<td></td>
</tr>
<tr>
<td></td>
<td>UK - DD/MM/YYYY 24:mm:ss</td>
<td></td>
</tr>
<tr>
<td></td>
<td>US - MM/DD/YYYY hh:mm:ss PM</td>
<td></td>
</tr>
<tr>
<td><strong>File Encoding</strong></td>
<td>The format in which the characters within your source file are encoded.</td>
<td>Unicode - UTF - 8</td>
</tr>
<tr>
<td></td>
<td>Possible values are:</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Chinese Simplified - GB, CP936</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Chinese Traditional - CP950</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Eastern European - Win, CP1250</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Greek - MS Windows, CP1253</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Japanese - Shift-JIS, CP932</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Unicode - UTF - 8</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Unicode - UTF - 16</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Unicode - UTF - 16BE, Mac, Unix</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Unicode - UTF - 16LE, MS Windows</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Western European - Win, CP1252</td>
<td></td>
</tr>
<tr>
<td><strong>End of Line</strong></td>
<td>The character used to indicate end of line in the export file. Possible</td>
<td>Line Feed</td>
</tr>
<tr>
<td></td>
<td>values are:</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Carriage Return</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Carriage Return and Line Feed</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Line Feed</td>
<td></td>
</tr>
<tr>
<td><strong>Quote Character</strong></td>
<td>The character used to indicate a quote. This field is read-only.</td>
<td>N/A</td>
</tr>
<tr>
<td><strong>Language Independent Header</strong></td>
<td>Select to export column headers. If you're modifying the exported data manually, then exporting column headers help in automatic mapping during the reimport process.</td>
<td>N/A</td>
</tr>
<tr>
<td>Option</td>
<td>Description</td>
<td>Default Value</td>
</tr>
<tr>
<td>-------------------------</td>
<td>-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
<td>---------------</td>
</tr>
<tr>
<td>Notification Email</td>
<td>The email to send export-processing notifications. The user submitting the export receives an email notification automatically. You use this field to specify any additional recipients. If you want to have more than one email recipient, separate the email addresses with a comma or semicolon. You can also specify a mailing list address so that a large number of recipients can be notified. If you don't want to receive the notification, then set the profile option ORA_ZCA_IMPEXP_ENABLE_EMAIL_NOTIFY to 'N' at user level.</td>
<td>N/A</td>
</tr>
<tr>
<td>Enable Split</td>
<td>Select to split the export data set based on a specified record count. On selecting this check box, you can see the Split Size drop-down list, with a default value of 100k. You can specify the split size in multiples of 100k records, ranging from 100k to 1000k. The exported data is split into multiple CSV files, and each file has a maximum of 50K records. You can further split the exported data into multiple ZIP files, based on the specified split size. For example, if your export job retrieves 300k records and split is enabled with a split size of 200k, then 2 export ZIP files are generated. The first ZIP file contains 200k records which is divided into 4 CSV files each with 50k records. The second ZIP file contains 100k records which is then divided into 2 CSV files each with 50k records.</td>
<td>N/A</td>
</tr>
</tbody>
</table>

- In the Create Schedule region, you can schedule the export to run either immediately or at a future date. If you select a future date, then provide the date and time to start the export.
5. Click **Next**. On the **Map Fields** page you can see the exportable object, its child objects, and the associated attributes. The **Export Mapping** drop-down list shows the maps that were used in earlier export jobs. You can select an existing mapping from the drop-down list and click **Apply**.

You can save your export maps for future use by clicking on the pencil icon (Save As) in the Create Export Activity page. You can also mark your maps as private by checking the **Private Map** checkbox. Private maps can only be viewed and reused by the user who created and saved the map.

**Note:** Your maps will only be saved once the job is completed.

To select and apply your saved maps, check the **My Maps** checkbox, select the required map from the **Export Mapping** drop down and click **Apply** in the Create Export Activity page.

6. You can select the child objects to export by selecting the **Enabled** check box. Selecting the **Enabled** check box for a child object displays the associated attributes in the **Available Fields** section. You can select the attributes to export by double-clicking the attribute in the Available Fields list. Alternatively, you can move the attribute from Available Fields list to the **Selected Fields** list. If you select any formula fields for export, it might impact your export performance.

7. You must provide a filter criterion for at least the top-level object. To filter the records to export using conditions, click the **Filter Name** icon. On the **Filter Name** dialog box, you can create the filter for the export attributes using the operators AND, OR, >, <, =, and !=. On the **Fields** tab select the attribute and click the **Insert** button. In the Script Edit window, provide the filter conditions for the selected attribute. After creating the filter criteria script, click **Validate Script**. Click **Save and Close** to save the filter.

**Note:** You must use GeographyCode='TM' filter to export the Zone Hierarchies. To export both Zone Hierarchy information and Geography Country Information, you need to use filter GeographyCode='TM' Or CountryCode='DE'.

8. Click **Next**. On the **Review and Submit** page, review the export activity configuration. If you want to change any configuration, then click the **Back** button. Submit to activate the export activity. After the export activity completes, clicking the **My Completed Exports** infotile shows your export status. Click the ZIP file link in the **Exported Data File** column to download the exported file.

You can cancel the export by clicking the Cancel icon in the Manage Exports page when the job status is Paused, Queued for Export, Preparing data to Export, or Exporting Data.

**Note:** The cancel job option is available for the logged in user and the hierarchy user only when the profile option ORA_ZCA_IMPEXP_RESTRICT_USERACCESS is enabled.

**Note:** CSV String Escape: By default, the escape character is a " (double quote) for CSV-formatted files. If a value contains a comma, a newline character, or a double quote then the string must be enclosed in double quotes. For example: "Newline char in this field \n". A double quote must be escaped with another double quote. For example: "The double quote character ‘"’ is offensive.".
Note: By default, you can't view the Personally Identifiable Information (PII) such as mobile numbers in the exported data. To view this information, follow these steps:

1. Navigate to Tools > Security Console.
2. Search for the role ORA_MOT_QUOTA_EXPORT_MANAGEMENT_DUTY.
3. Edit role and click the Data Security Policies link.
4. Click the Create Data Security Policy button, and add a new data security policy on the database resource Trading Community Contact Point with the following details.
   - Policy Name: Custom Grant on Person Contact and Mobile Phone Data (you can provide any name)
   - Database Resource: HZ_CONTACT_POINTS
   - Data Set: All Values
   - Actions: View Trading Community Person Contact, View Trading Community Mobile Phone Number
5. Click OK to save and navigate to Summary step to review and save changes.

Related Topics
- How You Monitor Export Activity
- Export Queues
- Roles Required for Import and Export Management

How You Monitor Export Activity

This topic explains how to monitor export activities and view their statuses.

View the Export Status

On the Manage Exports page, click the export activity name link to see additional information about the export activity. The Export Status page contains the following sections:

- Status Bar
- Details
- Export Attachments

The Export Status Bar

The status bar shows the progress of the export activity in a graphical format. It shows the following stages during the export process:

1. Queued for Export: The export request is queued for processing, and is waiting to begin execution.
2. Preparing data for Export: The data are loaded in the temporary staging table for further processing.
3. Exporting data: The data from the target objects are loaded into the export files (CSV).
4. Completing export activity: The export data have been loaded in the source files, and cleanup tasks, such as the generation of log files, are in progress.
5. Completed with errors: The export activity has completed with errors.
6. Completed with warnings: The export activity has completed with warnings.
7. Unsuccessful: The export activity was unsuccessful.

Activity and Record Details

The **Activity Details** section shows the name of the export activity, export job identifier, object exported, and the name of user who submitted the export. The section on date and time displays the start and end times, and the time taken to complete the export activity.

The **Record Details** section displays the number of records estimated, number of records exported, and the number of records with errors.

The object must not include any field with display name length greater than 120 characters. Your export job may fail if it includes a field with display name length greater than 120 characters.

Export Attachments

You can generate the diagnostics and log files from the **Action** menu. The **Export Attachments** section displays the list of files associated with this export activity in tabular format. The **Actions** column in this section lets you either download the file or view more details. These files include the diagnostics and log files generated.

**Note:** The export data is stored on the UCM server for some time before it’s purged. The duration after which export data should be purged is set in the profile option ZCA_EXPORT_UCM_PURGE_DURATION. The default value is 30.

How You Monitor Export Activities Using REST APIs

This topic explains how to receive completion notification through REST resource and also avoid the need to constantly keep checking the export status.

To receive export completion notification through REST service, you must define the REST service endpoint in Application Composer. You can configure and register your REST endpoint to receive notifications whenever your export job completes.

Register an External REST Endpoint in Application Composer

To register an endpoint for notification:

1. Create and enter into a sandbox by navigating to **Configuration > Sandboxes > Create Sandbox**.
2. Navigate to **Configuration > Application Composer > Web Services**. Note that this option is available only when you're inside the sandbox.
3. You can edit the existing endpoints, or create a new endpoint such as **ExternalEndPoint1**, by clicking the Create icon.
4. Enter the name of the endpoint and the URL, and select the authentication scheme. For example, your URL can be in the format https://servername/ic/api/integration/v1/connections/cbveTest.
5. Select and configure the POST method by clicking the check box for POST. Currently only POST method is supported for the Export Notification feature.
6. Select and provide the code samples for the request and response payloads. Following is the sample for request and response payloads:

```json
{
    "items": [],
    "count": 0,
    "hasMore": false,
    "limit": 25,
    "offset": 0,
    "link": [
        {
            "rel": "self",
            "href": "https://servername/ic/api/integration/v1/connections/cbveTest",
            "name": "ExternalEndPoint1",
            "kind": "collection"
        }
    ],
    "name": "ExternalEndPoint1",
    "kind": "collection"
}
```

7. Click **Save and Close**.

8. After making the changes, publish the sandbox to commit your changes.

**Validate the Endpoint**

You can validate the REST endpoint to ensure that your REST web service configuration in Web Services in Application Composer is correct and the export process can call the endpoint successfully. To validate your REST endpoint and set an endpoint as default:

1. Navigate to **Tools > Export Management > Export Configuration > REST Notification**.
2. Here, select REST Notification as the notification type, and select the endpoint you registered from the Notification Endpoint drop-down list. In our example, select **ExternalEndPoint1**.
3. To make this connection as the default one while creating export jobs, select the **Set as default** check box.
4. To validate, click the Payload Details section, and click the Validate REST Endpoint button. If your endpoint is valid, then you see one of the following response statuses in the Response text box:
   - 200
   - 201
   - 202
   - 204

Any other response status indicates that the endpoint is invalid.

**Create the Export Activity and Monitor the Status**

1. Navigate to **Tools > Export Management > Create Export Activity**.
2. Create the export activity, enter the name, and select the object to export.
3. Click the Advanced Options section and select the notification endpoint **ExternalEndPoint1** from the Notification Endpoint drop-down list. If you don't want to receive the notification, then select a blank value in the drop-down list.
4. Click **Next** and select the attributes to export on the Map Fields page. Create a filter for at least the top-level object, and click Next. For more information on creating an export activity, see the topic Export Data.
5. Review your export configurations and submit the export job. Once you submit the export, you can monitor the status by accessing the configured endpoint.
6. Alternatively, you can verify whether the notification is submitted by downloading the log files. The last entry in the file indicates the status of notification.
Export Notification in REST

You can use the RestNotification attribute to specify your notification endpoint while creating your export activity using REST. For example, you can use the following sample payload to create your export activity:

```json
{
    "Name": "Account_Export",
    "ExportObject": "Account",
    "ExportFilterCriteria": "OrganizationName IS NOT NULL",
    "ExportFileName": "Account.zip",
    "Activate": "YES",
    "RestNotification": "ExternalEndPoint1"
}
```

The following table describes the behavior when you don't provide the REST notification endpoint.

<table>
<thead>
<tr>
<th>REST Notification Value</th>
<th>Endpoint Used for Export Job</th>
<th>REST Notification Behavior</th>
</tr>
</thead>
<tbody>
<tr>
<td>null</td>
<td>Default endpoint is selected</td>
<td>REST notification is sent to the default REST endpoint.</td>
</tr>
<tr>
<td>REST notification not passed</td>
<td>Default endpoint is selected</td>
<td>REST notification is sent to the default REST endpoint.</td>
</tr>
<tr>
<td>***</td>
<td>No REST endpoint is selected</td>
<td>No REST notification is sent.</td>
</tr>
</tbody>
</table>

**Related Topics**
- Export Data

Export Attachments

This topic explains how to export and download the object attachments to your local directory. You can export the attachments in two steps:

1. Export the object records and the attachment information based on the selected search criteria of the object.
2. Download the attachment files from the content management server using the External Data Loader Client tool.

Export the Object Records and the Attachment Information

To export the object records and the attachment information:

1. Click **Tools > Export Management**.
2. On the Manage Exports page, click the Create Export Activity button.
3. On the Enter Export Options page, enter the export activity information such as export name, export object, and the file name. For more information on exporting data, see the topic Export Data.
4. Select the Export attachment check box to enable exporting the object attachments. You can optionally enter the advanced configuration options. Click Next.
5. On the Map Fields page, you can select the attributes to export by dragging them from the Available Fields section to the Selected Fields section. The Export Mapping drop-down list shows the maps used in earlier
export jobs. You can select an existing mapping from the drop-down list and click **Apply**. You can select the **Enabled** check box to export the child object attributes.

6. You must provide a filter criterion for at least the top-level object. To filter the records to export using conditions, click the **Filter Name** icon and enter the filter criteria for your object records. Click **Next**. On the **Review and Submit** page, review the export activity configuration and click **Submit**.

7. After the export activity completes, clicking the **My Completed Exports** infotile shows your export status. Click the ZIP file link in the **Exported Data File** column to download the exported file.

**Download the Attachment Files**

The ZIP file you downloaded in the previous step contains the following files:

- The attachment information CSV file - this file contains information about the attachment records such as content ID, REST resource URL, attachment file name, and so on.
- Attachment download instructions file - this HTML file contains the export details, and the sample EDLC command to download the attachments.

You can use the export command of EDLC to download the attachment files from the content management server to your directory. For example, use the following command to download your attachments exported from the previous step:

```
java -jar oscdataloader.jar export -object Attachments -export-id {export-id} -username {username} -target-url {environment-url} -output-path {output-directory-path}
```

Following are the parameters used in the command:

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>-objects</td>
<td>Indicates the object type exported. Currently this parameter supports only the value Attachments.</td>
</tr>
<tr>
<td>-export-id</td>
<td>Job ID of the export job.</td>
</tr>
<tr>
<td>-username</td>
<td>User name of the user submitting the export command. This must be the same user who submitted the export activity.</td>
</tr>
<tr>
<td>-target-url</td>
<td>URL of the environment.</td>
</tr>
<tr>
<td>-output-path</td>
<td>Directory path of the folder where the attachment files and reports are downloaded. The reports folder contains details about the attachment files exported, such as their status and error details if any. This should be an existing directory with read and write permissions for the user performing the export.</td>
</tr>
</tbody>
</table>

You can view the details of all available parameters and their descriptions using the command `export -help`.

**Related Topics**

- Export Data
- Overview of External Data Loader Client
- Command-Line Parameters
12 Round-Trip Export-Import

Round-Trip Feature

This topic gets you started on the round-trip feature of Import and Export Management.

It explains how to

- Export the data from one instance of CX Sales and B2B Service
- Makes any changes in the exported CSV files as required
- Reimport the updated CSV files either into the same instance or another instance

You can do this task without manually mapping the source file and the object attributes.

Export Data

You can use Export Management to export the data fields of an object. You can select the fields that you want to export. If you're importing the data into another instance of CX Sales and B2B Service, then select the Language Independent Header check box in the Advanced Options section of the Create Export page. This generates the header row in the exported CSV file that enables the round-trip feature. Don't modify the header row values in the CSV file.

You can export a single object and its child objects with attributes for each export activity. If the exported ZIP file contains the parent and child record files, then import the parent CSV file followed by the child CSV file.

You can either schedule the export process at a future date or run it immediately. The export activity generates a ZIP file that you can download.

Import Data

You can import the exported data into either the same instance or another instance of CX Sales and B2B Service. You must use the CSV file extracted from the downloaded ZIP file. Don't edit the file, or add or delete any rows in the file. Doing this disables the round-trip feature.

You import the data using the Import Management feature in the User Interface. During the import, the automatic mapping feature automatically maps the columns in your source file to the application attributes.

**Note:** While doing round trip import, you need to remove the attributes FileNameSystaskId and FileRecordNum from the CSV.

**Related Topics**

- Export Data
- Import Data
Export and Import Account Data between CX Sales and B2B Service Instances Using the Round-Trip Feature

This example shows how to export the Account object from one instance of CX Sales and B2B Service and import the exported data into another instance of CX Sales and B2B Service using the round-trip feature.

You can do this without manually mapping the source file and the application attributes.

Export Data from CX Sales and B2B Service Using Export Management

You can export Account object records from CX Sales and B2B Service using Export Management as follows:

1. Create an export activity for the Account object as explained in the topic Export Data.
2. Click the Advanced Options section. Select the Enable Round Trip check box. This enables the round-trip support for your export activity. This option generates the header row in the exported CSV file and is responsible for automatic mapping during the import. So don't modify any of the header row values. Review and submit the export activity.
3. On the Manage Exports page, you can see the status of your export. Once the export activity completes, click the My Completed Exports infotile to see the status of your export.
4. Click the link under the Exported Data File column to download your exported ZIP file. Save the ZIP file, and extract the CSV file.

Import Data from CX Sales and B2B Service Using Import Management

You can import data into CX Sales and B2B Service instance using the following steps:

1. Create an import activity for the Account object as explained in the topic Import Data. Browse and select the CSV file that you had exported in the last section.
2. Click Next to get the Map Fields page. On the Map Fields page, the round-trip feature automatically maps the source file attributes for you.
3. Click Next to review the import configurations and Submit.
4. On the Manage Imports page, you can see the status of your import. Once the import activity completes click the My Completed Imports infotile to see the status of your import.

Related Topics
- Round-Trip Feature
- Export Data
- Import Data
Best Practices and Troubleshooting

Best Practices for High Volume Data Import

Here are some best practices for high volume data import.

At some time, you might need to load large volumes of data into your CX Sales and B2B Service instance. For example, during initial roll-out, expanding use of CX Sales and B2B Service to other users or divisions, or expanding use of CX Sales and B2B Service to include other object types (for example, adding support for Service objects).

When loading large volumes of data to CX Sales and B2B Service, one of the key considerations is the time taken to import data. Reducing the amount of time required to import a large volume of data is crucial, if you have a limited period of time to run the data imports (for example, during a weekend migration). Oracle recommends certain best practices that you can use to improve the performance of the data import.

Actual throughput varies for users based on a number of factors including the volume of data contained in each record, the number of relationships being created during data import, and the number of records in your source file.

Before executing the data import in a production environment, Oracle recommends that you perform these functional validation and performance optimization procedures in your test environment:

- Data Cleansing
- Validate Functional Import
- Optimization Process

Performing these exercises in your test environment ensures that these exercises don't impact existing operations or the data in your production environment.

Data Cleansing

Before proceeding with high volume imports, you need to clean the data being imported thoroughly. Ensuring that your data is in the correct format reduces the number of errors that are encountered during data import. This benefits your overall throughput in two ways:

- Processing time isn't wasted on attempting to import records that can't be imported.
- You don't have to review error logs, fix issues, and reimport data. It costs less to clean your data before attempting a data import than it does to fix issues that arise during data import.

When cleaning the data, note the following:

- Field Length - ensure that the data doesn't exceed the maximum field length in OSC
- Data Type - ensure that the data is of the correct type for the field to which it's being imported in OSC
- Required - ensure that a value is provided for all mandatory fields
- Conditionally Required - in some cases, a value is required based on the value provided for another field (for example, for Opportunity a Close Date is required if the Status of the Opportunity is set to Closed)
- Foreign Keys - provide a valid value for foreign keys to create relationships between records. The foreign keys can vary for every object.
By ensuring that your data is clean, you can avoid many issues associated with importing your data from your legacy application into CX Sales and B2B Service.

**Validate Functional Import**

To verify that you have successfully cleaned your data, Oracle recommends that you validate your import in your test environment with a small set of data. Follow these guidelines to validate the functional import:

- Before you import large volumes of data, ensure that your import completes successfully and that the resulting data matches your expectations. This includes ensuring that the data is imported to the correct object, fields have been mapped correctly, and relationships are imported properly.

- Import a small number of records including values for each attribute. Oracle recommends that you use the smallest set of input data possible that can still save the variations present in your full data set.

- Identify any data issues that are reported in the import log files. Fix any specific issues reported for rows with errors. If a row doesn't have an error reported, then don't reimport that row. After you resolve all the issues and successfully import your subset of data, apply any changes to your larger data set (for example, if you determine that your time stamp format is incorrect, fix this for all records in the input data file for your full data set).

**Optimization Process**

Importing high volume of data is a project and should be included in the project plan for your implementation. You need to allocate time for the actual import of data and for the design and optimization of the import process for your data set.

When optimizing the data import, you identify the number of records to be included in your input data file as well as the number of concurrent import activities that can be activated. You trigger concurrent import activities by running more than multiple data import operations simultaneously. The number of concurrent import activities is the number of data imports that are running and haven't yet completed. Running import activities serially or running too many import activities concurrently can lower your throughput. Finding the right values for these two parameters is a key aspect of designing your import process. There's no right answer for every situation. Every data set is different; you need to repeat this process for any new data import operations that you plan to perform.

**Note:** Don't import more than 100,000 records in a single import operation or perform more than five concurrent import activities.

Oracle recommends that you adhere to this process when planning high volume data import:

- Establish baseline performance

- Scale up import volume

- Optimizing Concurrent Import Activities

Each of these steps is explained in greater detail.

**Establish Baseline Performance**

Oracle recommends that after you have cleaned your data and validated that your import is functionally correct, you should begin the process of scaling up your import volumes. The first step in this process is to establish a performance baseline. This involves performing a set of serial imports using a high volume of records.
Oracle recommends that you begin by importing a small number of records (a few hundred to a few thousand) in a single import activity. For example, you may import 10,000 records using four import activities of 2,500 records each. After these data import activities have completed, you should note the time required to complete the import of records and calculate the overall throughput (number of records imported per second).

**Note:** You may also want to track the time between data import operations.

### Scale Up Import Volume

After you have established a baseline, you can increase the number of records in your input file and begin to run multiple imports concurrently. Scale the volumes in a controlled manner and note your throughput at every step.

### Optimize Concurrent Import Activities

You can run multiple import activities simultaneously. This can improve your overall throughput versus serially running the same imports. The optimal number of concurrent import activities can vary across objects and use cases; you must perform testing prior to beginning your production data load to identify the most efficient data import plan.

You can run multiple data import activities concurrently by submitting a new import activity while the first activity is still being processed. CX Sales and B2B Service processes both import activities without waiting for the first activity to complete before starting the second activity. You can continue to run multiple data import activities concurrently for additional data import activities.

For example, you first run a test to measure the throughput when importing 200,000 records using four serial activities of 50,000 records each. You may then run a test to import a total of 600,000 records as shown in this table:

<table>
<thead>
<tr>
<th>Test Number</th>
<th>Total Number of Records</th>
<th>Number of Records per Activity</th>
<th>Number of Activities</th>
<th>Concurrency</th>
<th>Average Throughput</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>200,000</td>
<td>50,000</td>
<td>4</td>
<td>Serial</td>
<td></td>
</tr>
<tr>
<td>2.1</td>
<td>100,000</td>
<td>50,000</td>
<td>2</td>
<td>Concurrent</td>
<td></td>
</tr>
<tr>
<td>2.2</td>
<td>200,000</td>
<td>50,000</td>
<td>4</td>
<td>Concurrent</td>
<td></td>
</tr>
<tr>
<td>2.3</td>
<td>300,000</td>
<td>50,000</td>
<td>6</td>
<td>Concurrent</td>
<td></td>
</tr>
</tbody>
</table>

At every step, you should note the average throughput. If you reach a point where throughput is decreasing, then you may have exceeded your optimal concurrency. You may want to repeat the tests to ensure that you have sufficient data points to draw a correct conclusion.

You can import file attachments to some record types. Importing attachments impacts import performance and should be considered when planning your data import activities.

You can also adjust the data import based on the number of records in your input data file. For example, start with 25,000 records and increase by 25,000 records with every run. As you increase the number of records in each batch, note the average throughput. If you reach a point where throughput is decreasing, then you may have exceeded your optimal number of records. Oracle doesn't recommend importing more than 100,000 records in a single import activity and exceeding five concurrent import activities.
Pod Size

Significant changes to your usage patterns such as adding many new users or the execution of high volume data imports may change your pod sizing assessment. Ensure that your environment is properly sized to handle the import data volumes generated by your organization along with other operations that are performed by your users. Before starting a high volume import process or one time data load, you may want to have Oracle review your sizing. Contact Oracle help desk to start this review process.

Potential Issues When Opening CSV Files in Excel

Whenever you open the import source file or the exported source file in Excel, you might face issues with some of the field values. This topic explains the various issues that might occur and how to fix them.

Potential Issues

Potential issues that might occur include:

- Saving ID fields:

  Issue: If you save your CSV file and then reopen it in Excel, IDs and other large numbers are typically displayed in scientific notation: the product of a decimal number and a power of 10. For example, the value 123456789012 is displayed as 1.23457E+11.

  Cause: By default, Excel displays numbers that are greater than 11 characters in scientific notation.

  Workaround:
  a. Highlight the column containing the value.
  b. Right-click and select Format Cells.
  c. In the Format Cells dialog box, select the Category Number and set the decimal places to 0. Click OK.

- Saving date-related fields:

  Issue: If you save your CSV file and then reopen it in Excel, date-related fields such as PeriodName are typically displayed in yy-mmm format. For example, the value 12-16 is displayed as 16-Dec.

  Cause: By default, Excel displays date-related numbers in yy-mmm format.

  Workaround:
  a. Highlight the column containing the value.
  b. Right-click and select Format Cells.
  c. In the Format Cells dialog box, select the Category Custom and enter the type mm-yy or any other date format of your choice. Click OK.

- Saving numeric values that have more than 15 digits:

  Issue: If your CSV file has a value with more than 15 digits, such as 1234567890123456, then Excel displays it as 1234567890123450 when the file is opened. Excel replaces the digits beyond 15 with zeroes.

  Cause: Excel supports only 15 digits of precision.
Workaround:
Method 1
a. Highlight the column containing the value.
b. Right-click and select **Format Cells**.
c. In the Format Cells dialog box, select the Category **Text** and click **OK**.
d. Enter the value again in the cell.
Method 2
a. Highlight the cell containing the value.
b. On the Formula Bar, precede the value with an apostrophe. For example, type the value '1234567890123456 and press enter.

Best Practices for Round-Trip Export and Import

You export data and then import it into CX Sales and B2B Service environment forming round-trip operation. You can perform round-trip operations within an CX Sales and B2B Service environment or between two different CX Sales and B2B Service environments.

Before performing a round-trip operation, you must consider the identifiers and configurations. Although you can import most data directly into a target environment, you must ensure that the configurations from your source environment have been replicated in the target environment. Additionally, system-generated identifiers can't be imported and must be excluded from either the export or the import during round trip.

Use of Identifier Values

When importing records during a round-trip operation, you must ensure that the record to which you're associating (for example, if you're importing a Contact and want to assign an Owner value) already exists in the target application. You can't provide an identifier for a record that hasn't already been imported. If you attempt to associate with a record which can't be uniquely identified by the user-key provided, an error is displayed.

CX Sales and B2B Service uses these two types of identifiers:

- Record IDs, which contain system-generated values.
- Alternate keys, whose values are set by the user.

Record IDs

Record ID values are generated by the application when you create a record. During round trip, the target application assigns record ID values to all the imported records; you can't set these using a value contained in the input data file.

When performing a round-trip operation, you have two options:

- You can exclude the record ID value during export.
- You can ignore the ID value during import mapping.

Record ID values are generally named using the convention "Record Type ID". For example, Account ID, Opportunity ID, or Contact ID.
Alternate Keys

When importing data during a round-trip operation, you must use alternate key values to identify associations between records. The alternate key values that are available for a record in the source system can be included in the data file as they're set by the user and can be assigned the same value as the source system. The set of alternate key values that are available vary by object, but generally include one or more of the following:

- Original System and Original System Reference
- Record Number (for example Account Number, Opportunity Number)
- Record Name (Custom Objects if field is marked as unique)
- Email

Round-Trip Export and Import of Extensible Object and Attributes

If the object you have exported is a custom object or a standard object with custom attributes, then you must ensure that the object definition is identical between environments. This means that the custom object and attributes must exist in the target application and must use the same object and attribute names. During data import, if a difference in the object or attribute definition prevents the import of a record, then an error is generated and reported in the import logs. For example, if the length or data type of a field differs between the source and target applications, the data import operation may not complete.