3.4 Install Oracle R Distribution on IBM AIX

Instructions for installing Oracle R Distribution on IBM AIX.

Before installing Oracle R Distribution, verify that your version of IBM AIX is supported by Oracle Machine Learning for R, as described in the table of platform requirements in Oracle Machine Learning for R System Requirements. You can use this command to verify the version of IBM AIX:

uname -r

To install Oracle R Distribution on IBM AIX:

  1. Go to the Oracle Open Source Software Download page for Oracle R Distribution.

  2. Download the files for your installation, where Rversion is 3.3.0.0 for R-3.3.0:

    ord.Rversion-aix.tar.gz
    ord-supporting-aix-Rversion.tar.gz
  3. Uncompress and untar ord-supporting-aix-Rversion.tar.gz:

    $ gunzip ord-supporting-aix-Rversion.tar.gz  # get ord-supporting-aix-Rversion.tar
    $ tar -xvf ord-supporting-aix-Rversion.tar   # extract contents of .tar file
    $ ls ord-supporting-aix-Rversion             # list of rpms
    
    bash-4.2-5.aix5.1.ppc.rpm
    bzip2-1.0.6-1.aix5.1.ppc.rpm
    bzip2-devel-1.0.6-1.aix5.1.ppc.rpm
    cairo-1.10.0-1.aix5.2.ppc.rpm
    curl-7.28.1-1.aix5.1.ppc.rpm
    curl-devel-7.28.1-1.aix5.1.ppc.rpm
    expat-2.0.1-3.aix5.1.ppc.rpm
    fontconfig-2.5.0-1.aix5.1.ppc.rpm
    gettext-0.17-1.aix5.1.ppc.rpm
    glib2-2.28.6-1.aix5.1.ppc.rpm
    info-4.13a-2.aix5.1.ppc.rpm
    libiconv-1.14-1.aix5.1.ppc.rpm
    libidn-1.29-1.aix5.1.ppc.rpm
    libidn-devel-1.29-1.aix5.1.ppc.rpm
    libpng-1.5.9-1.aix5.1.ppc.rpm
    libpng-devel-1.5.9-1.aix5.1.ppc.rpm
    libssh2-1.4.3-2.aix5.1.ppc.rpm
    libssh2-devel-1.4.3-2.aix5.1.ppc.rpm
    openldap-2.4.23-0.3.aix5.1.ppc.rpm
    openldap-devel-2.4.23-0.3.aix5.1.ppc.rpm
    openssl-1.0.1p-1.aix5.1.ppc.rpm
    openssl-devel-1.0.1p-1.aix5.1.ppc.rpm
    pcre-8.35-1.aix5.1.ppc.rpm
    pcre-devel-8.35-1.aix5.1.ppc.rpm
    pixman-0.28.2-1.aix5.1.ppc.rpm
    pkg-config-0.25-2.aix5.1.ppc.rpm
    readline-6.2-3.aix5.1.ppc.rpm
    readline-devel-6.2-3.aix5.1.ppc.rpm
    texinfo-4.13a-2.aix5.1.ppc.rpm
    xrender-0.9.1-3.aix5.2.ppc.rpm
    xz-devel-5.0.7-1.aix5.1.ppc.rpm
    xz-libs-5.0.7-1.aix5.1.ppc.rpm
    zlib-1.2.6-1.aix5.1.ppc.rpm
    zlib-devel-1.2.6-1.aix5.1.ppc.rpm

    You can also download these RPMs from AIX Open Source Packages.

  4. Install the RPMs as root using an rpm command:

    $ cd /download_directory/ord-supporting-aix-Rversion
    $ su
    # rpm -i *.rpm
    

    To upgrade existing dependencies, use:

    # rpm -UF *.rpm

    If you experience conflicts with dependencies, use:

    # rpm -UF --nodeps *.rpm
  5. Add /opt/freeware/lib64 and /opt/freeware/lib to the LIBPATH environment variable:

    • For ksh:

      $ export LIBPATH=/opt/freeware/lib64:/opt/freeware/lib:$LIBPATH
    • For csh:

      $ setenv LIBPATH /opt/freeware/lib64:/opt/freeware/lib:$LIBPATH

    Ensure that /opt/freeware/lib64 is before /opt/freeware/lib and /opt/freeware/lib is before /usr/lib.

  6. Uncompress ord-Rversion-aix.tar.gz to get ord-Rversion-aix.tar install.sh and uninstall.sh:

    $ gunzip ord.Rversion-aix.tar.gz
    $ tar -xf ord.Rversion-aix.tar 
  7. Run install.sh as root to install the filesets in Oracle R Distribution:

    In the following command, installation_path is the desired location for the Oracle R Distribution that is different than / and rte_package_name is the Oracle R Distribution fileset to install.

    $ sudo ./install.sh rte_package_name installation_path

    The path /opt/R is used if you do not specify an installation path.

    The options for rte_package_name are:

    Option Description

    ORD

    Install all of the filesets in Oracle R Distribution.

    ORD.core

    Installs only the ORE.core fileset.

    ORD.devel

    Installs only the ORE.devel fileset, which requires the ORE.core fileset.

    The following command installs all of the filesets using the specified path:

    $ sudo ./install.sh ORD /opt/R/3_3

    The following commands install the ORD.core and ORD.devel filesets:

    $ sudo ./install.sh ORD.core installation_path
    $ sudo ./install.sh ORD.devel installation_path
  8. Add installation_path/usr/bin to the PATH environment variable:

    • For ksh:

      $ export PATH=installation_path/usr/bin:$PATH
    • For csh:

      $ setenv PATH installation_path/usr/bin:$PATH
  9. Run ldd to ensure that shared library dependencies were picked up correctly:

    $ ldd installation_path/usr/lib/R/bin/exec/R 
    $ ldd installation_path/usr/lib/R/lib/libR.so (libiconv, libreadline) 
    $ ldd installation_path/usr/lib/R/lib/libRlapack.so 
    $ ldd installation_path/usr/lib/R/lib/libRblas.so