Installation Requirements for Programming Environments for Linux x86-64

Ensure that your system meets the requirements for the programming environment you want to configure:

Table 4-10 Requirements for Programming Environments for Linux X86–64

Programming Environments Support Requirements

Java Database Connectivity (JDBC) / Oracle Call Interface (OCI)

JDK 8 (Java SE Development Kit) with the JNDI extension with Oracle Java Database Connectivity.

Oracle C++ Call Interface

Pro*C/C++

Intel C/C++ Compiler 14.0.3 or later, or the version of GNU C and C++ compilers listed in the software requirements section in this document for your platform.

Oracle C++ Call Interface (OCCI) applications can be built only with Intel C++ Compiler 14.0.3 used with the standard template libraries of the gcc versions listed in the software requirements section in this document for your platform.

Oracle XML Developer's Kit (XDK)

Oracle XML Developer's Kit is supported with the same compilers as OCCI.

Pro*COBOL

Micro Focus Server Express 5.1

Micro Focus Visual COBOL for Eclipse 2.2 - Update 2