Compatibility, Upgrading, Downgrading, and Installation

These sections describe compatibility, upgrading, downgrading, and installation topics for Oracle Database 12c Release 2 (12.2).

Oracle REST Data Services (ORDS)

JDK7 is the minimum Java version for Oracle REST Data Services (ORDS).

Core Dump ORA-00600 [8153] Error Encountered After Database Upgrade

A core dump ORA-00600 [8153] error is encountered after the database is upgraded to Oracle Database 12c Release 2 (12.2) and then downgraded back to its original release (reference Bug 20898997).

Always apply the patch for this bug before upgrading the database to Oracle Database 12c Release 2 (12.2).

Downgrading Oracle Database 12c Release 2 (12.2) to Oracle Database 11g Release 2 (11.2.0.3) Results in Errors When Running utlrp.sql

If SQLJ types are present when downgrading from Oracle Database 12c Release 2 (12.2) to Oracle Database 11g Release 2 (11.2.0.3), then the following ORA-00600 error can occur when running utlrp.sql to recompile invalid objects after running catrelod.sql (reference Bug 16230705):

ORA-00600: internal error code, arguments: [16211]

Apply the patch for this bug and recompile the type using the ALTER TYPE COMPILE statement.

Select Product Languages Screen Missing in Oracle Client

Starting with Oracle Database 12c Release 2 (12.2.0.1), the Select Product Languages screen has been removed and Oracle Universal Installer installs all supported language files irrespective of the operating system locale (reference Bug 18223148).