Operating System Checklist for Oracle Database Client on Linux

Use this checklist to check minimum operating system requirements for Oracle Database Client.

Table 1-2 Operating System General Checklist for Oracle Database Client on Linux

Item Task

Operating system general requirements

OpenSSH installed manually, if you do not have it installed already as part of a default Linux installation.

A Linux kernel in the list of supported kernels and releases listed in this guide.

Linux x86-64 operating system requirements

The following Linux x86-64 kernels are supported:

  • Oracle Linux 8.2 with the Unbreakable Enterprise Kernel 6: 5.4.17-2011.1.2.el8uek.x86_64 or later
    Oracle Linux 8.2 with the Red Hat Compatible Kernel: 4.18.0-193.el8.x86_64 or later

  • Oracle Linux 7.6 with the Unbreakable Enterprise Kernel 5: 4.14.35-1902.0.18.el7uek.x86_64 or later
    Oracle Linux 7.4 with the Unbreakable Enterprise Kernel 4: 4.1.12-124.32.3.el7uek.x86_64 or later

  • Red Hat Enterprise Linux 8.2: 4.18.0-193.el8.x86_64 or later

  • SUSE Linux Enterprise Server 15 SP1: 4.12.14-197.29-default or later

Review the system requirements section for a list of minimum package requirements.

Oracle Preinstallation RPM for Oracle Linux

If you use Oracle Linux, then Oracle recommends that you run an Oracle preinstallation RPM for your Linux release to configure your operating system for Oracle Database and Oracle Grid Infrastructure installations.