16.3.13 ORA-12525

Indicates that the client failed to complete its connect request in the time specified by the INBOUND_CONNECT_TIMEOUT_listener_name parameter in the listener.ora file.

Message

ORA-12525: Listener has not received client's request in time allowed

Cause

This error may be a result of network or system delays, or it may indicate that a malicious client is trying to cause a denial-of-service (DoS) attack on the listener.

Action

  • If the error occurred due to system or network delays that are normal for the particular environment, then reconfigure the INBOUND_CONNECT_TIMEOUT_listener_name parameter in listener.ora to a larger value.

  • If you suspect a malicious client, then perform the following steps:
    1. Locate the IP address of the client in the listener.log file to identify the source. Keep in mind that an IP address can be forged.

      For example, the following listener.log file excerpt shows a client IP address of 192.0.2.35.

      03-MAY-2023 16:42:35 * <unknown connect data> *
      (ADDRESS=(PROTOCOL=tcp)(HOST=192.0.2.35)(PORT=53208)) * establish *
      <unknown sid> * 12525
      TNS-12525: TNS:listener has not received client's request in time
      allowed
      TNS-12604: TNS: Application timeout occurred
      
    2. Restrict access to the client. You can configure parameters for access rights in the sqlnet.ora file.