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Preface

This manual explains the usage of Oracle Tuxedo ATMI on a Windows system.

7



Documentation Accessibility

For information about Oracle's commitment to accessibility, visit the Oracle Accessibility
Program website at http://www.oracle.com/pls/topic/lookup?ctx=acc&id=docacc.

Accessible Access to Oracle Support

Oracle customers who have purchased support have access to electronic support through My
Oracle Support. For information, visit http://www.oracle.com/pls/topic/lookup?
ctx=acc&id=info or visit http://www.oracle.com/pls/topic/lookup?ctx=acc&id=trs if you
are hearing impaired.
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1
Using Oracle Tuxedo ATMI on Windows
Server

The following sections describe some basic differences between using Oracle Tuxedo ATMI on
a UNIX server system and using Oracle Tuxedo ATMI on a Windows Server system:

• Windows Considerations

• Configuration Issues

• Specifying Machine Type and User ID Numbers

• Using Network Drives

• Allocating and Releasing Memory Buffers

• Using the bankapp Configuration File as Template

• Starting Oracle Tuxedo ATMI Applications Automatically

• See Also

1.1 Windows Considerations
The following general considerations are important when using Oracle Tuxedo ATMI on
Windows:

• When you specify pathnames, use a back slash (\), not a forward slash (/) to delimit file
and directory names. Use a drive letter (such as C:) for all fully qualified paths.

• You do not need to specify the .exe suffix for executable files. The suffix is always implied
for Oracle Tuxedo ATMI for Windows.

• Filenames follow Windows naming conventions. For instance, names ending in .dll
identify dynamically-linked libraries; names ending in .lib identify statically linked and
imported libraries; names ending in .cmd identify command scripts.

• All Oracle Tuxedo system executables, command scripts, and dynamically-linked libraries
are located in %TUXDIR%\bin. Statically-linked libraries are located in %TUXDIR%\lib.

1.2 Configuration Issues
The following general considerations are important when using Oracle Tuxedo ATMI on
Windows Server system:

• Server names are case sensitive.

• The names of Windows Server machines specified in Oracle Tuxedo ATMI application files
should always be spelled in uppercase.

• The OPENINFO string in the Oracle Tuxedo configuration file (UBBCONFIG) must be presented
in the following format: OPENINFO="resource managers:resource(s)"
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For example:

OPENINFO="TUXEDO\SQL:APPDIR1\bankdl3;bankdb;readwrite"

Note:

The first separator in the preceding string is a colon; subsequent separators are
semicolons.

1.3 Specifying Machine Type and User ID Numbers
In the MACHINES section of the configuration file, include the following three entries:

• TYPE="WinNT"

• UID=0
• GID=0

Note:

These entries require different settings on a UNIX system.

Whenever you create a configuration file for an environment with both UNIX and Windows
systems, include these entries in the MACHINES section for every Windows Server node in your
configuration.

1.4 Using Network Drives
For reliability purposes, Oracle recommends that you do not use network drives. If, however,
you try to start an Oracle Tuxedo ATMI application on a Windows Server machine in which the
TUXCONFIG file resides on a network drive, you must set the following permissions:

• These entries require different settings on a UNIX system.

• The administrator must use the same password on the local and remote systems.

• In the tuxipc service startup options, the ENTRY option must have Administrator set for
Log On As This Account. The password must be the same as the administrator’s so that
the tuxipc service has full administrator access rights.

1.5 Allocating and Releasing Memory Buffers
When allocating and releasing memory buffers on a Windows Server system, make sure each
memory buffer is released from the same heap in which it was allocated. If it is not, a
segmentation fault occurs.

For example, a memory buffer that is allocated using Falloc() must be released using
Ffree(). If a memory buffer allocated with malloc() is freed using Ffree(), a segmentation
fault occurs. The free() routine must be used, in the latter case, to free the memory buffer.

Chapter 1
Specifying Machine Type and User ID Numbers
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For more information about Falloc,Falloc32(3fml)and Ffree, Ffree32(3fml), see Oracle
Tuxedo ATMI FML Function Reference. For more information about malloc() and free(), see
the documentation delivered with your operating system.

1.6 Using the bankapp Configuration File as Template
The bankapp program is a small example application bundled with Oracle Tuxedo ATMI for
Windows Server. Besides demonstrating the operation of Oracle Tuxedo ATMI and providing
an example of Oracle Tuxedo ATMI application code, the file of %TUXDIR%
\samples\atmi\bankapp\nt\ubbshm (in Oracle Tuxedo SHM mode) or %TUXDIR%
\samples\atmi\bankapp\nt\ubbmp (in Oracle Tuxedo MP mode) can act as a template for
configurations for any new applications.

1.7 Starting Oracle Tuxedo ATMI Applications Automatically
When Oracle Tuxedo ATMI is installed on a Windows Server system, it may be useful to
configure the machine to start an Oracle Tuxedo ATMI application automatically when booting
up your system using the srvany.exe utility program provided in Microsoft Windows Resource
Kits. For configuration instructions, see srvany.wri and rktools.hlp.

To ensure proper operation of Oracle Tuxedo ATMI programs that start automatically when
booting up, you must set the Oracle Tuxedo system environment variables %TUXDIR% and
%NLSPATH%. Set these variables using the conventional Windows method or by using the Oracle
Administration program, as explained in Setting and Modifying Environment Variables.

1.8 See Also
For information about installing Oracle Tuxedo ATMI on a Windows Server system, see
Installing the Oracle Tuxedo System. For more information about the Oracle Tuxedo system,
see the following documents:

• Oracle® Tuxedo Application Configuration Guide

• Administering an Oracle Tuxedo Application at Run Time

• Using the Oracle Tuxedo ATMI Workstation Component

• Oracle® Tuxedo Command Reference

• Oracle® Tuxedo ATMI C Function Reference

• Oracle Tuxedo ATMI COBOL Function Reference

• Oracle Tuxedo ATMI FML Function Reference

• Oracle Tuxedo File Formats, Data Descriptions, MIBs, and System Processes Reference

Chapter 1
Using the bankapp Configuration File as Template
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2
Configuring Oracle Tuxedo ATMI for Windows
Server

The following sections describe how to configure Oracle Tuxedo ATMI on a Windows Server
system:

• Introducing the Oracle Administration Program

• Invoking the Oracle Administration Program

• Accessing Other Machines on a Network

• Setting and Modifying Environment Variables

• Directing Oracle Tuxedo Messages to the Windows Server Event Log

• Configuring tlisten Processes to Start Automatically

• Configuring and Monitoring IPC Resources to Maximize System Performance

• Reviewing the Windows Server Registry Content

2.1 Introducing the Oracle Administration Program
The Oracle Tuxedo 7.1 or later software for Windows provides an Oracle Administration
program and two Windows services (tlisten and Oracle procMGR) for configuring the Oracle
Tuxedo system on a Windows Server system. Only if the installation includes Oracle Tuxedo
server components will these additional administration tools be installed on the Windows
Server system.

You can use the Oracle Administration Program to perform the following tasks:

• Accessing Other Machines on a Network

• Setting and Modifying Environment Variables

• Directing Oracle Tuxedo Messages to the Windows Server Event Log

• Configuring tlisten Processes to Start Automatically

• Configuring and Monitoring IPC Resources to Maximize System Performance

2.2 Invoking the Oracle Administration Program
With Oracle Tuxedo release 7.1 or later software installed on your Windows Server system,
perform the following steps to access the Oracle Administration program:

1. Choose Start → Settings → Control Panel to launch the Control Panel.

2-1



Figure 2-1    Microsoft Windows Control Panel

2. In the Control Panel, double-click the Oracle Administration icon to launch the Oracle
Administration window.

Figure 2-2     Oracle Administration Window with Machines Page Displayed

2.3 Accessing Other Machines on a Network
The Machines page of the Oracle Administration window enables you, as the Oracle Tuxedo
system administrator, to access any machine (where you have login privileges) on the
Microsoft Windows Network running Microsoft Windows Server. You can then set environment
variables remotely; determine the location of Oracle Tuxedo event logging; add, remove, stop,
or start tlisten services; and tune IPC resources.

Chapter 2
Accessing Other Machines on a Network
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To access a remote machine, locate and click the machine’s icon on the network tree. If you
know the name of a remote machine, but do not know its work group, perform the following
steps to select it:

1. In the lower right-hand corner of the Machines page, click Select to display the Enter
Machine Name dialog box.

Figure 2-3    Enter Machine Name

2. In the Enter Machine Name dialog box, enter the name of the remote machine (for
example, \\intrepid) and click OK.

At this point, all subsequent actions performed on other pages (Environment, Logging,
Listener, and IPC Resources) in the Oracle Administration window will take place on the
selected machine (intrepid in this example).

2.4 Setting and Modifying Environment Variables
The Environment page enables you to view, set, or modify Oracle Tuxedo environment
variables on your Windows Server system.

Chapter 2
Setting and Modifying Environment Variables
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Figure 2-4    Oracle Administration Window with Environment Page Displayed

To add, modify, or delete environment variables using the Environment page, follow these
steps.

1. To add a variable, enter its name in the Variable field and its value in the Value field, and
then click Set.

2. To modify a variable, select the variable, enter its new value in the Value field, and then
click Set.

3. To delete a variable, select the variable you want to delete and then click Delete.

4. Click OK or Apply to write your changes to the Windows Server Registry.

2.5 Directing Oracle Tuxedo Messages to the Windows Server
Event Log

The Logging page enables you to direct Oracle Tuxedo system messages to the Event Log on
your Windows Server system, to the traditional user log (ULOG) disk file, or both.

Chapter 2
Directing Oracle Tuxedo Messages to the Windows Server Event Log
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Figure 2-5    Oracle Administration Window with Logging Page Displayed

You may select the Event Log option, or the traditional user log (ULOG) Disk File option, or both.

• Log Output: Windows Event Log

• Log Output: User Log (ULOG) Disk File

2.5.1 Log Output: Windows Event Log
• Setting Up to Log to Windows Event Log

• Viewing Windows Server Event Log Entries

2.5.1.1 Setting Up to Log to Windows Event Log
No setup is required for the Event Log.

2.5.1.2 Viewing Windows Server Event Log Entries
To view Windows Server Event Log entries, follow these steps:

1. From the Windows Server desktop, select Start → Programs → Administrative Tools `→
Event Viewer to display a list of all the events that have occurred since the application
booted.

Chapter 2
Directing Oracle Tuxedo Messages to the Windows Server Event Log
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Figure 2-6    Event Viewer Window

2. On the menu bar (across the top of the Event Viewer window), click Log to display a drop-
down Log menu.

3. From the drop-down Log menu, choose Application. As a result of this selection, only
application-specific events are listed in the Event Viewer window.

4. For detailed information on Event Details, refer to in the Detail tab.

Figure 2-7    Event Detail Window

This General tab provides the following information:

• Log Name—indicates where the event was recorded.

• Source—section of System Messages in which the event is described and an
appropriate action is recommended.

• Event ID—number under which the message is listed in System Messages.

• Level—purpose of the message; specifically, whether the message is intended to
provide information, a warning, or notification of an error.

• User—person using the software at the time the event occurred.

• OpCode—provides additional context about what action or operation was performed
when the event was logged.

Chapter 2
Directing Oracle Tuxedo Messages to the Windows Server Event Log
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• Logged—date and time on which the event occurred.

• Task Category—provides additional classification for an event.

• Keywords—filter and categorize events based on predefined tags.

• Computer—machine on which the event occurred.

2.5.2 Log Output: User Log (ULOG) Disk File
• Setting Up to Log to ULOG File

• Viewing ULOG Entries

2.5.2.1 Setting Up to Log to ULOG File
If you want to set up the traditional user log (ULOG) messages, perform the following steps to
select a storage directory:

1. On the Logging page, click the arrow to the right of the Directory field to display a drop-
down list of directories.

2. Select the name of the directory in which you want ULOG messages to be stored.

3. In the Prefix field, type a prefix for the name of the log file. The default prefix is ULOG, and
the default file name is ULOG.mmddyy, where mmddyy is the month, day and year that the
log file was created.

4. To save your selections to the Windows Server Registry, click OK or Apply.

2.5.2.2 Viewing ULOG Entries
A ULOG is a text file. You can use any text editor to open a ULOG and view its contents.

2.6 Configuring tlisten Processes to Start Automatically
The Listener page enables you to view, create, or modify tlisten services on your Windows
Server system.

Chapter 2
Configuring tlisten Processes to Start Automatically
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Figure 2-8    Oracle Administration Window with Listener Page Displayed

During the Oracle Tuxedo installation, the installer program installed a tlisten service on your
Windows Server system. Each time you boot your system, the tlisten service starts a
tlisten process on port 3050 of your machine. The password associated with the tlisten
process is the one you entered during the installation.

A tlisten process must be started on each machine of a networked Oracle Tuxedo
application before the Oracle Tuxedo system and application servers can boot. You use the
tlisten process to perform administrative actions across multiple machines. To learn more
about tlisten processes, see tlisten(1)in Oracle Tuxedo Command Reference.

To add, remove, stop, or start tlisten services using the Listener page, follow these steps.

1. To add a tlisten service, enter a port number in the Port Number field and then click Add.
(Generally, you need one tlisten process for each Oracle Tuxedo application running on
your machine.)

2. To remove a tlisten service, select the tlisten service you want to delete and then click
Remove.

3. To stop a tlisten service that has been started, select the tlisten service you want to
stop and then click Stop.

4. To start a tlisten service that has been stopped, select the tlisten service you want to
start and then click Start.

5. Click OK or Apply to write your changes to the Windows Server Registry.

Besides viewing and controlling tlisten services using the Listener page, you can click Start
→ Programs → Administrative Tools → Services to launch the Services window and then view
and control tlisten services via the Services window.

Chapter 2
Configuring tlisten Processes to Start Automatically

2-8



2.7 Configuring and Monitoring IPC Resources to Maximize
System Performance

The IPC Resources page enables you to configure the interprocess communication (IPC)
resources on your Windows Server system to maximize Oracle Tuxedo performance.

Figure 2-9    Oracle Administration Window with IPC Resources Page Displayed

During the Oracle Tuxedo installation, the installer program installed an Oracle ProcMGR
service on your Windows Server system. Each time you boot your system, the Oracle
ProcMGR service configures the IPC resources on your machine to whatever values you set
on the IPC Resources page. The values shown in the preceding display are the default IPC
values set by the installer program.

On most machines, Oracle ProcMGR runs as installed; however, you can use the IPC
Resources page to tune the IPC resources and maximize performance. To determine the
minimum IPC Resource values required for an Oracle Tuxedo application, see “Checking IPC
Requirements” in Installing the Oracle Tuxedo System. The following table maps the names of
the IPC Resources on a Windows Server system to the traditional names on a UNIX system.

Table 2-1    PC Resource Name Mappings Between Windows and UNIX Systems

Windows Server Name Traditional UNIX Name

Maximum Allowed Message Size MSGMAX

Maximum Number of Message Headers No matching name

Chapter 2
Configuring and Monitoring IPC Resources to Maximize System Performance
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Table 2-1    (Cont.) PC Resource Name Mappings Between Windows and UNIX Systems

Windows Server Name Traditional UNIX Name

Maximum Message Queue Size MSGMNB

Maximum Number of Message Queues MSGMNI

Size of Message Segment MSGSSZ

Number of Message Segement MSGSEG

Maximum Number of Processes Using IPC NPROC

Maximum Number of Semaphores SEMMNS

Maximum Number of Semaphores Sets SEMMNI

Maximum Number of Semaphore Undo Structures SEMMNU

Maximum Number of Processes Per Shared
Segement

No matching name

Number of Shared Memory Segments SHMMNI

To modify IPC Resource values using the IPC Resources page, follow these steps:

1. In the “Current Resource: Default box,” click the Use Default IPC Settings check box to
clear it. An insert box appears in the Current Resource: Default box.

2. Click the insert box, enter the name of your Windows Server machine, and press Enter.

3. Click the fields next to the IPC resources you want to change and enter the desired values.

4. Click OK or Apply to write your changes to the Windows Server Registry.

5. Stop and restart the Oracle ProcMGR service to put your changes into effect: click Start →
Programs → Administrative Tools → Services to launch the Services window and then stop
and restart the Oracle ProcMGR via the Services window.

When interpreting the Maximum Number of Processes Using IPC parameter on the IPC
Resources page, keep the following information in mind:

• You must count any multicontexted Oracle Tuxedo ATMI client multiple times. Your total
should match the number of application associations (contexts) that can be outstanding
concurrently.

• You must count any multicontexted Oracle Tuxedo ATMI server multiple times. Your total
should match the number of contexts calculated by adding 1 to the value of
MAXDISPATCHTHREADS in the target application’s configuration (UBBCONFIG) file, where 1
represents the main dispatcher thread.

You can view the performance of a running Oracle Tuxedo application on the Windows Server
Performance Monitor. Choose Start → Programs → Administration Tools → Performance
Monitor to launch the Performance Monitor window.

Chapter 2
Configuring and Monitoring IPC Resources to Maximize System Performance
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Figure 2-10    Performance Monitor

2.8 Reviewing the Windows Server Registry Content
The Windows Server Registry is the repository for all hardware, software, and application
configuration settings for the Windows Server system. During the Oracle Tuxedo installation,
the installer program writes general installation information as well as IPC Resource values to
the Registry. The structure of the Registry relevant to Oracle Tuxedo is as follows.

HKEY_LOCAL_MACHINE\SOFTWARE\Oracle\TUXEDO\<version>\...

• Developer
• Environment
• Security
• IPCResources
To view this structure, choose Start → Run to launch the Run dialog box, enter Regedit and
click OK to launch the Registry Editor window.

• Developer Key

• Environment Key

• Security Key

Chapter 2
Reviewing the Windows Server Registry Content
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2.8.1 Developer Key
The Developer key stores product information, including the major and minor version numbers
of the release, and user and company names.

2.8.2 Environment Key
The Environment key stores the locations referenced by the Oracle Tuxedo environment
variables set on your Windows Server system. It also stores other values such as IPC resource
settings.

2.8.3 Security Key
The Security key holds the access permissions for Oracle Tuxedo processes and services. The
following permissions are mandatory:

• Any user who runs tlisten(1) must have read access permissions.

• The account under which the Oracle ProcMGR service is running must have read access
permissions.

Oracle recommends that the Administrator have full control permissions.

Chapter 2
Reviewing the Windows Server Registry Content
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3
Using the Visual C++.Net IDE To Develop
Oracle Tuxedo ATMI Applications

The following sections describe how to develop ATMI application clients and/or servers in the
Microsoft Visual C++ Integrated Development Environment (msdev) on a Windows desktop
system, or Windows Server system:

• Before You Start

• Using Development Tool

• Using the buildserver and buildclient Commands

• Adding BuildTuxedo to the MSDEV Tools Menu

• Creating Oracle Tuxedo ATMI Project Files

• Setting Up Your Environment

• Debugging an Oracle Tuxedo ATMI Server Application

• Developing an ATMI Application Using the Command Line Instead of the Visual C++.Net
IDE GUI

• See Also

3.1 Before You Start
Because Oracle Tuxedo ATMI client but not server components can be installed on Windows
desktop systems, you can use the Microsoft Visual C++ IDE on these platforms to develop only
ATMI application clients. In contrast, because both Oracle Tuxedo ATMI client and server
components can be installed on Windows Server, you can use the Microsoft Visual C++.Net
IDE on the Windows Server platform to develop both ATMI application clients and servers.

3.2 Using Development Tool
Oracle Tuxedo ATMI integrates into the Microsoft Visual C++.Net IDE (msdev) and emulates
the functionality of msdev when integration is not possible. This integration makes it easier for
you to develop Oracle Tuxedo ATMI applications for 64-bit and 32-bit Windows operating
systems.

The coding required to create Oracle Tuxedo ATMI service requests, send requests, set up
conversational connections, and get replies is fundamentally the same in both UNIX and
Windows Server environments.

BuildTuxedo is a single development tool, tightly integrated with the msdev build environment,
that developers can use instead of the buildserver, buildclient, and buildclt commands to
develop an Oracle Tuxedo application. (Of course, these commands are still available for those
who prefer to use them.) The BuildTuxedo system operates seamlessly on all currently
supported Windows environments.
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3.3 Using the buildserver and buildclient Commands
Both the buildclient and buildserver commands are available to Windows Server systems;
however, only the buildclient command is available to Windows desktop systems, meaning
that only Tuxedo application clients can be built on a Windows desktop system. For more
information about the build commands, see buildclient(1)and buildserver(1)in Oracle Tuxedo
Command Reference.

There are differences between how the options to the buildclient and buildserver
commands work on non-integrated development environments and on integrated development
environments, as indicated in the following table.

Table 3-1    Using the buildserver and buildclient Commands

To . . . In a Non-
Integrated
Development
Environment,
Use This
Option . . .

In an Integrated Development Environment . . .

Turn on verbose
mode

-v All options are displayed on tabs by default. (The -v option is
unnecessary and unsupported.)

Specify an output
file

-o
(output_filenam
e)

1. Select Settings from the msdev Build menu.

2. Select the Link tab in the Project Settings dialog box.

3. Specify the name of your output file by using the edit
control.

Specify the first file
to be linked

-f 1. Select Settings from the msdev Build menu.

2. Select the Link tab in the Project Settings dialog box.

3. Specify the first file to be linked by using the edit control.

Specify the last file
to be linked

-1 1. Select Project from the msdev menu.

2. Select the Link tab in the Project Settings dialog box.

3. Specify the last file to be linked by using the edit control.

Specify a resource
manager

-r 1. Access the BuildTuxedo GUI.

2. Access the BuildTuxedo Test window and select the
Resources tab.

3. In the Tuxedo Resource Manager field, enter the name of
the resource manager.

Specify services
that will be
available on a
server

-s 1. Access the BuildTuxedo GUI.

2. Access the BuildTuxedo Test window and select the
Services tab.

3. In the Service Names field, enter the name of each
service on a separate line.

Use the COBOL
compiler

-c COBOL is unavailable.
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To modify the build environment in an integrated development environment, follow these steps:

1. Choose Settings from the msdev Project menu.

2. Select the C/C++ or Link tab.

Note:

CC and CFLAGS are no longer needed.

To specify the library and include paths in an integrated development environment, follow these
steps:

1. From the MSDEV Tools menu, choose Options to display the Options dialog box.

2. In the Options dialog box, select the Directories tab.

3.4 Adding BuildTuxedo to the MSDEV Tools Menu
To add BuildTuxedo to the MSDEV Tools menu, follow these steps:

1. In the Microsoft Visual C++.Net IDE (msdev) graphical user interface (GUI), choose Tools
→ External Tools. The External Tools window displays.

2. In the External Tools window, click Add to clear the Title field.

Figure 3-1    External Tools Window

3. In the Title field of the External Tools page, type &BuildTuxedo in the empty field.
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Note:

To enable a letter key as a hot key, put an ampersand (&) before the appropriate
letter.

4. In the Command field of the External Tools page, provide a pathname by doing one of the
following:

• Type the full pathname of BuildTuxedo (%TUXDIR%\bin\BuildTuxedo).

• To the right of the Command field, click the ellipsis button, browse to the desired
directory, select buildtuxedo.exe, and click Open. The selected pathname appears in
the External Tools window.

• In the Initial directory field of the External Tools page, click the right arrow button to
display a pop-up menu. In the pop-up menu, choose Project Directory ($
(ProjectDir)).

5. In the Initial directory field of the External Tools page, click the right arrow button to display
a pop-up menu. In the pop-up menu, choose Project Directory ($(ProjectDir)).

Note:

To modify an item, highlight it and type over it. To move any item, highlight it and
select the up or down arrow at the top of the Menu Contents box.

6. Click Apply to save the changes and click OK to close the External Tools window.

BuildTuxedo is now part of the MSDEV Tools menu.

3.5 Creating Oracle Tuxedo ATMI Project Files
BuildTuxedo maintains a separate project file in the current directory for each Oracle Tuxedo
ATMI application using it. When BuildTuxedo begins, it searches for a valid project file in the
current directory. If one is found, the various dialog controls are set to the values stored in the
file and the dialog is displayed. The title bar displays the following information:

BuildTuxedo project_name 

Because your BuildTuxedo project is closely associated with the msdev project in the current
directory, BuildTuxedo also searches for two other files:

• A valid msdev makefile ( filename .mak)

• An msdev project file ( filename .mdp, filename .dsw, or filename .dsp)

If BuildTuxedo cannot find either of these files, it displays a warning and/or fails to activate. If
the directory contains multiple BuildTuxedo project files, or multiple msdev project files or make
files, menu items that contain appropriate target names are added to the System menu.

To save the current project file, select OK or Apply. To cancel any changes that you make to
the project file or any file maintained by the Oracle Tuxedo system, click Cancel or Esc.
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3.6 Setting Up Your Environment
Before you can build your Oracle Tuxedo ATMI application in an IDE, you must set the
following fundamental parameters in your environment:

• Build type

• Header file

• Filename of the C or C++ file to be created and maintained by BuildTuxedo
• Function names

• Service names

To provide this information, access the BuildTuxedo project_name dialog box in the msdev GUI.

• Specifying the Build Type, Header File, and Filename

• How BuildTuxedo Uses the Header File

• Specifying Function and Service Names

• Specifying a Resource Manager

3.6.1 Specifying the Build Type, Header File, and Filename
To specify the build type, header file, and filename, follow these steps:

1. In the project_name dialog box, click the Build tab to display the Build page.
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Figure 3-2    Build Page

2. In the Build Types field of the Build page, click the down arrow and choose one of the
following:

• Server

• Native client or Workstation client

Note:

Windows desktop users can select only Workstation Client type.

If You Select . . . Then, After Making Your Selection . . .

Server Enter information in the Initialization, cleanup, and Entry
Point fields, Proceed to step 3.

Native Client or Workstation Client Proceed to step 3.

The Initialization and Cleanup options allow you to override the default init/exit functions by
specifying valid function names. The Entry Point option allows you to specify the name of
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the function generated by BuildTuxedo. After specifying its name, you can call the function
from anywhere in the application.

3. In the Header File field of the Build page, enter stdafx.h.

4. In the File Name field of the Build page, enter the name of the C or C++ file to be
generated and maintained by BuildTuxedo.

3.6.2 How BuildTuxedo Uses the Header File
In the header file, BuildTuxedo adds the necessary PRAGMA statements to build the current
Oracle Tuxedo ATMI project correctly. BuildTuxedo opens the file specified in the Header File
field of the Build page, if the file is present; otherwise, it creates a new one. A section starting
with:

//Begin Tuxedo Section*****DO NOT EDIT*****

and ending with:

//End Tuxedo Section

designates the area in the header file in which pragma statements are written. This area is
maintained by BuildTuxedo. If BuildTuxedo does not locate this section in the file, it appends it
to the end of the header file. Because all other text within the file remains unchanged, you can
specify stdafx.h as the header file.

Note:

If your project is new, and you select OK or Apply, you must select Files into Project
from the MSDEV Insert menu. You then add the file generated by BuildTuxedo to the
current project. You need to do this only for a new project or when you change the
name of the C/C++ output file.

3.6.3 Specifying Function and Service Names
Select the Services tab to display the Services page, in which you specify function and service
names.
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Figure 3-3    Services Page

In the Services page, two lists are used to maintain the service dispatch table:

• Function Names is a user-maintained list of functions that you can associate with a
service.

• Service Names is a user-maintained list of the associated services.

Note:

To scroll up and down either list, use the arrow keys.

Generally, the service and the function that performs the service are represented by the same
name. For example, function x performs service x. In some cases, the function may have a
different name from the service it performs. For example, in one case, function abc performs
services x, y, and z. In another case, the service name may not be known until run time.
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You must specify any function associated with a service when you build the server. For any
function associated with a service, you must specify the service, the appropriate prototype, a C
linkage, a void return, and a single TPSVCINFO pointer parameter. To specify a function to which
a service name can be mapped, you must add the function to the Function Name list. This
information is required for the service dispatch table.

Note:

If you are using the buildserver(1)command, you can provide this information with
the -s option. For more information about the -s option, see Programming an Oracle
Tuxedo ATMI Application Using C or Programming an Oracle Tuxedo ATMI
Application Using COBOL.

To add or edit names on the Function Names list, follow these steps:

1. If you are using the buildserver(1)command, you can provide this information with the -s
option. For more information about the -s option, see Programming an Oracle Tuxedo
ATMI Application Using C or Programming an Oracle Tuxedo ATMI Application Using
COBOL.

To Action

Add an item a. Click the New icon (broken box with twinkle in the upper left corner).

b. Click Insert, or select a blank area on the list (that is, a dotted lined box).

c. Type the name of the new function.

Modify an existing
name

Highlight the name and type over it.

Delete a name Highlight the name on the list and click the Xicon or click Delete.

2. When complete, click OK or press Enter to save your changes and exit. (To exit without
saving your changes, click Esc or Tab.)

See Also:

Section 1 - Commands

3.6.4 Specifying a Resource Manager
To specify a resource manager, follow these steps:

1. Select the Resources tab in the BuildTuxedo window to display the Resources page.
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Figure 3-4    Resources Page

2. In the Tuxedo Resource Manager field of the Resources page, type the full pathname of
the resource manager for your application.

Note:

The Tuxedo Resource Manager field contains a list of Oracle Tuxedo resource
managers available on the system, as defined in the %TUXDIR%\udataobj\RM file.
If the file is not present, a default (NONE) is displayed.

3.7 Debugging an Oracle Tuxedo ATMI Server Application
You must use the following procedure only if you have built the ATMI server application using
the Debug configuration for your project.

To debug a server that has not been booted, follow these steps:

1. At any Windows command prompt, type tmboot -n -d 1 -s servername to display the
command-line options used by tmboot(1) to start servername.
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2. Execute the tmboot -M command to boot the BBL. (If necessary, boot additional
application servers or machines.)

3. In msdev, select Project → Settings.

4. In the Program Arguments field of the Debug page, type the command-line options used in
step 1.

5. Start the debugger and start debugging the server application.

Note:

Because Oracle Tuxedo libraries are not built with debugging information and
source code is not provided, you cannot access the Oracle Tuxedo code directly.

6. To end the debugging session, type tmshutdown at any Windows command prompt.

WARNING:

Do not stop the server by selecting Debug → Stop; the Oracle Tuxedo system
may subsequently attempt to restart the server.

To debug a server that is already running, type msdev -p nnn at any Windows command
prompt, replacing nnn with the server’s process ID (represented by a decimal number).

3.8 Developing an ATMI Application Using the Command Line
Instead of the Visual C++.Net IDE GUI

If you must develop an Oracle Tuxedo ATMI application using the command line instead of the
Microsoft Visual C++ IDE GUI, use the buildserver(1)and buildclient(1)commands. To do
this, specify the compiler and link options necessary to build an Oracle Tuxedo ATMI
application. For information about using these tools, see the following documents:

• Oracle Tuxedo Command Reference

• Tutorials for Developing Oracle Tuxedo ATMI Applications

• One of the following language-specific guides:

– Programming an Oracle Tuxedo ATMI Application Using C

– Programming an Oracle Tuxedo ATMI Application Using COBOL

To build a debug version of your ATMI application using buildserver or buildclient, you
must compile all source files with the /Zi and /Od options. The /Zi option enables debugging;
the /Od option disables optimization. In addition, you may need to define the _DEBUG
preprocessor directive. To complete the process, indicate the link option as follows:

-l"/link/debug:full /debugtype:both"
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See Also:

Section 1 - Commands

3.9 See Also
For information about the Oracle Tuxedo ATMI, see the following documents:

• Oracle® Tuxedo Programming an Oracle Tuxedo ATMI Application Using C_Import

• Programming an Oracle Tuxedo ATMI Application Using Java

• Programming an Oracle Tuxedo ATMI Application Using COBOL

• Oracle® Tuxedo Programming an Oracle Tuxedo ATMI Application Using FML

• Oracle® Tuxedo Command Reference

• Oracle® Tuxedo ATMI C Function Reference

• Oracle Tuxedo ATMI COBOL Function Reference

• Oracle Tuxedo File Formats, Data Descriptions, MIBs, and System Processes Reference
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