Upgrade Requirements

Upgrading an existing store to release 4.0 or later requires that the store be running with a 3.0 release or later. If you want to use this release with a store created prior to the 3.0 release, be sure to upgrade the store to a 3.x release before upgrading it to this release. Once a store has been upgraded to this release, it cannot be downgraded to an earlier major or minor release.

See the section on Upgrading an Existing Oracle NoSQL Database Deployment in the Admin Guide.

This release of the server is compatible with Java SE 8 (64-bit) and later, and the client is compatible with Java SE 6 and later. Both have been tested and certified against Oracle Java SE 8 Update 121. We encourage you to upgrade to the latest Java releases to take advantage of the latest bug fixes and performance improvements.

Attempting to use this release with a version of Java earlier than the required version will produce an error message similar to:

Exception in thread "main" java.lang.UnsupportedClassVersionError:
  oracle/kv/impl/util/KVStoreMain : Unsupported major.minor version 52.0