1.2 Supported Platforms

You can use Oracle Autonomous Health Framework with all supported versions of Oracle Database and Oracle Grid Infrastructure.

Run Oracle Autonomous Health Framework on engineered systems such as, Oracle Database Applicance, and Oracle Exadata and Zero Data Loss Recovery Appliance.

Oracle Autonomous Health Framework supports the following operating systems. Use a Java Runtime Edition of version 1.8.

  • Linux OEL 4, 5, 6, 7

  • Linux RedHat 4, 5, 6, 7

  • Linux SuSE 9, 10, 11, 12

  • zLinux

  • Oracle Solaris SPARC (Solaris 9, 10, and 11)

  • Oracle Solaris x86-64 (Solaris 9, 10, and 11)

  • AIX

  • HPUX

  • Microsoft Windows 64-bit

  • Microsoft Windows Server 2012 R2 and above

Note:

Only 32-bit platforms are supported for 32-bit EBS environments using the command orachk compliance -ebs32bit.

Important:

AHF is not supported on Microsoft Windows 7 and 10.

Oracle Autonomous Health Framework is shipped with Oracle Grid Infrastructure since versions 11.2.0.4 and 12.1.0.2. However, this installation does not include many of the Oracle Database tools. Oracle releases new versions of Oracle Autonomous Health Framework several times a year. These new releases include new features and bug fixes.

Ensure that you get the latest Oracle Autonomous Health Framework with Oracle Database support tools bundle from My Oracle Support note 2550798.1.