Error Occurs While Testing the Proxy Server That Supports Only Digest Authentication

Issue

On the Proxy Settings page under My Oracle Support and Proxy Connection tab, when you provide the manual proxy configuration details, you get an exception error stating:
Error: -Proxy Test resulted in Exception. Error while reading data from URL https://updates.oracle.com. 
Cannot establish proxy connection: 407 Proxy Authentication Required

Cause

You provided the configuration details of a proxy server that supports only a Digest authentication schema. By default, the proxy server is mapped only to the Basic authentication schema. Currently there is no support for Digest authentication schema.

Solution

Reconfigure your proxy server to the Basic authentication schema.

For a better understanding of connectivity issues related to HTTP Client Logging, you can perform the following steps:

  1. Locate the startup.properties file under the GC instance directory:
    user_projects/domains/EMGC_DOMAIN/servers/EMGC_OMS1/data/nodemanager/startup.properties 
  2. Append the following string to the value of the property Arguments:
    -DHTTPClient.log.level\=ALL -DHTTPClient.log.verbose\=true
  3. Restart the OMS, and the WebLogic Server Administration Manager by running the following commands:
    emctl stop oms -all
    emctl start oms
  4. Navigate to the following location to check the log file:
    user_projects/domains/EMGC_DOMAIN/servers/EMGC_OMS1/logs/EMGC_OMS1-diagnostic.log
    You can also use grepto find all the HTTP connection logs as follows:
    grep HTTPClient EMGC_OMS1-diagnostic*.log