3 BRM Software Compatibility

Learn about the software that is compatible with Oracle Communications Billing and Revenue Management (BRM) 12.0 server and client systems and 12.0 patch sets.

For hardware and information requirements, see "System Requirements" in BRM Installation Guide.

Note:

  • BRM 12.0 server components do not support any 32-bit server operating systems.

  • Character Sets: BRM 12.0 supports AL32UTF8 as its default character set. It also continues to support the UTF8 character set for backward compatibility. The Unicode character set AL32UTF8 is recommended for all new BRM 12.0 deployments.

  • All BRM clients are supported on Solaris and Linux in addition to Windows.

Solaris

This section lists software compatible with a BRM implementation on Solaris.

Operating System Versions

  • Solaris 11.3

Compilers

  • Oracle Developer Studio 12.4

    Certified for use on Solaris platforms only.

  • Oracle Developer Studio 12.5

    Support added in BRM 12.0 Patch Set 1.

Database Servers

  • Oracle 12c Database (12.2.0 and later patch levels)

    (Oracle Enterprise)

  • Oracle 18c Database (18.1.0 and later patch levels)

    (Oracle Enterprise)

    Support added in BRM 12.0 Patch Set 1.

  • Oracle 19c Database (19.3.0 and later patch levels)

    Support added in BRM 12.0 Patch Set 2.

  • Oracle Real Application Clusters 12c (12.2.0 and later patch levels)

    Use this server for high-availability configurations only. For scalability, use a multischema system. See "Installing a Multischema System" in BRM Installation Guide.

  • Oracle Real Application Clusters 18c (18.1.0 and later patch levels)

    Use this server for high-availability configurations only. For scalability, use a multischema system.

    Support added in BRM 12.0 Patch Set 1.

  • Oracle Real Application Clusters 19c (19.3.0 and later patch levels)

    Use this server for high-availability configurations only. For scalability, use a multischema system.

    Support added in BRM 12.0 Patch Set 2.

  • Oracle 12c Database Enterprise Edition Partitioning (12.2.0 and later patch levels)

  • Oracle 18c Database Enterprise Edition Partitioning (18.1.0 and later patch levels)

    Support added in BRM 12.0 Patch Set 1.

  • Oracle 19c Database Enterprise Edition Partitioning (19.3.0 and later patch levels)

    Support added in BRM 12.0 Patch Set 2.

  • Oracle Clusterware 12c (12.2.0 and later patch levels)

  • Oracle Clusterware 18c (18.1.0 and later patch levels)

    Support added in BRM 12.0 Patch Set 1.

  • Oracle Clusterware 19c (19.3.0 and later patch levels)

    Support added in BRM 12.0 Patch Set 2.

Database Clients

  • Oracle Database 12c Release 2 Client (12.2.0.1.0)

Web Browsers

  • Mozilla Firefox 54.0.1 and later patch levels

  • Mozilla Firefox 58.0 and later patch levels

    Support added in BRM 12.0 Patch Set 1.

  • Mozilla Firefox 65.0 and later patch levels

    Support added in BRM 12.0 Patch Set 2.

  • Microsoft Internet Explorer 11 and later patch levels

  • Microsoft Edge (default version with operating system)

  • Google Chrome 72.0 and later patch levels

  • Apple Safari 12.0 and later patch levels

Linux

This section lists software compatible with a BRM implementation on Linux.

Operating System Versions

  • Oracle Linux 7 update 2 and higher 7.x updates (with critical patch updates)

  • Red Hat Enterprise Linux (RHEL) 7 update 2 and higher 7.x updates (with critical patch updates)

    See "About Critical Patch Updates".

Compilers

  • gcc version 4.8.x

    For Oracle Linux 7 and RHEL 7.

Database Servers

  • Oracle 12c Database (Oracle 12.2.0 and later patch levels)

    (Oracle Enterprise)

  • Oracle 18c Database (Oracle 18.1.0 and later patch levels)

    (Oracle Enterprise)

    Support added in BRM 12.0 Patch Set 1.

  • Oracle 19c Database (Oracle 19.3.0 and later patch levels)

    (Oracle Enterprise)

    Support added in BRM 12.0 Patch Set 2.

  • Oracle Real Application Clusters 12c (12.2.0 and later patch levels)

    Use this server for high-availability configurations only. For scalability, use a multischema system. See "Installing a Multischema System" in BRM Installation Guide.

  • Oracle Real Application Clusters 18c (18.1.0 and later patch levels)

    Use this server for high-availability configurations only. For scalability, use a multischema system.

    Support added in BRM 12.0 Patch Set 1.

  • Oracle Real Application Clusters 19c (19.3.0 and later patch levels)

    Use this server for high-availability configurations only. For scalability, use a multischema system.

    Support added in BRM 12.0 Patch Set 2.

  • Oracle 12c Database Enterprise Edition Partitioning (12.2.0 and later patch levels)

  • Oracle 18c Database Enterprise Edition Partitioning (18.1.0 and later patch levels)

    Support added in BRM 12.0 Patch Set 1.

  • Oracle 19c Database Enterprise Edition Partitioning (19.3.0 and later patch levels)

    Support added in BRM 12.0 Patch Set 2.

  • Oracle Clusterware 12c (12.2.0 and later patch levels)

  • Oracle Clusterware 18c (18.1.0 and later patch levels)

    Support added in BRM 12.0 Patch Set 1.

  • Oracle Clusterware 19c (19.3.0 and later patch levels)

    Support added in BRM 12.0 Patch Set 2.

Database Clients

  • Oracle Database 12c Release 2 Client (12.2.0.1.0)

Web Browsers

  • Mozilla Firefox 54.0.1 and later patch levels

  • Mozilla Firefox 58.0 and later patch levels

    Support added in BRM 12.0 Patch Set 1.

  • Mozilla Firefox 65.0 and later patch levels

    Support added in BRM 12.0 Patch Set 2.

  • Microsoft Internet Explorer 11 and later patch levels

  • Microsoft Edge (default version with operating system)

  • Google Chrome 72.0 and later patch levels

  • Apple Safari 12.0 and later patch levels

Windows

This section lists software compatible with BRM clients on Windows.

Operating System Versions

  • Windows 8.1 Enterprise

  • Windows 10

Web Browsers

  • Mozilla Firefox 54.0.1 and later patch levels

  • Mozilla Firefox 58.0 and later patch levels

    Support added in BRM 12.0 Patch Set 1.

  • Mozilla Firefox 65.0 and later patch levels

    Support added in BRM 12.0 Patch Set 2.

  • Microsoft Internet Explorer 11 and later patch levels

  • Microsoft Edge (default version with operating system)

  • Google Chrome 72.0 and later patch levels

  • Apple Safari 12.0 and later patch levels

Additional BRM Software Requirements

Table 3-1 provides the compatibility information for other applications you need in order to create a complete customer management and billing system for your business.

WARNING:

Oracle does not provide support for any prerequisite third-party software installation or configuration. Any installation or configuration issues related to non-Oracle prerequisite software needs to be handled by the customer.

Table 3-1 Required Third-Party Software for BRM

Product Version Notes
Apache Tomcat

8.5.16 – Support added in BRM 12.0

8.5.32 – Support added in BRM 12.0 Patch Set 1

8.5.38 – Support added in BRM 12.0 Patch Set 2

9.0.37 – Support added in BRM 12.0 Patch Set 3

Supported only for Web Services Manager.
Oracle Access Management 12.2.1.4 – Support added in BRM 12.0 Patch Set 3 Supported only for BRM REST Services Manager.
Oracle Business Intelligence Publisher

12.2.1.2.0 – Support added in BRM 12.0

12.2.1.4.0 – Support added in BRM 12.0 Patch Set 1

Supported only for BRM reports and invoices.

Supported on Solaris and Linux.

Note: Running reports and generating invoices with BI Publisher 12c running on Windows is not supported.

Oracle Analytics Publisher

5.5 – Support added in BRM 12.0 Patch Set 3 with Interim Patch 31848465

Supported on Linux 7.2.

Oracle Java Platform, Standard Edition (Java SE)

8 (1.8.0_144) – Support added in BRM 12.0

8 (1.8.0_221) – Support added in BRM 12.0 Patch Set 2

8 (1.8.0_241) – Support added in BRM 12.0 Patch Set 3

8 (1.8.0_261) – Support added in BRM 12.0 Patch Set 3 with Interim Patch 31848465

Obtain Java SE containing Java Development Kit (JDK) and Java Runtime Environment (JRE).
Oracle Remote Diagnostic Agent (RDA)

8.10 or later

N/A
Oracle WebLogic Server

12c R2 (12.2.1.2.0) – Support added in BRM 12.0

12c R2 (12.2.1.3.0) – Support added in BRM 12.0 Patch Set 2

Supported only for Web Services Manager.
Oracle Unified Directory

11.1.2.3.0

Supported only for LDAP Manager.
Oracle Unified Directory 12.2.1.4 – Support added in BRM 12.0 Patch Set 3 Supported only for BRM REST Services Manager.
Paymentech 120-Byte Batch Processing Format Specification

3.0.0 Revision 4.2 – Support added in BRM 12.0

Requires Paymentech Manager.

Paymentech 120-Byte Batch Processing Format Specification

3.0.0 Revision 12.4 – Support added in BRM 12.0 Patch Set 1

Requires Paymentech Manager.

Paymentech 120-Byte Batch Processing Format Specification

3.0.0 Revision 13.3 – Support added in BRM 12.0 Patch Set 2

Requires Paymentech Manager.

Paymentech 120-Byte Batch Processing Format Specification

3.0.0 Revision 14.3 – Support added in BRM 12.0 Patch Set 3

Requires Paymentech Manager.

The certification for CUP and RUP (feature specific) was done using Paymentech 120-Byte Batch Processing Format Specification 3.0.0 Revision 14.3.

Paymentech 120-Byte Batch Processing Format Specification

3.0.0 Revision 15.3 – Support added in BRM 12.0 Patch Set 3 with Interim Patch 31848465

Requires Paymentech Manager.

The certification for CTI (feature specific) was done using Paymentech 120-Byte Batch Processing Format Specification 3.0.0 Revision 15.3.

Paymentech Online Processing Format Specification

Version 7.4 Revision 5 – Support added in BRM 12.0

Requires Paymentech Manager.

Paymentech Online Processing Format Specification

Version 7.4 Revision 12.4 – Support added in BRM 12.0 Patch Set 1

Requires Paymentech Manager.

Paymentech Online Processing Format Specification

Version 7.4 Revision 13.3 – Support added in BRM 12.0 Patch Set 2

Requires Paymentech Manager.

Paymentech Online Processing Format Specification

Version 7.4 Revision 14.4 – Support added in BRM 12.0 Patch Set 3

Requires Paymentech Manager.

The certification for CUP and RUP (feature specific) was done using Paymentech Online Processing Format Specification Version 7.4 Revision 14.4.

Paymentech Online Processing Format Specification

Version 7.4 Revision 15.3 – Support added in BRM 12.0 Patch Set 3 with Interim Patch 31848465

Requires Paymentech Manager.

The certification for CTI (feature specific) was done using Paymentech Online Processing Format Specification Version 7.4 Revision 15.3.

Perl (32-bit)

5.24.0 – Support added in BRM 12.0

5.28.1 – Support added in BRM 12.0 Patch Set 1 with Interim Patch 29947745

5.28.1 – Support added in BRM 12.0 Patch Set 2

5.30.1 – Support added in BRM 12.0 Patch Set 3

5.32.0 – Support added in BRM 12.0 Patch Set 3 with Interim Patch 31848465

 
Vertex Communications Tax Q Series Vertex CTQ 3.01.04 - Support added in BRM 12.0 Patch Set 3 with Interim Patch 31848465 N/A
Vertex Sales Tax Q Series Vertex STQ certification will be made available with BRM 12.0 Patch Set 4 N/A

About Critical Patch Updates

You should install all critical patch updates as soon as possible. To download critical patch updates, find out about security alerts, and enable email notifications about critical patch updates, see Critical Patch Updates, Security Alerts and Bulletins on the Oracle website.