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Preface

Welcome to the Oracle HCM Cloud Configurations for Oracle HCM Cloud Integration
to Oracle Utilities Work and Asset Cloud Service Setup Guide.

This document covers the Oracle Human Capital Management Cloud configurations and
related information as required by the integration.

Note: The screenshots and images provided in this document are
sample references based on the current release of Oracle HCM Cloud
Configurations for Oracle HCM Cloud Integration to Oracle Ultilities
Work and Asset Cloud Service. They may change based on changes in

future releases.
The preface includes the following:
e Audience
*  Documentation and Resources
*  Updates to Documentation
*  Documentation Accessibility
*  Conventions

*  Acronyms
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Audience

Audience

This document is intended for anyone implementing the integration between Oracle
Human Capital Management Cloud and Oracle Utilities Work and Asset Cloud Service.

Documentation and Resources

For more information regarding this integration, foundation technology and the edge
applications, refer to the following documents:

Product Documentation

Resource

Location

Oracle HCM Cloud Configurations
for Oracle HCM Cloud Integration to
Oracle Utilities Work and Asset Cloud
Service documentation

https://docs.oracle.com/en/industries/utilities /
integrations-index.html

Oracle Utilities Work and Asset Cloud
Service documentation

https:/ /docs.oracle.com/en/industries/energy-
water/work-asset-cloud-service /index.html

Oracle Human Capital Management
Cloud

https:/ /docs.oracle.com/en/cloud/saas/human-
resoutces/22b/oawpm/index.html

Additional Documentation

Resource

Location

Oracle Integration Cloud Service
documentation

Refer to the OIC documentation at:
https://docs.oracle.com/en/cloud/paas/
integration-cloud/index.html

Oracle Support

Visit My Oracle Suppott at https://
support.oracle.com regulatly to stay informed about
updates and patches.

Refer to the Certification Matrix for Oracle Utilities
Products (Doc ID 1454143.1) on My Oracle Support to
determine if support for newer versions of the listed
products is included.

For more information, refer to the Oracle Utilities
Integrations page at http://my.oracle.com/site/
tugbu/productsindustry/productinfo/utilities/
integration/index.htm

Oracle University
for training opportunities

http://education.oracle.com/
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Updates to Documentation

Updates to Documentation

The complete Oracle HCM Cloud Configurations for Oracle HCM Cloud Integration to
Oracle Utilities Work and Asset Cloud Service documentation set is available from
Oracle Help Center at https://docs.oracle.com/en/industries/ utilities /index.html.

Visit My Oracle Support for additional and updated information about the product.

Documentation Accessibility

For information about Oracle's commitment to accessibility, visit the Oracle Accessibility
Program website at http://www.oracle.com/pls/topic/lookup?ctx=acc&id=docacc.

Access to Oracle Support

Oracle customers have access to electronic support for the hearing impaired. Visit:
http://www.oracle.com/pls/topic/lookuprectx=acc&id=info ot http://
www.otacle.com/pls/topic/lookup?ctx=acc&id=trs

Conventions

The following text conventions are used in this document:

Convention Meaning

boldface Boldface type indicates graphical user interface elements associated with an
action, or terms defined in text or the glossary.

italic Italic type indicates book titles, emphasis, or placeholder variables for which
you supply particular values.

monospace Monospace type indicates commands within a paragraph, URLs, code in
examples, text that appears on the screen, or text that you enter.

Acronyms

The following terms are used in this document:

Term Expanded Form

HCM Oracle Human Capital Management

WACS Oracle Utilities Work and Asset Cloud Service
OIC Oracle Integration Cloud
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Chapter 1

Configuration Overview

To configure Oracle Human Capital Management Cloud in the integration, perform the
following steps in the order mentioned:

This chapter focuses on the Employee integration and configuration details of employees
in Oracle Human Capital Management Cloud. It includes the following:

1. Create a profile. Refer to Employee Integration for more details.
2. Create a value set. Refer to Employee Integration for more information.

3. Create manage workforce structures extensible flex fields. Refer to Craft Integration
for details.

4. Create fast formula. For more details, refer to Craft Integration.

5. Create a Business Intelligence report template for job. Refer to Craft Integration for
more information.

6. Extract the upload for Employee/Jobs/Absence. Refer to Employee Unavailability
Integration for more details.

Configuration Overview 1 - 1
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Chapter 2

Employee Integration

This chapter focuses on the Employee integration and configuration details of employees
in Oracle Human Capital Management Cloud. It includes the following:

* Integration Overview

*  Oracle HCM Cloud Configuration for Employee

Employee Integration 2 - 1
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Integration Overview

Integration Overview

Design

This section covers basic integration overview for employee integration. Oracle Human
Capital Management Cloud (Employee) is the central repository of Employee records.

Key attributes will be captured from Oracle HCM Cloud and synced with Oracle Ultilities
Work and Asset Cloud Service in two modes:

*  Bulk (Initial Upload)
* Incremental Upload

This seamless integration between Oracle Human Capital Management Cloud and Oracle
Utilities Work and Asset Cloud Service helps to maintain the same Employee definition
across both platforms.

For information about implementing Oracle Human Capital Management Cloud, see:

https://docs.oracle.com/en/cloud/saas/human-resources/22c/fahcm/about-this-
guide.html#s20035480

Bulk Upload

Bulk Upload is an initial upload from Oracle Human Capital Management Cloud to
Oracle Utilities Work and Asset Cloud Service where all Employee definitions are
exported to UCM in XML format through Data Exchange that is inbuilt functionality of
ERP. Use the filter to select an employee in the Oracle Human Capital Management
Cloud module. The business may choose to import records based on filter as per
business requirement. Only Active employees in the system are part of the integration.

A few examples of attributes that will be passed to Oracle Utilities Work and Asset Cloud
Service in this integration are Personal Number, Legal Entity, Address, email 1D,
Employee type, rate, assignment, job role. Oracle Human Capital Management Cloud
schema will need a mapping with Oracle Utilities Work and Asset Cloud Service and each
field attribute will be mapped to the corresponding value in Oracle Integration Cloud.
These values will have a DVM for mapping between Oracle Ultilities Work and Asset
Cloud Service and Oracle Human Capital Management Cloud.

Incremental Update

The incremental upload will be a specific scenario, where Atom Feeds handle sync for a
set of changes made within employee definition. Filter Criterion for Increment will be
similar to bulk, where it will only send data Applied in the bulk filter.

For more information about Atom Feeds, see https://docs.oracle.com/en/cloud/saas/
human-resources/22c/faihm/atom-feeds.html.

Events for Employee:
* Empassignment
*  EmpUpdate
*  Newhire

* termination

Employee Integration 2 - 2
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Oracle HCM Cloud Configuration for Employee

Functions that are part of the Atom feed update:

*  Add or update the employee record from the tabs in Oracle Human Capital
Management Cloud

*  Definition change through Person Management

*  Assign Position/Jobs/Grade based on Assignment

Oracle HCM Cloud Configuration for Employee

Creating a Profile

This section focuses on importing the files that are part of the package and configuring
them in the Oracle Human Capital Management Cloud environment for the integration
to run successfully. Make sure to follow the same sequence for successful configuration.

Importing the extract definition includes the following:
*  Creating a Profile
*  Value Sets
*  Extract Upload

A user profile is a set of changeable options that affect the way Oracle applications
appear and how they function. Oracle applications use a set of user profile options that
are common to all the applications. In addition, each module has its own unique set of
user profile options.

For Employee Integration extract definition, create the following profile:

Managing Profile Options

1. Navigate to Setup and Maintenance > Search > Manage Profile Options.
2. Click the add button (+) to create a profile.
HCM_WACS_JOB_RATE_ANNUAL_HRS_PRF)
Profile Option Code: HCM_WACS_JOB_RATE_ANNUAL_HRS_PRF
Profile Display Name: “HCM: WACS Job Rate Annual Hours”
Application: Fast Formula
Module: Global Human Resources

Description: Global Human Resources

Employee Integration 2 - 3
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Creating a Profile

*Start Date: 1/1/51

Edit Profile Option - HCM_WACS_JOB_RATE_ANNUAL_HRS_PRF
Profile Option

Frofile Option Code  HCM_WACS_JOS_RATE_ANNUAL_HRS_PRF
* Profile Display Name

Application

* Module | Giokal Human Rescuwrces -
Description | Giobal Human Resources

SGL Validation

* Start Date | &/100 e

End Date | midiyy e

3. Click Save.

4. Select the record under Search Results: Profile Options

Manage Profile Options @

4 Search
Profil Option Code. WACS% Appication

Profiie Dispay Name:

rch Results : Profile Options
Adonsw Viewy 4 /X Desen

Profle Option Code Module sutDste  E" Doscripion

HOM_WACS_IOB_RATE_ANNUAL_HRS_PRE

4 HCM_WACS_JOB_RATE_ANNUAL_HRS_PRF" Profile Option Levels
v Veww ¥ Detach
Lovel Enabled Updatable
v v
Prosuct

5. Enable the levels as shown in the figure below.

4 HCM_WACS_JOB_RATE_ANNUAL_HRS_PRF: Profile Option Levels
View ¥ Detach
Level Enabled Updatable
Sike v v
Produc
e - "

6. Click Save and Close.

Managing Administrator Profile Values

1. Navigate to Setup and Maintenance > Search > Manage Administrator Profile
Values and search for the “HCM_WACS_JOB_RATE_ANNUAL_HRS_PREF”

profile.

2. Select the record under Search Results: Profile Options.

Employee Integration 2 - 4
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Creating a Profile

3. Click the add button (+) in the Profile Values section. Add the annual hours value.

anage Administrator Profile Values @ Swe savesnaciose Gancel

4 search : Profile Option

Profile Option Code. KCMWWACSH Appiscation v

[search Results
4 Search Results : Profile Options.
Profils Option Code Profil Display Neme Application Module Stan Dato End Date Description

HOM_WACS._J0B_RATE_ANNUAL_HRS_PRF HOM WACS Job Rate Al Hours Fast Fomus Olctalbuman Resourcss 1151 HEM : WACS Job Rats AnnuslHours

4 HOM_WAGS _JOB _RATE_ANNUAL _HRS, PRF: Profe Values
T - BT
.

* Profile Level Product Name User Name A~ Profle Value
Nodsta o pisy

4. Select Site in the Profile Level drop-down list. Profile Value indicates the number
of working hours in an Organization Year.

4 HCM_WACS_JOB_RATE_ANMNUAL_HRS_PRF: Profile Values
Acons v Vieww 4 M :,,_“;Dmcn

4

* Profile Level Product Name User Name a v Profile Value
Site v 2080
Site

This profile value is used to calculate the salary annual rate. The figure shows the default
value 2080; it is the number of working hours in a year. Note that the hours vary based
on the working days in an organization (to be used as per business case).

Value Sets
1. Login to the system with appropriate user or role.

2. Navigate to Setup and Maintenance > Search > Manage Value Sets for Global
Human Resources.

3. Search for Manage Value Sets for Global Human Resources (Workforce
Structures).

Search Task Results

4. Enter the details as in the table below.
a. To create a Manager Type with the following values:
HCM_WACS_MANAGER_TYPE_VS
HCM: WACS Manager/Supetvisor Type

*Value Set Name HCM_WACS_MANAGER_TYPE_VS

Employee Integration 2 - 5
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Creating a Profile

Description HCM: WACS Manager/Supervisor Type

* Module Global Human Resources

Validation Type Table

Value Data Type Character

*FROM Clause fnd_lookup_values

*Value Column Name ookup_code

Description Column Name Meaning

ID Column Name lookup_code

WHERE Clause lookup_type="PER_SUPERVISOR_TYPE'
AND language =SYS_CONTEXT(USERENV',
'LANG")

AND lookup_code='LINE_MANAGER'
AND Enabled_flag="Y"

Create Value Set

* Value Set Code
Description
* Module -
" validation Trne v

* Value Data Type ~

Save SaveandClose Cane|

Jefintion

b. To create the Annual Rate Value Sets:
a. Login to the system with the appropriate user or role.

b. Navigate to Setup and Maintenance > Search.

Employee Integration 2 - 6
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Creating a Profile

c.  Search for “Manage Value Sets for Global Human Resources” (Workforce
Structures).

Search Task Results

c. Enter the following details for the value set.
HCM_WACS_GET_PROFILE_JOB_ANNUAL_HRS_VS§

Note: Annual Rate Value Set is based on
“HCM_WACS_JOB_RATE_ANNUAL_HRS_PRF”.

*Value Set Name HCM_WACS_GET_PROFILE_JOB_ANNUAL_HRS
_VS

Description HCM: WACS Get profile Job Annual Hours

*Module Global Human Resources

Validation Type Table

Value Data Type Number

*FROM Clause (SELECT

TO_NUMBER(FND_PROFILE.VALUE(HCM_WA
CS_JOB_RATE_ANNUAL_HRS_PRF')) RATE

FROM DUAL)
*Value Column Name RATE
Description Column Name
ID Column Name RATE

WHERE Clause

Employee Integration 2 - 7
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Creating a Profile

dit Value Set. HC GET_PROFILE_JOB_ANNUAL_HRS VS Save | v andClose Co

Yo S

d. Click Save and Close.

HCM_WACS_JOB_SET_VS

1. Create a new value set.
2. Enter the following details for the value set.

3. Search for Setup and maintenance > Search > Manage Value Sets for Global
Human Resources (Workforce Structures).

4. Create a new value set and provide the details as below.

*Value Set Name HCM_WACS_JOB_SET_VS
Description HCM: WACS Job Set Name
* Module Application Core
Else: Global Human Resources
Validation Type Table
Value Data Type Character
*FROM Clause fnd_setid_sets_vl
*Value Column Name set_code
Description Column Name set_name
ID Column Name set_id

WHERE Clause
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Creating a Profile

= ORACLE

Edit Value Set: HCM_WACS_JOB_SET_VS @

Value Set Code MM _WACS

Data Security Rescurce Name

Definition

HCM_WACS_LEGISLATIVE_GROUP_VS

1. Create a new value set.
2. Enter details for the value set.

3. Navigate to Setup and maintenance > Search > Manage Value Sets for Global
Human Resources (Workforce Structures).

4.  Create new value set and provide the details as below.

*Value Set Name HCM_WACS_LEGISLATIVE_GROUP_VS

Description HCM: WACS LEGISLATIVE GROUP Names

* Module Global Human Resources

Validation Type Table

Value Data Type Character

*FROM Clause (SELECT DISTINCT legislation_code FROM
per_legislative_data_groups_vl)

*Value Column Name legislation_code

Description Column Name legislation_code

ID Column Name legislation_code

WHERE Clause
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Extract Upload

Extract Upload

Edit Value Set: HCM_WACS_LEGISLATIVE_GROUP_VS @

Value Set Code HCM

Description | HCA
" Module | Gick
Validation Type Tate

Vabue Data Type  Chacacter

Data Security Resource Name

Definition

" FROM Clause | (SELECT DISTINCT legislation_tode FROM per_legslative_data_groups_i
Vabue Attributes Table Alias

* Value Column Name
Value Column Type VA

Value Column Length 30

Description Column Name

Description Column Type VAR

Description Column Length 30

Make sure to upload the extract after all the configuration are done for all the Employee/
Craft/Absence sections.

Important! Verify that Profile, Value sets and Fast formula are uploaded before running
the extract upload process.

To extract the upload:

1.

Login with the HCM/Data Exchange user role.

2. Navigate to My Client Groups and click Data Exchange.

Tima Management

Employee Integration 2 - 10
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Extract Upload

3. Click Extract Definitions.

HCM Extracts

@ View Extract Results
@ Extract Definitions
o Refine Extracts

Submit Extracts
@ View User Entity Details

4. Select Upload and click Browse.
5. Upload the extract file “HCM_EMP_WACS”. The file is available in the package.

= vision D % P OL® e

< Extract Definitions ®

Q| ShowFilters
+ L import

HCM Data Loader Data Set Summary Type HR Archive
Last Saved 7/28/20 320 PM

6. Compile the extract. After successful compilation, click Validate.
7. Save the extract.

8. Click the edit icon (a pencil) to query the extract.

vision CE P OL® o

Extract Definitions @

HCM_EMP_WACS x [ showriters
L import Sort By
ansxmE® /=

Last Saved 10/7/207:29 AM

9. Navigate to Advanced and click Extract execution Tree on the left navigation
pane. When the status is green, validate it. Save and close.

= vision ) & e et

Edit Extract Definition: HCM_EMP_WACS1@ . Corcel

Hisrarchy
view v
4 s
‘Session Effective Date  1/1/2000 G © The data gr hierarchy structure in the extract HCM_EMP_WACS1 is valid.
8 jcn Ep wacs )
& View » Format v Export XML Schema C Fe a Validate ¥ ) Refresh &7 Detach
4 D Giowp
4 upovee pETALS Object Name e awmg  swws

B person de Exdract Definition HCM_EMP_WAC

Assig etaits
Bl wORK ADDR DETAILS

DamGiowp  EMPLOYEEDE

Person_delaits Recors PERSON_DETA Fast Fomuia
B Managers Detals 0 erson_ce o - <l
4@ WORK ADDR DETAILS Assignment_Details Recors ASSIGNMENT [ FastFomuia €|
Person Work Address Recora WORK_ADDR { FastFomua @
4 MANAGERS DETAILS
DataGrow  WORK ADDR €
B MANAGER DETAILS » CADDR ¢
4 rery Options Person_Work_Address Record PERSON_WOR} FastFomula @]
s 4 Managers Detais Recora MANAGER DET FastFomua g
8 fraract Becution Treq
4 MANAGERS_DETAILS DaaGiow  MANAGERS_DE
MANAGER DETAILS Recors MANAGER DET FastFomua €]

10. Click the extract definition.

vision

Extract Definitions @

HCM_EMP_WACST % |Q show Filters

+ L import !
HCM_EMP_WAC Type FullProfile

Last Saved 10/7/207:29 AM
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Extract Upload

11. Enter a definition to lock the extract. After successful lock, save and close.

= vision

HCM_EMP_WACS1: Define

TagName  HCMEMP_ WACS
Type Full Profile
Desgn Status Active
Valid Vi
& oen

Lock Definition ¥/

Description Employee Extract Bulk

Unlock Comments Extract Copled

¥
Show hidden parameters | | Show Basic View
Name Tag Name Data Type Display Format Description  Lookup Dispiay
Annual Rate Annual Rate Tt Value Set AnnualRate  HCM_WACS GET_PROFILE JOB_..  Mandatory
Delete Archive delete_archive Text Lookup Choice List  Delete Archive  ORA_PER_EXT_DELETE ARCHIVE  Yes
Effective Date Effective Date Date Effective Date Yes
Logal Entity Legal ntity Number Smart LOV Logal Entity Mandatory
Manager_Type Manager Type Tot Value Set Manager Type  HCM WACS MANAGER TYPEVS  Mandatory

To verify the Run page:

1. Review all the values and mandatory fields.

= vision
HCM_EMP_WACSE Define

I« 4 Extract A

Define TagName HCM EMP WACS
Type Full Profle
Status Active
Valid Valid

Design

& oewer
Lock Defnition

Description Employee Extract Bulk

Unlock Comments  Extract Copled

4 Parar
Show hidden parameters | | Show  Basic Vi
Name Tag Name Data Type Display Format
Annual Rate Annual_Rate Text Value Set
Text Lookup Choice List
Date
Legal Entity Number Smart LOV
Manager Type Text Value St

Del

Deseription

Effective Date
Legal Entity

Manager Type

Lookup
HCM_WACS GET_PROFILE_JOB_ANNUAL_HRS. VS

ORA_PER_EXT_DELETE ARCHIVE

HCM_WACS MANAGER TYPE VS

Display
Mandatory
Yes

Mandatory

-
e —

Mandatory

Note: The lookup values are also displayed in the Parameters section.
The Legal Entity is not attached to smart LOV.

To refine the extract, search for the extract and navigate to Parameters > Edit.

3. Click Legal Entity. Search and add the Legal Entity “LegalEmployerPVO” Smart

LOV.

vision

Payroll Flow Patter:

BaseFlowParameteriame.
errecTIve_DATE

LEGAL_EWPLOYER

XTRACT_NAME

_carEcoRY

PROGESS_GONFIGURATION_GROUP

51 HEM_EMP_ WACST

Basis Value

HOM_EMP W
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Extract Upload

4. Navigate to the Submit Extracts page and verify that the respective fields are
populated with the appropriate values.

< Data Exchange

E Fun Spreadsheet Data Loader

e Delete Spreadsheet Stage Table Data

5. On the Submit Extract Instance page, verify that the Manager Type, Legal
Entity and Annual Rate fields, under the Criteria section, are populated with values
in accordance with the configuration.

= vision o) DT o

Cancel

Submit Extract Instance
HCM_EMP_WACSY

“Extract Instance Name

Criteria

“Effective Date “Manager Type

@

midy
“Legal Entity *Annual Rate
Delete Archive

Crteria

Note: If the Legal Entity, Manager Type and Annual Rate ficlds are
empty, verify that the account accessing the data extract has privileges to
perform extract configuration and submit extract definitions.

After the report is submitted, report extract is available in UCM for the
Oracle Integration Cloud process.
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Chapter 3

Craft Integration

This chapter focuses on the overview and configuration for Craft/Jobs integration. It
includes the following:

* Integration Overview

*  Oracle Human Capital Management Cloud Configuration for Craft

Craft Integration 3 - 1
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Integration Overview

Integration Overview

Design

This section covers basic integration overview for Craft/Jobs integration. Oracle Human
Capital Management Cloud (Jobs) is the central repository for the Jobs records.

The key attributes are captured from Oracle Human Capital Management Cloud and
synced with Oracle Utilities Work and Asset Cloud Service using two modes:

*  Bulk (Initial Upload)
* Incremental Upload

This seamless integration between Oracle Human Capital Management Cloud and Oracle
Utilities Work and Asset Cloud Service helps to have the same Jobs and Grades rates
(summarized) defined across both platforms.

The goal of this integration is to create a central depository of Jobs in Oracle Human
Capital Management Cloud which is primarily mapped to Principle Craft in Oracle
Utilities Work and Asset Cloud Service. The integration has the ability to synchronize
crafts and related craft rates from Oracle Human Capital Management Cloud to Oracle
Utilities Work and Asset Cloud Service.

Bulk Upload

Bulk Upload will be an initial upload from Oracle Human Capital Management Cloud to
Oracle Utilities Work and Asset Cloud Service, where all Job/Craft information is
extracted in UCM using XML format through Data Exchange that is the inbuilt
functionality of ERP. The selection of the craft/jobs in the Oracle Human Capital
Management Cloud module is done using an extensible flexfeild that stores a value if it is
Oracle Utilities Work and Asset Cloud Service job or not. Only Active Jobs in the system
are part of the integration.

Incremental Update
The incremental upload will handle sync for a set of changes made within job
information.

The following functions are part of Jobs integration:

*  Add/update the Job record from the tabs in Oracle Human Capital Management
Cloud

* Information or rate change in Job
*  Active/Inactive of Job

Jobs extract report has the listed mandatory parameters (Job Set, Annual Rate and
Effective Date).

This report extract will have both Crafts and corresponding rates, which will be handled
in Oracle Integration Cloud using one service. (This is one-way integration from Oracle
Human Capital Management Cloud to Oracle Utilities Work and Asset Cloud Service.)
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Business Rules

The integration timeline needs to be decided by a business that can be scheduled
in the BI report setup. (Incremental report will take only the changes from last
run date - delta and new recozrds).

Filter criteria in Job extract:

L]

L]

Job-status is ACTIVE. (Bulk), INACTIVE/INACTIVE (Incremental)

Initial load, only active jobs are interfaced and incremental load both Active
and Inactive jobs are interfaced.

WACS JOB (Flextfield is set to YES)

Job Set (Based on Legislative Unit - can be global or specific to one
legislative unit): Mandatory

Effective Date: Mandatory

JOB HCM Extract extracts the data based on the effective date and need to be decided
before executing /scheduling the report.

Business Rules

Following are the business rules:

Craft rate is derived from the grades linked to Job.

If multiple rates (Houtrly, weekly, yearly, etc.) are attached to the single grade then
maximum annual factor (houtrly) grade is considered for the average calculation.

After the initial run, for all next report run:

Check if there is a change in Craft rate (If X=X go to step2, X [=X- Go to
Step3).

If no change = Effective date should be the same

If the rate is changed, update the rate with an effective date of the
assignment.

Sample Craft Rate
The craft rate will be average from all the average grades of the Job. In the following

example, the average rate will be 15, which will be sync to craft rate in Oracle Ultilities
Work and Asset Cloud Service.

Job1 Min Max Average
Gradel 10 14 12
Grade2 12 16 14
Grade3 14 18 16
Grade4 16 20 18
Craft Rate for WACS 15

Manual addition of expense account for Craft and attach at the craft level. This is
a prerequisite to the integration.
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Oracle Human Capital Management Cloud Configuration for Craft

Oracle Human Capital Management Cloud Configuration
for Craft

This section focuses on importing the files that come as a part of the package and
configuring them in the Oracle Human Capital Management Cloud environment for the

integration to run successfully. Make sure to follow the same sequence for successful
configuration.

The following topics are included:
*  Defining Extensible Flexfield
¢ Fast Formula

*  Business Intelligence Report Template for Job (Used in Data Exchange)

*  Extracting an Upload

Defining Extensible Flexfield

To define an extensible flexfield:
1. Navigate to Setup and Maintenance > Search.

2. Click Manage Workforce Structures Extensible Flexfields.

HCM_IMPL -~

Search Tasks Manage Workforce Structures Extensible Flexfi Q

Workforce Structures

View v Format w Freeze [u" Detach Wrap  Show ANl Tasks - El
Task Scope

Manage Workforce Structures Extensible Flexfields .-"'_":n-.—-= .

Manage Job Lookups for US

3. Click PER_JOBS_EIT_EFF.

= vision 2 Bt T OL® s

Manage Workforce Structures Extensible Flexfields
Actions ¥ View v rd 1. Detach

PER_IOBS_EIT_EFF P —]

4. Click the pencil icon to edit.

= vision
Manage Workforce Structures Extensible Flexfields (0 Oges.
Search Results G
Mewns v Vew v Fomatw S = Detach Deploy Flexield | Daploy Offine
Hame e Madite Fieafiald Cote Entty Usages  Description % Otfine status me

o EXT Infoerriaton Extensiie Flesbeld  Vork Struciures Job PER_JOBS_EIT_EFF =] The Job EIT informason - 0 swcoEw
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Defining Extensible Flexfield

5. On the Manage Workforce Structures Extensible Flexfields edit view, click
Manage Contexts.

= vision

HOM_IMPL

Category
View v Fommat v

Display Name

b Job Extra Informaton

4 : Details @

Associated Contexts  Foge

Actons ¥ View ¥ Format

Display Name

* Name Job EIT information

Description  The Job EIT Inf

Manage Workforce Structures Extensible Flexfields &

Flexfield Code PER_JOBS ENT_EFF Module otk Simctuses Jso

Application Gisbal Human Resources

Category Hisrarchy PER_JOB_EIT_EFF_CAT_HRCHY

< Deuch

Code Enabled Description

Jos €T -

vy X & ze o Detach

Job Extea information

Inherited  Protected  Assoclated Category

Behavior

Description

Manage Contexts  Save | Save and Close | Cancel

i

6. Click the add button (+).

= vision

Manage Contexts @
4
Flexfield Name  Job EIT Information
4 Search
Display Name. Enabled
Description Translaable
Code Usage
Behavior
Search Results
Actions w View w Fomatw . < Detaen
Display Name Code Enabled Protected
No search conducted

Behavior

Translatable Description

Flexfield Code

PER_JOBS_EIT_EFF

HCM_IMPL

Save | Save and Close| Cancel

Search  Reset

7. Add Context Usage and Add Context Sensitive Segments.
Flexfield Name: Job EIT Information
Flexfield Code: PER_JOBS_EIT_EFF
Display Name: WACS_JOB
Code: WACS_JOB
API name: WacsJob
Description: WACS JOB
Enabled: YES
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Defining Extensible Flexfield

9.

Instruction Help Text: WACS Job

Edit Context: WACS_JOB @

4

Flexfield Name Job EIT Informaior

* Display Name.

Code WACS_IOB
* APiname  WacsJob Instruction Help Text  WACS Job
Description WACS J0B

Context Sensitive Segments

@ | [seve] [5eve ana Closs ] [ganeet

Flefield Code  PER_JOBS_ENT_EFF

hciors v Veww Fomatw o+ £ K Dotsen
Sequence  Name Code Value Data Type  Display Type Value Set Default Type Default Value UOM Class Em
10 WACS_J08 WACS_108 Character List of Values s ot
« >
Context Usages
Actons ¥ View ¥ Fomal v Detach
Name View Privileges Edit Privileges
b None Hone
Edit Context: WACS_JOB @ @ | Save | SaveandClose | Cancel
4
Flexfield Name Job EIT Information Flexfield Code  PER_JOBS_EIT_EFF
* Display Name W Enabled
Code Behavior  Single Row
* API name Instruction Help Text
Description
Context Sensitive Segments
Actions v View v Fomatv Detach
Sequence  Name Code Value Data Type  Display Type  Value Set DefaultType  Default Value UOM Class =
ContextUsages  Associated Categones  Associated Pages
Acions v Viewv Fomatv 4 X Detach
Name View Privileges Edit Privileges
Job v None v None v

Navigate to Context Sensitive Segments and click the add button (+) to add a

segment. Fill the data as shown below.
Name: WACS_JOB

Code: WACS_JOB

API Name: wacs]Job

Data Type: Character

Value Set: Yes or No

Prompt: WACS_]JOB

Display Type: List of Values
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Defining Extensible Flexfield

BI Enabled: Yes

Dats Type

Table Codamn

* Value S0t

e 5ot Description

Farge Type w

Datautt Type -

* Display Type | List of Vais. - Definition Help Tant

Dvnplay Sizw
Inatruction Melp Text

Display Height

10. Click Save and Close.

Edi Context WACS_JOB @ | ten | e wea ]

Eose Vit DataType  Conpley Trpe  Vas S0 e [ e —

11. Select the seatch result and click the add button (+).

Manage Workforce Structures Extensible Flexfields @

" Application  Giabal Human Rescurces

Mame

Modue VW

Flexfield Code P

Categary Hierarchy

Description | The Jeb EIT Information
Category
View v Format w Detach
Display Name Code Enabled Description
P Job Extra information JOB_EIT v Job Extra Information

4 Job Extra Information: Details 3

Associated Contexts  Fages

Acions v View w Formatw 50 [ Detach
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Defining Extensible Flexfield

‘Select and Add: Contexts.

4 Search
Nome
Descnpton

ContextCade WACS

Context
Name Conte Enabled Behavior Transiate Description

WACSJ0B  WACSOB Yes  Sege. No  WACSJOB

(o] (o] [

12. Search for “WACS_JOB”. Click Apply and then OK. The Associate page is shown
as below after the Associated context is attached.

13. Click Save and Close.

14. Deploy Flexfield as shown below and make sure that the deployment status is

highlighted in green.
Manage Workforce Structures Extensible Flexfields @ Dane |
Search Results 0
Actons ¥ Vew ¥ Famiw  F Frosze n' Dutseh Vs | Degloy Flacheld || Cuploy Offine | Cancel Offine
Mo
[ o BT inrmaion Exonable Flestield  Work Stnctures Job PER_IOBS_E_EFF a The Job EIT iormation v :Q B0 123 P

To attach an EFF to a job in ERP:
1. Query any job that needs to be attached. Filter WACS JOB and attach EFF.

2. Navigate to Setup and Maintenance > Search > Manage Jobs.

Search Task Results

Task Functional Area
Manage Job Lookups for US. Worklorce Structures.

Manage Job Lookups for France. Wordorce Structures.

Manage Job Lookups Worklorce Structures.

Hanage Job Famiies Workdorce Structures.
Manage Job Workforce Structures.

Manage Job Roles Users and Securty
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Fast Formula

3. Query the Required JOBS.

= vision

Manage Jobs ®

** Name
* Code JOBOOG

Sutus Active

4 Search Result:

View v Formatv < Create ./ Edit

v 57 Bport | Manage in Spreadsheet

Job Sat

Effective As-of Date m/d/yy

Name. Code Job Set Status Z'h':;‘; Job Family Job Function  Management
Analyst Associate J0B0OS Common Set Active No Professional Administrative  Non-manage

Advanced | Saved Search

HCM_IMPL

Active Jobs

* Atleast one is required

o

| search | Reset | save..

4. Click the job name and edit it.

= vision

Job: Analyst Associate - JOB006

Effective Start Date /20,20
Effective End Date

Job Details Evaluation Criteria  Profiles

4 Basic Details @

Effective Start Date 6/29/20
Effective End Date

4 Job Description
Name
Code
Status Active
Full Time or Part Time

Analyst

Regular or Temporary Requl
Job Family Pro
Job Function Ad

Level

JOB00G

Full time

Associate

Context Value

Job Set Common Set
Action Reason

Job Set Common Set

Management Level Non-manager
Medical Checkup Required No
Benchmark No
Benchmark Job
Progression Job
Attachments None
Grade Ladder

HCM_IMPL.

Done

Edit ¥ View History

5. Click WACS Job and select Yes from the LOV.

CBO Occupation

WACS JOB Vs -:'_"_3:

4\alid Grades
Format »
*Grade

Admin01

Grade Code  Set Name

ADMINGT Common Set

6. Click Done.

JOBO006 is displayed in the Bulk extract or Incremental (if any changes).

Fast Formula

To use the Fast Formula file from the package available for Job extract:

1. Navigate to Setup and Maintenance > Search > Fast Formulas.
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Business Intelligence Report Template for Job (Used in Data Exchange)

2. Enter Formula Name, Type and Description from the package (refer to the
accelerator package on Market Place). Click Continue.

3. Take the text file HCM_WACS_JOB_RATE_FF.txt) from the accelerator package
and paste its code to Fast Formulas.

Formula Name: HCM_WACS_JOB_RATE_FF

Type: Extract Rule

Effective Start Date: 1/1/51

Description: HCM: WACS JOB Rate Calculation
4. Save it and click Compile.

vision

5. Make sure the Compile Status shows a green icon with a check-mark.

Business Intelligence Report Template for Job (Used in Data Exchange)

This template is used in data exchange to calculate the average rate of the job using the
midpoint of multiple grades attached to it. For more information, refer to the Business
Rules section.

Use the “.xdo.calatalog” file from package to a specified folder: Shared > Custom >
HCMJOBWACS
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Business Intelligence Report Template for Job (Used in Data Exchange)

Migrating Reports in Oracle Cloud Instance

The migration process involves un-archiving the report and data model.

To migrate reports in Oracle Cloud Instance:

1. Navigate to Tools > Report and Analytics.

2. Browse to the folder where the report and data model is placed.

3. Create a “HCMWACSJOB” folder in Shared Folder > Custom Folder (the name

cannot change).

ORACLE Transactional Business Intelligence
Catalog
uservieww llsw O [ R4
4 Folders Bl Treean
¥ _IZI Drafts L4
b Shared Foiders Expand
==| My Dashh

4. Use the files in the package with an extension of “xdo.catalog”.

5. Un-archive the report and data model.

ORACLE Transactional Bu

Catalog
Uservieww Jlow & ™
4 Folders Eb T

6. Un-archive files in the new instance.

a.  Navigate to the folder where the report should be uploaded.

b. Click Unarchive in the Tasks pane.

c. The system prompts to browse and upload the file from your desktop. Make sure

to select the “.xdo.catalog” file for the report.

ORALCLE Trnssctions Business Intsibgence
Catalog

4 Folgers Bl T  Sert ame AZ

varvewy e G B v X & Lesaton /Shived Foidery CauslomHCMIOBWACS

fr  HCMJOBWACSXSL Law Vooted 112420 306 PM  Oweer MCM_APL
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Extracting an Upload

Extracting an Upload

To extract an upload:

1.

3. Upload the extract file “HCM_JOB_WACS”.

Navigate to Tools > Report and Analytics > Data Exchange > HCM Extract.
2. Click Upload and Browse.

“—
"\’ Home
Sales
Service

Me
Procurement

My Client Groups

13 Hiring

;:.';_r." Person Management

%@ Goals

:‘ Career Development
Learning

| Payroll

5 Data Exchange

iF Onboarding

Absences

Performance

__{_ Talent Review

# Workforce Struciures

Y Workforce Medeling

F  Volunteering

New Person

» Time Management

Profiles

= Succession Plans

Mass Updates

| Workforce Predictions

| Personal Brand Administration

M E

View Extract Results
@ Extract Definitions
o Refine Extracts
)
[}

a Submit Extracts

View User Entity Details

= vision QB % P L™ e

< Extract Definitions ®

Q| showFiters
+ L import Sorty

HCM Data Loader Data Set Summary Type HR Archive

Last Saved 7/28/20 320 PM

Click Compile and Validate.

Query the extract. Navigate to Advanced and click Extract Execution Tree.
After the Compile Status is green, click Save and Close.

Click the extract definition. Lock and save it.

Check all the value sets and mandatory fields are set.

Y ©® N s

Click the name of the extract.
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Extracting an Upload

10. Check if the Run screen is populated with the appropriate values in the respective
fields.

11. On the Submit Extracts page, search for the job extract.

HOMMPL

= vision

Submit Extracts

Legistative Data Group

Extracts

HCM JOB WACS Q

HCM _JOB WACS

12. Click the Extract Name and verify the Legislative Group and Job Set values.

= vision

< Submit Extract Instance
HCM_JOB_WACST

Extract Name. “Bxtract Instance Name.

“Eftective Date “Legistative Group

3
&

Changes Only

Baseline Only
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Chapter 4

Employee Unavailability Integration

This chapter focuses on the overview and Oracle HCM Employee Unavailability
integration. It includes the following:

* Integration Overview

*  Oracle HCM Cloud Employee Unavailability
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Integration Overview

Integration Overview

Design

This section provides an overview of Oracle Human Capital Management Cloud absence
integration to Oracle Ultilities Work and Asset Cloud Service (Employee Unavailability).
It focuses on integration requirements and the business standpoint of the functionality.

*  Syncabsence from Oracle Human Capital Management Cloud to Oracle Utilities
Work and Asset Cloud system for employees

Oracle Cloud Absences Integration to Oracle Utilities Work and Asset Cloud provides
the features to satisfy the following basic business needs.

This seamless integration between Oracle Human Capital Management Cloud and Oracle
Utilities Work and Asset Cloud helps to have the same Employee absence across both
platforms.

The integration will support Bulk upload and incremental updates to Oracle Utilities
Work and Asset Cloud Service.

The scope of the absence integration is bulk data (initial) and incrementally based on the
following approach. Bulk data is part of initial run and changes are synchronized using
the incremental flow (changes/new/updated).

*  External Leave Details (Sick, Vacation, and so on) are integrated to Oracle
Utilities Work and Asset Cloud system. This type of leave would mean the
employee is not available to assign an activity in Oracle Utilities Work and Asset
Cloud Setvice.

Internal Absence details are handled in Oracle Utilities Work and Asset Cloud Service:
Training, Meeting, and more.

Oracle Human Capital Management Cloud passes the completed leaves in case an
employee applies in the system after taking leave. Example: An employee returning after
a sick day can also apply for leave which will be sent to Oracle Utilities Work and Asset
Cloud Setrvice.

Filter selection while data extract:

*  Level 1: Filter for Employee and Employee Unavailability extract will be the
same, based on Legal Entity.

*  For Bulk and Incremental “Approved (Scheduled and In progress)” absence
status would be filtered.

*  The status will need to be mapped in DVM with the Oracle Utilities Work and
Asset Cloud corresponding status.

When an employee applies for leave in Oracle Human Capital Management Cloud, the
system generates a Unique Absence ID for the record. Incremental will capture new
Absence and also record changed for existing approved absence data.
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Business Rules

Business Rules

Bulk Upload
Oracle HCM Absence Data (Bulk)

Bulk Absence data will be interfaced from Oracle Human Capital Management Cloud to
Oracle Utilities Work and Asset Cloud so that the Oracle Utilities Work and Asset Cloud
Service team can plan and assign the tasks accordingly to the employee/workers.

Incremental Update
Oracle HCM Incremental (Delta)/Changes

Incremental Absence data is be interfaced form Oracle Human Capital Management
Cloud to Oracle Utilities Work and Asset Cloud so that the Oracle Utilities Work and
Asset Cloud Service team can plan and assign the tasks accordingly to the employee/
workers.

The incremental update will use same extract used for bulk but with different parameter
to interface the delta data based on the last run date and time. Any change from that will
be captured in the new Extract.

Following are the business rules:

*  Oracle Human Capital Management Cloud (Data Exchange) should be available
for the absence design/extract/schedule.

*  Oracle Integration Cloud should be available for the integration activities.

*  Oracle Utilities Work and Asset Cloud Service system should be up and running
for the interface and validate the absence data.

¢ Oracle Utilities Work and Asset Cloud Service team should have other tools/
reportts to validate the interfaced data.

Oracle HCM Cloud Employee Unavailability

This section focuses on importing the files that come as a part of the package and
configuring them in the Oracle Human Capital Management Cloud environment for the
integration to run successfully. Make sure to follow the same sequence for successful
configuration.

Extract Name: HCM_ABS_WACS
Integration Name: HCMABSWACS

Extracting an Upload

To extract an upload:
1. Navigate to the Oracle Human Capital Management Cloud Extract page.

2. Click Upload and browse to the folder.
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Verifying the Run Screen

3. Upload the extract file “HCM_ABS_WACS”.

&« E
) Home

Sales -
Service -
Me v
Procurement v

My Client Groups

G g iy Onvowsng S Newpssson

(¥ Person Management | Absences fg Tme Management

%) Gost Pedomance ) Prosies

% Carser Deveiopment B TasnResion = Succassion Plans

©) Leaming Workiorce Stucires B Mass Updates
Payrl 2 Modeing () Workdorcs Prodictions

> Data Exchange ) Personal Brand Administration

HCM Extracts

View Extract Results

@

Extract DLTlnltans

a Refine Extracts

a Submit Extracts

@ View User Entity Details

e meL

= vision

< Extract Definitions ®

Q) showFiters
+ & import

HCM Data Loader Data Set

4. Query the extract. Navigate to Advanced > Extract Execution Tree > Compile.

5. Verify that the Compile Status shows a green icon with a check-mark. Save and
close.

6. Lock the extract definition.

Verifying the Run Screen

To verify the Run screen:
1. Check that all Value Sets and Mandatory ficlds are set.

2. Click on the extract name.

= vision

< Extract Definitions @

HCM_ABS WACS X |9 ShowFilers
+ L impont sonty
HCMABS. WACS Type Full Profle
AReXBR/E

Last Saved 10/7/20 453 AM
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Verifying the Run Screen

3. Check that all values are populated on the Run screen. Verify that the legal entity row
is populated with the correct values.

= vision

HCM_ABS_WACS: Define

Unlock Comments  HCM IMPL 07-Oct-2020 HCM IMPL 06-

Lock Definition '
Description

Show hidden parameters | Show Basic View

Data Type Display Format Description  Lookup Display

Text Lookup ChoiceList  BaselineOnly  YES.NO

PER_EXT_CHANGES ONLY

Mandatory

4. On the Submit Extracts page, search the Job Extract.

vision

Hw_ e

Submit Extracts

Legisiative Data Group

Extracts
HCM_ABS WACS

HCM_ABS WACS

5. Click on the extract name. Validate the Legislative Group and Job Set values.
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