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Preface

This preface contains the following sections:

• Documentation accessibility

• Related resources

• Diversity and Inclusion

• Access to Oracle Support

• Additional copyright information

Documentation accessibility
For information about Oracle's commitment to accessibility, visit the Oracle
Accessibility Program website at http://www.oracle.com/pls/topic/lookup?
ctx=acc&id=docacc.

Related resources
All documentation and other supporting materials are available on the Oracle Help
Center.

Diversity and Inclusion
Oracle is fully committed to diversity and inclusion. Oracle respects and values having
a diverse workforce that increases thought leadership and innovation. As part of our
initiative to build a more inclusive culture that positively impacts our employees,
customers, and partners, we are working to remove insensitive terms from our
products and documentation. We are also mindful of the necessity to maintain
compatibility with our customers' existing technologies and the need to ensure
continuity of service as Oracle's offerings and industry standards evolve. Because of
these technical constraints, our effort to remove insensitive terms is ongoing and will
take time and external cooperation.

Access to Oracle Support
Oracle customers that have purchased support have access to electronic support
through Support Cloud.

Contact our Oracle Customer Support Services team by logging requests in one of the
following locations:

• English interface of Oracle Health Sciences Customer Support Portal (https://
hsgbu.custhelp.com/)
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• Japanese interface of Oracle Health Sciences Customer Support Portal (https://hsgbu-
jp.custhelp.com/)

You can also call our 24x7 help desk. For information, visit http://www.oracle.com/us/support/
contact/health-sciences-cloud-support/index.html or visit http://www.oracle.com/pls/topic/
lookup?ctx=acc&id=trs if you are hearing impaired.

Additional copyright information
This documentation may include references to materials, offerings, or products that were
previously offered by Phase Forward Inc. Certain materials, offerings, services, or products
may no longer be offered or provided. Oracle and its affiliates cannot be held responsible for
any such references should they appear in the text provided.
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1
Architectural overview of the environment

In this chapter:

• Introduction to the Oracle Central Designer software

• Physical architecture

• Web farm capabilities

Introduction to the Oracle Central Designer software
The Oracle Central Designer software consists of:

• Oracle Central Designer server application—Communicates with the client
applications through web services.

• Oracle Central Designer client application—Provides a collaborative environment for
designing clinical studies and deploying them to the Oracle InForm application.

• Oracle Central Designer Administrator client application—Provides an environment
for setting up administrative information, such as users, roles, and system configuration
information.

Physical architecture
The physical configuration of the Oracle Central Designer software includes:

• A database server machine.

• One or more application server machines. For more information, see Web farm
capabilities.

• One or more client machines.

There are three configuration options for the Oracle Central Designer software.

Configuration Description

Single-tier The application server, database server, and client
applications run on the same machine.

Two-tier The application server and database server run on
the same machine, and the client applications run
on another machine.

Three-tier The database server, application server, and client
applications each run on a separate machine.
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Note:

• For optimum performance, Oracle recommends a three-tier
configuration.

• If the application server and database server are on the same computer,
you must install the Oracle Server software and Oracle Client software in
the same home.

Web farm capabilities
You can expand the performance capabilities of the Oracle Central Designer
application server by adding multiple servers in a farm configuration. This configuration
is called a web farm. A web farm setup distributes requests from the client applications
among multiple application servers. A web farm is useful for the following reasons:

• A large number of requests that might impact performance can be spread out
among multiple application servers, thus improving performance.

• Multiple application servers allow for redundancy and failover protection.

In a web farm configuration, all application servers can process any request. However,
certain operations are run asynchronously using the Oracle Central Designer Job
Scheduler. The Job Scheduler is installed on every application server, but only one
Job Scheduler can process jobs, and only one service is enabled to process requests.
The Job Scheduler service that processes all requests is called the primary Job
Scheduler. You can change the primary Job Scheduler at any time. Oracle
recommends setting the Job Scheduler on the most powerful machine in the web farm
as the primary.

Chapter 1
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Note:

You must use the same port number, which you specify during installation, for all
application servers within a web farm. If one of the application servers uses a
different port number, the Job Scheduler will not work if the machine is set to run
the primary Job Scheduler. By default, the port number is 53000.

For more information, see:

• Illustration of a web farm configuration

• Information that is stored in the database

• About adding application servers

• Managing web farm capabilities

Illustration of a web farm configuration
The following tasks are performed in a web farm configuration:

• The client applications send requests through a firewall to a load balancer. The load
balancer distributes requests among application servers.

• The job scheduler services on all of the application servers run; however, only the
primary job scheduler processes requests. The other job scheduler services do not
accept any requests. Examples of tasks that require the job scheduler service include
importing and validation.

• All tasks that do not require the job scheduler service are distributed among the
application servers.

Chapter 1
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Information that is stored in the database
Units information and report definitions are stored in the database and are used by all
application servers in a web farm.

• You can export the units information to a file and then modify and import the file.
You perform this task in the Oracle Central Designer Administrator application.

• If you have created custom reports, you must back up the Report configuration
section of the DesignerWebServices.config file before upgrading and then
import it into the database.

For more information about working with this information, see the Administrator Guide.

About adding application servers
You can add additional application servers to a web farm environment at any time,
even if you did not configure your first application server to support a web farm.

When you install a second application server, the installation recognizes the existing
application server installation. The Job Scheduler service on the existing application
server is set as the primary by default, but you can set the Job Scheduler for the
second (or higher) application server as the primary during the installation of its
application server.

You install additional application servers the same way that you install the first
application server. The installation process configures the application server
computers as a web farm. For more information, see Installing the Central Designer
application server.

Managing web farm capabilities
After a web farm is installed, you can manage it using the Oracle Central Designer
Administrator software. You perform the following tasks in the Oracle Central Designer
Administrator software:

• Viewing the servers that are in the web farm.

• Determining and changing the primary job scheduler.

• Working with Event Log messages for the web farm, including:

– Viewing the messages.

– Changing the default limit for the number of entries in the log.

– Deleting all entries in the log.

• Modifying the file for report definitions.

• Modifying units information.

For more information, see the Administrator Guide.

Chapter 1
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2
Checklists for software installation

In this chapter:

• Checklist—Planning the server installation

• Checklist—Planning the client installations

Checklist—Planning the server installation
Use the following checklist to help plan the Oracle Central Designer application server and
database server installations.

1. Determine if the setup is single-tier or multi-tier.

For more information, see Physical architecture.

2. Make sure all system requirements, including .NET Framework requirements, have been
met for the application server.

For more information, see:

• Application Server requirements in the Oracle Central Designer System requirements
guide.

• Verifying that all required IIS roles are installed.

• Verifying that the correct version of Microsoft .NET Framework is installed.

3. Make sure all system requirements, including required Oracle database parameters,
have been met for the database server.

For more information, see:

• Database Server requirements in the Oracle Central Designer System requirements
guide.

• Install the Oracle database software on the database server.

4. Register the .NET assemblies to the Global Assembly Cache (GAC).

For more information, see:

• Registering .NET assemblies.

• Database patch Release Notes.

5. On the database server, create the database and tablespaces.

The database and tablespaces must be created prior to installing the Oracle Central
Designer software. For more information, see Create the database and tablespaces.

6. On the database server, configure the Open Cursors setting.

For more information, see Configuring the Open Cursors setting for a database instance.

7. On the database server, configure the Cursor Sharing setting.

For more information, see Configuring the Cursor Sharing setting for a database
instance.
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8. On the database server, grant the appropriate rights to database administrators.

For more information, see Required rights for database administrators.

9. On the database server, create the Oracle Central Designer database user.

For more information, see Creating the Oracle Central Designer database user.

10. Configure the application server for optimal performance.

For more information, see Configuring the application server for optimal
performance.

11. On the database server, configure the listener to accept connections for the new
database.

For more information, see Configuring the listener to accept connections for the
new database.

12. Determine the security level to be used for communication between the client
applications and the application server.

For more information, see Securing communication with Transport Layer Security
(TLS).

13. Determine if you will implement a web farm.

For more information, see Web farm capabilities.

14. Increase the default value of the MS DTC timeout on the application server.

For more information, see Increasing the Microsoft Distributed Transaction
Coordinator timeout.

15. Monitor the tablespace in the database.

If the tablespace becomes full, expand the tablespace by adding another data file.

16. Make sure that the IIS Admin Service and World Wide Web Publishing Services
are running.

If the services are not running, the installation fails. The IIS Admin Service does
not have to run for the duration of the installation. However, you must start it
before you click the Next button on the Copying Files screen.

Note:

Do not use the iisreset command from the MMC or a command prompt
after the installation or upgrade completes, or the IIS settings that were
set by the installer are lost. Instead, use the net start command to start
the services.

17. Install a certificate for signing web service authorizations, and a certificate for
signing deployment packages and Oracle InForm web service authorizations.

For more information, see Installing certificates for signing web service
authorizations and deployment packages.

18. If necessary, install the root certificate and intermediate certificate or certificates,
and install the main certificate as the root certificate.

For more information, see:

• Installing root and intermediate certificates.

Chapter 2
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• Installing the main certificate as the root certificate.

19. To secure the web server and prevent clickjacking on the http://<server name>/
CentralDesignerInstall page, from which you install the Oracle Central Designer and
Oracle Central Designer Administrator applications, configure the HTTP response header
in IIS.

For more information, see Configuring the IIS HTTP response header setting.

20. If you perform automated deployments to Oracle InForm studies hosted by Oracle, make
sure the Microsoft Windows setting Automatic Root Certificates Update is turned on.

Automatic Root Certificates Update is turned on by default in Microsoft Windows 2019.
For more information, see the Microsoft website (http://technet.microsoft.com).

21. Install the application server.

For more information, see:

• Installing the Oracle Central Designer application server.

• Performing a silent installation.

22. Configure SMTP settings for sending email notifications related to automated deployment
events.

For more information, see Configuring SMTP settings for automated deployment email
notifications.

23. Verify the installation of the application server.

For more information, see Verifying the installation of the application server.

Checklist—Planning the client installations
Use the following checklist to help plan the installations of the client applications.

The Oracle Central Designer and Oracle Central Designer Administrator applications are
ClickOnce applications. You start a ClickOnce application by clicking a link from a Microsoft
Edge window.

When you click a link for either application, the Oracle Central Designer server checks
whether the release that is installed on the server matches the files that are cached on your
computer:

• If the server has been newly installed or has been upgraded after your last logon, the files
that are necessary to run the application are cached on your computer, and then are
used to open the application.

• If the server has not been updated since your last logon, the cached files on your
computer are used to open the application.

1. Make sure all system requirements, including .NET Framework requirements, have been
met for the client computers.

For more information, see:

• Oracle Central Designer System requirements guide.

• Verifying that the correct version of Microsoft .NET Framework is installed.

2. For clients using Microsoft Edge browser version 79 or later, enable ClickOnce support.

For more information, see Enabling ClickOnce support for Microsoft Edge version 79 or
later.

Chapter 2
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3. Make sure the clocks on the application server computer, database server
computer, and client computers are synchronized.

For more information, see Synchronizing clocks on server and client computers.

4. Start the client applications.

For more information, see:

• Starting the Oracle Central Designer client application.

• Starting the Central Designer Administrator client application.

Chapter 2
Checklist—Planning the client installations
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3
Planning your installation

In this chapter:

• Installing certificates for signing web service authorizations and deployment packages

• About installing root and intermediate certificates

• Verifying that all required IIS roles are installed

• Verifying that the correct version of Microsoft .NET Framework is installed

• Enabling ClickOnce support for Microsoft Edge version 79 or later

• Synchronizing clocks on server and client computers

• Hardware networking switches

• Configuring the IIS HTTP response header setting

• Configuring the application server for optimal performance

• Enabling TLS 1.2 for .NET Framework on Central Designer application servers

Installing certificates for signing web service authorizations and
deployment packages

Note:

When creating a private key for the Oracle Central Designer certificate, allow for all
key usage purposes, such as digital signature, key encipherment, and data
encipherment. If you do not do this, the Job Scheduler issues a Bad key error when
it starts, and the same error appears in Oracle Central Designer when accessing
objects.

You must install a certificate for each of the following purposes:

• Signing the web service authorizations.

• Signing deployment packages and Oracle InForm web service authorizations on the
Oracle Central Designer server.

Oracle recommends using certificates issued by trusted commercial Certificate Authorities.

Install certificates to the LOCAL_MACHINE\MY store. Each certificate in the certification path
must be 2048 bytes. For more information about converting existing certificates, see the
Microsoft support website.

For each certificate:

1. Open a command prompt window.
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2. Run the following command:

certutil -f -importpfx -csp "Microsoft Enhanced RSA and AES 
Cryptographic Provider" <full path to the pfx file> NoExport

3. Enter the password for the PFX file, and press Enter.

The Oracle Central Designer installation process grants Full Control to access the
certificate private keys to the IIS AppPool\DefaultAppPool user and the NETWORK
SERVICE user.

If a user other than the IIS AppPool\DefaultAppPool user is running the
DefaultAppPool application pool, you must grant the user Full Control to access the
private keys, or the user is unable to sign using the certificates. This content is used in
the STEP Certificate for web service authorizations topic.

To grant a user other than IIS AppPool\DefaultAppPool Full Control to the
private keys, for each certificate:

1. Select Start, enter mmc, and press Enter.
The Microsoft Management console appears.

2. Select File > Add/Remove Snap-in.
The Add or Remove Snap-ins dialog box appears.

3. In the list of available snap-ins, select Certificates.

4. Click Add.
The Add dialog box appears.

5. Click Computer account.

6. Click Next.

7. Click Local Computer.

8. Click Finish.

9. Click OK.

10. In the left pane of the console, select Certificates (Local Computer) > Personal
> Certificates.

11. Right-click the certificate and select All Tasks > Manage Private Keys.

12. Click Add > Locations, and then select the computer name.

13. Click Advanced > Find Now, select the user, and grant them Full Control.
If the user does not appear in the search results, type the user name in the Select
Users or Groups dialog box.

14. Click OK.

About installing root and intermediate certificates
You might need to install additional certificates for the following situations:

• When the main certificate you installed contains an intermediate certificate, a root
certificate, or both in its certification path.

Chapter 3
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• When the PFX file you imported contains an intermediate certificate, a root certificate, or
both embedded within it. In this case, the certificates might not have been installed in the
correct locations.

For more information, see:

• Determining whether to install additional certificates

• Installing root and intermediate certificates

• Installing the main certificate as the root certificate

Determining whether to install additional certificates
To check whether you need to install the additional certificates, double-click the main
certificate and select the Certification Path tab. If you see:

• Three or more certificates―Install the root certificate and one or more intermediate
certificates.
For more information, see Installing root and intermediate certificates.

• Two certificates―Install the root certificate.
For more information, see Installing root and intermediate certificates.

• One certificate―Install the main certificate from the PFX as the root certificate.
For more information, see Installing the main certificate as the root certificate.

Installing root and intermediate certificates
Perform this procedure for both the root certificate and one or more intermediate certificates.

1. Open the Microsoft Management console:

a. Open a Command Prompt window.

b. Enter mmc, and then press Enter.

2. Select File > Add/Remove Snap-in.

The Add or Remove Snap-ins dialog box appears.

3. From the list of available snap-ins, select Certificates.

4. Click Add.

The Add dialog box appears.

5. Click Computer account.

6. Click Next.

7. Click Local Computer.

8. Click Finish.

9. Click OK.

10. In the left pane of the console, select Certificates (Local Computer).

11. Click the Personal folder.

12. Double-click the main certificate you previously imported and select the Certification
Path tab.

13. Do one of the following:

Chapter 3
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• To install the root certificate, double-click the root certificate.

• To install the intermediate certificate, double-click the intermediate certificate
and select the Details tab.

14. Click Copy to File and do the following:

a. Deselect Do not export the private key.

b. Select the default file type.

c. Select DER encoded binary.

d. Navigate to the location in which to save the certificate.

e. Click OK.

15. In the left pane of the console, select one of the following:

• If you are installing an intermediate certificate, select Intermediate
Certification Authorities.

• If you are installing the root certificate, select Trusted root Certification
Authorities.

16. Right-click the Certificates folder and select All Tasks > Import.

The Certificate Import Wizard appears.

17. Click Next.

18. Select the CER file for the certificate you are installing, either the intermediate or
root certificate.

19. Click Next to accept the default options for the remaining wizard pages.

Installing the main certificate as the root certificate
1. Open the Microsoft Management console:

a. Open a Command Prompt window.

b. Enter mmc, and then press Enter.

2. Select File > Add/Remove Snap-in.

The Add or Remove Snap-ins dialog box appears.

3. From the list of available snap-ins, select Certificates.

4. Click Add.

The Add dialog box appears.

5. Click Computer account.

6. Click Next.

7. Click Local Computer.

8. Click Finish.

9. Click OK.

10. In the left pane of the console, select Certificates (Local Computer).

11. Click the Personal folder.

12. Double-click the main certificate you previously imported and select the
Certification Path tab.

Chapter 3
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13. To install the main certificate as the root certificate, double-click the main certificate.

14. Click Copy to File and do the following:

a. Deselect Do not export the private key.

b. Select the default file type.

c. Select DER encoded binary.

d. Navigate to the location in which to save the certificate.

e. Click OK.

15. In the left pane of the console, select Trusted root Certification Authorities.

16. Right-click the Certificates folder and select All Tasks > Import.

The Certificate Import Wizard appears.

17. Click Next.

18. Select the CER file for the root certificate.

19. Click Next to accept the default options for the remaining wizard pages.

Verifying that all required IIS roles are installed
1. Select Start > Apps > Server Manager > IIS.

2. Under Roles and Features, make sure the following Web Server (IIS) roles required by
Oracle Central Designer are installed:

Web Server

• Web Server\Common HTTP Features

• Web Server\Common HTTP Features\Default Document

• Web Server\Common HTTP Features\Directory Browsing

• Web Server\Common HTTP Features\HTTP Errors

• Web Server\Common HTTP Features\Static Content

• Web Server\Application Development

• Web Server\Application Development\.NET Extensibility 4.7 or higher

• Web Server\Application Development\Application Initialization

• Web Server\Application Development\ASP

• Web Server\Application Development\ASP.NET 4.7 or higher

• Web Server\Application Development\CGI

• Web Server\Application Development\ISAPI Extensions

• Web Server\Application Development\ISAPI Filters

• Web Server\Application Development\Server Side Includes

• Web Server\Health and Diagnostics

• Web Server\Health and Diagnostics\HTTP Logging

• Web Server\Security

• Web Server\Security\Request Filtering

Chapter 3
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• Web Server\Performance

• Web Server\Performance\Static Content Compression

Management Tools

• Management Tools\IIS Management Console

• Management Tools\IIS Management Service

• Management Tools\IIS Scripts and Tools

• Management Tools\IIS 6 Management Compatibility

• Management Tools\IIS 6 Management Compatibility\IIS 6 Metabase
Compatibility

• Management Tools\IIS 6 Management Compatibility\IIS 6 WMI Compatibility

• Management Tools\IIS 6 Management Compatibility\IiS 6 Scripting Tools

• Management Tools\IIS 6 Management Compatibility\IiS 6 Management
Console

Verifying that the correct version of Microsoft .NET
Framework is installed

For information about the required versions of Microsoft .NET Framework, see the
Oracle Central Designer system requirements guide. If a required version of .NET
Framework is not installed, install it.

Note:

If you have a version of .NET Framework prior to the required version for this
release, you do not need to uninstall it before installing the required version.

• To find .NET Framework versions by viewing the registry:

1. Select Start, enter regedit.exe, and press Enter.

2. In the Registry Editor, go to
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\NET Framework
Setup\NDP.
The installed versions are listed under the NDP subkey.

If .NET Framework is installed, the folder contains folders whose names begin with
v, followed by the .NET Framework version number. For example:

– v4.0—indicates that .NET Framework 4.0 is installed.

• To find .NET Framework versions by using Windows Explorer, paste the following
text into the Windows Explorer address bar: %systemroot%
\Microsoft.NET\Framework64.
If .NET Framework is installed, the folder contains folders listing the installed
versions.
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Enabling ClickOnce support for Microsoft Edge version 79 or
later

1. In Microsoft Edge, go to edge://flags/#edge-click-once, and select Enable from the drop-
down list.

2. Restart your browser.

Synchronizing clocks on server and client computers
The clocks on the client computers, application server computer, and database server
computer are not required to be in the same time zone, but they must be no more than 24
hours apart relative to the Coordinated Universal Time (UTC). Oracle recommends that the
clocks be no more than 10 minutes apart.

Hardware networking switches
Some hardware networking switches change the incoming URL before passing the request to
the Oracle Central Designer server. For example, if the address entered during a client
installation is https://abc.com, a switch might change the URL in the following ways:

• A switch that performs hardware SSL/TLS processing might change the URL to http://
abc.com.

• A switch that performs load balancing might change the URL to http://PhysicalServer1.

When the application server is installed in an environment that includes a hardware
networking switch, the URL that you enter for the Web server URL root field must match the
URL that the networking switch uses to address the application server. From the previous
examples, the required URLs must be:

• In the first example, http://abc.com.

• In the second example, http://PhysicalServer1.

Note:

The application server must be able to use the address that you enter for the Web
server URL root field to address itself.

Configuring the IIS HTTP response header setting
To secure the web server and prevent clickjacking on the http://<server name>/
CentralDesignerInstall page, from which you install the Oracle Central Designer and Oracle
Central Designer Administrator applications, configure the HTTP response header in IIS.

1. Open the Internet Information Services (IIS) Manager.

2. In the Connections section on the left, expand the Sites folder.

3. Select Default Web Site.
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4. In the Default Web Site Home pane, in the IIS section, double-click HTTP
Response Headers.

5. In the Actions section on the right, click Add.

The Add Custom HTTP Response Header dialog box appears.

6. Enter the following:

• Name—X-Frame-Options

• Value—SAMEORIGIN

7. Click OK.

Configuring the application server for optimal performance
Oracle recommends performing the following modifications on the Oracle Central
Designer application server to optimize performance.

• Configure the worker process recycling settings for Windows

• Configure the worker process health settings for Windows

• Increase the default Microsoft Distributed Transaction Coordinator timeout

Configure the worker process recycling settings for Windows
1. Select Start > Internet Information Services (IIS) Manager.

2. Expand the tree for the local computer and select Application Pools.

3. Right-click DefaultAppPool and select Recycling.

4. Configure the following settings:

• Verify that only Regular time intervals (in minutes) is selected.

• Verify that a value of 1740 is entered for that setting.

Configure the worker process health settings for Windows
1. Select Start > Internet Information Services (IIS) Manager.

2. Expand the tree for the local computer and select Application Pools.

3. Right-click DefaultAppPool and select Advanced Settings.

4. Under Process Model, set Shutdown time limit (seconds) to match the timeout
for the client application (the default is 1200 seconds).

Increase the default Microsoft Distributed Transaction Coordinator
timeout

Oracle recommends that you increase the Microsoft Distributed Transaction
Coordinator (MS DTC) timeout because the default Windows timeout setting of 60
seconds might be insufficient for some Oracle Central Designer processes.

1. Select Start > Component Services.

2. Open Component Services > Computers.
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3. Right-click My Computer, and select Properties.

4. Select the Options tab.

5. Change the value of the Transaction timeout (seconds) field to 3600 (the default is 60).

6. Click OK.

7. Select Start > Services.

8. Stop and restart all IIS services.

Enabling TLS 1.2 for .NET Framework on Central Designer
application servers

If TLS 1.2 is enabled on any Oracle InForm where automated deployments are performed,
you must update the Windows registry to enable TLS 1.2 for .NET Framework on the Oracle
Central Designer application servers.

1. On all Oracle Central Designer application servers, open a command prompt as an
Administrator and run the command reg add
"HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\.NETFramework\v4.0.30319" /v
SchUseStrongCrypto /t REG_DWORD /d 00000001

2. Restart the Oracle Central Designer application server.
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4
Preparing the database server

Before installing the Oracle Central Designer software, you must:

• Install and configure the Oracle database software on the database server.

• Create the necessary database instance and tablespaces.

In this chapter:

• Install the Oracle database software on the database server

• Registering .NET assemblies

• Create the database and tablespaces

• Configuring the listener to accept connections for the new database

• Configuring the Open Cursors setting for a database instance

• Configuring the Cursor Sharing setting for a database instance

• Use the performance tuning capabilities that are available with the Oracle database
software

• Required rights for database administrators

• Creating the Oracle Central Designer database user

Install the Oracle database software on the database server
After the database server requirements are met, you can install the Oracle database
software. Use the Oracle database software installation documentation as needed. For more
information about required Oracle database software versions, see the Oracle Central
Designer system requirements guide.

Note:

If the application server and database server are on the same computer, you must
install the Oracle Server software and Oracle Client software in the same home, or
the Oracle Central Designer server installation will not work.

For more information, see:

• Mandatory configuration
Most of the default Oracle settings can be used for the Oracle Central Designer
database. However, the following Oracle configuration must be used.

Mandatory configuration
Most of the default Oracle settings can be used for the Oracle Central Designer database.
However, the following Oracle configuration must be used.
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Page Option Value

Database Components Oracle Text, a standard
database component.

Selected.

Tip: The Oracle database
software installation requires
that you install Oracle Data
Mining if you install Oracle
Text. If you do not want to
install Oracle Data Mining, you
can install Oracle Text
manually after completing the
Oracle database installation.

-- Oracle Java Virtual Machine
(JVM)

Selected.

Character Sets Database Character Set AL32UTF8 - Unicode 4.0 UTF
universal character set, UTF-8
compliant.

-- National Character Set AL16UTF16 - Unicode UTF-16
universal character set.

Parameters CURSOR_SHARING
parameter

FORCE

-- OPEN_CURSORS parameter 500

Additional configuration information

In production databases at Oracle, the DB_BLOCK_SIZE Oracle parameter is set to
16k (16384 bytes).

Registering .NET assemblies
You must register the .NET assemblies to the Global Assembly Cache (GAC) after the
initial installation, and each time you apply a patch.

• Oracle.DataAccess.dll

• Policy files that redirect older Oracle.DataAccess.dll versions to the one installed

To add the assemblies to the GAC:

1. Open a command prompt as an Administrator.

2. Navigate to the directory that contains the assembly to add to the GAC (<oracle
home>\ODP.NET\bin\4).

3. Execute the following command:

oraprovcfg.exe /action:gac /providerpath:Oracle.DataAccess.dll

4. Navigate to the directory that contains the policy files to add to the GAC (<oracle
home>\ ODP.NET\PublisherPolicy\4).
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5. Execute the following commands:

OraProvCfg.exe /action:gac /
providerpath:Policy.4.112.Oracle.DataAccess.dll

OraProvCfg.exe /action:gac /
providerpath:Policy.4.121.Oracle.DataAccess.dll

OraProvCfg.exe /action:gac /
providerpath:Policy.4.122.Oracle.DataAccess.dll

Create the database and tablespaces
After you install the Oracle database software, create the database instance and
tablespaces. Make sure the Oracle server has sufficient space to accommodate the new
tablespaces. The Oracle Central Designer software uses the following tablespaces by
default.

Tablespace Description Minimum size

DESIGNER Main data tablespace 100 MB.

A 16k (16384 bytes) block size is
required.

Note: Depending on usage, you
might need to increase the MB
size.

SYSTEM Main data tablespace 500 MB.

SYSAUX Main data tablespace 250 MB.

TEMP Temporary tablespace Always present in the Oracle
database.

UNDOTBS1 Main data tablespace 200 MB.

Note:

The tablespace names provided are the default names. Any names can be used for
the tablespaces.

Note:

If you use non-default names, you must specify them during the installation of the
application server (by clicking Advanced on the Database Parameters page), so be
sure you take note of them.
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Configuring the listener to accept connections for the new
database

After installing the Oracle database software, you must configure the listener to accept
connections for the new database. For more information, see the Oracle database
software documentation.

Configuring the Open Cursors setting for a database
instance

When you create a database instance, you must set Open Cursors to 500 by running
the following SQL command:

ALTER SYSTEM SET open_cursors=500 SCOPE=BOTH;

Before you upgrade, ensure that the Open Cursors parameter is correctly set.

Configuring the Cursor Sharing setting for a database
instance

When you create a database instance, you must set the Cursor Sharing setting
properly to FORCE by running the following SQL command:

ALTER SYSTEM SET cursor_sharing=FORCE SCOPE=BOTH;

Before you upgrade, ensure that the Cursor Sharing parameter is correctly set.

Use the performance tuning capabilities that are available
with the Oracle database software

Open the Automatic Database Diagnostic Monitor (ADDM) from the Database Control
home page or from Advisor Central.
This tool helps you diagnose problems, identify their causes, and make
recommendations.

About acting on ADDM recommendations:

• Make configuration changes to the database or operating system as necessary.

• The SQL Tuning Advisor might recommend rewriting some SQL statements.
However, the SQL statements cannot be rewritten.

• Add database indexes as needed.
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Caution:

Take note of all new indexes. Before upgrading, you must drop them to ensure
that they do not cause conflicts with new indexes that have been added to the
product. After the upgrade is finished, you can add the indexes back.

Note:

Contact Oracle Global Support to forward SQL statement recommendations or
request index changes in the product.

The most common configuration recommendations from ADDM are:

• SGA_TARGET

• PGA_AGGREGATE_TARGET

• DB_FILE_MULTIBLOCK_READ_COUNT

– Reset to zero instead of using an explicit value.

– Oracle automatically manages this parameter value if it is set to zero.

For more information, see the Oracle database software documentation.

Required rights for database administrators
The database administrator must create the Oracle Central Designer database user before
you install the Oracle Central Designer application. During the Oracle Central Designer
installation, you are prompted to enter the user name and password for the Oracle Central
Designer database user. For more information, see Creating the Central Designer database
user.
The database administrator can be any user that has the rights to perform the following tasks:

Task SQL Automatically executed for

Create the Database User.
CREATE USER &1 
IDENTIFIED BY &2
DEFAULT TABLESPACE &3;
GRANT CONNECT TO &1;
GRANT RESOURCE TO &1;
GRANT CREATE VIEW TO &1;

All supported Oracle database
software versions.

Allow the Database User to
create function indexes. GRANT QUERY REWRITE TO 

&1;
GRANT CREATE SYNONYM TO 
&1;

All supported Oracle database
software versions.
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Note:

The database administrator user does not have the rights to grant the
database user execute privileges on required packages. For information on
how to assign the database administrator the necessary rights, see Granting
the database administrator the EXECUTE privilege on required packages.

For more information, see:

• Granting the database administrator the EXECUTE privilege on required packages

• Sample SQL

Granting the database administrator the EXECUTE privilege on
required packages

The database administrator user does not have rights to grant the database user
execute privileges on certain required packages. To grant the database administrator
the necessary rights, run the following SQL commands as a database superuser:

GRANT EXECUTE on SYS.DBMS_JOB to <Database Administrator user name> 
WITH GRANT OPTION;
GRANT EXECUTE on SYS.DBMS_LOB to <Database Administrator user name> 
WITH GRANT OPTION;
GRANT EXECUTE on SYS.DBMS_SQL to <Database Administrator user name> 
WITH GRANT OPTION;
GRANT EXECUTE on SYS.UTL_FILE to <Database Administrator user name 
WITH GRANT OPTION;

Sample SQL
The following SQL commands are not run by the installation but show an example of
what a database administrator needs to do to create the tablespaces. Database
administrators must set up the tablespaces before installing the Oracle Central
Designer software.

CREATE TABLESPACE designer
LOGGING
DATAFILE 'D:\Oracle\oradata\dev1\DESIGNER.ora' SIZE 400M
AUTOEXTEND ON NEXT 1M;
ALTER SYSTEM SET db_16k_cache_size = 80M;
EXTENT MANAGEMENT LOCAL SEGMENT SPACE MANAGEMENT AUTO;

Creating the Oracle Central Designer database user
1. On the database server computer, extract the CreateCentralDesignerSchema

folder from the product ZIP file.
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Note:

You must use the ZIP file for the product version being installed, or the Oracle
Central Designer database user will not be given the appropriate grants.

2. From the CreateCentralDesignerSchema folder, run the following command:

sqlplus <Database Administrator user name>/<Database Administrator 
password>@<Database> @_task.sql <Central Designer database user name> 
<Central Designer database user password> <Central Designer tablespace>

In the previous command:

• Database Administrator user name / password—Credentials of the database
administrator used to create the Oracle Central Designer database user.

• Database—Alias from the TNSnames.ora file.

• Central Designer database user name / password—Credentials of the Oracle Central
Designer database user account you are creating.

• Central Designer tablespace—Default value: DESIGNER.

When you run the Oracle Central Designer installation, you must enter the database
parameters set up during this procedure.
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5
Installing and uninstalling the software

In this chapter:

• Before you begin

• Overview of installation and configuration

• Installing the Oracle Central Designer application server

• Uninstalling the application server

• Configuring SMTP settings for automated deployment email notifications

• Starting the Central Designer client application

• Starting the Oracle Central Designer Administrator client application

Before you begin
The latest information about the Oracle Central Designer application is on the Oracle Support
self-service website, My Oracle Support. Before you install and use the Oracle Central
Designer application, check My Oracle Support for the latest information, including Release
Notes and Known Issues, alerts, white papers, bulletins, and patches.

For the latest Oracle Central Designer software, check the Oracle Software Delivery Cloud
(https://edelivery.oracle.com).

Overview of installation and configuration
Before you start your installation, plan your work:

• Checklist—Planning the server installation.

• Checklist—Planning the client installations.

For more information, see:

• Overview of installing the application and database servers

• Overview of uninstalling

Overview of installing the application and database servers
1. Install the Central Designer application server.

For more information, see Preparing the database server and Installing the Central
Designer application server.

2. Verify the installations.
For more information, see Verifying the installation of the application server.
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Overview of uninstalling
1. Uninstall the application server.

For more information, see Uninstalling the application server.

Note:

The client applications are ClickOnce applications and are therefore not
installed on users' computers. Therefore, you cannot uninstall the client
applications.

Installing the Oracle Central Designer application server
1. Locate the setup.exe program.

The setup.exe program is available the Oracle Software Delivery Cloud (https://
edelivery.oracle.com).

2. Double-click setup.exe.

The InstallShield Wizard prepares to install the application server.
A welcome page appears.

3. Click Next.

The Customer Information page appears.

4. Provide the following information:

• User Name—Your name.

• Company Name—The name of your company.

• Company URL—A unique identifier for your company data, typically your
company URL (for example, http://www.mycompany.com).

• Select whether to install the application for anyone who uses the computer, or
only for your user.

5. Click Next.

The Setup Type page appears.

6. Select New Database.

Note:

If you are installing the second or higher server in a web farm, select
Update.

7. In the Destination Folder area, specify the destination location for the installation.
By default, the installation wizard installs the software in the
<PROGRAMFILESDIR>\Oracle Health Sciences\Central Designer\
folder. PROGRAMFILESDIR is a system setting that is usually C:\Program
Files (x86). If you want to install to another location, click Browse, and select
the location.
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Note:

The instructions, paths, and Start Menu navigation in this guide assume you are
installing to the default location. Oracle strongly recommends that you install
the software to the default location.

8. Click Next.

The Database Parameters page appears.

9. Enter the database connection information. The database user must be created before
you run the installer. For more information, see Creating the Central Designer database
user.

Field Description

Database User Name The user name for the Oracle database user.

Database Password The password for the database user.

Note:

The password must not contain any
of the following characters: @ & ( )
[ or ].

Oracle TNS Name Alias from the TNSnames.ora file. This TNS
name is used to connect to the database
instance.

Create New Database Select this option if you want to create a new
database.

Caution:

If you have an existing database
schema and you select Create New
Database, all existing information in
your current database schema will be
deleted.

Note:

Do not use Oracle reserved words for user names or passwords.

10. If a new database was created and tablespaces were created with non-default names,
you must specify the names of the tablespaces. The tablespaces that you specify must
already exist. The installation does not create tablespaces.

a. Click Advanced.

The Advanced Database Settings page appears.
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b. Fill in the fields with the correct information, according to the following table.

c. Click OK to return to the Database Parameters page.

Field Description

Default Tablespace for new user The first tablespace for the tables of the
schema owner.

This tablespace must have a block size of
16k.

Large (16k) Tablespace for new user Not used. Enter the same value as for the
default tablespace.

Temp Tablespace for new user The temporary tablespace for the tables of
the schema owner.

11. Click Next.

The Job Service page appears.

12. Enter the TCP/IP port number that the job service will use. The port must be
unused. In most cases, you can use the default value.

Note:

If you are installing the server as part of a web farm, all of the servers
can use the same port number, as long as the port is unused.

13. Optionally, to configure the Oracle Central Designer software to support a web
farm, select Make this server part of a web farm. A web farm setup allows you to
install the Oracle Central Designer server software on multiple application server
computers. The installation is the same for all of the servers, and you must select
this option for all servers in the web farm. For more information, see Web farm
capabilities.

After you select the check box, the installation checks the database to see if a
primary Job Scheduler has been specified. Additional options appear, depending
on whether you are installing the first or second (or higher) server.

• If this installation is the first server in the web farm, the primary Job Scheduler
has not been set yet. The installation automatically sets the Job Scheduler
service on the server computer as the primary Job Scheduler. If you install
additional application servers, you can change the primary Job Scheduler
during the installations.

• If this installation is the second or higher server in the web farm, the primary
Job Scheduler service has already been set, and the name of the computer
that runs the primary Job Scheduler appears. To change the primary Job
Scheduler, select Make this server's Job Scheduler the primary.

14. Specify a password for the Job Service user.

Note:

Make sure that the user password meets the requirements listed on the
page.
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15. Click Next.

The System User Password page appears.

16. Specify a password for the system user.

Note:

Make sure that the user password meets the requirements listed on the page.

The Oracle Central Designer application installs the system user by default. You can
configure the lockout time for the system user separately from all other users. By default,
this user is assigned the superuser and DesignerAdministrator roles.

Note:

The password that you specify for the system user is also used for the
archiveimporter user. For more information about this user, see the Oracle
Central Designer Administrator Guide.

17. Click Next.

The Network Parameters page appears.

18. In the Web server URL root field, enter the server address to which requests will come
(for example, http://ABCServer or https://ABCServer). If you enabled Transport Layer
Security (TLS), use https.

Note:

When the application server is installed in an environment that includes a
hardware networking switch, the URL that you enter for the Web server URL
root field must match the URL that the networking switch uses to address the
application server. For more information, see Hardware networking switches.

As you enter a value in the Web server URL root field, the Public server URL root field is
automatically updated with the same value. If you edit the value in the Public server URL
root field, the field is no longer updated automatically when the Web server URL root field
is updated.

19. Optionally, you can secure (encrypt and prevent tampering of) communications by using
Transport Layer Security (TLS). For more information, see Securing communication with
Transport Layer Security (TLS).

20. Optionally, if the application server computer is behind a proxy that rewrites the request
URLs, in the Public server URL root field, enter the address that the client computer
uses to access the application server (the public address of the server computer as seen
by the client computer). This address will be added as the address of the server
computer during installation of the client applications.

If the value for the Public server URL root field does not need to be different from the
Web server URL root field, make sure that the values in both fields match.

21. Specify the certificate to use to sign web service authorizations:
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a. Click Choose Certificate.

The Choose Certificate dialog box appears.

b. Select a certificate.

c. Click OK.

The Issued to, Issuer, Expiration, and Friendly name fields are populated.

Note:

On each Oracle Central Designer application server, an administrator
must install the certificate that is used for signing web service
authorizations to the LOCAL_MACHINE\MY store. The Oracle Central
Designer installation process grants Full Control to access the certificate
private keys to the IIS AppPool\DefaultAppPool user and the NETWORK
SERVICE user.

Note:

If a user other than the IIS AppPool\DefaultAppPool user is running the
DefaultAppPool application pool, you must grant the user Full Control to
access the private keys, or the user is unable to sign using the
certificates. For more information, see Installing certificates for signing
web service authorizations and deployment packages.

22. If the Oracle Central Designer application server is outside the network of the
Oracle InForm application server. Specify the proxy URL or script used by the
Oracle Central Designer application server to communicate with the Oracle InForm
server during automated deployment:

• In the Proxy URL field, enter the web address for the proxy server.

• In the Proxy Script field, enter the web address for the proxy configuration
script.

23. Click Next.

The Client Installation Configuration page appears.

24. In the Environment Name field, enter the name for your Oracle Central Designer
instance.

The environment name appears on the web page to which you navigate to start
the Oracle Central Designer application.

25. Click Next.

The InForm Deployment page appears.

26. Specify the certificate to use to sign deployment packages and Oracle InForm web
service authorizations:

a. Click Choose Certificate.

The Choose Certificate dialog box appears.

b. Select a certificate.
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c. Click OK.

The Issued to, Issuer, Expiration, and Friendly name fields are populated.

Note:

For studies hosted by Oracle, the certificate must be issued by a trusted
commercial Certificate Authority.

27. Click Next.

The Start Copying Files page appears.

28. Review the installation settings. To change any settings, click Back. If you are satisfied
with the settings, click Next.

The installation begins. The Setup Status page appears, showing the status of the
installation. When the installation is complete, the InstallShield Wizard Complete page
appears.

29. Click Finish.

Note:

If the IIS worker process is running under any user other than NETWORK
SERVICE or IIS AppPool\DefaultAppPool, you must grant the user read
permission to the
HKEY_LOCAL_MACHINE\SOFTWARE\OracleHS\CentralDesigner registry key
after the installation.

For more information, see:

• Performing a silent installation

• Verifying the installation of the application server

Performing a silent installation
To create a setup.iss response file that contains all the installation parameters:

1. In a command prompt window, enter the path of the Oracle Central Designer setup.exe
program followed by /r to run the installation in record mode.

The InstallShield Wizard appears.

2. Follow the wizard steps.

3. When you reach the Start Copying Files page, the setup.iss file is created in the Windows
directory (by default C:\Windows).

To perform a silent installation:

1. Copy the setup.iss file to the same directory as the Oracle Central Designer setup.exe
program.

2. In a command prompt window, enter the path of the setup.exe program followed by /s.
The silent installation is performed.
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Verifying the installation of the application server
1. Verify that the job service is installed and running:

a. Open the Control Panel.

b. Open Administrative Tools > Services.

c. Verify that the Oracle Central Designer Job Scheduler service exists and is
running.

2. Verify that the Web site has been added to the Internet Information Services (IIS)
Manager directory:

a. Open the Control Panel.

b. Open Administrative Tools > Computer Management.

c. Open Services and Applications > Internet Information Services (IIS)
Manager > Web Sites > Default Web Site. Verify that CentralDesigner is
listed in the virtual directories.

3. Review the installer.log file. This log contains messages that were generated
during installation. It is available in the following location: \Program Files
(x86)\Oracle Health Sciences\Central Designer.

Uninstalling the application server
1. Select Start > Services.

2. Stop the job scheduler and IIS services.

3. Select Start > Control Panel > Programs and Features.

4. Select Central Designer Server, and click Change/Remove.

A confirmation dialog box appears.

5. Click Yes.

The Setup Status page appears, informing you of the status of the uninstall.
The Uninstall Complete page appears.

6. Click Finish.

7. Delete the Oracle Central Designer directory.

Configuring SMTP settings for automated deployment email
notifications

The Oracle Central Designer application can send email notifications for the following
automated deployment events:

• Deployment request is created, approved, or rejected.

• Deployment is started.

• Deployment is completed successfully or with failures.

• Deployment request is cancelled.
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• Deployment is cancelled.

To set up Oracle Central Designer to send email notifications:

1. Install the SMTP server feature in Microsoft Windows. For more information, see the
Microsoft documentation for your operating system.

2. Verify that you can send email from the SMTP server.

3. After you install the Oracle Central Designer application server, configure the Oracle
Central Designer web site to send email.
a. Select Start > Administrative Tools > Internet Information Services (IIS)

Manager.

b. Expand <machine_name> > Sites > Default Web Site.

c. Select CentralDesigner.

d. In the Features View, double-click SMTP E-mail.

The SMTP E-mail page appears.

e. Enter a dummy address as the email address from which messages are sent (for
example, designer@mycompany.com).

f. Select Deliver e-mail to SMTP server.

g. Select Use localhost.

h. Select the same authentication settings that are configured for the SMTP server.

i. Click Apply.

Note:

Every time you install the Oracle Central Designer application, you must reconfigure
the SMTP email settings for the Oracle Central Designer web site.

Starting the Central Designer client application
The client applications are ClickOnce applications, and you do not need to install them to
start them, as you would for applications using a traditional Windows installer.

1. Using Microsoft Edge, navigate to the following address:

http://<server name>/CentralDesignerInstall, where <server name> is the name of the
application server computer.

2. Click the Start Central Designer Client link.

The application files are downloaded to a cache and the application is installed. The
installation might take some time.
After the installation is complete, the application opens, and you can log on.

Starting the Oracle Central Designer Administrator client
application

The client applications are ClickOnce applications, and you do not need to install them to
start them, as you would for applications using a traditional Windows installer.
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1. Using Microsoft Edge, navigate to the following address:

http://<server name>/CentralDesignerInstall, where <server name> is the name of
the application server computer.

2. Click the Start Central Designer Administrator link.

The application files are downloaded to a cache and the application is installed.
The installation might take some time.
After the installation is complete, the application opens, and you can log on.
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6
Migrating the software to this release

In this chapter:

• About migrating the application server

• Checklist—Planning a migration

• Upgrading custom reports definitions

• Installing the application server

• Upgrading the client applications

• Updating certificates without reinstalling the Oracle Central Designer software

About migrating the application server
You can migrate to this release from Oracle Central Designer 2.1.2.x, 6.2.x, or 6.3.x.

Note:

If you are using Oracle Central Designer 2.0.5.1 or 2.1.1.x, you must first upgrade
to Oracle Central Designer 2.1.2 before migrating to Oracle Central Designer 7.0.

When you migrate, you must:

• Create a new Oracle 19c database and migrate to it. For more information, see your
Oracle database software documentation.

Note:

If you are migrating from Oracle Central Designer 6.3.2 you can use your
existing Oracle 19c database. For more information on required patches, see
the Oracle Central Designer System Requirements guide.

• Provide the database and user parameters that you entered when you created the new
database and database user.

Time considerations

Because the migration updates every study in the database, migrating from an earlier release
could take some time, so plan the upgrade carefully. For example, Oracle expects that
migrating a database with 150 studies could take 10 - 15 hours or longer.

Checklist—Planning a migration
1. Export the Oracle Central Designer database user.
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Caution:

You must perform this step. If the upgrade is not successful, you might
need to restore the database to attempt to install again.

Depending on the size of the database, this process could take several hours.

Note:

Use the following command to export a user:
expdp designer/designer@db1_dev1 directory=data_pump_dir
schemas=DESIGNER dumpfile=file_to_export.dmp

In this example, the user has the following information:

• User name—designer

• Database—db1_dev1:

Note:

When you execute this command, you are prompted for the user
password.

2. If you are upgrading to an Oracle 19c database, create a new database instance
with a 16k block size for the DESIGNER tablespace.

For more information, see Create the database and tablespaces.

3. If you are migrating to a new database, import the database user into the
destination database server.

Use the following command to import a database user into the destination
database server:
impdp designer/designer@db1_dev1 DIRECTORY=data_pump_dir
DUMPFILE=file_to_export.dmp SCHEMAS=DESIGNER

In this example, the user has the following information:

• User name—designer

• Database—db1_dev1

Note:

When you execute this command, you are prompted for the user
password.

4. Import the Oracle Central Designer database. If you are migrating to the Oracle
19c database from 11g, re-map the tablespaces.

Use the following command to import a database user into the destination
database server:
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impdp designer/designer@db1_dev1 DIRECTORY=data_pump_dir
DUMPFILE=file_to_export.dmp SCHEMAS=DESIGNER
REMAP_TABLESPACE=DESIGNER_BIGINDEX:DESIGNER

In this example, the user has the following information:

• User name—designer

• Database—db1_dev1

Note:

When you execute this command, you are prompted for the user password.

5. Make sure that the Cursor Sharing setting for the database instance is set properly.

For more information, see Configuring the Cursor Sharing setting for a database
instance.

6. Unlock statistics for specific tables.

Unlock statistics for the following tables:

• IC_OBJECT

• IC_OBJECT_REVISIONS

• IC_OBJECT_BACK_REFERENCES

• IC_OBJECT_FORWARD_REFERENCES

• IC_BLUEPRINT_OBJECT_MAP

The upgrade process drops non-primary key indexes on the tables affected by the
upgrade and recreates the indexes at the end of the process. If the index was originally
defined with the COMPUTE STATISTICS clause, the recreation also attempts to
COMPUTE STATISTICS. If statistics are locked, this process fails.

7. Make sure that the database UNDO_MANAGEMENT initialization parameter is set to
AUTO and the UNDO and TEMP tablespaces are set to autoextend.

These settings are necessary for a successful upgrade.

8. If you added any new indexes to the database, you must drop them before upgrading the
application server to ensure that they do not cause conflicts with new indexes that have
been added to the product.

After the upgrade is finished, you can add the indexes back.

9. Export custom reports definitions from the Oracle Central Designer Administrator
application.

For more information, see Upgrading custom reports definitions.

10. Update data mappings with the PhysicalMappingType property set to All.

For more information, see Updating data mappings with PhysicalMappingType set to All.

11. (Recommended) Run the DetectStudiesWithUnitsWithSpaces.sql script to determine if
any studies contain unit names with spaces.

A validation check produces an error if a unit name contains a space. For more
information, see Running the DetectStudiesWithUnitsWithSpaces.sql script.

12. Run the application server installation to install the application server.
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For more information, see Installing the application server.

13. If you dropped indexes from your database before upgrading, add them back in
after you finish upgrading.

14. Recompile user-defined functions and sign and secure user-defined function
assemblies as needed.

For more information, see Upgrading user-defined functions.

15. Re-import custom reports definitions.

For more information, see Upgrading custom reports definitions.

16. If the web service authorization and deployment authorization certificates have
expired, upgrade them.

Note:

If the certificates are current, you can skip this step.

For more information, see Updating certificates without reinstalling the Oracle
Central Designer software.

17. Inform users that they can resume using the client applications.

For more informtion, see Starting the Oracle Central Designer client application
and Starting the Oracle Central Designer Administrator client application.

For more information, see:

• Running the DetectStudiesWithUnitsWithSpaces.sql script

• Updating data mappings with PhysicalMappingType set to All

• Upgrading user-defined functions

Running the DetectStudiesWithUnitsWithSpaces.sql script
A SQL script called DetectStudiesWithUnitsWithSpaces.sql generates a report that
identifies the unit names with spaces and the study projects that contain unit names
with spaces. Oracle recommends that you run this script because a validation check
produces an error if a unit name contains a space.
Run the script before upgrading the application server. If the script finds units with
spaces and study projects that use the units, perform the following steps:

1. In any affected study, run validation to determine the items that refer to the units
with spaces in their names.

2. Modify the units file to remove the spaces from the unit names that appear in the
output file.

3. Using Control Panel > Administrative Tools > Services, restart the Job
Scheduler service (Oracle Central Designer Job Scheduler).

4. Restart the client applications.

5. In any affected study, modify the items to use the unit names that do not contain
spaces.
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The script and a readme file (DetectStudiesWithUnitsWithSpaces.Readme) are available on
the product ZIP file in the InstallSupport directory.

Updating data mappings with PhysicalMappingType set to All
If a study contains a data mapping for which PhysicalMappingType is set to All and you use
the data mapping for both CDD and CIS, you must use the existing data mapping for one
purpose only and create a new data mapping for the other purpose.
Because creating a new database for CDD is simpler, Oracle recommends using the existing
data mapping for CIS and creating a new CDD data mapping and, if necessary, a new CDD
database.

To modify the existing data mapping and create a new data mapping:

1. To determine whether your database contains any data mappings for which
PhysicalMappingType is set to All, before you upgrade, run the
DetectStudiesWithPhysicalMappingAll.sql script, which is available in the InstallSupport
directory on the product ZIP file.

2. For each data mapping for which PhycialMappingType is set to All, change the
PhysicalMappingType property of the data mapping from All to CIS.

The CIS data mapping continues to work as expected, and you are able to perform
resynchronizations with the CIS database.

3. Create a new CDD data mapping.

4. Copy the data sets in the CIS data mapping and paste them into the CDD data mapping.

The RefNames of the data sets and their data series are appended with _1.

5. If you deployed the study to the Oracle InForm application in an earlier release, remove
the _1 appended text from the aliases of the data sets and data series in the CDD data
mapping.

Caution:

Do not update the RefNames, or you will not be able to perform a CIS resynch
after you deploy again to the Oracle InForm application.

6. Deploy the study to the Oracle InForm application.

7. Set up the new CDD database.

Note:

After you create a new data mapping for either CDD or CIS, you cannot perform a
resynchronization with either the CDD or CIS database. You must create a new
database for the new data mapping type.

Upgrading user-defined functions
If a study contains a user-defined function that performs a task such as reading from or
writing to a file, accessing the database or the registry, making web service calls, running an
external application, sending an email, or using the event log directly, the assembly for the
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user-defined function must be signed with a strong named signature that is valid and
trusted in order for the function to work in the Oracle InForm application.

To ensure that the user-defined functions and assemblies in your study projects and
library projects are secure, Oracle recommends that you sign user-defined function
assemblies using a strong named, valid and trusted signature.

Note:

For Oracle InForm studies hosted by Oracle, all user-defined function
assemblies that require signing must be signed by Oracle Services prior to
deployment.

In addition, user-defined functions that use the Log4Net application must use the
Oracle Central Designer Log4Net wrapper or must be recompiled to use Log4Net
version 2.0.8. For more information about the Log4Net wrapper, see the Rules
Reference Guide.

For more information, see:

• Identifying user-defined functions and assemblies to update

• Securing and signing user-defined function assemblies

Identifying user-defined functions and assemblies to update
To identify study and library projects that contain user-defined functions that need to
be recompiled or assemblies that need to be secured and signed, run the
ValidateCustomFunctionAssemblies.exe file after you upgrade the application server.

Note:

User-defined functions that refer to an unsupported Log4Net version must be
recompiled or reconfigured to use the Oracle Central Designer Log4Net
wrapper. For more information about the Log4Net wrapper, see the Rules
Reference Guide.

1. Locate the ValidateCustomFunctionAssemblies.exe file in the product ZIP file, in
the InstallSupport directory.

2. Copy the file and paste it to the bin folder in the directory in which you installed the
Oracle Central Designer application.

3. In a command prompt window, enter one of the following:

• To view assemblies that reference the wrong Log4Net version, enter
ValidateCustomFunctionAssemblies L.

• To view assemblies with missing, invalid or untrusted signatures, enter
ValidateCustomFunctionAssemblies S.

• To view assemblies with invalid references to ExternalFunctions.dll, enter
ValidateCustomFunctionAssemblies I.

• To view all of the above, enter ValidateCustomFunctionAssemblies.

Chapter 6
Checklist—Planning a migration

6-6



4. When prompted, specify the following:

• System username—system.

• System password—Password that you specified on the Designer System User
Password page during the Oracle Central Designer application installation.

• Path for the output file, including file name—Location in which to save the output
file that lists the study and library projects with user-defined functions that must be
updated. For example, C:\Output\ValidateAssemblies.txt.

A list of user-defined functions is generated.

Securing and signing user-defined function assemblies
To secure and sign assemblies for user-defined functions, create a key pair, extract the public
key, and place the key file on the following servers:

• Oracle Central Designer application server. If you are using the Oracle Central Designer
application in a web farm environment, place the key on all the application servers in the
web farm.

• All Oracle InForm application servers where studies using the assembly will be deployed.

Note:

For Oracle InForm studies hosted by Oracle, all user-defined function assemblies
that require signing must be signed by Oracle Services prior to deployment.

For specific instructions and information about creating and signing an assembly with a
strong named signature, see the Rules Reference Guide and the documentation for the tool
that you use to create the strong name.

Upgrading custom reports definitions
If you have defined custom reports, you must export the XML report definition file before
migrating an upgrade. After the migration, you must re-import the report definitions.

1. In the Oracle Central Designer Administrator application, export the XML report definition
file. For more information, see the Oracle Central Designer Administrator Guide.

2. Migrate the Oracle Central Designer software.

3. Modify the XML file exported in the first step, replacing any instances of
assembly="PhaseForward.Designer.ServerCore" with
assembly="Oracle.Designer.ServerCore".

4. Re-import the report definitions on each Oracle Central Designer application server:

a. Copy the updated custom reports definition file to the following location, overwriting
the existing file:

<designer_root>\DBSchema\_Last\Datainstaller\DesignerReportsDe
finitions.xml
In the previous location, <designer_root> is the root directory of the Oracle Central
Designer installation.

b. From the <designer_root>\bin directory, run the UpdateReports.bat file.
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The UpdateReports.bat file updates the definitions of the custom reports in the
database.

Installing the application server
1. Export the Oracle Central Designer database user.

Caution:

You must perform this step. If the upgrade is not successful, you might
need to restore the database to attempt to install again.

To export a user with the following information:

• User name—designer

• Database—db1_dev1

Use the following command:

expdp designer/designer@db1_dev1 directory=data_pump_dir 
schemas=DESIGNER dumpfile=file_to_export.dmp

Note:

When you execute this command, you are prompted for the user
password.

2. Locate the setup.exe program.

The setup.exe program is available the Oracle Software Delivery Cloud (https://
edelivery.oracle.com).

3. Double-click setup.exe.

The InstallShield Wizard prepares to install the application server.

4. Click Yes.

A welcome page appears.

5. Click Next.

The Customer Information page appears.

6. Fill in the fields. You should provide the same values that were entered during the
initial installation of the application server.

• User Name—Your name.

• Company Name—The name of your company.

• Company URL—A unique identifier for your company data, typically your
company URL (for example, http://www.mycompany.com).

Chapter 6
Installing the application server

6-8

https://edelivery.oracle.com
https://edelivery.oracle.com


Note:

You must enter the company URL that you specified during the original Oracle
Central Designer installation.

7. Click Next.

The Setup Type page appears.

8. Select Update.

9. In the Destination Folder area, specify the destination location for the installation. By
default, the installation wizard installs the software in the
<PROGRAMFILESDIR>\Oracle\Central Designer\ folder. <PROGRAMFILESDIR>
is a system setting that is usually C:\Program Files (x86). If you want to install to another
location, click Browse, and select the location. You must choose the location to which
the application server was initially installed.

Note:

The instructions, paths, and Start Menu navigation in this guide assume you are
installing to the default location. Oracle strongly recommends that you install
the software to the default location.

10. Click Next.

The Database Parameters page appears. Because you are upgrading, the Create New
Database checkbox is grayed out.

11. Fill in the following fields. You must provide the values that you created when you set the
Oracle TNS name (typically set when you create the database) and the database user
name and password (set when you created the Oracle Central Designer user in the new
database).

Field Database

Database User Name The user name for the Oracle database user.

Note:

The password must not contain any
of the following characters: @ & ( )
[ or ].

Database Password The password for the Central Designer
database user.

Oracle TNS Name Alias from TNSnames.ora file. This TNS name
is used to connect to the Oracle Central
Designer database instance.
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Note:

Do not use Oracle reserved words for user names or passwords.

12. Click Next.

The Oracle Central Designer Job Service page appears.

13. Enter the TCP/IP port number that the job service will use. The port must be
unused. In most cases, you can use the default value.

Note:

If you are installing the server as part of a web farm, all of the servers
can use the same port number, as long as the port is unused.

14. Optionally, to configure the Oracle Central Designer software to support a web
farm, select Make this server part of a web farm. A web farm setup allows you to
install the Oracle Central Designer server software on multiple application server
computers. The installation is the same for all of the servers, and you must select
this option for all servers in the web farm. For more information, see Web farm
capabilities.

After you select the checkbox, the installation checks the database to see if a
primary Job Scheduler has been specified. Additional options appear, depending
on whether you are installing the first or second (or higher) server.

• If this installation is the first server in the web farm, the primary Job Scheduler
has not been set yet. The installation automatically sets the Job Scheduler
service on the server computer as the primary Job Scheduler. If you install
additional application servers, you can change the primary Job Scheduler
during the installations.

• If this installation is the second or higher server in the web farm, the primary
Job Scheduler service has already been set, and the name of the computer
that runs the primary Job Scheduler appears. To change the primary Job
Scheduler, select Make this server's Job Scheduler the primary.

15. Specify a password for the Job Service user.

Note:

Make sure that the user password meets the requirements listed on the
page.

16. Click Next.

The Network Parameters page appears.

17. In the Web server URL root field, enter the address of the server on its local
network (the server address to which requests will come, for example, http://
ABCServer or https://ABCServer). If you enabled Transport Layer Security (TLS),
use https. Unless you made changes that would cause the server address to have
changed, use the address that you entered for the last installation.
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Note:

When the application server is installed in an environment that includes a
hardware networking switch, the URL that you enter for the Web server URL
root field must match the URL that the networking switch uses to address the
application server.

As you enter a value in the Web server URL root field, the Public server URL root field is
automatically updated with the same value. If you edit the value in the Public server URL
root field, the field is no longer updated automatically when the Web server URL root field
is updated.

18. Optionally, you can secure (encrypt and prevent tampering of) communications by using
Transport Layer Security (TLS). For more information, see Securing communication with
Transport Layer Security (TLS).

19. Optionally, if the application server computer is behind a proxy that rewrites the request
URLs, in the Public server URL root field, enter the address that the client computer
uses to access the application server (the public address of the server computer as seen
by the client computer). This address will be added as the address of the server
computer during installation of the client applications.

If the value for the Public server URL root field does not need to be different from the
Web server URL root field, make sure that the values in both fields match.

20. Specify the certificate to use to sign web service authorizations:

a. Click Choose Certificate.

The Choose Certificate dialog box appears.

b. Select a certificate.

c. Click OK.

The Issued to, Issuer, Expiration, and Friendly name fields are populated.

Note:

On each Oracle Central Designer application server, an administrator must
install the certificate that is used for signing web service authorizations to the
LOCAL_MACHINE\MY store. The Oracle Central Designer installation process
grants Full Control to access the certificate private keys to the IIS
AppPool\DefaultAppPool user and the NETWORK SERVICE user.

Note:

If a user other than the IIS AppPool\DefaultAppPool user is running the
DefaultAppPool application pool, you must grant the user Full Control to access
the private keys, or the user is unable to sign using the certificates. For more
information, see Installing certificates for signing web service authorizations and
deployment packages.

21. If the Oracle Central Designer application server is outside the network of the Oracle
InForm application server, specify the proxy URL or script used by the Oracle Central
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Designer application server to communicate with the Oracle InForm server during
automated deployment:

• In the Proxy URL field, enter the web address for the proxy server.

• In the Proxy Script field, enter the web address for the proxy configuration
script.

22. Click Next.

The Client Installation Configuration page appears.

23. In the Environment Name field, enter the name for your Oracle Central Designer
instance.

The environment name appears on the web page to which you navigate to start
the Oracle Central Designer application.

24. Click Next.

The InForm Deployment pageappears.

25. Specify the certificate to use to sign deployment packages and Oracle InForm web
service authorizations:

a. Click Choose Certificate.

The Choose Certificate dialog box appears.

b. Select a certificate.

c. Click OK.

The Issued to, Issuer, Expiration, and Friendly name fields are populated.

Note:

For studies hosted by Oracle, the certificate must be issued by a trusted
commercial Certificate Authority.

26. Click Next.

The Start Copying Files page appears.

27. Review the installation settings. To change any settings, click Back. If you are
satisfied with the settings, click Next.

The installation begins. The Setup Status page appears, showing the status of the
installation. When the installation is complete, the InstallShield Wizard Complete
page appears.

28. Click Finish.

Upgrading the client applications
Because the client applications are ClickOnce applications, you do not need to
upgrade them. Simply start the applications as you always do.
For more information, see:

• Starting the Central Designer client application.

• Starting the Central Designer Administrator client application.
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Updating certificates without reinstalling the Oracle Central
Designer software

When the web service authorization and deployment authorization certificates expire, you can
install renewed certificates without reinstalling the Oracle Central Designer software.
The procedure updates the configuration files of both the web server and the job scheduler
with the certificates you select and adds access to the private keys for the certificates to
NETWORK SERVICE and DefaultAppPool users.

1. Open a command window.

2. Navigate to the <Designer Install Dir>\bin directory.

3. Enter Oracle.Designer.CertificateManager.exe and press Enter.

A prompt to select the web services authorization certificate appears.

4. Click OK.

The Certificate Browser appears.

5. Select the web services certificate, and click OK.

A prompt to select the for deployment authorization certificate appears.

6. Click OK.

The Certificate Browser appears.

7. Select the deployment authorization certificate, and click OK.

Messages appear that indicate the progress of the tool.

8. Copy the public key of the deployment authorization certificate to a location from where it
can be installed on the Oracle InForm server. For more information, see the Oracle
InForm Installation Guide.

Note:

If after the new certificate is installed you want to deploy packages that were
already deployed using the expired certificate, make sure the public key of the
expired certificate is not removed from the Oracle InForm server.
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7
Securing communication with Transport Layer
Security (TLS)

In this chapter:

• About communication security

About communication security
You can secure (encrypt and prevent tampering of) communications by using Transport Layer
Security (TLS) and, optionally, by signing authorization information issued by the application
server.

With Transport Layer Security, all web traffic between the client applications and the web
server is encrypted and tamper resistant. You configure TLS through IIS with an X.509
certificate obtained using your company certificate store or a third party application.

Oracle recommends that you enable TLS. For more information about enabling TLS, refer to
the Microsoft documentation about configuring TLS for your operating system.

Note:

When you start the client applications, enter the address of the application server,
including the correct protocol (either HTTP or HTTPS). If you enable TLS, the
address of the application server must begin with HTTPS
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8
Getting started

In this chapter:

• Logging on to the Oracle Central Designer Administrator application

• Changing your password in the Oracle Central Designer Administrator application

• Logging on to the Oracle Central Designer application

• Changing your password in the Oracle Central Designer application

• Logging off

• Overview of configuring the Oracle Central Designer software

• Creating a sample deployment package using the sample study

Logging on to the Oracle Central Designer Administrator
application

An administrator must log on to the Oracle Central Designer Administrator application and
create user accounts before other users can log on and use the Oracle Central Designer
application.

1. Using Microsoft Edge, navigate to the following address:

http://<server name>/CentralDesignerInstall

In the previous address, <server name> is the name of the application server computer.

2. Click the Start Central Designer Administrator link.

A dialog box appears, indicating that the application is starting. The logon window
appears.

3. Enter the following information:

• User name—system.

• Password—Password you set during the server installation.

4. If the web browser connects to the network through a proxy server that requires
authentication, click Proxy Settings to enter the user name, the password, and the
domain used to authenticate the connection to the proxy server.

5. Click Log On.

The application opens.

Oracle recommends:

• Changing the password of the system account after you log on to the Oracle Central
Designer Administrator application.
For more information, see Changing your password in the Oracle Central Designer
Administrator application.

• Deactivating or terminating the system user after you create and activate users.
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For more information, see the Oracle Central Designer Administrator Guide.

Changing your password in the Oracle Central Designer
Administrator application

1. In the Users view, right-click a user name, and do one of the following:

• Select Change Password.

• Press Ctrl+P.

A dialog box appears.

2. Enter the new password twice for confirmation, and click OK.

Logging on to the Oracle Central Designer application
You can log on after an administrator creates a user account for you.

1. Using Microsoft Edge, navigate to the following address:

http://<server name>/CentralDesignerInstall

In the previous address, <server name> is the name of the application server
computer.

2. Click the Start Central Designer Client link.

A dialog box appears, indicating that the application is starting. The logon window
appears.

3. Enter your user name and password.

4. If the web browser connects to the network through a proxy server that requires
authentication, click Proxy Settings to enter the user name, the password, and
the domain used to authenticate the connection to the proxy server.

5. Click Log On.

Note:

When a user account is created in the Oracle Central Designer
Administrator application, the administrator can require the user to
change the password after logging on the first time. You might be
prompted to change your password.

Changing your password in the Oracle Central Designer
application

If the administrator who created your user account requires that you change your
password, you are prompted when you start the application to change your password.
To change your password because it is required:

1. Log on to the Oracle Central Designer application.

The Change Password dialog box appears.
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2. Enter your old and new passwords. You must enter your new password twice.

3. Click OK.

To change your password at any time after logging on:

1. Select File > Change Password.
The Change Password dialog box appears.

2. Enter your old and new passwords. You must enter your new password twice for
confirmation.

3. Click OK.

Logging off
• Select File > Exit

If you have unsaved changes, you are prompted to save them.

Overview of configuring the Oracle Central Designer software
In the Oracle Central Designer Administrator application, you create and manage
administrative components such as users, roles, locales, and security settings.

Some tasks in the Oracle Central Designer application cannot be performed until the
administration information is set up correctly in the Oracle Central Designer Administrator
application.

Other types of administration, including administering studies and libraries, are performed in
the Oracle Central Designer application.

Creating a sample deployment package using the sample study
The Oracle Central Designer installation package contains a sample study and units file. You
can import the files into the Oracle Central Designer application and then deploy the sample
study to the Oracle InForm application using a manual deployment. Perform the following
steps to create a sample deployment package.

1. Import the DesignerUnit.xml file into the Oracle Central Designer Administrator
application. This file updates custom units of measurement.

For more information on exporting and importing a units file, see the Oracle Central
Designer Administrator Guide.
The DesignerUnit.xml file is located in the Oracle Central Designer installation package in
the InstallSupport\Sample Trial folder.

2. Set up locales in the Oracle Central Designer Administrator application, and include the
following locales for the sample study.

• English (United States)

• Japanese (Japan)

• Czech (Czech Republic)

• Spanish (Mexico)

For more information on adding and removing a locale, see the Oracle Central Designer
Administrator Guide.
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3. Import the CSML for the sample study into a new study project.

For more information, see the Oracle Central Designer User Guide.
The CSML for the sample study is located in the Oracle Central Designer
installation package in the InstallSupport\Sample Trial folder.

4. Add the locales from step 2 to the study.

For more information on selecting the supported locales for a study, see the
Oracle Central Designer User Guide.

5. Select all the dictionary types and all their verbatim types on the Coding tab.

For more information, see the Oracle Central Designer User Guide

6. Validate the study to create a baseline, and choose to ignore the warnings.

For more information, see the Oracle Central Designer User Guide

7. Create a deployment package.

For more information, see the Oracle Central Designer User Guide.

8. Save the deployment package to the local computer.

For more information, see the Oracle Central Designer User Guide.

9. Copy the deployment package and the public key to a location that is accessible to
the Oracle InForm server.

10. Perform additional steps in the Oracle InForm application to finish setting up the
study.

For more information, see the Oracle InForm Installation Guide.

Chapter 8
Creating a sample deployment package using the sample study
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9
Troubleshooting

What should I do if an error occurs during the server installation?

Errors during server installation can be caused by several issues, including issues with the
database user name and with the installation of the Oracledatabase software.

To troubleshoot:

• Read the installer.log file. The installer.log file contains information about the installation,
including any errors that occurred. The default location of the file on the application
server computer is C:\Program Files (x86)\Oracle Health
Sciences\Central Designer.

• If the application server and database server are on the same computer, you must install
the Oracle Server software and Oracle Client software in the same home, or the Oracle
Central Designer server installation will not work.
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