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Preface

This preface contains the following sections:

• Documentation accessibility

• Related resources

• Diversity and Inclusion

• Access to Oracle Support

• Additional copyright information

Documentation accessibility
For information about Oracle's commitment to accessibility, visit the Oracle Accessibility
Program website at http://www.oracle.com/pls/topic/lookup?ctx=acc&id=docacc.

Related resources
All documentation and other supporting materials are available on the Oracle Help Center.

Diversity and Inclusion
Oracle is fully committed to diversity and inclusion. Oracle respects and values having a
diverse workforce that increases thought leadership and innovation. As part of our initiative to
build a more inclusive culture that positively impacts our employees, customers, and partners,
we are working to remove insensitive terms from our products and documentation. We are also
mindful of the necessity to maintain compatibility with our customers' existing technologies and
the need to ensure continuity of service as Oracle's offerings and industry standards evolve.
Because of these technical constraints, our effort to remove insensitive terms is ongoing and
will take time and external cooperation.

Access to Oracle Support
Oracle customers that have purchased support have access to electronic support through
Support Cloud.

Contact our Oracle Customer Support Services team by logging requests in one of the
following locations:

• English interface of Oracle Health Sciences Customer Support Portal (https://
hsgbu.custhelp.com/)

• Japanese interface of Oracle Health Sciences Customer Support Portal (https://hsgbu-
jp.custhelp.com/)
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You can also call our 24x7 help desk. For information, visit http://www.oracle.com/us/support/
contact/health-sciences-cloud-support/index.html or visit http://www.oracle.com/pls/topic/
lookup?ctx=acc&id=trs if you are hearing impaired.

Additional copyright information
This documentation may include references to materials, offerings, or products that were
previously offered by Phase Forward Inc. Certain materials, offerings, services, or products
may no longer be offered or provided. Oracle and its affiliates cannot be held responsible for
any such references should they appear in the text provided.
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1
Basics

In this chapter:

• How do I log on?

• How do I change my password?

• How do I get help?

How do I log on?
1. Using Microsoft Edge, navigate to the following address: http://<application server name>/

CentralDesignerInstall.

2. Click Start Central Designer Client.

3. Do one of the following:

• Enter your User Name and Password, and click Log On.

• If the web browser connects to the network through a proxy server that requires
authentication, click Proxy Settings to enter the user name, the password, and the
domain used to authenticate the connection to the proxy server.

You are logged on to the application, and the application opens. By default, the Home
Page appears, but you can choose what you see after logon.

How do I change my password?
1. In the upper-left corner of the application window, select File, and select Change

Password.

2. Enter your old and new passwords. You must enter your new password twice for
confirmation.

3. Click OK.

How do I get help?
Do any of the following:

• Press F1, and then click the area of the application for which you want more information. A
Help window appears with the relevant page displayed.

• Select Help > Central Designer Documentation to open the Oracle Help Center.

• Hover Help
If you hold your mouse pointer over a button, tab, or icon without moving it, a tooltip
appears with a brief description of the item that you are pointing to.

If you need the version of the application, you can view it in the About Central Designer dialog
box. The dialog box also contains copyright information.
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2
Build a study

In this chapter:

• Step 1: Open your study

• Step 2: Set the default appearance of ayour forms (study-level styles)

• Step 3: Add library objects to your study (optional)

• Step 4: Create special Oracle InForm visits, forms, and items

• Step 5: Create all other visits, forms, and items

• Step 6: Create groups of visits (optional)

• Step 7: Design your study workflow

• Step 8: Create a coding map (optional)

• Step 9: Select a primary layout for the study

• Step 10: Lock and protect your study objects (optional)

• Step 11: Validate and deploy your study

Step 1: Open your study
• The first time you log in, or any time you want to open a study you haven't recently

opened:

1. In the upper-left corner of the application window, click File, and select Open.

2. From the list, double-click the study's name.

• To open a study you have recently opened, from the Home page, in the Recent Projects
List on the left, double-click the icon for the study you want to work on.

Tip

If you want to see your most recent project as soon as you log in:

1. In the upper-left corner of the application window, click Tools, and select Options.

2. In the At Startup drop-down list, select Load Most Recent Project.

Step 2: Set the default appearance of ayour forms (study-level
styles)

Show me how to set study-level styles.
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Tip

• We recommend that you set these study-level styles, for two reasons:

– To save time. When you set the styles at the study level, the settings are
propagated to all forms, codelists, and items in the study. As a result, you do
not need to set styles for each study object, unless you want to override the
study-level settings.

– To enforce standards and consistency across a study.

• This setting applies to all existing and new study objects that inherit the study-level
styles.

1. In the upper-left corner, click Tools, and select Edit Study Level Styles.

2. You can set the following styles.

Form styles

• Question column width—Percentage of the width of the layout table to use for the
question column.

For example, if you enter 50 in the field, the question occupies half of the form, and
the control where the InForm user enters data takes up the remaining half.

Codelist styles

• Control orientation—Display codelist items (radio buttons or checkboxes)
horizontally or vertically.

• Single selection settings—Display a list of options as radio buttons or in a drop-
down list.

– For radio buttons:

* Use pulldown when item count exceeds—When the number of radio
buttons exceeds the specified number, display them in a drop-down list.

* Display vertically when item count exceeds—When the number of radio
buttons exceeds the specified number, display them as a vertical list.

Compound item styles

• Caption alignment—Align the top-level item's caption to the left, top, right, or bottom
of the control.

• Control orientation—For a control with sub-controls (also called nested controls),
indicate whether you want the nested controls to be displayed horizontally or
vertically.

Date time item styles

• Year range—First and last years that you want to appear in the Year field for date
time items.

• Caption alignment—Align the top-level item's caption to the left, top, right, or bottom
of the control.

Chapter 2
Step 2: Set the default appearance of ayour forms (study-level styles)
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Float item styles

• Caption alignment—Align the top-level item's caption to the left, top, right, or bottom
of the control.

• Textbox width—Width of the control in which users can enter alphanumeric
characters such as letters, numbers, and punctuation marks.

– Use the item variable's length as the width—Use each item's length as the
width for the item's control.

– Use this width—Enter the number of characters wide you want for the item's
control, which is used instead of the control's specified width.

• Unit control type—For an item with more than one unit control, display the unit
controls as radio buttons or in a pulldown.

Integer item styles

• Caption alignment—Align the top-level item's caption to the left, top, right, or bottom
of the control.

• Textbox width—Width of the control in which users can enter alphanumeric
characters such as letters, numbers, and punctuation marks.

– Use the item variable's length as the width—Use each item's length as the
width for the item's control.

– Use this width—Enter the number of characters wide you want for the item's
control, which is used instead of the control's specified width.

• Unit control type—Display unit controls as radio buttons or in a pulldown.

Text item styles

• Caption alignment—Align the top-level item's caption to the left, top, right, or bottom
of the control.

• Textbox size—Width of the control in which users can enter alphanumeric characters
such as letters, numbers, and punctuation marks.

– Use the item variable's length as the width—Use each item's length as the
width for the item's control.

* Increase the height by one line for every __ chars—The control's height is
1 line per the number of characters entered for the item's length. Use this field
to increase the control's height by one line for every additional specified
number of characters used for its width.

For example, if you use the default value of 50 characters, an item with a
length of 10 has a height of 1 line, and an item with a length of 60 has a
height of 2 lines.

– Use the following width and height—Enter a width (in number of characters)
and height (in number of lines) for text boxes.

• Character set restriction—Indicate whether you want to require InForm users to
enter only ASCII characters in text items without codelists, or if InForm users can use
any character set for text items.

The ASCII Only restriction is enforced if you're deploying to InForm release 5.0 or
higher.

3. Click Apply, and click Close.

Chapter 2
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Step 3: Add library objects to your study (optional)

1. At the bottom of the Project Explorer, click the Visit Schedule ( ) button.

2. Expand the Study Design folder.

3. Continue expanding as needed and select the study object you want to add the library
object to. For example, if you are adding a library item to a form, expand the Study Design
folder and the visit the form is in, and select the form.

4. Search for the library object you want to add to the study.

a. Click the Libraries tab, which appears on the right of the page by default.

Tip

If you don't see the Libraries tab, at the top left of the page, select View, and
make sure Libraries is selected.

b. Do one or more of the following:

i. To open a saved search, select Actions > Open Search from Repository.

ii. To search for a library object by category, click Categories.

iii. To search for a library object using keywords, click Keywords.

iv. To specify the libraries you want to search in, click Libraries.

v. Select the checkboxes for the libraries you want to search in, or, to select all
available libraries, click Check All Libraries in Repository Results.

vi. Optionally, to search on the latest versions of each library object in the selected
libraries, click Include latest object revisions in Repository.

c. Enter the search criteria for the library object, and click Find.

Tip

If you are adding a library object that references other objects, we recommend that
you add the referenced objects first. For example, if you want to add a library
section with a link to a library item on another form, add the library item to the
other form before you add the library section.

5. Drag the library object from the Libraries tab and drop it on the object you want to add it to
in the Project Explorer.

Step 4: Create special Oracle InForm visits, forms, and items
In this section:

• Step 4a: Create a screening visit

• Step 4b: Create a screening form in the screening visit

• Step 4c: Create an enrollment visit

• Step 4d: Create an enrollment form in the enrollment visit

Chapter 2
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• Step 4e: Create a subject identification form

• Step 4f: Create a final visit

• Step 4g: Create a study completion in the final visit

• Step 4h: Create a randomization form (Optional)

• Step 4i: Create a visit report form (optional)

• Step 4j: Create a regulatory document form (optional)

• Step 4k: Create a Visit Approval form (optional)

Step 4a: Create a screening visit

1. At the bottom of the Project Explorer, click the Visit Schedule ( ) button.

2. At the top of the Project Explorer, right-click Study Design, and select New Event.

3. Enter a title, RefName, and description, and click OK.

4. In the Project Explorer, select the new visit, and click the Properties tab, which appears on
the right of the page by default.

Tip

If you don't see the Properties tab, at the top left of the page, select View, and
make sure Properties is selected.

5. At the top of the Properties tab, in the InForm section, click in the Special Forms field,
and select Screening.

6. Next, Step 4b: Create a screening form in the screening visit.

Step 4b: Create a screening form in the screening visit
1. In the Project Explorer, right-click the screening visit, select New, and select Form.

2. Enter a title, RefName, and description, and click OK.

3. In the Project Explorer, select the form, and make sure the Design tab is selected.

4. Click the Properties tab.

5. At the top of the Properties tab, in the InForm section, click in the Special Forms field,
and select Screening.

6. In the Project Explorer, right-click the form, and select New Section.

7. Enter a title, RefName, and description, and click OK.

8. Make sure the Design tab is selected, and create the following items in the section:

Subject initials

a. In the grid, enter the following, and press the Tab key to navigate through the
columns:

• Type—Text Item

Chapter 2
Step 4: Create special Oracle InForm visits, forms, and items
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• Title—Internal name for the item. You can choose to see study object titles or
RefNames in the Project Explorer by using the Options drop-down list at the top
of the Project Explorer. The Title can have 1-63 characters.

• RefName—Internal reference name for the study object.

• Question—Item question that appears on the form. The question can have
0-1000 characters. Certain words may be reserved for this field. For more
information, see Are there words I can't use in an item's Question or Short
Question?. If you enter a customized label or translation for the item, it overrides
the Question text.

• Short Question—In Oracle InForm, the short question appears as a column
heading in a repeating form, an itemset, and in reports. The short question can
have 0-255 characters. Certain words may be reserved for this field. For more
information, see Are there words I can't use in an item's Question or Short
Question?.

b. In the Item Required column, select the checkbox.

c. In the Item Properties column, click the Edit link, and enter the following:

• Length—Maximum number of characters that a user can enter for the item.

Tip

Sites in some countries might not collect subject initials due to data privacy
concerns. In this case, you can do the following:

• In the Display Override column for the item, select Hidden.

• Create a rule to populate the item with something other than the subject's initials.
For example, you might want to populate the item with dashes (---). For more
information, see the User Guide.

d. In the Project Explorer, select the item.

e. Click the Properties tab, click in the Special Fields drop-down list, and select Initials
(Screening).

Date of birth (optional)

a. In the grid, enter the following, and press the Tab key to navigate through the
columns:

• Type—Date Time Item

• Title—Internal name for the item. You can choose to see study object titles or
RefNames in the Project Explorer by using the Options drop-down list at the top
of the Project Explorer. The Title can have 1-63 characters.

• RefName—Internal reference name for the study object.

• Question—Item question that appears on the form. The question can have
0-1000 characters. Certain words may be reserved for this field. For more
information, see Are there words I can't use in an item's Question or Short
Question?. If you enter a customized label or translation for the item, it overrides
the Question text.

Chapter 2
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• Short Question—In Oracle InForm, the short question appears as a column
heading in a repeating form, an itemset, and in reports. The short question can
have 0-255 characters. Certain words may be reserved for this field. For more
information, see Are there words I can't use in an item's Question or Short
Question?

b. In the Item Properties column, click the Edit link, and enter the following:

• Date Time Component Settings—Select the date and time components that you
want to appear in Oracle InForm, specify whether each is required, and indicate
whether an Oracle InForm user can select Unknown as an option for the
component.

Tip

Sites in some countries might not collect subjects' date of birth
information due to data privacy concerns. In this case, you can make only
the Year date time component required, and set all other components to
optional.

• Year Range—Enter the first and last years that you want to appear in the Year
field.

c. In the Project Explorer, select the item.

d. Click the Properties tab, click in the Special Fields drop-down list, and select DOB
(Screening).

Screening date (optional)

a. In the grid, enter the following, and press the Tab key to navigate through the
columns:

• Type—Date Time Item

• Title—Internal name for the item. You can choose to see study object titles or
RefNames in the Project Explorer by using the Options drop-down list at the top
of the Project Explorer. The Title can have 1-63 characters.

• RefName—Internal reference name for the study object.

• Question—Item question that appears on the form. The question can have
0-1000 characters. Certain words may be reserved for this field. For more
information, see Are there words I can't use in an item's Question or Short
Question?. If you enter a customized label or translation for the item, it overrides
the Question text.

• Short Question—In Oracle InForm, the short question appears as a column
heading in a repeating form, an itemset, and in reports. The short question can
have 0-255 characters. Certain words may be reserved for this field. For more
information, see Are there words I can't use in an item's Question or Short
Question?

b. In the Item Properties column, click the Edit link, and enter the following:

• Date Time Component Settings—Select the date and time components that you
want to appear in Oracle InForm, specify whether each is required, and indicate
whether an InForm user can select Unknown as an option for the component.
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• Year Range—Enter the first and last years that you want to appear in the Year
field.

c. Click OK.

d. In the Project Explorer, select the item.

e. Click the Properties tab, click in the Special Fields drop-down list, and select
Screening date (Screening).

9. Create a layout for your form:

a. In the Project Explorer, select the form.

b. Select the Layout tab, and click the Create Layout button in the middle of the page.

By default, the layout for the form uses the study-level styles that you or your study
administrator configured. If you want to change the form's appearance, or the appearance
of one or more of its study objects, see Set the default appearance for a single form and its
study objects (form-level styles) and Set the appearance of a single study object (control
styles).

10. Next, Step 4c: Create an enrollment visit.

Step 4c: Create an enrollment visit

1. At the bottom of the Project Explorer, click the Visit Schedule ( ) button.

2. At the top of the Project Explorer, right-click Study Design, and select New Event.

3. Enter a title, RefName, and description, and click OK.

4. In the Project Explorer, select the visit, and click the Properties tab, which appears on the
right of the page by default.

Tip

If you don't see the Properties tab, at the top left of the page, select View, and
make sure Properties is selected.

5. At the top of the Properties tab, in the InForm section, click in the Special Forms field,
and select Enrollment.

6. Next, Step 4d: Create an enrollment form in the enrollment visit.

Step 4d: Create an enrollment form in the enrollment visit
1. In the Project Explorer, right-click the enrollment visit, select New, and select Form.

2. Enter a title, RefName, and description, and click OK.

3. In the Project Explorer, select the form, and make sure the Design tab is selected.

4. Click the Properties tab.

5. At the top of the Properties tab, in the InForm section, click in the Special Forms field,
and select Enrollment.

6. In the Project Explorer, right-click the form, select New Section.

7. Enter a title, RefName, and description, and click OK.

8. Create the following item in the section:
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Subject number (optional)

a. Make sure the Design tab is selected.

b. In the grid, enter the following, and press the Tab key to navigate through the
columns:

• Type—Text Item or Integer Item

• Title—Internal name for the item. You can choose to see study object titles or
RefNames in the Project Explorer by using the Options drop-down list at the top
of the Project Explorer. The Title can have 1-63 characters.

• RefName—Internal reference name for the study object.

• Question—Item question that appears on the form. The question can have
0-1000 characters. Certain words may be reserved for this field. For more
information, see Are there words I can't use in an item's Question or Short
Question?. If you enter a customized label or translation for the item, it overrides
the Question text.

• Short Question—In Oracle InForm, the short question appears as a column
heading in a repeating form, an itemset, and in reports. The short question can
have 0-255 characters. Certain words may be reserved for this field. For more
information, see Are there words I can't use in an item's Question or Short
Question?.

c. In the Item Properties column, click the Edit link, and enter the following:

• Length—Maximum number of characters (including the decimal point) that a user
can enter for the item.

Tip

If you want the subject number to be automatically populated, you can do the
following:

• In the Display Override column for the item, select Hidden.

• Create a rule to populate the item.

d. Click OK.

e. In the Project Explorer, select the item.

f. Click the Properties tab, click in the Special Fields drop-down list, and select Patient
No. (Enrollment).

9. Create a layout for your form:

a. In the Project Explorer, select the form.

b. Select the Layout tab, and click the Create Layout button in the middle of the page.

By default, the layout for the form uses the study-level styles that you or your study
administrator configured. If you want to change the form's appearance, or the appearance
of one or more of its study objects, see Set the default appearance for a single form and its
study objects (form-level styles) and Set the appearance of a single study object (control
styles).

10. Next, Step 4e: Create a subject identification form.
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Step 4e: Create a subject identification form
Why create a subject identification form?

To allow Oracle InForm users to edit the subject initials or subject number items.

In Oracle InForm, if you only include the subject initials and subject number items on the
screening and enrollment forms, a user cannot edit the items after a subject is screened or
enrolled. However, if you create a subject identification form and add those items to it, users
can edit the items on the subject identification form.

To create a subject identification form:

1. At the bottom of the Project Explorer, click the Visit Schedule ( ) button.

2. In the Project Explorer, right-click the visit you want to add the form to, select New, and
select Form.

3. Enter a title, RefName, and description, and click OK.

4. In the Project Explorer, select the form, and make sure the Design tab is selected.

5. Click the Properties tab, which appears on the right of the page by default.

Note

If you don't see the Properties tab, at the top left of the page, select View, and
make sure Properties is selected.

6. At the top of the Properties tab, in the InForm section, click in the Special Forms field,
and select Patient Identification.

7. In the Project Explorer, right-click the form, select New Section.

8. Enter a title, RefName, and description, and click OK.

9. If you created a Subject Number item on the enrollment form, add it as a link to the section:

a. In the Project Explorer, select the item.

b. Right-click the item, select Copy, and select Link.

c. In the Project Explorer, select the Subject Identification form, right-click the form, and
select Paste.

10. Create the following item in the section:

Subject intials (optional)

a. In the grid, enter the following, and press the Tab key to navigate through the
columns:

• Type—Text Item

• Title—Internal name for the item. You can choose to see study object titles or
RefNames in the Project Explorer by using the Options drop-down list at the top
of the Project Explorer. The Title can have 1-63 characters.

• RefName—Internal reference name for the study object.
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• Question—Item question that appears on the form. The question can have
0-1000 characters. Certain words may be reserved for this field. For more
information, see Are there words I can't use in an item's Question or Short
Question?. If you enter a customized label or translation for the item, it overrides
the Question text.

• Short Question—In InForm, the short question appears as a column heading in a
repeating form, an itemset, and in reports. The short question can have 0-255
characters. Certain words may be reserved for this field. For more information,
see Are there words I can't use in an item's Question or Short Question?.

b. In the Item Required column, select the checkbox.

c. In the Item Properties column, click the Edit link, and enter the following:

• Length—Maximum number of characters that a user can enter for the item.

Tip

Sites in some countries might not collect subject initials due to data privacy
concerns. In this case, you can do the following:

• In the Display Override column for the item, select Hidden.

• Create a rule to populate the item with something other than the subject's initials.
For example, you might want to populate the item with dashes (---). For more
information, see the User Guide.

d. In the Project Explorer, select the item.

e. Click the Properties tab, click in the Special Fields drop-down list, and select Initials
(Screening).

Tip

You can also map the items on the screening and enrollment forms directly to the
subject identification form, and create a rule to populate the items.

11. Create a layout for your form:

a. In the Project Explorer, select the form.

b. Select the Layout tab, and click the Create Layout button in the middle of the page.

By default, the layout for the form uses the study-level styles that you or your study
administrator configured. If you want to change the form's appearance, or the appearance
of one or more of its study objects, see Set the default appearance for a single form and its
study objects (form-level styles) and Set the appearance of a single study object (control
styles).

Tip

We recommend that you contact your study's librarian to add this form to a library
for reuse across studies. For more information, see the User Guide.

12. Next, Step 4f: Create a final visit
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Step 4f: Create a final visit
Why create a final visit?

Use the final visit to contain the Study Completion form, where Oracle InForm users enter data
such as the date of study completion or subject drop-out reason.

1. At the bottom of the Project Explorer, click the Visit Schedule ( ) button.

2. At the top of the Project Explorer, right-click Study Design, and select New Event.

3. Enter a title, RefName, and description, and click OK.

4. Next, Step 4g: Create a study completion in the final visit.

Step 4g: Create a study completion in the final visit
1. In the Project Explorer, right-click the final visit, select New, and select Form.

2. Enter a title, RefName, and description, and click OK.

3. In the Project Explorer, select the form, and make sure the Design tab is selected.

4. Click the Properties tab.

5. At the top of the Properties tab, in the Oracle InForm section, click in the Special Forms
field, and select Study Completion.

6. In the Project Explorer, right-click the form, select New Section.

7. Enter a title, RefName, and description, and click OK.

8. Create the following items in the section:

Study completion status

a. Make sure the Design tab is selected.

b. In the grid, enter the following, and press the Tab key to navigate through the
columns:

• Type—Text Item or Integer Item

• Title—Internal name for the item. You can choose to see study object titles or
RefNames in the Project Explorer by using the Options drop-down list at the top
of the Project Explorer. The Title can have 1-63 characters.

• RefName—Internal reference name for the item.

• Question—Item question that appears on the form. The question can have
0-1000 characters. Certain words may be reserved for this field. For more
information, see Are there words I can't use in an item's Question or Short
Question?. If you enter a customized label or translation for the item, it overrides
the Question text.

• Short Question—In InForm, the short question appears as a column heading in a
repeating form, an itemset, and in reports. The short question can have 0-255
characters. Certain words may be reserved for this field. For more information,
see Are there words I can't use in an item's Question or Short Question?.

c. In the Item Required column, select the checkbox.
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d. In the Item Properties column, click the Edit link, and enter the following:

• Length—Maximum number of characters (including the decimal point) that a user
can enter for the item.

e. Click OK.

f. In the Project Explorer, select the item.

g. Click the Properties tab, click in the Special Fields drop-down list, and select
Completion status (Study Completion).

h. Add a codelist with a drop-down list or set of radio buttons to so that the Oracle
InForm user can select the subject's status.

i. In the Project Explorer, right-click the item, and click New Codelist.

ii. Enter a Title, RefName, and Description for the codelist.

iii. Click OK.

iv. In the grid, create two codelist items so that an Oracle InForm user can indicate
whether a subject completed the study. For example, you can create a codelist
item called Complete, and one called Incomplete.

i. In the Project Explorer, select the item, and make sure the Design tab is selected.

j. In the Codelist Settings section, make sure Select Single Value is selected, and
click OK.

k. In the Project Explorer, expand the study completion form, the study completion status
item, and the completion status codelist.

l. For each codelist item, select the codelist item, click the Properties tab, and select
the following in the Study Completion Status Items drop-down list:

• Complete Study (Study Completion)

• Incomplete Study (Study Completion)

Drop-out reason

a. Make sure the Design tab is selected.

b. In the grid, enter the following, and press the Tab key to navigate through the
columns:

• Type—Text Item or Integer Item

• Title—Internal name for the item. You can choose to see study object titles or
RefNames in the Project Explorer by using the Options drop-down list at the top
of the Project Explorer. The Title can have 1-63 characters.

• RefName—Internal reference name for the study object.

• Question—Item question that appears on the form. The question can have
0-1000 characters. Certain words may be reserved for this field. For more
information, see Are there words I can't use in an item's Question or Short
Question?. If you enter a customized label or translation for the item, it overrides
the Question text.

• Short Question—In Oracle InForm, the short question appears as a column
heading in a repeating form, an itemset, and in reports. The short question can
have 0-255 characters. Certain words may be reserved for this field. For more
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information, see Are there words I can't use in an item's Question or Short
Question?.

c. In the Item Required column, select the checkbox.

d. In the Item Properties column, click the Edit link, and enter the following:

• Length—Maximum number of characters (including the decimal point) that a user
can enter for the item.

e. Click OK.

f. In the Project Explorer, select the item.

g. Click the Properties tab, click in the Special Fields drop-down list, and select Drop-
out reason (Study Completion).

h. Add a codelist with a drop-down list or set of radio buttons so that the InForm user can
select the reason a subject dropped out of the study.

Tip

If you are implementing a Custom-Defined Database (CDD), and want to map
each drop-out reason to a separate CDD column, we recommend that you
consider using one of the designs described in CDD design considerations.

i. In the Project Explorer, right-click the item, and click New Codelist.

ii. Enter a Title, RefName, and Description for the codelist.

iii. Click OK.

iv. In the grid, create two codelist items so that an InForm user can indicate why a
subject dropped out of the study. For example, you can create a codelist item
called Subject's decision to leave the study and one called Subject moved.

i. In the Project Explorer, select the item, and make sure the Design tab is selected.

j. In the Codelist Settings section, make sure Select Single Value is selected, and
click OK.

Tip

It is possible to write a rule to ensure that, if a user indicates that a subject didn't
complete the study, he must also select a drop-out reason. For more information
about writing rules, see the User Guide.

9. Create a layout for your form:

a. In the Project Explorer, select the form.

b. Select the Layout tab, and click the Create Layout button in the middle of the page.

By default, the layout for the form uses the study-level styles that you or your study
administrator configured. If you want to change the form's appearance, or the appearance
of one or more of its study objects, see Set the default appearance for a single form and its
study objects (form-level styles) and Set the appearance of a single study object (control
styles).

10. On the right of the page, right-click the study completion status codelist, select Control
Type, and select the type of control you want to create (Radio Button or Pulldown).
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11. On the right of the page, right-click the drop-out reason codelist, select Control Type, and
select the type of control you want to create (Radio Button or Pulldown).

Step 4h: Create a randomization form (Optional)
Why create a randomization form?

The randomization form has a randomization item that holds a sequence and drug kit number
that is generated by InForm randomization processing.

In order to populate the randomization item with the sequence number and drug kit, contact
your study's rule developer to create a randomization rule and any additional required
components.

1. At the bottom of the Project Explorer, click the Visit Schedule ( ) button.

2. In the Project Explorer, right-click the visit you want to add the form to, select New, and
select Form.

3. Enter a title, RefName, and description, and click OK.

4. In the Project Explorer, right-click the form, select New Section.

5. Enter a title, RefName, and description, and click OK.

6. Create the following item in the section:

Randomization (optional)

a. Make sure the Design tab is selected.

b. In the grid, enter the following, and press the Tab key to navigate through the
columns:

• Type—Text Item

• Title—Internal name for the item. You can choose to see study object titles or
RefNames in the Project Explorer by using the Options drop-down list at the top
of the Project Explorer. The Title can have 1-63 characters.

• RefName—Internal reference name for the study object.

• Question—Item question that appears on the form. The question can have
0-1000 characters. Certain words may be reserved for this field. For more
information, see Are there words I can't use in an item's Question or Short
Question?. If you enter a customized label or translation for the item, it overrides
the Question text.

• Short Question—In InForm, the short question appears as a column heading in a
repeating form, an itemset, and in reports. The short question can have 0-255
characters. Certain words may be reserved for this field. For more information,
see Are there words I can't use in an item's Question or Short Question?.

c. In the Item Properties column, click the Edit link, and enter the following:

• Length—Maximum number of characters (including the decimal point) that a user
can enter for the item.

d. In the Project Explorer, select the item.

e. Click the Properties tab, click in the Special Fields drop-down list, and select
Randomization field (Randomization).

7. Create a layout for your form:
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a. In the Project Explorer, select the form.

b. Select the Layout tab, and click the Create Layout button in the middle of the page.

By default, the layout for the form uses the study-level styles that you or your study
administrator configured. If you want to change the form's appearance, or the appearance
of one or more of its study objects, see Set the default appearance for a single form and its
study objects (form-level styles) and Set the appearance of a single study object (control
styles).

Tip

We recommend that you contact your study's librarian to add this form to a library for
reuse across studies. For more information, see the User Guide.

Step 4i: Create a visit report form (optional)
A visit report form is a form that a monitor fills out when inspecting a site. For example, the visit
report form might contain questions about whether a site is following all Standard Operating
Procedures (SOPs). You do not need to add this form to a visit. During deployment, a visit is
created and this form is added to it.

1. At the bottom of the Project Explorer, click the Forms and Transactions ( ) button, and
expand the InForm folder and the Forms folder, if necessary.

2. Right-click the Non-Clinical folder, and select New Visit Report Form.

3. Enter a title, RefName, and description, and click OK.

Tip

This form cannot be repeating, but can contain a repeating section.

4. Add a section to the form.

a. In the Project Explorer, right-click the form, select New Section.

b. Enter a title, RefName, and description, and click OK.

c. Make sure the Design tab is selected.

d. Optionally, click the Properties tab and specify any of the following properties for the
section:

• Fixed—Indicate whether the section is a fixed repeating section, which is deployed
to InForm as a Repeating Data itemset. If you select True, Repeating is
automatically set to True.

• Repeating—Indicate whether the section is a repeating section, which is deployed
to InForm as an Add Entry itemset.

e. If you selected both Fixed and Repeating, you must also:

• Choose the default view for a fixed repeating section.

• Configure a fixed repeating section.

5. Add the Date of visit item.

a. Make sure the Design tab is selected.
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b. In the grid, enter the following, and press the Tab key to navigate through the columns:

• Type—Date Time Item

• Title—Internal name for the item. You can choose to see study object titles or
RefNames in the Project Explorer by using the Options drop-down list at the top of
the Project Explorer. The Title can have 1-63 characters.

• RefName—Internal reference name for the study object.

• Question—Item question that appears on the form. The question can have 0-1000
characters. Certain words may be reserved for this field. For more information, see 
Are there words I can't use in an item's Question or Short Question?. If you enter a
customized label or translation for the item, it overrides the Question text.

• Short Question—In Oracle InForm, the short question appears as a column
heading in a repeating form, an itemset, and in reports. The short question can
have 0-255 characters. Certain words may be reserved for this field. For more
information, see Are there words I can't use in an item's Question or Short
Question?.

c. In the Item Properties column, click the Edit link, and enter the following:

• Date Time Component Settings—Select the date and time components that you
want to appear in InForm, specify whether each is required, and indicate whether
an InForm user can select Unknown as an option for the component.

• Year Range—Enter the first and last years that you want to appear in the Year
field.

d. Click OK.

e. In the Project Explorer, select the item.

f. Click the Properties tab, and from the Special Fields drop-down list, select DOV
(Date of Visit).

6. Create a layout for your form:

a. In the Project Explorer, select the form.

b. Select the Layout tab, and click the Create Layout button in the middle of the page.

By default, the layout for the form uses the study-level styles that you or your study
administrator configured. If you want to change the form's appearance, or the appearance
of one or more of its study objects, see Set the default appearance for a single form and its
study objects (form-level styles) and Set the appearance of a single study object (control
styles).

Step 4j: Create a regulatory document form (optional)
A regulatory document form is a form that a monitor fills out when inspecting a site. For
example, the regulatory document form might contain questions about whether a site has
complied with documentation requirements such as the availability of the study protocol. You
do not need to add this form to a visit. During deployment, a visit is created and this form is
added to it.

1. At the bottom of the Project Explorer, click the Forms and Transactions ( ) button, and
expand the InForm folder and the Forms folder, if necessary.

2. Right-click the Non-Clinical folder, and select New Reg Docs Form.

3. Enter a title, RefName, and description, and click OK.
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Tip

A regulatory document form is not repeating by default, but you can mark it as
repeating.

4. Add a section to the form

a. In the Project Explorer, right-click the form, select New Section.

b. Enter a title, ReName, and description, and click OK.

c. Make sure the Design tab is selected.

d. Optionally, click the Properties tab and specify any of the following properties for the
section:

• Fixed—Indicate whether the section is a fixed repreating seciton, which is
dpeloted to Oracle InForm as a Repeating Data intemset. If you select True,
Repeating is automatically set to True.

• Repeating—Indicate whether the section is a repeating section, which is deployed
to Oracle InForm as an Add Entry itemset.

e. If you specified both Fixed and Repeating, you must also:

• Create a fixed repeating section

• Choose the default view for a fixed repeating section

5. Add an item to the section.

a. In the library project, at the botoom of the Project Explorer, click the Visit Schedule

( ) button.

b. Expand the visit and form with the section you want to add the item to.

c. In the Project Explorer, select the section, and make sure the Design tab is selected.

d. Above the grid, clcik the Columns button, and add the columns for the properties you
want to configure for the item.

e. Do one of the following:

• In the grid, enter data in the columns, as needed.

Note

We recommend that you add the items in the order you want them to
appear in the section. However, if yo need to reorder the items, see 
Reorder the items in a section.

• If the Dynamic Grid checkbox in the upper-right above the grid is selected, you

must click the Edit Dynamic Grid ( ) to add items to the section. For more
information, see Create a section to collect related data (a dynamic grid).
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Item columns

a. In the library project, at the bottom of the Project Explorer, click the Visit Schedule

( ) button.

b. Expand the visit and form with the section you want to add the item to.

c. In the Project Explorer, select the section, and make sure the Design tab is selected.

d. Above the grid, click the Columns button, and add the columns for the properties you
want to configure for the item.

e. Do one of the following:

• In the grid, enter data in the columns, as needed.

Tip

We recommend that you add the items in the order you want them to
appear in the section. However, if you need to reorder the items, see 
Reorder the items in a section.

• If the Dynamic Grid checkbox in the upper-right above the grid is selected, you

must click the Edit Dynamic Grid icon ( ) to add items to the section. For
more information, see Create a section to collect related data (a dynamic grid).

Item columns

• Type—Select one of the following:

– Blood Pressure Item—Used to collect blood pressure information.

– Compound Item—Has one or more child items that can have different data
types.

– Date Time Item—Used to collect date and time information.

– Float Item—Used to collect numerical values with decimal points, or
information for a question with a codelist (a control such as a drop-down list, a
set of checkboxes, or a set of radio buttons).

– Integer Item—Used to collect numerical values without decimal points, or
information for a question with a codelist (a control such as a drop-down list, a
set of checkboxes, or a set of radio buttons).

– Text Item—Used to collect alphanumeric information, or information for a
question with a codelist (a control such as a drop-down list, a set of
checkboxes, or a set of radio buttons).

– Yes No Item—Used to collect yes or no answers to questions. A Yes No item
contains a predefined codelist with Yes and No options.
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Tip

To ensure that data is captured and maintained properly, do not change
this setting after you have deployed your study. Instead, deactivate this
study object and create a new object with the updated setting. For
example, do not change a Float item to an Integer item.

• Title—Internal name for the item. You can choose to see study object titles or
RefNames in the Project Explorer by using the Options drop-down list at the top
of the Project Explorer. The Title can have 1-63 characters.

• RefName—Internal reference name for the item.

• Question—Item question that appears on the form. The question can have
0-1000 characters. Certain words may be reserved for this field. For more
information, see Are there words I can't use in an item's Question or Short
Question?. If you enter a customized label or translation for the item, it overrides
the Question text.

• Short Question—In Oracle InForm, the short question appears as a column
heading in a repeating form, an itemset, and in reports. The short question can
have 0-255 characters. Certain words may be reserved for this field. For more
information, see Are there words I can't use in an item's Question or Short
Question?.

• Item Properties—Contains an Edit link, which you can click to edit additional
item properties.

• Item Required—Indicate whether the item is required for data entry on the form
to be complete.

• SDV Required—Indicate whether the item requires source document verification.

• SDV Critical—Indicate whether the item is considered critical for source
verification. The SDV Critical setting for an item can be overridden in Oracle
InForm.

• Conditional On—To configure the item so that it only appears on the form when a
particular option is selected in another item, select the item in the Conditional On
column, and the required option in the Conditional Value column.
This column contains items with a drop-down list, set of radio buttons, or set of
checkboxes.

• Conditional Value—To configure the item so that it only appears on the form
when a particular option is selected in another item, select the item in the
Conditional On column, and the required option in the Conditional Value column.
This column contains the code and label of drop-down list options, radio buttons,
or checkboxes on the item that you selected in the Conditional On column.

• Display Override—Determines the default behavior of an item when a layout is
generated.

– ReadOnly—The item is visible but not editable.

– Editable—The item is visible and editable by any user, regardless of the
rights assigned to the user.
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– Hidden—The item is not visible.

– None—The item is visible to all users, and visible and editable by any user
who has the rights to view and/or edit the item.

• Key—For key items, displays icons and numbers that indicate:

– Type of key item uniqueness (None, Individual, or Group).

– Order of the items in the drop-down navigation list that appears in the
summary view of a repeating form in InForm.

In Oracle InForm, key items are used to make it easier to navigate among the
instances of a repeating form and to enforce data uniqueness in specific items.

• Codelist—For text, float, and integer items, select an existing and eligible drop-
down list, set of radio buttons, or set of checkboxes to add to the item.

• Codelist Subset—Select a predefined set of drop-down list options, radio buttons
or checkboxes (a codelist subset) for the selected codelist.

• Collapsible—Indicate whether the item is always visible on the form in InForm, or
is collapsed and not visible until a condition is met.
For more information, see Make an item conditional on another object.

• Data Label—Text label for the item. The data label enables access to the item in
a target table with the Patient To Control key type of any of the pivot key types.

• Description—Description of the item.

• Identifier—Unique internal identifier for the item.

• Length—For text, float, and integer items, enter the length to use for the item.

Note

Enter a value of less than 4,000 characters if you anticipate that this
item's data will be sent to Data Management Workbench.

• Locked—Indicates whether the item is locked.

• MaxProperty—If a MaxValue is specified for the item, indicates whether the value
can be less than or less than or equal to the MaxValue.

• MaxValue—Maximum value that InForm will allow to be typed for the item.

• MinProperty—If a MinValue is specified for the item, indicates whether the value
can be greater than or greater than or equal to the MinValue.

• MinValue—Minimum value that the InForm application will allow to be typed for
the item.

• Modified—Indicates that the item is modified, and hasn't yet been saved.

• New—Indicates that the item is new, and hasn't yet been saved.

• PHI—Indicate whether an Oracle InForm user might enter Personal/Protected
Health Information (PHI) for the item. If you select True:

– A warning appears when you close the Rule Wizard if you create a rule with
an email action and you add the item to the subject or body of the email.
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– A validation error occurs if a rule with an email action contains the item in the
subject line or body of the email.

• Protected—Indicates that the item is protected. An item can be marked as
Protected explicitly, or by default if its parent item is protected. You cannot update
a protected item.

• Revision—Item's revision number.

• Special Fields—Used for items on special InForm forms.
For more information, see Step 4: Create special Oracle InForm visits, forms, and
items.

• Timestamp—Date and time when the item was most recently updated.

• Version—Item's version number.

f. In the Item Properties column, click Edit, and enter data for the additional properties:

• Base Unit—The default unit you want to capture data in for the item. The data for
the item is saved in this base unit in the study database. (For integer and float
items only.)

• Conversion Units—Optional units an Oracle InForm user can choose to enter
data in. If you specify one or more conversion units, the Oracle InForm user can
enter data and then select which unit he used. When the item data is stored in the
study database, the conversion unit value is converted to the base unit. (For
integer and float items only.)

• Signed Value—Reserved for future use. (For Integer items only.)

• Date Time Component Setting—Select the date and time components that you
want to appear in InForm, specify whether each is required, and indicate whether
an InForm user can select Unknown as an option for the component. (For date
time items only.)

• Year Range—First and last years that you want to appear in the Year field for the
item. (For date time items only.)

• Precision—Number of characters that a user must enter after the decimal point in
a number. For example, if an item has a precision of two, you must enter 1.00,
instead of 1.0. (For float items only.)

6. Create a layout for your form:

a. In the Project Explorer, select the form.

b. Select the Layout tab, and click the Create Layout button in the middle of the page.

By default, the layout for the form uses the study-level styles that you or your study
administrator configured. If you want to change the form's appearance, or the appearance
of one or more of its study objects, see Set the default appearance for a single form and its
study objects (form-level styles) and Set the appearance of a single study object (control
styles).

Step 4k: Create a Visit Approval form (optional)
A visit approval form allows study designers to assign a visit level signature to signature
groups. This is useful if data entered into CRFs needs to be verified as soon as possible after
the visit is complete.

When creating a Visit Approval form, consider that:

• Visit Approval CRFs can be used regardless of other CRF signature groups.
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• There can only be one Visit Approval form per visit.

• There are no restrictions on the type of visit (such as normal, dynamic, repeating, or
common) a Visit Approval form can be associated to.

Note

It is not recommended to set a Visit Approval for a common visit, as it is not a
discrete timepoint.

• Common and Repeating forms cannot be set as Visit Approval forms.

• When a Visit Approval form exists in a visit, all other forms within that visit, except common
forms, fall under the visit level signature. Any change to any of the forms within that visit
will then invalidate a Visit Approval form previously signed in Oracle InForm.

Note

If you are using visit approvals in your study and want the common form to be
signed as well, it will need to have its own CRF level signature associated with it,
as it is not part of the visit signature.

• You must create an item question for the Oracle InForm user to note whether the visit is
ready for signature.

• Oracle recommends that you create a section level note describing the visit level signature.

• Creating signature groups that include Visit Approval can be done in the same way as with
regular CRF signature groups.

To create a Visit Approval form:

1. At the bottom of the Project Explorer, click the Visit Schedule ( ) button.

2. Right-click the visit where you want to add the Visit Approval form, select New, then select
Form.

3. Enter a Title, RefName, and Description, and click OK.

4. In the Project Explorer, select the new form, and make sure the Design tab is selected.

5. Click the Properties tab, which appears on the right of the page by default.

Tip

If you don’t see the Properties tab, at the top of the page, select View, and make
sure Properties is selected.

6. At the top of the Properties tab, in the Oracle InForm section, click in the Special Forms
field, and select Visit Approval.

7. Add the Visit Approval form or forms to the CRF signature group, along with any other
CRFs that need to be signed.

8. Update the signature affidavit text as needed on a per language basis.

9. Complete the study build, validate the study, create a deployment package and deploy to
Oracle InForm.
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Step 5: Create all other visits, forms, and items
In this section:

• Step 5a: Create a visit

• Step 5b: Create forms in your visits

• Step 5c: Organize forms by creating sections

• Step 5d: Create items to collect data on forms

Step 5a: Create a visit

1. At the bottom of the Project Explorer, click the Visit Schedule ( ) button.

2. At the top of the Project Explorer, right-click Study Design, and select New Event.

3. Enter a title, RefName, and description, and click OK.

4. Click the Properties tab, which appears on the right of the page by default.

Tip

If you don't see the Properties tab, at the top left of the page, select View, and
make sure Properties is selected.

5. Optionally, specify any of the following properties for the visit:

• Repeating—Set the visit as repeating or non-repeating.

Tip

To ensure that data is captured and maintained properly, do not change this
setting after you have deployed your study. Instead, deactivate this study
object and create a new object with the updated setting.

• Short Title—Used as the visit mnemonic, which is used to identify the form in the
InForm user interface and reports. You can enter up to 63 characters.

6. Next, Step 5b: Create forms in your visits.

Step 5b: Create forms in your visits

1. At the bottom of the Project Explorer, click the Visit Schedule ( ) button.

2. Right-click the visit you want to add the form to, select New, and select Form.

3. Enter a title, RefName, and description, and click OK.

4. In the Project Explorer, select the new form, and make sure the Design tab is selected.

5. Optionally, in the upper-right above the grid, select one or more checkboxes:

• Repeating—Indicates whether the form can have more than one instance within a
visit. For example, you might want to mark an Adverse Event form as repeating.

Chapter 2
Step 5: Create all other visits, forms, and items

User Guide for Form Designers
F56110-04
Copyright © 2020, 2025, Oracle and/or its affiliates.

July 21, 2025
Page 24 of 56



• Common—Indicates whether the form is a common form. Data entered on a common
form is carried forward from visit to visit so that the form contains cumulative data for a
subject. For example, you might want to create one Logs form, which collects data
throughout the study, as common.

Tip

• To ensure that data is captured and maintained properly, do not change these
settings after you have deployed your study. If you need to make changes,
deactivate this study object and create a new object with the updated settings.

• If you plan to include items from this form, or a section on this form, in a
dynamic grid section so that it can be collected in a set of related data (for
example for submission to Argus Safety), do not mark the form as Common.

6. Click the Properties tab, which appears on the right of the page by default.

Tip

If you don't see the Properties tab, at the top left of the page, select View, and
make sure Properties is selected.

7. Optionally, specify any of the following properties for the form:

• Item Required—Indicates whether an Oracle InForm site user is required to fill out the
form.

• SDV Critical—Indicates whether the form must be source verified in Oracle InForm for
all subjects in a study at a site, even for subjects who are not part of the SV Pool. If
you select True, SDV Required is automatically set to True as well.

Note

The SDV Critical property of a form only applies to the specific study version
it was configured for. For example, if an earlier study version had SDV Critical
for a CRF set to False and a new study version is set to True, only CRFs
started on the new study version will appear in the Monitor UI.

• SDV Required—Indicates whether the form must be source verified in Oracle InForm
for all subjects in a study at a site who are part of the SV Pool.

• Short Title—Used as the form mnemonic, which is used to identify the form in the
Oracle InForm user interface and reports. You can enter up to 63 characters.
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Tip

• If this is the first form in a visit, you must include the Date of Visit item if you
are planning to use the Enforce visit date entry system configuration option
in Oracle InForm.

• If this is the first form in a repeating visit, you must include the date of visit
item.

• We recommend that you include 20 or fewer items on each form, and split any
extensive data capture requirements across multiple forms. Although there is
no predefined item limit in Oracle Central Designer, including 20 or fewer
items per form ensures optimal system performance and prevents impact on
integrated or downstream applications. For example, an in-place revision on a
study that contains a large form might create a database table with more than
1000 columns. As a result, the study deployment fails because the number of
columns exceeds an Oracle database column limit.

8. Create a layout for your form:

a. In the Project Explorer, select the form.

b. Select the Layout tab, and click the Create Layout button in the middle of the page.

By default, the layout for the form uses the study-level styles that you or your study
administrator configured. If you want to change the form's appearance, or the appearance
of one or more of its study objects, see Set the default appearance for a single form and its
study objects (form-level styles) and Set the appearance of a single study object (control
styles).

9. Next, Step 5c: Organize forms by creating sections.

For more information, see:

• Set the default appearance for a single form and its study objects (form-level styles)

• Preview a form

• Rename a form layout

Set the default appearance for a single form and its study objects (form-level styles)

1. At the bottom of the Project Explorer, click the Forms and Transactions ( ) button, and
expand the InForm folder and the Forms folder, if necessary.

2. Select the form.

3. Select the Layout tab, and click Edit Styles.

4. You can set the following styles.

Form styles

• Question column width—Percentage of the width of the layout table to use for the
question column.
For example, if you enter 50 in the field, the question occupies half of the form, and
the control where the InForm user enters data takes up the remaining half.

• Inherit—You must deselect this option to override the default study-level styles, or the
styles that your study administrator set up.
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Codelist styles

• Control orientation—Display codelist items horizontally or vertically.

• Single selection settings—Display codelist items as radio buttons or within a drop-
down list.

– Use pulldown when item count exceeds—When the number of codelist items
exceeds the specified number, display them in a pulldown control.

– Display vertically when item count exceeds—When the number of codelist
items exceeds the specified number, display them as a vertical list of radio
buttons.

• Inherit—You must deselect this option to override the default study-level styles, or the
styles that your study administrator set up.

Compound Item styles

• Caption alignment—Align the top-level item's caption to the left, top, right, or bottom
of the control.

• Control orientation—If you have a control and it has sub-controls (also called nested
controls), you can indicate whether you want the nested controls to be displayed
horizontally or vertically.

• Inherit—You must deselect this option to override the default study-level styles, or the
styles that your study administrator set up.

DateTime Item styles

• Year range—The range of years to display in date time items.

• Caption alignment—Align the top-level item's caption to the left, top, right, or bottom
of the control.

• Inherit—You must deselect this option to override the default study-level styles, or the
styles that your study administrator set up.

Float Item styles

• Caption alignment—Align the top-level item's caption to the left, top, right, or bottom
of the control.

• Textbox width—The width of the text box for the item.

– Use the item variable's length as the width—Use each item's length as the text
box width.

– Use this width—Enter a width for the text box.

• Unit control type—Display the unit controls as radio buttons or in a pulldown.

• Inherit—You must deselect this option to override the default study-level styles, or the
styles that your study administrator set up.

Integer Item styles

• Caption alignment—Align the top-level item's caption to the left, top, right, or bottom
of the control.

• Textbox width—The width of the text box for the item.
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– Use the item variable's length as the width—Use the item's length as the text
box width.

– Use this width—Enter a width for the text box.

• Unit control type—Display the unit controls as radio buttons or in a pulldown.

• Inherit—You must deselect this option to override the default study-level styles, or the
styles that your study administrator set up.

Text Item styles

• Caption alignment—Align the top-level item's caption to the left, top, right, or bottom
of the control.

• Textbox width—The width of the text box for the item.

– Use the item variable's length as the width—Use the item's length as the text
box width.

* Increase the height by one line for every __ chars—Increment the height
of the text box by one line for every specified number of characters entered
for the item.

* Use the following width and height—Enter a width (in number of
characters) and height (in number of lines) for the text box.

– Use this width—Enter a width for the text box.

• Character set restriction—Indicate whether you want to require InForm users to
enter only ASCII characters in text items without codelists, or if InForm users can use
any character set for text items.
The ASCII Only restriction is enforced if you're deploying to InForm release 5.0 or
higher.

• Inherit—You must deselect this option to override the default study-level styles, or the
styles that your study administrator set up.

5. Click OK.

Preview a form

1. At the bottom of the Project Explorer, click the Forms and Transactions ( ) button, and
expand the InForm folder and the Forms folder, if necessary.

2. Perform one of the following:

• Select a form, and select the Layout tab.

• If the layout is not generated, click Create Layout.

3. To generate a preview or an annotated preview, perform one of the following:

• Right-click a section header or the area below the layout table, and select Preview
Form.

• In the upper-left corner, click Preview, then select Preview Form.

Chapter 2
Step 5: Create all other visits, forms, and items

User Guide for Form Designers
F56110-04
Copyright © 2020, 2025, Oracle and/or its affiliates.

July 21, 2025
Page 28 of 56



Tip

• You can generate a form preview with or without annotations.

• You can preview one form at a time.

• To preview all forms in a study, generate an annotated study book.

• You can print a form preview if you have the Adobe Acrobat PDF Distiller print
driver.

Rename a form layout

1. At the bottom of the Project Explorer, click the Forms and Transactions ( ) button, and
expand the InForm folder and the Forms folder, if necessary.

2. Select a form or item, and select the Layout tab.

3. At the top of the Layout tab, click Layouts, then Rename Layout.

4. From the Layout to rename drop-down list, select a layout.

5. From the New layout name drop-down list, do one of the following:

• To use a new layout name, select New, and type a name for the layout. The name is
added to the list of registered names for the study, and you can select it from the drop-
down list.

• To use an existing name, select it from the drop-down list. The list includes all of the
study's registered names that have not been used for the form or item.

Tip

• The layout name must not already be in use for the form.

• You can rename a layout for a single form only.

Step 5c: Organize forms by creating sections
In this section:

• Create a non-repeating section

• Create a repeating section

• Create a fixed repeating section

• Create a section to collect related data (a dynamic grid)

• Optional tasks

Create a non-repeating section

1. At the bottom of the Project Explorer, click the Visit Schedule ( ) button.

2. Expand the visit with the form you want to add the section to, right-click the form, and
select New Section.
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3. Enter a title, RefName, and description, and click OK.

Tip

We recommend adding the sections in the order you want them to appear on the
form. However, if you need to reorder the sections, see Reorder the sections on a
form.

4. Make sure the Design tab is selected.

5. Next, create items in the section.

Create a repeating section
A repeating section is deployed to Oracle InForm as an Add Entry itemset. Add Entry itemsets
include the items in the section, and the ability for the Oracle InForm user to add items to the
section from within Oracle InForm.

1. At the bottom of the Project Explorer, click the Visit Schedule ( ) button.

2. Expand the visit with the form you want to add the section to, right-click the form, and
select New Section.

3. Enter a title, RefName, and description, and click OK.

Tip

We recommend adding the sections in the order you want them to appear on the
form. However, if you need to reorder the sections, see Reorder the sections on a
form.

4. Make sure the Design tab is selected.

5. In the upper-right above the grid, select the Repeating checkbox.

Tip

To ensure that data is captured and maintained properly, do not change this
setting after you have deployed your study. Instead, deactivate this study object
and create a new object with the updated setting.

6. Next, create items in the section.

Create a fixed repeating section

Why create a fixed repeating section?

You might want to design a form that allows a user to enter the same piece of data multiple
times for the same item. For example, a user might need to record a subject's heart rate while
the subject is sitting and then standing, at specified time intervals after the subject receives a
drug.

To do this, you can create a fixed repeating section in Oracle Central Designer. A fixed
repeating section is deployed to Oracle InForm as a Repeating Data itemset. For more
information, see How can I use a fixed repeating section on a form?.
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1. At the bottom of the Project Explorer, click the Visit Schedule ( ) button.

2. Expand the visit with the form you want to add the section to, right-click the form, and
select New Section.

3. Enter a title, RefName, and description, and click OK.

Tip

We recommend adding the sections in the order you want them to appear on the
form. However, if you need to reorder the sections, see Reorder the sections on a
form.

4. Make sure the Design tab is selected.

5. In the upper-right above the grid, select the Fixed and Repeating checkboxes.

Tip

To ensure that data is captured and maintained properly, do not change this
setting after you have deployed your study. Instead, deactivate this study object
and create a new object with the updated setting.

6. Next, create items in the section.

7. Do the following:

Configure the fixed repeating section

• Pre-requisites: Create an item on the section. For an item that you want to use as a
fixed column in the section, do one of the following:

– Create radio buttons on your item

– Create checkboxes on your item

– Create a drop-down list on your team

a. In the upper-right above the section's table, click the Fixed Table icon (
 

 
).

b. In the Edit Fixed Table dialog box, in the Define Fixed Columns section, select
the items to use as the columns in the section. For example, if you want to record
a subject's heart rate while the subject is sitting and then standing, at specified
time intervals after the subject receives a drug, the fixed items might be:

– Time point

– Position

– Heart rate

A fixed item must:
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– Be a top level item with no nested items.

– Be a text, integer, or float item.

– Have a codelist with:

* At least one codelist item defined. If the codelist has a defined subset,
you can only select a codelist item in the subset.

* A control type of radio button or pulldown.

Note

You cannot mark all items in a fixed repeating section as fixed.

c. Optionally, to view only fixed items in the fixed repeating section in the table,
deselect Show non-fixed columns.

d. Click Add Row.

e. Optionally, to indicate that you do not want a user to enter data for a particular
cell, right-click the cell and select Set as Blank.

f. Optionally, to modify the rows, use the buttons on the right of the dialog box.

g. Click OK.

Choose the default view for the fixed repeating section

a. In the upper-left corner of the application window, click Tools, and select Options.

b. In the Environment section, click Fixed Repeating Section, and in the Default view
type field, select one of the following:

• Grid landscape—Short questions for top-level items are arranged horizontally
across the top of the preview, and the labels for codelist items are laid out
vertically for each fixed item.
In the grid landscape view, blank cells have a gray background.

• Portrait—Short questions for top-level items are laid out vertically, and the labels
for codelist items are laid out horizontally for each fixed item.

c. Click OK.

For more information, see:

• Configure a fixed repeating section

• Choose the default view for a fixed repeating section

Configure a fixed repeating section
Pre-requisites: Create an item on the section. For an item that you want to use as a fixed
column in the section, do one of the following:

• Create radio buttons on your item

• Create checkboxes on your item

• Create a drop-down list on your team

1. In the upper-right above the section's table, click the Fixed Table icon ( ).

2. In the Edit Fixed Table dialog box, in the Define Fixed Columns section, select the items
to use as the columns in the section. For example, if you want to record a subject's heart
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rate while the subject is sitting and then standing, at specified time intervals after the
subject receives a drug, the fixed items might be:

• Time point

• Position

• Heart rate

A fixed item must:

• Be a top level item with no nested items.

• Be a text, integer, or float item.

• Have a codelist with:

– At least one codelist item defined. If the codelist has a defined subset, you can
only select a codelist item in the subset.

– A control type of radio button or pulldown.

Note

You cannot mark all items in a fixed repeating section as fixed.

3. Optionally, to view only fixed items in the fixed repeating section in the table, deselect
Show non-fixed columns.

4. Click Add Row.

5. Optionally, to indicate that you do not want a user to enter data for a particular cell, right-
click the cell and select Set as Blank.

6. Optionally, to modify the rows, use the buttons on the right of the dialog box.

7. Click OK.

Choose the default view for a fixed repeating section
1. In the upper-left corner of the application window, click Tools, and select Options.

2. In the Environment section, click Fixed Repeating Section, and in the Default view type
field, select one of the following:

• Grid landscape—Short questions for top-level items are arranged horizontally across
the top of the preview, and the labels for codelist items are laid out vertically for each
fixed item.
In the grid landscape view, blank cells have a gray background.

• Portrait—Short questions for top-level items are laid out vertically, and the labels for
codelist items are laid out horizontally for each fixed item.

3. Click OK.

Create a section to collect related data (a dynamic grid)

Why create a dynamic grid?

Show me how to create a section to collect related data (dynamic grid)
A dynamic grid section is a type of repeating section on a form, which contains a pointer to a
different repeating form or section, and a set of items from that source repeating form or
section. You can create a form with a set of dynamic grid sections, and when the study is

Chapter 2
Step 5: Create all other visits, forms, and items

User Guide for Form Designers
F56110-04
Copyright © 2020, 2025, Oracle and/or its affiliates.

July 21, 2025
Page 33 of 56

https://apexapps.oracle.com/pls/apex/f?p=44785:265:0:::265:P265_CONTENT_ID:23675


deployed to Oracle InForm, each dynamic grid section becomes an itemset, which allows a site
user to select items from across forms and visits that he deems to be related. The data that
appears in each dynamic grid is the most up-to-date data. For more information, see How can I
use a dynamic grid desction on a form?.

Note

If you mark an existing section as a dynamic grid section, the items that exist in the

section are removed, and you must click the Edit Dynamic Grid icon ( ) and
follow the steps to add new items to the section. However, you are warned before the
items are removed, and you can choose not to mark the section as a dynamic grid
section.

1. At the bottom of the Project Explorer, click the Visit Schedule ( ) button.

2. Expand the visit with the form you want to add the section to, right-click the form, and
select New Section.

3. Enter a title, RefName, and description, and click OK.

Tip

We recommend adding the sections in the order you want them to appear on the
form. However, if you need to reorder the sections, see Reorder the sections on a
form

4. Make sure the Design tab is selected.

5. In the upper-right above the grid, select Dynamic Grid, and click the Edit Dynamic Grid

icon ( ).

6. In the Edit Dynamic Grid Section dialog box, enter the following information:

• In the Source Repeating Object section at the top of the dialog box, select the visit,
repeating form, and (optionally) repeating section that contains the items you want to
make available to the InForm site user to include in the collection of related data.

• In the Item Selection for the Dynamic Grid section at the bottom of the dialog box, in
the Available items from source field, select the items to include in the dynamic grid
section, and use the buttons to move those items to the Selected items field.

7. Optionally, use the Move Up and Move Down buttons to configure the order of the items
in the dynamic grid section.

8. Click OK.

9. In the Project Explorer, select the form with the dynamic grid section, and select the
Layout tab.

10. To ensure that data is most accurately transferred from the source object to the dynamic
grid in Oracle InForm, make sure that the layout settings for the dynamic grid and its items
match the layout settings used on the items' source form.
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Tip

Pay careful attention to settings for date controls including the year range, date
components, and so forth.

Optional tasks
In this section:

• Create keys in a repeating form or section

• Hide a section header

• Reorder the sections on a form

• Remove an item from a dynamic grid section

• Disable a workflow

• Create a reference copy of a study object in a workflow diagram

• Create a site-specific layout

• Add or remove layout names

• Remove another user's lock on a study object

• Transfer another user's lock from a different session

• View the differences between two versions of a form

• View in-place revision changes for a study

• View a history of all in-place revisions for a LIVE deployment instance

• Remove the association between a deployment instance and an in-place revision

• Copy an IPR configuration from one deployment instance to another

• Lock an in-place revision object

Create keys in a repeating form or section
In repeating forms and repeating sections, you can identify certain items as key items. In
Oracle InForm, key items are used to:

• Simplify navigation to a specific instance of a repeating form. The values of key items
appear in a drop-down list in the summary view of the repeating form, and users can
navigate to a specific instance of the form by clicking the key item values for that instance.

• Verify that the values of certain items are unique among instances of a repeating form or
an itemset.

For more information, see What are key items? and What are the requirements for key items?.

1. At the bottom of the Project Explorer, click the Forms and Transactions ( ), and expand
the InForm folder and the Forms folder, if necessary.

2. Select a repeating form or section, and make sure the Design tab is selected.

3. Right-click the row of an item, and select Keys.

The key items can come from the repeating form or from a non-repeating section on the
form.
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4. In the Data uniqueness for selected keys section, select one of the following:

• None—Key items appear in a drop-down list in the summary view of a repeating form
as navigation aids. The key items are not used to enforce uniqueness of key values
across instances of the repeating form.

• Individual—Each key item must be unique across all insatnces of the repeating form
or itemset in the Oracle InForm application.

• Group—The combination of all key items evaluated together must be unique across
all instances of the repeating form or imteset in the Oracle InForm application.

5. In the Key selection section, move the key items from the Items available as keys list to
the Selected keys list, then click OK.

6. If you are creating keys for a repeating form, and you selected Individual in Step 4, select
the Unique checkbox for each item to designate as a unique key. (In a repeating section,
the Unique checkbox is selected and disabled for all selected key items.)

Tip

A set of key items for a repeating form can include items that are individually
unique and items that appear in the drop-down list but are nmot used to enforce
uniqueness.

7. To specify the order in which the items will appear in the Oracle InForm drop-down
summary list of the repeating form, select an item and click the Move Up or Move Down
button. Repeat this step for each item you want to move.

8. Click OK,

Hide a section header
A form can have multiple section headers. The top section header is the form title. An
additional section header, displaying the section title, appears for each section on the form.
Use this feature to prevent a section header from appearing on the form.

1. At the bottom of the Project Explorer, click the Forms and Transactions ( ) button, and
expand the InForm folder and the Forms folder, if necessary.

2. Select a form, and select the Layout tab.

3. Right-click a section header and from the drop-down menu select or de-select Section
Header:

If hidden, a dashed line appears above and below the header.

Reorder the sections on a form

1. At the bottom of the Project Explorer, click the Forms and Transactions ( ) button, and
expand the InForm folder and the Forms folder, if necessary.

2. Select a form with two or more sections, and then select the Design tab.

3. At the top of the Design tab, click Reorder Sections.

4. Select a section, and use the Move Up and Move Down buttons to reorder the form.

5. Click OK.
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Remove an item from a dynamic grid section

1. At the bottom of the Project Explorer, click the Visit Schedule ( ) button.

2. Select the form with the dynamic grid section, and make sure the Design tab is selected.

3. In the upper-right above the grid, select Dynamic Grid,click the Edit Dynamic Grid icon

( ).

4. In the Edit Dynamic Grid Section dialog box, in the Selected items field at the bottom
right, select the item that you want to remove, and click the Remove button.

5. Click OK.

Step 5d: Create items to collect data on forms

1. In the library project, at the bottom of the Project Explorer, click the Visit Schedule ( )
button.

2. Expand the visit and form with the section you want to add the item to.

3. In the Project Explorer, select the section, and make sure the Design tab is selected.

4. Above the grid, click the Columns button, and add the columns for the properties you want
to configure for the item.

5. Do one of the following:

• In the grid, enter data in the columns, as needed.

Tip

We recommend that you add the items in the order you want them to appear
in the section. However, if you need to reorder the items, see Reorder the
items in a section.

• If the Dynamic Grid checkbox in the upper-right above the grid is selected, you must

click the Edit Dynamic Grid icon ( ) to add items to the section. For more
information, see Create a section to collect related data (a dynamic grid).

Item columns

• Type—Select one of the following:

– Blood Pressure Item—Used to collect blood pressure information.

– Compound Item—Has one or more child items that can have different data types.

– Date Time Item—Used to collect date and time information.

– Float Item—Used to collect numerical values with decimal points, or information
for a question with a codelist (a control such as a drop-down list, a set of
checkboxes, or a set of radio buttons).

– Integer Item—Used to collect numerical values without decimal points, or
information for a question with a codelist (a control such as a drop-down list, a set
of checkboxes, or a set of radio buttons).
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– Text Item—Used to collect alphanumeric information, or information for a question
with a codelist (a control such as a drop-down list, a set of checkboxes, or a set of
radio buttons).

– Yes No Item—Used to collect yes or no answers to questions. A Yes No item
contains a predefined codelist with Yes and No options.

Tip

To ensure that data is captured and maintained properly, do not change this
setting after you have deployed your study. Instead, deactivate this study
object and create a new object with the updated setting. For example, do not
change a Float item to an Integer item.

• Title—Internal name for the item. You can choose to see study object titles or
RefNames in the Project Explorer by using the Options drop-down list at the top of the
Project Explorer. The Title can have 1-63 characters.

• RefName—Internal reference name for the item.

• Question—Item question that appears on the form. The question can have 0-1000
characters. Certain words may be reserved for this field. For more information, see Are
there words I can't use in an item's Question or Short Question?. If you enter a
customized label or translation for the item, it overrides the Question text.

• Short Question—In Oracle InForm, the short question appears as a column heading
in a repeating form, an itemset, and in reports. The short question can have 0-255
characters. Certain words may be reserved for this field. For more information, see Are
there words I can't use in an item's Question or Short Question?.

• Item Properties—Contains an Edit link, which you can click to edit additional item
properties.

• Item Required—Indicate whether the item is required for data entry on the form to be
complete.

• SDV Required—Indicate whether the item requires source document verification.

• SDV Critical—Indicate whether the item is considered critical for source verification.
The SDV Critical setting for an item can be overridden in InForm.

• Conditional On—To configure the item so that it only appears on the form when a
particular option is selected in another item, select the item in the Conditional On
column, and the required option in the Conditional Value column.
This column contains items with a drop-down list, set of radio buttons, or set of
checkboxes.

• Conditional Value—To configure the item so that it only appears on the form when a
particular option is selected in another item, select the item in the Conditional On
column, and the required option in the Conditional Value column.
This column contains the code and label of drop-down list options, radio buttons, or
checkboxes on the item that you selected in the Conditional On column.

• Display Override—Determines the default behavior of an item when a layout is
generated.

– ReadOnly—The item is visible but not editable.

– Editable—The item is visible and editable by any user, regardless of the rights
assigned to the user.

– Hidden—The item is not visible.
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– None—The item is visible to all users, and visible and editable by any user who
has the rights to view and/or edit the item.

• Key—For key items, displays icons and numbers that indicate:

– Type of key item uniqueness (None, Individual, or Group).

– Order of the items in the drop-down navigation list that appears in the summary
view of a repeating form in Oracle InForm.

In Oracle InForm, key items are used to make it easier to navigate among the
instances of a repeating form and to enforce data uniqueness in specific items.

• Codelist—For text, float, and integer items, select an existing and eligible drop-down
list, set of radio buttons, or set of checkboxes to add to the item.

• Codelist Subset—Select a predefined set of drop-down list options, radio buttons or
checkboxes (a codelist subset) for the selected codelist.

• Collapsible—Indicate whether the item is always visible on the form in Oracle InForm,
or is collapsed and not visible until a condition is met.
For more information, see Make an item conditional on another object.

• Data Label—Text label for the item. The data label enables access to the item in a
target table with the Patient To Control key type of any of the pivot key types.

• Description—Description of the item.

• Identifier—Unique internal identifier for the item.

• Length—For text, float, and integer items, enter the length to use for the item.

Tip

Enter a value of less than 4,000 characters if you anticipate that this item's
data will be sent to Data Management Workbench.

• Locked—Indicates whether the item is locked.

• MaxProperty—If a MaxValue is specified for the item, indicates whether the value can
be less than or less than or equal to the MaxValue.

• MaxValue—Maximum value that Oracle InForm will allow to be typed for the item.

• MinProperty—If a MinValue is specified for the item, indicates whether the value can
be greater than or greater than or equal to the MinValue.

• MinValue—Minimum value that the Oracle InForm application will allow to be typed for
the item.

• Modified—Indicates that the item is modified, and hasn't yet been saved.

• New—Indicates that the item is new, and hasn't yet been saved.

• PHI—Indicate whether an Oracle InForm user might enter Personal/Protected Health
Information (PHI) for the item. If you select True:

– A warning appears when you close the Rule Wizard if you create a rule with an
email action and you add the item to the subject or body of the email.

– A validation error occurs if a rule with an email action contains the item in the
subject line or body of the email.

• Protected—Indicates that the item is protected. An item can be marked as Protected
explicitly, or by default if its parent item is protected. You cannot update a protected
item.
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• Revision—Item's revision number.

• Special Fields—Used for items on special InForm forms.
For more information, see Step 4: Create special Oracle InForm visits, forms, and
items.

• Timestamp—Date and time when the item was most recently updated.

• Version—Item's version number.

6. In the Item Properties column, click Edit, and enter data for the additional properties:

• Base Unit—The default unit you want to capture data in for the item. The data for the
item is saved in this base unit in the study database. (For integer and float items only.)

• Conversion Units—Optional units an InForm user can choose to enter data in. If you
specify one or more conversion units, the InForm user can enter data and then select
which unit he used. When the item data is stored in the study database, the conversion
unit value is converted to the base unit. (For integer and float items only.)

• Signed Value—Reserved for future use. (For Integer items only.)

• Date Time Component Setting—Select the date and time components that you want
to appear in InForm, specify whether each is required, and indicate whether an InForm
user can select Unknown as an option for the component. (For date time items only.)

• Year Range—First and last years that you want to appear in the Year field for the item.
(For date time items only.)

• Precision—Number of characters that a user must enter after the decimal point in a
number. For example, if an item has a precision of two, you must enter 1.00, instead of
1.0. (For float items only.)

For more information, see:

• Add a caption to a control

• Align the position of a control's caption

• Change the orientation of a group control

• Create a drop-down list on your team

• Create radio buttons on your item

• Create checkboxes on your item

• Add a predefined set of drop-down list options, radio buttons or checkboxes (a codelist
subset) to your item

• Make an item conditional on another object

• Mark an item as hidden or read-only in Oracle InForm

• Set the appearance of a single study object (control styles)

• Reorder the items in a section

• Revert control style changes to use form- or study-level styles

• View the parents of a linked study object

Add a caption to a control
For a nested item, the Item Question becomes a caption in the Layout tab. For other items, you
can add a caption if you want to change the Item Question that appears for a particular item
instance. For example, you might want to use Gender as the question on one form, but
Gender (male or female) for the same item on another form.
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1. At the bottom of the Project Explorer, click the Forms and Transactions ( ) button, and
expand the InForm folder and the Forms folder, if necessary.

2. Select a form or item, and select the Layout tab.

3. Right-click a control, and select Edit Caption.

4. Type the caption. You can type up to 1000 characters.

5. Click one of these buttons:

• Apply/Next—Apply the caption, and advance to the next control, so that you can edit
its caption. The control for which you are editing a caption is outlined with a dotted
black line on the Layout tab.

• Apply—Apply the caption.

6. Click Close.

Tip

For a form with multiple layouts, if you add or edit a section note or caption for a
locale, the text is visible in all of the layouts.

Align the position of a control's caption

1. At the bottom of the Project Explorer, click the Forms and Transactions ( ) button, and
expand the InForm folder and the Forms folder, if necessary.

2. Select a form or item, and select the Layout tab.

3. In the workspace, select a control, and click Align Caption at the top of the Layout tab.

4. From the drop-down, select the alignment position.

Change the orientation of a group control
The child items (group control) of a compound item and the items in a codelist can appear
either horizontally or vertically in a layout.

1. At the bottom of the Project Explorer, click the Forms and Transactions ( ) button, and
expand the InForm folder and the Forms folder, if necessary.

2. Select a form or item, and select the Layout tab.

Right-click a group control, point to Orientation, and select either Horizontal or Vertical.

Create a drop-down list on your team
To add a list of choices that a user can select from a drop-down list to your form, you add a
codelist to an item. In Oracle InForm, the item question appears on the left of the page, and the
codelist (the drop-down list) appears on the right.

For example, your form might include a Gender item. To add a drop-down list that allows the
user to select a subject's gender, you add a codelist, and codelist items Male and Female.

1. At the bottom of the Project Explorer, click the Visit Schedule ( ) button.

2. Expand the visit and form with the item you want to add the codelist to.
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3. In the grid, highlight the item's row by clicking the box on the left.

4. At the top of the Design tab, click Codelist, and select New.

5. In the New Codelist dialog box, in the Design tab, enter a title, RefName, and description
for the codelist.

6. In the Data type drop-down list, select a data type for the codelist.

Tip

The data type must match the data type of the codelist's parent item, and all
codelist items (the options in the drop-down list) that you add to the codelist.

7. In the Pulldown display order dropdown select how you want the codelist options
displayed to the end user. Click Create.

8. In the grid, enter a title, RefName, code, label, and description for each codelist item
(option in the drop-down list), and press Enter or tab to save each row.

Tip

The label is the value that appears for each option in the drop-down list in InForm.
HTML formatting tags are not supported for pulldown controls. Do not use HTML
formatting tags in the Label of any of the codelist items.

9. In the Project Explorer, select the item you added the codelist to.

10. On the Design tab, in the Codelist Settings section, click Select Single Value.

11. At the top of the page, select the Layout tab.

12. If you haven't already done so, click Create Layout.

13. On the right of the page, right-click the codelist that you just created, select Control Type,
and select Pulldown.

Create radio buttons on your item
To add a set of radio buttons to your form, you add a codelist to an item. In Oracle InForm, the
item question appears on the left of the page, and the codelist (the set of radio buttons)
appears on the right.

For example, your form might include a Gender item (itmGender). To add radio buttons that
allow the user to select a subject's gender, you add a codelist (cdlGender), and codelist items
Male (cdlitmMale) and Female (cdlitmFemale).

1. At the bottom of the Project Explorer, click the Visit Schedule ( ) button.

2. Expand the visit and form with the item you want to add the codelist to.

3. In the grid, highlight the item's row by clicking the box on the left.

4. At the top of the Design tab, click Codelist, and select New.

5. In the New Codelist dialog box, in the Design tab, enter a title, RefName, and description
for the codelist.

6. In the Data type drop-down list, select a data type for the codelist.
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Tip

The data type must match the data type of the codelist's parent item, and all
codelist items (the options in the drop-down list) that you add to the codelist.

7. In the grid, enter a title, RefName, code, label, and description for each codelist item
(option in the drop-down list), and press Enter or tab to save each row.

Tip

The label is the value that appears for each option in the drop-down list in Oracle
InForm.

8. On the Design tab, in the Codelist Settings section, click Select Single Value.

9. At the top of the page, select the Layout tab.

10. If you haven't already done so, click Create Layout.

11. On the right of the page, right-click the codelist that you just created, select Control Type,
and select Radio Button.

12. To configure the display of the codelist items, right-click the codelist that you just created,
select Orientation, and select Horizontal or Vertical.

Create checkboxes on your item
To add a set of checkboxes to your form, you add a codelist to an item. In Oracle InForm, the
item question appears on the left of the page, and the codelist (the set of checkboxes) appears
on the right.

For example, your form might include a Gender item (itmGender). To add checkboxes that
allow the user to select a subject's gender, you add a codelist (cdlGender), and codelist items
Male (cdlitmMale) and Female (cdlitmFemale).

1. At the bottom of the Project Explorer, click the Visit Schedule ( ) button.

2. Expand the visit and form with the item you want to add the codelist to.

3. In the grid, highlight the item's row by clicking the box on the left.

4. At the top of the Design tab, click Codelist, and select New.

5. In the New Codelist dialog box, in the Design tab, enter a title, RefName, and description
for the codelist.

6. In the Data type drop-down list, select a data type for the codelist.

Tip

The data type must match the data type of the codelist's parent item, and all
codelist items (the options in the drop-down list) that you add to the codelist.

7. In the grid, enter a title, RefName, code, label, and description for each codelist item
(option in the drop-down list), and press Enter or tab to save each row.
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Tip

The label is the value that appears for each option in the drop-down list in Oracle
InForm.

8. On the Design tab, in the Codelist Settings section, click Select Multiple Values, and
select the minimum and maximum number of checkboxes the user can select.

9. At the top of the page, select the Layout tab.

10. If you haven't already done so, click Create Layout.

11. To configure the display of the checkboxes, right-click the codelist that you just created,
select Orientation, and select Horizontal or Vertical.

Add a predefined set of drop-down list options, radio buttons or checkboxes (a
codelist subset) to your item

A librarian or other study administrator creates a codelist and defines one or more sets of
codelist items (radio buttons, checkboxes, or options in a drop-down list), called subsets, for
the codelist. You can then add the codelist to an item, and select a subset to use for that item
instance. In this scenario, you must select a subset for each item that uses the codelist.

1. At the bottom of the Project Explorer, click the Visit Schedule ( ) button.

2. Expand the visit, form, and section with the item you want to add the drop-down list or set
of radio buttons or checkboxes to.

3. In the Project Explorer, select the item, and do one of the following:

• To add a codelist from the study, select the codelist with the subset in the drop-down
list in the Codelist field.

• To add a codelist from a library:

a. Click the Libraries tab, which appears on the right of the page by default.

Tip

If you don't see the Libraries tab, at the top left of the page, select View,
and make sure Libraries is selected.

b. Search for the drop-down list or set of radio buttons or checkboxes you want to
add:

i. Click the Categories tab, and select Codelists.

ii. Click the Libraries tab, and select the libraries you want to search in.

iii. Click Find.

c. Drag the codelist from the Libraries tab, and in the Project Explorer, drop it on the
item you want to add the drop-down list or set of radio buttons or checkboxes to.

4. Add the predefined drop-down list or set of radio buttons or checkboxes to:

A top-level (a standalone item that does not have a parent item):

a. In the Project Explorer, select the form that the item is on.
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b. Make sure that the Design tab is selected, and in the grid, in the Item Properties
column for the item, click Edit.

c. In the Codelist Settings section at the bottom of the Item Properties dialog box, in
the Subset drop-down list, select the subset of options you want to include for the
item.

d. Repeat these steps for each instance of the item in the study. You can select a
different subset for each item instance.

All other items:
If you select a form in the Project Explorer, you see top-level items and their child items.
To add a predefined drop-down list or set of radio buttons or checkboxes (a codelist
subset) to items nested at lower levels:

a. In the Project Explorer, select the form that the item is on.

b. Make sure that the Design tab is selected, and highlight the item's row by clicking the
box to the left.

c. At the top of the Design tab, click Codelist, and select Select subset for nested
items.

d. In the grid, highlight the item's row by clicking the box on the left.

e. In the Codelist Subset column, select the subset that you want to use for the item
instance, and press Enter.

f. Click OK.

g. Repeat these steps for each instance of the item in the study. You can select a
different subset for each item instance.

Make an item conditional on another object
You can configure an item so that it is only enabled in Oracle InForm if a user selects a specific
option from a drop-down list, a set of radio buttons, or a set of checkboxes. To do so, you make
the item conditional on the InForm user selecting a specified option.

• Create an item with a drop-down list, radio buttons, or checkboxes. For more information,
see:

– Create a drop-down list on your team.

– Create radio buttons on your item.

– Create checkboxes on your item.

• Make the item a child item of the item with the drop-down list, radio buttons, or
checkboxes.

Tip

If you plan to make more than one item conditional on the codelist selection within a
higher level item, include the conditional items in a compound item, and then make the
compound item conditional. This practice prevents issues down the line in Oracle
InForm reports and RDEs.

1. At the bottom of the Project Explorer, click the Visit Schedule ( ) button.

2. Expand the visit with the form that has the item you want to make conditional.
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3. In the Project Explorer, select the form.

4. In the grid, in the row for the item you want to set as conditional, in the Conditional On
column, select the item with the drop-down list, set of radio buttons, or set or checkboxes.

5. In the Conditional Value column, select the option in the drop-down list, radio button, or
checkbox that a user needs to select in order to see the conditional item.

6. Optionally, to make the item invisible on the form until the specified conditions are met:

a. In the Project Explorer, select the item.

b. Click the Properties tab, which appears on the right of the page by default.

Tip

If you don't see the Properties tab, at the top left of the page, select View,
and make sure Properties is selected.

c. To make the item invisible on the form, from the Collapsible drop-down list, select
True, and press Enter.

Mark an item as hidden or read-only in Oracle InForm

Tip

• This value overrides the form and study style settings, and applies to every
instance of the item. To configure this setting for a specific instance of the item,
use control styles. For more information, see Set the appearance of a single study
object (control styles).

• If you configure an item to be Hidden or ReadOnly, Oracle InForm site users
cannot enter data for the item. However, a rule developer can write a rule to
populate the item. For example, you can mark a BMI item as ReadOnly, and then
a rule developer can write a calculation rule to automatically populate it using the
values entered in the Height and Weight items.

1. At the bottom of the Project Explorer, click the Forms and Transactions ( ) button, and
expand the InForm folder and the Forms folder, if necessary.

2. In the grid, select the item by clicking the box to its left.

3. In the Display Override column, expand the drop-down for the item and select Hidden or
ReadOnly.

4. Save your changes.

Set the appearance of a single study object (control styles)

Tip

By following this procedure, you're configuring the styles for a particular study object
on a particular form. If the study object is used elsewhere in the study, its other
instances will use the default appearance set at the form level.
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1. At the bottom of the Project Explorer, click the Forms and Transactions ( ) button, and
expand the InForm folder and the Formsfolder, if necessary.

2. Select a form, and select the Layout tab.

3. Right-click a control, and select Edit Control Styles.

4. You can set up the following styles:

Blood Pressure Item

• Caption—Text that appears with the control in Oracle InForm.

• Caption alignment—Align the top-level item's caption to the left, top, right, or bottom
of the control.

• Control orientation—Align the controls of the Blood Pressure item horizontally or
vertically.

• Display Override—Make the control Read only (visible but not editable in Oracle
InForm) or Hidden (not visible in Oracle InForm).

Compound Item

• Caption—Text that appears with the control in Oracle InForm.

• Caption alignment—Align the caption to the left, top, right, or bottom of the control.

• Control orientation—For a control with sub-controls (also called nested controls),
indicate whether you want the nested controls to be displayed horizontally or
vertically.

Date Time Item

• Caption—Text that appears with the control in Oracle InForm.

• Caption alignment—Align the top-level item's caption to the left, top, right, or bottom
of the control.

• Visible fields—Date and time fields to make visible in Oracle InForm. For example,
you can make only the Month and Year controls visible for a date item.

• Year range—First and last years that you want to appear in the Year field for a date
item.

Float Item

• Caption—Text that appears with the control in Oracle InForm.

• Caption alignment—Align the top-level item's caption to the left, top, right, or bottom
of the control.

• Textbox size—Width of the control in which users can enter alphanumeric characters
such as letters, numbers, and punctuation marks.

• Unit control type—For an item with units or a codelist, indicate whether you want the
options to appear as radio buttons or in a drop-down list.

• Display Override—Make the control Read only (visible but not editable in Oracle
InForm) or Hidden (not visible in Oracle InForm).

Integer Item

• Caption—Text that appears with the control in Oracle InForm.
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• Caption alignment—Align the top-level item's caption to the left, top, right, or bottom
of the control.

• Textbox size—Width of the control in which users can enter alphanumeric characters
such as letters, numbers, and punctuation marks.

• Unit control type—For an item with units or a codelist, indicate whether you want the
options to appear as radio buttons or in a drop-down list.

• Display Override—Make the control Read only (visible but not editable in Oracle
InForm) or Hidden (not visible in Oracle InForm).

Text Item

• Caption—Text that appears with the control in Oracle InForm.

• Caption alignment—Align the top-level item's caption to the left, top, right, or bottom
of the control.

• Textbox size—Width of the control in which users can enter alphanumeric characters
such as letters, numbers, and punctuation marks.

• Display Override—Make the control Read only (visible but not editable in Oracle
InForm) or Hidden (not visible in Oracle InForm).

• Character set restriction—Indicate whether you want to require Oracle InForm users
to enter only ASCII characters in text items without codelists, or if InForm users can
use any character set for text items.
The ASCII Only restriction is enforced if you're deploying to Oracle InForm release 5.0
or higher.

Yes No Item

• Caption—Text that appears with the control in Oracle InForm.

• Caption alignment—Align the top-level item's caption to the left, top, right, or bottom
of the control.

• Control orientation—Align the controls horizontally or vertically.

• Codelist control type—For an item with a codelist, indicate whether you want the
options to appear as radio buttons or in a drop-down list.

• Display Override—Make the control Read only (visible but not editable in Oracle
InForm) or Hidden (not visible in Oracle InForm).

5. Click Apply, and click Close.

Reorder the items in a section

1. At the bottom of the Project Explorer, click the Forms and Transactions ( ) button, and
expand the InForm folder and the Forms folder, if necessary.

2. In the Forms folder, select the form or section containing the items to reorder. Don't select
an item itself.

3. On the Design tab, highlight a row by clicking the button on the left, then drag and drop the
button onto the button of the item to appear below it.

Chapter 2
Step 5: Create all other visits, forms, and items

User Guide for Form Designers
F56110-04
Copyright © 2020, 2025, Oracle and/or its affiliates.

July 21, 2025
Page 48 of 56



Revert control style changes to use form- or study-level styles

Tip

Text strings in the layout, including captions, notes, section titles, form titles, and
codelist item label overrides, are not affected when you reset.

1. At the bottom of the Project Explorer, click the Forms and Transactions ( ) button, and
expand the InForm folder and the Forms folder, if necessary.

2. Select a form or item, and select the Layout tab.

3. At the top of the Layout tab, click Layouts, then Reset Layout.

4. From the Layout to reset drop-down list, select the name of a layout.

5. Select one of the following options:

• Recreate layout using form-level styles and item layouts (if any)—Recreate the
layout using the form styles and existing item layouts.

• Replace all control styles with the styles from the following layout—Recreate the
layout using the form styles (which might inherit styles from the study styles) from
another layout for the same form. If you select this option, existing item layouts are not
used to recreate the layout.
If you select this option, select a layout from the drop-down list.

6. Click OK.

View the parents of a linked study object

1. In the Project Explorer, select a study object with a blue icon ( ) in the upper-left corner
of its icon. The blue icon indicates that the study object has more than one parent object.

2. Right-click the study object, and select Show Parents.

Tip

• Show Parents is available in both a study and library, but it lists only the
parents in the current project.

• Show Parents is not available for a study object on a single parent that
appears multiple times, such as an item on a form that is used multiple times
in a study.

Step 6: Create groups of visits (optional)
To create a group of visits in Central Designer, you create an element. It's useful to create
elements if your study is randomized and requires multiple treatment arms.

For example, you might create an element that contains the visits and forms for subjects taking
a specific drug, and another element that contains the visits and forms for subjects taking a
placebo. A randomization rule determines which element a subject progresses to.

To create an element:
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1. At the bottom of the Project Explorer, click the Visit Schedule ( ) button.

2. At the top of the Project Explorer, right-click Study Design, and select New Element.

3. Enter a title, RefName, and description, and click OK.

4. In the Project Explorer, select the visit, and click the Properties tab.

5. Next, add visits to your element.

• To move a visit from the study design to the element, in the Project Explorer, select the
visit, and drag and drop it onto the element.

• To add links or copies of existing visits to the element:

Tip

You might want to do this if you want to use a visit in more than one treatment
arm.

– Click the Add to tab, which appears on the right of the page by default.

– Optionally, search for a specific visit or filter the list by entering a keyword in the
Filter field.

– Select one visit, or press the Ctrl key and select multiple visits.

– At the bottom of the tab, from the drop-down list, select:

* Add as link—Add a link to the visit. If you update the visit object, it is updated
in the element.

* Add with children—Add a copy of the visit and its children. If you update the
visit object or its children, they are not updated in the element.

* Add without children—Add a copy of the visit without its children. If you
update the visit object, it is not updated in the element.

Step 7: Design your study workflow
In this section:

• Step 7a: Specify the order of visits in the study

• Step 7b: Define a visit schedule

• Step 7c: Specify the order of forms in each visit

• Step 7d: Add your rules and global conditions to the workflow

• Optional tasks

Step 7a: Specify the order of visits in the study

Tip

By following this procedure, you're placing your visits in the order you want them to be
completed in. To specify the amount of time between visits, see Step 7b: Define a
visit schedule.
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1. On the bottom of the Project Explorer, click Visit Schedule, and select Study Design.

2. Make sure the Workflow Diagram tab is selected.

3. Move the cursor over the first of the two visits you want to connect until it changes to a
pointing finger icon, and connect the visits.

Tip

• The numbers next to the screening and enrollment visits (the sequence
numbers) must be 1 (for the screening visit) and 2 (for the enrollment visit).

• The screening and enrollment visits must be disconnected from the rest of the
workflow.

4. Next, Step 7b: Define a visit schedule.

Step 7b: Define a visit schedule
Step 7a: Specify the order of visits in the study

1. On the bottom of the Project Explorer, click Visit Schedule, and select Study Design.

2. Make sure the Workflow Diagram tab is selected.

3. Double-click the arrow that connects the visits.

4. Schedule the interval between the visits:

• Target event interval—Number of weeks, days, and hours after the first visit that you
want to schedule the second visit.

• After event—The first visit that the second visit is scheduled to start after.

5. Click OK.

Tip

If you define more than one schedule leading into an element or visit (you connect
more than one arrow to the element or visit), Oracle InForm sets the interval
between visits to the schedule with the greatest amount of time. You might want to
use this workflow configuration if your study is randomized and includes more than
one treatment arm.

6. Next, for each visit, Step 7c: Specify the order of forms in each visit and, after your rules
have been written, Step 7d: Add your rules and global conditions to the workflow.

Step 7c: Specify the order of forms in each visit

1. At the bottom of the Project Explorer, click the Visit Schedule ( ) button.

2. Expand the visit you want to schedule forms in.

3. Make sure the Workflow Diagram tab is selected.

4. Move the cursor over the first of the two forms you want to connect until it changes to a
pointing finger icon, and connect the forms.
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Step 7d: Add your rules and global conditions to the workflow
A rule developer creates rules and global conditions on forms and visits, and they appear in
the Workflow Diagram tab after they're created. You can connect the rules to study objects to
specify the study object that comes next in the workflow based on the outcome of the rule.

1. At the bottom of the Project Explorer, click the Visit Schedule ( ) button.

2. Select Study Design.

3. Make sure the Workflow Diagram tab is selected.

4. Move the cursor over the rule or global condition until it changes to a pointing finger icon,
and connect the rule to the next object in the workflow.

5. In the If the value is section, indicate when you want the next object in the workflow to
appear, and click OK.

6. If the workflow branches differently for different outcomes of the rule, repeat the procedure
for the other branch.

Optional tasks
In this section:

• Create keys in a repeating form or section

• Hide a section header

• Reorder the sections on a form

• Remove an item from a dynamic grid section

• Disable a workflow

• Create a reference copy of a study object in a workflow diagram

• Create a site-specific layout

• Add or remove layout names

• Remove another user's lock on a study object

• Transfer another user's lock from a different session

• View the differences between two versions of a form

• View in-place revision changes for a study

• View a history of all in-place revisions for a LIVE deployment instance

• Remove the association between a deployment instance and an in-place revision

• Copy an IPR configuration from one deployment instance to another

• Lock an in-place revision object

Disable a workflow

1. At the bottom of the Project Explorer, click the Visit Schedule ( ) button.

2. Select a study design, study element, or study event.

3. Select the Workflow Diagram tab.
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4. Click Disable Workflow.

Tip

• The workflow arrows turn gray, and the study event sequence numbers re-appear
and turn gray.

• Central Designer only sends a message on validation about disabled rules. You
will not receive a message that lists the disabled workflows in your study.

Create a reference copy of a study object in a workflow diagram
A reference copy is a duplicate image of a study object in a workflow diagram. If you have a
complicated workflow diagram, you can use a reference copy of a study object to separate the
tangle of connecting lines and make the workflow diagram less cluttered.

1. In the Project Explorer, select a study design (in a study only), study element, or study
event.

2. Select the Workflow Diagram tab.

3. Right-click the study object in the workflow diagram, and select the Create Reference
Copy.

Step 8: Create a coding map (optional)
1. At the bottom of the Project Explorer, click the Forms and Transactions ( ) button, and

expand the InForm folder and the Forms folder, if necessary.

2. Select a form, and select the Coding tab.

3. Click New Coding Map.

4. Fill in the fields in the dialog box, then click OK.

Tip

If you specify an item other than the verbatim item in the Assign queries to field, all
queries entered in InForm by Oracle InForm Adapter, whether they come from Oracle
Central Coding, Oracle DMW, or any other integrated application, are entered on that
item.

Step 9: Select a primary layout for the study
In this section:

• Set the primary layout

• Optional tasks

Set the primary layout
1. In the upper-left corner, click Tools, then select Layout Names Manager.

2. In the Primary layout name section, select one of the following options:
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• Use Main as the primary layout name—The layout named Main is the primary
layout.

• Use the following as the primary layout name—The layout that you choose from the
drop-down list is the primary layout.

3. Click OK.

Tip

If you rename the primary layout, it is no longer the primary layout.

Optional tasks
In this section:

• Create keys in a repeating form or section

• Hide a section header

• Reorder the sections on a form

• Remove an item from a dynamic grid section

• Disable a workflow

• Create a reference copy of a study object in a workflow diagram

• Create a site-specific layout

• Add or remove layout names

• Remove another user's lock on a study object

• Transfer another user's lock from a different session

• View the differences between two versions of a form

• View in-place revision changes for a study

• View a history of all in-place revisions for a LIVE deployment instance

• Remove the association between a deployment instance and an in-place revision

• Copy an IPR configuration from one deployment instance to another

• Lock an in-place revision object

Create a site-specific layout
Creating a new layout is necessary if, for example, you cannot ask a question at a particular
site.

1. Set the primary layout for the study, and make sure that a primary layout exists for every
form in the study, even the forms for which you have to hide one or more questions for a
specific locale.

2. For the form that contains the question that you cannot ask at a site, create a new layout.

a. In the Project Explorer, select the form.

b. Select the Layout tab, and click the Create Layout button in the middle of the page.

For example, you might call the layout Hidden Question. This form still requires a primary
layout, even though you will not deploy it.
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3. In the Hidden Question layout, select the locale for the site that does not allow the
question, and hide the question.

4. Create additional layouts called Hidden Question for any other forms that must not ask
certain questions for the site.

5. When you create a deployment package, choose the Hidden Question layout as the
layout to deploy.

The Hidden Question layout is deployed for all forms that have it. For all other forms, the
primary layout is deployed.

Add or remove layout names

Tip

You can add a name to a layout at any time. However, you can use the name once for
each form in a study.

1. In the upper-left corner, click Tools and select Layout Names Manager.

2. Perform one of the following:

• To add a layout name, click Add, type the name of the layout, and click OK.

• To remove a layout name, from the list of layout names, select a layout, and click
Remove.

3. Click OK.

Step 10: Lock and protect your study objects (optional)
In this section:

• Step 10a: Lock a study object

• Step 10b: Protect a study object

• Optional tasks

Step 10a: Lock a study object
• In the Project Explorer, right-click the study object, and select Lock.

Step 10b: Protect a study object
1. In the Project Explorer, right-click a study object, and select Protect.

2. If the Protect dialog box appears, select the objects you want to protect, and click Yes.

Optional tasks
In this section:

• Create keys in a repeating form or section

• Hide a section header
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• Reorder the sections on a form

• Remove an item from a dynamic grid section

• Disable a workflow

• Create a reference copy of a study object in a workflow diagram

• Create a site-specific layout

• Add or remove layout names

• Remove another user's lock on a study object

• Transfer another user's lock from a different session

• View the differences between two versions of a form

• View in-place revision changes for a study

• View a history of all in-place revisions for a LIVE deployment instance

• Remove the association between a deployment instance and an in-place revision

• Copy an IPR configuration from one deployment instance to another

• Lock an in-place revision object

Remove another user's lock on a study object
1. In the Project Explorer, right-click the study object, and select Revoke Lock.

2. Click Yes to confirm.

Transfer another user's lock from a different session
1. In the Project Explorer, right-click the study object, and select Transfer Lock.

2. Click Yes to confirm.

Step 11: Validate and deploy your study
Contact the person in your organization who validates and deploys studies so that he can:

1. Validate the study and create a baseline.

2. Create a deployment package from the validation baseline.

3. Install the deployment package in the Oracle InForm study.

For more information, see the User Guide.
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3
After your study has been deployed

In this chapter:

• Make a study version change to a deployed study

• Make an in-place revision change to a deployed study

• Optional tasks

Make a study version change to a deployed study

1. At the bottom of the Project Explorer, click the Visit Schedule ( ) button.

2. At the top of the Project Explorer, right-click Study Design, and select Create Version.

3. Select one of the following options:

• Increment major number—Increment the major number by one and reset minor and
revision numbers to 0.

For example, version 1.2.34 changes to 2.0.0.

Tip

You might want to choose this option if you are deploying to a live study.

• Increment minor number—Increment the minor number by one and reset revision
number to 0.

For example, version 1.2.34 changes to 1.3.0.

Tip

You might want to do choose this option if you are deploying to a study in UAT.

4. Type a version label and description.

5. Click Create.

6. Edit the study objects as needed.

7. Contact the person in your organization who validates and deploys studies so that he can:

a. Validate the study and create a baseline.

b. Create a deployment package from the validation baseline.

c. Install the deployment package in the Oracle InForm study.

For more information, see the User Guide.

Make an in-place revision change to a deployed study
For a study that you deploy to Oracle InForm release 6.1 or later:

User Guide for Form Designers
F56110-04
Copyright © 2020, 2025, Oracle and/or its affiliates.

July 21, 2025
Page 1 of 5



1. At the bottom of the Project Explorer, click the Forms and Transactions ( ) button, and
expand the InForm folder and the Forms folder, if necessary.

2. Select a form, and then select the Layout tab.

3. Select an item question or section header on which to apply the in-place revision.

• To add or remove a codelist subset, select the item question.

• To make an in-place revision change to an existing item in a codelist subset, select the
section header.

• To make an in-place revision change to an existing item in a non-repeating section,
select the item question.

• To make an in-place revision change to an existing item in a repeating section, select
the section header.

• To add an item to a section (repeating, or dynamic grid), select the section header.

4. At the top of the Layout tab, all the way to the right, click IPR Configuration.

5. On the IPR Configuration screen, type a description of the change (optional).

6. Select or add the deployment instance to associate with the in-place revision.

7. Optionally, to compare the form containing the revised study object with the same form
from an existing InForm study version, click View Differences. For more information, see 
View the differences between two versions of a form.

8. Select the study version or versions to apply the change to, and click OK.

9. If your in-place revision includes any of the following changes to a form or section that is
used as a source form for a dynamic grid section, you must apply the same in-place
revision change to the dynamic grid section:

• Remove an item from a source form or section.

• Modify an item in a source form or section.

• Add an item to a source form or section, and map that item to a dynamic grid section.

Tip

If you want to add a form or section and use it as a source form for a dynamic grid,
you need to create a new study version, rather than an in-place revision.

10. Next, contact the person who does study validation at your organization to validate and
deploy the study.

Optional tasks
In this section:

• Create keys in a repeating form or section

• Hide a section header

• Reorder the sections on a form

• Remove an item from a dynamic grid section

• Disable a workflow

• Create a reference copy of a study object in a workflow diagram
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• Create a site-specific layout

• Add or remove layout names

• Remove another user's lock on a study object

• Transfer another user's lock from a different session

• View the differences between two versions of a form

• View in-place revision changes for a study

• View a history of all in-place revisions for a LIVE deployment instance

• Remove the association between a deployment instance and an in-place revision

• Copy an IPR configuration from one deployment instance to another

• Lock an in-place revision object

View the differences between two versions of a form

Tip

• If you manually deploy your study, you must have a successfully deployed
baseline to view the differences between two versions of a form.

• If you perform an in-place revision and manually deploy the study, when you
attempt to view the differences between two versions of a form, the differences
shown are not correct.

1. At the bottom of the Project Explorer, click the Forms and Transactions ( ) button, and
expand the InForm folder and the Forms folder, if necessary.

2. Select a form, and then select the Layout tab.

3. At the top of the Layout tab, all the way to the right, click IPR Configuration.

4. In the IPR Configuration dialog box, select a deployment instance and a study version, and
click View Differences.

5. Do the following:

• In the Form drop-down list, select a form.

• In the Preexisting version drop-down list, select a study version with which to
compare the form.

• If your study uses more than one locale, in the Locale drop-down list, select a locale.

6. Click View Differences.

7. Optionally:

• To view details about the differences, at the bottom of the screen, select a study object.

• To preview or print each version of the form individually, click the Preview Form
button, and select an action from the drop-down list.

View in-place revision changes for a study
You can also configure your annotated study book to include a listing of the in-place revisions
created for a study. For more information, see the User Guide.
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1. At the bottom of the Project Explorer, click the Visit Schedule ( ) button.

2. Select the study design.

3. Select the IPR Summary tab.

View a history of all in-place revisions for a LIVE deployment instance

1. At the bottom of the Project Explorer, click the Visit Schedule ( ) button.

2. Select the study design.

3. Select the IPR Summary tab.

4. Click History.

5. At the top of the IPR History dialog box, select a baseline with successful deployments to a
LIVE deployment instance, and click Show IPRs.

Note

IPR history appears only for in-place revisions applied through automated
deployments.

6. Optionally, to view the IPR configuration for an in-place revision, select the in-place
revision and click View Configuration.

Remove the association between a deployment instance and an in-place
revision

1. At the bottom of the Project Explorer, click the Visit Schedule ( ) button.

2. Select the study design.

3. Select the IPR Summary tab.

4. Select one or more in-place revision study objects for which to remove a deployment
instance association.

5. Click IPR Configurations, and select Remove.

6. Select one or more deployment instances, and click OK.

Note

If you delete a deployment instance that is associated with an IPR configuration,
and that IPR configuration is not associated with any other deployment instances,
Oracle Central Designer deletes the IPR configuration from the study.

Copy an IPR configuration from one deployment instance to another

1. At the bottom of the Project Explorer, click the Visit Schedule ( ) button.

2. Select the study design.

Chapter 3
Optional tasks

User Guide for Form Designers
F56110-04
Copyright © 2020, 2025, Oracle and/or its affiliates.

July 21, 2025
Page 4 of 5



3. Select the IPR Summary tab.

4. Select one or more in-place revision study objects for which to copy an IPR configuration.

5. Click IPR Configurations, and select Copy.

6. At the top of the page, select the deployment instance from which to copy IPR
configurations.

7. At the bottom of the page, select one or more instances to which to copy the
configurations.

Tip

Click Refresh to remove study versions that don't exist in the target deployment
instance, and select an existing study version.

8. Click OK.

Note

Oracle Central Designer overwrites IPR configurations that already exist for the
deployment instance.

Lock an in-place revision object

1. At the bottom of the Project Explorer, click the Visit Schedule ( ) button.

2. At the top of the Project Explorer, select Study Design, and select the IPR Summary tab.

3. In the grid, highlight the in-place revision that you want to lock, and at the top of the IPR
Summary tab, select Lock and Protect, and select Lock.
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4
FAQs

In this chapter:

• General

• Default appearance of forms

• Library objects and reuse

• Object reuse

• Forms

• Sections

• Items

• Group of visits

• Study workflow

• Coding maps

• Layouts

• Lock and protect

• LNMT (Lab Normals Management Tool)

• After your study has been deployed

General
In this section:

• What is the difference between a RefName and a title?

• Which HTML formatting tags are supported?

What is the difference between a RefName and a title?
• RefNames are referenced in rules and are deployed to Oracle InForm. Therefore, they

must:

– Follow C# or CDASH naming standards.

– Start with a letter or an underscore.

– Contain only letters, numbers, and underscores.

– Be unique within a study or library. For example, you cannot have a form and an item
with RefNames of DOV in the same study or library.

• Titles are the more readable display names for study objects. They can contain spaces
and special characters, but are not referenced in rules and are not deployed to Oracle
InForm.
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Which HTML formatting tags are supported?
HTML formatting tags, including but not limited to the following examples, are supported in
Oracle InForm when deployed from a Oracle Central Designer study.

Note

HTML formatting tags are not supported for pulldown controls. If you format a codelist
so that its codelist items appear in a pulldown control in Oracle InForm, do not use
HTML formatting tags in the Label of any of the codelist items.

HTML tag Use

<b ></b> Bold text.

<br> Line break.

<center></center> Centering text.

<i></i> Italic text.

<li></li> List items.

<ol></ol> Numbered list.

<p></p> Paragraphs.

<pre></pre> Preformatted plain text, for example, computer
output.

<s></s> Strikethrough text.

<strike></strike> Strikethrough text.

<tt></tt> Monospace font.

<u></u> Underlined text.

<ul></ul> Bulleted list.

Default appearance of forms
In this section:

• Can I change the way my forms and their study objects look?

Can I change the way my forms and their study objects look?
Yes you can, using styles.

• Study styles apply to all forms and items in the study.

• Form styles override study styles and apply to all layouts for a form.

• Control styles override form and study styles for one control only. Keep in mind that some
items, such as compound items, contain multiple controls. If you modify a control style,
only the selected control is changed.

For example:

• To align all captions on a form in the same way, you can provide a value in the form styles.
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• To align all captions on a form differently, you can provide a different value for each control
in the control styles.

Library objects and reuse
In this section:

• What happens when I add a library object to my study?

What happens when I add a library object to my study?
• A copy of the object and its children are created in the study. If you change the object in

the study, it's not updated in the library, and vice versa.

• The object RefName is appended with _1 (or similar) if:

– There is another object in the study with the same RefName.

– You use the Copy > With Children or the Copy > Without Children option.

Object reuse
In this section:

• What happens when I copy and apste a study object?

• What happens when I copy a study object grouped by data mappings?

• What happens when I break the link of a copied study object?

What happens when I copy and apste a study object?

Tip

• You can only paste a codelist on an item of the same type. For example, you can
add an integer codelist only to an integer item.

• When you copy a codelist item, a copy is created with a new identifier, meaning
that a new codelist item is created.

You can copy a study object as a link, with, or without children.

Drag and drop

• The object and its child objects are copied.

• The original object and its copy are linked. If you update the copied object, the original is
updated, and vice versa.

• The original child objects and their copies are linked. If you update the original child
object, the copy is updated, and vice versa.

• Reference copies of the object, its child objects, or their copies are linked. If you update
the copy or the original of the object or its child objects, reference copies of the updated
objects are also updated.
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Select Copy, then select Link (either in the Project Explorer, or in the Add To tab)

Tip

This option is not available for groups of visits (elements) or visits (events).

• The object and its child objects are copied.

• The original object and its copy are linked. If you update the copied object, the original is
updated, and vice versa.

• The original child objects and their copies are linked. If you update the original child
object, the copy is updated, and vice versa.

• Reference copies of the object, its child objects, or their copies are linked. If you update
the copy or the original of the object or its child objects, reference copies of the updated
objects are also updated.

Select Copy, then select With children (either in the Project Explorer, or in the Add To
tab)

• The codelist and its child objects are copied.

• The original codelist and its copy are not linked. If you update the original codelist, the
copy is not updated, and vice versa.

• The original child objects and their copies are not linked. If you update the original child
object, the copy is not updated, and vice versa.

Select Copy, then select Without children (either in the Project Explorer, or in the Add
To tab)

• The codelist and its child objects are copied.

• The original codelist and its copy are not linked. If you update the original codelist, the
copy is not updated, and vice versa.

• The original child objects and their copies are linked. If you update the original child
object, the copy is updated, and vice versa.

What happens when I copy a study object grouped by data mappings?
• When you copy a data mapping, data set, or data series, the new study object contains

item amppings.

• When you copy a data series, the items that are part of a data series are not copied, but
data series mappings to items are copied.

For example, you add an item to a data series, and the item is mapped to be part of the
data series only when the item appears in a specific form, the mapping of the item to the
data series for the form is copied.

• When you copy a data set or mapping definition that contains a data series, the mappings
are also copied.

– If you use the new data series in another study, the mappings are retained.

– If you later add the item and form that are mapped to the data series to the study
containing the data series, the mapping appears in the Data Series Summary tab.
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Copied study object Copied within a study or
library

Copied from one study or
library to another

Data mapping, data set, or data
series

Mappings to items that are part of
the data series are retained in the
new study object.

Item mappings are not copied to
the new study object.
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Copied study object Copied within a study or
library

Copied from one study or
library to another

Item, form, or visit that is mapped
to a data series

The new study object is mapped
to the data series.

If you break the link between the
original and the new study object,
the new study object is still
mapped to the data series.

The study object is copied, but
data mappings are not copied.
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Copied study object Copied within a study or
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Copied from one study or
library to another
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What happens when I break the link of a copied study object?
When you break the link of a study object, a new study object is created.

There are two ways to break a link:

• Right-click the object in the Project Explorer, and select Break link, then select:

– With new children

* A new study object is created in the original object's place.

* Identical child objects are created as children of the new study object.

– With links to children

* A new study object is created in the original object's place.

* The original child objects become the children of the new study object.

Forms
In this section:

• What types of forms I can create?

• Where do I edit the properties of a form, section, item, or codelist?

What types of forms I can create?
• Repeating—Holds multiple instances of the same set of data.

To make a form repeating, set the Repeating property to True.

• Common—Same data is visible in all study events that contain the form.
To make a form common, set the Common property to True.

• Associated (Two repeating forms in the same study event)—Data from both forms in the
association is accessible when a study user works with either form.
To associate two forms, set the AssociatedForm property of one form to the Title of the
other form.

Where do I edit the properties of a form, section, item, or codelist?
You can edit form and item properties from the grid or on the Properties tab, which appears on
the right of the page by default. Almost everything you might want to edit is within the grid on
the Design tab or accessible from the buttons at the top of the Design and Layout tabs.

Sections
In this section:

• Are sections required on forms?

• How do sections impact my RDE?

• What types of sections can I create?

• How can I use a fixed repeating section on a form?

• How can I use a dynamic grid desction on a form?
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• Can I use a Hidden item in a dynamic grid section?

• Can I use an item more than once in a section?

Are sections required on forms?
Sections are not required components of a form. However, if you create an item outside of a
section, you can't edit it after deployment. If you do include a section in a form, the section
must have at least one item.

When you select a form that has one or more sections in the Project Explorer, the grid shows
the sections in the form.

How do sections impact my RDE?
The structure of a Report Data Extract (RDE) is impacted by the design of your study. Some
considerations for using sections include, but are not limited to:

• For a form with more than one regular, non-repeating section, the RDE contains one row
for each section per subject and visit combination.

• For a form with a single regular, non-repeating section, the RDE contains one row for each
subject and visit combination.

• If you download an RDE as a set of SAS datasets, the RDE contains a separate SAS
dataset for each form and repeating section combination.
For example, for a form that contains a regular, non-repeating section and a repeating
section, the RDE includes two datasets; one of the non-repeating section, and one for the
repeating section.

What types of sections can I create?
• Repeating—Multiple instances of the same set of data appear in the section.

• Fixed repeating—Multiple instances of the same set of data appear in the section,
organized by one or more fixed items.
For more information, see How can I use a fixed repeating section on a form?.

• Dynamic grid—Pointers to items on an existing form, which an InForm site user can
select to indicate a relationship between the items.
For more information, see How can I use a dynamic grid desction on a form?.

How can I use a fixed repeating section on a form?
You might want to design a form that allows a user to enter the same piece of data multiple
times for the same item. For example, a user might need to record a subject's heart rate while
the subject is sitting and then standing, at specified time intervals after the subject receives a
drug.

To do this, you can create a fixed repeating section in Oracle Central Designer. A fixed
repeating section includes items for which predefined values are configured by using codelists
at study design time, and cannot be modified at runtime.

For the above example, the fixed repeating section contains the following study objects:
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Study object Type Description

TimePoint item Text, Integer, or Float The amount of time before or
after a drug is administered when
data is collected.

Contains predefined values.

Time points codelist Text, Integer, or Float Codelist items for each required
time point.

• Codelist item 1—Pre-dose
• Codelist item 2—15 minutes

post dose
• Codelist item 3—30 minutes

post dose
• Codelist item 4—45 minutes

post dose
• Codelist item 5—60 minutes

post dose
The codelist items are the
predefined values for the
TimePoint item.

Position item Text, Integer, or Float The subject's position when the
data is collected.

Contains predefined values.

Position codelist Text, Integer, or Float Codelist items for each required
subject position:

• Codelist item 1—Sitting
• Codelist item 2—Standing

The codelist items are the
predefined values for the
Position item.

HeartRate item Any type, other than Date The subject's heart rate at each
time point, for each position.

Does not contain predefined
values.

To create the rows, select an item and click the Fixed Table button at the top of the Design tab.
You might create the following rows:

Row itmTime value itmPosition value itmHeartRate

1 Pre-dose Sitting –

2 Pre-dose Standing –

3 15 minutes post dose Sitting –

4 15 minutes post dose Standing –

5 30 minutes post dose Sitting –

6 30 minutes post dose Standing BLANK

7 45 minutes post dose Sitting –

8 45 minutes post dose Standing –

9 60 minutes post dose BLANK –

10 60 minutes post dose Standing –
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You can also specify a data point that you do not want data for, but that appears in the fixed
repeating section. This becomes a blank cell.

The following illustration shows the fixed repeating section in the form layout.

 

 

Image Key Description

1 HeartRate item that does not contain predefined
values.

2 Fixed TimePoint and Position items that contain
predefined values.

3 TimePoint codelist item for the Pre-dose predefined
value. Each TimePoint codelist item contains two
rows; each row corresponds to a Position codelist
item.

4 Position codelist with predefined Sitting and
Standing values. These predefined values appear
five times in the fixed repeating section layout; each
instance corresponds to a TimePoint predefined
value.

5 Blank cell for an item in a non-fixed column.

6 Blank cell for an item in a fixed column.

In some cases, it might not make sense for you to collect certain data points. To do this, when
you create a fixed repeating section, you locate the cell that corresponds to the data point, and
set it as blank. In the annotated form preview, a cell that corresponds to data that should not be
collected is grayed out. In Oracle InForm, data cannot be entered for that data point.
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How can I use a dynamic grid desction on a form?
A dynamic grid section is a type of repeating section on a form, which contains a pointer to a
different repeating form or section, and a set of items from that source repeating form or
section. By adding a dynamic grid section, when the study is deployed the site user can select
which items from the itemset to include relying on clinical judgment.

For example, in Oracle InForm, a site user might want to use one form to collect all of the
information about a serious adverse event (SAE) that needs to be submitted to a safety
application such as Oracle Argus Safety. Consider a scenario in which a subject suffers a heart
attack while taking an investigational medication. Then, while in the hospital, the subject is
prescribed a blood thinner, and develops a fever. The Oracle InForm site user has determined
that the data entered about the heart attack, the investigational product the subject was taking,
the blood thinner, and the subsequent fever is all related to the SAE heart attack. He wants to
submit all of this information to Oracle Argus Safety.

To facilitate the collection and transmission of this data, which is entered on multiple forms over
the course of multiple visits, you can include a single form in the study design. The form
contains dynamic grid sections with all of the items from existing forms that might contain data
that the Oracle InForm site user wants to send to Oracle Argus Safety. For example, a
dynamic grid section to collect related adverse events and their onset and end dates, a
dynamic grid section to collect concomitant medications, and a dynamic grid section to collect
data from lab reports created during the subject's hospital stay. When the study is deployed to
Oracle InForm, the dynamic grid sections become itemsets in which the site user is presented
with the most up-to-date data entered in the items you added to the dynamic grid sections. The
site user can select all or some of the data presented in the dynamic grid section to send to
Oracle Argus Safety.

Can I use a Hidden item in a dynamic grid section?
No. Even though Oracle Central Designer does not prevent you from including a hidden item in
a dynamic grid, when you deploy your study to Oracle InForm, the Oracle InForm site user
can't select items to include on the form from the dynamic grid section with the hidden item.

Therefore, we recommend that you do not:

• Add an item with a Display Override setting of Hidden to a dynamic grid section.

• Set an item's Display Override control-level style to Hidden in the layout of a dynamic grid
section.

Can I use an item more than once in a section?
You can use an item only one time in any level of a particular study object hierarchy. For
example, you can use the same item in different sections of a form but not twice in the same
section of the form.

In a single section, you can use the same item as a child item in two different compound items.
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Tip

• If you copy an item as a link in different sections on a form, when you produce an
RDE, the column names that correspond to each link are appended with a suffix
such as _1, _2, and so forth.

• We recommend that you only reuse an item on multiple instances of the same
form (for example, on every Vital Signs form, but not on the Vital Signs form and
the Baseline form).

• If you copy an item as a link, you cannot make a change to a single instance of the
item. Each change is applied to all instances.

Items
In this section:

• How do I create multiple choices for users to select from?

• What are key items?

• What are the requirements for key items?

• Are there words I can't use in an item's Question or Short Question?

How do I create multiple choices for users to select from?
Codelists enable you to design items in which a user selects from multiple choices. A codelist
consists of codelist items, each with a code (the database value) and a label (the value, or
choice, that is visible to users). You create a codelist item for each choice.

Certain properties of codelists and codelist items must be unique:

• Code of a codelist item—Must be unique within a codelist.

• Label of a codelist item—Must be unique within a codelist.

• RefName of a codelist or codelist item—Must be unique within study object type.

• Title of a codelist or codelist item—Must be unique within a codelist.

You can include a codelist in the definition of a float, integer, or text item, and the Yes No item
type includes a predefined codelist that contains Yes and No options. When you create a
codelist, specify whether a study user must select only one option or can select multiple
options.

Codelist data can appear as a drop-down list, as a set of radio buttons, or as a set of
checkboxes. You specify the formatting information when you generate the layout of the form
or item containing the codelist.

Codelists and conditional item relationships

If you want to design more complex items in which a user both selects one or more options
and provides additional information about the selected option or options, you can make an item
conditional on an option in a codelist. You can use conditional relationships for collecting:

• Nested levels of multiple-choice data.

• User-entered information along with multiple-choice data.
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What are key items?
In repeating forms and repeating sections, you can identify certain items as key items. In
Oracle InForm, key items are used to:

• Simplify navigation to a specific instance of a repeating form. The values of key items
appear in a drop-down list in the summary view of the repeating form, and users can
navigate to a specific instance of the form by clicking the key item values for that instance.

• Verify that the values of certain items are unique among instances of a repeating form or
an itemset.

Key items can have individual or group uniqueness.

• Key items in a repeating section must always be defined as having individual or group
uniqueness and are not used as navigation tools for instances of itemsets in Oracle
InForm.

• If key items are defined with individual uniqueness, an Oracle InForm user cannot add an
instance of a repeating form or itemset in which the value of any key item is identical to the
value of that item in another instance.
A set of key items for a repeating form can include both items that are individually unique
and items that appear in the drop-down list for navigation but are not used to enforce
uniqueness. The key items can come from the repeating form or from a non-repeating
section in the form.

• If key items are defined with group uniqueness, they make up a composite key. An Oracle
InForm user cannot add an instance of a repeating form or itemset in which the values of
all of the items in the composite key are the same as the values of all of the composite key
items in another instance.
If a group of key items is defined with group uniqueness, no other items in the repeating
form or section can be defined as non-unique key items. Only the items that are defined
with group uniqueness appear in the drop-down list of a repeating form.

What are the requirements for key items?
A key item must:

• Be in a repeating section if the key is for an itemset.

• Be in a non-repeating section if the key is for a repeating form.

• Be unique in a repeating section.

A key item must not:

• Be a hidden item or be attached to a read-only control.

• Be a child in a compound item.

• Be a child of a conditional item.

• Have a combination of composite keys and individually unique keys in the same repeating
form or section.

• Have a conditional child that is a compound item or is formatted as a checkbox or radio
control.

• Be formatted as a checkbox.

• Have a caption that is aligned at the top or bottom of the control, including captions for
conditional items.
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• Be in a nested control structure, unless it is at the top of the hierarchy and conforms to
other eligibility requirements.

• Be in a repeating section, if the key is for a repeating form.

Are there words I can't use in an item's Question or Short Question?
The reserved words below cannot be used for the following item properties:

• Short question.

• Default question or Question if a Short question is not provided, or is populated with a
reserved word.

If you specify a reserved word for the item Default question or Question you must provide a
Short question that is not a reserved word, or the clinical model in the Reporting and Analysis
module fails to generate.

Note

You cannot use the English reserved words or Japanese reserved characters for any
locale.

For example, to design an item for which a reserved word appears as the question on the form
in the Oracle InForm application, specify the following:

• Question—Reserved word such as Subject Number.

• Default question or Short question—A word that is not on the reserved words list, such as
Subj Number.

Subject Number appears as the question on the form, and Subj Number appears in the clinical
model in the Reporting and Analysis module and as the itemset column header on the form in
the Oracle InForm application. In addition, the clinical model is successfully generated.

A warning does not appear in the Oracle Central Designer application if a reserved word is
used incorrectly.

English words Japanese characters

SITECOUNTRY 施設の国名

SITENAME 施設名

SITEMNEMONIC 施設略称

SUBJECTINITIALS 症例イニシャル

SUBJECTNUMBERSTR 症例番号

VISITMNEMONIC ビジット略称

VISITORDER ビジットオーダー

VISITIDX ビジットインデックス

FORMMNEMONIC フォーム略称

FORMIDX フォームインデックス

DELETED 削除フォーム

ITEMSETIDX アイテムセットインデックス

DELETEDITEMSET 削除アイテムセット
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English words Japanese characters

DOV ビジット日時

NOTDONE 未実施

CREATEDBYUSERID 基本データ

CREATEDDATETIME その他のデータ

MODIFIEDBYUSERID 不完全データの理由

MODIFIEDDATETIME 内部 ID

SITEID 施設

SUBJECTID 症例

VISITID ビジット

VISITINDEX フォーム

SUBJECTVISITID セクション

FORMID アイテム

FORMREV ルール

FORMINDEX クエリ

SECTIONID コメント

ITEMSETID 定義済フィルタ

ITEMSETINDEX すべての登録済症例

FORMASSOCID 脱落者を除いたすべての登録済症例

CD_COUNT 有効症例

Basic Data クリニカルビジット

Additional Data クリニカルフォーム

Incomplete Data Reasons 開始フォーム

Internal Id's 見込フォーム:予定ビジット

Sites 見込フォーム:予定ビジットまたは開始ビジット

Subjects 見込フォーム:現在までの予定ビジットまたは開始
ビジット

Visits 見込フォーム:現在までの予定ビジットまたは開始
フォーム

Forms データ完了(クエリを含む)

Sections データ完了(オープンクエリを含まない)

Items クリーンデータ:完了かつ SDV 済み

Rules –

Queries –

Comments –

Predefined Filters –

All Enrolled Subjects –

All Enrolled Subjects except Dropped –

Active Subjects –

Clinical Visit –

Clinical Form –

Started Forms –

Chapter 4
Items

User Guide for Form Designers
F56110-04
Copyright © 2020, 2025, Oracle and/or its affiliates.

July 21, 2025
Page 16 of 42



English words Japanese characters

Expected Forms: Scheduled Visits –

Expected Forms: Scheduled or Started Visits –

Expected Forms: Scheduled or Started Visits to
Date

–

Expected Forms: Scheduled Visits or Started
Forms to Date

–

Data Complete (Queries Allowed) –

Data Complete, No Open Queries –

Data Clean: Complete and SV –

Site Country –

Site Name –

Site Mnemonic –

Subject Initials –

Subject Number –

Visit Mnemonic –

Visit Order –

Visit Index –

Form Mnemonic –

Form Index –

Deleted Form –

Itemset Index –

Deleted Itemset –

DOV –

Not Done –

Group of visits
In this section:

• What is a study element?

What is a study element?
In Oracle InForm, a study element is a collection of visits that are scheduled as a unit. They're
optional, but provide the following benefits:

• To simplify a complex workflow diagram, create a study element and include several visits
in it. Your workflow diagram has more layers but is easier to navigate.

• Study elements make it easy to reuse a collection of visits. If you add several visits to a
study element and include the study element in a library, you can reuse all of the visits by
reusing the study element.

Study workflow
In this setion:
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• What happens during deploment if I disable a workflow?

• What kinds of rules can be added to my study?

• Sample Workflows

What happens during deploment if I disable a workflow?
If you disable a workflow, all workflow rules and global conditions associated with the workflow
are disabled. When you deploy the study, the forms associated with that workflow appear in
Oracle InForm in the order specified by their sequence numbers in the Workflow Diagram.

Note

This functionality only applies to the current workflow, and does not apply to child
workflows. For example, if you disable a workflow at the study design level, the child
workflows at the event or form level are not disabled.

What kinds of rules can be added to my study?
You might need to work with the following types of rules in a workflow diagram.

• Data-entry rules—Checks whether data is valid or that sets the value of an item based on
a calculation.

• Workflow rules—Tests data values to determine which element, visit, or form a subject
progresses to next.

• Global conditions—Determines whether the study object will appear for a particular
subject.

Sample Workflows
Simple sequence of forms or visits
 

 
Order in Oracle InForm: Form A, Form B, Form C.

Multiple sequences of forms or visits
A workflow can contain multiple sequences of connected study objects. The first study object
in each sequence is labeled with a sequence number.
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Order in Oracle InForm: Form A, Form B, Form C, Form D, Form E.

Workflow with study elements
 

 
Order in Oracle InForm: Visit 1, Visit 2, Visit 3, Visit 4.
(Dotted lines indicate that the study elements contain the visits. These study objects do not
appear together in the Workflow Diagram.)

Workflow with study elements and visits
 

 
Order in Oracle InForm: Visit 1, Visit 2, Visit 3, Visit 4, Visit 5.
(Dotted lines indicate that the study elements contain the visits. These study objects do not
appear together in the Workflow Diagram.)

Workflow with workflow rule (Example 1)
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Order in Oracle InForm:

• Initially—Visit 1, Visit 2. Only Visit 1 and Visit 2 are in the Case Book. All other visits are
dynamic and depend on the outcome of the rule.

• If the rule evaluates to True—Visit 1, Visit 2, Visit 3, Visit 4. Visit 5 and Visit 6 are
dynamic and do not appear in the Case Book.

• If the rule evaluates to False—Visit 1, Visit 2, Visit 5, Visit 6. Visit 3 and Visit 4 are
dynamic and do not appear in the Case Book.

(Dotted lines indicate that the study elements contain the visits. These study objects do not
appear together in the Workflow Diagram.)

Workflow with workflow rule (Example 2)
 

 
Order in Oracle InForm:

• Initially—Visit 1, Visit 2, Visit 4, and Visit 5. Only Visit 3 is dynamic.

• If the rule evaluates to True—Visit 1, Visit 2, Visit 3, Visit 4, and Visit 5.
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• If the rule evaluates to False—Visit 1, Visit 2, Visit 4, and Visit 5. Visit 3 is dynamic and
does not appear in the Case Book.

(Dotted lines indicate that the study elements contain the visits. These study objects do not
appear together in the Workflow Diagram.)

Workflow with a global condition
 

 
Order in Oracle InForm:

• Initially, or if the condition evaluates to False—Form A, Form C. Form B is dynamic
and does not appear in the Case Book.

• If the condition evaluates to True—Form A, Form B, Form C.

Workflow with a global condition (dynamic)
 

 
Dynamic status in Oracle InForm:

• Initially, or if the condition evaluates to False—Form A and Form C are in the Case
Book. Form B is dynamic and does not appear in the Case Book.

• If the condition evaluates to True—Forms A, B, and C are in the Case Book.

Complex workflow with global conditions (Example 1)
Study components

• Visit1

– Form1

* Item1

* Item2

• Visit2 (with a global condition)

– Form2 (with a global condition)

Behavior

• Enter a value for Item1 and submit Form1 without entering a value for Item2: Visit2
appears.

• Enter a value for Item2 and submit Form1 without entering a value for Item1: Neither
Visit2 nor Form2 appears.

• Subsequently enter a value for Item1 and submit Form1; Both Visit2 and Form2 appear.
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Complex workflow with global condition (Example 2)
Study components

• Visit1

– Form1

* Item1

* Item2

• Element1 (with a global condition)

– Visit2

– Visit3 (with a global condition)

Behavior

• Enter a value for Item1 and submit Form1 without entering a value for Item2: All the visits
in Element1 appear.

• Enter a value for Item2 and submit Form1 without entering a value for Item1: None of the
visits in Element1 appear.

• Subsequently enter a value for Item1 and submit Form1: All the visits in Element1 appear.

One sequence of visits with scheduling
 

 
Scheduling in Oracle InForm: Visit 1 and Visit 2 are scheduled. Visit 2 is scheduled one day
after Visit 1.

Multiple sequences of visits
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Scheduling in Oracle InForm:

• All visits except Visit 3 are scheduled. Visits 2, 4, and 5 are scheduled one day after the
previous visit.

• The STARTHOUR attribute of Visit 3 is one hour after Visit 2.

• Visit 5 is scheduled three days plus one hour after Visit 1.

Workflow rule with scheduled visits
 

 
Scheduling in Oracle InForm:
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• Visit 1 is scheduled.

• The STARTHOUR attribute of Visit 2 is calculated to be one day after Visit 1, but Visit 2
does not appear in the Visit Calculator when the value of Rule1 is true.

• The STARTHOUR attribute of Visit 3 is calculated to be five days after Visit 1, but Visit 3
does not appear in the Visit Calculator when the value of Rule1 is false.

Global condition with a scheduled and unscheduled visit
 

 
Scheduling in Oracle InForm:

• Visit 1 is scheduled.

• The STARTHOUR attribute of Visit 2 is calculated to be one hour after Visit 1, but Visit 2
does not appear in the Visit Calculator.

• Visit 3 is scheduled as one day after Visit 2 and one day plus one hour after Visit 1.

Scheduled study elements
 

 
Scheduling in Oracle InForm:

• Visit 1 is scheduled.
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• Visit 2 is unscheduled. Its STARTHOUR value is one hour after Visit 1.

• Visit 3 is scheduled as one day after Visit 2.

• Visit 4 is scheduled as one day after Visit 3, or two days plus one hour after Visit 1.

(Dotted lines indicate that the study elements contain the visits. These study objects do not
appear together in the Workflow Diagram.)

Unscheduled study elements
 

 
Scheduling in Oracle InForm:

• Visit 1 is scheduled.

• Visits 2, 3, and 4 are unscheduled. The STARTHOUR value of each is one hour after the
preceding visit.

(Dotted lines indicate that the study elements contain the visits. These study objects do not
appear together in the Workflow Diagram.)

Coding maps
In this section:

• What are the components of a coding map?

What are the components of a coding map?
When you create a coding map, you specify:

• An item to code.

• One or more items that will receive code or term information from Oracle Central Coding.

• One or more items that contain context information. Context information provides
assistance to the person who codes the item.

• A query target. When a Oracle Central Coding user creates a query, the query appears on
the query target item in the Oracle Health Sciences InForm application.

If you select a query target item for a coding map, you can only deploy the study to a version of
Oracle Health Sciences InForm that supports coding query targets. Only text items without
codelists are available for Item to code and Target Item.

Layouts
In this section:
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• What is the primary layout and how do I set it?

• What happens when I delete a layout?

What is the primary layout and how do I set it?
You set the primary layout for a study at the study level. The first layout that you create for a
form or item is given the name of the primary layout.

Note

Changing the name of the primary layout affects all forms. If a form has a layout
named Main, and you choose to use the layout named Spanish as the primary layout,
then all layouts named Spanish become the primary layouts.

What happens when I delete a layout?
You can delete any layout, including the primary layout. All text strings, including captions,
notes, section titles, form titles, and codelist item label overrides are saved until you delete the
last layout for a form. Questions are not deleted, even if you delete the last layout for a form.

Lock and protect
In this section:

• What happens when I revoke a lock held by another user?

• What happens when I revoke a lock on an object with children?

• What happens when I protect an object?

• What happens when I unprotect an object in a study?

What happens when I revoke a lock held by another user?
When you revoke a lock, any unsaved changes made by the person who holds the lock are
lost.

What happens when I revoke a lock on an object with children?
Remote locks on the child objects are also revoked.

What happens when I protect an object?
When a study object is protected, its icon changes to reflect its protected state, and you can't:

• Update the object.

• Explicitly or implicitly lock the object.

• Drag and drop an object onto the protected object.

• Paste an object onto the protected study object.

• Delete the object's child objects.
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What happens when I unprotect an object in a study?
• If you select Unprotect—Unprotect only the selected study object. You can unprotect a

study object that came from a library only if you have the Unprotect study objects from
libraries right.

• If you select Unprotect with children—Unprotect the selected study object and all of its
children.

– If the study object that you are unprotecting with children was copied from a library, the
study object and all of its children are unprotected.

– If the study object that you are unprotecting with children was created in the study and
you copied one or more of its children from a library, the study object is unprotected,
but any children copied from the library are not unprotected. You can unprotect them
individually.

LNMT (Lab Normals Management Tool)
In this section:

• Forms

• Units

• Queries

• Items and sections

• Design

• Rules

Forms
In this section:

• What type of forms are supported by LNMT?

What type of forms are supported by LNMT?
LNMT supports the following forms:

• Common forms

• Repeating forms

• Forms with fixed repeating sections

Note

Oracle recommends all lab forms to be repeating with both a date and time of draw in
order to accommodate labs split between different local laboratories and to
accommodate multiple labs in the same day for unscheduled visits.
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Units
In this section:

• Do lab test ranges and eCRFs have to be associated with the same single unit?

• Should I prompt sites to enter units on a form?

• Should lab tests and units be pre-identified for each study?

• Do lab tests and eCRFs must have the same specimen types?

Do lab test ranges and eCRFs have to be associated with the same single unit?
No. Lab tests that provide ranges in single units do not have to be associated with that unit on
the lab eCRFs. However, for Lab tests where ranges can be entered in more than one unit, the
site have to select a unit on the eCRF and configure LNMT to return ranges in that unit.

Note

When lab tests have more than one unit, the unit must be available through drop-down
controls. Radios controls are not recommended.

Should I prompt sites to enter units on a form?
It is not recommended to prompt sites to enter units on the form. However, if you want to use
this feature, units entered by a site must be contained in the same compound control with the
result.

Should lab tests and units be pre-identified for each study?
Yes. All lab tests and units should be pre-identified for each study and added to the LNMT
configuration files for entering normal ranges through the LNMT user interface.

Do lab tests and eCRFs must have the same specimen types?
Yes. If Lab Tests are captured for more than one specimen type, all associated lab specimen
types must be available via drop-down controls on the lab eCRF.

Queries
In this section:

• Why isn’t LNMT submitting query text in Oracle InForm?

Why isn’t LNMT submitting query text in Oracle InForm?
LNMT does not submit query text in Oracle InForm for an abnormal result.

To submit a query, program query rules when the “Within Range” value is “N” or “INV”.

LNMT generates error queries for range retrieval failures only when this feature is enabled in
the LNMT query module.
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Items and sections
In this section:

• What properties must LNMT-populated fields have?

• How should objects be created for LNMT?

• How can I reuse objects for LNMT?

What properties must LNMT-populated fields have?
Fields populated by LNMT must be read-only or hidden.

Also, SDV and item required properties must be set to FALSE.

How should objects be created for LNMT?
You must create each lab test in its own section within the form.

When the same lab test is used in two different sections with different refnames, two entries of
that test must be created in order to import data through LNMT.

Note

For a quicker and clearer LNMT configuration, Oracle recommends each object to be
named intuitively and uniquely.

How can I reuse objects for LNMT?
You can reuse objects so they have the same refnames starting from the section level down to
the control level. This makes creating the mappings between the LNMT database and the
Oracle InForm database easier for the technical consultant.

Design
In this section:

• Should I label each LNMT-related object in any specific way?

• How many lab tests can go into a form processed by LNMT?

• How should LNMT range items returned from LNMT be designed on lab forms?

• How should fixed repeating sections be configured for LNMT?

• What fields are defined in Oracle InForm for LNMT?

Should I label each LNMT-related object in any specific way?
Yes. Oracle recommends the LNMT items to be clearly labelled with the parameter name to
ensure these are easily identifiable in the reporting database.

For example, the question and short question texts must identify the parameters ‘Red Blood
Cells Normal Range’ and ‘RBC NR’ respectively.
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How many lab tests can go into a form processed by LNMT?
To avoid performance issues, Oracle recommends not to include more than 15 lab tests (for
example, Albumin) on each form processed by LNMT.

How should LNMT range items returned from LNMT be designed on lab forms?
There are different options to design a lab form for LNMT.

Option 1 – Common form with 4 textboxes

This option requires 4 textboxes for every lab test on the eCRF. The textboxes should display:

• Lower limit

• Upper limit

• Unit

• Within Range Flag

LNMT populates the Within Range flag with a value indicating if the lab result is In-range (Y),
Out of Range (N), or Invalid (INV).

With this option, you get separate columns in SAS for all 4 test boxes. However, if the lab
normal was entered as < 100 instead of 0 to 100, LLN is populated with -2147483648 and ULN
is populated with 100.

Option 2 – Common form with 2 textboxes

This option requires 2 textboxes for every lab test on the lab eCRF. The textboxes should
display the following values:

• Range and Unit textbox: Lower limit, Upper limit, and Unit. This textbox displays lab
normal ranges along with their unit.

• Within Range textbox: Within Range. This textbox indicates if the lab results are In-
range, Out of Range or Invalid.

With this option, not all lab tests will have lab normal ranges expressed as a numeric range
with defined lower and upper limits. Some lab tests can character-based normal values (for
example, “Negative”, “Neg”, “No” or “N”), some lab test can have normal ranges defined using
operators and others (for example, “Normal cholesterol is < 200 mg/dL”), and some lab tests
can have no units associated with test results (for example, “pH” or “specific gravity”).

However, using this options means you have to differentiate in SAS LLN, ULN, and Unit.

How should fixed repeating sections be configured for LNMT?
Fixed ItemSet controls must capture results for a single lab test at different time periods. The
fixed ItemSet should only have the following three columns:

• Lab test name column

• Result and unit column

• LNR values column

Chapter 4
LNMT (Lab Normals Management Tool)

User Guide for Form Designers
F56110-04
Copyright © 2020, 2025, Oracle and/or its affiliates.

July 21, 2025
Page 30 of 42



Note

For the Result and Unit and LNR values columns, display controls should be in a
compound control with fields required by LNMT.

What fields are defined in Oracle InForm for LNMT?
The following fields are defined in Oracle InForm for LNMT:

Data point Format Required? Comments

LAB ID A(50) Yes Usually entered by the
CRA or site staff. This
value is used by LNMT
to look for lab ID and lab
normals data in the
LNMT system.

Lab ID datatype must be
the same for all lab
forms.

Lab name Defined by the user No Can be entered by the
site staff to enable
correct entry of lab ID.

Collection/Sample
analysis date

Date (or datetime) Yes This date value is used
by LNMT to check if it
falls under the lab
normals effective dates
(to-from) when looking
for Lab Normal Ranges
(LNRs).

Specimen type Max A(50) Yes (if present) The specimen type
control must always be a
drop-down control.

Lab test parameter
(RBC) result

Character: Max A(50)

Numeric: F(10,4) or
N(10)

Yes Entered lab test result
(character: positive/neg;
Numeric: 12.5/30)
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Data point Format Required? Comments

Units Max A(50) Yes (if present) Lab result unit. The unit
control must always be a
drop-down control.
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Data point Format Required? Comments
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Data point Format Required? Comments

Range and unit A(150)

Read-only or Hidden

Yes/No Data points to which the
lab normal data is
returned. Short question
and Short question text
should include the
parameter (for example,
hemoglobin – NR).

The refname for LNMT
Range and unit textbox
should be descriptive
enough to be easily
identified as paired with
a particular parameter.

Note: Depending on the
lab design for each lab
test, LNMT either sends
lab normal ranges into 3
textboxes for Lower limit,
Uper limit, and Unit, or
an entire numeric and
character-based lab
normal range into one
textbox with the caption
“Range and unit”.

Within range? A(20)

Read-only or Hidden

Yes LNMT populates Y, N, or
INV in this textbox
indicating a result is in
range. No Oracle InForm
rule is required for this.
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Data point Format Required? Comments

DOB (M/D/Y) Date (mm/dd/yyy) No This is taken from the
Oracle InForm form, and
is usually the patient
demog form.
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Data point Format Required? Comments

d
e
f
i
n
e
d
i
n
L
N
M
T
.

Age (in years) N3 No For studies where DOB
is not captured.

This data point requires
some reference date
field, such as Oracle
InForm consent or
enrollment date.
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Data point Format Required? Comments

Gender Radio group:

• Male
• Female
• Unknown
• Undifferentiated

Yes This is taken from the
Oracle InForm form, and
is usually the patient
demog form.
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Data point Format Required? Comments
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Rules
In this section:

• What rules or edit checks should be on the lab eCRF?

What rules or edit checks should be on the lab eCRF?
• Add an edit check for Out of Range or Invalid lab values if you want these values to be

validated, as they won't be automatically queried in LNMT.

• Use form calculations to normalize the lab result, unit, LLN, and ULN, and create a grade
by populating a new item. Avoid using Oracle InForm normalization for lab results as the
conversions are often analyze-specific.

• Select Run Rules under the LNMT-Import tab application configuration to enable rule
enforcement based on LNMT-populated items. Remember to deselect Form Comment
under pre-processors so that comments on the form do not interfere with analyze returns.

After your study has been deployed
In this section:

• What in-place revision changes are supported?

• Can I change a form from common to not common?

• Can I change a form from repeating to non-repeating?

• What is an in-place revision?

• How do I mark a shared study objet as an in-place revision?

What in-place revision changes are supported?
In this section:
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• Supported in-place revision changes with no regulatory or data impact

• Supported in-place revision changes that may affect the meaning of data on a form

• Supported in-place revision changes that may affect reguilatory compliance

Supported in-place revision changes with no regulatory or data impact
• Expand the year ranges in a date control.

• Change item properties to not required or SDV not required.

• Increase the length of a text, integer, or float field.

• Add hidden items to manage rule modifications.

• Add a new checkbox option for a control used to trigger forms in an Unscheduled Visit.

Supported in-place revision changes that may affect the meaning of data on a form
• Update item text to correct spelling or punctuation errors, provided the meaning is not

changed.

• Add options to radio, pull down, or checkbox controls to allow sites to enter data
accurately.

• Add items to an existing section.

Supported in-place revision changes that may affect reguilatory compliance
• Remove items that contain data.

• Reduce the length of text, integer, or float fields.

• Decrease the precision of a float field.

• Reduce the maximum limit or increase the minimum limits on integer or float fields.

• Remove selections from pull down lists, radio controls, or checkbox controls.

• Decrease the date range for a date control.

• Change codelist selection labels.

• Remove UNK or NREQ in date controls.

• Remove date parts, such as hours and minutes.

• Change in control structure, such as adding levels of nesting.

Can I change a form from common to not common?
This change is not recommended. While this change is allowed in Oracle Central Designer,
changing a form from common to not common, or not common to common causes
downstream issues that could potentially result in data loss. We recommend creating a new
form, rather than modifying an existing form.

Can I change a form from repeating to non-repeating?
This change is not recommended. While this change is allowed in Oracle Central Designer,
changing a form or section from repeating to not repeating causes downstream issues that
could potentially result in data loss. We recommend creating a new form, rather than modifying
an existing form.
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What is an in-place revision?
An in-place revision (IPR) allows you to make a study design change and apply it to existing
study versions that were previously deployed to Oracle Health Sciences InForm. When you
update a study by deploying a new study version, you can only modify forms that have not
been started in Oracle Health Sciences InForm. However, the in-place revision feature allows
you to modify an item on a form and deploy the changes to all instances of the form in a
specified study version, including forms that were started or completed in that study version.

You create an in-place revision on a top-level item or a section by selecting the form from the
Visit Schedule and displaying the Layout tab. The annotated study book for a study optionally
includes a listing of the in-place revisions created for a study.

How do I mark a shared study objet as an in-place revision?
The following examples illustrate two ways to apply an in-place revision to a shared study
object, with the same results when deployed to Oracle Health Sciences InForm.

Method 1
Vital Signs 1 and Vital Signs 2 contain the shared item BP. You deploy the study and later edit
both forms by adding mmHg as caption text on the BP item. Next, you create a single in-place
revision on the Vital Signs 1 form, specifying that the change applies to the previously
deployed Vital Signs 1 and Vital Signs 2 forms upon deployment.
The in-place revision icon appears only on the Vital Signs 1 form in Oracle Central Designer.
After deployment, the mmHg caption appears on both forms in Oracle Health Sciences
InForm.

• Original forms in Oracle Central Designer and Oracle Health Sciences InForm:
 

 

• Forms in Oracle Central Designer after the caption is updated and the in-place revision is
created:
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• Forms in Oracle Health Sciences InForm after deployment of the in-place revision:
 

 

Method 2
For the same set of forms with the same caption changes to the deployed study, you create:

• A single in-place revision on the Vital Signs 1 form, specifying that the change applies to
the previously deployed Vital Signs 1 form upon deployment.

• A single in-place revision on the Vital Signs 2 form, specifying that the change applies to
the previously deployed Vital Signs 2 form upon deployment.

The in-place revision icon appears on both the Vital Signs 1 and Vital Signs 2 forms in Central
Designer.
After deployment, the mmHG caption appears on both forms in Oracle Health Sciences
InForm.

• Original forms in Oracle Central Designer and Oracle Health Sciences InForm:
 

 

• Forms in Oracle Central Designer after the caption is updated and the in-place revision is
created:
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• Forms in Oracle Health Sciences InForm after deployment of the in-place revision:
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5
What if...

In this chapter:

• A "Predefined value not found" message appears in a form layout

• A study object with a restriction is updated in the library

• I added a dynamic grid section from a library, but it doesn't contain any items

• I added a dynamic grid section from a library, but some items are missing

• I added a set of radio buttons to my form, but when I deployed, it showed up as a drop-
down list

• I can't add an item to a section

• I can't create a form or section in my study

• I can't create an item on a form in my study

• I can't copy a form or section

• I can't delete an object

• I can't edit items, codelists, codelist items, or codelist subsets in my study

• I can't find the item I want to add to a dynamic grid section

• I can't mark a section as a dynamic grid section

• I can't revoke the lock on a study object

• I copied a form as a link, but now I can't break the link

• I request an in-place revision for a study version that doesn't exist in the target deployment
instance

• There are no studies in my Recent Projects list

• Auto-deployment doesn't complete and I need to open a Support ticket

A "Predefined value not found" message appears in a form layout
If you create a fixed repeating section, define a codelist item in a subset as a fixed column or
row, and subsequently remove the codelist item from the subset or remove the subset from the
codelist, an error appears in the form layout. To resolve the error, update the fixed repeating
section so that it doesn't include invalid codelist items.

A study object with a restriction is updated in the library
If you add a library object to a study, and the object is restricted for editing, you can't update it
to match the new version in the library. To update the study object to match the library object,
you can replace it with the updated version from the library.
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I added a dynamic grid section from a library, but it doesn't
contain any items

Check to make sure that the dynamic grid section's source object is the same in the study as it
is in the library. For example, if the library dynamic grid contains item1 on section1 in form1
and visit, you must include that item in the same path. If your study contains item1 on
section2 in form1 and visit1, the item is removed from the library dynamic grid when you add
it to the study.

As a best practice, if you want to add a dynamic grid section from a library to a study, identify
the visits, forms, and sections that its items are on, and add those objects in the correct path
before you add the dynamic grid section.

I added a dynamic grid section from a library, but some items are
missing

This could happen if:

• The item in the library dynamic grid section exists in the study, but does not exist on the
source form or section that is referenced in the dynamic grid section.

• The item in the library dynamic grid section is a top-level item, but is not a top-level item on
the source form or section in the study.

• The item in the library dynamic grid section is a top-level item, but one or more of its
conditional items does not exist on the source form or section in the study.

• The item in the library dynamic grid section has conditional items that do not match the
study item's conditional items.

To prevent this issue, ensure that all items referenced in a dynamic grid section exist in the
study before you add a library dynamic grid to the study.

I added a set of radio buttons to my form, but when I deployed, it
showed up as a drop-down list

The Use pulldown when item count exceeds study-level style setting is set to five by default.
As a result, if you add a set of radio buttons (a codelist) to your form, and it contains more than
five radio buttons (codelist items), it appears in Oracle Health Sciences InForm as a drop-down
list when you deploy your study.

To change the setting for a single codelist instance, use the control-level styles. For more
information, see Set the appearance of a single study object (control styles).

I can't add an item to a section
The section might be a dynamic grid section. If it is, it can only contain items from a specified

source form or section, and you need to select the Edit Dynamic Grid button ( ) and add
items to the section in the Edit Dynamic Grid Section dialog box.
To determine if a section is a dynamic grid section:
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1. In the Project Explorer, select the form that the section exists on, and make sure the
Design tab is selected.

2. Check to see if the Dynamic Grid checkbox above the section is selected.

I can't create a form or section in my study
Your study might include restrictions that prevent you from creating new forms or sections in
your study. If your study includes these restrictions, you are also prevented from adding an
existing section to a form. To view the list of restrictions that are enabled, select the study in
the Project Explorer.

I can't create an item on a form in my study
Your study might include restrictions that prevent you from modifying a form from a library. To
view the list of restrictions that are enabled, select the study in the Project Explorer.

I can't copy a form or section
Your study might include restrictions that prevent you from copying existing forms or sections.
To view the list of restrictions that are enabled, select the study in the Project Explorer.

I can't delete an object
This can happen if:

• The object is protected, or is the child of a protected object.
Review the object's protected status and try again.

• The object is an item that is used in a dynamic grid section. (If you try to delete an item that
is used in a dynamic grid section, an error appears and tells you why you can't delete the
item.)
Remove the item from the dynamic grid section, and then try again to delete it from the
form.

• The object is a visit, form, or section that is used in a dynamic grid section.
Remove the item from the dynamic grid section, and then try again to delete it from the
form.

• The object is a child of an item that is used in a dynamic grid section.
Remove the item from the dynamic grid section, and then try again to delete it from the
form.

• The object is conditional on an item that is used in a dynamic grid section.
Remove the item from the dynamic grid section, and then try again to delete it from the
form.

I can't edit items, codelists, codelist items, or codelist subsets in
my study

Your study might include restrictions that prevent you from modifying the properties of items
from a library, or modifying codelists from a library. To view the list of restrictions that are
enabled, select the study in the Project Explorer.
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I can't find the item I want to add to a dynamic grid section
If you want to add an item to a dynamic grid section, but the visit, form, or section that it's on
(its source object) doesn't appear when you create the dynamic grid, make sure that the
following conditions are met for the source object.

• The source visit is not a repeating visit.

• The source form is not a common form.

• The source form is not the form you're adding the dynamic grid to.

• If the source form is repeating, the item exists in a non-repeating section. (If the item you
want to add is in a repeating section on a repeating form, you can't include that item
instance in the dynamic grid.)

• The source section is not a dynamic grid section.

• The source objects exist in the Study Design folder in the Project Explorer.

If the source visit, form, and section appear when you create the dynamic grid, but the item
doesn't, make sure that the following conditions are met for the item:

• If the source form is repeating, the item is a top-level item on the form or a top-level item in
a non-repeating section on the form.

• If the source section is repeating, the item is a top-level item in the section.

I can't mark a section as a dynamic grid section
If you want to mark a section as a dynamic grid section, but Oracle Central Designer prevents
you from doing so, make sure that the following conditions are met for the section.

• The section is repeating.

• The section is not marked as fixed.

• The section doesn't exist on a common form.

I can't revoke the lock on a study object
This can occur if a study object has a parent object that is locked by another user. Contact the
other user to unlock the parent object and try again.

I copied a form as a link, but now I can't break the link
If your study includes restrictions that prevent you from creating forms or sections in your
study, you are also prevented from breaking the link of copied forms and sections, because
breaking the link creates a new form or section. To view the list of restrictions that are enabled,
select the study in the Project Explorer.
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I request an in-place revision for a study version that doesn't
exist in the target deployment instance

Oracle Central Designer ignores the request, and the in-place revision change is not
completed for the study version that does not exist. A warning appears in the deployment
package.

Tip

Click Refresh in the IPR Configuration dialog box to remove study versions that don't
exist in the target deployment instance before you copy an in-place revision
configuration to a new deployment instance.

There are no studies in my Recent Projects list
One of the following may be true:

• You haven't opened any studies yet. When you open a study, it will appear in the Recent
Projects List the next time that you access the list.

• You aren't included in any study teams, and therefore don't have access to any studies.
Contact your application administrator to be granted the correct access.

Auto-deployment doesn't complete and I need to open a Support
ticket

If auto-deployment doesn't complete and the trial is left in Maintenance mode, you must submit
a ticket to Oracle Support.

1. Log into the Support home page.

2. Submit a Support ticket:

a. From the Issue Category list, choose System Unavailable.

b. In the text field, type Related to Auto-Deployment.
This is key to the ticket being routed correctly and effectively at Oracle, which helps
minimize resolution time.

c. Add any other text you feel is appropriate.

3. Immediately after submitting the ticket, alert other trial users that the trial is unexpectedly in
Maintenance mode as a result of an issue while deploying a design change.
Say that you have already submitted a ticket to request assistance. Emphasize that:

• Oracle will take the trial out of Maintenance mode at the earliest possible point. If
judged to be safe, this would be in parallel to the auto-restore issue being investigated.

• Do not submit further tickets on the issue to Oracle Support as this could detract focus
on optimum resolution time.

If other auto-deployment issues occur that you are unable to resolve, you must submit a ticket
to Oracle Support.

1. Log into the Support home page.
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2. Submit a Support ticket:

a. From the Issue Category list, choose an appropriate category.

b. In the text field, type Related to Auto-Deployment.
This is key to the ticket being routed correctly and effectively at Oracle, which helps
minimize resolution time.

c. Add any other text you feel is appropriate.

Chapter 5
Auto-deployment doesn't complete and I need to open a Support ticket

User Guide for Form Designers
F56110-04
Copyright © 2020, 2025, Oracle and/or its affiliates.

July 21, 2025
Page 6 of 6



6
Revision history

Date Part number Description

May 2025 F56110-03 Added a new LNMT (Lab
Normals Management Tool)
section to the FAQs chapter.

January 2025 F56110-02 Added a note on the SDV Critical
property, under step 7 in Step 5b:
Create forms in your visits.

January 2023 F56110-01 Original version of this document.

User Guide for Form Designers
F56110-04
Copyright © 2020, 2025, Oracle and/or its affiliates.

July 21, 2025
Page 1 of 1


	Contents
	Preface
	Documentation accessibility
	Related resources
	Diversity and Inclusion
	Access to Oracle Support
	Additional copyright information

	1 Basics
	How do I log on?
	How do I change my password?
	How do I get help?

	2 Build a study
	Step 1: Open your study
	Step 2: Set the default appearance of ayour forms (study-level styles)
	Step 3: Add library objects to your study (optional)
	Step 4: Create special Oracle InForm visits, forms, and items
	Step 4a: Create a screening visit
	Step 4b: Create a screening form in the screening visit
	Step 4c: Create an enrollment visit
	Step 4d: Create an enrollment form in the enrollment visit
	Step 4e: Create a subject identification form
	Step 4f: Create a final visit
	Step 4g: Create a study completion in the final visit
	Step 4h: Create a randomization form (Optional)
	Step 4i: Create a visit report form (optional)
	Step 4j: Create a regulatory document form (optional)
	Step 4k: Create a Visit Approval form (optional)

	Step 5: Create all other visits, forms, and items
	Step 5a: Create a visit
	Step 5b: Create forms in your visits
	Set the default appearance for a single form and its study objects (form-level styles)
	Preview a form
	Rename a form layout

	Step 5c: Organize forms by creating sections
	Create a non-repeating section
	Create a repeating section
	Create a fixed repeating section
	Configure a fixed repeating section
	Choose the default view for a fixed repeating section

	Create a section to collect related data (a dynamic grid)
	Optional tasks
	Create keys in a repeating form or section
	Hide a section header
	Reorder the sections on a form
	Remove an item from a dynamic grid section


	Step 5d: Create items to collect data on forms
	Add a caption to a control
	Align the position of a control's caption
	Change the orientation of a group control
	Create a drop-down list on your team
	Create radio buttons on your item
	Create checkboxes on your item
	Add a predefined set of drop-down list options, radio buttons or checkboxes (a codelist subset) to your item
	Make an item conditional on another object
	Mark an item as hidden or read-only in Oracle InForm
	Set the appearance of a single study object (control styles)
	Reorder the items in a section
	Revert control style changes to use form- or study-level styles
	View the parents of a linked study object


	Step 6: Create groups of visits (optional)
	Step 7: Design your study workflow
	Step 7a: Specify the order of visits in the study
	Step 7b: Define a visit schedule
	Step 7c: Specify the order of forms in each visit
	Step 7d: Add your rules and global conditions to the workflow
	Optional tasks
	Disable a workflow
	Create a reference copy of a study object in a workflow diagram


	Step 8: Create a coding map (optional)
	Step 9: Select a primary layout for the study
	Set the primary layout
	Optional tasks
	Create a site-specific layout
	Add or remove layout names


	Step 10: Lock and protect your study objects (optional)
	Step 10a: Lock a study object
	Step 10b: Protect a study object
	Optional tasks
	Remove another user's lock on a study object
	Transfer another user's lock from a different session


	Step 11: Validate and deploy your study

	3 After your study has been deployed
	Make a study version change to a deployed study
	Make an in-place revision change to a deployed study
	Optional tasks
	View the differences between two versions of a form
	View in-place revision changes for a study
	View a history of all in-place revisions for a LIVE deployment instance
	Remove the association between a deployment instance and an in-place revision
	Copy an IPR configuration from one deployment instance to another
	Lock an in-place revision object


	4 FAQs
	General
	What is the difference between a RefName and a title?
	Which HTML formatting tags are supported?

	Default appearance of forms
	Can I change the way my forms and their study objects look?

	Library objects and reuse
	What happens when I add a library object to my study?

	Object reuse
	What happens when I copy and apste a study object?
	What happens when I copy a study object grouped by data mappings?
	What happens when I break the link of a copied study object?

	Forms
	What types of forms I can create?
	Where do I edit the properties of a form, section, item, or codelist?

	Sections
	Are sections required on forms?
	How do sections impact my RDE?
	What types of sections can I create?
	How can I use a fixed repeating section on a form?
	How can I use a dynamic grid desction on a form?
	Can I use a Hidden item in a dynamic grid section?
	Can I use an item more than once in a section?

	Items
	How do I create multiple choices for users to select from?
	What are key items?
	What are the requirements for key items?
	Are there words I can't use in an item's Question or Short Question?

	Group of visits
	What is a study element?

	Study workflow
	What happens during deploment if I disable a workflow?
	What kinds of rules can be added to my study?
	Sample Workflows

	Coding maps
	What are the components of a coding map?

	Layouts
	What is the primary layout and how do I set it?
	What happens when I delete a layout?

	Lock and protect
	What happens when I revoke a lock held by another user?
	What happens when I revoke a lock on an object with children?
	What happens when I protect an object?
	What happens when I unprotect an object in a study?

	LNMT (Lab Normals Management Tool)
	Forms
	What type of forms are supported by LNMT?

	Units
	Do lab test ranges and eCRFs have to be associated with the same single unit?
	Should I prompt sites to enter units on a form?
	Should lab tests and units be pre-identified for each study?
	Do lab tests and eCRFs must have the same specimen types?

	Queries
	Why isn’t LNMT submitting query text in Oracle InForm?

	Items and sections
	What properties must LNMT-populated fields have?
	How should objects be created for LNMT?
	How can I reuse objects for LNMT?

	Design
	Should I label each LNMT-related object in any specific way?
	How many lab tests can go into a form processed by LNMT?
	How should LNMT range items returned from LNMT be designed on lab forms?
	How should fixed repeating sections be configured for LNMT?
	What fields are defined in Oracle InForm for LNMT?

	Rules
	What rules or edit checks should be on the lab eCRF?


	After your study has been deployed
	What in-place revision changes are supported?
	Supported in-place revision changes with no regulatory or data impact
	Supported in-place revision changes that may affect the meaning of data on a form
	Supported in-place revision changes that may affect reguilatory compliance

	Can I change a form from common to not common?
	Can I change a form from repeating to non-repeating?
	What is an in-place revision?
	How do I mark a shared study objet as an in-place revision?


	5 What if...
	A "Predefined value not found" message appears in a form layout
	A study object with a restriction is updated in the library
	I added a dynamic grid section from a library, but it doesn't contain any items
	I added a dynamic grid section from a library, but some items are missing
	I added a set of radio buttons to my form, but when I deployed, it showed up as a drop-down list
	I can't add an item to a section
	I can't create a form or section in my study
	I can't create an item on a form in my study
	I can't copy a form or section
	I can't delete an object
	I can't edit items, codelists, codelist items, or codelist subsets in my study
	I can't find the item I want to add to a dynamic grid section
	I can't mark a section as a dynamic grid section
	I can't revoke the lock on a study object
	I copied a form as a link, but now I can't break the link
	I request an in-place revision for a study version that doesn't exist in the target deployment instance
	There are no studies in my Recent Projects list
	Auto-deployment doesn't complete and I need to open a Support ticket

	6 Revision history

