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Preface

This preface contains the following sections:

• Documentation accessibility

• Related resources

• Diversity and Inclusion

• Access to Oracle Support

• Additional copyright information

Documentation accessibility
For information about Oracle's commitment to accessibility, visit the Oracle
Accessibility Program website at http://www.oracle.com/pls/topic/lookup?
ctx=acc&id=docacc.

Related resources
All documentation and other supporting materials are available on the Oracle Help
Center.

Diversity and Inclusion
Oracle is fully committed to diversity and inclusion. Oracle respects and values having
a diverse workforce that increases thought leadership and innovation. As part of our
initiative to build a more inclusive culture that positively impacts our employees,
customers, and partners, we are working to remove insensitive terms from our
products and documentation. We are also mindful of the necessity to maintain
compatibility with our customers' existing technologies and the need to ensure
continuity of service as Oracle's offerings and industry standards evolve. Because of
these technical constraints, our effort to remove insensitive terms is ongoing and will
take time and external cooperation.

Access to Oracle Support
Oracle customers that have purchased support have access to electronic support
through Support Cloud.

Contact our Oracle Customer Support Services team by logging requests in one of the
following locations:

• English interface Customer Support Portal (https://hsgbu.custhelp.com/)
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• Japanese interface Customer Support Portal (https://hsgbu-jp.custhelp.com/)

You can also call our 24x7 help desk. For information, visit https://www.oracle.com/life-
sciences/support/ or visit http://www.oracle.com/pls/topic/lookup?ctx=acc&id=trs if you are
hearing impaired.

Additional copyright information
This documentation may include references to materials, offerings, or products that were
previously offered by Phase Forward Inc. Certain materials, offerings, services, or products
may no longer be offered or provided. Oracle and its affiliates cannot be held responsible for
any such references should they appear in the text provided.
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1
Oracle Central Coding overview

In this chapter:

• Supported coding dictionaries

• Multilingual data

• Japanese dictionary support

• Chinese dictionary support

• Architectural overview

• Physical configuration options

Supported coding dictionaries
The Oracle Central Coding application supports:

• Using the following industry-standard coding dictionaries.

– MedDRA, MedDRA-J, and MedDRA-C—Medical Dictionary for Regulatory
Activities.

– WHO-DD (C and C3 formats)—World Health Organization Drug Dictionary.

When using WHO-DD you can configure the Oracle Central Coding application to
autocode to the Trade Name (default) or to the Medicinal Product. With either
configuration option, you can report (return) the Trade Name, Preferred Name, and
Ingredients to the source application.

– WHO-DD (Chinese)—Includes drugs approved in China and product information and
text of the assigned ATC code(s) in Chinese (Chinese characters) in addition to all
drug names already available in WHO-DD.

– JDrug—Data File for Ethical Drugs (Coding Table) from Iyaku-Joho-Kenkyujo, Inc.

• Using multiple standard and custom dictionaries, and using multiple versions of those
dictionaries.

For more information, contact Oracle Support.

Multilingual data
The Oracle Central Coding application can accept both English, Japanese, and Chinese
verbatims (multilingual data).

• When you install the Oracle Central Coding application on an English operating system,
you can choose whether to use multilingual data.

• When you install the Oracle Central Coding application on a Japanese operating system,
the installation program assumes that there will be multilingual data.

If you choose to use multilingual data, the Oracle Central Coding installation program:
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• Loads the Japanese and Chinese report templates. These reports contain the MS
Mincho or MS UI Gothic font so that Japanese and Chinese text appears correctly
in the reports. These reports can contain Japanese, Chinese, and English data.

• Sets the default date format to YYYY/MON/DD HH24:MI:SS. In an environment
with native authentication, you can modify this setting as needed on the System
Configuration page.

Note:

You cannot perform an upgrade to support the Japanese or Chinese
language.

Japanese dictionary support
The Oracle Central Coding application supports:

• English and Japanese versions of the supported operating systems.

This feature does not include localization. The Oracle Central Coding user
interface is available only in English.

• The MedDRA‑J and JDrug (Data File for Ethical Drugs (Coding Table) from Iyaku-
Joho-Kenkyujo, Inc.) dictionaries.

The Oracle Central Coding application supports data to be coded in any left to
right language supported by MedDRA, WHO‑DD, or JDrug.

• Sorting and searching of the Japanese character sets.

• Coding algorithms for the Japanese dictionaries.

– Synonyms and autocoding for Japanese dictionaries are supported.

– Stopwords for Japanese dictionaries are not supported because they are not
used in the Japanese character sets.

• Coding with both Japanese and English dictionaries in the same database and in
the same study.

• Dictionary types and language packs

Dictionary types and language packs
A dictionary type file and a Japanese language pack are provided for each supported
coding dictionary. For more information, see About dictionary types and dictionary
schemas.

A language pack displays the dictionary level names and additional information labels
in the user interface in an alternate language. You install the language pack using the
Dictionary Loader tool. For more information, see Installing the language packs for the
Japanese dictionaries.

Chinese dictionary support
The Oracle Central Coding application supports:

Chapter 1
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• English and Chinese versions of the supported operating systems.

This feature does not include localization. The Oracle Central Coding user interface is
available only in English.

• The WHO‑DD Chinese and MedDRA‑C dictionaries.

The Oracle Central Coding application supports data to be coded in any left to right
language supported by MedDRA, WHO‑DD, or JDrug.

• Sorting and searching of the Chinese character sets.

• Coding algorithms for the Chinese dictionaries.

– Synonyms and autocoding for Chinese dictionaries are supported.

– Stopwords for Chinese dictionaries are not supported because they are not used in
the Chinese character sets.

• Coding with Chinese and English dictionaries in the same database and in the same
study.

Architectural overview
The Oracle Central Coding software is built on a Microsoft .NET and Oracle Database
platform. It uses web services over a network for the transmission of coding requests and
responses, and uses Internet Information Services (IIS) to provide its web-based user
interface to the coding team, so they can provide coding services through the Internet.

The Oracle Central Coding software requires a database server and an application server.
This architecture provides for flexibility and scalability, allowing you to configure the web
server, application server, and database server layers independently. In all configurations,
you access the Oracle Central Coding software on the application server through HTTP
sessions from Windows clients using Microsoft Edge, Mozilla Firefox or Google Chrome.
Each Oracle Central Coding application server runs on a Windows server, which uses the
Oracle client with the Oracle Data Provider for .NET interface with an Oracle Database
server.

• Oracle Central Codingand Clintrial integration—The two applications communicate
through a web service that is configured using the Clintrial application. This integration
does not require an adapter. For more information, see the Clintrial Admin and Design
guide.
The Clintrial application initiates all communication to and from the Oracle Central Coding
application.

• Oracle Central Coding and Oracle InForm integration—The Oracle Central Coding
software uses the Oracle InForm Adapter software to control communication between
Oracle Central Coding servers and Oracle InForm studies.

The Oracle Central Coding application initiates all communication to and from the Oracle
InForm application.

Chapter 1
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Physical configuration options
• Oracle Central Coding and Clintrial integration—The Clintrial software is

installed on a different machine than any of the Oracle Central Coding application
servers.

• Oracle Central Coding and Oracle InForm integration—The Oracle InForm
software and the Oracle InForm Adapter software are installed on a different
machine than any of the Oracle Central Coding application servers.

• Single application server configurations

• Configurations with multiple Oracle Central Coding instances

• Deplyoment scenarios

Single application server configurations
• The Oracle Central Coding application server and database server running on the

same machine.

• The Oracle Central Coding application server running on one machine and the
database server running on a separate machine.

In a production environment, Oracle recommends running the Oracle Central
Coding application server and database server on separate machines. This
configuration allows more flexibility, scalability, and performance; is easier to
manage and troubleshoot; and is easier to expand in the future by adding
additional application servers.

Configurations with multiple Oracle Central Coding instances
• Multiple Oracle Central Coding instances and the database server on the same

machine.

• Multiple Oracle Central Coding instances on one machine and the database server
on a different machine.

• Multiple Oracle Central Coding instances on different machines and the database
server on a different machine.

Chapter 1
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This configuration might be practical if, for example, you use the Oracle Central Coding
application across different geographic regions.

You can configure application servers as logical entities, allowing multiple Oracle Central
Coding instances to co‑exist on the same machine. Oracle Central Coding instances can
map to either:

• Unique database instances, each of which has its own dictionaries.

• A single database instance that shares dictionaries.

In environments with multiple Oracle Central Coding instances, each instance has its own:

• URL

• Job scheduler

Deplyoment scenarios
In this section:

• About integrating with Clintrial or Oracle InForm application

• Oracle Central Coding and Clintrial application components

• Oracle Central Coding and Oracle InForm application components

About integrating with Clintrial or Oracle InForm application
The Oracle Central Coding application supports integration with the InForm application and
the Clintrial application at the same time under the following circumstances:

• One of the following is true:

– The Oracle InForm application, Clintrial application, and Oracle Central Coding
application are behind the same firewall.

– The Oracle InForm application, Clintrial application, and Oracle Central Coding
application are not behind the same firewall, but a VPN is used between the Oracle
Central Coding application and the Clintrial application.

• The Clintrial software is installed on a different machine than any of the Oracle Central
Coding application servers.

• The Oracle InForm software and the Oracle InForm Adapter software are installed on a
different machine than any of the Oracle Central Coding application servers.

To determine the hardware and software requirements for using the Oracle Central Coding
application with another application through the Services Interface (API), consult your Oracle
Services representative.

Oracle Central Coding and Clintrial application components
The Oracle Central Coding and Clintrial applications must be hosted at the customer site
behind the customer firewall.

Oracle Central Coding and Oracle InForm application components
The Oracle Central Coding application components can be deployed with or without enabling
security.

Chapter 1
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• All Oracle Life Sciences InForm and Oracle Central Coding components behind a
firewall

• Oracle Central Coding server(s) outside a firewall

All Oracle Life Sciences InForm and Oracle Central Coding components behind a firewall
When integrating with the Oracle Life Sciences InForm application, the application
servers for all the software components in the Oracle Central Coding environment can
be behind a firewall. This is the typical scenario when Oracle hosts all the applications.

Oracle Central Coding server(s) outside a firewall
When integrating with the InForm application, the application servers for the Oracle
InForm and Oracle InForm Adapter software components can be behind a firewall,
while the Oracle Central Coding server(s) are outside the firewall. This is the typical
scenario when Oracle hosts the Oracle InForm servers and a customer hosts its own
Oracle Central Coding application server(s).

Chapter 1
Physical configuration options

1-6



Chapter 1
Physical configuration options

1-7



2
Planning the Oracle Central Coding
installation

In this chapter:

• About the Oracle Central Coding 7.0.1 release

• Prerequisites

• Overview of the Oracle Central Coding installation process

About the Oracle Central Coding 7.0.1 release
The Oracle Central Coding 7.0.1 release includes the following components:

• Oracle Central Coding 7.0.1 product.

• Oracle Central Coding 7.0.1 documentation.

• Oracle InForm Adapter product and documentation.

The product documentation is available from the following locations:

• My Oracle Support (https://support.oracle.com/portal/) — What's New, What's Fixed, and
Known Issues.

• Oracle Help Center (https://docs.oracle.com/en/industries/life-sciences/central-coding/
7.0.1/index.html) — The most current documentation set.

• Oracle InForm Adapter product and documentation

Oracle InForm Adapter product and documentation
To use the Oracle Central Coding software with the Oracle InForm application, the Oracle
InForm Adapter software must also be configured. For more information, see the Oracle
InForm Installation Guide.

Prerequisites
In this section:

• Add the Japanese and Chinese languages on the client and application servers—English
operating systems only

• Rename the dictionary file for th JDrug dictionary

• Setup tasks for integrating the Oracle Central Coding and Clintrial applications.

• Setup tasks for integrating Oracle Central Coding and Oracle InForm applications
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Add the Japanese and Chinese languages on the client and
application servers—English operating systems only

Before performing a fresh installation on an English operating system, if you want to
support English, Japanese, and Chinese verbatims, you must add the Japanese and
Chinese languages on the client computers and the application server where you
install the Oracle Central Coding software.

1. Select Start > Settings > Time & Language > Language.

2. Click Add a language, and select Japanese, Chinese, or both.

Rename the dictionary file for th JDrug dictionary
The Dictionary Loader tool does not recognize Japanese file names. Therefore, you
must rename the JDrug dictionary file so that the Dictionary Loader can recognize the
file name and load the dictionary.

• Rename, or copy and rename, the JDrug dictionary file ( ) to
all_cases.txt.

Note:

Make sure that this file is in a local directory with only English names in
its path.

Setup tasks for integrating the Oracle Central Coding and Clintrial
applications.

1. Install the Clintrial software.

For more details, see: Clintrial Getting Started guide

Note:

The Clintrial software is installed on a different machine than any of the
Oracle Central Coding application servers.

2. Configure network or internet access to the Oracle Central Coding application
server.

For more details, see: Clintrial Getting Started guide

3. Configure the CC_HOST parameter with the HTTP address of the Oracle Central
Coding interface.

For more details, see: Clintrial Admin and Design guide

This may be set in the Clintrial Admin module as a System or Protocol
parameter.
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4. Set the USE_CENTRAL_CODING parameter to Yes for the target protocol.

For more details, see: Clintrial Admin and Design guide

This may be set in the Clintrial Admin module as a System or Protocol parameter.

5. Create a new dictionary definition.

For more details, see: Clintrial Manage, Classify, and Lab Loader guide.

6. Define labels for the dictionary definition.

For more details, see: Clintrial Manage, Classify, and Lab Loader guide.

7. Select a dictionary definition for an item in a panel.

For more details, see: Clintrial Admin and Design guide.

8. Create a Oracle Central Coding encoding target.

For more details, see: Clintrial Manage, Classify, and Lab Loader guide.

9. Map the target items with the definted labels.

For more details, see: Clintrial Manage, Classify, and Lab Loader guide.

10. Use the Clintrial Manage module to send coding requests (define the delivery schedule)
to the Oracle Central Coding application.

For more details, see: Clintrial Admin and Design guide.

Setup tasks for integrating Oracle Central Coding and Oracle InForm
applications

1. Install the Oracle Central Designer software.

For more information, see theOracle Central Designer Installation Guide.

2. Install the Oracle InForm software on a different machine then on the Oracle Central
Coding application server.

For more information, see the Oracle InForm Installation Guide.

Note:

Set up the Oracle InForm Adapter to accept data securely.

3. On the Oracle InForm application server, install the Oracle InForm Adapter software with
the Administration, Coding, and Disrepancy Enhanced interfaces.

For more information, see the Oracle InForm Adapter Installation Guide.

Note:

Set up the Oracle InForm Adapter to accept data securely.

4. On the Oracle InForm application server, register studies with Oracle InForm Adapter.

For more information, see the Oracle InForm Adapter Installation Guide.

Chapter 2
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5. Using the Oracle Central Designer and Oracle InForm applications, set up one or
more Oracle InForm studies.

Specify mappings and add Oracle InForm users for use with the Oracle Central
Coding application.

For integration with the Oracle InForm 5.0 release or later, see the Oracle InForm
Study and Reporting Setup Guide.

For integration with releases prior to the Oracle InForm 5.0 release, see the Oracle
InForm Installation and Configuration Guide.

For more information, see Checklist: Set up InForm studies for use with the
Central Coding application and About mapping data for coding with the Central
Coding application.

• Set up Oracle InForm studies for use with the Oracle Central Coding application

• About mapping Oracle InForm data for coding with the Oracle Central Coding
application

Set up Oracle InForm studies for use with the Oracle Central Coding
application

1. In the Oracle InForm application, specify a valid Oracle InForm user whose
credentials can be used by the Oracle Central Coding application to access the
Oracle InForm application.

Required only if you are using user name/password authentication for
communication with the Oracle InForm Adapter web services.

Enter the Oracle InForm authentication user name and password in the Oracle
Central Coding application:

• On the System Configuration page (Get/Put Job Options section) to use for all
studies.

• On the [Study Name] Study Information page for any study, to define the user
separately for that study.

In addition, when you create a new Oracle InForm adapter, you must also
select the option to Call InForm Adapter Web Services with User Name/
Password Authentication on the [Adapter Name] page.

2. Optional: In the Oracle Central Designer application, create a rule in the Oracle
InForm application to clear the coding targets.

If the following key items are changed in the Oracle InForm application after a
verbatim is coded, they will not be updated in the Oracle Central Coding
application. To get the key items to be updated, you must create a rule in the
InForm application to clear the coding targets.

• SubjectInitials

• SubjectNumber

• Visit

• Site Name

• Site

• Study

Chapter 2
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Note:

The key items are updated in the Oracle Central Coding application if the
verbatim is not coded in the Oracle InForm application.

3. In the Oracle Central Designer application, create the coding maps.

Specify mapping definitions for controls that hold verbatim text and controls that hold the
coded values assigned by the Oracle InForm application.

For more information, see the Oracle Central Designer documentation.

Note:

Oracle recommends that you do not modify coding maps after coding begins for
the study. Doing so can slow the coding process.

About mapping Oracle InForm data for coding with the Oracle Central Coding
application

Use the Oracle Central Designer application to specify the Oracle InForm mapping definitions
for controls that hold verbatim text and controls that hold the coded values. For more
information, see the Oracle Central Designer documentation.

1. For each form that contains data to be coded, design controls to hold data as entered
(verbatims), controls to hold coded data (code targets), items to hold query data (query
targets), and if supported by the dictionary, contorls to hold additional context inofmration
(context items).

Verbatim, code target, query target, and context items must be:

• In the same visit, if the visit is repeating.

• On the same form, if the form is repeating.

• In the same itemset, if the coded data appears in an itemset.

• Different from each other.

2. Create a mapping definition that specifies:

• Each verbatim to be coded.

• The dictionary used for coding.

• Each code target to which the Oracle Central Coding application returns a coded
value.

• Each context item used to provide additional context data to the Oracle Central
Coding application.

• Each applicable verbatim type.

• Each query target on which to place a query associated with the verbatim. The query
target can be the verbatim item, or any other visible, editable item on the form.

3. In a production study, use the Oracle Central Coding application to:

a. Export the verbatim and context data from the Oracle InForm application to the
Oracle Central Coding application.

Chapter 2
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b. Code the data.

c. Import the coded data from the Oracle Central Coding application to the
Oracle InForm application.

Overview of the Oracle Central Coding installation process

Note:

Before performing the tasks in the table, be sure you have met the
requirements list in Prerequisites.

1. Prepare the database, the application servers, and the client computers.

For more information, see: Preparing the Oracle Central Coding installation

2. Install the Oracle Central Coding

For more information, see: Installing the Oracle Central Coding software

3. Load the coding dictionaries.

For more information, see: Loading and managing the coding dictionaries

4. Configure the Oracle Central Coding application.

For more information, see the Oracle Central Coding User Guide.
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3
Preparing the Oracle Central Coding
installation

In this chapter:

• Install the Oracle software on the database server

• Create the database and tablespaces

• Create database user accounts

• Install a certificate to secure communication with the Job Scheduler and Oracle InForm
Adapter

• Launching the Dictionary Loader tool

• Enable TLS 1.2

• Configure the web browsers on the client computers

Install the Oracle software on the database server
When the database server requirements are met, install the Oracle database software. For
more information, see:

• Oracle Central Coding System Requirements.

• Oracle installation documentation.

Note:

Oracle recommends that you configure both the application server and the
database server to use the Coordinated Universal Time (UTC) time zone. This way
you can avoid any confusion in timestamp data in scenarios such as when
migrating to a new database server that uses a different time zone.

• Mandatory database parameters

Mandatory database parameters
Most of the default Oracle configuration parameters can be used for the Oracle Central
Coding database. However, the following parameters must be set to the specified values.

Parameter Value

Database Character Set AL32UTF8 - Unicode UTF-8 Universal character
set

National Character Set AL16UTF16 - Unicode UTF-16 Universal
character set
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Parameter Value

db_cache_size 80 MB

sga_max_size 1000 MB

sga_target 600 MB (dependent on how much memory is
available for Oracle)

pga_aggregate_target 300 MB (dependent on how much memory is
available for Oracle)

BLOCK_SIZE Database: 8k or 16k

Tablespace: 16k

Note:

Your database administrator should dynamically adjust the sga_target and
pga_aggregate_target values using Oracle Enterprise Manager Advisors as
the system grows.

Note:

Oracle recommends that the Oracle instance registry parameter
ORA_*SID*_AUTOSTART be set to True. This ensures that Oracle is
synchronized with the job scheduler, which is an auto-started service.

Create the database and tablespaces
After installing the Oracle software, create the database and tablespaces. The Oracle
Central Coding application uses the Coding application and Coding platform
tablespaces listed in the following table.

• Note the names of the tablespaces you create.

You need the names when you enter values for the database users during the
Oracle Central Coding software installation.

Each tablespace has one or more associated database users, which the
installation wizard creates when you install a Oracle Central Coding application
server. For more information, see Installing a Oracle Central Coding application
server.
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Note:

For demonstration purposes in this guide, example names are provided for the
recommended tablespaces, and for their associated database users and
passwords. The same example name is used for both the user name and
password.

The Central Coding Database User name and the Coding Platform
Database User name cannot be the same.

The tablespace and user names are not case-sensitive. The passwords are
case‑sensitive.

• The Oracle Central Coding application tablespace contains the coding dictionary
database, which is created by the Dictionary Loader tool. For more information, see 
About the Dictionary Loader tool.

Note:

All entries used as Oracle database objects (such as user names, passwords, and
tablespaces) should follow Oracle recommendations for naming conventions. In
addition, Oracle recommends using strong passwords, as described in the Security
Guide.

Tablespace Size Contains Database user(s)

Coding application

Example name:
CODING

500 MB

Auto extend enabled,

10 MB increments.

Oracle Central Coding
application

Oracle Central Coding
Database User

Example name: cca

Coding platform

Example name: CCP

100 MB

Auto extend enabled,

10 MB increments.

Coding dictionaries • Coding Platform
Database User

Example name:
codingplatform

• Coding Dictionary
Database User

Example name:
codingdictionaries

Create database user accounts
If you are performing a new Oracle Central Coding installation, Oracle recommends that a
database administrator performs the following steps before the Oracle Central Coding
application is installed.

1. Download and extract the Oracle Central Coding 7.0.1 product archive.

2. To create the Central Coding Database User and Coding Platform Database User:

a. Open a Windows command prompt in the CodingDBSteup folder.

b. Enter the following command: sqlplus /nolog @CodingDBSetup.sql
c. Enter the user account information when prompted.
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During the Oracle Central Coding installation, when configuring the two database
user accounts, the system administrator can select the options to use existing
users, and enter the credentials of the users created during this step.

Note:

If you create the Central Coding Database User and Coding Platform
Database User during the installation, you must enter the credentials of a
user with DBA privileges.

3. To create the Coding Dictionary Database Administrator User:

a. Open a Windows command prompt in the CodingDBSteup folder.

b. Enter the following command: sqlplus /nolog
@CreateDictAdminUser.sql

c. Enter the user account information when prompted.

In the Dictionary Loader tool, when performing certain operations, such as creating
a dictionary repository or a dictionary, the dictionary administrator must enter the
credentials of the user you created during this step.

Install a certificate to secure communication with the Job
Scheduler and Oracle InForm Adapter

On each Oracle Central Coding application server, an administrator must install a
certificate for securing communication with:

• The Job Scheduler service—You select the certificate in the installation wizard and
you can replace it after installation using the utility UpdateJSCertificate. For more
information, see Replacing the certificate to secure internal communication with
the Job Scheduler service.

• Oracle InForm Adapter web services—You select the certificate using the utility
PhaseForward.CentralCoding.UpdateIACertificate. For more information, see 
Selecting a certificate for Oracle Life Sciences InForm Adapter authentication.

The certificate:

• Must be installed to the LOCAL_MACHINE\MY store directory and made usable
by the user who runs the ASP.NET worker process (by default, NETWORK
SERVICE or IIS AppPool\Central Coding New Pool). You must also grant the
NETWORK SERVICE and IIS AppPool\Central Coding New Pool users Full
Control rights to the private key for the certificate.

• Must be 2048 bits or higher. This requirement applies to all the certificates in the
certification path.

• Must use the SHA256 hashing algorithm. If a SHA1 certificate is used, a warning
message appears when theOracle Central Coding application connects to Oracle
InForm Adapter.

To import the certificate:

1. Open a command prompt window.
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2. Run the following command:

certutil -f -p <certificate password> -importpfx -csp "Microsoft 
Enhanced RSA and AES Cryptographic Provider" <full path to the pfx file> 
NoExport

To grant the users NETWORK SERVICE and IIS AppPool\Central Coding New Pool full
control to the private key of the certificate:

1. Open the Microsoft Management console:

a. Open a Command Prompt window.

b. Enter mmc.

2. Select File > Add/Remove Snap-in.
The Add or Remove Snap-ins dialog box appears.

3. In the list of available snap-ins, select Certificates.

4. Click Add.
The Add dialog box appears.

5. Click Computer account.

6. Click Next.

7. Click Local Computer.

8. Click Finish.

9. Click OK.

10. In the Console Root tree of the Microsoft Management console, select Certificates
(Local Computer) > Personal > Certificates.

11. Right-click the certificate, and select All Tasks > Manage Private Keys.

12. Click Add > Locations, and then select the computer name.

13. Give full control rights to the users NETWORK SERVICE and ISS AppPool\Central
Coding New Pool.

14. Click OK.

Launching the Dictionary Loader tool
Use the Dictionary Loader tool for all dictionary installation and maintenance tasks.

• Select Start > Apps > Dictionary Loader.
The Dictionary Loader dialog box appears.

Note:

When you upgrade the Oracle Central Coding software, information about
previously defined connections appears in the Data Connections tree. The
upgrade may delete the connections that were defined for the dictionary
repository. You can restore the connections using the previous user information
so that the dictionary repository objects become available again. For more
information, see Creating a connection to the database
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Enable TLS 1.2
Oracle recommends that you configure the following security settings on the Oracle
Central Coding application server:

• Enable TLS 1.2 and higher.

• Disable SSL 2.0, SSL 3.0, TLS 1.0, and TLS 1.1.

If TLS 1.2 is enabled on the Oracle InForm Adapter computer or on the address
translator (in a load-balanced configuration, for example), you must enable TLS 1.2 on
the Oracle Central Coding application server:

• In
HKLM\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHA
NNEL\Protocols, create the following keys and subkeys:

Key Subkey Entries

SSL 2.0 Client – DisabledByDefault=1
– Enabled=0

- Server – DisabledByDefault=1
– Enabled=0

SSL 3.0 Client – DisabledByDefault=1
– Enabled=0

- Server – DisabledByDefault=1
– Enabled=0

TLS 1.0 Client – DisabledByDefault=1
– Enabled=0

- Server – DisabledByDefault=1
– Enabled=0

TLS 1.1 Client – DisabledByDefault=1
– Enabled=0

- Server – DisabledByDefault=1
– Enabled=0

TLS 1.2 Client – DisabledByDefault=0
– Enabled=1

- Server – DisabledByDefault=0
– Enabled=1

• In HKLM\SOFTWARE\Microsoft\.NetFramework\v4.0.30319, create a key
called SchUseStrongCrypto with the DWORD value=1.

Configure the web browsers on the client computers
In this section:

• Browser settings for Google Chrome

• Browser settings for Mozilla Firefox

• Browser settings for Microsoft Edge
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Browser settings for Google Chrome
Configure the following Chrome settings to access the Oracle Central Coding application.

• Specify the preferred browser language.

• Configure pop-up blocking to allow pop-ups for the Oracle Central Coding website
domain.

• Prevent Chrome from using stored passwords.

• Set the security protocol option to use TLS 1.2 and higher.

• Modify security settings to accept cookies.

• Set up tabbed browsing to launch links in a new tab.

For more information, see the Google Chrome documentation.

Browser settings for Mozilla Firefox
Configure the following Firefox settings to access the Oracle Central Coding application.

• Specify the preferred browser language.

• Configure pop-up blocking to allow pop-ups for the Oracle Central Coding website
domain.

• Prevent Firefox from using stored passwords.

• Set the security protocol option to use TLS 1.2 and higher.

• Modify security settings to accept cookies.

• Set up tabbed browsing to launch links in a new tab.

For more information, see the Mozilla Firefox documentation.

Browser settings for Microsoft Edge
Configure the following Edge settings to access the Oracle Central Coding application.

• Specify the preferred browser language.

• Configure pop-up blocking to allow pop-ups for the Oracle Central Coding website
domain.

• Prevent Edge from using stored passwords.

• Set the security protocol option to use TLS 1.2 and higher.

• Modify security settings to accept cookies.

• Set up tabbed browsing to launch links in a new tab.

For more information, see the Microsoft Edge documentation.
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4
Installing the Oracle Central Coding software

In this chapter:

• Before you begin

• Performing an interactive installation

• Performing a silent installation

• Verify the installation

• Run OnPremMigration.bat

• Repairing an installation

• Uninstalling a Oracle Central Coding application server

Before you begin
You can perform either a manual or a silent installation of the Oracle Central Coding software.

Before you run the installation, make sure that:

• The database instance is running.

• All clocks are synchronized on the machines where you are installing the Oracle Central
Coding software and the database server.
The installation program verifies that the clocks are synchronized. If they are not
synchronized, an error message appears. Installation cannot continue until the clocks are
synchronized.

Note:

Oracle recommends that you configure both the application server and the
database server to use the Coordinated Universal Time (UTC) time zone. In this
way you can avoid any confusion in timestamp data in scenarios such as
migration to a new database server that uses a different time zone.

• The ASP.NET state service is started.

Performing an interactive installation
In this section:

• Installing a Oracle Central Coding application server

• Modifying an existing Oracle Central Coding application server installation of the same
version

• Migrating an existing installation to a new application server
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Installing a Oracle Central Coding application server
Use this procedure to install an instance of the Oracle Central Coding software. After
you install one instance of the Oracle Central Coding software, you can run the
installation program as many times as necessary to install additional instances.

Perform this procedure on each application server.

Note:

This installation procedure requires that you enter the names of the database
tablespaces and their associated database users and passwords. For
demonstration purposes in this guide, example names for the tablespaces,
users, and passwords are provided in this procedure in the appropriate
steps. For more information, see Create the database and tablespaces.

Caution:

All entries used as Oracle database objects (such as user names,
passwords, and tablespaces) should follow Oracle recommendations for
naming conventions. In addition, Oracle recommends using strong
passwords, as described in the Security Guide.

• Configure application settings

• Configure the application instance

• Configure the Central Coding database user

• Configure the Coding Platform database user

• Configure the Coding Dictionary database user

• Complete the installation

Configure application settings
1. Download and extract the Oracle Central Coding 7.0.1 product archive.

2. Locate setup.exe

3. Right-click and select Run as administrator.

• If you are installing the Oracle Central Coding application for the first time, the
Welcome page appears.

• If you have already installed an instance of the Oracle Central Coding
application, the Existing Installed Instances Detected page appears.

– Select Install a new instance of this application, and click Next.
The Welcome page appears.

4. Click Next.

The page that appears depends on the operating system.
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• If you are performing a fresh installation on a Japanese operating system, the
Required System Components page appears. Proceed to step 5.

• If you are performing a fresh installation on an English operating system, the
Determine Database Sort page appears.
Use this page to specify the locale, which determines the correct linguistic sorting in
the database. The choice affects the language of verbatims that can be supported,
the default date format, and which report templates are installed.

5. Select the locale.

• English—Sets the default database sort group to English. The English option maps
to the Binary Oracle sort value.

Select this option to:

– Support only English verbatims.

– Set the default date format to DD/MON/YYYY HH24:MI:SS.

– Load the English report templates. The reports can contain only English data.

• European—Sets the default database sort group to WesternEuropean. The
European option supports more character sets than the English option. It maps to the
Generic_M Oracle sort value, which generally handles the order of the Latin, Cyrillic,
Greek, and other European characters.
Select this option to:

– Support only English verbatims.

– Set the default date format to DD/MON/YYYY HH24:MI:SS.

– Load the English report templates. The reports can contain only English data.

• Global—Sets the default database sort group to JapaneseWesternEuropean. The
Global option maps to the Japanese_M Oracle sort value.
Select this option:

– If you are using an English operating system and you want to support English,
Japanese, and Chinese verbatims, or if you are using a Japanese operating
system.

– To set the default date format to YYYY/MON/DD HH24:MI:SS.

– To load the Japanese or Chinese report templates. The reports can contain
Japanese, Chinese, and English data.

Note:

For the best performance, Oracle recommends that you select Global only
if you are working with Japanese or Chinese studies.

6. Click Next.

The Required System Components page appears. The installation wizard verifies that the
server has all the necessary software components, including the operating system,
IIS, .NET, and the Oracle client.

If required components are missing or are the wrong version, installation stops. The
missing and invalid components are listed on the Required System Components page.
You must install them before continuing the installation.

7. Click Next.
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The Company Information page appears.

8. Enter the following information:

• Company name—Name of the company licensed to use the software.
The company name may include any characters. This is informational only.

• Company URL—URL that is unique to the company.
This is used to define the security domain in inter-product communication. The
Company URL:

– Must be in English.

– Must follow the proper URL convention and be in valid URL (ASCII)
narrow characters.
The URL does not need to point to an actual running website or service.

– Should not begin with a protocol designation such as http://.
For example, www.oracle.com.

9. Click Next.

The Select Features page appears.

10. Select the features to install. At least one feature must be selected in order to
continue with the installation. If you select only the Dictionary Loader tool, the
installation program skips to the end of the wizard.

• Oracle Central Coding Server.

• Dictionary Loader.
The Dictionary Loader tool must be installed in order to load standard and
custom dictionaries. However, the Dictionary Loader tool:

– Does not need to be installed on every machine or on every application
server.

– Can be on a different machine from the Oracle Central Coding application
server(s).

– Can be installed without also installing the Oracle Central Coding Server.
To verify whether the Dictionary Loader tool is installed, go to Start >
Apps. If Dictionary Loader appears under Oracle HS, it is already
installed.

11. Click Next.

The Authentication Scheme page appears.

12. SelectNative Authentication, and then click Next.

Note:

Trust Authentication is available only for Oracle-hosted installations.

Configure the application instance
On the Application Instance Settings page, you enter the instance name and job
scheduler port number. From the instance name, the installer derives the virtual
directories and job scheduler service name. The port must be numeric and should
designate a port that is currently open and will be reserved for only this service. The
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installation program attempts to select a port that has not been used by a prior run of the
installation.

1. Enter the following information:

• Instance Name—Unique string identifier for this instance. The Instance Name
derives names for the various services.

– Do not use special characters and make sure that there are no spaces in the
name.

– If you plan to have multiple application servers, consider using a naming
convention for the names that allows you to easily identify each instance.

• TCP port—Port through which the job scheduler communicates on this Oracle
Central Coding application server.

– The Oracle Central Coding software reserves the range 14000 through 14100 by
convention, although it can be any open port.

– Each instance must be assigned a different open port.

– The installation program defaults to a unique number for each instance being
installed, starting in the conventional range, but not limited to it.

The following information is automatically populated and cannot be edited:

• Service name—Oracle Central Coding Job Scheduler. Job scheduler Windows
service name for this Oracle Central Coding instance.
This is a unique name across multiple instances. The installation appends the
instance name to the service name so that the services can be distinguished from
one another.

• Application URL—URL for the application server.

• Application Server—Name of the virtual directory under which the application is
published in IIS.
The installation appends the instance name to this name.

• Coding Service Virtual Directory—Unique name for the application server you are
creating.
The installation appends the instance name to this name.

• Secure Coding Service Virtual Directory.

• Platform Service Virtual Directory—Unique name for the platform you are creating
for this application server.
The installation appends the instance name to this name.

• Job Service Host Name—localhost. Machine name of the host.

2. Click Next.

The Choose Destination Location page appears.

3. Specify where on the local file system to install the instance of the application.

By default, the installation wizard installs the Oracle Central Coding software in C:\Oracle
HS. However, you can click Change and navigate to another location. The folder must
not be the same as any other installed instance.
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Note:

The instructions, paths, and Start Menu navigation in this guide assume
you are installing to the default location. Oracle strongly recommends
that you install the software to the default directory. If you select a
different location, the uninstaller might not remove all related files during
the uninstall process.

4. Click Next.

Configure the Central Coding database user
On the Central Coding Database User page, you create or select an existing user for
the Oracle Central Coding database. To create a new user, you must enter the
credentials of a user with DBA privileges; the database user and password; and the
default tablespace for the Oracle Central Coding application.

The installation program detects the Oracle home location, finds all currently
configured connection strings, and presents them in a list. Instead of typing in the
connection string, you pick it from the list.

Note:

If the connection string that you want to use is not in the list, it means the
connection has not been set up.

Select or enter the following information for the Central Coding Database User, and
then click Next.

• Connection string—TNS name to use when connecting to the database.

Note:

To receive the best performance, Oracle recommends that you specify
different connection strings for the Central Coding Database User, the
Coding Platform Database User, and the Coding Dictionary Database
User.

• Create/Recreate User—Select to create a new Central Coding Database User.
Select this option only if a database administrator did not create the user before
the installation. For more information, see Create database user accounts.
If you choose to create a new user, you must also enter data for the default
tablespace. If the Create/Recreate User option is selected and an existing user is
supplied, that user will be dropped and re-created.

– Oracle DBA User / Password—Credentials of a user with DBA privileges.
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WARNING:

SYS user is no longer an allowed account. Please use another account
name, such as SYSTEM or any other custom DBA account.

– Test Connection—Click to attempt an actual database connection using the
selected Connection string and DBA User credentials. You can continue with the
installation only after the connection test succeeds.

– Default tablespace—Select the name that was created for the Oracle Central
Coding application.
This list is populated from the database. For the example in this guide, that name is
CODING. For more information, see Create the database and tablespaces.

– Create—If the tablespace for Oracle Central Coding is not in the list, click to create a
new tablespace.
The Create New Default Tablespace dialog box appears. In the Name field, enter a
name for the tablespace, and click Create. The dialog box closes and the name of
the newly created tablespace appears in the Default tablespace field on the Central
Coding Database User page.

Note:

The tablespace that is created is the default size and in the default location.
If you want the tablespace to be a different size or in a different location,
you must create the tablespace from the database.

– User Name—Oracle user account name.
The Central Coding Database User name and the Coding Platform Database User
name cannot be the same.

– Password, Retype Password—Password for the Oracle user account.
The password must contain:

* One or more alphabetical (A-Z, a-z) and numeric (0-9) characters.

* At least one non-alphanumeric character.

* One or more upper case (A-Z) and lower case (a-z) characters.

* A minimum of 8 characters.

Note:

Do not use Oracle reserved words for the user name or password.

• Existing User—Select if the user was created before the installation, or to reuse an
existing user. In this case, the database is assumed to be present already, and the
specified user is not dropped. You can test a connection with this user before proceeding.

– User Name—Oracle user account name.

– Password—Password for the Oracle user account.

– Test User—Click to test the database connection with this user.
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Configure the Coding Platform database user
On the Central Coding Platform Database User page, you create or select an existing
user for the Oracle Central Coding Platform database. To create a new user, you must
enter the credentials of a user with DBA privileges; the database user and password;
and the default tablespace for the Oracle Central Coding Platform.

Select or enter the following information for the Coding Platform Database User, and
then clickNext.

• Connection string—The TNS name to use when connecting to the Platform
database.

• Create/Recreate User—Select to create a new Coding Platform Database User.
Select this option only if a database administrator did not create the user before
the installation. For more information, see Create database user accounts.
If you choose to create a new user, you must also enter data for the default
tablespace. If the Create/Recreate User option is selected and an existing user is
supplied, that user will be dropped and re-created.

– Oracle DBA User / Password—Credentials of a user with DBA privileges.

WARNING:

SYS user is no longer an allowed account. Please use another
account name, such as SYSTEM or any other custom DBA account.

– Test Connection—Click to attempt an actual database connection using the
selected Connection string and DBA User credentials. You can continue
with the installation only after the connection test succeeds.

– Default tablespace—Select the name that was created for the Oracle Central
Coding application.
This list is populated from the database. For the example in this guide, that
name is CCP. For more information, see Create the database and
tablespaces.

– Create—If the tablespace for Oracle Central Coding is not in the list, click to
create a new tablespace.
The Create New Default Tablespace dialog box appears. In the Name field,
enter a name for the tablespace and click Create. The dialog box closes and
the name of the newly created tablespace appears in the Default tablespace
field.

Note:

The tablespace that is created is the default size and in the default
location. If you want the tablespace to be a different size or in a
different location, you must create the tablespace from the database.

– User Name—The Oracle user account (Example name: codingplatform).
The Central Coding Database User name and the Coding Platform Database
User name cannot be the same.
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– Password, Retype Password—The password for the Oracle user account.
The password must contain:

* One or more alphabetical (A-Z, a-z) and numeric (0-9) characters.

* At least one non-alphanumeric character.

* One or more upper case (A-Z) and lower case (a-z) characters.

* A minimum of 8 characters.

• Existing User—Select if you created the user before the installation, or to reuse an
existing user. In this case, the database is assumed to be present already, and the
specified user is not dropped. You can test a connection with this user before proceeding.

– User Name—The Oracle user account name. The list is populated with users from
the database.

– Password—The password for the Oracle user account

– Test User—Click to test the database connection with this user.

Configure the Coding Dictionary database user
On the Create Coding Dictionary Database User page, you enter the user and password that
the Oracle Central Coding application will use to connect to the dictionary database. This
user is not dropped or created, and does not have to exist at the time of the installation. You
create the dictionary database using the Dictionary Loader tool. For more information, see 
Setting up the dictionary database.

Enter the following information, and then click Next.

• Connection string—The TNS name to use when connecting to the dictionary database.

Note:

To receive the best performance, Oracle recommends that you specify different
connection strings for the Central Coding Database User, the Coding Platform
Database User, and the Coding Dictionary Database User.

• User—The name of the user account for the dictionaries (Example name:
codingdictionaries).

• Password, Retype Password—The password for the user account for the dictionaries.
The password must contain:

– One or more alphabetical (A-Z, a-z) and numeric (0-9) characters.

– At least one non-alphanumeric character.

– One or more upper case (A-Z) and lower case (a-z) characters.

– A minimum of 8 characters.

Note:

Make a note of these values. You must use them when you create the repository for
the dictionaries and when you connect to the database. For more information, see 
Creating a dictionary repository and Creating a connection to the database.
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Complete the installation
1. On the Create Coding Administrator Account page, enter the following information,

then click Next.

• User—The name of the initial user account for the Oracle Central Coding
application.

• Password—The password for the initial user account.
The password must contain:

– One or more alphabetical (A-Z, a-z) and numeric (0-9) characters.

– At least one non-alphanumeric character.

– One or more upper case (A-Z) and lower case (a-z) characters.

– A minimum of 8 characters.

• Retype password—The password for the initial user account.

2. Click Choose Certificate.

A list of X.509 certificates on the machine appears in a new window.

Note:

The certificate is for internal communication only, and must already be
installed. For more information, see Install a certificate to secure
communication with the Job Scheduler and Oracle InForm Adapter

3. Select the certificate to use, and click OK.

The certificate properties appear on the page.

4. Click Next.

The Ready to Install the Program page appears.

5. Click Install.

After the isntallation completes, the Central Coding Installation Wizard Complete
page appears.

6. Click Finish.

Note:

After completing the installation, Oracle recommends assigning a SuperUser
account type to one or more users (preferably those with system and user
administrator privileges). This ensures you always have at least one account
with user management capabilities, since the last SuperUser account is
protected against deactivation.
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Modifying an existing Oracle Central Coding application server installation
of the same version

Use this procedure to change the features of the same version of the software that you
installed on an application server. You can change the Central Coding Server, the Dictionary
Loader, or both features:

1. Locate setup.exe.

2. Right-click and select Run as adminstrator.

The Existing Installed Instances Detected page appears.

3. Select Maintain or update the isntance of this applcation selected below.

4. Select the appropriate server, and click Next.

The Welcome page appears.

5. Select Modify, and click Next.

The Select Features page appears.

6. To modify an application server installation, select the features to change:

• Oracle Central Coding Server.

• Dictionary Loader.
The Dictionary Loader tool must be installed in order to load standard and custom
dictionaries. However, the Dictionary Loader tool:

– Does not need to be installed on every machine or on every application server.

– Can be on a different machine from the Oracle Central Coding application
server(s).

– Can be installed without also installing the Oracle Central Coding Server.

To verify whether the Dictionary Loader tool is installed, go to Start > Apps. If Dictionary
Loader appears under Oracle HS, it is already installed.

7. Select the features to install, deselect the features to uninstall, and click Next.

The files are updated and the Maintenance Complete page appears.

8. Click Finish.

Migrating an existing installation to a new application server
Use this procedure to migrate to Oracle Central Coding 7.0.1 from an earlier version of
Oracle Central Coding.

• You can migrate from Oracle Central Coding version older than 3.1.0.1 by doing an in-
place upgrade to Oracle Central Coding 3.1.0.1 followed by a migration to Oracle Central
Coding 6.2.0.0, then an in-place upgrade to 6.3.0, followed by an in-place upgrade to
6.3.1, and a final migration to Oracle Central Coding 7.0.1.

• You can migrate from Oracle Central Coding 3.1.0.1 by first doing a migration to Oracle
Central Coding 6.2.0.0, then an in-place upgrade to Oracle Central Coding 6.3.1,
followed by the migration to Oracle Central Coding 7.0.1.

• You can migrate from Oracle Central Coding 6.2.x by first processing an in-place upgrade
to Oracle Central Coding 6.3.1, followed by a migration to Oracle Central Coding 7.0.1.
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• You can migrate from a Oracle Central Coding 6.3.x release directly to Oracle
Central Coding 7.0.1.

• You can migrate from Oracle Central Coding 7.0 release directly to Oracle Central
Coding 7.0.1.

To migrate an existing installation to Oracle Central Coding 7.0.1:

1. Prepare the new server.

For more information, see:

• System Requirements.

• Preparing the Oracle Central Coding installation

2. If you are running Oracle Database 11.2.0.4, upgrade to Oracle Database
19.12.0.0.

3. On the old application server, stop Oracle Central Coding services and disable all
jobs.

4. If you are also migrating the database server:

a. On the old database server, export the schema files for Coding, Platform, and
Dictionary database users.

b. On the new database server, import the schema files exported during the
previous step.

c. Run ApplyHardeningGrantsToSchemas.cmd to grant database users
necessary permissions on required packages. The script is located in the
Oracle Central Coding 7.0.1 ZIP file in the foled
CodingDBSetup\CreateCentralCodingDatabase.

5. Install the Oracle Central Coding application on the new server running Microsoft
Windows Server 2012. During the installation, select the options for using the
existing Coding, Platform, and Dictionary Database users. For more information,
see Installing a Oracle Central Coding application server.

6. Using the Dictionary Loader, recreate the dictionary repository connections.

7. Make sure jobs are running on the new application server.

8. If user name/password authentication was configured for calls to the Oracle
InForm Adaptaer interfaces prior to migration, a system aministrator must re-enter
the Oracle InForm authentication user credentials in Oracle Central Coding 7.0.1
on the pages where they were previously entered (the Systems Configuration
page or the Study Information page for individual studies).

9. Uninstall Oracle Central Coding application from the old server.

Performing a silent installation
After you install one instance of the Oracle Central Coding software, you can run the
silent installation as many times as necessary to install additional instances. To
perform a silent installation of the Oracle Central Coding software:

1. Modify the response file.

For more information, see: Modifying the response file

2. Run the installation from the command line.

For more information, see: Running the installation
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• Modifying the response file

• Running the installation

• Checking the log file

Modifying the response file
Perform the procedure on each application server.

Note:

All entries used as Oracle database objects (such as user names, passwords, and
tablespaces) should follow Oracle recommendations for naming conventions. In
addition, Oracle recommends using strong passwords, as described in the Security
Guide.

1. Copy the Oracle Central Coding installation folder to your local machine.

2. Locate the setup.iss response file.

3. Save the setup.iss response file with a different name.

Note:

Oracle recommends saving the response file with a name that references the
Oracle Central Coding instance with which it is associated.

4. Modify the response file with following information:

Parameter Description

svLanguage Locale:
• English
• WesternEuropean
• JapaneseWesternEuropean

szCompanyName Company name.

szCompanyURL Company URL.

szDir
(First)

Base installation directory.

This should match the information you specify in
the parameter for the Oracle Central Coding
instance directory.

svAuthChoice Authentication scheme used.

This must be NATIVE for self-hosted
installations.

instanceName Instance name.

svPort Job Scheduler communication port number.

This must be an empty port that has not been
used by any other software.
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Parameter Description

szDir
(Second)

Directory for the Oracle Central Coding
instance.

This should match the information you specified
in the installation directory parameter.

Table 4-1    Central Coding Database user parameters

Parameter Description

svDBServer Database server connection string for the
Oracle Central Coding Database user.

svOracleSysDBAUser Oracle user with DBA privilegs.

This must be entered only if svCreateUser is
TRUE.

svOracleSysDBAPassword Password for Oracle user with DBA
privileges.

This must be entered only if svCteateUser is
TRUE.

svdbUID Oracle Central Coding Database User ID.

svdbPID Oracle Central Coding Database user
password.

svDBTablespace Name of the tablespace for the Oracle
Central Coding database.

svCreateUser Controls whether the user specified by
svdbUID is created (TRUE), or if an existing
user identified by svdbUID wil be reused
(FALSE).

Table 4-2    Platform Database user parameters

Parameter Description

svDBServer Database server connection string for the
Platform Database user.

svOracleSysDBAUser Oracle user with DBA privileges.

This must be entered only if svCreateUser is
TRUE.

svOracleSysDBAPassword Password for Oracle user with DBA
privileges.

This ,ust be entered only if svCreateUser is
TRUE.

svdbUID Platform Database user ID.

svdbPID Platform Database user password.

svDBTablespace Name of the tablespace for the Platform
database.

svCreateUser Controls whether the user specified by
svdbUID is created (TRUE), or if an
existring user identified by svdbUID will be
reused (FALSE).
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Table 4-3    Dictionary Database user parameters

Parameter Description

svDBServer Database server connection string for the
Dictionary Database user.

svdbUID Dictionary Database user ID.

svdbPID Dictionary Database user password.

Table 4-4    Certificate parameters

Parameter Description

svCertSubject Certificate subject.

svCertIssuer Certificate issuer.

svCertName Certificate name.

svCertExpiration Certificate expiration date, in the format
MM/DD/YYYY H:MM:SS AM/PM.

svCertThumbprint Certificate thumbprint.

Note:

Make sure there are no spaces in the
value of the parameter.

Running the installation
1. Open a Command Prompt window and navigate to the installation folder on your local

machine.

2. Run the following command: ...setup.exe -s -f1"[Location of response file]\
[Resonse file name]" -f2"[Location of log file]\[Log file name]"
In the command syntax:

• Location of response file—The directory where the response file you
modified exists.

• Response file name—The name you gave the response file to use during the
silent installation.

• Location of log file—The directory where you want the log file to be created.

Note:

Make sure the directory exists; otherwise the installation fails.

• Log file name—The name to give the log file.
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Note:

The log file is automatically created during the installation.

3. After you run the silent installation, Oracle recommends that you check the log file
to ensure that the installation was successful. For more information, see Checking
the log file

Checking the log file
1. Navigate to the directory in which the response file that you modified exists.

2. Open the log file with the name you specified during the installation.

• For successful installations, the log file inclues ResultCode=0.

• For unsuccessful installations, the ResultCode field is populated with a
number that specifies the type of error that occurred during the installation.

Note:

The error codes in the log file are created by InstallShielf. If an error
occurs during the instllation, contact Oracle for details.

Verify the installation
After the application server is created, do the following to verify that the installation
was successful:

• Review the setup log.
This log contains messages the system generated during the installation. It is
available in <Installation
Folder>\CentralCodingServer\Setuplog.txt.

If the following message appears in Setuplog.txt it indicates that the block size of
the tablespace for the Oracle Central Coding user is not large enough. For more
information, see Mandatory database parameters.

create index CCA_FLAT_LEVELS_IDX1 on CCA_FLAT_LEVELS (*

ERROR at line 1:
ORA-01450: maximum key length (6398) exceeded

• In IIS, verify that centralcoding<InstanceName> exists; <InstanceName> is the
Instance Name you entered on the Application Instance Settings page during the
Oracle Central Coding installation.

1. To open IIS, select Start > Apps > Internet Information Services (IIS)
Manager.

2. Double-click the machine name, expand Sites > Default Web Sites, and
locate centralcoding<InstanceName>.

• Verify that the Dictionary Loader tool is installed.
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If you selected Dictionary Loader on the Select Features page when you installed the
Oracle Central Coding software, the Dictionary Loader tool is available from the Start
menu under Oracle HS.

Note:

For instructions on using the Dictionary Loader tool to load and manage the
coding dictionaries, see Loading and managing the coding dictionaries

Run OnPremMigration.bat
This script is present in Oracle Central Coding 7.0.1 install directory in the folder
CentralCodingServer\UpgradeScripts\631To700.

Repairing an installation
Use this procedure to re-copy all relevant installation files onto the target machine. This
option is useful if the installation files were corrupted.

1. Locate setup.exe.

2. Right-clcik and select Run as administrator.

The Existing Installed Instances Detected page appears.

3. Select Maintain or update the instance of this application selected below.

4. Select the appropriate server, and click Next.

The Welcome page appears.

5. Select Repair, and click Next.

Uninstalling a Oracle Central Coding application server
Use this procedure to perform a complete uninstall of the Oracle Central Coding software.

1. Locate setup.exe.

2. Right-click and select Run as administrator.

The Existing Installed Instances Detected page appears.

3. Select Maintain or update the instance of this application selected below.

4. Select the appropriate server, and click Next.

The Welcome page appears.

5. Select Remove, and click Next.

A confirmation dialog box appears.

6. Click Yes.

Messages display as the system removes the Oracle Central Coding components. When
the process is complete, the Uninstall Complete page appears.

7. Select whether to restart the computer now or later, and click Finish.
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8. Remove the Oracle Central Coding folder from the Start menu.
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5
Loading and managing the coding dictionaries

In this chapter:

• About loading and managing the coding dictionaries

• About dictionary types and dictionary schemas

• About the Dictionary Loader tool

• Setting up the dictionary database

• Loading standard dictionaries

• Loading custom dictionaries

• Using custom icons in the coding browser

• Installing the language packs for the Japanese dictionaries

• Maintaining the coding dictionaries

About loading and managing the coding dictionaries
After you install the Oracle Central Coding software, you must load the coding dictionaries on
the Oracle Central Coding application server.

Note:

Coding dictionaries are not included as part of the Oracle Central Coding
installation; you must purchase and install your own coding dictionaries.

About dictionary types and dictionary schemas
A dictionary type is a Oracle Central Coding concept that identifies a family of coding
dictionaries.

Dictionary types are defined in XML files that contain the metadata for the dictionary levels
and the SQL needed to set up the tables in the database. These files also contain the default
element configuration settings that control which coding features and information are
available to users in the Oracle Central Coding user interface.

Dictionary schemas are created from dictionary types. Each dictionary version is loaded into
a separate Oracle database schema.

• Standard dictionary type XML files

• Custom dictionary type XML files

• Rename the dictionary file for th JDrug dictionary
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Standard dictionary type XML files
The Oracle Central Coding software includes XML files for the standard dictionary
types in <Installation Folder>\DictionaryLoader\Setup.

Dictionary type XML file Description

MedDRA_DictionaryType.xml All versions of MedDRA dictionaries have the
dictionary type MedDRA.

MedDRAJ_DictionaryType.xml All versions of MedDRA-J dictionaries have
the dictionary type MedDRAJ.

MedDRAJ_ja-JP.xml Used by the Dictionary Loader tool to install
the language pack for the MedDRA-J
dictionary.

The language pack displays the dictionary
level names and additional information labels
in Japanese in the user interface.

WHO-DD_DictionaryType.xml All versions of WHO-DD dictionaries have the
dictionary type WHODD.

JDrug_DictionaryType.xml All versions of JDrug dictionaries have the
dictionary type JDrug.

Note:

You must
rename the
dictionary file so
that the
Dictionary
Loader tool can
recognize the file
name. For more
information, see 
Renaming the
dictionary type
file for the JDrug
dictionary.

JDrug_ja-JP.xml Used by the Dictionary Loader tool to install
the language pack for the JDrug dictionary.
The language pack displays the dictionary
level names and additional information labels
in Japanese in the user interface.

Custom dictionary type XML files
For custom dictionaries, you must create the required XML file that defines the
dictionary type.
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Rename the dictionary file for th JDrug dictionary
The Dictionary Loader tool does not recognize Japanese file names. Therefore, you must
rename the JDrug dictionary file so that the Dictionary Loader can recognize the file name
and load the dictionary.

• Rename, or copy and rename, the JDrug dictionary file ( ) to all_cases.txt.

Note:

Make sure that this file is in a local directory with only English names in its path.

About the Dictionary Loader tool
The Oracle Central Coding software includes a stand-alone component, called the Dictionary
Loader tool, that you use to manage all functions associated with loading and managing the
coding dictionaries. The Dictionary Loader tool can be installed on a machine as part of the
Oracle Central Coding software installation.

• The Dictionary Loader tool is installed into the Oracle Central Coding application directory
and added to the Start menu for the Oracle Central Coding application.
The Dictionary Loader tool is accessible only from the Oracle Central Coding server. You
must have server-level access to run the Dictionary Loader tool; you cannot run it from
the user interface.

• Dictionaries can be loaded on the same machine as the Oracle Central Coding
application or on a different machine.
Coding dictionaries are not included as part of the Oracle Central Coding installation; you
must purchase and install your own coding dictionaries.

• All dictionaries can be loaded into a single tablespace, or you can create a separate
tablespace for each dictionary.
The instructions in this guide assume that all dictionaries are loaded into one tablespace.

• Dictionaries can be used by multiple application servers.

• Launching the Dictionary Loader tool

Launching the Dictionary Loader tool
Use the Dictionary Loader tool for all dictionary installation and maintenance tasks.

• Select Start > Apps > Dictionary Loader.
The Dictionary Loader dialog box appears.
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Note:

When you upgrade the Oracle Central Coding software, information
about previously defined connections appears in the Data Connections
tree. The upgrade may delete the connections that were defined for the
dictionary repository. You can restore the connections using the previous
user information so that the dictionary repository objects become
available again. For more information, see Creating a connection to the
database

Setting up the dictionary database
In this section:

• Overview of the steps to set up the dictionary database

• Creating a dictionary repository

• Creating a connection to the database

• Connecting to the database

• Viewing the dictionary types for a connection

• Importing the dictionary type XML file

Overview of the steps to set up the dictionary database

Note:

Setting up the dictionary database is the same for both standard and custom
dictionaries.

1. Create a dictionary repository.

Use to create a repository in the database to hold the dictionaries associated with
a connection.

Although you can create multiple repositories, only one repository can be
connected at a time.

2. Create a connection to the database.

Use to create a connection to the database.

Connections are created within repositories. Although you can create multiple
connections, only one connection can be active at a time.

3. Connect to the database.

Use to connect to an existing database connection.

4. View the dictionaries available for a database connection.

Use to view information about the dictionary types that are available for a
connection.

5. Import the dictionary type XML file.
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Use to import the dictionary type XML file for a dictionary.

Creating a dictionary repository
Use this procedure to create a repository in the database to hold the dictionaries associated
with a connection. Although you can create multiple repositories, only one repository can be
connected at a time.

1. Select Start > Apps > Dictionary Loader.

The Dictionary Loader dialog box appears.

2. Select File > New > Dictionary Repositroy.

The New Repository dialog box appears.

3. Enter the following information:

The values you enter here must match the values you specified during the Oracle Central
Coding software installation.

• Oracle Server—Oracle database server connection string.

• Schema Owner—Name of the coding dictionary database user.

– This must be the same name that was entered for the Central Coding
Dictionary User during the Oracle Central Coding installation.

– This name is also required when creating a connection to the database.
For more information, see Creating a connection to the database.

• Schema Password and Confirm Schema Password—Password for the coding
dictionary database user.
This password is also required when connecting to the database. For more
information, see Connecting to the database.

• Tablespace—The tablespace for the coding dictionaries.
The example used in this guide is coding.

Note:

For more information about the Oracle fields, see Create the database and
tablespaces. For instructions on installing the Oracle Central Coding
software, see Installing the Central Coding software.

4. Click OK.

The Enter Dictionary Administrator Credentials page appears.

5. Enter the user name and password for the dictionary database adminstrator, and click
OK.

A database administrator creates the dictionary database administrator account before
the Oracle Central Coding installation. For more information, see Create database user
accounts.

Messages appear in a window as the repository is created.

When repository creation is complete:

• A message appears in the Output pane in the Dictionary Loader tool.
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• The log for the job is available in <Installation
Folder>\DictionaryLoader\Setup\CreateRepository.log.

Creating a connection to the database
Connections are created within repositories. Although you can create multiple
connections, only one connection can be active at a time.

Note:

If a connection is already active, select File > Disconnect before beginning
this procedure.

1. Select Start > Apps > Dictionary Loader.

The Dictionary Loader dialog box appears.

2. In the Dictionary Loader tool, select File > New > Connection.

The Connection Information dialog box appears.

3. Enter the following information:

• Connection Name—Unique name for the connection.

• Server—TNS name for the database.

• User Name—Name of the coding dictionary database user that was created
when the repository was set up.
This is the name you entered in the Schema Owner field in the New
Repository dialog box. For more information, see Creating a dictionary
repository.

Note:

For more information about the Oracle fields, see Create the database
and tablespaces. For instructions on installing the Central Coding
software, see Installing the Central Coding software.

4. Click Save.

The connection is created. It appears in the Data Connections tree view in the left
pane of the Dictionary Loader tool dialog box.

Note:

If the connection does not appear in the tree, close the Dictionary Loader
tool and open it again.

Connecting to the database
1. Select Start > Apps > Dictionary Loader.
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The Dictionary Loader dialog box appears.

2. In the Dictionary Loader tool, select a connection from the Data Connections tree view
in the left pane.

3. Select File > Connect.

The Connection Information dialog box appears.

4. Enter the password that was created when the repository was set up.

This is the name you entered in the Schema Password field in the New Repository
dialog box. For more information, see Creating a dictionary repository.

5. Click Connect.

When the connection is established:

• A Dictionaries node is added to the Data Connections tree for this connection.
Select this node for information about the installed dictionaries.

• A Types node is added to the Data Connections tree for this connection.
Select this node for information about the installed dictionary types.

Viewing the dictionary types for a connection
Use this procedure to view information about the dictionary types that are available for a
connection.

1. Select Start > Apps > Dictionary Loader.

The Dictionary Loader dialog box appears.

2. Select a connection and connect to the database.

For more information, see Connecting to the database.

3. In the Data Connections tree in the left pane, select the Types node for the active
connection.

Information about the Dictionary Types for this connection appears in the top pane.

4. If the dictionary type file for the coding dictionary you want to load does not appear in the
Dictionary Loader tool, you can import the dictionary type.

For more information, see Importing the dictionary type XML file.

• Dictionary statuses

Importing the dictionary type XML file

1. Select Start > Apps > Dictionary Loader.

The Dictionary Loader dialog box appears.

2. Select a connection and connect to the database.

For more information, see Connecting to the database.

3. In the Data Connections tree in the left pane, select the Types node for the active
connection.

Information about the Dictionary Types for this connection appears in the top pane.

4. Select Dictionary Type > Import.
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The Locate Files dialog box appears.

5. Browse to the folder that contains the XML file to import.

The Oracle Central Coding software includes XML files for the standard dictionary
types in <Installation Folder>\DictionaryLoader\Setup.

• MedDRA_DictionaryType.xml

• MedDRAJ_DictionaryType.xml

• MedDRAC_DictionaryType.xml

• WHODD_DictionaryType.xml

• JDrug_DictionaryType.xml

Note:

If you created a custom dictionary type, browse to the file you created.
For more information, see Creating a new dictionary type for a custom
dictionary.

6. Select a file and click Open.

The full path to the XML file appears in the Location field.

7. Click OK.

When the import is complete, a message appears in the Output pane and
information about the dictionary type appears at the top of the Dictionary Types
pane.

Loading standard dictionaries
In this section:

• Overview of the steps to load a standard coding dictionary

• About pre-ICH and ICH formats of the WHO-DD dictionary

• Loading a pre-ICH version of the WHO-DD dictionary

• Viewing the dictionaries available for a database connection

• Generating the schema for the dictionary data

• Loading dictionary data

• Activating the dictionary

Overview of the steps to load a standard coding dictionary
1. If you are using a WHO-DD dictionary, determine whether you are using a pre-ICH

or ICH format of the dictionary.

For more information, see:

• About pre-ICH and ICH formats of the WHO-DD dictionary.

• Loading a pre-ICH version of the WHO-DD dictionary.
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2. Make sure that the dictionary type for the dictionary that you want to load has been
imported.

For more information, see Importing the dictionary type XML file.

3. Make sure that the dictionary connection is established.

For more information, see Viewing the dictionaries available for a database connection.

4. Generating the schema for the dictionary data.

The Dictionary Loader tool uses dictionary types to create dictionary schemas.

5. Load the dictionary data.

Load dictionary data into the database using the schema that you generated. The
dictionary schema must exist before you can load data into it.

6. Activate the dictionary.

Dictionaries must be activated to be used for coding.

About pre-ICH and ICH formats of the WHO-DD dictionary
The format of the WHO‑DD C dictionary files was changed for compliance with the ICH
guidelines for drug dictionaries. The Oracle Central Coding application ships with the control
files for both the pre-ICH and ICH dictionary formats. You can load either format of the
WHO‑DD dictionary for use in the Oracle Central Coding application.

• ICH format—An ICH version of the WHO-DD dictionary is one released in or after March
2006.
The control files for the ICH version of the dictionary are stored in two locations:

– <Installation Folder>\Dictionary Loader\bin\setup\control
files\whodd

– <Installation Folder>\Dictionary Loader\bin\setup\control
files\whodd\ICH

The Oracle Central Coding application is set up by default to use the ICH version of the
WHO‑DD dictionary. Therefore, if you want to use this dictionary format, no changes to
the control files are required.

• Pre-ICH format—A pre-ICH version of the WHO-DD dictionary is one released prior to
March 2006.
The control files for the pre-ICH version of the dictionary are stored in:

– <Installation Folder>\Dictionary Loader\bin\setup\control
files\whodd\Pre-ICH

If you want to use this dictionary format, you must copy the control files to a different
directory.

For more information, see Loading a pre-ICH version of the WHO‑DD dictionary.
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Loading a pre-ICH version of the WHO-DD dictionary

Note:

Use this procedure only if you plan to load a pre-ICH version of the WHO‑DD
dictionary. A pre-ICH version of the WHO-DD dictionary is one released prior
to March 2006.

1. Navigate to <Installation
Folder>\DictionaryLoader\bin\setup\control files\whodd.

2. Delete the control files (CTRL) from the whodd directory.

The control files for the ICH dictionary format are also stored in <Installation
Folder>\Dictionary Loader\bin\setup\control files\whodd\ICH
so that they are available if you decide to use the ICH dictionary format at a later
time.

3. Navigate to <Installation
Folder>\DictionaryLoader\bin\setup\control files\whodd\Pre-
ICH and copy the CTRL files into the <Installation
Folder>\DictionaryLoader\bin\setup\control
files\whodddirectory.

Viewing the dictionaries available for a database connection
1. Select Start > Apps > Dictionary Loader.

The Dictionary Loader dialog box appears.

2. Select a connection and connect to the database.

For more information, see Connecting to the database.

3. In the Data Connections tree in the left pane, select the Dictionaries node for the
active connection.

The Dictionaries pane displays one row of information for every dictionary
associated with this connection.

• Dictionary statuses

Dictionary statuses

Status Description

DEFINED The type, version, culture, and schema that
hold data for the dictionary are defined. Data is
not loaded into the schema.

LOADED Data is loaded into the schema for the defined
dictionary.

ACTIVE The dictionary is defined, data is loaded into
the schema, and the dictionary is available for
coding.
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Status Description

INACTIVE The dictionary is defined and data is loaded
into the schema, but the dictionary is not
available for coding.

REMOVED The schema and data associated with the
dictionary are deleted.

Generating the schema for the dictionary data

Note:

The Dictionary Loader tool uses dictionary types to create dictionary schemas.

1. Select Start > Apps > Dictionary Loader.

The Dictionary Loader dialog box appears.

2. Select a connection and connect to the database.

For more information, see Connecting to the database.

3. Verify that the dictionary type for the dictionary that you want to create has been
imported.

If necessary, import the dictionary type. For more information, see Importing the
dictionary type XML file.

4. In the Data Connections tree in the left pane, select the Dictionaries node for the active
connection.

Information about the Dictionary Types for this connection appears in the top pane.

5. Select File > New > Dictionary.

The New Dictionary dialog box appears.

6. Enter the following information:

• Type—Dictionary type that exists for this connection. Standard dictionary types are
WHO‑DD and MedDRA. If you imported custom types, they appear in the drop-down
list.

• Version—The version of the dictionary. For example, 06Q4 identifies the 2006 Q4
version for WHO‑DD; 9.1 identifies the 9.1 version for MedDRA. 30 characters
maximum.

• Culture—The culture setting for the dictionary data. For example, en-US. 10
characters maximum.

• Punctuation Filter—The characters that are to be considered as punctuation by the
coding algorithm in the step that removes punctuation. OPTIONAL. 100 characters
maximum.

• Description—A brief description of the dictionary. OPTIONAL. 200 characters
maximum.

• Owner for Schema—The unique name for the schema.

• Schema Password—The password for this dictionary schema.
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• Confirm Schema Password—The password for this dictionary schema.

• Tablespace—The name of the tablespace that was created for the
dictionaries.

7. Click OK.

The Enter Dictionary Administrator Credentials page appears.

8. Enter the user name and password for the dictionary database administrator, and
click OK.

When the dictionary has been created, a message appears in the Output pane
and information about the dictionary appears in the Dictionaries list in the top pane
in the Dictionary Loader tool.

Loading dictionary data
Use this procedure to Load dictionary data into the database using the schema that
you generated. The dictionary schema must exist before you can load data into it. For
more information, see Generating the schema for the dictionary data.

1. Select Start > Apps > Dictionary Loader.

The Dictionary Loader dialog box appears.

2. Select a connection and connect to the database.

For more information, see Connecting to the database.

3. In the Data Connections tree in the left pane, select the Dictionaries node for the
active connection.

Information about the Dictionaries for this connection appears in the top pane.

4. In the Dictionaries pane, select the dictionary to load data into.

5. Select Dictionary > Load.

The Locate Files dialog box appears.

6. Enter the following information:

• Location—Browse to the folder that contains the file with the dictionary data
to load.
Select a directory and click Open. The full path to the files appears in the
Location field.

• Dictionary schema password—Password for this dictionary schema, which
was created when the dictionary was created.

7. Click OK.

The dictionary data loads. Messages appear in the Output pane in the Dictionary
Loader tool. When the load is complete, you can check the log file to verify the
status of the load operation. The log file is in <Installation
Folder>\DictionaryLoader\Setup\gather_stats_[schemaowner].lo
g.

Activating the dictionary
1. Select Start > Apps > Dictionary Loader.

The Dictionary Loader dialog box appears.
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2. Select a connection and connect to the database.

For more information, see Connecting to the database.

3. In the Data Connections pane, select a connection.

4. Select Dictionary > Activate.

The dictionary status changes to ACTIVE. The dictionary is defined, data is loaded into
the schema, and the dictionary is available for coding.

Loading custom dictionaries
In this section:

• Overview of the steps to load a custom dictionary

• Creating a custom dictionary definition XML file

• Creating a new dictionary type for a custom dictionary

• Importing the dictionary type XML file

• Viewing the dictionary types for a connection

• Generating the schema for the dictionary data

• Loading dictionary data

• Activating the dictionary

Overview of the steps to load a custom dictionary
1. Create a custom dictionary definition XML file.

Create an XML file that contains the metadata for the dictionary levels and the SQL
needed to set up the tables in the database.

2. Create a new dictionary type for a custom dictionary.

For more information, see: Creating a new dictionary type for a custom dictionary.

3. Import the dictionary type XML file.

For more information, see: Importing the dictionary type XML file.

4. View the dictionaries available for a database connection

For more information, see: Viewing the dictionaries available for a database connection.

5. Generate the schema for a dictionary.

The Dictionary Loader tool uses dictionary types to create dictionary schemas.

6. Load dictionary data.

Load dictionary data into the database using the schema you generated.

The dictionary schema must exist before you can load data into it.

7. Activate the dictionary.

Dictionaries must be activated to be used for coding.

8. Create custom icons for the coding browser.

Create custom dictioanry icons for use in the coding browser Brose mode.
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Creating a custom dictionary definition XML file
Use the standard XML files for the MedDRA, MedDRA-J, WHO‑DD, and JDrug
dictionaries as the basis for your custom XML files. These files are in ...Central
Coding Application\DictionaryLoader\Setup.

For the DictionaryType element:

• adaptertype sub-element must be Custom.

• numlevels must be greater than 0 and must equal the number of Level elements.

Creating a new dictionary type for a custom dictionary
1. Select Start > Apps > Dictionary Loader.

The Dictionary Loader dialog box appears.

2. Select a connection and connect to the database.

For more information, see Connecting to the database.

3. Select the Types node for the active connection from the Data Connections tree
in the left pane.

Information about the Dictionary Types for this connection appears in the top pane.

4. Select File > New > New Dictionary Type.

The New Type dialog box appears.

When working in the grid:

• Note that each row represents one level in the dictionary.

• Use the buttons to add and remove levels and to change the order of levels for
the dictionary type.

• Create at least one level.

• Create the same number of terms (one or two) at each level.

5. Enter the following information:

• Type—The name for the new dictionary type.

• Description—A description of the dictionary type. OPTIONAL.

• Supports Stopwords—Select if you want to run the algorithm steps that
remove stopwords from the text to be coded for dictionaries of this type.

• Term—A label for the first term of this level.

• Additional Information—A label for each additional level of the dictionary.
Separate each additional information item with a pipe ( | ).

• Abbreviation—An abbreviated name to identify this level.
The full name of this level is the label for the first term, concatenated with the
label for the second term.

• Tablename—The name of the table to create in the schema of a dictionary of
this type to hold data for this level.

• Filename—The name of the flat file that contains the data for this level.
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• Encoding—The encoding type of the file specified in the Filename field. OPTIONAL.
If not specified, the default encoding type is used.

• Delimiter—The field delimiter used in records in the file specified in the Filename
field. OPTIONAL.
If not specified, the default delimiter is used.

6. Click OK.

The custom dictionary type is added to the Dictionary Types pane in the Dictionary
Loader tool.

Importing the dictionary type XML file

1. Select Start > Apps > Dictionary Loader.

The Dictionary Loader dialog box appears.

2. Select a connection and connect to the database.

For more information, see Connecting to the database.

3. In the Data Connections tree in the left pane, select the Types node for the active
connection.

Information about the Dictionary Types for this connection appears in the top pane.

4. Select Dictionary Type > Import.

The Locate Files dialog box appears.

5. Browse to the folder that contains the XML file to import.

The Oracle Central Coding software includes XML files for the standard dictionary types
in <Installation Folder>\DictionaryLoader\Setup.

• MedDRA_DictionaryType.xml

• MedDRAJ_DictionaryType.xml

• MedDRAC_DictionaryType.xml

• WHODD_DictionaryType.xml

• JDrug_DictionaryType.xml

Note:

If you created a custom dictionary type, browse to the file you created. For
more information, see Creating a new dictionary type for a custom dictionary.

6. Select a file and click Open.

The full path to the XML file appears in the Location field.

7. Click OK.

When the import is complete, a message appears in the Output pane and information
about the dictionary type appears at the top of the Dictionary Types pane.
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Viewing the dictionary types for a connection
Use this procedure to view information about the dictionary types that are available for
a connection.

1. Select Start > Apps > Dictionary Loader.

The Dictionary Loader dialog box appears.

2. Select a connection and connect to the database.

For more information, see Connecting to the database.

3. In the Data Connections tree in the left pane, select the Types node for the active
connection.

Information about the Dictionary Types for this connection appears in the top pane.

4. If the dictionary type file for the coding dictionary you want to load does not appear
in the Dictionary Loader tool, you can import the dictionary type.

For more information, see Importing the dictionary type XML file.

• Dictionary statuses

Dictionary statuses

Status Description

DEFINED The type, version, culture, and schema that
hold data for the dictionary are defined. Data is
not loaded into the schema.

LOADED Data is loaded into the schema for the defined
dictionary.

ACTIVE The dictionary is defined, data is loaded into
the schema, and the dictionary is available for
coding.

INACTIVE The dictionary is defined and data is loaded
into the schema, but the dictionary is not
available for coding.

REMOVED The schema and data associated with the
dictionary are deleted.

Generating the schema for the dictionary data

Note:

The Dictionary Loader tool uses dictionary types to create dictionary
schemas.

1. Select Start > Apps > Dictionary Loader.

The Dictionary Loader dialog box appears.
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2. Select a connection and connect to the database.

For more information, see Connecting to the database.

3. Verify that the dictionary type for the dictionary that you want to create has been
imported.

If necessary, import the dictionary type. For more information, see Importing the
dictionary type XML file.

4. In the Data Connections tree in the left pane, select the Dictionaries node for the active
connection.

Information about the Dictionary Types for this connection appears in the top pane.

5. Select File > New > Dictionary.

The New Dictionary dialog box appears.

6. Enter the following information:

• Type—Dictionary type that exists for this connection. Standard dictionary types are
WHO‑DD and MedDRA. If you imported custom types, they appear in the drop-down
list.

• Version—The version of the dictionary. For example, 06Q4 identifies the 2006 Q4
version for WHO‑DD; 9.1 identifies the 9.1 version for MedDRA. 30 characters
maximum.

• Culture—The culture setting for the dictionary data. For example, en-US. 10
characters maximum.

• Punctuation Filter—The characters that are to be considered as punctuation by the
coding algorithm in the step that removes punctuation. OPTIONAL. 100 characters
maximum.

• Description—A brief description of the dictionary. OPTIONAL. 200 characters
maximum.

• Owner for Schema—The unique name for the schema.

• Schema Password—The password for this dictionary schema.

• Confirm Schema Password—The password for this dictionary schema.

• Tablespace—The name of the tablespace that was created for the dictionaries.

7. Click OK.

The Enter Dictionary Administrator Credentials page appears.

8. Enter the user name and password for the dictionary database administrator, and click
OK.

When the dictionary has been created, a message appears in the Output pane and
information about the dictionary appears in the Dictionaries list in the top pane in the
Dictionary Loader tool.

Loading dictionary data
Use this procedure to Load dictionary data into the database using the schema that you
generated. The dictionary schema must exist before you can load data into it. For more
information, see Generating the schema for the dictionary data.

1. Select Start > Apps > Dictionary Loader.
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The Dictionary Loader dialog box appears.

2. Select a connection and connect to the database.

For more information, see Connecting to the database.

3. In the Data Connections tree in the left pane, select the Dictionaries node for the
active connection.

Information about the Dictionaries for this connection appears in the top pane.

4. In the Dictionaries pane, select the dictionary to load data into.

5. Select Dictionary > Load.

The Locate Files dialog box appears.

6. Enter the following information:

• Location—Browse to the folder that contains the file with the dictionary data
to load.
Select a directory and click Open. The full path to the files appears in the
Location field.

• Dictionary schema password—Password for this dictionary schema, which
was created when the dictionary was created.

7. Click OK.

The dictionary data loads. Messages appear in the Output pane in the Dictionary
Loader tool. When the load is complete, you can check the log file to verify the
status of the load operation. The log file is in <Installation
Folder>\DictionaryLoader\Setup\gather_stats_[schemaowner].lo
g.

Activating the dictionary
1. Select Start > Apps > Dictionary Loader.

The Dictionary Loader dialog box appears.

2. Select a connection and connect to the database.

For more information, see Connecting to the database.

3. In the Data Connections pane, select a connection.

4. Select Dictionary > Activate.

The dictionary status changes to ACTIVE. The dictionary is defined, data is loaded
into the schema, and the dictionary is available for coding.

Using custom icons in the coding browser
The coding browser in the Oracle Central Coding application displays icons for the
levels of the coding dictionary. When you create a custom dictionary, you must also
provide the icons for the coding browser.

To identify the custom dictionary icons to use in the coding browser:

1. Copy the graphics for the icons to the Resources folder in the virtual directory
where the Oracle Central Coding application is running.
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2. Use the following naming convention for the custom icons: <dictionary type>_<tablename
for the level>.gif.

In the previous example:

• <dictionary type> is the name of the XML file that defines the dictionary type.
For more information, see Creating a custom dictionary definition XML file.

• <tablename for the level> is the name of the Oracle table, where the data for that
level is stored.

For example, if a custom dictionary type XML file is named CustomTest.xml and it has
three levels named soc, pt, and llt, name the icons for the levels as follows:

• CustomTest_soc.gif

• CustomTest_pt.gif

• CustomTest_llt.gif

Installing the language packs for the Japanese dictionaries
Use this procedure to install the language pack for the MedDRA-J or JDrug dictionary. The
language pack displays the dictionary level names and additional information labels in
Japanese in the user interface.

1. Select Start > Apps > Dictionary Loader.

The Dictionary Loader dialog box appears.

2. Make sure that the dictionary database is set up, that you are connected to the database,
and that the dictionary or dictionaries are loaded.

For more information, see Setting up the dictionary database and Loading and managing
the coding dictionaries.

3. In the Data Connections tree in the left pane, select the Types node for the active
connection.

Information about the Dictionary Types for this connection appears in the top pane.

4. Select the Dictionary Type for which you want to install the language pack.

5. Select Dictionary Type > Localized Elements.

The Localized Elements dialog box appears.

6. Click Import.

The Locate Files dialog box appears.

7. Browse to the <LanguagePack>.xml file that you want to install.

The Oracle Central Coding software includes XML files for the standard dictionary types
in <Installation Folder>\DictionaryLoader\Setup.

• MedDRA_ja-JP.xml

• JDrug_ja-JP.xml

8. Click OK.

Maintaining the coding dictionaries
In this section:
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• Changing the punctuation filter for a dictionary type

• Updating a dictionary type and applying the changes to installed dictionaries

• Converting the WHO-DD dictionary to C format

• Deleting a dictionary type

• Inactivating a dictionary

• Deleting a connection to the database

• Removing a dictionary schema

• Reviving a dictionary schema

• Deleting a dictionary

Changing the punctuation filter for a dictionary type
Use this procedure to change the characters in the punctuation filter for a dictionary
type. The punctuation filter identifies characters that you want the coding algorithm to
consider as punctuation in the step that removes punctuation.

1. Select Start > Apps > Dictionary Loader.

The Dictionary Loader dialog box appears.

2. Select a connection and connect to the database.

For more information, see Connecting to the database.

3. Select the Types node for the active connection from the Data Connections tree
in the left pane.

Information about the Dictionary Types for this connection appears in the top pane.

4. Select a dictionary type.

An arrow appears in the column to the left of the Type column.

5. Select Dictionary > Change Punctuation Filter.

The Punctuation Filter dialog box appears.

6. Add or remove characters as necessary.

7. Click OK.

Updating a dictionary type and applying the changes to installed
dictionaries

Use this procedure to apply changes from a <Dictionary_Type>.xml file to installed
dictionaries. For more information, see About dictionary types and dictionary schemas.
The <Dictionary_Type>.xml file contains, among other things, the element
configuration settings for each dictionary type (MedDRA, MedDRA-J, WHO-DD,
JDrug, and custom). These settings control which coding features and information are
available to users in the Oracle Central Coding user interface. To apply the updated
settings to existing coding definitions, you must manually reset your element
configuration settings for the coding definitions created before the update and
associated with the dictionary. For more information, see the User Guide.

1. Select Start > Apps > Dictionary Loader.
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The Dictionary Loader dialog box appears.

2. Select a connection and connect to the database.

For more information, see Connecting to the database.

3. Select the Types node for the active connection.

4. Select a dictionary type.

5. Select Dictionary Type > Update.

The Locate Files dialog box appears.

6. Browse to the <Dictionary_Type>.xml file to use for the update.

The Oracle Central Coding software includes XML files for the standard dictionary types
in <Installation Folder>\DictionaryLoader\Setup.

• MedDRA_DictionaryType.xml

• MedDRAJ_DictionaryType.xml

• WHODD_DictionaryType.xml

• JDrug_DictionaryType.xml

If you are using a custom dictionary type, browse to the file you created. For more
information, see Creating a new dictionary type for a custom dictionary.

7. Click OK.

The Dictionary Selection Form dialog box appears.

8. Select one or more versions of the dictionary.

9. Click OK.

Converting the WHO-DD dictionary to C format
You can use the Dictionary Loader or the ConvertToC utility to convert the WHO-DD
dictionary to the C format.

• Using the Dictionray Loader to convert the WHO-DD dictionary to C format

• Using the ConvertToC utility to convert the WHO-DD dictionary to C format

Using the Dictionray Loader to convert the WHO-DD dictionary to C format
1. Select Start > Apps > Dictionary Loader.

The Dictionary Loader dialog box appears.

2. Select a connection and connect to the database.

For more information, see Connecting to the database.

3. In the Data Connections tree in the left pane, select the Dictionaries node for the active
connection.

Information about the dictionaries for this connection appears in the top pane.

4. Select the WHO-DD B format dictionary.

5. Select Dictionary > Convert WHODD B to C.

The Locate File dialog box appears.
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6. Click Browse and locate the folder that contains WHO-DD B format dictionary
files.

7. Select the directory and click Open.

The full path to the files appears in the Location field.

Using the ConvertToC utility to convert the WHO-DD dictionary to C format
1. Open a Command Prompt window and enter the name of the drive in which the

executable file is installed.

By default, the executable file is installed in the same location as the Oracle
Central Coding application.

2. Enter the location of the executable file in the drive that you specified.

3. Enter the following syntax for converting the WHO-DD B format dictionary to C
format:

ConvertToC [File Path]

In the command syntax:

• File Path—Path for the location of the WHO-DD B format dictionary files.

The ConvertToC utility creates a folder called C in the folder in which the WHO-DD
B format dictionary files are installed.

Deleting a dictionary type
You can delete dictionary types that do not have schemas associated with them. If a
dictionary schema that uses this dictionary type exists, you must delete the schema
before you can delete the dictionary type. For more information, see Removing a
dictionary schema.

1. Select Start > Apps > Dictionary Loader.

The Dictionary Loader dialog box appears.

2. Select a connection and connect to the database.

For more information, see Connecting to the database.

3. In the Data Connections tree in the left pane, select the Types node for the active
connection.

Information about the Dictionary Types for this connection appears in the top pane.

4. Select Dictionary Type > Delete.

A confirmation dialog box appears.

5. Click Yes.

Inactivating a dictionary
Inactive dictionaries remain in the list of dictionaries for a connection and can be
reactivated if necessary. You must inactivate a dictionary before you can delete it.

1. Select Start > Apps > Dictionary Loader.

The Dictionary Loader dialog box appears.
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2. Select a connection and connect to the database.

For more information, see Connecting to the database.

3. Select the Dictionaries node for the active connection.

4. Select a dictionary.

5. Select Dictionary > Inactivate.

The dictionary status changes to INACTIVE. The dictionary is defined and data is loaded
into the schema, but the dictionary is not available for coding.

Deleting a connection to the database
1. Select Start > Apps > Dictionary Loader.

The Dictionary Loader dialog box appears.

2. Select a connection and connect to the database.

For more information, see Connecting to the database.

3. Select Connection > Delete.

Deleted connections remain visible in the Data Connections tree view in the left pane of the
Dictionary Loader tool until you close the dialog box.

Removing a dictionary schema
Removing a dictionary removes the dictionary schema and all data. When you remove a
dictionary schema, all synonym lists, coding definitions, assignment rules, and requests
entered against the dictionary are lost and cannot be retrieved.

Caution:

Oracle recommends that you do not remove the dictionary schema or delete a
dictionary that has been used for coding. Delete only dictionaries that you have set
up but have not coded against.

1. Select Start > Apps > Dictionary Loader.

The Dictionary Loader dialog box appears.

2. Select a connection and connect to the database.

For more information, see Connecting to the database.

3. Make sure that you have inactivated the dictionary whose dictionary schema you want to
remove.

For more information, see Inactivating a dictionary (Updating a dictionary type and
applying the changes to installed dictionaries, Inactivating a dictionary, Reviving a
dictionary schema).

4. Select the Dictionaries node for the active connection.

5. Select a dictionary to remove.

6. Select Dictionary > Remove.

A confirmation dialog box appears.
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7. Click Yes.

8. If prompted, enter the user name and password for the dictionary schema
administrator, and click OK.

The dictionary remains in the list of Dictionaries. The dictionary status changes to
REMOVED.

Note:

You must revive this dictionary type before you can use it again to load
dictionaries. For more information, see Reviving a dictionary schema.

Reviving a dictionary schema
Reviving a dictionary schema recreates the schema of a previously removed
dictionary. For more information, see Removing a dictionary schema. After reviving a
dictionary schema, you can load data into the dictionary.

1. Select Start > Apps > Dictionary Loader.

The Dictionary Loader dialog box appears.

2. Select a connection and connect to the database.

For more information, see Connecting to the database.

3. Select the Dictionaries node for the active connection.

4. Select a dictionary with a status of REMOVED.

5. Select Dictionary > Revive.

The New Dictionary dialog box appears. The information in most fields is read-only
because it already exists in the database.

6. Enter the following information.

• Schema Password—The password for this dictionary schema.

• Confirm Schema Password—The password for this dictionary schema.

• Tablespace—The name of the tablespace that was created for the
dictionaries.

7. Click OK.

8. If prompted, enter the user name and password for the dictionary database
administrator, and click OK.

Deleting a dictionary
Deleted dictionaries cannot be revived or reactivated. When you delete a dictionary, all
synonym lists, coding definitions, assignment rules, and requests entered against the
dictionary become invalid and cannot be retrieved.
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Note:

Oracle recommends that you do not remove the dictionary schema or delete a
dictionary that has been used for coding. Delete only dictionaries that you have set
up but have not coded against.

1. Select Start > Apps > Dictionary Loader.

The Dictionary Loader dialog box appears.

2. Select a connection and connect to the database.

For more information, see Connecting to the database.

3. Make sure that you have removed the schema for the dictionary that you want to delete.

For more information, see Removing a dictionary schema.

4. Select the Dictionaries node for the active connection.

5. Select a dictionary.

6. Select Dictionary > Delete.

A confirmation dialog box appears.

7. Click Yes.

8. If prompted, enter the user name and password for the dictionary database administrator,
and click OK.
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6
Setting up coding metadata using the
command line

In this chapter:

• Using the Data Installer

• Adding adapters and studies using the command line

• Replacing the certificate to secure internal communication with the Job Scheduler service

• Selecting a certificate for Oracle Life Sciences InForm Adapter authentication

• Setting a web proxy for outgoing calls

Using the Data Installer
In this section:

• About the Data Installer

• Exporting data with the Data Installer

• Importing data with the Data Installer

• Updating data with the Data Installer

About the Data Installer
The Oracle Central Coding software includes a command line application, called the Data
Installer, that you can use to import data instead of entering the data through the user
interface, and to export the data.

The Data Installer is installed automatically as part of the Oracle Central Coding software
installation in <Installation Folder>\CentralCodingServer\CodingWebUI\bin.

Oracle recommends that you use the Data Installer to export data from a configured instance
of the Oracle Central Coding application, and import the data file as is, or edit it and perform
an update. Oracle does not recommend creating your own configuration file for import.

You can use the Data Installer to:

• Export and import synonym lists, stopword lists, coding algorithms, and coding
definitions.

Note:

You cannot update coding definitions. You can replace or update a synonym
list.

• Import assignment rules.
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Note:

You cannot update assignment rules.

• Export and import security data such as users, rights, roles, and workteams from
an existing installation to another installation.

Note:

Security data cannot be created manually. You must export it and then
import it to the new instance.

• Export and import system settings such as the authentication options, application
settings and lock management options, and impact analysis options from an
existing installation to another installation.

• Data Installer modes

• Data Installer parameters

Data Installer modes
The Data Installer has the following modes:

• Download—Used to export data from the Oracle Central Coding application.
When you export data using the Download mode, an export configuration XML file
is created. You can use this file with the Data Installer to import or update data in
the Oracle Central Coding application.

• Setup—Used to import data into the Oracle Central Coding application.
To import data in the Oracle Central Coding application, you can use the export
configuration XML file that is created when you run the Data Installer in Download
mode, a manually created XML configuration file, or the sample XML configuration
file called CentralCodingConfigMaster.xml, which you can edit as needed.

• Update—Used to update existing data in the Oracle Central Coding application.
To update data in the Oracle Central Coding application, you can use the export
configuration XML file that is created when you run the Data Installer in Download
mode, a manually created XML configuration file, or the sample XML configuration
file called CentralCodingConfigMaster.xml, which you can edit as needed.

Note:

The sample XML file is installed in the same location as the Data
Installer.
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Data Installer parameters

Parameter Description

ApplicationName Name of the Oracle Central Coding application.
The application name is located in the
PhaseForward.Platform.Config.xml
file, which is installed in the same directory as the
Data Installer. The default application name is
CentralCodingApplication.

Mode Type of action to perform. The available options
are:

• Download—Export data from the Oracle
Central Coding application.

• Setup—Import data to the Oracle Central
Coding application.

• Update—Update existing data in the Oracle
Central Coding application.

Note:

When using the Data Installer in
Update mode, make sure that the
GUIDs for the data in the update
configuration file do not already
exist in the Central Coding
application. If duplicate GUIDs
exist, the Data Installer displays an
error message and the update
does not complete.

Type SysConfig.

MasterFile Path to the master configuration file, called
MasterConfig.xml. The master configuration
file is installed in the same directory as the Data
Installer.

/DISABLESINGLETRANSACTION Instructs the Data Installer to execute each
transaction separately. By default, the Data
Installer executes all commands in a single
transaction.

Exporting data with the Data Installer
To export data from an instance of the Oracle Central Coding application, use the Data
Installer in Download mode. You can export synonym lists, stopword lists, coding algorithms,
coding definitions, and system settings.

1. Specify the data to export:

• Edit an existing configuration file.

• Create a configuration file.

Make sure to specify the directory path in which to generate the export files. The directory
must exist before you run the Data Installer.
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2. Open a Command Prompt window and enter the name of the drive in which the
Data Installer is installed.

3. Enter the location of the Data Installer in the drive you specified:

<Installation Folder>\CentralCodingServer\CodingWebUI\bin
4. Run the utility in Download mode, using the following syntax:

PhaseForward.Platform.Installation.DataInstaller.exe [ApplicationName]
[Download] [SysConfig] [MasterFile]
In the command syntax:

• ApplicationName—Name of the Oracle Central Coding application. The
application name is located in the PhaseForward.Platform.Config
config file, which is installed in the same directory as the Data Installer. The
default application name is CentralCodingApplication.

• MasterFile—Path to the master configuration file. The master configuration
file is called MasterConfig.xml, and is located in the same directory as the
Data Installer.

The Data Installer extracts the data and generates the XML files in the directory
that you specified in the export configuration file.

Importing data with the Data Installer
To import data into an instance of the Oracle Central Coding application, use the Data
Installer in Setup mode. You can import users, roles, workteams, assignment rules,
synonym lists, stopword lists, coding algorithms, and coding definitions.

Note:

You cannot import an object if its GUID is already used in the database into
which you are importing. If duplicate GUIDs exist, an error message appears,
and the import stops.

1. Specify the data to import:

• Edit an existing configuration file.

• Create a configuration file.

• Locate an existing export file.
For more information about the export procedure, see Exporting data with the
Data Installer.

Note:

Oracle recommends that you use the Data Installer to export data from a
configured instance of the Oracle Central Coding application, and import
the data file as is, or edit it and perform an update. Oracle does not
recommend creating your own configuration file for import.

Make sure to specify the directory path of the file to import.
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Note:

Data in XML files is case-sensitive.

2. Open a Command Prompt window and enter the name of the drive in which the Data
Installer is installed.

3. Enter the location of the Data Installer in the drive you specified:

<Installation Folder>\CentralCodingServer\CodingWebUI\bin
4. Run the utility in Setup mode, using the following syntax:

PhaseForward.Platform.Installation.DataInstaller.exe [ApplicationName]
[Setup] [SysConfig] [MasterFile]
In the command syntax:

• ApplicationName—Name of the Oracle Central Coding application. The
application name is located in the PhaseForward.Platform.Config config file,
which is installed in the same directory as the Data Installer. The default application
name is CentralCodingApplication.

• MasterFile—Path to the master configuration file. The master configuration file is
called MasterConfig.xml, and is located in the same directory as the Data
Installer.

The Data Installer adds the data to the appropriate tables in the target Oracle Central
Coding database, based on the import data type.

Updating data with the Data Installer
To update existing data in the Oracle Central Coding application using the Data Installer, run
the utility in Update mode. You can update users, roles, workteams, synonym lists, stopword
lists, coding algorithms, and system settings. You cannot update coding definitions or
assignment rules.

Note:

You cannot import an object if its GUID is already used in the database into which
you are importing. If duplicate GUIDs exist, an error message appears, and the
import stops.

1. Specify the data to update:

• Edit an existing configuration file.

• Create a configuration file.

• Locate an existing export file.
For more information about the export procedure, seeExporting data with the Data
Installer.
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Note:

Oracle recommends that you use the Data Installer to export data from a
configured instance of the Oracle Central Coding application, and import
the data file as is, or edit it and perform an update. Oracle does not
recommend creating your own configuration file for import.

Make sure to specify the directory path of the file to use in the update procedure.

Note:

Data in XML files is case-sensitive.

2. Open a Command Prompt window and enter the name of the drive in which the
Data Installer is installed.

3. Enter the location of the Data Installer in the drive you specified:

<Installation Folder>\CentralCodingServer\CodingWebUI\bin
4. Run the utility in Update mode, using the following syntax:

PhaseForward.Platform.Installation.DataInstaller.exe [ApplicationName]
[Update] [SysConfig] [MasterFile]
In the command syntax:

• ApplicationName—Name of the Oracle Central Coding application. The
application name is located in the PhaseForward.Platform.Config
config file, which is installed in the same directory as the Data Installer. The
default application name is CentralCodingApplication.

• MasterFile—Path to the master configuration file. The master configuration
file is called MasterConfig.xml, and is located in the same directory as the
Data Installer.

The Data Installer adds the data to the appropriate tables in your target Oracle
Central Coding database, based on the update data type.

Adding adapters and studies using the command line
In this section:

• About adding adapters and studies using the command line

• Adding an adapter and defining its job schedules using the command line

• Adding a study group using the command line

• Adding a study to an adapter and job schedules using the command line

About adding adapters and studies using the command line
You can add adapters and studies from the user interface, and also through the
command line. The following executable files are installed as part of the Oracle Central
Coding software installation. Run the executable files to install adapters and studies
into the Oracle Central Coding application.
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• PhaseForward.CentralCoding.SetAdapter.exe—Installs an adapter to a Oracle Central
Coding instance.
When you install the adapter using the executable file, you use the available parameters
to define Get Requests and Return Codes schedules for the adapter.

For more information, see Adding an adapter and defining its job schedules using the
command line.

• PhaseForward.CentralCoding.SetStudyGroup.exe—Creates a study group in a Oracle
Central Coding instance.
When you create a study group, you use the available parameters to specify the study to
add to the group, and the Get Requests and Return Codes schedules for the study.

For more information, see Adding a study group using the command line.

• PhaseForward.CentralCoding.SetStudy.exe—Installs a study to a Oracle Central
Coding instance.
When you add the study, you use the available parameters to specify which adapter with
which to associate the study, and you add the study to Get Requests and Return Codes
schedules.

For more information, see Adding a study to an adapter and job schedules using the
command line.

Note:

You can add a study to a Get Requests or Return Codes schedule only if the
schedule is already defined for the adapter to which you are adding the study.

The files are available in the following location:

<Installation Folder>\CentralCodingServer\CodingWebUI\bin

Note:

You must run the executable files in the location in which they were installed.

Adding an adapter and defining its job schedules using the command line
1. Open a Command Prompt window and enter the name of the drive in which the

executable file is installed.

Note:

By default, the executable file is installed in the same location as the Oracle
Central Coding application.

2. Enter the location of the executable file in the drive that you specified:

<Installation Folder>\CentralCodingServer\CodingWebUI\bin
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Note:

You must run the application from this directory.

3. Enter the following command for adding an adapter and defining its job schedules:

PhaseForward.CentralCoding.SetAdapter.exe [AdapterName] [AdapterURL]
[GetVerbatimsSchedule] [ReturnCodesSchedule]
In the command syntax:

• AdapterName—Name of the adapter to add.

• AdapterURL—URL of the adapter to add.

• GetVerbatimsSchedule—Rate at which to run the Get Requests job schedule.
This parameter corresponds to the Time span configuration setting on the
Schedule GetRequests Job page in the user interface.

– 0—Indicates that you will run manual Get Requests jobs for the adapter,
and the adapter should not be added to a Get Requests schedule.

– 1—Set a Get Requests job schedule to run every minute for the adapter.

– 5—Set a Get Requests job schedule to run every five minutes for the
adapter.

– 15—Set a Get Requests job schedule to run every fifteen minutes for the
adapter.

– 30—Set a Get Requests job schedule to run every thirty minutes for the
adapter.

Note:

This parameter is optional.

• ReturnCodesSchedule—Rate at which to run the Return Codes job schedule.
This parameter corresponds to the Time span configuration setting on the
Schedule ReturnCodes Job page in the user interface.

– 0—Indicates that you will run manual Return Codes jobs for the adapter,
and the adapter should not be added to a Return Codes schedule.

– 1—Set a Return Codes job schedule to run every minute for the adapter.

– 5—Set a Return Codes job schedule to run every five minutes for the
adapter.

– 15—Set a Return Codes job schedule to run every fifteen minutes for the
adapter.

– 30—Set a Return Codes job schedule to run every thirty minutes for the
adapter.

Note:

This parameter is optional
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Adding a study group using the command line
1. Open a Command Prompt window and enter the name of the drive in which the

executable file is installed.

Note:

By default, the executable file is installed in the same location as the Oracle
Central Coding application.

2. Enter the location of the executable file in the drive that you specified:

<Installation Folder>\CentralCodingServer\CodingWebUI\bin

Note:

You must run the application from this directory.

3. Enter the following command for adding a study group:

PhaseForward.CentralCoding.SetStudyGroup.exe [StudyGroupName]
[AllowAutoQuery] [AllowAutoClose]
In the command syntax:

• StudyGroupName—Name of the study group to add.

• AllowAutoQuery—Y or N, specifying whether to allow the Oracle Central Coding
application to duplicate an existing query and apply it to all matching verbatims in the
study group that are subsequently entered in the Oracle Central Coding application.

• AllowAutoClose—Y or N, specifying whether to allow the Oracle Central Coding
application to automatically close a query if the verbatim associated with the query is
successfully coded and approved.

Adding a study to an adapter and job schedules using the command line
1. Open a Command Prompt window and enter the name of the drive in which the

executable file is installed.

Note:

By default, the executable file is installed in the same location as the Oracle
Central Coding application.

2. Enter the location of the executable file in the drive that you specified:

<Installation Folder>\CentralCodingServer\CodingWebUI\bin
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Note:

You must run the application from this directory.

3. Enter the following command for adding a study to an adapter and job schedules:

PhaseForward.CentralCoding.SetStudy.exe [SourceApplication]
[AdapterName] [StudyName] [StudyURL] [StudyGroupName]
[ClientAuditUser] [InForm QueryUser] [InFormAuthenticationUser]
[SupportQuery] [StudyLocked] [GetVerbatimsSchedule]
[ReturnCodesSchedule]
In the command syntax:

• SourceApplication—The name of the application that is integrated with the
Oracle Central Coding application.

– InForm

– Clintrial

– Other—Any supported third-party application.

• AdapterName—Name of the adapter to which to add the study.

• StudyName—Name of the study to add.

• StudyURL—URL of the study to add.

• StudyGroupName—Name of the study group with which to associate the
study.

• ClientAuditUser—User name for the audit records that are created in the
InForm application to record the codes that are returned by the Oracle Central
Coding application.
The user name is case-sensitive and must match the Oracle Life Sciences
InForm name exactly.

• InFormQueryUser—User name used to create and update queries in the
Oracle Life Sciences InForm application.

• InFormAuthenticationUser—User name of an Oracle Life Sciences InForm
application user created to communicate with the Oracle Life Sciences InForm
server through web services.

• SupportQuery—Y or N, specifying whether the study supports query
management. Available for Oracle Life Sciences InForm studies.

• StudyLocked—Y or N, specifying whether to lock the study.

• GetVerbatimsSchedule—Y or N, specifying whether to add the study to the
Get Requests schedule for the adapter you specified.

Note:

You can only specify Y if a Get Requests schedule is already defined
for the adapter to which you are adding the study.

• ReturnCodesSchedule—Y or N, specifying whether to add the study to the
ReturnCodes schedule for the adapter you specified.
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Note:

You can only specify Y if a Return Codes schedule is already defined for
the adapter to which you are adding the study.

Replacing the certificate to secure internal communication with
the Job Scheduler service

You select a certificate to secure internal communication with the Job Scheduler service
during the Oracle Central Coding application server installation.
To replace the certificate:

1. Install a new certificate.

For more information, see Install a certificate to secure communication with the Job
Scheduler and InForm Adapter.

2. Run:

UpdateJSCertificate.cmd (located in <Installation
Folder>\CentralCodingServer\CodingWebUI\bin) using the following
syntax:UpdateJSCertificate.cmd <CertificateName> <CertificateThumbprint>
In the previous example:

• CertificateName—Name of the new certificate.

• CertificateThumbprint—Thumbprint of the new certificate.

Selecting a certificate for Oracle Life Sciences InForm Adapter
authentication

Certificate authentication can be used in the following cases between Oracle Central Coding
and Oracle Life Sciences InForm Adapter interfaces:

• Adapter Admin—When the Adapter URL starts with https.

• Coding and Discrepancy web services—When you prefer the certificate authentication
method to the username/password method, when the Adapter URL starts with https.

To select a certificate, or replace the certificate that is currently in use, run the utility
PhaseForward.CentralCoding.UpdateIACertificate.exe located in <Installation
Folder>\CentralCodingServer\CodingWebUI\bin.

Run the utility from the command line with one of the parameters:

• /?—Displays command help and exit codes.

• /s<certificate name> <certificate thumbprint>—Selects the specified certificate to be
used for Oracle Life Sciences InForm Adapter authentication.

• /r—Removes the certificate that is used for Oracle Life Sciences InForm Adapter
authentication.
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Setting a web proxy for outgoing calls
Oracle Central Coding supports proxy servers during web service invocation for
outbound calls.

To configure the outbound proxy, use
PhaseforwardCentralCodingSetDefaultProxy.exe, which is installed during the Oracle
Central Coding software installation in <Installation
Folder>\CentralCodingServer\CodingWebUI\bin.

Edit parameters in the following files:

• web.config
• PhaseForward.Platform.JobScheduler.exe.config
• PhaseForward.CentralCoding.SetStudy.exe.config
• PhaseForward.CentralCoding.SetAdapter.exe.config
Parameters:

• ProxyAddress {URL}—Sets ProxyAddress to the specified URL.

• BypassProxyOnLocal [True|False]—Sets the BypassProxyOnLocal
attribute. The default value is False.

• UseDefaultWebProxy [True|False]—Sets the UseDefaultWebProxy
attribute. The default value is False.

• REMOVE—Removes the current proxy settings.

• DISPLAY—Displays the current proxy settings.

Exit codes:

• 0—Success.

• 1—Command line argument is missing.

• 2—Invalid command on command line.

• 3—An exception occurred during processing.

Note:

If exit code 3 appears, contact Oracle Support.
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7
Performance reports

In this chapter:

• About performance reports

• Generating performance reports

• Performace report descriptions

About performance reports
The Oracle Central Coding software installation includes an executable file that gathers
coding data, and a Microsoft Excel spreadsheet template that uses the data to create reports
for analysis and troubleshooting assistance. You can produce data for a specified set of
studies, for the entire system, or a combination of both options, according to the parameters
you set when running the utility.

To produce the performance reports, you must have server-level access. If you do not have
access to the Oracle Central Coding server for your studies, please contact Oracle for
assistance.

Generating performance reports
To generate performance reports:

1. Run a script to gather study or system data, which is compiled into a CSV file.

For more information, see Gathering data for performance reports.

2. Create histograms from the data in a Microsoft Excel spreadsheet.

For more information, see Generating performance reports in Microsoft Excel.

• Gathering data for performance reports

• Generating performance reports in Microsoft Excel

Gathering data for performance reports
1. Open a Command Prompt window and enter the name of the drive in which the

executable file is installed.

2. Enter the location of the executable file in the drive you specified:

<Installation
Folder>\CentralCodingServer\CodingWebUI\Utilities\UsageCharts

3. Run PhaseForward.CentralCoding.CreateUsageCharts.exe, using the following syntax:

PhaseForward.CentralCoding.CreateUsageCharts.exe [dbUser] [UsageType]
[csvFileDirectory] [TrialList]
In the command syntax:
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• dbUser—Oracle Central Coding Database user ID.

• UsageType—The type of data to compile and display in Microsoft Excel.

– DAILYUSAGE—Produce reports for data from one or more specified
studies.

– SYSTEMSUMMARY—Produce reports for data from the entire system.

– BOTH—Produce separate reports for individual studies, and reports for
the system as a whole.

• csvFileDirectory—The directory in which you want to store the CSV data file.

• TrialList—For DAILYUSAGE or BOTH usage type, the list of studies for which
to produce the reports.

– For one study, specify the study name.

– For more than one study, list the study names in quotation marks,
separated by commas (for example, "PFST50, PFSTCardio").

4. When prompted for a password, enter the Oracle Central Coding Database user
password.

The utility produces a CSV file that you open in Microsoft Excel.

Generating performance reports in Microsoft Excel
1. Navigate to the Oracle Central Coding installation folder.

2. Open the UsageCharts.xlsm file.

A Microsoft Excel spreadsheet opens.

3. Click the Data tab.

4. In the Get External Data section of the ribbon, click From Text.

The Import Text File dialog box appears.

5. Navigate to the directory you specified for the csvFileDirectory parameter.

6. Click Import.

The Text Import Wizard - Step 1 of 3 dialog box appears.

7. Click Next.

8. Select the Tab and Comma delimiters, and click Next.

9. Click Finish.

The Import Data dialog box appears.

10. Select Existing worksheet and specify that you want to put the data in cell A1.

11. Click OK.

The worksheet is populated with the data from the CSV file.

12. Click the Process Usage Data button.

Note:

You may need to scroll to the right in order to see the button.
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It may take several minutes to process the data.

Performace report descriptions
The following table describes daily usage reports:

Tab Name Report Name Description

<StudyName> Daily Tally of <StudyName>'s
Verbatim Traffic

For the specified study, the
number of verbatims that were
received, delivered, undelivered,
or deleted each day, from the
beginning of the study.

<StudyName> Total Number of Verbatims in
<StudyName> Measured Daily

For the specified study, the total
number of verbatims that existed
and the total number of
verbatims that were delivered
each day, from the beginning of
the study.

The following table describes System summary reports:

Tab Name Report Name Description

Days of Activity Days of Activity For each study in the system, the
number of days during which
preprocessing occurred,
verbatims were received, and
verbatims were returned to the
source application.

Trial Running Days Trial Running Days The duration of each study in the
system, in days.

Verbatim and Transaction Counts Verbatim and Transaction Counts For each study in the system, the
number of verbatims that exist,
the number of deletions that
occurred, the number of times a
verbatim was received by the
Oracle Central Coding
application, and the largest
number of times a single
verbatim was received by the
Oracle Central Coding
application.

Percentage of Activity Percentage of Activity During
Trial Up-Time

For each study in the system, the
percentage of time taken for
preprocessing, receiving
verbatims, and returning
verbatims to the source
application.

Each percentage is calculated
based on a 20-hour day, allowing
for 4 hours of system inactivity.
The number of hours per day is a
configurable setting in Microsoft
Excel.

Chapter 7
Performace report descriptions

7-3



Tab Name Report Name Description

Verbatim Throughput Number of Verbatims Processed
per Hour over a Day

The maximum and the average
number of verbatims processed
in one hour. This data is
calculated based on a 20-hour
day and normalized to one hour.

This data is displayed in two
graphs. The first graph is
organized by system, and the
second graph displays the data
for each study in the system.

Percentage Autocoded Percentage of Verbatims
Autocoded

For each study in the system, the
percentage of verbatims that
were autocoded.

Active Trials Active Trials shown with Median
Verbatims Received per Day

The number of studies in the
system on any given day, and the
corresponding median number of
verbatims received on that day.

Verbatim Trial Size Size of Trial by # of Verbatims The number of verbatims in each
study, and the percent of total
verbatims in the system to which
it corresponds.

Histograms Preprocess Media/Active Day The median number of verbatims
that were preprocessed in a day,
and the number of studies that
fall into each category.

-- Preprocess Average/All Days The average number of
verbatims that were
preprocessed in a day, and the
number of studies that fall into
each category.

-- Return Media/Active Day The median number of verbatims
that were returned to the source
application in a day, and the
number of studies that fall into
each category.

-- Return Average/All Days The average number of
verbatims that were returned to
the source application in a day,
and the number of studies that
fall into each category.

-- Receive Media/Active Day The median number of verbatims
that were received in the Oracle
Central Coding application in a
day, and the number of studies
that fall into each category.

-- Receie Average/All Days The average number of
verbatims that were received in
the Oracle Central Coding
application in a day, and the
number of studies that fall into
each category.
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Tab Name Report Name Description

-- Verbatim Trial Size The number of verbatims in the
system, and the number of
studies that fall into each
category.
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8
Troubleshooting

In this chapter:

• Analyzing tables and indexes for performance

• Installation failure due to error accessing product user profile

• Changing the execution timeout value

• Changing the transaction timeout value

• Changing the number of matched terms that display in the coding browser

• About running statistics on the Oracle Central Coding application

• Cross-product issues

Analyzing tables and indexes for performance
Oracle recommends analyzing all tables and indexes for better performance. You should
perform this analysis whenever a significant amount of coding data is entered. To help
analyze tables and indexes, Oracle recommends that you run the following Oracle database
utilities:

• dbms_utility.analyze_schema—Run this utility as the Oracle Central Coding application
schema owner.
This utility updates the Oracle system tables that are used to perform analysis on a
schema.

• dbms_utility.analyze_schema—Run this utility to update the Oracle system tables for
the Oracle Central Coding database.

Installation failure due to error accessing product user profile
If an error occurs during installation indicating that the PRODUCT_USER_PROFILE table
cannot be accessed, run PUPBLD.SQL as SYSTEM and then start the installation again.

Changing the execution timeout value
The execution timeout value determines the number of seconds the Oracle Central Coding
application waits to receive information from the Oracle InForm application. The Oracle
Central Coding installation program sets the default value to 900 seconds.

If you consistently receive the Request timed out error message, you can change the value
for executionTimeout in the web.config file. The file is available in <Installation
Folder>\CentralCodingServer\CodingWebUI. The following shows a sample
web.config file.

<httpRuntime executionTimeout="900" maxRequestLength="4096" 
useFullyQualifiedRedirectUrl="false"
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minFreeThreads="8" minLocalRequestFreeThreads="4" 
appRequestQueueLimit="100" enableVersionHeader="true" /> <!-- 
compilation Attributes:
tempDirectory="directory"

Changing the transaction timeout value
If an error occurs when you are importing a large synonym file or when running the
Code and Propagate action, increase the transaction timeout value for the Microsoft
Distributed Transaction Coordinator (MS DTC).

1. Select Start > Apps > Component Services.

2. Expand Component Services.

3. Expand Computers.

4. Right-click My Computer and select Properties.

5. Click the Options tab.

6. Set the Transaction timeout (seconds) to 300 or more, and click Apply.

7. Click OK.

Changing the number of matched terms that display in the
coding browser

In the Coding Browser dialog box—Search mode, the Return All Matches checkbox
indicates whether you want all the matched terms found to display in the browser. By
default, the coding browser displays 200 matches. This number, and whether this
option is available, is set by your administrator.

The CodingPlatform.config file, located in <Installation
Folder>\CentralCodingServer\CodingWebUI\bin\config, contains the
following section (these are the default values the Central Coding application ships
with):

<CodingBrowserSettings>
 <QuickRowLimit>200</QuickRowLimit>
 <AllowReturnAllMatches>true</AllowReturnAllMatches>
 <HardRowLimit>500</HardRowLimit>
</CodingBrowserSettings>

In the file:

• QuickRowLimit—The number of matched terms to display in the browser.
The browser displays only the number of terms specified in this setting. It does not
allow you to page through the terms in lists.

• AllowReturnAllMatches—Determines whether the Return All Matches option
appears in the browser.
If you change this setting to false, the Return All Matches checkbox does not
appear in the coding browser, and the number of terms specified in the
HardRowLimit display in the browser.
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• HardRowLimit—The number of matched terms to display in the browser when the
Return All Matches option does not appear in the browser or if the option is not
selected.
If the QuickRowLimit is set to -1, or the Return All Matches checkbox is selected, the
HardRowLimit determines the maximum number of matches that can be returned.

If HardRowLimit is set to -1, all matches will be returned if the QuickRowLimit is -1 or the
Return All Matches checkbox is selected. Oracle does not recommend setting the
HardRowLimit to -1, as there could be thousands of possible returns.

About running statistics on the Oracle Central Coding
application

Oracle recommends that a database administrator run statistics on a Oracle Central Coding
application if:

• The performance of the Oracle Central Coding application is slow.

• A timeout exception error occurs when running a large get verbatims job.
If the job runs for a long time and a timeout exception error occurs, the
ExceptionMap.xml file contains an entry that instructs you to ask a database
administrator to gather statistics on the Oracle Central Coding account.

Oracle recommends that the database administrator monitor the statistics for the account
during the day and gather statistics if the statistics start to be out of date and the
performance of the application slows down.

Cross-product issues
In this section:

• Extra audit records in the Oracle Central Coding application

• Code map not found—Undeliverable requests

• Key items not updated

Extra audit records in the Oracle Central Coding application
• Issue—Additional audit records in the Oracle Central Coding application.

• Possible cause—If you change a verbatim in the InForm application that has already
been coded, and then change it back to what it was originally, the next time the InForm
Adapter Coding interface delivers coding data to the Oracle Central Coding application,
you will see additional audit records in the Audit History Report in the Oracle Central
Coding application. This is because although the verbatim is unchanged, it is newer than
its targets.

• Solution—If you use Oracle InForm Adapter software with the Oracle Central Coding,
you must:

– Create a rule in the Oracle InForm software that is applied to every verbatim that
clears the varbatime targets whenever the verbatim is changed.

– Make sure the rule is case-sensitive.
The rule ensures that the verbatim is treated as uncoded when it is delivered to the
Oracle Central Coding application.
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Code map not found—Undeliverable requests
• Issue—Codes are not returned to the Oracle InForm application and the Code

map not found error appears in the Oracle Central Coding application for
undeliverable requets when:

– The mappings for the Oracle Central Coding application have been updated in
the Oracle InForm application.

– Data that is in the Oracle Central Coding application was not delivered prior to
the mapping change.

• Possible cause—When the Oracle Central Coding mappings are updated in the
InForm application using the same RefName, the Oracle InForm application does
not create a new revision for the mappings. Instead, the InForm application
creates an entirely new set of mappings with new GUIDs.
As a result, when a verbatim is recoded in the Oracle Central Coding application
after the updated mappings are installed in the InForm application, the request is
undeliverable from the Oracle Central Coding application.

The Code map not found error appears when you view the hover help for a

request with a delivery status of Undeliverable (  ) on the Coding Requests,
Approvals, or All Requests page in the Oracle Central Coding application.

For more information, see the User Guide.

• Solution—Contact Oracle CAG.

Note:

This issue does not affect Oracle InForm release 6.1.1 and higher.

Key items not updated
If the following key items are changed in the Oracle InForm application after a
verbatim is coded, they will not be updated in the Oracle Central Coding application.

Note:

The key items are updated in the Oracle Central Coding if the verbatim is not
coded in the Oracle InForm application.

• Subject Initials

• Subject Number

• Visit

• Site Name

• Site

• Study
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If you want the key items to be updated, you must create a rule in the Oracle InForm to clear
the coding targets.
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