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About This Content

Audience

This guide is intended for anyone who is involved in installing or setting up Oracle Life
Sciences Central Designer, such as IT administrators, system integrators, and technical
support staff. It provides step-by-step instructions, prerequisites, and troubleshooting tips to
ensure a smooth and successful installation of Oracle Central Designer in your environment.

Documentation Accessibility

For information about Oracle's commitment to accessibility, visit the Oracle Accessibility
Program website at http://www.oracle.com/pls/topic/lookup?ctx=acc&id=docacc.

Access to Oracle Support

Oracle customers that have purchased support have access to electronic support through My
Oracle Support. For information, visit http://www.oracle.com/pls/topic/lookup?ctx=acc&id=info
or visit http://www.oracle.com/pls/topic/lookup?ctx=acc&id=trs if you are hearing impaired.

Conventions

The following text conventions are used in this document.

Convention Meaning

boldface Boldface type indicates graphical user interface elements associated with an
action, or terms defined in text or the glossary.

italic Italic type indicates book titles, emphasis, or placeholder variables for which
you supply particular values.

nonospace Monospace type indicates commands within a paragraph, URLs, code in
examples, text that appears on the screen, or text that you enter.
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Architectural overview of the environment

In this chapter:

* Introduction to the Oracle Central Designer software

»  Physical architecture

*  Web farm capabilities

Introduction to the Oracle Central Designer software

The Oracle Central Designer software consists of:

* Oracle Central Designer server application—Communicates with the client applications
through web services.

* Oracle Central Designer client application—Provides a collaborative environment for
designing clinical studies and deploying them to the Oracle InForm application.

* Oracle Central Designer Administrator client application—Provides an environment for
setting up administrative information, such as users, roles, and system configuration
information.

Physical architecture

The physical configuration of the Oracle Central Designer software includes:

e A database server machine.

*  One or more application server machines. For more information, see Web farm
capabilities.

*  One or more client machines.

There are three configuration options for the Oracle Central Designer software.

Configuration Description

Single-tier The application server, database server, and client
applications run on the same machine.

Two-tier The application server and database server run on
the same machine, and the client applications run
on another machine.

Three-tier The database server, application server, and client
applications each run on a separate machine.
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Web farm capabilities

® Note
*  For optimum performance, Oracle recommends a three-tier configuration.

» If the application server and database server are on the same machine, you must
install the Oracle Server software and Oracle Client software in the same home.
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Web farm capabilities

You can expand the performance capabilities of the Oracle Central Designer application server
by adding multiple servers in a farm configuration. This configuration is called a web farm. A
web farm setup distributes requests from the client applications among multiple application
servers. A web farm is useful for the following reasons:

e Alarge number of requests that might impact performance can be spread out among
multiple application servers, thus improving performance.

e Multiple application servers allow for redundancy and failover protection.

In a web farm configuration, all application servers can process any request. However, certain
operations are run asynchronously using the Oracle Central Designer Job Scheduler. The Job
Scheduler is installed on every application server, but only one Job Scheduler can process
jobs, and only one service is enabled to process requests. The Job Scheduler service that
processes all requests is called the primary Job Scheduler. You can change the primary Job
Scheduler at any time. Oracle recommends setting the Job Scheduler on the most powerful
machine in the web farm as the primary.

@® Note

You must use the same port number, which you specify during installation, for all
application servers within a web farm. If one of the application servers uses a different
port number, the Job Scheduler will not work if the machine is set to run the primary
Job Scheduler. By default, the port number is 53000.

For more information, see:
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Web farm capabilities

Illustration of a web farm configuration

Information that is stored in the database

About adding application servers

Managing web farm capabilities

lllustration of a web farm configuration

The following tasks are performed in a web farm configuration:

Client applicdion

The client applications send requests through a firewall to a load balancer. The load
balancer distributes requests among application servers.

The job scheduler services on all of the application servers run; however, only the primary
job scheduler processes requests. The other job scheduler services do not accept any
requests. Examples of tasks that require the job scheduler service include importing and
validation.

All tasks that do not require the job scheduler service are distributed among the application
servers.
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Information that is stored in the database

Units information and report definitions are stored in the database and are used by all
application servers in a web farm.

You can export the units information to a file and then modify and import the file. You
perform this task in the Oracle Central Designer Administrator application.

If you have created custom reports, you must back up the Report configuration section of
the Desi gner WebSer vi ces. confi g file before upgrading and then import it into the
database.

For more information about working with this information, see the Administrator Guide.
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About adding application servers

You can add additional application servers to a web farm environment at any time, even if you
did not configure your first application server to support a web farm.

When you install a second application server, the installation recognizes the existing
application server installation. The Job Scheduler service on the existing application server is
set as the primary by default, but you can set the Job Scheduler for the second (or higher)
application server as the primary during the installation of its application server.

You install additional application servers the same way that you install the first application
server. The installation process configures the application server computers as a web farm. For
more information, see Installing the Central Designer application server.

Managing web farm capabilities

After a web farm is installed, you can manage it using the Oracle Central Designer
Administrator software. You perform the following tasks in the Oracle Central Designer
Administrator software:

* Viewing the servers that are in the web farm.

»  Determining and changing the primary job scheduler.

*  Working with Event Log messages for the web farm, including:
— Viewing the messages.
— Changing the default limit for the number of entries in the log.
— Deleting all entries in the log.

*  Modifying the file for report definitions.

e Modifying units information.

For more information, see the Administrator Guide.
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Checklists for software installation

In this chapter:

Checklist—Planning the server installation

Checklist—Planning the client installations

Checklist—Planning the server installation

Use the following checklist to help plan the Oracle Central Designer application server and
database server installations.

Installation Guide
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1.

Determine if the setup is single-tier or multi-tier.
For more information, see Physical architecture.

Make sure all system requirements, including .NET Framework requirements, have been
met for the application server.

For more information, see:

« Application Server requirements in the Oracle Central Designer System requirements
guide.

«  Verifying that all required IIS roles are installed.
«  Verifying that the correct version of Microsoft .NET Framework is installed.

Make sure all system requirements, including required Oracle database parameters, have
been met for the database server.

For more information, see:

« Database Server requirements in the Oracle Central Designer System requirements
guide.

» Install the Oracle database software on the database server.
Register the .NET assemblies to the Global Assembly Cache (GAC).
For more information, see:

e Registering .NET assemblies.

« Database patch Release Notes.

On the database server, create the database and tablespaces.

The database and tablespaces must be created prior to installing the Oracle Central
Designer software. For more information, see Create the database and tablespaces.

On the database server, configure the Open Cursors setting.

For more information, see Configuring the Open Cursors setting for a database instance.
On the database server, configure the Cursor Sharing setting.

For more information, see Configuring the Cursor Sharing setting for a database instance.

On the database server, grant the appropriate rights to database administrators.
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Copyright © 2023, 2025, Oracle and/or its affiliates. Page 1 of 4



ORACLE

10.

11.

12.

13.

14.

15.

16.

17.

18.

19.
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Checklist—Planning the server installation

For more information, see Required rights for database administrators.

On the database server, create the Oracle Central Designer database user.

For more information, see Creating the Oracle Central Designer database user.

Configure the application server for optimal performance.

For more information, see Configuring the application server for optimal performance.

On the database server, configure the listener to accept connections for the new database.

For more information, see Configuring the listener to accept connections for the new
database.

Determine the security level to be used for communication between the client applications
and the application server.

For more information, see Securing communication with Transport Layer Security (TLS).
Determine if you will implement a web farm.

For more information, see Web farm capabilities.

Increase the default value of the MS DTC timeout on the application server.

For more information, see Increasing the Microsoft Distributed Transaction Coordinator
timeout.

Monitor the tablespace in the database.
If the tablespace becomes full, expand the tablespace by adding another data file.

Make sure that the 1IS Admin Service and World Wide Web Publishing Services are
running.

If the services are not running, the installation fails. The IS Admin Service does not have
to run for the duration of the installation. However, you must start it before you click the
Next button on the Copying Files screen.

@® Note

Do not use the iisreset command from the MMC or a command prompt after the
installation or upgrade completes, or the IIS settings that were set by the installer
are lost. Instead, use the net start command to start the services.

Install a certificate for signing web service authorizations, and a certificate for signing
deployment packages and Oracle InForm web service authorizations.

For more information, see Installing certificates for signing web service authorizations and
deployment packages.

If necessary, install the root certificate and intermediate certificate or certificates, and install
the main certificate as the root certificate.

For more information, see:
* Installing root and intermediate certificates.
* Installing the main certificate as the root certificate.

To secure the web server and prevent clickjacking on the http://<server name>/
CentralDesignerinstall page, from which you install the Oracle Central Designer and
Oracle Central Designer Administrator applications, configure the HTTP response header
in IIS.

For more information, see Configuring the IIS HTTP response header setting.
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20.

21.

22.

23.

24,

Chapter 2
Checklist—Planning the client installations

If you perform automated deployments to Oracle InForm studies hosted by Oracle, make
sure the Microsoft Windows setting Automatic Root Certificates Update is turned on.

Automatic Root Certificates Update is turned on by default in Microsoft Windows 2019. For
more information, see the Microsoft website (http:/technet.microsoft.com).

Install the application server.

For more information, see:

* Installing the Oracle Central Designer application server.
» Performing a silent installation.

Configure SMTP settings for sending email notifications related to automated deployment
events.

For more information, see Configuring SMTP settings for automated deployment email
notifications.

Grant the Special permissions permission to the Machinekeys folder
(C:\ProgramData\Microsoft\Crypto\RSA\Machinekeys folder).

Right-click on the Machinekeys folder and select Properties. On the Security tab click
Edit, select Allow for Special permissions, and click OK.

Verify the installation of the application server.

For more information, see Verifying the installation of the application server.

Checklist—Planning the client installations

Use the following checklist to help plan the installations of the client applications.

The Oracle Central Designer and Oracle Central Designer Administrator applications are
ClickOnce applications. You start a ClickOnce application by clicking a link from a Microsoft
Edge window.

When you click a link for either application, the Oracle Central Designer server checks whether
the release that is installed on the server matches the files that are cached on your computer:

Installation Guide
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If the server has been newly installed or has been upgraded after your last logon, the files
that are necessary to run the application are cached on your computer, and then are used
to open the application.

If the server has not been updated since your last logon, the cached files on your computer
are used to open the application.

Make sure all system requirements, including .NET Framework requirements, have been
met for the client computers.

For more information, see:

* Oracle Central Designer System requirements guide.

*  Verifying that the correct version of Microsoft .NET Framework is installed.

For clients using Microsoft Edge browser version 79 or later, enable ClickOnce support.

For more information, see Enabling ClickOnce support for Microsoft Edge version 79 or
later.

Make sure the clocks on the application server computer, database server computer, and
client computers are synchronized.

For more information, see Synchronizing clocks on server and client computers.
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4. Start the client applications.
For more information, see:
»  Starting the Oracle Central Designer client application.

e Starting the Central Designer Administrator client application.
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Planning your installation

In this chapter:

» |nstalling certificates for signing web service authorizations and deployment packages

«  About installing root and intermediate certificates

»  Verifying that all required IIS roles are installed

»  Verifying that the correct version of Microsoft .NET Framework is installed

«  Enabling ClickOnce support for Microsoft Edge version 79 or later

*  Synchronizing clocks on server and client computers

e Hardware networking switches

e Configuring the application server for optimal performance

 Enabling TLS 1.2 for .NET Framework on Central Designer application servers

Installing certificates for signing web service authorizations and
deployment packages

@® Note

When creating a private key for the Oracle Central Designer certificate, allow for all
key usage purposes, such as digital signature, key encipherment, and data
encipherment. If you do not do this, the Job Scheduler issues a Bad key error when it
starts, and the same error appears in Oracle Central Designer when accessing
objects.

You must install a certificate for each of the following purposes:
e Signing the web service authorizations.

e Signing deployment packages and Oracle InForm web service authorizations on the
Oracle Central Designer server.

Oracle recommends using certificates issued by trusted commercial Certificate Authorities.

Install certificates to the LOCAL_MACHINE\MY store. Each certificate in the certification path
must be 2048 bytes. For more information about converting existing certificates, see the
Microsoft support website.

For each certificate:

1. Open a command prompt window.

Installation Guide
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Chapter 3
About installing root and intermediate certificates

Run the following command:

certutil -f -inportpfx -csp "Mcrosoft Enhanced RSA and AES Cryptographic
Provider" <full path to the pfx file> NoExport

Enter the password for the PFX file, and press Enter.

The Oracle Central Designer installation process grants Full Control to access the certificate
private keys to the IS AppPool\DefaultAppPool user and the NETWORK SERVICE user.

If a user other than the IS AppPool\DefaultAppPool user is running the DefaultAppPool
application pool, you must grant the user Full Control to access the private keys, or the user is
unable to sign using the certificates. This content is used in the STEP Certificate for web
service authorizations topic.

To grant a user other than IIS AppPool\DefaultAppPool Full Control to the private keys,
for each certificate:

1.

Ea

© ® N o O

11.
12.
13.

14.

Select Start, enter mt, and press Enter.
The Microsoft Management console appears.

Select File > Add/IRemove Snap-in.
The Add or Remove Snap-ins dialog box appears.

In the list of available snap-ins, select Certificates.

Click Add.
The Add dialog box appears.

Click Computer account.
Click Next.

Click Local Computer.
Click Finish.

Click OK.

. In the left pane of the console, select Certificates (Local Computer) > Personal >

Certificates.
Right-click the certificate and select All Tasks > Manage Private Keys.
Click Add > Locations, and then select the computer name.

Click Advanced > Find Now, select the user, and grant them Full Control.

If the user does not appear in the search results, type the user name in the Select Users
or Groups dialog box.

Click OK.

About installing root and intermediate certificates

You might need to install additional certificates for the following situations:

Installation Guide
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When the main certificate you installed contains an intermediate certificate, a root
certificate, or both in its certification path.

When the PFX file you imported contains an intermediate certificate, a root certificate, or
both embedded within it. In this case, the certificates might not have been installed in the
correct locations.
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About installing root and intermediate certificates

For more information, see:

Determining whether to install additional certificates

Installing root and intermediate certificates

Installing the main certificate as the root certificate

Determining whether to install additional certificates

To check whether you need to install the additional certificates, double-click the main certificate
and select the Certification Path tab. If you see:

Three or more certificates—Install the root certificate and one or more intermediate
certificates.
For more information, see Installing root and intermediate certificates.

Two certificates—Install the root certificate.
For more information, see Installing root and intermediate certificates.

One certificate—Install the main certificate from the PFX as the root certificate.
For more information, see Installing the main certificate as the root certificate.

Installing root and intermediate certificates

Perform this procedure for both the root certificate and one or more intermediate certificates.

1.

© © N 9o O

11.
12.

13.

14.

Installation Guide
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Open the Microsoft Management console:

a. Open a Command Prompt window.

b. Enter mt, and then press Enter.

Select File > Add/Remove Snap-in.

The Add or Remove Snap-ins dialog box appears.
From the list of available snap-ins, select Certificates.
Click Add.

The Add dialog box appears.

Click Computer account.

Click Next.

Click Local Computer.

Click Finish.

Click OK.

. In the left pane of the console, select Certificates (Local Computer).

Click the Personal folder.

Double-click the main certificate you previously imported and select the Certification Path
tab.

Do one of the following:
» To install the root certificate, double-click the root certificate.

« To install the intermediate certificate, double-click the intermediate certificate and
select the Details tab.

Click Copy to File and do the following:
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a. Deselect Do not export the private key.
b. Select the default file type.
c. Select DER encoded binary.
d. Navigate to the location in which to save the certificate.
e. Click OK.
15. In the left pane of the console, select one of the following:

» If you are installing an intermediate certificate, select Intermediate Certification
Authorities.

* If you are installing the root certificate, select Trusted root Certification Authorities.
16. Right-click the Certificates folder and select All Tasks > Import.

The Certificate Import Wizard appears.
17. Click Next.

18. Select the CER file for the certificate you are installing, either the intermediate or root
certificate.

19. Click Next to accept the default options for the remaining wizard pages.

Installing the main certificate as the root certificate

1. Open the Microsoft Management console:
a. Open a Command Prompt window.
b. Enter mt, and then press Enter.
2. Select File > Add/Remove Snap-in.
The Add or Remove Snap-ins dialog box appears.
3. From the list of available snap-ins, select Certificates.
4. Click Add.
The Add dialog box appears.

5. Click Computer account.
6. Click Next.

7. Click Local Computer.

8. Click Finish.

9. Click OK.

10. In the left pane of the console, select Certificates (Local Computer).
11. Click the Personal folder.

12. Double-click the main certificate you previously imported and select the Certification Path
tab.

13. To install the main certificate as the root certificate, double-click the main certificate.
14. Click Copy to File and do the following:

a. Deselect Do not export the private key.

b. Select the default file type.

c. Select DER encoded binary.
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d. Navigate to the location in which to save the certificate.
e. Click OK.
15. In the left pane of the console, select Trusted root Certification Authorities.
16. Right-click the Certificates folder and select All Tasks > Import.
The Certificate Import Wizard appears.
17. Click Next.
18. Select the CER file for the root certificate.

19. Click Next to accept the default options for the remaining wizard pages.

Verifying that all required IIS roles are installed

1. Select Start > Apps > Server Manager > IIS.

2. Under Roles and Features, make sure the following Web Server (lIS) roles required by
Oracle Central Designer are installed:

Web Server

*  Web Serve\Common HTTP Features

*  Web Server\Common HTTP Features\Default Document

*  Web Server\Common HTTP Features\Directory Browsing

*  Web Serve\Common HTTP Features\HTTP Errors

*  Web Server\Common HTTP Features\Static Content

e Web Server\Application Development

*  Web Servern\Application Development\.NET Extensibility 4.7 or higher
*  Web Server\Application Development\Application Initialization
*  Web Server\Application Development\ASP

*  Web ServenApplication Development\ASP.NET 4.7 or higher
*  Web Server\Application Development\CGI

*  Web Server\Application Development\ISAPI Extensions

*  Web Server\Application Development\ISAPI Filters

*  Web Serven\Application Development\Server Side Includes

*  Web Server\Health and Diagnostics

*  Web Server\Health and Diagnostics\HTTP Logging

*  Web Server\Security

*  Web ServenSecurity\Request Filtering

*  Web Server\Performance

*  Web Server\Performance\Static Content Compression
Management Tools

* Management Tools\IIS Management Console

e Management Tools\IIS Management Service

*  Management Tools\IIS Scripts and Tools
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* Management Tools\IIS 6 Management Compatibility

* Management Tools\IIS 6 Management Compatibility\lIS 6 Metabase Compatibility
e Management Tools\IIS 6 Management Compatibility\lIS 6 WMI Compatibility

* Management Tools\IIS 6 Management Compatibility\liS 6 Scripting Tools

* Management Tools\IIS 6 Management Compatibility\liS 6 Management Console

Verifying that the correct version of Microsoft NET Framework is
installed

For information about the required versions of Microsoft .NET Framework, see the Oracle
Central Designer system requirements guide. If a required version of .NET Framework is not
installed, install it.

@® Note

If you have a version of .NET Framework prior to the required version for this release,
you do not need to uninstall it before installing the required version.

* Tofind .NET Framework versions by viewing the registry:
1. Select Start, enter regedit.exe, and press Enter.

2. Inthe Registry Editor, go to HKEY_LOCAL_MACHI NE\ SOFTWARE\ M cr osof t \ NET
Framewor k Set up\ NDP.
The installed versions are listed under the NDP subkey.

If NET Framework is installed, the folder contains folders whose names begin with v,
followed by the .NET Framework version number. For example:

— v4.0—indicates that .NET Framework 4.0 is installed.

e Tofind .NET Framework versions by using Windows Explorer, paste the following text into
the Windows Explorer address bar: %syst enr oot %4 M cr osof t . NET\ Fr anewor k64.
If .NET Framework is installed, the folder contains folders listing the installed versions.

Enabling ClickOnce support for Microsoft Edge version 79 or
later

1. In Microsoft Edge, go to edge://flags/#edge-click-once, and select Enable from the drop-
down list.

2. Restart your browser.

Synchronizing clocks on server and client computers

The clocks on the client computers, application server computer, and database server
computer are not required to be in the same time zone, but they must be no more than 24
hours apart relative to the Coordinated Universal Time (UTC). Oracle recommends that the
clocks be no more than 10 minutes apart.
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Hardware networking switches

Some hardware networking switches change the incoming URL before passing the request to
the Oracle Central Designer server. For example, if the address entered during a client
installation is https:/labc.com, a switch might change the URL in the following ways:

e A switch that performs hardware SSL/TLS processing might change the URL to http:/I
abc.com.

e A switch that performs load balancing might change the URL to http://PhysicalServerl.

When the application server is installed in an environment that includes a hardware networking
switch, the URL that you enter for the Web server URL root field must match the URL that the
networking switch uses to address the application server. From the previous examples, the
required URLs must be:

* In the first example, http:/labc.com.

* Inthe second example, http://PhysicalServerl.

@® Note

The application server must be able to use the address that you enter for the Web
server URL root field to address itself.

Configuring the application server for optimal performance

Oracle recommends performing the following modifications on the Oracle Central Designer
application server to optimize performance.

*  Configure the worker process recycling settings for Windows

»  Configure the worker process health settings for Windows

e Increase the default Microsoft Distributed Transaction Coordinator timeout

Configure the worker process recycling settings for Windows

1. Select Start > Internet Information Services (IIS) Manager.
2. Expand the tree for the local computer and select Application Pools.
3. Right-click DefaultAppPool and select Recycling.
4. Configure the following settings:
*  Verify that only Regular time intervals (in minutes) is selected.

e Verify that a value of 1740 is entered for that setting.

Configure the worker process health settings for Windows
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1. Select Start > Internet Information Services (IIS) Manager.
2. Expand the tree for the local computer and select Application Pools.

3. Right-click DefaultAppPool and select Advanced Settings.
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4. Under Process Model, set Shutdown time limit (seconds) to match the timeout for the
client application (the default is 1200 seconds).

Increase the default Microsoft Distributed Transaction Coordinator timeout

Oracle recommends that you increase the Microsoft Distributed Transaction Coordinator (MS
DTC) timeout because the default Windows timeout setting of 60 seconds might be insufficient
for some Oracle Central Designer processes.

1. Select Start > Component Services.

Open Component Services > Computers.

Right-click My Computer, and select Properties.

Select the Options tab.

Change the value of the Transaction timeout (seconds) field to 3600 (the default is 60).
Click OK.

Select Start > Services.

® N o g & w DN

Stop and restart all IS services.

Enabling TLS 1.2 for .NET Framework on Central Designer
application servers

If TLS 1.2 is enabled on any Oracle InForm where automated deployments are performed, you
must update the Windows registry to enable TLS 1.2 for .NET Framework on the Oracle
Central Designer application servers.

1. On all Oracle Central Designer application servers, open a command prompt as an
Administrator and run the command reg add
" HKEY_LOCAL_MACH NE\ SOFTWARE\ M cr osof t\ . NETFr amewor k\ v4. 0. 30319" /v
SchUseStrongCrypto /t REG DWORD /d 00000001

2. Restart the Oracle Central Designer application server.
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Preparing the database server

Before installing the Oracle Central Designer software, you must:

* Install and configure the Oracle database software on the database server.
e Create the necessary database instance and tablespaces.

In this chapter:

« Install the Oracle database software on the database server

* Regqistering .NET assemblies

* Create the database and tablespaces

«  Configuring the listener to accept connections for the new database

*  Configuring the Open Cursors setting for a database instance

*  Configuring the Cursor Sharing setting for a database instance

* Use the performance tuning capabilities that are available with the Oracle database
software

¢ Required rights for database administrators

e Creating the Oracle Central Designer database user

Install the Oracle database software on the database server

After the database server requirements are met, you can install the Oracle database software.
Use the Oracle database software installation documentation as needed. For more information
about required Oracle database software versions, see the Oracle Central Designer system
requirements guide.

@ Note

If the application server and database server are on the same computer, you must
install the Oracle Server software and Oracle Client software in the same home, or the
Oracle Central Designer server installation will not work.

For more information, see:

* Mandatory configuration
Most of the default Oracle settings can be used for the Oracle Central Designer database.
However, the following Oracle configuration must be used.

Mandatory configuration

Most of the default Oracle settings can be used for the Oracle Central Designer database.
However, the following Oracle configuration must be used.
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Page

Option

Value

Database Components

Oracle Text, a standard database
component.

Selected.

Tip: The Oracle database
software installation requires that
you install Oracle Data Mining if
you install Oracle Text. If you do
not want to install Oracle Data
Mining, you can install Oracle
Text manually after completing
the Oracle database installation.

Oracle Java Virtual Machine
(IVM)

Selected.

Character Sets

Database Character Set

AL32UTFS8 - Unicode 4.0 UTF
universal character set, UTF-8
compliant.

National Character Set

AL16UTF16 - Unicode UTF-16
universal character set.

Parameters

CURSOR_SHARING parameter

FORCE

OPEN_CURSORS parameter

500

Additional configuration information

In production databases at Oracle, the DB_BLOCK_SIZE Oracle parameter is set to 16k

(16384 bytes).

Registering .NET assemblies

You must register the .NET assemblies to the Global Assembly Cache (GAC) after the initial
installation, and each time you apply a patch.

¢ Oracle.DataAccess.dll

* Policy files that redirect older Oracle.DataAccess.dll versions to the one installed
To add the assemblies to the GAC:

1. Open acommand prompt as an Administrator.

2. Navigate to the directory that contains the assembly to add to the GAC (<or acl e

hone>\ CDP. NET\ bi n\ 4).

3. Execute the following commands:

oraprovcfg. exe /action:gac /providerpath: Oracl e. Dat aAccess. dl |

OraProvCfg. exe /action:config

/force /product:odp /

framewor kver si on; v4. 0. 30319 / provi der pat h: O acl e. Dat aAccess. dl |

4. Navigate to the directory that contains the policy files to add to the GAC (<or acl e
horme>\ ODP. NET\ Publ i sher Pol i cy\ 4).
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5. Execute the following commands:

OraProvCfg. exe /action: gac /providerpath: Policy.4.112. Oracl e. Dat aAccess. dl |
OraProvCfg. exe /action: gac /providerpath: Policy.4.121. Oracl e. Dat aAccess. dl |

OraProvCfg. exe /action: gac /providerpath: Policy.4.122. Oracl e. Dat aAccess. dl |

Create the database and tablespaces

After you install the Oracle database software, create the database instance and tablespaces.
Make sure the Oracle server has sufficient space to accommodate the new tablespaces. The
Oracle Central Designer software uses the following tablespaces by default.

Tablespace Description Minimum size

DESIGNER Main data tablespace 100 MB.
A 16k (16384 bytes) block size is
required.

Note: Depending on usage, you
might need to increase the MB

size.

SYSTEM Main data tablespace 500 MB.

SYSAUX Main data tablespace 250 MB.

TEMP Temporary tablespace Always present in the Oracle
database.

UNDOTBS1 Main data tablespace 200 MB.

@® Note

The tablespace names provided are the default names. Any names can be used for
the tablespaces.

@® Note

If you use non-default names, you must specify them during the installation of the
application server (by clicking Advanced on the Database Parameters page), so be
sure you take note of them.

Configuring the listener to accept connections for the new
database

After installing the Oracle database software, you must configure the listener to accept
connections for the new database. For more information, see the Oracle database software
documentation.
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Configuring the Open Cursors setting for a database instance

When you create a database instance, you must set Open Cursors to 500 by running the
following SQL command:

ALTER SYSTEM SET open_cursors=500 SCOPE=BOTH;

Before you upgrade, ensure that the Qpen Cur sor s parameter is correctly set.

Configuring the Cursor Sharing setting for a database instance

When you create a database instance, you must set the Cursor Sharing setting properly to
FORCE by running the following SQL command:

ALTER SYSTEM SET cursor _shari ng=FORCE SCOPE=BOTH;

Before you upgrade, ensure that the Cursor Sharing parameter is correctly set.

Use the performance tuning capabilities that are available with
the Oracle database software

Open the Automatic Database Diagnostic Monitor (ADDM) from the Database Control home
page or from Advisor Central.
This tool helps you diagnose problems, identify their causes, and make recommendations.

About acting on ADDM recommendations:

* Make configuration changes to the database or operating system as necessary.

e The SQL Tuning Advisor might recommend rewriting some SQL statements. However, the
SQL statements cannot be rewritten.

* Add database indexes as needed.

/\ Caution

Take note of all new indexes. Before upgrading, you must drop them to ensure
that they do not cause conflicts with new indexes that have been added to the
product. After the upgrade is finished, you can add the indexes back.

@ Note

Contact Oracle Global Support to forward SQL statement recommendations or
request index changes in the product.

The most common configuration recommendations from ADDM are:

- SGA_TARGET
-  PGA_AGGREGATE_TARGET
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e DB _FILE_MULTIBLOCK_READ_COUNT
— Reset to zero instead of using an explicit value.
— Oracle automatically manages this parameter value if it is set to zero.

For more information, see the Oracle database software documentation.

Required rights for database administrators

The database administrator must create the Oracle Central Designer database user before you
install the Oracle Central Designer application. During the Oracle Central Designer installation,
you are prompted to enter the user name and password for the Oracle Central Designer
database user. For more information, see Creating the Central Designer database user.

The database administrator can be any user that has the rights to perform the following tasks:

Task SQL Automatically executed for
Create the Database User. All supported Oracle database
CREATE USER &1 software versions.

| DENTI FI ED BY &2
DEFAULT TABLESPACE &3;
GRANT CONNECT TO &1;
GRANT RESOURCE TO &1,
GRANT CREATE VI EW TO &1;

Allow the Database User to All supported Oracle database
create function indexes. GRANT QUERY REWRI TE TO software versions.
&1;
GRANT CREATE SYNONYM TO
&1;
® Note

The database administrator user does not have the rights to grant the database user
execute privileges on required packages. For information on how to assign the
database administrator the necessary rights, see Granting the database administrator
the EXECUTE privilege on required packages.

For more information, see:
«  Granting the database administrator the EXECUTE privilege on required packages

e Sample SQL
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Granting the database administrator the EXECUTE privilege on required

packages

The database administrator user does not have rights to grant the database user execute
privileges on certain required packages. To grant the database administrator the necessary
rights, run the following SQL commands as a database superuser:

GRANT EXECUTE on SYS.DBM5 JOB to <Database Administrator user name> WTH
GRANT OPTI ON;
GRANT EXECUTE on SYS.DBM5 LOB to <Database Administrator user name> WTH
GRANT OPTI ON;
GRANT EXECUTE on SYS. DBM5_SQL to <Database Administrator user name> WTH
GRANT OPTI ON;
GRANT EXECUTE on SYS. UTL_FI LE to <Database Administrator user name> WTH
GRANT OPTI ON;

Sample SQL

The following SQL commands are not run by the installation but show an example of what a
database administrator needs to do to create the tablespaces. Database administrators must
set up the tablespaces before installing the Oracle Central Designer software.

CREATE TABLESPACE desi gner

LOGA NG

DATAFI LE ' D:\ Or acl e\ or adat a\ dev1\ DESI GNER. ora' S| ZE 400M
AUTOEXTEND ON NEXT 1M

ALTER SYSTEM SET db_16k_cache_si ze = 80M

EXTENT MANAGEMENT LOCAL SEGMVENT SPACE MANAGEMENT AUTO,

Creating the Oracle Central Designer database user

1.
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On the database server computer, extract the Cr eat eCent r al Desi gner Schenma folder
from the product ZIP file.

® Note

You must use the ZIP file for the product version being installed, or the Oracle
Central Designer database user will not be given the appropriate grants.

From the Cr eat eCent r al Desi gner Schena folder, run the following command:

sql pl us <Dat abase Adnmini strator user nane>/ <Database Admi nistrator
passwor d>@xDat abase> @t ask.sql <Central Designer database user nane>
<Central Designer database user password> <Central Designer tablespace>

In the previous command:

« Database Administrator user name / password—Credentials of the database
administrator used to create the Oracle Central Designer database user.

« Database—Alias from the TNSnames.ora file.
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e Central Designer database user name / password—Credentials of the Oracle Central
Designer database user account you are creating.

» Central Designer tablespace—Default value: DESIGNER.

When you run the Oracle Central Designer installation, you must enter the database
parameters set up during this procedure.
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Installing and uninstalling the software

In this chapter:

e Before you begin

»  Qverview of installation and configuration

» Installing the Oracle Central Designer application server

» Uninstalling the application server

e Configuring SMTP settings for automated deployment email notifications

»  Starting the Central Designer client application

e  Starting the Oracle Central Designer Administrator client application

Before you begin

The latest information about the Oracle Central Designer application is on the Oracle Support
self-service website, My Oracle Support. Before you install and use the Oracle Central
Designer application, check My Oracle Support for the latest information, including Release
Notes and Known Issues, alerts, white papers, bulletins, and patches.

For the latest Oracle Central Designer software, check the Oracle Software Delivery Cloud
(https://edelivery.oracle.com).

Overview of installation and configuration

Before you start your installation, plan your work:
»  Checklist—Planning the server installation.

»  Checklist—Planning the client installations.
For more information, see:

e Overview of installing the application and database servers

e Overview of uninstalling

Overview of installing the application and database servers

1. Install the Central Designer application server.
For more information, see Preparing the database server and Installing the Central
Designer application server.

2. Verify the installations.
For more information, see Verifying the installation of the application server.

Overview of uninstalling

1. Uninstall the application server.
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For more information, see Uninstalling the application server.

® Note

The client applications are ClickOnce applications and are therefore not installed on
users' computers. Therefore, you cannot uninstall the client applications.

Installing the Oracle Central Designer application server

1.

8.
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Locate the setup.exe program.

The setup.exe program is available the Oracle Software Delivery Cloud (https://
edelivery.oracle.com).

Double-click setup.exe.

The InstallShield Wizard prepares to install the application server.
A welcome page appears.

Click Next.

The Customer Information page appears.

Provide the following information:

* User Name—Your name.

e« Company Name—The name of your company.

e Company URL—A unique identifier for your company data, typically your company
URL (for example, http://www.mycompany.com).

e Select whether to install the application for anyone who uses the computer, or only for
your User.

Click Next.
The Setup Type page appears.

Select New Database.

@® Note

If you are installing the second or higher server in a web farm, select Update.

In the Destination Folder area, specify the destination location for the installation. By
default, the installation wizard installs the software in the <PROGRAMFI LESDI R>\ Or acl e
Heal t h Sci ences\ Central Designer\ folder. PROGRAMFILESDIR is a system
setting that is usually C: \ Program Fi | es (x86) . If you want to install to another
location, click Browse, and select the location.

® Note

The instructions, paths, and Start Menu navigation in this guide assume you are
installing to the default location. Oracle strongly recommends that you install the
software to the default location.

Click Next.
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The Database Parameters page appears.

9. Enter the database connection information. The database user must be created before you
run the installer. For more information, see Creating the Central Designer database user.

Field

Description

Database User Name

The user name for the Oracle database user.

Database Password

The password for the database user.

@ Note

The password must not contain any of
the following characters: @ & () [ or ].

Oracle TNS Name Alias from the TNSnames.ora file. This TNS
name is used to connect to the database
instance.

Create New Database Select this option if you want to create a new
database.

/\ Caution

If you have an existing database
schema and you select Create New
Database, all existing information in
your current database schema will be
deleted.

@ Note

Do not use Oracle reserved words for user names or passwords.

10. If a new database was created and tablespaces were created with non-default names, you
must specify the names of the tablespaces. The tablespaces that you specify must already
exist. The installation does not create tablespaces.

a. Click Advanced.
The Advanced Database Settings page appears.
b. Fill in the fields with the correct information, according to the following table.

c. Click OK to return to the Database Parameters page.

Field Description

Default Tablespace for new user The first tablespace for the tables of the

schema owner.
This tablespace must have a block size of 16k.

Large (16k) Tablespace for new user Not used. Enter the same value as for the
default tablespace.

Installation Guide
G46880-01 November 4, 2025

Copyright © 2023, 2025, Oracle and/or its affiliates. Page 3 of 9



ORACLE

11.

12.

13.

14.

15.

16.

Installation Guide
G46880-01

Chapter 5
Installing the Oracle Central Designer application server

Field Description

Temp Tablespace for new user The temporary tablespace for the tables of the
schema owner.

Click Next.
The Job Service page appears.

Enter the TCP/IP port number that the job service will use. The port must be unused. In
most cases, you can use the default value.

@® Note

If you are installing the server as part of a web farm, all of the servers can use the
same port number, as long as the port is unused.

Optionally, to configure the Oracle Central Designer software to support a web farm, select
Make this server part of a web farm. A web farm setup allows you to install the Oracle
Central Designer server software on multiple application server computers. The installation
is the same for all of the servers, and you must select this option for all servers in the web
farm. For more information, see Web farm capabilities.

After you select the check box, the installation checks the database to see if a primary Job
Scheduler has been specified. Additional options appear, depending on whether you are
installing the first or second (or higher) server.

« If this installation is the first server in the web farm, the primary Job Scheduler has not
been set yet. The installation automatically sets the Job Scheduler service on the
server computer as the primary Job Scheduler. If you install additional application
servers, you can change the primary Job Scheduler during the installations.

« If this installation is the second or higher server in the web farm, the primary Job
Scheduler service has already been set, and the name of the computer that runs the
primary Job Scheduler appears. To change the primary Job Scheduler, select Make
this server's Job Scheduler the primary.

Specify a password for the Job Service user.

@® Note

Make sure that the user password meets the requirements listed on the page.

Click Next.
The System User Password page appears.

Specify a password for the system user.

@® Note

Make sure that the user password meets the requirements listed on the page.

The Oracle Central Designer application installs the system user by default. You can
configure the lockout time for the system user separately from all other users. By default,
this user is assigned the superuser and DesignerAdministrator roles.
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@® Note

The password that you specify for the system user is also used for the
archiveimporter user. For more information about this user, see the Oracle Central
Designer Administrator Guide.

Click Next.
The Network Parameters page appears.

In the Web server URL root field, enter the server address to which requests will come
(for example, http://ABCServer or https://ABCServer). If you enabled Transport Layer
Security (TLS), use https.

@® Note

When the application server is installed in an environment that includes a
hardware networking switch, the URL that you enter for the Web server URL root
field must match the URL that the networking switch uses to address the
application server. For more information, see Hardware networking switches.

As you enter a value in the Web server URL root field, the Public server URL root field is

automatically updated with the same value. If you edit the value in the Public server URL

root field, the field is no longer updated automatically when the Web server URL root field
is updated.

Optionally, you can secure (encrypt and prevent tampering of) communications by using
Transport Layer Security (TLS). For more information, see Securing communication with
Transport Layer Security (TLS).

Optionally, if the application server computer is behind a proxy that rewrites the request
URLs, in the Public server URL root field, enter the address that the client computer uses
to access the application server (the public address of the server computer as seen by the
client computer). This address will be added as the address of the server computer during
installation of the client applications.

If the value for the Public server URL root field does not need to be different from the
Web server URL root field, make sure that the values in both fields match.

21. Specify the certificate to use to sign web service authorizations:

a. Click Choose Certificate.

The Choose Certificate dialog box appears.
b. Select a certificate.
c. Click OK.

The Issued to, Issuer, Expiration, and Friendly name fields are populated.

@® Note

On each Oracle Central Designer application server, an administrator must install
the certificate that is used for signing web service authorizations to the
LOCAL_MACHINE\MY store. The Oracle Central Designer installation process
grants Full Control to access the certificate private keys to the IIS
AppPool\DefaultAppPool user and the NETWORK SERVICE user.
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@® Note

If a user other than the IS AppPool\DefaultAppPool user is running the
DefaultAppPool application pool, you must grant the user Full Control to access
the private keys, or the user is unable to sign using the certificates. For more
information, see Installing certificates for signing web service authorizations and
deployment packages.

If the Oracle Central Designer application server is outside the network of the Oracle
InForm application server. Specify the proxy URL or script used by the Oracle Central
Designer application server to communicate with the Oracle InForm server during
automated deployment:

« Inthe Proxy URL field, enter the web address for the proxy server.

« Inthe Proxy Script field, enter the web address for the proxy configuration script.
Click Next.

The Client Installation Configuration page appears.

In the Environment Name field, enter the name for your Oracle Central Designer instance.

The environment name appears on the web page to which you navigate to start the Oracle
Central Designer application.

Click Next.
The InForm Deployment page appears.

Specify the certificate to use to sign deployment packages and Oracle InForm web service
authorizations:

a. Click Choose Certificate.

The Choose Certificate dialog box appears.
b. Select a certificate.
c. Click OK.

The Issued to, Issuer, Expiration, and Friendly name fields are populated.

@® Note

For studies hosted by Oracle, the certificate must be issued by a trusted
commercial Certificate Authority.

Click Next.
The Start Copying Files page appears.

Review the installation settings. To change any settings, click Back. If you are satisfied
with the settings, click Next.

The installation begins. The Setup Status page appears, showing the status of the
installation. When the installation is complete, the InstallShield Wizard Complete page
appears.

Click Finish.
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@® Note

If the 1IS worker process is running under any user other than NETWORK
SERVICE or 1IS AppPool\DefaultAppPool, you must grant the user read
permission to the
HKEY_LOCAL_MACHINE\SOFTWARE\OracleHS\CentralDesigner registry key
after the installation.

For more information, see:

Performing a silent installation

Verifying the installation of the application server

Performing a silent installation

To create a setup.iss response file that contains all the installation parameters:

1.

In a command prompt window, enter the path of the Oracle Central Designer setup.exe
program followed by /r to run the installation in record mode.

The InstallShield Wizard appears.
Follow the wizard steps.

When you reach the Start Copying Files page, the setup.iss file is created in the Windows
directory (by default C: \ W ndows).

To perform a silent installation:

1.

Copy the setup.iss file to the same directory as the Oracle Central Designer setup.exe
program.

In a command prompt window, enter the path of the setup.exe program followed by /s.
The silent installation is performed.

Verifying the installation of the application server

1.
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Verify that the job service is installed and running:

a. Open the Control Panel.

b. Open Administrative Tools > Services.

c. Verify that the Oracle Central Designer Job Scheduler service exists and is running.

Verify that the Web site has been added to the Internet Information Services (1IS) Manager
directory:

a. Open the Control Panel.
b. Open Administrative Tools > Computer Management.

c. Open Services and Applications > Internet Information Services (lIS) Manager >
Web Sites > Default Web Site. Verify that CentralDesigner is listed in the virtual
directories.

Review the installer.log file. This log contains messages that were generated during
installation. It is available in the following location: \ Program Fi | es (x86)\ Oracl e
Heal t h Sci ences\ Central Designer.
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Uninstalling the application server

1
2
3.
4

Select Start > Services.

Stop the job scheduler and 1IS services.

Select Start > Control Panel > Programs and Features.
Select Central Designer Server, and click Change/Remove.
A confirmation dialog box appears.

Click Yes.

The Setup Status page appears, informing you of the status of the uninstall.
The Uninstall Complete page appears.

Click Finish.

Delete the Oracle Central Designer directory.

Configuring SMTP settings for automated deployment emall

notifications

The Oracle Central Designer application can send email notifications for the following
automated deployment events:

Deployment request is created, approved, or rejected.
Deployment is started.

Deployment is completed successfully or with failures.
Deployment request is cancelled.

Deployment is cancelled.

To set up Oracle Central Designer to send email notifications:

1.
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Install the SMTP server feature in Microsoft Windows. For more information, see the
Microsoft documentation for your operating system.

Verify that you can send email from the SMTP server.

After you install the Oracle Central Designer application server, configure the Oracle
Central Designer web site to send email.

a. Select Start > Administrative Tools > Internet Information Services (lIS) Manager.
b. Expand <machine_name> > Sites > Default Web Site.
c. Select CentralDesigner.
d. Inthe Features View, double-click SMTP E-mail.
The SMTP E-mail page appears.

e. Enter a dummy address as the email address from which messages are sent (for
example, designer@mycompany.com).

f. Select Deliver e-mail to SMTP server.
g. Select Use localhost.

h. Select the same authentication settings that are configured for the SMTP server.
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i. Click Apply.

® Note

Every time you install the Oracle Central Designer application, you must reconfigure
the SMTP email settings for the Oracle Central Designer web site.

Starting the Central Designer client application

The client applications are ClickOnce applications, and you do not need to install them to start
them, as you would for applications using a traditional Windows installer.

1. Using Microsoft Edge, navigate to the following address:

http://<server name>/CentralDesignerinstall, where <server name> is the name of the
application server computer.

2. Click the Start Central Designer Client link.

The application files are downloaded to a cache and the application is installed. The
installation might take some time.
After the installation is complete, the application opens, and you can log on.

Starting the Oracle Central Designer Administrator client
application

The client applications are ClickOnce applications, and you do not need to install them to start
them, as you would for applications using a traditional Windows installer.
1. Using Microsoft Edge, navigate to the following address:

http://<server name>/CentralDesignerinstall, where <server name> is the name of the
application server computer.

2. Click the Start Central Designer Administrator link.

The application files are downloaded to a cache and the application is installed. The
installation might take some time.
After the installation is complete, the application opens, and you can log on.
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Upgrading the software to this release

In this chapter:

e About upgrading the application server

e Checklist—Planning a migration

« Removing the IIS HTTP response header

» |nstalling the application server

» Upgrading the client applications

e Updating certificates without reinstalling the Oracle Central Designer software

About upgrading the application server

You perform an in-place upgrade from Oracle Central Designer 7.0.1to 7.0.1.1

Time considerations

Because the migration updates every study in the database, migrating from an earlier release
could take some time, so plan the upgrade carefully. For example, Oracle expects that
migrating a database with 150 studies could take 10 - 15 hours or longer.

Checklist—Planning a migration

1. Export the Oracle Central Designer database user.

/\ Caution

You must perform this step. If the upgrade is not successful, you might need to
restore the database to attempt to install again.

Depending on the size of the database, this process could take several hours.

@ Note

Use the following command to export a user:
expdp designer/designer@dbl_devl directory=data_pump_dir
schemas=DESIGNER dumpfile=file_to_export.dmp

In this example, the user has the following information:
* User nhame—designer

» Database—dbl_devl:
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@® Note

When you execute this command, you are prompted for the user password.

If you are upgrading to an Oracle 19c database, create a new database instance with a
16k block size for the DESIGNER tablespace.

For more information, see Create the database and tablespaces.

If you are migrating to a new database, import the database user into the destination
database server.

Use the following command to import a database user into the destination database
server:

impdp designer/designer@dbl_devl DIRECTORY=data pump_dir
DUMPFILE=file_to_export.dmp SCHEMAS=DESIGNER

In this example, the user has the following information:
e User name—designer
- Database—dbl devl

@® Note

When you execute this command, you are prompted for the user password.

Import the Oracle Central Designer database. If you are migrating to the Oracle 19c
database from 11g, re-map the tablespaces.

Use the following command to import a database user into the destination database
server:

impdp designer/designer@dbl_devl DIRECTORY=data pump_dir
DUMPFILE=file_to_export.dmp SCHEMAS=DESIGNER
REMAP_TABLESPACE=DESIGNER_BIGINDEX:DESIGNER

In this example, the user has the following information:
e User name—designer
- Database—dbl devl

@® Note

When you execute this command, you are prompted for the user password.

Make sure that the Cursor Sharing setting for the database instance is set properly.

For more information, see Configuring the Cursor Sharing setting for a database instance.
Unlock statistics for specific tables.

Unlock statistics for the following tables:

« IC_OBJECT

« IC_OBJECT_REVISIONS

« IC_OBJECT BACK_REFERENCES

e IC_OBJECT_FORWARD_REFERENCES
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* IC_BLUEPRINT_OBJECT_MAP

The upgrade process drops non-primary key indexes on the tables affected by the upgrade
and recreates the indexes at the end of the process. If the index was originally defined with
the COMPUTE STATISTICS clause, the recreation also attempts to COMPUTE
STATISTICS. If statistics are locked, this process fails.

Make sure that the database UNDO_MANAGEMENT initialization parameter is set to
AUTO and the UNDO and TEMP tablespaces are set to autoextend.

These settings are necessary for a successful upgrade.

If you added any new indexes to the database, you must drop them before upgrading the
application server to ensure that they do not cause conflicts with new indexes that have
been added to the product.

After the upgrade is finished, you can add the indexes back.
Update data mappings with the PhysicalMappingType property set to All.
For more information, see Updating data mappings with PhysicalMappingType set to All.

(Recommended) Run the Det ect St udi esW t hUni t sWt hSpaces. sql script to determine if
any studies contain unit names with spaces.

A validation check produces an error if a unit name contains a space. For more
information, see Running the DetectStudiesWithUnitsWithSpaces.sql script.

Run the application server installation to install the application server.
For more information, see Installing the application server.

If you dropped indexes from your database before upgrading, add them back in after you
finish upgrading.

Recompile user-defined functions and sign and secure user-defined function assemblies
as needed.

For more information, see Upgrading user-defined functions.

If the web service authorization and deployment authorization certificates have expired,
upgrade them.

@® Note

If the certificates are current, you can skip this step.

For more information, see Updating certificates without reinstalling the Oracle Central
Designer software.

Inform users that they can resume using the client applications.

For more informtion, see Starting the Oracle Central Designer client application and
Starting the Oracle Central Designer Administrator client application.

For more information, see:

Installation Guide
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Running the DetectStudiesWithUnitsWithSpaces.sgl script

Updating data mappings with PhysicalMappingType set to All

Upgrading user-defined functions
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Running the DetectStudiesWithUnitsWithSpaces.sgl script

A SQL script called DetectStudiesWithUnitsWithSpaces.sql generates a report that identifies
the unit names with spaces and the study projects that contain unit names with spaces. Oracle
recommends that you run this script because a validation check produces an error if a unit
name contains a space.

Run the script before upgrading the application server. If the script finds units with spaces and
study projects that use the units, perform the following steps:

1. In any affected study, run validation to determine the items that refer to the units with
spaces in their names.

2. Modify the units file to remove the spaces from the unit names that appear in the output
file.

3. Using Control Panel > Administrative Tools > Services, restart the Job Scheduler
service (Oracle Central Designer Job Scheduler).

4. Restart the client applications.
5. In any affected study, modify the items to use the unit names that do not contain spaces.

The script and a readme file (DetectStudiesWithUnitsWithSpaces.Readme) are available on
the product ZIP file in the InstallSupport directory.

Updating data mappings with PhysicalMappingType set to Al

If a study contains a data mapping for which PhysicalMappingType is set to All and you use the
data mapping for both CDD and CIS, you must use the existing data mapping for one purpose
only and create a new data mapping for the other purpose.

Because creating a new database for CDD is simpler, Oracle recommends using the existing
data mapping for CIS and creating a new CDD data mapping and, if necessary, a new CDD
database.

To modify the existing data mapping and create a new data mapping:

1. To determine whether your database contains any data mappings for which
PhysicalMappingType is set to All, before you upgrade, run the
DetectStudiesWithPhysicalMappingAll.sql script, which is available in the InstallSupport
directory on the product ZIP file.

2. For each data mapping for which PhycialMappingType is set to All, change the
PhysicalMappingType property of the data mapping from All to CIS.

The CIS data mapping continues to work as expected, and you are able to perform
resynchronizations with the CIS database.

3. Create a new CDD data mapping.
4. Copy the data sets in the CIS data mapping and paste them into the CDD data mapping.
The RefNames of the data sets and their data series are appended with _1.

5. If you deployed the study to the Oracle InForm application in an earlier release, remove the
_1 appended text from the aliases of the data sets and data series in the CDD data

mapping.

Installation Guide
G46880-01 November 4, 2025
Copyright © 2023, 2025, Oracle and/or its affiliates. Page 4 of 12



ORACLE Chapter 6
Checklist—Planning a migration

/\ Caution

Do not update the RefNames, or you will not be able to perform a CIS resynch
after you deploy again to the Oracle InForm application.

6. Deploy the study to the Oracle InForm application.
7. Set up the new CDD database.

@® Note

After you create a new data mapping for either CDD or CIS, you cannot perform a
resynchronization with either the CDD or CIS database. You must create a new
database for the new data mapping type.

Upgrading user-defined functions

If a study contains a user-defined function that performs a task such as reading from or writing
to a file, accessing the database or the registry, making web service calls, running an external

application, sending an email, or using the event log directly, the assembly for the user-defined
function must be signed with a strong named signature that is valid and trusted in order for the
function to work in the Oracle InForm application.

To ensure that the user-defined functions and assemblies in your study projects and library
projects are secure, Oracle recommends that you sign user-defined function assemblies using
a strong named, valid and trusted signature.

@® Note

For Oracle InForm studies hosted by Oracle, all user-defined function assemblies that
require signing must be signed by Oracle Services prior to deployment.

In addition, user-defined functions that use the Log4Net application must use the Oracle
Central Designer Log4Net wrapper or must be recompiled to use Log4Net version 2.0.8. For
more information about the Log4Net wrapper, see the Rules Reference Guide.

For more information, see:

» Identifying user-defined functions and assemblies to update

»  Securing and signing user-defined function assemblies

Identifying user-defined functions and assemblies to update

To identify study and library projects that contain user-defined functions that need to be
recompiled or assemblies that need to be secured and signed, run the
ValidateCustomFunctionAssemblies.exe file after you upgrade the application server.
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@® Note

User-defined functions that refer to an unsupported Log4Net version must be
recompiled or reconfigured to use the Oracle Central Designer Log4Net wrapper. For
more information about the Log4Net wrapper, see the Rules Reference Guide.

Locate the ValidateCustomFunctionAssemblies.exe file in the product ZIP file, in the
InstallSupport directory.

Copy the file and paste it to the bin folder in the directory in which you installed the Oracle
Central Designer application.

In a command prompt window, enter one of the following:

* To view assemblies that reference the wrong Log4Net version, enter
Val i dat eCust onfuncti onAssenbl i es L.

e To view assemblies with missing, invalid or untrusted signatures, enter
Val i dat eCust onfuncti onAssenbl i es S.

*  To view assemblies with invalid references to ExternalFunctions.dll, enter
Val i dat eCust onfFunct i onAssenblies |.

« To view all of the above, enter Val i dat eCust onfFuncti onAssenbl i es.
When prompted, specify the following:
e System username—system.

e System password—Password that you specified on the Designer System User
Password page during the Oracle Central Designer application installation.

- Path for the output file, including file name—Location in which to save the output
file that lists the study and library projects with user-defined functions that must be
updated. For example, C: \ Qut put\ Val i dat eAssenbl i es. t xt.

A list of user-defined functions is generated.

Securing and signing user-defined function assemblies

To secure and sign assemblies for user-defined functions, create a key pair, extract the public
key, and place the key file on the following servers:

Oracle Central Designer application server. If you are using the Oracle Central Designer
application in a web farm environment, place the key on all the application servers in the
web farm.

All Oracle InForm application servers where studies using the assembly will be deployed.

@ Note

For Oracle InForm studies hosted by Oracle, all user-defined function assemblies that
require signing must be signed by Oracle Services prior to deployment.

For specific instructions and information about creating and signing an assembly with a strong
named signature, see the Rules Reference Guide and the documentation for the tool that you
use to create the strong name.

Installation Guide
G46880-01

November 4, 2025

Copyright © 2023, 2025, Oracle and/or its affiliates. Page 6 of 12



ORACLE Chapter 6
Removing the IS HTTP response header

Removing the IIS HTTP response header

In Oracle Central Designer 7.0 or earlier, the HTTP response header had to be manually
added to IIS. However, this header is automatically added in the web.config for this release of
Oracle Central Designer. As such, when upgrading from 7.0 or earlier to this release, the
previous HTTP response header needs to be removed from IIS:

1. Open the Internet Information Services (IIS) Manager.

2. Inthe Connections section on the left, expand the Sites folder.
3. Select Default Web Site.
4

In the Default Web Site Home pane, in the IIS section, double-click HTTP Response
Headers.

o

Select X-Frame-Options.
6. Click Remove.
A confirmation window appears.

7. Click Yes to confirm.

Installing the application server

1. Export the Oracle Central Designer database user.

/\ Caution

You must perform this step. If the upgrade is not successful, you might need to
restore the database to attempt to install again.

To export a user with the following information:
e User name—designer

- Database—dbl devl

Use the following command:

expdp desi gner/ desi gner @bl _devl directory=data punmp_dir schenmas=DESI GNER
dumpfile=file_to_export.dmp

@® Note

When you execute this command, you are prompted for the user password.

2. Locate the setup.exe program.

The setup.exe program is available the Oracle Software Delivery Cloud (https://
edelivery.oracle.com).

3. Double-click setup.exe.
The InstallShield Wizard prepares to install the application server.
4. Click Yes.
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A welcome page appears.
Click Next.
The Customer Information page appears.

Fill in the fields. You should provide the same values that were entered during the initial
installation of the application server.

* User Name—Your name.
¢ Company Name—The name of your company.

e Company URL—A unique identifier for your company data, typically your company
URL (for example, http://www.mycompany.com).

® Note

You must enter the company URL that you specified during the original Oracle
Central Designer installation.

Click Next.
The Setup Type page appears.
Select Update.

In the Destination Folder area, specify the destination location for the installation. By
default, the installation wizard installs the software in the

<PROGRAMFI LESDI R>\ Or acl e\ Cent ral Desi gner\ folder. <PROGRAMFILESDIR>
is a system setting that is usually C:\Program Files (x86). If you want to install to another
location, click Browse, and select the location. You must choose the location to which the
application server was initially installed.

@® Note

The instructions, paths, and Start Menu navigation in this guide assume you are
installing to the default location. Oracle strongly recommends that you install the
software to the default location.

Click Next.

The Database Parameters page appears. Because you are upgrading, the Create New
Database checkbox is grayed out.

Fill in the following fields. You must provide the values that you created when you set the
Oracle TNS name (typically set when you create the database) and the database user
name and password (set when you created the Oracle Central Designer user in the new
database).
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Field Database
Database User Name The user name for the Oracle database user.
@® Note

The password must not contain any of
the following characters: @ & () [or ].

Database Password The password for the Central Designer database
user.
Oracle TNS Name Alias from TNSnames.ora file. This TNS name is

used to connect to the Oracle Central Designer
database instance.

@® Note

Do not use Oracle reserved words for user names or passwords.

Click Next.
The Oracle Central Designer Job Service page appears.

Enter the TCP/IP port number that the job service will use. The port must be unused. In
most cases, you can use the default value.

® Note

If you are installing the server as part of a web farm, all of the servers can use the
same port number, as long as the port is unused.

Optionally, to configure the Oracle Central Designer software to support a web farm, select
Make this server part of a web farm. A web farm setup allows you to install the Oracle
Central Designer server software on multiple application server computers. The installation
is the same for all of the servers, and you must select this option for all servers in the web
farm. For more information, see Web farm capabilities.

After you select the checkbox, the installation checks the database to see if a primary Job
Scheduler has been specified. Additional options appear, depending on whether you are
installing the first or second (or higher) server.

« If this installation is the first server in the web farm, the primary Job Scheduler has not
been set yet. The installation automatically sets the Job Scheduler service on the
server computer as the primary Job Scheduler. If you install additional application
servers, you can change the primary Job Scheduler during the installations.

« If this installation is the second or higher server in the web farm, the primary Job
Scheduler service has already been set, and the name of the computer that runs the
primary Job Scheduler appears. To change the primary Job Scheduler, select Make
this server's Job Scheduler the primary.

Specify a password for the Job Service user.
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@® Note

Make sure that the user password meets the requirements listed on the page.

Click Next.
The Network Parameters page appears.

In the Web server URL root field, enter the address of the server on its local network (the
server address to which requests will come, for example, http://ABCServer or https:/
ABCServer). If you enabled Transport Layer Security (TLS), use https. Unless you made
changes that would cause the server address to have changed, use the address that you
entered for the last installation.

@® Note

When the application server is installed in an environment that includes a
hardware networking switch, the URL that you enter for the Web server URL root
field must match the URL that the networking switch uses to address the
application server.

As you enter a value in the Web server URL root field, the Public server URL root field is

automatically updated with the same value. If you edit the value in the Public server URL

root field, the field is no longer updated automatically when the Web server URL root field
is updated.

Optionally, you can secure (encrypt and prevent tampering of) communications by using
Transport Layer Security (TLS). For more information, see Securing communication with
Transport Layer Security (TLS).

Optionally, if the application server computer is behind a proxy that rewrites the request
URLs, in the Public server URL root field, enter the address that the client computer uses
to access the application server (the public address of the server computer as seen by the
client computer). This address will be added as the address of the server computer during
installation of the client applications.

If the value for the Public server URL root field does not need to be different from the
Web server URL root field, make sure that the values in both fields match.

Specify the certificate to use to sign web service authorizations:
a. Click Choose Certificate.
The Choose Certificate dialog box appears.
b. Select a certificate.
c. Click OK.

The Issued to, Issuer, Expiration, and Friendly name fields are populated.

@ Note

On each Oracle Central Designer application server, an administrator must install
the certificate that is used for signing web service authorizations to the
LOCAL_MACHINEMY store. The Oracle Central Designer installation process
grants Full Control to access the certificate private keys to the IIS
AppPool\DefaultAppPool user and the NETWORK SERVICE user.
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@® Note

If a user other than the IS AppPool\DefaultAppPool user is running the
DefaultAppPool application pool, you must grant the user Full Control to access
the private keys, or the user is unable to sign using the certificates. For more
information, see Installing certificates for signing web service authorizations and
deployment packages.

If the Oracle Central Designer application server is outside the network of the Oracle
InForm application server, specify the proxy URL or script used by the Oracle Central
Designer application server to communicate with the Oracle InForm server during
automated deployment:

« Inthe Proxy URL field, enter the web address for the proxy server.

« Inthe Proxy Script field, enter the web address for the proxy configuration script.
Click Next.

The Client Installation Configuration page appears.

In the Environment Name field, enter the name for your Oracle Central Designer instance.

The environment name appears on the web page to which you navigate to start the Oracle
Central Designer application.

Click Next.
The InForm Deployment pageappears.

Specify the certificate to use to sign deployment packages and Oracle InForm web service
authorizations:

a. Click Choose Certificate.

The Choose Certificate dialog box appears.
b. Select a certificate.
c. Click OK.

The Issued to, Issuer, Expiration, and Friendly name fields are populated.

@® Note

For studies hosted by Oracle, the certificate must be issued by a trusted
commercial Certificate Authority.

Click Next.
The Start Copying Files page appears.

Review the installation settings. To change any settings, click Back. If you are satisfied
with the settings, click Next.

The installation begins. The Setup Status page appears, showing the status of the
installation. When the installation is complete, the InstallShield Wizard Complete page
appears.

Click Finish.
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Upgrading the client applications

Because the client applications are ClickOnce applications, you do not need to upgrade them.
Simply start the applications as you always do.
For more information, see:

Starting the Central Designer client application.

Starting the Central Designer Administrator client application.

Updating certificates without reinstalling the Oracle Central
Designer software

When the web service authorization and deployment authorization certificates expire, you can
install renewed certificates without reinstalling the Oracle Central Designer software.

The procedure updates the configuration files of both the web server and the job scheduler
with the certificates you select and adds access to the private keys for the certificates to
NETWORK SERVICE and DefaultAppPool users.

1.
2.
3.

Installation Guide
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Open a command window.

Navigate to the <Desi gner I nstall Dir>\bin directory.

Enter Or acl e. Desi gner. Certi fi cat eManager . exe and press Enter.
A prompt to select the web services authorization certificate appears.
Click OK.

The Certificate Browser appears.

Select the web services certificate, and click OK.

A prompt to select the for deployment authorization certificate appears.
Click OK.

The Certificate Browser appears.

Select the deployment authorization certificate, and click OK.
Messages appear that indicate the progress of the tool.

Copy the public key of the deployment authorization certificate to a location from where it
can be installed on the Oracle InForm server. For more information, see the Oracle InForm
Installation Guide.

@® Note

If after the new certificate is installed you want to deploy packages that were
already deployed using the expired certificate, make sure the public key of the
expired certificate is not removed from the Oracle InForm server.
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Securing communication with Transport Layer
Security (TLS)

In this chapter:

e About communication security

About communication security

You can secure (encrypt and prevent tampering of) communications by using Transport Layer
Security (TLS) and, optionally, by signing authorization information issued by the application
server.

With Transport Layer Security, all web traffic between the client applications and the web
server is encrypted and tamper resistant. You configure TLS through 11S with an X.509
certificate obtained using your company certificate store or a third party application.

Oracle recommends that you enable TLS. For more information about enabling TLS, refer to
the Microsoft documentation about configuring TLS for your operating system.

@® Note

When you start the client applications, enter the address of the application server,
including the correct protocol (either HTTP or HTTPS). If you enable TLS, the address
of the application server must begin with HTTPS
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Getting started

In this chapter:

* Logging on to the Oracle Central Designer Administrator application

» Changing your password in the Oracle Central Designer Administrator application

» Logging on to the Oracle Central Designer application

e Changing your password in the Oracle Central Designer application

e Logging off
*  OQOverview of configuring the Oracle Central Designer software

* Creating a sample deployment package using the sample study

Logging on to the Oracle Central Designer Administrator
application

An administrator must log on to the Oracle Central Designer Administrator application and
create user accounts before other users can log on and use the Oracle Central Designer
application.

1. Using Microsoft Edge, navigate to the following address:

http://<server name>/CentralDesignerinstall

In the previous address, <server name> is the name of the application server computer.
2. Click the Start Central Designer Administrator link.

A dialog box appears, indicating that the application is starting. The logon window appears.
3. Enter the following information:

¢ User name—system.

e Password—Password you set during the server installation.

4. If the web browser connects to the network through a proxy server that requires
authentication, click Proxy Settings to enter the user name, the password, and the
domain used to authenticate the connection to the proxy server.

5. Click Log On.
The application opens.
Oracle recommends:

« Changing the password of the system account after you log on to the Oracle Central
Designer Administrator application.
For more information, see Changing your password in the Oracle Central Designer
Administrator application.

« Deactivating or terminating the system user after you create and activate users.
For more information, see the Oracle Central Designer Administrator Guide.
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Changing your password in the Oracle Central Designer
Administrator application

1.

In the Users view, right-click a user name, and do one of the following:
e Select Change Password.

*  Press Ctrl+P.

A dialog box appears.

Enter the new password twice for confirmation, and click OK.

Logging on to the Oracle Central Designer application

You can log on after an administrator creates a user account for you.

1.

Using Microsoft Edge, navigate to the following address:

http://<server name>/CentralDesignerinstall

In the previous address, <server name> is the name of the application server computer.
Click the Start Central Designer Client link.

A dialog box appears, indicating that the application is starting. The logon window appears.
Enter your user name and password.

If the web browser connects to the network through a proxy server that requires
authentication, click Proxy Settings to enter the user name, the password, and the
domain used to authenticate the connection to the proxy server.

Click Log On.

@® Note

When a user account is created in the Oracle Central Designer Administrator
application, the administrator can require the user to change the password after
logging on the first time. You might be prompted to change your password.

Changing your password in the Oracle Central Designer

application

If the administrator who created your user account requires that you change your password,
you are prompted when you start the application to change your password.
To change your password because it is required:

1.

2.
3.

Log on to the Oracle Central Designer application.

The Change Password dialog box appears.

Enter your old and new passwords. You must enter your new password twice.
Click OK.

To change your password at any time after logging on:
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1. Select File > Change Password.
The Change Password dialog box appears.

2. Enter your old and new passwords. You must enter your new password twice for
confirmation.

3. Click OK.

Logging off

® Select File > Exit

If you have unsaved changes, you are prompted to save them.

Overview of configuring the Oracle Central Designer software

In the Oracle Central Designer Administrator application, you create and manage
administrative components such as users, roles, locales, and security settings.

Some tasks in the Oracle Central Designer application cannot be performed until the
administration information is set up correctly in the Oracle Central Designer Administrator
application.

Other types of administration, including administering studies and libraries, are performed in
the Oracle Central Designer application.

Creating a sample deployment package using the sample study

Installation Guide
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The Oracle Central Designer installation package contains a sample study and units file. You
can import the files into the Oracle Central Designer application and then deploy the sample
study to the Oracle InForm application using a manual deployment. Perform the following steps
to create a sample deployment package.

1. Import the DesignerUnit.xml file into the Oracle Central Designer Administrator application.
This file updates custom units of measurement.

For more information on exporting and importing a units file, see the Oracle Central
Designer Administrator Guide.

The DesignerUnit.xml file is located in the Oracle Central Designer installation package in
the InstallSupport\Sample Trial folder.

2. Set up locales in the Oracle Central Designer Administrator application, and include the
following locales for the sample study.

e English (United States)
e Japanese (Japan)

e Czech (Czech Republic)
e Spanish (Mexico)

For more information on adding and removing a locale, see the Oracle Central Designer
Administrator Guide.

3. Import the CSML for the sample study into a new study project.

For more information, see the Oracle Central Designer User Guide.
The CSML for the sample study is located in the Oracle Central Designer installation
package in the | nst al | Support\ Sanpl e Tri al folder.
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Creating a sample deployment package using the sample study

Add the locales from step 2 to the study.

For more information on selecting the supported locales for a study, see the Oracle Central
Designer User Guide.

Select all the dictionary types and all their verbatim types on the Coding tab.
For more information, see the Oracle Central Designer User Guide

Validate the study to create a baseline, and choose to ignore the warnings.
For more information, see the Oracle Central Designer User Guide

Create a deployment package.

For more information, see the Oracle Central Designer User Guide.

Save the deployment package to the local computer.

For more information, see the Oracle Central Designer User Guide.

Copy the deployment package and the public key to a location that is accessible to the
Oracle InForm server.

Perform additional steps in the Oracle InForm application to finish setting up the study.

For more information, see the Oracle InForm Installation Guide.
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Troubleshooting

What should I do if an error occurs during the server installation?

Errors during server installation can be caused by several issues, including issues with the
database user name and with the installation of the Oracledatabase software.

To troubleshoot:

* Read the installer.log file. The installer.log file contains information about the installation,
including any errors that occurred. The default location of the file on the application server
computeris C:\ Program Fil es (x86)\Oracle Health Sci ences\ Central
Desi gner.

* If the application server and database server are on the same computer, you must install
the Oracle Server software and Oracle Client software in the same home, or the Oracle
Central Designer server installation will not work.
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