7 Known Issues and Limitations of SAP Concur Connector

This chapter provides solutions to the commonly encountered issues associated with the Concur connector.

  • Limitation: Delay in Account Status Update During Bulk Load

    Description:

    During periods of Bulk load, when a large number of user accounts are created simultaneously, some accounts may remain in the Provisioning state in Oracle Identity Manager (OIM), even though the account is successfully created in the SAP Concur target system

    Cause:

    This issue occurs due to temporary delays in the SAP Concur API response under high load conditions

    Resolution:

    A scheduled job (UpdateAccountStatus job) has been implemented to recover such accounts.

    The job performs the following actions:
    • Fetch all the users in OIG whose account status is Provisioning
    • Verifies whether the account exists in the SAP Concur target system
    • If the account exists:
      • Updates the account status in OIG to Provisioned
      • Updates the corresponding Object ID in OIG

      This job ensures proper synchronization between OIG and SAP Concur target and prevents accounts from remaining in the Provisioning state due to temporary API delays.