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WebCenter Forms Recognition Tools 

The Tools guide provides documentation for the following tools. 

 Project Merge Tool 

 Page Designer 

 Workdoc Browser 

 Merge SLW Learn Sets 

 SLW Export Local Project Tool 

 

Project Merge Tool 

About the Project Merge Tool 

The Project Merge Tool (PMT) is designed to handle large WebCenter Forms Recognition 

projects. It allows multiple users to work independently on separate copies of a project file. 

Users can then merge project objects, such as classes, into one project. 

The tool enables to transfer the following objects from one WebCenter Forms Recognition project to another. 

 Classes, along with the associated objects, verification forms, pages, and scripts, as well as templates 

and learn sets. 

 Verification forms 

 Zones 

 Anchors 

 Pages (the collection of zones and anchors for a class) 

 Scripts, both project and class level 

Prerequisites 

 The Project Merge Tool requires that you have installed WebCenter Forms Recognition 12.2.1.3 or 

later. 

 Each project you want to access with the tool must have database authentication enabled. 

For more information, see "Allow Database authentication" in the Oracle WebCenter Forms Recognition 

Designer User's Guide. 

Specify the Database Connection String 

To specify the database connection string, complete the following steps. 

1. Open DstPmt.exe.config in a text editor. 

2. Search for the <connectionStrings> element. 

3. For an ORACLE database, modify the following values. 

 Set Data Source. 

 Set User ID to the service account user ID. 
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 Set Password to the service account password. 

<connectionStrings> 

<add name="Entities" 

connectionString="metadata=res://*/Entity.ORAEntities.csdl|res://*/Ent 

ity.ORAEntities. ssdl|res://*/Entity.ORAEntities.msl; 

provider=EFOracleProvider; Provider Connection String='Data 

Source=<OracleServerName\InstanceName>;User 

ID=<UserID>;Password=<UserPassword>'" 

providerName="System.Data.EntityClient" /> 

</connectionStrings> 

 

4. For a SQL Server database, modify the following values. 

 Set Data Source. 

 Set Initial Catalog to the SQL Server database catalog. 

 Set User ID to the SQL Server user ID. 

 Set Password to the SQL Server password. 

<connectionStrings> 

<add name="Entities" 

connectionString="metadata=res://*/Entity.Entities.csdl|res://*/Entity 

.Entities.ssdl|r es://*/Entity.Entities.msl; 

provider=System.Data.SqlClient;provider connection string=&quot;Data 

Source=<DataSource>;Initial 

Catalog=<SQLServerDatabaseCatalog>;Integrated Security=false;User 

ID=<UserId>;Password=<UserPassword>;MultipleActiveResultSets=True&quo 

t;" providerName="System.Data.EntityClient" /> 

</connectionStrings> 

5. Save and close the file. 

Load Projects 

To log on and load projects, complete the following steps. 

1. Launch DstPmt.exe. 

2. In the WebCenter Forms Recognition Project Logon dialog box, type your user name and password 
and then click OK. 

Note: The user must be available in the WebCenter Forms Recognition database and have ADM role. 

PMT does not support either project users or Windows Authentication. 

For more information, see "Export users and groups to the WebCenter Forms Recognition database" in 
the Oracle WebCenter Forms Recognition Designer User's Guide. 

 

3. In the Select projects dialog box, in the Source project field, type or browse to the source project. 

4. In the Target project field, type or browse to the target project and then click Load. 

The structure of the two projects is displayed in the Project Data Transfer window. 
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5. Optional. To load a different project, in the source or target File field, type or browse to the required 

project. 

Deactivate Automatic Backups 

The Automatic backup option is activated by default. 

When the user modifies a project, the tool writes a backup of the project file and learn set in a subdirectory of 

the project directory named as follows. 

PMT Backup [project name] [YYYY-MM-DD HH-MM-SS] [computer name] [userid] 

To deactivate automatic backups, on the File menu, click Automatic backup. 

Transfer Objects Between Projects 

You can transfer objects from the source to the target project and vice versa. 

To transfer an object from one project to the other, complete the following steps. 

1. In the Project Merge Tool window, complete one of the following substeps. 

 Select one or more classes and drag them to the Classes node in the other project pane. 

Notes: 

• Any child classes of a transferred class will be transferred as well. 

• If you drag to an existing class within the Classes node, the transferred class will 

be created as a child of this class. 

• Any templates used by the transferred class are transferred as well. However, if 

there is an existing template in use with the same name, the existing template will 

be kept and applied to the transferred class. 

• If the name of a transferred class conflicts with the name of an existing class, you 

will be given the option to either rename the transferred class or replace the 

existing one. 
 

 Select one or more objects and drag them to the respective node in the other project pane. 

Notes: 

• If you drag an object to an invalid target, no notification is displayed. 

• If the name of a transferred object conflicts with the name of an existing object, you will be 

given the option to either rename the transferred object or replace the existing one. 

• The tool does not verify if a transferred verification form is compatible with the target class. 
 

The transferred objects are displayed in bold. 

2. Click Save. 

3. Review the status bar for messages. 

4. Optional. Review the [YYYYMMDD]_DstPmt_*.log file in the C:\Program 
Files (x86)\Oracle\WebCenter Forms Recognition\bin\Log 

directory. 

5. If you transferred classes, open the modified project in Designer, relearn, and then save the 
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project. 

Display a Script 

To display a script, double-click the script object. 

The script opens in a new window for review. 

Note: You cannot save any changes to the script. To modify a script, open the project in Designer. 

Display Format Analysis Engine Settings 

To display the Format Analysis Engine settings, double-click the Format Analysis Engine object.  

The settings open in a new window for review. 

Note: You cannot save any changes. To modify the settings, open the project in Designer. 
 

Run the Tool Using Windows Command Line 

You can transfer objects between projects using Windows Command Line interface. 

Syntax 

DstPmt login [UserName]#[password] [ObjectType] [operation] 

[SourceProjectName].sdp#[ObjectName] [TargetProjectName].sdp#[ObjectName] 

Note: If no password was assigned to the user, you can leave the password parameter blank. 
 

In Windows Command Line interface, complete any of the following steps. 

 To copy a class, type the following command. 

DstPmt login [UserName]#[password] class copy [SourceProjectName].sdp# 

[ClassName] [TargetProjectName].sdp#[ClassName] 

Example 

DstPmt login ADM#PWD class copy SourceProject.sdp#Invoices1 

TargetProject.sdp#Invoices2 

 To copy a class without specifying the target class, type the following command. This command adds 

the source class to the base classes in the target project. 

DstPmt login [UserName]#[password] class copy [SourceProjectName].sdp# 

[ClassName] [TargetProjectName].sdp 

Example 

DstPmt login ADM#PWD class copy SourceProject.sdp#Invoices1 

TargetProject.sdp 

 To copy a form to a class in the target project, type the following command. 

DstPmt login [UserName]#[password] form copy [SourceProjectName].sdp# 

[FormName] [TargetProjectName].sdp#[ClassName] 

Example 

DstPmt login ADM#PWD form copy SourceProject.sdp#InvoiceForm 

TargetProject.sdp#Invoices2 
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 To copy a zone, type the following command. 

Note: SourceProjectName and TargetProjectName project can be the same. 
 

DstPmt login [UserName]#[password] zone copy [SourceProjectName].sdp# 

[PageName]#[ZoneName] [TargetProjectName].sdp#[PageName] 

Example 

DstPmt login ADM#PWD zone copy SourceProject.sdp#PageName#ZoneName 

TargetProject.sdp#PageName 

 To copy an anchor, type the following command. 

Note: SourceProjectName and TargetProjectName project can be the same. 
 

 

DstPmt login [UserName]#[password] anchor copy 

[SourceProjectName].sdp#[PageName]#[AnchorName] 

[TargetProjectName].sdp#[PageName] 

Example 

DstPmt login ADM#PWD anchor copy SourceProject.sdp#PageName#AnchorName 

TargetProject.sdp#PageName 

 To replace a page, type the following command. 

Note: SourceProjectName and TargetProjectName project can be the same. 
 

DstPmt login [UserName]#[password] page replace 

[SourceProjectName].sdp#[PageName] [TargetProjectName].sdp#[PageName] 

Example 

DstPmt login ADM#PWD page replace SourceProject.sdp#PageName 

TargetProject.sdp#PageName 

 To replace a script, type the following command. 

Note: SourceProjectName and TargetProjectName project can be the same. 
 

DstPmt login [UserName]#[password] script replace 

[SourceProjectName].sdp#[ScriptName] [TargetProjectName].sdp# 

[ScriptName] 

Example 

DstPmt login ADM#PWD script replace SourceProject.sdp#ScriptName 

TargetProject.sdp#ScriptName 

 
 
 
Page Designer 
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About Page Designer 

Page Designer provides an overview about the zones defined for each class and the recognition engines 

used. Furthermore, the tool enables you to quickly review reading zones for OCR, OMR and Barcode 

recognition and to easily experiment with the zone properties. 

Note: Use this tool for testing purposes only and never save any changes. This might corrupt the project. 
 

Page Designer User Interface 

The left pane displays the classes, their zones and the used engines. 

The right pane displays the images. 

Load an Image 

To load an image, complete the following steps. 

1. Click File > Open Image. 

2. In the Select Image file dialog box, browse to the required directory, select a file and then click Open. 

3. Optional. Use the buttons on the toolbar to adjust the view to your needs. 

Load an Image List 

To load an image list, complete the following steps. 

1. Click File > Open Image List. 

2. In the Select Image List dialog box, under Imagepath Settings, complete the following substeps. 

1. Browse to the required directory. 

2. Select the file type. 

3. Complete one of the following substeps. 

 From the Available images list, select the images you want to load and then click Add. 

 To load all images listed in the Available images list, click Add all. 

4. Click OK 

5. Optional. Use the buttons on the toolbar to adjust the view to your needs. 

Create a Project 

Do not create projects with Page Designer, this function is no longer in use. 

Load a Project 

To load a project, complete the following steps. 

1. Click File > Load Project. 

2. In the Load project file dialog box, browse to the required directory. 

3. From the File Type list, select WebCenter Forms Recognition Project File (*.sdp). 

4. Select the project and then click Open. 

About Version Control 

The Page Designer version control feature is no longer in use. 
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Display Information About the Image 

To display path, resolution, size, bits per pixel, and color of the image, complete the following step. 

 Click Image > Image Info. 

About Reading Zones 

For information about reading zones, see "About reading zones" and "About the Zone Analysis Engine" in the  
Oracle WebCenter Forms Recognition Designer User's Guide. 

 

Create a Reading Zone 

To create a reading zone, complete the following steps. 

Note: Never save your changes in Page Designer, any modifications must be applied in Designer. 
 

1. Complete the following options as needed. 

 To create an OCR reading zone, click the Insert OCR zone  button. 

 To create an OMR reading zone, click the Insert OMR zone  button. 

 To create a bar code reading zone, click the Insert barcode zone button. 

2. On the document, drag to mark the required zone. 

Note: The zone must be large enough to hold the expected content, but not much larger. 
 
 

Adjust a Reading Zone 

To adjust a reading zone, complete any of the following steps. 

 Drag the zone to another place. 

 Resize the zone by dragging the corner handles. 

 To adjust the zone size to the size of the entire page, right-click the zone and then click Fit to image 

size. 

 To delete a zone, select the zone and then press Del. 
 

Modify the Zone Properties 

To modify the zone properties, complete the following steps. 

1. In the image pane, right-click a zone and then click Properties. 

2. In the Zone Properties dialog box, modify the settings. 

Note: For more information, see "Zone-level recognition settings" in the Oracle WebCenter Forms Recognition 

Designer User's Guide. 
 

About Anchors 

For information about anchors, see "About Anchors" in the Oracle WebCenter Forms Recognition Designer 
User's Guide. 

 

Create an Anchor 

To create an anchor, complete the following steps. 
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1. Click the Anchor   button. 

2. On the document, drag to mark the anchor zone. 

Note: Ensure that the anchor zone is proportional to the geometric feature that you want to locate. For 

example, if all the documents in your class contain a 50 mm line in the footer area, your anchor should 

not have a side length of 5 or 250 mm. The anchor position should be close to the geometric feature 

you want to use. 

3. Optional. To create more anchors, repeat the previous steps. 
 

Modify the Anchor Properties 

To modify the anchor properties, complete the following steps. 

1. In the image pane, right-click the anchor and then click Properties. 

2. In the Anchor Properties dialog box, modify the properties. 

Note: For more information, see "Modify the anchor properties" in the Oracle WebCenter Forms Recognition 

Designer User's Guide. 

Read a Zone 

To read a zone, complete the following steps. 

1. Browse to the required image. 

2. On the image, select a zone. 

3. Click the Read active zone   button. 

4. In the Zone dialog box, observe the result. 

Read all Zones on an Image 

To read all zones on an image, complete the following steps. 

1. Browse to the required image. 

2. Click the Read all zones  button. 

3. In the Recognition Result dialog box, observe the result. 

Read all Zones on all Images 

To read all zones on all images, complete the following steps. 

1. Click the Read zones at all images  button. 

2. In the Recognition Result all dialog box, observe the result. 

3. Optional. To save the result in a text file, complete the following substeps. 

1. Click Save. 

2. In the Save Textfile dialog box, in the File name field, type a name and then click Save. 

Workdoc Browser 

About Workdoc Browser 

Workdoc Browser enables you to review the workdoc data gained during processing, such as the found 
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words and text blocks, the content of fields and their properties. 

This may help you to investigate errors, OCR problems, or to examine properties you want to use in scripting. 

Furthermore, you can review the whole structure of the documents storage base such as batches, folders, 

and workdocs. You can operate with the batches of documents by filtering and sorting them and to create 

copies of the documents or batches of documents. It can be especially helpful for example at reviewing or 

reproducing issues in the document processing results. 

Workdoc Browser User Interface 

The user interface provides the following panes. 

 The upper left pane displays the directories on the file system or the jobs and batches from the database, 

depending on the selected view. 

 The lower left pane displays the workdocs of the selected batch. 

 The middle pane displays the selected workdoc. 

 The attributes pane displays the pages, words, text blocks, and text lines as well as several other 

attributes. 

 The properties pane displays the properties of the selected attribute. 

Configure the Database Connection 

To configure the database connection, complete the following steps. 

1. From the C:\Program Files (x86)\Oracle\WebCenter Forms Recognition directory, open 
DstWkBrw.exe.config in a text editor. 

2. Complete one of the following actions. 
 

Situation Steps 

Configure the connection to an Oracle 
database. 

 

 Set Data Source to the data source. 

 Set User ID to the service account user ID. 

 Set Password to the service account password. 

Configure the connection to a SQL Server 
database. 

 

 Set Data Source to the data source. 

 Set Initial Catalog to the SQL Server 

database catalog. 

 Set User ID to the SQL Server user ID. 

 Set Password to the SQL Server password. 

  

 
3. Save and close the file. 

Open a Workdoc from the File System 

To open a workdoc from the file system, complete the following steps. 

a. On the toolbar, click the File System View  button. 

b. In the upper left pane, browse to the required directory. 
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c. In the lower left pane, select the required workdoc. 

d. Optional. In the middle pane, use the buttons on the toolbar to adjust the view to your needs. 

Open a Workdoc from the Database 

To open a workdoc from the file system, complete the following steps. 

1. On the toolbar, click the Database View  button. 

2. If the Login dialog appears, type your user name and password and then click OK. 

Note: The user must be available in the WebCenter Forms Recognition database. 

3. In the upper left pane, expand the required job and then select a batch. 

4. In the lower left pane, select the required workdoc. 

5. Optional. In the middle pane, use the buttons on the toolbar to adjust the view to your needs. 

Copy a Batch to the File System 

To copy a batch to the file system, complete the following steps. 

1. On the toolbar, click the Database View  button. 

2. If the Login dialog appears, type your user name and password and then click OK.  

Note: The user must be available in the WebCenter Forms Recognition database. 

3. In the upper left pane, right-click a batch and then click Copy Batch To File System. 

4. In the Select Folder dialog box, type or browse to the required directory and then click OK. 

Copy a Batch to a Database 

To copy a batch to a database, complete the following steps. 

1. On the toolbar, click the Database View  button. 

2. If the Login dialog appears, type your user name and password and then click OK. 

Note: The user must be available in the WebCenter Forms Recognition database. 
 

3. In the upper left pane, right-click a batch and then click Copy Batch to Database. 

4. In the Select The Target Database dialog box, select a database and then click OK. 

The batch is copied to a job with the same name. If the job does not exist in the target database, it will 

be created. If the batch is copied within the same database, a duplicate batch named 

[OriginalBatchName]_[ConsecutiveNumber] within the same job is created. 

5. On the View menu, click Refresh. 

 

Copy a Document to the File System 

To copy a workdoc WDC file and its associated documents to the file system, complete the following steps. 

1. On the toolbar, click the Database View  button. 

2. If the Login dialog appears, type your user name and password and then click OK. 
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Note: The user must be available in the WebCenter Forms Recognition database. 
 

3. In the lower left pane, right-click a document and then click Copy Document to File System. 

4. In the WebCenter Forms Recognition Workdoc Browser - Save Workdoc dialog box, type or 

browse to the required directory and then click OK. 

Filter and Sort the Batches 

To filter and sort the batches, complete the following steps. 

Note: For more information, see "Batch filter conditions using column names" in the Oracle WebCenter 
Forms Recognition Runtime Server User's Guide. 

Note: This function is only available in the Database View. 

1. On the toolbar, click the Filtering  button. 

2. In the Batch Filtering & Sorting dialog box, in the Batch Filtering field, type a WHERE condition. 

Example State=550 

3. Optional. In the Batch Sorting field, type the field you want to sort by and then click Request. 

Export Filtered Batches 

To export filtered batches, complete the following steps. 

1. In the upper left pane, right-click the job and then click Export All Filtered Batches. 

2. In the Select The Target Database dialog box, select a database and then click OK. 

Examine the Attributes and Properties 

The attribute pane displays the attributes of the current workdoc. Complete any of the following steps. 

 To expand an entry that displays the book  symbol to its left, double-click the entry and then 

select any of the subordinate entries to display its properties. 

 To highlight the found words, text blocks, or text lines, select the corresponding entry. 

The Attributes Pane 

The attributes pane displays the following information. 
 

Attribute Description 

DocFiles The number of images contained in the workdoc displays in brackets. 

The subordinate entries display path and file name of the TIF file. Select an 

entry to display the image in the document pane. 

Pages The number of pages of the workdoc displays in brackets. 

The subordinate entries list the page indexes and their properties. Select an 

entry to display the page in the document pane. 
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Words The number of words found during OCR displays in brackets. Select this 

attribute to highlight all words on the document. 

The subordinate entries list all words found on the document. Select an 

entry to highlight the word on the document and to display its properties. 

TextBlocks The number of blocks displays in brackets. Select this attribute to highlight 

all blocks on the document. 

During OCR, the found words that have a geometrical relationship are 

assigned to blocks, for example the vendor address on an invoice. 

The subordinate entries list all text blocks found on the document. Select an 

entry to highlight the text block on the document and to display its 

properties. 

TextLines The number of lines found by the Brainware line extraction or the Advanced 

line extraction displays in brackets. Select this attribute to highlight all lines 

on the document. 

During OCR, the words that are geometrically on the same line, are 

assigned to text lines. 

The subordinate entries list all text lines found on the document. Select an 

entry to highlight the text line on the document and to display its properties. 

Fields The number of fields displays in brackets. 

The subordinate entries list all fields defined in the assigned class. Select an 

entry to display its properties. 

In the properties pane, select a candidate to highlight the candidate on the 

document. 

DocClassName Name of the assigned class. 

BlockCount Number of text blocks. 

DisplayPage Index of the currently displayed page. 

DocState Current state of the document within the workflow. 

For more information, see "CDRDocState" in the Oracle WebCenter Forms 

Recognition Scripting User's Guide. 

ErrorDescription Description of the error or blank if none occurred. 

FileName File name of the workdoc. 

Folder Folder name. 

FolderIndex Index of the folder. 

Language Language activated for the workdoc. 
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Showtooltips True: Display tool tips when the user moves the pointer over the workdoc. 

False: Do not display tool tips when the user moves the pointer over the 

workdoc. 

TextLineCount Number of lines. 

VersionCount Number of versions. 

WordSegmentationChars Characters that indicate the end of a word and the beginning of a new one. 

 

Merge SLW Learn Sets tool 

About the Merge SLW Learn Sets Tool 

An administrator supporting a highly distributed system of different workstations could be easily confronted 

with maintenance of a high number of separate knowledge bases, created at different locations, at different 

times. Thus in some cases it might be required to merge the learn sets (created in context of the same 

production global SLW project) from different project files, being able to provide some additional 

considerations. 

Use this tool to quickly merge multiple SLW sub-projects, overtaking the “SLW knowledge” without using the 

learnset manager tool. The Merge SLW Learn Sets tool enables you for example to quickly correct 

corresponding configuration errors related to “disconnected” local Advanced Verifier workstations. 

The tool works only with Supervised Learning Workflow (SLW) projects, which are the instances of the same 

master (global) SLW project. In this connection, only the SLW vendor classes can be populated and/or 

updated through this tool. The tool cannot update classes if the project contains any classes that are not 

created automatically by SLW. 
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Merge SLW Learn Sets 

To merge SLW learn sets, complete the following steps. 

1. From the Windows Start menu, launch the Merge SLW Learn Sets tool. 

2. In the Source Project field, type or browse to the source project. 

3. In the Target Project field, type or browse to the target project. 

4. To discover and analyze the structures, click Scan Projects. 

5. In the Copy column, select the classes you want to merge. 

6. To merge the learn set into the target project, click Merge. 

Example 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

In the example above, the tool analyzed and found out the following. 

Base class “Invoices” with no documents in learn sets (neither source, nor target) 

Lines 2,3,4,5 the derived classes with names and number of already learned documents (both in 

source and target projects) 

As of line 4 the “Worldnet 1234565” has one document in the source project, but no documents in the 

target project, therefore the tool automatically suggests to make a copy from source to target project. 

You can also manually select some other nodes; for example, you’d choose two extra nodes “Unicom” 

and “BOLZ”, the class “Unicom” of the target project is trained with one more document available for 

this class in the source project and the class “BOLZ” – with two more documents available in the 

source project. 
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Note: The Merge button is only active if the tool finds learn sets that can be merged. 
 

SLW Export Local Project tool 

About the SLW Export Local Project Tool 

Use this tool to create local project templates that can be used by Advanced Verifier workstations from your 

global project to provide the Supervised Learning content for the local projects. 

The tool automatically analyzes and creates the corresponding learn set directories and learn sets and saves 

them with the new project. 

Use the SLW Export Local Project Tool 

To create a new local project from an existing global one, keeping either the entire settings of your base class, 

your learn set and your script, complete the following steps. 

1. From the Windows Start menu, launch the SLW Export Local Project Tool. 

2. Click Load Project. 

3. In the Export Local Project dialog box, select a global project and then click Open. 

4. Optional. To save the entire export project configuration as a part of the global project’s stream, click 

Save Project. 

5. Click Export Project. 

6. In the Export Project dialog box, select the classes, learn sets, and scripts you want to export and 

then click Export. 

Note: The project is marked with P, base classes are marked with B, sub-classes are marked with S. 

7. In the Export Local Project dialog box, type a name for the new project and then click Save. 


