5.1.8 32-bit RDMA packages are installed when upgrading a system that has rdma-core installed

For upgrades prior to Oracle Linux 7 Update 4, where the rdma-core.noarch package is installed, 32-bit versions of the packages and many dependencies are also installed, unnecessarily. This problem occurs because the original version of the package is obsoleted. Thus, during upgrade, the package is replaced with both the rdma-core.i686 and rdma-core.x86_64 versions of the package, along with those packages' dependencies.

To work around the issue, run the yum update command with the --exclude=\*.i686 option:

# yum update --exclude=\*.i686

(Bug ID 28217831)