5.1.7 Incompatible libpmemobj++-devel package version in ol7_optional_latest repository causes dependency issue during an upgrade

The version of the libpmemobj++-devel package that is provided in the ol7_optional_latest repository is not compatible with the version of the libpmemobj-devel package that is provided in Oracle Linux 7 Update 7. This incompatibility causes a package dependency issue during an upgrade from Oracle Linux 7 Update 6 to Oracle Linux 7 Update 7.

The workaround for this issue is to remove the libpmemobj++-devel package from the Oracle Linux 7 Update 6 system prior to upgrading to Oracle Linux 7 Update 7.

(Bug ID 30141105)