Appendix A Developer Preview Releases

Warning

Oracle does not support Kubernetes on systems where the ol7_preview, ol7_developer or ol7_developer_EPEL yum repositories or ULN channels are enabled, or where software from these repositories, or channels, is currently installed on the systems where Kubernetes runs. If you follow the instructions in this section, you may render your platform unsupported if these repositories or channels are enabled or software from these channels or repositories is installed on your system.

Oracle makes interim releases of Oracle Linux Container Services for use with Kubernetes available as technical previews. These releases are not supported by Oracle and are not intended for production use.

Developer preview releases can be obtained by enabling the ol7_developer repository on the Oracle Linux yum server:

# yum-config-manager --enable ol7_developer

The packages from this repository are intended for use with the images provided in the Container Services (Developer) Repositories on the Oracle Container Registry. You must login and accept the terms and conditions to use these.

If you install developer preview packages, make sure that you are pulling the correct images for the release by setting the KUBE_REPO_PREFIX environment variable:

# export KUBE_REPO_PREFIX=container-registry.oracle.com/kubernetes_developer

The installation procedures described in this guide should continue to apply for each developer preview release. You can find older preview releases in ol7_preview , but the use of that channel for Oracle Linux Container Services for use with Kubernetes is now deprecated.

Important

Oracle does not support any upgrade from a developer preview release to a stable and supported release. Oracle does not support upgrade from a supported release to a newer developer preview.