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Preface

This is Your First Cup: An Introduction to Java Platform, Enterprise Edition, a short tutorial for
beginning Java EE programmers. This tutorial is designed to give you a hands-on lesson on
developing an enterprise application from initial coding to deployment.

Who Should Use This Book
This tutorial is for novice Java EE developers. You should be familiar with the Java
programming language, particularly the features introduced in Java Platform, Standard Edition
5. While familiarity with enterprise development and Java EE technologies is helpful, this
tutorial assumes you are new to developing Java EE applications.

Before You Read This Book
Before you start this tutorial, you should:

■ Be familiar with the Java programming language
■ Be able to install software on your work machine
■ Have a modern web browser installed on your work machine

Related Books and Projects
The following books and projects may be helpful to you in understanding this tutorial:

■ The Java EE 5 Tutorial
■ The Oracle GlassFish Server documentation set
■ The NetBeans IDE documentation set

5
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Typographic Conventions
The following table describes the typographic conventions that are used in this book.

TABLE P–1 Typographic Conventions

Typeface Meaning Example

AaBbCc123 The names of commands, files, and directories,
and onscreen computer output

Edit your .login file.

Use ls -a to list all files.

machine_name% you have mail.

AaBbCc123 What you type, contrasted with onscreen
computer output

machine_name% su

Password:

aabbcc123 Placeholder: replace with a real name or value The command to remove a file is rm
filename.

AaBbCc123 Book titles, new terms, and terms to be
emphasized

Read Chapter 6 in the User's Guide.

A cache is a copy that is stored
locally.

Do not save the file.

Note: Some emphasized items
appear bold online.

Shell Prompts in Command Examples
The following table shows the default UNIX system prompt and superuser prompt for the C
shell, Bourne shell, and Korn shell.

TABLE P–2 Shell Prompts

Shell Prompt

C shell machine_name%

C shell for superuser machine_name#

Bourne shell and Korn shell $

Bourne shell and Korn shell for superuser #

Preface
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Introduction

This chapter outlines the goals and the prerequisites for completing this tutorial.

Goals of This Tutorial
At the completion of this tutorial, you will:

■ Understand the basics of tiered applications
■ Understand the basics of the Java EE platform
■ Have created a multi-tiered Java EE application
■ Have deployed and run your application on a Java EE server
■ Know where to go next for more information on the Java EE platform

Requirements for This Tutorial
Before you begin this tutorial, you need to complete the following tasks:

■ “Getting the Tutorial Bundle” on page 7
■ “Getting the Java EE 5 SDK” on page 8
■ “Getting NetBeans IDE” on page 8
■ “Configuring Your Environment” on page 8

Getting the Tutorial Bundle
To get the tutorial bundle, go to the project's java.net (https://firstcup.java.net/) site.

1C H A P T E R 1
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Getting the Java EE 5 SDK
To get the Java EE 5 SDK, go to http://www.oracle.com/

technetwork/java/javaee/downloads/java-archive-downloads-eesdk-419427.html and
click Java Application Platform SDK 5 Update 8 No JDK.

The Java EE 5 SDK includes the Oracle GlassFish Server, which is the reference implementation
of the Java EE platform APIs.

The GlassFish (https://glassfish.java.net) project is the open-source basis for the Oracle
GlassFish Server.

Getting NetBeans IDE
To get NetBeans IDE go to http://www.netbeans.org/downloads/index.html.

Configuring Your Environment
Once you have all the necessary downloads, you must configure the tutorial bundle to reflect
your environment.

Building the Examples Using NetBeans IDE
To run the tutorial examples in NetBeans IDE, you must register your GlassFish Server
installation as a NetBeans Server Instance. Follow these instructions to register the GlassFish
Server in NetBeans IDE.

1. Select Tools→Servers to open the Server Manager dialog.
2. Click Add Server.
3. Under Server, select Oracle GlassFish Server and click Next.
4. Under Platform Location, enter the location of your GlassFish Server installation.
5. Select Register Local Default Domain and click Next.
6. Under Admin Username and Admin Password, enter the admin name and password

created when you installed the GlassFish Server.
7. Click Finish.

Building the Examples on the Command-Line Using Ant
Build properties common to all the examples are specified in the build.properties file in the
tut-install/example/bp-project/ directory. You must create this file before you can run the
examples. Copy the file build.properties.sample to build.properties and edit it to reflect
your environment. The tutorial examples use the Java BluePrints build system and application
layout structure.

Requirements for This Tutorial
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To run the Ant scripts, you must set common build properties in the file
tut-install/example/bp-project/build.properties as follows:

■ Set the javaee.home property to the location of your GlassFish Server installation. The build
process uses the javaee.home property to include the libraries in as-install/lib/ in the
classpath. All examples that run on the GlassFish Server include the Java EE library archive,
as-install/lib/javaee.jar. in the build classpath. Some examples use additional libraries in
as-install/lib/; the required libraries are enumerated in the individual technology chapters.

Note – On Windows, you must escape any backslashes in the javaee.home property with
another backslash or use forward slashes as a path separator. So, if your GlassFish Server
installation is C:\Sun\AppServer, you must set javaee.home to javaee.home =

C:\\Sun\\AppServer or javaee.home=C:/Sun/AppServer.

■ Set the firstcup.tutorial.home property to the location of your tutorial. This property is
used for Ant deployment and undeployment.
For example, on UNIX:

firstcup.tutorial.home=/home/username/firstcup

On Windows:

firstcup.tutorial.home=C:/firstcup

Do not install the tutorial to a location with spaces in the path.
■ If you did not accept the default values for the admin user and password, set the admin.user

property to the value you specified when you installed the GlassFish Server, and set the
admin user’s password in the admin-password.txt file in the
tut-install/example/bp-project/ directory to the value you specified when you installed
the GlassFish Server.

■ If you did not use port 8080, set the javaee.server.port property to the value specified
when you installed the GlassFish Server.

Requirements for This Tutorial
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The Java Platform, Enterprise Edition

This chapter outlines the features of Java EE, how it differs from Java SE and Java ME, and the
basic concepts behind enterprise application development.

Differences between Java EE and Java SE
Java technology is both a programming language and a platform. The Java programming
language is a high-level object-oriented language that has a particular syntax and style. A Java
platform is a particular environment in which Java programming language applications run.

There are several Java platforms. Many developers, even long-time Java programming language
developers, do not understand how the different platforms relate to each other.

The Java Programming Language Platforms
There are three platforms of the Java programming language:

■ Java Platform, Standard Edition (Java SE)
■ Java Platform, Enterprise Edition (Java EE)
■ Java Platform, Micro Edition (Java ME)

All Java platforms consist of a Java Virtual Machine (VM) and an application programming
interface (API). The Java Virtual Machine is a program, for a particular hardware and software
platform, that runs Java applications. An API is a collection of software components that you
can use to create other software components or applications. Each Java platform provides a
virtual machine and an API, and this allows applications written for that platform to run on any
compatible system with all the advantages of the Java programming language:
platform-independence, power, stability, ease-of-development, and security.

2C H A P T E R 2
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Java SE
When most people think of the Java programming language, they think of the Java SE API. Java
SE's API provides the core functionality of the Java programming language. It defines
everything from the basic types and objects of the Java programming language to high-level
classes that are used for networking, security, database access, graphical user interface (GUI)
development, and XML parsing.

In addition to the core API, the Java SE platform consists of a virtual machine, development
tools, deployment technologies, and other class libraries and toolkits commonly used in Java
applications.

Java EE
The Java EE platform is built on top of the Java SE platform. Java EE provides an API and
runtime environment for developing and running large-scale, multi-tiered, scalable, reliable,
and secure network applications.

Java ME
The Java ME platform provides an API and a small-footprint virtual machine for running Java
programming language applications on small devices, like cellular phones. The API is a subset
of the Java SE API, along with special class libraries useful for small device application
development. Java ME applications are often clients of Java EE application services.

Overview of Enterprise Applications
This section describes enterprise applications and how they are designed and developed.

As stated above, the Java EE platform is designed to help developers create large-scale,
multi-tiered, scalable, reliable, and secure network applications. A shorthand name for such
applications is “enterprise applications,” so called because these applications are designed to
solve the problems encountered by large enterprises. Enterprise applications are not only useful
for large corporations, agencies, and governments, however. The benefits of an enterprise
application are helpful, even essential, for individual developers and small organizations in an
increasingly networked world.

The features that make enterprise applications powerful, like security and reliability, often make
these applications complex. The Java EE platform is designed to reduce the complexity of
enterprise application development by providing a development model, API, and runtime
environment that allows developers to concentrate on functionality.

Overview of Enterprise Applications
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Tiered Applications
In a multi-tiered application, the functionality of the application is separated into isolated
functional areas, called tiers. Typically, multi-tiered applications have a client tier, a middle tier,
and a data tier (often called the enterprise information systems tier). The client tier consists of a
client program that makes requests to the middle tier. The middle tier's business functions
handle client requests and process application data, storing it in a permanent datastore in the
data tier.

Java EE application development concentrates on the middle tier to make enterprise application
management easier, more robust, and more secure.

The Client Tier
The client tier consists of application clients that access a Java EE server and that are usually
located on a different machine from the server. The clients make requests to the server. The
server processes the requests and returns a response back to the client. Many different types of
applications can be Java EE clients, and they are not always, or even often Java applications.
Clients can be a web browser, a stand-alone application, or other servers, and they run on a
different machine from the Java EE server.

The Web Tier
The web tier consists of components that handle the interaction between clients and the
business tier. Its primary tasks are the following:

■ Dynamically generate content in various formats for the client.
■ Collect input from users of the client interface and return appropriate results from the

components in the business tier.
■ Control the flow of screens or pages on the client.
■ Maintain the state of data for a user's session.
■ Perform some basic logic and hold some data temporarily in JavaBeans components.

Java EE Technologies Used in the Web Tier

The following Java EE technologies are used in the web tier in Java EE applications.

TABLE 2–1 Web Tier Technologies

Technology Purpose

Servlets Java programming language classes that dynamically
process requests and construct responses, usually for
HTML pages

Overview of Enterprise Applications
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TABLE 2–1 Web Tier Technologies (Continued)
Technology Purpose

JavaServer Pages (JSP) Text-based documents that are compiled into servlets
and define how dynamic content can be added to
static pages, such as HTML pages.

JavaServer Faces technology A user-interface component framework for web
applications that allows you to include UI
components (such as fields and buttons) on a page,
convert and validate UI component data, save UI
component data to server-side data stores, and
maintain component state.

JavaServer Pages Standard Tag Library A tag library that encapsulates core functionality
common to JSP pages

JavaBeans Components Objects that act as temporary data stores for the pages
of an application

The Business Tier
The business tier consists of components that provide the business logic for an application.
Business logic is code that provides functionality to a particular business domain, like the
financial industry, or an e-commerce site. In a properly designed enterprise application, the
core functionality exists in the business tier components.

Java EE Technologies Used in the Business Tier

The following Java EE technologies are used in the business tier in Java EE applications:

■ Enterprise JavaBeans (EJB) components, referred to here as enterprise beans
■ JAX-WS web service endpoints
■ Java Persistence API entities

The Enterprise Information Systems Tier
The enterprise information systems (EIS) tier consists of database servers, enterprise resource
planning systems, and other legacy data sources, like mainframes. These resources typically are
located on a separate machine than the Java EE server, and are accessed by components on the
business tier.

Java EE Technologies Used in the EIS Tier

The following Java EE technologies are used to access the EIS tier in Java EE applications:

■ The Java Database Connectivity API (JDBC)
■ The Java Persistence API
■ The J2EE Connector Architecture

Overview of Enterprise Applications
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■ The Java Transaction API (JTA)

Java EE Servers
A Java EE server is a server application that the implements the Java EE platform APIs and
provides the standard Java EE services. Java EE servers are sometimes called application servers,
because they allow you to serve application data to clients, much as how web servers serve web
pages to web browsers.

Java EE servers host several application component types that correspond to the tiers in a
multi-tiered application. The Java EE server provides services to these components in the form
of a container.

Java EE Containers
Java EE containers are the interface between the component and the lower-level functionality
provided by the Java EE platform to support that component. The functionality of the container
is defined by the Java EE platform, and is different for each component type. Nonetheless, the
Java EE server allows the different component types to work together to provide functionality in
an enterprise application.

The Web Container
The web container is the interface between web components and the web server. A web
component can be a servlet, a JavaServer Pages (JSP) page, or a JavaServer Faces page. The
container manages the component's lifecycle, dispatches requests to application components,
and provides interfaces to context data, such as information about the current request.

The Application Client Container
The application client container is the interface between Java EE application clients, which are
special Java applications that use Java EE server components, and the Java EE server. The
application client container runs on the client machine, and is the gateway between the client
application and the Java EE server components that the client uses.

The EJB Container
The EJB container is the interface between enterprise beans, which provide the business logic in
a Java EE application, and the Java EE server. The EJB container runs on the Java EE server and
manages the execution of an application's enterprise beans.

Java EE Servers
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Creating Your First Java EE Application

This chapter gives an overview of the example application and step-by-step instructions on
coding the example application.

This chapter covers the following topics:

■ “Architecture of the Example Application” on page 17
■ “Coding the Example Application” on page 18

Architecture of the Example Application
The example application consists of three main components: DukesAgeService, a web service
endpoint; DukesBirthdayBean, an enterprise bean; and firstcup, a web application created
with JavaServer Faces technology.

DukesAgeService is a JAX-WS endpoint that calculates the age of Duke, the Java mascot. Duke
was born on May 23, 1995, when the first demo of Java technology was publicly released.

DukesBirthdayBean is a stateless session bean that calculates the difference between the user's
age and Duke's age.

The firstcup web application is a JavaServer Faces application that accesses DukesAgeService
to display Duke's age, reads in a date provided by the user, accessesDukesBirthdayBean to
calculate who is older, and then displays the difference in years between the user and Duke.

The web application consists of the following:

■ greeting.jsp: A JSP page with which a user can enter a date.
■ response.jsp: A JSP page that tells the user whether he or she is older or younger than

Duke, based on the date the user entered in the greeting.jsp page.
■ DukesBDay.java: A JavaServer Faces managed bean that defines properties to hold the user's

birth date, get Duke's current age from the web service, and get the age difference between
the user and Duke from the enterprise bean.

3C H A P T E R 3
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■ faces-config.xml: A file used to configure resources for the JavaServer Faces application.
In the case of this application, the file configures a resource bundle containing messages, the
managed bean, DukesBDay, and the page navigation rules.

■ web.xml: The web application's deployment descriptor, which is used to configure certain
aspects of a web application when it is installed. In this case, it is used to provide a mapping
to the application's FacesServlet instance, which accepts incoming requests, passes them
to the life cycle for processing, and initializes resources.

Tiers in the Example Application
The example application has one web tier component (the firstcupweb client) and two
business tier components (the DukesAgeServiceweb service and the
DukesBirthdayBeanenterprise bean). The user's web browser is the client tier component, as it
accesses the rest of the application through the web tier. The example application does not
access the EIS tier.

Java EE Technologies Used in the Example Application
The DukesAgeService web service endpoint is a JAX-WS endpoint The DukesBirthdayBean
enterprise bean is a stateless session bean. The firstcupweb client is a JavaServer Faces
application that runs in the web container of the Java EE server.

Coding the Example Application
This section describes how to code the example application. It covers the following general
tasks:
■ “Getting Started” on page 18
■ “Creating the Web Service Endpoint” on page 20
■ “Creating the Enterprise Bean” on page 23
■ “Creating the Web Client” on page 27
■ “Building, Packaging, Deploying, and Running the firstcup Enterprise Application” on

page 43

Getting Started
Before you start coding the example, you need to perform some set-up tasks:
■ “Register the Server with NetBeans IDE” on page 19
■ “Create a Directory for the Example” on page 19
■ “Specify Some Settings” on page 19

Coding the Example Application
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▼ Register the Server with NetBeans IDE

Launch NetBeans IDE.

From the menu, select Tools→Server Manager.

Click Add Server.

In the Add Server Instance dialog, select Oracle GlassFish Server from the Server menu.

(Optional) Enter a name for the server in the Name field.

Click Next.

Click Browse to find the location of the GlassFish Server installation.

Click Next.

Enter the user name you chose when you installed the GlassFish Serverin the Admin Username
field.

Enter the password for this username in the Admin Password field.

Click Finish.

Click Close.

▼ Create a Directory for the Example

Create another directory at the same level as the exampledirectory and call it myexample.

You'll put the First Cup application that you build while following this tutorial in this directory.

Copy the entire bp-project folder from the exampledirectory to the myexampledirectory.

▼ Specify Some Settings

In the myexample/bp-project directory, copy the build.properties.sample file to
build.properties.

Open the build.properties file in a text editor.
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Set the javaee.homeproperty to the path of your GlassFish Server installation.

Use forward slashes in the path, even if you are on the Windows platform. For example, you
would enter C:/myServer instead of C:\myServer.

Set the firstcup.tutorial.home property to the location of your firstcup tutorial
installation, such as C:/firstcup.

Change example to myexample in the path specified by the javaee.server.passwordfile
property.

Open the admin-password.txt file from the myexample/bp-project directory in a text editor.

Set the AS_ADMIN_PASSWORD property to your GlassFish Server password.

Save the build.properties and admin-password.txt files and close them.

Creating the Web Service Endpoint
The DukesAgeService endpoint is a simple web service. Web services are web-based
applications that use open, XML-based standards and transport protocols to exchange data
with calling clients. Both the requests and responses are sent as XML documents, and are
usually sent as HTTP packets. This makes interoperability between different systems and
applications easy, as it is not necessary for the client to know the underlying architecture of the
server and vice-versa to make a successful web service call.

Web services are designed to be independent of the client. Typically web service endpoints are
publicly available to a wide variety of clients, and the clients are located throughout the internet.
This is called “loose coupling,” as the clients and servers are connected only by the standard
XML-based requests and responses. For this reason, DukesAgeService will be developed in its
own application module, and deployed separately from the DukesBirthdayBean enterprise
bean and firstcup web client.

JAX-WS Endpoints
DukesAgeService is a JAX-WS endpoint implemented as a servlet. Servlets are web
components that run in the web container.

You'll begin by creating a servlet class, then decorate the class with the @WebServiceannotation
to make the class a web service endpoint, and finally you will add the getDukesAge method to
calculate and return Duke's age.
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Creating the Endpoint
In NetBeans IDE or another editor, create a Java class source file called DukesAge.java in the
com.sun.firstcup.webservice package.

This task involves the following steps:

■ “Create the Project in NetBeans IDE” on page 21
■ “Create the DukesAge Class” on page 22
■ “Annotate the DukesAge Class as a Web Service” on page 22
■ “Remove the Default Constructor” on page 22
■ “Add the getDukesAge Method” on page 22
■ “Resolve the Import Statements” on page 23

▼ Create the Project in NetBeans IDE

Select File→New Project.

Select Web in the Categories pane.

Select Web Application in the Projects pane.

Click Next.

Set Project Name to firstcup-dukes-age.

Set the Project Location to <INSTALL>/myexample, in which INSTALL is the location of the
firstcup tutorial installation.

Select your GlassFish Server from the Server menu.

Select Java EE 5 from the Java EE Version menu.

Set Context Path to /DukesAgeService

Click Finish.

You should now see the module you created in the Projects pane.

From the Projects pane, right-click the index.jspfile and select Delete. Click Yes in the dialog.
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▼ Create the DukesAge Class

Select File→New File.

Make sure firstcup-dukes-age is selected in the Project menu.

Select Java Classes in the Categories pane.

Select Java Class in the File Types pane.

Click Next.

Set Class Name to DukesAge.

Set Package to com.sun.firstcup.webservice.

Click Finish.

You should now see the DukesAge.java file inside the com.sun.firstcup.webservice package
in the Projects pane. The DukesAge.java file should also be open in the editor pane.

▼ Annotate the DukesAge Class as a Web Service

Add a @WebService annotation to the class.
@WebService

public class DukesAge {

...

}

▼ Remove the Default Constructor

Highlight the following default constructor and delete it, as web service endpoints do not
require a default constructor.
public DukesAge() {

}

▼ Add the getDukesAge Method

Create a public getDukesAgemethod with a return type of int.
public int getDukesAge() {

}
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Add a @WebMethod annotation to getDukesAge.
@WebMethod

public int getDukesAge() {

}

Add the following code to getDukesAge:
Calendar dukesBirthday = new GregorianCalendar(1995, Calendar.MAY, 23);

Calendar now = Calendar.getInstance();

int dukesAge = now.get(Calendar.YEAR) - dukesBirthday.get(Calendar.YEAR);

dukesBirthday.add(Calendar.YEAR, dukesAge);

if (now.before(dukesBirthday)) {

dukesAge--;

}

return dukesAge;

▼ Resolve the Import Statements

Right-click in the Editor.

Select Fix Imports.

In the Fix Imports dialog, choose the javax.jws.WebService package for the WebService class.

Select File→Save from the menu to save the file.

▼ Build and Deploy the Web Service
The DukesAgeService endpoint was packaged in a WAR file, firstcup-dukes-age.war. Now
you'll build firstcup-dukes-age.war and deploy it to the GlassFish Server. This task gives
instructions on building and deploying firstcup-dukes-age.war in NetBeans IDE.

Select firstcup-dukes-age in the Projects tab.

Right-click firstcup-dukes-age and select Build Project.

Right-click firstcup-dukes-age and select Deploy Project.

Creating the Enterprise Bean
DukesBirthdayBean is a stateless session bean. Stateless session beans are beans that do not
maintain a conversational state with a client. With stateless session beans the client makes
isolated requests that do not depend on any previous state or requests. If you require
conversational state, you use stateful session beans.
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To create DukesBirthdayBean you need to create two Java source files: DukesBirthdayBean, the
enterprise bean class; and DukesBirthdayRemote, the enterprise bean business interface. The
enterprise bean class and the business interface are the only files you need to create an
enterprise bean.

This section has instructions for creating the enterprise application and DukesBirthdayBean

enterprise bean by performing the following tasks:

■ “Create the Enterprise Application” on page 24
■ “Set the Context Root” on page 24
■ “Create the DukesBirthdayBeanEnterprise Bean Class” on page 25
■ “Modify DukesBirthdayBean.java” on page 25
■ “Modify DukesBirthdayRemote.java” on page 26

▼ Create the Enterprise Application
In this task, you will create an enterprise application archive (EAR) that will contain the
DukesBirthdayBean enterprise bean and firstup web client.

Select File→New Project.

Select Enterprise in the Categories pane.

Select Enterprise Application in the Projects pane.

Click Next.

Set Project Name to firstcup.

Set the Project Location to <INSTALL>/myexample.

By default the wizard creates an enterprise bean module firstcup-ejb and a web application
module firstcup-war. Leave everything in the dialog as it is.

Click Finish.

▼ Set the Context Root
In this task, you will specify the context root to identify the web application in a J2EE server.

Expand the firstcupmodule in the Projects pane.

In the Configuration Files node, double-click the application.xml file.

In application.xml, locate the context-root element.
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Change the context root from /firstcup-war to /firstcup.

Select File → Save to save the file.

Right-click the firstcup-warmodule in the Projects pane.

Select Properties from the popup menu.

In the Categories tree, select Run.

Change the Context Path to /firstcup.

Click OK.

▼ Create the DukesBirthdayBeanEnterprise Bean Class
Now you'll create the enterprise bean class and business interface source files in NetBeans IDE.
The DukesBirthdayRemote business interface is a remote interface.

Select firstcup-ejbproject in the Projects tab.

Select File→New File.

Select Enterprise in the Categories pane.

Select Session Bean in the File Types pane.

Click Next.

Set EJB Name to DukesBirthdayBean.

Set the Package name to com.sun.firstcup.ejb.

Set the Session Type to Stateless.

Uncheck Local and check Remote under Create Interface.

Click Finish.

▼ Modify DukesBirthdayBean.java
Now you'll add the code that calculates the difference in age in years between Duke and the user.

In DukesBirthdayBean.java, delete the empty default constructor that NetBeans IDE
generated.
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Directly after the class declaration, paste in the following code:
private static Logger logger =

Logger.getLogger("com.sun.firstcup.ejb.DukesBirthdayBean");
public int getAgeDifference(Date date) {

int ageDifference;

Calendar theirBirthday = new GregorianCalendar();

Calendar dukesBirthday = new GregorianCalendar(1995, Calendar.MAY, 23);

// Set the Calendar object to the passed in Date

theirBirthday.setTime(date);

// Subtract the user’s age from Duke’s age

ageDifference = dukesBirthday.get(Calendar.YEAR) -

theirBirthday.get(Calendar.YEAR);

logger.info("Raw ageDifference is: " + ageDifference);

// Check to see if Duke’s birthday occurs before the user’s. If so,

// subtract one from the age difference

if (dukesBirthday.before(theirBirthday) && (ageDifference > 0)) {

ageDifference--;

}

logger.info("Final ageDifference is: " + ageDifference);

return ageDifference;

}

Right-click in the editor window and select Fix Imports.

Choose the java.util.logging.Logger fully-qualified name for the Logger class.

Choose the java.util.Date fully-qualified name for the Date class.

Click OK.

Right-click within the new getAgeDifferencemethod and select EJB Methods→Add to
Remote Interface.

Select File→Save.

▼ Modify DukesBirthdayRemote.java

Expand the firstcup-ejbmodule in the Projects pane.

Double-click DukesBirthdayRemote.java under Source Packages→com.sun.firstcup.ejb.

Right-click in the editor window and select Fix Imports.

Select java.util.Date as the fully-qualified class name of the Date class and click OK.
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Remove the throws clause from the method definition so that you are left with int

getAgeDifference(Date date);.

Select File→Save.

Creating the Web Client
To create the web client, you need to perform the following tasks, some of which have subtasks:

■ “Set firstcup-war to Support JavaServer Faces Technology” on page 27
■ “Create a Web Service Client for the firstcup-war Web Module” on page 28
■ “Create a Resource Bundle to Hold Localized Messages” on page 29
■ “Configure the Resource Bundle” on page 30
■ “Add a Dependency on the Enterprise Bean Module” on page 30
■ “Creating the DukesBDay Managed Bean Class” on page 31
■ “Configure the DukesBDay Managed Bean” on page 34
■ “Creating the greeting.jsp Page” on page 35
■ “Define Page Navigation Rules” on page 40
■ “Create the response.jsp Page” on page 41

▼ Set firstcup-war to Support JavaServer Faces Technology
All JavaServer Faces applications must include a mapping to the FacesServlet instance in their
web.xmo deployment descriptors. The FacesServlet instance accepts incoming requests,
passes them to the life cycle for processing, and initializes resources.

You create the mapping to FacesServlet in the web application's deployment descriptor.
Rather than adding the mapping to the web.xml file directly, NetBeans IDE will create the
web.xml file and perform the mapping to FacesServlet for you when you specify that your web
application supports JavaServer Faces technology. To do this, perform the following task.

Right-click the firstcup-warmodule of the firstcup enterprise application in the Projects
pane.

Select Properties from the popup menu.

Select Frameworks from the Categories tree.

Click Add.

Select JavaServer Faces from the list of choices in the dialog.

Click OK.

5

6

1

2

3

4

5

6

Coding the Example Application

Chapter 3 • Creating Your First Java EE Application 27



Change the servlet URL mapping to /firstcupWeb/*.
This path will be the path to the FacesServlet instance. All requests must include this path in
between the application's context path and the page in the URL. Users don't have to include this
path in the URL because firstcup includes an index.jsp page that forwards users to the
greeting.jsp page when they enter the following URL:
http://localhost:8080/firstcup

De-select the Validate XML checkbox.

Click OK.
The remaining steps tell you how to perform the forward to greeting.jsp from the index.jsp
page.

Expand the firstcup-warmodule in the Projects pane and double-click Web Pages.

Right-click welcomeJSF.jsp, select Delete from the popup menu, and click Yes in the dialog.

Double-click index.jsp.
NetBeans IDE generated this file when you created the firstcup project.

Delete everything on the page.

Enter the following in the index.jsppage:
<jsp:forward page="/firstcupWeb/greeting.jsp"/>

Save the file by selecting File → Save from the menu bar.

▼ Create a Web Service Client for the firstcup-war Web Module
The firstcup-war web module must consume the firstcup-dukes-age web service in order
to get Duke's current age. For this to happen, you need to create a web service client for the
firstcup-war web module.

Select firstcup-war from the Project pane.

Select File → New File.

Select Web Services from the Categories pane.

Select Web Service client from the File Types pane.

Click Next.

Select WSDL URL.
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Into the WSDL URL field, enter the following location of the WSDL file of the web service that the
web service client will consume.
http://localhost:8080/DukesAgeService/DukesAgeService?WSDL

Into the Package field, enter the following package where the client files will be generated.
com.sun.firstcup.webservice

Click Finish.

▼ Create a Resource Bundle to Hold Localized Messages
In this section, you'll create the resource bundle that contains the static text and error messages
used by the JSP pages. The firstcup client supports both English and Spanish locales.
Therefore you need to create two properties files, each of which will contain the messages for
one of the locales.

Right-click firstcup-war in the Projects pane.

Select New → File/Folder from the popup menu.

Select the Other category, then Properties File from the New File dialog.

In the New Properties File dialog, enter WebMessages in the File Name field.

In the Folder field, enter src/java/com/sun/firstcup/web as the location of the file.

Click Finish.

After NetBeans IDE creates the properties file, enter the following messages or copy them from
here to the file:
Welcome=Hi. My name is Duke. Let us find out who is older -- You or me.

DukeIs=Duke is

YearsOldToday=years old today.

Instructions=Enter your birthday and click submit.

YourBD=Your birthday

Pattern=MM/dd/yyyy

DateError=Please enter the date in the form MM/dd/yyyy.

YouAre=You are

Year=year

Years=years

Older=older than Duke!

Younger=younger than Duke!

SameAge= the same age as Duke!

Submit=Submit

Back=Back

These messages will be referenced from the JSP pages.
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Save the file by selecting File → Save from the menu.

To add the Spanish translations of the messages, copy the properties file
WebMessages_es.properties from
<INSTALL>/firstcup/example/firstcup/firstcup-war/src/java/com/sun/firstcup/webto
<INSTALL>/firstcup/myexample/firstcup/firstcup-war/src/java/com/sun/firstcup/web.
You can create multiple properties files, each with a set of messages for a different locale. By
storing localized static text and messages in resource bundles, you don't need to create a
separate set of JSP pages for each locale.

Refresh the files in the application by selecting File → Refresh All Files from the menu bar.

▼ Configure the Resource Bundle
To make the resource bundle available to the application, you need to configure it in the
configuration file, by performing the following task.

Expand the firstcup-warmodule in the Projects pane.

Open the folders Web Pages → WEB-INF.

Double-click faces-config.xml.

Before the end-tag of the faces-config element, add the following elements:
<application>

<resource-bundle>

<base-name>com.sun.firstcup.web.WebMessages</base-name>

<var>bundle</var>

</resource-bundle>

<locale-config>

<default-locale>en</default-locale>

<supported-locale>es</supported-locale>

</locale-config>

</application>

The base-name element of the resource-bundle element identifies the fully-qualified class
name of the resource bundle. The var element identifies the name by which the JSP pages will
reference the resource bundle. The locale-config element identifies the locales supported by
the resource bundle.

Save the file by selecting File → Save from the menu bar.

▼ Add a Dependency on the Enterprise Bean Module
The firstcup-war module depends on some classes in the firstcup-ejb module. You need to
tell NetBeans IDE that this dependency exists by performing the following task.

Right-click the firstcup-warmodule in the Projects pane.
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Select Properties.

Select Libraries from the Categories pane.

Select Add Project.

Navigate to <INSTALL>/myexample/firstcup.

Select the firstcup-ejbproject.

Click Add Project JAR Files.

Make sure Build Required Projects is selected.

Click OK.

Creating the DukesBDay Managed Bean Class
The DukesBDay JavaBeans component is a backing bean. A backing bean is a JavaServer Faces
managed bean that acts as a temporary data storage for the values of the components included
on a particular JavaServer Faces page. A managed bean is a JavaBeans component that a
JavaServer Faces application instantiates and stores in scope. The section following this one
describes more about managed beans and how to configure them.

This section describes how to create the DukesBDay class. To create the class you need to do the
following:

1. Create an empty class.
2. Decorate the bean with a web service reference and an enterprise bean reference.
3. Add a property that accesses Duke's current age from the web service.
4. Add a property that accesses the user's current birth date.
5. Add a property that accesses the age difference from the DukesBirthdayBean enterprise

bean.
6. Add a property that accesses the absolute value of the age difference.

This section describes the following tasks:

■ “Create an Empty Class” on page 32
■ “Add an Enterprise Bean Reference” on page 32
■ “Add Properties to the Bean” on page 32
■ “Generate the Accessor Methods for the Properties” on page 33
■ “Get Duke's Current Age” on page 33
■ “Get the Age Difference from the DukesBirthdayBean Enterprise Bean” on page 34
■ “Add Import Statements” on page 34
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■ “Save DukesBDay” on page 34

▼ Create an Empty Class

Right-click the firstcup-warmodule in the Projects pane.

Select New → Java Class

Enter DukesBDay in the Class Name field.

Enter com.sun.firstcup.web in the Package field.

Click Finish.

▼ Add an Enterprise Bean Reference

Directly after the class declaration, add a private variable to hold a reference to the enterprise
bean using the @EJB annotation:
@EJB

private DukesBirthdayRemote dukesBirthday;

▼ Add Properties to the Bean
During this task, you will add the following properties to the DukesBDay bean:

■ age for getting Duke's age from the web service.
■ yourBD to hold the user's birth date.
■ ageDiff to get the age difference from the enterprise bean.
■ absAgeDiff to hold the absolute value of the age difference.

After the dukesBirthday variable declaration, add the following private variables:
private int age;

private Date yourBD;

private int ageDiff;

private int absAgeDiff;

Initialize the variables by adding the following inside the default constructor:
age = -1;

yourBD = null;

ageDiff = -1;

absAgeDiff = -1;
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▼ Generate the Accessor Methods for the Properties

Right-click in the editor window.

Select Refactor→Encapsulate Fields from the popup window.

In the Encapsulate Fields dialog, de-select the getDukesBirthday checkbox and the
setDukesBirthday checkbox.

Click Next.

Click Do Refactoring in the Refactoring pane at the bottom of the IDE window.

You should now see two methods for each property, one to set the value and one to get the value
of the variable for that property.

▼ Get Duke's Current Age
While performing this task, you will add some code to the getAge method to access Duke's
current age from the web service.

Expand the firstcup-warmodule.

Expand the Web Service References node in the firstcup-warmodule.

From within the Web Service References node, go to
DukesAgeService→DukesAgeService→DukesAgePort→getDukesAge.

Drag the getDukesAge operation from inside the DukesAgePort node to the getAgemethod in
DukesBDay.java in the editor, directly before the return age; statement so that your getAge
method looks like this:
public int getAge() {

try { // Call Web Service Operation

com.sun.firstcup.webservice.DukesAgeService service =

new com.sun.firstcup.webservice.DukesAgeService();

com.sun.firstcup.webservice.DukesAge port =

service.getDukesAgePort();

// TODO process result here

int result = port.getDukesAge();

System.out.println("Result = "+result);
} catch (Exception ex) {

// TODO handle custom exceptions here

}

return age;

}

1

2

3

4

5

1

2

3

4

Coding the Example Application

Chapter 3 • Creating Your First Java EE Application 33



In the getAge method of DukesBDay, change the line int result = port.getDukesAge(); so
that the age variable rather than the result variable is set to the result of the call to
port.getDukesAge:
age = port.getDukesAge();

Remove the following line from the getAgemethod.
System.out.println(“Result = “+result);

▼ Get the Age Difference from the DukesBirthdayBean Enterprise Bean
During this task, you will add code to the getAgeDiff method to get the difference in age
between the user's age and Duke's age from the EJB and to set the absAgeDiff variable to the
absolute value of the age difference.

Inside the getAgeDiffmethod, directly before the return statement, add the following code:
ageDiff = dukesBirthday.getAgeDifference(yourBD);

setAbsAgeDiff(Math.abs(ageDiff));

▼ Add Import Statements

Right-click in the editor window.

Select Fix Imports from the popup menu.

Select java.util.Date as the fully qualified name of the Date class.

Click OK.

▼ Save DukesBDay

Select File → Save.

▼ Configure the DukesBDay Managed Bean
JavaServer Faces technology allows you to use the configuration file to initialize, configure, and
store managed beans in one of the following scopes:
■ Request, which begins when the user submits a page and ends when the response is

rendered.
■ Session, which begins when a user first accesses a page and ends when the user's session

ends, such as when the user's session times out.
■ Application, which lasts until the server stops the application.

Once a bean is configured, a JavaServer Faces page can create and access the bean. In this
section, you'll configure the DukesBDay managed bean.
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Expand the firstcup-warmodule in the Projects pane.

Open the folders Web Pages → WEB-INF.

Double-click faces-config.xml.

Right-click in the editor window and select JavaServer Faces → Add Managed Bean.

In the Add Managed Bean dialog, enter dukesBDay in the Bean Name field.

Enter com.sun.firstcup.web.DukesBDay in the Bean Class field.

Select session from the scope menu.

Enter DukesBDay backing bean in the Bean Description field.

Click Add.
You should now see the following in the faces-config.xml file:
<managed-bean>

<description>DukesBDay backing bean</description>

<managed-bean-name>dukesBDay</managed-bean-name>

<managed-bean-class>com.sun.firstcup.web.DukesBDay</managed-bean-class>

<managed-bean-scope>session</managed-bean-scope>

</managed-bean>

The managed-bean-name element is the name by which the JavaServer Faces pages will refer to
the bean. The managed-bean-class element is the fully-qualified class name of the bean. The
managed-bean-scope element is the scope in which the bean is saved. You specify session scope
because you need an instance of the bean to be available for the entire session so that all pages
can access the values held by the bean.

Select File → Save to save the file.

Creating the greeting.jsp Page
The greeting.jsp page includes the welcome message, displays Duke's current age, and
accepts the user's birth date. To create the page, you need to perform the following tasks:

■ “Create an Empty JSP Page” on page 36
■ “Declare the JavaServer Faces Tag Libraries” on page 36
■ “Add the f:view and f:form Tags” on page 37
■ “Add Output Labels to Display Read-only Content” on page 37
■ “Add an Input Component to Accept the User's Birth Date” on page 39
■ “Register a Converter on the Input Component” on page 39
■ “Add an Error Message to Display if Conversion Fails” on page 40
■ “Add a Button for Submitting the Form” on page 40
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▼ Create an Empty JSP Page
To create an empty JSP page, do the following.

Right-click the firstcup-warmodule in the Projects pane.

Select New → JSP from the popup menu.

Enter greeting in the JSP File Name field.

Click Finish.

In the greeting.jsp file, after the html tag, replace any head tag that is already in the page and
add the following one, which defines the content type:
<head>

<meta http-equiv="Content-Type" content="text/html; charset=UTF-8">
<title>Firstcup Greeting Page</title>

</head>

Remove the beginning and ending body tags.

Remove <h1>JSP Page</h1> from the file.

Select File → Save to save the file.

▼ Declare the JavaServer Faces Tag Libraries
JavaServer Faces technology defines JSP custom tags for representing UI components,
converters, validators, and event listeners on a JSP page. A custom tag provides a way to
reference some Java logic from a JSP page, thereby freeing page authors from including the logic
in the page and allowing them to reuse the logic by adding the same tag in any of their JSP pages.
See the Custom Tags chapter of the Java EE 5 Tutorial (http://docs.oracle.com/javaee/5/
tutorial/doc/) for more information.

Custom tags are defined in tag libraries. JavaServer Faces technology defines two tag libraries.
The HTML Render Kit library defines all of the standard UI component tags. Each instance of a
component tag used on a page represents a corresponding stateful component object on the
server. The core tag library defines tags for representing type converters, data validators, event
listeners, and other objects and functions. Similarly to the component tags, each instance of a
converter, validator or listener tag represents an object on the server.

To use the tags in a page, you need to declare the tag libraries.

To declare the tag libraries, do the following.
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After the ending head tag in greeting.jsp, add a taglibdeclaration for the HTML render kit
tag library:
<%@ taglib prefix="h" uri="http://java.sun.com/jsf/html" %>

When using a particular tag from this tag library, a page author must use the prefix h: to specify
in which tag library the tag is defined. The uri resolves to the tag library definition.

After the taglibdeclaration from the previous step, add a taglibdeclaration for the core tag
library:
<%@ taglib prefix="f" uri="http://java.sun.com/jsf/core" %>

Again, when the page author uses a tag from this library, he or she must use the f: prefix to
specify that the tag is defined in the core tag library.

▼ Add the f:view and f:form Tags
A JavaServer Faces page is represented by a tree of UI components. When a JavaServer Faces
implementation processes the page during the page's life cycle, it will traverse the tree of
components and perform such tasks as converting the values of the components to the proper
type, validate the components' values, and store the components' values in backing beans.

Every JSP page that uses JavaServer Faces technology must include a view tag, which is defined
in the core tag library. The view tag represents the root of the component tree. All JavaServer
Faces component tags must be included inside the view tag.

A typical JavaServer Faces page also includes a form in which the user enters some data in input
fields and clicks a button to submit the form. If the page contains a form, it must also have a
form tag. All components that are part of the form submission must be inside the form tag.

To add the view and form tags to the page:

After the tag library declarations, add beginning and ending f:view tags:
<f:view>

</f:view>

In between the beginning and ending f:view tags, add beginning and ending h:form tags:
<f:view>

<h:form>

</h:form>

</f:view>

▼ Add Output Labels to Display Read-only Content
One of the more commonly used component tags is the outputText tag, which represents a
read-only component that only displays content. The greeting.jsp page contains outputText
tags that display the welcome message, the instructions, the label for the input component, and
Duke's current age.

1

2

1

2

Coding the Example Application

Chapter 3 • Creating Your First Java EE Application 37



The outputText tags that display the localized messages reference the messages from the
resource bundle that you configured previously. The outputText tag that displays Duke's age
references the age from the age property of DukesBDay bean.

To reference values for display, the outputText tags use the expression language syntax defined
by the unified expression language. The expression language syntax allows you to use the . or []
notation to reference objects and their properties. The name by which an expression references
an object is defined in the configuration file. For example, an expression must refer to the
WebMessages resource bundle with the name bundle. For more information on the expression
language, see the Expression Language section of the Introduction to JavaServer Pages chapter
of the Java EE tutorial (http://docs.oracle.com/javaee/5/tutorial/doc/).

While doing the following exercise, you might want to refer to the WebMessages.properties
file, the DukesBDay bean, and the faces-config.xml file that you created earlier.

To reference the read-only values displayed on the greeting page using outputText tags and
expressions, add the following tags:

In between the beginning and ending h:form tags, add an outputText tag that displays“Hi. I'm
Duke. Let's see who's older - you or me.”and add some h2 tags around it.
<h2><h:outputText value="#{bundle.Welcome}"/></h2>

The value attribute of the outputText tag specifies the text to display. In this case, the value
attribute uses an expression to reference the message stored in the resource bundle, called
bundle, under the key, Welcome.

After the outputText tag you added in the previous step, add an outputText tag that displays
“Duke is”.

Add an extra space between the closing curly brace and the double quote of the expression so
that there will be a space between “Duke Is” and the text following it on the page:
<h:outputText value="#{bundle.DukeIs} "/>

After the outputText tag you added in the previous step, add an outputText tag that displays
Duke's age:
<h:outputText value="#{dukesBDay.age}"/>

The dukesBDay part of the expression refers to the DukesBDay bean. The age part of the
expression refers to the age property of DukesBDay bean.

After the outputText tag you added in the previous step, add a paragraph tag and another
outputText tag to display the instructions for filling out the form.
<p><h:outputText value="#{bundle.Instructions}"/>
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After the outputText tag you added in the previous step, add another paragraph tag and an
outputText tag that displays the label for the input component.
Add an extra space at the end of this expression too:
<p><h:outputText value="#{bundle.YourBD} "/>

▼ Add an Input Component to Accept the User's Birth Date
Another commonly used component tag is the inputText tag. This tag represents a text field,
which accepts input from the user. The inputText tag also uses expressions to reference values.
However, the inputText tag can use the expressions to set values as well as get them. The
inputText tag on the greeting.jsp page accepts the user's birth date and sets this value into
the yourBD property of the DukesBDay bean.

To add the inputText tag, do the following:

Add a beginning and ending inputText tag, right after the previous outputText tag that you
added and give it an ID of userBirthday:
<h:inputText id="userBirthday">
</h:inputText>

Later, you'll register a converter on this component. Any error messages displayed as a result of
conversion failing will reference this id attribute.

Add to the inputText tag a value attribute that references the yourBDproperty of DukesBDay:
<h:inputText id="userBirthday"

value="#{dukesBDay.yourBD}">
</h:inputText>

▼ Register a Converter on the Input Component
JavaServer Faces technology includes a set of standard converters and validators that you can
register on components in order to convert and validate their data. You register a converter or
validator by nesting the tag representing the converter or validator inside the input
component's tag.

To add a converter to the input component discussed in the previous section, do the following:

Add an f:convertDateTime tag inside the inputText tag and specify the acceptable format of
the input:
<h:inputText ...>

<f:convertDateTime pattern="MM/dd/yyyy" />

</h:inputText>

If the user does not enter something that can be converted to a Date type or the date the user
entered is not of the specified pattern then a conversion error occurs. The next section describes
how to create an error message and display it.
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After the ending inputText tag, add an outputText tag that tells the user what the acceptable
pattern is.
Add an extra space in between the double-quote and the pound sign of the expression so that
there will be space between the text field and the text displayed by this outputText tag:
<h:outputText value=" #{bundle.Pattern}"/>

▼ Add an Error Message to Display if Conversion Fails
To specify an error message to be displayed if conversion fails, do the following:

Add a converterMessage attribute to the inputText tag and use it to specify the error message:
<h:inputText id="userBirthday"

value="#{dukesBDay.yourBD}"
converterMessage="#{bundle.DateError}">

</h:inputText>

If the conversion of the user's input fails, the following message, stored with the DateError key
in the resource bundle will display on the page:

Please enter the date in the format MM/dd/yyyy.

Add a paragraph tag followed by a message tag to indicate where the error message must
appear on the page, right before the ending form tag:
<p><h:message for="userBirthday" style="color:red"/>
</h:form>

The style attribute indicates the style of the error message. In this case, the error message text
will be red. The for attribute references the ID of the component that generated the error.

▼ Add a Button for Submitting the Form
In order for the user to submit the form with his or her birth date to the server, he or she needs
to click a button or a hyperlink, thereby causing a form submit.

To add a button to the page, do the following:

Right before the message tag you added in the previous section, add the following paragraph
tag and commandButton tag:
<p><h:commandButton value="#{bundle.Submit}" action="success"/>

Save the file by selecting File → Save from the menu.

▼ Define Page Navigation Rules
JavaServer Faces technology supports a powerful rule-based system for defining the flow of
pages in an application. These rules are defined in the configuration file. To define the page
navigation rules for the firstcup application, do the following:
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Expand the firstcup-warmodule in the Projects tree.

Open the folders Web Pages → WEB-INF.

Double-click faces-config.xml.

Right-click in the editor window and select JavaServer Faces → Add Navigation Rule.

In the Add Navigation Rule dialog, enter /greeting.jsp in the Rule from View field.

Click Add.

Repeat steps 4 through 6 except enter /response.jsp in the Rule from View field.

Right-click in the editor again and select JavaServer Faces → Add Navigation Case.

Select /greeting.jsp from the From View menu.

Enter success in the From Outcome field.

Select /response.jsp from the To View menu.

Click Add.

Repeat steps 8 through 12, except select /response.jsp from the From View menu and select
/greeting.jsp from the To View menu.
You should now see two navigation rules, one that defines how to navigate from greeting.jsp

to response.jsp, and another one that defines how to navigate from response.jsp to
greeting.jsp. The from-view-id tag indicates what the current page is. The to-view-id tag
indicates what page to go to next.

Recall from the section on adding a button that the commandButton tag has an action attribute
that indicates a logical outcome string. When the button is clicked, the navigation system
matches the current page ID and the logical outcome to a navigation rule. When it finds a
match, it will navigate to the page that the rule specifies with its to-view-id tag.

Save the file by selecting File → Save from the menu bar.

▼ Create the response.jsp Page
To create the response.jsp page, do the following:

Right-click the firstcup-warmodule.

Select New → JSP from the popup menu.
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Enter response in the JSP File Name field.

Click Finish.

In the response.jsp file, after the html tag, replace any head tag in the file with the following
head tag, which defines the content type:
<head>

<meta http-equiv="Content-Type" content="text/html; charset=UTF-8">
<title>Response Page</title>

</head>

Remove the beginning and ending body tags.

Remove <h1>JSP Page</h2> from the file.

Add the following taglibdeclarations right after the ending head tag.
<%@ taglib uri="http://java.sun.com/jsf/html" prefix="h" %>

<%@ taglib uri="http://java.sun.com/jsf/core" prefix="f" %>

After the taglibdeclarations, add the beginning and ending f:view tags.

In between the beginning and ending f:view tags, add the beginning and ending h:form tags.

In between the beginning and ending h:form tags, add the following outputText tags:
<h2><h:outputText value="#{bundle.YouAre} "/>
<h:outputText value="#{bundle.SameAge}" rendered="#{dukesBDay.ageDiff == 0}"/>

<h:outputText value="#{dukesBDay.absAgeDiff}" rendered="#{dukesBDay.ageDiff < 0}"/>
<h:outputText value=" #{bundle.Year} " rendered="#{dukesBDay.ageDiff == -1}"/>
<h:outputText value=" #{bundle.Years} " rendered="#{dukesBDay.ageDiff < -1}"/>
<h:outputText value="#{bundle.Younger}" rendered="#{dukesBDay.ageDiff < 0}"/>

<h:outputText value="#{dukesBDay.absAgeDiff}" rendered="#{dukesBDay.ageDiff > 0}"/>
<h:outputText value=" #{bundle.Year} " rendered="#{dukesBDay.ageDiff == 1}"/>
<h:outputText value=" #{bundle.Years} " rendered="#{dukesBDay.ageDiff > 1}"/>
<h:outputText value="#{bundle.Older}" rendered="#{dukesBDay.ageDiff > 0}"/>

The outputText tags on the response.jsp page use the rendered attribute to control which
one of the tags will actually have their content rendered. Let's take a look at the set of
outputText tags:

The first tag will yield the text “You are”.

The rendered attribute of the second outputText tag references an expression that tests if the
ageDiff property of DukesBDay is equal to zero. If this expression returns true then the
message referenced by the tag's value attribute will be rendered. This message is “the same age
as Duke”.

The value attribute of the third tag references the absAgeDiff property of DukesBDay. This
property holds the absolute value of the age difference. The expressions referenced by the
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rendered attributes of the fourth and fifth tags test whether or not the age difference is equal to
-1 or less than –1 to determine whether the age difference is only one year or more than one year
so that “year” or “years” is rendered appropriately. The sixth tag tests if ageDiff is less than
zero. If this is true then the absolute value of the age difference is rendered along with the
message “younger than Duke!”. So an example message that can be rendered by this group of
tags is:

You are 10 years younger than Duke!

The last group of tags work similarly to the previous set of tags, except that their rendered
attributes test for age differences greater than zero, indicating that the user is older than Duke.

Before the ending </h:form> tag, add the following paragraph tag and commandButton tag to
render a button used for returning to the greeting.jsppage.
<p><h:commandButton id="back" value="#{bundle.Back}" action="success"/>

Save the file by selecting File → Save.

Building, Packaging, Deploying, and Running the
firstcup Enterprise Application
In this section, you will build the DukesBirthdayBean and the firstcup web client, package
them into an EAR file, deploy the EAR file to the server, and run the application.

▼ Prepare the Deployment Descriptor
In this task, you will remove some extra parameters from the deployment descriptor of the
firstcup-war module. NetBeans IDE generates these parameters, but this example doesn't
need them.

Expand the firstcup-warmodule in the Projects pane.

Expand the Configuration Files directory.

Double-click web.xml.

Click General at the top of the editor window.

Select the plus sign next to Context Parameters.

From the table of context parameters, select the first context parameter in the table and click
Remove.

Repeat step 6 until all context parameters are removed.
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Click XML at the top of the editor window.

Remove the entire welcome-file-list element and all its contents.

Save the file by selecting File→Save from the menu bar.

▼ Build and Package the firstcup Enterprise Application
While performing this task, you'll build and package the DukesBirthdayBean enterprise bean
and the firstcup web client into an EAR file, firstcup.ear, in the dist directory.

Select firstcup in the Projects tab.

Right-click firstcup and select Build Project.

▼ Deploy the firstcup Enterprise Application
While performing the previous task, you packaged the DukesBirthdayBean enterprise bean and
firstcup web client into the firstcup.ear file. Now you'll deploy them to the GlassFish
Server.

Select firstcup in the Projects tab.

Right-click firstcup and select Deploy Project.

▼ Run the firstcup Application
This section describes how to run the firstcup application.

Launch an internet browser.

Enter the following URL in the address field of the browser:
http://localhost:8080/firstcup

Enter your birth date in the Your birthday text field. Make sure you use the date pattern
specified on the page: MM/dd/yyyy.

Click Submit.

After the response.jsppage is launched, click Back to return to the greeting.jsppage.
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Building, Packaging, and Deploying and
Running the Example Application

This chapter details how to build, deploy, and run the pre-coded example application included
in the firstcup download bundle using the Ant build tool. If you want to build, deploy, and run
the example that you built in the previous chapter, use NetBeans IDE rather than the Ant build
tool by following the instructions in the previous chapter.

This chapter covers the following topics:

■ “Building and Packaging the Example Application” on page 45
■ “Deploying the Example Application” on page 46
■ “Running the Web Client” on page 47
■ “Undeploying the Application” on page 47

Building and Packaging the Example Application
This section describes how to build the example application.

Building and Packaging the Example Application
Using Ant

▼ Build and Package firstcup-dukes-age Using Ant
This task builds firstcup-dukes-age and creates a WAR file, firstcup-dukes-age.war in the
dist directory.

Verify that you have added the Ant build tool that comes with the Application Server to your
path. The location is the lib/ant/bindirectory of your Application Server installation.

In a terminal, go to <INSTALL>/firstcup/example/firstcup-dukes-age.
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Enter the following command:
ant

You should see Build Successful when the command finishes.

▼ Build and Package DukesBirthdayBean and firstcup Using Ant

In a terminal, go to <INSTALL>/firstcup/example/firstcup.

Enter the following command:
ant

You should see Build Successful when the command finishes.

Deploying the Example Application
The DukesBirthdayBean enterprise bean and firstcup web client were packaged in
firstcup.ear. Now you'll deploy them to the GlassFish Server.

▼ Deploy firstcup-dukes-age.war Using Ant
This task gives instructions on deploying firstcup-dukes-age.war using Ant.

Start the Application Server if you haven't already. Refer to your Application Server
documentation if you are not sure how to start the server.

In a terminal go to <INSTALL>/firstcup/example/firstcup-dukes-age.

Enter the following command:
ant deploy

You should see Build Successful when the command finishes.

▼ Deploy firstcup.ear Using Ant
This task gives instructions on deploying firstcup.ear using Ant.

In a terminal go to <INSTALL>/firstcup/example/firstcup.

Enter the following command:
ant deploy

You should see Build Successful when the command finishes.
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Running the Web Client
This section describes how to run the firstcup application.

To run the application, do the following.

▼ Run the firstcup Application
Launch an internet browser.

Enter the following URL in the address field of the browser:
http://localhost:8080/firstcup

Enter your birth date in the Your birthday text field. Make sure you use the date pattern
specified on the page: MM/dd/yyyy.

Click Submit.

After the response.jsppage is launched, click Back to return to the greeting.jsppage.

Undeploying the Application

▼ Undeploy with Ant
Go to the <INSTALL>/firstcup/example/firstcup directory.

Run ant undeploy.

Go to the <INSTALL>/firstcup/example/firstcup-dukes-age directory.

Run ant undeploy.

▼ Undeploy with asadmin
Run asadmin undeploy firstcup-dukes-age.

Run asadmin undeploy firstcup.
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Next Steps

This chapter points the user at additional resources for learning more about enterprise
application architecture and the Java EE platform.

The Java EE Tutorial
The Java EE Tutorial (http://docs.oracle.com/javaee/5/tutorial/doc/) documents the
technologies that make up the Java EE platform. The Java EE Tutorial describes each piece of
the platform in detail, and includes code examples that demonstrate how to use each piece of
the platform.

More Information on the Java EE Platform
For more information on the Java EE platform, see these resources:

■ The Java EE site (http://www.oracle.com/technetwork/java/javaee/overview/
index.html)

■ GlassFish (https://glassfish.java.net)
■ The Aquarium (http://blogs.oracle.com/theaquarium/)
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