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Preface

The Oracle® Java ME SDK is a mobile and embedded application development tool 
available as a plugin to the NetBeans IDE.

The Oracle Java ME SDK provides supporting tools and sample implementations for 
the latest in Java ME technology. It provides support for recent versions of the 
Connected Limited Device Configuration (CLDC), Information Module Profile - Next 
Generation (IMP-NG), and Connected Device Configuration (CDC) platforms.

Audience 
This document is intended for Java ME application developers.

Documentation Accessibility
For information about Oracle's commitment to accessibility, visit the Oracle 
Accessibility Program website at 
http://www.oracle.com/pls/topic/lookup?ctx=acc&id=docacc.

Access to Oracle Support
Oracle customers have access to electronic support through My Oracle Support. For 
information, visit 
http://www.oracle.com/pls/topic/lookup?ctx=acc&id=info or visit 
http://www.oracle.com/pls/topic/lookup?ctx=acc&id=trs if you are 
hearing impaired.

Conventions
The following text conventions are used in this document:

Convention Meaning

boldface Boldface type indicates graphical user interface elements associated 
with an action, or terms defined in text or the glossary.

italic Italic type indicates book titles, emphasis, or placeholder variables for 
which you supply particular values.

monospace Monospace type indicates commands within a paragraph, URLs, code 
in examples, text that appears on the screen, or text that you enter.
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Related Documents
For more information, see the following documents:

■ See Table 15–1 for supported API documentation links. 

■ To see documentation for the Oracle Java Wireless Client and CLDC Hotspot go to 
http://docs.oracle.com/javame/mobile.html and look under 
Documentation for Device Makers

■ For legacy SDK, documentation, see:

http://docs.oracle.com/javame/developer.html

Legacy Sun Java Wireless Toolkit documentation is also available from this site.
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1Before You Begin

The Oracle® Java Micro Edition (Java ME) Software Development Kit (SDK) is a 
natural starting point for learning and using Java ME technology. The focus of the SDK 
is to provide emulation and deployment assistance during the development process. 
This chapter introduces the SDK and provides a quick introduction to using the SDK

Using this simple yet powerful tool you can create, edit, compile, package, and sign an 
application. After testing your application in the Oracle Java ME SDK emulation 
environment, you can move to deploying and debugging on an external device.

This chapter provides information you need to ensure that your Microsoft Windows 
XP (32-bit) or Windows 7 (32-bit or 64-bit) platform is correctly set up for working 
with Oracle Java ME SDK. Both Windows XP and Windows 7 must include the most 
recent Microsoft service packs.

Installing the Java SE Platform
To properly run the Java ME SDK software and its associated Tools, you must have 
Java Platform, Standard Edition (Java SE), Version 7, Update 11 (or later) installed on 
your computer. 

This guide assumes you have already installed the Java SE platform. If you have not 
installed Java SE, you can download it from the following location:

http://www.oracle.com/technetwork/java/javase/downloads

The Java SE platform must also be in your PATH.

Setting and Verifying Your Java SE PATH
To verify if Java SE platform is set in your PATH:

1. In the Windows command line, type:

C:\>echo %PATH%

2. If Java SE is properly installed, you see a path to the default installation directory:

C:\>Program Files\Java\jdk1.7.0_x

3. If not, you need to add Java SE to your PATH. 

4. Set the Java SE variable, JDK_DIR:

Note: Setting the PATH may require using a Windows short name.  
To see top-level Windows short names, type C:\>dir /x
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C:\>set JDK_DIR=C:\Program Files\Java\jdk1.7.0_13

5. Add JDK_DIR to your PATH:

C:\>set PATH=%PATH%;%JDK_DIR%\bin

6. To verify the version of your Java SE platform, type:

C\:>java -version

The version number shown in the output should be version 1.7.0_11 or higher.

Installing the Java ME SDK Platform
Follow these steps to install the Java ME SDK 3.3. 

1. If you have previously installed an earlier version of Java ME SDK, uninstall the 
previous version as shown below.

■ If you have Java ME SDK data to save, please copy it to a safe location before 
continuing.

■ In the Windows system tray, right click on the emulator icon and choose Exit.

■ From the Windows Programs menu, select the previous version and choose 
Uninstall from the submenu. The Installer opens.

■ On the first page check the option to remove the user data directory.

■ Follow the prompts.

2. Download the SDK from:

http://www.oracle.com/technetwork/java/javame/javamobile/down
load

3. Double-click the executable. When the installer starts, follow the prompts.

Installing and the Starting the NetBeans IDE
If you do not already have the NetBeans 7.3 IDE installed on your system, you can 
download it here:

http://dlc.sun.com.edgesuite.net/netbeans/7.3/final/

Next, optionally select your Language and Platform, and then download the version 
that contains all supported technologies. The approximate size of executable 
distributive is 198 MB. Once you have downloaded the NetBeans installation module, 
do the following:

1. Unzip the NetBeans distribution zip file into the C:\Program Files directory. 

2. In the C:\Program Files\NetBeans 7.3\bin directory, click on netbeans.exe to 
launch NetBeans, as shown in Figure 1–1.

Note: If you are installing Java ME SDK for the first time, skip to 
Step 2.
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Figure 1–1 The NetBeans Start Screen

The Oracle Java ME SDK is also a plugin to the Eclipse IDE. For more information on 
using Java ME SDK with the Eclipse IDE, see Oracle Java Micro Edition Software 
Development Kit Developer’s Guide for Eclipse. 
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2Installing Plugins

This chapter describes the NetBeans integrated development environment. NetBeans 
provides a rich, visual environment for developing embedded applications and 
numerous tools to improve the programming process.

Oracle Java ME SDK provides two plugins for working with NetBeans:

■ Java ME SDK Tools plugin

■ Java ME SDK Demos plugin

The Java ME SDK Demos plugin is optional, but recommended.

Downloading Oracle Java ME SDK Plugins
 To download the Oracle Java ME SDK Plugins file for NetBeans 
(oracle-jmesdk-3-3-rr-nb-plugins.zip) go to the following location:

http://www.oracle.com/technetwork/java/javame/javamobile/download/sdk

Installing Oracle Java ME SDK Plugins
There are two ways to install the Oracle Java ME SDK Plugins:

■ "Installing Plugins Using the Update Center"

■ "Installing NetBeans Plugins Manually"

To get the plugins ready for installation, start NetBeans as described in "Installing and 
the Starting the NetBeans IDE."

Installing Plugins Using the Update Center
To install the NetBeans Plugins using the NetBeans Update Center:

1. Select Tools > Plugins to open the NetBeans Plugins manager, as shown in 
Figure 2–1.

Note: Using the NetBeans Update Center to install the plugins is 
recommended. However, installing the plugins manually also works.
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Figure 2–1 The NetBeans Plugins Manager

2. Click the Settings tab. This displays the available update centers, as shown in 
Figure 2–2.
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Figure 2–2 Adding a Plugin Portal

3. Click the Add button. In the new window, type a provider name and a URL for the 
location that contains the plugin center files, as shown in Figure 2–3.

Figure 2–3 Creating a New Update Center

4. When plugins are detected, they are displayed on the Available Plugins tab. If you 
do not see them, click the Check for Updates button.

■ Locate the Oracle Java ME SDK plugins.

■ In the Install column check the desired plugins, then click the Install button. 
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Figure 2–4 The Oracle Java ME SDK Plugins

5. Restart NetBeans.

6. In the Plugins Manager Settings tab, enable all available update centers.

7. In the Installed tab, check Show details (above the plugin list) and sort by category 
to easily find the Java ME SDK Tools plugins.

■ Make sure the plugins you installed are active (with a green check mark), as 
shown in Figure 2–5.

■ If the Oracle Java ME SDK plugins are not Active, check the Select boxes for 
the plugins and click Activate.

Figure 2–5 The Plugins Manager Installed Tab

The Oracle Java ME SDK is ready to use. For more information on how to verify your 
plugin installation, see "Verifying Your Installation."

Installing NetBeans Plugins Manually
To install the NetBeans Plugins manually.

1. Extract the contents of the NetBeans Plugins file to a directory on your local 
machine. Make note of the location.

2. Open the NetBeans Plugins Manager. Select:

Tools > Plugins

3. Uninstall previous plugins.

■ Go to the Installed tab and click Show details, as shown in Figure 2–6. 

■ Check Java ME SDK Tools and Java ME SDK Demos.

Note: If the previous plugins have already been uninstalled, go to 
Step 6.
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Figure 2–6 The NetBeans Plugins Manager Window

■ Click Uninstall. 

■ Restart when requested.

4. Re-open the Plugins Manager and click the Downloaded tab, as shown in 
Figure 2–7.

5. Click the Add Plugins button.

Figure 2–7 The Downloaded Tab and Add Plugins Button

6. In the file browser, go to the directory in which you have extracted the contents of 
the NetBeans Plugins. 

7. Select all the .nbm files and click Open, as shown in Figure 2–8.
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Figure 2–8 Adding Plugins

8. Go to the Downloaded tab and select all downloaded plugins, as shown in 
Figure 2–9, and click Install.

Figure 2–9 Selecting Downloaded Plugins
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9. When the NetBeans IDE Installer screen is displayed, as shown in Figure 2–10, 
click Next. 

■ Accept the license terms and click Install.

■ If additional Validation screens appear, click Continue.

Figure 2–10 The NetBeans IDE Installer

10. Click Finish to restart NetBeans.

11. Select Tools > Plugins to display the Plugins screen.

12. In the Installed tab, check Show details and click Category to sort the plugins. 

■ Find the Java ME SDK Tools and Java ME SDK Demos plugins in the list.

■ Make sure the plugins you installed are Active (you should see a green check 
mark), as shown in Figure 2–6.

■ If the Oracle Java ME SDK plugins are not Active, check the Select boxes for 
the plugins and click Activate.

13. When your Oracle Java ME SDK plugins are Active, click Close.

The Oracle Java ME SDK is ready to use. For more information on how to verify 
your plugin installation, see "Verifying Your Installation."
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Verifying Your Installation
Once you have installed the Oracle Java ME SDK Plugins into NetBeans (using the 
Update Center or by manual installation), the Oracle Java ME SDK platform is 
installed into the NetBeans IDE. To verify a successful installation, do the following:

1. To verify the Active Device Manager, select Tools > Java ME > Active Device 
Manager, and select the latest version (Oracle Java ME SDK 3.3).

2. To view available Oracle Java ME SDK 3.3 devices, select Tools > Java ME > Device 
Selector. The ME SDK devices are listed, as shown in Figure 2–11. 

Figure 2–11 The Device Selector

3. To display the new Oracle Java ME SDK platform, choose Tools > Java Platforms. 
This displays the Java Platform Manager with the new platform, as shown in 
Figure 2–12.
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Figure 2–12 The Java Platform Manager

The Oracle ME SDK Platform is now ready for you to work with, to create a new 
project and develop code.

Quick Start
The following tips offer some hints for getting started as quickly as possible.

■ Access the documentation. The online help is the primary documentation for the 
SDK. Many windows and dialogs feature a help button that opens 
context-sensitive help in the help viewer. You can also type F1. 

Select Help > Help Contents to open the JavaHelp Online Help viewer. 
Remember to use the search capability and the index to help you find topics.

■ Run sample projects. Running sample projects is a good way to become familiar 
with the SDK.   See "Running a Project" for a general overview of how to run a 
project. 

■ See the Projects window and the Files window for a visual overview of the logical 
and physical layout of a project. When viewing items in the tree, use the context 
menu (right-click) to see the available actions. See "Working With Projects."

■ A project has a default device that is used when you run it from the toolbar (the 
green arrow), Run > Run Project, or Run on the project's context menu. To see a 
project’s default device, right-click the project and select Properties. Select the 

Note: If you require a larger font size, the help topics are also 
available as a printable PDF and a set of HTML files. 
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Platform category to see the default device displayed in the Device field. To reset 
the Device make another choice from the drop down menu.

■ To run an application on different devices without changing the default device, 
right-click on the project and select Run With from the context menu. Select a 
different device and click OK.

■ The emulator is an independent process, and when it has started it is a separate 
process from the build process running in NetBeans. Stopping the build process or 
closing a project does not always affect the application running in the emulator. 
You must be sure to terminate the application (the emulator can remain open). See 
"Running a Project."

■ The SDK provides two unique emulator instances for most devices. For example, 
IMPNGDevice1 and IMPNGDevice2 are the same except for the device number 
and the phone number, so you can perform tests that require two devices 
(messaging, for example) without customization. If you want to create your own 
device, see "Using the Custom Device Editor."
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3Platforms

This chapter describes the Oracle Java ME SDK technology platforms, also called 
stacks. They are: "CLDC with MIDP," "IMP-NG," and "CDC," as discussed in 
"Emulation Platforms."

A project runs on a particular emulation platform. The Device Manager determines 
whether a device is appropriate for your project based on the platform, the APIs your 
application uses, and a set of device properties. If you run an application and an 
appropriate emulator or device is currently running, the SDK automatically installs 
and runs your application in the current device so that you do not have to launch the 
emulator repeatedly.

Emulation Platforms
An emulator simulates the execution of an application on one or more target devices. 
An emulation platform enables you to understand the user experience for an 
application and test basic portability. For example, a platform enables you to run 
applications on several sample devices with different features, such as screen size, 
keyboard, runtime profile and other characteristics. 

Oracle Java ME SDK provides the following emulation platforms: 

■ CLDC with Mobile Information Device Profile (MIDP)

■ CLDC with MIDP, Information Module Profile - Next Generation (IMP-NG) subset

■ CDC with Advanced Graphics and User Interface (AGUI)

■ CDC with Personal Basis Profile (PBP)

All platforms include predefined devices with different screen sizes, runtime profiles, 
and input methods. 

See "CLDC with MIDP," "IMP-NG," and "CDC."

CLDC with MIDP
CLDC/MIDP applications conform to the following specifications: 

■ Connected Limited Device Configuration 1.1

http://jcp.org/en/jsr/detail?id=139

■ Mobile Information Device Profile 2.1

http://download.oracle.com/otndocs/jcp/midp-2.1-mrel-oth-JSpec

■ All the JSRs listed in "JCP APIs"
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CLDC/MIDP applications are targeted for devices that typically have the following 
capabilities:

■ A 16-bit or 32-bit processor with a clock speed of 16MHz or higher

■ At least 160 KB of non-volatile memory allocated for the CLDC libraries and 
virtual machine

■ At least 192 KB of total memory available for the Java platform

■ Low power consumption, often operating on battery power

■ Connectivity to some kind of network, often with a wireless, intermittent 
connection and limited bandwidth

Typical devices might be cellular phones, pagers, low-end personal organizers, and 
machine-to-machine equipment. In addition, CLDC can also be deployed in home 
appliances, TV set-top boxes, and point-of-sale terminals. 

The SDK provides two default emulators to support CLDC: 

■ ClamshellJavaMEPhone1

A flip phone with a primary display and a secondary display.

■ JavaMEPhone1 and JavaMEPhone2

A flat touch screen device.

These devices support CLDC 1.1, MIDP 2.1, and optional packages for JSRs 75, 82, 135, 
172, 177, 179, 184, 205, 211, 226, 234, 239, 256, 257, and 280.

See "Running MIDP and CLDC Sample Projects," "Create a MIDP Project," and 
Chapter 7, "Working With Devices."

IMP-NG
JSR 228 describes the Information Module Profile - Next Generation, referred to as 
IMP-NG. This JSR extends and enhances JSR 195: Information Module Profile. 

The IMP-NG implementation depends upon CLDC 1.0. It is a strict subset of MIDP 2.0 
that excludes MIDP 2.0 graphical display capabilities, resulting in a smaller footprint 
appropriate for Information Modules (IMs). Potential devices for CLDC with IMP-NG 
might be modems, home electronics devices, or industrial metering devices. 

An IMP-NG application is an IMlet, and multiple IMlets in a single JAR file form an 
IMlet suite. When creating an IMlet project you follow the same process as that you 
use to create a Java ME Mobile Application project and select an IMP-NG device. The 
device selection determines the supported JSRs.

The IMP-NG stack supports the following JCP APIs: JSRs 75, 120, 172, 177, 179, 257, 
and 280. In addition, Oracle provides APIs to support IMP-NG development, as 
described in "Oracle APIs."

The Java ME SDK implementation provides IMP-NG emulation, on-device tooling 
connectivity to external devices, and Attention (AT) Command support. The SDK 
emulator supports IMP-NG with IMPNGDevice1 and IMPNGDevice2 skins and 
provides simple interfaces for Inter-Integrated Circuit (I2C), Serial Peripheral Interface 
(SPI), General Purpose Input/Output (GPIO), and Memory-mapped I/O (MMIO) 
buses. The emulator’s external event generator provides a way for you to inject calls to 
emulate AT Commands, alter basic pin and port information for GPIO, and memory 
block values. 

See "Running IMP-NG Sample Projects."
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CDC
A Java ME Platform, Connected Device Configuration (CDC) 
(http://jcp.org/en/jsr/detail?id=218) application is an application targeted 
for network-connected consumer and embedded devices, including high-end mobile 
phones, smart communicators, high-end PDAs, and set-top boxes. 

Devices that support CDC typically include a 32-bit microprocessor or controller and 
make about 2 MB of RAM and 2.5 MB of ROM available to the Java application 
environment.

CDC is based upon the open source project phoneME Advanced, found at 
http://java.net/projects/phoneme. A CDC application conforms to the 
Connected Device Configuration with a set of profiles that include Personal Basis 
Profile, Foundation Profile, and AGUI: 

■ CDC 1.1 with PBP 1.1 (http://jcp.org/en/jsr/detail?id=217)

■ Foundation Profile 1.1 
(http://jcp.org/aboutJava/communityprocess/final/jsr219/index
.html)

■ AGUI 1.0 (http://www.jcp.org/en/jsr/detail?id=209)

The SDK provides three default emulators to support CDC:

■ Default CdcPbpPhone1

CDC 1.1, PBP 1.1, Foundation Profile (FP) 1.1

■ VgaAGUIPhone1

CDC 1.1, PBP 1.1, FP 1.1 and AGUI 1.0

■ VgaCdcPhone1

CDC 1.1, PBP 1.1, FP 1.1

See "Project Types" and "Viewing Device Properties" for more information on project 
types and device properties. 

Managing Java Platforms
To view the Java Platform Manager, click the Tools menu and select Java Platforms. 
Alternatively, right-click a project, choose Properties from the context menu, select the 
Platform category, and select the Manage Emulators button to open the Java Platform 
Manager.

The Java Platform Manager is a tool for managing different versions of the Java 
Development Kit (JDK) and customizing Java platforms that your applications depend 
on. You can add source files and Javadoc documents to the existing platforms. 

The Oracle Java ME SDK pre-registers CDC, J2ME, and Java SE (the JDK serves as the 
default platform) for version 3.3. These platforms have similar options:

■ Devices. (J2ME) View all the CLDC and IMP-NG devices that the Device Manager 
has discovered. Click Refresh to reconfigure the platform and refresh the list.

■ Classes. (CDC) View the platform's classpaths. A class’s location in the list 
determines its place in the classpath. For the CDC platform, you can add a JAR or 
folder containing additional classes. You can also use the Move Up and Move 
Down buttons to change the class position.
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■ Sources. (CDC, J2ME, and Java SE) Add JAR files or source files to the Sources tab 
to register source code.

■ Javadoc. (CDC, J2ME, and Java SE) Add Javadoc documentation to support any 
new classes or source files you have added.

■ Tools and Extensions. (For J2ME, only as Devices) See "Java ME Platforms" for 
more information.

Java ME Platforms
In the Oracle Java ME SDK the platforms are embedded Java runtimes specifically for 
resource-constrained devices. Because the NetBeans Mobility pack is installed for Java 
ME, you see the legacy 3.2 platforms coexisting with version 3.3 platforms and 
devices. Each platform has its own set of devices and optional packages.

Applications that worked in previous platform versions might not run on the current 
version, and vice versa. Follow these steps to set a project’s platform options.

1. Right-click on a project and choose Properties from the context menu.

2. Select the Platform category. Be sure that the Emulator Platform is set to version 
3.3. 

3. The device configuration should be automatically selected, but the Device Profile 
might not be explicitly selected. Be sure to choose a profile.

4. Optional. Check any optional packages that are required to support the current 
project. (If this is an IMP-NG project you also see the Oracle APIs listed as optional 
packages. See "Oracle APIs").

Click OK.

5. Rebuild the project and run.

Create a Platform for Legacy CDC Projects
The Oracle Java ME SDK version 3.3 platform name for CDC does not match the name 
in the legacy CDC toolkit and the CDC Mobility Pack. The legacy name is "Sun Java 
Toolkit 1.0 for Connected Device Configuration" while the SDK name is "CDC Oracle 
Java(TM) Platform Micro Edition SDK 3.3." To ensure a successful import, you can 
create a new platform and give it the legacy name. 

The following procedure enables you to import legacy CDC projects without Reference 
errors (see "Resolving Reference Problems").

1. Click the Tools menu and select Java Platforms. Select "CDC Oracle Java(TM) 
Platform Micro Edition SDK 3.3." and in the Classes tab, note the libraries required 
for the platform.

2. Click Add Platform... .

3. Select Java ME CDC Platform Emulator and click Next.

4. On the Choose Platform page, select the SDK installation directory. Click Next.

Note: If you cannot see the 3.3 devices in the Device Selector, select 
Tools > Java ME > Active Device Manager and select Java(TM) ME 
Platform SDK 3.3.
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5. On the Platform Name page, type "Sun Java Toolkit 1.0 for Connected Device 
Configuration" in the Name field. In the Sources tab, click Add and select the 
following libraries from the SDK installation directory: agui_1.0.jar, cdc_
1.1.jar, fp_1.1.jar, pbp_1.1.jar, and secop_1.0.jar. 

Click Finish and Close.

See "Import a Legacy CDC Project" and "Resolving Reference Problems."
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4Using Sample Projects

The Oracle Java ME SDK sample projects introduce you to the emulator's API features 
and the SDK features, tools, and utilities that support the various APIs. These features 
can help you customize the sample projects or create applications of your own.

For instructions on running projects, see the following topics:

■ "Creating a Sample Project"

■ "Running a Project"

■ "Troubleshooting"

■ "Sample Project Overview"

■ "Configuring the Web Browser and Proxy Settings"

■ "Resolving Reference Problems"

■ "Running MIDP and CLDC Sample Projects"

■ "Running IMP-NG Sample Projects"

Creating a Sample Project
Sample applications are installed in a separate NetBeans plugin. Do not run or edit 
these projects directly. You create a new project that is an instance of the sample 
project. 

The default location for Oracle Java ME SDK projects is the default NetBeans project 
directory. Each project has a src directory that contains Java programming language 
source code. For example, the default location of the source code for the SMS sender 
MIDlet (example.sms.SMSSend) in WMADemo resides in the following location:

username\My Documents\NetBeansProjects\WMADemo\src\example\sms\SMSSend.jav
a

1. Click the File menu and select New Project. In the Categories window, click 
Samples and select Java ME SDK 3.3. Single-click a sample project name and click 
Next.

Note: Before using the Oracle Java ME SDK demo applications, see 
"Installation and Runtime Security Guidelines" in Appendix A. Some 
demos use network access and open ports, and do not include 
protections against malicious intrusion.  If you choose to run the 
sample projects, you should ensure your environment is secure.
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2. Accept Name and Location page default values or provide your own. Click Next.

3. Choose an emulator platform and a device. Depending on the project you choose 
to run, you might need to select a different profile (for example, you might need to 
run the MIDP 2.1 device profile rather than MIDP 2.0). Note, changing the device 
affects the possible device profiles. Click Finish.

The project is added to the Project window. 

4. Set the project’s default execution mode. Right-click on a project and select 
Properties from the context menu, then choose the Running category. 

Figure 4–1 The Project Property Screen

If you want to install the application in the emulator each time it is run, select 
Execute through OTA (Over the Air Provisioning). 

If the application does not need to be installed in the emulator, click Regular 
Execution (see "Security Domains"). 

Running a Project
Create your own project, or instantiate one of the sample projects provided with the 
SDK as described in "Creating a Sample Project."

1. Use one of the following methods to run a project:

■ Right-click the project and select Run from the context menu.

Note: If you cannot see the Project window, click the  Window 
menu and select Projects. To see console output, select Window > 
Output > Output. 
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■ To run the main project (which is shown in bold text in the Projects window), 
click the green Run button in the toolbar or press F6.   To set the main project, 
click the Run menu and select Set Main Project. Select a project from the 
dropdown menu.

■ To run an open project on a different device or to change the execution mode, 
choose the device in the Device Selector window (select Tools >Java ME > 
Device Selector). Right-click on a device and select Run Project or Run 
Project via OTA from the context menu. Pull right to see a listing of open 
projects. Only open projects that can run on the selected device are listed. (Not 
all open projects are shown in the list.)

Figure 4–2 Running a Project from the Device Selector Menu

■ To run a project on an emulator, click the Windows Start button,  open All 
Programs.  Click Java(TM) ME Platform SDK 3.3 and select Java ME SDK 
CLDC Emulator or Java ME SDK IMP-NG Emulator, then drag and drop the 
project’s JAD or JAR file onto the emulator. Click OK in the Run MIDlet (or 
IMlet) Suite dialog box.

The device emulator window opens with the demo application running. If the 
demo is a MIDlet suite you might have to choose a MIDlet to launch.

2. As the sample project runs, soft keys might be enabled below the screen on the left 
or right side. 

You use soft keys to install or launch an application, open a menu, exit, or perform 
some other action. Some demos include these instructions in the application.

See Table 4–1 or Table 4–3 for instructions on running samples.

3. When you are finished viewing the application, go to the emulator's Application 
menu and select Exit to close the emulator and stop the execution of the project's 
build script. 

When the emulator is launched, it runs as an independent process. Pressing the 
red stop button in the NetBeans Output window terminates the build script, but it 
does not close the emulator instance. You can also terminate the build script by 
clicking the X next to the progress meter at the bottom of the IDE.

Figure 4–3 Cancelling the NetBeans Build Script
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Likewise, closing the NetBeans IDE does not affect the emulator instance. In the 
emulator, click the Application menu and select Exit or press the emulator’s exit 
button (the X) on the upper right to ensure that both the emulator process and the 
project build process close.

Periodically, you might want to clear a device’s database especially after you have run 
several projects. Right-click the device and select Clean RMS storage files. When you 
run the command, a completion notice is displayed in the IDE’s status bar. 

Troubleshooting
Sometimes even a "known good" application, such as a sample project, does not run 
successfully. The problem is usually your environment.

■ Some demonstrations require specific setup and instructions. For example, if a 
sample uses web services and you are behind a firewall, you must configure the 
emulator's proxy server settings or web access fails. See "Configuring the Web 
Browser and Proxy Settings."

■ If an application must run over the air (OTA), the SDK automatically installs it in 
the device instance. See "Emulator Command Line Options."

MIDlet Suites use runMIDlet to perform the installation:

installdir\runtimes\cldc-hi\bin\runMidlet.exe

IMlet Suites also use runMIDlet to perform the installation, but from the impng 
directory:

installdir\runtimes\impng\bin\runMidlet.exe

CDC platforms install applications as follows:

installdir\runtimes\cdc-hi\bin\cvm.exe

Because these programs are launched remotely, virus checking software can 
prevent them from running. If this happens, the project compiles, but the emulator 
never opens. In the console you see warnings that the emulator cannot connect. 

Consider configuring your antivirus software to exclude runMidlet and cvm from 
checking.

Sample Project Overview
The Oracle Java ME SDK includes demonstration applications that highlight some 
technologies and APIs that are supported by the emulator. 

Most demonstration applications are simple to run. "Running a Project" contains 
instructions for running most demonstrations. Sample projects usually have some 
additional operation instructions.

Table 4–1 lists the MIDP/CLDC demonstration applications available in this release. 

Table 4–2 lists the MIDP/IMP-NG demonstration applications available in this release.

Table 4–3 lists the CDC sample projects available in this release.
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Table 4–1 MIDP/CLDC Sample Projects

Sample
Optional 
Package Description Instructions

Advanced 
Multimedia 
Supplements

JSR 234 Demonstrates 3D audio, 
reverberation, image 
processing, and camera 
control.

"Running the AdvancedMultimediaSupplements 
Sample Project"

AudioDemo MMAPI 1.1 Demonstrates audio 
capabilities, including mixing 
and playing audio with an 
animation.

"Running AudioDemo"

BluetoothDemo JSR 82 Demonstrates device 
discovery and data exchange 
using Bluetooth.

"Running the Bluetooth Demo"

CHAPIDemo JSR 211 A content viewer that also 
uses MediaHandler.

"Running the CHAPIDemo Content Browser"

CityGuide JSR 179 A city map that displays 
landmarks based on the 
current location.

"Running the CityGuide Sample Project"

ContactlessDemo JSR 257 Emulates detection of RFID 
tags.

"Using ContactlessDemo"

Demos MIDP 2.0 Includes various examples: 
animation, color, networking, 
finance, and others.

"Running the Demos Sample Project"

FPDemo CLDC 1.1 Simple floating point 
calculator.

"Running FPDemo"

Games MIDP 2.0 Includes TilePuzzle, 
WormGame, and 
PushPuzzle.

"Running Games"

JSR172Demo JSR 172 Demonstrates how to use the 
JSR 172 API to connect to a 
web service from a MIDlet.

"Run JSR172Demo"

MMAPIDemos MMAPI Demonstrates MMAPI 
features, including tone 
sequences, MIDI playback, 
sampled audio playback, and 
video.

"Running MMAPIDemos"

Multimedia MMAPI Demonstrates different video 
playback formats.

"Video"

NetworkDemo MIDP 2.0 Demonstrates how to use 
datagrams and serial 
connections.

"Socket Demo" and "Datagram Demo"

ObexDemo JSR 82 Demonstrates device 
discovery and data exchange 
using Bluetooth.

"Running the OBEX Demo"

PDAPDemo JSR 75 Demonstrates how to 
manipulate contacts, 
calendar items, and to-do 
items. Demonstrates 
accessing local files.

"Running PDAPDemo"

PhotoAlbum MIDP 2.0 Demonstrates a variety of 
image formats.

"Running PhotoAlbum"
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SATSADemo JSR 177 Demonstrates 
communication with a smart 
card and other features of 
SATSA.

Chapter 20, "JSR 177: Smart Card Security 
(SATSA)"

SATSAJCRMIDe
mo

JSR 177 Shows how to use the 
SATSA-Java Card Remote 
Invocation method.

Chapter 20, "JSR 177: Smart Card Security 
(SATSA)"

Sensors JSR 256 The SensorBrowser and 
Marbles game demonstrate 
sensor input.

"SensorBrowser" and "Marbles"

SVGContactList JSR 226 Uses SVG to create a contact 
list displayed with different 
skins.

"Running SVGContactList"

SVGDemo JSR 226 Uses different SVG rendering 
techniques.

"Running SVGDemo"

UIDemo MIDP 2.0 Showcases the breadth of 
MIDP 2.0's user interface 
capabilities.

"Running UIDemo"

WMADemo WMA 2.0 Shows how to send and 
receive SMS, CBS, and MMS 
messages.

"Running WMADemo"

XMLAPIDemo JSR 280 Uses DOM and STAX APIs to 
create an XML sample and 
SAX, DOM and StAX APIs to 
parse the sample.

Follow the instructions the application provides.

Table 4–2 IMP-NG Sample Projects

Sample Description Instructions

GPIODemo Changes the state of LEDs in an emulator or 
reference platform.

"Running the GPIODemo"

I2CDemo Writes data to a slave and then retrieves it. "Running the I2CDemo"

NetworkDemoIMPNG Allows connection and  communication 
between a server and a client instance.

"Running the 
NetworkDemoIMPNG"

PDAPDemoIMPNG Demonstrates management of a file system in 
the emulator.

"Running the PDAPDemoIMPNG"

Pulse Counter (Data 
Collection) Demo

Sends pulses to a counter and tracks them 
when they arrive using a timestamp.

"Running the Pulse Counter (Data 
Collection) Demo"

LightTrackerDemo Controls LEDs on a reference platform. "Running the Light Tracker Demo"

SystemControllerDemo Demonstrates IMlet lifecycle on a reference 
platform.

"Running the System Controller 
Demo"

Table 4–1 (Cont.) MIDP/CLDC Sample Projects

Sample
Optional 
Package Description Instructions
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Configuring the Web Browser and Proxy Settings
If you are behind a firewall you must configure the proxy server so that MIDP 
applications using web services can succeed. 

The settings are typically the same as those you are using in your web browser.

1. Select Tools > Options > General. 

2. Choose a Proxy Setting:

■ No Proxy

■ Use System Proxy Settings

■ Manual Proxy Settings

To set the HTTP Proxy, fill in the proxy server address field and the port 
number. The HTTP Proxy Host is the host name or numeric IP address of the 
proxy server used to connect to HTTP and FTP sites. The Proxy Port is the port 
number of the proxy server. 

To set the HTTPS or Socks proxy, click More and fill out the Advanced Proxy 
Options form.

Resolving Reference Problems
Sometimes when you open a project you can see it has a reference warning. In the 
Projects tab the project name is red, and the icon shows a warning symbol, as seen 
below: 

Figure 4–4 Project Warning Sign

Usually this warning means the project refers to a platform, file, or library that cannot 
be found. 

Table 4–3 CDC Sample Projects

Sample
Optional 
Package Description Instructions

AGUIJava2DDemo JSR 209 This standalone application is a Java 
SE application adapted for the CDC 
environment. It demonstrates the 
graphical and animation capabilities of 
the Java 2D™ API.

Click the blue arrows to page 
through the various images and 
animations. The applications focus 
on curves. Click the AA icon to see 
how antialiasing affects 
appearance.

AGUISwingSet2 JSR 209 Functional tools such as buttons, 
sliders, and menus implemented with 
Swing.

Click through the tabs to view the 
controls and animations.

Note: CDC emulators do not work through a proxy. 
Communications such as downloading images from the Internet 
fail on CDC emulators.
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If you are using an old project it might be referring to a platform or device that is not 
installed. In this case, edit the project properties and select an available platform and 
device as described in "Java ME Platforms," then rebuild the project.

If the problem is not the platform, right-click the project and choose Resolve Reference 
Problems.

Figure 4–5 Resolve Reference Problems Screen

The window displays the missing file, the problem, and a possible solution. In this 
case the project probably used a literal path to the file keystore.ks. Clicking the 
Resolve... button opens a file browser so you can find the missing keystore file. The 
default location is as follows:

installdir\runtimes\cldc-hi\lib (for CLDC)

installdir\runtimes\impng\lib (for IMP-NG)

installdir\runtimes\cdc-hi\lib (for CDC)

Locate and select the file. You receive confirmation that the problem is resolved, and 
you can now click Close.

Running MIDP and CLDC Sample Projects
This topic gathers MIDP and CLDC samples that are not discussed in separate 
chapters. This is the case when a sample uses many JSRs, or when a supported JSR 
does not have any special implementation details.

■ "Running the AdvancedMultimediaSupplements Sample Project"

■ "Running the Demos Sample Project"

■ "Running FPDemo"

■ "Running Games"

■ "Running Network Demo"

■ "Running PhotoAlbum"
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■ "Running UIDemo"

For other CLDC demos, see Table 4–1.

Running the AdvancedMultimediaSupplements Sample Project
This MIDlet suite demonstrates the power of JSR 234 Advanced Multimedia 
Supplements (AMMS). It consists of the following MIDlets:

■ "Image Effects"

■ "Music Effects"

■ "Camera"

■ "Moving Helicopter"

Image Effects
This MIDlet demonstrates standard image processing operations. 

■ Launch the Image Effects MIDlet. 

■ Choose input and output image formats, and press Done. The input image and 
output images are displayed simultaneously.

■ Choose an effect from the Menu and click the Done button to apply a 
transformation, effect or overlay. The source image is shown above and the 
processed image is shown below. Some items, Set Transforms, for example, can 
perform several operations in a single transaction. 

The menu options are as follows:

■ Reset - Set transforms, effects, and overlays to the initial state.

■ Monochrome Effects - Activate grayscale rendering.

■ Negative Effect -Reverse dark and light areas.

■ Set Formats - Select an input object type and an output image format.

■ Set Effect Order - Specify the order in which transforms, effects and overlays 
are applied.

■ Set Transforms - Change width and height scale, border, and rotation options.

■ Set Overlays - Specify the color and orientation of a color block overlay.

Music Effects
Demonstrates the advanced audio capabilities of the Advanced Multimedia 
Supplements. As an audio file loops continuously, you can adjust the volume, and 
reverberation settings.

Camera
This MIDlet demonstrates how the Advanced Multimedia Supplements provide 
control of a device’s camera. The screen shows the viewfinder of the camera 
(simulated with a movie). You can use commands in the menu to change the camera 
settings and take and manage snapshots.

■ Zoom settings - digital and optical zoom settings 100-300 in increments of 20. 
Make a selection and press Back.
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■ View gallery - View a list of the snapshots stored in: 
username\javame-sdk\3.3\work\devicename\appdb\filesystem\root1. Choose 
Display to see the snapshot. You have the option to delete the file from disk.

■ Set flash mode - Off, AUTO, AUTO_WITH_REDEYEREDUCE, FORCE, FORCE_
WITH_REDEYEREDUCE, FILLIN.

■ Change F_Stop number - 0, 400, 560, 800, 1600.

■ Choose exposure modes - Preset modes are auto, landscape, snow, beach, sunset, 
night, fireworks, portrait, backlight, spotlight, sports, text.

■ Disable/Enable shutter feedback.

■ Exit - Close this MIDlet and return to the initial window.

■ Snapshot setting - Set whether to display the snapshot on the screen or print it to a 
file. Snapshots are stored in:

username\javame-sdk\3.3\work\devicename\appdb\filesystem\root1

Moving Helicopter
Simulates a helicopter (red dot) flying around a stationary observer (blue dot). Use 
headphones for best results. You can control the parameters of the simulation with the 
soft menu options: Volume, Location settings, Spectator orientation, and Distance 
Attenuation settings. After viewing menu options, press the close button (the X on the 
right) to return to the helicopter scenario.

With the Location settings be aware that supplying large values for the screen width or 
flight altitude means the helicopter might be out of range - that is, it flies off the screen 
and you might not be able to hear it. 

For spectator orientation stereo headphones or speakers help detect the difference in 
position, assuming your volume and location settings put the helicopter in audible 
range. The same is true for the Distance Attenuation settings, which enable you to 
control the doppler effect.

Running the Demos Sample Project
This demo contains several MIDlets that highlight different MIDP features. Click or 
use the navigation keys to highlight a MIDlet, then choose the Launch soft key.

■ "Colors"

■ "Properties"

■ "Http"

■ "FontTestlet"

■ "Stock"

■ "Tickets"

■ "ManyBalls"

■ "MiniColor"

■ "Chooser"

■ "HttpExample"

■ "HttpView"

■ "PushExample"
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Colors
This application displays a large horizontal rectangle that runs the width of the screen. 
Below, ten small vertical rectangles span the screen. Finally, three horizontal color bars 
indicate values for blue, green, and red (RGB). Values are expressed as decimal (0-255) 
or hexadecimal (00-ff) based on the first menu selection.

■ To select a vertical bar to change, use the up navigation arrow to move to the color 
bars. Use the right navigation arrow to highlight a color bar. The large rectangle 
becomes the color of the selected bar. 

■ Use the up or down selection arrows to choose the value to change (red, green, or 
blue). Use the left or right arrow keys to increase or decrease the selected value. 
The second menu item enables you to jump in increments of 4 (Fine) or 32 (coarse).

■ You can change the color on any or all of the vertical bars.

Properties
This MIDlet displays your system property values. The output is similar to the 
following values:

Free Memory = 2333444
Total Memory = 4194304
microedition.configuration = "CLDC-1.1"
microedition.profiles = "MIDP-2.1"
microedition.platform = "j2me"
microedition.locale = "en-US"
microedition.encoding = "IS08859_1"

Http
This test application uses an HTTP connection to request a web page. The request is 
issued with HTTP protocol GET or POST methods. If the HEAD method is used, the head 
properties are read from the request.

Preparing to Run the Demo

Before beginning, examine your settings as follows.

■ Right-click on Demos and select Properties. 

■ Select the Running category. 

■ Select Regular Execution.

■ Check Specify the Security Domain and select Maximum. 

■ Click OK. 

■ If you are using a proxy server, you must configure the emulator's proxy server 
settings as described in "Configuring the Web Browser and Proxy Settings." The 
HTTP version must be 1.1.

■ If you run antivirus software, it might be necessary to create a rule that allows 
your MIDlet to permit connections to and from a specific website. See 
"Troubleshooting."

Running the Demo

Launch the Http MIDlet. To test, choose the Menu soft key and choose Get, Post, or 
Head to test the selected URL. 
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Http Test returns the information it obtains. If the information fills the screen use the 
down arrow to scroll to the end. The amount of information depends on the type of 
request and on the amount of META information the page provides. To provide body 
information or content, the page must declare CONTENT-LENGTH as described in RFC 
2616.

Using Menu Options

Use the Menu soft key to choose an action. The Menu items vary depending on the 
screen you are viewing.

■ Choose Qwerty to set the input type. This activates a submenu with the options 
Qwerty, 123, Abc, Virtual, and Symbols. This choice is present if you have the 
option to edit a URL (select Choose, then click the Add soft button).

■ Choose GET or press the Get soft key to retrieve data from the selected URI.

■ Choose POST to retrieve the post information from the server handling the selected 
page.

■ Choose HEAD to retrieve only the META information from the headers for the 
selected URI.

■ Select Choose to display the current list of web pages. You can chose a different 
page or add your own page to the list. To specify a new URL, click the Add soft 
button. The screen displays http://. Type in the rest of the URL. If necessary 
select Qwerty on the menu and choose a different input method. Be sure to end 
with a slash (/). For example http://www.internetnews.com/. Press the OK 
soft button. The Http Test screen shows your new URL and prompts for an action. 

FontTestlet
This MIDlet shows the various fonts available: Proportional, Regular, Regular Italic, 
Bold Plain, and Bold Italic. Choose 1 or 2 from the menu to toggle between the system 
font (sans serif) and the monospace font.

Stock
Like the Http demonstration, this sample uses an HTTP connection to obtain 
information. Use the same preparation steps as "Http."

Run the Demos project and launch the Stock MIDlet.

By default, the screen displays an empty ticker bar at the top. Below the ticker, the 
menu list shows four applications: Stock Tracker, What If? Alerts, and Settings. You 
must add stock symbols before you can use the first three applications.

Add Stock Symbols to the Ticker

To add a stock symbol to the ticker, use the navigation arrows to select Settings.

Select Add Stock.

The display prompts you to enter a stock symbol. Type ORCL and select the Done soft 
key. The stock you added and its current value is now displayed in the ticker. Add a 
few more stock symbols, such as IBM and HPQ. 

Change the Update Interval

By default the update interval is 15 minutes. Select Updates to change the interval. Use 
the navigation arrows to select one of Continuous, 15 minutes, 30 minutes, one hour, 
or three hours. Select the Done soft key. 

Remove a Stock
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Select Remove a Stock. You see a list of the stocks you have added. Use the navigation 
keys to select one or more stocks to remove. Select the Done soft key.

Stock Tracker

Stock Tracker displays a list of the stocks you added and their current values. Stock 
tracker displays additional information about the selected stock, for example, the last 
trade and the high and low values.

Choose a stock and press Select.

What If?

What If? is an application that asks for the original purchase price and the number of 
shares you own. It calculates your profit or loss based on the current price. 

Select a stock symbol.

Enter the purchase price and the number of shares, then press Calc.

Alerts

This application sends you a notification when the price changes to a value you 
specify. 

From the main menu, select Alerts.

Select Add.

Choose a Stock. The screen prompts, "Alert me when a stock reaches". Enter an 
integer.

The alert is placed on the Current Alerts list. To remove an alert, press Remove and 
select the alert. Select the Done soft key.

When the value is reached you hear a ring and receive a message. For example, Symbol 
has reached your price point of $value and is currently trading at $current_value. When 
the alert is triggered it disappears from the Current Alerts list.

Tickets
This demonstrates how an online ticket auction application might behave. The home 
screen displays a ticket ticker across the top. Click Done to continue to the Welcome To 
Tickets page. The Choose a Band field displays BootWare & Friends by default. 

Choose a band from the dropdown menu. The available auction appears.

Select Make a Bid from the menu. Use the arrow keys to move from field to field. Fill 
out each field, then select the Next soft key. The application asks you to confirm your 
bid. Press the Submit soft key or use the arrow keys to highlight Submit then press 
Select. You receive a Confirmation number. Click Bands to return to the Bands page.

Select set an alert, select Set an Alert from the soft Menu. In the bid field type in a 
value higher than the current bid and click the Save soft key. You are returned to the 
Choose a Band page. You can trigger the alert by making a bid that exceeds your alert 
value. Your settings determine how often the application checks for changes, so the 
alert may not sound for a few minutes.

To add a band to the Choose a Band dropdown list, select the Menu soft key and 
choose Add Bands. Type in a band name or a comma-delimited list of names. Choose 
the Save soft key. After confirmation you are returned to the Welcome To Tickets page. 
The added band(s) are displayed after the Choose a Band drop-down menu. 

Note, this is only a demonstration. To fully describe the band you must edit the 
following file:
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username\My Documents\NetBeansProjects\Demos\src\example\auction\NewTicket
Auction.java

To remove a band, click the Menu soft key and select Remove Bands. Check a box for 
one or more bands. Select the Save soft key.

To display the current settings for ticker display, updates, alert volume, and date, 
select the Menu soft key and choose 6. If desired, use the arrow keys and the select key 
to change these values. Select the Save soft key. 

ManyBalls
This MIDlet starts with one ball traveling the screen. Use the up and down arrows to 
accelerate or decelerate the ball speed (fps). Use the right or left arrows to increase or 
decrease the number of balls.

MiniColor
This MIDlet sets an RGB value. Use navigation keys to change color values.

Keyboard controls work as you would expect. First cursor up or down to highlight a 
color, and then use left and right keys to lower and raise the value of the selected color.

Chooser
The Chooser application uses a variety of controls to change text color, background 
color, and fonts.

■ Select Menu > Text Color. Change the color as described in the  "MiniColor" and 
select the OK soft button.

■ Select Menu Menu > Background Color. Change the color as described in the 
"MiniColor" and select the OK soft button.

■ Select Menu > Fonts. Change the font face, style, and size using the navigation 
and selection buttons to move through the font options. 

Cursor up and down to highlight a property, then select. The left and right keys 
jump between lists. Up and down keys move item by item.

Click OK to continue.

HttpExample
This sample makes an HTTP communication. A popup confirms the transaction was 
successful.

HttpView
This application displays three predefined URLs. 

Choose a URL, and press the soft buttons to cycle through Head, Headers, Requests, 
and Errors. 

Alternatively, Use the menu options.

PushExample
This application simulates a feed. As soon as you connect, you receive and display a 
graphic. Select Done to continue.
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Running FPDemo
FPDemo is a simple floating point calculator. 

1. Enter a number in the first field. 

2. To choose an operator, highlight the drop-down list and click to select. Cursor 
down to highlight an operator, then click to make a selection.

3. Enter a second value.

4. From the Menu, select Calc or choose 2 to calculate the result.

Running Games
This application features three games: TilePuzzle, WormGame, and PushPuzzle.

TilePuzzle. The desired result, "Rate your mind pal" is shown first. From the soft 
Menu, select 1, Start. The scrambled puzzle is displayed. The arrow keys move the 
empty space, displacing tiles accordingly (the arrow key indicates which tile to swap 
with the space). From the menu you can Reset, or change options. 

WormGame. From the soft Menu, select 1, Launch. Use the arrow keys to move the 
worm to the green box without touching the edge of the window. When the game is 
launched, use the soft menu to change game options.

PushPuzzle. Use the blue ball to push the orange boxes into the red squares in the 
fewest number of moves. 

Running Network Demo
This demo has two MIDlets: Socket Demo and Datagram Demo. Each demo requires 
you to run two emulator instances so that you can emulate the server and client 
relationship. For example, run the demo on JavaMEPhone1 and JavaMEPhone2.

Socket Demo
In this application one emulator acts as the socket server, and the other as the socket 
client. 

1. In the first emulator, launch the application, then select the Server peer. Choose 
Start. The Socket Server displays a status message that it is waiting on port 5000. 

2. In the second emulator, launch the application, select the Client peer, then choose 
Start. Choose Start to launch the client. The Socket Client displays a status 
message that indicates it is connected to the server on port 5000. Use the down 
navigation arrow to highlight the Send box. Type a message in the Send box, then 
choose the Send soft key. 

For example, in the client, type Hello Server in the Send box. Choose Send from 
the menu. The server emulator activates a blue light when the message is received. 

3. On the emulator running the Socket Server, the status reads: Message received - 
Hello Server. You can use the down arrow to move to the Send box and type a 
reply. For example, Hello Client, I heard you. From the menu, select Send. 

4. Back in the Socket Client, the status is: Message received - Hello Client, I 
heard you. Until you send a new message, the Send box contains the previous 
message you sent. 
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Datagram Demo
This demo is similar to Socket Demo. Run two instances of the emulator. One acts as 
the datagram server, and the other as the datagram client. 

1. In the first emulator, launch Datagram Demo, then select the Server peer. Choose 
Start. Initially, the Datagram Server status is Waiting for connection on port 
5555, and the Send box is empty. 

2. In the second emulator, launch Datagram Demo, select the Client peer, ensure the 
port number is 5555 and choose Start. The Datagram Client status is: Connected 
to server on port 5555. Use the down navigation arrow to highlight the Send 
box. Type a message in the Send box, then choose the Send from the menu. For 
example, type Hello datagram server. From the menu, select Send.

3. On the emulator running the Datagram Server, the status displays: Message 
received - Hello datagram server. You can use the down arrow to move to the 
Send box and type a reply to the client. 

4. In the Datagram Client, the status field displays the message received from the 
server. The Send box contains the last message you sent. Overwrite it to send 
another message.

Running PhotoAlbum
The PhotoAlbum demo displays both static and animated images. When you are 
displaying an image, you can use the Options soft menu to change the borders. If the 
image is animated, you can change the speed of the playback.

Running UIDemo
UIDemo showcases a variety of MIDP user interface element implementations. Most 
elements have some interactive capability (navigate and select) and some allow 
keypad or keyboard input. 

Input interaction is similar across demos. You can choose items from lists or type in 
data. 

This demo implements three list selection methods: 

■ Exclusive (radio buttons)

■ Multiple (check boxes) 

■ Pop-Up (a drop list).

When entering data, you can use the soft menu to apply one of the following input 
types to text boxes and fields (note, some elements do not use all input types). When a 
field is selected, the soft Menu label displays Qwerty. Open the menu and you see the 
input types numbered 1 through 5.

1. Qwerty. Any character on the keyboard

2. 123. Any numeral

3. ABC. Any letter

4. Predict. Predicts next character based on prior input

5. Symbols. Opens a list of symbols; click to make a selection.

6. Virtual. Click keys on a virtual keyboard to enter data.
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The Qwerty, 123, and ABC categories act as filters. For example, if you assign 123 to a 
field and you type "abc", nothing is entered in the field. 

When you finish a demo, select the home button to return to the UIDemo launch page:

Figure 4–6 The Home Button

CustomItem. This demo features text fields, and text fields in table form. To type in 
the table, select a cell, then click to open a text entry panel and type your input. From 
the menu, select OK. 

StringItem. Displays labels, a hyperlink, and a button. The soft menu action varies 
depending on the selected element. 

Gauge. Interactive, non-interactive, indefinite and incremental gauges.

Alert. Uses pop-ups to display alerts. Set the alarm type and the length of the timeout 
from drop lists. Select the alert type and select the Show soft button.

ChoiceGroup. Radio buttons, check boxes, and pop-ups on one screen.

List. Select exclusive, implicit, or multiple to display the list type on a subsequent 
screen.

TextBox. Use text fields, radio buttons, check boxes, and pop-ups. Select a text box 
type and press the Show button.

TextField. Text fields with the six input types. 

DateField. Set date and time using drop lists.

Ticker. A scrolling ticker.

Running IMP-NG Sample Projects
This section describes how to use demos created specifically for the IMP-NG platform 
(see "IMP-NG"). Because IMP-NG is headless the only user interface is to observe 
application status in the emulator’s external events generator, or in the Output 
window (or the console if you execute the demo from the command line).

With the exception of I2CDemo, the sample projects in this section can be run on the 
emulator or on an external device. 

See the Oracle® Java ME Embedded Getting Started Guide for the Windows Platform These 
documents are available on the Java ME documentation site at:

http://docs.oracle.com/javame/embedded/embedded.html

Expand the Oracle Java ME Embedded Version node and then the Getting Started and 
Release Notes node.

Running the GPIODemo
This demo can be run on an emulator or an external device. The implementations are 
different, as the emulator uses the external events generator, and the external device 
supports direct interaction.
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Running the GPIODemo on the Emulator
1. Run GPIO demo on an IMP-NG emulator.

2. Click the GPIO Pins tab. This view approximates the device actions.

3. Click the Tools menu and select External Events Generator to open the external 
events generator, and click the GPIO tab. A single click on a button turns on LEDs 
indicating the button pushed and the pin affected. This information is also written 
to the Output window.

Beneath each pin you can click the blue wave button to open the wave generator. 
The wave generator simulates the frequency and duration of the signal to the LED.

4. Pressing pin BUTTON 2 in the external events generator changes the state of the 
pin named LED 5. The button value "Low" corresponds to the LED value "High" 
and vice versa.

5. Pressing pin BUTTON 3 changes the  state of the port named "LEDS." 
Consequently pins bound to this port (LED 1, LED 2, LED 3, LED 4) in the 
following way:

■ If the BUTTON 3 state is "High" the port value is set to 0 and all bound pins 
are set to "Low."

■ If the BUTTON 3 state "is Low’ and the BUTTON 2 state is "Low," the port 
value is set to 2 and the pins are set to the following state: 

LED 1 - Low, LED 2 - High, LED 3 - Low, LED 4 - Low 

■ If the BUTTON 3 state "Low" and the "BUTTON 2" state is "High,"  the port 
value is set to 3 and the pins are set to the following states: 

LED 1 - High, LED 2 - High, LED 3 - Low, LED 4 - Low

Running the GPIODemo on the Reference Board
The buttons are wired by GPIO. Assuming that you are looking at the board and the 
Reset button is on the bottom left:

■ Reading from left to right, the LEDS are labeled: PH.3, PH.6, PH.7, PI.10, PG.6, 
PG.6, PG.8, and PH.2

■ The buttons, from left to right, are Reset, Wakeup, Tamper, and User.

The Wakeup button corresponds to PH.3 (Listener 1 Pin 5)

The Tamper button corresponds to PG.6 (Listener 2 Pin 6). 

The User button corresponds to PH.3 and PI.10 (Listener 3 Pin 7)

■ Pressing Tamper turns on the light (PG.6), and releasing turns off the light

■ Pressing the User button when the Tamper button is released turns on lights on for 
LEDs PH.3 and PH.6. 

■ Pressing the User button when the Tamper button is pressed (and as a result the 
light on LED PG.6 is on) turns on light on LED PH.3 only.

■ Releasing the User button turns the lights off on LEDs PH.3 and PH.6.

Running the I2CDemo
This demo is designed to work with the IMP-NG runtime for Windows. It has no user 
interaction.
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■ Launch the I2C demo.

■ In the emulator, click the I2C tab. 

The demo acquires a slave named I2C_Echo, writes data to the slave, and retrieves 
it. The demo is successful if the Sent Data and Received Data matches.

Running the NetworkDemoIMPNG
This demo is a headless version of "Socket Demo."

You can configure this demo as a server or as a client by editing the application 
descriptor. You launch two instances of this demo, the first one acts as a server and the 
second one acts as a client. The client instance attempts to connect to the server 
instance and if the connection is successful they exchange a message.

Running NetworkDemoIMPNG on the Emulator
1. Create two instance projects of the NetworkDemoIMPNG sample project.

2. Right click the first project and select Properties.

3. In the Platform category choose the device IMPNGDevice1. In the Application 
Description category set the value of the following property:

Oracle-Demo-Network-Mode:Server

4. Click OK.

5. Launch the first project. It opens on the emulator IMPNGDevice1 and waits for a 
connection. You should see messages like the following:

6. Right click the second project and select Properties.

7. In the Platform category choose the device IMPNGDevice2. In the Application 
Description category set the value of the following property:

 Oracle-Demo-Network-Mode:Client

8. Click OK.

9. Launch the second project. It opens on the emulator IMPNGDevice2.

10. The client attempts to connect to the server. If successful, you see the following in 
the output tab of the first project (the server):

Waiting for connection on port 500
[AMS-TRACE] MIDlet:NetworkDemoIMPNG status=2
[AMS-TRACE] MIDlet:NetworkDemoIMPNG status=1
Connection accepted
Message received - Client messages

The output of the second project (the client) shows the following:

[AMS-TRACE] MIDlet:NetworkDemoIMPNG status=2
[AMS-TRACE] MIDlet:NetworkDemoIMPNG status=1
Connected to server localhost on port 500
Message received - Server string

Running NetworkDemoIMPNG on the Reference Board
You can run one of the instance projects on the board and the other in one of the 
emulators. Follow these steps to run the client on the board and the server in one of 
the emulators:
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1. Right click on the first project (the server) and select Properties. In the Platform 
category choose the device IMPNGDevice1 (the emulator) and click OK. In the 
Application Description category set the value of the property 
Oracle-Demo-Network-Mode to Server and click OK.

2. Launch the first project (the server). It runs on the emulator and waits for a 
connection.

3. Right click on the second project (the client) and select Properties. In the Platform 
category choose the device IMPNGExternalDevice1 (the board). In the Application 
Description category set the value of the property Oracle-Demo-Network-Mode to 
Client and click OK.

In the Application Descriptor category set the value of the property 
Oracle-Demo-Network-Address to the IP address of the computer where Eclipse is 
running and click OK.

4. Launch the second project (the client). It runs on the board and attempts to connect 
to the server. If successful, you see the following in the output tab of the first 
project (the server):

Connection accepted
Message received - Client messages

The TCP log of the board (the client) shows the following:

Connected to server 10.0.0.10 on port 5000
Message received - Server String

Running the PDAPDemoIMPNG
This demo is a headless version of the PDAPDemo file browser.

Running the PDAPDemoIMPNG on the Emulator
Follow these steps to run the demo on the emulator:

1. Create test files and directories inside the emulator’s file system:

\username\javame-sdk\3.3\work\IMPNGDevice1\appdb\filesystem\root1

2. Load the project in the Package window.

3.  In the Platform category, select the device IMPNGDevice1 and click OK.

4. In the Device Selector window, right-click an IMPNGDevice1 emulator.

5. Select Run Project > PDAPDemoIMPNG from the context menu.

6. Launch the project. 

7. On the emulator, click the Tools menu and select Manage File System to see a list 
of mounted file systems.

8. Open a terminal emulator and create a Telnet connection to localhost on port 5001.

Note: The Telnet negotiation mode must be set to Passive.  The 
negotiation mode can be set inside a Telnet client application (for 
example, PuTTY), by choosing Category --> Connection --> Telnet --> 
Passive.
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9. A command line opens where you can browse the emulator’s file system. You can 
use the following commands:

– cd - change directory

– ls - list information about the FILEs for the current directory

– new - create new file or directory

– prop - show properties of a file

– rm - remove the file

– view -View a file's content

Running PDAPDemoIMPNG on the Reference Board
Follow these steps to run the demo on the reference board:

1. Right-click the project and select Properties. In the Platform category, select the 
device IMPNGExternalDevice1 and click OK.

2. Launch the project. It runs on the reference board.

3. Open a terminal emulator and create a raw connection to the IP address of the 
board on port 5001.

4. The command line that opens is the same as the one you use when you run the 
demo on the emulator.

The file system of the demo is stored in the directory java/IMletID inside the SD card, 
where IMletID is a number that the AMS assigns to an IMlet during its installation.

Running the Pulse Counter (Data Collection) Demo
Pulse counting is the process of sending an electronic pulse to a counter, and then 
tracking them (via a timestamp) when they arrive.  To observe this process, run the 
following demo on your IMPNG device, using the External Events Generator and the 
Pulse Counters tab:

1. Launch the Data Collection Demo.

2. In the Device Selector, right-click the IMPNGDevice1 emulator and select Run JAR 
or JAD.

3. In the file browser, navigate to and select the Data Collection demo JAD file. For 
example:

installdir/apps/DataCollectionDemo/dist/DataCollectionDemo.jad

4. When the emulator opens with DataCollectionDemo installed, select 
DataProcessorIMlet and PulseCounterImlet and click Run.

5. Click OK twice (once for each IMlet) in the Run IMlet dialog box. 

You do not have to select the debugger, profiler, or memory monitor tool.

6. Open the External Events Generator by clicking the Tools menu and selecting 
External Events Generator or clicking the External Events Generator icon.

7. Click the Pulse Counters tab.

8. Observe Output Console in the IDE as you click Send Pulse for the first counter, 
COUNTER_PA0.



Running IMP-NG Sample Projects

4-22 Oracle Java Micro Edition Software Development Kit Developer's Guide

Alternatively, you can select View > Output Console in the emulator menu to 
open the Output Console window.

Figure 4–7 Output Console Window Showing Pulse Counter Output

A pulse timestamp is output for each click of Send Pulse. 

Configuring a Pulse Counter 
You can configure a pulse counter for an IMPNG device.  You can also create a custom 
IMPNG device with pulse counter capabilities.  To do this, follow these steps:

1. Go to Tools > Java ME > Custom Device Editor.  

For Eclipse users, go to Run > Custom Device Editor.

2. Select IMP-NG in the Custom Device Editor window and click New... .

3. In the New IMP-NG Device dialog box, specify a name for the custom device, for 
example, IMPNGCustomDevice1.

4. (Optional) you can provide a brief description such as emulator with pulse 
counter.

5. Click the Pulse Counters tab.

6. Click Add for the number of pulse counters you want. For example, click Add four 
times to create pulse counters with IDs of 0, 1, 2, and 3.

IDs are automatically assigned to each pulse counter. To unassign an ID, select the 
row of the desired pulse counter and uncheck the Assign ID option. The 
unassigned pulse counter is moved to the top of the list.

7. For each pulse counter, click in the Type column and select the signal trigger type: 
Falling Pulse Edge, Negative Edge Pulse, Rising Pulse Edge, or Positive Edge 
Pulse.

8. Click OK.

You also have the option to bind a pulse counter to an existing GPIO input pin by 
selecting the specific pin from the dropdown list in the Input Pin column.

The pulse counter type should conform to the trigger value of the binding input GPIO 
pin. This means that:

■ Pulse counters of the type Falling Pulse Edge can only be bound to input pins with 
the Falling Edge trigger.
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■ Pulse counters of the type Rising Pulse Edge can only be bound to input pins with 
the Rising Edge trigger.

■ Pulse counters of the type Negative Pulse Edge or Positive Pulse Edge can only be 
bound to input pins with the Both Edges trigger.

Running the Light Tracker Demo
 The Light Tracker demo is specifically aimed ast showing off funtionality on a 
embedded device, such as the Keil MCBSTM32F200 reference platform.

In this demo, a certain number of LEDs are turned on and turned off on the board, in a 
sequence that you can control.  It makes use of the Device Access API and the GPIO 
Port to demonstrate its functionality.  It requires connection of an ADC channel to an 
on-board potentiometer.

For more information on the setup of the Light Tracker demo, see the LightTrackDemo 
readme.txt file, in the location where you have installed the Oracle Java ME SDK 
sample applications.  For example: 

C:\Documents and Settings\username\Java_ME_SDK\samples\LightTrackDemo

For more information on the Keil MCBSTM32F200 platform, see the Oracle Java ME 
Embedded Getting Started Guide for the Reference Platform (Keil).

Running the System Controller Demo
 The System Controller demo is specifically aimed ast showing off funtionality on a 
embedded device, such as the Keil MCBSTM32F200 reference platform.

The purpose of this demo is to control the lifecycle of IMlets on the reference platform.  
It makes use of the following functionalities:

■ Multitasking Virtual Machine (MVM)

■ IMlet auto-start

■ Application Management System (AMS) API

■ Logging API

■ Device Access API 

■ General Purpose Input/Output (GPIO)

■ Watchdog timer

For more information on the setup of the System Controller demo, see the 
SystemControllerDemo readme.txt file, in the location where you have installed the 
Oracle Java ME SDK sample applications.  For example: 

C:\Documents and Settings\username\Java_ME_
SDK\samples\SystemControllerDemo

For more information on the Keil MCBSTM32F200 platform, see the Oracle Java ME 
Embedded Getting Started Guide for the Reference Platform (Keil).
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5Creating and Editing Projects

A project is a group of files comprising a single application. Files include source files, 
resource files, XML configuration files, automatically generated Apache Ant build 
files, and a properties file. 

When a project is created, the SDK performs these tasks:

■ Creates a source tree you can examine in the "Working With Projects" or "View 
Project Files."

■ Sets the emulator platform for the project.

■ Sets the project run and compile-time classpaths.

■ Creates a build script that contains actions for running, compiling, debugging, and 
building Javadoc. Project properties influence the build process, as described in 
"Building a Project." See also "Build a Project from the Command Line."

Java ME SDK and NetBeans create their project infrastructure directly on top of 
Apache Ant. Java ME SDK projects can be opened and edited in NetBeans, and 
vice-versa. With the Ant infrastructure in place, you can build and run your projects 
within the SDK or from the command line. 

The SDK provides two views of the project:

■ The Projects window provides a logical view of the project.

■ The Files window displays a physical view of the project.

Project settings are controlled in the project Properties window. Typically, you 
right-click on an item or subitem in a tree (a project, a file, or a device) and select 
Properties. 

Project Types
The MIDP/CLDC platform implements the Mobile Information Device Profile and 
Connected Limited Device Configuration (JSRs 118 and 139). As described in 
"IMP-NG," the IMP-NG platform is a type of CLDC platform.

The CDC platform is implemented to support Advanced Graphics and User Interface 
Optional Package for the J2ME Platform, Personal Basis Profile 1.1, and the Connected 
Device Configuration (JSRs 209, 217 and 218). The AGUI API combines the PBP API 
and a subset of Java Platform, Standard Edition (Java SE) Swing capabilities.

MIDP Projects
A MIDP application (a MIDlet), is deployed as a MIDlet suite. A MIDlet suite is 
distributed as a Java archive (JAR) file and a Java Application Descriptor (JAD) file. 
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The IMP-NG version of a MIDlet is an IMlet. However, because IMP-NG is a subset of 
CLDC you can write IMP-NG applications as MIDlets.

The JAR file includes the Java classes for each MIDlet in the suite, Java classes shared 
between MIDlets, resource files, and other supporting files. The JAR file also includes 
a manifest describing the JAR contents and specifying attributes the Application 
Management Software (AMS) uses to identify and install the MIDlet suite. 

The JAD file contains attributes that allow the AMS to identify, retrieve, and install the 
MIDlets in a project. The SDK automatically creates JAD and JAR files when you build 
the project.

CDC Projects
The CDC platform is implemented to support Advanced Graphics and User Interface 
Optional Package for the J2ME Platform, Personal Basis Profile 1.1, and the Connected 
Device Configuration (JSRs 209, 217 and 218). The AGUI API combines the PBP API 
and a subset of Java Platform, Standard Edition (Java SE) Swing capabilities.

Oracle Java ME SDK version 3.3 supports CDC projects running as standalone 
applications. The CDC project structure and behavior are much the same as that of 
CLDC projects.

A standalone CDC project requires a main application class that includes a method 
named main() that handles class loading, object creation, and method execution. The 
application interacts directly with the Java Runtime Environment to manage its own 
life cycle and system resource needs. When the main() method exits, the standalone 
application terminates.

The Project Wizard
This section describes how to use the Project Wizard to create Java ME projects. The 
project provides a basic infrastructure for development. You provide source files, 
resource files, and project settings as needed. Most project properties can be edited 
later. For more on project properties, see Chapter 6, "Viewing and Editing Project 
Properties."

Create a MIDP Project
Follow these steps to create a MIDP project.

1. Click the File menu and select New Project.

The New Project wizard opens. 

2. In the New Project window, select the Java ME category, and the Mobile 
Application project type. Click Next.

3. On the Name and Location page, specify a project name. 

Most of the form is auto-filled, but you can alter any of the editable fields. 

Checking Create Default Package and Main executable Class creates a sample 
package and main class for your application. Click Next.

Note: An Xlet cannot be run standalone. It depends upon an 
application manager to manage its life cycle (its state) and system 
services. Xlets are not supported in this release.
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4. On the Default Platform Selection page, select the Oracle Java(TM) Platform Micro 
Edition SDK 3.3 platform. 

The platform determines which devices you see in the Device dropdown menu.

5. Make a device selection. 

The selected device typically determines the Device Configuration. If more than 
one Device Profile is available, make a selection. Click Finish.

The new project is listed in the Projects pane.

Create an IMP-NG Project
The process for creating an IMP-NG project is almost the same as a CLDC project. 
There are just a few things to watch for.

1. Click the File menu and select New Project.

The New Project wizard opens. 

2. In the Choose Project window, select the Java ME category, and the Mobile 
Application project type. Click Next.

3. On the Name and Location page, specify a project name. Most of the form is 
auto-filled, but you can alter any of the editable fields. 

Checking Create Default Package and Main executable Class creates a sample 
package and main class for your application. Click Next.

4. On the Select Platform page, change the platform selection to Oracle Java(TM) 
Platform Micro Edition SDK 3.3. The platform determines which devices you see 
in the Device dropdown menu.

Choose an IMPNG device, and choose a Device Profile.

Click Finish.

5. To run the new project follow the steps in "Running a Project."

Create a CDC Project
NetBeans provides a wizard for creating new projects quickly and easily. Most project 
properties can be edited later on. 

1. Click the File menu and select New Project.

The New Project wizard opens.

2. In the Categories window choose Java ME and in the Projects window choose 
CDC Application.

3. On the Name and Location page, specify a project name. Most of the form is 
auto-filled, but you can alter any of the editable fields. 

Check the Create Main class option to insert a template of the class Main in your 
project. You can rename the class or accept the default name. Click Next.

Note: You can make additional project configurations using project 
configuration templates from previously saved templates or from 
templates installed on the platform by clicking Next on the Default 
Platform Selection page.
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4. On the Select Platform page, change the platform selection to CDC Oracle 
Java(TM) Platform Micro Edition SDK 3.3. The platform determines which devices 
you see in the Device dropdown menu.

Choose a CDC device and a Device Profile, then click Finish.

5. To run the new project follow the steps in "Running a Project," except you can 
select your new project instead of a sample project.

Import a Legacy MIDP Project
If you created a project using the Sun Java Wireless Toolkit for CLDC on Windows or 
Linux you can import your MIDlets into Java ME SDK projects. You can also use this 
procedure to create a project based upon a legacy sample project.

1. In the File menu, select New Project.

2. In the New Project dialog box, be sure Java ME is selected and select Import 
Wireless Toolkit Project. Click Next.

3. Specify the WTK project location. 

Use browse to open the directory containing the legacy project. 

4. Select a project and click Next. 

5. Provide the project name, location, and folder for the new project. 

The default name, project name and folder name are based on the name of the 
project you are importing. Click Next.

6. Select the platform type, the default device, and the configuration and profile, if 
applicable. Click Finish. 

Your new project opens in the Projects window. 

7. If the legacy project used signing, you must configure the signing properties as 
described in "Managing Keystores and Key Pairs."

Import a Legacy CDC Project
If you created a project using the CDC Toolkit, you can import your applications into 
Java ME SDK projects. You can also use import to create a project based upon a sample 
project.

The CDC platform name for the Oracle Java ME SDK version 3.3 does not match the 
legacy platform name in the CDC Toolkit 1.0 and the CDC Mobility Pack. 
Consequently, you get a reference error when you import a legacy CDC project. 

1. In the File menu, select New Project.

Note: Standalone projects created in the CDC Toolkit can be 
imported. Xlets cannot be imported.

Note: To avoid the reference error, create a platform with the 
legacy name, as described in "Create a Platform for Legacy CDC 
Projects." You only need to create the platform once.
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2. In the New Project dialog box, be sure Java ME is selected and select Import CDC 
Toolkit Project. Click Next.

3. Browse to select the project location.

The wizard detects any applications in the legacy installation and displays their 
locations on disk. Select a project and click Next. 

4. Provide the Project Name, Location, and Folder for the new project. Note that the 
default name project name and folder name are based on the name of the project 
you are importing. Click Finish.

The imported project opens in the Projects window. 

See "Create a Platform for Legacy CDC Projects" and "View Project Files."

Working With Projects
The logical view of the project, shown in the Projects window, provides a hierarchy of 
sources and resources. Right-click on the project node to see actions related to the 
project.

New. Opens a form to build a new object for the current project. The new object is 
placed in the project's file structure by default, but you can control the file name and 
location. The Other option in the New menu permits adding different types of files to 
the project. For a sample procedure, see "Generating Stub Files from WSDL 
Descriptors."

Build. Builds a distribution Java archive (JAR) file. Project properties control the build 
process as described in "Building a Project."

Clean & Build. Cleans, then builds a distribution JAR file.

Clean. Cleans the build files.

Generate Javadoc. See the online help topic Generating Javadoc Documentation.

Deploy. See the online help topic "Deploying Java ME Applications."

Batch Build..., Batch Clean & Build..., Batch Clean..., Batch Deploy... See the online 
help topic "About Java ME MIDP Projects."

Run. Runs the project with the default device, as specified on the Platform property 
page. See "Platform Selection."

Run With... Run the selected project with a device you choose. This option can 
override the default device specified in the project properties.

Debug. See the online help topic "Debugging Tasks: Quick Reference."

Profile. Attach the profiler to the selected project. See Chapter 9, "Profiling 
Applications."

Set as Main Project. Make the current project the new main project. Toolbar actions, 
such as clicking the green Run button, act upon the main project by default. 

Unset as Main Project. This option is visible if the selected project is the main project. 

Open Required Projects. Open any projects that the current project requires.

Close. Close the current project. Be sure that any processes are stopped, as closing a 
project might not stop the emulator.
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View Project Files
The Files window displays a physical view of all project files. Right-click to view 
project properties or choose an action related to the project.

build. The output directory for the compiled classes listed below. This directory also 
contains manifest.mf, the manifest file that is added to the JAR file.

■ compiled. Contains all compiled classes.

■ obfuscated. Holds the obfuscated versions of the class files.

■ preprocessed. Holds the source files after they are preprocessed. The files differ 
from the original source files if you are using project configurations.

■ preverified. Holds the preverified versions of the class files. These files are 
packaged into your project's distribution JAR.

■ preverifysrc. Versions of the source files before they are preverified.

dist. The output directory of packaged build outputs (JAR files and JAD files). The 
dist directory also contains generated Javadoc documentation.

lib. Contains libraries you have added to the project. See "Adding Libraries and 
Resources."

nbproject. The directory that contains the project Ant script and other metadata. This 
directory contains the following files:

■ build-impl.xml. The SDK-generated Ant script. Do not edit build-impl.xml 
directly. Always override its targets in build.xml.

■ private/private.properties. Properties that are defined for you alone. If you are 
sharing the project, any properties you define in this file are not checked in with 
other project metadata and are only applied to your SDK installation.

■ project.properties. Ant properties used to configure the Ant script. This file is 
automatically updated when you configure the project's properties. Manual 
editing is possible, but it is not recommended.

■ project.xml and genfiles.properties. Generated metadata files. It is possible to 
edit project.xml manually, but it is not recommended. Do not edit 
genfiles.properties.

res. Resource files you have added to the project. See "Adding Libraries and 
Resources."

src. Project source files.

build.xml. The build script. This build script only contains an import statement that 
imports targets from nbproject/build-impl.xml. Use the build.xml to override 
targets from build-impl.xml or to create new targets.

See "Create a MIDP Project" and "Create a CDC Project."

Create a New MIDlet
To create a new MIDlet from the Files view, right-click a project and select New > 
MIDlet. With this form you can specify the name of the MIDlet and its location within 
the selected project.

MIDlet Name. The name that users see when the application runs on a device.

MIDlet Class Name. The name of the new MIDP class.
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MIDlet Icon. The path to an icon associated with the MIDlet. Users see the icon when 
the application runs on a device.

Project. Displays the name of the project.

Package. Specifies the location of the MIDlet class in the package hierarchy. You can 
select an existing package from the drop down menu, or type in the name of a new 
package. The new package is created along with the class.

Created File. Displays the name and the location of the MIDlet in the system’s 
hierarchy.

When the new MIDlet is created the SDK automatically adds it to the project's 
Application Descriptor File.

Add Files to a Project
For all projects, right-click to use the context menu to add files to a project. Using this 
method places files in the proper location in project source or resources. 

To add a MIDlet, Java class, Java package, Java interface or Other files, right-click the 
project name or the Source Packages node, choose New, and select the file type.

To add files by format (Project, JAR, Folder, Library) right-click the Resources node 
and select a format. See "Adding Libraries and Resources."

It is possible to add files by copying them directly to the project directory but it is not 
recommended.

Search Project Files
To search a project's files, right-click on the project and select Find... . The Find in Files 
utility supports searching a project's file contents or file names. The search input fields 
supports simple text matching and regular expressions. 

Containing Text. The string you are looking for. If File Name Patterns is empty, all files 
are searched.

File Name Patterns. The files you are searching in. If the Containing Text field is 
empty you get a listing of files that match the pattern.

The options Whole Words, Match Case, and Regular Expression further restrict the 
search. Regular Expression Constructs are fully explained in: 

http://download.oracle.com/javase/6/docs/api/java/util/regex/Pat
tern.html#sum

Debugging MIDP and IMP-NG Projects
Java ME Projects use standard NetBeans debugging utilities. Refer to the NetBeans 
help topic, Debugging Tasks: Quick Reference. This topic includes links to a variety of 
debugging procedures.

If you have an external device that runs a supported runtime you can perform 
on-device debugging. The device must be detected by the Device Selector, as described 
in "Adding an External Device."

For a sample scenario, see the Oracle® Java ME Embedded Getting Started Guide for the 
Windows Platform at:

http://docs.oracle.com/javame/embedded/embedded.html
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6Viewing and Editing Project Properties

All projects have properties. Some properties, such as the project's name and location 
cannot be changed, but other properties can be freely edited as work on your project 
progresses.

To view or edit a project's properties, right-click the project node and select Properties. 
In the resulting window, you can view and customize the project properties. See the 
following topics:

■ "General Project Properties"

■ "Platform Selection"

■ "Editing Application Descriptor Properties"

■ "Building a Project"

■ "Running Settings"

General Project Properties
To view the General property page, right-click a project, click Properties, and select the 
General category. The general properties page displays basic project properties. You 
can set application versioning here, but all other values cannot be edited. 

The project name, folder, and source location are set when the project is created. The 
Application Version Number field displays the version number of the current build.

Application Versioning

The Application Version Counter field displays the next version number to be used. 
The default advance is 0.0.1. To advance the number beyond this, use the dropdown 
menu to select a new digit, or enter the value into the field. For example, changing the 
value to 3 results in a build number of 0.0.3. Changing the value to 100 results in the 
version number 0.1.0.

Required Projects

This area displays projects you have added to this project. It might be a dependent 
project or an external library. See "Adding Libraries and Resources."

Platform Selection
An emulator platform simulates the execution of an application on one or more target 
devices. To view this property page, right-click a project and click Properties and 
select the Platform category. 

Select a platform type from the dropdown menu.
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For the emulator platform, be sure to select the 3.3 platform. You might have to use the 
dropdown menu to ensure the right version is selected.

By default, the devices in the device menu are also suitable for the platform type and 
emulator platform. The device you select is the default device for this project. It is used 
whenever you use the Run command. Your device selection influences the Device 
Configuration and Device Profile options, and the available optional packages.

Be sure that a Device Profile is selected, and select the optional packages you want to 
include in this project. The selected APIs are automatically added to the project's 
classpath. See "Create a MIDP Project."

Editing Application Descriptor Properties
To view this property page, right-click on a project, choose Properties, and select the 
Application Descriptor category. The Application Descriptor properties page enables 
adding, editing, or deleting project attributes. 

CDC Attributes
To view this property page, right-click on a CDC project and choose Properties. Select 
the Application Descriptor category.

Application Name. The display name of the application on the target device.

ApplicationVendor. The company name or author name for the application.

Description. A concise description of the application.

Detail Description. A detailed description of the application.

MIDP Attributes
To view this property page, right-click on a MIDP project and choose Properties. Select 
the Application Descriptor category, and select the Attributes tab. 

The General Attributes table lists the attributes currently contained in the JAD and 
JAR manifest files:

Type. Lists whether the attribute is required or optional. Custom attributes for passing 
parameters to the MIDlet using the JAD are also available.

Name. The name of the attribute. 

Value. The values for each attribute.

To avoid errors in verification:

■ Define all required attributes.

■ Do not begin user-defined attribute keys with MIDlet- or MicroEdition-.

Add an Attribute
Follow these steps to add an attribute.

1. Click Add... to open the Add Attribute window.

2. Choose an attribute from the Name combo box, or delete the current entry and 
add your own custom entry. 
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3. Enter a value for the attribute. 

4. Click OK.

Edit an Attribute
1. Select an attribute.

2. Click Edit... to open the Edit Attribute window.

3. Enter a value for the attribute.

4. Click OK.

API permissions, Push Registry Entries, and API Permissions have their own property 
pages.

Remove an Attribute
Select an Attribute and click Remove to delete it from the list.

MIDlets
To view this page, right-click a project and choose Properties. Select the Application 
Descriptor category, and select the MIDlets tab. 

The MIDlets table lists the MIDlets contained in the suite and the following properties:

Name. The displayable name of the MIDlet that the user sees when the MIDlet is run 
on a mobile device.

Class. The Java class for the MIDlet.

Icon. An icon (a .png file), representing the MIDlet that the user sees when the MIDlet 
is run on a mobile device.

Add a MIDlet
1. Click Add... to open the Add MIDlet window. 

The window lists the MIDlets available in the project.

2. Enter a name, then select a MIDlet class from the dropdown menu. 

You can also choose an icon for the MIDlet from the MIDlet icon dropdown menu.

3. Click OK.

Edit a MIDlet
1. Select a MIDlet.

2. Click Edit... to open the Edit MIDlet window.

3. Enter a value for the attribute.

4. Click OK. The revised values are listed in the table.

Remove a MIDlet
Select a MIDlet and click Remove to delete it from the list.

Note: Remember that user-defined attribute names must not 
begin with MIDlet- or MicroEdition-.
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Change MIDlet Display Order
The list order determines the order in which the MIDlets are displayed.

Select a MIDlet and select Move Up or Move Down to change its position.

Push Registry
To view this page, right-click on a project and choose Properties. Select the Application 
Descriptor category, and select the Push Registry tab. 

Add a Push Registry Entry
1. Click Add... to open the Add Push Registry window.

2. Enter Class Name, Sender IP, and Connection String values. 

■ Class Name. The MIDlet's class name.

■ Sender IP. A valid sender that can launch the associated MIDlet. If the value is 
the wildcard (*), connections from any source are accepted. If datagram or 
socket connections are used, the value of Allowed Sender can be a numeric IP 
address.

■ Connection String. A connection string that identifies the connection protocol 
and port number.

3. Click OK. 

The new values are listed in the table. A push registration key is automatically 
generated and shown as an attribute in the MIDlet suite's Java Application 
Descriptor (JAD) file. 

Enabling a Push Registry Entry
To make use of the Push Registry, you must also have permission to access the Push 
Registry API, javax.microedition.io.PushRegistry. API permission, are handled in 
the API Permissions property page ("API Permissions").

Remove a Push Registry Entry
Select an entry and click Remove to delete it from the list.

Change Push Registry Display Order
The list order determines the order in which the MIDlets are displayed. Select an entry 
and select Move Up or Move Down to change its position.

API Permissions
These properties set permission attributes for protected APIs called by the MIDlet 
suite. To view this property page, right-click on a project and click Properties. Select 
the Application Descriptor category, and select the API Permissions tab. 

Adding Permission Requests
1. Click the Add. 

The Add Permission for API dialog opens.

2. Choose an API package from the dropdown list or enter an API package name into 
the combo box and click OK.
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3. (Optional) In the Requested Permissions table, check the Required box if you want 
installation to fail when that permission cannot be granted.

For more information, see Security for MIDP Applications in the MIDP 2.1 (JSR 118) 
specification, available at: 
http://jcp.org/aboutJava/communityprocess/mrel/jsr118/index.html

Building a Project
When you build a project, the SDK compiles the source files and generates the 
packaged build output (a JAR file) for your project. You can build the main project and 
all of its required projects, or build any project individually.

In general you do not need to build the project or compile individual classes to run the 
project. By default, the SDK automatically compiles classes when you save them. You 
can use properties to modify the following build tasks:

■ "Compiling"

■ "Adding Libraries and Resources"

■ "Obfuscating"

■ "Creating JAR and JAD Files (Packaging)"

■ "Signing"

Configuring Ant
To view this form, follow these steps:

1. Click the Tools menu and select Options.

2. Select Java and click the Ant tab.

Ant Home. The installation directory of the Ant executable the SDK uses. To change 
Ant versions, type the full path to a new Ant installation directory in this field or click 
Browse to find the location. You can only switch between versions 1.5.3 and higher of 
Ant. The Ant installation directory must contain a lib subdirectory which contains the 
ant.jar binary. If you enter a directory that does not match the expected structure, the 
SDK gives you an error. See the NetBeans help topic for more options.

Save All Modified Files Before Running Ant. If selected, saves all unsaved files in the 
SDK before running Ant. It is recommended to leave this property selected because 
modifications to files in the SDK are not recognized by Ant unless they are first saved 
to disk.

Reuse Output Tabs from Finished Processes. If selected, writes Ant output to a single 
Output window tab, deleting the output from the previous process. If not selected, 
opens a new tab for each Ant process.

Always Show Output. If selected, the SDK displays the Output window for all Ant 
processes. If not selected, raises the Output window tab only if the Ant output requires 
user input or contains a hyperlink. Output that contains hyperlinks usually denotes an 
error or warning. 

Verbosity Level. Sets the amount of compilation output. Set the verbosity lower to 
suppress informational messages or higher to get more detailed information.

Classpath. Contains binaries and libraries that are added to Ant's classpath. Click Add 
Directory or Add JAR/ZIP to open the Classpath Editor.
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Properties. Configures custom properties to pass to an Ant script each time you call 
Ant. Click Manage Properties to edit the properties in the property editor. This 
property is similar to the Ant command-line option, -Dkey=value. The following 
default properties are available:

${build.compiler.emacs}. Setting this property to true enables Emacs-compatible error 
messages. 

Compiling
To view this property page, right-click a project and choose Properties. In the 
Properties window Build category, choose Compiling.

This page enables you to set the following options:

Generate Debugging Info. If checked, the compiler generates line numbers and 
source files information. This is the -g option in javac. If unchecked, no debugging 
information is generated (the -g:none option in javac).

Debug Block Level. The block level can be set to: debug, info, warn, error, and fatal.

Compile with Optimization. If checked, the compiled application is optimized for 
execution. This is the -O option in javac. Optimizing can slow down compilation, 
produce larger class files, and make the program difficult to debug.

Report Uses of Deprecated APIs. If checked, the compiler lists each use or override of 
a deprecated member or class. This is the -deprecated option in javac. If unchecked, 
the compiler shows only the names of source files that use or override deprecated 
members or classes.

Encoding. Overrides default encoding used by preprocessor and compiler. The default 
value is the default encoding used by your VM.

Adding Libraries and Resources
To view this property page, right-click on a project and select Properties. In the 
Properties window Build category, choose Libraries and Resources to add a dependent 
project, libraries, and other supporting files to the current project. 

Add Project. A JAR file produced by another project and the associated source files 
and Javadoc documentation. Adding this item to a classpath sets up a dependency 
between the current project and the selected JAR file.

Add Library. A Library is a collection of JAR files or folders with compiled classes, 
which can optionally have associated source files and Javadoc documentation. 

Add Jar/Zip. A JAR file created by another project.

Add Folder. The root of a package or directory containing files.

When a library or resource is added, it is visible in the Libraries & Resources table, 
which reflects the order of the libraries and resources in the classpath. To change the 
order in the classpath, select the listing and click Move Up or Move Down. You can 
also remove libraries and resources from this page.

Each row in the table has a Package check box. If Package is checked, the library or 
resource is bundled and added to the project JAR file. If Package is not checked, the 
library or resource is copied to the lib  subdirectory at build time.
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Creating JAR and JAD Files (Packaging)
To view this property page, right-click on a project and select Properties. In the 
Properties window Build category, choose Creating JAR.

You can set the following options:

JAD File Name. Name of the JAD file created by the project sources. The file name 
must have a .jad extension.

JAR File Name. Name of the JAR file created by the project sources. The file name 
must have a .jar extension.

Compress JAR. If checked, the JAR file is compressed.

Obfuscating
To view this property page, right-click on a project and select Properties. In the 
Properties window Build category, choose Obfuscating.

Use the Obfuscation properties page to set the level of obfuscation for project files.

Move the Obfuscation slider to set the level. The Level Description window describes 
the impact each level has.

You can add more obfuscation parameters in the Additional Obfuscation Settings 
window. 

Signing
To view this property page, right-click on a project and select Properties. In the 
Properties window Build category, choose Signing. These properties enable you to 
enable signing and assign key pairs to a CLDC project. See "Security Domains."

Sign Distribution. Check this box to enable signing for the MIDlet suite. If it is 
unchecked, this page is disabled.

Keystore. A file that stores one or more key pairs as a keystore (.ks) file. The 
dropdown menu lists all available keystores. Click the Unlock button to unlock a 
keystore with the keystore password.

Alias. A name assigned to a key pair within a keystore. The dropdown menu lists the 
aliases available for the selected keystore. Click the Unlock button to unlock a key pair 
for use.

The Certificate Details window provides information about the certificate assigned to 
the key pair.

Click Open Keystores Manager to manage keystores and key pairs. See "Managing 
Keystores and Key Pairs" and "Exporting a Key."

Signing CDC Projects
To sign a CDC project use the JDK jarsigner command from the command line. For 
example: jarsigner.exe -keystore keystore.ks -storepass keystorepwd 
MyCdcApp.jar dummyCA

Exporting a Key
Follow these steps to export a key into an emulator:

■ Click the Tools menu and select Keystores. This opens the Keystores Manager.
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You can use the Keystores Manager to add a keystore to the Keystores list. Click  
Add Keystore. After you create the keystore, click New to create a key pair.

■ In the Keys area, select a key, and click Export. This opens the dialog Export Key 
into Java ME SDK/Platform/Emulator. 

■ Select the target emulator from the Emulator list.

■ Select the Security Domain.

■ Click Export to export your key pair to the selected emulator. 

Your key is added to the bottom of the list in Keys Registered in the Emulator.

The Export window has the following components:

Keystore File. Displays the name of the keystore file to which the key pair belongs. 
This field cannot be edited.

Key Pair Alias. The name given to the key pair within the keystore. This field cannot 
be edited.

Certificate Details. Displays the details of the certificate of the key to be exported.

Emulator. The drop-down menu lists all the device emulators available. See "Security 
Domains."

Security Domain. Enables you to select a security domain for the key pair. The menu 
lists all domains supported by the selected emulator platform.

Keys Registered in the Emulator. Lists all keys that have been registered in the 
selected platform. Click to select the key you want to export.

Delete Key. Deletes a selected key from the Keys Registered in the Emulator window.

Export. Exports the selected key to the selected emulator. The export button is enabled 
if it is possible to export the key. If a specific key is installed it cannot be installed 
again.

Running Settings
To view this property page, right-click a project and choose Properties. In the 
Properties window, choose Running. The options shown depend on the platform. See 
"MIDP Project Run Options" and "CDC Project Run Options."

MIDP Project Run Options
To set emulator command line options for a MIDP project, type in the command line 
switches. See "Emulator Command Line Options."
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Figure 6–1 Emulator Command Line Switches

For CLDC projects, the Regular execution button is enabled by default. The setting for 
"Specify the Security Domain" applies when the project is run on an emulator. It does 
not apply for OTA provisioning or an external emulator platform.

If you do not check Specify the Security Domain the project runs with the default that 
was assigned when the project was created. If you check the box, you can select a 
domain from the dropdown list. See "Security Domains" and "Specify the Security 
Domain for a Project."

CDC Project Run Options
For CDC projects you must enter the name of the entry point Java file in the Main 
Class field. The Main Class Browse button only shows executable classes in the 
project's source folders. For a CDC project you see all classes with a static main 
method, or classes extending the Applet or Xlet classes.

Arguments are passed only to the main class, not to individual files. If an Xlet is 
executed, all arguments are passed to all the Xlets you specify.

For VM options, see "CDC Options."
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7Working With Devices

The Oracle Java ME SDK provides default device skins. A skin is a thin layer on top of 
the emulator implementation that defines the appearance, screen characteristics, and 
input controls. This chapter discusses the default emulators provided by Oracle Java 
ME SDK and describes how you can create and modify a custom device. To make your 
own device, see "Using the Custom Device Editor."

The Oracle Java ME SDK  emulator simulates a CLDC, CDC, or IMP-NG device on 
your desktop computer. The emulator does not represent a specific device, but it 
provides correct implementations of its supported APIs. 

Emulators
The SDK runs applications on an emulator or an external device. Before you can run 
an application from the SDK, the Device Manager, which manages both emulators and 
external devices, must be running. When the Oracle Java ME SDK runs, the Device 
Manager automatically launches and starts detecting devices. The default emulators 
shipped with the SDK are automatically found and displayed in the Device Selector 
window (Tools > Java ME > Device Selector). 

The Device Manager on Windows
The SDK uses the device manager to detect devices and displays the available devices 
in the Device Selector window (Tools > Java ME > Device Selector). The Device 
Manager is a service and you can see it running in your Windows system tray. In the 
task manager, the process is labeled device-manager.exe. 

Figure 7–1 The Device Manager Icon

You can right-click the icon and select Exit to stop the service.

Note: The configuration of all peripherals, except UART, can be 
inspected in the emulator main window.  The configuration of UART 
is defined by the hardware configuration of the COM ports on your 
Windows XP or Windows 7 PC.
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Figure 7–2 The Device Manager Menu

To restart the device manager, double-click device-manager.exe in your installdir\bin 
directory. You can also start it from the command line as described in "Run the Device 
Manager."

In the Windows system tray, click the icon or right-click the icon and select Manage 
Device Addresses from the menu to open the Device Address Manager. Enter an IP 
address and select Add to add a device. Select an address and click Remove if you 
have an address you no longer want to detect. The device is no longer displayed in the 
Device Selector. 

Right-click the icon in the system tray and select Registered Devices to see a list of 
registered devices and their configuration information such as, screen dimensions, 
screen depth, security domains, supported APIs, and more.

Starting an Emulator
Typically an emulator is launched when a Java ME SDK project is run from the 
NetBeans IDE or the command line. The default emulator is determined by the Java 
ME platform selected for the project, as described in "Managing Java Platforms."

You can open an emulator without running an application from the IDE. From the 
Windows Start menu, click Programs and select Java(TM) ME Platform SDK 3.3 and 
select the desired emulator. You can also click the emulator shortcuts installed on your 
Windows desktop.

Figure 7–3 Opening an Emulator

To run an application from the emulator, click the Application menu and select Run 
MIDlet Suite (or Run IMlet Suite). Provide the path to the application and any other 
information, and click OK.

CLDC Application Management System
The CLDC AMS home screen features three utilities:

■ Install Application. This utility opens a form in which you can specify a URL (or a 
file path) for a JAD file to install.

■ Manage Certificate Authorities. This feature displays the certificates authorities for 
the device. In this interface the white box indicates the certificate is checked 
(active). You can uncheck certificates that are not needed.
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■ Output Console. The output console displays system output statements from a 
running application. The application must write to the Java standard output 
console using, for example:

System.out.println("text");

Start the emulator’s Output Console, then start your application. Use F7, Switch 
running MIDlet, to switch between the application and the Output Console. 

Note that the emulator’s Output Console is an application that consumes 
resources. If you get the message "No more concurrent applications allowed," you 
must close some applications before continuing.

Figure 7–4 The Output Console Window

See "Emulator Features" and "Emulator Menus."

You can also access system output information from the emulator by clicking the View 
menu and selecting Output Console..., which opens an Output Console dialog box. 
Select a filter from the dropdown list to display specific system output. Click Save to 
save the output as a .log file. 

Adding an External Device
The device selector can detect a device that has a compatible runtime. Typically this 
device has network capabilities and is connected to the computer running Java ME 
SDK.

1. To detect a physical device, click CTRL-D, or click the device icon at the top of the 
Device Selector window.

2. Type an IP address and click Next. Click Finish. 

You can also enter an IP address in the Device Manager, as described in "The 
Device Manager on Windows."

3. The physical device is listed in the appropriate platform tree. By default, the 
device has "ExternalDevice" appended to the name.
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For example, if an IMP-NG device is detected it is placed in the IMP-NG node and 
given the name IMPNGExternalDevice1.

For an example of how to configure and work with an external device, see the Oracle 
Java ME Embedded Getting Started Guide for the Windows Platform. This document is 
available on the Java ME documentation site under the Oracle Java ME: 

http://docs.oracle.com/javame/embedded/embedded.html

Expand the Oracle Java ME Embedded Version node and then the Getting Started and 
Release Notes node.

Viewing Device Properties
The Device Selector window lists all available devices grouped by platform. If this 
window is not visible, select Tools > Java ME > Device Selector.

If no Java ME platform is registered in NetBeans, the Device Selector displays a node 
labeled No Device Found. If you see this message at startup, it typically means device 
discovery is incomplete and you must wait a few seconds.

Each sub node represents a device. Two instances are provided for some CLDC 
devices, for example, JavaMEPhone1 and JavaMEPhone2. Instances of the same device 
have the same capabilities but unique names and phone numbers, making it easy for 
you to test communication between devices of the same type. To make your own 
device, see "Using the Custom Device Editor."

For Device names, see "Oracle Java ME SDK Directories." The properties for each 
device are stored in XML files in your user work directory. See Table 8–1.

Platform Properties
To view platform properties from the device selector, click on the platform node (for 
example, CLDC or IMP-NG). The Properties window is, by default, docked in the 
upper right portion of the user interface. If the Properties window is not visible, click 
the Windows menu and select Properties.

To view the platform properties in a separate window, right-click the platform node 
and select Properties. The information in the docked properties window and the 
separate window is the same.

Device Information
In the Device Selector window, double-click a device node. The Device Information tab 
opens in the central Main window. It displays a picture of the device and displays 
details, supported hardware capabilities, keyboard support, supported media formats, 
and the supported runtimes.

Device Properties
In the Device Selector window, click a device node (such as JavaMEPhone1) to display 
the device properties. The Properties window is, by default, docked in the upper right 
portion of the user interface. If the Properties window is not visible, click the Windows 
menu and select Properties.
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Setting Device Properties
In the Device Selector window, right-click a device and select Properties. Any 
properties shown in gray font cannot be changed. You can adjust the device properties 
shown in black. Only CLDC and IMP-NG options can be adjusted. The CDC options 
cannot be changed.

General
This section lists general properties that can be changed.

Phone Number. You can set the phone number to any appropriate sequence, 
considering country codes, area codes, and so forth. If you reset this value, the setting 
applies to future instances. The number is a base value for the selected device.

Heapsize. The heap is the memory allocated on a device to store your applications's 
objects. The Heapsize property is the maximum heap size for the emulator. You can 
choose a new maximum size from the dropdown menu.

Security Domain. Select a security setting from the dropdown menu. See "Specify the 
Security Domain for an Emulator." Applies to CLDC platforms.

JAM storage size in KB. The amount of space available for applications installed over 
the air.

Locale. Type in the locale as defined in the MIDP 2.1 specification at:

http://download.oracle.com/otndocs/jcp/midp-2.1-mrel-oth-JSpec

Remove MIDlet Suite in execution mode. If this option is enabled, record stores and 
other resources created by the MIDlet are removed when you exit the MIDlet 
(assuming the MIDlet was started in execution mode). 

Monitor
If enabled (checked), the Check boxes for Trace GC (garbage collection), Trace Class 
Loading, Trace Exceptions, and Trace Method Calls activate tracing for the device the 
next time the emulator is launched. The trace output is displayed at runtime in the 
user interface Output window. Trace Method Calls returns many messages, and 
emulator performance can be affected. See Chapter 11, "Monitoring Memory."

SATSA
See "Card Slots in the Emulator."

Location Provider #1 and #2
These properties determine the selection of a location provider. Two providers are 
offered so that your application can test matching the location provider criteria.

If you select a property a short explanation is shown in the description area just below 
the Properties table. For more information on these values, see the Location API at:

http://jcp.org/en/jsr/detail?id=179.

Bluetooth and OBEX
See "Setting OBEX and Bluetooth Properties."
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Connecting to a UART Device
To utilize the Universal Asynchronous Receiver/Transmitter (UART) functionality, 
you need to create a configuration file (for example UARTConfig.xml). The 
configuration file defines the device ID and Name, and the Name must point to a real 
serial port name  defined by the operating system. For example,

deviceaccess.uart.dev14.name = COM1

For an already opened UART, you can add it to the peripheral manager by calling 
PeripheralManager.open with the configuration object.

Opening a Serial Port
In application code, you can use Connector.open("comm:COM1") to open a port on the 
device. On Windows, you can open a serial port such as COM1 or COM2.

Running a Project from the Device Selector
The SDK determines which open projects are suitable for a device. Right-click the 
device and select a project from the context menu.

You can also launch the emulator to ru.n a project from the command line, as 
explained in "Emulator Command Line Options."

Running Projects Simultaneously on a Single Device
CLDC-based devices are capable of running multiple virtual machines. You can test 
this behavior in the emulator. Be sure the output window is visible in the SDK (select 
Window > Output > Output). To test this feature, follow these steps:

1. Open the sample projects Games and AudioDemo.

2. In the device selector, choose a CLDC device and run Games. When the emulator 
launches, run AudioDemo on the same device. 

As each MIDlet loads, the AMS automatically installs it. 

3. In AudioDemo, launch the Audio Player, and play the JavaOne theme.

Select AudioPlayer, then from the soft menu, select 1, Launch. Select JavaOne 
Theme and press the Play soft button.

4. In the emulator, click the Application menu and select AMS Home, or press F4.

Select Games. From the soft menu, select 1, Open. The music continues to play 
while you are able to simultaneously launch and play games.

5. Click the Application menu and select AMS Home, or press F4. Highlight 
AudioSamples, and from the soft menu, select 2, Bring to foreground. Press the 
Pause soft key. The music stops playing.

6. Click the Application menu and select AMS Home, or press F4. Highlight 
AudioSamples and from the soft menu, select 1, Open. Select Bouncing Ball from 
the list and press the Launch soft button. Select MIDI background and press the 
Play soft button.

7. Click the Application menu and select AMS Home, or press F4. Then click the 
Application menu and select Switch Running MIDlet. Select Audio Player and 
press the Switch to soft button. You can press the Play soft button to resume the 
Audio Player.
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Emulator Features
Figure 7–5 shows common emulator features available on emulators for the CLDC 
platform.

Figure 7–5 Emulator Features

Device Name. Shown in the upper window frame. See Table 8–1for a list of default 
emulator names.

Transmission Indicator. On the upper left of the emulator image, this blue light turns 
on when a transmission is occurring. Typically you see it when an application is 
installed over-the-air, or when a message is being sent or received. For example, when 
you receive a message from the WMA console.



Emulator Features

7-8 Oracle Java Micro Edition Software Development Kit Developer's Guide

Menus. See "Emulator Menus."

Tool Bar. For the CLDC emulator, the Tool Bar provides shortcuts for the following 
operations:

■ Run MIDlet Suite

■ Install MIDlet Suite

■ Resume

■ Suspend

■ Rotate Clockwise

■ Rotate Counter Clockwise

■ External Events Generator

■ Emulator window always on top

Device ID. Numerical identifier that is unique for each device.

Exit Button. On the upper right of the emulator image, is the termination button. 
Pushing this button the same effect as clicking Application and selecting Exit.

Emulator Status Bar. Information about the current system state is shown in the status 
bar at the bottom of the emulator window.

Figure 7–6 shows common emulator features available on emulators for the IMPNG 
platform.

Figure 7–6 IMPNG Emulator
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Device Name. Shown in the upper window frame. See Table 8–1 for a list default 
emulator names.

Menus. See "Emulator Menus."

Tool Bar. For the IMP-NG Emulator, the Tool Bar provides shortcuts for the following 
operations:

■ Run IMlet Suite

■ Install IMlet Suite

■ External Events Generator

■ Emulator window always on top

Device ID. Numerical identifier that is unique for each device.

Display Panel and Tabs. The display panel displays fields and information dependent 
on the selected tab:

■ AMS. The AMS (Application Management System) tab displays the name of the 
IMlet suite, the IMlet, and the status of the IMlet suite. You can select a suite and 
perform one of the following operations by clicking the corresponding button to 
the right of the display:

■ Install - Specify the location of the IMlet suite path or URL and the security 
domain and click OK to load the IMlet suite.

■ Update - Check for any updates to the application and performs the update.

■ Info - Open a dialog box displaying the application name, vendor name, 
version, description of the application, class name, and the URL.

■ Run - Run the selected application. This button is only visible for an installed 
application that is not running.

■ Suspend (Resume) - Pause the running IMlet. This button toggles to Resume 
when execution is paused.

■ Stop - Stop execution of the application. This button is only visible for a 
running application.

■ Remove - Remove the application.

■ GPIO Pins. The General Purpose Input Ouput (GPIO) Pins tab displays which 
pins are selected to output and their high or low values.

■ GPIO Ports. The GPIO Ports tab displays a list of ports, which ports are selected to 
output, and their maximum and current values.

■ I2C. The Inter-Integrated Circuit (I2C) tab displays information for the selected 
slave device and data sent to a master device and data received from a master 
device.

■ SPI. In the default SPI implementation, buffered written data can be read from the 
Slave named SPI. If you have created a custom implementation with the Custom 
Device Editor, the Slave dropdown list might have additional slaves.

Note: When the Device Manager detects an external IMP-NG device, 
only the Application, View, and Help menus and the Run IMlet Suite, 
Install IMlet Suite, and Emulator window always on top icons in the 
Toolbar are available in the device display.
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■ MMIO. The memory-mapped I/O tab displays information for the current device.

■ DAC. The Digital-to-Analog Converter tab displays the current channel 
information, converter characteristics, and a graphic display of signal 
characteristics with the x-axis showing the digital input and the y-axis showing 
the analog output.

Emulator Status Bar. Information about the current system state is shown in the status 
bar at the bottom of the emulator window. Also shown is the memory indicator 
showing used and total memory.

Emulator Menus
The emulator for the CLDC platform has Application, Device, Edit, Tools, View, and 
Help menus. 

The emulator for the CDC platform has Application, View, and Help menus. The View 
and Help menus are the same on CDC and CLDC platforms. For CDC, the Device 
menu is not populated, and Application menu contains only the Exit option.

The Emulator for the IMP-NG platform has Application, Device, Tools, View, and Help 
menus.

Application
The Application menu is fully populated for the CLDC platform. Table 7–1 describes 
the Application options:

Table 7–1 Emulator Application Menu

Option Accelerator Description

Install MIDlet 
Suite

Permanently add a MIDlet suite to the emulator. 

Enter the path or URL of the MIDlet suite to install on the 
emulator. Select the desired level of the permissions in the 
Security Domain field.

Install IMlet Suite Permanently add a IMlet suite to the emulator. (IMP-NG 
emulator)

Enter the path or URL of the IMlet suite to install on the 
emulator. Select the desired level of the permissions in the 
Security Domain field.

Run MIDlet Suite Emulator interface for launching MIDlets.

Run IMlet suite Emulator interface for launching IMlets. (IMP-NG 
platform)

AMS Home F4 Exit the current application and return to the Application 
Management Software home. (CLDC emulator)

Stop F10 Stops the currently running MIDlet. (CLDC emulator)

Change Locale This option only works with localized MIDlets. (CLDC 
emulator)

Enter a locale identifier. The format is similar to Java SE 6, 
as follows:

2-letter-lang-code separator 2-letter-country-code

For example, en-US, cs-CZ, zh-CN, ja-JP. The separator can 
be a dash or an underscore.

Resume F6 Resume a suspended application. (CLDC emulator)
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Device
This menu is available on CLDC and IMP-NG platforms. 

Messages
Click the Device menu and select Messages to see what is written in the message area. 
This is the emulator's Inbox. The Inbox displays WMA messages that are addressed to 
the device, not an application on the device. Messages are sent to this interface in the 
following cases:

■ An MMS message is sent without an AppID in the address

■ An SMS message is sent without a port in the address (or the port number is 0)

■ An SMS text message is sent with a port in the address, but there is not a Java ME 
application listening on the specified port

To test sending messages to the inbox use the WMA Console in NetBeans, or from the 
command line, use wma-tool.exe to send SMS messages. Note, wma-tool.exe requires 
an AppID for MMS, so wma-tool cannot be used to send an MMS. 

Orientation
This option is only visible for the CLDC emulator.

Use this feature to test your application's ability to display in portrait and landscape 
formats. The default is 0 degrees. Change the orientation to 90, 180, or 270 degrees. 
You can also rotate 90 degrees clockwise (F8) or counterclockwise (F9) from the current 
position.

Edit
Table 7–2 describes the Edit menu, which provides basic editing operations for the 
CLDC platform.

Suspend F5 Pause a running application. (CLDC emulator)

Do not use this option if you are running the memory 
monitor.

Switch Running 
MIDlet

F7 When you have multiple MIDlets running, toggle between 
them. You see a list of running MIDlets and you can chose 
the one you want to switch to. See "Running Projects 
Simultaneously on a Single Device" (CLDC emulator).

Exit Exit button 
on emulator 
upper right

Close the emulator process and stop the build process (or 
processes).

Table 7–2 Emulator Edit Menu

Option Accelerator Description

Copy CTRL-C Copy selected material to the paste buffer.

Cut CTRL-X Move selected material to the paste buffer.

Paste CTRL-V Insert the contents of the paste buffer.

Table 7–1 (Cont.) Emulator Application Menu

Option Accelerator Description
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Tools
Table 7–3 describes the utilities accessible from the Tools menu.

External Events Generator
The following menu options each have a tab on the External Events Generator. The use 
of the External Events Generator is addressed in the discussion for each JSR:

■ ADC. The Analog-to-Digital Conversion tab is only visible for the IMP-NG 
emulator.

■ Access Points. This tab displays connection information for the selected access 
point. This tab is visible only for the IMP-NG emulator.

■ Contactless Communication. See "Using ContactlessDemo." This feature is 
available only for CLDC devices.

■ GPIO. This General Purpose Input Output (GPIO) option is visible only for the 
IMP-NG emulator.

By default, this tab displays ports and pins for a specific device described in 
"Running the GPIODemo." You can create a custom device to represent a different 
device. "General Purpose Input Output (GPIO)."

See the Device Access API (installdir\docs\api\deviceaccess) for a description of 
the GPIO interface.

■ Location. "Setting the Emulator's Location at Runtime."

■ MMIO. The memory-mapped I/O (MMIO) option is visible only for the IMP-NG 
emulator. From the Device dropdown list, choose one of the default devices: 

■ TEST_DEVICE. A Little Endian device that contains all block types: byte, 
short, int, long, and block. Writes to this device also affect BIG_ENDIAN_
DEVICE which shares the address space.

Table 7–3 Emulator Tools Menu

Option Description

Manage Landmarks Opens the Landmark Store utility. 

In this interface, you can view and edit a landmark store 
installed as part of an application. You can also create a new 
landmark store, define landmarks, define landmark categories, 
and assign landmarks to categories.

Manage File System Opens the File System manager and displays the mounted file 
system root directories.

You can mount or unmount a file system directory, copy a 
mounted file system directory, remount or remove directories. 
For a description of managing a file system, click the Tools 
menu and select Manage File System. Click Help in the dialog 
box.

External Events Generator Opens the External Events Generator.

The External Events Generator provides a way to interact with 
an application by injecting events. The interaction may be 
through a user interface, or through a script file. 

For a description of the External Events Generator, see "External 
Events Generator."

Take Screenshot Takes a screenshot of the emulator display screen and saves it to 
the clipboard. (CLDC emulator)
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■ WDOGLOG. A Little Endian device that supports only the block type.

■ RTC. STM32F2xx RTC device. A Little Endian device that supports only the 
int type.

■ BIG_ENDIAN_DEVICE. A Big Endian device that shares the address space 
with the TEST_DEVICE, therefore it contains the same memory blocks. Writes 
to this device also affect TEST_DEVICE which shares the address space.

If you are using a custom device created with the Custom Device Editor (see 
"Using the Custom Device Editor"). The device list might include additional 
devices.

See the Device Access API (installdir\docs\api\deviceaccess) and the Embedded 
Support API (installdir\docs\api\embedded-support-api) for descriptions of the 
MMIO interface.

■ Mobile. The unique International Mobile Subscriber Identity (IMSI) and the 
International Mobile Station Equipment identity (IMEI) identifiers of the device. 
This tab is visible only for the IMP-NG emulator.

■ Pulse Counter. This tab displays the current pulse counters on the device. The 
default configurations are:

– COUNTER_PA0

– COUNTER_PB3

– COUNTER_PB10

– COUNTER_PA3

You can configure the pulse counters you want and send a signal to the configured 
pulse counter by clicking Send Pulse.

This tab is visible only for the IMP-NG emulator. 

■ Sensors. "Using a Mobile Sensor Project" and "Creating a Sensor Script File." This 
tab is only visible for the CLDC emulator.

View
Table 7–4 describes the View menu, which is available for the CLDC, CDC, and 
IMP-NG platforms.

Table 7–4 Emulator View Menu

Option Description

Always On Top Keeps the emulator in the foreground.

 This option is especially useful when you are running multiple 
emulator instances and you want to see them all and send 
messages between devices.

Output Console Displays system output statements from a running application 
in the Output Console window.

You can filter the output statements for IMP-NG emulators by 
selecting All, Standard, or Error from the Show dropdown list.  
Error messages are highlighted.

Filtering of output statements and highlighting of error 
messages are not available for CLDC emulators or external 
devices.

You can save system output information to a .log file by 
clicking Save in the window. 
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Help
The Help menu displays an abbreviated helpset specifically for the emulator window.

Using the Custom Device Editor
With the Custom Device Editor you can create your own devices. The appearance of 
the custom devices is generic, but the functionality can be tailored to your own 
specifications. 

Creating a Custom Device
Follow these steps to create a custom device. 

1. Select Tools > Java ME > Custom Device Editor.

The custom device tree displays Java ME platforms and custom devices, if any.

Alternatively, you can launch the Custom Device Editor from the your 
installation’s bin directory. For example:

C:\Java_ME_platform_SDK_3.3\bin\device-editor.exe

The custom device tree displays Java ME platforms and custom devices, if any.

2. Select a platform and click the New... button.

3. Change the default configuration to match your specifications, and click OK.

Your device is added to the custom device tree and eventually appears in the Device 
Selector. You can run projects from the IDE or from the command line from the custom 
device.

The custom device tree affects what appears in the Device Selector. For example, if you 
do not want a custom device to appear in the device selector, you must remove it from 
the custom device tree.

The device definition is saved in installdir\toolkit-lib\devices.

Device Log Displays emulator log messages in the Device Log window.

The following filters are available from the Level dropdown list:

■ Trace - Tracing information, such as garbage collection, 
exceptions, and method calls.

■ Debug - General debugging information.

■ Info - Information messages.

■ Warn - Alerts that issues were encountered during runtime. 
Warnings are highlighted.

■ Error - Errors encountered during runtime but do not 
prevent the application from running. Error messages are 
highlighted.

■ Fatal - Non-recoverable errors that can potentially prevent 
the application from running and might cause the 
application to quit.

You can save system output information to a .log file by 
clicking Save in the window. 

Table 7–4 (Cont.) Emulator View Menu

Option Description
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Managing Custom Devices
Custom devices should always be managed using the Custom Device Editor. Using 
the tool ensures that your device can be detected and integrated with the Oracle Java 
ME SDK. 

■ New. Select a platform and click New to add a new device.

■ Edit. Select a device to change, and click Edit.

■ Clone. Select a device to copy, and click Clone. To prevent confusion, be sure to 
provide a unique name.

■ Remove. Select a device to delete and click Remove. This action completely 
deletes the device.

■ Import. Select a node in the custom device tree and click Import. Choose a .zip 
file created with the Export command.

■ Export. Select a device to save, and click Export.

When a custom device is created it is saved in installdir\toolkit-lib\devices, 
therefore you could lose your device if you reinstall. 

An exported device is stored in a .zip file and saved in the user’s My Documents 
directory (typically username\My Documents).

IMP-NG Device Options
When you create a new IMP-NG device you can use the default implementation or 
create your own custom implementation for the interfaces discussed in this section.

See the following resources for in-depth descriptions of the IMP-NG interfaces or 
devices:

■ Device Access API (installdir\docs\api\deviceaccess)

■ Embedded Support API (installdir\docs\api\embedded-support-api)

■ For more information about default devices look at an IMP-NG property file:

username\javame-sdk\3.3\work\IMPNGDevice1\device.properties

General Purpose Input Output (GPIO)
A GPIO port is a platform-defined grouping of GPIO pins that may be configured for 
output or input. Output ports are both writable and readable while input ports are 
only readable. Note that GPIO pins that are part of a GPIO port cannot be retrieved 
nor controlled individually as GPIO Pin instances. 

Click Add Port to add entries to the Ports table. Each item in a Ports table row is 
editable. Check Output to set the port direction to output. 

A GPIO pin may be configured for output or input. Output pins are both writable and 
readable while input pins are only readable. Note, an input listener can only be 
assigned to a pin set for input.

Click Add Pin to add a row to the Pins table. The ID and name are editable. Click 
Output to make a pin both readable and writable. Click in the Initial Value column to 
toggle the Initial Value from Low to High. 

Inter-Integrated Circuit (I2C) and Serial Peripheral Interface (SPI)
The process for configuring I2C and SPI interfaces is very similar. 
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On an I2C bus, data is transferred between the I2C master device and an I2C slave 
device through single or combined messages. On an SPI bus, data is transferred 
between the SPI master device and an SPI slave device in full duplex. That is, data is 
transmitted by the SPI master to the SPI slave at the same time data is received from 
the SPI slave by the SPI master. See the Embedded Support API for more details.

■ Select Sample Echo to choose the default bus implementation. This default 
implementation simply reads buffered written data from the slave. 

■ Select Custom to specify your own bus implementation.

1. Supply your bus implementation JAR file and the name of the Java class that 
implements the bus.

For I2C, the bus is:

com.oracle.jme.toolkit.deviceaccess.i2c.I2CSlaveBus

For SPI, the bus is:

com.oracle.jme.toolkit.deviceaccess.spi.SPISlaveBus 

2. To add Slaves, click Add and specify an ID and Name. For SPI, specify the 
Word Length as well.

Memory-Mapped I/O (MMIO)
The default devices are described in "External Events Generator."

If you want to provide your own MMIO emulation, you must specify a custom 
handler. 

Supply your implementation JAR file and the name of the Java class that implements 
com.oracle.jme.toolkit.deviceaccess.mmio.MMIOHandler. For comparison, the 
default JAR file is:

installdir\toolkit-lib\devices\IMPNGDevice\code\emulator_deviceaccess_
mmio-sample-handler.jar

To add devices to the custom MMIO implementation, use the Devices and Device 
Memory tables as follows:

1. Click Add Device to add a row to the Devices table.

■ A default ID is assigned but you can double-click in the ID column to edit the 
value.

■ A default Name is supplied, but it can also be edited.

■ In the Byte Ordering column, make a selection from the dropdown list.

2. Click a row in the Device table to select a Device.

3. Click Add Memory.

■ In the Type column, make a selection from the dropdown list. Double-click to 
edit the Address column entries.

Note: On an SPI bus, data is transferred between the SPI master device and 
an SPI slave device in full duplex. So every 
com.oracle.deviceaccess.spibus.SPIDevice.read(...) method also writes 
an array of zeros to the slave device. The length of this array equals a length of 
read data. In the default implementation this array of zeros is appended to the 
loopback's buffer.
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If the type is Block, you can double-click to edit the Size column entries as well 
as the Address column entries.

4. Click OK.
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8Finding Files in the Multiple User
Environment

The Oracle Java ME SDK can be installed on a system running a supported operating 
system version. All users with an account on the host machine can access the SDK. 
This feature is called the Multiple User Environment.

To support multiple users the SDK creates an installation directory that is used as a 
source for copying. This document uses the variable work to represent the SDK 
working directory and installdir to represent the Oracle Java ME SDK installation 
directory. Each user's personal files are maintained in a separate working directory 
named javame-sdk that has a subdirectory for each version installed.

■ "Installation Directories"

■ "NetBeans User Directories"

To locate logs, see "Device Manager Logs" and "Device Instance Logs."

Switching Users
Multiple users cannot run the SDK simultaneously, but, you can run the SDK from 
different user accounts on the SDK host machine. When you switch users, you must 
close the SDK and exit the Device Manager, as described in "The Device Manager on 
Windows." A different user can then launch the SDK and own all processes.

Installation Directories
The SDK directory structure conforms to the Unified Emulator Interface Specification 
(http://www.oracle.com/technetwork/java/javame/documentation/uei
specs-187994.pdf), version 1.0.2. This structure is recognized by all IDEs and other 
tools that work with the UEI. 

The installation directory has the following structure:

■ bin. The bin directory contains the following command line tools. The default 
location of the bin directory is:

installdir\bin

Note: The Multiple User Environment supports access from 
several accounts. It does not support multiple users accessing the 
SDK simultaneously. See "Switching Users."
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– cref. The Java Card Platform Simulator tool, which is used to simulate smart 
cards in the emulator.  It is used for testing SATSA (JSR 177) applications with 
the Oracle Java ME SDK.  For more information on SATAS, see Chapter 20.

– device-address is a tool for viewing, adding, and removing devices that the 
SDK is not able to discover automatically. See "Manage Device Addresses 
(device-address)"

– device-manager. The device manager is a component that must be running 
when you work with Oracle Java ME SDK. After installation it starts as a 
service, and it automatically restarts every time your computer restarts. See 
"Emulators."

– emulator. UEI compliant emulator. See "Emulator Command Line Options."

– jadtool. Tool for signing MIDlets. See "Sign MIDlet Suites (jadtool)."

– mekeytool. Management of ME keystores. See "Manage Certificates 
(MEKeyTool)".

– preverify. The Java ME preverifier.

– device-editor. Tool for creating new custom devices. See "Creating a Custom 
Device."

– update-center. The Java ME SDK Update Center.

– wma-tool. A command line tool for sending and receiving SMS, CBS, and 
MMS messages. See "Running WMA Tool."

– wscompile. Compiles of stubs and skeletons for JSR 172. See "Generate Stubs 
(wscompile)".

■ docs. Release documentation.

■ legal. License and copyright files.

■ lib. JSR JAR files for compilation.

■ runtimes. CDC, CLDC, and IMP-NG runtime files.

■ toolkit-lib. Java ME SDK files for configuration and definition of devices and UI 
elements. Executables and configuration files for the device manager and other 
SDK services and utilities. 

NetBeans User Directories
These are the default NetBeans user directories.

■ NetBeans default project location:

username\My Documents\NetBeansProjects

■ To see the NetBeans user directory, click the Help menu and select About in the 
main window. The default location is:

username\.netbeans\3.3

Oracle Java ME SDK Directories
This documentation sometimes uses username to represent the root location of user 
files. 
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■ The javame-sdk directory contains device instances and session information. If 
you delete this directory, it is re-created automatically when the device manager is 
restarted.

username\javame-sdk\3.3

■ Device working directories

username\javame-sdk\3.3\work\devicename

The named subdirectories each correspond to an emulation device, as described in 
Table 8–1. Any detected external devices are also added to this directory space. 
Device detection is described in "Adding an External Device."

■ Device instances (device definitions). 

installdir\toolkit-lib\process\device-manager\device-adapter

This directory contains the bean files for the adapter categories. The beans in this 
directory and subdirectories determine whether a skin is visible in the Device 
Selector, among other things. You should not manipulate these files directly.

See "Using the Custom Device Editor" for instructions on creating your own 
custom skin. 

■ Both default skins and custom skins created with the Custom Device Editor are 
represented in the device-adapter directory. 

Table 8–1 Device Names

Device Platform Emulator # 

ClamshellJavaMEPhone1 CLDC 0

DefaultCdcPbpPhone1 CDC 1

IMPNGDevice1 CLDC 2

IMPNGDevice2 CLDC 3

JavaMEPhone1 CLDC 4

JavaMEPhone2 CLDC 5

VgaAGUIPhone1 CDC 6

VgaCdcPhone1 CDC 7

Note: Do not manipulate custom skin files from the operating 
system. All custom skin activity should take place in the Custom 
Device Editor.
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9Profiling Applications

The Oracle Java ME SDK supports performance profiling for Java ME applications. 
The profiler keeps track of every method in your application. For a particular 
emulation session, it figures out how much time was spent in each method and how 
many times each method was called.

The SDK supports offline profiling. Data is collected during the emulation session. 
After you close the emulator you can export the data to a .nps file you can load and 
view later. As you view the snapshot you can investigate particular methods or classes 
and save a customized snapshot (a .png file) for future reference.

You can start a profiling session from the NetBeans IDE, as described in "Collecting 
and Saving Profiler Data in the IDE" or from the command line, as discussed in 
"Command Line Profiling." It is important to understand that profiling data produced 
from the command line has a different format (*.prof) than data produced from the 
NetBeans profiler (a.nps  file). 

Profiling data from Oracle Java ME SDK projects is displayed in a tab in the IDE. The 
NetBeans IDE has a Profiling window (Window > Profiling > Profiler) but it is not 
discussed here. Because only performance profiling is supported, the Profiler window 
has limited usefulness for Java ME applications. 

Collecting and Saving Profiler Data in the IDE
This procedure describes interactive profiling. To run profile an application from the 
command line, see "Command Line Profiling."

1. In the Projects widow, right-click the project you want to profile and select Profile.

If this is the first time profiling this project you are prompted to integrate the 
profiler. Click Yes to perform the integration.

Note: This feature might slow the execution of your application.

Note: The profiler maintains a large amount of data, so profiled 
MIDlets place greater demands on the heap. To increase the Heapsize 
property, see "Setting Device Properties."
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Figure 9–1 Profiling of AudioDemo

The profiler attaches. You are prompted for the running options. Click Yes.

Figure 9–2 Attaching the Profiler

Check the CPU Profiler, and optionally check Profile System Classes. Press Run.

The emulator opens with your application running.

2. Interact with the application MIDlet(s) as you normally would.

The data is automatically displayed in a tab labeled cpu:time, where time is the 
time the data was displayed. 
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Figure 9–3 The Profiling Tab with Combined View Selected

3. To export the profile data, press the Export icon and supply a .nps file name and 
location. This data can be reloaded at a later time. See "Loading a .nps File."

Figure 9–4 Exporting Profile Data

4. To the save the current view to a .png file, press the "Save current view to image" 
icon and supply a file name and location. 

Figure 9–5 Saving the Current View
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Loading a .nps File
A previously exported .nps file ("Collecting and Saving Profiler Data in the IDE") can 
be loaded at a later time.

Follow these steps to retrieve profile data:

1. Click the  Profile menu and select Load Snapshot... .

2. Choose the .nps file. 

The Profiler opens in its own tab labeled cpu:filename. Click the Info tab at the bottom 
of the Method table to view the snapshot. 

Importing a .prof File
A .prof file created from the command line ("Command Line Profiling") can be loaded 
from the NetBeans IDE. The following example shows what a command line profiling 
session command might look like:

emulator.exe -Xdevice:JavaMEPhone1 
-Xdescriptor:"C:\Documents and Settings\username\My Documents\NetBeansProjects\UID
emo\dist\Games.jad" -Xprofile:file=C:\temp\UIDemo.prof

Files created from the command line are formatted differently from the .nps files 
created as described in "Collecting and Saving Profiler Data in the IDE."

Follow these steps to retrieve command line profile data from the IDE:

1. Click the File menu and select Open File... .

2. Browse to the .prof file you want and click Open. 

The Profiler displays the data in its own tab labeled cpu:filename.

When the file has been loaded it can be saved in the .nps format. Click the Export to... 
icon and supply a  file name and location.

Note: The profiling values obtained from the emulator do not 
reflect actual values on an external device.
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10Network Monitoring

MIDP applications, at a minimum, are capable of HTTP network connections, but 
many other types of network connections are also possible. The network monitor 
provides a convenient way to see the information your application is sending and 
receiving on the network. This is helpful if you are debugging network interactions or 
looking for ways to optimize network traffic.

Networking monitoring works for emulators only (it is not supported for external 
devices).

■ "Monitor Network Traffic"

■ "Filter or Sort Messages"

■ "Save and Load Network Monitor Information"

■ "Clear the Message Tree"

Monitor Network Traffic
Follow these steps to activate the network activity for an application.

1. In the Projects window, right-click a project and select Profile.

2. If this is the first time profiling this application you are prompted to integrate the 
profile with the project. Click Yes to perform the integration.

In the Profile window, select Network Monitor, and click Run.

Figure 10–1 Activating Network Activity

3. Start your application. 
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When the application makes any type of network connection, information about 
the connection is captured and displayed in the Network Monitor tab.

Figure 10–2 The Network Monitor Tab

The top frame displays a list of messages. Click a message to display its details in 
the bottom frame.

In the Hex View, message bodies are shown as raw hexadecimal values with the 
equivalent text.

You can view information up to a specific delimiter or back to a previous delimiter 
by clicking the Find Previous(Shift+F3) Occurrence or Find Next Occurrence(F3) 
icons in the toolbar (between the Find Results and Clear Inactive Connection 
icons).

Note: You can examine messages that are still in the process of 
being sent. Incomplete messages are indicated by bold highlighting 
in the message tree.
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Filter or Sort Messages
Filters are useful for examining some subset of the total network traffic.

■ In the [Select Devices] list check only the devices you want to view.

■ In the [Select Protocols] list check only the protocols you want to view. The 
protocols listed reflect what is currently installed on the device.

■ Click the magnifying glass in the Network Monitor toolbar to search for a specific 
string in the data in the Phone or URL columns.

Time. Messages are sorted in chronological order of time sent or received.

URL. Messages are sorted by URL address. Multiple messages with the same address 
are sorted by time.

Click on a table header to sort the message data.

Save and Load Network Monitor Information
To save your network monitor session, click the Save Snapshot or Save As a Snapshot 
icon at the left of the Network Monitor toolbar. 

Figure 10–3 The Network Monitor Toolbar

Choose a file name. The default file extension is .nmd (network monitor data). 

Follow these steps to load a network monitor session: 

1. Click the File menu and select Open File... .

2. Browse to the .nmd file you saved.

Clear the Message Tree
To remove all inactive protocol records from the network monitor choose the clear icon 
(the broom icon on the right of the Network Monitor tool bar).

Note: To avoid memory issues, the Hex view display is currently 
limited to 16kB of data.
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11Monitoring Memory

This chapter describes how to use tracing and the memory monitor to examine an 
application’s memory use on a particular device.

Activating tracing for a particular device enables you to see low-level information as 
an application runs.

The Memory Monitor shows memory use as an application runs. It displays a dynamic 
detailed listing of the memory usage per object in table form, and a graphical 
representation of the memory use over time. You can take a snapshot of the memory 
monitor data. Snapshots can be loaded and examined later.

Enabling Tracing
Follow these steps to enable tracing. 

1. In the Device Selector window, right-click a device and select Properties.

2. In the Properties window, go to the Monitor node and check the desired trace 
options. 

■ Trace GC (garbage collection). Monitoring GC can help you determine object 
health. The garbage collector cannot delete objects that do not have a null 
reference. Dead objects will be garbage collected and not reported as live. 

■ Trace Class Loading. Observing class initialization and loading is useful for 
determining dependencies among classes.

■ Trace Exceptions. Display exceptions caught.

■ Trace Method Calls. Reports methods called and returned. The output for this 
option is very verbose and it can affect performance.

3. (Optional) Verbose tracing output might cause you to run out of memory on the 
device before the application is fully tested. You can increase the device memory 
as follows:

Right-click a device and select Properties. From the General node, select Heapsize, 
and choose a size. 

Note: The memory use you observe with the emulator is not exactly 
the same as the memory use on an external device. Remember, the 
emulator does not represent an external device. It is one possible 
implementation of its supported APIs.
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Tracing data is displayed in the output window (Window > Output > Output) when 
an application is run on this device. It is also written to the device log, which is stored 
in the working directory for the device. For example: 

username\javame-sdk\3.3\work\JavaMEPhone1\device.log

Using the Memory Monitor
Follow these steps to examine an application’s memory use. 

1. In the Projects view, right-click the project and select Profile. 

■ If the profiler is not yet integrated you are prompted to enable profiling for the 
project. Click Yes to continue.

The Profile window opens.

■ Select Memory Monitor, and click Run.

The output window tab is labeled "memory-monitor" indicating that the memory 
monitor is active for this session. The output window displays both application 
status and tracing outputs for this device.

The memory monitor opens.

2. Interact with the application as usual.

In the Memory Monitor tab you see data displayed on the graph above and in the 
object table below. 

To the left of the graph you see the Current memory use in bytes. The green line 
plots these values. The red line is the maximum amount of memory used since 
program execution, corresponding to the Maximum size in bytes on the left.

The object table columns are as follows:

■ Name. Object class name.

■ Total. Total number of objects allocated since the application began. The 
percentage given is the number of objects allocated over the total number of 
objects.

■ Total Size. Total amount of memory the object uses in bytes. The percentage 
value is the amount of memory used over the total amount of memory.

■ Average Size. Average object size in bytes, calculated by dividing the number 
of live instances by the total size.

Beneath the table you see counters displaying the total number of objects, the 
amount of memory used, the amount of free memory, and the total amount of 
memory on the device.

WARNING: Do not suspend the emulator while using the memory 
monitor. 
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Figure 11–1 The Memory Monitor Tab

3. Interact with the object table while the memory monitor is running.

■ Click a column header to sort the data. The sorting is case sensitive.

■ Click a row to display the call stack tree in a window to the right of the table.

– Click a folder to browse the call stacks tree to see the methods that create 
the object.

– To find a particular method in the call stacks tree, click Find and enter a 
search string. 

– Click Refresh to update the call stacks tree as data is gathered. It is not 
refreshed automatically.

4. Take a snapshot of the memory monitor. Because the data changes rapidly it is 
convenient to take several snapshots and review them later.

Click the "Save session to file" icon above the graph and specify a file name and 
location for the monitor data. The automatically supplied extension is .mms.

5. Exit the application. 

Some applications contain multiple MIDlets. 

■ When you exit a MIDlet the table data is cleared.

■ The graph data is not cleared when you exit a MIDlet. The graph data you see 
is cumulative for this emulator session. The memory monitor plots session 
data for any MIDlet run on the current emulator until you exit the application 
and close the emulator. 
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Viewing a Session Snapshot
Follow these steps to reload a memory monitor snapshot.

1. Click the File menu and select Open File... .

2. Browse to an .mms file you saved.

The memory monitor opens in its own tab in the main window. Note the tab 
displays the time the snapshot was taken.
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12Security and MIDlet Signing

MIDP 2.1 (JSR 118) includes a comprehensive security model based on protection 
domains. MIDlet suites are installed into a protection domain that determines access to 
protected functions. The MIDP 2.1 specification also includes a recommended practice 
for using public key cryptography to verify and authenticate MIDlet suites.

The general process to create a cryptographically signed MIDlet suite is as follows:

1. The MIDlet author, probably a software company, buys a signing key pair from a 
certificate authority (the CA).

2. The author signs the MIDlet suite with the signing key pair and distributes their 
certificate with the MIDlet suite.

3. When the MIDlet suite is installed on the emulator or on a device, the 
implementation verifies the author's certificate using its own copy of the CA's root 
certificate. Then it uses the author's certificate to verify the signature on the MIDlet 
suite. 

4. After verification, the device or emulator installs the MIDlet suite into the security 
domain that is associated with the CA's root certificate.

For definitive information, consult the MIDP 2.1 specification at:

http://download.oracle.com/otndocs/jcp/midp-2.1-mrel-oth-JSpec

See the following topics:

■ "Security Domains"

■ "Setting Security Domains"

■ "Signing a Project"

■ "Managing Keystores and Key Pairs"

■ "Managing Root Certificates"

Security Domains
The SDK supports the following security domains:

minimum. All permissions are denied to MIDlets in this domain.

maximum. All permissions are granted to MIDlets in this domain. Maximum is the 
default setting.

unidentified_third_party. Provides a high level of security for applications whose 
origins and authenticity cannot be determined. The user is prompted frequently when 
the application attempts a sensitive operation.
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identified_third_party. Intended for MIDlets whose origins were determined using 
cryptographic certificates. Permissions are not granted automatically, but the user is 
prompted less often than for the unidentified_third_party domain.

operator. All permissions are denied to MIDlets in this domain.

manufacturer. Intended for MIDlet suites whose credentials originate from the 
manufacturer's root certificate.

Setting Security Domains
In the SDK, when you use Run Project via OTA, your packaged MIDlet suite is 
installed directly into the emulator where it is placed in a security domain. The 
emulator uses public key cryptography to determine the appropriate security domain.

■ If the MIDlet or MIDlet suite is not signed, it is placed in the default security 
domain.

■ If the MIDlet or MIDlet suite is signed, it is placed in the protection domain that is 
associated with the root certificate of the signing key's certificate chain.  See 
"Signing a Project."

If your project is a MIDlet suite, the entire suite is signed (the individual MIDlets 
contained within are not).

Specify the Security Domain for an Emulator
1. In the Device Selection window, right-click on the device and select Properties.

2. Find the Security Domain setting and make a selection from the context menu. 

The SDK knows the runtimes the device can support and supplies only possible 
domains. The default setting for the sample projects is Maximum.

Specify the Security Domain for a Project
1. Right-click a project and select Properties.

2. In the Category area, select Running (the green triangle).

3. Select Regular Execution and check the Security Domain box. 

In this context regular execution means you are running in the emulator, as 
opposed to running OTA.

4. Select the domain from the drop-down menu.

Signing a Project
Devices use signing information to check an application's source and validity before 
allowing it to access protected APIs. For test purposes, you can create a signing key 
pair to sign an application. The keys are as follows:

■ A private key that is used to create a digital signature, or certificate.

■ A public key that anyone can use to verify the authenticity of the digital signature.

You can create a key pair with the Keystores Manager as described in "Managing 
Keystores and Key Pairs."
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Sign a CLDC Project With a Key Pair
Follow these steps to sign a CLDC project with a key pair:

1. Right-click a project and select Properties.

2. From the Build category, select Signing.

3. Check the Sign Distribution checkbox.

4. Choose a keystore from the Keystores drop-down menu, or click Open Keystores 
Manager to create a keystore. 

The Certificate Details area displays the Subject, Issuer, and Valid (validity dates 
for the selected keystore) information.

5. Choose a key pair alias from the drop-down menu. 

A keystore might be accessed by several key pairs, each with a different alias. If 
you prefer to use a unique key pair, select Open Keystores Manager and create a 
new key pair. See "Create a Keystore."

6. Click OK.

See "Obfuscating."

Sign a CDC Project
To sign a CDC project use the JDK jarsigner command from the command line. For 
example:

jarsigner.exe -keystore keystore.ks -storepass keystorepwd MyCdcApp.jar dummyCA

Managing Keystores and Key Pairs
For test purposes, you can create a signing key pair to sign a MIDlet. The Keystores 
Manager administers this task, as described in the remainder of this topic, the key pair 
consists of two keys:

■ A private key that is used to create a digital signature, or certificate.

■ A public key anyone can use to verify the authenticity of the signature.

To deploy on a device, you must obtain a signing key pair from a certificate authority 
recognized by the device. You can also import keys from an existing Java SE platform 
keystore.

The following topics describe the user interface: 

■ "Security Domains"

■ "Create a New Key Pair"

■ "Remove a Key Pair"

■ "Import an Existing Key Pair"

You can also use the command line tools described in "Command Line Security 
Features."

Working With Keystores and Key Pairs
The Keystores Manager handles creating and using keystores. The keystores known to 
the Keystores Manager are listed when you sign a project, as described in "Signing.".
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Keystores contain key pairs, which you can also manage from this dialog. You must 
select a keystore to access the key pair tools.

■ Section , "Security Domains"

■ Section , "Create a New Key Pair"

■ Section , "Remove a Key Pair"

■ Section , "Import an Existing Key Pair"

Create a Keystore
1. Select the Tools menu and select Keystores.

The Keystores Manager opens.

2. Click Add Keystore....

The Add Keystores window opens.

3. Select Create a New Keystore.

4. Supply a name, location, and password.

5. Click OK.

The new keystore appears in the Keystores list.

Add an Existing Keystore
1. Select the Tools menu and select Keystores.

The Keystores Manager opens.

2. Click Add Keystore....

The Add Keystores window opens.

3. Select Add Existing Keystore.

4. Browse to the location of the keystore and select the keystore file. The default 
location for user-defined keystores is:

username

5. Select a keystore and Click Open, then click OK.

The existing keystore appears in the Keystores list. You might have to unlock this 
keystore, and each key pair within it.

Create a New Key Pair
1. Select the Tools menu and select Keystores.

The Keystores Manager opens.

2. Select a Keystore in the Keystores area on the left. If you prefer a different 
keystore, you can create one as described in "Create a Keystore."

 Note, you cannot add a key to the Built-in Keystore, but you can export a key 
from it.

3. Click the New... button.

4. Fill in the Create Key Pair dialog:

You must provide an alias to refer to this key pair. 
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The six Certificate Details fields are provisionally optional. You must complete at 
least one field.

Key Pair Alias. The name used to refer to this key pair.

Common Name. Common name of a person, such as "Jane Smith"

Organization Unit. Department or division name, such as "Development"

Organization Name. Large organization name, such as "Oracle Corporation"

Locality Name. Locality (city) name, such as "Santa Clara"

State Name. State or province name, such as "California"

Country. Two-letter country code, such as "US"

Although not required, you should provide a password. The password should be 
at least six characters long.

5. Click OK.

The new key is displayed in the Keys area under its alias. You can now select this 
keypair when you sign a project. See "Signing a Project."

Remove a Key Pair
1. Select the Tools menu and select Keystores.

2. In the Keys area, click a Key Pair.

3. Select Delete. You are asked if you are sure. Click Yes if you are and the delete 
proceeds.

Import an Existing Key Pair
If you have keys in a Java SE platform keystore that you would like to use for MIDlet 
signing, you can import the signing keys to the Java ME SDK.

1. Select the Tools menu and select Keystores.

2. Click Add Keystore....

The Add Keystore window opens.

3. Click Add Existing Keystore.

4. Browse to the keystore location.

5. Click OK.

Managing Root Certificates
The Oracle Java ME SDK command line tools described in "Manage Certificates 
(MEKeyTool)" manage the emulator's list of root certificates.

External devices have similar lists of root certificates, although you typically cannot 
modify them. When you deploy your application on an external device, you must use 
signing keys issued by a certificate authority whose root certificate is present on the 
device. This makes it possible for the device to verify your application.

Each emulator instance has its own _main.ks file located in its appdb directory. For 
example: username\javame-sdk\3.3\work\devicename\appdb.

You can use the -import option to import certificates from these keystores as described 
in "Manage Certificates (MEKeyTool)."
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This topic describes how to operate the Oracle Java ME SDK from the command line 
and details the command line tools required to build and run an application.

■ "Run the Device Manager"

■ "Manage Device Addresses (device-address)"

■ "Emulator Command Line Options"

■ "Build a Project from the Command Line"

■ "Packaging a MIDlet Suite (JAR and JAD)"

■ "Command Line Security Features"

■ "Generate Stubs (wscompile)"

Run the Device Manager
The device manager is a component that runs as a service. It detects devices (real or 
emulated) that conform to the Unified Emulator Interface Specification 
(http://www.oracle.com/technetwork/java/javame/documentation/uei
specs-187994.pdf), version 1.0.2. The Device Manager automatically restarts every 
time you use the SDK. You can manually launch the device manager from a script or a 
command line.

installdir\bin\device-manager.exe 

To see a log of activities, launch the device manager with the -XenableOutput option. 

Manage Device Addresses (device-address)
installdir\bin\device-address is a tool for viewing, adding, and removing devices 
that the SDK is not able to discover automatically. The Microsoft device emulator is an 
example of such a device. The syntax is:

Table 13–1 Device Address Commands

Command Action

add address_type address Add the specified address.

del address_type address Delete the specified address.

list List all addresses.

list address_type List the addresses of the specified type.
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For example, the following command adds a device:

installdir\bin\device-address.exe add ip 192.168.1.2

Emulator Command Line Options
You can launch the emulator independent of the GUI using bin\emulator. The syntax 
is as follows:

emulator options

The general options are as follows:

This is a simple example of running the emulator from the command line:

emulator.exe -Xdescriptor:C:\Java_ME_platform_SDK_3.3\apps\Games\dist\Games.jad 
-Xdevice:JavaMEPhone2

MIDlet Options
Options for running MIDlets in the emulator are as follows:

■ -Xautotest:JAD-file-URL

Run in autotest mode. This option installs a MIDlet suite from a URL, runs it, 
removes it, and repeats the process. The purpose is to run test compatibility kits 
(TCKs) with the emulator, using a test harness such as JT Harness or Java Device 
Test Suite (JDTS).

For example:

emulator -Xautotest:http://localhost:8080/test/getNextApp.jad

Given the above command, -Xautotest causes the emulator to repeatedly install, 
run, and remove the first MIDlet from the MIDlet suite provided through the 
HTTP URL. When the emulator starts, it queries the test harness, which then 
downloads and installs the TCK MIDletAgent.

■ -Xdescriptor:jad-file

Install a MIDlet, run it, and uninstall it after it finishes.

■ -Xdomain:domain-name

Set the MIDlet suite's security domain.

Table 13–2 Emulator Commands

Command Action

-classpath path

-cp path

Specifies a search path for application classes. The path consists 
of directories, ZIP files, and JAR files separated by semicolons.

-D property=value Sets a system property value.

-help Display a list of valid options.

-version Display version information about the emulator.

-Xdevice:devicename Run an application on the emulator using the given device 
instance name. 

-Xquery Print emulator skin information on the standard output stream 
and exit immediately. The information includes the skin name, 
screen size, and other capabilities.
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The Xjam argument runs an application remotely using the Application Management 
Software (AMS) to run over-the-air (OTA) provisioning. If no application is specified 
with the argument, the graphical AMS is run. 

■ -Xjam[:install=<JAD-file-url> |force|list|storageNames| 
run=[<storageNames>|<StorageNumber>]|remove=[<storage name>|<storage 
number> | all]]

Installs the application with the specified JAD file onto a device. 

■ force. If an existing application has the same storage name as the application 
to be installed, force removes the existing application before installing the 
new application. 

■ list. List all the applications installed on the device and exit. The list is 
written to standard output before the emulator exits.

■ storageNames. List all applications installed on the device. The list is written 
to standard output before the emulator exits. Each line contains one storage 
name in numerical order. The list contains only the name so the order is 
important. For example the first storage name must be storage number 1. 

■ -Xjam:run=[<storage-name> | <storage-number>] 

Run a previously installed application. The application is specified by its valid 
storage name or storage number.

■ -Xjam:remove=[<storage-name> | <storage-number> | all] 

Remove a previously installed application. The application is identified by its 
valid storage name or storage number. If all is supplied, all previously installed 
applications are removed.

■ -Xjam:transient=jad-file-url

If specified, transient is an alias for installing, running, and removing the 
application with the specified JAD file.

■ -Xprofile[:system=<y/n>, file=file]

Profile the application’s CPU usage.

■ system. Whether to profile system classes. Default value is n (only user classes 
are profiled).

■ file. CPU profiler snapshot is stored to the specified file, %d in file name is 
replaced by snapshot number. If not specified, profiler data is not stored to a 
file, it is passed to a connected profiler if one is present.

This example illustrates OTA installation:

emulator -Xjam:install=http://www.myserver.com/apps/MyApp.jad
         -Xdevice:JavaMEPhone2

The above command returns the ID of the installed application. When you obtain the 
ID you can run it with: emulator=Xjam:run=ID

See  "Emulator Command Line Options" and "Debugging and Tracing Options."

CDC Options
The following options apply to CDC projects.

■ -Xmain:main-class-name
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Run the main method of a Java class, as in Java SE.

■ -Xxlet:classpath=class-path, class=fully-qualified-name,[arg=argument]*

Run an Xlet application.

See "Emulator Command Line Options" and "Debugging and Tracing Options."

Debugging and Tracing Options
You can use the following options with the emulator for debugging and tracing CLDC 
projects.

■ -Xdebug

Enable runtime debugging. The -Xrunjdwp option must be called to support 
-Xdebug.

■ -Xrunjdwp:debug-settings

Start a Java debug wire protocol session, as specified by a list of comma-separated 
debug settings. Both -Xrunjdwp and -Xdebug must be called. 

Valid debug settings include the following:

■ transport=transport-mechanism - Transport mechanism used to communicate 
with the debugger. The only transport mechanism supported is dt_socket.

■ address=host:port - Transport address for the debugger connection. If host is 
omitted, localhost is assumed to be the host machine.

■ server={y|n} - Starts the debug agent as a server. The debugger must connect 
to the port specified. The possible values are y and n. Currently, only y is 
supported (the emulator must act as a server).

■ suspend={y|n} - The possible values are y and n. 

When suspend is set to n, the application starts immediately and the debugger 
can be attached at any time during its run. 

When suspend is set to y, the application does not start until a debugger 
attaches to the debugging port and sends a resume command, so an 
application can be debugged from the very beginning.

This example shows debugging:

emulator.exe -Xdevice:JavaMEPhone1 -Xdebug -Xrunjdwp:transport=dt_

socket,suspend=n, server=y,address=51307 -Xdescriptor:..\apps\Games\dist\Games.jad 

-Xdomain:maximum

With the emulator running you can attach a debugger. 

■ To attach a graphical debugger from NetBeans, select Debug > Attach Debugger.

■ A sample command would be:

jdk/bin/jdb -connect 
com.sun.jdi.SocketAttach:hostname=localhost,port=51307

Command Line Profiling
To add profiling to an emulator session, use:

-Xprofile:[system=<y|n>], file=filename.prof

For example:
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emulator.exe -Xdevice:JavaMEPhone1 
-Xdescriptor:"C:\username\My Documents\NetBeansProjects\Games\dist\Games.jad" 
-Xprofile:file=C:\temp\Games.prof

When you launch the emulator and profile an application from the command line the 
data profile you save has a different format than .nps files created with the Profile 
option in the NetBeans IDE. 

Files created from the command line should be given the extension .prof to 
distinguish them from IDE profiler files. 

To view .prof files in the IDE, select Profile > Java ME > Import CPU Profiler 
Snapshot.... Your file is displayed in a tab labeled with the name of the file containing 
the snapshot. 

When the file is loaded in the IDE you can export the data in .nps form, using the 
Export to... feature as described in "Collecting and Saving Profiler Data in the IDE," 
Step 5. These files can be loaded using Profile > Java ME > Import CPU Profiler 
Snapshot....

Build a Project from the Command Line
In the user interface, building a project is a single step. Behind the scenes, however, 
there are two steps. First, Java source files are compiled into Java class files. Next, the 
class files are preverified, which means they are prepared for the CLDC VM. See the 
following topics:

■ "Check Prerequisites"

■ "Compile Class Files"

■ "Preverify Class Files"

Check Prerequisites
Before building and running an application from the command line, verify that the jar 
command is in your path. To find the version of the development kit, run java 
-version at the command line. 

Compile Class Files
Use the javac compiler from the Java SE development kit to compile Java source files. 
You can use the existing Oracle Java ME SDK project directory structure. Use the 
-bootclasspath option to tell the compiler to use the MIDP APIs, and use the -d 
option to tell the compiler where to put the compiled class files.

The following example demonstrates how you might compile a MIDP 2.1 application, 
taking source files from the src directory and placing the class files in the tmpclasses 
directory. Newlines have been added for clarity.

javac -target 1.3 -source 1.3 
   -bootclasspath ..\..\lib\cldc_10.jar;..\..\lib\midp2.1.jar
   -d tmpclasses
   src\*.java

For more information on javac, consult the Java SE documentation.
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Preverify Class Files
The next step is to preverify the class files. The bin directory of the Oracle Java ME 
SDK includes the preverify utility. The syntax for the preverify command is as 
follows:

preverify files | directories
Some of the options are as follows:

Following the example for compiling, use the following command to verify the 
compiled class files. As before, newlines are added for clarity.

preverify.exe
  -classpath ..\..\lib\cldcapi10.jar;..\..\lib\midpapi20.jar
  -d classes
  tmpclasses

As a result of this command, preverified class files are placed in the classes directory. 
If your application uses WMA, MMAPI, or other versions of CLDC or MIDP, be sure 
to include the relevant .jar files in the classpath.

Packaging a MIDlet Suite (JAR and JAD)
To package a MIDlet suite manually you must create a manifest file, an application 
JAR file, and finally, a MIDlet descriptor (also known as a Java Application Descriptor 
or JAD).

Create a manifest file containing the appropriate attributes as specified in the MIDP 
specification. You can use any text editor to create the manifest file. For example, a 
manifest might have the following contents:

MIDlet-1: My MIDlet, MyMIDlet.png, MyMIDlet
MIDlet-Name: MyMIDlet
MIDlet-Vendor: My Organization
MIDlet-Version: 1.0
MicroEdition-Configuration: CLDC-1.1
MicroEdition-Profile: MIDP-2.1

Create a JAR file containing the manifest and the suite's classes and resource files. To 
create the JAR file, use the jar tool that comes with the Java SE software development 
kit. The syntax is as follows:

jar cfm file manifest -C class-directory . -C resource-directory .
The arguments are as follows:

■ file - JAR file to create.

■ manifest - Manifest file for the MIDlets.

■ class-directory - Directory containing the application's classes.

Table 13–3 Options to preverify Command

Name Description

-classpath classpath Specify the directories or JAR files (given as a 
semicolon-delimited list) from which classes are loaded.

-d output-directory Specify the target directory for the output classes. This directory 
must exist before preverifying. If this option is not used, the 
preverifier places the classes in a directory called output. 
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■ resource-directory - Directory containing the application's resources.

For example, to create a JAR file named MyApp.jar whose classes are in the classes 
directory and resources are in the res directory, use the following command:

jar cfm MyApp.jar MANIFEST.MF -C classes . -C res .
Create a JAD file containing the appropriate attributes as specified in the MIDP 
specification. You can use any text editor to create the JAD file. This file must have the 
extension .jad.

For example, a JAD file might have the following contents:

MIDlet-Name: MyMIDlet
MIDlet-Vendor: My Organization
MIDlet-Version: 1.0
MIDlet-Jar-URL: MyApp.jar
MIDlet-Jar-Size: 24601

Command Line Security Features
The full spectrum of the Oracle Java ME SDK's security features are also available from 
the command line. You can adjust the emulator's default protection domain, sign 
MIDlet suites, and manage certificates.

■ "Change the Default Protection Domain"

■ "Sign MIDlet Suites (jadtool)"

■ "Manage Certificates (MEKeyTool)"

Change the Default Protection Domain
To adjust the emulator's default protection domain, use the following option with the 
emulator command:

-Xdomain:domain-type

Assigns a security domain to the MIDlet suite. Enter an appropriate security domain 
as described in "Security Domains." For example, -Xdomain:maximum.

Sign MIDlet Suites (jadtool)
jadtool is a command-line interface for signing MIDlet suites using public key 
cryptography according to the MIDP 2.1 specification. Signing a MIDlet suite is the 
process of adding the signer certificates and the digital signature of the JAR file to a 
JAD file. jadtool is also capable of signing payment update (JPP) files.

jadtool only uses certificates and keys from Java SE platform keystores. Java SE 
software provides keytool, the command-line tool to manage Java SE platform 
keystores.

jadtool is packaged in a JAR file. To run it, open a command prompt, change the 
current directory to installdir\bin, and enter the following command:

jadtool command

Note: You must set the MIDlet-Jar-Size entry to the size of the 
JAR file created in the previous step.
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The commands are as follows:

■ -help

Prints the usage instructions for jadtool.

■ -addcert -alias key alias[-storepass password] [-keystore  keystore] [-certnum 
number] [-chainnum number] [-encoding encoding]  -inputjad filename  
-outputjad filename

Adds the certificate of the key pair from the given keystore to the JAD file or JPP 
file.

■ -addjarsig [-jarfile filename] -keypass password -alias key alias -storepass 
password] [-keystore keystore] [-chainnum number] [-encoding encoding]  
-inputjad  filename  -outputjad  filename

Adds a digital signature of the input JPP file to the specified output JPP file.

■ -showcert [<[-certnum number]  [-chainnum number]> |[-all]]  [-encoding 
encoding] -inputjad filename

Displays information about certificates in JAD files. 

The default values are as follows:

■ -encoding - UTF-8 

■ -jarfile - MIDlet-Jar-URL property in the JAD file

■ -keystore - $HOME\.keystore 

■ -certnum - 1 

■ -chainnum - 1 

Manage Certificates (MEKeyTool)
MEKeyTool manages the public keys of certificate authorities (CAs), making it 
functionally similar to the keytool utility that comes with the Java SE SDK. The 
purpose of the keys is to facilitate secure HTTP communication over SSL (HTTPS).

Before using MEKeyTool, you must first have access to a Java Cryptography Extension 
keystore. You can create one using the Java SE keytool utility (found in the \bin 
directory for your JDK).

To run MEKeyTool, open a command prompt, change the current directory to 
installdir\bin, and enter the following command:

installdir\bin\mekeytool.exe -command

The command keywords follow. 

The Oracle Java ME SDK contains a default ME keystore named _main.ks, which is 
located in:

installdir\runtimes\cldc-hi\appdb

This keystore includes all the certificates that exist in the default Java SE platform 
keystore that comes with the Java SE installation. 

Also, each emulator instance has its own _main.ks file located in 
username\javame-sdk\3.3\work\devicename\appdb. If you do not specify a value for 
MEkeystore, a new key is added to the default ME key for this emulator instance.

If you do not specify a value for -keystore, the default keystore is used:
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username\keystore.ks

■ -help

Prints the usage instructions for MEKeyTool.

■ -import -alias alias [-keystore JCEkeystore][-MEkeystore filename] [-storepass 
storepass] -domain domain-name

Imports a public key into the ME keystore from the given JCE keystore using the 
given Java Cryptography Extension keystore password. and the default Java 
Cryptography Extension keystore is username\.keystore.

■ -list [-MEkeystore filename]

Lists the keys in the ME keystore, including the owner and validity period for 
each.

■ -delete (-owner owner | -number key-number)[-MEkeystore filename]

Deletes a key from the given ME keystore with the given owner.

Generate Stubs (wscompile)
Mobile clients can use the Stub Generator to access web services. The wscompile tool 
generates stubs, ties, serializers, and WSDL files used in Java API for XML (JAX) RPC 
clients and services. The tool reads a configuration file, that specifies either a WSDL 
file, a model file, or a compiled service endpoint interface. The syntax for the stub 
generator command is as follows:

wscompile [options] configuration-files

Table 13–4 lists the wscompile options:

Table 13–4 wscompile Options 

Option Description

-gen Same as -gen:client

-gen:client Generates client artifacts (stubs, etc.)

-import Generates interfaces and value types only

-d output directory Specifies where to place generated output files

-f:features Enables the given features

-g Generates debugging info

-features:features Same as -f:features

-httpproxy:host:port Specifies a HTTP proxy server (port defaults to 8080)

-model file Writes the internal model to the given file

-O Optimizes generated code

-s directory Specifies where to place generated source files

-verbose Outputs messages about what the compiler is doing

-version Prints version information

-cldc1.0 Sets the CLDC version to 1.0 (default). Float and double 
become String.

-cldc1.1 Sets the CLDC version to 1.1 (float and double are OK)

-cldc1.0info Shows all CLDC 1.0 information and warning messages.
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Table 13–5 lists the features (delimited by commas) that can follow the -f option. The 
wscompile tool reads a WSDL file, compiled service endpoint interface (SEI), or model 
file as input. The Type of File column indicates which of these files is used with a 
particular feature.

Examples

wscompile -gen -d generated config.xml
wscompile -gen -f:nounwrap -O -cldc1.1 -d generated config.xml

Note: Exactly one -gen option must be specified. The -f option 
requires a comma-separated list of features.

Table 13–5 Command Supported Features (-f) for wscompile 

Option Description Type of File

explicitcontext Turns on explicit service context mapping WSDL

nodatabinding Turns off data binding for literal encoding WSDL

noencodedtypes Turns off encoding type information WSDL, SEI, model 

nomultirefs Turns off support for multiple references WSDL, SEI, model 

novalidation Turns off full validation of imported WSDL 
documents

WSDL

searchschema Searches schema aggressively for subtypes WSDL 

serializeinterfaces Turns on direct serialization of interface 
types

WSDL, SEI, model 

wsi Enables WSI-Basic Profile features (default) WSDL

resolveidref Resolves xsd:IDREF WSDL

donotunwrap No unwrap. WSDL
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Oracle Java ME SDK uses the log4j logging facility to manage Device Manager and 
Device Instance logs.

Logging levels are configurable.

Device Manager Logs
The device manager log is placed into: 

username\javame-sdk\3.3\log\device-manager.log

You can configure logging levels in the following XML file:

installdir\toolkit-lib\process\device-manager\conf\log4j.xml

A priority value for the categories com.sun or VM can be set to the following levels: 
FATAL, ERROR, WARN, INFO, DEBUG, TRACE (ordered from least to most verbose).

Example 14–1 Setting a Category Value

<category name="com.sun">
   <priority value="DEBUG"/>
   <appender-ref ref="CONSOLE-ALL"/>
   <appender-ref ref="FILE"/>
</category>
   
<category name="VM">
   <priority value="INFO"/>
   <appender-ref ref="CONSOLE-ALL"/>
   <appender-ref ref="FILE"/>
</category>

Device Instance Logs
Each device (or emulator) instance writes its own log in to its directory. 

username\javame-sdk\3.3\work\devicename\device.log

log4j.xml controls the verbosity of the device instance logs, as described in "Device 
Manager Logs."
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15API Support

The Oracle Java ME SDK supports many standard Application Programming 
Interfaces (APIs) defined through the Java Community Process (JCP) program. JCP 
APIs are often referred to as JSRs, named after the Java Specification Request process. 
JSRs that are not part of the platform are referred to as "optional packages."

The CLDC/MIDP platform is based on the Mobile Information Device Profile and 
Connected Limited Device Configuration (JSRs 118 and 139). 

The IMP-NG platform is base on Information Module Profile - Next Generation (IMP-NG) 
(JSR 228).

See Table 15–1 for a full list of supported JCP APIs. The Oracle Java ME SDK provides 
documentation describing how certain APIs are implemented in the SDK. Many 
supported APIs do not require special implementation considerations, so they are not 
discussed in this help set. "Oracle APIs" describes Oracle APIs provided to support the 
IMP-NG platform. 

For convenience the Javadocs that are the intellectual property of Oracle are in your 
installation’s \docs directory. The remainder can be downloaded from 
http://jcp.org.

JCP APIs

Table 15–1 Supported JCP APIs

JSR, API Name, URL

JSR 75, PIM and File PDA Optional Packages for the J2ME Platform

http://jcp.org/en/jsr/detail?id=75

JSR 82, Bluetooth and 
OBEX

Java APIs for Bluetooth

http://jcp.org/en/jsr/detail?id=82

JSR 118, MIDP 2.1 Mobile Information Device Profile

http://jcp.org/en/jsr/detail?id=118

JSR 135, MMAPI 1.1 Mobile Media API

http://jcp.org/en/jsr/detail?id=135

JSR 139, CLDC 1.1 Connected Limited Device Configuration

http://jcp.org/en/jsr/detail?id=139

JSR 172, Web Services J2ME Web Services Specification

http://jcp.org/en/jsr/detail?id=172
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Oracle APIs
The IMP-NG project type supports developing applications for the Oracle Java ME 
Embedded 3.3 runtime. The Java ME Embedded 3.3 runtime includes several standard 
JSR APIs and additional Oracle APIs for embedded use cases. These new APIs are:

■ Device Access API

The Device Access API provides interfaces and classes for communicating with 
and controlling peripheral devices.

■ Logging API

JSR 177, SATSA Security and Trust Services API for Java ME

http://jcp.org/en/jsr/detail?id=177

JSR 179, Location Location API for Java ME

http://jcp.org/en/jsr/detail?id=179

JSR 184, 3D Graphics Mobile 3D Graphics API for J2ME

http://jcp.org/en/jsr/detail?id=184

JSR 205, WMA 2.0 Wireless Messaging API

http://jcp.org/en/jsr/detail?id=205

JSR 209, AGUI 1.0 Advanced Graphics and User Interface Optional Package for the J2ME 
Platform

http://www.jcp.org/en/jsr/detail?id=209

JSR 211, CHAPI Content Handler API

http://jcp.org/en/jsr/detail?id=211

JSR 217, PBP 1.1 Personal Basis Profile 1.1

http://www.jcp.org/en/jsr/detail?id=217

JSR 218, CDC 1.1 Connected Device Configuration 1.1

http://jcp.org/en/jsr/detail?id=218

JSR 226, SVG Scalable 2D Vector Graphics API for J2ME

http://jcp.org/en/jsr/detail?id=226

JSR 228, IMP-NG Information Module Profile - Next Generation (IMP-NG)

http://jcp.org/en/jsr/detail?id=228

JSR 234, AMMS Advanced Multimedia Supplements

http://jcp.org/en/jsr/detail?id=234

JSR 239 Java Binding for OpenGL ES API

http://jcp.org/en/jsr/detail?id=239

JSR 256 Mobile Sensor API

http://jcp.org/en/jsr/detail?id=256

JSR 257 Contactless Communication API

http://jcp.org/en/jsr/detail?id=257

JSR 280, XML API XML API for Java ME

http://jcp.org/en/jsr/detail?id=280

Table 15–1 (Cont.) Supported JCP APIs

JSR, API Name, URL
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The Logging API provides a lightweight and extensible framework based on the 
concepts of the java.util.logging package, enabling applications to log messages in 
a variety of formats and using custom handlers. 

■ AMS API

The AMS API provides an interface to the application management capabilities of 
the runtime to allow authorized applications to interact with and extend the 
application management system.

■ AccessPoint API

The AccessPoint API is an extension to the Generic Connection Framework and 
enables applications to select among multiple access points if the underlying 
platform provides more than one data access point.

The Javadocs for these APIs are in your installation’s \docs directory.
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16JSR 75: PDA Optional Packages

The Oracle Java ME SDK supports JSR 75, the PDA Optional Packages (PDAP) for the 
J2ME Platform. JSR 75 includes two independent APIs:

■ The FileConnection optional package allows MIDlets access to a local device file 
system.

■ The Personal Information Management (PIM) optional package includes APIs for 
manipulating contact lists (address book), calendars, and to-do lists.

This chapter describes how the Oracle Java ME SDK implements the FileConnection 
and PIM APIs.

FileConnection API
On an external device, the FileConnection API typically provides access to files stored 
in the device's memory or on a memory card.

In the Oracle Java ME SDK emulator, the FileConnection API enables MIDlets to access 
files stored on your computer's hard disk.

The files that can be accessed using the FileConnection optional package are stored in 
the following subdirectory: 

username\javame-sdk\3.3\work\devicename\appdb\filesystem

For example, the JavaMEPhone1 emulator instance comes with a root directory installed 
named root1. Each subdirectory of filesystem is called a root. The Oracle Java ME 
SDK provides a mechanism for managing roots. 

While the emulator is running, click the Tools menu and select Manage File System. 
The Manage File System dialog box opens.

In the Mounted File System Root Directories panel you can mount, unmount, or 
unmount and delete filesystem roots. Mounted roots are displayed in the top list, and 
unmounted roots are listed in the Unmounted File System Root Directories panel. You 
can remount or delete a selected directory. Mounted root directories and their 
subdirectories are available to applications using the FileConnection API. Unmounted 
roots can be remounted in the future.

■ To add a new empty filesystem root directory, click Mount Empty... and fill in a 
name for the directory.

■ To mount a copy of an existing directory, click Mount Copy..., and browse to 
choose a directory you want to copy. When the File System Root Entry dialog 
opens, enter the name for this root. A deep copy of the selected directory is placed 
into the emulator's filesystem with the specified root name.
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■ To make a directory inaccessible to the FileConnection API, select it in the list and 
click Unmount. The selected root is unmounted and moved to the Unmounted 
roots list.

■ To completely remove a mounted directory, select it and click Unmount & Delete.

■ To remount an unmounted directory, select it and click Remount. The root is 
moved to the mounted roots list.

■ To delete an unmounted directory, select it and click Delete. The selected root is 
removed from the list.

PIM API
The Oracle Java ME SDK emulator stores contact, calendar, and to-do information in 
standard files on your desktop computer's hard disk. All information is stored in:

username\javame-sdk\3.3\work\devicename\appdb\PIM

Each device instance has its own data. Lists are stored in subdirectories of the 
contacts, events, and todo directories. For example, a contact list called Contacts is 
contained in installdir\appdb\PIM\contacts\Contacts.

Inside the list directory, items are stored in vCard (.vcf) or vCalendar (.vcs) format 
(see http://www.imc.org/pdi/). Contacts are stored in vCard format, while 
calendar and to-do items are both stored in vCalendar format.

Running PDAPDemo
PDAPDemo shows how to use the PIM and FileConnection APIs that are part of the JSR 
75 specification.

Browsing Files
The default emulators have one directory, root1. This directory is located at:

username\javame-sdk\3.3\work\devicename\appdb\filesystem\root1

For test purposes, copy files or even directories into root1. You can also add other 
directories at the same level as root1.

Now open and run the PDAPDemo project. 

■ Launch the FileBrowser MIDlet. You see a directory listing, and you can browse 
through the directories and files you have placed there. 

■ Select a directory and press the View soft button to enter it. 

■ Using the Menu commands you can view a file or see its properties. Try selecting 
the file and choosing Properties or View from the menu. 

You can view the content of text files in the browser.

■ Try using the External Events Generator to unmount and mount directories. 
Unmounted directories are not visible in the application running on the emulator.

The PIM API
The JSR75 PIM APIs example demonstrates how to access personal information, such 
as contact lists, calendars, and to-do lists. 

■ After you launch the example, choose a type of list from the main menu.
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In this example each type of list works the same way and each list type contains a 
single list. For example, if you choose Contact Lists, there is a single contact list 
called Contacts. Event Lists contains a single list called Events, and To-Do Lists 
contains a single list named To Do.

■ After you have selected a list type and chosen the specific list, you can view all the 
items in the list. If this is the first time you have run the example, the list might be 
empty.

■ To add an item, select New from the menu. The application prompts you for a 
Formatted Name for the item. 

To add more data fields to this item select Add Field. You see a list of field names. 
Pick as many as you like. You can fill in the fields at any time.

■ To save the new item, select Commit from the menu.

To return to the list, choose the Back command. You see the item you just created 
in the list.

The items that you create are stored in standard vCard or vCalendar format in this 
directory:

username\javame-sdk\3.3\work\devicename\appdb\PIM

The PIM API allows for exporting contact, calender, and to-do items in a standard 
format. The exact format depends on the list type. When you are viewing an item in 
any list, the menu contains a command for viewing the exported item.

For example, when you are viewing a contact list item, the menu contains Show 
vCard. When you choose this command, the exported item is shown on the screen. 
Calendar items and to-do items both get exported as vCalendar.
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17JSR 82: Bluetooth and OBEX Support

This chapter describes how the Oracle Java ME SDK implements the Bluetooth and 
OBEX APIs.

The Oracle Java ME SDK emulator supports JSR 82, the Java APIs for Bluetooth. The 
emulator is fully compliant with version 1.1 of the specification, which describes 
integration with the push registry. JSR 82 includes two independent APIs:

■ The Bluetooth API provides an interface to Bluetooth wireless networking, 
including device discovery and data exchange.

The Oracle Java ME SDK emulator enables you to develop and test applications 
that use Bluetooth without having actual Bluetooth hardware. The SDK simulates 
a Bluetooth environment for running emulators. Multiple emulator instances can 
discover each other and exchange data using the Bluetooth API.

For an example, see "Running the Bluetooth Demo."

■ The OBEX API allows applications to use the Object Exchange (OBEX) protocol 
over Bluetooth or other communication channels.

The Oracle Java ME SDK implements OBEX transfer over simulated Bluetooth and 
TCP connections. 

For an example, see "Running the OBEX Demo."

Setting OBEX and Bluetooth Properties
The Oracle Java ME SDK enables you to configure the Bluetooth and OBEX simulation 
environment. Because the simulation requires a sender and receiver, Bluetooth settings 
are configured separately for each device. Follow these steps to set device properties:

1. In the device selector, right-click a CLDC device and select Properties.

The device properties are displayed in the Properties window. If you do not see 
this window, click the Window menu and select Properties from the NetBeans 
toolbar.

2. Scroll down to see the Bluetooth and OBEX properties. When you click a property 
a description is shown in the description area. If you can not see this area, right 
click a property and select Show Description Area.

The System Properties can be retrieved in an application using the getProperty() 
method in javax.bluetooth.LocalDevice. The Bluetooth properties are fully 
described in the JSR 82 specification.

■ Bluetooth Enabled

Enable or disable state of Bluetooth functionality
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■ Bluetooth Address

The Bluetooth address of this device

■ Friendly Name

Human-readable name of the device

■ bluetooth.sd.trans.max

The maximum number of concurrent service discovery transactions. The default is 
8.

■ bluetooth.sd.attr.retrievable.max

The maximum number of service attributes to be retrieved per service record.The 
default is 16.

■ bluetooth.master.switch

Enable or disable a master or slave switch. Enabled by default.

■ bluetooth.l2cap.receiveMTU.max

The maximum ReceiveMTU size in bytes supported in L2CAP. This is the 
maximum payload size this connection can accept.

The default value is 672.

■ OBEX Maximum Packet Length

The default is 4096 bytes. 

The maximum packet length affects how much data is sent in each packet between 
emulators. Shorter packet values result in more packets and more packet 
overhead.

■ Device is discoverable

Enabled by default. 

■ Authentication is enabled

Enabled by default. 

■ Encryption is enabled

Enabled by default. 

■ Authorization is enabled

Enabled by default. 

Running the Bluetooth Demo
This application contains MIDlets that demonstrate the use of JSR 82's Bluetooth API. 
It shows how images can be transferred between devices using Bluetooth.

You must run two emulator instances to see this process, and each device must have a 
different phone number. 

1. Use JavaMEPhone1 to launch Bluetooth Demo, then launch Bluetooth Demo on 
JavaMEPhone2.

2. The demo gives you a choice of Server or Client. 

3. On the first emulator, highlight Server and use the right softbutton to select OK.
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The server starts and displays a list of images. At the beginning, none of the 
images are available on the Bluetooth network.

Select the image you want to make available. 

Press Publish image (the right soft button). The icon color changes from purple to 
green, indicating it is published.

4. On the second emulator running the Bluetooth Demo, highlight Client and click 
OK. The MIDlet displays "Ready for images search." Click the Find soft button. 
The MIDlet finds the other emulator and gets a list of published images. Select one 
from the list and choose Load.

■ If you are running the demonstration in a trusted protection domain, the 
image is transferred using simulated Bluetooth and is shown on the client 
emulator.

■ If you are not running in a trusted protection domain, the first emulator (the 
server) displays a prompt asking if you want to authorize the connection from 
the client. Select Yes. The image is displayed in the client emulator.

Running the OBEX Demo
This application shows how to transfer image files between emulator instances using 
the OBEX API. This demonstration shows the use of OBEX over a simulated infrared 
connection.

1. Launch two instances of the emulator. One listens for incoming connections, while 
the other attempts to send an image.

For example, right-click ObexDemo, select Run With... and choose the device 
JavaMEPhone1. Repeat and choose JavaMEPhone2.

2. In the first emulator, choose Receive Image. (Depending on your security level, the 
application warns that an OBEX connection allows other devices to talk to yours 
and asks, "Is it OK to make the connection?" Select Yes.) Click Start to run the 
application. The listener emulator displays a screen reading "Waiting for 
connection."

3. In the second emulator (the sender), choose Send Image and press the Start soft 
key. Select an image from the list and choose Send. (Depending on your security 
level, the application warns that the demo wants to make an outgoing client 
connection, and asks if it is OK. Select Yes.) The Send Image utility uploads the 
image. 

4. In the listening emulator, the utility displays information about the incoming 
image and asks "Would you like to receive it?" Select Yes.

The image you selected is transferred over the simulated infrared link and 
displayed on the first emulator.
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18JSR 135: Mobile Media API Support

JSR 135, the Mobile Media API (MMAPI), provides a standard API for rendering and 
capturing time-based media, like audio or video. The API is designed to be flexible 
given the media formats, protocols, and features supported by various devices.

See the following topics:

■ "Media Types"

■ "MMAPI MIDlet Behavior"

■ "Ring Tones"

■ "Running AudioDemo"

■ "Running MMAPIDemos"

For information on programming with MMAPI, see the following articles:

Mobile Media API Overview: 
http://developers.sun.com/techtopics/mobility/apis/articles/mmap
i_overview/

The J2ME Mobile Media API: http://www.jcp.org/en/jsr/detail?id=135

Media Types
The emulator's MMAPI implementation supports the following media types.

Table 18–1 Supported MIME Types

MIME Type Description

audio/amr* Adaptive Multi-Rate Narrow Band

audio/midi MIDI files

audio/mpeg* MP3 files

audio/mp4* MP4 Audio files

audio/sp-midi Scalable Polyphony MIDI

audio/x-tone-seq MIDP 2.0 tone sequence

audio/x-wav* WAV PCM sampled audio

image/gif GIF 89a (animated GIF)

video/3gpp* Third generation mobile broadband with video

video/mpeg* MPEG video

video/mp4* MP4 video files
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In the previous table, an asterisk (*) indicates a media type that requires corresponding 
DirectShow filters to be installed on your system. For example, MP3 support might 
require an MP3 Splitter and an MP3 Decoder (these might be two separate DirectShow 
filters, or they might be combined in one filter). You can use any appropriate filter, but 
Java ME SDK 3.3 has only been tested with filters from the K-Lite Mega Codec Pack 
4.8.0. If no appropriate DirectShow filters are found on your system, JSR 135 Player 
creation for the media type might fail. 

Media Capture
The Oracle Java ME SDK emulator supports audio and video capture. Audio capture 
is supported using the capture capabilities of the system upon which the emulator 
runs.

Video capture is supported by simulating a camera input.

Consult the MMAPIDemo example application for details and source code that 
demonstrates how to capture audio and video.

MMAPI MIDlet Behavior
MIDlets have a lifecycle that is defined in the MIDP specification. MIDlets can be 
paused by events such as incoming phone calls. A well-behaved MIDlet releases 
important device resources when it is paused and reallocates or restarts those 
resources when the MIDlet is resumed. In the MMAPI arena, stop any Players that are 
rendering content when a MIDlet is paused.

The Oracle Java ME SDK prints a message to the console if you pause a MIDlet and it 
does not stop its running Players. You can test this feature using the Pausing Audio 
Test MIDlet. 

The warning message is printed only once for each running emulator.

Ring Tones
MMAPI plays ring tones, as demonstrated in "Simple Tones" and "Simple Player.". The 
ring tone formats mentioned here are in common use. You can download ring tones or 
create your own.

Download Ring Tones
Ring tone files can be downloaded from many internet sites, including the following: 

■ http://www.convertyourtone.com/

■ http://www.phonezoo.com

Ring Tone Formats
This section provides samples of several formats

■ RTTTL, the Ringing Tones text transfer language format, is explained at

video/avi* Video capture emulation and Audio-Video Interleaved files

Table 18–1 (Cont.) Supported MIME Types

MIME Type Description
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 http://en.wikipedia.org/wiki/Ring_Tone_Transfer_Language

■ Nokia Composer

This is a rendition of Beethoven's 9th symphony in Nokia Composer format:

16g1,16g1,16g1,4#d1,16f1,16f1,16f1,4d1,16g1,16g1,16g1,16#d1,

16#g1,16#g1,16#g1,16g1,16#d2,16#d2,16#d2,4c2,16g1,16g1,16g1,

16d1,16#g1,16#g1,16#g1, 16g1,16f2,16f2,16f2,4d2

■ Ericsson Composer

Beethoven's Minuet in G:

a b + c b + c b + c b + C p + d a B p + c g A 

p f g a g a g a g A p b f G p a e F

Beethoven's 9th symphony theme:

f f f # C # d # d # d C p f f f # c # f #f # f f +# c + # c + # c # A 
ff f c # f # f # f f + # d + # d + # d

■ Siemens Composer Format

Inspector Gadget theme:

C2(1/8) D2(1/16) Dis2(1/8) F2(1/16) G2(1/8)

P(1/16) Dis2(1/8) P(1/16) Fis2(1/8) P(1/16)

D2(1/8) P(1/16) F2(1/8) P(1/16) Dis2(1/8)

P(1/16) C2(1/8) D2(1/16) Dis2(1/8) F2(1/16)

G2(1/8) P(1/16) C3(1/8) P(1/16) B2(1/2) P(1/4)

C2(1/8) D2(1/16) Dis2(1/8) F2(1/16) G2(1/8) P(1/16)

Dis2(1/8) P(1/16) Fis2(1/8) P(1/16) D2(1/8) P(1/16)

F2(1/8) P(1/16) Dis2(1/8) P(1/16) C3(1/8) B2(1/16)

Ais2(1/8) A2(1/16) Gis2(1/2) G2(1/8) P(1/16) C3(1/2)

■ Motorola Composer

Beethoven's 9th symphony:

4 F2 F2 F2 C#4 D#2 D#2 D#2 C4 R2 F2 F2 F2 C#2 F#2 F#2

F#2 F2 C#+2 C#+2 C#+2 A#4 F2 F2 F2 C2 F#2 F#2 F#2 F2

D#+2 D#+2 D#+2

■ Panasonic Composer

Beethoven's 9th symphony:

444** 444** 444** 1111* 4444** 4444** 4444** 111*

0** 444** 444** 444** 1111** 4444** 4444** 4444**

444** 11** 11** 11** 6666* 444** 444** 444** 111**

4444** 4444** 4444** 444** 22** 22** 22**

■ Sony Composer

Beethoven's 9th symphony:
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444****444****444****111#*****444#****444#****444#****

111*****(JD)0000444****444****444****111#****444#****

444#****444#****444****11#****11#****11#****666#*****

444****444****444****111****444#****444#****

444#****444****22#****22#****22#****

Running AudioDemo
Demonstrates audio capabilities, including mixing and playing audio with an 
animation. Select a MIDlet from the list, and from the menu, select 1, Launch.

■ Audio Player. Select a sound clip and press the Play soft button. Click Back to 
return to the list of clips.

■ Bouncing Ball. Select No Background and press the Play soft button. Two balls 
randomly bounce in the screen, emitting a tone whenever they contact a wall. 

Wave background, tone seq background, and MIDI background play the same 
two-ball audio visual sequence with the additional audio background.

■ Mix Demo. Select a MIDlet and press the Play soft button. This demo shows that 
different audio formats can play simultaneously.

Tone+Wav. The audio clip starts playing and the Tone soft button is displayed. 
Press the Tone button to hear a tone playing over the original audio clip.

Tone+ToneSeq - The audio clip starts playing and the Tone soft button is 
displayed. Press the Tone button to hear a tone playing over the original audio 
clip.

ToneSeq+Wav - The tone sequence and the wav sequence play simultaneously. 
Press the Pause soft button to interrupt, and press Play to resume.

Running MMAPIDemos
The MMAPIDemos application contains four MIDlets that showcase the SDK's 
multimedia capabilities.

Simple Tones
Simple Tones demonstrates how to use interactive synthetic tones. Select a sample, 
then click Play on the lower right.

■ Short Single Tone and Long Single Tone use Manager.playTone() to play tones 
with different pitch. 

■ Short MIDI event plays a chord on the interactive MIDI device (locator 
"device://midi"). The shortMidiEvent() method of MIDIControl is used to 
trigger the notes of the chord.

To run the MMAPI Drummer demo, click or type number keys (0-9). Each number 
plays a different sound.

Simple Player
The Simple Player application demonstrates the range of audio and video capabilities 
of the emulator. It includes sample files in a variety of formats and can play files from 
the emulator's persistent storage or from HTTP URLs. 
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The player portion uses a generic javax.microedition.media.Player interface. The 
player displays duration, media time, and controls for running the media file. If 
metadata is available in a file, the player enables you to view the information, such as 
author and title. In the case of MIDI files, if karaoke text is present in the file, it 
displays on the screen during play. Graphical user interface controls can be viewed on 
the display screen if applicable. You can access these controls by selecting one of the 
media samples in Simple Player, then pressing the Menu button to view and select the 
desired command.

Select Simple Player then click Launch. The demo includes the following media 
samples:

■ Bong plays a short WAV file. You can adjust certain playback features, as described 
later in this document. The display shows the duration of the sound in 
minutes:seconds.hundredths of a second, for example 00:01.04. This audio sample is a 
resource file in the MIDlet suite JAR file.

■ MIDI Scale plays a sample musical scale. The display shows the title of the 
selected music file, the duration of the song, the elapsed time during playback, 
and the current tempo in beats per minute (bpm). This MIDI file is stored in the 
MIDlet suite JAR file.

■ Simple Ring Tone plays a short sequence of Beethoven's Fifth Symphony. The 
display shows the title of the selected music file, the duration of the song, the 
elapsed time in seconds and tenths of a second during playback, and the current 
tempo in beats per minute (bpm). This ring tone file (.jts format) is stored in the 
MIDlet suite JAR file.

■ WAV Music plays a brief audio file. The display shows the title of the audio file, 
the duration of the audio the elapsed time during playback, and the playback rate 
in percent. This WAV file is retrieved from an HTTP server.

■ MIDI Scale plays a MIDI file that is retrieved from an HTTP server.

■ The Animated GIF example shows an animated GIF that counts from 1 to 5. The 
file is stored in the MIDlet suite JAR file.

■ AMR Narrow band. Plays an Adaptive Multi-rate narrow band file. This sample 
requires an AMR codec. This sample was tested with the K-Lite Mega Codec Pack 
4.8.0. This codec is freely downloadable. 

■ Audio Capture from a default device lets you capture audio from a microphone or 
connected device. The sound is captured and played back on the speaker. To avoid 
feedback, use a headset.

■ Video Capture Simulation simulates viewing input video. For example, on a 
device equipped with a camera.

■ [enter URL] Plays back media files from arbitrary HTTP servers. Type a valid 
URL at the insertion point and click OK to play a file. If you want to open an 
HTTP directory from which to select media, be sure to add a slash to the end of the 
URL.

In addition, Simple Player parses ring tones in Ringing Tones text transfer language 
(RTTTL). See http://www.convertyourtone.com/rtttl.html for information 
on RTTTL.

The Simple Player menu lists commands that control media playback. 

The first menu item, Quick Help, displays a list of commands and actions mapped to 
keypad buttons. Some actions are not applicable for every media type.
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The remaining menu items vary depending on the media type. Some actions, such as 
Rate, open a control with which you can arbitrarily change the playback. Click Back to 
return to the player screen and see or hear your changes.

Video
The Video application illustrates how the emulator is capable of playing animated GIF 
files and capturing video. On an external device with a camera, video capture shows 
the user what the camera sees.

Animated GIFs and video capture can be implemented using either a Form Item or a 
Canvas. The Video demonstration includes all the possibilities. 

■ Animated GIF - Form [jar] shows an animated GIF in a Form. A simple indicator 
shows the progress through the animation. The form also includes some 
information about the playback, including the current time. 

■ Animated GIF - Canvas [jar] shows an animated GIF in a Canvas. A simple 
indicator shows the progress through the animation.

■ Video Capture - Form simulates capturing video from a camera or other source 
and showing it as an Item in a Form. Select Snapshot to take a snapshot of the 
captured video. The snapshot is placed beneath the video capture for comparison.

■ Video Capture - Canvas simulates capturing video from a camera or other source 
and showing it in a Canvas. Select Snapshot to get a still image of the current 
appearance. The snapshot is shown briefly, then the display goes back to the video 
capture.

Pausing Audio Test
This test MIDlet demonstrates the proper use of pauseApp()and the alternative. 

In the Well-Behaved case suspending uses pauseApp() to close the player and 
remembers the length of time the audio file played. When the player resumes, it starts 
playing the audio file at the point that it was suspended.

In the Not Well-Behaved case the player is stopped instead of suspended. When the 
player is restarted the audio file plays from the beginning.

Test the two cases as follows:

■ Run MMAPIDemos, and launch Pausing Audio Test.

The music starts playing. The initial value of Current State is Well-Behaved. 

■ Select Application > Suspend (or F5), to pause the music.

■ Select Application > Resume (or F6) to resume playing the audio clip from the 
stopping point.

■ Click the Misbehave soft key.

■ Select Application > Suspend (or F5), to stop the music.

■ Select Application > Resume (or F6). The player restarts but the clip plays from 
the beginning.

WARNING: Do not run the memory monitor while using this demo.
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19JSR 172: Web Services Support

The Oracle Java ME SDK emulator supports JSR 172, the J2ME Web Services 
Specification. JSR 172 provides APIs for accessing web services from mobile 
applications. It also includes an API for parsing XML documents.

See the following topics:

■ "Generating Stub Files from WSDL Descriptors"

■ "Creating a New Mobile Web Service Client"

■ "Run JSR172Demo"

Generating Stub Files from WSDL Descriptors
The NetBeans IDE provides a stub generator that automates creating source code for 
accessing web services that conform to the J2ME Web Services Specification. You can 
add stubs to any MIDP application. 

The following is a general procedure for adding stubs:

1. In the Projects window, expand the tree for a project. 

2. Launch the Java ME Web Service Client wizard:

Right-click the Source Packages node and select New > Other and select the CLDC 
category, then select Java ME Web Service Client....

3. In the New Java ME Webservice Client page, you can do one of the following 
actions:

■ Click Running Web Service and enter the URL for the WSDL and then click 
Retrieve WSDL.

■ Click Specify the Local filename for the retrieved WSDL and browse to a file 
on your system.

In either case, you must enter a package name (if it is not supplied), then click 
Finish. The new package appears in the project and includes an interface file and a 
stub file.

4. You can now edit your source files to call the content the stub provides, then build 
and run.

Note: If you are using NetBeans 7.1.2, or 7.2.1 or higher the  "SOAP 
Web Services" plugin must be installed and activated. 
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See "Creating a New Mobile Web Service Client" for a step by step process, or see 
"Run JSR172Demo" and view the demo source files.

Creating a New Mobile Web Service Client
This sample procedure creates a new project and adds a web service client. However, 
you can add a web service client to any MIDP project, it does not have to be new.

If you are using a proxy server, you must configure the emulator's proxy server 
settings as described in "Configuring the Web Browser and Proxy Settings."

1. Click the File menu and select New Project, choose the Java ME category, and the 
Mobile Application project type, and click Next. 

Figure 19–1 Creating a New Project and Adding a Mobile Application

2. Name your project and check Create Default Package and Main Executable Class. 
Click Next.  Be sure to create Hello MIDlet for this example.

Figure 19–2 Creating the Main Executable Class

3. Ensure that Java ME SDK is the platform and choose a device. Click Next.
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4. Right-click on the Source Packages node and select New > Java ME Web Service 
Client....

5. In the New Java ME Webservice Client page:

■ Click Running Web Service and in the WSDL URL field, enter:

http://www.xmlme.com/WSShakespeare.asmx?WSDL

Click Retrieve WSDL.

■ The Package name is wsshakespeare.

Click Finish. 

Figure 19–3 The Java ME Web Servce Client Information Dialog Box

The new package appears in the Source Packages tree and includes 
Shakespeare.java and Shakespeare_Stub.java.

6. Edit HelloMIDlet.java as follows:

■ At the beginning, replace the default import declarations with:

import javax.microedition.lcdui.*;
import javax.microedition.midlet.*;
import wsshakespeare.*; 

Note: Many additional project options can be found under the New 
--> Other menu item.  
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■ Locate the startApp() method and replace its contents with the following 
code:

String text;
Shakespeare s = new Shakespeare_Stub();
 try {
     text = s.getSpeech("Romeo");
 } catch (java.rmi.RemoteException rex) {
     text = "error";
     System.out.println(rex.getMessage());
 }
 TextBox t = new TextBox("Hello", text, 2048, 0);

 final Command exitCommand = new Command("Exit", Command.EXIT, 1);
 t.addCommand(exitCommand);
 t.setCommandListener(new CommandListener() {
     public void commandAction(Command c, Displayable d) {
       if (c == exitCommand) {
    notifyDestroyed();
       }
     }
 });

 Display.getDisplay(this).setCurrent(t);

7. Build and run the project. You see a quote from Shakespeare's Romeo and Juliet on 
the device screen.

You can vary the above procedure to use a local WSDL file. Open the following 
web page in a browser: 

 http://www.xmlme.com/WSShakespeare.asmx?WSDL

Save it to a local file. For example, C:\ws\WSShakespeare.wsdl. Follow the 
procedure above, except at Step 4, specify the local file name.

Run JSR172Demo
JSR172Demo shows how to access a web service from a MIDlet. The web service in this 
demo is running on an Internet server, and it conforms to the J2ME Web Services 
Specification. The client is the MIDlet running in the emulator

If you are using a proxy server, you must configure the emulator's proxy server 
settings as described in "Configuring the Web Browser and Proxy Settings."

Set Up the GlassFish Server

This demo requires the Oracle GlassFish server. 

■ If you installed a full version of NetBeans you probably have a GlassFish 
installation. Choose Tools > Servers and choose Glassfish to view the defaults.

■ If you do not have Glassfish, it can be downloaded from:

http://www.oracle.com/technetwork/java/javaee/downloads

Set Up Environment Variables

Set the following environment variables:

JAVA_HOME=Java-installation-path

GLASSFISH_HOME=GlassFish-installation-path
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Run the Demo Scripts

The scripts in the \server subdirectory assume that your server has a domain named 
"domain1" in which the service is automatically deployed. If you do not have a 
domain named domain1, set up this domain or edit run.bat and specify a domain you 
already have. Run the scripts:

demo_directory\JSR172Demo\server\build.bat

demo_directory\JSR172Demo\server\run.bat

Verify the Web Service

■ Start the Glassfish service.

■ In a browser, open the following URL:

http://localhost:8080/serverscript/serverscript

You see a page titled Web Services that displays information about the service 
including links to the WSDL file corresponding to the localhost url.

Run the MIDlet in the Emulator

JSR172Demo contains a single MIDlet named Server Script. Launch it and follow the 
prompts. You can browse through fictitious news headlines, all of which are retrieved 
from the web service.
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20JSR 177: Smart Card Security (SATSA)

The Security and Trust Services APIs (SATSA) provide smart card access and 
cryptographic capabilities to applications running on small devices. JSR 177 (the 
SATSA specification) defines four distinct APIs as optional packages:

■ SATSA-APDU - Enables applications to communicate with smart card 
applications using a low-level protocol.

■ SATSA-JCRMI - Provides an alternate method for communicating with smart 
card applications using a remote object protocol.

■ SATSA-PKI -Enables applications to use a smart card to digitally sign data and 
manage user certificates.

■ SATSA-CRYPTO - A general-purpose cryptographic API that supports message 
digests, digital signatures, and ciphers.

The Oracle Java ME SDK emulator fully supports SATSA. This topic describes how 
you can use the Oracle Java ME SDK to work with SATSA in your own applications.

For a more general introduction to SATSA and using smart cards with small devices, 
see the SATSA Developer's Guide, which is available at:

http://download.oracle.com/javame/config/cldc/opt-pkgs/api/secur
ity/satsa-dg.

If you must develop your own Java Card applications, download the Java Card 
Development Kit, available at:

 
http://www.oracle.com/technetwork/java/javacard/overview/index.h
tml. 

This kit is for Windows.

Card Slots in the Emulator
Real SATSA devices are likely to have one or more slots that house smart cards. 
Applications that use SATSA to communicate with smart cards must specify a slot and 
a card application.

The Oracle Java ME SDK emulator is not an external device and, therefore, does not 
have physical slots for smart cards. Instead, it communicates with a smart card 
application using a socket protocol. The other end of the socket might be a smart card 
simulator or it might be a proxy that talks with real smart card hardware.
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The Oracle Java ME SDK emulator includes two simulated smart card slots. Each slot 
has an associated socket that represents one end of the protocol that is used to 
communicate with smart card applications.

The default card emulator host name is localhost, and the default ports are 9025 for 
slot 0 and 9026 for slot 1. These port defaults are a property of the device. To change 
the defaults in the user interface, right click on the device in the Device Selector, and 
select Properties. By default the Properties window is docked on the upper right of the 
Java ME SDK interface. 

You can also change the port values in the device’s property file found at:

username\javame-sdk\3.3\work\devicename

Edit the device.properties file and modify this line:

runtime.internal.com.sun.io.j2me.apdu.hostsandports = 
localhost:9025,localhost:9026

start cref -p 9025 -i memory_image.eeprom

For detailed instructions on running Mohair, see 

Adjusting Access Control
Access control permissions and PIN properties can be specified in text files. When the 
first APDU or Java Card RMI connection is established, the implementation reads the 
ACL and PIN data from the acl_slot-number in the workdir\devicename\appdb directory. 
For example, an access control file for slot 0 might be:

username\javame-sdk\3.3\work\devicename\appdb\acl_0

If the file is absent or contains errors, the access control verification for this slot is 
disabled.

The file can contain information about PIN properties and application permissions.

Specifying PIN Properties
PIN properties are represented by a pin_data record in the access control file.

Example 20–1 PIN Properties Example

pin_data {
    id number
    label string
    type       bcd | ascii | utf | half-nibble | iso
    min        minLength
    max        maxLength
    stored     storedLength
    reference  byte
    pad        byte - optional
    flag       case-sensitive | change-disabled | unblock-disabled
               needs-padding | disable-allowed | unblockingPIN
   }

Specifying Application Permissions
Application permissions are defined in access control file (acf) records. The record 
format is as follows:
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Example 20–2 Access Control File Record Format

acf AID fnumbers separated by blanks {
    ace {
         root CA name
         ...
         apdu {
                eight numbers separated by blanks
                ...
         }
         ...
         jcrmi {
                 classes {
                   classname
                   ...
                   }
                    hashModifier string
                    methods {
                   method name and signature
                   ...
                 }
         }
         ...
         pin_apdu {
                 id number
            verify | change | disable | enable | unblock
            four hexadecimal numbers
                 ...
         }
         ...
         pin_jcrmi {
                id number
            verify | change | disable | enable | unblock
            method name and signature
                ...
           }
        ...
        }
    ...
}

The acf record is an Access Control File. The AID after acf identifies the application. 
A missing AID indicates that the entry applies to all applications. The acf record can 
contain ace records. If there are no ace records, access to an application is restricted by 
this acf.

The ace record is an Access Control Entry. It can contain root, apdu, jcrmi, pin_apdu, 
and pin_jcrmi records. 

The root record contains one CA name. If the MIDlet suite was authorized using a 
certificate issued by this CA, this ace grants access to this MIDlet. A missing root field 
indicates that the ace applies to all identified parties. One principal is described by one 
line. This line must contain only the word root and the principal name, for example:

root CN=thehost;OU=JCT;O=dummy CA;L=Santa Clara;ST=CA;C=US
The apdu or jcrmi record describes an APDU or Java Card RMI permission. A missing 
permission record indicates that all operations are allowed.

An APDU permission contains one or more sequences of eight hexadecimal values, 
separated by blanks. The first four bytes describe the APDU command and the other 
four bytes are the mask, for example:
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apdu {
     0 20  0 82  0 20  0 82
    80 20  0  0 ff ff  0  0
}

The Java Card RMI permission contains information about the hash modifier 
(optional), class list, and method list (optional). If the list of methods is empty, an 
application is allowed to invoke all the remote methods of interfaces in the list of 
classes, for example:

jcrmi {
    classes {
             com.sun.javacard.samples.RMIDemo.Purse
    }
    hashModifier zzz
    methods {
        debit(S)V
        setAccountNumber([B)V
        getAccountNumber()[B
    }
}

All the numbers are hexadecimal. Tabulation, blank, CR, and LF symbols are used as 
separators. Separators can be omitted before and after symbols { and }.

The pin_apdu and pin_jcrmi records contain information necessary for PIN entry 
methods, which is the PIN identifier and APDU command headers, or remote method 
names.

Access Control File Example

Example 20–3 Access Control File Example

pin_data {
  label   Unblock pin
  id        44
  type      utf
  min       4
  stored    8
  max       8
  reference 33
  pad       ff
  flag      needs-padding
  yflag     unblockingPIN
}
pin_data {
  label     Main pin
  id        55
  type      half-nibble
  min       4
  stored    8
  max       8
  reference 12
  pad       ff
  flag      disable-allowed
  flag      needs-padding
}
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acf a0 0 0 0 62 ff 1 {
  ace {
        root CN=thehost;OU=JCT;O=dummy CA;L=Santa Clara;ST=CA;C=US
 
        pin_jcrmi {
            id 55
            verify enterPIN([B)S
            change changePIN([B[B)S
            disable disablePIN([B)S
            enable enablePIN([B)S
            unblock unblockPIN([B[B)S
           }
  }
}

acf a0 0 0 0 62 ee 1 {
  ace {
    root CN=thehost;OU=JCT;O=dummy CA;L=Santa Clara;ST=CA;C=US

    pin_apdu {
            id 55
            verify 1 2 3 1
            change 4 3 2 2
            disable 1 1 1 3 
            enable 5 5 5 4
            unblock 7 7 7 5
        }
  }
}

acf a0 0 0 0 62 3 1 c 8 1 {
  ace {
        root CN=thehost;OU=JCT;O=dummy CA;L=Santa Clara;ST=CA;C=US

        jcrmi {
                 classes {
                     com.sun.javacard.samples.RMIDemo.Purse
              }
                 hashModifier xxx
                 methods {
                   setAccountNumber([B)V
                   getBalance()S
                   credit(S)V
                 }
  }
}
  ace {
        jcrmi {
                classes {
                     com.sun.javacard.samples.RMIDemo.Purse
                  }

                  debit(S)V
                  getAccountNumber()[B
              }
            }
       }
  }
 
acf a0 00 00 00 62 03 01 0c 02 01 {
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  ace {
        root CN=thehost;OU=JCT;O=dummy CA;L=Santa Clara;ST=CA;C=US
        apdu {
               0 20  0 82  0 20  0 82
               80 20  0  0 ff ff  0  0
             }
        apdu {
               80 22  0  0 ff ff  0  0 
             }
        }
  }
acf a0 00 00 00 62 03 01 0c 02 01 {

  ace {
    apdu {
        0 20 0 82 ff ff ff ff
    }
  }
}

acf a0 00 00 00 62 03 01 0c 06 01 {

  ace {
    apdu {
        0 20 0 82 ff ff ff ff
    }
  }
}

Running the SATSA Demo
For the demo to work this project must reside in the Java ME SDK installation’s \apps 
subdirectory. You must create the apps directory yourself

1. Click the File menu and select New Project and in the Categories window select 
Samples > Java ME SDK 3.3 and single-click SATSADemos. Click Next. Save the 
sample project in:

installdir\apps\SATSADemos

Click Finish.

2. Right-click on the project, click Properties and then click the Running category. 
Enable Regular execution and check Specify the Security Domain. Select 
maximum from the list.

3. Start the instance(s) of cref from the command line. 

4. Run the project.

5. click Properties and then click the Running category

6. start installdir\bin\cref -i installdir\apps\SATSADemos\sat.eeprom

7. start installdir\bin\cref -p 9025 -i installdir\apps\SATSADemos\pki.eeprom

8. lick Properties and then click the Running category. Enable Regular execution and 
check Specify the Security Domain

9. start installdir\bin\cref -p 9025 -i installdir\apps\SATSADemos\demo2.eeprom
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The JSR 179 Location API gives applications the opportunity to use a device's location 
capabilities. For example, some devices include Global Positioning System (GPS) 
hardware. Other devices might be able to receive location information from the 
wireless network. The Location API provides a standard interface to location 
information, regardless of the underlying technique.

In the Location API, a location provider encapsulates a positioning method and supplies 
information about the device's location. The application requests a provider by 
specifying required criteria, such as the desired accuracy and response time. If an 
appropriate implementation is available, the application can use it to obtain 
information about the device's physical location.

The Oracle Java ME SDK includes a simulated location provider. You can use the 
emulator's External Events Generator to specify where the emulator should think it is 
located. In addition, you can configure the properties of the provider itself, and you 
can manage a database of landmarks.

Setting the Emulator's Location at Runtime
You can specify the simulated location of the emulator while it is running. In the 
emulator, click the Tools menu and select External Events Generator. Click the 
Location tab. 

In the Location area of the tab, you can fill in values for the latitude, longitude, 
altitude, speed, and course. Applications that use the Location API can retrieve these 
values as the location of the emulator.

For more elaborate testing, you can set up a location script that describes motion over 
time. Location scripts are XML files consisting of a list of locations, called waypoints, 
and associated times. The Oracle Java ME SDK determines the current location of the 
emulator by interpolating between the points in the location script. Here, for example, 
is a simple location script that specifies a starting point (time="0") and moves to a new 
point in ten seconds:

Example 21–1 Location Script Example

<waypoints>
  <waypoint time="0"
            latitude="14" longitude="50" altitude="310" />
  <waypoint time="10000"
            latitude="14.5" longitude="50.1" altitude="215" />
</waypoints>
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Figure 21–1 External Events Generator Location Tab

The altitude measurement is in meters, and the time values are in milliseconds.

Use a text editor to create your location script. You can load it into the external event 
window by pressing the Browse button next to the Script field. Immediately below are 
controls for playing, pausing, stopping, and moving to the beginning and end of the 
location script. You can also drag the time slider to a particular point.

Some devices are also capable of measuring their orientation. To make this kind of 
information available to your application, change the State field in the Orientation box 
to Supported and fill in values for azimuth, pitch, and roll. The Magnetic Orientation 
check box indicates whether the azimuth and pitch measurements are relative to the 
Earth's magnetic field or relative to true north and gravity.

To test how your application handles unexpected conditions, try changing the State 
field in the Location Provider box to Temporarily Unavailable or Out of Service. When 
your application attempts to retrieve the emulator's location, an exception is thrown 
and you can see how your application responds.
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Running the CityGuide Sample Project
CityGuide demonstrates how to use the Location API (JSR 179). It shows a walker's 
current position superimposed on a city map. The walker moves around the city and 
landmarks are highlighted and identified as the walker approaches. This demo gets 
the walker's location from an XML script named citywalk.xml (the event file) that 
submits the device location information. 

Because location prompts occur frequently, it is best to run this demonstration in 
manufacturer (trusted) mode, as explained in the topic "Security Domains“"Security 
Domains." In the user interface, right-click on your project and select the Running 
category. Select Specify the Security Domain, and select manufacturer or maximum.

1. Open and run the CityGuide project. In the emulator, launch the CityGuide 
MIDlet. The map page opens.

2. By default the display shows icons for four types of landmarks: restaurants, 
museums, shops, and theaters. 

To adjust the landmark display (this is optional), open the soft menu and choose 
the Settings command. Use the navigation keys to highlight a category, then use 
Select to check or uncheck an item. In the default skin, the item is selected when 
the square is filled with white.

Figure 21–2 The Location Settings Dialog Box

3. In the emulator, click the Tools menu and select External Events Generator. Click 
the Location tab, then click the Browse button. Select the event file from the 
directory containing the Citywalk application. 

The player buttons at the bottom of the window are now active. Press the green 
play button (right-pointing triangle) to run the script.

4. When you are near a landmark its name appears at the top of the map. Open the 
soft menu and select the Detail command to see more information. 
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Figure 21–3 The Landmark Detail Screen
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22JSR 205: Wireless Messaging

The Oracle Java ME SDK supports the Wireless Messaging API (WMA) with a 
sophisticated simulation environment. WMA 1.1 (JSR 120) enables MIDlets to send 
and receive Short Message Service (SMS) or Cell Broadcast Service (CBS) messages. 
WMA 2.0 (JSR 205) includes all this and support for Multimedia Message Service 
(MMS) messages as well.

This chapter describes the tools you can use to develop WMA applications. It begins 
by showing how to configure the emulator's support of WMA. Next, it describes the 
WMA console, a tool for testing WMA applications. 

Many of the tasks in this topic can also be accomplished from the command line. See 
"Running WMA Tool."

Using the WMA Console to Send and Receive Messages
The WMA console is a tool that enables you to send messages to and receive messages 
from applications that use JSR 205. You can, for example, use the WMA console to 
send SMS messages to a MIDlet running on the emulator.

See "WMA Console Interface" or "Running WMA Tool."

Launching the WMA Console
To launch the WMA console, select Tools > Java ME > WMA Console. Messages can 
be sent from the WMA Console to an emulator instance.

The console opens as a tab in the NetBeans documents area. The console phone 
number is displayed as part of the WMA Console tab label (for example, 987654321). 

The WMA console phone number is an editable CLDC property. In the Device Selector, 
right-click the CLDC, Java(TM) ME Platform SDK 3.3 node in the device selector, and 
select Properties. Type a new value in the WMA Console Phone Number field. If the 
number is available it is assigned to the console immediately. If the number is in use it 
is assigned to the console the next time you restart the NetBeans IDE.

WMA Console Interface
To open the WMA Output window, select Window > Output > WMA Console 
Output. This window displays messages received from an emulator. By default it is 
docked at the bottom of the NetBeans IDE.
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Figure 22–1 WMA Console and Output Windows

Emulator Phone Numbers
Each instance of the emulator has a simulated phone number that is shown in the 
emulator window. The phone numbers are important because they are used as 
addresses for WMA messages. The phone number is a device property and it can be 
changed. In the device selector, right-click a device and view its properties. 

Sending a Text or Binary SMS Message
To launch the WMA console, select Tools > Java ME > WMA Console. To open the 
WMA Output window, select Window > Output > WMA Console Output.

To send a text SMS message, click Send SMS. 

■ The To Clients window automatically lists the phone numbers of all running 
emulator instances. Select one or more destinations and enter a port number (the 
default is 50000, as described in "WMADemo Push Registry Values"). 
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■ To send a text message, select the Text Message tab, type your message and click 
Send.

■ To send the contents of a file as a binary message, click the Binary Message tab. 
Type in the path of a file directly, or click Browse to open a file chooser.

To try this yourself see "Sending SMS Messages From WMA Console to an Emulator 
and Back."

Sending Text or Binary CBS Messages
Sending CBS messages is similar to Section , "Sending a Text or Binary SMS Message" 
except that recipients are unnecessary because it is a broadcast. 

To send a text or binary CBS message, click Send CBS in the WMA console. Specify a 
message identifier (see "WMADemo Push Registry Values") and enter the text or 
binary content of your message. The maximum message length for text and binary 
messages is 4096 bytes. 

To try this yourself see "Sending CBS Messages from WMA Console to an Emulator."

Sending MMS Messages
MMS messages consist of one or more files, usually images or sounds. An MMS 
message can be sent to multiple recipients. 

To send an MMS message from the WMA console, click the Send MMS button. The 
window for composing MMS messages has Header and Parts tabs.

■ The header tab addresses the message.

The To area automatically lists one of the phone numbers from the running 
emulator instances. Click Add to select other available phone numbers from the 
drop-down list.

To remove a recipient, first select its line, then click Remove. 

When a recipient is removed it must be added back manually. Click Add and a 
new line is added to the recipient table. 

■ To add optional media files (Parts) to the message, click the Parts tab and click 
Add. The maximum message length for text and binary messages is 4096 bytes.

Most media files have information to fill the Content Location, Content ID, 
Mime-Type (text/plain for simple MMS), and Encoding fields, but you can edit 
these fields as well. The default ID for the demo is example.mms.MMSDemo (see 
"WMADemo Push Registry Values").

To remove a part, select it and press Remove.

To try this yourself, see "Sending MMS Messages from WMA Console to an Emulator."

Note: The maximum message length for text and binary messages is 
4096 bytes.

Note: The emulator displays only the first 160 symbols of a received 
CBS message.
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Receiving Messages in the WMA Console
To start the WMA console, select Tools > Java ME > WMA Console. The WMA 
console window has its own phone number displayed on the WMA Console tab. You 
can send messages from your applications running on the emulator to the WMA 
console.

Received messages are displayed in the WMA output window.

Running WMADemo
The WMADemo sample project shows how to send and receive SMS, CBS, and MMS 
messages. Messages can be exchanged between emulator instances and can be 
generated or received using the WMA console utility.

WMADemo Push Registry Values
The push registry determines how the demo establishes certain types of connections. 
This information is set in the Application Descriptor. To view it, right-click the WMA 
Demo project and select Properties. In the Properties window, select the Application 
Description category and view the Push Registry tab.

■ For SMS messages the port number is 50000.

■ For CBS Messages, the Message Identifier is 50001.

■ For MMS messages, the application ID is example.mms.MMSDemo. 

Running WMADemo OTA
Because this sample uses the push registry, you cannot see all of its features with the 
regular execution process. You must install the application into the emulator using the 
over the air provisioning capability that mirrors how applications are installed on 
external devices. 

1. Right-click the WMADemo project and select Properties from the context menu.

2. Select the Running Category and select the Execute through OTA option. Click 
OK.

3. Run WMADemo in an emulator. 

Wait a few seconds for the application to download to the emulator and register 
itself.

The application home screen shows the MIDlets you can launch: SMS Send, SMS 
Receive, CBS Receive, MMS Send and MMS Receive.

4. Launch the WMA console (see "Launching the WMA Console").

Sending SMS Messages From WMA Console to an Emulator and Back
In this demo you send messages between the WMA Console and the client demo 
application running on the emulator. Using the WMA console to send messages to the 
emulator exercises the push registry. 

1. To launch the WMA console, select Tools > Java ME > WMA Console. To open the 
WMA Output window, select Window > Output > WMA Console Output. The 
WMADemo should be running in the emulator, as described in "Running 
WMADemo OTA."
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2. Click the Send SMS button in the WMA console window.

Choose the number that corresponds to the emulator. Typically, you check the box 
in front of 123456789. If you are not sure what number the emulator is using, look 
for a number above the emulator screen. 

Fill in a port number of 50000. This is required because the demo waits for the SMS 
on that port.

Type your text message in the Message field and click Send.

3. The emulator asks if it is OK if the WMADemo interrupts and if it can be started. You 
might receive several permission requests based on your firewall settings.

Select Yes. The SMSReceive MIDlet is launched and immediately displays the 
incoming SMS message.

4. To type a return message, press the Reply soft button. Type a message and select 
Send from the menu. You might be asked to give permission because there is a cost 
to your phone number. In the IDE, look in the WMA Output Window to confirm 
that your reply has been received. (The output window is typically displayed 
below the WMA Console. Be sure to click the WMA Output Window tab.)

Sending CBS Messages from WMA Console to an Emulator
This process is similar to sending SMS Messages. Instead of specifying a port number 
you specify a Message Identifier. 

1. To launch the WMA console, select Tools > Java ME > WMA Console. To open the 
WMA Output window, select Window > Output > WMA Console Output. 

2. Click the Send button in the WMA console window.

Supply a Message Identifier of 50001. 

Type your text message or attach a binary message and click Send.

3. The emulator asks if it is OK if the WMADemo interrupts and if it can be launched. 
You might receive several permission requests based on your firewall settings.

Select Yes. The CBSReceive MIDlet is launched and immediately displays the 
incoming message. Click Exit to close the MIDlet.

Sending MMS Messages from WMA Console to an Emulator
To send an MMS message from the WMA console to the emulator, ensure that WMADemo 
has been installed using Run Project via OTA. 

1. From the WMADemo home screen, select MMS Receive. The emulator displays: 
"MMS Receive" and the message "Waiting for MMS on applicationID 
example.mms.MMSDemo..."

2. In the WMA console, click Send MMS to open the MMS composition window. 
The Header tab is open by default. Supply any message subject, the application ID 
example.mms.MMSDemo, and the telephone number of the running emulator. That 
number is displayed to the right of the To field by default. If you do not see the 
number you want, click the Add button to add it. When you have listed multiple 
numbers the number field is a dropdown list

The To field on the left is a dropdown list from which you can choose To, Cc or 
Bcc.
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3. Click the Parts tab. The WMA console enables you to select files to send as parts of 
the MMS message. Click Add and use the file browser to find the file you want to 
send. Click OK.

4. Click Send to send the message.

The image and its information are displayed in the emulator.

Running WMA Tool
WMA Tool is the command line version of the WMA Console. To send and receive 
SMS, CBS, and MMS messages from the command line, run: 

installdir\bin\wma-tool <command> [options]

The device manager must be running before you launch wma-tool.

When the tool is started, it outputs the phone number it is using.

Command

Each protocol has send and receive commands. The requested command is passed to 
the tool as a first argument. Possibilities are: 

■ receive

■ smsreceive - receives SMS messages

■ cbsreceive - receives CBS messages

■ mmsreceive - receives MMS messages

■ smssend - sends SMS message

■ cbssend - sends CBS message

■ mmssend - sends MMS message

The *send commands send the specified message and exit. The *receive commands 
print incoming messages until they are explicitly stopped.

Options

-o outputDir. Store binary contents to outputDir.

-t timeout. Non-interactive mode, waits the number of timeout seconds for messages.

-f Store text contents as files instead of printing them.

-q Quiet mode.

smsreceive, cbsreceive, and mmsreceive
The syntax for receiving a message is basically the same for all three protocols.

smsreceive [-o outputDir] [-t timeout] [-q] 

cbsreceive [-o outputDir] [-t timeout] [-q] 

mmsreceive [-o outputDir] [-t timeout] [-q] 

Example
This example demonstrates how to receive a message from an emulator.

1. Start the emulator from the Windows Start menu: 
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Start > Programs > Java(TM) ME Platform SDK 3.3 > Java ME SDK CLDC 
Emulator.

You can also start the emulator from the bin directory. This example also runs the 
WMADemo project.

emulator.exe -Xdevice:JavaMEPhone1 
-Xdescriptor:"C:\Documents and Settings\username\My Documents\NetBeansP
rojects\WMADemo\dist\WMADemo.jad"

2. Start wma-tool from the Java ME SDK installdir\bin directory:

C:\Java_ME_platform_SDK_3.3\bin\wma-tool smsreceive

WMA tool started with phone number: 987654321
press <Enter> to exit.

3. In the emulator run the SMS Send MIDlet and send a message to the WMA 
console. Enter the console telephone number

The console receives the message as follows:

SMS Received:
          From: 123456789
Timestamp: Thu Aug 23 23:31:26 PDT 2012
          Port: 50000
  Content type: Text
      Encoding: GSM7BIT
       Content: A message from JavaMEPhone1 to wma-tool
Waiting for another message, press <Enter> to exit.

smssend
wma-tool smssend target_phone target_port message_content

■ target_phone

Phone number of the target phone. Mandatory first argument.

■ target_port

Port of the target phone. Mandatory second argument.

■ message_content

Mandatory third argument. Can have one of these two forms:

■ text: text of the text message

■ -f file: sends content of the specified file as a binary message.

Example:

wma-tool smssend 123456789 50000 "smssend message from wma-tool"

cbssend
wma-tool cbssend  message_id message_content

■ message_id

ID of the message. Mandatory first argument.

■ message_content
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Mandatory second argument. Can have one of these two forms:

■ text: text of the text message

■ -f file: sends content of the specified file as a binary message.

Example:

wma-tool cbssend 50001 "cbssend message from wma-tool"

mmssend
wma-tool mmssend applicationId subject
     [-to <targetphone>]* [-cc <target phone>]* [-bcc <target phone>]*
     [-part { <part_from_file> | <part_from_text> } ]*
Each part is defined by name=value pairs delimited by a semicolon ";" separator.

Part Variables

To create part_from_file, define the following variables. 

■ file

File to send as a message part.

■ mimeType

Mime type of the file.

To create part_from_text, define the following variables:

■ text

Text to send as a message part. mimeType is set to text/plain.

■ -to target_phone

"to" target phone number. You can use any number of these options.

■ -cc target_phone

"cc" target phone number. You can use any number of these options.

■ -bcc target_phone

"bcc" target phone number. You can use any number of these options. 

Part from Text Options

Separate options with semicolons. For example: 

■ -part contentId=content ID; encoding=encoding; text=text

Appends text part to the message. You can use any number of these options. 
Contains the following options:

■ content ID: content ID of this message part

■ encoding: Sent text encoding. Only relevant for "text/plain." Mime type 
defaults to UTF8.

Part from File Options

mimeType=mime type; contentId=content ID; file=file name

Note: The file and the mimeType must be separated by a semicolon.
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■ Appends binary part to the message with content loaded from the given file. You 
can use any number of these options. 

Separate the options with a semicolon. 

■ content id: content ID of this message part

■ mime type: mime type of this message part

■ file name: file with content of this message part

■ fileEncoding: Encoding of text in the file, only relevant for "text/plain", only 
applies if the file argument is present. Defaults to the value of the encoding 
variable.

Example:

wma-tool mmssend example.mms.MMSDemo MySubject -to 123456789 -part 
file=Duke.png;mimeType=image/png
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23JSR 184: Mobile 3D Graphics

The Mobile 3D Graphics API for J2ME, (JSR 184) provides 3D graphics capabilities 
with a low-level API and a high-level scene graph API. This chapter provides a brief 
overview and general guidelines for working with JSR 184.

JSR 184 is a specification that defines the Mobile 3D Graphics (M3G) API for the J2ME. 
This API provides 3D functionality in a compact package that's appropriate for 
CLDC/MIDP devices. The API provides two methods for displaying 3D graphics 
content:

■ The immediate mode API makes it possible for applications to directly create and 
manipulate 3D elements. 

■ Layered on top of this is a scene graph API, also called retained mode, that makes it 
possible to load and display entire 3D scenes that are designed ahead of time. 

For more information, consult the JSR 184 specification at 
http://jcp.org/en/jsr/detail?id=184.

Choosing a Graphics Mode
Applications are free to use whichever approach is most appropriate or to use a 
combination of the retained mode and immediate mode APIs. 

JSR 184 provides a standard API for CLDC/MIDP devices, enabling a new generation 
of 3D applications. The immediate mode API, in turn, is compatible with OpenGL ES, 
a standard lightweight API for 3D graphics. See http://khronos.org/ for more 
information on OpenGL ES.

Immediate Mode
Immediate mode is appropriate for applications that generate 3D graphics content 
algorithmically, such as scientific visualizations or statistical graphs. The application 
creates 3D objects and manipulates them directly.

For an example of immediate mode, see the Life3D MIDlet in the Demo3D example 
application.

Retained Mode
Most applications, particularly games, use the retained mode or scene graph API. In 
this approach, a graphic designer or artist uses 3D modeling software to create a scene 
graph. The scene graph is saved in the JSR 184 file format. The scene graph file is 
bundled with the application. At runtime, the application uses the scene graph API to 
load and display the file.
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Applications can manipulate parts of a loaded scene graph to animate characters or 
create other effects. The basic strategy is to do as much work as possible in the 
modeling software. At runtime, the application can grab and manipulate parts of the 
scene graph, which can also include paths for animation or other effects.

For an example of retained mode, see the retainedmode MIDlet in the Demo3D example 
application.

Quality Versus Speed
One of the challenges of MIDP development is the constrained environment of typical 
devices. Compared to desktop computers, MIDP devices have slow processors and 
little memory. These challenges extend into the arena of 3D graphics. To accommodate 
a wide variety of implementations, the JSR 184 specification provides various 
mechanisms to make the display of a 3D scene as efficient as possible.

One approach is scoping, a technique where you tell the 3D graphics implementation 
when objects are not going to interact with each other. For example, if you defined a 
scene graph for a house, you could use scoping to specify that the light in the 
basement doesn't affect the appearance of the bedroom on the second floor. Scoping 
simplifies the implementation's task because it reduces the number of calculations 
required to show a scene.

In general, the best way to improve the rendering speed of 3D scenes is to make some 
compromises in quality. The Mobile 3D Graphics API includes rendering hints so that 
applications can suggest how the implementation can compromise quality to improve 
rendering speed.

Content for Mobile 3D Graphics
Most mobile 3D applications use scene graphs in resource files to describe objects, 
scenes, and characters. Usually it is not programmers but graphic designers or artists 
who create the scene graphs, using standard 3D modeling tools.

Several vendors offer tools for authoring content and converting files to the JSR 184 
format. 

Because it is relatively difficult to create and manipulate 3D graphics content in an 
application using the immediate mode API, most applications rely as much as possible 
on a scene graph file. By putting as much as possible into the scene graph file at design 
time, the application's job at runtime is considerably simplified.

Running Demo3D Samples
Demo3D contains MIDlets that demonstrate JSR 184 features.

Click the File menu and select New Project. In the Categories window, click Samples 
and select Java ME SDK 3.3. Then single-click Demo3D and click Next. Specify a 
name and location and click Finish.

Life3D 
Life3D implements the popular Game of Life in three dimensions. Live cells are 
represented by cubes. Each cell has 26 possible neighbors (including diagonals). For 
each step of the animation, cells with fewer than four neighbors die of loneliness, 
while cells with more than five neighbors die of overcrowding. An empty cell with 
exactly four neighbors becomes a new live cell.
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The view of the playing board rotates slowly so you can view the board from all 
angles.

The keypad buttons in Table 23–1 provide control over the game:

The source code for this example can be found at:

 projects\Demo3D\src\com\superscape\m3g\wtksamples\life3d\Life3D.java

The variable, projects, is the directory you are using to store your NetBeans projects.

RetainedMode 
The RetainedMode MIDlet plays a scene file that shows a skateboarder in an endless 
loop. The source code is found at:

 projects\Demo3D\src\com\superscape\m3g\wtksamples\retainedmode

PogoRoo
PogoRoo displays a kangaroo bouncing up and down on a pogo stick. To steer the 
kangaroo, use the arrow keys. Press up to go forward, down to go backward, and left 
and right to change direction. Try holding down the key to see an effect. The source 
code is found at:

projects\Demo3D\src\com\superscape\m3g\wtksamples\pogoroo

Table 23–1 Controls for Life3D

Button Description

0 Pause the animation.

1 Resume the animation at its default speed.

2 Speed up the animation.

3 Slow down the animation.

4 Choose the previous preset configuration from an arbitrary list. The name of the 
configuration is shown at the top of the screen.

5 Choose the next preset configuration from the list.

* Generate a random configuration and animate until it stabilizes or dies. If it dies, 
generate a new random configuration.
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24JSR 211: Content Handler API (CHAPI)

JSR 211 defines the Content Handler API (CHAPI). The basic concept is that MIDlets 
can be launched in response to incoming content (files). Modern mobile phones can 
receive content using SMS, infrared, Bluetooth, e-mail, and other methods. Most 
content has an associated content type. CHAPI specifies a system by which MIDlets 
can be launched in response to specific types of content.

See "Using Content Handlers" and "Running the CHAPIDemo Content Browser."

Using Content Handlers
In the Oracle Java ME SDK Content Handlers are integrated in a project as application 
descriptors. Content Handlers you define are packaged with the application

Follow these steps to work with content handlers in the CHAPIDEMO sample 
application (see "Running the CHAPIDemo Content Browser").

1. In the Projects window, right-click CHAPIDemo and select Properties from the 
context menu. 

2. In the Category pane, select Application Descriptor, and click the Content 
Handlers tab.

3. In the Content Handlers table, each line in the list represents the settings for a 
content handler. 

Figure 24–1 The Content Handlers Tab

■ To create a new content handler, press Add, or to edit an existing content 
handler, press Edit. Both actions open the Content Handler Properties 
window. See "Defining Content Handler Properties."
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■ To adjust the order of the content handlers, select one and click Move Up and 
Move Down. To remove a content handler from the list, select it and press 
Remove.

■ See Defining Content Handler Properties and "Running the CHAPIDemo 
Content Browser."

Defining Content Handler Properties
In the Projects window, right-click a project and select Properties from the context 
menu. In the Category pane, select Application Descriptor, and click the Content 
Handler tab. Pressing Add or Edit opens the Content Handler Properties window. 

Figure 24–2 The Content Handlers Properties Window

■ In the Class field, choose a class name from the dropdown menu. 

■ ID is a required identification string when you invoke a content handler and 
control access.

■ In Content types, list the content types for which this content handler is 
responsible. Use Add Type and Remove to manage the list. 

■ In Suffixes, provide a list of URL suffixes that act as a substitute for an explicit 
content type.
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■ In Access allowed to, list IDs for content handlers that are allowed access to this 
content handler. If the list is empty, access to this content handler is granted to 
every content handler.

Defining Content Handler Actions
Content handler actions give invoking applications a choice about how to handle 
content. An Action is associated with an existing content handler. An image viewer 
content handler, for example, might include an action for viewing the image at its 
original size and another action that makes the image fill the available screen space.

In the Projects window, right-click a project and select Properties from the context 
menu. In the Category pane, select Application Descriptor, and click the Content 
Handler tab. Press Add or Edit to open the Content Handler Properties window and 
click the Actions tab, as shown here.

Figure 24–3 The Content Handlers Properties Window

The Actions list contains the internal names of the actions for this content handler. 
Locales is a list of all the locales for which human-readable action names are provided. 
Localized Actions is a grid which contains the human-readable action names for 
various locales. Each locale is represented by a row, while the actions are listed as 
columns. You can see all the human-readable action names for a particular locale by 
reading across a single row.

Running the CHAPIDemo Content Browser
This demo is a content browser that takes advantage of the content handler registry. It 
enables you to view different types of content from different sources. 

Note: For the demo to work this project must reside in the Java ME 
SDK installation’s \apps subdirectory. You must create this directory 
yourself. For example, 
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1. Click the File menu and select New Project.

2. In the Categories window select Samples > Java ME SDK 3.3 and single-click 
CHAPIDemo. Click Next.

Save the CHAPIDemo sample project in installdir\apps directory; for example, 
C:\Java_ME_platform_SDK_3.3\apps\CHAPIDemo. Click Finish.

3. Right-click the project and select Properties. Choose the Running category, and 
select Execute through OTA and click OK.

Not all features of the demo are available if you choose the Run command. 
Additionally, to see certain features of the demo, an HTTP server is required. The 
server is located in the installdir\apps directory. Also the audio and video files are 
located in the content directory, which must be located in the CHAPIDemo. 
directory (installdir\apps\CHAPIDemo\content).

You might see security messages as CHAPIDemo registers itself. 

4. Launch CHAPIDemo.

On the Favorite Links page, choose CHAPI Demo. Press Select or click the Menu 
soft button and choose Go.

You might see a request for permission to use airtime. To speed up the demo 
interaction, select "Ask once per application use" and select the Yes soft key (if you 
do not check this option you can still use the demo but you see the airtime 
message more frequently).

The Text Viewer displays a Media Player URL and links to various media files.

5. Install the Media Player to view media.

■ Click the URL http:handlers/dist/MediaHandler.jad, or, use arrow keys to 
highlight the URL and from Menu, select Go.

■ The application asks, "Are you sure you want to install Media Handler?" Click 
the Install soft key.

An authorization Information screen is displayed. 

■ Click the Install soft key. 

The installation is confirmed and you are returned to the Text Viewer. The 
Media Handler shows as a separate application in the AMS.

6. Select and view the different image, video, audio and text URLs. 

Click on a link to open that media in the viewer, or, use arrows to highlight the 
link, then select Go from the soft menu. 

Select the Back soft key to return to the Text Viewer.
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25JSR 226: Scalable 2D Vector Graphics

JSR 226, Scalable 2D Vector Graphics for J2ME, supports rendering sophisticated and 
interactive 2D content.

Scalable Vector Graphics (SVG) is a standard defined by the World Wide Web 
Consortium. It is an XML grammar for describing rich, interactive 2D graphics.

The Scalable Vector Graphics (SVG) 1.1 specification (available at 
http://www.w3.org/TR/SVG11/) defines a language for describing 
two-dimensional graphics in XML. 

SVG Tiny (SVGT) is a subset of SVG that is appropriate for small devices such as 
mobile phones. See http://www.w3.org/TR/SVGMobile/. SVGT is a compact, yet 
powerful, XML format for describing rich, interactive, and animated 2D content. 
Graphical elements can be logically grouped and identified by the SVG markup. 

Java ME applications using SVG content can create graphical effects that adapt to the 
display resolution and form factor of the user's display. 

SVG images can be animated in two ways. One is to use declarative animation, as 
illustrated in Section , "Play SVG Animation." The other is to repeatedly modify the 
SVG image parameters (such as color or position), through API calls. 

While it is possible to produce SVG content with a text editor, most people prefer to 
use an authoring tool. Here are two possibilities:

■ Inkscape: http://inkscape.org

■ Adobe Illustrator: 
http://www.adobe.com/products/illustrator/main.html

Running SVGDemo
This project contains MIDlets that demonstrate different ways to load manipulate, 
render, and play SVG content.

Click the File menu and select New Project and in the Categories window select 
Samples then select Java ME SDK 3.3 and single-click SVGDemo. Click Next.

SVG Browser
The SVGBrowser MIDlet displays SVG files residing in the phone file system. Before 
running this demo, place an SVG file in your device skin's file structure. The default 
location is:

username\javame-sdk\3.3\work\devicename\appdb\filesystem\root1
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For your device location, see "Oracle Java ME SDK Directories" and Table 8–1. Launch 
the demo. The application displays the contents of root1. Select your SVG file and 
choose the Open soft key.

Render SVG Image
Render SVG Image loads an SVG image from a file and renders it. Looking at the 
demo code you can see that the image is dynamically sized to exactly fit the display 
area. The output is clear and sharp.

Play SVG Animation
This application plays an SVG animation depicting a Halloween greeting card. Press 8 
to pause, 5 to start or resume, and 0 to stop. 

The SVG file contains a description of how the various image elements evolve over 
time to provide this short animation. 

In the following code sample, the JSR 226 javax.microedition.m2g.SVGImage class is 
used to load the SVG resource. Then, the javax.microedition.m2g.SVGAnimator class 
can take all the complexity of SVG animations and provides a java.awt.Component or 
javax.swing.JComponent which plays the animation. The SVGAnimator class provides 
methods to play, pause, and stop the animation. 

Example 25–1 SVG File Example

import javax.microedition.m2g.ScalableGraphics;
import javax.microedition.m2g.SVGImage;

...
String svgURI = ...;
SVGImage svgImage = (SVGImage) SVGImage.createImage(svgURI, null);
SVGAnimator svgAnimator = SVGAnimator.createAnimator(svgImage);

// If running a JSE applet, the target component is a JComponent.
JComponent svgAnimationComponent = (JComponent) svgAnimator.getTargetComponent();
...

svgAnimator.play();
...
svgAnimator.pause();
...
svgAnimator.stop();

Create SVG Image from Scratch
This demo builds an image using API calls. It creates an empty SVGImage, populates 
it with a graphical content, and then displays that content.

Bouncing Balls
Bouncing Balls plays an SVG animation. Press 8 to play, 5 to start, and 0 to stop. If you 
press 8, pressing 5 resumes the animation. If you press 0, pressing 5 starts the 
animation from the beginning.
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Optimized Menu
In this demo, selected icons have a yellow border. As you move to a new icon, it 
becomes selected and the previous icon flips to the unselected state. If you navigate off 
the icon grid, selection loops around. That is, if the last icon in a row is selected, 
moving right selects the first icon in the same row.

This demo illustrates the flexibility that combining UI markup and Java offers: a rich 
set of functionality (graphics, animations, high-end 2D rendering) and flexibility in 
graphic manipulation, pre-rendering or playing.

In this example, a graphic artist delivered an SVG animation defining the transition 
state for the menu icons, from the unselected state to the selected state. The program 
renders each icon's animation sequence separately into off-screen buffers (for faster 
rendering later on), using the JSR 226 API.

With buffering, the MIDlet adapts to the device display resolution (because the 
graphics are defined in SVG format) and still retain the speed of bitmap rendering. In 
addition, the MIDlet is still leveraging the SVG animation capabilities.

The task of defining the look of the menu items and their animation effect (the job of 
the graphic artist and designer) is cleanly separated from the task of displaying the 
menu and starting actions based on menu selection (the job of the developer). The two 
can vary independently provided both the artist and the developer observe the SVG 
document structure conventions.

Picture Decorator
In this sample you use the phone keys to add decorations to a photograph. The key 
values are:

This demo provides 16 pictures for you to decorate. 

Use the 2 and 8 keys to page forward and back through the photos. 

To decorate, press # to display the picker. Use the arrow keys to highlight a graphic 
object. The highlighted object is enlarged. Press Select to choose the current graphic or 
press the arrow keys to highlight a different graphic. Press Select again to add the 
graphic to the photo. When the decoration is added you see a red + on the graphic, 
indicating it is selected and can be moved, resized, and manipulated. 

Key Action

1 key shrink

2 key next picture

3 key grow

4 key help

5 key horizontal flip

6 key vertical flip

7 key rotate counter-clockwise

8 key previous picture

9 key rotate clockwise

# display picker options
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Figure 25–1 Adding a Graphic

Use the navigation arrows to move the graphic. Use 1 to shrink the graphic, and 3 to 
enlarge the graphic. Use 5 or 6 to flip, and 7 or 9 to rotate. When you are satisfied with 
the position, press Select. Look for a green triangle. This is a cursor. Use the navigation 
keys to move the green triangle around the picture. When the cursor is over an object 
it is highlighted with a red box. Press Select. The red + indicates the object is selected 
and it can be manipulated or removed. 

Figure 25–2 Highlighting a Graphic

To remove a decoration (a property), select an object, then click the Menu soft key and 
choose Remove prop.

Location Based Service
Launch the application. A splash screen (also used as the help) appears. The initial 
view is a map of your itinerary - a walk through San Francisco. The bay (in blue) is on 
the right of your screen. Press 1 to start following the itinerary. The application zooms 
in on your location on the map. Turn-by-turn directions appear in white boxes on the 
horizontal axis. While the itinerary is running, Press 7 to rotate the map 
counter-clockwise. Note, the map rotates and the text now appears on the vertical axis. 
Press 7 again to restore the default orientation. Press 4 to display the help screen.
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Figure 25–3 A Location-Based Service Screen

Running SVGContactList
This application uses different skins to display the same contact list information and a 
news banner. The skins feature different colors and fonts.

Select SVGContactlist(skin 1) or SVGContactlist(skin 2), then click Launch.

Use the up and down arrows to navigate the list of contacts. The selected name is 
marked with a special character (a > or a dot) and is displayed in a larger font.

Press > or the select button to see more information for the selected name. When you 
are in the detailed view you can traverse the detail entries using the up or down 
arrows.

Press < or the select button to return to the contact list.

Press the left soft button to go back to the demos MIDlet list and view another skin.
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26JSR 239: Java Bindings for Open GL ES

JSR 239 provides a Java language interface to the open standard OpenGL ES graphics 
API.

 OpenGL ES is a standard API for 3D graphics, a subset of OpenGL, which is pervasive 
on desktop computers.

Open GL Overview
JSR 239 defines the Java programming language bindings for two APIs, OpenGL for 
Embedded Systems (OpenGL ES) and EGL. EGL is a standard platform interface layer. 
Both OpenGL ES and EGL are developed by the Khronos Group 
http://khronos.org/opengles/.

While JSR 184 (which is object oriented) requires high level functionality, OpenGL is a 
low-level graphics library that is suited for accessing hardware accelerated 3D 
graphics. 
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27JSR 256: Mobile Sensor API Support

The JSR 256 Mobile Sensor API allows Java ME application developers to fetch data 
from sensors. A sensor is any measurement data source. JSR 256 supports many 
different types of sensor connections (wired, wireless, embedded, and more) but 
Oracle Java ME SDK only provides preconfigured support for sensors embedded in a 
device.

Sensors can vary from physical sensors such as magnetometers and accelerometers to 
virtual sensors that combine and manipulate the data they have received from various 
kinds of physical sensors. An example of a virtual sensor might be a level sensor 
indicating the remaining charge in a battery or a field intensity sensor that measures 
the reception level of the mobile network signal in a mobile phone.

The SDK GUI provides sensor simulation. The emulator's External Events Generator 
Sensors tab enables you to run a script that simulates sensor data.

You can use the API available with the SDK to create a custom sensor implementation 
with additional capabilities and support for different connection types.

The Sensors demonstration has two MIDlets, SensorBrowser and Marbles that 
demonstrate the SDK's implementation of the Mobile Sensor API.

Creating a Mobile Sensor Project
The Mobile Sensor API is automatically included in version 3.3 CLDC projects. In 
NetBeans, create a new Java ME Mobile Application, choose the CLDC version 3.3 
platform, and specify a device that supports CLDC-1.1 and MIDP-2.1 (JavaMEPhone1 
for example). 

A sensor project freely detects sensors, but this does not imply you can get data from 
the sensors you find. You might need to explicitly set permissions in your project so 
you can interact with certain sensors. To see an example, open the Sensors sample 
project. Right-click on Sensors and select Properties, choose the Application Descriptor 
category, and select the API Permissions tab.

The following permissions work with the preconfigured embedded sensors shipped 
with the SDK:

■ javax.microedition.io.Connector.sensor

Required to open a sensor connection and start measuring data.

■ javax.microedition.sensor.ProtectedSensor

Required to access a protected sensor.

■ javax.microedition.sensor.PrivateSensor
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Required to access a private sensor.

A sensor is private or protected if the sensor's security property has the value private 
or protected. The security property is an example of a sensor property you might 
create for yourself in your own sensor configuration. You can create your own optional 
properties using com.sun.javame.sensorN.proplist and 
com.sun.javame.sensorN.prop.any_name, where N is the sensor number and any_
name is the name of your property. The security sensor property was created as 
follows:

# add security into proplist
com.sun.javame.sensor<N>.proplist: security
# add security property value
com.sun.javame.sensor<N>.prop.security: private

Using a Mobile Sensor Project
The sample Sensor project can be installed over the air. To install the application into 
the emulator right-click the Sensors project and select Properties, select the Running 
category, select Execute through OTA, and click OK.

In the emulator window, click the Tools menus and select External Events Generator. 
In the External Events Generator, click the Sensors tab. In this tabbed pane, you can 
view all sensors currently available in the emulator, with the sensor ID, name, and 
availability. If the sensor supports change to availability you can click on the check box 
to change it. As mentioned earlier, the provided implementation does not support 
availability change, but a custom implementation you create might do so. 

When you select a sensor row the bottom of the dialog displays any custom sensor 
controls. For example, the acceleration sensor, has three channels: axis_x, axis_y, and 
axis_z. Each channel has a slider that changes the current channel value, and an edit 
box you can use to input a value. The channel unit label is displayed on the far right.

Under the channels there is a script player control that enables you to play sensor 
value events from a script file of the format discussed in "Creating a Sensor Script 
File." See "SensorBrowser" for a description of how to use the Sensors demo.

Creating a Sensor Script File
To simulate sensor inputs, provide a sensor script. The file format is as follows:

Example 27–1 Sensor Script File Format Example

<sensors>
   <value time="0">
      <channel id="0" value="0" />
      <channel id="1" value="0" />
   </value>
   <value time="100">
      <sensor active="false"/>
   </value>
   <value time="100">
      <channel id="0" value="-50" />
      <channel id="1" value="10" />
     <sensor active="true"/>
   </value>
</sensors>
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marbles.xml in the Sensors project directory is an example of a sensor script file. The 
attributes are as follows:

■ The attribute time in the value tag is the delay from the previous command in 
milliseconds.

■ The channel tag sets the value of the channel with the specified id value, to value. 
The channel ignores the id if the value of id is not specified or if the value is out of 
the channel range.

■ The sensor tag is a true or false value that makes the sensor available or 
unavailable. The preconfigured sensors provided with this release are embedded, 
so they cannot be deactivated. If you configure your own sensor that is not 
embedded, it is possible to deactivate it.

SensorBrowser
The SensorBrowser application displays the sensor detail information for reach 
channel defined for the demo.

1. In the emulator, select SensorBrowser and use the soft key to select Launch the 
application.

Depending on your security settings you might see the warning: "Sensors" wants 
to connect to sensor <#>. Is it OK to use sensor? For test purposes, select "Ask once 
per application use" and choose the Yes soft button.

The emulator displays a list of sensors.

2. Use the navigation keys to highlight a sensor, then use the soft key to select Detail.

For example, the following screen shows the details for the acceleration sensor.

Figure 27–1 Acceleration Sensor Screen

Click Back, then click Exit to return to the application menu.
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Marbles
This demonstration uses the Marbles game to provide visual feedback for sensor 
inputs provided in a script.

1. From the application menu select Marbles and use the soft key to launch the 
application. 

2. In the emulator, click the Tools menu and select External Events Generator. Click 
the Sensors tab to display a list of the sensors in this application.

3. Select the Acceleration Sensor row (ID 3).

4. Click the Browse button, and in the Sensors project directory select marbles.xml.

5. Observe the movement of the marbles on the emulator screen. On the external 
events screen you can see the sliders move as the script runs. You can use the 
familiar controls to play, pause, and stop the script.
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28JSR 257: Contactless Communication API

The Contactless Communication API (http://jcp.org/en/jsr/detail?id=257) 
is a Java ME optional package that allows applications to access information on 
contactless targets, such as Radio Frequency Identification (RFID) tags and bar codes. 
RFID tags are often used in business for item identification, article surveillance, and 
inventory. Each RFID tag contains a unique identification number used to identify a 
tagged object.

Using the JSR 257 API, an RFID reader can be built into an Oracle Java Wireless Client 
software phone stack, allowing the handset to read data from a tagged target and write 
data back to it. RFID readers use the 13.56 MHz radio frequency and the 
communication distance is usually less than 10 centimeters.

The Near Field Communication (NFC) Forum defines the NFC Data Exchange Format 
(NDEF) data packaging format. NDEF facilitates communication with an RFID tag, or 
between one NFC device and another. The Contactless Communication API provides a 
connection to any physical target that supports the NDEF standard, allowing 
applications to exchange data with any target tagged with NDEF formatting, 
regardless of actual physical type.

Using ContactlessDemo
The Oracle Java ME SDK provides a way to test contactless communication. The 
MIDlet running on the emulator waits to detect an RFID tag. You can simulate the tag 
communication using the emulator’s external events generator to detect and attach the 
tag. You can use one of the tags included in the sample, or create tag files of your own, 
as described in "Tag File Formats."

1. Launch the ContactlessDemo. The MIDlet registers the RFID tag listener, the 
NDEF tag listener and the NDEF record listener, then notifies you that it is waiting 
for a tag.

2. In the emulator, click the Tools menu and select External Events Generator. The 
Contactless Communication tab is automatically displayed. In the external events 
generator, the tag emulator supplies several tags by default: hello, nested, vcard, 
jdts, jdts2, and ndefEmpty.

3. To test the connection, select an available tag and press the Attach tag.

In the emulator, the MIDlet notifies you that the NDEF target is detected, displays 
the tag information, and prints the payload if it is a text record. 

In the external events generator, press Detach tag to end the session.

Events are recorded in the log area. To clear the log, right-click and select Delete 
Text. To clear the emulator screen press Clear.
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4. To create your own tag, create a tag file according to the NDEF standard. For a 
sample, see "Tag File Formats."

In the External Events Generator, press Create tag and browse to select your tag 
file, and press Open. If the file is properly formed, the new tag is added to the 
available tags list. To write protect the tag, select the tag and select the Locked 
option. When a tag is locked, no data can be written to the tag.

Click Remove tag to remove any tag from the list. If it is a tag you created, the 
original file on disk is not affected. If the default tags are removed, they reappear 
when you restart the demo.

5. Optional. Instead of performing interactive actions in the external events 
generator, you can use a script to do the same thing. 

Create a file as directed in "Script Format." In the external events generator, click 
the Browse button to locate your script, then press Play.

Tag File Formats
Tags are created in XML format in accordance with the NFC and NDEF standards. To 
see how the sample files are formed, see: 
installdir\toolkit-lib\modules\emulator-ui-window-external-events\jsr257\conf
\tags.

A sample file with several records might look like this:

Example 28–1 Tag File Format Example

<?xml version="1.0" encoding="UTF-8"?>
<jsr257client>
    <UID>12-CD-45-67-89-AB-CD</UID>

    <TargetProperties>
        <TargetProperty>NDEF</TargetProperty>
    </TargetProperties>

    <NDEFMessage>
        <NDEFRecord>
            <Format>MIME</Format>
            <Name>text/plain</Name>
            <Id>mimeid</Id>
            <Payload>Hello, MIME World!</Payload>
        </NDEFRecord>
        <NDEFRecord>
            <Format>MIME</Format>
            <Name>text/example</Name>
            <Id>urn:company:product:ndef:payload:2</Id>
            <Payload>payload2</Payload>
        </NDEFRecord>
        <NDEFRecord>
            <Format>EXTERNAL_RTD</Format>
            <Name>urn:nfc:ext:oracle.com:type1</Name>
            <Id></Id>
            <Payload>payload3</Payload>
        </NDEFRecord>
        <NDEFRecord>
            <Format>URI</Format>
            <Name>urn:company:product:test_uri</Name>
            <Id>urn:company:product:ndef:payload:4</Id>
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            <Payload>payload4/<Payload>
        </NDEFRecord>
        <NDEFRecord>
            <Format>NFC_FORUM_RTD</Format>
            <Name>urn:nfc:wkt:Sp</Name>
            <Id></Id>
            <Payload>smart-poster</Payload>
        </NDEFRecord>
        <NDEFRecord>
            <Format>MIME</Format>
            <Name>text/x-vCard</Name>
            <Id>duke</Id>
            <Payload>BEGIN:VCARD VERSION:2.1 FN:Oracle TEL:+1-650-506-7000
                     ADR:500 Oracle Parkway City:Redwood Shores
                     State:CA;94065 END:VCARD
            </Payload>
        </NDEFRecord>
    </NDEFMessage>
</jsr257client>

Script Format
You can use the external events generator buttons to attach and detach a tag, or you 
can write a script to perform these actions. The script syntax is as follows:

Example 28–2 Tag Script File Format Example

# Comment:
  # this is a comment
# Tag definition:
    tag <tag name> <path to the tag xml file>
# Attach tag:
   attach <tag name>
# Delay. Ensures the tag is attached before other actions.
   wait <time in ms>
# Print tag information:
   print <tag name>
# Detach tag:
   detach <tag name>

This is a sample script:

Example 28–3 Tag Script Sample

   tag C D:\MyTags\ccomtag.xml
   attach C
   print C
   wait 10000
   detach C

In the external events generator, click Browse and select the script file, then press Play 
to run the script. The results are shown in the Log area. For example, if the sample 
script calls the sample tag file in "Tag File Formats," the log output is as follows:

[18:24:10]  Run Script: D:\JMESDKLocal\ccomtag.xml
[18:24:10]  Define tag 2058 (C)
[18:24:10]  Print 2058 (C)
[18:24:10]  Attached tag 2058 (C)
[18:24:10]  UID: 02-34-56-78-9A-BC-DE
Properties:  NDEF
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NDEF message: 8 record(s)
#0: NDEF record:  format=MIME, name=text/plain, id.length=2, payload.length=18
payload=Hello, MIME world!
#1: NDEF record:  format=MIME, name=text/example, id.length=34, payload.length=8
payload=payload2
#2: NDEF record:  format=EXTERNAL_RTD, name=oracle.com:type1, payload.length=8
payload=payload3
#3: NDEF record:  format=URI, name=urn:company:product:test_uri, id.length=34, 
payload.length=8
payload=payload4
#4: NDEF record:  format=EXTERNAL_RTD, name=company.com:type1, id.length=34, 
payload.length=8
payload=payload5
#5: NDEF record:  format=NFC_FORUM_RTD, name=Sp, payload.length=12
payload=smart-poster
#6: NDEF record:  format=URI, name=message/http, id.length=3, payload.length=56
payload=http://www.oracle.com/technetwork/java/javame/index.html
#7: NDEF record:  format=MIME, name=text/x-vCard, id.length=4, payload.length=122
payload=BEGIN:VCARD VERSION:2.1 FN:Oracle TEL:+1-650-506-7000
ADR:500 Oracle Parkway; City:Redwood Shores;State:CA;94065 END:VCARD
[18:24:10]  Wait 10000ms
[18:24:20]  Detached tag 2058 (C)
[18:24:20]  Script finished.
[18:24:25]  Received data for unknown tag 2,058
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AInstallation and Runtime Security Guidelines

The Oracle Java ME SDK requires an execution model that makes certain networked 
resources available for emulator execution. These required resources might include - 
but are not limited to - a variety of communication capabilities between Java ME SDK 
components.

During execution, the Oracle Java ME SDK architecture can present an insecure 
operating environment to the platform’s installation file system, as well as its runtime 
environment. For this reason, it is critically important to observe the precautions 
outlined in these guidelines when installing and running the Oracle Java ME SDK.

Maintaining Optimum Network Security
To maintain optimum network security, Oracle Java ME SDK can be installed and run 
in a “closed” network operating environment, where the Oracle Java ME SDK system 
is not connected directly to the Internet. Or, it can be connected to a secure company 
Intranet environment that can reduce unwanted exposure to malicious intrusion.

An example of an Oracle Java ME SDK requirement for an Internet connection is when 
wireless functionality requires a connection to the Internet to support communications 
with the wireless network infrastructure that is part of a Java ME application execution 
process. Whether or not an Internet connection is required depends on the particular 
Java ME application running on Oracle Java ME SDK. For example, some Java ME 
applications can use an HTTP connection.

In any case, if the Oracle Java ME SDK is open to any network access you must 
observe the following precautions to protect valuable resources from malicious 
intrusion: 

■ Installing the Java ME SDK Demos plugin is optional. Some sample projects use 
network access and open ports. Because the sample code does not include 
protection against malicious intrusion, you must ensure your environment is 
secure if you choose to install and run the sample projects. 

■ Install the Oracle Java ME SDK behind a secure firewall that strictly limits 
unauthorized network access to the Oracle Java ME SDK file system and services. 
Limit access privileges to those that are required for Oracle Java ME SDK usage 
while allowing all the bidirectional local network communications that are 
necessary for Oracle Java ME SDK functionality. The firewall configuration must 

Note: the Oracle Java ME SDK installation and runtime system is 
fundamentally a developer system. It is not designed to guard against 
any malicious attacks from outside intruders.
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support these requirements to run the Oracle Java ME SDK while also addressing 
them from a security standpoint.

■ Follow the principle of “least privilege” by assigning the minimum set of system 
access permissions required for installation and execution of the Oracle Java ME 
SDK.

■ Do not store any data sensitive information on the same file system that is hosting 
the Oracle Java ME SDK.

■ To maintain the maximum level of security, make sure the operating system 
patches are up-to-date on the Oracle Java ME SDK host machine.
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BTips for Legacy Toolkit Users

If you previously used the Sun Java Wireless Toolkit for CLDC or the CDC Toolkit, the 
advice in "Quick Start" still applies. Although the user interface is quite different, the 
project concept is similar. 

The following tips apply legacy terms and ideas to the SDK.

■ Runtime focus is less on the project and more on device capabilities and the 
emulation process.

In legacy toolkits you had to be careful to match the platforms, the APIs, and the 
capability of the output device. The SDK handles this problem differently, but as 
described in "Java ME Platforms," you should be sure that the emulator platform is 
correct and a device profile is selected. 

Clicking the green arrow runs the main project. If no project is set as the main 
project, clicking the green arrow runs the current project. To set a main project, 
click the Run menu, select Set Main Project, and select a project from the 
dropdown menu. Alternatively, you can right-click any open project and select 
run. 

In the device selector (Tools > Java ME > Device Selector) you can test many 
devices without changing the project properties. Right-click any device and choose 
Run Project, Run via OTA, or Run JAR or JAD... and select a project, or in the 
case of running a JAR or JAD, select the application’s JAR or JAD file. Only 
projects that are compatible with the device are shown in the context menu.

■ Import applications from legacy toolkits to SDK projects. The installation of the 
legacy toolkit must exist on the host machine. See "Import a Legacy MIDP Project," 
"Create a Platform for Legacy CDC Projects," and "Import a Legacy CDC Project."

■ Legacy toolkit settings are Application Descriptors in the SDK. Right-click a 
project and select Properties. Choose the Application Descriptor category.

■ Legacy toolkit utilities are generally accessible from Tools > Java ME submenu in 
the NetBeans IDE. For example, the WMA console, the Java ME SDK Update 
Center and more can be started from the Tools > Java ME submenu.

For example, select Tools > Java ME > WMA Console in the NetBeans IDE to see 
the WMA Console output.

■ CPU Profiler, Network Monitor, and Memory Monitor utilities can be accessed 
from the Profile menu or by right-clicking a project and selecting Profile. See 
Chapter 9, "Profiling Applications," Chapter 10, "Network Monitoring," and 
Chapter 11, "Monitoring Memory" for information on running these utilities.

■ The emulator is familiar, but there are some fundamental differences. 
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It is important to realize that the emulator is a remote process, and when it starts it 
is independent of the build process running in NetBeans. Stopping the build 
process or closing a project does not always affect the application running in the 
emulator. You must be sure to terminate the application from the emulator. For 
more on this topic, see "Running a Project" and "Working With Projects."

In the Wireless Toolkit, you could simultaneously run multiple versions of a 
device because the toolkit would increment the phone number automatically each 
time you launched a project. Because the emulator is now a remote process, the 
phone number is a unique property that must be set explicitly for the device 
instance. 

The emulator has additional display functionality. See "Emulator Features."
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