This document describes how to use the Oracle Java ME SDK plugin for Eclipse on Windows.
# Contents

**Preface** .............................................................................................................................................................. xv
  Audience ....................................................................................................................................................... xv
  Documentation Accessibility ....................................................................................................................... xv
  Conventions ..................................................................................................................................................... xv
  Related Documents ....................................................................................................................................... xvi

## 1 Before You Begin

- Installing the Java SE Platform ................................................................................................................. 1-1
  - Setting and Verifying Your Java SE PATH ............................................................................................... 1-1
- Installing the Oracle Java ME SDK Platform ............................................................................................. 1-2
- Installing and Starting the Eclipse IDE ........................................................................................................ 1-2

## 2 Installing Plugins and Configuring Eclipse

- Installing the Oracle Java ME SDK Eclipse Plugin ...................................................................................... 2-1
  - Installing Plugins on Eclipse Indigo 3.7 ................................................................................................. 2-1
  - Installing Plugins on Eclipse Juno 4.2 ................................................................................................. 2-5
- Configuring Eclipse ........................................................................................................................................ 2-6
- Verify Your Installation .................................................................................................................................. 2-8
  - Adding Devices Manually ....................................................................................................................... 2-8
- Quick Start ................................................................................................................................................... 2-9

## 3 Platforms

- Emulation Platforms ........................................................................................................................................ 3-1
  - CLDC with MIDP ...................................................................................................................................... 3-1
  - IMP-NG .................................................................................................................................................... 3-2

## 4 Using Sample Projects

- Creating a Sample Project .............................................................................................................................. 4-1
- Running a Project .......................................................................................................................................... 4-2
- Troubleshooting ............................................................................................................................................ 4-3
- Sample Project Overview ............................................................................................................................... 4-3
- Configuring the Web Browser and Proxy Settings ....................................................................................... 4-5
- Running MIDP and CLDC Sample Projects .............................................................................................. 4-6
  - Running the AdvancedMultimediaSupplements Sample Project ............................................................. 4-6
Image Effects ................................................................. 4-6
Music Effects ................................................................. 4-7
Camera ........................................................................... 4-7
Moving Helicopter ......................................................... 4-7
Running the Demos Sample Project ............................... 4-7
Colors ............................................................................ 4-8
Properties ....................................................................... 4-8
Http ................................................................................ 4-8
FontTestlet ...................................................................... 4-9
Stock .............................................................................. 4-9
Tickets ........................................................................... 4-10
ManyBalls ....................................................................... 4-11
MiniColor ........................................................................ 4-11
Chooser .......................................................................... 4-11
HttpExample ................................................................... 4-12
HttpExample ................................................................... 4-12
PushExample ................................................................... 4-12
Running FPDemo ............................................................ 4-12
Running Games ............................................................. 4-12
Running Network Demo ............................................... 4-12
Socket Demo .................................................................... 4-12
Datagram Demo ............................................................. 4-13
Running PhotoAlbum .................................................... 4-13
Running UIDemo ............................................................ 4-13
Running IMP-NG Sample Projects ................................. 4-14
Running the GPODemo ................................................... 4-15
Running the GPODemo on the Emulator ......................... 4-15
Running the GPODemo on the Reference Board ............... 4-15
Running the I2C Demo ..................................................... 4-16
Running the NetworkDemoMPNG ................................. 4-16
Running NetworkDemoMPNG on the Emulator ............... 4-16
Running NetworkDemoMPNG on the Reference Board ....... 4-17
Running the PDAPDemoMPNG ....................................... 4-17
Running the PDAPDemoMPNG on the Emulator ............... 4-17
Running the PDAPDemoMPNG on the Reference Board ....... 4-18
Running the Pulse Counter (Data Collection) Demo .......... 4-18
Configuring a Pulse Counter ........................................... 4-19
Running the Light Tracker Demo .................................... 4-20
Running the System Controller Demo ............................... 4-20

5 Viewing and Editing Project Properties

Projects ........................................................................ 5-1
Project Properties ......................................................... 5-2
Platform Selection ......................................................... 5-2
Editing Application Descriptor Properties ....................... 5-3
Building a Project ......................................................... 5-3
Compiling ....................................................................... 5-3
6 Working With Devices

The Device Manager on Windows ............................................................................................................. 6-1
Adding an External Device ......................................................................................................................... 6-3

Starting and Running Emulators ........................................................................................................... 6-4
Starting an Emulator ................................................................................................................................. 6-4

The IMP-NG Emulator .............................................................................................................................. 6-5
The External Events Generator .................................................................................................................. 6-7
IMP-NG Device Options ............................................................................................................................. 6-8

The Qualcomm IoE Emulator ..................................................................................................................... 6-8
The External Events Generator .................................................................................................................. 6-9
The Serial Peripheral Interface (SPI) Tab .................................................................................................... 6-9
The Inter-Integrated Circuit (I2C) Tab ......................................................................................................... 6-10

The CLDC Mobile Emulator ..................................................................................................................... 6-13
CLDC Application Management System .................................................................................................. 6-14
Mobile Emulator Menus ............................................................................................................................ 6-14
Running Projects Simultaneously on a Single Device ............................................................................. 6-15

Emulator Menu Settings .......................................................................................................................... 6-16
The Application Menu ............................................................................................................................... 6-16
The Device Menu ....................................................................................................................................... 6-17
Messages ................................................................................................................................................... 6-17
Orientation ................................................................................................................................................ 6-17
The Edit Menu .......................................................................................................................................... 6-17
The Tools Menu ....................................................................................................................................... 6-18
The View Menu ....................................................................................................................................... 6-18
The Help Menu ....................................................................................................................................... 6-19

Using the Device Selector ........................................................................................................................ 6-19
Viewing Device Properties ......................................................................................................................... 6-19
Platform Properties .................................................................................................................................. 6-19
Device Information .................................................................................................................................... 6-20
Device Properties ....................................................................................................................................... 6-20
Setting Device Properties .......................................................................................................................... 6-20
General Device Properties ....................................................................................................................... 6-20
Monitor ..................................................................................................................................................... 6-20
Location Provider #1 and #2 ...................................................................................................................... 6-21
SATSA ...................................................................................................................................................... 6-21
Bluetooth and OBEX ................................................................................................................................. 6-21
Running a Project from the Device Selector ............................................................................................ 6-21

Using the Custom Device Editor .............................................................................................................. 6-21
Creating a Custom Device .......................................................................................................................... 6-21

Running Projects Simultaneously on a Single Device 6-15
Creating a Custom Device 6-21
Running a Project from the Device Selector 6-21
Using the Custom Device Editor 6-21
Using the Device Selector 6-19
Viewing Device Properties 6-19
Platform Properties 6-19
Device Information 6-20
Device Properties 6-20
Setting Device Properties 6-20
General Device Properties 6-20
Monitor 6-20
Location Provider #1 and #2 6-21
SATSA 6-21
Bluetooth and OBEX 6-21
Running a Project from the Device Selector 6-21

Using the Custom Device Editor 6-21
Creating a Custom Device 6-21
Running a Project from the Device Selector 6-21
Using the Custom Device Editor 6-21
Using the Device Selector 6-19
Viewing Device Properties 6-19
Platform Properties 6-19
Device Information 6-20
Device Properties 6-20
Setting Device Properties 6-20
General Device Properties 6-20
Monitor 6-20
Location Provider #1 and #2 6-21
SATSA 6-21
Bluetooth and OBEX 6-21
Running a Project from the Device Selector 6-21

Using the Custom Device Editor 6-21
Creating a Custom Device 6-21
Running a Project from the Device Selector 6-21
Using the Custom Device Editor 6-21
Using the Device Selector 6-19
Viewing Device Properties 6-19
Platform Properties 6-19
Device Information 6-20
Device Properties 6-20
Setting Device Properties 6-20
General Device Properties 6-20
Monitor 6-20
Location Provider #1 and #2 6-21
SATSA 6-21
Bluetooth and OBEX 6-21
Running a Project from the Device Selector 6-21

Using the Custom Device Editor 6-21
Creating a Custom Device 6-21
Running a Project from the Device Selector 6-21
Using the Custom Device Editor 6-21
Using the Device Selector 6-19
Viewing Device Properties 6-19
Platform Properties 6-19
Device Information 6-20
Device Properties 6-20
Setting Device Properties 6-20
General Device Properties 6-20
Monitor 6-20
Location Provider #1 and #2 6-21
SATSA 6-21
Bluetooth and OBEX 6-21
Running a Project from the Device Selector 6-21

Using the Custom Device Editor 6-21
Creating a Custom Device 6-21
Running a Project from the Device Selector 6-21
Using the Custom Device Editor 6-21
Using the Device Selector 6-19
Viewing Device Properties 6-19
Platform Properties 6-19
Device Information 6-20
Device Properties 6-20
Setting Device Properties 6-20
General Device Properties 6-20
Monitor 6-20
Location Provider #1 and #2 6-21
SATSA 6-21
Bluetooth and OBEX 6-21
Running a Project from the Device Selector 6-21
<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>IMP-NG Device Properties</td>
<td>6-22</td>
</tr>
<tr>
<td>General Purpose Input Output (GPIO)</td>
<td>6-22</td>
</tr>
<tr>
<td>Inter-Integrated Circuit (I2C) and Serial Peripheral Interface (SPI)</td>
<td>6-22</td>
</tr>
<tr>
<td>Memory-Mapped I/O (MMIO)</td>
<td>6-23</td>
</tr>
<tr>
<td>Managing Custom Devices</td>
<td>6-24</td>
</tr>
<tr>
<td>Making Device Connections</td>
<td>6-24</td>
</tr>
<tr>
<td>Connecting to a UART Device</td>
<td>6-24</td>
</tr>
<tr>
<td>7 Finding Files in the Multiple User Environment</td>
<td></td>
</tr>
<tr>
<td>Switching Users</td>
<td>7-1</td>
</tr>
<tr>
<td>Installation Directories</td>
<td>7-1</td>
</tr>
<tr>
<td>Eclipse User Directories</td>
<td>7-2</td>
</tr>
<tr>
<td>Oracle Java ME SDK Directories</td>
<td>7-2</td>
</tr>
<tr>
<td>8 Profiling Applications</td>
<td></td>
</tr>
<tr>
<td>Collecting and Saving Profiler Data in the IDE</td>
<td>8-1</td>
</tr>
<tr>
<td>Loading a .prf File</td>
<td>8-1</td>
</tr>
<tr>
<td>9 Network Monitoring</td>
<td></td>
</tr>
<tr>
<td>Monitor Network Traffic</td>
<td>9-1</td>
</tr>
<tr>
<td>Filter or Sort Messages</td>
<td>9-1</td>
</tr>
<tr>
<td>Save and Load Network Monitor Information</td>
<td>9-2</td>
</tr>
<tr>
<td>10 Monitoring Memory</td>
<td></td>
</tr>
<tr>
<td>Enabling Tracing</td>
<td>10-1</td>
</tr>
<tr>
<td>Using the Memory Monitor</td>
<td>10-2</td>
</tr>
<tr>
<td>Saving and Viewing a Session Snapshot</td>
<td>10-4</td>
</tr>
<tr>
<td>11 Security and MIDlet Signing</td>
<td></td>
</tr>
<tr>
<td>Security Domains</td>
<td>11-1</td>
</tr>
<tr>
<td>Setting Security Domains</td>
<td>11-2</td>
</tr>
<tr>
<td>Specify the Security Domain for an Emulator</td>
<td>11-2</td>
</tr>
<tr>
<td>Specify the Security Domain for a Project</td>
<td>11-2</td>
</tr>
<tr>
<td>Signing a Project With a Key Pair</td>
<td>11-2</td>
</tr>
<tr>
<td>Managing Keystores and Key Pairs</td>
<td>11-3</td>
</tr>
<tr>
<td>Command Line Samples</td>
<td>11-3</td>
</tr>
<tr>
<td>12 Command Line Reference</td>
<td></td>
</tr>
<tr>
<td>Run the Device Manager</td>
<td>12-1</td>
</tr>
<tr>
<td>Manage Device Addresses (device-address)</td>
<td>12-1</td>
</tr>
<tr>
<td>Emulator Command Line Options</td>
<td>12-2</td>
</tr>
<tr>
<td>MIDlet Options</td>
<td>12-2</td>
</tr>
<tr>
<td>Debugging and Tracing Options</td>
<td>12-3</td>
</tr>
<tr>
<td>Command Line Profiling</td>
<td>12-4</td>
</tr>
<tr>
<td>Build a Project from the Command Line</td>
<td>12-4</td>
</tr>
</tbody>
</table>
Check Prerequisites ............................................................................................................ 12-5
Compile Class Files ............................................................................................................ 12-5
Preverify Class Files ........................................................................................................ 12-5
Packaging a MIDlet Suite (JAR and JAD) ........................................................................ 12-6
Command Line Security Features ..................................................................................... 12-6
  Change the Default Protection Domain ........................................................................ 12-7
  Sign MIDlet Suites (jadtool) ......................................................................................... 12-7
  Manage Certificates (MEKeyTool) ................................................................................. 12-8
  Generate Stubs (wscompile) ......................................................................................... 12-8

13 Logs
  Device Manager Logs ..................................................................................................... 13-1
  Device Instance Logs .................................................................................................... 13-1

14 API Support
  JCP APIs .................................................................................................................... 14-1
  Oracle APIs .................................................................................................................. 14-2

15 JSR 75: PDA Optional Packages
  FileConnection API ..................................................................................................... 15-1
  PIM API ....................................................................................................................... 15-2
  Running PDAPDemo ..................................................................................................... 15-2
    Browsing Files ......................................................................................................... 15-2
    The PIM API ............................................................................................................. 15-2

16 JSR 82: Bluetooth and OBEX Support
  Setting OBEX and Bluetooth Properties ..................................................................... 16-1
  Running the Bluetooth Demo ....................................................................................... 16-2
  Running the OBEX Demo ............................................................................................. 16-3

17 JSR 135: Mobile Media API Support
  Media Types ............................................................................................................... 17-1
  Media Capture .............................................................................................................. 17-2
  MMAPI MIDlet Behavior ............................................................................................. 17-2
  Ring Tones .................................................................................................................... 17-2
    Download Ring Tones ............................................................................................... 17-2
    Ring Tone Formats .................................................................................................... 17-2
  Running AudioDemo .................................................................................................... 17-4
  Running MMAPIDemos ............................................................................................... 17-4
    Simple Tones ............................................................................................................. 17-4
    Simple Player ............................................................................................................ 17-4
    Video ......................................................................................................................... 17-6
    Pausing Audio Test ................................................................................................. 17-6
18   JSR 177: Smart Card Security (SATSA)
Card Slots in the Emulator ................................................................. 18-1
Adjusting Access Control ................................................................ 18-2
   Specifying PIN Properties ......................................................... 18-2
   Specifying Application Permissions ......................................... 18-2
   Access Control File Example .................................................... 18-4
   Running the SATSA Demo .......................................................... 18-6

19   JSR 179: Location API Support
Setting the Emulator's Location at Runtime ................................... 19-1
Running the CityGuide Sample Project ........................................... 19-3

20   JSR 205: Wireless Messaging
Using the WMA Console to Send and Receive Messages ............... 20-1
   Launching the WMA Console ...................................................... 20-1
   WMA Console Interface ............................................................ 20-1
   Emulator Phone Numbers ......................................................... 20-2
   Sending a Text or Binary SMS Message .................................... 20-2
   Sending Text or Binary CBS Messages ..................................... 20-3
   Sending MMS Messages ........................................................... 20-3
   Receiving Messages in the WMA Console ................................. 20-3
Running WMADemo ........................................................................ 20-3
   WMADemo Push Registry Values .............................................. 20-4
   Sending SMS Messages From WMA Console to an Emulator and Back ........................................ 20-4
   Sending MMS Messages from WMA Console to an Emulator ................................................. 20-4
Running WMA Tool ........................................................................ 20-5
   smsreceive, cbsreceive, and mmsreceive ................................ 20-5
   smssend .................................................................................... 20-5
   cbssend .................................................................................... 20-6
   mmssend .................................................................................... 20-6

21   JSR 184: Mobile 3D Graphics
Choosing a Graphics Mode ............................................................ 21-1
   Immediate Mode ....................................................................... 21-1
   Retained Mode ......................................................................... 21-1
Quality Versus Speed ..................................................................... 21-2
Content for Mobile 3D Graphics .................................................... 21-2
Running Demo3D Samples ............................................................. 21-2
   Life3D ...................................................................................... 21-2
   RetainedMode ......................................................................... 21-3
   PogoRoo ................................................................................... 21-3

22   JSR 211: Content Handler API (CHAPI)
Using Content Handlers .................................................................. 22-1
Running the CHAPIDemo Content Browser ................................. 22-1
23 JSR 226: Scalable 2D Vector Graphics

Running SVGDemo.................................................................................................................. 23-1
  SVG Browser ......................................................................................................................... 23-1
  Render SVG Image ................................................................................................................. 23-2
  Play SVG Animation ............................................................................................................ 23-2
  Create SVG Image from Scratch ......................................................................................... 23-2
  Bouncing Balls ..................................................................................................................... 23-2
  Optimized Menu .................................................................................................................... 23-3
  Picture Decorator ................................................................................................................ 23-3
  Location Based Service ....................................................................................................... 23-4
Running SVGContactList...................................................................................................... 23-5

24 JSR 239: Java Bindings for Open GL ES

Open GL Overview.................................................................................................................. 24-1

25 JSR 256: Mobile Sensor API Support

Creating a Mobile Sensor Project........................................................................................... 25-1
Using a Mobile Sensor Project............................................................................................... 25-2
Creating a Sensor Script File................................................................................................. 25-3
SensorBrowser ..................................................................................................................... 25-3
Marbles.................................................................................................................................. 25-4

26 JSR 257: Contactless Communication API

Using ContactlessDemo ......................................................................................................... 26-1
Tag File Formats.................................................................................................................... 26-2
Script Format........................................................................................................................ 26-3

A Installation and Runtime Security Guidelines

Maintaining Optimum Network Security............................................................................. A-1
**List of Figures**

1–1  The Eclipse Workspace Launcher............................................................................................ 1-3
1–2  The Eclipse Start Screen ............................................................................................................ 1-3
1–3  The Eclipse Workbench Start Screen..................................................................................... 1-4
2–1  The Eclipse Available Software Screen.................................................................................. 2-2
2–2  Selecting Eclipse Plugins......................................................................................................... 2-3
2–3  The Add Repository Window with Eclipse Plugins............................................................... 2-3
2–4  Selecting Oracle Java ME SDK Plugins................................................................................ 2-4
2–5  Eclipse Plugins Installation Details......................................................................................... 2-4
2–6  The Eclipse Welcome Screen.................................................................................................... 2-5
2–7  Selecting Java ME for Configuration....................................................................................... 2-6
2–8  The Device Management Screen............................................................................................. 2-7
2–9  Manual Device Installation....................................................................................................... 2-8
4–1  Running a Project on the Device Selector............................................................................. 4-2
4–2  The Home Button.................................................................................................................... 4-14
4–3  Pulse Counter Output ............................................................................................................. 4-19
5–1  Edit Application Descriptor MicroEdition-Profile Setting................................................... 5-2
6–1  The Device Manager Icon ........................................................................................................ 6-1
6–2  The Device Manager Menu..................................................................................................... 6-2
6–3  The Device Address Manager.................................................................................................. 6-2
6–4  The Registered Devices Screen............................................................................................... 6-3
6–5  Adding a COM Port................................................................................................................. 6-4
6–6  The IMP-NG Emulator............................................................................................................ 6-5
6–7  The Qualcomm_IoE_Device Emulator.................................................................................... 6-9
6–8  The External Events Generator SPI Tab................................................................................ 6-10
6–9  The External Events Generator I2C Tab with Available Sensors....................................... 6-11
6–10 Emulator Features................................................................................................................ 6-13
6–11 The Output Console Window................................................................................................ 6-14
6–12 The Custom Device Editor...................................................................................................... 6-21
10–1 The Memory Monitor Screen................................................................................................. 10-3
19–1 The External Events Generator Location Tab..................................................................... 19-2
19–2 The Location Settings Dialog Box......................................................................................... 19-3
19–3 The City Guide Landmark Detail Screen............................................................................... 19-4
20–1 The WMA Console and Output Windows............................................................................. 20-2
23–1 Adding a Graphic .................................................................................................................. 23-4
23–2 Highlighting a Graphic .......................................................................................................... 23-4
23–3 A Location-Based Service Screen......................................................................................... 23-5
25–1 The Acceleration Sensor Screen............................................................................................ 25-4
**List of Tables**

<table>
<thead>
<tr>
<th>Table No.</th>
<th>Title</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>4–1</td>
<td>MIDP/CLDC Sample Projects</td>
<td>4-4</td>
</tr>
<tr>
<td>4–2</td>
<td>IMP-NG Sample Projects</td>
<td>4-5</td>
</tr>
<tr>
<td>6–1</td>
<td>Emulator Application Menu</td>
<td>6-16</td>
</tr>
<tr>
<td>6–2</td>
<td>Emulator Edit Menu</td>
<td>6-17</td>
</tr>
<tr>
<td>6–3</td>
<td>Emulator Tools Menu</td>
<td>6-18</td>
</tr>
<tr>
<td>6–4</td>
<td>Emulator View Menu</td>
<td>6-18</td>
</tr>
<tr>
<td>7–1</td>
<td>Device Names</td>
<td>7-3</td>
</tr>
<tr>
<td>12–1</td>
<td>Device Address Commands</td>
<td>12-1</td>
</tr>
<tr>
<td>12–2</td>
<td>Emulator Commands</td>
<td>12-2</td>
</tr>
<tr>
<td>12–3</td>
<td>Options to preverify Command</td>
<td>12-5</td>
</tr>
<tr>
<td>12–4</td>
<td>wscompile Options</td>
<td>12-9</td>
</tr>
<tr>
<td>12–5</td>
<td>Command Supported Features (-f) for wscompile</td>
<td>12-9</td>
</tr>
<tr>
<td>14–1</td>
<td>Supported JCP APIs</td>
<td>14-1</td>
</tr>
<tr>
<td>21–1</td>
<td>Controls for Life3D</td>
<td>21-3</td>
</tr>
</tbody>
</table>
List of Examples

13–1 Setting a Category Value ........................................................................................................ 13-1
18–1 PIN Properties Example ......................................................................................................... 18-2
18–2 Access Control File Record Format .................................................................................... 18-2
18–3 Access Control File Example ................................................................................................ 18-4
19–1 Location Script Example ...................................................................................................... 19-1
23–1 SVG File Example .................................................................................................................... 23-2
25–1 Sensor Script File Format Example ..................................................................................... 25-3
26–1 Tag File Format Example ...................................................................................................... 26-2
26–2 Tag Script File Format Example .......................................................................................... 26-3
26–3 Tag Script Sample .................................................................................................................. 26-3
Preface

The Oracle® Java ME SDK is mobile application development tool available as a plugin to the Eclipse IDE.

The Oracle Java ME SDK provides supporting tools and sample implementations for the latest in Java ME technology. It supports recent versions of the Connected Limited Device Configuration (CLDC), Information Module Profile - Next Generation (IMP-NG), and Qualcomm Orion IoE (Internet of Everything) platforms.

Audience

This document is intended for Java ME application developers.

Documentation Accessibility

For information about Oracle's commitment to accessibility, visit the Oracle Accessibility Program website at http://www.oracle.com/pls/topic/lookup?ctx=acc&id=docacc.

Access to Oracle Support

Oracle customers have access to electronic support through My Oracle Support. For information, visit http://www.oracle.com/pls/topic/lookup?ctx=acc&id=info or visit http://www.oracle.com/pls/topic/lookup?ctx=acc&id=trs if you are hearing impaired.

Conventions

The following text conventions are used in this document:

<table>
<thead>
<tr>
<th>Convention</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>boldface</strong></td>
<td>Boldface type indicates graphical user interface elements associated with an action, or terms defined in text or the glossary.</td>
</tr>
<tr>
<td><em>italic</em></td>
<td>Italic type indicates book titles, emphasis, or placeholder variables for which you supply particular values.</td>
</tr>
<tr>
<td>monospace</td>
<td>Monospace type indicates commands within a paragraph, URLs, code in examples, text that appears on the screen, or text that you enter.</td>
</tr>
</tbody>
</table>
Related Documents

For more information, see the following documents:

■ To see documentation for the Oracle Java Wireless Client and CLDC Hotspot go to http://download.oracle.com/javame/mobile.html and look under Documentation for Device Makers.

■ For legacy SDK documentation, see: http://download.oracle.com/javame/developer.html

Legacy Sun Java Wireless Toolkit documentation is also available from this site.
Before You Begin

The Oracle® Java Micro Edition (Java ME) Software Development Kit (SDK) is a natural starting point for learning and using Java ME technology. The focus of the SDK is to provide emulation and deployment assistance during the development process. This chapter introduces the SDK and provides a quick introduction to using the SDK.

Using this simple yet powerful tool you can create, edit, compile, package, and sign an application. After testing your application in the Oracle Java ME SDK emulation environment, you can move to deploying and debugging on an external device.

This chapter provides information you need to ensure that your Microsoft Windows XP (32-bit) or Windows 7 (32-bit or 64-bit) platform is correctly set up for working with Oracle Java ME SDK. Both Windows XP and Windows 7 must include the most recent Microsoft service packs.

Installing the Java SE Platform

To properly run the Oracle Java ME SDK software and its associated Tools, you must have Java Platform, Standard Edition (Java SE), Version 7, Update 11 (or later) installed on your computer.

This guide assumes you have already installed the Java SE platform. If you have not installed Java SE, you can download it from the following location:
http://www.oracle.com/technetwork/java/javase/downloads

The Java SE platform must also be in your PATH.

Setting and Verifying Your Java SE PATH

To verify if Java SE platform is set in your PATH:

1. In the Windows command line, type:
   C:\>echo %PATH%

2. If Java SE is properly installed, you see a path to the default installation directory:
   C:\>Program Files\Java\jdk1.7.0_x

3. If not, you need to add Java SE to your PATH.

   Note: Setting the PATH may require using a Windows short name. To see top-level Windows short names, type C:\>dir /x

4. Set the Java SE variable, JDK_DIR:
Installing the Oracle Java ME SDK Platform

Follow these steps to install the Oracle Java ME SDK 3.4.

1. If you have previously installed an earlier version of Oracle Java ME SDK, uninstall the previous version as shown below.

   - If you have Oracle Java ME SDK data to save, please copy it to a safe location before continuing.
   - In the Windows system tray, right click on the emulator icon and select Exit.
   - From the Windows Programs menu, select the previous version and select Uninstall from the submenu. The Installer opens.
   - On the first page check the option to remove the user data directory.
   - Follow the prompts.

2. Download the SDK from:

   http://www.oracle.com/technetwork/java/javame/javamobile/download

3. Double-click the executable. When the installer starts, follow the prompts.

Installing and Starting the Eclipse IDE

If you do not already have Eclipse Indigo 3.7 installed on your system, you can download it here:


You can download Juno 4.2 here:

http://www.eclipse.org/downloads/packages/release/juno/sr1

Once you have downloaded the Eclipse Indigo 3.7 or Juno 4.2 installation module, do the following to install Eclipse on your system:

1. Unzip the distribution file into the C:\Program Files directory.

2. In the C:\Program Files\eclipse directory, click on eclipse.exe to launch Eclipse.

3. When the Select a Workspace dialog box appears, specify a directory location in which to store your Eclipse project files. Click OK.
Installing and Starting the Eclipse IDE

Before You Begin

1-3

Figure 1–1  The Eclipse Workspace Launcher

This opens the Eclipse main screen, as shown in Figure 1–2.

Figure 1–2  The Eclipse Start Screen

4. Click on the icons on the far right (it says "Go to the Workbench"). This displays an empty workbench screen, as shown in Figure 1–3.
Figure 1–3  The Eclipse Workbench Start Screen
Using the Eclipse integrated development environment, you can create and test embedded applications using a graphical development environment.

---

**Note:** The examples in this chapter use the Eclipse Indigo 3.7 platform.

---

### Installing the Oracle Java ME SDK Eclipse Plugin

The Oracle Java ME SDK Plugins are the same for both the Indigo 3.7 and Juno 4.2 platforms.

To download the Oracle Java ME SDK Plugins file for Eclipse (oracle-jmesdk-3-3-rr-eclipse-plugins.zip), go to the following location:

http://www.oracle.com/technetwork/java/javame/javamobile/download/sdk

### Installing Plugins on Eclipse Indigo 3.7

1. In Eclipse, go to Help > Install New Software. This displays the Available Software screen, as shown in Figure 2–1.
2. Press the Add button. This displays the Add Repository window.

3. In the Add Repository window, press the Archive button to open a file browser.

4. In the file browser, select the Eclipse plugin file that you downloaded, as shown in Figure 2–2. Click Open to return to the previous dialog.
5. The Add Repository window appears as shown in Figure 2–3. Press OK.

6. The category Java ME SDK Tools appears in the Name area. Check the box in front of Java ME SDK Tools and ME SDK Demos as shown in Figure 2–4. Click Next.
7. The installation details are displayed. Press Next. The items you checked are listed, as shown in Figure 2–5. Press Next again.

8. Accept the terms of the license agreement and click Finish.

9. Check the Java ME SDK Tools Category and its subcategories and press the Next button to start the Add wizard.

10. Accept the terms of the license agreement and click Finish. The installation process starts.
11. When the installation process completes, restart Eclipse. The Eclipse Welcome Screen is displayed, as shown in Figure 2–6.

Figure 2–6 The Eclipse Welcome Screen

Installing Plugins on Eclipse Juno 4.2

On Eclipse Juno 4.2, installing the Oracle Java ME SDK plugins requires the Eclipse Mobile Tools for Java (MTJ) toolkit. The MTJ is not bundled with Juno and must be installed manually, before installing the Eclipse plugins.

To install the Eclipse Mobile Tools for Java toolkit:

1. Go to Help > Install New Software.
2. In the “Work with” field, enter this URL: http://download.eclipse.org/releases/indigo
3. Click Add.
4. When the plugins are discovered, open the Mobile and Device Development Tools hierarchy and check Mobile Tools for Java Examples and Mobile Tools for Java SDK.
5. Uncheck the “Contact all update sites....” checkbox and click Next.
6. On the installation screen select all plugins and click Finish. Then click OK.

A Juno plugin named org.eclipse.jetty.server_<version>.jar conflicts with the MTJ libraries when the plugin version is higher than 6.

If the org.eclipse.jetty.server version is higher than 6 you must prevent it from loading by changing its name so the JAR file is not parsed. Locate the file in the
Configuring Eclipse

To configure Eclipse, follow these steps:

1. Select Window > Open Perspective > Other and select Java ME, as shown in Figure 2–7. Click OK.

   Figure 2–7 Selecting Java ME for Configuration

2. Select Window > Preferences > and expand the Java ME node.

3. Select Device Management. The Device Management page displays a list of devices used by Oracle Java ME SDK projects, as shown in Figure 2–8.

\plugins directory of your Juno installation and change the extension from .jar to something else.

For example, change it to: org.eclipse.jetty.server_<version>.old.

---

**Note:** Once you have installed the MTJ toolkit for Eclipse Juno 4.2, the procedure for installing the Oracle Java ME SDK plugins is the same as for Eclipse Indigo 3.7. See "Installing Plugins on Eclipse Indigo 3.7".

---

**Configuring Eclipse**

To configure Eclipse, follow these steps:

1. Select Window > Open Perspective > Other and select Java ME, as shown in Figure 2–7. Click OK.

   Figure 2–7 Selecting Java ME for Configuration

2. Select Window > Preferences > and expand the Java ME node.

3. Select Device Management. The Device Management page displays a list of devices used by Oracle Java ME SDK projects, as shown in Figure 2–8.
4. Click the Manual Install... button, to the right of the Device Management screen.

5. In the Specify Search Directory field, enter or browse to the location of the Oracle Java ME SDK platform installation. For example:

   C:\Java_ME_platform_SDK_3.4

6. Click OK. When the five default emulators are detected, make sure all the devices are checked, as shown in Figure 2–9, and click Finish.
Verify Your Installation

The outstanding feature of Oracle Java ME SDK is device emulation for the Connected Limited Device Configuration (CLDC). If the plugins are properly installed you see the Device Selector tab on the bottom left. If they are not visible, you can select Window > Show View > Device Selector.

The Oracle Java ME SDK has two components.

- The Oracle Java ME SDK platform software installation includes the supported runtimes, emulation software, device configurations, supporting libraries, documentation (including Javadocs), the command line interface, and other utility executables. The default location of the ME SDK is:
  C:\Java_ME_platform_SDK_3.4

- The ME SDK provides two unique instances for most devices. For example, IMPNGDevice1 and IMPNGDevice2 are the same except for the device number and the phone number, so you can perform tests that require two devices (messaging, for example) without customization.

  For more information, see Chapter 6, "Working With Devices."

Adding Devices Manually

If the Oracle Java ME SDK plugins are installed and you cannot see the Device Selector, you can add the Oracle Java ME SDK devices manually.

1. Select Window > Open Perspective > Other > Java ME and click OK.
2. Go to Window > Preferences > Java ME > Device Management and click on Manual Install.

3. In the Specify Search Directory field, insert the path to the Oracle Java ME SDK platform installation directory, and press Enter. The devices appear on the Devices table. Click on Finish and then click on OK. The Device Selector opens.

Quick Start

The following tips offer some hints for getting started as quickly as possible.

- Access the documentation. The online help is the primary documentation for the Oracle Java ME SDK. Many windows and dialogs feature a help button that opens context-sensitive help in the help viewer. You can also type F1.

  Click the Help menu and select Help Contents to open the Eclipse Online Help viewer. Remember to use the search capability to help you find topics.

  Note: If you require a larger font size, the help topics are also available as a printable PDF and a set of HTML files.

- Run sample projects. Running sample projects is a good way to become familiar with the SDK.

  See "Running a Project" for a general overview of how to run a project.

- See the Package Explorer window and the Navigator window for a visual overview of the logical and physical layout of a project. When viewing items in the tree, use the context menu (right-click) to see the available actions.

- A project has a default device that is used when it is run from the toolbar by clicking the green arrow or going to the Run menu and choosing Run.

- To see a project’s default device, expand the project node and double-click the Application Descriptor subnode. The project’s Overview tab opens in the central editing area. The Runtime table on the bottom right of the Application Descriptor panel lists devices (execution environments) for the current project. The checked device will be used when the project is run. You can easily add, modify, or remove a device.

- To run an application on different devices without changing the default device, right-click a device in the Device Selector pane, then select Run Project and select an open project.

- The emulator is an independent process, and when it has started it is a separate process from the build process running in Eclipse. Stopping the build process or closing a project does not always affect the application running in the emulator. You must be sure to terminate the application (the emulator can remain open). See "Running a Project."
This chapter describes the Oracle Java ME SDK technology platforms, also called stacks. They are: CLDC with MIDP and IMP-NG, as discussed in "Emulation Platforms."

A project runs on a particular emulation platform. The Device Manager determines whether a device is appropriate for your project based on the platform, the APIs your application uses, and a set of device properties. If you run an application and an appropriate emulator or device is currently running, the SDK automatically installs and runs your application in the current device so that you do not have to launch the emulator repeatedly.

**Emulation Platforms**

An emulator simulates the execution of an application on one or more target devices. An emulation platform enables you to understand the user experience for an application and test basic portability. For example, a platform enables you to run applications on several sample devices with different features, such as screen size, keyboard, runtime profile and other characteristics.

Oracle Java ME SDK provides the following emulation platforms:

- Connected Limited Device Configuration (CLDC) with Mobile Information Device Profile (MIDP)
- CLDC with MIDP, Information Module Profile - Next Generation (IMP-NG) subset

All platforms include predefined devices with different screen sizes, runtime profiles, and input methods.

See "CLDC with MIDP," and "IMP-NG."

**CLDC with MIDP**

CLDC/MIDP applications conform to the following specifications:

- Connected Limited Device Configuration 1.1
  

- Mobile Information Device Profile 2.1
  

- All the JSRs listed in "JCP APIs."

CLDC/MIDP applications are targeted for devices that typically have the following capabilities:
Emulation Platforms

- A 16-bit or 32-bit processor with a clock speed of 16MHz or higher
- At least 160 KB of non-volatile memory allocated for the CLDC libraries and virtual machine
- At least 192 KB of total memory available for the Java platform
- Low power consumption, often operating on battery power
- Connectivity to some kind of network, often with a wireless, intermittent connection and limited bandwidth

Typical devices might be cellular phones, pagers, low-end personal organizers, and machine-to-machine equipment. In addition, CLDC can also be deployed in home appliances, TV set-top boxes, and point-of-sale terminals.

The SDK provides two default emulators to support CLDC:
- ClamshellJavaMEPhone1
  - A flip phone with a primary display and a secondary display.
- JavaMEPhone1 and JavaMEPhone2
  - A flat touch screen device.

These devices support CLDC 1.1, MIDP 2.1, and optional packages for JSRs 75, 82, 135, 172, 177, 179, 184, 205, 211, 226, 234, 239, 256, 257, and 280.

See Chapter 4, "Using Sample Projects" and Chapter 6, "Working With Devices."

**IMP-NG**

JSR 228 describes the Information Module Profile - Next Generation, referred to as IMP-NG. This JSR extends and enhances JSR 195: Information Module Profile.

The IMP-NG implementation depends upon CLDC 1.1. It is a strict subset of MIDP 2.1 that excludes MIDP 2.1 graphical display capabilities, resulting in a smaller footprint appropriate for Information Modules (IMs). Potential devices for CLDC with IMP-NG might be modems, home electronics devices, or industrial metering devices.

An IMP-NG application is an IMlet, and multiple IMlets in a single JAR file form an IMlet suite. When creating an IMlet project you follow the same process that you use to create a Java ME Mobile Application project and select an IMP-NG device. The device selection determines the supported JSRs.

The IMP-NG stack supports the following JCP APIs: JSRs 75, 120, 172, 177, 179, 257, and 280. In addition, Oracle provides APIs to support IMP-NG development, as described in "Oracle APIs."

The Oracle Java ME SDK implementation provides IMP-NG emulation, on-device tooling connectivity to external devices, and Attention (AT) Command support. The SDK emulator supports IMP-NG with IMPNGDevice1 and IMPNGDevice2 skins and provides simple interfaces for Inter-Integrated Circuit (I2C), Serial Peripheral Interface (SPI), General Purpose Input/Output (GPIO), and Memory-mapped I/O (MMIO) buses. The emulator’s external event generator provides a way for you to inject calls to emulate AT Commands, alter basic pin and port information for GPIO, and memory block values.

See "Running IMP-NG Sample Projects."
The Oracle Java ME SDK sample projects introduce you to the emulator’s API features and the SDK features, tools, and utilities that support the various APIs. These features can help you customize the sample projects or create applications of your own. For instructions on creating new projects, see "Projects."

---

**Note:** Before using the Oracle Java ME SDK demo applications, see "Installation and Runtime Security Guidelines" in Appendix A. Some demos use network access and open ports, and do not include protections against malicious intrusion. If you choose to run the sample projects, you should ensure your environment is secure.

---

For instructions on running projects, see the following topics:

- "Creating a Sample Project"
- "Running a Project"
- "Troubleshooting"
- "Sample Project Overview"
- "Configuring the Web Browser and Proxy Settings"
- "Running MIDP and CLDC Sample Projects"
- "Running IMP-NG Sample Projects"

---

**Creating a Sample Project**

Sample applications are installed in a separate Eclipse plugin. Do not run or edit these projects directly. You create a new project that is an instance of the sample project.

The default location for Oracle Java ME SDK projects is the default Eclipse project directory. Each project has a `src` directory that contains Java programming language source code. For example, the default location of the source code for the SMS sender MIDlet (`example.sms.SMSSend`) in `WMADemo` resides in the following location:

```
EclipseWorkspace\WMADemo\src\example\sms\SMSSend.java
```

1. Go to `File > New > Project` and in the Categories window.
2. Select `Examples > Java ME SDK 3.4` and click on `Java ME Sample Applications` then Click `Next`.
   In the next screen select one of the samples and click `Finish`. 
Running a Project

3. If prompted, select an emulator platform and a device. Note, changing the device affects the possible device profiles, so you might need to explicitly select a profile. Click OK.

The project is added to the Package Explorer window.

---

**Note:** If you cannot see the Package Explorer window select Window > Show View > Package Explorer. To see console output, select Window > Show View > Console.

---

Running a Project

Create your own project, or instantiate one of the sample projects provided with the SDK as described in "Creating a Sample Project."

1. Use one of these methods to run a project.
   - Select a project and click the Run button in the toolbar.
   - Right-click a project and select Run As > Emulated Java ME JAD from the context menu.
   - To run a project on a different device, or to change the execution mode, select the device in the Device Selector window (Window > Show View > Other > Java ME SDK Tools > Device Selector). Right-click on a device and select Run Project from the context menu. Pull right to see a listing of open projects.

![Figure 4–1 Running a Project on the Device Selector](image)

---

- To run a project on an emulator, drag and drop the project’s JAD or JAR file onto a running emulator. Click OK in the Run MIDlet (or IMlet) Suite dialog box.

The device emulator window opens with the demo application running. If the demo is a MIDlet suite you might have to select a MIDlet to launch.

2. As the sample project runs, soft keys might be enabled below the screen on the left or right side.

You use soft keys to install or launch an application, open a menu, exit, or perform some other action. Some demos include these instructions in the application.
For instructions on running samples, see Table 4–1.

3. When you are finished viewing an application, go to the emulator’s Application menu and select Exit to close the emulator and stop the execution of the project’s build script.

When the emulator is launched, it runs as an independent process. Stopping the application from Eclipse does not close the emulator instance.

Likewise, closing the Eclipse IDE does not affect the emulator instance. In the emulator, click the Application menu and select Exit or press the emulator’s exit button (the X) on the upper right to ensure that both the emulator process and the project build process close.

Periodically, you might want to clear a device’s database especially after you have run several projects. Right-click the device and select Clean RMS storage files. When you run the command, a completion notice is displayed in the IDE’s status bar.

Troubleshooting

Sometimes even a “known good” application, such as a sample project, does not run successfully. The problem is usually your environment.

- Some demonstrations require specific setup and instructions. For example, if a sample uses web services and you are behind a firewall, you must configure the emulator’s proxy server settings or web access fails. See “Configuring the Web Browser and Proxy Settings.”

- If an application must run over the air (OTA), the SDK automatically installs it in the device instance. See “Emulator Command Line Options.”

MIDlet Suites use runMIDlet to perform the installation.

`installDir\runtimes\cldc-hi\bin\runMidlet.exe`

IMlet Suites also use runMIDlet to perform the installation, but from the impng directory:

`installDir\runtimes\impng\bin\runMidlet.exe`

Because these programs are launched remotely, virus checking software can prevent them from running. If this happens, the project compiles, but the emulator never opens. In the console you see warnings that the emulator cannot connect.

Consider configuring your antivirus software to exclude runMidlet from checking.

Sample Project Overview

The Oracle Java ME SDK includes demonstration applications that highlight some technologies and APIs that are supported by the emulator.

Most demonstration applications are simple to run. "Running a Project” contains instructions for running most demonstrations. Sample projects usually have some additional operation instructions.

Table 4–1 lists all the MIDP/CLDC demonstration applications that are included in this release.
<table>
<thead>
<tr>
<th>Sample</th>
<th>Optional Package</th>
<th>Description</th>
<th>Instructions</th>
</tr>
</thead>
<tbody>
<tr>
<td>Advanced Multimedia Supplements</td>
<td>JSR 234</td>
<td>Demonstrates 3D audio, reverberation, image processing, and camera control.</td>
<td>Chapter 17, &quot;JSR 135: Mobile Media API Support&quot;</td>
</tr>
<tr>
<td>AudioDemo</td>
<td>MMAPI 1.1</td>
<td>Demonstrates audio capabilities, including mixing and playing audio with an animation.</td>
<td>Chapter 17, &quot;JSR 135: Mobile Media API Support&quot;</td>
</tr>
<tr>
<td>BluetoothDemo</td>
<td>JSR 82</td>
<td>Demonstrates device discovery and data exchange using Bluetooth.</td>
<td>Chapter 16, &quot;JSR 82: Bluetooth and OBEX Support&quot;</td>
</tr>
<tr>
<td>CHAPIDemo</td>
<td>JSR 211</td>
<td>A content viewer that also uses MediaHandler.</td>
<td>Chapter 22, &quot;JSR 211: Content Handler API (CHAPI)&quot;</td>
</tr>
<tr>
<td>CityGuide</td>
<td>JSR 179</td>
<td>A city map that displays landmarks based on the current location.</td>
<td>Chapter 19, &quot;JSR 179: Location API Support&quot;</td>
</tr>
<tr>
<td>ContactlessDemo</td>
<td>JSR 257</td>
<td>Emulates detection of RFID tags.</td>
<td>Chapter 26, &quot;JSR 257: Contactless Communication API&quot;</td>
</tr>
<tr>
<td>Demos</td>
<td>MIDP 2.1</td>
<td>Includes various examples: animation, color, networking, finance, and others.</td>
<td>&quot;Running MIDP and CLDC Sample Projects&quot;</td>
</tr>
<tr>
<td>FPDemo</td>
<td>CLDC 1.1</td>
<td>Simple floating point calculator.</td>
<td>&quot;Running MIDP and CLDC Sample Projects&quot;</td>
</tr>
<tr>
<td>Games</td>
<td>MIDP 2.1</td>
<td>Includes TilePuzzle, WormGame, and PushPuzzle.</td>
<td>&quot;Running MIDP and CLDC Sample Projects&quot;</td>
</tr>
<tr>
<td>MMAPI Demos</td>
<td>MMAPI</td>
<td>Demonstrates MMAPI features, including tone sequences, MIDI playback, sampled audio playback, and video.</td>
<td>Chapter 17, &quot;JSR 135: Mobile Media API Support&quot;</td>
</tr>
<tr>
<td>Multimedia</td>
<td>MMAPI</td>
<td>Demonstrates different video playback formats.</td>
<td>Chapter 17, &quot;JSR 135: Mobile Media API Support&quot;</td>
</tr>
<tr>
<td>NetworkDemo</td>
<td>MIDP 2.1</td>
<td>Demonstrates how to use datagrams and serial connections.</td>
<td>&quot;Running MIDP and CLDC Sample Projects&quot;</td>
</tr>
<tr>
<td>ObexDemo</td>
<td>JSR 82</td>
<td>Demonstrates device discovery and data exchange using Bluetooth.</td>
<td>Chapter 16, &quot;JSR 82: Bluetooth and OBEX Support&quot;</td>
</tr>
<tr>
<td>PDAPDemo</td>
<td>JSR 75</td>
<td>Demonstrates how to manipulate contacts, calendar items, and to-do items. Demonstrates accessing local files.</td>
<td>Chapter 15, &quot;JSR 75: PDA Optional Packages&quot;</td>
</tr>
<tr>
<td>PhotoAlbum</td>
<td>MIDP 2.1</td>
<td>Demonstrates a variety of image formats.</td>
<td>&quot;Running MIDP and CLDC Sample Projects&quot;</td>
</tr>
<tr>
<td>SATSADemo</td>
<td>JSR 177</td>
<td>Demonstrates communication with a smart card and other features of SATSA.</td>
<td>Chapter 18, &quot;JSR 177: Smart Card Security (SATSA)&quot;</td>
</tr>
</tbody>
</table>
Configuring the Web Browser and Proxy Settings

If you are behind a firewall you must configure the proxy server so that MIDP applications using web services can succeed.

The settings are typically the same as those you are using in your web browser. Select **Window > Preferences > General > Network Connections** and change the settings as appropriate.

### Table 4–1  MIDP/CLDC Sample Projects

<table>
<thead>
<tr>
<th>Sample</th>
<th>Optional Package</th>
<th>Description</th>
<th>Instructions</th>
</tr>
</thead>
<tbody>
<tr>
<td>SATSAJCRMIDemo</td>
<td>JSR 177</td>
<td>Shows how to use the SATSA-Java Card Remote Invocation method.</td>
<td>Chapter 18, &quot;JSR 177: Smart Card Security (SATSA)&quot;</td>
</tr>
<tr>
<td>Sensors</td>
<td>JSR 256</td>
<td>The SensorBrowser and Marbles game demonstrate sensor input.</td>
<td>Chapter 25, &quot;JSR 256: Mobile Sensor API Support&quot;</td>
</tr>
<tr>
<td>SVGContactList</td>
<td>JSR 226</td>
<td>Uses SVG to create a contact list displayed with different skins.</td>
<td>Chapter 23, &quot;JSR 226: Scalable 2D Vector Graphics&quot;</td>
</tr>
<tr>
<td>SVGDemo</td>
<td>JSR 226</td>
<td>Uses different SVG rendering techniques.</td>
<td>Chapter 23, &quot;JSR 226: Scalable 2D Vector Graphics&quot;</td>
</tr>
<tr>
<td>UIDemo</td>
<td>MIDP 2.1</td>
<td>Showcases the breadth of MIDP 2.0's user interface capabilities.</td>
<td>&quot;Running MIDP and CLDC Sample Projects&quot;</td>
</tr>
<tr>
<td>WMADemo</td>
<td>WMA 2.0</td>
<td>Shows how to send and receive SMS, CBS, and MMS messages.</td>
<td>Chapter 20, &quot;JSR 205: Wireless Messaging&quot;</td>
</tr>
<tr>
<td>XMLAPIDemo</td>
<td>JSR 280</td>
<td>Uses DOM and STAX APIs to create an XML sample and SAX, DOM and STAX APIs to parse the sample.</td>
<td>Follow the instructions the application provides.</td>
</tr>
</tbody>
</table>

### Table 4–2  IMP-NG Sample Projects

<table>
<thead>
<tr>
<th>Sample</th>
<th>Description</th>
<th>Instructions</th>
</tr>
</thead>
<tbody>
<tr>
<td>GPIODemo</td>
<td>Changes the state of LEDs in an emulator or reference platform.</td>
<td>&quot;Running the GPIODemo&quot;</td>
</tr>
<tr>
<td>I2C Demo</td>
<td>Writes data to a slave and then retrieves it.</td>
<td>&quot;Running the I2C Demo&quot;</td>
</tr>
<tr>
<td>NetworkDemoIMPNG</td>
<td>Allows connection and communication between a server and a client instance.</td>
<td>&quot;Running the NetworkDemoIMPNG&quot;</td>
</tr>
<tr>
<td>PDAPDemoIMPNG</td>
<td>Demonstrates management of a file system in the emulator.</td>
<td>&quot;Running the PDAPDemoIMPNG&quot;</td>
</tr>
<tr>
<td>Pulse Counter (Data Collection) Demo</td>
<td>Sends pulses to a counter and tracks them when they arrive using a timestamp.</td>
<td>&quot;Running the Pulse Counter (Data Collection) Demo&quot;</td>
</tr>
<tr>
<td>LightTrackerDemo</td>
<td>Controls LEDs on a reference platform.</td>
<td>&quot;Running the Light Tracker Demo&quot;</td>
</tr>
<tr>
<td>SystemControllerDemo</td>
<td>Demonstrates IMlet lifecycle on a reference platform.</td>
<td>&quot;Running the System Controller Demo&quot;</td>
</tr>
</tbody>
</table>
Running MIDP and CLDC Sample Projects

This topic gathers MIDP and CLDC samples that are not discussed in separate chapters. This is the case when a sample uses many JSRs, or when a supported JSR does not have any special implementation details.

- "Running the AdvancedMultimediaSupplements Sample Project"
- "Running the Demos Sample Project"
- "Running FPDemo"
- "Running Games"
- "Running Network Demo"
- "Running PhotoAlbum"
- "Running UIDemo"

For other CLDC demos, see Table 4–1.

Running the AdvancedMultimediaSupplements Sample Project

This MIDlet suite demonstrates the power of JSR 234 Advanced Multimedia Supplements (AMMS). It consists of the following MIDlets:

- "Image Effects"
- "Music Effects"
- "Camera"
- "Moving Helicopter"

Image Effects

This MIDlet demonstrates standard image processing operations.

- Launch the Image Effects MIDlet.
- Select input and output image formats, and press Done. The input image and output images are displayed simultaneously.
- Select an effect from the Menu and click the Done button to apply a transformation, effect or overlay. The source image is shown above and the processed image is shown below. Some items, Set Transforms, for example, can perform several operations in a single transaction.

The menu options are as follows:

- Reset - Set transforms, effects, and overlays to the initial state.
- Monochrome Effects - Activate grayscale rendering.
- Negative Effect - Reverse dark and light areas.
- Set Formats - Select an input object type and an output image format.
- Set Effect Order - Specify the order in which transforms, effects and overlays are applied.
- Set Transforms - Change width and height scale, border, and rotation options.
- Set Overlays - Specify the color and orientation of a color block overlay.
Music Effects
Demotstrates the advanced audio capabilities of the Advanced Multimedia Supplements. As an audio file loops continuously, you can adjust the volume, and reverberation settings.

Camera
This MIDlet demonstrates how the Advanced Multimedia Supplements provide control of a device’s camera. The screen shows the viewfinder of the camera (simulated with a movie). You can use commands in the menu to change the camera settings and take and manage snapshots.

■ Zoom settings - digital and optical zoom settings 100-300 in increments of 20. Make a selection and press Back.
■ View gallery - View a list of the snapshots stored in: 
  username\javame-sdk\3.4\work\devicename\appdb\filesystem\root1. Select Display to see the snapshot. You have the option to delete the file from disk. If \root1 is empty use the Snapshot option to save images for the gallery.
■ Set flash mode - Off, AUTO, AUTO_WITH_REDEYEREDUCE, FORCE, FORCE_WITH_REDEYEREDUCE, FILLIN.
■ Change F_Stop number - 0, 400, 560, 800, 1600.
■ Select exposure modes - Preset modes are auto, landscape, snow, beach, sunset, night, fireworks, portrait, backlight, spotlight, sports, text.
■ Disable/Enable shutter feedback.
■ Exit - Close this MIDlet and return to the initial window.
■ Snapshot setting - Set whether to display the snapshot on the screen or print it to a file. Snapshots are stored in:
  username\javame-sdk\3.4\work\devicename\appdb\filesystem\root1

Moving Helicopter
Simulates a helicopter (red dot) flying around a stationary observer (blue dot). Use headphones for best results. You can control the parameters of the simulation with the soft menu options: Volume, Location settings, Spectator orientation, and Distance Attenuation settings. After viewing menu options, press the close button (the X on the right) to return to the helicopter scenario.

With the Location settings be aware that supplying large values for the screen width or flight altitude means the helicopter might be out of range - that is, it flies off the screen and you might not be able to hear it.

For spectator orientation stereo headphones or speakers help detect the difference in position, assuming your volume and location settings put the helicopter in audible range. The same is true for the Distance Attenuation settings, which enable you to control the doppler effect.

Running the Demos Sample Project
This demo contains several MIDlets that highlight different MIDP features. Click or use the navigation keys to highlight a MIDlet, then select the Launch soft key.

■ “Colors”
■ “Properties”
- "Http"
- "FontTestlet"
- "Stock"
- "Tickets"
- "ManyBalls"
- "MiniColor"
- "Chooser"
- "HttpExample"
- "HttpView"
- "PushExample"

**Colors**

This application displays a large horizontal rectangle that runs the width of the screen. Below, ten small vertical rectangles span the screen. Finally, three horizontal color bars indicate values for blue, green, and red (RGB). Values are expressed as decimal (0-255) or hexadecimal (00-ff) based on the first menu selection.

- To select a vertical bar to change, use the up navigation arrow to move to the color bars. Use the right navigation arrow to highlight a color bar. The large rectangle becomes the color of the selected bar.
- Use the up or down selection arrows to select the value to change (red, green, or blue). Use the left or right arrow keys to increase or decrease the selected value. The second menu item enables you to jump in increments of 4 (Fine) or 32 (coarse).
- You can change the color on any or all of the vertical bars.

**Properties**

This MIDlet displays your system property values. The output is similar to the following values:

```
Free Memory = 2333444
Total Memory = 4194304
microedition.configuration = 'CLDC-1.1'
microedition.profiles = 'MIDP-2.1'
microedition.platform = 'generic'
microedition.locale = 'en-US'
microedition.encoding = 'IS08859_1'
```

**Http**

This test application uses an HTTP connection to request a web page. The request is issued with HTTP protocol GET or POST methods. If the HEAD method is used, the head properties are read from the request.

**Preparing to Run the Demo**

Before beginning, examine your settings as follows.

- Select Demos.
  - Click the Run menu and select Run Configurations.
- Click the Emulation tab.
- Select Maximum in the Security Domain field.
- Click Apply.

- If you are using a proxy server, you must configure the emulator’s proxy server settings as described in "Configuring the Web Browser and Proxy Settings." The HTTP version must be 1.1.

- If you are running antivirus software it might be necessary to create a rule that allows your MIDlet to permit connections to and from a specific website. See "Troubleshooting."

### Running the Demo

Launch the Http MIDlet. To test, select the Menu soft key and select Get, Post, or Head to test the selected URL.

Http Test returns the information it obtains. If the information fills the screen use the down arrow to scroll to the end. The amount of information depends on the type of request and on the amount of META information the page provides. To provide body information or content, the page must declare CONTENT-LENGTH as described in RFC 2616.

### Using Menu Options

Use the Menu soft key to select an action. The Menu items vary depending on the screen you are viewing.

- Select Qwerty to set the input type. This activates a submenu with the options Qwerty, 123, Abc, Virtual, and Symbols. This choice is present if you have the option to edit a URL (select Choose, then click the Add soft button).

- Select GET or press the Get soft key to retrieve data from the selected URI.

- Select POST to retrieve the post information from the server handling the selected page.

- Select HEAD to retrieve only the META information from the headers for the selected URI.

- Select Choose to bring up the current list of web pages. You can chose a different page or add your own page to the list. To specify a new URL, click the Add soft button. The screen displays http://. Type in the rest of the URL. If necessary select Qwerty on the menu and select a different input method. Be sure to end with a slash (/). For example http://www.internetnews.com/. Press the OK soft button. The Http Test screen shows your new URL and prompts for an action.

### FontTestlet

This MIDlet shows the various fonts available: Proportional, Regular, Regular Italic, Bold Plain, and Bold Italic. Select 1 or 2 from the menu to toggle between the system font (sans serif) and the monospace font.

### Stock

Like the Http demonstration, this sample uses an HTTP connection to obtain information. Use the same preparation steps as "Http."

Run the Demos project and launch the Stock MIDlet.
By default, the screen displays an empty ticker bar at the bottom. The MIDlet home screen shows four applications: Stock Tracker, What If? Alerts, and Settings. You must add stock symbols before you can use the first three applications.

**Add Stock Symbols to the Ticker**

To add a stock symbol to the ticker, use the navigation arrows to select Settings.

Select Add Stock.

The display prompts you to enter a stock symbol. Type `ORCL` and select the Done soft key. The stock you added and its current value is now displayed in the ticker. Add a few more stock symbols, such as IBM and HPQ.

**Change the Update Interval**

By default the update interval is 15 minutes. Select Settings > Updates to change the interval. Use the navigation arrows to select one of Continuous, 15 minutes, 30 minutes, one hour, or three hours. Select the Done soft key.

**Remove a Stock**

Select Remove a Stock. You see a list of the stocks you have added. Use the navigation keys to select one or more stocks to remove. Select the Done soft key.

**Stock Tracker**

Stock Tracker displays a list of the stocks you added and their current values. Click a stock to display additional information. For example, the last trade and the high and low values.

**What If?**

What If? is an application that asks for the original purchase price and the number of shares you own. It calculates your profit or loss based on the current price.

Select a stock symbol.

Enter the purchase price and the number of shares, then press Calc.

**Alerts**

This application sends you a notification when the price changes to a value you specify.

From the Stock Menu application home screen, select Alerts.

Select Add.

Select a Stock. The screen prompts, "Alert me when a stock reaches". Enter an integer.

When an alert is created it is placed on the Current Alerts list. To remove an alert, press Remove and select the alert. Select the Done soft key.

When the value is reached you hear a ring and receive a message. For example, Symbol has reached your price point of $value and is currently trading at $current_value. When the alert is triggered it disappears from the Current Alerts list.

**Tickets**

This demonstrates how an online ticket auction application might behave. Click Done to continue to the Welcome To Tickets page. The Choose a Band field displays BootWare & Friends by default, and an auction ticker runs at the bottom of the screen.

Select a band from the dropdown menu. The available auction appears.
Select **Make a Bid** from the menu. Use the arrow keys to move from field to field. Fill out each field, then select the **Next** soft key. The application asks you to confirm your bid. Press the Submit button or use the arrow keys to highlight Submit then press the **Submit** soft key. You receive a Confirmation number. Click **Bands** to return to the Bands page.

Select **Set an Alert** from the soft Menu. In the bid field type in a value higher than the current bid and continue bidding as before. You can trigger the alert by making a bid that exceeds your alert value. Your settings determine how often the application checks for changes, so the alert may not sound for a few minutes.

To add a band to the Choose a Band dropdown list, click the **Menu** soft key and select **Add Bands**. Type in a band name or a comma-delimited list of names and select **Save** from the soft menu. After a confirmation message, select **Done** and you are returned to the Welcome To Tickets page. The added band(s) are displayed at the end of the Choose a Band drop-down menu. If you do not see your bands, use the down arrow key to move to the bottom of the list.

Note, this is only a demonstration. To fully describe the band you must edit the following file:

```
src\example\auction\NewTicketAuction.java.
```

To remove a band, click the **Menu** soft key and select **Remove Bands**. Check a box for one or more bands. Click the **Save** soft key.

To display the current settings for ticker display, updates, alert volume, and date, select the **Menu** soft key and select **Show More Info**. If desired, use the arrow keys and the select key to change these values. Select the **Save** soft key.

**ManyBalls**

This MIDlet starts with one ball traveling the screen. Use the up and down arrows to accelerate or decelerate the ball speed (fps). Use the right or left arrows to increase or decrease the number of balls.

**MiniColor**

This MIDlet sets an RGB value. Use navigation keys to change color values.

Keyboard controls work as you would expect. First cursor up or down to highlight a color, and then use left and right keys to lower and raise the value of the selected color.

**Chooser**

The Chooser application uses a variety of controls to change text color, background color, and fonts.

- Click the **Menu** soft key and select **Text Color**. Change the color as described in the "MiniColor" and select the **OK** soft button.
- Click the **Menu** soft key **Background Color**. Change the color as described in the "MiniColor" and select the **OK** soft button.
- Click the **Menu** soft key and select **Fonts**. Change the font face, style, and size using the navigation and selection buttons to move through the font options.

Cursor up and down to highlight a property item by item. The left and right keys jump between lists. Click Select to choose the highlighted option. The chosen option’s circle or square is filled with white.

Click **OK** to display a sample formatted with your settings.
Click **Exit** to return to the home screen.

**HttpExample**
This sample makes an HTTP communication. A popup confirms the transaction was successful.

**HttpView**
This application displays three predefined URLs.
Select a URL, and press the soft buttons to cycle through Head, Headers, Requests, and Errors.
Alternatively, use the menu options.

**PushExample**
This application simulates a feed. As soon as you connect, you receive and display a graphic. Select **Done** to continue.

**Running FPDemo**
FPDemo is a simple floating point calculator.
1. Enter a number in the first field.
2. To select an operator, highlight the drop-down list and click to select. Cursor down to highlight an operator, then click to make a selection.
3. Enter a second value.
4. From the **Menu**, select **Calc** to calculate the result.

**Running Games**
This application features three games: TilePuzzle, WormGame, and PushPuzzle.

**TilePuzzle**. The desired result, "Rate your mind pal" is shown first. From the soft Menu, select Start. The scrambled puzzle is displayed. The arrow keys move the empty space, displacing tiles accordingly. To change the arrow behavior, select Options from the soft menu, and select reverse arrows, then click OK. From the menu you can Reset, or change options.

**WormGame**. From the soft Menu, select 1, Launch. Use the arrow keys to move the worm to the green box without touching the edge of the window. When the game is launched, use the soft menu to change game options.

**PushPuzzle**. Use the blue ball to push the orange boxes into the red squares in the fewest number of moves.

**Running Network Demo**
This demo has two MIDlets: Socket Demo and Datagram Demo. Each demo requires you to run two emulator instances so that you can emulate the server and client relationship. For example, run the demo on JavaMEPhone1 and JavaMEPhone2.

**Socket Demo**
In this application one emulator acts as the socket server, and the other as the socket client.
1. In the first emulator, launch the application, then select the Server peer. Select Start. The Socket Server displays a status message that it is waiting on port 5000.

2. In the second emulator, launch the application, select the Client peer, then select Start. Select Start to launch the client. The Socket Client displays a status message that indicates it is connected to the server on port 5000. Use the down navigation arrow to highlight the Send box. Type a message in the Send box, then select the Send soft key.

   For example, in the client, type Hello Server in the Send box. Select Send from the menu. The server emulator activates a blue light when the message is received.

3. On the emulator running the Socket Server, the status reads: Message received - Hello Server. You can use the down arrow to move to the Send box and type a reply. For example, Hello Client, I heard you. From the menu, select Send.

4. Back in the Socket Client, the status is: Message received - Hello Client, I heard you. Until you send a new message, the Send box contains the previous message you sent.

**Datagram Demo**

This demo is similar to Socket Demo. Run two instances of the emulator. One acts as the datagram server, and the other as the datagram client.

1. In the first emulator, launch Datagram Demo, then select the Server peer. Select Start. Initially, the Datagram Server status is Waiting for connection on port 5555, and the Send box is empty.

2. In the second emulator, launch Datagram Demo, select the Client peer, ensure the port number is 5555 and select Start. The Datagram Client status is: Connected to server on port 5555. Use the down navigation arrow to highlight the Send box. Type a message in the Send box, then select the Send from the menu. For example, type Hello datagram server. From the menu, select Send.

3. On the emulator running the Datagram Server, the status displays: Message received - Hello datagram server. You can use the down arrow to move to the Send box and type a reply to the client.

4. In the Datagram Client, the status field displays the message received from the server. The Send box contains the last message you sent. Overwrite it to send another message.

**Running PhotoAlbum**

The PhotoAlbum demo displays both static and animated images. When you are displaying an image, you can use the Options soft menu to change the borders. If the image is animated, you can change the speed of the playback.

**Running UIDemo**

UIDemo showcases a variety of MIDP user interface element implementations. Most elements have some interactive capability (navigate and select) and some allow keypad or keyboard input.

Input interaction is similar across demos. You can select items from lists or type in data.

This demo implements three list selection methods:

- Exclusive (radio buttons)
Multiple (check boxes)
Pop-Up (a drop list).

When entering data, you can use the soft menu to apply one of the following input types to text boxes and fields (note, some elements do not use all input types). When a field is selected, the soft Menu label displays Qwerty. Open the menu and you see the input types numbered 1 through 5.

1. **Qwerty**. Any character on the keyboard
2. **123**. Any numeral
3. **ABC**. Any letter
4. **Predict**. Predicts next character based on prior input
5. **Symbols**. Opens a list of symbols; click to make a selection.
6. **Virtual**. Click keys on a virtual keyboard to enter data.

The Qwerty, 123, and ABC categories act as filters. For example, if you assign 123 to a field and you type "abc", nothing is entered in the field.

When you finish a demo, select the home button to return to the UIDemo launch page:

![The Home Button](image)

**CustomItem**. This demo features text fields, and text fields in table form. To type in the table, select a cell, then click to open a text entry panel and type your input. From the menu, select OK.

**StringItem**. Displays labels, a hyperlink, and a button. The soft menu action varies depending on the selected element.

**Gauge**. Interactive, non-interactive, indefinite and incremental gauges.

**Alert**. Uses pop-ups to display alerts. Set the alarm type and the length of the timeout from drop lists. Select the alert type and select the Show soft button.

**ChoiceGroup**. Radio buttons, check boxes, and pop-ups on one screen.

**List**. Select exclusive, implicit, or multiple to display the list type on a subsequent screen.

**TextBox**. Use text fields, radio buttons, check boxes, and pop-ups. Select a text box type and press the Show button.

**TextField**. Text fields with the six input types.

**DateField**. Set date and time using drop lists.

**Ticker**. A scrolling ticker.

---

**Running IMP-NG Sample Projects**

This section describes how to use demos created specifically for the IMP-NG platform (see "IMP-NG"). Because IMP-NG is headless the only user interface is to observe application status in the emulator’s external events generator, or in the Output window (or the console if you execute the demo from the command line).
With the exception of I2CDemo, the sample projects in this section can be run on the emulator or on an external device.

See the Oracle® Java ME Embedded Getting Started Guide for the Windows Platform. These documents are available on the Java ME documentation site at:

http://docs.oracle.com/javame/embedded/embedded.html

Expand the Oracle Java ME Embedded Version node and then the Getting Started and Release Notes node.

Running the GPIODemo

This demo can be run on an emulator or an external device. The implementations are different, as the emulator uses the external events generator, and the external device supports direct interaction.

Running the GPIODemo on the Emulator

1. Run GPIO demo on an IMP-NG emulator.
2. Click the GPIO Pins tab. This view approximates the device actions.
3. Click the Tools menu and select External Events Generator to open the external events generator, and click the GPIO tab. A single click on a button turns on LEDs indicating the button pushed and the pin affected. This information is also written to the Output window.
   
   Beneath each pin you can click the blue wave button to open the wave generator. The wave generator simulates the frequency and duration of the signal to the LED.
4. Pressing pin BUTTON 2 in the external events generator changes the state of the pin named LED 5. The button value “Low” corresponds to the LED value “High” and vice versa.
5. Pressing pin BUTTON 3 changes the state of the port named "LEDS." Consequently pins bound to this port (LED 1, LED 2, LED 3, LED 4) in the following way:
   - If the BUTTON 3 state is "High" the port value is set to 0 and all bound pins are set to "Low."
   - If the BUTTON 3 state "is Low" and the BUTTON 2 state is "Low," the port value is set to 2 and the pins are set to the following state:
     LED 1 - Low, LED 2 - High, LED 3 - Low, LED 4 - Low
   - If the BUTTON 3 state "Low" and the "BUTTON 2" state is "High," the port value is set to 3 and the pins are set to the following states:
     LED 1 - High, LED 2 - High, LED 3 - Low, LED 4 - Low

Running the GPIODemo on the Reference Board

The buttons are wired by GPIO. Assuming that you are looking at the board and the Reset button is on the bottom left:

- Reading from left to right, the LEDs are labeled: PH.3, PH.6, PH.7, PL.10, PG.6, PG.6, PG.8, and PH.2
- The buttons, from left to right, are Reset, Wakeup, Tamper, and User.
  The Wakeup button corresponds to PH.3 (Listener 1 Pin 5)
  The Tamper button corresponds to PG.6 (Listener 2 Pin 6).
The User button corresponds to PH.3 and PI.10 (Listener 3 Pin 7)

- Pressing Tamper turns on the light (PG.6), and releasing turns off the light
- Pressing the User button when the Tamper button is released turns on lights on for LEDs PH.3 and PH.6.
- Pressing the User button when the Tamper button is pressed (and as a result the light on LED PG.6 is on) turns on light on LED PH.3 only.
- Releasing the User button turns the lights off on LEDs PH.3 and PH.6.

Running the I2CDemo

This demo is designed to work with the IMP-NG runtime for Windows 32. It has no user interaction.

- Launch the I2C demo.
- In the emulator, click the I2C tab.

  The demo acquires a slave named I2C_Echo, writes data to the slave, and retrieves it. The demo is successful if the Sent Data and Received Data matches.

Running the NetworkDemoIMPNG

This demo is a headless version of "Socket Demo."

You can configure this demo as a server or as a client by editing the application descriptor. You launch two instances of this demo, the first one acts as a server and the second one acts as a client. The client instance attempts to connect to the server instance and if the connection is successful they exchange a message.

Running NetworkDemoIMPNG on the Emulator

1. Create two instance projects of the NetworkDemoIMPNG sample project.
2. Right click the first project and select Properties.
3. In the Platform category select the device IMPNGDevice1. In the Application Description category set the value of the following property:

   Oracle-Demo-Network-Mode:Server

4. Click OK.
5. Launch the first project. It opens on the emulator IMPNGDevice1 and waits for a connection. You should see messages like the following:

6. Right click the second project and select Properties.
7. In the Platform category select the device IMPNGDevice2. In the Application Description category set the value of the following property:

   Oracle-Demo-Network-Mode:Client

8. Click OK.
9. Launch the second project. It opens on the emulator IMPNGDevice2.
10. The client attempts to connect to the server. If successful, you see the following in the output tab of the first project (the server):

    Waiting for connection on port 500
    [AMS-TRACE] MIDlet:NetworkDemoIMPNG status=2
    [AMS-TRACE] MIDlet:NetworkDemoIMPNG status=1
Running NetworkDemoIMPNG on the Reference Board

You can run one of the instance projects on the board and the other in one of the emulators. Follow these steps to run the client on the board and the server in one of the emulators:

1. Right click on the first project (the server) and select Properties. In the Platform category select the device IMPNGDevice1 (the emulator) and click OK. In the Application Description category set the value of the property Oracle-Demo-Network-Mode to Server and click OK.
2. Launch the first project (the server). It runs on the emulator and waits for a connection.
3. Right click on the second project (the client) and select Properties. In the Platform category select the device IMPNGExternalDevice1 (the board). In the Application Description category set the value of the property Oracle-Demo-Network-Mode to Client and click OK.
   In the Application Descriptor category set the value of the property Oracle-Demo-Network-Address to the IP address of the computer where Eclipse is running and click OK.
4. Launch the second project (the client). It runs on the board and attempts to connect to the server. If successful, you see the following in the output tab of the first project (the server):
   Connection accepted
   Message received - Client messages
   The TCP log of the board (the client) shows the following:
   Connected to server 10.0.0.10 on port 65002
   Message received - Server String

Running the PDAPDemoIMPNG

This demo is a headless version of the PDAPDemo file browser in "Browsing Files."

Running the PDAPDemoIMPNG on the Emulator

Follow these steps to run the demo on the emulator:

1. Create test files and directories inside the emulator’s file system:
   username\javame-sdk\3.4\work\IMPNGDevice1\appdb\filesystem\root1
2. Load the project in the Package window.
3. In the Platform category, select the device IMPNGDevice1 and click OK.
4. In the Device Selector window, right-click an IMPNGDevice1 emulator.
5. Select Run Project > PDAPDemoIMPNG from the context menu.

6. Launch the project.

7. On the emulator, click the Tools menu and select Manage File System to see a list of mounted file systems.

8. Open a terminal emulator and create a Telnet connection to localhost on port 65002.

9. A command line opens where you can browse the emulator’s file system. You can use the following commands:
   - `cd` - change directory
   - `ls` - list information about the files for the current directory
   - `new` - create new file or directory
   - `prop` - show properties of a file
   - `rm` - remove the file
   - `view` - View a file’s content

**Running PDAPDemoIMPNG on the Reference Board**

Follow these steps to run the demo on the reference board:

1. Right-click the project and select Properties. In the Platform category, select the device IMPNGExternalDevice1 and click OK.

2. Launch the project. It runs on the reference board.

3. Open a terminal emulator and create a raw connection to the IP address of the board on port 65002.

4. The command line that opens is the same as the one you use when you run the demo on the emulator.

The file system of the demo is stored in the directory `java/IMletID` inside the SD card, where `IMletID` is a number that the AMS assigns to an IMlet during its installation.

**Running the Pulse Counter (Data Collection) Demo**

Pulse counting is the process of sending an electronic pulse to a counter, and then tracking them (via a timestamp) when they arrive. To observe this process, run the following demo on your IMPNG device, using the External Events Generator and the Pulse Counters tab:

1. Launch the Data Collection Demo.

2. In the Device Selector, right-click the IMPNGDevice1 emulator and select Run JAR or JAD.

3. In the file browser, navigate to and select the Data Collection demo JAD file. For example:

   `installdir/apps/DataCollectionDemo/dist/DataCollectionDemo.jad`
4. When the emulator opens with DataCollectionDemo installed, select DataProcessorIMlet and PulseCounterIMlet and click **Run**.

5. Click **OK** twice (once for each IMlet) in the Run IMlet dialog box.
   You do not have to select the debugger, profiler, or memory monitor tool.

6. Open the External Events Generator by clicking the **Tools** menu and selecting **External Events Generator** or clicking the External Events Generator icon.

7. Click the Pulse Counters tab.

8. Observe Output Console in the IDE as you click **Send Pulse** for the first counter, COUNTER_PA0.
   Alternatively, you can select **View > Output Console** in the emulator menu to open the Output Console window.

![Figure 4–3 Pulse Counter Output](image)

A pulse timestamp is output for each click of **Send Pulse**.

**Configuring a Pulse Counter**

You can configure a pulse counter for an IMPNG device. You can also create a custom IMPNG device with pulse counter capabilities. To do this, follow these steps:

1. Go to **Tools > Java ME > Custom Device Editor**.
   For Eclipse users, go to **Run > Custom Device Editor**.

2. Select IMP-NG in the Custom Device Editor window and click **New...**.

3. In the New IMP-NG Device dialog box, specify a name for the custom device, for example, IMPNGCustomDevice1.

4. (Optional) you can provide a brief description such as emulator with pulse counter.

5. Click the Pulse Counters tab.

6. Click Add for the number of pulse counters you want. For example, click **Add** four times to create pulse counters with IDs of 0, 1, 2, and 3.
   IDs are automatically assigned to each pulse counter. To unassign an ID, select the row of the desired pulse counter and uncheck the Assign ID option. The unassigned pulse counter is moved to the top of the list.
7. For each pulse counter, click in the Type column and select the signal trigger type: Falling Pulse Edge, Negative Edge Pulse, Rising Pulse Edge, or Positive Edge Pulse.

8. Click OK.

You also have the option to bind a pulse counter to an existing GPIO input pin by selecting the specific pin from the dropdown list in the Input Pin column.

The pulse counter type should conform to the trigger value of the binding input GPIO pin. This means that:

- Pulse counters of the type Falling Pulse Edge can only be bound to input pins with the Falling Edge trigger.
- Pulse counters of the type Rising Pulse Edge can only be bound to input pins with the Rising Edge trigger.
- Pulse counters of the type Negative Pulse Edge or Positive Pulse Edge can only be bound to input pins with the Both Edges trigger.

## Running the Light Tracker Demo

The Light Tracker demo is specifically aimed at showing off functionality on an embedded device, such as the Keil MCBSTM32F200 reference platform.

In this demo, a certain number of LEDs are turned on and turned off on the board, in a sequence that you can control. It makes use of the Device Access API and the GPIO Port to demonstrate its functionality. It requires connection of an ADC channel to an on-board potentiometer.

For more information on the setup of the Light Tracker demo, see the LightTrackDemo readme.txt file, in the location where you have installed the Oracle Java ME SDK sample applications. For example:

```
C:\Documents and Settings\username\Java_ME_SDK\samples\LightTrackDemo
```

For more information on the Keil MCBSTM32F200 platform, see the Oracle Java ME Embedded Getting Started Guide for the Reference Platform (Keil).

## Running the System Controller Demo

The System Controller demo is specifically aimed at showing off functionality on an embedded device, such as the Keil MCBSTM32F200 reference platform.

The purpose of this demo is to control the lifecycle of IMlets on the reference platform. It makes use of the following functionalities:

- Multitasking Virtual Machine (MVM)
- IMlet auto-start
- Application Management System (AMS) API
- Logging API
- Device Access API
- General Purpose Input/Output (GPIO)
- Watchdog timer

For more information on the setup of the System Controller demo, see the SystemControllerDemo readme.txt file, in the location where you have installed the Oracle Java ME SDK sample applications. For example:
C:\Documents and Settings\username\Java_ME_SDK\samples\SystemControllerDemo

For more information on the Keil MCBSTM32F200 platform, see the Oracle Java ME Embedded Getting Started Guide for the Reference Platform (Keil).
All projects have properties. Some properties, such as the project’s name and location cannot be changed, but other properties can be freely edited as work on your project progresses. This chapter describes how to work with project properties.

To view or edit a project’s properties, right-click the project node and select Properties. In the resulting window, you can view and customize the project properties. See the following topics:

- "Projects"
- "Project Properties"
- "Platform Selection"
- "Editing Application Descriptor Properties"
- "Building a Project"
- "Running and Debugging Settings"

Projects

The Oracle Java ME SDK plugin works with Mobile Tools for Java (MTJ) to create CLDC projects. For complete information on creating projects, see the Mobile Tools for Java Developer Guide included in the Eclipse online help. The basic steps to create a MIDP project are as follows:

1. Select File > New > MIDlet Project.
2. On the Create a MIDlet Project page, specify a project name and the location in the workspace.
3. The Configuration list determines the runtime type. If the default device is not what you want, select it and click Remove. Click Add to open the Create a MIDlet project page.
   - Supply a configuration name.
   - In the SDK field, select the Oracle Java ME SDK.
   - In the Device field, select a device from the dropdown.

   For the mobile runtime, select ClamshellJavaMEPhone, JavaMEPhone1 or JavaMEPhone2. For the IMP-NG runtime, select IMPNGDevice1 or IMPNGDevice2. You can add more than one device, but they must be for the same runtime.
You can optionally remove JSRs that your application does not require. Select a row in the Symbols table and click Remove.

Click Finish.

4. (IMP-NG projects only). The MicroEdition-Profile value must be IMP-NG. In some projects there is a version number appended and this must be manually removed.

In the project tree, click Application Descriptor to open a tab with your application properties. At the bottom of your project’s tab, select the Application Descriptor tab. Edit the profile if necessary. Figure 5–1 demonstrates the correct setting.

![Figure 5–1 Edit Application Descriptor MicroEdition-Profile Setting](image)

**Project Properties**

To view the project properties, right-click a project, click Properties, and select the Java ME category. The Java ME category enables you to select the emulator platform and configuration for the project, and it contains the following subcategories: Library, Obfuscation, Packaging, Preprocessor, Preverification and Signing.

**Platform Selection**

An emulator platform simulates the execution of an application on one or more target devices. To view this property page, right-click a project and click Properties and select the Java ME category.

Select a configuration from the table. You can edit the configuration and select the SDK platform and the device that you want to use for this project.

For the emulator platform, be sure to select the 3.4 platform. You might have to use the dropdown menu to ensure the right version is selected.

By default, the devices in the device menu are also suitable for the platform type and emulator platform. The device you select is the default device for this project. It is used whenever you use the Run command. Your device selection influences the Device Configuration and Device Profile options, and the available optional packages.
Add the optional packages you want to include in this project. The selected APIs are automatically added to the project’s classpath.

**Editing Application Descriptor Properties**

In Eclipse, the application descriptor is an element in the Package Explorer window. Double click on Application Descriptor in the Package Explorer under your project tree and edit the properties on the window that appears. There are different categories of properties on the tabs on the bottom: Overview, MIDlets, Optional, User Defined, Signing, and so on.

**Building a Project**

When you build a project, the SDK compiles the source files and generates the packaged build output (a JAR file) for your project. You can build the main project and all of its required projects, or build any project individually.

In general you do not need to build the project or compile individual classes to run the project. By default, the SDK automatically compiles classes when you save them. You can use properties to modify the following build tasks:

- "Compiling"
- "Adding Libraries and Resources"
- "Obfuscating"
- "Creating JAR and JAD Files (Packaging)"
- "Signing"

**Compiling**

To view this property page, right-click on a project and select Properties. Select the Java Compiler category. In this category and its subcategories you can select the Java compiler options and other compilation options.

**Adding Libraries and Resources**

To view this property page, right-click a project and select Properties. In the Java ME category, select the Library subcategory. Here you can add libraries to your project.

**Creating JAR and JAD Files (Packaging)**

To view this property page, right-click a project and select Properties. In the Java ME category, select the Packaging subcategory.

---

**Note:** In some cases the JAD file might have an incorrect value for MicroEdition-Profile. To fix this problem, see the project procedure in "Projects."

---

**Obfuscating**

To view this property page, right-click a project and select Properties. In the Java ME category, select the Obfuscation subcategory.
Signing

To view this property page, right-click a project and select Properties. In the Java ME category, select the Signing subcategory.

Running and Debugging Settings

To view this property page, right-click on a project and select Properties. In the Properties window, select Run/Debug Settings. The options shown depend on the platform. See "MIDP Project Run Options."

MIDP Project Run Options

To set emulator command line options for a MIDP project, type in the command line switches. See "Emulator Command Line Options."

To view the running settings page, right-click a project and select Properties. Select the Run/Debug Settings category and click on New. Select Java Application and click OK. In the window that appears you can adjust the run options for your project.

Debugging Options

Use the Eclipse debugging options found in Windows > Preferences > Run/Debug when you start a debugging session. See the Eclipse help topic, "Debugging a program" for explicit information on running a debugging session and available debugging options.

Note that when a debugging session is started for the first time for a Java project, the following warning message might appear:

"There are some problems with your Java Debug settings for MTJ debug. Do you want to fix them?"

Click yes to automatically set the following Java debug preferences:

- Suspend execution on uncaught exceptions
- Suspend execution on compilation errors
- Debugger timeout value (in milliseconds) is set to 15000

The timeout value must have a value of at 15000 ms.

If any of these items has a different setting, the debugging operation fails. You can set these options manually be going to Windows > Preferences > Java and selecting the Debug node.
The Oracle Java ME SDK provides default device skins. A skin is a thin layer on top of the emulator implementation that defines the appearance, screen characteristics, and input controls. This chapter discusses the default emulators provided by Oracle Java ME SDK and describes how you can create and modify a custom device. To make your own device, see "Using the Custom Device Editor."

The Oracle Java ME SDK emulator simulates a CLDC, IMP-NG, or Qualcomm device on your desktop computer. The CLDC, and IMP-NG emulators do not represent a specific device, but provide correct implementations of the supported APIs for these platforms.

The Qualcomm_IoE_Device emulator provides an emulation of the Qualcomm Orion IoE embedded device. For more information on the Qualcomm Orion IoE device, see the Oracle Java ME Embedded Getting Started Guide for the Reference Platform (Qualcomm Orion IoE).

### The Device Manager on Windows

The Oracle Java ME SDK uses the Device Manager to detect devices and displays the available devices in the Device Selector window (Tools > Java ME > Device Selector). The Device Manager is a service used to manage both emulators and external devices.

The Device Manager runs in your Windows system tray. Once you have installed the Oracle Java ME SDK software, it starts automatically when you start Windows. In the task manager, the process is labeled `device-manager.exe`.

![The Device Manager Icon](image)

You can right-click the icon and select Exit to stop the service. To restart the Device Manager, double-click `device-manager.exe` in your `installdir\bin` directory. You can also start it from the command line as described in "Run the Device Manager."

In the Windows system tray, click the icon or right-click the icon and select Manage Device Addresses from the menu to open the Device Address Manager, a shown in Figure 6–2.
Enter an IP address and select **Add** to add a device. Select an address and click **Remove** if you have an address you no longer want to detect. The device is no longer displayed in the Device Selector.

If an embedded device is attached, the user can select a COM port for the hardware connection in the Select COM Port field. If Disable is selected, Oracle Java ME SDK stops detecting external devices via COM port, as shown in **Figure 6–3**.

Right-click the icon in the system tray and select Registered Devices to see a list of registered devices and their configuration information such as, screen dimensions, screen depth, security domains, supported APIs, and more, as shown in **Figure 6–4**.
Adding an External Device

The device selector can detect a device that has a compatible runtime. Typically this device has network capabilities and is connected to the computer running Oracle Java ME SDK.

1. To detect a physical device, click CTRL-D, or click the device icon at the top of the Device Selector window.

2. Type an IP address and click Next. Click Finish.

You can also enter an IP address in the Device Manager, as described in "The Device Manager on Windows."

3. The physical device is listed in the appropriate platform tree. By default, the device has "ExternalDevice" appended to the name.

For example, if an IMP-NG device is detected it is placed in the IMP-NG node and given the name IMPNGExternalDevice1.

4. If your device is supported by a serial connection, you can define a port for the connection in the Device Address Manager. To define a COM port, click the Select COM Port field and select a port, as shown in Figure 6–5.
The Oracle Java ME SDK provides support for several embedded external devices through the Oracle Java ME Embedded runtime, including:

- Keil MCBSTM32F200
- Raspberry Pi
- Qualcomm Orion IoE

For additional information on how to install, configure, and work with a supported external device, see the Oracle Java ME Embedded documentation at:

http://docs.oracle.com/javame/embedded/embedded.html

### Starting and Running Emulators

The Oracle Java ME SDK runs applications on an emulator or an external device. Before you can run an application from the SDK, the Device Manager, must be running. When the Oracle Java ME SDK runs, the Device Manager automatically launches and starts detecting devices. The default emulators shipped with the SDK are automatically found and displayed in the Device Selector window (Window > Show View > Device Selector).

### Starting an Emulator

Typically an emulator is launched when a Oracle Java ME SDK project is run from the IDE or the command line. The default emulator is determined by the Java ME platform selected for the project.

You can open an emulator without running an application from the IDE. From the Windows Start menu, click Programs -> All Programs and select Java(TM) ME Platform SDK 3.4. On the pull-right menu, select the desired emulator. You can also click the emulator shortcuts installed on your Windows desktop.

To run an application from the emulator, click the Application menu and select Run MIDlet Suite (or Run IMlet Suite). Provide the path to the application and any other information, and click OK.
The IMP-NG Emulator

IMP-NG is a Java ME profile commonly used on small embedded devices. Figure 6–6 shows the IMP-NG emulator provided in Oracle Java ME SDK.

**Figure 6–6  The IMP-NG Emulator**

**Device Name.** Shown in the upper window frame. See Table 7–1 for a list default emulator names.

**Menus.** See "Emulator Menu Settings."

**Toolbar.** For the IMP-NG Emulator, the Toolbar provides shortcuts for the following operations:
- Run IMlet Suite
- Install IMlet Suite
- External Events Generator
- Emulator window always on top

**Note:** When the Device Manager detects an external IMP-NG device, only the Application, View, and Help menus and the Run IMlet Suite, Install IMlet Suite, and Emulator window always on top icons in the Toolbar are available in the device display.

**Device ID.** Numerical identifier that is unique for each device.

**Display Panel and Tabs.** The display panel displays fields and information dependent on the selected tab:

- **AMS.** The AMS (Application Management System) tab displays the name of the IMlet suite, the IMlet, and the status of the IMlet suite. You can select a suite and perform one of the following operations by clicking the corresponding button to the right of the display:
  - Install - Specify the location of the IMlet suite path or URL and the security domain and click OK to load the IMlet suite.
  - Update - Check for any updates to the application and performs the update.
  - Info - Open a dialog box displaying the application name, vendor name, version, description of the application, class name, and the URL.
  - Run - Run the selected application. This button is only visible for an installed application that is not running.
  - Suspend (Resume) - Pause the running IMlet. This button toggles to Resume when execution is paused.
  - Stop - Stop execution of the application. This button is only visible for a running application.
  - Remove - Remove the application.

- **GPIO Pins.** The General Purpose Input Output (GPIO) Pins tab displays which pins are selected to output and their high or low values.

- **GPIO Ports.** The GPIO Ports tab displays a list of ports, which ports are selected to output, and their maximum and current values.

- **I2C.** The Inter-Integrated Circuit (I2C) tab displays information for the selected slave device and data sent to a master device and data received from a master device.

- **SPI.** In the default SPI implementation, buffered written data can be read from the Slave named SPI. If you have created a custom implementation with the Custom Device Editor, the Slave drop down list might have additional slaves.

- **MMIO.** The memory-mapped I/O tab displays information for the current device.

- **ADC.** The Analog-to-Digital Converter tab displays the current channel, converter number, sampling intervals, minimum and maximum values, and other information.

- **DAC.** The Digital-to-Analog Converter tab displays the current channel information, converter characteristics, and a graphic display of signal characteristics with the x-axis showing the digital input and the y-axis showing the analog output.
■ **Pulse Counters.** The Pulse Counters tab displays the ID, counter name, counter number, counter type, and the pins to which the counters are bound.

**Emulator Status Bar.** Information about the current system state is shown in the status bar at the bottom of the emulator window. Also shown is the memory indicator showing used and total memory.

### The External Events Generator

The following menu options each have a tab on the External Events Generator. The use of the External Events Generator is addressed in the discussion for each JSR:

■ **ADC.** The Analog-to-Digital Conversion tab is only visible for the IMP-NG emulator.

■ **Access Points.** This tab displays connection information for the selected access point.

■ **GPIO.** This General Purpose Input Output (GPIO) option.
  
  By default, this tab displays ports and pins for a specific device described in "Running the GPIODemo." You can create a custom device to represent a different device. See "General Purpose Input Output (GPIO)."

  See the Device Access API ([installdir\docs\api\deviceaccess](installdir\docs\api\deviceaccess)) for a description of the GPIO interface.

■ **Location.** "Setting the Emulator's Location at Runtime."

■ **MMIO.** The memory-mapped I/O (MMIO) option is visible only for the IMP-NG emulator. From the Device drop down list, select one of the default devices:

  ■ **TEST_DEVICE.** A Little Endian device that contains all block types: byte, short, int, long, and block. Writes to this device also affect BIG_ENDIAN_DEVICE which shares the address space.

  ■ **WDOGLOG.** A Little Endian device that supports only the block type.

  ■ **RTC.** STM32F200 RTC device. A Little Endian device that supports only the int type.

  ■ **BIG_ENDIAN_DEVICE.** A Big Endian device that shares the address space with the TEST DEVICE, therefore it contains the same memory blocks. Writes to this device also affect TEST DEVICE which shares the address space.

  If you are using a custom device created with the Custom Device Editor (see "Using the Custom Device Editor"). The device list might include additional devices.

  See the Device Access API ([installdir\docs\api\deviceaccess](installdir\docs\api\deviceaccess)) and the Embedded Support API ([installdir\docs\api\embedded-support-api](installdir\docs\api\embedded-support-api)) for descriptions of the MMIO interface.

■ **Mobile.** The unique International Mobile Subscriber Identity (IMSI) and the International Mobile Station Equipment identity (IMEI) identifiers of the device.

■ **Pulse Counter.** This tab displays the current pulse counters on the device. The default configurations are:
  
  - COUNTER_PA0
  - COUNTER_PB3
  - COUNTER_PB10
- COUNTER_PA3

You can configure the pulse counters you want and send a signal to the configured pulse counter by clicking Send Pulse.

IMP-NG Device Options

For in-depth descriptions of the IMP-NG interfaces or devices, see the following resources:

- Device Access API (installdir/docs/api/deviceaccess)
- Embedded Support API (installdir/docs/api/embedded-support-api)
- For more information about default devices and their properties, you can use the Properties View from the Device Selector. For more information, see "Viewing Device Properties."

The Qualcomm IoE Emulator

The Qualcomm_IoE_Device emulator is based on IMP-NG, but for a specific embedded platform, the Qualcomm Orion IoE device. Many of the menus and settings are the same as in the IMP-NG emulator.

For more information on Qualcomm_IoE_Device emulator menus and settings that are not mentioned in this section, see "The IMP-NG Emulator."

The Qualcomm_IoE_Device emulator is launched from the Windows command prompt:

1. Change to the bin directory of the Oracle java ME SDK distribution:
   
   C:\>cd Java_ME_platform_SDK_3.4\bin

2. Enter the following command, as shown here:

   emulator.exe -Xdevice:Qualcomm_IoE_Device -Xdescriptor:location_of_jad_file

   For example:

   emulator.exe -Xdevice:Qualcomm_IoE_Device -Xdescriptor:C:\Java_ME_platform_SDK_3.4\apps\sample\sample_imlet.jad

   This launches the Qualcomm_IoE_Device emulator, as shown in Figure 6–7.
The Qualcomm IoE Emulator

Figure 6–7  The Qualcomm_IoE_Device Emulator

The tabs on the External Events Generator for the Qualcomm_IoE_Device emulator largely match those of the IMP-NG emulator. Those that differ are shown below.

The Serial Peripheral Interface (SPI) Tab
The Qualcomm_IoE_Device emulator External Events Generator SPI tab provides a sample accelerometer sensor, G-Sensor, as shown in Figure 6–8.
The G-Sensor sample allows an IMlet to read accelerometer values from the emulator through the Serial Peripheral Interface. Move the slider of the X, Y, and Z acceleration scale to change the x, y, and z values transmitted over SPI. The minimum and maximum values for the sliders in the G-Sensor are defined by the Java ME application.

The G-Sensor sample duplicates in emulation the functionality of the digital, triaxial acceleration sensor on the Qualcomm Orion IoE embedded device. The acceleration sensor is used to sense tilt, motion, and shock vibration in embedded devices, such as medical instruments, computer peripherals, and monitoring devices.

The G-Sensor Fields

The G-Sensor has the following fields:

- **Range.** Allows you to specify a range to be sensed.
- **Bandwidth.** Allows you to specify a bandwidth to be sensed.
- **Accelerator-X.** Allows you to select a value within a specified range by moving the slider position.
- **Accelerator-Y.** Allows you to select a value within a specified range by moving the slider position.
- **Accelerator-Z.** Allows you to select a value within a specified range by moving the slider position.

For more information on working with the Qualcomm Orion IoE embedded device, see the Oracle Java ME Embedded Getting Started Guide for the Reference Platform (Qualcomm Orion IoE).

The Inter-Integrated Circuit (I2C) Tab

The Inter-Integrated Circuit (I2C) tab displays information for the selected slave device, and data sent to and received from a master device. The Qualcomm_IoE_Device emulator External Events Generator I2C tab provides three sample sensors, as shown in Figure 6–9.
The three sample sensors in the I2C tab are:

- **G-Sensor**: Operates in the same way as described in the External Events Generator SPI tab. However, the sample IMLet reads the accelerometer values through the I2C interface. For more information, see "The Serial Peripheral Interface (SPI) Tab."

- **Light Sensor**: Allows the user to test three kinds of light sensing: ambient light, proximity, and Infrared (IR). A lux value can be specified, and the values changed within the lux value range by moving the Light slider.

- **Temperature Sensor**: High and Low temperature values can be set, and temperature values read when the slider is moved.

**The Light Sensor Fields**
The Light Sensor has the following fields:

- **Type.** Three types of light sensing are possible:
  - Ambient Light. Allows changes in light brightness to be registered by the emulated sensor.
  - Proximity. Allows changes in light proximity (distance) to be registered by the emulated sensor.
  - Infrared (IR). Allows changes in infrared light to be registered by the emulated sensor.

- **Range.** Four values of illuminance (luminous flux) are possible:
  - 1. (0.015 - 100 lux)
  - 2. (0.06 - 4000 lux)
  - 3. (0.24 - 16000 lux)
  - 4. (0.96 - 64000 lux)

- **Resolution.** Allows, 4, 8, 12, or 16 bits.

- **Low Limit (lux).** Defined by the value set in the Range field.

- **High Limit (lux).** Defined by the value set in the Range field.

- **Interrupt Flag Set.** If the user changes the sensor value and the new value is out of the High-Low Limits interval, the Interrupt Flag is set to Yes and the Java ME application reads the value. If the sensor values stay within the defined range, the Interrupt Flag is reset to No.

- **Light (lux).** Allows the user to define the lux value for the application by moving the slider. The high and low lux limits are defined by the value set in the Range field.

The Temperature Sensor Fields

The Temperature Sensor has the following fields:

- **Low Temperature Limit (Celsius).** Defines a low temperature setting, beyond which a Limit Flag is tripped. Has a corresponding Limit Tripped field.

- **High Temperature Limit (Celsius).** Defines a high temperature setting, beyond which a Limit Flag is tripped. Has a corresponding Limit Tripped field.

- **Limit Tripped.** Applies to both High and Low Temperature fields. If the user moves the slider and the new value is outside the High or Low Limits, the Limit Tripped flag is set to Yes and the Java ME application reads the value in Status Register 1. When the Limit Tripped value is read in Status Register 1, the Limit Tripped flag is reset to No. If the slider values stay within the defined range, no Limit Tripped flag is set and the value is No.

- **Temperature (Celsius).** Allows the user to define the temperature value for the application by moving the slider. The high and low temperature limits are defined by the value set in the Low Temperature and High Temperature fields.

The Temperature Sensor can operate in Default or Extended mode.

- In Default mode, the user can change the temperature from 0 to 127 degrees Celsius.
In Extended mode, the user can change the temperature from -64 to 191 degrees Celsius.

To set the Default or Extended mode, use `setDefaultMode()` and `setExtendedMode()` in the Java ME application.

The CLDC Mobile Emulator

The Oracle Java ME SDK provides a Mobile emulator based on CLDC, as shown in Figure 6–10.

Figure 6–10 Emulator Features
CLDC Application Management System

The CLDC AMS home screen features three utilities:

- **Install Application.** This utility opens a form in which you can specify a URL (or a file path) for a JAD file to install.

- **Manage Certificate Authorities.** This feature displays the certificate authorities for the device. In this interface the white box indicates the certificate is checked (active). You can uncheck certificates that are not needed.

- **Output Console.** The output console displays system output statements from a running application. The application must write to the Java standard output console using, for example:

  ```java
  System.out.println("text");
  ```

  Start the emulator’s Output Console, then start your application. Use F7, Switch running MIDlet, to switch between the application and the Output Console.

  Note that the emulator’s Output Console is an application that consumes resources. If you get the message “No more concurrent applications allowed,” you must close some applications before continuing.

  **Figure 6–11  The Output Console Window**

  ![Output Console Window](image)

  See "The CLDC Mobile Emulator" and "Emulator Menu Settings."

  You can also access system output information from the emulator by clicking the View menu and selecting Output Console..., which opens an Output Console dialog box. Select a filter from the drop down list to display specific system output. Click Save to save the output as a .log file.

Mobile Emulator Menus

- **Device Name.** Shown in the upper window frame. See Table 7–1 for a list of default emulator names.
Transmission Indicator. On the upper left of the emulator image, this blue light turns on when a transmission is occurring. Typically you see it when an application is installed over-the-air, or when a message is being sent or received. For example, when you receive a message from the WMA console.

Menus. See "Emulator Menu Settings."

Toolbar. For the CLDC emulator, the Toolbar provides shortcuts for the following operations:
- Run MIDlet Suite
- Install MIDlet Suite
- Resume
- Suspend
- Rotate Clockwise
- Rotate Counterclockwise
- External Events Generator
- Emulator window always on top

Device ID. Numerical identifier that is unique for each device.

Exit Button. On the upper right of the emulator image, is the termination button. Pushing this button the same effect as clicking Application and selecting Exit.

Emulator Status Bar. Information about the current system state is shown in the status bar at the bottom of the emulator window.

Running Projects Simultaneously on a Single Device

CLDC-based devices are capable of running multiple virtual machines. To test this feature, follow these steps:

1. Display the Output window. Select Window > Show View > Console.
   The Output window does not need to be open to run this procedure. You can open the Output window at any time to display all output from the beginning of the emulator session.

2. Open the sample projects Games and AudioDemo.

3. In the device selector, select a CLDC device and run Games. When the emulator launches, run AudioDemo on the same device.
   As each MIDlet loads, the AMS automatically installs it.

4. In AudioDemo, launch the Audio Player, and play the JavaOne theme.
   Select AudioPlayer, then from the soft menu, select 1, Launch. Select JavaOne Theme and press the Play soft button.

5. In the emulator, click the Application menu and select AMS Home, or press F4.
   Select Games. From the soft menu, select 1, Open. The music continues to play while you are able to simultaneously launch and play games.

6. Click the Application menu and select AMS Home, or press F4. Highlight AudioSamples, and from the soft menu, select 2, Bring to foreground. Press the Pause soft key. The music stops playing.
7. Click the **Application** menu and select **AMS Home**, or press F4. Highlight AudioSamples and from the soft menu, select 1, Open. Select Bouncing Ball from the list and press the Launch soft button. Select MIDI background and press the Play soft button.

8. Click the **Application** menu and select **AMS Home**, or press F4. Then click the **Application** menu and select **Switch Running MIDlet**. Select Audio Player and press the Switch to soft button. You can press the Play soft button to resume the Audio Player.

### Emulator Menu Settings

The Menus available on the three Oracle Java ME SDK emulators are very similar, with differing suboptions. The following tables describe the operations of each menu in more detail.

- The IMP-NG emulator has Application, Device, Tools, View, and Help menus.
- The Qualcomm_IoE_Device emulator has Application, Device, Tools, View, and Help menus.
- The CLDC (Mobile) emulator has Application, Device, Edit, Tools, View, and Help menus.

#### The Application Menu

The Application menu is fully populated for the CLDC platform. Table 6–1 describes the Application options:

<table>
<thead>
<tr>
<th>Option</th>
<th>Accelerator</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Install MIDlet Suite</td>
<td></td>
<td>Permanently add a MIDlet suite to the emulator. Enter the path or URL of the MIDlet suite to install on the emulator. Select the desired level of the permissions in the Security Domain field.</td>
</tr>
<tr>
<td>Install IMlet Suite</td>
<td></td>
<td>Permanently add a IMlet suite to the emulator. (IMP-NG emulator) Enter the path or URL of the IMlet suite to install on the emulator. Select the desired level of the permissions in the Security Domain field.</td>
</tr>
<tr>
<td>Run MIDlet Suite</td>
<td></td>
<td>Emulator interface for launching MIDlets.</td>
</tr>
<tr>
<td>Run IMlet suite</td>
<td></td>
<td>Emulator interface for launching IMlets. (IMP-NG platform)</td>
</tr>
<tr>
<td>AMS Home</td>
<td>F4</td>
<td>Exit the current application and return to the Application Management Software home. (CLDC emulator)</td>
</tr>
<tr>
<td>Stop</td>
<td>F10</td>
<td>Stops the currently running MIDlet. (CLDC emulator)</td>
</tr>
<tr>
<td>Change Locale</td>
<td></td>
<td>This option only works with localized MIDlets. (CLDC emulator) Enter a locale identifier. The format is similar to Java SE 6, as follows: 2-letter-lang-code separator 2-letter-country-code For example, en-US, cs-CZ, zh-CN, ja-JP. The separator can be a dash or an underscore.</td>
</tr>
</tbody>
</table>

---

The Device Menu

This menu is available on CLDC and IMP-NG platforms.

Messages

Click the Device menu and select Messages to see what is written in the message area. This is the emulator’s Inbox. The Inbox displays WMA messages that are addressed to the device, not an application on the device. Messages are sent to this interface in the following cases:

- An MMS message is sent without an AppID in the address
- An SMS message is sent without a port in the address (or the port number is 0)
- An SMS text message is sent with a port in the address, but there is not a Java ME application listening on the specified port

To test sending messages to the inbox use the WMA Console or from the command line, use wma-tool.exe to send SMS messages. Note, wma-tool.exe requires an AppID for MMS, so wma-tool.exe cannot be used to send an MMS.

Orientation

This option is only visible for the CLDC emulator.

Use this feature to test your application’s ability to display in portrait and landscape formats. The default is 0 degrees. Change the orientation to 90, 180, or 270 degrees. You can also rotate 90 degrees clockwise (F8) or counterclockwise (F9) from the current position.

The Edit Menu

Table 6–2 describes the Edit menu, which provides basic editing operations for the CLDC platform.

<table>
<thead>
<tr>
<th>Option</th>
<th>Accelerator</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Copy</td>
<td>CTRL-C</td>
<td>Copy selected material to the paste buffer.</td>
</tr>
<tr>
<td>Cut</td>
<td>CTRL-X</td>
<td>Move selected material to the paste buffer.</td>
</tr>
<tr>
<td>Paste</td>
<td>CTRL-V</td>
<td>Insert the contents of the paste buffer.</td>
</tr>
</tbody>
</table>

Table 6–2 Emulator Edit Menu
The Tools Menu

Table 6–3 describes the utilities accessible from the Tools menu.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Manage Landmarks</td>
<td>Opens the Landmark Store utility. In this interface, you can view and edit a landmark store installed as part of an application. You can also create a new landmark store, define landmarks, define landmark categories, and assign landmarks to categories.</td>
</tr>
<tr>
<td>Manage File System</td>
<td>Opens the File System manager and displays the mounted file system root directories. You can mount or unmount a file system directory, copy a mounted file system directory, remount or remove directories. For a description of managing a file system, click the Tools menu and select Manage File System. Click Help in the dialog box.</td>
</tr>
<tr>
<td>External Events Generator</td>
<td>Opens the External Events Generator. The External Events Generator provides a way to interact with an application by injecting events. The interaction may be through a user interface, or through a script file. For a description of the External Events Generator, see &quot;The External Events Generator.&quot;</td>
</tr>
<tr>
<td>Take Screenshot</td>
<td>Takes a screenshot of the emulator display screen and saves it to the clipboard. (CLDC emulator)</td>
</tr>
</tbody>
</table>

The View Menu

Table 6–4 describes the View menu, which is available for the CLDC and IMP-NG platforms.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Always On Top</td>
<td>Keeps the emulator in the foreground. This option is especially useful when you are running multiple emulator instances and you want to see them all and send messages between devices.</td>
</tr>
<tr>
<td>Output Console</td>
<td>Displays system output statements from a running application in the Output Console window. You can filter the output statements for IMP-NG emulators by selecting All, Standard, or Error from the Show dropdown list. Error messages are highlighted. Filtering of output statements and highlighting of error messages are not available for CLDC emulators or external devices. You can save system output information to a .log file by clicking Save in the window.</td>
</tr>
</tbody>
</table>
The Help Menu
The Help menu displays an abbreviated helpset specifically for the emulator window.

Using the Device Selector
The Device Selector lists the devices that are currently available in Eclipse, grouped by platform. If the Device Selector is not visible, click on the Device Selector tab, or select Window > Show View > Device Selector.

The list in the Device Selector matches the list displayed in the Registered Devices window.

Viewing Device Properties
If no Java ME platform is registered in Eclipse, the Device Selector displays a node labeled No Device Found. If you see this message at startup, it typically means device discovery is incomplete and you must wait a few seconds.

Each sub node represents a device. Two instances are provided for some CLDC devices, for example, JavaMEPhone1 and JavaMEPhone2. Instances of the same device have the same capabilities but unique names and phone numbers, making it easy for you to test communication between devices of the same type. To make your own device, see "Using the Custom Device Editor."

For Device names, see "Oracle Java ME SDK Directories." The properties for each device are stored in XML files in your user work directory. See Table 7–1.

Platform Properties
To view platform properties from the device selector, click on the platform node (for example, CLDC or IMP-NG). The Properties window is, by default, docked in the upper right portion of the user interface. If the Properties window is not visible, click the Window menu and select Properties.

To view the platform properties in a separate window, right-click the platform node and select Properties. This displays a Properties window for the selected device.

### Table 6–4 (Cont.) Emulator View Menu

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Device Log</td>
<td>Displays emulator log messages in the Device Log window.</td>
</tr>
<tr>
<td></td>
<td>The following filters are available from the Level dropdown list:</td>
</tr>
<tr>
<td></td>
<td>- Trace - Tracing information, such as garbage collection, exceptions, and method calls.</td>
</tr>
<tr>
<td></td>
<td>- Debug - General debugging information.</td>
</tr>
<tr>
<td></td>
<td>- Info - Information messages.</td>
</tr>
<tr>
<td></td>
<td>- Warn - Alerts that issues were encountered during runtime. Warnings are highlighted.</td>
</tr>
<tr>
<td></td>
<td>- Error - Errors encountered during runtime but do not prevent the application from running. Error messages are highlighted.</td>
</tr>
<tr>
<td></td>
<td>- Fatal - Non-recoverable errors that can potentially prevent the application from running and might cause the application to quit.</td>
</tr>
</tbody>
</table>

You can save system output information to a .log file by clicking Save in the window.
The information in the docked properties window and the separate window is the same.

**Device Information**
In the Device Selector window, double-click a device node. The Device Information tab opens in the central Main window. It displays a picture of the device and displays details, supported hardware capabilities, keyboard support, supported media formats, and the supported runtimes.

**Device Properties**
In the Device Selector window, click a device node (such as JavaMEPhone1) to display the device properties. The Properties window is, by default, docked in the upper right portion of the user interface. If the Properties window is not visible, click the Window menu and select Properties.

**Setting Device Properties**
In the Device Selector window, right-click a device and select Properties. Any properties shown in gray font cannot be changed. You can adjust the device properties shown in black. The CLDC and IMP-NG options can be adjusted.

Setting device properties for an existing device and creating a custom device with new property settings are very similar. For additional information, see "Creating a Custom Device."

**General Device Properties**
This section lists general properties that can be changed.

**Phone Number.** You can set the phone number to any appropriate sequence, considering country codes, area codes, and so forth. If you reset this value, the setting applies to future instances. The number is a base value for the selected device.

**Heapsize.** The heap is the memory allocated on a device to store your application’s objects. The Heapsize property is the maximum heap size for the emulator. You can select a new maximum size from the drop down menu.

**Security Domain.** Select a security setting from the drop down menu. See "Specify the Security Domain for an Emulator." Applies to CLDC platforms.

**JAM storage size in KB.** The amount of space available for applications installed over the air.

**Locale.** Type in the locale as defined in the MIDP 2.1 specification at:
http://download.oracle.com/otndocs/jcp/midp-2.1-mrel-oth-JSpec

**Remove MIDlet Suite in execution mode.** If this option is enabled, record stores and other resources created by the MIDlet are removed when you exit the MIDlet (assuming the MIDlet was started in execution mode).

**Monitor**
If enabled (checked), the Check boxes for Trace GC (garbage collection), Trace Class Loading, Trace Exceptions, and Trace Method Calls activate tracing for the device the next time the emulator is launched. The trace output is displayed at runtime in the user interface Output window. Trace Method Calls returns many messages, and emulator performance can be affected. See Chapter 10, "Monitoring Memory."
Location Provider #1 and #2
These properties determine the selection of a location provider. Two providers are offered so that your application can test matching the location provider criteria. If you select a property a short explanation is shown in the description area just below the Properties table. For more information on these values, see the Location API at: http://jcp.org/en/jsr/detail?id=179.

SATSA
For more information on working with Security and Trust Services (SATSA), see Chapter 18, "JSR 177: Smart Card Security (SATSA)."

Bluetooth and OBEX
For more information on working with Bluetooth and Object Exchange (OBEX), see Chapter 16, "JSR 82: Bluetooth and OBEX Support."

Running a Project from the Device Selector
The SDK determines which open projects are suitable for a device. Right-click the device and select a project from the context menu.
You can also launch the emulator to run a project from the command line, as explained in "Emulator Command Line Options."

Using the Custom Device Editor
With the Custom Device Editor you can create your own devices. The appearance of the custom devices is generic, but the functionality can be tailored to your own specifications. The Custom Device Editor is shown in Figure 6–12.

Figure 6–12  The Custom Device Editor

Creating a Custom Device
Follow these steps to create a custom device.
1. Launch the Custom Device Editor from the your installation’s bin directory. For example

   `C:\Java_ME_platform_SDK_3.4\bin\device-editor.exe`

   The custom device tree displays Java ME platforms and custom devices, if any.

2. Select a platform and click the **New...** button.

3. Change the default configuration to match your specifications, and click **OK**.

Your device is added to the custom device tree and eventually appears in the Device Selector. You can run projects from the IDE or from the command line from the custom device.

The custom device tree affects what appears in the Device Selector. For example, if you do not want a custom device to appear in the device selector, you must remove it from the custom device tree.

The device definition is saved in `installdir\toolkit-lib\devices`.

**IMP-NG Device Properties**

When you create a new IMP-NG device using the Custom Device Editor (**Run > Custom Device Editor**) you can use the default implementation or create your own custom implementation for the interfaces discussed in this section.

See the following resources for in-depth descriptions of the IMP-NG interfaces or devices:

- **Device Access API** (`installdir\docs\api\deviceaccess`)
- **Embedded Support API** (`installdir\docs\api\embedded-support-api`)
- For more information about default devices and their properties, you can use the Properties View from the Device Selector. For more information, see "Viewing Device Properties."

**General Purpose Input Output (GPIO)**

A GPIO port is a platform-defined grouping of GPIO pins that may be configured for output or input. Output ports are both writable and readable while input ports are only readable. Note that GPIO pins that are part of a GPIO port cannot be retrieved nor controlled individually as GPIO Pin instances.

Click **Add Port** to add entries to the Ports table. Each item in a Ports table row is editable. Check **Output** to set the port direction to output.

A GPIO pin may be configured for output or input. Output pins are both writable and readable while input pins are only readable. Note, an input listener can only be assigned to a pin set for input.

Click **Add Pin** to add a row to the Pins table. The ID and name are editable. Click **Output** to make a pin both readable and writable. Click in the Initial Value column to toggle the Initial Value from Low to High.

**Inter-Integrated Circuit (I2C) and Serial Peripheral Interface (SPI)**

The process for configuring I2C and SPI interfaces is very similar.

On an I2C bus, data is transferred between the I2C master device and an I2C slave device through single or combined messages. On an SPI bus, data is transferred between the SPI master device and an SPI slave device in full duplex. That is, data is
transmitted by the SPI master to the SPI slave at the same time data is received from the SPI slave by the SPI master. See the Embedded Support API for more details.

- Select Sample Echo to select the default bus implementation. This default implementation simply reads buffered written data from the slave.
- Select Custom to specify your own bus implementation.
  1. Supply your bus implementation JAR file and the name of the Java class that implements the bus.
     
     For I2C, the bus is:
     ```
     com.oracle.jme.toolkit.deviceaccess.i2c.I2CSlaveBus
     ```
     
     For SPI, the bus is:
     ```
     com.oracle.jme.toolkit.deviceaccess.spi.SPISlaveBus
     ```
  2. To add Slaves, click Add and specify an ID and Name. For SPI, specify the Word Length as well.

---

**Note:** On an SPI bus, data is transferred between the SPI master device and an SPI slave device in full duplex. So every `com.oracle.deviceaccess.spibus.SPIDevice.read(...)` method also writes an array of zeros to the slave device. The length of this array equals a length of read data. In the default implementation this array of zeros is appended to the loopback’s buffer.

---

**Memory-Mapped I/O (MMIO)**

The default devices are described in "The External Events Generator."

If you want to provide your own MMIO emulation, you must specify a custom handler.

Supply your implementation JAR file and the name of the Java class that implements `com.oracle.jme.toolkit.deviceaccess.mmio.MMIOHandler`. For comparison, the default JAR file is:

```
installdir\toolkit-lib\devices\IMPNGDevice\code\emulator_deviceaccess_mmio-sample-handler.jar
```

To add devices to the custom MMIO implementation, open the MMIO properties for your device. Use the Devices and Device Memory tables as follows:

1. Click **Add Device** to add a row to the Devices table.
   - A default ID is assigned but you can double-click in the ID column to edit the value.
   - A default Name is supplied, but it can also be edited.
   - In the Byte Ordering column, make a selection from the drop down list.

2. Click a row in the Device table to select a Device.

3. Click **Add Memory**.
   - In the Type column, make a selection from the drop down list. Double-click to edit the Address column entries.
   - If the type is Block, you can double-click to edit the Size column entries as well as the Address column entries.
Managing Custom Devices

Custom devices should always be managed using the Custom Device Editor. Using the tool ensures that your device can be detected and integrated with the Oracle Java ME SDK.

- **New.** Select a platform and click **New** to add a new device.
- **Edit.** Select a device to change, and click **Edit**.
- **Clone.** Select a device to copy, and click **Clone**. To prevent confusion, be sure to provide a unique name.
- **Remove.** Select a device to delete and click **Remove**. This action completely deletes the device.
- **Import.** Select a node in the custom device tree and click **Import**. Select a .zip file created with the Export command.
- **Export.** Select a device to save, and click **Export**.

When a custom device is created it is saved in `installdir\toolkit-lib\devices`, therefore you could lose your device if you reinstall.

An exported device is stored in a .zip file and saved in the user’s My Documents directory (typically `username\My Documents`).

Making Device Connections

The configuration of all peripherals, except UART, can be inspected in the emulator main window. The configuration of UART is defined by the hardware configuration of the COM ports on your Windows XP or Windows 7 PC.

For more information on connecting to a UART Device, see "Connecting to a UART Device."

To open a serial port, such as COM1 or COM2, in Windows you can use the Device Address Manager. In application code, you can use `Connector.open("comm:COM1")`

Connecting to a UART Device

To utilize the Universal Asynchronous Receiver/Transmitter (UART) functionality, you need to create a configuration file (for example `UARTConfig.xml`). The configuration file defines the device ID and Name, and the Name must point to a real serial port name defined by the operating system. For example,

```
deviceaccess.uart.dev14.name = COM1
```

For an already opened UART, you can add it to the peripheral manager by calling `PeripheralManager.open` with the configuration object.
Finding Files in the Multiple User Environment

The Oracle Java ME SDK can be installed on a system running a supported operating system version. All users with an account on the host machine can access the SDK. This chapter describes this feature, called the Multiple User Environment.

Note: The Multiple User Environment supports access from several accounts. It does not support multiple users accessing the SDK simultaneously. See "Switching Users."

To support multiple users the SDK creates an installation directory that is used as a source for copying. This document uses the variable `work` to represent the SDK working directory and `installdir` to represent the Oracle Java ME SDK installation directory. Each user's personal files are maintained in a separate working directory named `javame-sdk` that has a subdirectory for each version installed.

- "Installation Directories"
- "Eclipse User Directories"

To locate logs, see "Device Manager Logs" and "Device Instance Logs."

Switching Users

Multiple users cannot run the SDK simultaneously, but, you can run the SDK from different user accounts on the SDK host machine. When you switch users, you must close the SDK and exit the Device Manager, as described in "The Device Manager on Windows." A different user can then launch the SDK and own all processes.

Installation Directories

The SDK directory structure conforms to the Unified Emulator Interface Specification (http://www.oracle.com/technetwork/java/javame/documentation/ueispecs-187994.pdf), version 1.0.2. This structure is recognized by all IDEs and other tools that work with the UEI.

The installation directory has the following structure:

- bin. The bin directory contains the following command line tools. The default location of the bin directory is:

  `installdir\bin`
- ` cref`. The Java Card Platform Simulator tool, which is used to simulate smart cards in the emulator. It is used for testing SATSA (JSR 177) applications with the Oracle Java ME SDK. For more information on SATAS, see Chapter 20.

- `device-address` is a tool for viewing, adding, and removing devices that the SDK is not able to discover automatically. See "Manage Device Addresses (device-address)."

- `device-manager`. The Device Manager is a component that must be running when you work with Oracle Java ME SDK. After installation it starts as a service, and it automatically restarts every time your computer restarts. See “Starting and Running Emulators.”

- `emulator`. UEI compliant emulator. See "Emulator Command Line Options."

- `jadtool`. Tool for signing MIDlets. See "Sign MIDlet Suites (jadtool)."

- `mekeytool`. Management of ME keystores. See "Manage Certificates (MEKeyTool)."

- `preverify`. The Java ME preverifier.

- `wma-tool`. A command line tool for sending and receiving SMS, CBS, and MMS messages. See "Running WMA Tool."

- `wscompile`. Compiles of stubs and skeletons for JSR 172. See "Generate Stubs (wscompile)."

- `docs`. Release documentation.

- `legal`. License and copyright files.

- `lib`. JSR JAR files for compilation.

- `runtimes`. CLDC and IMP-NG runtime files.

- `toolkit-lib`. Oracle Java ME SDK files for configuration and definition of devices and UI elements. Executables and configuration files for the Device Manager and other SDK services and utilities.

---

**Eclipse User Directories**

By default, the Eclipse default workspace file is located at:

`username\workspace`

Click the **File** menu and select **Switch Workspace** to change the location.

---

**Oracle Java ME SDK Directories**

This documentation sometimes uses *username* to represent the root location of user files.

- The `javame-sdk` directory contains device instances and session information. If you delete this directory, it is re-created automatically when the Device Manager is restarted.

  `username\javame-sdk\3.4`

- Device working directories

  `username\javame-sdk\3.4\work\devicename`
The named subdirectories each correspond to an emulation device, as described in Table 7–1. Any detected external devices are also added to this directory space. Device detection is described in "Adding an External Device."

<table>
<thead>
<tr>
<th>Device</th>
<th>Platform</th>
<th>Emulator #</th>
</tr>
</thead>
<tbody>
<tr>
<td>ClamshellJavaMEPhone1</td>
<td>CLDC</td>
<td>0</td>
</tr>
<tr>
<td>IMPNGDevice1</td>
<td>CLDC</td>
<td>2</td>
</tr>
<tr>
<td>IMPNGDevice2</td>
<td>CLDC</td>
<td>3</td>
</tr>
<tr>
<td>Qualcomm_IoE_Device</td>
<td>CLDC</td>
<td>4</td>
</tr>
<tr>
<td>JavaMEPhone1</td>
<td>CLDC</td>
<td>5</td>
</tr>
<tr>
<td>JavaMEPhone2</td>
<td>CLDC</td>
<td>6</td>
</tr>
</tbody>
</table>
The Oracle Java ME SDK supports performance profiling for Java ME applications. The profiler keeps track of every method in your application. For a particular emulation session, it figures out how much time was spent in each method and how many times each method was called. This chapter describes how to set up profiling.

The SDK supports offline profiling. Data is collected during the emulation session. As you view the snapshot you can investigate particular methods or classes.

**Note:** This feature might slow the execution of your application.

### Collecting and Saving Profiler Data in the IDE

This procedure describes interactive profiling. To run profile an application from the command line, see "Command Line Profiling."

**Note:** The profiler maintains a large amount of data, so profiled MIDlets place greater demands on the heap. To increase the Heapsize property, see "Setting Device Properties."

1. Select a project.
2. Select **Run >Profile As... >CPU Profiler** (alternatively, you can right-click the project and select **Profile As** and then **CPU Profiler** from the context menu).
3. Interact with the application MIDlet as you normally would.
4. Exit the MIDlet.
   
   You are asked if you want to transfer the profiling data to a profiler. Select Yes.
   
   The profile data is automatically displayed in a tab labeled **cpu:time**, where **time** is the time the data was displayed.
   
   In the IMP-NG emulator the data transfer occurs when you press the Stop button.
5. To export the profile data, click the **File** menu and select **Save As**. The file is saved as a PRF file in the project directory in your workspace.

### Loading a .prf File

A previously exported .prf file ("Collecting and Saving Profiler Data in the IDE") can be loaded at a later time.
Follow these steps to retrieve profile data:

1. Click the **File** menu and select **Open File...**
2. Browse to the .prf file you want and click Open.

The Profiler opens in its own tab labeled `cpu:filename`.

---

**Note:** The profiling values obtained from the emulator do not reflect actual values on an external device.
MIDP applications, at a minimum, are capable of HTTP network connections, but many other types of network connections are also possible. The network monitor provides a convenient way to see the information your application is sending and receiving on the network. This is helpful if you are debugging network interactions or looking for ways to optimize network traffic.

Networking monitoring works for emulators only (it is not supported for external devices).

- "Monitor Network Traffic"
- "Filter or Sort Messages"
- "Save and Load Network Monitor Information"

Monitor Network Traffic

Follow these steps to activate the network activity for an application.

1. Select Run > Profile As... > Network Monitor or right click a project, select Profile As... > Network Monitor.
2. Start your application.

When the application makes any type of network connection, information about the connection is captured and displayed in the Network Monitor tab.

The top frame displays a list of messages. Click a message to display its details in the bottom frame.

In the Hex View, message bodies are shown as raw hexadecimal values with the equivalent text. To avoid memory issues, the Hex view is currently limited to 16kB of data.

**Note:** You can examine messages that are still in the process of being sent. Incomplete messages are indicated by bold highlighting in the message tree.

Filter or Sort Messages

Filters are useful for examining some subset of the total network traffic.

- In the [Select Devices] list check only the devices you want to view.
- In the [Select Protocols] list check only the protocols you want to view. The protocols listed reflect what is currently installed on the device.
Save and Load Network Monitor Information

URL. Messages are sorted by URL address. Multiple messages with the same address are sorted by time.

To arrange the message tree in a particular order, click the Sort By combo box and select a criteria.

---

**Note:** Sorting parameters are dependent on the message protocol you choose. For example, sorting by time is not relevant for socket messages.

---

**Save and Load Network Monitor Information**

Click the **File** menu and select **Save As** to save your network monitor session. The session is saved as a Network Monitor Snapshot file and is added to the project tree, just like the profiling information.

Follow these steps to load a network monitor session:

1. Select **Open File...** from the **File** menu.
2. Browse to the `.nmd` file you saved.

---

**Note:** To avoid memory issues, the Hex view display is currently limited to 16kB of data.

---
This chapter describes how to use tracing and the memory monitor to examine an application’s memory use on a particular device.

Activating tracing for a particular device enables you to see low-level information as an application runs.

The Memory Monitor shows memory use as an application runs. It displays a dynamic detailed listing of the memory usage per object in table form, and a graphical representation of the memory use over time. You can take a snapshot of the memory monitor data. Snapshots can be loaded and examined later.

---

**Note:** The memory use you observe with the emulator is not exactly the same as the memory use on an external device. Remember, the emulator does not represent an external device. It is one possible implementation of its supported APIs.

---

**Enabling Tracing**

Follow these steps to enable tracing.

1. In the Device Selector window, right-click a device.

2. In the properties window for the selected device, go to the Monitor section and check the desired trace options:

   - Trace GC (garbage collection). Monitoring GC can help you determine object health. The garbage collector cannot delete objects that do not have a null reference. Dead objects are garbage collected and not reported as live.
   - Trace Class Loading. Observing class initialization and loading is useful for determining dependencies among classes.
   - Trace Exceptions. Display exceptions caught.
   - Trace Method Calls. Reports methods called and returned. The output for this option is very verbose and it can affect performance.

3. (Optional) Verbose tracing output might cause you to run out of memory on the device before the application is fully tested. You can increase the device memory as follows:

   a. In the Properties window, go to the General section.
   
   b. Click **Heapsize** and select a size.
Using the Memory Monitor

Follow these steps to examine an application’s memory use.

**WARNING:** Do not suspend the emulator while using the memory monitor.

1. Right-click a project and select **Profile As...** and then **Memory Monitor** from the context menu.

   If the profiler is not yet integrated you are prompted to enable profiling for the project:

   a. Click Yes to continue.

   b. Select Memory Monitor in the Profile window that opens.

   The Console window tab is labeled "Memory Monitor" indicating that the memory monitor is active for this session. The Console window displays both application status and tracing outputs for this device.

2. Interact with the application as usual.

   In the Memory Monitor tab, you see displayed on the graph above and in the object table below.

   To the left of the graph you see the Current memory use in bytes. The green line plots these values. The red line is the maximum amount of memory used since program execution, corresponding to the Maximum size in bytes on the left.

   The object table columns are as follows:

   - Name. Object class name.
   - Total. Total number of objects allocated since the application began.
   - Total Size. Total amount of memory the object uses in bytes.
   - Average Size. Average object size in bytes, calculated by dividing the number of live instances by the total size.

   Beneath the table you see counters displaying the total number of objects, the amount of memory used, the amount of free memory, and the total amount of memory on the device.
3. Interact with the object table while the memory monitor is running.
   ■ Click a column header to sort the data. The sorting is case sensitive.
   ■ Click a row and the call stack tree is displayed in the window to the right of
     the table.
     – Click a folder to browse the call stacks tree to see the methods that create
       the object.
     – To find a particular method in the call stacks tree, click the Find button
       and enter a search string.
     – Click Refresh to update the call stacks tree as data is gathered. It is not
       refreshed automatically.
4. Take a snapshot of the memory monitor. Because the data changes rapidly it is
   convenient to take several snapshots and review them later.
   Click the File menu and select Save. Specify a file name and location for the
   monitor data. The automatically supplied extension is .mms.
5. Exit the application.
   Some applications contain multiple MIDlets.
   ■ When you exit a MIDlet the table data is cleared.
The graph data is not cleared when you exit a MIDlet. The graph data you see is cumulative for this emulator session. The memory monitor plots session data for any MIDlet run on the current emulator until you exit the application and close the emulator.

Saving and Viewing a Session Snapshot

You can take a snapshot of a current memory monitor session by clicking the File menu and selecting Save As... during the session. The file is saved as a .mms file.

Follow these steps to reload a memory monitor snapshot.

1. Click the File menu and select Open File....
2. Select an .mms file you saved.

   The memory monitor opens in its own tab in the main window. Note the tab displays the time the snapshot was taken.
This chapter describes how to work with sign MIDlets and work with MIDlet suite security. The Oracle Java ME SDK provides tools to sign MIDlet suites, manage keys, and manage root certificates.

MIDP 2.1 (JSR 118) includes a comprehensive security model based on protection domains. MIDlet suites are installed into a protection domain that determines access to protected functions. The MIDP 2.1 specification also includes a recommended practice for using public key cryptography to verify and authenticate MIDlet suites.

The general process to create a cryptographically signed MIDlet suite is as follows:

1. The MIDlet author, probably a software company, buys a signing key pair from a certificate authority (the CA).
2. The author signs the MIDlet suite with the signing key pair and distributes their certificate with the MIDlet suite.
3. When the MIDlet suite is installed on the emulator or on a device, the implementation verifies the author's certificate using its own copy of the CA's root certificate. Then it uses the author's certificate to verify the signature on the MIDlet suite.
4. After verification, the device or emulator installs the MIDlet suite into the security domain that is associated with the CA's root certificate.

For definitive information, consult the MIDP 2.1 specification:

http://download.oracle.com/otndocs/jcp/midp-2.1-mrel-oth-JSpec

See the following topics:

- "Security Domains"
- "Managing Keystores and Key Pairs"
- "Signing a Project With a Key Pair"

Security Domains

The SDK supports the following security domains:

- **minimum.** All permissions are denied to MIDlets in this domain.
- **maximum.** All permissions are granted to MIDlets in this domain. Maximum is the default setting.
- **unidentified_third_party.** Provides a high level of security for applications whose origins and authenticity cannot be determined. The user is prompted frequently when the application attempts a sensitive operation.
Setting Security Domains

identified_third_party. Intended for MIDlets whose origins were determined using cryptographic certificates. Permissions are not granted automatically, but the user is prompted less often than for the unidentified_third_party domain.

operator. All permissions are denied to MIDlets in this domain.

manufacturer. Intended for MIDlet suites whose credentials originate from the manufacturer’s root certificate.

Setting Security Domains

In the SDK, when you use Run Project via OTA your packaged MIDlet suite is installed directly into the emulator where it is placed in a security domain. The emulator uses public key cryptography to determine the appropriate security domain.

- If the MIDlet or MIDlet suite is not signed, it is placed in the default security domain.
- If the MIDlet or MIDlet suite is signed, it is placed in the protection domain that is associated with the root certificate of the signing key’s certificate chain. See the topic "Signing a Project”. See "Signing a Project With a Key Pair.”

If your project is a MIDlet suite, the entire suite is signed (the individual MIDlets contained within are not).

Specify the Security Domain for an Emulator

Follow these steps to specify the security domain for an emulated device.

1. Select the device in the device selector.
2. In the Properties Window, expand the General properties, and for the Security Domain option, select a domain from the dropdown list.

Specify the Security Domain for a Project

Follow these steps to set a MIDlet Suite’s security domain at runtime.

1. Right-click the package and select Run As > Run Configurations... from the context menu.
2. Select the project’s JAD file, then select the Emulation tab.
3. Specify the device and the security domain, and click Run.

You can also sign your MIDlet or IMlet with JADtool ("Sign MIDlet Suites (jadtool).”.

Signing a Project With a Key Pair

Devices use signing information to check an application’s source and validity before allowing it to access protected APIs. For test purposes, you can create a signing key pair to sign an application. A key pair consists of the following:

- A private key that is used to create a digital signature, or certificate.
- A public key that anyone can use to verify the authenticity of the digital signature.

You can create a key pair as described in "Managing Keystores and Key Pairs.”

Follow these steps to sign a Java ME package in Eclipse.

1. In the Package view right-click on a package and select Properties to open the Properties dialog.
2. In the Java ME category, select Signing. For help with this page, view the following help topic: Java ME Development User Guide > Reference > Property Pages > Java ME.

3. Click Enable project specific settings. Specify a keystore and a password option.

4. Click OK.

To obfuscate code, see "Obfuscating."

Managing Keystores and Key Pairs

The Oracle Java ME SDK command line tools described in "Manage Certificates (MEKeyTool)" manage an emulator’s list of root certificates.

Oracle Java ME SDK ships a default keystore named _main.ks in \installdir\runtimes\cldc-hi\appdb. This keystore is automatically copied from your installation’s default location to each instance of the default devices (the emulators). These instances are typically stored in:

\username\javame-sdk\3.4\work\devicename

External devices have similar lists of root certificates, although you typically cannot modify them. When you deploy your application on an external device, you must use signing keys issued by a certificate authority whose root certificate is present on the device. This makes it possible for the device to verify your application.

In Eclipse you can also use MTJ utilities to manage keystores as described in "Signing a Project With a Key Pair." You can also use the -import option to import certificates from these keystores as described in "Manage Certificates (MEKeyTool)."

Command Line Samples

This section is a summary of command line samples for keystore and certificate tasks. To find information on keytool, see:

http://docs.oracle.com/javase/7/docs/technotes/tools

These samples show literal paths on a sample system. You can replace the paths and options as you see fit. These samples contain line feeds to accommodate the book format. In practice they commands should be entered on a single line.

Generate a keypair.

As mentioned in "Managing Keystores and Key Pairs," Java ME includes a default keystore used for the emulators. For test purposes you can also make your own keypair containing a new keystore and a certificate. For example:

"C:\Program Files\Java\jdk1.6.0_35\bin\keytool" -genkeypair -alias mykp -keyalg RSA -keysize 1024 -validity 365 -dname "cn=dlp, L=Santa Clara, S=CA" -keypass 123456 -keystore D:/temp/mykeystore.ks -storepass 654321

List the keypair.

C:\Program Files\Java\jdk1.7.0_13\bin\keytool -list -alias mykp -keystore mykeystore.ks -storepass 654321

Export a certificate to a file.

C:\Program Files\Java\jdk1.7.0_13\bin\keytool -exportcert -alias mykp -keystore mykeystore.ks -storepass 654321 -file d:\temp\mykpcert
Print the certificate file.

C:\Program Files\Java\jdk1.7.0_13\bin\keytool -printcert -file d:\temp\mykpcert

Import the keystore (including your certificate) into the default keystore.

For a description of MEKeyTool, see "Manage Certificates (MEKeyTool)." In this example mekeytool is launched from the Oracle Java ME SDK installation bin directory.

mekeytool -import -alias mykp -keystore D:\temp\mykeystore.ks -MEkeystore D:\temp\_main.ks -storepass 654321
This topic describes how to operate the Oracle Java ME SDK from the command line and details the command line tools required to build and run an application.

- "Run the Device Manager"
- "Manage Device Addresses (device-address)"
- "Emulator Command Line Options"
- "Build a Project from the Command Line"
- "Packaging a MIDlet Suite (JAR and JAD)"
- "Command Line Security Features"
- "Generate Stubs (wscompile)"

### Run the Device Manager

The Device Manager is a component that runs as a service. It detects devices (real or emulated) that conform to the Unified Emulator Interface Specification (http://www.oracle.com/technetwork/java/javame/documentation/ueispecs-187994.pdf), version 1.0.2. The Device Manager automatically restarts every time you use the SDK. You can manually launch the Device Manager from a script or a command line.

```
installdir\bin\device-manager.exe
```

To see a log of activities, launch the Device Manager with the `-XenableOutput` option.

### Manage Device Addresses (device-address)

`installdir\bin\device-address` is a tool for viewing, adding, and removing devices that the SDK is not able to discover automatically. The Microsoft device emulator is an example of such a device. The syntax is:

<table>
<thead>
<tr>
<th>Command</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td><code>add address_type address</code></td>
<td>Add the specified address.</td>
</tr>
<tr>
<td><code>del address_type address</code></td>
<td>Delete the specified address.</td>
</tr>
<tr>
<td><code>list</code></td>
<td>List all addresses.</td>
</tr>
<tr>
<td><code>list address_type</code></td>
<td>List the address of the specified type.</td>
</tr>
</tbody>
</table>

Table 12–1  Device Address Commands
For example, the following command adds a device:

```
installdir\bin\device-address.exe add ip 192.168.1.2
```

**Emulator Command Line Options**

You can launch the emulator independent of the GUI using `bin\emulator`. The syntax is as follows:

```
emulator options
```

The general options are as follows:

**Table 12–2  Emulator Commands**

<table>
<thead>
<tr>
<th>Command</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>-classpath <code>path</code></td>
<td>Specifies a search path for application classes. The path consists of directories, ZIP files, and JAR files separated by semicolons.</td>
</tr>
<tr>
<td>-cp <code>path</code></td>
<td></td>
</tr>
<tr>
<td>-D <code>property=value</code></td>
<td>Sets a system property value.</td>
</tr>
<tr>
<td>-help</td>
<td>Display a list of valid options.</td>
</tr>
<tr>
<td>-version</td>
<td>Display version information about the emulator.</td>
</tr>
<tr>
<td>-Xdevice:<code>devicename</code></td>
<td>Run an application on the emulator using the given device instance name.</td>
</tr>
<tr>
<td>-Xquery</td>
<td>Print emulator skin information on the standard output stream and exit immediately. The information includes the skin name, screen size, and other capabilities.</td>
</tr>
</tbody>
</table>

This is a simple example of running the emulator from the command line:

```
emulator.exe -Xdescriptor:"C:\Program Files\Java_ME_platform_SDK_3.4\apps\Games\dist\Games.jad"
-Xdevice:JavaMEPhone2
```

`emulator.exe` also supports *"MIDlet Options"* and *"Debugging and Tracing Options."*

**MIDlet Options**

Options for running MIDlets in the emulator are as follows:

- **-Xautotest:`JAD-file-URL`**
  
  Run in autotest mode. This option installs a MIDlet suite from a URL, runs it, removes it, and repeats the process. The purpose is to run test compatibility kits (TCKs) with the emulator, using a test harness such as JT Harness ([http://jtharness.java.net](http://jtharness.java.net)), or Java Device Test Suite (JDTS [http://www.oracle.com/technetwork/java/javame/javadevice-140362.html](http://www.oracle.com/technetwork/java/javame/javadevice-140362.html)). For example:

  ```
  emulator -Xautotest:http://localhost:8080/test/getNextApp.jad
  ```

  Given the above command, `-Xautotest` causes the emulator to repeatedly install, run, and remove the first MIDlet from the MIDlet suite provided through the HTTP URL. When the emulator starts, it queries the test harness, which then downloads and installs the TCK MIDletAgent.

- **-Xdescriptor:`jad-file`**

  Install a MIDlet, run it, and uninstall it after it finishes.
-\texttt{Xdomain:domain-name}

Set the MIDlet suite's security domain.

The \texttt{Xjam} argument runs an application remotely using the Application Management Software (AMS) to run over-the-air (OTA) provisioning. If no application is specified with the argument, the graphical AMS is run.

- \texttt{-Xjam:[install=<JAD-file-url> | force | list | storageNames | run=[]<storageNames>|<StorageNumber>|remove=[]<storage name>|<storage number> | all]}

Installs the application with the specified JAD file onto a device.

- \texttt{force}. If an existing application has the same storage name as the application to be installed, \texttt{force} removes the existing application before installing the new application.

- \texttt{list}. List all the applications installed on the device and exit. The list is written to standard output before the emulator exits.

- \texttt{storageNames}. List all applications installed on the device. The list is written to standard output before the emulator exits. Each line contains one storage name in numerical order. The list contains only the name so the order is important. For example the first storage name must be storage number 1.

- \texttt{-Xjam:run=[]<storage-name>|<storage-number>}

Run a previously installed application. The application is specified by its valid storage name or storage number.

- \texttt{-Xjam:remove=[]<storage-name>|<storage-number>| all]}

Remove a previously installed application. The application is identified by its valid storage name or storage number. If \texttt{all} is supplied, all previously installed applications are removed.

- \texttt{-Xjamtransient=jad-file-url}

If specified, \texttt{transient} is an alias for installing, running, and removing the application with the specified JAD file.

This example illustrates OTA installation:

\begin{verbatim}
emulator -Xjam:install=http://www.myserver.com/apps/MyApp.jad
-Xdevice:JavaMEPhone2
\end{verbatim}

The above command returns the ID of the installed application. When you obtain the ID you can run it with: \texttt{emulator=Xjam:run=ID}

See also “Emulator Command Line Options” and “Debugging and Tracing Options.”

**Debugging and Tracing Options**

You can use the following options with the emulator for debugging and tracing CLDC projects.

- \texttt{-Xdebug}

  Enable runtime debugging. The \texttt{-Xrunjdwp} option must be called to support \texttt{-Xdebug}.

- \texttt{-Xrunjdwp:debug-settings}
Start a Java debug wire protocol session, as specified by a list of comma-separated debug settings. Both `-Xrunjdwp` and `-Xdebug` must be called.

Valid debug settings include the following:

- `transport=transport-mechanism` - Transport mechanism used to communicate with the debugger. The only transport mechanism supported is `dt_socket`.
- `address=host:port` - Transport address for the debugger connection. If `host` is omitted, `localhost` is assumed to be the host machine.
- `server={y|n}` - Starts the debug agent as a server. The debugger must connect to the port specified. The possible values are `y` and `n`. Currently, only `y` is supported (the emulator must act as a server).
- `suspend={y|n}` - The possible values are `y` and `n`.

When `suspend` is set to `n`, the application starts immediately and the debugger can be attached at any time during its run.

When `suspend` is set to `y`, the application does not start until a debugger attaches to the debugging port and sends a resume command, so an application can be debugged from the very beginning.

This example shows debugging:

```shell
emulator.exe -Xdevice:JavaMEPhone1 -Xdebug -Xrunjdwp:transport=dt_socket,suspend=n, server=y,address=51307 -Xdescriptor:..\apps\Games\dist\Games.jad -Xdomain:maximum
```

With the emulator running you can attach a debugger.

- To find more information on how to attach a command line debugger, see:
  ```http://docs.oracle.com/javase/6/docs/technotes/tools```

A sample command would be:

```shell
jdk/bin/jdb -connect
com.sun.jdi.SocketAttach:hostname=localhost,port=51307
```

### Command Line Profiling

To add profiling to an emulator session, use:

```shell
-Xprofile:[system={<y|n>},file=filename.prof
```

For example:

```shell
emulator.exe -Xdevice:JavaMEPhone1
-Xdescriptor:C:\username\My Documents\Projects\Games\dist\Games.jad
-Xprofile:file=C:\temp\Games.prof
```

### Build a Project from the Command Line

In the user interface, building a project is a single step. Behind the scenes, however, there are two steps. First, Java source files are compiled into Java class files. Next, the class files are `preverified`, which means they are prepared for the CLDC VM. See the following topics:

- "Check Prerequisites"
- "Compile Class Files"
- "Preverify Class Files"
Check Prerequisites

Before building and running an application from the command line, verify that the `jar` command is in your path. To find the version of the development kit, run `java -version` at the command line.

Compile Class Files

Use the `javac` compiler from the Java SE development kit to compile Java source files. You can use the existing Oracle Java ME SDK project directory structure. Use the `-bootclasspath` option to tell the compiler to use the MIDP APIs, and use the `-d` option to tell the compiler where to put the compiled class files.

The following example demonstrates how you might compile a MIDP 2.1 application, taking source files from the `src` directory and placing the class files in the `tmpclasses` directory. Newlines have been added for clarity.

```
javac -target 1.3 -source 1.3
  -bootclasspath ..\.\lib\cldc_10.jar;..\.\lib\midp2.1.jar
  -d tmpclasses
  src\*.java
```

For more information on `javac`, consult the Java SE documentation.

Preverify Class Files

The next step is to preverify the class files. The `bin` directory of the Oracle Java ME SDK includes the `preverify` utility. The syntax for the `preverify` command is as follows:

```
preverify files | directories
```

Some of the options are as follows:

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><code>-classpath</code></td>
<td>Specify the directories or JAR files (given as a semicolon-delimited list)</td>
</tr>
<tr>
<td><code>classpath</code></td>
<td>from which classes are loaded.</td>
</tr>
<tr>
<td><code>-d</code></td>
<td>Specify the target directory for the output classes. This directory</td>
</tr>
<tr>
<td><code>output-directory</code></td>
<td>must exist before preverifying. If this option is not used, the preverifier</td>
</tr>
<tr>
<td></td>
<td>places the classes in a directory called <code>output</code>.</td>
</tr>
</tbody>
</table>

Following the example for compiling, use the following command to verify the compiled class files. As before, newlines are added for clarity.

```
preverify.exe
  -classpath ..\.\lib\cldcapi10.jar;..\.\lib\midpapi20.jar
  -d classes
  tmpclasses
```

As a result of this command, preverified class files are placed in the `classes` directory. If your application uses WMA, MMAPI, or other versions of CLDC or MIDP, be sure to include the relevant `.jar` files in the classpath.
Packaging a MIDlet Suite (JAR and JAD)

To package a MIDlet suite manually you must create a manifest file, an application JAR file, and finally, a MIDlet descriptor (also known as a Java Application Descriptor or JAD).

Create a manifest file containing the appropriate attributes as specified in the MIDP specification. You can use any text editor to create the manifest file. For example, a manifest might have the following contents:

```plaintext
MIDlet-1: My MIDlet, MyMIDlet.png, MyMIDlet
MIDlet-Name: MyMIDlet
MIDlet-Vendor: My Organization
MIDlet-Version: 1.0
MicroEdition-Configuration: CLDC-1.1
MicroEdition-Profile: MIDP-2.1
```

Create a JAR file containing the manifest and the suite's classes and resource files. To create the JAR file, use the `jar` tool that comes with the Java SE software development kit. The syntax is as follows:

```
jar cfm file manifest -C class-directory . -C resource-directory .
```

The arguments are as follows:

- `file` - JAR file to create.
- `manifest` - Manifest file for the MIDlets.
- `class-directory` - Directory containing the application's classes.
- `resource-directory` - Directory containing the application's resources.

For example, to create a JAR file named `MyApp.jar` whose classes are in the `classes` directory and resources are in the `res` directory, use the following command:

```
jar cfm MyApp.jar MANIFEST.MF -C classes . -C res .
```

Create a JAD file containing the appropriate attributes as specified in the MIDP specification. You can use any text editor to create the JAD file. This file must have the extension `.jad`.

For example, a JAD file might have the following contents:

```plaintext
MIDlet-Name: MyMIDlet
MIDlet-Vendor: My Organization
MIDlet-Version: 1.0
MIDlet-Jar-URL: MyApp.jar
MIDlet-Jar-Size: 24601
```

Command Line Security Features

The full spectrum of the Oracle Java ME SDK's security features are also available from the command line. You can adjust the emulator’s default protection domain, sign MIDlet suites, and manage certificates.

- "Change the Default Protection Domain"
Change the Default Protection Domain

To adjust the emulator's default protection domain, use the following option with the emulator command:

\[-X\text{domain:domain-type}\]

Assigns a security domain to the MIDlet suite. Enter an appropriate security domain as described in "Security Domains.". For example, \(-X\text{domain:maximum}\).

Sign MIDlet Suites (jadtool)

\textit{jadtool} is a command-line interface for signing MIDlet suites using public key cryptography according to the MIDP 2.1 specification. Signing a MIDlet suite is the process of adding the signer certificates and the digital signature of the JAR file to a JAD file.

\textit{jadtool} only uses certificates and keys from Java SE platform keystores. Java SE software provides \textit{keytool}, the command-line tool to manage Java SE platform keystores.

\textit{jadtool} is packaged in a JAR file. To run it, open a command prompt, change the current directory to \textit{installdir/bin}, and enter the following command:

\texttt{jadtool \textit{command}}

The commands are as follows:

- \texttt{-help}
  
  Prints the usage instructions for \textit{jadtool}.

- \texttt{-addcert -alias key alias [-storepass password] [-keystore keystore] [-certnum number] [-chainnum number] [-encoding encoding] -inputjad filename -outputjad filename}
  
  Adds the certificate of the key pair from the given keystore to the JAD file or JPP file.

- \texttt{-addjarsig [-jarfile filename] -keypass password -alias key alias -storepass password [-keystore keystore] [-chainnum number] [-encoding encoding] -inputjad filename -outputjad filename}
  
  Adds a digital signature of the input JPP file to the specified output JPP file.

- \texttt{-showcert [<[-certnum number] [-chainnum number]> | [-all]] [-encoding encoding] -inputjad filename}
  
  Displays information about certificates in JAD files.

The default values are as follows:

- \texttt{-encoding UTF-8}
- \texttt{-jarfile MIDlet-Jar-URL property in the JAD file}
- \texttt{-keystore $HOME/.keystore}
- \texttt{-certnum -1}
- \texttt{-chainnum -1}
Manage Certificates (MEKeyTool)

MEKeyTool manages the public keys of certificate authorities (CAs), making it functionally similar to the keytool utility that comes with the Java SE SDK. The purpose of the keys is to facilitate secure HTTP communication over SSL (HTTPS).

Before using MEKeyTool, you must first have access to a Java Cryptography Extension keystore. You can create one using the Java SE keytool utility (found in the \bin directory for your JDK). For more information on keytool, see:

http://docs.oracle.com/javase/7/docs/technotes/tools

To run MEKeyTool, open a command prompt, change the current directory to installdir\bin, and enter the following command:

installdir\bin\mekeytool.exe -command

The command keywords follow.

The Oracle Java ME SDK contains a default ME keystore named _main.ks, which is located in:

installdir\runtimes\cldc-hi\appdb

This keystore includes all the certificates that exist in the default Java SE platform keystore that comes with the Java SE installation.

Also, each emulator instance has its own _main.ks file located in username\javame-sdk\3.4\work\devicename\appdb. If you do not specify a value for MEkeystore, a new key is added to the default ME key for this emulator instance.

If you do not specify a value for -keystore, the default keystore is used:

username\keystore.ks

- help
  Prints the usage instructions for MEKeyTool.

- import -alias alias [-keystore JCEkeystore][-MEkeystore filename]
  [-storepass storepass] [-domain domain-name]

  Imports a public key into the ME keystore from the given JCE keystore using the given Java Cryptography Extension keystore password. and the default Java Cryptography Extension keystore is username\.keystore.

- list [-MEkeystore filename]

  Lists the keys in the ME keystore, including the owner and validity period for each.

- delete (-owner owner | -number key-number)[-MEkeystore filename]

  Deletes a key from the given ME keystore with the given owner.

Generate Stubs (wscompile)

Mobile clients can use the Stub Generator to access web services. The wscompile tool generates stubs, ties, serializers, and WSDL files used in Java API for XML (JAX) RPC clients and services. The tool reads a configuration file, that specifies either a WSDL file, a model file, or a compiled service endpoint interface. The syntax for the stub generator command is as follows:

wscompile [options] configuration-files

Table 12–4 lists the wscompile options:
Table 12–4  \texttt{wscompile} Options

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>\texttt{-gen}</td>
<td>Same as \texttt{-gen:client}</td>
</tr>
<tr>
<td>\texttt{-gen:client}</td>
<td>Generates client artifacts (stubs, etc.)</td>
</tr>
<tr>
<td>\texttt{-import}</td>
<td>Generates interfaces and value types only</td>
</tr>
<tr>
<td>\texttt{-d output directory}</td>
<td>Specifies where to place generated output files</td>
</tr>
<tr>
<td>\texttt{-f:features}</td>
<td>Enables the given features</td>
</tr>
<tr>
<td>\texttt{-g}</td>
<td>Generates debugging info</td>
</tr>
<tr>
<td>\texttt{-features:features}</td>
<td>Same as \texttt{-f:features}</td>
</tr>
<tr>
<td>\texttt{-httpproxy:host:port}</td>
<td>Specifies a HTTP proxy server (port defaults to 8080)</td>
</tr>
<tr>
<td>\texttt{-model file}</td>
<td>Writes the internal model to the given file</td>
</tr>
<tr>
<td>\texttt{-0}</td>
<td>Optimizes generated code</td>
</tr>
<tr>
<td>\texttt{-s directory}</td>
<td>Specifies where to place generated source files</td>
</tr>
<tr>
<td>\texttt{-verbose}</td>
<td>Outputs messages about what the compiler is doing</td>
</tr>
<tr>
<td>\texttt{-version}</td>
<td>Prints version information</td>
</tr>
<tr>
<td>\texttt{-clldc1.0}</td>
<td>Sets the CLDC version to 1.0 (default). Float and double become String.</td>
</tr>
<tr>
<td>\texttt{-clldc1.1}</td>
<td>Sets the CLDC version to 1.1 (float and double are OK)</td>
</tr>
<tr>
<td>\texttt{-clldc1.0info}</td>
<td>Shows all CLDC 1.0 information and warning messages.</td>
</tr>
</tbody>
</table>

\textbf{Note:} Exactly one \texttt{-gen} option must be specified. The \texttt{-f} option requires a comma-separated list of features.

Table 12–5 lists the features (delimited by commas) that can follow the \texttt{-f} option. The \texttt{wscompile} tool reads a WSDL file, compiled service endpoint interface (SEI), or model file as input. The Type of File column indicates which of these files is used with a particular feature.

Table 12–5  \texttt{Command Supported Features (-f) for wscompile}  

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
<th>Type of File</th>
</tr>
</thead>
<tbody>
<tr>
<td>explicitcontext</td>
<td>Turns on explicit service context mapping</td>
<td>WSDL</td>
</tr>
<tr>
<td>nodatabinding</td>
<td>Turns off data binding for literal encoding</td>
<td>WSDL</td>
</tr>
<tr>
<td>noencodedtypes</td>
<td>Turns off encoding type information</td>
<td>WSDL, SEI, model</td>
</tr>
<tr>
<td>nomultirefs</td>
<td>Turns off support for multiple references</td>
<td>WSDL, SEI, model</td>
</tr>
<tr>
<td>novalidation</td>
<td>Turns off full validation of imported WSDL documents</td>
<td>WSDL</td>
</tr>
<tr>
<td>searchschema</td>
<td>Searches schema aggressively for subtypes</td>
<td>WSDL</td>
</tr>
<tr>
<td>serializeinterfaces</td>
<td>Turns on direct serialization of interface types</td>
<td>WSDL, SEI, model</td>
</tr>
<tr>
<td>wsi</td>
<td>Enables WSI-Basic Profile features (default)</td>
<td>WSDL</td>
</tr>
<tr>
<td>resolveidref</td>
<td>Resolves \texttt{xsd:IDREF}</td>
<td>WSDL</td>
</tr>
<tr>
<td>donotunwrap</td>
<td>No unwrap.</td>
<td>WSDL</td>
</tr>
</tbody>
</table>
Examples

wscompile -gen -d generated config.xml
wscompile -gen -fnounwrap -O -cldc1.1 -d generated config.xml
This chapter describes how to use the Oracle Java ME SDK log4j logging facility to manage Device Manager and Device Instance logs.

Logging levels in the logging facility are configurable using XML files.

### Device Manager Logs

The Device Manager log is placed into:

```
username\javame-sdk\3.4\work\devicename\device-manager.log
```

You can configure logging levels in the following XML file:

```
installdir\toolkit-lib\process\device-manager\conf\log4j.xml
```

A priority value for the categories `com.sun` or `VM` can be set to the following levels: `FATAL, ERROR, WARN, INFO, DEBUG, TRACE` (ordered from least to most verbose).

#### Example 13–1 Setting a Category Value

```xml
<category name="com.sun">
  <priority value="DEBUG"/>
  <appender-ref ref="CONSOLE-ALL"/>
  <appender-ref ref="FILE"/>
</category>

<category name="VM">
  <priority value="INFO"/>
  <appender-ref ref="CONSOLE-ALL"/>
  <appender-ref ref="FILE"/>
</category>
```

### Device Instance Logs

Each device (or emulator) instance writes its own log into its directory.

```
username\javame-sdk\3.4\work\devicename\device.log
```

`log4j.xml` controls the verbosity of the device instance logs, as described in "Device Manager Logs."
The Oracle Java ME SDK supports many standard Application Programming Interfaces (APIs) defined through the Java Community Process (JCP) program. JCP APIs are often referred to as JSRs, named after the Java Specification Request process. This chapter describes the JSRs available in Oracle Java ME SDK.

The CLDC/MIDP platform is based on the Mobile Information Device Profile and Connected Limited Device Configuration (JSRs 118 and 139).

The IMP-NG platform is based on Information Module Profile - Next Generation (IMP-NG) (JSR 228).

See Table 14–1 for a full list of supported JCP APIs. The Oracle Java ME SDK provides documentation describing how certain APIs are implemented in the SDK. Many supported APIs do not require special implementation considerations, so they are not discussed in this help set. "Oracle APIs" describes Oracle APIs provided to support the IMP-NG platform.

For convenience the Javadoc files that are the intellectual property of Oracle are in your installation’s \docs directory. The remainder can be downloaded from http://jcp.org.

### JCP APIs

<table>
<thead>
<tr>
<th>JSR, API</th>
<th>Support Description</th>
<th>URL</th>
</tr>
</thead>
<tbody>
<tr>
<td>JSR 75, PIM and File</td>
<td>PDA Optional Packages for the J2ME Platform</td>
<td><a href="http://jcp.org/en/jsr/detail?id=75">http://jcp.org/en/jsr/detail?id=75</a></td>
</tr>
<tr>
<td>JSR 82, Bluetooth and OBEX</td>
<td>Java APIs for Bluetooth</td>
<td><a href="http://jcp.org/en/jsr/detail?id=82">http://jcp.org/en/jsr/detail?id=82</a></td>
</tr>
<tr>
<td>JSR 118, MIDP 2.1</td>
<td>Mobile Information Device Profile</td>
<td><a href="http://jcp.org/en/jsr/detail?id=118">http://jcp.org/en/jsr/detail?id=118</a></td>
</tr>
<tr>
<td>JSR 139, CLDC 1.1</td>
<td>Connected Limited Device Configuration</td>
<td><a href="http://jcp.org/en/jsr/detail?id=139">http://jcp.org/en/jsr/detail?id=139</a></td>
</tr>
</tbody>
</table>
Oracle APIs

The IMP-NG project type supports developing applications for the Oracle Java ME Embedded 3.4 runtime. The Java ME Embedded 3.4 runtime includes a number of standard JSR APIs as well as additional Oracle APIs for embedded use cases. These new APIs are:

- **Device Access API**
  
The Device Access API provides interfaces and classes for communicating with and controlling peripheral devices.

- **Logging API**
  
The Logging API provides a lightweight and extensible framework based on the concepts of the java.util.logging package, enabling applications to log messages in a variety of formats and using custom handlers.

- **AMS API**

---

**Table 14–1 (Cont.) Supported JCP APIs**

<table>
<thead>
<tr>
<th>JSR, API</th>
<th>Name, URL</th>
</tr>
</thead>
<tbody>
<tr>
<td>JSR 228, IMP-NG</td>
<td>Information Module Profile - Next Generation (IMP-NG) <a href="http://jcp.org/en/jsr/detail?id=228">http://jcp.org/en/jsr/detail?id=228</a></td>
</tr>
</tbody>
</table>
The AMS API provides an interface to the application management capabilities of the runtime to allow authorized applications to interact with and extend the application management system.

- AccessPoint API

The AccessPoint API is an extension to the Generic Connection Framework and enables applications to select among multiple access points if the underlying platform provides more than one data access point.

The Javadoc files for these APIs are in your installation’s \docs directory.
The Oracle Java ME SDK supports JSR 75, the PDA Optional Packages (PDAP). This chapter describes how the Oracle Java ME SDK implements JSR 75.

JSR 75 includes two independent APIs:
- The FileConnection optional package allows MIDlets access to a local device file system.
- The Personal Information Management (PIM) optional package includes APIs for manipulating contact lists (address book), calendars, and to-do lists.

**FileConnection API**

On an external device, the FileConnection API typically provides access to files stored in the device’s memory or on a memory card.

In the Oracle Java ME SDK emulator, the FileConnection API enables MIDlets to access files stored on your computer’s hard disk.

The files that can be accessed using the FileConnection optional package are stored in the following subdirectory:

```
username\javame-sdk\3.4\work\devicename\appdb\filesystem
```

For example, the JavaMEPhone1 emulator instance comes with a root directory installed named root1. Each subdirectory of filesystem is called a root. The Oracle Java ME SDK provides a mechanism for managing roots.

While the emulator is running, click the Tools menu and select Manage File System. The Manage File System dialog box opens.

In the Mounted File System Root Directories panel you can mount, unmount, or unmount and delete filesystem roots. Mounted roots are displayed in the top list, and unmounted roots are listed in the Unmounted File System Root Directories panel. You can remount or delete a selected directory. Mounted root directories and their subdirectories are available to applications using the FileConnection API. Unmounted roots can be remounted in the future.

- To add a new empty filesystem root directory, click Mount Empty... and fill in a name for the directory.
- To mount a copy of an existing directory, click Mount Copy..., and browse to select a directory you want to copy. When the File System Root Entry dialog opens, enter the name for this root. A deep copy of the selected directory is placed into the emulator’s filesystem with the specified root name.
To make a directory inaccessible to the FileConnection API, select it in the list and click Unmount. The selected root is unmounted and moved to the Unmounted roots list.

To completely remove a mounted directory, select it and click Unmount & Delete.

To remount an unmounted directory, select it and click Remount. The root is moved to the mounted roots list.

To delete an unmounted directory, select it and click Delete. The selected root is removed from the list.

PIM API

The Oracle Java ME SDK emulator stores contact, calendar, and to-do information in standard files on your desktop computer's hard disk. All information is stored in:

```
username\javame-sdk\3.4\work\devicename\appdb\PIM
```

Each device instance has its own data. Lists are stored in subdirectories of the contacts, events, and todo directories. For example, a contact list called Contacts is contained in:

```
username\javame-sdk\3.4\work\devicename\appdb\PIM\contacts\Contacts
```

Inside the list directory, items are stored in vCard (.vcf) or vCalendar (.vcs) format (see [http://www.imc.org/pdi/](http://www.imc.org/pdi/)). Contacts are stored in vCard format, while calendar and to-do items are both stored in vCalendar format.

Running PDAPDemo

PDAPDemo shows how to use the PIM and FileConnection APIs that are part of the JSR 75 specification.

Browsing Files

The default emulators have one directory, root1. This directory is located at:

```
username\javame-sdk\3.4\work\devicename\appdb\filesystem\root1
```

For test purposes, copy files or even directories into root1. You can also add other directories at the same level as root1.

Now open and run the PDAPDemo project.

- Launch the FileBrowser MIDlet. You see a directory listing, and you can browse through the directories and files you have placed there.
- Select a directory and press the View soft button to enter it.
- Using the Menu commands you can view a file or see its properties. Try selecting the file and choosing Properties or View from the menu. You can view the content of text files in the browser.
- Try using the External Events Generator to unmount and mount directories. Unmounted directories are not visible in the application running on the emulator.

The PIM API

The JSR75 PIM APIs example demonstrates how to access personal information, such as contact lists, calendars, and to-do lists.
■ After you launch the example, select a type of list from the main menu.
In this example each type of list works the same way and each list type contains a single list. For example, if you select Contact Lists, there is a single contact list called Contacts. Event Lists contains a single list called Events, and To-Do Lists contains a single list named To Do.

■ After you have selected a list type and chosen the specific list, you can view all the items in the list. If this is the first time you have run the example, the list might be empty.

■ To add an item, select New from the menu. The application prompts you for a Formatted Name for the item.
To add more data fields to this item select the menu item Add Field. You see a list of field names. Pick as many as you like. You can fill in the fields at any time.

■ To save the new item, select Commit from the menu.
To return to the list, select the Back command. You can see the item you just created in the list.

The items that you create are stored in standard vCard or vCalendar format in this directory:

```
username\javame-sdk\3.4\work\devicename\appdb\PIM
```

The PIM API allows for exporting contact, calendar, and to-do items in a standard format. The exact format depends on the list type. When you are viewing an item in any list, the menu contains a command for viewing the exported item.

For example, when you are viewing a contact list item, the menu contains Show vCard. When you select this command, the exported item is shown on the screen. Calendar items and to-do items both get exported as vCalendar.
Running PDAPDemo
This chapter describes how the Oracle Java ME SDK implements the Bluetooth and OBEX APIs.

The Oracle Java ME SDK emulator supports JSR 82, the Java APIs for Bluetooth. The emulator is fully compliant with version 1.1 of the specification, which describes integration with the push registry. JSR 82 includes two independent APIs:

- The Bluetooth API provides an interface to Bluetooth wireless networking, including device discovery and data exchange.
  
The Oracle Java ME SDK emulator enables you to develop and test applications that use Bluetooth without having actual Bluetooth hardware. The SDK simulates a Bluetooth environment for running emulators. Multiple emulator instances can discover each other and exchange data using the Bluetooth API.

  For an example, see "Running the Bluetooth Demo."

- The OBEX API allows applications to use the Object Exchange (OBEX) protocol over Bluetooth or other communication channels.
  
The Oracle Java ME SDK implements OBEX transfer over simulated Bluetooth and TCP connections.

  For an example, see "Running the OBEX Demo."

### Setting OBEX and Bluetooth Properties

The Oracle Java ME SDK enables you to configure the Bluetooth and OBEX simulation environment. Because the simulation requires a sender and receiver, Bluetooth settings are configured separately for each device. Follow these steps to set device properties.

1. In the device selector, double-check on a CLDC device.

   The device properties are displayed in the Properties pane.

2. Scroll down to see the Bluetooth and OBEX properties. When you click a property a description is shown in the description area.

The System Properties can be retrieved in an application using the `getProperty()` method in `javax.bluetooth.LocalDevice`. The Bluetooth properties are fully described in the JSR 82 specification.

- **Bluetooth Enabled**

  Enable or disable state of Bluetooth functionality

- **Bluetooth Address**

  The Bluetooth address of this device.
■ **Friendly Name**  
Human-readable name of the device

■ **bluetooth.sd.trans.max**  
The maximum number of concurrent service discovery transactions. The default is 8.

■ **bluetooth.sd.attr.retrievable.max**  
The maximum number of service attributes to be retrieved per service record. The default is 16.

■ **bluetooth.master.switch**  
Enable or disable a master or slave switch. Enabled by default.

■ **bluetooth.l2cap.receiveMTU.max**  
The maximum ReceiveMTU size in bytes supported in L2CAP. This is the maximum payload size this connection can accept.  
The default value is 672.

■ **OBEX Maximum Packet Length**  
The default is 4096 bytes.  
The maximum packet length affects how much data is sent in each packet between emulators. Shorter packet values result in more packets and more packet overhead.

■ **Device is discoverable**  
Enabled by default.

■ **Authentication is enabled**  
Enabled by default.

■ **Encryption is enabled**  
Enabled by default.

■ **Authorization is enabled**  
Enabled by default.

---

**Running the Bluetooth Demo**

This application contains MIDlets that demonstrate the use of JSR 82's Bluetooth API. It shows how images can be transferred between devices using Bluetooth.

You must run two emulator instances to see this process, and each device must have a different phone number.

1. Use JavaMEPhone1 to launch Bluetooth Demo, then launch Bluetooth Demo on JavaMEPhone2.

2. The demo gives you a choice of Server or Client.

3. On the first emulator, highlight Server and use the right soft button to select OK.  
The server starts and displays a list of images. At the beginning, none of the images are available on the Bluetooth network.  
Select the image you want to make available.
Press Publish image (the right soft button). The icon color changes from purple to green, indicating it is published.

4. On the second emulator running the Bluetooth Demo, highlight Client and select OK. The MIDlet displays "Ready for images search". Click the Find soft button. The MIDlet finds the other emulator and gets a list of published images. Select one from the list and select Load.

- If you run the demonstration in a trusted protection domain, the image is transferred using simulated Bluetooth and is shown on the client emulator.
- If you are not running in a trusted protection domain, the first emulator (the server) displays a prompt asking if you want to authorize the connection from the client. Select Yes. The image is displayed in the client emulator.

Running the OBEX Demo

This application shows how to transfer image files between emulator instances using the OBEX API. This demonstration shows the use of OBEX over a simulated infrared connection.

1. Launch two instances of the emulator. One listens for incoming connections, while the other attempts to send an image.

   For example, right-click ObexDemo, select Run With and select the device JavaMEPhone1. Repeat and select JavaMEPhone2.

2. In the first emulator, select Receive Image. (Depending on your security level, the application warns that an OBEX connection allows other devices to talk to yours and asks, "Is it OK to make the connection?" Select Yes.) Click Start to run the application. The listener emulator displays a screen reading "Waiting for connection."

3. In the second emulator (the sender), select Send Image and press the Start soft key. Select an image from the list and select Send. (Depending on your security level, the application warns that the demo wants to make an outgoing client connection, and asks if it is OK. Select Yes.) The Send Image utility uploads the image.

4. In the listening emulator, the utility displays information about the incoming image and asks "Would you like to receive it?" Select Yes.

   The image you selected is transferred over the simulated infrared link and displayed on the first emulator.
JSR 135, the Mobile Media API (MMAPI), provides a standard API for rendering and capturing time-based media, like audio or video. The API is designed to be flexible given the media formats, protocols, and features supported by various devices.

See the following topics:

- "Media Types"
- "MMAPI MIDlet Behavior"
- "Ring Tones"
- "Running AudioDemo"
- "Running MMAPIDemos"

For information on programming with MMAPI, see the following article:


### Media Types

The emulator's MMAPI implementation supports the following media types.

<table>
<thead>
<tr>
<th>MIME Type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>audio/amr*</td>
<td>Adaptive Multi-Rate Narrow Band</td>
</tr>
<tr>
<td>audio/midi</td>
<td>MIDI files</td>
</tr>
<tr>
<td>audio/mpeg*</td>
<td>MP3 files</td>
</tr>
<tr>
<td>audio/mp4*</td>
<td>MP4 Audio files</td>
</tr>
<tr>
<td>audio/sp-midi</td>
<td>Scalable Polyphony MIDI</td>
</tr>
<tr>
<td>audio/x-tone-seq</td>
<td>MIDP 2.1 tone sequence</td>
</tr>
<tr>
<td>audio/x-wav*</td>
<td>WAV PCM sampled audio</td>
</tr>
<tr>
<td>image/gif</td>
<td>GIF 89a (animated GIF)</td>
</tr>
<tr>
<td>video/3gpp*</td>
<td>Third generation mobile broadband with video</td>
</tr>
<tr>
<td>video/mpeg*</td>
<td>MPEG video</td>
</tr>
<tr>
<td>video/mp4*</td>
<td>MP4 video files</td>
</tr>
<tr>
<td>video/avi*</td>
<td>Video capture emulation and Audio-Video Interleaved files</td>
</tr>
</tbody>
</table>
In the previous table, an asterisk (*) indicates a media type that requires corresponding DirectShow filters to be installed on your system. For example, MP3 support might require an MP3 Splitter and an MP3 Decoder (these might be two separate DirectShow filters, or they might be combined in one filter). You can use any appropriate filter, but Oracle Java ME SDK 3.4 has only been tested with filters from the K-Lite Mega Codec Pack 4.8.0. If no appropriate DirectShow filters are found on your system, JSR 135 Player creation for the media type might fail.

Media Capture

The Oracle Java ME SDK emulator supports audio and video capture. Audio capture is supported using the capture capabilities of the system upon which the emulator runs.

Video capture is supported by simulating a camera input.

Consult the `MMAPI Demo` example application for details and source code that demonstrates how to capture audio and video.

MMAPI MIDlet Behavior

MIDlets have a lifecycle that is defined in the MIDP specification. MIDlets can be paused by events such as incoming phone calls. A well-behaved MIDlet releases important device resources when it is paused and reallocates or restarts those resources when the MIDlet is resumed. In the MMAPI arena, stop any Players that are rendering content when a MIDlet is paused.

The Oracle Java ME SDK prints a message to the console if you pause a MIDlet and it does not stop its running Players. You can test this feature using the Pausing Audio Test MIDlet.

The warning message is printed only once for each running emulator.

Ring Tones

MMAPI plays ring tones, as demonstrated in "Simple Tones" and "Simple Player." The ring tone formats mentioned here are in common use. You can download ring tones or create your own.

Download Ring Tones

Ring tone files can be downloaded from many internet sites, including the following:

- [http://www.phonezoo.com](http://www.phonezoo.com)

Ring Tone Formats

This section provides samples of several formats

- RTTTL, the Ringing Tones text transfer language format, is explained at [http://en.wikipedia.org/wiki/Ring_Tone_Transfer_Language](http://en.wikipedia.org/wiki/Ring_Tone_Transfer_Language)
- Nokia Composer
  
  This is a rendition of Beethoven's 9th symphony in Nokia Composer format:

  `16g1,16g1,16g1,4#d1,16f1,16f1,16f1,4d1,16g1,16g1,16g1,16g1,16#d1,`
16#g1,16#g1,16#g1,16g1,16#d2,16#d2,16#d2,4c2,16g1,16g1,16g1,
16d1,16#g1,16#g1,16#g1,16g1,16f2,16f2,16f2,4d2

- **Ericsson Composer**
  
  *Beethoven's Minuet in G:*
  
  a b c b + c b + C p + d a B p + c g A
  p f g a g a g A p b f G p a e F
  
  *Beethoven's 9th symphony theme:*
  
  f f f # C # d # d C p f f f # c # f + # c + # c + # c # A
  f f c # f # f f + # d + # d + #

- **Siemens Composer Format**
  
  *Inspector Gadget theme:*
  
  C2(1/8) D2(1/16) Dis2(1/8) F2(1/16) G2(1/8)
  P(1/16) Dis2(1/8) P(1/16) Fis2(1/8) P(1/16)
  D2(1/8) P(1/16) F2(1/8) P(1/16) Dis2(1/8)
  P(1/16) C2(1/8) D2(1/16) Dis2(1/8) F2(1/16)
  G2(1/8) P(1/16) C3(1/8) P(1/16) B2(1/2) P(1/4)
  C2(1/8) D2(1/16) Dis2(1/8) F2(1/16) G2(1/8) P(1/16)
  Dis2(1/8) P(1/16) Fis2(1/8) P(1/16) D2(1/8) P(1/16)
  F2(1/8) P(1/16) Dis2(1/8) P(1/16) C3(1/8) B2(1/16)
  Ais2(1/8) A2(1/16) Gis2(1/2) G2(1/8) P(1/16) C3(1/2)

- **Motorola Composer**
  
  *Beethoven's 9th symphony:*
  
  4 F2 F2 F2 C#4 D#2 D#2 C4 R2 F2 F2 F2 C#2 F#2 F#2
  F#2 F2 C#+2 C#+2 C#+2 A#4 F2 F2 F2 C2 F#2 F#2 F#2 F2
  D#+2 D#+2 D#+2

- **Panasonic Composer**
  
  *Beethoven's 9th symphony:*
  
  444** 444** 444** 444** 444** 444** 444** 111*
  0** 444** 444** 444** 444** 444** 444**
  444** 11** 11** 11** 11** 6666* 444** 444** 444** 444** 111**
  444** 444** 444** 444** 444** 22** 22** 22**

- **Sony Composer**
  
  *Beethoven's 9th symphony:*
  
  444****444****444****111#####4444###4444###4444****
  111#####(JD)0000444****4444###4444###4444#####
  44444444#####4444###111#####4444###6666#####
  44444444#####4444###111#####4444###4444#####
Running AudioDemo

Demonstrates audio capabilities, including mixing and playing audio with an animation. Select a MIDlet from the list, and from the menu, select 1, Launch.

- Audio Player. Select a sound clip and press the Play soft button. Click Back to return to the list of clips.
- Bouncing Ball. Select No Background and press the Play soft button. Two balls randomly bounce in the screen, emitting a tone whenever they contact a wall. Wave background, tone seq background, and MIDI background play the same two-ball audio visual sequence with the additional audio background.
- Mix Demo shows that different audio formats can play simultaneously. Select a MIDlet and press the Play soft button.
  - Tone+Wav - The audio clip starts playing and the Tone soft button is displayed. Press the Tone to hear a tone playing over the original audio clip.
  - Tone+ToneSeq - The audio clip starts playing and the Tone soft button is displayed. Press the Tone to hear a tone playing over the original audio clip.
  - ToneSeq+Wav - The tone sequence and the wav sequence play simultaneously. Press the Pause to interrupt, and press Play to resume.

Running MMAPIDemos

The MMAPIDemos application contains four MIDlets that showcase the SDK’s multimedia capabilities.

Simple Tones

Simple Tones demonstrates how to use interactive synthetic tones. Select a sample, then click Play on the lower right.

- Short Single Tone and Long Single Tone use Manager.playTone() to play tones with different pitch.
- Short MIDI event plays a chord on the interactive MIDI device (locator "device://midi"). The shortMidiEvent() method of MIDIControl is used to trigger the notes of the chord.
- To run the MMAPI Drummer demo, click or type number keys (0-9). Each number plays a different sound.

Simple Player

The Simple Player application demonstrates the range of audio and video capabilities of the emulator. It includes sample files in a variety of formats and can play files from the emulator’s persistent storage or from HTTP URLs.

The player portion uses a generic javax.microedition.media.Player interface. The player displays duration, media time, and controls for running the media file. If metadata is available in a file, the player enables you to view the information, such as author and title. In the case of MIDI files, if karaoke text is present in the file, it displays on the screen during play. Graphical user interface controls can be viewed on the display screen if applicable. You can access these controls by selecting one of the
media samples in Simple Player, then pressing the Menu button to view and select the desired command.

Select Simple Player then click Launch. The demo includes the following media samples:

- **Bong** plays a short WAV file. You can adjust certain playback features, as described later in this document. The display shows the duration of the sound in minutes:seconds.hundredths of a second, for example 00:01.04. This audio sample is a resource file in the MIDlet suite JAR file.

- **MIDI Scale** plays a sample musical scale. The display shows the title of the selected music file, the duration of the song, the elapsed time during playback, and the current tempo in beats per minute (bpm). This MIDI file is stored in the MIDlet suite JAR file.

- **Simple Ring Tone** plays a short sequence of Beethoven’s Fifth Symphony. The display shows the title of the selected music file, the duration of the song, the elapsed time in seconds and tenths of a second during playback, and the current tempo in beats per minute (bpm). This ring tone file (.jts format) is stored in the MIDlet suite JAR file.

- **WAV Music** plays a brief audio file. The display shows the title of the audio file, the duration of the audio the elapsed time during playback, and the playback rate in percent. This WAV file is retrieved from an HTTP server.

- **MIDI Scale** plays a MIDI file that is retrieved from an HTTP server.

- **The Animated GIF example** shows an animated GIF that counts from 1 to 5. The file is stored in the MIDlet suite JAR file.

- **AMR Narrow band.** Plays an Adaptive Multi-rate narrow band file. This sample requires an AMR codec. This sample was tested with the K-Lite Mega Codec Pack 4.8.0. This codec is freely downloadable.

- **Audio Capture from a default device** lets you capture audio from a microphone or connected device. The sound is captured and played back on the speaker. To avoid feedback, use a headset.

- **Video Capture Simulation** simulates viewing input video. For example, on a device equipped with a camera.

- **[enter URL]** Plays back media files from arbitrary HTTP servers. Type a valid URL at the insertion point and click OK to play a file. If you want to open an HTTP directory from which to select media, be sure to add a slash to the end of the URL.

In addition, Simple Player parses ring tones in Ringing Tones text transfer language (RTTTL). See [http://www.converতয়oরt৷e.com/rtttl.html](http://www.converতয়oরt৷e.com/rtttl.html) for information on RTTTL.

The Simple Player menu lists commands that control media playback.

The first menu item, Quick Help, displays a list of commands and actions mapped to keypad buttons. Some actions are not applicable for every media type.

The remaining menu items vary depending on the media type. Some actions, such as Rate, open a control with which you can arbitrarily change the playback. Click Back to return to the player screen and see or hear your changes.
Video

The Video application illustrates how the emulator is capable of playing animated GIF files and capturing video. On an external device with a camera, video capture shows the user what the camera sees.

Animated GIFs and video capture can be implemented using either a Form Item or a Canvas. The Video demonstration includes all the possibilities.

- **Animated GIF - Form [jar]** shows an animated GIF in a Form. A simple indicator shows the progress through the animation. The form also includes some information about the playback, including the current time.

- **Animated GIF - Canvas [jar]** shows an animated GIF in a Canvas. A simple indicator shows the progress through the animation.

- **Video Capture - Form** simulates capturing video from a camera or other source and showing it as an Item in a Form. Select **Snapshot** to take a snapshot of the captured video. The snapshot is placed beneath the video capture for comparison.

- **Video Capture - Canvas** simulates capturing video from a camera or other source and showing it in a Canvas. Select **Snapshot** to get a still image of the current appearance. The snapshot is shown briefly, then the display goes back to the video capture.

Pausing Audio Test

This test MIDlet demonstrates the proper use of `pauseApp()` and the alternative.

---

**WARNING:** Do not run the memory monitor while using this demo.

---

In the Well-Behaved case suspending uses `pauseApp()` to close the player and remembers the length of time the audio file played. When the player resumes, it starts playing the audio file at the point that it was suspended.

In the Not Well-Behaved case the player is stopped instead of suspended. When the player is restarted the audio file plays from the beginning.

Test the two cases as follows:

- Run MMAPIDemos, and launch Pausing Audio Test.
  The music starts playing. The initial value of Current State is Well-Behaved.

- Select **Application > Suspend** (or F5), to pause the music.

- Select **Application > Resume** (or F6) to resume playing the audio clip from the stopping point.

- Click the **Misbehave** soft key.

- Select **Application > Suspend** (or F5), to stop the music.

- Select **Application > Resume** (or F6). The player restarts but the clip plays from the beginning.
The Security and Trust Services APIs (SATSA) provide smart card access and
cryptographic capabilities to applications running on small devices. JSR 177 (the
SATSA specification) defines four distinct APIs as optional packages:

- **SATSA-APDU** - Enables applications to communicate with smart card
  applications using a low-level protocol.

- **SATSA-JCRMI** - Provides an alternate method for communicating with smart
  card applications using a remote object protocol.

- **SATSA-PKI** - Enables applications to use a smart card to digitally sign data and
  manage user certificates.

- **SATSA-CRYPTO** - A general-purpose cryptographic API that supports message
digests, digital signatures, and ciphers.

The Oracle Java ME SDK emulator fully supports SATSA. This topic describes how
you can use the Oracle Java ME SDK to work with SATSA in your own applications.

If you must develop your own Java Card applications, download the Java Card
Development Kit, available at:

http://www.oracle.com/technetwork/java/javacard/overview

### Card Slots in the Emulator

Real SATSA devices are likely to have one or more slots that house smart cards.
Applications that use SATSA to communicate with smart cards must specify a slot and
a card application.

The Oracle Java ME SDK emulator is not an external device and, therefore, does not
have physical slots for smart cards. Instead, it communicates with a smart card
application using a socket protocol. The other end of the socket might be a smart card
simulator or it might be a proxy that talks with real smart card hardware.

The Oracle Java ME SDK emulator includes two simulated smart card slots. Each slot
has an associated socket that represents one end of the protocol that is used to
communicate with smart card applications.

The default card emulator host name is localhost, and the default ports are 9025 for
slot 0 and 9026 for slot 1. These port defaults are a property of the device. To change
the defaults in the user interface, right click on the device in the Device Selector, and
select Properties. By default the Properties window is docked on the upper right of the
Oracle Java ME SDK interface.

You can also change the port values in the device’s property file found at:
username\\javame-sdk\\3.4\\work\\devicename

Edit the device.properties file and modify this line:

```
runtime.internal.com.sun.io.j2me.apdu.hostsandports = localhost:9025,localhost:9026
```

```
start cref -p 9025 -i memory_image.eeprom
```

---

### Adjusting Access Control

Access control permissions and PIN properties can be specified in text files. When the first APDU or Java Card RMI connection is established, the implementation reads the ACL and PIN data from the acl_slot-number in the workdir\devicename\appdb directory. For example, an access control file for slot 0 might be:

```
username\\javame-sdk\\3.4\\work\\devicename\\appdb\\acl_0
```

If the file is absent or contains errors, the access control verification for this slot is disabled.

The file can contain information about PIN properties and application permissions.

---

### Specifying PIN Properties

PIN properties are represented by a pin_data record in the access control file.

**Example 18–1 PIN Properties Example**

```
pin_data {
  id number
  label string
  type bcd | ascii | utf | half-nibble | iso
  min minLength
  max maxLength
  stored storedLength
  reference byte
  pad byte - optional
  flag case-sensitive | change-disabled | unblock-disabled
                   needs-padding | disable-allowed | unblockingPIN
}
```

---

### Specifying Application Permissions

Application permissions are defined in access control file (acf) records. The record format is as follows:

**Example 18–2 Access Control File Record Format**

```
acf AID fnnumbers separated by blanks {
  ace {
    root CA name
    ...
    apdu {
      eight numbers separated by blanks
      ...
    }
    ...
    jcrmi {
      classes {
```
The **acf** record is an Access Control File. The AID after **acf** identifies the application. A missing AID indicates that the entry applies to all applications. The **acf** record can contain **ace** records. If there are no **ace** records, access to an application is restricted by this **acf**.

The **ace** record is an Access Control Entry. It can contain **root**, **apdu**, **jcrmi**, **pin_apdu**, and **pin_jcrmi** records.

The **root** record contains one CA name. If the MIDlet suite was authorized using a certificate issued by this CA, this **ace** grants access to this MIDlet. A missing **root** field indicates that the **ace** applies to all identified parties. One principal is described by one line. This line must contain only the word **root** and the principal name, for example:

```
root CN=thehost;OU=JCT;O=dummy CA;L=Santa Clara;ST=CA;C=US
```

The **apdu** or **jcrmi** record describes an APDU or Java Card RMI permission. A missing permission record indicates that all operations are allowed.

An APDU permission contains one or more sequences of eight hexadecimal values, separated by blanks. The first four bytes describe the APDU command and the other four bytes are the mask, for example:

```
apdu {
  0 20 0 82 0 20 0 82
  80 20 0 0 ff ff 0 0
}
```

The Java Card RMI permission contains information about the hash modifier (optional), class list, and method list (optional). If the list of methods is empty, an application is allowed to invoke all the remote methods of interfaces in the list of classes, for example:
Adjusting Access Control

```
jcrmi {
  classes {
    com.sun.javacard.samples.RMIDemo.Purse
  }
  hashModifier zzz
  methods {
    debit(S)V
    setAccountNumber([B)V
    getAccountNumber()[B
  }
}
```

All the numbers are hexadecimal. Tabulation, blank, CR, and LF symbols are used as separators. Separators can be omitted before and after symbols { and }.

The pin_apdu and pin_jcrmi records contain information necessary for PIN entry methods, which is the PIN identifier and APDU command headers, or remote method names.

Access Control File Example

**Example 18–3  Access Control File Example**

```
pin_data {
  label Unblock pin
  id 44
  type utf
  min 4
  stored 8
  max 8
  reference 33
  pad ff
  flag needs-padding
  yflag unblockingPIN
}

pin_data {
  label Main pin
  id 55
  type half-nibble
  min 4
  stored 8
  max 8
  reference 12
  pad ff
  flag disable-allowed
  flag needs-padding
}

acf a0 0 0 0 62 ff 1 {
  ace {
    root CN=thehost;OU=JCT;O=dummy CA;L=Santa Clara;ST=CA;C=US

    pin_jcrmi {
      id 55
      verify enterPIN([B)S
      change changePIN([B)S
      disable disablePIN([B)S
      enable enablePIN([B)S
      unblock unblockPIN([B)S
    }
  }
```
acf a0 00 00 62 ee 1 {
    ace {
        root CN=thehost;OU=JCT;O=dummy CA;L=Santa Clara;ST=CA;C=US
        pin_apdu {
            id 55
            verify 1 2 3 1
            change 4 3 2 2
            disable 1 1 1 3
            enable 5 5 5 4
            unblock 7 7 7 5
        }
    }
}

acf a0 00 00 62 31 c8 1 {
    ace {
        root CN=thehost;OU=JCT;O=dummy CA;L=Santa Clara;ST=CA;C=US
        jcrmi {
            classes {
                com.sun.javacard.samples.RMIDemo.Purse
            }
            hashModifier xxx
            methods {
                setAccountNumber([B)V
                getBalance()S
                credit(S)V
            }
        }
    }
}

acf a0 00 00 00 62 03 01 0c 02 01 {
    ace {
        root CN=thehost;OU=JCT;O=dummy CA;L=Santa Clara;ST=CA;C=US
        apdu {
            0 20 0 82 0 20 0 82
            80 20 0 0 ff ff 0 0
        }
        apdu {
            80 22 0 0 ff ff 0 0
        }
    }
}
Adjusting Access Control

acf a0 00 00 00 62 03 01 0c 02 01 {
  ace {
    apdu {
      0 20 0 82 ff ff ff ff
    }
  }
}

acf a0 00 00 00 62 03 01 0c 06 01 {
  ace {
    apdu {
      0 20 0 82 ff ff ff ff
    }
  }
}

Running the SATSA Demo

For the demo to work this project must reside in the Oracle Java ME SDK installation’s \apps subdirectory. You must create the apps directory yourself

1. Click the File menu and select New Project and in the Categories window select Samples > Java ME SDK 3.4 and single-click SATSADemos. Click Next. Save the sample project in:

   installdir\apps\SATSADemos

   Click Finish.

2. Right-click on the project, click Run As > Run Configurations. The Run Configurations window opens. Select the project JAD file on the left. On the right, switch to the Emulation tab where you can set the SDK/Device/Security domain.

3. Start the instance(s) of cref from the command line.

4. Run the project.

5. Right-click the project, click Properties and then click the Running category. Enable Regular execution and check Specify the Security Domain. Select maximum from the list.

6. Start up two instances of cref, one for each simulated card slot (assuming the current directory is the SDK installation directory):

   start installdir\bin\ cref -p 9025 -i installdir\apps\SATSADemos\demo2.eprom
   start installdir\bin\ cref -p 9026 -i installdir\apps\SATSADemos\demo2.eprom

7. When you have the two smart card simulators running, run SATSADemos. Select APDUMIDlet, select the Menu soft key and select Launch (1). Press Go when prompted.

   The emulator screen displays the process of exchanging APDUs between eeproms.

8. To set up the simulated smart card, use cref, very much like you did for APDUMIDlet. This time you do not have to specify a port number, and the memory image is different:

   start installdir\bin\ cref -i installdir\apps\SATSADemos\sat.eprom
9. When you have the smart card simulator running, run SATSADemos. Select SATMIDlet, select the Menu soft key and select Launch (1). Press Go when prompted.

The emulator screen displays the process of sending envelopes over a SAT connection.

10. Start cref from the SDK installation directory:

```
start installdir\bin\cref -p 9025 -i installdir\apps\SATSADemos\pki.eeprom
```

11. In the emulator, select Find Slots. After you see the slots found, select the Back soft key.

12. Select SATSA-PKI Sign test. The following confirmation message appears:

```
This certificate will be used: Certificate two
```

Select the OK soft key.

13. For PIN 1, type: 1234

Select the OK from the menu. The following confirmation message appears:

```
This string will be signed: JSR 177 Approved
```

14. Select the OK soft key. The following confirmation message appears:

```
This certificate will be used: Certificate one
```

Select the OK soft key.

15. For non repudiation key 1 PIN, type: 2345

Select the soft menu and select OK (option 2). The sign test is complete.

16. Right-click the project, click Properties and then click the Running category. Enable Regular execution and check Specify the Security Domain. Select maximum from the list.

17. Start cref from the SDK installation directory as follows:

```
start installdir\bin\cref -p 9025 -i installdir\apps\SATSADemos\demo2.eeprom
```
This chapter describes the JSR 179 Location API. This API gives applications the opportunity to access and use the location capabilities of an external device.

For example, some devices include Global Positioning System (GPS) hardware. Other devices might be able to receive location information from the wireless network. The Location API provides a standard interface to location information, regardless of the underlying technique.

In the Location API, a location provider encapsulates a positioning method and supplies information about the device’s location. The application requests a provider by specifying required criteria, such as the desired accuracy and response time. If an appropriate implementation is available, the application can use it to obtain information about the device’s physical location.

The Oracle Java ME SDK includes a simulated location provider. You can use the emulator’s External Events Generator to specify where the emulator should think it is located. In addition, you can configure the properties of the provider itself, and you can manage a database of landmarks.

Setting the Emulator's Location at Runtime

You can specify the simulated location of the emulator while it is running. In the emulator, click the Tools menu and select External Events Generator. Click the Location tab.

In the Location area of the tab, you can fill in values for the latitude, longitude, altitude, speed, and course. Applications that use the Location API can retrieve these values as the location of the emulator.

For more elaborate testing, you can set up a location script that describes motion over time. Location scripts are XML files consisting of a list of locations, called waypoints, and associated times. The Oracle Java ME SDK determines the current location of the emulator by interpolating between the points in the location script. Here, for example, is a simple location script that specifies a starting point (time="0") and moves to a new point in ten seconds:

Example 19–1  Location Script Example

```xml
<waypoints>
  <waypoint time="0"
    latitude="14" longitude="50" altitude="310" />
  <waypoint time="10000"
    latitude="14.5" longitude="50.1" altitude="215" />
</waypoints>
```
The altitude measurement is in meters, and the time values are in milliseconds.

Use a text editor to create your location script. You can load it into the external event window by pressing the Browse button next to the Script field. Immediately below are controls for playing, pausing, stopping, and moving to the beginning and end of the location script. You can also drag the time slider to a particular point.

Some devices are also capable of measuring their orientation. To make this kind of information available to your application, change the State field in the Orientation box to Supported and fill in values for azimuth, pitch, and roll. The Magnetic Orientation check box indicates whether the azimuth and pitch measurements are relative to the Earth's magnetic field or relative to true north and gravity.
To test how your application handles unexpected conditions, try changing the State field in the Location Provider box to Temporarily Unavailable or Out of Service. When your application attempts to retrieve the emulator’s location, an exception is thrown and you can see how your application responds.

Running the CityGuide Sample Project

CityGuide demonstrates how to use the Location API (JSR 179). It shows a walker's current position superimposed on a city map. The walker moves around the city and landmarks are highlighted and identified as the walker approaches. This demo gets the walker’s location from an XML script named citywalk.xml (the event file) that submits the device location information.

Because location prompts occur frequently, it is best to run this demonstration in manufacturer (trusted) mode, as explained in “Security Domains.” In the user interface, right-click your project and select the Running category. Select Specify the Security Domain, and select manufacturer or maximum.

1. Open and run the CityGuide project. In the emulator, launch the CityGuide MIDlet. The map page opens.

2. By default the display shows icons for four types of landmarks: restaurants, museums, shops, and theaters.

   To adjust the landmark display (this is optional), open the soft menu and select the Settings command. Use the navigation keys to highlight a category, then use Select to check or uncheck an item. In the default skin the item is selected when the square is filled with white.

3. In the emulator, lick the Tools menu and select External Events Generator. Click the Location tab, then click the Browse button. Select the event file from the directory containing the Citywalk application.

Figure 19–2  The Location Settings Dialog Box
The player buttons at the bottom of the window are now active. Press the green play button (right-pointing triangle) to run the script.

4. When you are near a landmark its name appears at the top of the map. Open the soft menu and select the **Detail** command to see more information.

CityGuide demo shows your location in the city

*Figure 19–3  The City Guide Landmark Detail Screen*
Using the WMA Console to Send and Receive Messages

The WMA console is a tool that enables you to send messages to and receive messages from applications that use JSR 205. You can, for example, use the WMA console to send SMS messages to a MIDlet running on the emulator.

Launching the WMA Console

Be sure to select the Java ME perspective. Select Window > Open Perspective > Other > Java ME.

To launch the WMA console, select Run > WMA Console. Messages can be sent from the WMA Console to an emulator instance.

The console opens as a tab in the Eclipse documents area. The console phone number is displayed as part of the WMA Console tab label (for example, 987654321).

The WMA console phone number is an editable CLDC property. To edit a property, follow these steps:

1. In the Device Selector, click the Oracle Java ME Platform SDK 3.4 node.
2. Type a new value in the WMA Console Phone Number 1 field.

If the number is available it is assigned to the console immediately. If the number is in use it is assigned to the console the next time you restart the IDE.

WMA Console Interface

To open the WMA Output window, select Run > WMA Console Output. This window displays messages received from an emulator.
Emulator Phone Numbers

Each instance of the emulator has a simulated phone number that is shown in the emulator window. The phone numbers are important because they are used as addresses for WMA messages. The phone number is a device property and it can be changed. In the device selector, right-click a device and view its properties.

Sending a Text or Binary SMS Message

To send a text SMS message, click **Send SMS**.

- The To Clients window automatically lists the phone numbers of all running emulator instances. Select one or more destinations and enter a port number (the default is 50000, as described in "WMADemo Push Registry Values.

- To send a text message, select the Text Message tab, type your message and click **Send**.

- To send the contents of a file as a binary message, click the Binary Message tab. Type in the path of a file directly, or click Browse to open a file chooser.

**Note:** The maximum message length for text and binary messages is 4096 bytes.

To try this yourself see "Sending SMS Messages From WMA Console to an Emulator and Back."
Sending Text or Binary CBS Messages

Sending CBS messages is similar to "Sending a Text or Binary SMS Message" except that recipients are unnecessary because it is a broadcast.

To send a text or binary CBS message, click **Send CBS** in the WMA console. Specify a message identifier (see "WMADemo Push Registry Values") and enter the text or binary content of your message. The maximum message length for text and binary messages is 4096 bytes.

---

**Note:** The emulator displays only the first 160 symbols of a received CBS message.

---

Sending MMS Messages

MMS messages consist of one or more files, usually images or sounds. An MMS message can be sent to multiple recipients.

To send an MMS message from the WMA console, click the **Send MMS** button. The window for composing MMS messages has Header and Parts tabs.

- The header tab addresses the message. The To area automatically lists one of the phone numbers from the running emulator instances. Click **Add** to select other available phone numbers from the drop-down list.

  When a recipient is removed it must be added back manually. Click **Add** and a new line is added to the recipient table.

- To add optional media files (Parts) to the message, click the Parts tab and click **Add**. The maximum message length for text and binary messages is 4096 bytes. Most media files have information to fill the Content Location, Content ID, Mime-Type (text/plain for simple MMS), and Encoding fields, but you can edit these fields as well. The default ID for the demo is `example.mms.MMSDemo` (see WMADemo Push Registry Values).

  To remove a part, select it and press **Remove**.

  To try this yourself, see "Sending MMS Messages from WMA Console to an Emulator."

---

Receiving Messages in the WMA Console

To start the WMA console, click the **Run** menu and select **WMA Console**. The WMA console window has its own phone number displayed on the WMA Console tab. You can send messages from your applications running on the emulator to the WMA console.

Received messages are displayed in the WMA output window.

---

Running WMADemo

The WMADemo sample project shows how to send and receive SMS, CBS, and MMS messages. Messages can be exchanged between emulator instances and can be generated or received using the WMA console utility.
WMADemo Push Registry Values

The push registry determines how the demo establishes certain types of connections. This information is set in the Application Descriptor. To view it, right-click the WMA Demo project and select Properties. In the Properties window, go to Application Description > Optional > Push Registry.

- For SMS messages the port number is 50000.
- For CBS Messages, the Message Identifier is 50001.
- For MMS messages, the application ID is `example.mms.MMSDemo`.

Sending SMS Messages From WMA Console to an Emulator and Back

In this demo you send messages between the WMA Console and the client demo application running on the emulator. Using the WMA console to send messages to the emulator exercises the push registry.

1. To launch the WMA console, select Run > WMA Console. To open the WMA Output window, select Run > WMA Console Output. The WMADemo should be running in the emulator.

2. Click the Send SMS button in the WMA console window.
   
   Select the number that corresponds to the emulator. Typically you check the box in front of 123456789. If you are not sure what number the emulator is using, look for a number above the emulator screen.
   
   Fill in a port number of 50000. This is required because the demo waits for the SMS on that port.
   
   Type your text message in the Message field and click Send.

3. The emulator asks if it is OK if the WMADemo interrupts and if it can be started. You might receive several permission requests based on your firewall settings.
   
   Select Yes. The SMSReceive MIDlet is launched and immediately displays the incoming SMS message.

4. To type a return message, press the Reply soft button. Type a message and select Send from the menu. You might be asked to give permission because there is a cost to your phone number. In the IDE, look in the WMA Output Window to confirm that your reply has been received. (The output window is typically displayed below the WMA Console. Be sure to click the WMA Output Window tab.)

Sending MMS Messages from WMA Console to an Emulator

To send an MMS message from the WMA console to the emulator, follow these steps:

1. From the WMADemo home screen, select MMS Receive. The emulator displays: "MMS Receive" and the message "Waiting for MMS on application ID example.mms.MMSDemo..."

2. In the WMA console, click Send MMS to open the MMS composition window.
   
   The Header tab is open by default. Supply any message subject, the application ID `example.mms.MMSDemo`, and the telephone number of the running emulator. That number is displayed to the right of the To field by default.
   
   The Address Type field on the left is a drop-down list from which you can select To, Cc or Bcc.
If you do not see the number of a running emulator, click the Add button to add it to the Address field. When you have listed multiple numbers, the Address field becomes a drop-down list.

3. Click the Parts tab. The WMA console enables you to select files to send as parts of the MMS message. Click Add and use the file browser to find the file you want to send. Click OK.

4. Click Send to send the message.

The image and its information are displayed in the emulator.

Running WMA Tool

WMA Tool is the command line version of the WMA Console. To send and receive SMS, CBS, and MMS messages from the command line, run:

```
installdir\bin\wma-tool <command> [options]
```

The Device Manager must be running before you launch wma-tool.

When the tool is started, it outputs the phone number it is using.

Command

Each protocol has send and receive commands. The requested command is passed to the tool as a first argument. Possibilities are:

- receive
- smsreceive - receives SMS messages
- cbsreceive - receives CBS messages
- mmsreceive - receives MMS messages
- smssend - sends SMS message
- cbssend - sends CBS message
- mmssend - sends MMS message

The *send commands send the specified message and exit. The *receive commands print incoming messages until they are explicitly stopped.

Options

- `-o outputDir`. Store binary contents to outputDir.
- `-t timeout`. Non-interactive mode, waits the number of timeout seconds for messages.
- `-f` Store text contents as files instead of printing them.
- `-q` Quiet mode.

smsreceive, cbsreceive, and mmsreceive

The syntax for receiving a message is basically the same for all three protocols.

```
smsreceive [-o outputDir] [-t timeout] [-q]
cbsreceive [-o outputDir] [-t timeout] [-q]
mmsreceive [-o outputDir] [-t timeout] [-q]
```

smssend

```
wma-tool smssend target_phone target_port message_content
```
Running WMA Tool

- **target_phone**
  Phone number of the target phone. Mandatory first argument.

- **target_port**
  Port of the target phone. Mandatory second argument.

- **message_content**
  Mandatory third argument. Can have one of these two forms:
  - **text**: text of the text message
  - **-f file**: sends content of the specified file as a binary message.

Example:
```
  wma-tool smssend 123456789 50000 "smssend message from wma-tool"
```

**cbssend**

```
wma-tool cbssend message_id message_content
```

- **message_id**
  ID of the message. Mandatory first argument.

- **message_content**
  Mandatory second argument. Can have one of these two forms:
  - **text**: text of the text message
  - **-f file**: sends content of the specified file as a binary message.

Example:
```
wma-tool cbssend 50001 "cbssend message from wma-tool"
```

**mmssend**

```
wma-tool mmssend applicationId subject
  [-to <target_phone>] [-cc <target_phone>] [-bcc <target_phone>]
  [-part { <part_from_file> | <part_from_text> }]
```

Each part is defined by name=value pairs delimited by a semicolon ";" separator.

**Part Variables**

To create **part_from_file**, define the following variables.

- **file**
  File to send as a message part.

- **mimeType**
  Mime type of the file.

To create **part_from_text**, define the following variables:

- **text**
  Text to send as a message part. mimeType is set to text/plain.

---

**Note:** The file and the mimeType must be separated by a semicolon.
- `to target_phone`
  "to" target phone number. You can use any number of these options.

- `cc target_phone`
  "cc" target phone number. You can use any number of these options.

- `bcc target_phone`
  "bcc" target phone number. You can use any number of these options.

**Part from Text Options**

Separate options with semicolons. For example:

- `-part contentId=content ID; encoding=encoding; text=text`

  Appends text part to the message. You can use any number of these options.
  Contains the following options:
  - `content ID`: content ID of this message part
  - `encoding`: Sent text encoding. Only relevant for "text/plain". Mime type defaults to UTF8.

**Part from File Options**

- Appends binary part to the message with content loaded from the given file. You can use any number of these options.

  Separate the options with a semicolon.
  - `content id`: content ID of this message part
  - `mime type`: mime type of this message part
  - `file name`: file with content of this message part
  - `fileEncoding`: Encoding of text in the file, only relevant for "text/plain", only applies if the file argument is present. Defaults to the value of the `encoding` variable.

**Example:**

```bash
wma-tool mmssend example.mms.MMSDemo MySubject -to 123456789 -part file=Duke.png;mimeType=image/png
```
The Mobile 3D Graphics API (JSR 184) provides 3D graphics capabilities with a low-level API and a high-level scene graph API. This chapter provides a brief overview and general guidelines for working with JSR 184.

JSR 184 is a specification that defines the Mobile 3D Graphics (M3G) API for Java ME. This API provides 3D functionality in a compact package that's appropriate for CLDC/MIDP devices. The API provides two methods for displaying 3D graphics content:

- **The immediate mode** API makes it possible for applications to directly create and manipulate 3D elements.
- **Layered on top of this is a scene graph** API, also called retained mode, that makes it possible to load and display entire 3D scenes that are designed ahead of time.


**Choosing a Graphics Mode**

Applications are free to use whichever approach is most appropriate or to use a combination of the retained mode and immediate mode APIs.

JSR 184 provides a standard API for CLDC/MIDP devices, enabling a new generation of 3D applications. The immediate mode API, in turn, is compatible with OpenGL ES, a standard lightweight API for 3D graphics. See [http://khronos.org/](http://khronos.org/) for more information on OpenGL ES.

**Immediate Mode**

Immediate mode is appropriate for applications that generate 3D graphics content algorithmically, such as scientific visualizations or statistical graphs. The application creates 3D objects and manipulates them directly.

For an example of immediate mode, see the Life3D MIDlet in the Demo3D example application.

**Retained Mode**

Most applications, particularly games, use the retained mode or scene graph API. In this approach, a graphic designer or artist uses 3D modeling software to create a scene graph. The scene graph is saved in the JSR 184 file format. The scene graph file is bundled with the application. At runtime, the application uses the scene graph API to load and display the file.
Applications can manipulate parts of a loaded scene graph to animate characters or create other effects. The basic strategy is to do as much work as possible in the modeling software. At runtime, the application can grab and manipulate parts of the scene graph, which can also include paths for animation or other effects.

For an example of retained mode, see the retainedmode MIDlet in the Demo3D example application.

Quality Versus Speed

One of the challenges of MIDP development is the constrained environment of typical devices. Compared to desktop computers, MIDP devices have slow processors and little memory. These challenges extend into the arena of 3D graphics. To accommodate a wide variety of implementations, the JSR 184 specification provides various mechanisms to make the display of a 3D scene as efficient as possible.

One approach is scoping, a technique where you tell the 3D graphics implementation when objects are not going to interact with each other. For example, if you defined a scene graph for a house, you could use scoping to specify that the light in the basement does not affect the appearance of the bedroom on the second floor. Scoping simplifies the implementation’s task because it reduces the number of calculations required to show a scene.

In general, the best way to improve the rendering speed of 3D scenes is to make some compromises in quality. The Mobile 3D Graphics API includes rendering hints so that applications can suggest how the implementation can compromise quality to improve rendering speed.

Content for Mobile 3D Graphics

Most mobile 3D applications use scene graphs in resource files to describe objects, scenes, and characters. Usually it is not programmers but graphic designers or artists who create the scene graphs, using standard 3D modeling tools.

Several vendors offer tools for authoring content and converting files to the JSR 184 format.

Because it is relatively difficult to create and manipulate 3D graphics content in an application using the immediate mode API, most applications rely as much as possible on a scene graph file. By putting as much as possible into the scene graph file at design time, the application’s job at runtime is considerably simplified.

Running Demo3D Samples

Demo3D contains MIDlets that demonstrate JSR 184 features.

Select File > New > Project.... In the Categories window, click Example and select Java ME Sample Applications. Then single-click Demo3D and click Next. Specify a name and location and click Finish.

Life3D

Life3D implements the popular Game of Life in three dimensions. Live cells are represented by cubes. Each cell has 26 possible neighbors (including diagonals). For each step of the animation, cells with fewer than four neighbors die of loneliness, while cells with more than five neighbors die of overcrowding. An empty cell with exactly four neighbors becomes a new live cell.
The view of the playing board rotates slowly so you can view the board from all
angles.

The keypad buttons in Table 21–1 provide control over the game.

<table>
<thead>
<tr>
<th>Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>Pause the animation.</td>
</tr>
<tr>
<td>1</td>
<td>Resume the animation at its default speed.</td>
</tr>
<tr>
<td>2</td>
<td>Speed up the animation.</td>
</tr>
<tr>
<td>3</td>
<td>Slow down the animation.</td>
</tr>
<tr>
<td>4</td>
<td>Select the previous preset configuration from an arbitrary list.</td>
</tr>
<tr>
<td></td>
<td>The name of the configuration is shown at the top of the screen.</td>
</tr>
<tr>
<td>5</td>
<td>Select the next preset configuration from the list.</td>
</tr>
<tr>
<td>*</td>
<td>Generate a random configuration and animate until it stabilizes or</td>
</tr>
<tr>
<td></td>
<td>dies. If it dies, generate a new random configuration.</td>
</tr>
</tbody>
</table>

The source code for this example can be found at:

`projects\Demo3D\src\com\superscape\m3g\wtksamples\life3d\Life3D.java`

Where projects is the directory you are using to store your Eclipse projects.

**RetainedMode**

The RetainedMode MIDlet plays a scene file that shows a skateboarder in an endless loop. The source code is found at:

`projects\Demo3D\src\com\superscape\m3g\wtksamples\retainedmode`

**PogoRoo**

PogoRoo displays a kangaroo bouncing up and down on a pogo stick. To steer the
kangaroo, use the arrow keys. Press up to go forward, down to go backward, and left
and right to change direction. Try holding down the key to see an effect. The source
code is found at:

`projects\Demo3D\src\com\superscape\m3g\wtksamples\pogoroop`
JSR 211 defines the Content Handler API (CHAPI). CHAPI specifies a system by which MIDlets can be launched in response to specific types of content.

The basic concept is that MIDlets can be launched in response to incoming content (files). Modern mobile phones can receive content using SMS, infrared, Bluetooth, e-mail, and other methods. Most content has an associated content type.

Using Content Handlers

In the Oracle Java ME SDK Content Handlers are integrated in an Eclipse project as application descriptors. Content Handlers you define are packaged with the application.

Running the CHAPIDemo Content Browser

This demo is a content browser that takes advantage of the content handler registry. It enables you to view different types of content from different sources.

---

**Note:** For the demo to work this project must reside in the Oracle Java ME SDK installation’s \apps subdirectory. You must create this directory yourself. For example, C:\Java_ME_platform_SDK_3.4\apps.

---

1. If your workspace is the Oracle Java ME SDK installation’s \apps subdirectory, continue to step 2. If not, follow these steps to create the workspace:
   - Create an \apps directory in your Oracle Java ME SDK platform installation. For example, C:\Java_ME_platform_SDK_3.4\apps.
   - In Eclipse, select File > Switch Workspace > Other.
   - Browse to the \apps directory, and click OK.
2. Select File > New > Project... and in the New Project window, select Examples > Java ME SDK 3.4 > Java ME Sample Applications, and click Next.
   - Select CHAPIDemo.
3. Right-click a device and select Run Project via OTA > CHAPIDemo.

Not all features of the demo are available if you select the Run command. Additionally, to see certain features of the demo, an HTTP server is required. The server is located in the installdir\apps directory. Also the audio and video files are located in the content directory, which must be located in installdir\apps\CHAPIDemo directory (installdir\apps\CHAPIDemo\content).
4. On the Favorite Links page, select CHAPI Demo.

5. Press **Select** or click the **Menu** soft button and select **Go**.

   You might see a request for permission to use airtime. To speed up the demo interaction, select "Ask once per application use" and select the **Yes** soft key (if you do not check this option you can still use the demo but you see the airtime message more frequently).

   The Text Viewer displays a Media Player URL and links to various media files.

6. Install the Media Player to view media.

   - Click the URL `http:handlers/dist/MediaHandler.jad`, or, use arrow keys to highlight the URL and from Menu, select **Go**.
   - The application asks, "Are you sure you want to install Media Handler?" Click the **Install** soft key.
     - An authorization Information screen is displayed.
   - Click the **Install** soft key.
     - The installation is confirmed. When the installation completes, you are returned to the Text Viewer. The Media Handler is shown as a separate application in the AMS.

7. Select and view the different image, video, audio and text URLs.

   Click a link to open that media in the viewer, or, use arrows to highlight the link, then select **Go** from the soft menu.

   Select the **Back** soft key to return to the Text Viewer.
JSR 226, the Scalable 2D Vector Graphics API (SVG), supports rendering of sophisticated and interactive 2D content. This chapter describes how to work with SVG capabilities in Oracle Java ME SDK.

Scalable Vector Graphics is a standard defined by the World Wide Web Consortium. It is an XML grammar for describing rich, interactive 2D graphics.

The Scalable Vector Graphics 1.1 specification (available at http://www.w3.org/TR/SVG11/) defines a language for describing two-dimensional graphics in XML.

SVG Tiny (SVGT) is a subset of SVG that is appropriate for small devices such as mobile phones. See http://www.w3.org/TR/SVGMobile/. SVGT is a compact, yet powerful, XML format for describing rich, interactive, and animated 2D content. Graphical elements can be logically grouped and identified by the SVG markup.

Java ME applications using SVG content can create graphical effects that adapt to the display resolution and form factor of the user’s display.

SVG images can be animated in two ways. One is to use declarative animation, as illustrated in “Play SVG Animation.” The other is to repeatedly modify the SVG image parameters (such as color or position), through API calls.

While it is possible to produce SVG content with a text editor, most people prefer to use an authoring tool. Here are two possibilities:

- Inkscape: http://inkscape.org

**Running SVGDemo**

This project contains MIDlets that demonstrate different ways to load manipulate, render, and play SVG content.

**SVG Browser**

The SVGBrowser MIDlet displays SVG files residing in the phone file system. Before running this demo, place an SVG file in your device skin’s file structure. The default location is:

username\javame-sdk\3.4\work\devicename\appdb\filesystem\root
For your device location, see "Oracle Java ME SDK Directories" and Table 7–1. Launch the demo. The application displays the contents of root1. Select your SVG file and select the Open soft key.

**Render SVG Image**

Render SVG Image loads an SVG image from a file and renders it. Looking at the demo code you can see that the image is dynamically sized to exactly fit the display area. The output is clear and sharp.

**Play SVG Animation**

This application plays an SVG animation depicting a Halloween greeting card. Press 8 to pause, 5 to start or resume, and 0 to stop.

The SVG file contains a description of how the various image elements evolve over time to provide this short animation.

In the following code sample, the JSR 226 javax.microedition.m2g.SVGImage class is used to load the SVG resource. Then, the javax.microedition.m2g.SVGAnimator class can take all the complexity of SVG animations and provides a java.awt.Component or javax.swing.JComponent which plays the animation. The SVGAnimator class provides methods to play, pause, and stop the animation.

**Example 23–1 SVG File Example**

```java
import javax.microedition.m2g.ScalableGraphics;
import javax.microedition.m2g.SVGImage;
...
String svgURI = ...;
SVGImage svgImage = (SVGImage) SVGImage.createImage(svgURI, null);
SVGAnimator svgAnimator = SVGAnimator.createAnimator(svgImage);

// If running a JSE applet, the target component is a JComponent.
JComponent svgAnimationComponent = (JComponent) svgAnimator.getTargetComponent();
...

svgAnimator.play();
...
svgAnimator.pause();
...
svgAnimator.stop();
```

**Create SVG Image from Scratch**

This demo builds an image using API calls. It creates an empty SVGImage, populates it with a graphical content, and then displays that content.

**Bouncing Balls**

Bouncing Balls plays an SVG animation. Press 8 to play, 5 to start, and 0 to stop. If you press 8, pressing 5 resumes the animation. If you press 0, pressing 5 starts the animation from the beginning.
Optimized Menu

In this demo, selected icons have a yellow border. As you move to a new icon, it becomes selected and the previous icon flips to the unselected state. If you navigate off the icon grid, selection loops around. That is, if the last icon in a row is selected, moving right selects the first icon in the same row.

This demo illustrates the flexibility that combining UI markup and Java offers: a rich set of functionality (graphics, animations, high-end 2D rendering) and flexibility in graphic manipulation, pre-rendering or playing.

In this example, a graphic artist delivered an SVG animation defining the transition state for the menu icons, from the unselected state to the selected state. The program renders each icon's animation sequence separately into off-screen buffers (for faster rendering later on), using the JSR 226 API.

With buffering, the MIDlet adapts to the device display resolution (because the graphics are defined in SVG format) and still retain the speed of bitmap rendering. In addition, the MIDlet is still leveraging the SVG animation capabilities.

The task of defining the look of the menu items and their animation effect (the job of the graphic artist and designer) is cleanly separated from the task of displaying the menu and starting actions based on menu selection (the job of the developer). The two can vary independently provided both the artist and the developer observe the SVG document structure conventions.

Picture Decorator

In this sample you use the phone keys to add decorations to a photograph. The key values are:

<table>
<thead>
<tr>
<th>Key</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>key shrink</td>
</tr>
<tr>
<td>2</td>
<td>key next picture</td>
</tr>
<tr>
<td>3</td>
<td>key grow</td>
</tr>
<tr>
<td>4</td>
<td>key help</td>
</tr>
<tr>
<td>5</td>
<td>key horizontal flip</td>
</tr>
<tr>
<td>6</td>
<td>key vertical flip</td>
</tr>
<tr>
<td>7</td>
<td>key rotate counter-clockwise</td>
</tr>
<tr>
<td>8</td>
<td>key previous picture</td>
</tr>
<tr>
<td>9</td>
<td>key rotate clockwise</td>
</tr>
<tr>
<td>#</td>
<td>display picker options</td>
</tr>
</tbody>
</table>

This demo provides 16 pictures for you to decorate.

Use the 2 and 8 keys to page forward and back through the photos.

To decorate, press # to display the picker. Use the arrow keys to highlight a graphic object. The highlighted object is enlarged. Press Select to select the current graphic or press the arrow keys to highlight a different graphic. Press Select again to add the graphic to the photo. When the decoration is added you see a red + on the graphic, indicating it is selected and can be moved, resized, and manipulated.
Use the navigation arrows to move the graphic. Use 1 to shrink the graphic, and 3 to enlarge the graphic. Use 5 or 6 to flip, and 7 or 9 to rotate. When you are satisfied with the position, press Select. Look for a green triangle. This is a cursor. Use the navigation keys to move the green triangle around the picture. When the cursor is over an object it is highlighted with a red box. Press Select. The red + indicates the object is selected and it can be manipulated or removed.

To remove a decoration (a property), select an object, then click the Menu soft key and select Remove prop.

Location Based Service

Launch the application. A splash screen (also used as the help) appears. The initial view is a map of your itinerary - a walk through San Francisco. The bay (in blue) is on the right of your screen. Press 1 to start following the itinerary. The application zooms in on your location on the map. Turn-by-turn directions appear in white boxes on the horizontal axis. While the itinerary is running, Press 7 to rotate the map counter-clockwise. Note, the map rotates and the text now appears on the vertical axis. Press 7 again to restore the default orientation. Press 4 to display the help screen.
Running SVGContactList

This application uses different skins to display the same contact list information and a news banner. The skins feature different colors and fonts.

Select SVGContactlist(skin 1) or SVGContactlist(skin 2), then click Launch.

Use the up and down arrows to navigate the list of contacts. The selected name is marked with a special character (a > or a dot) and is displayed in a larger font.

Press > or the select button to see more information for the selected name. When you are in the detailed view you can traverse the detail entries using the up or down arrows.

Press < or the select button to return to the contact list.

Press the left soft button to go back to the demos MIDlet list and view another skin.
JSR 239 provides a Java language interface to the OpenGL for Embedded Systems (ES) graphics API, an open graphics standard.

While JSR 184 (which is object oriented) requires high level functionality, OpenGL is a low-level graphics library that is suited for accessing hardware accelerated 3D graphics.

Open GL Overview

JSR 239 defines the Java programming language bindings for two APIs, OpenGL for Embedded Systems (OpenGL ES) and EGL. OpenGL ES is a standard API for 3D graphics, a subset of OpenGL, which is pervasive on desktop computers. EGL is a standard platform interface layer. Both OpenGL ES and EGL are developed by the Khronos Group.

For more information, see [http://khronos.org/opengles/](http://khronos.org/opengles/).
The JSR 256 Mobile Sensor API allows Java ME application developers to fetch data from sensors. A sensor is any measurement data source. This chapter describes how to work with JSR 256 in Oracle Java ME SDK.

Sensors can vary from physical sensors, such as magnetometers and accelerometers, to virtual sensors that combine and manipulate the data they have receive from various kinds of physical sensors. An example of a virtual sensor might be a level sensor indicating the remaining charge in a battery or a field intensity sensor that measures the reception level of the mobile network signal in a mobile phone.

---

**Note:** JSR 256 supports many different types of sensor connection (wired, wireless, embedded and more) but Oracle Java ME SDK provides only preconfigured support for sensors embedded in the device.

---

The Oracle Java ME SDK GUI provides sensor simulation. The emulator's External Events Generator Sensors tab enables you to run a script that simulates sensor data.

You can use the API available with the SDK to create a custom sensor implementation with additional capabilities and support for different connection types.

The Sensors demonstration has two MIDlets, "SensorBrowser" and "Marbles," that demonstrate the Oracle Java ME SDK’s implementation of the Mobile Sensor API.

---

**Creating a Mobile Sensor Project**

Follow these steps to create a mobile sensor project:

1. Select `File > New > MIDlet Project` and fill in the information in the Create a MIDlet Project dialog box. Click `Next`.

2. On the MIDlet Project Content page, change the Microedition Configuration version to 1.1. Ensure that the MIDP version is 2.1. Click `Finish`.

3. Expand the finished project in the Package pane and double-click Application Descriptor to open the Overview pane.

4. Click the Application Descriptor tab at the bottom of the Overview pane and add configuration values for the embedded sensors shipped with the ME SDK as described below.

A sensor project freely detects sensors, but this does not imply you can get data from the sensors you find. You might need to explicitly set permissions in your project so you can interact with certain sensors. To see an example, open the Sensors sample...
Using a Mobile Sensor Project

The sample Sensor project can be installed over the air. To install the application into the emulator, follow these steps:

1. Expand the Sensors project node and double-click the Application Descriptor node.

2. Click Launch as emulated Java ME OTA under the Running section.

Alternatively, you can right-click a device and select Run Project via OTA and then select Sensors.

In the emulator window, click the Tools menus and select External Events Generator. In the External Events Generator, click the Sensors tab. In this tabbed pane, you can view all sensors that are currently available in the emulator (sensor ID, name, and availability are listed). If the sensor supports change to availability you can click on the check box to change it. As mentioned earlier, the provided implementation does not support availability change, but a custom implementation you create might do so.

When you select a sensor row, the bottom of the dialog displays any custom sensor controls. For example, the acceleration sensor, has three channels: axis_x, axis_y, and axis_z. Each channel has a slider that changes the current channel value, and an edit box you can use to input a value. The channel unit label is displayed on the far right.

Under the channels there is a script player control that enables you to play sensor value events from a script file of the format discussed in "Creating a Sensor Script File." See "SensorBrowser" for a description of how to use the Sensors demo.

To create your own optional properties using com.sun.javame.sensorN.proplist and com.sun.javame.sensorN.prop.any_name, where N is the sensor number and any_name is the name of your property. The security sensor property was created as follows:

```java
# add security into proplist
com.sun.javame.sensor<N>.proplist: security
# add security property value
com.sun.javame.sensor<N>.prop.security: private
```
Creating a Sensor Script File

To simulate sensor inputs, provide a sensor script. The file format is as follows:

Example 25–1  Sensor Script File Format Example

```xml
<sensors>
  <value time='0'>
    <channel id='0' value='0' />
    <channel id='1' value='0' />
  </value>
  <value time='100'>
    <sensor active='false'/>
  </value>
  <value time='100'>
    <channel id='0' value='-50' /> 
    <channel id='1' value='10' /> 
    <sensor active='true'/>
  </value>
</sensors>
```

`marbles.xml` in the Sensors project directory is an example of a sensor script file. The attributes are as follows:

- The attribute `time` in the `value` tag is the delay from the previous command in milliseconds.
- The `channel` tag sets the value of the channel with the specified id value, to value. The channel ignores the id if the value of id is not specified or if the value is out of the channel range.
- The `sensor` tag is a true or false value that makes the sensor available or unavailable. The preconfigured sensors provided with this release are embedded, so they cannot be deactivated. If you configure your own sensor that is not embedded, it is possible to deactivate it.

SensorBrowser

The SensorBrowser application displays the sensor detail information for each channel defined for the demo.

1. In the emulator, select SensorBrowser and use the soft key to select Launch the application.
   
   Depending on your security settings you might see the warning: "Sensors" wants to connect to sensor "#". Is it OK to use sensor? For test purposes, select "Ask once per application use" and select the Yes soft button.
   
   The emulator displays a list of sensors.

2. Use the navigation keys to highlight a sensor, then use the soft key to select Detail.
   
   For example, the following screen shows the details for the acceleration sensor.
Figure 25–1  The Acceleration Sensor Screen

Click Back, then click Exit to return to the application menu.

Marbles

This demonstration uses the Marbles game to provide visual feedback for sensor inputs provided in a script.

1. From the application menu select Marbles and use the soft key to launch the application.

2. In the emulator, click the Tools menu and select External Events Generator. Click the Sensors tab to display a list of the sensors in this application.

3. Select the Acceleration Sensor row (ID 3).

4. Click the Browse button, and in the Sensors project directory select marbles.xml.

5. Observe the movement of the marbles on the emulator screen. On the external events screen you can see the sliders move as the script runs. You can use the familiar controls to play, pause, and stop the script.
The Contactless Communication API (JSR 257) is a Java ME optional package that allows applications to access information on contactless targets, such as Radio Frequency Identification (RFID) tags and bar codes. This chapter describes how to use JSR 257 in Oracle Java ME SDK.

RFID tags are often used in business for item identification, article surveillance, and inventory. Each RFID tag contains a unique identification number used to identify a tagged object.

Using the JSR 257 API, an RFID reader can be built into a software phone stack, allowing the handset to read data from a tagged target and write data back to it. RFID readers use the 13.56 MHz radio frequency and the communication distance is usually less than 10 centimeters.

The Near Field Communication (NFC) Forum defines the NFC Data Exchange Format (NDEF) data packaging format. NDEF facilitates communication with an RFID tag, or between one NFC device and another. The Contactless Communication API provides a connection to any physical target that supports the NDEF standard, allowing applications to exchange data with any target tagged with NDEF formatting, regardless of actual physical type.

For more information, see http://jcp.org/en/jsr/detail?id=257.

Using ContactlessDemo

The Oracle Java ME SDK provides a way to test contactless communication. The MIDlet running on the emulator waits to detect an RFID tag. You can simulate the tag communication using the emulator’s external events generator to detect and attach the tag. You can use one of the tags included in the sample, or create tag files of your own, as described in “Tag File Formats.”

1. Launch the ContactlessDemo. The MIDlet registers the RFID tag listener, the NDEF tag listener and the NDEF record listener, then notifies you that it is waiting for a tag.

2. In the emulator, click the Tools menu and select External Events Generator. The Contactless Communication tab is automatically displayed. In the external events generator the tag emulator supplies several tags by default: hello, nested, vcard, jdts, jdts2, and nndefEmpty.

3. To test the connection, select an available tag and press the Attach tag.

In the emulator the MIDlet notifies you that the NDEF target is detected, displays the tag information, and prints the payload if it is a text record.

In the external events generator, press the Detach tag to end the session.
Events are recorded in the log area. To clear the log, right-click and select **Delete Text**. To clear the emulator screen press the Clear soft button.

4. To create your own tag, create a tag file according to the NDEF standard. For a sample, see "**Tag File Formats**."

In the External Events Generator, press the **Create tag** and browse to select your tag file, and press Open. If the file is properly formed, the new tag is added to the available tags list. To write protect the tag, select the tag and select the **Locked** option. When a tag is locked, no data can be written to the tag.

Click **Remove tag** to remove any tag from the list. If it is a tag you created, the original file on disk is not affected. If the default tags are removed, they reappear when you restart the demo.

5. Optional. Instead of performing interactive actions in the external events generator, you can use a script to do the same thing.

Create a file as directed in "**Script Format**." In the external events generator, click the Browse button to locate your script, then press Play.

---

**Tag File Formats**

Tags are created in XML format in accordance with the NFC and NDEF standards. To see how the sample files are formed, see: *installdir/toolkit-lib/modules/emulator-ui-window-external-events/jsr257/conf/tags*.

A sample file with several records might look like this:

**Example 26–1 Tag File Format Example**

```xml
<?xml version="1.0" encoding="UTF-8"?>
<jsr257client>
  <UID>12-CD-45-67-89-AB-CD</UID>
  ...
  <TargetProperties>
    <TargetProperty>NDEF</TargetProperty>
  </TargetProperties>
  ...
  <NDEFMessage>
    <NDEFRecord>
      <Format>MIME</Format>
      <Name>text/plain</Name>
      <Id>mimeid</Id>
      <Payload>Hello, MIME World!</Payload>
    </NDEFRecord>
    <NDEFRecord>
      <Format>MIME</Format>
      <Name>text/example</Name>
      <Id>urn:company:product:ndef:payload:2</Id>
      <Payload>payload2</Payload>
    </NDEFRecord>
    <NDEFRecord>
      <Format>EXTERNAL_RTD</Format>
      <Name>urn:nfc:ext:oracle.com:type1</Name>
      <Id></Id>
      <Payload>payload3</Payload>
    </NDEFRecord>
    <NDEFRecord>
      <Format>URI</Format>
  </NDEFMessage>
</jsr257client>
```
<Name>urn:company:product:test_uri</Name>
<Id>urn:company:product:ndef:payload:4</Id>
<Payload>payload4</Payload>
</NDEFRecord>

<NDEFRecord>
<Format>NFC_FORUM_RTD</Format>
<Name>urn:nfc:wkt:Sp</Name>
<Id></Id>
<Payload>smart-poster</Payload>
</NDEFRecord>

<NDEFRecord>
<Format>MIME</Format>
<Name>text/x-vCard</Name>
<Id>duke</Id>
<Payload>BEGIN:VCARD VERSION:2.1 FN:Oracle TEL:+1-650-506-7000
ADR:500 Oracle Parkway City:Redwood Shores
State:CA;94065 END:VCARD
</Payload>
</NDEFRecord>
</NDEFMessage>
</jsr257client>

**Script Format**

You can use the external events generator buttons to attach and detach a tag, or you can write a script to perform these actions. The script syntax is as follows:

**Example 26–2 Tag Script File Format Example**

```plaintext
# Comment:
# this is a comment
# Tag definition:
tag <tag name> <path to the tag xml file>
# Attach tag:
attach <tag name>
# Delay. Ensures the tag is attached before other actions.
wait <time in ms>
# Print tag information:
print <tag name>
# Detach tag:
detach <tag name>
```

This is a sample script:

**Example 26–3 Tag Script Sample**

```plaintext
tag C D:\MyTags\ccomtag.xml
attach C
print C
wait 10000
detach C
```

In the external events generator, click **Browse** and select the script file, then press **Play** to run the script. The results are shown in the Log area. For example, if the sample script calls the sample tag file in "Tag File Formats," the log output is as follows:

```
[18:24:10] Run Script: D:\JMESDKLocal\ccomtag.xml
[18:24:10] Define tag 2058 (C)
[18:24:10] Print 2058 (C)
[18:24:10] Attached tag 2058 (C)
```
Properties: NDEF
NDEF message: 8 record(s)
#0: NDEF record: format=MIME, name=text/plain, id.length=2, payload.length=18
payload=Hello, MIME world!
#1: NDEF record: format=MIME, name=text/example, id.length=34, payload.length=8
payload=payload2
#2: NDEF record: format=EXTERNAL_RTD, name=oracle.com:type1, payload.length=8
payload=payload3
#3: NDEF record: format=URI, name=urn:company:product:test_uri, id.length=34,
payload.length=8
payload=payload4
#4: NDEF record: format=EXTERNAL_RTD, name=company.com:type1, id.length=34,
payload.length=8
payload=payload5
#5: NDEF record: format=NFC_FORUM_RTD, name=Sp, payload.length=12
payload=smart-poster
#6: NDEF record: format=URI, name=message/http, id.length=3, payload.length=56
payload=http://www.oracle.com/technetwork/java/javame/index.html
#7: NDEF record: format=MIME, name=text/x-vCard, id.length=4, payload.length=122
payload=BEGIN:VCARD VERSION:2.1 FN:Oracle TEL:+1-650-506-7000
ADR:500 Oracle Parkway; City:Redwood Shores;State:CA;94065 END:VCARD
[18:24:10] Wait 10000ms
[18:24:20] Detached tag 2058 (C)
[18:24:25] Received data for unknown tag 2,058
The Oracle Java ME SDK requires an execution model that makes certain networked resources available for emulator execution. These required resources might include - but are not limited to - a variety of communication capabilities between Oracle Java ME SDK components.

**Note:** the Oracle Java ME SDK installation and runtime system is fundamentally a developer system. It is not designed to guard against any malicious attacks from outside intruders.

During execution, the Oracle Java ME SDK architecture can present an insecure operating environment to the platform’s installation file system, as well as its runtime environment. For this reason, it is critically important to observe the precautions outlined in these guidelines when installing and running the Oracle Java ME SDK.

### Maintaining Optimum Network Security

To maintain optimum network security, Oracle Java ME SDK can be installed and run in a “closed” network operating environment, where the Oracle Java ME SDK system is not connected directly to the Internet. Or, it can be connected to a secure company Intranet environment that can reduce unwanted exposure to malicious intrusion.

An example of an Oracle Java ME SDK requirement for an Internet connection is when wireless functionality requires a connection to the Internet to support communications with the wireless network infrastructure that is part of a Java ME application execution process. Whether or not an Internet connection is required depends on the particular Java ME application running on Oracle Java ME SDK. For example, some Java ME applications can use an HTTP connection.

In any case, if the Oracle Java ME SDK is open to any network access you must observe the following precautions to protect valuable resources from malicious intrusion:

- Installing the Oracle Java ME SDK Demos plugin is optional. Some sample projects use network access and open ports. Because the sample code does not include protection against malicious intrusion, you must ensure your environment is secure if you select to install and run the sample projects.

- Install the Oracle Java ME SDK behind a secure firewall that strictly limits unauthorized network access to the Oracle Java ME SDK file system and services. Limit access privileges to those that are required for Oracle Java ME SDK usage while allowing all the bidirectional local network communications that are necessary for Oracle Java ME SDK functionality. The firewall configuration must
support these requirements to run the Oracle Java ME SDK while also addressing them from a security standpoint.

- Follow the principle of “least privilege” by assigning the minimum set of system access permissions required for installation and execution of the Oracle Java ME SDK.
- Do not store any data sensitive information on the same file system that is hosting the Oracle Java ME SDK.
- To maintain the maximum level of security, make sure the operating system patches are up-to-date on the Oracle Java ME SDK host machine.