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This document describes how to install the ADF Skin Editor that creates ADF skins for
applications built using different releases of Oracle ADF.
This document includes the following sections:
■

Section 1, "ADF Skin Editor System Requirements"

■

Section 2, "Installing the ADF Skin Editor"

■

Section 3, "Using the ADF Skin Editor on Windows"

■

Section 4, "Using the ADF Skin Editor on Linux and UNIX Systems"

■

Section 5, "Using the ADF Skin Editor on Mac OS X Platforms"

■

Section 6, "Enabling ADF Skin Editor Extensions"

■

Section 7, "Setting the User Home Directory"

■

Section 8, "Documentation Accessibility"

1 ADF Skin Editor System Requirements
This release of the ADF Skin Editor is tested and supported on the specific versions
Windows, Linux, and Mac OS X, as listed in Section 1.1, "Recommended CPU,
Memory, Display, and Hard Drive Configurations." In addition, it is supported on any
operating system that supports Java SE Development Kit (JDK) 7 Update 15 or later.
For the most current information on software that is certified for use with the ADF
Skin Editor, see the Certification Information link for this release on the Oracle
Technology Network (OTN) web site:
http://www.oracle.com/technetwork/developer-tools/jdev/documenta
tion/index.html

1.1 Recommended CPU, Memory, Display, and Hard Drive Configurations
The following tables list the recommended CPU, memory, display, and hard drive
requirements for the different operating systems:
■

■

■

Table 1, " Recommended CPU, Memory, Display, and Hard Drive Requirements
for Windows"
Table 2, " Recommended CPU, Memory, Display, and Hard Drive Requirements
for Linux"
Table 3, " Recommended CPU, Memory, Display, and Hard Drive Requirements
for MAC OS X"
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The following table lists the recommended CPU, memory, display, and hard drive
requirements for the Windows operating system:
Table 1 Recommended CPU, Memory, Display, and Hard Drive Requirements for
Windows
Resource

Recommended

Operating System

Windows 7
Windows XP-Service Pack 3

CPU Type and Speed

Pentium IV 1.70 GHz or faster

Memory

32-bit systems: 2 GB RAM
64-bit systems: 3 GB RAM

Display

65536 colors, set to at least 1024 X 768 resolution

Hard Drive Space

500 MB

JDK

JDK 7.0 Update 15 for Windows, available at:
http://www.oracle.com/technetwork/java/javase/downloads/index.html

The following table lists the recommended CPU, memory, display, and hard drive
requirements for the Linux operating system:
Table 2

Recommended CPU, Memory, Display, and Hard Drive Requirements for Linux

Resource

Recommended

Distribution

Red Hat Enterprise Linux 6.0
Red Hat Enterprise Linux 5.0
Oracle Enterprise Linux 6.0
Oracle Enterprise Linux 5.0
SUSE Linux Enterprise Server 11

CPU Type and Speed

Pentium IV 1.70 GHz or faster

Memory

2 GB RAM

Display

65536 colors, set to at least 1024 X 768 resolution

Hard Drive Space

500 MB

JDK

JDK 7.0 Update 15 for Linux, available at:
http://www.oracle.com/technetwork/java/javase/downloads/index.html

The following table lists the recommended CPU, memory, display, and hard drive
requirements for the Mac OS X operating system:
Table 3
OS X

Recommended CPU, Memory, Display, and Hard Drive Requirements for MAC

Resource

Recommended

Operating System

Apple Mac OS X Version 10.6 or later

CPU Type and Speed

64-bit Intel processors

Memory

3 GB RAM

Display

"Thousands" of colors

Hard Drive Space

500 MB

JDK

Mac Java 7 Update 18 or later, available at:
http://www.java.com/en/download/faq/java_
mac.xml
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2 Installing the ADF Skin Editor
The ADF Skin Editor does not require an installer. You install it by extracting it from
the skineditor.zip file that it is packaged in. To download the skineditor.zip
file, see Oracle ADF's Download page on the Oracle Technology Network at:
http://www.oracle.com/technetwork/developer-tools/adf/downloads/
index.html.
To install the ADF Skin Editor, you will need an unzip tool. You can download a free,
cross-platform unzip tool, Info-Zip, available at: http://www.info-zip.org/.
Caution: Make sure that you install the ADF Skin Editor into a
directory that does not contain spaces. For example, do not use
C:\Program Files as the installation directory.

To install the ADF Skin Editor from skineditor.zip:
1.

If you do not have JDK 7.0 Update 15 or later installed, you can obtain it from:
http://www.oracle.com/technetwork/java/javase/downloads/index
.html.

2.

Unzip skineditor.zip to the target directory.
Caution: After you unzip skineditor.zip to the target directory,
do not rename the skineditor directory that contains the ADF Skin
Editor executable. For example, if you unzipped skineditor.zip to
C:\installdir, do not rename the skineditor directory at the
following location: C:\installdir\skineditor. This directory is
part of the ADF Skin Editor installation.

For the remainder of this document, in the context of the ADF
Skin Editor, MW_HOME is used to represent the directory of the
installation. For example, if you unzipped skineditor.zip into
C:\installdir, then MW_HOME refers to
C:\installdir\skineditor.
Note:

3 Using the ADF Skin Editor on Windows
Once the installation is complete, you can begin using the ADF Skin Editor on
Windows systems.

3.1 Starting the ADF Skin Editor
To start the ADF Skin Editor on Windows, run the following command from the
command line:
■

MW_HOME\skineditor.exe
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3.2 Specifying the JDK location
Specify the location of your JDK installation in the dialog that appears when you start
the ADF Skin Editor for the first time. You need to enter the path to the Java
executable, for example D:\jdk1.7.0_15\bin.

3.3 Changing the JDK location
To change a JDK location that you have previously specified, set the variable
SetJavaHome in the file MW_HOME\skineditor\bin\skineditor.conf to the
location of your JDK installation. Use an editor that recognizes UNIX end-of-line
characters, such as WordPad. When you save the file, WordPad warns you that it is
about to save the file in text-only format. You can ignore this warning.
For example, in a Windows environment, if the location of your JDK is in a directory
called jdk1.7.0_15 on your D: drive, your entry in skineditor.conf is:
SetJavaHome d:\jdk1.7.0_15

3.4 User Directories
The following list describes the default directory structure within the ADF Skin Editor
on Windows:
■

■

The default location for the system subdirectory is
%APPDATA%\skineditor\system12.1.2.0.XX.XX.XX, where XX.XX.XX is
the unique number of the product build.
The default location for user-generated content is:
-

C:\Users\user\Documents\skineditor\mywork on Windows 7
systems.

-

C:\skineditor\mywork on all other Windows platforms.

For more information on user directories and how to set the value for the home
environment variable, see Section 7, "Setting the User Home Directory."

4 Using the ADF Skin Editor on Linux and UNIX Systems
Once the installation is complete, you can begin working with the ADF Skin Editor on
Linux and UNIX systems.

4.1 Changing System Cursors
On UNIX or Linux platforms, the Java cursors may display large and opaque, creating
difficulties when used for drag and drop operations. To address this problem the ADF
Skin Editor provides a set of cursors to replace the default set. You must have write
access to the JDK in order to replace the cursors.
To replace the cursors:
1.

Make a backup copy of the default cursors located in the JDK directory at:
<jdk_install>/jre/lib/images/cursors

2.

Extract the replacement cursors from the tar file at:
MW_HOME/skineditor/jdev/bin/clear_cursors.tar

4

4.2 Setting the System Resource Limit
The minimum recommended system resource limit for the ADF Skin Editor on Linux
systems is 4096.
To determine the resource limit configuration for your system, enter:
■

/bin/sh -c ulimit -n

If the value returned is less than 4096, you set the system resource limit:
1.

Open the limits.conf file, which is located in the /etc/security/ directory.

2.

Look for the following lines:
*
*

3.

soft nofile <value>
hard nofile <value>

In the lines, change the value to 4096. The lines will then read:
*
*

soft nofile 4096
hard nofile 4096

In case the lines listed in Step 2 do not exist, add the lines
listed in Step 3 to the limits.conf file.

Note:

4.3 Starting the ADF Skin Editor
To start the ADF Skin Editor on Linux and UNIX, run the following file:
MW_HOME/skineditor/bin/skineditor

4.4 Specifying the JDK location
When you start the ADF Skin Editor for the first time, the skineditor script prompts
you to provide the location of your JDK installation if it cannot locate it. You need to
enter the path to the Java executable, for example /usr/local/java/bin/java.

4.5 Changing the JDK location
To change a JDK location that you have previously specified, set the variable
SetJavaHome in the file MW_HOME/skineditor/bin/skineditor.conf to the
location of your Java installation.
For example, in a UNIX environment, if the location of your JDK is in a directory
called /usr/local/java, your entry in skineditor.conf is:
SetJavaHome /usr/local/java

5 Using the ADF Skin Editor on Mac OS X Platforms
Once the installation is complete, you can begin using the ADF Skin Editor on Mac OS
X platforms.

5.1 Starting the ADF Skin Editor
To start the ADF Skin Editor, run the following file:
MW_HOME/skineditor/bin/skineditor.
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5.2 Specifying the JDK location
When you start the ADF Skin Editor for the first time, the skineditor script prompts
you to provide the location of your JDK installation if it cannot locate it. You need to
enter the path to the Java executable, for example /usr/local/java/bin/java.

5.3 Changing the JDK location
To change a JDK location that you have previously specified, set the variable
SetJavaHome in the file MW_HOME/skineditor/bin/skineditor.conf to the
location of your Java installation.
For example, in a Mac OS X environment, if the location of your JDK is in a directory
called /usr/local/java, your entry in skineditor.conf is:
SetJavaHome /usr/local/java

6 Enabling ADF Skin Editor Extensions
You can use the ADF Skin Editor to create ADF skins for Fusion web applications built
on different releases of Oracle ADF. Before you create an ADF skin that targets a
different release, you may need to download an extension from OTN that provides
support for the release you want to target.
To automatically download and install an ADF Skin Editor extension:
■

From the Help menu, select Check for Updates.
On the Source page of the Check for Updates wizard, you can specify the update
center to download the extension from, or specify a local file from which to install
the extension.
Search the Official Oracle Extensions and Updates update center to download
extensions for the ADF Skin Editor.

To manually download an ADF Skin Editor extension:
1.

Go to
http://www.oracle.com/ocom/groups/public/@otn/documents/webco
ntent/131167.xml.

2.

Select an extension for the ADF Skin Editor.

3.

Follow the instructions to download the zip file.

To manually install an extension for the ADF Skin Editor:
1.

Verify if there are additional installation instructions in the extension archive.

2.

From the Help menu, select Check for Updates.

3.

On Step 1 of the wizard, select Install from a Local File and navigate to the ZIP
file.

4.

Finish the wizard and restart ADF Skin Editor. After you restart ADF Skin Editor,
you will be able to use the extension.

For more information, click Help in the dialogs that the Check for Updates wizard
displays.
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7 Setting the User Home Directory
This section provides instructions on how to define a user home environment variable
and set its value for each user in order for the ADF Skin Editor to identify user home
directories correctly.
The user home directory contains the user's preferences for the ADF Skin Editor (in the
system subdirectory). It is also the default location for new projects (in the
\skineditor\mywork\ directory) as well as other configuration files that are
specific to a given user.
Caution: Make sure that you choose a directory that does not contain
spaces. For example, do not use C:\My Home as your home directory.

To define the name of the user home environment variable:
1.

Open the file MW_HOME/skineditor/bin/skineditor.boot in a text editor.
Use an editor that recognizes UNIX end-of-line characters, such as WordPad.

2.

Find the entry:
ide.user.dir.var = JDEV_USER_HOME, JDEV_USER_DIR
This is the default variable that the ADF Skin Editor looks for at startup. You can
define or add any environment variable that the ADF Skin Editor should use. As
the terminal server administrator, you may change the name of this variable to
follow your system's naming conventions.
You can explicitly set the home environment variable by
adding the following line in the skineditor.boot file:
ide.user.dir = <Path to preferred user directory>
Note:

The output should look something like this:
ide.user.dir = D:\users\jdoe (on Windows)
ide.user.dir = /home/users/jdoe (on Linux and UNIX)

3.

Save the file. If you are using WordPad, it warns you that it is about to save the file
in text-only format. You can ignore this warning.

The user home directory can also be specified from the command line using this
command:
skineditor.exe -J-Dide.user.dir=<Path>
Examples:
■

skineditor.exe -J-Dide.user.dir=D:\users\jdoe (on Windows).

■

skineditor -J-Dide.user.dir=/home/users/jdoe (on Linux and UNIX).

7.1 Setting the Home Environment Variable on Windows
To set the home environment variable on a Windows systems, including individual
users of the ADF Skin Editor on a multiuser system, use the following steps:
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Caution: Do not set the home environment variable to a directory
that contains spaces. For example, do not specify C:\My Projects
as the home directory.

1.

From the Windows Start menu, select Control Panel, and then select System.

2.

Select the Advanced tab, then click Environment Variables.

3.

In the User Variables section, click New.

4.

Add JDEV_USER_DIR, or the name you chose for ide.user.dir.var, as a user
variable.

5.

Set the value of this variable to your home directory (for example,
N:\users\jdoe), and click OK.

6.

To check your variable setting, open a command shell and enter:
set
You should see output similar to the following:
JDEV_USER_DIR=N:\users\jdoe

7.

Launch the ADF Skin Editor.

8.

From the Help menu, select About to verify that the value of ide.user.dir is
set to your user home directory.

7.2 Setting the Home Environment Variable on Linux and UNIX
Use the following steps to set the environment variable on Linux and UNIX systems.
The examples and syntax provided refer to the C Shell.
Caution: Do not set the home environment variable to a directory
that contains spaces. For example, do not specify home/jdoe/my
projects as the home directory.

1.

In your startup configuration file (for example, .cshrc), set the environment
variable to your preferred directory. For example, use the following command to
set the home environment variable to mydocs/skinfiles under the $HOME
directory:
setenv JDEV_USER_DIR $HOME/mydocs/skinfiles

2.

Source the file to make your changes take effect:
source .cshrc

3.

Display the environment variable to confirm the change:
echo $JDEV_USER_DIR
You should see output similar to the following:
/home/jdoe/mydocs/skinfiles

4.

Launch the ADF Skin Editor.

5.

From the Help menu, select About to verify that the value of ide.user.dir is
set to your user home directory.
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By default, the user home directory on Linux and UNIX is $HOME/jdevhome.

7.3 Setting the Home Environment Variable on Mac OS X
Use the following steps to set the environment variable on Mac OS X systems. The
examples and syntax provided refer to the BASH shell.
Caution: Do not set the home environment variable to a directory
that contains spaces. For example, do not specify home/jdoe/my
projects as the home directory.

1.

In your startup configuration file (for example, .bashrc), set the environment
variable to your preferred directory:
JDEV_USER_DIR=$HOME/mydocs/skinfiles

2.

Export the new value of the environment variable:
export JDEV_USER_DIR

3.

Source the file to make your changes take effect:
. .profile

4.

Display the environment variable to confirm the change:
echo $JDEV_USER_DIR
You should see output similar to the following:
/users/jdoe/mydocs/skinfiles

5.

Launch the ADF Skin Editor.

6.

From the Help menu, select About to verify that the value of ide.user.dir is
set to your user home directory.

By default, the user home directory on Mac OS X is $HOME/jdeveloper.

8 Documentation Accessibility
For information about Oracle's commitment to accessibility, visit the Oracle
Accessibility Program website at
http://www.oracle.com/pls/topic/lookup?ctx=acc&id=docacc.
Access to Oracle Support
Oracle customers have access to electronic support through My Oracle Support. For
information, visit
http://www.oracle.com/pls/topic/lookup?ctx=acc&id=info or visit
http://www.oracle.com/pls/topic/lookup?ctx=acc&id=trs if you are
hearing impaired.
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