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7 Getting Started with Developing Java Applications


This chapter is an overview of the tools and features that JDeveloper provides to speed up the process of writing Java code.

This chapter includes the following sections:

	
About Developing Java Applications


	
Using the Java Source Editor


	
Using Code Insight


	
Using Code Peek


	
Using Scroll Tips


	
Using InfoTips


	
Searching Incrementally


	
Using Shortcut Keys


	
Bookmarking


	
Browsing Java Source


	
Using Code Templates


	
Setting Preferences for the Java Source Editor


	
Using Toolbar Options


	
Using the Quick Outline Window


	
Working with the Java UI Visual Editor








7.1 About Developing Java Applications


JDeveloper enables you to build and assemble Java applets and client applications using JavaBeans and interactive, desktop-based GUI applications using Swing and AWT components. You can also create and run Java client applications with Java Web Start within the JDeveloper IDE.







7.2 Using the Java Source Editor


The Java Source Editor displays Java source files, and facilitates editing of Java code. The Java Source editor is a specialized form of the generic Source Editor that JDeveloper provides for editing source code across several technologies, including XML, JSP, and HTML.

Double-clicking a node in the Applications window either opens or brings the default editor to the foreground. When a file is open in the Source Editor, its corresponding elements are displayed hierarchically in the Structure window. Double-clicking a node in the Structure window shifts the focus to the definition of that element in the Source Editor.

You can customize the behavior of the Java Source Editor by specifying preferences in the Preferences Dialog. For more information, see Setting Preferences for the Java Source Editor.







7.3 Using Code Insight


With Java Code Insight, you can filter out unnecessary information such as top-level packages, imported classes, default Object methods, deprecated items, and emphasize more key detail such as local variables, locally declared members, overloaded methods.

You can use Code Insight to speed up the process of writing code. Code Insight has two varieties: completion insight and parameter insight. You can enable or disable each independently and set the delay in seconds for each to appear when the cursor is paused at an appropriate insertion point.

To invoke completion after typing the period separator or, in the default keymap, press Ctrl+Space. To invoke parameter insight, pause after typing an opening (the left) parenthesis or, in the default keymap, press Ctrl+Shift+Space. To exit either type of insight at any time, press Esc. Note that if you change your keymap ping, these keyboard accelerators may change. You can click QuickDoc, located at the bottom right of the completion insight list, to display the Javadoc for the currently selected element

After a method has been completed by completion insight, the source editor automatically fills in the parameters based on the method code.

You can tab between these parameters, and edit them manually or using parameter insight. The source editor will automatically add an import if it can find only one exact match for an unresolved reference to a class. You can set preferences for this feature in the Preferences Dialog.

You can also use and configure member insight, the Java-specific implementation of Code Insight's completion insight, and you can choose to display deprecated members or not in Code Insight's parameter insight window.

Member insight provides you with a list of which instance and static members (fields, methods, inner classes) are accessible from a given statement context. For example, it tells you which methods you can call from any given method.

To change Code Insight settings or to view or change accelerators, from the main menu choose Tools > Preferences to open the Preferences dialog and then navigate to the appropriate page. For more information, see Editing with the Java Visual Editor





7.3.1 Using Code Insight to Add Annotations to Your Java Code



An annotation is used to associate information with a program element. Annotations can be used in classes, fields, methods, parameters, local variables, constructors, enumerations, and packages. To add annotations in your Java code: declare the annotation, create a function, and then add your annotations.

When you start adding an annotation, Member Insight (Ctrl+Space) displays a list of options (fields, members, classes) based on the statement context. Parameter Insight (Ctrl+Shift+Space) displays information about the annotation like the names of the elements of the annotation type, the default values, and the created values. It also highlights the element currently under the cursor in the annotation.

For more information see How to Add Documentation Comments.











7.4 Using Code Peek



You can hold down the Shift key and then hover over a variable or method to show its definition in a ghost window. This feature makes it convenient to quickly view code without moving cursor focus from your current code.


Figure 7-1 Code Peek

[image: This image is described in the surrounding text]









7.5 Using Scroll Tips



While dragging the vertical scroll bar, a small tip window appears next to the bar, revealing the methods that are visible or partially visible on screen. This enables you to more easily see what methods are in view while quickly scrolling. You can also see the name of the method whose beginning is not immediately in view.









7.6 Using InfoTips



An InfoTip is a pop-up window that reveals additional detail about an item in the application, for example, text in the Java Source Code editor and the overview gutter. You display the InfoTip by pointing or hovering over the item with your mouse cursor. It remains visible until you move the mouse away or click elsewhere in the UI.


Figure 7-2 InfoTips

[image: This image is described in the surrounding text]









7.7 Searching Incrementally



To search incrementally, from the main menu choose Search > Incremental Find Forward or Search > Incremental Find Backward. Begin typing in the dialog that displays. As you type, the cursor jumps to the next instance of that particular letter combination, either forward or backward. The search does not support wildcards.









7.8 Using Shortcut Keys



Shortcut keys, or accelerators, are combinations of keys that you can use to navigate or to perform certain operations using the keyboard instead of the mouse. You can select from a variety of predefined keymaps or define your own accelerators.

To view or change existing accelerators, to define new accelerators, or to load preset keymaps, from the main menu choose Tools, then Preferences to open the Preferences dialog and then navigate to the Shortcut Keys page. To view or change accelerators for the editor, select Code Editor from the Category list.

Note that block commenting is indicated by Toggle Line Comments. It is defined in the default keymap as Ctrl-Shift-Slash or Ctrl-Slash.

For more information, see Keyboard Navigation in .









7.9 Bookmarking



While bookmarking code:





	
You can see a list of all bookmarks you have created in a Bookmarks window. This window appears when you click the Go to Bookmark icon. This window also displays the line number and method name that contains the bookmark.


Figure 7-3 Go to Bookmark Icon

[image: This image is described in the surrounding text.]


	
You can create numbered bookmarks using the keyboard shortcut Ctrl+Shift+<number>. You can quickly navigate to that bookmark by pressing Ctrl+<number>.




For more information, see How to Set Bookmarks in Source Files.









7.10 Browsing Java Source



To navigate to the source for any identifier in an open Java file, right-click on the identifier you would like to browse and choose Go to Declaration. Alternatively, you can hold down the Ctrl key and click on an identifier to navigate to its source. If the source is not available, JDeveloper will reverse-engineer the class file. You may browse imported classes and interfaces, member fields and methods, and local variables. If you are browsing a method or constructor invocation, this declaration search will resolve the types in order to determine the correct method or constructor invocation. For instance, the following code revokes the declaration search at SetText. It brings up the source code for javax.swing.JButton, with the SetText() method displayed.


import javax.swing.JButton
...
JButton b1 = new JButton();
...
b1.SetText: ('OK');


If the identifier cannot be browsed or if there is nothing at that cursor position, this search command on the context-sensitive menu will be disabled. If JDeveloper is unable to locate the appropriate location to jump to or if the identifier cannot be browsed due to access restrictions (for example, private members), the Java Source Editor's status bar will display a message indicating so.









7.11 Using Code Templates



Code templates are sections of pre-written code that can be conveniently inserted into source file to avoid typing it in manually. Templates can intelligently modify the inserted code to suit its surrounding code, and imports required by code templates are automatically imported.

A complete list of all code templates is available in the Code Editor Help. To edit or create code templates, or to view or change accelerators, from the main menu choose Tools > Preferences to open the Preferences dialog and then navigate to the appropriate page.

For more information, see How to Use Code Templates.









7.12 Setting Preferences for the Java Source Editor



You can customize the behavior of the Java Source Editor using the Preferences Dialog. You can also use the Preferences Dialog to specify settings for the general source editing environment. For more information, see How to Set Preferences for the Source Editor.

To set the options for Code Insight as it applies to Java:




	From the main menu, choose Tools > Preferences.
	In the Preferences dialog, expand the Code Editor node.

A list of selectable options displays, for example, Bookmarks and Code Templates.




	Click an option and choose options that appear on the new page that displays.
	Click OK when you are finished.






7.12.1 How to Set Comment and Brace-Matching Options for the Java Source Editor



JDeveloper enables you to set comment and brace-matching options for the Java source editor. For example, you can choose to add leading and closing asterisks as you add new lines either in multi-line Java comments or in Javadoc comments.

To set the options for Java comment and brace matching in the source editor:




	From the main menu, choose Tools > Preferences.
	In the Preferences dialog, expand the Code Editor node.
	Select the Display node.
	On the Display page, enable or disable automatic brace matching and set the delay time.
	Click OK.
	Reopen the Preferences dialog, expand the Code Editor node, and select the Java node.
	On the Java page, set the attributes for comments and brace matching to create the behavior that you want.

For example, you can select the Add Closing Bracket or Parenthesis Automatically option.




	Click OK.



Note that block commenting is an accelerator function. In the default keymap, use Ctrl+Shift+/ or Ctrl+/ to block-comment Java code.









7.12.2 How to Set Import Statement Sorting Options for the Java Source Editor



You can set options to sort import statements in the Java Source Editor.

To set the options for sorting import statements:




	From the main menu, choose Tools > Preferences.
	In the Preferences dialog, expand the Code Editor node.
	Expand the Java node and select Imports.
	On the Imports page, choose options to create the behavior that you want when sorting import statements in the editor.
	Click OK.








7.12.3 How to Choose a Coding Style



You can use the Tools > Preferences dialog to select a profile that determines the style of code shown in the Java Source Code editor. The coding style determines Java Code conventions such as formatting, how import statements display in code, variable names, and member order.

To select a coding style for the Java Source Code editor:




	From the main menu, choose Tools > Preferences.
	In the Preferences dialog, expand the Code Editor node.
	Click the Code Style node.
	On the Code Style page, choose a Profile.
	Click OK.






7.12.3.1 How to Edit a Coding Style



You can edit an existing coding style and make it available as a selectable Profile option on the Code Style page. You can also import an existing code style profile from an XML file.

To edit an existing code profile:




	Follow the steps in How to Choose a Coding Style to choose an existing profile in the Profile list.
	Click Save As and enter a name for your new profile.
	Click Edit.
	In the Edit Code Style Profile - Java Code Conventions page, choose options for your new profile.
	Click OK.
	You can alternately click Import to import a code style profile into JDeveloper from an XML file.








7.12.3.2 How to Set Up a Coding Style Using an Extension



You can create a custom coding profile using an extension, then set it as the default for a role, for example, developer, using the extension.xml file. For more information, see "Introduction to Developing Oracle JDeveloper Extensions" in Developing Extensions for Oracle JDeveloper.

To set a default coding profile using an extension:




	Edit a custom style according to How to Edit a Coding Style.
	Choose Export from the More Actions list.
	Add it to an extension and put an entry in the extension.xml file, similar to the following.:


<hooks>
  <code-style xmlns="http://xmlns.oracle.com/ide/extension">
    <profile-url>/META-INF/custom-profile.xml<profile-url>
  </code-style>
<hooks>




	To set the profile as the default style, add a section to the role shaping file with the profile name, similar to the following:


<c:settings-ui-customizations>
  <c:page idref="/preferences/ceditor/style">
    <c:field idref="CodingStylePreferences.profile">
       <c:value>Custom Profile</c:value>
    </c:field>
  </c:page>
</c:settings-ui-customizations> 
















7.13 Using Toolbar Options



The Java Source Editor displays Java source files, and facilitates editing of Java code. Icons that perform various features are located at the top of the Java Source Editor, as described in Table 7-1.







Table 7-1 Toolbar Options

	Icon	Name	Description
	
[image: This image is described in the surrounding text.]

	
Quick Outline

	
Click to display a tree of the available methods and fields of the current class and its super classes.

Clicking this icon brings up the Quick Outline window (for more information, see Using the Quick Outline Window). This window floats just above the code and contains a tree of the available methods and fields of the current class and its super classes. You can instantly start typing in a filter field to reduce the visible items, allowing quick and easy selection for navigation to the desired place


	
[image: This image is described in the surrounding text.]

	
Code Highlight

	
Click to highlight all instances of the code component that the cursor is currently placed on.


	
[image: This image is described in the surrounding text.]

	
Clear All Highlighting

	
Click to clear all highlighting.


	
[image: This image is described in the surrounding text.]

	
Surround

	
Click to surround the currently selected block of text in the Java Source Editor with a coding construct, using the Surround With dialog.


	
[image: This image is described in the surrounding text.]

	
Generate Accessors

	
Click to insert get and set methods into a class, using the Generate Accessors dialog.


	
[image: This image is described in the surrounding text.]

	
Override Methods

	
Click to override inherited methods for the class in focus.


	
[image: This image is described in the surrounding text.]

	
Implement Interfaces

	
Click to modify a target class to implement one or more interfaces, or to make a target interface extend one or more other interfaces, using the Implement Interface dialog.


	
[image: This image is described in the surrounding text.]

	
Reformat

	
Click to apply source formatting to your code.


	
[image: This image is described in the surrounding text.]

	
Toggle Bookmark

	
Click to insert or remove a bookmark on the line of code currently in focus.


	
[image: This image is described in the surrounding text.]

	
Go to Next Bookmark

	
Click to place the cursor at the next bookmark.


	
[image: This image is described in the surrounding text.]

	
Go to Previous Bookmark

	
Click to place the cursor at the previous bookmark.


	
[image: This image is described in the surrounding text.]

	
Show Selected Element Only

	
Click to view only one particular element in the editor. You can use this feature to tightly focus on a method, class, inner class, or field declaration. A message at the bottom of the file reminds you that the Show Selected Element mode is currently active.


	
[image: This image is described in the surrounding text.]

	
Block Coloring

	
Click to activate block coloring. You can use this feature to highlight blocks of code for better readability. Coloring preferences can be set using the Preferences Dialog.













7.14 Using the Quick Outline Window



Clicking the Quick Outline Toolbar icon (Figure 7-4) to the right of the Find field in the Java source editor displays the Quick Outline window shown in Figure 7-5.


Figure 7-4 Quick Outline Icon

[image: This image is described in the surrounding text.]


This window floats just above the code and contains a tree of the available methods and fields of the current class and its super classes. You can instantly start typing in a filter field to reduce the visible items, allowing quick and easy selection for navigation to the place.


Figure 7-5 Quick Outline Window

[image: This image is described in the surrounding text]


Table 7-2 lists the available icons and options.







Table 7-2 Quick Toolbar Icons

	Icon	Name	Description
	
[image: This image is described in the surrounding text.]

	
Show Methods

	
Click to display methods and constructors. The default is methods, fields, and static members all displayed.


	
[image: This image is described in the surrounding text.]

	
Show Fields

	
Click to display fields. The default is methods, fields, and static members all displayed.


	
[image: This image is described in the surrounding text.]

	
Show Static Members

	
Click to display static members. The default is methods, fields, and static members all displayed.


	
[image: This image is described in the surrounding text]

	
Show Public Members Only

	
Click to display only public members. The default value is deselected.


	
[image: This image is described in the surrounding text.]

	
Show Inherited Member

	
Click to display only inherited members.


	
[image: This image is described in the surrounding text.]

	
Sort Alphabetically

	
Click to sort class members alphabetically. The default value is deselected.


	
[image: This image is described in the surrounding text.]

	
Sort by Type

	
Click to sort class members first by type (in this order: constructors, methods, fields, inner classes), and then alphabetically within those categories. The default value is selected.

Click the down arrow next to Sort Alphabetically to view the option.


	
[image: This image is described in the surrounding text.]

	
Sort by Access

	
Click to sort class members first by access modifier, and then alphabetically within those categories. The default value is deselected.

Click the down arrow next to Sort Alphabetically to view the option


	
[image: This image is described in the surrounding text.]

	
Show Detail Window

	
Click to open the Show Detail window for the selected item in the Quick Outline window.

In the Show Detail window, click the Documentation tab to view the package containing the item.

In the Show Detail window, click the Code tab to see its definition in the source file.













7.15 Working with the Java UI Visual Editor


The Java UI Visual Editor displays the visual components of a user interface in editing mode. For more information, see Editing with the Java Visual Editor .


Note:

You can use the Java Visual Editor for Swing/AWT Applications only.







7.15.1 Java Swing and AWT Components


Use Swing and AWT JavaBeans components to assemble the user interface (UI) for a Java application or applet. You construct the UI in the Java Visual Editor by selecting JavaBeans from the Components window, such as buttons, text areas, lists, dialogs, and menus. Then, you set the values of the component properties and attach event-handler code to the component events. Tools to visually design and program Java classes to produce new compound or complex component.

For more information, see About Java Swing UI Components and Containers.












6 Versioning Applications with Source Control


This chapter describes how to use source control systems to manage the versions of applications developed in a team environment. It discusses the available version control systems, how to download the various version-control extensions available to Oracle JDeveloper, and then includes instructions for each of the source control systems that can be used with JDeveloper.

This chapter includes the following sections:

	
About Versioning Applications with Source Control


	
Downloading Source Control Extensions in


	
Setting Up and Configuring Source Control


	
Setting Up and Configuring a Source Repository


	
Working with Files in Source Control


	
Working with Branches and Tags


	
Working with File History_ Status and Revisions


	
Working with Patches in Source Control








6.1 About Versioning Applications with Source Control


Developing in teams often requires coordination among multiple developers who may be called upon to make changes to the same files, to track these changes against project management or bug reporting systems, and eventually to check in or commit their edited files to a commonly used repository of content that will be built into a functioning product.

At least one team member is typically required to administer and maintain the versioning system as it relates to JDeveloper. If you are the administrator for your versioning system, you will most likely have additional tasks beyond checking files in and out.







6.2 Downloading Source Control Extensions in Oracle JDeveloper


For users familiar with other versioning systems, or whose teams use systems other than Subversion and Git, JDeveloper provides downloadable extensions that give you access to the following:

	
Concurrent Version System (CVS) http://www.oracle.com/pls/topic/lookup?ctx=E52620-01&id=OJDUG4067


	
Mercurial


	
Perforce http://www.oracle.com/pls/topic/lookup?ctx=E52620-01&id=OJDUG5473


	
Microsoft Team System http://www.oracle.com/pls/topic/lookup?ctx=E52620-01&id=OJDUG5476




If your team requires you to download a JDeveloper Extension to integrate your versioning system with JDeveloper, you can browse for the versioning system from the Update Center by selecting Help > Check for Updates. Be sure to select all update centers when you search for your versioning system.







6.3 Setting Up and Configuring Source Control


JDeveloper offers several tools for developing in teams. These include integrated solutions such as Subversion and Git, as well as downloadable extensions such as Mercurial. In addition, an application lifecycle management system, , is available as a downloadable extension. You can access commands for all of these systems directly from the JDeveloper interface, through the Team menu or through the Versions window





6.3.1 Setting Up Subversion and JDeveloper


JDeveloper is integrated with the popular team development solution Subversion (SVN). If you are part of a team that uses Subversion, JDeveloper's Team menu contains commands for using Subversion to manage the content you are working on while maintaining a connection to your team's repository and tracking changes, merges, and more. Setting up Subversion involves creating a repository for your source-controlled files, making sure that JDeveloper can connect to that repository, importing files to the repository, and more.

In general, you begin by importing your working files into the Subversion repository to bring them under version control.Once in the repository, your files are then available to be checked out from the Subversion repository to a local folder known as the "Subversion working copy." When you create a new file in JDeveloper (or move it into JDeveloper), you store it in the Subversion working copy. When you are ready to make your work available to the team, you add these new files to Subversion control. When it comes time to make your changed and new files available to other users, you can do so by committing them to the Subversion repository. To take advantage of the work others on your team have done, you can copy changed files from the Subversion repository to your working copy by updating your files.

After completing setup, your work with Subversion will revolve around checking files out, editing them in JDeveloper, and checking them in with your changes. You may also need to resolve conflicts between changes you made and those made by others in your team. Files may also be moved in and out of Subversion control, and finally, you might use special properties of the files associated with specific versions for tracking bugs, customer requests, and other characteristics.





6.3.1.1 Installing Subversion Client Software



In addition to creating a repository for your source-controlled files, making sure that JDeveloper can connect to that repository, and importing files to the repository, it may be necessary to install Subversion client software under the following circumstances:





	
You wish to create a local Subversion repository using the JDeveloper Subversion VCS extension.


	
You wish to use a Java binding (helper library) other than SVNKit, which is the one supplied with the extension.


	
You wish to connect to a Subversion repository through a proxy server




In all of the above cases, you will need to install separate Subversion client software. If you wish to use an alternate Java binding, you will additionally have to install the binding software.

To install Subversion client software:




	Download the Subversion installer (svn-1.7.8-setup.exe) from http://subversion.apache.org/ (to, for example, c:\downloads).
	Run the installer and place the Subversion client in a convenient location, for example c:\subversion. Reboot your computer.



This procedure assumes that the operating system is Windows. For non-Windows environments, consult the documentation for the operating system package management system to ensure the vendor-supplied Subversion client contains JavaHL.

To check the installation so far, open a command prompt and type svn help. You should see a list of subcommands. If not, check that the system path contains the bin directory of the location where the client software was installed (in this example, c:\subversion\bin).









6.3.1.2 Checking the Subversion Client Installation



Once you have completed installing the Subversion client software, you can check the Subversion Client installation.

Important: If you subsequently accept an update of the JDeveloper Subversion extension from the Update Center (Official Oracle Extensions and Updates), the client preference will be reset to SVNKit, even if you had previously chosen an alternate client.

To check the installation:




	In JDeveloper, select Subversion as the versioning system (Team > Configure, and then select Subversion).
	Open the main Subversion preferences page (Tools > Preferences > Versioning), and then check that the required client installation is available. If more than one is listed, select the one that you wish to use.








6.3.1.3 Creating a Subversion Connection



Before you can work with a Subversion repository through JDeveloper, you must create a connection to it. You can subsequently edit the connection details if they change for any reason.

Typically, you will obtain the details of your Subversion connection (server name, user ID, password, etc.) from your team or version control administrator. You will need to know those details before you create a connection to your Subversion repository.

To create a Subversion connection:




	In the Versions window (Team > Versions), right-click the Subversion node and choose New Repository Connection.

The Create Subversion Connection dialog is opened. For help when using this dialog, press F1 or click Help.




	Enter the URL of the location of the Subversion repository.
	Optionally, enter a name for the connection.
	If the Subversion repository has been set up with password protection, enter the username and password.
	If you want to test the connection to the Subversion repository, click the Test Connection button. The results will be displayed in the Status area.
	To complete the connection, click OK.








6.3.1.4 Editing a Subversion Connection



If any of the details (such as IP address, port, user ID, password, etc.) of your Subversion connection change, you can edit the connection in JDeveloper so that you can connect to it with the new details.

To edit a Subversion Connection:




	In the Subversion Navigator (Team > Versions), right-click the Subversion connection name and choose Properties.

The Edit Subversion Connection dialog is opened. For help when using this dialog, press F1 or click Help.




	Make changes as required and click OK.








6.3.1.5 Exporting Subversion Repository Connection Details



You can export the details of your Subversion repository connections to a file. You can subsequently import the connection details from the file to recreate the Subversion repository connections. This can greatly simplify the process of connecting to a Subversion repository as new team members join, as the repository connection file can be stored on a server accessible to the team, then downloaded as required as new members join. Similarly, if new servers are added, the team leader or administrator can distribute new connection information in a connection detail file to be imported by all team members.

To export Subversion connection details to a file:




	In the Subversion Navigator, select the Subversion node and, from the context menu, choose Export Connections.

The Export Subversion Connections dialog opens.




	Enter a location and name for the file that will contain the connection details, then click OK.








6.3.1.6 Importing Subversion Repository Connection Details



If you or your team have saved the details of your Subversion repository connection, you can import them into JDeveloper to simplify making the connection to your repository.

To import Subversion connection details from a file:




	In the Subversion Navigator, select the Subversion node and, from the context menu, choose Import Connections.

The Import Subversion Connections dialog opens.




	Browse to the file that contains the connection details that you wish to import, then click OK.








6.3.1.7 Connecting to a Subversion Repository Through a Proxy Server



If you want to connect to a Subversion repository through a proxy server, you must first install separate Subversion client software.

Once you have installed the Subversion client software, you will have a Subversion subdirectory in your Windows Application Data directory. To find the Application Data directory, at the c:/ prompt type cd %APPDATA%. Then open the Subversion subdirectory. (On Linux, the equivalent subdirectory will be in ~/.subversion, where ~ is the home directory.)


Note:

If you have entered the proxy settings in the JDeveloper Preferences, you can omit editing the servers file as described in the following paragraphs.



In the Subversion subdirectory will be a file named servers. Open this file with a text editor and find the [global] section. Remove the comment marker (#) from the line http-proxy-host and overtype the placeholder proxy information with the details of the proxy server that you use. Remove the comment marker (#) from the line http-proxy-port and overtype the placeholder port information with the port number for the proxy server. If you wish to exclude certain URLs from using the proxy server, remove the comment marker (#) from the line http-proxy-exceptions and overtype the placeholder URLs with URLs that you wish to exclude.

Add additional http-proxy-host and http-proxy-port lines with details of any other proxy servers that you use.

It is important that the proxy server supports all the http methods used by Subversion. Some proxy servers do not support the following methods by default: PROPFIND, REPORT, MERGE, MKACTIVITY, CHECKOUT. If you experience problems with using a proxy server to access a Subversion repository, ask the server's system administrator to change the configuration to support these http methods.









6.3.1.8 Exporting Subversion Controlled Files from the Working Copy



You can export copies of JDeveloper files that are under Subversion control from either of two places: the Applications window, in which case the files will be exported from the Subversion “working copy", or the Subversion Navigator, in which case the files will be exported from the Subversion repository. Exporting the files means copying them to a local file system directory that you specify.

To export files from the Applications window:




	In the Applications window, select the project containing the files that you wish to export.
	Select Team > Export Files.

An Export Files dialog opens.




	In the Destination Path box, enter or browse to the location where you want the files to be copied to.
	To export the files, click OK.



This exports the selected files from the Subversion "working copy" of your local file system.









6.3.1.9 Exporting Files from the Subversion Navigator



You can export copies of files under Subversion control from the Subversion Navigator. This ensures that the files will be exported from the Subversion repository (not from the "working copy"). In addition, exporting with the Subversion Navigator lets you specify which revision of the files to export.

To export files from the Subversion Navigator:




	In the Subversion Navigator, select the repository node or directory containing the files that you wish to export.
	Select Team > Export Files.

An Export Files dialog opens.




	In the Destination Path box, enter or browse to the location where you want the files to be copied to.
	If you want to export a particular revision of the files, select Use Revision and enter the revision number in the adjacent text box.
	To export the files, click OK.



This exports the selected files from the repository to your local file system.











6.3.2 How to Set Up and Configure a Git Repository



Git is a popular open-source version control system with a growing user community. To begin using Git with JDeveloper, you create a clone of your team's repository on your local system.

To complete this procedure, you will need the following information, which should be available from the Git administrator on your team:





	
The name of the repository


	
The URL at which the repository is stored


	
The user name and password you will use for accessing the repository. Optionally, your team may use a private key file with a passphrase; you can select the appropriate option for your team when you connect to Git.


	
The name of the remote branch that your team uses for development.


	
The destination pathname in your local system to which you wish to store your local repository.




To connect to Git:




	Select Team > Connect to Git. This displays the Clone from Git wizard welcome screen. Click Next to continue.
	Enter the information about your team's remote Git repository, then click Next to continue.
	Specify the remote branch your team uses for development, then click Next to continue.
	Specify the pathname on your local system at which you wish to create your local repository, then click Next to continue.
	Verify all the information displayed in the Git Clone Summary screen, then click OK.



JDeveloper connects you to the remote repository and creates a local clone based on the branch you selected. From this local clone you can check out, edit, merge, and commit files to the main repository.









6.3.3 How to Set Up CVS with Oracle JDeveloper


In general, CVS uses a common repository of files, accessible to JDeveloper, that you and your team share while developing a software project. To modify files in that repository, you first check them out so that CVS tracks the who, when, and what of file access. In the event that two team members edit the same file at the same time, CVS contains tools that help you determine whether those changes conflict, and to resolve problems that may arise and merge these simultaneous changes into a single, comprehensive file. Finally, CVS lets you check these changed files back into the repository so that your build tools will have access to the latest files, with new and/or merged content.


Note:

For extensive information about how to use and administer CVS, see the CVS online manual at http://www.cvshome.org.



Before you can use CVS to manage your shared content, you need to connect JDeveloper to CVS. This means configuring JDeveloper, making a connection to your team's CVS repository, creating a local repository, and more. The topics in this section cover all the steps you'll need to make sure CVS is available from JDeveloper after downloading the CVS extension from Check For Updates. If your team is already using CVS, you should check with them for specifics on how CVS is implemented in your organization.

The process of setting up CVS with JDeveloper involves configuring JDeveloper, creating a CVS connection, importing files for the project into your CVS repository, and then checking out the CVS modules to be edited.





6.3.3.1 Configuring CVS for Use with JDeveloper



Before you can use CVS, you need to configure JDeveloper by setting preferences.

To configure JDeveloper for use with CVS:




	Choose Tools > Preferences, then select Versions from the left panel of the Preferences dialog.
	In the right panel, click Load Extension. The main CVS preferences panel is shown. Other CVS preferences panels are shown when you click on the items beneath the CVS node.
	Make changes to the preferences as required. For more information about the specific preferences, press F1 or click Help.
	Click OK to close the Preferences dialog.








6.3.3.2 Creating a CVS Connection



Once you have installed the CVS extension in JDeveloper, you must create a connection to CVS before you can access the repository.

To create a CVS connection:




	Select Team > CVS > Check Out Module.

JDeveloper prompts you to create a CVS connection. Click OK to open the Create CVS Connection wizard.




	Complete the Create CVS Connection wizard.

For help when using the wizard, press F1 or click Help.












6.3.3.3 Editing a CVS Connection



If any of the connection details change after creation, you can edit the CVS connection.

To edit a CVS connection:




	In the CVS Navigator (View > CVS Navigator) right-click the connection name and choose Properties.

The Edit CVS Connection wizard is opened.




	Use the wizard to make changes as required.

For help when using this wizard, press F1 or click Help.












6.3.3.4 Exporting a CVS Module



You use the CVS Export wizard to export the revisions of files for a module, creating a deployment-ready file structure.

To use the CVS Export wizard:




	Choose Team > CVS > Export Module. The CVS Export wizard is displayed.
	Complete the export as prompted by the wizard. To obtain more information when working with the wizard, F1 or click Help.



The files are exported to the location you have specified.









6.3.3.5 Copying the CVSROOT Path to the Clipboard



You can copy the path of the CVSROOT from a node in the CVS Navigator to the Clipboard, for use in other applications.

To copy the CVSROOT path to the Clipboard:




	In the Connection Navigator, right click the connection name.
	From the context menu, choose Copy CVSROOT.



The full path of the CVSROOT is copied to the Clipboard, from where you can paste it into another application.











6.3.4 How to Configure CVS For Use with JDeveloper


In addition to setting up JDeveloper to be able to use CVS, there are certain tasks you need to perform to make CVS usable with JDeveloper. Some of these tasks may be performed by your administrator. You should always check to make sure which of these tasks have been performed in your installation.

In general, you need a local CVS repository for storing files as you are working on them. You may also need to configure a secure shell (SSH) for communicating with CVS, and you may need to choose a character set. Finally, you will need to log in to CVS.





6.3.4.1 Choosing a Character Set (Local Client Only)



If your installation uses a local CVS client, you need to choose a character set.

For each CVS repository connection, you can choose the character set to be used for the encoding of files. The default is to use the character set specified by the platform/operating system.

You can change to the IDE default or to a specific character set through the Set Encoding dialog.

To choose a character set:




	Select a connection in the CVS Navigator.
	Clicking the right mouse button and choose Set Encoding.
	Select the desired character set.










6.3.5 How to Set Up Perforce with JDeveloper


Before using Perforce with JDeveloper, in addition to downloading the Perforce extension, you need to install a number of Perforce features so that they are available to JDeveloper. Once installed, you configure JDeveloper and connect to the Perforce client workspace. Finally, you need to bring your working files under Perforce control so that they are available from within JDeveloper while using Perforce.

There must be at least one Perforce server installed, on a machine that is accessible to the intended JDeveloper users. If a Perforce server installation does not already exist, obtain the necessary software (for example, from www.perforce.com) and install it in accordance with Perforce's instructions. Record the identity of the machine on which the Perforce server software has been installed: you will need this when you connect to it through JDeveloper.

Before using Perforce with JDeveloper, in addition to downloading the Perforce extension, you need to install a number of Perforce features so that they are available to JDeveloper. Once installed, you configure JDeveloper and connect to the Perforce client workspace. Finally, you need to bring your working files under Perforce control so that they are available from within JDeveloper while using Perforce.







6.3.6 Installing Perforce Components for use with JDeveloper


There must be at least one Perforce server installed, on a machine that is accessible to the intended JDeveloper users. If a Perforce server installation does not already exist, obtain the necessary software (for example, from www.perforce.com) and install it in accordance with Perforce's instructions.





6.3.6.1 Perforce Client Installation


You must install the Perforce client application on the machines that contain (or that will contain) JDeveloper. The Perforce client application can be installed from the same software as the server software, obtainable from www.perforce.com. The installation must include the “Command Line Client (P4)".

When you first run the Perforce client application, you will be required to create a Perforce client workspace. The Perforce client workspace is where the working copies of files under Perforce control will be stored. You can use the JDeveloper default directory as the Perforce client workspace, whether or not it already contains JDeveloper files. The JDeveloper default directory is <installation_directory>\jdev\mywork. Alternatively, you can accept the default Perforce client workspace, or specify one of your own. In these cases, you should note the location you have used, because you will need to specify it when creating applications and projects in JDeveloper.

If you set up passwords in the Perforce client application, you will also need to use them when connecting to Perforce through JDeveloper.







6.3.6.2 JDeveloper Installation


JDeveloper must be installed in the normal way. Each installation of JDeveloper can act as a client application for Perforce. You can install JDeveloper on every machine that you wish to be a Perforce client, or you can use a mixture of JDeveloper installations and Perforce's own client applications. The JDeveloper and Perforce client applications will work together in a seamless manner. In addition to the JDeveloper embedded support for Perforce, you will also be able to access a Perforce client application through the JDeveloper interface.







6.3.6.3 Configuring JDeveloper for Use with Perforce



Before you can configure JDeveloper to use Perforce, you must have installed the Perforce server and client software.

To configure JDeveloper for use with Perforce:




	Choose Tools > Preferences > Versioning > Perforce.
	Verify that the path to the Perforce client is as you installed it.
	If your team uses comment templates, select Comment Templates from the left-hand pane and configure your team's comment templates. topicid:f1_scsversiontemplates_html
	In the left pane of the Preferences dialog, select General, then make selections about icons, log messages, opening files automatically for edit, and the length of the idle period before timeout.topicid:f1_pfcpreferencesgeneral_html
	In the left pane of the Preferences dialog, select General, then make selections about the Pending Changes window and the Merge Editor.
	To save the configuration you have just set up, click OK to close the Preferences dialog.








6.3.6.4 Selecting Perforce as the Version System



Once you have configured JDeveloper for use with Perforce, you can select Perforce as the version system. This will specify a number of default settings which mean that all team operations will default to Perforce as your chosen version system.

To select Perforce as the version system:





	
Choose Team > Perforce.




You can change this default selection at any time if your team changes to a different version system at a later date.











6.3.7 How to Set Up Team System and JDeveloper


Oracle JDeveloper's Team System extension allows you to use the source control features of Microsoft Visual Team System inside JDeveloper. Once you have JDeveloper configured to work with Team System, you can add files to source control, and check them in and out from the Applications windows.

To begin using Team System with JDeveloper, you must first create a workspace using Team System software, and then populate this workspace with content from the Team System server. Files are checked out to the workspace, where they can be worked on. Files newly created within JDeveloper must be added to version control. Changed and new files are made available to other users by checking them in to the Team System server.

Before beginning to use Team System with JDeveloper, there are some initial steps you need to follow:

	
Set up the Team System client software. See Setting Up Team System for Use with .


	
Configure JDeveloper for use with Team System, including the preferences and other settings for making Team System the source control system recognized by JDeveloper. See Configuring for Use with Team System.




In practice, Team System (like any version control system) consists of operations that you use at varying times depending on the place in the product lifecycle. For example, if you create a new file, you'll need to add it to Team System control. Other operations you may perform, depending on the stage of development, include:

	
Checking out files from the server so that you can work on them. See Checking Out Files in Team System.


	
Making changes to a file saved in your Team System workspace, and make them available to other users. See How to Check In Files to Team System.


	
Using Team System's Shelving feature to save file changes in the Team System server without having to check the files in. See Shelving and Unshelving Team System Files.


	
Resolving conflicts between your changes and changes made by your team mates to your Team System files


	
Checking in files to your Team System server.








6.3.7.1 Setting Up Team System for Use with JDeveloper



Using Team System with JDeveloper requires a setup procedure that includes installing software, connecting to your server, and populating your workspace.

To set up Team System with JDeveloper:




	Install the Team System server.
	Install the Team System client software.
	Connect the Team System client software to the Team System server.
	Use the Team System client software to create one or more workspaces.
	Use the Team System client software to populate the workspace(s) with content from the Team System server.



Instructions for doing the above are given in the Team System online help.









6.3.7.2 Configuring JDeveloper for Use with Team System



Once you have set up Team System for use with Oracle JDeveloper, you are ready to configure JDeveloper to use Team System. In addition to the steps in Setting Up Team System for Use with , make sure you have already installed the JDeveloper Team System VCS extension (from the Official Oracle Extensions and Updates center).

To configure JDeveloper for use with Team System, carry out the following activities in JDeveloper:





	
Connect to Team System as the JDeveloper versioning system.


	
Set the workspace to use with JDeveloper.


	
Create a JDeveloper project to hold the workspace files.


	
Refresh the workspace folders in JDeveloper.












6.3.7.3 Selecting Team System as the Versioning System



Connecting to Team System as the default versioning system specifies that Team System is the target for a number of actions from the Team menu.

To connect Team System as the versioning system:





	
Choose Team > Connect to Team System.




This displays the Team System connection menu, from which you can select the available operations. Detailed instructions for this are given in the Team System online help.









6.3.7.4 Setting the Team System Workspace to use JDeveloper



Before beginning, you need to set your selected Team System workspace to use JDeveloper.

To set the workspace to use with JDeveloper:




	Choose Team > Team System > Set Workspace.
	Select the required workspace from the list.








6.3.7.5 Creating a JDeveloper Project for the Workspace Files



Associating the JDeveloper project with the selected Team System workspace ensures that the files you create and edit will remain part of the workspace your team is using.

To create a JDeveloper project to hold the workspace files:




	Select File > New to open the New Gallery.
	Use the New Gallery to create a new application and project.
	In the Applications window, select the newly created project and click the Add to Project Content button in the toolbar.

This opens the Project Content page of the Project Properties dialog.




	Use the Add button in the Java Content area to add the location of the workspace.

If your workspace contained Java sources, a dialog is displayed through which you should confirm that you want the sources added to the project content.

To avoid confusion, you may wish to remove non-workspace locations from the Java Content list.




	Click OK to close the Project Properties dialog.



Once completed, refresh the workspace folders in JDeveloper by choosing Team > Refresh Workspace Folders.









6.3.7.6 Getting Versions of Files from the Team System Server



JDeveloper lets you get (from the Team System server) a version of a file that is in the Applications window. You must previously have used the get command in the Team System client software to populate your workspace with source files.

You can use this procedure to obtain the following versions of files: the latest version; files from a previously saved named changelist; files with a particular date stamp; files from a previously created named label; files from a particular workspace version.

The version obtained from the Team System server will replace the version currently in the Applications window.

To get versions of files from the Team System server:




	In the Applications window, select the application, project or files to set the scope of the Get operation.
	Select Team > Team System > Get.

The Get dialog is opened.




	Complete the dialog.

For information while using the dialog, press F1.












6.3.7.7 Adding Files to Team System Control



You can bring files under Team System source control. The files will be added to the Team System server and made available to other users when you next check in the file.

To add files to Team System Control:




	In the Applications window, select the file that you want to add to Team System control.
	Select Team > Add.

The Add dialog is opened.




	Complete the dialog.

For information while using the dialog, press F1.




	To add the file to the server and make it available to other users, check in the file.










6.3.8 Versioning Applications With Mercurial


Mercurial is a Source Control Management system designed for efficient handling of very large distributed projects. Unlike Subversion, Mercurial works with distributed repositories which are commonly used in many open source projects today and support distributed development without any centralized control.The Mercurial Plugin support enables you to manage changes to version-controlled files as you work. You can call Mercurial commands on both files and directories in the Projects, Files and Favorites windows.

The advantages of a distributed revision control system like Mercurial include:

	
Better support for distributed teams by removing a centralized bottleneck


	
Better scalability with large numbers of concurrent users


	
After the initial clone, faster to work with, independent of a user's network infrastructure








6.3.8.1 About Mercurial Visualization Features


JDeveloper provides several file status information tools that simplify the process of working with version-controlled files, including:

	
Color Coding. Enables you to view the current status of version-controlled files.


	
Annotations. Enables you to view revision and author information for each line of version-controlled files.




JDeveloper's Mercurial support is similar in style to its Subversion support. The main difference is that Mercurial is a distributed revision control system. Therefore, you typically begin by cloning an external repository to work with. This clone is a complete copy of the repository including the revision history. You can clone this local copy as often as you like. When you want, you can push your changes back to the original repository provided you have permissions, or export your changes and send them to the owner if you do not.

For further documentation on the Mercurial Plugin support and Mercurial itself, see the following resources:

Mercurial Home: http://mercurial.selenic.com/wiki/

Understanding Mercurial: http://mercurial.selenic.com/wiki/UnderstandingMercurial

Mercurial Man Pages: http://www.selenic.com/mercurial/wiki/index.cgi/ManPages






6.3.8.2 How to Install Mercurial


Before you can take advantage of the Mercurial support, you need to have Mercurial client software installed on your system. JDeveloper's Mercurial support works by using the same commands as the Mercurial command line interface.

Mercurial is available through JDeveloper's Check for Updates feature. After you set up Mercurial, you can run Mercurial commands from the Team > Mercurial menu at the top of the JDeveloper main window.

To install Mercurial:

	
Select Help from the main JDeveloper window, then Check for Updates.


	
On the first page of the Select Update Source wizard, make sure Search Update Centers is selected.


	
Select Official Oracle Extensions and Updates.


	
Click Next.

The wizard updates with a list of extensions you can install.


	
On the Select Updates to Install page of the wizard, select the checkbox next to Mercurial VCS Extension.


	
Click Next, then Finish.

The Mercurial extension installs. Installation is complete after you restart JDeveloper.




You can also access the Check for Updates wizard by selecting Tools > Features > Check for Updates. For more information, see Working with Extensions.

After the Mercurial client is set up, you can run Mercurial commands from the main window by selecting Team > Mercurial.






6.3.8.3 How to Set the Path to the Mercurial Executable


After installing through Check for Updates, you may set the path to the hg.exe executable file. hg.exe is the executable file for Mercurial. You only need to set the executable file if is not on the system path.

To set the path to the Mercurial executable file:

	
On the main JDeveloper window, select Tools >Preferences.


	
In the left pane of the Preferences dialog, expand Versioning, then click on Mercurial.


	
On the Versioning: Mercurial page you can select:

	
The name of the executable that will be used to run Mercurial, for example, hg.exe.


	
One of the installations of hg.exe in the system or different revisions of it, if they exist.


	
Some other location of hg.exe if, for example, it isn't on the system path.












6.3.8.4 How to Clone an External Mercurial Repository


A repository is a directory that contains source files, along with their complete histories. Cloning makes a complete copy of another repository so that you have a local, private version of it to work with. You can create a local repository in any directory where you have write permission.

When cloning, you effectively create a copy or clone of the entire repository to work with in the IDE. To do so, you need to be able to access a Mercurial repository that you have read privileges for.

To clone a Mercurial repository:

	
On the main JDeveloper window, select Team > Mercurial > Clone.


	
On the Clone Repository window, enter the Source Location of the repository.

This is the location of the repository that is to be cloned. You can enter either a URL or local path, for example, http://selenic.com/hg.


	
In the Destination field, enter a destination for the local repository, for example, C:/JDeveloper/mywork/hg1.


	
Enter a User Name and Password for the remote repository, if required.


	
Click OK.









6.3.8.5 How to Place Projects Under Version Control


You can place any project you are working on under version control. This creates a new local Mercurial repository in the current directory and imports your sources into it. The repository files are placed under a .hg directory under the project directory.

To place a project under version control:

	
In the Projects window (located on the left side of JDeveloper), select an unversioned project.


	
From the JDeveloper main window, select Team > Mercurial > Initialize.

You can view files being added to the repository and their status from the Messages Log window.

Once complete, all the project files are registered in the repository as Locally New.


	
Select Mercurial > Commit from the project's context menu to commit these project files to the Mercurial repository.


	
Enter a message about the change being committed in the Commit Message text area, and then click Commit.

The committed files are placed together with the .hg directory in the Mercurial repository directory.









6.3.8.6 How to Merge File Revisions


You can merge changes between repository revisions and your local working copy. The current working directory is updated with all changes made to the requested revision since the last revision.

To merge file revisions:

	
From the JDeveloper main window, select Team > Mercurial > Initialize.


	
In the Working Directory field of the Merge Working Directory dialog, enter the top-level directory in the repository, for example, c:\JDeveloper\mywork\hg1.


	
Check the Use Revision checkbox and enter the revision number.

If you don't know the number for the revision, click Select Revision. A dialog displays the available revisions number listed from most recent, the revision date, the user who made the revision, and comments.









6.3.8.7 How to Commit Changes


Once your working copies of version-controlled files have been edited, you can then place changes into the repository using the Mercurial Commit action.

It's a good idea to update any copies you have against the repository prior to performing a commit in order to ensure that conflicts do not arise. This updates the local repository to include the latest changes.

To perform an update on sources that you have modified:

	
In the JDeveloper main window, select Team > Mercurial > Update.




To commit changes in local files to the repository:

	
Select a version-controlled file (for example, from the Projects window) and right-click.


	
Select Versioning > Commit from the context menu.

The Commit Dialog opens, listing all files that contain local changes.


	
Enter a commit message in the Commit Message text area, indicating the purpose of the commit.

You can also select either a comment template you created in Tools > Preferences > Versioning > Templates or one of the comments that you have previously entered in the Commit dialog.


	
Click OK.

JDeveloper executes the commit and sends your local changes to the repository. You can view files being committed to the repository in the Messages log.

Use Commit All to view all the changed files that you can commit to the Mercurial repository. You can commit selected files or all outstanding changes. Use the Shift or Ctrl keys to select which files you want to commit.














6.4 Setting Up and Configuring a Source Repository


After initializing your version control system in JDeveloper, the next important step is to configure the source repository. Typically, you maintain a local repository, containing local copies of the files you are working with, on your own system. You typically check out the files you want to work on, make edits to the versions on your local system, and then check the files back in to the remote repository. Your version control system typically tracks, or at least notifies you of, changes and conflicts if more than one person is editing a file at a time. The menu options and details vary from system to system; these variations are described individually in each of the following sections.

Before beginning to use Subversion with JDeveloper, you will need to load your repository with content so that you have local versions to edit. For more information, see How to Load the Repository with Content.





6.4.1 How to Create a Source Repository


Creating a repository is something you typically only do once per project/release; once you have created the repository, you check files in and out as part of your daily work routine. In many teams, the source repository is created by a team member assigned to the role of administrator for the repository; if this is the case, you may be able to skip this section and rely instead on accessing the existing source repository for checking out and checking in files.

The details of creating and connecting to your source repository differ depending on the versioning software your team uses. The following sections include instructions on creating source repositories for the versioning systems available to JDeveloper.





6.4.1.1 Creating a Subversion Repository



In most cases, you will connect to your team's Subversion repository. As you develop your projects and applications, you will check files out from the Subversion repository, modify them, and check them back in. This is the typical, and recommended, practice for using Subversion.

Depending on your installation, however, you may find it necessary to create a Subversion repository on your local file system through JDeveloper. A connection to the repository will be created at the same time.

JDeveloper will try to use the file:/// protocol to access the newly created repository. SVNKit, the Subversion client installed with JDeveloper, supports the file:/// protocol. If you are using a Subversion client that does not support the file:/// protocol, you will need to use a different access method (http://, https://, svn:// or svn+ssh://). Consult the Subversion documentation for how to do this.

To create a Subversion Repository:

	
Choose Team > Create Local Repository.

If your installation does not support local repository creation, you will see an error message. Otherwise, the Create Subversion Repository dialog will open.


	
Complete the Create Subversion Repository dialog.

To obtain help while using the dialog, press F1 or click Help.




To browse a Subversion Repository:




	Expand the connection to your Subversion repository in the Versions window.
	Double-click on a folder to view its contents.
	Right-click on an element to view available operations.








6.4.1.2 Initializing a New Git Repository



If you have new files that are not already part of any existing Git repository, you need to initialize a Git repository.

You initialize a Git repository when you have a new project with all new files. This is typically done once per project, at the beginning. As an ongoing task, you are more likely to add new files to an existing Git repository (see Adding New Files to an Existing Git Repository), or check out files, edit them, and then commit the changes back to the Git repository (see Committing a Change to the Git Repository).

To initialize a Git repository:




	Select Team > Git > Initialize. This displays the Initialize Repository dialog.
	Enter the path to the local repository, then click OK.








6.4.1.3 Making a Local Copy of an Existing Git Repository



If your team already has a central Git repository and you wish to make a local copy of it for your work, you can clone the Git repository as described here.

The following protocols can be used to clone Git repositories:





	
Git (git://). The simplest way of connecting to the Git server. The connection is not authenticated.


	
HTTP (http://). HTTP is another simple way of connecting to the server. http:// connections are insecure even with authentication as the files will be transferred in clear.


	
HTTPS (https://). Connects to the server using password authentication. https:// connections are fully secure and will work through a web proxy.


	
Secure Shell (ssh://). This uses public key authentication, and you will need to generate an authentication key using a utility such as ssh-keygen. This is the most secure way of cloning an existing Git Repository. However, it will require additional setup if you are trying to connect through a web proxy.




To clone a Git repository:

	
Select Team > Git > Clone.




This opens the Clone from Git Wizard. Enter the information requested on each screen. You can press F1 or click Help at any time for more information.









6.4.1.4 Adding New Files to an Existing Git Repository



Adding new files to an existing Git repository involves selecting, then adding the files, and finally committing them for the changes to be incorporated into the repository.

To add new files to an existing Git repository:




	Select the files to be added.
	Select Team > Git > Add (or Team > Git > Add All). This displays the Add dialog.
	Click OK.








6.4.1.5 Creating a Local CVS Repository



From within JDeveloper, you can create a new CVS repository on your local file system. This feature is available only if you are using external CVS client software, rather than the internal CVS client installed as part of the CVS extension to JDeveloper.

To create a local CVS repository:




	Select Team > CVS > Create Local Repository.
	In the Repository Folder box, enter the path of a directory where you want the new local repository to be created.

You can specify or select an existing directory if it is empty, or you can specify a new directory. If the directory you have specified exists and is not empty, you will see a warning dialog telling you to specify an empty or new directory for the repository.




	If you want to create a connection to the local repository that you are creating, make sure that the Create Repository Connection box is checked.

The connection will be given a name in the form :local:{path}. If you later want to change this name, you can do so through the CVS Navigator: from the context menu of the connection name, open the properties dialog and, on the Name tab, overtype the existing name with a new one.




	Click OK. You will see a confirmation dialog when the new local repository has been created.








6.4.1.6 Importing JDeveloper Project Files Into CVS



Before you can start using your JDeveloper project with CVS, you have to import the project files into the CVS repository. This copies all your folders and files to the CVS repository and places them under source control.

You import your project files into the CVS repository using the Import to CVS wizard.

To use the Import to CVS wizard:




	Choose Team > CVS > Import Module. The Import to CVS wizard is displayed.
	Complete the import as prompted by the wizard. For help when using this wizard, press F1 or click Help.



Before you can change any files, you have to copy them back to your machine, where you can work on them locally.









6.4.1.7 Bringing Files Under Perforce Control



Perforce uses a local directory structure to receive files that are going to be placed under formal source control. This location is called the “Perforce client workspace". Files created in (or moved into) JDeveloper must be stored in this location. Once files are in your Perforce client workspace, you bring them fully under source control by submitting them to a central location called the “Perforce depot". Files must be submitted to the Perforce depot before they can be versioned and accessed by other users.

Files that you create within JDeveloper, or files that you bring into JDeveloper from outside, must be brought under Perforce control before you can use the JDeveloper Perforce versioning facilities with them.

If you have an existing JDeveloper project that you wish to bring under Perforce control, use the Import to Perforce wizard.

To put individual JDeveloper files under Perforce control:

	
Select the files in the Applications window and choose Team > Perforce > Open for Add.

The files can be your work files, or they can be the application and project files used by JDeveloper.

The Add Files to Perforce dialog is displayed with the files listed.


	
If you wish to lock the files, making them unavailable to others for editing, check the Lock Files box.


	
To add the files to Perforce control, click OK.

The files are now shown in the Applications window with a red cross, meaning that they are stored in your Perforce client workspace but not yet in the Perforce depot. Files must be added to the Perforce depot before they can be versioned and accessed by other users.


	
To add files to the Perforce depot, select the files in the Applications window and choose Team > Perforce > Submit.

The Submit Files dialog is displayed with the files listed.


	
Add your versioning comments in the Comments box.

You will later be able to see these comments when viewing the list of versions of a particular file.


	
To submit the files to the Perforce depot, click OK.

The files are now shown in the Applications window with a green dot, indicating that they are known to the Perforce depot and are up to date.




To bring files created outside JDeveloper under Perforce control:




	Copy or move the files into an existing \src directory under the JDeveloper file storage directory (which should be the same as the Perforce client workspace).
	Refresh the application or project.

The files should now appear in the Applications window, within the project whose \src directory you used. The files are marked with a white-on-blue diagonal cross, showing that they are known to JDeveloper but not under source control.




	Bring the files under Perforce control as described in the previous procedure.










6.4.2 How to Connect to a Source Control Repository


Once the source control repository has been created (either by you or by a team administrator), you typically connect to it from the Team menu, then selecting your versioning system from the Connect To... option.





6.4.2.1 Viewing Subversion Repository Content


You can view the current content of the Subversion repository through the Versions window. The nodes under your selected Subversion connection unfold to reveal the structure and file content of the Subversion repository.

You can open a read-only version of a Subversion repository file by choosing Open from its context menu. This will let you see what changes have been made to the files in the Subversion repository since you checked out or updated your local versions.

Folders in the Subversion repository, visible from the Versions window, offer the following operations:

	New
	
Opens the new gallery, from which you can create applications, connections, projects, and other entities.


	New Remote Directory
	
Opens the Create Directory dialog, which lets you create a new directory to associate with the URL of the element on which you right-clicked.


	Delete
	
Removes the selected element immediately from the JDeveloper view, without a confirmation dialog. Use with caution.


	Check Out
	
By default, opens the Check Out from Subversion dialog.




If you have configured JDeveloper for a different version control system, Check Out will open the checkout dialog for your selected version control software.







6.4.2.2 Logging In to CVS



Some types of connection to a CVS repository require you to log in independently of making the connection. If you cannot access any CVS features even though a CVS connection exists, you need to log in.

To log in to a CVS repository:




	In the CVS Navigator, select Team > Log In.

If the Log In menu option is unavailable but the Log Out option is available, you are already logged in.




	In the Log In To CVS dialog, enter your password. If you want your password to be remembered and supplied automatically when you connect to the CVS repository in future, check the Connect Automatically on Startup box.
	Complete login by clicking OK.








6.4.2.3 Accessing Local Files with CVS


If JDeveloper finds a path to a CVS client on your machine, the JDeveloper CVS preferences will by default be set to use that CVS client (rather than the internal CVS client installed with JDeveloper). If no path to a CVS client is found, the preferences will be set to use the internal CVS client.

The internal CVS client cannot be used to access a local CVS repository (that is, one on your own machine). If you wish to access a local CVS repository, you must install a full client/server version of CVS onto your machine and set the JDeveloper CVS preferences accordingly.

If you wish to use an external CVS client, we recommend the following:

	
CVSNT 2.0.58a or higher for Windows platforms - http://march-hare.com/cvspro/


	
cvshome's CVS 1.11.9 for other platforms





Note:

You may already have a CVS installation that is client-only. This will not be able to access a local CVS repository, and you should install a full client/server version instead. If you are unable to expand the connections node in the CVS Navigator or open the list of modules from the Get Module List button in the CVS wizards, you probably have client-only CVS software that is attempting to access a local CVS repository. You can check which type of CVS installation you have by typing cvs -v at the CVS command prompt. A client-only installation will display (client) at the end of the version information line, whereas a client/server installation will display (client/server).



To access CVS through a firewall:

If you are accessing a CVS server through a firewall, you can connect to it if:

	
The firewall allows TCP/IP communication on the CVS port


	
You use a CVS client that supports HTTP Tunneling (for example, CVSNT)




If there is an authentication failure when you log in, try using the CVS command line to connect. If this fails, the connection may be being blocked by the firewall, and you should contact your network administrator.

If necessary, you can alter the value of the CVS root variable to support connection through a firewall.





6.4.2.3.1 Handling CVS File Types


The CVS administrator has to configure the CVS repository for the automatic handling of binary files produced by JDeveloper, such as image file formats.

Where other file types are updated, CVS attempts to merge them. If you do not want is to occur, you must change the configuration of the CVS repository.

For more information about CVS, refer to the CVS documentation, or see the CVS website, http://www.cvshome.org. This is also where you can download CVS software.









6.4.2.4 Connecting to Perforce



Before Perforce operations become available within JDeveloper, you must connect to it.

To connect to Perforce manually:




	Choose Team > Connect to Perforce.

The Connection dialog is opened. The username, port and client information should have been derived automatically and should now appear in the Connection dialog.




	If not already present, enter the correct username, port and client information.
	If the Perforce server has been set up with password protection, enter the password. (If you want the password to be remembered for the next time you make a connection, check the Remember Password box.)
	If you want to test the connection to the Perforce server, click the Test Connection button. The results will be displayed in the rectangular text area.
	To complete the connection, click OK.








6.4.2.5 Making Multiple Connections to Perforce



In some development environments, you may need to make more than one connection to Perforce. For example:





	
Your organization uses one Perforce server for development and another Perforce server for test.


	
You wish to connect using two different Perforce clients.


	
You wish to use different Perforce user IDs.




The Perforce extension to JDeveloper permits all these operations. You begin by giving each Perforce connection a name as you create it.

To create a named Perforce connection:




	Choose Team > Connect to Perforce.

The Connection dialog is opened. The username, port and client information should have been derived automatically and should now appear in the Connection dialog.




	If not already present, enter the correct username, port and client information.
	Enter a name to use for this Perforce connection. Make sure it is different from any other Perforce connection that you currently have open.
	If the Perforce server has been set up with password protection, enter the password. (If you want the password to be remembered for the next time you make a connection, check the Remember Password box.)
	If you want to test the connection to the Perforce server, click the Test Connection button. The results will be displayed in the rectangular text area.
	To complete the connection, click OK.



Note that your Perforce changelist will display the connection that applies to each file in the changelist. For more information on changelists, see How to Use Change Sets and Changelists.











6.4.3 Configuring JDeveloper for the Source Repository


If you are using Subversion, which is included by default in JDeveloper, you do not need to configure JDeveloper for your source repository. You only need to connect to the repository, then you update your local working copy, check files out to work on them, and then check in your changed files on completion. Other version control systems, however, have configuration requirements, which require you to configure them, and JDeveloper, before use.





6.4.3.1 How to Configure CVS For Use with JDeveloper


In addition to setting up JDeveloper to be able to use CVS, there are certain tasks you need to perform to make CVS usable with JDeveloper. Some of these tasks may be performed by your administrator. You should always check to make sure which of these tasks have been performed in your installation.

In general, you need a local CVS repository for storing files as you are working on them. You may also need to configure a secure shell (SSH) for communicating with CVS, and you may need to choose a character set. Finally, you will need to log in to CVS.

JDeveloper supports SSH Levels 1 and 2 as access methods for CVS repositories.







6.4.3.2 Configuring for SSH Level 1 (SSH)



JDeveloper does not provide a direct way of using SSH Level 1 as an access method for the CVS repository. It is however possible to configure SSH Level 1 so that it can be used for remote shell access.

To configure SSH Level 1 to enable remote shell access:

	
Generate public and private keys using the command: ssh-keygen


	
Concatenate the ~/.ssh/identity.pub public key file with ~/.ssh/authorized_keys on the machine with the CVS repository.




Before running JDeveloper and attempting to use CVS with SSH Level 1, users should be explicitly authorized and the environment correctly configured. Follow the steps below to configure the environment correctly.

To configure the environment for SSH Level 1:




	Set the CVS_RSH environment variable to the location of the SSH client.
	At the UNIX command line, enter ssh-agent {shell}, and then press Enter.
	At the UNIX command line, enter ssh-add, and then press Enter.
	Start JDeveloper.
	Select External as the CVS access method when using the CVS Connection Wizard.








6.4.3.3 Configuring for SSH Level 2 (SSH2)



JDeveloper provides a direct way of using SSH2 as an access method for the CVS repository.

To use SSH2 for remote shell access:




	On the JDeveloper CVS preferences page, set the CVS Client preference to Internal to JDeveloper [...].
	Start the CVS Connection Wizard.
	While using the CVS Connection Wizard, on the Connection page, choose Secure Shell via SSH2 as the Access Method. For more help at this stage, press F1 or click Help.
	On the Connection page, click Generate SSH2 Key Pair. This opens the Generate SSH2 Key Pair dialog. For help using this dialog, press F1 or click Help.
	After generating the SSH2 key files, an information dialog will appear that explains where to install the files.
	Install the SSH2 key files as instructed in the dialog.
	Complete the CVS Connection Wizard to create the CVS connection.



If you are using an internal CVS client, you can generate SSH2 key files at any time by choosing Team > CVS > Administration > Generate SSH2 Key Pair. If you are using an external CVS client, this menu option is unavailable.









6.4.3.4 Editing and Watching Files in CVS



Editing and watching are available only when an external CVS client executable is used.

These procedures allow you to obtain and release an editor on a file, to know who else in your team is editing files, and to know who is watching for files to be edited. Two or more developers retain the ability to edit the same file at the same time.

To set up JDeveloper to use editing and watching:

	
Open the preferences page obtainable from Tools > Preferences | Versioning | CVS.


	
Ensure that External Executable is selected and that valid details are entered.


	
Select Run CVS in Edit/Watch Mode.


	
Open the preferences page obtainable from Tools > Preferences | Versioning | CVS | General.


	
Deselect Automatically Make Files Editable.




To obtain an editor on a file:

	
With the file selected in the Applications window, select Team > Edit.


	
Check that you want the operation to apply to all of the files highlighted in the file selection box.


	
To set up a watch for this file, select the Set Watch Actions checkbox and select a watch action from the drop-down list.


	
Click OK.




To release an editor on a file (to unedit a file):

This action reverses changes made in the current edit. Any local file modifications will be lost when the editor is released.

	
With the file selected in the Applications window, select Team > Unedit.


	
Check that you want the operation to apply to all of the files highlighted in the file selection box.


	
Click OK.




To turn on or turn off the file watching facility:

	
In the Applications window, select a project containing files about which you want to be notified.


	
Select Team > Watch.


	
In the Watch CVS Files dialog, choose Turn On Watching or Turn Off Watching from the Command Type drop-down list.


	
Click OK.




To add yourself to the list of people who receive notification of work done on files:




	In the Applications window, select the project containing the files about which you want to be notified.
	Select Team > Watch.
	Check that you want the operation to apply to all of the files in the file selection box.
	On the Watch Settings tab, choose Add File Watch as the Command Type from the drop-down list.
	Optionally, check the Set Watch Actions checkbox and choose the particular actions that you want to be notified about.
	Click OK.



To remove yourself from the list of people that receive notification of work done on files:

	
Follow the procedure for adding yourself to the list (above), but choose Remove File Watch from the Command Type dropdown list.




To see who is watching for changes being made to files:

	
Select Team > Edit Notifications.




The Edit Notifications window is opened. The Watchers tab shows the files that are being watched and the user(s) who are currently watching for changes.

To see who is currently editing files:

	
Select Team > Edit Notifications.




The Edit Notifications window is opened. The Editors tab shows the files that currently have editors on them and the user(s) who have obtained those editors.











6.4.4 How to Load the Repository with Content


Before you can use the repository for your selected version control system, you typically have to load the repository with the content your team will be working on. You might need to do this when:

	
Your team begins to work on a new version of the project (especially if you are working on more than one version concurrently, such as a patch set and a major update)


	
Your team is starting an all-new project, either by beginning with an older version or with file templates


	
You are performing a clean installation of JDeveloper on a new workstation that does not yet contain a local file system to store your repository's files as you work on them




Normally, loading the repository with content is done once per project. After this initial load, you will regularly update the files and folders in your local repository to ensure that your files are up to date with the work of your team.





6.4.4.1 Importing JDeveloper Files Into Subversion



Files that you created within (or brought into) JDeveloper before using Subversion control must be imported into the Subversion repository, and then checked out from it.

To import an existing JDeveloper project or application into Subversion:




	In the Applications window, select the application or project that you want to import into Subversion.
	Select Team > Import Files.

The Import to Subversion wizard opens.




	Complete the wizard. For help while using the wizard, press F1 or click Help.

If you allowed the wizard to check out the imported files, the files are shown in the Applications window with a version number next to them. You may have to refresh the view before the files are shown.

If you did not allow the wizard to check out the imported files, you must now check them out before you can work on them.












6.4.4.2 Importing a Project to Subversion



You can also import an entire project into Subversion using the JDeveloper Version Application feature.

To import files using Version Project:




	Select the application you wish to add to version control.
	Select Team > Version Project. This opens the Import to Subversion wizard.
	Complete the wizard. For help while using the wizard, press F1 or click Help.

If you allowed the wizard to check out the imported files, the files are shown in the Applications window with a version number next to them. You may have to refresh the view before the files are shown.

If you did not allow the wizard to check out the imported files, you must now check them out before you can work on them.







After you import files into Subversion using the Version Application feature, you will notice that Subversion creates two directories, one as your work area and one as a backup directory.

For example: after creating a new application called Catalog, select Versioning > Version Application > Subversion. Be sure to select the Perform Checkout from the Options page, then finish the wizard.

When the wizard completes, browse to the local directory that you have specified as the Source Directory for this application in Subversion. You will see two directories listed there: Catalog.svn-import-backup and Catalog.svn-import-workarea.

JDeveloper (and Subversion) will use the Catalog.svn-import-workarea directory for file access, checkout/checkin, and other activities. You should avoid editing, moving, or manipulating files in those directories outside of JDeveloper and Subversion.









6.4.4.3 Adding a File to Subversion Automatically



When you create a new file in JDeveloper that is part of a local working copy (that is, an application that has been versioned and checked out of your SVN repository), you need to add and then commit the file to Subversion control before you can use the JDeveloper Subversion facilities with it. The preferred method is to set up JDeveloper to do this automatically, through the Preferences menu.

To add new files on commit:




	Select Tools > Preferences > Versioning > Subversion > General.
	Select Automatically Add New Files On Committing Working Copy.
	Click OK.








6.4.4.4 Adding Files Individually to Subversion



You can also place individual files under Subversion control.

To place individual files under Subversion control:




	Select the files in the Applications window and choose Team > Add.

The files can be your work files, or they can be the application and project files used by JDeveloper.

The Add to Source Control dialog is displayed with the files listed.




	To add the files to Subversion control, click OK.

The files are now shown in the Applications window with a black cross, meaning that they are stored in your JDeveloper workarea but are not yet committed to the Subversion repository. Files must be committed to the Subversion repository before they can be versioned and accessed by other users.




	To commit files to the Subversion repository, select the files in the Applications window and choose Team > Commit.

The Commit Resources dialog is displayed with the files listed.




	Add your versioning comments in the Comments box.

You will later be able to see these comments when viewing the list of versions of a particular file.




	To commit the files to the Subversion repository, click OK.

The files are now shown in the Applications window with an orange dot, indicating that they are known to the Subversion repository and are up to date.












6.4.4.5 Moving Files from Remote Repositories in Git



While you use your local Git repository for changes made while editing, it is frequently necessary in a distributed team to work with remote repositories. Push, pull and clone are three concepts that apply to remote Git repositories.

Fetching and pulling are two different methods of obtaining content from a remote repository. When you fetch from a remote repository, Git loads all changes into your local repository but it does not change any of your existing branches. This way, you can inspect the changes and merge them as appropriate.

To copy from a remote repository without changing existing branches:




	Select Team > Git > Fetch
	Follow the instructions on the wizard screens to specify the remote repository and remote branch you wish to fetch.
	Click Finish to fetch the files from the remote repository.



Pulling, on the other hand, copies files from the remote repository and updates the HEAD branch of your local repository.topicid:f1_git_pull_wizard_1_html

To copy changes from your local repository to the remote repository, use the Push command.









6.4.4.6 Importing JDeveloper Files Into Perforce



Perforce uses a local directory structure to receive files that are going to be placed under formal source control. This location is called the “Perforce client workspace". Files created in (or moved into) JDeveloper must be stored in this location. Once files are in your Perforce client workspace, you bring them fully under source control by submitting them to a central location called the “Perforce depot". Files must be submitted to the Perforce depot before they can be versioned and accessed by other users.

Before you can start using existing JDeveloper project and source files with Perforce, you have to import them into your Perforce client workspace. Once they are in your Perforce client workspace, you bring them fully under source control by submitting them to the Perforce depot.

You import JDeveloper project and source files into your Perforce client workspace using the Import to Perforce wizard.

To use the Import to Perforce wizard:




	If you have not already done so, connect to Perforce by choosing Team > Connect to Perforce.
	In the Applications window, select the JDeveloper project that you want to bring under Perforce control.
	Choose Team > Import Project. The Import to Perforce wizard is displayed.
	Complete the import as prompted by the wizard. To obtain more information when working with the wizard, press F1.

The project and files will be shown in the Applications window. If you have chosen to display overlay icons, these will indicate the current source control status of the files.




	To bring the files fully under Perforce source control, submit them to the Perforce depot.








6.4.4.7 Updating a Project, Folder, or File in CVS



The CVS update operation updates your local files with data in the CVS repository. Alternately, you can choose to completely replace your local files with those held in the CVS repository.

You can update individual files (including project files), or you can update the entire contents of a project folder.

You can view the contents of the CVS repository through the CVS Navigator. The nodes under CVS Server unfold to reveal the structure and file content of the CVS repository. You can open a read-only version of a CVS repository file by choosing Open from its context menu. This will let you see what changes have been made to the files in the CVS repository since you checked out or last committed your local versions.

To update an individual file (including a project file):

	
Select the file(s) in the Applications window, and then choose Team > Update.


	
Set the options as required. For information about these options, press F1 or click Help.


	
To update all the files listed, click OK.




To update the contents of a project folder:

	
Select the project folder(s) in the Applications window and then, from the context menu, choose Update Project Folders.


	
Set the options as required. For information about these options, press F1 or click Help.


	
To update all the files listed, click OK.




To update files shown in the Pending Changes window:




	With the Pending Changes window in Incoming Changes mode, select the files that you want to update.

To obtain more information about the Pending Changes window, press F1 or click Help.




	Click the Update button.




Note:

For the Pending Changes window to be populated with candidates, the project containing those candidates must be open. If you do not see a file that you expect to see, open the project (File > Open > Project, then select your project).













6.4.5 How to Create a WebDAV Connection


Web-based Distributed Authoring and Versioning, or WebDAV, is an extension to HTTP which allows users to edit and manage files on WebDAV-enabled servers in a collaborative fashion. WebDAV connections in JDeveloper allow you to view files hosted on WebDAV servers in the same way as you would files on the local file system. Files located on WebDAV servers, accessed using WebDAV connections in JDeveloper, can be viewed in the same way as files stored on the local file system or LAN.

As WebDAV clients provide access using HTTP, files can be accessed through firewalls (configured to support WebDAV extensions) that would otherwise prevent FTP file transfer. The JDeveloper read-only implementation of WebDAV supports the current WebDAV 1.0 standard, which does not support versioning. As a WebDAV client, JDeveloper can connect directly to any Oracle Internet File System, allowing you to view WebDAV files from the database.





6.4.5.1 WebDAV Server Requirements



You must run a WebDAV server to use JDeveloper as a WebDAV client. The WebDAV server must be one of the following:

	
Apache 1.3.19 (or above)


Note:

If the Apache server is version 1.x, the mod_dav module must also be installed.




	
A server that conforms to the WebDAV 1.0 standard





Note:

If you access the Internet through a firewall, it must be configured to process the extended HTTP commands used by WebDAV.

If your web server is configured to redirect URLs to a different server (for example, if you are using JkMount in Apache to redirect requests for certain file extensions to Tomcat), be aware that WebDAV will not be available for those resources if the server you are redirecting to does not support WebDAV in that context.



If you'd like to find out more about WebDAV, see the following Web sites:

	
http://www.webdav.org


	
http://httpd.apache.org/docs-2.1/mod/mod_dav.html












6.4.5.2 Creating a WebDAV Connection



WebDAV connections created in JDeveloper allow you to view files and folders as part of a JDeveloper project.


Note:

The same URL cannot be used for more than one WebDAV connection on the same JDeveloper client.



To create a WebDAV connection in JDeveloper:




	In the New Gallery, choose General > Connections > WebDAV Connection, then click OK.
	Use the WebDAV Connection dialog to create a connection.

For more information while using the dialog, press F1.












6.4.5.3 Accessing a WebDAV-Enabled Server Via a Proxy Server



If you access the internet via a proxy server you need to configure JDeveloper before accessing WebDAV-enabled servers on the internet.

To access a WebDAV-enabled server via a proxy server:




	Check with your network administrator to ensure that your proxy server is WebDAV-enabled.
	In JDeveloper choose Tools > Preferences, click Web Browser and Proxy in the left pane of the Preferences dialog box, make sure that the Use HTTP Proxy Server checkbox is checked, then enter the details for the proxy.
	If the WebDAV-enabled server you want to access is inside your firewall and you do not need to go through your proxy server to access it, add the name of the WebDAV server to your default web browser's proxy exceptions list. This is normally set on the browser's preferences/settings page with the other proxy settings.








6.4.5.4 Modifying a WebDAV Connection



WebDAV connections are shown in the Application Resources section of the Applications window, listed under the Connections node.

Existing WebDAV connections can be modified.

To modify a WebDAV connection:




	Right-click the WebDAV connection that you want to modify.
	Choose Properties.
	On the WebDAV Connection Properties dialog, change the details of the WebDAV connection.

For help while using the dialog, press F1.




	Click OK.








6.4.5.5 Refreshing a WebDAV Connection



WebDAV connections are shown in the Application Resources section of the Applications window, listed under the Connections node.

To ensure that the folders and files accurately reflect the current contents of the WebDAV server, you can manually refresh the display of a WebDAV connection.


Note:

All folders and files listed for the WebDAV connection are refreshed. The properties of the folders and files, and their contents, are refreshed.



To refresh the entire contents of a WebDAV connection:




	Right-click the WebDAV connection that you want to refresh.
	Choose Refresh.








6.4.5.6 Deleting a WebDAV Connection



WebDAV connections are shown in the Application Resources section of the Applications window, listed under the Connections node.

Deleting a WebDAV connection from JDeveloper does not affect any of the files or folders on the WebDAV server itself.

To delete a WebDAV connection:




	Right-click the WebDAV connection you want to delete.
	Choose Delete.



You can subsequently recreate the connection, in which case the files and folders that were part of it will be shown beneath it again.













6.5 Working with Files in Source Control


As a general rule, your workflow in the version control system your team uses will follow this basic format:

	
Check out files from the repository


	
Make changes


	
Check in (or commit) files back to the repository




In some circumstances, you may find that other team members have been editing the same files that you are committing. This requires resolving file conflicts.

In addition, many version control systems allow you to lock a file so that other users cannot check it out. This prevents you from having file conflicts which need to be resolved.





6.5.1 How to Check Out Files


Commonly, your version control system requires you to check out a file from the repository before you begin making changes to it. This logs your access to the file and, in many instances, locks the file you have checked out to prevent other team members from accessing it while you are editing it. This can help prevent problems where multiple team members make conflicting edits to the same file.





6.5.1.1 Checking Out Files from the Subversion Repository



To begin making edits and revisions to files in your project, you check out the files you will be working with. It is recommended that you check out the entire application from the Subversion repository, so that you will have access to all files in that application in your local work area. Subversion uses the term modules to refer to the application it is recommended you check out.


Note:

With Subversion, there is no "check in" procedure, so you do not check in files that you have updated and check them out again when you next want to work on them. Instead, when you have finished working on your local copies of files, you commit them to the Subversion repository to bring the files up to date.



When you check out Subversion files, they are copied from the Subversion repository to a new location (specified by you) on your local machine. This location and the files within it constitute the Subversion "working copy."

To check out modules from the Subversion repository:




	In the Versions window, select the repository node or folder containing the files that you want to check out.
	Choose Team > Subversion > Check Out.

If there is no current connection to a Subversion repository, the Create Subversion Connection dialog is opened for you to create one.

The Check Out from Subversion dialog is displayed. To obtain more information when working with the dialog, press F1 or click Help.




	Make sure that the Subversion connection that the dialog displays is the correct connection (if you have more than one Subversion connection or repository).
	Browse to the path in the Subversion connection containing the application files you wish to check out.
	Enter the destination in your work area to which you wish the checked-out files to be copied, or click Browse to navigate to your local work area.
	You have the option of checking specific tags, if your team uses them.
	If you wish to check out files within folders contained by this Subversion module, make sure to select Depth.

When you have made all your selections, click OK.












6.5.1.2 Checking Out Files in Git



Checking out a file from your Git repository makes that file available for changes and edits. You can also specify the revision you wish to check out.

To check out a file:




	Select Team > Git > Checkout. This displays the Git Checkout Revision dialog.
	Enter the branch from which you wish to check out the file. To browse from a list of available branches, click the Branch button.
	Select the tag (optional) you wish to check out. To view a list of tags, click the Tag button, then select the desired tag.
	Specify the commit ID (optional) for the checkout. To view a list of commit IDs used in your repository, click the Select Commit button, then choose from the list of commit revisions.
	Optionally, create a new branch for the checkout.
	When you have made all your selections, click OK.



Git checks out the files you have selected. They are now available for editing.









6.5.1.3 Checking Out CVS Modules



This is a configuration task you perform when you first start to use JDeveloper with files and folders that are under CVS source control. You perform this task once, after (if necessary) importing your JDeveloper project into the CVS repository.

To check out modules from the CVS repository:




	In the CVS Navigator, select the CVS module that you want to check out by choosing Team > CVS > Check Out Module.

Alternatively, you can select Check Out Module from the contextual menu.

The Check Out from CVS dialog is displayed.




	Complete the dialog. For help when using this dialog, press F1 or click Help.








6.5.1.4 Editing Files in Perforce



Unlike some version control systems, Perforce does not require you to explicitly check out a file. To begin editing a file in Perforce, select Team > Perforce > Open for Edit. This opens the Open Files for Edit dialog, which gives you the option of placing the file on a changelist, locking the file so that other team members cannot edit it simultaneously, and more. topicid:f1_pfcopenfilesforedit_html

You can start editing a file under Perforce control just by opening it from the Applications window. While the Perforce server is being contacted, you may experience a delay before you can type into the opened file. If you would prefer files to remain closed until you manually open them for editing, set the Automatically Open Files for Edit preference to off.











6.5.2 How to Update Files with Subversion


Updating files at the beginning of every work session helps ensure that you have all the changes made and checked in by your team members. This reduces the amount of time you might have to spend reconciling changes later, because it helps ensure that you have the latest version of your files when you begin editing them.





6.5.2.1 Updating Files from the Subversion Repository



Once your Subversion repository is set up, you typically update your local working copy with files from the repository. This ensures that the files you work on contain all committed changes that others on your team may have made to the same files.

It is recommended that you perform the update operation on a working copy.

When you use Update Working Copy, all the files in your checked-out working copy will be updated, regardless of which node you have active in your application in the JDeveloper Applications window. The alternative is to select Update. This will only update the folder or file (and any child folders and files) that you have selected in the Applications window.

To update a working copy (recommended):




	In the Applications window, select a navigator node or file that is part of the working copy.
	Select Team > Update Working Copy.

The Update Working Copy dialog is displayed with the working copy folder listed.




	Ensure that the folder shown is the correct one for the working copy that you wish to update. If it is not, cancel the dialog and begin again from step 1.
	Set the options on the Update Working Copy dialog as required.

To obtain more information about the options, press F1 or click Help.




	To update the working copy from the Subversion repository, click OK.








6.5.2.2 Updating Individual Files in the Subversion Repository



You can also update individual files. However, this runs the risk of not updating all files that may have been modified by your team members since the last time you checked them out.

To update individual files:




	In the Applications window, select the file(s) that you wish to update and choose Team > Update.

The Update Resources dialog is displayed with the file(s) listed.




	Set the options on the Update Resources dialog as required.

To obtain more information about the options, press F1 or click Help.




	To update the listed file(s) from the Subversion repository, click OK.








6.5.2.3 Removing Files from Subversion Control



If you wish to remove a file from Subversion control, use the JDeveloper Delete feature. This performs a “safe delete," which searches for usages of the file you are deleting and provides you with a dialog with options for proceeding.

To remove a file from Subversion control:




	In the Applications window, select the file to be removed from Subversion.
	Select Edit > Delete (or right-click the file and select Delete).
	Make sure that Delete Safely is selected.
	Click OK.

If JDeveloper finds usages of the file you are deleting, a dialog will offer you options for proceeding. Choose the appropriate option, then click OK.












6.5.2.4 Working with Files in CVS


As a general rule, working with files in CVS means checking out the latest version of a file, making your edits, and checking the file in with your changes. Occasionally, if you and a colleague have made edits to the same file, you may need to merge your changes to make sure your work is not lost. Other functions of CVS are also available, such as adding a new file or removing unused/obsolete files from the repository, but your general workflow will follow the checkout-edit-checkin pattern.

The file operations in CVS include refreshing the display of CS objects, adding and removing files, using templates, comparing files, replacing a file in CVS, viewing the history and status of a file, locking and unlocking files, and working with revisions and tags.







6.5.2.5 Refreshing the Display of CVS Objects



The source control status of an object is indicated in the Applications window by an icon overlay, as listed in Table 6-1.







Table 6-1 CVS Object Status

	Icon	Description
	
[image: This image is described in the surrounding text.]

	
The object has been copied from the CVS repository and added to your working files directory.


	
[image: This image is described in the surrounding text.]

	
The object is not under CVS source control, but may be added to the CVS repository.


	
[image: This image is described in the surrounding text.]

	
There were conflicts when the object (a file) was updated from the CVS repository. In this case, you have to manually edit the file to resolve all the points of conflict.


	
[image: This image is described in the surrounding text.]

	
The object has been scheduled for removal from the CVS repository with the next commit action.


	
[image: This image is described in the surrounding text.]

	
The object is out of synch with the CVS repository due to local or remote changes.


	
[image: This image is described in the surrounding text.]

	
The object is unmodified since it was last copied from the CVS repository.


	
[image: This image is described in the surrounding text.]

	
The object is unmodified since it was last copied from the CVS repository but is read-only.


	
[image: This image is described in the surrounding text.]

	
The package or node is a CVS sandbox folder.


	
[image: This image is described in the surrounding text.]

	
The apparent object may comprise several underlying objects, the statuses of which may not all be identical.













6.5.2.6 Refreshing the Status of Objects in JDeveloper



If the status of an object is changed outside JDeveloper, for example by checking in an object using external source control software, the new status might not immediately be shown in JDeveloper. To ensure that the status indicated in the Applications window matches the true status of the object in the source control system, you can perform a manual refresh.

To refresh the status of objects in JDeveloper:





	
In the Applications window or CVS Navigator, click Refresh.












6.5.2.7 Adding and Removing Files in CVS



You can add a file to CVS only if it is part of a project that is already under CVS version control.

When you create a new file, for example a new class, it has to be added to source control before you can use the other CVS operations on it. The file is added to source control locally, and the CVS repository is not updated. The file is identified in the Applications window by the icon +.

After completing setup, your work will revolve around the following:





	
Updating your files from the repository


	
Checking out the files you need to work on


	
Editing them in JDeveloper


	
Committing the modified files back to the repository




You may also need to resolve conflicts between changes you made and those made by others in your team. Files may also be moved in and out of CVS control as the project changes. Finally, you might use special properties of the files associated with specific versions for tracking bugs, customer requests, and other characteristics.

To add a file to CVS through the Applications window:

	
Select the file in the Applications window and choose Team > Add (or, if the file is binary, Team > Add as Binary). JDeveloper usually recognizes binary files and adds (Binary) after the file name in the Applications window. The Add to CVS dialog (or Add to CVS as Binary dialog) is displayed, with the file listed.


	
Click OK.

The file will be added to the CVS repository when the next commit is performed.




To add files shown in the Pending Changes window:

	
With the Pending Changes window in Candidate Files mode, select the files that you want to add to source control.

To obtain more information about the Pending Changes window, press F1 or click Help.


	
Click the Add button.




To remove a file from CVS:

When you remove a file from CVS it is removed from your local disk.




	In the Applications window, select one or more files to be removed, then choose Team > Remove.
	The Remove from CVS dialog is displayed with the files listed.
	Click OK.



The file or files will be removed from the CVS repository when the next commit is performed.











6.5.3 How to Work with New and Changed Files in Git


In the Git version control system, you commit files for two reasons: to make your initial import of new files to your repository, and to check in changes when you have made edits.

In Git, the basic file workflow is in three parts:

	
You initially create a local file system with the selected branch and content from your repository. You can do this using Team > Git > Clone.


	
You add new files to the repository: one at a time using Team > Git > Add, or multiple files with Team > Git > Add All.


	
As you edit files, you check them back into the Git repository one at a time with Team > Git > Commit, or multiple files with Team > Git > Commit All.




The following sections describe how to perform these operations.





6.5.3.1 Adding a File to a Git Repository



To add a single file to your Git repository, use the Add command from the Git menu.

To add a file:




	Select Team > Git > Add.
	Browse to the pathname for the file you wish to add.
	Click OK.



The file is added to your selected Git repository.









6.5.3.2 Adding Multiple Files to a Git Repository



To add multiple files to your Git repository, use the Add All command from the Git menu. This command adds all files in a directory.

To add multiple file:




	Select Team > Git > Add All.
	Browse to the pathname for the directory from which you wish to add files.
	Click OK.



All files in the selected directory are added to your Git repository.









6.5.3.3 Committing a Change to the Git Repository



When you have made changes to a file, you can commit them to the Git repository.

To commit a change:




	In the Applications window, select the file whose changes you want to commit.
	Select Team > Git > Commit. This displays the Commit dialog, which displays the file name and location in your local directory.
	In the Commit dialog, you can optionally choose to commit non-staged files.
	In the Comments field, enter a short description of the changes you have made to the file you are committing.
	If your team uses comment templates, select one from the Comment Templates drop-down list. You can also select the link to display the Preferences > Git > Comment Templates dialog. This allows you to add or import comment templates.
	When you are finished, click OK.



JDeveloper commits your changed file to the Git repository.









6.5.3.4 Committing Multiple Files to the Git Repository



When you have made changes to multiple files, you can commit them all to the Git repository in one operation.

To commit a number of changed files:




	In the Applications window, select the files whose changes you want to commit.
	Select Team > Git > Commit All. This displays the Commit dialog, which displays the path name to the files in your local directory.
	In the Commit dialog, you can optionally choose to commit non-staged files.
	In the Comments field, enter a short description of the changes you have made to the file you are committing.
	If your team uses comment templates, select one from the Comment Templates drop-down list. You can also select the link to display the Preferences > Git > Comment Templates dialog. This allows you to add or import comment templates.
	When you are finished, click OK.



JDeveloper commits your changed files to the Git repository.











6.5.4 How to Work with Files in Perforce


Perforce provides features for creating and applying patches—methods for determining changes between two revisions of a file, and then applying those changes to a third file. In addition, Perforce contains features for exporting the details about repository connections, as well as files in the repository.





6.5.4.1 Synchronizing Local Files With the Controlled Versions in Perforce



Another person may edit a file through their Perforce client and submit their changes to the Perforce depot. This will cause your copy of the file to become out of date compared with the controlled version.

To test that your view is showing the latest file statuses:





	
Choose View > Refresh.

A file that is out of date with the controlled version is shown with an exclamation point icon.




To bring your files up to date compared with the controlled version:




	From the Connection drop-down list, select the preferred Perforce connection (if you have more than one) for this changelist.
	Select the files in the Applications window and choose Team > Sync.

The Sync Files dialog is displayed with the files listed.




	Complete the dialog.

For more information about the dialog options, press F1.




	To synchronize the files, click OK.

Your local files are replaced with copies of the controlled versions. The icon shown next to the files changes to a green dot.












6.5.4.2 Synchronizing Files With the Perforce Navigator



The Perforce Navigator lets you browse the Perforce depot and update your working directory from content at the depot. Using the Applications window, you can select folders or files to sync to your client workspace, downloading content from the Perforce Server to your computer. If new files are detected in the depot, you have several options for handling them.

If you open a connection node and no connection has been made, Perforce displays the connection dialog.

To synchronize your files using the Perforce Navigator:




	Expand the content under Perforce in the Versions window, selecting the folders and/or files you wish to synchronize. When you expand to the level of the project you're working on, right-click the file or folder, and then select Sync From Depot. This displays the Sync From Depot dialog.
	The project you selected displays in the Name pane of the Sync From Depot dialog. Below that are fields you can select or specify:

Head Revision

Synchronize to the Head revision of your project. If you select this, the Sync From Depot dialog displays the Force sync checkbox. Select Force Sync if you wish to download the depot content to your working directory regardless of the contents of each (for example, if you know you want to start with a clean download of the depot's contents).

Revision Number

Select this to synchronize to a specific revision number. The Sync From Depot opens the Target field; use the Target field to type the revision number to which you wish to synchronize your local working copy.

Changelist

Select this to synchronize to a specific changelist. The Sync From Depot opens the Target field; use the Target field to type the name of the change list from which you wish to synchronize your local working copy.

Label Name

Select this to open files with a specific label (typically, used to identify a specific branch). The Sync From Depot opens the Target field; use the Target field to type the name of the label from which you wish to synchronize your local working copy.

Date

Select this to specify a date (and, optionally, time) from which you wish to synchronize your local files. The Sync From Depot opens the Target field; use the Target field to type the date (in either yyyy/mm/dd or yyyy/mm/dd:hh:mm:ss format) of the files from which you wish to synchronize your local working copy.

Choose the field that applies to your current project, then click OK.




	If the depot contains files that do not exist in your source, Perforce tells you that new files were detected, and lists the following options:

Open files in active project

Copy the files, and open them in the project you have selected.

Create new project from files

Creates a new project, using the files Perforce has detected.

Open editors onto files

Open the files in editor windows, so that you can review them and determine the best resolution (keep, rename, discard, or modify).

Do not open files

Leaves the files unopened, without copying them from the depot to your working directory.












6.5.4.3 Filtering Files By Perforce Workspace



If you have a very large number of files in your Perforce depot, it can be much easier to navigate to the files you're working on by filtering files in the Perforce workspace. You can do this by setting things up in the Perforce client, and then displaying the filtered view in JDeveloper.

Filtering files in Perforce (specifically, p4v) requires making sure that you are viewing the Depot Tree, then select the Filter icon > Tree Restricted to Workspace View.

To filter files in JDeveloper:





	
Version Navigator > Perforce > Connection name > Context menu - Filter by Client Workspace.




You will only see a difference in the JDeveloper Version Navigator if the Perforce client has a rule that restricts the Perforce workspace. (In p4v, the rules are shown and set in the View field of the Workspace dialog for the selected workspace.) You could restrict the workspace view in your p4v client with a rule like the following:

//depot/JDeveloper_1013/... //<client name>//JDeveloper_1013

In JDeveloper, if you select Filter by Client Workspace, the Applications window would be filtered so only //depot/JDeveloper is shown.









6.5.4.4 Refreshing the Status of Files under Perforce Control



The source control status of a file is indicated in the JDeveloper navigators by icon overlays, as listed in.







Table 6-2 Perforce Status Icons

	Icon	Meaning
	
[image: This image is described in the surrounding text.]

	
The file is in the Perforce client workspace but is not yet submitted to the Perforce depot.


	
[image: This image is described in the surrounding text]

	
The file will be deleted when next submitted to the Perforce depot.


	
[image: This image is described in the surrounding text.]

	
The file is out of date compared with the Perforce depot.


	
[image: \]

	
The file is up to date compared with the Perforce depot.


	
[image: This image is described in the surrounding text.]

	
The file is open for edit.


	
[image: This image is described in the surrounding text.]

	
The file is locked.









If the status of a file is changed outside JDeveloper, for example by using a Perforce client application, the new status might not immediately be shown in JDeveloper. To ensure that the status indicated in the Applications window matches the true status of the file in the source control system, you can perform a manual refresh.

To refresh the status of files in JDeveloper:

	
Select View > Refresh.












6.5.4.5 Deleting Files from Perforce



If you wish to delete a file that it is under Perforce control, you should do so using the Perforce facilities within JDeveloper or the Perforce client application.

If you need to retrieve a file that has been deleted, you will need to use the Perforce client. To do this, select Team > Perforce > Launch Perforce Client.

To delete a file under Perforce control:




	Select the file in the Applications window and choose Team > Open for Delete.

The Delete Files dialog is displayed with the file listed.




	Click OK.

The file is deleted from the local file system. A black diagonal cross is added to the file's icon in the Applications window.














6.5.5 How to Lock and Unlock Files


Not all version control systems explicitly require, or even have the facility for, locking files before editing. In some systems, checking out the file automatically locks it and prevents other team members from editing that file. In other systems, the files can be checked out by any team member, with the emphasis being on easily merging different changes to the resulting file.

The following sections explain how each version control system handles locking and unlocking a file.





6.5.5.1 Locking and Unlocking Files in CVS




Note:

The locking of files is not supported in newer releases of CVS client software and this facility may be removed in future releases of JDeveloper.



You can choose to prevent other users working on a file while you are working on it yourself. This is not normally considered necessary, because CVS can usually reconcile differing versions of files as they are being committed to the CVS repository. The JDeveloper compare and merge facilities will reconcile differing versions of files automatically, or present you with a tool for doing so manually if there are serious conflicts.

You may want to ensure that a file is worked on only by you, until you have finished working on it. This might be because a file is in binary format and therefore inherently difficult to merge. In this case, you can lock the file that you want to work on. The file is locked in the CVS repository, and other users are prevented from accessing it. When you want to let others work on the file, you unlock it.

To lock files in CVS:

	
With the file or files that you want to lock selected in the Applications window, choose Team > CVS> Administration > Lock.


	
Check that you want the operation to apply to all of the files highlighted in the file selection box.


	
Click OK.




To unlock files in CVS:




	With the file or files that you want to lock selected in the Applications window, choose Team > CVS> Administration > Unlock.
	Check that you want the operation to apply to all of the files highlighted in the file selection box.
	Click OK.








6.5.5.2 Editing Files in Perforce



By default, you can start editing a file under Perforce control just by opening it from the Applications window, without explicitly locking the file. While the Perforce server is being contacted, you may experience a delay before you can type into the opened file. If you would prefer files to remain closed until you manually open them for editing, set the Automatically Open Files for Edit preference to off. The following procedure works whichever way the preference is set.

To edit a file under Perforce control:




	Select the file in the Applications window and choose Team > Open for Edit.

The Open Files for Edit dialog is displayed with the file listed.




	If the file is out of date with the controlled version and you wish to edit the controlled version, check the Sync files to box.

If you do not obtain the controlled version before editing the file, you may create a conflict between your file and the version in the Perforce depot. You will then have to resolve the conflict before your changes can be accepted into the controlled version.




	If you wish to lock the file, check the Lock Files box.

Locking a file means that others can edit the file but cannot submit the file until the person who applied the lock has released it.




	To make the file editable under Perforce control, click OK.

The file will be indicated to Perforce as editable. A red check mark is added to the file's icon in the Applications window.




	To edit the file, choose Open from the file's context menu.
	Make your changes and save the file.

You can also close the file if you wish.







The changes that you made to the file are now saved in your Perforce client workspace. To add your changes to the controlled version of the file and make them available to other users, you must now submit them.









6.5.5.3 Checking Out Files in Team System



Use to check out files so that you can work on them. The files must already by under Team System source control.

To check out files:




	In the Applications Navigator, select the application, project or file that you want to check out.
	Select Team > Check Out.

The Check Out dialog is opened.




	Complete the dialog.

For information while using the dialog, press F1.












6.5.5.4 Viewing the Status of a File in Team System



You can check the status of a file that is under Team System source control. See also Refreshing the Status of Files in Team System.

To view the status of a file:




	With the file selected in the Applications window, open the context menu and select Team > Properties.
	Select the Versioning tab.



The status labels shown are those used by Team System to describe the source control status of the file.

The main statuses are:

	
Edited - In JDeveloper, the file is checked out and may have been modified.


	
Unchanged - In JDeveloper, the file is currently checked in.


	
Scheduled for addition - In JDeveloper, the file has been added (that is, brought under source control) but not yet checked in.












6.5.5.5 Refreshing the Status of Files in Team System



The source control status of a file is indicated in the JDeveloper navigators by icon overlays, as below.







Table 6-3 File status icons in Team System

	Icon	Description
	
[image: This image is described in the surrounding text]

	
The object is checked in and must be checked out before it can be modified.


	
[image: This image is described in the surrounding text]

	
The object is checked out and can be modified.


	
[image: This image is described in the surrounding text]

	
The object is not under source control.


	
[image: This image is described in the surrounding text]

	
The file has been brought under source control but has not yet been checked in to the Team System server.


	
[image: This image is described in the surrounding text]

	
The object has been scheduled for removal from the Team System server the next time it is checked in.









To refresh the status of files in JDeveloper:

	
Select View > Refresh.














6.5.6 How to Check In Changed Files


Checking in, sometimes called committing, is the process by which the changes you have made to your local file version are uploaded to the central repository. The following sections outline the procedures used by the various version control systems in use with JDeveloper.





6.5.6.1 Committing Files to the Subversion Repository



Once you have made edits and revisions to your working files, you return them to the Subversion repository.

Use these procedures to bring the Subversion repository up to date with the latest version of the files you have been working on, at the same time adding any new files to or removing any unwanted files from the Subversion repository.

You can perform the commit operation on individual files, or in the context of a working copy.

If an individual object that you want to commit has uncommitted parent objects, you must first commit the parent objects. An alternative is to commit the working copy that the objects are part of, in which case all the uncommitted objects will be committed.

You can also use change sets to manage groups of files, which can help ensure that you commit all files pertaining to a particular sub-project or task within the overall application.

To commit individual files shown in the Applications window or the Pending Changes window:





	
Select the file(s) and choose Team > Commit.

The Commit Resources dialog is displayed with any files listed. Set the options on the Commit Resources dialog as required.

To obtain more information about the options, press F1 or click Help. To commit the listed file or files to the Subversion repository, click OK.




To commit a working copy from the Applications window:

	
Select a navigator node or file that is part of the working copy.


	
Select Team > Commit Working Copy.




To obtain more information about the options, press F1 or click Help. To update the Subversion repository with the content of the working copy, click OK.

When you use Commit Working Copy, all the files in your checked out working copy will be committed, regardless of which node you have active in your application in the JDeveloper Applications window. The alternative is to select Commit. This will only commit the folder or file (and any child folders and files) that you have selected in the Applications window.

Additionally, you can commit a working copy from the Pending Changes window.

To commit a working copy from the Pending Changes window:




	Put the Pending Changes window into Outgoing Changes mode.

To obtain more information about the Pending Changes window, press F1 or click Help.




	Select a file from the working copy that you wish to commit.
	Select Team > Commit Working Copy.






6.5.6.1.1 Saving Work Item ID with the Oracle Team Productivity Center Extension


If you are using Oracle Team Productivity Center, the work item ID will automatically be saved as a tag in the comment dialog when you commit.









6.5.6.2 Committing Changes to the Git Repository



There are two options for committing your changes to the Git repository: selecting an individual file to commit, or committing all files at once.

To commit an individual file:

	
Select the file you wish to commit.


	
Select Team > Git > Commit. This opens the Save Files dialog. Click OK to continue. This opens the Commit dialog.


	
If your team uses comment templates (for example, to make it simpler to track issues automatically in a bug-tracking system), select the template or add a comment. Otherwise, click OK to commit the file to the repository.




To commit all files in a project:




	Select the project whose files you wish to commit.
	Select Team > Git > Commit All. This opens the Save Files dialog. Click OK to continue. This opens the Commit All dialog.
	If your team uses comment templates (for example, to make it simpler to track issues automatically in a bug-tracking system), select the template or add a comment. Otherwise, click OK to commit the files to the repository.








6.5.6.3 Committing Changes to CVS



Use these procedures to update the CVS repository with the latest version of the files you have been working on, and to add any new files to or remove any unwanted files from the CVS repository.

You can perform this on a single file, or in the context of a project. When in the context of a project, JDeveloper determines which files have changed since they were last committed and displays them as a list.

If you select a project to be committed that includes files that are not yet part of CVS version control, the Add Files to CVS message dialog will open. To obtain information about using this dialog, press F1.

You can view the current contents of the CVS repository through the CVS Navigator. The nodes under CVS unfold to reveal the structure and file content of the CVS repository. You can open a read-only version of a CVS repository file by choosing Open from its context menu. This will let you see what changes have been made to the files in the CVS repository since you checked out or updated your local versions.

To commit individual files shown in the Applications window:

	
Select the file(s) in the Applications window, and then choose Team > Commit.

The Commit to CVS dialog is displayed with the file(s) listed.


	
Set the options on the Commit to CVS dialog as required.

To obtain more information about the options, press F1 or click Help.


	
To update the listed file(s) in the CVS repository, click OK.




To commit the contents of project folders shown in the Applications window:

	
Select the project folder(s) in the Applications window and, from the context menu, choose Versioning > Commit Project Folders.

If there are files in the project that are not under CVS control, you will be asked whether you want to add them.

The Commit to CVS dialog is displayed with the folder(s) listed.


	
Set the options on the Commit to CVS dialog as required.

To obtain more information about the options, press F1 or click Help.


	
To update the listed file(s) in the CVS repository, click OK.




To commit files shown in the Pending Changes window:




	With the Pending Changes window in Outgoing Changes mode, select the files that you want to commit.

To obtain more information about the Pending Changes window, press F1 or click Help.




	Click the Commit button.








6.5.6.4 Submitting Changed Files to the Perforce Depot



Any changes that you make to a file are initially saved in your Perforce client workspace. To add these changes to the controlled version of the file and make them available to other users, you must submit them. In the following procedure, if the Submit menu option is unavailable, it is because there are unresolved conflicts between your copy of the file and the one in the Perforce depot. Before proceeding, you will have to resolve the conflicts or revert the file to a non-conflicting version.

To submit changes to the Perforce depot:




	With the file selected in the Applications window, choose Team > Submit.

The Submit Files dialog is displayed with the file listed.




	Add your versioning comments in the Comments box.
	To submit the files to the Perforce depot, click OK.

The file is now shown in the Applications window with a green dot, indicating that it is up to date compared with the version in the Perforce depot.












6.5.6.5 How to Check In Files to Team System



Use to check in a file to the Team System server. A checked in version of a file can be seen and worked on by other users.

To check in files:




	In the Applications window, select the file that you want to check in.
	Select Team > Check In.

The Check In dialog is opened.




	Complete the dialog.

For information while using the dialog, press F1.














6.5.7 How to Use Change Sets and Changelists


Some version control systems (notably Subversion and Perforce) use the notion of change sets or changelists to group together files which form part of a single logical group. For example, you might be adding a new feature to an application which has a number of specific files: the HTML framework which calls a JavaScript function, the JavaScript file which contains the function itself, and a set of image files which represent the various states of the button before, when and after the user clicks on it in the final application. You might choose to group all these files in a single change set, as a way of tracking them and ensuring that you commit all of them to the repository (or that you refer to all of them in your team's tracking or build software).

The following sections describe how to use change sets or changelists in the version control systems that support them.





6.5.7.1 Using Change Sets in Subversion



Change sets, or change lists, are essentially labels which can be applied to working copy files to enable group operation on each change list. The idea behind adding files to a change set is similar to sorting files into directories, but change lists can be created dynamically and the labels applied to each file, regardless of their level in the file system hierarchy. You can then address all the files in the change set as a single group. For example, if you make a single bug fix that requires editing three different files, you can add all three files to the change set and track them as a single logical unit in the JDeveloper Pending Changes window.

Subversion lets you associate files with a named change set, either manually or automatically. You make additions to the change set through the menu system; automatic additions are also possible through default association, when JDeveloper detects outgoing changes.

You can browse changes for a named change set in a view of the Pending Changes window. From there, you can manipulate the change sets, and commit associated changes to the repository.

To add a selected file to a new change set:





	
Select a file from the Pending Changes window, then select Team > Add To > New Change Set.




To add file to a change set:




	In the Pending Changes window, select a file to add to an existing change set and click the right mouse button.
	Select Add To, then choose an existing change set.
	Select one of the existing change sets displayed in the dialog, or select New Change Set to create a new change set containing this file.
	Click OK.






6.5.7.1.1 Editing Change Sets


JDeveloper creates a default, unnamed change set for each installed version control system, and uses this change set until you specify another change set as the default. You can make changes to the content and the status of individual change sets, including this default change set, by right-clicking any change set and selecting from the following:

	Edit
	
Change the content of the selected change set.




	Remove
	
Deletes the selected change set from Pending Changes. Does not delete the files associated with the change set.




	Make Default
	
Makes the selected change set the default for future operations. All newly created and edited files will be made part of this change set until you either change the default or manually add the file to a different change set.












6.5.7.2 Creating a Perforce Changelist



In Perforce, changelists let you group files together to simplify operations. Once files are grouped in a changelist, you can check them out and submit them all in a single operation.

In Perforce, changes are submitted to a Perforce repository using a changelist. This lets you group changes to several files into a logical unit, and then submit this unit to the Perforce repository in one operation.

You can have more than one changelist. You may find it useful to create changelists for specific projects, for related groups of files, or for any other grouping of files that you find create a logical unit, based on the way you and your team work. You can also move files from one changelist to another.

In general, you use changelists by following this workflow: create a changelist, add files to your changelist, edit your files and submit your changelist with the edited files.

You can also browse existing changelists through the Changelist Browser. The Changelist Browser also lets you create, submit, and move files between changelists. If the submit operation fails on any file in the changelist, then the whole changelist fails. This means the Perforce repository is left in a consistent state.

A Perforce changelist lets you manipulate a number of changed files and folders in a single operation, simplifying the process when you have several files that you have been working on.

To create a Perforce changelist:




	From the Versioning menu, select Perforce > Create Changelist.
	From the Connection drop-down list, select the preferred Perforce connection (if you have more than one) for this changelist.
	Select the files to be added to the changelist, or click Select All to add all displayed files to this changelist.
	Add comments to this changelist, if desired. You can choose a previous comment (with the option of editing it if necessary), or you can select your comment template.
	When you have set up the changelist as desired, click OK.








6.5.7.3 How to Annotate a Perforce Revision or Changelist



Annotating a Perforce revision or changelist lets you store the Perforce revision or changelist as a comment linked to every file in the revision. When you modify these files later in Perforce, you can view the sequence of revisions or changelists to these files, as annotations to the files.

To add annotations to a changelist:




	From the Versioning menu, select Team > Perforce > Perforce Pending Changelists.
	Select the changelist to view by clicking the Use Changelist selector.



Any previous annotations will be visible in the Comments field of the changelist.









6.5.7.4 Adding Files to a Perforce Changelist



A Perforce changelist lets you manipulate a number of changed files and folders in a single operation, simplifying the process when you have several files that you have been working on. When you add files to Perforce, you can select the changelist to which these files will be added at the same time, through the Open for Add menu.

To add files to a changelist:




	From the Versioning menu, select Perforce > Open for Add.
	Select the changelist to use by clicking the Use Changelist selector.








6.5.7.5 Submitting a Perforce Changelist



Once you have made a series of edits to your files, you are ready to submit them in Perforce. If you have created a changelist, you can submit all the files on that changelist in a single operation, or select just the ones you have edited and submit them.

To select and submit the files in a changelist:




	From the Versioning menu, select Perforce > Submit Changelist.
	Enter a description of the changes you have made in the Description field.
	Check the files you wish to submit. Use the Select All and Deselect All buttons if required.








6.5.7.6 Using the Perforce Changelist Browser



The Changelist Browser lets you see, at a glance, the state of all the pending changelists in your Perforce repository. Each pending changelist is shown with its name, description, and contents. The default changelist is always shown at the top of the browser. Under each changelist, you can browse the files that are associated with that changelist. Additionally, the Perforce connection and client are displayed at the top of the browser.

From the Pending Changelist browser, you can create and submit changelists, move files between changelists, and refresh the browser.

To create a changelist with the Changelist Browser:

	
From the Versioning menu, select Perforce > Create Changelist.


	
From the Connection drop-down list, select the preferred Perforce connection (if you have more than one) for this changelist.


	
Select the files to be added to the changelist, or click Select All to add all displayed files to this changelist.


	
Add comments to this changelist, if desired. You can choose a previous comment (with the option of editing it if necessary), or you can select your comment template.


	
When you have set up the changelist as desired, click OK.




To submit a changelist:

	
From the Versioning menu, select Perforce > Submit Changelist.


	
Enter a description of the changes you have made in the Description field.


	
Check the files you wish to submit. Use the Select All and Deselect All buttons if required.




To move files between changelists:




	Click the right mouse button the file in the Changelist Browser and select Move File to Changelist.
	Select the changelist to which you wish to move this file, then click OK.



You can also refresh the changelist browser by pressing F1.











6.5.8 How to Use Comment Templates for Checkins


Subversion, CVS, Git, and Perforce all let you configure comment templates to be used when checking in or committing files. One popular use for a comment template is to structure the comment text in such a way that it can be read by a bug-tracking system to correlate file checkins with issues being tracked. For example, beginning a comment with the string bugtraq and then following with the issue number would make it possible to analyze comments automatically and generate a report of files and the bugs they were filed against.

The four version control systems that use comment templates all allow you to are Subversion, CVS, Git, and Perforce. The following instructions are common to all these systems.





6.5.8.1 Creating Templates



Many team environments allow the developer to enter comments when a file is checked in. These comments might include bug report numbers, dependencies on other files, or some other explanatory information to be stored in connection with the file being committed to the repository.

In particular, some teams wish to correlate checked-in files with the bugs that the files address. One way to do this is to set up a standard template for issue tracking, for example, bugtraq <bug number> where you replace <bug number> with the actual ID of the issue this file addresses, and use that as the comment to a file checkin. This way, file checkin comments can be used to correlate the edits with the issues being tracked.

JDeveloper lets you create and select templates for use with such comments. The templates are available from the Commit or Checkin menu, depending on how your version control system refers to the process of committing changes to the repository.

To create a new template:




	Select Tools > Preferences > Versioning > Subversion > Comment Templates.
	Click Add. This brings up the Add Template dialog.
	Type in the comment template as you wish to use it, then click OK.



The template you created will now be available to select when you commit or check in your files.









6.5.8.2 Sharing Templates



JDeveloper lets you import and export templates as text files, allowing you to share a set of templates with your team. This simplifies using the exact format that any tracking system you use will expect to see in the commit comments, and also avoids errors in formatting the template.

To import a template:

	
From the Comment Templates page, click Import. This opens a file browser.


	
Navigate to the directory containing the template file you wish to import and click on the file to select it.


	
Click Open.




The template file will be imported to JDeveloper.

You can also export your templates as a file to be imported later, either by you or (if you make the file available on a shared resource) by your team members.

To export a template:




	From the Comment Templates page of your selected version control system, click Export. This opens a file browser.
	Navigate to the directory in which you wish to save your template file. Note that the default template file format is XML.
	Give your template file a name (for example, my_bugtraq.xml) and click Save.



The template file is now available for import to JDeveloper.

Note that if your team uses more than one version control system, you can use Export and Import to share the same templates across systems.









6.5.8.3 Selecting and Using Templates at Checkin



Many team environments require the developer to enter comments when a file is checked in. These comments might include bug report numbers, dependencies on other files, or some other explanatory information to be stored in connection with the file being committed to the repository.

JDeveloper lets you create and select templates for use with such comments. The templates are available from the Commit menu.

To select a template:




	From the Commit menu for your selected versioning system, click Choose a template or previous comment.
	Select the template from the list.
	If your template requires you to enter specific data (for example, a bug or enhancement tracking number), make the edits in the Comments field.
	Click OK.



Your file will be committed with the template you selected, plus any edits you made.









6.5.8.4 Shelving and Unshelving Team System Files



Shelving lets you save file changes in the Team System server without having to check the files in. As part of the shelving process, you can choose either to continue to work on the changed files or to remove them from view and revert to unchanged versions.

When you later want to make use of the file changes that were shelved, you can unshelve them.

If you decide you no longer want to keep changes that were shelved, you can delete the shelveset that you put them in.

To shelve a set of file changes that have not been checked in:

To shelve a set of file changes that have not been checked in:

	
In the Applications window, select the versioned project containing the files.


	
Select Team > Shelve.

The Shelve dialog opens.


	
Complete the dialog.




For information while completing the dialog, click F1.

The file changes will be shelved when you click OK.

The file icons in the Applications window will change to reflect the new file statuses, if any.

To unshelve a set of file changes:

	
In the Applications window, select the versioned project into which you want to unshelve the file changes.


	
Select Team > Unshelve.

The Unshelve dialog opens.


	
Select the shelveset name for the shelveset containing the file changes.




The file changes will be unshelved when you click OK.

Files deleted since the shelveset was created will be reinstated and the file icons in the Applications window will change to reflect the new file statuses.

To delete a shelveset:




	Select Team > Delete Shelveset.

The Delete Shelveset dialog opens.




	Select the name of the shelveset that you want to delete.



The shelveset will be deleted when you click OK.









6.5.8.5 Deleting Team System Files



Use to delete files from your workspace and from the Team System server.

To delete a file:




	Select the file in the Applications window and choose Team > Delete.

The Delete dialog is displayed with the file listed.




	Click OK.

On the Outgoing tab of the Pending Changes window (Team > Pending Changes), the file will be indicated as ready for deletion: a black diagonal cross is added to the file's icon.




	To complete the deletion of the file, select it in the Pending Changes window and choose Team > Check In.

The Check In dialog is opened.




	Add your comments, if any, and click OK.



The file is deleted from your workspace and from the Team System server.













6.6 Working with Branches and Tags


Many version control systems used with JDeveloper (notably, Subversion, Git, and CVS) use branches to keep track of development projects or streams. Branches are a useful way to separate out development when (as is often the case) your team is working on multiple releases -- for example, a patch release, a major update, and a new project -- at the same time. Tracking each of these projects as a separate branch in your version control system makes it easy to track, modify, and update each project with the correct feature set, bug fixes, and other changes, and to ensure that all members of the team are tracking the same issues on the same branch.

Tags, on the other hand, are a way of tracking collections of files that capture the state of development at a particular point. Where a branch represents a stream of development moving towards a particular release, product or version, tags are useful for tracking elements within a branch -- such as a specific bug fix that might affect multiple files in a given release.





6.6.1 How to Create Branches


To work on files independently of the main line of development (the "trunk") you can create a branch. Using the same feature, you can also create a tag, a collection of files that captures the state of development at a particular point. Creating branches varies slightly from system to system.





6.6.1.1 Working with Branches and Tags in Subversion



When you wish to put the work you have being doing on a branch back into the main line of development, you can start the process by using the merge revision facility. This will compare the content of two revisions and apply the differences to the current working copy. You can also use this facility whenever you wish to copy changes made in one revision to another revision.

You may want to change your working copy so that it is based on a different branch. You can do this using the switch feature, either as part of branch creation or independently.

To create a branch or tag:

	
Ensure that you have committed your files to Subversion before continuing.


	
In the Applications window, select a project or file that is in the line of development that you wish to branch or tag.


	
Select Team >Branch/Tag.


	
Complete the Branch/Tag dialog.

For help when completing the dialog, press F1 or click Help.




To use the merge facility (that is, to compare two revisions and apply the results to the working copy):

	
In the Applications window, select a project or file that is in the start revision (that is, the resource that is to be compared against).


	
Select Team > Merge.


	
Complete the Merge dialog.

For help when completing the dialog, press F1 or click Help.




To switch the working copy to be based on another location in the repository:




	In the Applications window, select a project or file that is in the current working copy.
	Select Team > Subversion > Switch.
	Complete the Switch dialog.

For help when completing the dialog, press F1 or click Help.












6.6.1.2 Creating a New Branch in Git



You can create a new, named branch of your Git repository, and optionally apply a tag when you create it, from the Create Branch dialog.This creates the named branch for use with Git, and associates the selected tag with it if you choose.

To create a new branch in Git:




	Select Team > Git > Create Branch.
	Enter the name for your branch or tag -- for example, the version number of the release you are working on, or the code name for the current update.
	Enter the branch you are using as the source for the branch you are creating. To select from available branches, click Select Branch. This places the branch name in the Branch field and greys out the Tag field.
	To give your new branch a tag, click Select Tag, then select from one of the available tags displayed in the Select Tag dialog.
	Optionally, use a specific commit ID for the source of the branch you are creating. You can either enter the commit ID by hand, by copy and paste (the commit ID is a 40-digit hexadecimal number), or click Select Commit to choose one from a list of available IDs.
	When you are finished, click OK.










6.6.1.3 Creating a New Branch in CVS



You create a new branch when you are beginning a project based on an earlier version of your code repository, such as for fixing bugs after a major release, or working on specific features for a subset of your customers.

To create a new branch:

	
In the CVS repository, select the file or folder on which you wish to base your new branch, then click the right mouse button.


	
Choose Branch > Branch in CVS.


	
Type in the branch name. JDeveloper converts the branch name to the default tag for the branch, by appending _BASE to the branch name as you type it.


	
Choose whether the branch source is the trunk or the working copy. If you select the trunk, the HEAD revision of every file is branched.


	
Click Save.




The base tag is applied before the branch is created, allowing you to specify these versions as a merge point in future.

You can also specify that you wish to create your new branch from an existing branch, by choosing the branch to use as the base.

To create a new branch from an existing branch:




	Click Details.
	Select the desired branch from the list of existing branches.










6.6.2 How to Use Branches


Once you have created a branch, JDeveloper presents a number of methods of using it to manage and track the projects you have under version control. Typically, you check out branches at the beginning of a project involving that branch, then later you can check out the individual files that you are editing or reviewing. You may also occasionally need to delete a branch (when a project is archived, for example), and you may also need to merge a branch.





6.6.2.1 Checking Out a Branch in Git



Checking out a branch in Git gives you access to the files on that branch.

To check out a branch in Git:




	Select Team > Git > Checkout.
	The Name and Location fields list the available repositories from which you can select the branch to check out. Select the repository you wish to use.
	Click on Select Branch to display the list of available branches in the Select Branch dialog. Expand the folders as required to locate the desired branch. Select the desired branch, then click OK.
	If you wish to check out content associated with a specific tag, click Select Tag, then choose the desired tag from the Select Tag dialog. When you are finished, click OK.
	To check out content from an existing commit, click on Select Commit, then select the desired commit from the Select Commit Revision dialog. This lists all available commits (including their 40-digit hex ID), and also displays the date and time of the commit, the ID of the team member who made the commit, and a message field if notes were added at the time of the commit. When you have selected the commit, click OK.
	Give the checked-out branch a name to associate with this branch, then click OK.



JDeveloper displays the branch that you have checked out, with any projects and files associated with the selected branch. You can access these files from the Application window.









6.6.2.2 Merging a Branch in Git


Note that after merging your changes from the branch into HEAD, you must still commit those changes. The changes will be available in the main repository after they have been pushed to the main repository







6.6.2.3 Using Branches in CVS


CVS lets you define branches, used when development needs to be carried out separately from the main (or trunk) branch of a project. JDeveloper gives you access to CVS branches in your repository through the Tag, Branch and Merge menu.

In CVS, you can create a separate branch when you want to carry out specific work (such as bug fixes or specialized feature development) without any impact to the main set of files, also called the trunk.

Once you have created a branch, you interact with it as normally with CVS -- check out files, commit changes, etc. You can switch back and forth between branches, and you can merge the changes you have made to your branch back into the trunk.

CVS also lets you apply tags to specific branches, or to specific files in a branch (as well as generating a new tag for the branch you create, when you create it).

Branch selection is integrated into a number of CVS functions. You can switch branches or versions for files you are editing or have checked out; you can choose tags, branches, or version dates while updating the contents of your work area, as well as while you are checking out a CVS module.





6.6.2.3.1 Switching the Branch or Version



You can switch the branch or version of a file you are editing, either from the JDeveloper Versioning menu or from the file or project's context menu.

To select a branch, version or date from the Versioning menu:

	
From the Versioning menu, choose Tag, Branch or Merge > Switch Branch or Version.


	
Click the chooser to display a list of branches or versions.


	
Select the branch or version you wish to use.


	
Optionally, click Add Date to specify a date to use.


	
Click OK.




To select a branch, version or date from the project's context menu:




	Choose Team > Switch Branch or Version.
	Click the chooser to display a list of branches or versions.
	Select the branch or version you wish to use.
	Optionally, click Add Date to specify a date to use.
	Click OK.








6.6.2.3.2 How to Choose a Branch while Updating



When you are updating your content to capture the latest revisions to the repository, you have the option of branch (via its associated tag) at the same time.

To select a tag and branch while updating:




	From the project's context menu, choose Update Project Folders.
	In the Update from CVS dialog, check the box marked Use Revision, Tag or Date, then click the chooser icon.
	Select a tag to use.
	Optionally, click Add Date to specify a date to use.
	Check any other boxes (Overwrite Local Changes, Prune Empty Folders, etc.) that you wish to apply to the current update, then click OK.








6.6.2.3.3 Choosing a Branch While Checking Out



As with other CVS operations, tags and branches are integrated into the process of checking out a CVS module.

To choose a branch while checking out:




	Click the right mouse button on the content in the Versions window to bring up the context menu, then choose Check Out Module.
	Check the box labeled Use Revision, Tag or Date, then click the chooser to select a tag.
	Select a tag. Optionally, you can click the Add Date button to specify a date. When you have made your selection, click OK to close the Tags dialog.
	Choose any other options (Force Match, Ignore Child Folders, etc.), then click OK to close the Check Out from CVS dialog.












6.6.3 How to Create Tags


Tags give you another way of identifying content that is logically grouped in some way, typically as a subset of files within a branch (for example, a list of files associated with a particular feature set, or with a particular bug fix). Once you create tags, they can be used in a number of ways, in particular for checking out files from the version control system.





6.6.3.1 Creating Tags in Git



You have the option of creating a new tag when you check out a branch in Git. However, you can also create a tag at any time by using the Create Tag dialog.

To create a tag in Git:




	Select Team > Git > Create Tag. This opens the Create Tag dialog.
	In the Name field, type a descriptive name for the tag you are creating (for example, Version 1.2.3 Beta Release).
	In the Comments field, enter any descriptive notes that can help you identify this content in the future when you are using this tag.
	In the Branch field, enter the branch name or click Select Branch to open the Select Branch dialog, then choose the branch on which you wish to create this tag. When you have made your selection from the Select Branch dialog, click OK to close the dialog and make you selection.
	If you wish to base this tag on content currently associated with another tag, click Select Tag to open the Select Tag dialog.
	Optionally, use a specific commit ID for the source of the tag you are creating. You can either enter the commit ID by hand (or more likely, by copy and paste as the commit ID is a 40-digit hexadecimal number), or click Select Commit to choose one from a list of available IDs.
	When you have entered all the information for this tag, click OK.








6.6.3.2 Creating and Assigning CVS Tags



CVS allows you to create and assign tags to content.

To assign CVS tags:

This procedure will assign symbolic tags to the local CVS revisions of selected files.

	
In the Applications window, select a single file, a project or a workspace. If you select a project or a workspace, all the files within the project or workspace will be selected for tagging.


	
Choose Team > Tag > Tag.


	
Check that you want the operation to apply to all of the files highlighted in the file selection box.


	
Enter a name for the tag in the Tag Name box.


	
Set the other options as required. To obtain descriptions of the options, press F1.


	
Click OK.




To view CVS tags:

This procedure will display a dialog containing information about any existing tags that have been applied to the file revision.

	
From the context menu of the file, choose Team > Properties.


	
Select the Versioning tab. The sticky tag, date and options (if any) are shown, as is a list of existing tags for the file revision.




To reset CVS tags:

This procedure will remove any sticky tags or dates that have been applied to the selected files and reset them to the HEAD revision.




	In the Applications window, select the file or files whose tags you wish to reset.
	Choose Team > Tag > Reset Tags.








6.6.3.3 Deleting CVS Tags



Deleting a tag does not delete the content associated with it, but if you are using tags to identify a specific project that has completed, you can delete the tag to simplify the display when you are choosing tagged content in future.

To delete CVS tags:

This procedure will delete symbolic tags from the local CVS revisions of selected files.




	In the Applications window, select a single file, a project or a workspace. If you select a project or a workspace, the tag will be deleted from all the files within the project or workspace.
	Choose Team > Tag > Delete Tag.
	Check that you want the operation to apply to all of the files highlighted in the file selection box.
	Enter the name of the tag in the Tag Name box.
	Click OK.










6.6.4 How to Use Tags


In Subversion, creating a tag is like creating a branch.





6.6.4.1 Using Tags in Git



You can select from an existing tag in Git and apply it to the file you have selected for the current transaction.

To select a tag in Git:





	
Select Team > Tag. Scroll through the list to find the tag you wish to apply to the selected file.




If there are more than one tags that apply to the file, hold down the Ctrl key, then select each tag that you wish to use.









6.6.4.2 Using Tags in CVS


Tags in CVS are a way of identifying branches, branch-specific content, or other content that you wish to identify and manipulate as a single logical group. You can tag files, folders, or projects. You can then later use these tags to identify branches, update files from a branch with a specific tag, and other operations.

You can select and browse tags from context menus as well as the Team > CVS > Tags menu. The availability of tags differs depending on the context of the operations you are performing on your content.





6.6.4.2.1 Adding a Tag to a Project



You can identify a project by adding a tag to it. You can then operate on this project by selecting the tag from any of the CVS menus that contain the tag chooser.

To add a tag to a project:




	Select the project you want to tag.
	Choose Team > CVS > Tag, Branch and Merge > Tag.
	Type the tag you want to use, or click the chooser icon to browse the existing tags.
	Optional: Choose Use Revision, Tag or Date, then type the tag or click the icon to browse the list.








6.6.4.2.2 Applying Tags While Updating a Project or File



You can choose and apply a tag while using the Update from CVS dialog.

To select an existing branch, version or date from the Projects view:




	From the project's context menu, select Team > Tag.
	Choose Use Revision, Tag or Date.
	Click the tag chooser icon.
	Choose a tag from the list that appears.








6.6.4.2.3 How to Delete a Tag



You can also delete a tag. Deleting a tag removes it from any resources to which you have applied it. Deleting the tag does not delete the content to which the tag was applied; it merely removes it from the list of available tags.

To delete a tag:




	Select Team > Tag, Branch and Merge > Delete Tag.
	Click the chooser icon. Choose the tag you wish to delete, then click OK.



In this context, only existing tag versions (regular non-branch tags) can be selected.













6.6.5 How to Use Properties in Subversion


Subversion lets you define and add properties to various levels of the elements in the Applications window: files, folders, and other resources. You can define these properties and use them as a way of tracking files or folders that have something in common.





6.6.5.1 About Subversion Properties



As an example of using subversion properties, you can associate a specific subversion property with a newly added feature. Viewing all files or folders with this subversion property lets you see all the files associated with this feature: an HTML file, a JavaScript file, a class definition file, or any other elements that are involved in adding this new feature to your application.

When you add or edit subversion properties, the dialog lets you select or specify the following elements:

	Resource file
	
The file (or folder or other resource) to which this property is to be applied. To change this value, select a different file or resource. Note that if you wish to add this property at the application or project folder level, edit the resource file entry so that it refers to the folder, not the file.




	Property name
	
Select a property name from the available list, or enter a new name to create a new Subversion property. Preface the new property name with svn: to be tracked as a Subversion property.




	Value string
	
Enter the string to be displayed with this Subversion property when you view properties. For example, you can associate a specific Subversion property with a particular bug identification number or a specific upcoming release.

Note that the Value String might differ depending on the property. For instance, consider a property named svn:externals meant to record the connection between a local file and its external URL in the SVN repository. This property's value string would be a pair of text strings, respectively showing the local directory where the external file is to be checked out and the URL to the external file in the SVN repository

Assume for this example that the resource file is D:\temp and the property name is svn:externals. The value string (a value pair) might be:

external_libs https://ukp16449.uk.oracle.com/repos/trunk/FOD/StoreFront.jar

This indicates that the file StoreFront.jar held in the Subversion repository at that URL is to be checked out to D:\temp\external_libs. If the Value String entries were held in a specific file pointed to from this property, use the Value File entry.




	Value file
	
If you know you will be adding the same Subversion property to a number of resources in your application, you can save the value string in a text file. Click Browse to select the text file that contains the value string you wish to use.




	Set property recursively
	
Select this if you wish Subversion to apply this property to all files and elements below the current level in the application or project hierarchy.












6.6.5.2 Working with Subversion Properties



If your team has been using Subversion properties for some time, you can use the View Subversion Properties menu to see a list of all elements that use a selected Subversion property. You can also compare the Subversion properties between different versions.

To view a list of Subversion properties:

	
Select an element under Subversion control from the Applications window.


	
Select Team > Subversion > View Subversion Properties.




If your project needs a new property for tracking and managing a particular aspect (such as a new feature or a bug fix), you can also add new properties.

To add a new Subversion property




	Select an element under Subversion control from the Applications window.
	Select Team > Subversion > Add Subversion Property.
	Enter the values for the property, then click OK. Refer to the following section for examples of Subversion properties and how to use them.



When you set an external property with a revision number, make sure you follow the correct format for the value string. You can use either of the following as the value string for a property of type svn:external to set the ExternalWebINF revision to 16, using the JDeveloper integrated Subversion:

ExternalWebINF -r 16 https://myserver.myteam.com/svn/repos/public-html/WEB-INFhttps://myserver.myteam.com/svn/repos/public-html/WEB-INF@16 ExternalWebInf









6.6.5.3 Viewing File and Property Status



Use this procedure to check the content status and any associated property status of a file that is under Subversion source control. You can also refresh the status of a file.

To view the status of a file:




	With the file selected in the Applications window, open the context menu and select Team > Properties.
	Select the Versioning tab.



The status labels shown are those used by Subversion to describe the source control status of content and any associated property.

The main statuses for content are:

	
added - The content has been added to source control but has not yet been committed to the Subversion repository.


	
modified - The property has been locally modified since it was copied from the repository.


	
unmodified (normal) - The property is unmodified since it was last updated from the Subversion repository.


	
conflicted - There were conflicts when the property was updated from the Subversion repository.


	
deleted - The file (content and any associated property) will be removed from the Subversion repository with the next commit action.




The main statuses for associated properties are:

	
modified - The property has been locally modified since it was copied from the repository.


	
unmodified (normal) - The property is unmodified since it was last updated from the Subversion repository.


	
conflicted - There were conflicts when the property was updated from the Subversion repository.












6.6.5.4 Resolving Property Conflicts in Subversion



Subversion allows you to create and save properties associated with folders or files. These properties have a name and a value string.

You can resolve any such conflicts using Subversion's Resolve Tree Conflicts feature.

To resolve Subversion property conflicts:




	In the Applications window, select the element under Subversion control that has a property conflict.
	Click the right mouse button, and then select Team > Subversion > Resolve Conflicts.



This displays the versions with the conflicting properties in two adjacent panes, as with the Version Compare.

To resolve the conflict, you can make changes in the Subversion Properties window.













6.7 Working with File History, Status and Revisions


One of the most useful parts of working with version control is the ability it gives you to look at the history of a file and compare changes made to different revisions. In debugging, you can look through the file history to find a version just prior to the introduction of a defect, which can help you identify where the problem occurred. If you and another team member make conflicting changes to a file or a set of files, you can go back to versions of the file from before the changes were made.





6.7.1 File History



You can refer to the history of a file in your repository to review changes made to it over the life of the project.

To help you understand the sequence of changes made to a specific Subversion file, you can use the History Viewer and view the history of Subversion files.

To view the history of a file:





	
With the file selected in the Applications window, choose Team > Version History from the context menu.

For more information while using the History Viewer, press F1 or click Help.










6.7.1.1 Refreshing the Status of Files Under Subversion Control



The source control status of a file is indicated in the JDeveloper navigators (Applications window and Teams window) by icon overlays, as below.

If the status of a file is changed outside JDeveloper, for example by using a Subversion client application, the new status might not immediately be shown in JDeveloper. To ensure that the status indicated in the Applications window matches the true status of the file in the source control system, you can perform a manual refresh.

To refresh the status of files in JDeveloper:





	
Select View > Refresh.














6.7.2 Replacing a File with the Subversion Base Revision



Use this procedure to replace a file with the base revision. The base revision is the revision from which the one you are currently working on originated.

To replace a file with the Subversion base revision:




	In the Applications window, select the file to be replaced.
	Choose File > Replace With Base Revision. The Replace With Base Revision dialog opens. Check that the file that you want to replace is shown in the dialog.
	To replace the file, click OK.








6.7.3 How to Undo or Revert Changes


Undo changes, revert to previous versions, selecting specific revisions: these are all commonly used phrases to describe the process of canceling changes you have decided not to check in to the repository.





6.7.3.1 Reverting Files to their Previous State in Subversion



Use the Revert command to:





	
Undo changes that you have made locally to the contents of a file.


	
Change the status of a file that has been added, but not yet committed, back to unadded.


	
Stop a file that is scheduled for removal (in the Pending Changes window) from being removed from the Subversion repository.




To revert a file:




	Select the file in the Applications window or Pending Changes window and choose Team > Revert.

The Revert Local Changes dialog is displayed with the file or files listed.

For help while using the dialog, press F1 or click Help.




	To revert the listed file or files, click OK.








6.7.3.2 Reverting Changes to Files in Git



You can revert changes made to a file that you have committed to a Git repository to return it to a previous state.

To revert changes:




	Select Team > Git > Revert. This displays a list of files that you can revert to a previous version, with the path in your local file system at which the file resides.
	Select the file you wish to revert, then click OK.








6.7.3.3 Working with Revisions and Tags in CVS



CVS lets you select specific revisions from the CVS repository, if you find it necessary to begin or resume working with a previous version of the file you are currently working on.

To open a CVS file revision:

This procedure will obtain a revision of a file from the CVS repository so that you can view it or save it locally.




	With the file selected in the Applications window, choose Team > Open Revision.
	Set the options on the dialog as required. To obtain descriptions of the options, press F1 or click Help.
	Click OK.










6.7.4 How to Merge Changes from Different Files


Many version control systems offer ways to let you merge changes from different files, ending up with a single version which contains edits from multiple team members. To begin, you will need to compare different versions of the file, then follow the procedures for selecting and merging changes.





6.7.4.1 Comparing Files in Subversion



Use these procedures to compare files that are under Subversion control with other revisions of the same files, or with other files.

To compare revisions of a file:

	
From the context menu for the file, choose Compare With.


	
Select either Previous Revision, Latest Revision, or Other Revision.

If there are no differences, a message is displayed. Otherwise the revision or revisions are shown in the Compare panel of the History tool.




To compare a file with another file:

	
From the context menu for the file, choose Compare With > Other File.

The Select File to Compare With dialog is opened.


	
Select the file to be compared.

The files are shown in the Compare panel of the History tool.




To compare two files:




	Select the two files in the Applications window.
	From the context menu for one of the files, choose Compare With > Each Other.

The files are shown in the Compare panel of the History tool.







You can hide (and later expose) the Compare panel of the History tool to view other panels in JDeveloper.









6.7.4.2 Resolving Conflicts in File Versions



If there is a conflict between your copy of the file and the one in the Subversion repository, the icon next to the affected file will include an exclamation point. You will not be able to submit such a file to the Subversion repository. To overcome this problem, you should do one of the following:





	
Revert to a non-conflicting version of the file.


	
Resolve the conflict using the JDeveloper merge tool.


	
Indicate to the Subversion control system that the conflict has been resolved (Team > Mark Resolved), even if no changes have been made (usually necessary only for binary files).




Another reason you might need to do this is if you have resolved the conflict yourself in the file, rather than using the merge tool. This might be the case if you have chosen to merge files at the server rather than the more usual solution of merging files locally.

To revert to a non-conflicting file version:

	
Select the file in the Applications window and choose Team > Revert.




To resolve the conflicts using the merge tool:




	Select the file in the Applications window and choose Team > Resolve Conflicts.

The file is opened with the Merge tab displayed, showing the merge tool.




	Use the merge tool to resolve the conflicts.

For help while using the merge tool, press F1 or click Help.







To indicate that the conflict has been resolved, even if no changes have been made:

	
Select the file (usually a file with binary content) in the Applications window and choose Team > Mark Resolved.












6.7.4.3 Using the Merge Tool to Resolve Conflicts



Use this procedure to merge two revisions of a file, where the revisions contain conflicting content. Conflicts are notified in the Pending Changes window: the outgoing status is "conflicts" or "conflicts on merge", and the Resolve Conflicts button is active.

To merge two revisions with conflicting content:




	On the Outgoing tab of the Pending Changes window, select the revision that has conflicts and click the Resolve Conflicts button. (You can also select the revision in the Applications window.)
	The merge tool is opened (as the Merge tab of the file editor).

For help while using the merge tool, press F1 or click Help.

The merge tool has three panels. The left panel contains the content of the version in the repository. The right panel contains the content of the most recent local version. The center panel contains the results of the merge. In the margins between the panels are symbols representing suggested actions to resolve each conflict.




	View the suggested actions for resolving the conflicts by reading the tooltip of the margin symbols.

More suggested actions may be available from the context menus of the margin symbols.




	Resolve the conflicts by implementing a suggested action in each case.

Accepting an initial suggested action may cause the appearance of additional suggested actions.

You can also make changes to the content of the center panel by typing into it.




	To complete the merge, save the changes that have been made by clicking on the Save Changes button on the merge tool (not the JDeveloper Save option).








6.7.4.4 Using the Subversion Merge Wizard


The Merge Wizard is instrumental to the way that JDeveloper supports Subversion merge tracking. Merge tracking in Subversion means in essence that Subversion remembers your merges so you don't have to. The Merge Wizard provides you with an easy way of selecting which components you wish to merge, such as specific revisions, branches, or change sets.

The Merge Wizard gives you a number of options:

	Merge Selected Revision Range
	
Select this when merging a range of revisions to another branch, for example, when you are back-porting a group of bug fixes to the release branch.




	Reintegrate a branch
	
Normally used when merging the changes on a branch back to the trunk, for example, if you completed the work on a feature branch and want to reintegrate the changes back to trunk.




	Merge two different trees
	
Select this to merge the differences between two branches into the working copy.




	Block specific revisions from being merged
	
Select this if you know that specific revisions are not yet ready, or not appropriate, to be merged into the trunk.












6.7.5 Working with File Versions and History in CVS


CVS gives you techniques that allow you to merge, compare, replace, and view different versions of the files in your repository.





6.7.5.1 Merging Files in CVS



Use this procedure to merge two revisions of a file, where the revisions contain conflicting content. Conflicts are notified in the Pending Changes window: the outgoing status is "conflicts" or "conflicts on merge", and the Resolve Conflicts button is active.

To merge two revisions with conflicting content:




	On the Outgoing tab of the Pending Changes window, select the revision that has conflicts and click the Resolve Conflicts button.
	The merge tool is opened (as the Merge tab of the file editor).

For help while using the merge tool, press F1.

The merge tool has three panels. The left panel contains the content of the version in the repository. The right panel contains the content of the most recent local version. The center panel contains the results of the merge. In the margins between the panels are symbols representing suggested actions to resolve each conflict.




	View the suggested actions for resolving the conflicts by reading the tooltip of the margin symbols.

More suggested actions may be available from the context menus of the margin symbols.




	Resolve the conflicts by implementing a suggested action in each case.

Accepting an initial suggested action may cause the appearance of additional suggested actions.

You can also make changes to the content of the center panel by typing into it.




	To complete the merge, save the changes that have been made, using the Save button.








6.7.5.2 Comparing Files in CVS



Use these procedures to compare revisions of files that are under CVS source control. You can compare a file with its immediate predecessor, or you can compare with any of the file's previous revisions.

To compare a file shown in the Applications window:




	From the context menu for the file, choose Compare With.
	Select either Previous Revision, Head Revision or Other Revision.
	If you are comparing with previous revisions, these are listed in the Compare CVS File dialog: Select the file that you want to compare with.

If there are no differences, a message is displayed. Otherwise the Compare tool is displayed.







To compare a file shown in the Pending Changes window:

You can compare a file in the Pending Changes window either with a previous revision or with the HEAD revision, depending on which mode the window is in. To obtain more information when using the Pending Changes window, press F1.

	
With the window in Outgoing Changes mode, select the file to be compared, then select the Compare with Previous Revision button.


	
With the window in Incoming Changes mode, select the file to be compared, then select the Compare with Head Revision button.




If there are no differences, a message is displayed. Otherwise the Compare tool is displayed.









6.7.5.3 Replacing a File with a CVS Revision



Use this procedure to replace a file with the base or head revision, or with a file with a specific revision number or tag. The head revision is the latest one. The base revision is the revision from which the one you are currently working on originated.

To replace a file with a CVS revision:




	In the Applications window, select the file to be replaced.
	Do one of the following:

	
To replace with the base revision, choose File > Replace With > Base Revision. The Replace With Base Revision dialog opens.


	
To replace with a specific revision number or tag, choose File > Replace With > Tagged Revision. The Replace With Tagged Revision dialog opens.


	
To replace with the head revision, choose File > Replace With > Head Revision. The Replace With Head Revision dialog opens.







	Check that the file that you want to replace is shown in the dialog.
	When replacing with a specific revision number or tag, enter the revision number or tag into the text box on the dialog.
	To replace the file, click OK.








6.7.5.4 Viewing the History and Status of a File in CVS



The history and status of a file will tell you what has been done to it, and what has been done to it last. This can help you make the determination of what you need to do to bring the file up to date, or to begin making your own modifications.

Use this procedure to open the History Viewer and view the history of CVS files.

To view the history of a project or file:





	
With the project or file selected in the Applications window, choose Team > Version History from the context menu.

For more information while using the History Viewer, press F1.




Use this procedure to check the status of a file that is under CVS source control. You can also refresh the status of files under CVS control.

To view the status of a file:




	With the file selected in the Applications window, open the context menu and select Team > Properties.
	Select the Versioning tab. The status of the file is the first item on the tab.



Possible statuses are:

	
Changed locally - the file has been locally modified since it was copied from the repository.


	
Changed in repository - the file has been modified by another user since it was copied from the repository.


	
Locally removed - the file will be removed during the next commit.


	
Locally added - the file will be added during the next commit.


	
Up-to-date - the file is up-to-date with the latest CVS repository revision.


	
File has conflicts - these may have resulted from a file update or commit action. If necessary, consult your CVS administrator for assistance.


	
Needs merge or needs patch - the file has been updated externally, for example, by another user.


	
Modified - the file previously had merge conflicts, but the timestamp has changed since.














6.7.6 Working with File Versions in Perforce



Perforce provides tools for resolving conflicts in file versions.

If there is a conflict between your copy of the file and the one in the Perforce depot, the icon next to the affected file will include an exclamation point. You will not be able to submit such a file to the Perforce depot. To overcome this problem, you should either revert to a non-conflicting version of the file, or resolve the conflict.

To revert to a non-conflicting file version:





	
Select the file in the Applications window and choose Team > Revert.




To resolve conflicting file versions (assumes use of Perforce merge tool):




	Open the Perforce client by choosing Team > Resolve.
	In the pending changelists for the client, identify the change.
	Resolve the conflict using the Perforce tools.

If you cannot automerge the conflicts, run the merge tool and use its facilities to create a definitive version from the conflicting data.




	Accept the merge.
	Submit the merge.
	In JDeveloper, use View > Refresh to obtain the green dot on the file.

The file will still be marked as open for edit.




	Submit the file.








6.7.7 Working with File Versions in Team System


Team System provides tools for working with file versions, including viewing, comparing, and resolving conflicts among different files in the repository.





6.7.7.1 Resolving Conflicts in Team System File Versions



If there is a conflict between your copy of the file and the one in the Team System server when you attempt to check it in, you will see a message box saying that the operation cannot be completed. To overcome this problem, you must first cancel the check-in operation, then do one of the following:





	
Revert to a non-conflicting version of the file.


	
Resolve the conflict using the merge tool in the Team System client software.




To revert to a non-conflicting file version:

	
Select the file in the Applications window and choose Team > Undo.












6.7.7.2 Undoing Changes to Team System Files



Use to undo the most recent change to a file.

To undo changes:




	In the Applications window, select the file whose last change you want to undo.
	Select Team > Undo.

The Undo dialog is opened.

The change will be undone when you click OK.












6.7.7.3 Replacing a File with the Team System Base Version



Use this procedure to replace a file with the base version. The base version is the version from which the one you are currently working on originated.

To replace a file with the Team System base revision:




	In the Applications window, select the file to be replaced.
	Choose File > Replace With > Base Version.

The Replace With Base Version dialog opens.




	Check that the file that you want to replace is shown in the dialog.
	To replace the file, click OK.








6.7.7.4 Viewing the History of a File



Use this procedure to open the History Viewer and view the history of files held under Team System control.

To view the history of a file:





	
With the file selected in the Applications window, choose Team > Version History from the context menu.




For more information while using the History Viewer, press F1.









6.7.7.5 Comparing Files In Team System



Use these procedures to compare files that are under Team System control with other versions of the same files, or with other files.

To compare versions of a file:

	
From the context menu for the file, choose Compare With.


	
Select either Previous Version, Latest Version or Other Version.




If there are no differences, a message is displayed. Otherwise the version or versions are shown in the History tool.

To compare a file with another file:

	
From the context menu for the file, choose Compare With > Other File.

The Select File to Compare With dialog is opened.


	
Select the file to be compared.

The files are shown in the Compare tool.




To compare two files:




	Select the two files in the Applications window.
	From the context menu for one of the files, choose Compare With > Each Other.



The files are shown in the Compare tool.











6.7.8 Using an External Diff Tool with CVS



JDeveloper has an integrated compare viewer that works well for most circumstances. However, you may prefer to use another compare tool or the simple output from CVS DIFF. JDeveloper lets you integrate third party tools and applications. This procedure describes how to use the External Tools support in JDeveloper to integrate external compare viewers.

To integrate CVS DIFF:




	In JDeveloper, select Tools > External Tools.
	Click Add. This opens the Create External Tool wizard.
	On the External Program Options page, enter the following information:

	Program Executable
	The location of your CVS installation (for example c:\cvsnt\cvs.exe) or just cvs
	Arguments
	-d ${cvs.root} diff ${file.name}
	Alternate arguments
	-d ${cvs.root} diff -r ${cvs.revision} -r ${cvs.second.revision} ${file.name}
	Run Directory
	${file.dir}
	Enter the alternate arguments if you want to integrate a tool that compares two specific CVS revisions when the history tool is visible.





	On the Display page, enter a caption for the diff tool (for example CVS Diff with Repository) in the Caption for Menu Items box.
	On the Integration page, choose how you want the diff tool to be integrated into JDeveloper. For example, select the Tools Menu, Navigator Context Menu, and Code Editor Context Menu items.
	On the Availability page, select When a File is Selected or Open in the Editor.
	Click Finish.








6.7.9 Integrating a Third Party Diff Utility


You can use external tools macros to view differences between two revisions in the history tool using a third party utility such as Araxis Merge. The following steps will install a menu item to invoke Araxis Merge. For other utilities, consult the documentation of the utility to determine which command line arguments need to be passed in.

To integrate a third party diff utility:

	
In JDeveloper, select Tools > External Tools.


	
Click Add. This opens the Create External Tool wizard.


	
On the External Program Options page, enter the following information:

	Program Executable The path to the third party tool (for example c:\araxismerge\compare.exe)
	Arguments
	/wait /title1:"${file.name} revision ${cvs.revision}" /title2:"${file.name} revision ${cvs.second.revision}" /2 ${cvs.revision.file} ${cvs.second.revision.file}



	
On the Display page, enter a caption for the third party tool (for example Araxis Diff) in the Caption for Menu Items box.


	
Complete the remainder of the wizard as required. For help when using the wizard, press F1 or click Help.


	
Click Finish.










6.7.10 Integrating other CVS Commands



You can take advantage of the supplied external tool macros to easily integrate other CVS commands into JDeveloper. An example is the CVS annotate command (sometimes referred to as “blame"), which shows a summary of who changed each line of code and when the change was made. To integrate a tool for CVS annotate, set the following options in a new tool.

To integrate other commands




	In JDeveloper, select Tools > External Tools.
	Click Add. This opens the Create External Tool wizard.
	On the External Program Options page, enter the following information:

	Program Executable
	The path to the CVS executable (for example, C:\cvs\cvs.exe)
	Arguments
	-d ${cvs.root} annotate ${file.name}
	Run Directory
	${file.dir}





	Complete the remainder of the wizard as required. For help when using the wizard, press F1 or click Help.
	Click Finish.










6.8 Working with Patches in Source Control



Many of the version control systems available in JDeveloper provide features for creating and applying patches—methods for determining changes between two revisions of a file, and then applying those changes to a third file. In addition, Subversion contains features for exporting the details about repository connections, as well as files in the repository.

Subversion (included in JDeveloper) uses the following procedures for creating and applying patches. In addition, the version control extensions for Concurrent Version System (CVS), Perforce and Team System all use the same steps for creating and applying patches.

To create a patch:

This generates a patch comprising the differences between a controlled revision of a file and a revision of the file held locally.

	
In JDeveloper, open the file for which you want to create a patch.


	
Click the History tab.

The History view lists all the revisions of the file. In the lower portion of the History view, the left pane shows the contents of a local revision, and the right pane shows the contents of the controlled revision.


	
Select the revision combination for which you want to create a patch.


	
From the context menu, choose Generate Patch.

The Select Patch Context dialog may open. For help while using this dialog, press F1 or click Help.

The Generate Patch dialog opens. Complete the dialog as required. For help while using the dialog, press F1 or click Help.




To apply a patch:




	In the Applications window, select the resource to which you want to apply a patch.

The resource can be an application, a project, or a source file.




	Select Team > Apply Patch.

If you chose to apply a patch to a project, the Select Patch Context dialog opens, through which you should specify whether you are applying a project file (.jpr) patch, or whether you are updating the contents of a project.

The Apply Patch dialog is opened.




	In the grid at the top of the Apply Patch dialog, check that the target resources are correctly identified.
	Choose the source of the patch. For more information about this and the other options on the dialog, press F1 or click Help.
	Click Preview. This opens the Apply Patch Preview window, in which you can accept or reject particular changes. For more information about the options in the Apply Patch Preview window, press F1 or click Help.
	To apply the patch, click OK.






6.8.1 How to Create and Apply Patches


JDeveloper provides features for creating and applying patches—methods for determining changes between two revisions of a file, and then applying those changes to a third file. You can typically save these patches either as a separate file, or as a section of text to be copy-and-pasted into the target file.





6.8.1.1 Creating Patches



You may wish to record the changes between two revisions of a file, then apply those changes to a third file. You do this by creating a patch and then applying it.

To create a patch:

This generates a patch comprising the differences between a controlled revision of a file and a revision of the file held locally.




	In JDeveloper, open the file for which you want to create a patch.
	Click the History tab.

The History view lists all the revisions of the file. In the lower portion of the History view, the left pane shows the contents of a local revision, and the right pane shows the contents of the controlled revision.




	Select the revision combination for which you want to create a patch.
	From the context menu, choose Generate Patch.

The Select Patch Context dialog may open. For help while using this dialog, press F1 or click Help.

The Generate Patch dialog opens. Complete the dialog as required. For help while using the dialog, press F1 or click Help.












6.8.1.2 Applying Patches



Once you have created a patch, you apply it from the Team menu.

To apply a patch:




	In the navigator, select the resource to which you want to apply a patch.

The resource can be an application, a project, or a source file.




	Select Team > Apply Patch.

If you chose to apply a patch to a project, the Select Patch Context dialog opens, through which you should specify whether you are applying a project file (.jpr) patch, or whether you are updating the contents of a project.

The Apply Patch dialog is opened.




	In the grid at the top of the Apply Patch dialog, check that the target resources are correctly identified.
	Choose the source of the patch. For more information about this and the other options on the dialog, press F1 or click Help.
	Click Preview. This opens the Apply Patch Preview window, in which you can accept or reject particular changes. For more information about the options in the Apply Patch Preview window, press F1 or click Help.
	To apply the patch, click OK.















13 Implementing Java Swing User Interfaces


This chapter describes how to create graphical user interfaces (GUIs) for applications using the Swing components.

Using the Swing GUI builder in JDeveloper, you can quickly and easily assemble the elements of a user interface (UI) for a Java application using Swing components. You construct the UI with components selected from the Components window, such as buttons, text areas, lists, dialogs, and menus. Then, you set the values of the component properties and attach event-handler code to the component events.

Included is a description of the UI debugger, which is used to debug user interfaces specifically for AWT and Swing-based client applications. The UI Debugger offers an alternative way of debugging a GUI application.

This chapter includes the following sections:

	
About Java Swing UI Components and Containers


	
Designing Java GUIs


	
How to Create a Form


	
Understanding the Forms You Can Create


	
Working with Layout Managers


	
Adding Components


	
Working with Containers


	
Working with Layout Managers


	
How to Create Accessible Forms


	
Working with Event Handling


	
How to Modify GUI Source Code


	
Working with the UI Debugger








13.1 About Applications Developed in Earlier Versions


Applications which use Swing which were developed in earlier versions of JDeveloper can be migrated and opened in this version of JDeveloper, and there is full support for working with previously designed visual classes. The legacy editor works with any class that has a jbInit() method.

You can visually edit forms in the old application using the old Java Visual Editor, however the way it worked and the way the new Swing GUI builder works are different, and there is no migration from one to another.







13.2 About Java Swing UI Components and Containers


Java Swing components include everything from buttons, tables, text components, and split panes. For example, the JCheckbox component is a square box used to display boolean (true/false) values. Many components are capable of sorting, printing, and drag and drop, as well as other supported features.

You can see examples of Java Swing in the tutorials, which are available at http://docs.oracle.com/javase/tutorial/uiswing/.

When you lay out a form to design the UI in JDeveloper, you use a container. Containers are also components. They hold and manage other components. You interact with them by getting and setting their properties, calling their methods, and responding to their events as with any other component. JDeveloper provides tools to help you generate your containers. See Working with Containers for more information.

A layout manager automatically arranges the components in a container according to a particular set of rules specific to that layout manager. It determines the size and position of the components within a container. For example, the BorderLayout arranges a container's components in areas named First, Last, Before, After, Center.


Figure 13-1 BorderLayout
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13.3 Designing Java GUIs


The IDE's GUI Builder enables you to design GUI's (graphical user interfaces) visually. As you create and modify your GUI, the IDE automatically generates the Java code to implement the interface.

Whenever you open a GUI form, the IDE displays it with tabs enabling you to switch between Source and Design views. The Design view enables you to work with GUI forms visually while the Source view permits editing of the form's source code directly.

Typically, you add components to a form using the Components window and arrange them in the GUI Builder workspace. As you work, the GUI Builder automatically displays guidelines suggesting preferred alignment and anchoring for the components you add. Using the Properties window in conjunction with the Structure window, you can then examine and adjust properties of a form's components and layout managers, manage component event handlers, and define how code is generated.


Notes:





	
GroupLayout was added to version 6 of the Java Platform. You can set the version of GroupLayout in the property sheet for each form.


	
To use the GUI Builder, you must work with files that were created with the IDE's GUI form templates. You cannot use the GUI Builder to edit GUI forms (that is Java files) that were created outside of the IDE.










13.3.1 About Guarded Blocks


As you work with a form in the Design view, code is generated automatically by the GUI Builder and is displayed in the Source view with a grey background. This code is called guarded code and is not directly editable.


Note:

You can freely edit all the code that is not guarded. For example, you can write code for initialization or customization of the UI (in the constructor just after the initComponents() call).

All the components have assigned fields so they can be accessed from anywhere in the Java class.



Guarded text generated by the GUI Builder's includes:

	
Blocks of components' variable declarations.


	
The initComponents() method, in which form initialization is performed. This method is called from the form's constructor and though it is not editable manually, you can affect the way it is generated by editing the Code properties in the component's property sheet.


	
The header (and trailing brace) of all event handlers.












13.4 How to Create a Form



You can create forms within an existing project.

To create a new form:




	In the Applications window, select the project where you want to create the form.
	From the main menu, select New > From Gallery > Client Tier > Swing/AWT.
	Select the type of form you want to create.
	Complete the wizard and click OK.
	Scroll to the source file for the form in the Applications window, for example, NewPanel.java.
	Double-click the source file.

The GUI builder displays where you can edit the form.












13.5 Understanding the Forms You Can Create



The following table contains the forms you can build in JDeveloper.







	Form	Description
	
JPanel Form

	
Creates a new Swing panel. Panels are frequently used to group together several other components into one place. A JPanel itself can be used as a component within a JFrame or JDialog.


	
JFrame Form

	
Creates a new Swing frame. Frames are typically used as stand-alone top level windows as the main user interface to the application. Most Swing applications are built starting from this form.


	
JDialog Form

	
Creates a new Swing dialog. Dialogs are modal or modeless windows that are typically used to prompt users for input.


	
JInternalFrame Form

	
Creates a new Swing internal frame that can be placed into a JDesktopPane to provide an MDI user interface.


	
Bean Form

	
Creates a new form based on any JavaBeans component (either visual or non-visual). You must specify the bean class in the wizard.


	
Panel Form

	
Creates a new AWT (Abstract Window Toolkit) panel. Panels are frequently used to group together several other components into one place.

AWT is the toolkit used in previous versions of JDeveloper. Swing is preferred now.


	
Frame Form

	
Creates a new AWT form. Frames are typically used as stand-alone top level windows as the main user interface to the application.


	
Dialog Form

	
Creates a new AWT dialog. Dialogs are modal or modeless windows that are typically used to prompt users for input













13.6 Adding Components



Once you have created a new form, you can add components for display and control. You can add components a few different ways:

To add a component from the Components window:

	
Select a component in the Components window by clicking its icon.


	
Without releasing the mouse button, drag the component to the desired location in the form.


	
If you want to add a non-visual component, or a visual component, out of the visual hierarchy of the designed container, place it in the white area around the form. It will then appear under the Other Components node in the Structure window.




To add multiple components from the Components window:

	
Select a component in the Components window by clicking its icon. Release the mouse button.


	
While holding down the shift key, click each location in the form where you want to place an instance of the component you selected in the palette.


	
Release the shift key when adding the last component, or press Esc or right click to cancel adding.


	
If you want to add a non-visual component, or a visual component but out of the visual hierarchy of the designed container, place it in the white area around the form. It will then appear under the Other Components node in the Structure window.




To add a component using the context menu:




	In the Structure window, right-click the container to which you want to add a component.
	Choose Add From Components and then choose desired component from the appropriate submenu:

	
Containers


	
Controls


	
Menus


	
Windows


	
Box Fillers


	
AWT


	
Beans













13.6.1 How to Set Component Properties



Once you have added a component to a form, you can adjust its behavior and appearance in the Properties window.

To edit a component's properties:




	Select the component in the GUI Builder or Structure window to display its properties in the Properties window. Note that if you select multiple components, their common properties are displayed and any modifications apply to all of the selected components.
	Edit the component's properties in the Properties window by selecting the property and entering the desired value.
	If the property you want to edit has an ellipsis (...) button, you can click it to open a special property editor that provides more advanced editing options (e.g. a color chooser for a color-type property), or alternate ways of specifying the property value (e.g. using a resource bundle for a text property), including a possibility to type directly the code that should represent the property value.

Use this to edit a given property in another way than in the small in-place editor in the properties window. You can also choose from several ways how to enter the property value via the combo box at the top.












13.6.2 How to Select Components in Your User Interface



Before attempting to select an existing component in your UI, be sure the selection arrow in the GUI builder toolbar is depressed. Otherwise, you may accidentally place a component on your UI.







13.6.2.1 How to Select a Single Components



To select a single component, do one of the following:





	
Click the component in the GUI Builder.


	
With focus on the GUI Builder, tab to the component (Tab = forward; Shift+Tab = backward).


	
Select the component in the Structure window












13.6.2.2 How to Select Multiple Components



To select multiple components, hold down the Ctrl key and do one of the following:





	
Hold down the Ctrl key and click the components in the GUI builder or in the Structure window to add/remove components from selection one by one.


	
Click and drag around the outside of the components you want to select. As you drag, you surround the components with a rectangle, or "lasso." When this rectangle encloses all the components you want to select, release the mouse button. If necessary, you can then use Ctrl+click to individually add or remove components from the selected group.

If you need to drag for selection inside a sub-container, you would normally drag the sub-container away. To prevent that, press and hold Shift during dragging.


	
Hold down shift holding Shift and click components in the Structure window to perform an interval selection. On design canvas clicking with Shift adds to selection one by one, but does not remove from selection.














13.6.3 How to Align Components



Once you have added components, you can adjust their alignment them to ensure that your form will appear as desired at runtime.

Most of the time, you can achieve the desired alignments by "snapping" components at the suggested positions when dragging. Then you can further adjust the alignment using alignment actions from the toolbar or context menu.


Note:

This applies only to Free Design (the default layout mode), not to other layout managers.



To align components:




	Select the components you want to align in the GUI Builder.
	Click the appropriate align button in the GUI Builder toolbar.

Alternately, you can right-click either component and choose Align > Left in Column (or Align > Right in Column) from the pop-up menu.

The IDE shifts the component positions so that the specified edges are aligned and the component anchoring relationships are updated.












13.6.4 How to Size Components



It is often beneficial to set several related components, such as buttons in modal dialogs to be the same size so they can be easily recognized as offering similar functionality. You can also adjust the resizing behavior of components to ensure that component relationships are maintained at runtime.

The Free Design mode allows you to size components using mouse any way you need. Do this with consideration, though. Resizing a component from its default size to a fixed size leads to setting the component with a hardcoded size in pixels that may go against the cross-platform layout principles. Typically you do not want to resize buttons or labels, their size should only be defined by their text. It is usually fine to resize components with no fixed content that are set to "Auto Resizing" because they can still accommodate their size in runtime (for example, text fields).

When working with null, AbsoluteLayout, or GridBagLayout, you can size components when you first place them in your UI, or you can resize and move components later.


Note:

This applies only to Free Design (the default layout mode), not to other layout managers.



To set components to the same size:

	
Select all of the components you want to be the same size in the GUI Builder.


	
Right-click any one of components, and choose Same Size > Set Width (or Same Size > Set Height) from the context menu.




To set component resizing behavior:




	Select the components whose auto resizing behavior you want to set.
	Right-click any one of the components and choose Auto Resizing > Horizontal (or Auto Resizing > Vertical) from the context menu.

Alternatively, use the toolbar buttons.

Component auto-resizing behavior is set to resize horizontally at runtime. The alignment guidelines and anchoring indicators are updated to indicate the new component relationships.














13.7 Working with Containers



Java GUIs are forms comprised of top-level containers within which are grouped sub-containers as well as the various components used to provide the desired information and control functionality.

It is often useful to focus work on single subcontainers rather than the entire form the GUI Builder generally displays. When working with large forms containing complex nested hierarchies of containers, changing the scope of the GUI Builder's focus enables you to concentrate on specific parts of your interface.

To change the GUI Builder's focus to a specific container:

	
In the GUI Builder or Structure window, right-click the container you want to edit.


	
Choose Design This Container from the contextual menu.

The IDE adjusts display of the workspace such that the current container fills the work area and hides the form's other components. The form's entire hierarchy remains available in the Structure window.




To return the GUI Builder's display focus to the entire form:




	Right-click the container in the GUI Builder.
	Choose Design Parent > [Top Parent] from the contextual menu.

The IDE adjusts the work area display such that the entire form is visible. If the Design Parent menu item is dimmed, you are already designing the entire form.










13.7.1 Reordering Components Within a Container


The order of components in a container follows the sequence in which components are added. If the layout manager you have chosen for a container does not use constraints (FlowLayout, BoxLayout, and GridLayout), the order of components also determines how they are arranged visually. You can, however, reorder the components using the Structure window or by dragging them in the form itself.

With layout managers that use constraints (BorderLayout, GridBagLayout, CardLayout, AbsoluteLayout, and Null Layout), the order of components in the container does not determine the order in which the components appear. For these containers, you can only rearrange the component order in the Structure window. Although GridBagLayout uses constraints to determine how components are arranged, component order determines the layout when the Grid X and Grid Y constraints are not used.









13.8 Working with Layout Managers


A Java program can be deployed on more than one platform. If you use standard UI design techniques of specifying absolute positions and sizes for your UI components, your UI might not look good on all platforms. For this reason, you should not use AbsoluteLayout and null layout in production UI. These are not suitable for cross-platform UI, should be used only for prototyping or with awareness of their restrictions.What looks fine on your development system might be unusable on another platform. To solve this problem, Java provides a system of portable layout managers. Layout managers allow you to specify rules and constraints for the layout of your UI in a way that will be portable.

Layout managers enable you to control the way in which visual components are arranged in GUI forms by determining the size and position of components within containers. This is accomplished by implementing the LayoutManager interface.

Use JDeveloper's layout managers to control how components are located and sized in the container each time it is displayed. A layout manager automatically arranges the components in a container according to a particular set of rules specific to that layout manager.

Layout managers give you the following advantages:

	
Correctly positioned components that are independent of fonts, screen resolutions, and platform differences.


	
Intelligent component placement for containers that are dynamically resized at runtime.


	
Ease of translation with different sized strings. If a string increases in size, the components stay properly aligned.




The layout manager sets the sizes and locations of the components based on various factors such as:

	
Layout manager's layout rules


	
Layout manager's property settings, if any


	
Certain properties common to all components, such as preferredSize, minimumSize, maximumSize, alignmentX, and alignmentY


	
Size of the container




Normally, when coding your UI manually, you override the default layout manager before adding components to the container. To change a layout manager on the container, right click it in the designer area or in the Structure window, go to Set Layout menu and select the desired layout manager. For more information, see How to Set the Layout Manager.

When using the GUI builder (or visual editor), you can change the layout whenever you like. JDeveloper will adjust the code as needed.


Note:

If you want to change the properties for a layout manager using the GUI builder, you must explicitly specify a layout for a container so its properties will be accessible in the Properties window.



Choose a layout manager based on the overall design you want for the container. Some layouts can be difficult to work with in the GUI builder because they immediately take over placement and resizing of a component as soon as you add it to the container. To alleviate this problem during initial layout prototyping, JDeveloper provides a layout called null, which leaves the components exactly where you place them and at the size you specify. Starting with null makes prototyping easier in your container. Later, after adding components to the container, you can switch to an appropriate portable layout for your design.

If you cannot get what you need with the Free Design mode, experiment with different layouts to see their effect on the container's components. For example, a viable alternative of an complex layout is the GridBagLayout. For more information, see How to Use the GridBag Customizer. If you find the layout manager you've chosen doesn't give you the results you want, try a different one, or try nesting multiple panels with different layouts to get the desired effect.





13.8.1 How to Set the Layout Manager



When you create a new container, it is generally created using a default layout so that you can take advantage of the IDE's Free Design features. If necessary, you can change the layout of most containers using the GUI Builder or the Structure window.

To set the layout manager from the GUI Builder:

	
Right-click the container whose layout you wish to change.


	
Select Set Layout and a layout menu




To set the layout manager from the Structure window:




	Right-click the node for the container whose layout you wish to change.
	In the contextual menu, choose the desired layout from the Set Layout submenu.



When you change layouts, the IDE remembers the properties of the discarded layout manager. If you then revert back the to the previous layout manager, the form also returns to its prior state.









13.8.2 Understanding FreeDesign Layout


FreeDesign lays out your form using visual guidelines that automatically suggest optimal alignment and spacing. As you work, the GUI Builder translates your design decisions into a functional UI without requiring you to specify a layout manager. Because Free Design employs a dynamic layout model, whenever you resize the form or switch locales, the GUI adjusts to accommodate your changes without changing the relationships between components.

	
You can combine FreeDesign containers and containers using other layout managers together in the same form. Free Design enables you to lay out your form using visual guidelines that automatically suggest optimal alignment and spacing of components.










13.8.3 How to Set Layout Properties



You can modify the appearance of your forms by adjusting general layout manager properties as well as properties specific to components.

You can modify:





	
General layout properties which affect all components in a container, such as alignment of components and gaps between the components.


	
Layout properties specific to a component that is managed by a particular layout manager and which apply to that component alone. These type of properties are also known as constraints.




To set general layout manager properties:

	
Select the layout manager's node in the Structure window.


	
In the Properties window, select the property you want to edit and enter the desired value. Note that the properties vary depending on the layout manager and that some layout managers do not have any properties.




To set layout properties of components:




	Select the component in the Structure window.
	In the Properties window, scroll down to Layout, select the property you want to edit and enter the desired value.


Note:

You can edit the custom code of a component in a more natural way by selecting Customize Code from context menu of the component and then edit its custom code in more natural way.














13.8.4 Understanding Layouts Provided with JDeveloper



You can choose from the following Layout Managers in the IDE:

	
FlowLayout

FlowLayout arranges components in a container like words on a page. It fills the top line from left to right until no more components can fit, continuing the same way on each successive line below.


	
BorderLayout

BorderLayout arranges components along the edges or the middle of their container. Using BorderLayout, you can place components in five possible positions relative to the ComponentOrientation of the container:

	
First, which correspond to BorderLayout.PAGE_START


	
Last, which correspond to BorderLayout.PAGE_END


	
Before, which correspond to BorderLayout.LINE_START


	
After, which correspond to BorderLayout.LINE_END


	
Center, which corresponds to interior area.





	
GridLayout

GridLayout places components in a grid of equally sized cells, adding them to the grid from left to right and top to bottom.


	
GridBagLayout

GridBagLayout is a powerful layout manager that provides precise control over all aspects of the layout even when the container is resized, using a complex set of component properties called "constraints." It is particularly useful for multiplatform Java applications as it enables you to create a free-form layout that maintains a consistent appearance across platforms.

GridBagLayout places components in a grid of rows and columns in which grid cells do not all have to be the same size. In addition, components can span multiple rows, columns, or both.


	
CardLayout

CardLayout provides a means of managing two or more components occupying the same display area. When using CardLayout each component is like a card in a deck, where all cards are the same size and only the top card is visible at any time. Since the components share the same display space, at design time you must select individual components using the Structure window.


	
BoxLayout

BoxLayout allows multiple components to be arranged either vertically or horizontally, but not both. Components managed by BoxLayout are arranged from left to right or top to bottom in the order they are added to the container. Components in BoxLayout do not wrap to a second row or column when more components are added or even when the container is resized.


	
AbsoluteLayout

AbsoluteLayout enables components to be placed exactly where you want them in the form, move them around in the IDE, and resize them using their selection borders. It is particularly useful for making prototypes since there are no formal limitations and you do not have to enter any property settings. However, it is not recommended for production applications since the fixed locations and sizes of components do not change with the environment.


	
Null Layout

The Null Layout is used to design forms without any layout manager at all. Like the AbsoluteLayout, it is useful for making quick prototypes but is not recommended for production applications, as the fixed locations and sizes of components do not change when the environment changes.












13.8.5 Using BorderLayout


BorderLayout arranges a container's components in areas named First, Last, Before, After, Center.

	
The components in First and Last are given their preferred height and are stretched across the full width of the container.


	
The components in Before and After are given their preferred width and are stretched vertically to fill the space between the first and last areas.


	
A component in the Center expands to fill all remaining space.





Figure 13-2 BorderLayout

[image: This image is described in the surrounding text]


The BorderLayout that appears in Figure 13-2 is good for forcing components to one or more edges of a container, and for filling up the center of the container with a component. It is also the layout you want to use to cause a single component to completely fill its container.

You will probably find BorderLayout to be the most useful layout manager for the larger containers in your UI. By nesting a panel inside each area of the BorderLayout, then populating each of those panels with other panels of various layouts, you can achieve quite complicated UI designs.

Components are positioned in one of five areas within a BorderLayout, based on the constraints property. You can set the constraints property for the component in the Properties window to one of the following values: First, Last, Before, After, Center.

For example, to put a toolbar across the top of a BorderLayout container, you could create a FlowLayout panel of buttons and place it in the First area of the container. You do this by selecting the panel and choosing First for its constraints property in the Properties window.

Each of the five areas can contain any number of components (or panel of components). However, unless the topmost component is not opaque, any lower components in the same area will be covered by the topmost one.

The following are some general guidelines for working with multiple components and BorderLayout:

	
Make sure the container has no more than five components.


	
If you need more components in one area of the BorderLayout, use the Enclose In context menu option to group the selected components into a sub-panel.





Note:

BorderLayout ignores the order in which you add components to the container.



By default, a BorderLayout puts no gap between the components it manages. However, you can use the Properties window to specify the horizontal or vertical gap in pixels for a BorderLayout associated with a container.

To modify the gap surrounding BorderLayout components, select the BorderLayout object in the Structure window (displayed immediately below the container it controls), then modify the pixel value in the Properties window for the horizontal gap and vertical gap properties.







13.8.6 Using CardLayout


CardLayout places components (usually panels) on top of each other in a stack like a deck of cards. You see only one at a time, and you can flip through the panels by using another control to select which panel comes to the top.


Figure 13-3 Card layout
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CardLayout is a good layout to use when you have an area that can contain different components at different times. This gives you a way to manage two or more panels that need to share the same display space.

By selecting CardLayout in the Structure window you can then you can then specify the amount of horizontal and vertical gap surrounding stack of components in the Properties window.







13.8.7 Using FlowLayout


FlowLayout arranges components in rows from left to right, and then top to bottom using each component's preferredSize. FlowLayout lines up as many components as it can in a row, then moves to a new row. Typically, FlowLayout is used to arrange buttons on a panel.


Figure 13-4 FlowLayout
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You can choose how to arrange the components in the rows of a FlowLayout container by specifying an alignment justification of left, right, or center. You can also specify the amount of gap (horizontal and vertical spacing) between components and rows. Use the Properties window to change both the alignment and gap properties when you're in the GUI builder.





13.8.7.1 Changing the Alignment



To change the alignment, select the FlowLayout object in the Structure window, then specify a value in the Properties window for the alignment property.









13.8.7.2 Changing the Gap



The default gap between components in a FlowLayout is 5 pixels.

To change the horizontal or vertical gap, select the FlowLayout object in the Structure window, then modify the pixel value of the horizontal gap or vertical gap property in the Properties window.









13.8.7.3 Changing the Order of Components



To change the order of the components in a FlowLayout container, drag the component to the new location, or right-click a component and choose Move Up or Move Down.











13.8.8 Using GridBagLayout


GridBagLayout is an extremely flexible and powerful layout that provides more control than GridLayout in laying out components in a grid. GridBagLayout positions components horizontally and vertically on a dynamic rectangular grid. The components do not have to be the same size, and they can fill up more than one cell.


Figure 13-5 GridBagLayout
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GridBagLayout determines the placement of its components based on each component's constraints and minimum size, plus the container's preferred size.

In the following discussion:

	
A component's cell refers to the entire set of grid cells the component occupies.


	
A component's display area refers to all the space of the cell that it occupies which is not taken up by the component's external padding (insets).




While GridBagLayout can accommodate a complex grid, it will behave more successfully (and more predictably) if you organize your components into smaller panels, nested inside the GridBagLayout container. These nested panels can use other layouts, and can contain additional panels of components if necessary. This method has two advantages:

	
It gives you more precise control over the placement and size of individual components because you can use more appropriate layouts for specific areas, such as button bars.


	
It uses fewer cells, simplifying the GridBagLayout and making it much easier to control.




On the other hand, GridBagLayout requires more containers, and therefore your program uses more memory than if you used other layout managers.





13.8.8.1 Adding Components to a GridBagLayout Container



When you add components to the design canvas they appear in one row by default. You cannot position them using the mouse. Instead, you must use the GridBag customizer. For more information, see How to Use the GridBag Customizer.









13.8.8.2 How to Set GridBagConstraints in the Properties Window



Using the Properties window, you can specify some of the GridBagConstraints.


Figure 13-6 Layout Properties in Properties Window
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If you want all the buttons in your GridBagLayout container to use the same internal padding, you can hold down the Ctrl key while you select each one, then edit the corresponding layout constraint property.

To set layout properties in the Properties window:




	Select the component(s) within the GridBagLayout container you want to modify, either in the Structure window or in the GUI builder.
	In the Properties window, select Layout.
	Select a value for the constraints property in the Properties window.
	Set the desired constraints in the property editor, then press OK.








13.8.8.3 How to Use the GridBag Customizer



The GridBag customizer enables you to visually adjust the placement and constraints of components in a GridBagLayout.


Figure 13-7 Customize Layout Dialog
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It includes a property sheet for GridBag constraints, buttons for adjusting the constraints, and a rough depiction of the layout of the components. The GUI Builder more closely reflects how the components will look at runtime.

To use the GridBag customizer:




	Add the components you require to your form and ensure the GridBagLayout is set for it.
	To open the customizer, right-click the GridBagLayout node in the Structure window and choose Customize from the contextual menu.
	Drag the components in the right pane to reposition them as desired.

As you drag a component, its Grid X and Grid Y properties change to reflect its new position.




	Once the approximate layout of the components has been established, select a component and adjust its constraints as desired in the left pane.

Note that you can either enter the values directly or use the provided buttons to adjust the component's constraints.

While editing:

	
You may need the Redo, Undo, Pad, and Test Layout buttons in the toolbar above the right pane.


	
You can right click the column/row headers and add or remove columns/rows.


	
You can also right click an empty cell and add a new component (so you do not have to close the GridBag customizer dialog in order to access the palette).




If after several rows, your design has fit nicely into a certain number of columns, and you suddenly have a row that requires an odd number of components, then consider dropping a panel into that row that takes up the entire row, and use a different layout inside that panel to achieve the look you want.




	Once you are satisfied with the layout, click Close to exit the customizer.










13.8.9 Using GridLayout


GridLayout places components in a grid of cells that are in rows and columns. GridLayout expands each component to fill the available space within its cell. Each cell is exactly the same size and the grid is uniform. When you resize a GridLayout container, GridLayout changes the cell size so the cells are as large as possible, given the space available to the container.


Figure 13-8 GridLayout
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You can specify the number of columns and rows in the grid, but only one of the rows or columns can be zero. You must have a value in at least one so the GridLayout manager can calculate the other.

For example, if you specify four columns and zero rows for a grid that has 15 components, GridLayout creates four columns of four rows, with the last row containing three components. Or, if you specify three rows and zero columns, GridLayout creates three rows with five full columns.

In addition to number of rows and columns, you can specify the number of pixels between the cells by modifying the horizontal gap and vertical gap properties. The default horizontal and vertical gap is zero.

To change the property values for a GridLayout container, select the GridLayout object in the Structure window, then edit the values for the rows, columns, horizontal gap and vertical gap properties in the Properties window.







13.8.10 Previewing a User Interface



To quickly test how your GUI will display when it is compiled and run, click the Preview Design button in the GUI Builder toolbar. A dialog box is displayed with the components arranged as they would actually appear on your form.

When you click in the previewed GUI form, mouse events are delivered to the actual components and you can see the components "in action." Thus, for example, you can move sliders, type into text fields, and buttons look "pressed" when you click them, however, cross-component and event handling code is not executed.











13.9 How to Create Accessible Forms



To ensure that your GUI forms and the components contained within them meet accessibility requirements, you can adjust their accessibility properties. A GUI is considered accessible when it works with various assistive technologies, such as screen readers.

The following properties can be edited to aid accessibility:





	
Accessible Name - Sets the name for the component. By default, the name is set to the component's text property value.


	
Accessible Description - Sets the description for the component.


	
Accessible Parent - Sets the name of the accessible parent component.




To edit a form or component's accessibility properties:




	In the Structure window, select the form or component whose accessibility properties you want to modify.
	In the Properties window, scroll down to the Accessibility properties.
	Click the ellipsis (...) button to open the Property Editor and then enter the desired value.

Alternately, you can click the current property value to select it and enter a new value.












13.10 Working with Event Handling


Use UI design tools in JDeveloper to attach event handler code to component and menu events.

In building your Java program, you can think of your code as being divided into two categories: initialization code and event-handling code.

	
Initialization code is executed when the UI components are created. You can think of this primarily as "start up" code for the components. This initialization code includes anything in the initComponents() method that all JDeveloper-designed GUI classes have. JDeveloper generates this code based on your UI design. For example, JDeveloper generates a button1.setLabel("OK") method call because you set the text property of a button, using the Properties window, to "OK".


	
Event-handling code is the code that is executed when the user performs an action, such as pressing a button or using a menu item. JDeveloper creates the stub (empty) event-handling method for you when you enter an event name in the Structure window for that component and press Enter. In that stub, you write code to handle the actual action caused by the event.




Your entire program consists of the initialization code, which says how things should look when they first appear, and the event-handling code, which says what should happen in response to user input.





13.10.1 How to Attach Event Handling Code to Menu Events



In Swing, a menu item has actionPerformed events and CheckboxMenuItems have itemStateChanged events. Code that you add to the actionPerformed event for a menu item is executed whenever the user chooses that menu item or uses its accelerator keys.

To add code to a menu item's event:




	Open a JFrame form in the visual editor.
	Add a menubar to your UI frame and insert menus and menu items into the menubar. Alternatively, you can open a file that already contains a menu.
	Select a menu item in the Menu Editor or the Structure window.
	In the Properties window, expand the Events node and click the desired event value field.
	Type the stub name of the event into the event value field and press Enter to create an event-handling method stub in the source code with the supplied name.

When you enter a name in the event value field, JDeveloper open the Code Editor and displays the source code in the Structure window. The cursor is positioned in the body of the newly created event-handling method, ready for you to enter code.




	Inside the open and close braces, enter the code you want to have executed when the user clicks the menu command.








13.10.2 How to Attach Event-Handling Code to a Component Event



Using the Events category in the Properties window, you can attach handlers to component events and delete existing event handlers.

To attach event-handling code to a component event:




	Select the component in the GUI builder or in the Structure window.
	In the Properties window, select the Events tab to display the Events for that component and click the desired event value field.
	Type the stub name of the event into the event value field and press Enter to create an event-handling method stub in the source code with the supplied name.

JDeveloper creates an event handler with the new name and switches to that event handler in the source code. JDeveloper also inserts some additional code into your class, called an adapter, to make the connection from the event to your event handling method.




	Inside the stub of the event handler write the code that specifies the response to that component event.








13.10.3 How to Quickly Create an Event Handler for a Component's Default Event



You can create an event handler in the GUI builder.

To quickly create an event handler for a component's default event:




	Select a component on the Components window and add it to your UI.
	Double-click the component in the GUI builder. An event stub is created and focus switches to that event handler in the source code.
	Add the necessary code to the event handler to complete it.




Note:

The default event is defined by BeanInfo, or as actionPerformed if none was specified.













13.11 How to Modify GUI Source Code



The IDE automatically generates grey guarded blocks of code as you create your GUI form in the GUI Builder. However, you can modify the way initialization code is generated and even write custom code to be placed within the initialization code.

You can modify the way initialization code is generated for a component, form, or component property by editing its Code properties in the Properties window. In addition, you can write custom code and specify where it should be placed within the initialization code.

To modify a form component's guarded block:




	In the Structure window, select the component whose initialization code you want to edit.
	Scroll down to Code Generation group of properties that lists individual properties for adding custom code to be generated for given component in the guarded code.

Alternatively, right click the component itself and from context menu choose Customize Code which opens a dialog where the custom code of all types can be edited in a more comfortable way.








Note:

You can freely edit all the other code in the Java class that is not guarded, and so customize the UI to your needs. All components have fields, so can be further modified from anywhere. The best place is in the constructor just after the initComponents() call. In most cases it is sufficient to write the code here, and it's much easier than trying to get the piece of the code appear inside initComponents() by entering it in the correct code property in the GUI builder. That should be left only for really special cases.









13.11.1 Modifying GUI Form Code Outside of the IDE


In the IDE each form is comprised of two files:

	
A .java file, which contains the form's Java source code.


	
A .form file, which stores the information that is used to generate the .java file when you make changes to the form in the GUI Builder. This file does not need to be distributed with your application. If you delete this file, you can no longer use the GUI Builder to change the form.




You can edit the .java files using external editors (not while the form is being edited in the IDE), with the following exceptions:

	
Do not modify the content of the initComponents() method. The body of this method is always regenerated when the form is opened in the IDE.


	
Do not remove or modify any of the special comments placed in the source by the IDE's GUI Builder (// GEN-...). They are required for the form to open correctly. These comments are not visible inside the IDE's Source Editor.


	
Do not modify the headers or footers of event handlers.










13.11.2 How to Modify Code Generation for a Property



A property value can be set as custom code.

To modify code generation:




	Select the component in the GUI Builder or Structure window to display its properties in the Properties window. Note that if you select multiple components, their common properties are displayed and any modifications apply to all of the selected components.
	Edit the component's properties in the Properties window by selecting the property and entering the desired value.
	If the property you want to edit has an ellipsis (...) button, you can click it to open a special property editor that provides more advanced editing options (e.g. a color chooser for a color-type property), or alternate ways of specifying the property value (for example, using a resource bundle for a text property), including a possibility to type directly the code that should represent the property value.

Use this to edit a given property in another way than in the small in-place editor in the properties window. You can also choose from several ways how to enter the property value via the combo box at the top.














13.12 Working with the UI Debugger


In addition to JDeveloper's standard Java and PL/SQL debugger facilities, JDeveloper also provides support for debugging graphical user interfaces (GUIs) specifically for AWT and Swing-based client applications and applets.

The UI Debugger offers an alternative way of debugging a GUI application. Traditional debuggers let you examine the data structure and track program flow. Instead, the UI Debugger lets you examine the GUI structure and the event sequences. The UI debugger helps you to see the relationship between UI components displayed on the screen with the actual data. It will also show you the events that are fired by the UI components, and the listeners that receive the events.

To use the UI Debugger, you need to first download it by choosing Help > Check for Updates and following the instructions in the wizard.

There are no additional special prerequisites for the using the UI Debugger beyond those requirements for using the JDeveloper debugger, other than ensuring that the JDeveloper Runtime library, jdev-remote.jar, is selected in the Project Properties - Libraries page.

Debugging a GUI application can be a challenge since most traditional debuggers do not let you easily examine the tree structure of a GUI application, nor do they display the details of what is displayed by your application.

To start debugging, select a project and choose Run > UI Debug <projectname>.jpr to start debugging.





13.12.1 Working with UI Debugger Windows


You can use the UI Debugger features which are exposed in JDeveloper via three dockable windows. The UI Tree and the UI Outline windows appear automatically when the UI Debugger is started. The Events window appears the first time you track events. You can toggle all three windows by choosing View > UI Debugger - <UI_debugger_window>.


Note:

No information is displayed in the UI Debugger windows until you take a snapshot. Click the Snapshot (F5) button to populate the UI Tree and the UI Outline windows.



	
UI Tree: Displays a hierarchical structure of your application's components and sub-components and their parent-child relationships. Select a component from the tree and right-click to display the context menu options. You will notice that the component is also selected in the UI Outline window.


	
UI Outline: Displays an image or outline image of the application's GUI. Select a component from the graphical representation of the GUI application and right-click to display the context menu options.


Note:

Since AWT components may not be painted correctly, Oracle recommends that you work in Outline mode for non-Swing based applications.




	
Events: Displays information about those events you've selected to listen to from the Listeners dialog. The Listener dialog displays when you choose the Events context menu option from either the UI Tree or UI Outline windows. When you select an event in this window, its source component is selected in the tree and outline windows.










13.12.2 How to Start the UI Debugger



Before performing any UI Debugger task, you must first start the UI Debugger.

To start the UI debugger:




	Select the project in the Applications window that you want to debug.
	Select a run configuration. For more information, see Configuring a Project for Running.
	Choose Run > UI Debug <projectname>.jpr to start the project's default target and to run the application.

JDeveloper starts the UI Debugger. The application is launched and the UI Tree and UI Outline windows automatically appear. However, no information is displayed in the UI Debugger windows yet.




	After the application is completely launched, go to the dialog or window you want to debug and select it.
	From either UI Debugger windows, click the Snapshot (F5) button.

JDeveloper displays a hierarchical structure of the application in the UI Tree window and displays a graphical representation of the application's user interface in the UI Outline window.












13.12.3 Examining the Application Component Hierarchy



The information in the UI Tree and the UI Outline windows and the relationship between them are always synchronized. Since the information in the UI Tree and the UI Outline windows is identical (only the way they are presented is different), whenever you select a component in the UI Tree hierarchy, JDeveloper locates and highlights the same object in the UI Outline window, and vice versa.

Before examining the application component hierarchy, you must start the UI Debugger and take a snapshot. Whenever the UI of the application is updated, you must click Snapshot again to update the information displayed by the UI Debugger windows.

To examine the application component hierarchy:





	
Use the tree of the UI Tree window to explore the hierarchical structure of the components or use the UI Outline window to locate the components visually.


	
Use the Image and Outline checkboxes at the top of the UI Outline window to toggle respectively the image and the borders of the components.


	
Use the icons at the bottom of the UI Outline window to zoom in or zoom out of the application image. If the image is larger than the window, you can pan across by clicking and dragging the image.


	
Note that the components that are not selected in the UI Outline window are shaded red.


	
Note that hidden components are represented by gray text in the UI Tree.


	
Right-click a component in either windows to display the context menu options. See UI Tree or UI Outline for more information.












13.12.4 How to Display Component Information in the Watches Window



To examine the data associated to a component, you can choose to watch the component in the JDeveloper Watches window. A watch enables you to monitor the changing values of variables or expressions as your program runs.

To display component information in the Watches window:




	If not already done, start the UI Debugger and take a snapshot.
	Right-click a component either in the UI Tree or the UI Outline window and choose Watch from the context menu.

The Watches window opens as a tab in the Smart Data window (if it is not already open), and a tree representing the component's structure is displayed in it.












13.12.5 How to Inspect a UI Component in an Properties window



You can view the state of a UI component in a JDeveloper Properties window.

To display a UI component in an Properties window:




	If not already done, start the UI Debugger and take a snapshot.
	Right-click a component either in the UI Tree or the UI Outline window and choose Inspect from the context menu.

The Inspect window opens as a tab in the Smart Data window (if it is not already open), and a tree representing the component's structure is displayed in it.












13.12.6 How to Trace Events Generated by Components



Use the event tracing feature to monitor the firing of selected events generated by UI components. Use this information to determine the content of events, and their sequence.

To trace events generated by components:




	If not already done, start the UI Debugger and take a snapshot.
	Right-click a component either in the UI Tree or the UI Outline window and choose Trace Events from the context menu.

The Trace Events dialog opens, displaying a list of the listeners that receive the event types fired by the component.


Note:

Event listeners are listed only for UI components that were visible when the snapshot was taken. If subsequent execution have added or removed UI components, the change will not be seen in the list.






	(Optional) Select Include Children to also show additional event types fired by the children of the selected component.
	In the Listeners dialog, select which event listener(s) you want to trace. For example, if you select FocusListener, all focus events will be traced.
	Click OK.
	The events fired by the selected listeners are displayed in the Events window. Right-click in the window to Clear the contents of the window or to Remove a specific Listener.








13.12.7 How to Show Event Listeners



Use the show listeners feature to find the recipients of events fired by UI components. Use this information to determine the extent of UI events.


Caution:

Event listeners are listed only for UI components that were visible when the snapshot was taken. If subsequent execution have added or removed UI components, the change will not be seen in the list.



To trace events generated by components:




	If not already done, start the UI Debugger and take a snapshot.
	Right-click a component either in the UI Tree or the UI Outline window and choose Show Listeners from the context menu.

The Listeners dialog opens for the selected component, displaying a list of listener types informed by the component, the classes of the registered listeners for each listener type, and the event methods implemented by each class.


Note:

The debugger's tracing filter is applied to the listener's list. A listener whose class is excluded by the filter will not be shown.






	Select a method.
	Click Go To Source.

An edit window opens, showing the source code for the selected method.












13.12.8 Remote Debugging GUI Applications


JDeveloper supports remote debugging of GUI applications via the command line. To achieve this, you must manually launch the program you want to debug. Once the program is launched and the JDeveloper debugger is attached to it, remote debugging is very similar to local debugging.

Performing remote UI debugging is similar to remote debugging any application. Just make sure that the following requirements are met first:

	
Add the JDeveloper runtime, jdev-remote.jar, to the libraries


	
Specify the UI Debugger agent's main class before your application's main class








13.12.8.1 How to Remote Debug GUI Applications



You can remote debugging a GUI application by entering commands on the command line.

To remote debug GUI applications:




	Configure your project for debugging, making sure to enable it for remote debugging.
	Start your application manually as follows by executing:


java -XXdebug -cp ...\jdev\lib\jdev-remote.jar 
oracle.jdevimpl.runner.uidebug.debuggee.Debuggee <MainClass>


where

	
...\jdev\lib\jdev-remote.jar is the JDeveloper Runtime Library classpath which you must add to the command.


	
oracle.jdevimpl.runner.uidebug.debuggee.Debuggee is the name of the main class of the UI Debugger's agent.







	A message similar to the following is printed in the command window:


*** Port is 4000 ***
*** Waiting for JVM debugger connection. ***




	The UI Debugger uses a socket to interact with your application. The default port number for the socket is 4030 but you can specify another port number by inserting -uidport,<port> before the application's main class as follows:


java -XXdebug -cp ...\jdev\lib\jdev-remote.jar
oracle.jdevimpl.runner.uidebug.debuggee.Debuggee -uidport,5678 
mypackage1.Application1


In this case, you will also have to specify the port number when you start the UI Debugger in the JDeveloper IDE.












13.12.8.2 How to start the JDeveloper IDE for Remote UI Debugging



You can use the JDeveloper IDE to remote UI debug a project.

To start the JDeveloper IDE for remote UI debugging:




	Select a run configuration that has been set up for remote debugging (Run > Choose Active Run Configuration).
	Choose Debug, then UI Debug <project_name>.jpr.

The main method of your Java application is started.




	The Attach to JPDA dialog appears, prompting you to specify a host name and a UI debugger port.

Unless you have used the -uidport option, you should leave this value as the default, 4030.




	Your UI debugging session will now behave as if it were performing local UI debugging. You can begin performing any UI debugger task.










13.12.9 Automatic Discovery of Listeners


The list of events that can be tracked by the UI Debugger is not hard-coded but is dynamically discovered at runtime. It is therefore possible to track events fired by any listener, provided that they adhere to the following guidelines:

	
The component class must have public methods to add and remove a listener.


	
The name of the methods must start with add or remove and end with Listener.


	
The return type must be void.


	
The methods must have only one argument.


	
The type of the argument must be an interface that extends java.util.EventListener.


	
The name of the method must be equal to the name of the interface preceded by add or remove.


	
The return type of each method in the specified interface must be void.


	
The method can only have one argument (the event).


	
The type of the argument must be a class accessible as a bean.


	
The return values of the getters can be anything except void. If the type is a non-primitive type, the value that will be shown in the UI Debugger will be the string obtained by calling the object's toString() method.





Examples





	
For example, if you want to define a new event listener of type Xxx, your component must have methods with the following signatures:


public void addXxxListener(XxxListener); 
public void removeXxxListener(XxxListener);


	
An example of an XxxListener interface could be:


public interface XxxListener extends java.util.EventListener
{
   public void methodOne(XxxEvent xxxEvent);
   public void methodTwo(XxxEvent xxxEvent);
   public void methodThree(XxxEvent xxxEvent);
}


	
An example of a XxxEvent class could be:


public class XxxEvent 
{
   public int getA(){...} 
   public String getB(){...} 
   public OtherType getC(){...}

















19 Developing Secure Applications


This chapter describes how you can develop, deploy, and administer secure Java EE applications in Oracle JDeveloper.

This chapter includes the following sections:

	
About Developing Secure Applications


	
Securing Applications in Phases


	
About Web Application Security and Support


	
Handling User Authentication in Web Applications


	
Securing Application Resources in Web Applications


	
Configuring an Application-Level Policy Store


	
Migrating the Policy Stores


	
Securing Development with JDBC








19.1 About Developing Secure Applications


The Fusion Middleware Suite lets you develop, deploy, and administer secure applications. You can secure Java EE applications using only container-managed security or, for Fusion web applications, you can use Oracle ADF Security. s are Java EE applications that you develop using the Oracle Application Development Framework (Oracle ADF).





19.1.1 Understanding Java EE Applications and Oracle Platform Security Services for Java (OPSS)


A Java EE application can be enhanced to use OPSS. In this scenario, you work with JDeveloper's declarative editors to configure users and roles. You secure application resources using Java EE container-managed security.







19.1.2 Understanding Fusion Web Applications and ADF Security


This scenario is a fully declarative implementation that adds ADF Security to enable fine-grained security policies for Oracle ADF resources. You work with JDeveloper's declarative editors to configure a file-based identity store, policy store, and credential store; and, because your application utilizes Oracle ADF, you also run a wizard to configure security for web pages associated with ADF resources (such as ADF task flows and ADF page definitions) and then use the jazn-data.xml policy editor to define security policies.







19.1.3 Understanding Container-managed Security


The Java EE security model is a role-based, declarative model based on container-managed security, where resources are protected by roles that are assigned to users. This model allows decoupling an application from its underlying security infrastructure since security can be specified separately from the application logic in an application deployment descriptor. The container, where an application runs, provides security for the application according to a specifications in the deployment descriptor. This model also allows embedding security data (annotations) in the application code that can be referenced in deployment descriptors.

For more information about container-managed security, see the Oracle Fusion Middleware Security Guide.







19.1.4 Additional Functionality


The Oracle ADF Security framework is the preferred technology to provide authentication and authorization services to the Fusion web application. A prime reason is that Oracle ADF Security is built on top of the Oracle Platform Security Services (OPSS) architecture, which provides a critical security framework and is itself well-integrated with Oracle WebLogic Server.

For more information about Oracle ADF security, see the “Enabling ADF Security in a Fusion Web Application" chapter of the Oracle Fusion Middleware Developer's Guide for ADF.

For more information on OPSS, see the Oracle Fusion Middleware Application Security Guide.









19.2 Securing Applications in Phases


When developing secure applications in JDeveloper it is often useful to think of development and deployment (to the production environment) as different phases, each with different needs. This is because during development and testing, JDeveloper supports easy to manage file-based security through integration with Oracle Platform Security Services (OPSS).

JDeveloper simplifies the application development life-cycle for security, and allows you to store the data in a flat file, for easy development. The jazn-data.xml file is JDeveloper's default file-based security provider for integration with OPSS. The jazn-data.xml file stores the users, groups, roles, and policies that you define the Fusion web application built using the Oracle Application Development Framework (Oracle ADF) and Oracle ADF Security. JDeveloper provides a dedicated editor for this file that simplifies creating the security data stores.

A feature of OPSS is the abstraction of users defined by the production environment's enterprise roles into application roles that are specific to the functions of your application. During development the application developer adds application roles and security policies that use application roles to the policy store of the jazn-data.xml file. Then, to simplify testing, the developer may add a few users to the identity store and directly assign these test users to application roles. Therefore, for testing the application, the jazn-data.xml can also be used as the identity store.

During development, your application does not ned to be aware of the enterprise roles defined in the production environment. After deployment an administrator will use Oracle Enterprise Manager Fusion Middleware Control to map the production-level enterprise roles to the application roles of your application's policy store. This mapping will allow a user who is a member of a given enterprise role to have access to the resources that are accessible from the associated application role.

After you complete the application, you migrate the policy store to the production environment provider on Oracle WebLogic Server. At that point, you will replace your test user identity store with enterprise users configured in the Oracle WebLogic Server embedded LDAP server. In contrast to the jazn-data.xml file, the LDAP server supports a distributed application server configuration that may be employed in a production environment. For details about the LDAP server, see Administering Security for Oracle WebLogic Server.

Therefore, working with the file-based provider and OPSS in JDeveloper helps separate the demands of the production environment through:

	
Declaratively defining test users and application roles


	
Declaratively defining security policies for Oracle ADF resources


	
Easily migrating from application-level security provider to system-jazn-data.xml security provider during deployment


	
Delaying the mapping of enterprise roles until deployment










19.3 About Web Application Security and JDeveloper Support


Java EE declarative security in Oracle WebLogic Server is implemented with Oracle Platform Security Services (OPSS), Oracle's implementation of the JAAS standard. OPSS extends Java EE security to provide application developers, system integrators, security administrators, and independent software vendors with a portable, integrated, and comprehensive security platform framework for Java SE and Java EE applications.

To learn more about OPSS and its features, see Oracle Fusion Middleware Security Guide.

JDeveloper provides tools to support configuring Java EE security for web applications and for deploying secure web applications to an application server instance. A developer, while developing an application, can configure OPSS services from JDeveloper through wizards and editors.

JDeveloper provides specific editors to create and edit Oracle Platform Security configurations (jps-config.xml), JAAS configurations (jazn-data.xml), and Web application deployment descriptors (web.xml). JDeveloper also supports direct deployment of web applications to application servers. For more information, see Securing Applications in Phases.

When you develop web applications you may choose to use Oracle Application Development Framework (Oracle ADF) to work with data-aware components in the user interface. When your user interface contains ADF resources, such as ADF task flows and ADF page definitions, then you have the option to secure the web pages that rely on those resources through the ADF Security framework. JDeveloper tools support iterative development of security so you can easily create, test, and edit security policies that you create for ADF resources. You can proceed to create test users in JDeveloper and run the application in Integrated WebLogic Server to simulate how end users will access the secured resources. For more information, see. How to Secure ADF Resources Using ADF Security in Fusion Web Applications.

For more information on web application security, see Oracle Fusion Middleware Programming Security for Oracle WebLogic Server.







19.4 Handling User Authentication in Web Applications


Authentication in declarative security is enforced when a user requests a protected web application area.





19.4.1 About Authentication Type Choices


Authentication in declarative security is enforced when a user requests a protected web application area. If the user has not been authenticated before, the container will retrieve credentials from the user. Users stay authenticated throughout the server session.

The supported types of authentication are: FORM based authentication, BASIC authentication, and CLIENT-CERT authentication. The type of authentication is specified in the web.xml deployment descriptor using the <login-config> element.





19.4.1.1 BASIC authentication


BASIC authentication uses the browser login dialog for the user to enter his user name and password. This dialog form cannot be customized and thus varies in its look and feel depending on the type of browser used. The user credentials are stored in the browser session for the authenticated realm. A realm is a repository that contains a set of permissions for the authenticated user. The default realm in Oracle Platform Security Services is jazn.com.

The code snippet below demonstrates how BASIC authentication is specified in the web.xml file:


<login-config>
<auth-method>BASIC</auth-method>
<realm-name>jazn.com</realm-name> 
</login-config>







19.4.1.2 FORM authentication


FORM based authentication allows the application developer to specify a custom login dialog. The username parameter must have a name of j_username, the password field must be named j_password. The login form action must have a value of j_security_check for the Java EE container to authenticate the request.

The code snippet below demonstrates how FORM authentication is specified in the web.xml file:


<login-config> 
       <auth-method>FORM</auth-method>
       <form-login-config>
             <form-login-page>loginform.jsp</form-login-page>
             <form-error-page>error.jsp</form-error-page>
       </form-login-config>
</login-config>







19.4.1.3 CLIENT-CERT authentication


CLIENT-CERT authentication uses the X.509 certificate to authenticate users. This type of authentication is also known as public key encryption.

For more information about authentication type choices, see the Oracle Fusion Middleware Security Guide.

For more information about authentication type using Oracle WebLogic Server, see Oracle Fusion Middleware Programming Security for Oracle WebLogic Server.









19.4.2 Encrypting Passwords for a Target Domain


As password encryption is specific to a WebLogic Server domain, you must manually add the password handling to the weblogic-jdbc.xml file. To encrypt a password, use the encrypt utility (weblogic.security.Encrypt) for the domain to which you want to deploy.


Note:

Passwords are domain-specific, so each time you want to deploy to a different domain you must re-encrypt the password for the target domain



The XML code you need to add to the weblogic-jdbc.xml should look something like this:


<password-encrypted>toystore</password-encrypted>


You can either put the clear text password or the encrypted password string in between the tags. This element goes inside of the <jdbc-driver-params> element, which will already be present in the weblogic-jdbc.xml if it has been edited using the Overview Editor.





19.4.2.1 weblogic.security.Encrypt


The weblogic.security.Encrypt utility encrypts cleartext strings for use with WebLogic Server. The utility uses the encryption service of the current directory, or the encryption service for a specified WebLogic Server domain root directory.


Note:

An encrypted string must have been encrypted by the encryption service in the WebLogic Server domain where it will be used. If not, the server will not be able to decrypt the string.



You can only run the weblogic.security.Encrypt utility on a machine that has at least one server instance in a WebLogic Server domain; it cannot be run from a client. Table 19-1 defines the arguments for the weblogic.security.Encrypt utility.


Note:

It is recommended that you run the utility from the Administration Server domain directory or on the machine hosting the Administration Server and specifying a domain root directory.



Syntax


java [ -Dweblogic.RootDirectory= dirname ] 
[ -Dweblogic.management.allowPasswordEcho=true ]
weblogic.security.Encrypt [ password ]





Table 19-1 Arguments for the weblogic.security.Encrypt utility

	Argument	Definition
	
weblogic.RootDirectory

	
Optional. WebLogic Server domain directory in which the encrypted string will be used. If not specified, the default domain root directory is the current directory (the directory in which the utility is being run).


	
weblogic.management. allowPasswordEcho

	
Optional. Allows echoing characters entered on the command line. weblogic.security. Encrypt expects that no-echo is available; if no-echo is not available, set this property to true.


	
password

	
Optional. Cleartext string to be encrypted. If omitted from the command line, you will be prompted to enter a password.









Examples

The utility returns an encrypted string using the encryption service of the domain located in the current directory:






java weblogic.security.Encrypt xxxxxx {3DES}Rd39isn4LLuF884Ns


The utility returns an encrypted string using the encryption service of the specified domain location:


java -Dweblogic.RootDirectory=./mydomain weblogic.security.Encrypt xxxxxx {3DES}hsikci118SKFnnw


The utility returns an encrypted string in the current directory, without echoing the password:


java weblogic.security.Encrypt Password: {3DES}12hsIIn56KKKs3











19.4.3 How to Create an Identity Store



An identity store is a data store of users, enterprise roles (user groups), and login credentials. The credentials are verified during authentication and used to authorize the user's access to application functions.





Understanding Users, Roles, and Realms

A user is an end user accessing a service; it could be an individual or a software component. A enterprise role is a collection of users that you group with the purpose of conferring the same set of permissions. A realm is a collection of authenticated users and enterprise roles.





For more information about users, enterprise roles, and realms, see the Oracle Fusion Middleware Security Guide.





Understanding Identity Stores in JDeveloper

When you develop secure applications in JDeveloper, you work with a file-based data store to define the users you wish to allow to log on. The advantage of defining a file-based identity store through the jazn-data.xml file is that it supports easy testing yet remains compatible with deployment to your production environment through migration to the system-jazn-data.xml file. It also avoids the complexity of setting up and maintaining an Oracle Internet Directory service for the LDAP-based identity store.





When you create a Fusion web application with Oracle ADF, the identity store will be created automatically when you run the Configure ADF Security wizard.


Note:

The LDAP-based identity store is a design time feature in JDeveloper, and is not available at runtime. JDeveloper's Integrated WebLogic Server overrides any LDAP identity store configuration.



For more information about identity stores, see the Oracle Fusion Middleware Security Guide.

To create an identity store:




	Double-click the jps-config.xml file in the Descriptors > META-INF folder in the Application Resources panel of the Applications window.
	Select the Identity Store tab in the jps-config.xml Overview Editor.
	Click the Add a New Identity Store icon at the top of the page. The Create Identity Store dialog opens.
	Choose the desired type of identity store option:

	
To create a file based identity store, choose XML-Based Identity Store, and enter the name for the store. By default, the file name is idstore.xml.


	
To create an LDAP based identity store, choose LDAP-Based Identity Store, and enter the name for the store. By default, the file name is idstore.oid.

Note: The LDAP-based identity store is a design time feature in JDeveloper, and is not available at runtime. The Integrated WebLogic Server in JDeveloper overrides any LDAP identity store configuration.







	When you are done, click OK to close the dialog.








19.4.4 How to Add Test Users to the Identity Store



The identity store is an XML file and is used while authenticating users. There can be an identity store at either the domain or application level.

To add users to the identity store:




	Open the application in the Applications window.
	Choose Application > Secure > Users to open the overview editor for the jazn-data.xml file.
	On the Users page, click the New User icon.
	Enter the new user name and password.
	Select the user from the Users list and enter further details, such as display name and description.
	Save your changes to the jazn-data.xml file.








19.4.5 Managing Enterprise Roles in the Identity Store


An enterprise role is a set of users that you group with the intention of conferring the same permission grants. You add enterprise roles to the identity store. You add application roles to the policy store.


Note:

Before adding a user to an enterprise role, ensure that you have created users in the identity store







19.4.5.1 How to Add Roles to the Identity Store



You can add roles to the identity store using the overview editor for the jazn-data.xml file.

To add roles to the identity store:




	Open your application in the Applications window.
	Choose Application > Secure > Groups to open the Enterprise Roles page of the overview editor for the jazn-data.xml file.
	Under Enterprise Roles, click the New Role icon. The new role appears in the Enterprise Roles list.
	Select the role from the Enterprise Roles list and enter further details, such as display name and description.








19.4.5.2 How to Manage Users Assigned to User Roles



You can manage roles in the identity store using the overview editor for the jazn-data.xml file.

To manage users assigned to enterprise roles:




	Open the Enterprise Roles page of the overview editor for jazn-data.xml file.
	Select the role from the Enterprise Roles list, and then click the Members tab.
	In the Members section, add or remove other members or roles.








19.4.5.3 How to View Assigned Enterprise Roles



You can view assigned roles in the identity store using the overview editor for the jazn-data.xml file.

To view assigned enterprise roles:




	Open the Enterprise Roles page of the overview editor for the jazn-data.xml file.
	Select the role from the Roles list, and then click the Assigned Roles tab.










19.4.6 How to Create a Credential Store



A credential store is a wallet-based file for storage of system credentials required by Oracle Platform Security Services (OPSS) in connecting to external systems such as databases. In JDeveloper, the credential store is the cwallet.sso file. The file contains all your OPSS-based credentials, and will be used in JDeveloper to store credentials that you define for Oracle ADF security. This file is normally not edited directly.

JDeveloper checks for the existence of a credential store service instance and creates the store the first time the you create a connection, for example, a database connection, in the Application Resources panel of the Applications window.

For more information about credential stores, see the Oracle Fusion Middleware Security Guide.

To create a credential store:




	Double-click the jps-config.xml file in the Descriptors > META-INF folder in the Application Resources panel of the Applications window.
	Select the Credential Store tab in the jps-config.xml Overview Editor.
	Click the Add the Credential Store icon at the top of the page. The Create Credential Store dialog opens.
	Enter the name of credential store file, and click OK.




Note:

You can create only one credential store in an application.











19.4.7 How to Add a Login Module


A login module is a component that authenticates users and populates a subject with principals. Login modules can be plugged in and used by applications without changing application code. An application can use more than one login module.

The login authentication process occurs in two distinct phases:

	
The login module attempts to authenticate a user requesting, as necessary, a name and a password or some other credential data; only if this phase succeeds, the second phase is invoked.


	
The login module assigns relevant principals to a subject, which is eventually used to perform some privileged action.




All login modules in a domain are configured in the file jps-config.xml using the following elements:

	
serviceProvider — to define a service provider for the login module.


	
serviceInstance — to define one or more instances of the service provider


	
jpsContext — to specify which instances to use




In JDeveloper, you can choose a pre-defined login module for your application, or create a new custom login module. Table 19-2 contains the pre-defined login modules that are available in JDeveloper:




Table 19-2 Predefined Login Modules

	Module	Description
	
saml.loginmodule

	
Used for SAML token assertion and implements the oracle.security.jps.internal.jaas.module.saml. JpsSAMLLoginModule class.


	
krb5.loginmodule

	
Used for Kerberos token assertion and implements com.sun.security.auth.module.Krb5LoginModule class.


	
wss.digest.loginmodule

	
Used to authenticate the digest based user name token based on WSS Digest specification and implements oracle.security.jps.internal.jaas.module.digest.WSSDigestLoginModule. This is supported only for JSE use cases


	
certificate.authenticator. loginmodule

	
Used to assert the X509 certificates and implements oracle.security.jps.internal.jaas.module.x509.X509LoginModule class.


	
user.authentication. loginmodule

	
Used to authenticate the user based on valid user name and password, and implements oracle.security.jps.internal.jaas.module.authentication.JpsUserAuthenticationLoginModule class


	
user.assertion.loginmodule

	
Used to authenticate the user based on valid user name and password, and implements oracle.security.jps.internal.jaas.module.assertion.JpsUserAssertionLoginModule class.


	
idstore.loginmodule

	
Used to authenticate JSE bases use cases and implements oracle.security.jps.internal.jaas.module. idstore.IdStoreLoginModule class








For more information about login modules, see the Oracle Fusion Middleware Security Guide.

To add a login module:

	
Double-click the jps-config.xml file in the Descriptors > META-INF folder in the Application Resources panel of the Applications window.


	
Select the Login Modules tab in the jps-config.xml Overview Editor.


	
Click the Choose from a list of pre-defined Login Modules icon at the top of the page. The Add Login Modules dialog appears.


	
Select the checkbox of login modules you want to add. You can add more than one login module in an application.


	
Click OK when you are done.










19.4.8 How to Authenticate Through a Custom Login Module



A key Oracle Platform Security component is the login service. Conceptually, the login service is an adapter that ties the JAAS login module SPI (javax.security.auth.spi.LoginModule) to the Oracle Platform Security for Java framework (OPSS).

The primary role of the login service is to enable JAAS login module implementations to be configured and used in OPSS.

To add a custom login module:




	Double-click the jps-config.xml file in the Descriptors > META-INF folder in the Application Resources panel of the Applications window.
	Select the Login Modules tab in the jps-config.xml Overview Editor.
	Click the Create New Login Module button at the top of the page.
	Enter the Login Module Name then click OK.
	Enter the classname for the login module. To search for an existing classname available to the project, click the Search button.
	Select the Login Control Flag. This can be: REQUISITE, REQUIRED, SUFFICIENT, or OPTIONAL.
	Select the Log Level. This can be: FINE, FINER, FINEST, CONFIG, INFO, WARNING, SEVERE.
	Click Debug to define whether the login module will output debug messages.
	Select Add All Roles to define whether all directly or indirectly granted roles of the user are added to the subject after authentication using the login module.
	Enter the names and values for any other properties required by the login modules.








19.4.9 How to Add a Key Store



A keystore is a repository of private keys and digital certificates.

If you have keys and certificates and wish to use them for secure services in your application, JDeveloper allows you to import a Java Key Store, Oracle Wallet (from a *.sso or *.p12 file), or PCKS12 file (from a *.p12 file). You cannot create a keystore in JDeveloper.

For more information about key stores and key store providers, see the Understanding Security for Oracle WebLogic Server guide.

To add a key store:




	Double-click the jps-config.xml file in the Descriptors > META-INF folder in the Application Resources panel of the Applications window.
	Select the Key Stores tab in the jps-config.xml Overview Editor.
	Click the Add a Key Store icon at the top of the page.

The Add Key Store dialog appears.




	Import the keystore file and complete the required fields.

You can import a Java Key Store (from a *.jks file), Oracle Wallet (from a *.sso or *.p12 file), or PCKS12 (from a *.p12 file) file as a key store.




	Click OK when you are done.








19.4.10 How to Enable an Anonymous Provider



The anonymous provider is an alternative to public pages in that unauthenticated user access can have permissions assigned that are more fine grained than allowing access to the whole (public) page.

Enabling the anonymous provider creates an anonymous JpsContext, which contains the anonymous service instance and the anonymous login module. Anonymous credentials will be used at runtime when the application user has not been authenticated and the application allows some resources to be accessible without authentication.

For more information about the anonymous provider, see the Oracle Fusion Middleware Security Guide.

To enable an anonymous provider for a web application:




	Double-click the jps-config.xml file in the Descriptors > META-INF folder in the Application Resources panel of the Applications window.
	Select the Anonymous Provider tab in the jps-config.xml Overview Editor.
	Select Enable Anonymous Provider.
	Select the Security Contexts tab and ensure that anonymous is automatically chosen as the Anonymous Provider.








19.4.11 How to Add Credentials to Users in the Identity Store



Credentials contain the authentication password for a user. The credentials appear in obfuscated form by default. Before adding credentials in the identity store, the member users must first be defined for the identity store.

To add credentials to users in the identity store:




	Open the application in the Applications window.
	Choose Application > Secure > Users to open the Users page of the overview editor for jazn-data.xml.
	Select a user in the Users list, and add credentials to the Password field.








19.4.12 How to Choose the Authentication Type for the Web Application



Authentication in declarative security is enforced when a user requests a protected web application area. If the user has not been authenticated before, the container will retrieve credentials from the user. Users stay authenticated throughout the server session.

The supported types of authentication are: FORM based authentication, BASIC authentication, and CLIENT-CERT authentication. The type of authentication is specified in the web.xml deployment descriptor using the <login-config> element.

For more information on authentication types, see About Authentication Type Choices.

To select the authentication type for the web application:




	Double-click the web.xml for the application in the Applications window.
	Click the Security tab of the web.xml Overview Editor.
	Expand the Login Authentication section and select the desired authentication type.










19.5 Securing Application Resources in Web Applications


Web pages and other resources of the web application should be secured. Depending on the type of application, you can secure your application in one of the two following ways:

	
For a Java EE web application, use Oracle Platform Security Services (OPSS) to secure your web application.


	
For an application developed using Oracle Application Development Framework (ADF), use Oracle ADF Security to secure your application.





Using OPSS Security

The following tasks outline the process of securing an application using Java EE security:





	
Specifying an authentication mechanism for users.


	
Managing users and groups in the realm.


	
Creating security roles for the application.


	
Mapping roles to users and groups.








Using Oracle ADF Security

You can use the Oracle ADF Security framework to provide authentication and authorization services to the Fusion web application.





For more information about Oracle ADF security, see the “Enabling ADF Security in a Fusion Web Application" chapter of the Oracle Fusion Developer's Guide for ADF.







19.5.1 How to Secure Application Resources Using the jazn-data.xml Overview Editor



JDeveloper enables you to secure your application resource types. The resource types can be known, that is, recognized by JDeveloper, or you can create your own resource type.

A resource type represents the type of a secured artifact, such as a flow, a job, or a web service, and, essentially, it is a template for creating resources of a particular type. All resources have an associated type and are filtered or grouped according to type.

To secure an application resource:




	Open the application in the Applications window.
	In the main menu, choose Application > Secure > Resource Grants to open the Resource Grants page in the overview editor for the jazn-data.xml file.
	In the Resource Type dropdown list, select the resource type you want to secure, for example, Task Flow. The list will display all the resource types available in the selected projects. You can also create a new resource type.
	Click the Select Source Project icon to select the source project. Instances of the selected resource type from the selected source projects will be displayed in the Resources list.
	Add the grantees (application roles, enterprise roles, or code sources) that will be granted the resource permissions. You can grant resource permissions to users, application roles, enterprise roles, and code sources. Click the Add Grantee icon in the Granted To list to add grantees.
	In the Actions list, select the actions that will be allowed on the resource.
	Save your changes to the jazn-data.xml file.








19.5.2 How to Secure ADF Resources Using ADF Security in Fusion Web Applications


Security policies that you define in a Fusion web application support fine-grained access control for ADF security-aware resources, including ADF task flows and ADF page definitions. To enable ADF security policies, you begin by running the Configure ADF Security wizard on the user interface project.

After you enable ADF Security you must grant users access rights so that they may view the web pages of the Fusion web application. Access rights that you grant users are known as a security policy that you specify for the page's corresponding ADF security-aware resource. Ultimately, it is the security policy on the ADF resource that controls the user's ability to enter a task flow or view a web page:

	
Do not define security policies for the individual web pages of a bounded task flow. When the user accesses the bounded task flow, security for all pages will be managed by the permissions you grant to the task flow. And, because the individual web pages (with associated page definitions) will be inaccessible by default, ADF Security prevents users from directly accessing the pages of the task flow. This supports a well-defined security model for task flows that enforces a single entry point for all users.


	
Do define security policies for the individual web page only when the page is not a constituent of a bounded task flow. Page-level security is checked for pages that have an associated page definition binding file only if the page is directly accessed or if it is accessed in an unbounded task flow.




ADF security policies are maintained in the file-based jazn-data.xml policy store. Defining and updating ADF security policies in JDeveloper is supported by the overview editor for this file. The resulting declarative ADF security policies are easy to read.

The detailed steps for securing Oracle ADF resources are in the “Enabling ADF Security in a Fusion Web Application" chapter of the Oracle Fusion Developer's Guide for ADF.

To define security policies for ADF resources:

	
Enforce ADF Security for the application by running the Configure ADF Security wizard.


	
Add application role names to the policy store.


	
Grant permission on the entire set of web pages contained in an ADF bounded task flows.


	
Grant permission on top-level web pages that are associated with an ADF page definition file and that are not associated with a bounded task flow.

If your application contains top-level web pages that are not associated with an ADF resource because they do not contain data-aware components, you can optionally secure these pages too.


	
If necessary, grant permission on rows of data that are defined by an ADF entity object.


	
Provision the identity store by adding the users who will login to test security.


	
Associate the test users you created with one or more application roles.












19.6 Configuring an Application-Level Policy Store


A Policy Store is the repository of application and enterprise policies. A policy specifies the permissions granted to code running from a specific location.

An Application Policy Store is a repository of application policies together with application roles, application policies, principals, and permissions. Application roles can include application users and roles, and roles specific to the application (such as administrative roles). A policy can use any of these roles or users as principals. Similarly, a System Policy store is a repository of system policies, principals, and permissions. A system policy store does not contain roles.

When you create a Fusion web application with Oracle ADF, the policy store will be created automatically when you run the Configure ADF Security wizard.

The difference between an application policy store and a system policy store is in their scope. An application policy store is constrained within an application limiting it's accessibility, where as a system policy store can be accessed openly.

For more information on policy stores, see the Oracle Fusion Middleware Security Guide.

A Principal is an identity assigned to an entity; the entity could be a user or a role. A Permission is a set of operations allowed for a group of entities; the entity could be a principal too. A Grant, or a custom policy, includes permissions and principals. In JDeveloper, you cannot create a principal or a permission without creating a grant.





19.6.1 How to Add Application Roles to an Application Policy Store



Application roles are specific to an application and defined in the application policy store. They are used by the application directly (either a Java SE or Java EE application) and are not necessarily known to the Java EE container. In the file-based policy store in a jazn-data.xml file, these application roles are defined in <app-role> elements under <policy-store>, and then written to system-jazn-data.xml at the domain level during deployment.

To add application roles to the application policy store:




	Open the application in the Applications window.
	Choose Application > Secure > Application Roles to open the Application Roles page of the overview editor for the jazn-data.xml file.
	Click the Add icon to create a new application role as a peer or child of the currently selected role, or to create a new role category. The new application role or category is listed in the Roles list.
	Enter details of the role or role category in the Name, Display Name, and Description fields.
	Save your changes to the jazn-data.xml file.



For more information, see the Oracle Fusion Middleware Securing Resources Using Roles and Policies for Oracle WebLogic Server guide.









19.6.2 How to Add Member Users or Enterprise Roles to an Application Role



Deployment users and roles are defined in the security provider that you use. For the file-based provider, deployment users and roles are defined in the jazn-data.xml file.


Note:

Before adding member users or member roles to an application role, the member users and member roles must first be defined for the identity store.



To add users or enterprise roles to an application role:




	Open the application in the Applications window.
	Choose Application > Secure > Application Roles to open the Application Roles page in the overview editor for the jazn-data.xml file.
	From the Application Roles list, select the application role, and then click the Members tab.
	To add a user, under Member Users and Roles, click the Add User or Role icon, and select Add User.
	To add an enterprise role, under Member Users and Roles, click the Add User or Role icon, and select Add Enterprise Role.
	Save your changes to the jazn-data.xml file.








19.6.3 How to Create Custom Resource Types



You can create custom resource types and specify them in the jazn-data.xml file.

A resource type represents the type of a secured artifact, such as a flow, a job, or a web service, and, essentially, it is a template for creating resources of a particular type. All resources have an associated type and are filtered or grouped according to type.

To create a custom resource type:




	Open your application in the Applications window.
	Choose Application > Secure > Resource Grants to open the Resource Grants page of the overview editor for the jazn-data.xml file.
	In the Resource Grants page, click the New Resource Type icon next to the Resource Type field.
	In the Create Resource Type dialog, specify the properties of the resource, such as name, display name, and associated actions. The Actions list in the Create Resource Type dialog is used to populate the checkable items list in the Resource Grants page for resources of this type.
	Save the jazn-data.xml file.








19.6.4 How to Add Resource Grants to the Application Policy Store



You can add application resource grants to an application policy store by updating the Resource Grants page of the overview editor for jazn-data.xml.

A resource is an instance of a resource type that represents a concrete resource; it defines an application resource that can be secured by a policy, such as software components managed by a container (for example, URLs, EJBs, JSPs) or an application business (for example, Reports, Transactions, Revenue Charts).

To add a resource grant for the application policy store:




	Open your application in the Applications window.
	Choose Application > Secure > Resource Grants to open the Resource Grants page of the overview editor for the jazn-data.xml file.
	To define the security policy, select an item in the Security Policy field. The application security policy is selected by default. To define global resource grants, select Global.
	Select the resource type from the Resource Type dropdown menu, or click the New Resource Type icon to create one.
	For the resource types that are filtered by project, the Source Project selector is enabled. You may need to change the source project selection to find the desired resources.
	The resources that belong to the selected resource type are listed in the Resources list.
	Manage the entities that the resource permissions have been granted to, by clicking the Add Grantee icon in the Granted To list. You can grant to an application role, a user, an enterprise role, or a code source.
	View and select the actions allowed on the resource in the Actions list.








19.6.5 How to Add Entitlement Grants to the Application Policy Store



Using the Entitlement Grants page of the overview editor for jazn-data.xml, you can define a set of resource permissions and grant those permissions to multiple application roles without having to grant each permission to each application role individually.

An entitlement is a collection of permissions. Typically, it encapsulates the list of permissions needed to perform a given business function or task.

To add entitlement grants to an application policy store:




	Open your application in the Applications window.
	In the main menu, choose Application > Secure > Entitlement Grants to open the Entitlement Grants page in the overview editor for the jazn-data.xml file.
	To add an entitlement, click the Add Entitlement icon in the Entitlements list.
	To add a member resource, click Resources, and in the Member Resources list, click the Add Member Resource icon.
	To select the application role to grant the entitlement to, select Grants and then click the Add Role Grant icon. In the Select Application Roles dialog, you can select an application role or create a new one.
	Save the jazn-data.xml file.




Tips:

	
You can view grants to resources that are members of an entitlement group in the Resource Grants page by clicking the Show Grants from Entitlements icon in the Granted To column. This option is selected by default.


	
You can also add member resources to new or existing entitlements from the context menu in the Resource Grants page.














19.6.6 How to Create a Custom JAAS Permission Class



A new permission class is useful when you want to create your own JAAS permission for a logical artifact type to secure. For example, although Oracle ADF already provides built-in permission classes for the artifacts on which it enforces security (including task flows, page definitions, entity objects, and entity attributes), you might create a custom permission class for a set of UI components that you want to secure in the user interface. Once this class is created, you can add enforcement checks using Java, Expression Language (EL), or embedded Groovy expressions, and then you can grant the new custom permission class to application roles by editing the jazn-data.xml file directly. For example, you could define a security policy to limit access to a menu that your application displays and then associate the rendering of the menu with the user's granted custom permission using the EL value userGrantedPermission on the component's rendered property.

To create a custom JAAS-compliant permission class:




	Open your application in the Applications window.
	From the main menu, select File > New to open the New Gallery.
	In the New Gallery, under Categories, select Business Tier > Security.
	Under Items, select JAAS Permission.
	In the Create JAAS Permission dialog, enter the details of the custom permission class. For any help from within the dialog, click Help or press F1.








19.6.7 How to Add Grants to the System Policy Store



Currently, this release does not provide an editor to add system permission grants to a system policy store; you will need to manually add grants in the source code for jazn-data.xml.

To add a grant to the system policy:




	Open your application in the Applications window.
	In the Applications window, double-click the jazn-data.xml to open the overview editor.
	Click Source to open the source editor.
	In the source code, inside the <jazn-data> element, create a <jazn-policy> element.
	Inside the <jazn-policy> element create a <grant> element that defines the <grantee> with the desired application role and the <permission> with the fully qualified class name of the permission class, the name that you want to use as the target for the grant, and the action that you want to grant to the application role principal.
	Save changes to the jazn-data.xml file.










19.7 Migrating the Policy Stores


JDeveloper is configured by default to deploy the security objects from your application repositories to Integrated WebLogic Server each time you run the application. You can change this behavior by selecting security deployment options in the Application Properties dialog to:

	
Decide whether to overwrite the domain-level policies with those from the application jazn-data.xml file.


	
Decide whether to overwrite the system credentials from the application's cwallet.sso file.


	
Decide whether to migrate the identity store portion of the jazn-data.xml file to the domain-level identity store.




If you make no changes to the deployment settings, each time you run the application, JDeveloper will overwrite the domain-level security policies and system credentials. Additionally, JDeveloper will migrate new user identities you create for test purposes and update existing user passwords in the embedded LDAP server that Integrated WebLogic Server uses for its identity store. However, if you prefer to run the application without updating the existing security objects in Integrated WebLogic Server, you have this option.





19.7.1 How to Migrate the Policy Stores



When you are ready to deploy the application to standalone Oracle WebLogic Server, you can use the same configuration settings to control how JDeveloper handles migration of the security objects.

To configure deployment of security objects:




	Choose Application > Secure > Configure Security Deployment to open the Application Properties dialog.
	In the Application Properties dialog, under Security Deployment Options, select the security objects that you want to deploy with the application.

By default, each time your run the application, JDeveloper will overwrite the application policies and credentials at the domain level with those from the application. If you prefer not to overwrite either of these repositories, deselect Application Policies or Credentials. When deselected, JDeveloper will merge only new policies or credentials into the domain-level stores. For further details, see the sections below.

By default, each time you run the application, JDeveloper will migrate new user identities you create for test purposes and update existing user passwords in the embedded LDAP server that Integrated WebLogic Server uses for its identity store. You can disable migration of the application identity store by deselecting Users and Groups. For further details, see the sections below.




	Click OK.








19.7.2 Migrating Application Policies


Application policies, specified in jazn-data.xml, can be migrated to a domain policy store when the application is deployed to a server in the Oracle WebLogic Server environment. If desired, the policies can also be removed from the domain policy store when the application is undeployed, or updated when the application is redeployed.

If Application Policies is selected in the Application Properties dialog, a jps.policystore.migration property is set to OVERWRITE in the packaged weblogic-application.xml when you deploy the application using JDeveloper. If Application Policies is unselected, the jps.policystore.migration setting will not be added to the packaged weblogic-application.xml, and will be removed if it is already present. This causes the default operation MERGE to be used by Oracle WebLogic Server. Merge will only migrate policies the first time the application is deployed if they do not already exist. If the policies for the application already exist, they will not be remigrated.

To find out more about automatic and manual migration of application policies, see the Oracle Fusion Middleware Security Guide.







19.7.3 Migrating Credentials


When you migrate your application policies, you might also want to migrate your credentials. Application credentials, specified in cwallet.sso, can be migrated to a domain credential store when the application is deployed or redeployed to a managed server in the WebLogic environment. Thus, credential migration includes the passwords for all connections created within JDeveloper, including those created for web services. (This is not related to user credentials specified in the identity store of the jazn-data.xml file. See Migrating Users and Groups below for details about identity store migration.)

If Credentials is selected in the Application Properties dialog, a jps.policystore.migration property is set to OVERWRITE in the packaged weblogic-application.xml when you deploy the application in JDeveloper. If Credentials is unselected, the jps.policystore.migration setting will not be added to the packaged weblogic-application.xml, and will be removed if it is already present. This causes the default operation MERGE to be used by Oracle WebLogic Server. Merge will only migrate credentials the first time the application is deployed if they do not already exist. If the credentials for the application already exist, they will not be remigrated.

The credential migration is possible only when the server is running in development mode only. In production mode, credential overwrite is prohibited. Application credentials must be manually migrated when you deploy using tools outside of JDeveloper.







19.7.4 Migrating Users and Groups


Users and roles, specified in jazn-data.xml, can be migrated to a domain identity store when the application is deployed to a server in the WebLogic environment.

If Users and Groups is selected in the Application Properties dialog, JDeveloper will make calls when you deploy the application to create Oracle WebLogic Server users and groups corresponding to the application's jazn-data.xml users and role. If the user already exists in the domain store, only the description and password will be remigrated during deployment. If a group exists in the domain store with the same name as the roles in the jazn-data.xml file, it will be replaced entirely. If Users and Groups is unselected, JDeveloper will not try to migrate the identity store from the application jazn-data.xml.


Note:

Before migrating users and groups ensure that administrator roles (admin) and users (weblogic) are not used in the application jazn-data.xml file so that the domain identity store is not overwritten. When your application is ready for deployment to a production environment, you should remove the identities from the jazn-data.xml file or disable the migration of identities by deselecting Users and Groups from the Application Properties dialog.











19.8 Securing Development with JDBC



A JDBC database connection created in JDeveloper derives its encryption properties from the database client install on your machine. To create a secure connection using JDBC:





	
Configure encryption support using the OCI driver by setting parameters in the sqlnet.ora file on your client machine.


	
Use the thin JDBC driver to create a secure JDBC connection in JDeveloper. To do this, select Enter Custom JDBC URL in step 3 (Connection page) of the Create Database Connection Wizard, then enter your encryption parameters as part of a custom JDBC URL, as shown below:


jdbc:oracle:thin:@(description
=(address=(protocol=tcp)(host=myhost)(port=1521))(connect_data=
(sid=ORCL)(SQLNET.ENCRYPTION_CLIENT=REQUIRED)(SQLNET.ENCRYPTION_TYPES_
CLIENT=DES40)(SQLNET.CRYPTO_CHECKSUM_CLIENT=REQUESTED)
(SQLNET.CRYPTO_CHECKSUM_TYPES_CLIENTMD5=MD5) ))















What's New in This Guide


The following topics introduce the new and changed features of Oracle JDeveloper and other significant changes that are described in this guide, and provides pointers to additional information. This document is the new edition of Developing Applications with Oracle JDeveloper.





New and Changed Features for 12c (12.2.1)


Oracle JDeveloper 12c (12.2.1) includes the following new and changed features for this document.

	
Building Java projects and testing Java applications:

	
Support for refreshing an application at the same time as running the Clean command. For more information, see Cleaning Applications and ProjectsHow to Use Fast Infoset for Optimizing XML Transmission.


	
Support for Heap Walker, a heap dump viewer to use when profiling. For more information, see Creating RESTful Web Services and Clients.





	
Building Java projects with Maven

	
Maven remote repositories can be added or removed either directly through the project POM file or through the Tools main menu. For more information, see How to Specify and Manage Remote Repositories.


	
Populating a shared repository enables development teams to share application dependencies. A shared repository can be populated using the Maven Synchronization plugin. For more information, see Populating the Repository.


	
Use of Maven archetypes as templates for quickly creating Maven projects. Several archetypes are available, including the ADF oracle-adffaces-ejb archetype that creates a basic Fusion Web application containing Model and ViewController projects. For more information, see How to Create Maven Projects Using Maven Archetypes.


	
Support for running Maven goals from the Tools main menu. For more information, see How to Run Maven Goals on POM Files.


	
Support for ojmake and ojdeploy deployment plugins in POM files. For more information, see Using ojdeploy and ojmake.





	
Conversion of inner classes to lambda expressions (this feature available only if your are running JDK 1.8) to simplify coding. For more information, see How to Convert an Anonymous Inner Class to a Lambda Expression.


	
Working with databases:

	
Improved support for editing PL/SQL:

	
The PL/SQL Source Editor now uses many of the common set of features that JDeveloper provides to enhance coding across all domains. These include: code folding, usage highlighting, code insight (for offline PL/SQL), show methodsignature and comments for called methods, using the audit framework to highlight missing methods and using Code Assist to implement the appropriate action.


	
Offline and database PL/SQL can be compiled against a database connection.


	
A new test query feature to ensure that SELECTs in L/SQL return the correct rows.


	
Synchronize package specification and body, which provides a quick way of creating a new package body, and allows you to synchronize the specification and body and automatically create missing methods.




For more information, see Using the PL/SQL Source Editor.


	
Improved database connection support:

	
Additional parameters can now be specified when you make a database connection. For more information, see Defining Additional JDBC Parameters.


	
The type of database and version number are reported when you test a database connection. For more information, see How to Create Database Connections.



















10 Testing and Profiling Java Application Projects


JDeveloper provides a suite of tools for analyzing the quality and performance of your Java code. Use these tools to improve both the quality of your code and your own programming skills.

This chapter includes the following sections:





10.1 About Profiling Applications


The profiler gathers statistics on a running program that enable you to diagnose performance issues and correct code inefficiencies.

The following profiling capabilities are available:

	
Telemetry—monitors CPU, memory usage, number of threads and loaded classes. See Profiling Telemetry.


	
Methods—profiles methods execution times and invocation count, including call trees. See Profiling Methods.


	
Objects—profiles size and count of allocated objects including allocation paths. See Profiling Objects.


	
Threads-—profiles threads time and state. See Profiling Threads.


	
Locks—profiles locks content data. See Profiling Locks.










10.2 About Starting the Profiler


JDeveloper provides the following pathways for starting the profiler:

	
Starting and Profiling JDeveloper Applications Simultaneously


	
"Attaching the Profiler to a Running JDeveloper Applications "


	
"Profiling External Applications"










10.3 Starting and Profiling JDeveloper Applications Simultaneously



You may simultaneously start a JDeveloper application and the profiling of that application by following these steps:




	Choose Run > Profile Project
	On the main window click the Configure Session button and select a profiler mode by clicking on it. You can change the profiler mode at any point by clicking the Profile drop down arrow.
	On the main window, click the Profile button.

The application and the profile session are simultaneously started.












10.4 Attaching the Profiler to a Running JDeveloper Applications



You may profile a JDeveloper project that is already running by following these steps:




	Choose Run > Attach to Project
	On the main window click the Configure Session button and select a profiler mode by clicking on it. You can change the profiler mode at any point by clicking the Profile drop down arrow.

If the target application is running outside JDeveloper, select the Setup attach to project target and make the appropriate selections in the Attach Settings window. For more information on profiling external applications, see Profiling External Applications




	On the main window, click the Attach button.

A profile session tracking the running application is started.












10.5 Profiling External Applications



You may profile an application that is not started from within the JDeveloper IDE by following these steps:




	Choose Run > Attach to External Process

The Profiling External Process tab opens in the main window.




	Click the Configure Session button and select Setup attach to process

The Attach Settings window appears.




	Select the type of application to be profiled from the Profile drop-down menu and select the process to be profiled. The Attach Settings window explains and provides detailed instructions for each option. Click OK.
	On the main window click the Configure Session button and select a profiler mode by clicking on it. You can change the profiler mode at any point by clicking the Profile drop down arrow.
	Click the Attach button.

A profile session tracking the selected application is started.












10.6 Profiling Telemetry


The telemetry mode provides the following metrics:

CPU and GC—displays the CPU and GC percentage of use at a given time

Memory—displays in MB the heap size and used heap at a given time

Surviving Generations —displays the number of surviving generations at a given time. It also displays indicates the GC intervals

Threads and Classes—displays number of loaded classes and threads at a given time

To start a profiling telemetry session, see "About Starting the Profiler"

Figure 10-1 shows a snapshot of a telemetry session


Figure 10-1 Telemetry Session

[image: img/GUID-DC7FAAB8-3294-4990-9224-5AE30941C163-default.gif]







10.7 Profiling Methods


The methods mode provides metrics for methods and classes. The methods report allows you to view the data by Forward Calls, Hot Spots, and Reverse Calls by clicking on the appropriate icons. You may also choose to Show Delta Values and Select Threads.
	
Show Delta Values-this action switches from absolute values to incremental values. The values displayed prior to switching the view are remembered but the new view displays changes starting at the moment the new selection was made. Clicking this icon again resets the results back to absolute values.


	
Select Threads-this action shows threads available in live results or a saved snapshot and allows you to select specific threads for displaying results. This feature is especially useful when tracking EDT slowness in desktop applications or analyzing worker threads in server applications. The Merge selected threads option is enabled if some of the threads are selected and it is disabled for the Show all threads option. This feature merges results from the selected threads to a single tree.






Additionally, you may select the columns to be displayed; the options are Total Time, Total Time (CPU), Selected, and Hits/Invocations (depending on the session configuration).

To start a profiling methods session, see "About Starting the Profiler"

Figure 10-2 shows a snapshot of a methods session.


Figure 10-2 Methods Session

[image: img/GUID-BCC42A18-7C2B-421A-83E5-958714D5A571-default.gif]





10.7.1 Profiling Specific Methods



You may narrow down the scope of the methods session to profile specific methods or classes by following these steps:




	Click on the [image: img/GUID-AB27E7F1-EA51-401B-AB48-B627E62BCC60-default.gif]icon.

A new settings bar appears.




	On the Profile dropdown make the appropriate selection.
	Click the Plus icon to add a class or method.

The Select Class or Select Method window appears.




	To select a class in the Select Class window, choose the Project, Package, and Class and click OK.

To select a method in the Select Method window, choose the Project, Package, Class and Method and click OK

Alternatively, you may right click on a method or a class to select it. This feature is available in the profile results and snapshot windows.














10.8 Profiling Objects


The objects mode provides a list of classes allocated to a project including live instances and bytes allocation. By clicking the [image: img/GUID-AB27E7F1-EA51-401B-AB48-B627E62BCC60-default.gif] icon on the top-right corner of the page you access a drop-down menu that allows you select the classes to be profiled. The All Classes mode shows all classes and object that are live on the Virtual Machine heap. The Project Classes filter allows to view only the classes defined in the project.

To start a profiling objects session, see "About Starting the Profiler"

Figure 10-3 shows a snapshot of an Objects session


Figure 10-3 Objects Session

[image: img/GUID-C7AD11A3-B1B7-4757-9F9C-742BC2D8F378-default.gif]





10.8.1 Profiling Specific Objects



You may elect to profile specific classes by right clicking on a class and selecting Profile Class. The Track only live objects and Limit allocations depth checkboxes appear.

Track only live objects — when selected, it tracks only live objects. If not selected, it tracks all objects allocated by the application.

Limit allocations depth — limits the stack depth allocations to the number specified.

After selecting a class, click the Apply button on the right while the profiling session is in progress to submit your changes. This action clears the view to display only the classes that you selected as shown in Figure 10-4


Figure 10-4 Objects Session - Selected Classes View

[image: img/GUID-6DAEB54F-74DF-4858-B71E-3FADAE383211-default.gif]











10.9 Profiling Threads


The threads mode allows you to view detailed information about application thread activity.

To start a profiling threads session, see "About Starting the Profiler"

Figure 10-5 shows a snapshot of a threads session


Figure 10-5 Threads Session

[image: img/GUID-7772FB4F-2F0C-40AC-967F-34843FBBFD06-default.gif]


Additionally, you may customize the threads you monitor by accessing the Live Threads drop-down list and choosing from the available options: All Threads, Live Threads (Default), Finished Threads, and Selected Threads.







10.10 Profiling Locks


The locks mode allows you to view details about locked threads and the threads that are monitoring and holding locks.

To start a profiling locks session, see "About Starting the Profiler"

Figure 10-6 shows a snapshot of a locks session


Figure 10-6 Locks Session

[image: img/GUID-DCA22797-5C9D-4C0B-89B4-7D824F1F966B-default.gif]


In the session window you can choose Threads or Monitors in the Threads drop-down list. Choose Threads to view locked threads. Expand the nodes to view the owners of the locks. Choose Monitors to view the threads that are locking other threads.







10.11 Additional Functions when Running a Profiling Session


While the profiler session is in progress, additional actions related to the actual profiler mode are available in the toolbar of the profiler window. The following actions are always available:

Thread dump—creates a textual dump of all active threads and monitors of the profiled application. It shows what methods have been executed at the point of capturing the dump, thread by thread. This information is useful to view what the application is currently doing. The thread dump also contains information about locks, threads holding the locks, and threads waiting to acquire a lock. This data is essential when debugging deadlocks. To capture a Thread Dump, click the Thread Dump icon during the profiling session. To learn more about taking snapshots, see Taking and Accessing Snapshots of Profiling Data

Heap dump—saves an image of the current heap content of the profiled process in .hprof format and optionally opens it in heap browser. For more information, see Capturing Heap Dump Data

GC—requests the JVM of the profiled process to invoke garbage collection. The JVM behavior for garbage collection is not defined in the JVM specification. It should do the garbage collection at some point, but there is no guarantee it will do it immediately or at all.

Additionally, when profiling Methods or Objects, the following actions are available:

Snapshot—creates a snapshot of all currently collected profiling data related to methods or objects. The snapshot opens in a separate window and can be saved to the project or to an external file. For more information, see Taking and Accessing Snapshots of Profiling Data

Reset collected results—clears all currently collected profiling data related to methods or objects.

The other actions displayed in the toolbar of the profiler window are specific to the actual profiling mode. If multiple profiling modes are active in a profiling session, the toolbar displays actions available for the currently displayed modes.







10.12 Capturing Heap Dump Data



You can take a heap dump when a profiling session is in progress. When you take a heap dump you are prompted to save the heap to your project or local file system. After you save a heap dump you can load the heap dump at any time and browse the objects on the heap, locate references to individual objects and compare heap dumps to view the differences between the snapshots. You do not need to have a running profiling session to load and browse the heap dump.

The application must be running on JDK 1.5.0_12 or higher to take a heap dump.

To take a heap dump using a profiling point:

	
Open the source file containing the code where you want to place the profiling point.


	
Right-click in the line of code where you want to place the profiling point and select Add Profiling Point.


	
In the Profiling Point Type list, select one of the following snapshot options and click Next:

	
Take Snapshot


	
Timed Take Snapshot


	
Triggered Take Snapshot





	
In the Customize Properties page of the wizard, select Heap Dump as the type of snapshot and modify any additional settings. The Heap Dump option is available under Settings > Take.




When you use a profiling point to take a heap dump, you specify the point in your source code where you want to place the profiling point. For example, you may want to take a heap dump when a thread enters a specific method.

To take a heap dump on OutOfMemory error:




	From the Main menu, select Tools > Preferences > Profiler.
	In the On OutOfMemoryError list, select an option from the drop-down list to specify what the IDE does when an OutOfMemoryError is encountered.

The default behavior is to save the heap dump to the profiled project.










10.12.1 Viewing UI Elements with Heap Walker


The heap dump viewer (Heap Walker) displays logical values of objects such as String value, File path, URL address, etc. In addition, it also provides a visual snapshot of UI attributes and elements such as Color, Font, Button, etc.

For most classes and instances represented in the heap dump, the textual and numerical properties are adequate for describing and examining data structures and for discovering bugs such as memory leaks, inefficient memory usage and others. However, for many types of objects, the in-memory representation is not suited for quickly determining what the object is.

The visual representation feature is ideal for examining UI elements, where displaying object properties is not precise enough to aid users in identifying the exact location of the application UI. For example, by just reading position, size and references to nested elements of an UI container the user may not realize that an object may represent an Open File dialog created by the application.

Access the image representation of a heap dump element by browsing through the instance of a given class. Figure 10-7 shows Heap Walker panels including a visual preview of the application window at the point when the heap has been dumped.


Figure 10-7 Heap Walker - Image Preview

[image: img/GUID-0B10306F-0FBB-44A9-8F54-7424CC05BCCD-default.png]





10.12.1.1 Image Preview Use Cases


The Heap Walker image preview is useful in the following use cases:

	
Identifying selected UI element. Browse instances of the desired type when you need to find a particular UI element like Button, Label, etc


	
Determining application state at the time of dumping the heap. Bugs reported by users often do not contain all the necessary information or miss important details. By displaying the application UI users can immediately see that for example a text document was being loaded when an out of memory exception was thrown.


	
Searching for UI snippets unintentionally kept in memory. Parts of the UI are sometimes not being released from memory, which can cause serious problems given that tables, trees or editors often reference very large data models. By browsing for example Panel elements users can easily discover these snippets, realize how much memory is being wasted and identify the problem preventing the UI from being released.


	
Discovering duplicities. By browsing Images, for example, users can immediately see multiple instances of the same image being allocated in memory, which is a waste of resources.


	
Offline UI analysis. Heap Walker is able to recreate the UI structure from a heap dump. This way an UI developer can analyze the UI building blocks without access to the actual application, which could be running on a different and incompatible system




It is important to note the following exceptions to the Image Preview function:

	
No support for viewing tree data.


	
Foreground, background or font attributes may not show on certain implementations.


	
Custom controls cannot be displayed.


	
UI text for certain elements may not fully display in the Instance view.












10.12.2 How to Analyze a Heap Dump Using Object Query Language (OQL)



OQL is a SQL-like query language to query a Java heap that enables you to filter/select information wanted from the Java heap. While pre-defined queries such as "show all instances of class X" are already supported by the tool, OQL adds more flexibility. OQL is based on JavaScript expression language.

When you load a Java heap in the Heap window, you can click the OQL Console tab of the window to open the OQL editor. The OQL Console contains an OQL editor, a saved OQL queries window and a window that displays the query results. You can use any of the sample OQL queries or create a query to filter and select heap data to locate the information that you want from the Java heap. After you choose or write a query, you can run the query against the Java heap and view the results.

An OQL query is of the following form:


select <JavaScript expression to select>
[ from [instanceof] <class name> <identifier>
[ where <JavaScript boolean expression to filter> ] ]


where class name is fully qualified Java class name (example: java.net.URL) or array class name. char[] (or [C) is char array name, java.io.File (or [Ljava.io.File;) is name of java.io.File[] and so on. Note that fully qualified class name does not always uniquely identify a Java class at runtime. There may be more than one Java class with the same name but loaded by different loaders. So, class name is permitted to be id string of the class object. If instanceof keyword is used, subtype objects are selected. If this keyword is not specified, only the instances of exact class specified are selected. Both from and where clauses are optional.

In select and (optional) where clauses, the expression used in JavaScript expression. Java heap objects are wrapped as convenient script objects so that fields may be accessed in natural syntax. For example, Java fields can be accessed with obj.field_name syntax and array elements can be accessed with array[index] syntax. Each Java object selected is bound to a JavaScript variable of the identifier name specified in from clause.







10.12.2.1 OQL Examples



Select all Strings of length 100 or more:


select s from java.lang.String s where s.count >= 100


Select all int arrays of length 256 or more:


select a from int[] a where a.length >= 256


Show content of Strings that match a regular expression:


select {instance: s, content: s.toString()} from java.lang.String s
    where /java/(s.toString())


Show path value of all File objects:


select file.path.toString() from java.io.File file


Show names of all ClassLoader classes:


select classof(cl).name 
    from instanceof java.lang.ClassLoader cl


Show instances of the Class identified by given id string:


select o from instanceof 0xd404b198 o


0xd404b198 is id of a Class (in a session). This is found by looking at the id shown in that class's page.









10.12.2.2 OQL built-in objects and functions



Heap object





The heap built-in object supports the following methods:

	
heap.forEachClass - calls a callback function for each Java Class


heap.forEachClass(callback);


	
heap.forEachObject - calls a callback function for each Java object


heap.forEachObject(callback, clazz, includeSubtypes);


clazz is the class whose instances are selected. If not specified, defaults to java.lang.Object. includeSubtypes is a boolean flag that specifies whether to include subtype instances or not. Default value of this flag is true.


	
heap.findClass - finds Java Class of given name


heap.findClass(className);


where className is name of the class to find. The resulting Class object has following properties:

	
name - name of the class.


	
superclass - Class object for super class (or null if java.lang.Object).


	
statics - name, value pairs for static fields of the Class.


	
fields - array of field objects. field object has name, signature properties.


	
loader - ClassLoader object that loaded this class.




Class objects have the following methods:

	
isSubclassOf - tests whether given class is direct or indirect subclass of this class or not.


	
isSuperclassOf - tests whether given Class is direct or indirect superclass of this class or not.


	
subclasses - returns array of direct and indirect subclasses.


	
superclasses - returns array of direct and indirect superclasses.





	
heap.findObject - finds object from given object id


heap.findObject(stringIdOfObject);


	
heap.classes - returns an enumeration of all Java classes


	
heap.objects - returns an enumeration of Java objects


heap.objects(clazz, [includeSubtypes], [filter])


clazz is the class whose instances are selected. If not specified, defaults to java.lang.Object. includeSubtypes is a boolean flag that specifies whether to include subtype instances or not. Default value of this flag is true. This method accepts an optional filter expression to filter the result set of objects.


	
heap.finalizables - returns an enumeration of Java objects that are pending to be finalized.


	
heap.livepaths - return an enumeration of paths by which a given object is alive. This method accepts optional second parameter that is a boolean flag. This flag tells whether to include paths with weak reference(s) or not. By default, paths with weak reference(s) are not included.


select heap.livepaths(s) from java.lang.String s


Each element of this array itself is another array. The later array is contains an objects that are in the 'reference chain' of the path.


	
heap.roots - returns an Enumeration of Roots of the heap.

Each Root object has the following properties:

	
id - String id of the object that is referred by this root


	
type - descriptive type of Root (JNI Global, JNI Local, Java Static, etc.)


	
description - String description of the Root


	
referrer - Thread Object or Class object that is responsible for this root or null











Examples





	
Access static field 'props' of class java.lang.System


select heap.findClass("java.lang.System").statics.props
select heap.findClass("java.lang.System").props


	
Get number of fields of java.lang.String class


select heap.findClass("java.lang.String").fields.length


	
Find the object whose object id is given


select heap.findObject("0xf3800b58")


	
Select all classes that have name pattern java.net.*


select filter(heap.classes(), "/java.net./(it.name)")








Functions on individual objects





	
allocTrace function

Returns allocation site trace of a given Java object if available. allocTrace returns array of frame objects. Each frame object has the following properties:

	
className - name of the Java class whose method is running in the frame.


	
methodName - name of the Java method running in the frame.


	
methodSignature - signature of the Java method running in the frame.


	
sourceFileName - name of source file of the Java class running in the frame.


	
lineNumber - source line number within the method.





	
classof function

Returns class object of a given Java object. The resulting object supports the following properties:

	
name - name of the class


	
superclass - class object for super class (or null if java.lang.Object)


	
statics - name, value pairs for static fields of the class


	
fields - array of field objects. Field objects have name, signature properties


	
loader - ClassLoader object that loaded this class.




Class objects have the following methods:

	
isSubclassOf - tests whether given class is direct or indirect subclass of this class or not


	
isSuperclassOf - tests whether a given class is direct or indirect superclass of this class or not


	
subclasses - returns array of direct and indirect subclasses


	
superclasses - returns array of direct and indirect superclasses




Examples

	
Show class name of each Reference type object


select classof(o).name from instanceof java.lang.ref.Reference o


	
Show all subclasses of java.io.InputStream


select heap.findClass("java.io.InputStream").subclasses()


	
Show all superclasses of java.io.BufferedInputStream


show all superclasses of java.io.BufferedInputStream 







	
forEachReferrer function

Calls a callback function for each referrer of a given Java object.


	
identical function

Returns whether two given Java objects are identical or not, for example:


select identical(heap.findClass("Foo").statics.bar, heap.findClass("AnotherClass").statics.bar)


	
objectid function

Returns String id of a given Java object. This id can be passed to heap.findObject and may also be used to compare objects for identity. For example:


select objectid(o) from java.lang.Object o


	
reachables function

Returns an array of Java objects that are transitively referred from the given Java object. Optionally accepts a second parameter that is comma separated field names to be excluded from reachability computation. Fields are written in class_name.field_name pattern.

Examples

	
Print all reachable objects from each Properties instance.


select reachables(p) from java.util.Properties p


	
Print all reachables from each java.net.URL but omit the objects reachable via the fields specified.


select reachables(u, 'java.net.URL.handler') from java.net.URL u





	
referrers function

Returns an enumeration of Java objects that hold reference to a given Java object. This method accepts optional second parameter that is a boolean flag. This flag tells whether to include weak reference(s) or not. By default, weak reference(s) are not included.

Examples

	
Print number of referrers for each java.lang.Object instance


select count(referrers(o)) from java.lang.Object o


	
Print referrers for each java.io.File object


select referrers(f) from java.io.File f


	
Print URL objects only if referred by 2 or more


select u from java.net.URL u where count(referrers(u)) > 2





	
referees function

Returns an array of Java objects to which the given Java object directly refers to. This method accepts optional second parameter that is a boolean flag. This flag tells whether to include weak reference(s) or not. By default, weak reference(s) are not included. For example, to print all static reference fields of java.io.File class:


select referees(heap.findClass("java.io.File"))


	
refers function

Returns whether first Java object refers to second Java object or not.


	
root function

If the given object is a member of root set of objects, this function returns a descriptive Root object describing why it is so. If given object is not a root, then this function returns null.


	
sizeof function

Returns size of the given Java object in bytes, for example:


select sizeof(o) from int[] o


	
retainedsize function

Returns size of the retained set of the given Java object in bytes. Note: Using this function for the first time on a heap dump may take significant amount of time.

The following is an example usage of the retainedsize function:


select rsizeof(o) from instanceof java.lang.HashMap o


	
toHtml function

Returns HTML string for the given Java object. Note that this is called automatically for objects selected by select expression. But, it may be useful to print more complex output. For example, to print a hyperlink in bold font:


select "<b>" + toHtml(o) + "</b>" from java.lang.Object o












10.12.2.3 Selecting Multiple Values



Multiple values can be selected using JavaScript object literals or arrays.

For example, show the name and thread for each thread object


select { name: t.name? t.name.toString() : "null", thread: t } 
from instanceof java.lang.Thread t





array/iterator/enumeration manipulation functions





These functions accept an array/iterator/enumeration and an expression string [or a callback function] as input. These functions iterate the array/iterator/enumeration and apply the expression (or function) on each element. Note: JavaScript objects are associative arrays. So, these functions may also be used with arbitrary JavaScript objects.

	
concat function

Returns whether the given array/enumeration contains an element the given boolean expression specified in code. The code evaluated can refer to the following built-in variables.

	
it - currently visited element


	
index - index of the current element


	
array - array/enumeration that is being iterated




For example, to select all Properties objects that are referred by some static field some class:


select p from java.util.Properties p
where contains(referrers(p), "classof(it).name == 'java.lang.Class'")


	
count function

Returns the count of elements of the input array/enumeration that satisfy the given boolean expression. The boolean expression code can refer to the following built-in variables.

	
it - currently visited element


	
index - index of the current element


	
array - array/enumeration that is being iterated




For example, print the number of classes that have a specific name pattern:


select count(heap.classes(), "/java.io./(it.name)")


	
filter function

Returns an array/enumeration that contains elements of the input array/enumeration that satisfy the given boolean expression. The boolean expression code can refer to the following built-in variables.

	
it - currently visited element


	
index - index of the current element


	
array - array/enumeration that is being iterated


	
result -> result array/enumeration




Examples

	
Show all classes that have java.io.* name pattern


select filter(heap.classes(), "/java.io./(it.name)")


	
Show all referrers of URL object where the referrer is not from java.net package


select filter(referrers(u), "! /java.net./(classof(it).name)")
from java.net.URL u





	
length function

Returns number of elements of an array/enumeration.


	
map function

Transforms the given array/enumeration by evaluating given code on each element. The code evaluated can refer to the following built-in variables.

	
it - currently visited element


	
index - index of the current element


	
array - array/enumeration that is being iterated


	
result -> result array/enumeration




Map function returns an array/enumeration of values created by repeatedly calling code on each element of input array/enumeration.

For example, show all static fields of java.io.File with name and value:


select map(heap.findClass("java.io.File").statics, "index + '=' + toHtml(it)")


	
max function

Returns the maximum element of the given array/enumeration. Optionally accepts code expression to compare elements of the array. By default numerical comparison is used. The comparison expression can use the following built-in variables:

	
lhs - left side element for comparison


	
rhs - right side element for comparison




Examples

	
Find the maximum length of any string instance


select max(map(heap.objects('java.lang.String', false), 'it.count'))


	
Find string instance that has the maximum length


select max(heap.objects('java.lang.String'), 'lhs.count > rhs.count')





	
min function

Returns the minimum element of the given array/enumeration. Optionally accepts code expression to compare elements of the array. By default numerical comparison is used. The comparison expression can use the following built-in variables:

	
lhs - left side element for comparison


	
rhs - right side element for comparison




Examples

	
Find the minimum size of any vector instance


select min(map(heap.objects('java.util.Vector', false), 'it.elementData.length'))


	
Find vector instance that has the maximum length


select min(heap.objects('java.util.Vector'), 'lhs.elementData.length < rhs.elementData.length')





	
sort function

Sorts a given array/enumeration. Optionally accepts code expression to compare elements of the array. By default numerical comparison is used. The comparison expression can use the following built-in variables:

	
lhs - left side element for comparison


	
rhs - right side element for comparison




Examples

	
Print all char[] objects in the order of size.


select sort(heap.objects('char[]'), 'sizeof(lhs) - sizeof(rhs)')


	
Print all char[] objects in the order of size but print size as well.


select map(sort(heap.objects('char[]'), 'sizeof(lhs) - sizeof(rhs)'),  '{ size: sizeof(it), obj: it }')





	
top function

Returns top N elements of the given array/enumeration. Optionally accepts code expression to compare elements of the array and the number of top elements. By default the first 10 elements in the order of appearance is returned. The comparison expression can use the following built-in variables:

	
lhs - left side element for comparison


	
rhs - right side element for comparison




Examples

	
Print 5 longest strings


select top(heap.objects('java.lang.String'), 'rhs.count - lhs.count', 5)


	
Print 5 longest strings but print size as well.


select map(top(heap.objects('java.lang.String'),  'rhs.count - lhs.count', 5), '{ length: it.count, obj: it }')





	
sum function

Returns the sum of all the elements of the given input array or enumeration. Optionally, accepts an expression as second param. This is used to map the input elements before summing those.

For example, return the sum of sizes of the reachable objects from each Properties object:


select sum(map(reachables(p), 'sizeof(it)')) 
from java.util.Properties p
 
// or omit the map as in ...
select sum(reachables(p), 'sizeof(it)') 
from java.util.Properties p


	
toArray function

Returns an array that contains elements of the input array/enumeration.


	
unique function

Returns an array/enumeration containing unique elements of the given input array/enumeration.

The following example selects a unique char[] instances referenced from strings. Note that more than one string instance can share the same char[] for the content.


// number of unique char[] instances referenced from any String
select count(unique(map(heap.objects('java.lang.String'), 'it.value')))
 
// total number of Strings
select count(heap.objects('java.lang.String'))












10.12.2.4 Other Examples



The following example prints a histogram of each class loader and number of classes loaded by it.

java.lang.ClassLoader has a private field called classes of type java.util.Vector and Vector has a private field named elementCount that is number of elements in the vector. The query selects multiple values (loader, count) using JavaScript object literal and map function. It sorts the result by count (i.e., number of classes loaded) using sort function with comparison expression.


select map(sort(map(heap.objects('java.lang.ClassLoader'), 
'{ loader: it, count: it.classes.elementCount }'), 'lhs.count < rhs.count'),
'toHtml(it) + "<br>"')


The following example shows the parent-child chain for each class loader instance.


select map(heap.objects('java.lang.ClassLoader'),
      function (it) {
         var res = '';
         while (it != null) {
            res += toHtml(it) + "->";
            it = it.parent;
         }
         res += "null";
         return res + "<br>";
      })


Note that the parent field of java.lang.ClassLoader class is used and the example walks until the parent is null using the callback function to map call.

The following example prints the value of all System properties. Note that this query (and many other queries) may not be stable - because private fields of the Java platform classes may be modified or removed without any notification (implementation detail). But using such queries on user classes may be safe, given that you have control over the classes.


select map(filter(heap.findClass('java.lang.System').props.table, 'it != null && it.key != null && it.value != null'),
            function (it) {
                var res = it.key.toString() + ' = ' + it.value.toString();
                return res;
            });


	
java.lang.System has static field by name 'props' of type java.util.Properties.


	
java.util.Properties has field by 'table' of type java.util.Hashtable$Entry (this field is inherited from java.util.Hashtable). This is the hashtable buckets array.


	
java.util.Hashtable$Entry has key, value and next fields. Each entry points the next entry (or null) in the same hashtable bucket.


	
java.lang.String class has a value field of type char[].
















10.13 Taking and Accessing Snapshots of Profiling Data


A snapshot captures profiling data at a specific point in time and allows you to access them via the Snapshot window. See Accessing Snapshots

A snapshot differs from live profiling results in the following ways:

	
Snapshots can be examined when no profiling session is running.


	
Snapshots can be easily compared.




There are two options for taking snapshots:

	
While the profiling session is in progress. See Taking Snapshots During a Profiling Session


	
At the end of the profiling session. See Taking Snapshots at the End of a Profiling Session








10.13.1 Taking Snapshots at the End of a Profiling Session



When closing a profiled application, or if it finishes on its own, while the profiling session is in progress, the profiler asks you whether to take a snapshot of the results collected so far by displaying the Application Finished dialog.


Figure 10-8 Application Finished Dialog

[image: img/GUID-01669882-37A3-4E4D-A699-DB8A09D2D406-default.gif]


Click Yes to save the snapshot.









10.13.2 Taking Snapshots During a Profiling Session



You may take a snapshot of the profiling data at any time during the profiling session by clicking the Snapshot icon shown in the figure below.


Figure 10-9 Snapshot Icon

[image: img/GUID-272E1907-8E63-480E-8EFA-4A77376181B7-default.gif]


To control how the snapshots functionality behaves during a session, go to Tools > Preferences > Profiler and click the When taking snapshots drop-down menu to see the following options:

Open New Snapshot—it opens the snapshot right after clicking the Snapshot icon

Save New Snapshot—it saves a new snapshot every time you click the Snapshot Icon

Open and Save New Snapshot—it saves and opens a snapshot right after clicking the Snapshot icon.

You may take multiple snapshots during a profiling session and you will also be prompted to save a "final" snapshot at the end of the session.









10.13.3 Starting and Stopping the Application Finished Dialog



When the Application Finished dialog appears at the end of the profiling session, if you select the Do not show this message again checkbox the dialog would not display again. If at a later time you want to reactivate the display of this dialog, go to Tools > Preference > Profiler and click Reset button as shown in the figure below.


Figure 10-10 Reset Button in the Profiler Preferences Dialog

[image: img/GUID-6DF22B7B-BE27-47F7-98B0-7071BC6746B0-default.gif]









10.13.4 Accessing Snapshots



You may access you profiling session snapshots by going to Windows > Profiling > Snapshots. The Snapshots window appears as shown in the figure below.


Figure 10-11 Snapshot Windows

[image: img/GUID-1AA54C50-5EBD-4818-900B-5BA52C5F4733-default.gif]


At the bottom of the Snapshots window there are icons that allow you to export, open, rename, and delete selected snapshots.











10.14 How to Calibrate the Profiler



You must calibrate the IDE before you can use the IDE to profile an application. You must run the calibration process for each JDK that you use for profiling. You do this because instrumenting the bytecode of the application imposes some overhead, and the time spent in code instrumentation needs to be "factored out" to achieve more accurate results.

You only have to calibrate the IDE once for each JDK that you use. However, you should run the calibration process again when anything changes on your local or remote configuration that could affect system performance. The following could affect system performance:





	
Any hardware upgrade


	
Any significant change or upgrade of the operating system


	
An upgrade of the Java platform used for profiling




To calibrate the IDE on your local system:




	Close any other programs that are running.

The IDE runs the calibration if other applications are running, but running any CPU-intensive programs when performing the calibration might affect the accuracy of profiling results.




	Go to Tools > Preferences > Profiler > Manage Calibration Data and click the Manage button.

The Manage Calibration Data window appears.




	Select the Java Platform to be used for profiling. Click Calibrate.

You can click Java Platforms to open the Manage Libraries window to add a new Java platform. The Manage Calibration Data dialog box displays the date that the most recent calibration was performed.







When you click Calibrate, the IDE collects calibration data on the selected Java platform. When the calibration process is complete you can start using the IDE to profile your applications.

Do not share calibration data between various computers or systems.









10.15 How to Set Profiling Points



A profiling point is a marker in your source code which can invoke specific profiling actions. You set a profiling point in your code by using the popup menu in the Source Editor or by using the toolbar in the Profiling Points window.

You can set the following types of profiling points:





	
Reset Results


	
Stopwatch


	
Take Snapshot


	
Timed Take Snapshot


	
Triggered Take Snapshot




Note: Icons for the Timed Take Snapshot and Triggered Take Snapshot do not display in code editors. They only display in the Profiling Points window.

You can use a profiling point to reset profiling results, take a snapshot or record the timestamp or execution time of a code fragment.

Once you set a profiling point it becomes part of the project until you delete it.

To set a profiling point:

	
Locate the class where you want to add the profiling point and open the class in the Source Editor.


	
In the Source Editor, right-click in the gutter on the line where you want to add the profiling point.


	
Select Add Profiling Point to open the New Profiling Point wizard.


	
Select a profiling point type and the project.


	
Click Next.


	
Customize the properties of the profiling point, if necessary.


	
Click Finish.




An icon representing the profiling point type appears in the Source Editor where you inserted the profiling point.

To enable or disable a profiling point, in the Source Editor, right-click in the left margin of the line containing the profiling point and choose <Profiling point name> > Enable or Disable.

To view active profiling points:




	Open the application.
	From the main menu, select Run > Profile.. The last profile mode session is displayed. and a Profiling Points section appears.

Alternatively you may select Window > Profiling > Profiling Points.




	Use the Project or Profiling Point columns to view the defined profiling points.








10.16 Unit Testing with JUnit


JUnit is an open source regression testing framework for Java. Use JUnit to write and run tests that verify Java code.

Use JUnit wizards in JDeveloper to create test fixtures, cases, and suites. In addition to wizards for creating test components for generic projects, specialized wizards for business components projects are provided.

JUnit is an optional feature that can be installed and integrated with JDeveloper.





10.16.1 How to Install JUnit



JUnit is an optional feature that is not distributed with JDeveloper. You must download and install it if you wish to use it.


Note:

JUnit is provided under an IBM public license agreement. You must accept to the license agreement before downloading JUnit.



To install JUnit in JDeveloper:




	Navigate to Help > Check for Updates to download JUnit from the Oracle Technology Network (OTN).
	Exit and restart JDeveloper.

JUnit will be installed. Use the Extension Manager if you want to uninstall it.












10.16.2 Creating a JUnit Test for a Java Project


A JUnit test application consists of the following components:

	
One or more test cases, which invoke the methods that are to be tested, and make assertions about the expected results. While test case classes generated by default have 'Test' in their names, the user can specify any valid Java name.


	
Test fixtures, which provide the state in which the tests are run. Any class can serve as a test fixture, but JDeveloper provides wizards to help you create specialized test fixture classes. While test fixture classes generated by default have 'Fixture' in their names, the user can specify any valid Java name.


	
A test suite, which invokes the test cases. Default test suite classes have 'AllTests' in their names.


	
A runner, which invokes the test suite and collates and displays the results of the tests.










10.16.3 How to Create a JUnit Custom Test Fixture



A test fixture is a set of objects, having known values, that provide data for the test cases. Any class can serve as a test fixture, but JDeveloper provides wizards to help you create custom test fixture classes and various specialized test fixture classes.


Note:

UnitTestFixture is a public class. If you create an instance of it, there will be no errors in generated code.

AppModuleAMFixture is a private class. If you create an instance of it, there will be errors in the generated code.



To create a JUnit custom test fixture class:




	In the Applications window, select the project.
	Choose File > New > From Gallery.
	In the Categories tree, expand General and select Unit Tests.
	In the Items list, double-click Test Fixture.
	Complete the wizard to create the test fixture class.

The class created by the wizard will be opened for editing.




	Modify the file as needed.

In particular, add code that initializes test fixture objects to the setUp() method. Add code that releases any resources they acquire to the tearDown() method.












10.16.4 How to Create a JUnit JDBC Test Fixture


A test fixture is a set of objects, having known values, that provide data for the test cases. A JDBC test fixture provides code that establishes a database connection for the test cases to use.

To create a JUnit JDBC test fixture class:

	
In the Applications window, select the project.


	
Choose File > New > From Gallery.


	
In the Categories tree, expand General and select Unit Tests (JUnit).


	
In the Items list, double-click Test Fixture.


	
Complete the dialog to create the test fixture class.

The class that was created will be opened for editing.


	
Modify the file as needed. In particular, to the setUp() method add code that initializes test fixture objects, and to the tearDown() method add code that releases any resources they acquire.










10.16.5 Creating a JUnit Test Case



A test case class has one or more methods that perform tests by calling JUnit assertions. The following is a typical test case in JUnit 3.x. It passes test fixture data to the method being tested, and then compare the result with a known value to confirm that it is what is expected.


public void testCountChars()
{
      int expected = 4;
      int actual = fixture1.countChars('a');
      assertEquals(expected, actual);
}



@Test
public void testCountChars()
{
      int expected = 4;
      int actual = fixture1.countChars('a');
      Assert.assertEquals(expected, actual);
}


In the test case above, countChars() is being tested, and the result of the test is checked by assertEquals(), which is one of a variety of assertion methods defined in the JUnit Assert class. The state of the test fixture, fixture1, is established in the setUp() method, which will have been called before the test case is called, as shown below:


protected void setup() throws Exception
{
fixture1 = new StringFixture("Goin' to Kansas City, Kansas City, here I come.");
}


To create a JUnit test case class:




	In the Applications window, select the project or the particular class that you want to test.
	Choose File > New > From Gallery.
	In the Categories tree, expand General and select Unit Tests.
	In the Items list, double-click Test Case.
	In the Select the Class to Test page of the Create Test Case dialog, enter the class under test or click Browse.
	In the Class Browser dialog, locate the class you want to test or enter the beginning letters in the Match Class Name field. The Match Class list will be filtered for easier identification.

Select the class and click OK to close the dialog. Click Next.




	Select the individual methods you want to test and click Next.
	In the Setup Test Case Class page, enter the name of the test case, the package, and the class it extends and select the list of built-in functions JUnit will create stubs for. Click Next.
	In the Select Test Fixtures page, select any test fixtures you want to add to the test case or click Browse.
	Make sure that all the test fixtures you want to add to the test case are selected in the list and click Finish.

The class created by the wizard will be opened for editing.







You can create a test case specifically for an EJB application. For more information, see How to Test EJB Unit with JUnit.









10.16.6 How to Add a Test to a JUnit Test Case



You can add a unit test for a method to an existing JUnit test case class.

To add a test to a JUnit test case class:




	In the code editor, select a method for which you want to create a new unit test.
	From the main menu, choose Source > New Method Test.
	Select Add to Existing TestCase Class.
	From the Class Name dropdown box, or by using Browse, select the test case class that you want to add the new test to.
	To add the new test to the test case, click OK.








10.16.7 Creating a JUnit Test Suite



A test suite is a class that invokes test cases.

The JUnit Test Suite wizard has options to insert a main() method and a call to a TestRunner class. Within JDeveloper, this will open the JUnit TestRunner log window to display the test results. Edit the method if you wish to use a different test runner.

In the JUnit 3.x test suite shown below, the suite() method creates a TestSuite instance and adds the test cases to it. Edit this method if you wish to add or remove test cases.


public class AllTests {
    public static Test suite() {
    TestSuite suite;
    suite = new TestSuite("project1.AllTests");
    return suite;    }        


In the JUnit 4 test suite shown below, the test case classes are written with @Suite and @RunWith annotations.


@RunWith(Suite.class)
@Suite.SuiteClasses( {})
public class AllTests1 {
    public static void main(String[] args) {
    String[] args2 = { AllTests1.class.getName() };
    org.junit.runner.JUnitCore.main(args2);
    }
}


To create a JUnit test suite class:

Before you create a JUnit test case, you must have created a project that is to be tested.




	In the Applications window, select the project.
	Choose File > New > From Gallery.
	In the Categories tree, expand General and select Unit Tests (JUnit).
	In the Items list, double-click Test Suite.
	Complete the wizard to create the test suite class. The class created by the wizard displays for editing.
	Modify the file as needed. In particular:

	
In the suite() method, add the test cases.


	
In the main() method, replace the runner invocation, if desired.















10.16.8 How to Create a Business Components Test Suite



The test fixture that is created is a singleton class to reduce the number of connections. If you want to connect or disconnect for each test case, customize the test case using the JUnit 4 annotations @Before and @After.

The JUnit BC4J Test Suite wizard will generate tests for each view object in the application module. If the application module does not have exported methods, the wizard will also generate a test for the application module itself. A generated view object class has the format view_objectVOTest.java and is placed into a package with the format package.view.viewobjectVO, where package is the application module package. A generated application module test has the format application_moduleAMTest.java and is placed into a package with the format package.applicationModule. A generated test fixture class has the format applicationmoduleAMFixture.java and is placed in the same package as the application module test.

The generated all test suite class has the format AllapplicationmoduleTest.java and is placed into the package with the same name as the application module package name.

A test case XML file is also generated for each application module or view object test. The XML file contains test methods defined in the application module or view object test cases. It does not include the test methods from the base classes (if any) because there may be too many duplicates.

To create a business components test suite:




	In the main menu, choose File and then New.

You will create a separate project for the business components tests.




	In the New Gallery, expand General, select Projects and then Java Projects, and click OK.
	In the Project Name page of the Create Java Project wizard, enter a name and the directory path for the test project, and click Next.
	In the Project Java Settings page, enter the package name, the directory of the Java source code in your project, and output directory where output class files will be placed, and click Finish.
	In the Applications window, double-click the application module you want to test.
	In the overview editor, click the Java navigation tab.
	In the Java page, click the Edit icon for the Java Class section.
	In the Select Java Options dialog, select Generate Application Module Class and click OK.
	In the Java page of the overview editor, click the Edit icon for the Class Interface section.
	In the Edit Client Interface dialog, shuttle the methods you want to test to the Selected pane, and click OK.
	In the Applications window, right-click the test project you have created and choose New.
	In the New Gallery, expand General, select Unit Tests and then Business Components Test Suite, and click OK.
	In the Configure Tests page of the JUnit BC4J Test Suite wizard, select values for the following and click Next:

	
Business Component Project: Select the project that has the application module you want to test.


	
Application Module: Select the application module you want to test.


	
Configuration: Choose a local or shared application module.


	
Test Base Class-Application Module Extends: You can specify different base cases. The generated test case classes will extend from that base class where all public abstract methods in the base class will have simple and default implementation method bodies.


	
Test Base Class-View Object Extends: You can specify which class the view object extends. The generated test case classes will extend from that base class where all public abstract methods in the base class will have simple and default implementation method bodies.







	In the Summary page, verify the selections and click Finish.








10.16.9 How to Create a Business Components Test Fixture



When you create a business components test suite, a business components test fixture is created with it. You can also create Business Components test fixtures independently.

A generated test fixture class has the format applicationmoduleAMFixture.java and put into a package with the format package.applicationModule, where package is the application module package.

To create a business components test fixture:




	In the main menu, choose File > New > From Gallery.

You will create a separate project for the business components tests.




	In the New Gallery, expand General, select Projects > Java Project, and click OK.
	In the Project Name page of the Create Java Project dialog, enter a name and the directory path for the test project, and click Next.
	In the Project Java Settings page, enter the package name and the source and output directories, and click Finish.
	In the Applications window, double-click the application module you want to test.
	In the overview editor, click the Java navigation tab and then click the Edit icon for the Java Class section.
	In the Select Java Options dialog, select Generate Application Module Class, and click OK.
	In the Java page of the overview editor, click the Edit icon for the Class Interface section.
	In the Edit Client Interface dialog, shuttle the methods you want to test to the Selected pane, and click OK.
	In the Applications window, right-click the test project you have created and choose New.
	In the New Gallery, expand General, select Unit Tests and then Business Components Test Fixture, and click OK.
	In the Configure Tests page of the JUnit BC4J Test Fixture wizard, select values for the following and click Next:

	
Business Component Project: Select the project that has the application module you want to test.


	
Application Module: Select the application module you want to test.


	
Configuration: Choose a local or shared application module.







	In the Summary page, verify the test fixture class and click Finish.








10.16.10 How to Update a Test Suite with all Test Cases in the Project



You update a test suite with all test cases in a project.

To update a test suite:




	In a class that has a suite() method, from the context menu, choose Source > Refresh Test Suite.
	Ensure that all items in the list of test cases are checked.
	To update the test suite, click OK.








10.16.11 How to Run JUnit Test Suites



When your test suite has been successfully compiled you can run it.

To run a JUnit test suite:




	In the Applications window, select the test suite class.
	Right click it, and choose Run.

The test executes and the test runner displays the results.
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27 Using Java in the Database


JDeveloper supports features that allow you to write and execute Java programs that access Oracle Databases.

This chapter includes the following sections:

	
About Using Java in the Database


	
Choosing SQLJ or JDBC


	
Accessing Oracle Objects and PL/SQL Packages using Java


	
Using Java Stored Procedures








27.1 About Using Java in the Database


There are three aspects to using Java in the database:

	
Using SQLJ or JDBC, both of which can be used to embed SQL in Java programs.


	
Accessing database objects and PL/SQL packages from Java programs.


	
Using Java stored procedures, which are Java methods that reside and run inside the database.










27.2 Choosing SQLJ or JDBC


JDeveloper supports two mechanisms for embedding SQL in Java programs:

	
SQLJ: If you know the PL/SQL tables and columns involved at compile time (static application), you can use SQLJ. SQLJ is an industry standard for defining precompiled SQL code in Java programs.

SQLJ allows you to code at a higher level than JDBC, by embedding SQL statements directly in your Java code. The SQLJ precompiler that is integrated into JDeveloper translates the SQL into Java plus JDBC code for you. SQLJ with JDeveloper lets you write and debug applications much faster than you can using just JDBC.


	
JDBC: If you require fine-grained control over database access, or if you are developing an application that requires precise information about database (or instance) metadata, you can code your application entirely in Java using the JDBC API.




You can mix JDBC calls with SQLJ statements in your program. One way to do this is through connection context sharing.





27.2.1 Using SQLJ


SQLJ is a standard way to embed static SQL statements in Java programs. SQLJ applications are portable and can communicate with databases from multiple vendors using standard JDBC drivers.

SQLJ provides a way to develop applications both on the client side and on the middle-tier that access databases using Java. Developing in SQLJ is fast and efficient, and JDeveloper completely supports SQLJ development. You can create or include SQLJ files in your JDeveloper projects. When you compile a project that contains SQLJ source files, JDeveloper automatically calls the SQLJ translator, or precompiler. The translator produces completely standard Java source code, with calls to JDBC methods to provide the database support. JDeveloper then compiles the Java that the SQLJ translator generates.

For more information, see the Oracle® Database SQLJ Developer's Guide.







27.2.2 Using Oracle JDBC Drivers


JDBC provides Java programs with low-level access to databases.

Oracle JDBC drivers can be grouped into two main categories with the following attributes:

	
Java-based drivers (thin client / Type 4 driver):

	
are implemented entirely in Java


	
are highly portable


	
can be downloaded from the server system to a web browser


	
can connect using the TCP/IP protocol


	
are the only option for applets (due to security restrictions)





	
OCI-based drivers (Type 2 driver):

	
are implemented using native method libraries (OCI DLLs)


	
have OCI libraries that must be available on the client system


	
cannot be downloaded to a browser


	
can connect using any Net8 protocol


	
deliver high performance




The following figure illustrates how JDBC components and the driver run in the same memory space as an applet.


Figure 27-1 JDBC Components

[image: This image is described in the surrounding text]




The following figure illustrates how the Oracle JDBC OCI drivers run in a separate memory space from your Java application. These JDBC drivers make OCI calls to a separately loaded file.


Figure 27-2 Oracle JDBC OCI Drivers

[image: This image is described in the surrounding text]



Note:

Take care not to confuse the terms JDBC and JDBC drivers. All Java applications, no matter how they are developed or where they execute, ultimately use the JDBC-level drivers to connect to Oracle. However, coding using the pure JDBC API is low-level development, akin to using the Oracle Call Interface (OCI) to develop a database application. Like the OCI, the JDBC API provides a very powerful, but also very code-intensive, way of developing an application.









27.2.3 SQLJ versus JDBC


How does SQLJ compare to JDBC? Here are some of the advantages that SQLJ offers over coding directly in JDBC:

	
SQLJ programs require fewer lines of code than JDBC programs. They are shorter, and hence easier to debug.


	
SQLJ can perform syntactic and semantic checking on the code, using database connections at compile time.


	
SQLJ provides strong type-checking of query results and other return parameters, while JDBC values are passed to and from SQL without having been checked at compile time.


	
SQLJ provides a simplified way of processing SQL statements. Instead of having to write separate method calls to bind each input parameter and retrieve each select list item, you can write one SQL statement that uses Java host variables. SQLJ takes care of the binding for you.




However, JDBC provides finer-grained control over the execution of SQL statements and offers true dynamic SQL capability. If your application requires dynamic capability (discovery of database or instance metadata at runtime), then you should use JDBC.







27.2.4 Embedding SQL in Java Programs with SQLJ


You have to perform a number of tasks to embed SQL in Java programs with SQLJ.





27.2.4.1 How to Create SQL Files



You can create a new SQL (.sql) file and add it to the current project.

To create a SQL file:




	In the Applications window, select the project.
	From the main menu, choose File > New to open the New Gallery.
	In the New Gallery, in the Categories tree, select Database Tier then Database Files. In the Items list, double-click SQL File.
	In the Create SQL File dialog, provide the details to describe the new file.

For more information at any time, press F1 or click Help from within the dialog.




	Click OK.



An empty SQL file is added to the current project and opened for editing.









27.2.4.2 How to Create SQLJ Classes



Create a new SQLJ (.sqlj) file and add it to the current project.

To create a new SQLJ file:




	In the Applications window, select the project.
	From the main menu, choose File > New to open the New Gallery.
	In the Categories tree, expand Database Tier and select Database Files.

For more information at any time, press F1 or click Help from within the dialog.




	In the Items list, double-click SQLJ Class to open the Create SQLJ Class dialog.
	In the Create SQLJ File dialog, provide the details to describe the new file.

For more information at any time, press F1 or click Help from within the dialog.




	Click OK.



A skeleton SQLJ class will be added to the current project and be opened for editing.









27.2.4.3 How to Compile SQLJ Classes



You can compile SQLJ classes into Java .class files.

To compile a SQLJ class:




	Set the project's SQLJ translator options to control how the file is compiled in the Compiler > SQLJ page of the Project Properties dialog.
	In the Applications window, locate and select the SQLJ class.
	Right-click the class, and choose Make.



The status bar at the bottom of the JDeveloper window shows the result of the compilation. Errors, if any, are listed in the log window.









27.2.4.4 How to Use Named SQLJ Connection Contexts


A SQLJ executable statement can designate a connection context object that specifies the database connection where the SQL operation in that clause will execute. If the SQLJ statement omits the connection context clause, then the default connection context is used.







27.2.4.5 How to Declare a SQLJ Connection Context Class



A connection context is an object of a connection context class, which you define using a SQLJ connection declaration.

To declare a context class:




	Declare a context class.

Named connection contexts are not required: SQLJ statements that omit the connection context name use the default connection context.

For example, this statement declares the context class MyConnectionContext:


#sql context MyConnectionContext; 


Context classes extend sqlj.runtime.ref.ConnectionContextImpl and implement sqlj.runtime.ConnectionContext.







After you have declared a context class, create a context object.









27.2.4.6 How to Create a Connection Context Object



Before it can be used in an SQLJ statement, a declared connection context must be created.

To create a context object:




	Named connection contexts are not required: SQLJ statements that omit the connection context name use the default connection context.

For example, use this statement to create an instance thisCtx for the connection context class MyConnectionContext:


MyConnectionContext thisCtx = new MyConnectionContext (myPath, myUID, myPasswd, autocommit












27.2.4.7 How to Debug SQLJ Classes


You debug SQLJ code by debugging the SQLJ source directly, not the generated Java code.

SQLJ is debugged in JDeveloper in the same manner as other source code.

For more information, see the Oracle® Database SQLJ Developer's Guide.







27.2.4.8 How to Set SQLJ Translator Options



You can control the translation of SQLJ classes through the controls in the Project Properties dialog:





	
Provide syntactic as well as semantic checking of SQL code.


	
Provide syntax and type checking on the SQL statements.


	
Test the compatibility of Java and SQL expressions at compile time.


	
Specify a connection to a database server.


	
Check the semantics of your SQL statements against the database schemas specified by connection contexts.




To set the SQLJ translator options:




	In the Applications window, select the project that contains the SQLJ file.
	Choose Application > Project Properties > Compiler and select SQLJ.
	In the SQLJ panel, set the compilation options. These include:

	
The level at which translater warnings should be set.


	
Type of code generation.


	
Whether you want to perform SQL semantic checking against a database schema.


	
Additional options to be used in the SQLJ translator.







	Click OK.



You can set SQLJ translator properties for all projects by choosing Default Project Properties from the Application menu









27.2.4.9 How to Use SQLJ Connection Options


SQLJ connection options specify the database connection for online checking. The general form for connection options is


-option@context=value 


where option is one of the four options listed below.

The context tag is a connection context type, which permits the use of separate exemplar schemas for each of the connection contexts. If you omit the connection context type, the value will be used for any SQL statements that use the default connection context. The driver option does not allow a context tag.

The options are:

	
user This option specifies the user name for connecting to a database in order to perform semantic analysis of the SQL expressions embedded in a SQLJ program. It contains the user name, for example:


-user=hr


The user command line option may include a connection context type. For example:


-user@Ctx1=hr


Whenever a user name is required for the connection to a database context Ctx1, SQLJ uses the user option that was tagged with Ctx1. If it can not find one, SQLJ issues a message and looks for an untagged user option to use instead.

Specifying a user value indicates to SQLJ that online checking is to be performed. If you do not specify the user option, SQLJ does not connect to the database for semantic analysis. There is no default value for the user option.

If you have turned on online checking by default (by specifying, for example, -user=hr), then in order to disable online checking for a particular connection context type Ctx2, you must explicitly specify an empty user name, for example:


-user@Ctx2Z 


	
password This option specifies a password for the user. The password will be requested interactively if it is not supplied. This option can be tagged with a connection context type. Examples of the two forms are:


-password=hr
-password@Ctx1=hr 


	
url This option specifies a JDBC URL for establishing a database connection. The default is jdbc:oracle:oci9:@. This option can be tagged with a connection context type. For example:


-url=jdbc:oracle:oci8:@ -url@Ctx1=jdbc:oracle:thin:@<local_host>:1521:orcl


	
driver This option specifies a list of JDBC drivers that should be registered in order to interpret JDBC connection URLs for online analysis. The default is oracle.jdbc.driver.OracleDriver. For example:


-driver=sun.jdbc.odbc.JdbcOdbcDriver,oracle.jdbc.driver.OracleDriver


This option cannot be tagged with a connection context type.












27.2.5 Embedding SQL in Java Programs with JDBC


JDBC provides Java programs with low-level access to databases.

For more information, see the Oracle® Database SQLJ Developer's Guide.





27.2.5.1 How to Choose a JDBC Driver


JDBC uses a driver manager to support different drivers, so that you can connect to multiple database servers. To connect your database application to a data server, you must have available the appropriate JDBC driver. JDeveloper provides the Oracle Thin and OCI JDBC drivers. OCI for Oracle is the default driver. If you wish you may install a non-default JDBC driver.

Consider the following when choosing a JDBC driver to use for your application or applet:

	
If you are writing an applet, you must use the JDBC Thin driver. JDBC OCI-based driver classes will not work inside a Web browser, because they call native (C language) methods.


Note:

When the JDBC Thin driver is used with an applet, the client browser must have the capability to support Java sockets.




	
If you are writing a client application for an Oracle client environment and need maximum performance, then choose the JDBC OCI driver.


	
For code that runs in an Oracle server acting as a middle tier, use the server-side Thin driver.


Note:

JDeveloper does not supply the server-side Thin driver.




	
If your code will run inside the target Oracle server, then use the JDBC server-side internal driver to access that server. You can also access remote servers using the server-side Thin driver.


Note:

JDeveloper does not supply the server-side Thin driver.




	
If performance is critical to your application, you want maximum scalability of the Oracle server, or you need the enhanced availability features like TAF (Transparent Application Failover) or the enhanced proxy features like middle-tier authentication, then choose the OCI driver.










27.2.5.2 How to Modify a Project to Use a Non-Default JDBC Driver



If your JDeveloper programming environment has been modified to allow the use of a non-default JDBC driver, you can modify the current project to use the new driver by performing these steps.

To modify the project:




	In the Applications window, select the project.
	Choose Application > Project Properties > Profiles > Development > Libraries.
	Select the driver's library from the list displayed, and transfer it to the Selected Libraries list. The driver's library was created when you registered the driver.
	If necessary, order the list of selected libraries so that the library you have just added appears before other driver libraries, or libraries that pull in other driver libraries. These include:

	
Oracle JDBC


	
Enterprise Java Beans




If necessary, select the library you added and drag it up to the top of the list.




	Click OK to save your changes and close the dialog.








27.2.5.3 How to Code a JDBC Connection



You can establish a database connection in pure JDBC code.

A summary is given here, but for more information, see "Getting Started" in the Oracle® Database SQLJ Developer's Guide.

To code a JDBC Connection:




	Import the JDBC classes using the statement


import java.sql.*;


This statement is required for all JDBC programming.




	Register the JDBC drivers. If you are using an Oracle JDBC driver and use a constructor that uses the static Oracle.connect() method to set the default connection, the Oracle JDBC drivers are automatically registered.

Alternatively, if you are using an Oracle JDBC driver, but do not use Oracle.connect(), then you must manually register the Oracle Driver class using the statement


DriverManager.registerDriver(new oracle.jdbc.OracleDriver());


If you are not using an Oracle JDBC driver, then you must register an appropriate driver class:


DriverManager.registerDriver(new mydriver.jdbc.driver.MyDriver()); 


In any case, you must also set your connection URL, user name, and password.




	Get a connection to a data server using a getConnection() method, for example


Connection conn = DriverManager.getConnection(parameters...);
















27.3 Accessing Oracle Objects and PL/SQL Packages using Java



Use Oracle JPublisher to access Oracle objects and PL/SQL packages from your Java programs. Oracle JPublisher lets you specify and customize the mapping of Oracle object types, reference types, and collection types to Java classes in a strongly typed paradigm

You can use JPublisher to access Oracle objects and PL/SQL packages from your Java programs. JPublisher lets you specify and customize the mapping of Oracle object types, reference types, and collection types to Java classes in a strongly typed paradigm.

Also, SQLJ programmers who want to call stored procedures declared in PL/SQL packages can use JPublisher to generate SQLJ wrapper classes for the packages. The SQLJ wrapper classes let you invoke the PL/SQL stored procedures, and pass and return values from them, directly from your SQLJ program.

To access Oracle objects and PL/SQL packages using Java:




	Create the desired object data types (Oracle objects) and PL/SQL packages in the database. It is recommended that any custom classes or interfaces you use in Oracle Database implement the oracle.sql.CustomDatum interface.
	Use JPublisher to generate source code — Java and SQLJ files — that represents the Oracle objects, PL/SQL packages, user-defined types, and REF types.
	Import these classes into your application code.
	Use the methods in the generated classes to access and manipulate the Oracle Objects and their attributes.
	Compile all classes (the code generated by Oracle JPublisher and your code). The SQLJ compiler compiles the .sqlj files, and the Java or SQLJ compiler compiles the .java files.
	Run your compiled application.



This process is illustrated in the following figure:


Figure 27-3 Oracle Objects and PL/SQL Packages

[image: This image is described in the surrounding text]







27.3.1 How to Use JPublisher


Oracle JPublisher increases your productivity by letting you access Oracle objects and PL/SQL packages from your Java programs. Oracle JPublisher lets you specify and customize the mapping of Oracle object types, reference types, and collection types (VARRAYs or nested tables) to Java classes in a strongly typed paradigm


JPublisher





JPublisher increases your productivity by letting you access Oracle objects and PL/SQL packages from your Java programs. JPublisher lets you specify and customize the mapping of Oracle object types, reference types, and collection types (VARRAYs or nested tables) to Java classes in a strongly typed paradigm.

SQLJ programmers who want to call stored procedures declared in PL/SQL packages can use JPublisher to generate SQLJ wrapper classes for the packages. The SQLJ wrapper classes let you invoke the PL/SQL stored procedures, and pass and return values from them, directly from your SQLJ program.

For more information, see the Oracle Database JPublisher User's Guide.





Object Types and JPublisher





JPublisher allows your Java language applications to use user-defined object types in Oracle Database. These objects can be user-defined objects, VARRAYs, nested tables, index-by tables, or REFs to object types. If you intend to have your Java-language application access object data, then it must represent the data in a Java format. JPublisher helps you do this by creating the mapping between object types and Java classes, and between object attribute types and their corresponding Java types.

The mapping is determined by both:

	
The selected Java mapping option.


	
The object's data type category.




Additionally, JPublisher generates get and set accessor methods for each of the object's attributes, and optionally generates a wrapper method for each of the object's stored procedures. A wrapper method is a method that invokes a stored procedure that executes in the database. Wrapper methods generated by JPublisher are always instance methods even when the original object methods are static.

The following table summarizes the types of Java classes that JPublisher generates for objects.




Table 27-1 Mapping SQL Type to Java Class

	SQL type	Java class mapping
	
user-defined object type

	
Java class with accessor methods to get and set each attribute of the object, and optional wrapper methods to call the object's stored procedures.


	
VARRAY,

nested table,

index-by table.

	
Java classes that can get and set the following:

	
The entire array


	
A subset of the array


	
An individual element of the array





	
REF to an object type

	
Java class to get and set the object to which the REF refers.








Classes generated by JPublisher implement either the oracle.sql.CustomDatum interface or the java.sql.SQLData interface. Either interface makes it possible to transfer object type instances between the database and your Java program. It is recommended that you use the oracle.sql.CustomDatum interface.





PL/SQL Packages and JPublisher





You might want to call stored procedures in a PL/SQL package from your Java application. The stored procedure can be implemented in PL/SQL, or it can be a Java method that has been published to PL/SQL. Java arguments and functions are passed to and returned from the stored procedure.

To help you do this, you can direct JPublisher to create a class containing a wrapper method for each subprogram in the package. Like object methods, the wrapper methods generated for each subprogram are always instance methods even when the original method is static. The wrapper methods that JPublisher generates provide a convenient way to invoke PL/SQL stored procedures from Java code or to invoke a Java stored procedure from a client Java program.

JPublisher lets you generate Java wrappers by selecting an individual package, or by selecting the Packages node to select all of the packages in the schema. If you call PL/SQL code that includes subprograms at the top-level, JPublisher generates a single class containing a wrapper method for each top-level subprogram.

For PL/SQL functions, whether you generate Java for a single PL/SQL function or multiple functions, JPublisher generates a single class. For a single function, the class contains a single wrapper method for the function. For multiple functions, the class contains a wrapper method for each function.

For PL/SQL procedures, whether you generate Java for a single PL/SQL procedure or multiple procedures, JPublisher generates a single class. For a single procedure, the class contains a single wrapper method for the procedure. For multiple procedures, the class contains a wrapper method for each procedure





Java Mapping Options





The mapping options you select for data type categories determine the set of type mappings that JPublisher uses to translate object types and PL/SQL packages into Java classes:

	
For object types, JPublisher applies the mappings to the object's attributes and to the arguments and results of any methods included with the object. The mappings control the types that the generated accessor methods should support, that is, what types the get methods should return and the set methods should require.


	
For PL/SQL packages, JPublisher applies the mappings to the arguments and results of the methods.


	
For a collection type (that is, nested tables and VARRAYs), JPublisher applies the mappings to the element type of the collection.


	
For user-defined types (usertypes category) JPublisher generates CustomDatum classes or SQLData classes and generates code for collection and REF types.




You may select from the following mapping options:

	
Oracle Mapping represents data in PL/SQL format.


	
JDBC Mapping represents simple data types as Java primitive types.


	
Object JDBC Mapping represents simple data types as Java wrapper classes.


	
BigDecimal Mapping uses a common class to represent all numeric types.




For more information, see the Oracle Database JPublisher User's Guide.





Mapping Built-in Types





Syntax: jpub.builtintypes={jdbc|oracle}

The builtintypes parameter (and its JPublisher wizard equivalent Built-in Types) controls type mappings for all the built-in database types except the LOB and BFILE types (controlled by the lobtypes parameter) and the different numeric types (controlled by the numbertypes parameter). The following table lists the database types affected by the builtintypes parameter, and shows their Java type mappings for builtintypes=oracle and for builtintypes=jdbc (the default).




Table 27-2 Built In Mapping Types

	PL/SQL Data Type	Oracle Mapping Class	JDBC Mapping
	
CHAR

CHARACTER

LONG

STRING

VARCHAR

VARCHAR2

	
oracle.sql.CHAR

	
java.lang.String


	
RAW

LONG RAW

	
oracle.sql.RAW

	
byte[ ]


	
DATE

	
oracle.sql.DATE

	
java.sql.Timestamp











Mapping LOB Types





Syntax: lobtypes={jdbc|oracle}

The lobtypes parameter (and its JPublisher wizard equivalent LOB Types) controls type mappings for the LOB types. The following table shows how these types are mapped for lobtypes=oracle (the default) and for lobtypes=jdbc.




Table 27-3 LOB Type Mapping

	PL/SQL Data Type	Oracle Mapping Class	JDBC Mapping Class
	
CLOB

	
oracle.sql.CLOB

	
java.sql.CLOB


	
BLOB

	
oracle.sql.BLOB

	
java.sql.BLOB








The BFILE type does not appear in this table, because it has only one mapping. It is always mapped to oracle.sql.BFILE, because there is no java.sql.BFILE class.





Mapping Numeric Types





Syntax: jpub.numbertypes={jdbc|objectjdbc|bigdecimal|oracle}

The numbertypes parameter (and its JPublisher wizard equivalent Number Types) controls type mappings for numeric PL/SQL types. Four choices are available:

	
The jdbc mapping maps most numeric database types to Java primitive types such as int and float, and maps DECIMAL and NUMBER to java.math.BigDecimal.


	
The objectjdbc mapping (the default) maps most numeric database types to Java wrapper classes such as java.lang.Integer and java.lang.Float, and maps DECIMAL and NUMBER to java.math.BigDecimal.


	
The bigdecimal mapping maps all numeric database types to java.math.BigDecimal. The oracle mapping maps all numeric database types to oracle.sql.NUMBER.


	
The oracle mapping maps all numeric database types to oracle.sql.NUMBER.




The following table lists the PL/SQL types affected by the numbertypes option, and shows their Java type mappings for numbertypes=jdbc and numbertypes=objectjdbc (the default).




Table 27-4 Numeric Type Mapping

	PL/SQL Data type	JDBC Mapping Class	Object JDBC Mapping
	
BINARY_INTEGER

INT

INTEGER

NATURAL

NATURALN

PLS_INTEGER

POSITIVE

POSITIVEN

SIGNTYPE

	
int

	
java.lang.Integer


	
SMALLINT

	
short

	
java.lang.Float


	
REAL

	
float

	
java.lang.Double











Mapping User-Defined Types





Syntax: jpub.usertypes={oracle|jdbc}

The usertypes parameter (and its JPublisher wizard equivalent User Types) controls whether JPublisher generates CustomDatum classes or SQLData classes for user-defined types:

	
When usertypes=oracle (the default), JPublisher generates CustomDatum classes for object, collection, and REF types.


	
When usertypes=jdbc, JPublisher generates SQLData classes for object types. JPublisher does not generate anything for collection or REF types. Use java.sql.Array for all collection types, and java.sql.Ref for all REF types.












27.3.2 JPublisher Output


JPublisher generates a Java class for each object type that it translates. For each object type, JPublisher generates a type.java file (or a type.sqlj file if wrapper methods were requested) for the class code and a typeRef.java file for the code for the REF class of the Java type. For example, if you define an EMPLOYEE PL/SQL object type, JPublisher generates an employee.java file and an employeeRef.java file.

For each collection type (nested table or VARRAY) it translates, JPublisher generates a type.java file. For nested tables, the generated class has methods to get and set the nested table as an entire array and to get and set individual elements of the table. JPublisher translates collection types when generating CustomDatum classes but not when generating SQLData classes. JPublisher does not generate a typeRef.java file for nested tables or VARRAYs. This is because PL/SQL does not allow a REF to be made to these types.

For PL/SQL packages, JPublisher generates classes containing wrapper methods as SQLJ files. JPublisher also generates method wrappers in your class that invoke the associated package methods executing in the server. This is specified by the Include Methods option.


Note:

Since version 8.1.6, the wrapper methods that JPublisher generates to invoke stored procedures are in SQLJ only. Classes generated by JPublisher that contain wrapper methods must be compiled by SQLJ.









27.3.3 Properties Files


A properties file is an optional text file where you can specify frequently used parameters or parameters that you cannot specify in the JPublisher wizard. Note that if you need only the default output of JPublisher, then you do not need a properties file.

The properties file is designated in the JPublisher wizard.

In a properties file, you enter one (and only one) parameter and its associated value on each line. Each parameter name must be preceded with the prefix "jpub." and you cannot use any white space within a line. You can enter any parameter except the props parameter in the properties file. JPublisher processes the parameters, in order, from the top of the list to the bottom. If you specify a parameter more than once, JPublisher uses the last encountered value.

A properties file might contain the following:


jpub.case=lower
jpub.package=package1
jpub.numbertypes=jdbc
jpub.lobtypes=jdbc
jpub.builtintypes=jdbc
jpub.usertypes=jdbc
jpub.omit_schema_names
jpub.methods=true
jpub.input=mySchema.txt
jpub.sql=employee:oracleEmployee







27.3.4 How to Enhance JPublisher-Generated Classes


You can enhance the functionality of a custom Java class generated by JPublisher by adding methods and transient fields to it. For example:

	
Extend the class. That is, treat the JPublisher-generated class as a superclass, write a subclass to extend its functionality, and then map the object type to the subclass.


	
Write a new class that delegates the functionality provided by the JPublisher-generated class to a field whose type is the generated class.


	
Add methods to the class. This is not recommended if you anticipate running JPublisher at some future time to regenerate the class. If you regenerate a class that you have modified in this way, your changes (that is, the methods you have added) will be overwritten. Even if you direct JPublisher output to a separate file, you will still need to merge your changes into the file.










27.3.5 How to Extend JPublisher-Generated Classes


The Declaration Name and Use Name fields in the JPublisher wizard give you the flexibility of extending generated classes. In the Declaration Name field, enter the name of the class that you want JPublisher to generate from the given database object. In the Use Name field, enter the name of the class that your Java program will use to represent the database object.

When publishing an object type where Use Name is different from Declaration Name, JPublisher creates a declaration_name.sqlj file and a use_nameRef.java file, where use_name represents the object type in your Java program.

JPublisher expects that you have written the class use_name, which extends declaration_name. If you do not provide this class, then the use_nameRef.java file will not compile.

For example, suppose you want JPublisher to generate the class JAddress from the PL/SQL object type ADDRESS. You have also written a class, MyAddress, to represent ADDRESS objects, where MyAddress either extends the functionality provided by JAddress or has a JAddress field.

Under this scenario, select ADDRESS in the Database Browser and right-click Generate Java. In the JPublisher wizard, enter JAddress in the Declaration Name field and MyAddress in the Use Name field. JPublisher will generate the custom Java class JAddress, and map the ADDRESS object to the MyAddress class—not to the JAddress class. JPublisher will also produce a reference class for MyAddress, not JAddress.

This is how JPublisher will alter the code it generates:

	
JPublisher generates the REF class MyAddressRef rather than JAddressRef.


	
JPublisher uses the MyAddress class, instead of the JAddress class, to represent attributes whose database type is ADDRESS. This situation occurs in classes generated by JPublisher, or in classes written by the user.


	
JPublisher uses the MyAddress class, instead of the JAddress class to represent VARRAY and nested table elements whose database type is ADDRESS.


	
JPublisher will use the MyAddress factory, instead of the JAddress factory, when the CustomDatumFactory interface is used to construct Java objects whose database type is ADDRESS. This situation will occur both in classes generated by JPublisher, and in classes written by the user.




The class that you create (for example, MyAddress.java) must have the following features:

	
The class must have a no-argument constructor. The easiest way to construct a properly initialized object is to invoke the constructor of the superclass, either explicitly or implicitly.


	
The class must implement the CustomDatum interface. The simplest way to do this is to inherit the toDatum() method from the superclass.


	
You must also implement the CustomDatumFactory interface, either in the same class or in a different one. For example, you could have a class Employee that implements CustomDatum and a class EmployeeFactory that implements CustomDatumFactory.










27.3.6 JPublisher Options



JPublisher options can be set for these types of PL/SQL subprograms in your schema.





How to Set JPublisher Options





JPublisher options can be set for these types of PL/SQL subprograms in your schema:

	
Functions


	
Package Bodies


	
Packages


	
Procedures




For more information, see the Oracle® Database JPublisher User's Guide.

To set JPublisher options for PL/SQL subprograms in a schema:

	
In the Connection Manager, navigate a schema to find and select the node for the subprogram type


	
Right-click and choose Generate Java to launch the JPublisher wizard. For more help at any time, press F1 or click Help in the wizard.








How to Generate Classes for Packages and Wrapper Methods for Methods





Set the JPublisher methods option in the JPublisher wizard by checking Include Methods

The value of the methods option determines whether JPublisher generates classes for PL/SQL packages and wrapper methods for methods in packages and object types.

If selected, JPublisher generates PL/SQL classes and methods. This is default behavior.

If not selected, JPublisher does not generate PL/SQL classes and methods.





How to Omit the Schema Name from Generated Names





Set the JPublisher omit_schema_names option in the JPublisher wizard by checking the Omit Schema Names box.

The value of the omit_schema_names option determines whether certain object type and PL/SQL wrapper names generated by JPublisher include the schema name. If an object type or wrapper name generated by JPublisher does not include the schema name, the type or wrapper is looked up in the schema associated with the current connection when the code generated by JPublisher is executed. This makes it possible for you to use classes generated by JPublisher with a connection other than the one used when JPublisher was invoked. However, the type or package must be declared identically in the two schemas.

If selected, an object type or wrapper name generated by JPublisher is qualified with a schema name only if either:

	
You declare the object type or wrapper in a schema other than the one to which JPublisher is connected; or


	
You declare the object type or wrapper with a schema name in the properties file or INPUT file.




That is, an object type or wrapper from another schema requires a schema name to identify it, and the use of a schema name with the type or package in the properties file or INPUT file overrides the omit_schema_names option.

If not selected, every object type or wrapper name generated by JPublisher is qualified with a schema name. This is default behavior.





How to Set the Package Name for Generated Classes





The package option specifies the name of the Java package JPublisher generates. The name of the package appears in a package declaration in each Java file. The directory structure also reflects the package name. An explicit name in the INPUT file, after the sql option, overrides the value given to the package option.

To set the package option:




	Set the JPublisher package option in the JPublisher wizard by providing a name in the Package field.










27.4 Using Java Stored Procedures


A Java stored procedure is a Java method that resides and runs in a database. Stored procedures can help improve the performance of database applications because they are efficient: they are stored in the RDBMS in executable form, and run in the RDBMS (rather than the client) memory space.

Use JDeveloper to write methods in Java for new stored procedures and deploy them to Oracle Database. When you deploy a Java class to Oracle, you can select the methods that you want to publish to PL/SQL for use as stored procedures. Methods can be deployed together in a package or separately.

For more information, see "Developing Java Stored Procedures" in the Oracle® Database JPublisher User's Guide.

A stored procedure is a program that resides and runs in a database. Application developers can use stored procedures to help improve the performance of a database application. Procedure calls are quick and efficient because a stored procedure is compiled once and stored in an executable form. Because a stored procedure runs in the RDBMS memory space, complex functions run faster than a routine run by a client. You can also use stored procedures to group PL/SQL statements so that they are executed in a single call. This reduces network traffic and improves round-trip response times. By designing applications around a common set of stored procedures, you can avoid redundant coding and increase your productivity.

A Java stored procedure contains Java public static methods that are published to PL/SQL and stored in Oracle Database for general use. To publish Java methods, you write call specifications, that map Java method names, parameter types, and return types to their PL/SQL counterparts. This allows a Java stored procedure to be executed from an application as if it were a PL/SQL stored procedure. When called by client applications, a Java stored procedure can accept arguments, reference Java classes, and return Java result values.


Figure 27-4 Java Stored Procedure Deployment

[image: This image is described in the surrounding text]


Any Java class can be deployed to Oracle Database and the conforming methods of the class can be published to PL/SQL as stored procedures. These Java stored procedures can then be executed from an application as if they were PL/SQL stored procedures. Java stored procedures can be an entry point for your application into other (Java and non-Java) procedures deployed to Oracle Database.

Deploying and publishing Java stored procedures to Oracle Database generates call specifications that act as PL/SQL wrappers for each of the methods selected for publishing. The PL/SQL wrappers allow the stored procedures to be accessible from SQL*Plus, JDBC, or any other Oracle application environment.

The call specifications (the PL/SQL wrappers) for Java stored procedure packages and methods deployed to a database schema can be inspected through Oracle Database connection. Only published Java stored procedures appear as PL/SQL blocks, and only public static methods in Java classes can be published to PL/SQL when deployed. Java classes can be deployed without being published, in which case they are not seen in the PL/SQL nodes.

Depending on how Java stored procedures were published, they appear in one of the following nodes under a schema:

	
Packages include call specs for Java stored procedures deployed in packages.


	
Functions include call specs for Java stored procedures deployed as functions (that return a value).


	
Procedures include call specs for Java stored procedures deployed as procedures (that do not return a value).




To view a Java stored procedure's call specification, find its node in the schema's hierarchy, and double-click it.


How to Create Java Stored Procedures




You create Java stored procedures by first developing business application logic in a Java class file. Declare methods that are to become stored procedures as public static.

Use the editor in JDeveloper to add and edit business logic in the Java class. During deployment to Oracle Database, all public static methods included in the class file are available to be published to PL/SQL as stored procedures. You can choose which public static methods in the class to be published to PL/SQL.

There are different JDeveloper Java stored procedure creation scenarios:

	
Use an existing Java class and make any necessary edits to the public static methods in the class that will be deployed to Oracle Database. The existing class could include public static methods used for validation or database triggers. The methods in the class might also be in local use by several applications. These methods could be deployed to Oracle Database and used by multiple applications from the database. The deployed methods could also supplement existing PL/SQL stored procedures and functions.


	
Create a new class with methods designed for publishing as stored procedures. Use the editor in JDeveloper to create the public static methods that will be exposed as stored procedures. Write in industry-standard Java and use the original Java class for other application deployments. In Oracle Database, this programming could supplement existing PL/SQL stored procedures.




For example, assume the following Java package Welcome was created with the public class Greeting and the public static method Hello().


package Welcome;
 public class Greeting {
 public static String Hello() {
 return "Hello World!";
 }


When this package is deployed to Oracle Database and the Hello() method is published there, the call spec for the package as viewed in the source editor looks like this:


PACKAGE WELCOME AS
FUNCTION HELLO RETURN VARCHAR2
AS LANGUAGE JAVA
NAME 'Welcome.Greeting.Hello() return java.lang.String'
END WELCOME;



How to Deploy Java Stored Procedures




You create a deployment profile for Java stored procedures, then deploy the classes and, optionally, any public static methods in JDeveloper using the settings in the profile.

Deploying to the database uses the information provided in the Deployment Profile wizard and two Oracle Database utilities:

	
loadjava loads the Java class containing the stored procedures to Oracle Database.


	
publish generates the PL/SQL call spec wrappers for the loaded public static methods. Publishing enables the Java methods to be called as PL/SQL functions or procedures.




To deploy Java stored procedures in JDeveloper:

	
If necessary, create a database connection in JDeveloper.


	
If necessary, create a deployment profile for Loadjava and Java stored procedures.


	
Deploy the objects.





How to Create a Deployment Profile for Loadjava and Java Stored Procedures




The Loadjava and Java stored procedure deployment profile is very similar to the simple archive profile, except that the selected contents of the profile will be uploaded into Oracle Database via the command-line tool loadjava or in the case of Java stored procedures, they are stored in Oracle Database for general use.


Note:

Make sure that you have configured a database connection in JDeveloper before you complete this task.



To create a deployment profile for Loadjava or Java stored procedures in JDeveloper:

	
In the Applications window, select the project in which you want to create the deployment profile.


	
Choose File > New to open the New Gallery.


	
In the Categories tree, expand Database Tier and select Database Files. In the Items list, double-click Loadjava and Java Stored Procedures.

If the category or item is not found, make sure the correct project is selected, and select All Technologies in the Filter By dropdown list.


	
In the Create Deployment Profile dialog, specify a location for the deployment profile or accept the defaults. The deployment profile is named with a .dbexport filename extension.


	
Click Save to display the Loadjava and Java Stored Procedures Deployment Profile Settings dialog. Configure the settings for each page as appropriate, and click OK when you are done.

The newly created storedProc.dbexport deployment profile appears in the Applications window below the specified project.


	
Select and right-click storedProc.dbexport in the Applications window. Choose from the available context menu options.


	
(Optional) If you choose Add Stored Procedure Package, choose the methods you want to load as a stored procedure. For each Java method callable from SQL a call spec is required, which exposes the method's top-level entry point to the database. Typically, only a few call specs are needed. JDeveloper generates the call spec for you from this page.


	
Select a method and click Settings.

If a method on the list is dimmed, this indicates a problem with deploying this method as a Java stored procedure. Click Why not? for an explanation.

For more information, see "Developing Java Stored Procedures" in the Oracle® Database JPublisher User's Guide.


	
Configure the Method Settings as required. These settings allow you to customize the parts of the CREATE PROCEDURE and CREATE FUNCTION SQL statements that are used to customize the stored procedure.


	
(Optional) Right-click and choose Preview SQL Statements to display a dialog that shows the SQL statements used to load the specifically selected item in the Applications window. In the case of top-level procedures or functions and packages, you will see complete SQL statements. In the case of packaged procedures or functions, you will only see fragments of SQL statements which represent the portion of the CREATE PACKAGE BODY statement corresponding to the packaged procedure or function.

	
(Optional) If you choose Add PL/SQL Package, enter the name of a PL/SQL package that you want to start building.


	
(Optional) Right-click and choose Preview SQL Statements to display a dialog that shows the SQL statements used to load the specifically selected item in the Applications window. In the case of top-level procedures or functions and packages, you will see complete SQL statements. In the case of packaged procedures or functions, you will only see fragments of SQL statements which represent the portion of the CREATE PACKAGE BODY statement corresponding to the packaged procedure or function.


	
To deploy the profile, see Deploying Loadjava and Java Stored Procedures Profile.








How to Deploy to Oracle Databases




If necessary:

	
Create a database connection in JDeveloper.


	
Create a deployment profile for Loadjava and Java stored procedures.





Note:

If you are deploying to Oracle9i Database release 2 (9.2) or later, set the compiler's target to 1.1 or 1.2. in the Project Properties dialog, available from the Application menu.



To deploy Loadjava and Java stored procedures in JDeveloper:

	
Right-click storedProc.deploy which appears in the Applications window below the specified project.


	
From the context menu, choose Export to and select one of the already existing database connections; the Java application's source files are uploaded directly into the selected database.

Or, choose New Connection to display the Create Database Connection Wizard.


	
(Optional) If you want to edit the deployment profile, right-click storedProc.deploy in the Applications window below the specified project and choose Settings.





Note:

If you are deploying your files as both compiled files and source files and you have selected either -resolve or -andresolve in the Resolver page, then the deployment profile will only upload the source files. The reason is that when loadjava resolves the uploaded .java source files, loadjava also compiles the .java source files into .class files. You will only see the source files when previewing the loadjava deployment profile settings.




How to Invoke Java Stored Procedures




The SQL CALL statement lets you call Java stored procedures.

To invoke a Java Stored Procedure using SQL:

	
In SQL*Plus, execute the CALL statement interactively to invoke a Java stored procedure, using the syntax:


CALL [schema_name.][{package_name | object_type_name}][@dblink_name]
 { procedure_name ([param[, param]...])
 | function_name ([param[, param]...]) INTO :host_variable};
where param represents this syntax: 
{literal | :host_variable}


Host variables, that is variables declared in a host environment, must be prefixed with a colon. The following examples show that a host variable cannot appear twice in the same CALL statement, and that a subprogram with no parameters must be called with an empty parameter list:


CALL swap(:x, :x); -- illegal, duplicate host variables
 
CALL balance() INTO :current_balance; -- () required




To invoke a Java stored procedure using JDBC:

	
Java stored procedures invoked from JDBC must be encapsulated in CallableStatement objects.

Create a callable statement object:

	
Declare a callable statement object. For example:


private CallableStatement checkIn;


	
Initialize the callable statement object by calling prepareCall on the connection with a SQL CALL statement for the stored procedure. For example:


checkIn = connection.prepareCall(quot;{call NPL.CHECKIN(?, ?, ?)}");





Note:

The number of parameters in the stored procedure is represented by the number of place-holders in the SQL call.




	
Register the callable statement object's output parameters. Call registerOutParameter for each output parameter, identifying it by position, and declaring its type. For example, if the second parameter is an SQL INTEGER (which maps to a Java int), and the third is a SQL VARCHAR (which maps to a Java String), then:


newCustomer.registerOutParameter(2, Types.INTEGER); 
newCustomer.registerOutParameter(3, Types.VARCHAR); 


	
Execute the callable statement object:

	
Provide the callable statement object's input parameters by calling a set method, identifying the parameter by position, and assigning it a value. For example, if the first parameter is an int input parameter:


checkIn.setInt(1, bookID); 


	
Execute the callable statement object. For example:


checkIn.execute(); 


	
Extract the callable statement object's output parameters. Call a get method for each output parameter, identifying the parameter by position. The get methods return values of corresponding Java types. For example:


int daysLate = checkIn.getInt(2); 
String title = checkIn.getString(3); 







To invoke a Java stored procedure using SQLJ:

	
Declare and initialize input and in-out variables. For example, if the first parameter is an int input parameter:


int bookID = scanID();


	
Declare output variables. For example:


int daysLate; String title; 


	
Invoke the stored procedure in a SQLJ statement. In the statement identify the parameters by name, and designate them as :in, :out, or :inout. For example:


#sql { call NPL.CHECKIN (:in bookID, :out daysLate, :out title)}


Return values will be assigned to output and input variables.




To Invoke a Java Stored Procedure using PL/SQL

	
Use a CALL statement in the trigger body clause of a PL/SQL statement to invoke a stored procedure, and pass arguments to it.

The CALL statement's arguments can be:

	
Literal values.


	
SQL expressions, but not bind variables.


	
Column references, qualified by correlation names.




Correlation names are prefixes to column references. Use these names to qualify whether the reference applies to the existing column value of the row being processed by the trigger or the value being written by the triggering event:

	
OLD refers to the value of the column prior to the triggering operation.


	
NEW refers to the value being assigned to the column by the triggering operation. It is possible for the trigger body to redefine this value before the triggering operation occurs.




An example of a complete trigger definition:


CREATE TRIGGER check_salary
BEFORE UPDATE OF salary ON employee
CALL salaryCheck(:new.job, :old.salary, :new.salary, :old.employee


CREATE TRIGGER check_salary

BEFORE UPDATE OF salary ON employee

CALL salaryCheck(:new.job, :old.salary, :new.salary, :old.employeeID)





How to Test Java Stored Procedures




For stored procedures deployed in packages, access the stored procedure by the package name and/or the stored procedure name set during deployment. The package name may be the default name taken from the project or another name entered during deployment. The stored procedure name may be the default name taken from the method name or a name chosen for the stored procedure during deployment. Stored Procedures may also be deployed without packages.

For example, assume a public static method hello()is in the Java package Welcome and the public class Greeting. Further assume it is deployed in a package Openings.

You could execute a PL/SQL query to the deployed stored procedure that executes the public static method deployed there and returns the result. To invoke SQL*Plus from within JDeveloper, right-click a connection or select it from the Tools menu.

With a working connection to the database, your SQL*Plus client could execute the following:


package Welcome;
 public class Greeting {
 public static String Hello() {
 return "Hello World!";
 }
 }


You could execute a PL/SQL query to the deployed stored procedure that executes the public static method deployed there and returns the result. To invoke SQL*Plus from within JDeveloper, right-click a connection or select it from the Tools menu.

With a working connection to the database, your SQL*Plus client could execute the following:


select Hello() from dual;Hello()


Executing the code displays:


Hello World!



Note:

The reference to the stored procedure call spec uses package.method syntax; the name of the class from which the method originated is not part of the call.



For stored procedures deployed separately (not in packages), access the stored procedure by the stored procedure name set during deployment. The stored procedure name may be the default name taken from the method name or a name chosen for the stored procedure during deployment.

For example, for a public static method hello() that was deployed as hello from a class greeting and package welcome, you could execute a PL/SQL query to the deployed stored procedure that returns the result.

Assume the above hello() method as the example method, but this time assume it was deployed without a package.

With a working connection to the database, your SQL*Plus client could execute the following:


select Openings.Hello() from dual;
 
Openings.Hello()


The executed code displays:


Hello World!





27.4.1 How to Debug Java Stored Procedures



Debug Java stored procedures through a database connection.

To debug PL/SQL:




	Choose Window > Database > Databases window.
	Expand IDE Connections or application, and select a database connection.
	Expand a schema, and find a node with the name of the object type (for example, Package), and expand the node.
	In the node, right-click the PL/SQL program, and choose Debug.
	A Debug PL/SQL window opens. Select a target and parameter(s), and click OK.
	JDeveloper debugs the program. Check status windows for progress and information.



Additional information is available in Debugging PL/SQL Programs and Java Stored Procedures.









27.4.2 How to Remove Java Stored Procedures



To drop a stored procedure:




	Choose Window > Database > Databases window.
	Expand IDE Connections or application, and select a database connection.
	Expand the connection and select a schema.
	Expand the schema and locate the object you wish to remove. Depending on how Java stored procedures were published, they appear in one of these nodes:

	
Packages includes call specs for Java stored procedures deployed in packages.


	
Functions includes call specs for Java stored procedures deployed as functions (that return a value).


	
Procedures includes call specs for Java stored procedures deployed as procedures (that do not return a value).







	Select the object and right-click to display the context menu and choose Drop.













12 Running and Debugging Java Projects


This chapter describes how to use the tools and features provided by JDeveloper to run and debug Java programs. Debugging is the process of locating and fixing errors in your programs. The JDeveloper integrated debugger enables you to debug Java applications, applets, servlets, JavaServer Pages (JSPs), and Enterprise JavaBeans (EJBs). You can debug a single object or several of them on the same or different machine, because JDeveloper supports distributed debugging.

JDeveloper provides several debugging windows (for example, Breakpoint, Heap, and Stack) that enable you to identify problem areas in your code. In addition, the various JDeveloper debugger and runner icons available from areas in the JDeveloper user interface are described.

This chapter includes the following sections:

	
About Running and Debugging Java Programs


	
Understanding the Processes Window


	
Configuring a Project for Running


	
How to Run a Project or File


	
Debugging Java Programs


	
Using the Debugger Windows


	
Managing Breakpoints


	
Examining Program State in Debugger Windows


	
Debugging Remote Java Programs








12.1 About Running and Debugging Java Programs


JDeveloper offers several techniques to monitor and control the way Java programs run. When running Java programs, JDeveloper keeps track of processes that are run and debugged, or profiled. In addition, JDeveloper offers both local and remote debugging of Java, JSP, and servlet source files.

JDeveloper supports two types of debugging: local and remote. A local debugging session is started by setting breakpoints in source files, and then starting the debugger. When debugging an application such as a servlet in JDeveloper, you have complete control over the execution flow and can view and modify values of variables. You can also investigate application performance by monitoring class instance counts and memory usage. JDeveloper will follow calls from your application into other source files, or generate stub classes for source files that are not available.

Remote debugging requires two JDeveloper processes: a debugger and a debuggee which may reside on a different platform. Once the debuggee process is launched and the debugger process is attached to it, remote debugging is similar to local debugging.







12.2 Understanding the Processes Window


The Processes window keeps track of processes that are run, debugged, or profiled. When two or more such processes are active at the same time, the Processes window is automatically displayed. When a process has completed, it is automatically removed from the Processes window.

	
To open the Processes window, choose Window > Processes from the main menu.


	
To terminate a process within the Processes window, right-click a process in the Processes window and choose Terminate from the context menu.


	
To view the Run Log, right-click a process in the Processes window and choose View Log from the context menu.










12.3 Configuring a Project for Running


Settings that control the way programs are run - such as the target, launch options, and the behavior of the debugger, logger, and profiler - are collected in run configurations.

A project may have several run configurations, each set up for a specific facet of the project or phase of the development process. A run configuration can be bound to the project and be available to all who work on the project, or it can be custom configuration, for your use only.


Note:

Java programs that are run from JDeveloper, for example the Oracle ADF Model Tester, do not inherit the JDeveloper IDE Java options. Therefore in most cases you should set the run/debug Java options you want to use in the run configuration.







12.3.1 How to Choose a Run Configuration



A default run configuration is created for each new project. You can select it or any other configurations you have created to run a selected project.

To choose a run configuration:




	From the main menu choose Application > Project Properties.
	Select Run/Debug.


Note:

If you have not previously accessed the Run/Debug/Profile page, a button labelled Launch displays. Click the button to access the Run/Debug/Profile page.






	In the Run Configurations list, choose a run configuration.


Note:

The last edited run configuration is the active run configuration.














12.3.2 How to Create a Run Configuration



You create a new run configuration by copying an existing one, for example, Default. Then you modify the settings for the new configuration

To create a run configuration:




	Select a run configuration as described in How to Choose a Run Configuration.
	Click New.
	In the Name box, enter a name for the new run configuration.
	In the Copy Settings From dropdown box, choose an existing run configuration to copy from.
	To create a new run configuration having the same settings as the one it was copied from, click OK.
	To create a new run configuration having different settings, choose the new settings and click OK










12.4 How to Run a Project or File



After compiling your project or file, you can run it. For more information about building a project or file, see Building Java Projects The log window displays any warning or error messages that may occur during the run.

To run a project or file:




	In the Applications window, select the project or file you want to run.
	Run an application in any of these ways:

	
For a project only, from the main menu choose Run > Run > <target>.


	
Right click and from the context menu, select Run.


	
Click the Run icon on the toolbar.


	
Press the F11 key.




The main method of your Java application starts.










12.4.1 How to Run a Project from the Command Line



In order to run a project from the operating system command line:





	
The project must be a standalone executable.


	
You must select the class file containing the application main() method.




To launch an application, enter the following:


java -cp <jdev_install>\jdeveloper\jdev\mywork\Workspace1\Project1\classes package1.Application1


To launch the executable JAR file from the command line, enter the following:


java -jar <application>.jar 


where <application> is your JAR file name.









12.4.2 How to Change the Java Virtual Machine



You may need to change the Java Virtual Machine (VM) for which you are developing because of operating system considerations. For example, for client-side applications, you would use the HotSpot Client VM, whereas for executing long-running server applications, you would use the Server VM.

To change the Java Virtual Machine:




	Right-click a project in the Applications window and choose Project Properties from the context menu.
	Open the Run/Debug/Profile page.
	Select a run configuration and click Edit.

The Edit Run Configuration dialog displays.




	On the Launch Settings page, in the Virtual Machine list box, select an available option.

The selected JVM is used when running and debugging the project.




	Click Help for additional information.










12.5 Setting the Classpath for Programs


When you run a Java program from the command line, you must provide the Java Virtual Machine (JVM) with a list of the paths to the class files and libraries that comprise your application. The form of the classpath changes depending on the method you use to run the Java program.

Your Java classes can be stored in Java Archive (*.jar) files, or as separate class (*.class) files in their package directory. There are differences in the ways Java handles JAR files and package directories.

	
When you refer to JAR files in your CLASSPATH, you use the fully qualified path to the JAR file. When you refer to package directories in your CLASSPATH, you use the path to the parent directory of the package.


	
You can refer to both JARs and package directories in a CLASSPATH statement. When you refer to more than one CLASSPATH in the same statement, each CLASSPATH is separated with a semicolon(;).




Once you have defined the classpath, you pass the value to the JVM in different ways, depending on how you run your Java program.

	
Set the CLASSPATH environment variable to run a standalone application using java.exe.


	
Set the CLASSPATH environment variable to.use the -classpath option of java.exe.


	
Embed the CLASSPATH in the <APPLET> tag of an.html file to run an applet in an Internet browser.




You have the option of using either the -classpath option when calling an SDK tool (the preferred method) or by setting the CLASSPATH environment variable.





12.5.1 Setting the CLASSPATH Environment Variable (for java.exe)


The java.exe file is included as part of the Java2 Standard Edition (J2SE). It is intended to be used as a development tool, and is not licensed for distribution with your Java programs. It is used to test your Java applications from the command prompt.

In order to run a Java application from the command prompt, the system environment variable CLASSPATH must be defined to include all of the classes necessary to run your program. This includes any library classes provided with JDeveloper that your program uses.







12.5.2 Using the JDeveloper Library CLASSPATH


JDeveloper ships hundreds of library classes to help you generate your Java programs. The classes come from J2SE, third-party developers, and Oracle Corporation. Each of the libraries is kept separate for easy upgrade. As a result, many archive files may need to be included in your classpath to ensure that any program you create in JDeveloper can be run from the command prompt.

Oracle recommends that you list only the paths to each of the libraries that your project uses. If you list paths that your project does not use, your program will still run, but for performance reasons, you will want to eliminate any unnecessary libraries.


Note:

Never use quotation marks in the classpath even when there is a space character in one of the paths.









12.5.3 Setting the CLASSPATH to Include Your Projects


If you have used the default directory for your output path, you can test your Java application using java.exe by appending the following directory to your classpath:


C:\<jdev_install>\jdeveloper\jdev\mywork\Workspace1\Project1\classes


Having set this variable, you can use java.exe to run your application from the output directory mywork.

If you have deployed your Java program to any other directory, you need to add the path to the parent directory of the application package.

The CLASSPATH variable is a long string that can be difficult to type accurately. To save time and reduce errors, you can set the CLASSPATH as a system environment variable.







12.5.4 Setting the CLASSPATH Parameter (for java.exe)


The Java Runtime Engine (java.exe) doesn't use the CLASSPATH environment variable. The CLASSPATH must be included as a parameter to the java.exe command. The format for the command is:


java -cp <classpath> package.Application


Where classpath is the complete CLASSPATH to your Java program and the dependency classes it uses. Quotation marks are optional if there are no spaces in any of the CLASSPATH directory names.









12.6 Debugging Java Programs


The Debugger provides you with a number of features to investigate your code, and identify and fix problem areas. Two types of debugging are available to analyze your code - local and remote.

A local debugging session is started by setting breakpoints in source files, and then starting the debugger. When debugging an application such as a servlet in JDeveloper, you have complete control over the execution flow and can view and modify values of variables. You can also investigate application performance by monitoring class instance counts and memory usage. JDeveloper will follow calls from your application into other source files, or generate stub classes for source files that are not available.

Remote debugging requires two JDeveloper processes: a debugger and a debuggee which may reside on a different platform. Once the debuggee process is launched and the debugger process is attached to it, remote debugging is similar to local debugging.

Table 12-1 contains the special-purpose debugging windows that enable you to efficiently identify the problematic areas in your code.




Table 12-1 Debugging Windows

	Window	Description
	
Breakpoint

	
Displays the breakpoints for the current workspace and project. For more information, see How to Use the Breakpoints Window.


	
Smart Data

	
Displays the data which is being used in the code that you are stepping through. For more information, see How to Use the Smart Data Window.


	
Data

	
Displays the arguments and local variables for the current context. Note that Full Debug Info must be selected in the Compiler page of the Project Properties dialog. For more information, see How to Use the Data Window.


	
Watches

	
Displays the watches created for fields or variables. A watch evaluates an expression according to the current context. If you move to a new context, the expression is reevaluated for the new context. For more information, How to Use the Watches Window.


	
Inspector

	
Displays a single data item in its own floating window. An inspector evaluates an expression according to the current context. For more information, see How to Use the Inspector Window.


	
Heap

	
Displays information about the heap in the program you are debugging and helps you to detect memory leaks in your program. For more information, see How to Use the Heap Window.


	
Stack

	
Displays the call stack for the current thread. For more information, see Using the Stack Window.


	
Classes

	
Displays information about the classes which have been loaded as your application runs, including the name and package of each class. The debugger can also display the number of live instances of each class and the amount of memory being consumed by those instances. For more information, How to Use the Classes Window.


	
Monitors

	
Displays information for active monitors in your application, as well as information about the status of threads accessing those monitors. This window is useful for examining deadlocks and other thread synchronization problems. For more information, see How to Use the Monitors Window.


	
Threads

	
Displays the threads and the thread groups, highlights the current thread, and shows the name, status, priority, and group of each thread. For more information, see How to Use the Threads Window .











12.6.1 Understanding the Debugger Icons



Table 12-2 contains the various JDeveloper debugger and runner icons. These icons are available from areas in the JDeveloper user interface, including the Debugger window and the Log window.







Table 12-2 Debugger and Runner icons

	Icon	Name	Description
	
[image: This image is described in the surrounding text.]

	
Array

	
Represents an array class in any JDeveloper data-related window.


	
[image: This image is described in the surrounding text.]

	
Add Breakpoint

	
Represents the Breakpoint toolbar button used to create a breakpoint.


	
[image: This image is described in the surrounding text.]

	
Breakpoints menu

	
Represents the View > Debugger > Breakpoints menu option or the tab icon for the Breakpoints window.


	
[image: This image is described in the surrounding text.]

	
Class

	
Represents the View > Debugger > Classes menu option, the tab icon for the Classes window and a class in the Classes window (grayed if the class has tracing disabled).


	
[image: This image is described in the surrounding text.]

	
Class Without Line Number Tables

	
Appears in the Classes window. Represents a class which does not have line number tables (obfuscated class).


	
[image: This image is described in the surrounding text.]

	
Current Execution Point

	
Represents the current execution point shown in the source editor margin which you can display by choosing the Run > Show Execution Point menu option.


	
[image: This image is described in the surrounding text.]

	
Current Thread

	
Represents the current thread in the Threads window.


	
[image: This image is described in the surrounding text.]

	
Data

	
Represents the View > Debugger > Data menu option; the View > Debugger > Smart Data menu option; and the tab icon for the Data window and Smart Data window.


	
[image: This image is described in the surrounding text.]

	
Debug (Shift + F9)

	
Represents the Run > Debug <project_name> menu option; the debug toolbar button, a debugging process contained in the processes folder in the Processes window, a log page for a debugging process, the debug layout, and the Remote Debugging and Profiling Project Wizard.


	
[image: This image is described in the surrounding text.]

	
Debug Listener Node

	
Represents a debug listener node in the Processes window.


	
[image: This image is described in the surrounding text.]

	
Delete Breakpoint

	
Represents Delete Breakpoint in the toolbar. Click to remove a breakpoint.


	
[image: This image is described in the surrounding text.]

	
Disable

	
Represents a disabled breakpoint in the source editor margin and a disabled breakpoint in the Breakpoints window. The icon also represents the Disable Breakpoint command in the toolbar. Click to disable a breakpoint.


	
[image: This image is described in the surrounding text.]

	
Disable All Breakpoints

	
Represents Suspend All Breakpoints command in the toolbar. Click to run the application without stopping at the breakpoints, then return to debugging mode.


	
[image: This image is described in the surrounding text.]

	
Edit Breakpoint

	
Represents the Edit Breakpoint command in the toolbar, which you can use to edit the selected breakpoint.


	
[image: This image is described in the surrounding text.]

	
Enabled

	
Represents an active breakpoint in the source editor margin and the Enable Breakpoint command in the toolbar. Click to enable the selected breakpoint. When the debugger is not running, the enabled breakpoint icon looks same as the unverified breakpoint icon.


	
[image: This image is described in the surrounding text.]

	
Garbage Collection

	
Represents the Run > Garbage Collection menu option and the Garbage Collection command in the toolbar, which you can click.


	
[image: This image is described in the surrounding text.]

	
Interface

	
Represents an interface in the Classes window.


	
[image: This image is described in the surrounding text.]

	
Heap

	
Represents the View > Debugger > Heap menu option and the tab icon for the Heap window.


	
[image: This image is described in the surrounding text.]

	
Heap Folder

	
Represents a folder in the Heap window.


	
[image: This image is described in the surrounding text.]

	
Method

	
Represents a method in the Stack window.


	
[image: This image is described in the surrounding text.]

	
Monitors

	
Represents the View > Debugger > Monitors menu option and the tab icon for the Monitors window.


	
[image: This image is described in the surrounding text.]

	
Object

	
Represents an object in any JDeveloper data-related window.


	
[image: This image is described in the surrounding text.]

	
Package

	
Represents a package in the Classes window (grayed if the package has tracing disabled).


	
[image: This image is described in the surrounding text.]

	
Pause

	
Represents the Run > Pause menu option and the Pause toolbar button which you can click.


	
[image: This image is described in the surrounding text.]

	
Primitive

	
Represents a primitive item in any JDeveloper data-related window.


	
[image: This image is described in the surrounding text.]

	
Resume

	
Represents the Run > Resume menu option and the Resume toolbar button which you can click.


	
[image: This image is described in the surrounding text.]

	
Run

	
Represents a running process in the Processes window, in a log page for a running process, and in the toolbar to run the selected node.


	
[image: This image is described in the surrounding text.]

	
Run to Cursor (F4)

	
Represents the Run > Run to Cursor menu option. Lets you run to a specified location and execute the code until it reaches that location


	
[image: This image is described in the surrounding text.]

	
Stack

	
Represents the Window > Debugger > Stack menu option and the tab icon for the Stack window.


	
[image: This image is described in the surrounding text.]

	
Stack Folder

	
Represents the static folder in the Data window


	
[image: This image is described in the surrounding text.]

	
Step to End of Method

	
Represents the Run > Step to End of Method menu option and the Step to End of Method toolbar button which you can click.


	
[image: This image is described in the surrounding text.]

	
Step Into (F7)

	
Represents the Run > Step Into menu option and the Step Into toolbar button which you can click.


	
[image: This image is described in the surrounding text.]

	
Step Out (Shift + F7)

	
Represents the Run > Step > Out menu option and the Step Out toolbar button which you can click.


	
[image: This image is described in the surrounding text.]

	
Step Over

	
Represents the Run > Step Over menu option and the Step Over toolbar button which you can click.


	
[image: This image is described in the surrounding text.]

	
Terminate

	
Represents the Terminate toolbar button which you can click to stop debugging your application.


	
[image: This image is described in the surrounding text.]

	
Threads

	
Represents the Window > Debugger > Threads menu option and the tab icon for the Threads window.


	
[image: This image is described in the surrounding text.]

	
Thread Group

	
Represents a thread group in the Threads window.


	
[image: This image is described in the surrounding text.]

	
Unverified Breakpoint

	
Represents an unverified breakpoint in the source editor margin, and an unverified breakpoint in the Breakpoints window


	
[image: This image is described in the surrounding text.]

	
Verified Breakpoint

	
Represents the verified breakpoint in the source editor margin.













12.6.2 Debugging an Application Deployed to Integrated WebLogic Server


When debugging an application deployed to an integrated WebLogic Server, you can make changes to files and they will be reflected in the running application without you having to stop and redeploy the application. To debug the application, start the server in debug mode. Go to ORACLE_HOME/jdeveloper/jdev/bin and run java -? to see the run configuration options available for the version of the JDK you are running.

	
Modify JSF files

Save and refresh the browser if you are currently viewing the page that you modified, or navigate to the page if you were not on it. The page will reflect the changes you just made.


	
Save and recompile them. You can see the changes the next time the altered code is executed without having to re-start the application.




If you are stopped at a break point, you can:

	
Modify the class you are currently stopped in including the method that you are currently stopped in.


	
Right-click in the editor and rebuild the individual class.


	
Select the Stack tab (by default grouped with the Structure tab under the Applications window). At the top of the stack you will see that the method you are stopped in is obsoleted.


	
Right click on the previous method and select the Pop back to here menu item. JDev will re-position the cursor to the code that invoked the obsolete method.




When you restart execution, the changes you made to the class or method will be reflected.


Note:

you can only modify code that is private to the class. Review the console output after re-compiling. The output will make it clear whether of not the recompiled code is available for run-time.









12.6.3 How to Debug a Project in JDeveloper



Your code must be compiled with debugging information before you can make use of some of the debugger features such as viewing arguments and local variables in the Data window. This saves time when debugging and testing an application.

To set breakpoints and step through your code:




	In a source editor, set a breakpoint on an executable statement by clicking in the margin to the left of the statement. For more information, see Managing Breakpoints.

The unverified breakpoints icon appears in the left margin.




	Select Run > Debug filename.jpr.

The class runs and stops at the first breakpoint.




	From the toolbar, click Step Into to trace into a method call or click Step Over to step over a method call.
	Look in the Stack window to examine the sequence of method calls that brought your program to its current state.
	Double-click a method to display the associated source code in the source editor.
	In the Smart Data and Data windows, examine the arguments and variables.
	Display the Threads window to see the status of other threads in your program.








12.6.4 How to Edit and Recompile


While debugging, use the HotSwap feature to fix errors and substitute corrected class definitions, without stopping and restarting your application. HotSwap is an enhancement to the Java Platform Debugger Architecture (JPDA) in Java 2 SDK v1.4, and has been implemented in JDeveloper's Java virtual machine, OJVM.

When the debugger is paused you can recompile classes. When the debugger resumes after code has been HotSwapped, threads that are currently executing old method definitions will continue to do so until those methods return. For subsequent method calls, the class definition will be used. However, existing instances of the class will not be modified, and class variables will not be reset. Use HotSwap to modify the logic of class methods. In most cases you cannot use HotSwap to make more substantial changes, such as adding or removing fields or methods.






12.6.5 Using FastSwap Deployment to Minimize Redeployment


Today's Web application developers expect to make changes to a deployed application and see those changes immediately by refreshing the browser. On the Java EE side, developers typically have to go through the following cycle to see their changes in action.

Edit -> Build -> Deploy -> Test

These steps, along with the many required descriptor elements, makes developing applications with Java EE seem complex and top-heavy. Among these steps, the build and deploy cycles are necessitated by Java and by the application server being employed. IDEs are trying to make the edit and build steps seamless by providing incremental compilation support. On the server side, the WebLogic Server FastSwap deployment feature, available in JDeveloper, makes the deploy and test cycles just as seamless.




12.6.5.1 How FastSwap Deployment Works


Java EE 5 introduced the ability to redefine a class at run time without dropping its classloader or abandoning existing instances. This allowed containers to reload altered classes without disturbing running applications, vastly speeding up iterative development cycles and improving the overall development and testing experiences. The usefulness of the Java EE dynamic class redefinition is severely curtailed, however, by the restriction that the shape of the class – its declared fields and methods – cannot change. The purpose of FastSwap is to remove this restriction in WebLogic Server, allowing the dynamic redefinition of classes with new shapes to facilitate iterative development.

With FastSwap, Java classes are redefined in-place without reloading the classloader, thereby having the decided advantage of fast turnaround times. This means that you do not have to wait for an application to redeploy and then navigate back to wherever you were in the Web page flow. Instead, you can make your changes, auto compile, and then see the effects immediately.






12.6.5.2 Supported FastSwap Application Configurations


The following application configurations are supported when using FastSwap deployment:

	
FastSwap is only supported when WebLogic Server is running in development mode. It is automatically disabled in production mode.


	
Only changes to class files in exploded directories are supported. Modifications to class files in archived applications, as well as archived JAR files appearing in the application's classpath are not supported. Examples are as follows:

	
When a Web application is deployed as an archived WAR within an EAR, modifications to any of the classes are not picked up by the FastSwap agent.


	
Within an exploded Web application, modifications to Java classes are only supported in the WEB-INF/classes directory; the FastSwap agent does not pick up changes to archived JARs residing in WEB-INF/lib.












12.6.5.3 Enabling FastSwap In Your Application



To enable FastSwap in your application, create an Oracle WebLogic deployment descriptor weblogic-application.xml and enable Fast Swap.

FastSwap can also be enabled for a standalone Web application by creating the WebLogic deployment descriptorweblogic.xml and enabling Fast Swap.








12.6.5.4 Overview of the FastSwap Process


The following steps describe how the FastSwap deployment process works:

	
Once FastSwap is enabled at the descriptor level, an appropriate classloader is instantiated when the application is deployed to WebLogic Server.


	
Open a browser to see the application at work. Modify (add/edit/delete) the methods and/or classes (see Limitations When Using FastSwap) and then compile them.

Note that the FastSwap agent does not compile Java files.


	
Refresh the browser or send a new request to the application.

The FastSwap agent tries to find all classes that have been modified since the last iteration by looking at all directories in the classpath. Considering an exploded application with a single Web application, the following directories are examined for any class file modifications based on their timestamps:


ExampleApp/APP-INF/classes
ExampleApp/webapp/WEB-INF/classes


The FastSwap agent redefines the modified classes in the application and then serves the request.









12.6.5.5 Application Types and Changes Supported with FastSwap



FastSwap is supported with POJOs (JARs), Web applications (WARs) and enterprise applications (EARs) deployed in an exploded format. FastSwap is not supported with resource adapters (RARs).

The following types of changes are supported with FastSwap:

	
Addition of static methods


	
Removal of static methods


	
Addition of instance methods


	
Removal of instance methods


	
Changes to static method bodies


	
Changes to instance method bodies


	
Addition of static fields


	
Removal of static fields


	
Addition of instance fields


	
Removal of instance fields




The following table lists detailed change types supported with FastSwap:





Table 12-3 Supported Application Types and Changes

	Scope	Java Change Type	Supported	Notes
	
Java Class

	
Add method

	
Yes

	
Addition of the finalize method is not supported.


	
Instance (non-abstract)

	
Remove method

	
Yes

	
Addition of the finalize method is not supported.


		
a) Add field

	
Yes

	
		
b) Remove field

	
Yes

	
		
c) Change method body

	
Yes

	
		
d) Add constructor

	
Yes

	
		
e) Remove constructor

	
Yes

	
		
f) Change field modifiers

	
Yes

	
		
g) Change method modifiers

	
Yes

	
	
Class-level (static)

	
Add method

	
Yes

	
		
Remove method

	
Yes

	
		
Change body method

	
Yes

	
	
Class Hierarchy Changes

	
Change list of implemented interfaces

	
No

	
		
Change extends "SuperClass"

	
No

	
	
Abstract Java Class

	
Add abstract method

	
Yes

	
		
Delete abstract method

	
Yes

	
		
All other supported changes (a–g) listed in Instance

	
Yes

	
	
"final" Java Class

	
Same supported changes (a–g) listed in Instance

	
Yes

	
	
"final" Java Method

	
Same supported changes (a–g) listed in Instance

	
Yes

	
	
"final" Java Field

	
Same supported changes (a–g) listed in Instance

	
Yes

	
	
Enum

	
Add constants

	
No

	
		
Remove constants

	
No

	
		
Add/remove methods

	
No

	
	
Anonymous Inner Class

	
Add/remove fields

	
NA

	
Not supported by the Java language


	
Add/remove methods

	
No

	
	
Static Inner Class

	
Same supported changes (a–g) listed in Instance

	
Yes

	
	
Member Inner Classes (non-static inner classes)

	
Same supported changes (a–g) listed in Instance

	
Yes

	
	
Local Inner Classes

	
Same supported changes (a–g) listed in Instance

	
Yes

	
	
Java Interface

	
Add method

	
Yes

	
	
Java Reflection

	
Access existing fields/methods

	
Yes

	
		
Access new methods

	
No

	
New methods are not seen using Reflection and some synthetic methods are exposed.


		
Access new fields

	
No

	
New fields are not seen using Reflection.


	
Annotations on Classes

	
Add or remove method/field annotations

	
No

	
	
Annotation Type

	
Add or remove methods/attributes

	
No

	
	
Exception Classes

	
Same supported changes (a–g) listed in Instance

	
Yes

	
	
EJB Interface

	
Add/remove methods

	
No

	
Changes to EJB interfaces involve Reflection, which is not fully supported.


	
EJB 3.0 Session/MDB

EJB Implementation Class

	
Add/remove methods

	
No

	
Any support classes referenced by the EJB classes can be modified.


	
Add/remove fields

	
No

	
	
EJB 3.0 EntityBean

	
Add/remove methods

	
No

	
Any support classes referenced by the EJB classes can be modified.


		
Add/remove fields

	
No

	
	
EJB Interceptors

	
Add/remove methods

	
No

	
Any support classes referenced by the EJB classes can be modified.


		
Add/remove fields

	
No

	









12.6.5.6 Limitations When Using FastSwap


The following limitations apply when using FastSwap deployment:

	
Java reflection results do not include newly added fields and methods and include removed fields and methods. As a result, use of the reflection API on the modified classes can result in undesired behavior.


	
Changing the hierarchy of an already existing class is not supported by FastSwap. For example, either a) changing the list of implemented interfaces of a class; or b) changing the superclass of a class, is not supported.


	
Addition or removal of Java annotations is not supported by FastSwap, since this is tied to the reflection changes mentioned above.


	
Addition or removal of methods on EJB Interfaces is not supported by FastSwap since an EJB Compilation step is required to reflect the changes at run time.


	
Addition or removal of constants from Enums is not supported.


	
Addition or removal of the finalize method is not supported.


	
When you change a field name, the object state is not retained. This type of change occurs as follows: the field with the old name is deleted and a field with the new name is added. As such, any state in the old field is not carried over to the renamed field. You should expect an instance value to be reset when you change a field name.









12.6.5.7 Handling Unsupported FastSwap Changes


When FastSwap is enabled, after you recompile a class, FastSwap attempts to redefine classes in existing classloaders. If redefinition fails because your changes fall outside the scope of supported FastSwap changes, the JVM throws an UnsupportedOperationException in the Log window and in the server log file. Your application will not reflect the changes, but will continue to run.

To implement your changes, you can redeploy the application or affected modules (partial redeploy), depending on the application type and the extent of your changes.









12.6.6 How to Debug ADF Components



JDeveloper allows you to debug with breakpoints using the ADF Declarative Debugger. If an error cannot be easily identified, you can use the ADF Declarative Debugger in JDeveloper to set breakpoints. When a breakpoint is reached, the execution of the application is paused and you can examine the data that the Oracle ADF binding container has to work with, and compare it to what you expect the data to be. Depending on the types of breakpoints, you may be able to use the step functions to move from one breakpoint to another.

Table 12-4 contains the windows that JDeveloper provides for debugging ADF components.







Table 12-4 ADF Component Debugging Windows

	Window	Description
	
ADF Data

	
Displays relevant data based on the selection in the ADF Structure window when the application is paused at a breakpoint. For more information, see How to Use the Data Window.


	
EL Evaluator

	
Evaluates EL Expressions when a breakpoint is reached during a debugging session. Only JSF applications can use the EL Evaluator.


	
ADF Structure

	
Displays a tree structure of the ADF runtime objects and their relationships when the application is stopped at a breakpoint. For more information, see Structure Window .









You can control what type of information is displayed in each of the debugger windows. To see what options are available in each window such as which columns to display, right-click in a window and choose Preferences from the context menu. Or, you can choose Tools > Preferences from the main menu and expand the Debugger node to display a preferences page for each debugger window. You can also save the debug information as text or HTML output file. For more information. see How to Export Debug Information to a File.







12.6.6.1 How to Use JDeveloper Debugger to Execute a Program



To use the JDeveloper debugger to control the execution of a program:




	Run to a breakpoint. For more information, see Managing Breakpoints.

A breakpoint is a trigger in a program that, when reached, pauses program execution. This allows you to examine the values of some or all of the program variables. When your program execution encounters a breakpoint, the program pauses, and the debugger displays the line containing the breakpoint in the source editor.




	Step into a method and execute a single program statement at a time. For more information, see How to Step Into a Method.

If the execution point is located on a call to a method, the Step Into command steps into that method and places the execution point on the method's first statement.




	Step over a method. For more information, see How to Step Over a Method.

If you issue the Step Over command when the execution point is located on a method call, the debugger runs that method without stopping, instead of stepping into it. Program statements are executed one at a time.




	Run to the cursor location. For more information, see How to Run to the Cursor Location.

This allows you to go to a particular location in the program without having to single step or set a breakpoint.




	Pause and resume the debugger. For more information, see How to Pause and Resume the Debugger .

You can pause your program when the program is running in the debugger. You can then use the debugger to examine the state of your program with respect to this program location. When you have finished examining that part of the program, you can then continue running the program.




	Terminate a debugging session. For more information, see How to Terminate a Debugging Session..



When finished, you can modify program values as a way to test hypothetical bug fixes during a program run. If you find that a modification fixes a program error, exit the debugging session, fix your program code, and recompile the program to make the fix permanent.











12.6.7 How to Configure a Project for Debugging



JDeveloper allows you to control how your program is debugged, including enabling and disabling packages and classes and configuring remote debugging options.

To configure debugger and remote debugger options in JDeveloper:




	Choose Application > Default Project Properties (to set preferences that apply to all projects)
	Choose Application > Project Properties (to set preferences that apply only to the current project).
	Select the Run/Debug node.
	Select a run configuration. For more information, see Configuring a Project for Running.
	Click Edit.
	Select Tool Settings > Debugger.
	Set the options on the Debugger and Remote pages.
	Click OK when finished.








12.6.8 How to Set the Debugger Start Options



By setting up the debugger start option, you are specifying how you would like the debugger to behave when you start a new debugging session. Specifically, decide if you want the debugger to execute until a breakpoint is reached, or if you want the debugger to stop when it reaches your project's code (for example, at the beginning of your application's main method).

To set the debugger start options:




	From the main menu choose Tools > Preferences > Debugger.
	Select a Start Debugging option.




Table 12-5 Start Debugging Options

	Option	Description
	
Run Until a Breakpoint Occurs

	
When you start debugging, the debugger will let the program you are debugging execute until a breakpoint is reached.


	
Step Over

	
When you start debugging, the debugger will let the program you are debugging execute until a method in a tracing-enabled class is reached, but it will not stop in a class static initializer method.


	
Step Into

	
When you start debugging, the debugger will let the program you are debugging execute until any method, including a class static initializer method, is reached.














Note:

You can press F7 to display a choice of methods you want to step into. When there are multiple methods, they are highlighted when you press F7. You can click the one you want to step into.

This feature is useful there can be multiple method calls on a line, and you may be interested in a specific one that might not be the first one encountered.











12.6.9 How to Launch the Debugger



You must build the project before debugging it. The project is built using options you specify on the Compiler page of the Project Properties.

To build a project and start the debugger:




	In the Applications window, select the project.
	Right-click and choose Project Properties > Compiler.
	If not already enabled, select Full Debug Info.
	Click OK to close the dialog.
	Use one of the following methods to start the debugger:

	
To start the debugger using the current run configuration, from the main menu choose Run > Debug <target>.


	
To start the debugger using your choice of run configuration, select the dropdown menu beside the Debug icon on the toolbar and click the required run configuration name.










If the project builds successfully, the debugger starts.









12.6.10 How to Export Debug Information to a File



You can export debug information generated by the JDeveloper debugger to either a text or HTML output file from within any of the debugger windows.

To export debug information to a file:




	Start debugging by clicking Debug from the toolbar.
	Once the debugger has stopped at a breakpoint, locate the debugger window containing the information you would like to export.
	Right-click in a debugger window and choose Preferences from the context menu.
	In the appropriate Preferences - Debugger page below Columns, select which columns you want to show or hide in the debugger window and output file.
	Click OK to close the Preferences dialog.
	In the debugger window, right-click and choose Export.
	In the Export dialog, enter the name of the file. The output file is saved as a text file with tabs between columns and new lines between rows. To export to an HTML file, add the extension as.html or .htm (case-insensitive).








12.6.11 Using the Source Editor When Debugging


When the debugger stops (for example, at a breakpoint after completing a step command, or when paused), the source file for the current class will open in the source editor and will be marked with the execution point, as shown in Figure 12-1.


Figure 12-1 Execution Point Icon

[image: This image is described in the surrounding text.]


If JDeveloper cannot locate the source file for the class while debugging, the Source Not Found dialog is displayed prompting you for the source file location.

You can use the source editor to debug to:

	
Hover over a variable name to see its value.


	
Set a breakpoint, click in the source editor's margin.


	
Remove a breakpoint, click the breakpoint in the source editor's margin.


Figure 12-2 Breakpoint Icon

[image: This image is described in the surrounding text.]










12.6.12 Using Context Menu Items



The debugger adds several menu items to the source editor's context menu, including those shown in Table 12-6.







Table 12-6 Debugger Context Menu Items

	Item	Function
	
Run to Cursor

	
Run to the current location of the cursor and execute the code until it reaches that location.


	
Watch (Ctrl+F5)

	
Add an expression to the Watches Window.


	
Inspect

	
Open up a floating Inspector window.


	
Step Into Method at Cursor

	
Executes Run to Cursor, and then steps into the method that the cursor is currently on.













12.6.13 Using Tooltips


The debugger displays tooltips in the source editor if you hover the mouse over the name of a data item. By default, the tooltip will show the name, value, and type of the data item; providing an easy way to quickly inspect a data item without adding it in Data window or Watches window. If the data item is an array or object, you can inspect children of the selected item deep in the object hierarchy. The tooltip displays 20 children data items, use the navigation buttons to view remaining data items.

The columns that display in the tooltip depend on the column settings that were enabled in the Tools > Preferences – Debugger – Tooltip page.

If the project builds successfully, the debugger starts.







12.6.14 Using Java Expressions in the Debugger



Java expressions are used in the Watches window, Inspector window, Breakpoint Conditions, and Breakpoint Log Expressions. You can specify a Java expression that you want the debugger to watch or inspect. The expression must be a legal Java expression that the debugger can evaluate. The debugger accepts Java expressions in the forms shown in Table 12-7.







Table 12-7 Java Expressions Accepted by Debugger

	Java Expression	Form
	
Simple variable name

	
rect


	
Field access

	
rect.width


	
Method call

	
myString.length()


	
Array element

	
myArray[3]


	
Array length

	
myArray.length


	
Comparison operation

	
rect.height == 100 myArray.length > 7


	
Arithmetic operation

	
rect.width * rect.height x + y + z


	
Logical operation

	
frame1.enabled && frame1.visible

textField1.hasFocus || textField2.hasFocus


	
Instance of operator

	
<my_value> instanceof java.lang.String


	
Shift operator

	
x << 2

y >> 1


	
Binary Operator

	
keyEvent.modifiers & java.awt.event.InputEvent.CTRL_MASK


	
Question-colon operation

	
y>5 ? y*7 : y*4


	
Static field name

	
java.awt.Color.pink


	
Fully qualified class name

	
java.awt.Color













12.6.15 Moving Through Code While Debugging


The JDeveloper debugger lets you control the execution of your program; you can control whether your program executes a single line of code, an entire method, or an entire program block. By manually controlling when the program should run and when it should pause, you can quickly move over the sections that you know work correctly and concentrate on the sections that are causing problems. For more information, see How to Set the Debugger Start Options.

The debugger lets you control the execution of your program by:

	
Stepping into a method


	
Stepping over a method


	
Controlling which classes are traced into


	
Locating the execution point for a thread


	
Running to the cursor location


	
Pausing and resuming the debugger


	
Terminating a debugging session




The Step Into and Step Over commands offer the simplest way of moving through your program code. While the two commands are very similar, they each offer a different way to control code execution.

The smallest increment by which you step through a program is a single line of code. Multiple program statements on one line of text are treated as a single line of code – you cannot individually debug multiple statements contained on a single line of text. The easiest approach is to put each statement on its own line. This also makes your code more readable and easier to maintain.







12.6.16 How to Step Into a Method



The Step Into command executes a single program statement at a time. If the execution point is located on a call to a method, the Step Into command steps into that method and places the execution point on the method's first statement.


Note:

A warning dialog appears if you attempt to step into a line with multiple methods. Currently there is no way to turn this warning back on if you turn it off.



The Step Into action will highlight methods on a line any time it is invoked on a line with multiple methods. The current execution point determines what line of code the debugger will step into. Moving the cursor does not alter the execution point or cause a different set of methods to become available to step into.

This feature is particularly useful when a selected outer method belongs to an interface and you do not know beforehand where the method that will actually get called is implemented.

If the execution point is located on the last statement of a method, choosing Step Into causes the debugger to return from the method, placing the execution point on the line of code that follows the call to the method you are returning from.

The term single stepping refers to using Step Into to run successively though the statements in your program code.

You can step into a method in any of the following ways:





	
Select Run > Step Into.


	
Press the F7 key.


	
Click the Step Into button from the toolbar.


Figure 12-3 Step Into Button

[image: This image is described in the surrounding text.]





Note:

Step Into will only cause stepping on an already-started debugging process.



When you set the debugger to start by stepping into, the debugger will let the program you are debugging execute until a method in a tracing-enabled class is reached.

As you debug, you can step into some methods and step over others. If you are confident that a method is working properly, you can step over calls to that method, knowing that the method call will not cause an error. If you are not sure that a method is well behaved, step into the method and check whether it is working properly.









12.6.17 How to Step Over a Method



The Step Over command, like Step Into, enables you to execute program statements one at a time. However, if you issue the Step Over command when the execution point is located on a method call, the debugger runs that method without stopping (instead of stepping into it), then positions the execution point on the statement that follows the method call.

If the execution point is located on the last statement of a method, choosing Step Over causes the debugger to return from the method, placing the execution point on the line of code that follows the call to the method you are returning from.

You can step into a method in any of the following ways:





	
Select Run > Step Over.


	
Press the F8 key.


	
Click the Step Over button on the toolbar.


Figure 12-4 Step Over Button

[image: This image is described in the surrounding text.]




Unlike previous releases of JDeveloper, you cannot start debugging by clicking the Step Over button. Step Over will cause stepping only on an already-started debugging process.

When you set it to start by stepping over, the debugger will let the program you are debugging execute until a method in a tracing-enabled class is reached, but it will not stop in class static initializer method.

As you debug, you can step into some methods and step over others. If you are confident that a method is working properly, you can step over calls to that method, knowing that the method call will not cause an error. If you aren't sure that a method is well behaved, step into the method and check whether it is working properly.









12.6.18 Controlling Which Classes Are Traced Into


Normally, you should set the tracing include and exclude lists in the project properties before you start debugging. However, if you need to change the tracing include and exclude lists, you can do so from the Classes window. Right-click in the Classes window and choose Tracing from the context menu. The Tracing dialog appears in which you can adjust the tracing include and exclude lists.

When you specify a package to be included or excluded from tracing, all descending classes within that package are included or excluded as well unless you've specified them individually.

To closely examine part of your program, you can enable tracing on only the files you want to step through in the debugger. For example, you usually don't want to step through classes that are in the J2SE library because you're not going to troubleshoot on them; you usually only want to trace into your own classes.







12.6.19 How to Step Through Behavior as Guided by Tracing Lists



If you exclude a class or package, and you instruct the debugger to step into that class, the debugger runs straight through that code without pausing. The debugger pauses at the next line of code in a class which has not been excluded. The tracing include and exclude lists are used for all step commands including Step Into, Step Over, Step Out, and so on. Using these lists does not prevent you from setting a breakpoint in a class which has been excluded. If the debugger stops at such a breakpoint, the step commands will be disabled. To enable tracing for a class, you can adjust the tracing include or exclude list by adding or removing a class or package:

To adjust the tracing include or exclude list:




	Right-click a project in the Applications window and choose Project Properties from the context menu.
	Select the Run/Debug node.
	Choose a run configuration and click Edit.
	In the Edit Run Configuration dialog select Tools Settings > Debugger.
	In the Tracing Classes and Packages to Include and Tracing Classes and Packages to Exclude fields, enter the name of the packages or classes you want to include or exclude in the appropriate field, separated by a semicolon (;). For example:


oracle.xml;org.apache;org.omg;org.w3c;org.xml


You can also click Edit to open the Tracing Classes and Packages to Include/Exclude dialog, then click Add or Remove. If you click Add, the Class and Package Browser dialog appears. If you click Remove, the selected class or package is removed from the appropriate tracing List. Navigate to the class or package you want to add and click OK. The class or package is added to the appropriate tracing list.







By leaving the include lists blank, you are actually specifying that you would like to enable tracing in all packages except for those specifically listed in the exclude list. For example:


include:
exclude:java;javax









12.6.20 How to Locate the Execution Point for a Thread



When you're debugging, the line of code that is the current execution point for the current thread is highlighted and the execution point icon appears in the left margin of the source editor.

The execution point marks the next line of source code to be executed by the debugger.

To find the current execution point:




	Choose Run > Find Execution Point from the main menu.
	Right-click a thread in the Threads window and choose Go To Source of Thread.

The debugger displays the block of code containing the execution point in the source editor.












12.6.21 How to Run to the Cursor Location



When stepping through your application code in the debugger, you may want to run to a particular location without having to single step or set a breakpoint.

To run to a specific program location:




	In a source editor, position your text cursor on the line of code where you want the debugger to stop.
	Run to the cursor location in any of the following ways:

	
In the source editor, right-click and choose Run to Cursor.


	
Choose the Run > Run to Cursor option from the main menu.


	
Press the F4 key. The F4 key works unless you Operating System (OS) intercepts that key.


Note:

On ADC or SLC machines, F4 key is intercepted and never reaches the debugger.












Any of the following conditions may result:

	
When you run to the cursor, your program executes without stopping, until the execution reaches the location marked by the text cursor in the source editor.




	
If your program never actually executes the line of code where the text cursor is, the Run to Cursor command will cause your program to run until it encounters a breakpoint or when your program finishes.












12.6.22 How to Pause and Resume the Debugger



You can pause your program when the program is running in the debugger. You can then use the debugger to examine the state of your program with respect to this program location. When you have finished examining that part of the program, you can then continue running the program.

When you are using the debugger, your program can be in one of two possible states: running, or paused by the debugger. When your program is waiting for user input, it is still considered to be running. When your program is in the running mode, Pause is available. When your program is paused by the debugger, the available debugger buttons include Resume, Step Over, and Step Into.

You can pause the debugger in the following ways:





	
Choose Run > Pause from the main menu.


	
Click the Pause icon from the debugger toolbar.


Figure 12-5 Pause Icon

[image: This image is described in the surrounding text.]




Your program may be paused at a location for which there is no source available. In this case, the Source Not Found dialog displays, prompting you for the source file location or whether to generate stub files.

Also, your program may be paused at a location where tracing is disabled because the class is on the tracing exclude list. For example, your program may be paused in the java.lang.Object.wait method.

While the debugger is paused, you can force garbage collection to occur. The results of the garbage collection are immediately reflected in the Classes and the Heap window. This enables you to find memory leaks in your application.

To resume the debugger when it is paused, choose Run > Resume.









12.6.23 How to Terminate a Debugging Session



Sometimes while debugging, you will find it necessary to restart the program from the beginning. For example, you might need to restart the program if you step past the location of a bug.

To terminate the current debugging session:





	
Choose the Run > Terminate - <target> menu option, or


	
Click Terminate in the debugger toolbar.




Terminating a debugging session closes all debugger windows. However, this action does not delete any breakpoints or watches that you have set, which makes it easy to restart a debugging session.









12.6.24 How to View the Debugger Log



The Debugger log displays information about the debugging process. You can view the Debugger log at any time while the debuggee process is still active.

To view the Debugger log while the process is still active:





	
Select Window > Debugger > Log


	
In the Processes window, right-click the process and select View Log in the context menu.














12.7 Using the Debugger Windows



JDeveloper provides a number of special-purpose debugging windows to help you analyze your code and identify problem areas. You can control what type of information is displayed in each of the debugger windows. To see what options are available in each window such as which columns to display, right-click in a window and choose Preferences from the context menu. Or, you can choose Tools > Preferences from the main menu and expand the Debugger node to display a preferences page for each debugger window. You can also save the debug information as text or HTML output file.







12.7.1 How to Open Debugger Windows



You open a Debugger window by setting a breakpoint and starting a debugging session. When the Debugger stops at the breakpoint, select Window > Debugger > deubugger_window. For example, Window > Debugger > Threads. You can access the Breakpoints windows by simply starting a debugging session (it is also accessible from Window > Breakpoints)

Select one of the following Debugger windows depending on the information you want to see: Classes, Heap, Data, Log, Monitors, Stack, Smart Data, Threads, and Watches. See the following sections for information on using these windows.









12.7.2 How to Use the Breakpoints Window



Information about set breakpoints can be viewed in the Breakpoints window. For more information about this window including its context menu options, press F1 in the Breakpoints window.

To open the Breakpoints window to display a list of set breakpoints:





	
Choose Window > Breakpoints from the main menu. The Breakpoints window appears.












12.7.3 How to Use the Data Window



You use the Data window to display information about variables in your program. In the current context, which is controlled by the selection in the Stack window. If you move to a new context, the Data window is updated to show the data for the new context. If the current class was compiled without debug information, you will not be able to see the local variables. The debugger analyzes the local variable memory locations in the stack frame to show you as much information as possible.

The Data window also displays the current return value of a non-void method when you set a breakpoint in the method and issue a Step to End of Method command or Step Out command. The return value is not displayed for Step Over or Step Into commands.







12.7.3.1 How to View Array Elements in the Data Window



You can set the number of elements in an array that you want to display in the Data Window.

To view array elements in Data window:




	Start debugging the project and open Data window.
	Select the array in the Data window and expand to view its elements.

If the array contains more than 20 elements, the Data window displays first 20 elements.

	
To view the next 20 entries, click Next.


	
To view the previous 20 entries, click Previous.


	
To view the first 20 entries, click First.


	
To view the last 20 entries, click Last.


	
To change the default display size of 20, select the array, right-click and select Adjust Range from the context menu, and enter the new value in the New Count field. Click OK when you are done.

















12.7.4 How to Use the Smart Data Window


Unlike the Data window which displays all arguments, local variables, and static fields for the current method, the Smart Data window displays only the data that appears to be relevant to the source code that you are stepping through. Specifically, the debugger analyzes the source code near the execution point and finds the variables, fields, and expressions, that are used in the lines of code that you are stepping through.

For more information, see How to Locate the Execution Point for a Thread.

The Smart Data window also displays the current return value of a non-void method when you set a breakpoint in the method and issue a Step to End of Method command or Step Out command. The return value is not displayed for Step Over or Step Into commands.

By default, the debugger analyzes only one line of code for each location and analyzes up to two locations. You can adjust these settings in the Tools > Preferences - Debugger - Smart Data page which you can also access by right-clicking in the Smart Data window and choosing Preferences from the context menu.







12.7.5 How to Use the Watches Window


A watch enables you to monitor the changing values of variables or expressions as your program runs. After you enter a watch expression, the Watches window displays the current value of the expression. As your program runs, the value of the watch changes as your program updates the values of the variables in the watch expression.

A watch evaluates an expression according to the current context which is controlled by the selection in the Stack window. If you move to a new context, the expression is reevaluated for the new context. If the execution point moves to a location where any of the variables in the watch expression are undefined, the entire watch expression becomes undefined. If the execution point returns to a location where the watch expression can be evaluated, the Watches window again displays the value of the watch expression.





12.7.5.1 How to Add a Watch from the Source Editor



You can add a watch to an expression in the source editor.

To add a watch from the Source Editor:




	In the source editor, select the expression you want to watch with your cursor.
	Right-click and choose Watch from the context menu to add the expression to the Watches window.

A dialog appears with the expression.




	Edit the expression, if necessary.
	Click OK.



You can also add a watch in the following ways:

	
Right-click an item in the Data window and choose Watch from the context menu.


	
Drag and drop variables, fields, and objects from the Data window to the Watches window.












12.7.5.2 How to Watch a Static Field



To watch a static field:

Enter the full name of the class followed by a period (.) and the name of the field. For example:


java.io.File.separator


To watch the current exception while stopped at an exception breakpoint, enter:


_throw









12.7.5.3 How to Edit a Watch



You can edit a watch by selecting its expression in the Watches window.

To edit a watch:




	Select the expression in the Watches window, then right-click and choose Edit Watch.

The Edit Watch dialog appears.




	Enter a new expression or modify the existing one and click OK.








12.7.5.4 How to Delete a Watch



You can edit a watch by selecting its expression in the Watches window.

To delete a watch:




	Select the expression in the Watches window.
	Press the Delete key or right-click and choose Remove Watch from the context menu.

You can also delete all the watches by choosing Remove All Watches from the context menu.


Caution:

You cannot restore a deleted watch.
















12.7.6 How to Use the Inspector Window



The Inspector window enables you to single out a selected variable, field or object, and display the same information that is available in the Watch or Data windows. For more information about this window, including its context menu options, press F1 in the Inspector window.

The Inspector window is slightly different from the other windows in that it floats by default, and you can have multiple instances of Inspector windows. Each Inspector window contains one data item. You can drag one Inspector window into another and dock them together.

To open the Inspector Window:




	Set at least one breakpoint in the Source Editor.
	Click Debug from the toolbar.
	When the debugger reaches a breakpoint, select a variable in the Source Editor, right-click, and choose Inspect.

The floating Inspect window appears and contains the variable you selected. If you want to inspect something else, enter a new expression or variable in the text field, or select a previous one from the dropdown list.

If no variable or expression is selected, the Inspect dialog appears pre-populated with the text under the cursor in the editor as the expression to inspect. Click OK to open the Inspector window.







The Inspector window will appear floating in the center of your screen, but you can dock the Inspector window with other windows. To prevent docking, press the Ctrl key while moving the window. An inspector evaluates an expression according to the current context of the Stack window. For more information, see Using the Stack Window.

If you move to a new context, the expression is reevaluated for the new context. If the execution point moves to a new location where any of the variables in the expression are undefined, the entire expression becomes undefined. If the execution point returns to a location where the expression can be evaluated, the inspector again displays the value of that expression.









12.7.7 How to Use the Heap Window



The Heap window displays information about the heap in the program you are debugging and helps you to detect memory leaks in your program. You can view all instances of a class as well as why an object has not been garbage collected.

Two types of folders display in the Heap window:





	
Class Folder

Displays the name of the class and how many instances of the class exist in memory, and when expanded lists the specific instances and their addresses in the heap.


	
Reference Path Folder

Contains all the "root" references which point, either directly or indirectly, to a specific object. Root references are static fields, stack variables, pinned objects. The garbage collector will not discard an object if there are any root references. Expanding a root reference will show you the reference path from the root reference to the specified object.




To use the Heap window:

	
Right-click in the Heap window and choose Add New Type from the context menu. Alternatively, drag a class node from the Classes window into the Heap window. Or, right click on a class node in the Classes window and choose Display in Heap from the context menu. Information about the classes appears in the Heap window.












12.7.8 Using the Stack Window


The Stack window displays the call stack for the current thread. When you highlight a line in the Stack window, the Data window, Watches window, and all Inspector windows are updated to show data for the highlighted method.





12.7.8.1 How to Use the Stack Window


In the Stack window, you can highlight a line in the stack thread to update values in the Data, Watches, and Inspector windows.







12.7.8.2 How to View the Stack of a Tread



You can view the stack of a selected thread in the Stack window.

To view the stack of a thread:




	Start debugging the project and open the Stack window.
	Select the thread from the dropdown list, above the columns.

The Stack window immediately reflects the stack of the selected thread.














12.7.9 How to Use the Classes Window


The Classes window displays which classes have been loaded and may also include useful information, such as the number of instances of a class and how much memory that number of instances requires. In conjunction with the Classes window, the debugger also includes a garbage collection tool when you want to force a run of the Java garbage collector. When you run the garbage collector, the impact is shown immediately in the Classes window. You can only force a run of the garbage collector when you are using a virtual machine that allows the debugger to do so.





12.7.9.1 How to Change the View Order



You can change the order in which items in each column of the Classes Window displays.

To change the ascending or descending view order:





	
Click at the top of a column to change the sort order. You can sort by:

	
Name


	
Count


	
Memory


	
File







If the Show Packages check box is selected, by default the classes display in a tree structure, where each branch represents a package. Also, the icon and entry next to each class or package indicates whether the class is included or excluded from tracing. The special icon shown in Figure 12-6 for a class without line number tables is used for classes to indicate that tracing is not possible because the class has been stripped or obfuscated.


Figure 12-6 Icon Indicating Tracing Is Not Possible
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In the Classes window, choose Preferences from the context menu to select which columns to view from the following available options:

	
Count


	
Memory


	
File














12.7.10 How to Use the Monitors Window


Java supports multithreading at the language level through the use of synchronization. Synchronization is the coordinating of activities and data access among multiple threads. The mechanism that Java uses to support synchronization is the monitor. The Monitors window displays status and control information for active monitors.

The Monitors window will also open automatically if the debugger is in a deadlock state.







12.7.11 How to Use the Threads Window



The Threads window displays the names and status of all the threads and thread groups in your program. The columns that display in this window depend on those column settings that are enabled in the Tools > Preferences > Debugger > Threads page or by choosing Preferences from the Threads window context menu options which you can access by right-clicking in the Threads window

The step commands including Step Over, Step Into, and Set Next Statement apply to the current thread. To select a different thread, right-click a thread and choose Select Thread from the context menu.

When you highlight a thread in the Threads window, the Stack window is automatically updated to show the stack for the highlighted thread.









12.7.12 How to Set Preferences for the Debugger Windows



You can choose to customize various debugger window settings including the column resize mode and other options you want to display.


Tip:

If the debugger has trouble connecting to the debuggee (the program you are debugging), try increasing the connection retry setting.



To set any of the Debugger window preferences:




	Choose Tools > Preferences > Debugger.

The debugging panel appears with customizable fields.




	Make your selections from the fields and options provided.
	To set any options for a specific debugger window, expand the Debugger node and click the appropriate window node. For example, if you want to change the columns displayed in the Smart Data window, click Smart Data.
	Edit any of the available options as desired.
	Click OK when you are done.








12.7.13 How to Specify Which Columns Display in the Window



You can choose which columns display in each of the debugger windows. *

To specify which columns display in the window:





	
Right-click in the window and choose Preferences from the context menu. Under Columns, select the columns you want to be displayed in the Breakpoints window.


	
Or, in the window, right-click on the columns heading and select column names.














12.8 Managing Breakpoints


A breakpoint is a trigger in a program that, when reached, pauses program execution allowing you to examine the values of some or all of the program variables. By setting breakpoints in potential problem areas of your source code, you can run your program until its execution reaches a location you want to debug. When your program execution encounters a breakpoint, the program pauses, and the debugger displays the line containing the breakpoint in the source editor. You can then use the debugger to view the state of your program. Breakpoints are flexible in that they can be set before you begin a program run or at any time while you are debugging. Figure 12-7 displays an example breakpoint in a Java Application source file.


Figure 12-7 Breakpoint in Source Editor

[image: This image is described in the surrounding text]


Breakpoints set on comment lines, blank lines, declarations, and other non-executable lines of code are invalid and will not be verified by the debugger.

The JDeveloper debugger supports a number of different types of breakpoints:

	
Source breakpoints


	
Exception breakpoints


	
Method breakpoints


	
Class breakpoints


	
File breakpoints


	
Deadlock breakpoints




Deadlock breakpoints are useful in situations when you find it difficult to locate the source of the deadlock. When a deadlock breakpoint is encountered, the debugger halts. The deadlock breakpoint is automatically enabled when you start debugging.

Information about set breakpoints can be viewed in the Breakpoints window.





12.8.1 Understanding Verified and Unverified Breakpoints


While debugging, you can place a breakpoint to the left of any line of code in the source editor. However, for a breakpoint to be valid, it must be set on an executable line of code. Before a method is first executed, the debugger verifies all valid breakpoints in the method. Breakpoints set on comment lines, blank lines, declarations, and other non-executable lines of code are invalid and will not be verified by the debugger.

When a breakpoint has been verified as valid, the icon displayed in the source editor margin and in the Breakpoints window changes to the icon shown in Figure 12-8.


Figure 12-8 Verified Breakpoint Icon
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12.8.2 Understanding Deadlocks


A deadlock occurs when one or more threads in your program are blocked from gaining access to a resource or waiting on a condition that cannot be satisfied. A common deadlock in Java is a monitor block cycle deadlock.

A monitor block cycle deadlock occurs when two or more threads are unable to proceed because each is waiting to enter synchronized code that one of the others has already entered.

The following example shows a typical Java synchronization deadlock:


synchronized (a) 
 {
 ...
 synchronized (b)  {
 ...
  }
  ...
 }


At the same time, thread 2 is executing the following code:


synchronized (b) 
{
...
  synchronized (a) 
  {
  ...
   }
   ...
 }  


A deadlock will occur if thread 1 enters the synchronized (a) as thread 2 enters the synchronized (b). Thread 1 will be blocked from entering synchronized (b) until thread 2 finishes the synchronized (b) and thread 2 will be blocked from entering synchronized (a) until thread 1 finishes the synchronized (a). A deadlock is also called a "deadly embrace." This example is for two threads but the same situation could occur for 3, 4, 5, and so on threads. The deadlock breakpoint can detect this type of deadlock.

Another kind of deadlock is where one thread calls the wait method on a particular object and no other threads call the notify method on that object. The most common cause of this kind of deadlock is timing. The notifying thread may have called notify before the waiting thread called wait. The important thing to know about calling wait is that even if notify was already called many times before, the wait method waits until notify is called again. Also, notify doesn't return any kind of error if there was no thread waiting. The deadlock breakpoint cannot detect this type of deadlock.

If you think your program is hanging, click Pause to pause your program in the debugger, and open the Monitors window. Perhaps you can see that one thread is waiting, investigate the code. If you can see that another thread probably called notify before the first thread called wait, there is a deadlock. This kind of deadlock is very hard to detect. You must know your code well in order to figure out which other thread should have called notify.







12.8.3 Understanding the Deadlock Breakpoint


The JDeveloper debugger sets a persistent deadlock breakpoint when it starts running. A deadlock breakpoint is useful in situations when you find it difficult to locate the source of the deadlock. When the debugger encounters a deadlock breakpoint, the debugger halts. It can detect a monitor block cycle deadlock as described above. The Monitors window can be useful when working with deadlocks.

The deadlock breakpoint has the following characteristics:

	
It is a persistent breakpoint that is created automatically when you use JDeveloper.


	
It cannot be deleted, but it can be disabled.


	
It pauses the debugger if a monitor block cycle deadlock is detected. A monitor block cycle deadlock occurs when two or more threads are unable to proceed because each is waiting to enter synchronized code that one of the others has already entered.




The JDeveloper debugger automatically creates a persistent deadlock breakpoint; this breakpoint will occur whenever a monitor block cycle is detected. You cannot delete a persistent breakpoint. You cannot create a new deadlock breakpoint, but you can edit the existing persistent deadlock breakpoint.

Not all Java Virtual Machines support deadlock detection; for example, the HotSpot VM does not support deadlock detection.







12.8.4 Understanding Grouped Breakpoints


Grouped breakpoints let you enable a set of breakpoints. When the debugger reaches a certain point in your code, you can instruct the debugger to enable a breakpoint or a group of breakpoints that was previously disabled.

For example, even though your code might be catching a NullPointerException, it may not be behaving correctly. In some cases, NullPointerExceptions occur more frequently than expected which causes the debugger to stop repeatedly for NullPointerExceptions, including those that are of no consequence to your code. This situation can be resolved by creating a breakpoint group, adding this breakpoint to the group, and disabling the breakpoint group so that the debugger does not stop at this breakpoint when debugging.

Next, you can create a source breakpoint in some code that you know is executed just before the problematic NullPointerException is thrown. You can set the actions for this source breakpoint so that when the source breakpoint occurs, it will automatically enable the breakpoint group which contains the exception breakpoint.







12.8.5 How to Edit Breakpoint Options



JDeveloper allows you to edit the options of a breakpoint after you have added it in the source code. From the Edit Breakpoint dialog, you can:





	
Set a breakpoint option.


	
Set the threads to which the breakpoint will apply.


	
Set a pass count for the breakpoint.


	
Put the breakpoint in a breakpoint group.


	
Choose what actions the debugger will take when the breakpoint occurs.




To view and modify the options of a breakpoint:




	If the Breakpoints window is not open, select View > Breakpoints from the main menu.
	In the Breakpoints window, select a breakpoint.
	Right-click and choose Edit, or click the Edit icon on the Breakpoint toolbar.

The Edit Breakpoint dialog appears with a Definition tab, a Conditions tab, and an Actions tab.




	Make any necessary changes to the breakpoint options.
	To accept the changes, click OK.








12.8.6 Editing a Breakpoint



You can right-click to edit a breakpoint located in the source editor. The Edit Breakpoint dialog shown in Figure 12-9 displays, where you can specify the definition of the breakpoint. In the dialog, you can edit some of the most important breakpoint attributes, such as enabled/disabled, condition and more.





	

Figure 12-9 Edit Breakpoints Dialog
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You can also hover over a breakpoint in the source editor to display the dialog in Figure 12-9.









12.8.7 How to Set Source Breakpoints



A source breakpoint is the most common type of breakpoint. It is set on a line of the source code and program execution is paused when it hits that line.

To set a source breakpoint, do one of the following:





	
In the source editor, click in the left margin next to a line of executable code.


	
In the source editor, right-click in the left margin next to a line of code, then choose Toggle Breakpoint (F5).


	
Choose Window > Breakpoints to display the Breakpoints window. Then, right-click anywhere in this window and choose Add Breakpoint from the context menu. From the submenu, select Source Breakpoint as the breakpoint type, then complete the package, source file name, and line number information in the dialog. The source filename should not include any directory information, but must include the extension of the file. For example:


Application1.java or MyWebApp.jsp


You might want to set a least one breakpoint before you start debugging, but it is not necessary. While your program is running in the debugger, you can set a breakpoint. The program pauses when it reaches the breakpoint.












12.8.8 How to Control Breakpoint Behavior



You can control how the debugger behaves when a breakpoint occurs.

To control how the debugger behaves when a breakpoint occurs:




	In the Breakpoints window toolbar, click Add Breakpoint. Or, select a breakpoint and click Edit.
	Click the Actions tab in the New/Edit Breakpoint dialog. The Actions tab allows you to change these behaviors:

	
Halt execution (default)


	
Beep


	
Log breakpoint occurrence (enter a tag or an expression)


	
Enable a group of breakpoints


	
Disable a group of breakpoints















12.8.9 How to Delete a Breakpoint



When you no longer need to examine the code at a breakpoint location, you can delete the breakpoint. You can delete breakpoints either using the source editor or in the Breakpoints window.

To delete a breakpoint, do one of the following:





	
In the left margin of the source editor, click the breakpoint you want to delete.


	
In the left margin of the source editor, right-click the breakpoint you want to delete, and choose Toggle Breakpoint.


	
In the source editor, place the cursor in the line of code containing the breakpoint, and press F5.


	
To delete all currently set breakpoints, right-click in the Breakpoints window and select Delete All.


	
Select the breakpoint in the Breakpoints window and click Delete Breakpoint on the toolbar.





Caution:

You cannot undelete a breakpoint.









12.8.9.1 How to Disable a Breakpoint



When you disable a breakpoint, all the breakpoint settings remain defined, but the breakpoint is not triggered when your program is run; your program will not stop on a disabled breakpoint. Disabling a breakpoint is useful if you have defined a breakpoint that you don't need to use now, but might need to use at a later time.

To disable a breakpoint, do one of the following:





	
In the source editor, right-click the breakpoint symbol in the left margin and choose Disable Breakpoint.


	
In the Breakpoints window (Window > Debugger > Breakpoints) right-click the breakpoint you want to disable and choose Disable.


	
To disable a group of breakpoints in the Breakpoints window, select the group that you want to disable, right-click and choose Disable Group.

You can also disable breakpoints from the Breakpoint toolbar. Select the breakpoint or breakpoint group, and click Disable on the toolbar.


	
To disable all current breakpoints, right-click in the Breakpoints window, and choose Disable All from the context menu.












12.8.9.2 How to Enable a Breakpoint



You can reenable a disabled breakpoint.

To reenable a disabled breakpoint:





	
To enable a breakpoint that is disabled, right-click the disabled breakpoint symbol (or entry in the Breakpoints window), and choose Enable.


	
To enable all breakpoints that have been set, right-click in the Breakpoints window, and choose Enable All.


	
To enable a group of breakpoints, right-click a breakpoint group in the Breakpoints window, and choose Enable Group.

You can also enable breakpoints from the Breakpoint toolbar. Select the breakpoint or breakpoint group, and click Enable on the toolbar.














12.8.10 How to Set Instance Breakpoints



Breakpoints typically have effect whenever they are reached. An instance breakpoint is associated with a specific instance of the class that defines the method where the breakpoint appears.

An instance breakpoint is a source breakpoint that has been associated with an instance filter that identifies the selected instances. Instance breakpoints do not persist between runs of the debugger. Instance filters are shown in the Instance Filters column of the Breakpoints window.

To set an instance breakpoint:




	Set the source breakpoint that you will convert to an instance breakpoint. It must be in a method of the instance's class. For more information, see How to Set Source Breakpoints ..
	Set a second breakpoint at some point where the desired instance will be accessible.
	Define the instance filter:

	
Start or resume the debugger.


	
When the debugger stops at the second breakpoint, find the desired instance in the Data window, Smart Data window, or Watches window.


	
Right-click the instance, choose Instance Filters, and choose the source breakpoint that is to become an instance breakpoint.

Repeat for other instances you want to track.







	Resume the debugger.

The debugger will stop at the instance breakpoint only for the selected instances.












12.8.11 How to Set Exception Breakpoints



Breakpoints are typically attached to a particular line of code; they pause the debugger when a particular line of code is about to be executed. In addition, you can set a breakpoint to be activated when a certain type of exception is thrown. Exception breakpoints are not associated with a particular line of code.

To set an exception breakpoint:




	In the Breakpoints window, click Add Breakpoint on the Breakpoint toolbar. From the submenu, choose Exception Breakpoint.

The Create Exception Breakpoint dialog appears.




	In the Definition tab, enter or choose the name of an exception class.
	If desired, select or clear the Break for Caught Exceptions or Break for Uncaught Exceptions checkboxes. Both checkboxes are selected by default.
	Click OK.



The debugger will now pause if an exception of the specified type is thrown.

By default, the debugger automatically creates a persistent exception breakpoint for uncaught throws for java.lang.Throwable. This breakpoint will occur whenever an uncaught exception is thrown. You cannot delete a persistent breakpoint, although you can disable it.









12.8.12 How to Make a Breakpoint Conditional



When you make a breakpoint conditional, the debugger pauses when a certain condition is met. When a breakpoint is first set, the debugger pauses the program execution each time the breakpoint is encountered. However, using the Edit Breakpoints dialog, you can customize breakpoints so that they are activated only in certain conditions.

The Conditions tab in the Edit Breakpoint dialog is where you enter an expression that is evaluated each time the debugger encounters the breakpoint while executing the program. If the expression evaluates to true, then the breakpoint pauses the program. If a breakpoint condition cannot be evaluated, the debugger will stop at the location as if it was an unconditional breakpoint.

When the debugger stops at a line with a conditional breakpoint, a ghost window appears next to the breakpoint icon showing the breakpoint condition. If the debugger stopped because the condition was true, the condition is shown with a green checkmark icon; if it stopped because the condition could not be evaluated, the condition will be shown with a question mark icon.

For example, suppose you want a breakpoint to pause on a line of code only when the variable mediumCount is greater than 10.

To set a breakpoint condition:




	Set a breakpoint on a line of code by clicking to the left of the line in the source editor.
	Open the Breakpoints window by choosing View > Debugger > Breakpoints.
	In the Breakpoints window, right-click the breakpoint you just set and choose Edit.
	In the Edit Breakpoint dialog, click Conditions.
	Enter an expression in the Condition field, for example, mediumCount > 1
	Click OK.



You can enter any valid Java language expression in the Edit Breakpoint dialog, but all symbols in the expression must be accessible from the breakpoint's location, and the expression cannot contain any method calls. For an exception breakpoint, you may want to use the exception object in your condition by using _throw.

You can also right-click a breakpoint located in the source editor to set conditions. Or, with your mouse cursor, hover over a breakpoint icon in the gutter of an editor window. For more information, see Editing a Breakpoint..









12.8.13 Using Pass Count Breakpoints


The Pass Count field specifies the number of times that a breakpoint must be passed for the breakpoint to be activated. Pass counts are useful when you think that a loop is failing on the nth iteration. The debugger pauses the program the nth time that the breakpoint is encountered during the program run. The default value is 1.

If the Pass Count column is shown in the Breakpoints window, you can see the pass count value decrement each time the breakpoint line of code is encountered during the program execution. If the pass count equals 1 when the breakpoint line is encountered, the breakpoint is activated, and the program pauses at that line.

When pass counts are used together with breakpoint conditions, the breakpoint pauses the program execution the nth time that the condition is true; the condition must be true for the pass count to be decremented.







12.8.14 How to Examine Breakpoints with the Breakpoints Window



To see the list of breakpoints, choose Window > Debugger > Breakpoints from the main menu. Breakpoints that have been verified as valid by the debugger are indicated by the icon shown in Figure 12-8. You can use the Breakpoints window to quickly find the breakpoint location in your source code.

To use the Breakpoints window to locate a breakpoint in the source editor:




	In the Breakpoints window, select a breakpoint.
	Right-click and choose Go to Source from the context menu.








12.8.15 How to Manage Breakpoint Groups


You can enable or disable several breakpoints with a single action, by creating a breakpoint group and putting breakpoints into it. Once you've created a breakpoint group, you can enable, disable, or remove it like a single breakpoint.





12.8.15.1 How to Create a Breakpoint Group



You create a breakpoint group by first creating a breakpoint, then editing it to create a breakpoint group. This enables all the breakpoints contained in the selected group. When a breakpoint is enabled, it means that the conditions and actions are executed when the breakpoint is encountered.

To create a breakpoint group:




	In the Breakpoints window, right-click a breakpoint and choose Edit from the context menu.

The Edit Breakpoint dialog appears.




	In the Breakpoint Group Name field, enter a group name for this breakpoint.
	Click OK.

A new group is created in the Breakpoints window, and is indicated by a folder icon. The breakpoint you just edited is automatically put in the new group.












12.8.15.2 How to Move a Breakpoint into a Breakpoint Group



To move a breakpoint, you can either drag-and-drop it into the breakpoint group, or follow these steps.

To move a breakpoint into a breakpoint group:




	In the Breakpoints window, right-click a breakpoint and choose Edit from the context menu.

The Edit Breakpoint dialog appears.




	From the Breakpoint Group Name field, select a breakpoint group from the dropdown list, or enter a new group name.
	Click OK.

The breakpoint is added into the specified group.












12.8.15.3 Enabling Disabling or Removing a Breakpoint Group



To enable, disable, or remove a breakpoint group, in the Breakpoints window, right-click a breakpoints group, and choose Enable Group, Disable Group, or Delete Group from the context menu.

You can also enable or disable a group from the Breakpoint toolbar. With the group name selected in Breakpoints window, click the Enable or Disable icon on the toolbar. All the breakpoints of the selected group will be enabled or disabled.













12.9 Examining Program State in Debugger Windows


Even though you can view your program by running and stepping through it, you usually need to examine the values of program variables to uncover bugs. For example, it is helpful to know the value of the index variable as you step though a loop, or the values of the parameters passed in a method call. When your program is paused in the debugger, you can examine the values of variables, arguments, fields, and array items.





12.9.1 How to Inspect and Modify Data Elements



You can inspect and change the values of data items using the Data, Smart Data, Inspector, or Watches windows during the course of your debugging sessions.

JDeveloper also allows you to inspect a data item without adding it in Data window. When the debugger has stopped at a breakpoint in the Source Editor, hover the mouse over a data item to view the its name, value, and type. If the data item is an object or an array, you can inspect children of the selected item deep in the object hierarchy.







12.9.1.1 How to Inspect a Data Item



When you inspect a data item, you evaluate it with different expressions while your debugging session is running. You can then modify program data values as a way to test hypothetical bug fixes during a program run. If you find that a modification fixes a program error, you can exit the debugging session, fix your program code accordingly, and recompile the program to make the fix permanent.

To inspect a data item:




	Open the Data window while the debugger is stopped at a breakpoint.
	Right-click an item in the Data window and choose Inspect from the context menu.

The floating Inspector window opens displaying the item's name, value, and other related information. The columns which display in this window depend on those column settings that were enabled in the Tools > Preferences - Debugger - Inspector page. For more information, see How to Use the Inspector Window.




	To evaluate the item for an expression, choose Edit Expression from the context menu.

You can also add a watch expression or further inspect the data item.




	When you are done, close the Inspector window.








12.9.1.2 How to Modify the Value of a Variable



You can modify program data values during a debugging session as a way to test hypothetical bug fixes during a program run. If you find that a modification fixes a program error, you can exit the debugging session, fix your program code accordingly, and recompile the program to make the fix permanent.


Note:

Some object types cannot be modified while the program is running. A warning appears if you attempt to modify such an object type.



When you modify the value of a variable, the modification is effective for that specific program run only; the changes you make through the Data or Watches windows do not affect your program source code or the compiled program. To make your change permanent, you must modify your program source code in the source editor, then recompile your program.

The new value needs to be type-compatible with the variable you want to assign it to. A good rule of thumb is that if the assignment would cause a compile-time or run-time error, it is not a legal modification value.

To modify the value of a variable in the Data window:




	Open the Data window while the debugger is stopped at a breakpoint.
	Right-click an item in the Data window and choose Modify Value from the context menu.

The Modify Value dialog appears with the selected item's name and its current value.




	Enter a new value for the item.

	
If you are modifying a primitive value, you can enter a new value.


	
If you are modifying a reference pointer (other than a string), you can enter the memory address of an existing object or array.


	
If you are modifying a string, you can enter either a new string value or the memory address of an existing string.







	Click OK to change the value for the item and to close the dialog.

The new value appears in the Data, Smart Data, Inspector, or Watches windows.














12.9.2 How to Modify Expressions in the Inspector Window



You can modify an existing expression in the inspector window.

To modify an expression in the Inspector window:




	You can type the new expression in the corresponding text box, or in the Inspector window, right-click and choose Edit Expression from the context menu.

The Edit Expression dialog appears.




	Enter a new expression.
	Click OK.








12.9.3 How to Show and Hide Fields in the Filtered Classes List



While debugging, you can use filters to reduce the number of fields that are displayed when you expand an object in a data-related debugger window. You can perform this task in the Smart Data window, the Data window, the Inspector window, the Watches window, and the left-hand side of the Monitors window through the Object Preferences dialog. Displaying fewer fields narrows your focus when debugging and may make it easier to locate and isolate potential problems in your program.

For example, you can create filters for classes in the data windows so that the debugger displays only the fields of interest to you. This drastically reduces clutter and allows you to find the relevant data more quickly.

To show or hide fields in the filtered classes list:




	Select an object in a data-related debugger window. Right-click and choose Object Preferences from the context menu.

Choosing Object Preferences lets you go directly to the Object Preferences dialog for this specific object from which you can specify filters to control which fields are displayed and which fields are not displayed when you expand an object.




	In the Object Preferences dialog, you can easily traverse the superclass hierarchy of the selected object, defining or updating the filters for each superclass. Select a class in the Types window and choose the fields to hide or display in the Value column of the debugger window.
	Click the arrows to shuttle filters from the Fields to Show list to the Fields to Hide list.
	Click OK when you are done.










12.10 Debugging Remote Java Programs


In addition to debugging code locally in the JDeveloper IDE, you can also debug code which is located on a remote machine or running in a different VM instance. This means that you can use the debugger to debug code that has already been deployed. The debugger can simultaneously attach to multiple remote VMs, so you can seamlessly debug distributed applications, such as JSPs deployed to a web server accessing EJBs deployed to an application server.

The main difference between remote debugging and local debugging is how you start the debugging session. For local debugging, JDeveloper automatically launches the program you want to debug (called a debuggee process) and then attaches the debugger to that program. For remote debugging, you must manually launch the program you want to debug. Also, if you are debugging a JSP or a servlet, you must manually start a browser to invoke your JSP or servlet.

Once the debuggee is launched and the JDeveloper debugger is attached to it, remote debugging is very similar to local debugging. Remember that you can use remote debugging when the debuggee process is running on the same machine as JDeveloper or when the debuggee process is running on a different machine.

Unlike local debugging, you must choose which protocol to use before you start your remote debugging session. The remote debugging protocols are configured in Debugger - Remote page of the Edit Run Configuration dialog.

You can also debug Web pages such as JSPs or servlets using the HTTP Analyzer. For more information, see Auditing and Monitoring Java Projects.

	
Select Attach to JPDA to attach to the debugger application at a specified address. For more information about the Sun Java Platform Debugger Architecture (JPDA) Connection and Invocation, see http://docs.oracle.com/javase/6/docs/technotes/guides/jpda/conninv.html


	
Select Listen for JPDA to specify that the debugger listen for a debuggee to attach to the debugger. Also, choose this option if you are debugging remote PL/SQL programs.








12.10.1 How to Start a Java Process in Debug Mode



After you have configured a project for remote debugging, you can start your remote debugging session by issuing the appropriate command based on the debugging protocol and the environment.

To start the Java process, enter the following at the command line:


java [-client|server] -cp <project_directory>\classes -agentlib:jdwp,<option1>[=<value1>],<option2>[=<value2>]... <java_main_class> 


The available options are:





	
server(=n/y)

If set to y, then the Java process waits for a Debugger to attach. If set to n (default), the process attaches itself to the debugger application at the specified address.


	
address

Specifies the port for the connection. Defaults to 4000.


	
timeout

Time interval after which the connection attempt times out. Defaults to 2 seconds.


	
suspend =(y/n)

If set to y (default), the Java process runs after the debugger connects to it. If set to n, the debuggee process starts right away without waiting for the debugger to connect to it.





Note:

The options shown are applicable if you are running JDK 1.6 or later. See the documentation for the version of JDK you are running if earlier than JDK 1.6.







Command line examples:





	
java -cp <project_directory>\classes -agentlib:jdwp=transport=dt_socket,server=y,suspend=n,address=4000

Listen for a debugger connection on port 4000, but begin execution without waiting for the debugger. Timeout after 2s (default). Implement the Client VM (default).


	
java -server -cp <project_directory>\classes -agentlib:jdwp=transport=dt_socket,server=n,suspend=y,timeout=3,address=8000

Attach to a debugger connection on port 8000. Begin execution only after connecting to the debugger. Timeout after 3s. Implement the Server VM.




For more information about the Sun JPDA Connection and Invocation, see http://www.oracle.com/technetwork/java/javase/documentation/ index-jsp-135444.html.









12.10.2 How to Use a Project Configured for Remote Debugging



Any project can be configured to perform remote debugging.

To configure a project for remote debugging:




	Click Debug from the toolbar.

The appropriate Attach to dialog appears.




	In the Host list box, enter or select the name or IP address of the machine where the remote debuggee has been started.
	In the Port list box, enter or select the port number for the remote debuggee.
	Click OK.

In the Log window, once the debugger has connected, a successful connection message appears.




	If you are remote debugging a JSP or servlet, you will want to access your JSP or servlet by launching your browser.

If you are remote debugging an EJB, you will want to run an EJB client that will access your EJB.




	Continue with your debugging session as usual.
	To detach the debugger from the remote debugging process without terminating the debuggee process, choose the Run > Detach menu option. T

This option is appropriate for remote debugging an application server.




	To terminate the remote debugging process, choose the Run > Terminate menu option, or select the Terminate icon.








12.10.3 How to Configure JPDA Remote Debugging



This section describes how to configure JDeveloper for Java Platform Debugger Architecture (JPDA) remote debugging.

To configure your project for remote debugging:

	
Make changes in the JSP section of global-web-application.xml as follows:


<init-param> 
   <param-name>debug</param-name> 
   <param-value>class</param-value> 
</init-param>


	
Start commands for Integrated WebLogic Server (make sure -server is the first parameter).


value="-server -agentlib:jdwp=transport=dt_socket,server=y,suspend=n,address=4000 -Xms512m -Xmx750m -XX:PermSize=128m -XX:MaxPermSize=256m -Djava.security.policy=$ORACLE_HOME/j2ee/home/config/java2.policy -Djava.awt.headless=true -Dhttp.webdir.enable=false"/> 




To configure JDeveloper for remote debugging:




	Choose Application > Project Properties, select the Run/Debug/Profile node, select a run configuration and click Edit.
	Select the Remote Debugging and Profiling check box.
	On the Debugger - Remote page, verify that Protocol is set to Attach to JPDA.
	Close the Preferences dialog.
	Set breakpoints in your code and from the Debug button dropdown list select the desired run configuration. Complete the connection dialog and verify connection to the debuggee.
	Access JSP previously deployed to server via a browser. The breakpoint should be hit and all work as expected.













26 Designing Databases Within Oracle JDeveloper


This chapter describes how to work with database objects in a database connection. It also contains information about working with offline databases in JDeveloper to create and edit offline database objects that can then be generated to a script database connection.

This chapter includes the following sections:

	
About Designing Databases Within


	
Creating_ Editing_ and Dropping Database Objects


	
Creating Scripts from Offline and Database Objects








26.1 About Designing Databases Within Oracle JDeveloper


You can use JDeveloper to:

	
Create, edit, or delete database objects


	
Create, edit, or delete offline database objects


	
Work with offline versions of database definitions, and then generate those definitions figgeroisd to a file that is processed immediately or at a time you choose to create a table or other database objects via the database connection


	
Model offline databases, and model database objects in a live database connection on a diagram. For more information about modeling databases, see Modeling with Database Diagrams .










26.2 Creating, Editing, and Dropping Database Objects


You can create database objects and offline database definitions, you can edit those objects, and you can delete them or drop them from a database connection.





26.2.1 Working with Offline Database Definitions


This section describes how to work with database objects, such as tables, views, constraints, outside the context of a database schema. Offline database is a technology in JDeveloper that allows you to create and edit database object definitions within a project, saved as .xml files, using the same editors that are used to create and edit database objects on live database connections.

You can create new offline database objects. Alternatively, you can have a connection to a live database and reverse engineer database objects. After you have finished working with them, you can generate DDL that can be used to create and update database definitions in online database schemas.

The JDeveloper Offline database supports the following object types:

	
Function


	
Index (as part of a table)


	
Database Link


	
Materialized View


	
Materialized View Log


	
Package


	
Procedure


	
Sequence


	
Synonym


	
Table


	
Tablespace


	
Trigger


	
Type


	
View




For more information about Oracle Database support of any of these object types, see the Oracle® Database SQL Reference.


How to Work with Offline Database Definitions




When you work with offline database definitions in JDeveloper, you work with objects that are stored as XML files, but which provide a model of objects in live database connections. You can generate offline database definitions to live database connections to create, alter, or drop database objects.

JDeveloper provides the tools you need to create and edit database objects such as tables and constraints outside the context of a database. For example

	
You can create new tables and views and generate the information to a database.


	
You can create new tables and views and generate the information to a file, which you can edit and later run on a database connection.


	
You can reverse engineer tables and views from a database schema, make the changes you want and then generate the changes back to the same database schema, to a new database schema, or to a file that you can run against a database at a later date. JDeveloper allows you to manually reconcile changes before committing them to a database.


	
You can use the modeling tools in JDeveloper to visualize your offline database objects on a diagram. For more information about modeling databases, see Modeling with Database Diagrams .





How to Set Paths for Offline Database Files




You can configure a project's settings to specify the root locations for offline database objects available to that project. The database path is configured by default, so you only need to change it if you want to:

	
Include offline database objects that are stored in another project


	
Store new offline database object files somewhere else.




Offline database objects can be shared between projects by adding their file system location to the database path for a project. The order in which file system locations are entered in the database path signifies the order in which the directories are searched for offline database objects. The first location in the database path is the location in which new offline database object files are stored.

If you are modeling database objects, the model path (located on the Modelers preferences page in the Project Properties dialog) is used to specify the file location for the diagram.


Note:

When you are adding another database path to a project, you should save your work before proceeding. When you change the database path, the project reloads the offline database object definitions so any unsaved work for example, changes to tables, views, schemas or new objects that you have not yet saved, may be lost.



You can set a default root directory for database objects that will be used for all new projects.

To set the default root directory for database objects for new projects:

	
Choose Application > Default Project Properties.


	
Select Project > Source Paths > Offline Database, and enter the root directory.




You can change the database path for an existing project.

To set the database path for an existing project:

	
Right-click the project and choose Project Properties.


	
Select Project > Source Paths > Offline Database, and enter the file system location for your project's offline database objects. Separate multiple file system locations using semicolons (;).


	
You can selectively include and exclude subfolders using the Included and Excluded tabs. For more information, press F1 or click Help from within the dialog.








26.2.1.1 Offline Databases


JDeveloper works with offline database definitions in the context of offline databases that act as containers in a similar way to packages. In the Applications window, the offline database is shown below the Offline Database Sources node, shown in Figure 26-1.


Figure 26-1 Offline Database in the Applications Window

[image: This image is described in the surrounding text]


In this case, a Java class and a database diagram have been created in the package project1, which is under the Application Sources node, and some offline database definitions have been created in an offline database called DATABASE1, which is under the Offline Database Sources node.

When you create an offline database, you choose the database emulation of the offline database.







26.2.1.2 Configuring Offline Database Emulation


You can specify the type of database an offline database emulates. This determines the data types supported in the project.

For information about which database versions are compatible with JDeveloper, see the JDeveloper Certification Information at http://www.oracle.com/technetwork/developer-tools/jdev/documentation/index.html







26.2.1.3 How to Create Offline Databases



An offline database is a node in the Applications window that contains offline schemas and offline database object definitions.

To create an offline database:




	In the Applications window, locate the project you want to work in.
	Right-click a project or anything in it, and choose New to display the New Gallery.
	From the New Gallery, expand Database Tier, and select Offline Database Objects, and select Offline Database.
	In the Create Offline Database dialog, enter a name for the offline database and choose the database type to emulate.

For more information at any time, press F1 or click Help from within Create Offline Database dialog.












26.2.1.4 Offline Schemas


JDeveloper works with offline database definitions in the context of offline databases. Within the offline databases, offline schemas are the equivalent of schemas (or users) in live database connections. In the Applications window, the offline schema is shown below the Offline Database Sources node, illustrated in Figure 26-2.


Figure 26-2 Offline Schema in Applications Window

[image: This image is described in the surrounding text]


In this case, a Java class and a database diagram have been created in the package project1, which is under the Application Sources node, and some offline database definitions have been created in a schema called SCHEMA1, which is in an offline database called DATABASE1 under the Offline Database Sources node.







26.2.1.5 How to Create Offline Schemas



To create an offline schema:




	In the Applications window, locate the project you want to work in.
	Right-click a project or anything in it, and choose New to display the New Gallery.
	From the New Gallery, expand Database Tier, and select Offline Database Objects, and select Schema.
	In the Offline Database dialog, choose the offline database to create the schema in.
	In the Create Schema dialog, enter a name for the offline schema. For more information at any time, press F1 or click Help from within Create Schema dialog.



Example 26-1 Context Menu Shortcut:





In the Applications window, right-click the offline database, and choose New Schema.









26.2.1.6 How to Create Offline Database Objects


There are a number of ways that you can create offline database objects:

	
You can always create offline database objects from the New Gallery.


	
You can always create a database diagram, a table or a view from the context menu of a project configured for offline database development, or from a node under that project.


	
Once you have created an offline database object, you can create another from the context menu of a project configured for offline database development, or from a node under that project.





About Tables




The types of tables that are available are:

	
Normal. This is a regular database table which can be partitioned. A partitioned table is a table that is organized into smaller and more manageable pieces called partitions. SQL queries and DML statements do not need to be modified in order to access partitioned tables; however, after partitions are defined, DDL statements can access and manipulate individual partitions rather than entire tables or indexes. Also, partitioning is entirely transparent to applications.


	
External. An external table is a read-only table whose metadata is stored in the database but whose data is stored outside the database. Among other capabilities, external tables enable you to query data without first loading it into the database.


	
Index Organized. An index-organized table is a table in which the rows, both primary key column values and non-key column values, are maintained in an index built on the primary key. Index-organized tables can be used to store index structures as tables in Oracle Database. Index-organized tables are best suited for primary key-based access and manipulation.


	
Temporary. The temporary table definition persists in the same way as the definition of a regular table, but the table segment and any data in the temporary table persist only for the duration of either the transaction or the session, and the table is not stored permanently in the database. Temporary tables cannot be partitioned or index organized.





Note:

You can only create and use relational table definitions in offline schemas, you cannot create and use object relational table definitions.




About Partitions




You can partition a table, an index, or a materialized view. A partitioned table or materialized view is a table or materialized view that is organized into smaller and more manageable pieces called partitions. SQL queries and DML statements do not need to be modified in order to access partitioned tables; however, after partitions are defined, DDL statements can access and manipulate individual partitions rather than entire tables or indexes. Also, partitioning is entirely transparent to applications.

Temporary tables cannot be partitioned.

A partitioned index consists of partitions containing an entry for each value that appears in the indexed column(s) of the table.

There are three types of partitions:

	
RANGE, which partitions the table on ranges of values from the column list. For an index-organized table this must be a subset of the primary key columns of the table.


	
HASH, which partitions the table using the hash method. Rows are assigned to partitions using a hash function on values found in columns designated as the partitioning key.


	
LIST, which partitions the table on lists of literal values from a column. This is useful for controlling how individual rows map to specific partitions.




You can combine two partitioning methods, called composite partitioning, to further divide the data into subpartitions. Composite partitioning is supported for:

	
Range-Range


	
Range-Hash


	
Range-List


	
List-Range


	
List-Hash


	
List-List




You can define subpartition templates which will be used in any partition for which you do not explicitly define subpartitions.


Note:

A table or index in Oracle Database which uses a hash partition by quantity will be displayed in JDeveloper as having individual hash partitions. You can either specify your individual partitions manually using the Create or Edit Table or Materialized View dialog, or define them by quantity and let the database do the work for you. Whichever way you choose to define your partitions, when you edit the database table or materialized view in JDeveloper, they will be displayed as individual partitions.




About Indexes




You can create indexes on columns in tables in order to speed up queries. Indexes provide faster access to data for operations that return a small portion of a table's rows. In general, you may want to create an index on a column in any of the following situations:

	
The column is queried frequently.


	
A referential integrity constraint exists on the column.


	
A unique key integrity constraint exists on the column.




You can create an index on any column; however, if the column is not used in any of these situations, creating an index on the column does not increase performance and the index takes up resources unnecessarily. Although the database creates an index for you on a column with an integrity constraint, explicitly creating an index on such a column is recommended. You can use the SQL Worksheet's execution plan to show a theoretical execution plan of a given query statement.

Index types are non-unique, unique, or bitmap, or they can be domain indexes.

In a non-unique normal index, the index can contain multiple identical values. In a unique normal index, no duplicate values are permitted. Use a unique normal index when values are unique in the column. In a bitmap normal index, rowids associated with a key value are stored as a bitmap. These are useful for systems in which data is not frequently updated by many concurrent systems, or where there is a small range of values.

Domain indexes are user-defined indexes, each of which indexes data in an application-specific domain. They are built using the indexing logic supplied by a user-defined indextype. An indextype provides an efficient mechanism to access data that satisfy certain operator predicates. Typically, the user-defined indextype is part of an Oracle option, like the Spatial option.


Working with User-Defined Data Types




JDeveloper allows you to define your own data types, which can be either object types or collection types.

Object types are abstractions of the real-world entities—for example, purchase orders—that application programs deal with. An object type is a schema object with three kinds of components:

	
A name, which serves to identify the object type uniquely within that schema.


	
Attributes, which model the structure and state of the real world entity. Attributes are built-in types or other user-defined types.


	
Methods, which are functions or procedures written in PL/SQL and stored in the database, or written in a language like C and stored externally. Methods implement operations the application can perform on the real world entity.




An object type is a template. A structured data unit that matches the template is called an object.

JDeveloper allows you to create an object type specification, or an object type specification and body.

When you create a new object type spec, it is similar to


TYPE TYPE1 AS OBJECT (a null );


When you create an object type body, it is similar to


CREATE TYPE BODY TYPE1 AS VARRAY(1) OF null;


Collection types are different. Each collection type describes a data unit made up of an indefinite number of elements, all of the same data type. The collection types are array types and table types.

Array types and table types are schema objects. The corresponding data units are called VARRAYs and nested tables. When there is no danger of confusion, we often refer to the collection types as VARRAYs and nested tables.

Collection types have constructor methods. The name of the constructor method is the name of the type, and its argument is a comma-separated list of the new collection's elements. The constructor method is a function. It returns the new collection as its value.

An expression consisting of the type name followed by empty parentheses represents a call to the constructor method to create an empty collection of that type. An empty collection is different from a null collection.

JDeveloper allows you to create array types and table types.

An array type is similar to


TYPE TYPE1 AS VARRAY(1) OF null;


A table type is similar to


TYPE TYPE1 AS TABLE OF null; 



Note:

In order to use data types when the project is configured for database emulation other than Oracle Database, the database it emulates must support type creation.




About Materialized Views




Materialized views are database objects that contain the results of a query. The FROM clause of the query can name tables, views, and other materialized views. You can model, create, and edit materialized views in a live database connection, and offline materialized views in an offline database in JDeveloper.

When reverse engineering materialized views from Oracle Database to a JDeveloper project:

	
If a materialized view on the database specifies WITHOUT REDUCED PRECISION, when it is reverse engineered into JDeveloper it will use reduced precision, and the Reduced Precision option on the Properties page of the Edit Materialized View dialog is selected. If it is important that the materialized view does not reduce precision, select No Reduced Precision in the dialog.


	
If a materialized view on the database specifies USING ROLLBACK SEGMENT and USING TRUSTED CONSTRAINTS, when it is reverse engineered into JDeveloper no rollback segment is selected on the Properties page of the Edit Materialized View dialog, and the constraint is shown as Enforced. If necessary, change the options in the Edit Materialized View dialog




To create an offline type definition:

	
In the Applications window, expand the application and project you want to work in.


	
Right-click a project or a node under it such as an offline schema, and choose New > From Gallery to display the New Gallery.


	
From the New Gallery, expand Database Tier, and select Offline Database Objects.


	
Select Type to launch the Create Offline Type dialog.


	
Enter parameters and select options to define the type.

For more information at any time, press F1 or click Help from within the Create Offline Type dialog.




You can edit user-defined types by double-clicking the type in the Applications window. The SQL comprising the type opens in the source editor.

To create offline database object definitions:


Note:

You can only create and use relational table definitions in offline schemas, you cannot create and use object relational table definitions.



	
In the Applications window, right-click a project or anything in it, and choose New to display the New Gallery.


	
From the New Gallery, expand Database Tier, and select Offline Database Objects.


	
Select the offline database object you want to create to launch the Create dialog or wizard.

For more information at any time, press F1 or click Help from within the Create Offline Type dialog.





Context Menu Shortcut:




In the Applications window, right-click the offline schema, select New Database Object, then select object you want to create.

To drop an offline database definition:

	
In the Applications window, expand the project, offline database, and offline schema containing the offline object. Right-click the offline object, and choose Delete.

Alternatively, right-click the offline table and choose File > Delete.


Note:

If the offline table has any dependencies, the Confirm Delete dialog warns you and allows you to see the usages. If you still choose to delete the offline table, the Cascade Confirm Delete dialog warns you which objects will also be deleted.












26.2.1.7 How Reverse Engineer Database Definitions Based on Database Objects



You can drag tables, views, materialized views, synonyms, and sequences from an online database schema onto a database diagram, where they become accessible as offline database objects.

To drag objects onto a database diagram:

	
Create a new database diagram.

Alternatively, open an existing diagram.


	
Choose the database connection. Go to either:

	
Window > Database > Databases window.


	
Application Resources in the Applications window.




Expand IDE Connections or application, and select a database connection.


	
In the connection, expand the schema and expand the node you want: Tables, Views, Materialized Views, Sequences, or Synonyms.


	
Select the object you want to model, and drag it onto the database diagram. This opens the Specify Location dialog. Ensure that Copy Objects to Project is selected, and click OK. The object is now displayed on the diagram and listed in the Applications window.




You can drag more than one object of the same type onto a database diagram, by holding down the Ctrl key as you select them.


Note:

If you reverse engineer the same object more than once a warning message is displayed. If you are using Copy to Project and choose to proceed, you can replace or delete the existing object. If you drag a database object onto the diagram and choose to proceed the new object overwrites the existing one.







How to Reverse Engineer Database Objects and Offline Database Definitions to Projects





You can reverse engineer database objects from a database schema to an offline database where they become available as offline database objects. You can also copy offline database objects to a project.

If you try to reverse engineer database objects to an offline database which emulates a different database version you will see an error message giving you guidance on how to proceed. In general, it is a good idea to make sure that the offline database uses the same database emulation as the source database.

You can apply filters in the wizard to only display the objects you are interested in, and when there are a large number of objects in the schema you can turn off auto-query so that the wizard does not refresh every time you type a filter character.

You can apply filters to select the objects that are displayed as available for reverse engineering. In the Object Picker page (step 3 of the wizard), you can:

	
Enter characters in Name Filter to filter the list of available objects by name. Name Filter is case sensitive.


	
When there are a large number of objects, you can turn off Auto-Query, and click Query after you have entered the filter you want to use.




To reverse engineer database objects:




	In the Applications window, select the project you want to work in.
	Choose File > New to open the New Gallery.
	In the Categories tree, expand Database Tier and select Offline Database Objects.
	In the Items list, double-click Offline Database Objects from Source Database to launch the Offline Database Objects from Source Database wizard.

For more information at any time, press F1 or click Help from within the wizard.












26.2.1.8 Offline Tables and Foreign Keys


When you reverse engineer a table from a live database schema to JDeveloper, information about any foreign keys will not necessarily be available. The following sections discuss how foreign key information is treated in different cases.


Reverse Engineering Tables at Both Ends of a Foreign Key





This is the simplest case. When JDeveloper reverse engineers tables that have foreign keys between them, information about the foreign key is also reverse engineered. Therefore the foreign key is correctly shown on a database diagram and on the Constraint Information page of the Edit Offline Table dialog.

After you have finished working on the tables you can choose to generate your changes directly back to the database.





Best Practice





From the information above you can see that if you are reverse engineering tables to act as the basis of a new database schema, then you do not need to worry about foreign keys to tables that you are not interested in. You can safely make your changes and generate the online tables in a new schema.

However if you are reverse engineering tables so that you can make the changes you want and then generate the changes back to the same database schema you should reverse engineer all tables that have a foreign key relationship, whether you intend to change them or not, so that you generate the correct information about the foreign keys to a SQL file or directly to the database. The Specify Operation page of the Offline Database Objects from Source Database wizard allows you to reverse engineer dependencies.









26.2.1.9 How to Refresh Offline Database Objects



You can refresh any reverse engineered offline object from the database connection it was originally reverse engineered from. Note that if you reverse engineer the object, you will lose any changes you have made in the offline object.


Note:

You cannot refresh an object that was created as an offline object in JDeveloper and then generated to the database. If you make changes to the object in the database and want those changes to be reflected in the offline object, you must reverse engineer the object from the database and overwrite the offline object by selecting the Replace on the Specify Operation page.



To reverse engineer an object from a database connection a second time:




	Right-click the offline object in the Applications window, and choose Refresh from db-connection.
	When the Confirm Offline Object Overwrite dialog appears, check that you want to reverse engineer the object and then click Yes. Otherwise click No. This may take a few seconds.








26.2.1.10 How to Create Objects from Templates



You can create offline database objects based on templates, for example:





	
To use a default set of storage options for all tables created.


	
To use a default set of user property values for all tables created.


	
To use a set of default columns for all tables created.




A template table can create a default primary key, a column sequence, and a trigger.

When you create a new object using the template, the properties that are set on the template are copied to the new object and therefore pre-populate the options in the create dialog. When the namespace of owned objects is not the parent object, the name must be unique within the schema, not just within the parent object. For example, Index and Constraint names must be unique within the schema, not just within the owning Table, Materialized View, or View.





How to Create Offline Templates





You can create offline database objects from templates.

To create default templates for an offline database:

	
Create a new offline database.


	
In the Create Offline Database dialog, select Initialize Default Templates. When you click OK, the offline database is created, along with default template objects which have the name TEMPLATE_object. You can edit the template database objects by right-clicking the one you want and choosing Properties, which opens the Edit object dialog.




To edit the default templates for an existing offline database:

	
In the Applications window, navigate to the template object and choose Open from the context menu. The template object opens in the appropriate editor where you an edit it.








How to Create Offline Database Objects from Templates





You can create offline database objects from templates as offline database objects in the Applications window, or as modeled offline database objects on a database diagram.

Before creating offline database objects based on templates, you first need to create the templates.

To create an offline database object based on a template:




	In the Applications window, right-click a project or anything in it, and choose New to display the New Gallery.
	From the New Gallery, expand Database Tier, and select Offline Database Objects.
	Select Database Object from Template to launch the Choose Template Object dialog. For more information at any time, press F1 or click Help from within the Create object dialog.
	Choose the object type to create from a template. When you click OK, the Create object dialog opens, pre populated with the values in the template. For more information at any time, press F1 or click Help from within the Create object dialog.

When you click OK the object is created and listed in the Applications window under the offline database and schema.












26.2.1.11 Working with User Property Libraries


You can add user defined properties to database objects. For an instance of a database object; these user defined properties can be assigned specific values.

You can work with libraries that can limit the properties you can define for an offline database object. For example, you can determine that all tables must have a column of a particular type, or that only certain values are allowed, or that a property is mandatory.

User property libraries are defined in the context of an offline database. First you have to define user properties for the types of offline database objects you want to use. Then you can use the user property libraries when creating offline database objects.

User property libraries can contain properties defined for:

	
Tables, columns, constraints, indexes


	
Database links


	
Functions, packages, procedures


	
Materialized Views


	
Materialized View Logs


	
Sequences


	
Synonyms


	
Tablespaces


	
Triggers


	
Types


	
Views








26.2.1.11.1 How to Create and Edit User Property Libraries



User property libraries are independent of offline databases, but can be added to them using the offline database edit dialog.

To create or use a user property library:




	In the Applications window, expand the project, right-click the offline database and choose Properties.
	In the Edit Offline Database dialog, choose User Property Libraries.
	You can:

	
Create a new library. In this case, you enter a filename and location for the library.


	
Add a library that exists in the file system. In this case, you browse to the library location on the file system.


	
Edit an existing library by selecting it from the list.







	Enter values for the user properties in the Edit User Property Library File dialog. For more information at any time, click F1 or press Help in the dialog.



Once you have created a user property library for an offline database object type, you can use it to store user property values.

You can provide validation for the user defined property value to validate the database objects by writing your own validation code. This is an advanced procedure which is outside the scope of this user guide. For more information see UserPropertyValidationManager in Java API Reference for Oracle Extension SDK. For information about using the Extension SDK, see Developing Extensions for Oracle JDeveloper.









26.2.1.11.2 How to Use User Property Libraries



Use user properties for database objects.

Before you can use user properties in offline database objects, you must define the user property libraries.

To use user properties in an offline database object:




	Create the offline database object.
	Navigate to the User Properties page or tab of the offline database object dialog, and enter values for the user properties.










26.2.1.12 How to Generate Offline Database Objects to the Database


The Generate SQL from Database Objects wizard allows you to choose how to update a database schema with the offline objects that you have created or edited. You can:

	
Create or replace the objects in the database.

If you choose to generate a SQL file, it will contain CREATE and DROP statements.


	
Update existing database schema objects with the changes you have made to the offline database objects. JDeveloper first reconciles the offline database definitions against the objects in the database schema to identify the changes necessary. You can choose to do a manual reconcile and select only some of the changes.

If you choose to generate a SQL file, it will contain ALTER statements.




Whether you are generating changes to a database, or reconciling changes, you can choose to:

	
Generate a SQL file that you can examine, and run against the database later.


	
Make the changes directly to the database.




Alternatively, if you just want to generate one or more offline tables back to the database connection they were originally reverse engineered from, you can do this directly from the Applications window.


Note:

If you have made changes to tables that have foreign keys, it is possible that the foreign keys will be dropped when you generate your changes to the database.







26.2.1.12.1 Reconciliation issues


This section contains information about problems you may come across when reconciling.


Cannot modify constraints




Constraints can be created or dropped during reconciliation; they cannot be modified. The only ALTER TABLE reconciliations that can be performed are ADD CONSTRAINT, DROP CONSTRAINT, ADD COLUMN, DROP COLUMN, and WIDEN COLUMN.


Cannot reconcile renamed tables




You can change the name of a table when you reverse engineer it or while you are editing it offline. If you try to reconcile the renamed table back to the database, you will receive an error message because the database does not have a record of the table with its new name.

To avoid this, create the renamed table in the database, do not reconcile or replace it.







26.2.1.12.2 How to Generate Database Definitions to a File



Create a SQL file containing the CREATE and DROP statements that you can run against an online database schema.


Note:

If you have made changes to tables that have foreign keys, it is possible that the foreign keys will be dropped when you generate your changes to the database.

If you have one or more offline database definitions containing information that you want to generate to a database, you can use this method. However if you want to quickly generate one or more offline database definitions back to their original database connection, you can do this from the Applications window.

When you have an offline version of an online database table, JDeveloper keeps track of the information comprising the offline database table columns behind the scenes. When the database is updated outside JDeveloper, for example when the generated SQL script is run in a SQL session, or when another user updates the database, JDeveloper cannot track the link between the offline database table and the table in the database. To get around this, you must refresh the offline schema objects from the database.



To create the file:




	In the Applications window, expand the application and project.
	Right-click an offline schema and choose New to display the New Gallery.
	From the New Gallery, expand Database Tier, and select Database Files.
	Select SQL File from Source Database to launch the Generate SQL from Database Objects wizard.
	On the page specify details for the generated file, then click Next.
	On the Finish page, click Finish to create the file.



Context Menu Shortcut:

In the Applications window, right-click one or more offline database definitions and choose Generate to

or

On the database diagram select one or more modeled database definitions, right-click and choose Synchronize with Database > Generate To.











26.2.1.13 Renaming Offline Database Objects


JDeveloper has a limited ability to keep track of renamed offline database objects such as tables and sub objects such as columns or constraints. In some circumstances JDeveloper will drop the database object with the unchanged name and create a new database object with the new name, which can lead to loss of data. You need to be aware of the situations when this can arise so as to avoid them.

This can occur when an offline database object is generated to a database connection. If you then change the name of the offline database object or of a sub object such as a column or index, and then generate the changed offline database object to a database connection, in the database the object with the original name is dropped and a new object using the new name is created.

A different situation which can lead to loss of data is when an object is reverse engineered from a database connection, then the name of an offline database sub object is changed. In this case, the first time you generate to a database connection the database sub object is correctly updated. However if you attempt to generate to the database connection a second time the sub object with the original name is dropped and a new database sub object with the new name is created. The reason that this happens is because Copy to Project uses the original name in an internal reference to the online sub object.







26.2.1.14 Using Offline Database Reports


JDeveloper provides many reports about an offline database and its objects. You can also create your own user-defined reports for offline database objects.





26.2.1.14.1 Offline Database Reports


JDeveloper comes with a set of pre-built report definitions, and you can also define your own report definitions.

You can use the pre-built reports directly to provide information about an offline database, or you can alter them to create a report tailored to your specific requirements.

Once you have created a pre-built report, you can examine the SQL that makes up the query for the report, and if necessary change it. You can also set parameters in the report query that are called when the report is run.





26.2.1.14.1.1 How to Use Pre-built Reports



The pre-built reports quickly provide useful reports which provide the following queries for an offline database:





	
OBJECT_COUNT, which lists the number of schema objects of each object type.


	
OBJECT_LIST, which lists all schema objects in the offline database.


	
TABLE_COLUMNS, which lists all tables with their column information.


	
TABLE_COLUMN_COUNT, which lists all tables with their column count.


	
TABLE_NO_PKS, which displays all tables that do not have a primary key.




When you run the Pre-Built Reports wizard, a separate file is generated for each of the pre-built reports that you choose to the location that you specified, and the file is listed in the Applications window under Resources.


Note:

If you specify a location that is outside the current project the reports are generated, but they are not listed in the Applications window. The files have the file name pre-built-report.report, and they are structured as XML files.



How to use predefined reports:

	
In the Applications window, expand the application and project.


	
Right-click an offline database and choose New to display the New Gallery.


	
From the New Gallery, expand Database Tier, and select Offline Database Objects.


	
Select Pre-Built Reports to launch the Pre-Built Reports wizard.


	
Choose the reports you want to generate and if necessary click Next to change the offline database that you want to run the report on.


	
Click Finish. The reports you have chosen are listed in the Applications window under the offline database node.




To edit a predefined report:




	In the Applications window, expand the application, project and offline database.
	Right-click the report and choose Properties to open the Edit Report dialog, where you can examine and change the properties.
	On the Report Definition page, change the name of the report. Change other details as required, for example, you can change the offline database that the report is to run on.
	To change the SQL query for the report, either change the SQL on the Query Definition page, or expand the Query Definition node and declaratively define the SQL query. You can use the Check Syntax button on the Query Definition page to check that the SQL parses.
	To add parameters to the query, use the Report Parameters page.
	To change the format that the report is published in, use the Publish Report page.



To run a pre-built report:

	
In the Applications window, right-click the report and choose Run. The report is run against the offline database you specified. The results are either displayed in the Reports Log window (default), or in the location and format that you have chosen in the Publish Report page of the Edit Report dialog.












26.2.1.14.1.2 How to Define Report Definitions



You can define your own report definitions. You can either define a query from scratch, or you can base the new report definition on an existing report or on one of the pre-built reports.

You can specify that just the report definition is produced, or you can specify that when the report definition is run a comma-separated file is produced, or that a formatted HTML document is produced.

If you choose to generate an HTML document, you can optionally specify that a CSS file is used, and you can edit the default boilerplate text that formats the body of the HTML document.

How to create a report:




	In the Applications window, expand the application and project.
	Right-click an offline database and choose New to display the New Gallery.
	From the New Gallery, expand Database Tier, and select Offline Database Objects.
	Select Reports to launch the Create Report wizard.
	Enter a name for the report, and choose whether to copy report details from a pre-built report, from an existing report, or whether to create a new report from scratch.
	Change the offline database the report is to run on in the Offline Database page.
	Create or examine the SQL query for the report in the Query Definition page. You can use the pages under the Query Definition node to declaratively create the SQL Query.
	If you want to use parameters with the report, enter them in the Report Parameters page.
	Click Finish. The new report is listed in the Applications window under the offline database node.



To run a report:

	
In the Applications window, right-click the report and choose Run. The report is run against the offline database you specified. The results are either displayed in the Reports Log window (default), or in the location and format that you have chosen in the Publish Report page of the Edit Report dialog.










26.2.1.14.1.2.1 How to Use Boilerplate Text with HTML Reports


JDeveloper provides some boiler-plate code to help you to format the report, and it includes three new HTML tags:

	
<report/>, which defines the report output.


	
<query/>, which defines the text of the query used to generate the report.


	
<rows/>, which is the number of rows in the report.




The boiler-plate code provided is:


<h1>Table Report</h1>
<p>Query used:</p>
<pre><query/></pre>
<p>The report output is:</p>
<report/>
<p>Report complete. <rows/> row(s) returned.</p>


You can edit this in the Create or Edit Report dialog to customize the report.







26.2.1.14.1.2.2 How to Edit User-Defined Reports



You can change the properties of defined reports:





	
Change the name of the report, or the directory where it is stored.


	
Change the database connection you want to use.


	
Use parameters to define a query for the report.


	
Choose the format that the report should be published in.




To edit a report:




	In the Applications window, expand the application, project and offline database.
	Right-click the report and choose Properties to open the Edit Report dialog, where you can examine and change the properties.














26.2.1.15 Transforming from a UML Model


You can transform a UML Class model to an offline database model using the Offline Database Objects from UML Class Model wizard. For more information, see UML-Offline Database Transformation







26.2.1.16 Working with Offline Database Objects in Source Control Systems


JDeveloper provides a number of features for developing in teams, including several version control software systems. These are described in Versioning Applications with Source Control.

Offline database definitions can be version controlled and shared using a source control system. JDeveloper provides a compare tool optimized for working with offline table definitions:

	
You can compare any offline db object. You can either compare with previous version, or get a full version history and compare any two versions.


	
You can track name changes and the identity of objects.


	
You can check for consistency, for example:

	
Ensuring that a column which is used in a key is not dropped.


	
That a constraint which uses an absent column is not added.


	
That a primary key column cannot be optional.





Note:

While you can only compare versions of offline database objects using a source control system, for example to see the dependency of a constraint on a column, you can manually reconcile changes before committing them to a database using the Generate SQL from Database Objects wizard. For more information, see How to Generate Offline Database Objects to the Database .














26.2.2 Working with Database Objects



You can create database objects in a database connection in the Databases window.

You must have a database connection in order to create database objects, and the user name used to create that connection must have the privilege to create the database object, either by having been granted the appropriate privileges (CREATE, DROP, and so on) or having been granted a role such as administrator that contains the privilege.

For more information about Oracle Database objects, see the Oracle® Database SQL Reference.

To create a database object in the Databases window:

	
If necessary, choose Window > Database > Databases window.


	
Expand IDE Connections or application, and expand the database connection.


	
Navigate to the node for the database object type you want to create. Right-click and choose New object from the context menu.

Alternatively, click File > New to open the New Gallery. In the New Gallery, expand Database Tier, and select Database Objects. Select the offline database object type you want to create to launch the Create dialog or wizard.


	
Complete the Create object dialog.

For more information at any time, press F1 or click Help from within the Create object dialog.




To edit a database object:

	
If necessary, choose Window > Database > Databases window.


	
Expand IDE Connections or application, and expand the database connection, and navigate to the node and database object you want to edit.


	
Right-click and choose Edit to open the Edit object dialog.

For more information at any time, press F1 or click Help from within the Create object dialog.




To drop a database object:




	If necessary, choose Window > Database > Databases window.
	Expand IDE Connections or application, and expand the database connection, and navigate to the node and database object you want to drop.
	Right-click and choose Drop.








26.2.3 Using Database Reports


JDeveloper provides a number of predefined reports about the database and its objects. You can also create your own user-defined database reports.

Database reports that query the database for latest information are run from the Database Reports window. For more information, see Using the Database Reports Window.







26.2.4 Validating Date and Time Values


When you create offline table definitions or tables in a database and use date and time default values, JDeveloper validates these values. For a date, you can use:

	
Oracle date functions


	
A quoted string of the form DD-MON-RR, where:

	
The month can be spelled out in full.


	
The year can be written in full, e.g., 2011.


	
The separators (-) can be absent, or any non-alphanumeric character combined with spaces.







For a time stamp, you can use a quoted string of the form DD-MON-RR HH.MI.SSXFF AM TZR, where:

	
The month can be spelled out in full.


	
The year can be written in full, e.g., 2011.


	
The hours and minutes must be present.


	
Seconds, fractions of second, AM/PM, and time zone are optional.


	
The separators (-) can be absent, or any non-alphanumeric character combined with spaces.




When you reverse engineer tables from a database, date and time values are validated according to the rules above. If the validation prevents you from reverse engineering a table from Oracle Database, you can turn it off.

To turn off date and time validation:

	
Choose Tools > Preferences > Database.


	
Uncheck Validate date and time default values.












26.3 Creating Scripts from Offline and Database Objects


You can generate database objects and offline database definitions to SQL scripts, Oracle MetaBase (OMB) files which can be imported into Oracle Warehouse Builder, or SXML files.





26.3.1 How to Create SQL Scripts



You can create SQL scripts from offline database definitions or from database objects.

The script is generated with the default name script1.sql. It is opened in the SQL Worksheet, and listed in the Applications window under the Resources node for the current project.

To create a SQL script from the Databases window or Applications Window:

	
Choose Window > Database > Databases window, expand the database connection and schema, and right-click the database object you want to create the script from.

or

Choose Window > Applications, navigate to the offline database definition you want to create the script from, and right-click the database object you want to create the script from.


	
Choose Generate to > SQL script.


	
The Generate SQL from Database Objects wizard opens where you specify the details of how to create the script. For more information at any time, press F1 or click Help in the dialog.


	
When you click Finish, the script is created and opened in the source editor.




To create a SQL script from the New Gallery:




	Open the New Gallery by choosing File > New.
	In the New Gallery, in the Categories tree, under Database Tier, select Database Files.
	In the Items list, double-click SQL Script from Source Database.
	In the Generate SQL Script from Database Objects wizard, enter details of the script, the source and the objects.

For help with the wizard, press F1 or click Help.




	When you click Finish, the script is created and opened in the source editor.








26.3.2 How to Create OMB Scripts from Tables



You can create files formatted as Oracle MetaBase (OMB) scripts for Oracle Warehouse Builder from offline tables in the Applications window.

The file is generated with the default name omb_scriptn.tcl. It is opened in the source editor, and listed in the Applications window under the Resources node for the current project.

To create a OMB script from the Applications window:

	
Choose Window > Applications, navigate to the offline table or tables you want to create the file from.


	
Right-click and choose Generate to > OMB script.

The file is created and opened in the source editor.




To create a OMB script from the New Gallery:




	Open the New Gallery by choosing File > New.
	In the New Gallery, in the Categories tree, under Database Tier, select Database Files.
	In the Items list, double-click OMB File from Source Database.
	In the Generate OMB Script from Database Objects wizard, enter a name for the file and select the source offline database and click Next.

For help with the wizard, press F1 or click Help.




	On the Select Objects page, choose the offline objects to include in the file, then click Finish.

The file is created and opened in the source editor.












26.3.3 How to Create SXML Scripts



You can create SXML files from offline tables in the Applications window.

A script is generated for each offline database object with the name object-name_object-type.xml. The scripts are opened in the XML Source Editor, and listed in the Applications window under the offline database node.

To create SXML files from the Applications window:

	
Choose Window > Applications, navigate to the offline table or tables you want to create the script from.


	
Right-click and choose Generate to > SXML.

The files are created and opened in the source editor.




To create SXML files from the New Gallery:




	Open the New Gallery by choosing File > New.
	In the New Gallery, in the Categories tree, under Database Tier, select Database Files.
	In the Items list, double-click SXML File from Source Database.
	In the Generate SXML File from Database Objects wizard, enter a name for the script and select the source offline database and click Next.

For help with the wizard, press F1 or click Help.




	On the Select Objects page, choose the offline objects to include in the file, then click Finish.

The file is created and opened in the source editor.

















22 Deploying Applications


This chapter describes how to deploy JDeveloper applications to the JDeveloper integrated application server, or to a target application server, for example to Oracle WebLogic Server or to a third-party server.

This chapter includes the following sections:

	
About Deploying Applications


	
Running Java EE Applications in the Integrated Application Server


	
Connecting and Deploying Java EE Applications to Application Servers


	
Deploying Java Applications


	
Deploying Java EE Applications


	
Post-Deployment Configuration


	
Testing the Application and Verifying Deployment


	
Deploying from the Command Line


	
Deploying Using Java Web Start


	
Deploying Using Weblogic SCA Spring


	
Troubleshooting Deployment








22.1 About Deploying Applications


Deployment is the process of packaging application files as an archive file and transferring it to a target application server. You can use JDeveloper to deploy Java or Java EE applications directly to the application server (such as Oracle WebLogic Server or IBM WebSphere), or indirectly to an archive file as the deployment target, and then install this archive file to the target server.

For application development, you can use JDeveloper to run an application in the integrated application server.

If you are using Oracle Fusion Middleware extensions, refer to the appropriate developer's guide for deployment information specific to the product. For example, if you are deploying an ADF Fusion Web application, see the "Deploying Fusion Web Applications" chapter in Developing Fusion Web Applications with Oracle Application Development Framework.

You can deploy applications in the following ways:

	
Directly to an application server through an application server connection.


	
To an archive file. You can deploy applications indirectly by choosing an archive file as the deployment target. The archive file can subsequently be installed on the target Java EE application server.


	
To a test environment using the JDeveloper integrated application server, a Java EE runtime service used for running and testing JDeveloper applications and projects as Java EE applications and modules within a Java EE container.





Note:

Normally, you use JDeveloper to deploy applications for development and testing purposes. If you are deploying applications for production purposes, you can use Enterprise Manager or scripts to deploy to production-level application servers.

For more information about deployment to later-stage testing or production environments, refer to the appropriate developer's guide for deployment information specific to the product.



Figure 22-1 shows the flow diagram that describes the overall deployment process. Note that preparing the target application server for deployment is outside the scope of this guide; you should refer to the appropriate documentation for a third-party application server.


Figure 22-1 Deployment Overview Flow Diagram

[image: This image is described in the surrounding text]


Java and Java EE applications are based on standardized, modular components and can be deployed to the following application servers:

	
Oracle WebLogic Server

Oracle WebLogic Server provides a complete set of services for those modules and handles many details of application behavior automatically, without requiring programming.


	
Oracle Glassfish Server

You can deploy to Oracle GlassFish Server


	
A third-party application server, that is an application server provided by a vendor other than Oracle:

	
Apache Tomcat


	
IBM WebSphere


	
JBoss


	
GlassFish Server Open Source Edition




For information about which server versions are compatible with JDeveloper, see the JDeveloper Certification Information at http://www.oracle.com/technetwork/developer-tools/jdev/documentation/index.html.




You can also deploy applications to Oracle Java Cloud Service. For more information, see Developing Applications to Deploy to Oracle Java Cloud Service.

You can use JDeveloper to:

	
Run applications in the integrated application server

You can run and debug applications using Integrated WebLogic Server and then deploy to a standalone WebLogic Server or to a third party server.


	
Deploy directly to the standalone application server

You can deploy applications directly to the standalone application server by creating a connection to the server and choosing the name of that server as the deployment target.


	
Deploy to an archive file

You can deploy applications indirectly by choosing an EAR file as the deployment target. The archive file can subsequently be installed on a target application server.




Deployment can be an iterative process where refinements to the application, or corrections to issues in the deployed application, require redeployment to either the test deployment environment, archive file, or application server. The process of deploying an application from JDeveloper can involve a number of processes.





22.1.1 Developing Applications with the Integrated Application Server


JDeveloper is bundled with an integrated application server called Integrated WebLogic Server and a default connection called IntegratedWebLogicServer is defined for it. The integrated application server is a Java EE runtime for services using deployment optimized for the iterative code development cycle. You can use it for running and testing JDeveloper applications and projects as Java EE applications and modules within a Java EE container, as well as for post-run services such as launching a browser or tester. JDeveloper has a default connection to the integrated application server and does not require any deployment profiles or descriptors. In most cases, deploying to the integrated application server is a one-click operation, for example, running a web service by choosing Run from the right-mouse menu of the web service in the Applications window, or running an application by clicking Run on the JDeveloper main menu.

If you want to debug the application use the features described in Running and Debugging Java Projects .







22.1.2 Developing Applications to Deploy to Standalone Application Servers


Typically, for deployment to standalone application servers, you test and develop your application by running it in the integrated application server. You can then test the application further to more closely simulate the production environment by deploying it to standalone Oracle WebLogic Server in development mode or to a third-party application server.

In general, you use JDeveloper to prepare the application or project for deployment by:

	
Creating a connection to the target application server. For more information, see How to Create a Connection to the Target Application Server.


	
Creating deployment profiles (if necessary). For more information, see How to Create and Edit Deployment Profiles.


	
Creating deployment descriptors (if necessary, and that are specific to the target application server). How to Create and Edit Deployment Dependencies.


	
Updating application.xml and web.xml to be compatible with the application server (if required). Viewing or Modifying Deployment Descriptor Properties.


	
Migrating application-level security policy data to a domain-level security policy store. For more information, see Setting Up JDBC Data Sources on .




You must already have an installed application server. For Oracle WebLogic Server, you can use the Oracle 11g Installer or the Oracle Fusion Middleware 11g Application Developer Installer to install one. For other applications servers, follow the instructions in the applications server documentation to obtain and install the server.

You must prepare the application server by creating a global JDBC data source for applications that require a connection to a data source.

After the application and application server have been prepared, you can:

	
Use JDeveloper to:

	
Directly deploy to the application server using the deployment profile and the application server connection.


	
Deploy to an EAR file using the deployment profile.





	
Use Enterprise Manager, scripts, or the application server's administration tools to deploy the EAR file created in JDeveloper. For more information, see the Administering Oracle ADF Applications.










22.1.3 Developing Applications to Deploy to Oracle Java Cloud Service


Developing an application for deployment to Oracle Java Cloud Service is similar to developing an application for deployment to an application server.

You must:

	
Ensure that the application is written in code that is valid to run on Oracle Java Cloud Service.


	
Create a connection to your Oracle Java Cloud Service instance.




For more information, see Developing Applications for Oracle Java Cloud Service - SaaS Extension at:

http://docs.oracle.com/cloud/latest/javacs_gs/CSJSU/GUID-5891AC7A-0110-49D3-BDD2-2EA33D00460D.htm#CSJSU7037

More information about Oracle Cloud services is available at http://docs.oracle.com/cloud/latest/index.html.







22.1.4 Understanding the Archive Formats


A Java EE archive file contains a Java EE module or application. A module consists of one or more JDeveloper projects of a common component type, which have been configured for deployment. An application is comprised of one or more modules. An archive also contains a deployment descriptor, which is an XML file that describes the configuration of the module or application to the server, and is specific to the type of server. A deployment descriptor can be server specific or generic for Java EE servers.

JAR, EJB JAR, and WAR files each contain a module consisting of one or more components. An Enterprise Archive (EAR file) contains an application consisting of one or more modules.

When you create a web (servlet, JSP, JSF, and ADF Faces) or EJB application and deploy it via an application server connection, JDeveloper packages it as a WAR or EJB JAR, which you can optionally wrap in an EAR file. If your application consists of components of differing types, the components will be packaged into multiple modules, which you can deploy independently or assembled as an EAR file.







22.1.5 Understanding Deployment Profiles


Deployment profiles are application or project properties that govern the deployment of a project or application. A deployment profile names the source files, deployment descriptors, and other auxiliary files that will be packaged, the type and name of the archive file to be created, dependency information, platform-specific instructions, and other information.







22.1.6 Understanding Deployment Descriptors


Deployment descriptors define the content and organization of the deployed applications. Deployment descriptor files that are required by an application depend on the technologies the application uses and on its target application server.







22.1.7 Configuring Deployment Using Deployment Plans


You can control how an application is deployed using a deployment plan which allows you to make configuration adjustments in the application deployment descriptors web.xml, weblogic.xml, application.xml, and weblogic-application.xml.

Deployment plans are controlled using a descriptor called plan.xml. Only Weblogic deployment descriptor configuration can be customized using plan.xml. The primary use case for deployment customization is to modify Weblogic specific application configuration for different servers being deployed without requiring modification of the base Weblogic descriptor. For more information, see the section on Deployment Plans in Deploying Applications to Oracle WebLogic Server.







22.1.8 Deploying from the Java Edition


If you are using the Java edition of JDeveloper, which contains only the core Java and XML features, the only deployment actions you can perform are:

	
Creating a simple JAR archive which you can then manually deploy to a server.

JDeveloper Java Edition provides the facility to package applications into a JAR file. The deployment dialog in Java Edition allows for only limited configuration of standard JAR options such as specifying JAR name, file groupings, or dependencies on other deployment profiles. Any application that requires more configuration than this must be deployed from the Studio edition of JDeveloper.


	
Creating deployment profiles as part of extension development. For more information about creating extensions to JDeveloper, see Developing Extensions for Oracle JDeveloper












22.2 Running Java EE Applications in the Integrated Application Server



JDeveloper is installed with Integrated WebLogic Server, an integrated application server which you can use to test and develop your application. For most development purposes, the integrated application server will suffice. When your application is ready to be tested, you can select the run target and then choose the Run command from the main menu.


Note:

The first time you start the integrated application server by running or debugging a project, file, or web service, a dialog is displayed where you enter a password for the administrator ID on the default domain. When you click OK, the default domain is created. You only need to do this once.



When you run the application target, JDeveloper detects the type of Java EE module to deploy based on artifacts in the projects and application. JDeveloper then creates an in-memory deployment profile for deploying the application to the integrated application server. JDeveloper copies project and application files to an "exploded EAR" directory structure. This file structure closely resembles the EAR file structure that you would have if you were to deploy the application to an EAR file. JDeveloper then follows the standard deployment procedures to register and deploy the "exploded EAR" files into the integrated application server. The "exploded EAR" strategy reduces the performance overhead of packaging and unpackaging an actual EAR file.

In summary, when you select the run target and run the application in the integrated application server, JDeveloper:





	
Detects the type of Java EE module to deploy based on the artifacts in the project and application


	
Creates a default deployment profile (that is, without customizations) in memory


	
Copies project and application files into a working directory with a file structure that simulate the "exploded EAR" file of the application.


	
Performs the deployment tasks to register and deploy the simulated EAR into the integrated application server


	
Automatically migrates identities, credentials, and policies. If you plan to deploy the application to a standalone Oracle WebLogic Server instance, you will need to migrate this security information.





Note:

When you run the application in the integrated application server, JDeveloper ignores the deployment profiles that have been created for the application.



The application will run in the base domain in the integrated application server. The base domain has the same configuration as a base domain in a standalone Oracle WebLogic Server instance. In other words, this base domain is the same as if you had used the Oracle Fusion Middleware Configuration Wizard to create a base domain with the default options in a standalone Oracle WebLogic Server instance.

JDeveloper extends this base domain with the necessary domain extension templates, based on the JDeveloper technology extensions. For example, if you have installed JDeveloper Studio, JDeveloper will automatically configure the integrated application server environment with the ADF runtime template (JRF Fusion Middleware runtime domain extension template).

You can use the Application Server Properties dialog to edit the port you want the application to use. However you cannot specify a port number lower than 1024. This setting can be found on the Configuration page of the Application Server Properties dialog. Open the Application Server Navigator, right-click IntegratedWebLogicServer and choose Properties, then click the Configuration tab and enter the desired port number (1024 or greater) in the Preferred Port field.

You can explicitly create additional default domains for the integrated application server which you can use to run and test your applications in addition to using the default domain. Open the Application Servers window, right-click IntegratedWebLogicServer and choose Create Default Domain.







22.2.1 Understanding the Integrated Application Server Log Window


The output messages generated when running or debugging an application in the integrated application server are displayed in a log window which has a title of either Running: IntegratedWebLogicServer or Debugging: IntegratedWebLogicServer.

The content of the Integrated WebLogic Server Log Window includes:

	
Status log messages about the server and the applications running on the server


	
Output from the integrated application server instance's console (in color)


	
Messages generated from deploying the application to the integrated application server


	
Messages that log the Java EE archives (EAR, WAR, and EJB JAR) as they are created. You can click on the links in the log window to browse the generated archives.




The generated log files are located at jdeveloper-user-home/DefaultDomain/server/DefaultServer/logs.

You can configure diagnostic logging parameters in the logging.xml file. Transient loggers can only be added while the server is running in debug mode.

You can control the level of information sent to the log file using the -verbose element in the jsp-descriptor and logging elements of weblogic.xml. For more information, see the weblogic.xml descriptor elements information in Developing Web Applications, Servlets, and JSPs for Oracle WebLogic Server







22.2.2 Rules Governing Deployment to the Integrated Application Server


Deployment to the integrated application server uses default deployment profiles which rely on project metadata for the default mappings. Default contributors to the profiles are based on project dependencies, and the rules governing dependencies are:

	
If project A depends on the build output of project B, then the build output of project B is merged into project A. If project A is a web application, this means the build outputs of project A and project B are both copied into WEB-INF/classes of the resulting WAR.

Merging implies that you can only have one copy of any particular URI, because it can only exist once within WEB-INF/classes.


	
If project A depends on the deployment profile of project B, for example a JAR profile, then the result of that deployment profile is included in the WEB-INF/lib of the resulting WAR.


	
A project containing a WEB-INF/web.xml is recognized as a web project and a default WAR profile is created for it.


	
A project that contains at least one session EJB bean is recognized as an EJB project and  a default EJB JAR profile is created for it.


	
All libraries marked Deploy by Default for a web project are deployed as a web application library (in the WEB-INF/lib of the WAR).


	
All libraries marked Deploy by Default for an EJB project are deployed as an application library (in the lib of the EAR).


	
If an EJB Project A depends on the build output of Project B, the build output (e.g. classes directory) of Project B is merged with the build output of Project A and deployed in the root directory of the EJB JAR.










22.2.3 Working with Integrated Application Servers



The definition of an integrated application server controls the interaction of the instance with JDeveloper and your computer system.

JDeveloper is bundled with an integrated application server called Integrated WebLogic Server, and a default instance called IntegratedWebLogicServer is defined for it. All applications are bound by default to IntegratedWebLogicServer.

You can modify the properties of the integrated application server that an application is bound to.


Note:

WebLogic Server domains used as integrated application servers must be collocated on the same host as the JDeveloper process.



To modify the properties of the integrated application server that an application is bound to:




	In the Applications window, select a project.
	Choose Application > Application Properties.
	Select Run from the left panel.
	Select an existing integrated application server in Bind Application to Server Instance, or click Application Server Properties to open the Application Server Properties dialog, where you can change some properties for the integrated application server.
	Define the other options for the integrated application server, including startup and shutdown options. For more information, press F1 or click Help from within the dialog.



You can create a new integrated application server instances.







22.2.3.1 How to Create a New Integrated Application Server Connection



To define an integrated server connection:




	In the Application Servers window, right-click Application Servers and choose New Application Server. The Create Application Server Connection wizard opens. For more information at any time, press F1 or click Help from within the wizard.
	On the Usage page, select Integrated Server. If you want to manage the server from within JDeveloper, select Let JDeveloper manage the lifecycle for this Server Instance on the Name and Domain page, and provide the Domain and Server Instance directories.
	Complete the wizard.








22.2.3.2 How to Run and Debug with an Integrated Application Server



By default, the integrated application server is automatically started when you run or debug an EJB, servlet, HTML, web service, or JSP project. Alternatively, you can start the integrated application server by clicking Start Server Instance or Debug Server Instance from the Run menu.

After it has been started, an integrated application server does not terminate automatically when you terminate a running Java EE application. Therefore, you can select an object, such as a JSP or a servlet in the Applications window, and choose an option from the Run menu.

You can run or debug a working set, which is a group of files created by applying a named filter to a project, by choosing the Use Current Working Set (Java JEE Only) option from the Run menu.

Once this is enabled, when you select Run or Debug from the context menu of the source editor or from a node in the Applications window, it is the current working set that is run or debugged.

Only a single integrated application server can be run at any given time. Thus, if you attempt to start another instance of the server, JDeveloper will shut down the previous instance and restart the instance in order to perform the requested task on the selected icon in the Applications window. After an integrated application server is started, multiple applications can run on it independently of each other. If an application is running, rerunning the application redeploys the up-to-date version of the application.

To run in an integrated application server, an application must be bound to a server instance. JDeveloper is supplied with a WebLogic Server domain, and a default server instance named DefaultServer is defined for it. The unique integrated application server connection defined for this integrated application server is called IntegratedWebLogicServer, and has the Domain Home defined as the system directory $SYSTEM_ROOT/DefaultDomain. All applications are bound by default to IntegratedWebLogicServer.









22.2.3.3 Working with the Default Domain



If you have not explicitly created the integrated application server's default domain, it will automatically be created with default settings when you start the server by running or debugging an application.

Alternatively, you can explicitly create the default domain from the Application Servers window.

If necessary, you can delete the existing default domain so that you can create it again to use new values.

To explicitly create the integrated application server's default domain:

	
If necessary, open the Application Servers window by choosing Window > Application Servers.


	
Right-click the integrated application server connection IntegratedWebLogicServer and choose Create Default Domain. The Configure Default Domain dialog opens, where you can accept the defaults, or explicitly set other values, such as choosing a different listen address. For more information at any time, click Help or press F1 from the Configure Default Domain dialog.




When you install extensions to JDeveloper you may have to update the integrated application server's default domain.

To update the integrated application server's default domain:




	If necessary, open the Application Servers window by choosing Window > Application Servers.
	Right-click the integrated application server connection IntegratedWebLogicServer and choose Update Default Domain.



If you have already created the default domain, but you need to use specific settings you can delete the existing default domain and create it again.

To delete the integrated application server's default domain, With JDeveloper closed, locate the system folder in the file system and delete it. When you restart JDeveloper, you can create a new default domain for the integrated application server.

After the server has started, select Processes from the Window menu to display the integrated application server process.


Note:

You can run more than one application simultaneously on a server in run mode, however you can only debug one application at a time in debug mode. To return JDeveloper back into non-debug editing mode, the integrated application server must be shut down.











22.2.3.4 One-Click Running of Applications in the Integrated Application Server


You can test an application by running it in the integrated application server. You can also set breakpoints and then run the application with the integrated application server in debug mode. For more information about running and debugging, see Running and Debugging Java Projects .

To run an application in the integrated application server:

	
In the Applications window, select the run target, for example a project, web service, unbounded task flow, or JSF page.


	
Right-click the run target and choose Run or Debug. Alternatively, choose Run or Debug from the main menu.

The first time you start the integrated application server by running or debugging an application, a dialog is displayed where you enter a password for the default user weblogic on the default domain. When you click OK, the default domain is created. You only need to do this once.





Application-level and Global Data Sources

If you are deploying to an integrated application server, you can use application level data sources or global data sources.




For both one-click deployment to an integrated application, JDeveloper ensures that your web application web.xml, or EJB application ejb-jar.xml, contains the necessary <resource-ref> entry to identify an application resource name. The name is jdbc/connection-nameDS, where connection-name is the name of the application resources connection.

The application looks up this data source using the application-specific resource JNDI namespace of java:comp/env/jdbc/connection-nameDS, and it finds this resource because web.xml contains the <resource-ref> entry for jdbc/connection-nameDS.

To use application level data sources in one-click deployment to Integrated WebLogic Server, select Auto Generate JDBC Connections When Running Application in JDeveloper on the WebLogic page of the Application Properties dialog (available from the Application menu). This:

	
Generates a file called connection-name-jdbc.xml in the /META-INF directory of the application's EAR file


	
Creates a corresponding <module> entry in the weblogic-application.xml file in META-INF that references this JDBC module




If the application uses more than one application resources database connection, then a connection-name-jdbc.xml file will be created for each, and there will be a similar number of <module> entries in the weblogic-application.xml file.

To use global data sources in one-click deployment to Integrated WebLogic Server, deselect Auto Generate JDBC Connections When Running Application in JDeveloper on the WebLogic page of the Application Properties dialog (available from the Application menu), and:

	
Connect to the Integrated WebLogic Server Administration Console, described in How to Log In to the Integrated WebLogic Server Administration Console.


	
Create the global data source in a similar manner to creating one on Oracle WebLogic Server, see Setting Up JDBC Data Sources on .










22.2.3.5 How to Start the Integrated Application Server



By default, the integrated application server is automatically started when you run or debug an EJB, servlet, or JSP project. Therefore, you can select an object, such as a JSP or a servlet in the Applications window, and choose an option from the Run menu.


Note:

The first time you start the integrated application server by running or debugging a project, file, or web service, a dialog is displayed where you enter a password for the administrator ID on the default domain. When you click OK, the default domain is created. You only need to do this once.



Only a single integrated application server can be run at any given time. Thus, if you attempt to start another instance of the server, JDeveloper will shut down the previous instance and restart the instance in order to perform the requested task on the selected icon in the Applications window.

After the server has started, open the Processes window to display the integrated application server process. You can open the Processes window by choosing Window > Processes from the main menu.

To start an integrated application server:

	
If necessary, open the Application Servers window by choosing Window > Application Servers.


	
Right-click the Integrated WebLogic Server connection and choose Start Server Instance.




Alternatively, choose Run > Start Server Instance from the main menu.

To start an integrated application server in debug mode:




	If necessary, open the Application Servers window by choosing Window > Application Servers.
	Right-click the Integrated WebLogic Server connection and choose Debug Server Instance.



Alternatively, choose Run > Debug Server Instance from the main menu.









22.2.3.6 How to Cancel a Running Deployment



If you are running a large application on the integrated application server, you can cancel it before it has finished deploying.

To cancel a running deployment, In the Log Window, click the Terminate button and choose the profile or application you want to cancel.









22.2.3.7 How to Terminate an Integrated Application Server



After an integrated application server has started, the integrated application server process appears in the Processes window. For more information, see Understanding the Processes Window.

You can open the Processes window by choosing Window > Processes from the main menu.


Note:

Applications deployed on an integrated application server are automatically undeployed whenever the integrated application server is terminated.



The default behavior is to undeploy all the applications, but you can change the behavior.

To shutdown the running integrated application server, do one of the following:





	
Choose Run > Terminate > IntegratedWebLogicServer (or the integrated application server connection name) from the main menu.


	
Select the integrated application server name from the Terminate dropdown list in the toolbar.


	
Choose Window > Processes from the main menu. Right-click the integrated application server name and choose Terminate.


	
Choose File > Exit to exit JDeveloper. Click Yes when prompted to terminate the instance's process.


	
In the Application Servers window, right click on the integrated application server connection and select Terminate Server Instance.




To force shutdown of Integrated WebLogic Server:

	
If you need to force shutdown of Integrated WebLogic Server, press the Terminate button twice.












22.2.3.8 How to Configure Startup and Shutdown Behavior for Integrated Application Servers



You can configure startup and shutdown behavior for integrated application server connections.

To configure the startup and shutdown behavior for an integrated application server:




	If necessary, open the Application Servers window by choosing Window > Application Servers.
	Right-click the integrated application server connection and choose Properties to open the Application Server Properties dialog. For more information at any time, press F1 or click Help from within the dialog.

If you are viewing the properties of the default integrated application server, you can only change settings on the Configuration, Shutdown and Launch Settings tabs in the dialog. Otherwise, you can edit everything except the connection name.












22.2.3.9 How to Log In to the Integrated WebLogic Server Administration Console



The integrated application server is an implementation of Oracle WebLogic Server and as such you can connect to the server's Administration Console.


Note:

To log in to the Administration Console, you must have the integrated application server running from JDeveloper, for example:

	
By starting Integrated WebLogic Server from the Application Servers window.


	
By running an application.






To launch and log in to the integrated application server Administration Console:




	If necessary, open the Application Servers window by choosing Window > Application Servers.
	Right-click IntegratedWebLogicServer and select Launch Administrative Console. A browser instance opens at the login page, which is http://host:port/console.

For example, if the default configuration is used, the browser uses http://localhost:7001/console.




	Log in using the username for the default domain and password you used when the integrated application server was launched for the first time.



The integrated application server is an implementation of Oracle WebLogic Server, so for more information about the integrated application server Administration Console refer to the Administration Console Online Help, which is available from the WebLogic Server online documentation in your JDeveloper installation, or from the Administration Console.













22.3 Connecting and Deploying Java EE Applications to Application Servers


Before you deploy an application to a standalone application server, you must perform prerequisite tasks within JDeveloper to prepare the application for deployment.

Figure 22-2 show the process flow to prepare the application for deployment. After the application has been prepared and the application server has been prepared, you can proceed to deploy the application.


Figure 22-2 Preparing the Application for Deployment Flow Diagram

[image: This image is described in the surrounding text]





22.3.1 How to Create a Connection to the Target Application Server



You can deploy applications to the application server via JDeveloper application server connections.

This section describes how to generically create a connection to an application server. For information about connecting to a specific type of application server, see Connecting to Specific Application Server Types.

Before you begin:





	
Ensure that the application server is installed and started.


	
If you are working behind a proxy server you may want to be check the proxy settings that JDeveloper is using.

	
Choose Tools > Preferences to open the Preferences dialog and navigate to the Web Browser and Proxy page. For more information at any time, press F1 or click Help in the Web Browser and Proxy page of the Preferences dialog.


	
On the Proxy Settings tab you can see the proxy settings that JDeveloper is using, and if necessary change them. By default, JDeveloper uses the system default proxy settings. You can override these by choosing No Proxy, Use Automatic Configuration Script, or Manual Proxy Settings and entering your settings as appropriate. See Configuring Proxy Settings.







To create a connection to an application server:

	
Launch the Application Server Connection wizard in one of the following ways:

	
In the Application Servers window, right-click Application Servers and choose New Application Server.


	
In the New Gallery, expand General, select Connections and then Application Server Connection, and click OK.


	
In the Resources window, choose New > New Connection > Application Server.





	
If the Usage page of the wizard is displayed, ensure that Standalone Server is selected and click Next.


	
In the Name and Type page, enter a name for your new connection.


	
In the Connection Type dropdown list, choose the type of application server you want to create a connection to. The options are:

	
WebLogic 10.3 or WebLogic 12.x to create a connection to Oracle WebLogic Server


	
GlassFish 3.1 to create a connection to Oracle GlassFish Server or GlassFish Open Source Edition


	
JBoss 5.x to create a connection to JBoss


	
Tomcat 7.x to create a connection to Tomcat


	
WebSphere Server 8.x to create a connection to IBM WebSphere Server


	
Oracle Cloud to create a connection to Oracle Java Cloud Service





	
Click Next.


	
On the Authentication page, enter a user name and password for the administrative user authoriweblogic1zed to access the application server.


	
Click Next.


	
On the Configuration page, enter the parameters to create a connection to the application server:


	
Click Next.


	
If you have chosen WebSphere, the JMX page appears where you enter JMX configuration values needed for deploying SOA applications.


	
Click Next.


	
On the Test page, click Test Connection to test the connection.

JDeveloper performs several types of connections tests. The JSR-88 test must pass for the application to be deployable. If the test fails, return to the previous pages of the wizard to fix the configuration.


	
Click Finish.








How to Launch Oracle WebLogic Server Administration Console

You can launch and connect to the Oracle WebLogic Server Administration Console from the Application Servers window.






Note:

To log in to the console, the server must be started.



	
In the Application Servers window, right-click the name of the connection to the Oracle WebLogic Server instance, and choose Launch Admin Console. A browser instance opens at the login page, which is http://host:port/console.

For example, if the default configuration is used, the browser uses http://localhost:7001/console.


	
Log in using the username and password you used when creating the connection to the Oracle WebLogic Server instance. If you are launching the Administration Console for Integrated WebLogic Server, the default user is weblogic and the password you entered when the default domain was created.




For more information about the WebLogic Server Administration Console, refer to the Administration Console Online Help, which is available from the WebLogic Server online documentation in your JDeveloper installation, or from the Administration Console.









22.3.2 Connecting to Specific Application Server Types


This section contains the specific information for accounting to different types of application server.

JDeveloper supports deploying to server clusters, but you cannot use JDeveloper to deploy to individual managed servers that are members of a cluster.





22.3.2.1 Connecting to Oracle WebLogic Server



To connect to Oracle WebLogic Server:





	
The Oracle WebLogic host name is the name of the WebLogic Server instance containing the TCP/IP DNS where your application (.jar,.war,.ear,.gar) will be deployed.


	
In the Port field, enter a port number for the Oracle WebLogic Server instance on which your application (.jar,.war,.ear,.gar) will be deployed.

If you do not specify a port, the port number defaults to 7001.


	
In the SSL Port field, enter an SSL port number for the Oracle WebLogic Server instance on which your application (.jar,.war,.ear,.gar) will be deployed.

Specifying an SSL port is optional. It is required only if you want to ensure a secure connection for deployment.

If you do not specify an SSL port, the port number defaults to 7002.


	
Select Always Use SSL to connect to the Oracle WebLogic Server instance using the SSL port.


	
Optionally enter a WebLogic Domain only if Oracle WebLogic Server is configured to distinguish non administrative server nodes by name.












22.3.2.2 Connecting to GlassFish



If you are creating a secure connection to a GlassFish server, you must use the host name, for example localhost, instead of an IP address in Host name on the Configuration page, otherwise, the connection will fail. This is because the host name in the URL used to create the connection the server must match the host name in the certificate.









22.3.2.3 Connecting to JBoss



For JBoss:





	
Enter or browse to the location of the JBoss deploy directory, where your application files (.jar,.war,.ear,.gar) are.


	
If you are using JMX, Select Enable JMX for this connection. (optional).


Note:

JMX configuration is optional and is not required for connecting to the JBoss Application Server. JMX is only needed for deploying SOA applications.

You must use the Oracle JMX RMI connector (oracle-jboss-remoting.sar) on the JBoss server; the standard JBOSS JMX connector (jmx-remoting.sar) does not work with JDeveloper.




	
In the Host Name field, enter host name of the target server. The default is the machine name.


	
In the RMI Port field, enter the port number of JBoss's RMI connector port. The default is 19000.












22.3.2.4 Connecting to Tomcat



For Tomcat:





	
In the Webapps Directory field enter or browse to the location of the webapps directory where you place the application .war files.












22.3.2.5 Connecting to WebSphere Server



For WebSphere:





	
In the Host Name field, enter the name of the WebSphere server containing the TCP/IP DNS where your Java EE applications (.jar, .war, .ear, [.gar]) are deployed. If no name is entered, the name defaults to localhost


	
In the SOAP Connector Port field, enter the port number. The host name and port are used to connect to the server for deployment. The default SOAP connector port is 8879


	
In the Server Name field, enter the name assigned to the target application server for this connection.


	
In the Target Node field, enter the name of the target node for this connection. A node is a grouping of Managed Servers. The default is machineNode01, where machine is the name of the machine the node resides on


	
In the Target Cell field, enter the name of the target cell for this connection. A cell is a group of processes that host runtime components. The default is machineNode01Cell, where machine is the name of the machine the node resides on.


	
In the Wsadmin script location field, enter, or browse to, the location of the wsadmin script file to be used to define the system login configuration for your IBM WebSphere application server connection. Note that you should not use the wsadmin files from the ORACLE_HOME/oracle_common/common/bin directory, which are not the correct version. The default location is websphere-home/bin/wsadmin.sh for Unix/Linux and websphere-home/bin/wsadmin.bat for Windows.


Note:

When the script file is specified you can encounter problems if the path contains a space. For example, C:\Program Files (x86)\IBM\WebSphere\AppServer\profiles\AppSrv01\bin\wsadmin.bat To work around this problem, use an OS short name for the directory with a space in the name (for example, Progra~1), or create a WebSphere application server instance in a path that does not have spaces and refer to the batch file there.




	
If you have chosen WebSphere, the JMX page appears. On the JMX page, enter the JMX information (optional):


Note:

JMX configuration is optional and is not required for connecting to the WebSphere Application Server. JMX is only needed for deploying SOA applications.



	
Select Enable JMX for this connection to enable JMX.


	
In the RMI Port field, enter the port number of WebSphere's RMI connector port. The default is 2809.


	
In the WebSphere Runtime Jars Location field, enter or browse to the location of the WebSphere runtime JARs.


	
In the WebSphere Properties Location (for secure MBEAN access) field, enter or browse to the location of the file that contains the properties for the security configuration and the mbeans that are enabled. This field is optional.















22.3.2.6 Connecting to Oracle Java Cloud Service



After you sign up for Oracle Java Cloud Service, you will receive information about the data center, the identity domain, and the service name which you use to establish a connection to your Oracle Java Cloud Service instance:

To connect to the Oracle Java Cloud Service, you need to enter the following information:





	
On the Authentication page, enter the administration username and password.


	
On the Configuration page, choose the data center and enter the identity domain and service name for your Oracle Java Cloud Service instance.














22.3.3 How to Create and Edit Deployment Profiles



A deployment profile defines the way the application is packaged into the archive that will be deployed to the target environment. The deployment profile:





	
Specifies the format and contents of the archive file that will be created


	
Lists the source files, deployment descriptors, and other auxiliary files that will be packaged


	
Describes the type and name of the archive file to be created


	
Highlights dependency information, platform-specific instructions, and other information










22.3.3.1 About Deployment Profiles


Deployment to application servers uses deployment profiles which rely on project metadata for the default mappings. Default contributors to the profiles are based on project dependencies, although you can customize the deployment profiles to change them.

The rules governing dependencies are:

	
If project A depends on the build output of project B, then the build output of project B is merged into project A. If project A is a web application, this means the build outputs of project A and project B are both copied into the WEB-INF/classes of the resulting WAR.

Merging implies that you can only have one copy of any particular URI, because it can only exist once within WEB-INF/classes.


	
If project A depends on the deployment profile of project B, for example a JAR profile, then the result of that deployment profile is included in the WEB-INF/lib of the resulting WAR.


	
All libraries marked Deploy by Default for a web project are deployed as a web application library (in the WEB-INF/lib of the WAR).


	
All libraries marked Deploy by Default for an EJB project are deployed as an application library (in the lib of the EAR).


	
All libraries marked Deploy by Default at the application level are deployed as an application library (in the lib of the EAR).


	
If an EJB Project A depends on the build output of Project B, the build output (for example, classes directory) of Project B is merged with the build output of Project A and deployed in the root directory of the EJB JAR.




Application level deployment profiles are:

	
EAR files: Used to deploy the Java EE enterprise archive (EAR) file. The EAR file consists of the application's assembled WAR, EJB JAR, and client JAR files.


	
MAR files: Used for deploying metadata archive files for seeded customizations or base metadata in an MDS repository in the application server. For more information about MAR files, refer to the appropriate developer's guide for the Oracle Fusion Middleware product you are using.




Project level Java EE deployment profiles are:

	
Business Components Archive: Creates a simple archive file for deploying ADF Business Components.


	
Business Components Service Interface: Creates a profile for deploying ADF Business Components as a service interface.


	
Client JAR File: Used for deploying the standard Java EE client JAR file.


	
EJB JAR File: Used to deploy the Java EE EJB module (EJB JAR). The EJB JAR contains the EJB components and the corresponding deployment descriptors.


	
Extension JAR: Creates a profile for deploying an extension as a JAR file.


	
JAR file: Creates a simple JAR archive from a project.


	
GAR file: Creates an Oracle Coherence grid archive file. The GAR contains the artifacts of a Coherence application and includes a deployment descriptor.


	
MOF Model Library: Creates MOF (Meta-Object Facility) Model Library JAR files which enable UML objects from one project to be reused by another.


	
OSGi Bundle: Creates an OSGi bundle that can be deployed to an OSGi container. You use this when you create extensions to JDeveloper.


	
RAR file: Creates a profile for deploying a Java EE connector RAR file.


	
Shared Library JAR file: Creates a profile for deploying a simple archive, which can be a JAR of ZIP file, to the file system or as a shared library to a remote server.


	
Taglib JAR file: Creates a profile for deploying custom tag libraries to a JAR file.


	
WAR files: Used to deploy the JAVA EE web module (WAR). The WAR consists of the web components (JSPs and servlets) and the corresponding deployment descriptors.










22.3.3.2 Creating Deployment Profiles



To create a deployment profile, select an application or a project then choose File > New > From Gallery, and from the General category, choose Deployment Profile. To create application level profiles, invoke the New Gallery at application level.

Other methods can be used to create a deployment profile:





	
Use the Application Properties Deployment dialog:

	
From the JDeveloper toolbar, select Application > Deploy > New Deployment Profile...


	
Right-click on an application and select Deploy > New Deployment Profile... from the context menu.


	
In the Applications window, open the dropdown list on the Applications window toolbar. and choose Deploy.





	
Use the Project Properties Deployment dialog:

	
Select the project in the Applications window, then from the menu, choose Application > Project Properties. Choose Deployment, and in the Deployment panel on the right, click the New Profile icon on the menu bar.


	
The context menu of a project in the Applications window.







To modify an existing deployment profile:

	
Right-click the project in the Applications window and choose Project Properties then choose Deployment in the tree structure in the wizard, then select the deployment profile and choose Edit.


	
Right-click the application in the Applications window and choose Application Properties then choose Deployment in the tree structure in the wizard, then select the deployment profile and choose Edit.




To activate profile deployment:

	
For a project level deployment profile, right-click the project in the Applications window then choose Deploy > deployment profile.


	
For an application deployment profile, right-click the application in the Applications window then choose Deploy > deployment profile. Alternatively,

	
Right-click the application in the Applications window then choose Deploy > deployment profile.


	
Choose Deploy > deployment profile from the context menu of an application.


	
Choose Deploy > deployment profile from the dropdown list on the Applications window toolbar.







The project and any projects on which it depends will be compiled and packaged.

You may find that the application you created already contains the deployment profile you need, for example if you create a web-based project you should already have a default WAR deployment profile which includes the dependent model projects it requires.

To create a deployment profile:




	For an application level deployment profile, in the Applications window, right-click the application and choose New.

For a project level deployment profile, in the Applications window, right-click the project that you want to deploy and choose New.




	In the New Gallery, expand General, select Deployment Profiles and then choose the deployment profile type you want, and click OK.

If you don't see Deployment Profiles in the Categories tree, click the All Features tab.




	Choose the deployment profile type you want to create, and click OK. For example, for an EAR deployment profile:

	
Select Application Assembly and then in the Java EE Modules list, select all the project profiles that you want to include in the deployment, including any WAR profiles.


	
(Optional) Select Platform, select the application server you are deploying to, and then select the target application connection from the Target Connection dropdown list.

By default, deployment will set this platform at deployment time to match the server you are deploying to. When you are deploying to a file, the default will be the "default platform" which is the latest Oracle Weblogic server release, in this case, Oracle WebLogic Server 12.x.







	In the Edit Deployment Profile Properties dialog, configure the profile by setting property values. For example, you may want to change the file groups that are included in the profile. When you have finished, click OK.



Deployment profiles are available from the Application Properties dialog, for application level deployment profiles, or from the Project Properties dialog, for project level deployment profiles, and you can edit them or delete them.









22.3.3.3 Viewing and Changing Deployment Profile Properties



After you have created a deployment profile, you can view and change its properties.

To edit or delete a deployment profile:




	For an application level deployment profile, choose Application > Application Properties to open the Application Properties dialog.

For a project level deployment profile, choose Application > Project Properties to open the Project Properties dialog.




	Click Deployment in the left panel to open the Deployment page.
	Choose the deployment profile you want to edit or delete, and click:

	
Edit to open the Edit Deployment Profile Properties dialog.


	
Delete to delete the deployment profile.















22.3.3.4 Configuring Deployment Profiles


Configuring is the process of assembling an archive file from its component files. Configuring is specified in the File Groups branch of deployment profile properties dialogs.

The File Groups branch consists of a list of file groups, each specifying some components. The packaged archive will be the union of all the file groups. The order of the file groups resolves name collisions: if two files have the same name, the one from the file group higher in the list is included, and the one from the lower file group is omitted.

A newly created deployment profile will include one or more predefined file groups. You can add, delete, and edit file groups.

File groups are defined by a set of contributors pruned by a set of filters. Contributors are source files, JAR files, and directories that are selected for inclusion. Filters are rules that are applied to the contributors or contributor's component subdirectories and files to identify the set and files that will be packaged. There are three kinds of file groups:

	
The Packaging file group type allows you to select contributors, project directories and other directories and JAR files, and filters. The file group mechanism is flexible and transparent, and is appropriate for most projects.


	
The Libraries file group type allows you to select contributors that are project libraries. A libraries file group is created for WAR deployment profiles. Libraries files groups are useful in other projects that need to repackage existing JAR files.












22.3.4 How to Create and Edit Deployment Dependencies


Deployment dependencies between the components of an application are stated in their project's deployment profiles. In a project's deployment profile, name the profiles for the projects that are immediately upstream. When a deployment profile is activated for deployment, its dependencies will first be deployed.

Set deployment profile dependencies on the deployment profile's Profile Dependencies page. Only deployment profiles in the current application are listed and available for selection. Click the Help button for more information. The various profile dependencies you can select include:

	
Profile-to-profile dependency


	
Profile-to-JAR dependency


	
Profile-to-WAR dependency


	
Profile-to-RAR (Resource Archive) dependency




When deploying a profile contained in a project that has project-to-profile dependencies on other profiles, at deploy-time the profile incorporates the dependencies specified in the project. For example, if Project1.jpr contains Servlet1.java and depends on ejb1.jar, and project2.jpr contains MySessionEJB and ejb1.jar, then deploying the first project will result in an EAR file containing both webapp1.war and ejb1.jar.

When creating profile dependencies between JAR, WAR, and EJB JAR modules that share common JAR files, you can use the META-INF/MANIFEST.MF Class-Path attribute to link JAR files together at deploy-time. From the deployment profile properties JAR options page, select Include Manifest File (META-INF/MANIFEST.MF). Doing so causes a single shared copy of any common JARs to be included in the EAR file.

Dependency projects can have dependencies of their own, but cyclical dependencies should be avoided. When JDeveloper encounters a circular dependency it will attempt to deploy anyway, but a warning will be displayed in the log window.





22.3.4.1 About Library Dependencies


Dependent libraries are any library needed for a module to compile and run. In the Libraries and Classpath page of the Project Properties dialog for the project containing the library, dependent libraries are shown as available for export.

In an application, dependent libraries can be in the following projects:

	
Projects of the current module's profile, that is the profile container.


	
Projects that the profile container depends on.


	
Projects associated with any profile dependency for this module's profile (recursively to its profile and project dependencies).




The example below illustrates project dependencies (arrows on the left) and profile dependencies (arrows on the right).


Figure 22-3 Dependencies Between Projects and Deployment Profiles

[image: This image is described in the surrounding text]


Project dependencies are recursive at deployment time, even though they are not at compile time, which is why the libraries from JavaProject are considered dependent libraries. WebProfile, which represents a web module, has the following dependent libraries:

	
EjbDepLib (a library from a project dependency to WebProject)


	
EjbDep.jar (a library jar from a project dependency to WebProject)


	
JavaDepLib (a library from a recursive project dependency to JavaProject)


	
JavaDep.jar (a library jar from a recursive project dependency to JavaProject)


	
SampleLib (a library from a profile dependency)


	
Sample.jar (a library jar from a profile dependency)


	
OtherLib (a library from a recursive profile dependency)


	
Other.jar (a library jar from a recursive profile dependency)








22.3.4.1.1 Resolved and Unresolved Libraries


Dependent Libraries can either be resolved or unresolved. Dependent libraries are considered unresolved until they are included in an archive and placed on the classpath, thereby making the library content available to classes that need to reference it.

For example, a WAR profile resolves libraries by selecting those libraries in a library file group contributor where the target output directory is WEB-INF\lib. This ensures that the WAR archive created will include those libraries in the archive's WEB-INF\lib directory and thereby including the library content on the WAR archive's classpath.

When a library is not resolved by a deployment profile, this profile will expose the unresolved library in the application hierarchy so that it can be resolved at a higher level. Consider the situation where libraries contained in an EJB project remain unresolved from the EJB profile's perspective. This information will be exposed so that an EAR profile can ensure that those libraries are resolved at the EAR level (in the EAR profile's library file group).

In the illustration above, WebProject has a project dependency to JavaProject, and JavaProject includes a library called JavaDepLib. You can define a web application which creates a WAR deployment profile on WebProject. You can then resolve JavaDepLib in the web module by ensuring that this library is selected in the WEB-INF\lib library file group of the WAR deployment profile.







22.3.4.1.2 Manifest Entries for Libraries


When libraries are included in an EAR archive in a directory other than the standard \lib or APP-INF\lib, JDeveloper automatically inserts the required manifest entries into the modules that refer to those libraries.











22.3.5 How to Create and Edit Deployment Descriptors


Deployment descriptors are server configuration files that define the configuration of an application for deployment and that are deployed with the Java EE application as needed. The deployment descriptors that a project requires depend on the technologies the project uses and on the type of the target application server. Deployment descriptors are XML files that can be created and edited as source files, but for most descriptor types, JDeveloper provides dialogs or an overview editor that you can use to view and set properties. If you cannot edit these files declaratively, JDeveloper opens the XML file in the source editor for you to edit its contents.

In addition to the standard Java EE deployment descriptors (for example, application.xml and web.xml), you can also have deployment descriptors that are specific to your target application server. For example, if you are deploying to Oracle WebLogic Server, you can also have weblogic.xml, weblogic-application.xml, and weblogic-ejb-jar.xml.

The essential descriptors are created by the wizards that create deployment profiles. Add other descriptors only if you wish to override default behavior. In some cases descriptors will be created and included in archive files as they are deployed.

Deployment descriptors can also be created from the New Gallery. Deployment descriptors are placed in a META-INF subfolder of a project's Application Sources or WEB-INF subfolder of a project's Web Contents folders.

Each Java EE standard deployment descriptor is extended by a corresponding Oracle WebLogic Server-specific descriptor. Table 22-1 provides a description of these files and illustrates how they relate to one another.




Table 22-1 Deployment Descriptors

	Java EE Standard Descriptors	Oracle WebLogic Server Proprietary Descriptors
	
application-client.xml

Describes the EJB modules and other resources used by a Java EE application client deployed as an archive.

	
weblogic-appclient.xml

The file format is defined in weblogic-appclient.xsd.

For more information, see the chapter about client application deployment descriptor elements in Developing Stand-alone Clients for Oracle WebLogic Server.


	
application.xml

Specifies the components of a Java EE application, such as EJB and web modules, and can specify additional configuration for the application as well. This descriptor must be included in the /META-INF directory of the application's EAR file.

	
weblogic-application.xml

The file format is defined in weblogic-application.xsd.

For more information, see Developing XML Applications for Oracle WebLogic Server.


	
ejb-jar.xml

Defines the specific structural characteristics and dependencies of the Enterprise JavaBeans within a JAR, and provides instructions for the EJB container about how the beans expect to interact with the container.

	
weblogic-ejb-jar.xml

The format of this file is defined in weblogic-ejb-jar.xsd.

persistence-configuration.xml

For EJB 3.x modules. The format of this file is defined in persistence-configuration.xsd.

For more information, see Developing Enterprise JavaBeans for Oracle WebLogic Server.

weblogic-cmp-rdbms-jar.xml


	
ra.xml

Contains information on implementation code, configuration properties and security settings for a resource adapter packaged within a RAR file.

	
weblogic-ra.xml

The format of this file is defined in weblogic-ra.xsd.

For more information, see tDeveloping Resource Adapters for Oracle WebLogic Server.


	
web.xml

Specifies and configures a set of Java EE web components, including static pages, servlets, and JSP pages. It also specifies and configures other components, such as EJBs, that the web components might call. The web components might together form an independent web application and be deployed in a standalone WAR file.

	
weblogic.xml

The format of this file is defined by weblogic-web-app.xsd.

For more information, see Developing XML Applications for Oracle WebLogic Server.


	
None.

	
module-name-jdbc.xml

Defines data sources to be used in the deployed application.

The format of this file is defined by weblogic-jdbc.xsd.

For more information, see Administering JDBC Data Sources for Oracle WebLogic Server.

plan.xml

The format of this file is defined by deployment-plan.xsd.

Contains a list of name/value pairs, and a description of the various deployment descriptors in an application. It allows administrators to override values in deployment descriptors.

For more information, see Deploying Applications to Oracle WebLogic Server.

weblogic-diagnostics.xml

The format of this file is defined by weblogic-diagnostics.xsd.

Used in the WebLogic Server Administration Console to create or modify diagnostic monitors in the diagnostic application module.

For more information, see Oracle Application Server 10g Release Notes for AIX Based Systems.

weblogic-jms.xml

The format of this file is defined by weblogic-jms.xsd.

Used to configure JMS drivers in the Oracle WebLogic Server.

For more information, see Developing JMS Applications for Oracle WebLogic Server.

weblogic-webservices.xml

The format of this file is defined by weblogic-webservices.xsd.

For more information, see WebLogic Web Services Reference for Oracle WebLogic Server.











22.3.5.1 Creating Deployment Descriptors



JDeveloper automatically creates many of the required deployment descriptors for you. If they are not present, or if you need to create additional descriptors, you can explicitly create them.

Before you begin:

Check to see whether JDeveloper has already generated deployment descriptors.

To create a deployment descriptor:

	
In the Applications window, right-click the project for which you want to create a descriptor and choose New.


	
In the New Gallery, expand General, select Deployment Descriptors and then a descriptor type, and click OK.

If you cannot find the item you want, make sure that you chose the correct project, and then choose the All Features tab or use the Search field to find the descriptor. If the item is not enabled, check to make sure that the project does not already have a descriptor of that type. A project is allowed only one instance of a descriptor.

JDeveloper starts the Create Deployment Descriptor wizard and then opens the file in the overview or source editor, depending on the type of deployment descriptor you choose.


Note:

For EAR files, do not create more than one of any type of deployment descriptor per application. Only the application resources descriptors or descriptors generated at the EAR level will be used by the runtime. If multiple projects in an application have the same deployment descriptor, the one belonging to the launched project will supersede the others. This restriction applies to application.xml, weblogic-jdbc.xml, jazn-data.xml, and weblogic.xml.

The best place to create an application-level descriptor is in the Descriptors node of the Application Resources panel in the Applications window. This ensures that the application is created with the correct descriptors.






To inspect or change deployment descriptor properties:




	In the Applications window, select the deployment descriptor.
	Right-click and choose Open.

The file will open in an overview editor specific to that descriptor type, or in an XML editor window.












22.3.5.2 How to Create a Web Service Policy Reference



Follow these steps to create a web service policy reference:




	Select File > New > WebLogic Deployment Descriptor. From the General category, select Deployment Descriptors; choose the Weblogic item in the right‐hand pane and click OK. The wizard opens.
	On the Select Descriptor page, scroll down to select webservice-policy-ref.xml.
	On the Select Version page, select the Deployment Descriptor version and click Next.
	On the Summary page, click Finish.
	The new configuration file opens in the editor.



The tabs on the left allow you to edit the Policy Reference Name, the Port Policy, and the Operation Policy separately. The wizard provides Overview, Source, and History views for each setting. See the online help.









22.3.5.3 Viewing or Modifying Deployment Descriptor Properties



After you have created a deployment descriptor, you can change its properties by using JDeveloper dialogs or by editing the file in the source editor. The deployment descriptor is an XML file (for example, application.xml) typically located under the Application Sources node.

To view or change deployment descriptor properties:




	In the Applications window or in the Application Resources panel, double-click the deployment descriptor.
	In the overview editor, select either the Overview tab or the Source tab, and configure the descriptor by setting property values.

If the overview editor is not available, JDeveloper opens the file in the source editor.














22.3.6 How to Configure Global Deployment Preferences



You can set global deployment options in the Deployment page of the Preferences dialog.

To configure the deployment preferences:




	Choose Tools > Preferences from the main menu.
	Select the Deployment node. Configure the deployment options as required. For more information, click Help.
	Click OK.




Note:

Set application-specific and project-specific deployment profile options via the application properties or project properties. The Application Properties and Project Properties dialogs are available from the Application menu











22.3.7 How to Configure Applications for Deployment


This section describes the tasks you may have to perform for the application to deploy successfully to an application server.





22.3.7.1 How to Configure an Application for Deployment to Oracle WebLogic Server



When you create applications in JDeveloper You can deploy the packaged application to Oracle WebLogic Server through an application server connection. A packaged application will contain a deployment profile that names the files to be deployed, describes their organization, and specifies the target server. The target Oracle WebLogic Server instance must be installed locally or mapped to a network drive.

To configure an application for deployment to Oracle WebLogic Server:




	Set up any JDBC data sources you need on the server. For more information, see Setting Up JDBC Data Sources on .
	For clients that access EJBs on Oracle WebLogic Server, the following code is required in the client.


env.put(Context.INITIAL_CONTEXT_FACTORY, 
  "weblogic.jndi.WLInitialContextFactory"); 
env.put(Context.SECURITY_PRINCIPAL, "system"); 
env.put(Context.SECURITY_CREDENTIALS, "welcome1"); 
env.put(Context.PROVIDER_URL, "t3://localhost:7001"); 




	When deploying to Oracle WebLogic Server, if you use the same EJB in two or more different applications, the second deployment will usually cause a JNDI name collision. Therefore, you must rename the JNDI name of the EJB for the second and any subsequent deployments:

	
Right-click weblogic-ejb-jar.xml, and choose Open.


	
Under Enterprise Java Beans, select the relevant ModuleBM bean. The EJB tab is displayed on the right.


	
In the EJB tab, change the JNDI Name so that it is different from any other JNDI Name in weblogic-ejb-jar.xml and any other EJBs that are already deployed to Oracle WebLogic Server.


	
Deploy the application accessing the EJB to Oracle WebLogic Server. During deployment, the IDE automatically fills in weblogic.xml with appropriate EJB references.















22.3.7.2 How to Configure a Client Application for Deployment



A Java EE Client module is packaged as a client JAR file which contains one or more Java application components and a client deployment descriptor file named application-client.xml. After you have created the deployment profile and the deployment descriptor file, you can deploy the client JAR to the application server.

To package a client application for deployment:




	Create a Client JAR File deployment profile for your project.

A profile may have already been created for your project. If you wish to deploy to multiple targets, create a separate profile for each.




	Create the application-client.xml deployment descriptor file, if not already present in your project.

Normally, this file is created with the application client.












22.3.7.3 How to Configure an Applet for Deployment



A standalone applet is packaged as a web archive (WAR) file which contains the applet, the Applet HTML file, as well as the standard Java EE web deployment descriptor, web.xml and possibly target-specific deployment descriptors, as well. After you have created the deployment profile and the appropriate deployment descriptor files, you can deploy the application to an application server, or as an archive file.

To configure a web application for deployment:




	Create a WAR file deployment profile for your project.

A profile may have already been created for your project. If you wish to deploy to multiple targets, create a separate profile for each.




	Add a web.xml deployment descriptor to your project, if it is not already present.

Normally, this file is created with the WAR file deployment profile.








Note:

If you encounter problems when deploying a Swing applet (JApplet), for example, the error Class not found is displayed, this may indicate that JDeveloper cannot locate the Swing libraries. Your clients may need to use Sun's Java SE browser plugin or bundle the Swing libraries for JVMs version 1.1 with your applet. Deployed applet files must reside in a separate location from any other web application files you have deployed.











22.3.7.4 Setting Up JDBC Data Sources on Oracle WebLogic Server



To avoid passwords being present in plain text in deployed files, JDeveloper uses password indirection, which means that passwords for the data sources must be set on the server before the application will run correctly.

You do this using global data sources, which are set up in the Oracle WebLogic Server Administration Console using the Data Sources link under JDBC.

JDeveloper ensures that your web application web.xml, or EJB application ejb-jar.xml, contains the necessary <resource-ref> entry to identify an application resource name. The name is jdbc/connection-nameDS, where connection-name is the name of the application resources connection.

The application looks up this data source using the application-specific resource JNDI namespace of java:comp/env/jdbc/connection-nameDS, and it finds this resource because web.xml contains the <resource-ref> entry for jdbc/connection-nameDS.

An important control for the files that are generated is the Auto Generate and Synchronize weblogic-jdbc.xml Descriptors During Deployment field on the WebLogic page of the Application Properties dialog.

When the Auto Generate field is selected, JDeveloper does the following:





	
Generates an application-name-jdbc.xml file for each connection in the application resources, and sets the indirect password attribute


<jdbc-driver-params>
<use-password-indirection>true</use-password-indirection>
</jdbc-driver-params>


Upon deployment, JDeveloper determines the JDBC connection password from the username in application-name-jdbc.xml, and populates the JDBC connection password using an Mbean.


	
weblogic-application.xml is updated to add each application-name-jdbc.xml as a module.


	
web.xml (if it exists) has a resource reference to each JDBC JNDI name.








How to Create a Global Data Source on Oracle WebLogic Server

You create a global data source on Oracle WebLogic Server Administration Console.





To set up a global data source:




	Login to the Oracle WebLogic Server Administration Console. For more information, see How to Create a Connection to the Target Application Server.
	Click on the Data Sources link under JDBC.
	On the Summary of JDBC Data Sources page, click New.
	In the Create a New JDBC Data Source page, enter details of the data source.

The name can be anything.

The JNDI name must be of the form jdbc/connection-nameDS. For example, if the application has a connection name connection1, the JNDI name is jdbc/connection1DS.




	Ensure that the database type is Oracle and that the driver is Oracle's Driver (Thin) for Service Connections;Version 9.0.1,9.2.0,10,11.
	Click Next twice to navigate to the Create a New JDBC Data Source page, where you enter the connection details.

The database name is the Oracle SID.

The host name is the name of the machine the database is on.

The default port is 1521.




	Enter the user name and password, for example hr/hr.
	Click Next and click Test Configuration.
	Click Next to navigate to the Select Targets page, where you select a target for this data source. If you fail to select a target, the data source is created but not deployed.
	Click Finish.



Example 22-1 Deploying to an EAR File to Run on Oracle WebLogic Server

To deploy an application to an EAR file to run on Oracle WebLogic Server, you can:





	
Select the Auto Generate and Synchronize weblogic-jdbc.xml Descriptors During Deployment field, and set up passwords using application level credential mapping.


	
Alternatively, you can deselect the Auto Generate and Synchronize weblogic-jdbc.xml Descriptors During Deployment field and set up passwords by creating a global data source on Oracle WebLogic Server.




If you are deploying using ojdeploy:

	
You can use the -nodatasources switch, in which case you can set up passwords on Oracle WebLogic Server by either:

	
Creating a global data source.


	
Manually creating application level data sources.




For more information about ojdeploy, see Deploying from the Command Line.


	
If you do not use the -nodatasources switch, you can only set up passwords using application level credential mapping.












22.3.7.5 Preparing an Application for Deployment to a Third Party Server



There may be specific tasks that you have to perform so that your application will run on a third party server.

Deploying to Tomcat:





	
Stop and restart the Tomcat server after deployment.


	
Make sure that you have the tools.jar library in the Tomcat classpath, located in jdeveloper_install/jdk/lib. This file must be the same version of the JDK being used to run Tomcat. Otherwise, you may encounter problems when running applications in Tomcat.


	
The recommended deployment for web applications is tomcat_install/webapps/subdirectory. Set this option in the General page of the WAR File deployment profile.


	
The system administrator of the Tomcat application server must assign a context path to your application in the conf/server.xml file:


<DefaultContext crossContext="true"/> 


See Tomcat system administration documentation for more information.


	
You may get the following error message when running a JSP application deployed to Tomcat:


Only one of the two parameters ... or ... should be defined.


Because Tomcat does not release tags after pooling, subsequent uses of the same tag with incompatible attributes defined will cause this error.

To avoid the error, you must disable tag pooling in Tomcat:

	
Open the file tomcat_home/conf/web.xml in a text editor.


	
Find the following element:


<init-param>
  <param-name>enablePooling</param-name>
  <param-value>true</param-value>
</init-param>




Change the value of <param-value> to false








Deploying to WebSphere

WebSphere deployment on Windows does not work when the directory containing the JDeveloper generated EAR contains spaces.





You can directly access the target application server connection in order to pass command line options. For example, you can specify the client JAR which contains the necessary stubs and skeletons on the client side to support RMI-IIOP deployment. These options would overwrite or bypass the server's default settings.

To pass options to target application server connections when deploying:

	
If not already done, create the appropriate deployment profile.


	
In the Applications window, right-click the project, then choose Properties.


	
Select Deployment in the panel on the left of the Project Properties dialog.


	
Select the deployment profile you want to edit, and click Edit.


	
Open the page which corresponds to the target connection type for which you want to pass command options.


	
Edit the page, or click Restore Default to revert to the default settings for the target server.

For instructions click Help.


	
Click OK when you are finished editing the deployment profile properties.














22.3.8 How to Use Deployment Plans


You can use deployment plans to override deployment values. One reason you might want to do this is to change settings so that an application that has finished testing can be run in a production environment without having to change the deployment profiles.

When an EAR, WAR, or EJB JAR archive configured to use a deployment plan is deployed, both the archive and the deployment plan are sent to the application server. You can use multiple deployment plans in an application.

For more information, see the section about deployment plans in the chapter about configuring applications for production deployment in Deploying Applications to Oracle WebLogic Server.

The following is an example of a deployment plan for an EAR called application.ear. Note that the module-name element must contain the name of the deployment profile that it is associated with.


<deployment-plan xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" 
xsi:schemaLocation="http://www.oracle.com/technology/weblogic/10.3/deployment-plan
http://www.oracle.com/technology/weblogic/10.3/deployment-plan/1.0/deployment-plan.xsd" 
xmlns="http://www.oracle.com/technology/weblogic/10.3/deployment-plan">
  <application-name>DeployPlan</application-name>
  <variable-definition>
    <variable>
      <name>SessionDescriptor_timeoutSecs</name>
      <value>888</value>
    </variable>
    <variable>
      <name>SessionDescriptor_invalidationIntervalSecs</name>
      <value>888</value>
    </variable>
    <variable>
      <name>SessionDescriptor_cookieMaxAgeSecs</name>
      <value>888</value>
    </variable>
  </variable-definition>
  <module-override>
    <module-name>application.ear</module-name>
    <module-type>ear</module-type>
    <module-descriptor external="false">
      <root-element>weblogic-application</root-element>
      <uri>META-INF/weblogic-application.xml</uri>
      <variable-assignment>
        <name>SessionDescriptor_timeoutSecs</name>
        <xpath>/weblogic-application/session-descriptor/timeout-secs</xpath>
      </variable-assignment>
      <variable-assignment>
        <name>SessionDescriptor_invalidationIntervalSecs</name>
        <xpath>/weblogic-application/session-descriptor/invalidation-interval-secs</xpath>
      </variable-assignment>
      <variable-assignment>
        <name>SessionDescriptor_cookieMaxAgeSecs</name>
        <xpath>/weblogic-application/session-descriptor/cookie-max-age-secs</xpath>
      </variable-assignment>
    </module-descriptor>
  </module-override>
</deployment-plan>


When an EAR, WAR, or EJB JAR archive configured to use a deployment plan is deployed, both the archive and the deployment plan are sent to the application server. You can use multiple deployment plans in an application.





22.3.8.1 How to Create and Use Deployment Plans



You can create a deployment plan from the New Gallery and edit it in the XML editor.

Once created, a deployment plan can be associated with an EAR, WAR, or EJB JAR archive.

Alternatively, you can generate a deployment plan in Oracle WebLogic Server, then use it in JDeveloper.

To create a deployment plan:




	In the Applications window, select the project for which you want to create a deployment plan.
	Choose File > New to open the New Gallery.
	In the Categories tree, expand General and select Deployment Descriptors. In the Items list, select WebLogic Deployment Descriptor and click OK.
	In the Select Descriptor page of the Create WebLogic Deployment Descriptor wizard, choose plan.xml.

If this is the first deployment descriptor you are creating in the application, you can choose Finish to create a deployment plan with the default name of plan.xml.

If you already have a deployment plan called plan.xml in the application, navigate to the Select Name page and enter a new name for the deployment plan, then click Finish. The deployment plan will be created and added to the project, and it will be opened in an XML editor window.




	Open the Deployment Profile Properties of the EAR, WAR or EJB JAR.
	Enter the path to the deployment plan in the Deployment Plan field.








22.3.8.2 How to Generate Deployment Plans



Deployment plans enable you to export an application's configuration for deployment to multiple WebLogic Server environments.

You can create a deployment plan from scratch in JDeveloper.

Alternatively, you can generate a deployment plan which you can then add to your application in JDeveloper and edit it to suit your purposes, described in this topic. There are two ways to do this:





	
Deploy the application to a Oracle WebLogic Server, make changes to the application using the Administration Console, and save the resulting deployment plan. You can then copy the deployment plan back into your source in JDeveloper, and if necessary you can modify it. For more information, see the section about deployment plans in the chapter about configuring applications for production deployment in Deploying Applications to Oracle WebLogic Server.


	
Use the weblogic.PlanGenerator command-line tool to generate a deployment plan for an application that uses an EAR. For more information, see the reference chapter about weblogic.PlanGenerator command line tool in Deploying Applications to Oracle WebLogic Server.




To generate a deployment plan using WebLogic Server Administration Console:

	
Deploy the application to Oracle WebLogic Server.


	
Open the WebLogic Server Administration Console.

The WebLogic Server Administration Console automatically generates (or updates) a valid deployment plan for an application when you interactively change deployment properties for an application that you have installed to the domain. You can use the generated deployment plan to configure the application in subsequent deployments, or you can generate new versions of the deployment plan by repeatedly editing and saving deployment properties.




To use the weblogic.PlanGenerator command-line tool to generate a deployment plan:




	From the command line, navigate to install/wlserver_10.3/server/bin/ and run either setWLSEnv.sh or setWLSEnv.cmd script, to add the WebLogic Server classes to the CLASSPATH environment variable on your machine, and ensure that the correct JDK binaries are available in your PATH.
	From the command line, navigate to the location of the EAR file, and run java weblogic.PlanGenerator -plan plan.xml application-name.ear -all.

The switch -all specifies that the deployment plan is generated containing elements for all possible attributes in your EAR file. If you remove this switch, the generated deployment plan will only contain elements for the existing attributes in your descriptor files.
















22.4 Deploying Java Applications


JDeveloper supports deployment of applications containing a variety of technologies to a variety of application servers. This section provides instructions for deploying an application to an executable JAR file on your file system. If you wish to deploy an application containing Java EE technologies, or you wish to deploy to the integrated application server, Oracle WebLogic Server, or another supported application server, be sure to verify that you have performed the necessary configuration and preparation steps as outlined in Connecting and Deploying Java EE Applications to Application Servers.





22.4.1 Deploying to a Java JAR



Applications can be deployed indirectly by choosing an archive file as the deployment target. The archive file can subsequently be installed on a target Java EE application server

JDeveloper has various deployment modes for different applications. However, you may want to quickly and simply deploy your application as a JAR file to your file system.


Note:

Before deploying an executable JAR file you must first create a deployment profile.



To deploy a simple archive in JDeveloper:

	
Select and right-click the project in the Applications window.


	
Choose Deploy deployment profile, where deployment profile is the deployment profile that you created earlier.


	
In the Deployment Action page of the Deploy dialog, choose Deploy to JAR file, and finish the wizard.




You can make your simple archive or Java EE Client Module into an executable JAR file that you can launch with the java command.


Note:

Before deploying an executable JAR file you must first create a deployment profile.



To deploy an executable JAR file:




	Right-click the project in the Applications window and choose Project Properties.
	Select the name of the profile in the Deployment section of the Project Properties dialog and click Edit.
	Click JAR Options in the tree.
	Select Include Manifest File (META-INF/MANIFEST.MF).
	In the Main Class field, enter the fully qualified name of the application class that is to be invoked.
	Click OK.
	Create the JAR file by deploying the profile to file (see previous section). This creates the JAR file, for example, myapp.jar.
	Launch the executable JAR file from the command line


java -jar myapp.jar












22.4.2 Deploying to an OSGi Bundle



Applications can be deployed as OSGi bundles which can then be deployed to an OSGi container.

JDeveloper has various deployment modes for different applications. However, you may want to quickly and simply deploy your application as a JAR file to your file system.


Note:

Before deploying an OSGi bundle you must first create a deployment profile. For more information, see How to Create and Edit Deployment Profiles.



To deploy an OSGi bundle in JDeveloper:




	Select and right-click the project in the Applications window.
	Choose Deploy > deployment profile, where deployment profile is the OSGi bundle deployment profile that you created earlier.
	In the Deployment Action page of the Deploy dialog, choose Deploy to OSGi bundle, and finish the wizard.










22.5 Deploying Java EE Applications


You can use JDeveloper to deploy Java EE applications directly to the standalone application server or create an archive file and use other tools to deploy to the application server.





22.5.1 How to Deploy to the Application Server from JDeveloper



The Java EE Enterprise Archive (EAR) deployment profile provides you with centralized control over the process of application assembly. This assembling task involves selecting which already-configured Java EE deployment profiles to include with the EAR file. You can mix and match any combination of configured WAR, EJB JAR, and/or client JAR profiles in projects within the same application. When you deploy an application to an application server connection, JDeveloper assembles a minimal EAR file which includes the profile combinations and deploys it with the EAR file to the target application server.

To deploy an application as a Java EE Enterprise Archive (EAR File):




	Create an EAR File deployment profile.
	Create a connection to the target application server.
	Right-click the project in Applications window and choose Deploy > deployment profile.
	In the Deployment Action page of the Deploy dialog, choose one of the deployment options:

	
Deploy to application server connection to package the web module as an EAR file, and deploy it to the application server connection you select or create on the Select Server page of the Deploy dialog.


	
Deploy to EAR file to package the web module as an EAR file and save to the location specified in the EAR deployment profile.










To reopen the EAR deployment profile later to make changes, right-click the application in the Applications window toolbar and choose Application Properties, then select the name of the profile in the Deployment section of the Application Properties dialog and click Edit.

	
If you have an existing EAR file, you can use the JDeveloper EAR import facility to import the EAR into any project.


	
JAR, WAR, and GAR files to be included in an EAR file must be created before the EAR file is deployed. For the included application's deployment profiles, choose Deploy to JAR file, Deploy to GAR, or Deploy to WAR file in the Deploy dialog to create these subordinate archives.


	
The EAR file does not contain passwords so if, for example, you are creating an EAR file to run on Oracle WebLogic Server, you must set up a data source on the server.












22.5.2 How to Deploy a RAR File



Stored in a Resource Adapter Archive (RAR) file, a resource adapter may be deployed on any Java EE server, much like the EAR file of a Java EE application. A RAR file may be contained in an EAR file or it may exist as a separate file

To deploy a resource adapter archive in JDeveloper:




	Create a deployment profile.


Note:

To reopen a project deployment profile later to make changes, right-click the project in the Applications window and choose Project Properties, then select the name of the profile in the Deployment section of the Project Properties dialog and click Edit.






	Right-click the project in the Applications window, then choose Deploy > deployment profile.
	In the Deployment Action page of the Deploy dialog, choose Deploy to RAR file.








22.5.3 How to Add a Resource Adapter Archive (RAR) to the EAR



The EAR profile supports Resource Adapter Archive files (RAR or .rar) in a JDeveloper project. A RAR file is typically provided by an Enterprise Intelligence Server (EIS) vendor, similar to a JDBC driver. Java EE developers may need to package a RAR file into their EAR file if their Java EE application makes use of the EIS services supported by the RAR. JDeveloper does not directly support RAR file creation, but RAR files can be assembled using the File Groups feature of a JAR file deployment profile.

The ra.xml file is the deployment descriptor for the RAR file for the J2EE Connector Architecture (JCA). For more information, see:

http://www.oracle.com/technetwork/java/javaee/tech/entapps-138775.html

To add a RAR to an EAR deployment profile:




	In JDeveloper, add an existing RAR file to a project.
	Create an EAR deployment profile in the same project as the RAR file.
	Right-click the project in the Applications window and choose Project Properties.
	Select the name of the profile in the Deployment section of the Project Properties dialog and click Edit.
	Click the Application Assembly node to display all the Java EE modules (WAR and EJB JAR) currently available and saved in your project.
	Select the checkbox next to the RAR (.rar) file that you want to assemble and package with the EAR file.
	Click OK.
	Deploy the Java EE EAR.



At deploy-time, the EAR file's application.xml contains a <connector> element which is automatically added to the RAR file.









22.5.4 How to Deploy a Metadata Archive (MAR) File


Metadata Archive (MAR) profiles are application level deployment profiles which are used to package seeded customizations or place base metadata in the MDS repository. In a MAR profile, selections can only be done at the package level, not at the file level.

There are two uses for a MAR profile

	
The first use is to create a MAR profile. Once you have created it you can include it in an application's EAR for deployment.


	
The second use is to export MAR contents to MDS repository configured for a deployed application in a remote server. This procedure is for applying ADF Library customizations changes to an application that has already been deployed to a remote application server. It is not for the initial packaging of customizations into a MAR that will eventually be a part of an EAR.




For more information, see How to Package and Deploy Customized Applications in Developing Fusion Web Applications with Oracle Application Development Framework.







22.5.5 How to Deploy an Applet as a WAR File



You can deploy web application components including applets as a WAR or EAR file to the target application server.

To deploy an applet as a WAR file:




	If not already done, configure the applet for deployment.
	If not already done, create an application server connection.
	In the Applications window, right-click the project and choose Deploy and select the deployment profile.
	Deploy to application server connection to create the archive type specified in the deployment profile, and deploy it to the application server connection you select or create on the Select Server page of the Deploy dialog.

	
Deploy to application server connection to create the archive type specified in the deployment profile, and deploy it to the application server connection you select or create on the Select Server page of the Deploy dialog.


	
Deploy to EAR file to deploy the project and any of its dependencies (specified in the deployment profile) to an EAR. JDeveloper puts the EAR file in the default directory specified in the deployment profile.


	
Deploy to WAR file to deploy the project to a WAR. JDeveloper puts the WAR file in the default directory specified in the deployment profile.





Note:

The deployed applet files must reside in a separate location from any other web application files you have deployed.









You can test the deployed web application by running it in a browser. For more information, see Testing the Application and Verifying Deployment.

If you encounter problems when deploying a Swing applet (JApplet), for example, the error "Class not found" is displayed, this may indicate that JDeveloper cannot locate the Swing libraries. You may need to force your clients to use Sun's Java SE browser plugin or bundle the Swing libraries for JVMs version 1.1 with your applet.









22.5.6 How to Deploy a Shared Library Archive



Shared Java EE libraries provides an easy way to share one or more different types of Java EE modules among multiple Enterprise Applications. You can deploy shared libraries as JAR files to the application server.

For more information, see Chapter 9 "Creating Shared Java EE Libraries and Optional Packages" in Developing Applications for Oracle WebLogic Server.

To create and deploy a shared library archive:




	Create a shared library deployment profile, (Shared Library JAR file). For more information, see Creating Deployment Profiles.
	Add the libraries to the profile in the Edit JAR Deployment Profile Properties dialog. Choose File Groups, and click New to open the Create File Group dialog, where you define a new file group.
	Create a connection to the target application server.
	Right-click the project in Applications window and choose Deploy > shared library deployment profile.
	On the Deployment Action page of the Deploy shared library dialog, choose Deploy to a Weblogic Application Server and click Finish.








22.5.7 How to Deploy to a Managed Server That Is Down



For successful deployment, the Administration Server for the WebLogic Server domain has to be up as it is handling the deployment process. When you deploy to a server that is down, the deployment log window messages indicate that the server is currently down but the application will be installed when it is brought back up. The log messages will be similar to:


[02:27:21 PM] ----  Deployment started.  ----
   [02:27:21 PM] Target platform is  (Weblogic 10.3).
   [02:27:23 PM] Retrieving existing application information
   [02:27:23 PM] Running dependency analysis...
   [02:27:23 PM] Building...
   [02:27:26 PM] Deploying 2 profiles...
   [02:27:26 PM] Wrote Web Application Module to /scratch/.../jdev/mywork/Application1/Project1/deploy/webapp1.war
   [02:27:26 PM] Wrote Enterprise Application Module to /scratch/.../jdev/mywork/Application1/application1.ear
   [02:27:26 PM] Deploying Application...
   [02:27:27 PM] [Deployer:149195]Operation 'deploy' on application 'application1' has been deferred since   'Server-2' is unavailable
   [02:27:27 PM] [Deployer:149034]An exception occurred for task [Deployer:149026]deploy application application1   on Server-2.: .
   [02:27:27 PM] Application Deployed Successfully.
   [02:27:27 PM] Elapsed time for deployment:  5 seconds
 [02:27:27 PM] ----  Deployment finished.  


One situation that can occur is that deployment appears to succeed, but as the server is brought back up the deployment cannot successfully terminate, for example, because some validation that is part of the deployment process was not performed, or because a library that needs to be present for deployment to be successful is missing. In these cases, when the server is brought back up and deployment resumes, it fails.

You can only deploy an application once to a server that is down. If you attempt to redeploy the same application to the same down server a second time, an error is displayed.











22.6 Post-Deployment Configuration


After you have deployed your application to Oracle WebLogic Server, you can migrate it from one Oracle WebLogic Server to another.

You may need to perform some of the same steps you did for a first time deployment.

In general, to migrate an application to another application server, you would:

	
Configure the target application server with the correct database or URL connection information.


	
Migrate security information, for example JDBC data sources, from the source to the target.


	
Deploy the application to the new server.










22.7 Testing the Application and Verifying Deployment


After you deploy the application, you can test it from Oracle WebLogic Server.

The deployment log window displays the context root URLs for any Web applications deployed. You can access a deployed web application by entering the application URL in a browser. The URL of the deployed web application appears in the deployment log window, for example:


[03:08:20 PM] The following URL context root(s) were defined and can be used as a starting point to test your application:
[03:08:20 PM] http://12.345.678.912:7101/Project1
[03:08:21 PM] Elapsed time for deployment: 7 seconds
[03:08:21 PM] ---- Deployment finished. ----


You can copy the URL and paste it into a browser to test the deployed web application.

Depending on your browser proxy settings, you may need to specify the full domain name of the host machine. If the servlet engine and the browser used to view a deployed application are on the same machine, you may use localhost for the host name.







22.8 Deploying from the Command Line


JDeveloper deployment is built around a Design-Time data structure called a profile. A common implementation is an ArchiveProfile that describes the structure of a JAR archive. Deployment profiles can be created as part of a JDeveloper project or workspace. JDeveloper a offers a command-line tool, ojdeploy that allows deployment of ArchiveProfile(s) without invoking the JDeveloper GUI. This is the simplest form of deployment. It has the following characteristics:

ojdeploy can run a deployment locally in-process, or submit to a background server, ojserver. For more information, see Using ojserver.

Before deploying from the command line, you need to run JDeveloper at least once to create a deployment profile for either the application or the project.

Deployment profiles are stored as part of either the application or project properties.





22.8.1 ojdeploy


ojdeploy is available from the command line at jdeveloper_install/jdeveloper/jdev/bin, and the usage is


ojdeploy <commandId>


For additional details, type:


ojdeploy <commandId> -help


Currently the only available commands is deployToArchive (the default). This command deploys to an Archive File.

Usage:


ojdeploy -profile <name> -workspace <jws> [ -project <name> ] [ <options> ]
ojdeploy -buildfile <ojbuild.xml> [ <options> ]
ojdeploy -buildfileschema


Arguments:




Table 22-2 Arguments

	
-buildfile

	
Full path to a build file for batch deploy.


	
-buildfileschema

	
Print XML Schema for the build file.


	
-profile

	
The name of the Profile to deploy.


	
-project

	
Name of the JDeveloper project within the .jws where the profile can be found. If omitted, the profile is assumed to be in the Workspace.


	
-workspace

	
Full path to the JDeveloper workspace file(.jws).








Options




Table 22-3 Options

	
-address

	
The listen address for ojserver if not using default (localhost:2010). The default parts of the address may be omitted, for example, -address :2001 or -address fasup-pls01


	
-basedir

	
Lets Workspace path names be interpreted relatively. The built-in macro ${base.dir} captures the value of -basedir.


	
-clean

	
Clean output directories before compiling


	
-datasources

	
Deprecated For JEE applications, the -nodatasources option prevents the data-sources.xml file from being updated with connection information found in the IDE. This is ignored for non-JEE applications


	
-define

	
Define variables as comma separated name=value pairs


	
-failonwarning

	
Prevents the build system from being invoked. This is useful if a workspace or project just needs to be packaged, and not compiled at this time. Adding -clean will delete all files from the project output directory before compiling. Deployment will stop for that profile, if a file or directory could not be deleted.


	
-forcerewrite

	
Output file is rewritten even if the contents have not changed in this run of ojdeploy.


	
-nocompile

	
Prevents the build system from being invoked. This is useful if a Workspace or Project just needs to be packaged, and not compiled at this time. Adding -clean will delete all files from the Project output directory before compiling. Deployment will stop for that profile, if a file or directory could not be deleted.


	
-nodatasources

	
Does not include datasources from IDE.


	
-nodependents

	
Tells ojdeploy not to navigate to project and profile dependencies. This means dependent projects will not be automatically compiled and dependent profiles will not be automatically deployed. This is useful in situations where the dependencies between projects and profiles are being calculated externally or when multiple instances of ojdeploy(s) are working on the same set of projects and workspaces.


	
-ojserver

	
Runs the deployment job on an ojserver. All paths referenced by the other options should be accessible on the server.


	
-outputfile

	
Redirects any JAR files created from the profile. The default is within a \deploy directory inside the Project or Workspace.

Automatic file extension: If the -outputfile parameter does not specify a file extension, ojdeploy will figure out the extension by looking at the original file name in the profile.


	
-project

	
If specified, tells ojdeploy to look for the profile in the project. Specify the name only, without the path or .jpr extension


	
-statuslogfile

	
Creates an XML file that stores a list of all the profiles processed and the status of each. A summary section at the end can be checked to quickly determine the exit status for the entire script.


	
-stderr

	
Lets these respective streams be redirected to a file for each profile and project. Macros are allowed in the name or path of the files.


	
-stdout

	
Redirect stdout to file


	
-timeout

	
Lets the user specify the number of seconds after which deployment of a single profile should be aborted. If the profile is dependent on other profiles that also need to be deployed, they all have to complete within this time.


	
-updatewebxmlejbrefs

	
Updates EJB references in web.xml


	
-workspace

	
Deployment profiles can be classified into two broad categories, those that are defined at the Application or Workspace level, and those defined at the Project level. To deploy a Workspace-profile, ojdeploy takes the workspace location, and the name of the profile. To deploy a Project-profile, it takes an additional -project argument.








Built-in Macros




Table 22-4 Built-in Macros

	
${workspace.name}

	
Name of workspace (excluding .jws)


	
${workspace.dir}

	
Directory containing the .jws file


	
${project.name}

	
Name of project (excluding .jpr)


	
${project.dir}

	
Directory containing the .jpr file


	
${profile.name}

	
Defined name of the profile


	
${deploy.dir}

	
Default deploy directory (usually ${project.dir}/deploy or ${workspace.dir}/deploy for project-level and workspace-level profiles respectively)


	
${base.dir}

	
Value of the -basedir parameter, or current directory.








Examples:

Deploy a project-level profile:


ojdeploy -profile webapp1 -workspace /usr/jdoe/Application1/Application1.jws
         -project Project1
ojdeploy -profile webapp1 -workspace Application1/Application1.jws 
         -basedir /usr/jdoe -project Project1





Deploy a workspace-level profile:


ojdeploy -profile earprofile1 -workspace /usr/jdoe/Application1/Application1.jws


Deploy all profiles from all projects of a workspace:


ojdeploy -workspace /usr/jdoe/Application1/Application1.jws 
         -project \* -profile \*


Build in batch mode from a ojbuild file:


ojdeploy -buildfile /usr/jdoe/ojbuild.xml


Build using ojbuild file, pass into, or override default variables in, the build file:


ojdeploy -buildfile /usr/jdoe/ojbuild.xml -define myhome=/usr/jdoe,mytmp=/tmp
ojdeploy -buildfile /usr/jdoe/ojbuild.xml -basedir /usr/jdoe


Build using ojbuild file, set or override parameters in the default section:


ojdeploy -buildfile /usr/jdoe/ojbuild.xml -nocompile

ojdeploy -buildfile /usr/jdoe/ojbuild.xml 
         -outputfile '${workspace.dir}/${profile.name}.jar'
ojdeploy -buildfile /usr/jdoe/ojbuild.xml -define mydir=/tmp 
         -outputfile '${mydir}/${workspace.name}-${profile.name}'


More examples:


ojdeploy -workspace Application1/Application1.jws,Application2/Application2.jws
         -basedir /home/jdoe -profile app*
ojdeploy -buildfile /usr/jdoe/ojbuild.xml 
         -define outdir=/tmp,rel=11.1.1 
         -outputfile'${outdir}/built/${workspace.name}/${rel}/${profile.name}.jar'
ojdeploy -workspace Application1/Application1.jws -basedir /home/jdoe -nocompile
         -outputfile '${base.dir}/${workspace.name}-${profile.name}'
ojdeploy -workspace /usr/jdoe/Application1.jws -project * -profile * 
         -stdout /home/jdoe/stdout/${project.name}.log
ojdeploy -buildfile /usr/jdoe/ojbuild.xml -ojserver







22.8.2 Using ojdeploy from Mac OS X Platforms


If you are using ojdeploy on a on Mac OS X platform, you must set the variable SetSkipJ2SDKCheck in the file jdev_install/jdeveloper/jdev/bin/jdev.conf to true. Your entry should look like this:

SetSkipJ2SDKCheck true







22.8.3 Using ojdeploy


JDeveloper currently supports deployment in Ant scripts. For more information, see How to Deploy from the Command Line Using Ant .

Deploying from the command line using ojdeploy is especially useful where you need to deploy existing projects or applications using a batch file or other script.





22.8.3.1 How to Override Without Editing a Build Script



To pass in macro values or override the ones defined in a build script, use the -define option to supply a new value:


ojdeploy -buildfile /home/jdoe/ojbuild.xml -define "mycustomdir=/tmp"


This adds the mycustomdir variable to the <defaults> section of the build script, or replace it if it already is defined with the value /tmp.

To pass in parameter values or override the ones defined in a build script, use the appropriate parameter option, for example:


ojdeploy -buildfile /home/jdoe/ojbuild.xml -nocompile -nodatasources


This adds the -nocompile and -nodatasources parameters to the default section of the build file.









22.8.3.2 How to Deploy Multiple Profiles from the Command Line



Command-line deployment supports deployment of multiple applications in a single invocation. If more complex control is required, ojdeploy can take an XML build script and process it, running all deploy tasks found in it. Macros and wild cards can be used both in command-line and batch mode. Macros can be strung together or nested.

Each profile to be deployed is qualified by an application and a project. In addition each profile's output can be directed to a different output file/location. Further to this, the calling script assumes no knowledge of the projects within am application, only deploying all or a subset of them matching a criteria. The command-line syntax for specifying such inputs and criteria can quickly become cumbersome and inflexible.

A build file can be passed to ojdeploy. The build file will contain multiple <deploy> tasks, along with a shared <defaults> section which allows for setting up an environment. Each deploy-task specifies the type of deployment (the set mentioned before) and customizes any defaults as required. Each task also allows wild cards as applicable within parameter arguments that apply to the scope of that task. A pre-processor will parse the build file and pass it to ojdeploy, expanding wild cards and substituting variables as necessary.

The build file approach has the following advantages over the command-line syntax:





	
It lets more parameters be added to ojdeploy without forcing the implementor for that parameter to be aware of a batch-build concept.


	
It keeps the command-line syntax simple, for the degenerate case.


	
It allows parameters to be dynamically evaluated based on the current context, and access to a predefined list of pre-processor macros. For example, OutputFile location may be specified as c:\temp\${profile.name} where the macro ${profile.name} is added automatically.




A sample build file is shown below. To invoke all of these deploy actions, the command-line would be ojdeploy ojdeploy-build.xml. The file is processed from top to bottom.


<?xml version="1.0" encoding="US-ASCII" ?>
<ojdeploy-build basedir="/usr/jdoe/">
  <!-- Defines default parameters for all deploy tasks.
       Also defines some variables strictly for use within this file
       in macros
  -->
  <defaults>
    <parameter name="profile" value="*"/>
    <parameter name="nocompile" />
    <-- define a macro -->
    <variable name="customdir" value="/var/projects/fin/"/>
  </defaults>
  <!-- Select all .jws files in location ${customdir} called absoluteFile1.jws, absoluteFile2.jws.
       Open all projects.
       Deploy profiles p1, p2, p3 in each project, in each workspace.
  -->
  <deploy>
    <parameter name="workspace" value="${customdir}/absoluteFile1.jws,${customdir}/absoluteFile2.jws"/>
    <parameter name="project" value="*"/>
    <-- Override default profile parameter -->
    <parameter name="profile" value="p1,p2,p3"/>
  </deploy>
  <!--
    Open relativeFile1.jws in the base directory
    Open all projects.
    Deploy all profiles (default for "profile" parameter is "*")
  -->
  <deploy>
    <parameter name="workspace" value="relativeFile1.jws"/>
    <parameter name="project" value="*"/>
  </deploy>
  <!--
    Open relativeFile2.jws in base directory.
    Open all Projects
    Deploy profiles matching the patter "web*"
  -->
  <deploy>
    <parameter name="workspace" value="relativeFile2.jws"/>
    <parameter name="project" value="*"/>
    <parameter name="profile" value="web*"/>
  </deploy>
</ojdeploy-build>









22.8.3.3 How to Use Wildcard Samples



Project and profile names can be specified as "*" or "name*" or "name1,name2,name3,..." or any combination of these. Application names need to be enumerated, so "*" is not allowed in application names, but application names can be specified as "application1" or "application1,application2,application3".

For example:





	
adf* (Profile)


	
View* (Project)


	
*Controller (All Controller Projects)




An example of using wild cards with an application:


<ojdeploy-build basedir= "/home/jdoe" >
  <deploy>
    <parameter name= "workspace" value= "Application1.jws,Application2.jws" />
    <!-- above pattern gets /home/jdoe/Application1.jws and /home/jdoe/Application2.jws -->
    . . .
  </deploy>
/ojdeploy-build>









22.8.3.4 How to Create a Log File for Batch Deployment



The -statuslogfile parameter lets the user create a build summary for the entire deployment batch. An absolute path should be specified without macros.

The log file contains a list of the deployment tasks processed and the status from each task in XML format. The status will be either SUCCESS or FAILED and includes an exitcode attribute. Possible values for exitcode are:





	
0 - Success


	
1 - Fatal error (NPE, OutOfMemory, etc.)


	
2 - JDeveloper configuration error (missing extensions, etc.)


	
4 - Deployment Error (compilation, deployment exception, etc.) All exit codes are bitwise OR-ed.




A combined status is available in a summary section at the end of each log.

The following is an example of batch deployment log output.


<?xml version="1.0"?>
 <ojdeploy-log>
  <deploy-task>
   <target>
    <profile>webapp1</profile>
    <workspace>/scratch/jdoe/jdev/mywork/Application3/Application3.jws</workspace>
    <project>Project1.jpr</project>
   </target>
   <exception msg="**** One or more compilation errors prevented deployment from continuing.">
    oracle.jdeveloper.deploy.DeployException: **** One or more compilation errors prevented deployment from continuing.
    at oracle.jdevimpl.deploy.common.ModulePackagerImpl.compileDependents(ModulePackagerImpl.java:143)
    at oracle.jdeveloper.deploy.common.ModulePackager.compile(ModulePackager.java:65)
    at oracle.jdeveloper.deploy.common.ModulePackager.prepareImpl(ModulePackager.java:52)
    at oracle.jdeveloper.deploy.common.AbstractDeployer.prepare(AbstractDeployer.java:69)
    at oracle.jdevimpl.deploy.fwk.WrappedDeployer.prepareImpl(WrappedDeployer.java:32)
    at oracle.jdeveloper.deploy.common.AbstractDeployer.prepare(AbstractDeployer.java:69)
    at oracle.jdevimpl.deploy.fwk.WrappedDeployer.prepareImpl(WrappedDeployer.java:32)
    at oracle.jdeveloper.deploy.common.AbstractDeployer.prepare(AbstractDeployer.java:69)
    at oracle.jdevimpl.deploy.fwk.DeploymentManagerImpl.deploy(DeploymentManagerImpl.java:411)
    at oracle.jdevimpl.deploy.fwk.DeploymentManagerImpl$1.run(DeploymentManagerImpl.java:281)
 
   </exception>
   <status exitcode="4">FAILED</status>
  </deploy-task>
  <deploy-task>
  <target>
   <profile>archive1</profile>
   <workspace>/scratch/jdoe/jdev/mywork/Application3/Application3.jws</workspace>
   <project>Project1.jpr</project>
  </target>
  <exception msg="**** One or more compilation errors prevented deployment from continuing.">
    oracle.jdeveloper.deploy.DeployException: **** One or more compilation errors prevented deployment from continuing.
    at oracle.jdevimpl.deploy.common.ModulePackagerImpl.compileDependents(ModulePackagerImpl.java:143)
    at oracle.jdeveloper.deploy.common.ModulePackager.compile(ModulePackager.java:65)
    at oracle.jdeveloper.deploy.common.ModulePackager.prepareImpl(ModulePackager.java:52)
    at oracle.jdeveloper.deploy.common.AbstractDeployer.prepare(AbstractDeployer.java:69)
    at oracle.jdevimpl.deploy.fwk.WrappedDeployer.prepareImpl(WrappedDeployer.java:32)
    at oracle.jdeveloper.deploy.common.AbstractDeployer.prepare(AbstractDeployer.java:69)
    at oracle.jdevimpl.deploy.fwk.WrappedDeployer.prepareImpl(WrappedDeployer.java:32)
    at oracle.jdeveloper.deploy.common.AbstractDeployer.prepare(AbstractDeployer.java:69)
    at oracle.jdevimpl.deploy.fwk.DeploymentManagerImpl.deploy(DeploymentManagerImpl.java:411)
   at oracle.jdevimpl.deploy.fwk.DeploymentManagerImpl$1.run(DeploymentManagerImpl.java:281)
 
  </exception>
  <status exitcode="4">FAILED</status>
 </deploy-task>
 <deploy-task>
  <target>
   <profile>ejb1</profile>
   <workspace>/scratch/jdoe/jdev/mywork/Application3/Application3.jws</workspace>
   <project>Project3.jpr</project>
  </target>
 <status exitcode="0">SUCCESS</status>
 </deploy-task>
 <summary>
 <start-time>2007-12-19 12:10:42 PST</start-time>
 <end-time>2007-12-19 12:10:45 PST</end-time>
 <total-tasks>3</total-tasks>
 <failures>2</failures>
 <status exitcode="4">FAILED</status>
 </summary>
 </ojdeploy-log>









22.8.3.5 Timeouts


The -timeout parameter can be used for terminating runaway deployments. It specifies an upper limit on how much time deployment can take.

Timeout is for each Profile, not for the entire batch.









22.8.4 How to Deploy from the Command Line Using Ant


JDeveloper deployment is built around deployment profiles. A common implementation is an ArchiveProfile that describes the structure of a JAR archive.

Deployment profiles can be created as part of a project or application. With ojdeploy you can deploy ArchiveProfile(s) without invoking the JDeveloper IDE.

Command line deployment requires a JDeveloper installation. but this installation is invoked in 'headless mode', not displaying the JDeveloper IDE, loading all extensions defined for headless mode. This form of deployment can read JDeveloper applications and projects and their meta-data.

Ant scripts to invoke command line deployment must be created manually. The resulting deployed archive depends on the version of JDeveloper used, and which extensions are enabled when command line deployment is invoked.


Note:

It is a best practice to generate an .ear file from JDeveloper for the application. The .ear file will be generated with all the right class dependencies required to deploy it. Deploying with Ant by referring to an application directly (without generating an .ear file) may require dependencies for the classes and JAR files to be resolved manually.







22.8.4.1 How to Generate an Ant Build Script



To make it easier to create an Ant build script for command line deployment, you can generate an Ant script from JDeveloper.




	In the Projects window select a project or an application, and select File > New > From Gallery. In the General category, choose Ant. In the Items pane select the Buildfile type, then click OK.

[image: Ant Buildfile for a project]




	Complete the Create Buildfile from Project dialog and click OK. To invoke ojdeploy from this script enable Include Packaging Tasks.

[image: check Include Packaging tasks to call ojdeploy]


The generated file has the structure shown in the build.properties file in About The build.properties File.












22.8.4.2 About The build.xml File


The build.properties file, which is generated along with build.xml, defines the additional variables needed for command line deployment.

The following is an example of build.xml.


#Fri Feb 15 10:45:22 PST 2008
   #Sun Feb 24 18:47:36 PST 2008
   javac.nowarn=off
   javac.debug=on
   build.compiler=oracle.ojc.ant.taskdefs.OjcAdapter
   output.dir=classes
   oracle.home=../../oracle/
   javac.deprecation=off
   oracle.jdeveloper.ant.library=/scratch/jdoe/oracle/jdev//lib/ant-jdeveloper.jar
   oracle.jdeveloper.deploy.dir=/scratch/jdoe/Application7/Project1/deploy/
   oracle.jdeveloper.ojdeploy.path=/scratch/jdoe/oracle/jdev//bin/ojdeploy
   oracle.jdeveloper.workspace.path=/scratch/jdoe/Application7/Application7.jws
   oracle.jdeveloper.project.name=Project1
   oracle.jdeveloper.deploy.profile.name=*
   oracle.jdeveloper.deploy.outputfile=/scratch/jdoe/Application







22.8.4.3 About The build.properties File


The Ant build script can be run outside of JDeveloper by simply changing to the directory containing build.xml and running Ant. It can also be run from within JDeveloper, by right-clicking on the build.xml node in the Applications window and selecting the "all" or the "deploy" targets.


Note:

By default, the command line deployment task has the nocompile option enabled as the task has dependency on the compile task. If this dependency is removed then the nocompile option can be removed.



It is a best practice to generate an .ear file from JDeveloper for the application. The .ear file will be generated with all the right class dependencies required to deploy it. Deploying with Ant by referring to an application directly without generating an .ear file may require that dependencies for the classes and jars files must be resolved manually.

The following is an example of the build.properties file.


Buildfile: /scratch/jdoe/Application7/Project1/build1.xml 
 
init: 
 
compile: 
deploy:
 [ora:ojdeploy]
 [ora:ojdeploy] Oracle JDeveloper Deploy 11.1.1.0.0
 [ora:ojdeploy] Copyright (c) 2008, Oracle. All rights reserved.
 [ora:ojdeploy]
 [ora:ojdeploy] ----build file----
 [ora:ojdeploy] <?xml version = '1.0' standalone = 'yes'?>
 [ora:ojdeploy] <ojdeploy-build>
 [ora:ojdeploy] <deploy>
 [ora:ojdeploy] <parameter name="workspace" 
value="/scratch/jdoe/Application7/Application7.jws"/>
 [ora:ojdeploy] <parameter name="project" value="Project1"/>
 [ora:ojdeploy] <parameter name="profile" value="*"/>
 [ora:ojdeploy] <parameter name="nocompile" value="true"/>
 [ora:ojdeploy] <parameter name="outputfile" 
value="/scratch/jdoe/Application7/Project1/deploy/${profile.name}"/>
 [ora:ojdeploy] </deploy>
 [ora:ojdeploy] <defaults>
 [ora:ojdeploy] <parameter name="buildfile" 
value="/scratch/jdoe/Application7/Project1/deploy/ojdeploy-build.xml"/>
 [ora:ojdeploy] <parameter name="statuslogfile" 
value="/scratch/jdoe/Application7/Project1/deploy/ojdeploy-statuslog.xml"/>
 [ora:ojdeploy] </defaults>
 [ora:ojdeploy] </ojdeploy-build>
 [ora:ojdeploy] ------------------
 [ora:ojdeploy] ---- Deployment started. ---- Feb 24, 2008 6:49:51 PM
 [ora:ojdeploy] Target platform is (WebLogic 10.3).
 [ora:ojdeploy] Running dependency analysis...
 [ora:ojdeploy] Wrote JAR file to 
/scratch/jdoe/Application7/Project1/deploy/archive1.jar
 [ora:ojdeploy] Elapsed time for deployment: less than one second
 [ora:ojdeploy] ---- Deployment finished. ---- Feb 24, 2008 6:49:51 PM
 [ora:ojdeploy] ---- Deployment started. ---- Feb 24, 2008 6:49:51 PM
 [ora:ojdeploy] Target platform is (Java Enterprise Edition 1.5).
 [ora:ojdeploy] Running dependency analysis...
 [ora:ojdeploy] Wrote WAR file to 
/scratch/jdoe/Application7/Project1/deploy/WindowMobile.war
 [ora:ojdeploy] Elapsed time for deployment: less than one second
 [ora:ojdeploy] ---- Deployment finished. ---- Feb 24, 2008 6:49:52 PM
 [ora:ojdeploy] Status summary written to 
/scratch/jdoe/Application7/Project1/deploy/ojdeploy-statuslog.xml
 
BUILD SUCCESSFUL
 Total time: 19 seconds







22.8.4.4 ojdeploy for Extension Developers


The ojdeploy command offers a framework that allowed extensions to plug into the ojdeploy process. Prior to the new framework, ojdeploy only allowed deployment to archives. The new framework is designed to handle the creation and execution of any DeployCommand implementation. The framework allows, for example, any extension to define ojdeploy support for its DeployCommand.

The new framework allows extensions the freedom to:

	
Define their own OJDeploy arguments and parsing rules.


	
Define their own Command Parser and Model (optional).


	
Define their own argument expansion and wildcard logic via ContextIterators. (optional)


	
Control the exact makeup of their DeployCommand Context.


	
Control the creation and setup of their DeployCommand instances.




The framework is designed to allow a great deal of flexibility while offering extension writers a mechanism that is easy to use because it provides many built-in components; for example, AbstractCommandSupport and AbstractContextIterator.




Table 22-5 Class Lexicon

	Class Name	Description
	
Arguments

	
Represents command line arguments passed into the ojdeploy process. Note that Buildfiles parameters/variables are also converted into Arguments for processing.


	
BuildScript

	
A BuildScript represents the buildfile that is the input of the OJDeploy process. Note that a BuildScript can be created from a buildfile or by parsing command line arguments. Regardless, a BuildScript is always created during the OJDeploy process.


	
OJBuildScriptSupport

	
This class converts the BuildScript into an ojdeploycommanditerator. As shown in the sequence diagram below, this class controls the OJCommandSupport creation, parsing of arguments and the creation of OJContextIterators.


	
OJCommandSupport

	
This class is used to support the proper creation of a given DeployCommand. For example, the DeployToArchiveCommandSupport is one implementation that allows Deployment of Profiles to an archive file. This is where the bulk of the logic will be implemented for your own ojdeploy command extension. You can refer to the following HOW To section for instructions on How to write your own OJCommandSupport implementation.


	
Context

	
An IDE Context. The context is critical because it is used in order to create any DeployCommand instance via the DeployCommandFactory. As an ojdeploy extension, you will be required to construct the Context necessary to instantiate your DeployCommand instances.


	
OJContextIterator

	
An Iterator of Contexts. Note that various Context Iterators have been pre-built for you to use. For example, the ojdeploy framework includes iterators that will populate Context instances based on a given Workspace (WorkspaceContextIterator), Project (ProjectContextIterator) and Profile (ProfileContextIterator). You likely will not need to create your own ContextIterator but in the event that you do, the framework also includes an AbstractContextIterator that you can extend for that purpose (more on this in the following section on How to write your own OJContextIterator.).


	
DeployCommand

	
The entire purpose of the ojdeploy process is to create DeployCommand instances and run them. A DeployCommand is an extension of the IDE Command.


	
DeployService

	
The DeployService is invoked by the ojdeploy process to control creation and execution of a DeployCommand in the ojdeploy process. It is in effect the client of the OJDeploy Framework API as shown in the sequence diagram below.


	
OJCommandModel

	
An OJCommandModel is an extension to the IDE CommandModel. It holds the arguments parsed into the OJCommandParser.


	
OJCommandParser

	
The OJCommandParser is used to parse Arguments and create the OJCommandModel.


	
OJCommand

	
Not to be confused with the DeployCommand, the OJCommand is a simple class which simply holds the CommandID (for example, "Deployment.DeployToFile") and Command Label (DeployToArchive). The CommandID is used by the DeployCommandFactory in order to create the DeployCommand. The Command Label is what is used as the DeployCommand identifier on the command line or buildFile. The Command Label is simply a user friendly representation that corresponds to the CommandID. There is therefore a one to one relationship between the two.


	
OJDeployCommandIterator

	
The OJDeployCommandIterator is used to iterate all DeployCommand instances of a given BuildScript. Note that the OJDeployCommandIterator in conjunction with the OJContextIterators allow for lazy loading of all DeployCommand context objects (Workspace, Project, Profile etc) and also releases those objects automatically after each command execution for proper resource management during the ojdeploy process.









Figure 22-4 Sequence Diagram

[image: sequence diagram for extension framework]


Current Limitations

	
To recreate a deployed module with ojdeploy just as if it were being deployed from within the IDE in GUI mode, the exact same JDeveloper installation should be used. A change in the Jdeveloper installation means a possible change in the extensions that are loaded, or their versions, and thus the end result may also change.


	
Startup time of ojdeploy is dependant on startup time for a headless JDeveloper. All the extensions that are registered for this mode, need to be initialized. This time could be shortened by each Extension optimizing itself for the headless mode. For large builds, the -ojserver option can submit a deploy job to a server running in the background. See OJServer





Using the headless Attribute

ojdeploy runs JDeveloper in headless (non-GUI) mode, which enables all the various extensions that support this mode.





	
To ensure IDE Addins (oracle.ide.Addin) are loaded when running in headless mode they should be marked with the "headless=true" tag. Addins that are not marked as such, should not be referred to from these headless Addins.

During Addin.initialize() all the IDE contexts are available, including the current Active Workspace and Project.


	
All Deployment Toolkits provided by the extension that need to run in ojdeploy also need to be marked with the "headless=true" attribute














22.8.5 Using ojserver


ojserver is a headless version of JDeveloper that runs in server mode, listening to remote client requests. Clients and submit service requests to the server using RMI. ojserver's main purpose is to reduce the startup time incurred when using command-line tools in batch scripts that run JDeveloper in headless mode. ojserver can be found in the oracle/jdeveloper/jdev/bin directory.

To see the usage, parameters, options, and examples for ojserver, at the command line for jdeveloper_install/jdeveloper/jdev/bin type ojserver.

ojdeploy can run a deployment locally in-process, or submit to a background OJServer using the -ojserver option. When using -ojserver, ojdeploy blocks till the deployment is complete, and exit codes are set depending on how deployment fared on the server.

All the options for local deployment are also available when running on ojserver, however, if any absolute paths are being used, they have to be accessible on the server.









22.9 Deploying Using Java Web Start


Java Web Start is included in the Java Runtime Environment (JRE) as part of Java SE 6 and later: http://www.oracle.com/technetwork/java/javase/tech/index-jsp-136112.html.

JDeveloper supports the creation of the XML-based JNLP (Java Network Launching Protocol) definition upon which the Java Web Start technology is based. Java Web Start allows you to deploy Java applications so that they can be launched from an internet browser. Java Web Start lets you maintain Java client applications and applets on the web server, which users download and run on their client machines.With the Create Java Web Start-Enabled wizard in JDeveloper, you can set up applications and applets to be maintained on the web server, but downloaded and run on client machines.


Note:

Double-check this note on next review

Starting with Java SE 7 Update 21 in April 2013 all Java Applets and Web Start Applications are encouraged to be signed with a trusted certificate. And starting with 7u25, all files must be added to JARs prior to signing. For more details, refer to the Java web site at http://www.oracle.com/technetwork/java/javase/tech/java-code-signing-1915323.html.



The process of developing a Java Web Start application can be summarized as:

	
Develop the Java application.


	
Simulate the user's experience of running the application with Java Web Start within the JDeveloper IDE.


	
Use the JDeveloper Java EE Web deployment process to move the production application to the web server.





Note:

To launch applications and applets with Java Web Start in JDeveloper, you must download and install the Java Web Start software. Users of your application or applet will also be required to install the software on their machines.



For more information on Java Web Start and to download the Java Web Start software, see: http://www.oracle.com/technetwork/java/javase/tech/index-jsp-136112.html.





22.9.1 Purpose of the Java Web Start Technology


Although Java Web Start and applets may appear to be similar technologies, there are several differences:

	
Unlike the applet approach to deploying web-centric Java applications, Java Web Start does not rely on the web browser to perform the downloading of the application JAR files. Instead, Java Web Start downloads the application resources after the Java Web Start JNLP descriptor is downloaded through the web browser. The JNLP descriptor causes Java Web Start to launch and perform the actual downloading.


	
While users of the application may experience the applet identically in Java Web Start, they are not tied to the web browser as they would be with applets. Once the application is running, the web browser can be closed, and the application continues to run in Java Web Start.




With the Java Web Start software installed once on the client machine, the application user can run applications and applets simply by clicking on a web page link. If the application is not present on their computer, Java Web Start automatically downloads all necessary files from the web server where the application libraries reside. It then caches the files on the client computer so the application is always ready to be relaunched anytime either from an icon on your desktop or from the browser link. The most current version of the application is always presented to the user since Java Web Start performs updates as needed.





22.9.1.1 Files Generated by the Create Java Web Start-Enabled Wizard


Application users can use Java Web Start to run applications and applets on client machines, while you maintain the application on the web server. To support Java Web Start and web server downloading, the Create Java Web Start-Enabled wizard generates these files:

	
The Java Network Launching Protocol (JNLP) definition required by Java Web Start to download and launch the application. The .jnlp file describes the archive files and whether this instance includes an applet or an application.


	
An HTML file that contains the URL to initiate the downloading from the web server to the client. Although HMTL file creation is optional, it is highly recommended unless you intend to create the file manually.




Users can use Java Web Start to run applications and applets on client machines, while you maintain the application on the web server. To support Java Web Start and web server downloading, the Create Java Web Start-Enabled wizard generates these files:







22.9.1.2 Role of the Web Server in JDeveloper


JDeveloper provides an Integrated WebLogic Server web server. You can use it to simulate the process of deploying the Web Application Archive and downloading for use with Java Web Start. JDeveloper follows the J2SE deployment profile conventions for archiving components that run on the client machine (simple archive) and components that are deployed to the web server (Web Application Archive).

How to complete the Java Web Start setup:

	
Create a simple Java Archive (.jar) file that contains the application source files to be downloaded and run on the client machine.


	
Launch the Create Java Web Start-Enabled wizard in JDeveloper to create the HTML and JNLP files that will enable the application or applet to be downloaded and run on the client machine.


	
.Create a Web Application Archive (.war) file which you deploy to the web server. It will contain the contents of the public_html directory in your JDeveloper mywork folder, including the JAR, HTML and JNLP files.





Note:

You will not be required to deploy the application to use the JDeveloper-embedded web server. JDeveloper provides a default web.xml definition to locate the contents of the public_html directory in your JDeveloper mywork folder.



Once you have set up the web server, you can launch the Java Web Start software in JDeveloper using the generated .html file. Java Web Start relies on your web browser to download the components identified by the .jnlp file. Another definition in the .jnlp file determines whether it will run as an application or a secure applet. Once you have launched Java Web Start and the downloading is complete, you can close your web browser and continue to run the application or applet.









22.9.2 How to Create a Java Web Start File



A Java Network Launching Protocol definition file, application-name.jnlp, is automatically created when you use the Create Java Web Start-Enabled wizard to create Java clients to download and run Java applications and applets on client machines. However, if you want to control the contents of the application-name.jnlp, you can manually create your own file to use.


Note:

If this item appears grayed out, this indicates that there is an application-name.jnlp file already created in the project. You can have only one of each deployment descriptor type per project.



To manually create a Java Web Start (.jnlp) file:




	In the Categories tree, expand General and select Deployment Descriptors. In the Items list, double-click Java Web Start (JNLP) Files.
	If the category or item is not found, make sure the correct project is selected, and choose All Technologies in the Filter By dropdown list.
	Click OK.
	The newly created file opens in the Code Editor. Edit this file to add the configuration settings as appropriate.



For more information on Java Web Start, see http://www.oracle.com/technetwork/java/javase/tech/index-jsp-136112.html.









22.9.3 How to Create a Java Client Web Archive for Java Web Start



You can use the JDeveloper Java EE web deployment process to set up the server before downloading and running the application using Java Web Start.

Once the application resides on the web server, it becomes very easy to maintain. Java Web Start takes care of identifying and downloading application updates each time the user runs the application.

To create Java client applications for deployment to the web server:




	Create a simple JAR archive of your Java client application.
	Create a Web Start JNLP Definition for Java Clients to generate the JNLP file and HTML file for use with Java Web Start.
	In the Applications window, select the project in which you want to create the WAR deployment profile.
	Choose File > New to open the New Gallery.
	In the Categories tree, expand General and select Deployment Profiles. In the Items list, double-click WAR File.
	If the category or item is not found, make sure the correct project is selected, and choose All Technologies in the Filter By dropdown list. Enter the name of the new deployment profile then click OK.
	The WAR Deployment Profile Properties panel displays. Configure the settings for each page as appropriate. Click OK when you have finished defining the properties.

The newly created web.xml deployment descriptor appear in the Applications window below the specified project.




	Deploy the Java Client Web Archive for Java Web Start.
	(Optional) If you want to edit the web.xml deployment descriptor, right-click the web.xml file in the Applications window and choose Open.
	(Optional) To reopen a project deployment profile later to make changes, right-click the project in the Applications window and choose Project Properties, then select the name of the profile in the Deployment section of the Project Properties dialog and click Edit.



When you are ready to deploy the resulting WAR or EAR to the target application server, make sure to create an application server connection.


Note:

The web module is deployed to the target deployment directory.

Make sure that the web application deployment descriptor is located inside the Web Application Archive (WAR) file WEB-INF/web.xml.











22.9.4 How to Create a Java Web Start JNLP Definition for Java Clients



You use the Create Java Web Start-Enabled wizard to create the XML-based JNLP (Java Network Launching Protocol) definition file that the Java Web Start software uses to download and run Java applications and applets on client machines.


Note:

You must download and install the Java Web Start software to launch applications and applets with Java Web Start in JDeveloper. Users of your application or applet will also be required to install the software on their machines. See


http://www.oracle.com/technetwork/java/javase/tech/index-jsp-136112.html



The application or applet must be delivered in a set of JAR files and all application resources, such as images, configuration files and native libraries, must be included in the JAR files. The resources must be looked up using the ClassLoader getResource or another method. Java Web Start only transfers JAR files from the web server to the client. for additional information, see http://www.oracle.com/technetwork/java/javase/tech/index-jsp-136112.html

The wizard adds a JNLP file and (optionally) an HTML file to your project. Java Web Start will use these generated files to determine what application source to download from the web server:





	
The Java Network Launching Protocol (JNLP) definition is required by Java Web Start to download and launch the application. The .jnlp file describes the archive files and whether this instance includes an applet or an application.


	
An HTML file. Although HMTL file creation is optional, it is highly recommended unless you intend to create the file manually. The HTML file contains the URL to initiate the downloading from the web server to the client.




Before you launch the Create Java Web Start-Enabled wizard to create the JNLP and HTML files, you must create a simple archive (JAR) file for it. You must also know in which class the main function can be found, as you will be asked to specify this.

To create the JNLP definition for your application or applet:




	In the Applications window, select the project in which you want to generate a JNLP definition. Choose File > New to open the New Gallery.
	In the Categories tree, expand Client Tier and select Swing/AWT. In the Items list, double-click Java Web Start (JNLP) Files to open the Create Java Web Start-Enabled wizard.

Click Next in the Welcome page.




	In the Application Information page, enter the file name, the name and location of the JAR file that you created, and the class that you want to use to run your application.
	For detailed help in using the Create Java Web Start-Enabled wizard, press F1 or click Help from within the wizard.
	Check Create Homepage to create the optional HTML file. Click Next after specifying the desired options.
	In the Web Start page, specify information to document the JNLP file. Complete the wizard and click Finish.



You can also use a JSP file or servlet with Java Web Start; however, you will have to manually configure the file and change the content type. Here is an example JNLP with contentType = application/x-java-jnlp-file, specified in the first line:


<%@ page contentType="application/x-java-jnlp-file" %>
<?xml version="1.0" encoding="utf-8"?>
<jnlp spec="1.0+" codebase="http://192.168.1.102:8888" href="jnlpfile.jnlp">
<information>
<title>Test</title>
<vendor>Oracle</vendor>
<homepage href="Test.html"/>
<description>Encryption Tool</description>
<icon href="images/frontpage.gif"/>
<offline-allowed/>
</information>
<security><all-permissions/></security>
<resources>
<j2se version="1.3"/>
<jar href="/apps/archive1.jar" main="true" download="eager" />
</resources>
<application-desc main-class="oracle.Ide">
</application-desc>
</jnlp>









22.9.5 How to Deploy a Java Client Web Application Archive for Java Web Start



You can use the JDeveloper simple Java EE web deployment process to set up the web server before downloading and running the application using Java Web Start.

Once the application resides on the web server, it becomes very easy to maintain. Java Web Start takes care of identifying and downloading application updates each time the user runs the application.

To deploy Java client applications to the web server:




	If not already done, create a Java Client Web Archive for Java Web Start.
	If not already done, create an application server connection.
	Create a simple JAR archive of your Java client application.
	Create a Web Start JNLP Definition for Java Clients to generate the JNLP file and HTML file for use with Java Web Start.
	Select and right-click project in the Applications window. The context menu displays these deployment options:

	
Deploy > deployment profile > to most-recent to deploy the project to the application server or archive file you previously chose.


	
Deploy > deployment profile > to application server connection creates the archive type specified in the deployment profile, and deploys it to the selected application server connection.


	
Deploy > deployment profile > to EAR file to deploy the project and any of its dependencies (specified in the deployment profile) to an EAR. JDeveloper puts the EAR file in the default directory specified in the deployment profile.


	
Deploy > deployment profile to > WAR file the web module is packaged as a WAR file and saved to the local directory you specified earlier in the deployment profile settings.







	(Optional) If you want to edit the web.xml deployment descriptor, right-click the web.xml file in the Applications window and choose Open.
	(Optional) To reopen a project deployment profile later to make changes, right-click the project in the Applications window and choose Project Properties, then select the name of the profile in the Deployment section of the Project Properties dialog and click Edit.




Note:

Make sure that the web application deployment descriptor is located inside the Web Application Archive (WAR) file, WEB-INF/web.xml.













22.10 Deploying Using Weblogic SCA Spring


The Oracle JDeveloper Weblogic SCA Spring Extension provides integrated support for WebLogic SCA and for the open-source Spring framework.

The extension allows you to create:

	
WebLogic SCA enabled projects that can be deployed as a JAR file which can then be included in an EAR file for deployment, or as a WAR file.


	
Spring framework projects.








22.10.1 About WebLogic SCA


The extension provides support for creating WebLogic SCA applications in JDeveloper and deploying them in Oracle WebLogic Server. WebLogic SCA is based on a subset of the OASIS Service Component Architecture Spring Component Implementation Specification. For more information, see https://www.oasis-open.org.

Service Component Architecture (SCA) provides a model for building enterprise applications and systems as modular business services that can be integrated and reused. WebLogic SCA provides support for developing and deploying SCA applications using POJOs (Plain Old Java Objects). In SCA, the implementation of a component and its communication are separate. In WebLogic SCA, you can write Java applications using POJOs and, through the different protocols available, expose components as SCA services and access them via references. You do this using SCA semantics configured in a Spring application context. In SCA terms, a WebLogic Spring SCA application is a collection of POJOs plus a Spring SCA context file that declares SCA services and references with the appropriate bindings. WebLogic Spring SCA applications can be used without modification as components in Oracle SOA composites.

In WebLogic Server, WebLogic Spring SCA applications run in the WebLogic SCA Runtime. The runtime must be deployed to WebLogic Server as a shared Web application library before applications can be deployed to it. For more, see How to Deploy WebLogic SCA Applications to Integrated WebLogic Server.

For more information about Oracle WebLogic SCA, see Developing WebLogic SCA Applications for Oracle WebLogic Server.







22.10.2 About Spring


Spring is an open-source framework that simplifies development of enterprise Java applications. The Spring framework includes models for various layers and functionality areas of Java applications. It focuses on using POJOs, leverages inversion of control concepts and dependency injection, and implements aspect oriented programming.

The Weblogic SCA Spring Extension provides integrated support for creating open source Spring projects in JDeveloper that can be used in Java EE applications. It adds the Spring JAR files as a library to JDeveloper, and it adds a wizard and editing features for creating Spring Bean configuration files. The extension creates: Adds the Spring JAR files as the Spring 2.5 library to JDeveloper. Adds a wizard for creating Spring Bean configuration files Registers the relevant XSDs and DTDs with the IDE to provide a productive editing experience for Spring definitions.

For more information about Spring, see Developing and Administering Spring Applications for Oracle WebLogic Server.







22.10.3 Installing the Weblogic SCA Spring Extension


To use the Oracle JDeveloper Weblogic SCA Spring Extension, you must download it and install it. The extension adds the following to JDeveloper:

	
The Spring category to the Business Tier in the New Gallery. The options for creating the Spring Bean Configuration file and the WebLogic SCA Configurations are available here.


	
The Spring 2.5 library is added to JDeveloper, along with the JAR files of the Spring framework and support for WebLogic SCA.










22.10.4 Using Oracle WebLogic SCA


You can use the Weblogic SCA Spring Extension to create WebLogic SCA enabled projects that can be deployed as a JAR file which can then be included in an EAR file for deployment, or as a WAR file.





22.10.4.1 How to Create WebLogic SCA Projects



You begin developing a WebLogic SCA project by creating the WebLogic SCA Configuration file which acts as the control file for the application. As part of this process, JDeveloper configures either the JAR or WAR deployment descriptor for WebLogic SCA so that the necessary libraries are deployed to the server.

To create a WebLogic SCA application:




	Create a Java application and project.
	Choose File > New > New Gallery > Business Tier > Spring.
	Choose either:

	
WebLogic SCA Configuration for JAR deployment to create a project that includes a JAR file that can be included in an EAR file for deployment.


	
WebLogic SCA Configuration for WAR deployment to create a project that includes a WAR file.










Example 22-2 What the WebLogic SCA Wizard Does

When you run the WebLogic SCA Configuration wizard, the following happens:





	
An SCA definition file called spring-context.xml is created in META-INF/jsca and opened in the JDeveloper XML source editor. You can use the advanced XML editing framework to assist you as you edit it.


	
If the project does not already contain a web.xml file one is created.


	
Depending on the option you choose in the New Gallery:

	
A JAR deployment descriptor is added to the project, and a dependency on the weblogic-sca shared library is added at application level.


	
A WAR deployment descriptor is added to the project, and a dependency on the weblogic-sca shared library is added at web application level.











Example 22-3 Next Steps

Once you have created an SCA project, you can:





	
Deploy the application to Oracle WebLogic Server.


	
Test the application with the JDeveloper Integrated WebLogic Server.












22.10.4.2 How to Edit Oracle WebLogic SCA Definition Files


The SCA definition file created when you create a WebLogic SCA project is called spring-context.xml, and it is created in META-INF/jsca and opened in the XML source editor.

The following example shows the outline spring-context.xml file.


<?xml version="1.0" encoding="windows-1252" ?>
<beans xmlns="http://www.springframework.org/schema/beans"
       xmlns:util="http://www.springframework.org/schema/util"
       xmlns:jee="http://www.springframework.org/schema/jee"
       xmlns:lang="http://www.springframework.org/schema/lang"
       xmlns:aop="http://www.springframework.org/schema/aop"
       xmlns:tx="http://www.springframework.org/schema/tx"
       xmlns:sca="http://xmlns.oracle.com/weblogic/weblogic-sca"
       xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
       xsi:schemaLocation="http://www.springframework.org/schema/beans 
http://www.springframework.org/schema/beans/spring-beans-2.5.xsd 
http://www.springframework.org/schema/util 
http://www.springframework.org/schema/util/spring-util-2.5.xsd 
http://www.springframework.org/schema/aop 
http://www.springframework.org/schema/aop/spring-aop-2.5.xsd 
http://www.springframework.org/schema/jee 
http://www.springframework.org/schema/jee/spring-jee-2.5.xsd 
http://www.springframework.org/schema/lang 
http://www.springframework.org/schema/lang/spring-lang-2.5.xsd 
http://www.springframework.org/schema/tx 
http://www.springframework.org/schema/tx/spring-tx-2.5.xsd 
http://www.springframework.org/schema/tool 
http://www.springframework.org/schema/tool/spring-tool-2.5.xsd 
http://xmlns.oracle.com/weblogic/weblogic-sca META-INF/weblogic-sca.xsd">
  <!--Spring Bean definitions go here-->
 
</beans> 
 


The comment shows where you enter the bean definitions.

Use the XML source editor features, Structure window features, the Components window, and the Properties window to navigate the hierarchy of the XML file and edit it.


Source Editor Features

The source editor has a number of features which help you to edit an XML file.





	
XML Code Insight, the XML-specific implementation of completion insight. Type < and wait for a second, and JDeveloper will pop-up the possible entries appropriate for that location. If the tag you chose has mandatory attributes, JDeveloper will automatically add them.


	
The XML source editor provides many features to help, for example, errors are underlined with a curly red line.


	
You can choose options from the context menu such as Find Usages, which will display all the usages of the element in the Usages log window. You can also use Find Usages from the Structure window.








Structure Window Features

The Structure window allows you to quickly navigate the hierarchy of the XML file, and it also offers editing features.





	
Right click on nodes in the Structure window to add more components.


	
Error messages are displayed in the Structure window.








Components Window Features

You can select tags from the Components window and drag and drop them directly into the source editor or the Structure window to build spring-context.xml files.






Note:

You can only drop tags in places that are correct in terms of syntax.



By default, the Components window displays all the available tags. Click All Pages and choose just the type of tags you want to reduce the number of tags displayed. For example, to use WebLogic SCA Bindings, choose that option at the top of the Components window and the components listed are EJB Binding and Webservice Binding.





Properties Window Features

The Properties window allows you to edit the properties of tags.





	
Changes in the Properties window are synchronized with the source editor view.


	
Lists of values are shown when they are relevant for a specific property.












22.10.4.3 How to Deploy WebLogic SCA Applications to Integrated WebLogic Server



Once you have created a WebLogic SCA project you can test the application by quickly deploying it to the Integrated WebLogic Server.

To deploy to Integrated WebLogic Server, In the Applications window right-click spring-context.xml under the project node in the Applications window and choose Run, or Debug, or one of the Profiler options.





What Happens When You Run the Application in Integrated WebLogic Server

If Integrated WebLogic Server has not yet been started, the default domain is automatically created with default settings and the server is started.





The application is deployed to Integrated WebLogic Server and the Log Window displays messages that show the progress of the deployment.

In the Application Servers window, you can see the services deployed under the Web Services and EJB nodes under IntegratedWebLogicServer.









22.10.4.4 How to Deploy WebLogic SCA Applications to Oracle WebLogic Server



Once you have created a WebLogic SCA project you can deploy it to Oracle WebLogic Server.

The process is slightly different depending on whether you chose to create a JAR or a WAR file.


Note:

Before you deploy a WebLogic SCA application to Oracle WebLogic Server, you must install WebLogic SCA on the server. For more information, see the chapter about deploying WebLogic SCA Runtime to WebLogic Server in the Developing and Administering Spring Applications for Oracle WebLogic Server.



To deploy an Application Containing a WebLogic SCA WAR File to WebLogic Server, Deploy the application as usual.

To deploy an Application Containing a WebLogic SCA JAR File to WebLogic Server:




	Set the location of the JAR file to be either lib or APP-INF/lib and deploy it into an EAR file.


Note:

The EAR file must contain at least one other Java EE artifact, for example a WAR file or EJB-JAR or the deployment will fail.






	Deploy the application as usual.



Example 22-4 What Happens When You Deploy the Application to WebLogic Server

If necessary, an EAR file is created.





The application is deployed to the WebLogic Server connection and the Log Window displays messages that show the progress of the deployment.

In the Application Servers window, you can see the services deployed under the Web Services and EJB nodes under the connection node for the application server.











22.10.5 Using Spring


The Weblogic SCA Spring Extension provides integrated support for the open-source Spring framework. The extension adds a number of libraries to JDeveloper, and adds support for creating Spring framework projects





22.10.5.1 How to Create Spring Bean Applications



The Weblogic SCA Spring Extension adds libraries to JDeveloper containing the JAR files of the Spring framework. You begin developing a Spring framework application by creating the Spring Bean Configuration file, which acts as the control file for the application.

To create a Spring Bean Configuration file:




	Create a Java application and project.
	Choose File > New > New Gallery > Business Tier > Spring > Spring. Enter the file name and directory for the Spring Bean definition file and click OK.








22.10.5.2 What Happens When You Create a Spring Bean Configuration File


When you create a Spring Bean Configuration from the Spring category in the Business Tier of the New Gallery, the Spring 2.5 and Commons Logging 1.0.4 libraries are automatically added to the project. You can access the library definitions by choosing Project Properties from the context menu of the project in the Applications window, and then choosing Libraries and Classpath.

The Spring Bean Configuration file, beans.xml, is created in META-INF/jsca and opened in the XML source editor. You can use the advanced XML editing framework to assist you as you edit it.











22.11 Troubleshooting Deployment


There a number of common problems that you may come across when deploying applications. This topic describes them and their solutions. It is divided into issues that may arise when deploying to both Integrated WebLogic Server and Oracle WebLogic Server, and issues that are specific to one or other type of deployment





22.11.1 Common Deployment Issues


This section contains information about issues that may arise when deploying to both Integrated WebLogic Server and Oracle WebLogic Server.





22.11.1.1 [Deployer: 149164] The domain edit lock is owned by another session in exclusive mode - hence this deployment operation cannot proceed



Oracle WebLogic Server instances use the domain edit lock to make sure that only one user can deploy applications and change configurations at one time, and this message is displayed when another deployment is going on at the same time (only one deployment at a time is allowed), or some change has been made in the WebLogic Server Administration Console that has not been activated. Rarely, this message may also appear when you are running an application on Integrated WebLogic Server.

To activate a change in the WebLogic Server Administration Console:




	Log in to the Administration Console.
	In the Change Center, at the upper left of the console, click View changes and restarts.
	In the Changes and Restarts section, ensure that the Change List tab is selected, and activate any pending changes.
	Select the Restart Checklist tab, and select the server to restart, and click Start.



To enable or disable the domain configuration locking feature, see the section about enabling and disabling the domain configuration lock in the Administration Console Online Help, which is available from the WebLogic Server online documentation in your JDeveloper installation, or from the Administration Console.

If the error has appeared when you are deploying to Integrated WebLogic Server, you can check the Administration Console to determine what the problem is.











22.11.2 How to Troubleshoot Deployment to Integrated Application Servers


This section contains information about issues that are specific to running on integrated application servers.





22.11.2.1 Stopping Integrated Application Server



If you need to stop integrated application server, for example, to clear out an orphaned WebLogic Server instance that was created and left running from an earlier JDeveloper session, and you are unable to do so from within JDeveloper, go to jdeveloper-user-home/DefaultDomain/bin, and run stopWebLogic.cmd (on Windows) or stopWebLogic.sh (on Linux). This gracefully shuts down the integrated application server so that it will not conflict with subsequent attempts to launch the integrated application server from JDeveloper.

You can force shutdown of an instance that is still actively under the JDeveloper control (that is, not orphaned) by pressing the Terminate button twice.









22.11.2.2 Running Out of Memory



If you run multiple applications on Integrated WebLogic Server, you may run out of memory and see the java.lang.OutOfMemoryError: PermGen space exception. To avoid this, increase the MEM_MAX_PERM_SIZE from the default of 128m to 256m, 512m, or higher. This is set in setStartupEnv.cmd (Windows) or setDomainEnv.sh (Linux), which is located at jdeveloper-user-home/DefaultDomain/bin.

You first need to stop Integrated WebLogic Server using one of the methods described above.









22.11.2.3 Reinstalling JDeveloper in a Different Location



If you reinstall JDeveloper into a new location, you may find that you have problems because the integrated application server uses some hard-coded references to JDeveloper. You must do one of:





	
Set JDEV_USER_DIR to use a new system directory. This is described in "Setting the User Home Directory" in the Installing Oracle JDeveloper.


	
Delete the old system directory, so that JDeveloper regenerates a new system directory.


	
In the Application Servers window, right-click on IntegratedWebLogicServer and select Delete Default Domain.














22.11.3 How to Troubleshoot Deployment to Oracle WebLogic Server



This section contains information about issues that are specific to deploying to Oracle WebLogic Server.







22.11.3.1 ORA-01005: null password given; logon denied



This is usually caused by a blank password in the <encrypted-password> entry of the application-name-jdbc.xml file or no <encrypted-password> entry at all.









22.11.3.2 ORA-01017: invalid username/password; logon denied



This is usually caused by the wrong password in the <encrypted-password> entry of the application-name-jdbc.xml file.









22.11.3.3 [Oracle JDBC Driver] Kerberos Authentication was requested, but is not supported by this Oracle Server



This will cause logon to be denied, and it is due to using the Oracle WebLogic Server database driver, weblogic.jdbcx.oracle.OracleDataSource. This driver is not certified by Oracle and should not be used.









22.11.3.4 Application Does Not Work After Creating a Global Data Source from the Oracle WebLogic Server Administration Console



Make sure there is a target domain selected for the data source. If you clicked Finish before the last panel of the wizard, then this was not done.

Also, make sure that the Java naming lookup call is correct if you are using a lookup in Java code. For example, if the connection name is connection1, the naming lookup should be java:comp/env/jdbc/connection1DS.









22.11.3.5 Redeploying an Application to a Server that is Down



You can only deploy an application once to a server that is down.

If you attempt to redeploy the same application to the same down server a second time, deployment fails with the following log message:


[03:29:47 PM] ---- Deployment started. ----
[03:29:47 PM] Target platform is (Weblogic 10.3).
[03:29:47 PM] Retrieving existing application information
[03:29:47 PM] Running dependency analysis...
[03:29:47 PM] Building...
[03:29:50 PM] Deploying 2 profiles...
[03:29:50 PM] Wrote Web Application Module to /path/oracle/jdeveloper/jdev/mywork/Application1/Project1/deploy/webapp1.war
[03:29:50 PM] Wrote Enterprise Application Module to /path/oracle/jdeveloper/jdev/mywork/Application1/application1.ear
[03:29:50 PM] Redeploying Application...
[03:29:50 PM] [Deployer:149034]An exception occurred for task [Deployer:149026]deploy application application1 on Server-1.: [DeploymentService:290049]Deploy failed for id '1,244,759,390,503' since no targets are reachable..
[03:29:50 PM] Weblogic Server Exception: java.lang.Exception: [DeploymentService:290049]Deploy failed for id '1,244,759,390,503' since no targets are reachable.
[03:29:50 PM] See server logs or server console for more details.
[03:29:50 PM] java.lang.Exception: [DeploymentService:290049]Deploy failed for id '1,244,759,390,503' since no targets are reachable.
[03:29:50 PM] #### Deployment incomplete. ####
[03:29:50 PM] Remote deployment failed









22.11.3.6 Attempting to Deploy to a Server that No Longer Exists



When you have successfully deployed an application to a Managed Server, the deployment wizard saves this deployment action in its history so that you can perform the same action later. However, if the Managed Server is removed from your Oracle WebLogic Server domain and you subsequently deploy using the deployment history action, deployment fails with the following log message:


[02:38:40 PM] ---- Deployment started. ----
[02:38:40 PM] Target platform is (Weblogic 10.3).
[02:38:40 PM] Retrieving existing application information
[02:38:40 PM] #### Deployment incomplete. ####
[02:38:40 PM] [J2EE Deployment SPI:260013]Target array passed to DeploymentManager was null or empty.









22.11.3.7 Deploying to a remove server fails with HTTP Error Code 502



If you are deploying to a server running on a machine that is not known to the network DNS server, and you have set a proxy for JDeveloper, deployment will fail with a 502 HTTP error code. This is because the proxy does not know where to forward the request. This will also happen if you are deploying to a server on the localhost that is referred to by its machine name, which typically happens with SOA development.

To avoid this happening either add the machine to the Exceptions list in the proxy settings in the Web Browser and Proxy page of the Preferences dialog, or choose not to use a HTTP Proxy Server for any connections.









22.11.3.8 No Credential Mapper Entry Found



If you see the following message, it usually means that an EAR using password indirection did not have the passwords injected via mbeans before deployment.


weblogic.common.ResourceException: No credential mapper entry found for password indirection user=scott for data source Connection1


This usually happens when trying to deploy an EAR manually from the console or from an ant script.











22.11.4 How to Troubleshoot Deployment to IBM WebSphere



This section contains information about issues that may arise when deploying to both Integrated WebLogic Server and Oracle WebLogic Server.







22.11.4.1 Deployment Fails When EAR Contains Spaces



WebSphere deployment on Windows does not work when the directory containing the EAR generated by JDeveloper contains spaces.









22.11.4.2 Deployment Fails When the Path to the WebSphere Server Contains Spaces



WebSphere deployment on Windows does not work when the path to wsadmin.bat contains spaces. See Connecting to WebSphere Server.









22.11.4.3 Application Displays Administrative Console User Name



When you deploy your application to IBM WebSphere application servers and use the same machine to log into the WebSphere administrative console, your application may display the name of the user logged into the administrative console, instead of the name of the user who logs into the application.
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