# Contents

## Preface

- Audience ........................................... xxv
- Documentation Accessibility ..................... xxv
- Related Documentation ............................ xxv
- Conventions ........................................ xxv
- Accessing the Example Reports .................. xxvi
- Accessing the Data Sources ....................... xxvi

## 1 Basic Concepts

1.1 Oracle Reports Builder ........................................ 1-1
   1.1.1 About Oracle Reports Builder .......................... 1-1
   1.1.2 About this release ...................................... 1-2
1.2 Reports ...................................................... 1-2
   1.2.1 About Reports .......................................... 1-3
      1.2.1.1 Creating a new report using the Report Wizard .... 1-3
      1.2.1.2 Creating a new report manually .................. 1-3
   1.2.2 About Web Reports ................................. 1-4
1.3 Report Styles .............................................. 1-5
   1.3.1 About tabular reports ............................... 1-5
   1.3.2 About group above reports ....................... 1-5
   1.3.3 About group left reports ............................ 1-6
   1.3.4 About form-like reports ......................... 1-6
   1.3.5 About form letter reports ......................... 1-6
   1.3.6 About mailing label reports ...................... 1-6
   1.3.7 About matrix reports .............................. 1-6
      1.3.7.1 Matrix data model ................................ 1-7
      1.3.7.2 Matrix layout .................................... 1-11
1.4 Wizards ................................................. 1-12
   1.4.1 About the Report Wizard ......................... 1-13
   1.4.2 About the Report Block Wizard .................. 1-13
   1.4.3 About the Data Wizard .............................. 1-13
   1.4.4 About Graphs and the Graph Wizard .......... 1-14
1.5 The Object Navigator .................................... 1-14
   1.5.1 About the Object Navigator ...................... 1-14
   1.5.2 About Object Navigator views ................... 1-15
2 Advanced Concepts

2.1 Reports ................................................................. 2-1
2.1.1 About report titles ........................................... 2-1
2.1.2 About report sectioning and sections ............... 2-2
2.1.3 About the report unit of measurement .............. 2-3
2.1.4 About the report dimensions ......................... 2-3
2.1.5 About fonts in reports .................................... 2-4
2.1.6 About conditional formatting ......................... 2-4
2.1.7 About nested matrix reports ......................... 2-5
2.1.8 About matrix with group reports .................... 2-5
2.2 Web Reports ..................................................... 2-6
2.2.1 About JavaServer Pages (JSPs) and servlets .... 2-7
2.2.1.1 Using JSPs in Oracle Reports .................. 2-7
2.2.1.2 Opening or running an encoded JSP-based Web report .... 2-8
<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>2.2.1.3 Embedding a character set in a JSP file dynamically</td>
<td>2-8</td>
</tr>
<tr>
<td>2.2.2 About previewing JSP-based Web reports</td>
<td>2-9</td>
</tr>
<tr>
<td>2.2.3 About Web links for HTML output</td>
<td>2-10</td>
</tr>
<tr>
<td>2.2.4 About Web links for PDF output</td>
<td>2-11</td>
</tr>
<tr>
<td>2.2.5 About hyperlinks</td>
<td>2-12</td>
</tr>
<tr>
<td>2.2.6 About graph hyperlinks</td>
<td>2-12</td>
</tr>
<tr>
<td>2.2.7 About hyperlink destinations</td>
<td>2-12</td>
</tr>
<tr>
<td>2.2.8 About bookmarks</td>
<td>2-12</td>
</tr>
<tr>
<td>2.2.9 About application command line links</td>
<td>2-13</td>
</tr>
<tr>
<td>2.2.10 About before and after escapes</td>
<td>2-13</td>
</tr>
<tr>
<td>2.2.11 About style sheets</td>
<td>2-14</td>
</tr>
<tr>
<td>2.3 Data Model Objects</td>
<td>2-15</td>
</tr>
<tr>
<td>2.3.1 About summary columns</td>
<td>2-15</td>
</tr>
<tr>
<td>2.3.2 About formula columns</td>
<td>2-16</td>
</tr>
<tr>
<td>2.3.3 About placeholder columns</td>
<td>2-16</td>
</tr>
<tr>
<td>2.3.4 About referencing columns and parameters</td>
<td>2-16</td>
</tr>
<tr>
<td>2.3.4.1 About bind references</td>
<td>2-17</td>
</tr>
<tr>
<td>2.3.4.2 About lexical references</td>
<td>2-18</td>
</tr>
<tr>
<td>2.3.4.3 Differences between bind and lexical references</td>
<td>2-21</td>
</tr>
<tr>
<td>2.3.5 About non-linkable queries</td>
<td>2-21</td>
</tr>
<tr>
<td>2.3.6 About links versus groups</td>
<td>2-22</td>
</tr>
<tr>
<td>2.3.7 About matrix objects</td>
<td>2-23</td>
</tr>
<tr>
<td>2.4 Layout Objects</td>
<td>2-25</td>
</tr>
<tr>
<td>2.4.1 About layout objects</td>
<td>2-25</td>
</tr>
<tr>
<td>2.4.2 About layout defaulting</td>
<td>2-26</td>
</tr>
<tr>
<td>2.4.3 About images</td>
<td>2-27</td>
</tr>
<tr>
<td>2.4.4 About anchors</td>
<td>2-28</td>
</tr>
<tr>
<td>2.4.4.1 Implicit anchoring algorithm</td>
<td>2-31</td>
</tr>
<tr>
<td>2.4.5 About changing colors and patterns</td>
<td>2-33</td>
</tr>
<tr>
<td>2.4.6 About resizing objects</td>
<td>2-34</td>
</tr>
<tr>
<td>2.4.7 About moving and layering objects in the Paper Layout view</td>
<td>2-34</td>
</tr>
<tr>
<td>2.5 Parameter Form Objects</td>
<td>2-35</td>
</tr>
<tr>
<td>2.5.1 About Parameter Form HTML extensions</td>
<td>2-35</td>
</tr>
<tr>
<td>2.6 PL/SQL</td>
<td>2-36</td>
</tr>
<tr>
<td>2.6.1 About the PL/SQL Editor</td>
<td>2-36</td>
</tr>
<tr>
<td>2.6.2 About the Stored PL/SQL Editor</td>
<td>2-36</td>
</tr>
<tr>
<td>2.6.3 About the Syntax Palette</td>
<td>2-37</td>
</tr>
<tr>
<td>2.6.4 About program units</td>
<td>2-37</td>
</tr>
<tr>
<td>2.6.5 About stored program units</td>
<td>2-38</td>
</tr>
<tr>
<td>2.6.6 About external PL/SQL libraries</td>
<td>2-38</td>
</tr>
<tr>
<td>2.6.7 About attached libraries</td>
<td>2-39</td>
</tr>
<tr>
<td>2.6.8 About formulas</td>
<td>2-39</td>
</tr>
<tr>
<td>2.6.9 About group filters</td>
<td>2-40</td>
</tr>
<tr>
<td>2.6.10 About REF CURSOR queries</td>
<td>2-42</td>
</tr>
<tr>
<td>2.6.11 About DML and DDL</td>
<td>2-45</td>
</tr>
<tr>
<td>2.6.12 About built-in packages</td>
<td>2-45</td>
</tr>
<tr>
<td>2.6.12.1 About the Oracle Reports Builder built-in package (SRW)</td>
<td>2-45</td>
</tr>
<tr>
<td>Section</td>
<td>Page</td>
</tr>
<tr>
<td>------------------------------------------------------------------------</td>
<td>------</td>
</tr>
<tr>
<td>2.6.12.2 About the Tools built-in packages</td>
<td>2-46</td>
</tr>
<tr>
<td>2.6.13 About triggers</td>
<td>2-47</td>
</tr>
<tr>
<td>2.6.13.1 About report triggers</td>
<td>2-48</td>
</tr>
<tr>
<td>2.6.13.2 About format triggers</td>
<td>2-50</td>
</tr>
<tr>
<td>2.6.13.3 About validation triggers</td>
<td>2-51</td>
</tr>
<tr>
<td>2.6.13.4 About database triggers</td>
<td>2-51</td>
</tr>
<tr>
<td>2.7 Templates</td>
<td>2-52</td>
</tr>
<tr>
<td>2.7.1 About templates</td>
<td>2-52</td>
</tr>
<tr>
<td>2.7.2 About template attributes</td>
<td>2-53</td>
</tr>
<tr>
<td>2.7.3 About applying templates</td>
<td>2-54</td>
</tr>
<tr>
<td>2.7.4 About inheritance in templates</td>
<td>2-55</td>
</tr>
<tr>
<td>2.7.5 About the Template Editor</td>
<td>2-55</td>
</tr>
<tr>
<td>2.8 Output Formats and Capabilities</td>
<td>2-56</td>
</tr>
<tr>
<td>2.8.1 About format order</td>
<td>2-57</td>
</tr>
<tr>
<td>2.8.2 About batch reporting</td>
<td>2-58</td>
</tr>
<tr>
<td>2.8.3 About report distribution</td>
<td>2-58</td>
</tr>
<tr>
<td>2.8.3.1 About the DST file</td>
<td>2-59</td>
</tr>
<tr>
<td>2.8.4 About pluggable destinations</td>
<td>2-60</td>
</tr>
<tr>
<td>2.8.5 About event-driven publishing</td>
<td>2-61</td>
</tr>
<tr>
<td>2.8.6 About switching the printer tray</td>
<td>2-61</td>
</tr>
<tr>
<td>2.8.7 About XML in reports</td>
<td>2-61</td>
</tr>
<tr>
<td>2.8.8 About HTML and HTMLCSS output</td>
<td>2-62</td>
</tr>
<tr>
<td>2.8.8.1 About HTML page streaming</td>
<td>2-64</td>
</tr>
<tr>
<td>2.8.9 About HTML formatting</td>
<td>2-65</td>
</tr>
<tr>
<td>2.8.10 About PDF output</td>
<td>2-70</td>
</tr>
<tr>
<td>2.8.11 About RTF output</td>
<td>2-71</td>
</tr>
<tr>
<td>2.8.12 About delimited output</td>
<td>2-72</td>
</tr>
<tr>
<td>2.8.13 About Enhanced Spreadsheet output</td>
<td>2-75</td>
</tr>
<tr>
<td>2.8.14 About text output</td>
<td>2-79</td>
</tr>
<tr>
<td>2.8.15 About creating an ASCII (character-mode) report</td>
<td>2-79</td>
</tr>
<tr>
<td>2.9 Data Sources</td>
<td>2-80</td>
</tr>
<tr>
<td>2.9.1 About database roles</td>
<td>2-80</td>
</tr>
<tr>
<td>2.9.2 About Oracle Net Services</td>
<td>2-81</td>
</tr>
<tr>
<td>2.9.3 About user exits</td>
<td>2-81</td>
</tr>
<tr>
<td>2.9.4 About the Oracle Call Interface (OCI)</td>
<td>2-81</td>
</tr>
<tr>
<td>2.10 Debugging Tools</td>
<td>2-82</td>
</tr>
<tr>
<td>2.10.1 About the debugging process</td>
<td>2-82</td>
</tr>
<tr>
<td>2.10.2 About the PL/SQL Interpreter</td>
<td>2-82</td>
</tr>
<tr>
<td>2.10.3 About the Source pane</td>
<td>2-83</td>
</tr>
<tr>
<td>2.10.4 About debug commands in the PL/SQL Interpreter</td>
<td>2-83</td>
</tr>
<tr>
<td>2.10.5 About debug actions</td>
<td>2-84</td>
</tr>
<tr>
<td>2.10.5.1 About creating a debug action</td>
<td>2-84</td>
</tr>
<tr>
<td>2.10.6 About the current execution location</td>
<td>2-85</td>
</tr>
<tr>
<td>2.10.7 About the current scope location</td>
<td>2-85</td>
</tr>
<tr>
<td>2.10.8 About debug levels</td>
<td>2-86</td>
</tr>
<tr>
<td>2.10.9 About modifying code at runtime</td>
<td>2-86</td>
</tr>
</tbody>
</table>
### 3 Visual Index

#### 3.1 Part 1: Building Basic Reports

- 3.1.1 Building a tabular report ................................................................. 3-1
- 3.1.2 Building a mailing label report ......................................................... 3-1
- 3.1.3 Building a form letter report .......................................................... 3-2
- 3.1.4 Building a master/master report .................................................... 3-2
- 3.1.5 Building a summary report ............................................................. 3-3

#### 3.2 Part 2: Building Group Reports

- 3.2.1 Building a single-query group report ............................................. 3-3
- 3.2.2 Building a two-query group report .................................................. 3-4
- 3.2.3 Building an across group report ..................................................... 3-5
- 3.2.4 Building a group left summary report ............................................. 3-5
- 3.2.5 Building a group left formula report .............................................. 3-6

#### 3.3 Part 3: Building Reports with Special Formatting

- 3.3.1 Building a wrapped field report ..................................................... 3-6
- 3.3.2 Building a header and footer report .............................................. 3-7
- 3.3.3 Building a header with database values report ............................. 3-7
- 3.3.4 Building a report with graphics, text, and color ............................ 3-8
- 3.3.5 Building a report that renumbers pages by repeating frame .......... 3-9
- 3.3.6 Building an intermixed fields report .............................................. 3-9
- 3.3.7 Building a report that suppresses labels ....................................... 3-10
- 3.3.8 Building a conditional form letter report ...................................... 3-10
- 3.3.9 Building a report with conditional highlighting ............................ 3-12
- 3.3.10 Building a report with dynamic graphics ..................................... 3-13

#### 3.4 Part 4: Building Matrix Reports

- 3.4.1 Building a matrix report ............................................................... 3-13
- 3.4.2 Building a nested matrix report .................................................... 3-14
- 3.4.3 Building a matrix with group above report .................................... 3-14

#### 3.5 Part 5: Building Reports for Business Cases

- 3.5.1 Building a time series calculations report .................................... 3-15
- 3.5.2 Deploying a paper report to Microsoft Excel output ..................... 3-16
- 3.5.3 Building a report with aggregate data ......................................... 3-16
- 3.5.4 Building a check printing report with spelled-out cash amounts .... 3-17
- 3.5.5 Building a report using a preprinted form ................................... 3-18
- 3.5.6 Building an invoice report ............................................................ 3-18
- 3.5.7 Building a ranking report .............................................................. 3-19
- 3.5.8 Building a report with a simple table of contents and index ........... 3-20
- 3.5.9 Building a report with a multilevel table of contents .................... 3-21
- 3.5.10 Bursting and distributing a report ............................................... 3-22
- 3.5.11 Building a report with multibyte characters for PDF output .......... 3-22

#### 3.6 Part 6: Building Reports with PL/SQL and Java

- 3.6.1 Building a PL/SQL report .............................................................. 3-23
- 3.6.2 Building a paper report with REF CURSORs ............................... 3-24
- 3.6.3 Building a simple Parameter Form for a JSP-based Web report .... 3-24
- 3.6.4 Building a report with a barcode .................................................. 3-25
- 3.6.5 Building an accessible JSP-based Web report .............................. 3-26

#### 3.7 Part 7: Building Reports with Pluggable Data Sources

- 3.7.1 Building a report with a multilevel table of contents .................... 3-27
4 How To...

4.1 Access Oracle Reports Documentation ................................................................. 4-1
4.1.1 Using the Oracle Reports online Help ............................................................... 4-2
4.1.2 Locating other documentation ............................................................................ 4-2
4.2 Set Properties and Preferences .............................................................................. 4-3
4.2.1 Displaying the Property Inspector .................................................................. 4-4
4.2.2 Setting report properties .................................................................................. 4-4
4.2.3 Setting report preferences .............................................................................. 4-4
4.2.3.1 Using the Auto Save Feature ................................................................... 4-4
4.2.4 Setting preferences for the Object Navigator ............................................... 4-5
4.2.5 Setting properties for an ASCII (character-mode) report ............................ 4-5
4.2.6 Setting color palette preferences ...................................................................... 4-6
4.2.7 Setting properties of multiple objects ............................................................. 4-6
4.2.8 Comparing the properties of one object to another ........................................ 4-7
4.3 Perform Common Tasks ...................................................................................... 4-7
4.3.1 Connecting to a database ................................................................................ 4-8
4.3.2 Opening a report ............................................................................................. 4-8
4.3.3 Saving a report ............................................................................................... 4-8
4.3.4 Copying a report ............................................................................................. 4-8
4.3.5 Renaming a report ......................................................................................... 4-8
4.3.6 Deleting a report ............................................................................................. 4-9
4.3.7 Selecting and deselecting objects ................................................................... 4-9
4.3.7.1 Selecting single objects .............................................................................. 4-9
4.3.7.2 Selecting multiple objects .......................................................................... 4-9
4.3.7.3 Selecting objects owned by a frame ............................................................ 4-10
4.3.7.4 Selecting grouped objects ......................................................................... 4-10
4.3.7.5 Selecting all objects in a report region ....................................................... 4-10
4.3.7.6 Selecting overlapped objects ...................................................................... 4-10
4.3.7.7 Deselecting single objects ......................................................................... 4-10
4.3.7.8 Deselecting multiple objects ...................................................................... 4-10
4.3.8 Deleting an object ............................................................................................ 4-11
4.4 Work with the Object Navigator .......................................................................... 4-11
4.4.1 Displaying a Report Editor view from the Object Navigator ....................... 4-11
4.4.2 Expanding and collapsing nodes .................................................................... 4-11
4.4.3 Searching for nodes ....................................................................................... 4-12
4.4.4 Changing Object Navigator views .................................................................. 4-12
4.4.5 Setting preferences for the Object Navigator ................................................. 4-12
4.5 Work with Reports ............................................................................................... 4-12
4.5.1 Creating a report ............................................................................................. 4-13
4.5.2 Creating a multiquery group above report ..................................................... 4-13
4.5.3 Creating a nested matrix report ...................................................................... 4-13
4.5.4 Creating a default layout for a report ............................................................. 4-13
4.5.5 Creating an additional report layout .............................................................. 4-14
<table>
<thead>
<tr>
<th>Section</th>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>4.5.6</td>
<td>Adding a title to a report</td>
<td>4-14</td>
</tr>
<tr>
<td>4.5.7</td>
<td>Adding a table of contents to a report</td>
<td>4-15</td>
</tr>
<tr>
<td>4.5.8</td>
<td>Adding index to a report</td>
<td>4-15</td>
</tr>
<tr>
<td>4.5.9</td>
<td>Creating an ASCII (character-mode) report</td>
<td>4-15</td>
</tr>
<tr>
<td>4.5.10</td>
<td>Preparing a multiplatform report</td>
<td>4-16</td>
</tr>
<tr>
<td>4.5.11</td>
<td>Preparing a report for translation into other languages</td>
<td>4-16</td>
</tr>
<tr>
<td>4.6</td>
<td>Work with Web Reports</td>
<td>4-16</td>
</tr>
<tr>
<td>4.6.1</td>
<td>Creating a Web report</td>
<td>4-16</td>
</tr>
<tr>
<td>4.6.2</td>
<td>Viewing the source code for a Web report</td>
<td>4-17</td>
</tr>
<tr>
<td>4.6.3</td>
<td>Adding report data to an existing Web page (HTML file)</td>
<td>4-17</td>
</tr>
<tr>
<td>4.6.4</td>
<td>Adding a report block to a Web page</td>
<td>4-18</td>
</tr>
<tr>
<td>4.6.5</td>
<td>Adding an image</td>
<td>4-18</td>
</tr>
<tr>
<td>4.6.6</td>
<td>Adding a graph</td>
<td>4-18</td>
</tr>
<tr>
<td>4.6.7</td>
<td>Editing a graph</td>
<td>4-18</td>
</tr>
<tr>
<td>4.6.8</td>
<td>Adding a graph hyperlink</td>
<td>4-18</td>
</tr>
<tr>
<td>4.6.9</td>
<td>Preparing a paper-based report for the Web</td>
<td>4-18</td>
</tr>
<tr>
<td>4.6.10</td>
<td>Adding Web links to paper-based reports</td>
<td>4-19</td>
</tr>
<tr>
<td>4.6.10.1</td>
<td>Using the user interface</td>
<td>4-19</td>
</tr>
<tr>
<td>4.6.10.2</td>
<td>Using PL/SQL</td>
<td>4-25</td>
</tr>
<tr>
<td>4.7</td>
<td>Run and Dispatch a Report</td>
<td>4-30</td>
</tr>
<tr>
<td>4.7.1</td>
<td>Running and dispatching a report from the user interface</td>
<td>4-31</td>
</tr>
<tr>
<td>4.7.2</td>
<td>Running a report from the command line</td>
<td>4-32</td>
</tr>
<tr>
<td>4.7.3</td>
<td>Running a report using a command file</td>
<td>4-32</td>
</tr>
<tr>
<td>4.7.4</td>
<td>Running a report to a remote Reports Server</td>
<td>4-32</td>
</tr>
<tr>
<td>4.7.5</td>
<td>Generating HTML or HTMLCSS output</td>
<td>4-33</td>
</tr>
<tr>
<td>4.7.6</td>
<td>Generating PDF output</td>
<td>4-33</td>
</tr>
<tr>
<td>4.7.7</td>
<td>Generating XML output</td>
<td>4-34</td>
</tr>
<tr>
<td>4.7.8</td>
<td>Generating RTF output</td>
<td>4-36</td>
</tr>
<tr>
<td>4.7.9</td>
<td>Generating text output</td>
<td>4-36</td>
</tr>
<tr>
<td>4.7.10</td>
<td>Generating delimited output</td>
<td>4-36</td>
</tr>
<tr>
<td>4.7.11</td>
<td>Generating Enhanced spreadsheet output</td>
<td>4-38</td>
</tr>
<tr>
<td>4.7.12</td>
<td>Distributing a report to multiple destinations</td>
<td>4-38</td>
</tr>
<tr>
<td>4.7.13</td>
<td>Deploying a report</td>
<td>4-39</td>
</tr>
<tr>
<td>4.7.14</td>
<td>Changing orientation</td>
<td>4-39</td>
</tr>
<tr>
<td>4.7.15</td>
<td>Suppressing the Parameter Form</td>
<td>4-41</td>
</tr>
<tr>
<td>4.7.16</td>
<td>Viewing report output</td>
<td>4-41</td>
</tr>
<tr>
<td>4.7.16.1</td>
<td>Viewing the printable area</td>
<td>4-42</td>
</tr>
<tr>
<td>4.7.16.2</td>
<td>Displaying report output in the Paper Design view</td>
<td>4-42</td>
</tr>
<tr>
<td>4.7.16.3</td>
<td>Displaying report output in the Previewer</td>
<td>4-42</td>
</tr>
<tr>
<td>4.7.16.4</td>
<td>Displaying report output in your Web browser</td>
<td>4-43</td>
</tr>
<tr>
<td>4.7.16.5</td>
<td>Displaying individual pages of HTML report output</td>
<td>4-43</td>
</tr>
<tr>
<td>4.7.16.6</td>
<td>Scrolling and paging</td>
<td>4-44</td>
</tr>
<tr>
<td>4.7.16.7</td>
<td>Splitting the viewing region</td>
<td>4-44</td>
</tr>
<tr>
<td>4.7.16.8</td>
<td>Magnifying or reducing the output</td>
<td>4-44</td>
</tr>
<tr>
<td>4.7.17</td>
<td>Printing a Report</td>
<td>4-45</td>
</tr>
<tr>
<td>4.7.17.1</td>
<td>Printing a report from the Paper Design or Paper Layout view</td>
<td>4-45</td>
</tr>
<tr>
<td>4.7.17.2</td>
<td>Printing a report from the Previewer</td>
<td>4-45</td>
</tr>
<tr>
<td>Section</td>
<td>Description</td>
<td>Page</td>
</tr>
<tr>
<td>---------</td>
<td>-----------------------------------------------------------------------------</td>
<td>------</td>
</tr>
<tr>
<td>4.7.17.3</td>
<td>Printing a report from your Web browser</td>
<td>4-46</td>
</tr>
<tr>
<td>4.7.17.4</td>
<td>Printing a report on a preprinted form</td>
<td>4-46</td>
</tr>
<tr>
<td>4.7.17.5</td>
<td>Switching the printer tray</td>
<td>4-46</td>
</tr>
<tr>
<td>4.7.17.6</td>
<td>Printing a report on UNIX</td>
<td>4-47</td>
</tr>
<tr>
<td>4.7.18</td>
<td>E-mailing a report</td>
<td>4-48</td>
</tr>
<tr>
<td>4.8</td>
<td>Work with the Data Model</td>
<td>4-48</td>
</tr>
<tr>
<td>4.8.1</td>
<td>Creating a query</td>
<td>4-49</td>
</tr>
<tr>
<td>4.8.1.1</td>
<td>Creating a query: Report Wizard</td>
<td>4-49</td>
</tr>
<tr>
<td>4.8.1.2</td>
<td>Creating a query: Data Wizard</td>
<td>4-49</td>
</tr>
<tr>
<td>4.8.1.3</td>
<td>Creating a query: SQL Query tool</td>
<td>4-50</td>
</tr>
<tr>
<td>4.8.1.4</td>
<td>Creating a query: XML Query tool</td>
<td>4-50</td>
</tr>
<tr>
<td>4.8.1.5</td>
<td>Creating a query: JDBC Query tool</td>
<td>4-50</td>
</tr>
<tr>
<td>4.8.1.6</td>
<td>Creating a query: Text Query tool</td>
<td>4-51</td>
</tr>
<tr>
<td>4.8.1.7</td>
<td>Creating a query: REF CURSOR Query tool</td>
<td>4-51</td>
</tr>
<tr>
<td>4.8.2</td>
<td>Modifying a query</td>
<td>4-52</td>
</tr>
<tr>
<td>4.8.3</td>
<td>Using Query Builder</td>
<td>4-52</td>
</tr>
<tr>
<td>4.8.4</td>
<td>Selecting HTML tags from the database</td>
<td>4-52</td>
</tr>
<tr>
<td>4.8.5</td>
<td>Selecting an image from the database</td>
<td>4-53</td>
</tr>
<tr>
<td>4.8.6</td>
<td>Selecting an image URL from the database</td>
<td>4-54</td>
</tr>
<tr>
<td>4.8.7</td>
<td>Creating a break group</td>
<td>4-55</td>
</tr>
<tr>
<td>4.8.8</td>
<td>Creating a matrix (cross-product) group</td>
<td>4-55</td>
</tr>
<tr>
<td>4.8.9</td>
<td>Creating a data link</td>
<td>4-56</td>
</tr>
<tr>
<td>4.8.10</td>
<td>Creating or editing a formula column</td>
<td>4-56</td>
</tr>
<tr>
<td>4.8.11</td>
<td>Creating a summary column</td>
<td>4-57</td>
</tr>
<tr>
<td>4.8.12</td>
<td>Creating or editing a placeholder column</td>
<td>4-58</td>
</tr>
<tr>
<td>4.9</td>
<td>Work with the Report Layout</td>
<td>4-59</td>
</tr>
<tr>
<td>4.9.1</td>
<td>General Layout Objects</td>
<td>4-59</td>
</tr>
<tr>
<td>4.9.1.1</td>
<td>Creating a field object</td>
<td>4-59</td>
</tr>
<tr>
<td>4.9.1.2</td>
<td>Creating a frame or repeating frame</td>
<td>4-60</td>
</tr>
<tr>
<td>4.9.1.3</td>
<td>Creating a matrix object</td>
<td>4-60</td>
</tr>
<tr>
<td>4.9.1.4</td>
<td>Creating a barcode using a barcode font</td>
<td>4-61</td>
</tr>
<tr>
<td>4.9.1.5</td>
<td>Applying conditional formatting to a layout object</td>
<td>4-62</td>
</tr>
<tr>
<td>4.9.2</td>
<td>Text Objects</td>
<td>4-62</td>
</tr>
<tr>
<td>4.9.2.1</td>
<td>Creating a boilerplate object for text</td>
<td>4-62</td>
</tr>
<tr>
<td>4.9.2.2</td>
<td>Creating a boilerplate object for text that displays every other page</td>
<td>4-63</td>
</tr>
<tr>
<td>4.9.2.3</td>
<td>Creating a boilerplate text object for HTML tags</td>
<td>4-63</td>
</tr>
<tr>
<td>4.9.2.4</td>
<td>Editing text</td>
<td>4-65</td>
</tr>
<tr>
<td>4.9.2.5</td>
<td>Referencing a field in boilerplate text</td>
<td>4-65</td>
</tr>
<tr>
<td>4.9.2.6</td>
<td>Linking a boilerplate text object to a file</td>
<td>4-65</td>
</tr>
<tr>
<td>4.9.2.7</td>
<td>Linking an HTML text object to a file</td>
<td>4-66</td>
</tr>
<tr>
<td>4.9.2.8</td>
<td>Wrapping text in a field</td>
<td>4-66</td>
</tr>
<tr>
<td>4.9.2.9</td>
<td>Changing text attributes</td>
<td>4-67</td>
</tr>
<tr>
<td>4.9.2.10</td>
<td>Changing text attributes using PL/SQL</td>
<td>4-67</td>
</tr>
<tr>
<td>4.9.3</td>
<td>Page Numbers or Date/Time Stamps</td>
<td>4-68</td>
</tr>
<tr>
<td>4.9.3.1</td>
<td>Creating page numbers</td>
<td>4-68</td>
</tr>
<tr>
<td>4.9.3.2</td>
<td>Resetting page numbers</td>
<td>4-69</td>
</tr>
<tr>
<td>4.9.3.3</td>
<td>Creating a time or date stamp</td>
<td>4-69</td>
</tr>
<tr>
<td>Page</td>
<td>Title</td>
<td>Section</td>
</tr>
<tr>
<td>------</td>
<td>----------------------------------------------------------------------</td>
<td>--------------------------------</td>
</tr>
<tr>
<td>4.9.12</td>
<td>Resize Objects</td>
<td>4-95</td>
</tr>
<tr>
<td>4.9.12.1</td>
<td>Resizing objects</td>
<td>4-95</td>
</tr>
<tr>
<td>4.9.12.2</td>
<td>Making multiple objects the same size</td>
<td>4-96</td>
</tr>
<tr>
<td>4.9.12.3</td>
<td>Resizing object borders</td>
<td>4-96</td>
</tr>
<tr>
<td>4.9.13</td>
<td>Change Spacing</td>
<td>4-96</td>
</tr>
<tr>
<td>4.9.13.1</td>
<td>Changing columns labels or widths</td>
<td>4-96</td>
</tr>
<tr>
<td>4.9.13.2</td>
<td>Changing spacing within a text object</td>
<td>4-97</td>
</tr>
<tr>
<td>4.9.13.3</td>
<td>Changing the default layout spacing</td>
<td>4-97</td>
</tr>
<tr>
<td>4.9.13.4</td>
<td>Changing the spacing between all rows</td>
<td>4-97</td>
</tr>
<tr>
<td>4.9.13.5</td>
<td>Adding blank lines between groups of rows</td>
<td>4-98</td>
</tr>
<tr>
<td>4.9.14</td>
<td>Modify the Page Layout</td>
<td>4-98</td>
</tr>
<tr>
<td>4.9.14.1</td>
<td>Adjusting margins</td>
<td>4-99</td>
</tr>
<tr>
<td>4.9.14.2</td>
<td>Adding a page break</td>
<td>4-99</td>
</tr>
<tr>
<td>4.10</td>
<td>Work with Report Sections</td>
<td>4-99</td>
</tr>
<tr>
<td>4.10.1</td>
<td>Displaying a section layout view</td>
<td>4-100</td>
</tr>
<tr>
<td>4.10.2</td>
<td>Creating a default layout for a section</td>
<td>4-100</td>
</tr>
<tr>
<td>4.11</td>
<td>Work with Parameters and the Parameter Form</td>
<td>4-100</td>
</tr>
<tr>
<td>4.11.1</td>
<td>Using a pre-defined system parameter</td>
<td>4-101</td>
</tr>
<tr>
<td>4.11.2</td>
<td>Creating a user parameter</td>
<td>4-101</td>
</tr>
<tr>
<td>4.11.3</td>
<td>Creating a list of values (LOV) for a parameter</td>
<td>4-102</td>
</tr>
<tr>
<td>4.11.4</td>
<td>Validating a parameter value at runtime</td>
<td>4-102</td>
</tr>
<tr>
<td>4.11.5</td>
<td>Creating a default Parameter Form</td>
<td>4-103</td>
</tr>
<tr>
<td>4.11.6</td>
<td>Selecting parameters to include in the Runtime Parameter Form</td>
<td>4-103</td>
</tr>
<tr>
<td>4.11.7</td>
<td>Displaying the Parameter Form at runtime</td>
<td>4-103</td>
</tr>
<tr>
<td>4.11.8</td>
<td>Adding more pages to the Runtime Parameter Form</td>
<td>4-103</td>
</tr>
<tr>
<td>4.11.9</td>
<td>Passing parameters to reports running in batch mode</td>
<td>4-104</td>
</tr>
<tr>
<td>4.11.10</td>
<td>Creating an HTML Parameter Form header using PL/SQL</td>
<td>4-104</td>
</tr>
<tr>
<td>4.11.11</td>
<td>Creating an HTML Parameter Form footer using PL/SQL</td>
<td>4-104</td>
</tr>
<tr>
<td>4.11.12</td>
<td>Creating HTML Parameter Form input or select events</td>
<td>4-104</td>
</tr>
<tr>
<td>4.11.13</td>
<td>Changing HTML Parameter Form input to uppercase</td>
<td>4-106</td>
</tr>
<tr>
<td>4.12</td>
<td>Define a Template</td>
<td>4-107</td>
</tr>
<tr>
<td>4.12.1</td>
<td>Creating a template</td>
<td>4-107</td>
</tr>
<tr>
<td>4.12.2</td>
<td>Defining default template attributes</td>
<td>4-107</td>
</tr>
<tr>
<td>4.12.3</td>
<td>Defining override template attributes</td>
<td>4-108</td>
</tr>
<tr>
<td>4.12.4</td>
<td>Applying a template to a report</td>
<td>4-109</td>
</tr>
<tr>
<td>4.12.5</td>
<td>Formatting the report title in a template</td>
<td>4-109</td>
</tr>
<tr>
<td>4.12.6</td>
<td>Adding items and objects to a template</td>
<td>4-110</td>
</tr>
<tr>
<td>4.12.7</td>
<td>Modifying objects in the template margin</td>
<td>4-110</td>
</tr>
<tr>
<td>4.12.8</td>
<td>Modifying the color, pattern, or border of body objects in a template</td>
<td>4-110</td>
</tr>
<tr>
<td>4.12.9</td>
<td>Adding a template to the pre-defined templates list</td>
<td>4-111</td>
</tr>
<tr>
<td>4.12.10</td>
<td>Creating an HTML template for a report portlet</td>
<td>4-112</td>
</tr>
<tr>
<td>4.13</td>
<td>Use PL/SQL in a Report or Template</td>
<td>4-112</td>
</tr>
<tr>
<td>4.13.1</td>
<td>Using a built-in package</td>
<td>4-112</td>
</tr>
<tr>
<td>4.13.2</td>
<td>Working with the PL/SQL Editor</td>
<td>4-112</td>
</tr>
<tr>
<td>4.13.2.1</td>
<td>Defining PL/SQL</td>
<td>4-113</td>
</tr>
<tr>
<td>4.13.2.2</td>
<td>Searching and replacing text in a program unit</td>
<td>4-113</td>
</tr>
<tr>
<td>4.13.2.3</td>
<td>Editing a program unit</td>
<td>4-114</td>
</tr>
<tr>
<td>Section</td>
<td>Title</td>
<td>Page</td>
</tr>
<tr>
<td>---------</td>
<td>----------------------------------------------------------------------</td>
<td>------</td>
</tr>
<tr>
<td>4.13.2.4</td>
<td>Inserting syntax into the PL/SQL Editor</td>
<td>4-117</td>
</tr>
<tr>
<td>4.13.3</td>
<td>Creating or editing report-level or template-level PL/SQL</td>
<td>4-118</td>
</tr>
<tr>
<td>4.13.3.1</td>
<td>Creating a local program unit</td>
<td>4-118</td>
</tr>
<tr>
<td>4.13.3.2</td>
<td>Creating a stored program unit</td>
<td>4-119</td>
</tr>
<tr>
<td>4.13.3.3</td>
<td>Deleting a program unit</td>
<td>4-120</td>
</tr>
<tr>
<td>4.13.3.4</td>
<td>Moving a program unit between client and database server</td>
<td>4-120</td>
</tr>
<tr>
<td>4.13.3.5</td>
<td>Creating a report trigger</td>
<td>4-120</td>
</tr>
<tr>
<td>4.13.3.6</td>
<td>Deleting a report trigger</td>
<td>4-121</td>
</tr>
<tr>
<td>4.13.3.7</td>
<td>Creating a database trigger</td>
<td>4-121</td>
</tr>
<tr>
<td>4.13.4</td>
<td>Creating or editing object-level PL/SQL</td>
<td>4-121</td>
</tr>
<tr>
<td>4.13.4.1</td>
<td>Creating or editing a format trigger</td>
<td>4-122</td>
</tr>
<tr>
<td>4.13.4.2</td>
<td>Creating or editing a group filter</td>
<td>4-122</td>
</tr>
<tr>
<td>4.13.4.3</td>
<td>Creating or editing a formula column</td>
<td>4-122</td>
</tr>
<tr>
<td>4.13.4.4</td>
<td>Creating a placeholder column</td>
<td>4-122</td>
</tr>
<tr>
<td>4.13.4.5</td>
<td>Changing colors and patterns using PL/SQL</td>
<td>4-122</td>
</tr>
<tr>
<td>4.13.5</td>
<td>Creating or editing an external PL/SQL library</td>
<td>4-123</td>
</tr>
<tr>
<td>4.13.5.1</td>
<td>Creating an external PL/SQL library</td>
<td>4-123</td>
</tr>
<tr>
<td>4.13.5.2</td>
<td>Adding a program unit to an open library</td>
<td>4-123</td>
</tr>
<tr>
<td>4.13.5.3</td>
<td>Editing a program unit in a PL/SQL library</td>
<td>4-123</td>
</tr>
<tr>
<td>4.13.5.4</td>
<td>Removing a program unit from a PL/SQL library</td>
<td>4-123</td>
</tr>
<tr>
<td>4.13.5.5</td>
<td>Attaching a PL/SQL library</td>
<td>4-124</td>
</tr>
<tr>
<td>4.13.5.6</td>
<td>Converting external PL/SQL libraries</td>
<td>4-124</td>
</tr>
<tr>
<td>4.13.6</td>
<td>Compiling and running program units</td>
<td>4-124</td>
</tr>
<tr>
<td>4.13.6.1</td>
<td>Compiling a single program unit</td>
<td>4-124</td>
</tr>
<tr>
<td>4.13.6.2</td>
<td>Compiling all program units</td>
<td>4-125</td>
</tr>
<tr>
<td>4.13.6.3</td>
<td>Compiling all uncompiled program units</td>
<td>4-125</td>
</tr>
<tr>
<td>4.14</td>
<td>Debug a Report</td>
<td>4-126</td>
</tr>
<tr>
<td>4.14.1</td>
<td>Debugging a report</td>
<td>4-126</td>
</tr>
<tr>
<td>4.14.2</td>
<td>Running a report in debug mode</td>
<td>4-127</td>
</tr>
<tr>
<td>4.14.3</td>
<td>Setting a breakpoint</td>
<td>4-127</td>
</tr>
<tr>
<td>4.14.4</td>
<td>Setting a debug trigger</td>
<td>4-128</td>
</tr>
<tr>
<td>4.14.5</td>
<td>Browsing debug actions</td>
<td>4-129</td>
</tr>
<tr>
<td>4.14.6</td>
<td>Editing a debug action</td>
<td>4-129</td>
</tr>
<tr>
<td>4.14.7</td>
<td>Disabling and enabling debug actions</td>
<td>4-129</td>
</tr>
<tr>
<td>4.14.8</td>
<td>Deleting a debug action</td>
<td>4-129</td>
</tr>
<tr>
<td>4.14.9</td>
<td>Running a program unit in the PL/SQL Interpreter</td>
<td>4-130</td>
</tr>
<tr>
<td>4.14.10</td>
<td>Inserting a Navigator pane in the PL/SQL Interpreter</td>
<td>4-130</td>
</tr>
<tr>
<td>4.14.11</td>
<td>Controlling program unit execution</td>
<td>4-130</td>
</tr>
<tr>
<td>4.14.12</td>
<td>Stepping through the code</td>
<td>4-131</td>
</tr>
<tr>
<td>4.14.13</td>
<td>Modifying code at runtime</td>
<td>4-132</td>
</tr>
<tr>
<td>4.14.14</td>
<td>Displaying the current scope location</td>
<td>4-132</td>
</tr>
<tr>
<td>4.14.15</td>
<td>Examining or changing local variables</td>
<td>4-132</td>
</tr>
<tr>
<td>4.14.16</td>
<td>Modifying application variables</td>
<td>4-133</td>
</tr>
<tr>
<td>4.14.17</td>
<td>Viewing subprogram references</td>
<td>4-133</td>
</tr>
<tr>
<td>4.14.18</td>
<td>Tracing report execution</td>
<td>4-133</td>
</tr>
<tr>
<td>4.14.19</td>
<td>Tracing report distribution</td>
<td>4-133</td>
</tr>
<tr>
<td>4.14.20</td>
<td>Tracing using the SQL TRACE function</td>
<td>4-134</td>
</tr>
</tbody>
</table>
null
Part II  Building Group Reports

10  Building a Single-Query Group Report

10.1 Prerequisites for This Example ................................................................. 10-2
10.2 Group Report with One Break Column .................................................... 10-2
10.2.1 Create a data model with a break group and group left layout ............ 10-3
10.2.2 Format a field ......................................................................................... 10-5
10.2.3 Use the Property Inspector to add white space ................................... 10-6
10.3 Group Report with Two Break Columns .................................................... 10-8
10.3.1 Modify the data model ........................................................................... 10-8
10.3.2 Redefault the layout ............................................................................ 10-9
10.4 Group Report with Two Break Groups ...................................................... 10-10
10.4.1 Modify the data model ........................................................................... 10-10
10.4.2 Redefault the layout ............................................................................ 10-11
10.5 Summary .................................................................................................... 10-11

11  Building a Two-Query Group Report

11.1 Prerequisites for This Example ................................................................. 11-3
11.2 Create a New Report Manually ............................................................... 11-3
11.3 Create a Data Model with a Data Link ..................................................... 11-3
11.4 Use the Report Wizard to Layout the Data .............................................. 11-5
11.5 Format a Field .......................................................................................... 11-7
11.6 Summary .................................................................................................... 11-8

12  Building an Across Group Report

12.1 Prerequisites for This Example ................................................................. 12-2
12.2 Create Two Queries .................................................................................. 12-2
12.3 Create the Default Layout ....................................................................... 12-3
12.4 Run Your Report to Paper ........................................................................ 12-4
12.5 Summary .................................................................................................... 12-5

13  Building a Group Left Summary Report

13.1 Prerequisites for This Example ................................................................. 13-2
13.2 Create a New Report Manually ............................................................... 13-2
13.3 Create a Data Model with a Data Link ..................................................... 13-3
13.4 Use the Paper Layout View to Create Two Layouts .................................. 13-5
13.5 Merge the Two Layouts .......................................................................... 13-8
13.6 Format Fields ............................................................................................ 13-10
13.7 Summary .................................................................................................... 13-11

14  Building a Group Left Formula Report

14.1 Prerequisites for This Example ................................................................. 14-2
14.2 Use the Report Wizard to Create a Simple Report ................................... 14-2
14.3 Create Two Formula Columns .................................................................. 14-3
14.3.1 Create a formula column to calculate the tax ...................................... 14-4
14.3.2 Create a formula column that calculates customer order totals ................................ 14-5
14.3.3 Add the formula columns to the report layout ......................................................... 14-5
14.4 Summary .................................................................................................................... 14-6

Part III Building Reports with Special Formatting

15 Building a Wrapped Field Report
15.1 Prerequisites for This Example .................................................................................. 15-2
15.2 Create a Query in the Data Model View ...................................................................... 15-2
15.3 Create Three Summary Columns .............................................................................. 15-4
15.4 Create the Default Layout Using the Report Wizard ................................................ 15-4
15.5 Modify the Layout of the Report .............................................................................. 15-5
15.6 Run your Report to Paper ...................................................................................... 15-6
15.7 Summary ................................................................................................................. 15-6

16 Building a Header and Footer Report
16.1 Prerequisites for This Example ................................................................................ 16-2
16.2 Create a Data Model and a Group Left Layout ......................................................... 16-2
16.3 Move a Summary ...................................................................................................... 16-4
16.4 Add a Page Heading ............................................................................................... 16-5
16.5 Add White Space and Format Fields ...................................................................... 16-6
16.6 Summary ................................................................................................................. 16-7

17 Building a Header with Database Values Report
17.1 Prerequisites for This Example ................................................................................ 17-2
17.2 Create a Data Model and a Group Left Layout ......................................................... 17-2
17.3 Add Summary Columns for the Header Data ............................................................. 17-4
17.4 Add a Page Heading ............................................................................................... 17-5
17.5 Summary ................................................................................................................. 17-6

18 Building a Report with Graphics, Text, and Color
18.1 Prerequisites for This Example ................................................................................ 18-2
18.2 Create a Simple Report Definition ......................................................................... 18-2
18.3 Modify the Report in the Paper Layout View ........................................................... 18-4
18.3.1 Add a border around the report ......................................................................... 18-4
18.3.2 Change the font size and style .......................................................................... 18-5
18.3.3 Add bullets to your report .................................................................................. 18-6
18.3.4 Display a line between each record .................................................................... 18-7
18.3.5 Add a title to your report .................................................................................... 18-8
18.4 Summary ................................................................................................................. 18-10

19 Building a Report that Renumbers Pages by Repeating Frame
19.1 Prerequisites for This Example ................................................................................ 19-3
19.2 Create a Data Model and a Group Above Layout ..................................................... 19-3
19.3 Add a Second Query ............................................................................................... 19-5
24.2 Create the Data Model with Two Linked Queries .............................................................. 24-3
24.3 Create the Layout of the Report........................................................................................ 24-4
24.3.1 Create the initial layout of your report using the Report Wizard ............................ 24-4
24.3.2 Modify the layout of your report ............................................................................... 24-5
24.4 Run your Report to Paper.............................................................................................. 24-6
24.5 Summary ....................................................................................................................... 24-7

Part IV Building Matrix Reports

25 Building a Matrix Report
25.1 Prerequisites for This Example ......................................................................................... 25-2
25.2 Create a Single-Query Matrix ............................................................................................ 25-2
25.3 Create a Multiple-Query Matrix ....................................................................................... 25-4
25.3.1 Create a new report manually ..................................................................................... 25-4
25.3.2 Create a data model with a cross product and a data link ........................................... 25-4
25.3.3 Create the layout with the Report Wizard ................................................................. 25-6
25.4 Add Summaries to the Single-Query Matrix ................................................................... 25-7
25.5 Format Monetary Values ................................................................................................. 25-8
25.6 Add Zeroes in Place of Blanks .......................................................................................... 25-9
25.7 Add a Grid ........................................................................................................................ 25-12
25.8 Summary ......................................................................................................................... 25-12

26 Building a Nested Matrix Report
26.1 Prerequisites for This Example ........................................................................................ 26-3
26.2 Create a Single-Query Matrix ............................................................................................ 26-3
26.3 Create a Multiple-Query Matrix ....................................................................................... 26-5
26.3.1 Create a new report manually ..................................................................................... 26-5
26.3.2 Create a data model with a cross product and data links ........................................... 26-5
26.3.3 Create the layout with the Report Wizard ................................................................. 26-8
26.4 Create a Multiple-Query Matrix with a Break ................................................................ 26-10
26.4.1 Create a new report manually ..................................................................................... 26-10
26.4.2 Create a data model with a cross product and data links ........................................... 26-10
26.4.3 Create the layout with the Report Wizard ................................................................. 26-13
26.5 Format Monetary Values ................................................................................................. 26-15
26.6 Summary ......................................................................................................................... 26-15

27 Building a Matrix with Group Above Report
27.1 Prerequisites for This Example ........................................................................................ 27-2
27.2 Create a Matrix Group Data Model and Layout .............................................................. 27-2
27.3 Add Labels and Lines for Summaries ............................................................................. 27-4
27.4 Add Space Between Groups ............................................................................................ 27-5
27.5 Create a Web Layout ........................................................................................................ 27-6
27.6 Summary ......................................................................................................................... 27-6

Part V Building Reports for Business Cases
<table>
<thead>
<tr>
<th>Section</th>
<th>Title</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>32.3.3</td>
<td>Add the order item details to your report</td>
<td>32-9</td>
</tr>
<tr>
<td>32.3.4</td>
<td>Adjust the layout and add summaries</td>
<td>32-10</td>
</tr>
<tr>
<td>32.4</td>
<td>Format Your Report in the Paper Design View</td>
<td>32-12</td>
</tr>
<tr>
<td>32.5</td>
<td>Add Page Numbers (optional)</td>
<td>32-14</td>
</tr>
<tr>
<td>32.6</td>
<td>Summary</td>
<td>32-16</td>
</tr>
<tr>
<td>33</td>
<td><strong>Building an Invoice Report</strong></td>
<td></td>
</tr>
<tr>
<td>33.1</td>
<td>Prerequisites for This Example</td>
<td>33-3</td>
</tr>
<tr>
<td>33.2</td>
<td>Create a New Report Manually</td>
<td>33-3</td>
</tr>
<tr>
<td>33.3</td>
<td>Create a Data Model With a Data Link</td>
<td>33-3</td>
</tr>
<tr>
<td>33.4</td>
<td>Create Summary and Formula Columns</td>
<td>33-5</td>
</tr>
<tr>
<td>33.5</td>
<td>Prepare the Layout</td>
<td>33-7</td>
</tr>
<tr>
<td>33.6</td>
<td>Insert Invoice Information</td>
<td>33-7</td>
</tr>
<tr>
<td>33.7</td>
<td>Summary</td>
<td>33-11</td>
</tr>
<tr>
<td>34</td>
<td><strong>Building a Ranking Report</strong></td>
<td></td>
</tr>
<tr>
<td>34.1</td>
<td>Prerequisites for This Example</td>
<td>34-2</td>
</tr>
<tr>
<td>34.2</td>
<td>Create a Data Model and Tabular Layout</td>
<td>34-2</td>
</tr>
<tr>
<td>34.3</td>
<td>Create Ranking Logic for Top number of Customers</td>
<td>34-3</td>
</tr>
<tr>
<td>34.4</td>
<td>Add a Layout Object for a Parameter</td>
<td>34-5</td>
</tr>
<tr>
<td>34.5</td>
<td>Create a Parameter Form</td>
<td>34-6</td>
</tr>
<tr>
<td>34.6</td>
<td>Add a Percentage Ranking</td>
<td>34-7</td>
</tr>
<tr>
<td>34.7</td>
<td>Summary</td>
<td>34-10</td>
</tr>
<tr>
<td>35</td>
<td><strong>Building a Paper Report with a Simple Table of Contents and Index</strong></td>
<td></td>
</tr>
<tr>
<td>35.1</td>
<td>Prerequisites for This Example</td>
<td>35-3</td>
</tr>
<tr>
<td>35.2</td>
<td>Create a Simple Table of Contents</td>
<td>35-4</td>
</tr>
<tr>
<td>35.2.1</td>
<td>Create a table in the database to hold the TOC data</td>
<td>35-4</td>
</tr>
<tr>
<td>35.2.2</td>
<td>Create a group above report</td>
<td>35-4</td>
</tr>
<tr>
<td>35.2.3</td>
<td>Create an After Parameter Form trigger and a format trigger</td>
<td>35-6</td>
</tr>
<tr>
<td>35.2.3.1</td>
<td>Create an After Parameter Form trigger</td>
<td>35-6</td>
</tr>
<tr>
<td>35.2.3.2</td>
<td>Create a format trigger</td>
<td>35-7</td>
</tr>
<tr>
<td>35.2.4</td>
<td>Create a second query in the data model</td>
<td>35-7</td>
</tr>
<tr>
<td>35.2.5</td>
<td>Create a report block to display the table of contents</td>
<td>35-9</td>
</tr>
<tr>
<td>35.2.6</td>
<td>Run your simple table of contents report to paper</td>
<td>35-10</td>
</tr>
<tr>
<td>35.3</td>
<td>Create an Index</td>
<td>35-11</td>
</tr>
<tr>
<td>35.3.1</td>
<td>Create a table in the database to hold the information for the index</td>
<td>35-12</td>
</tr>
<tr>
<td>35.3.2</td>
<td>Create a format trigger</td>
<td>35-12</td>
</tr>
<tr>
<td>35.3.3</td>
<td>Add a query to the data model</td>
<td>35-13</td>
</tr>
<tr>
<td>35.3.4</td>
<td>Create a report block to display the index in the Trailer section</td>
<td>35-14</td>
</tr>
<tr>
<td>35.3.5</td>
<td>Run your report to paper</td>
<td>35-14</td>
</tr>
<tr>
<td>35.4</td>
<td>Summary</td>
<td>35-15</td>
</tr>
<tr>
<td>36</td>
<td><strong>Building a Paper Report with a Multilevel Table of Contents</strong></td>
<td></td>
</tr>
<tr>
<td>36.1</td>
<td>Prerequisites for This Example</td>
<td>36-3</td>
</tr>
<tr>
<td>36.2</td>
<td>Create a table in the database to hold the TOC data</td>
<td>36-3</td>
</tr>
<tr>
<td>Section</td>
<td>Description</td>
<td>Page</td>
</tr>
<tr>
<td>---------</td>
<td>------------------------------------------------------------------------------</td>
<td>------</td>
</tr>
<tr>
<td>36.3</td>
<td>Create an After Parameter Form Trigger and a Format Trigger</td>
<td>36-4</td>
</tr>
<tr>
<td>36.3.1</td>
<td>Create an After Parameter Form trigger</td>
<td>36-4</td>
</tr>
<tr>
<td>36.3.2</td>
<td>Create a format trigger</td>
<td>36-5</td>
</tr>
<tr>
<td>36.4</td>
<td>Create a Second Query in the Data Model</td>
<td>36-6</td>
</tr>
<tr>
<td>36.5</td>
<td>Create a Report Block to Display the Table of Contents</td>
<td>36-7</td>
</tr>
<tr>
<td>36.6</td>
<td>Run Your Multilevel Table of Contents Report to Paper</td>
<td>36-8</td>
</tr>
<tr>
<td>36.7</td>
<td>Summary</td>
<td>36-10</td>
</tr>
</tbody>
</table>

37  **Bursting and Distributing a Report**

<table>
<thead>
<tr>
<th>Section</th>
<th>Description</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>37.1</td>
<td>Prerequisites for This Example</td>
<td>37-2</td>
</tr>
<tr>
<td>37.2</td>
<td>Set Up an Existing Report for Bursting</td>
<td>37-2</td>
</tr>
<tr>
<td>37.3</td>
<td>Edit the Distribution XML Definition</td>
<td>37-3</td>
</tr>
<tr>
<td>37.4</td>
<td>Run the Report</td>
<td>37-4</td>
</tr>
<tr>
<td>37.5</td>
<td>Summary</td>
<td>37-5</td>
</tr>
</tbody>
</table>

38  **Building a Report with Multibyte Characters for PDF Output**

<table>
<thead>
<tr>
<th>Section</th>
<th>Description</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>38.1</td>
<td>Prerequisites for This Example</td>
<td>38-3</td>
</tr>
<tr>
<td>38.2</td>
<td>Create the Query and Paper Layout for a Multibyte Report</td>
<td>38-4</td>
</tr>
<tr>
<td>38.3</td>
<td>Display Multibyte Characters in the Report</td>
<td>38-7</td>
</tr>
<tr>
<td>38.4</td>
<td>Create a PDF Document of Your Report</td>
<td>38-8</td>
</tr>
<tr>
<td>38.5</td>
<td>Summary</td>
<td>38-9</td>
</tr>
</tbody>
</table>

Part VI  **Building Reports with PL/SQL and Java**

39  **Building a Report with Graphs**

<table>
<thead>
<tr>
<th>Section</th>
<th>Description</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>39.1</td>
<td>About Graphs and Graph Wizards</td>
<td>39-1</td>
</tr>
<tr>
<td>39.2</td>
<td>New Features and Benefits</td>
<td>39-4</td>
</tr>
<tr>
<td>39.3</td>
<td>New Graph Types</td>
<td>39-5</td>
</tr>
<tr>
<td>39.3.1</td>
<td>Funnel Graph</td>
<td>39-5</td>
</tr>
<tr>
<td>39.3.2</td>
<td>Curved Line or Fit To Curve Graph</td>
<td>39-5</td>
</tr>
<tr>
<td>39.3.3</td>
<td>Enhanced Pie</td>
<td>39-6</td>
</tr>
</tbody>
</table>

40  **Building a Report that Includes PL/SQL**

<table>
<thead>
<tr>
<th>Section</th>
<th>Description</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>40.1</td>
<td>Prerequisites for This Example</td>
<td>40-2</td>
</tr>
<tr>
<td>40.2</td>
<td>Create a New PL/SQL Library</td>
<td>40-2</td>
</tr>
<tr>
<td>40.3</td>
<td>Create the Report Definition</td>
<td>40-4</td>
</tr>
<tr>
<td>40.3.1</td>
<td>Create a query</td>
<td>40-4</td>
</tr>
<tr>
<td>40.3.2</td>
<td>Create a formula column that calculates bonuses</td>
<td>40-5</td>
</tr>
<tr>
<td>40.3.3</td>
<td>Create a report-level function that calculates total compensation</td>
<td>40-7</td>
</tr>
<tr>
<td>40.3.4</td>
<td>Create a second formula column for total compensation</td>
<td>40-8</td>
</tr>
<tr>
<td>40.4</td>
<td>Create the Report Layout Using the Report Block Wizard</td>
<td>40-9</td>
</tr>
<tr>
<td>40.5</td>
<td>Add Vertical Space Between Records</td>
<td>40-12</td>
</tr>
<tr>
<td>40.5.1</td>
<td>Create a user parameter</td>
<td>40-12</td>
</tr>
<tr>
<td>40.5.2</td>
<td>Create a summary column that counts the number of records</td>
<td>40-12</td>
</tr>
<tr>
<td>40.5.3</td>
<td>Modify the layout</td>
<td>40-13</td>
</tr>
</tbody>
</table>
### 40.5.4 Create a format trigger

Create a format trigger to customize the appearance of your report. This section provides detailed instructions on how to create a format trigger, including setting properties, defining formats, and applying them to your report.

---

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Create a format trigger</td>
<td>40-14</td>
</tr>
<tr>
<td>Run Your Report to Paper</td>
<td>40-14</td>
</tr>
<tr>
<td>Summary</td>
<td>40-15</td>
</tr>
</tbody>
</table>

### 41 Building a Paper Report with REF CURSORs

This chapter focuses on building a paper report using REF CURSORs. REF CURSORs are a powerful feature in Oracle Reports, allowing you to create complex reports with multiple layers of data. This chapter covers the steps involved in creating a report with REF CURSORs, from defining the REF CURSOR type to creating a layout.

#### 41.1 Prerequisites for This Example

Before you begin, ensure that you have the necessary environment set up to run the examples in this chapter. This includes having the necessary software and access to the database.

#### 41.2 Define a REF CURSOR Type

In this section, you will define a REF CURSOR type, which is a type of variable that can reference a SQL query and return a result set.

#### 41.3 Create a REF CURSOR Query

Create a REF CURSOR query that will be used to fetch data from the database. This query will define the structure of the data that will be returned.

#### 41.4 Refine the Data Model

Refine the data model to ensure that it is properly organized and ready for use with the REF CURSOR queries.

#### 41.5 Create Links Between REF CURSOR Queries

Create links between the REF CURSOR queries to establish a hierarchy of data and create a more complex report.

#### 41.6 Add Summary Columns

Add summary columns to your report to provide aggregated data and enhance the overall presentation.

#### 41.7 Create a Layout

Create a layout for your report, defining how the data will be displayed on paper.

#### 41.8 Move the SELECT Statements Into Packages

Move the SELECT statements into packages to encapsulate the logic and make your report more maintainable.

#### 41.9 Move the Packages Into a Library

Move the packages into a library to facilitate reuse and organization of your code.

#### 41.10 Summary

The chapter concludes with a summary of the key points covered in building a paper report with REF CURSORs, offering insights and recommendations for best practices.

---

### 42 Building a Simple Parameter Form for a JSP-based Web Report

This chapter introduces the concept of creating a simple parameter form for a JSP-based web report. A parameter form is a user interface that allows users to input criteria for the report, such as dates or selection criteria.

#### 42.1 Prerequisites for This Example

Ensure that you have the necessary environment and software set up to run the examples in this chapter. This includes having access to the database and JSP development environment.

#### 42.2 Create a Parameter Form in HTML

Create a basic parameter form in HTML, defining input fields and labels for user interaction.

#### 42.3 Modify the HTML Parameter Form in Reports Builder

In this section, you will modify the HTML parameter form in Reports Builder, ensuring that it is compatible with the Oracle Reports environment.

#### 42.3.1 Create a data model manually for the Parameter Form

Create a data model manually for the parameter form, defining the fields and types of data that will be passed to the form.

#### 42.3.2 Create a dynamic LOV in the Parameter Form

Create a dynamic list of values (LOV) in the parameter form, allowing users to select from a list of values.

#### 42.3.3 Run the Parameter Form report to the Web

Run the parameter form report to the web, allowing users to interact with the form and see the report results.

#### 42.4 Set up the Target Report

Set up the target report, defining the data model and layout to display the results of the parameter form.

#### 42.5 Deploy the JSP Parameter Form and the Target Report

Deploy the JSP parameter form and the target report, making them available to users within the Oracle Reports environment.

#### 42.6 Summary

The chapter concludes with a summary of the key points covered in building a simple parameter form for a JSP-based web report, offering insights and recommendations for best practices.

---

### 43 Building a Report with a Barcode

This chapter focuses on creating a report with a barcode. Barcodes are a convenient way to encode information, making it easy to transfer data from one medium to another, such as from a paper report to a digital format.

#### 43.1 Prerequisites for This Example

Ensure that you have the necessary environment and software set up to run the examples in this chapter. This includes having access to the database and the BARCODE JavaBean.

#### 43.1.1 Update the REPORTS_CLASSPATH environment variable

Update the REPORTS_CLASSPATH environment variable to include the BARCODE JavaBean.

#### 43.2 Create a Barcode Report for Paper

Create a barcode report for paper, defining the barcode image and the order total.

#### 43.2.1 Import the Java classes into Reports Builder

Import the Java classes into Reports Builder, ensuring that they are available for use in your report.

#### 43.2.2 Create a package to store your information

Create a package to store your information, allowing for structured management of your data.

#### 43.2.3 Create a Before Report trigger

Create a Before Report trigger to set up the barcode JavaBean and store properties.

#### 43.2.4 Create a query in the Data Model view

Create a query in the data model to retrieve the barcode image and the order total.

#### 43.2.5 Create a formula column to retrieve the barcode image

Create a formula column to retrieve the barcode image from the query.

#### 43.2.6 Create a formula column that returns the order total

Create a formula column that returns the order total from the query.

#### 43.2.7 Create a layout for your report

Create a layout for your report, defining how the barcode and order total will be displayed.

#### 43.3 Create a Barcode Report for the Web

Create a barcode report for the web, allowing users to view the report on their web browsers.

#### 43.3.1 Create a query in an existing HTML file

Create a query in an existing HTML file to display the barcode and order total.

#### 43.3.2 Create three formula columns in your data model

Create three formula columns in your data model to store the barcode and order total.

#### 43.3.3 Initialize the barcode JavaBean and set its properties

Initialize the barcode JavaBean and set its properties, preparing it to be used in the report.

#### 43.3.4 Run your report to the Web

Run your report to the web, allowing users to view the barcode and order total on their web browsers.

#### 43.4 Summary

The chapter concludes with a summary of the key points covered in building a report with a barcode, offering insights and recommendations for best practices.
44  Building an Accessible JSP-based Web Report

Part VII  Building Reports with Pluggable Data Sources

45  Building a Report with an XML Pluggable Data Source

45.1  Prerequisites for This Example ................................................................. 45-6
45.2  Create a Report Manually with SQL and XML Queries .......................... 45-6
45.2.1  Create a SQL query for your new report ............................................ 45-6
45.2.2  Create an XML query to access your XML data source ...................... 45-7
45.2.3  Create a data link between two queries ................................................. 45-8
45.2.4  Create a layout for your report using the Report Wizard .................. 45-9
45.2.5  Apply alternating row colors to your report ......................................... 45-10
45.2.6  Filter your XML data using a group filter ........................................... 45-12
45.3  Run Your Report to Paper ................................................................. 45-14
45.4  Summary .............................................................................................. 45-15

46  Building a Report with a Text Pluggable Data Source

46.1  Prerequisites for This Example ................................................................. 46-2
46.2  Set Up the textpds.conf File ................................................................... 46-2
46.3  Use the Report Wizard to Create a Report ........................................... 46-3
46.4  Summary .............................................................................................. 46-5

A  Tool Palette and Toolbar Reference

A.1  Main Toolbar .......................................................................................... A-1
A.2  Data Model View Tool Palette ................................................................. A-2
A.3  Paper Layout View Tool Palette ............................................................... A-3
Preface

This manual will help you learn about the extensive capabilities of Reports Builder (the report-building component of Oracle Reports), how to build different types of reports, and how to customize your reports to meet a wide variety of requirements.

Audience

This manual is intended for anyone who uses Oracle Reports to build reports. The needs of both novice and advanced users are addressed. Following the step-by-step instructions, you can build the example reports from start to finish. Each report that you build will demonstrate how to use many of the powerful features in Reports Builder.

Documentation Accessibility

For information about Oracle's commitment to accessibility, visit the Oracle Accessibility Program website at

Access to Oracle Support

Oracle customers that have purchased support have access to electronic support through My Oracle Support. For information, visit http://www.oracle.com/pls/topic/lookup?ctx=acc&id=info or visit
http://www.oracle.com/pls/topic/lookup?ctx=acc&id=trs if you are hearing impaired.

Related Documentation

For more information about Oracle Reports, refer to the following resources:

- Oracle Reports Tutorial
- Publishing Reports to the Web with Oracle Reports Services
- Oracle Reports online Help, which is available in Oracle Reports Builder or hosted on the Oracle Technology Network (OTN), as described in Section 4.1.1, "Using the Oracle Reports online Help”.

Conventions

The following text conventions are used in this document:
Accessing the Example Reports

The supporting files for the reports you will build are available on the Oracle Technology Network (OTN). On the Oracle Reports page (http://www.oracle.com/technetwork/middleware/reports/overview/index.html), navigate to the Learn More tab, and click Getting Started. The Getting Started with Oracle Reports home page will be displayed. In the list of topic sections on the left, click Index. In the Topic list, choose Building and Developing Reports; in the Collateral Type list, choose Examples, then click Search. In the list of topics that displays, find Building Reports sample files and click the Download icon to download a zip file, called buildingreports_examples.zip. This zip file contains subfolders that correspond to the names of each chapter. Each of the subfolders contains all the supporting files (example reports, images, SQL query code, and so on) necessary for building the individual reports. Extract this zip file into ORACLE_HOME\examples (for example, D:\orawin\examples).

Additionally, the remaining examples in Getting Started with Oracle Reports provide a Web-based selection of examples in this manual, and also examples not covered in this manual.

Accessing the Data Sources

The data sources used in this manual are:

- SCOTT schema
- Sample Human Resources, Sales History, and Order Entry schemas
- Summit Sporting Goods (SUMMIT) schema

The SCOTT, Human Resources, Sales History, and Order Entry schemas are available with the Oracle Database. You can contact your database administrator for more information on where to find these schemas. You can download the SQL scripts to install the Summit Sporting Goods (SUMMIT) schema from the Oracle Technology Network (OTN): on the Oracle Reports page (http://www.oracle.com/technetwork/middleware/reports/overview/index.html), click Getting Started to display the Getting Started with Oracle Reports home page. In the list of topic sections on the left, click Index. In the Topic list, choose Building and Developing Reports; in the Collateral Type list, choose Tools/Utilities, then click Search. In the list of tools and utilities that displays, click the Download icon to download the SQL scripts to install the SUMMIT sample schema.
This chapter introduces the fundamental concepts of the 12c Release 12.2.1.1 component of Oracle Reports. Each topic in this chapter is also included in the Basic Concepts section of the Oracle Reports online Help (see Section 4.1.1, "Using the Oracle Reports online Help").

Topics are grouped into the following sections:

- Section 1.1, "Oracle Reports Builder"
- Section 1.2, "Reports"
- Section 1.3, "Report Styles"
- Section 1.4, "Wizards"
- Section 1.5, "The Object Navigator"
- Section 1.6, "The Report Editor"
- Section 1.7, "Data Model Objects"
- Section 1.8, "Layout Objects"
- Section 1.9, "Parameter Form Objects"
- Section 1.10, "The Property Inspector"
- Section 1.11, "Runtime Views"
- Section 1.12, "Oracle Reports Components"

1.1 Oracle Reports Builder

The topics in this section discuss the features and functionality in Oracle Reports Builder.

- About Oracle Reports Builder
- About this release

1.1.1 About Oracle Reports Builder

Oracle Reports Builder is the report-building component of Oracle Reports, a powerful enterprise reporting tool that enables you to rapidly develop and deploy sophisticated Web and paper reports against any data source (including an Oracle database, JDBC, XML, and text files). Leveraging Java EE technologies such as JSP and XML, you can publish your reports in a variety of formats (including HTML, XML, PDF, spreadsheet, delimited text, PostScript, and RTF) to any destination (including e-mail, Web browser, Oracle Portal, and file system) in a scalable, efficient manner.
Recognizing the differences between Web publishing and paper publishing, Oracle Reports Builder provides the power to develop high quality output for the Web and e-business requirements, also high-fidelity printed reports. Oracle Reports Builder includes:

- user-friendly wizards that guide you through the report design process
- pluggable data sources (PDSs), such as JDBC and XML, that provide access to data from any source for your reports
- a query builder with a graphical representation of the SQL statement to obtain report data
- default report templates and layout styles that can be customized if needed
- a live editor that enables you to modify paper report layouts in WYSIWYG mode
- the ability to add dynamic report output to an HTML page by embedding custom JSP tags within an HTML document
- an integrated graph builder to graphically represent report data
- the ability to generate code to customize how reports will run
- tools that dynamically generate Web pages based on your data
- standard report output formats such as HTML, HTMLCSS, XML, PDF, RTF, Spreadsheet, PCL, PostScript, and ASCII
- client-side parameter validation using JavaScript
- the ability to execute dynamic SQL statements within PL/SQL procedures
- support for Oracle database objects
- event-based reporting (report execution based on database events)
- seamless integration with Oracle Portal for administering report security and publishing report output to portlets

1.1.2 About this release

Oracle Reports 12c (12.2.1.1) provides many new features and enhancements. The primary themes of this release are:

- Tighter integration with Oracle Fusion Middleware Platform and Services to provide simplified administration of complex topologies and deployments.
- Enhancements in top supportability areas with architectural changes.
- New features in key enterprise reporting areas.

The "Introduction" chapter in Publishing Reports to the Web with Oracle Reports Services, available on the Oracle Technology Network details the new functionality in Oracle Reports 12c (12.2.1.1), along with the equivalent 10g Release 2 (10.1.2) functionality, when applicable.

For additional information, see the Oracle Reports 11g page on the Oracle Technology Network.

1.2 Reports

The topics in this section discuss basic concepts of reports; for more advanced concepts, see Section 2.1, "Reports".
1.2.1 About Reports

A report consists of objects that collectively define the report:

- data model objects (queries, groups, columns, links, user parameters)
- layout objects (repeating frames, frames, fields, boilerplate, anchors)
- parameter form objects (parameters, fields, boilerplate)
- PL/SQL objects (program units, triggers)
- references to external PL/SQL libraries, if any
- code shown in the Web Source view (for JSP-based Web reports)

Using the Property Inspector, you define report properties. The document taxonomy (classification) properties (Title, Author, Subject, and Keywords) assist in cataloging and searching a report document.

When you first start Oracle Reports Builder, you can choose to open an existing report, create a new report using the Report Wizard, or create a new report manually.

---

**Note:** Source Control is disabled by default. Therefore, the Administration option on the File menu is always disabled.

---

1.2.1.1 Creating a new report using the Report Wizard

Using the Report Wizard, you can quickly and easily accomplish the steps to build a report for both Web and paper layouts:

1. Create a new report definition.
2. Define the data model (choose the data, data relationships, and calculations you will use to produce the report output).
3. Specify a layout. You can use a default, customizing it if desired, or create your own. Oracle Reports Builder provides the default layout styles described in Section 1.3, "Report Styles".
4. Then, you can modify your report using the different views of the Report Editor.

1.2.1.2 Creating a new report manually

If you choose to create a new report manually, Oracle Reports Builder creates a new default report definition for you. The first window you see is called the Object Navigator. This window displays a comprehensive list of report objects. Initially, it shows all objects that Oracle Reports Builder has created for you, as part of the report definition. As you define your report, the Object Navigator provides a central location to access and modify all objects in your report(s), including attached libraries, triggers, and program units. You can change the Object Navigator view to list objects hierarchically or by object type.

**See also**

Section 4.5.1, "Creating a report"
1.2.2 About Web Reports

With a focus on Web publishing, Oracle Reports has moved more fully into its role as a universal publishing solution. In prior releases, Oracle Reports Builder’s Web feature simply displayed paper reports (that is, multiple pages) in HTML or PDF. This moves corporate data onto the Web, but also results in large and somewhat inflexible HTML pages.

While all the prior Web report functionality remains for paper-based reports (see Section 4.6.10, "Adding Web links to paper-based reports"), Oracle Reports can also use JavaServer Pages (JSPs) as the underlying technology to enable you to enhance Web pages with information retrieved using Oracle Reports Builder. This introduces the Web Source view of a report, and enables you to have both JSP-based and paper-based definitions in a single report. In other words, you can either publish your paper reports to the Web in various output formats, or take more advantage of Web features by adding JSP coding in the Web Source view. For example, you can create a report that has a paper PDF version and a JSP-based Web version; what you choose depends on your needs and whether you are able to produce the desired results more easily in the Web Source view or in the Paper Design view.

Oracle Reports also includes servlet technology. Servlets provide a Java-based alternative to CGI programs. Servlets provide a platform-independent method for building Web-based applications, without the performance limitations of CGI programs.

You can create a Web report in any of the following ways:

- In the Report Wizard, select whether the report layout is both Web and paper, Web only, or paper only. The layout for both Web and paper reports defaults in the Paper Design view. You can view the source code for the Web report in the Web Source view.

- Open an existing HTML document (Web page) and embed a report in your Web page using the Report Block Wizard. This provides tremendous flexibility in creating reports that meet the demands of completely integrating multiple sources of information within a single Web page. See Section 4.6.4, "Adding a report block to a Web page".

- Display the Web Source view (see Section 4.6.2, "Viewing the source code for a Web report") and manually insert the Oracle Reports custom JSP tags. See the topic "Oracle Reports JSP tags" in the Reference section of the Oracle Reports online Help.

- Insert an existing report into an existing Web page, by displaying the Web Source view for the report and source code of the Web page, then copying and pasting the report block into the desired position in the Web page.

- Use the functionality available since Oracle Reports 6i to add HTML and hyperlinks to an existing report to create a paper-based Web report (HTML file). See Section 4.6.10, "Adding Web links to paper-based reports".

To preview your report output in a Web browser, use Program > Run Web Layout. It enables you to immediately see the effect of your changes on the output.
1.3 Report Styles

The topics in this section describe the built-in report styles in Oracle Reports Builder.

- About tabular reports
- About group above reports
- About group left reports
- About form-like reports
- About form letter reports
- About mailing label reports
- About matrix reports

1.3.1 About tabular reports

A tabular report is the most basic type of report. Each column corresponds to a column selected from the database.

See also
Section 4.5.1, "Creating a report"

1.3.2 About group above reports

A group above report contains multiple groups in its data model. It is a "master/detail" report, where there may be a lot of information in the master group. For every master group, the related values of the detail group(s) are fetched from the database and are displayed below the master information.

See also
Section 4.5.1, "Creating a report"
Section 1.7.2, "About groups"
Section 4.8.7, "Creating a break group"

1.3.3 About group left reports

A group left report also contains multiple groups in its data model, dividing the rows of a table based on a common value in one of the columns. Use this type of report to restrict a column from repeating the same value several times while values of related columns change. The data model for group above and group left reports is the same, but the layouts differ; group above reports display the master information at the top while group left reports display break columns to the side.

See also
Section 4.5.1, "Creating a report"
Section 1.7.2, "About groups"
Section 4.8.7, "Creating a break group"

1.3.4 About form-like reports

A form-like report displays one record per page, displaying field values to the right of field labels.

See also
Section 4.5.1, "Creating a report"

1.3.5 About form letter reports

A form letter report contains database values embedded in boilerplate text (any text that you enter or import into a Report Editor.)

See also
Section 4.5.1, "Creating a report"

1.3.6 About mailing label reports

A mailing label report prints mailing labels in multiple columns on each page. Using the Report Wizard, you can specify the format for your mailing labels.

See also
Section 4.5.1, "Creating a report"

1.3.7 About matrix reports

A matrix (cross-product) report is a cross-tabulation of four groups of data:

- One group of data is displayed across the page.
- One group of data is displayed down the page.
- One group of data is the cross-product, which determines all possible locations where the across and down data relate and places a cell in those locations.
- One group of data is displayed as the "filler" of the cells.
Thus, to create a matrix report, you need at least four groups in the data model: one group must be a cross-product group, two of the groups must be within the cross-product group to furnish the "labels", and at least one group must provide the information to fill the cells. The groups can belong to a single query or to multiple queries.

A distinguishing feature of matrix reports is that the number of columns is not known until the data is fetched from the database.

With Oracle Reports Builder, you can create many different matrix reports. The four general types of matrix reports are simple matrix, nested matrix, multiquery matrix with break, and matrix break, but you are not confined to these designs.

For a detailed example, see Chapter 25, "Building a Matrix Report".

1.3.7.1 Matrix data model
In building your matrix data model, you should consider the following:

- number of queries
- group structure
- summary settings

1.3.7.1.1 Number of queries Although matrix reports always require at least four groups, they can be built with any number of queries. If you build a matrix report with only one query (usually the most efficient structure), you must create at least three groups in addition to the one created by default. If you build a matrix report with multiple (three or more) queries, you still need to create at least one additional group. The figure below illustrates the two types of query structures that you can use for your matrix data model.
One advantage to a one-query data model is that the resulting report is generally more efficient than a report based on a multiquery data model.

**Multiquery matrix.** You may consider using a multiquery data model, as it often has simple queries and can be easier to maintain than the equivalent one-query data model. In addition, a multiquery data model is required for some types of matrices (for example, some nested matrix reports).

### 1.3.7.1.2 Group structure
Matrix reports are built with four or more groups:

- **Two or more dimension groups.** Dimension groups are contained within the cross product group. In the layout, the information in at least one group goes across the page, and the information in at least one group goes down the page, forming a grid. The information in these groups is sometimes referred to as "matrix labels", as they appear to provide column and row labels for the matrix.

- **One or more cross product groups.** The cross product group represents all possible combinations of the values of the dimension groups. In the layout, the cross product group is shown by the intersection of the repeating frames for the across and down dimension groups. When the report is run, it expands, and each instance of data intersection becomes a separate cell. This concept is sometimes best understood graphically, as in the figure below. The rectangles are cells, and show where each department/job combination is valid.

**Figure 1–3 Conceptual matrix**

<table>
<thead>
<tr>
<th></th>
<th>Analyst</th>
<th>Clerk</th>
<th>Manager</th>
<th>President</th>
<th>Salesman</th>
</tr>
</thead>
<tbody>
<tr>
<td>10</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>20</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>30</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

- **One cell, or "filler" group.** The cell group contains the actual information that is represented by the cells of the cross product. For each intersection of the values of the dimension groups (cell), the cell group contains zero, one, or multiple values. When the report is run, these values appear in the appropriate cells.
The following figure shows graphical representations of how groups are related for both single and multiquery data models.

**Figure 1–4  Matrix data model relationships**

Notice that for each data model the cross product group is shown by the large rectangle, while the dimension groups are the smaller rectangles enclosed by it, and the cell group is shown outside of the cross product group.

1.3.7.1.3  **Summary settings**  Creating a summary for a matrix requires more information than creating a summary for other kinds of reports. When you create summary columns for your matrix, you need to indicate the following:

- The frequency of the summary. The frequency specifies the dimension groups for which to compute the summary.
- The order in which to compute the summary. The order specifies how to traverse the matrix in calculating the summary (top to bottom or left to right).

In Oracle Reports Builder, you specify this information by setting the Product Order property for your summary. All summaries that are owned by the cross product group require that a Product Order be specified. Suppose that you have a matrix report that looks something like the one below.
This is a nested matrix report. Assume that group G_YEAR contains the YEAR column, G_DEPT contains the DEPTNO column, G_JOB contains the JOB column, and G_CROSS is the cross product group.

To create the summary of salaries by job that appears at the bottom of the matrix for each job, you create a summary column in G_CROSS with the following property settings:

**Figure 1–6  Matrix summary settings**

<table>
<thead>
<tr>
<th>Product Order</th>
<th>Reset At</th>
</tr>
</thead>
<tbody>
<tr>
<td>G_JOB</td>
<td>G_JOB</td>
</tr>
</tbody>
</table>

These settings specify that the summary should be calculated for each job in the G_JOB group and the summary should be reset to zero for each job in the G_JOB group.

To create the summary of salaries by year which appears at the right of the matrix directly underneath the boilerplate lines, you create a summary column in G_CROSS with the following property settings:

**Figure 1–7  Matrix summary settings**

<table>
<thead>
<tr>
<th>Product Order</th>
<th>Reset At</th>
</tr>
</thead>
<tbody>
<tr>
<td>G_YEAR</td>
<td>G_YEAR</td>
</tr>
</tbody>
</table>

These settings specify that the summary should be calculated for each year in the G_YEAR group and the summary should be reset to zero for each year in the G_YEAR group. To create the summary of salaries by year and department that appears at the right of the matrix for each department row of the matrix that contains a value, you create a summary column in G_CROSS with the following property settings:
These settings specify that the summary should be calculated for each record of G_DEPT within each record of G_YEAR. G_DEPT comes after G_YEAR in the Product Order because, in this report, it changes more frequently than G_YEAR. If G_YEAR changed more frequently (that is, years were listed for each department), it would make more sense to have a Product Order of G_DEPT, G_YEAR.

This summary is reset to zero for each record in the G_DEPT group. When you have multiple groups listed in Product Order and you want a non-running summary, the reset group should be the same as the last group in Product Order. When you have multiple groups listed in the Product Order and you want a running summary, the reset group should be a group other than the last one in the Product Order.

### 1.3.7.2 Matrix layout

The figure below shows the objects that comprises a simple, two-dimensional matrix. All of these objects are necessary for a matrix, except for the boilerplate field labels.

A matrix layout model must consist of the following layout objects:

- At least three repeating frames: one with the Print Direction property set to *Down*, one with the Print Direction property set to *Across*, and one for the cell in the matrix object.
- Several group, header, and footer (if summaries are included) frame.
- A matrix object created for the cross product group, inside of which are the cells of the matrix (for example, the rectangle in the figure above with F_SUMSAL inside it).
- Boilerplate for each column and row of values, and also for summaries (for example, Job and Deptno). Displaying the boilerplate is optional, but Oracle Reports Builder will generate it by default.
1.3.7.2.1 Matrix object

The matrix object defines the intersection of at least two repeating frames. The repeating frames are the dimensions of the matrix and the matrix object contains the repeating frame that will hold the “filler” or values of the cell group. You need one matrix object for each pair of intersecting repeating frames in the layout. One of the repeating frames must have the Print Direction property set to Down and for the other the Print Direction property should be set to Across, to form a matrix.

For more details, see Section 2.3.7, “About matrix objects”.

Usage notes
You can improve the performance of matrix reports with:

- fewer queries
- WHERE clauses

Note: Cross-product groups always cause "fetching ahead." The reason for this is that to cross-tabulate the data in a cross-product group, Oracle Reports Builder must first fetch all of the data.

See also
Section 2.3.7, "About matrix objects"
Section 2.1.7, "About nested matrix reports"
Section 2.1.8, "About matrix with group reports"
Section 2.4.2, "About layout defaulting"
Section 4.5.1, "Creating a report"

1.4 Wizards

Oracle Reports Builder includes wizards to help you quickly and easily define a report and add objects to it. The topics in this section describe each Oracle Reports Builder wizard.

- About the Report Wizard
- About the Report Block Wizard
- About the Data Wizard
1.4.1 About the Report Wizard

The Report Wizard helps you to quickly and easily define a single-query report for both Web and paper layouts. Oracle Reports Builder uses what you specify on each page of the wizard to create a data model and layout for your report. After the wizard has created the report, you can modify it using the Report Editor views. See Section 1.6.1, "About the Report Editor".

Re-entrancy
To re-enter the Report Wizard for an existing report:

- Click the report, then choose Tools > Report Wizard.

Using the Report Wizard
For help on the fields on any tab page of the wizard, click Help at the bottom of the tab page.

1.4.2 About the Report Block Wizard

The Report Block Wizard is a version of the Report Wizard. You can open an existing HTML document (Web page) and embed a report in your Web page using the Report Block Wizard to specify the layout of the data.

Access
To display the Report Block Wizard:

- In the Paper Layout view or Web Source view, choose Insert > Report Block.
- In the Paper Layout view, click the Report Block tool in the tool palette, then click in an open area of the Paper Layout view.

Using the Report Block Wizard
For help on the fields on any tab page of the wizard, click Help at the bottom of the tab page.

1.4.3 About the Data Wizard

The Data Wizard helps you to quickly and easily define a query, break groups, and totals for a multiquery report. After the wizard has created the data model, you can:

- modify the data model in the Data Model view.
- use the Data Wizard to create additional queries.
- use the Report Wizard to default the layout.
- modify the layout in the Paper Layout view, including reordering or adding new layout sections.

Access
To display the Data Wizard:

- In the Data Model view, choose Insert > Query.
Re-entrancy
To re-enter the Data Wizard for an existing query, do either of the following:

- Right-click the query, and choose Data Wizard.
- Click the query, then choose Edit > Settings.

Using the Data Wizard
For help on the fields on any tab page of the wizard, click Help at the bottom of the tab page.

1.4.4 About Graphs and the Graph Wizard
The Graph Wizard provides an easy way for you to add a wide variety of graphs to both paper-based and JSP-based Web reports. Oracle Reports Builder uses the information you specify on each page of the wizard to create an XML definition that describes the graph and renders to resulting look-and-feel of the graph at runtime.

For more information, see Chapter 39, "Building a Report with Graphs".

1.5 The Object Navigator
The topics in this section discuss the Object Navigator in Oracle Reports Builder.

- About the Object Navigator
- About Object Navigator views

1.5.1 About the Object Navigator
The Object Navigator provides a hierarchical display of all objects in a report or template, including attached libraries and program units.

Using the Object Navigator, you can:

- Create reports, parameters, PL/SQL program units, and attached libraries.
- Select and work with reports, queries, PL/SQL program units and libraries, data model objects, layout objects, and parameter form objects.
- Display Report Editor views.
- Expand and collapse nodes.
- Search for objects.
- View objects by hierarchy or type.
- Display properties.
- Customize the Object Navigator.
- Drag and drop PL/SQL program units.

Access
To display the Object Navigator:
Click Finish or Cancel in the Report Wizard.

Open an existing report.

Choose Tools > Object Navigator.

Press F5.

See also
Section 4.2.4, "Setting preferences for the Object Navigator"

1.5.2 About Object Navigator views

The Object Navigator enables you to view objects by ownership hierarchy or by object type.

View > Change View > Ownership View displays objects in a parent-child hierarchy. For example, a query’s columns would appear underneath the query and a field would appear underneath the repeating frame that encloses it. This view can be a useful debugging tool because it enables you to easily see the relationships between objects.

View > Change View > Object Type View displays objects by their type. For example, all queries would appear underneath the Queries heading and all database columns underneath the Database Columns heading. This view can be useful when you want to quickly find objects in the Object Navigator.

See also
Section 4.2.4, "Setting preferences for the Object Navigator"

1.6 The Report Editor

The topics in this section discuss the Report Editor and its different views of a report.

About the Report Editor
About the Data Model view
About the Paper Layout view
About the Paper Design view
About the Paper Parameter Form view
About the Web Source view
About the tool palette and toolbar

1.6.1 About the Report Editor

The Report Editor is a work area in which you can manipulate the objects in your report directly or by changing properties in the Property Inspector. In the Report Editor window, you can navigate between different views of your report: the Data Model view, Paper Layout view, Paper Design view, Paper Parameter Form view, and Web Source view.

Note: By default the File > Administration option is always disabled.
1.6.2 About the Data Model view

The Report Editor’s Data Model view is a work area in which you create, define, and modify data model objects (queries, groups, queries, groups, formula columns, summary columns, placeholder columns, system and user parameters, and data links) to be used in your report. In this view, objects and their property settings are represented symbolically to highlight their types and relationships. To create the query objects for your data model, you can use the Report Wizard, Data Wizard, or the Query tools in the tool palette.

Oracle Reports Builder uses the data model to determine what data to retrieve for the report. The data retrieved from the database may or may not appear in the report output.

Access
To display the Data Model view:

- In any of the Report Editor views, choose View > Change View > Data Model.
- Click the Data Model view button in the toolbar.
- In the Object Navigator, double-click the Data Model view icon next to the Data Model node.

1.6.3 About the Paper Layout view

The Report Editor’s Paper Layout view is a work area in which you can modify the format of your paper report. The default format for your report is defined by the information you specify in the Report Wizard. You can modify the format by working with layout objects (boilerplate text and graphic objects, frames, repeating frames, graphs, fields, anchors, file links, and report blocks). In this view, objects and their property settings are represented symbolically to highlight their types and relationships.

The Paper Layout view is similar to the Paper Design view, in that it is a work area in which you modify the format of your report. However, the Paper Design view displays only when you run your report, allowing you to preview your report and manipulate the actual, or live, data at the same time. In the Paper Design view, you can customize reports interactively, meaning that you can see the results immediately as you make each change.

Access
To display the Paper Layout view:

- In any of the Report Editor views, choose View > Change View > Paper Layout.
- Click the Paper Layout view button in the toolbar.
- In the Object Navigator, double-click the Paper Layout view icon next to the Paper Layout node.

1.6.4 About the Paper Design view

The Report Editor’s Paper Design view is a work area in which you can preview your paper report and manipulate the actual, or live, data at the same time. In the Paper Design view, you can customize reports interactively, meaning that you can see the results immediately as you make each change.
To edit your report, such as changing column size, the Paper Design view must be in Flex mode.

**Access**

The Paper Design view is displayed whenever you run a report. To run a report from the Object Navigator or any editor, click the Run Paper Layout button in the toolbar or choose Program > Run Paper Layout. To run a report from the Report Wizard, click Finish.

You can also display the Paper Design view in these ways:

- In any of the Report Editor views, choose View > Change View > Paper Design.

  **Note:** In the Object Navigator, there is no Paper Design node; this view is displayed only after running a report.

- Click the Paper Design view button in the toolbar.

**Usage notes**

To speed the execution of your report, avoid "fetching ahead" when sending report output to the Paper Design view. The following items can result in fetching ahead when referenced before the data on which they rely:

- total number of pages/panels
- grand totals
- break columns that are formulas
- break columns that have Value if Null specified

Matrix (cross-product) groups also cause fetching ahead. In order to cross-tabulate the data, Oracle Reports Builder must first fetch all of the data.

It should be noted that while these items slow down the Paper Design view, they do not affect performance when writing to a file or some other destination.

**Note:** A column can cause fetching ahead even if it is not displayed. For example, a grand total may not appear in the report output, but since it is in the report, fetching ahead may still occur when Oracle Reports Builder calculates it.

---

1.6.5 About the Paper Parameter Form view

The Report Editor’s Paper Parameter Form view is a work area in which you define the format of the report’s Runtime Parameter Form. To do it, you define and modify parameter form objects (fields and boilerplate). You can select pre-defined system parameters for your report using the Parameter Form Builder, or you can create your own.

When you run a report, Oracle Reports Builder uses the Paper Parameter Form view as a template for the Runtime Parameter Form. Fields and boilerplate appear in the Runtime Parameter Form exactly as they appear in the Paper Parameter Form view. If you do not define a Runtime Parameter Form in the Paper Parameter Form view, Oracle Reports Builder displays a default Runtime Parameter Form for you at runtime.
Note: At runtime, the Runtime Parameter Form displays only when running the paper report layout. For JSP-based Web reports, the Runtime Parameter Form displays when you run your report within Oracle Reports Builder for debugging purposes, but will not display at runtime. For more information, see Section 1.9.4, “About Parameter Forms for Web reports”.

Access
To display the Paper Parameter Form view:

- In any of the Report Editor views, choose View > Change View > Paper Parameter Form.
- Click the Paper Parameter Form view button in the toolbar.
- In the Object Navigator, double-click the Paper Parameter Form view icon next to the Paper Parameter Form node.

1.6.6 About the Web Source view

The Report Editor’s Web Source view displays the source code for your JSP-based Web report, including HTML, JSP, and XML tags. It is a Web page where you can view and add dynamic report blocks using the Report Block Wizard, and graphs using the Graph Wizard. Experienced Web developers can edit the Web source directly in this view using JSP tags, HTML, Java, and XML.

Access
To display the Web Source view, do any of the following:

- In any of the Report Editor views, choose View > Change View > Web Source.
- Click the Web Source button in the toolbar.
- In the Object Navigator, double-click the Web Source view icon next to the Web Source node.

Usage notes

- In the Web Source view, the following languages may appear garbled: Arabic, Central European languages, Cyrillic, Greek, Hebrew, Japanese, Thai, and Turkish. To work around this issue, you can set the font names for Oracle Reports Builder in uifont.ali (in $DOMAIN_HOME\config\fmwconfig\components\ReportsToolsComponent\<reports_tools_name>\tools\common) as follows:

```
rwbuilder
.....AR8MSWIN1256="Courier New"
.....CL8MSWIN1251="Courier New"
.....EE8MSWIN1250="Courier New"
.....EL8MSWIN1253="Courier New"
.....IN8MSWIN1255="Courier New"
.....JA16SJIS="MS Gothic"
.....TH8TISASCII="Andale Duospace WT"
.....TR8MSWIN1254="Courier New"
```

You can download a copy of the Andale Duospace WT (fixed-width) font from My Oracle Support (http://support.oracle.com). The patch ID is 2638552.
When performing a Find/Replace operation in the Web Source view and running in an Asian language (for example, Japanese) on Windows, Oracle Reports Builder fails. This problem does not occur on UNIX.

See also
Section 1.2.2, "About Web Reports"
Section 2.2.1, "About JavaServer Pages (JSPs) and servlets"
Section 4.6.3, "Adding report data to an existing Web page (HTML file)"
Section 4.6.4, "Adding a report block to a Web page"
Section 4.9.8.2.2, "Adding a graph to a JSP-based Web report"
"Oracle Reports JSP tags" in the Reference section of the Oracle Reports online Help

1.6.7 About the tool palette and toolbar

The tool palette and toolbar contain tools used to manually create or manipulate objects in the Report Editor views (excluding the Web Source view). Each tool appears as an icon. Some tools, such as the Select tool, are common to tool palettes in all Report Editor views. Other tools are specific to the views in which they appear. In Oracle Reports Builder, run your cursor over a tool to display the hint text that identifies the tool.

Tool palette
The tool palette is positioned along the left side of the Report Editor views. Click a tool to activate it for a single operation, or double-click a tool to "lock" it for multiple operations. You can hide the tool palette by choosing View > Tool Palette to deselect it.

Toolbar
The toolbar is positioned along the top of the Report Editor views. To use the tools in the toolbar, click the desired tool to perform the action. All toolbar tools also have menu equivalents. If the tool is designed to perform an action on a group of objects, it appears grayed out until one or more objects are selected. Then clicking the tool performs the action on the selected object(s).

See also
Appendix A, "Tool Palette and Toolbar Reference"

1.7 Data Model Objects

The topics in this section discuss basic concepts of data model objects; for more advanced concepts, see Section 2.3, "Data Model Objects".

- About queries
- About groups
- About database columns
- About data links
- About Query Builder
### 1.7.1 About queries

Queries provide the data for your report. You create a query using the Report Wizard, Data Wizard, or manually using the query tools in the Data Model tool palette. Queries can select data from any data source (Oracle, XML, JDBC, Text, or your own data source that you can access through the pluggable data source (PDS) API). You can also use a **REF CURSOR** to create queries (see Section 2.6.10, "About REF CURSOR queries").

#### Single-query reports

Reports built using one query are the simplest reports. The most popular formats for single-query reports are tabular, mailing label, form letter, and break (either group above or group left). In one report, you can display one query’s data any number of times, even in different formats. You can query data without including it in the report output. This is useful for establishing relationships between multiple queries, performing calculations, and so on.

The figure below shows the data of one query formatted various ways.

**Figure 1–10  Formatting the same data in different ways**

---

#### TABULAR

<table>
<thead>
<tr>
<th>Name</th>
<th>Address</th>
<th>City</th>
<th>State</th>
<th>Zip</th>
</tr>
</thead>
<tbody>
<tr>
<td>EVERY MOUNTAIN</td>
<td>574 SHURY RD.</td>
<td>CUPERTINO</td>
<td>CA</td>
<td>93011</td>
</tr>
<tr>
<td>JOCKEYSPORTS</td>
<td>345 VEEBURGE</td>
<td>BELMONT</td>
<td>CA</td>
<td>90711</td>
</tr>
<tr>
<td>JUST TENNIS</td>
<td>HILLVIEW MALL</td>
<td>BURLINGAME</td>
<td>CA</td>
<td>97534</td>
</tr>
<tr>
<td>K + Y SPORTS</td>
<td>3476 EL PASO</td>
<td>SANTA CLARA</td>
<td>CA</td>
<td>91003</td>
</tr>
</tbody>
</table>

#### MAILING LABEL

<table>
<thead>
<tr>
<th>Name</th>
<th>Address</th>
<th>City</th>
<th>State</th>
<th>Zip</th>
</tr>
</thead>
<tbody>
<tr>
<td>EVERY MOUNTAIN</td>
<td>574 SHURY RD.</td>
<td>CUPERTINO</td>
<td>CA</td>
<td>93011</td>
</tr>
<tr>
<td>JUST TENNIS</td>
<td>HILLVIEW MALL</td>
<td>BURLINGAME</td>
<td>CA</td>
<td>97534</td>
</tr>
<tr>
<td>JOCKEYSPORTS</td>
<td>345 VEEBURGE</td>
<td>BELMONT</td>
<td>CA</td>
<td>90711</td>
</tr>
<tr>
<td>K + Y SPORTS</td>
<td>3476 EL PASO</td>
<td>SANTA CLARA</td>
<td>CA</td>
<td>91003</td>
</tr>
</tbody>
</table>

#### FORM LETTER

May 31, 1991

EVERY MOUNTAIN
574 SHURY RD.
CUPERTINO, CA 93011

Dear Customer:

Because you are one of our most valued customers, we would like to invite you to our fiscal year-end sales bonanza. Tennis racquets, tennis balls, and sports apparel will all be significantly marked down. In fact, most prices will be 90% off suggested retail price.

The sale begins on June 15 at our Belmar warehouse. If you are unable to attend but still wish to take advantage of these spectacular prices, call 1-800-442-4667 to place your order.

Thank you for your business.

J. King

President, Sweat Sporting Goods

#### BREAK

<table>
<thead>
<tr>
<th>Deptno</th>
<th>Explo</th>
<th>Itemno</th>
<th>Sal</th>
</tr>
</thead>
<tbody>
<tr>
<td>10</td>
<td>7363</td>
<td>LANE</td>
<td>5800</td>
</tr>
<tr>
<td>7634</td>
<td>5455</td>
<td>MILLER</td>
<td>1300</td>
</tr>
</tbody>
</table>

| 20     | 7339  | SMITH  | 800  |
| 7316   | 5956  | ADAMS  | 1100 |
| 7302   | 5902  | ROOD   | 3000 |
| 7300   | 5908  | SCOTT  | 3000 |
| 7356   | 5956  | JONES  | 2200 |
Notice that the last report style (group left break) seems to use an entirely different query for its data than the first three. However, the data it displays was hidden in the other reports, and vice versa. With Oracle Reports Builder, you can query data without including it in the report output. This is useful for establishing relationships between multiple queries, performing calculations, and so on.

**Multiquery reports**
A report may contain any number of queries. Multiquery reports are useful when you want to:

- produce multipart unrelated query reports.
- produce multipart related query reports.
- make your queries easier to maintain (often a report with a complex query containing embedded `SELECT` statements and joins can also be created with multiple simple queries that are linked; the latter are often easier for others to understand and maintain).
- display the same data twice in a report with different sorting criteria.

If you create a report with multiple queries, you can either leave the queries unrelated, or establish a relationship between them using a data link.

**Multipart unrelated query reports**
If you do not link the queries, you will produce a multipart unrelated query report (commonly called a master/master report). These types of reports display lists of unrelated data. For example, in the report below, one query selects products and another selects customers. Notice that there is no relationship between the products and customers.

*Figure 1–11 Unrelated queries*

<table>
<thead>
<tr>
<th>ProdId</th>
<th>Name</th>
<th>CustId</th>
<th>Name</th>
</tr>
</thead>
<tbody>
<tr>
<td>100850</td>
<td>ACE TENNIS RACKET</td>
<td>101</td>
<td>TKB SPORT SHOP</td>
</tr>
<tr>
<td>100851</td>
<td>ACE TENNIS RECKET</td>
<td>102</td>
<td>VOLLEYWHITE</td>
</tr>
<tr>
<td>100870</td>
<td>ACE TENNIS BALLS-PACK</td>
<td>103</td>
<td>JUST TENNIS</td>
</tr>
<tr>
<td>100871</td>
<td>ACE TENNIS BALLS-PACK</td>
<td>104</td>
<td>EVERY MOUNTAIN</td>
</tr>
<tr>
<td>100890</td>
<td>ACE TENNIS NET</td>
<td>105</td>
<td>E + T SPORTS</td>
</tr>
<tr>
<td>101850</td>
<td>SP TENNIS RACKET</td>
<td>106</td>
<td>SHAPE UP</td>
</tr>
<tr>
<td>101859</td>
<td>SP TENNIS RACKET</td>
<td>107</td>
<td>WOMENS SPORTS</td>
</tr>
<tr>
<td>102130</td>
<td>FU: GUIDE TO TENNIS</td>
<td>108</td>
<td></td>
</tr>
<tr>
<td>200357</td>
<td>SB ENERGY BAR-6 PACK</td>
<td>109</td>
<td></td>
</tr>
<tr>
<td>200380</td>
<td>SB VITA SNACK-6 PACK</td>
<td>110</td>
<td></td>
</tr>
</tbody>
</table>

**Multipart related query reports**
In many reports, the data fetched for one part of the report is determined by the data fetched for another part. This is termed a "master/detail," or "parent/child," relationship, and is defined with a data link between two queries. When you run a master/detail report, each row of the master (or parent) query will cause the detail (or child) query to be executed, retrieving only matching rows.

**Usage notes**
- External queries are no longer supported.
Reduce the number of queries in your report as much as possible. In general, the fewer queries you have, the faster your report will run. While multiquery data models are often easier to understand, single-query data models tend to execute more quickly.

Queries are processed on the server.

To restrict the number of pages that a certain user can produce, insert a record into the PRODUCT_PROFILE table for that user.

The only times you should use multiquery data models are:

- when you’re fetching many large columns from the parent and only a few small columns from the child.
- when you’re trying to do things that the query type, such as a SQL query, does not support directly (for example, multiway outer join).
- when you have complex views (for example, distributed queries or GROUP BY queries).
- when you need but do not have or want to use a view.

**Rationale**

For a single-query report, Oracle Reports Builder opens only one cursor to fetch all of the master and detail records. For a two-query report, Oracle Reports Builder opens two cursors—one for each query—after appending the detail query’s link to the WHERE clause of the detail query. Therefore, for each master record fetched in the master query, Oracle Reports Builder must rebind, execute, and fetch data from the detail query.

**See also**

Section 2.3.5, "About non-linkable queries"

Section 4.8.1, "Creating a query"

### 1.7.2 About groups

Groups are created to organize the columns in your report. Groups can do two things: separate a query’s data into sets, and filter a query’s data.

When you create a query, Oracle Reports Builder automatically creates a group that contains the columns selected by the query. You create additional groups to produce break levels in the report, either manually in the Data Model view or by using the Report Wizard to create a group above or group left report.

Create groups when you want to treat some columns differently than others. For example, you create groups to:

- produce subtotals (that is, totals at a more granular level).
- create breaks or cross products in your report output.

With the exception of cross-product groups, all user-created groups are called break groups.

**Break groups**

You create break groups to produce subtotals, print columns in a different direction, create breaks, and so on. A break group suppresses duplicate values in sequential records. For example, Oracle Reports Builder can select the department number for each record; however, the duplicate department numbers are not printed.
Cross-product groups
You create cross-product groups to perform mathematical cross products, which are generally used to create matrix reports.

Group filters
Filters enable you to conditionally remove records selected by your queries. Groups can have two types of filters:

- Oracle Reports Builder packaged filters:
  - First, to display only the first n records for the group (for example, the first 5 records)
  - Last, to display only the last n records for the group
- User-created filters, using PL/SQL.

See also
Section 2.3.6, "About links versus groups"
Section 2.6.9, "About group filters"
Section 1.3.2, "About group above reports"
Section 1.3.3, "About group left reports"
Section 2.1.8, "About matrix with group reports"
Section 4.5.1, "Creating a report"
Section 4.5.2, "Creating a multiquery group above report"
Section 4.8.7, "Creating a break group"
Section 4.8.8, "Creating a matrix (cross-product) group"

1.7.3 About database columns
A database column represents a column that is selected by the query, containing the data values for a report. For each column that you select in your query, Oracle Reports Builder automatically creates a column in the data model of your report. If you want to perform summaries and computations on database column values, you can create new columns manually in the Data Model view (for summary and formula columns) or by using the Report Wizard (for summary columns). You can also reassign one or more columns to a group or groups you have created.

In addition to the traditional column types (for example, date, number, character), Oracle Reports Builder also supports graphics or images columns, which are columns whose values can be:

- graphics or images stored directly in the database. Such a column is usually of data type LONG or LONG RAW and contains a graphics or images. In this case, specify the graphic’s format in the column’s properties.
- file names. The values of such columns are pointers to files stored in the operating system. In this case, specify in the column’s properties that its values are file contents (Read from File) and the format of the files. Many graphics or images formats are supported, including BMP, CALS, CGM, GIF, JFIF, PCD, PCX, PICT, RAS, TIFF, and so on.
1.7.4 About data links

A data link (or parent-child relationship) relates the results of multiple queries. A data link can establish these relationships:

- between one query’s column and another query’s column.
- between one query’s group and another query’s group (this is useful when you want the child query to know about its parent’s data).

A data link causes the child query to be executed once for each instance of its parent group. The child query is executed with the values of the primary key used by the parent.

When a report with a data link is executed, the data link is converted into a SQL clause (as specified in the link’s Property Inspector) and appended to the child query if Oracle Reports Builder can parse the query.

Important note: If the query cannot be parsed, the query is not modified (for example, Oracle Reports Builder has no way to modify how the data is fetched when the query is defined for a pluggable data source).

Although links are commonly equijoins (for example, \WHERE DEPTNO=DEPTNO\), you can create links with various SQL clauses (that is, \WHERE\, \HAVING\, or \START WITH\) and conditions. If your database has database constraints, you can create a data link that derives its SQL clause and condition from the constraints. You can view the \SELECT\ statements for the individual parent and child queries in Oracle Reports Builder, but cannot view the \SELECT\ statement that includes the clause created by the data link you define.

Example

For the report below, the following link was defined:

Figure 1–12 Sample data link

<table>
<thead>
<tr>
<th>Parent Group</th>
<th>SQL Clause</th>
<th>Parent Column(s)</th>
<th>Condition</th>
<th>Child Column(s)</th>
</tr>
</thead>
<tbody>
<tr>
<td>G. ORD</td>
<td>WHERE</td>
<td>ORDID =</td>
<td></td>
<td>ORDID</td>
</tr>
</tbody>
</table>

The default group of the master query (containing the columns "Order ID" and "Customer") is the parent group; the detail query (the query to which "Item", "Product", and "Amount" belong) is the child query.
### About Query Builder

Query Builder is an easy-to-use data access tool designed for analysts, managers, and other business professionals. It provides a logical and intuitive means to access information from your organization's databases for analysis and reporting.

Query Builder is designed for professionals who do not have a computer programming or database background. Because of its powerful query features and its support of Structured Query Language (SQL) statements, experienced database users and programmers will find that Query Builder serves many of their needs as well.

In Query Builder's graphical Query window, you can specify a request for data from your organization's database(s). The request for data is called a query.

You can use Query Builder to define almost any query that you would build using a SQL `SELECT` statement. Query Builder automatically generates the appropriate `SELECT` clause based on columns displayed in the Query Builder workspace.

### See also

- Section 2.3.6, "About links versus groups"
- Section 2.3.5, "About non-linkable queries"
- Section 4.8.9, "Creating a data link"
1.8 Layout Objects

The topics in this section discuss basic concepts of layout objects; for more advanced concepts, see Section 2.4, "Layout Objects".

- About frames
- About repeating frames
- About frame and repeating frame sizing
- About fields
- About boilerplate objects

1.8.1 About frames

Frames surround other objects and protect them from being overwritten or pushed by other objects. For example, a frame might be used to surround all objects owned by a group, to surround column headings, or to surround summaries.

When you default the layout for a report, Oracle Reports Builder creates frames around report objects as needed; you can also create a frame manually in the Paper Layout view. See Section 1.6.3, "About the Paper Layout view".

Create frames when you want to:

- group together objects to ensure they maintain their relative positions during printing.
- delineate sections in your report.
  
  **Example:** You want the top of each page to have a tabular format, but the bottom of each page to have a matrix format.
- protect other objects from being overwritten.
  
  **Example:** A summary is centered under two repeating frames. Defaulting rules state that the summary must remain at a fixed distance from only the first object that can overwrite it; therefore, the summary is in danger of being overwritten by the second repeating frame. Enclosing both repeating frames with a frame will force the summary to maintain a fixed distance from both of them, and it will not be overwritten.
- prevent an object from printing until other objects finish printing.
  
  **Example:** A summary is centered under two repeating frames. According to defaulting rules, the summary will print as soon as the first repeating frame finishes printing. Create a frame around the two repeating frames to ensure the summary prints after both repeating frames have finished printing.

See also

Section 4.9.1.2, "Creating a frame or repeating frame"

1.8.2 About repeating frames

Repeating frames surround all of the fields that are created for a group's columns. The repeating frame prints (is fired) once for each record of the group.

When you default the layout for a report, Oracle Reports Builder generates one repeating frame for each group in the data model, and places one field inside it for each of the group's columns. Repeating frames can enclose any layout object, including other repeating frames. Nested repeating frames are typically used to produce
master/detail and break reports. For each record of the outer repeating frame, Oracle Reports Builder will format all related records of the enclosed repeating frame.

You can also create a repeating frame manually in the Paper Layout view. See Section 1.6.3, "About the Paper Layout view".

See also
Section 4.9.1.2, "Creating a frame or repeating frame"

1.8.3 About frame and repeating frame sizing

For each object or record, a frame or repeating frame’s size can be expandable, contractible, variable, or fixed (specified by the Horizontal Elasticity and Vertical Elasticity properties). For example, you can set the properties to specify that it should be fixed in size horizontally, but expand vertically if a record requires more space.

In the figure below, notice that there are four records for department 20, but only one record each for departments 10 and 30. The repeating frame has expanded vertically to accommodate department 20’s additional records.

Figure 1–14 Repeating frame sizing

Frames or repeating frames that contract horizontally or vertically reduce in size when an object or record requires less space than the frame or repeating frame’s initial size. A frame or repeating frame may also be variable in size: it expands or contracts based on the size of the value it displays. Also, if a frame or repeating frame is fixed in size and an object or record’s data requires a larger field than it can contain, the remaining data will be pushed onto the following page(s) in the same x and y coordinates.

See also
Section 4.9.1.2, "Creating a frame or repeating frame"

1.8.4 About fields

Fields are placeholders for parameters, columns, and such values as the page number, current date, and so on. If a parameter or column does not have an associated field, its values will not appear in the report output. A field is owned by the object surrounding it, which is the first enclosing object (either a frame or repeating frame).

When you default the layout for a report, Oracle Reports Builder generates one field for each column, and places each field inside of a repeating frame. You can also create a field manually in the Paper Design view, Paper Layout view or Paper Parameter Form view.
1.8.5  About boilerplate objects

A boilerplate object is any text, lines, or graphics that appear in a report every time it is run.

Oracle Reports Builder creates one boilerplate object for each label selected in the Report Wizard (it is named \texttt{B\_columnname}). For example, if a column is named \texttt{ENAME}, for the column a boilerplate object containing \texttt{ENAME} is generated. For some report types, Oracle Reports Builder also generates lines under the labels.

You can also create a boilerplate objects manually in the Paper Design view, Paper Layout view, or Paper Parameter Form view using any of the following tools in the tool palette:

- Arc tool
- Ellipse tool
- File Link
- Freehand tool
- Line tool
- Polygon tool
- Polyline tool
- Rectangle tool
- Rounded Rectangle tool
- Text tool

Boilerplate from files

If you have text, graphics, or HTML in a file that you would like to display as boilerplate in your report, you can link to the file, as described in the following procedures:

- Section 4.9.2.6, "Linking a boilerplate text object to a file"
- Section 4.9.8.1.2, "Linking an image object to a file"
- Section 4.9.2.7, "Linking an HTML text object to a file"

Linking to a file means that the contents of the file are pulled into the boilerplate object each time the report is run. In this way, you can ensure that your output includes the most recent changes to the file.
You can also link a boilerplate image object to a URL where the image is located. See Section 4.9.8.1.3, "Linking an image object to a URL".

---

**Note:** These procedures are for paper-based reports only. File Link objects are not implemented in JSP-based Web reports.

---

**See also**
Section 1.9.3, "About Parameter Form boilerplate"
Section 4.9.2.1, "Creating a boilerplate object for text"
Section 4.9.2.2, "Creating a boilerplate object for text that displays every other page"
Section 4.9.2.5, "Referencing a field in boilerplate text"
Section 4.9.11.8, "Rotating a boilerplate object"

## 1.9 Parameter Form Objects

The topics in this section discuss basic concepts of Parameter Form objects; for more advanced concepts, see Section 2.5, "Parameter Form Objects".

- About parameters
- About Parameter Form fields
- About Parameter Form boilerplate
- About Parameter Forms for Web reports

### 1.9.1 About parameters

A parameter is a variable whose value can be set at runtime (for example, from the Runtime Parameter Form or the command line). Parameters are especially useful for modifying SELECT statements and setting PL/SQL variables at runtime.

Oracle Reports Builder automatically creates a set of system parameters at runtime, but you can create your own as well. You can create parameters to replace either single literal values or entire expressions in any part of a query. You can reference parameters elsewhere in the report, such as in PL/SQL constructs providing conditional logic for the report.

---

**Note:** While you can delete or rename a user parameter, you cannot delete or rename a system parameter.

---

Parameter values can be specified in these ways:

- Accepting the default parameter values (default values are set in the Parameter properties, and you can control whether the values are displayed at runtime on the Runtime Parameter Form).

- Typing the parameter value(s) as arguments on the command line (where applicable). Parameters specified on the command line override the equivalent system parameter values set in the report definition. For detailed information about command line arguments, see the "Command Line Keywords" appendix in the Publishing Reports to the Web with Oracle Reports Services, or the Oracle Reports online Help.
Choosing from a list or entering the parameter value(s) in the Runtime Parameter Form.

System parameters
Oracle Reports is shipped with the following system parameters. You can change their default values as described above.

Table 1–1  System parameter descriptions

<table>
<thead>
<tr>
<th>System Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>COPIES</td>
<td>Is the number of report copies that should be made when the report is printed.</td>
</tr>
</tbody>
</table>
| DESFORMAT        | Is either:  
  - the output format for the report (for example, PDF, HTML, HTMLCSS, RTF, XML, SPREADSHEET, DELIMITED, or DELIMITEDDATA for bitmapped reports).  
  - the printer definition to use when formatting the report when DESTYPE=FILE and DESNAME=filename. If MODE=BITMAP, this is the name of the printer. If MODE=CHARACTER, this is the character mode printer definition file (.prt file). |
| DESNAME          | Is the name of the output device (for example, the file name, printer's name, mail user ID). |
| DESTYPE          | Is the type of device that will receive the report output (for example, SCREEN (to format the report using screen fonts), FILE, PRINTER, MAIL, SYSOUT, CACHE, or LOCALFILE. |
| MODE             | Is whether the report should run in CHARACTER mode or BITMAP. |
| ORIENTATION      | Is the print direction for the report (LANDSCAPE, PORTRAIT, DEFAULT). |
| PRINTJOB         | Is whether the Print Job dialog box should appear before the report is run. |

User parameters
You can create a user parameter in the following ways:

- Create a parameter in the Object Navigator.
- Use a bind parameter reference in a query, which causes Oracle Reports Builder to automatically create the parameter the first time it is referenced (see Section 2.3.4.1, "About bind references").

See also
Section 2.3.4, "About referencing columns and parameters"
Section 4.11.1, "Using a pre-defined system parameter"
Section 4.11.2, "Creating a user parameter"
Section 4.11.3, "Creating a list of values (LOV) for a parameter"
Section 4.11.4, "Validating a parameter value at runtime"
Section 4.11.6, "Selecting parameters to include in the Runtime Parameter Form"
Section 4.11.9, "Passing parameters to reports running in batch mode"
1.9.2 About Parameter Form fields

Fields in the Paper Parameter Form view (Section 1.6.5, ”About the Paper Parameter Form view”) act as placeholders for parameters. They define the formatting attributes for the parameters displayed in the Runtime Parameter Form. By default, one field is created for each parameter that you select in the Parameter Form Builder.

See also
Section 1.8.4, ”About fields”
Section 4.11.5, ”Creating a default Parameter Form”
Section 4.11.7, ”Displaying the Parameter Form at runtime”

1.9.3 About Parameter Form boilerplate

Boilerplate in the Paper Parameter Form view refers to text and graphics that appear in the Runtime Parameter Form each time it is run; for example, a label denoting a particular parameter is boilerplate text created by Oracle Reports Builder. Lines or boxes that you create in the layout are also considered boilerplate, and also any added text.

Boilerplate enables you to customize the Runtime Parameter Form. By default, a boilerplate label is produced for each field that appears on the Runtime Parameter Form.

See also
Section 1.8.5, ”About boilerplate objects”
Section 4.11.5, ”Creating a default Parameter Form”
Section 4.11.7, ”Displaying the Parameter Form at runtime”

1.9.4 About Parameter Forms for Web reports

You can design a Parameter Form for both Web and paper reports. However, at runtime, the Runtime Parameter Form displays only when running the paper report layout. For JSP-based Web reports, the Runtime Parameter Form displays when you run your report within Oracle Reports Builder for debugging purposes, but will not display at runtime.

Because you now have the flexibility to display your reports on any Web page, the report may be just one object on a Web page containing many other portlets and objects, and parameters for the report may be retrieved from sources other than the Parameter Form. For example, parameters might be provided by the Web page to all portlets on the page. Therefore, it does not make sense to display a Runtime Parameter Form for JSP-based Web reports before the report is formatted.

In the absence of the Runtime Parameter Form, you will need to use an alternate method to provide required parameters to a JSP-based Web report designed with a Parameter Form. For example:

- When you design the report, set all parameters to a default value.
- If you run your report using a URL, provide the parameters through the URL.
- Create an HTML form that your report calls to provide parameter values, either as static values, or as a list of values using the Oracle Reports custom JSP tags.
- If the report displays as a portlet in a Web page, you can pass the page level parameters to the report.
Use the JSP tag `<rw:reports id="myReport" parameters="yourParameterList"/>`, where `yourParameterList` can be a Java variable. For example:

```jsp
<% String myParameterList="userid=scott/tiger&p_deptno=10"; %>
<wl:report id="myReport" parameters="<%= myParameterList %>">
```

For more information on creating a Parameter Form for a JSP-based Web report, see Chapter 42, "Building a Simple Parameter Form for a JSP-based Web Report".

---

**Note:** If you display your paper-based report on the Web, you can create an HTML Parameter Form by adding HTML header and footer tags using either:

- **the Property Inspector**: set the Before Form Value property and After Form Value property for the report
- **PL/SQL**: set format triggers using the `SRW.SET_BEFORE_FORM_ HTML` and `SRW.SET_AFTER_FORM_HTML` procedures.

---

See also

Section 1.2.2, "About Web Reports"

Section 1.6.5, "About the Paper Parameter Form view"

Section 1.11.1, "About the Runtime Parameter Form"

Section 2.5.1, "About Parameter Form HTML extensions"

1.10 The Property Inspector

The topics in this section discuss the Property Inspector in Oracle Reports Builder.

- About the Property Inspector
- About making multiple selections in the Property Inspector

1.10.1 About the Property Inspector

The Property Inspector is a window that enables you to access the properties of the currently selected object(s) in the Object Navigator, Report Editor, and Template Editor.

Every Oracle Reports Builder object (query, group, frame, parameter, and so on.) has associated properties that can be viewed using the Property Inspector. To get help on any property, click the property in the Property Inspector and press F1.

1.10.1.1 About making multiple selections in the Property Inspector

You can select multiple objects at the same time by using Shift+Click or Ctrl+Click in the navigators or the editors. When two or more objects are selected, a list of object names is displayed at the top of the Property Inspector.

The Intersection/Union button on the Property Inspector toolbar determines which properties are displayed in the property list when more than one object is selected. Toggling between Intersection and Union changes the list of properties displayed in the Property Inspector, but does not affect the setting of any property.
Properties that are common to two or more objects in a multiple selection are listed only once, and the property setting is displayed as follows:

- If the property has the same setting for all of the selected objects that have it in common, the common setting is displayed.
- If the property is set differently for the objects that have it in common, the string "*****" is displayed.

See also
Section 4.2.2, "Setting report properties"
Section 4.2.5, "Setting properties for an ASCII (character-mode) report"
Section 4.2.7, "Setting properties of multiple objects"
Section 4.2.8, "Comparing the properties of one object to another"

### 1.11 Runtime Views

The topic in this section discuss the views of a report shown at runtime.

- About the Runtime Parameter Form
- About the Previewer

#### 1.11.1 About the Runtime Parameter Form

The Runtime Parameter Form is a dialog box that optionally displays at runtime in which you can override default parameter values (for example, values that modify SELECT statements, route the report output to a specified device, and so on). You define the format of the Runtime Parameter Form in the Paper Parameter Form view. If you do not define a Runtime Parameter Form in the Paper Parameter Form view, Oracle Reports Builder displays a default Runtime Parameter Form for you at runtime.

Change the parameters as desired and then click the Run Paper Layout button in the toolbar to run the report.

Alternatively, you can click the Cancel Run button in the toolbar to cancel.

See also
Section 1.6.5, "About the Paper Parameter Form view"
Section 1.9.4, "About Parameter Forms for Web reports"
Section 4.11.7, "Displaying the Parameter Form at runtime"

#### 1.11.2 About the Previewer

The Previewer displays on your screen how the printed version of your report will look. In the Previewer, you can scroll though a single page of report output, page
through the entire report, and split the screen to view different sections of the same report concurrently. You can also perform the following actions:

**Table 1–3 Print previewer actions**

<table>
<thead>
<tr>
<th>To...</th>
<th>Click in the toolbar...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Print the report</td>
<td>the Print button</td>
</tr>
<tr>
<td>Specify page setup settings</td>
<td>the Page Setup button</td>
</tr>
<tr>
<td>Open a new Previewer</td>
<td>the New Previewer button</td>
</tr>
<tr>
<td>Close the Previewer</td>
<td>the Close Previewer button</td>
</tr>
<tr>
<td>Zoom in</td>
<td>the Zoom In button</td>
</tr>
<tr>
<td>Zoom out</td>
<td>the Zoom Out button</td>
</tr>
</tbody>
</table>

A physical page (or panel) is the size of a page that will be output by your printer. A logical page is the size of one page of your actual report (it can be any number of physical pages wide or long). The Previewer displays the logical pages of your report output, one at a time.

**Access**

To display the Previewer:
- choose **File > Print Preview**.

**Usage notes**

To speed the execution of your report, avoid "fetching ahead" when sending report output to the Previewer or Paper Design view. The following items can result in fetching ahead when referenced before the data on which they rely:

- total number of pages/panels
- grand totals
- break columns that are formulas
- break columns that have Value if Null specified

Matrix (cross-product) groups also cause fetching ahead. To cross-tabulate the data, Oracle Reports must first fetch all of the data.

It should be noted that while these items slow down the Previewer or Paper Design view, they do not affect performance when writing to a file or some other destination.

---

**Note:** A column can cause fetching ahead even if it is not displayed. For example, a grand total may not appear in the report output, but since it is in the report, fetching ahead may still occur when Oracle Reports calculates it.

---

**See also**

Section 4.7.16.3, "Displaying report output in the Previewer"

Section 4.7.17.2, "Printing a report from the Previewer"
1.12 Oracle Reports Components

The Oracle Reports components are:

<table>
<thead>
<tr>
<th>Component</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>rwbuilder</td>
<td>Starts Oracle Reports Builder.</td>
</tr>
<tr>
<td>rwr</td>
<td>Runs a report using the Oracle Reports Services in-process server.</td>
</tr>
<tr>
<td>rwclient</td>
<td>Parses and transfers a command line to the specified Reports Server.</td>
</tr>
<tr>
<td>rwserver</td>
<td>Invokes the Reports Server (through Oracle Enterprise Manager).</td>
</tr>
<tr>
<td>rwservlet</td>
<td>Translates and delivers information between either a Web server or a Java EE Container (for example, Oracle WebLogic Server) and the Reports Server, enabling you to run a report dynamically from your Web browser.</td>
</tr>
<tr>
<td>rwconverter</td>
<td>Converts one or more report definitions or PL/SQL libraries from one storage format to another.</td>
</tr>
</tbody>
</table>

All components listed in Table 1–4, except rwclient and rwserver, can be run from the command line. See the Reference > Command Line section of the Oracle Reports online Help for detailed information about the components and command line keywords. Refer to Publishing Reports to the Web with Oracle Reports Services for information about managing and monitoring Reports Server, Reports Tools and Oracle Reports Bridge through Oracle Enterprise Manager or OPMN commands.

See also

Section 4.7.2, "Running a report from the command line"
Section 4.7.3, "Running a report using a command file"
Advanced Concepts

This chapter introduces the concepts for advanced users of Oracle Reports. Each topic in this chapter is also included in the Advanced Concepts section of the Oracle Reports online Help.

Topics are grouped into the following sections:

- Section 2.1, "Reports"
- Section 2.2, "Web Reports"
- Section 2.3, "Data Model Objects"
- Section 2.4, "Layout Objects"
- Section 2.5, "Parameter Form Objects"
- Section 2.6, "PL/SQL"
- Section 2.7, "Templates"
- Section 2.8, "Output Formats and Capabilities"
- Section 2.9, "Data Sources"
- Section 2.10, "Debugging Tools"

2.1 Reports

The topics in this section build on the basic concepts discussed in Section 1.2, "Reports".

- About report titles
- About report sectioning and sections
- About the report unit of measurement
- About the report dimensions
- About conditional formatting
- About nested matrix reports
- About matrix with group reports

2.1.1 About report titles

You can add a title to a report in either of the following ways:

- Manually, by creating a boilerplate text object in the margin of the Paper Layout view.
Typing in the **Title** field on the Style page of the Report Wizard.

When you use the Report Wizard to add a title and *do not* select a template for your report output, the title is inserted into the margin of the report with default attributes defined by Oracle Reports Builder. You can modify the attributes in the Paper Layout view.

When you use the Report Wizard to add a title, and *do* select a predefined template or a user-defined template file for your report output, Reports Builder looks for a boilerplate text object named **B_OR$REPORT_TITLE** defined for the selected template:

- If **B_OR$REPORT_TITLE** exists, the title is displayed using the attributes of this object, with the text you typed in the Report Wizard.
- If **B_OR$REPORT_TITLE** is not found, the title is displayed using the attributes defined by the Default properties (under the Title node in the Property Inspector) of the selected template.

---

**Note:** If you do not specify a title in the Report Wizard, the **B_OR$REPORT_TITLE** object is not copied to your report.

---

For layouts created using the Report Block Wizard, the title is inserted into the new layout as a group title rather than into the margin of the report. In this case, the attributes are set per the Default properties (under the Title node in the Property Inspector) of the selected template, and **B_OR$REPORT_TITLE** is ignored. If you do not select a template, the title uses the default attributes defined by Oracle Reports Builder.

**See also**

Section 4.5.6, "Adding a title to a report"

Section 4.12.5, "Formatting the report title in a template"

Section 2.7.1, "About templates"

### 2.1.2 About report sectioning and sections

Report sectioning enables you to define multiple layouts in the same report, each with a different target audience, output format, page layout, page size, or orientation. You can define up to three report sections, each with a body area and a margin area: the names of the sections are Header, Main, and Trailer. By default, a report is defined in the Main section. In the other sections, you can define different layouts, rather than creating multiple separate reports. If you want, you can use the margin and body of the Header and Trailer sections to create a Header and Trailer page for your reports.

In the Object Navigator, the report sections are exposed in the Object Navigator under the **Paper Layout** node as **Header Section**, **Main Section**, and **Trailer Section**.

You can specify the order in which the three sections of a report (Header, Main, and Trailer) are formatted using **SRW_SET_FORMAT_ORDER** or the Format Order of Sections property. This capability allows Oracle Reports to format any section first to create information that is only known at the time of formatting, such as page numbers, then use that information in the formatting of another section. As an example, this property is sometimes used to create a table of contents. For an example of using **SRW_SET_FORMAT_ORDER** for this purpose, see Chapter 35, "Building a Paper Report with a Simple Table of Contents and Index" and Chapter 36, "Building a Paper Report with a Multilevel Table of Contents".

---
For an example of using section-level distribution, see Chapter 37, "Bursting and Distributing a Report". This chapter covers defining distribution of a single section to multiple destinations, using the Repeat On property and a sample distribution XML file. For information about advanced section-level distribution and creating your own distribution XML file, see the "Creating Advanced Distributions" chapter in Publishing Reports to the Web with Oracle Reports Services.

Examples

Example 1
You can use sectioning and distribution to publish your report output in HTML, and also send a PostScript version to the printer.

Example 2
You can send an executive summary of the report to senior management, and also e-mail detailed breakdowns to individual managers. In this example, a single report with two report sections needs to be created: a portrait-sized summary section and a landscape-sized detail section. Use the Repeat On property to associate the detail section with a data model group that lists the managers and then alter the destination on each instance of the data model group to send the output to the appropriate managers.

See also
Section 2.8.3, "About report distribution"
Section 4.10.1, "Displaying a section layout view"
Section 4.10.2, "Creating a default layout for a section"

2.1.3 About the report unit of measurement

A report can be defined using inches, centimeters, or points. The unit of measurement is independent of the device on which you build the report. As a result, you can design reports that will run on any platform on which Reports Builder runs. You can change a report’s unit of measurement in these ways:

- Setting the Unit of Measurement property.
- Converting the report using rwconverter, specifying a different unit of measurement with the DUNIT keyword.
- Opening the report in a different environment. For example, if you open a character-mode report, Reports Builder will change the report’s unit of measurement to the bit-mapped environment's default. If you then save the report, it will be saved with the new unit of measurement.

2.1.4 About the report dimensions

A report page can have any length and any width. Because printer pages may be smaller or larger than your paper report’s "page," the concept of physical and logical pages is used. A physical page is the size of a page that is output by your printer. A logical page is the size of one page of your report; one logical page may be made up of multiple physical pages.

For each section (header, main, trailer) of a report:

- you specify the dimensions of the physical page (including the margin) using the Width property and Height property.
you specify the dimensions of the logical page (report page) in physical pages (printer pages) using the Horizontal Panels per Page property (width) and the Vertical Panels per Page property (height). For example, a Horizontal Panels per Page size of 1 means that each logical page is one physical page wide, and a Vertical Panels per Page size of 2 means that each logical page is two physical pages in height.

In this example, one logical page is made up of six physical pages. The logical page is three physical pages wide and two physical pages high. Consequently, Horizontal Panels per Page size is 3 and Vertical Panels per Page size is 2. If you wanted the logical page to be two physical pages wide and three physical pages high, you would specify a Horizontal Panels per Page size of 2 and a Vertical Panels per Page size of 3.

**Figure 2–1 Report dimensions**

<table>
<thead>
<tr>
<th>Physical Page Width</th>
<th>Physical Page Height</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Margin</th>
<th>Logical Page Width</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Logical Page Height</td>
</tr>
</tbody>
</table>

### 2.1.5 About fonts in reports

For detailed information about using and adding fonts in Oracle Reports, including font configuration files, font aliasing, troubleshooting font issues, and font types, refer to the "Managing Fonts in Oracle Reports" chapter in *Publishing Reports to the Web with Oracle Reports Services*.

### 2.1.6 About conditional formatting

Using the Conditional Formatting and Format Exception dialog boxes, you can specify output formatting attributes (font and color) for a selected layout object based on conditions that exist. The conditions that you define are called format exceptions.

You can display the Conditional Formatting dialog box from the Paper Layout view or Paper Design view in any of the following ways:

- Double-click the object to display the Property Inspector. Under the **General Layout** node, click the Conditional Formatting value field (labeled...).
- Display the shortcut menu (right-click in Windows) for the object.
- Click the object, then choose **Format > Conditional Formatting**.
The Format Exception dialog box displays when you click **New** or **Edit** in the Conditional Formatting dialog box, and enables you to quickly and easily specify output formatting attributes for a selected layout object based on defined conditions. After you specify conditions and formatting for the current layout object in the Format Exception dialog box, the entire definition is exported to a PL/SQL format trigger. If a format trigger already exists for the layout object, the definition in the Format Exception dialog box overwrites the existing trigger code when you confirm the Oracle Reports Builder prompt.

You can edit the format trigger manually through the PL/SQL Editor; however, if you subsequently modify the definition using the Format Exception dialog box, Oracle Reports Builder displays a prompt to overwrite the existing format trigger.

**See also**
Section 4.9.1.5, "Applying conditional formatting to a layout object"

### 2.1.7 About nested matrix reports

A nested matrix report is a matrix report in which at least one parent/child relationship appears within the matrix grid.

A nested matrix report has more than two dimensions; therefore, it has multiple dimensions going across or down the page. For example, see Figure 2–2. Notice that for each year there is a nested list of related departments. Also notice that the list of jobs (the across values) appears only once. Because the job values appear only once, a summary of each category of jobs can be made to line up with the values it summarizes.

---

**Note:** In a nested matrix report, where you create a matrix query that has a child matrix query, the fields on which you join should be separated into a separate group in your master matrix. Otherwise, on some platforms, only the first group prints.

---

For a detailed example, see Chapter 26, "Building a Nested Matrix Report".

**See also**
Section 2.3.7, "About matrix objects"
Section 1.3.7, “About matrix reports”

### 2.1.8 About matrix with group reports

A matrix with group report is a group above report with a separate matrix for each value of the master group. For example, for each year (master) in the report below there is a unique matrix that contains only that year’s departments and jobs. It defines that a summary of each job category may not line up with the values it summarizes because the position of each job category in the matrix may vary for each year.

A multiquery matrix with group report is similar to a nested matrix report in that it has more than two dimensions. For example, in the following report, notice that for each year there is a nested list of related departments.
Web Reports

2.2 Web Reports

The topics in this section build on the basic concepts discussed in Section 1.2.2, "About Web Reports".

■ About JavaServer Pages (JSPs) and servlets
■ About previewing JSP-based Web reports
■ About Web links for HTML output
■ About Web links for PDF output
■ About hyperlinks
■ About hyperlink destinations
■ About bookmarks
■ About application command line links
■ About before and after escapes
■ About style sheets
2.2.1 About JavaServer Pages (JSPs) and servlets

JavaServer Pages (JSPs) technology is an extension to the Java servlet technology from Sun Microsystems that provides a simple programming vehicle for displaying dynamic content on a Web page. A JSP is an HTML page with embedded Java source code that is executed in the Web server or application server. The HTML provides the page layout that is returned to the Web browser, and Java provides the business logic.

JSPs keep static page presentation and dynamic content generation separate. Because JSPs cleanly separate dynamic application logic from static HTML content, Web page designers who have limited or no Java programming expertise can modify the appearance of the JSP page without affecting the generation of its content, simply using HTML or XML tags to design and format the dynamically-generated Web page. JSP-specific tags or Java-based scriptlets can be utilized to call other components that generate the dynamic content on the page.

JSPs have the .jsp extension. This extension notifies the Web server that the page should be processed by a JSP container. The JSP container interprets the JSP tags and scriptlets, compiles the JSP into a Java servlet and executes it, which generates the content required, and sends the results back to the browser as an HTML or XML page.

A JSP can be accessed and run from a browser-based client, typically over the Internet or a corporate intranet. Unlike traditional client-server applications, JSP applications:

- run on a wider variety of client machines and browsers.
- run on thinner clients, thereby consuming fewer client-machine resources.
- scale to a larger number of simultaneous users.
- require less effort to install and maintain.

When a JSP is called for the first time, it is compiled into a Java servlet class and stored in the Web server’s memory. Because it is stored in memory, subsequent calls to that page are very fast, thereby avoiding the performance limitations seen with traditional Common Gateway Interface (CGI) programs, which spawn a new process for each HTTP request.

For additional background information about JSP technology, see Oracle Technology Network (OTN) at http://www.oracle.com/technetwork/java/index.html.

2.2.1.1 Using JSPs in Oracle Reports

Oracle Reports supports JavaServer Pages (JSPs) as the underlying technology to enable you to enhance Web pages with information retrieved using Oracle Reports Builder.

In Oracle Reports, you use JSPs to embed data retrieved using the data model into an existing Web page to create a JSP-based Web report. You can create new JSP reports, or save existing reports as JSP reports. New reports are by default saved as JSP reports. The benefit of saving reports as JSPs is that JSPs are text files that are easy to edit as opposed to, for example, the binary .rdf format. When a report is saved as a JSP file, the data model is embedded using XML tags. The entire report can now be defined using XML tags and saved as an XML file.

Using the Oracle Reports custom JSP tags, you can easily add report blocks and graphs to existing JSP files. These tags can be used as templates to enable you to build and insert your own data-driven Java component into a JSP-based Web report. Not only
can you edit the HTML or XML code that encapsulates the report block, but you can also edit the report block in the JSP itself, by modifying, adding or deleting their bodies and attributes.

The Report Editor's Web Source view displays the source code for your Web report, including HTML, XML, and JSP tags.

By default, a new JSP created in Oracle Reports Builder contains the following:

```html
<%@ page contentType="text/html;charset=ISO-8859-1" %>
```

If you are creating your JSP outside Oracle Reports Builder, you should ensure that it contains similar encoding information.

In prior releases, Oracle Reports introduced Web links that you can add to paper-based reports, which become active when you display your paper report in a Web browser or PDF viewer. For JSP reports, hyperlinks have to be created manually, and if the hyperlinks need to substitute data values, the data values must be provided through the `rw:field` JSP tag. For example:

```html
```

### 2.2.1.2 Opening or running an encoded JSP-based Web report

If your JSP-based Web report's character encoding (for example, EUC-JP) differs from the character set portion of the `NLS_LANG` environment variable (for example, JA16SJIS), you will get the following errors:

- When running the JSP file:
  
  REP-6106 or REP-6104 with `javax.servlet.jsp.JspException` (multibyte)
  REP-0495 Unable to tokenize the query (singlebyte)

- When opening the JSP file using Oracle Reports Builder:

  REP-0069 Internal Error or REP-6106

To work around this issue, you must ensure that your JSP-based Web report's character encoding matches the IANA encoding corresponding to Oracle Reports Builder's character set portion of the `NLS_LANG` environment variable.

For example:

- JSP-based Web report encoding:

  ```html
  <%@ page contentType="text/html;charset=EUC-JP" %>
  <META http-equiv="Content-Type" content="text/html;charset=EUC-JP">
  
  This JSP file must be encoded in the character set (EUC-JP).

- Oracle Reports Builder encoding:

  ```
  NLS_LANG=JAPANESE_JAPAN.JA16EUC
  ```

  In this example, the JSP-based Web report's encoding (EUC-JP) matches Oracle Reports Builder's character set portion of NLS_LANG; that is, JA16EUC.

### 2.2.1.3 Embedding a character set in a JSP file dynamically

In Oracle Reports, Web report templates are configured for Western European character encoding by default. However, for other languages, you can specify the
character encoding for every JSP file by using both the `charset` attribute of the `<Meta>` tag and the `<%@page%>` page directive.

To dynamically associate the appropriate character encoding with the JSP file, you can make the following modifications:

1. Edit the `rw*.html` files and the `blank_template.jsp` file, as follows:
   - Modify the page directive to read:
     ```jsp
     <%@ page contentType="text/html;charset=yourIANAencoding" %>
     ```
     where:
     `yourIANAencoding` is the IANA encoding name that corresponds to the `NLS_CHARACTERSET` portion of the `NLS_LANG` variable.
   - Modify the `<Meta>` tag inside the `<Head>` tag to read:
     ```html
     <meta http-equiv="Content-Type" content="text/html;charset=yourIANAencoding" />
     ```

2. Edit the `template.xsl` (`ORACLE_HOME/reports/templates/`) file, as follows:
   - Modify the `<xsl:output>` tag to read:
     ```xml
     <xsl:output
       method="jsp"
       indent="yes"
       encoding="yourIANAencoding"
     />
     ```
     where:
     `yourIANAencoding` is the IANA encoding name that corresponds to the `NLS_CHARACTERSET` portion of the `NLS_LANG` variable.
   - Add the page directive to the file:
     ```jsp
     <%@ page contentType="text/html;charset=yourIANAencoding" %>
     ```
   - Add or modify the `<META>` tag inside the `tag`:
     ```html
     <meta http-equiv="Content-Type" content="text/html;charset=yourIANAencoding" />
     ```
     where:
     `yourIANAencoding` is the IANA encoding name that corresponds to the `NLS_CHARACTERSET` portion of the `NLS_LANG` variable.

See also
Topics "Oracle Reports JSP tags" and "Oracle Reports XML tags" in the Reference section of the Oracle Reports online Help

### 2.2.2 About previewing JSP-based Web reports
You can preview a JSP-based Web report by clicking the Run Web Layout button in the toolbar, or by choosing Program > Run Web Layout, to run the Web Source. Reports Builder displays Web reports in your default browser.
It is not necessary that you have Reports Server configured to use this functionality. Oracle Reports Builder uses the standalone Oracle WebLogic Server for running a report to Web layout.

### Document Root

By default, the Oracle Reports Builder document root directory is 
$DOMAIN_HOME/servers/<managed_server_name>/tmp/_WL_user/reports_<version>/<dir_name>/web.war. It can be configured in the Oracle Reports Builder configuration file (rwbuilder.conf) as follows:

```bash
$DOMAIN_HOME/servers/<managed_server_name>/tmp/_WL_user/reports_<version>/<dir_name>/web.war
```

The end user can also override this configurable docroot from the command line using the `WEBSERVER_DOCROOT` command line keyword. If your JSP depends on external files, such as images, style sheets, and so on, make sure you copy them into the docroot directory. The docroot should point to any Oracle WebLogic Server component, $DOMAIN_HOME/servers/<managed_server_name>/tmp/_WL_user/reports_<version>/<dir_name>/web.war directory where Reports Application has been deployed.

### Web Server Port

By default, the OHS port is considered to be the Web server port. It can be configured in the Oracle Oracle Reports Builder configuration file (rwbuilder.conf) as follows:

```xml
<webLayout port="ohs_port"/>
```

The end user can override this configurable port parameter from the command line using the `WEBSERVER_PORT` command line keyword.

### Usage notes

- The large numbers in generated filenames are simply unique IDs, and have no particular meaning (for example, `emp012345678.jsp`).
- The temporary files created in the docroot directory get cleaned up when you exit Oracle Reports Builder.

### See also

- Section 4.7.16.4, "Displaying report output in your Web browser"
- Section 4.7.17.3, "Printing a report from your Web browser"

### 2.2.3 About Web links for HTML output

This topic discusses the Web links that you can add to paper-based reports that will become active when you generate your report to an HTML file and display it in a Web browser.

---

**Note:** If Netscape 7.0 is your default browser, and the browser does not display, set the registry key HKEY_CURRENT_USER\Software\Oracle\Toolkit\Tkbrowser to the default browser location. Ensure that the `BrowserName` and the `BrowserPath` keys reflect the correct values. For example: `BrowserName=Netscape 7; BrowserPath=C:\Program Files\Netscape\Netscape\Netscp.exe.`
In most cases, you can define Web links in an object's Property Inspector. You can specify column and field names in the link value to create dynamic links at runtime. If you require more complex implementation of Web links, such as conditional settings, you must specify the link using PL/SQL and the Oracle Reports Builder built-in packaged procedure SRW.SET_ATTR.

Reports output in HTML format can include the following types of Web links:

- A link from an object to another object within the same report, or to another HTML or PDF document (see Section 2.2.5, "About hyperlinks").
- An identifier for the destination of a Web link (see Section 2.2.7, "About hyperlink destinations"). The destination can be any printable object (field, boilerplate, frame, and so on) in your report layout.
- A string in a frame of the master HTML document that links to an associated object (see Section 2.2.8, "About bookmarks"). You can associate a bookmark with any printable object (field, boilerplate, frame, and so on) in your report layout. In the formatted report, you can click a bookmark to display the associated object at the top of the window.
- URLs that specify image resources. The URLs must be available to your Web server so that the images can be located when the HTML output is displayed by the server.
- A graph hyperlink to link areas of a graph to specified destinations.

Additionally, your report can include the following headers and footers that use escapes to add HTML tags to your paper-based report:

- a document header (a before report escape) for placing a logo or some standard links at the beginning of an HTML document (see Section 2.2.10, "About before and after escapes").
- a document footer (an after report escape) for placing a logo or some standard links at the bottom of an HTML document.
- a page header (a before page escape) for placing a logo or some standard links at the beginning of one page or all pages in an HTML document.
- a page footer (an after page escape) for placing a logo or some standard links at the bottom of one page or all pages in an HTML document.
- a Parameter Form header (a before form escape) for placing a logo or some standard links in the header of the HTML Parameter Form.
- a Parameter Form footer (an after form escape) for placing a logo or some standard links in the footer of the HTML Parameter Form.

### 2.2.4 About Web links for PDF output

This topic discusses the Web links that you can add to paper-based reports that will become active when you run your report to a PDF file and display it in a PDF viewer.

Reports output in PDF format can include the following types of Web links:

- A link from an object to another object within the same report, or to another HTML or PDF document (see Section 2.2.5, "About hyperlinks").
- An identifier for the destination of a Web link (see Section 2.2.7, "About hyperlink destinations"). The destination can be any printable object (field, boilerplate, frame, and so on) in your report layout.
A string in the bookmark area of the PDF viewer that links to an associated object (see Section 2.2.8, "About bookmarks"). You can associate a bookmark with any printable object (field, boilerplate, frame, and so on) in your report layout. In the formatted report, you can click a bookmark to display the associated object at the top of the window.

A link that executes a command when clicked (see Section 2.2.9, "About application command line links"). You can associate a command with any printable object (field, boilerplate, frame, and so on) in your report layout. In the formatted report, you can click the object to execute the associated command.

A graph hyperlink to link areas of a graph to specified destinations.

In most cases, you can define Web links in an object's Property Inspector. You can specify column and field names in the link value to create dynamic links at runtime. If you require more complex implementation of Web links, such as conditional settings, you must specify the link using PL/SQL.

2.2.5 About hyperlinks

A hyperlink is an attribute of an object that specifies a hypertext link to either of the following destinations:

- an object identified with a hyperlink destination within the same report
- another HTML or PDF document on the same machine or on a remote Web server

You can set the Additional Hyperlink Attributes property to specify additional HTML to be applied to the hyperlink.

See also
Section 4.6.10.1.8, "Creating a hyperlink using the Property Inspector"
Section 4.6.10.2.7, "Creating a hyperlink using PL/SQL"

2.2.6 About graph hyperlinks

A graph hyperlink provides an active link from an area of a graph to a specified destination in a Web report. When end users display the report on the Web (JSP-based, or paper-based PDF or HTML), they can click one or more areas of the graph to drill down to additional linked information.

See also
Section 4.6.8, "Adding a graph hyperlink"

2.2.7 About hyperlink destinations

A hyperlink destination is an attribute of an object that identifies the destination of a hypertext link.

See also
Section 4.6.10.1.7, "Creating a hyperlink destination using the Property Inspector"
Section 4.6.10.2.8, "Creating a hyperlink destination using PL/SQL"

2.2.8 About bookmarks

A bookmark is an attribute of an object that specifies a string that is a link to the object.
See also
Section 4.6.10.1.10, "Creating a bookmark using the Property Inspector"
Section 4.6.10.2.10, "Creating a bookmark using PL/SQL"
Section 4.6.10.1.11, "Creating a bookmark on break columns using the Property Inspector"

2.2.9 About application command line links
(PDF output only) An application command line link is an attribute of an object that specifies a command line to be executed when the object is clicked.

Restrictions
An object that is associated with an application command line link cannot also be the source of a Web link (a hyperlink).

See also
Section 4.6.10.1.9, "Creating an application command line link using the Property Inspector"
Section 4.6.10.2.9, "Creating an application command line link using PL/SQL"

2.2.10 About before and after escapes
- A before report escape specifies any text, graphics, or HTML commands that you want to appear at the beginning of your document.
- An after report escape specifies any text, graphics, or HTML commands that you want to appear at the bottom of your document.
- A before page escape specifies any text, graphics, or HTML commands that you want to appear at the beginning of one page or all pages of your document.
- An after page escape specifies any text, graphics, or HTML commands that you want to appear at the bottom of one page or all pages of your document.
- A before form escape specifies any text, graphics, or HTML commands that you want to appear at the top of the HTML Parameter Form.
- An after form escape specifies any text, graphics, or HTML commands that you want to appear at the bottom of the HTML Parameter Form.

Limitations
In an after report escape (see Section 2.2.10, "About before and after escapes"), adding an HTML command outside the body does not reflect when the report is generated to spreadsheet output, even though the HTML command is written in output properly. For example:

```html
</body><table><tr><td><B> the text to be bolded </B></td><tr></table>
</html>
```

Adding the HTML command before the closing body tag reflect correctly when the report is generated to spreadsheet output. For example:

```html
<table><tr><td><B> the text to be bolded </B></td></tr></table></body></html>
```
For more information about spreadsheet output, see Section 2.8.13, "About Enhanced Spreadsheet output".

See also
Section 4.6.10.1.1, "Creating an HTML document header using the Property Inspector"
Section 4.6.10.2.1, "Creating an HTML document header using PL/SQL"
Section 4.6.10.1.2, "Creating an HTML document footer using the Property Inspector"
Section 4.6.10.2.2, "Creating an HTML document footer using PL/SQL"
Section 4.6.10.1.3, "Creating an HTML page header using the Property Inspector"
Section 4.6.10.2.3, "Creating an HTML page header using PL/SQL"
Section 4.6.10.1.4, "Creating an HTML page footer using the Property Inspector"
Section 4.6.10.2.4, "Creating an HTML page footer using PL/SQL"
Section 4.6.10.1.5, "Creating an HTML Parameter Form header using the Property Inspector"
Section 4.6.10.2.5, "Creating an HTML Parameter Form header using PL/SQL"
Section 4.6.10.1.6, "Creating an HTML Parameter Form footer using the Property Inspector"
Section 4.6.10.2.6, "Creating an HTML Parameter Form footer using PL/SQL"

2.2.11 About style sheets

Style sheets (or Cascading Style Sheets) refer to HTML extensions that provide powerful formatting flexibility. With style sheet support, your HTML documents can include any of the following:

- any font size or style
- overlapping objects
- horizontal and vertical lines and rectangles of any color or width
- precise object positioning on a page
- pagination
- printing from a Web browser
- inline image maps

It means that the sophisticated formatting in a report is preserved when you format the report as an HTMLCSS document. Without style sheet extensions, your HTML documents display only basic text formats and imported images. With style sheets, images of highly formatted text can be replaced with text objects of equivalent style, color, and font. Text objects can be positioned to overlay image objects. All text is fully searchable, and fewer images have to be downloaded.

To view an HTML document that takes advantage of style sheets, you must display it in a browser that supports style sheets.

Using external style sheets for HTMLCSS output

Every corporate website today uses style sheets to enforce the corporate look-and-feel across Web pages. External style sheets are Cascading Style Sheet (CSS) files that are referenced by these Web pages. End users typically want the same style used in pages on their website applied to their Web reports.
In prior releases, applying style sheets and user-defined styles to reports involved manually editing the HTMLCSS output.

You can specify user-defined styles and style sheets for HTMLCSS output using Oracle Reports Builder. Styles can be applied to report, field, text, frame, and repeating frame objects using the new properties Style Sheets, CSS Class Name, and CSS ID properties (see the Oracle Reports online Help for descriptions of these properties). The generated HTMLCSS output includes links to the style sheets and the user-defined styles are applied to the objects.

Restrictions
The following elements are not supported by HTML style sheet extensions:

- ellipses, arcs, polygons/polylines, and diagonal lines
- rounded rectangles (formatted as rectangles)
- arrows on lines
- dashes on lines or borders of objects

See also
Section 4.7.16.4, "Displaying report output in your Web browser"
Section 4.7.17.3, "Printing a report from your Web browser"

2.3 Data Model Objects

The topics in this section build on the basic concepts discussed in Section 1.7, "Data Model Objects".

- About summary columns
- About formula columns
- About placeholder columns
- About referencing columns and parameters
- About non-linkable queries
- About links versus groups
- About matrix objects

2.3.1 About summary columns

A summary column performs a computation on another column’s data. Using the Report Wizard or Data Wizard, you can create the following summaries: sum, average, count, minimum, maximum, % total. You can also create a summary column manually in the Data Model view, and use the Property Inspector to create the following additional summaries: first, last, standard deviation, variance.

If your report requires a customized computation, for example, one that computes sales tax, create a formula column (see Section 4.8.10, "Creating or editing a formula column").
2.3.2 About formula columns

A formula column performs a user-defined computation on the data of one or more column(s), including placeholder columns. For example, :ITEMTOT *.07 is a formula that performs a computation on one column, while :SAL + :COMM performs a computation using two columns in a record. You create formulas in PL/SQL using the PL/SQL Editor.

Note: Formula columns should not be used to set values for parameters.

See also
Section 4.8.10, "Creating or editing a formula column"
Section 2.6.8, "About formulas"

2.3.3 About placeholder columns

A placeholder is a column for which you set the datatype and value in PL/SQL that you define. Placeholder columns are useful when you want to selectively set the value of a column (for example, each time the nth record is fetched, or each time a record containing a specific value is fetched, and so on). You can set the value of a placeholder column in the following places:

- the Before Report trigger, if the placeholder is a report-level column
- a report-level formula column, if the placeholder is a report-level column
- a formula in the placeholder’s group or a group below it (the value is set once for each record of the group)

See also
Section 4.8.12, "Creating or editing a placeholder column"
Section 2.6.8, "About formulas"

2.3.4 About referencing columns and parameters

You can reference user parameters, system parameters and columns as either bind references or lexical references.

Note: For group reports, the Report Wizard and Data Wizard create $n$ summary fields in the data model for each summary column you define: one at each group level above the column being summarized, and one at the report level. For example, if a report is grouped by division, and further grouped by department, then a summary column defined for a salary total would create fields for the sum of salaries for each division and each department group (group-level summaries), and the sum of all salaries (report-level summary).

See also
Section 4.8.11, "Creating a summary column"
2.3.4.1 About bind references

Bind references (or bind variables) replaces a single value in SQL or PL/SQL, such as a character string, number, or date. Specifically, bind references may be used to replace expressions in SELECT, WHERE, GROUP BY, ORDER BY, HAVING, CONNECT BY, and START WITH clauses of queries. Bind references may not be referenced in FROM clauses or for reserved words or clauses.

You create a bind reference by typing a colon (:) followed immediately by the column or parameter name. If you do not create a column or parameter before making a bind reference to it in a SELECT statement, Oracle Reports Builder will create a parameter for you by default.

Restrictions

Bind references must not be the same name as any reserved SQL keywords. For more information, see the Oracle Server SQL Language Reference manual.

Examples

Example 1: SELECT clause

In the following example, the value of DFLTCOMM replaces null values of COMMPLAN in the rows selected.

```sql
SELECT CUSTID, NVL(COMMPLAN, :DFLTCOMM) COMMPLAN
FROM ORD;
```

Example 2: WHERE clause

The value of CUST helps in selecting a single customer.

```sql
SELECT ORDID, TOTAL
FROM ORD
WHERE CUSTID = :CUST;
```

Example 3: GROUP BY clause

All non-aggregate expressions such as NVL(COMMPLAN, :DFLTCOMM) in the SELECT clause must be replicated in the GROUP BY clause.

```sql
SELECT NVL(COMMPLAN, :DFLTCOMM) COMMPLAN, SUM(TOTAL) TOTAL
FROM ORD
GROUP BY NVL(COMMPLAN, :DFLTCOMM);
```

Example 4: HAVING clause

The value of MINTOTAL helps in selecting customers with a minimum total of orders.

```sql
SELECT CUSTID, SUM(TOTAL) TOTAL
FROM ORD
GROUP BY CUSTID HAVING SUM(TOTAL) > :MINTOTAL;
```

Example 5: ORDER BY clause

The value of SORT helps in selecting either SHIPDATE or ORDERDATE as the sort criterion. Notice that this is different from ORDER BY 1 because :SORT is used as a value rather than to identify the position of an expression in the SELECT list. Notice that DECODE is required in this example. You cannot use a bind variable in an ORDER BY clause unless it is with DECODE.

```sql
SELECT ORDID, SHIPDATE, ORDERDATE, TOTAL
FROM ORD
ORDER BY DECODE(:SORT, 1, SHIPDATE, 2, ORDERDATE);
```
Example 6: CONNECT BY and START WITH clauses

References in CONNECT BY and START WITH clauses are used in the same way as they are in the WHERE and HAVING clauses.

Example 7: PL/SQL

procedure double is begin; :my_param := :my_param*2; end;

The value of myparam is multiplied by two and assigned to myparam.

2.3.4.2 About lexical references

Lexical references are placeholders for columns or parameters that you embed in a SELECT statement. You can use lexical references to replace the clauses appearing after SELECT, FROM, WHERE, GROUP BY, ORDER BY, HAVING, CONNECT BY, and START WITH. Use a lexical reference when you want the parameter to substitute multiple values at runtime.

You cannot make lexical references in a PL/SQL statement. You can, however, use a bind reference in PL/SQL to set the value of a parameter that is then referenced lexically in SQL, as shown in the example below.

You create a lexical reference by typing an ampersand (&) followed immediately by the column or parameter name. A default definition is not provided for lexical references. Therefore, you must do the following:

- Before you create your query, define a column or parameter in the data model for each lexical reference in the query. For columns, you must set the Value if Null property, and, for parameters, you must set the Initial Value property. Oracle Reports Builder uses these values to validate a query with a lexical reference.
- Create your query containing lexical references.

Restrictions

- You cannot make lexical references in a PL/SQL statement.
- If a column or parameter is used as a lexical reference in a query, its Datatype must be Character.
- If you want to use lexical references in your SELECT clause, you should create a separate lexical reference for each column you will substitute. In addition, you should assign an alias to each lexical reference. It enables you to use the same layout field and boilerplate label for whatever value you enter for the lexical reference on the Runtime Parameter Form.
- If you use lexical references in your SELECT clause, you must specify the same number of items at runtime as were specified in the report’s data model. Each value you specify for your lexical references at runtime must have the same datatype as its Initial Value.
- If you use lexical references in your SELECT clause, the width of the column is derived from the Initial Value property of the parameter. Consequently, you should ensure that the Initial Value of the parameter corresponds to the widest column that you intend to use.
- A Oracle Reports Builder link should not depend upon a lexical reference. That is, neither the child column of a link or its table name should be determined by a lexical reference. To achieve this functionality, you need to create a link with no columns specified and then enter the SQL clause (for example, WHERE) for the link.
directly in the query. For example, your parent and child queries might be written as follows:

Parent Query:

```sql
SELECT DEPTNO FROM EMP
```

Child Query:

```sql
SELECT &PARM_1 COL_1, &PARM2 COL_2
FROM EMP
WHERE &PARM_1 = :DEPTNO
```

Note how the `WHERE` clause makes a bind reference to `DEPTNO`, which was selected in the parent query. Also, this example assumes that you have created a link between the queries in the Data Model view with no columns specified.

A lexical reference cannot be used to create additional bind variables after the After Form trigger fires. For example, suppose you have a query like the following (notice that a lexical reference replaces the `WHERE` clause):

```sql
SELECT ENAME, SAL FROM EMP
&where_clause
```

If the value of the `where_clause` parameter contains a reference to a bind variable, you must specify the value in the After Form trigger or earlier. You would get an error if you supplied the following value for the parameter in the Before Report trigger:

```sql
WHERE SAL = :new_bind
```

If you supplied this same value in the After Form trigger, the report would run.

**Examples**

**Example 1: SELECT clause**

```sql
SELECT &P_ENAME NAME, &P_EMPNO ENO, &P_JOB ROLE
FROM EMP;
```

`P_ENAME`, `P_EMPNO`, and `P_JOB` can be used to change the columns selected at runtime. For example, you could enter `DEPTNO` as the value for `P_EMPNO` on the Runtime Parameter Form. In this case, you should use aliases for your columns. Otherwise, if you change the columns selected at runtime, the column names in the `SELECT` list will not match the Oracle Reports Builder columns and the report will not run.

**Example 2: FROM clause**

```sql
SELECT ORDID, TOTAL
FROM &ATABLE;
```

`ATABLE` can be used to change the table from which columns are selected at runtime. For example, you could enter `ORD` for `ATABLE` at runtime. If you dynamically change the table name in this way, you may also want to use lexical references for the `SELECT` clause (look at the previous example) in case the column names differ between tables.

**Example 3: WHERE clause**

```sql
SELECT ORDID, TOTAL
FROM ORD
WHERE &CUST;
```
CUST can be used to restrict records retrieved from ORD. Any form of the WHERE clause can be specified at runtime.

Example 4: GROUP BY clause

```
SELECT NVL(COMMPLAN, DFLTCOMM) CPLAN, SUM(TOTAL) TOTAL
FROM ORD
GROUP BY &NEWCOMM;
```

The value of NEWCOMM can be used to define the GROUP BY clause.

Example 5: HAVING clause

```
SELECT CUSTID, SUM(TOTAL) TOTAL
FROM ORD
GROUP BY CUSTID HAVING &MINTOTAL;
```

The value of MINTOTAL could, for example, be used to select customers with a minimum total of orders.

Example 6: ORDER BY clause

```
SELECT ORID, SHIPDATE, ORDERDATE, TOTAL
FROM ORD
ORDER BY &SORT;
```

The value of SORT can be used to select SHIPDATE, ORDERDATE, ORID, or any combination as the sort criterion. It could also be used to add on to the query, for example to add a CONNECT BY and START WITH clause.

Example 7: CONNECT BY and START WITH clauses

Parameters in CONNECT BY and START WITH clauses are used in the same way as they are in the WHERE and HAVING clauses.

Example 8: Multiple clauses

```
SELECT &COLSTABLE;
```

COLSTABLE could be used to change both the SELECT and FROM clauses at runtime. For example, you could enter DNAME ENAME, LOC SAL FROM DEPT for COLSTABLE at runtime.

```
SELECT * FROM EMP &WHEREORD;
```

WHEREORD could be used to change both the WHERE and ORDER BY clauses at runtime. For example, you could enter WHERE SAL > 1000 ORDER BY DEPTNO for WHEREORD at runtime.

Example 9: PL/SQL and SQL

```
SELECT &BREAK_COL C1, MAX(SAL)
FROM EMP
GROUP BY &BREAK_COL;
```

BREAK_COL helps to change both the SELECT list and the GROUP BY clause at runtime. The Initial Value of the parameter &BREAK_COL is JOB. At runtime, the user of the report can provide a value for a parameter called GROUP_BY_COLUMN (of data type Character).

In the Validation Trigger for GROUP_BY_COLUMN, you call the following PL/SQL procedure and pass it the value of GROUP_BY_COLUMN:
procedure conv_param (in_var IN char) is
begin
  if upper(in_var) in ('DEPTNO', 'EMPNO', 'HIREDATE') then
    :break_col := 'to_char('||in_var||')' ;
  else
    :break_col := in_var;
  end if;
end;

This PL/SQL ensures that, if necessary, a TO_CHAR is placed around the break column the user chooses. Notice how in SQL, you make a lexical reference to BREAK_COL. In PL/SQL, you must make a bind reference to BREAK_COL because lexical references are not allowed in PL/SQL.

### 2.3.4.3 Differences between bind and lexical references

Bind references replace a single value in SQL or PL/SQL. Specifically, bind references may be used to replace expressions in SELECT, WHERE, GROUP BY, ORDER BY, HAVING, CONNECT BY, and START WITH clauses of queries. Bind references may not be referenced in the FROM clause. An example is:

```
SELECT ORDID, TOTAL
  FROM ORD
  WHERE CUSTID = :CUST
```

Lexical references are placeholders for text that you embed in a SELECT statement, when you want the parameter to substitute multiple values at runtime. You can use lexical references to replace the clauses appearing after SELECT, FROM, WHERE, GROUP BY, ORDER BY, HAVING, CONNECT BY, and START WITH. You cannot make lexical references in PL/SQL. Before you reference a lexical parameter for a column or table, you must have predefined the parameter and given it an initial value. An example is:

```
SELECT ORDID, TOTAL
  FROM &ATABLE
```

### 2.3.5 About non-linkable queries

A non-linkable query is a detail query that contains column objects that prevent the query from being linked to through a column-to-column link (when you create a column-to-column link, Oracle Reports Builder adds a WHERE clause to your query). If you attempt to create such a link, a message dialog box displays, which prompts you to choose whether to create a group-to-group query (using the parent groups), or to cancel the operation. A non-linkable query displays the non-linkable query icon in its title bar.

Instead, you can create a group-to-group link (when you create a group-to-group link, Oracle Reports Builder does not add a WHERE clause to your query) between the two queries and add a WHERE clause to the child query’s SELECT statement, using a bind variable to reference the parent column. See Section 4.8.9, "Creating a data link".

For example, suppose you want to create a column-to-column link between the ADDRESS.STREET column in your child query and the LOC1 column in your parent query. You can create a group-to-group link, and then modify the child query SQL statement to say:

```
SELECT * FROM EMP E WHERE E.ADDRESS.STREET = :LOC1
```

**See also**

Section 1.7.4, "About data links"
2.3.6 About links versus groups

In Oracle Reports Builder, data is defined independent of format (layout). Therefore, you should be aware of when to use data links instead of groups.

The layouts of a master/detail report that uses two queries and a data link, and a group report that uses one query and two groups can be identical. Following is an example of a default master/detail report and a group report that query the same data. Notice the difference between the two reports: unlike the group report, the master/detail report displays department 40. This is because the data link in the master/detail report causes an outer-join: the link automatically fetches unrelated data. If you are designing a group report that requires an outer-join, explicitly add it to your `SELECT` statement with (+).

![Default master/detail and group report that query same data](image)

A master/detail/detail report, as shown in the figure below, is a report that contains three groups of data: for each master group, two unrelated detail groups are displayed. To produce a master/detail/detail report or any variation of it, you must use data links. If you try to produce this report with a control break using a single query and three groups the query will establish a relationship between the two detail groups.
2.3.7 About matrix objects

A matrix object defines a relationship between two repeating frames: it isn't really owned by any object, nor does it own any object. A matrix object is created only for layouts with a Matrix layout style. A report may have multiple matrices within it, if the data model contains the necessary groups. Oracle Reports Builder creates one matrix object for each pair of intersecting, perpendicular repeating frames.

The repeating frames are the dimensions of the matrix and the matrix object contains the field that will hold the "filler" or values of the cell group. One of the repeating frames must have the Print Direction property set to Down and the other must have the Print Direction property set to Across in order to form a matrix.

Note: When running a JSP-based Web report that includes a matrix object, the JSP <rw:include> tag expects the matrix object to format on only one page. However, if the cells in the across repeating frame expand, the column headers of the matrix may be forced onto a second page regardless of the page size. Therefore, these matrix headers will not appear in the report output. Additionally, in this situation, the paper layout does not display correctly as header fields move to subsequent pages where the cell values remain on the first page. To resolve, it is important to carefully define in the Report Editor the space available to the across repeating frame to allow for displaying the largest values, then set the Vertical Elasticity property of the across repeating frame to Fixed.

Restrictions
- The down repeating frames must be below the across repeating frames in a matrix.
- A matrix object must always be on top of the repeating frames that form it (that is, it must be one or more layers above its horizontal and vertical repeating frames).
Oracle Reports Builder prevents you from moving the matrix below its horizontal and vertical repeating frames.

- Moving a matrix also causes its two repeating frames to move.
- A matrix object cannot be anchored to another object and other objects cannot be anchored to it (that is, a matrix object cannot be the parent or child object for an anchor).
- To copy a matrix, you must select the matrix and its two repeating frames. If you select the matrix object by itself, nothing will be copied to the paste buffer. If you select the matrix and one of the repeating frames, only the repeating frame is placed in the paste buffer.
- A matrix object can only be resized by resizing its associated repeating frames.
- You cannot use Alignment or Size Objects from the Layout menu on matrix objects.
- The source groups of the repeating frames that form the dimensions of a matrix must be from the same cross-product group.
- Repeating frames whose source groups are in the same "family" hierarchy (that is, are descendants or ancestors of each other) must have the same Print Direction. Parent-child relationships within a cross-product group are used to create nesting in the matrix. As a result, the repeating frames associated with such groups must print in the same direction on the page.
- You can put a border on a matrix object just as you would any other object, but the width will always be the minimum width possible. You cannot widen the border due to the closeness of the objects in a matrix layout.

**Example**

Suppose that you have a group named Group1 that contains a column called C_DEPTNO, which gets its values from the database column DEPTNO. A group called Group2, contains column C_JOB, which gets its values from the database column JOB, and column C_DEPTNO1, which is used for linking to Group1's query. A group called Group3 contains a column called SUMSAL, which is a summary of the database column SAL.

<table>
<thead>
<tr>
<th></th>
<th>Job</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Analyst</td>
<td>$1300</td>
<td>$2450</td>
</tr>
<tr>
<td>Clerk</td>
<td>$6000</td>
<td>$2975</td>
</tr>
<tr>
<td>20</td>
<td>$950</td>
<td>$2850</td>
</tr>
<tr>
<td>Manager</td>
<td>$4800</td>
<td></td>
</tr>
</tbody>
</table>

In this example:
- The Vertical Repeating Frame is the repeating frame that contains Group2 (the job titles).
- The Horizontal Repeating Frame is the repeating frame that contains Group1 (the department numbers).
- The Cross Product Group is Group4 (the group that is the parent of Group1 and Group2).

If you need to build a more complex matrix, you can do so by adding more columns to Group1 and Group2. For example, instead of having Group1 just contain department numbers, it could also contain the locations (LOC) of the departments. The matrix might then look something like this:
### 2.4 Layout Objects

The topics in this section build on the basic concepts discussed in Section 1.8, "Layout Objects".

- About layout objects
- About layout defaulting
- About images
- About anchors
- About changing colors and patterns
- About resizing objects
- About moving and layering objects in the Paper Layout view

#### 2.4.1 About layout objects

Several important concepts and properties apply to layout objects:

- the frequency with which you want the object to appear in the report, specified by the Print Object On property
- how Oracle Reports Builder fetches and formats data for instances of repeating frames, specified by the Column Mode property
- whether to keep an object and the object to which it is anchored on the same logical page, specified by the Keep With Anchoring Object property
- whether to try to keep the entire object and its contents on the same logical page, specified by the Page Protect property
- format triggers, which are PL/SQL functions executed before an object is formatted that can dynamically change the formatting attributes of objects
- report layout, generated by defaulting applied by Oracle Reports Builder, modified in the Paper Layout view, or created from start.

See also

Section 4.5.4, "Creating a default layout for a report"
Section 4.10.2, "Creating a default layout for a section"
Section 2.6.13.2, "About format triggers"

The Properties section of the Oracle Reports online Help

2.4.2 About layout defaulting

When you select one of the default layout styles in the Report Wizard, Oracle Reports Builder creates the necessary layout objects, based upon the report's data model. For example, to build a mailing label report and have defined an appropriate data model, simply choose the mailing label default style. Oracle Reports Builder automatically creates the report's layout objects and displays them in the Layout Model view. You can completely customize any default layout you create. You can cut, copy, paste, move, resize, and edit each layout object that Oracle Reports Builder generates for you.

Layout defaulting is governed by the following rules:

- All previously-defined layout objects for the report will be overwritten (including format triggers) unless you define the area in which you wish to create the layout as one which does not already contain layout objects.

- One report can have any number of different formats. For example, you can build a report that has a tabular format on the top of the first page, and a matrix format on the bottom of the same page by creating an additional report layout (see Section 4.5.5, "Creating an additional report layout").

- Once you have created a report layout, any further changes you make to the data model will not automatically be included in the layout. For example, if you create a query after you have created a report layout and then run your report, the data from the new query will not appear in the report output. To incorporate your changes, you need to either redefault or modify the layout.

Oracle Reports Builder defaults report layout according to the following rules:

1. Unless otherwise noted, a group with a Print Direction of Across defaults identically to a group with a Print Direction of Down, except that the default format is transposed. To quickly determine the defaulting of an Across group, do the following:
   - Draw the down layout for the group on translucent paper.
   - Turn the page over as if it was a page in a book.
   - Rotate the page counter-clockwise 90 degrees.

2. In form letter reports, all default fields are hidden, and have a Horizontal Elasticity property setting of Variable and a Vertical Elasticity property setting of Fixed. In all other reports, all default fields have a Horizontal and Vertical Elasticity property setting of Fixed.

   Exception: For tabular, form-like, group left/above, and matrix reports, the default for CHAR (if you reduce the default width) and LONG fields have a Horizontal Elasticity property setting of Fixed and a Vertical Elasticity property setting of Variable. As a result, all of the field's value will be displayed, instead of truncated, by word-wrapping any data to the next lines.
3. Summaries that are owned by the report, not by a group, are allowed in all report layout styles. They are all formatted in the following way:
   ■ If the layout style is form-like, form letter, or mailing label, the summary is a report column. A report column is formatted like any other database column for that report style.
   ■ If the layout style is tabular, group left/above, or matrix, and the column on which the summary performs its function is not selected, the summary is a report column. (It is formatted as stated in the bullet above.) Otherwise, the summary is a report summary. It is formatted left-justified at the bottom of the report, with the label to the left of the field (if there is room).

4. If the layout style is tabular, group left/above, or matrix, a summary is defaulted like a database column if the column it summarizes is not selected. Otherwise, a summary is defaulted like summaries (that is, appearing inside the M_groupname_FTR frames).

5. If the layout style is tabular, group left/above, or matrix, Oracle Reports Builder places one summary type per line, in the following order:
   ■ SUM
   ■ AVERAGE
   ■ MINIMUM
   ■ MAXIMUM
   ■ COUNT
   ■ FIRST
   ■ LAST
   ■ % OF TOTAL
   ■ STANDARD DEVIATION
   ■ VARIANCE

6. If the layout style is tabular, group left/above, or matrix, the summary label will appear to the far-left of the group footer frame (M_groupname_FTR). If there is not room for the full label, the label will be truncated.

**See also**
Section 4.5.4, "Creating a default layout for a report"
Section 4.10.2, "Creating a default layout for a section"

**2.4.3 About images**
You can add an image to a report by:
   ■ Importing an image from a file into the report layout (paper-based report only).
   See Section 4.9.8.1.1, "Importing an image".

---

**Caution:** For form letter and mailing label reports, the default for CHAR (if you reduce the default width) and LONG fields have a Horizontal Elasticity and Vertical Elasticity property setting of Fixed. As a result, the field value will be truncated if the size of the data is greater than the size of the field.
Creating a file link object in the Paper Layout (paper-based reports only). See:
  - Section 4.9.8.1.2, "Linking an image object to a file"
  - Section 4.9.8.1.3, "Linking an image object to a URL" (for HTML and HTMLCSS output)

Selecting a database column in a query (both paper-based and JSP-based Web reports). See:
  - Section 4.8.5, "Selecting an image from the database"
  - Section 4.8.6, "Selecting an image URL from the database" (for HTML output)

The first method (using the Import Image dialog box) provides for including images in the following formats: TIFF, JFIF, BMP, TGA, PCX, PICT, GIF, CALS, RAS, OIF, PCD.

The other two methods (creating a file link object, and selecting a column in the database) provide for including additional formats supported by Oracle Reports, including JPEG (all types, such as Progressive JPEG and Exif JPEG), PNG, BMP, TIFF, GIF, and CGM.

By default, images display in fields so that they appear in the printed report, not only in the Previewer.

Enhanced imaging support is provided by the REPORTS_OUTPUTIMAGEFORMAT environment variable and OUTPUTIMAGEFORMAT command line keyword. The enhancements in imaging support provide the capability to generate complex graphics-intensive reports with high fidelity image output. Additionally on UNIX, the dependency on a windowing system for displaying images is removed; the PostScript printer driver screenprinter.ppd provides surface resolution for images.

You can include an unlimited number of image objects without running out of local disk space by using non-caching references. A non-caching reference causes objects to be read from the database only when needed while a report is processing. You must be connected to an ORACLE V7.1 or later database to use this feature.

If you reference a URL for an image, the image is displayed when you format your report for HTML output. For other output formats, the URL text displays in the Paper Design view; in the output destination (for example, a file or PDF document), nothing is displayed. It is your responsibility to verify that the URL exists; Oracle Reports Builder does not validate the existence of the resource nor the syntax of the protocol. The size of the object that contains the URL defines the size of the image in the HTML output. Any elasticity properties applied to the object are ignored.

Limitations
  - If the input image includes more than 256 colors, and the output image format is set to GIF (with the OUTPUTIMAGEFORMAT command line keyword or the REPORTS_OUTPUTIMAGEFORMAT environment variable), Oracle Reports implements a color reduction to 256 colors to successfully generate the GIF.
  - On UNIX, CGM format is not supported in HTML output. This limitation does not apply on the Windows platform.

2.4.4 About anchors

Anchors fasten an edge of one object to an edge of another object, ensuring that they maintain their relative positions. For example, you can anchor boilerplate text to the edge of a variable-sized repeating frame, guaranteeing the boilerplate’s distance and position in relation to the repeating frame, no matter how the frame’s size might change.
Anchors determine the vertical and horizontal positioning of a child object relative to its parent. The child object may be either outside of or contained within the parent.

Since the size of some layout objects may change when the report runs (and data is actually fetched), you need anchors to define where you want objects to appear relative to one another. An anchor defines the relative position of an object to the object to which it is anchored. Positioning is based on the size of the objects after the data has been fetched rather than on their size in the editor. It should also be noted that the position of the object in the Paper Layout view affects the final position in the report output. Any physical offset in the layout is incorporated into the percentage position specified in the Anchor properties.

There are two types of anchors:

- **Implicit anchors.** At runtime, Oracle Reports Builder generates an implicit anchor for each layout object that does not already have an explicit anchor. It determines for each layout object which objects, if any, can overwrite it, then creates an anchor from the layout object to the closest object that can overwrite it. This prevents the object from being overwritten. The implicit anchor functionality saves you from having to define the positioning of each object. Implicit anchors are not visible in the Paper Layout view. However, you can specify in the Object Navigator Options dialog box that the Object Navigator display anchoring information. By default, objects are anchored to the upper left corner of their enclosing object. If this view of the Object Navigator does not show anchoring information for an object, you can assume that the object is anchored to its enclosing object, which might be the frame or the body.

- **Explicit anchors.** You can create an anchor in the Layout editor using the Anchor tool, dragging from one edge of the child to the one of the parent’s edges. Any anchor you create for an object will override its implicit anchoring. Explicit anchors are always visible in the Paper Layout view unless you specify otherwise in the Layout Options dialog box.

### Relative positioning of anchors

When you anchor a child object to a parent object, the x and y coordinates of the anchor’s attachments are important.

**If the parent object is located above or below the child object:**

- the vertical distance between the two objects is fixed. For example, in the figure below, the vertical spacing between the parent and Object 1 is fixed.

- the horizontal positioning of the anchor’s x-coordinate on the child object is relative to the anchor’s x-coordinate on the parent object. For example, in the figure below, the anchor is 50% from the edge of the parent and 75% from the left edge of Object 1. Therefore, when this report is run, Oracle Reports Builder will shift Object 1 25% to the left of the center of the parent.
If the parent object is located to the right or left of the child object:

- the vertical positioning of the two objects is relative. For example, in the figure below, both ends of the anchor are about 80% down from the top edges of the objects. Therefore, when the report is run, Oracle Reports Builder will calculate the length of the two objects (as they may expand), calculate the y coordinate that is 80% down for both objects, and position the two objects so that those two points are separated by the amount of space separating them in the Paper Layout view.

- the horizontal positioning between the two objects is fixed. For example, in the figure below, the horizontal spacing between the parent and Object 1 is fixed.

If you need to position an object outside a repeating frame or frame, but you want the object to be "owned" by the repeating frame or frame (that is, to be formatted when its "owner" is formatted), create an anchor that is attached to an object inside the frame or repeating frame.

Collapsing Anchors

You can create anchors to be "collapsible." Collapsing anchors help avoid unnecessary empty space in your report. Such empty space can occur when the parent object does not print on the same page as the child object, either because the parent and child cannot fit on the same page or because of an assigned Print Condition. A collapsing anchor allows the child object to move into the position that would have been taken by the parent had it printed. The child object will also maintain its relative position as defined by the anchor.
2.4.4.1 Implicit anchoring algorithm

Oracle Reports Builder creates implicit anchors at runtime in the body region. The margin algorithm differs slightly.

Body algorithm

1. Determine which objects are not entirely enclosed by a repeating frame of frame (directly or indirectly), or explicitly anchored to an object that is enclosed by a frame or repeating frame (directly or indirectly). We'll call these objects Type A objects. (Type A objects are typically group frames, repeating frames, other objects you create that are not owned by a frame or repeating frame, and so on). An object is considered to be enclosed by another object only if all of the following are true:

   ■ Both objects belong to the same region (Body or Margin).
   ■ The outermost of the two objects is a frame or repeating frame.
   ■ The outermost of the two objects is behind the other object.
   ■ The innermost of the two objects lies entirely within the borders of the other object.

2. Determine all children objects of a frame or repeating frame (these are the non-Type A objects). We'll call these objects Type B objects.

3. Follow this procedure for Type A and Type B objects independently:

   ■ Find all objects that are of the same type (for example, Type A), and are on the same layer.

   ■ Determine which of those objects have potential to "push" other objects of that type. An object has potential to "push" object of that type if it has a Horizontal or Vertical Elasticity setting of Variable or Expand, and a second object is located in its "push path" (that is, in the area in which it can possibly grow). Also, a repeating frame with a Horizontal or Vertical Elasticity setting of Fixed or Contract has a "push path": its Print Direction.

   ■ Create pairs of objects. Each pair must contain a pusher (that is, the object that will grow) and a pushee (that is, the object that will be pushed). When creating these pairs, a pushee object cannot be a child of an explicit anchor--those objects are ignored.

   ■ Go through this loop. For each pair, determine the distance in the "push path" between the pusher and pushee. Next, find the pair with the shortest distance. Finally, create an implicit anchor between those two objects using this algorithm:

     If the "push path" direction is Down, anchor the pushee object's top 0% to the pusher object's bottom 0%.

     If the "push path" direction is Across, anchor the pushee object's left 0% to the pushed object's right 0%.

   ■ That pair is now treated like one object, and the loop continues until either all objects have one anchor, or nothing will push the remaining, unanchored objects.

   ■ For each remaining, unanchored object, create an implicit anchor from the top-left corner of the object to the top-left corner of the body region.

   ■ Move to the next layer, and follow the procedure starting at step 1.
Rules:

- If an object is in the "push path" of two other objects and it is equidistant from the other two objects, the implicit anchoring of the object may vary between executions of the report. For example, the drawing that follows shows two cases where this could occur:

Figure 2–7 Object in push path of two other objects

In the first case, M_Sums is in the "push path" of both B_Text1 and R_Ename. Because M_Sums is equidistant from B_Text1 and R_Ename, though, the normal criteria (shortest distance) for determining implicit anchors does not work in this case. Consequently, the formatting algorithm will randomly create an implicit anchor between M_Sums and either B_Text1 or R_Ename at runtime. To avoid this behavior, you could create an explicit anchor between M_Sums and B_Text1 or R_Ename.

In the second case, B_Text3 is in the "push path" of M_Emp. Since the bottom edges of M_Emp and R_Mgr are virtually in the same position, though, B_Text3 could be implicitly anchored to either M_Emp or R_Mgr at runtime. To avoid this behavior, you could create an explicit anchor from B_Text3 to one of the objects or remove the explicit anchor between R_Ename and B_Text2. Removing the explicit anchor would cause R_Mgr to be treated as a descendant of M_Emp and, therefore, the implicit anchor would always be created between B_Text3 and M_Emp.

(Notice that Case 2 is most likely to occur in character mode, where it is common to have the edges of objects overlap in the Paper Layout view.)

Margin algorithm

Oracle Reports Builder creates implicit anchors for all Type B objects in the margin region using the Body algorithm. For each Type A object, however, Oracle Reports Builder creates an implicit anchor from the top-left corner of the object to the top-left corner of the margin. No Type A object will be implicitly anchored to another Type A
object. (This ensures that Type A objects will not be pushed off the page. However, they may be overwritten by another Type A object, if they are found on the same layer.)

See also
Section 4.9.5.1, "Anchoring objects together"
Section 4.9.5.2, "Viewing implicit anchors"
Section 4.9.5.3, "Moving an anchor"

2.4.5 About changing colors and patterns

Color and pattern selections are applied to an entire object (for example, you can apply a color to all the text in the object but not to a segment of the text).

You can change colors and patterns in your report in the following ways:

■ In the Oracle Reports Builder user interface, use the following tools in the Paper Layout view’s tool palette:
  ■ The **Line Color** tool helps to customize the color of borders around layout objects.

  **Note:** The Windows platform does not support a border pattern (that is, patterns for the Line Color tool).

  ■ The **Fill Color** tool helps to fill layout objects with colors and patterns.
  ■ The **Text Color** tool helps to change the default text color.
  ■ The **Fill/Line/Text Display**, the box directly above the three Color tools, shows the currently selected fill, border, and text. The default fill and border for objects created by Oracle Reports Builder is transparent, while the default for objects you create is a black, one point line around a white fill.

■ In PL/SQL, use the following SRW packaged procedures:
  ■ SRW.SET_BACKGROUND_BORDER_COLOR
  ■ SRW.SET_BACKGROUND_FILL_COLOR
  ■ SRW.SET_FOREGROUND_BORDER_COLOR
  ■ SRW.SET_FOREGROUND_FILL_COLOR
  ■ SRW.SET_TEXT_COLOR
  ■ SRW.SET_FILL_PATTERN
  ■ SRW.SET_BORDER_PATTERN

■ For templates, set the following properties in the template Property Inspector:
  ■ The Fill Pattern property defines the pattern to use for the space enclosed by the objects. You can define the background and foreground colors of the fill pattern using the Foreground Color and Background Color properties.
  ■ The Edge Pattern property defines the pattern to use for the borders of the objects. You can define the background and foreground colors of the edge pattern using the Edge Foreground Color and Edge Background Color properties.
The Text Color property specifies the text color to use for the object(s).

Additionally, you can set color palette preferences to specify how reports use it (see Section 4.2.6, "Setting color palette preferences") and modify the color palette to change the definition of individual colors (see Section 4.9.6.5, "Modifying the color palette").

To change the color palette being used by the current report, you can import a new color palette. You can also export the current color palette for use by other reports. (See Section 4.9.6.6, "Importing or exporting a color palette").

See also
Section 4.9.6.2, "Changing colors"
Section 4.9.6.3, "Changing patterns"
Section 4.9.6.4, "Changing colors and patterns using PL/SQL"
Section 4.9.4.2, "Changing object border attributes"

Topics "Oracle CDE1 color palette", "Default color palette", "Grayscale color palette", and "Pattern color palette" in the Reference > Color and Pattern Palettes section of the Oracle Reports online Help

Topic "SRW built-in package" in the Reference > PL/SQL Reference > Built-in Packages section of the Oracle Reports online Help

Topic "Template properties" in the Properties section of the Oracle Reports online Help

2.4.6 About resizing objects

You can resize queries, groups, frames, repeating frames, fields, matrix objects, and boilerplate objects. You cannot resize anchors. However, an anchor is automatically resized if you move one of the objects it anchors.

Caution: When you resize boilerplate text, be very careful that all of the text fits within the object. If font descends (the space left for the lower parts of letters like g and q) do not fit, the line of text will appear in the Report Editor view, but, when the report is run, the line will not appear in the output. When you click a handle and drag it, the two edges that join at the corner will be resized; that is, the object will grow or reduce in both the x and y directions.

See also
Section 4.9.12.1, "Resizing objects"
Section 4.9.12.2, "Making multiple objects the same size"
Section 4.9.11.3, "Adjusting parent borders automatically"

2.4.7 About moving and layering objects in the Paper Layout view

In the Paper Layout view, objects must be on a layer above the objects that enclose them. For example, the fields that belong to a repeating frame must be at least one layer above the repeating frame in the Paper Layout view. If not, then they are not considered to be enclosed by the repeating frame any longer and will cause a
frequency error at runtime. When you move or group objects in the Paper Layout view, it is possible to change the layering such that you will get frequency errors when you run the report. To avoid this problem, you should take advantage of Confine or Flex mode when moving objects in the Paper Layout view.

See also
Section 4.9.4.3, "Changing the current mode (Confine or Flex)"
Section 4.9.11.7, "Changing object layering"
Section 4.9.11.2, "Moving an object outside its parent"
Section 4.9.11.1, "Moving multiple objects"
Section 4.9.11.6, "Aligning objects"

2.5 Parameter Form Objects

The topic in this section builds on the basic concepts discussed in Section 1.9, "Parameter Form Objects".

2.5.1 About Parameter Form HTML extensions

Parameter Form HTML extensions enable you to enhance your Runtime Parameter Form with HTML tagged text and JavaScript when your paper reports are run through the Web. To enhance your Paper Parameter Form for displaying on the Web, you can:

- create boilerplate text with HTML tags for adding hyperlinks or any other HTML tagged text to your Parameter Form (see Section 4.9.2.3, "Creating a boilerplate text object for HTML tags").

- insert parameter fields with JavaScript for defining input or select events, such as raising errors when users enter invalid data in a parameter field (see Section 4.11.12, "Creating HTML Parameter Form input or select events").

- create a Parameter Form header (a before form escape) for placing a logo or some standard links in the header of the HTML Parameter Form (see Section 4.6.10.1.5, "Creating an HTML Parameter Form header using the Property Inspector“ to use the Property Inspector, or Section 4.6.10.2.5, "Creating an HTML Parameter Form header using PL/SQL").

- create a Parameter Form footer (an after form escape) for placing a logo or some standard links in the footer of the HTML Parameter Form (see Section 4.6.10.1.6, "Creating an HTML Parameter Form footer using the Property Inspector“ to use the Property Inspector, or Section 4.6.10.2.6, "Creating an HTML Parameter Form footer using PL/SQL").

You can access the Parameter Form Builder from the Object Navigator or by choosing Tools > Parameter Form Builder.

See also
Section 1.2.2, "About Web Reports"
Section 1.9.4, "About Parameter Forms for Web reports"
Section 2.2.3, "About Web links for HTML output"
2.6 PL/SQL

The topics in this section discuss the use of PL/SQL in Oracle Reports Builder.

- About the PL/SQL Editor
- About the Stored PL/SQL Editor
- About the Syntax Palette
- About program units
- About stored program units
- About external PL/SQL libraries
- About attached libraries
- About formulas
- About group filters
- About REF CURSOR queries
- About DML and DDL
- About built-in packages
- About triggers

2.6.1 About the PL/SQL Editor

The PL/SQL Editor enables you to create and edit PL/SQL program units.

Usage notes
When you make changes to a program unit, dependent program units lose their compiled status, which is indicated by an asterisk (*) after their name under the Program Units node in the Object Navigator. You can navigate to those program units directly in the PL/SQL Editor using the Name list to recompile them.

Restrictions
- If you delete a PL/SQL package, function, or procedure, you must also delete all references to it in your report. Otherwise, you will get an error when you compile, generate, or run the report.
- PL/SQL package, function, and procedure names must be unique within the report and may not duplicate the names of any columns, groups, queries, or printable objects.

See also
Section 4.13.2.3.1, "Editing features in the PL/SQL Editor"

2.6.2 About the Stored PL/SQL Editor

The Stored PL/SQL Editor enables you to create and edit stored PL/SQL program units in a database (listed under the Database Objects node in the Object Navigator).

See also
Section 4.13.3.2, "Creating a stored program unit"
2.6.3 About the Syntax Palette

The Syntax Palette is a programming tool that enables you to display and copy the constructs of PL/SQL language elements and built-in packages into the PL/SQL Editor and Stored PL/SQL Editor.

See also
Section 4.13.2.4, "Inserting syntax into the PL/SQL Editor"

2.6.4 About program units

Program units are packages, functions, or procedures that you can reference from any PL/SQL within the current report.

Note: Program units cannot be referenced from other documents. If you want to create a package, function, or procedure that can be referenced from multiple documents, create an external PL/SQL library (see Section 4.13.5.1, "Creating an external PL/SQL library").

For a detailed example of using PL/SQL in a report, see Chapter 40, "Building a Report that Includes PL/SQL".

Restrictions

- If you delete a PL/SQL package, function, or procedure, you must also delete all references to it in your report. Otherwise, you will get an error when you compile, generate, or run the report.
- PL/SQL package, function, and procedure names must be unique within the report and may not duplicate the names of any columns, groups, queries, or printable objects.

Example: Referencing a PL/SQL function in formulas

Suppose that you have a report with the following groups and columns:

<table>
<thead>
<tr>
<th>Groups</th>
<th>Columns</th>
<th>Summary</th>
</tr>
</thead>
<tbody>
<tr>
<td>RGN</td>
<td>REGION</td>
<td></td>
</tr>
<tr>
<td></td>
<td>RGNSUMSAL</td>
<td>SUM(DEPTSUMSAL)</td>
</tr>
<tr>
<td></td>
<td>COSTOFLIVING</td>
<td></td>
</tr>
<tr>
<td>DEPT</td>
<td>DNAME</td>
<td></td>
</tr>
<tr>
<td></td>
<td>DEPTNO</td>
<td></td>
</tr>
<tr>
<td></td>
<td>DEPTSUMSAL</td>
<td>SUM(EMP.SAL)</td>
</tr>
<tr>
<td>JOB</td>
<td>JOB</td>
<td>SUM(EMP.EMPNO)</td>
</tr>
<tr>
<td>EMP</td>
<td>ENAME</td>
<td>COUNT(EMP.EMPNO)</td>
</tr>
<tr>
<td></td>
<td>EMPNO</td>
<td></td>
</tr>
<tr>
<td></td>
<td>SAL</td>
<td></td>
</tr>
<tr>
<td></td>
<td>COMM</td>
<td></td>
</tr>
</tbody>
</table>

Given these groups and columns, you might create multiple formulas that apply the cost of living factor (COSTOFLIVING) to salaries. To avoid duplication of effort, you could create the following PL/SQL function and reference it from the formulas:

```plsql
function CompSal(salary number) return number is
```

Advanced Concepts 2-37
begin
    return (salary*CostofLiving);
end;

Following are some examples of how you might reference the PL/SQL function in formulas:
CompSal(:RGNSUMSAL)

or

CompSal(:SAL) + COMM

See also
Section 4.13.3.1, "Creating a local program unit"

2.6.5 About stored program units

Stored program units (also known as stored subprograms, or stored procedures) can be compiled separately and stored permanently in an Oracle database, ready to be executed. Once compiled and stored in the data dictionary, they are schema objects, which can be referenced by any number of applications connected to that database.

Stored program units offer higher productivity, better performance, memory savings, application integrity, and tighter security. For example, by designing applications around a library of stored procedures and functions, you can avoid redundant coding and increase your productivity.

Stored program units are stored in parsed, compiled form. So, when called, they are loaded and passed to the PL/SQL engine immediately. Also, they take advantage of shared memory. So, only one copy of a program unit need be loaded into memory for execution by multiple users.

Because stored program units run in ORACLE, they can perform database operations more quickly than PL/SQL that is local to your report. Therefore, in general, use stored program units for PL/SQL that performs database operations. Use local program units for PL/SQL that does not involve database operations. However, if you are on a heavily loaded network with very slow response time, using stored program units may not be faster for database operations. Similarly, if your server is significantly faster than your local machine, then using local program units may not be faster for non-database operations.

See also
Section 4.13.3.2, "Creating a stored program unit"

2.6.6 About external PL/SQL libraries

External PL/SQL libraries are collections of PL/SQL procedures, functions, and packages that are independent of a report definition. By attaching an external library to a report, you can reference its contents any number of times. For example, you could reference a procedure in an attached library from both a Before Report trigger and a format trigger. This eliminates the need to re-enter the same PL/SQL for each application.

When you associate an external PL/SQL library with a report or another external library, it is called an attached library.
See also
Section 4.13.5.1, "Creating an external PL/SQL library"

2.6.7 About attached libraries
Attached libraries are external PL/SQL libraries that you have associated with a report or another external library. When an external library is attached, you can reference its packages, functions, and procedures from within your report. For example, if you attached an external library name MYLIB to your report and it contained a function named ADDXY, then you could reference ADDXY from any PL/SQL in the report.

External PL/SQL libraries are independent of a report definition.

Usage notes
Local PL/SQL executes more quickly than a reference to a procedure or function in an external PL/SQL library. As a result, you should only use external PL/SQL libraries when the benefits of sharing the code across many applications outweigh the performance overhead.

Restrictions
- If Oracle Reports Builder cannot find a library that you specify in the Attached Libraries list, a warning will be raised when you accept the dialog box, save the report, or open the report. If you try to run the report or compile the PL/SQL in it, an error will be raised.
- The Attached Libraries list is saved. The next time you open the report or library the list will have the same contents it did when you last saved the report.
- If an external library references another library, you must attach both libraries to the report even if the first library already has the second one attached.

See also
Section 4.13.5.5, "Attaching a PL/SQL library"

2.6.8 About formulas
Formulas are PL/SQL functions that populate formula or placeholder columns. You can access the PL/SQL for formulas from the Object Navigator, the PL/SQL Editor, or the Property Inspector (that is, the PL/SQL Formula property).

A column with Datatype property set to Number can only have a formula that returns a value of datatype NUMBER. A column with Datatype property set to Date can only have a formula that returns a value of datatype DATE. A column with Datatype property set to Character can only have a formula that returns a value of datatype CHARACTER, VARCHAR, or VARCHAR2.

Restrictions
- You can read and assign values to a column in a formula, if the column is a placeholder or parameter column; you cannot change the value of database columns (values retrieved from the database). For example, you can use the value of a column called COMP in a condition (for example, IF :COMP = 10) and you can directly set its value in an assignment statement (for example, :COMP := 15).
- A formula can only make reference to columns that are in the same or a higher group in the group hierarchy. For example, a formula for a report-level column can only reference other report-level columns.
Formulas are calculated such that any column referenced in the formula will be calculated first. To do so, Oracle Reports Builder builds a dependency list, to guarantee proper ordering of calculations. Notice that circular dependencies, in which a column references another column which in turn references the first column, either directly or indirectly, are not allowed.

When using SRW.DO_SQL, it is recommended that you do not read database values that are updated or inserted in the same report. There is no guarantee of the exact time Oracle Reports Builder will fetch records from the database for formatting the output. Oracle Reports Builder does internal “data look-ahead” to optimize performance. Thus, a particular record might already have been accessed before an update is issued to the same record. Oracle Reports Builder builds internal dependency lists which guarantee that events, such as invocation of user exits, calculation of summaries, and so on, happen in the correct order. However, Oracle Reports Builder cannot guarantee these events will be synchronized with its internal data access or with the formatting of data.

Examples

Example 1: Adding values
The following example populates the column with the value of the salary plus the commission.

```plsql
function salcomm return NUMBER is
begin
  return(:sal + :comm);
end;
```

Example 2: Using conditions
The following code adds the commission to the salary if the value for the commission is not null.

```plsql
function calcomm return NUMBER is
  temp number;
begin
  if :comm IS NOT NULL then
    temp := :sal + :comm;
  else
    temp := :sal;
  end if;
  return (temp);
end;
```

See also
Section 2.3.2, "About formula columns"
Section 4.13.4.3, "Creating or editing a formula column"
Section 4.13.4.4, "Creating a placeholder column"

2.6.9 About group filters
A group filter determines which records to include in a group. You can use the packaged filters, First and Last, to display the first n or last n records for the group, or you can create your own filters using PL/SQL. You can access group filters from the Object Navigator, the Property Inspector (the PL/SQL Filter property), or the PL/SQL Editor.
The function must return a boolean value (TRUE or FALSE). Depending on whether the function returns TRUE or FALSE, the current record is included or excluded from the report.

**Difference between group filters and Maximum Rows to Fetch property**

The Maximum Rows to Fetch property restricts the actual number of records fetched by the query. A group filter determines which records to include or exclude, after all the records have been fetched by the query. Since Maximum Rows to Fetch actually restricts the amount of data retrieved, it is faster than a group filter in most cases. If you set the Filter Type property to Last or Conditional, Oracle Reports Builder must retrieve all of the records in the group before applying the filter. Also, you should be aware that when using Maximum Rows to Fetch for queries, it can affect summaries in other groups that depend on this query. For example, if you set the Maximum Rows to Fetch property to 8, any summaries based on that query will only use the 8 records retrieved.

**Restrictions**

- Group filters cannot be added to groups if the Filter Type property is set to First or Last.
  
  Group filters cannot be added to cross-product groups.

- The function that you enter for a group filter can only depend upon the following columns:
  
  - a database column owned by the group's query or a query above it in the data model hierarchy
  - computed columns (formulas or summaries) that depend on unrelated queries (that is, computed columns that do not depend upon columns in the group, the group's ancestors, or the group's descendants)

- In a group filter, you can read the values of Oracle Reports Builder columns and parameters of the correct frequency, but you cannot directly set their values. For example, you can use the value of a parameter called COUNT1 in a condition (for example, IF :COUNT1 = 10), but you cannot directly set its value in an assignment statement (for example, :COUNT1 := 10). Note also that the use of PL/SQL global variables to indirectly set the values of columns or parameters is not supported. If you do this, you may get unpredictable results. You also cannot reference any page-dependent columns (that is, Reset At of Page) or columns that rely on page-dependent columns in a group filter.

**Example**

```plsql
function filter_comm return boolean is
    begin
        if :comm IS NOT NULL then
            if :comm < 100 then
                return (FALSE);
            else
                return (TRUE);
            end if;
        else
            return (FALSE); -- for rows with NULL commissions
        end if;
    end;
```
See also
Section 4.13.4.2, "Creating or editing a group filter"

2.6.10 About REF CURSOR queries

A REF CURSOR query uses PL/SQL to fetch data. Each REF CURSOR query is associated with a PL/SQL function that returns a cursor value from a cursor variable. The function must ensure that the REF CURSOR is opened and associated with a SELECT statement that has a SELECT list that matches the type of the REF CURSOR.

Note: The use of REF CURSOR queries in Oracle Reports 12c (12.2.1.1) requires that your database version is 10.1.0.5 (for 10.1) or 10.2.0.2 (for 10.2) or higher.

Interoperability between a 12c (12.2.1.1) database or Oracle Forms Services client and a 10.1/10.2 database requires a minimum patchset level of 10.1.0.5 (for 10.1) or 10.2.0.2 (for 10.2).

An attempt to reference a 10.1 or 10.2 PL/SQL unit or view under the following circumstances will fail with a PLS-801[55916] error unless the 10.1 or 10.2 environment has been patched to the right level:

- A PL/SQL unit, anonymous block, trigger, call statement, or SQL statement on a 12c (12.2.1.1) database invokes a PL/SQL unit on a 10.1 or 10.2 database across a database link.
- A PL/SQL unit, anonymous block, trigger, or call statement on a 12c (12.2.1.1) database references a view on a 10.1 or 10.2 database across a database link and the view directly or indirectly references a PL/SQL function or an object type.
- An Oracle Forms Services 12c (12.2.1.1) client invokes a PL/SQL unit in a 10.1 or 10.2 database using RPC.

Oracle Reports supports both static and dynamic REF CURSORS. For example:

**Static REF CURSOR:**

```plsql
open l_rc for SELECT * FROM emp WHERE ename = 'KING';
```

**Dynamic REF CURSOR:**

```plsql
l_query := SELECT empno, ename, sal, hiredate FROM emp WHERE 1-1';
open l_rc for l_query;
```

**Note:** The `SELECT` statement must be explicitly set for dynamic REF CURSORS.

For a detailed example, see Chapter 41, "Building a Paper Report with REF CURSORs".

**Usage notes**

- Oracle Reports supports only strongly typed REF CURSORS. For example:
  ```plsql
type c1 is REF CURSOR RETURN emp%ROWTYPE;
  ```
- When you make a REF CURSOR query the child in a data link, the link can only be a group to group link. It cannot be a column to column link.
If you use a stored program unit to implement `REF CURSORS`, you receive the added benefits that go along with storing your program units in the Oracle database.

You base a query on a `REF CURSOR` when you want to:

- more easily administer SQL.
- avoid the use of lexical parameters in your reports.
- share data sources with other applications, such as Form Builder.
- increase control and security.
- encapsulate logic within a subprogram.

Furthermore, if you use a stored program unit to implement `REF CURSORS`, you receive the added benefits that go along with storing your program units in the Oracle database.

For more information about `REF CURSORS` and stored subprograms, refer to the `PL/SQL User’s Guide and Reference`.

**Examples**

**Example 1: Package with `REF CURSOR` example**

```plsql
/* This package spec defines a `REF CURSOR` type that could be referenced from a `REF CURSOR` query function. If creating this spec as a stored procedure in a tool such as SQL*Plus, you would need to use the CREATE PACKAGE command. */

PACKAGE cv IS
  type comp_rec is RECORD
    (deptno number,
     ename varchar(10),
     compensation number);
  type comp_cv is REF CURSOR return comp_rec;
END;
```

**Example 2: Package with `REF CURSOR` and function**

```plsql
/* This package spec and body define a ref cursor type as well as a function that uses the `REF CURSOR` to return data. The function could be referenced from the `REF CURSOR` query, which would greatly simplify the PL/SQL in the query itself. If creating this spec and body as a stored procedure in a tool such as SQL*Plus, you would need to use the CREATE PACKAGE and CREATE PACKAGE BODY commands. */

PACKAGE cv IS
  type comp_rec is RECORD
    (deptno number,
     ename varchar(10),
     compensation number);
```
type comp_cv is REF CURSOR return comp_rec;
function emprefc(deptno1 number) return comp_cv;
END;

PACKAGE BODY cv IS
function emprefc(deptno1 number) return comp_cv is
  temp_cv cv.comp_cv;
beg
  if deptno1 > 20 then
    open temp_cv for select deptno, ename,
    1.25*(sal+nvl(comm,0)) compensation
    from emp where deptno = deptno1;
  else
    open temp_cv for select deptno, ename,
    1.15*(sal+nvl(comm,0)) compensation
    from emp where deptno = deptno1;
  end if;
  return temp_cv;
end;
END;

Example 3: REF CURSOR query
/* This REF CURSOR query function would be coded
** in the query itself. It uses the cv.comp_cv
** REF CURSOR from the cv package to return
** data for the query.
*/
function DS_3RefCurDS return cv.comp_cv is
  temp_cv cv.comp_cv;
beg
  if :deptno > 20 then
    open temp_cv for select deptno, ename,
    1.25*(sal+nvl(comm,0)) compensation
    from emp where deptno = :deptno;
  else
    open temp_cv for select deptno, ename,
    1.15*(sal+nvl(comm,0)) compensation
    from emp where deptno = :deptno;
  end if;
  return temp_cv;
end;

Example 4: REF CURSOR query calling function
/* This REF CURSOR query function would be coded
** in the query itself. It uses the cv.comp_cv
** REF CURSOR and the cv.emprefc function from
** the cv package to return data for the query.
** Because it uses the function from the cv
** package, the logic for the query resides
** mainly within the package. Query
** administration/maintenance can be
** done at the package level (for example,
** modifying SELECT clauses could be done
** by updating the package). You could also
** easily move the package to the database.
** Note this example assumes you have defined
** a user parameter named deptno.
*/
function DS_3RefCurDS return cv.comp_cv is
  temp_cv cv.comp_cv;
begin
  temp_cv := cv.emprefc(:deptno);
  return temp_cv;
end;

See also
Section 4.8.1.7, "Creating a query: REF CURSOR Query tool"

2.6.11 About DML and DDL

If you want to use Data Manipulation Language (DML) or Data Definition Language (DDL) in your PL/SQL, you can use the SRW.DO_SQL built-in procedure. Notice that SRW.DO_SQL should only be used for DML and DDL; you should not use it to fetch data. For more information on DML and DDL, see the Oracle Server SQL Language Reference manual.

Because of Oracle Reports' processing model, it is recommended that you only use DDL in the Before Parameter Form and After Parameter Form triggers. DML can be entered any place that accepts PL/SQL.

Any DML or DDL that will be reported on with this report's processing should be done in (or before) the After Parameter Form trigger. Consistency cannot be guaranteed in the Before Report trigger, since Oracle Reports may have to start some work on data cursors before that trigger based on the definition of the report. One thing Oracle Reports Builder always does before the Before Report trigger is to describe the tables involved and open cursors. Any change to the tables after that will not be seen by the report.

See also
Section 2.6.13.1, "About report triggers"

2.6.12 About built-in packages

A built-in package is a group of logically related PL/SQL types, objects, and functions or procedures. It generally consists of two parts: the package spec (including data declarations) and the package body. Packages are especially useful because they allow you to create global variables.

Oracle provides several packaged procedures that you can use when building or debugging your PL/SQL-based applications. Your PL/SQL code can make use of the procedures, functions, and exceptions in the Oracle Reports Builder built-in package (SRW), and numerous Tools built-in packages, as described below.

2.6.12.1 About the Oracle Reports Builder built-in package (SRW)

Oracle Reports Builder is shipped with a built-in package (SRW), a collection of PL/SQL constructs that include many functions, procedures, and exceptions you can reference in any of your libraries or reports.

The PL/SQL provided by the SRW package enables you to perform such actions as change the formatting of fields, run reports from within other reports, create customized messages to display if a report error occurs, and execute SQL statements.

You can reference the contents of the SRW package from any of your libraries or reports without having to attach it. However, you cannot reference its contents from within another product, for example, from SQL*Plus.
Constructs found in a package are commonly referred to as "packaged" (that is, packaged functions, packaged procedures, and packaged exceptions).

See also
Topic "SRW built-in package" in the Reference section of the Oracle Reports online Help

2.6.12.2 About the Tools built-in packages
Several client-side built-in packages are provided that contain many PL/SQL constructs you can reference while building applications or debugging your application code. These built-in packages are not installed as extensions to the package STANDARD. As a result, any time you reference a construct in one of the packages, you must prefix it with the package name (for example, TEXT_IO.PUT_LINE).

The Tools built-in packages are:

- **DDE**
  Provides Dynamic Data Exchange support within Oracle Reports Builder components.

- **DEBUG**
  Provides procedures, functions, and exceptions for when debugging your PL/SQL program units. Use these built-in subprograms to create debug triggers and set breakpoints with triggers.

- **EXEC_SQL**
  Provides procedures and functions for executing dynamic SQL within PL/SQL code written for Oracle Reports Builder applications.

- **LIST**
  Provides procedures, functions, and exceptions you can use to create and maintain lists of character strings (VARCHAR2). This provides a means of creating arrays in PL/SQL Version 1.

- **ORA_FFI**
  Provides a foreign function interface for invoking C functions in a dynamic library.

- **ORA_JAVA**
  Provides an interface for invoking Java classes from PL/SQL.

- **ORA_NLS**
  Enables you to extract high-level information about your current language environment. This information can be used to inspect attributes of the language, enabling you to customize your applications to use local date and number format. Information about character set collation and the character set in general can also be obtained. Facilities are also provided for retrieving the name of the current language and character set, allowing you to create applications that test for and take advantage of special cases.

- **ORA_PROF**
  Provides procedures, functions, and exceptions you can use for tuning your PL/SQL program units (for example, examining how much time a specific piece of code takes to run).

- **TEXT_IO**
Provides constructs that allow you to read and write information from and to files. There are several procedures and functions available in Text_IO, falling into the following categories:

- **file operations.** The FILE_TYPE record, the FOPEN and IS_OPEN functions, and the FCLOSE procedure enable you to define FILE_TYPE variables, open files, check for open files, and close open files, respectively.

- **output (write) operations.** The PUT, PUTF, PUT_LINE, and NEW_LINE procedures enable you to write information to an open file or output it to the PL/SQL Interpreter.

- **input (read) operations.** The GET_LINE procedure enables you to read a line from an open file

- **TOOL_ENV**
  Enables you to interact with Oracle environment variables by retrieving their values for use in subprograms.

- **TOOL_ERR**
  Enables you to access and manipulate the error stack created by other built-in packages such as DEBUG.

  In addition to using exceptions to signal errors, some built-in packages (for example, the DEBUG package) provide additional error information. This information is maintained in the form of an “error stack”.

  The error stack contains detailed error codes and associated error messages. Errors on the stack are indexed from zero (oldest) to n-1 (newest), where n is the number of errors currently on the stack. Using the services provided by the TOOL_ERR package, you can access and manipulate the error stack.

- **TOOL_RES**
  Provides a means of extracting string resources from a resource file with the goal of making PL/SQL code more portable by isolating all textual data in the resource file.

  The following packages are used only internally by Oracle Reports. There are no subprograms available for external use with these packages.

- **ORA_DE**
  Contains constructs used by Reports for private PL/SQL services.

- **STPROC**
  Calls subprograms stored in the database. Calls to this package are automatically generated Note: STPROC is obsoleted in Oracle Reports 12c (12.2.1.1).

- **JNI**
  Facilitates calling Java from PL/SQL.

**See also**
Topics for each of the Tools built-in packages under in the Reference > PL/SQL Reference > Built-in Packages section of the Oracle Reports online Help.

### 2.6.13 About triggers

Triggers check for an event. When the event occurs they run the PL/SQL code associated with the trigger.
Report triggers are activated in response to report events such as the report opening and closing rather than the data that is contained in the report. They are activated in a predefined order for all reports.

Format triggers are executed before an object is formatted. A format trigger can be used to dynamically change the formatting attributes of the object.

Validation triggers are PL/SQL functions that are executed when parameter values are specified on the command line and when you accept the Runtime Parameter Form.

Database triggers are procedures that are stored in the database and implicitly executed when a triggering statement such as INSERT, UPDATE, or DELETE is issued against the associated table.

2.6.13.1 About report triggers

Report triggers execute PL/SQL functions at specific times during the execution and formatting of your report. Using the conditional processing capabilities of PL/SQL for these triggers, you can do things such as customize the formatting of your report, perform initialization tasks, and access the database. To create or modify a report trigger, you use the Report Triggers node in the Object Navigator. Report triggers must explicitly return TRUE or FALSE.

Oracle Reports has five global report triggers. You cannot create new global report triggers. The trigger names indicate at what point the trigger fires:

- **Before Report trigger**: Fires before the report is executed but after queries are parsed.
- **After Report trigger**: Fires after you exit the Paper Design view, or after report output is sent to a specified destination, such as a file, a printer, or an e-mail ID. This trigger can be used to clean up any initial processing that was done, such as deleting tables. Notice, however, that this trigger always fires, whether your report completed successfully or not.
- **Between Pages trigger**: Fires before each page of the report is formatted, except the very first page. This trigger can be used for customized page formatting. In the Paper Design view, this trigger only fires the first time that you go to a page. If you subsequently return to the page, the trigger does not fire again.
- **Before Parameter Form trigger**: Fires before the Runtime Parameter Form is displayed. From this trigger, you can access and change the values of parameters, PL/SQL global variables, and report-level columns. If the Runtime Parameter Form is suppressed, this trigger still fires. Consequently, you can use this trigger for validation of command line parameters.
- **After Parameter Form trigger**: Fires after the Runtime Parameter Form is displayed. From this trigger, you can access parameters and check their values. This trigger can also be used to change parameter values or, if an error occurs, return to the Runtime Parameter Form. Columns from the data model are not accessible from this trigger. If the Runtime Parameter Form is suppressed, the After Parameter Form trigger still fires. Consequently, you can use this trigger for validation of command line parameters or other data.

Order of report trigger execution

The order of events when a report is executed is as follows:

1. Before Parameter Form trigger is fired.
2. Runtime Parameter Form appears (if not suppressed).
3. After Parameter Form trigger is fired (unless the user cancels from the Runtime Parameter Form).
4. Report is ‘compiled’.
5. Queries are parsed.
7. SET TRANSACTION READONLY is executed (if specified with the READONLY command line keyword or setting).
8. The report is executed and the Between Pages trigger fires for each page except the first one. (Notice that data can be fetched at any time while the report is being formatted.) COMMITs can occur during this time due to: SRW.DO_SQL with DDL, or if ONFAILURE=COMMIT, and the report fails.
9. COMMIT is executed (if READONLY is specified) to end the transaction.
10. After Report trigger is fired.
11. COMMIT/ROLLBACK/NOACTION is executed based on what was specified with the ONSUCCESS command line keyword or setting.

Usage notes
- In steps 4 through 9, avoid DDL statements that would modify the tables on which the report is based. Step 3 takes a snapshot of the tables and the snapshot must remain valid throughout the execution of the report. In steps 7 through 9, avoid DML statements that would modify the contents of the tables on which the report is based. Queries may be executed in any order, which makes DML statements unreliable (unless performed on tables not used by the report).
- If you specify READONLY on the command line, you should avoid DDL altogether. When you execute a DDL statement (for example, with SRW.DO_SQL), a COMMIT is automatically issued. If you are using READONLY, this will prematurely end the transaction begun by SET TRANSACTION READONLY.
- As a general rule, any processing that will affect the data retrieved by the report should be performed in the Before Parameter Form or After Parameter Form triggers. (These are the two report triggers that fire before anything is parsed or fetched.) Any processing that will not affect the data retrieved by the report can be performed in the other triggers.
- Consistency is guaranteed if you use DML or DDL in (or before) the After Form Trigger. However, consistency is not guaranteed in the Before Report trigger, since Oracle Reports may have to start work on data cursors before that trigger based on the definition of the report. Before the Before Report trigger, Oracle Reports
describes the tables involved and opens cursors. Any change to the tables after that will not be seen by the report.

Restrictions

- If you are sending your report output to the Paper Design view or Previewer, you should observe that some or all of the report triggers may be fired before you see the report output. For example, suppose that you use SRW.MESSAGE to issue a message in the Between Pages trigger when a condition is met. If there are forward references in the report (for example, a total number of pages displayed before the last page), Oracle Reports may have to format ahead to compute the forward references. Hence, even though you have not yet seen a page, it may already have been formatted and the trigger fired.

- In report triggers, you can use the values of report-level columns and parameters. For example, you might need to use the value of a parameter called COUNT1 in a condition (for example, IF :COUNT1 = 10). Note, though, that you cannot reference any page-dependent columns (that is, a column with a Reset At property set to Page) or columns that rely on page-dependent columns.

- In the Before and After Parameter Form, and Before and After Report triggers, you can set the values of parameters (for example, give them a value in an assignment statement, :COUNT1 = 15). In the Before and After Report triggers, you can also set the values of report-level, placeholder columns.

- In the Between Pages trigger, you cannot set the values of any data model objects. Note also that the use of PL/SQL global variables to indirectly set the values of columns or parameters is not recommended. If you do this, you may get unpredictable results.

- A lexical reference cannot be used to create additional bind variables after the After Parameter Form trigger fires. For example, suppose you have a query like the following (notice that the WHERE clause is replaced by a lexical reference):

  ```plsql
  SELECT ENAME, SAL FROM EMP 
  &WHERE_CLAUSE
  ```

  If the value of the WHERE_CLAUSE parameter contains a reference to a bind variable, you must specify the value in the After Parameter Form trigger or earlier. You would get an error if you supplied the following value for the parameter in the Before Report trigger. If you supplied this same value in the After Parameter Form trigger, the report would run.

  ```plsql
  WHERE SAL = :new_bind
  ```

See also

Section 4.13.3.5, "Creating a report trigger"
Section 4.13.3.6, "Deleting a report trigger"

### 2.6.13.2 About format triggers

A format trigger is a PL/SQL function executed before an object is formatted. A trigger can be used to dynamically change the formatting attributes of the object. For example, you can use a format trigger to cause a value to display in bold if it is less than zero. Another example is to use a format trigger to use scientific notation for a field if its value is greater than 1,000,000.

A format trigger can fire multiple times for a given object, whenever Oracle Reports Builder attempts to format the object. Consider the case where Oracle Reports Builder
starts to format the object at the bottom of a page. If the object does not fit on the page, Oracle Reports Builder stops formatting and reformats on the following page. In this case, the format trigger will fire twice. It is therefore not advisable to do any kind of "persistence" operation, such as logging, in this trigger.

The Oracle Reports Builder SRW built-in package contains PL/SQL procedures with which you can quickly change the format attributes of an object. These include procedures to:

- change the border pattern and color of an object
- change the interior pattern and color of an object
- change the font size, style, weight, spacing, and justification of a field or boilerplate text
- change the format mask of a field
- access a field’s value

**Examples**
See the topic "Format trigger" in the Reference section of the Oracle Reports online Help.

**See also**
Section 4.13.4.1, "Creating or editing a format trigger"

**2.6.13.3 About validation triggers**
Validation triggers are PL/SQL functions that are executed when parameter values are specified on the command line and when you accept the Runtime Parameter Form.

**Note:** For JSP-based Web reports, the Runtime Parameter Form displays when you run a report in Oracle Reports Builder, but does not display in the runtime environment. If parameters are not specified on the Runtime Parameter Form, the validation trigger returns false and generates error message rep-546 Invalid Parameter Input error. Thus, you need to provide the parameters in an alternate way, as described in Section 1.9.4, "About Parameter Forms for Web reports".

Validation triggers are also used to validate the Initial Value property of the parameter. Depending on whether the function returns TRUE or FALSE, the user is returned to the Runtime Parameter Form.

**Example**
See the topic "Validation trigger" in the Reference section of the Oracle Reports online Help.

**See also**
Section 4.11.4, "Validating a parameter value at runtime"

**2.6.13.4 About database triggers**
Database triggers are procedures that are stored in the database and implicitly executed when a triggering statement such as INSERT, UPDATE, or DELETE is issued against the associated table. Triggers can be defined only on tables, not on views.
However, triggers on the base table of a view are fired if an INSERT, UPDATE, or DELETE statement is issued against a view.

A trigger can include SQL and PL/SQL statements that execute as a unit, and can invoke other stored procedures. Use triggers only when necessary. Excessive use of triggers can result in cascading or recursive triggers. For example, when a trigger is fired, a SQL statement in the trigger body potentially can fire other triggers.

By using database triggers, you can enforce complex business rules and ensure that all applications behave in a uniform manner. Use the following guidelines when creating triggers:

- Use triggers to guarantee that when a specific operation is performed, related actions are performed.
- Use database triggers only for centralized, global operations that should be fired for the triggering statement, regardless of which user or database application issues the statement.
- Do not define triggers that duplicate the functionality already built into Oracle. For example, do not define triggers to enforce data integrity rules that can be easily enforced using declarative integrity constraints.
- Limit the size of triggers (60 lines or fewer is a good guideline). If the logic for your trigger requires much more than 60 lines of PL/SQL code, it is better to include most of the code in a stored procedure, and call the procedure from the trigger.
- Be careful not to create recursive triggers. For example, creating an AFTER UPDATE statement trigger on the EMP table that itself issues an UPDATE statement on EMP causes the trigger to fire recursively until it has run out of memory.

For additional information about how triggers are used in applications, see the *Oracle Application Developer’s Guide*. See the *Oracle Concepts Manual* for more information about the different types of triggers.

See also
Section 4.13.3.7, "Creating a database trigger"

### 2.7 Templates

The topics in this section discuss the use of templates in Oracle Reports Builder.

- About templates
- About template attributes
- About applying templates
- About inheritance in templates
- About the Template Editor

#### 2.7.1 About templates

Templates define common characteristics and objects that you want to apply to multiple paper-based reports. For example, you can define a template that includes the company logo and sets fonts and colors for selected areas of a report.

When you use the Report Wizard to create a paper-based report, you use the Templates page of the wizard to apply a template (.tdf file) to the report. The
Templates page lists the default templates, as well as any templates that you have created.

---

**Note:** If the list of templates does not appear, make sure that the REPORTS_PATH environment variable includes the location of the templates (for example, ORACLE_HOME\reports\templates).

---

When you choose a template, objects in the margin area of a template are imported into the same locations in the current report section, overwriting any existing objects. The characteristics (formatting, fonts, colors, and so on) of objects in the body area of the template are applied to objects in the body area of the current report section. Any template properties, parameters, report triggers, program units, and attached libraries you have defined are also applied. You can apply different templates to each section of the report. However, if you are applying one of the default templates, you cannot combine two report blocks that use different default templates in a single report. All of your report blocks in any one report must use the same default template.

If you later apply another template to a report, the existing template objects will be deleted in the current report section.

**See also**
Section 4.12, "Define a Template"

### 2.7.2 About template attributes

In the Layout Body area of a template, you can define Default and Override attributes under the following Object Navigator nodes:

- **Frames**, which contains the following:
  - a **Section Frame** node, which defines attributes for the parent frame surrounding the currently selected section.
  - a **Headings Frame** node, which defines attributes for the parent frame surrounding the column headings.
  - a **Fields Frame** node, which defines attributes for the parent frame surrounding the fields.
  - a **Summaries Frame** node, which defines attributes for the parent frame surrounding the summaries (totals).

- **Field Labels/Headings**, which contains the following:
  - a **Character** node, which defines attributes for the labels or column headings of character fields.
  - a **Number** node, which defines attributes for the labels or column headings of number fields.
  - a **Date** node, which defines attributes for the labels or column headings of date fields.

- **Fields**, which contains the following:
  - a **Character** node, which defines attributes for character fields.
  - a **Number** node, which defines attributes for number fields.
  - a **Date** node, which defines attributes for date fields.
Templates

- **Summary Labels**, which contains the following:
  - a **Character** node, which defines attributes for the labels of summaries on character fields.
  - a **Number** node, which defines attributes for the labels of summaries on numeric fields.
  - a **Date** node, which defines attributes for the labels of summaries on date fields.

- **Summaries**, which contains the following:
  - a **Character** node, which defines attributes for summaries on character fields.
  - a **Number** node, which defines attributes for summaries on number fields.
  - a **Date** node, which defines attributes for summaries on date fields.

**Default attributes**
The **Default** node in the Object Navigator defines the default visual attributes (formatting, fonts, colors, and so on) for all report styles. If you want to define attributes for individual report styles, you do so under the **Override** node. When you apply a template to a report, all Default attributes are applied to the report, except for attributes that are localized under the **Override** node.

**Override attributes**
Under the **Override** node in the Object Navigator, you can define attributes for individual report styles. Each report style contains one or more sections that map to groups in the report:

- **Single-section report styles**: Tabular, Form, Mailing Label, Form Letter
- **Multiple section report styles**: Group Left, Group Above, Matrix, Matrix with Group

For the report styles that support multiple groups, you can create additional sections as needed. Sections are mapped to groups as follows:

- **Same number of groups as sections**: one-to-one mapping (the first section is mapped to the first group, the second section to the second group, and so on).
- **More groups than sections**: one-to-one mapping until the next-to-last section. Then, all subsequent groups are mapped to the next-to-last section, and the last group is mapped to the last section. If only one section exists, all groups are mapped to it.
- **More sections than groups**: one-to-one mapping until the next-to-last group. Then, the last group is mapped to the last section.

**See also**
Section 4.12.2, "Defining default template attributes"
Section 4.12.3, "Defining override template attributes"

### 2.7.3 About applying templates
When you apply a template to a report, all of the following objects, properties, and attributes from the template are applied to the current report section:

- parameters and their validation triggers
- physical page size
- logical page size
■ character/bitmap mode
■ margin position
■ panel print order

In addition, all of the layout objects in the margin of the template are copied into the same location in the current report section.

Usage notes
■ The template will be applied to the current section of the report (the section displayed in the Paper Layout view) by default. If no section is displayed, the template will be applied to the Main Section of the report by default. If you select the node for the entire report in the Object Navigator, the template will be applied to the Main Section of the report by default. To apply the template to a specific section of your report, select the node for that section in the Object Navigator.

■ You can apply different templates to each section of the report. However, if you are applying one of the default templates, you cannot combine two report blocks that use different default templates in a single report. All of your report blocks in any one report must use the same default template.

See also
Section 4.12.4, "Applying a template to a report"

2.7.4 About inheritance in templates

In templates, Sections, Frames, Fields, Labels, Headings, and Summaries properties all may inherit their values.

Default properties
The Default properties inherit the values preset by Oracle Reports Builder. When a property is set to its default Oracle Reports Builder value, the icon next to it in the Property Inspector is a small circle. Default properties become localized when you change their values, or select them and click the Localize Property button in the toolbar. When a property is localized, the icon next to it changes to a square. To return the properties to their inherited values, select the properties and click the Inherit Property button in the toolbar.

Override properties
The properties of Override Sections inherit their values from the Default properties. When a property inherits from a Default property, the icon next to it in the Property Inspector is an arrow. Properties in the Override Sections become localized when you change their values, or select them and click the Localize Property button in the toolbar. When a property is localized, the icon next to it changes to an arrow with a red cross through it. To return the values of properties in the Override Sections to their inherited values, select the properties and click the Inherit Property button in the toolbar.

2.7.5 About the Template Editor

The Template Editor is a work area in which you can define objects and formatting properties for your templates. It is similar to the Paper Layout view of the Report Editor. You can create, delete, and modify objects (for example, page numbers, text, and graphics) in the margin area. You cannot create and delete objects in the body
area, but you can modify the properties of body objects in the Property Inspector (Tools > Property Inspector).

The Report Style list enables you to view the layout for a selected report style. To define default settings for all report styles, you can choose Default from the Report Style list. To make changes for an individual report style, you can select that report style from the Report Style list to specify settings that override the default.

**Access**

You can access the Template Editor in the following ways:

When creating a new template:

- Choose File > New > Template.
- In the Object Navigator, click the Templates node, then click the Create button in the toolbar.

When displaying an existing template:

- From the Window menu, choose a window displaying Template Editor Paper Layout view.
- In the Object Navigator, double-click the view icon next to the Paper Layout node for a template.

### 2.8 Output Formats and Capabilities

The topics in this section discuss the various output formats and capabilities in Oracle Reports Builder.

- About format order
- About batch reporting
- About report distribution
- About pluggable destinations
- About event-driven publishing
- About switching the printer tray
- About XML in reports
- About HTML and HTMLCSS output
- About HTML formatting
- About PDF output
- About RTF output
- About delimited output
- About Enhanced Spreadsheet output
- About text output
- About creating an ASCII (character-mode) report
2.8.1 About format order

In prior releases, Oracle Reports formatted the sections of a report in sequential order: Header section, followed by Main section, followed by Trailer section. This release introduces the capability to change the order in which the three sections of a report are formatted.

The format order can be set in either of the following ways:

- Format Order of Sections property
- `SRW.SET_FORMAT_ORDER` built-in procedure (if defined, overrides the Format Order of Sections property setting)

This feature is useful for formatting any report section first to retrieve information that is known only at the time of formatting, such as page numbers, then using that information in the formatting of a previous section.

For example, to create a table of contents (TOC) for a report, you can format the Main section first and use report triggers to build a table containing the TOC entries. When the first element for the TOC is formatted, a trigger fires and creates a row in the TOC table containing the TOC entry and the page number. After the Main section has completed formatting, the format order setting can define that the Header section is formatted next. The Header section can contain a report block based on the TOC table. After formatting, you can output your report with a TOC (the Header section), followed by the report body (the Main section), followed by the Trailer section.

For the steps to create a TOC for a report, see the example reports in Chapter 35, "Building a Paper Report with a Simple Table of Contents and Index" and Chapter 36, "Building a Paper Report with a Multilevel Table of Contents".

A note about page numbering:

The page numbering of a report follows the format order. For example, in a report with a Header section of 2 pages, a Main section of 8 pages, and a Trailer section of 3 pages, with Format Order set to Main-Trailer-Header, the page numbering will be as follows in the report output: 12, 13 (Header pages, which were formatted last), 1, 2, 3, 4, 5, 6, 7, 8, (Main pages, which were formatted first) 9, 10, 11 (Trailer pages, which were formatted second).
2.8.2 About batch reporting

If it is not necessary to examine report output in the Previewer (for example, you may have to generate large volumes of output from a fully-tested report or run several reports in succession), you can run your report in batch using rwrun. This leaves you free to pursue other tasks while your reports are running.

You can run reports in batch mode from the command line, or use a command file to specify arguments. A command file can save you a great deal of typing if you wish to run several reports using the same set of arguments.

You can also use the Reports Server to batch process reports by specifying BACKGROUND=YES on the command line (valid for rwclient or rwservlet) to run reports asynchronously (the client sends the call to the server, then continues with other processes without waiting for the report job to complete; if the client process is killed, the job is canceled).

See also
Section 4.7.2, "Running a report from the command line"
Section 4.7.3, "Running a report using a command file"
The Reference > Command Line section of the Oracle Reports online Help (for information about BATCH and BACKGROUND)

2.8.3 About report distribution

Report distribution enables you to design a report that can generate multiple output formats and be distributed to multiple destinations from a single run of the report. You can create distributions for an entire report, and also burst to distribute individual sections of the report. For example, in a single run of a report, you can generate HTML output, send a PostScript version to the printer, and also e-mail any or all sections of the report to a distribution list.

To distribute a report, you first define the distribution, then enable the distribution, as described in Section 4.7.12, "Distributing a report to multiple destinations".

For an example of using section-level distribution, see Chapter 37, "Bursting and Distributing a Report". This chapter covers defining distribution of a single section to multiple destinations, using the Repeat On property and distribution XML file.

Usage notes

■ You cannot mix character mode and bit-mapped output in one report. The MODE system parameter can only be set to one value per the entire report (DEFAULT, BITMAP, or CHARACTER).

■ In order to use the same report definition file to burst and distribute to data-driven formats such as XML and DELIMITEDDATA, as well as to layout-driven formats such as PDF and ENHANCEDSPREADSHEET, you must ensure the following requirements are met:

■ The distribution XML file must specify the include element. For example:

```xml
&lt;include src="mainSection"/&gt;
```

■ The Repeat On property must be set appropriately for the section(s) specified in the distribution XML file.

■ The section(s) specified in the distribution XML file in the report paper layout must not be empty.
Examples

Example 1
You can use sectioning and distribution to publish your report output in HTML, and also send a PostScript version to the printer.

Example 2
You can send an executive summary of a report to senior management, and also e-mail detailed breakdowns to individual managers. In this example, a single report with two report sections must be created: a portrait-sized summary section and a landscape-sized detail section. Use the Repeat On property to associate the detail section with a data model group that lists the managers and then alter the destination to *burst* the report on each instance of the data model group to send the output to the appropriate managers.

See also
Section 2.1.2, "About report sectioning and sections"
Section 4.14.19, "Tracing report distribution"
Chapter "Creating Advanced Distributions" in the *Publishing Reports to the Web with Oracle Reports Services* manual.

2.8.3.1 About the DST file
As an alternative to defining the distribution for a report or report section in the Distribution dialog box, you can also create a DST file and specify its name on the command line with the DESTINATION keyword to distribute the report.

---

**Note:** DST files are supported for backward compatibility with prior releases; the preferred and recommended method of distributing reports is with the Distribution dialog box or using XML.

---

If a DST file is specified on the command line, the distribution that it defines overrides the distribution defined using the Distribution dialog box.

---

**Note:** If you trace report distribution to identify distribution errors (see Section 4.14.19, "Tracing report distribution"), the trace file format is very similar to the DST file, so you can cut and paste to generate a DST file from the trace file.

---

The format of each line of a DST file is as follows:

```
dist_ID: output_def
```

where

- `dist_ID` is an identifier for a distribution destination.
- `output_def` is a series of `rwrn` or `rwclnt` command line keywords that specify the distribution definition. In addition, the following parameter is valid:
  - `LEVEL` specifies the scope of the distribution.

**Values for LEVEL**
REPORT means that the distribution applies to the entire report.
Header_Section means that the distribution applies to the header section only.
Main_Section means that the distribution applies to the main (body) section only.
Trailer_Section means that the distribution applies to the trailer section only.

**Default**
REPORT

**Example**
The definition in this example sends report output to an HTML file, 3 copies of the main section to a printer, and the header section to a PDF file.

;dst file (specified with the DESTINATION keyword on the command line)
DEST1: DESNAME=dst1.HTM DESTYPE=file DESFORMAT=HTML COPIES=1 LEVEL=Report
DEST2: DESNAME=prt1 DESTYPE=printer DESFORMAT=BITMAP COPIES=3 LEVEL=Main_Section
DEST3: DESNAME=SECT1.pdf DESTYPE=file DESFORMAT=pdf COPIES=1 LEVEL=Header_Section

**Note:** All parameters for each distribution destination in a DST file (DEST1, DEST2, and DEST3 in the example above) must be specified on a single line. Specifying parameters on a new line results in failed distribution with error message REP-34304 and/or REP-34305.

**See also**
Section 2.1.2, "About report sectioning and sections"

### 2.8.4 About pluggable destinations

Pluggable destinations can be used to distribute any content that an engine (not only the Oracle Reports engine) has created in the Reports Server's cache. Oracle Reports provides the following out-of-the-box destinations:

- Web
- printer
- e-mail
- file
- Oracle Portal
- FTP
- WebDAV

You can also define access to your own custom destination by using the Oracle Reports Java APIs to implement a new destination component in the Reports Server. You can choose for your jobs to use an out-of-the-box destination or your customized destination to determine the destination for the output in the cache.

For information and steps to implement and register a destination class, then use the destination with Oracle Reports, see the Oracle FTP Destination tutorial available on the Oracle Reports Plugin Exchange on the Oracle Technology Network (OTN): on the Oracle Reports page (http://www.oracle.com/technetwork/middleware/reports/overview/index.html), click **Plugin Exchange**.
2.8.5 About event-driven publishing

Event-driven publishing enables you to set up a report to execute when a certain action has been performed. For example, when an employee submits an expense report, new data is being inserted into the database. When this insert event (for example, a database trigger or an Advanced Queuing (AQ) message) occurs, a report is sent to the employee’s manager through their portal page or e-mail notifying them to approve/reject this expense report.

Event-driven publishing functionality includes making report objects available inside Oracle Workflow.

For detailed information, refer to the "Using Event-Driven Publishing" chapter in Publishing Reports to the Web with Oracle Reports Services.

2.8.6 About switching the printer tray

Using the Before Report, Between Pages, or format triggers, you can switch to different printer trays as your report formats. This enables you to easily print pages of the same report on different sheets of paper (for example, letterhead, forms, colored).

You can determine the names of the printer trays defined for your printer in the Page Setup dialog box, then use SRW.SET_PRINTER_TRAY to set the printer tray as desired.

See also
Section 4.7.17.5, "Switching the printer tray"

2.8.7 About XML in reports

Oracle Reports uses XML (Extensible Markup Language) in the following ways:

- XML tags are used to define Web-based reports (see the topic "Oracle Reports XML tags" in the Reference section of the Oracle Reports online Help).
- XML helps to define tag-delimited, structured information.
- XML is a supported pluggable data source (PDS). For more information, see Chapter 45, "Building a Report with an XML Pluggable Data Source".

XML is a form of encoding text formats that can be read by many different applications. The XML tags can be used to output information or as a basis for building a pluggable data source to exchange electronic data with a third-party application (EDI).

You may change the XML properties that control XML output for your report at three levels: report, group, and column. Notice that in any Oracle Reports Builder-generated XML file, your output mimics the data model, structured by groups and columns. For information on how to view your changes in XML output, see Section 4.7.7,
"Generating XML output".

For detailed information about using XML for report distribution and customizing reports through XML, see the "Creating Advanced Distributions" and "Customizing Reports with XML" chapters in Publishing Reports to the Web with Oracle Reports Services.

See also
Section 4.7.7, "Generating XML output"
Section 4.7.1, "Running and dispatching a report from the user interface"
The XML PDS section of the Oracle Reports online Help

2.8.8 About HTML and HTMLCSS output

Oracle Reports Builder can generate report output to Hypertext Markup Language (HTML) and Hypertext Markup Language with a Cascading Style Sheet (HTMLCSS) files, containing the formatted data and all objects. When you generate your report output to an HTML or HTMLCSS file, you can distribute the output to any HTML destination, including e-mail, printer, Oracle Portal, and Web browser.

Note: This topic discusses the HTML generated when you run a paper-based report to an HTML or HTMLCSS file. This is unrelated to HTML that might be generated when you run a JSP-based Web report (when you click the Run Web Layout button in the toolbar, or choose Program > Run Web Layout).

Usage notes
■ You apply style sheets and user-defined styles to your report or report objects for HTMLCSS output, using the following properties:
  – Style Sheets property
  – CSS Class Name property
  – CSS ID property
■ You can include HTML formatting in all bitmap output supported by Oracle Reports (including PDF, RTF, HTML, HTMLCSS, and PostScript), as described in Section 2.8.9, "About HTML formatting".
■ HTML and HTMLCSS output pass HTML 4.01 syntax checkers.

Note: If you modify your report's Before Report Value property or After Report Value property, you must make sure that you specify valid HTML. If the HTML is not valid, the generated HTML report output may not pass HTML 4.01 syntax checkers.

■ You can preview your HTML or HTMLCSS report output in your Web browser by choosing File > Preview Format > Paginated HTML (or Paginated HTMLCSS).
■ Bookmarks cause multiple HTML files to be created. One master file is created with two frames: one for bookmarks and one for the report output. One HTML file is created for each of these frames. The master document filename is the name specified in the DESNAME parameter. The bookmark filename is desnamedb.htm. The report output filename is desnamed.htm.
Linked images, image fields, and graphs in a report cause GIF files to be created and referenced from the HTML document. Notice that even if the linked boilerplate or image field refers to an external GIF file, a new GIF file is generated.

If an image is stored in the database, one GIF file may be generated for each occurrence of the image in the report. If an image is stored in a file (for example, imported images, linked boilerplate, or image fields that reference files), only one GIF file will be generated per image regardless of how many times it is repeated in the report.

Any GIF image files generated for HTML output have a number sequence (for example, desname0.gif... desname17.gif).

A comment block in the master document contains the names of all of the files that are associated with the master document.

HTML has seven sizes for text. The font sizes in the report are mapped according to the following table. Notice that the user can override the size specified in the HTML file from their browser.

<table>
<thead>
<tr>
<th>Report font size</th>
<th>HTML font size</th>
</tr>
</thead>
<tbody>
<tr>
<td>less than 8</td>
<td>1</td>
</tr>
<tr>
<td>8 through 9</td>
<td>2</td>
</tr>
<tr>
<td>10 through 12</td>
<td>3</td>
</tr>
<tr>
<td>13 through 15</td>
<td>4</td>
</tr>
<tr>
<td>16 through 20</td>
<td>5</td>
</tr>
<tr>
<td>21 through 30</td>
<td>6</td>
</tr>
<tr>
<td>more than 30</td>
<td>7</td>
</tr>
</tbody>
</table>

Note: If the font used in the report is non-proportional, TeleType mode is turned on for the generated HTML file.

HTML does not have the concept of a page. A separator line is placed between each page of the report. Depending upon the browser, you may or may not need to scroll to see the entire report page. Furthermore, if you print the HTML document from your browser, the printer will not necessarily print the separator lines at the bottom of each page. If you do not want the separator line or you want to use a different separator line, you can use SRW.SET_AFTER_PAGE_HTML to change it.

For HTMLCSS, graphics and text can be overlapped.

Once you have generated your report to an HTML or HTMLCSS file, the data model and looping tags are removed and replaced with the data. You can open the HTML or HTMLCSS file in Oracle Reports Builder, but it will be a static text file and not a report.

For information about paginating HTML or HTMLCSS output, see Section 2.8.8.1, “About HTML page streaming”.

Restrictions

Objects cannot overlap one another. For example, you could not have text on top of an image.
If objects overlap slightly (two characters or less), then the underneath object is truncated to prevent overlap.

If objects overlap significantly (or one is completely on top of the other), then the underneath object is removed altogether. In this case, any linking information of the removed object is transferred using the same rules as if it were a frame (see the rules about frames below).

Text always takes precedence over horizontal lines, regardless of which is on top. This prevents the line underneath a column label from eliminating the label text.

When multiple output files are generated (for example, when bookmarks are used), any file except the master file will be overwritten without confirmation. For example, GIF files and bookmark files would be overwritten without prompting.

Report frames are not visually represented in the HTML output. Any fill or border attributes of frames do not appear in HTML output.

If the frame in a report is the target of a link or a bookmark, that attribute is transferred to the visible object nearest to the upper left corner of the frame in HTML output. If the frame object is a hyperlink, that attribute will be transferred to all the child (interior) objects that are not hyperlinks. If the hyperlink attribute cannot be transferred to the child objects, the frame’s hyperlink is lost.

The only drawn object supported in HTML is a solid, black, horizontal line. The line width specified in the report may be honored depending upon the browser. All other drawn objects (for example, rectangles or circles) in the report layout will not show up in the HTML output. Space for these drawn objects is reserved, but there is no visible representation in the HTML output. HTMLCSS output supports some additional drawn objects (for example, rectangles).

Background (fill) and border (line) colors/patterns for text are not available in HTML. Bold, italic, underline, and foreground (text) color are supported if the browser supports them.

The PDF action attribute is ignored for HTML output.

Any browser customizations that have been made will affect how the generated HTML is displayed.

See also
Section 1.2.2, "About Web Reports"
Section 2.2.3, "About Web links for HTML output"
Section 4.7.5, "Generating HTML or HTMLCSS output"
Section 4.9.2.3, "Creating a boilerplate text object for HTML tags"
Section 4.9.2.7, "Linking an HTML text object to a file"
Section 4.8.4, "Selecting HTML tags from the database"

2.8.8.1 About HTML page streaming
HTML page streaming enables you to display individual pages of your HTML/HTMLCSS report output in your Web browser, without having to download the entire report. From the first page of the report, you can navigate to any page in the rest of the report. When you click a bookmark or hyperlink with a destination:

- within the report, the frame that contains the current page will update with the destination page.
outside the report, the entire base frame (including the bookmark frame, the page, and the navigation frame) will reload.

**Navigation controls**

You can specify the navigation controls script for a report in either of the following ways:

- with PL/SQL (SRW.SET_PAGE_NAVIGATION_HTML in a Before Report trigger)
- in the Report Property Inspector with the Page Navigation Control Type and Page Navigation Control Value properties

**Output file names**

With HTML page streaming, each page is formatted as a separate HTML document. If your HTML file is named `myreport.htm` and there are no bookmarks, the new files are named as follows:

- `myreport.htm` (for the base frame)
- `myreportnumber.htm` (for the bookmark file, present only if bookmarks are used in the HTML files)
- `myreportnumber_1.htm` through `myreportnumber_n.htm` (for the pages)
- `myreportnumberj.htm` (for the navigation JavaScript)

**Scope of HTML output**

To specify HTML to be displayed on only the first (header) or last (footer) pages of your report, set the Before Report or After Report properties or use the **SRW.SET_BEFORE_REPORT_HTML** or **SRW.SET_AFTER_REPORT_HTML** PL/SQL procedures. To specify global HTML to apply to the entire report, such as background colors or images, set the Before Page properties or **SRW.SET_BEFORE_PAGE_HTML** PL/SQL procedure. The Oracle Reports Builder-generated HTML logo appears only on the last page of your report.

**Enabling page-streamed output**

To enable page streaming when you format your report as HTML or HTMLCSS output, you must specify `PAGESSTREAM=YES` on the command line. This option cannot be set using the Oracle Reports Builder user interface.

**See also**

Section 4.7.16.5, "Displaying individual pages of HTML report output"

Section 4.6.10.1.12, "Adding navigation controls for HTML page-streamed output using the Property Inspector"

Section 4.6.10.2.11, "Adding navigation controls for HTML page-streamed output using PL/SQL"

### 2.8.9 About HTML formatting

Oracle Reports allows a variety of fonts, styles, and colors for text objects in your reports. Through the use of the **SRW** built-in procedures (see the Reference section of the Oracle Reports online Help), you can allow end users to change text attributes at runtime to a whole object, but not to a section of the text (for example, different formatting for different parts of a text object).
Alternatively, you can use a defined set of HTML formatting tags to format text style (bold, italics, underline, and strikethrough) and text attributes (font name, font color, and font size), and generate formatted text objects in all bitmap output formats supported by Oracle Reports when the objects’ Contains HTML Tags property is set to Yes.

The text objects can have static values as in boilerplate text objects, or dynamic values as in field objects or text file link objects. A boilerplate text object can also have dynamic values if it references a field object or a report-level column. For boilerplate text, the formats specified at design-time are merged with rich text formats obtained at runtime. This feature also supports multibyte text containing HTML tags.

In the Paper Design view or Paper Layout view, you can choose the objects to which HTML formatting should be applied by setting their Contains HTML Tags property to Yes. If you run the report from the command line with CONTAINSHTMLTAGS=NO, Oracle Reports will not interpret the HTML tags for the report, regardless of the object’s Contains HTML Tags property setting. For HTML and HTMLCSS output, the browser will interpret the HTML formatting tags; for other output formats, the HTML tags themselves will appear as is in the report output.

The following HTML tags are interpreted by Oracle Reports if they appear in a boilerplate text, text file link, or field object. Any HTML tags or attributes not listed appear as is in non-HTML/HTMLCSS report output.

<table>
<thead>
<tr>
<th>Tag</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td><code>&lt;b&gt;</code></td>
<td>Text enclosed in either of these tags will be bold.</td>
</tr>
<tr>
<td><code>&lt;strong&gt;</code></td>
<td>For example: &lt;b&gt;my format&lt;/b&gt;</td>
</tr>
<tr>
<td><code>&lt;i&gt;</code></td>
<td>Text enclosed in either of these tags will be italics.</td>
</tr>
<tr>
<td><code>&lt;em&gt;</code></td>
<td>For example: &lt;i&gt;my format&lt;/i&gt;</td>
</tr>
<tr>
<td><code>&lt;u&gt;</code></td>
<td>Text enclosed in this tag will be underlined.</td>
</tr>
<tr>
<td><code>&lt;s&gt;</code></td>
<td>Text enclosed in either of these tags will be struck through.</td>
</tr>
<tr>
<td><code>&lt;strike&gt;</code></td>
<td>For example: &lt;s&gt;my format&lt;/s&gt;</td>
</tr>
</tbody>
</table>

For example:

- `<b>my format` will appear as **my format**
- `<i>my format` will appear as *my format*
- `<u>my format` will appear as _my format_
- `<s>my format` will appear as _my format_
- `<strike>my format` will appear with a line struck through it.
The following are the supported properties for the `span` tag's `style` attribute:

**Table 2–3  Supported properties for style attribute of span tag**

<table>
<thead>
<tr>
<th>Property</th>
<th>Result</th>
</tr>
</thead>
</table>
| font-family | This property specifies the font name. Oracle Reports provides support for specifying only one font name. If you specify a comma-separated list containing more than one font name, Oracle Reports uses the system default font (usually Courier, or its equivalent) to render this tag, without generating a warning. For example:  
font-family: Arial |
| font-size  | This property describes the size of the font. CSS level 2 specifies the following options for this property:  
`absolute_size` | `relative_size` | `length` | `percentage`  
Oracle Reports provides support for only `absolute_size` and `length`. Where:  
`absolute-size` is:  
xx-small | x-small | small | medium | large | x-large | xx-large  
xx-small is 7 points  
x-small is 8 points  
small is 10 points  
medium is 12 points  
large is 14 points  
x-large is 17 points  
xx-large is 20 points  
`length` is:  
font_size | font_sizept |
| For example: |  
font-size:xx-large  
font-size:12pt |
The supported output formats are: PDF, RTF, HTML, HTMLCSS, and PostScript.

HTML formatting supports interleaving and nesting of tags. For example, if you open an italics tag, it is applied to the point of its corresponding closing tag. If a tag is opened several times, it must be closed the same number of times for its effect to cease.

Format attributes are not inherited across instances of a text object of the same name or type (for example, if they are enclosed in a repeating frame). If, however, a text object contains multiple lines, formatting instructions are inherited across the lines of this object only.

This feature supports HTML tags that are hard-coded or referenced in a boilerplate text object. The tags can also be retrieved from a table column with a

---

**Table 2–3 (Cont.) Supported properties for style attribute of span tag**

<table>
<thead>
<tr>
<th>Property</th>
<th>Result</th>
</tr>
</thead>
</table>
| color          | This property describes the color of the enclosing element’s text content. Oracle Reports supports the following options for this property: color_name|rgb|rgb(r_integer, g_integer, b_integer)|rgb(r_value%, g_value%, b_value%) where color names and rgb equivalents are as follows: aqua:#0FF black:#000 blue:#00F fuchsia:#F0F gray:#707070 green:#007000 lime:#0F0 maroon:#70000 navy:#00007F olive:#707000 purple:#70007F red:#F00 silver:#C0C0C0 white:#FFF yellow:#FF0 For example: color:aqua color:#F0F color:#0FA color:#0FACE0 color:rgb(100, 245, 33) color:rgb(23%, 49%, 87%) Note: For rgb(x, x, x) specification, color intensity must be specified in percentage (0–100) or rgb integer (0–255). Any value higher than the allowable range is set to the maximum value. A negative value for any color intensity is invalid. You may mix the percent and rgb integer values for colors; for example: <span style="color:rgb(100%, 125, 3%)"> is equivalent to: <span style="color:rgb(255, 125, 8%)"> or <span style="color:rgb(100%, 49%, 3%)">
field object. A file link object that points to a text file which in turn contains HTML
tags is also supported.

- Oracle Reports tries to find the closest match according to the following criteria for
  fonts with the same character set:
  
  * font face > font size > font style > font weight > font width

  If Oracle Reports cannot match the font face, it will try to match the font size; if it
cannot match the font size, it will try to match the font style; and so on. For the
font lookup algorithm, refer to the "Managing Fonts in Oracle Reports" chapter in
_Publishing Reports to the Web with Oracle Reports Services_. In font lookup, it is
possible that the font used does not have all the required attributes (such as style,
size, and so on) embedded in data. In this case, the unavailable font attributes do
not appear in the report output.

**Limitations**

- A tag must be specified in its entirety on a single line. If the tag continues to the
  next line, it is not supported.

  **For example:**

  ```
  <b>My</b><br/>
  <b>format</b>
  ```

  - Only one font name can be specified in the _span_ tag’s _style_ attribute _font-family_
property.

  **For example:**

  ```
  font-family:Arial
  ```

  If you specify a comma-separated list containing more than one font name, Oracle
Reports uses the system default font (usually Courier, or its equivalent) to render
this tag, without generating a warning.

- Entities such as _“_ are not supported.

  **For example:**

  ```
  <span style="font-family: "Courier New"">my format!</span>
  ```

  You must use literal double quote (") instead.

**Examples**

**Example 1: Inline font change**

In a boilerplate text object, you can specify the text boilerplate as follows:

```
<\b>My</\b>text
```  

With the Contains HTML Tags property set to Yes, the formatted output will look like
this:

*My text*

**Example 2: Single line text with multiple formats**

Assume a span of text (in a boilerplate object or database column) that formats on one
line, such as:

```
<\b>My <\span style="font-family:Courier">HTML</span> Formats</span></\u>
```
With the Contains HTML Tags property set to Yes, the formatted output will look like this:

**My HTML Formats**

**Example 3: Multiline text with multiple formats**

Assume a span of text that formats on multiple lines, such as:

Line 1: `<i>My</i><span style="font-family:Courier">Line 2: HTML</span>`
Line 3: Formatting`. 

With the Contains HTML Tags property set to Yes, the formatted output will look like this:

Line 1: *My*
Line 2: *HTML*
Line 3: *Formatting*.

Note in the preceding example that the formats are maintained in successive lines.

**See also**

Section 4.7.5, "Generating HTML or HTMLCSS output"
Section 4.9.2.3, "Creating a boilerplate text object for HTML tags"
Section 4.9.2.7, "Linking an HTML text object to a file"
Section 4.8.4, "Selecting HTML tags from the database"

### 2.8.10 About PDF output

Oracle Reports Builder can generate report output to PDF files, containing the formatted data and all objects. When you generate your report output to a PDF file, you can distribute the output to any PDF destination, including e-mail, printer, Oracle Portal, and Web browser.

Document taxonomy (classification) for PDF output is provided by the report properties Title, Author, Subject, and Keywords, which assist in cataloging and searching a report document.

With font subsetting, the PDF file includes the font information needed to render the PDF, regardless of the availability of that font on the machine used to view the report. PDF font subsetting works for single byte, multibyte, and Unicode fonts, and is the preferred method of creating multibyte reports.

Oracle Reports 10g Release 2 (10.1.2) provided the following enhancements to PDF output:

- Direct subsetting of True Type fonts (as a Type0 font), no longer converting to Type3 fonts. As a result, PDF output is clearer, smoother, searchable, and accessible.
- Improved True Type Collection (TTC) support, allowing you to use the zero-based index to indicate the specific TTC font file to pick up. In prior releases, Oracle Reports picked up the first font file in the True Type Collection (TTC).

Oracle Reports 12c (12.2.1.1) adds more enhancements to PDF output:

- Ability to run the reports designed on Windows on Unix platforms by simply copying the font file to the `fonts` folder.
With the new font model, no misalignment will be seen in the PDF subsetted report output.

For detailed information about PDF enhancements and capabilities in Oracle Reports, refer to the chapter "Using PDF in Oracle Reports" in the Publishing Reports to the Web with Oracle Reports Services.

Usage notes

- You can preview your PDF report output in your Web browser by choosing File > Preview Format > PDF.
- If you are building a multibyte report for multibyte languages, such as Chinese or Japanese, and you need to alias the font in PDF output, you need the CID fonts named within the Acrobat 4.0 packs. Otherwise, you do not need the CID fonts in the Acrobat 4.0 packs.
- Oracle Reports does not support Windows UDC for PDF output. For the user-defined characters to be printed or rendered, all the glyphs must be within a single TTF or TTC file.
- Graphics and text can be overlapped.
- The foreground color of the object will be used as the fill color (regardless of a specified pattern).
- You can modify the PDF file, if you have:
  - the fonts used in your report installed on your machine.
  - a PDF writer.

Restrictions

- For PDF output, the bit-mapped drivers (for example, PostScript) for the currently selected printer are used to produce the output.

See also

Section 1.2.2, "About Web Reports"
Section 2.2.4, "About Web links for PDF output"
Section 4.7.6, "Generating PDF output"

2.8.11 About RTF output

Oracle Reports Builder can generate report output to Rich Text Format (RTF) files, containing the formatted data and all objects. RTF can be read by many different word processing software packages, such as Microsoft Word. You can use the software's editing and graphics features to modify and enhance your report output. When you generate your report output to an RTF file, you can distribute the output to any RTF destination, including e-mail, printer, Oracle Portal, and Web browser.

Usage notes

- Graphics and text can be overlapped.
- Text can only be rotated by 90-degree variations.
- As with PDF output, the foreground color of the object will be used as the fill color (regardless of a specified pattern).
2.8.12 About delimited output

Oracle Reports can generate report output that includes a delimiter to delimited files (for example, files that contain comma-separated or tab-separated data), which are easily imported into spreadsheets or for use with word processors.

Oracle Reports provides two options for generating delimited output:

- Delimited: uses the paper layout to generate the output.
- DelimitedData (for use when you have problems running large volume reports with Delimited): does not take into account the paper layout, and directly runs off the data model (that is, all fields that are available in the data model will appear in the output, not only those that are displayed in paper layout).

You can specify a delimiter (a character or string of characters) to separate the data (boilerplate or field objects) in your report output in either of the following ways:

- On the command line using the `DELIMITER` keyword.
- In the Delimited Output dialog box or DelimitedData Output dialog box (displayed with `File > Generate to File > Delimited` or `File > Generate to File > DelimitedData`) in Oracle Reports Builder.

**Note:** If you do not specify a delimiter, the default delimiter is a tab.

You can further distinguish the cells by using a cell wrapper. A cell wrapper can consist of any series of characters, such as a comma or parentheses.

For example, if the data in your report output include the same character as the delimiter (for example, a comma), you can use the parentheses cell wrapper to distinguish each cell:

\((1,000,000), (3,6000), (543), (2,003,500)\)…

**Usage notes**

*DelimitedData output:*

- When you generate a report to DelimitedData output, only data (as defined by the report data model) displays in the output. Any formatting changes defined in the layout are not reflected in the DelimitedData output.
- You can set the following column properties to alter column names and exclude columns from the DelimitedData output file:
  - The XML Tag property can be used to enter a column alias.
The Exclude from XML Output property can be used to exclude the column from the DelimitedData output.

To generate report output that preserves the report layout information, see Section 2.8.13, “About Enhanced Spreadsheet output”.

You can distribute and burst a report in DelimitedData output format, specified either in a distribution XML file or in the Distribution dialog box.

**Delimited output:**

When you generate a report to Delimited output, the data displays according to the positions of the objects in the Paper Layout view.

- If you place A above or to the left of B (where A and B are any boilerplate or field objects) Oracle Reports Builder displays each instance of A before each instance of B in every line of output.

**Figure 2–8 Delimited output of A above B**

![Figure 2–8 Delimited output of A above B](image)

- If you create a frame that contains a boilerplate object (A) and encloses a repeating frame that contains a field object (B), each instance of A displays with each instance of B.

**Figure 2–9 Delimited output of frame enclosing repeating frame**

![Figure 2–9 Delimited output of frame enclosing repeating frame](image)
In the previous layout, if you add another frame that contains a boilerplate object (C) and encloses another repeating frame that contains a field object (D), A displays for every instance of B, and then C displays for every instance of D.

Figure 2–10  Delimited output of two frames enclosing repeating frames

If you create a matrix in your report, be sure to align your objects carefully according to the grid in the Layout Model view. If the objects are not aligned, Oracle Reports Builder may interpret the extra space as an extra row or column and disrupt your report output.

If you create a boilerplate object outside of a matrix, each instance of the boilerplate repeats with every row (not column) of the matrix. Notice that boilerplates contained in the matrix will not be repeated with field objects outside of the matrix.

Figure 2–11  Delimited output of boilerplate outside matrix
Restrictions

- If the text file contains a field labeled ID (in uppercase) as the first field, you will be unable to open the file in Microsoft Excel. The following delimited output causes an error in Excel:

  ID, name, title, dept

  If you want to generate delimited output that contains an ID field, try changing the database column name to lowercase (that is, id), or re-arranging the order of the fields.

- Report distribution and bursting do not support Delimited output format. You cannot specify DELIMITED as an output format in a distribution XML file or in the Distribution dialog box.

  **Note:** You can distribute and burst a report in DelimitedData output format, specified either in a distribution XML file or in the Distribution dialog box.

See also

- Section 4.7.10, "Generating delimited output"
- Section 4.7.1, "Running and dispatching a report from the user interface"
- Section 1.2.2, "About Web Reports"

### 2.8.13 About Enhanced Spreadsheet output

Oracle Reports 12c (12.2.1.1) introduces a new spreadsheet output format, ENHANCEDSPREADSHEET, which enables you to burst and distribute reports to the spreadsheet format, as well as generate large data sets (up to 75,000 rows) to spreadsheets.

**ENHANCEDSPREADSHEET** output formats generate output from paper layout report to HTML files that can be directly opened with Microsoft Excel 2000. You can:

- Generate report output to spreadsheet format from existing paper layout reports saved in any format (.rdf, .xml, .jsp), using rwrun or Reports Server clients (rwclient, rwservlet). See the Example below.

- Preserve the rich layout formatting such as colors, fonts, conditional formatting, graphs, and images.

**Note:** DESFORMAT=ENHANCEDSPREADSHEET behavior is the same as the functionality of the rw:include JSP tag. Enhanced Spreadsheet output is not paginated; no page setup information is written in the output, and it is formatted as a single worksheet. Enhanced Spreadsheet output is driven by the layout; the reports output displays objects that are in the body area of each section (Header, Main, and Trailer) of the paper layout, and does not format any content in the margin, header, or footer areas.

**Prerequisites**

- Microsoft Excel 2000 or higher (on the client machine for viewing the output). Notice that this software is not needed on the machine where Oracle Reports Services is running.
Usage notes

- Enhanced Spreadsheet output requires more memory than DelimitedData output. This is an important consideration for long-running and large reports.

- To change the name of the output worksheet, set the report's Title property.

- Only bitmapped reports can be generated to spreadsheet output; you cannot generate a character-mode report to Enhanced Spreadsheet output.

- The following paper layout objects are supported in Enhanced Spreadsheet output:
  - text (boilerplate and field)
  - images (any format), including images that are imported, linked, or stored in the database
  - imported drawings, as well as CGM and OWF drawings
  - graphic lines

- The following paper layout objects are not supported in Spreadsheet output: graphic arc, polygon, rectangle, rounded rectangle, stretchable line, and OLE external object (for reports developed prior to Oracle9i Reports (9.0.2)). Space for these drawn objects is reserved, but there is no visible representation in the output. This limitation does not apply to horizontal lines.

- The following font attributes are supported in Spreadsheet output: size, face, color, style (italic, oblique, underline, overstrike, outline, shadow), weight (bold, normal, extra bold, ultra bold).

- The following Web report properties are supported in Spreadsheet output:
  - Hyperlink property
  - Hyperlink Destination property
  - Additional Attributes (HTML) property (for Parameter Form fields)
  - Table Attributes (HTML) property (for frames and repeating frames)
  - Alternative Text property (for images)
  - Contains HTML Tags property (for boilerplate text or field objects that include HTML tags)

- The following report taxonomy properties are supported in spreadsheet output:
  - Title property
  - Author property
  - Subject property
  - Keywords property

- Graphs embedded in Spreadsheet output are static image files, and are not interactive. Thus, the Graph Hyperlink property is not supported in Spreadsheet output.

- For reports that support globalization, the metadata for direction and charset must be provided in a before report escape, because this information is not written to the generated output, by default. For example, you can define a before report escape as follows:

```html
<html>
<META HTTP-EQUIV="Content-Type" CONTENT="text/html; charset=&encoding">```
The frames and repeating frames defined in the paper layout are translated to tables in the output. You can specify table attributes such as cellspacing, cellpadding, and width using the Table Attributes (HTML) property for frames and repeating frames.

For reliable formatting of spreadsheet output, the whole layout area should be enclosed in a frame. This prevents the possibility of parallel objects displaying in different vertical positions, one below the other.

The order of the report sections (Header, Main, and Trailer) is preserved in spreadsheet output; that is, the Header section output appears first, followed by the Main section, followed by the Trailer section.

If boilerplate objects or fields are not contiguous to each other; that is, if there is a gap between their boundaries, this might result in empty cells in the spreadsheet output.

If your report defines conditions that may change cell positions when the report is formatted, these changes are not reflected in spreadsheet output format. For example, if a report defines a condition that causes column 2 to display at the position of column 1 when column 1 is empty, Spreadsheet output will always display both columns, even when the condition is met. Oracle Reports generates the HTML table that forms the spreadsheet immediately after the report is compiled, not during formatting. During formatting of spreadsheet output, the table cells are filled with values.

The Oracle Reports color palette is used while designing the report. When you generate your report output to spreadsheet output, Microsoft Excel will show the closest matching color from its color palette.

If you rotate a boilerplate object in the paper layout, the object will appear horizontal in the spreadsheet output.

The following cell properties are not supported in spreadsheet output: background pattern, border color, and border pattern.

Images included in the paper layout of the report will appear in the spreadsheet output only if the Reports Server is running in non-secure mode. In the case of a secure Reports Server, images will not appear in the spreadsheet output. This is because generating images in the output involves multiple calls to the Reports Server (one call per image). Once the user is authenticated, Oracle Reports passes the user’s identity between the browser and the secure Reports Server using cookies. However, Excel does not support cookies. As a result, the call to the secure Reports Server seems like a call from a non-authenticated user. Thus, the Reports Server refuses to pass on the images. As a workaround, you can generate the spreadsheet output from a secure Reports Server to a URL using WebDAV.

Summary and formula columns will be shown as values, not as dynamic Excel formulas. Also, the page-level summary columns are reduced to report-level summary columns, since there is no page concept in Excel.

If you set the Vertical Elasticity property of a frame to Fixed, the output in Excel will show only as many records as could appear on the first page of the paper output. Since Excel does not have a page concept, it is not able to "overflow" the remaining rows to the next "page".

Since spreadsheet output is not paginated, only the before report escape and after report escape are supported (see Section 2.2.10, "About before and after escapes").
In an after report escape, adding an HTML command outside the body does not reflect when the report is generated to spreadsheet output, even though the HTML command is written in output properly. For example:

```html
</body><table><tr><td><B> the text to be bolded </B></td></tr></table></html>
```

Adding the HTML command before the closing body tag reflects correctly when the report is generated to spreadsheet output. For example:

```html
<table><tr><td><B> the text to be bolded </B></td></tr></table></body></html>
```

For a matrix report, if the horizontal panels per page is set to a value higher than 1, running the report in the ENHANCEDSPREADSHEET output format would result in the following error:

REP-1223: THE PAGE SIZE IS INVALID

You can set the horizontal panels per page to a value higher than 1 for a matrix report for all DEFSFORMATs except ENHANCEDSPREADSHEET.

Spreadsheet format is supported in rwservlet commands such as SHOWJOBS. It is also supported in Enterprise Manager’s job queue, and in Oracle Portal’s access object definition.

You can distribute a report in Enhanced spreadsheet output format, specified in a distribution XML file.

**Restrictions**

XML-based bursting is supported in ENHANCEDSPREADSHEET output format only.

**Example**

To generate the paper layout of your report to Microsoft Excel output through a URL (using rwservlet), you can type a URL that includes the following in your browser:

```
+server=server_name+userid=db_connect_string+destype=file
+desformat=Enhancedspreadsheet+desname=C:\temp\myexcel_output.htm
```

**Note:** Microsoft Office 2000/2002/2003 supports Hypertext Markup Language (HTML) as a native file format. Enhanced Spreadsheet output relies on producing HTML output, which can be understood by Microsoft Excel as a file with valid Excel format.

**Other capabilities for generating Spreadsheet Output**

You can also generate spreadsheet output as implemented in releases prior to Oracle Reports 12c (12.2.1.1), in the following ways:

- **Generate a report to delimited output**, as described in Section 4.7.10, "Generating delimited output":

  **Advantage:** Delimited output can be generated from existing paper layout reports saved in any format (.*rdf, .xml, .jsp), either directly from Oracle Reports Builder, or by running the report from the command line.

  **Disadvantage:** Only data (as defined by the report Data Model), no layout information, displays in the output.
Deploy a report with the Reports Server under Oracle WebLogic Server to display it in Microsoft Excel inside your Web browser, using either of the following methods:

- When you do not have an existing paper layout: open an Excel HTML template file in Oracle Reports Builder, add the data, save the report as a JSP file, then deploy the report. This method enables you to use JSP coding to include dynamic Excel formulas (not just static values of Reports summary and formula columns), dynamic graphs (not just static Reports graph images).

- When you do have an existing paper layout: starting with a paper layout report, edit the Web Source view to add a \texttt{rw:include} tag to include the group frame of your paper layout in the Web source view as JSP code, save the report as a JSP file, then deploy the report. For the steps to implement this method, see Chapter 29, "Building a Report for Enhanced Spreadsheet Output".

\textit{Advantage:} You can use rich formatting such as colors and fonts so that you generate report layout, not just data, in Microsoft Excel output inside a Web browser.

\textit{Disadvantages:} You must add custom JSP coding to get the output in Excel. The report can only be run through the JSP engine and not through \texttt{rwservlet}, thus this method can only display the Microsoft Excel output inside a Web browser.

\textbf{See also}
Section 4.7.11, "Generating Enhanced spreadsheet output"

For choosing the appropriate delimited output solution for given requirements, see "Displaying Report Output in Microsoft Excel" in the appendix "Troubleshooting Oracle Reports Services" in the \textit{Publishing Reports to the Web with Oracle Reports Services}.

\subsection*{2.8.14 About text output}

Oracle Reports Builder can generate report output to text files, containing the formatted data and all objects. When you generate your report output to text, and the running mode is character (MODE=CHARACTER, or MODE system parameter Initial Value property set to \texttt{Character}), the result is pure text output, which can be read by many different applications. If the running mode is bitmap (MODE=BITMAP, or MODE system parameter Initial Value property set to \texttt{Bitmap}), the result is PostScript output, which can be read and rendered only by PostScript-compatible applications (such as a PostScript printer).

\textbf{See also}
Section 4.7.9, "Generating text output"

\subsection*{2.8.15 About creating an ASCII (character-mode) report}

To create a character-mode report, you first create a bit-mapped report, then convert that report to an ASCII (character-mode) report. The process will create a new character-mode version of your bit-mapped report; the original bit-mapped report remains unchanged.

After conversion, many of your fields and text objects may need to be resized. Also, graphical objects such as images and drawings will not be included in your character-mode report. The following lists summarize what is supported in each output format:
### 2.9 Data Sources

Oracle Reports enables you to access any data source. See Section 4.15.2, "Accessing non-Oracle data sources".

The topics in this section discuss information related to accessing other data sources in Oracle Reports Builder.

- About database roles
- About Oracle Net Services
- About user exits
- About the Oracle Call Interface (OCI)

**See also**

The **Pluggable Data Sources** section of the *Oracle Reports online Help*, including the topics:

- About pluggable data sources
- Adding a pluggable data source
- Connecting to a pluggable data source
- Adding online Help to a pluggable data source
- Pluggable data source interface definition
- Troubleshooting PDS problems

#### 2.9.1 About database roles

Database roles provide a way for end users to run reports that query tables to which they do not have access privileges. For example, a report may query a table that includes sensitive information such as salary data, even though the final report does not display this data.

---

**Table 2–4  Supported items in bit-mapped and character-mode reports**

<table>
<thead>
<tr>
<th>Bit-mapped</th>
<th>Character-mode</th>
</tr>
</thead>
<tbody>
<tr>
<td>Images</td>
<td>Boxes</td>
</tr>
<tr>
<td>Colors</td>
<td>Horizontal lines</td>
</tr>
<tr>
<td>Drawings</td>
<td>Vertical lines</td>
</tr>
<tr>
<td>Ellipses/Circles</td>
<td>ASCII text</td>
</tr>
<tr>
<td>Italicized text</td>
<td>Boldface text</td>
</tr>
<tr>
<td>Diagonal lines</td>
<td>Underlines</td>
</tr>
<tr>
<td>Bit-mapped patterns</td>
<td></td>
</tr>
<tr>
<td>Multimedia objects</td>
<td></td>
</tr>
</tbody>
</table>
Database roles are checked in the runtime environment only. If a table requires special access privileges, end users without those privileges cannot run a report that retrieves data from that table. However, if a database role is defined for the report, end users with privileges for that role can run the report using Reports Runtime (rwr
).

**Note:** To run a report for which a database role is defined, the end user must run the .rdf file, not the .rep file. When running multiple reports, Reports Runtime automatically switches to the role defined for the current report.

If you try to open a report in Oracle Reports Builder for which a database role has been defined, you will be prompted for the role password. Typically, only the report designer and DBA have this information.

**See also**
Section 4.16.1, "Setting a database role"

### 2.9.2 About Oracle Net Services

Oracle Net Services is Oracle’s remote data access software that enables both client-server and server-server communications across any network. It supports distributed processing and distributed database capability. Oracle Net Services runs over and interconnects many communication protocols. Oracle Net Services is backwardly compatible with Net8 and SQL*Net.

### 2.9.3 About user exits

In releases prior to Oracle Reports 10g, user exits provided a way to pass control from Oracle Reports Builder to a program you have written, which performs some function, and then returns control to Oracle Reports Builder. You could write ORACLE Precompiler user exits, ORACLE Call Interface (OCI) user exits, or non-ORACLE user exits to perform tasks such as complex data manipulation, passing data to Oracle Reports Builder from operating system text files, manipulating LONG RAW data, supporting PL/SQL blocks, or controlling real time devices, such as a printer or a robot.

Beginning with Oracle Reports 10g, you can call Java methods using the ORA_JAVA built-in package and the Java Importer. This reduces the need to have user exits in a report and allows for a more open and portable deployment. You may also use the ORA_FFI built-in package, which provides a foreign function interface for invoking C functions in a dynamic library. With the availability of these new built-in packages, the use of user exits is deprecated in Oracle Reports, though makefiles will still be supplied to permit you to continue to work with existing user exits.

### 2.9.4 About the Oracle Call Interface (OCI)

In releases prior to Oracle Reports 10g, the Oracle Call Interface (OCI) provided a set of standard procedures that you could call in your 3GL programs to call Oracle Reports components. These procedures (written in C) were shipped with the Oracle Reports Builder, Reports Runtime, and Reports Converter components. For example, to run a Oracle Reports Builder report from a Pro*FORTRAN program, you could add a RWCRRRB procedure call to your program to run the report using the Reports Runtime component.
Beginning with Oracle Reports 10g, the OCI is obsolete. Instead, use the rwclient.exe command line interface or the JSP tag library.

2.10 Debugging Tools

The topics in this section discuss debugging reports in Oracle Reports Builder.

- About the debugging process
- About the PL/SQL Interpreter
- About the Source pane
- About debug commands in the PL/SQL Interpreter
- About debug actions
- About the current execution location
- About the current scope location
- About debug levels
- About modifying code at runtime

2.10.1 About the debugging process

Debugging an application is an iterative process in which application errors are identified and corrected. In general, quickly identifying and locating failing code is essential to successfully debugging your application.

See also
Section 4.14.1, "Debugging a report"
Section 4.14.2, "Running a report in debug mode"

2.10.2 About the PL/SQL Interpreter

The PL/SQL Interpreter is your debugging workspace, where you can display source code, create debug actions, run program units, and execute Interpreter commands, PL/SQL, and SQL statements.

By default, two panes are always open in the PL/SQL Interpreter: Source pane and Interpreter pane.

Debugging features include the following:

- Direct manipulation debugging: insert debug actions and inspect program data by directly manipulating displayed source text.

- Dynamic execution feedback: Oracle Reports Builder automatically displays and tracks the current PL/SQL source location as program execution is interrupted by debug actions or incrementally advanced during program stepping.

- Browsing of interrupted program state: once execution has been interrupted, it is possible to browse the current stack, browse and modify variable state, and execute arbitrary PL/SQL statements. All information is accessed symbolically (that is, by name as opposed to by address or number).
### 2.10.3 About the Source pane

The PL/SQL Interpreter's Source pane displays a read-only copy of the program unit currently selected in the Object Navigator pane.

The numbers along the left hand margin correspond to the line numbers of the displayed program unit.

In addition, the symbols described below may appear in the margin.

| Table 2–5 Symbols in the margin of the Source pane |
|---------------------------------|----------------------------------|
| **Symbol** | **Description** |
| | |
| `|` | Specifies the current source location. |
| `=>` | Specifies the current scope location. |
| `-` | Specifies the current execution location (if different from the current scope location). |
| `B(n)` | Specifies the location of a breakpoint, where n is the corresponding debug action ID. It appears in the line number column. |
| `T(n)` | Specifies the location of a trigger, where n is the corresponding debug action ID. It appears in the line number column. |

### 2.10.4 About debug commands in the PL/SQL Interpreter

The following commands are available when using the PL/SQL Interpreter:

| Table 2–6 PL/SQL Interpreter Commands |
|---------------------------------------|--------------------------------------|
| **Command** | **Description** |
| | |
| `CREATE` | Creates a new library that can be stored in either the file system or the current database. |
| `DELETE` | Deletes: |
| | ■ libraries that reside in the current database |
| | ■ library program units |
| | ■ program units |
| `DESCRIBE` | Inspects a variable or parameter that is local to the current scope location. The description includes the name, type, and value of the specified local. |
| `EXPORT` | Writes the source of one or more program units to a text file. |
| `LIST` | Displays the source text for program units, triggers, and debug actions. |
| `LOG` | Saves a transcript of PL/SQL Interpreter input and output to the specified log file. |
| `RESET` | Returns control to an outer debug level without continuing execution in the current debug level. |
| `SET` | Changes the current scope location to a specified frame of the stack. You can specify relative motion from the current stack frame to any other frame, or move to a particular subprogram on the stack. There are several ways to invoke SET: |
| | ■ select a frame entry in the Object Navigator |
| | ■ enter the SET command in the PL/SQL Interpreter |
2.10.5 About debug actions

The PL/SQL Interpreter can be invoked from report code (triggers, user-named program units, libraries, and so on) by creating debug actions in the code. These are instructions that track the execution of PL/SQL program units so they can be monitored.

Each debug action you create is automatically assigned a unique numeric ID. While debugging, you can refer to this ID to browse, display, or modify a specific debug action with Oracle Reports Builder debug commands.

You can display detailed information about one or more debug actions, including its ID, source location, and whether or not it is enabled. You can temporarily disable specific debug actions and then re-enable them later if necessary.

There are two types of debug actions: breakpoints and debug triggers.

**Breakpoints** suspend execution at a specific source line of a program unit, passing control to the PL/SQL Interpreter.

Create breakpoints to identify specific debugging regions. For example, create a breakpoint at lines 10 and 20 to debug the code within this region.

With breakpoints, suspension occurs just before reaching the line on which the breakpoint is specified. At this point, use the PL/SQL Interpreter’s features to inspect or modify program state. Once satisfied, resume execution with the GO or STEP commands, or abort execution using the RESET command.

**Debug Triggers** are a general form of debug action that associate a block of PL/SQL code with a specific source line within a program unit. When a debug trigger is encountered, Oracle Reports Builder executes the debug trigger code.

Create a debug trigger to execute a block of PL/SQL code provided at debug time in any of the following cases:

- When program execution reaches a single line in a program unit (for example, the current source location, line 5, line 23, and so on).
- Every time the PL/SQL Interpreter takes control (that is, whenever it suspends program execution due to a breakpoint, program stepping, and so on).
- At every PL/SQL source line being run.

Debug triggers are especially useful as conditional breakpoints. You can raise the exception DEBUG.BREAK from within a trigger. For example, the debug trigger shown below establishes a conditional breakpoint on line 10 of my_proc, which will be reached only if the local NUMBER variable my_sal exceeds 5000:

```
PL/SQL> line 10 is
+> IF Debug.Getn('my_sal') > 5000 THEN
+> Raise Debug.Suspend;
+> END IF;
```

2.10.5.1 About creating a debug action

You can create debug actions (breakpoints and debug triggers) in the PL/SQL Interpreter in the following ways:
Debugging Tools

Advanced Concepts

2.10.6 About the current execution location

The current execution location specifies the next PL/SQL source line to be executed. It corresponds to what is commonly referred to as the program counter, or PC.

When control passes to the PL/SQL Interpreter while running a program (for example, when a breakpoint is encountered or following a step operation), the Source pane in the PL/SQL Interpreter automatically displays the source line associated with the current execution location.

Use the LIST command in the Interpreter pane to manually display the current execution location.

For example, entering:

```
.LIST PC
```

will list the current execution location in the Source pane.

2.10.7 About the current scope location

The current scope location dictates where the PL/SQL Interpreter looks for local variables and parameters. It corresponds to the current execution location of one of the PL/SQL subprograms on the stack.

Each time a program unit’s execution is interrupted (for example, by a debug action), the scope location is initialized to the execution location of the subprogram at the bottom of the stack.

Once execution has been interrupted, you can change the current scope location to another frame on the stack. This enables you to view local variables in another subprogram in the call chain.

See also

Section 4.14.14, "Displaying the current scope location"
2.10.8 About debug levels

When a debug action interrupts program execution, the PL/SQL Interpreter takes control and establishes what is known as a **debug level**. At a debug level, you can enter commands and PL/SQL statements to inspect and modify the state of the interrupted program unit as well as resume execution.

Since any PL/SQL code interactively entered at a debug level may itself be interrupted (for example, by encountering another breakpoint), it is possible for debug levels to nest. To facilitate distinguishing one debug level from another, the levels are numbered. The most deeply nested level is assigned the highest number. Numbering starts at zero with the outermost level.

The 0th or outermost level is commonly referred to as top level. Top level has no associated program state since it is the outermost level at which program units are originally invoked. When code invoked from top level is interrupted, debug level 1 is established. Similarly, interrupting code invoked from debug level 1 establishes debug level 2, and so on.

The PL/SQL Interpreter command prompt reflects the current debug level. When the PL/SQL Interpreter enters levels below top level, the prompt includes a prefix containing the current debug level number. For example, the PL/SQL Interpreter command prompt at debug level 1 appears as:

```
(debug 1) PL/SQL>
```

2.10.9 About modifying code at runtime

At runtime, you can modify and compile any program unit, menu item command, or trigger that is not on the current stack.

---

**Note:** To modify an item on the current stack, first clear the stack by issuing the `RESET` command.

---

Although runtime code modification is not communicated back to Oracle Reports Builder, you can interactively test possible fixes, before returning to implement the eventual fix.

**See also**

*Section 4.14.13, "Modifying code at runtime"*
This chapter provides an overview of the example reports in this manual. For information on accessing the demo reports and the data sources, refer to "Accessing the Example Reports" and "Accessing the Data Sources".

The chapter lists the example reports contained in this manual, a brief description of each report, a pointer to the location of the steps to build the example, and an image of the sample output.

### 3.1 Part 1: Building Basic Reports

This part of the manual introduces and explains the basic steps on how you can build reports.

#### 3.1.1 Building a tabular report

In this example, you will use the Report Wizard to build a simple tabular report.

*Figure 3–1  Final output of the tabular report example*

<table>
<thead>
<tr>
<th>Department Id</th>
<th>Department Name</th>
<th>Manager Id</th>
<th>Location Id</th>
</tr>
</thead>
<tbody>
<tr>
<td>10</td>
<td>Administration</td>
<td>200</td>
<td>1700</td>
</tr>
<tr>
<td>20</td>
<td>Marketing</td>
<td>201</td>
<td>1800</td>
</tr>
<tr>
<td>30</td>
<td>Purchasing</td>
<td>114</td>
<td>1700</td>
</tr>
<tr>
<td>40</td>
<td>Human Resources</td>
<td>203</td>
<td>2400</td>
</tr>
<tr>
<td>50</td>
<td>Shipping</td>
<td>121</td>
<td>1500</td>
</tr>
<tr>
<td>60</td>
<td>IT</td>
<td>163</td>
<td>1400</td>
</tr>
<tr>
<td>70</td>
<td>Public Relations</td>
<td>204</td>
<td>2700</td>
</tr>
<tr>
<td>80</td>
<td>Sales</td>
<td>145</td>
<td>2500</td>
</tr>
<tr>
<td>90</td>
<td>Executive</td>
<td>100</td>
<td>1700</td>
</tr>
<tr>
<td>100</td>
<td>Finance</td>
<td>105</td>
<td>1700</td>
</tr>
<tr>
<td>110</td>
<td>Accounting</td>
<td>205</td>
<td>1700</td>
</tr>
</tbody>
</table>

For more information on building this example, refer to Chapter 5, "Building a Tabular Report".

#### 3.1.2 Building a mailing label report

In this example, you will use the Report Wizard to build a simple mailing label report. The steps will show you how to fill out the provided template to format your mailing labels.
3.1.3 Building a form letter report

In this example, you will use the Report Wizard to build a simple form letter report. The steps will show you how to fill out the provided template to design your form letter.

For more information on building this example, refer to Chapter 7, "Building a Form Letter Report".

3.1.4 Building a master/master report

In this example, you will learn how to build a master/master report, which displays at least two sets of data which are not directly related. That is, the records constituting the data are fetched using at least two separate queries. A master/master report (also called a parent/parent report) contains two or more queries with no links (parent/child relationships).

For more information on building this example, refer to Chapter 7, "Building a Form Letter Report".
3.1.5 Building a summary report

In this example, you will learn how to use the Summary Column tool to create a summary report.

A summary report contains at least one column whose value or values consist of a summary of other data. A column that totals sales, a column that averages a list of commissions, and a column that shows the maximum amounts found in a series of purchase orders are all examples of summary columns.

For more information on building this example, refer to Chapter 9, "Building a Summary Report".

3.2 Part 2: Building Group Reports

This part of the manual explains the different kinds of report layouts.

3.2.1 Building a single-query group report

In this example, you will build a simple group left report using one query.

Group left and group above reports divide the rows of a report into “sets,” based on common values in one or more of the columns, such as the department number in the

---

**Figure 3–5** Final output of the second master/master report example

<table>
<thead>
<tr>
<th>Last Name</th>
<th>First Name</th>
<th>Job Id</th>
<th>Salary</th>
</tr>
</thead>
<tbody>
<tr>
<td>Abel</td>
<td>Etan</td>
<td>SA REP</td>
<td>$11000.00</td>
</tr>
<tr>
<td>Ande</td>
<td>Sandor</td>
<td>SA REP</td>
<td>$6400.00</td>
</tr>
<tr>
<td>Atkinson</td>
<td>Mothe</td>
<td>ST_CLERK</td>
<td>$2300.00</td>
</tr>
<tr>
<td>Austin</td>
<td>David</td>
<td>IT_PROG</td>
<td>$4900.00</td>
</tr>
<tr>
<td>Baer</td>
<td>Hermine</td>
<td>PR REP</td>
<td>$1000.00</td>
</tr>
<tr>
<td>Benda</td>
<td>Shell</td>
<td>PU_CLERK</td>
<td>$2500.00</td>
</tr>
<tr>
<td>Benda</td>
<td>Amit</td>
<td>SA REP</td>
<td>$6500.00</td>
</tr>
</tbody>
</table>

For more information on building this example, refer to Chapter 8, "Building a Master/Master Report".

**Figure 3–6** Final output of the summary report example

| Sales Rep 7499 |          |          |          |          |          |
|----------------|----------|----------|----------|----------|
| Code           | Dollars  | % of Total|
| 124            | $7160.00 | 50.99%   |
| 127            | $710.00  | 5.02%    |
| Total:         | $7870.00 |          |
| % of Total:    | 7.68%    |          |

| Sales Rep 7521 |          |          |          |          |          |
|----------------|----------|----------|----------|----------|
| Code           | Dollars  | % of Total|
| 126            | $9004.40 | 91.25%   |
| 103            | $764.00  | 7.73%    |
| 101            | $101.40  | 1.03%    |
| Total:         | $9889.80 |          |
| % of Total:    | 9.55%    |          |

| Sales Rep 7654 |          |          |          |          |          |
|----------------|----------|----------|----------|----------|
| Code           | Dollars  | % of Total|
| 122            | $27775.50| 100.00%  |
| Total:         | $27775.50|          |
| % of Total:    | 26.01%   |          |

For more information on building this example, refer to Chapter 9, "Building a Summary Report".
preceding example. In the sample output below, notice that each department number prints only once. If the report above was not a group report, the department number would print once for each employee in the department rather than just once for the whole department.

**Figure 3–7  Final output of the single-query group report example**

<table>
<thead>
<tr>
<th>Department</th>
<th>Job Id</th>
<th>Employee Id</th>
<th>First Name</th>
<th>Last Name</th>
<th>Salary</th>
</tr>
</thead>
<tbody>
<tr>
<td>10</td>
<td>AD_ASST</td>
<td>200</td>
<td>Jennifer</td>
<td>Whallen</td>
<td>$4400.00</td>
</tr>
<tr>
<td>20</td>
<td>MLC_MAN</td>
<td>201</td>
<td>Michael</td>
<td>Hantstein</td>
<td>$13000.00</td>
</tr>
<tr>
<td></td>
<td>MLC_REP</td>
<td>202</td>
<td>Brahman</td>
<td>Goyal</td>
<td>$2000.00</td>
</tr>
<tr>
<td>30</td>
<td>PU_CLERK</td>
<td>115</td>
<td>Alexander</td>
<td>Kehoe</td>
<td>$3100.00</td>
</tr>
<tr>
<td></td>
<td></td>
<td>116</td>
<td>Shelt</td>
<td>Bada</td>
<td>$3500.00</td>
</tr>
<tr>
<td></td>
<td></td>
<td>117</td>
<td>Sigel</td>
<td>Tokaka</td>
<td>$2800.00</td>
</tr>
<tr>
<td></td>
<td></td>
<td>118</td>
<td>Karen</td>
<td>Colemanae</td>
<td>$2600.00</td>
</tr>
<tr>
<td></td>
<td></td>
<td>119</td>
<td>Guy</td>
<td>Himuro</td>
<td>$3600.00</td>
</tr>
<tr>
<td></td>
<td></td>
<td>120</td>
<td>Dan</td>
<td>Rafaely</td>
<td>$11000.00</td>
</tr>
<tr>
<td>40</td>
<td>HR_REP</td>
<td>203</td>
<td>Susan</td>
<td>Manis</td>
<td>$9500.00</td>
</tr>
<tr>
<td>50</td>
<td>SH_CLERK</td>
<td>180</td>
<td>Winston</td>
<td>Taylor</td>
<td>$2500.00</td>
</tr>
<tr>
<td></td>
<td></td>
<td>181</td>
<td>Alexis</td>
<td>Bull</td>
<td>$4100.00</td>
</tr>
<tr>
<td></td>
<td></td>
<td>182</td>
<td>Anthony</td>
<td>Celine</td>
<td>$3000.00</td>
</tr>
<tr>
<td></td>
<td></td>
<td>183</td>
<td>Alana</td>
<td>Walsh</td>
<td>$3100.00</td>
</tr>
<tr>
<td></td>
<td></td>
<td>184</td>
<td>Vance</td>
<td>Jones</td>
<td>$2800.00</td>
</tr>
<tr>
<td></td>
<td></td>
<td>185</td>
<td>Samuel</td>
<td>McCain</td>
<td>$2000.00</td>
</tr>
</tbody>
</table>

For more information on building this example, refer to Chapter 10, "Building a Single-Query Group Report".

### 3.2.2 Building a two-query group report

In this example, you will build a group above report using two queries.

A two-query group report appears much the same as a single-query group report. Performance is the key issue when contrasting single-query and multiple-query group reports. In most cases, single-query reports will run faster than multiple-query reports. Multiple-query reports are, however, sometimes easier to understand conceptually and easier to maintain. For example, if you are in a situation where only a few users run the report and the report returns a relatively small number of records, you might want to use multiple queries to simplify maintenance and make the data model easier to understand. If you have many users and the report is quite large, then you should try to use a single-query report.
3.2.3 Building an across group report

In this example, you will build an across group report that prints the values of a database column across the page instead of down.

For more information on building this example, refer to Chapter 12, "Building an Across Group Report".

3.2.4 Building a group left summary report

In this example, you will build a summary report that groups the summaries on the left in the report output.

This report consists of master records (Name, at the upper left of the figure below), detail records (Product, Itemtot, and Orderdate, to the upper right), and summary records (Product, and Sum Total). The summary calculates totals for the details under each master record. Notice that the column Product appears twice. With Reports Builder, you can display columns any number of times.
Part 3: Building Reports with Special Formatting

3.2.5 Building a group left formula report

In this example, you will use the Report Wizard to set up your report and write the one query that selects all the necessary database columns. You will then manually create the two formula columns to calculate tax and order totals for each customer, then add the formula columns to your report. You will use a Group Left style report to make the data in the report easy to read.

3.3 Part 3: Building Reports with Special Formatting

This part of the manual explains how you can build reports with special formats.

3.3.1 Building a wrapped field report

In this example, you will build a break report where the line wraps on word boundaries if it is too long to fit on one line.
3.3.2 Building a header and footer report

In this example, you will build a report that has a page header printed in the upper margin area of every page of the report, and a footer printed at the end of the list of employee information for each department.

For more information on building this example, refer to Chapter 16, “Building a Header and Footer Report”.

3.3.3 Building a header with database values report

In this example, both the first and last department numbers found on each page are displayed in the page header.
3.3.4 Building a report with graphics, text, and color

In this example, you will build a report and enhance it by adding an image to the margin, a title, and a border. You will also change the look of the report by applying different fonts and text styles.

For more information on building this example, refer to Chapter 18, "Building a Report with Graphics, Text, and Color".
3.3.5 Building a report that renumbers pages by repeating frame

In this example, you will build a report that numbers pages using the format "Page X of Y Pages". The first number (X) corresponds to the current page for each parent record (that is, each sales representative). This page number is reset to "1" for each sales representative, thus tracking the statistics of each representative separately.

Figure 3–16 Final output of the renumbering pages by repeating frame example

For more information on building this example, refer to Chapter 19, "Building a Report that Renumbers Pages by Repeating Frame".

3.3.6 Building an intermixed fields report

In this example, you will build a report where the group field appears between its related fields. Normally, a group (break) field appears to the left of (in group left report) or above (in group above report) its related fields.

Figure 3–17 Final output of the intermixed fields report example
For more information on building this example, refer to Chapter 20, "Building an Intermixed Fields Report".

### 3.3.7 Building a report that suppresses labels

In this example, you will build a master/detail report that fetches a master record with no associated details. In the sample output below, notice how the field labels for Department 40 do not display because no detail records were found. In this chapter, you will learn how to suppress the detail information for a single record, but allow the other master/detail records to display.

![Figure 3–18 Final output for the suppressing labels example](image)

For more information on building this example, refer to Chapter 21, "Building a Report that Suppresses Labels".

### 3.3.8 Building a conditional form letter report

In this example, you will build two form letters from the same report, as shown in the sample output below. As you can see, the two letters share a number of features. Hence, it is more convenient to create a base form letter and then apply conditions to certain parts to determine whether they should be displayed for the current record, in this case, employees.
Figure 3–19  Final output for the first conditional form letter report example

Dear Employee Adams,

Mark your calendar! You are invited to attend the Summit Sporting Goods annual picnic on June 15, from 11:00 AM to 6:00 PM. Be prepared for lots of food, lots of entertainment, and lots of fun.

We would also like to take this opportunity to thank you for all of your efforts over the last year. As a result of your hard work, company revenues increased 15%.

I look forward to seeing you there!

J. King
President
Summit Sporting Goods
3.3.9 Building a report with conditional highlighting

In this example, you will learn how to highlight data in your report. In this report that shows employee salaries, salaries that are greater than or equal to 10,000 are displayed in bold and in red color, and values that are between 4,999 and 10,000 are displayed in bold. Using the Conditional Formatting dialog box in Reports Builder, you can create format triggers that will change the appearance of retrieved data depending on factors you define.
3.3.10 Building a report with dynamic graphics

In this example, you will build an employee report with a bar graph that displays monthly revenues for the company. Since the data in it changes monthly, you cannot import or draw the graph.

For more information on building this example, refer to Chapter 24, "Building a Report with Dynamic Graphics".

3.4 Part 4: Building Matrix Reports

This part of the manual explains how you can build various kinds of matrix reports.

3.4.1 Building a matrix report

A matrix report looks like a grid. As shown in the sample output below, it contains one row of labels, one column of labels, and information in a grid format that is related to
both the row and column labels. (Matrix reports are also sometimes referred to as "crosstab" reports.)

In this example, you will build a matrix report that contains three additions to the basic matrix: summaries have been added, zeroes replace non-existent values in the cells, and the cells themselves are surrounded by grid lines. Of the summaries, one sums the salaries by department, one sums them by job, and one sums them for the whole report.

Figure 3–23  Final output of the matrix report example

<table>
<thead>
<tr>
<th></th>
<th>ANALYST</th>
<th>CLERK</th>
<th>MANAGER</th>
<th>PRESIDENT</th>
<th>SALESMAN</th>
</tr>
</thead>
<tbody>
<tr>
<td>10</td>
<td>10.00</td>
<td>150.00</td>
<td>250.00</td>
<td>650.00</td>
<td>0.00</td>
</tr>
<tr>
<td>20</td>
<td>500.00</td>
<td>150.00</td>
<td>2575.00</td>
<td>0.00</td>
<td>0.00</td>
</tr>
<tr>
<td>30</td>
<td>10.00</td>
<td>350.00</td>
<td>250.00</td>
<td>600.00</td>
<td>0.00</td>
</tr>
<tr>
<td></td>
<td>500.00</td>
<td>4150.00</td>
<td>8275.00</td>
<td>5600.00</td>
<td>5600.00</td>
</tr>
</tbody>
</table>

For more information on building this example, refer to Chapter 25, ”Building a Matrix Report”.

3.4.2 Building a nested matrix report

In this example, you will build the nested matrix report shown below. The cross product is capable of displaying every possible value for three dimensions: two down (YEAR and DEPTNO) and one across (JOB). This method does not include rows that have null values.

Figure 3–24  Final output of the nested matrix report example

<table>
<thead>
<tr>
<th></th>
<th>ANALYST</th>
<th>CLERK</th>
<th>MANAGER</th>
<th>PRESIDENT</th>
<th>SALESMAN</th>
</tr>
</thead>
<tbody>
<tr>
<td>80</td>
<td>20</td>
<td></td>
<td>$800.00</td>
<td></td>
<td></td>
</tr>
<tr>
<td>91</td>
<td>10</td>
<td></td>
<td></td>
<td>$900.00</td>
<td>$900.00</td>
</tr>
<tr>
<td></td>
<td>20</td>
<td></td>
<td>$2450.00</td>
<td>$2500.00</td>
<td>$900.00</td>
</tr>
<tr>
<td>82</td>
<td>10</td>
<td></td>
<td>$3500.00</td>
<td>$3500.00</td>
<td>$3500.00</td>
</tr>
<tr>
<td></td>
<td>20</td>
<td></td>
<td>$1200.00</td>
<td></td>
<td></td>
</tr>
<tr>
<td>83</td>
<td>20</td>
<td></td>
<td>$3500.00</td>
<td>$3600.00</td>
<td>$3750.00</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>$1100.00</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

For more information on building this example, refer to Chapter 26, ”Building a Nested Matrix Report”.

3.4.3 Building a matrix with group above report

In this example, you will build a report that shows department, job, and salary information for each employee by the year they were hired using a matrix break format.
Part 5: Building Reports for Business Cases

This part of the manual explains how you can build various kinds of reports to suit your business requirements.

3.5.1 Building a time series calculations report

In this example, you will build a report that calculates and displays the four-month average of purchases for each customer. You will use the Report Wizard to create a simple time series calculations report for both paper and the Web. For the JSP-based Web report, you will modify the Web source to change labels and add format masks.

For more information on building this example, refer to Chapter 28, "Building a Time Series Calculations Report".
3.5.2 Deploying a paper report to Microsoft Excel output

In this example, you will deploy a report with the Reports Server under Oracle WebLogic Server to display it in Microsoft Excel inside your Web browser, when you have an existing paper layout. You will generate a report to Microsoft Excel output after integrating the paper layout into a Web layout by modifying the Web source of your report.

Figure 3–27  Final output of the Microsoft Excel report

For more information on building this example, refer to Chapter 29, "Building a Report for Enhanced Spreadsheet Output".

3.5.3 Building a report with aggregate data

In this example, you will build a report that collects and displays names of all employees whose salaries fall within the range of 0 to 999, then collects and displays all employees whose salaries fall within the range of 1000 to 1999, and so on. You will be able to modify this report to display any aggregate range you need.
3.5.4 Building a check printing report with spelled-out cash amounts

In this example, you will build a check printing report with a stub and spelled-out cash amounts. The steps described in this example will help you create a PL/SQL function that returns spelled-out numerical values. You will also learn how to import an image of a preprinted form (in this case, a blank check image) and use the tools in the Paper Layout and Paper Design views to print your report on such a form. Although a check has been used as an example in this report, you can use the steps to use any preprinted form with Oracle Reports.
3.5.5 Building a report using a preprinted form

In this chapter, you will learn formatting techniques for printing reports on preprinted forms when you do not have access to a computer readable version of the forms. Such reports must be designed so that the data prints in exact positions on the form.

For more information on building this example, refer to Chapter 32, "Building a Report Using a Preprinted Form".

3.5.6 Building an invoice report

In this example, you will build a report that displays several distinguishing characteristics of a typical invoice, such as customer name and address, sales order number, billing information, and billing totals.
3.5.7 Building a ranking report

In this example, you will build a report that ranks data in two different ways: by count and by percentage. The upper portion displays the names and the total purchases of the top three customers; the lower portion displays the names and total purchases of those customers who constitute 75% of all sales. You can set the ranking criteria at runtime, or let them default to previously specified values.

For more information on building this example, refer to Chapter 34, "Building a Ranking Report".
3.5.8 Building a report with a simple table of contents and index

This example is designed to teach you how to add navigational items to a large paper report. You will learn how to create a group above report, then add a simple table of contents to the beginning of your report, which will enable users to find an item by its category. You will also learn how to create an index so users can directly find a specific piece of information.

---

**Note:** Generating a table of contents or index is not supported for matrix reports.

---

*Figure 3–33  Simple table of contents*

<table>
<thead>
<tr>
<th>Topic</th>
<th>Pages</th>
</tr>
</thead>
<tbody>
<tr>
<td>Argentina</td>
<td>1-7</td>
</tr>
<tr>
<td>Australia</td>
<td>7-26</td>
</tr>
<tr>
<td>Brazil</td>
<td>26-45</td>
</tr>
<tr>
<td>Denmark</td>
<td>45-54</td>
</tr>
<tr>
<td>France</td>
<td>54-147</td>
</tr>
<tr>
<td>Germany</td>
<td>147-345</td>
</tr>
<tr>
<td>India</td>
<td>345-362</td>
</tr>
<tr>
<td>Ireland</td>
<td>362-411</td>
</tr>
<tr>
<td>Japan</td>
<td>411-426</td>
</tr>
<tr>
<td>Malaysia</td>
<td>426-440</td>
</tr>
<tr>
<td>New Zealand</td>
<td>440-446</td>
</tr>
<tr>
<td>Poland</td>
<td>446-462</td>
</tr>
</tbody>
</table>
3.5.9 Building a report with a multilevel table of contents

This example is designed to teach you how to add a multilevel table of contents to a large paper report. You will add a table of contents based on a category and sub-category to an existing paper report.

<table>
<thead>
<tr>
<th>Term</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Aaron, Abel</td>
<td>357</td>
</tr>
<tr>
<td>Aaron, Abel</td>
<td>386</td>
</tr>
<tr>
<td>Aaron, Abel</td>
<td>346</td>
</tr>
<tr>
<td>Aaron, Abel</td>
<td>586</td>
</tr>
<tr>
<td>Aaron, Abel</td>
<td>615</td>
</tr>
<tr>
<td>Aaron, Abel</td>
<td>691</td>
</tr>
<tr>
<td>Aaron, Abel</td>
<td>732</td>
</tr>
<tr>
<td>Aaron, Abel</td>
<td>550</td>
</tr>
<tr>
<td>Aaron, Abel</td>
<td>444</td>
</tr>
<tr>
<td>Aaron, Abel</td>
<td>529</td>
</tr>
<tr>
<td>Aaron, Abel</td>
<td>668</td>
</tr>
<tr>
<td>Aaron, Abel</td>
<td>773</td>
</tr>
<tr>
<td>Aaron, Abel</td>
<td>656</td>
</tr>
<tr>
<td>Aaron, Abel</td>
<td>347</td>
</tr>
<tr>
<td>Aaron, Abel</td>
<td>430</td>
</tr>
<tr>
<td>Aaron, Dolly</td>
<td>416</td>
</tr>
<tr>
<td>Aaron, Dolly</td>
<td>642</td>
</tr>
<tr>
<td>Aaron, Dolly</td>
<td>457</td>
</tr>
<tr>
<td>Aaron, Dolly</td>
<td>21</td>
</tr>
<tr>
<td>Aaron, Dolly</td>
<td>19</td>
</tr>
<tr>
<td>Aaron, Dolly</td>
<td>14</td>
</tr>
</tbody>
</table>

For more details on building this example, refer to Chapter 35, "Building a Paper Report with a Simple Table of Contents and Index".

Note: Generating a table of contents is not supported for matrix reports.
3.5.10 Bursting and distributing a report

In this example, you will modify a simple report that have been provided to burst each section to a separate report. You will then modify a sample distribution XML file to send an e-mail to each destination with an attachment based on the separate reports. You will also send multiple e-mails to the same e-mail address with a single attachment (the entire report).

For more information on building this example, refer to Chapter 37, "Bursting and Distributing a Report".

---

Note: No sample output is available for this report.

3.5.11 Building a report with multibyte characters for PDF output

In this example, you will learn how to create a report in PDF format that contains multibyte characters for the Web and paper output. You will build a multibyte character set report using UTF8. You can produce reports that display text in multibyte character sets, such as Simplified Chinese, Traditional Chinese, Japanese, Korean, and Unicode.
3.6 Part 6: Building Reports with PL/SQL and Java

This part of the manual explains how you can build reports using PL/SQL and Java.

3.6.1 Building a PL/SQL report

In this example, you will learn how to use an external PL/SQL library and PL/SQL within a report to modify formatting and calculate the total compensation for each employee. In the sample output below, notice the spacing between records (for example, between the record for Alexander Khoo and the record for Alexis Bull). This space is not due to a break; it is the result of using a PL/SQL procedure in a format trigger.

For more information on building this example, refer to Chapter 40, "Building a Report that Includes PL/SQL".
3.6.2 Building a paper report with REF CURSORS

In this example, you will learn how to use Reports Builder's features for using REF CURSORS. To build this paper report, you will use the Data Model view to create a multiquery data model, and then use the Report Wizard to create the report layout. You will make fairly extensive manual refinements in the Data Model view.

Figure 3–38 Final output for the REF CURSORS example

For more information on building this example, refer to Chapter 41, "Building a Paper Report with REF CURSORs".

3.6.3 Building a simple Parameter Form for a JSP-based Web report

This example is designed to teach you how to build a simple JSP Parameter Form for a Web report. You will build a simple form in HTML, then create a JSP Parameter Form based on a data model in Reports Builder. You will then learn how to link the Parameter Form with an existing JSP-based Web report, then deploy and test both the JSP Parameter Form and the Web report through your browser.

Figure 3–39 JSP Parameter Form

Parameter Form

Choose a department from the list, then click the Run Report button to show salary details for each employee in that department.

Department: [Select]

Login ID: [hr/hr@orcl]

Run Report
Figure 3–40  JSP-based Web report based on a user parameter

Employee Details

The information below shows your employees’ salaries, and will prepare you for the Departmental Review meeting.

The following graph shows your direct reports by salary:

Employees by Salary

The following report provides salary details on your direct reports:

<table>
<thead>
<tr>
<th>Employee Id</th>
<th>Emp Name</th>
<th>Hire Date</th>
<th>Job Id</th>
<th>Salary</th>
<th>Department Id</th>
</tr>
</thead>
<tbody>
<tr>
<td>109</td>
<td>Paul</td>
<td>1988-03-01</td>
<td>10001-0001</td>
<td>90000</td>
<td>100</td>
</tr>
</tbody>
</table>

For more details on building this example, refer to Chapter 42, "Building a Simple Parameter Form for a JSP-based Web Report".

3.6.4 Building a report with a barcode

In this example, you will build a report using the barcode Java bean in Oracle Reports. You will build two reports: one for paper and one for the Web. The paper report shows an invoice for a single customer who has ordered multiple items from a company. The barcode indicates the tracking information for the order.
3.6.5 Building an accessible JSP-based Web report

In this example, you will use the properties in Oracle Reports to produce a JSP-based Web report that is accessible using assistive technology. You will learn how to modify an existing paper-based report to be accessible.

For more information on building this example, refer to Chapter 44, "Building an Accessible JSP-based Web Report".

Note: No sample output is available for this report.
3.7 Part 7: Building Reports with Pluggable Data Sources

This part of the manual explains how you can build reports using pluggable data sources.

3.7.1 Building a report with an XML pluggable data source

Reports Builder enables you to use any data source you wish. In this example, you will learn how to use the XML pluggable data source that is provided with Oracle Reports.

Figure 3–43  Final output of the XML PDS example

<table>
<thead>
<tr>
<th>Warehouse ID</th>
<th>PRODUCT_ID</th>
<th>QUANTITY_ON_HAND</th>
<th>PRODUCT_NAME</th>
</tr>
</thead>
<tbody>
<tr>
<td>6</td>
<td>1733</td>
<td>29</td>
<td>PS 220V AUK</td>
</tr>
<tr>
<td>6</td>
<td>1734</td>
<td>30</td>
<td>Cable RS232 10/100M</td>
</tr>
<tr>
<td>6</td>
<td>1737</td>
<td>30</td>
<td>Cable SCSI 10/100/1000</td>
</tr>
<tr>
<td>6</td>
<td>1738</td>
<td>30</td>
<td>PS 110V A8A8</td>
</tr>
<tr>
<td>6</td>
<td>1739</td>
<td>30</td>
<td>SDRAM - 128 MB</td>
</tr>
<tr>
<td>6</td>
<td>1740</td>
<td>30</td>
<td>HDD 12GB/2GB/1GB</td>
</tr>
<tr>
<td>6</td>
<td>1742</td>
<td>31</td>
<td>CD-ROM 500/160</td>
</tr>
<tr>
<td>6</td>
<td>1745</td>
<td>31</td>
<td>Cable SCSI 20/20/20</td>
</tr>
<tr>
<td>6</td>
<td>1746</td>
<td>32</td>
<td>PS 230V EUVR</td>
</tr>
<tr>
<td>6</td>
<td>1749</td>
<td>32</td>
<td>DIMM - 256MB</td>
</tr>
<tr>
<td>6</td>
<td>1750</td>
<td>32</td>
<td>DIMM - 2GB</td>
</tr>
<tr>
<td>6</td>
<td>1765</td>
<td>33</td>
<td>32MB Cache 1/8M</td>
</tr>
</tbody>
</table>

For more information on building this example, refer to Chapter 45, "Building a Report with an XML Pluggable Data Source".

3.7.2 Building a report with a text pluggable data source

In this example, you will learn how to use character-delimited text as a data source.
Summary

For more information on building this example, refer to Chapter 46, "Building a Report with a Text Pluggable Data Source".

3.8 Summary

In this chapter, each of the example reports contained in this manual are described. For more details on each of the examples, refer the location provided. For access to the latest versions of the documentation and example files, visit the Oracle Technology Network (OTN): on the Oracle Reports page (http://www.oracle.com/technetwork/middleware/reports/overview/index.html), click Getting Started to display the Getting Started with Oracle Reports home page.
This chapter provides procedures for using Oracle Reports to create objects and design your reports. Each topic in this chapter is also included in the How To... section of the Oracle Reports online Help (see Section 4.1, "Using the Oracle Reports online Help").

The procedures are grouped into the following sections:

- Section 4.1, "Access Oracle Reports Documentation"
- Section 4.2, "Set Properties and Preferences"
- Section 4.3, "Perform Common Tasks"
- Section 4.4, "Work with the Object Navigator"
- Section 4.5, "Work with Reports"
- Section 4.6, "Work with Web Reports"
- Section 4.7, "Run and Dispatch a Report"
- Section 4.8, "Work with the Data Model"
- Section 4.9, "Work with the Report Layout"
- Section 4.10, "Work with Report Sections"
- Section 4.11, "Work with Parameters and the Parameter Form"
- Section 4.12, "Define a Template"
- Section 4.13, "Use PL/SQL in a Report or Template"
- Section 4.14, "Debug a Report"
- Section 4.15, "Integrate with Other Products"
- Section 4.16, "Administer Oracle Reports Builder"

### 4.1 Access Oracle Reports Documentation

This section provides procedures for the following tasks that you may perform to access the Oracle Reports documentation:

- Using the Oracle Reports online Help
- Locating other documentation
4.1.1 Using the Oracle Reports online Help

For more information on using Oracle Reports Builder, as well as Oracle Reports reference information, refer to the *Oracle Reports online Help*, which you can access in any of the following ways:

- From Oracle Reports Builder:
  - Choose **Help > Help Contents**.
  - Click **Help** or press F1 in any dialog box.
  - In the Property Inspector, click a property, then press F1 to display the property's help topic.

  - Under **Resources**, click **Hosted Online Help** to display the Web-based version of the most recent *Oracle Reports online Help*.
  - Under **News**, click **Oracle Reports Online Help Update** to replace your *Oracle Reports online Help* in Oracle Reports Builder with the most recent update. Instructions for replacing your help file are included in the readme.txt in the download file.

The following guidelines will help you to make effective use of the online Help:

- Familiarize yourself with the **Contents** tab to get an idea of the scope of the topics covered in the online Help.

- Click the **Index** tab to locate specific topics on a subject.

- The Help Navigator window and Help Topic window can be separated or kept together. Move the windows as desired.

4.1.2 Locating other documentation

To get started and become proficient with building reports, refer to the following resources:

<table>
<thead>
<tr>
<th>For...</th>
<th>Refer to...</th>
</tr>
</thead>
<tbody>
<tr>
<td>An overview of Oracle Reports</td>
<td>Overview information available on the Oracle Technology Network Oracle Reports page (<a href="http://www.oracle.com/technetwork/middleware/reports/overview/index.html">http://www.oracle.com/technetwork/middleware/reports/overview/index.html</a>).</td>
</tr>
<tr>
<td></td>
<td>Online help topics under the Welcome node in the Help Navigator window (choose <strong>Help &gt; Help Contents</strong>).</td>
</tr>
<tr>
<td></td>
<td>&quot;Introduction&quot; chapter in <em>Publishing Reports to the Web with Oracle Reports Services</em> manual details the new functionality in Oracle Reports 112c (12.2.1), along with the equivalent 10g Release 2 (10.1.2) functionality.</td>
</tr>
</tbody>
</table>
### Table 4-1 (Cont.) Oracle Reports documentation roadmap

<table>
<thead>
<tr>
<th>For...</th>
<th>Refer to...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Instructions and hands-on lessons about building paper and Web-based reports</td>
<td>This manual and Oracle Reports Tutorial, available in the Oracle Fusion Middleware Documentation Library. Online Help (choose Help &gt; Help Contents in Oracle Reports Builder) for specific tasks and reference information.</td>
</tr>
<tr>
<td>Context-sensitive help on dialog boxes, messages, and properties</td>
<td>For dialog boxes and messages, the online Help topics displayed when you click Help, or press F1. For properties, the online Help topics displayed when you click a property in the Property Inspector, then press F1.</td>
</tr>
<tr>
<td>Examples and demos</td>
<td>Via the Oracle Reports Search page on OTN (<a href="http://www.oracle.com/technetwork/middleware/report">http://www.oracle.com/technetwork/middleware/report</a> s/overview/index.html): In the Collateral Type list, choose Examples or Demonstrations, and click Search. In the list that displays, click an example or demo that interests you.</td>
</tr>
<tr>
<td>Other resources, such as white papers</td>
<td>Via the Oracle Reports Search page on OTN (<a href="http://www.oracle.com/technetwork/middleware/report">http://www.oracle.com/technetwork/middleware/report</a> s/overview/index.html): In the Collateral Type list, choose White Papers &amp; How To Documents, and click Search.</td>
</tr>
</tbody>
</table>

### 4.2 Set Properties and Preferences

This section provides procedures for the following tasks that you may perform as you work with property and preference settings:

- Displaying the Property Inspector
- Setting report properties
- Setting report preferences
- Setting preferences for the Object Navigator
- Setting properties for an ASCII (character-mode) report
- Setting color palette preferences
Set Properties and Preferences

- Setting properties of multiple objects
- Comparing the properties of one object to another

4.2.1 Displaying the Property Inspector

To display the Property Inspector for an object:

- In the Object Navigator, do any of the following:
  - Double-click the icon immediately to the left of the object name.
  - Click the object name, then right-click and choose Property Inspector.
  - Click the object name, then choose Tools > Property Inspector.
  - Click the object name, then press F4.

- In the Report Editor views, do any of the following:
  - Double-click the object.
  - Click the object, then right-click and choose Property Inspector.
  - Click the object, then choose Tools > Property Inspector.
  - Click the object, then press F4.

See also
Section 1.10.1, "About the Property Inspector"

4.2.2 Setting report properties

To set the properties for a report:

1. In the Object Navigator, double-click the properties icon next to the report name to display the Property Inspector.
2. Set report properties as desired.

4.2.3 Setting report preferences

To specify the preferences for a report:

1. Choose Edit > Preferences.
2. To specify preferences for designing reports, set values on the General, Access, and Wizards tabs.
3. To specify preferences for running reports, set values on the Runtime Values and Runtime Settings tabs.
4. For a detailed description of settings in the Preferences dialog box, click Help.

4.2.3.1 Using the Auto Save Feature

Oracle Reports 12c (12.2.1.1) provides the Auto Save feature that recovers any unsaved changes during an unexpected event in Reports Builder or system failure.

If Auto Save is enabled, Reports Builder recovers any unsaved data automatically.

To enable the Auto Save feature:

1. In the Object Navigator, choose Edit > Preferences...
2. In the General tab, select the Auto Save check box.
3. Click OK.

### 4.2.4 Setting preferences for the Object Navigator

To specify options for the Object Navigator display:

1. In the Object Navigator, choose **Tools > Options > Navigator**.
2. In the Object Navigator Options dialog box, change the settings as desired.
3. Click **OK**.

See also

Section 1.5.1, “About the Object Navigator”

### 4.2.5 Setting properties for an ASCII (character-mode) report

To set properties for an ASCII (character-mode) report:

1. Double-click the properties icon next to the report name to display the Property Inspector.
2. Under the **Character Mode** node, set **Design In Character Units** to Yes.
3. In the Object Navigator, under the **Paper Layout** node, double-click the Header Section, Main Section, or Trailer Section properties icon for the pertinent report section (Header, Main, or Trailer) to display the Property Inspector.

   **Note:** By default, a report is defined in the Main section.

4. In the Property Inspector, under the **Section** node:
   - set the **Report Width** and **Report Height** to the appropriate character-mode dimensions for the report. For example, 132 (or 180) width x 66 height for landscape or 102 width x 85 (or 116) height for portrait.
   - set the **Orientation** property to the desired value.
5. In the Object Navigator, expand the **Data Model** node, then the **System Parameters** node.
6. Double-click the properties icon next to **MODE** to display the Property Inspector, and set the following properties:
   - Under the **Parameter** node, set the **Initial Value** property to **Character**.
7. In the Paper Layout view, choose **Tools > Options > Rulers** to display the Ruler Settings dialog box:
   - Set Units to **Character Cells** and **Number of Snap Points Per Grid Spacing** to 1.
   - Click **OK**.
8. Click **View** in the menu bar and make sure that **Snap to Grid** is checked.
9. Choose **Edit > Preferences** to display the Preferences dialog box:
   - On the **Wizards** page, set **Horizontal Interfield** to 1 and **Vertical Interfield** to 0.
   - Click **OK**.
10. Choose Format > Font, and select the font, style, and size that most closely approximates the character-mode font. For example, Courier, Regular, 12 points.

See also
Section 4.5.9, "Creating an ASCII (character-mode) report"

4.2.6 Setting color palette preferences

To set color palette preferences:

1. Choose Edit > Preferences.

2. In the Preferences dialog box, on the General tab page, set the Color Mode as desired:

   - **Editable.** Oracle Reports Builder temporarily replaces your system's color palette with the palette of the active report. Each time a new report is made active, its color palette replaces the system palette. A report can have only one color palette. The active report will then be shown accurately, although the appearance of the inactive reports may suffer. You must choose Editable if you want to modify the color palette or import or export a color palette.

   - **Read Only - Shared.** (Default) Oracle Reports Builder continues to append each active report's color palette to your system's original palette until there is no room left in the palette for any more colors. That palette becomes the single palette that all open reports share. If you create a report that uses entirely different colors, it may not be shown accurately.

   - **Read Only - Private.** Each time you make a report active, Oracle Reports Builder appends that report's color palette to your system's original palette until there is no room left in the palette for any more colors. This palette is then used whenever that report is active. The active report is then shown accurately, although the appearance of the inactive reports may suffer.

   **Note:** A report can have only one color palette.

3. If you change the Color Mode, shut down and restart Oracle Reports Builder to enable the new mode.

See also
Section 2.4.5, "About changing colors and patterns"
Section 4.9.6.6, "Importing or exporting a color palette"
Section 4.9.6.5, "Modifying the color palette"
Section 4.9.6.2, "Changing colors"

Topics "Oracle CDE1 color palette", "Default color palette", and "Grayscale color palette" in the Reference > Color and Pattern Palettes section of the Oracle Reports online Help.

4.2.7 Setting properties of multiple objects

To set the properties of multiple objects:
1. In the Object Navigator or any Report Editor view, select the objects whose properties you want to set. The objects can be of different types and can even be in different documents.

2. Choose Tools > Property Inspector.

3. In the Property Inspector, click the Union button to see all properties of all objects or leave the tool as the Intersection button to see only the properties the objects have in common.

4. Set the properties as desired.

For example, a report includes several fields, each of which displays the date. The Datatype property of each field is DATE, which causes dates to be displayed in the default ORACLE format DD-MON-YY.

To use a different date format throughout the application, you need to set the Format Mask property for each field that displays dates. Rather than setting each field’s Format Mask property individually, select all of the items, then set the Format Mask property once to change the format mask for each item selected.

**See also**

Section 1.10.1.1, "About making multiple selections in the Property Inspector"

### 4.2.8 Comparing the properties of one object to another

To compare the properties of one object to another:

1. In the Object Navigators or the editors, double-click the first object so that its properties are displayed in the Property Inspector.

2. In the Property Inspector, click the Pin button to attach this copy of the Property Inspector to the current object.

3. In the Object Navigator, double-click the second object, then choose Tools > Property Inspector.

A second Property Inspector is displayed. If the second window is on top of the first, drag it to move it alongside the first window.

### 4.3 Perform Common Tasks

As you work with Oracle Reports Builder, you will become very familiar with the following tasks:

- Connecting to a database
- Opening a report
- Saving a report
- Renaming a report
- Deleting a report
- Selecting and deselecting objects
- Deleting an object
Usage notes
Beginning with Oracle Reports 10g, reports are no longer stored in the database (including the obsolescence of Rename, Grant, and Get Info functionality for reports in the database). Instead, reports are saved to files.

4.3.1 Connecting to a database
To connect to a database when designing a report in Oracle Reports Builder:
1. Choose File > Connect.
2. In the Connect dialog box, type the required information in the User Name, Password, and Database fields (click Help for more information), then click Connect.

To connect to a database using the command line:
- On the rwbuilder or rwrn command line, use the USERID keyword to specify connection information (USERID=username[/password][@database]). For information about USERID, see the Reference > Command Line section of the Oracle Reports online Help.

4.3.2 Opening a report
To open a report:
1. Choose File > Open.
2. In the Open dialog box, browse to the report, click its name, then click Open to open the report in Oracle Reports Builder.

4.3.3 Saving a report
To save a report:
1. Choose File > Save or File > Save As or click the Save button in the toolbar.
2. In the Save dialog box, browse to the desired location, and type a name for the report, if it has never been saved before. Click Save.

4.3.4 Copying a report
To copy a report:
1. In the Object Navigator, click the report you want to copy.
2. Choose File > Save As.
3. In the Save As dialog box, browse to the desired location, and type a name for the new copy of the report. Click Save.

4.3.5 Renaming a report
To rename a report in the Object Navigator:
1. In the Object Navigator, double-click the properties icon next to the report name to display the Property Inspector.
2. In the Property Inspector, under the General Information node, set the Name property by typing a new name.

To rename a report in the file system:
1. In your operating system’s file system (for example, Windows Explorer on Windows), browse to the location of the report.
2. Click the report name, then click again to make its name active.
3. Type a new name for the report.

### 4.3.6 Deleting a report

To delete a report in the Object Navigator:

1. In the Object Navigator, click the report name, then choose Edit > Delete, or click the Delete button in the toolbar.
2. In the alert dialog box, click Yes to delete the report. To cancel the delete operation, click No.

To delete a report in the file system:

1. In your operating system’s file system, for example, Windows Explorer on Windows, browse to the location of the report.
2. Click the report name, then choose File > Delete.
3. In the alert dialog box, click Yes to delete the report. To cancel the delete operation, click No.

### 4.3.7 Selecting and deselecting objects

To manipulate objects or define their properties, you must first select them.

#### 4.3.7.1 Selecting single objects

To select a single object in the Object Navigator:
- Click the object. If the object is displayed in one of the Report Editor views, it is also selected in the corresponding view.

To select a single object in the Data Model view, Paper Layout view, Paper Design view, or Parameter Form view:

1. If a tool in the tool palette is active, first click the Select tool in the tool palette.
2. Click the object.

#### 4.3.7.2 Selecting multiple objects

To select multiple objects in the Object Navigator:

- Click the first object, then either:
  - Shift-click another object to select all objects between the first and current object.
  - Or, control-click additional objects to add them to the selection group.

Objects that are displayed in one of the Report Editor views are also selected in the corresponding view.

To select multiple objects in the Data Model view, Paper Layout view, Paper Design view, or Parameter Form view:

1. If a tool in the tool palette is active, first click the Select tool in the tool palette.
2. Do either of the following:
Perform Common Tasks

- Shift-click each object.
- Or, click and drag a region that includes all of the objects you want to select. (In the Data Model view, notice that if the first object you select is a column within a group, everything else you select must be a column within the same group; you cannot select columns within groups at the same time as you select queries, groups, report-level columns, or parameters.)

4.3.7.3 Selecting objects owned by a frame
To select a set of objects owned by a frame or repeating frame:

1. In the Paper Layout view, either:
   - Click the Confine On button in the toolbar.
   - Or, if you want to explicitly select all objects to set common properties, click the Frame Select button in the toolbar.
2. Click the frame or repeating frame.
   All objects within the frame or repeating frame are selected, depending upon their explicit anchors.

4.3.7.4 Selecting grouped objects
To select grouped objects (grouped using Layout > Group Operations > Group), click the Select tool in the tool palette and click one of the grouped objects.

4.3.7.5 Selecting all objects in a report region
To select all objects within the region (Body or Margin of the Header Section, Main Section, or Trailer Section) you are currently editing, choose Edit > Select All. (In the Data Model view, notice that this does not select any columns within groups.)

4.3.7.6 Selecting overlapped objects
To select any object that is partially or completely overlapped by another object:

1. Click the object that obscures the object you want to select.
2. Choose Layout > Send to Back to move the object that you want on top of the object that obscured it.
3. Click the object.

4.3.7.7 Deselecting single objects
To deselect a single object in the Object Navigator:

- Control-click the object. If the object is displayed in one of the Report Editor views, it is also deselected in the corresponding view.

To deselect a single object in the Data Model view, Paper Layout view, Paper Design view, or Parameter Form view:

- Shift-click the object.

4.3.7.8 Deselecting multiple objects
To deselect all selected objects:

- Click anywhere in a blank area.
4.3.8 Deleting an object

To delete an object:

1. Click the object(s).

   **Tip:** To select multiple objects, click one object, then Shift-click all other objects. To select all objects, choose Edit > Select All.

2. Choose Edit > Delete.

4.4 Work with the Object Navigator

This section provides procedures for the following tasks that you may perform as you work with the Object Navigator:

- Displaying a Report Editor view from the Object Navigator
- Expanding and collapsing nodes
- Searching for nodes
- Changing Object Navigator views
- Setting preferences for the Object Navigator

See also

Section 1.5.1, "About the Object Navigator"

4.4.1 Displaying a Report Editor view from the Object Navigator

To display a Report Editor view from the Object Navigator, do any of the following:

- Double-click the icon next to the node of the view you want to display. For example, to display the Paper Layout view, double-click the view icon next to the Paper Layout node.
- Click the node, then click the right mouse button and choose Report Editor.
- Click the node, then choose Tools > Report Editor.

   **Note:** In the Object Navigator, there is no Paper Design node; the Paper Design view is displayed only after running a report.

See also

Section 1.6.2, "About the Data Model view"
Section 1.6.3, "About the Paper Layout view"
Section 1.6.5, "About the Paper Parameter Form view"
Section 1.6.6, "About the Web Source view"

4.4.2 Expanding and collapsing nodes

To expand or collapse a node one level, do either of the following:

- In the Object Navigator, click the plus or minus sign next to the node.
4.4.3 Searching for nodes

To search for a specific node in the Object Navigator:
1. Type the full or partial name of the node in the Find field.
2. To search for the next match, click the Find Next button in the toolbar.
3. To search for the previous match, click the Find Previous button in the toolbar.

4.4.4 Changing Object Navigator views

To view objects in the Object Navigator by object hierarchy to see the parent-child relationships:
- Choose View > Change View > Ownership View.

To view objects in the Object Navigator by their type such as all queries under a single heading:
- Choose View > Change View > Object Type View.

See also
Section 1.5.2, "About Object Navigator views"

4.4.5 Setting preferences for the Object Navigator

See Section 4.2.4, "Setting preferences for the Object Navigator".

4.5 Work with Reports

This section provides procedures for the following tasks that you may perform as you work with reports (either paper-based or Web-based):
- Creating a report
- Creating a multiquery group above report
- Creating a nested matrix report
- Creating a default layout for a report
- Creating an additional report layout
- Adding a title to a report
- Adding a table of contents to a report
- Adding index to a report
- Creating an ASCII (character-mode) report
- Preparing a multiplatform report
Preparing a report for translation into other languages

4.5.1 Creating a report

To create a single-query report:

1. In the Object Navigator, click the Reports node, then click the Create button in the toolbar.
2. In the New Report dialog box, click Use the Report Wizard, then click OK.
3. Follow the Report Wizard to create your report, clicking Help for assistance on any tab page.
4. Modify the resulting report output in the Web Source view or Paper Design view, or choose Tools > Report Wizard to re-enter the wizard.

To build a multiquery report:

1. Create each query using the Data Wizard, clicking Help for assistance on any tab page (see Section 4.8.1.2, "Creating a query: Data Wizard").
2. Create a layout for the report (see Section 4.5.4, "Creating a default layout for a report").

See also
Section 1.2.1, "About Reports"
Section 1.2.2, "About Web Reports"
Section 4.5.1, "Creating a report"
Section 1.3.1, "About tabular reports"
Section 1.3.2, "About group above reports"
Section 1.3.3, "About group left reports"
Section 1.3.4, "About form-like reports"
Section 1.3.5, "About form letter reports"
Section 1.3.6, "About mailing label reports"
Section 1.3.7, "About matrix reports"
Section 2.1.7, "About nested matrix reports"
Section 2.1.8, "About matrix with group reports"

4.5.2 Creating a multiquery group above report

See the example report in Chapter 11, "Building a Two-Query Group Report".

4.5.3 Creating a nested matrix report

See the example report in Chapter 26, "Building a Nested Matrix Report".

4.5.4 Creating a default layout for a report

To create a default layout for a report:

1. To default the layout for the current report (by default, the Main section of the report), choose Tools > Report Wizard, then follow the wizard to create the layout for the report style you choose.
2. To add another layout section to the current report layout, create an additional report layout, as described below.

3. Make further modifications to the default layout manually in the Paper Layout view.

---

**Caution:** If you re-enter the Report Wizard after making manual adjustments to your layout in the Paper Layout or Paper Design view, you will lose these layout changes when you click **Finish** in the Report Wizard, which redefaults the layout.

---

**See also**

Section 2.4.2, "About layout defaulting"

Section 4.10.2, "Creating a default layout for a section"

Chapter 4.9.13.3, "Changing the default layout spacing"

---

### 4.5.5 Creating an additional report layout

To add a new layout section to a report without overriding existing layouts:

1. In the Paper Layout view, click the Report Block tool in the tool palette.
2. Drag a rectangular area for the new layout to display the Report Block Wizard.
3. Follow the wizard to select the data to display in the new layout section.
4. To reorder the layout sections, click and drag them to new positions in the Paper Layout view.

---

**Caution:** If you re-enter the Report Wizard to make modifications, then click **Finish** in the Report Wizard, your entire layout will be overwritten with a new default layout. You will lose the additional report layout you have created, and any manual changes made to the layout in the Paper Layout or Paper Design view.

---

### 4.5.6 Adding a title to a report

To add a title to a report:

1. In the Object Navigator, select or open the report.
2. Choose **Tools > Report Wizard**.
3. On the **Style** page, type a title for the report in the **Title** field.
4. If the report title is to be used in a template, see Section 4.12.5, "Formatting the report title in a template".

---

**See also**

Section 2.1.1, "About report titles"

Section 2.7.1, "About templates"
4.5.7 Adding a table of contents to a report

To create a table of contents (TOC) for a report, you can use the Format Order property or the \texttt{SRW.SET_FORMAT_ORDER} built-in procedure to format the Main section of the report first and use report triggers to build a table containing the TOC entries. When the first element for the TOC is formatted, a trigger fires and creates a row in the TOC table containing the TOC entry and the page number. After the Main section has completed formatting, the format order setting can define that the Header section is formatted next. The Header section can contain a report block based on the TOC table. After formatting, you can output your report with a TOC (the Header section), followed by the report body (the Main section), followed by the Trailer section.

For two step-by-step examples, see Chapter 35, "Building a Paper Report with a Simple Table of Contents and Index" and Chapter 36, "Building a Paper Report with a Multilevel Table of Contents".

See also
Section 2.8.1, "About format order"

4.5.8 Adding index to a report

To create an index for a report, you can use report triggers to build a table containing the index entries as you format the Main section of your report. When the first element for the index is formatted, a trigger fires and creates a row in the index table containing the index entry and the page number. After the Main section has completed formatting, the Trailer section is formatted next by default. The Trailer section can contain a report block based on the index table. After formatting, you can output your report with the report body (the Main section), followed by an index (the Trailer section).

For a step-by-step example, see Chapter 35, "Building a Paper Report with a Simple Table of Contents and Index".

4.5.9 Creating an ASCII (character-mode) report

To create an ASCII (character-mode) report:

1. First, create and save a report using the Report Wizard.
2. In the Object Navigator, under the \texttt{Reports} node, click the report you want to convert to character mode.
4. In the Convert dialog box, on the Conversion tab page:
   - set Document Type to Report.
   - set Source to the name of the existing bit-mapped report.
   - set Destination Type to Report Binary File (RDF).
   - set Destination to the name of the new character-mode report.
5. On the Options tab page, set Destination Unit to Character.
6. Click OK.
7. Set properties for your new character-mode report.

See also
Section 2.8.15, "About creating an ASCII (character-mode) report"
Section 4.2.5, "Setting properties for an ASCII (character-mode) report"

4.5.10 Preparing a multiplatform report

To prepare a report to run on multiple platforms, consider the following GUI differences:

Fonts: A font type, style, or size might not be available in the target GUI. You can handle this in one of two ways:

- Use a font that you know exists on the target GUI or one that maps well to the default font of the target GUI.
- Modify the font mapping file, uifont.ali, to ensure that the fonts map correctly.

Colors: A color might not be available in the target GUI. If possible, use a color that you know exists on the target GUI; otherwise, use one that maps well to the default color of the target GUI. The following colors are typically available on many platforms: blue, magenta, red, cyan, green, yellow.

DPI: The dots-per-inch (DPI) that your monitor uses may not be the same as the DPI used by the person who runs the report. The DPI only affects how alpha-numeric characters word-wrap on the screen. If you design a report that may be displayed in the Paper Design view, try to use the same DPI as the people who will run it. Also avoid giving layout objects fixed sizing.

4.5.11 Preparing a report for translation into other languages

For detailed information about National Language Support (NLS), review the topics in the National Language Support section of the Oracle Reports online Help.

4.6 Work with Web Reports

This section provides procedures for the following tasks that you may perform as you work with Web reports:

- Creating a Web report
- Viewing the source code for a Web report
- Adding report data to an existing Web page (HTML file)
- Adding a report block to a Web page
- Adding an image
- Adding a graph
- Editing a graph
- Adding a graph hyperlink
- Preparing a paper-based report for the Web
- Adding Web links to paper-based reports

See also
Section 1.2.2, "About Web Reports"

4.6.1 Creating a Web report

You can create a Web report in any of the following ways:
Create a report using the Report Wizard, (see Section 4.5.1, "Creating a report"), choosing to create a report for both Web and paper, or Web only.

Insert a report in a Web page by adding report data, then adding a report block to a Web page, as described in Section 4.6.3, "Adding report data to an existing Web page (HTML file)" and Section 4.6.4, "Adding a report block to a Web page".

Display the Web Source view and manually insert the Oracle Reports custom JSP tags (see the Reference section of the Oracle Reports online Help).

Insert an existing report into an existing Web page, by displaying the Web Source view for both the report and the Web page, then copying and pasting the report block into the desired position in the Web page.

Prepare a paper-based report for the Web by adding hyperlinks to an existing report (see Section 4.6.9, "Preparing a paper-based report for the Web").

4.6.2 Viewing the source code for a Web report

To view the source code for a Web report, do any of the following:

- In the Report Editor, click the Web Source button in the toolbar.
- In the Object Navigator, double-click the view icon next to the Web Source node for the report to display the source code in the Web Source view.
- Choose View > Change View > Web Source.

See also
Topic "Oracle Reports JSP tags" in the Reference section of the Oracle Reports online Help.

4.6.3 Adding report data to an existing Web page (HTML file)

To retrieve the data to be used to build a report to add to an existing Web page (HTML file):

1. In the Object Navigator, choose File > Open.
2. Navigate to your Web page (HTML file), and click Open.
3. In the Object Navigator, find the report created when you opened the HTML file (Oracle Reports Builder may give the report a default name, such as REP1), then double-click the view icon next to the Data Model node to display the Data Model view.

---

Caution: If you right-click the Data Model node, then choose Report Wizard to use the Report Wizard to select the data for a report, the report will overwrite all of the data in your existing Web page.

---

4. In the Data Model view, choose Insert > Query to select data for the report using the Data Wizard.

After you click Finish, the data you have selected is available to your Web report.

Next step
See Section 4.6.4, "Adding a report block to a Web page"
4.6.4 Adding a report block to a Web page

To add a report block to an existing Web page:

1. In the Object Navigator, choose File > Open.
2. Navigate to your Web page (HTML file), and click Open.
3. In the Object Navigator, find the report created when you opened the HTML file (Oracle Reports Builder may give the report a default name, such as REP1).
4. After you have added the data to be used to build the report (see Section 4.6.4, "Adding a report block to a Web page"), double-click the view icon next to the Web Source node to display the source code for the Web page in the Web Source view.
5. Locate the section in the source code where you want to add the report block.

Note: Adding some comment text such as "Place the report block here" to your Web page enables you to easily locate the correct position for your report block.

7. In the Report Block Wizard, specify the information for the report block.

4.6.5 Adding an image

See Section 4.9.8.1, "Adding an image"

4.6.6 Adding a graph

See Section 4.9.8.2, "Adding a graph"

4.6.7 Editing a graph

See Section 4.9.8.3, "Editing a graph"

4.6.8 Adding a graph hyperlink

See Section 4.9.8.4, "Adding a graph hyperlink"

4.6.9 Preparing a paper-based report for the Web

To prepare a paper-based report for the Web:

1. (Optional) Add desired Web links to a new or existing report:
   - Create an HTML document header (see Section 4.6.10.1.1)
   - Create an HTML document footer (see Section 4.6.10.1.2)
   - Create an HTML page header (see Section 4.6.10.1.3)
   - Create an HTML page footer (see Section 4.6.10.1.4)
   - Create an HTML Parameter Form header (see Section 4.6.10.1.5)
   - Create an HTML Parameter Form footer (see Section 4.6.10.1.6)
   - Create a hyperlink (and, if linking to an object within the report, create an associated hyperlink destination) (see Section 4.6.10.1.8 and Section 4.6.10.1.7)
Create an application command line link (PDF output only) (see Section 4.6.10.1.9)

Create a bookmark (see Section 4.6.10.1.10)

2. Select a printer or use the default printer setup (the drivers for the currently selected printer are used to produce the output; you must have a printer configured for the machine on which you are running the report).

3. Display your report output in your Web browser (see Section 4.7.16.4, "Displaying report output in your Web browser")

See also
Section 1.2.2, "About Web Reports"
Section 2.2.3, "About Web links for HTML output"
Section 2.2.4, "About Web links for PDF output"

4.6.10 Adding Web links to paper-based reports

This section provides procedures that apply to paper-based reports generated to an HTML or PDF file. This is unrelated to HTML that might be generated when you run a JSP-based Web report (when you click the Run Web Layout button in the toolbar, or choose Program > Run Web Layout).

You can add Web links to paper-based reports by either:

- Using the user interface.
- Using PL/SQL.

4.6.10.1 Using the user interface

This section provides procedures for the following tasks that you may perform using the Oracle Reports Builder user interface to add Web links to paper-based reports:

- Creating an HTML document header using the Property Inspector
- Creating an HTML document footer using the Property Inspector
- Creating an HTML page header using the Property Inspector
- Creating an HTML page footer using the Property Inspector
- Creating an HTML Parameter Form header using the Property Inspector
- Creating an HTML Parameter Form footer using the Property Inspector
- Creating a hyperlink destination using the Property Inspector
- Creating a hyperlink using the Property Inspector
- Creating an application command line link using the Property Inspector
- Creating a bookmark using the Property Inspector
- Creating a bookmark on break columns using the Property Inspector
- Adding navigation controls for HTML page-streamed output using the Property Inspector
- Selecting HTML tags from the database

See also
Section 1.2.2, "About Web Reports"
Section 2.2.3, "About Web links for HTML output"
Section 2.2.4, "About Web links for PDF output"
Section 2.2.10, "About before and after escapes"

4.6.10.1.1 Creating an HTML document header using the Property Inspector

**Note:** This procedure is for HTML output only.

To insert an HTML file or text on the header page of your HTML document:
1. In the Object Navigator, double-click the properties icon for the report to display the Property Inspector.
2. Under the Report Escapes node, set the Before Report Type property to Text (if you will type the header) or File (if you will import the header from a file).
3. Set the Before Report Value property by clicking the... button to either type HTML code in the dialog box or select an HTML file to import.

See also
Section 4.6.10.2.1, "Creating an HTML document header using PL/SQL"

4.6.10.1.2 Creating an HTML document footer using the Property Inspector

**Note:** This procedure is for HTML output only.

To insert an HTML file or text on the footer page of your HTML document:
1. In the Object Navigator, double-click the properties icon for the report to display the Property Inspector.
2. Under the Report Escapes node, set the After Report Type property to Text (if you will type the footer) or File (if you will import the footer from a file).
3. Set the After Report Value property by clicking the... button to either type HTML code in the dialog box or select an HTML file to import.

See also
Section 4.6.10.2.2, "Creating an HTML document footer using PL/SQL"

4.6.10.1.3 Creating an HTML page header using the Property Inspector

**Note:** This procedure is for HTML output only.

To add a page header to every page of your HTML document:
1. In the Object Navigator, double-click the properties icon for the report to display the Property Inspector.
2. Under the Report Escapes node, set the Before Page Type property to Text (if you will type the header) or File (if you will import the header from a file).
3. Set the Before Page Value property by clicking the... button to either type HTML code in the dialog box or select an HTML file to import.
To add a page header to a single page of your HTML document:

- See Section 4.6.10.2.3, "Creating an HTML page header using PL/SQL".

4.6.10.1.4 Creating an HTML page footer using the Property Inspector

**Note:** This procedure is for HTML output only.

To add a page footer to every page of your HTML document:

1. In the Object Navigator, double-click the properties icon for the report to display the Property Inspector.
2. Under the Report Escapes node, set the After Page Type property to Text (if you will type the footer) or File (if you will import the footer from a file).
3. Set the After Page Value property by clicking the... button to either type HTML code in the dialog box or select an HTML file to import.

To add a page footer to a single page of your HTML document:

- See Section 4.6.10.2.4, "Creating an HTML page footer using PL/SQL".

4.6.10.1.5 Creating an HTML Parameter Form header using the Property Inspector

**Note:** This procedure is for HTML output only.

To add items to the top of the HTML Parameter Form:

1. In the Object Navigator, double-click the properties icon next to the report name to display the Property Inspector.
2. Under the Report Escapes node, set the Before Form Type property to Text (if you will type the header) or File (if you will import the header from a file).
3. Set the Before Form Value property by clicking the... button to either type HTML code in the dialog box or select an HTML file to import.

**See also**

Section 2.5.1, "About Parameter Form HTML extensions"

Section 4.6.10.2.5, "Creating an HTML Parameter Form header using PL/SQL"

4.6.10.1.6 Creating an HTML Parameter Form footer using the Property Inspector

**Note:** This procedure is for HTML output only.

To add items to the bottom of the HTML Parameter Form:

1. In the Object Navigator, double-click the properties icon next to the report name to display the Property Inspector.
2. Under the Report Escapes node, set the After Form Type property to Text (if you will type the footer) or File (if you will import the footer from a file).
3. Set the After Form Value property by clicking the... button to either type HTML code in the dialog box or select an HTML file to import.
See also
Section 2.5.1, "About Parameter Form HTML extensions"
Section 4.6.10.2.6, "Creating an HTML Parameter Form footer using PL/SQL"

4.6.10.1.7 Creating a hyperlink destination using the Property Inspector

To add a hyperlink destination to your report:

1. In the Object Navigator, expand the Paper Layout node, then expand the node that contains the object that will be the destination of a Web link.

   **Note:** If you are defining a template, you can select objects in the margin. Objects in the body are unknown until the template is applied to a report.

2. Double-click the object that will be the destination of a Web link to display the Property Inspector.

3. Under the Web Settings node, set the Hyperlink Destination property to an identifier for the object.

See also
Section 2.2.7, "About hyperlink destinations"
Section 4.6.10.2.8, "Creating a hyperlink destination using PL/SQL"

4.6.10.1.8 Creating a hyperlink using the Property Inspector

To add a hyperlink to your report:

1. Create a hyperlink destination, as described in the steps above, which will be the target of the Web link.

2. In the Object Navigator, expand the Paper Layout node, then expand the node that contains the object that will be the source of the Web link.

   **Note:** If you are defining a template, you can select objects in the margin. Objects in the body are unknown until the template is applied to a report.

3. Double-click the object that will be the source of the Web link to display the Property Inspector.

4. Under the Web Settings node, set the Hyperlink property to the destination of the link.

   For examples, see the description of the Hyperlink property in the Reference section of the Oracle Reports online Help.

   **Note:** A report output in PDF format can include both hyperlinks and application command line links. If the Application Command Line property is set for an object, it will be applied to the object. Otherwise, the Hyperlink property is applied.
5. To apply additional HTML attributes to the hyperlink, set the Additional Hyperlink Attributes property accordingly.

See also
Section 2.2.5, “About hyperlinks”
Section 4.6.10.2.7, “Creating a hyperlink using PL/SQL”

4.6.10.1.9 Creating an application command line link using the Property Inspector

Note: This procedure is for PDF output only.

To associate a command with an object in your report:

1. In the Object Navigator, expand the Paper Layout node, then expand the node that contains the object with which you want to associate a command.

   Note: If you are defining a template, you can select objects in the Margin. Objects in the body are unknown until the template is applied to a report.

2. Double-click the object with which you want to associate a command to display the Property Inspector.

3. Under the Web Settings node, set the Application Command Line property to the command you want to execute when the object is clicked.

   Note: A report output in PDF format can include both hyperlinks and application command line links. If the Application Command Line property is set for an object, it will be applied to the object. Otherwise, the Hyperlink property is applied.

Restrictions
An object that is associated with an application command line link cannot also be the source of a Web link (a hyperlink).

See also
Section 2.2.9, "About application command line links"
Section 4.6.10.2.9, "Creating an application command line link using PL/SQL”

4.6.10.1.10 Creating a bookmark using the Property Inspector

To create a bookmark on objects other than break columns in the bookmark area of your HTML or PDF document:

1. In the Object Navigator, expand the Paper Layout node, then expand the node that contains the object with which you want to associate a bookmark (typically, the object is a repeating frame or frame that encloses the relevant section of the report).
2. Double-click the object with which you want to associate a bookmark to display the Property Inspector, and set the following properties:

- Under the **Web Settings** node, set the Bookmark property to the string you want to appear in the bookmark area of the formatted report.

**See also**

Section 2.2.8, "About bookmarks"

Section 4.6.10.2.10, "Creating a bookmark using PL/SQL"

**4.6.10.1.11 Creating a bookmark on break columns using the Property Inspector**

To create a bookmark on break columns in the bookmark area of your paginated HTMLCSS or paper PDF document:

1. In the Paper Layout view, choose **Insert > Bookmark**.
2. In the Insert Bookmarks dialog box, move the desired column(s) to the Bookmarks list.
3. Click **OK**.

**See also**

Section 2.2.8, "About bookmarks"

Section 4.6.10.2.10, "Creating a bookmark using PL/SQL"

**4.6.10.1.12 Adding navigation controls for HTML page-streamed output using the Property Inspector**

**Note:** This procedure is for HTML output only.

To add navigation controls for HTML page-streamed (paginated) output:

1. In the Object Navigator, double-click the properties icon next to the report name to display the Property Inspector.
2. Set the Page Navigation Control Type and Page Navigation Control Value properties.

**Note:** If you do not change the default Page Navigation Control Value, Oracle Reports Builder will use a default built-in JavaScript for implementing the navigation between the pages of output.

**See also**

Section 2.8.8.1, "About HTML page streaming"

Section 4.7.16.5, "Displaying individual pages of HTML report output"

Section 4.6.10.2.11, "Adding navigation controls for HTML page-streamed output using PL/SQL"
4.6.10.2 Using PL/SQL

This section provides procedures for the following tasks that you may perform as you work with PL/SQL to add Web links to paper-based reports:

- Creating an HTML document header using PL/SQL
- Creating an HTML document footer using PL/SQL
- Creating an HTML page header using PL/SQL
- Creating an HTML page footer using PL/SQL
- Creating an HTML Parameter Form header using PL/SQL
- Creating an HTML Parameter Form footer using PL/SQL
- Creating a hyperlink using PL/SQL
- Creating a hyperlink destination using PL/SQL
- Creating an application command line link using PL/SQL
- Creating a bookmark using PL/SQL
- Adding navigation controls for HTML page-streamed output using PL/SQL

See also
Section 1.2.2, "About Web Reports"
Section 2.2.3, "About Web links for HTML output"
Section 2.2.4, "About Web links for PDF output"
Section 2.2.10, "About before and after escapes"

4.6.10.2.1 Creating an HTML document header using PL/SQL

Note: This procedure is for HTML output only. A before report escape should be set in a trigger that fires before the report starts formatting, such as the Before Report trigger.

To add items to the header page of your HTML document using PL/SQL instead of the Property Inspector:

1. In the Object Navigator, expand the Report Triggers node.
2. Double-click the PL/SQL icon next to the Before Report trigger.
3. In the PL/SQL Editor, include SRW.SET_BEFORE_REPORT_HTML to define the PL/SQL for the format trigger. (See the Reference section of the Oracle Reports online Help for more information).

See also
Section 4.6.10.1.1, "Creating an HTML document header using the Property Inspector"

4.6.10.2.2 Creating an HTML document footer using PL/SQL

Note: This procedure is for HTML output only. An after report escape should be set in a trigger that fires before the report is done formatting, such as the Before Report trigger.
To add items to the footer page of your HTML document using PL/SQL instead of the Property Inspector:

1. In the Object Navigator, expand the **Report Triggers** node.
2. Double-click the PL/SQL icon next to the Before Report trigger.
3. In the PL/SQL Editor, include `SRW.SET_AFTER_REPORT_HTML` to define the PL/SQL for the format trigger.

**See also**
Section 4.6.10.1.2, "Creating an HTML document footer using the Property Inspector"

---

### 4.6.10.2.3 Creating an HTML page header using PL/SQL

**Note:** This procedure is for HTML output only. If you want the escape to apply to every page, set it in a trigger that fires before the report begins formatting, such as the Before Report trigger. If you want the escape to apply to a single page, set it in a Format trigger.

To add a page header to every page of your HTML document using PL/SQL instead of the Property Inspector:

1. In the Object Navigator, expand the **Report Triggers** node.
2. Double-click the PL/SQL icon next to the Before Report trigger.
3. In the PL/SQL Editor, include `SRW.SET_BEFORE_PAGE_HTML` to define the PL/SQL for the format trigger.

To add a page header to a single page of your HTML document using PL/SQL:

1. In the Object Navigator, expand the **Paper Layout** node, then expand the node that contains the object that should fire the trigger when formatted.
2. Double-click the PL/SQL icon next to the object that should fire the trigger when formatted.
3. In the PL/SQL Editor, include `SRW.SET_BEFORE_PAGE_HTML` to define the PL/SQL for the format trigger.

**See also**
Section 4.6.10.1.3, "Creating an HTML page header using the Property Inspector"

---

### 4.6.10.2.4 Creating an HTML page footer using PL/SQL

**Note:** This procedure is for HTML output only. If you want the escape to apply to every page, set it in a trigger that fires before the report begins formatting, such as the Before Report trigger. If you want the escape to apply to a single page, set it in a Format trigger.

To add a page footer to every page of your HTML document using PL/SQL instead of the Property Inspector:

1. In the Object Navigator, expand the **Report Triggers** node.
2. Double-click the PL/SQL icon next to the **Before Report** trigger.
3. In the PL/SQL Editor, include `SRW.SET_AFTER_PAGE_HTML` to define the PL/SQL for the format trigger.

To add a page footer to a single page of your HTML document using PL/SQL:

1. In the Object Navigator, expand the Paper Layout node, then expand the node that contains the object that should fire the trigger when formatted.
2. Double-click the PL/SQL icon next to the object that should fire the trigger when formatted.
3. In the PL/SQL Editor, include `SRW.SET_AFTER_PAGE_HTML` to define the PL/SQL for the format trigger.

**See also**

Section 4.6.10.1.4, "Creating an HTML page footer using the Property Inspector"

*4.6.10.2.5 Creating an HTML Parameter Form header using PL/SQL*

**Note:** This procedure is for HTML output only. A before form escape should be set in a trigger that fires before the Parameter Form starts formatting, such as the Before Parameter Form trigger.

To add items to the top of the HTML Parameter Form using PL/SQL instead of the Property Inspector:

1. In the Object Navigator, expand the Report Triggers node.
2. Double-click the PL/SQL icon next to the Before Parameter Form trigger.
3. In the PL/SQL Editor, include `SRW.SET_BEFORE_FORM_HTML` to define the PL/SQL for the format trigger.

**See also**

Section 2.5.1, "About Parameter Form HTML extensions"

Section 4.6.10.1.5, "Creating an HTML Parameter Form header using the Property Inspector"

*4.6.10.2.6 Creating an HTML Parameter Form footer using PL/SQL*

**Note:** This procedure is for HTML output only. A before form escape should be set in a trigger that fires before the Parameter Form starts formatting, such as the Before Parameter Form trigger.

To add items to the bottom of the HTML Parameter Form using PL/SQL instead of the Property Inspector:

1. In the Object Navigator, expand the Report Triggers node.
2. Double-click the PL/SQL icon next to the Before Parameter Form trigger.
3. In the PL/SQL Editor, include `SRW.SET_AFTER_FORM_HTML` to define the PL/SQL for the format trigger.

**See also**

Section 2.5.1, "About Parameter Form HTML extensions"
Section 4.6.10.1.6, "Creating an HTML Parameter Form footer using the Property Inspector"

4.6.10.2.7 Creating a hyperlink using PL/SQL

To add a hyperlink to your report using PL/SQL instead of the Property Inspector:

1. In the Object Navigator, expand the Paper Layout node, then expand the node that contains the object that will be the source of the Web link.

   **Note:** If you are defining a template, you can select objects in the Margin. Objects in the body are unknown until the template is applied to a report.

2. Double-click the PL/SQL icon next to the object that will be the source of the Web link.

3. In the PL/SQL Editor, include `SRW.SET_HYPERLINK` to define the PL/SQL for the format trigger.

4. To apply additional HTML attributes to the hyperlink, use `SRW.SET_HYPERLINK_ATTRS`.

**Next step**

Section 4.6.10.2.8, "Creating a hyperlink destination using PL/SQL"

**See also**

Section 2.2.5, "About hyperlinks"

Section 4.6.10.1.8, "Creating a hyperlink using the Property Inspector"

4.6.10.2.8 Creating a hyperlink destination using PL/SQL

To add a hyperlink destination to your report using PL/SQL instead of the Property Inspector:

1. In the Object Navigator, expand the Paper Layout node, then expand the node that contains the object that will be the destination of a Web link.

   **Note:** If you are defining a template, you can select objects in the Margin. Objects in the body are unknown until the template is applied to a report.

2. Double-click the PL/SQL icon next to the object that will be the destination of a Web link.

3. In the PL/SQL Editor, include `SRW.SET_LINKTAG` to define the PL/SQL for the format trigger.

**Next step**

Section 4.6.10.2.7, "Creating a hyperlink using PL/SQL"

**See also**

Section 2.2.7, "About hyperlink destinations"

Section 4.6.10.1.7, "Creating a hyperlink destination using the Property Inspector"
4.6.10.2.9 Creating an application command line link using PL/SQL

To associate a command with an object in your report using PL/SQL instead of the Property Inspector:

1. In the Object Navigator, expand the Paper Layout node, then expand the node that contains the object with which you want to associate an application command line link.

   **Note:** If you are defining a template, you can select objects in the Margin. Objects in the body are unknown until the template is applied to a report.

2. Double-click the PL/SQL icon next to the object with which you want to associate an application command line link.

3. In the PL/SQL Editor, include `SRW.SET_PDF_ACTION` to define the PL/SQL for the format trigger.

**Restrictions**

An object that is associated with an application command line link cannot also be the source of a Web link (a hyperlink).

**See also**

Section 2.2.9, "About application command line links"

Section 4.6.10.1.9, "Creating an application command line link using the Property Inspector"

4.6.10.2.10 Creating a bookmark using PL/SQL

To add a bookmark string in the bookmark area of your report using PL/SQL:

1. In the Object Navigator, expand the Paper Layout node, then expand the node that contains the object with which you want to associate a bookmark (typically, the object is a repeating frame or frame that encloses the relevant section of the report).

   **Note:** If you are defining a template, you can select objects in the Margin. Objects in the body are unknown until the template is applied to a report.

2. Double-click the PL/SQL icon next to the object with which you want to associate a bookmark.

3. In the PL/SQL Editor, include `SRW.SET_BOOKMARK` to define the PL/SQL for the format trigger.

**See also**

Section 2.2.8, "About bookmarks"

Section 4.6.10.1.10, "Creating a bookmark using the Property Inspector"
Section 4.6.10.1.11, "Creating a bookmark on break columns using the Property Inspector"

4.6.10.2.11 Adding navigation controls for HTML page-streamed output using PL/SQL

Note: This procedure is for HTML output only.

To add navigation controls for HTML page-streamed output using PL/SQL instead of the Property Inspector:

- in a Before Report trigger, use the `SRW.SET_PAGE_NAVIGATION_HTML` PL/SQL procedure

See also

Section 2.8.8.1, "About HTML page streaming"
Section 4.7.16.5, "Displaying individual pages of HTML report output"
Section 4.6.10.1.12, "Adding navigation controls for HTML page-streamed output using the Property Inspector"

4.7 Run and Dispatch a Report

This section provides procedures for the following tasks that you may perform as you run and dispatch a report:

- Running and dispatching a report from the user interface
- Running a report from the command line
- Running a report using a command file
- Running a report to a remote Reports Server
- Generating HTML or HTMLCSS output
- Generating PDF output
- Generating XML output
- Generating RTF output
- Generating text output
- Generating delimited output
- Generating Enhanced spreadsheet output
- Distributing a report to multiple destinations
- Deploying a report
- Changing orientation
- Suppressing the Parameter Form
- Viewing report output
- Printing a Report
- E-mailing a report

Note: This procedure is for HTML output only.
4.7.1 Running and dispatching a report from the user interface

To run and dispatch a report from the Oracle Reports Builder user interface:

1. In the Object Navigator, click the report name, or choose File > Open to open it.
2. If you are not already connected, connect to a database.
3. Click the Run Paper Layout button in the toolbar.
4. If the Runtime Parameter Form displays, specify settings for the desired output:
   
   **Note:** When you create the report, you must use the Parameter Form Builder (choose Tools > Parameter Form Builder) to select the system and user parameters you want to appear in the Runtime Parameter Form.

   - To preview output in the Paper Design view using screen fonts: set Destination Type to Screen.
   - To preview output in the Paper Design view using screen fonts and size the fonts using the printer font metrics: set Destination Type to Preview.
   - To send output to a file: set Destination Type to File, Destination Name to the path and filename, Destination Format to the output format for the report (for example, PDF, HTML, HTMLCSS, RTF, XML, or DELIMITED for bitmapped reports, or the character-mode printer definition file (.prt file) for character-mode reports).
   
   **Note:** It is not possible to generate spreadsheet output directly from Oracle Reports Builder. Instead, on the command line, you can run the report using rwrup and Reports Server clients (rclient, rwservlet), with DESFORMAT=SPREADSHEET or DESFORMAT=ENHANCEDSPREADSHEET.

   - To send output to a printer: set Destination Type to Printer and Destination Name to the printer driver name.
   - To send output through e-mail using your Internet standard protocol SMTP e-mail application: set Destination Type to Mail and leave Destination Name blank. In the Mail dialog box, specify the recipients and subject line for your e-mail report.

   **Note:** The configuration file ORACLE_HOME\reports\conf\rwbuilder.conf must include the plug-in parameter mailServer (for example, <pluginParam name="mailServer">smtp01.mycorp.com</pluginParam>) with the outgoing mail server name. This applies in both the Windows and Solaris environments.

5. In the Runtime Parameter Form, click the Run Report button in the toolbar.
6. If a dialog box appears, enter required information.

Usage notes

- If you want the orientation of the report to be landscape, you must change the orientation for the report (see Section 4.7.14, "Changing orientation"). However, if
your printer does not support the specified page size, you may get truncated results. To enable character-mode printers to support landscape (or other page sizes), you can set printer escape sequences in the printer definition files. Refer to your printer documentation for the escape sequences to use.

- When you view the report output in Microsoft Word, you must choose View > Page Layout to see all the graphics and objects in your report.

See also
Section 4.11.6, "Selecting parameters to include in the Runtime Parameter Form"

4.7.2 Running a report from the command line

To run a runfile (.rep) or a report definition file (.rdf) from the command line on Windows:

1. Type %ORACLE_HOME%\BIN\rwrun, followed by the report name and desired arguments.
2. If you sent the output to a file (DESTYPE=FILE DESNAME=filename DESFORMAT=fileformat), open or print the file to verify the output.

See also
Section 1.12, "Oracle Reports Components"
Topic "rwrun" in the Reference section of the Oracle Reports online Help
Section 2.8.2, "About batch reporting"

4.7.3 Running a report using a command file

To run a report using a command file on Windows:

1. Create a text file using a word processor of your choice.
2. In the file, type %ORACLE_HOME%\BIN\rwrun, followed by the report name and desired arguments.
3. Name the file filename.bat.
4. To run the report, type filename.bat on the command line.
5. If you sent the output to a file (DESTYPE=FILE DESNAME=filename DESFORMAT=HTML), open or print the file to verify the output.

See also
Section 2.8.2, "About batch reporting"
Section 1.12, "Oracle Reports Components"
Topic "rwrun" in the Reference section of the Oracle Reports online Help.

4.7.4 Running a report to a remote Reports Server

To run a report to a remote Reports Server:

- Type %ORACLE_HOME%\bin\rwclient, followed by the report name, server name, and desired arguments.

For additional information, see the Publishing Reports to the Web with Oracle Reports Services manual.
4.7.5 Generating HTML or HTMLCSS output

To apply external style sheets and user-defined styles to your report or report objects for HTMLCSS output, you can set the following properties (for information about these properties, see the Reference > Properties section of the Oracle Reports online Help):

- Style Sheets property
- CSS Class Name property
- CSS ID property

To generate HTML or HTMLCSS output:

1. In the Object Navigator, select or open the report, then click the Run Paper Layout button in the toolbar to run the report.

2. In the Paper Design view, specify the scope of output you want to display:
   - To display only the current page of the report, choose File > Preview Format > Current Page.
   - To display all pages, choose File > Preview Format > All Pages.

   **Note:** If you choose to show all pages of your report output, and you have HTML page streaming enabled, the first page will display in your Web browser, and you will be able to quickly navigate to any other page in the rest of the report.

3. To preview your HTML or HTMLCSS report output in a Web browser, choose File > Preview Format > Paginated HTML or Paginated HTMLCSS (to format with style sheet extensions).

4. To save your report output as an HTML or HTMLCSS, choose File > Generate to File.

See also
Section 2.8.8, "About HTML and HTMLCSS output"
Section 2.8.8.1, "About HTML page streaming"
Section 2.2.11, "About style sheets"

4.7.6 Generating PDF output

To generate PDF output:

1. In the Object Navigator, select or open the report, then click the Run Paper Layout button in the toolbar to run the report.

2. In the Paper Design view, specify the scope of output you want to display:
   - To display only the current page of the report, choose File > Preview Format > Current Page.
   - To display all pages, choose File > Preview Format > All Pages.

3. To preview your PDF report output in your Web browser, choose File > Preview Format > PDF.

4. To save your report output as a PDF file, choose File > Generate to File > PDF.
See also
Section 2.8.10, "About PDF output"

4.7.7 Generating XML output

In any Oracle Reports-generated XML file, your output mimics the data model; that is, it is structured by groups and columns. Follow the steps below to do any of the following:

- Generate an XML output file from your current report.
- Preview the contents of an XML file in a Web browser in conjunction with command line invocation.
- Change the XML properties that control XML output for the entire report.
- Change the XML properties that control XML output for a column or group.

To generate an XML output file from your current report in Oracle Reports Builder:

1. Optionally, in the Object Navigator, select or open the report, then click the Run Paper Layout button in the toolbar to run the report. Currently, any report style can be generated to XML output, but with limited support for matrix-style reports.
2. Optionally, in the Paper Design view, choose File > Preview Format > XML to preview XML data in your default XML viewer (for example, your Web browser).

   **Tip:** An .XML extension is required by XML-supporting browsers to recognize the format as XML and display it accordingly.

3. Click the report in the Object Navigator, and choose File > Generate to File > XML to save the XML output file to the directory of your choice.

To generate an XML output file from the command line, then preview the contents of the XML file in a Web browser:

1. On the command line, run your report with the arguments DESFORMAT=XML, DESTYPE=FILE, and DESNAME=filename.XML.
2. Open an XML-supporting Web browser.
3. Choose File > Open to navigate to the XML file that you just generated, and display it in the browser window.
4. If you make changes to the XML output or regenerate the XML file with the same name, click the Reload button in your browser to view the updated XML output.

To change the XML properties of the entire report:

1. In the Object Navigator double-click the properties icon next to the report name to display the Property Inspector.
2. Under XML Settings, set the XML properties as required for this report.

To change the XML properties of a column or group:

1. In the Data Model view, double-click the column or the title bar of the group to display the Property Inspector.
2. Under XML Settings, set the XML properties as required.
### Usage notes

- Oracle Reports Builder creates "well-formed" XML output. This means that there is an XML Declaration present in the prolog of the XML document, but not necessarily a DTD (document type definition). If you wish to create "valid" XML, you must add the DTD in the XML Prolog Value property field at the report level.

- For a report developed in a release prior to Oracle Reports 10g Release 2 (10.1.2) patch 2, you may encounter the following issue when saving the report in XML format: if the report defines a PL/SQL package, the package specification, and sometimes the body, is not saved in the XML report. To resolve this issue, perform either of the following steps:
  
  - If the RDF exists, regenerate the XML output file using Oracle Reports 10g Release 2 (10.1.2) patch 2 or later.
  
  - If the RDF does not exist, edit the XML to manually to add `type="packageSpec"` and/or `type="packageBody"` to the function element, as shown in the following example:

```xml
<programUnits>
  <function name="a" type="packageSpec">
    <! [CDATA[
      PACKAGE a IS
      function lire return date ;
      END a;
    ]]> </textSource>
  </function>

  <function name="a" type="packageBody">
    <! [CDATA[
      PACKAGE BODY a IS
      function lire return date is
        c2 date;
      begin
        c2 :=sysdate;
        return c2;
      end;
      END;
    ]]> </textSource>
  </function>

  <function name="cf_1formula" returnType="date">
    <! [CDATA[
      function CF_1Formula return Date is
        aa date;
      begin
        --aa :=a.lire;
        end;
    ]]> </textSource>
  </function>
</programUnits>
```

- If your report includes a graph, the graph information will not be saved in the XML file (XML is text-based output, which means images are not included).
4.7.8 Generating RTF output

To generate RTF output:

1. In the Object Navigator, select or open the report, then click the Run Paper Layout button in the toolbar to run the report.

2. To preview your report output in a Microsoft Word document, choose **File > Preview Format > RTF**.

3. To save your report output as an RTF file, choose **File > Generate to File > RTF**.

4. In the Save dialog box, specify a location and file name. Click **Save**.

See also
Section 2.8.11, "About RTF output"

4.7.9 Generating text output

To generate text output:

1. To generate pure text output, which can be read by many different applications, set the Initial Value property of the MODE system parameter to **Character** (see Section 4.11.1, "Using a pre-defined system parameter").

   **Note:** If MODE is set to **Bitmap** (the default), the result is PostScript output, which can be read and rendered only by PostScript-compatible applications (such as a PostScript printer).

2. In the Object Navigator, select or open the report, then click the Run Paper Layout button in the toolbar to run the report.

3. To preview your report output in a text viewer, choose **File > Preview Format > Text**.

4. To save your report output as a text file, choose **File > Generate to File > Text**.

5. In the Save dialog box, specify a location and file name. Click **Save**.

See also
Section 2.8.14, "About text output"

4.7.10 Generating delimited output

You can generate a report to delimited output using either of the following methods:

- From Oracle Reports Builder
- From the command line

To generate delimited output from Oracle Reports Builder:
1. In the Object Navigator, select or open the report, then click the Run Paper Layout button in the toolbar to run the report.

2. To preview your delimited report output in a spreadsheet, choose File > Preview Format > Delimited or File > Preview Format > DelimitedData (for large volume reports).

3. To save your delimited report output to a file, choose File > Generate to File > Delimited or File > Generate to File > DelimitedData (for large volume reports).

4. In the Delimited Output dialog box or DelimitedData Output dialog box, choose from the list or type the delimiter that will separate the cells in your report output.

5. If you want to use formatting options, choose from the list or type a Date Format Mask or a Number Format Mask.

6. If you want to use a cell wrapper, choose from the list or type the cell wrapper that will be placed around the cell data in your report output.

7. Click OK.

8. In the Save dialog box, specify a location and file name. Click Save.

To generate delimited output from the command line:

- Run a report using Reports Server clients (rwclient, rwservlet) or rwrn, with DESFORMAT=DELIMITED or DELIMITEDDATA.

**Note:** To run a report through a URL, specify the Excel mimetype so that your browser opens the report output directly in Excel. For example:

```
http://hostname:port/reports/rwservlet?report=report_name +server=server_name+userid=db_connect_string+destype=cache +desformat=delimited+mimetype=application/vnd.ms-excel
```

You can open your delimited output file (.csv) to display it automatically in Microsoft Excel. Or, you can import the output file into an existing Excel worksheet.

**Usage notes**

- You can distribute a report in DelimitedData output format, specified either in a distribution XML file or in the Distribution dialog box.

**Limitations**

- When generating a report to delimited output, only data (as defined by the report Data Model), no layout information, displays in Microsoft Excel. To generate report output that preserves the layout information in Excel, see Section 2.8.13, "About Enhanced Spreadsheet output".

- Report distribution does not support Delimited output format. You cannot specify DELIMITED as an output format in a distribution XML file or in the Distribution dialog box.

- Report bursting does not support Delimited or DelimitedData output format.

**See also**

Section 2.8.12, "About delimited output"

Section 4.9.7.1, "Specifying date and time format masks"

Section 4.9.7.2, "Specifying number format masks"
4.7.11 Generating Enhanced spreadsheet output

To generate Enhanced spreadsheet output:

- On the command line, run the report using `rwrn` or Reports Server clients (`rclient`, `rwserver`), with `DESFORMAT=ENHANCEDSPREADSHEET`.

For example, to use `rwserver` to generate Microsoft Excel output from the paper layout of your report, enter a command that includes the following:

```plaintext
http://hostname:port/reports/rwserver?report=report_name
+server=server_name+userid=db_connect_string+destype=file
+desformat=enhancedspreadsheet+desname=C:\temp\myexcel_output.htm
```

---

**Notes:**

- Microsoft Office 2000/2002/2003 supports Hypertext Markup Language (HTML) as a native file format. Enhanced Spreadsheet output relies on producing HTML output, which can be understood by Excel as a file with valid Excel format.

- For reliable formatting, enclose the whole layout area in a frame. This prevents the possibility of parallel objects displaying in different vertical positions, one below the other.

---

**See also**

- Section 2.8.13, "About Enhanced Spreadsheet output"
- Chapter 29, "Building a Report for Enhanced Spreadsheet Output"

4.7.12 Distributing a report to multiple destinations

To distribute a report, you first define the distribution, then enable the distribution.

You can define the distribution for a report in any of the following ways:

- Use XML, as described in the "Creating Advanced Distributions" chapter in *Publishing Reports to the Web with Oracle Reports Services* manual.

- In the Distribution dialog box, define a distribution list for the entire report or any report section.

---

**Note:** To display the Distribution dialog box: In the report or section Property Inspector, under the **Report** node, click the Distribution property value field.

---

For an example of using section-level distribution, see Chapter 37, "Bursting and Distributing a Report". This chapter covers defining distribution of a single section to multiple destinations, using the Repeat On property and distribution XML file.

- On the command line, include the `DESTINATION` keyword to specify a DST file or XML file.

---

**Note:** The DST file method is supported for backward compatibility; the preferred and recommended method of distributing reports is with XML or the Distribution dialog box.
To enable the distribution of a report, you can do either of the following:

- Choose File > Distribute in Oracle Reports Builder.
- Specify DISTRIBUTE=YES on the command line.

You can also trace the report distribution to verify a successful distribution, as described in Section 4.14.19, "Tracing report distribution".

**Usage notes**

- In order to use the same report definition file to burst and distribute to data-driven formats such as XML and DELIMITEDDATA, as well as to layout-driven formats such as PDF and ENHANCEDSPREADSHEET, you must ensure the following requirements are met:
  - The distribution XML file must specify the include element. For example:
    ```xml
    &lt;include src="mainSection"/&gt;
    ```
  
  - The Repeat On property must be set appropriately for the section(s) specified in the distribution XML file.
  
  - The section(s) specified in the distribution XML file in the report paper layout must not be empty.

- In some cases, Microsoft Internet Explorer ignores the mimetype of a URL's return stream and instead sets the type by looking at the URL. This can be a problem when you are defining the distribution for a report because your URL might end with the DESTINATION keyword. For example:

  ```
  ...DISTRIBUTE=yes
  DESTINATION=c:\oracle\reports\distribution\mydist.xml
  ```

  In this scenario, the URL ends with the extension xml and Internet Explorer treats the return stream as XML, when in fact it is HTML. As a result, you will receive a browser error. To work around this issue, you should never use recognized file extensions at the end of a URL. In the preceding example, you could switch the positions of the DISTRIBUTE and DESTINATION keywords in your URL.

**See also**

- Section 2.8.3, "About report distribution"
- Section 2.1.2, "About report sectioning and sections"

"Creating Advanced Distributions" chapter in *Publishing Reports to the Web with Oracle Reports Services*.

### 4.7.13 Deploying a report

To deploy a report so that end users can view it, refer to the section "Deploying Your Reports" in the chapter "Running Report Requests" in the *Publishing Reports to the Web with Oracle Reports Services*. This section describes how to deploy a report with a paper layout (that is, a REP, RDF, XML, spreadsheet, or JSP report) and how to deploy a report with a Web layout (that is, a JSP report).

### 4.7.14 Changing orientation

To change the orientation (portrait or landscape) of a report section, follow the steps for the desired output format:

- Printer output (DESTYPE=PRINTER) or RTF output (DESFORMAT=RTF)
PDF output

Printer output (DESTYPE=PRINTER) or RTF output (DESFORMAT=RTF)
The orientation of report output is based on the following order of precedence:

1. ORIENTATION command line keyword.
2. ORIENTATION system parameter.
3. Orientation property for the pertinent report section (Header, Main, or Trailer):
   Portrait or Landscape.
4. (If the Orientation property is set to Default) Width and Height properties for the
   pertinent report section:
   – If Width is greater than Height (for example, 11 x 8.5), then orientation is
     landscape.
   – If Height is greater than Width (for example, 8.5 x 11), then orientation is
     portrait.

To set the report output orientation, do one of the following:

- On the command line, specify the ORIENTATION command line keyword. This takes
  precedence over the ORIENTATION system parameter, the Orientation property, and
  the Width and Height properties. For information about the ORIENTATION
  command line keyword, see the "Command Line Keywords" appendix in
  Publishing Reports to the Web with Oracle Reports Services.

- Specify the ORIENTATION system parameter. This takes precedence over the
  Orientation property, and the Width and Height properties. To specify the
  ORIENTATION system parameter, which allows end users to modify the orientation
  at runtime:

  - Choose Tools > Parameter Form Builder to display the Parameter Form Builder.
  - Click the ORIENTATION system parameter.
  - Click OK to display the Paper Parameter Form view.
  - Double-click the Orientation value field (PF_ORIENTATION) to display the
    Property Inspector.
  - Under the Parameter node, set the Initial Value property to Portrait or
    Landscape.
  - Click the Run Paper Layout button in the toolbar.
  - From the Orientation list, change the orientation if desired.

- Set the Orientation property and/or the Width and Height properties:
  – In the Object Navigator, under the Paper Layout node, double-click the
    properties icon for the pertinent report section (Header, Main, or Trailer) to
    display the Property Inspector (by default, a report is defined in the Main
    Section).
  – In the Property Inspector, under the Section node, set the Orientation property
    to the desired value. If set to Portrait or Landscape, this value takes
    precedence over the Width and Height properties. If set to Default,
    orientation is based on the values of the Width and Height properties
    (landscape orientation if Width is greater than Height, and portrait orientation
    if Height is greater than Width).
PDF output
For PDF output, any values specified for the ORIENTATION command line keyword, ORIENTATION system parameter, and Orientation property are ignored. Orientation of the PDF output is based solely on the values of the Width and Height properties:

1. In the Object Navigator, under the Paper Layout node, double-click the properties icon for the pertinent report section (Header, Main, or Trailer) to display the Property Inspector (by default, a report is defined in the Main Section).

2. In the Property Inspector, under the Section node, set the Width and Height properties as desired (for example, 11 (or 15) width x 8.5 height for landscape, or 8.5 width x 11 (or 15) height for portrait). Make sure that you subtract the margin depths (for example, for an 8.5 x 11 page with top, bottom, left, and right margins of .25, set Width to 8 and Height to 10.5).

See also
Section 2.1.2, "About report sectioning and sections"

4.7.15 Suppressing the Parameter Form
If the report is run from another product, you may not want the Parameter Form to appear.

To suppress the Parameter Form and have the report assign a default value to DESTYPE, do either of the following:
- Create a list parameter to explicitly pass the values of DESTYPE and PARAMFORM.
- In the Preferences dialog box (Edit > Preferences), on the Runtime Settings page, clear the Parameter Form check box to specify PARAMFORM=NO.

See also
Section 1.6.5, "About the Paper Parameter Form view"
Section 1.11.1, "About the Runtime Parameter Form"
Section 1.9.4, "About Parameter Forms for Web reports"

4.7.16 Viewing report output
This section provides procedures for various ways to view report output:
- Viewing the printable area
- Displaying report output in the Paper Design view
- Displaying report output in the Previewer
- Displaying report output in your Web browser
- Displaying individual pages of HTML report output
- Scrolling and paging
- Splitting the viewing region
- Magnifying or reducing the output
4.7.16.1 Viewing the printable area
The printable area is the physical region in which your printer can print on a physical page. Most printers usually cannot print up to the edge of a page, leaving a blank “unprintable” area.

To view the printable area of your report:
2. In the Paper Layout view, click the Edit Margin button in the toolbar.
   The printable area is displayed as the area within the dotted lines in the margin area.
3. Choose View > Zoom > Zoom Out to see more.

4.7.16.2 Displaying report output in the Paper Design view
The Paper Design view is displayed whenever you run a report.

To run a report from the Object Navigator or any editor:
- Click the Run Paper Layout button or choose Program > Run Paper Layout.

To run a report from the Report Wizard:
- Click Finish.

You can also display the Paper Design view in these ways:
- Click the Paper Design View button in the toolbar.
- Choose View > Change View > Paper Design.
- In the Object Navigator, double-click the view icon next to the Paper Design node.

In the Paper Design view, manipulate the output as desired, and use any of the following features:
- scrolling and paging (see Section 4.7.16.6, "Scrolling and paging")
- splitting horizontally and vertically (see Section 4.7.16.7, "Splitting the viewing region")
- magnifying or reducing the output (see Section 4.7.16.8, "Magnifying or reducing the output")

See also
Section 4.7.17.1, "Printing a report from the Paper Design or Paper Layout view"

4.7.16.3 Displaying report output in the Previewer
To display your report output in the Previewer:
1. In the Paper Design view, choose File > Print Preview.
2. In the Previewer, use any of the following features:
   - scrolling and paging (see Section 4.7.16.6, "Scrolling and paging")
   - splitting horizontally and vertically (see Section 4.7.16.7, "Splitting the viewing region")
   - magnifying or reducing the output (see Section 4.7.16.8, "Magnifying or reducing the output")
See also
Section 1.11.2, "About the Previewer"
Section 4.7.17.2, "Printing a report from the Previewer"

4.7.16.4 Displaying report output in your Web browser
To display report output in your Web browser:

1. In the Object Navigator, select or open the report, then click the Run Paper Layout button in the toolbar to run the report.

2. In the Paper Design view, specify the scope of output you want to display:
   - To display only the current page of the report, choose File > Preview Format > Current Page.
   - To display all pages, choose File > Preview Format > All Pages.

   **Note:** If you choose to show all pages of your report output, and you have HTML page streaming enabled, the first page will display in your Web browser, and you will be able to quickly navigate to any other page in the rest of the report.

3. To preview your report output in a Web browser, choose File > Preview Format > Paginated HTML, File > Preview Format > Paginated HTMLCSS (to format with style sheet extensions), File > Preview Format > PDF, or File > Preview Format > XML (if you have an XML-supporting browser set as your default XML viewer).

4. To preview your report output with Web layout in a Web browser, choose Program > Run Web Layout to run the Web Source. If you have made changes to the Web Source view (for JSP-based Web reports), this enables you to immediately see the effect of your changes on the output.

   **Note:** If Netscape 7.0 is your default browser, and the browser does not display, set the registry key HKEY_CURRENT_USER\Software\Oracle\Toolkit\Tkbrowser to the default browser location. Ensure that the BrowserName and the BrowserPath keys reflect the correct values. For example: BrowserName=Netscape 7; BrowserPath=C:\Program Files\Netscape\Netscape\Netscp.exe.

5. To save your report output as an HTML, HTMLCSS, PDF, or XML file, choose File > Generate to File.

See also
Section 1.2.2, "About Web Reports"
Section 2.2.2, "About previewing JSP-based Web reports"
Section 2.2.11, "About style sheets"
Section 4.7.17.3, "Printing a report from your Web browser"

4.7.16.5 Displaying individual pages of HTML report output
To paginate the HTML output for a report:
1. Specify navigation controls for HTML page-streamed output using either of the following methods:
   ■ in the Report Property Inspector (see Section 4.6.10.1.12, “Adding navigation controls for HTML page-streamed output using the Property Inspector”)
   ■ using PL/SQL (see Section 4.6.10.2.11, "Adding navigation controls for HTML page-streamed output using PL/SQL")

2. Enable HTML page streaming by running your report from the command line, specifying PAGESTREAM=YES.

See also
Section 1.2.2, "About Web Reports"
Section 2.8.8.1, "About HTML page streaming"

**4.7.16.6 Scrolling and paging**
To move around pages of the report using the scroll bars and paging buttons:
   ■ Use the mouse cursor to drag the horizontal and vertical scroll bars to move around the current page.
   ■ Click the First Page, Previous Page, Next Page, and Last Page buttons in the toolbar to display the indicated pages of the report.
   ■ To display a specific page, type the page number in the **Page** field.

**4.7.16.7 Splitting the viewing region**
To create two views of the report output by splitting the display horizontally or vertically:
   ■ In the Data Model view, Paper Layout view, Paper Design view, or Paper Parameter Form view, drag the black bar **below** the vertical scroll bar (to split horizontally), or to the **right** of the horizontal scroll bar (to split vertically).
   ■ In the Previewer, drag the grey bar **above** the vertical scroll bar (to split horizontally), or to the **left** of the horizontal scroll bar (to split vertically)

You can scroll and page within each view to move the contents of that view while the other view remains unchanged.

**4.7.16.8 Magnifying or reducing the output**
To magnify a hard-to-see portion of your report:
   ■ In the Data Model view, Paper Layout view, Paper Design view, or Paper Parameter Form view, click the Magnify tool in the tool palette (or, choose View > Zoom > Zoom In).
   ■ In the Previewer, click the Zoom In button in the toolbar.

To reduce the image to get a sense of your report’s overall layout:
   ■ In the Data Model view, Paper Layout view, Paper Design view, or Paper Parameter Form view, choose View > Zoom > Zoom Out or Normal Size.
   ■ In the Previewer, click the Zoom Out button in the toolbar.
4.7.17 Printing a Report

This section provides procedures for the following tasks that you may perform to print a report:

- Printing a report from the Paper Design or Paper Layout view
- Printing a report from the Previewer
- Printing a report from your Web browser
- Printing a report on a preprinted form
- Switching the printer tray
- Printing a report on UNIX

Before printing your report from the Reports Builder, do the following:

- Configure a valid printer, and enter the value of the printer in the uiPrint.txt file which is located at:

  INSTANCE_HOME/config/FRCOMPONENT/frcommon/guicommon/tk/admin/uiPrint.txt

  OR

- From the Reports Builder menu, go to **Edit > Preferences**. Select the **Runtime Values** tab.

  From the Destination Type drop-down list, select **Printer** and provide a valid value for printer name, and click **OK**.

  For more information, see "Configuring the Printing Environment" in the **Publishing Reports to the Web with Oracle Reports Services** manual.

4.7.17.1 Printing a report from the Paper Design or Paper Layout view

To print a report from the Paper Design or Paper Layout view:

1. In the Paper Design view or Paper Layout view choose **File > Print**.
2. In the Print dialog box, type the number of pages and copies you want to print.
3. Click **OK**.

See also

Section 4.7.16.2, "Displaying report output in the Paper Design view"

4.7.17.2 Printing a report from the Previewer

To print a report from the Previewer:

1. In the Previewer, click the Page Setup button in the toolbar to verify your printer setup.
2. Click the Print button in the toolbar.
3. In the Print dialog box, specify the pages and copies you want to print.

   If the report has a Destination Type of **Screen** (set by system parameter **DESTYPE**), a warning displays to run the report with a Destination Type of **Preview** before printing. **Preview** creates PostScript output, which is typically more desirable for printing bit-mapped reports.
4. Click **OK**.
Run and Dispatch a Report

See also
Section 4.7.16.3, "Displaying report output in the Previewer"

4.7.17.3 Printing a report from your Web browser

To print a report from your Web browser:

1. If your report is formatted with HTML style sheet extensions (HTMLCSS), set up your browser to print the HTML document in the same way the report is paginated:
   a. In your browser, choose File > Page Setup and modify the margin settings as desired.
   b. In the Object Navigator, under the Paper Layout node, double-click the Header Section, Main Section, or Trailer Section properties icon for the pertinent report section (Header, Main, or Trailer) to display the Property Inspector (by default, a report is defined in the Main Section).
   c. In the Property Inspector, under the Section node, set the Width and Height properties as desired (for example, 11 (or 15) width x 8.5 height for landscape or 8.5 width x 11 (or 15) height for portrait). Make sure that you subtract the margin depths (for example, for an 8.5 x 11 page with top, bottom, left, and right margins of .25, set Width to 8 and Height to 10.5).

2. Display your report output in your Web browser (see Section 4.7.16.4, "Displaying report output in your Web browser").

3. Choose File > Print.

See also
Section 1.2.2, "About Web Reports"
Section 2.2.2, "About previewing JSP-based Web reports"
Section 2.2.11, "About style sheets"

4.7.17.4 Printing a report on a preprinted form
See the example report in Chapter 32, "Building a Report Using a Preprinted Form".

4.7.17.5 Switching the printer tray
To switch the printer tray:

1. Choose File > Page Setup and in the Source list, note the names of the printer trays defined for your printer.

2. Use SRW.SET_PRINTER_TRAY to define the desired trigger:
   a. To change the printer tray before the report begins formatting, create a Before Report trigger (see Section 4.13.3.5, "Creating a report trigger").
To change the printer tray between pages of the report, create a Between Pages trigger (see Section 4.13.3.5, "Creating a report trigger").

To change the printer tray for a specific page on which a particular object prints, create a format trigger for that object (see Section 4.13.4.1, "Creating or editing a format trigger").

See also
Section 2.8.6, "About switching the printer tray"

4.7.17.6 Printing a report on UNIX

Printing on UNIX requires some setup and configuration to create the proper printing environment. For detailed information about printing your reports on UNIX, refer to the "Printing on UNIX with Oracle Reports" chapter in Publishing Reports to the Web with Oracle Reports Services.

Oracle Reports 10g (9.0.4) introduced the following enhancements for printing reports on UNIX:

- The REPORTS_DEFAULT_DISPLAY environment variable, which provides for the removal of dependency on the DISPLAY environment variable. Prior releases of Oracle Reports required the DISPLAY environment variable to be set to run and print reports on UNIX.

- The PostScript printer driver screenprinter.ppd, which eliminates the dependency on having a valid printer defined (PRINTER and TK_PRINTER environment variables set to a valid printer, or a valid entry in uiprint.txt) for Reports Runtime on UNIX. This driver provides surface resolution for images and specifies font information. Prior releases of Oracle Reports required a printer to resolve fonts to run and print reports on UNIX.

This driver is the first entry in uiscreenprint.txt. The file locations (UNIX only) are:

uiscreenprint.txt: $DOMAIN_HOME/config/fmwconfig/components/ReportsToolsComponent/<reports_tools_name>/guicommon/tk/admin
screenprinter.ppd: $DOMAIN_HOME/config/fmwconfig/components/ReportsToolsComponent/<reports_tools_name>/guicommon/tk/admin/PPD

Limitations
- If your report includes an Oracle Graphics 6i graph, a printer is required to generate the graph. However, TK_PRINT_STATUS=echo is set in g90runm.sh. Thus, to run a report with an Oracle Graphics 6i graph without a valid printer, set the PRINTER environment variable to any value.
E-mailing a report

To e-mail a report from Oracle Reports Builder:

1. Log on to your Internet Standard Protocol SMTP mail application.
2. Select or open the report.
3. If you are not already connected, connect to a database.
5. In the Mail dialog box, specify the recipients and subject line for your e-mail report.
6. Click OK.

To e-mail a report in batch mode:

1. Log on to your Internet Standard Protocol SMTP mail application.
2. Run the report from the command line, specifying DESTYPE=MAIL, and DESNAME=recipient1, recipient2, recipient3,....

Usage notes

The configuration file `{DOMAIN_HOME}/config/fmwconfig/components/ReportsToolsComponent/<reports_tools_name>/rwbuilder.conf` must include the plug-in parameter mailServer. For example:

```xml
<pluginParam name="mailServer" value="stbeehive.oracle.com">
<property name="enableSSL" value="yes"/>
</pluginParam>
```

With the outgoing mail server name. This applies in both the Windows and Solaris environments.

4.8 Work with the Data Model

This section provides procedures for the following tasks that you may perform as you work with the data model of your report:

- Creating a query
- Modifying a query
- Using Query Builder
- Selecting HTML tags from the database
- Selecting an image from the database
- Selecting an image URL from the database
- Creating a break group
- Creating a matrix (cross-product) group
4.8.1 Creating a query

To create a query, you can use any of the following tools:

- Report Wizard (single-query reports only)
- Data Wizard
- SQL Query tool (to create a query that selects data from an Oracle relational database)
- XML Query tool (to access an XML data file, if you have the DTD file)
- JDBC Query tool (to access any JDBC-enabled data source)
- Text Query tool (to create a query that selects data from a text pluggable data source)
- REF CURSOR Query tool (to use REF CURSORS)

See also
Section 1.7.1, "About queries"
Section 1.7.3, "About database columns"

4.8.1.1 Creating a query: Report Wizard

To create a query using the Report Wizard:

- On the Data page of the Report Wizard, enter the query statements for the type of data source previously selected. For example, if you selected the SQL Query data source, you can enter your SQL query in any of the following ways:
  - Type the `SELECT` statement in the **Data Source definition** field.
  - Click **Query Builder** for a graphical method of creating a query without a knowledge of SQL.
  - Click **Import Query** to use a query that has been written by someone else or to use the text editor of your choice.

4.8.1.2 Creating a query: Data Wizard

To create a query using the Data Wizard:

1. In the Data Model view, choose **Insert > Query** to display the Data Wizard.
2. Follow the wizard to create the first query for the data model.
3. Repeat Steps 1 and 2 for each query you want to create.
4. Modify the resulting data model in the Data Model view.
5. To re-enter the Data Wizard, do either of the following:
   - Right-click, and choose **Data Wizard**.
   - Click the query, then choose **Edit > Settings**.
4.8.1.3 Creating a query: SQL Query tool
To create a SQL query:

1. In the Data Model view, click the SQL Query tool in the tool palette then click in an open area of the Data Model view to display the SQL Query Statement dialog box.

2. In the SQL Query Statement field, define a SELECT statement for the query in any of the following ways:
   - To use Query Builder for an easy graphical method of creating a query without a knowledge of SQL, click Query Builder.
   - To import a query from a file, click Import Query.
   - To enter the SELECT statement yourself, type it in the SQL Query Statement field.

3. Click OK.

4. Refine the query using either of the following methods:
   - Right-click the query object, then choose Property Inspector to set desired properties.
   - Right-click the query object, then choose Data Wizard to specify which fields to display, group fields, and any totals.

5. Repeat Steps 1 through 5 for each query you want to create.

Note: The Data Wizard does not support creating links between queries. To define parent/child query relationships, you can create a data link manually.

4.8.1.4 Creating a query: XML Query tool
To create an XML query:

1. In the Data Model view, single-click the XML Query tool in the tool palette.

2. Click in the main area (canvas region) of the window.

3. In the Define XML Query dialog box, define the XML query based on the fields defined in the data definition file (DTD) selected. The query is run against the data in the XML data file. If an XSL file is specified, it translates the XML data file before running the query.

4. Click OK.

Note: If you define multiple queries in the Data Model view of your report, the Data page does not appear when you invoke the Report Wizard to default the layout.

4.8.1.5 Creating a query: JDBC Query tool
To create a JDBC query:

Note: The Data Wizard does not support creating links between queries. To define parent/child query relationships, you can create a data link manually.
1. In the Data Model view, single-click the JDBC Query tool in the tool palette.
2. Click in the main area (canvas region) of the window.
3. In the JDBC Query dialog box, define the JDBC query or procedure and the connection parameters for the data source. Click Help for assistance.
4. Click OK.

4.8.1.6 Creating a query: Text Query tool
To create a Text query:
1. In the Data Model view, single-click the Text Query tool in the tool palette.
2. Click in the main area (canvas region) of the window.
3. In the Define Text Query dialog box, specify the data definition and data source for the text query. Click Help for assistance.
4. Click OK.

4.8.1.7 Creating a query: REF CURSOR Query tool
To create a REF CURSOR query:
1. Create a package that defines a REF CURSOR type in one of the following ways:
   - Create a local program unit (see Section 4.13.3.1, "Creating a local program unit")
   - Create an external PL/SQL library (see Section 4.13.5.1, "Creating an external PL/SQL library")
   - Create a stored program unit (see Section 4.13.3.2, "Creating a stored program unit")
2. If the package created in Step 1 is an external PL/SQL library, you must attach it to the report before referencing it.
3. In the Data Model view, single-click the REF CURSOR Query tool in the tool palette.
4. Click in the main area (canvas region) of the window.
5. In the PL/SQL Editor, type the PL/SQL for a function that opens a cursor and returns a cursor variable of the REF CURSOR type you defined in the package. For example:

```plsql```
empCur rcPackage.empCurType;
BEGIN
  OPEN empCur FOR SELECT * FROM emp;
  RETURN empCur;
END;
```

/* Note, rcPackage is a local program unit defined as: */
PACKAGE rcPackage IS
  TYPE empCurType IS REF CURSOR RETURN emp%ROWTYPE;
END;
```

**Note:** Oracle Reports supports both static and dynamic REF CURSORS. For more information, see Section 2.6.10, "About REF CURSOR queries".
6. Refine the query as desired:
   ■ Click the REF CURSOR query object, then choose Tools > Property Inspector to modify properties.
   ■ Click the query object, then choose Tools > Data Wizard to specify which fields to display, group fields, and any totals.
7. Repeat Steps 1 through 6 for each REF CURSOR query you want to create.

See also
Section 2.6.10, "About REF CURSOR queries"

4.8.2 Modifying a query
To modify a SQL query statement or the columns displayed in your report:
1. In the Data Model view, click the query object, then right-click and choose Data Wizard.
2. To change the SELECT statement, click the Data tab.
3. To change the break groups, click the Groups tab.
4. To add or change summary columns for totals, click the Totals tab.
5. To change which selected database columns are displayed in your report, choose Tools > Report Wizard, then click the Fields tab.

To modify the properties of a query:
1. In the Data Model view, click the query object, then right-click and choose Property Inspector.
2. In the Property Inspector, modify the properties as desired.

4.8.3 Using Query Builder
You can use Query Builder to define almost any query that you would build using a SQL SELECT statement. Query Builder automatically generates the appropriate SELECT FROM [table.column] clause based on columns displayed in the Query Builder workspace.

See the How To section of the Oracle Reports online Help for topics about using Query Builder.

See also
Section 1.7.5, "About Query Builder"

4.8.4 Selecting HTML tags from the database

Note: This procedure applies to paper-based reports.

To select HTML tags from the database:
1. Create a query, with a SELECT statement that selects a column containing HTML tags or the names of files that contain HTML tags.
2. In the Data Model view, double-click the HTML tags column to display the Property Inspector.
3. If the column contains the names of files that contain the HTML tags, rather than the HTML tags themselves:
   - Under the **Column** node, set the Read from File property to Yes.
   - Set the File Format property to Text.

4. In the Paper Layout view, create a field object that references the column.

5. Double-click the field object to display the Property Inspector.

6. In the Property Inspector, under the **Web Settings** node, set the Contains HTML Tags property to Yes.

**Usage notes**

When the text object’s Contains HTML Tags property is set to Yes, HTML tags and attributes are formatted in your report output as follows:

- If the report is generated to HTML or HTMLCSS output, all HTML tags and attributes are interpreted and formatted in the output.
- If the report is generated to other bitmap output formats (for example, PDF, RTF, PostScript), a fixed set of HTML tags and attributes are interpreted and formatted in the output, as described in Section 2.8.9, "About HTML formatting". Any HTML not in the supported set of tags and attributes are not interpreted, and appear as is in the report output.

**4.8.5 Selecting an image from the database**

**Note:** These steps, and the steps in Section 4.9.8.1.2, "Linking an image object to a file" (for paper-based reports only), allow you to include images in a wide variety of formats supported by Oracle Reports, including JPEG (all types, such as Progressive JPEG and Exif JPEG), PNG, BMP, TIFF, GIF, and CGM. For paper-based reports, you can also use Insert > Image to import an image from a file into the report layout for images in the following formats: TIFF, JFIF, BMP, TGA, PCX, PICT, GIF, CALS, RAS, OIF, PCD (see Section 4.9.8.1.1, "Importing an image").

To select an image from the database:

1. Create a query that selects a column containing images or the filenames of image objects.

2. In the Data Model view, double-click the image column to display the Property Inspector.

3. If the column contains the **filenames** of image objects, rather than the images themselves:
   - Under the **Column** node, set the Read from File property to Yes.

4. In both cases (a column containing images or a column containing the filenames of image objects): under the **Column** node, set the File Format property to Image.

5. If you are developing a JSP-based Web report, you will also need to add the `containsHtml` attribute to the `<rw:field>` JSP tag for the column, as follows:
   - Display the Web Source view for the report.
- Search for the `rw:field` tag for the column (`<rw:field ... src="column_name" ...>`)  
  - Add the `containsHtml=yes` attribute to specify that the field's value contains an image.  
    - For example:  
      ```html  
      <rw:field id="F_MYIMAGE" src="MYIMAGE" nullValue="&nbsp;"  
      containsHtml="yes"  
      ```

6. To preview your report output with Web layout in a Web browser, choose Program > Run Web Layout to run the Web Source. If you have made changes to the Web Source view (for JSP-based Web reports), this enables you to immediately see the effect of your changes on the output.

**See also**

Section 2.4.3, "About images"

Section 1.7.3, "About database columns"

### 4.8.6 Selecting an image URL from the database

---

**Notes:** This procedure is for HTML output only.

These steps, and the steps in Section 4.9.8.1.3, "Linking an image object to a URL" (for paper-based reports only), allow you to include images in a wide variety of formats supported by Oracle Reports, including JPEG (all types, such as Progressive JPEG and Exif JPEG), PNG, BMP, TIFF, GIF, and CGM. For paper-based reports, you can also use Insert > Image to import an image from a file into the report layout for images in the following formats: TIFF, JFIF, BMP, TGA, PCX, PICT, GIF, CALS, RAS, OIF, PCD (see Section 4.9.8.1.1, "Importing an image").

---

To select a URL from the database that point to an image to include in an HTML report:

1. Create a query, with a `SELECT` statement that selects a column containing URLs.
2. In the Data Model view, double-click the column containing the URLs to display the Property Inspector.
3. Under the **Column** node:
   - Set the Read from File property to Yes.
   - Set the File Format property to Image URL.
4. If you are developing a JSP-based Web report, you will also need to add the `containsHtml` attribute to the `<rw:field>` JSP tag for the column, as follows:
   - Display the Web Source view for the report.
   - Search for the `rw:field` tag for the column (`<rw:field ... src="column_name" ...>`)  
     - Add the `containsHtml=yes` attribute to specify that the field’s value contains an image.  
       - For example:
5. To preview your report output with Web layout in a Web browser, choose **Program > Run Web Layout** to run the Web Source. If you have made changes to the Web Source view (for JSP-based Web reports), this enables you to immediately see the effect of your changes on the output.

**See also**
Section 2.4.3, "About images"
Section 2.8.8, "About HTML and HTMLCSS output"

### 4.8.7 Creating a break group

You can define break groups in the Report Wizard or create them manually.

To create a break group manually:

1. In the Data Model view, drag the group that contains the column at which you want to break your report down from the query object about 2 inches (5 centimeters).

2. Select the column that you want to use to divide your report (for example, if you want to group a list of employee data by department number, select the department number column) and drag it out of and above the group to create a new group. This is the **break column**.

3. Double-click the new group object to display its Property Inspector, where you can set properties for the break group.

**See also**
Section 1.7.2, "About groups"
Section 1.3.2, "About group above reports"
Section 1.3.3, "About group left reports"

### 4.8.8 Creating a matrix (cross-product) group

You can define matrix groups in the Data Wizard or create them manually. To create a matrix (cross-product) group using the Data Wizard:

1. In the Data Model view, right-click and choose **Data Wizard**.

2. On the **Query** page, select the **Matrix query** check box.

3. Follow the wizard to select the columns for the matrix group(s), rows, columns, and cells.

   To create a matrix (cross-product) group manually:

4. In the Data Model view, drag the title bar of the group object down.

5. Drag the "row" column and "column" column out of the group object into the space to create two new groups.


7. Drag a box around the groups you want to include in the matrix (cross-product) group.
8. If the cell group is a separate query from the matrix (cross-product) groups, create the appropriate links between the columns in the matrix groups and the cell group.

See also
Section 2.3.7, "About matrix objects"
Section 1.3.7, "About matrix reports"
Section 2.1.7, "About nested matrix reports"
Section 2.1.8, "About matrix with group reports"
Section 1.7.2, "About groups"
Section 4.9.1.3, "Creating a matrix object"
Section 4.5.3, "Creating a nested matrix report"
Section 1.7.2, "About groups"
Section 1.3.2, "About group above reports"
Section 1.3.3, "About group left reports"

4.8.9 Creating a data link

To create a data link:

1. In the Data Model view, single-click the Data Link tool in the tool palette. A link is always drawn from the parent group to the child query.

2. Create the link:

   Create a Group to Group Link: To create a link between one query’s group and another query’s group, which is useful when you want the child query to know about the parent’s data, click the parent group (avoiding the columns in the group) and drag a link to the child group.

   Create a Column to Column Link: To create a link between columns, click a column of the parent query and drag a link to a column of the child query.

3. Double-click the new link object to display the Property Inspector, and set the desired properties.

See also
Section 1.7.4, "About data links"
Section 2.3.5, "About non-linkable queries"

4.8.10 Creating or editing a formula column

To create or edit a formula column:

1. In the Data Model view, single-click the Formula Column in the tool palette, then:
   - To create a column within a group, click in the group at the position you want the column placed in the hierarchy.
   - To create a report-level column, click in an open area of the canvas region.

2. Double-click the formula column object to display the Property Inspector.

3. Under the Placeholder/Formula node, double click the PL/SQL Formula property field.

4. In the PL/SQL Editor, define the PL/SQL for the formula for example SAL * 0.07.
Example: Referencing a PL/SQL function in formulas

Suppose that you have a report with the following groups and columns:

<table>
<thead>
<tr>
<th>Groups</th>
<th>Columns</th>
<th>Summary</th>
</tr>
</thead>
<tbody>
<tr>
<td>RGN</td>
<td>REGION</td>
<td></td>
</tr>
<tr>
<td></td>
<td>RGNSUMSAL</td>
<td>SUM(DEPTSUMSAL)</td>
</tr>
<tr>
<td></td>
<td>COSTOFLIVING</td>
<td></td>
</tr>
<tr>
<td>DEPT</td>
<td>DNAME</td>
<td></td>
</tr>
<tr>
<td></td>
<td>DEPTNO</td>
<td>SUM(EMP.SAL)</td>
</tr>
<tr>
<td>JOB</td>
<td>JOB</td>
<td></td>
</tr>
<tr>
<td></td>
<td>HEADCOUNT</td>
<td>COUNT(EMP.EMPNO)</td>
</tr>
<tr>
<td>EMP</td>
<td>ENAME</td>
<td></td>
</tr>
<tr>
<td></td>
<td>EMPNO</td>
<td></td>
</tr>
<tr>
<td></td>
<td>SAL</td>
<td></td>
</tr>
<tr>
<td></td>
<td>COMM</td>
<td></td>
</tr>
</tbody>
</table>

Given these groups and columns, you might create multiple formulas that apply the cost of living factor (COSTOFLIVING) to salaries. To avoid duplication of effort, you could create the following PL/SQL function and reference it from the formulas:

```sql
function CompSal(salary number) return number is
begin
  return (salary * CostofLiving);
end;
```

Following are some examples of how you might reference the PL/SQL function in formulas:

- `CompSal(:RGNSUMSAL)`
- `CompSal(:SAL) + COMM`

See also

Section 2.3.2, "About formula columns"

4.8.11 Creating a summary column

To create a summary column (for totals or subtotals) using the Data Wizard:

1. In the Data Model view, click the query that contains the column you want to total.
2. Choose Tools > Data Wizard.
3. On the Totals page, follow the wizard to add the desired summary to your report.
To create a summary column (for totals or subtotals) using the tool palette:

1. In the Data Model view, single-click the Summary Column tool in the tool palette, then:
   - To create a column within a group, click in the group at the position you want the column placed in the hierarchy.
   - To create a report-level column, click in an open area of the canvas region.

2. Double-click the new summary column object to display the Property Inspector.

3. Under the Summary node:
   - Set the Function property by choosing the type of summary you want from the list.
   - Set the Source property to the column you want to summarize.
   - Set the Reset At property to the group at which the summary column value resets.

Usage notes
For JSP-based Web reports with a Group Above or Matrix style, if any summary column values are not correctly left-aligned when you click the Run Web Layout button in the toolbar (or choose Program > Run Web Layout), you can implement the following workaround to align the values:

- In the Web Source view, locate the section where the summary column is defined, and delete the following line to remove the extra space:

  `<th class="summary_column_name"> </th>`

See also
Section 2.3.1, "About summary columns"
Chapter 9, "Building a Summary Report"
Chapter 13, "Building a Group Left Summary Report"

4.8.12 Creating or editing a placeholder column

To create or edit a placeholder column:

1. In the Data Model view, single-click the Placeholder Column tool in the tool palette.
   - To create a column within a group, click in the group at the position you want the column placed in the hierarchy.
   - To create a report-level column, click in an open area of the canvas region.

Note: For group reports, the Report Wizard and Data Wizard create \( n \) summary fields in the data model for each summary column you define: one at each group level above the column being summarized, and one at the report level. For example, if a report is grouped by division, and further grouped by department, then a summary column defined for a salary total would create fields for the sum of salaries for each division and each department group (group-level summaries), and the sum of all salaries (report-level summary).
2. Double-click the placeholder column object.

3. In the Property Inspector, set the desired properties for the placeholder column.

4. Set the value of a placeholder column in:
   - the Before Report trigger, if the placeholder is a report-level column
   - a report-level formula column, if the placeholder is a report-level column
   - a formula in the placeholder’s group or a group below it (the value is set once for each record of the group)

See also
Section 2.3.2, "About formula columns"

4.9 Work with the Report Layout

This section provides procedures for creating and modifying objects in your report layout. The procedures are grouped into the following sections:

- General Layout Objects
- Text Objects
- Page Numbers or Date/Time Stamps
- Borders
- Anchors
- Colors, Patterns, and Highlighting
- Format Masks
- Graphic or Image Objects
- Page or Group Headers or Footers
- Margin, Header Page, or Trailer Page Objects
- Move Objects
- Resize Objects
- Change Spacing
- Modify the Page Layout

4.9.1 General Layout Objects

This section provides procedures for the following tasks that you may perform as you work with container objects:

- Creating a field object
- Creating a frame or repeating frame
- Creating a matrix object
- Creating a barcode using a barcode font
- Applying conditional formatting to a layout object

4.9.1.1 Creating a field object

To create a field object manually in the report layout:
1. In the Paper Design view, Paper Layout view, or Paper Parameter Form view, click the Field tool in the tool palette.

2. Click and drag a rectangle.

3. Double-click the new field object.

4. In the Property Inspector, under the Field node, set the Source property to the column or parameter that will provide the value for the field.

5. Set other properties as desired.

See also
Section 1.8.4, "About fields"
Section 1.9.2, "About Parameter Form fields"

### 4.9.1.2 Creating a frame or repeating frame

To create a frame or repeating frame manually:

1. In the Paper Layout view, click the Frame tool or the Repeating Frame tool in the tool palette.

2. Click and drag a rectangle.

3. Double-click the new frame object.

4. In the Property Inspector, set the desired properties.

See also
Section 1.8.1, "About frames"
Section 1.8.2, "About repeating frames"
Section 1.8.3, "About frame and repeating frame sizing"

### 4.9.1.3 Creating a matrix object

Note: This procedure provides steps to create a matrix object manually. The recommended method for creating a matrix object is to use the Report Block Wizard (choose Insert > Report Block in the Paper Layout view).

To create a matrix object:

1. In the Paper Layout view, click the Repeating Frame tool in the tool palette, then drag a rectangle to create a repeating frame.

2. In the Property Inspector, under Repeating Frame, set the Source property to the "column" for the matrix, and set the Print Direction property to Down.

3. Click the Repeating Frame tool in the tool palette again, then drag a rectangle to create a second repeating frame, intersecting the first repeating frame.
4. In the Property Inspector, under **Repeating Frame**, set the Source property to the "row" for the matrix, and set the Print Direction property to **Across**.

5. Drag a rectangle around both repeating frames to select them, then choose **Insert > Layout Matrix**.
   
   This creates a matrix object that is the intersection of the two repeating frames. For example:

   **Figure 4–1  Example matrix object**

   ![Example matrix object](image)

6. Double-click the matrix object to set its properties.

**See also**

- Section 2.3.7, "About matrix objects"
- Section 1.3.7, "About matrix reports"
- Section 2.1.7, "About nested matrix reports"
- Section 2.1.8, "About matrix with group reports"
- Section 4.8.8, "Creating a matrix (cross-product) group"
- Section 4.5.3, "Creating a nested matrix report"

### 4.9.1.4 Creating a barcode using a barcode font

**Note:** Beginning with Oracle9i Reports, Release 2 (9.0.2), you can use a barcode JavaBean that automatically generates the barcode for you. See the example report in Chapter 43, "Building a Report with a Barcode".

To create a barcode using a barcode font:

1. Install a barcode font on your machine (for example, on Windows, install the barcode font in the Windows Control Panel **Font**). Barcode fonts are available from most computer stores.

   **Note:** For portability between platforms, you can use a PostScript barcode font to allow you to print your report to any PostScript-enabled output device.

2. Create a query that selects a column from the database containing the numbers for the barcodes you want included in your report.
3. In the Paper Layout view, click the barcode field, and choose **Format > Font** to apply the barcode font to the field.

### 4.9.1.5 Applying conditional formatting to a layout object

To apply conditional formatting to a layout object:

1. Click the object, then choose **Format > Conditional Formatting**.

    **Tip:** To select multiple objects, click one object, then Shift-click all other objects. To select all objects, choose **Edit > Select All**.

2. In the Conditional Formatting dialog box, click **New** to display the Format Exception dialog box.

3. Specify the conditions and formatting attributes to be applied when the condition(s) evaluate to TRUE.

4. Click **OK**.

#### Usage notes

- For more complex conditional formatting, you can define conditions against an object using a PL/SQL format trigger in the PL/SQL Editor.

#### See also

- Section 2.1.6, "About conditional formatting"
- Chapter 4.9.6.7, "Highlighting a value"
- Chapter 4.9.6.8, "Highlighting a row"

### 4.9.2 Text Objects

This section provides procedures for the following tasks that you may perform as you work with text objects:

- Creating a boilerplate object for text
- Creating a boilerplate object for text that displays every other page
- Creating a boilerplate text object for HTML tags
- Editing text
- Referencing a field in boilerplate text
- Linking a boilerplate text object to a file
- Linking an HTML text object to a file
- Wrapping text in a field
- Changing text attributes

#### 4.9.2.1 Creating a boilerplate object for text

To create a boilerplate object for text:

1. In the Paper Design view, Paper Layout view or Paper Parameter Form view, click the Text tool in the tool palette.

2. Click and drag a rectangle.
3. In the new boilerplate object, type the desired text.
   The text you type is composed of paragraphs which are separated by new lines.
   Text within a paragraph is word-wrapped inside the boilerplate object’s horizontal size.

4. Click outside the boilerplate text object.

See also
Section 1.8.5, "About boilerplate objects"

4.9.2.2 Creating a boilerplate object for text that displays every other page
To create a boilerplate object for text that displays every other page:

1. Create a boilerplate text object where you want it to appear on the page, either in
   the margin, or in a repeating frame (expand the repeating frame to make room for
   the boilerplate text, below the fields in the repeating frame).

2. Double-click the boilerplate text object to display the Property Inspector. Under
   the Advanced Layout node, set the Format Trigger property by typing the
   following code in the PL/SQL Editor:

   ```plsql
   function XXX_HDRFormatTrigger return boolean is page_num number;
   begin
     srw.get_page_num(page_num);
     if mod(page_num, 2) = 0 then
       return(false);
     else
       return (true);
     end if;
   end;
   ```

3. Run the report to see the boilerplate text appear every other page.

See also
Section 1.8.5, "About boilerplate objects"

4.9.2.3 Creating a boilerplate text object for HTML tags

To create a boilerplate text object for HTML tags:

1. In the Paper Design view, click the Text tool in the tool palette.

2. Click and drag a rectangle.

3. In the new boilerplate object, type the desired HTML.

4. Click outside the boilerplate text object.

5. Double-click the boilerplate text object (or right-click the object, and choose
   Property Inspector).

6. In the Property Inspector, under the Web Settings node, set the Contains HTML
   Tags property to Yes.

Note: This procedure applies to paper-based reports.
**Usage notes**

When the text object's Contains HTML Tags property is set to Yes, HTML tags and attributes are formatted in your report output as follows:

- If the report is generated to HTML or HTMLCSS output, all HTML tags and attributes are interpreted and formatted in the output.
- If the report is generated to other bitmap output formats (for example, PDF, RTF, PostScript), a fixed set of HTML tags and attributes are interpreted and formatted in the output, as described in Section 2.8.9, "About HTML formatting". Any HTML not in the supported set of tags and attributes are not interpreted, and appear as is in the report output.

**Example 1: Turning formatting on and off**

Consider a text boilerplate object that is defined as follows:

```html
<i><b>Design time format</b> is merged with <span style="font-family:Arial; color:#00F">run time formatting instructions.</span></i>
```

With its Contains HTML Tags property set to Yes, this will format as:

Design time format is merged with run time formatting instructions.

With its Contains HTML Tags property set to No, this will format in the report output as:

```html
<i><b>Design time format</b> is merged with <span style="font-family:Arial; color:#00F">run time formatting instructions.</span></i>
```

**Example 2: Boilerplate text object tagged as a hyperlink**

In a boilerplate text object, you can type the following text:

```html
<a href=http://your_webserver/reports/my_report.html><img src=oracle.gif> </a>
```

With the Contains HTML tags property set to Yes, this object will appear in HTML/HTMLCSS report output as a graphic (oracle.gif), which the end user can click to link to my_report.html.

**Example 3: Parameter values output to HTML**

In a boilerplate text object, you can type the following Java Applet, called NervousText.class, which takes the object width and height as parameters:

```html
<base href=http://cagney.uk.oracle.com/java/NervousText/>
<applet code="NervousText.class" width=&ObjectWidth height=&ObjectHeight>
<param name=text value="&deptno">
</applet>
```

With the Contains HTML tags property set to Yes, this object will be interpreted with the parameters replaced with their actual values, as follows:

```html
<base href=http://cagney.uk.oracle.com/java/NervousText/>
<applet code="NervousText.class" width=84 height=72>
<param name=text value="10">
</applet>
```

**See also**

- Section 1.8.5, "About boilerplate objects"
- Section 2.5.1, "About Parameter Form HTML extensions"
4.9.2.4 Editing text
To insert and replace text:

1. In the Paper Design view, Paper Layout view, or Paper Parameter Form view, single-click the text object.
2. Click the text to change to edit mode.
3. Modify the text as desired, then click outside the text object.

To delete text:

1. In the Paper Design view, Paper Layout view, or Paper Parameter Form view, single-click the text object.
2. To cut all the text, choose Edit > Delete.

To cut, copy, or paste text:

1. In the Paper Layout view or Parameter Form view, single-click the text object.
2. Click and drag to mark the text you want to cut or copy, then choose Edit > Cut or Edit > Copy.
3. To paste text, choose Edit > Paste.

4.9.2.5 Referencing a field in boilerplate text
To reference a field in boilerplate text:

1. In the Paper Design view or Paper Layout view, click in the boilerplate text where you want the reference to a field to appear.
2. Type an ampersand (&) followed by the name of the field.

   If you want to place the field reference in front of other text with no spaces in between, enclose the field name in angle brackets to separate it from the text (for example, &<fieldname>Oracle). If the field reference follows other text, no angle brackets are needed (for example, Oracle&fieldname). You can include field references right next to each other with no spaces in between and without angle brackets (for example, &field1&field2&field3).

Usage notes

- A reference to a field includes the field’s properties. Therefore, if the Horizontal Elasticity property is set to Fixed, any extra spaces in the field will appear in the report output. For example, $&<f_sal>/week may produce $800/week in the report output.

- In addition to referencing fields in a boilerplate text object, you can directly reference a database column (for example, &SAL). For example, $&<SAL>/week may produce $800/week in the report output.

See also

Section 1.8.4, "About fields"
Section 1.8.5, "About boilerplate objects"

4.9.2.6 Linking a boilerplate text object to a file

Note: This procedure applies paper-based reports. File Link objects are not implemented in JSP-based Web reports.
To link a boilerplate text object to a file:

1. In the Paper Design view or Paper Layout view, click the File Link tool in the tool palette.
2. Click and drag a rectangle.
3. Double-click the file link object to display the Property Inspector.
4. Under the **File Link Boilerplate** node:
   - Set the Source File Format property to Text.
   - Set the Source Filename property to the name of the file containing the text.

**See also**

Section 1.8.5, "About boilerplate objects"

### 4.9.2.7 Linking an HTML text object to a file

**Note:** This procedure applies to paper-based reports. File Link objects are not implemented in JSP-based Web reports.

To link an HTML object to a file:

1. In the Paper Design view or Paper Layout view, click the File Link tool in the tool palette.
2. Click and drag a rectangle.
3. Double-click the file link object to display the Property Inspector.
4. Under the **File Link Boilerplate** node:
   - set the Source File Format property to Text.
   - set the Source Filename property to the name of the file containing the HTML tags.
5. Under the **Web Settings** node, set the Contains HTML Tags property to Yes.

**Usage notes**

When the text object’s Contains HTML Tags property is set to Yes, HTML tags and attributes are formatted in your report output as follows:

- If the report is generated to HTML or HTMLCSS output, *all* HTML tags and attributes are interpreted and formatted in the output.
- If the report is generated to other bitmap output formats (for example, PDF, RTF, PostScript), a fixed set of HTML tags and attributes are interpreted and formatted in the output, as described in Section 2.8.9, "About HTML formatting". Any HTML not in the supported set of tags and attributes are not interpreted, and appear as is in the report output.

**See also**

Section 1.8.5, "About boilerplate objects"

### 4.9.2.8 Wrapping text in a field

To wrap text in a field:

---

4-66  Publishing Reports to the Web with Oracle Reports Services
1. Choose **Tools > Report Wizard**.

2. In the Report Wizard, click the **Labels** tab.

3. Change the value in the **Width** column for the field in which you want to wrap text, as desired.

4. Click **Apply**.

---

**Caution:** If you have made manual adjustments to your layout in the Paper Layout view or Paper Design view, you will lose these layout changes when you click **Apply** or **Finish** in the Report Wizard, which redefaults the layout. If you do not want to overwrite your current layout, you can manually drag the column to the desired width in the Paper Layout view or Paper Design view.

---

5. In the Paper Layout view or Parameter Form view, double-click the field to display the Property Inspector, and set the following properties:

   - Under **General Layout**, verify that the Vertical Elasticity property is set to **Expand**.

---

### 4.9.2.9 Changing text attributes

To change the font, justification, spacing, or reading direction of a text object:

1. In the Paper Design view, click the text object(s).

   **Tip:** To select multiple objects, click one object, then Shift-click all other objects. To select all objects, choose **Edit > Select All**.

2. From the **Format** menu, choose **Font, Justify, Text Spacing**, or **Direction**.

---

### 4.9.2.10 Changing text attributes using PL/SQL

To change the font or justification of a text object using PL/SQL instead of the user interface:

1. In the Object Navigator, expand the **Paper Layout** node.

2. Double-click the PL/SQL icon next to the text object(s).

   **Tip:** To select multiple objects, click one object, then Shift-click all other objects. To select all objects, choose **Edit > Select All**.

3. In the PL/SQL Editor, use the following built-in procedures to change the font or justification of the object as desired:

   ```plsql
   SRW.SET_CHARMODE_TEXT
   SRW.SET_FONT_FACE
   SRW.SET_FONT_STYLE
   SRW.SET_FONT_WEIGHT
   SRW.SET_FONT_SIZE
   ```
SRW.SET_JUSTIFICATION

See also
Topic "SRW built-in package" in the Reference > PL/SQL Reference > Built-in Packages section of the Oracle Reports online Help.

4.9.3 Page Numbers or Date/Time Stamps
This section provides procedures for the following tasks that you may perform as you work with page numbers or date/time stamps:

- Creating page numbers
- Resetting page numbers
- Creating a time or date stamp

4.9.3.1 Creating page numbers
To create default page numbers:
1. In the Paper Layout view or Paper Design view, choose Insert > Page Number.
2. In the Insert Page Number dialog box, choose from the list the location for the page number.
3. Click the desired page number format: Page Number Only or Page Number and Total Pages.
4. Optionally, change the default attributes of the page number text as desired.
   
To create customized page numbers:
1. In the Paper Layout view or Paper Design view, click the Edit Margin button in the toolbar.

   Usage notes
   - To generate odd page numbers on the right and even pages numbers on the left, you have to create two fields: one on the right side, one on the left side. In the format trigger of each field, you test if it is an odd or an even page by using SRW.GET_PAGE_NUM. Then, you specify whether or not to display the field.

Note: The margin area is defined by a thick black line that separates it from the body. If you create objects in the body portion of a report while displaying the margin area, you can only edit those objects when the margin is displayed.
4.9.3.2 Resetting page numbers
To reset default page numbers (created with Insert > Page Number):

1. In the Paper Layout view or Paper Design view, click the default page number field, then choose Edit > Delete to delete it.
2. Create customized page numbers (see Section 4.9.3.1, "Creating page numbers").
3. In the page number field’s Property Inspector, under Field, double-click the Page Numbering property value.
4. In the Page Numbering dialog box, click the desired Reset At setting. Page numbers will reset to the Start at value each time the selected frame is formatted. Click OK.

4.9.3.3 Creating a time or date stamp
To add a date or time stamp to your report:

1. In the Paper Layout view or Paper Design view, choose Insert > Date and Time.
2. In the Insert Date and Time dialog box, choose from the list the location for the date or time stamp.
3. Click the desired date or time format, or click Custom to define your own format.

4.9.4 Borders
This section provides procedures for the following tasks that you may perform as you work with borders:

- Showing or hiding object borders
- Changing object border attributes
- Changing the current mode (Confine or Flex)

4.9.4.1 Showing or hiding object borders
To show or hide the borders around an object:

1. Click the object(s).

   **Tip:** To select multiple objects, click one object, then Shift-click all other objects. To select all objects, choose Edit > Select All.

2. Click the Line color tool in the tool palette.
3. To add a border, click any color solid square.
4. To make a border transparent in the report output, click No Line at the bottom of the color palette.

   **Note:** If you make the borders transparent for all the objects, this includes the underlines beneath the column headings. To add the underlines, click the underline objects, and use the Line Color in the tool palette to select a line color.

5. To show or hide part of the border, choose Format > Line > Border, and select from the menu to toggle between showing and hiding the sides of the border.
4.9.4.2 Changing object border attributes

To change the borders around an object:

1. Click the object(s).

   **Tip:** To select multiple objects, click one object, then Shift-click all other objects. To select all objects, choose **Edit > Select All**.

2. To change the line width, choose **Format > Line > Line Width**.

3. To select a pattern, choose **Format > Line > Dash**. Even though it appears in the output, the dash pattern is sometimes obscured by the object's outline. You can choose **Tools > Options > Paper Layout** and clear the Options:Frame Outlines check box.

4. To "frame" the border, choose **Format > Bevel**.

**See also**

Section 2.4.5, "About changing colors and patterns"

Section 4.12.8, "Modifying the color, pattern, or border of body objects in a template"

4.9.4.3 Changing the current mode (Confine or Flex)

To set or override Confine mode:

- In the Paper Layout view, click the Confine On button or the Confine Off button in the toolbar to toggle the mode:
  
  **On:** child objects cannot be moved outside their enclosing parent objects.
  
  **Off:** child objects can be moved outside their enclosing parent objects.

To set or override Flex mode:

- In the Paper Layout view, click the Flex On button or the Flex Off button in the toolbar to toggle the mode:
  
  **On:** parent borders "stretch" when child objects are moved against them. The child object maintains the same distance from the side it moves against.
  
  **Off:** parent borders remain fixed when child objects are moved against them.

**See also**

Section 2.4.7, "About moving and layering objects in the Paper Layout view"

Chapter 4.9.11.3, "Adjusting parent borders automatically"

Chapter 4.9.11.2, "Moving an object outside its parent"

4.9.5 Anchors

This section provides procedures for the following tasks that you may perform as you work with anchors:

- Anchoring objects together
- Viewing implicit anchors
- Moving an anchor
See also
Section 2.4.4, "About anchors"

4.9.5.1 Anchoring objects together
Anchoring objects assures that the anchored object will move with the parent object. An object can be anchored to only one other object.

To anchor objects together:
1. In the Paper Layout view, click the Anchor tool in the tool palette.
2. Click an edge of the child object and double-click an edge of the parent object.
   A line is drawn from the child to the parent. A small box appears at the end of the line that is attached to the parent object.

4.9.5.2 Viewing implicit anchors
By default, you see the explicit anchors created in the Paper Layout view of the Report Editor.

To view information on both implicit and explicit anchors:
1. In the Object Navigator, choose Tools > Options > Navigator to display the Object Navigator Options dialog box.
2. Click the Layout tab, and select the Anchoring Information check box.
   With this option selected, you can see all information on both implicit and explicit anchors in the Object Navigator.

Note: By default, objects are anchored to the upper left corner of their enclosing object. If this view of the Object Navigator does not show anchoring information for an object, you can assume that the object is anchored to its enclosing object, which might be the frame or the body.

See also
Section 2.4.4.1, "Implicit anchoring algorithm"

4.9.5.3 Moving an anchor
Moving an anchor changes how the objects will be displayed in relationship to each other.

To move an anchor:
1. In the Paper Layout view, click the anchor.
2. Click the Reshape tool in the tool palette, then drag one of the anchor endpoints to its new location on the object edge.

To move an anchor along an object edge:
- Press the constrain (for example, shift) key when moving the anchor.

To change the position of the anchor on the object edge, as a percentage down or across from top to bottom or left to right:
1. Double-click the anchor object to display the Property Inspector.
2. Set the Child Edge Percent property or Parent Edge Percent property to a new value.

To change the edge on which the anchor is positioned:

- Set the Child Edge Type property or Parent Edge Type property as desired.

### 4.9.6 Colors, Patterns, and Highlighting

This section provides procedures for the following tasks that you may perform as you work with colors, patterns, and highlighting:

- Setting color palette preferences
- Changing colors
- Changing patterns
- Changing colors and patterns using PL/SQL
- Modifying the color palette
- Importing or exporting a color palette
- Highlighting a value
- Highlighting a row

#### 4.9.6.1 Setting color palette preferences

See Section 4.2.6, "Setting color palette preferences".

#### 4.9.6.2 Changing colors

To change the color of an object or text:

1. In the Paper Layout view, click the object(s).

   **Tip:** To select multiple objects, click one object, then Shift-click all other objects. To select all objects, choose Edit > Select All.

2. Click the Fill Color tool, the Line Color tool, or the Text Color tool in the tool palette, depending on which part of the object you want to apply a color to.

   **Note:** The Fill/Line/Text Display, the box directly above the three Color tools, shows the currently selected fill, border, and text. The default fill and border for objects created by Oracle Reports Builder is transparent, while the default for objects you create is a black, one-point line around a white.

3. On the color palette, click a color.

   **See also**
   
   Section 2.4.5, "About changing colors and patterns"

   Section 4.12.8, "Modifying the color, pattern, or border of body objects in a template"

#### 4.9.6.3 Changing patterns

To change the pattern of an object:
1. In the Paper Layout view, click the object(s).

**Tip:** To select multiple objects, click one object, then Shift-click all other objects. To select all objects, choose **Edit > Select All**.

2. Click the Fill Color tool or the Line Color tool in the tool palette, depending on which part of the object you want to apply a pattern to.

**Note:** The Windows platform does not support a border pattern (that is, patterns for the Line Color tool).

3. On the color palette, click **Patterns**.

4. On the pattern palette, click a pattern. To change the foreground and background colors, choose from the color palettes at the bottom of the pattern palette.

**See also**
Section 2.4.5, "About changing colors and patterns"
Section 4.12.8, "Modifying the color, pattern, or border of body objects in a template"
Topic "Pattern color palette" in the Reference > Color and Pattern Palettes section of the Oracle Reports online Help.

**4.9.6.4 Changing colors and patterns using PL/SQL**
To change the color of an object using PL/SQL instead of the user interface:

1. In the Object Navigator, expand the **Paper Layout** node.

2. Double-click the PL/SQL icon next to the object for which you want to change the color.

3. In the PL/SQL Editor, use the following built-in procedures to change the color of the object as desired:

   SRW.SET_BACKGROUND_BORDER_COLOR
   SRW.SET_BACKGROUND_FILL_COLOR
   SRW.SET_FOREGROUND_BORDER_COLOR
   SRW.SET_FOREGROUND_FILL_COLOR
   SRW.SET_TEXT_COLOR
   SRW.SET_BORDER_PATTERN

**See also**
Section 2.4.5, "About changing colors and patterns"
Topic "SRW built-in package" in the Reference > PL/SQL Reference > Built-in Packages section of the Oracle Reports online Help.

**4.9.6.5 Modifying the color palette**
To modify the color palette:

1. First, make the color palette editable:
Work with the Report Layout

- Choose Edit > Preferences, and set Color Mode to Editable, as described in Section 4.2.6, "Setting color palette preferences".

  **Note:** By default, color palettes are read-only.

- Shut down and restart Oracle Reports Builder to enable the Editable mode.

2. In the Paper Layout view, choose Format > Color Palette > Edit.

3. In the Color Palette dialog box, modify the color palette as desired:
   - Click Edit to alter the settings of the current color.
   - Type a new name in Current Color, then click Rename to rename the current color.
   - Select Color to Edit contains the current color palette being used in the Report Editor for the current report. Select a color from the palette to alter it.
   - Click OK to apply your changes to the current report.

  **Note:** A report can have only one color palette.

**See also**
Section 2.4.5, "About changing colors and patterns"

Topics "Oracle CDE1 color palette", "Default color palette", and "Grayscale color palette" in the Reference > Color and Pattern Palettes section of the Oracle Reports online Help.

4.9.6.6 Importing or exporting a color palette

To import or export a color palette:

1. First, make the color palette editable:
   - Choose Edit > Preferences, and set Color Mode to Editable, as described in Section 4.2.6, "Setting color palette preferences".

  **Note:** By default, color palettes are read-only.

- Shut down and restart Oracle Reports Builder to enable the Editable mode.

2. In the Paper Layout view, choose Format > Color Palette > Import or Format > Color Palette > Export.

3. In the dialog box, specify the name and format of the file.

4. Click OK.

  **Note:** A report can have only one color palette.

**See also**
Section 2.4.5, "About changing colors and patterns"
Topics "Oracle CDE1 color palette", "Default color palette", and "Grayscale color palette" in the Reference > Color and Pattern Palettes section of the Oracle Reports online Help.

4.9.6.7 Highlighting a value
To highlight a value in a report:

1. In the Paper Layout view or Paper Design view, click the field that contains the value to be highlighted.
2. Choose Format > Conditional Formatting.
3. In the Conditional Formatting dialog box, click New to display the Format Exception dialog box.
4. Select the field and define the condition(s) when the value should be highlighted.
5. In the Format group box, select the Fill Color to be used to highlight the value.

Note: If you can’t select the condition you want to use in the dialog box, select the formatting you want and a placeholder condition. The condition can be edited in the PL/SQL Editor for the format trigger that is created.

6. Click OK to close the Format Exception dialog box, then click OK again to close the Conditional Formatting dialog box. If the code compiles without errors, the new formatting is reflected in the Paper Layout view. The code is stored as a format trigger for the field.

Example
The following code determines the monthly compensation and changes the background color to red if the compensation has exceeded four thousand dollars a month and the employee is not a manager.

```plsql
function R_G_EMPNOFormatTrigger return boolean is varcomm number;
beg
  if :comm is null then
    varcomm := 0;
  else
    varcomm := :comm;
  end if;
  if (:sal * 2 + varcomm > 4000) and :job != 'MANAGER' then
    srw.set_background_fill_color('red');
  end if;
  return (TRUE);
end;
```

See also
Section 2.1.6, "About conditional formatting"
Section 4.9.1.5, "Applying conditional formatting to a layout object"

4.9.6.8 Highlighting a row
To highlight an entire row:

1. In the Paper Layout view, click the repeating frame that contains the fields that make up the rows to be highlighted.
2. Choose **Format > Conditional Formatting**.

3. In the Conditional Formatting dialog box, click **New** to display the Format Exception dialog box.

4. Select the field(s) and define the condition(s) that describe the rows to be highlighted.

5. In the **Format** group box, select the **Fill Color** to be used to highlight the row.

   **Note:** If you can’t select the condition you want to use in the dialog box, select the formatting you want and a placeholder condition. The condition can be edited in the PL/SQL Editor for the format trigger that is created.

6. Click **OK** to close the Format Exception dialog box, then click **OK** again to close the Conditional Formatting dialog box. If the code compiles without errors, the new formatting is reflected in the Paper Layout view. The code is stored as a format trigger for the repeating frame.

**Example**

The following code determines the monthly compensation and changes the background color to red if the compensation has exceeded four thousand dollars a month and the employee is not a manager.

```plsql
function R_G_EMPNOFormatTrigger return boolean is
  varcomm number;
begin
  if :comm is null then
    varcomm := 0;
  else
    varcomm := :comm;
  end if;

  if (:sal * 2 + varcomm > 4000) and :job != 'MANAGER' then
    srw.set_background_fill_color('red');
  end if;
  return (TRUE);
end;
```

**See also**

Section 2.1.6, "About conditional formatting"

Section 4.9.1.5, "Applying conditional formatting to a layout object"

**4.9.6.9 Alternating row colors**

To alternate the colors of either the text or the fill of a row:

- See Chapter 45, "Building a Report with an XML Pluggable Data Source". This chapter provides detailed steps for using PL/SQL procedures and format triggers to apply alternating row colors.

**4.9.7 Format Masks**

This section provides procedures for the following tasks that you may perform as you work with format masks:

- Specifying date and time format masks
- Specifying number format masks
- Applying a format mask to a numeric object
- Applying a format mask to a date object
- Adding a custom format mask
- Changing the format mask for multiple fields

4.9.7.1 Specifying date and time format masks
The following tables describe the date and time format masks, and the suffixes you can add to date format masks:

**Table 4-2 Date and time format masks**

<table>
<thead>
<tr>
<th>Format Mask</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>SCC or CC</td>
<td>Century, abbreviated; 'S' prefixes &quot;BC&quot; with (-)</td>
</tr>
<tr>
<td>YYYY or YYYY</td>
<td>Year; 'S' prefixes &quot;BC&quot; date with a (-)</td>
</tr>
<tr>
<td>I or IY or IYY</td>
<td>Last 1, 2, or 3 digit(s) of year</td>
</tr>
<tr>
<td>Y or YY or YYY</td>
<td>Last 1, 2, or 3 digit(s) of year</td>
</tr>
<tr>
<td>YYYY</td>
<td>Year with comma</td>
</tr>
<tr>
<td>SYEAR or YEAR</td>
<td>Year, spelled out; 'S' prefixes &quot;BC&quot; date with (-)</td>
</tr>
<tr>
<td>RRRR or SRRRR</td>
<td>Year; 'S' prefixes &quot;BC&quot; date with a (-)</td>
</tr>
<tr>
<td>RR</td>
<td>Last 2 digit(s) of year</td>
</tr>
<tr>
<td>BC, AD, or B.C., A.D.</td>
<td>Century indicator</td>
</tr>
<tr>
<td>Q</td>
<td>Quarter of year (Jan-Mar= Quarter 1)</td>
</tr>
<tr>
<td>MM</td>
<td>Month in digits (Jan = 01)</td>
</tr>
<tr>
<td>MONTH or MON</td>
<td>Name of month, or 3-letter abbreviation</td>
</tr>
<tr>
<td>WW, IW</td>
<td>Week in year</td>
</tr>
<tr>
<td>W</td>
<td>Week in Julian days</td>
</tr>
<tr>
<td>J</td>
<td>Julian day; the number of days since January 1,4712 BC</td>
</tr>
<tr>
<td>DDD, DD, or D</td>
<td>Day in year, month, or week</td>
</tr>
<tr>
<td>DAY</td>
<td>Day of week fully spelled out (for example, MONDAY)</td>
</tr>
<tr>
<td>DY</td>
<td>Name of day, 3-letter abbreviation (for example, MON)</td>
</tr>
<tr>
<td>AM, PM, or A.M., P.M.</td>
<td>Meridian indicator</td>
</tr>
<tr>
<td>HH or HH12</td>
<td>Hour of day (1-12)</td>
</tr>
<tr>
<td>HH24</td>
<td>Hour of day (0-23)</td>
</tr>
<tr>
<td>MI</td>
<td>Minute</td>
</tr>
<tr>
<td>SS; SSSSS</td>
<td>Second in minute; seconds in day</td>
</tr>
<tr>
<td>FM</td>
<td>Toggles fill mode which replaces multiple spaces before or between dates, numbers, or words with a single space</td>
</tr>
</tbody>
</table>

The following suffixes may be added to the format masks:
### Examples

#### Table 4–3  Date format mask suffixes

<table>
<thead>
<tr>
<th>Suffix</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>TH</td>
<td>Suffixed number (&quot;DDth&quot; for &quot;4th&quot;)</td>
</tr>
<tr>
<td>SP</td>
<td>Spelled out number (&quot;DDSP&quot; for &quot;FOUR&quot;)</td>
</tr>
<tr>
<td>SPTH or THSP</td>
<td>Spelled and suffixed number (&quot;DDSPTH&quot; for &quot;FOURTH&quot;)</td>
</tr>
</tbody>
</table>

#### Table 4–4  Date format mask examples

<table>
<thead>
<tr>
<th>Sample Date Format</th>
<th>Date Displayed</th>
</tr>
</thead>
<tbody>
<tr>
<td>MM/DD/RR</td>
<td>03/04/09</td>
</tr>
<tr>
<td>DD MON RRRR</td>
<td>04 MAR 2009</td>
</tr>
<tr>
<td>Mon. DD, RRRR</td>
<td>Mar. 4, 2009</td>
</tr>
<tr>
<td>Day Month DD fmHH:MI AM</td>
<td>Monday March 4 11:35 AM</td>
</tr>
<tr>
<td>Dy Mon ddth fmHH24:MI:SS</td>
<td>Mon Mar 4th 23:35:22</td>
</tr>
<tr>
<td>Day &quot;the&quot; ddthsp &quot;of&quot; Month</td>
<td>Monday the fourth of March</td>
</tr>
</tbody>
</table>

#### 4.9.7.2 Specifying number format masks

The following table describes the tokens you can use in creating a number format mask:

#### Table 4–5  Tokens for number format masks

<table>
<thead>
<tr>
<th>Format Token</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>Prints one digit.</td>
</tr>
<tr>
<td>N</td>
<td>Prints one digit, unless it is a leading zero to the left of the decimal point or a trailing zero to the right of the decimal point.</td>
</tr>
<tr>
<td>*</td>
<td>Prints one digit, unless it is a leading zero to the left of the decimal point, in which case an asterisk (*) is printed. Trailing zeros to the right of the decimal point are printed.</td>
</tr>
<tr>
<td>9</td>
<td>Prints one digit, unless it is a leading zero to the left of the decimal point, in which case a space is printed. Trailing zeros to the right of the decimal point are printed.</td>
</tr>
<tr>
<td>+</td>
<td>Prints a leading plus (+) for positive values and a leading minus (-) for negative values. This token must lead the mask.</td>
</tr>
<tr>
<td>-</td>
<td>Prints a leading minus (-) for negative values and nothing for positive values. This token must lead the other tokens.</td>
</tr>
<tr>
<td>MI</td>
<td>Prints a minus (-) after negative values and a space after positive values. This token must trail the other tokens.</td>
</tr>
<tr>
<td>S</td>
<td>Prints a minus (-) for negative values and a plus (+) for positive values (wherever the S appears in the mask). This token must lead or trail the other tokens.</td>
</tr>
<tr>
<td>PR</td>
<td>Prints angle brackets (&lt;&gt; around negative values and spaces around positive values. This token must trail the other tokens.</td>
</tr>
</tbody>
</table>
Table 4–5  (Cont.) Tokens for number format masks

<table>
<thead>
<tr>
<th>Format Token</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>()</td>
<td>Prints parentheses around negative values and spaces around positive values. The parentheses must surround the other tokens.</td>
</tr>
<tr>
<td>DB</td>
<td>Prints a &quot;DB&quot; after positive values. This token must trail the other tokens.</td>
</tr>
<tr>
<td>CR</td>
<td>Prints a &quot;CR&quot; after negative values. This token must trail the other tokens.</td>
</tr>
<tr>
<td>Y</td>
<td>Causes no sign symbol to be printed for negative or positive values.</td>
</tr>
<tr>
<td>V</td>
<td>Causes the number to be multiplied by 10N, where N is the number of 0, 9, *, and S tokens that appear to the right of the V.</td>
</tr>
<tr>
<td>EEEE</td>
<td>Causes the number to be printed in scientific notation. All digit tokens refer to digits of the mantissa. There must be exactly one digit to the left of the decimal point (displayed or implicit). The token EEEE prints as E followed by a plus (+), if the ordinate is positive or zero, and a minus (-), if the ordinate is negative, and two digits representing the ordinate (for example, E-99).</td>
</tr>
<tr>
<td>&quot;string&quot;</td>
<td>Prints the string between the double quotes. To have double-quotes inside the string, type double-quotes back to back (&quot;&quot;).</td>
</tr>
<tr>
<td>. (period)</td>
<td>Prints a period (.) to separate the integral and fractional parts of a number.</td>
</tr>
<tr>
<td>D</td>
<td>Prints the local decimal character to separate the integral and fractional parts of a number.</td>
</tr>
<tr>
<td>, (comma)</td>
<td>Prints a comma (,) as the group/thousands separator.</td>
</tr>
<tr>
<td>G</td>
<td>Prints the local group/thousands separator.</td>
</tr>
<tr>
<td>$</td>
<td>Prints $.</td>
</tr>
<tr>
<td>L</td>
<td>Prints the local currency symbol.</td>
</tr>
<tr>
<td>C</td>
<td>Prints the ISO currency symbol.</td>
</tr>
<tr>
<td>%</td>
<td>Prints %.</td>
</tr>
<tr>
<td>&quot; &quot;</td>
<td>Prints a blank space. (Do not include quotes in mask.)</td>
</tr>
<tr>
<td>v</td>
<td>Prints a blank space for all zero values, regardless of other tokens.</td>
</tr>
<tr>
<td>K</td>
<td>Prints a blank space.</td>
</tr>
<tr>
<td>&lt;&gt;</td>
<td>Delineates the beginning and ending of the decimal-aligned region (that is, that part of the number that you want aligned with the decimal point in the format mask). Angle brackets indicate that the number should always occupy the same amount of space. If necessary, values are padded with blanks to the left or right of the decimal point.</td>
</tr>
<tr>
<td>RN, rm</td>
<td>Prints values in uppercase or lowercase Roman numerals, respectively. You cannot enter any other tokens with this token.</td>
</tr>
</tbody>
</table>

Restrictions

- For number format masks, if the actual value is longer than the specified format mask, the value will appear as a string of asterisks in the report output, regardless
of the field’s width. For example, if a fixed field’s width is 8, the value is 1234567, and the format mask is <NNNUNN>, your output will be *******.

- Similarly, if the number format mask causes the value to be larger than the field width, asterisks will appear in place of the value. For example, if a fixed field’s width is 6, the value is 1234, and the format mask is -99999999, your output will be ******. This occurs because the format token 9 prints a blank for leading zeros to the left of the decimal. As a result, the value is too long to be displayed in a field of width 6.

- If you do not specify a sign token in the format mask, positive values are preceded by a space and negative values are preceded by a minus (-).

- After you create a format mask it will display in the list of values only if it is an appropriate format mask for the Datatype of the Source. That is, format masks for numbers are displayed when the Source is a number, and format masks for dates are displayed when the Source is a date.

- Format masks that print spaces for zeros (for example, 9) increase the number of bytes per page taken up by your output.

Examples

Table 4–6 Number format mask examples

<table>
<thead>
<tr>
<th>Sample Number Format</th>
<th>Number</th>
<th>Number Displayed</th>
</tr>
</thead>
<tbody>
<tr>
<td>-0000</td>
<td>7934</td>
<td>&quot;7934&quot;</td>
</tr>
<tr>
<td>-7934</td>
<td></td>
<td>&quot;-7934&quot;</td>
</tr>
<tr>
<td>-00000</td>
<td>7934</td>
<td>&quot;07934&quot;</td>
</tr>
<tr>
<td>-NNNN</td>
<td>7639</td>
<td>&quot;7639&quot;</td>
</tr>
<tr>
<td>535</td>
<td></td>
<td>&quot;535&quot;</td>
</tr>
<tr>
<td>-NNN</td>
<td>7639</td>
<td>&quot;****&quot;</td>
</tr>
<tr>
<td>.****</td>
<td>7902</td>
<td>&quot;7902&quot;</td>
</tr>
<tr>
<td>.*****</td>
<td>7902</td>
<td>&quot;*7902&quot;</td>
</tr>
<tr>
<td>+NNNN</td>
<td>100</td>
<td>&quot;+100&quot;</td>
</tr>
<tr>
<td>.99</td>
<td></td>
<td>&quot; .99&quot;</td>
</tr>
<tr>
<td>(NNNN)</td>
<td>1600</td>
<td>&quot; 1600 &quot;</td>
</tr>
<tr>
<td>-800</td>
<td></td>
<td>&quot;(800)&quot;</td>
</tr>
<tr>
<td>NNNNPVR</td>
<td>1600</td>
<td>&quot; 1600 &quot;</td>
</tr>
<tr>
<td>-800</td>
<td></td>
<td>&quot;&lt;800&gt;&quot;</td>
</tr>
<tr>
<td>NNNNNMI</td>
<td>1600</td>
<td>&quot;1600 &quot;</td>
</tr>
<tr>
<td>-800</td>
<td></td>
<td>&quot;800-&quot;</td>
</tr>
<tr>
<td>NNNVNN</td>
<td>343</td>
<td>&quot;34300&quot;</td>
</tr>
<tr>
<td>N.NNEEEE</td>
<td>7369</td>
<td>&quot;7.37E+03&quot;</td>
</tr>
<tr>
<td>&quot;SRW&quot;-0000</td>
<td>7782</td>
<td>&quot;SRW7782&quot;</td>
</tr>
<tr>
<td>-$NNNN.NN</td>
<td>800</td>
<td>&quot;$800&quot;</td>
</tr>
<tr>
<td>1600</td>
<td></td>
<td>&quot;$1600&quot;</td>
</tr>
<tr>
<td>-%NNN</td>
<td>10</td>
<td>&quot;%-10&quot;</td>
</tr>
</tbody>
</table>
4.9.7.3 Applying a format mask to a numeric object

1. To apply a format mask to a numeric object:
2. In the Paper Design view, click the object(s).

   **Tip:** To select multiple objects, click one object, then Shift-click all other objects. To select all objects, choose **Edit > Select All**.

3. To apply the currency format to the object, click the Currency button in the toolbar.
4. To apply the percentage format to the object, click the Percentage button in the toolbar.
5. To add commas to the value of the object, click the Commas button in the toolbar.
   To move the comma right or left, click the Remove Decimal Place button or the Add Decimal Place button.
6. Choose **Tools > Property Inspector**.
7. Under the **Field** node, verify the Format Mask property is set to the desired format.
8. Set other properties as desired.

4.9.7.4 Applying a format mask to a date object

To apply a format mask to a date object:
1. In the Paper Design view, click the object(s).

   **Tip:** To select multiple objects, click one object, then Shift-click all other objects. To select all objects, choose **Edit > Select All**.

2. Choose **Tools > Property Inspector**.
3. Under the **Field** node, set the Format Mask property to the desired date format.
4. Set other properties as desired.

4.9.7.5 Adding a custom format mask
To add a custom format mask to the default format masks list:
1. Choose Edit > Preferences.
2. In the Preferences dialog box, click Edit Masks.
3. In the Format Masks dialog box, set Display to the type of format mask you want to add.
4. In the Mask field, type the format mask to add, then click Add.
5. Click OK.

Now, you will see your new custom format masks in the list of values for the Format Mask property for fields and the Input Mask property for parameters.

4.9.7.6 Changing the format mask for multiple fields
To change the format mask for multiple fields at one time:
1. In the Paper Layout view, click the fields you want to change.
2. Choose Tools > Property Inspector.
3. In the Property Inspector, set the Format Mask property to a new format mask.

4.9.8 Graphic or Image Objects
This section provides procedures for the following tasks that you may perform as you work with graphic or image objects:

- Adding an image
- Adding a graph
- Editing a graph
- Adding a graph hyperlink
- Creating a drawing object

4.9.8.1 Adding an image
To add an image to your report, perform the steps in any of the topics listed below.

For paper-based reports and JSP-based Web reports:
- Section 4.8.5, "Selecting an image from the database"
- Section 4.8.6, "Selecting an image URL from the database"

For paper-based reports only:
- Importing an image
- Linking an image object to a file
- Linking an image object to a URL

See also
Section 2.4.3, "About images"

4.9.8.1.1 Importing an image
To import an image:

1. In the Paper Layout view, choose **Insert > Image** and click the type of object you want to import.
2. In the dialog box, specify the name and format of the file. Click **OK**.
3. Move the object to the desired position.

**Usage notes**

This procedure is for paper-based reports only. If you want to include static images in your JSP-based Web reports, you can add HTML `<img>` tags in the Web Source view.

### 4.9.8.1.2 Linking an image object to a file

**Notes:** This procedure applies to paper-based reports. File link objects are not implemented in JSP-based Web reports.

These steps, and the steps in Section 4.8.5, "Selecting an image from the database", allow you to include images in a wide variety of formats supported by Oracle Reports, including JPEG (all types, such as Progressive JPEG and Exif JPEG), PNG, BMP, TIFF, GIF, and CGM. For paper-based reports, you can also use Insert > Image to import an image from a file into the report layout for images in the following formats: TIFF, JFIF, BMP, TGA, PCX, PICT, GIF, CALS, RAS, OIF, PCD (see Section 4.9.8.1.1, "Importing an image", above).

To link an image object to a file:

1. In the Paper Design view or Paper Layout view, click the File Link tool in the tool palette.
2. Click and drag a rectangle.
3. Double-click the file link object to display the Property Inspector.
4. Under the **File Link Boilerplate** node:
   - Set the Source File Format property to Image.
   - Set the Source Filename property to the name of the file containing the image.

### 4.9.8.1.3 Linking an image object to a URL

**Note:** This procedure applies to paper-based reports. For JSP-based Web reports, see the Usage notes, below.

These steps allow you to include images in the following formats: TIFF, JFIF, BMP, TGA, PCX, PICT, GIF, CALS, RAS, OIF, PCD. For images in other formats supported by Oracle Reports, including JPEG (all types, such as Progressive JPEG and Exif JPEG), PNG, BMP, TIFF, GIF, and CGM, see Section 4.9.8.1.2, "Linking an image object to a file" or Section 4.8.5, "Selecting an image from the database".
To link an image object to a URL that points to an image to include in an HTML report:

1. In the Paper Design view or Paper Layout view, click the File Link tool in the tool palette.
2. Click and drag a rectangle.
3. Double-click the file link object to display the Property Inspector.
4. Under the **File Link Boilerplate** node:
   - Set the Source File Format property to Image URL.
   - Set the Source Filename property to the URL where the image is located with the required protocol.

**Example 1: Image URL**

HTTP://www.oracle.com/images/logo.gif

**Example 2: Image URL containing user parameter**

HTTP://&<P_SERVER_NAME>/images/logo.gif

where **P_SERVER_NAME** is a user parameter of type CHAR.

At runtime, the end user can specify a value for the parameter (for example, **P_SERVER_NAME=www.oracle.us.com** for a dynamic URL link of http://www.oracle.us.com/images/logo.gif).

**Example 3: URL to a file**

FILE://c:/images/logo.gif

**Note:** If you click **Browse** to find a file, Oracle Reports automatically prepends **FILE://** to the returned path.

4.9.8.2 Adding a graph

To add a graph to your report, follow the steps in either of the following topics:

- Adding a graph to a paper-based report
- Adding a graph to a JSP-based Web report
Usage notes

Inserting a graph with a once-per-group position in the Paper Design view of a matrix with group report causes Oracle Reports Builder to fail. As a workaround, insert the graph in the Paper Layout view, rather than the Paper Design view, when adding a graph to a matrix with group report.

See also
Section 1.6.6, "About the Web Source view"
Chapter 39, "Building a Report with Graphs"

4.9.8.2.1 Adding a graph to a paper-based report

To add a graph to your paper-based report:

1. In the Paper Layout view, click the Graph tool in the tool palette.
2. Drag a square in the area where the graph should appear to display the Graph Wizard.
3. In the Graph Wizard, specify information for the graph. Click Help on any wizard page for assistance.

Note: When you specify a graph title, subtitle, footnote, or axis title in the Graph Wizard, you can insert lexical references (to user parameters, system parameters, and columns) in the text. For example, in the Show Title field on the Title page of the Graph Wizard, type: titletext &<P_1> to insert the value of the user parameter P_1 into the title text at runtime. The angle brackets (<>) are required around the parameter or column name.

4. Double-click the graph object you have created to display the Property Inspector, and set properties as desired.

To customize your graph XML definition beyond the scope of the Graph Wizard, you can directly edit the XML in the graph’s Graph Settings property. The full list of attributes available is defined in the DTD file, graph.dtd.

Note: The graph.dtd is available in the following locations:

■ ORACLE_HOME/jlib/bigraphbean.jar
■ In Getting Started with Oracle Reports on the Oracle Technology Network (OTN): on the Oracle Reports page (http://www.oracle.com/technetwork/middleware/reports/overview/index.htm), navigate to the Learn More tab and click Getting Started to display the Getting Started with Oracle Reports home page. In the list of topic sections on the left, click Index. In the Collateral Type list, choose Documentation and click Search. In the list that displays, find the Documented Graph DTD.

5. To re-enter the Graph Wizard, do either of the following:

■ Right-click the graph, and choose Graph Wizard.
■ Click the graph, then choose Edit > Settings.
4.9.8.2.2 Adding a graph to a JSP-based Web report

To add a graph to a JSP-based Web report:

1. In the Object Navigator, double-click the view icon next to the Web Source node to display the source code in the Web Source view.

2. Locate the section in the source code where you want to add the graph.

   **Note:** Previously adding some text such as "Place the graph here" to your Web page enables you to easily locate the correct position for your graph.

3. Choose Insert > Graph.

4. In the Graph Wizard, specify the information for the graph. Click Help on any tab page for assistance.

   **Note:** When you specify a graph title, subtitle, footnote, or axis title in the Graph Wizard, you can insert lexical references (to user parameters, system parameters, and columns) in the text. For example, in the Show Title field on the Title page of the Graph Wizard, type titletext &<P_1> to insert the value of the user parameter P_1 into the title text at runtime. The angle brackets (<> are required around the parameter or column name.

5. Click the Run Web Layout button in the toolbar (or choose Program > Run Web Layout) to display your report and graph in your Web browser.

   **Note:** If Netscape 7.0 is your default browser, and the browser does not display, set the registry key HKEY_CURRENT_ USERS\Software\Oracle\Toolkit\Tkbrowser to the default browser location. Ensure that the BrowserName and the BrowserPath keys reflect the correct values. For example: BrowserName=Netscape 7; BrowserPath=C:\Program Files\Netscape\Netscape\Netscp.exe.

6. To re-enter the Graph Wizard, place your cursor anywhere between the <rw:graph> and </rw:graph> tags in the Web Source view, then choose Edit > Settings.

   To customize your graph XML definition beyond the scope of the Graph Wizard, you can directly edit the XML in the Web Source view. The full list of attributes available is defined in the DTD file, graph.dtd.
4.9.8.3 Editing a graph

To add a graph to your report, follow the steps in either of the following topics:

- Editing a graph in a paper-based report
- Editing a graph in a JSP-based Web report

See also
Section 1.4.4, "About Graphs and the Graph Wizard"
Section 1.6.6, "About the Web Source view"

4.9.8.3.1 Editing a graph in a paper-based report

To edit a graph in a paper-based report:

1. In the Paper Layout view, click the graph.

   Note: The graph is represented as a bar graph even if the graph is of another type.

2. To edit the XML definition of the graph:

   - Right-click the graph, and choose Property Inspector.
   - In the Property Inspector, under the Graph node, click the Graph Settings property value field to display the Graph Settings dialog box. To customize your graph XML definition beyond the scope of the Graph Wizard, specify additional rw:graph tag attributes. The full list of attributes available is defined in the DTD file, graph.dtd.

---

Note: The graph.dtd is available in the following locations:

- ORACLE_HOME\jlib\bigraphbean.jar
- In Getting Started with Oracle Reports on the Oracle Technology Network (OTN): on the Oracle Reports page (http://www.oracle.com/technetwork/middleware/reports/overview/index.html), navigate to Learn More and click Getting Started to display the Getting Started with Oracle Reports home page. In the list of topic sections on the left, click Index. In the Collateral Type list, choose Documentation and click Search. In the list that displays, find the Documented Graph DTD.
3. To re-enter the Graph Wizard to redefine the graph, do either of the following:
   - Right-click the graph, and choose Graph Wizard.
   - Click the graph, then choose Edit > Settings.

4.9.8.3.2 Editing a graph in a JSP-based Web report

To edit a graph in a JSP-based Web report, do any of the following in the Web Source view:
   - Place your cursor anywhere between the `<rw:graph>` and `</rw:graph>` tags, then choose Edit > Settings to re-enter the Graph Wizard.

   **Note:** Any manual changes and additions you’ve made to the graph XML will be lost if you click Finish, which redefaults the graph to the definition in the Graph Wizard.

   - Delete and re-create the graph as follows:
     1. Delete all lines from the `<rw:graph>` tag to the `</rw:graph>` tag.
     2. Leaving the cursor in the position where the graph was cut, choose Insert > Graph and follow the Graph Wizard to re-create the graph.
     - Between the `<rw:graph>` and `</rw:graph>` tags that define the graph, make changes directly to the JSP and XML tags. This enables you to customize your graph XML definition beyond the scope of the Graph Wizard. The full list of attributes available is defined in the DTD file, `graph.dtd`.

   **Note:** Any manual changes and additions you’ve made to the graph XML will be lost if you click Finish, which redefaults the graph to the definition in the Graph Wizard.

   - The `graph.dtd` is available in the following locations:
     - `ORACLE_HOME\jlib\bigraphbean.jar`
     - In Getting Started with Oracle Reports on the Oracle Technology Network (OTN): on the Oracle Reports page (http://www.oracle.com/technetwork/middleware/reports/overview/index.html), navigate to Learn More and click Getting Started to display the Getting Started with Oracle Reports home page. In the list of topic sections on the left, click Index. In the Collateral Type list, choose Documentation and click Search. In the list that displays, find the Documented Graph DTD.
4.9.8.4 Adding a graph hyperlink

You can add a graph hyperlink to a graph in your paper-based Web report (output to PDF or HTML), or JSP-based Web report. When end users display the report on the Web, they can click the areas of the graph to drill down to additional linked information.

To add a graph hyperlink to a graph, follow the steps in either of the following topics:

- Adding a graph hyperlink to a paper-based report
- Adding a graph hyperlink to a JSP-based Web report

See also

Section 2.2.6, "About graph hyperlinks"
Section 1.4.4, "About Graphs and the Graph Wizard"
Section 1.6.6, "About the Web Source view"

4.9.8.4.1 Adding a graph hyperlink to a paper-based report

For a paper-based Web report (for HTML or PDF output), you can add a graph hyperlink to a graph in either of the following ways:

- Property Inspector
- Graph Wizard

To specify a graph hyperlink in a paper-based report using the Property Inspector:

1. In the Paper Layout view, display the Property Inspector for the graph.
2. Set the Graph Hyperlink property to a hyperlink from any graph section to any object in your report output, another report, or any valid hyperlink destination.
   Examples:
   - A hyperlink from any graph section to any object in your report:
     `#&<dept_id>`
   - A hyperlink to another report:
     `http://my_machine:8888/reports/myWebApp/Dept_Detail.jsp?p_deptid=&<deptid>+...`
   - A hyperlink to any valid hyperlink destination:
     `www.oracle.com`

To specify a graph hyperlink in a paper-based report using the Graph Wizard:

1. On the Define Hyperlink panel, use the examples shown on the panel to enter a hyperlink value to link areas of the graph to specified destinations.
2. Click Finish.

After you have defined the graph hyperlink, generate your report to HTML, HTMLCSS, or PDF to test the graph hyperlinks. Refer to Section 4.7.5, "Generating HTML or HTMLCSS output" and Section 4.7.6, "Generating PDF output".

4.9.8.4.2 Adding a graph hyperlink to a JSP-based Web report

To add a graph hyperlink to a graph in a JSP-based Web report:

- In the Web Source view of your report, modify the `<rw:graph>` JSP tag to include the `graphHyperlink` attribute.
For example:

```
graphHyperlink="http://my_machine:8888/reports/myWebApp/Dept_Detail.jsp? userid=hr/hr@mydb+server=myserver+p_deptno=&<deptno>
```

After you have defined the graph hyperlink, click the Run Web Layout button in the toolbar (or choose Program > Run Web Layout) to display your report and graph in your Web browser, and click the graph hyperlinks to test them.

### 4.9.8.5 Creating a drawing object

To create a drawing object:

1. In the Paper Layout view, click a drawing tool in the tool palette (for example, Rectangle, Ellipse, Polyline, and so on).
2. To create a line, rounded rectangle, rectangle, ellipse, arc, or freehand object, click in the main area (canvas region) of the window and drag to create the object.
3. To create a polygon or polyline, click in the main area (canvas region) of the window where you want each point of the object, then double-click to create the object.
4. To draw constrained objects (that is, perfect circles and squares, and so on), hold down the constrain key (for example, the shift key) when drawing the graphic.
5. Double-click the drawing object.
6. In the Property Inspector, set the desired properties.

### 4.9.9 Page or Group Headers or Footers

This section provides procedures for the following tasks that you may perform as you work with page or group headers or footers:

- Creating a text heading
- Creating a heading that includes database values
- Creating a group header or footer

#### 4.9.9.1 Creating a text heading

To create an object or heading in the margin of a report:

1. In the Paper Layout view, click the Edit Margin button in the toolbar.

---

**Note:** The margin area is defined by a thick black line that separates it from the body. If you create objects in the body portion of a report while displaying the margin area, you can only edit those objects when the margin is displayed.

2. To adjust the margin, click the margin border, then drag a handle to the desired position. You can adjust the margin on all four sides of a report.
3. Create required objects in the margin area. They will appear on all pages of the report.
4. Click the Header Section, Main Section, or the Trailer Section buttons in the toolbar to reactivate the appropriate section of the body area of the report.
4.9.9.2 Creating a heading that includes database values

To create a heading that includes database values:

2. On the Totals page, create any totals that you want to include in the heading.
   
   **Note:** Any totals that you intend to place in the margin area of your report must be report-level totals. Group totals (for example, the total for a department) placed in the margin will cause a frequency error when you run your report.

3. On the Fields page, verify that the fields and totals you want to include in the heading are either available or displayed in the report.
4. In the Paper Layout view, click the Margin button in the toolbar.
   
   **Note:** The margin area is defined by a thick black line that separates it from the body. If you create objects in the body portion of a report while displaying the margin area, you can only edit those objects when the margin is displayed.

5. For any values that require a format mask, create a hidden field object in the margin area (see Section 4.9.1.1, "Creating a field object"):
   - In the Property Inspector, under the Field node, set the Source property to the source column for the value, set the Visible property to No, and set the Format Mask property as desired.
   - Under the General Layout node, set the Horizontal Elasticity property to Variable.
   
   **Note:** If you do not need to specify a format mask, you can simply reference the value directly in Step 6, and you do not need to create this hidden field.

6. Create a boilerplate text object in the margin area, and reference the field or report-level totals you want to include in the heading. See Section 4.9.2.1, "Creating a boilerplate object for text" and Section 4.9.2.5, "Referencing a field in boilerplate text".

**See also**
The example report in Chapter 17, "Building a Header with Database Values Report".

4.9.9.3 Creating a group header or footer

To create a header or footer above or below each group of records:

1. In the Paper Layout view, click the Confine Off button and the Flex On button in the toolbar.
2. Click frame that encloses the repeating frame for the group to which you want to add a header or footer, then drag and resize the frame to allow enough room to type the header or footer text.
3. Create a boilerplate text object for the header or footer text (see Section 4.9.2.1, "Creating a boilerplate object for text").

4.9.10 Margin, Header Page, or Trailer Page Objects

This section provides procedures for the following tasks that you may perform as you work with margin, header page, or trailer page objects:

- Creating a margin object
- Creating a header page or trailer page object

4.9.10.1 Creating a margin object

To create an object or heading in the margin of a report:

1. In the Paper Layout view, click the Edit Margin button in the toolbar.

2. To adjust the margin, click the margin border, then drag a handle to the desired position. You can adjust the margin on all four sides of a report.

3. Create required objects in the margin area. They will appear on all pages of the report.

4. Click the Header Section, Main Section, or the Trailer Section buttons in the toolbar to reactivate the appropriate section of the body area of the report.

4.9.10.2 Creating a header page or trailer page object

With report sectioning, Header and Trailer pages are identical to Body pages. In effect, this means that the Header, Trailer, and Body are three sections of a report. The names of the sections are exposed under the Paper Design node in the Object Navigator as Header Section, Main Section, and Trailer Section. You can use the margin and body of the Header and Trailer sections to create a Header and Trailer "page" as in earlier releases of Oracle Reports.

1. In the Paper Layout view, click the Confine Off button and the Flex On button in the toolbar.

2. Click the repeating frame for the page, then drag and resize the frame to allow enough room to type the header or footer text.

3. Create a boilerplate text object for the header or footer text.
4.9.11 Move Objects

This section provides procedures for the following tasks that you may perform as you move your report objects:

- Moving multiple objects
- Moving an object outside its parent
- Adjusting parent borders automatically
- Moving a column in report output
- Offsetting detail objects in a group report
- Aligning objects
- Changing object layering
- Rotating a boilerplate object

4.9.11.1 Moving multiple objects

To move multiple objects:

1. Click or drag a box around the objects you want to move.

   **Tip:** To select multiple objects, click one object, then Shift-click all other objects. To select all objects, choose Edit > Select All.

2. Use the arrow keys on your keyboard to move the objects in the desired direction.

   See also
   Section 2.4.7, "About moving and layering objects in the Paper Layout view"

4.9.11.2 Moving an object outside its parent

To move a child object outside its enclosing parent object:

1. In the Paper Layout view or Paper Design view, click the Confine Off button in the toolbar.

2. Click and drag the child object(s) as desired.

   **Tip:** To select multiple objects, click one object, then Shift-click all other objects. To select all objects, choose Edit > Select All.

   See also
   Section 2.4.7, "About moving and layering objects in the Paper Layout view"

4.9.11.3 Adjusting parent borders automatically

To adjust parent borders as you move child objects:

1. In the Paper Layout view, click the Flex On button in the toolbar.

2. Click and drag the child object(s) as desired.
3. To move an object that aligns with another object in the horizontal or vertical direction (for example, a field and its label), hold down the Ctrl key as you drag the first object. To move both objects simultaneously, do not use the Ctrl key.

See also
Section 2.4.6, "About resizing objects"

4.9.11.4 Moving a column in report output
To move a column in report output:
1. In the Paper Layout view or Paper Design view, click the column.
2. Click the Flex On button in the toolbar.
3. Drag the column to the desired position.

See also
Section 2.4.7, "About moving and layering objects in the Paper Layout view"
Chapter 4.9.13.1, "Changing columns labels or widths"
Chapter 4.9.13.3, "Changing the default layout spacing"

4.9.11.5 Offsetting detail objects in a group report
To offset the detail fields in a group above or group left report:
1. In the Paper Design view, click the Flex On button in the toolbar.
2. Select the detail objects and move them to the right.
3. Click the Flex Off button in the toolbar.

See also
Section 1.3.2, "About group above reports"
Section 1.3.3, "About group left reports"

4.9.11.6 Aligning objects
To align objects:
1. Click the objects you want to align.
   
   Tip: To select multiple objects, click one object, then Shift-click all other objects. To select all objects, choose Edit > Select All.

2. Choose Layout > Alignment.
3. In the Align Objects dialog box, specify the desired alignment.
4. Click OK.
**See also**
Section 2.4.7, "About moving and layering objects in the Paper Layout view"

### 4.9.11.7 Changing object layering

To change the order in which objects are layered on top of each other:

1. In the Paper Layout view, click the Confine Off button in the toolbar.
2. Click the object you want to move.
3. Choose one of the following items from the *Arrange* menu:
   - **Bring to Front** to move the object in front of all other objects.
   - **Send to Back** to move the object behind all other objects.
   - **Move Forward** to move the object in front of the object directly on top of it.
   - **Move Backward** to move the object behind the object directly underneath it.

**See also**
Section 2.4.7, "About moving and layering objects in the Paper Layout view"

### 4.9.11.8 Rotating a boilerplate object

You can only rotate boilerplate text and graphics. You cannot rotate other layout objects (repeating frames or fields).

To rotate a boilerplate object:

1. Click the object(s) that you want to rotate.
2. Click the Rotate tool in the tool palette.
3. Drag a handle to rotate the object or group.

**See also**
Section 1.8.5, "About boilerplate objects"

### 4.9.12 Resize Objects

This section provides procedures for the following tasks that you may perform as you resize your report objects:

- **Resizing objects**
- **Making multiple objects the same size**
- **Resizing object borders**

#### 4.9.12.1 Resizing objects

To resize one or more objects:

1. Click the object(s) that you want to resize.
2. Set the size:
   - For a fixed size, drag the handle of one of the selected objects. All selected objects will change size accordingly.
   - Or, choose Tools > Property Inspector. In the Property Inspector, under the General Layout node, set the Vertical Elasticity and Horizontal Elasticity properties to Contract, Expand, Fixed, or Variable.

See also
Section 2.4.6, "About resizing objects"
Section 1.8.3, "About frame and repeating frame sizing"

4.9.12.2 Making multiple objects the same size
To make multiple objects the same size:
1. Click the objects you want to size.

   **Tip:** To select multiple objects, click one object, then Shift-click all other objects. To select all objects, choose Edit > Select All.

2. Choose Layout > Size Objects.
3. In the Size Objects dialog box, specify the desired settings. Click OK.

4.9.12.3 Resizing object borders
See Section 4.9.11.3, "Adjusting parent borders automatically".

4.9.13 Change Spacing
This section provides procedures for the following tasks that you may perform as you change spacing between your report objects:

- Changing columns labels or widths
- Changing spacing within a text object
- Changing the default layout spacing
- Changing the spacing between all rows
- Adding blank lines between groups of rows

4.9.13.1 Changing columns labels or widths
To change column labels or widths:
2. In the Report Wizard, click the Labels tab.
3. Change the values in the Labels and Width columns, as desired.
4. Click Apply.
See also

Chapter 4.9.11.4, "Moving a column in report output"

4.9.13.2 Changing spacing within a text object
To change spacing within a text object:

1. In the Paper Design view, click the object(s).

Tip: To select multiple objects, click one object, then Shift-click all other objects. To select all objects, choose Edit > Select All.

2. Choose Format > Text Spacing and select the desired spacing for the text object.

4.9.13.3 Changing the default layout spacing
To change the default layout spacing used by the Report Wizard when defaulting the report layout:

1. Choose Tools > Preferences.
2. In the Preferences dialog box, click the Wizards tab.
3. To increase the space between objects and the objects they enclose, type larger values for Horizontal Gap and Vertical Gap.
4. To increase the space between fields, type larger values in Horizontal Interfield and Vertical Interfield.
5. Click OK to close the Preferences dialog box.
6. For smaller spacings, choose View > Snap to Grid to toggle this setting off (no checkmark). When Snap to Grid is set on, defaulting the layout honors the layout spacing values, but then snaps to the closest grid point; the result may be that smaller changes to these values are not evident in the report output.

See also

Chapter 4.9.11.4, "Moving a column in report output"

4.9.13.4 Changing the spacing between all rows
To change the spacing between all rows using the Paper Design view:

1. In the Paper Design view, click the second record.
2. Drag the second record down to create the desired spacing between all rows in the report output.

To change the spacing between all rows using the Property Inspector:

1. In the Paper Design view, click any field in the body of the report.
2. Click the Select Parent Frame button in the toolbar.
4. Under the Repeating Frame node, set the Vert. Space Between Frames (inches) property to the amount of blank space in inches to leave between row in the report output (for example, 0.25).
4.9.13.5 Adding blank lines between groups of rows

To add blank lines between groups of rows:

1. Create a summary column (see Section 4.8.11, "Creating a summary column"). On the Totals page of the Data Wizard (or Report Wizard), select any field that appears in each row of output, and Count as the calculation. On the Fields page, remove the summary from the displayed fields column.

2. Create a user parameter named SPACE (see Section 4.11.2, "Creating a user parameter"). In the Property Inspector, under the Parameter node, set the Datatype property to Number and the Initial Value property to the number of records you want in each group (for example, 5).

3. In the Paper Layout view, click the Flex On and Confine Off buttons in the toolbar.

4. Click the repeating frame for the group, then drag the handle on the bottom of the frame to create a space slightly larger than the space you want to add between groups of rows in the report output.

5. Choose Tools > Property Inspector to display the Property Inspector for the repeating frame.

6. Under the General Layout node, set the Vertical Elasticity property to Variable.

7. Click the Rectangle tool in the tool palette.

8. Draw a rectangle in the space under the record.

9. Double-click the rectangle object.

10. In the Property Inspector, under the Advanced Layout node, double-click the Format Trigger property value to display the PL/SQL Editor.

11. In the PL/SQL Editor, define the PL/SQL for the format trigger. For example, the following PL/SQL code inserts blank space between groups of rows (displays a boilerplate rectangle when the row count divided by the value of SPACE leaves no remainder):

   ```plsql
   function spacing return BOOLEAN is
   begin
     if :CountENAMEPerReport MOD :SPACE = 0 then
       return (true);
     else
       return (false);
     end if;
   end;
   ```

12. Hide the rectangle object:
   - On the Fill Color palette, click No Fill.
   - On the Line Color palette, click No Line.

4.9.14 Modify the Page Layout

This section provides procedures for the following tasks that you may perform as you modify the page layout of your report:

- Adjusting margins
- Adding a page break
4.9.14.1 Adjusting margins
To adjust margins:

1. In the Paper Layout view, click the Edit Margin button in the toolbar.

   Note: The margin area is defined by a thick black line that separates it from the body. If you create objects in the body portion of a report while displaying the margin area, you can only edit those objects when the margin is displayed.

2. Click the margin border, then drag a handle to the desired position. You can adjust the margin on all four sides of a report.

4.9.14.2 Adding a page break
To add a page break:

1. In the Paper Layout view, click any field that is part of the frame at which you want to insert a page break.

2. Click the Parent Frame in the toolbar.


4. To set a page break...

   ■ before the selected frame: under the General Layout node, set the Page Break Before property to Yes.

   ■ after the selected frame: under the General Layout node, set the Page Break After property to Yes.

   ■ after a certain number of rows of output on each page: under the Repeating Frame node, set the Maximum Records per Page property to the number of rows you want to display on each page.

5. To display icons that identify where page breaks are set, choose View > Page Breaks in the Paper Layout view.

Usage notes
If you want to set a page break at a specific row of report output, you can create a hidden object (for example, a rectangle with No Fill and No Line) that formats only at the specific row. If you set the Page Break Before property to Yes for the rectangle object, you will get a page break after the row.

4.10 Work with Report Sections
This section provides procedures for the following tasks that you may perform as you work with report sections:

■ Displaying a section layout view

■ Creating a default layout for a section

See also
Section 2.1.2, "About report sectioning and sections"
4.10.1 Displaying a section layout view

To display the layout view for a report section:

- In the Paper Layout view, do either of the following:
  - Choose View > Layout Section, then select the section you want to view and check whether or not you want to view or edit the margin area.
  - In the toolbar, click the Header Section, the Main Section, or Trailer Section buttons to view the Header Section, Main Section, or Trailer Section, respectively; click the Edit Margin button to view or edit the margin area.

4.10.2 Creating a default layout for a section

To create a default layout for a report section:

1. In the Paper Layout view, display the layout view for the section.
3. Follow the wizard to create a default layout for your report.
4. To create a layout or objects in the margin area of a section, click the Edit Margin button in the toolbar to view/edit the margin area.
5. To add another layout section to the current layout, create an additional report layout (see Section 4.5.5, "Creating an additional report layout").
6. Make further modifications to the default layout manually in the Paper Layout view.

Caution: If you re-enter the Report Wizard after making manual adjustments to your layout in the Paper Layout or Paper Design view, you will lose these layout changes when you click Finish in the Report Wizard, which redefaults the layout.

7. Set properties for the section, as desired.

See also
Section 2.4.2, "About layout defaulting"
Section 4.5.4, "Creating a default layout for a report"
Chapter 4.9.13.3, "Changing the default layout spacing"

4.11 Work with Parameters and the Parameter Form

This section provides procedures for the following tasks that you may perform as you work with parameters and the Parameter Form:

- Using a pre-defined system parameter
- Creating a user parameter
- Creating a list of values (LOV) for a parameter
- Validating a parameter value at runtime
- Creating a default Parameter Form
- Selecting parameters to include in the Runtime Parameter Form
Work with Parameters and the Parameter Form

- Displaying the Parameter Form at runtime
- Adding more pages to the Runtime Parameter Form
- Passing parameters to reports running in batch mode
- Creating an HTML Parameter Form header using PL/SQL
- Creating an HTML Parameter Form footer using PL/SQL
- Creating HTML Parameter Form input or select events
- Changing HTML Parameter Form input to uppercase

See also
Section 1.9.1, "About parameters"
Section 2.3.4, "About referencing columns and parameters"
Section 1.6.5, "About the Paper Parameter Form view"
Section 1.11.1, "About the Runtime Parameter Form"
Section 1.9.4, "About Parameter Forms for Web reports"

4.11.1 Using a pre-defined system parameter
To use a system parameter:

1. In the Object Navigator, expand the Data Model node, then expand the System Parameters node.
2. Double-click the properties icon for the desired parameter to display the Property Inspector.
3. Under the Parameter node, set the Initial Value property, if required.
4. To validate the parameter's value at runtime, set the Validation Trigger property by clicking the ... button to display the PL/SQL Editor and define the PL/SQL to be triggered at runtime.

4.11.2 Creating a user parameter

Note: Oracle Reports Builder automatically creates a user parameter when you use a bind parameter reference in a query.

To create a user parameter:

1. In the Object Navigator, expand the Data Model node, then click the User Parameters node.
2. Click the Create button in the toolbar.
3. Double-click the properties icon for the new parameter to display the Property Inspector.
4. Under the General Information node, replace the Name property with the desired parameter name.
5. Under the Parameter node, set the Initial Value and List of Values properties, if required.
6. To validate the parameter’s value at runtime, set the Validation Trigger property by clicking property field to display the PL/SQL Editor and define the PL/SQL to be triggered at runtime.

4.11.3 Creating a list of values (LOV) for a parameter

**Tip:** If you define a parameter in a template, you must apply the template to a report in order to select that parameter for the Runtime Parameter Form.

To create a LOV for a parameter:

1. In the Object Navigator, expand the Data Model node, then the User Parameters node.
2. Double-click the properties icon for the parameter for which you want to create a LOV to display the Property Inspector.
3. Under the Parameter node, double-click the List of Values property field to display the Parameter List of Values dialog box.
4. Select the type of list that you want to create:
   - For Static Values, type a value in the Value text box and click Add. Repeat for each value you want to add. (Click Remove to delete items from the list)
   - For SELECT Statement, type a query to populate the list of values. You can select more than one column to display in the LOV, where the first column contains the value to be assigned to the parameter. The LOV displays columns in the order specified in the query.
5. If you want the parameter value to be restricted to only those in the LOV, select the Restrict List to Predetermined Values check box. To display a combo box that allows users to edit values or type a different value in the Runtime Parameter Form, clear the check box.
6. If you do not want the first column (which contains the parameter value) of your query displayed in the LOV, select the Hide First Column check box. If there is no need to preserve the confidentiality of the first column, clear the check box.

**Caution:** If you send the report output to an HTML file, either from Oracle Reports Builder or running it in your Web browser, the value of the first column will be visible in the HTML source, even if Hide First Column is selected.

If you run the report from a Web browser and the list of values is unrestricted, the HTML Parameter Form will display a text field instead of a combo box, and a list of static values that you can copy and paste into the text field. In this case, the first column will always be shown in the Parameter Form, even if Hide First Column is selected.

7. Click OK.

4.11.4 Validating a parameter value at runtime

To validate a parameter value at runtime:
1. In the Object Navigator, expand the Data Model node, then the System Parameters or User Parameters node.

2. Double-click the PL/SQL icon for the parameter for which you want to add a PL/SQL validation trigger.

3. In the PL/SQL Editor, define the PL/SQL to be triggered at runtime.

**See also**

Section 2.6.13.3, "About validation triggers"

### 4.11.5 Creating a default Parameter Form

To create a default Parameter Form:

1. Choose **Tools > Parameter Form Builder**.

2. Click **OK** to display the Paper Parameter Form view with the default Parameter Form.

### 4.11.6 Selecting parameters to include in the Runtime Parameter Form

To select parameters to include in the Runtime Parameter Form:

1. Choose **Tools > Parameter Form Builder**.

2. In the Parameter Form Builder, click the parameters you want to include in the Runtime Parameter Form.

3. Modify the parameter labels as desired.

4. Click **OK** to display the Paper Parameter Form view.

### 4.11.7 Displaying the Parameter Form at runtime

To display the Runtime Parameter Form when you run your report:

1. Choose **Edit > Preferences** to display the Preferences dialog box.

2. On the Runtime Settings page, make sure that the Parameter Form check box is selected.

**Note:** The Parameter Form can be used only for paper reports. If you display your paper-based report on the Web, you can create an HTML Parameter Form by adding HTML header and footer tags (using either the Before Form Value property and After Form Value property or the SRW.SET_BEFORE_FORM_HTML and SRW.SET_AFTER_FORM_HTML procedures). However, if you design a JSP-based Web report with a Parameter Form in Oracle Reports Builder, be aware that Web reports that use JSPs do not support the display of the Runtime Parameter Form at runtime. For more information, see Section 1.9.4, "About Parameter Forms for Web reports".

### 4.11.8 Adding more pages to the Runtime Parameter Form

To add more pages to the Runtime Parameter Form:

1. In the Object Navigator, double-click the properties icon next to the report name.
2. In the Property Inspector, under the Parameter Form Window node, set the Number of Pages property as desired.

### 4.11.9 Passing parameters to reports running in batch mode

To pass parameters (for example, data ranges) to reports running in batch mode:

- Use bind variables in your query to restrict the query, and use the command line parameters to pass the values to the query. For example:

  **Query:**
  ```sql
  SELECT * FROM EMP WHERE HIREDATE BETWEEN :FROM_DATE AND :END_DATE
  ```

  **Runtime:**
  ```
  RWRUN REP1 SCOTT/TIGER FROM_DATE='12-JUN-92'
  END_DATE='24-JUN-92'
  ```

### 4.11.10 Creating an HTML Parameter Form header using PL/SQL

See [Section 4.6.10.2.5, "Creating an HTML Parameter Form header using PL/SQL"](##)

### 4.11.11 Creating an HTML Parameter Form footer using PL/SQL

See [Section 4.6.10.2.6, "Creating an HTML Parameter Form footer using PL/SQL"](##)

### 4.11.12 Creating HTML Parameter Form input or select events

To create an HTML Parameter Form field with input or select events:

1. In the Object Navigator, double click the view icon next to the Paper Parameter Form node to display the Paper Parameter Form view.
2. Create or edit a Parameter Form field (see [Section 4.9.1.1, "Creating a field object"](##)).
3. Double-click the field object to display the Property Inspector.
4. Under Web Settings, set the Additional Attributes (HTML) property to a valid JavaScript event handler.

**Note:** In some cases, for example, when raising messages it may be necessary to type JavaScript code in the Before Form trigger.

To insert the JavaScript code in the Before Form trigger:

1. In the Object Navigator, double-click the properties icon next to the report name to display the Property Inspector.
2. Under Report Escapes, set the Before Form Type property to Text (if you will type the Javascript) or File (if you will import the JavaScript from a file).
3. Set the Before Form Value property by clicking the ... button to either type JavaScript in the dialog box or select an HTML file with the JavaScript to import.

**Example 1: Data input validation**

This example shows how to set Parameter Form fields for input validation when the report is run through with the Web. Doing so will raise a message whenever an end user enters invalid data in the Parameter Form field.
1. In the Paper Parameter Form view, create a Parameter Form field called PF_DEPTNO.

2. Double-click the field object to display the Property Inspector, and set the following properties:
   - Under Parameter Form Field, set the Source property to DEPTNO.
   - Under Web Settings, set the Additional Attributes (HTML) property to the following JavaScript event handler:
     ```javascript
     onChange="checkIt(this.form)"
     ```

3. In the Object Navigator, click (the properties icon) next to your report name to display the Property Inspector, and set the following properties:
   - Under Report Escapes, set the Before Form Type property to Text.
   - Set the Before Form Value property the following JavaScript code:
     ```javascript
     function isNumber(inputStr) {
       for (var i = 0; i < inputStr.length; i++) {
         var oneChar = inputStr.charAt(i);
         if (oneChar < "0" || oneChar > "9") {
           alert("Please enter a numeric value.");
           return false
         }
       }
       return true
     }
     function checkIt(form) {
       inputStr = form.DEPTNO.value;
       if (isNumber(inputStr)) {
         // statements if true
       } else {
         form.numeric.focus();
         form.numeric.select();
       }
     }
     </SCRIPT>
     ```

At runtime, if the end user enters the department name in the Runtime Parameter Form rather than the department number when running the report through the Web, the following message is raised:

Please enter a numeric value.

**Example 2: Select validation**

This example shows you how to set Parameter Form fields for select validation when the report is run through the Web. Doing so will raise a message whenever an end user selects Printer from the DESTYPE list of values in the Runtime Parameter Form.

1. In the Paper Parameter Form view, create a Parameter Form field called PFDESTYPE.

2. Double-click the field object to display the Property Inspector, and set the following properties:
   - Under Parameter Form Field, set the Source property to DESTYPE.
Under **Web Settings**, set the Additional Attributes (HTML) property to the following JavaScript event handler:

```javascript
onChange="isPrinter(this.form)"
```

3. In the Object Navigator, click (the properties icon) next to your report name to display the Property Inspector, and set the following properties:

- **Under Report Escapes**, set the Before Form Type property to Text.
- **Set the Before Form Value property** with the following JavaScript code:

```javascript
<SCRIPT LANGUAGE = "JavaScript">
function isPrinter(form) {
if( form.DESTYPE.options[form.DESTYPE.selectedIndex].value == 'Printer')
   alert("Please be sure that your print is installed and running.")
   return true
}
</SCRIPT>
```

At runtime, if the end user selects PRINTER from a list of values in the DESTYPE field, the following message is raised:

Please be sure that your print is installed and running.

**See also**

Section 2.5.1, "About Parameter Form HTML extensions"

### 4.11.13 Changing HTML Parameter Form input to uppercase

To change data input values default to uppercase upon entry in a Parameter Form field:

1. Choose **Tools > Parameter Form Builder**.
2. In the Parameter Form Builder, create a Parameter Form field called PF_DESFORMAT, with a source of DESFORMAT.
3. Choose **Tools > Property Inspector**.
4. In the Property Inspector, under Web Settings, set the Additional Attributes (HTML) property to:

```javascript
onChange="this.value=this.value.toUpperCase()"
```

**Example: Default input to uppercase**

This example specifies that data input values default to uppercase upon entry in a Parameter Form field.

1. In the Paper Parameter Form view, create a Parameter Form field called PF_DESTYPE.
2. Double-click the field object to display the Property Inspector, and set the following properties:

- **Under Parameter Form Field**, set the Source property to DESFORMAT.
- **Under Web Settings**, set the Additional Attributes (HTML) property to the following JavaScript event handler:

```javascript
onChange="this.value=this.value.toUpperCase()"
```
At runtime, if the end user enters pdf as the destination format, the value will change to uppercase (that is, PDF) in the Runtime Parameter Form when running the report through the Web.

4.12 Define a Template

This section provides procedures for the following tasks that you may perform as you define a report template:

- Creating a template
- Defining default template attributes
- Defining override template attributes
- Applying a template to a report
- Formatting the report title in a template
- Modifying the color, pattern, or border of body objects in a template
- Adding a template to the pre-defined templates list

4.12.1 Creating a template

To create a template:

1. In the Object Navigator, click the Templates node, then click the Create button in the toolbar.
2. Define default template attributes for all report styles.
3. Optionally, define override template attributes for a selected report style.
4. To define system parameters, user parameters, report triggers, program units, and attached libraries for the template, double-click the associated nodes in the Object Navigator.

See also
Section 2.7.5, "About the Template Editor"
Section 2.7.1, "About templates"
Section 2.7.2, "About template attributes"
Section 2.7.3, "About applying templates"
Section 2.7.4, "About inheritance in templates"

4.12.2 Defining default template attributes

To define default attributes for report objects in a template that applies to all report styles:

1. In the Object Navigator, expand the Templates node, then the Paper Layout node, then the Section node, then the Body node, then the Default node.
2. To change default properties for the overall layout and spacing for report styles, double-click the properties icon next to the Default node to display the Property Inspector.
3. To change default properties for frames, field labels/headings, fields, summary labels, and summaries (totals), fully expand the Default node, then double-click the properties icons to display the Property Inspector.
4. In the Paper Layout view, select from the Report Style list to view the layout for individual report styles.

5. To make further changes for the currently displayed report style, either return to the Object Navigator, or double-click an object to display the Property Inspector.

---

**Note:** Any changes you make for an individual report style will override the attributes defined under the Default node.

---

**See also**

Section 2.7.1, "About templates"

Section 2.7.2, "About template attributes"

### 4.12.3 Defining override template attributes

To define override attributes for a selected report style:

1. In the Object Navigator, expand the Templates node, then the Paper Layout node, then the Section node, then the Body node, then the Override node, then the node for the report style for which you want to define overrides (for example, Tabular, Group Left).

2. To change default properties for the overall layout and spacing for a section of the selected report style, double-click the properties icon next to the Section (Level n) node to display the Property Inspector.

3. To create more than the default number of sections for a particular report style, click a Section (Level n) node, then click the Create button in the toolbar.

   **Note:** Sections are mapped to groups in a report. For more information, see About template attributes.

4. To delete a section for a particular report, click a Section (Level n) node, then click the Delete button in the toolbar.

   **Note:** You can only delete nodes down to the minimum requirement for the current report style.

5. For each section for which you want to define overrides, fully expand the Section (Level n) node, then double-click the properties icons to display the Property Inspectors for the frames, field labels/headings, fields, summary labels, and summaries (totals).
6. In the Paper Layout view, select from the Report Style list to view the layout for individual report styles.

7. To make further changes for the currently displayed report style, either return to the Object Navigator, or double-click an object to display the Property Inspector.

Note: Any changes you make for an individual report style will override the attributes defined under the Default node.

See also
Section 2.7.1, "About templates"
Section 2.7.2, "About template attributes"

4.12.4 Applying a template to a report

To apply a template to a report:

1. In the Object Navigator, click the report or report section to which you want to apply a template.

Note: If you select the node for the entire report in the Object Navigator, the template will be applied to the Main section of the report by default. To apply the template to a specific section of your report, select the node for that section in the Object Navigator.


3. On the Template page, select a pre-defined template, or click Template file, and click Browse to open the desired template.

4. Click Finish to apply the template to the current report section.

See also
Section 2.7.1, "About templates"
Section 2.7.3, "About applying templates"

4.12.5 Formatting the report title in a template

To set default attributes (such as font and color) for the title in a selected template:

1. In the Object Navigator, expand the Templates node, then the Paper Layout node, then the Section node, then the Body node, then the Default node.

2. Double-click the properties icon next to the Default node to display the Property Inspector.

3. Under Title, modify the properties as desired.
To set the placement and override attributes (such as font and color) for the title in a selected template:

1. In the Paper Layout view of the template, create a boilerplate text object for the title in the margin.
2. Size and position the title, and modify the color and text attributes as desired.
3. Double-click the title object to display its Property Inspector.
4. Under **General Information**, set the Name property to B_OR$REPORT_TITLE.

**See also**
- Section 2.1.1, "About report titles"
- Section 2.7.1, "About templates"

### 4.12.6 Adding items and objects to a template

To add items and objects to a template:

1. In the Paper Layout view of the Template Editor, click the Margin button in the toolbar to display the margin area.
2. Create objects in the margin of your template. You cannot create objects in the body of a template.

**See also**
- Section 2.7.5, "About the Template Editor"
- Section 2.7.1, "About templates"
- Section 2.7.2, "About template attributes"
- Section 2.7.4, "About inheritance in templates"

### 4.12.7 Modifying objects in the template margin

To modify objects in the margin of a template:

1. In the Paper Layout view of the Template Editor, click the Edit Margin button in the toolbar.
2. Modify objects in the margin of your template.

**See also**
- Section 2.7.5, "About the Template Editor"
- Section 2.7.1, "About templates"
- Section 2.7.2, "About template attributes"
- Section 2.7.4, "About inheritance in templates"

### 4.12.8 Modifying the color, pattern, or border of body objects in a template

Template objects can be modified using the same techniques as report objects. To change the color or pattern of objects in a template, however, you use the template Property Inspector, rather than the Color tools in the tool palette:
Define a Template

- The Fill Pattern property defines the pattern to use for the space enclosed by the objects. You can define the background and foreground colors of the fill pattern using the Foreground Color and Background Color properties.

- The Edge Pattern property defines the pattern to use for the borders of the objects. You can define the background and foreground colors of the edge pattern using the Edge Foreground Color and Edge Background Color properties.

- The Text Color property specifies the text color to use for the object(s).

See also
Section 2.4.5, "About changing colors and patterns"
Section 4.9.6.2, "Changing colors"
Section 4.9.6.3, "Changing patterns"
Section 2.7.1, "About templates"

4.12.9 Adding a template to the pre-defined templates list

To add your own template to the list of predefined templates in the Report Wizard:

1. In a text editor (for example, Wordpad), open the preferences file:

   - On Windows, open $DOMAIN_HOME/config/fmwconfig/components/ReportsToolsComponent/<reports_tools_name>/tools/admin/CAUPREFS.ORA (user preferences) if it exists; otherwise, open $DOMAIN_HOME/config/fmwconfig/components/ReportsToolsComponent/<reports_tools_name>/tools/admin/CAGPREFS.ORA (global preferences).

   - On UNIX, open your_home_directory/prefs.ora (user preferences) if it exists; otherwise, open $DOMAIN_HOME/config/fmwconfig/components/ReportsToolsComponent/<reports_tools_name>/tools/admin/prefs.ora (global preferences).

2. Scroll down to the template descriptions identified by Reports.xxx_Template_Desc (where xxx specifies a report style: Tabular, BreakAbove, BreakLeft, FormLetter, Formlike, MailingLabel, Matrix, MatrixBreak).

3. For each report style for which the template is defined:

   - To the Reports.xxx_Template_Desc list, add the description that you want to appear on the Template page of the Report Wizard.

   - To the corresponding Reports.xxx_Template_File list, add the file name of your template in the same position as the addition you made to the description list.

4. Copy the template file (filename.tdf) to ORACLE_HOME/REPORTS/Templates.

To include a sample image of your template in the Report Wizard:

1. Copy or create the .bmp file you want to use as the image for the template and name it yyyy.bmp, where yyyy is the file name of your template.

2. Copy each .bmp file to ORACLE_HOME/REPORTS/Templates.

See also
Section 2.7.1, "About templates"
Section 2.7.3, "About applying templates"
4.12.10 Creating an HTML template for a report portlet

To create and use an HTML template for a report that can be published on an Oracle Portal page:

- See the How To Create a Report Portlet Template in Getting Started with Oracle Reports white paper, available on the Oracle Technology Network Oracle Reports page (http://www.oracle.com/technetwork/middleware/reports/overview/index.html). Navigate to Learn More and Click Getting Started. In the list of topic sections on the left, click Index. On the Index page, in the Collateral Type list, choose White Papers & How To Documents, and click Search. In the list that displays, click Creating a Report Portlet Template.

See also
Section 2.7.1, "About templates"
Section 2.7.3, "About applying templates"

4.13 Use PL/SQL in a Report or Template

This section provides procedures for the following tasks that you may perform as you use PL/SQL in a report or template:

- Using a built-in package
- Working with the PL/SQL Editor
- Creating or editing report-level or template-level PL/SQL
- Creating or editing an external PL/SQL library
- Compiling and running program units

4.13.1 Using a built-in package

To use a built-in package:

1. Choose Tools > PL/SQL Editor to display the PL/SQL Editor.
2. In the Object Navigator, expand the Built-in Packages node, then the package you want to use.
3. Right-click a procedure, function, or exception and choose Paste Name or Paste Arguments to copy a call to the package into your PL/SQL code.

See also
Section 2.6.12, "About built-in packages"

4.13.2 Working with the PL/SQL Editor

This section provides procedures for the following tasks that you may perform as you work with the PL/SQL Editor:

- Defining PL/SQL
- Searching and replacing text in a program unit
- Editing a program unit
- Inserting syntax into the PL/SQL Editor
4.13.2.1 Defining PL/SQL

To define PL/SQL:

1. In the PL/SQL Editor, type or edit the PL/SQL code for the program unit.
2. Click Compile.
3. If necessary, click an error to navigate to its location in the source code.

   **Tip:** Check for missing semicolons at the end of statements, or misspelled syntax.

4. When the code compiles successfully, click Close.

**See also**
Section 2.6.4, "About program units"

4.13.2.2 Searching and replacing text in a program unit

To search and replace text in a program unit:

1. In the Object Navigator, expand the Program Units node.
2. Double-click the PL/SQL Editor view icon next to the program unit you want to edit.
3. In the PL/SQL Editor, place your cursor where you wish to begin the search.
4. Choose Edit > Find and Replace.
5. In the dialog box, type your search criteria, and, optionally, the replace string. You can supply either a text string or a regular expression for your search text.
6. Click Search.
7. Upon locating an instance of the search criteria, click Replace to replace a single instance, Replace All to replace all instances, or edit the text directly in the PL/SQL Editor.
8. Click Search to proceed to the next instance, or click Cancel to close the dialog box.
9. When you have finished replacing all text in the program unit, click Compile to recompile the program unit.

   **Tip:** If you replace text in multiple program units, you can recompile them all at once when you are finished.

10. When the code compiles successfully, click Close.

   **Tip:** If your edits are extensive, you may want to click Apply to save your changes incrementally, without having to compile.

**See also**
Section 2.6.4, "About program units"
4.13.2.3 Editing a program unit

To edit a program unit:

1. In the Object Navigator, expand the Program Units node.
2. Double-click the PL/SQL Editor view icon for the program unit you want to edit.
3. In the PL/SQL Editor, edit the PL/SQL for the program unit.

See also
Section 2.6.4, "About program units"

4.13.2.3.1 Editing features in the PL/SQL Editor The editing features in the PL/SQL Editor (and Stored PL/SQL Editor) include:

<table>
<thead>
<tr>
<th>Editing Feature</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Automatic indent</td>
<td>When you press the Enter key at the end of a line, the next line is automatically indented.</td>
</tr>
<tr>
<td>Color syntax highlighting</td>
<td>Keywords, comments, strings, and symbols such as := and</td>
</tr>
<tr>
<td>Column and line selection</td>
<td>You can select columns of text as well as lines of source code. To select a column, press the ALT key, then click and drag horizontally. To select a line, click the extreme left margin of the line in the Source pane.</td>
</tr>
<tr>
<td>Drag and drop text manipulation</td>
<td>Selected text may be copied or moved by dragging and dropping. To copy text, press the CTRL key and drag the selected text. To move text, simply drag the selected text.</td>
</tr>
<tr>
<td>Indent/Outdent lines</td>
<td>The Indent/Outdent commands on the Edit menu enable you to indent or outdent selected source lines.</td>
</tr>
<tr>
<td>Multiple split views</td>
<td>You can create up to four separate views of the current program unit. To create horizontal views, place the cursor on the split bar at the top of the vertical scroll bar. Then click and drag the split bar down. To create vertical views, place the cursor on the split bar at the far left of the horizontal scroll bar. Then click and drag the split bar to the right. To remove a horizontal or vertical view, double-click the split bar that separates the views.</td>
</tr>
<tr>
<td>Printing</td>
<td>Choose File &gt; Print to print the current program unit.</td>
</tr>
<tr>
<td>Unlimited undo/redo</td>
<td>The Undo/Redo commands on the Edit menu enable you to undo or redo changes as far back as the last save operation.</td>
</tr>
</tbody>
</table>

Note: These features are available in Microsoft Windows only. On UNIX, you can print the current program unit, and you can use TAB/Shift-TAB to indent/outdent selected lines.
4.13.2.3.2 Using the keyboard in the PL/SQL Editor  The following keyboard actions are supported when using the PL/SQL Editor (and Stored PL/SQL Editor) in Microsoft Windows and UNIX:

<table>
<thead>
<tr>
<th>To do the following</th>
<th>Use Keystroke</th>
<th>On Platform</th>
</tr>
</thead>
<tbody>
<tr>
<td>Move cursor left one character</td>
<td>Left arrow key</td>
<td>Windows and UNIX</td>
</tr>
<tr>
<td>Select character as cursor moves left</td>
<td>Shift + Left arrow key</td>
<td>Windows and UNIX</td>
</tr>
<tr>
<td>Move cursor right one character</td>
<td>Right arrow key</td>
<td>Windows and UNIX</td>
</tr>
<tr>
<td>Select character as cursor moves right</td>
<td>Shift + Right arrow key</td>
<td>Windows and UNIX</td>
</tr>
<tr>
<td>Copy selected characters or words</td>
<td>Ctrl + C</td>
<td>Windows and UNIX</td>
</tr>
<tr>
<td>Cut selected characters or words</td>
<td>Ctrl + X</td>
<td>Windows and UNIX</td>
</tr>
<tr>
<td>Paste from the clipboard</td>
<td>Ctrl + V</td>
<td>Windows and UNIX</td>
</tr>
<tr>
<td>Delete character on the right of current cursor position</td>
<td>Delete key</td>
<td>Windows and UNIX</td>
</tr>
<tr>
<td>Delete character on the left of current cursor position</td>
<td>Backspace</td>
<td>Windows and UNIX</td>
</tr>
<tr>
<td>Move cursor to the end of the program unit</td>
<td>Ctrl + End</td>
<td>Windows</td>
</tr>
<tr>
<td>Move cursor to the start of the program unit</td>
<td>Ctrl + Home</td>
<td>Windows</td>
</tr>
<tr>
<td>Select source lines from the current cursor position to the end of the program unit</td>
<td>Ctrl + Shift + End</td>
<td>Windows</td>
</tr>
<tr>
<td>Select source lines from the current cursor position to the start of the program unit</td>
<td>Ctrl + Shift + Home</td>
<td>Windows</td>
</tr>
<tr>
<td>Move cursor to the end of current line</td>
<td>End</td>
<td>Windows</td>
</tr>
<tr>
<td>Move cursor to the start of current line</td>
<td>Home</td>
<td>Windows</td>
</tr>
<tr>
<td>Select characters from the current cursor position to the end of the current line</td>
<td>Shift + End</td>
<td>Windows</td>
</tr>
<tr>
<td>Select characters from the current cursor position to the start of the current line</td>
<td>Shift + Home</td>
<td>Windows</td>
</tr>
</tbody>
</table>
### Table 4–8 (Cont.) Using the keyboard in the PL/SQL Editor

<table>
<thead>
<tr>
<th>To do the following</th>
<th>Use Keystroke</th>
<th>On Platform</th>
</tr>
</thead>
<tbody>
<tr>
<td>Indent selected line, or indent characters on the right of current cursor position</td>
<td>Tab Key</td>
<td>Windows and UNIX</td>
</tr>
<tr>
<td>Outdent selected line</td>
<td>Shift + Tab key</td>
<td>Windows and UNIX</td>
</tr>
<tr>
<td>Move cursor down one line</td>
<td>Down arrow key</td>
<td>Windows and UNIX</td>
</tr>
<tr>
<td>Select line as cursor moves down</td>
<td>Shift + Down arrow key</td>
<td>Windows and UNIX</td>
</tr>
<tr>
<td>Move cursor up one line</td>
<td>Up arrow key</td>
<td>Windows and UNIX</td>
</tr>
<tr>
<td>Select line as cursor moves up</td>
<td>Shift + Up arrow key</td>
<td>Windows and UNIX</td>
</tr>
<tr>
<td>Scroll down the program unit by the number of lines that are shown in the Source pane</td>
<td>PageDown key</td>
<td>Windows and UNIX</td>
</tr>
<tr>
<td>Scroll down the program unit by the number of lines that are shown in the Source pane and select the lines at the same time</td>
<td>Shift + PageDown key</td>
<td>Windows and UNIX</td>
</tr>
<tr>
<td>Scroll up the program unit by the number of lines that are shown in the Source pane</td>
<td>PageUp key</td>
<td>Windows and UNIX</td>
</tr>
<tr>
<td>Scroll up the program unit by the number of lines that are shown in the Source pane and select the lines at the same time</td>
<td>Shift + PageUp key</td>
<td>Windows and UNIX</td>
</tr>
<tr>
<td>Undo most recent action</td>
<td>Ctrl + Z</td>
<td>Windows</td>
</tr>
<tr>
<td>Revert most recent undo action</td>
<td>Ctrl + Y</td>
<td>Windows</td>
</tr>
</tbody>
</table>

#### 4.13.2.3.3  Using the mouse in the PL/SQL Editor

The following table describes the mouse actions that are supported when using the PL/SQL Editor (and Stored PL/SQL Editor) in Microsoft Windows:

### Table 4–9  Using the mouse in the PL/SQL Editor

<table>
<thead>
<tr>
<th>To do the following</th>
<th>Use mouse action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Select characters in a range</td>
<td>Click and drag the cursor from the first character to the last character in the range you wish to select. (also supported in UNIX) or... Click the first character, then press the <strong>Shift</strong> key, and click the last character in the range you wish to select.</td>
</tr>
</tbody>
</table>
4.13.2.4 Inserting syntax into the PL/SQL Editor

To copy syntax into the PL/SQL Editor:

1. Make sure the PL/SQL Editor or Stored PL/SQL Editor is the current (most recently selected) window.

2. Place the cursor in the editor where you want to insert the syntax, then choose Tools > Syntax Palette.

3. In the Syntax Palette, click the PL/SQL tab or the Built-ins tab.

4. Choose a PL/SQL category or a built-in package from the list.

When you click a category or a package, the PL/SQL language elements or PL/SQL constructs that are available for selection appear in the list area below.

---

**Table 4–9 (Cont.) Using the mouse in the PL/SQL Editor**

<table>
<thead>
<tr>
<th>To do the following</th>
<th>Use mouse action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Select word under cursor</td>
<td>Double-click the word. (also supported in UNIX) or... Press the Ctrl key, then click the word you wish to select.</td>
</tr>
<tr>
<td>Select words in a range</td>
<td>Press the Ctrl key, then click and drag the cursor from the first word to the last word in the range you wish to select.</td>
</tr>
<tr>
<td>Select a line</td>
<td>Place the cursor on the left margin of the line you wish to select. Click when the cursor changes to an arrow.</td>
</tr>
<tr>
<td>Select multiple lines</td>
<td>Place the cursor on the left margin of the first line you wish to select. When the cursor changes to an arrow, click and drag the cursor to the last line you wish to select.</td>
</tr>
<tr>
<td>Select columns of text</td>
<td>Press the Alt key, then click and drag the cursor from the first column to the last column in the range you wish to select.</td>
</tr>
<tr>
<td>Move selected text</td>
<td>Select the text first. Then click and drag the selected text to its new position.</td>
</tr>
<tr>
<td>Copy selected text</td>
<td>Select the text first. Then press the Ctrl key, and drag the selected text to the location where you want to place a copy and release the mouse.</td>
</tr>
<tr>
<td>Split window into two horizontal views</td>
<td>Double-click the split bar at the top of the vertical scroll bar. or... Click and drag the split bar at the top of the vertical scroll bar.</td>
</tr>
<tr>
<td>Split window into two vertical views</td>
<td>Double-click the split bar at the extreme left of the horizontal scroll bar. or... Click and drag the split bar at the extreme left of the horizontal scroll bar.</td>
</tr>
<tr>
<td>Adjust relative size of split views</td>
<td>Click and drag the split bar that separates the views.</td>
</tr>
<tr>
<td>Remove split views</td>
<td>Double-click the split bar that separates the views. or... Click and drag the split bar to the edge of the window. To remove all four views at once, double-click the intersection where the split bars meet or drag it to any corner of the window.</td>
</tr>
</tbody>
</table>
5. Choose a PL/SQL language element or construct in the list area.
   When you click a PL/SQL language element or construct, the syntax appears in
   the display area that is below the list area.

6. Click Insert to copy the selected syntax.
   The selected PL/SQL language element or construct is inserted into the active
   editor at the current cursor position.

7. Replace all lowercase items that are not comments with the appropriate values.
   Items within comments are optional. Reserved words are in uppercase.

   **Note:** You can also double-click a PL/SQL language element or
   construct in the list area to insert the syntax into an editor.

**See also**
Section 2.6.3, "About the Syntax Palette"

4.13.3 Creating or editing report-level or template-level PL/SQL

This section provides procedures for the following tasks that you may perform as you
create or edit report-level or template-level PL/SQL:

- Creating a local program unit
- Creating a stored program unit
- Deleting a program unit
- Moving a program unit between client and database server
- Creating a report trigger
- Deleting a report trigger
- Creating a database trigger

4.13.3.1 Creating a local program unit

To create a local (client-side) program unit:

1. In the Object Navigator, click the **Program Units** node.
2. Click the Create button in the toolbar.
3. In the dialog box, type a name for the program unit in the **Name** text box.
4. If your program unit is not a procedure (a PL/SQL subprogram that performs a
   specified sequence of actions), click one of the following:
   - **Function** (a PL/SQL subprogram that performs a specified sequence of
     actions, and then returns a value)
   - **Package Spec** (datatypes and subprograms that can be referenced by other
     program units)
   - **Package Body** (implementation of the package, which may include private
     subprograms and datatypes; optional if the package consists only of
     declarations)
How To...

4-119

5. Click OK.

6. In the PL/SQL Editor, define the PL/SQL for the program unit.

See also
Section 2.6.4, "About program units"

4.13.3.2 Creating a stored program unit
To create a stored (server-side) program unit:

1. In the Object Navigator, double-click the Database Objects node. If this node is disabled, the Connect dialog box displays so you can establish a database connection.

2. Expand the subnode that corresponds to the database user name you used to log in to the database to show the PL/SQL Stored Program Units node.

3. Click the PL/SQL Stored Program Units node, then click the Create button in the toolbar.

4. In the dialog box, type a name for the program unit in the Name text box.

5. If your program unit is not a procedure (a PL/SQL subprogram that performs a specified sequence of actions), click one of the following:
   - Function (a PL/SQL subprogram that performs a specified sequence of actions, and then returns a value)
   - Package Spec (datatypes and subprograms that can be referenced by other program units)
   - Package Body (implementation of the package, which may include private subprograms and datatypes; optional if the package consists only of declarations)
   - Type Spec (declares the name, variables (attributes) and member subprograms (methods) for an object type or collection type)
   - Type Body (implementation of the member methods (functions and procedures) defined in the type specification for an object type. For each method specified in an object type, there must be a corresponding method body)

Note: If the radio button is not selected when you click, try clicking a different radio button, then click the desired Type again.

6. Click OK.

7. In the Stored PL/SQL Editor, select a database owner name from the Owner list to indicate where the program unit will be stored in the database, then define the PL/SQL for the stored program unit.

See also
Section 2.6.5, "About stored program units"
4.13.3.3 Deleting a program unit

To delete a program unit:

1. In the Object Navigator, expand the Program Units node.
2. Click the program unit you want to delete.
3. Click the Delete button in the toolbar.
4. In the message dialog box, click Yes to confirm the deletion.

See also
Section 2.6.4, "About program units"

4.13.3.4 Moving a program unit between client and database server

To move a program unit from the client to the database server:

1. In the Object Navigator, double-click the Database Objects node. If this node is disabled, the Connect dialog displays so you can establish a database connection.
2. Expand the subnode that corresponds to the database user name you used to log in to the database to show the PL/SQL Stored Program Units node.
3. In the Reports section of the Object Navigator, expand the Program Units node.
4. Click the program unit you want to store in the database, and drag it from the Program Units node to the Stored Program Units subnode.
5. Release the mouse button to insert a copy of the program unit on the server.

To move a program unit from the database server to the client:

1. In the Object Navigator, double-click the Database Objects node. If this node is disabled, the Connect dialog box displays so you can establish a database connection.
2. Expand the subnode that corresponds to the database user name you used to log in to the database.
3. Expand the Stored Program Units node.
4. Click the stored program unit you wish to move to the client and drag it from the Stored Program Units node to the Program Units node in the Reports section of the Object Navigator.
5. Release the mouse button to insert a copy of the program unit on the client.

See also
Section 2.6.5, "About stored program units"
Section 2.6.4, "About program units"

4.13.3.5 Creating a report trigger

To create a report trigger:

1. In the Object Navigator, expand the Report Triggers node.
2. Double-click the PL/SQL icon for the trigger you want to create.
3. In the PL/SQL Editor, define the PL/SQL for the report trigger.

See also
Section 2.6.13.1, "About report triggers"

4.13.3.6 Deleting a report trigger
To delete a report trigger:
1. In the Object Navigator, expand the Report Triggers node.
2. Double-click the PL/SQL icon for the trigger you want to delete.
3. In the PL/SQL Editor, drag to select the PL/SQL code.
4. Choose Edit > Delete.

See also
Section 2.6.13.1, "About report triggers"

4.13.3.7 Creating a database trigger
To create a database trigger:
1. Choose Tools > Database Trigger Editor.
2. In the Database Trigger Editor, choose a user name (schema) from the Table Owner list.
3. Choose a table name from the Table list.
   The Table list shows a list of table names owned by the user shown in the Table Owner field. If you select a user name other than your own in the Table Owner field, the Table list shows only the tables to which you have been granted access.
4. (For views only) To define an INSTEAD OF trigger for an object view, click the arrow next to Table to display a list and choose View. Then choose a view name from the View list.
5. Click New to create a new database trigger.
   A unique trigger name (with respect to other triggers in the same schema) is automatically assigned to the new trigger in the Name list. You can modify the trigger name.
   The Name list displays a list of trigger names associated with the table (or view) shown in the Table (or View) field. The Name list displays only the names of the database triggers associated with the tables to which you have access.
6. After specifying the trigger options and action, click Save to compile the trigger.

See also
Section 2.6.13.4, "About database triggers"

4.13.4 Creating or editing object-level PL/SQL
This section provides procedures for the following tasks that you may perform as you create or edit object-level PL/SQL:
- Creating or editing a format trigger
- Creating or editing a group filter
- Creating or editing a formula column
- Creating a placeholder column
- Changing colors and patterns using PL/SQL

4.13.4.1 Creating or editing a format trigger
To create or edit a format trigger using the Property Inspector:

1. In the Paper Design view, double-click the object for which you want to create or edit a format trigger to display the Property Inspector.
2. Under Advanced Layout, set the Format Trigger property by clicking the ... button to display the PL/SQL Editor.
3. Define the PL/SQL for the format trigger.

To create or edit a format trigger using the Object Navigator:

1. In the Object Navigator, expand the Paper Layout node, then expand the node that contains the object for which you want to create or edit a format trigger.
2. Double-click the PL/SQL icon next to the object for which you want to create or edit a format trigger to display the PL/SQL Editor.
3. Define the PL/SQL for the format trigger.

4.13.4.2 Creating or editing a group filter
To create or edit a group filter:

1. In the Data Model view, double-click the title bar of the group to display the Property Inspector.
2. Scroll to the Group node.
3. To display the first n records for the group, set the Action Type property to First and set the Number of Records property to n.
4. To display the last n records for the group, set the Action Type property to Last and set the Number of Records property to n.
5. To create your own filter using PL/SQL, set the Action Type property to PL/SQL and set the PL/SQL Filter property by clicking ... to display the PL/SQL Editor to define the PL/SQL for the filter.
6. Set other properties as desired.

See also
Section 2.6.9, "About group filters"

4.13.4.3 Creating or editing a formula column
See Section 4.8.10, "Creating or editing a formula column".

4.13.4.4 Creating a placeholder column
See Section 4.8.12, "Creating or editing a placeholder column".

4.13.4.5 Changing colors and patterns using PL/SQL
See Section 4.9.6.4, "Changing colors and patterns using PL/SQL".
4.13.5 Creating or editing an external PL/SQL library

This section provides procedures for the following tasks that you may perform as you create or edit an external PL/SQL library:

- Creating an external PL/SQL library
- Adding a program unit to an open library
- Editing a program unit in a PL/SQL library
- Removing a program unit from a PL/SQL library
- Attaching a PL/SQL library
- Converting external PL/SQL libraries

See also

Section 2.6.6, "About external PL/SQL libraries"

4.13.5.1 Creating an external PL/SQL library

To create an external PL/SQL library:

1. In the Object Navigator, click the PL/SQL Libraries node.
2. Click the Create button in the toolbar.

The newly created library (initially named LIB_xxx) is automatically opened. Once a library has been created, its contents can be modified by inserting or removing program units, or attaching other libraries.

4.13.5.2 Adding a program unit to an open library

To add a program unit to an open library:

1. Perform one of the following steps in the Object Navigator, depending on your current state:
   - if the library is open, expand the library node
   - if the library is not currently open, click the PL/SQL Libraries node and choose File > Open to open the library
2. Under the Reports node, expand the Program Units node.
3. Drag the program unit you want to add to the library below the library’s Program Units node.
4. Release the mouse button to insert a copy of the program unit in the library.

4.13.5.3 Editing a program unit in a PL/SQL library

To edit a program unit in a PL/SQL library:

1. In the Object Navigator, expand the PL/SQL Libraries node, then the library node for the program unit.
2. Under the library’s Program Units node, double-click the PL/SQL Editor view icon for the program unit you want to edit.
3. In the PL/SQL Editor, edit the PL/SQL for the program unit.

4.13.5.4 Removing a program unit from a PL/SQL library

To remove a program unit from a PL/SQL library:
1. In the Object Navigator, expand the PL/SQL Libraries node, then the library node for the program unit.

2. Under the open library's Program Units node, click the library program unit you want to delete.

3. Click the Delete button in the toolbar.

4. In the message box, click Yes.

4.13.5.5 Attaching a PL/SQL library

To attach a PL/SQL library:

1. In the Object Navigator, click the Attached Libraries node.

2. Click the Create button in the toolbar.

3. In the Attach Library dialog box, type the name of the external PL/SQL library in the Library text box, or click Browse to search for the external PL/SQL library you want to reference.

4. Click Attach.

Restrictions

■ If Oracle Reports Builder cannot find the specified library, a warning will be raised when you accept the dialog box, save the report, or open the report. If you try to run the report or compile the PL/SQL in it, an error will be raised.

■ The Attached Libraries list is saved. The next time you open the report or library the list will have the same contents it did when you last saved the report.

■ If an external library references another library, you must attach both libraries to the report even if the first library already has the second one attached.

4.13.5.6 Converting external PL/SQL libraries

To convert one or more PL/SQL libraries from one storage format to another on Windows:

■ On the command line, type %ORACLE_HOME%\BIN\rwconverter, followed by the report name and desired arguments. See the Reference section of the Oracle Reports online Help for more information about rwconverter.

4.13.6 Compiling and running program units

This section provides procedures for the following tasks that you may perform as you compile and run program units:

■ Compiling a single program unit
■ Compiling all program units
■ Compiling all uncompiled program units

See also

Section 2.6.4, "About program units"

4.13.6.1 Compiling a single program unit

To compile a single program unit:
1. In the Object Navigator, under the **Program Units** node, click the program unit you want to compile (PL/SQL subprogram, report trigger, formula, group filter, format trigger, or validation trigger).

2. Choose **Program > Compile > Selection** to compile the selected program unit, regardless of its current compilation status.

   **Note:** An uncompiled program unit is indicated by an asterisk (*) after its name under the **Program Units** node in the Object Navigator. When you make changes to a program unit, dependent program units lose their compiled status.

3. In the **Compile** dialog box, click any error to navigate to the source of the error in the program unit.

   **Tip:** Check for missing semicolons at the end of statements, or misspelled syntax.

4.13.6.2 Compiling all program units

   To compile all program units:

1. In the Object Navigator, click the report or library for which you want to compile all program units (including PL/SQL subprograms, report triggers, formulas, group filters, format triggers, and validation triggers).

2. Choose **Program > Compile > All** to compile all program units, regardless of their current compilation status.

   **Note:** An uncompiled program unit is indicated by an asterisk (*) after its name under the **Program Units** node in the Object Navigator. When you make changes to a program unit, dependent program units lose their compiled status.

3. In the Compile dialog box, click any error to navigate to the source of the error in the program unit.

   **Tip:** Check for missing semicolons at the end of statements, or misspelled syntax.

4.13.6.3 Compiling all uncompiled program units

   To compile all uncompiled program units:

1. In the Object Navigator, click the report or library for which you want to compile all uncompiled program units (including PL/SQL subprograms, report triggers, formulas, group filters, format triggers, and validation triggers).

2. Choose **Program > Compile > Incremental** to compile all uncompiled program units.
### 4.14 Debug a Report

This section provides procedures for the following tasks that you may perform as you debug a report:

- Debugging a report
- Running a report in debug mode
- Setting a breakpoint
- Setting a debug trigger
- Browsing debug actions
- Editing a debug action
- Disabling and enabling debug actions
- Deleting a debug action
- Running a program unit in the PL/SQL Interpreter
- Inserting a Navigator pane in the PL/SQL Interpreter
- Controlling program unit execution
- Stepping through the code
- Modifying code at runtime
- Displaying the current scope location
- Examining or changing local variables
- Modifying application variables
- Viewing subprogram references
- Tracing report execution
- Tracing report distribution
- Tracing using the SQL TRACE function

For conceptual information that supports these tasks, see Section 2.10, "Debugging Tools".

#### 4.14.1 Debugging a report

To debug a report:

---

**Note:** An uncompiled program unit is indicated by an asterisk (*) after its name under the Program Units node in the Object Navigator. When you make changes to a program unit, dependent program units lose their compiled status.

**Tip:** Check for missing semicolons at the end of statements, or misspelled syntax.

3. In the Compile dialog box, click any error to navigate to the source of the error in the program unit.
1. Run the report in debug mode (described below) to check for logical errors in the report, and displays these as warnings at runtime, before displaying the report output. Running a report in debug mode is not the same as debugging a report using the PL/SQL Interpreter.

2. After identifying a problem area, choose Tools > PL/SQL Interpreter to display the PL/SQL Interpreter, and create the desired debug actions (see Section 4.14.3, "Setting a breakpoint" and Section 4.14.4, "Setting a debug trigger") to isolate the failing code to a specific region of number of statement.

3. Close the PL/SQL Interpreter to run your report.

4. Browse your debug actions and evaluate application information.

5. After narrowing the failing code to a specific region, use the PL/SQL Interpreter to implement and test possible code fixes.

Usage notes
When debugging a JSP-based Web report in Oracle JDeveloper, you must disable any breakpoints that are not of Source type. If these breakpoints are not disabled, a deadlock is detected. You can disable breakpoints that are not of Source type in the Breakpoints window.

4.14.2 Running a report in debug mode
To compile and run a report in debug mode:

1. Choose Edit > Preferences.

2. In the Preferences dialog box, on the Runtime Settings page, select Run Debug. Click OK.

3. Click the Run Paper Layout button in the toolbar to run the report.

To compile and run a report in debug mode from the command line:

- On the rwbuilder or rwrn command line, specify RUNDEBUG=YES. For information about RUNDEBUG, see the Reference > Command Line section of the Oracle Reports online Help.

Usage notes
Running a report in debug mode specifies that you want extra runtime checking for logical errors in the report. It checks for things that are not errors but might result in undesirable output, and displays these as warnings at runtime, before displaying the report output. Running a report in debug mode is not the same as debugging a report using the PL/SQL Interpreter.

4.14.3 Setting a breakpoint
To set a breakpoint in the execution of your report:

1. If the PL/SQL Interpreter is not already displayed, choose Tools > PL/SQL Interpreter.

2. In the Object Navigator, single-click a compiled program unit node to display the program unit in the Interpreter Source pane.

| Note: | Uncompiled program units are indicated by an asterisk (*) after their name. |
3. Double-click an executable statement (a PL/SQL construct used for conditional, iterating, and sequential control, and for error handling. A semi-colon (;) must terminate every PL/SQL statement) where you wish to create the break point.

**Tip:** You cannot place a breakpoint on a BEGIN, END, or NULL statement, or on a comment.

The breakpoint is inserted and is indicated by B00n, where n is the number of the breakpoint. When you run the program unit, execution is suspended at the line just prior to the breakpoint.

### 4.14.4 Setting a debug trigger

To set a debug trigger:

1. If the PL/SQL Interpreter is not already displayed, choose **Tools > PL/SQL Interpreter**.

2. In the Object Navigator, single-click a compiled program unit node to display the program unit in the Interpreter source pane.

**Note:** Uncompiled program units are indicated by an asterisk (*) after their name.

3. In the Source pane, select the line where you want to create the debug trigger, then choose **Program > Debugging Triggers** (or right-click in the Source pane and choose **Trigger**).

**Tip:** You cannot place a breakpoint on a BEGIN, END, or NULL statement, or on a comment.

4. In the PL/SQL Trigger dialog box, define the trigger:

   - If you want the trigger to fire at different location than the current program unit, select a location from the **Location** list.

   - Type the debug trigger in the **Trigger Body** text box.

For example, to create a debug trigger that interrupts program execution if the local NUMBER variable *my_sal* exceeds 5000, enter the following as the trigger body:

```
IF Debug.Getn('my_sal') > 5000 THEN
  raise Debug.Suspend;
END IF;
```

**Note:** To create a debug trigger that contains multiple lines of text, include a BEGIN and an END statement around the code.

You must raise the DEBUG.SUSPEND exception from the DEBUG package if you want the PL/SQL Interpreter to appear when this line is executed. Otherwise, Oracle Reports Builder executes the code silently and the PL/SQL Interpreter does not appear.
5. Click OK to create a debug trigger for the selected line.

**Tip:** You can also create a debug trigger by entering commands in the PL/SQL Interpreter pane.

### 4.14.5 Browsing debug actions

To browse debug actions:

- In the Object Navigator, expand the Debug Actions node. The Object Navigator displays a list of the debug actions associated with the current report.
  
  or

- In the PL/SQL Interpreter, use the DESCRIBE command to display information about a specific debug action.
  
  For example, entering DESCRIBE BREAK 1 in the Interpreter pane reveals the following about Breakpoint 1:

    Breakpoint: 1  
    Program Unit: Procedure Body <programunit_name>  
    Line: 3  
    Enabled: YES

### 4.14.6 Editing a debug action

To edit a debug action:

1. In the Object Navigator, expand the Debug Actions node, then double-click the debug action icon to display the appropriate dialog box.

2. Edit the content or properties of the debug action in the dialog box.

3. Click OK.

### 4.14.7 Disabling and enabling debug actions

To disable/enable a debug action:

- In the Object Navigator, under the Debug Actions node, right-click the desired debug action and choose Enable or Disable.
  
  or

- In the PL/SQL Interpreter, use the ENABLE or DISABLE command to enable or disable the specific debug action.
  
  For example, entering .DISABLE ACTION 1 in the Interpreter pane disables the first debug action and displays the following status:

    Disabling debug action 1...

### 4.14.8 Deleting a debug action

To delete a debug action:

1. In the Object Navigator, expand the Debug Actions node, then click the action you want to delete.

2. Click the Delete button in the toolbar.
4.14.9 Running a program unit in the PL/SQL Interpreter

To run a program unit in the PL/SQL Interpreter:

1. If the PL/SQL Interpreter is not already displayed, choose Tools > PL/SQL Interpreter to display it.

2. At the Interpreter's PL/SQL> prompt, type the name of the program unit followed by a terminating semi-colon (;). If the program unit requires any arguments, be sure to supply them in parentheses. For example: `getdata(SCOTT);`

3. Press the Enter or Return key to produce one of the following reactions:
   - Any output generated by the program unit is displayed at the command line, and the PL/SQL> prompt returns to indicate successful execution.
   - The secondary prompt appears (+>) indicating you have not finished entering an executable statement. If you forgot the terminating semicolon, enter it now and press Enter or Return. Otherwise, right-click and choose New Prompt.
   - Runtime errors are displayed at the command line, then the PL/SQL> prompt appears. You need to edit or debug your program unit.
   - If you have set a breakpoint or debug trigger in the program unit, execution is suspended and a new prompt is displayed as: `(debug n)PL/SQL>`.  

Usage notes
Running a program unit as described above only works for procedures (or packaged procedures), not for functions (since there's no variable for a return value to be returned to).

4.14.10 Inserting a Navigator pane in the PL/SQL Interpreter

To insert an Object Navigator pane in the PL/SQL Interpreter:

1. If the Interpreter is not already displayed, choose Program > PL/SQL Interpreter.

2. In the PL/SQL Interpreter, choose View > Navigator Pane to insert the Object Navigator pane in the middle of the PL/SQL Interpreter.

   Notice that the button bar is updated with new Object Navigator buttons.

3. Optionally, use the split bars to resize the proportions of the three panes.

4.14.11 Controlling program unit execution

Once you have inspected and modified the program state, you can resume or terminate execution using the following features:

<table>
<thead>
<tr>
<th>Execution Feature</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>STEP</td>
<td>You can use the STEP command to temporarily resume execution of an interrupted program. Control returns to the PL/SQL Interpreter after the specified set of statements have been executed. STEP Into or Over enables you to: execute the next statement (optionally descending into subprogram calls) resume execution until the current subprogram has returned continue execution until the specified source location is reached</td>
</tr>
</tbody>
</table>
Execute these commands from either the PL/SQL Interpreter toolbar or by typing the command in the PL/SQL Interpreter pane.

### 4.14.12 Stepping through the code

To step through the code:

Before proceeding, you must already have set a debug action such as a breakpoint, and run your program unit at the PL/SQL Interpreter prompt to suspend execution.

To step to the next line of the suspended program unit:

- Click the Step Into button in the PL/SQL Interpreter toolbar to execute the next line of executable code in the current program unit.
  
  If the next executable line is a call to a nested subprogram (a program unit that is called from within another program unit), Step Into halts execution at the first line of the nested subprogram.

To step over a nested subprogram call in the suspended program unit:

- Click the Step Over button in the PL/SQL Interpreter toolbar.
  
  Step Over executes any calls to nested subprograms and then halts execution at the next executable line of the current program unit.

To step out of a nested subprogram and return to the outer program unit:

- Click the Step Out button in the PL/SQL Interpreter toolbar.
  
  If you previously used Step In to descend into a nested subprogram, Step Out completes execution of the nested subprogram and returns to the next line of the original program unit.

To resume program unit execution:

- Click the Go button in the PL/SQL Interpreter toolbar.
  
  Execution of the program unit continues until the program unit execution has finished, or until interrupted again by another debug action.

---

**Note:** If your debug action is located in a PL/SQL LOOP, using Go will cycle through the loop.

---

To exit suspended execution at the current debug level:
- Click the Reset button in the PL/SQL Interpreter toolbar.
  Control is returned to the Interpreter, or to an outer debug level (if any exist).

4.14.13 Modifying code at runtime
To modify your code at runtime:
1. In the Object Navigator, double-click the desired program unit, menu item command, or trigger to display the PL/SQL Editor.
2. In the PL/SQL Editor, make the desired modifications.
3. Click Compile then Close to dismiss the PL/SQL Editor.
4. In the PL/SQL Interpreter toolbar, choose Go or Step Into, Over, or Out to resume program execution.

See also
Section 2.10.9, "About modifying code at runtime"

4.14.14 Displaying the current scope location
To display the current scope location:
- In the Object Navigator, expand the Stack node, then expand the desired frame in the stack to reveal information about local variables and parameters.
  or
- In the PL/SQL Interpreter, display the Source pane to view the current scope location.

See also
Section 2.10.7, "About the current scope location"

4.14.15 Examining or changing local variables
You must currently have a suspended program unit in the PL/SQL Interpreter to examine or change local variables values.
To examine local variable values:
1. In the Object Navigator, expand the Stack node to show the call stack frames.
2. Under the Stack node, double-click the node for the program unit whose variables you wish to examine or modify.
   Each local variable is displayed with its current value.
To edit local variable values:
1. In the Object Navigator, expand the Stack node to show the call stack frames.
2. Under the Stack node, double-click the node for the program unit whose variables you wish to examine or modify.
   Each local variable is displayed with its current value.
3. Click the variable value in the Object Navigator.
4. Click the variable value again to enter edit mode.
5. Change the value of the variable.
6. Click a blank area in the Object Navigator to exit edit mode and accept the changed value.

7. Resume program unit execution in the PL/SQL Interpreter to test the effect of the new value.

4.14.16 Modifying application variables

To modify a variable:

1. In the Object Navigator, expand the Global Variables node or the Stack node for local variables.

2. Select and expand the desired entry. The Object Navigator displays any variables associated with the entry.

3. Click the existing value after the "=" then edit the value by entering the desired value.

4.14.17 Viewing subprogram references

To view subprogram references:

1. In the Object Navigator, select and expand the desired subprogram.

2. Select and expand either the References or Referenced By node.

The Object Navigator displays any subprogram references.

**Note:** Referenced By shows the program units that call the current program unit. References shows the program units that are called by the current program unit.

4.14.18 Tracing report execution

To set tracing options, do one of the following:

- Choose Program > Tracing and fill out the Runtime Trace Settings dialog box as desired.

- In the ReportsTools logging configuration file (logging.xml), set the trace level in the level attribute of the logger element (oracle.reports.runtime).

For more information, including tracing for rwserver and rwservlet, see the "Configuring Oracle Reports Services" and "Diagnosing and Tuning Oracle Reports" chapters in *Publishing Reports to the Web with Oracle Reports Services*.

4.14.19 Tracing report distribution

To trace report distribution:

1. Choose Program > Tracing.

2. In the Runtime Trace Settings dialog box, specify a name for the trace file in the Trace File field.

3. Select the Distribution check box.

4. Click OK.

5. Run the report.
6. Use a text editor to open and view the trace file. If the trace file is empty, the distribution was successful. Otherwise, the trace file identifies the distribution error.

See also
Section 2.8.3, "About report distribution"
Section 4.7.12, "Distributing a report to multiple destinations"

4.14.20 Tracing using the SQL TRACE function

The TRACE function provides you with the exact statements that are being parsed. Once you have them, you can time them in SQL*Plus, and multiply these times with the expected number of rows to retrieve from the database. (Always compare apples to apples; that is, send output to a file—not to the screen. Do not change anything in the SQL statements when moving it to SQL*Plus; even the slightest change in the WHERE clause can make a big difference in the performance.)

There are two ways to trace your reports:

- user level
- system level

It is recommended that the user level because you can more easily find the information you need. For more information on SQL TRACE, see the Oracle Server SQL Language Reference manual.

4.14.20.1 Performing a user-level trace

1. Open the report for which you want the performance data.
2. Create a report-level formula column named SQL-TRACE that has the following formula:

   ```sql
   SRW.DO_SQL ('ALTER SESSION SET SQL_TRACE=TRUE');
   return(1); --Formulas must return a value.
   ```

   **Note:** You could also call SQL TRACE from the Before Form trigger.

3. Run the report. A new file, `some_number.trc`, will be created in either `ORACLE_HOME/rdbms/log`, or the destination indicated by the `init.ora` parameter `USER_DUMP_DEST`. (The date stamp on the file can help you determine which `.trc` file is yours.)
4. Use the TKPROF command to format the trace output file.

   If you issue more than one trace during the `rwbuilder` session, the trace outputs are concatenated into one file.

4.14.20.2 Performing a system-level trace

1. Insert these statements into your `init.ora` file: `SQL_TRACE=TRUE` and `TIMED_STATISTICS=TRUE`.
2. Shut down, then restart your database.
4.15 Integrate with Other Products

This section provides procedures for the following tasks that you may perform as you integrate your reports with other products:

- **Publishing a report in Oracle Portal**
- **Accessing non-Oracle data sources**

4.15.1 Publishing a report in Oracle Portal

Oracle Portal is integrated with Oracle Reports. This integration enables you to quickly publish a report as a portlet (that is, a small, dynamic region) or an item on a page, so that end users can easily access dynamic reports.

For general information, refer to the Oracle Technology Network (OTN): on the Oracle Reports page (http://www.oracle.com/technetwork/middleware/reports/overview/index.html), navigate to Learn More and click Getting Started to display the Getting Started with Oracle Reports home page. In the list of topic sections on the left, click Any Format, then select Integration with Oracle Portal.

For detailed information and tasks to publish a report as a portlet in Oracle Portal, see the "Deploying Reports in Oracle Portal" chapter in *Publishing Reports to the Web with Oracle Reports Services*.

4.15.1.1 Running reports in Oracle Portal as an item link

When you install Oracle Portal with a non default language setting, some entries required to publish a report as an item link on a portal page are not installed automatically. You must install the language of your choice by using the rwlang.sql script.

Thus, you must run `rwlang.sql` (ORACLE_HOME/portal/admin/plsql/wwd/) if:

- You have selected at least one language in addition to the default (US) at the time of installing Oracle Portal.
  
  **AND**

- You want to publish a report as an item link in Oracle Portal.

  **Note:** By default, a report is defined in the Main section.

To run the script:

1. Change the directory to `ORACLE_HOME/portal/admin/plsql/wwd/`.
2. Run sqlplus.
3. Log on to Oracle Portal using the portal schema.
4. Run the `rwlang.sql` script with the following parameters:
   
   `@rwlang.sql language_list`

   where
\textit{language\_list} is the list of languages separated by commas.

For example, to install French and Japanese:

@rwlang.sql f,ja

\textbf{Usage notes}

- There should be no space before or after the comma (,) because \texttt{sqlplus} treats the language list as two parameters, instead of one parameter separated by a comma (,).
- The header of the \texttt{rwlang.sql} script contains the complete list of all language abbreviations. Edit the script file using any text editor to find out the various abbreviations.

\subsection*{4.15.2 Accessing non-Oracle data sources}

Oracle Reports enables you to access any data source. The pluggable data source (PDS) architecture replaces Oracle Open Client Adapter (OCA) and the Open Database Connectivity (ODBC) drivers, which are no longer supported in Oracle Reports. However, Java Database Connectivity (JDBC) is one of the pluggable data sources available that can utilize the JDBC-ODBC bridge, allowing access to other data sources.

Use the following steps to determine the easiest method for accessing your data source:

1. Does your data source have Java Database Connectivity (JDBC)?
   
   A pluggable data source (PDS) has already been set up. All you have to do is select JDBC as your data type.

2. Does your data source have ODBC?
   
   If so, make sure that you have downloaded the JDBC-ODBC bridge from Sun Microsystems. This lets you use the JDBC connection mentioned in Step 1. If you do not know if there is an ODBC driver for your data source, check the company website. For example, Microsoft has a downloadable ODBC driver for Excel.

3. Is the file in XML?
   
   Oracle Reports includes an XML PDS. If the DTD file is available, all you have to do is select XML as your data type. If the DTD file is not available, you will have to create one.

4. Is the file comma-delimited?
   
   You can use the Text PDS included with Oracle Reports to query the data source.

5. Has someone in your company built a PDS for your data type?
   
   If the PDS exists, it will probably be on the Reports Server. Ask your administrator if such a file exists. If the PDS exists, add it to the classpath for your copy of Oracle Reports Builder. If the PDS does not exist, use the API Reference to help you build one.

\textbf{Examples}

Oracle Reports ships with XML data source sample files.
See also
The Pluggable Data Sources section of the Oracle Reports online Help, including the topics:
- About pluggable data sources
- Adding a pluggable data source
- Connecting to a pluggable data source
- Adding online Help to a pluggable data source
- Pluggable data source interface definition
- Troubleshooting PDS problems

4.16 Administer Oracle Reports Builder

This section provides procedures for the following tasks that you may perform as you administer Oracle Reports Builder:
- Setting a database role
- Converting from one format to another
- Improving performance using SQL statements
- Improving performance using WHERE clauses

4.16.1 Setting a database role

Before beginning this procedure, verify that the database administrator has created the role, granted privileges to the role, and granted the role to approved end users. Refer to your Oracle Application Developer’s Guide for more information.

To set a database role for a report:

1. In the Object Navigator, double-click the properties icon for the report to display the Property Inspector.
2. Under the Report node, set the Role Name property as defined by the database administrator in the database.
3. Optionally, to set a Role Password, double-click the button in the Role Name value field to display the Set Role dialog box.

Usage notes
- The role settings in the report are overridden if you specify a role using the command line with Reports Runtime (rwrn).
- You can set only one role for a report. To set multiple roles, you need to set a role to which the other roles have been granted.

Caution: Do not attempt to set the role in a PL/SQL trigger. The PL/SQL will not compile.

See also
Section 2.9.1, "About database roles"
4.16.2 Converting from one format to another

To convert one or more report definitions or PL/SQL libraries from one storage format to another:

- In Oracle Reports Builder, choose Tools > File Conversion to display the Convert dialog box.
- On the command line on Windows, type `%ORACLE_HOME%\bin\rwconverter`, followed by the report name and desired arguments.

4.16.3 Improving performance using SQL statements

Performing operations in SQL is faster than performing them in Oracle Reports Builder or PL/SQL. The following are the most common cases where using SQL would improve performance:

- Use a WHERE clause instead of a group filter or format trigger to exclude records.
- Use the SUBSTR function to truncate character strings instead of truncating in Oracle Reports Builder.
- Perform calculations directly in your query rather than in a formula or summary.

Rationale: SQL can perform calculations more quickly than a summary or formula. WHERE and SUBSTR can reduce unnecessary fetching because they operate on the data during rather than after data retrieval. Improvements in performance become more noticeable when retrieving thousands of records versus a few records.

4.16.4 Improving performance using WHERE clauses

Consider adding a WHERE clause for the matrix cell query in a multiquery data model. If you are using a multiquery data model and your dimension queries are restricted by a WHERE clause, adding a WHERE clause to the matrix cell query ensures that you do not retrieve more records than are necessary. For example, suppose that you had the following queries for your dimensions:

**Q_Dept**
```
SELECT DEPTNO FROM DEPT
WHERE DEPTNO < 100
```

**Q_Job**
```
SELECT DISTINCT JOB FROM EMP
WHERE DEPTNO < 100
```

**Q_Filler**
```
To ensure that your cell query only retrieves the records that are necessary, you would write the following SELECT statement:
```
SELECT DEPTNO, JOB, SUM(SAL) FROM EMP
WHERE DEPTNO IN (SELECT DEPTNO FROM DEPT
WHERE DEPTNO < 100) AND JOB IN (SELECT
DISTINCT JOB FROM EMP WHERE DEPTNO < 100)
GROUP BY DEPTNO, JOB
```

If you did not add the WHERE clause to this query, all rows would be retrieved from the database, regardless of what you selected in Q_Dept and Q_Job.
Note: If you added a WHERE clause that did not use the subqueries (for example, WHERE EMP.DEPTNO = DEPT.DEPTNO), the query would be executed once for each combination of values in the cross-product. This can lead to excessive execution of the filler query, if the cross-product has a lot of combinations.
Part I
Building Basic Reports

The chapters in this Part provide steps to build simple reports.
This part contains the following chapters:

■ Chapter 5, "Building a Tabular Report"
A tabular report is the most basic type of report. The output of this report is organized in a multicolumn, multirow format (with rows and columns corresponding to those in the database table).

■ Chapter 6, "Building a Mailing Label Report"
A mailing label report is displayed in a format suitable for use as address labels on envelopes. You write custom text and embed database values, or text from files, to create the labels. You can print the labels in one or many columns and at any position.

■ Chapter 7, "Building a Form Letter Report"
A form letter report is displayed in a format suitable for use in printed forms or letters. Similar to the mailing label report, you can write custom text and embed to it, database values or text from files.

■ Chapter 8, "Building a Master/Master Report"
A master-master report (also called a parent-parent report) consists of at least two sets of data that are not directly related. This report contains two or more queries with no links (that is, no parent-child relationships).

■ Chapter 9, "Building a Summary Report"
A summary report contains a field that summarizes at least one column of the report. This summary can be: total sales, average of a list of commissions, maximum amount found in a series of purchase orders, and so on.
In this chapter, you will learn about tabular reports, the most basic report style. By following the steps in this chapter, you can generate the report output shown in Figure 5–1.

**Figure 5–1  Tabular report output**

<table>
<thead>
<tr>
<th>Department Id</th>
<th>Department Name</th>
<th>Manager Id</th>
<th>Location Id</th>
</tr>
</thead>
<tbody>
<tr>
<td>10</td>
<td>Administration</td>
<td>200</td>
<td>1700</td>
</tr>
<tr>
<td>20</td>
<td>Marketing</td>
<td>201</td>
<td>1900</td>
</tr>
<tr>
<td>30</td>
<td>Purchasing</td>
<td>114</td>
<td>1700</td>
</tr>
<tr>
<td>40</td>
<td>Human Resources</td>
<td>303</td>
<td>2400</td>
</tr>
<tr>
<td>50</td>
<td>Shipping</td>
<td>121</td>
<td>1500</td>
</tr>
<tr>
<td>60</td>
<td>IT</td>
<td>103</td>
<td>1400</td>
</tr>
<tr>
<td>70</td>
<td>Public Relations</td>
<td>204</td>
<td>2700</td>
</tr>
<tr>
<td>80</td>
<td>Sales</td>
<td>145</td>
<td>2500</td>
</tr>
<tr>
<td>90</td>
<td>Executive</td>
<td>100</td>
<td>1700</td>
</tr>
<tr>
<td>100</td>
<td>Finance</td>
<td>109</td>
<td>1700</td>
</tr>
<tr>
<td>110</td>
<td>Accounting</td>
<td>205</td>
<td>1700</td>
</tr>
</tbody>
</table>

**Concepts**

A tabular report is the most basic type of report you can build. The report output is organized in a multicolumn, multirow format, with each column corresponding to a column in the database table. In this example, the column labels **Department Id**, **Department Name**, **Manager Id**, and **Location Id** are derived from the columns in your SQL `SELECT` statement, but you can modify column labels as you wish.

**Data Relationships**

- Generally, the first step is to define the data Oracle Reports should fetch from the database by creating a query that contains a `SELECT` statement. Although this example report uses only one query, reports can contain any number of queries.

- For each query you create, Oracle Reports automatically creates one default group. The default query names are **Q_1**, **Q_2**, and so on. The default group name is **G_fieldname**, where **fieldname** is the first field of the table specified in the query. For example, if the first field of the table `EMPLOYEE` is **FIRSTNAME**, then the default group name is **G_FIRSTNAME**.

- For each database column you specify in the query’s `SELECT` statement, Oracle Reports creates a report column and assigns it to the group. By default, the columns appear in the order in which you enter them in your `SELECT` statement.
The default column names are generated from the database column names or replaced by any aliases specified in your `SELECT` statement.

- If you select two or more columns with the same name, the first column is given the default name, the second column is given the default name with a 1 appended to it (for example, Deptno, Deptno1, and so on).

**Layout**

- Before you can run your report, you must specify the layout (that is, the format) of the report output. If you do not, Oracle Reports will fetch the data but will not display it; you may receive an error message, depending on whether you choose paper or Web layout.

- For this example report, you will use the tabular layout style, which is one of eight styles provided by Oracle Reports. The tabular layout displays data in a series of columns running down the page, with the column headings displayed directly above the columns.

**Example Scenario**

As you build this example report, you will:

- Use the Report Wizard to Create a Report with a paper layout that includes one query to select all of the columns displayed in this report. Oracle Reports will create all other necessary objects (for example, groups and columns) by default.

To see a sample tabular report, open the examples folder named `tabular`, then open the Oracle Reports example named `tabular.rdf`. For details on how to open it, see "Accessing the Example Reports" in the Preface.

5.1 Prerequisites for This Example

To build the example in this chapter, you must have access to the Human Resources sample schema (HR) provided with the Oracle Database. If you do not know if you have access to this sample schema, contact your database administrator.

5.2 Use the Report Wizard to Create a Report

When you create a report, you can either use the Report Wizard to assist you or create the report yourself. To build the simple report in this example, you can use the Report Wizard. Using the wizard enables you to define the layout for the report, as well as set the data definition.

**To create a simple report:**

1. Launch Reports Builder (or, if already open, choose File > New > Report).
2. In the Welcome or New Report dialog box, select Use the Report Wizard, then click OK.
3. If the Welcome page displays, click Next.
4. On the Report Type page, select Create Paper Layout Only, then click Next.
5. On the Style page, type a Title for your report, select Tabular, then click Next.
6. On the Data Source page, click SQL Query, then click Next.
7. On the Data page, enter the following `SELECT` statement in the Data Source definition field:

Prerequisites for This Example
SELECT ALL DEPARTMENTS.DEPARTMENT_ID, DEPARTMENTS.DEPARTMENT_NAME, DEPARTMENTS.MANAGER_ID, DEPARTMENTS.LOCATION_ID FROM DEPARTMENTS ORDER BY DEPARTMENTS.DEPARTMENT_ID

**Tip:** This query selects all the department IDs, the department names, the manager IDs, and the location IDs, then sorts the data by the department IDs.

**Note:** You can enter this query in any of the following ways:

- Copy and paste the code from the provided text file called tabular_code.txt into the **Data Source definition** field.
- Click **Query Builder** to build the query without entering any code manually.
- Type the code in the **Data Source definition** field.

8. Click **Next**.

**Note:** If you are not already connected to a database, you will be prompted to connect to the database when you click **Query Builder** or **Next**. Ensure that you connect to a database that has the appropriate schema for this example. **Section 5.1, “Prerequisites for This Example”** describes the sample schema requirements for this example.

9. On the Fields page, click the double right arrows (>>) to move all of the fields to the **Displayed Fields** list, then click **Next**.

10. On the Totals page, click **Next**.

11. On the Labels page, click **Next**.

12. On the Template page, select **Predefined Template** and click **Beige**, then click **Finish** to display your report output in the Paper Design view. It should look something like this:

*Figure 5–2  Paper Design view for the tabular report*
13. Save the report as tabularreport_your_initials.rdf.

### 5.3 Summary

Congratulations! You have successfully created a tabular paper report. You now know how to:


For more information on any of the wizards, views, or properties used in this example, refer to the *Oracle Reports online Help*, which is available in Oracle Reports Builder or hosted on the Oracle Technology Network (OTN), as described in Section 4.1.1, "Using the Oracle Reports online Help".

---

**Note:** In the Paper Design view, you can see how the tabular report displays the data like a table, in order of department ID number.
Building a Mailing Label Report

In this chapter, you will learn about mailing label reports, one of the standard report styles. By following the steps in this chapter, you can generate the report output shown in Figure 6–1.

Figure 6–1  Mailing label report output

Hermann Baer  
Schwanthalerstr. 7031  
Munich, Bavaria  80925

Adam Fripp  
2011 Interiors Blvd  
South San Francisco,

Nancy Greenberg  
2004 Charade Rd  
Seattle, Washington  98199

Michael Hartstein  
147 Spadina Ave  
Toronto, Ontario  M5

Concepts

■ A mailing label report consists of data displayed in a format suitable for use as address labels on envelopes. The labels can be printed in one or many columns, and can begin at any position.

■ In a mailing label report, you can combine data from the database with static text to create addresses, and print them out as mailing labels for envelopes.

■ Mailing labels can be created using simple, one-query reports with a mailing label layout style.

Data Relationships

To fetch the data for a mailing label report, all you need to do is create a query to select it.

Layout

■ Oracle Reports provides a default mailing label layout in which the fields are positioned so that each field is directly below the preceding field. Field labels are not printed.

■ You will use the Report Wizard to create a simple mailing label report. The Report Wizard provides you with a formatting page, where you can choose the layout of each mailing label.

■ You will use the Vertical Spacing field, located in the Property Inspector for the repeating frame, to control the amount of blank space between each mailing label. The default spacing between repeating frames may not be sufficient, and you may
want to specify that space be inserted between mailing labels in the layout so that they are correctly positioned when printing them onto labels.

**Example Scenario**
As you build this example report, you will:

- **Use the Report Wizard to Create a Mailing Label Report** and use Query Builder to write a single query that selects all of the columns for this report. You do not need to create any other data objects; Oracle Reports will create all other necessary data objects by default.

- **Add Vertical Spacing** using the Vertical Spacing property to add space between each record in your mailing label report

To see a sample mailing label report, open the examples folder named **mailinglabel**, then open the Oracle Reports example report named **mailinglabel.rdf**. For details on how to open it, see "Accessing the Example Reports" in the Preface.

### 6.1 Prerequisites for This Example

To build the example in this chapter, you must have access to the Human Resources sample schema (HR) provided with the Oracle Database. If you do not know if you have access to this sample schema, contact your database administrator.

### 6.2 Use the Report Wizard to Create a Mailing Label Report

When you create a report, you can either use the Report Wizard to assist you or create the report yourself. To build the simple report in this example, you can use the Report Wizard. Using the wizard enables you to define the layout for the report, as well as set the data definition.

**To create a simple mailing label report:**

1. Launch Reports Builder (or, if already open, choose File > New > Report).
2. In the Welcome or New Report dialog box, select **Use the Report Wizard**, then click **OK**.
3. If the Welcome page displays, click **Next**.
4. On the Report Type page, select **Create Paper Layout Only**, then click **Next**.
5. On the Style page, type a **Title** for your report, select **Mailing Label**, then click **Next**.
6. On the Data Source page, click **SQL Query**, then click **Next**.
7. On the Data page, click **Query Builder**.
8. In the Select Data Tables dialog box, click the **EMPLOYEES** table, then click **Include**.
9. Click the **DEPARTMENTS** table, then click **Include**.

---

**Note:** In this case, you must include the DEPARTMENTS table since the EMPLOYEES and LOCATIONS tables are not directly related in the schema.

10. Click the **LOCATIONS** table, then click **Include**.
11. Click Close.

The three tables display in the Query Builder.

12. In the EMPLOYEES table, select the check boxes next to the following column names:
   - FIRST NAME
   - LAST NAME
   - EMPLOYEE ID

13. In the LOCATIONS table, select the check boxes next to the following column names:
   - STREET ADDRESS
   - POSTAL CODE
   - CITY
   - STATE PROVINCE
   - LOCATION ID

14. Click OK.

15. In the Data Source definition field, your query should look something like this:

```sql
SELECT ALL EMPLOYEES.EMPLOYEE_ID, EMPLOYEES.FIRST_NAME, EMPLOYEES.LAST_NAME, LOCATIONS.STREET_ADDRESS, LOCATIONS.POSTAL_CODE, LOCATIONS.CITY, LOCATIONS.STATE_PROVINCE, LOCATIONS.LOCATION_ID
FROM EMPLOYEES, DEPARTMENTS, LOCATIONS
WHERE ((EMPLOYEES.DEPARTMENT_ID = DEPARTMENTS.DEPARTMENT_ID) AND (DEPARTMENTS.MANAGER_ID = EMPLOYEES.EMPLOYEE_ID) AND (DEPARTMENTS.LOCATION_ID = LOCATIONS.LOCATION_ID))
```

**Note:** You can enter this query in any of the following ways:
- Copy and paste the code from the provided text file called mailinglabel_code.txt into the Data Source definition field.
- Click Query Builder to build the query without entering any code manually, as described in the steps above.
- Type the code in the Data Source definition field.

16. Click Next.

**Note:** If you are not already connected to a database, you will be prompted to connect to the database when you click Query Builder or Next. Ensure that you connect to a database that has the appropriate schema for this example. Section 6.1, "Prerequisites for This Example" describes the sample schema requirements for this example.

17. On the Text page, format the way you want the mailing labels to display. Steps 21 through 30 will show you how to display your labels in the following format:

  John Smith
  55 Main Street
  Springfield, ME 00000
18. In the Available Fields list, click FIRST_NAME, then click the right arrow (>) to move this field to the Mailing Label list.

19. In the Available Fields list, click LAST_NAME, then click the right arrow (>).

20. Click New Line.

21. In the Available Fields list, click STREET_ADDRESS, then click the right arrow (>).

22. Click New Line.

23. In the Available Fields list, click CITY, then click the right arrow (>).

24. Press Backspace on your keyboard to remove the extra space.

25. Click Comma.

26. In the Available Fields list, click STATE_PROVINCE, then click the right arrow (>).

27. In the Available Fields list, click POSTAL_CODE, then click the right arrow (>).

   The code in the Mailing Label Text box should look like this (if necessary, add spaces as shown):
   \&<FIRST_NAME> &<LAST_NAME> &<STREET_ADDRESS> &<CITY>, &<STATE_PROVINCE> &<POSTAL_CODE>

   **Tip:** For more information on formatting your mailing labels, click Help on this page of the Report Wizard.

28. Click Next.

29. On the Template page, select No Template and click Finish to display your report output in the Paper Design view. It should look something like this:

   **Figure 6–2** Paper Design view for the mailing label report

30. Save your report as mailinglabel_your_initials.rdf.

### 6.3 Add Vertical Spacing

In this section, you will use the Vertical Spacing property to add space between each record in your mailing label report. You can adjust this spacing according to the size of the mailing labels where the records will be printed.

**To add vertical spacing:**

1. In the Object Navigator, under your report name, expand the Paper Layout node.
2. Under Paper Layout, expand the Main Section node.
3. Under Body, find the repeating frame called R_G_FIRST_NAME.
4. Double-click the repeating frame icon next to the R_G_FIRST_NAME node to display the Property Inspector.
5. Under Repeating Frame, next to Vert. Spacing Between Frames, type 0.25.
6. Press Enter to add your changes.
7. In the toolbar, click Run Paper Layout to display your report in the Paper Design view.

Your report should look something like this:

**Figure 6–3  Final mailing label report with vertical spacing**

<table>
<thead>
<tr>
<th>Hemann Baer</th>
<th>Adam Fripp</th>
</tr>
</thead>
<tbody>
<tr>
<td>Schwanthalerstr. 7031</td>
<td>2011 Interiors Blvd</td>
</tr>
<tr>
<td>Munich, Bavaria  80925</td>
<td>South San Francisco</td>
</tr>
<tr>
<td>Nancy Greenberg</td>
<td>Michael Hartstein</td>
</tr>
<tr>
<td>2004 Charade Rd</td>
<td>147 Spadina Ave</td>
</tr>
<tr>
<td>Seattle, Washington  98199</td>
<td>Toronto, Ontario  M5</td>
</tr>
</tbody>
</table>

**6.4 Summary**

Congratulations! You have successfully created a mailing label paper report. You now know how to:

- define a mailing label report using the Report Wizard.
- adjust the vertical spacing between labels.

For more information on any of the wizards, views, or properties used in this example, refer to the Oracle Reports online Help, which is available in Oracle Reports Builder or hosted on the Oracle Technology Network (OTN), as described in Section 4.1.1, "Using the Oracle Reports online Help".
In this chapter, you will learn about form letter reports, one of the standard report styles. By following the steps in this chapter, you can generate the report output shown in Figure 7–1.

**Figure 7–1  Form letter report output**

![Form letter report output](image)

**Concepts**

- Form letter reports contain database values embedded in boilerplate text (boilerplate text can be defined as any text that appears each time the report is run). It can be text generated by Oracle Reports, text you create, or text you import from a file.
- A form letter report is useful for printing multiple copies of the same letter addressed to different people.
- A form letter report is similar to a mailing label report, in that it is a simple report with a form letter layout style.

**Data Relationships**

There are no special restrictions on data relationships for a form letter report.

**Layout**

- A default form letter layout style is provided by Oracle Reports. It consists of the field names for the columns you have selected, prefixed by ampersands (&). The ampersands indicate that they are hidden fields, and are contained within boilerplate and repeating frame objects. You then add the text of the letter to the layout. Oracle Reports prints one record (that is, one letter) per page.
- Hidden fields, which are the default for a form letter layout, appear in the layout but not the output until referenced. You can do this in the Paper Layout view by typing its name, prefixed by an ampersand (&). Oracle Reports treats the reference as a normal field.
In general, if you are embedding a field within boilerplate text (as in a form letter), it is best to hide the field and reference it where desired. The field values will then flow with the text. A field can appear in a report both where placed by default in the report layout and where referenced. Fields can also be referenced more than once in the same piece of boilerplate text.

**Example Scenario**
As you build this example report, you will:

- **Use the Report Wizard to Create a Form Letter Report** with a paper layout that includes one query to select all of the columns displayed in this report. Oracle Reports will create all other necessary objects, for example, groups and columns, by default

To see a sample form letter report, open the examples folder called formletter, then open the Oracle Reports example report called formletter.rdf. For details on how to open it, see "Accessing the Example Reports" in the Preface.

### 7.1 Prerequisites for This Example
To build the example in this chapter, you must have access to the Human Resources sample schema (HR) provided with the Oracle Database. If you do not know if you have access to this sample schema, contact your database administrator.

### 7.2 Use the Report Wizard to Create a Form Letter Report
When you create a report, you can either use the Report Wizard to assist you or create the report yourself. To build the form letter report in this example, you can use the Report Wizard. Using the wizard enables you to define the layout for the report, as well as set the data definition.

In the Report Wizard, on the Text page, you will be able to set up your form letter report exactly the way you want it to appear. On this page of the wizard, you can set up your boilerplate text (for example, the body of the letter), and use the fields from your data tables to fill in the variable data (for example, the addressee's name).

**To create a form letter report:**

1. Launch Reports Builder (or, if already open, choose File > New > Report)
2. In the Welcome or New Report dialog box, select **Use the Report Wizard**, then click **OK**.
3. If the Welcome page displays, click **Next**.
4. On the Report Type page, select **Create Paper Layout Only**, then click **Next**.
5. On the Style page, type a **Title** for your report, select **Form Letter**, then click **Next**.
6. On the Data Source page, click **SQL Query**, then click **Next**.
7. On the Data page, enter the following **SELECT** statement in the **Data Source definition** field:

   ```sql
   SELECT ALL EMPLOYEES.LAST_NAME, EMPLOYEES.FIRST_NAME, JOBS.JOB_ID, 
   EMPLOYEES.EMPLOYEE_ID, JOBS.JOB_TITLE 
   FROM EMPLOYEES, JOBS 
   WHERE (EMPLOYEES.JOB_ID = JOBS.JOB_ID) 
   ORDER BY EMPLOYEES.EMPLOYEE_ID
   ```
Use the Report Wizard to Create a Form Letter Report

---

**Note:** You can enter this query in any of the following ways:

- Copy and paste the code from the provided text file called `formletter_code.txt` into the **Data Source definition** field.
- Click **Query Builder** to build the query without entering any code manually.
- Type the code in the **Data Source definition** field.

---

8. Click **Next**.

---

**Note:** If you are not already connected to a database, you will be prompted to connect to the database when you click **Query Builder** or **Next**. Ensure that you connect to a database that has the appropriate schema for this example. Section 7.1, "Prerequisites for This Example" describes the sample schema requirements for this example.

---

9. On the Text page, format the letter the way you want it to appear. The steps that follow will show you how to make your form letter report look like this:

   Employee: &<FIRST_NAME> &<LAST_NAME>
   Emp. #: &<EMPLOYEE_ID>

   Dear &<FIRST_NAME> &<LAST_NAME>:

   The Human Resources department is updating its records of the company’s employees. Currently, our records show your employee number as &<EMPLOYEE_ID>, and that you hold the position of &<JOB_TITLE>. If any of this information is incorrect, please contact the Human Resources department.

   Thank you,
   Human Resources

10. In the Form Letter Text box, type Employee:

11. Click **Space** four times to enter four spaces.

12. In the **Available Fields** list, click **FIRST_NAME**, then click the right arrow (>) to move this field to the **Form Letter Text** field.

13. In the **Available Fields** list, click **LAST_NAME**, then click the right arrow (>).

14. Click **New Line**.

15. In the **Form Letter Text** field, type Emp. #:

16. Click **Space** four times to enter four spaces.

17. In the **Available Fields** list, click **EMPLOYEE_ID**, then click the right arrow (>).

18. Click **New Line** twice.

19. In the **Form Letter Text** field, type Dear.
20. Click Space.

21. In the Available Fields list, click FIRST_NAME, then click the right arrow (>).

22. In the Available Fields list, click LAST_NAME, then click the right arrow (>).

23. In the Form Letter Text field, type a colon (:) next to LAST_NAME, then click New Line twice.

24. Type the body of the letter. For the field names, use the Available Fields list to select the appropriate name, then click the right arrow (>) to insert it into the Form Letter Text field. The result should look like this:

   The Human Resources department is updating its records of the company’s employees. Currently, our records show your employee number as &<EMPLOYEE_ID>, and that you hold the position of &<JOB_TITLE>. If any of this information is incorrect, please contact the Human Resources department.

   Thank you,
   Human Resources

25. Click Next.

26. On the Template page, select Predefined Template and click Beige, then click Finish to display your report output in the Paper Design view. It should look something like this:

   ![Paper Design view for the form letter report](image)

27. Save the report as formletterreport_your_initials.rdf.

7.3 Summary

Congratulations! You have successfully created a form letter paper report. You now know how to:


For more information on any of the wizards, views, or properties used in this example, refer to the Oracle Reports online Help, which is available in Oracle Reports Builder or hosted on the Oracle Technology Network (OTN), as described in Section 4.1.1, “Using the Oracle Reports online Help”.
In this chapter, you will learn about master/master reports. By following the steps in this chapter, you can generate the report output shown in Figure 8–1.

**Figure 8–1  Master/Master report output**

<table>
<thead>
<tr>
<th>Department ID</th>
<th>Department Name</th>
<th>Location ID</th>
</tr>
</thead>
<tbody>
<tr>
<td>10</td>
<td>Administration</td>
<td>1700</td>
</tr>
<tr>
<td>20</td>
<td>Marketing</td>
<td>1800</td>
</tr>
<tr>
<td>30</td>
<td>Purchasing</td>
<td>1700</td>
</tr>
<tr>
<td>40</td>
<td>Human Resources</td>
<td>2400</td>
</tr>
<tr>
<td>50</td>
<td>Shipping</td>
<td>1500</td>
</tr>
<tr>
<td>60</td>
<td>IT</td>
<td>1400</td>
</tr>
<tr>
<td>70</td>
<td>Public Relations</td>
<td>2700</td>
</tr>
<tr>
<td>80</td>
<td>Sales</td>
<td>2500</td>
</tr>
<tr>
<td>90</td>
<td>Executive</td>
<td>1700</td>
</tr>
</tbody>
</table>

**Figure 8–2  Master/Master report output**

<table>
<thead>
<tr>
<th>Last Name</th>
<th>First Name</th>
<th>Job ID</th>
<th>Salary</th>
</tr>
</thead>
<tbody>
<tr>
<td>Abet</td>
<td>Etan</td>
<td>SA_REP</td>
<td>$10000.00</td>
</tr>
<tr>
<td>Ander</td>
<td>Sander</td>
<td>GA_REP</td>
<td>$8400.00</td>
</tr>
<tr>
<td>Alkmanoe</td>
<td>Medha</td>
<td>ST_CLERK</td>
<td>$2800.00</td>
</tr>
<tr>
<td>Austin</td>
<td>David</td>
<td>IT_PROG</td>
<td>$4800.00</td>
</tr>
<tr>
<td>Baer</td>
<td>Hermann</td>
<td>PR_REP</td>
<td>$10000.00</td>
</tr>
<tr>
<td>Baida</td>
<td>Shell</td>
<td>PU_CLERK</td>
<td>$3900.00</td>
</tr>
<tr>
<td>Banda</td>
<td>Amrit</td>
<td>SA_REP</td>
<td>$6230.00</td>
</tr>
</tbody>
</table>

**Concepts**

A master/master report displays at least two sets of data that are not directly related—that is, the records constituting the data are fetched using at least two separate queries. A master/master report (also called a parent/parent report) contains two or more queries with no links (parent/child relationships).

**Data Relationships**

Although the data may be conceptually related, the queries make no attempt to relate it by the manner in which it is fetched. To select the data for a master/master report, you create two or more unrelated queries. Reports Builder will create all other necessary data objects by default.
Prerequisites for This Example

Layout
This report uses the default tabular layout style. You will move the layout objects associated with the second query to insert more space between the information fetched by the two queries and make your report easier to read.

Example Scenario
In this example, you will create a master layout that lists department names, numbers, and locations followed by another master layout that lists all employees with their job, titles, and salaries.

As you build this example report, you will:
- Create a New Report Manually.
- Use the Data Wizard to Create Two Queries.
- Use the Report Wizard to Layout the Data.
- Use the Paper Layout View to Add White Space.
- Format a Field to format monetary values.

To see a sample master/master report, open the examples folder named masterb, then open the Oracle Reports example named masterb.rdf. For details on how to access it, see "Accessing the Example Reports" in the Preface.

8.1 Prerequisites for This Example
To build the example in this chapter, you must have access to the Human Resources sample schema (HR) provided with the Oracle Database. If you do not know if you have access to this sample schema, contact your database administrator.

8.2 Create a New Report Manually
In this case, it is easier to create the data model and layout separately. Hence, an empty report would be created first, then add the queries, and then create the layouts.

To create a blank report:
1. Launch Reports Builder (or, if already open, choose File > New > Report)
2. In the Welcome or New Report dialog box, select Build a new report manually, then click OK.

8.3 Use the Data Wizard to Create Two Queries
When you create a report with multiple queries, it is typically easier to create all of the queries with the Data Wizard first and then create the layouts with the Reports Wizard.

To create the queries:
1. In the Data Model view, choose Insert > Query to display the Data Wizard.
2. If the Welcome page displays, click Next.
3. On the Query page, type Q_Dept for the Query name and click Next.
4. On the Data Source page, click SQL Query, then click Next.
5. On the Data page, enter the following `SELECT` statement in the **Data Source definition** field:

   ```sql
   SELECT DEPARTMENT_ID, DEPARTMENT_NAME, LOCATION_ID
   FROM DEPARTMENTS
   ```

   **Note:** You can enter this query in any of the following ways:
   - Copy and paste the code from the provided text file called `masterb_code.txt` into the **Data Source definition** field.
   - Click **Query Builder** to build the query without entering any code manually.
   - Type the code in the **Data Source definition** field.

6. Click Next.

   **Note:** If you are not already connected to a database, you will be prompted to connect to the database when you click **Query Builder** or **Next**. Ensure that you connect to a database that has the appropriate schema for this example. Section 8.1, "Prerequisites for This Example" describes the sample schema requirements for this example.

7. On the Groups page, click **Next**.

8. Click **Finish** to display the data model for your report in the Data Model view.

9. Repeat the steps above for a second query, but this time name your query `Q_Emp` and use the following `SELECT` statement:

   ```sql
   SELECT LAST_NAME, FIRST_NAME, JOB_ID, SALARY
   FROM EMPLOYEES
   ORDER BY LAST_NAME, FIRST_NAME
   ```

**Figure 8–3  Data model with two unrelated queries**

8.4 Use the Report Wizard to Layout the Data

Once your data model is complete, you need to create a layout for the data objects to display in the report output. The Report Wizard enables you to create layouts for your data model.
Tip: When you have multiple queries in your data model, make sure that you check the names of the groups associated with each query prior to entering the Report Wizard. The Report Wizard requires you to choose data for the layout by group name.

To create the layout:
1. In the Data Model view, right-click on the canvas, then choose Report Wizard.
2. In the Report Wizard, on the Report Type page, select Create Paper Layout only.
3. On the Style page, select Tabular.
4. On the Groups page, ensure that both groups from your data model appear in the Displayed Groups list.
5. On the Fields page, click the double right arrows (>>) to move all of the fields to the Displayed Fields list.
6. On the Template page, select Predefined Template and click Beige, then click Finish to display your report output in the Paper Design view. The output for the Department report should look something like this:

Figure 8–4  Paper Design view for the Master/Master report

8.5 Use the Paper Layout View to Add White Space

If you scroll down in the Paper Design view, you will notice that the field labels from the second query, Q_Emp, are located directly below the fields from the first query, Q_Dept. In fact, they are almost touching each other. For this report, you will move all of the layout objects belonging to Q_Emp down the page to create some white space between the two layouts.

To create white space between the layouts:
1. Move and resize the Report Editor window such that you can easily view it and the Object Navigator simultaneously.
2. Click the Paper Layout button in the toolbar of the Report Editor window to display the Paper Layout view.

3. In the Object Navigator, expand the Paper Layout node, then the Main Section node, then the Body node.

4. Click the frame named M_G_LAST_NAME_GRPFR. Notice that it is also now selected in the Paper Layout view.

5. Click the title bar of the Report Editor to make it the active window.

6. Press the down arrow key a few times to move the frame and all of its objects down the page about 0.25 inches (0.5 centimeters).

   Notice that you have moved not only M_G_LAST_NAME_GRPFR but also all the layout objects within it. Here you take advantage of Confine mode, the default mode for the Paper Layout view. With Confine mode on, an object cannot be moved outside of or placed behind its parent. Such a situation renders the layout invalid and no output is produced.

   Sometimes moving an object outside of its parent is a valid action. If you need to do so, you can turn off Confine mode by clicking the Confine Off button in the toolbar.

7. Save the report as masterb_your_initials.rdf.

8. Click the Paper Design button in the toolbar to preview your output again. Notice the additional space between the two layouts now.

---

**8.6 Format a Field**

In the Paper Design view, notice the Salary field. The values are neither aligned nor displayed as monetary amounts. You can quickly rectify this in the Paper Design view.
To assign a format mask to monetary values:

1. In the Paper Design view, select the first number value underneath the Salary label in the second layout. Notice that all of the values are immediately selected, indicating that you can change their properties simultaneously.

   **Tip:** If you are familiar with format mask syntax, you could now right-click the field values, choose Property Inspector, and choose or manually type a value for the Format Mask property.

2. Click the Currency button in the toolbar. A currency symbol immediately appears next to all of the values.

3. Click the Add Decimal Place button twice. Two decimal places are added to the right of the decimal point.

4. Click the Align Right button. All of the values are immediately right aligned.

5. Save your report.

**Figure 8–6  Paper Design view with monetary values formatted**

---

**8.7 Summary**

Congratulations! You have successfully created a master/master report. You now know how to:

- create queries with the Data Wizard.
- layout the data with the Report Wizard.
- create white space in the Paper Layout view.
- format fields in the Paper Design view.

For more information on any of the wizards, views, or properties used in this example, refer to the [Oracle Reports online Help](https://www.oracle.com), which is available in Oracle Reports Builder or hosted on the Oracle Technology Network (OTN), as described in Section 4.1.1, “Using the Oracle Reports online Help”.

---
In this chapter, you will learn about summary reports. By following the steps in this chapter, you can generate the report output shown in Figure 9–1.

Figure 9–1  Summary report output

<table>
<thead>
<tr>
<th>Sales Rep 7499</th>
<th>Cust Id</th>
<th>Dollars</th>
<th>% of Total</th>
</tr>
</thead>
<tbody>
<tr>
<td>104</td>
<td>$7160.00</td>
<td>50.80%</td>
<td></td>
</tr>
<tr>
<td>107</td>
<td>$713.00</td>
<td>5.02%</td>
<td></td>
</tr>
<tr>
<td><strong>Total:</strong></td>
<td><strong>$7870.00</strong></td>
<td><strong>7.60%</strong></td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Sales Rep 7621</th>
<th>Cust Id</th>
<th>Dollars</th>
<th>% of Total</th>
</tr>
</thead>
<tbody>
<tr>
<td>106</td>
<td>$8924.00</td>
<td>81.25%</td>
<td></td>
</tr>
<tr>
<td>105</td>
<td>$764.00</td>
<td>7.03%</td>
<td></td>
</tr>
<tr>
<td>104</td>
<td>$101.40</td>
<td>1.00%</td>
<td></td>
</tr>
<tr>
<td><strong>Total:</strong></td>
<td><strong>$9809.80</strong></td>
<td><strong>9.55%</strong></td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Sales Rep 7654</th>
<th>Cust Id</th>
<th>Dollars</th>
<th>% of Total</th>
</tr>
</thead>
<tbody>
<tr>
<td>102</td>
<td>$27775.50</td>
<td>100.00%</td>
<td></td>
</tr>
<tr>
<td><strong>Total:</strong></td>
<td><strong>$27775.50</strong></td>
<td><strong>100.00%</strong></td>
<td></td>
</tr>
</tbody>
</table>

Concepts

A summary report contains at least one column whose value or values consist of a summary of other data. A column that totals sales, a column that averages a list of commissions, and a column that shows the maximum amounts found in a series of purchase orders are all examples of summary columns.

Data Relationships

- The value or values in a summary column are calculated by summarizing data retrieved from another column. Reports Builder provides packaged summary functions you can use to compute the values of summary columns.
- By default, the values of a column summarizing data on a record-by-record basis appear in a default report column, as in the preceding example, where % of Total displays as a default tabular column.
- The values of a column summarizing data once per set of information (one summary for each break group) appear under the column of values it summarizes.
- The result of a column calculating one final result appears once at the bottom of the report.
The difference between a summary column and the columns in previous introductory reports is that you do not select summary columns from the database. You create the summary columns and add them to groups in your report.

To create a summary column, you need to define at least three properties:

- **Source** is the name of the column that contains the data on which the summary column performs its computations. The source column remains unchanged.

- **Function** is the type of summary to be performed. The function tells Reports Builder how to compute summary column values. The functions provided with Reports Builder are Average, Count, First, Last, Maximum, Minimum, % of Total, Standard Deviation, Sum, and Variance. (If none of the Reports Builder summary functions performs the computation you need for your report, you can create your own functions using PL/SQL.)

- **Reset At** is the level or frequency at which the summary columns value returns to zero. The reset level, also known as the reset group, determines when to reset the value of the summary column to zero—in other words, how much of the source column to summarize. You can specify that the summary column summarize all values of the source column for the entire report, you can summarize column values in a break group, or you can summarize column values on a record-by-record basis.

**Layout**

This report uses a master/detail layout style.

**Example Scenario**

In this example, you will create a report that displays and summarizes sales data by sales representative. This report includes the following summaries:

- The total of all orders from all customers for each sales representative.
- The percentage value of each customer's orders in relation to each sales representative's total orders.
- The percentage value of each sales representative's orders in relation to the total orders.
- The grand total of all orders in the report.

As you build this example report, you will:

- Create a Data Model and a Group Above Layout that includes summaries.
- Format Fields for monetary values.
- Examine the Summary Column Properties (optional) created by the Report Wizard.

To see a sample summary report, open the examples folder named *summary*, then open the Oracle Reports example called *summary.rdf*. For details on how to access it, see "Accessing the Example Reports" in the Preface.

### 9.1 Prerequisites for This Example

To build the example in this chapter, you must have access to the Order Entry sample schema provided with the Oracle Database. If you do not know if you have access to this sample schema, contact your database administrator.
9.2 Create a Data Model and a Group Above Layout

When you are creating a single-query report, such as this one, you can use the Report Wizard to create the data model and layout simultaneously.

To create a data model and layout:
1. Launch Reports Builder (or, if already open, choose File > New > Report).
2. In the Welcome or New Report dialog box, select Use the Report Wizard, then click OK.
3. If the Welcome page displays, click Next.
4. On the Report Type page, select Create Paper Layout Only, then click Next.
5. On the Style page, type a Title for your report, select Group Above, then click Next.
6. On the Data Source page, click SQL Query, then click Next.
7. On the Data page, enter the following SELECT statement in the Data Source definition field:

```sql
SELECT SALES_REP_ID, CUSTOMER_ID, SUM(ORDER_TOTAL) TOTAL
FROM ORDERS
GROUP BY SALES_REP_ID, CUSTOMER_ID
```

8. Click Next.

```
Note: You can enter this query in any of the following ways:

- Copy and paste the code from the provided text file called summary_code.txt into the Data Source definition field.
- Click Query Builder to build the query without entering any code manually.
- Type the code in the Data Source definition field.
```

9. On the Groups page, click SALES_REP_ID and click the right arrow (>) to move this field to the Group Fields list, then click Next.
10. On the Fields page, click the double right arrows (>>) to move all of the fields to the **Displayed Fields** list, then click **Next**.

11. On the Totals page, click **TOTAL** in the **Available Fields** list, then click **Sum**. Given the data model you are using, this step will create two summary columns for you:

   - SumTOTALPerSALES_REP_ID sums the total of TOTAL for each value of SALES_REP_ID (that is, for each sales representative).
   - SumTOTALPerReport sums the total of TOTAL for the entire report (that is, for all sales representatives).

12. Still on the Totals page, click **% of Total**. Given the data model you are using, this step will create two columns for you:

   - TotalTOTALPerCUSTOMER_ID calculates dollars for each customer (CUSTOMER_ID) as a percentage of the total dollars for each sales representative (SALES_REP_ID).
   - TotalTOTALPerSALES_REP_ID calculates dollars for each sales representative (SALES_REP_ID) as a percentage of the total dollars in the entire report.
13. Click Next.

14. On the Labels page, change the labels as follows, then click Next:

<table>
<thead>
<tr>
<th>Fields</th>
<th>Labels</th>
</tr>
</thead>
<tbody>
<tr>
<td>SALES_REP_ID</td>
<td>Sales Rep</td>
</tr>
<tr>
<td>CUSTOMER_ID</td>
<td>Customer</td>
</tr>
<tr>
<td>TOTAL</td>
<td>Dollars</td>
</tr>
</tbody>
</table>

15. On the Template page, make sure Beige is selected under Predefined Template.

16. Click Finish to display your report output in the Paper Design view.

### 9.3 Format Fields

In the Paper Design view, notice the Total field. The values are neither aligned nor displayed as monetary amounts. You can quickly rectify this in the Paper Design view.

**To assign a format mask to monetary values:**

1. In the Paper Design view, select the first number value underneath the Dollars label. Notice that all of the values are immediately selected, indicating that you can change their properties simultaneously.

   **Tip:** If you are familiar with format mask syntax, you could now right-click the field values, choose Property Inspector, and choose or manually enter a value for the Format Mask property.

2. Click the Currency button in the toolbar. A currency symbol immediately appears next to all of the values.

3. Click the Add Decimal Place button twice. Two decimal places are added to the right of the decimal point.

4. Resize the field by clicking and dragging the rightmost handle of the field approximately 0.5 inches (1.5 centimeters) to the left.
5. Click the Align Right button. All of the values are immediately right aligned.

6. Select the Dollars label itself.

7. Click the Align Right button.

8. Select the number value to the right of the **Total**: label.

9. Click the Currency button. A currency symbol immediately appears next to all of the values.

10. Click the Add Decimal Place button twice. Two decimal places are added to the right of the decimal point.

11. Click the Align Right button. All of the values are immediately right aligned.

**Figure 9–4  Summary report output with monetary values formatted**

<table>
<thead>
<tr>
<th>Sales Rep 7499</th>
<th>Custid</th>
<th>Dollars</th>
<th>% of Total:</th>
</tr>
</thead>
<tbody>
<tr>
<td>104</td>
<td>104</td>
<td>$7100.00</td>
<td>90.80%</td>
</tr>
<tr>
<td>102</td>
<td>102</td>
<td>$740.00</td>
<td>9.20%</td>
</tr>
<tr>
<td>Total:</td>
<td></td>
<td>$7870.00</td>
<td></td>
</tr>
<tr>
<td>% of Total:</td>
<td></td>
<td>7.60%</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Sales Rep 7521</th>
<th>Custid</th>
<th>Dollars</th>
<th>% of Total:</th>
</tr>
</thead>
<tbody>
<tr>
<td>106</td>
<td>106</td>
<td>$9024.40</td>
<td>91.25%</td>
</tr>
<tr>
<td>103</td>
<td>103</td>
<td>$764.00</td>
<td>7.75%</td>
</tr>
<tr>
<td>101</td>
<td>101</td>
<td>$101.40</td>
<td>1.00%</td>
</tr>
<tr>
<td>Total:</td>
<td></td>
<td>$9899.80</td>
<td></td>
</tr>
<tr>
<td>% of Total:</td>
<td></td>
<td>9.56%</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Sales Rep 7654</th>
<th>Custid</th>
<th>Dollars</th>
<th>% of Total:</th>
</tr>
</thead>
<tbody>
<tr>
<td>102</td>
<td>102</td>
<td>$27775.50</td>
<td>100.00%</td>
</tr>
<tr>
<td>Total:</td>
<td></td>
<td>$27775.50</td>
<td></td>
</tr>
<tr>
<td>% of Total:</td>
<td></td>
<td>26.81%</td>
<td></td>
</tr>
</tbody>
</table>

12. Go to the end of the report. The last value on the last page should be a summary labelled **Total**: which sums the values of TOTAL across the entire report.

13. Select the unformatted number to the right of the **Total**: label.

14. Click and drag this field until its right edge is aligned with the right edge of the values in the Total column.

15. Click the Currency button in the toolbar. A currency symbol immediately appears next to the Total value.

16. Click the Add Decimal Place button twice. Two decimal places are added to the right of the decimal point.

17. Click the Align Right button. All of the values are immediately right aligned.

18. Save the report as summaryb_your_initials.rdf.
Examine the Summary Column Properties (optional)

In this case, the Report Wizard created the summaries according to the requirements of the project. However, in some cases, you may need to manually adjust the settings of summaries to get the exact calculations you wish. By carefully reviewing the summaries created by the Report Wizard, you can gain a better understanding of how summaries work.

In this section, you will not be making any changes to the report, you will only be checking the summary settings to better understand summaries.

Reviewing summary settings

1. In the Paper Design view, select the percentage value to the right of the % of Total label.

2. Double-click the values to display the Property Inspector.

3. In the Property Inspector, notice the Source property, which indicates the column that is the source of the field.

4. Repeat steps 1 through 3 for all of the summaries in the report. Note down the name of the columns that are the sources for each of these summary fields.

5. In the Object Navigator, double-click the view icon next to the Data Model node to display the Data Model view.

6. In the Data Model view, double-click TotalTOTALPerSALES_REP_ID in group G_SALES_REP_ID to display the Property Inspector.

7. In the Property Inspector, notice the values of the properties under Summary:
   - Function is % of Total. Change % of Total to Sum. Notice that the Compute At property disappears because it is unnecessary for a Sum calculation. Change Function back to % of Total and Compute At reappears.
   - Source is the TOTAL column, which means that TOTAL has been used to compute the summary.
   - Reset At is G_SALES_REP_ID. The value of TotalTOTALPerREPID will reset to zero after each record in G_SALES_REP_ID (that is, for each sales representative).
8. Repeat steps 6 and 7 for each of the summaries in the data model. Notice the differences in the properties for each of the summaries.

9. It can also be a useful exercise to return to the Paper Design view and see where fields that correspond to the summaries are placed in the layout. For example, the field that corresponds to TotalTOTALPerSALES_REP_ID is placed inside the master repeating frame, R_G_SALES_REP_ID, but outside of the detail repeating frame, R_G_CUSTOMER_ID.

9.5 Summary

Congratulations! You have successfully created a summary report. You now know how to:

- create a data model with summaries and lay out the data with the Report Wizard.
- format fields in the Paper Design view.
- examine the summaries and their properties.

For more information on any of the wizards, views, or properties used in this example, refer to the Oracle Reports online Help, which is available in Oracle Reports Builder or hosted on the Oracle Technology Network (OTN), as described in Section 4.1.1, "Using the Oracle Reports online Help".
The chapters in this Part provide steps to build group reports. In these reports, the rows of output are displayed as groups based on a single query or on multiple queries. Group reports can contain formula columns and the values of the report can be printed from top to bottom or across a page.

- **Chapter 10, "Building a Single-Query Group Report"**
  A single-query group report contains a single query and divides the rows of a report into groups based on common values in one or more column(s). For example, employees can be grouped based on department numbers, which means each department number prints only once for every group. Otherwise, the department number would print once for every employee in the department. These reports include the group left and group above reports and were earlier known as break reports or master/detail reports.

- **Chapter 11, "Building a Two-Query Group Report"**
  A two-query group report appears much the same as a single-query group report except that the former report uses multiple queries. Multiple queries enable you to simplify maintenance or make the data model easier to understand.

- **Chapter 12, "Building an Across Group Report"**
  An across group report prints the values of a database column across the page instead of down. In these reports, the values in the master group print from top to bottom, and the values in the detail group print across the page, from left to right.

- **Chapter 13, "Building a Group Left Summary Report"**
  A group left summary report consists of master record values, detail records, and summaries. Summaries are totals calculated for the details under each master record.

- **Chapter 14, "Building a Group Left Formula Report"**
  A group left formula report contains a formula column, for which values are calculated based on a PL/SQL formula. A formula column, like a summary column, is a computational column that you create. This column performs user-defined calculations on other column(s) data including placeholder columns.
Building a Single-Query Group Report

In this chapter, you will learn about single-query group reports. By following the steps in this chapter, you can generate the report output shown in Figure 10–1.

**Figure 10–1  Group report output**

<table>
<thead>
<tr>
<th>Department Id</th>
<th>Job Id</th>
<th>Employee Id</th>
<th>First Name</th>
<th>Last Name</th>
<th>Salary</th>
</tr>
</thead>
<tbody>
<tr>
<td>10</td>
<td>AD_ASM</td>
<td>200</td>
<td>Jennifer</td>
<td>Whalen</td>
<td>$4400.00</td>
</tr>
<tr>
<td>20</td>
<td>MK_MAN</td>
<td>201</td>
<td>Michael</td>
<td>Hartstein</td>
<td>$13000.00</td>
</tr>
<tr>
<td></td>
<td>MK_REP</td>
<td>202</td>
<td>Bryden</td>
<td>Goyal</td>
<td>$8000.00</td>
</tr>
<tr>
<td>30</td>
<td>PU_CLERK</td>
<td>115</td>
<td>Alexander</td>
<td>Khoi</td>
<td>$3100.00</td>
</tr>
<tr>
<td></td>
<td></td>
<td>116</td>
<td>Sheik</td>
<td>Basla</td>
<td>$9500.00</td>
</tr>
<tr>
<td></td>
<td></td>
<td>117</td>
<td>Sige</td>
<td>Teikes</td>
<td>$2600.00</td>
</tr>
<tr>
<td></td>
<td></td>
<td>118</td>
<td>Karen</td>
<td>Colmenares</td>
<td>$2600.00</td>
</tr>
<tr>
<td></td>
<td></td>
<td>119</td>
<td>Guy</td>
<td>Himuro</td>
<td>$3600.00</td>
</tr>
<tr>
<td></td>
<td>PU_MAN</td>
<td>114</td>
<td>Dan</td>
<td>Raphaely</td>
<td>$11000.00</td>
</tr>
<tr>
<td>40</td>
<td>HR_REP</td>
<td>203</td>
<td>Susan</td>
<td>Morris</td>
<td>$6500.00</td>
</tr>
<tr>
<td>50</td>
<td>SH_CLERK</td>
<td>180</td>
<td>Winston</td>
<td>Taylor</td>
<td>$5200.00</td>
</tr>
<tr>
<td></td>
<td></td>
<td>185</td>
<td>Alexis</td>
<td>Bull</td>
<td>$4100.00</td>
</tr>
<tr>
<td></td>
<td></td>
<td>187</td>
<td>Anthony</td>
<td>Cabrion</td>
<td>$3000.00</td>
</tr>
<tr>
<td></td>
<td></td>
<td>186</td>
<td>Ana</td>
<td>Welsh</td>
<td>$5100.00</td>
</tr>
<tr>
<td></td>
<td></td>
<td>190</td>
<td>Vance</td>
<td>Jones</td>
<td>$2600.00</td>
</tr>
<tr>
<td></td>
<td></td>
<td>194</td>
<td>Samuel</td>
<td>McCam</td>
<td>$3200.00</td>
</tr>
</tbody>
</table>

**Concepts**

Group left and group above reports divide the rows of a report into "sets," based on common values in one or more of the columns, such as the department number in the preceding example. Notice that each department number prints only once. If the report above was not a group report, the department number would print once for each employee in the department rather than just once for the whole department.

**Note:** This type of report may also be referred to as a break report or a master/detail report.

**Example Scenario**

In this example, you will create a group left report that lists employees with their jobs and salaries by department. As you build this example report, you will:
10.1 Prerequisites for This Example

To build the example in this chapter, you must have access to the Human Resources sample schema (HR) provided with the Oracle Database. If you do not know if you have access to this sample schema, contact your database administrator.

10.2 Group Report with One Break Column

The most basic case of a group left or above report is to have one break group with one break column in it. This means that a single master field value will print once for many detail field values.

To see a sample group left report with one break column, open the examples folder named break, then open the Oracle Reports example named grp1col_lft1.rdf. For details on how to open it, see “Accessing the Example Reports” in the Preface.

Concepts

- Create a group left (or above) report when you want to prevent a column from repeatedly displaying the same value while other column values in the rows change.
- You can build a group left or above report with either a single-query or multiple queries. A single-query report typically runs faster than a multiquery report.
- You must ensure that your SELECT statement includes a column, called a break column, containing at least one value which repeats over multiple records (for example, department number in the example report above). With the break column, you will create a second group, called a break group, to create the breaks in the data.
- This report uses a default tabular format. You will improve the readability of the report by changing the vertical spacing for a repeating frame to insert a space between each set of department information (for example, between the last record of Department 10 and the first record of Department 20, as shown in the example report above). You will also add a format mask.
10.2.1 Create a data model with a break group and group left layout

When you are creating a single-query report, such as this one, you can use the Report Wizard to create the data model and layout simultaneously.

To create a data model and layout:
1. Launch Reports Builder (or, if already open, choose File > New > Report)
2. In the Welcome or New Report dialog box, select Use the Report Wizard, then click OK.
3. If the Welcome page displays, click Next.
4. On the Report Type page, select Create Paper Layout Only, then click Next.
5. On the Style page, type a Title for your report, select Group Left, then click Next.
6. On the Data Source page, click SQL Query, then click Next.
7. On the Data page, enter the following SELECT statement in the Data Source definition field:

   ```sql
   SELECT EMPLOYEE_ID, FIRST_NAME, LAST_NAME,
       JOB_ID, SALARY, DEPARTMENT_ID
   FROM EMPLOYEES
   ```

   Note: You can enter this query in any of the following ways:
   - Copy and paste the code from the provided text file called across_code.txt into the Data Source definition field.
   - Click Query Builder to build the query without entering any code manually.
   - Type the code in the Data Source definition field.

8. Click Next.

   Note: If you are not already connected to a database, you will be prompted to connect to the database when you click Query Builder or Next. Ensure that you connect to a database that has the appropriate schema for this example. Section 10.1, “Prerequisites for This Example” describes the sample schema requirements for this example.

9. On the Groups page, click DEPARTMENT_ID and click the right arrow (>) to move this field to the Group Fields list, then click Next.
10. On the Fields page, click the double right arrows (>>) to move all of the fields to the Displayed Fields list.


12. On the Template page, select Predefined Template and click Beige, then click Finish to display your report output in the Paper Design view. It should look something like this:
10.2.2 Format a field

In the Paper Design view, notice the Salary field. The values are neither aligned nor displayed as monetary amounts. You can quickly rectify this in the Paper Design view.

To assign a format mask to monetary values:

1. In the Paper Design view, click the first number value underneath the Salary label. Notice that all of the values are immediately selected, indicating that you can change their properties simultaneously.

2. Click the Currency button in the toolbar. A currency symbol immediately appears next to all of the values.

3. Click the Add Decimal Place button twice. Two decimal places are added to the right of the decimal point.

4. Resize the fields. Click and drag the right most handle of the cell value under the Salary label about 0.5 inches (1.5 centimeters) to the left.

5. Shift-click the Salary label.

6. Click the Align Right button in the toolbar.

7. Click in an open area of the Paper Design view to deselect all of the objects.

8. Save the report as grp_lft2_your_initials.rdf.
10.2.3 Use the Property Inspector to add white space

If you examine your report output in the Paper Design view, you will notice that it can be difficult to distinguish where one department's data ends and the next department's data begins. To make the report more readable, you want to add some white space between the departments, but you want to retain the same spacing between employee rows. For this report, you will change a repeating frame property for the master repeating frame to create some white space between the department records.

To create white space between the departments:

1. In the Paper Design view, click the first number value underneath the Department Id label. Notice that all of the department numbers are immediately selected.

2. Click the Select Parent Frame button in the toolbar. Notice how the border of the repeating frame that contains the Department Id field is now highlighted.

3. Choose Tools > Property Inspector to display the Property Inspector, and set the following properties:
   - Under Repeating Frame, set the Vert. Space Between Frames property to 0.25.
4. Click the title bar of the Report Editor to make it the active window again.
5. Save your report.

**Figure 10–6  Property Inspector for master repeating frame**

![Property Inspector for master repeating frame]

**Figure 10–7  Paper Design view after white space is added**

<table>
<thead>
<tr>
<th>Department Id</th>
<th>Employee Id</th>
<th>First Name</th>
<th>Last Name</th>
<th>Job Id</th>
<th>Salary</th>
</tr>
</thead>
<tbody>
<tr>
<td>10</td>
<td>200</td>
<td>Jennifer</td>
<td>Whalen</td>
<td>AD_ASST</td>
<td>$4400.00</td>
</tr>
<tr>
<td>20</td>
<td>201</td>
<td>Michael</td>
<td>Neustein</td>
<td>MK_MAN</td>
<td>$13000.00</td>
</tr>
<tr>
<td></td>
<td>202</td>
<td>Paul</td>
<td>Fay</td>
<td>MK_REP</td>
<td>$9300.00</td>
</tr>
<tr>
<td>30</td>
<td>114</td>
<td>Dan</td>
<td>Raphael</td>
<td>PU_MAN</td>
<td>$11000.00</td>
</tr>
<tr>
<td>115</td>
<td>Alexander</td>
<td>Khoo</td>
<td></td>
<td>PU_CLERK</td>
<td>$31000.00</td>
</tr>
<tr>
<td>116</td>
<td>Shelli</td>
<td>Basilla</td>
<td></td>
<td>PU_CLERK</td>
<td>$23000.00</td>
</tr>
<tr>
<td>119</td>
<td>Karen</td>
<td>Colmanares</td>
<td></td>
<td>PU_CLERK</td>
<td>$25000.00</td>
</tr>
<tr>
<td>118</td>
<td>Guy</td>
<td>Hirano</td>
<td></td>
<td>PU_CLERK</td>
<td>$25000.00</td>
</tr>
<tr>
<td>117</td>
<td>Gay</td>
<td>Tolivres</td>
<td></td>
<td>PU_CLERK</td>
<td>$25000.00</td>
</tr>
<tr>
<td>40</td>
<td>203</td>
<td>Susan</td>
<td>Mavis</td>
<td>HR_REP</td>
<td>$65000.00</td>
</tr>
</tbody>
</table>
10.3 Group Report with Two Break Columns

Figure 10-8  Group left report output with two break columns

<table>
<thead>
<tr>
<th>Department Id</th>
<th>Job Id</th>
<th>Employee Id</th>
<th>First Name</th>
<th>Last Name</th>
<th>Salary</th>
</tr>
</thead>
<tbody>
<tr>
<td>10</td>
<td>AD_ASST</td>
<td>200</td>
<td>Jennifer</td>
<td>Whalen</td>
<td>$4400.00</td>
</tr>
<tr>
<td>20</td>
<td>MK_MAN</td>
<td>201</td>
<td>Michael</td>
<td>Heitstein</td>
<td>$13000.00</td>
</tr>
<tr>
<td>20</td>
<td>MK_REP</td>
<td>202</td>
<td>Brajesh</td>
<td>Goyal</td>
<td>$6000.00</td>
</tr>
<tr>
<td>30</td>
<td>PU_CLERK</td>
<td>116</td>
<td>Alexander</td>
<td>Khoo</td>
<td>$3100.00</td>
</tr>
<tr>
<td>116</td>
<td></td>
<td></td>
<td>Shelli</td>
<td>Buida</td>
<td>$2000.00</td>
</tr>
<tr>
<td>117</td>
<td>Sigal</td>
<td>Tobias</td>
<td></td>
<td></td>
<td>$2600.00</td>
</tr>
<tr>
<td>118</td>
<td>Karan</td>
<td>Colomano</td>
<td></td>
<td></td>
<td>$2500.00</td>
</tr>
<tr>
<td>118</td>
<td>Guy</td>
<td>Henuto</td>
<td></td>
<td></td>
<td>$2800.00</td>
</tr>
<tr>
<td>30</td>
<td>PU_MAN</td>
<td>114</td>
<td>Dan</td>
<td>Raphaely</td>
<td>$11000.00</td>
</tr>
<tr>
<td>40</td>
<td>HR_REP</td>
<td>203</td>
<td>Susan</td>
<td>Marvin</td>
<td>$6500.00</td>
</tr>
<tr>
<td>50</td>
<td>SH_CLERK</td>
<td>180</td>
<td>Winston</td>
<td>Taylor</td>
<td>$3200.00</td>
</tr>
<tr>
<td>166</td>
<td>Alexis</td>
<td>Bull</td>
<td></td>
<td></td>
<td>$4100.00</td>
</tr>
<tr>
<td>187</td>
<td>Anthony</td>
<td>Castro</td>
<td></td>
<td></td>
<td>$3000.00</td>
</tr>
</tbody>
</table>

The report above looks similar to the group left report you built in Section 10.2, "Group Report with One Break Column". However, notice that DEPARTMENT_ID values sometimes print more frequently than they did in the previous report. The DEPARTMENT_ID value repeats for each unique value of JOB_ID within the department. This behavior occurs because DEPARTMENT_ID is now grouped with JOB_ID and must print with JOB_ID. While DEPARTMENT_ID values may repeat several times, not until the position of PU_CLERK in department 30 does a job repeat, and not until that point can the break group actually break.

**Concepts**

- You can specify that your report break on certain combinations of information by varying the columns you include in the break group.
- You can modify your previous report by moving JOB_ID into the break group, so that your report has two break columns instead of one.
- After changing the data model, redefault the layout to incorporate your changes, then specify the format mask again.

To see a sample group left report with two break columns, open the examples folder named `break`, then open the Oracle Reports example named `grp2col_lft1.rdf`. For details on how to access it, see "Accessing the Example Reports" in the Preface.

10.3.1 Modify the data model

The first task in changing your previous report is to modify the data model by placing an additional column in the break group.

**To add a column to the break group:**

1. Open the report you created in the previous section.
2. In the Object Navigator, double-click the view icon next to the **Data Model** node to display the Data Model view.

3. In the Data Model view, click the break group, **G_DEPARTMENT_ID**, then click and drag the handle on the bottom center of the **G_DEPARTMENT_ID** group box down about 0.25 inches (0.5 centimeters) to resize it.

4. Click and drag the **JOB_ID** column in the **G_EMPLOYEE_ID** group and move it into the **G_DEPARTMENT_ID** group, underneath the **DEPARTMENT_ID** column.

![Data model with two break columns](image)

**Figure 10–9  Data model with two break columns**

10.3.2 Redefault the layout

In order for your data model change to be reflected in your output, you need to redefault the layout for your report using the Report Wizard.

**To redefault the layout with the Report Wizard:**

1. Click the title bar of the Report Editor to make it the active window. The Report Editor must be the active window for you to access the Report Wizard.

2. Choose **Tools > Report Wizard**.

3. Select **Create Paper Layout only**.

4. Click **Finish**. Notice the changes to the output in the Paper Design view. Also note how the formatting of the Salary field and the additional spacing between records is retained. When possible, Reports Builder will retain your manual modifications between uses of the Report Wizard.

5. Save your report.
10.4 Group Report with Two Break Groups

The figure above shows a further modification of your group left report. In this version, DEPARTMENT_ID prints only once for each department. JOB_ID also prints only once when more than one employee in a department has the same job. Both columns are now in separate break groups and DEPARTMENT_ID is in the higher group. Hence, it does not repeat for each unique value of JOB_ID within a department any more.

Concepts
- You can also create reports that include multiple break groups and assign one or more columns to each break group.
- You will further modify the data model to include two break groups: G_DEPARTMENT_ID and G_JOB_ID.
- After changing the data model, redefault the layout to incorporate your changes, then specify the format mask again.

To see a sample group left report with two break groups, open the examples folder named break, then open the Oracle Reports example named grp_lft2.rdf. For details on how to access it, see "Accessing the Example Reports" in the Preface.

10.4.1 Modify the data model

The first task in changing your previous report is to modify the data model by creating another break group.

To add another break group:
1. Open the report you created in the previous section.
2. In the Object Navigator, double-click the view icon next to the Data Model node to display the Data Model view.
3. In the Data Model view, click and drag the group, G_EMPLOYEE_ID, down about 0.25 inches (0.5 centimeters).

4. Click the JOB_ID column in G_DEPARTMENT_ID and drag it to a spot somewhere in between G_DEPARTMENT_ID and G_EMPLOYEE_ID. Another break called G_JOB_ID is created.

10.4.2 Redefault the layout

In order for your data model change to be reflected in your output, you need to redefine the layout for your report using the Report Wizard.

To redefine the layout with the Report Wizard:

1. Click the title bar of the Report Editor to make it the active window. The Report Editor must be the active window for you to access the Report Wizard.


3. Select Create Paper Layout only.


5. Save your report.

10.5 Summary

Congratulations! You have successfully created a single-query group report. You now know how to:

- create a data model and layout with the Report Wizard.
- format fields in the Paper Design view.
- add white space between records with the Property Inspector.
- add another column to the break group and redefine the layout.
- add another break group and redefine the layout.

For more information on any of the wizards, views, or properties used in this example, refer to the Oracle Reports online Help, which is available in Oracle Reports Builder or hosted on the Oracle Technology Network (OTN), as described in Section 4.1.1, "Using the Oracle Reports online Help".
Building a Two-Query Group Report

In this chapter, you will learn about multiquery group reports. By following the steps in this chapter, you can generate the report output shown in Figure 11–1.

Figure 11–1  Group above report output, two queries

<table>
<thead>
<tr>
<th>Name</th>
<th>Emp. No.</th>
<th>Product</th>
<th>Amount</th>
<th>Customer</th>
</tr>
</thead>
<tbody>
<tr>
<td>ALLEN</td>
<td>7499</td>
<td>ACE TENNIS RACKET</td>
<td>$300.00</td>
<td>EVERY MOUNTAIN</td>
</tr>
<tr>
<td></td>
<td></td>
<td>ACE TENNIS RACKET</td>
<td>$10.00</td>
<td>EVERY MOUNTAIN</td>
</tr>
<tr>
<td></td>
<td></td>
<td>ACE TENNIS BALLS-6 PACK</td>
<td>$36.00</td>
<td>EVERY MOUNTAIN</td>
</tr>
<tr>
<td></td>
<td></td>
<td>SP TENNIS RACKET</td>
<td>$24.00</td>
<td>EVERY MOUNTAIN</td>
</tr>
<tr>
<td></td>
<td></td>
<td>SP JUNIOR RACKET</td>
<td>$50.00</td>
<td>EVERY MOUNTAIN</td>
</tr>
<tr>
<td></td>
<td></td>
<td>RH &quot;GUIDE TO TENNIS&quot;</td>
<td>$4.00</td>
<td>EVERY MOUNTAIN</td>
</tr>
<tr>
<td></td>
<td></td>
<td>BB ENERGY BAR-6 PACK</td>
<td>$20.00</td>
<td>EVERY MOUNTAIN</td>
</tr>
<tr>
<td></td>
<td></td>
<td>BB VITA SNACK-6 PACK</td>
<td>$20.00</td>
<td>EVERY MOUNTAIN</td>
</tr>
<tr>
<td></td>
<td></td>
<td>ACE TENNIS RACKET</td>
<td>$48.00</td>
<td>WOMENS SPORTS</td>
</tr>
<tr>
<td></td>
<td></td>
<td>ACE TENNIS BALLS-3 PACK</td>
<td>$36.00</td>
<td>WOMENS SPORTS</td>
</tr>
<tr>
<td></td>
<td></td>
<td>ACE TENNIS BALLS-6 PACK</td>
<td>$25.00</td>
<td>WOMENS SPORTS</td>
</tr>
<tr>
<td>WARD</td>
<td>7521</td>
<td>ACE TENNIS RACKET</td>
<td>$48.00</td>
<td>JUST TENNIS</td>
</tr>
<tr>
<td></td>
<td></td>
<td>ACE TENNIS BALLS-3 PACK</td>
<td>$16.00</td>
<td>JUST TENNIS</td>
</tr>
<tr>
<td></td>
<td></td>
<td>ACE TENNIS NET</td>
<td>$16.00</td>
<td>JUST TENNIS</td>
</tr>
<tr>
<td></td>
<td></td>
<td>RH &quot;GUIDE TO TENNIS&quot;</td>
<td>$3.00</td>
<td>JUST TENNIS</td>
</tr>
<tr>
<td></td>
<td></td>
<td>BB ENERGY BAR-6 PACK</td>
<td>$4.00</td>
<td>JUST TENNIS</td>
</tr>
<tr>
<td></td>
<td></td>
<td>ACE TENNIS RACKET</td>
<td>$48.00</td>
<td>SHAPE UP</td>
</tr>
<tr>
<td></td>
<td></td>
<td>ACE TENNIS RACKET</td>
<td>$48.00</td>
<td>SHAPE UP</td>
</tr>
<tr>
<td></td>
<td></td>
<td>ACE TENNIS BALLS-3 PACK</td>
<td>$16.00</td>
<td>SHAPE UP</td>
</tr>
</tbody>
</table>

Concepts

As you can see above, a two-query group report appears much the same as a single-query group report. Performance is the key issue when contrasting single-query and multiple-query group reports. In most cases, single-query reports will run faster than multiple-query reports. The multiple-query reports are, however, sometimes easier to understand conceptually and easier to maintain. For example, if you are in a situation where only a few users run the report and the report returns a relatively small number of records, you might want to use multiple queries to simplify maintenance and make the data model easier to understand. If you have many users and the report is quite large, then you should try to use a single-query report.
Data Relationships

- The single and multiple-query group reports look the same but have different data models. A single-query report has multiple groups underneath one query, while a multiple-query report uses one group underneath each of several queries. In the single-query case, the relationship is established by the hierarchy of groups underneath the query. In the multiple-query case, the relationship is established by data links between the groups of different queries.

- A data link is a data model object that enables you to relate multiple queries. For a simple group report, you relate the two queries using the primary and foreign keys of the tables from which you are selecting data.

- A primary key is a column for which each value uniquely identifies the record in which it is found. A foreign key is a column which contains the same values as the primary key for another table, and has been used to reference records in that table.

- Linking two tables through primary and foreign keys is similar to specifying a join condition. In fact, the data link causes Reports Builder to create a SQL clause defining a join, based on information specified when creating the link. This clause is added to the child query’s `SELECT` statement at run time.

- The join defined by a default data link is an outer join—in addition to returning all rows that satisfy the link’s condition, an outer join returns all rows from one table that do not match a row from the second table.

Layout

- This report uses a default group above layout style in which master records display across the page with the labels to the left of their fields and the detail records appear below the master records in standard tabular format.

- You will deselect one default column to keep it from appearing in the report, change some field widths to ensure the fields fit across the page, and format one of the fields.

- You will also specify a maximum of one master record per page to ensure that only one master record and its associated detail records are displayed per page of report output.

Example Scenario

In this example, you will create a group above report that lists employees with their jobs and salaries by department.

As you build this example report, you will:

- **Create a New Report Manually** to create a new, empty report.
- **Create a Data Model with a Data Link** between two queries.
- **Use the Report Wizard to Layout the Data.**
- **Format a Field** to format monetary values.

---

**Note:** For more information on streamlining your report’s performance, refer to the chapter "Diagnosing and Tuning Oracle Reports" in the *Publishing Reports to the Web with Oracle Reports Services*. 

---
To see a sample group above report with two queries, open the examples folder named masterdetail, then open the Oracle Reports example named grp_above.rdf. For details on how to access it, see "Accessing the Example Reports" in the Preface.

### 11.1 Prerequisites for This Example

To build the example in this chapter, you must have access to the Summit Sporting Goods (SUMMIT) schema. To download the SQL scripts that install the schema, see "Accessing the Data Sources" in the Preface.

### 11.2 Create a New Report Manually

In this case, it is easier to create the data model and layout separately. Hence, an empty report would be created first, then add the queries, and then create the layouts.

**To create a blank report:**
1. Launch Reports Builder (or, if already open, choose File > New > Report)
2. In the Welcome or New Report dialog box, select Build a new report manually, then click OK.

### 11.3 Create a Data Model with a Data Link

When you create a report with multiple queries, it is typically easier to create all of the queries with the Data Wizard first and then create the layouts with the Report Wizard.

**To create the queries:**
1. In the Data Model view, choose Insert > Query to display the Data Wizard.
2. If the Welcome page displays, click Next.
3. On the Query page, type Q_Salesrep for the Query name and click Next.
4. On the Data Source page, click SQL Query, then click Next.
5. On the Data page, enter the following SELECT statement in the Data Source definition field:

   ```sql
   SELECT ENAME, EMPNO
   FROM EMP
   WHERE JOB = 'SALESMAN'
   ```

   **Note:** You can enter this query in any of the following ways:
   - Copy and paste the code from the provided text file called grp_above_code.txt into the Data Source definition field.
   - Click Query Builder to build the query without entering any code manually.
   - Type the code in the Data Source definition field.
6. Click Next.
Create a Data Model with a Data Link

7. On the Groups page, click Next.

8. Click Finish to display the data model for your report in the Data Model view.

9. Repeat the steps above for a second query, but this time name your query Q_Product and use the following SELECT statement:

    ```sql
    SELECT REPID, PRODNAME, AMOUNT, CUSTNAME
    FROM SALES
    ORDER BY REPID, CUSTNAME
    ```

**Figure 11–2 Two-query data model without a link**

To add the data link

1. In the Data Model view, click the Data Link tool in the tool palette.

2. Click and drag from the EMPNO column in the G_ENAME group to the REPID column in the G_REPID group. Notice that a line is drawn from the bottom of the G_ENAME group to the Q_Product query. Labels for EMPNO and REPID are created at each end of the line to indicate they are the columns linking G_ENAME to Q_Product.

**Figure 11–3 Two-query data model with a data link**

3. Double-click the new data link line to display the Property Inspector and examine the property settings:

---

**Note:** If you are not already connected to a database, you will be prompted to connect to the database when you click Query Builder or Next. Ensure that you connect to a database that has the appropriate schema for this example. Section 11.1, "Prerequisites for This Example" describes the sample schema requirements for this example.
G_ENAME is identified as the parent, while Q_Product is listed as the child. In terms of the data, the sales rep’s name and employee number make up the master record and should print once for the associated product information retrieved by the Q_Product query.

Notice that WHERE already appears in the SQL Clause property. WHERE is the default clause used in master/detail relationships. You can replace WHERE with other SQL clauses such as HAVING and START WITH, but for this report the default is correct.

The other point to notice is that an equal sign (=) appears in the Condition property. An equality (that is, table1.columnname = table2.columnname) is the default condition for master/detail relationships defined through a data link. You can replace the equal sign with any other supported conditional operator (to see what is supported, click the field), but for this report the default is the proper condition.

Linking the group G_ENAME and the query Q_Product through the EMPNO and REPID columns is analogous to writing both queries as the single-query shown below:

```
SELECT ENAME, EMPNO, REPID,
PRODNAME, AMOUNT, CUSTNAME
FROM EMP, SALES
WHERE JOB = 'SALESMAN'
AND EMPNO = REPID (+)
ORDER BY REPID, CUSTNAME
```

11.4 Use the Report Wizard to Layout the Data
Once your data model is complete, you need to create a layout for the data objects to display in the report output. The Report Wizard enables you to create layouts for your data model.

**Tip:** When you have multiple queries in your data model, make sure that you check the names of the groups associated with each query prior to entering the Report Wizard. The Report Wizard requires you to choose data for the layout by group name.

**To create the layout:**
1. In the Data Model view, right-click on the canvas, then choose Report Wizard.
2. In the Report Wizard, on the Report Type page, select Create Paper Layout only.
3. On the Style page, select Group Above.
4. On the Groups page, ensure that both groups from your data model appear in the Displayed Groups list.
5. On the Fields page:
   - Click the double right arrows (>>) to move all of the fields to the Displayed Fields list.
   - Click REPID in the Displayed Fields list and click the left arrow (<) to move it back to the Available Fields list. Since REPID and EMPNO represent the same value, you only need to display one of them. EMPNO is part of the master group, which is the level where we want to see its values in the report. REPID is part of the detail group. Hence, you remove REPID from the Displayed Fields list to prevent it from appearing in the output.
6. On the **Labels** page, change the labels and field widths as follows:

<table>
<thead>
<tr>
<th>Fields</th>
<th>Labels</th>
<th>Width</th>
</tr>
</thead>
<tbody>
<tr>
<td>PRODNAME</td>
<td>Product</td>
<td>22</td>
</tr>
<tr>
<td>AMOUNT</td>
<td>(no change)</td>
<td>10</td>
</tr>
<tr>
<td>CUSTNAME</td>
<td>Customer</td>
<td>15</td>
</tr>
<tr>
<td>ENAME</td>
<td>Name</td>
<td>(no change)</td>
</tr>
<tr>
<td>EMPNO</td>
<td>Emp. No.</td>
<td>(no change)</td>
</tr>
</tbody>
</table>

7. On the **Template** page, make sure **Beige** is selected under **Predefined Template**, then click Finish to display your report output in the Paper Design view. It should look like this:
In the Paper Design view, notice the Amount field. The values are neither aligned nor displayed as monetary amounts. You can quickly rectify this in the Paper Design view.

**To assign a format mask to monetary values:**

1. In the Paper Design view, select the first number value underneath the Amount label. Notice that all of the values are immediately selected, indicating that you can change their properties simultaneously.

   **Tip:** If you are familiar with format mask syntax, you could now right-click the field values, choose Property Inspector, and choose or manually enter a value for the Format Mask property.

2. Click the Currency button in the toolbar. A currency symbol immediately appears next to all of the values.

3. Click the Add Decimal Place button twice. Two decimal places are added to the right of the decimal point.

4. Resize the field by clicking and dragging the right most handle of the field approximately a 0.5 inches (1.5 centimeters) to the left.

5. Click the Align Right button. All of the values are immediately right aligned.

6. Select the Amount label.

7. Click the Align Right button.

8. Save the report as `grp_above_your_initials.rdf`.

The final report output should look something like this:
Congratulations! You have successfully created the two-query, group report. You now know how to:

- create queries with a data link between them in the Data Model view.
- layout the data with the Report Wizard.
- format a field in the Paper Design view.

For more information on any of the wizards, views, or properties used in this example, refer to the Oracle Reports online Help, which is available in Oracle Reports Builder or hosted on the Oracle Technology Network (OTN), as described in Section 4.1.1, "Using the Oracle Reports online Help".

### Figure 11–6  Group above report output with monetary values formatted

<table>
<thead>
<tr>
<th>Product</th>
<th>Amount</th>
<th>Customer</th>
</tr>
</thead>
<tbody>
<tr>
<td>ACE TENNIS RACKET I</td>
<td>$300.00</td>
<td>EVERY MOUNTAIN</td>
</tr>
<tr>
<td>ACE TENNIS RACKET II</td>
<td>$60.00</td>
<td>EVERY MOUNTAIN</td>
</tr>
<tr>
<td>ACE TENNIS BALLS-6 PACK</td>
<td>$30.00</td>
<td>EVERY MOUNTAIN</td>
</tr>
<tr>
<td>SP TENNIS RACKET</td>
<td>$2.00</td>
<td>EVERY MOUNTAIN</td>
</tr>
<tr>
<td>SP JUNIOR RACKET</td>
<td>$1.00</td>
<td>EVERY MOUNTAIN</td>
</tr>
<tr>
<td>RH &quot;GUIDE TO TENNIS&quot;</td>
<td>$20.00</td>
<td>EVERY MOUNTAIN</td>
</tr>
<tr>
<td>SB ENERGY BAR-6 PACK</td>
<td>$2.00</td>
<td>EVERY MOUNTAIN</td>
</tr>
<tr>
<td>SB VITA SNACK-6 PACK</td>
<td>$1.00</td>
<td>EVERY MOUNTAIN</td>
</tr>
<tr>
<td>ACE TENNIS BALLS-3 PACK</td>
<td>$1.00</td>
<td>WOMENS SPORTS</td>
</tr>
<tr>
<td>ACE TENNIS BALLS-6 PACK</td>
<td>$2.00</td>
<td>WOMENS SPORTS</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Product</th>
<th>Amount</th>
<th>Customer</th>
</tr>
</thead>
<tbody>
<tr>
<td>ACE TENNIS RACKET II</td>
<td>$150.00</td>
<td>JUST TENNIS</td>
</tr>
<tr>
<td>ACE TENNIS BALLS-3 PACK</td>
<td>$1.00</td>
<td>JUST TENNIS</td>
</tr>
<tr>
<td>ACE TENNIS BALLS-6</td>
<td>$1.00</td>
<td>JUST TENNIS</td>
</tr>
<tr>
<td>RH &quot;GUIDE TO TENNIS&quot;</td>
<td>$1.00</td>
<td>JUST TENNIS</td>
</tr>
<tr>
<td>SB ENERGY BAR-6 PACK</td>
<td>$1.00</td>
<td>JUST TENNIS</td>
</tr>
<tr>
<td>ACE TENNIS RACKET I</td>
<td>$400.00</td>
<td>SHAPE UP</td>
</tr>
<tr>
<td>ACE TENNIS RACKET II</td>
<td>$500.00</td>
<td>SHAPE UP</td>
</tr>
<tr>
<td>ACE TENNIS BALLS-3 PACK</td>
<td>$1.00</td>
<td>SHAPE UP</td>
</tr>
</tbody>
</table>

### 11.6 Summary
Building an Across Group Report

In this chapter, you will learn about across group reports. By following the steps in this chapter, you can generate the report output shown in Figure 12–1.

Figure 12–1  Across group report output

<table>
<thead>
<tr>
<th>Department Id</th>
<th>Last Name</th>
<th>First Name</th>
<th>Department Name</th>
</tr>
</thead>
<tbody>
<tr>
<td>10</td>
<td>Whalen</td>
<td></td>
<td>Administration</td>
</tr>
<tr>
<td>20</td>
<td>Goyal</td>
<td>Birgash</td>
<td>Marketing</td>
</tr>
<tr>
<td>30</td>
<td>Baiada</td>
<td>Shelli</td>
<td>Purchasing</td>
</tr>
<tr>
<td></td>
<td>Ceminares</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Himuro</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Karen</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Guy</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Concepts

- Reports Builder enables you to modify the look of your report in multiple ways. In this example, you will build an across group report that prints the values of a database column across the page instead of down.

- In across reports with breaks, the master (or break) group prints "top to bottom"; that is, as it would in other master/detail reports. However, the values in the detail group print across the page, from left to right. When there are more values than will fit on a line, Oracle Reports wraps the line and prints the remaining values across the page on the next line. Note, however, in the case of ENHANCEDSPREADSHEET output, the across group keeps repeating (until it reaches the 75,000 rows limit). This is natural Excel behavior because Excel does not have a fixed "page width", and Oracle Reports adapts ENHANCEDSPREADSHEET output to this Excel behavior.

- For more information on break reports, refer to the Oracle Reports online Help.

Data Relationships

The break in this report is created through a data link between a master group and a detail query.

Layout

To create the layout used in this report, you will select the master/detail style, then modify the Print Direction setting for one of the groups to ensure it prints across the page instead of down the page.

Example Scenario

As you build this example report, you will:
Prerequisites for This Example

- Create Two Queries that select all of the columns displayed, then link them to establish a master/detail relationship
- Create the Default Layout using the Report Block Wizard.
- Run Your Report to Paper.

To see a sample across report with control breaks, open the examples folder called acrossbreak, then open the Oracle Reports example report named acrossbreak.rdf. For details on how to open it, see "Accessing the Example Reports" in the Preface.

12.1 Prerequisites for This Example

To build the example in this chapter, you must have access to the Human Resources sample schema (HR) provided with the Oracle Database. If you do not know if you have access to this sample schema, contact your database administrator.

12.2 Create Two Queries

When you create a report, you can either use the Report Wizard to assist you or create the report yourself. In this example, you will use the Data Model view to create your two queries, then use the tool palette to create a data link between the two queries to relate the data tables.

To create two queries:

1. Launch Reports Builder (or, if already open, choose File > New > Report)
2. In the Welcome or New Report dialog box, select Build a new report manually, then click OK.
3. In the Data Model view that displays, click the SQL Query tool in the tool palette then click in an open area of the Data Model view to display the SQL Query Statement dialog box.
4. In the SQL Query Statement field, enter the following SELECT statement:
   
   ```
   SELECT ALL DEPARTMENTS.DEPARTMENT_ID, DEPARTMENTS.DEPARTMENT_NAME, DEPARTMENTS.MANAGER_ID, DEPARTMENTS.LOCATION_ID
   FROM DEPARTMENTS
   ```
   
   5. Click OK.

   The data model for your new query displays:

   Note: You can enter this query in any of the following ways:
   - Copy and paste the code from the provided text file called acrossbreak_code.txt into the SQL Query Statement field.
   - Click Query Builder to build the query without entering any code manually.
   - Type the code in the SQL Query Statement field.
6. Create another query, this time using the following code:

```sql
SELECT ALL EMPLOYEES.LAST_NAME, EMPLOYEES.FIRST_NAME, EMPLOYEES.DEPARTMENT_ID FROM EMPLOYEES ORDER BY EMPLOYEES.LAST_NAME
```

**Note:** You can also copy and paste the code from the text file provided in the acrossbreak folder, called acrossbreak_code.txt.

7. Click OK.

8. In the Data Model view, click the Data Link tool in the tool palette.

9. Click and drag your mouse from DEPARTMENT_ID column in Q_1, to DEPARTMENT_ID1 in Q_2 to create a data link between the two queries. Your data model should now look like this:

**Figure 12–3 Data Model of the two linked queries**

**Note:** You can right-click the data link, then choose Property Inspector from the pop-up menu to ensure that the data link was created properly.

### 12.3 Create the Default Layout

The steps in this section show you how to use the Report Block Wizard to create the layout and choose how your data will display in your report. Here, you will choose
the style of report you want to create, and choose to display the data across the report (hence creating the across group report).

**To create the default layout:**
1. In the Object Navigator, double-click the Paper Layout node to display the Paper Layout view.
2. In the Paper Layout view, choose Insert > Report Block to display the Report Block Wizard.
3. In the Report Block Wizard, on the Style page, select Group Above, then click Next.
4. On the Groups page:
   - Click G_LAST_NAME in the Available Groups list, then click Across to specify the Print Direction and move this field to the Displayed Groups list.
   - Click G_DEPARTMENT_ID, then click Down.
   - Click Next.
5. On the Fields page, click the right arrow (>) to move the following fields from the Available Fields list to the Displayed Fields list, then click Next:
   - DEPARTMENT_ID
   - DEPARTMENT_NAME
   - LAST_NAME
   - FIRST_NAME
6. On the Labels page, click Next.
7. On the Template page, make sure Beige is selected under Predefined Template, then click Finish to display your report output in the Paper Design view. It should look like this:

![Figure 12–4 Paper Layout view for the across group report](image)

**12.4 Run Your Report to Paper**

In this section, you will run your report to the Paper Design view so you can see how your report displays.

1. Click the Paper Design button in the toolbar. Your report runs, then displays in the Paper Design view. It should look like the following:
Congratulations! You have successfully created an across group paper report. You now know how to:

- manually create a data model with two queries.
- create a master/detail report using the Report Block Wizard.

For more information on any of the wizards, views, or properties used in this example, refer to the Oracle Reports online Help, which is available in Oracle Reports Builder or hosted on the Oracle Technology Network (OTN), as described in Section 4.1.1, "Using the Oracle Reports online Help".

2. Save your report as `acrossbreak_your_initials.rdf`.
In this chapter, you will learn about group left summary reports. By following the steps in this chapter, you can generate the report output shown in Figure 13–1.

Figure 13–1  Group left summary report output

<table>
<thead>
<tr>
<th>Name</th>
<th>Product</th>
<th>Itemtot</th>
<th>Orderdate</th>
</tr>
</thead>
<tbody>
<tr>
<td>EVERY MOUNTAIN</td>
<td>ACE TENNIS BALLS 6 PACK</td>
<td>$6.60</td>
<td>18-JUL-86</td>
</tr>
<tr>
<td></td>
<td></td>
<td>$11.00</td>
<td>26-JUL-86</td>
</tr>
<tr>
<td></td>
<td></td>
<td>$27.00</td>
<td>16-JAN-87</td>
</tr>
<tr>
<td></td>
<td></td>
<td>$550.00</td>
<td>22-FEB-87</td>
</tr>
<tr>
<td></td>
<td>ACE TENNIS RACKET I</td>
<td>$3000.00</td>
<td>15-JAN-87</td>
</tr>
<tr>
<td></td>
<td>ACE TENNIS RACKET II</td>
<td>$810.00</td>
<td>16-JAN-87</td>
</tr>
<tr>
<td></td>
<td>RH: &quot;GUIDE TO TENNIS&quot;</td>
<td>$340.00</td>
<td>22-FEB-87</td>
</tr>
<tr>
<td></td>
<td>SB ENERGY BARS PACK</td>
<td>$240.00</td>
<td>22-FEB-87</td>
</tr>
<tr>
<td></td>
<td>SB VITA SNACK 6 PACK</td>
<td>$420.00</td>
<td>22-FEB-87</td>
</tr>
<tr>
<td></td>
<td>SP JUNIOR RACKET</td>
<td>$1700.00</td>
<td>16-JAN-87</td>
</tr>
<tr>
<td></td>
<td>SP TENNIS RACKET</td>
<td>$24.00</td>
<td>25-JUL-86</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Product</th>
<th>Sum Total</th>
</tr>
</thead>
<tbody>
<tr>
<td>ACE TENNIS BALLS 6</td>
<td>$846.80</td>
</tr>
<tr>
<td>ACE TENNIS RACKET I</td>
<td>$3300.00</td>
</tr>
<tr>
<td>ACE TENNIS RACKET II</td>
<td>$810.00</td>
</tr>
<tr>
<td>RH: &quot;GUIDE TO TENNIS&quot;</td>
<td>$340.00</td>
</tr>
<tr>
<td>SB ENERGY BARS PACK</td>
<td>$240.00</td>
</tr>
<tr>
<td>SB VITA SNACK 6 PACK</td>
<td>$420.00</td>
</tr>
<tr>
<td>SP JUNIOR RACKET</td>
<td>$1700.00</td>
</tr>
<tr>
<td>SP TENNIS RACKET</td>
<td>$24.00</td>
</tr>
</tbody>
</table>

Concepts

- This report consists of master records (Name, at the upper left of the figure above), detail records (Product, Itemtot, and Orderdate, to the upper right), and summary records (Product, and Sum Total). The summary calculates totals for the details under each master record. Notice that the column Product appears twice. With Reports Builder, you can display columns any number of times.

- A master/detail summary report is a master/detail report that also contains one or more summaries.

Data Relationships

- This report will use two queries to select data from four tables. The master query will select the customer name, while the detail query will select the information associated with the products ordered by each customer.
Because the detail query will select data from several tables, you’ll need to specify joins to link the information in the tables together.

You’ll drag a column out of the detail group to further group the data. You’ll also create a summary column to calculate the item totals.

**Layout**

The layout for this report is constructed in two parts. The top portion contains the master and detail information, and is created using the Report Wizard. The second portion is constructed by hand in the Paper Layout view and formats the summary.

You’ll also resize two groups in the layout to ensure that the new, user-created bottom portion of the layout is integrated into the top portion, omit some columns from the layout that were queried only to join the tables, and include more space between instances of a repeating frame.

**Example Scenario**

In this example, you will create a report that displays and summarizes sales data by customer. This report would include the following for each customer:

- a list of the products they purchased by order date and how much they spent on each product
- a summary for each customer that shows how much they spent in total on each product over time

As you build this example report, you will:

- Create a New Report Manually to create a new, empty report.
- Create a Data Model with a Data Link between two queries.
- Use the Paper Layout View to Create Two Layouts.
- Merge the Two Layouts to combine the separate layouts into one.
- Format Fields to format monetary values.

To see a sample master/detail summary report, open the examples folder named masterdetailsummary, then open the Oracle Reports example called grp_above_summ.rdf. For details on how to access it, see "Accessing the Example Reports" in the Preface.

### 13.1 Prerequisites for This Example

To build the example in this chapter, you must have access to the Summit Sporting Goods (SUMMIT) schema. To download the SQL scripts that install the schema, see "Accessing the Data Sources" in the Preface.

### 13.2 Create a New Report Manually

In this case, it is easier to create the data model and layout separately. Hence, an empty report would be created first, then add the queries, and then create the layouts.

**To create a blank report:**

1. Launch Reports Builder (or, if already open, choose File > New > Report).
2. In the Welcome or New Report dialog box, select **Build a new report manually**, then click **OK**.

### 13.3 Create a Data Model with a Data Link

When you create a report with multiple queries, it is typically easier to create all of the queries with the Data Wizard first and then create the layouts with the Report Wizard.

**To create the queries:**

1. In the Data Model view, choose **Insert > Query** to display the Data Wizard.
2. If the Welcome page displays, click **Next**.
3. On the Query page, type **Q_Customer** for the **Query name**, then click **Next**.
4. On the Data Source page, select **SQL Query**, then click **Next**.
5. On the Data page, enter the following **SELECT** statement in the **Data Source definition** field:

   ```sql
   SELECT CUSTID, NAME
   FROM CUSTOMER
   ORDER BY NAME
   ```

   **Note:** You can enter this query in any of the following ways:
   - Copy and paste the code from the provided text file called `grp_above_summ_code.txt` into the **Data Source definition** field.
   - Click **Query Builder** to build the query without entering any code manually.
   - Type the code in the **Data Source definition** field.

6. Click **Next**.

   **Note:** If you are not already connected to a database, you will be prompted to connect to the database when you click **Query Builder** or **Next**. Ensure that you connect to a database that has the appropriate schema for this example. Section 13.1, "Prerequisites for This Example" describes the sample schema requirements for this example.

7. On the Groups page, click **Next**.
8. Click **Finish** to display your first query in the Data Model view.
9. Repeat the steps above for a second query, but this time name your query **Q_Item** and use the following **SELECT** statement:

   ```sql
   SELECT CUSTID, DESCRIP, ITEMTOT, ORDERDATE, ITEM.ORDID
   FROM ORD, PRODUCT, ITEM
   WHERE ITEM.ORDID = ORD.ORDID
   AND ITEM.PRODID = PRODUCT.PRODID
   ORDER BY CUSTID, DESCRIP, ORDERDATE
   ```

10. On the Groups page of the Data Wizard:
Create a Data Model with a Data Link

- Click CUSTID1 and click the right arrow (>) to move this field to the **Group Fields** list.
- Do the same for DESCRIP.

*Figure 13–2  Groups page of the Data Wizard*

![Groups page of the Data Wizard]

11. Click **Next**.

12. On the **Totals** page, click ITEMTOT and click **Sum**.

13. Click **Finish** to display the data model for your report in the Data Model view. It should look something like this:

*Figure 13–3  Two-query data model with summaries*

![Two-query data model with summaries]

**To add the data link:**

1. In the Data Model view, click the Data Link tool in the tool palette.

2. Click and drag from the CUSTID column in the **G_CUSTID** group to the **G_CUSTID1** column in the **G_CUSTID1** group. Notice that a line is drawn from the bottom of the **G_CUSTID** group to the **Q_Item** query. Labels for CUSTID and
CUSTID1 are created at each end of the line to indicate they are the columns linking G_CUSTID to Q_Item.

Figure 13–4 Two-query data model with a data link

3. Double-click the new data link line to display the Property Inspector and examine the property settings:

- G_CUSTID is identified as the parent, while Q_Item is listed as the child. In terms of the data, the customer’s identifier and name make up the master record and should print once for the associated item order information retrieved by the Q_Item query.
- Notice that WHERE already appears in the SQL Clause property. WHERE is the default clause used in master/detail relationships. You can replace WHERE with other SQL clauses such as HAVING and START WITH, but for this report the default is correct.
- The other point to notice is that an equal sign (=) appears in the Condition property. An equality (that is, table1.columnname = table2.columnname) is the default condition for master/detail relationships defined through a data link. You can replace the equal sign with any other supported conditional operator (to see what is supported, click the field), but for this report the default is the proper condition.

13.4 Use the Paper Layout View to Create Two Layouts

Once your data model is complete, you need to create a layout for the data objects to display in the report output. This particular report consists of two separate layouts:

- a group left layout for listing customer purchases individually
- a tabular layout that shows a summary of the customer’s purchases by product

Given that two layouts are required, you need to create the first layout through the Report Wizard and the second by inserting a report block. The reason for taking this approach is that the Report Wizard overwrites everything in the layout. Hence, you can only create the first layout through the Report Wizard. Additional layouts must be created by inserting a report block.

To create the first layout:

2. On the **Report Type** page, select **Create Paper Layout only**.

3. On the **Style** page, select **Group Left**.

4. On the **Groups** page, ensure that all of the groups from your data model appear in the **Displayed Groups** list.

5. On the **Fields** page, click column names and the right arrow (>) or left arrow (<) to move columns so that the following columns appear in the **Displayed Fields** list:
   - NAME
   - DESCRIP
   - ITEMTOT
   - ORDERDATE

   **Figure 13–5  Fields page of Report Wizard**

6. On the **Labels** page, change the labels and field widths as follows:

   **Table 13–1  Field Description Labels Page**

<table>
<thead>
<tr>
<th>Fields</th>
<th>Labels</th>
<th>Width</th>
</tr>
</thead>
<tbody>
<tr>
<td>NAME</td>
<td>(no change)</td>
<td>15</td>
</tr>
<tr>
<td>DESCRIP</td>
<td>Product</td>
<td>20</td>
</tr>
<tr>
<td>ITEMTOT</td>
<td>(no change)</td>
<td>(no change)</td>
</tr>
<tr>
<td>ORDERDATE</td>
<td>(no change)</td>
<td>(no change)</td>
</tr>
</tbody>
</table>

   **Table 13–1  Field Description Labels Page**

7. On the **Template** page, make sure **Beige** is selected under **Predefined Template**, then click Finish to display your report output in the Paper Design view. It should look like this:
Use the Paper Layout View to Create Two Layouts

**Figure 13–6  Paper Design view for the group left layout with two group columns**

<table>
<thead>
<tr>
<th>Name</th>
<th>Product</th>
<th>Itemtot</th>
<th>Orderdate</th>
</tr>
</thead>
<tbody>
<tr>
<td>EVERY MOUNTAIN</td>
<td>ACE TENNIS BALLS 6 PACK</td>
<td>5.6</td>
<td>18-JUL-86</td>
</tr>
<tr>
<td></td>
<td></td>
<td>1.2</td>
<td>25-JUL-86</td>
</tr>
<tr>
<td></td>
<td></td>
<td>5.50</td>
<td>15-JAN-87</td>
</tr>
<tr>
<td></td>
<td></td>
<td>200</td>
<td>22-FEB-87</td>
</tr>
<tr>
<td></td>
<td>ACE TENNIS RACKET I</td>
<td>3000</td>
<td>15-JAN-87</td>
</tr>
<tr>
<td></td>
<td>ACE TENNIS RACKET II</td>
<td>810</td>
<td>15-JAN-87</td>
</tr>
<tr>
<td></td>
<td>RI: “GUIDE TO TENNIS”</td>
<td>340</td>
<td>22-FEB-87</td>
</tr>
<tr>
<td></td>
<td>SH ENERGY BAR 6 PACK</td>
<td>240</td>
<td>22-FEB-87</td>
</tr>
<tr>
<td></td>
<td>SH VITA SNACK 6 PACK</td>
<td>400</td>
<td>22-FEB-87</td>
</tr>
<tr>
<td></td>
<td>JP JUNIOR RACKET</td>
<td>1500</td>
<td>15-JAN-87</td>
</tr>
<tr>
<td></td>
<td>SP TENNIS RACKET</td>
<td>24</td>
<td>25-JUL-86</td>
</tr>
<tr>
<td>JOCKSPORTS</td>
<td>ACE TENNIS BALLS 3 PACK</td>
<td>125</td>
<td>01-AUG-86</td>
</tr>
<tr>
<td></td>
<td></td>
<td>200</td>
<td>15-MAR-87</td>
</tr>
<tr>
<td></td>
<td>ACE TENNIS NET</td>
<td>50</td>
<td>01-AUG-86</td>
</tr>
<tr>
<td></td>
<td>ACE TENNIS RACKET I</td>
<td>350</td>
<td>12-MAR-87</td>
</tr>
<tr>
<td></td>
<td>ACE TENNIS RACKET II</td>
<td>35</td>
<td>01-AUG-86</td>
</tr>
<tr>
<td></td>
<td></td>
<td>400</td>
<td>15-MAR-87</td>
</tr>
<tr>
<td></td>
<td>RH: “GUIDE TO TENNIS”</td>
<td>3.4</td>
<td>14-JUL-86</td>
</tr>
<tr>
<td></td>
<td></td>
<td>1700</td>
<td>12-MAR-87</td>
</tr>
<tr>
<td>JUST TENNIS</td>
<td>ACE TENNIS BALLS 3 PACK</td>
<td>140</td>
<td>03-FEB-87</td>
</tr>
</tbody>
</table>

**To create the second layout:**

1. Click the Paper Layout button in the toolbar to display the Paper Layout view.
2. In the Paper Layout view, click the Report Block tool in the tool palette.
3. Starting about 0.5 inches (1.5 centimeters) below the existing layout, click and drag a box about 2 inches (5 centimeters) high and 4 inches (19 centimeters) wide. Release your mouse button to display the Report Block Wizard.
4. In the Report Block Wizard, on the Style page, select Tabular, then click Next.
5. On the Groups page, click G_CUSTID1 and click Down to specify the Print Direction and move this group to the Displayed Groups list, then click Next. (G_CUSTID1 should be the only group in the Displayed Groups list when you are done.)
6. On the Fields page, click the following fields and click the right arrow (>) to move them to the Displayed Fields list, then click Next:
   - DESCRIP
   - SumITEMTOTPerCUSTID1.
   DESCRIP and SumITEMTOTPerCUSTID1 should be the only fields in the Displayed Fields list when you are done.
7. On the Labels page, change the labels as follows, then click Next:

**Table 13–2  Field Description**

<table>
<thead>
<tr>
<th>Fields</th>
<th>Labels</th>
</tr>
</thead>
<tbody>
<tr>
<td>DESCRIP</td>
<td>Product</td>
</tr>
<tr>
<td>SumITEMTOTPerCUSTID1</td>
<td>Sum Total</td>
</tr>
</tbody>
</table>
8. On the Template page, make sure **Beige** is selected under **Predefined Template**, then click Finish to display your report output in the Paper Design view. It should look like this:

![Figure 13–7  Paper Layout view with two layouts](image)

### 13.5 Merge the Two Layouts

After you have created the two layouts, you have only achieved part of your desired result. The summary of purchases by product is outside of the master/detail layout. Hence it summarizes the product purchases for the entire report rather than the product purchases for each customer. To show the summary for each customer, you must move the second layout inside of the first one.

**To merge the second layout with the first:**

1. In the Object Navigator, select **M_G_CUSTID1_GRPFR1**.

   **Tip:** To make finding this frame easier, just type in the name in the Find field at the top of the Object Navigator.

2. Click the title bar of the Report Editor to return to the Paper Layout view. Notice that the frame around the second layout is now selected for you.

3. Use the arrow keys to position the second layout so that the **F_DESCRIP1** field lines up with the **F_DESCRIP** field in the first layout.

4. Click the Confine Off button in the toolbar. Ensure that Flex mode is on (it is on by default).

5. In the Object Navigator, select **R_G_CUSTID**.

6. Click the title bar of the Report Editor to return to the Paper Layout view. Notice that the master repeating frame in the first layout is now selected for you.

7. Click the handle at the bottom center of **R_G_CUSTID** and drag it down about 0.5 inches (1.5 centimeters). Because Flex Mode is on, the frame surrounding it grows
as you drag. Similarly, the second layout is moved down to avoid being overwritten.


9. Change the Vert. Space Between Frames property to 0.25.

10. In the Object Navigator, select M_G_CUSTID1_GRPFR1.

11. Click the title bar of the Report Editor to return to the Paper Layout view.

12. Using the toolbar along the top of the Paper Layout view, turn Flex Mode off.

13. Using the arrow keys, move M_G_CUSTID1_GRPFR1 and its contents inside of the first layout.

![Figure 13–8  Paper Layout view with two layouts merged into one](image)

14. Click the Paper Design button in the toolbar of the Report Editor to display the Paper Layout view. Notice how the summary table now repeats for each customer.
13.6 Format Fields

In the Paper Design view, notice the monetary values are neither aligned nor displayed as monetary amounts. You can quickly rectify this in the Paper Design view.

To assign a format mask to monetary values:

1. In the Paper Design view, shift-click the values underneath the Itemtot and Sum Total. Notice that all of the values are immediately selected, indicating that you can change their properties simultaneously.

2. Click the Currency button in the toolbar. A currency symbol immediately appears next to all of the values.

3. Click the Add Decimal Place button twice. Two decimal places are added to the right of the decimal point.

4. Resize the fields. Click and drag the right most handle of the Itemtot field approximately 0.5 inches (1.5 centimeters) to the left. Repeat for the Sum Total field. Try to have the right boundaries of the two fields align with each other.

5. Click the Align Right button. All of the values are immediately right aligned.

6. Shift-click the Itemtot label and the Sum Total label.

7. Click the Align Right button.

8. Save your report as grp_above_summ_your_initials.rdf.
13.7 Summary

Congratulations! You have successfully created a group left summary report. You now know how to:

- create two queries with a data link between them.
- create two separate layouts.
- combine the separate layouts into one.
- format monetary values.

For more information on any of the wizards, views, or properties used in this example, refer to the Oracle Reports online Help, which is available in Oracle Reports Builder or hosted on the Oracle Technology Network (OTN), as described in Section 4.1.1, "Using the Oracle Reports online Help".
In this chapter, you will learn about group left formula reports, containing formula columns. By following the steps in this chapter, you can generate the report output shown in Figure 14–1.

**Figure 14–1  Formula report output**

<table>
<thead>
<tr>
<th>Customer Id</th>
<th>Order Id</th>
<th>Order Total</th>
<th>Tax</th>
<th>Sales Total</th>
</tr>
</thead>
<tbody>
<tr>
<td>101</td>
<td>2456</td>
<td>76279.6</td>
<td>5473.572</td>
<td>81753.172</td>
</tr>
<tr>
<td>2447</td>
<td>53963.6</td>
<td>2372.952</td>
<td>30260.152</td>
<td></td>
</tr>
<tr>
<td>2430</td>
<td>22689.9</td>
<td>2078.683</td>
<td>31168.723</td>
<td></td>
</tr>
<tr>
<td>2413</td>
<td>45662</td>
<td>6989.64</td>
<td>61850.64</td>
<td></td>
</tr>
<tr>
<td>Total</td>
<td>110035.1</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

**Concepts**

- A formula column, like a summary column, is a computational column you create yourself. Unlike a summary, its values are calculated based on a PL/SQL formula you provide. The formula may use data from another column in the report, but is not required to do so.

- A formula column performs a user-defined computation on another column(s) data, including placeholder columns. Formula columns should not be used to set values for parameters.

- A formula column contains at least one column whose value or values are computed using a PL/SQL formula. Formula columns are similar in usage to summary columns.

- For more information on formula columns, refer to the Oracle Reports online Help.

**Data Relationships**

- To create a formula report, create a query and select your data. Next, create additional columns and add them to groups in your report. Specify their formulas in the column property sheets.

- As with summaries, you do not select formulas from the database. unlike summaries, which use packaged computations shipped with Oracle Reports, formula columns use formulas you provide by referencing PL/SQL functions. These formulas can be any legal PL/SQL constructs, which allow a great deal of flexibility in the formulas you use.
Prerequisites for This Example

A formula performs computations using data from a single record, which can span multiple columns. This is in contrast to a summary, which summarizes the data from multiple records in a single column.

Layout
This report uses the default group left format with no modifications.

Example Scenario
As you build this example report, you will:

Use the Report Wizard to Create a Simple Report with Group Left style that includes one query that selects all the necessary database columns.

Create Two Formula Columns manually to calculate tax and order totals for each customer, then add the formula columns to your report.

To see a sample formula report, open the examples folder called formula, then open the Oracle Reports example report named formula.rdf. For details on how to open it, see "Accessing the Example Reports" in the Preface.

14.1 Prerequisites for This Example

To build the example in this chapter, you must have access to the Order Entry sample schema provided with the Oracle Database. If you do not know if you have access to this sample schema, contact your database administrator.

14.2 Use the Report Wizard to Create a Simple Report

When you create a report, you can either use the Report Wizard to assist you or create the report yourself. To build the simple report in this example, you can use the Report Wizard. Using the wizard enables you to define the layout for the report, as well as set the data definition.

To create a simple report:
1. Launch Reports Builder (or, if already open, choose File > New > Report).
2. In the Welcome or New Report dialog box, select Use the Report Wizard, then click OK.
3. If the Welcome page displays, click Next.
4. On the Report Type page, select Create Paper Layout Only, then click Next.
5. On the Title page, select Group Left, then click Next.
6. On the Data Source page, click SQL Query, then click Next.
7. On the Data page, enter the following SELECT statement in the Data Source field:

```
SELECT ALL CUSTOMERS_A1.CUSTOMER_ID, ORDERS.ORDER_ID, ORDERS.ORDER_TOTAL
FROM CUSTOMERS CUSTOMERS_A1, ORDERS
WHERE (ORDERS.CUSTOMER_ID = CUSTOMERS_A1.CUSTOMER_ID)
ORDER BY CUSTOMERS_A1.CUSTOMER_ID
```
8. Click Next.

9. On the Groups page, select CUSTOMER_ID and click the right arrow (>) to move this field to the Groups Fields list, then click Next.

10. On the Fields page, click the double right arrow button (>>) to move all of the fields to the Displayed Fields list, then click Next.

11. On the Totals page, click ORDER_TOTAL and click Sum, then click Next.

12. On the Template page, select Predefined Template and click Beige, then click Finish to display your report output in the Paper Design view. It should look something like this:

Figure 14–2  Paper Design view for the formula report

13. Save the report as formulareport_your_initials.rdf.

14.3 Create Two Formula Columns

Frequently, you want to base calculations on values in your data source. One way you can do this is by using formula columns. The steps in this section will show you how to create two formula columns that calculate the following values:

Note: You can enter this query in any of the following ways:

- Copy and paste the code from the provided text file called formula_code.txt into the Data Source definition field.
- Click Query Builder to build the query without entering any code manually.
- Type the code in the Data Source definition field.
Create Two Formula Columns

- the tax on each order
- the grand total for each customer, including tax

14.3.1 Create a formula column to calculate the tax

To create a formula column that calculates the tax:
1. In Reports Builder, click the Data Model button in the toolbar to display the Data Model view of your report.

The data model should look something like this:

Figure 14–3  Data Model of the Formula Report

2. Click the Formula Column tool in the tool palette, then click in the G_ORDER_ID group under ORDER_TOTAL to create a formula column.

   Tip: To view the names of the tools in the tool palette and the toolbar, drag and hold your mouse over each icon and hint text will display describing the icon.

3. Double-click the new formula column object (CF_1) to display the Property Inspector, and set the following properties:
   - Under General Information, set the Name property to Tax.
   - Under Placeholder/Formula, click the PL/SQL Formula property field to display the PL/SQL Editor.

4. In the PL/SQL Editor, use the template to enter the following PL/SQL code:

   ```plsql
   function TAXFormula return Number is
     tax number;
   begin
     tax := :ORDER_TOTAL * .07;
     return (tax);
   end;
   
   5. Click Compile.

6. If no errors display, click Close. If errors display, verify that your code looks exactly like the above code, paying close attention to the column names.
7. Close the Property Inspector.
You have created a formula column that calculates the tax (7%) of each order.

14.3.2 Create a formula column that calculates customer order totals

To create a formula column that calculates customer order totals:
1. Repeat Steps 2 and 3 from Section 14.3.1, "Create a formula column to calculate the tax": click the Formula Column tool in the tool palette, then click in the G_ORDER_ID group under TAX. Then, double-click CF_1 to display the Property Inspector.
2. Change the name of the column to SALES_TOTAL.
3. Open the PL/SQL Editor and modify your formula so that it looks like this:
   
   ```plsql
   function SALES_TOTALFormula return Number is
   sales_total number;
   begin
   sales_total := :ORDER_TOTAL + :TAX;
   return (sales_total);
   end;
   ```
4. Click Compile.
5. If no errors display, click Close. If errors display, verify that your code looks exactly like the above code, paying close attention to the column names.
You have created a formula column that calculates the total orders of each customer. Your data model should now look something like this:

   ![Diagram of Data Model with Formula Columns]

14.3.3 Add the formula columns to the report layout

Now that you have created your formula columns, you must add them to your report layout. The easiest way to do this is to return to the Report Wizard.
To add formula columns to your report layout:

1. In the Data Model view, right-click on the canvas, then choose Report Wizard.

2. In the Report Wizard, click the Fields tab. In the Available Fields list, you should now see your two new formula columns. Click each one, then click the right arrow (>) to move them to the Displayed Fields list.

3. Click Finish to display your report output in the Paper Design view. It should look something like this:

Figure 14–5  Final formula report output

<table>
<thead>
<tr>
<th>Customer Id</th>
<th>Order Id</th>
<th>Order Total</th>
<th>Tax</th>
<th>Sales Total</th>
</tr>
</thead>
<tbody>
<tr>
<td>101</td>
<td>2456</td>
<td>76279.6</td>
<td>5479.672</td>
<td>81759.172</td>
</tr>
<tr>
<td></td>
<td>2447</td>
<td>31063.6</td>
<td>2372.552</td>
<td>33436.152</td>
</tr>
<tr>
<td></td>
<td>2430</td>
<td>26589.8</td>
<td>2078.833</td>
<td>28668.633</td>
</tr>
<tr>
<td></td>
<td>2413</td>
<td>48562</td>
<td>3388.84</td>
<td>51950.84</td>
</tr>
<tr>
<td><strong>Total:</strong></td>
<td></td>
<td><strong>190395.1</strong></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

14.4 Summary

Congratulations! You have successfully created a formula paper report. You now know how to:

- create two formula columns and add them to your report.

For more information on any of the wizards, views, or properties used in this example, refer to the Oracle Reports online Help, which is available in Oracle Reports Builder or hosted on the Oracle Technology Network (OTN), as described in Section 4.1.1, "Using the Oracle Reports online Help".
Part III

Building Reports with Special Formatting

The chapters in this Part provide steps to build reports that include special formatting. The example reports show you how to wrap text data, add headers and footers, format headers with database values that change at runtime, renumber pages, include intermixed fields, suppress labels, use conditional text, and add text, color, and graphics to your report.

This Part contains the following chapters:

- Chapter 15, "Building a Wrapped Field Report"
  A wrapped field report wraps the data on word boundaries if it is too long to fit in one line. The report contains a field that is of a fixed horizontal width but can expand vertically if the contents of the break field are longer than the specified width. The contents of the fields are not truncated.

- Chapter 16, "Building a Header and Footer Report"
  A header and footer report contains boilerplate or fields in the header or footer section. This report has a page header printed in the upper margin area of every page of the report and a footer printed at the end.

- Chapter 17, "Building a Header with Database Values Report"
  A header with database values report can include dynamic values in the page header of the report. For example, you can print both the first and last department numbers found on each page.

- Chapter 18, "Building a Report with Graphics, Text, and Color"
  A report with graphics, text, and color enables you to modify the look of your report. You can enhance a report by adding an image to the margin, adding a title or a border, or applying different fonts and text styles.

- Chapter 19, "Building a Report that Renumbers Pages by Repeating Frame"
  A report that renumbers pages by repeating frame displays page numbers using the format "Page X of Y Pages". The first number (X) corresponds to the current page of each parent record. The second number (Y) corresponds to the total number of pages of each parent record.

- Chapter 20, "Building an Intermixed Fields Report"
  An intermixed fields report includes the group field between its related fields. This is in contrast to a group report. Normally in the group report, the break field appears to the left of its related fields in the group left report or above in the group above report.

- Chapter 21, "Building a Report that Suppresses Labels"
A report that suppresses labels is a master/detail report that fetches a master record with no associated details. Therefore, the report suppresses the detail information for a single record but allows the other master/detail records to display.

- **Chapter 23, "Building a Conditional Form Letter Report"**

A conditional form letter report generates two different form letters from one report. Since the two letters share common features, it is more convenient to create a base form letter and then apply conditions to certain parts. The conditions will determine whether the part should display for the current record.

- **Chapter 22, "Building a Report with Conditional Highlighting"**

Conditional highlighting draws attention to specific data in a report by using visual formatting. You can use Oracle Reports Builder or the PL/SQL Editor to create a format trigger that changes the appearance of retrieved data depending on factors you define. For example, you can display amounts greater than 1000 in red.

- **Chapter 24, "Building a Report with Dynamic Graphics"**

A report with dynamic graphics contains drawings and images that are "dynamic." Any changes that you make to the graphics will be reflected in your report output at runtime.
In this chapter, you will learn about reports that include fields with wrapped text. By following the steps in this chapter, you can generate the report output shown in Figure 15–1.

Figure 15–1  Wrapped field report output

<table>
<thead>
<tr>
<th>Cust Last Name</th>
<th>Alex Cust First Name</th>
<th>Order Id</th>
<th>Order Total</th>
<th>Pct</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td>2438</td>
<td>909</td>
<td>0.01%</td>
</tr>
<tr>
<td>Total:</td>
<td></td>
<td>309</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Cust Last Name</td>
<td>Ayler Cust First Name</td>
<td>Order Id</td>
<td>Order Total</td>
<td>Pct</td>
</tr>
<tr>
<td></td>
<td></td>
<td>2389</td>
<td>17620</td>
<td>0.48%</td>
</tr>
<tr>
<td>Total:</td>
<td></td>
<td>17620</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Concepts
- Reports Builder enables you to modify the look of your report in multiple ways. In this example, you will build a break report where the line wraps on word boundaries if it is too long to fit on one line.
- This report contains a field which is of a fixed horizontal width, but can expand vertically if the contents of the break field are longer than the specified width. The field’s contents are not truncated; rather, the contents will wrap within the specified width of the field, and the field will expand vertically.
- For more information on break reports, refer to the Oracle Reports online Help.

Data Relationships
This is a simple, one-query break report. In addition, you will add three summary columns.

Layout
- This report is formatted as a master/detail report. You will modify the layout to add space between sets of information, then change the width of a field so that the break field will wrap.
- Optional: You will change the format masks of three fields. You will also use Page Protect in this report. Page Protect causes all objects within a frame or repeating frame to remain together. By specifying Page Protect for the master repeating frame, the customer name and all of its related records will always appear on the same page.
**Example Scenario**
As you build this example report, you will:

- **Create a Query in the Data Model View** manually, to include one query and two groups.
- **Create Three Summary Columns** to calculate various totals and percentages for your report.
- **Create the Default Layout Using the Report Wizard**.
- **Modify the Layout of the Report**.
- **Run your Report to Paper**.

To see a sample wrapped field report, open the examples folder called wrappedbreak, then open the Oracle Reports example report named wrappedbreak.rdf. For details on how to open it, see "Accessing the Example Reports" in the Preface.

### 15.1 Prerequisites for This Example

To build the example in this chapter, you must have access to the Order Entry sample schema provided with the Oracle Database. If you do not know if you have access to this sample schema, contact your database administrator.

### 15.2 Create a Query in the Data Model View

When you create a report, you can either use the Report Wizard to assist you or create the report yourself. In this example, you will use the Data Model view to create your two queries, then use the tool palette to create a data link between the two queries to relate the data tables.

**To create the query:**

1. Launch Reports Builder (or, if already open, choose File > New > Report).
2. In the Welcome or New Report dialog box, select **Build a new report manually**, then click OK.
3. In the Data Model view that displays, click the SQL Query tool in the tool palette then click in an open area of the Data Model view to display the SQL Query Statement dialog box.
4. In the **SQL Query Statement** field, enter the following SELECT statement:

   ```sql
   SELECT ALL CUSTOMERS_A1.CUST_FIRST_NAME, 
   CUSTOMERS_A1.CUST_LAST_NAME, ORDERS.ORDER_ID, ORDERS.ORDER_TOTAL 
   FROM CUSTOMERS CUSTOMERS_A1, ORDERS 
   WHERE (ORDERS.CUSTOMER_ID = CUSTOMERS_A1.CUSTOMER_ID) 
   ORDER BY CUSTOMERS_A1.CUST_LAST_NAME
   ```

**Note:** You can enter this query in any of the following ways:

- Copy and paste the code from the provided text file called wrappedbreak_code.txt into the SQL Query Statement field.
- Click **Query Builder** to build the query without entering any code manually.
- Type the code in the SQL Query Statement field.
5. Click OK to display the data model for your new query in the Data Model view. It should look like this:

*Figure 15–2  Data Model for the query*

![Data Model for the query](image)

6. In the **G_CUST_FIRST_NAME** group, click **CUST_FIRST_NAME** and drag it above the group to create another group.

7. Click **CUST_LAST_NAME**, then drag it into the new group, so that the data model now looks like this:

*Figure 15–3  Data model with groups*

![Data model with groups](image)

8. Double-click the new group (**G_1**) to display the Property Inspector, and set the following properties:
   - Under **General Information**, set the Name property to **G_Name**.
   
   Your data model should now look like this:

*Figure 15–4  Data model with new G_Name group*

![Data model with new G_Name group](image)

9. Save your report as `wrappedbreak_your_initials.rdf`.
15.3 Create Three Summary Columns

The steps in this section show you how to use the Summary Column tool in the Data Model view to create three summary columns. These columns will calculate the percentage of each order total that the customer has purchased, the total purchases the customer has made, and the percentage of the total sales of all customers.

To create the summary columns:
1. In the Data Model view, click the Summary Column tool in the tool palette, then click in the G_CUST_FIRST_NAME group to create a summary column.

2. Double-click the new summary column object (CS_1) to display the Property Inspector, and set the following properties:
   - Under General Information, set the Name property to PCT.
   - Under Summary, set the Function property to % of Total, set the Source property to ORDER_TOTAL, set the Reset At property to G_CUST_FIRST_NAME, and set the Compute At property to Report.

3. Create a second summary column in group G_NAME with the following properties:
   - Under General Information, set the Name property to CUST_TOTAL.
   - Under Summary, set the Function property to Sum, set the Source property to ORDER_TOTAL, and set the Reset At property to G_NAME.

4. Create a third summary column in group G_NAME with the following properties:
   - Under General Information, set the Name property to PCT_TOTAL_SALES.
   - Under Summary, set the Function property to Sum, set the Source property to PCT, and set the Reset At property to G_NAME.

Your data model should now look something like this:

Figure 15–5  Data Model with Three Summary Columns

5. Save your report as wrappedbreak_your_initials.rdf.

15.4 Create the Default Layout Using the Report Wizard

The steps in this section show you how to use the Report Wizard to create the layout and choose how your data will display in your report. Here, you will choose the style of report you want to create, and choose to display the data across the report (hence creating the across group report).
You can create a default layout using the Report Wizard, which deletes any existing layouts in your report and replaces it with the new one.

**To create the default layout:**
1. In the Data Model view, right-click on the canvas, then choose Report Wizard.
2. In the Report Wizard, on the Report Type page, select Create Paper Layout only.
3. On the Style page, select Group Above.
4. On the Fields page, click the double right arrows (>>) to move all of the fields to the Displayed Fields list.
5. On the Labels page, change the field widths as follows:

<table>
<thead>
<tr>
<th>Fields</th>
<th>Width</th>
</tr>
</thead>
<tbody>
<tr>
<td>CUST_FIRST_NAME</td>
<td>2</td>
</tr>
<tr>
<td>CUST_LAST_NAME</td>
<td>2</td>
</tr>
</tbody>
</table>

6. Click Finish to display your report output in the Paper Design view. It should look something like this:

![Figure 15–6  Paper Design view for the wrapped field report](image)

Notice how the complete names do not display. The steps in the next section will show you how to quickly correct this issue.

### 15.5 Modify the Layout of the Report

In this section, you will change the field to expand vertically if the contents of the break field are longer than the specified width. As you can see in Figure 15–6, the width of the fields are fixed, but the names are incomplete. You will also add space to display between each record in the report.

**To modify the layout:**
1. In the Object Navigator, double-click the repeating frame icon next to the R_G_NAME node under Paper Layout > Main Section > Body > M_G_Name_GRPFR, to display the Property Inspector.
2. Under Repeating Frame, change the Vert. Space Between Frames to 0.25, then press Enter.
3. Close the Property Inspector.
4. In the Object Navigator, under the Paper Layout node, navigate to Main Section > Body > M_G_NAME_GRPFR > R_G_NAME.
5. Double-click the icon next to the F_CUST_LAST_NAME field to display the Property Inspector.

6. Under General Layout, make sure the Vertical Elasticity property is set to Expand, then close the Property Inspector to accept your changes.

7. Follow steps 5 and 6 for the F_CUST_FIRST_NAME field.

You have now modified the layout of your report to display all the text in the wrapped fields, and added space between the records.

15.6 Run your Report to Paper

In this section, you will run your report to the Paper Design view so you can see how your report displays.

Click the Paper Design button in the toolbar to display the Paper Design view. Your report runs, then displays in the Paper Design view. It should look like the following:

![Figure 15–7 Paper Design view for the wrapped field report](image)

Save your report as wrappedbreak_your_initials.rdf.

15.7 Summary

Congratulations! You have successfully created a wrapped field paper report. You now know how to:

- manually create a data model.
- create a master/detail (or group above) report using the Report Wizard.
- modify the layout of your report to wrap the text in a field.
- add space between records.

For more information on any of the wizards, views, or properties used in this example, refer to the Oracle Reports online Help, which is available in Oracle Reports Builder or hosted on the Oracle Technology Network (OTN), as described in Section 4.1.1, "Using the Oracle Reports online Help".
In this chapter, you will learn about reports that include headers and footers. By following the steps in this chapter, you can generate the report output shown in Figure 16–1.

**Figure 16–1  Group left report output with header and footer**

<table>
<thead>
<tr>
<th>Department</th>
<th>First Name</th>
<th>Last Name</th>
<th>Employee Id</th>
<th>Salary</th>
</tr>
</thead>
<tbody>
<tr>
<td>10</td>
<td>Jennifer</td>
<td>Whalen</td>
<td>200</td>
<td>$4400.00</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td><strong>Total Salary for Department 10:</strong> $4400.00</td>
</tr>
<tr>
<td>20</td>
<td>Michael</td>
<td>Hartstein</td>
<td>201</td>
<td>$13000.00</td>
</tr>
<tr>
<td></td>
<td>Pat</td>
<td>Fay</td>
<td>202</td>
<td>$6000.00</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td><strong>Total Salary for Department 20:</strong> $19000.00</td>
</tr>
<tr>
<td>30</td>
<td>Den</td>
<td>Raphaely</td>
<td>114</td>
<td>$11000.00</td>
</tr>
<tr>
<td></td>
<td>Alexander</td>
<td>Khoo</td>
<td>115</td>
<td>$31000.00</td>
</tr>
<tr>
<td></td>
<td>Shelli</td>
<td>Beida</td>
<td>116</td>
<td>$2500.00</td>
</tr>
<tr>
<td></td>
<td>Sigal</td>
<td>Tobias</td>
<td>117</td>
<td>$20000.00</td>
</tr>
<tr>
<td></td>
<td>Guy</td>
<td>Himura</td>
<td>118</td>
<td>$26000.00</td>
</tr>
<tr>
<td></td>
<td>Karen</td>
<td>Colmanes</td>
<td>119</td>
<td>$25000.00</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td><strong>Total Salary for Department 30:</strong> $24900.00</td>
</tr>
<tr>
<td>40</td>
<td>Susan</td>
<td>Mavis</td>
<td>203</td>
<td>$6500.00</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td><strong>Total Salary for Department 40:</strong> $6500.00</td>
</tr>
</tbody>
</table>

This report has a page header, Employee Summary Report, printed in the upper margin area of every page of the report, and a footer, Total Salary for Department <number>: <sum_sal>, printed at the end of the list of employee information for each department.

**Concepts**

- A header and footer report contains boilerplate or fields in its header or footer. To create headers and footers in your report, add the boilerplate or field in the Paper Layout view of the Report Editor. If you create a field, make sure there is only one value for it. Otherwise, Reports Builder will not know which of the different values you want to print.

- How often the boilerplate and fields appear and whether they are headers or footers depends on where you position them in the layout. Any boilerplate that is positioned within a repeating frame will print once every time the repeating frame prints. Boilerplate that is outside of all repeating frames will print once for the entire report.
Prerequisites for This Example

Data Relationships
This report uses one query to select all necessary columns. You’ll add a break by assigning a column to a second group.

Layout
This report uses a group left layout with modifications. You’ll increase the size of a repeating frame and the frame enclosing it to ensure they are large enough to contain a footer, then add the footer. Then you’ll modify the vertical spacing of a repeating frame to add space between each instance of it.

Example Scenario
In this example, you will create a report that displays and summarizes employee data by department. To make the report more readable, you decide to add a header to each page and to add footer for each master record.

As you build this example report, you will:

■ Create a Data Model and a Group Left Layout.
■ Move a Summary to move the departmental summary closer to its label.
■ Add a Page Heading that repeats on all pages.
■ Add White Space and Format Fields to format monetary values.

To see a sample report with a header and footer, open the examples folder named headerfooter, then open the Oracle Reports example named headfoot.rdf. For details on how to access it, see "Accessing the Example Reports" in the Preface.

16.1 Prerequisites for This Example
To build the example in this chapter, you must have access to the Human Resources sample schema (HR) provided with the Oracle Database. If you do not know if you have access to this sample schema, contact your database administrator.

16.2 Create a Data Model and a Group Left Layout
When you are creating a single-query report, such as this one, you can use the Report Wizard to create the data model and layout simultaneously.

To create a data model and layout:
1. Launch Reports Builder (or, if already open, choose File > New > Report).
2. In the Welcome or New Report dialog box, select Use the Report Wizard, then click OK.
3. If the Welcome page displays, click Next.
4. On the Report Type page, select Create Paper Layout Only, then click Next.
5. On the Style page, type a Title for your report, select Group Left, then click Next.
6. On the Data Source page, click SQL Query, then click Next.
7. On the Data page, enter the following SELECT statement in the Data Source definition field:

```sql
SELECT FIRST_NAME, LAST_NAME, EMPLOYEE_ID, SALARY, DEPARTMENT_ID
FROM EMPLOYEES
ORDER BY DEPARTMENT_ID, EMPLOYEE_ID
```
Create a Data Model and a Group Left Layout

16-3

8. Click Next.

**Note:** You can enter this query in any of the following ways:

- Copy and paste the code from the provided text file called headfoot_code.txt into the **Data Source definition** field.
- Click **Query Builder** to build the query without entering any code manually.
- Type the code in the **Data Source definition** field.

9. On the Groups page, click **DEPARTMENT_ID** and click the right arrow (>) to move this field to the **Group Fields** list, then click **Next**.

10. On the Fields page, click the double right arrows (>>) to move all of the fields to the **Displayed Fields** list, then click **Next**.

11. On the Totals page, click **SALARY**, then click Sum.

12. Click **Next**.

13. On the Labels page, change the labels as follows, then click **Next**:

<table>
<thead>
<tr>
<th>Fields</th>
<th>Labels</th>
</tr>
</thead>
<tbody>
<tr>
<td>DEPARTMENT_ID</td>
<td>Department</td>
</tr>
<tr>
<td>SumSALARYPerDEPARTMENT_ID</td>
<td>Total Salary for Department &amp;DEPARTMENT_ID:</td>
</tr>
</tbody>
</table>

This step will add a footer to each instance of the master repeating frame (departments).

**Note:** The **DEPARTMENT_ID** column is part of the data model so you need to reference **DEPARTMENT_ID** in the footer label using &DEPARTMENT_ID.

14. On the Template page, click Finish to display your report output in the Paper Design view. It should look something like this.
16.3 Move a Summary

In the Paper Design view, notice how the department summary of salaries is very far to the right of the footer label (Total Salary for Department &DEPARTMENT_ID). For this report, you will move the salary summary closer to its label.

To move the summary closer to its label:

1. In the Paper Design view, click the Flex Off button in the toolbar to turn Flex mode off.
2. Select the label, Total Salary for Department &DEPARTMENT_ID.
3. Click and drag the right most handle of the label about 0.75 inches (2 centimeters) to the left to resize the object.
4. Select the first summary value to the right of the label Total Salary for Department &DEPARTMENT_ID.
5. Click and drag the summary value to the left until it is fairly close to its label.
6. Click and drag the right most handle of the field about 1 inch (2.5 centimeters) to the left.
7. Click the Flex On button in the toolbar to turn Flex mode back on.
16.4 Add a Page Heading

Now that you have added the repeating frame footer, it is time to add a page header. You perform this task from the Paper Layout view.

1. In the Paper Layout view, click the Edit Margin button in the toolbar.
2. From the font lists in the toolbar, choose Arial Black, point size 16.
3. Click the Text tool in the tool palette.
4. Click somewhere to the right of the logo image and type the following text:
   Employee Summary Report

5. Move to an open area of the Paper Layout view and click the mouse button to exit text mode. Notice that the text object you just created is still selected, you can now adjust its positioning with the arrow keys. If you click in an open area a second time, the object is deselected.

Note: Similarly, you can add a page footer, below the page margin.

6. Click the Run Paper Layout button in the toolbar to display your report in the Paper Design view. It should look like the following:
Figure 16–4 Group left report output with page heading

**Employee Salary Details**

<table>
<thead>
<tr>
<th>Department</th>
<th>First Name</th>
<th>Last Name</th>
<th>Employee Id</th>
<th>Salary</th>
</tr>
</thead>
<tbody>
<tr>
<td>10</td>
<td>Jennifer</td>
<td>Whalen</td>
<td>200</td>
<td>4400</td>
</tr>
<tr>
<td>20</td>
<td>Michael</td>
<td>Hartstone</td>
<td>201</td>
<td>13000</td>
</tr>
<tr>
<td></td>
<td>Pat</td>
<td>Fay</td>
<td>202</td>
<td>6000</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Total Salary for Department 10:</td>
<td>4400</td>
</tr>
<tr>
<td>30</td>
<td>Don</td>
<td>Raphaely</td>
<td>114</td>
<td>11000</td>
</tr>
<tr>
<td></td>
<td>Alexander</td>
<td>Klaus</td>
<td>115</td>
<td>3100</td>
</tr>
<tr>
<td></td>
<td>Shanti</td>
<td>Basios</td>
<td>116</td>
<td>2900</td>
</tr>
<tr>
<td></td>
<td>Situl</td>
<td>Tobias</td>
<td>117</td>
<td>2600</td>
</tr>
<tr>
<td></td>
<td>Guy</td>
<td>Mihura</td>
<td>118</td>
<td>2600</td>
</tr>
<tr>
<td></td>
<td>Kenya</td>
<td>Camesage</td>
<td>119</td>
<td>2600</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Total Salary for Department 20:</td>
<td>10000</td>
</tr>
<tr>
<td>40</td>
<td>Susan</td>
<td>Mavis</td>
<td>203</td>
<td>6600</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Total Salary for Department 30:</td>
<td>24600</td>
</tr>
</tbody>
</table>

7. Save the report as `headfoot_your_initials.rdf`.

### 16.5 Add White Space and Format Fields

The only task that remains now is to make your report a little more readable by adding some white space between records and formatting values properly.

1. In the Paper Design view, select the first department number value, which should be 10. All of the department numbers are immediately selected indicating that you can change their properties simultaneously.

2. Click the Align Center button in the toolbar.

3. Click the Select Parent Frame button in the toolbar.

4. Choose **Tools > Property Inspector** to display the Property Inspector, and set the following property:
   - Under **Repeating Frame**, set the Vert. Space Between Frames property to 0.25.

5. Click the title bar of the Paper Design view.

6. Select the first number value underneath the **Salary** label.

7. Shift-click the department summary value for the first department.

   **Tip:** If you are familiar with format mask syntax, you could now right-click the field values, choose Property Inspector, and choose or manually enter a value for the Format Mask property.

8. Click the Currency button in the toolbar. A currency symbol immediately appears next to all of the values.

9. Click the Add Decimal Place button twice. Two decimal places are added to the right of the decimal point.

10. Resize the salary field (F_SALARY) by clicking and dragging its rightmost handle approximately 0.5 inches (1.5 centimeters) to the left. Notice that even though the summary field (F_SumSALARYPerDEPARTMENT_ID) is also selected, only F_SALARY is resizes.

11. Shift-click the **Salary** label itself.

12. Click the Align Right button in the toolbar. All of the values are immediately right aligned.
Tip: The steps above have formatted all of the salaries and the department summary of your report. The report summary (the summary of all salaries in the report), however, is not yet formatted. You can find the report summary on the last page of the report and format it using the same techniques as above.

Figure 16–5 Group left report output with values formatted

<table>
<thead>
<tr>
<th>Department</th>
<th>First Name</th>
<th>Last Name</th>
<th>Employee Id</th>
<th>Salary</th>
</tr>
</thead>
<tbody>
<tr>
<td>10</td>
<td>Jennifer</td>
<td>Whalen</td>
<td>200</td>
<td>$4400.00</td>
</tr>
<tr>
<td>20</td>
<td>Michael</td>
<td>Hartstein</td>
<td>201</td>
<td>$13000.00</td>
</tr>
<tr>
<td>20</td>
<td>Pat</td>
<td>Fay</td>
<td>202</td>
<td>$6000.00</td>
</tr>
<tr>
<td>30</td>
<td>Dan</td>
<td>Raphaely</td>
<td>114</td>
<td>$11000.00</td>
</tr>
<tr>
<td>30</td>
<td>Alexander</td>
<td>Khoo</td>
<td>115</td>
<td>$31000.00</td>
</tr>
<tr>
<td>30</td>
<td>Shelli</td>
<td>Baia</td>
<td>116</td>
<td>$25000.00</td>
</tr>
<tr>
<td>30</td>
<td>Sigal</td>
<td>Tobias</td>
<td>117</td>
<td>$28000.00</td>
</tr>
<tr>
<td>30</td>
<td>Guy</td>
<td>Himuro</td>
<td>118</td>
<td>$29000.00</td>
</tr>
<tr>
<td>30</td>
<td>Karen</td>
<td>Colmanres</td>
<td>119</td>
<td>$25000.00</td>
</tr>
<tr>
<td>40</td>
<td>Susan</td>
<td>Maris</td>
<td>203</td>
<td>$65000.00</td>
</tr>
<tr>
<td></td>
<td>Total Salary for Department 10:</td>
<td>$4400.00</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Total Salary for Department 20:</td>
<td>$19000.00</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Total Salary for Department 30:</td>
<td>$25900.00</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Total Salary for Department 40:</td>
<td>$65000.00</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

16.6 Summary

Congratulations! You have successfully created a header and footer report. You now know how to:

- create a data model and a layout.
- move a summary field.
- add a heading that repeats on all pages.
- add white space and format values.

For more information on any of the wizards, views, or properties used in this example, refer to the Oracle Reports online Help, which is available in Oracle Reports Builder or hosted on the Oracle Technology Network (OTN), as described in Section 4.1.1, "Using the Oracle Reports online Help".
In this chapter, you will learn about reports with headers that include values queried from the database. By following the steps in this chapter, you can generate the report output shown in Figure 17–1.

**Figure 17–1**  Group left report output with database values in header

<table>
<thead>
<tr>
<th>Department</th>
<th>First Name</th>
<th>Last Name</th>
<th>Job Id</th>
<th>Salary</th>
</tr>
</thead>
<tbody>
<tr>
<td>10</td>
<td>Jennifer</td>
<td>Whalen</td>
<td>AG_ASS</td>
<td>$4400.00</td>
</tr>
<tr>
<td>20</td>
<td>Michael</td>
<td>Hartstein</td>
<td>MK_MAN</td>
<td>$13000.00</td>
</tr>
<tr>
<td>30</td>
<td>Bratko</td>
<td>Gayal</td>
<td>MK_REP</td>
<td>$8500.00</td>
</tr>
<tr>
<td>40</td>
<td>Deri</td>
<td>Raphaely</td>
<td>PU_MAN</td>
<td>$11000.00</td>
</tr>
<tr>
<td>50</td>
<td>Alexander</td>
<td>Klose</td>
<td>PU_CLERK</td>
<td>$3100.00</td>
</tr>
<tr>
<td>60</td>
<td>Shelli</td>
<td>Blida</td>
<td>PU_CLERK</td>
<td>$8100.00</td>
</tr>
<tr>
<td>70</td>
<td>Sigal</td>
<td>Tobias</td>
<td>PU_CLERK</td>
<td>$2900.00</td>
</tr>
<tr>
<td>80</td>
<td>Guy</td>
<td>Himuro</td>
<td>PU_CLERK</td>
<td>$2500.00</td>
</tr>
<tr>
<td>90</td>
<td>Karen</td>
<td>Colmaneses</td>
<td>PU_CLERK</td>
<td>$2100.00</td>
</tr>
<tr>
<td>10</td>
<td>Susan</td>
<td>Marvin</td>
<td>HR_REP</td>
<td>$8500.00</td>
</tr>
<tr>
<td>20</td>
<td>Matthew</td>
<td>Weiss</td>
<td>ST_MAN</td>
<td>$8200.00</td>
</tr>
<tr>
<td>30</td>
<td>Adam</td>
<td>Fipps</td>
<td>ST_MAN</td>
<td>$4200.00</td>
</tr>
<tr>
<td>40</td>
<td>Dayam</td>
<td>Kiefling</td>
<td>ST_MAN</td>
<td>$7900.00</td>
</tr>
<tr>
<td>50</td>
<td>Shanta</td>
<td>Volman</td>
<td>ST_MAN</td>
<td>$6900.00</td>
</tr>
<tr>
<td>60</td>
<td>Kevin</td>
<td>Moutges</td>
<td>ST_MAN</td>
<td>$6000.00</td>
</tr>
<tr>
<td>70</td>
<td>Julie</td>
<td>Nayer</td>
<td>ST_CLERK</td>
<td>$5300.00</td>
</tr>
<tr>
<td>80</td>
<td>Irene</td>
<td>Mikkilini</td>
<td>ST_CLERK</td>
<td>$2700.00</td>
</tr>
<tr>
<td>90</td>
<td>James</td>
<td>Landry</td>
<td>ST_CLERK</td>
<td>$5400.00</td>
</tr>
<tr>
<td>10</td>
<td>Sloan</td>
<td>Maitte</td>
<td>ST_CLERK</td>
<td>$2200.00</td>
</tr>
<tr>
<td>20</td>
<td>Laura</td>
<td>Gliscot</td>
<td>ST_CLERK</td>
<td>$3300.00</td>
</tr>
</tbody>
</table>

**Concepts**

In this example report, both the first and last department numbers found on each page are displayed in the page header.

**Layout**

This report uses one query and two groups. You'll also create two summary columns to provide the values for the header fields. To ensure unique field values for each page, you'll compute the values using the First and Last functions. The First function will return the first database value selected for a group, page, or report, and the Last function will return the last database value selected for a group, page, or report.
Example Scenario

In this example, you will create a report that displays and summarizes employee data by department. To make the report more readable, you decide to add a header to each page that indicates which departments appear on the page.

As you build this example report, you will:

■ Create a Data Model and a Group Left Layout.
■ Add Summary Columns for the Header Data.
■ Add a Page Heading that repeats on all pages with database values.

To see a sample header with database values report, open the examples folder named headingdb, then open the Oracle Reports example called headingdb.rdf. For details on how to access it, see "Accessing the Example Reports" in the Preface.

17.1 Prerequisites for This Example

To build the example in this chapter, you must have access to the Human Resources sample schema (HR) provided with the Oracle Database. If you do not know if you have access to this sample schema, contact your database administrator.

17.2 Create a Data Model and a Group Left Layout

When you are creating a single-query report, such as this one, you can use the Report Wizard to create the data model and layout simultaneously.

To create a data model and layout:

1. Launch Reports Builder (or, if already open, choose File > New > Report)
2. In the Welcome or New Report dialog box, select Use the Report Wizard, then click OK.
3. If the Welcome page displays, click Next.
4. On the Report Type page, select Create Paper Layout Only, then click Next.
5. On the Style page, type a Title for your report, select Group Left, then click Next.
6. On the Data Source page, click SQL Query, then click Next.
7. On the Data page, enter the following SELECT statement in the Data Source definition field:

   ```sql
   SELECT DEPARTMENT_ID, FIRST_NAME, LAST_NAME, JOB_ID, SALARY
   FROM EMPLOYEES
   ORDER BY DEPARTMENT_ID, EMPLOYEE_ID
   ```

   Note: You can enter this query in any of the following ways:

   ■ Copy and paste the code from the provided text file called heading_code.txt into the Data Source definition field.
   ■ Click Query Builder to build the query without entering any code manually.
   ■ Type the code in the Data Source definition field.

8. Click Next.
9. On the Groups page, click DEPARTMENT_ID and click the right arrow (>) to move this field to the Group Fields list, then click Next.

10. On the Fields page, click the double right arrows (>>) to move all of the fields to the Displayed Fields list, then click Next.

11. On the Totals page, click Next.

12. On the Labels page, change the labels as follows, then click Next:

<table>
<thead>
<tr>
<th>Fields</th>
<th>Labels</th>
</tr>
</thead>
<tbody>
<tr>
<td>DEPARTMENT_ID</td>
<td>Department</td>
</tr>
<tr>
<td>JOB_ID</td>
<td>Job</td>
</tr>
</tbody>
</table>


14. In the Paper Design view, click the first number value underneath the Salary label.

   Tip: If you are familiar with format mask syntax, you could now right-click the field values, choose Property Inspector, and choose or manually enter a value for the Format Mask property.

15. Click the Currency button in the toolbar. A currency symbol immediately appears next to all of the values.

16. Click the Add Decimal Place button twice. Two decimal places are added to the right of the decimal point.

17. Resize the field by clicking and dragging the right most handle of the field approximately 0.5 inches (1.5 centimeters) to the left.

18. Shift-click the Salary label itself.

19. Click the Align Right button in the toolbar. All of the values and the Salary label are immediately right aligned.

20. Click the first department number value under the Department label to select it.

21. Click the Align Center button in the toolbar.

   Your report should look something like this:
Add Summary Columns for the Header Data

17.3 Add Summary Columns for the Header Data

For the header that you want to create (that is, departments found on this page), you need to create two summary columns that compute the values you need in order to populate the header.

1. In the Report Editor, click the Data Model button in the toolbar to display the Data Model view.

2. Click the Summary Column tool in the tool palette, then click in an open area of the Data Model view to create a summary column.

3. Double-click the new summary column object (CS_1) to display the Property Inspector, and set the following properties:
   - Under General Information, set the Name property to FirstDeptRec.
   - Under Summary, set the Function property to First, set the Source property to DEPARTMENT_ID, set the Reset At property to Page.

4. Create a second summary column, and set its properties as follows:
   - Under General Information, set the Name property to LastDeptRec.
   - Under Summary, set the Function property to Last, set the Source property to DEPARTMENT_ID, set the Reset At property to Page.

Your data model should now look like this:

22. Save your report as headingdb_your_initials.rdf.

Figure 17–2  Group left report output with values formatted

<table>
<thead>
<tr>
<th>Department</th>
<th>First Name</th>
<th>Last Name</th>
<th>Job id</th>
<th>Salary</th>
</tr>
</thead>
<tbody>
<tr>
<td>10</td>
<td>Jennifer</td>
<td>Wilken</td>
<td>AD_ASST</td>
<td>$44200.00</td>
</tr>
<tr>
<td>20</td>
<td>Michael</td>
<td>Hartstein</td>
<td>MK_MAN</td>
<td>$12000.00</td>
</tr>
<tr>
<td>30</td>
<td>Rajesh</td>
<td>Goyal</td>
<td>MK_REP</td>
<td>$60000.00</td>
</tr>
<tr>
<td>Alexander</td>
<td></td>
<td></td>
<td>PU_CLERK</td>
<td>$9100.00</td>
</tr>
<tr>
<td>Shelli</td>
<td></td>
<td></td>
<td>PU_CLERK</td>
<td>$2900.00</td>
</tr>
<tr>
<td>Sigel</td>
<td></td>
<td></td>
<td>PU_CLERK</td>
<td>$3900.00</td>
</tr>
<tr>
<td>Guy</td>
<td></td>
<td>Hiro</td>
<td>PU_CLERK</td>
<td>$9200.00</td>
</tr>
<tr>
<td>Karen</td>
<td></td>
<td>Colmenares</td>
<td>PU_CLERK</td>
<td>$25000.00</td>
</tr>
<tr>
<td>Susan</td>
<td></td>
<td>Mann</td>
<td>HR_REP</td>
<td>$85000.00</td>
</tr>
<tr>
<td>50</td>
<td>Matthew</td>
<td>Weiss</td>
<td>ST_MAN</td>
<td>$80000.00</td>
</tr>
<tr>
<td>Adam</td>
<td></td>
<td>Frigo</td>
<td>ST_MAN</td>
<td>$62000.00</td>
</tr>
<tr>
<td>Payram</td>
<td></td>
<td>Kaufling</td>
<td>ST_MAN</td>
<td>$79000.00</td>
</tr>
<tr>
<td>Shastra</td>
<td></td>
<td>Vollman</td>
<td>ST_MAN</td>
<td>$85000.00</td>
</tr>
<tr>
<td>Keirn</td>
<td></td>
<td>Morgen</td>
<td>ST_MAN</td>
<td>$65000.00</td>
</tr>
<tr>
<td>Jobs</td>
<td></td>
<td>Neyer</td>
<td>ST_CLERK</td>
<td>$32000.00</td>
</tr>
<tr>
<td>Iona</td>
<td></td>
<td>Munkiman</td>
<td>ST_CLERK</td>
<td>$27000.00</td>
</tr>
<tr>
<td>James</td>
<td></td>
<td>Landry</td>
<td>ST_CLERK</td>
<td>$24000.00</td>
</tr>
</tbody>
</table>
17.4 Add a Page Heading

Now that you have the data for the header, you need to add the corresponding layout objects to the margin area of the report.

1. In the Paper Design view, from the font lists in the toolbar, choose Arial (Western), point size 10.

2. In the Paper Layout view, click the Edit Margin button in the toolbar.

3. Click the Text tool in the tool palette.

4. Draw an area somewhere to the right of the logo image and type the following text:
   
   Departments found on this page: &FirstDeptRec through &LastDeptRec
   
5. Move to an open area of the Paper Layout view and click the mouse button to exit text mode. Notice that the text object you just created is still selected, you can now adjust its positioning with the arrow keys. If you click in an open area a second time, the object is deselected.

6. Choose Program > Run Paper Layout to run your report.

   Your report should now look like this:
7. Save your report.

17.5 Summary

Congratulations! You have successfully created a header with database values report. You now know how to:

- create a data model and a layout.
- add summary columns to populate a header.
- add a heading that repeats on all pages with database values.

For more information on any of the wizards, views, or properties used in this example, refer to the Oracle Reports online Help, which is available in Oracle Reports Builder or hosted on the Oracle Technology Network (OTN), as described in Section 4.1.1, "Using the Oracle Reports online Help".
In this chapter, you will learn about reports that include graphics, text, and color. By following the steps in this chapter, you can generate the report output shown in Figure 18–1.

**Figure 18–1  Graphics, text, and color report output**

### Employee Details

<table>
<thead>
<tr>
<th>Department</th>
<th>First Name</th>
<th>Last Name</th>
<th>Salary</th>
<th>Job Title</th>
</tr>
</thead>
<tbody>
<tr>
<td>10</td>
<td>Jennifer</td>
<td>Whalen</td>
<td>$4500</td>
<td>Administration Assistant</td>
</tr>
<tr>
<td>20</td>
<td>Michael</td>
<td>Hartstein</td>
<td>$18000</td>
<td>Marketing Manager</td>
</tr>
<tr>
<td></td>
<td>Pat</td>
<td>Fey</td>
<td>$6000</td>
<td>Marketing Representative</td>
</tr>
<tr>
<td>30</td>
<td>Ben</td>
<td>Rapaporty</td>
<td>$11000</td>
<td>Purchasing Manager</td>
</tr>
</tbody>
</table>

### Concepts

- Reports Builder enables you to modify the look of your report in multiple ways. In this example, you will build a report and enhance it by adding an image to the margin, a title, and a border. You will also change the look of the report by applying different fonts and text styles.

- This report shows you how to enhance your reports with graphics by:
  - using the Paper Layout view’s drawing tools.
  - highlighting boilerplate text appearing in the output.
  - using different colors (if available) and patterns for boilerplate text.

- For more information on enhancing the appearance of your reports, refer to the Oracle Reports online Help.

### Data Relationships

This is a one-query group left report.
Layout
This report uses a Group Above layout, which you will modify in the Paper Layout view to make room for the title and company logo. Then, you will import the logo, create the report title, and the rest of the graphics shown in the image above.

Example Scenario
As you build this example report, you will:

- **Create a Simple Report Definition** using the Report Wizard to create one query that selects all the columns for this report, and assign a column to a new break group.

- **Modify the Report in the Paper Layout View** to:
  - Add a border around the report
  - Change the font size and style using the Font dialog box.
  - Add bullets to your report using the tool palette.
  - Display a line between each record using the Line tool.
  - Add a title to your report using the Fill Color tool and other layout tools.

To see a sample report with graphics and highlighted text, open the examples folder named graphics, then open the Oracle Reports example named graphics.rdf. For details on how to open it, see "Accessing the Example Reports" in the Preface.

18.1 Prerequisites for This Example
To build the example in this chapter, you must have access to the Human Resources sample schema (HR) provided with the Oracle Database. If you do not know if you have access to this sample schema, contact your database administrator.

18.2 Create a Simple Report Definition
When you create a report, you can either use the Report Wizard to assist you or create the report yourself. In this example, you will use the Report Wizard to create your query and basic report layout.

**To create the report definition:**
1. Launch Reports Builder (or, if already open, choose File > New > Report).
2. In the Welcome or New Report dialog box, select Use the Report Wizard, then click OK.
3. If the Welcome page displays, click Next.
4. On the Report Type page, select Create Paper Layout Only, then click Next.
5. On the Style page, type a Title for your report, select Group Above, then click Next.
6. On the Data Source page, click SQL Query, then click Next.
7. On the Data page, enter the following SELECT statement in the Data Source definition field:

   ```sql
   SELECT ALL DEPARTMENTS.DEPARTMENT_ID, EMPLOYEES.FIRST_NAME, EMPLOYEES.LAST_NAME, EMPLOYEES.JOB_ID, EMPLOYEES.SALARY, JOBS.JOB_TITLE
   FROM DEPARTMENTS, EMPLOYEES, JOBS
   ```
WHERE ((DEPARTMENTS.DEPARTMENT_ID = EMPLOYEES.DEPARTMENT_ID) AND (EMPLOYEES.JOB_ID = JOBS.JOB_ID))
ORDER BY DEPARTMENTS.DEPARTMENTS.DEPARTMENT_ID

Note: You can enter this query in any of the following ways:

- Copy and paste the code from the provided text file called graphics_code.txt into the Data Source definition field.
- Click Query Builder to build the query without entering any code manually.
- Type the code in the Data Source definition field.

8. Click Next.

Note: If you are not already connected to a database, you will be prompted to connect to the database when you click Query Builder or Next. Ensure that you connect to a database that has the appropriate schema for this example. Section 18.1, "Prerequisites for This Example" describes the sample schema requirements for this example.

9. On the Groups page, click DEPARTMENT_ID and click the right arrow (>) to move this field to the Group Fields list, then click Next.

10. On the Fields page, move all fields except JOB_ID to the Displayed Fields list, then click Next.

11. On the Totals page, click Next.

12. On the Labels page, change the label Department Id to Department, then click Next.

13. On the Template page, select Predefined Template and click Blue, then click Finish to display your report output in the Paper Design view. It should look something like this:

Figure 18–2 Paper Design view for the graphics report with one query

<table>
<thead>
<tr>
<th>Department 10</th>
<th>First Name</th>
<th>Last Name</th>
<th>Salary</th>
<th>Job Title</th>
</tr>
</thead>
<tbody>
<tr>
<td>Jennifer</td>
<td>Whalen</td>
<td>4400</td>
<td></td>
<td>Administration Assistant</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Department 20</th>
<th>First Name</th>
<th>Last Name</th>
<th>Salary</th>
<th>Job Title</th>
</tr>
</thead>
<tbody>
<tr>
<td>Michael</td>
<td>Hartstein</td>
<td>1300</td>
<td></td>
<td>Marketing Manager</td>
</tr>
<tr>
<td>Pat</td>
<td>Fay</td>
<td>6000</td>
<td></td>
<td>Marketing Representative</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Department 30</th>
<th>First Name</th>
<th>Last Name</th>
<th>Salary</th>
<th>Job Title</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ken</td>
<td>Raphaely</td>
<td>11000</td>
<td></td>
<td>Purchasing Manager</td>
</tr>
<tr>
<td>Alexander</td>
<td>Khoop</td>
<td>3100</td>
<td></td>
<td>Purchasing Clerk</td>
</tr>
<tr>
<td>Shahi</td>
<td>Balda</td>
<td>2900</td>
<td></td>
<td>Purchasing Clerk</td>
</tr>
</tbody>
</table>
18.3 Modify the Report in the Paper Layout View

The steps in this section show you how to use the various tools in the Paper Layout view to modify the appearance of your report. First, you will move the existing frames to accommodate the changes you will make. You will then add a title to your report, borders around each record, and change the text color.

To modify your report:
1. Click the Paper Layout view button in the toolbar to display the Paper Layout view.
2. Make sure the Confine On button in the toolbar is set to Confine mode on. Doing so enables you to move the objects in the Paper Layout view around the canvas.
3. In the Object Navigator, under Paper Layout > Main Section > Body, click the item M_G_DEPARTMENT_ID_GRPFR.
   Notice that, in the Paper Layout view, the outermost frame is selected.
4. Using the arrow keys, move the frame about 2 inches (5 centimeters) down and 1 inch (2.5 centimeters) to the right.
   You can use the rulers along the sides of the Paper Layout view as guidance. Your Paper Layout should now look something like this:

   ![Paper Layout View of Adjusted Report Layout](image)

5. Now, make sure Flex mode is on and click the Confine Off button in the toolbar to set Confine mode off.
6. Make space for the border you will create that will surround each record. In the Object Navigator, select M_G_DEPARTMENT_ID_GRPFR again.
7. Drag each corner to make space around the inner repeating frame, so that the layout now looks like the following image. Notice the white space around the groups.

   ![Paper Layout View of Adjusted Report Layout](image)
8. Now, let us make space between each record so that a horizontal line can be placed between the records. In the Object Navigator, click R_G_DEPARTMENT_ID.

9. In the Paper Layout view, click the bottom right corner and drag it down about 0.5 inches (1.5 centimeters) so that your layout now looks like this:

10. Save your report as graphics_your_initials.rdf.

18.3.1 Add a border around the report

Now that you have set up your layout, you can start adding new items. In this section, you will add a border around the entire report.

To add a border:

1. In the Object Navigator, select the M_G_DEPARTMENT_ID_GRPFR frame.

2. In the Paper Layout view, while the M_G_DEPARTMENT_ID_GRPFR frame is selected, click the Line Color tool. The tool can be found at the very bottom of the tool palette.

3. In the color palette that displays, choose the black square to make the border black.

4. While the line is still selected, choose Format > Line > Line Width > 2 pt.

5. Now, preview the layout. In the toolbar, click the Paper Design button to run the report to paper. It should look something like this:
Figure 18–6  Preview of the Report with a Border

<table>
<thead>
<tr>
<th>Department</th>
<th>First Name</th>
<th>Last Name</th>
<th>Salary</th>
</tr>
</thead>
<tbody>
<tr>
<td>10</td>
<td>Jennifer</td>
<td>Whalen</td>
<td>4400</td>
</tr>
<tr>
<td>20</td>
<td>Michael</td>
<td>Hartstein</td>
<td>13000</td>
</tr>
<tr>
<td></td>
<td>Pat</td>
<td>Fay</td>
<td>6000</td>
</tr>
</tbody>
</table>

6. Save your report as graphics_your_initials.rdf.

18.3.2 Change the font size and style

In the Paper Layout view, you can also change the font and style of the text. The steps in this section will show you how to modify the Department Number text.

To change the font:
1. In the Paper Design view, click the Paper Layout button in the toolbar.
2. In the Object Navigator, select the B_DEPARTMENT_ID and F_DEPARTMENT_ID fields so that you can change the font of the Department ID label and text.

Note: B_DEPARTMENT_ID refers to the boilerplate text "Department ID", which serves as the label for the F_DEPARTMENT_ID field.

3. Click the title bar of Paper Layout view to make it the active window.
4. While the two fields are selected, choose Format > Font.
5. In the Font dialog box, choose a different font and size. In the example, Times New Roman and 12 pt is selected.
6. When you have finished your changes, click OK.

Note: Depending on the font and font size you choose, you may have to adjust the size of the fields to accommodate the text. In the example, since the font was increased, the boilerplate text field was selected and enlarged.

7. Display your report in the Paper Design view to see what it looks like. Here’s an example:
8. Save your report as `graphics_your_initials.rdf`.

### 18.3.3 Add bullets to your report

The steps in this section will show you how to add bullets so that a bullet displays next to each department ID.

**To add bullets to your report:**

1. In the Paper Layout view, make sure you have enough space next to the `B_DEPARTMENT_ID` field where you can add a bullet. The bullet needs to be within the `R_G_DEPARTMENT_ID` repeating frame so that it displays for each record.

2. Click the Ellipse tool in the tool palette.

3. Press the SHIFT key, then draw an ellipse next to the boilerplate text "Department."

**Note:** Pressing the SHIFT key while you draw the ellipse puts the tool in a "constrained" mode. When you create an ellipse in this mode, you can create a circle. Other tools are similar; for example, constraining the Rectangle tool creates a square. For more information on using these tools, refer to the Oracle Reports online Help.

4. You should now see a circle in the repeating frame. To make the bullet a solid color, select the circle, then click the Fill Color tool in the tool palette.

5. In the color palette that displays, choose black.

6. Run your report to the Paper Design view to see what it looks like.

**Note:** When you are checking your layout, make sure that the ellipse displays within the `R_G_DEPARTMENT_ID` repeating frame.
7. Save your report as `graphics_your_initials.rdf`.

### 18.3.4 Display a line between each record

When you have a lot of data, you sometimes want to further distinguish each record, so that it is clear how the information is related. In this section, you will add a horizontal line to the layout that will display between each department record.

#### To add a line separator:

1. In the Paper Layout view, click the Line tool in the tool palette.
2. Press the SHIFT key, then draw a line in the `R_G_DEPARTMENT_ID` frame beneath the fields, like this:

![Figure 18–9 Paper Layout View with Line Separator](image)

3. Format the line the way you want it to appear. In our example, `Format > Line > Line Width > 2 pt` was selected. Then, color was changed to black.

4. Run your report to the Paper Design view. It should now look something like this:
5. Save your report as graphics_your_initials.rdf.

18.3.5 Add a title to your report

The steps in this section will show you how to use the tools in the tool palette to create a title for your report. You will use the Fill Color to create a black background and white text, as well as arrange your items so they display properly.

To add a title to the report:
1. In the Paper Layout view, click the Rectangle tool in the tool palette.
2. Draw a rectangle where you want the title to display. We drew the rectangle above the repeating frames, so that the title would display once, above all the data.
3. Click the Text tool in the tool palette, then click in the rectangle and type a title, such as "Employee Details."
4. With the text object selected, click the Text Color tool and choose white.
5. With the rectangle object selected, click the Fill Color tool in the tool palette, and choose black.
6. In the Object Navigator, find the text object you created under Body. You can tell which objects are text objects by the A icon next to the name. In our case, the text object is B_3.
7. Once you have selected the object, click the title bar of the Paper Design view to select the Paper Design view.
8. Choose Layout > Bring to Front.
9. Run your report to the Paper Design view. It should now look something like this:
10. Save your report as graphics_your_initials.rdf.

18.4 Summary

Congratulations! You have successfully created a paper report and modified the text color and fill colors, as well as added graphics. You now know how to:

- use the Report Wizard to create a simple report definition.
- modify the layout of the objects in your report.
- add a border to the report.
- add bullets to each record.
- add a horizontal separator between each record.
- add a title to your report using fill colors and layout features.

For more information on any of the wizards, views, or properties used in this example, refer to the Oracle Reports online Help, which is available in Reports Builder or hosted on the Oracle Technology Network (OTN), as described in Section 4.1.1, "Using the Oracle Reports online Help".
In this chapter, you will learn about reports that resets page numbers based on data shown. By following the steps in this chapter, you can generate the report output shown in Figure 19–1.

Figure 19–1  Pages renumbered by repeating frame report output

This example numbers pages using the format "Page X of Y". The first number (X) corresponds to the current page for each parent record (that is, each sales representative). This page number is reset to "1" for each sales representative, thus tracking the statistics of each representative separately.

The second number (Y) is the total pages required to display the customer information for each sales representative. This field is also reset with each new parent record.

Important Note: The steps in this chapter explain how to produce the "Page X of Y Pages" for the paper layout and have no effect on the Web source, because the Web source does not have pagination.

Concepts

- The Page Numbering dialog box enables you to specify that the page number either reset at a particular repeating frame or increment over the entire report.
However, if you decide to use a page total that repeats on several pages, as with the second number in the example report, you need to be aware of certain rules that apply when formatting a field that contains a count of other objects. To be able to display such a value, called a page-dependent reference, on the first page—or any page prior to the final page—of the report, Reports Builder must format the field that will contain the value before it knows the value. As a result, any field displaying a value of this type must be fixed, so that Reports Builder knows how much space to reserve for it when formatting the report. Even if you set the Horizontal Elasticity property or Vertical Elasticity property to Expand, Contract, or Variable for such a field, Reports Builder considers it fixed. When you create such a field, you must ensure that it is large enough to contain the value.

An alternative is to hide the field and reference it from a boilerplate object. When using this method, the field can be variable, but the boilerplate remains fixed, so be sure to create a boilerplate object of sufficient size to hold the field.

Some values that are treated in this fashion by Reports Builder are &TOTAL LOGICAL PAGES, &TOTAL PANELS, and &TOTAL PHYSICAL PAGES, and any summaries or formulas that reference them. Summaries with either a Compute At property or Reset At property setting of Page and formulas that reference them are also considered page-dependent references. For a complete list of such values and a comprehensive discussion of Reports Builder’s treatment of them, see the topics “Vertical Elasticity property” or “Horizontal Elasticity property” in the Oracle Reports online Help.

Data Relationships
As illustrated in Figure 19–1, this report contains both a master/detail relationship and a break. This results in two levels of data differentiation. The top level (the break) will determine when page numbers reset.

Layout
This report uses the master/detail layout style, with modifications. In addition, you will create two hidden fields for the page numbers, then reference them in a boilerplate object. This will ensure that the field displaying the total number of pages is the proper size. Then you will check the Maximum Records Per Page property setting for the break group’s repeating frame to ensure that your pages are numbered correctly.

Example Scenario
In this example, you will create a page number in the margin of a report in the format "Page X of Y Pages". The page number X is incremented for each page produced by customer sales for one sales representative at a time. Y represents the total number of pages for the sales representative of that sales grouping and is reset for the next sales representative.

As you build this example report, you will:

- Create a Data Model and a Group Above Layout.
- Add a Second Query to group the output for each sales representative by customer.
- Redefault the Layout to use the additional query data.
- Set Properties and Format Fields
- Create New Fields for the page numbers of the report.
- Reference Fields to create the page numbers.
To see a sample report that rennumbers pages by repeating frame, open the examples folder named `pagenum`, then open the Oracle Reports example called `pagenum.rdf`. For details on how to open it, see "Accessing the Example Reports" in the Preface.

### 19.1 Prerequisites for This Example

- To build the example in this chapter, you must have access to the Summit Sporting Goods (SUMMIT) schema. To download the SQL scripts that install the schema, see "Accessing the Data Sources" in the Preface. Only the EMP, CUSTOMER, and SALES tables are required.

- The HTML view of the report that displays the page number technique must be deployed through a report server using the report in JSP or RDF format and HTML as the destination format. For example:

  ```
  http://computer_host:port/reports/rwservlet?report=pgnum.rdf
  &userid=scott/tiger@my_database
  &destype=cache&desformat=html&server=rep_server
  ```

### 19.2 Create a Data Model and a Group Above Layout

When you are creating a single-query report, such as this one, you can use the Report Wizard to create the data model and layout simultaneously.

**To create a data model and group above layout:**

1. Launch Reports Builder (or, if already open, choose File > New > Report).

2. In the Welcome or New Report dialog box, select Use the Report Wizard, then click OK.

3. If the Welcome page displays, click Next.

4. On the Report Type page, select Create both Web and Paper Layout, then click Next.

5. On the Style page, type a Title for your report, select Group Above, then click Next.

6. On the Data Source page, click SQL Query, then click Next.

7. On the Data page, enter the following SELECT statement in the Data Source definition field:

   ```sql
   SELECT ENAME, REPID, CUSTID, NAME, ADDRESS, TRIM(CITY)||', '||STATE||' '||ZIP LOCATION,  AREA||' '||PHONE, CREDITLIMIT
   FROM EMP, CUSTOMER
   WHERE EMPNO = REPID
   ORDER BY REPID
   ```

   **Note:** You can enter this query in any of the following ways:

   - Copy and paste the code from the provided text file called `pagenum_code.txt` into the Data Source definition field.
   - Click Query Builder to build the query without entering any code manually.
   - Type the code in the Data Source definition field.

8. Click Next.
Note: If you are not already connected to a database, you will be prompted to connect to the database when you click Query Builder or Next. Ensure that you connect to a database that has the appropriate schema for this example. Section 19.1, "Prerequisites for This Example" describes the sample schema requirements for this example.

9. On the Groups page, click ENAME in the Available Fields list and click the right arrow (>) to move this field to the Group Fields list.

10. Move REPID to the Group Fields list, too, then click Next.

Figure 19–2 Selecting group fields in the Report Wizard

11. On the Fields page, click the double right arrows (>>) to move all of the fields to the Displayed Fields list, then click CUSTID and click the left arrow (<) to move it back to the Available Fields list, then click Next.

12. On the Totals page, click Next.

13. On the Labels page, change the labels and field widths as follows, then click Next:

<table>
<thead>
<tr>
<th>Fields</th>
<th>Labels</th>
<th>Width</th>
</tr>
</thead>
<tbody>
<tr>
<td>ENAME</td>
<td>Rep Name</td>
<td>10</td>
</tr>
<tr>
<td>REPID</td>
<td>Rep ID</td>
<td>6</td>
</tr>
<tr>
<td>NAME</td>
<td>Customer Name</td>
<td>20</td>
</tr>
<tr>
<td>ADDRESS</td>
<td>Address</td>
<td>20</td>
</tr>
<tr>
<td>LOCATION</td>
<td>Location</td>
<td>20</td>
</tr>
<tr>
<td>AREA_PHONE</td>
<td>Area Phone</td>
<td>12</td>
</tr>
<tr>
<td>CREDITLIMIT</td>
<td>Credit Limit</td>
<td>8</td>
</tr>
</tbody>
</table>

15. Save the report as `pagenum_your_initials.rdf`.

### 19.3 Add a Second Query

In the Paper Design view, the data is grouped by the Sales Representative with customer data listed below each Sales Representative.

![Report layout in the Paper Design view](image)

All the data will display on one page and the individual sales transactions for each customer is not yet available. You will need an additional query in the Data Model to accomplish this.
To add a new query to the report:
1. Click the Data Model button in the toolbar.
2. In the Data Model view, click the SQL Query tool in the tool palette then click in an open area of the Data Model view, somewhere to the right of query Q_1, to display the SQL Query Statement dialog box.
3. In the SQL Query Statement field, enter the following SELECT statement:

```
SELECT CUSTID, PRODNAME, AMOUNT
FROM SALES
ORDER BY CUSTID
```

**Note:** You can enter this query in any of the following ways:
- Copy and paste the code from the provided text file called `pagenum_code.txt` into the SQL Query Statement field.
- Click Query Builder to build the query without entering any code manually.
- Type the code in the SQL Query Statement field.

4. Click OK to display the new query in the Data Model view.
5. In the Data Model view, click the Data Link tool in the tool palette.
6. Using the cross hairs of the cursor, click CUSTID in the G_NAME group and drag the cursor to custid1 in the G_custid1 group, then release the mouse button to link the CUSTID and custid1 fields between the two groups.
7. Position the Report Editor window to display it alongside the Object Navigator so that you can view both windows simultaneously.
8. In the Object Navigator, under the Data Model node, expand the Groups node. Then, under the Paper Layout node, expand the Main Section node. Compare these two structures and notice that even though additional data is made available in the Data Model by adding query Q_2, the Paper Layout will not use this additional data unless modified to do so. We will do this next.

### 19.4 Redefault the Layout

To redefault the layout to use the additional query data:
1. In the Object Navigator, click the report name.
2. Choose Tools > Report Wizard to re-enter the wizard.
3. In the Report Wizard, on the Groups page, click G_custid1 in the Available Groups list and click Down to specify the Print Direction and move this group to the Displayed Groups list.
4. On the Fields page, click prodname and amount in the Available Fields list and click the right arrow (>) to move these fields to the Displayed Fields list.
5. On the Labels page, change the labels and field widths as follows:

<table>
<thead>
<tr>
<th>Fields</th>
<th>Labels</th>
<th>Width</th>
</tr>
</thead>
<tbody>
<tr>
<td>prodname</td>
<td>Product Name</td>
<td>30</td>
</tr>
</tbody>
</table>
6. On the Template page, click Finish to display your report output in the Paper Design view. It should look something like this:

*Figure 19–5  Revised report layout in Paper Design view*

Notice that the data is still grouped by the Sales Representative with customer data listed below each Sales Representative. But now, the individual products sold to the customers are listed below each customer. The report now has multiple pages.

### 19.5 Set Properties and Format Fields

To set properties and format the fields of your report:

1. In the Object Navigator, click the Paper Layout node and click the Expand All button in the toolbar.

2. Double-click the repeating frame icon next to the R_G_ENAME node to display the Property Inspector, and set the following properties:
   - Under **Repeating Frame**, set the Maximum Records per Page property to 1.

3. In the Object Navigator, double-click the repeating frame icon next to the R_G_CUSTID1 node to display the Property Inspector, and set the following properties:
   - Under **Repeating Frame**, set the Vert. Space Between Frames property to 0.25 to specify 0.25 inches (0.5 centimeters) of vertical space between instances of the repeating frame; that is, between each customer record.
   - Under **General Layout**, set the Page Protect property to Yes to specify that the first instance of the repeating frame (that is, the first customer record) must all fit on the same logical page.

4. In the Object Navigator, click the F_CREDITLIMIT node, then Ctrl-click F_AMOUNT to select both nodes.
5. Click the Paper Design button in the toolbar to make the Paper Design view the active window, with the F_CREDITLIMIT and F_AMOUNT fields selected, and make the format changes (you can also click the corresponding buttons in the toolbar):
   - choose Format > Number > Currency
   - choose Format > Number > Add Decimal Place
   - choose Format > Number > Add Decimal Place (again, for two decimal places)
   - choose Format > Justify > Right

6. In the Paper Design view, click the Amount label (column heading), and choose Format > Justify > Right.

19.6 Create New Fields

To create new fields for the page numbers of the report:

1. Click the Paper Layout button in the toolbar to display the Paper Layout view.
2. In the Paper Layout view, click the Edit Margin button in the toolbar to display the margin areas of your report. You will be creating two page number fields in the top margin, as shown here:

![Figure 19–6 Page number source fields in top margin of report](image)

3. Click the Field tool in the tool palette and draw a field about two characters long in the center of your margin.
4. Double-click the new field object (F_1) to display the Property Inspector, and set the following properties:
   - Under General Information, set the Name property to F_TOTAL_PAGENO.
   - Under Field, set the Source property to Total Pages, and set the Visible property to No.
   - Under General Layout, set the Horizontal Elasticity property to Variable.
     Hiding both this field and the field you’ll create below ensures that they’ll appear only where you reference them. Changing the horizontal sizing to Variable ensures that the fields can expand to accommodate large page ranges.
   - Under Field, click the Page Numbering property field to display the Page Numbering dialog box:
     In the Reset at list, click R_G_ENAME, and verify that the Start at and Increment by values are both 1, then click OK.
5. Close the Property Inspector.
6. In the Paper Layout view, click the F_TOTAL_PAGENO field.
7. Choose Edit > Copy, then choose Edit > Paste to create a new field with the same dimensions as F_TOTAL_PAGENO next to F_TOTAL_PAGENO.

8. Drag the new field object (F_TOTAL_PAGENO1) to an open area of the margin.

9. Double-click the new field object (F_TOTAL_PAGENO1) to display its Property Inspector, and make the following changes:
   - Under General Information, set the Name property to F_PAGENO.
   - Under Field, set the Source property to Page Number.
     Because it is a duplicate of F_TOTAL_PAGENO, the Horizontal Elasticity and Visible properties are already set as desired.
   - Under Field, click the Page Numbering property field to display the Page Numbering dialog box.
     In the Reset at list, click R_G_ENAME, and verify that the Start at and Increment by values are both 1, then click OK.


   Next, you will reference these fields in a text box to display page numbers in the format "Page X of Y Pages."

19.7 Reference Fields

To reference the page number fields:
1. In the Paper Layout view, click the Line Color tool in the tool palette.
2. In the color palette, click No Line.
3. Click the Text tool in the tool palette.
4. Position the cursor in the top margin where you would like the page number to appear, and click to create a boilerplate object.
5. In the new boilerplate object, type Page &F_PAGENO of &F_TOTAL_PAGENO.

Figure 19–7  Page number source and reference fields in top margin of report

In the report output, the current page number will appear where you reference the field F_PAGENO, while the total number of pages for each master will appear where you reference the field F_TOTAL_PAGENO. If you wish, you can resize the page number boilerplate text object to lengthen it to ensure that no values for F_TOTAL_PAGENO get truncated.
6. Save and run your report. Your final report output should look something like this:

**Figure 19–8  Final pages renumbered by repeating frame report output**

<table>
<thead>
<tr>
<th>Prodname</th>
<th>Amount</th>
</tr>
</thead>
<tbody>
<tr>
<td>ACE TENNIS RACKET I</td>
<td>$360.00</td>
</tr>
<tr>
<td>ACE TENNIS RACKET II</td>
<td>$465.00</td>
</tr>
<tr>
<td>ACE TENNIS BALLS-3 PACK</td>
<td>$292.50</td>
</tr>
<tr>
<td>ACE TENNIS NET</td>
<td>$50.00</td>
</tr>
<tr>
<td>RH: &quot;GUIDE TO TENNIS&quot;</td>
<td>$1703.40</td>
</tr>
<tr>
<td>SB ENERGY BARS PACK</td>
<td>$2400.00</td>
</tr>
</tbody>
</table>

**19.8 Summary**

Congratulations! You have successfully created a report that renumbers pages by repeating frame. You now know how to:

- create a data model with a group above layout.
- add a second query to create a multiquery report, and redefine the layout.
- set properties and format fields.
- create and reference a page number boilerplate object in your layout.

For more information on any of the wizards, views, or properties used in this example, refer to the *Oracle Reports online Help*, which is available in Oracle Reports Builder or hosted on the Oracle Technology Network (OTN), as described in Section 4.1.1, "Using the Oracle Reports online Help".
In this chapter, you will learn about reports that display group fields in different positions. By following the steps in this chapter, you can generate the report output shown in Figure 20–1.

Figure 20–1  Group with master record in the middle of report output

<table>
<thead>
<tr>
<th>Name</th>
<th>Department</th>
<th>Salary</th>
</tr>
</thead>
<tbody>
<tr>
<td>CLARK</td>
<td>ACCOUNTING</td>
<td>2450</td>
</tr>
<tr>
<td>KING</td>
<td>ACCOUNTING</td>
<td>9500</td>
</tr>
<tr>
<td>MILLER</td>
<td>ACCOUNTING</td>
<td>1300</td>
</tr>
<tr>
<td>SMITH</td>
<td>RESEARCH</td>
<td>800</td>
</tr>
<tr>
<td>ADAMS</td>
<td>RESEARCH</td>
<td>1100</td>
</tr>
<tr>
<td>FORD</td>
<td>RESEARCH</td>
<td>9000</td>
</tr>
<tr>
<td>SCOTT</td>
<td>RESEARCH</td>
<td>3000</td>
</tr>
<tr>
<td>JONES</td>
<td>RESEARCH</td>
<td>2075</td>
</tr>
<tr>
<td>ALLEN</td>
<td>SALES</td>
<td>1600</td>
</tr>
<tr>
<td>BLAKE</td>
<td>SALES</td>
<td>2950</td>
</tr>
<tr>
<td>MARTIN</td>
<td>SALES</td>
<td>1250</td>
</tr>
</tbody>
</table>

Concepts

Normally, a group (break) field appears to the left of (in group left report) or above (in group above report) its related fields. In this example, the group field appears between its related fields.

Data Relationships

- To create this type of report you need to build a data model with two groups.
- A formula column in the detail group returns the value of the group column. The formula column is moved to the middle position of its group.

Layout

- This report uses a group above layout. In the Paper Layout view, the break column is deleted from its defaulted position.
- A format trigger is created to suppress redundant printing of the formula column group value in the detail group.
Example Scenario
In this example, you will create a report that displays salary data by employee and department. Your users have indicated to you that they prefer the group value (that is, department name) to appear in the middle of the layout with employee names to the left and employee salaries to the right.

As you build this example report, you will:
- Create a Data Model and a Layout using the Report Wizard.
- Add a Formula Column to the detail group.
- Add a Field in the Report Wizard.
- Remove a Redundant Field in the Paper Design view.
- Suppress Redundant Values in a Format Trigger.

To see a sample report that intermixes fields, open the examples folder named intermix, then open the Oracle Reports example named intermix.rdf. For details on how to access it, see “Accessing the Example Reports” in the Preface.

20.1 Prerequisites for This example
To build the example in this chapter, you must have access to the SCOTT sample schema provided with the Oracle Database. If you do not know if you have access to this sample schema, contact your database administrator.

20.2 Create a Data Model and a Layout
When you are creating a single-query report, such as this one, you can use the Report Wizard to create the data model and layout simultaneously.

To create a data model and group above layout:
1. Launch Reports Builder (or, if already open, choose File > New > Report).
2. In the Welcome or New Report dialog box, select Use the Report Wizard, then click OK.
3. If the Welcome page displays, click Next.
4. On the Report Type page, select Create Paper Layout Only, then click Next.
5. On the Style page, type a Title for your report, select Group Above, then click Next.
6. On the Data Source page, click SQL Query, then click Next.
7. On the Data page, enter the following SELECT statement in the Data Source definition field:

   ```sql
   SELECT DEPT.DNAME, EMP.ENAME, EMP.SAL
   FROM DEPT, EMP
   WHERE (EMP.DEPTNO = DEPT.DEPTNO)
   ```
8. Click Next.

9. On the Groups page, click DNAME in the Available Fields list and click the right arrow (>) to move this field to the Group Fields list.

**Figure 20–2  Group page of Report Wizard**

![Group page of Report Wizard](image)

10. Click Next.

11. On the Fields page, click the double right arrows (>>) to move all of the fields to the Displayed Fields list, then click Next.

12. On the Totals page, click Next.

13. On the Labels page, change the labels as follows, then click Next:

<table>
<thead>
<tr>
<th>Fields</th>
<th>Labels</th>
</tr>
</thead>
<tbody>
<tr>
<td>DNAME</td>
<td>Dept.</td>
</tr>
<tr>
<td>ENAME</td>
<td>Name</td>
</tr>
<tr>
<td>SAL</td>
<td>Salary</td>
</tr>
</tbody>
</table>
14. On the Template page, click **Finish** to display your report output in the Paper Design view. It should look something like this:

**Figure 20–3  Paper Design view for intermixing fields report**

15. Save the report as `intermix_your_initials.rfd`.

### 20.3 Add a Formula Column

To have the department names appear in the center of this group report, it is simplest to have a column in the detail group for the department names. To achieve this result, you must create a formula column in the detail group that will display the department names.

**To add a formula column:**

1. Click the Data Model tool in the toolbar to display the Data Model view.

2. In the Data Model view, resize the **G_ENAME** group to be large enough to contain a third column.

3. Click the Formula Column tool in the tool palette.

4. Click in the **G_ENAME** group to create a formula column.

5. Double-click the new formula column object (**CF_1**) to display the Property Inspector, and set the following properties:
   - Under **General Information**, set the Name property to **DEPARTMENT**.
   - Under **Column**, set the Datatype property to Character, and set the Width property to 14.
   - Under **Placeholder/Formula**, double-click the PL/SQL Formula property field to display the PL/SQL Editor.

6. In the PL/SQL Editor, at the flashing cursor (after the word `begin`), type the following:

   ```sql
   return(:dname);
   ```

7. Click **Compile**.

8. Click **Close**.
9. Click the title bar of the Report Editor to make it the active window again.

### 20.4 Add a Field

Now that you have added the formula column to the data model, you need to add a corresponding field to display it. You can easily do this by invoking the re-entrant Report Wizard.

#### To add a field:

1. Choose **Tools > Report Wizard**.
2. On the **Report Type** page, select **Create Paper Layout Only**.
3. On the **Fields** page:
   - Click **DEPARTMENT** in the **Available Fields** list and click the right arrow (>) to move it to the **Displayed Fields** list.
   - Click and drag **DEPARTMENT** in the **Displayed Fields** list until it is located between **ENAME** and **SAL**.
4. Click **Finish** to preview your report output in the Paper Design view. It should look something like this:

   ![Figure 20–4 Paper Design view of the intermixing fields report](image)

### 20.5 Remove a Redundant Field

After you have added a field for the formula column, you will notice that the department values appear in two places. To eliminate this redundancy, you need to remove the master field and its heading.

#### To remove a field and its label:

1. In the Paper Design view, shift-click on the first instance of the label **Dept.** and the value next to it.
2. Choose **Edit > Delete**.
20.6 Suppress Redundant Values

Notice in your output that the department values are properly positioned, but they repeat for every record in the department. What you really want is for the department values to appear once for each department. To accomplish this task, you will first create a global variable to be used in comparing the current department value to the previous one. You will then write a Format Trigger to determine which values to suppress based upon the comparison within each department’s records.

To create a global variable:
1. In the Object Navigator, click the Program Units node.
2. Click the Create button in the toolbar. The New Program Unit dialog box displays.
3. Type global in the Name field and select Package Spec.
4. Click OK.
5. In the PL/SQL Editor, type the following PL/SQL:

```plsql
PACKAGE global IS
  prev_val varchar2(14);
END global;
```
END;

6. Click Compile

7. Click Close.

To add the format trigger:
1. In the Object Navigator, type `F_DEPARTMENT` in the Find field to select it.
2. Double-click the properties icon to the left of `F_DEPARTMENT` to display the Property Inspector, and set the following properties:
   - Under Advanced Layout, double-click the Format Trigger property field to display the PL/SQL Editor.
3. In the PL/SQL Editor, use the template to enter the following PL/SQL code:
   ```plsql
   function F_DEPARTMENTFormatTrigger return boolean is
   begin
   If global.prev_val = :department then
       return(false);
   Else
       global.prev_val := :department;
       return(true);
   END IF;
   end;
   ```
4. Click Compile.
5. Click Close.
6. Click the title bar of the Report Editor to make it the active window. Return to the Paper Design view if you are not already there. Notice the change in your report output.

Figure 20–7 Final report output displayed in the Paper Design view

<table>
<thead>
<tr>
<th>Name</th>
<th>Department</th>
<th>Salary</th>
</tr>
</thead>
<tbody>
<tr>
<td>CLARK</td>
<td>ACCOUNTING</td>
<td>2450</td>
</tr>
<tr>
<td>KING</td>
<td></td>
<td>6000</td>
</tr>
<tr>
<td>MILLER</td>
<td></td>
<td>1300</td>
</tr>
<tr>
<td>SMITH</td>
<td>RESEARCH</td>
<td>800</td>
</tr>
<tr>
<td>ADAMS</td>
<td></td>
<td>1100</td>
</tr>
<tr>
<td>FORD</td>
<td></td>
<td>2000</td>
</tr>
<tr>
<td>SCOTT</td>
<td></td>
<td>3000</td>
</tr>
<tr>
<td>JONES</td>
<td></td>
<td>2975</td>
</tr>
<tr>
<td>ALLEN</td>
<td>SALES</td>
<td>1600</td>
</tr>
<tr>
<td>BLAKE</td>
<td></td>
<td>2850</td>
</tr>
<tr>
<td>MARTIN</td>
<td></td>
<td>1250</td>
</tr>
</tbody>
</table>

7. Save the report.
20.7 Summary

Congratulations! You have successfully created an intermixed fields report. You now know how to:

■ create a data model and layout in the Report Wizard.
■ add a formula column to the detail group.
■ add a field in the Report Wizard.
■ remove a redundant field in the Paper Design view.
■ suppress values in a Format Trigger.

For more information on any of the wizards, views, or properties used in this example, refer to the Oracle Reports online Help, which is available in Oracle Reports Builder or hosted on the Oracle Technology Network (OTN), as described in Section 4.1.1, "Using the Oracle Reports online Help".
In this chapter, you will learn about reports that suppress the display of field labels. By following the steps in this chapter, you can generate the report output shown in Figure 21–1. Notice how the field labels for Department 40 do not display because no detail records were found.

**Figure 21–1  Suppressed labels report output**

<table>
<thead>
<tr>
<th>Dept ID</th>
<th>Dept</th>
<th>Location</th>
</tr>
</thead>
<tbody>
<tr>
<td>10</td>
<td>ACCOUNTING</td>
<td>NEW YORK</td>
</tr>
<tr>
<td>Name</td>
<td>Job Title</td>
<td></td>
</tr>
<tr>
<td>CLARK</td>
<td>MANAGER</td>
<td></td>
</tr>
<tr>
<td>KING</td>
<td>PRESIDENT</td>
<td></td>
</tr>
<tr>
<td>MILLER</td>
<td>CLERK</td>
<td></td>
</tr>
<tr>
<td>20</td>
<td>RESEARCH</td>
<td>DALLAS</td>
</tr>
<tr>
<td>Name</td>
<td>Job Title</td>
<td></td>
</tr>
<tr>
<td>ADAMS</td>
<td>CLERK</td>
<td></td>
</tr>
<tr>
<td>FORD</td>
<td>ANALYST</td>
<td></td>
</tr>
<tr>
<td>JONES</td>
<td>MANAGER</td>
<td></td>
</tr>
<tr>
<td>SCOTT</td>
<td>ANALYST</td>
<td></td>
</tr>
<tr>
<td>SMITH</td>
<td>CLERK</td>
<td></td>
</tr>
<tr>
<td>30</td>
<td>SALES</td>
<td>CHICAGO</td>
</tr>
<tr>
<td>Name</td>
<td>Job Title</td>
<td></td>
</tr>
<tr>
<td>ALLEN</td>
<td>SALESMAN</td>
<td></td>
</tr>
<tr>
<td>BLAKE</td>
<td>MANAGER</td>
<td></td>
</tr>
<tr>
<td>JAMES</td>
<td>CLERK</td>
<td></td>
</tr>
<tr>
<td>MARTIN</td>
<td>SALESMAN</td>
<td></td>
</tr>
<tr>
<td>TURNER</td>
<td>SALESMAN</td>
<td></td>
</tr>
<tr>
<td>WARD</td>
<td>SALESMAN</td>
<td></td>
</tr>
<tr>
<td>40</td>
<td>OPERATIONS</td>
<td>BOSTON</td>
</tr>
</tbody>
</table>

**Concepts**

A default master/detail report must print a detail label or field, even if there are neither fetched detail records nor values for user-created columns. This example demonstrates how to suppress the detail information for a single record, but allow the other master/detail records to display.

**Data Relationships**

- This report uses a master/detail data model. You will also create a formula column in the detail group whose sole function is to return a value; this ensures the detail group contains at least one column that will always return a value each time a detail record is returned (as opposed to, for example, a null value).

- You will create a summary to count the number of times this formula column returns a value. In the layout, you will create a format trigger that references the summary to determine if the detail labels should be displayed. Doing so provides a reliable method for determining the existence of detail records.
**Layout**
This report uses a Group Above layout style with modifications.

**Example Scenario**
In this example, you will build a report that does not display field labels when there are no detail records. Instead, text displays that notifies the user that no detail records were retrieved.

As you build this example report, you will:
- Create the Data Model with Two Linked Queries manually in the Data Model view.
- Create a Formula Column and a Summary Column in the Data Model view.
- Create the report layout using the Report Wizard.
- Add a Format Trigger to Suppress Labels when no detail records are retrieved.
- Add Text to Display when No Records Display.

To see a sample report that suppresses labels, open the examples folder named `suppresslabels`, then open the Oracle Reports example named `suppresslabels.rdf`. For details on how to open it, see "Accessing the Example Reports" in the Preface.

### 21.1 Prerequisites for This Example
To build the example in this chapter, you must have access to the SCOTT sample schema provided with the Oracle Database. If you do not know if you have access to this sample schema, contact your database administrator.

### 21.2 Create the Data Model with Two Linked Queries
The steps in this section will show you how to build a simple data model with two queries in a master/detail relationship.

**To create a data model**
1. Launch Reports Builder (or, if already open, choose File > New > Report).
2. In the Welcome or New Report dialog box, select Build a new report manually, then click OK.
3. In the Data Model view that displays, click the SQL tool in the tool palette, then click in an open area of the Data Model view to display the SQL Query Statement dialog box.
4. In the SQL Query Statement dialog box, type the first `SELECT` statement:

```sql
SELECT * FROM DEPT
ORDER BY DEPTNO
```
Create the Data Model with Two Linked Queries

5. Click OK.

6. When the query displays in the Data Model view, right-click the query name (Q_1), then choose Property Inspector from the pop-up menu to set the following property:
   - Under General Information, set the Name property to Q_DEPT.

7. Follow the steps above to create another query named Q_EMP, with the following SELECT statement:
   
   ```sql
   SELECT DEPTNO, ENAME, JOB FROM EMP
   ORDER BY ENAME
   ```

8. In the Data Model view, click the Data Link tool in the tool palette.

9. Drag a link between DEPTNO in Q_DEPT and DEPTNO1 in Q_EMP. Your data model should now look like this:

   ![Figure 21–2 Data Model view of the Suppress Labels report](image)

10. Save your report as suppresslabels_your_initials.rdf.

---

**Note:** You can enter this query in any of the following ways:

- Copy and paste the code from the provided text file called suppresslabels_code.txt into the SQL Query Statement field.
- Click Query Builder to build the query without entering any code manually.
- Type the code in the SQL Query Statement field.

Also notice that if you have not installed the Pictures table into the sample schema, you will not be able to create this query.

---

**Note:** If you are not already connected to a database, you will be prompted to connect to the database when you click Query Builder or Next. Ensure that you connect to a database that has the appropriate schema for this example. Section 21.1, "Prerequisites for This Example" describes the sample schema requirements for this example.

---

6. When the query displays in the Data Model view, right-click the query name (Q_1), then choose Property Inspector from the pop-up menu to set the following property:
   - Under General Information, set the Name property to Q_DEPT.

7. Follow the steps above to create another query named Q_EMP, with the following SELECT statement:

   ```sql
   SELECT DEPTNO, ENAME, JOB FROM EMP
   ORDER BY ENAME
   ```

8. In the Data Model view, click the Data Link tool in the tool palette.

9. Drag a link between DEPTNO in Q_DEPT and DEPTNO1 in Q_EMP. Your data model should now look like this:

   ![Figure 21–2 Data Model view of the Suppress Labels report](image)

10. Save your report as suppresslabels_your_initials.rdf.

---

**Note:** You can enter this query in any of the following ways:

- Copy and paste the code from the provided text file called suppresslabels_code.txt into the SQL Query Statement field.
- Click Query Builder to build the query without entering any code manually.
- Type the code in the SQL Query Statement field.

Also notice that if you have not installed the Pictures table into the sample schema, you will not be able to create this query.

---

**Note:** If you are not already connected to a database, you will be prompted to connect to the database when you click Query Builder or Next. Ensure that you connect to a database that has the appropriate schema for this example. Section 21.1, "Prerequisites for This Example" describes the sample schema requirements for this example.

---

6. When the query displays in the Data Model view, right-click the query name (Q_1), then choose Property Inspector from the pop-up menu to set the following property:
   - Under General Information, set the Name property to Q_DEPT.

7. Follow the steps above to create another query named Q_EMP, with the following SELECT statement:

   ```sql
   SELECT DEPTNO, ENAME, JOB FROM EMP
   ORDER BY ENAME
   ```

8. In the Data Model view, click the Data Link tool in the tool palette.

9. Drag a link between DEPTNO in Q_DEPT and DEPTNO1 in Q_EMP. Your data model should now look like this:

   ![Figure 21–2 Data Model view of the Suppress Labels report](image)

10. Save your report as suppresslabels_your_initials.rdf.

---

**Note:** You can enter this query in any of the following ways:

- Copy and paste the code from the provided text file called suppresslabels_code.txt into the SQL Query Statement field.
- Click Query Builder to build the query without entering any code manually.
- Type the code in the SQL Query Statement field.

Also notice that if you have not installed the Pictures table into the sample schema, you will not be able to create this query.

---

**Note:** If you are not already connected to a database, you will be prompted to connect to the database when you click Query Builder or Next. Ensure that you connect to a database that has the appropriate schema for this example. Section 21.1, "Prerequisites for This Example" describes the sample schema requirements for this example.
21.3 Create a Formula Column and a Summary Column

The steps in this section will show you how to add a formula column to the Q_EMP (or detail) query you built in the previous section that will return a value every time a detail record is returned. You will then add a summary column to the Q_DEPT (or master) query that will count the number of times this formula column returns a value.

Before you create either of these columns, you may want to expand the size of your groups for better visibility. To do so, select the yellow group box. Click the bottom frame, then drag it down about 0.25 inches (0.5 centimeters). If you do this for both groups, you will have enough room to add your new columns.

21.3.1 Create a formula column in the detail query

This section will show you how to create a formula column that will return a single value.

To create a formula column:
1. In the Data Model view, click the Formula Column tool in the tool palette.
2. Click in the Q_EMP query, under the JOB column to create a formula column.
3. Double-click the new formula column object (CF_1) to display the Property Inspector, and set the following properties:
   ■ Under General Information, set the Name property to DETAIL_VAL.
   ■ Under Placeholder/Formula, click the PL/SQL Formula property field to display the PL/SQL Editor.
4. In the PL/SQL Editor, use the template to enter the following PL/SQL code:

   ```plsql
   function DETAIL_VALFormula return Number is
   begin
       return(1);
   end;
   ```

5. Click Compile.

6. When the code is compiled, click Close.

   **Tip:** If you receive errors when compiling, compare your code against the code provided. You can also simply copy and paste the code from suppresslabels_code.txt.

21.3.2 Create a summary column in the master query

The steps in this section will show you how to create and customize a summary column in the master query that will depend on the information returned by the formula column.

To create a summary column:
1. In the Data Model view, click the Summary Column tool in the tool palette.
2. Click in the Q_DEPT query, under the LOC column to create a summary column.
3. Double-click the new summary column object (CS_1) to display the Property Inspector, and set the following properties:
   ■ Under General Information, set the Name property to COUNT_DETAIL.
Under **Summary**, set the Function property to Count, set the Source property to DETAIL_VAL, and set the Reset At property to G_DEPTNO.

Your data model now contains both the formula and summary columns, and should look like this:

*Figure 21–3  Data Model view with formula and summary columns*

4. Save your report as `suppresslabels_your_initials.rdf`.

### 21.4 Create the report layout

In this section, you will create a default layout for your report. You will then add all the necessary layout objects for your checks.

#### 21.4.1 Create the initial layout of your report

**To create the initial layout:**

1. In the Data Model view, right-click on the canvas, then choose **Report Wizard**.
2. In the Report Wizard, on the **Report Type** page, select **Create Paper Layout only**.
3. On the **Style** page, select **Group Above**.
4. On the **Groups** page, click the following groups in the **Available Groups** list and click **Down** to specify the Print Direction and move them to the **Displayed Groups** list:
   - G_DEPTNO
   - G_DEPTNO1
5. On the **Fields** page:
   - Click the double right arrows (>>) to move all of the fields to the **Displayed Fields** list.
   - In the **Displayed Fields** list, click DEPTNO1 then click the left arrow (<) to move this field back to the **Available Fields** list.
   - Do the same for the **COUNT_DETAIL** and **DETAIL_VAL** fields.
6. On the **Labels** page, make any desired changes to the labels.
7. On the **Template** page, select **Predefined Template** and click **Blue**, then click **Finish** to display your report output in the Paper Design view. It should look something like this:
Add a Format Trigger to Suppress Labels

Figure 21–4  Paper Design view for the suppress labels report

8. Save your report as suppresslabels_your_initials.rdf.

21.5 Add a Format Trigger to Suppress Labels

The steps in this section will show you how to add a format trigger to your report that will prevent labels from being displayed for records will null values.

To create a format trigger:

1. In the Object Navigator, under the Paper Layout node, navigate to Main Section > Body > M_G_DEPTNO_GRPFR > R_G_DEPTNO > M_G_DEPTNO1_GRPFR > M_G_DEPTNO1_HDR. Or, use the Find field in the Object Navigator to find M_G_DEPTNO1_HDR.

   Tip: See the image below for an example of where the frame is located in your Object Navigator. When you select the frame name in the Object Navigator, the corresponding frame will be selected in the Paper Layout view, as well.

Figure 21–5  Navigating to M_G_DEPTNO1_HDR
2. Double-click the properties icon next to M_G_DEPTNO1_HDR to display the Property Inspector, and set the following properties:
   ■ Under Advanced Layout, double-click the Format Trigger property field to display the PL/SQL Editor.
3. In the PL/SQL Editor, use the template to enter the following PL/SQL code:
   ```plsql
   function M_G_DEPTNO1_HDRFormatTrigger return boolean is
     begin
       if :count_detail=0 then
         return (FALSE);
       else
         return (TRUE);
       end if;
     end;
   end;
   ```
4. Click Compile.

   **Tip:** If you receive errors when compiling, compare your code against the code provided. You can also simply copy and paste the code from `suppresslabels_code.txt`.
5. When there are no compiling errors, click Close.
6. Save your report as `suppresslabels_your_initials.rdf`.

### 21.6 Add Text to Display when No Records Display

The steps in this section will show you how to add boilerplate text to your report layout that will display when no records are retrieved.

**To add boilerplate text:**
1. In the Paper Layout view, click the Confine Off and the Flex Off buttons in the toolbar.

   **Note:** To adjust the way the boilerplate objects display in your resulting report, you must turn off Confine and Flex modes before you create the objects.
2. Click the Text tool in the tool palette.
3. Draw a rectangle above the two fields F_ENAME and F_JOB to create a new boilerplate text object.
4. Click in the boilerplate text object, and type "No detail records retrieved."
5. Select the text, then choose **Format > Font**.
6. In the Font dialog box, choose **Arial**, then click **OK**.
7. While the Paper Layout view still displays, click the Object Navigator and position the two windows so that you can see them side-by-side.
8. In the Object Navigator, navigate to M_G_DEPTNO1_GRPFR, and select these objects using CTRL-click:
   ■ R_G_DEPTNO1
     F_ENAME
- **F_JOB**

  Your Object Navigator should look like this:

  ![Figure 21–6  Selected objects in the Object Navigator](image)

  - In the Paper Layout view, click the Confine On button in the toolbar.
  - Choose **Layout > Bring to Front**.

  **Note:** If this menu option is greyed out, click the title bar of the Paper Layout view, but do not click on the canvas itself. This menu option is only available when the Paper Layout view is active.

  By choosing this menu option, Reports Builder will display the records in front of the boilerplate text you just created. If there are no records, the boilerplate text will display.

  The Object Navigator should now look like this:
Now, we need to change the fill color of the parent frame, so that you cannot see the boilerplate text behind the detail records.

11. In the Object Navigator, click M_G_DEPTNO1_GRPFR so that it is the only object selected. In the Paper Layout view, you should see this same frame selected.

12. Click the Fill Color tool in the tool palette, and change the fill color to light blue, so that it matches the template.

13. Click the Paper Design button in the toolbar to run and display your report in the Paper Design view. Your report should look something like this:

Note: You will notice that the boilerplate text, B_1, is now located directly under the parent frame, M_G_DEPTNO1_GRPFR. This placement means that the records displayed by the objects in the repeating frame, R_G_DEPTNO1, will display in front of the boilerplate text. The boilerplate text, which says that no detail records were retrieved, only displays when no records are present.
### Figure 21–8  Final Paper Output of the Suppressing Labels Report

<table>
<thead>
<tr>
<th>Dept ID</th>
<th>Dept</th>
<th>Name</th>
<th>Job Title</th>
<th>Location</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>ACCOUNTING</td>
<td>CLARK</td>
<td>MANAGER</td>
<td>NEW YORK</td>
</tr>
<tr>
<td></td>
<td>RESEARCH</td>
<td>KING</td>
<td>PRESIDENT</td>
<td>DALLAS</td>
</tr>
<tr>
<td></td>
<td></td>
<td>MILLER</td>
<td>CLERK</td>
<td></td>
</tr>
<tr>
<td></td>
<td>SALES</td>
<td>ADAMS</td>
<td>CLERK</td>
<td></td>
</tr>
<tr>
<td></td>
<td>OPERATIONS</td>
<td>ALLEN</td>
<td>SALESMAN</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>BLAKE</td>
<td>MANAGER</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>JAMES</td>
<td>CLERK</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>MARTIN</td>
<td>SALESMAN</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>TURNER</td>
<td>SALESMAN</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>WARD</td>
<td>SALESMAN</td>
<td></td>
</tr>
</tbody>
</table>

No detail records retrieved.

**Note:** Notice how the record for Department 40 shows the boilerplate text you added, and the field names for the record are suppressed.

14. Save your report as `suppresslabels_your_initials.rdf`.

### 21.7 Summary

Congratulations! You have successfully built a report that suppresses labels when no data is retrieved. You now know how to:

- manually create and link two queries.
- create a formula column and a summary column.
- create a default layout in the Report Wizard.
- create a format trigger that suppresses the field labels when no detail records are displayed.
- added boilerplate text and manipulated the layout.

For more information on any of the wizards, views, or properties used in this example, refer to the *Oracle Reports online Help*, which is available in Oracle Reports Builder or hosted on the Oracle Technology Network (OTN), as described in Section 4.1.1, "Using the Oracle Reports online Help".
In this chapter, you will learn about reports that display highlighted values based on one or more conditions. By following the steps in this chapter, you can generate the report output shown in Figure 22–1.

Figure 22–1  Conditional highlighting report output

<table>
<thead>
<tr>
<th>Employee Id</th>
<th>First Name</th>
<th>Last Name</th>
<th>Salary</th>
</tr>
</thead>
<tbody>
<tr>
<td>100</td>
<td>Steven</td>
<td>Kings</td>
<td>$24,000.00</td>
</tr>
<tr>
<td>101</td>
<td>Neena</td>
<td>Kochharr</td>
<td>$17,000.00</td>
</tr>
<tr>
<td>102</td>
<td>Lex</td>
<td>De Haan</td>
<td>$17,000.00</td>
</tr>
<tr>
<td>103</td>
<td>Alexander</td>
<td>Hunold</td>
<td>$9,000.00</td>
</tr>
<tr>
<td>104</td>
<td>Bruce</td>
<td>Ernst</td>
<td>$6,000.00</td>
</tr>
<tr>
<td>105</td>
<td>David</td>
<td>Austin</td>
<td>$4,800.00</td>
</tr>
<tr>
<td>106</td>
<td>Vali</td>
<td>Palaballa</td>
<td>$4,800.00</td>
</tr>
<tr>
<td>107</td>
<td>Diana</td>
<td>Lorentz</td>
<td>$4,200.00</td>
</tr>
<tr>
<td>108</td>
<td>Nancy</td>
<td>Greenberg</td>
<td>$12,000.00</td>
</tr>
<tr>
<td>109</td>
<td>Dariel</td>
<td>Faviet</td>
<td>$9,000.00</td>
</tr>
<tr>
<td>110</td>
<td>John</td>
<td>Chen</td>
<td>$8,200.00</td>
</tr>
<tr>
<td>111</td>
<td>Ismael</td>
<td>Sciarra</td>
<td>$7,700.00</td>
</tr>
<tr>
<td>112</td>
<td>Jose Manuel</td>
<td>Urman</td>
<td>$7,800.00</td>
</tr>
<tr>
<td>113</td>
<td>Luis</td>
<td>Popp</td>
<td>$6,900.00</td>
</tr>
<tr>
<td>114</td>
<td>Der</td>
<td>Raphaely</td>
<td>$11,000.00</td>
</tr>
<tr>
<td>115</td>
<td>Alexander</td>
<td>Khoo</td>
<td>$3,100.00</td>
</tr>
</tbody>
</table>

Concepts

- You can create a format trigger that will change the appearance of retrieved data depending on factors you define.
- You can use the Conditional Formatting dialog box to create this format trigger, or you can manually create them using the PL/SQL Editor. The steps in this example will show you how to use the Conditional Formatting dialog box, then display the code in the PL/SQL Editor to see how the format trigger was automatically generated by Reports Builder.
With conditional highlighting, you can format specified portions of a report’s output when certain criteria are met.

Data Relationships
This report uses one query to fetch all data.

Layout
This report uses a tabular layout style. To add conditional highlighting, you will use the Conditional Formatting dialog box to determine which names and salaries will be highlighted in the report output.

Example Scenario
In this example, you will create a report for managers that shows a complete list of employees in the company, but also highlights employee salaries that are greater than or equal to $10,000. You also need to indicate which employees’ salaries are between $4,999 and $10,000. In this example, you will use conditional formatting to highlight these figures in bold and red text.

As you build this example report, you will:

- **Create a Basic Tabular Report** using the Report Wizard to included a single query.
- **Add Conditional Formatting to the Report** using the Conditional Formatting dialog box to highlight specific data in the report.
- **Examine the Conditional Format Trigger Code** using the PL/SQL Editor, for the format trigger generated by Reports Builder.

To see a sample report that uses conditional highlighting, open the examples folder named `condhigh`, then open the Oracle Reports example report named `condhigh.rdf`. For details on how to open it, see "Accessing the Example Reports" in the Preface.

### 22.1 Prerequisites for This Example

To build the example in this chapter, you must have access to the Human Resources sample schema (HR) provided with the Oracle Database. If you do not know if you have access to this sample schema, contact your database administrator.

### 22.2 Create a Basic Tabular Report

The steps in this section will show you how to use the Report Wizard to build a simple tabular report.

**To create a tabular report:**

1. Launch Reports Builder (or, if already open, choose File > New > Report).
2. In the Welcome or New Report dialog box, select **Use the Report Wizard**, then click **OK**.
3. If the Welcome page displays, click **Next**.
4. On the Report Type page, select **Create Paper Layout Only**, then click **Next**.
5. On the Style page, type a **Title** for your report, select **Tabular**, then click **Next**.
6. On the Data Source page, click **SQL Query**, then click **Next**.
7. On the Data page, enter the following **SELECT** statement in the **Data Source definition** field:
CREATE REPORT

SELECT ALL EMPLOYEES.FIRST_NAME, EMPLOYEES.LAST_NAME, EMPLOYEES.EMPLOYEE_ID, EMPLOYEES.SALARY
FROM HR.EMPLOYEES

Note: You can enter this query in any of the following ways:
- Copy and paste the code from the provided text file called condhigh_code.txt into the Data Source definition field.
- Click Query Builder to build the query without entering any code manually.
- Type the code in the Data Source definition field.

8. Click Next.

Note: If you are not already connected to a database, you will be prompted to connect to the database when you click Query Builder or Next. Ensure that you connect to a database that has the appropriate schema for this example. Section 22.1, "Prerequisites for This Example" describes the sample schema requirements for this example.

9. On the Fields page, click the right arrow (>) to move the following fields to the Displayed Fields list, then click Next. Make sure you move them in the following order:
   - EMPLOYEE_ID
   - FIRST_NAME
   - LAST_NAME
   - SALARY

10. On the Totals page, click Next.


12. On the Template page, select Predefined Template and click Beige, then click Finish to preview your report output in the Paper Design view. It should look something like this:
Now, let us format the data to make it more meaningful.

**To format the report:**

1. In the Paper Design view, select the **Salary** column by clicking once on the column of data.

2. Click the Currency button in the toolbar. A currency symbol immediately appears next to all of the values.

3. Click the Commas button.

4. Click the Add Decimal button twice. Two decimal places are added to the right of the decimal point.

   The Salary column of your report should now look like this:
5. Change the alignment of your columns by doing the following:
   a. Click the **Salary** column heading, then click the Align Center button in the toolbar.
   b. Click the **Salary** column once, then click the Align Right button in the toolbar.
   c. While the **Salary** column is selected, Shift-click to select the column heading too, then click and drag one of the right black squares to size the column and column heading.
   d. Click the **Employee Id** column heading, Shift-click to select the **Employee Id** column too, then click the Align Center button in the toolbar.

6. The Paper Design view of your report should now look like this:

7. Save your report as **condhigh_your_initials.rdf**.
22.3 Add Conditional Formatting to the Report

The steps in this section will show you how to add conditional formatting so that salaries greater than or equal to $10,000 will be highlighted in bold, red text, and salaries between $4,999 and $10,000 will be highlighted in bold text.

Since the data retrieved cannot be both greater than or equal to $10,000 and between $4,999 and $10,000, you will need to create two separate format exceptions. In this section, you will see how to create each distinct format exception.

To add conditional formatting:

1. In the Paper Design view, right-click the Salary column of data (not the Salary column heading), then choose Conditional Formatting.

2. In the Conditional Formatting dialog box, click New to create a new Format Exception.

3. In the Format Exception dialog box, make sure SALARY is selected.

4. Next to SALARY, choose Greater Than or Equal from the list.

5. In the next box, type 10000.

6. Under Format, click the icon next to Text Color to display the color palette.

   **Note:** You can choose as many options as you want in the Format Exception dialog box, such as text color, style, and font.

7. Click Red.

8. Click Font, then choose Bold.

9. Click OK to accept the new font style.

   You should now see the following options selected in the Format Exception dialog box:

**Figure 22–5 Format Exception dialog box**

10. Click OK.
11. In the Conditional Formatting dialog box, click **New** to create your second format exception.

12. Create a format exception where the values of the SALARY column are between $4999 and $10000 are highlighted in bold.

---

**Note:** Make sure you type the values in the order described, so that Reports Builder knows to highlight the data between $4999 and $10000, and *not* $10000 and $4999.

---

13. When you are done, click **OK**. The Conditional Formatting dialog box should now look like the following:

**Figure 22–6  Conditional Formatting dialog box**

![Conditional Formatting dialog box]

14. Click **Apply**, then click **OK**. Your report displays in the Paper Design view, and should now look something like this:

**Figure 22–7  Final Conditional Formatting report**

![Final Conditional Formatting report]

15. Save your report as **condhigh_your_initials.rdf**.
22.4 Examine the Conditional Format Trigger Code

The steps in this section will show you the PL/SQL code that was automatically generated by Reports Builder when you used the Conditional Formatting dialog box to set up your format exceptions.

---

**Note:** You can also edit the conditional format trigger code in the PL/SQL Editor, but if you attempt to modify the code again in the Conditional Formatting dialog box, your edits will be overwritten by the selections in the dialog box. If you do modify the code in the PL/SQL Editor, you will see a warning note when you try to open the Conditional Formatting dialog box.

---

**To examine the automatically generated code:**

1. In the Paper Design view, right-click the **Salary** column (on which you just applied formatting), then choose **PL/SQL Editor**.

2. In the PL/SQL Editor, you will see the following code that was automatically generated by Reports Builder.

**Figure 22–8  PL/SQL code for the new format triggers**

```sql
function F_SALARYFormatTrigger return boolean is
begin
    -- Automatically Generated from Report Builder.
    if (:SALARY >= '10000')
        then
            srw.set_text_color('red');
            srw.set_font_face('Arial');
            srw.set_font_size(10);
            srw.set_font_weight(srw.bold_weight);
            srw.set_font_style(srw.plain_style);
        end if;

    -- Automatically Generated from Report Builder.
    if (:SALARY BETWEEN '4999' and '10000')
        then
            srw.set_font_face('Arial');
            srw.set_font_size(10);
            srw.set_font_weight(srw.bold_weight);
            srw.set_font_style(srw.plain_style);
        end if;

    return true;
end F_SALARYFormatTrigger;
```

---

**Note:** In this code, you can see that the two format exceptions you created comprise two parts of a format trigger. You needed to create two separate format exceptions in the Conditional Formatting dialog box to achieve this effect. If you had tried to create both exceptions simultaneously in the same Format Exception dialog box, your data would not have satisfied both exceptions, and thus would not have been highlighted.
22.5 Summary

Congratulations! You have successfully built a report that highlights specified data in the report output. You now know how to:

■ use the Report Wizard to create a simple tabular report.
■ format the appearance of your report using tools in the Paper Design view.
■ use the Conditional Formatting dialog box and the Format Exception dialog box to create format triggers that highlight certain data in your report output.
■ examine the code automatically generated by Reports Builder.

For more information on any of the wizards, views, or properties used in this example, refer to the *Oracle Reports online Help*, which is available in Oracle Reports Builder or hosted on the Oracle Technology Network (OTN), as described in Section 4.1.1, "Using the Oracle Reports online Help".
In this chapter, you will learn about reports that generate different versions of a form letter based on changing conditions. By following the steps in this chapter, you can generate the report output shown in Figure 23–1 and Figure 23–2.

**Figure 23–1  Conditional form letter report output, base version**

Dear Employee ADAMS,

Mark your calendar! You are invited to attend the Summit Sporting Goods annual picnic on June 15, from 11:00 AM to 6:00 PM. Be prepared for lots of food, lots of entertainment, and lots of fun.

We would also like to take this opportunity to thank you for all of your efforts over the last year. As a result of your hard work, company revenues increased 15%.

I look forward to seeing you there!

J. King
President
Summit Sporting Goods
Figure 23–2  Conditional form letter report output, alternate version

Dear Employee Name,

Mark your calendar! You are invited to attend the Summit Spotting Goods annual picnic on June 16, from 11:00 AM to 6:00 PM. Be prepared for lots of food, lots of entertainment, and lots of fun.

Because you’re one of our top sales representatives, we would like to invite you to a celebration dinner after the picnic. Employees such as yourself brought in over $10 million in increased revenues this year, a 15% increase over last year. The dinner will be held at the City Inn from 7:00 PM to midnight. Dinner will be served at 7:30 PM. Please reply to Human Resources if you plan to attend.

I look forward to seeing you there!

J. King
President
Summit Spotting Goods

Concepts

■ The two form letters above were generated from the same report. As you can see, the two letters share a number of features. Hence, it is more convenient to create a base form letter and then apply conditions to certain parts to determine whether they should be displayed for the current record, in this case, employees.

■ Conditional printing is useful when you want to display a section of a report only if certain conditions are met at run time. Conversely, you may wish to use conditional printing to suppress certain information for those who don’t need it.

Data Relationships

This report uses one query to select all data.

Layout

This report uses the Form Letter layout style. You’ll also create the various pieces of boilerplate that will comprise the letter. To govern the printing of these boilerplate objects, you’ll use vertically collapsing anchors and PL/SQL format triggers to conditionally produce different form letters for employees who meet the specified criteria.

Example Scenario

In this example, you will create a form letter to invite all of your employees to the company picnic. For your top sales representatives, though, you also want to include a
Create the Data Model and Layout

Building a Conditional Form Letter Report 23-3

special invitation to a dinner party in the form letter. For all other employees, you want to include a thank you without the dinner invitation.

As you build this example report, you will:

■ Create the Data Model and Layout.
■ Add Additional Text.
■ Add Logic for Text, which involves anchoring objects together and creating format triggers to control whether the text displays.

To see a sample conditional form letter report, open the examples folder named condform, then open the Oracle Reports example named condform.rdf. For details on how to access it, see "Accessing the Example Reports" in the Preface.

23.1 Prerequisites for This Example

To build the example in this chapter, you must have access to the SCOTT sample schema provided with the Oracle Database. If you do not know if you have access to this sample schema, contact your database administrator.

23.2 Create the Data Model and Layout

When you are creating a single-query report, such as this one, you can use the Report Wizard to create the data model and layout simultaneously.

To create a data model and layout:

1. Launch Reports Builder (or, if already open, choose File > New > Report)
2. In the Welcome or New Report dialog box, select Use the Report Wizard, then click OK.
3. If the Welcome page displays, click Next.
4. On the Report Type page, select Create Paper Layout Only, then click Next.
5. On the Style page, type a Title for your report, select Form Letter, then click Next.
6. On the Data Source page, click SQL Query, then click Next.
7. On the Data page, enter the following SELECT statement in the Data Source definition field:
   
   SELECT ENAME, COMM FROM EMP
   ORDER BY ENAME

   SELECT ENAME, COMM FROM EMP
   ORDER BY ENAME

   Note: You can enter this query in any of the following ways:
   ■ Copy and paste the code from the provided text file called condform_code.txt into the Data Source definition field.
   ■ Click Query Builder to build the query without entering any code manually.
   ■ Type the code in the Data Source definition field.

8. Click Next.
9. Type the first paragraph of your letter in the Form Letter Text window:

Dear Employee &<ENAME>,

Mark your calendar! You are invited to attend the Summit Sporting Goods annual picnic on June 15, from 11:00 AM to 6:00 PM. Be prepared for lots of food, lots of entertainment, and lots of fun.

Tip: Be sure to include hard returns at the end of each line.

10. Click Next.

11. On the Template page, select No template, then click Finish to preview your report output in the Paper Design view.

12. Save the report as condform_your_initials.rdf.

23.3 Add Additional Text

After you add the basic text in the Report Wizard, you need to create some additional text. The text must reside inside of the repeating frame, so before you add text, you will resize the repeating frame.

To resize the repeating frame:
1. Click the Paper Layout button in the toolbar to display the Paper Layout view.
2. In the Object Navigator, type R_G_ENAME in the Find field to locate it.
3. Click R_G_ENAME to select it. It is simultaneously selected in the Paper Layout view.
4. Click the title bar of the Report Editor to make it the active window.
5. Click the bottom handle of R_G_ENAME and drag it down about 4 inches (10 centimeters).

To add more text:
1. Click the Text tool in the tool palette.
2. Click about 0.25 inches (0.5 centimeters) below the first text object.
3. Type the following text:

Because you're one of our top sales representatives, we would like to invite you to a celebration dinner after the picnic. Employees such as yourself brought in over $10 million in increased revenues this year, a 15% increase over last year. The
dinner will be held at the City Inn from 7:00 PM to midnight. Dinner will be served at 7:30 PM. Please reply to Human Resources if you plan to attend.

4. Click once in an open area of the Paper Layout view.

5. Choose Tools > Property Inspector to display the Property Inspector for the boilerplate text object:
   - Under General Information, set the Name property to B_SALESREP.

6. Click the title bar of the Report Editor to make it the active window again.

7. Repeat the steps above, but this time use the following text and name it B_ALL2:

   We would also like to take this opportunity to thank you for all of your efforts over the last year. As a result of your hard work, company revenues increased 15%.

8. Again, repeat the steps above, but this time use the following text and name it B_ALL3:

   I look forward to seeing you there!

   J. King
   President
   Summit Sporting Goods

9. Rename the original text object to B_ALL by selecting it and choosing Tools > Property Inspector to set the Name property.

### 23.4 Add Logic for Text

The text in B_SALESREP and B_ALL2 applies only to some employees. Hence, you need to apply a condition to each one to determine when it should appear. You also need to ensure that objects (for example, B_ALL2 and B_ALL3) move up in the layout whenever objects above them (for example, B_SALESREP and B_ALL2) do not print. Otherwise, you will have large gaps in your report output for employees who do not get all of the objects. To achieve this, you must anchor the text objects together.

To create collapsing anchors:

1. In the Paper Layout view, click the Anchor tool in the tool palette.

2. Click and drag a line from the top left corner of B_SALESREP (the second text object) to the top left corner of B_ALL (the first text object). Double-click to create the new anchor object.

3. Choose Tools > Property Inspector to display the Property Inspector for the anchor object:
   - Set the Child Edge Percent and Parent Edge Percent properties to 0.
   - Set the Collapse Vertically property to Yes.

4. Click the title bar of the Report Editor to make it the active window again.

5. Repeat the steps above, but this time drag from top left corner of B_ALL2 to the top left corner of B_SALESREP.
6. Again, repeat the steps above, but this time drag from top left corner of B_ALL3 to the top left corner of B.ALL2.

Figure 23–3  Property Inspector with anchor properties displayed

To create format triggers:

1. In the Paper Layout view, double-click B_SALESREP to display the Property Inspector, and set the following properties:
   - Under Advanced Layout, double-click the Format Trigger property field to display the PL/SQL Editor.

2. In the PL/SQL Editor, use the template to enter the following PL/SQL code:

   function B_SalesrepFormatTrigger return boolean is
   begin
      if :comm >= 500 then return(TRUE);
      else return(FALSE);
   end if;
   end;

   This boilerplate will print only in the letters to employees whose commissions are greater than $500.

3. Repeat the steps above, but this time enter the following PL/SQL for B_ALL2:

   function B_ALL2FormatTrigger return boolean is
   begin
      if (:comm < 500) or (:comm is null) then
         return(TRUE);
      else return(FALSE);
   end if;
   end;

   This logic causes B_ALL2 to print only in the letters where B_SALESREP does not print.
4. Compile, save, and run your report. Page through the form letters to see that some have the dinner invitation while others have the “thank you” message.

Tip: To preview this report for a specific destination type, in the Paper Design view, choose File > Preview Format, and select the destination type. Your report output will display as though using Printer fonts instead of screen display fonts, and you can get a clearer indication of the appearance (for example, line wrapping) of the printed report.

In addition, when you print a conditional form letter report on stationery as illustrated, be sure to take into account the position of the letterhead, and so on, when creating the layout so the text of the letter fits into the overall design of the stationery.

23.5 Summary

Congratulations! You have successfully created a conditional form letter report. You now know how to:

- create a data model and a layout.
- add text.
- anchor objects together and create format triggers to control whether the text displays.

For more information on any of the wizards, views, or properties used in this example, refer to the Oracle Reports online Help, which is available in Oracle Reports Builder or hosted on the Oracle Technology Network (OTN), as described in Section 4.1.1, "Using
the Oracle Reports online Help".
In this chapter, you will learn about reports that include graphics that change depending on the data. By following the steps in this chapter, you can generate the report output shown in Figure 24–1.

Figure 24–1  Dynamic graphics report output

<table>
<thead>
<tr>
<th>Dept</th>
<th>Name</th>
<th>Job</th>
<th>Hire Date</th>
</tr>
</thead>
<tbody>
<tr>
<td>ACCOUNTING</td>
<td>CLARK</td>
<td>MANAGER</td>
<td>06 JUN 81</td>
</tr>
<tr>
<td>KING</td>
<td>MILLER</td>
<td>PRESIDENT</td>
<td>17 NOV 81</td>
</tr>
<tr>
<td></td>
<td></td>
<td>CLERK</td>
<td>23 JAN 82</td>
</tr>
</tbody>
</table>

Concepts
Oracle Reports enables you to link to and display drawings and images that are "dynamic." That is, any changes made to the graphics will be reflected in your report output at runtime.

Data Relationships
- One way to display dynamic graphics in a report involves creating a database column that stores the names of the graphic files you want to display. You do this in the Data Model view.
- In the Data Model view, Oracle Reports provides a property called Read from File that enables you to pull the latest versions of the graphics into your report. When you set the Read from File property for a column listing file names, Oracle Reports displays the graphic contained within the named file, rather than the file name itself. Doing so enables Oracle Reports to pull into the report the latest version of the graphic at runtime.
- Another way to include dynamic graphics in your report is to use the File Link tool in the Paper Layout view. This tool enables you to create a boilerplate object used to contain an external file, such as graphics and text. This example does not show you how to use this method, but you can read more about this tool in the Oracle Reports online Help.

Layout
This report uses a simple Group Above layout.
### Example Scenario

In this example, you will create a simple report using the Group Above layout to display data about an employee, showing a different image depending on the location of the employee's department.

As you build this example report, you will:

- **Create the Data Model with Two Linked Queries** manually in the Data Model view.
- **Create the Layout of the Report**, first using the Reports Wizard, then making modifications in the Paper Layout view.
- **Run your Report to Paper**

To see a sample report containing dynamic graphics, open the examples folder called `dynamicgraphics`, then open the Oracle Reports example report named `dynamicgraphics.rdf`. For details on how to open it, see "Accessing the Example Reports" in the Preface.

### 24.1 Prerequisites for This Example

To build this example report, you will need access to the data source and the graphics we have provided. You will also need to install an extra table into the database, which contains the pictures for this report.

#### 24.1.1 Access to the data source and installing the Pictures table

To build the example in this chapter, you must have access to the SCOTT sample schema provided with the Oracle Database. If you don't know if you have access to this sample schema, contact your database administrator.

You will also need to ask your database administrator to install the Pictures table by using the provided file called `pictures.dmp`.

#### 24.1.2 Graphics for the report

Before you build this report, make sure the following images are in the `dynamicgraphics` directory where the sample report file is located:

- NEW_YORK.TIF
- BOSTON.TIF
- DALLAS.TIF
- CHICAGO.TIF

Although we have chosen to use TIF files in this example, you can use other graphic file formats, such as GIF, JPEG, and BMP.

Then, update your `REPORTS_PATH` in the Windows registry to include the directory where these images are located. The `REPORTS_PATH` is located under the Oracle Home entry in the Windows entry. When you edit the entry, add the full directory path of the location of your images.

On UNIX, you can set `REPORTS_PATH` in `$DOMAIN_HOME/reports/bin/reports.sh`.
24.2 Create the Data Model with Two Linked Queries

The steps in this section will show you how to build a simple data model with two queries in a master/detail relationship.

**To create a data model:**

1. After you have updated the REPORTS_PATH with the images directory path, launch Reports Builder.
3. Select Build a new report manually, then click OK.
4. In the Data Model view that displays, click the SQL Query tool in the tool palette then click in an open area of the Data Model view to display the SQL Query Statement dialog box.
5. In the SQL Query Statement field, enter the following SELECT statement:

   ```
   SELECT ALL DEPT.DEPTNO, DEPT.DNAME, PICTURES.PICTURE
   FROM DEPT, PICTURES
   WHERE (DEPT.DEPTNO = PICTURES.DEPTNO)
   ORDER BY DEPT.DEPTNO
   ```

   **Note:** You can enter this query in any of the following ways:
   - Copy and paste the code from the provided text file called `dynamicgraphics_code.txt` into the SQL Query Statement field.
   - Click Query Builder to build the query without entering any code manually.
   - Type the code in the SQL Query Statement field.

   Also notice that if you have not installed the Pictures table into the sample schema, you will not be able to create this query.

6. Click OK.

   **Note:** If you are not already connected to a database, you will be prompted to connect to the database when you click Query Builder or Next. Ensure that you connect to a database that has the appropriate schema for this example. Section 24.1, "Prerequisites for This Example" describes the sample schema requirements for this example.

7. When the query displays in the Data Model view, right-click the query name (Q_1), then choose Property Inspector from the pop-up menu to display the Property Inspector, and set the following properties:
   - Under General Information, set the Name property to Q_PICTURES.
8. In the Data Model view, double-click the picture column in the Q_PICTURES query to display the Property Inspector, and set the following properties:
   - Under Column, set the Read from File property to Yes, and set the File Format property to Image.
9. In the Data Model view, follow the steps above to create another query named `Q_EMPLOYEES` with the following code:

```sql
SELECT ALL EMP.DEPTNO, EMP.ENAME, EMP.JOB, EMP.HIREDATE
FROM EMP
ORDER BY DEPTNO, ENAME
```

**Note:** You can enter this query in any of the following ways:

- Copy and paste the code from the provided text file called `dynamicgraphics_code.txt` into the SQL Query Statement field.
- Click Query Builder to build the query without entering any code manually.
- Type the code in the SQL Query Statement field.

10. In the Data Model view, click the Data Link tool in the tool palette.

11. Drag a link between `DEPTNO` in `Q_PICTURES` and `DEPTNO1` in `Q_EMPLOYEES`. Your data model should now look like this:

![Figure 24-2 Data Model view for the dynamic graphics report](image)

12. Save your report as `dynamicgraphics_your_initials.rdf`.

### 24.3 Create the Layout of the Report

In this section, you will create a default layout for your report using the Report Wizard. You will then modify all the necessary layout objects for your graphics.

#### 24.3.1 Create the initial layout of your report using the Report Wizard

**To create the initial layout:**

1. In the Paper Layout view, choose Tools > Report Wizard to display the Report Wizard.
2. In the Report Wizard, on the Report Type page, select Create Paper Layout only.
3. On the Style page, select Group Above.
4. On the Groups page, click the following groups in the Available Groups list and click Down to specify the Print Direction and move them to the Displayed Groups list:
Create the Layout of the Report

- G_deptno
- G_DEPTNO1

5. On the Fields page:
   - Click the double right arrows (>>) to move all of the fields to the Displayed Fields list.
   - In the Displayed Fields list, click deptno, then click the left arrow (ﬂ) to move this field back to the Available Fields list.
   - Do the same for DEPTNO1.

6. On the Labels page, delete the label for the Picture field.

7. On the Template page, select No template, then click Finish to display your report layout in the Paper Layout view. It should look something like this:

![Initial Paper Layout view for the dynamic graphics report](image)

8. Save your report as dynamicgraphics_your_initials.rdf.

24.3.2 Modify the layout of your report

Now that you have created an initial layout for your report, you can rearrange your layout objects and add dynamic graphics.

To modify your layout:

1. In the Paper Layout view, select all the objects by pressing Ctrl+A on your keyboard.

2. Use the arrow keys on your keyboard to move all the objects 0.5 inches (1.5 centimeters) to the right.

3. In the Paper Layout view, expand the screen so that you can see down to 7 inches (18 centimeters) on the ruler.

4. In the Object Navigator, find your report name, then navigate to Paper Layout > Main Section > Body > M_G_DEPTNO_GRPFR.

5. Click R_G_DEPTNO. In the Paper Layout view, the R_G_DEPTNO repeating frame should also be selected.

6. While the R_G_DEPTNO repeating frame is selected, click the right part of the frame, and drag it to 6.5 inches (16.5 centimeters). The repeating frame should now expand from the 3.0 inch (7.5 centimeter) mark to the 6.5 inch (16.5 centimeter) mark on the top ruler.

7. Now, click the bottom part of the frame, and drag it to 2.0 inches (5 centimeters). You can see where you are by looking at the left-hand ruler. The repeating frame should now expand from the 0.5 inch (1.3 centimeter) mark to the 2.0 inch (5 centimeter) mark on the left-hand ruler.
8. Click the Flex Off button in the toolbar.

9. Move the Picture field to the right, and enlarge it to about 1.5 by 1.5 inches (4 by 4 centimeters).

10. In the Object Navigator, navigate to Paper Layout > Main Section > Body, then select the M_G_DEPTNO_GRPFR frame.

11. In the Paper Layout view, click the right edge of the frame and drag it to the right to include the Picture field.

12. Do the same for the R_G_DEPTNO repeating frame.

13. While R_G_DEPTNO is selected, choose Tools > Property Inspector to display the Property Inspector.


   **Note:** By setting the maximum records per page to 1, only one state will display per page in your report.

15. Save your report as dynamicgraphics_your_initials.rdf.

### 24.4 Run your Report to Paper

**To run your report:**

1. Click the Run Paper Layout button in the toolbar.

   Your report displays in the Paper Design view and should look something like this:

   ![Figure 24–5](image)

2. Click the Next Page button in the toolbar to see how the other pages of the report display different graphics depending on the location of the department.
24.5 Summary

Congratulations! You have successfully built a report that displays graphics depending on the data in the report. You now know how to:

- manually create and link two queries.
- use the Read from File property to make graphics dynamic.
- create a default layout in the Report Wizard.
- modify a paper layout to display desired information.

For more information on any of the wizards, views, or properties used in this example, refer to the Oracle Reports online Help, which is available in Oracle Reports Builder or hosted on the Oracle Technology Network (OTN), as described in Section 4.1.1, "Using the Oracle Reports online Help".
The chapters in this Part introduce matrix reports in Oracle Reports Developer and provide steps to build matrix reports. Matrix reports display information in a grid format and include variations, such as information displayed as nested grids or grids displayed for each group in the report.

- **Chapter 25, “Building a Matrix Report”**
A matrix report looks like a grid that contains a row of labels, a column of labels, and information in a grid format related to both the row and column labels. These reports are sometimes referred to as “crosstab” reports.

- **Chapter 26, “Building a Nested Matrix Report”**
A nested matrix report contains the cross product, that displays every possible value for three dimensions - two down (such as YEAR and DEPTNO) and one across (such as JOB).

- **Chapter 27, “Building a Matrix with Group Above Report”**
A matrix with group above report is a combination of a matrix layout and a group above layout. For each group in this report, the break group (for example, the department number) displays across the top of the record, and the details of the group (for example, the employee information) displays in a matrix format.
Building a Matrix Report

In this chapter, you will learn about matrix reports. By following the steps in this chapter, you can generate the report output shown in Figure 25–1.

Figure 25–1 Matrix report output

<table>
<thead>
<tr>
<th></th>
<th>ANALYST</th>
<th>CLERK</th>
<th>MANAGER</th>
<th>PRESIDENT</th>
<th>SALESMAN</th>
</tr>
</thead>
<tbody>
<tr>
<td>10</td>
<td>$0.00</td>
<td>$1500.00</td>
<td>$2450.00</td>
<td>$8000.00</td>
<td>$0.00</td>
</tr>
<tr>
<td>20</td>
<td>$300.00</td>
<td>$1800.00</td>
<td>$2975.00</td>
<td>$0.00</td>
<td>$2.00</td>
</tr>
<tr>
<td>30</td>
<td>$10.00</td>
<td>$950.00</td>
<td>$2650.00</td>
<td>$0.00</td>
<td>$500.00</td>
</tr>
<tr>
<td></td>
<td>$16000.00</td>
<td>$44500.00</td>
<td>$6075.00</td>
<td>$50000.00</td>
<td>$56000.00</td>
</tr>
</tbody>
</table>

Concepts

- A matrix report looks like a grid. As shown by the example report above, it contains one row of labels, one column of labels, and information in a grid format that is related to both the row and column labels.

- This sample matrix also contains three additions to the basic matrix: summaries have been added, zeroes replace non-existent values in the cells, and the cells themselves are surrounded by grid lines. Of the summaries, one sums the salaries by department, one sums them by job, and one sums them by job, and one sums them for the whole report.

- Certain requirements exist for building matrix reports:
  - You must have at least four groups in your data model.
  - One group must be a cross product group.
  - At least two of the groups must be within the cross product group. These groups furnish the "labels" of the matrix report.
  - At least one group must be a "cell" group; that is, it must provide the information related to the labels. The values from this group fill the cells created by the matrix.

- These requirements can be seen in the preceding example. It contains four groups—four groups supplies the vertical labels (department numbers) and one group supplies the horizontal labels (job identifiers). These two groups are the children of the third group, called the cross product group, which creates the grid. The fourth group provides the values that fill in the grid.

- Matrix reports are different from tabular reports because the number of columns is not known in advance; that is, the number of columns in your report is not determined by the number of columns you specify in your SELECT statement plus...
the columns you create yourself. The number of columns in your report depends on the number of values contained in the columns providing the horizontal and vertical labels. Thus, the report would automatically be extended if a new job function, called RECEPTIONIST, was added to the underlying data tables.

- The queries used to select data for these sample matrix reports are not intended as definitive examples of matrix queries. If you are concerned with performance issues, for example, there are alternate methods of querying data that can improve the performance of a matrix report.

- You can create matrix reports with any number of queries. Section 25.2, "Create a Single-Query Matrix" explains how to create the matrix report using one query. Section 25.3, "Create a Multiple-Query Matrix" explains how to create the same report using three queries. These two methods yield the same results. They are presented as options; feel free to try both methods and settle on a favorite.

- This report uses the matrix layout style. You’ll modify some default settings to ensure that the column and row labels display correctly. You’ll also modify some field widths to ensure that the fields fit across the page.

- For additional conceptual information, see Section 1.3.7, "About matrix reports",

Example Scenario
In this example, you will create report that cross tabulates salaries by job function and department. The result would be a matrix with job functions listed across the top, departments down the side, and sums of salaries in the cells. Thus, you could quickly determine the sum of all of the salaries for clerks in department 20 and compare that value to the one for all clerks in some other department.

As you build this example report, you will:

- Create a Single-Query Matrix
- Create a Multiple-Query Matrix
- Add Summaries to the Single-Query Matrix for rows and columns.
- Format Monetary Values
- Add Zeroes in Place of Blanks
- Add a Grid to add grid lines around cells.

To see a sample matrix report, open the examples folder named matrix, then open the Oracle Reports example named matrix1qb.rdf for a single-query matrix report, or matrix3qb.rdf for a multi-query matrix report. For details on how to access these reports, see "Accessing the Example Reports" in the Preface.

25.1 Prerequisites for This Example
To build the example in this chapter, you must have access to the SCOTT sample schema provided with the Oracle Database. If you do not know if you have access to this sample schema, contact your database administrator.

25.2 Create a Single-Query Matrix
You can build a matrix report with a single query in the data model. A single-query data model typically performs better than a multiple-query data model.

When you are creating a single-query report, such as this one, you can use the Report Wizard to create the data model and layout simultaneously.
To create a data model and layout:
1. Launch Reports Builder (or, if already open, choose File > New > Report).
2. In the Welcome or New Report dialog box, select Use the Report Wizard, then click OK.
3. If the Welcome page displays, click Next.
4. On the Report Type page, select Create Paper Layout Only, then click Next.
5. On the Style page, type a Title for your report, select Matrix, then click Next.
6. On the Data Source page, click SQL Query, then click Next.
7. On the Data page, enter the following SELECT statement in the Data Source definition field:
   ```sql
   SELECT DEPTNO, JOB, SUM(SAL)
   FROM EMP
   GROUP BY DEPTNO, JOB
   ORDER BY DEPTNO, JOB
   ```
   
8. Click Next.

9. On the Rows page, click DEPTNO and click the right arrow (>) to move this field to the Matrix Row Fields list, then click Next.
10. On the Columns page, click JOB and click the right arrow (>) to move this field to the Matrix Column Fields list, then click Next.
11. On the Cell page, click SUM_SAL and click the right arrow (>) to move this field to the Matrix Cell Fields list, then click Next.

   Note: In this case, the query itself performs the summary through the SUM function. Hence, you should not use the Sum button in this instance.

12. On the Totals page, click Next.
13. On the Labels page, delete the labels for all of the fields, then click Next.
Create a Multiple-Query Matrix

14. On the Template page, make sure Beige is selected under Predefined Template, then click Finish to display your report output in the Paper Design view. It should look like this:

![Figure 25–2 Paper Design view for the matrix report](image)

25.3 Create a Multiple-Query Matrix

You can build a matrix report with multiple queries in the data model. A multiple-query data model is typically easier to conceptualize and code than a single-query, but the single-query data model typically performs better.

25.3.1 Create a new report manually

In this case, it is easier to create the data model and layout separately. Hence, we will create an empty report first, then add the queries, and then create the layouts.

To create a blank report:
2. Select Build a new report manually, then click OK.

25.3.2 Create a data model with a cross product and a data link

When you create a report with multiple queries, it is typically easier to create all of the queries with the Data Wizard first and then create the layouts with the Report Wizard.

To create the queries:
1. In the Data Model view, choose Insert > Query to display the Data Wizard.
2. If the Welcome page displays, click Next.
3. On the Query page, type Q_Dept for the Query name, then click Next.
4. On the Data Source page, click SQL Query, then click Next.
5. On the Data page, enter the following SELECT statement:

   ```sql
   SELECT DISTINCT DEPTNO
   FROM EMP
   ```

   **Tip:** If you click Query Builder, you can build the query without entering any code manually.
6. Click Next.
7. On the Groups page, click Next.

8. Click Finish to display your first query in the Data Model view.

9. Repeat the steps above for a second query, but this time name your query Q_Job and use the following SELECT statement:

   ```sql
   SELECT DISTINCT JOB
   FROM EMP
   ```

10. Again, repeat the steps above for a third query, but this time name your query Q_Matrix and use the following SELECT statement:

    ```sql
    SELECT DEPTNO, JOB, SUM(SAL)
    FROM EMP
    GROUP BY DEPTNO, JOB
    ORDER BY DEPTNO, JOB
    ```

    **Figure 25–3  Three query data model, queries unrelated**

To create the cross product group:
1. In the Data Model view, click the Cross Product tool in the tool palette.
2. Drag a box around G_DEPTNO and G_JOB. When you release the mouse button, the cross product group is created. Ensure that it completely surrounds both groups.

   **Figure 25–4  Three query data model with cross product group**

To add the data link:
1. In the Data Model view, click the Data Link tool in the tool palette.
2. Click and drag from the DEPTNO column in the G_DEPTNO group to the DEPTNO1 column in the G_DEPTNO1 group.

3. Repeat steps 1 and 2, but this time drag the link between the JOB column in G_JOB and JOB1 in G_DEPTNO1.

Figure 25–5  Three query data model with cross product group and data links

25.3.3 Create the layout with the Report Wizard

Once your data model is complete, you need to create a layout for the data objects to display in the report output.

To create the layout:
1. In the Data Model view, right-click on the canvas, then choose Report Wizard.
2. In the Report Wizard, on the Report Type page, select Create Paper Layout only.
3. On the Style page, select Matrix.
4. On the Groups page, ensure that all of the groups from your data model appear in the Displayed Groups list. G_1 should be Matrix, G_DEPTNO should be Down, G_JOB should be Across, and G_DEPTNO1 should be Down.

Figure 25–6  Groups page of the Report Wizard

5. On the Fields page, ensure that only the following columns appear in the Displayed Fields list:
   - DEPTNO
Add Summaries to the Single-Query Matrix

- JOB
- SUM_SAL

**Figure 25–7 Fields page of the Report Wizard**

6. On the **Labels** page, delete the labels for all of the fields.

7. On the **Template** page, make sure **Beige** is selected under **Predefined Template**, then click Finish to display your report output in the Paper Design view. It should look like this:

**Figure 25–8 Paper Design view for the matrix report**

25.4 Add Summaries to the Single-Query Matrix

To make your matrix report more useful, you should add summaries of each row and column in the matrix, and the whole report. In the single-query case, you can add these summaries very easily with the Report Wizard. In the multiquery case, you would need to add the summaries manually and then use the Report Wizard to create fields for them.

The steps below describe the procedure for adding summaries to the single-query matrix.

**To add summaries to a single-query matrix:**

2. On the Report Type page, select Create Paper Layout only.
3. On the Totals page, click SUM_SAL in the Available Fields list, then click Sum.

   **Tip:** You may have to use the arrows to make the Totals tab visible.

4. Click Finish to preview your report output in the Paper Design view.

   **Note:** When your new layout is created, you should notice a couple of things. First, at the bottom of each column of the matrix, you should now see a summary of that column’s values. The report is also probably more than one page long now. Because of the width of the layout, the summaries for the departments cannot fit on the page with the rest of the matrix. Hence, the department summaries and the report summary overflow to the next page. Go to the second page of the report and you will see the department summaries and the report summary.

25.5 Format Monetary Values

To make your report easier to read, you can add formatting to the monetary values.

**To format monetary values:**

1. On the first page of the report, click one of the cell values. Notice that all of the values are immediately selected, indicating that you can change their properties simultaneously.
2. Shift-click one of the summary values at the bottom of a column of the matrix.
3. Click the Currency button in the toolbar. A currency symbol immediately appears next to all of the values.
4. Click the Add Decimal Place button in the toolbar twice. Two decimal places are added to the right of the decimal point.
5. Resize the fields. Click and drag the right most handle of the cell value under the SALESMAN label about 0.5 inches (1.5 centimeters) to the left. After you complete this operation, the department summaries from the second page should move onto the first page.
6. Shift-click the SALESMAN label.
7. Click the Align Right button in the toolbar.
8. Click in an open area of the Paper Design view to deselect all of the objects.
9. Click one of the department summaries at the end of a row in the matrix. All of the department summaries are immediately selected.
10. Shift-click the report summary underneath the department summaries.
11. Use the left arrow key to move these summaries to the left until they are approximately flush with the SALESMAN column in the matrix.
12. Click the Currency button in the toolbar. A currency symbol immediately appears next to all of the values.

13. Click the Add Decimal Place button in the toolbar twice. Two decimal places are added to the right of the decimal point.

14. Resize the fields. Click and drag the right most handle of one of the selected fields about 0.5 inches (1.5 centimeters) to the left.

15. Click the Align Right button in the toolbar.

**Figure 25–9 Matrix report in Paper Design view with monetary values formatted**

![Matrix report in Paper Design view with monetary values formatted](image)

### 25.6 Add Zeroes in Place of Blanks

A matrix report displays a juxtaposition of data – in other words, the values held in common by two different categories of data. These categories are indicated by the row and column labels.

The matrix displays this juxtaposition of values using a grid-like format. If the two categories have nothing in common, the grid at that point is empty. The matrix appears to be full of “holes”. You can fill the holes using boilerplate text.

---

**Note:** Do not confuse empty spaces in the grid with null values. A null value is an actual value fetched from the database. The spaces in a matrix report are empty because nothing has been fetched to fill them.

---

**To replace blanks with zeroes:**

1. Open the matrix report to which you previously added the summaries.

2. In the Object Navigator, double-click the view icon next to the **Paper Layout** node to display the Paper Layout view.

   **Tip:** The steps that follow require some precision in the placement of objects. Hence, you may want to magnify the view to make the process easier. Click the Magnify tool and then click somewhere in the Paper Layout view. Repeat as many times as necessary.

3. In the Paper Layout view, click the Confine On and Flex On buttons in the toolbar to turn both modes on.

4. From the font lists in the toolbar, choose **Arial** (Western), point size **10**.

5. Click the Align Right button in the toolbar.

6. Click the Text tool in the tool palette.

7. Click the top of the **F_SUM_SAL** field about 0.75 inches (2 centimeters) from its right edge. Your objective is to create an object right on top of **F_SUM_SAL**.
8. Type the following:

$0.00

9. Click in an open area of the layout to deselect all objects.

10. In the Object Navigator, type B_1 in the Find field. You will be taken to the object you just created. If you are viewing the Object Navigator in Ownership View (View > Change View > Ownership View), you should see B_1 underneath R_G_SUM_SAL and on the same level as F_SUM_SAL.

   Tip: If B_1 does not appear underneath R_G_SUM_SAL, return to the Paper Layout view, delete B_1 and try again.

   **Figure 25–10** Object Navigator with new object selected

11. Click R_G_SUM_SAL and then ctrl-click F_SUM_SAL so that they are both selected and B_1 is deselected.
12. Click the title bar of the Report Editor to make it the active window.

13. Click the Confine Off button in the toolbar to turn Confine mode off.


**Tip:** After this operation, B_1 should appear just above R_G_SUM_SAL, as a peer rather than a child of R_G_SUM_SAL. If B_1 is still appearing as a child under R_G_SUM_SAL, repeat steps 11 through 14 until it is no longer appearing as a child of R_G_SUM_SAL.

15. In the Paper Layout view, click the Confine On button in the toolbar to turn Confine mode back on again.

16. Click the Paper Design button in the toolbar to display the Paper Design view.

**Tip:** If the $0.00 is not quite aligning with the other monetary values around it, select it and use the arrow keys to move it to the desired location.

Figure 25–12  Matrix report output with zeroes replacing blanks
25.7 Add a Grid

Sometimes matrix reports are easier to read when they have grid lines that divide the cells from each other. For most objects, No Line is the default setting. To add grid lines, all you need to do is select the appropriate objects and give them a line color.

To add grid lines
1. Open the matrix report which you previously modified to show zeroes instead of blanks.
2. In the Object Navigator, double-click the view icon next to the Paper Layout node to display the Paper Layout view.
3. In the Object Navigator, choose View > Change Views > Object Type View.
4. Select all of the following objects in the Object Navigator under the Paper Layout node using Ctrl-click:
   - F_SUMSUM_SALPERDEPTNO
   - F_SUMSUM_SALPERJOB
   - F_SUMSUM_SALPERREPORT
   - F_SUM_SAL
   - B_1
5. Click the title bar of Paper Layout view to make it the active window.
6. In the Paper Layout view, click the Line Color tool in the tool palette, and click a block that shows the color black.
7. Click the Paper Design button in the toolbar to display the Paper Design view. You should now see a grid around all of the cells in your matrix.

Figure 25–13 Matrix report output with a grid

8. Save your report as matrix1qb_your_initials.rdf

25.8 Summary

Congratulations! You have successfully created a matrix report. You now know how to:
- create a matrix report with a single-query data model.
- create a matrix report with a multiple-query data model.
- add summaries and format monetary values.
- substitute zeroes for blanks in a matrix layout.
- add a grid.
For more information on any of the wizards, views, or properties used in this example, refer to the Oracle Reports online Help, which is available in Oracle Reports Builder or hosted on the Oracle Technology Network (OTN), as described in Section 4.1.1, "Using the Oracle Reports online Help".
In this chapter, you will learn about nested matrix reports. By following the steps in this chapter, you can generate the report output shown in Figure 26–1.

Figure 26–1  Nested matrix report output

Concepts
- A nested matrix report is a matrix report which contains more than the usual two dimensions (across and down) of a simple matrix.
- You can create nested matrix reports with any number of queries. In Section 26.2, "Create a Single-Query Matrix", you'll create the example nested matrix report using one query. In Section 26.3, "Create a Multiple-Query Matrix", you'll use multiple queries. In Section 26.4, "Create a Multiple-Query Matrix with a Break", you will use not only group hierarchy to nest one dimension within another, but you'll also create a true parent/child relationship between the relevant groups by explicitly creating a new group and placing it within the cross product and above the other group. This will restrict the records displayed to only those for which data exists.
Notes:

- In a nested matrix report, where you create a matrix query that has a child matrix query, the fields on which you join should be separated into a separate group in your master matrix. Otherwise, on some platforms, only the first group prints.

- The queries used to select data for those sample matrix reports are not intended as definitive examples of matrix queries. If you are concerned with performance issues, for example, there are alternate methods of querying data that can improve the performance of a matrix report. Refer to the *Oracle Reports online Help* for details.

This example report uses a matrix with three dimensions, created by including three columns in the cross product. The cross product is capable of displaying every possible value for three dimensions: two down (YEAR and DEPTNO) and one across (JOB). This method does not include rows that have null values because there is a break group within the cross product group in the data model. As mentioned above, this chapter describes how to create a nested matrix with and without a break group inside of the cross product group so that you can see the difference in the output.

- The order in which the two down dimensions (YEAR and DEPTNO) will be displayed is based upon the order in which you position their corresponding groups within the cross product; that is, of YEAR and DEPTNO, you’ll position YEAR to the left of DEPTNO. This “nests” DEPTNO inside of YEAR and causes all records for DEPTNO to appear for each value of YEAR, regardless of whether that department has any data for that year.

- For additional conceptual information, see Section 2.1.7, "About nested matrix reports".

Example Scenario

In this example, you will create a report that cross tabulates salaries by year and department, and by job function. The result is a matrix with job functions listed across the top, years and departments down the side, and sums of salaries in the cells. Thus, you can quickly determine the sum of all of the salaries for clerks in department 20 and compare that value to the one for all clerks in some other department.

As you build this example report, you will:

- **Create a Single-Query Matrix.**
- **Create a Multiple-Query Matrix.**
- **Create a Multiple-Query Matrix with a Break** within the cross product group.
- **Format Monetary Values.**

To see a sample nested matrix report, open the examples folder named `nestedmatrix`, then open any of the Oracle Reports examples named `nested1.rdf`, `nested2.rdf`, or `nested3.rdf`. For details on how to access them, see "Accessing the Example Reports" in the Preface.
26.1 Prerequisites for This Example

To build the example in this chapter, you must have access to the SCOTT sample schema provided with the Oracle Database. If you do not know if you have access to this sample schema, contact your database administrator.

26.2 Create a Single-Query Matrix

You can build a matrix report with a single-query in the data model. A single-query data model typically performs better than a multiple-query data model.

When you are creating a single-query report, such as this one, you can use the Report Wizard to create the data model and layout simultaneously.

To create a data model and layout:
1. Launch Reports Builder (or, if already open, choose File > New > Report).
2. In the Welcome or New Report dialog box, select Use the Report Wizard, then click OK.
3. If the Welcome page displays, click Next.
4. On the Report Type page, select Create Paper Layout Only, then click Next.
5. On the Style page, type a Title for your report, select Matrix, then click Next.
6. On the Data Source page, click SQL Query, then click Next.
7. On the Data page, enter the following SELECT statement in the Data Source definition field:

   ```sql
   SELECT TO_CHAR (HIREDATE, 'YY') YEAR, DEPTNO, JOB,
   SUM (SAL) FROM EMP
   GROUP BY TO_CHAR(HIREDATE, 'YY'), DEPTNO, JOB
   ORDER BY TO_CHAR(HIREDATE, 'YY'), DEPTNO, JOB
   ```

   **Note:** You can enter this query in any of the following ways:
   - Copy and paste the code from the provided text file called nested1_code.txt into the Data Source definition field.
   - Click Query Builder to build the query without entering any code manually.
   - Type the code in the Data Source definition field.

   **Note:** If you are not already connected to a database, you will be prompted to connect to the database when you click Query Builder or Next. Ensure that you connect to a database that has the appropriate schema for this example. Section 26.1, "Prerequisites for This Example" describes the sample schema requirements for this example.

8. On the Rows page:
   - Click YEAR in the Available Fields list and click the right arrow (>) to move this field to the Matrix Row Fields list. YEAR should appear under Level 1.
Create a Single-Query Matrix

Figure 26–2  First matrix row in the Report Wizard

- Click **Level 1** in the **Matrix Row Fields** list. This step ensures that the next column added will be at Level 2 rather than Level 1.
- Click **DEPTNO** in the **Available Fields** list and click the right arrow (>) to move this field to the **Matrix Row Fields** list. Notice that it is added under Level 2 rather than Level 1.

Figure 26–3  Second matrix row in Report Wizard

- Click **Next**.

9. On the Columns page, click **JOB** and click the right arrow (>) to move this field to the **Matrix Column Fields** list. **JOB** should appear under **Level 1**, then click **Next**.

10. On the Cell page, click **SUM_SAL** and click the right arrow (>) to move this field to the **Matrix Cell Fields** list, then click **Next**.

11. On the Totals page, click **Next**.

12. On the Labels page, change the labels and field widths as follows, then click **Next**:
26.3 Create a Multiple-Query Matrix

You can build a matrix report with multiple queries in the data model. A multiple-query data model is typically easier to conceptualize and code than a single-query, but the single-query data model typically performs better.

26.3.1 Create a new report manually

In this case, it is easier to create the data model and layout separately. Hence, we will create an empty report first, then add the queries, and then create the layouts.

To create a blank report:
2. Select Build a new report manually, then click OK.

26.3.2 Create a data model with a cross product and data links

When you create a matrix report with multiple queries, it is typically easier to create all of the queries with the Data Wizard first and then create the cross product group and the necessary links in the Data Model view.
To create the queries:

1. In the Data Model view, choose Insert > Query to display the Data Wizard.
2. If the Welcome page displays, click Next.
3. On the Query page, type Q_Year for the Query name, then click Next.
4. On the Data Source page, select SQL Query, then click Next.
5. On the Data page, enter the following SELECT statement in the Data Source definition field:
   ```sql
   SELECT DISTINCT TO_CHAR (HIREDATE, 'YY') YEAR
   FROM EMP
   ```

   **Note:** You can enter this query in any of the following ways:
   - Copy and paste the code from the provided text file called nested3_code.txt into the Data Source definition field.
   - Click Query Builder to build the query without entering any code manually.
   - Type the code in the Data Source definition field.

6. Click Next.

7. On the Groups page, click Next.
8. Click Finish to display the data model for your report in the Data Model view.
9. Repeat the steps above for a second query, but this time name your query Q_Dept and use the following SELECT statement:
   ```sql
   SELECT DISTINCT DEPTNO
   FROM EMP
   ```

   **Note:** You can enter these queries in any of the following ways:
   - Copy and paste the code from the provided text file called nested3_code.txt into the Data Source definition field.
   - Click Query Builder to build the query without entering any code manually.
   - Type the code in the Data Source definition field.

10. Again, repeat the steps above for a third query, but this time name your query Q_Job and use the following SELECT statement:
SELECT DISTINCT JOB
FROM EMP

11. Again, repeat the steps above for a fourth query, but this time name your query Q_Salary and use the following SELECT statement:

```
SELECT TO_CHAR(HIREDATE, 'YY') YEAR, DEPTNO, JOB,
      SUM(SAL) FROM EMP
GROUP BY TO_CHAR(HIREDATE, 'YY'), DEPTNO, JOB
ORDER BY TO_CHAR(HIREDATE, 'YY'), DEPTNO, JOB
```

Figure 26–5  Data model with four queries

Tip: The order of the queries is significant in this case. Q_Dept must appear to the right of or below Q_Year in order for the values of DEPTNO to be nested inside of the values of YEAR in the output.

To create the cross product group:

1. In the Data Model view, click the Cross Product tool in the tool palette.
2. Drag a box around G_YEAR, G_DEPTNO, and G_JOB. When you release the mouse button, the cross product group is created. Ensure that it completely surrounds all three groups.
Figure 26–6  Data Model with four queries and a cross product group

To add the data links:
1. In the Data Model view, click the Data Link tool in the tool palette.
2. Click and drag from the YEAR column in the G_YEAR group to the YEAR1 column in the G_YEAR1 group.
3. Repeat steps 1 and 2, but this time drag the link between the DEPTNO column in G_DEPTNO and DEPTNO1 in G_YEAR1.
4. Again, repeat steps 1 and 2, but this time drag the link between the JOB column in G_JOB and JOB1 in G_YEAR1.

Figure 26–7  Nested matrix data model

5. Optionally, move the data model objects around to appear like the above figure.

26.3.3 Create the layout with the Report Wizard

Once your data model is complete, you need to create a layout for the data objects to display in the report output.

To create the layout:
1. In the Data Model view, right-click on the canvas, then choose Report Wizard.
2. In the Report Wizard, on the Report Type page, select Create Paper Layout only.
3. On the **Style** page, select **Matrix**.

4. On the **Groups** page, ensure that all of the groups from your data model appear in the **Displayed Groups** list. **G_1** should be **Matrix**, **G_YEAR** and **G_DEPTNO** should be **Down**, **G_JOB** should be **Across**, and **G_YEAR1** should be **Down**.

**Figure 26–8  Groups page of the Report Wizard**

5. On the **Fields** page, ensure that only the following columns appear in the **Displayed Fields** list:
   - YEAR
   - DEPTNO
   - JOB
   - SUM_SAL

**Figure 26–9  Fields page of the Report Wizard**

6. On the **Labels** page, change the labels and field widths as follows:
26.4 Create a Multiple-Query Matrix with a Break

If you compare the single-query nested matrix output in Figure 26–4, "Paper Design view for the nested matrix report" to the multiple-query output in Figure 26–10, "Paper Design view for the nested matrix output", you notice that the multiple-query case displays all of the departments for every year while the single-query case does not. In the single-query case, only those departments that actually have values in their matrix cells are displayed in the output. To achieve a similar result with multiple queries, you need to have a parent/child relationship between the groups containing YEAR and DEPTNO.

26.4.1 Create a new report manually

In this case, it is easier to create the data model and layout separately. Hence, we will create an empty report first, then add the queries, and then create the layouts.

To create a blank report:
2. Select Build a new report manually, then click OK.

26.4.2 Create a data model with a cross product and data links

When you create a matrix report with multiple queries, it is typically easier to create all of the queries with the Data Wizard first and then create the cross product group and the necessary links in the Data Model view.
To create the queries:
1. In the Data Model view, choose Insert > Query to display the Data Wizard.
2. If the Welcome page displays, click Next.
3. On the Query page, type Q_Dept for the Query name, then click Next.
4. On the Data Source page, select SQL Query, then click Next.
5. On the Data page, enter the following SELECT statement in the Data Source definition field:

   ```sql
   SELECT TO_CHAR(HIREDATE, 'YY') YEAR, DEPTNO
   FROM EMP
   GROUP BY TO_CHAR(HIREDATE, 'YY'), DEPTNO
   ORDER BY TO_CHAR(HIREDATE, 'YY'), DEPTNO
   ```

   Note: You can enter this query in any of the following ways:
   - Copy and paste the code from the provided text file called nested2_code.txt into the Data Source definition field.
   - Click Query Builder to build the query without entering any code manually.
   - Type the code in the Data Source definition field.

6. Click Next.

   Note: If you are not already connected to a database, you will be prompted to connect to the database when you click Query Builder or Next. Ensure that you connect to a database that has the appropriate schema for this example. Section 26.1, "Prerequisites for This Example" describes the sample schema requirements for this example.

7. On the Groups page, click YEAR in the Available Fields list and click the right arrow (>) to move this field to the Group Fields list, then click Next.
8. On the Totals page, click Next.
9. Click Finish to display the data model for your report output in the Data Model view.
10. Choose Insert > Query and follow the steps above to create another query named Q_Job and use the following SELECT statement:

    ```sql
    SELECT DISTINCT JOB
    FROM EMP
    ```

11. Again, choose Insert > Query and follow the steps above to create a third query named Q_Salary and use the following SELECT statement:

    ```sql
    SELECT TO_CHAR(HIREDATE, 'YY') YEAR, DEPTNO, JOB,
    SUM(SAL) FROM EMP
    GROUP BY TO_CHAR(HIREDATE, 'YY'), DEPTNO, JOB
    ORDER BY TO_CHAR(HIREDATE, 'YY'), DEPTNO, JOB
    ```
To create the cross product group:
1. In the Data Model view, click the Cross Product tool in the tool palette.
2. Drag a box around G_YEAR, G_DEPTNO, and G_JOB. When you release the mouse button, the cross product group is created. Ensure that it completely surrounds all three groups.

To add the data links:
1. In the Data Model view, click the Data Link tool in the tool palette.
2. Click and drag from the YEAR column in the G_YEAR group to the YEAR1 column in the G_YEAR1 group.
3. Repeat steps 1 and 2, but this time drag the link between the DEPTNO column in G_DEPTNO and DEPTNO1 in G_YEAR1.
4. Again, repeat steps 1 and 2, but this time drag the link between the JOB column in G_JOB and JOB1 in G_YEAR1.
5. Optionally, move the data model objects around to appear like the above figure.

### 26.4.3 Create the layout with the Report Wizard

Once your data model is complete, you need to create a layout for the data objects to display in the report output.

**To create the layout:**

1. In the Data Model view, right-click on the canvas, then choose **Report Wizard**.
2. In the Report Wizard, on the **Report Type** page, select **Create Paper Layout only**.
3. On the **Style** page, select **Matrix**.
4. On the **Groups** page, ensure that all of the groups from your data model appear in the **Displayed Groups** list. **G_1** should be **Matrix**, **G_YEAR** and **G_DEPTNO** should be **Down**, **G_JOB** should be **Across**, and **G_YEAR1** should be **Down**.

**Figure 26–14  Groups page of the Report Wizard**

5. On the **Fields** page, ensure that only the following columns appear in the **Displayed Fields** list:
- YEAR
- DEPTNO
- JOB
- SUM_SAL

**Figure 26–15 Fields page of the Report Wizard**

6. On the **Labels** page, change the labels and field widths as follows:

<table>
<thead>
<tr>
<th>Fields</th>
<th>Labels</th>
<th>Width</th>
</tr>
</thead>
<tbody>
<tr>
<td>SUM_SAL</td>
<td>&lt;none&gt;</td>
<td>10</td>
</tr>
<tr>
<td>YEAR</td>
<td>&lt;none&gt;</td>
<td>4</td>
</tr>
<tr>
<td>JOB</td>
<td>&lt;none&gt;</td>
<td>10</td>
</tr>
</tbody>
</table>

7. On the **Template** page, make sure **Beige** is selected under **Predefined Template**, then click **Finish** to display your report output in the **Paper Design view**. It should look like this:

**Figure 26–16 Paper Design view for the final nested matrix report output**
26.5 Format Monetary Values

To make your matrix report more readable, you should format the monetary values.

To format monetary values:
1. On the first page of the report, click one of the cell values. Notice that all of the values are immediately selected, indicating that you can change their properties simultaneously.
2. Click the Currency button in the toolbar. A currency symbol immediately appears next to all of the values.
3. Click the Add Decimal Place button in the toolbar twice. Two decimal places are added to the right of the decimal point.
4. Resize the fields. Click and drag the right most handle of the cell value under the SALESMAN label about 0.5 inches (1.5 centimeters) to the left. After you complete this operation, the department summaries from the second page should move onto the first page.
5. Shift-click the SALESMAN label.
6. Click the Align Right button in the toolbar.
7. Click in an open area of the Paper Design view to deselect all of the objects.

Figure 26–17  Nested matrix report output with formatted monetary values

8. Save your report as nested3_your_initials.rdf

26.6 Summary

Congratulations! You have successfully created three nested matrix reports. You now know how to:

■ create a nested matrix report with a single-query data model.
■ create a nested matrix report with a multiple-query data model.
■ create a nested matrix report with multiple queries and a break within the cross product group.
■ format monetary values.

For more information on any of the wizards, views, or properties used in this example, refer to the Oracle Reports online Help, which is available in Oracle Reports Builder or hosted on the Oracle Technology Network (OTN), as described in Section 4.1.1, "Using the Oracle Reports online Help".
In this chapter, you will learn about nested matrix with group above reports. By following the steps in this chapter, you can generate the report output shown in Figure 27–1.

Figure 27–1   Matrix with group above report output

<table>
<thead>
<tr>
<th>Year 80</th>
<th>Job</th>
<th>Dept. TOT.</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Job</td>
<td>DEPT. TOT.</td>
</tr>
<tr>
<td>Deptno</td>
<td></td>
<td></td>
</tr>
<tr>
<td>20</td>
<td>800</td>
<td>800</td>
</tr>
</tbody>
</table>

Job Tot.: 800  800

<table>
<thead>
<tr>
<th>Year 81</th>
<th>Job</th>
<th>Dept. TOT.</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Job</td>
<td>DEPT. TOT.</td>
</tr>
<tr>
<td>Deptno</td>
<td></td>
<td></td>
</tr>
<tr>
<td>10</td>
<td>2450</td>
<td>5960</td>
</tr>
<tr>
<td>20</td>
<td>2975</td>
<td>5975</td>
</tr>
<tr>
<td>30</td>
<td>2850</td>
<td>5600</td>
</tr>
</tbody>
</table>

Job Tot.: 3000  950  8375  5960  5600  22825

Concepts

- A matrix with group above report is a combination of a matrix and a group above report layout. Essentially, a matrix report is printed for each master group record. A matrix with group is similar to the multiquery nested matrix, except that in a matrix with group report, the parent exists above the cross product. In a multiquery nested matrix report with groups, the parent/child relationship exists within the across or down dimension of the cross product.

- For additional conceptual information, see Section 2.1.8, "About matrix with group reports".

Data Relationships

This example of a matrix with group above report uses one query and at least five groups. At least one group is placed above the cross product to serve as the Master group.

Layout

This report uses the Matrix with Group layout style.
Example Scenario
In this example, you will create a report that cross tabulates salaries by department and by job for each year. The result is a group report where year is the master and the detail is a matrix with job functions listed across the top, departments down the side, and sums of salaries in the cells. Thus, you can quickly determine the sum of all of the salaries for clerks in department 20 for any particular year.

As you build this example report, you will:

- Create a Matrix Group Data Model and Layout for a single query.
- Add Labels and Lines for Summaries.
- Add Space Between Groups.
- Create a Web Layout without changing the paper layout.

To see a sample matrix with group above report, open the examples folder named matrixgroup, then open the Oracle Reports example named matrixgroup.rdf. For details on how to access it, see "Accessing the Example Reports" in the Preface.

27.1 Prerequisites for This Example

To build the example in this chapter, you must have access to the SCOTT sample schema provided with the Oracle Database. If you do not know if you have access to this sample schema, contact your database administrator.

27.2 Create a Matrix Group Data Model and Layout

Since this report is a single-query report, it is easiest to build it with the Report Wizard.

To create the data model and layout with the Report Wizard:

1. Launch Reports Builder (or, if already open, choose File > New > Report).
2. In the Welcome or New Report dialog box, select Use the Report Wizard, then click OK.
3. If the Welcome page displays, click Next.
4. On the Report Type page, select Create Paper Layout Only, then click Next.
5. On the Style page, type a Title for your report, select Matrix with Group, then click Next.
6. On the Data Source page, click SQL Query, then click Next.
7. On the Data page, enter the following SELECT statement in the Data Source definition field:

   ```sql
   SELECT TO_CHAR(HIREDATE, 'YY') YEAR, DEPTNO, JOB, SUM(SAL)
   FROM EMP
   GROUP BY TO_CHAR(HIREDATE, 'YY'), DEPTNO, JOB
   ```
8. Click Next.

9. On the Groups page, click YEAR in the Available Fields list and click the right arrow (>) to move this field to the Matrix Group Fields list, then click Next.

10. On the Rows page, click DEPTNO in the Available Fields list and click the right arrow (>) to move this field to the Matrix Row Fields list, then click Next.

11. On the Columns page, click JOB in the Available Fields list and click the right arrow (>) to move this field to the Matrix Column Fields list, then click Next.

12. On the Cell page, click SUM_SAL in the Available Fields list and click the right arrow (>) to move this field to the Matrix Cell Fields list, then click Next.

Note: In this case, the query itself performs the summary through the SUM function. Hence, you should not use the Sum button in this instance.

13. On the Totals page, click SUM_SAL in the Available Fields list and click Sum to move this field to the Matrix Totals list, then click Next.

14. On the Labels page, remove the label for SUM_SAL, then click Next.

15. On the Template page, select No Template, then click Finish to display your report output in the Paper Design view. It should look something like this:
27.3 Add Labels and Lines for Summaries

To make your report more readable, it would be useful to add labels for the row and column summaries. It would also be nice to have lines above the column summaries to better distinguish them from the cell values.

To add labels:
1. In the Paper Design view, click the Text tool in the tool palette.
2. Click in the open space just below the first department number and to the left of the first total.
3. Enter Job Tot., then click in a blank area of the Paper Design view. If you perform this step correctly, the label should now appear for all of the column summaries in the report.
4. If necessary, use the arrow keys to better align the label with the summaries.

   **Tip:** If you want more precise movements, turn off Snap to Grid in the View menu. It may also be helpful for this step to turn off Flex mode by clicking the Flex Off button in the toolbar.

5. Click the Text tool in the tool palette.
6. Click in the open space just above the row summaries.
7. Enter Dept. Tot., then click in a blank area of the Paper Design view. If you perform this step correctly, the label should now appear for all of the column summaries in the report.
8. If necessary, use the arrow keys to better align the label with the summaries.
Add Space Between Groups

**Figure 27–3** Matrix with group above report output with summary labels

<table>
<thead>
<tr>
<th>Year 60</th>
<th>Job</th>
<th>CLERK</th>
<th>DEPT. Tot.</th>
<th>Year 61</th>
<th>Job</th>
<th>ANALYST</th>
<th>CLERK</th>
<th>MANAGER</th>
<th>PRESIDENT</th>
<th>SALESMAN</th>
<th>DEPT. Tot.</th>
</tr>
</thead>
<tbody>
<tr>
<td>10</td>
<td>1000</td>
<td></td>
<td>2500</td>
<td>10</td>
<td>1300</td>
<td></td>
<td>1300</td>
<td></td>
<td></td>
<td></td>
<td>1300</td>
</tr>
<tr>
<td>20</td>
<td>3000</td>
<td></td>
<td>5275</td>
<td>20</td>
<td>3000</td>
<td></td>
<td>3000</td>
<td></td>
<td></td>
<td></td>
<td>3000</td>
</tr>
<tr>
<td>Job Tot.: 4000</td>
<td>4500</td>
<td>4300</td>
<td>4300</td>
<td>Job Tot.: 4000</td>
<td>5000</td>
<td>4500</td>
<td>4300</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

To add lines above column summaries

1. In the Paper Design view, click the Job Tot. label that you created in the previous section.

2. Shift-click the summaries to the right of Job Tot.

3. Click the Flex On button in the toolbar to set Flex mode on.

4. Click and drag Job Tot. and the summary fields down about 0.25 inches (0.5 centimeters).

5. Click the Paper Layout button in the toolbar to display the Paper Layout view.

6. In the Paper Layout view, note the two spaces that now appear just above the F_SumSUM_SALPerJOB and F_SumSUM_SALPerYEAR fields.

7. Click the Line tool in the tool palette.

8. Click and drag a line in the space above F_SumSUM_SALPerJOB.

9. Repeat steps 7 and 8 to create a line above F_SumSUM_SALPerYEAR.

**Figure 27–4** Layout model with lines above column summaries

27.4 Add Space Between Groups

Notice that the output has no space between the groups.

**To add more space:**

1. In the Paper Layout view, click the Confine Off and Flex On buttons in the toolbar to set Confine mode off and Flex mode on.
2. Click the Year label to select it, then Shift-click the F_YEAR field to the right to select it, too.

3. Click and drag the F_YEAR field down about 0.25 inches (0.5 centimeters).

4. Click the Paper Design button in the toolbar to preview your report output in the Paper Design view.

Figure 27–5 Matrix group above report output with added space

27.5 Create a Web Layout

Now that you have created a paper layout, suppose that you decide to have a Web layout for this report. You can quickly create a Web layout in the Report Wizard without changing your paper layout.

To create a Web Layout:
2. Select Create Web Layout only.
3. Click Finish.
4. Click the Web Source view button in the toolbar and review the Web source for your Web layout.
5. Choose Program > Run Web Layout to preview your Web layout.

Notes: If Netscape 7.0 is your default browser, and the browser does not display, set the registry key HKEY_CURRENT_USERS\Software\Oracle\Toolkit\Tkbrowser to the default browser location. Ensure that the BrowserName and the BrowserPath keys reflect the correct values. For example: BrowserName=Netscape 7;BrowserPath=C:\Program Files\Netscape\Netscape\Netscp.exe.

27.6 Summary

Congratulations! You have successfully created a matrix group above report. You now know how to:
- create a matrix group above report with a single-query data model.
- add labels and line for summaries.
Summary

- add some white space between the master records.
- create a Web layout without changing the paper layout.

For more information on any of the wizards, views, or properties used in this example, refer to the *Oracle Reports online Help*, which is available in Oracle Reports Builder or hosted on the Oracle Technology Network (OTN), as described in Section 4.1.1, "Using the Oracle Reports online Help".
Part V
Building Reports for Business Cases

The chapters in this Part provide steps to build reports that are intended for specific business purposes. The examples provided include computing values over specified periods of time, collecting data over a specified range, and grading data. Following the steps, you will learn how to print reports on preprinted forms (for checks or invoices), split a report into sections and distribute each section to a different destination, and include a simple table or contents and index, or a multilevel table of contents.

- **Chapter 28, "Building a Time Series Calculations Report"**
  A time series calculations report computes values over a specified period of time. You can use the techniques used for this report to produce other formats of time series calculations. For example, you can build a report that calculates and displays the quarterly average of purchases for each customer.

- **Chapter 29, "Building a Report for Enhanced Spreadsheet Output"**
  A paper report generated to spreadsheet output can be displayed in your browser. You can integrate the paper layout into a Web layout by modifying the Web source of your report, and then generate the output. You can then deploy this report with the Reports Server under Oracle WebLogic Server and display it in a spreadsheet utility (such as Microsoft Excel) inside your browser.

- **Chapter 30, "Building a Report with Aggregate Data"**
  A report with aggregate data collects data within a range, retrieves values from the database, and formats them based on an aggregate range defined. You can use parameters to specify the range over which the data should be collected.

- **Chapter 31, "Building a Check Printing Report with Spelled-Out Cash Amounts"**
  A check printing report contains a stub and spelled-out cash amounts. You can create a PL/SQL function that returns spelled-out numerical values, imports an image of a preprinted form (such as a blank check image), and prints your report on the form.

- **Chapter 32, "Building a Report Using a Preprinted Form"**
  A report using a preprinted form enables you to use formatting techniques to print reports on preprinted forms when you do not have access to a computer readable version of the forms. Such reports must be designed so that the data prints in the exact positions on the form.

- **Chapter 33, "Building an Invoice Report"**
  An invoice report displays several distinguishing characteristics of a typical invoice, such as customer name and address, sales order number, billing information, and billing totals. You can import an image and print your report on a preprinted form.

- **Chapter 34, "Building a Ranking Report"**
A ranking report grades data in two different ways: by count and by percentage. You can set the ranking criteria at runtime or let the criteria default to previously specified values.

■ Chapter 35, "Building a Paper Report with a Simple Table of Contents and Index"

Navigational tools, such as a simple table of contents and an index, can be added to a paper report. First, the page numbering must be determined for the entire report, then Oracle Reports Builder can generate the table of contents and index based on the established page numbering.

■ Chapter 36, "Building a Paper Report with a Multilevel Table of Contents"

A multilevel table of contents can be added to a paper report to facilitate navigation. This table of contents is created similarly to that in Chapter 35, "Building a Paper Report with a Simple Table of Contents and Index", however with a hierarchy that categorizes the information in the table of contents.

■ Chapter 37, "Bursting and Distributing a Report"

A report built for bursting and distributing a report enables you to simultaneously deliver a single report to multiple destinations. You can create a single report, burst each section to a separate report, and then send each section in any format (such as, PDF or HTML) to multiple destinations.

■ Chapter 38, "Building a Report with Multibyte Characters for PDF Output"

A multibyte character report can display text in virtually any language. You can produce reports that display text in multibyte character sets, such as Simplified Chinese, Traditional Chinese, Japanese, Korean, and Unicode.
In this chapter, you will learn about reports that show data based on calculations over a period of time. By following the steps in this chapter, you can generate the report output shown in Figure 28–1.

### Concepts
Reports with time series calculations calculate values over a specified period of time. The techniques described for this report can be used to produce other formats of time series calculations, as well.

### Data Relationships
This time series calculations report uses a query that will compute four-month moving averages of customer purchases. The `SELECT` statement will sum the current purchase (`TOTAL`) with purchases made by that customer in the previous four months, then average that sum through use of a self-join. For example, if the data queried is 30-JUL-00, Oracle Reports will average all purchases the customer made between 30 MAR-00 and 30-JUL-00.

### Example Scenario
In this example, you will use the Report Wizard to create a simple time series calculations report for both paper and the Web that calculates and displays the

---

Figure 28–1  Time series calculations report output

<table>
<thead>
<tr>
<th>CustID</th>
<th>Shipdate</th>
<th>Total</th>
<th>4-Month Moving Average</th>
</tr>
</thead>
<tbody>
<tr>
<td>100</td>
<td>30-JUL-86</td>
<td>$3.40</td>
<td>$3.40</td>
</tr>
<tr>
<td></td>
<td>15-AUG-86</td>
<td>$97.50</td>
<td>$50.45</td>
</tr>
<tr>
<td></td>
<td>01-JAN-87</td>
<td>$730.00</td>
<td>$730.00</td>
</tr>
<tr>
<td></td>
<td>12-MAR-87</td>
<td>$4,450.00</td>
<td>$2,590.00</td>
</tr>
<tr>
<td>101</td>
<td>08-JAN-87</td>
<td>$101.40</td>
<td>$101.40</td>
</tr>
<tr>
<td>102</td>
<td>05-JUN-86</td>
<td>$224.00</td>
<td>$224.00</td>
</tr>
<tr>
<td></td>
<td>20-JUN-86</td>
<td>$56.00</td>
<td>$140.00</td>
</tr>
<tr>
<td></td>
<td>11-JAN-87</td>
<td>$45.00</td>
<td>$45.00</td>
</tr>
<tr>
<td></td>
<td>05-FEB-87</td>
<td>$23,940.00</td>
<td>$11,992.50</td>
</tr>
<tr>
<td></td>
<td>06-MAR-87</td>
<td>$3,510.50</td>
<td>$9,165.17</td>
</tr>
<tr>
<td>103</td>
<td>10-FEB-87</td>
<td>$764.00</td>
<td>$764.00</td>
</tr>
<tr>
<td>104</td>
<td>18-JUL-86</td>
<td>$5.60</td>
<td>$5.60</td>
</tr>
<tr>
<td></td>
<td>25-JUL-86</td>
<td>$35.20</td>
<td>$20.40</td>
</tr>
</tbody>
</table>
four-month average of purchases for each customer. For the JSP-based Web report, you will modify the Web source to change labels and add format masks.

As you build this example report, you will:

- **Create a Query and the Layout** using the Report Wizard to create a data model and layout for both the paper and Web reports.
- **Modify the Web Source of Your JSP Report** to generate the JSP-based Web report.

To see a sample time series calculations report, open the examples folder named timeseries, then open the Oracle Reports example called timeseries.rdf. For details on how to open it, see "Accessing the Example Reports" in the Preface.

### 28.1 Prerequisites for This Example

To build the example in this chapter, you must have access to the Summit Sporting Goods (SUMMIT) schema. To download the SQL scripts that install the schema, see "Accessing the Data Sources" in the Preface.

### 28.2 Create a Query and the Layout

The steps in this section will show you how to build a simple data model and report layout in the Report Wizard, which you can then use to generate either a JSP-based Web report or a paper report. In the next section, you will modify the JSP so that the appropriate information displays in your Web report.

When you are creating a single-query report, such as this one, you can use the Report Wizard to create the data model and layout simultaneously.

**To create a data model and layout:**

1. Launch Reports Builder (or, if already open, choose File > New > Report).
2. In the Welcome or New Report dialog box, select **Use the Report Wizard**, then click **OK**.
3. If the Welcome page displays, click **Next**.
4. On the Report Type page, select **Create both Web and Paper Layout**, then click **Next**.
5. On the Style page, type a **Title** for your report, select **Group Left**, then click **Next**.
6. On the Data Source page, click **SQL Query**, then click **Next**.
7. On the Data page, enter the following SELECT statement in the **Data Source definition** field:

   ```sql
   SELECT O.CUSTID, O.SHIPDATE, O.TOTAL, 
   AVG(A.TOTAL) MAVG 
   FROM ORD O, ORD A 
   WHERE A.CUSTID = O.CUSTID 
   AND A.SHIPDATE BETWEEN O.SHIPDATE -123 AND O.SHIPDATE 
   GROUP BY O.CUSTID, O.SHIPDATE, O.TOTAL
   ```
8. Click Next.

**Note:** If you are not already connected to a database, you will be prompted to connect to the database when you click Query Builder or Next. Ensure that you connect to a database that has the appropriate schema for this example. Section 28.1, "Prerequisites for This Example" describes the sample schema requirements for this example.

9. On the Groups page, click CUSTID and click the right arrow (>) to move this field to the Group Fields list, then click Next.

10. On the Fields page, click the double right arrows (>>) to move all of the fields to the Displayed Fields list, then click Next.

11. On the Totals page, click Next.

12. On the Labels page, change the label for MAVG to 4-Month Moving Average, then click Next

13. On the Template page, select Predefined Template and click Beige, then click Finish to display your report output in the Paper Design view.

14. In the Paper Design view, double-click field F_MAVG to display the Property Inspector, and set the following properties:

   - Under Field, set the Format Mask property to LNNNGNN0D00.

15. Do the same for field F_TOTAL.

16. Select the first number value underneath the Total label. Notice that all of the values are immediately selected.

17. Shift-click the first number value underneath the 4-Month Moving Average label.

18. Click the Align Right button. All of the values are immediately right aligned.

19. The report in the Paper Design view should now look something like this:
20. To view the data model you just created using the Report Wizard, click the Data Model button in the toolbar. The same data model can be used for both your paper and your JSP-based Web reports.

Your data model should look something like this:

21. Save your report as timeseries_your_initials.rdf.

28.3 Modify the Web Source of Your JSP Report

Now that you have created your paper report layout, you can take the same report and generate a JSP-based Web report that looks the same as your paper report.
To modify your JSP-based Web report:

1. Save your report, timeseries_your_initials.rdf as a JSP under the same name (timeseries_your_initials.jsp).

2. Click the Web Source button in the toolbar to display the Web Source view.

   In the Web Source, you need to change the format mask to match that of the paper report.

3. In the Web Source view, find the text:

\[
\text{<td } \text{rw:headers id="HFtotal" src="HBtotal, HBcustid, HFcustid"/}\text{>}
\text{class="OraCellNumber">}\text{rw:field id="F_total" src="total" nullValue="&nbsp;"> F_total </td>}
\]

4. Add the tag \text{formatMask="LNNNGNN0D00"} to the line, so that the line looks like this:

\[
\text{<td } \text{rw:headers id="HFtotal" src="HBtotal, HBcustid, HFcustid"/}\text{>}
\text{class="OraCellNumber">}\text{rw:field id="F_total" src="total" formatMask="LNNNGNN0D00" nullValue="&nbsp;"> F_total </td>}
\]

Note: The bold text is the new format mask tag that we have added to the Total field.

5. Change the format mask for the MAVG field. The resulting line in the Web Source should look like this:

\[
\text{<td } \text{rw:headers id="HFmavg" src="HBmavg, HBcustid, HFcustid"/}\text{>}
\text{class="OraCellNumber">}\text{rw:field id="F_mavg" src="mavg" formatMask="LNNNGNN0D00" nullValue="&nbsp;"> F_mavg </td>}
\]

6. Save your report as a JSP.

7. Click the Run Web Layout button in the toolbar to display your new JSP-based Web report in your browser. The report should look something like this:

Note: If Netscape 7.0 is your default browser, and the browser does not display, set the registry key HKEY_CURRENT_ USERS\Software\Oracle\ToolKit\Tkbrowser to the default browser location. Ensure that the BrowserName and the BrowserPath keys reflect the correct values. For example: BrowserName=Netscape 7; BrowserPath=C:\Program Files\Netscape\Netscape\Netscp.exe.
Figure 28–4  Time Series Calculations JSP-based Web Report

<table>
<thead>
<tr>
<th>Custid</th>
<th>Shipdate</th>
<th>Total</th>
<th>4-Month Moving Average</th>
</tr>
</thead>
<tbody>
<tr>
<td>100</td>
<td>30-JUL-86</td>
<td>$3.40</td>
<td>$3.40</td>
</tr>
<tr>
<td></td>
<td>15-AUG-86</td>
<td>$97.50</td>
<td>$50.45</td>
</tr>
<tr>
<td></td>
<td>01-JAN-87</td>
<td>$730.00</td>
<td>$730.00</td>
</tr>
<tr>
<td></td>
<td>12-MAR-87</td>
<td>$4,460.00</td>
<td>$2,590.00</td>
</tr>
<tr>
<td>101</td>
<td>08-JAN-87</td>
<td>$101.40</td>
<td>$101.40</td>
</tr>
<tr>
<td>102</td>
<td>05-JUN-86</td>
<td>$224.00</td>
<td>$224.00</td>
</tr>
<tr>
<td></td>
<td>20-JUN-86</td>
<td>$65.00</td>
<td>$140.00</td>
</tr>
<tr>
<td></td>
<td>11-JAN-87</td>
<td>$45.00</td>
<td>$45.00</td>
</tr>
<tr>
<td></td>
<td>05-FEB-87</td>
<td>$23,940.00</td>
<td>$11,992.50</td>
</tr>
<tr>
<td></td>
<td>06-MAR-87</td>
<td>$3,510.50</td>
<td>$9,165.17</td>
</tr>
<tr>
<td>103</td>
<td>10-FEB-87</td>
<td>$764.00</td>
<td>$764.00</td>
</tr>
<tr>
<td>104</td>
<td>18-JUL-86</td>
<td>$5.60</td>
<td>$5.60</td>
</tr>
<tr>
<td></td>
<td>25-JUL-86</td>
<td>$35.20</td>
<td>$20.40</td>
</tr>
</tbody>
</table>

The report displays the total for each customer, as well as the average over the past four months.

Note: For information on creating a Parameter Form for a JSP-based Web report, refer to the documented example on the Oracle Technology Network (OTN): on the Oracle Reports page (http://www.oracle.com/technetwork/middleware/reports/overview/index.html), navigate to Learn More and click Getting Started to display the Getting Started with Oracle Reports home page. In the list of topic sections on the left, click Index. In the Collateral Type list, choose Examples, and click Search. In the list of examples that displays, click Building a JSP-based Web Report with a Parameter Form.

28.4 Summary

Congratulations! You have successfully created a time series calculations report for both paper and Web. You now know how to:

- create a time series calculations report definition.
- modify your report for the Web.

For more information on any of the wizards, views, or properties used in this example, refer to the Oracle Reports online Help, which is available in Oracle Reports Builder or hosted on the Oracle Technology Network (OTN), as described in Section 4.1.1, “Using the Oracle Reports online Help”.

28-6  Publishing Reports to the Web with Oracle Reports Services
Building a Report for Enhanced Spreadsheet Output

In this chapter, you will learn about Enhanced Spreadsheet reports. Oracle Reports generates spreadsheet output using the `ENHANCEDSPREADSHEET` format. The `ENHANCEDSPREADSHEET` output format is new in Oracle Reports 12c (12.2.1.1) and provides the following benefits:

- Large data sets (up to 75,000 rows) can be generated to the `ENHANCEDSPREADSHEET` output format.
- `ENHANCEDSPREADSHEET` output format allows for bursting and distributing reports to spreadsheet output format.
- In `ENHANCEDSPREADSHEET` output, the complete report data is shown as one unbroken chunk of information in Microsoft Excel, not broken up by page breaks, as happens in other output formats, such as PDF and RTF that are restricted by horizontal and vertical page sizes.

For more information about Enhanced spreadsheet output, refer to Section 2.8.13, "About Enhanced Spreadsheet output".

By completing the steps in this chapter, you can generate the Enhanced Spreadsheet report output, as shown in Figure 29–1.

**Figure 29–1 Enhanced Spreadsheet report output**

<table>
<thead>
<tr>
<th>Employee Id</th>
<th>First Name</th>
<th>Last Name</th>
<th>Email</th>
<th>Hire Date</th>
<th>Salary</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Steven</td>
<td>Myers</td>
<td>SMYERS</td>
<td>7-Mar-94</td>
<td>$13,500.00</td>
</tr>
<tr>
<td>2</td>
<td>Hermann</td>
<td>Baer</td>
<td>HBAER</td>
<td>7-Jan-94</td>
<td>$10,000.00</td>
</tr>
<tr>
<td>3</td>
<td>John</td>
<td>Russell</td>
<td>JRUSS</td>
<td>1-Oct-93</td>
<td>$14,000.00</td>
</tr>
<tr>
<td>4</td>
<td>Karen</td>
<td>Peterson</td>
<td>HPARTN</td>
<td>5-Jan-97</td>
<td>$12,000.00</td>
</tr>
<tr>
<td>5</td>
<td>Alberto</td>
<td>Emmerzau</td>
<td>AEMLER</td>
<td>10-Mar-97</td>
<td>$12,000.00</td>
</tr>
<tr>
<td>6</td>
<td>Gerald</td>
<td>Cambraut</td>
<td>KCAMBA</td>
<td>15-Oct-93</td>
<td>$11,000.00</td>
</tr>
<tr>
<td>7</td>
<td>Peter</td>
<td>Hall</td>
<td>PHALL</td>
<td>20-Aug-97</td>
<td>$9,000.00</td>
</tr>
<tr>
<td>8</td>
<td>Ninetta</td>
<td>Cambraut</td>
<td>NCAMBA</td>
<td>9-Dec-95</td>
<td>$7,500.00</td>
</tr>
<tr>
<td>9</td>
<td>Janette</td>
<td>King</td>
<td>JKING</td>
<td>30-Jan-96</td>
<td>$10,000.00</td>
</tr>
<tr>
<td>10</td>
<td>Allan</td>
<td>McEwen</td>
<td>AMCEW</td>
<td>1-Aug-96</td>
<td>$9,000.00</td>
</tr>
<tr>
<td>11</td>
<td>Louise</td>
<td>Doane</td>
<td>LDOAN</td>
<td>15-Dec-97</td>
<td>$7,500.00</td>
</tr>
<tr>
<td>12</td>
<td>Harrison</td>
<td>Broome</td>
<td>HBRM</td>
<td>23-Mar-99</td>
<td>$10,000.00</td>
</tr>
<tr>
<td>13</td>
<td>Lisa</td>
<td>Ozer</td>
<td>LOZER</td>
<td>11-Mar-97</td>
<td>$11,500.00</td>
</tr>
<tr>
<td>14</td>
<td>Amir</td>
<td>Bandhia</td>
<td>ABANDH</td>
<td>21-Apr-97</td>
<td>$6,200.00</td>
</tr>
<tr>
<td>15</td>
<td>Sumbal</td>
<td>Ande</td>
<td>SANDE</td>
<td>24-Mar-00</td>
<td>$9,500.00</td>
</tr>
<tr>
<td>16</td>
<td>David</td>
<td>Lee</td>
<td>DLEE</td>
<td>23-Feb-00</td>
<td>$10,000.00</td>
</tr>
<tr>
<td>17</td>
<td>Matea</td>
<td>Mandina</td>
<td>MMANDI</td>
<td>24-Jan-00</td>
<td>$2,200.00</td>
</tr>
<tr>
<td>18</td>
<td>Danielle</td>
<td>Greene</td>
<td>DGRENE</td>
<td>19-Mar-99</td>
<td>$9,500.00</td>
</tr>
<tr>
<td>19</td>
<td>Clara</td>
<td>Vivian</td>
<td>CVIVIA</td>
<td>11-Nov-97</td>
<td>$10,000.00</td>
</tr>
<tr>
<td>20</td>
<td>Sarah</td>
<td>Sewall</td>
<td>SSWALL</td>
<td>3-Nov-98</td>
<td>$7,000.00</td>
</tr>
</tbody>
</table>
Concepts

- This chapter provides steps for building a JSP-based Web report and deploying it with Reports Server under Oracle WebLogic Server to display it in Microsoft Excel inside your Web browser. You can use an existing paper layout report to create a new Web layout.

- If you want to generate Microsoft Excel output from your Web report, but you do not have an existing paper layout, refer to the slideshow demonstration on the Oracle Technology Network (OTN): on the Oracle Reports page (http://www.oracle.com/technetwork/middleware/reports/overview/index.html), click Getting Started to display the Getting Started with Oracle Reports home page. In the list of topic sections on the left, click Index. In the Collateral Type list, choose Demonstrations, and click Search. In the list of demos that displays, click Output to Excel with Oracle Reports.

Note: The steps in both this chapter and the Getting Started demonstration allow you to use rich formatting, such as colors and fonts so that you generate report layout, not just data, in Microsoft Excel output inside a Web browser. However, you must add custom JSP code to get the output in Microsoft Excel. The Web report can only be run as JSP in Oracle WebLogic Server and not through rwservlet, thus this method can only display the Microsoft Excel output inside a Web browser.

- The ENHANCEDSPREADSHEET output format enables you to burst and distribute reports to spreadsheet format, as well as generate large data sets (up to 75,000 rows) to spreadsheets.

The ENHANCEDSPREADSHEET output formats generate output from paper layout reports to HTML files that can be directly opened with Microsoft Excel 2000. You can:

- Generate report output to Enhanced spreadsheet format from existing paper layout reports saved in any format (.rdf, .xml, .jsp), using rwrn or Reports Server clients (rwcclient, rwservlet). See the following example scenario.

- Preserve the rich layout formatting, such as colors, fonts, conditional formatting, graphs, and images.

For the steps to implement this functionality to directly generate spreadsheet output, see Section 2.8.13, “About Enhanced Spreadsheet output” and Section 4.7.11, “Generating Enhanced spreadsheet output”.

Example Scenario

In this example, you will generate a report to Microsoft Excel output. The output is generated after integrating the paper layout into a Web layout by modifying the Web source of your report.

As you build this example report, you will:

- Create a Query and the Layout using the Report Wizard to create a simple query for a paper layout report.

- Modify the Web source of Your JSP Report to generate the JSP-based Web report.

- Modify Your JSP Report to Display in Microsoft Excel.
To see a sample report, open the examples folder named `papertoexcel`, then open the Oracle Reports example named `mypaperreport.rdf`. For details on how to open it, see "Accessing the Example Reports" in the Preface. The example files used in this chapter are listed and described in Table 29-1.

<table>
<thead>
<tr>
<th>File</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><code>papertoexcel\mypaperreport.rdf</code></td>
<td>The sample paper report. Running this RDF in Reports Builder will display the result of your paper report in the Paper Design view.</td>
</tr>
<tr>
<td><code>papertoexcel\myexcelreport.jsp</code></td>
<td>This JSP-based Web report contains the modifications to the paper report you will make in Reports Builder.</td>
</tr>
<tr>
<td><code>papertoexcel\papertoexceldata_code.txt</code></td>
<td>The SQL for the query you need to enter.</td>
</tr>
</tbody>
</table>

### 29.1 Prerequisites for This Example

To build the example in this chapter, you must have the example files packaged with the Oracle Reports software (see "Example Scenario", above), as well as access to the Human Resources sample schema (HR) provided with the Oracle Database. If you do not know if you have access to this sample schema, contact your database administrator. You must have Microsoft Excel 2000 or higher to complete this example.

### 29.2 Create a Query and the Layout

The steps in this section show you how to build a simple data model and report layout in the Report Wizard, which you can then use to generate either a JSP-based Web report or a paper report. In the next section, you will modify the JSP, so that the appropriate information displays in your Web report.

**To create a data model and layout:**

1. Launch Reports Builder (or, if already open, choose **File > New > Report**).
2. In the Welcome or New Report dialog box, select **Use the Report Wizard**, then click **OK**.
3. If the Welcome page displays, click **Next**.
4. On the Report Type page, select **Create Paper Layout only**, then click **Next**.
5. On the Style page, select **Tabular**, then click **Next**.
6. On the Data Source page, click **SQL Query**, then click **Next**.
7. On the Data page, enter the following `SELECT` statement in the **Data Source definition** field:

   ```sql
   SELECT EMPLOYEES.EMPLOYEE_ID, EMPLOYEES.FIRST_NAME, EMPLOYEES.LAST_NAME, EMPLOYEES.HIRE_DATE, EMPLOYEES.SALARY, DEPARTMENTS.DEPARTMENT_NAME, LOCATIONS.CITY
   FROM EMPLOYEES, DEPARTMENTS, LOCATIONS
   WHERE EMPLOYEES.DEPARTMENT_ID=DEPARTMENTS.DEPARTMENT_ID AND DEPARTMENTS.LOCATION_ID=LOCATIONS.LOCATION_ID
   ORDER BY CITY
   ```

Building a Report for Enhanced Spreadsheet Output 29-3
8. Click Next.

**Note:** You can enter this query in either of the following ways:

- Copy and paste the code from the papertoexceldata_code.txt file packaged with Oracle Reports, into the Data Source definition field.
- Click Query Builder to build the query, without entering any code manually.
- Type the code in the Data Source definition field.

9. On the Fields page, click the double right arrows (>>) to move all of the fields to the Displayed Fields list, then click Next.

10. On the Totals page, click Next.


12. On the Template page, select Predefined Template and click Wine, and then click Finish to display your report output in the Paper Design view. It should look something like this:

   **Figure 29–2  Paper Design Output**

<table>
<thead>
<tr>
<th>Employee Id</th>
<th>First Name</th>
<th>Last Name</th>
<th>Email</th>
<th>Hire Date</th>
<th>Salary</th>
<th>Department Name</th>
<th>City</th>
</tr>
</thead>
<tbody>
<tr>
<td>203</td>
<td>Susan</td>
<td>Norris</td>
<td>SM@PR</td>
<td>07-JUN-94</td>
<td>$7,000.0</td>
<td>Human Resources</td>
<td>London</td>
</tr>
<tr>
<td>204</td>
<td>Hermann</td>
<td>Baer</td>
<td>H@E@R</td>
<td>07-JUN-94</td>
<td>$10,000.0</td>
<td>Public Relations</td>
<td>Munich</td>
</tr>
<tr>
<td>145</td>
<td>Johan</td>
<td>Russell</td>
<td>JRUSSEL</td>
<td>01-OCT-96</td>
<td>$14,500.0</td>
<td>Sales</td>
<td>Oxford</td>
</tr>
<tr>
<td>146</td>
<td>Karen</td>
<td>Partners</td>
<td>KPARTNER</td>
<td>15-JAN-97</td>
<td>$13,200.0</td>
<td>Sales</td>
<td>Oxford</td>
</tr>
<tr>
<td>147</td>
<td>Albard</td>
<td>Enraza</td>
<td>AERRAZUR</td>
<td>10-MAR-97</td>
<td>$12,000.0</td>
<td>Sales</td>
<td>Oxford</td>
</tr>
<tr>
<td>149</td>
<td>Gerald</td>
<td>Cambrault</td>
<td>CAMBRANU</td>
<td>15-OCT-96</td>
<td>$11,000.0</td>
<td>Sales</td>
<td>Oxford</td>
</tr>
<tr>
<td>152</td>
<td>Peter</td>
<td>Hall</td>
<td>PHALL</td>
<td>20-AUG-97</td>
<td>$5,000.0</td>
<td>Sales</td>
<td>Oxford</td>
</tr>
<tr>
<td>154</td>
<td>Nanette</td>
<td>Cambrault</td>
<td>NCAMBRANU</td>
<td>19-DEC-98</td>
<td>$7,500.0</td>
<td>Sales</td>
<td>Oxford</td>
</tr>
<tr>
<td>158</td>
<td>Janette</td>
<td>King</td>
<td>JKING</td>
<td>30-JAN-98</td>
<td>$10,000.0</td>
<td>Sales</td>
<td>Oxford</td>
</tr>
<tr>
<td>159</td>
<td>Allan</td>
<td>McEwen</td>
<td>AMCEVEN</td>
<td>01-AUG-98</td>
<td>$8,000.0</td>
<td>Sales</td>
<td>Oxford</td>
</tr>
<tr>
<td>160</td>
<td>Larue</td>
<td>Doran</td>
<td>LORAN</td>
<td>15-DEC-97</td>
<td>$7,500.0</td>
<td>Sales</td>
<td>Oxford</td>
</tr>
<tr>
<td>169</td>
<td>Harrison</td>
<td>Bloom</td>
<td>BLOOM</td>
<td>23-MAR-96</td>
<td>$10,000.0</td>
<td>Sales</td>
<td>Oxford</td>
</tr>
<tr>
<td>168</td>
<td>Lisa</td>
<td>Ozer</td>
<td>LOZER</td>
<td>11-MAR-97</td>
<td>$11,500.0</td>
<td>Sales</td>
<td>Oxford</td>
</tr>
<tr>
<td>167</td>
<td>Arnd</td>
<td>Bandera</td>
<td>ABANDA</td>
<td>21-APR-00</td>
<td>$8,200.0</td>
<td>Sales</td>
<td>Oxford</td>
</tr>
<tr>
<td>166</td>
<td>Sundar</td>
<td>Ande</td>
<td>ANDI</td>
<td>24-MAR-00</td>
<td>$8,400.0</td>
<td>Sales</td>
<td>Oxford</td>
</tr>
<tr>
<td>165</td>
<td>David</td>
<td>Lee</td>
<td>DLIEE</td>
<td>23-FEB-00</td>
<td>$8,500.0</td>
<td>Sales</td>
<td>Oxford</td>
</tr>
<tr>
<td>164</td>
<td>Matthias</td>
<td>Marvino</td>
<td>MMARVIN</td>
<td>24-MAR-00</td>
<td>$7,200.0</td>
<td>Sales</td>
<td>Oxford</td>
</tr>
<tr>
<td>163</td>
<td>Danielle</td>
<td>Greene</td>
<td>DOGREENE</td>
<td>19-MAR-98</td>
<td>$8,500.0</td>
<td>Sales</td>
<td>Oxford</td>
</tr>
<tr>
<td>162</td>
<td>Clara</td>
<td>Moshiev</td>
<td>CMOSHEVY</td>
<td>11-NOV-97</td>
<td>$10,500.0</td>
<td>Sales</td>
<td>Oxford</td>
</tr>
<tr>
<td>161</td>
<td>Sarah</td>
<td>Sewall</td>
<td>SSEWALL</td>
<td>03-NOV-98</td>
<td>$7,000.0</td>
<td>Sales</td>
<td>Oxford</td>
</tr>
<tr>
<td>178</td>
<td>Charles</td>
<td>Johnson</td>
<td>COJHNSON</td>
<td>01-APR-98</td>
<td>$8,200.0</td>
<td>Sales</td>
<td>Oxford</td>
</tr>
<tr>
<td>177</td>
<td>Jack</td>
<td>Livingston</td>
<td>JVING</td>
<td>23-APR-98</td>
<td>$8,400.0</td>
<td>Sales</td>
<td>Oxford</td>
</tr>
<tr>
<td>176</td>
<td>Jennifer</td>
<td>Taylor</td>
<td>JTAYLOR</td>
<td>24-MAR-98</td>
<td>$8,000.0</td>
<td>Sales</td>
<td>Oxford</td>
</tr>
</tbody>
</table>

13. Save your report as mypaperreport_your_initials.rdf.
29.3 Modify the Web source of Your JSP Report

Now that you have created your paper report layout, you will learn how to take the same report and generate a JSP-based Web report that looks the same as your paper report.

To modify your JSP-based Web report:

1. In the Report Editor, click the Web Source button in the toolbar to display the Web Source view.
   
   In the Web Source view, you need to change the dummy JSP code created by Oracle Reports Builder.

2. In the Web Source view, find the text:

   ```
   <rw:dataArea id="yourDataArea">
   <!-- Report Wizard inserts the default jsp here -->
   </rw:dataArea>
   ```

   **Tip:** Choose Edit > Find and Replace, then type dataArea in the Find what text box.

3. Ensure that you place the cursor in between the opening and closing `<rw:dataArea>` tags, and choose Insert > Frame. This inserts the following code in your Web Source view:

   ```
   <rw:include id="include" src="..." />
   </rw:dataArea>
   ```

   **Note:** The `rw:include` tag enables you to include the outer frame of your paper layout in the Web Source view as JSP code. Adding a `rw:include` tag to the `rw:dataArea` tag enables you to include and reuse the existing paper layout in a Web layout.

4. In the Object Navigator, locate the top level layout object frame of your paper layout. Specify its name in the `src` attribute of `rw:include` tag. The line should look like this:

   ```
   <rw:dataArea id="yourDataArea">
   <!-- Report Wizard inserts the default jsp here -->
   <rw:include id="mypaperreport_id" src="M_G_EMPLOYEE_ID_GRPFR">
   </rw:include>
   </rw:dataArea>
   ```

5. Click the Run Web Layout button in the toolbar to display your new JSP-based Web report in your browser. The report should look something like this:
29.4 Modify Your JSP Report to Display in Microsoft Excel

Now that you have created your JSP-based Web report, which looks the same as your paper report, you will modify it further to display the report in Microsoft Excel in your Web browser.

First, copy `myexcelreport_your_initials.jsp` to the deployment directory of your Application Server. For testing purposes, in this example, we will use the Oracle WebLogic Server instance shipped with the Oracle Developer Suite.

For more information on deploying a JSP-based Web report, refer to the "Deploying Your Reports" section in *Publishing Reports to the Web with Oracle Reports Services*.

To modify the report to display in Microsoft Excel:

1. In the Report Editor, click the **Web Source** button in the toolbar to display the Web Source view.

   In the Web Source view, you will change the content type of the HTTP response using the JSP directive `contentType`, so that the browser opens Microsoft Excel to display your report output.

2. In the Web Source view, find the following text:

   ```
   <%@ taglib uri="/WEB-INF/lib/reports_tld.jar" prefix="rw" %>
   <%@ page language="java" import="java.io.*" errorPage="/rwerror.jsp" session="false" %>
   <%@ page contentType="text/html;charset=ISO-8859-1" %>
   <rw:report id="report">
   <rw:objects id="objects">
   ```

The report displays, in Web format, the employee data you specified. Here, you can see employee details, such as their name, email, hire date, salary, department to which they belong and their location.

6. Save your report as `myexcelreport_your_initials.jsp`.
Modify Your JSP Report to Display in Microsoft Excel

......
......
<!--
</rw:report>
--> and modify it to read as follows:

<%@ taglib uri="/WEB-INF/lib/reports_tld.jar" prefix="rw" %>
<%@ page language="java" import="java.io.*" errorPage="/rwerreport.jsp"
session="false" %>
<%@ page contentType="application/vnd.ms-excel;charset=ISO-8859-1" %>
<rw:report id="report">
<rw:objects id="objects">
......
......
<!--
</rw:report>
--> 3. Save your report.

4. Copy the Web report (myexcelreport_your_initials.jsp) into the following
directory:

$DOMAIN_HOME/servers/<managed_server_name>/tmp/_WL_user/reports_<version>/<dir_name>/web.war

5. Start your Oracle WebLogic Server instance to enable the deployment of your report.

- On Windows, you can do either of the following:
  - From the Start menu, choose Programs > Oracle Classic Instance > Reports Services > Start WebLogic Server - WLS_REPORTS.
    For example, the Oracle Classic Instance may be Oracle Classic Instance-asinst_1.
  - From the command line, run the following command:
    `cd $DOMAIN_HOME\bin\startManagedServer.bat WLS_REPORTS`

- On UNIX, start the shell script from the command line:
  - `$DOMAIN_HOME/bin/startManagedServer.sh WLS_REPORTS`

**Tip:** The Oracle WebLogic Server instance starts once the containers for Java EE have been initialized.

6. Type the following URL to display your report in Microsoft Excel in your Web browser:

http://your_computer:port/reports/yourexcelreportname.jsp?userid=hr/hr@db

In our example, we use:

http://mycomputer-pc:8888/reports/my_excel_report.jsp?userid=hr/hr@orcl
7. The report runs, and the browser displays your report in Microsoft Excel.

**Note:** If you want your report to display the same colors in Excel as in your report definition, you must use colors supported by the Excel color palette. Otherwise, Excel tries to match unsupported colors, but the match may not be what you expect.

Your final report output should look something like this:

*Figure 29–4  Microsoft Excel Output of Your Report*

![Microsoft Excel Output of Your Report](http://dbs009.dbs.oracle.com:8099/reports/my_excel_report.jsp?reportid=be/hr/award payroll - Microsoft Internet Explorer)

<table>
<thead>
<tr>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
<th>E</th>
<th>F</th>
<th>G</th>
<th>H</th>
<th>I</th>
<th>J</th>
<th>K</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Employee Id</td>
<td>First Name</td>
<td>Last Name</td>
<td>Email</td>
<td>Hire Date</td>
<td>Salary</td>
<td>Department</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2</td>
<td>203</td>
<td>Susan</td>
<td>Marks</td>
<td>SMARKS</td>
<td>7-Jun-94</td>
<td>$21,500.00</td>
<td>Human Ress</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>3</td>
<td>204</td>
<td>Herman</td>
<td>Bauer</td>
<td>HBAUER</td>
<td>7-Jun-94</td>
<td>$15,000.00</td>
<td>Public Relations</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>4</td>
<td>145</td>
<td>John</td>
<td>Russell</td>
<td>JRUSSEL</td>
<td>1-Oct-96</td>
<td>$14,000.00</td>
<td>Sales</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>5</td>
<td>145</td>
<td>Karen</td>
<td>Palmore</td>
<td>KPALMORE</td>
<td>5-Jan-97</td>
<td>$12,500.00</td>
<td>Sales</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>6</td>
<td>147</td>
<td>Albert</td>
<td>Edmonds</td>
<td>AEEDMONDS</td>
<td>10-Jan-97</td>
<td>$8,000.00</td>
<td>Sales</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>7</td>
<td>148</td>
<td>Gerald</td>
<td>Cambrault</td>
<td>GCAMBRAL</td>
<td>15-Oct-99</td>
<td>$11,000.00</td>
<td>Sales</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>8</td>
<td>152</td>
<td>Peter</td>
<td>Hall</td>
<td>PHALL</td>
<td>20-Aug-97</td>
<td>$5,000.00</td>
<td>Sales</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>9</td>
<td>154</td>
<td>Nancie</td>
<td>Cambrault</td>
<td>NCAMBRAL</td>
<td>5-Dec-98</td>
<td>$7,500.00</td>
<td>Sales</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>10</td>
<td>156</td>
<td>Janette</td>
<td>King</td>
<td>JKG</td>
<td>30-Jan-98</td>
<td>$10,000.00</td>
<td>Sales</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>11</td>
<td>156</td>
<td>Allen</td>
<td>McEwen</td>
<td>AMCEWEN</td>
<td>1-Aug-96</td>
<td>$9,000.00</td>
<td>Sales</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>12</td>
<td>150</td>
<td>Louise</td>
<td>Doman</td>
<td>LDOMAN</td>
<td>16-Dec-97</td>
<td>$5,000.00</td>
<td>Sales</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>13</td>
<td>150</td>
<td>Hamilton</td>
<td>Bloom</td>
<td>HBLoom</td>
<td>23-Mar-98</td>
<td>$10,000.00</td>
<td>Sales</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>14</td>
<td>150</td>
<td>Lisa</td>
<td>Otter</td>
<td>LOTT</td>
<td>5-Mar-98</td>
<td>$11,300.00</td>
<td>Sales</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>15</td>
<td>157</td>
<td>Arnie</td>
<td>Bland</td>
<td>ABAND</td>
<td>21-Apr-00</td>
<td>$6,300.00</td>
<td>Sales</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>16</td>
<td>150</td>
<td>Donnor</td>
<td>Aude</td>
<td>SAIK</td>
<td>24-Mar-00</td>
<td>$6,060.00</td>
<td>Sales</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>17</td>
<td>159</td>
<td>David</td>
<td>Lee</td>
<td>LEE</td>
<td>29-Feb-00</td>
<td>$6,800.00</td>
<td>Sales</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>18</td>
<td>154</td>
<td>Melodie</td>
<td>Manns</td>
<td>MMANNs</td>
<td>24-Jan-00</td>
<td>$7,200.00</td>
<td>Sales</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>19</td>
<td>153</td>
<td>Danielle</td>
<td>Greene</td>
<td>DGRENE</td>
<td>11-Mar-98</td>
<td>$8,000.00</td>
<td>Sales</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>20</td>
<td>152</td>
<td>Gloria</td>
<td>Vickers</td>
<td>GVICKERS</td>
<td>11-Nov-97</td>
<td>$10,000.00</td>
<td>Sales</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>21</td>
<td>151</td>
<td>Sarah</td>
<td>Sewall</td>
<td>SSEWALL</td>
<td>3-Nov-98</td>
<td>$7,000.00</td>
<td>Sales</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

### 29.5 Summary

You have created Excel output of your report. You now know how to:

- create a simple paper layout report.
- modify a Web layout to use an existing paper layout report.
- test and deploy a JSP-based Web report to Microsoft Excel output using Oracle WebLogic Server.

For more information on any of the wizards, views, or properties used in this example, refer to the Oracle Reports online Help, which is available in Oracle Reports Builder or hosted on the Oracle Technology Network (OTN), as described in Section 4.1.1, "Using the Oracle Reports online Help".
In this chapter, you will learn about reports that include aggregate data, based on value ranges. By following the steps in this chapter, you can generate the report output shown in Figure 30–1.

**Figure 30–1  Aggregate data report output**

<table>
<thead>
<tr>
<th>Salary Range</th>
<th>Name</th>
<th>Dept</th>
</tr>
</thead>
<tbody>
<tr>
<td>0 - 1000</td>
<td>SMITH</td>
<td>20</td>
</tr>
<tr>
<td></td>
<td>JAMES</td>
<td>30</td>
</tr>
<tr>
<td>1000 - 2000</td>
<td>ADAMS</td>
<td>20</td>
</tr>
<tr>
<td></td>
<td>WARD</td>
<td>30</td>
</tr>
<tr>
<td></td>
<td>MARTIN</td>
<td>30</td>
</tr>
<tr>
<td></td>
<td>MILLER</td>
<td>10</td>
</tr>
<tr>
<td></td>
<td>TURNER</td>
<td>30</td>
</tr>
<tr>
<td></td>
<td>ALLEN</td>
<td>30</td>
</tr>
<tr>
<td>2000 - 3000</td>
<td>CLARK</td>
<td>10</td>
</tr>
<tr>
<td></td>
<td>BLAKE</td>
<td>30</td>
</tr>
<tr>
<td></td>
<td>JONES</td>
<td>20</td>
</tr>
<tr>
<td>3000 - 4000</td>
<td>SCOTT</td>
<td>20</td>
</tr>
<tr>
<td></td>
<td>FORD</td>
<td>20</td>
</tr>
<tr>
<td>5000 - 6000</td>
<td>KING</td>
<td>10</td>
</tr>
</tbody>
</table>

**Concepts**

In a report that aggregates, or collects, data within ranges, values from the database are retrieved and formatted based on an aggregate range that you define. You can even use parameters to specify the range over which the data should be collected.

**Data Relationships**

This report uses two "functions" in its SELECT statement to specify the aggregate range. The functions are \((\text{FLOOR}(\text{SAL}/1000)) \times 1000\), which calculates the lowest salary, and \((\text{CEIL}((\text{SAL}+1)/1000) \times 1000)\), which calculates the highest salary. The columns that receive the values of these functions are placed into a break group to produce the control break format of this example report.

**Layout**

This report uses the Group Left layout style.
Example Scenario
In this example, you will build both a paper and JSP-based Web report that collects and displays names of all employees whose salaries fall within the range of 0 to 999, then collects and displays all employees whose salaries fall within the range of 1000 to 1999, and so on. You will be able to modify this report to display any aggregate range you need.

As you build this example report, you will:

- Create a Query and the Layout using the Report Wizard to create a data model and layout for both the paper and Web reports.
- Modify the Web Source of Your JSP Report to generate the JSP-based Web report.

To see a sample report that aggregates data within ranges, open the examples folder named aggregatingdata, then open the Oracle Reports example named aggregatingdata.rdf. For details on how to open it, see "Accessing the Example Reports" in the Preface.

30.1 Prerequisites for This Example
To build the example in this chapter, you must have access to the SCOTT sample schema provided with the Oracle Database. If you do not know if you have access to this sample schema, contact your database administrator.

30.2 Create a Query and the Layout
The steps in this section will show you how to build a simple data model and report layout in the Report Wizard, which you can then use to generate either a JSP-based Web report or a paper report. In the next section, you will modify the JSP so that the appropriate information displays in your Web report.

When you are creating a single-query report, such as this one, you can use the Report Wizard to create the data model and layout simultaneously.

To create a data model and layout:
1. Launch Reports Builder (or, if already open, choose File > New > Report).
2. In the Welcome or New Report dialog box, select Use the Report Wizard, then click OK.
3. If the Welcome page displays, click Next.
4. On the Report Type page, select Create both Web and Paper Layout, then click Next.
5. On the Style page, type a Title for your report, select Group Left, then click Next.
6. On the Data Source page, click SQL Query, then click Next.
7. On the Data page, enter the following SELECT statement in the Data Source definition field:

   ```sql
   SELECT (FLOOR(SAL/1000)) * 1000 BOTTOM, 
   CEIL((SAL+1)/1000) * 1000 TOP, 
   ENAME, 
   DEPTNO 
   FROM EMP 
   ORDER BY 1, 2, SAL
   ```
Note: You can enter this query in any of the following ways:

- Copy and paste the code from the provided text file called aggregatingdata_code.txt into the Data Source definition field.
- Click Query Builder to build the query without entering any code manually.
- Type the code in the Data Source definition field.

8. Click Next.

Note: If you are not already connected to a database, you will be prompted to connect to the database when you click Query Builder or Next. Ensure that you connect to a database that has the appropriate schema for this example. Section 30.1, "Prerequisites for This Example" describes the sample schema requirements for this example.

9. On the Groups page, click the following fields in the Available Fields list and click the right arrow (>) to move them to the Group Fields list, then click Next:
   - BOTTOM
   - TOP

10. On the Fields page, click the double right arrows (>>) to move all of the fields to the Displayed Fields list, then click Next.

11. On the Totals page, click Next.


13. On the Template page, select Predefined Template and click Beige, then click Finish to display your report output in the Paper Design view. It should look something like this:

![Figure 30–2  Paper Design view for the aggregating data report](image)

<table>
<thead>
<tr>
<th>Bottom</th>
<th>Top</th>
<th>Ename</th>
<th>Deptno</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>1000</td>
<td>SMITH</td>
<td>20</td>
</tr>
<tr>
<td></td>
<td></td>
<td>JAMES</td>
<td>30</td>
</tr>
<tr>
<td>1000</td>
<td>2000</td>
<td>ADAMS</td>
<td>20</td>
</tr>
<tr>
<td></td>
<td></td>
<td>WARD</td>
<td>30</td>
</tr>
<tr>
<td></td>
<td></td>
<td>MARTIN</td>
<td>30</td>
</tr>
<tr>
<td></td>
<td></td>
<td>MILLER</td>
<td>10</td>
</tr>
<tr>
<td></td>
<td></td>
<td>TURNER</td>
<td>30</td>
</tr>
<tr>
<td></td>
<td></td>
<td>ALLEN</td>
<td>30</td>
</tr>
<tr>
<td>2000</td>
<td>3000</td>
<td>CLARK</td>
<td>10</td>
</tr>
<tr>
<td></td>
<td></td>
<td>BLAKE</td>
<td>30</td>
</tr>
<tr>
<td></td>
<td></td>
<td>JCNES</td>
<td>20</td>
</tr>
<tr>
<td>3000</td>
<td>4000</td>
<td>SCOTT</td>
<td>20</td>
</tr>
<tr>
<td></td>
<td></td>
<td>FORD</td>
<td>20</td>
</tr>
<tr>
<td>5000</td>
<td>6000</td>
<td>KING</td>
<td>10</td>
</tr>
</tbody>
</table>
14. In the Paper Design view, click the text **Bottom** and change the text to **Salary Range**.

15. Delete the text **Top**.

---

**Note:** You can also modify the other column headers to make the text more meaningful.

---

16. Click the Paper Layout button in the toolbar to display the Paper Layout view. The layout currently looks like this:

*Figure 30–3  Paper Layout view of the Aggregating Data report*

<table>
<thead>
<tr>
<th>Salary Range</th>
<th>Ename</th>
<th>Deptno</th>
</tr>
</thead>
<tbody>
<tr>
<td><em>f_bottom</em></td>
<td></td>
<td></td>
</tr>
<tr>
<td><em>f_top</em></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

17. In the Paper Layout view, click the Flex Off button in the toolbar to set Flex mode off.

18. Click the right edge of the *f_bottom* frame and drag it to the left about 0.5 inches (1.5 centimeters) to make room between the *f_bottom* and *f_top* fields.

**Tip:** To find objects in the Paper Layout view, you can use the Object Navigator. When you click an item name in the Object Navigator, the corresponding object is selected in the Paper Layout view.

19. Click the Text tool in the tool palette.

20. Drag a boilerplate text object between *f_bottom* and *f_top*, then type "-" in the text box. The layout should now look like this:

*Figure 30–4  Paper Layout view with new boilerplate text*

<table>
<thead>
<tr>
<th>Salary Range</th>
<th>Ename</th>
<th>Deptno</th>
</tr>
</thead>
<tbody>
<tr>
<td><em>f_bottom</em></td>
<td>-</td>
<td><em>_ename</em></td>
</tr>
<tr>
<td><em>f_top</em></td>
<td></td>
<td><em>_deptno</em></td>
</tr>
</tbody>
</table>

21. Now, click the Run Paper Layout button in the toolbar to display your report. It should look something like this.
22. Save your report as aggregatereport_your_initials.rdf.

23. Take a look at the data model of your report. You can use this data model to generate either a paper report or a JSP-based Web report. To view the data model, click the Data Model button in the toolbar. Your data model should look something like this:

Note: Notice how the report displays the employee names per salary range, hence aggregating the data.

<table>
<thead>
<tr>
<th>Salary Range</th>
<th>Name</th>
<th>Dept</th>
</tr>
</thead>
<tbody>
<tr>
<td>0 - 1000</td>
<td>SMITH</td>
<td>20</td>
</tr>
<tr>
<td></td>
<td>JAMES</td>
<td>30</td>
</tr>
<tr>
<td>1000 - 2000</td>
<td>ADAMS</td>
<td>20</td>
</tr>
<tr>
<td></td>
<td>WARD</td>
<td>30</td>
</tr>
<tr>
<td></td>
<td>MARTIN</td>
<td>30</td>
</tr>
<tr>
<td></td>
<td>MILLER</td>
<td>10</td>
</tr>
<tr>
<td></td>
<td>TURNER</td>
<td>30</td>
</tr>
<tr>
<td></td>
<td>ALLEN</td>
<td>30</td>
</tr>
<tr>
<td>2000 - 3000</td>
<td>CLARK</td>
<td>10</td>
</tr>
<tr>
<td></td>
<td>BLAKE</td>
<td>30</td>
</tr>
<tr>
<td></td>
<td>JONES</td>
<td>20</td>
</tr>
<tr>
<td>3000 - 4000</td>
<td>SCOTT</td>
<td>20</td>
</tr>
<tr>
<td></td>
<td>FORD</td>
<td>20</td>
</tr>
<tr>
<td>5000 - 6000</td>
<td>KING</td>
<td>10</td>
</tr>
</tbody>
</table>
30.3 Modify the Web Source of Your JSP Report

Now that you have created your paper report layout, you will now learn how to take the same report and generate a JSP-based Web report that looks the same as your paper report.

To modify your JSP-based Web report:

1. Save your report, aggregatesreport_your_initials.rdf as a JSP under the same name (aggregatereport_your_initials.jsp).
2. Click the Web Source button in the toolbar to display the Web Source view.
   In the Web Source, you need to change the column titles to match those of the paper report.
3. In the Web Source view, find the text:
   
   `<th <rw:id id="HBbottom" asArray="no"/> class="OraColumnHeader"> Bottom </th>`

   **Tip:** Choose Edit > Find and Replace, then type "bottom" in the Find what text box.

4. Change the column header to "Salary" so that the line now looks like this:
   
   `<th <rw:id id="HBbottom" asArray="no"/> class="OraColumnHeader"> Salary </th>`

5. The next line of code indicates the header for the "Top" column. Delete the header text so that the line looks like this:
   
   `<th <rw:id id="HBtop" asArray="no"/> class="OraColumnHeader"> </th>`

6. Change the other two columns for Ename and Deptno as desired. For example, we changed them to "Name" and "Dept", like so:
   
   `<th <rw:id id="HBename" asArray="no"/> class="OraColumnHeader"> Name </th>`
   `<th <rw:id id="HBdeptno" asArray="no"/> class="OraColumnHeader"> Dept </th>`

7. Save your report as a JSP.
8. Click the Run Web Layout button in the toolbar to display your new JSP-based Web Report in your browser.

---

**Note:** If Netscape 7.0 is your default browser, and the browser does not display, set the registry key HKEY_CURRENT

USERS\Software\Oracle\Toolkit\Tkbrowser to the default

browser location. Ensure that the BrowserName and the BrowserPath

keys reflect the correct values. For example: BrowserName=Netscape

7; BrowserPath=C:\Program

Files\Netscape\Netscape\Netscp.exe.

---

The report should look something like this:
Figure 30–7  Aggregating Data JSP-based Web Report

<table>
<thead>
<tr>
<th>Salary</th>
<th>Name</th>
<th>Dept</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>1000</td>
<td>SMITH 20</td>
</tr>
<tr>
<td>1000</td>
<td>2000</td>
<td>JAMES 30</td>
</tr>
<tr>
<td>2000</td>
<td>3000</td>
<td>ADAMS 20</td>
</tr>
<tr>
<td>3000</td>
<td>4000</td>
<td>WARD 30</td>
</tr>
<tr>
<td>4000</td>
<td></td>
<td>MARTIN 30</td>
</tr>
<tr>
<td>5000</td>
<td>6000</td>
<td>MILLER 10</td>
</tr>
<tr>
<td></td>
<td></td>
<td>TURNER 30</td>
</tr>
<tr>
<td></td>
<td></td>
<td>ALLEN 30</td>
</tr>
<tr>
<td></td>
<td>5000</td>
<td>CLARK 10</td>
</tr>
<tr>
<td></td>
<td>6000</td>
<td>BLAKE 30</td>
</tr>
<tr>
<td></td>
<td></td>
<td>JONES 20</td>
</tr>
<tr>
<td></td>
<td></td>
<td>SCOTT 20</td>
</tr>
<tr>
<td></td>
<td></td>
<td>FORD 20</td>
</tr>
<tr>
<td></td>
<td></td>
<td>KING 10</td>
</tr>
</tbody>
</table>

The report displays, in Web format, the aggregate data you specified. Here, you can see which employees fall into the specified salary ranges.

Note: For information on creating a Parameter Form for a JSP-based Web report, refer to the documented example on the Oracle Technology Network (OTN): on the Oracle Reports page (http://www.oracle.com/technetwork/middleware/reports/overview/index.html), navigate to Learn More and click Getting Started to display the Getting Started with Oracle Reports home page. In the list of topic sections on the left, click Index. In the Collateral Type list, choose Examples, and click Search. In the list of examples that displays, click Building a JSP-based Web Report with a Parameter Form.

30.4 Summary

Congratulations! You have successfully built a report that aggregates data, for both paper and Web. You now know how to:

- create a report definition that aggregates data.
- modify your report for the Web.

For more information on any of the wizards, views, or properties used in this example, refer to the Oracle Reports online Help, which is available in Oracle Reports Builder or hosted on the Oracle Technology Network (OTN), as described in Section 4.1.1, "Using the Oracle Reports online Help".
In this chapter, you will learn about reports that format output as checks with cash amounts spelled out in words. By following the steps in this chapter, you can generate the report output shown in Figure 31–1.

**Figure 31–1  Check printing report output**

<table>
<thead>
<tr>
<th>Line</th>
<th>Product ID</th>
<th>Product Name</th>
<th>Unit Price</th>
<th>Quantity</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>3106</td>
<td>KB 102/2020</td>
<td>$125.00</td>
<td>51</td>
</tr>
<tr>
<td>2</td>
<td>3114</td>
<td>MB - S900/600+</td>
<td>$86.00</td>
<td>43</td>
</tr>
<tr>
<td>3</td>
<td>3123</td>
<td>PS 220V/ID</td>
<td>$79.00</td>
<td>47</td>
</tr>
<tr>
<td>4</td>
<td>3129</td>
<td>Sound Card STD</td>
<td>$41.00</td>
<td>47</td>
</tr>
</tbody>
</table>

**Concepts**

To spell out the value of a check, you use a PL/SQL function to split the number into its constituent numerals, then use a formula column to combine the words into the spelled-out cash amount.
Data Relationships

- This report uses two linked queries. The first query retrieves the information necessary for the check, and the second query retrieves the order details that will be printed on the check stub.
- One of the queries you will create assumes that the numbers to be spelled are stored in the TOTAL column of the ORDERS table. The text of the spelled-out number will be fetched from the table called Lookup, and returned in the Thousands_text, Thousands_Symbol, Ones_text, and Decimal_Text columns.

Layout

This report uses a default Form style.

Example Scenario

In this example, you will use the Report Wizard to create your basic report definition. You will create a PL/SQL function that spells out the numerical value of the check amount. You will also create a formula column that formats the dollar amounts on your checks. You will import an image of a blank check image, and use the tools in the Paper Layout and Paper Design views to rearrange the fields in your report according to how you want them to display on the resulting check printing report. You will also use these tools to create a stub for every check.

As you build this example report, you will:

- Create a Report Using the Report Wizard to create a simple form report.
- Create a Formula Column That returns the Spelled-Out Cash Amounts using the PL/SQL Editor and the Data Model view.
- Create a Query That Returns the Items in the Order using the Data Model view to create a second query and link the two queries together.
- Import a Check Image and Arrange Fields for Printing using the Paper Layout view to import a blank check image and add fields necessary for printing the check and check stub. Use the Paper Design view to arrange the new fields on the blank check image.
- Create a Check Stub With Payment Information and Order Details using the Paper Design view to create a check stub and the Report Block Wizard to create a simple tabular report that displays order details.

Note: Many of the concepts in this example are used in the following example reports:

- This example, where you import an image of a check and use it as a guide to position fields in the Paper Layout view. In addition, you learn how to create a PL/SQL function that returns spelled-out numerical values.
- Chapter 32, "Building a Report Using a Preprinted Form", where you learn formatting techniques for printing reports on preprinted forms when you do not have access to a computer readable version of the forms. Such reports must be designed so that the data prints in exact positions on the form.
- Chapter 33, "Building an Invoice Report", where you import an image of an invoice and use it as a guide to position fields in the Paper Layout view.
To see a sample report where the cash amounts are spelled out, open the examples folder named spellcash, then open the Oracle Reports example named spellcash.rdf. For details on how to open it, see "Accessing the Example Reports" in the Preface.

31.1 Prerequisites for This Example

To build the example in this chapter, you must have access to the Order Entry sample schema provided with the Oracle Database. If you do not know if you have access to this sample schema, contact your database administrator.

31.2 Create a Report Using the Report Wizard

The steps in this section will show you how to use the Report Wizard to create a simple report definition.

**To create a report definition:**

1. Launch Reports Builder (or, if already open, choose File ➤ New ➤ Report).
2. In the Welcome or New Report dialog box, select Use the Report Wizard, then click OK.
3. If the Welcome page displays, click Next.
4. On the Report Type page, select Create Paper Layout Only, then click Next.
5. On the Style page, type a Title for your report, select Form, then click Next.
6. On the Data Source page, click SQL Query, then click Next.
7. On the Data page, enter the following SELECT statement in the Data Source definition field:
   
   ```
   SELECT ALL ORDERS.ORDER_ID, TO_CHAR(ORDERS.ORDER_DATE, 'DD-MON-YYYY') ORDER_DATE, ORDERS.CUSTOMER_ID, ORDERS.ORDER_TOTAL, CUSTOMERS.CUST_FIRST_NAME || ' ' || CUSTOMERS.CUST_LAST_NAME CUSTOMER_NAME, CUSTOMERS.CUST_ADDRESS, (ROWNUM + 1000) AS CHECK_NO FROM ORDERS, CUSTOMERS WHERE CUSTOMERS.CUSTOMER_ID = ORDERS.CUSTOMER_ID ORDER BY ORDERS.ORDER_ID ASC
   ```

   **Note:** You can enter this query in any of the following ways:
   
   - Copy and paste the code from the provided text file called spellcash_code.txt into the Data Source definition field.
   - Click Query Builder to build the query without entering any code manually.
   - Type the code in the Data Source definition field.

8. Click Next.
Create a Formula Column That returns the Spelled-Out Cash Amounts

Note: If you are not already connected to a database, you will be prompted to connect to the database when you click Query Builder or Next. Ensure that you connect to a database that has the appropriate schema for this example. Section 31.1, "Prerequisites for This Example" describes the sample schema requirements for this example.

9. On the Fields page, click the double right arrows (>>) to move all of the fields to the Displayed Fields list, then click Next.

10. On the Totals page, click Next.

11. On the Labels page, change the labels and field widths as follows, then click Next:

<table>
<thead>
<tr>
<th>Fields</th>
<th>Labels</th>
<th>Width</th>
</tr>
</thead>
<tbody>
<tr>
<td>ORDER_ID</td>
<td>Order No.</td>
<td>5</td>
</tr>
<tr>
<td>ORDER_DATE</td>
<td>Order Date</td>
<td>12</td>
</tr>
<tr>
<td>CUSTOMER_ID</td>
<td>Customer No.</td>
<td>3</td>
</tr>
<tr>
<td>ORDER_TOTAL</td>
<td>Order Total</td>
<td>15</td>
</tr>
<tr>
<td>CUSTOMER_NAME</td>
<td>Customer</td>
<td>40</td>
</tr>
<tr>
<td>C_STREET_ADDRESS</td>
<td>[blank]</td>
<td>40</td>
</tr>
<tr>
<td>C_POSTAL_CODE</td>
<td>[blank]</td>
<td>5</td>
</tr>
<tr>
<td>C_CITY</td>
<td>[blank]</td>
<td>20</td>
</tr>
<tr>
<td>C_STATE_PROVINCE</td>
<td>[blank]</td>
<td>3</td>
</tr>
<tr>
<td>C_COUNTRY_ID</td>
<td>[blank]</td>
<td>3</td>
</tr>
<tr>
<td>CHECK_NO</td>
<td>Check No.</td>
<td>5</td>
</tr>
</tbody>
</table>

12. On the Template page, select No Template, then click Finish to preview your report output in the Paper Design view.

Since you have only created the initial report definition, the formatting will not display like a check. It should look something like this:

Figure 31–2  Paper Design view of the simple report

Order No. 2854 Order Date 14-JUL-2000 Customer No. 104 Order Total 453.57
Customer Harrison Sutherland 6445 Bay Harbor Ln
46754 Indianapolis IN 88 Check No. 1016

13. Save your report as spellcash_your_initials.rdf.

31.3 Create a Formula Column That returns the Spelled-Out Cash Amounts

The steps in this section will show you how to create a formula column that is based on a function. The function you create will return verbal or word value for the numerical value of the check. You will then create a formula column that will spell out
Create a Formula Column That returns the Spelled-Out Cash Amounts

the numerical value in the designated currency. In this case, we will use dollars and cents.

31.3.1 Create a PL/SQL function

In this section, you will create a function that simply returns the check amount in word format, such as "twenty-four sixty-five." The formula column you create in the next section will use the information retrieved by this function to spell out the cash amounts on your checks.

To create a PL/SQL function:

1. In the Object Navigator, under your report name, double-click Program Units.
2. In the New Program Unit dialog box, type Spell in the Name box.
3. Select Function, then click OK.
4. In the PL/SQL Editor, type the following code:

   ```plsql
   FUNCTION Spell (val number) RETURN CHAR IS
     sp varchar2(100);
   BEGIN
     if val > 0 then
       return(initcap(to_char(to_date(val, 'SSSSS'), 'SSSSSSP')));
     else
       return('');
     end if;
   END;
   ``

   **Note:** You can enter this code by copying and pasting it from the provided text file called spellcash_code.txt into the PL/SQL Editor.

5. Click Compile. If you see any errors, compare your code against the code shown in the image below:

   ![Figure 31–3 PL/SQL Editor displaying the SPELL function](image)

6. When your code successfully compiles, click Close.

   Your new function now displays in the Object Navigator:
Create a Formula Column That returns the Spelled-Out Cash Amounts

31.3.2 Create a formula column in your data model

In this section, you will create a formula column that uses the information retrieved by the Spell function you created in Section 31.3.1, "Create a PL/SQL function". This formula column will use the verbal values of the check amounts and combine the words with the correct currency. For example, the "twenty-four sixty-five" returned by the Spell function will be turned into "twenty-four dollars and sixty-five cents".

To create a formula column:

1. In the Object Navigator, under your report name, double-click the view icon next to the Data Model node to display the Data Model view.

   Your data model should look like this:

   ![Data Model view](image)

2. Resize the G_ORDER_ID box by clicking at the top, then dragging the bottom center resize handle downwards. Your data model should now look something like this:

   ![Data Model view](image)
3. Click the Formula Column tool in the tool palette.

4. Click in the G_ORDER_ID group, in the space you just created, to create a new formula column.

5. Double-click the new formula column object (CF_1) to display the Property Inspector, and set the following properties:
   - Under General Information, set the Name property to SPELLED_AMOUNT.
   - Under Column, set the Datatype property to CHARACTER, and the Width property to 100.
   - Under Placeholder/Formula, click the PL/SQL Formula property field to display the PL/SQL Editor.

6. In the PL/SQL Editor, use the template to enter the following PL/SQL code:

   ```plsql
   function SPELLED_AMOUNTFormula return Char is
     cents number;
     c_str varchar2(80);
     val number;
     begin
       val := :order_total;
       cents := (val mod 1) * 100;
       if cents > 0 then --creates string for cents
         c_str := ' and ' || TO_CHAR(cents) || '/100 Dollars******';
       else
         c_str := ' Dollars******';
       end if;
       if val < 1000 and val > 1 then
         return (initcap(spell(floor(val))) || c_str);
       elsif val > 1000 then
         return(initcap(spell(floor(val/1000))) || ' Thousand ' ||
               spell(floor(val mod 1000)) || c_str);
       else
         return('Zero'||c_str);
   end if;
   end;
   ```
7. **Click Compile.** If you see any errors, compare your code against the code we have provided.

8. **When your code successfully compiles, click Close.**

   Your new formula column, called SPELLED_AMOUNT, now displays in the data model.

**Figure 31–7  Data Model with SPELLED_AMOUNT formula column**

9. **Save your report.**

### 31.4 Create a Query That Returns the Items in the Order

The steps in this section will show you how to manually create a query in the Data Model view that will return the items in the customer’s order. This data retrieved will be used to display the order details in the check stub.

**To manually create a query:**

1. In the Data Model view, click the SQL Query tool in the tool palette, then click an open area in the Data Model view to display the SQL Query Statement dialog box.

2. In the **SQL Query Statement** field, enter the following **SELECT** statement:

   ```sql
   SELECT ALL
   ORDER_ITEMS.LINE_ITEM_ID,
   ORDER_ITEMS.ORDER_ID,
   ```
Create a Query That Returns the Items in the Order

ORDER_ITEMS.PRODUCT_ID,
ORDER_ITEMS.UNIT_PRICE,
ORDER_ITEMS.QUANTITY,
PRODUCT_INFORMATION.PRODUCT_NAME
FROM ORDER_ITEMS, PRODUCT_INFORMATION
WHERE PRODUCT_INFORMATION.PRODUCT_ID=ORDER_ITEMS.PRODUCT_ID
ORDER BY ORDER_ITEMS.LINE_ITEM_ID ASC

Note: You can enter this query in any of the following ways:

- Copy and paste the code from the provided text file called spellcash_code.txt into the SQL Query Statement field.
- Click Query Builder to build the query without entering any code manually.
- Type the code in the SQL Query Statement field.

3. Click OK. Your query displays in the Data Model view, and should look something like this:

Figure 31–8  Data Model with two queries

4. In the Data Model view, click the Data Link tool in the tool palette.

5. In the first query, Q_1, under G_ORDER_ID, click ORDER_ID, then drag the line to ORDER_ID1 in Q_2.

6. Your data model should now look like this:
31.5 Import a Check Image and Arrange Fields for Printing

The steps in this section will show you how to adjust the margins of your check printing report and align the fields with an image of a check. You can scan any check and use its image to lay out the objects of your check report. In this section, we use the image we have provided to you, called blankcheck.jpg. This image is located in the spellcash example folder.

31.5.1 Rearrange the layout objects

Before you can insert the check image, you must first rearrange the layout objects.

To rearrange the layout objects:

1. Click the Paper Layout button in the toolbar to display the Paper Layout view.
   
   The layout currently looks like this:

   ![Paper Layout view of your report](image)

2. Click the Edit Margin button in the toolbar.

3. In the Paper Layout view, click the margin frame (the heavy black line) to select it.

4. At the top of the frame, click the center black resizing square and drag it up, so that the margin is 0.25 inches (0.5 centimeters).

   **Tip:** When you click the center square, notice that a dotted guideline displays while your mouse button is depressed. You can use these guidelines to help place objects exactly where you want them in the Paper Layout view.

   When you are done, it should look something like this:
31.5.2 Import the blank check image

In this section, you will import an image of a blank check. You can use any check you like. For this example, we have provided an image called blankcheck.jpg in the spellcash example directory.

To import the blank check image:
1. While the frame is still selected, choose Insert > Image.
2. In the Import Image dialog box, make sure that File is selected.
3. In the text box next to File, type or browse for the location of the image, blankcheck.jpg, then click OK to display the blank check image in the Paper Layout view.
4. Click the Edit Margin button in the toolbar to return to edit mode. Notice that the image no longer displays.

31.5.3 Set up the check printing fields

The steps in this section will show you how to use the various tools in the Paper Layout view to modify the look and feel of your check report. Here, you will learn how to add and modify layout objects and fields according to how you want them to display on the resulting checks. You will create copies of certain fields that you will then use in Section 31.6, “Create a Check Stub With Payment Information and Order Details” to create the check stub.

To set up the check printing fields:
1. In the Paper Layout view, click the Order No. boilerplate text.
2. Click the Select Parent Frame button in the toolbar.
   The repeating frame called R_G_ORDER_ID should now be selected in the Paper Layout view. You can also look in the Object Navigator, under Paper Layout, to make sure R_G_ORDER_ID is selected.
3. While R_G_ORDER_ID is selected, click and drag the bottom center resize handle to 8.75 inches (22 centimeters), or the bottom of the page.

   Tip: When you click and drag a resize handle in the Paper Layout view, guidelines display along the ruler to help you place your objects. In this case, drag the bottom center resize handle down the page until the horizontal guideline reaches 8.75 inches (22 centimeters).
4. Click the Flex Off button in the toolbar to set Flex mode off.
5. In the Paper Layout view, click F_ORDER_TOTAL, then press CTRL+C on your keyboard.
6. Click in the area below your layout objects and press CTRL+V.

You should see a new field called F_ORDER_TOTAL1. If this field displays on top of the other layout objects, click and drag it down below the other layout objects so that your Paper Layout view now looks something like this:

![Figure 31–12 Partial Paper Layout view with F_ORDER_TOTAL1](image)

7. Copy the F_ORDER_DATE field and paste it below the other fields, so that your layout now looks like this:

![Figure 31–13 Partial Paper Layout view with F_ORDER_DATE1](image)

**Note:** When you copy and paste a field, Reports Builder maintains the size of the field. So, when you copy and paste F_ORDER_DATE, you may not see the full name of the field. While the field is selected, you can click and drag the right border of the field to the right so that you can see the full name of the field, F_ORDER_DATE1.

8. Copy F_CUSTOMER_NAME and paste the field below the other layout objects, so that your layout looks like this:

![Figure 31–14 Partial Paper Layout view with F_CUSTOMER_NAME1](image)

9. Make two copies of F_CHECK_NO by pressing CTRL+C on your keyboard once, then CTRL+V twice.
10. Position these two new fields below the other layout objects, so that your layout looks like this:

Figure 31–15 Partial Paper Layout view with F_CHECK_NO1 and F_CHECK_NO2

Note: Since this field is small, it may be difficult to find. You can use the Object Navigator to find and select the field. When you click a field in the Object Navigator, under Paper Layout, the corresponding field is also selected in the Paper Layout view.

11. Click the Field tool in the tool palette.

12. Draw a field below the other layout objects about 5 inches (12.5 centimeters) long, so that your layout now looks like this:

Figure 31–16 Partial Paper Layout view with F_1 field

Note: We have expanded the size of the two new fields (F_CHECK_NO1 and F_CHECK_NO2) to make them easier to see, but you do not need to resize these fields.

13. While the new field, F_1, is still selected, click the Fill Color tool in the tool palette, and choose No Fill.

14. Click the Line Color tool in the tool palette, and choose No Line.

15. Double-click the field F_1 display the Property Inspector.
16. Set the Name property to F_SPELLED_AMOUNT.

17. Under Field, set the Source property to SPELLED_AMOUNT (the formula column you created in Section 31.3.2, "Create a formula column in your data model").

18. Save your report.

31.5.4 Rearrange the new fields according to the blank check image

The steps in this section will show you how to use the Paper Design view to rearrange the fields you just created. You will use the blank check image we have provided as a guide.

1. Click the Paper Design button in the toolbar to display your report in the Paper Design view.

   **Note:** When you click the Paper Design button while you are in another view (that is, Paper Layout view or Data Model view), Reports Builder runs your query and your layout. If you receive any error messages when you click the Paper Design button, go back to your original view to verify your changes. You can always compare your report against the sample report we have provided, called spellcash.rdf.

You will see your layout objects, as well as the blank check image:

   **Figure 31–17  Partial Paper Design view of the check report**

   ![Partial Paper Design view of the check report](image)

   **Note:** You will see that the preview does not quite look like a check report. The steps in this section will show you how to move your fields so that your report looks like a proper check.

2. In the Paper Design view, position the F_ORDER_TOTAL field in the "Amount" box in the blank check image.

   **Note:** If you closed Reports Builder for any reason and are returning to building this report, make sure you click the Flex Off button in the toolbar so that you can move the fields around in the Paper Design view.
3. Click the Align Right button in the toolbar, so that this portion of the check looks like the following:

Figure 31–18  Amount area on blank check

4. Position the F_CHECK_NO field in the "Check No." box on the blank check, and center-align the text.

5. Position the F_ORDER_DATE field in the "Date" box on the blank check, and center-align the text.

6. Position the F_CHECK_NO2 field in the upper right-hand corner of the check image, and right-align the text.

7. Position the F_SPELLED_AMOUNT field next to the "Pay Exactly:" text on the blank check image.

8. Position the F_CUSTOMER_NAME field next to the "Pay To The Order Of:" text on the blank check image.

   The check should now look like this:

Figure 31–19  Check image with fields positioned

9. Save your report.

31.5.5 Modify the look and feel of the check

The steps in this section will show you how to change the font, alignment, and formatting of the data on your check.

To modify the look and feel of the check:

1. In the Paper Design view, choose Edit > Select All (or press CTRL+A).

2. Choose Format > Font.

3. In the Font dialog box, choose Arial font, Regular style, Size 10, then click OK.

4. In the Paper Design view, click anywhere to deselect all the objects.

   Tip:  If you have trouble deselecting the objects, go to the Object Navigator and click any item. The objects that were selected in the Object Navigator should display as deselected.
5. In the Paper Design view, click **F_CHECK_NO2** (the check number in the upper right-hand corner of the check) and change the font to Arial, Bold, 12 point.

6. Click the **F_ORDER_TOTAL** field (the number in the Amount box on the check).

7. Click the Currency button in the toolbar, then click the Commas button.

8. While **F_ORDER_TOTAL** is still selected, click the Add Decimal Place button in the toolbar twice, so that the amount now displays like this: $46,257.00.

9. Choose **Tools > Property Inspector** to display the Property Inspector for **F_ORDER_TOTAL**.

10. Under Field, next to the Format Mask property, add to the beginning of the existing format mask "****", then close the Property Inspector.
    
    The amount should now display like this: ****$46,257.00.

11. Select the **F_CUSTOMER_NAME** and **F_SPELLED_AMOUNT** fields by Shift-clicking them, then change the font to Times New Roman, 12 point.

    Your report should now look something like this:

    **Figure 31–20  Formatted Check**

![Formatted Check](image)

**Note:** You will notice that the other boilerplate text is still overlaying the image. We will rearrange this text later in the chapter.

12. Save your report.

### 31.6 Create a Check Stub With Payment Information and Order Details

When you create a check printing report, you will sometimes want to create a check "stub" that contains the payment information on the check, as well as the details of the order. The steps in this section will show you how to create a check stub that contains the payee, amount, date, check number, and other payment information.

You will then use the information retrieved by the second query in your data model to print a simple tabular report on the check stub that displays the order information associated with the check.

#### 31.6.1 Create a check stub in the Paper Design view

The steps in this section will show you how to use the tools in the Paper Design view to create a check stub for your check report. You will rearrange the fields you created
in the previous section so that every time you run the report, a corresponding check stub will display for every check.

You will also create guidelines in the Paper Design view to help you align the check stub information with the data in the check report.

**To create a check stub:**

1. Click the Flex Off button in the toolbar.
2. Click in the left, vertical ruler and drag your mouse to the right, so that the line is flush with the text "Pay Exactly."
3. When you release your mouse button, you will notice that a guideline displays, like the one in the following image:

   ![Figure 31–21 Partial Paper Design view of the check report with horizontal guideline](image)

   **Note:** The guideline is a broken black line spanning across this image, to the right of "Pay Exactly."

4. Click the Order No. boilerplate object (located in the upper left-hand corner of the check) and position it along the new guideline, and below the check image at 3.25 inches (8.5 centimeters), like this:
5. Create another vertical guideline that is aligned next to the first one.

6. Click the F_ORDER_ID field (in the above image, it is the field with "2354") and position it next to the Order No. field, like this:

![Figure 31–23  Order No. and F_ORDER_ID fields in the Paper Design view](image)

**Note:** You can always select your fields in the Object Navigator, under Paper Layout > Main Section > Body, and these fields will appear selected in the Paper Design view.

7. Now, click the Order Date boilerplate text and position it directly below "Order No.", like this:

![Figure 31–24  Order Date field in the Paper Design view](image)

8. Click F_ORDER_DATE1 (the copy you made of the F_ORDER_DATE field), which you can locate using the Object Navigator, and position the field next to the Order Date boilerplate text, like this:
9. Position the **Order Total** boilerplate text directly below the **Order Date** boilerplate text.

10. Position the **F.ORDER TOTAL1** field next to the **Order Total** boilerplate text.

11. Position the **Check No.** boilerplate text directly below the **Order Total** boilerplate text.

12. Position **F.CHECK_NO1** next to the **Check No.** boilerplate text.

The check stub should now look like this:

**Figure 31–26  Partial check stub in Paper Design view**

<table>
<thead>
<tr>
<th>Order No.</th>
<th>2354</th>
</tr>
</thead>
<tbody>
<tr>
<td>Order Date</td>
<td>15-JUL-2000</td>
</tr>
<tr>
<td>Order Total</td>
<td>45257</td>
</tr>
<tr>
<td>Check No.</td>
<td>1016</td>
</tr>
</tbody>
</table>

13. Create another pair of vertical guidelines that are aligned with the box containing the date, amount, and check number. The guidelines should appear here:

**Figure 31–27  Second vertical guideline in the Paper Design view**

**Note:** To create this guideline, click in the left-hand ruler, then drag your mouse until the line is aligned to the left of box containing Date, Check No., and Amount.

14. Click the **Customer** boilerplate text, and position it so that it is vertically aligned with the second guideline, and horizontally aligned with the **Order No.** text (at 3.25 inches (8.5 centimeters)), like this:
Create a Check Stub With Payment Information and Order Details

- Figure 31–28  **Customer field in the Paper Design view**

  | Order No. | 2354 | Customer |
  | Order Date | 15-JUL-2000 |  |
  | Order Total | 46257 |  |
  | Check No. | 1016 |  |

15. Position the **F_CUSTOMER_NAME1** field next to the **Customer** boilerplate text so that these layout objects look like this:

- Figure 31–29  **Customer and F_CUSTOMER_NAME1 fields**

  Customer  Harrison Sutherland

**Tip:** If you have difficulty fitting the **F_CUSTOMER_NAME1** field into the provided space, you may need to resize the field. To do so, select the field, then drag the right middle resize handle to the left, making sure that there is still enough space for the customer name (Harrison Sutherland).

16. Position the **F_C_STREET_ADDRESS** field directly below **F_CUSTOMER_NAME1**.

17. Position **F_C_CITY** directly below **F_C_STREET_ADDRESS**.

18. Position the **F_C_STATE_PROVINCE** field next to **F_C_CITY**.

19. Position the **F_C_POSTAL_CODE** field next to **F_C_STATE_PROVINCE**.

20. Position the **F_C_COUNTRY_ID** field next to **F_C_POSTAL_CODE**.

21. Position the **F_CUSTOMER_ID** field directly below the **F_C_CITY** field.

22. Position the **Customer No. boilerplate text (B_CUSTOMER_ID)** directly to the left of the **F_CUSTOMER_ID** field, so that this portion of the check stub should now look like this:

- Figure 31–30  **Partial check stub in the Paper Design view**

  | Order No. | 2354 | Customer | Harrison Sutherland |
  | Order Date | 15-JUL-2000 |  | 445 Bay Harbor Ln |
  | Order Total | 46257 |  | Indianapolis IN 46254 US |
  | Check No. | 1016 | Customer No. | 04 |

23. Now, let us format the information you have just added. Select the following boilerplate text objects in the check stub:

- Order No.
- Order Date
- Order Total
- Check No.
- Customer
- Customer No.

24. Change the font to Bold, then right-align the text.
25. Click F.ORDER_TOTAL1, then click the Currency button and the Commas button in the toolbar.

26. Click the Add Decimals button in the toolbar twice.

Your check stub should now look like this:

*Figure 31–31  Formatted check stub*

<table>
<thead>
<tr>
<th>Order No.</th>
<th>2354</th>
</tr>
</thead>
<tbody>
<tr>
<td>Order Date</td>
<td>16-JUL-2000</td>
</tr>
<tr>
<td>Order Total</td>
<td>$46,257.00</td>
</tr>
<tr>
<td>Check No.</td>
<td>016</td>
</tr>
<tr>
<td>Customer</td>
<td>Harrison Sutherland</td>
</tr>
<tr>
<td></td>
<td>3445 Bay Harbor Ln</td>
</tr>
<tr>
<td></td>
<td>Indianapolis IN 46254 US</td>
</tr>
</tbody>
</table>

27. Save your report.

31.6.2 Add order details to the check stub

In the previous section, you created a check stub that displays the payment information, that is a copy of the information on the check itself. The steps in this section will show you how to add the details of the order to the check stub by creating a simple tabular report. You will use the Report Block Wizard to create the simple tabular report, then format the data in the Paper Design view.

**To add order details:**

1. In the Paper Layout view, click the Report Block tool in the tool palette.
2. Drag a rectangular area for the new layout to display the Report Block Wizard.
3. In the Report Block Wizard, on the Style page, select *Tabular*, then click *Next*.
4. On the Groups page, click G.LINE_ITEM_ID and click *Down* in the *Available Groups* list to specify the Print Direction and move this group to the *Displayed Groups* list, then click *Next*.
5. On the Fields page, click each of the following fields in the *Available Fields* list, then click the right arrow (>) to move them to the *Displayed Fields* list, then click *Next*:
   - LINE_ITEM_ID
   - PRODUCT_ID
   - PRODUCT_NAME
   - UNIT_PRICE
   - QUANTITY
6. On the Labels page, change the labels and field widths as follows, then click *Next*:

<table>
<thead>
<tr>
<th>Fields</th>
<th>Labels</th>
<th>Width</th>
</tr>
</thead>
<tbody>
<tr>
<td>LINE_ITEM_ID</td>
<td>Line</td>
<td>2</td>
</tr>
<tr>
<td>PRODUCT_ID</td>
<td>Product ID</td>
<td>4</td>
</tr>
<tr>
<td>PRODUCT_NAME</td>
<td>Product Name</td>
<td>40</td>
</tr>
<tr>
<td>UNIT_PRICE</td>
<td>Unit Price</td>
<td>4</td>
</tr>
<tr>
<td>QUANTITY</td>
<td>Quantity</td>
<td>4</td>
</tr>
</tbody>
</table>
7. On the Template page, select No template, then click Finish to display your report layout in the Paper Layout view, with the new fields and layout objects displaying below the original layout objects.

8. In the Paper Layout view, make sure the new fields and layout objects are located within the R_G_ORDER_ID repeating frame, and that all the layout objects fit on a single page (within 8.75 inches (22 centimeters)).

9. Click the Paper Design button in the toolbar to run and display your report in the Paper Design view. It should look something like this:

    ![Figure 31–32 Check printing report with non-formatted order details](image)

Since the new report block is not formatted, let us format the data to look like the rest of the report.

10. Shift-click the following new labels, then click the Bold button in the toolbar and change the font to Arial, 10 point:
    - Line
    - Product ID
    - Product Name
    - Unit Price
    - Quantity

11. Click the data under Line (F_LINE_ITEM_ID), then click the Align Center button in the toolbar.

12. Click the data under Unit Price (F_UNIT_PRICE), then click the Align Right button in the toolbar.

13. While the data is still selected, click the Currency button, Commas button, then click the Add Decimal button twice in the toolbar.

14. Click the right resize handle and align the right edge of the data field with the Unit Price label.
15. Click the data under **Quantity** (F_QUANTITY), then click the Align Right button in the toolbar, then resize the field so that the right edge of the data field is aligned with the **Quantity** label.

16. Save your report.

Your report should now look like this:

**Figure 31–33  Final check report with spelled-out cash amounts and stub**

![Final check report with spelled-out cash amounts and stub](image)

<table>
<thead>
<tr>
<th>Line</th>
<th>Product ID</th>
<th>Product Name</th>
<th>Unit Price</th>
<th>Quantity</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>3106</td>
<td>KB 101/EN</td>
<td>$45.00</td>
<td>51</td>
</tr>
<tr>
<td>2</td>
<td>3114</td>
<td>MB - S900/650+</td>
<td>$86.00</td>
<td>43</td>
</tr>
<tr>
<td>3</td>
<td>3123</td>
<td>PS 200/10</td>
<td>$79.00</td>
<td>47</td>
</tr>
<tr>
<td>4</td>
<td>3120</td>
<td>Sound Card STD</td>
<td>$41.00</td>
<td>47</td>
</tr>
</tbody>
</table>

**Order No. 2254**  **Customer: Harrison Sutherland**
**Order Date: 14-JUL-2000**  **4445 Bay Harbor Ln**
**Order Total: $403,257.00**  **Indianapolis IN 46254 US**
**Check No.: 1016**  **Customer No.: 104**

**Pay To The Order Of:**  **Harrison Sutherland**
**Pay Exactly:**  **Forty Six Thousand Two Hundred Fifty Seven Dollars***

---

**Note:** You can also compare your results with the example report we have provided, called spellcash.rdf.

### 31.7 Summary

Congratulations! You have successfully built a report with spelled-out cash amounts on the check, as well as the payment and order details on the check stub. You now know how to:

- use the Report Wizard to create a simple report definition.
- use the tools in the Paper Layout view to import a blank check image and add fields to the report.
- create a PL/SQL function that returns spelled-out numbers.
- create a formula column based on a PL/SQL function.
- use the tools in the Data Model view to link two queries.
- use the tools in the Paper Design view to format your check printing report to print on a desired check.
- create a check stub that displays a duplicate of the information on the check.
- use the Report Block Wizard to create a simple tabular report that displays order details on a check stub.
For more information on any of the wizards, views, or properties used in this example, refer to the Oracle Reports online Help, which is available in Oracle Reports Builder or hosted on the Oracle Technology Network (OTN), as described in Section 4.1.1, "Using the Oracle Reports online Help".
In this chapter, you will learn about reports that display output on preprinted forms. By following the steps in this chapter, you can generate the report output shown in Figure 32–1.

**Figure 32–1  Printing reports on preprinted forms**

<table>
<thead>
<tr>
<th>Date</th>
<th>No.</th>
<th>Product Description</th>
<th>Qty.</th>
<th>Price</th>
<th>Amount</th>
</tr>
</thead>
<tbody>
<tr>
<td>07-Nov-99</td>
<td>2022</td>
<td>Extended life Battery, for laptop computers</td>
<td>1</td>
<td>$90.00</td>
<td>$90.00</td>
</tr>
<tr>
<td>3517</td>
<td></td>
<td>Business cards box, capacity 1000. Use form BC110-2, Rev. 3/2000 (hardcopy or online) when ordering and complete all fields marked with an asterisk.</td>
<td>50</td>
<td>$135.00</td>
<td>$6,750.00</td>
</tr>
<tr>
<td>10-Nov-99</td>
<td>3104</td>
<td>Standard PC/AT Enhanced Keyboard [101/102-Key]. Input locales: English (US).</td>
<td>100</td>
<td>$45.00</td>
<td>$4,500.00</td>
</tr>
<tr>
<td>3108</td>
<td></td>
<td>Ergonomic Keyboard with two separate key areas, detachable numeric pad. Key layout: English (US).</td>
<td>40</td>
<td>$75.00</td>
<td>$3,000.00</td>
</tr>
<tr>
<td>3110</td>
<td></td>
<td>Standard PC/AT Enhanced Keyboard [101/102-Key]. Input locales: French.</td>
<td>43</td>
<td>$45.00</td>
<td>$1,935.00</td>
</tr>
<tr>
<td>3117</td>
<td></td>
<td>Standard power supply, 230V, for desktop computers.</td>
<td>4</td>
<td>$79.00</td>
<td>$316.00</td>
</tr>
</tbody>
</table>

**Concepts**

Using the various tools in the Paper Layout view and the Paper Design view, you can format a report to print on preprinted forms.

**Note:** Many of the concepts in this example are used in the following example reports:

- This example, where you learn formatting techniques for printing reports on preprinted forms when you do not have access to a computer readable version of the forms. Such reports must be designed so that the data prints in exact positions on the form.

- Chapter 31, "Building a Check Printing Report with Spelled-Out Cash Amounts", where you import an image of a check and use it as a guide to position fields in the Paper Layout view. In addition, you learn how to create a PL/SQL function that returns spelled-out numerical values.

- Chapter 33, "Building an Invoice Report", where you import an image of an invoice and use it as a guide to position fields in the Paper Layout view.
Data Relationships
This report uses two queries linked in a master/detail relationship. You will create a break in the detail group and two summary columns in the master group.

Layout
This report consists of two partial default layouts, one with a mailing label format and one with a tabular format. You will move fields to the correct positions on the page and restrict the master repeating frame to appearing once per form.

Example Scenario
In this example, you will learn formatting techniques for printing reports on preprinted forms when you do not have access to a computer readable version of the forms. Such reports must be designed so that the data prints in exact positions on the form. This example report consists of data formatted such that all values fall precisely within the corresponding fields of a preprinted sales order. The form is on a standard sized 8.5 inches by 11 inches (21.6 centimeters by 27.9 centimeters) page. The employee name and the customer's name and address must display in the region at the top of the page. The order item details must only display 40 characters. Anything over 40 characters will be placed on a second page of the form. At the end of our example, we add page numbers. This section is optional, as your forms may not require page numbers.

Note: The above measurements are for the form we use in this example. If you do not have access to an online, or computer readable version of your preprinted form, you will need to take these measurements yourself, then use the steps below to create your own report definition.

As you build this example report, you will:

- **Manually Create the Data Model for Your Report** using the tools in the Data Model view to manually create two queries. You will also link the two queries, create a break group, and create two summary columns.

- **Create the Layout for Your Report** using the tools in the Paper Layout view. You will also use the Report Block Wizard to create a mailing label portion of your report and a tabular report that displays the order detail information.

- **Format Your Report in the Paper Design View** using the tools in the Paper Design view to add format masks and adjust the appearance of your report.

- **Add Page Numbers (optional)** using the tools in the Paper Layout view to add page numbering fields.

To see a sample report that uses preprinted forms, open the examples folder named `preprint`, then open the Oracle Reports example named `preprint.rdf`. For details on how to open it, see "Accessing the Example Reports" in the Preface.

32.1 Prerequisites for This Example
To build the example in this chapter, you must have access to the Order Entry sample schema provided with the Oracle Database. If you do not know if you have access to this sample schema, contact your database administrator.
32.2 Manually Create the Data Model for Your Report

The steps in this section will show you how to manually create the data model for your report. Your data model will consist of two linked queries. The first query will retrieve all the customers that have orders in the database. The second query will retrieve all of the order information for each of the customers, and will contain a break group based on the date of each order.

32.2.1 Create the queries

The steps in this section will show you how to manually create two queries in the Data Model view.

**To create the queries:**

1. Launch Reports Builder (or, if already open, choose File > New > Report).
2. In the Welcome or New Report dialog box, select Build a new report manually, then click OK.
3. In the Data Model view that displays, click the SQL Query tool in the tool palette then click in an open area of the Data Model view to display the SQL Query Statement dialog box.
4. In the SQL Query Statement field, enter the following SELECT statement:
   
   ```sql
   SELECT FIRST_NAME||' '||LAST_NAME EMPLOYEE_NAME
   , CUST_FIRST_NAME||' '||CUST_LAST_NAME CUSTOMER_NAME
   , CUST_ADDRESS
   , CUSTOMER_ID
   FROM EMPLOYEES, CUSTOMERS
   WHERE EMPLOYEE_ID = ACCOUNT_MGR_ID
   AND CUSTOMER_ID IN (SELECT UNIQUE(CUSTOMER_ID) FROM ORDERS)
   ORDER BY LAST_NAME, CUST_LAST_NAME
   ```

   **Note:** You can enter this query in any of the following ways:
   
   - Copy and paste the code from the provided text file called preprint_code.txt into the SQL Query Statement field.
   - Click Query Builder to build the query without entering any code manually.
   - Type the code in the SQL Query Statement field.

5. Click OK.

   **Note:** If you are not already connected to a database, you will be prompted to connect to the database when you click Query Builder or Next. Ensure that you connect to a database that has the appropriate schema for this example. Section 32.1, "Prerequisites for This Example" describes the sample schema requirements for this example.

6. If the Connect dialog box displays, type the connection information for the database where the Order Entry sample schema resides, then click Connect.

   The query displays in the Data Model view, and should look something like this:
Manually Create the Data Model for Your Report

Publishing Reports to the Web with Oracle Reports Services

**Figure 32–2 Data Model view of the first query**

7. Right-click the query (Q_1), then choose **Property Inspector** from the pop-up menu.

8. In the Property Inspector, under **General Information**, set the Name property to Q_CUSTOMER.

9. Double-click the group (G_EMPLOYEE_NAME) to display the Property Inspector, and set the Name property to G_CUSTOMER.

10. In the Data Model view, click the SQL Query tool in the tool palette to create a second query with the following **SELECT** statement:

    ```sql
    SELECT to_char(ORDER_DATE, 'DD-Mon-YY') ORDER_DATE
    , I.PRODUCT_ID
    , PRODUCT_DESCRIPTION
    , QUANTITY
    , UNIT_PRICE
    , QUANTITY * UNIT_PRICE ITEM_TOTAL
    , CUSTOMER_ID
    FROM ORDERS O, ORDER_ITEMS I, PRODUCTS P
    WHERE O.ORDER_ID = I.ORDER_ID
    AND I.PRODUCT_ID = P.PRODUCT_ID
    ORDER BY ORDER_DATE, I.PRODUCT_ID
    ```

11. Right-click the query object, then choose **Property Inspector** from the pop-up menu.

12. In the Property Inspector, set the Name property to Q_ORDERS.

13. Double-click the new group object to display the Property Inspector.

14. In the Property Inspector, set the Name property to G_ORDER_ITEMS.

Your data model should now look like this:
Figure 32–3  Data Model view with two queries

![Data Model view with two queries](image)

Note:  In Q_CUSTOMER, the second WHERE clause restricts the values returned to only those customers who have current orders. In Q_ORDERS, we have used "to_char" to account for a new datatype, "Datetime." Since this new datatype is not recognized by Oracle Reports, you cannot use format masks on this particular column yet.

15. Save your report as preprint_your_initials.rdf.

32.2.2 Modify your data model

The steps in this section will show you how to modify your data model to link the two queries and to cause the data retrieved to break on a particular column. You will also create several summary columns to calculate information for each order.

To modify your data model:

1. In the Data Model view, click the Data Link tool in the tool palette.

2. Click the CUSTOMER_ID column in the G_Customer group.

3. While holding down your mouse button, drag your cursor to the CUSTOMER_ID1 column in the G_ORDER_ITEMS group and release your mouse button to create a link between the two queries.

4. Now, create a break group by clicking the ORDER_DATE column in the G_ORDER_ITEMS group and dragging it above the group.

Tip: You can select the group or the query title and use the resize handles to modify the look of your data model.

Your data model should now look like this:
5. Click the Summary Column tool in the tool palette, then click in the G_CUSTOMER group to create a summary column. You may want to resize the group so that you can see your summary columns.

6. Double-click the new summary column object (CS_1) to display the Property Inspector, and set the following properties:
   - Under General Information, set the Name property to CS_PAGE_TOTAL.
   - Under Summary, set the Function property to Sum, set the Source property to ITEM_TOTAL, and set the Reset At property to Page.

7. Create another summary column in the G_CUSTOMER group, and set its properties as follows:
   - Under General Information, set the Name property to CS_ORDER_TOTAL.
   - Under Summary, set the Function property to Sum, set the Source property to ITEM_TOTAL, and set the Reset At property to G_CUSTOMER.

Note: These two summary columns calculate the total items per page and the total items in the order for the report.

Your data model is now complete, and should look like this:
32.3 Create the Layout for Your Report

The steps in this section will show you how to create a layout that displays the objects in the desired locations on your preprinted form. You will start by adjusting the margin of your report, then creating the mailing label portion that will print at the top of each page that shows the address information for the customer. You will then create the body of the report, which contains the order information that display the date, order number, description, number, price per item, and total price.

32.3.1 Set up your report layout

Before you can start adding layout objects, you will need to adjust the margin of your layout.

To set up the layout:
1. Click the Paper Layout button in the toolbar to display the Paper Layout view of your report.
2. To make it easier for you to manipulate your layout objects, expand the size of the Paper Layout window.
3. Click the Edit Margin button in the toolbar to view the margin portion of the layout.
4. Using the resize handles, adjust the size of the margin (the solid black bar) to the dimensions of your form. In our example, our form is 8.5 inches by 11 inches (21.6 centimeters by 27.9 centimeters), so we will expand the margin to 8.5 inches (21.6 centimeters) across, and 11 inches (27.9 centimeters) down.

Tip: You can use the corner resize handles to adjust the size of your margin.

8. Save your report.
5. Click the Edit Margin button in the toolbar again to return to the body of the layout.

Now, you are ready to create your report layout.

### 32.3.2 Create an address label for your form

In this section, you will use the Report Block Wizard to create a mailing label for the address section of your preprinted form.

**To create an address label:**

1. In the Paper Layout view, click the Report Block tool in the tool palette.

2. Using the rulers along the edges of the Paper Layout view, drag a rectangle starting at 1 inch (2.5 centimeters) from the left and 0.25 inches (0.5 centimeters) from the top, to 6 inches (15 centimeters) from the left and 1.25 inches (3 centimeters) from the top. Release your mouse button to display the Report Block Wizard.

3. On the Style page of the Report Block Wizard, select Mailing Label, then click Next.

4. On the Groups page, click G_CUSTOMER and click Down in the Available Groups list to specify the Print Direction and move this group to the Displayed Groups list, then click Next.

5. In the Mailing Label Text field, create a mailing label by clicking the appropriate columns and buttons (for example, click EMPLOYEE_NAME in the Available Fields list, then click > and New Line, and so on), so that the Mailing Label Text field looks like this:

   &<EMPLOYEE_NAME>
   &<CUSTOMER_NAME>
   &<C_STREET_ADDRESS>
   &<C_CITY>, &<C_STATE_PROVINCE> &<C_POSTAL_CODE>

   **Note:** For more information on building a mailing label report, see Chapter 6, "Building a Mailing Label Report".

6. Click Next.

7. On the Template page, select No template, then click Finish to display your report layout in the Paper Layout view. It should look something like this:

   **Figure 32–6 Paper Layout view of the initial layout**

8. The region that you just created is a boilerplate object called B_TBP. While this object is selected, view the Object Navigator and notice the new boilerplate object:
While the object is selected, choose **Tools > Property Inspector** to display the Property Inspector (or right-click the object and choose **Property Inspector**).

10. In the Property Inspector, under **General Layout**, set the Horizontal Elasticity property to Variable. This ensures that appropriate space is available for the mailing label text.

11. Save your report.

### 32.3.3 Add the order item details to your report

In this section, you will add a report block that displays the order items and details that correspond to the customer identified in each mailing label. These items and details are required for your preprinted form.

**To add order item details to your report:**

1. In the Object Navigator, click the repeating frame R_G_CUSTOMER that surrounds the boilerplate object B_TBP created in Section 32.3.2, "Create an address label for your form".

2. In the Paper Layout view, with R_G_CUSTOMER selected, use the corner resize handles to adjust the size of the repeating frame to the size of your preprinted form (in our example, 8.5 inches (21.6 centimeters) across and 11 inches (27.9 centimeters) down). Make sure the frame does not extend beyond the single page boundary.

3. Click the Report Block tool in the tool palette.

4. Using the rulers as guides, drag a region 0.25 inches (0.5 centimeters) from the left and 1.5 inches (4 centimeters) from the top, to 8.25 inches (21 centimeters) from the left and 2 inches (5 centimeters) from the top. Release your mouse button to display the Report Block Wizard.


6. On the Groups page, click the following groups and click **Down** in the Available Groups list to specify the Print Direction and move them to the Displayed Groups list, then click Next:
   - G_ORDER_DATE
   - G_ORDER_ITEMS

7. On the Fields page, click the following fields in the Available Fields list and click the right arrow (>) to move them to the Displayed Fields list, then click Next:
8. On the Labels page, remove the label names since they are not required for the preprinted form, and adjust the widths as follows, then click Next:

<table>
<thead>
<tr>
<th>Fields and Totals</th>
<th>Labels</th>
<th>Width</th>
</tr>
</thead>
<tbody>
<tr>
<td>ORDER_DATE</td>
<td>&lt;none&gt;</td>
<td>9</td>
</tr>
<tr>
<td>PRODUCT_ID</td>
<td>&lt;none&gt;</td>
<td>8</td>
</tr>
<tr>
<td>PRODUCT_DESCRIPTION</td>
<td>&lt;none&gt;</td>
<td>40</td>
</tr>
<tr>
<td>QUANTITY</td>
<td>&lt;none&gt;</td>
<td>4</td>
</tr>
<tr>
<td>UNIT_PRICE</td>
<td>&lt;none&gt;</td>
<td>8</td>
</tr>
<tr>
<td>ITEM_TOTAL</td>
<td>&lt;none&gt;</td>
<td>10</td>
</tr>
</tbody>
</table>

**Note:** The Width values are based on the space available on the preprinted form.

9. On the Template page, select No Template, then click Finish to display your report layout in the Paper Layout view. It should look something like this:

*Figure 32–8  Paper Layout view of the preprinted form example with mailing label and order item details*

10. Save your report.

### 32.3.4 Adjust the layout and add summaries

Now that you have added the elements you want displayed on your report, you need to set up the layout so that only records required for the preprinted form display on each page, and that the correct amount of information displays in the available amount of space on the form. Also, the form requires that a summary of each page displays in the same location on the page.
To adjust the layout and add page summaries:

1. In the Object Navigator, click `M_G_ORDER_ITEMS_GRPFR`, as shown in the following image:

   **Figure 32–9 Selected frame in the Object Navigator**

   ![Object Navigator](image1)

   - To adjust the layout and add page summaries:
     - In the Object Navigator, click `M_G_ORDER_ITEMS_GRPFR`, as shown in the following image:
     - In the Paper Layout view, you should see the same object selected, as shown in the following image:
     - In the Object Navigator, double-click the properties icon next to `M_G_ORDER_ITEMS_GRPFR` to display the Property Inspector, and set the following properties:
       - Under **General Layout**, set the Vertical Elasticity property to **Fixed** to ensure that only this area is available for the order items to display.
     - In the Object Navigator, double-click the properties icon next to `R_G_CUSTOMER` to display the Property Inspector, and set the following properties:
       - Under **Repeating Frame**, set the Maximum Records per Page property to **1**, to ensure that only one customer's information prints per page.

2. In the Paper Layout view, you should see the same object selected, as shown in the following image:

   **Figure 32–10 Selected repeating frame in the Paper Layout view**

   ![Paper Layout View](image2)

   - In the Object Navigator, double-click the properties icon next to `M_G_ORDER_ITEMS_GRPFR` to display the Property Inspector, and set the following properties:
     - Under **General Layout**, set the Vertical Elasticity property to **Fixed** to ensure that only this area is available for the order items to display.
   - In the Object Navigator, double-click the properties icon next to `R_G_CUSTOMER` to display the Property Inspector, and set the following properties:
     - Under **Repeating Frame**, set the Maximum Records per Page property to **1**, to ensure that only one customer's information prints per page.
   - In the Object Navigator, double-click the view icon next to the **Paper Layout** node to display the Paper Layout view.
   - In the Paper Layout view, click the Field tool in the tool palette.
   - Draw a region 7 inches (18 centimeters) from the left and 10.25 inches (26 centimeters) from the top, to 8 inches (20 centimeters) from the left and 10.5 inches (27 centimeters) from the top.

   **Note:** This field, as well as the second field you will create, should not be located within the repeating frame called `M_G_ORDER_DATE_GRPFR`. If you cannot fit these fields on the page, resize the repeating frame so that you can place the fields below the repeating frame, but still on the same page.
8. Double-click the new field object (F_1) to display the Property Inspector, and set the following properties:
   ■ Under **General Information**, set the Name property to F_PAGE_TOTAL.
   ■ Under **Field**, set the Source property to CS_PAGE_TOTAL (the summary column you created in Section 32.2, "Manually Create the Data Model for Your Report").

9. Following the steps above, create another field directly below F_PAGE_TOTAL in the Paper Layout view, then set its Name property to F_ORDER_TOTAL and Source property to CS_ORDER_TOTAL.

10. The new layout objects should now look like this:

    ![Figure 32–11  F_PAGE_TOTAL and F_ORDER_TOTAL fields in the Paper Layout view](image)

11. Save your report.

### 32.4 Format Your Report in the Paper Design View

The steps in this section will show you how to preview your report in the Paper Design view, and make a few last-minute tweaks using the tools in the Paper Design view. It is sometimes easier to use the Paper Design view to finish your report, since you can see actual data displayed.

**To format your report in the Paper Design view:**
1. Click the Paper Design button in the toolbar to display the Paper Design view.
2. In the Paper Design view, click the field **F_PRODUCT_DESCRIPTION**.
3. Increase the size of this field as much as possible, given the size of the area on your form.
4. Shift-click to select the four numbered fields, then click the Align Right button in the toolbar.

   **Tip:** If you cannot find this field, you can use the Object Navigator to find the field name and click it. When you select an item in the Object Navigator, the corresponding object is selected in the Paper Design view.
5. At the bottom of the page, Shift-click the two fields (**F_PAGE_TOTAL** and **F_ORDER_TOTAL**), then click the Line Color tool in the tool palette and choose **No Line**.

6. Shift-click the three currency number fields on the right.

7. Click the Currency button in the toolbar to add a dollar sign to the amounts.

8. Click the Commas button to add a comma to values over 999.

9. Click the Add Decimal Place button twice to add two decimal places to the values.

10. In the Object Navigator, Shift-click the following three objects:
   - **B_TBP**
   - **F_ORDER_TOTAL**
   - **F_PAGE_TOTAL**

11. Choose **Tools > Property Inspector** to display the Property Inspector, and set the following properties:
   - Under **Advanced Layout**, set the Print Object On property to All Pages, and set the Base Printing On property to Enclosing Object.

12. In the Paper Design view, adjust the sizes of the fields according to the measurements on your preprinted form.

   Your report should now look like this:

   ![Figure 32–12](image)

   **Figure 32–12** Final preview of your preprinted form report

<table>
<thead>
<tr>
<th>Date</th>
<th>Code</th>
<th>Description</th>
<th>Qty</th>
<th>Price</th>
<th>Ext. Price</th>
</tr>
</thead>
<tbody>
<tr>
<td>07-Nov-95</td>
<td>2523</td>
<td>Extended life battery, for laptop computer</td>
<td>5</td>
<td>$40.00</td>
<td>$200.00</td>
</tr>
<tr>
<td>2537</td>
<td>Business cards box, capacity 1000. Use form BC11-5, Rev. 3/2000 (hardcopy or online) when ordering and complete all fields marked with an asterisk.</td>
<td>19</td>
<td>$193.60</td>
<td>$3,678.40</td>
<td></td>
</tr>
<tr>
<td>10-Nov-95</td>
<td>3106</td>
<td>Standard PC/AT Enhanced Keyboard [301/102-Key].</td>
<td>200</td>
<td>$42.00</td>
<td>$8,400.00</td>
</tr>
<tr>
<td>2100</td>
<td>Keyboard with two separate key areas, detachable numeric pad. Key layout: English (US).</td>
<td>40</td>
<td>$76.00</td>
<td>$3,040.00</td>
<td></td>
</tr>
<tr>
<td>3110</td>
<td>Standard PC/AT Enhanced Keyboard [301/102-Key].</td>
<td>43</td>
<td>$45.00</td>
<td>$1,955.00</td>
<td></td>
</tr>
</tbody>
</table>

**Note:** To see a more complete view of the report, you can open the sample report we have provided, called **preprint.rdf**. To view the report, open the report and click the Run Paper Layout button in the toolbar.

13. When you print your report on to the form, it might look something like this:
Add Page Numbers (optional)

Figure 32–13  Final report printed on a sample preprinted form

<table>
<thead>
<tr>
<th>Date</th>
<th>No.</th>
<th>Product Description</th>
<th>Qty.</th>
<th>Price</th>
<th>Amount</th>
</tr>
</thead>
<tbody>
<tr>
<td>07-Nov-99</td>
<td>2522</td>
<td>Extended life battery, for laptop computers</td>
<td>6</td>
<td>$49.00</td>
<td>$294.00</td>
</tr>
<tr>
<td>05-Nov-99</td>
<td>3106</td>
<td>Standard PC/AT Enhanced Keyboard (101/102-Key)</td>
<td>200</td>
<td>$42.00</td>
<td>$8,400.00</td>
</tr>
<tr>
<td>10-Nov-99</td>
<td>3108</td>
<td>Ergonomic Keyboard with two separate key areas, detachable numeric pad.</td>
<td>40</td>
<td>$176.00</td>
<td>$5,040.00</td>
</tr>
<tr>
<td></td>
<td>3110</td>
<td>Standard PC/AT Enhanced Keyboard (101/102-Key)</td>
<td>43</td>
<td>$145.00</td>
<td>$6,335.00</td>
</tr>
<tr>
<td></td>
<td>3123</td>
<td>Standard power supply, 220V, for desktop computers.</td>
<td>46</td>
<td>$179.00</td>
<td>$8,164.00</td>
</tr>
</tbody>
</table>

Note: The Paper Design view of your report will not look like the image above. We printed our report on a sample preprinted form. The above image is a snapshot of that form.

14. Save your report.

32.5 Add Page Numbers (optional)

Some preprinted forms may require you to print page numbers. The steps in this section will show you how to add page numbers to your output that will display when the number of order items extends beyond a single page.

To add page numbers to your report:

1. Click the Paper Layout button in the toolbar to display the Paper Layout view.
2. Click the Field tool in the tool palette.
3. Draw a small region on your layout 6 inches (15 centimeters) from the left and 0.25 inches (0.5 centimeters) from the top, to 7 inches (18 centimeters) from the left and 0.5 inches (1.5 centimeters) from the top.
4. Double-click the new field object, F_1, to display the Property Inspector, and set the following properties:
   - Under General Information, set the Name property to F_PAGE_NUMBER.
   - Under General Layout, set the Horizontal Elasticity property to Variable.
   - Under Field, set the Source property to Page Number, and set the Visible property to No. Click the Page Numbering property field to display the Page Numbering dialog box.
5. In the Page Numbering dialog box:
   - Clear the Header Section and Trailer Section check boxes, and make sure that the Main Section check box is selected.
   - In the Reset At list, click R_G_Customer.
   - Click OK.
6. In the Paper Layout view, following the steps above to create another field from (7.25, 0.25) to (8.25, 0.5) inches (or (18.5, 0.5) to (21, 1.5) centimeters).
7. Double-click the new field object to display the Property Inspector, and set the following properties:
   - Under **General Information**, set the Name property to F_TOTAL_PAGES.
   - Under **General Layout**, set the Horizontal Elasticity property to Variable.
   - Under **Field**, set the Source property to Total Pages, and set the Visible property to No. Click the Page Numbering property field to display the Page Numbering dialog box.

8. In the Page Numbering dialog box:
   - Clear the **Header Section** and **Trailer Section** check boxes, and make sure that the **Main Section** check box is selected.
   - In the **Reset At** list, click **R_G_Customer**.
   - Click OK.

Now that you have created the page number fields, you need to make them visible.

9. In the Paper Layout view, click the Text tool in the tool palette.

10. Draw a region on your layout 6 inches (15 centimeters) from the left and 1 inch (2.5 centimeters) from the top, to 8 inches (20 centimeters) from the left and 1.25 inches (3 centimeters) from the top.

11. Click inside the rectangle and type **&<F_PAGE_NUMBER> of &<F_TOTAL_PAGES>**.

    **Note:** The "&<F_PAGE_NUMBER>" text will replace that text with the current value of the summary field you just created, which determines the page number of the current page. The "&<F_TOTAL_PAGES>" text will replace that text with the current total number of pages of the report, based on the value of the summary field of the same name.

12. With the text object selected, choose **Tools > Property Inspector** to display the Property Inspector, and set the following properties:
   - Under **General Information**, set the Name property to B_PAGE_NUMBERS.
   - Under **Advanced Layout**, set the Print Object On property to All Pages, and set the Base Printing On property to Enclosing Object.

13. In the Paper Design view, click the Run Paper Layout button in the toolbar to run your report and display it in the Paper Design view.

    Your report should now look like the following image. Notice how Reports Builder calculates that this particular report is one page, thus displays "1 of 1" above the order details.
32.6 Summary

Congratulations! You have successfully built a report that you can print on a preprinted form. You now know how to:

- manually create two queries and link them.
- create a summary column.
- create a break group in your data model.
- use the tools in the Paper Layout view to create your layout.
- use the Report Block Wizard to create a mailing label report.
- use the Report Block Wizard to create a tabular report.
- add page numbering using fields in the Paper Layout view.

For more information on any of the wizards, views, or properties used in this example, refer to the Oracle Reports online Help, which is available in Oracle Reports Builder or hosted on the Oracle Technology Network (OTN), as described in Section 4.1.1, "Using the Oracle Reports online Help".

14. Save your report.
In this chapter, you will learn about reports that display output on invoices. By following the steps in this chapter, you can generate the report output shown in Figure 33–1.

**Figure 33–1 Invoice report output**

**Concepts**

- Invoice reports are master/detail reports with billing amounts that print conditionally. The customer name, address, and related information are derived from the master query (or group, if there is only one query). The line–items come from the detail query. The billing amounts are printed in the page footer.

- This information must all print on specific line and column positions on the preprinted invoice form. To format your information correctly, you will use many of the same techniques as you used in Chapter 32, "Building a Report Using a Preprinted Form".

- As an additional aid to formatting this report, you will link to a TIFF image of the invoice. This will enable you to position your fields more precisely.
Data Relationships
The data for this report is fetched using two queries, linked together in a master/detail relationship. You will also define a break and two summaries.

Layout
This layout is similar to the layout for the preprinted form report, but in this case you will also link to a TIFF image of your form to use as a guide while adjusting the positions of several fields.

Example Scenario
In this example, you will create a report that prints an invoice for each customer, listing the following information:

- standard billing information such as name, address, date, purchase order number, and so on
- a list of items purchased, including item number, description, and price
- the total cost of all items purchased

You will also learn how to import an image of a preprinted form (in this case, a blank invoice image) and use the tools in the Paper Layout view to print your report on this form.

As you build this example report, you will:

- Create a New Report Manually to create a new, empty report.
- Create a Data Model With a Data Link to create two queries with a data link between them.
- Create Summary and Formula Columns to include on the invoice.
- Prepare the Layout for inserting the invoice information.
- Insert Invoice Information by creating new fields for the invoice information, positioning them in the correct locations on the invoice form.

To see a sample invoice report, open the examples folder named invoice, then open the Oracle Reports example named invoice.rdf. For details on how to open it, see "Accessing the Example Reports" in the Preface.
33.1 Prerequisites for This Example
To build the example in this chapter, you must have access to the Order Entry sample schema provided with the Oracle Database. If you do not know if you have access to this sample schema, contact your database administrator.

33.2 Create a New Report Manually
In this case, it is easier to create the data model and layout separately. Hence, we will create an empty report first, then add the queries, and then create the layout.

To create a blank report:
1. Launch Reports Builder (or, if already open, choose File > New > Report).
2. In the Welcome or New Report dialog box, select Build a new report manually, then click OK.

33.3 Create a Data Model With a Data Link
When you create a report with multiple queries, it is typically easier to create all of the queries with the Data Wizard in the Data Model view. In this report, you will create two queries, linked with a group-to-group data link.

To create the queries:
1. In the Data Model view, choose Insert > Query to display the Data Wizard.
2. If the Welcome page displays, click Next.
3. On the Query page, type Q_Order for the Query name, then click Next.
4. On the Data Source page, select SQL Query, then click Next.
5. On the Data page, enter the following SELECT statement in the Data Source definition field:

   ```sql
   SELECT
      ORDER_ID,
      ORDER_DATE,
      ORDER_TOTAL,
      ORDERS.CUSTOMER_ID,
      SALES_REP_ID,
      C1.CUST_FIRST_NAME,
      C1.CUST_LAST_NAME,
      C1.CUST_ADDRESS,
      C1.CUSTOMER_ID,
      C2.CUST_FIRST_NAME,
      C2.CUST_LAST_NAME,
      C2.CUST_ADDRESS,
      C2.CUSTOMER_ID
   FROM ORDERS, CUSTOMERS C1, CUSTOMERS C2
   WHERE ORDERS.CUSTOMER_ID = C1.CUSTOMER_ID AND
   ORDERS.SALES_REP_ID = C2.CUSTOMER_ID
   ```

   This query joins the Orders table to the Customers table for customer information and sales representative information.
6. Click Next.

**Note:** If you are not already connected to a database, you will be prompted to connect to the database when you click *Query Builder* or *Next*. Ensure that you connect to a database that has the appropriate schema for this example. Section 33.1, "Prerequisites for This Example" describes the sample schema requirements for this example.

7. On the Groups page, click *Next*.

8. Click *Finish* to display your first query in the Data Model view.

9. Repeat the steps above for a second query, but this time name your query *Q_Item* and use the following SELECT statement:

   ```sql
   SELECT
   O.ORDER_ID,
   O.LINE_ITEM_ID,
   O.PRODUCT_ID,
   O.QUANTITY,
   O.UNIT_PRICE,
   TRANSLATED_DESCRIPTION,
   P.PRODUCT_ID,
   O.QUANTITY * O.UNIT_PRICE
   FROM ORDER_ITEMS O, PRODUCT_DESCRIPTIONS P
   WHERE O.PRODUCT_ID = P.PRODUCT_ID
   AND P.LANGUAGE_ID = 'US'
   ```

   This query joins Order items to the Product table for product descriptions.

10. In the Data Model view, double-click the title bar of the *G_ORDER_ID* group (for the master query *Q_ORDER*) to display the Property Inspector, and set the following properties:

   - Under *General Information*, set the Name property to *G_ORDER*.

11. Double-click the title bar of the *G_ORDER_ID1* group (for the detail query *Q_ITEM*) to display the Property Inspector, and set the following properties:

   - Under *General Information*, set the Name property to *G_LIST*.

Your data model should now look something like this:

---

**Note:** You can enter this query in any of the following ways:

- Copy and paste the code from the provided text file called `invoice_code.txt` into the *Data Source definition* field.
- Click *Query Builder* to build the query without entering any code manually.
- Type the code in the *Data Source definition* field.

---
To add the data link:

1. In the Data Model view, click the Data Link tool in the tool palette.
2. Click and drag from the ORDER_ID column in the G_ORDER group to the ORDER_ID1 column in the G_LIST group. Notice that a line is drawn from the bottom of the G_ORDER group to the Q_Item query. Labels for ORDER_ID and ORDER_ID1 are created at each end of the line to indicate they are the columns linking G_ORDER to Q_Item.

33.4 Create Summary and Formula Columns

To provide the necessary information for the invoice, you need to create summary and formula columns for subtotal amounts, a total amount, and due dates.

To create the invoice summary and formula columns:

1. Click the Summary Column tool in the tool palette, then click in an open area of the Data Model view to create a summary column.
2. Double-click the new summary column object to display the Property Inspector, and set the following properties:
   - Under General Information, set the Name property to CS_SUB_TOTAL.
   - Under Summary, set the Source property to O_QUANTITY_O_UNIT_PRICE, and set the Reset At property to Page.

This summary is used for subtotal amounts on each page of the invoice.
3. Click the G_ORDER group, and drag the bottom edge handle down to create an empty space at the bottom of the group.
4. Again, click the Summary Column tool in the tool palette, then click in the empty space in the G_ORDER group to create a second summary column.
5. Double-click the new summary column object to display the Property Inspector, and set the following properties:
   - Under General Information, set the Name property to CS_TOTAL.
Under **Summary**, set the Source property to O_QUANTITY_O_UNIT_PRICE and set the Reset At property to G_ORDER.

This summary is used for a total amount of each invoice.

6. Click the Formula Column tool in the tool palette, then click in an open area of the Data Model view to create a formula column.

7. Double-click the new formula column object to display the Property Inspector, and set the following properties:
   - Under **General Information**, set the Name property to CF_DUE_DATE.
   - Under **Column**, set the Datatype property to Date.
   - Under **Placeholder/Formula**, click the PL/SQL Formula property field to display the PL/SQL Editor.

8. In the PL/SQL Editor, use the template to enter the following PL/SQL code:

   ```plsql
   function CF_DUE_DATEFormula return Date is
   today date;
   begin
   select sysdate into today from dual;
   return today + 30;
   end;
   ```

   This formula helps to calculate the due date, which is 30 days after today.

9. Click **Compile**.

10. Click **Close**.

Your data model should now look something like this:

**Figure 33–3  Data Model view with data link, summary, and formula columns**

11. Save the report as invoice_your_initials.rdf.
33.5 Prepare the Layout

The layout for an invoice report is created by importing an image of the invoice form, then creating desired fields and frames on top of the image. First, you need to set up your layout with the invoice form.

To prepare the invoice report layout:
1. Click the Paper Layout button in the toolbar to display the Paper Layout view.
2. In the Paper Layout view, choose Insert > Image, and browse to select the provided file `invdemo.tif`. Position the image at the top left corner of the Paper Layout view.
3. Double-click the new image object to display the Property Inspector.
4. In the Property Inspector, under Advanced Layout, set the Print Object On property to All Pages.
5. In the Object Navigator, expand the Paper Layout node, double-click the properties icon next to Main Section to display the Property Inspector, and set the following properties:
   - Under Section, set the Width property to 11 and the Height property to 8.5 for landscape paper orientation to fit the invoice image.
6. In the Paper Layout view, click the Repeating Frame tool in the tool palette, then drag a repeating frame around the invoice image so that the image falls just inside the repeating frame. The repeating frame that you create should cover the image.
7. Double-click the repeating frame to display the Property Inspector, and set the following properties:
   - Under General Information, set the Name property to R_ORDER.
   - Under Repeating Frame, set the Source property to G_ORDER, the Print Direction property to Down, and the Maximum Records per Page property to 1.
8. Click the Frame tool in the tool palette, then create a frame just inside the borders of the R_ORDER repeating frame.
9. Double-click the frame object to display the Property Inspector, and set the following properties:
   - Under General Information, set the Name property to M_INVOICE.
   - Under Advanced Layout, set the Print Object On property to All Pages.
10. Click the repeating frame, then click the Fill Color tool in the tool palette and choose No Fill. Do the same for the frame. You should now see the invoice image, even though it is still layered behind the frame and repeating frame.

33.6 Insert Invoice Information

You are now ready to create fields on the invoice image to retrieve desired information for the invoice report. When you print the report, the field values will be correctly positioned on the invoice form. As you complete the steps below, use the figure below as a guide (you can also open the provided example report `invoice.rdf` in Reports Builder).
To insert the information for the invoice report:

1. In the Paper Layout view, click the Text tool in the tool palette, then create a boilerplate text object on top of the invoice image, in the area labeled Terms. In the boilerplate text object, type 30 days.

2. Click the Field tool in the tool palette, and create fields on top of the invoice image, in the following areas:

   - **Bill To** (one field for each element of the name and address):
     
     Set Name property to F_FIRST_NAME, Source property to CUST_FIRST_NAME.
     
     Set Name property to F_LAST_NAME, Source property to CUST_LAST_NAME.
     
     Set Name property to F_STREET, Source property to C_STREET_ADDRESS.
     
     Set Name property to F_CITY, Source property to C_CITY.
     
     Set Name property to F_STATE, Source property to C_STATE_PROVINCE.
     
     Set Name property to F_POSTAL, Source property to C_POSTAL_CODE.

   - **Ship To** (one field for each element of the name and address):
     
     Set Name property to F_FIRST_NAME1, Source property to CUST_FIRST_NAME1.
     
     Set Name property to F_LAST_NAME1, Source property to CUST_LAST_NAME1.
     
     Set Name property to F_STREET1, Source property to C_STREET_ADDRESS1.
     
     Set Name property to F_CITY1, Source property to C_CITY1.
     
     Set Name property to F_STATE1, Source property to C_STATE_PROVINCE1.
Set Name property to F_POSTAL1, Source property to C_POSTAL_CODE.

- **Date**: Set Name property to F_TODAY, Source property to Current Date, and Format Mask property to MM/DD/RR.

- **Page**: Set Name property to F_PAGE, Source property to Page Number, and Page Numbering property (in the Page Numbering dialog box) to Reset at: R_ORDER.

- **Purchase Order Number**: Set Name property to F_ORDER_NO, Source property to ORDER_ID.

- **Sales Order Number**: Set Name property to F_ORDER_NO1, Source property to ORDER_ID.

- **Customer Number**: Set Name property to F_CUST_NO, Source property to CUSTOMER_ID.

- **Due Date**: Set Name property to F_DUE_DAY, Source property to CF_DUE_DATE.

- **Salesperson** (2 fields, one for first name, one for last name):
  
  Set Name property to F_SALES_REP_FNAME, Source property to CUST_FIRST_NAME.

  Set Name property to F_SALES_REP_LNAME, Source property to CUST_LAST_NAME.

- **Customer Contact** (2 fields, one for first name, one for last name):
  
  Set Name property to F_SALES_REP_FNAME1, Source property to CUST_FIRST_NAME.

  Set Name property to F_SALES_REP_LNAME1, Source property to CUST_LAST_NAME.

---

**Note**: This example assumes that the customer contact is same person as the sales representative.

---

- **Ship Date**: Set Name property to F_TODAY1, Source property to Current Date, and Format Mask property to MM/DD/RR.

- **Item No.**: Set Name property to F_ITEM_NO, Source property to LINE_ITEM_ID. With the field selected, click the Align Right button in the toolbar.

- **Description** (column has no heading): Set Name property to F_ITEM_DESC, Source property to TRANSLATED_DESCRIPTION.

- **Quantity Ordered**: Set Name property to F_QUANTITY, Source property to QUANTITY. With the field selected, click the Align Right button in the toolbar.

- **Unit Price**: Set Name property to F_UNIT_PRICE, Source property to UNIT_PRICE, and Format Mask property to $NNN,NN0.00. With the field selected, click the Align Right button in the toolbar.

- **Extended Amount**: Set Name property to F_ITEM_PRICE, Source property to O_QUANTITY_O_UNIT_PRICE, and Format Mask property to $NNN,NN0.00. With the field selected, click the Align Right button in the toolbar.

- **Subtotal**: Set Name property to F_SUB_TOTAL, Source property to CS_SUB_TOTAL.
3. Click the Frame tool in the tool palette, and draw a frame around the following fields to group them:

- **Bill To**: F_FIRST_NAME, F_LAST_NAME, F_STREET, F_CITY, F_STATE, and F_POSTAL. Set the Frame's Name property to M_BILL_TO.
- **Ship To**: F_FIRST_NAME1, F_LAST_NAME1, F_STREET1, F_CITY1, F_STATE1, and F_POSTAL1. Set the Frame's Name property to M_SHIP_TO.
- **Salesperson**: F_SALES_REP_FNAME and F_SALES_REP_LNAME. Set the Frame's Name property to M_SALES_REP.
- **Customer Contact**: F_SALES_REP_FNAME1 and F_SALES_REP_LNAME1. Set the Frame's Name property to M_CUST_CONTACT.
- **Item list**: F_ITEM_NO, F_ITEM_DESC, F_QUANTITY, F_UNIT_PRICE, and F_ITEM_PRICE, including all the empty space below these fields to the bottom border of the list area. Set the Frame's Name property to M_ORDER_LIST. This frame have been used to position and size the detail item list repeating frame.

   **Note**: Using a frame ensures that other objects will not be pushed by the variable horizontal size of the name fields.

4. Click the Repeating Frame tool in the tool palette, and draw a repeating frame around the following fields to group them:

- **Item list**: F_ITEM_NO, F_ITEM_DESC, F_QUANTITY, F_UNIT_PRICE, and F_ITEM_PRICE, including just the fields and *not* the empty space below the fields. Set the Repeating Frame's Name property to R_ORDER_LIST, and the Source property to G_LIST.

5. Save and run your report. Adjust the position of objects if necessary to fit to the background of the invoice image. Your final report output should look something like this:
33.7 Summary

Congratulations! You have successfully created an invoice report. You now know how to:

- create two queries with a data link between them.
- add two summary columns and a formula column to the data model to include on the invoice.
- prepare a report layout for adding information onto an image of an invoice.
- create and position fields in the correct locations on an invoice form.

For more information on any of the wizards, views, or properties used in this example, refer to the Oracle Reports online Help, which is available in Oracle Reports Builder or hosted on the Oracle Technology Network (OTN), as described in Section 4.1.1, "Using the Oracle Reports online Help".

---

**Figure 33–5  Final invoice report output**

![Final invoice report output](image-url)
In this chapter, you will learn about reports that rank data in different ways. By following the steps in this chapter, you can generate the report output shown in Figure 34–1.

**Figure 34–1  Tabular report output, ranked by number and percentage of customers**

<table>
<thead>
<tr>
<th>Top 5 Customers</th>
<th>Total Purchase</th>
</tr>
</thead>
<tbody>
<tr>
<td>K + T SPORTS</td>
<td>$46,370.00</td>
</tr>
<tr>
<td>VOLLRYTE</td>
<td>$27,775.50</td>
</tr>
<tr>
<td>SHAPE UP</td>
<td>$9,024.40</td>
</tr>
<tr>
<td>EVERY MOUNTAIN</td>
<td>$7,186.80</td>
</tr>
<tr>
<td>NORTH WOODS HEALTH AND FITNESS SUPPLY CENTER</td>
<td>$6,900.00</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Top 50 Percent of Sales</th>
<th>Total Purchases</th>
</tr>
</thead>
<tbody>
<tr>
<td>K + T SPORTS</td>
<td>$46,370.00</td>
</tr>
<tr>
<td>VOLLRYTE</td>
<td>$27,775.50</td>
</tr>
</tbody>
</table>

**Concepts**

You can create a report that ranks data by comparing it to a user-specified bind parameter. This enables you to rank data in different ways in the same report; for example, by count and by percentage. You can set the ranking criteria at runtime, or let them default to previously specified values.

**Data Relationships**

This report requires one query to fetch the data. To rank the data, you’ll create the following objects:

- A bind parameter that gives you the option of setting the cutoff point at runtime.
- A bind parameter that increments by one each time a record is fetched from the database. The value in this parameter will be compared to the cutoff Bind parameter.
- A customized group filter to include only records within the cutoff value. Using a customized filter rather than a packaged filter enables you to parameterize your cutoff values.

**Layout**

This report uses a tabular layout style, with some modifications.
Example Scenario

In this example, you will create a report that displays the names and total purchases of your top three customers and the top 75% of all customers. Furthermore, you will allow end users of your report to set the ranking criteria (that is, the top $x$ customers and the top $y\%$ of all customers) at runtime.

As you build this example report, you will:

- Create a Data Model and Tabular Layout.
- Create Ranking Logic for Top number of Customers by creating parameters and a group filter to control the ranking criteria.
- Add a Layout Object for a Parameter to display the parameter value in the report output.
- Create a Parameter Form that only displays the parameter you want end users to set.
- Add a Percentage Ranking.

To see a sample ranking report, open the examples folder named ranking, then open the Oracle Reports example named rank.rdf. For details on how to access it, see "Accessing the Example Reports" in the Preface.

34.1 Prerequisites for This Example

To build the example in this chapter, you must have access to the Summit Sporting Goods (SUMMIT) schema. To download the SQL scripts that install the schema, see "Accessing the Data Sources" in the Preface.

34.2 Create a Data Model and Tabular Layout

When you are creating a single-query report, such as this one, you can use the Report Wizard to create the data model and layout simultaneously.

To create a data model and layout:

1. Launch Reports Builder (or, if already open, choose File > New > Report).
2. In the Welcome or New Report dialog box, select Use the Report Wizard, then click OK.
3. If the Welcome page displays, click Next.
4. On the Report Type page, select Create Paper Layout Only, then click Next.
5. On the Style page, type a Title for your report, select Tabular, then click Next.
6. On the Data Source page, click SQL Query, then click Next.
7. On the Data page, enter the following SELECT statement in the Data Source definition field:

   ```sql
   SELECT CUSTNAME CNAME, SUM(AMOUNT) SUM_AMT FROM SALES
   GROUP BY CUSTNAME
   ORDER BY SUM(AMOUNT) DESC
   ```
Create Ranking Logic for Top number of Customers

8. Click Next.

9. On the Fields page, click the double right arrows (>>) to move all of the fields to the Displayed Fields list, then click Next.

10. On the Totals page, click Next.

11. On the Labels page, set the labels and field widths as follows, then click Next:

<table>
<thead>
<tr>
<th>Fields</th>
<th>Labels</th>
<th>Width</th>
</tr>
</thead>
<tbody>
<tr>
<td>CNAME</td>
<td>Customer Name</td>
<td>35</td>
</tr>
<tr>
<td>SUM_AMT</td>
<td>Total Purchases</td>
<td>15</td>
</tr>
</tbody>
</table>

12. On the Template page, click Finish to preview your report output in the Paper Design view. It should look something like this:

![Figure 34–2 Paper Design view for the ranking report](image)

34.3 Create Ranking Logic for Top number of Customers

Now that your report has a data model and layout, you can add the logic to control the number of customers displayed. First, you will create two parameters that the user can enter values for at runtime. Second, you will create a group filter that uses the parameters to control which data is included.
To create parameters and add a group filter:

1. In the Object Navigator, under the Data Model node, click the User Parameters node.

2. Choose Edit > Create to create a new user parameter under the User Parameters node.

3. If the Property Inspector is not already displayed, right-click the new user parameter (P_1), then choose Property Inspector to display the Property Inspector, and set the following properties:
   - Under General Information, set the Name property to CUTOFF_CNT.
   - Under Parameter, set the Datatype property to Number, set the Width property to 1, and set the Initial Value property to 3.

4. Repeat the steps above to create another user parameter, using the following property settings this time:
   - Under General Information, set the Name property to INCR_CNT.
   - Under Parameter, set the Datatype property to Number, set the Width property to 3, and set the Initial Value property to 0.

5. In the Object Navigator, under the Data Model node, expand the Groups node, then double-click the properties icon next to the G_CNAME group to display the Property Inspector, and set the following properties:
   - Under Group, set the Filter Type property to PL/SQL, then click the PL/SQL Filter property field to display the PL/SQL Editor.

6. In the PL/SQL Editor, use the template to enter the following PL/SQL code:

   ```sql
   function G_CNAMEGroupFilter return boolean is
   begin
     :incr_cnt:=:incr_cnt+1;
     if :incr_cnt <= :cutoff_cnt then
      return (TRUE);
     else
      return(FALSE);
     end if;
   end;
   
   Note: You can enter this code by copying and pasting it from the provided text file called rank_code.txt. This code is for the Group Filter.
   
7. Click Compile.

8. Click Close.

   This filter increments the counter by 1 each time a record in G_CNAME is fetched, then compares the counter’s value to the specified cutoff. When the counter exceeds the cutoff, no more records are fetched.
Tip: Notice that, if the Paper Design view is still open while you add this logic, the report now returns no records in the Paper Design view. To fix this issue, you should display one of the other views (for example, the Data Model view) and then come back to the Paper Design view. You will be prompted by the Runtime Parameter Form to enter values for the two parameters, INCR_CNT and CUTOFF_CNT.

9. Click the Run Paper Layout button in the toolbar to display the Runtime Parameter Form, which enables you to change the default values for CUTOFF_CNT and INCR_CNT.

10. Click the Run Report button to display the report output in the Paper Design view.

11. Save your report as rank_your_initials.rdf.

Figure 34–3 Tabular report output restricted to top three customers

<table>
<thead>
<tr>
<th>Customer Name</th>
<th>Total Purchase</th>
</tr>
</thead>
<tbody>
<tr>
<td>K + T SPORTS</td>
<td>4500.0</td>
</tr>
<tr>
<td>YOLLYNIE</td>
<td>22175.5</td>
</tr>
<tr>
<td>SHAPE UP</td>
<td>9024.4</td>
</tr>
</tbody>
</table>

34.4 Add a Layout Object for a Parameter

As a way for users to quickly tell the number of customers displayed in the list, you need to display the value of CUTOFF_CNT in the report. To perform this task, you will create a boilerplate text object that references the parameter.

1. In the Object Navigator, double-click the view icon next to the Paper Layout node to display the Paper Layout view.

2. Position the Paper Layout view and Object Navigator side-by-side so that they are visible simultaneously.

3. In the Object Navigator, in the Find field, type M_G_CNAME_GRPFR.

4. Click M_G_CNAME_GRPFR in the Object Navigator to select it in the Paper Layout view.

5. Click the title bar of the Paper Layout view to make it the active window.

6. Select M_G_CNAME_GRPFR and all of its contents by press CTRL-A on your keyboard.

   Note: You can also use the Find field in the Object Navigator to locate specific objects. When you select an item in the Object Navigator while the Paper Layout view is displayed, the corresponding object is selected in the Paper Layout view.

7. Use the down arrow key to move the items down about 1 inch (2.5 centimeters).

8. From the font lists in the toolbar, choose Arial (Western), point size 10.

9. Click the Text tool in the tool palette.
10. Click directly above the label **Customer Name** to create a new boilerplate text object and type the following text:

   Top &CUTOFF_CNT Customers:

11. Move to an open area of the Paper Layout view and click the mouse button to exit text mode. Notice that the text object you just created is still selected, you can now adjust its positioning with the arrow keys.

12. Click the Bold button in the toolbar to make the new text bold.

13. Shift-click the labels **Customer Name** and **Total Purchase** so that they are selected simultaneously with the object you just created.

14. Click the Underline button in the toolbar.

15. Click in an open area of the Paper Layout view to deselect everything.

16. Click **F_SUM_AMT**, then choose **Tools > Property Inspector** to display the Property Inspector, and set the following properties:

   - **Under Field**, set the Format Mask property by typing the following:

     - $NNN,NN0.00

17. Click the Paper Design button in the toolbar to display the Paper Design view. (If the Runtime Parameter Form displays, click the Run Report button in the toolbar.)

**Figure 34–4  Tabular report output with parameter value displayed**

<table>
<thead>
<tr>
<th>Customer Name</th>
<th>Total Purchase</th>
</tr>
</thead>
<tbody>
<tr>
<td>K + T SPORTS</td>
<td>$45,370.00</td>
</tr>
<tr>
<td>VOLLYSITE</td>
<td>$37,775.90</td>
</tr>
<tr>
<td>SHAPE UP</td>
<td>$9124.49</td>
</tr>
</tbody>
</table>

18. Save your report.

### 34.5 Create a Parameter Form

By default, both of your user parameters appear in the Runtime Parameter Form. In reality, you only want users to set CUTOFF_CNT. You do not want them to be able to set INCR_CNT (the amount by which your counter is increased for each record). To prevent users from seeing INCR_CNT on the Runtime Parameter Form, you will build your own Parameter Form.

**To create a Parameter Form:**

1. Choose **Tools > Parameter Form Builder**.
2. In the Parameter Form Builder dialog box, scroll down the list of parameters until you find **INCR_CNT**.
3. Click **INCR_CNT** to deselect it.
4. Change the label for **CUTOFF_CNT** to:

   # of Top Customers:

5. Click **OK**.
6. Click the Run Paper Layout button in the toolbar.
7. In the Runtime Parameter Form, type a value for # of Top Customers, then click the Run Report button in the toolbar. You should now see as many records as you asked for in the Runtime Parameter Form and they should be in order from largest total purchases to smallest total purchases.

   **Tip:** As an additional exercise, you could now change the Initial Value property of CUTOFF_CNT to see its effect on the Runtime Parameter Form.

8. Save your report.

### 34.6 Add a Percentage Ranking

Another way to rank customers is by percentage of total sales. The idea is the same as ranking by count, but with an important difference. Since you need to fetch all of the data in order to compute a running percent of total summary, you don’t want to use a group filter to weed out data. You need to use a format trigger on the repeating frame to compare the running total to your cutoff parameter.

#### To fetch the data for the percentage calculation:

1. In the Object Navigator, double-click the view icon next to the Data Model node.

2. In the Data Model view that displays, click the SQL Query tool in the tool palette then click in an open area of the Data Model view, somewhere to the right of query Q_1, to display the SQL Query Statement dialog box.

3. In the SQL Query Statement field, enter the following `SELECT` statement:

   ```sql
   SELECT CUSTNAME CNAME2, SUM(AMOUNT) SUM_AMT2
   FROM SALES
   GROUP BY CUSTNAME
   ORDER BY SUM(AMOUNT) DESC
   ```

4. Click OK. Your data model should now look like the following image.

---

**Note:** You can enter this query in any of the following ways:

- Copy and paste the code from the provided text file called `rank_code.txt` (SELECT statement for Percentage Calculation) into the SQL Query Statement field.
- Click Query Builder to build the query without entering any code manually.
- Type the code in the SQL Query Statement field.

---

4. Click OK. Your data model should now look like the following image.
5. Save your report.

**To create a parameter for the percentage cutoff:**

1. In the Object Navigator, under the Data Model node, click the User Parameters node.
2. Choose Edit > Create to create a new user parameter under the User Parameters node.
3. If the Property Inspector is not already displayed, right-click the new user parameter (P_1), then choose Property Inspector to display the Property Inspector, and set the following properties:
   - Under General Information, set the Name property to CUTOFF_PCT.
   - Under Parameter, set the Datatype property to Number, set the Width property to 2, and set the Initial Value property to 75.
4. In the Data Model view, click the group object G_CNAME2, then click and drag the bottom handle down about 0.25 inches (0.5 centimeters) to make the group bigger.
5. Click the Summary Column tool in the tool palette.
6. Click in the empty space beneath SUM_AMT2 to create a summary column.
7. Double-click the new summary column object (CS_1) to display the Property Inspector, and set the following properties:
   - Under General Information, set the Name property to R_PCT.
   - Under Column, set the Datatype property to Number, and set the Width property to 10.
   - Under Summary, set the Function property to % of Total, set the Source property to SUM_AMT2, set the Reset At property to Report, and set the Compute At property to Report.

**To create a second layout for the list of customers by percentage:**

1. Click the Paper Layout button in the toolbar to display the Paper Layout view.
2. In the Paper Layout view, click the Report Block tool in the tool palette.
3. Starting about 1 inch (2.5 centimeters) below the existing layout, click and drag a box about the same size as the existing layout to define the size of the second layout and display the Report Block Wizard.
4. On the Style page of the Report Block Wizard, select Tabular, then click Next.
5. On the Groups page, click G_CNAME2 in the Available Groups list and click Down to specify its Print Direction and move this group to the Displayed Groups list, then click Next.

6. On the Fields page, click the following fields and click the right arrow (>) to move them to the Displayed Fields list, then click Next:
   - CNAME2
   - SUM_AMT2

7. On the Labels page, change the labels and field widths as follows, then click Next:

<table>
<thead>
<tr>
<th>Fields</th>
<th>Labels</th>
<th>Width</th>
</tr>
</thead>
<tbody>
<tr>
<td>CNAME2</td>
<td>Customer Name</td>
<td>35</td>
</tr>
<tr>
<td>SUM_AMT2</td>
<td>Total Purchases</td>
<td>15</td>
</tr>
</tbody>
</table>

8. On the Template page, select No template. (If you were to select a template, it would override the template of the previous layout), then click Finish to display your report layout in the Paper Layout view.

9. From the font lists in the toolbar, choose Arial (Western), point size 10.

10. In the Paper Layout view, click the Text tool in the tool palette.

11. Click directly above the label Customer Name in the new layout and type the following text in the new boilerplate text object:

```
Top &CUTOFF_PCT Percent of Sales:
```

12. Move to an open area of the Paper Layout view and click the mouse button to exit text mode. Notice that the text object you just created is still selected, you can now adjust its positioning with the arrow keys.

13. If the text is not already bold, click the Bold button in the toolbar to make it bold.

14. Shift-click the labels Customer Name and Total Purchases so that they are selected simultaneously with the object you just created.

15. Click the Underline button in the toolbar.

16. Click in an open area of the Paper Layout view to deselect everything.

17. Double-click field F_SUM_AMT2 to display the Property Inspector, and set the following properties:
   - Under Field, set the Format Mask property by typing:
     `-N00, N00.00`

   **To add the logic for the percentage cutoff:**

1. In the Object Navigator, type R_G_CNAME2 in the Find field to locate that repeating frame.

2. Double-click the properties icon next to R_G_CNAME2 to display the Property Inspector, and set the following properties:
   - Under Advanced Layout, double-click the Format Trigger property field to display the PL/SQL Editor.

3. In the PL/SQL Editor, use the template to enter the following PL/SQL code:

   ```plsql
   function R_G_CNAME2FormatTrigger return boolean is
   function R_G_CNAME2FormatTrigger return boolean is
   ```
begin
if :r_pct <= :cutoff_pct then
  return(TRUE);
else
  return(FALSE);
end if;
end;

Note: You can enter this code by copying and pasting it from the provided text file called rank_code.txt. This code is for the Percentage Cutoff.

To update the Parameter Form for the new percentage parameter:
1. Choose Tools > Parameter Form Builder.
2. In the Parameter Form Builder dialog box, scroll down the list of parameters until you find CUTOFF_PCT, and change its label to:
   Top Percentage (%):
3. Click OK.
4. Click the Run Paper Layout button in the toolbar.
5. In the Runtime Parameter Form:
   ■ For # of Top Customers, type 5.
   ■ For Top Percentage (%), type 80.
6. Click the Run Report button in the toolbar.

Figure 34–6 Tabular report output restricted by number and percentage of customers

34.7 Summary

Congratulations! You have successfully created a ranking report. You now know how to:

■ create a data model and a tabular layout.
■ create parameters and group filter to control the ranking criteria.
■ add a layout object to display the parameter value in the report output.
■ create a Parameter Form that only displays the parameter you want users to set.
- add a percentage ranking.

For more information on any of the wizards, views, or properties used in this example, refer to the Oracle Reports online Help, which is available in Oracle Reports Builder or hosted on the Oracle Technology Network (OTN), as described in Section 4.1.1, "Using the Oracle Reports online Help".
In this chapter, you will learn about reports that include a simple table of contents and index.

---

**Note:** Generating a table of contents or index is not supported for matrix reports.

---

By following the steps in this chapter, you can generate the report output shown in Figure 35–1 and Figure 35–2.

**Figure 35–1  Simple table of contents for a large report**

<table>
<thead>
<tr>
<th>Topic</th>
<th>Pages</th>
</tr>
</thead>
<tbody>
<tr>
<td>Argentina</td>
<td>1-7</td>
</tr>
<tr>
<td>Australia</td>
<td>7-26</td>
</tr>
<tr>
<td>Brazil</td>
<td>26-45</td>
</tr>
<tr>
<td>Denmark</td>
<td>45-54</td>
</tr>
<tr>
<td>France</td>
<td>54-147</td>
</tr>
<tr>
<td>Germany</td>
<td>147-345</td>
</tr>
<tr>
<td>India</td>
<td>345-362</td>
</tr>
<tr>
<td>Ireland</td>
<td>362-411</td>
</tr>
<tr>
<td>Japan</td>
<td>411-426</td>
</tr>
<tr>
<td>Malaysia</td>
<td>426-440</td>
</tr>
<tr>
<td>New Zealand</td>
<td>440-446</td>
</tr>
<tr>
<td>Poland</td>
<td>446-462</td>
</tr>
</tbody>
</table>
When you have large paper report, it is sometimes easier for your users to navigate through the report if you include a table of contents. Using Reports Builder, you can generate a table of contents that displays at the beginning of your paper report.

Normally, Reports Builder formats the report starting with the Header section, then the Main section, followed by the Trailer section. With the functionality demonstrated in this example report, Reports Builder can format any section first to create information that is only known at the time of formatting, such as page numbers, then use that information in the formatting of a previous section.

In this example, you will use the built-in procedure called SRW.SET_FORMAT_ORDER to generate the Main section of the report first, then the Header and Trailer sections. Doing so enables you to generate the page numbers for the report in the Main section, then display the page numbers in the table of contents in the Header section.

**Note:** Although you can use SRW.SET_FORMAT_ORDER to change the order in which the report is formatted, the report will still display the Header section first, then the Main section, and finally the Trailer section. You can use SRW.SET_FORMAT_ORDER to simply change the formatting order, but not the display order of the report sections.
You will use the After Parameter Form trigger and a format trigger to place the page numbers temporarily in a table you create in the database. You will then create a simple tabular report that displays at the beginning of your report, that lists the category and its page number. Finally, you will create an index that simply lists the record and the page number in the Trailer section of the report.

For information on creating a multilevel table of contents, refer to Chapter 36, "Building a Paper Report with a Multilevel Table of Contents".

Example Scenario
In this example, you will generate a list of all the e-mail addresses for your customer database, which contains thousands of records. First, you want to categorize the customers (in this case, by country), then generate a table of contents so you can easily find the e-mail address for the desired customer. Then, you will learn how to create an index for your report.

As you build this example report, you will:

- **Create a Simple Table of Contents:**
  - Create a table in the database to hold the TOC data using SQL*Plus.
  - Create a group above report using the Report Wizard.
  - Create an After Parameter Form trigger and a format trigger using the PL/SQL Editor to change the order in which the report sections are executed and fetch the page number for each record.
  - Create a second query in the data model with a formula column that calculates the page range for the data under each country name.
  - Create a report block to display the table of contents using the Report Block Wizard to create a tabular report block in the Header section to display the country name and page number.
  - Run your simple table of contents report to paper.

- **Create an Index:**
  - Create a table in the database to hold the information for the index.
  - Create a format trigger to generate a page number for every customer record.
  - Add a query to the data model using the Data Model view to create another query that retrieves the necessary information for the index.
  - Create a report block to display the index in the Trailer section.
  - Run your report to paper.

To see a sample table of contents and index report, open the examples folder named tocindex, then open the Oracle Reports example named toc_index.rdf. For details on how to open it, see "Accessing the Example Reports" in the Preface.

35.1 Prerequisites for This Example

To build the example in this chapter, you must have the example files we have provided (see "Example Scenario", above), as well as access to the Sales History sample schema provided with the Oracle Database. If you do not know if you have access to this sample schema, contact your database administrator.
35.2 Create a Simple Table of Contents

The steps in this section will show you how to create a basic table of contents for a large, multipage report. The table of contents will look like the following:

![Simple table of contents]

<table>
<thead>
<tr>
<th>Topic</th>
<th>Pages</th>
</tr>
</thead>
<tbody>
<tr>
<td>Argentina</td>
<td>1-7</td>
</tr>
<tr>
<td>Australia</td>
<td>7-26</td>
</tr>
<tr>
<td>Brazil</td>
<td>26-45</td>
</tr>
<tr>
<td>Denmark</td>
<td>45-54</td>
</tr>
<tr>
<td>France</td>
<td>54-147</td>
</tr>
<tr>
<td>Germany</td>
<td>147-345</td>
</tr>
<tr>
<td>India</td>
<td>345-362</td>
</tr>
<tr>
<td>Ireland</td>
<td>362-411</td>
</tr>
<tr>
<td>Japan</td>
<td>411-426</td>
</tr>
<tr>
<td>Malaysia</td>
<td>426-440</td>
</tr>
<tr>
<td>New Zealand</td>
<td>440-446</td>
</tr>
<tr>
<td>Poland</td>
<td>446-462</td>
</tr>
</tbody>
</table>

35.2.1 Create a table in the database to hold the TOC data

The steps in this section will show you how to create a table in the database that will hold the page numbers for the records you want to list in the table of contents. If you are not sure whether you have the privileges to create a table in the database, contact the database administrator.

To create a table in the database:

1. Start SQL*Plus.
   - On Windows, from the Start menu, choose Programs > Oracle Application Server - oracle_home_name > Application Development > SQL Plus.
   - On UNIX, type `sqlplus`.
2. Connect to the Sales History schema of the database (for example, use the `sh/sh@database_name` connect string).
3. At the SQL prompt, type the following line:
   ```sql
   create table toc_example (topic varchar2(100), page number);
   ```
4. Press Enter.
   You should see a notification that the table has been created.
5. Exit SQL*Plus.

35.2.2 Create a group above report

The steps in this section will show you how to build a simple group above report in Reports Builder. This group above report will display the country name, then the customers and customer e-mail addresses under each country name. The table of contents you create will then be based on the country name in this report.
To create a simple group above report:

1. In Reports Builder, choose File > New > Report, then choose to create the report manually.
2. In the Data Model view that displays, right-click on the canvas, then choose Report Wizard from the pop-up menu.
3. On the Report Type page, select Create Paper Layout only, then click Next.
4. On the Style page, select Group Above, then click Next.
5. On the Data Source page, click SQL Query, then click Next.
6. On the Data page, enter the following SELECT statement in the Data Source definition field:

```
SELECT ALL COUNTRIES.COUNTRY_NAME,
    CUSTOMERS.CUST_LAST_NAME,
    CUSTOMERS.CUST_FIRST_NAME,
    CUSTOMERS.CUST_email
FROM CUSTOMERS, COUNTRIES
WHERE (CUSTOMERS.COUNTRY_ID = COUNTRIES.COUNTRY_ID)
```

7. Click Next.

```
Note: You can enter this query in any of the following ways:

- Copy and paste the code from the provided text file called toc_index_code.txt into the Data Source definition field.
- Click Query Builder to build the query without entering any code manually.
- Type the code in the Data Source definition field.
```

8. On the Groups page, click COUNTRY_NAME, then click > to move the field to the Group Fields list.
9. Click Next.
10. On the Fields page, click >> to move all fields to the Displayed Fields list, then click Next.
11. On the Totals page, click Next.
14. In the toolbar, click the Data Model view button. The data model should look like this:
Create a Simple Table of Contents

35-6  Publishing Reports to the Web with Oracle Reports Services

15. In the toolbar, click the Paper Layout view button. The Paper Layout view should look like this:

![Figure 35–4  Data model for the group above report]

16. Save your report as toc_your_initials.rdf. You have now created the data model and the basic layout for your report.

35.2.3 Create an After Parameter Form trigger and a format trigger

The steps in this section will show you how to create two triggers. The first trigger will use the SRW.SET_FORMAT_ORDER built-in procedure to format the Main section of the report first, then the Header and Trailer sections. The second trigger will fetch the number of the page on which each country name displays, and place that information into the table you created in Section 35.2.1, "Create a table in the database to hold the TOC data".

35.2.3.1 Create an After Parameter Form trigger

An After Parameter Form trigger is a function that executes after the parameter form is executed. In this section, you will set the trigger to change the order of the report execution, so that the Main section runs first.

To create an After Parameter Form trigger:

1. In the Object Navigator, under your report name (TOC_your_initials), expand the Report Triggers node.
2. Right-click AFTER PARAMETER FORM, then choose PL/SQL Editor from the pop-up menu.
3. In the PL/SQL Editor, use the template to enter the following PL/SQL code:

```plsql
function AfterPForm return boolean is
    begin
        srw.set_format_order(srw.main_section, srw.header_section, srw.trailer_section);
        return (TRUE);
    end;
```
Create a format trigger

In this section, you will create a format trigger based on the field F_COUNTRY_NAME. This field displays the country name. This format trigger will fetch the page number for each country name, so that the table of contents will enable the user to navigate to various parts of the report based on the name of the country.

To create a format trigger:

1. In the Object Navigator, under the Paper Layout node for your report, navigate to Main Section > Body > M_G_1_GRPFR > R_G_1, then click F_COUNTRY_NAME.

   Tip: If you cannot find this field, use the Find field at the top of the Object Navigator.

2. Choose Tools > Property Inspector to display the Property Inspector for this field.

3. Under Advanced Layout, double-click the Format Trigger property field to display the PL/SQL Editor.

4. In the PL/SQL Editor, type the following code:

   ```plsql
   function F_COUNTRY_NAMEFormatTrigger return boolean is
     pageNum number;
   begin
     -- get current page number
     srw.get_page_num(pageNum);
     -- insert row into table
     insert into toc_example
       values (:country_name, pageNum);
     return (TRUE);
   end;
   ```

5. Click Compile.

6. Once the code is compiled, click Close, then close the Property Inspector.

7. Save your report.

35.2.4 Create a second query in the data model

The steps in this section will show you how to create a second query in the data model with a formula column that calculates the page range for the data under each country name. This query will fetch the information from the database table you created in
Create a Simple Table of Contents

Section 35.2.1, "Create a table in the database to hold the TOC data". You will later create a tabular layout to display this information in your table of contents.

To create a second query with a formula column:

1. In the Data Model view, click the SQL Query tool in the tool palette then click in an open area of the Data Model view, somewhere to the right of query Q_1, to display the SQL Query Statement dialog box.

2. In the SQL Query Statement field, enter the following SELECT statement:

   ```
   SELECT TOPIC, 
   MIN(PAGE) FROMPAGE, 
   MAX(PAGE) TOPAGE 
   FROM TOC_EXAMPLE 
   GROUP BY TOPIC
   ```

   **Note:** You can enter this query in any of the following ways:
   - Copy and paste the code from the provided text file called `toc_index_code.txt` into the SQL Query Statement field.
   - Click Query Builder to build the query without entering any code manually.
   - Type the code in the SQL Query Statement field.

3. Click OK. Your data model should now look like this:

   **Figure 35–6  Data model with second query**

4. In the Data Model view, click the Formula Column tool in the tool palette, then click in the group (G_TOPIC) for the second query.

5. While the formula column is selected, choose Tools > Property Inspector to display its Property Inspector.

6. Under General Information, set the Name property to TOC_pages, and the Datatype property to Character.

7. Under Placeholder/Formula, click the PL/SQL Formula property field to display the PL/SQL Editor.

8. In the PL/SQL Editor, use the template to enter the following code:
function TOC_pagesFormula return Char is
begin
if :fromPage = :toPage then
return (:fromPage);
else
return (:fromPage || '−' || :toPage);
end if;
end;

Note: You can also copy and paste this code from the provided file, called toc_index_code.txt.

9. Click **Compile**.

10. Once the code is compiled, click **Close**.

11. Save the report.

### 35.2.5 Create a report block to display the table of contents

The steps in this section will show you how to create a tabular report block in the Header section of your report. This report block will display the headings in the table of contents (in this example, the country name), and the page range where the information can be found in the report.

**To create a tabular report block in the Header section:**

1. In the Paper Layout view, click the Header Section button in the toolbar.

2. Click the Report Block tool in the tool palette, then draw an area about 5 inches (12.5 centimeters) wide and 1.5 inches (4 centimeters) high in the Paper Layout view. When you release the mouse button, the Report Block Wizard displays.

3. On the Style page, select **Tabular**, then click **Next**.

4. On the Groups page, click **G_TOPIC** and click **Down** to move it to the **Displayed Groups** list, then click **Next**.

5. On the Fields page, click each of the following fields in the **Available Fields** list, then click the right arrow (>) to move them to the **Displayed Fields** list, then click **Next**:
   - **TOPIC**
   - **TOC_pages**

6. On the Labels page, click **Next**.

7. On the Template page, click **Finish**.

   Your report block displays in the Paper Layout view:

**Figure 35–7  Paper Layout view of the Header Section**

<table>
<thead>
<tr>
<th>Topic</th>
<th>Toc Pages</th>
</tr>
</thead>
<tbody>
<tr>
<td><em>TOPIC</em></td>
<td><em>TOC_pages</em></td>
</tr>
</tbody>
</table>

8. Save your report.
35.2.6 Run your simple table of contents report to paper

**To run your report to paper:**

- Click the Run Paper Layout button in the toolbar.

---

**Note:** To generate the table of contents (TOC), you must click the Run Paper Layout button. If you click the Paper Design view button, the change of format order will not take effect, thus the TOC will not be generated.

The table of contents displays on the first page of the report, and looks something like the following:

*Figure 35–8  Table of contents page of the report*

<table>
<thead>
<tr>
<th>Topic</th>
<th>Pages</th>
</tr>
</thead>
<tbody>
<tr>
<td>Argentina</td>
<td>1-7</td>
</tr>
<tr>
<td>Australia</td>
<td>7-26</td>
</tr>
<tr>
<td>Brazil</td>
<td>26-45</td>
</tr>
<tr>
<td>Denmark</td>
<td>45-54</td>
</tr>
<tr>
<td>France</td>
<td>54-147</td>
</tr>
<tr>
<td>Germany</td>
<td>147-345</td>
</tr>
<tr>
<td>India</td>
<td>345-362</td>
</tr>
<tr>
<td>Ireland</td>
<td>362-411</td>
</tr>
<tr>
<td>Japan</td>
<td>411-426</td>
</tr>
<tr>
<td>Malaysia</td>
<td>426-440</td>
</tr>
<tr>
<td>New Zealand</td>
<td>440-446</td>
</tr>
<tr>
<td>Poland</td>
<td>446-462</td>
</tr>
</tbody>
</table>

You can navigate to various pages in your report to view the data for each country. For example, when you navigate to page 1, you will see the e-mail addresses for the customers in Argentina:
35.3 Create an Index

In this section, you will create an index that displays at the end of your report. This index will simply display the customer's name and the page number on which the name appears. This indexing technique is useful when users want to find a specific customer's name, but are not sure what category (for example, country) to reference.

For information on creating a multilevel table of contents, see Chapter 36, "Building a Paper Report with a Multilevel Table of Contents".

Note: At this point, you can compare your report against the example file we have provided, toc.rdf. First, compile the PL/SQL by choosing Program > Compile > All, then run the report to paper.

Figure 35–9  Results for customers in Argentina

<table>
<thead>
<tr>
<th>Country Name</th>
<th>Argentina</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cust Last Name</td>
<td>Cust First Name</td>
</tr>
<tr>
<td>Grandy</td>
<td>Mandica</td>
</tr>
<tr>
<td>Eubank</td>
<td>Hattie</td>
</tr>
<tr>
<td>Pearson</td>
<td>Idola</td>
</tr>
<tr>
<td>Pardue</td>
<td>Bryant</td>
</tr>
<tr>
<td>Elgin</td>
<td>Torrey</td>
</tr>
<tr>
<td>Naber</td>
<td>Torrance</td>
</tr>
<tr>
<td>Markerman</td>
<td>Diana</td>
</tr>
<tr>
<td>Burgess</td>
<td>Beulah</td>
</tr>
<tr>
<td>Tanney</td>
<td>Woodrow</td>
</tr>
<tr>
<td>Justice</td>
<td>Diamond</td>
</tr>
<tr>
<td>Gutierrez</td>
<td>Marcel</td>
</tr>
<tr>
<td>Felton</td>
<td>Madeleine</td>
</tr>
</tbody>
</table>
35.3.1 Create a table in the database to hold the information for the index

The steps in this section will show you how to create a table in the database that will hold the page numbers for the items you want to list in the index. If you are not sure if you can create a table in the database, contact the database administrator.

To create a table in the database:

1. Follow the steps in Section 35.2.1, "Create a table in the database to hold the TOC data" to create a new table in the database, using the following code:

   ```sql
   create table index_example (term varchar2(100), page number);
   ```

2. Press Enter.
   You should see a notification that the table has been created.

3. Exit SQL*Plus.

35.3.2 Create a format trigger

The steps in this section will show you how to create a format trigger based on the customer's last name. You will use the SRW.GET_PAGE_NUM built-in function to find the page number for the current customer, and insert that page number into the table you created in the previous section.

To create a format trigger:

1. In Reports Builder, open the report, `toc_your_initials.rdf`. 

2. Click the Paper Layout button in the toolbar to display the Paper Layout view.

3. In the Paper Layout view, right-click the field \texttt{F\_CUST\_LAST\_NAME}, then choose \textit{Property Inspector} from the pop-up menu.

4. Under Advanced Layout, double-click the Format Trigger property field to display the PL/SQL Editor.

5. In the PL/SQL Editor, use the template to enter the following code:

   \begin{verbatim}
   function F\_CUST\_LAST\_NAMEFormatTrigger return boolean is
     PageNum number;
   begin
     -- get pagenumber
     srw.get_page_num(pageNum);
     -- insert into table
     insert into index_example
         values (:Cust\_last\_name||', '||:Cust\_first\_name, PageNum);
     return (TRUE);
   end;
   \end{verbatim}

\textbf{Note:} You can enter this code by copying and pasting it from the provided text file called toc\_index\_code.txt.

6. Click \textit{Compile}.

7. If there are compilation errors, match your code to the code we have provided (either in the example RDF file or in this chapter), then compile it again.

8. Once there are no compilation errors, click \textit{Close}.

9. Save your report as \textit{toc\_index\_your\_initials.rdf}.

\textbf{35.3.3 Add a query to the data model}

The steps in this section will show you how to add a query to your data model that will retrieve the individual customer names and the page numbers for your index.

\textbf{To add the query:}

1. In the Data Model view, click the SQL Query tool in the tool palette then click in an open area of the Data Model view, somewhere to the right of query \textit{Q\_1}, to display the SQL Query Statement dialog box.

2. In the \textbf{SQL Query Statement} field, enter the following \texttt{SELECT} statement:

   \begin{verbatim}
   SELECT SUBSTR(TERM,1,1) INITIAL\_LETTER, TERM, PAGE FROM INDEX\_EXAMPLE ORDER BY TERM
   \end{verbatim}

\textbf{Note:} You can enter this query in any of the following ways:

- Copy and paste the code from the provided text file called toc\_index\_code.txt into the \textit{Data Source definition} field.
- Click \textit{Query Builder} to build the query without entering any code manually.
- Type the code in the \textit{Data Source definition} field.
3. Click OK.

4. In the new query that displays in the Data Model view, click and drag the \texttt{INITIAL\_LETTER} column above the rest of the query, so that the data model now looks like this:

\textit{Figure 35–11 Data model view of the index}

5. Save your report.

### 35.3.4 Create a report block to display the index in the Trailer section

The steps in this section will show you how to display the index information in the Trailer section of your report.

\textbf{To create a report block in the Trailer section:}

1. In the Paper Layout view, click the Trailer Section button in the toolbar.

2. Choose \textit{Insert > Report Block}.

3. On the Style page, select the \textbf{Group Above} radio button, then click \textit{Next}.

4. On the Groups page, click \texttt{G\textunderscore 2} (the name of the new group that contains the \texttt{INITIAL\_LETTER} column), then click \textit{Down} to specify the print direction.

5. In the \textit{Available Groups} list, click \texttt{G\textunderscore INITIAL\_LETTER}, then click \textit{Down}.

6. Click \textit{Next}.

7. On the Fields page, click \texttt{INITIAL\_LETTER}, then click > to move it to the Displayed Fields list.

8. Move \texttt{TERM} and \texttt{PAGE} to the Displayed Fields list.

9. Click \textit{Next}, then \textit{Next} again, then click \textit{Finish}.

10. Save your report.

### 35.3.5 Run your report to paper

Click the Run Paper Layout button in the toolbar. The index displays on the last pages of the report. We chose page 2402, which (in our example) looks like the following:
Congratulations! You have successfully created a report with a table of contents and an index. You now know how to:

- create a table of contents (TOC) and index for a large paper report.
- use the SRW.SET_FORMAT_ORDER built-in procedure to change the order in which the sections of a report are executed.
- use the SRW.GET_PAGE_NUM built-in procedure to retrieve the page number for a specific record.
- create a new table in your database to hold the necessary page numbers.
- create a simple group above report using the Report Wizard.

**Note:** To generate the table of contents (TOC), you must click the Run Paper Layout button. If you click the Paper Design view button, the change of format order will not take effect, thus the TOC will not be generated.

**Figure 35–12  Index page of the report**

<table>
<thead>
<tr>
<th>Term</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Aaron, Abel</td>
<td>357</td>
</tr>
<tr>
<td>Aaron, Abel</td>
<td>386</td>
</tr>
<tr>
<td>Aaron, Abel</td>
<td>346</td>
</tr>
<tr>
<td>Aaron, Abel</td>
<td>686</td>
</tr>
<tr>
<td>Aaron, Abel</td>
<td>615</td>
</tr>
<tr>
<td>Aaron, Abel</td>
<td>691</td>
</tr>
<tr>
<td>Aaron, Abel</td>
<td>732</td>
</tr>
<tr>
<td>Aaron, Abel</td>
<td>550</td>
</tr>
<tr>
<td>Aaron, Abel</td>
<td>444</td>
</tr>
<tr>
<td>Aaron, Abel</td>
<td>529</td>
</tr>
<tr>
<td>Aaron, Abel</td>
<td>666</td>
</tr>
<tr>
<td>Aaron, Abel</td>
<td>773</td>
</tr>
<tr>
<td>Aaron, Abel</td>
<td>656</td>
</tr>
<tr>
<td>Aaron, Abel</td>
<td>347</td>
</tr>
<tr>
<td>Aaron, Abel</td>
<td>430</td>
</tr>
<tr>
<td>Aaron, Dolly</td>
<td>416</td>
</tr>
<tr>
<td>Aaron, Dolly</td>
<td>642</td>
</tr>
<tr>
<td>Aaron, Dolly</td>
<td>457</td>
</tr>
<tr>
<td>Aaron, Dolly</td>
<td>21</td>
</tr>
<tr>
<td>Aaron, Dolly</td>
<td>19</td>
</tr>
<tr>
<td>Aaron, Dolly</td>
<td>14</td>
</tr>
</tbody>
</table>

**Note:** The data on page 2402 in your report may not appear the same as ours, depending on the amount and type of data you have in the schema.

### 35.4 Summary

Congratulations! You have successfully created a report with a table of contents and an index. You now know how to:

- create a table of contents (TOC) and index for a large paper report.
- use the SRW.SET_FORMAT_ORDER built-in procedure to change the order in which the sections of a report are executed.
- use the SRW.GET_PAGE_NUM built-in procedure to retrieve the page number for a specific record.
- create a new table in your database to hold the necessary page numbers.
- create a simple group above report using the Report Wizard.
■ manually create a simple data model to retrieve the information for your report.
■ create a format trigger to generate the necessary page numbers for an index.
■ use the Report Block Wizard to create a group report that displays the index in the trailer of a report.

For more information on any of the wizards, views, or properties used in this example, refer to the Oracle Reports online Help, which is available in Oracle Reports Builder or hosted on the Oracle Technology Network (OTN), as described in Section 4.1.1, "Using the Oracle Reports online Help".
In this chapter, you will learn about reports that include a multilevel table of contents.

**Note:** Generating a table of contents is not supported for matrix reports.

By following the steps in this chapter, you can generate the report output shown in Figure 36–1 and Figure 36–2.

**Figure 36–1  Multilevel table of contents**

<table>
<thead>
<tr>
<th>Boys</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Outerwear - Boys</td>
<td>1</td>
</tr>
<tr>
<td>Shirts - Boys</td>
<td>22</td>
</tr>
<tr>
<td>Shoes - Boys</td>
<td>38</td>
</tr>
<tr>
<td>Shorts - Boys</td>
<td>53</td>
</tr>
<tr>
<td>Sleepwear - Boys</td>
<td>71</td>
</tr>
<tr>
<td>Sweaters - Boys</td>
<td>31</td>
</tr>
<tr>
<td>Trousers And Jeans - Boys</td>
<td>39</td>
</tr>
<tr>
<td>Underwear - Boys</td>
<td>105</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Girls</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Dresses - Girls</td>
<td>117</td>
</tr>
<tr>
<td>Outerwear - Girls</td>
<td>133</td>
</tr>
<tr>
<td>Shirts - Girls</td>
<td>144</td>
</tr>
<tr>
<td>Shoes - Girls</td>
<td>157</td>
</tr>
<tr>
<td>Shorts - Girls</td>
<td>159</td>
</tr>
<tr>
<td>Skirts - Girls</td>
<td>173</td>
</tr>
<tr>
<td>Sleepwear - Girls</td>
<td>179</td>
</tr>
<tr>
<td>Sweaters - Girls</td>
<td>187</td>
</tr>
<tr>
<td>Trousers And Jeans - Girls</td>
<td>192</td>
</tr>
</tbody>
</table>
This chapter assumes that you know how to create a basic data model and layout for your report, and focuses on the building of the table of contents. If you are not sure how to create a data model and paper layout, refer to the Oracle Reports online Help or, for specific steps, refer to any other chapter in this manual.

When you create a large paper report, you can create a table of contents (TOC) to make it easier for users to navigate through the pages of information. In Chapter 35, you learned how to create a basic table of contents that categorized customer information by country, then listed the country and page ranges in the table of contents. You also learned how to index this information.

In this chapter, you will learn how to create a multilevel table of contents that will enable you to create a hierarchy. This hierarchy will further enable you to categorize your information, so that users can find a specific piece of information.

As in Chapter 35, you will use the SRW.SET_FORMAT_ORDER built-in procedure in an After Parameter Form trigger to generate the Main section of your report before the Header and Trailer sections. Doing so enables you to generate the page numbers for the report in the Main section, then display the page numbers in the table of contents in the Header section.

Note: Although you can use SRW.SET_FORMAT_ORDER to change the order in which the report is formatted, the report will still display the Header section first, then the Main section, and finally the Trailer section. You can use SRW.SET_FORMAT_ORDER to simply change the formatting order, but not the display order of the report sections.

You will also create a format trigger based on a sub-category in your report that will use the SRW.GET_PAGE_NUM built-in package to retrieve the page number for each record and temporarily place it in a database table you create. This format trigger will also get the page numbers for each sub-category that you specify. Finally, you will use a SQL query to display the desired information in a multilevel table of contents that displays at the beginning of your report.

For more information on the SRW built-in package in Oracle Reports, refer to the Oracle Reports online Help.
Example Scenario
In this example, you have a large paper catalog that lists all the clothing products a company sells. This catalog simply lists all the items in a simple report. Since the product line has become much larger, the catalog report now exceeds 700 pages. You will create a multilevel table of contents that sorts the clothing by department (for example, Boys, Girls), then lists each item under each category.

As you build this example report, you will:

- **Create a table in the database to hold the TOC data** (the first and second tier categories and page numbers) using SQL*Plus.
- **Create an After Parameter Form Trigger and a Format Trigger** using the PL/SQL Editor to change the order in which the report sections are executed and fetch the page numbers for each category, sub-category, and record.
- **Create a Second Query in the Data Model** to retrieve the information stored in the table you created.
- **Create a Report Block to Display the Table of Contents** using the Report Block Wizard to create a group above report block in the Header section to display two levels of headings. You will also add a field to your layout to display the page number where each heading is found in report.
- **Run Your Multilevel Table of Contents Report to Paper**.

To see a sample report with a multilevel table of contents, open the examples folder named multileveltoc, then open multilevel_toc.rdf. For details on how to open it, see “Accessing the Example Reports” in the Preface. The example files used in this chapter are listed and described in Table 36–1.

### Table 36–1  Example report files

<table>
<thead>
<tr>
<th>File</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>multileveltoc\multilevel_source.rdf</td>
<td>The source file that contains a basic paper layout and data model for your report.</td>
</tr>
<tr>
<td>multileveltoc\multilevel_toc.rdf</td>
<td>The final RDF version of the report with a multilevel table of contents.</td>
</tr>
<tr>
<td>multileveltoc\multilevel_code.txt</td>
<td>The various SQL statements you will use in this report.</td>
</tr>
</tbody>
</table>

#### 36.1 Prerequisites for This Example

To build the example in this chapter, you must have the example files we have provided (see "Example Scenario", above), as well as access to the Sales History sample schema provided with the Oracle Database. If you do not know if you have access to this sample schema, contact your database administrator.

#### 36.2 Create a table in the database to hold the TOC data

The steps in this section will show you how to create a table in the database that will hold the page numbers for the main and sub-categories in the report. If you are not sure if you can create a table in the database, contact the database administrator.

**To create a table in the database:**

1. Start SQL*Plus.
On Windows, from the Start menu, choose Programs > Oracle Application Server - oracle_home_name > Application Development > SQL Plus.

On UNIX, type sqlplus.

2. Connect to the Sales History schema of the database (for example, use the $sh/sh@database_name connect string).

3. At the SQL prompt, type the following line:
   
   ```sql
   create table toc_multilevel (main_topic varchar2(100), sub_topic varchar2(100), page_number);
   ```

4. Press Enter.
   You should see a notification that the table has been created.

5. Exit SQL*Plus.

### 36.3 Create an After Parameter Form Trigger and a Format Trigger

The steps in this section will show you how to create two triggers. The first trigger will use the SRW.SET_FORMAT_ORDER built-in procedure to format the Main section of the report first, then the Header and Trailer sections. The second trigger will fetch the page number for each category, sub-category, and record, and place that information into the table you created in Section 36.2, "Create a table in the database to hold the TOC data".

### 36.3.1 Create an After Parameter Form trigger

An After Parameter Form trigger is a function that executes after the Parameter Form is executed. In this section, you will set the trigger to change the order of the report execution, so that the Main section formats first.

**To create an After Parameter Form trigger:**

1. In Reports Builder, open the provided file `multilevel_source.rdf`.

2. In the Object Navigator, under your report name (MULTILEVEL_SOURCE), expand the Report Triggers node.

3. Right-click AFTER PARAMETER FORM, then choose PL/SQL Editor from the pop-up menu.

4. In the PL/SQL Editor, use the template to enter the following code:

   ```plsql
   function AfterPForm return boolean is
   begin
     srw.set_format_order(srw.main_section, srw.header_section, srw.trailer_section);
     return (TRUE);
   end;
   ```

   **Note:** You can also copy and paste the code from the provided file, `multilevel_code.txt`.

5. Click Compile.

6. Once the code has compiled, click Close.
36.3.2 Create a format trigger

In this section, you will create a format trigger based on the field F_PROD_SUBCATEGORY. This field displays the sub-category, which is the product name. This sub-category falls under the main category, which is the product department. This format trigger will fetch the page number for each product name, so that the table of contents will enable the user to navigate to various parts of the report based on the department name, then the product name.

To create a format trigger:

1. In the Object Navigator, under the Paper Layout node for your report, navigate to Main Section > Body > M_G_PROD_CATEGORY_GRPFR > R_G_PROD_CATEGORY > M_G_PROD_SUBCATEGORY_GRPFR > R_G_PROD_SUBCATEGORY_GRPFR, then click F_PROD_SUBCATEGORY.

   **Tip:** If you cannot find this field, use the Find field at the top of the Object Navigator.

2. Choose Tools > Property Inspector to display the Property Inspector for this field.

3. Under Advanced Layout, double-click the Format Trigger property field to display the PL/SQL Editor.

4. In the PL/SQL Editor, use the template to enter following code:

   ```plsql
   function F_PROD_SUBCATEGORYFormatTrigge return boolean is
     pageNum number;
     myCount number;
     begin
     -- get page number
     srw.get_page_num(pageNum);
     -- check table for duplicates
     select count(*)
     into myCount
     from toc_multilevel
     where main_topic = :PROD_CATEGORY and
     sub_topic = :PROD_SUBCATEGORY;
     -- if no duplicates, insert row
     if myCount = 0 then
     insert into toc_multilevel
     values (:PROD_CATEGORY, :PROD_SUBCATEGORY, pageNum);
     end if;
     return (TRUE);
   end;
   ```

5. Click Compile.

6. Once the code is compiled, click Close, then close the Property Inspector.

7. Save your report.

Note: You can also copy and paste this code from the provided file, multilevel_code.txt.
36.4 Create a Second Query in the Data Model

The steps in this section will show you how to create a second query in the data model that retrieves the information stored in the table you created in Section 36.2, "Create a table in the database to hold the TOC data". This query will fetch the data necessary for generating the table of contents in the Header section of your report.

To create a query:

1. In the Data Model view, click the SQL Query tool in the tool palette then click in an open area of the Data Model view, somewhere to the right of query Q_1, to display the SQL Query Statement dialog box.

2. In the SQL Query Statement field, enter the following SELECT statement:

   ```sql
   SELECT * FROM TOC_MULTILEVEL
   ```

   **Note:** You can enter this query in any of the following ways:

   - Copy and paste the code from the provided text file called `multilevel_code.txt` into the SQL Query Statement field.
   - Click Query Builder to build the query without entering any code manually.
   - Type the code in the SQL Query Statement field.

3. Click OK.

4. In the new query, click and drag the MAIN_TOPIC column to a separate group above the rest of the query.

5. Click the Summary Column tool in the tool palette, then click in the new group object to create a summary column.

6. Double-click the new summary column object to display the Property Inspector, and set the following properties:

   - Under General Information, set the Name property to Subcategory_Page
   - Under Summary, set the Function property to Minimum and set the Source property to PAGE

   Your data model should now look like this:
7. Save your report.

36.5 Create a Report Block to Display the Table of Contents

The steps in this section will show you how to create a group above report block in the Header section of your report. This report block will display two levels of headings in the table of contents. You will also add a field to your layout to display the page number where each heading is found in report.

To create a group above report block in the Header section:
1. In the Paper Layout view, click the Header Section button in the toolbar.
2. Click the Report Block tool in the tool palette, then draw an area about 6 inches (15 centimeters) wide and 1.5 inches (4 centimeters) high. Release the mouse button to display the Report Block Wizard.
3. In the Report Block Wizard, on the Style page, select Group Above, then click Next.
4. On the Groups page, click G_MAIN_TOPIC, then click Down to move it to the Displayed Groups list.
5. In the Available Groups list, click G_1, then click Down to move it to the Displayed Groups list.
6. Click Next.
7. On the Fields page, click each of the following fields in the Available Fields list, then click the right arrow (>) to move them to the Displayed Fields list, then click Next.
   - MAIN_TOPIC
   - SUB_TOPIC
   - PAGE
8. On the Labels page, clear all the labels, then click Next.

Your report block displays in the Paper Layout view:
10. Click the Field tool in the tool palette and create a field above the PAGE field, next to the F_MAIN_TOPIC field.

11. Double-click the new field object to display the Property Inspector, and set the following properties:
   - Under Field, set the Source property to Subcategory_Page.
   - Under Summary, set the Reset At property to G_1.

12. Save your report.

36.6 Run Your Multilevel Table of Contents Report to Paper

The steps in this section will show you how to make a few modifications in the Paper Layout view and run your report.

To modify and run your report to paper:
1. In the Paper Layout view, change the font of the field (F_1) to Arial, Bold.
2. Change the Fill color to any color (for example, Beige), and the Line Color to No Line Color.
3. Click the Run Paper Layout button in the toolbar.

---

**Note:** To generate the table of contents (TOC), you must click the Run Paper Layout button. If you click the Paper Design view button, the change of format order will not take effect, thus the TOC will not be generated.

---

The table of contents displays on the first page of the report, and looks something like the following:
In this example, under the BOYS product department, the SHIRTS sub-category starts at page 22 and the next sub-category, SHOES, starts at page 38. If you move to any page between page 22 and 38 in the report, you will see the SHIRTS sub-category.

**Note:** The page numbers may differ depending upon the data used in your report.

You can navigate to various pages in your report to view the data for each department and sub-category.
Note: At this point, you can compare your report against the example file we have provided, multilevel_toc.rdf. First, compile the PL/SQL by choosing Program > Compile > All, then run the report to paper.

36.7 Summary

Congratulations! You have successfully created a report with a multilevel table of contents. You now know how to:

- create a multilevel table of contents for a large paper report.
- Use the SRW.SET_FORMAT_ORDER built-in procedure to change the order in which the report sections are formatted.
- create a format trigger that fetches the page numbers for categories and subcategories that you specify.
- use the Report Block Wizard to create a simple group above report layout to display your table of contents.

For more information on any of the wizards, views, or properties used in this example, refer to the Oracle Reports online Help, which is available in Oracle Reports Builder or hosted on the Oracle Technology Network (OTN), as described in Section 4.1.1, "Using the Oracle Reports online Help".
Bursting and Distributing a Report

Oracle Reports enables you to deliver a single report to multiple destinations simultaneously. By taking advantage of this feature, you can create a single report, then send it in any format (layout driven formats, such as PDF or HTML, as well as data model driven formats, such as XML or delimited) to multiple destinations.

In this example, you will modify a simple report we have provided to burst each group to a separate report. You will then modify a sample distribution XML file to send an e-mail to each destination with an attachment based on the separate reports. You will also send multiple e-mails to the same e-mail address with a single attachment (the entire report).

Concepts

Oracle Reports enables you to deliver a single report to multiple destinations simultaneously. Using the distribution feature, you can set up your report to be distributed to an e-mail destination, a portal, a printer, or anywhere else when the report is run. This feature also enables you to improve performance, since you fetch the data only once for many different formats and destinations. Using distribution also reduces your maintenance overhead because you need only one job request to publish the report to multiple destinations. You can refine this further by sending the Header section to some recipients, the Main section to others, and the entire report to an entirely different recipient list.

For more information on bursting and distribution, see "Creating Advanced Distributions" in the Publishing Reports to the Web with Oracle Reports Services.

Example Scenario

In this example, you are the report developer for a manufacturing company who needs to deliver monthly information to its warehouses. You will modify an existing report to burst on each warehouse ID, creating separate PDF reports for each warehouse. You will then edit the distribution XML file we have provided to e-mail each report as an attachment to the corresponding warehouses.

As you build this example report, you will:

- Set Up an Existing Report for Bursting on a warehouse group.
- Edit the Distribution XML Definition.
- Run the Report to PDF format so that the report is e-mailed to the destinations defined in the distribution.xml file.

To see a sample distribution report, open the examples folder named distribution, then open source\inventory_report_dist.rdf for report you will distribute, or result\inventory_report_dist.rdf for the report you will burst. For details on how
to open these reports, see "Accessing the Example Reports" in the Preface. The example files used in this chapter are listed and described in Table 37–1.

### Table 37–1 Example report files

<table>
<thead>
<tr>
<th>File</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>distribution\source\distribution.xml</td>
<td>The XML file that controls the distribution properties for your report.</td>
</tr>
<tr>
<td>distribution\source\inventory_report_dist.rdf</td>
<td>The source report you will modify to burst and distribute.</td>
</tr>
<tr>
<td>distribution\result\inventory_report_dist.rdf</td>
<td>The modified report you will burst and distribute.</td>
</tr>
<tr>
<td>distribution\result\REP_*.pdf</td>
<td>The PDFs that are generated when you distribute and burst your report.</td>
</tr>
</tbody>
</table>

---

**Note:** The distribution.xml file we have provided for this example is specific to building this example report. A more comprehensive distribution.xml is shipped with Oracle Reports in the ORACLE_HOME\samples\demo directory; you can reuse this file for your own purposes so that you do not have to create one from scratch.

---

### 37.1 Prerequisites for This Example

To build the example in this chapter, you must have the example files we have provided (see "Example Scenario", above), as well as access to the Order Entry sample schema provided with the Oracle Database. If you do not know if you have access to this sample schema, contact your database administrator.

### 37.2 Set Up an Existing Report for Bursting

For the purposes of this chapter, we have provided an RDF file you can use for bursting. In this section, you will set up the report for bursting by deleting the repeating frame and setting the Repeat On property of the Main section, so that the data bursts on each warehouse ID. This way, you can distribute the data for each warehouse as a report to the corresponding warehouse e-mail ID.

**Note:** For more information on the Repeat On property, refer the Oracle Reports online Help.

**To set up the report for bursting:**

1. In Reports Builder, choose File > Open.
2. Navigate to the directory where your examples source files are located, and open the file inventory_report_dist.rdf.
   The report displays in the Object Navigator.
3. In the Object Navigator, under the report name, double-click the view icon next to the Paper Layout node to display the Paper Layout view.
4. In the Paper Layout view, select the outermost repeating frame (R_G_WAREHOUSE_ID), then delete it.
5. In the Object Navigator, right-click the **Main Section** node, then choose **Property Inspector** to display the Property Inspector for the Main Section:

   ■ Under **Section**, set the Repeat On property to `G_WAREHOUSE_ID`.

6. Save the report as `inventoryreport_dist_your_initials.rdf`.

   You have set up your report to burst based on the warehouse ID.

### 37.3 Edit the Distribution XML Definition

The Oracle Reports distribution XML file enables you to specify the details of your distribution. For example, if you are distributing through e-mail, you can specify such details as the addressee, the reply to address, and the subject.

In this section, you will learn how to modify a distribution XML file. We have indicated locations where you need to enter your own information to make the distribution work.

When you want to distribute a report, you need to either:

   ■ Make sure your source report (for example, `inventory_report_dist.rdf`) and your distribution XML file (for example, `distribution.xml`) are in the same directory.

   OR

   ■ When you run the report from the Reports Server, set the destination to the path of the XML file. (This is explained in Section 37.4, "Run the Report".)

---

**Note:** For more information on distribution, see the chapter "Creating Advanced Distributions" in the *Publishing Reports to the Web with Oracle Reports Services*.

This guide is available on the Oracle Technology Network Oracle Reports Documentation page (http://www.oracle.com/technetwork/middleware/reports/overview/index.html).

---

**To edit the distribution XML file:**

1. In a text editor, such as Notepad, open the sample `distribution.xml` file we have provided.
2. Find the placeholder text: `<YourFilePath>`, and replace it with the location of where your resulting PDFs will be stored.

Example: Replacing the placeholder text with:

`d:\temp\`

changes the path to:

`d:\temp\Rep_&lt;city&gt;.&pdf`

Using this complete path places the resulting PDF files in `d:\temp`.

3. Find the placeholder text: `<OriginEmailAddress>`, and replace it with the sender's e-mail address.

4. Perform step 3 for all instances of the placeholder text: `<OriginEmailAddress>`.

5. Find the placeholder text: `<DestinationEmailAddress>`, and replace it with the recipient's e-mail address.

6. Perform step 5 for all instances of the placeholder text: `<DestinationEmailAddress>`.

7. Save the XML file to the same directory where you have saved `inventoryreport_dist_your_initials.rdf`.

---

**Note:** For this example, we show you how to send e-mails to static e-mail addresses. However, if you want to send the report to various e-mail destinations, you must create a recipient field in your data model. Then, in the `ex2` section of `distribution.xml`, replace the placeholder text `<DestinationEmailAddress>` with `&amp;&lt;recipient&gt;`. You can then delete the first section of the `distribution.xml` file (marked `ex1`).

---

You have finished customizing the distribution XML file to send a single e-mail to corporate headquarters with all of the individual warehouse reports, and multiple e-mails with a single attachment each to the individual warehouses.

### 37.4 Run the Report

You can distribute the report using a Web browser. Type the following command in the `Location` field of your browser:

```
http://host:port/reports/rwservlet?REPORT=your_path/inventory_report_dist_your_initials.rdf&USERID=your_login_ID&SERVER=your_server_name&DISTRIBUTE=YES&DESTINATION=your_path/distribution.xml
```

where
your_path is where your RDF file and the distribution.xml file is located. your_login_ID is your login information for the sample schema you have used with the sample RDF.

The SMTP mail server is set up during the installation process. If you did not specify a server during installation, you can set up the mail server manually before distributing your report to an e-mail destination. You can specify the outgoing mail server using pluginParam in the server config file.

EXAMPLE:

```xml
<pluginParam name="mailServer">smtp01.mycorp.com</pluginParam>
```

For more information on setting up the mail server, refer to the chapter "Configuring Oracle Reports Services" in the *Publishing Reports to the Web with Oracle Reports Services*

This guide is available on the Oracle Technology Network Oracle Reports Documentation page (http://www.oracle.com/technetwork/middleware/reports/documentation/index.html).

Running the report creates a file for each warehouse based on the warehouse ID in the specified directory. When the report is distributed, a single e-mail is sent to one address with all of these files attached to the e-mail.

If you set up the distribution.xml file for multiple e-mail addresses, each warehouse (or each e-mail address) would be sent a single e-mail with a single attachment file that includes the report for that warehouse.

37.5 Summary

Congratulations! You have distributed a report. You now know how to:

- modify the layout of an existing report to burst on a group in your layout.
- distribute a report using e-mail by modifying the distribution.xml file.

For more information on any of the wizards, views, or properties used in this example, refer to the Oracle Reports online Help, which is available in Oracle Reports Builder or hosted on the Oracle Technology Network (OTN), as described in Section 4.1.1, "Using the Oracle Reports online Help".
In this chapter, you will learn about reports that include multibyte characters. By following the steps in this chapter, you can generate the PDF report output shown in Figure 38–1 and Figure 38–2.

Figure 38–1  Output of the multibyte character set UTF8 report in Japanese

<table>
<thead>
<tr>
<th>Product Id</th>
<th>Translated Name</th>
<th>Translated Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1726</td>
<td>LCDモニター11/PM</td>
<td>液晶ディスプレイ11インチ・パッシブ・モニター。垂直フラット、高解像度画面により、グレアを低減して高品質画像を提供します。</td>
</tr>
<tr>
<td>2359</td>
<td>LCDモニター9/PM</td>
<td>液晶ディスプレイ9インチ・パッシブ・モニター。省スペースの小さな画面で機上の生産性を向上します。プログラムプレイ互換性により、セットアップが簡単です。</td>
</tr>
</tbody>
</table>
With multibyte character support built into Oracle Reports, you can publish reports in any language for your global enterprise. You can produce reports that display text in multibyte character sets, such as Simplified Chinese, Traditional Chinese, Japanese, Korean, and Unicode.

Oracle Reports supports multibyte characters in various output formats, including PDF. In this chapter, you will build a multibyte character set report using the UTF8 character set to generate PDF output.

You can generate a portable PDF file using Oracle Reports. The PDF features, such as font subsetting and embedding, enable you to generate PDF files that can be viewed on an end user's computer without having special fonts installed.

Note: You must have Acrobat Reader installed on your computer to view PDF output.

When you use PDF font embedding, you include the entire font set in the PDF file.

PDF font embedding in Oracle Reports is for single-byte Type1 fonts and not for TrueType fonts. Therefore, if you want to include specific TrueType fonts in your report, you must first convert these fonts to Type1 fonts using any of the available third party tools.

Tip: Make sure that you have the necessary licenses for the fonts before embedding them in your output PDF file.

Although PDF font subsetting and font embedding are mutually exclusive, PDF font subsetting is a variant of PDF font embedding. PDF font subsetting is the preferred method of creating multibyte reports because it works for both single and multibyte fonts.

With the font subsetting, the PDF output file contains information of only those characters that appear in the document. Therefore, this feature produces more efficient output in terms of file size. Both font embedding and subsetting eliminate the dependency of installing specific fonts on your computer.
Example Scenario

In this example, you have an international business with offices in the United States, Japan, and Poland. In the organization, local managers have control of the inventory of the warehouses. Offices in different locations want to print the list of products in their preferred language. You will create a report in PDF format that contains multibyte characters for the Web and paper output.

As you build this example report, you will:

- **Create the Query and Paper Layout for a Multibyte Report** using the Report Wizard.
- **Display Multibyte Characters in the Report** using the UTF8 TrueType font.
- **Create a PDF Document of Your Report**.

To see a sample multibyte character set report, open the examples folder named multibyte, then open the Oracle Reports example named multibyte_utf8.rdf. For details on how to open it, see "Accessing the Example Reports" in the Preface.

38.1 Prerequisites for This Example

To build the example in this chapter, you must have the example files we have provided (see "Example Scenario", above), as well as access to the Order Entry sample schema provided with the Oracle Database. If you do not know if you have access to this sample schema, contact your database administrator. You must also have Acrobat Reader installed on your system.

**Note:** Due to some limitations of Oracle Reports regarding use of the UTF-8 character set and multibyte fonts on UNIX, it is recommended to build this report only on Windows. To deploy a multibyte report on UNIX, refer the chapter "Resolving Cross-Platform Porting Issues" in the *Publishing Reports to the Web with Oracle Reports Services* manual.

**Perform the following set up activities before you run the report:**

1. In the Windows registry, under **KEY_OH** in the **ORACLE** key, set **NLS_LANG** to **AMERICAN_AMERICA.UTF8**.

   **Tip:** Back up your registry before editing it as working with registry keys can cause the system to become unstable.

2. Open the **uifont.ali** file and edit it to specify the TrueType font file name. Type "Arial Unicode MS" = "Arialuni.ttf" under the **[PDF:Subset]** section. After including the line, the **uifont.ali** file should look like:
38.2 Create the Query and Paper Layout for a Multibyte Report

When you create a report, you can use either the Report Wizard to assist you or create the report manually.

To build the report in this example, you will use the Report Wizard. Using the wizard you will specify the layout, style, fields, and template details for the report. You will also provide the SQL query that contains the condition with a runtime user parameter. This parameter allows users to specify the language in which they want the report output printed.

To create a simple report:
1. Launch Oracle Reports Builder (or, if already open, choose File > New > Report).
2. In the Welcome or New Report dialog box, select Use the Report Wizard, then click OK.
3. If the Welcome page displays, click Next.
4. On the next page, make sure that Create both Web and Paper Layout is selected, then click Next.
5. On the Style page:
   - Type a Title for your report, such as Product List.
   - Make sure that Tabular is selected.
   - Click Next.
6. On the Data Source page, make sure that SQL Query is selected, then click Next.

7. On the Data page, click Query Builder.

8. In the Select Data Tables dialog box, click PRODUCT DESCRIPTIONS, then click Include.

9. Click Close.

10. The table is displayed in the Query Builder. Click to the left of the following column names to select them:
    - PRODUCT_ID
    - LANGUAGE ID
    - TRANSLATED_NAME
    - TRANSLATED_DESCRIPTION

11. Click OK.

12. In the Data Source definition field, your query should look something like this:

    SELECT ALL PRODUCT_DESCRIPTIONS.PRODUCT_ID,
    PRODUCT_DESCRIPTIONS.LANGUAGE_ID,
    PRODUCT_DESCRIPTIONS.TRANSLATED_NAME,
    PRODUCT_DESCRIPTIONS.TRANSLATED_DESCRIPTION
    FROM PRODUCT_DESCRIPTIONS

    **Note:** You can enter this query in any of the following ways:
    - Copy and paste the code from the provided text file called utf8_code.txt into the Data Source definition field.
    - Click Query Builder to build the query without entering any code manually, as described in the steps above.
    - Type the code in the Data Source definition field.

13. In the Data Source definition field, type where language_id = :p_lang_id, after the FROM clause in the query. This adds the where clause to the query definition. The where clause restricts data based on the language selected by the user at runtime.

    Your query should now look like this:

    SELECT ALL PRODUCT_DESCRIPTIONS.PRODUCT_ID,
    PRODUCT_DESCRIPTIONS.LANGUAGE_ID,
    PRODUCT_DESCRIPTIONS.TRANSLATED_NAME,
    PRODUCT_DESCRIPTIONS.TRANSLATED_DESCRIPTION
    FROM PRODUCT_DESCRIPTIONS
    where language_id = :p_lang_id

    **Note:** The expression, :p_lang_id, when prefixed with a colon is treated as a parameter. If the parameter does not exist, Oracle Reports Builder creates the parameter. From here on, you can access this parameter in the User Parameters section under the Data Model node in the Object Navigator.

14. Click Next.
Oracle Reports Builder displays the following message to indicate that an additional parameter is created:

Note: The query 'Q_1' has created the bind parameter(s) 'P_LANG_ID'.

15. Click OK.

16. On the Fields page:
   - Click PRODUCT_ID in the Available Fields list, and click the right arrow (>) to move the field to the Displayed Fields list.
   - Click TRANSLATED_NAME and click the right arrow (>) to move the field to the Displayed Fields list.
   - Click TRANSLATED_DESCRIPTION and then click the right arrow (>) to move the field to the Displayed Fields list.

17. Click Next.

18. On the Totals page, click Next.

19. Click Next on the Labels page.

20. On the Templates page, make sure that Beige is selected and click Finish.

   Oracle Reports Builder displays the Runtime Parameter Form because you referenced a user parameter.

21. Type JA, and click the Run Report button to execute the report.

   The report output is displayed in Paper Design view. It should look something like this:

   **Figure 38–4  Paper design view of the report without Japanese characters in default setting**

   ![Product List](image)

   **Tip:** If you do not see any results, make sure that the value JA is typed in capital letters so that data is retrieved from the database for the specified condition.

   You will not see any Japanese characters yet since a UTF8 TrueType font has not been selected.

22. Save the report as multibyteutf8_your_initials.rdf.
You have successfully created and executed the report. Next, you have to change the font to a UTF8 multicharacter set TrueType font to see the characters of the language chosen in the report output.

To change the font to a multicharacter TrueType font:

1. In the Paper Design view, Shift-click the values below the Translated Name and Translated Description labels to select all the values in these two columns. You can now change their properties simultaneously.

2. From the font box in the toolbar, choose Arial Unicode MS.

The report is executed and the Paper Design view of the report output is displayed in Japanese characters. It should look something like this:

![Figure 38–5  Paper design view of the report with Japanese characters](image)

To run the same report again with a different runtime parameter and see the output in another language, perform the following steps:

1. Click the Run Paper Layout button in the toolbar, or choose Program > Run Paper Layout.

2. In the Runtime Parameter Form, type the value `PL`, and click the Run Report button to run the report.
The Paper Design view of the report output is displayed with Polish characters. It should look something like this:

Figure 38–6  Paper design view of the report with Polish characters

<table>
<thead>
<tr>
<th>Product Id</th>
<th>Translated Name</th>
<th>Translated Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1726</td>
<td>Monitor LCD 11/PM</td>
<td>11-calowy pasywny monitor z wyświetlaczem ciełkocrystalcznym. Płaski ekran o dużej rozdzielczości zapewnia doskonałą jakość obrazu ze zmniejszoną poświatą.</td>
</tr>
<tr>
<td>2359</td>
<td>Monitor LCD 9/PM</td>
<td>9-calowy pasywny monitor z wyświetlaczem ciełkocrystalcznym. Niewielkie wymiary monitora pozwalają zacząć dość wiele cernego miejsca na biurku. Łatwa konfiguracja dzięki</td>
</tr>
</tbody>
</table>

### 38.4 Create a PDF Document of Your Report

Oracle Reports Builder supports multibyte characters in the PDF format. By generating the PDF file of your report, you have the advantages of being able to:

- create the report output in a portable format.
- use PDF font subsetting and PDF font embedding feature.

**Tip:** Make sure you perform the following steps before you generate the file:

- Change the registry entry for `NLS_LANG` to `AMERICAN_america.UTF8`.
- Edit the `uifont.ali` file.
- Edit the `REPORTS_PATH` registry entry.

See Section 38.1, "Prerequisites for This Example" for more details.

**To generate the PDF file:**

1. In Oracle Reports Builder, choose File > Generate to File > PDF.
2. Save the report as `multibyteutf8_your_initials.pdf`.
3. In the Runtime Parameter Form that displays, type the value `PL` (exactly as shown), and click the Run Report button to execute the report.
The Report Progress dialog box is displayed and provides the print status of the PDF output. When the PDF is created, this dialog box disappears.

4. Locate the PDF file (multibyteutf8_your_initials.pdf) and double-click to open the file.

It should look something like this:

*Figure 38–7  PDF file of the report with Polish characters*

<table>
<thead>
<tr>
<th>Product Id</th>
<th>Translated Name</th>
<th>Translated Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1726</td>
<td>Monitor LCD 11/PM</td>
<td>11-calowy paskowy monitor z wyświetlarzem dektrystalcznym. Plaski ekran o dużej rozdzielczości zapewnia doskoną jasność obrazu ze zmniejszoną poświatą.</td>
</tr>
</tbody>
</table>

**Note:** You can open the PDF file on any computer and it will look exactly the same, without installing any Unicode font. This is because the PDF file includes the font used in the report.

Notice the default rough visual appearance of the characters in the PDF output. You can smooth the characters by using "smoothe lineart" setting in Acrobat Reader.

### 38.5 Summary

Congratulations! You have successfully created a report to support any character set in your enterprise. You have used Oracle Reports Builder to generate a portable PDF file using font subsetting.

You now know how to:

- create the query and paper layout for the multibyte report using the Report Wizard.
- display multibyte characters using the UTF8 TrueType font.
- create a portable PDF file of your report.

For more information on any of the wizards, views, or properties used in this example, refer to the Oracle Reports online Help, which is available in Oracle Reports Builder or hosted on the Oracle Technology Network (OTN), as described in Section 4.1.1, "Using the Oracle Reports online Help".
The chapters in this Part provide steps to build reports that use PL/SQL code or Java. You can include PL/SQL, PL/SQL libraries, REF CURSORS, and barcodes in your reports, and build JSP-based Web reports that include a Parameter Form.

- Chapter 40, "Building a Report that Includes PL/SQL"
A PL/SQL report uses an external PL/SQL library and PL/SQL within a report to modify formatting and to perform calculations on column values. For example, you can use a PL/SQL procedure in a format trigger to include a space between records similar to a break report or to calculate the total compensation for each employee.

- Chapter 41, "Building a Paper Report with REF CURSORS"
A paper report with REF CURSORS helps manage queries. (A REF CURSOR is a PL/SQL cursor datatype that you can reference from within a PL/SQL query.) For example, if you already have numerous queries built and you want to reuse those queries in your reports, you can use a REF CURSOR in your report data model to access those queries.

- Chapter 42, "Building a Simple Parameter Form for a JSP-based Web Report"
A JSP-based Web report can be modified by adding a Parameter Form to accept user input at runtime that will determine what data will display in the report.

- Chapter 43, "Building a Report with a Barcode"
A barcode can be added to a paper or Web report by using the barcode JavaBean. In Oracle Reports Builder, the barcode JavaBean automatically generates a barcode for you based on the data you specify. For example, you can use the barcode to track shipping orders by generating a barcode based on the shipping order code.

- Chapter 44, "Building an Accessible JSP-based Web Report"
Using Oracle Reports and the standards defined in the Web Accessibility Guidelines, you can create a report that produces output that is compatible with assistive technologies such as screen readers. Oracle Reports provides properties and tags to support this effort.
39

Building a Report with Graphs

In this chapter, you will learn about the new graph types in Oracle Reports 12c (12.2.1.1) and new features supported by Oracle Reports Builder.

39.1 About Graphs and Graph Wizards

The Graph Wizard provides an easy way for you to add a wide variety of graphs to both paper-based and JSP-based web reports. Oracle Reports Builder uses the information you specify on each page of the wizard to create an XML definition that describes the graph and renders to resulting look-and-feel of the graph at runtime.

Table 39–1 details the new graphing functionality in Oracle Reports 12c (12.2.1.1), along with the equivalent 10g Release 2 (10.1.2) functionality:

Table 39–1  11g Functionality vs. 10g Functionality

<table>
<thead>
<tr>
<th>11g New Features and Enhancements</th>
<th>Equivalent 10g Functionality</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>New graph types</strong>: New funnel, enhanced pie and curved line graph types allow for more variety in graphing.</td>
<td></td>
</tr>
<tr>
<td>- For funnel graphs, use the Graph Wizard to choose the funnel graph style on the Style panel.</td>
<td></td>
</tr>
<tr>
<td>- For curved line graphs, use the steps in Section 4.9.8.2, &quot;Adding a graph&quot; to create a simple line graph, then add the following to your graph XML definition:</td>
<td></td>
</tr>
<tr>
<td><code>&lt;SeriesItems&gt;</code></td>
<td></td>
</tr>
<tr>
<td><code>&lt;Series id=&quot;0&quot; markerType=&quot;MT_CURVE_LINE&quot;/&gt;</code></td>
<td></td>
</tr>
<tr>
<td><code>&lt;/SeriesItems&gt;</code></td>
<td></td>
</tr>
<tr>
<td><strong>Enhancements for existing graph types:</strong></td>
<td></td>
</tr>
<tr>
<td>Support for number formatting in the Graph Wizard, and plotting irregular time periods on the time-axis.</td>
<td></td>
</tr>
<tr>
<td>- Number formatting support in the Graph Wizard allows you to format the numbers in the graph, independent of the data model.</td>
<td></td>
</tr>
<tr>
<td>For number formatting, use the Graph Wizard (Y Format panel &gt; Format Axis Labels button &gt; Number tab) to format Y-axis numbers.</td>
<td></td>
</tr>
<tr>
<td>- Support for irregular time period enables plotting the time data without restrictions. For more information, see Plotting Irregular Time Periods.</td>
<td></td>
</tr>
<tr>
<td><strong>Scalable Vector Graphic (SVG) image support</strong>: SVG provides for high resolution and smaller file size in graph output. Graph image output scales up better without losing resolution.</td>
<td></td>
</tr>
<tr>
<td><strong>New Chart Styles</strong>: Support for new pre-defined styles in style panel of Graph Wizard.</td>
<td></td>
</tr>
<tr>
<td><strong>Restrictions on plotting time data.</strong></td>
<td></td>
</tr>
<tr>
<td>Support for only PNG, JPG, and GIF output formats.</td>
<td></td>
</tr>
</tbody>
</table>
While the Graph Wizard enables you to create and edit the attribute values and layout of a graph, there are additional attributes that are not exposed through the Graph Wizard. To customize your graph XML definition beyond the scope of the Graph Wizard, you can directly edit the XML in the graph’s Graph Settings property (for paper-based reports), or in the Web Source view (for JSP-based Web reports). The full list of attributes available is defined in the DTD file, `graph.dtd`.

---

**Note:** The `graph.dtd` is available in the following locations:

- `ORACLE_COMMON/modules/oracle.adf.view_11.1.1/dvt-jclient.jar`
- In *Getting Started with Oracle Reports* on the Oracle Technology Network (OTN): on the Oracle Reports page (http://www.oracle.com/technetwork/middleware/reports/overview/index.html), navigate to Learn More and click Getting Started to display the Getting Started with Oracle Reports home page. In the list of topic sections on the left, click Index. In the Collateral Type list, choose Documentation and click Search. In the list that is displayed, find Documented Graph DTD.

---

**Usage notes**

- When you specify a graph title, subtitle, footnote, or axis title in the Graph Wizard, you can insert lexical references (to user parameters, system parameters, and columns) in the text that will display their value at runtime.
- When you specify dates in your graphs, the date values may display in a different format in a graph than in other fields in your report output.
- In prior releases, the Graph Wizard’s Type panel included a 3DEffect check box to allow you to specify whether to display the graph with the appearance of depth. To implement this effect in the current release, you will need to edit your graph XML definition as shown in bold font in the following example for a bar graph:

```xml
<rw:graph id="CT_1" src="G_EMPNO" groups="ENAME" dataValues="SAL">
    <xml version="1.0" ?>
        <Graph version="3.2.0.22" depthAngle="50" depthradius="8" pieDepth="30" pieTilt="20"/>
    ...
    -->
</rw:graph>
```

- Reports built with previous versions of Oracle Reports containing Oracle Graphics 6i charts will continue to run if the Oracle Graphics 6i runtime is installed on the same computer in a separate ORACLE_HOME. However, this is not a supported configuration, and Oracle will not fix bugs that result from this configuration.

---

**Primary Graph Types**

For most graphing needs, the following primary graph types will provide the best means to represent data:

- Bar graph
- line graph
- area graph
- pie graph
Secondary Graph Types
These are special usage or less common graphs that are associated with particular data types or ways to display unique cases of data:

- scatter graph
- bubble graph
- radar graph
- polar graph
- pareto graph
- stock graph
- 3-D graph
- curved line graph

See Also, Section 39.3, "New Graph Types"

Access
To display the Graph Wizard for paper reports:

- In the Paper Layout view, choose Insert > Graph.
- In the Paper Layout view, right-click in the main area (canvas region) and choose Graph Wizard.

To display the Graph Wizard for JSP-based Web reports:

- In the Web Source view, choose Insert > Graph.

Re-entrancy
To re-enter the Graph Wizard for an existing graph in paper reports:

1. In the Paper Layout view, click the graph.
2. To display the Graph Wizard in re-entrant mode, do either of the following:
   - Right-click the graph, and choose Graph Wizard.
   - Click the graph, then choose Edit > Settings.

To re-enter the Graph Wizard for an existing graph in JSP-based Web reports:

In the Web Source view, place your cursor anywhere between the <rw:graph> and </rw:graph> tags, then choose Edit > Settings.

Using the Graph Wizard
For help on the fields on any tab page of the wizard, click Help at the bottom of the tab page.

See also
Section 4.9.8.2, "Adding a graph"
Section 4.9.8.3, "Editing a graph"
Section 4.9.8.4, "Adding a graph hyperlink"
### 39.2 New Features and Benefits

Oracle Reports provides a convenient way for you to add a wide variety of graphs to both paper-based and JSP-based Web Reports.

Oracle Reports 12c (12.2.1.1) supports the following features:

- Scalable Vector Graphics (SVG) image support
- Plotting Irregular time periods. For more information, see Plotting Irregular Time Periods.
- New Chart Style in Graph Wizard. For more information, see New Chart Styles.
- Number formatting support in Graph Wizard

With the new graph types and features, Reports Builder provides the following benefits:

- More graph types for the varied usage
- Better graph image output without loosing resolution
- Plot time data without restrictions
- Format the numbers in the graph independent of the data model

**Plotting Irregular Time Periods**

Oracle Reports 12c (12.2.1.1) provides support for plotting irregular time periods on time axis. For more information see Figure 39–1, "Plotting Irregular Time Period”.

**Figure 39–1  Plotting Irregular Time Period**

![Plotting Irregular Time Period](image)

**New Chart Styles**

Oracle Reports 12c (12.2.1.1) supports the following new chart styles:

- Autumn
- Black and White
- Earth
- Executive
- Financial
- Projection
- Regatta
For more information, see Figure 39–2, "New Chart Styles".

**Figure 39–2  New Chart Styles**

Oracle Reports 12c (12.2.1.1) supports the following graph types:

- **Funnel Graph**
- **Curved Line or Fit To Curve Graph**
- **Enhanced Pie**

### 39.3.1 Funnel Graph

A funnel graph is a visual representation of data related to steps in a process. As the value for a given step of the funnel approaches the quota for that slice, the slice fills. A funnel renders a three-dimensional chart that represents the target and actual values, and levels by color. For more information, see Figure 39–3, "Funnel Graph".

**Figure 39–3  Funnel Graph**

### 39.3.2 Curved Line or Fit To Curve Graph

A curved line or fit-to-curve is a graph in which data is represented as a curved line, as a series of data points, or as data points that are connected by a line. Curved line graphs require data for at least two points for each member in a group. For more information, see Figure 39–4, "Curved Line Graph".
39.3.3 Enhanced Pie

A pie graph represents data as sections of one or more circles, making the circles look like sliced pies. With the enhanced pie, you can include any combination of data value, percent, and text label.
In this chapter, you will learn about reports that include PL/SQL. By following the steps in this chapter, you can generate the report output shown in Figure 40–1.

![PL/SQL report output](image)

### Figure 40–1  PL/SQL report output

<table>
<thead>
<tr>
<th>Name</th>
<th>Job Id</th>
<th>Salary</th>
<th>Commission</th>
<th>Bonus</th>
<th>Total Compensation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ellen Abel</td>
<td>SA_REP</td>
<td>$10,000.00</td>
<td>$0.30</td>
<td>$2145.00</td>
<td>$18445.00</td>
</tr>
<tr>
<td>Sunder Anoo</td>
<td>SA_REP</td>
<td>$8,400.00</td>
<td>$0.10</td>
<td>$1056.00</td>
<td>$8056.00</td>
</tr>
<tr>
<td>Michle Alliron</td>
<td>ST_CLERK</td>
<td>$5800.00</td>
<td>$420.00</td>
<td>$5220.00</td>
<td>$5220.00</td>
</tr>
<tr>
<td>David Austin</td>
<td>IT_PROG</td>
<td>$4800.00</td>
<td>$720.00</td>
<td>$5520.00</td>
<td>$5520.00</td>
</tr>
<tr>
<td>Hermann Beer</td>
<td>PR_REP</td>
<td>$10000.00</td>
<td>$1500.00</td>
<td>$11500.00</td>
<td>$11500.00</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Name</th>
<th>Job Id</th>
<th>Salary</th>
<th>Commission</th>
<th>Bonus</th>
<th>Total Compensation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Sheili Balda</td>
<td>PU_CLERK</td>
<td>$2000.00</td>
<td>$435.00</td>
<td>$2335.00</td>
<td>$2335.00</td>
</tr>
<tr>
<td>Amy Banda</td>
<td>BA_REP</td>
<td>$6200.00</td>
<td>$0.10</td>
<td>$1023.00</td>
<td>$7243.00</td>
</tr>
<tr>
<td>Elizabeth Sales</td>
<td>SA_REP</td>
<td>$7000.00</td>
<td>$0.15</td>
<td>$1250.25</td>
<td>$8250.25</td>
</tr>
<tr>
<td>Sarah Bell</td>
<td>SH_CLERK</td>
<td>$5000.00</td>
<td>$600.00</td>
<td>$4600.00</td>
<td>$4600.00</td>
</tr>
<tr>
<td>David Bernstein</td>
<td>BA_REP</td>
<td>$6000.00</td>
<td>$0.25</td>
<td>$1791.25</td>
<td>$13691.25</td>
</tr>
</tbody>
</table>

### Concepts

- There are a variety of ways to incorporate PL/SQL into your reports. You have already created formula columns that used simple PL/SQL expressions to compute their values, and format triggers that used PL/SQL to conditionally determine the formatting of mailing labels. Here, you will create external libraries and local functions and procedures.

- External PL/SQL libraries are modules that contain named PL/SQL functions and procedures. They may be stored either in the database or in a file, and can be referenced from not only any report, but from other Oracle products. External libraries eliminate the need to re-enter commonly-used PL/SQL constructs, whether in reports, forms, or graphs. This, in turn, eliminates the problem of maintaining several versions of the same PL/SQL code.

- Local PL/SQL consists of named PL/SQL functions and procedures that are saved in a report definition. Local PL/SQL may be referenced only by objects within the report (for example, group filters, formula columns, format triggers, and so on). However, the usefulness of storing PL/SQL in a single location still applies.

### Data Relationships

This report uses one query. You will add a function stored in an external library, a report-level function, two formula columns, and a parameter governing the number of records to display before inserting a space.

### Layout

This report uses the tabular layout style, with minor modifications.
Example Scenario
In this example, you will use an external PL/SQL library and PL/SQL within a report to modify formatting to add spacing between records, and calculate the total compensation for each employee. You will manually create a query in the Data Model view, then modify the layout of the report in the Paper Layout view. You will create formula columns, a summary column, and a format trigger that uses a summary column and a user parameter.

As you build this example report, you will:

- Create a New PL/SQL Library that you will use in this report.
- Create the Report Definition:
  - Create a query.
  - Create a formula column that calculates bonuses.
  - Create a report-level function that calculates total compensation.
  - Create a second formula column for total compensation.
- Create the Report Layout Using the Report Block Wizard.
- Add Vertical Space Between Records:
  - Create a user parameter.
  - Create a summary column that counts the number of records.
  - Modify the layout.
  - Create a format trigger.
- Run Your Report to Paper.

To see a sample PL/SQL report, open the examples folder named \texttt{plsql}, then open the Oracle Reports example named \texttt{plsql.rdf}. For details on how to open it, see "Accessing the Example Reports" in the Preface.

40.1 Prerequisites for This Example
To build the example in this chapter, you must have access to the Human Resources sample schema (HR) provided with the Oracle Database. If you do not know if you have access to this sample schema, contact your database administrator.

40.2 Create a New PL/SQL Library
The steps in this section will show you how to create a new PL/SQL library, then create a function that will live in this library.

To create the library:
1. Launch Reports Builder (or, if already open, choose File > New > Report).
2. In the Welcome or New Report dialog box, select Build a new report manually, then click OK.
3. In the Object Navigator, choose File > New > PL/SQL Library.
A new library displays in the Object Navigator below your report name, under the PL/SQL Libraries node.
4. If it is not already expanded, expand the node of the new library to show the two subnodes: **Program Units** and **Attached Libraries**.

5. Click the **Program Units** node, then choose **Edit > Create**.

6. In the New Program Unit dialog box, in the **Name** field, type **BONUS_PAY**.

7. Select **Function**, then click **OK** to display the PL/SQL Editor.

8. In the PL/SQL Editor, use the template to enter the following PL/SQL code:

   ```plsql
   FUNCTION BONUS_PAY(JOB_ID IN CHAR, SAL IN NUMBER, COMM_PCT IN NUMBER) RETURN NUMBER IS
   BEGIN
   IF JOB_ID != 'SA_REP' THEN
     RETURN (SAL * 0.15);
   ELSE
     IF SAL * COMM_PCT >= 500 THEN
       RETURN ((SAL + SAL * COMM_PCT) * 0.15);
     ELSE
       RETURN ((SAL + SAL * COMM_PCT) * 0.10);
     END IF;
   END IF;
   END;
   ```

---

**Note:** You can enter this code by copying and pasting it from the provided text file called `plsql_code.txt`.

---

9. Click **Compile**.

10. If there are compilation errors, match your code to the code we have provided (either in the example RDF file or in this chapter), then compile it again.

11. Once there are no compilation errors, click **Close**.

   Your new function displays in the Object Navigator.

12. Choose **File > Save** to save your new function.

13. In the Save Library dialog box, type `bonus.pll`, make sure **File System** is selected, then click **OK**.

14. In the Object Navigator, under the **MODULE1** report you have created, click the **Attached Libraries** node. Be sure to select this node, and not the one under the **PL/SQL Libraries** node.

15. Choose **Edit > Create**.

16. In the Attach Library dialog box, in the **Library** field, type `bonus.pll`.

   **Note:** If you saved `bonus.pll` to another directory, you can click **Browse** to find it on your file system. Just make sure you have selected **File System** before browsing.

17. When the library name displays in the **Library** field, click **Attach** to attach the library.
Create the Report Definition

40.3 Create the Report Definition

The steps in this section will show you how to create the query and the formula columns that will define the report and call the code in the bonus.pll external PL/SQL library you created.

We recommend that you create the objects in the order described, as some of the formula columns depend on the functions, and so on.

40.3.1 Create a query

The steps in this section will show you how to create the query that will retrieve the data necessary for this report.

To create the query:

1. In the Object Navigator, double-click the view icon next to the Data Model node to display the Data Model view.

2. In the Data Model view, choose Insert > Query to display the Data Wizard.

3. If the Welcome page displays, click Next.

4. On the Query page, leave the default query name, then click Next.

5. On the Data Source page, select SQL Query, then click Next.
6. On the Data page, enter the following `SELECT` statement in the **Data Source definition** field:

```
SELECT FIRST_NAME, LAST_NAME, JOB_ID, SALARY, COMMISSION_PCT
FROM EMPLOYEES
ORDER BY LAST_NAME
```

**Note:** You can enter this query in any of the following ways:
- Copy and paste the code from the provided text file called `plsql_code.txt` into the **Data Source definition** field.
- Click **Query Builder** to build the query without entering any code manually.
- Type the code in the **Data Source definition** field.

7. Click **Next**.

**Note:** If you are not already connected to a database, you will be prompted to connect to the database when you click **Query Builder** or **Next**. Ensure that you connect to a database that has the appropriate schema for this example. Section 40.1, "Prerequisites for This Example" describes the sample schema requirements for this example.

8. On the Groups page, click **Next**.

9. Click **Finish** to display your first query in the Data Model view. It should look something like this:

![Figure 40–3 Data Model view of the PL/SQL report](image)

10. Save your report.

### 40.3.2 Create a formula column that calculates bonuses

The steps in this section will show you how to create a formula column that will calculate the salary bonus for each employee using the PL/SQL function.
To create the BONUS formula column:

1. In the Data Model view, click group `G_FIRST_NAME`, then click the bottom resize handle and drag it down to make room in the group for more columns. Here is an example of what it should look like now:

   **Figure 40–4  Data Model with expanded G_FIRST_NAME**

   ![Data Model with expanded G_FIRST_NAME](image)

2. Click the Formula Column tool in the tool palette, then click in the `G_FIRST_NAME` group to create a formula column.

   **Figure 40–5  Data Model with unnamed formula column**

   ![Data Model with unnamed formula column](image)

3. Double-click the new formula column object (CF_1) to display the Property Inspector, and set the following properties:
   - Under **General Information**, set the Name property to `BONUS`.
   - Under **Placeholder/Formula**, click the PL/SQL Formula property field to display the PL/SQL Editor.

4. In the PL/SQL Editor, use the template to enter the following PL/SQL code:

   ```plsql
   function BONUSFormula return Number is
   begin
     return BONUS_PAY(:JOB_ID, :SALARY, :COMMISSION_PCT);
   end;
   ```
5. Click Compile.

---

**Note:** If there are compilation errors, compare your code closely against the code we have provided.

6. When there are no compilation errors, click Close to display the data model for your report in the Data Model view. It should look something like this:

![Figure 40–6 Data Model with BONUS formula column](image)

7. Save your report.

### 40.3.3 Create a report-level function that calculates total compensation

The steps in this section will show you how to write a function that returns the total compensation for each sales representative (the values of columns SALARY plus COMM plus BONUS), as well as other employees (SALARY plus BONUS).

1. In the Object Navigator, click the Program Units node, then choose Edit > Create.

2. In the New Program Unit dialog box, in the Name field, type FINAL_CALC.

3. Select Function, then click OK.

4. In the PL/SQL Editor, use the template to enter the following PL/SQL code:

   ```plsql
   FUNCTION FINAL_CALC RETURN NUMBER IS
   BEGIN
     IF :JOB_ID = 'SA_REP' THEN
       RETURN (:BONUS + :SALARY + :COMMISSION_PCT * :SALARY);
     ELSE
       RETURN (:BONUS + :SALARY);
     END IF;
   END;
   ```

**Note:** You can enter this code by copying and pasting it from the provided text file called `plsql_code.txt`. This code is for the Bonus Formula Column.

**Note:** If there are compilation errors, compare your code closely against the code we have provided.
5. Click **Compile**.

6. When the code is compiled without errors, click **Close**.

   The new function, **FINAL_CALC**, now displays in the Object Navigator:

   ![Object Navigator with FINAL_CALC function](image)

   **Figure 40–7**  *Object Navigator with FINAL_CALC function*

7. Save your report.

### 40.3.4 Create a second formula column for total compensation

The steps in this section will show you how to create another formula column that will calculate the total compensation. The value calculated by the report-level function **FINAL_CALC** will be assigned to the column **TOTAL_COMP**. If you are not sure how to create a formula column, refer to *Section 40.3.2, “Create a formula column that calculates bonuses”.*

**To create the TOTAL_COMP formula column:**

1. In the Data Model view, follow the steps above to create a second formula column below the **BONUS** formula column.

2. Double-click the new formula column object (**CF_1**) to display the Property Inspector, and set the following properties:
   - Under **General Information**, set the Name property to **TOTAL_COMP**.
   - Under **Placeholder/Formula**, click the PL/SQL Formula property field to display the PL/SQL Editor.

3. In the PL/SQL Editor, use the template to enter the following PL/SQL code:

   ```plsql
   function TOTAL_COMPFormula return Number is
       begin
           return FINAL_CALC;
       end;
   
   Note: You can enter this code by copying and pasting it from the provided text file called plsql_code.txt. This code is for the Total Comp Formula Column.
   ```
4. Click Compile.

5. When the code is compiled without errors, click Close to display the data model for your report in the Data Model view. It should look something like this:

![Data Model with BONUS and TOTAL_COMP formula columns](Figure 40–8)

6. Save your report.

40.4 Create the Report Layout Using the Report Block Wizard

Now that you have created the necessary formula columns and functions, you can create the layout for your report.

To create the report layout:
1. Click the Paper Layout button in the toolbar to display the Paper Layout view.

2. In the Paper Layout view, choose Insert > Report Block.

3. In the Report Block Wizard, on the Style page, select Tabular, then click Next.

4. On the Groups page, click G_FIRST_NAME in the Available Groups list and click Down to specify the Print Direction and move this group to the Displayed Groups list, then click Next.

5. On the Fields page, click the double right arrows (>>) to move all of the fields to the Displayed Fields list. The Displayed Fields list should look like this:

![Displays Fields list](Figure 40–9)
6. Click Next.

7. On the Labels page, change the labels as follows, then click Next:

<table>
<thead>
<tr>
<th>Fields</th>
<th>Labels</th>
</tr>
</thead>
<tbody>
<tr>
<td>COMMISSION_PCT</td>
<td>Commission</td>
</tr>
<tr>
<td>TOTAL_COMP</td>
<td>Total Compensation</td>
</tr>
</tbody>
</table>

8. On the Template page, click Finish to display your report layout in the Paper Layout view. It should look something like this:

**Figure 40–10  Paper Layout view of the PL/SQL example report**

9. Click the Run Paper Layout button in the toolbar to run and display your report in the Paper Design view.

10. In the Paper Design view, click the Flex Off button in the toolbar.

11. Delete the Last Name label.

12. Change the text for the First Name label to Name.

13. Adjust the width of the new Name label to span over both the first name and last name columns.

14. Adjust the sizes of the first name and last name columns so that one character displays between the columns.

15. In the Object Navigator, double-click the properties icon next to the F_FIRST_NAME field to display the Property Inspector, and set the following properties:
   - Under General Layout, set the Vertical Elasticity property to Fixed, and set the Horizontal Elasticity property to Variable.

16. Repeat the above step for the F_LAST_NAME field.

17. Click the Paper Layout button in the toolbar to display the Paper Layout view.

18. In the Paper Layout view, click the Frame tool in the tool palette.

19. Draw a frame around the two fields: F_FIRST_NAME and F_LAST_NAME.

20. With the frame selected, choose Tools > Property Inspector to display the Property Inspector, and set the following properties:
   - Under General Information, set the Name property to M_NAME.

21. In the Paper Layout view, make sure Flex Off is selected in the toolbar.

22. With the frame selected, choose Layout > Move Backward until the frame encloses both the F_FIRST_NAME and F_LAST_NAME fields.

---

**Note:** If the fields do not display in the correct order, simply click the field name and drag the field to the correct position in the list.
Create the Report Layout Using the Report Block Wizard

**Tip:** You can watch the fields in the Object Navigator as you choose Layout > Move Backward. When you see the two fields are sub-nodes of **M_NAME**, stop.

When you are done, the Object Navigator should look like this:

*Figure 40–11 Object Navigator with **M_NAME** repeating frame*

23. Click the Paper Design button in the toolbar to display the report in the Paper Design view.

24. In the Paper Design view, Shift-click the values under the following columns:
   - Salary
   - Commission
   - Bonus
   - Total Compensation

25. Click the Currency button in the toolbar to add "$" to the numbers.

26. Click the Add Decimal Place button twice to add two decimal points to the numbers.

27. Shift-click the Salary, Commission, Bonus, and Total Compensation column headings to select them too.

28. Click the Align Right button to right justify the columns.

Your report should now look something like this:

*Figure 40–12 Paper Design view of modified report*

<table>
<thead>
<tr>
<th>Name</th>
<th>Job Id</th>
<th>Salary</th>
<th>Commission</th>
<th>Bonus</th>
<th>Total Compensation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ellen Abel</td>
<td>SA REP</td>
<td>$10000.00</td>
<td>$0.30</td>
<td>$2145.00</td>
<td>$12345.00</td>
</tr>
<tr>
<td>Susan Anne</td>
<td>SA REP</td>
<td>$6400.00</td>
<td>$0.16</td>
<td>$1606.30</td>
<td>$8006.30</td>
</tr>
<tr>
<td>Kristie Johnson</td>
<td>ST_CLERK</td>
<td>$2000.00</td>
<td>$420.90</td>
<td>$2420.90</td>
<td>$3200.00</td>
</tr>
<tr>
<td>David Austin</td>
<td>IT_PROG</td>
<td>$4800.00</td>
<td>$720.90</td>
<td>$5520.00</td>
<td>$6520.00</td>
</tr>
<tr>
<td>Hermann Buer</td>
<td>PR REP</td>
<td>$10000.00</td>
<td>$1500.90</td>
<td>$11500.00</td>
<td>$11500.00</td>
</tr>
</tbody>
</table>

29. Save your report.
40.5 Add Vertical Space Between Records

To make the report more readable, you can add space between a certain number of records. To do so, you first create the parameter that determines the number of records between which the space will display. Then, you create a summary column in the data model that counts the number of records. You will then modify the paper layout of your report so that the vertical elasticity is variable. Finally, you will create a format trigger that will display the space between the user-determined number of records.

40.5.1 Create a user parameter

The parameter you will create in this section will determine how many records are displayed before an extra space is printed. Since this parameter is a user parameter, the user can change this value at runtime.

To create a user parameter:
1. In the Object Navigator, under the Data Model node, click the User Parameters node.
2. Choose Edit > Create to create a new user parameter under the User Parameters node.
3. If the Property Inspector is not already displayed, right-click the new user parameter (P_1), then choose Property Inspector to display the Property Inspector, and set the following properties:
   ■ Under General Information, set the Name property to SPACE.
   ■ Under Parameter, set the Datatype property to Number, and set the Initial Value property to 5.

   Note: By giving the user parameter an initial value, the user can simply run the report without changing the parameters, and a space will display between every five records.

   The user parameter now displays in the Object Navigator:

   Figure 40–13  User Parameter in the Object Navigator

4. Save your report.

40.5.2 Create a summary column that counts the number of records

In this section, you will create a summary column in the data model that counts the number of employee records. This information will then be used by the format trigger to determine where to add extra space.
To create a summary column:
1. In the Object Navigator, double-click the view icon next to the Data Model node to display the Data Model view.
2. In the Data Model view, click the Summary Column tool in the tool palette, then click in the G_FIRST_NAME group beneath the TOTAL_COMP formula column to create a new summary column:

![Data Model with new summary column](image)

3. Double-click the new summary column object (CS_1) to display the Property Inspector, and set the following properties:
   - Under General Information, set the Name property to CNT_COLUMN.
   - Under Summary, set the Function property to Count, and set the Source property to FIRST_NAME.
4. Save your report.

40.5.3 Modify the layout

To allow Reports Builder to insert the vertical spacing, you must modify the layout of your report.

To add vertical elasticity:
1. Click the Paper Layout button in the toolbar to display the Paper Layout view.
2. Click the Flex On button in the toolbar.
3. In the Paper Layout view, click the repeating frame associated with G_FIRST_NAME.
4. Click the center handle of the frame and drag the frame downward to create additional space. This additional space should be slightly larger than what you want to see between the sets of records.

Note: If you cannot find the repeating frame in the Paper Layout view, you can click R_G_FIRST_NAME in the Object Navigator. The associated repeating frame will be selected in the Paper Layout view.
5. With the repeating frame selected, choose **Tools > Property Inspector** to display the Property Inspector, and set the following properties:
   - Under **General Layout**, set the Vertical Elasticity property to Variable.
6. In the Paper Layout view, click the Rectangle tool in the tool palette, and draw a rectangle below the fields in the newly created space.
7. Make sure the new rectangle has no fill and no line so that it is not visible.
   The following image shows the new layout with the invisible rectangle:

   **Figure 40–15  Layout with added vertical space**

8. Save your report.

### 40.5.4 Create a format trigger

Now that you have adjusted the layout, you can create a format trigger based on the new boilerplate rectangle you created in the previous section. This format trigger will display this space after every set number of records, determined by the user parameter.

**To create a format trigger on the boilerplate rectangle:**

1. While the rectangle is selected in the Paper Layout view, press F11 on your keyboard (or choose **Tools > PL/SQL Editor**) to display the PL/SQL Editor.
2. In the PL/SQL Editor, use the template to enter the following PL/SQL code:

   ```plsql
   function B_1FormatTrigger return boolean is
     begin
       if :CNT_COLUMN mod :SPACE = 0 then
         return(TRUE);
       else
         return(FALSE);
       end if;
     end;
   end;
   ```

3. Click **Compile**.
4. When the code is compiled without errors, click **Close**.
5. Save your report.

### 40.6 Run Your Report to Paper

Now that you have added space and created your format trigger, your report should display with space after every five records (or the number of records you specify in the Parameter Form).
To run your report:

- Click the Run Paper Layout button in the toolbar. When the Parameter Form displays, click the Run button in the toolbar.

Your report displays in the Paper Design view, and should look something like this:

![Figure 40–16 Final PL/SQL example report](image)

<table>
<thead>
<tr>
<th>Name</th>
<th>Job Id</th>
<th>Salary</th>
<th>Commission</th>
<th>Bonus</th>
<th>Total Compensation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ellen Abel</td>
<td>BA_REP</td>
<td>$11000.00</td>
<td>$0.30</td>
<td>$2145.00</td>
<td>$13145.00</td>
</tr>
<tr>
<td>Sundar Arora</td>
<td>BA_REP</td>
<td>$8400.00</td>
<td>$0.10</td>
<td>$1056.00</td>
<td>$9456.00</td>
</tr>
<tr>
<td>Michelle Alkinson</td>
<td>ST_CLERK</td>
<td>$3800.00</td>
<td>$0.00</td>
<td>$420.00</td>
<td>$4200.00</td>
</tr>
<tr>
<td>David Austin</td>
<td>IT_PROG</td>
<td>$4800.00</td>
<td>$0.00</td>
<td>$720.00</td>
<td>$5520.00</td>
</tr>
<tr>
<td>Hermann Baer</td>
<td>PR_REP</td>
<td>$10000.00</td>
<td>$0.00</td>
<td>$1500.00</td>
<td>$11500.00</td>
</tr>
<tr>
<td>Shellie Belda</td>
<td>PU_CLERK</td>
<td>$2900.00</td>
<td>$0.00</td>
<td>$435.00</td>
<td>$3335.00</td>
</tr>
<tr>
<td>Amit Banda</td>
<td>BA_REP</td>
<td>$12000.00</td>
<td>$0.10</td>
<td>$1023.00</td>
<td>$13023.00</td>
</tr>
<tr>
<td>Elizabeth Bales</td>
<td>BA_REP</td>
<td>$7300.00</td>
<td>$0.15</td>
<td>$1259.25</td>
<td>$8559.25</td>
</tr>
<tr>
<td>Sarah Bell</td>
<td>SH_CLERK</td>
<td>$4000.00</td>
<td>$0.00</td>
<td>$600.00</td>
<td>$4600.00</td>
</tr>
<tr>
<td>David Bernstein</td>
<td>BA_REP</td>
<td>$8500.00</td>
<td>$0.25</td>
<td>$1781.25</td>
<td>$10281.25</td>
</tr>
</tbody>
</table>

40.7 Summary

Congratulations! You have successfully built a report that uses an external PL/SQL library to calculate employee bonuses, which you can now use in other reports by simply referring to it. You now know how to:

- create and use an external PL/SQL library.
- create a default layout in the Report Wizard.
- add vertical space between a user-determined number of records.

For more information on any of the wizards, views, or properties used in this example, refer to the Oracle Reports online Help, which is available in Oracle Reports Builder or hosted on the Oracle Technology Network (OTN), as described in Section 4.1.1, "Using the Oracle Reports online Help".
Building a Paper Report with REF CURSORs

In this chapter, you will learn about reports that include the PL/SQL datatype \texttt{REF CURSOR}. By following the steps in this chapter, you can generate the report output shown in Figure 41–1.

Figure 41–1 \textit{REF CURSOR} report output

![Employee Table]

<table>
<thead>
<tr>
<th>Employee Id</th>
<th>Start Date</th>
<th>End Date</th>
</tr>
</thead>
<tbody>
<tr>
<td>114</td>
<td>01-MAY-97</td>
<td>01-JUL-99</td>
</tr>
<tr>
<td>145</td>
<td>01-OCT-95</td>
<td>11-AUG-98</td>
</tr>
<tr>
<td>103</td>
<td>19-AUG-96</td>
<td>17-MAY-98</td>
</tr>
<tr>
<td>104</td>
<td>21-MAY-91</td>
<td>07-JUL-95</td>
</tr>
<tr>
<td>100</td>
<td>17-AUG-94</td>
<td>16-JAN-97</td>
</tr>
<tr>
<td>158</td>
<td>01-AUG-96</td>
<td>17-JUN-98</td>
</tr>
<tr>
<td>174</td>
<td>11-MAY-86</td>
<td>23-JUL-89</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Employee Id</th>
<th>Start Date</th>
<th>End Date</th>
</tr>
</thead>
<tbody>
<tr>
<td>122</td>
<td>01-MAY-95</td>
<td>31-DEC-97</td>
</tr>
<tr>
<td>115</td>
<td>03-JUN-96</td>
<td>22-SEP-98</td>
</tr>
</tbody>
</table>

Concepts

- A \texttt{REF CURSOR} is a PL/SQL datatype that you can use in a query to fetch data. Each \texttt{REF CURSOR} query is associated with a PL/SQL function that returns a strongly typed \texttt{REF CURSOR}. The PL/SQL function must ensure that the \texttt{REF CURSOR} is opened and associated with a \texttt{SELECT} statement that has a \texttt{SELECT} list that matches the \texttt{REF CURSOR} type. You base a query on a \texttt{REF CURSOR} when you want to:
  - more easily administer SQL.
  - avoid the use of lexical parameters in your reports.
  - share data sources with other applications.
  - increase control and security.
  - encapsulate logic within a subprogram.
- If you use a stored program unit to implement \texttt{REF CURSORs}, you receive the added benefits that go along with storing program units in the Oracle database.
Reports Builder enables you to easily manage your queries by use of using REF CURSORS. For example, if you already have numerous queries built and you want to reuse those queries in your reports, you can simply use a REF CURSOR in your report data model to access those queries.

Figure 41–2 shows that you create a report with the SELECT statement in the REF CURSOR query of the report. It also shows that you can store the SELECT statement in a package in the database. Then, from the report, you can call the database package allowing you to reuse the package in many reports.

**Figure 41–2  Overview of the REF CURSOR example**

---

**Example Scenario**

In this example, you will learn how to use REF CURSORS in Reports Builder to create a detailed paper report showing information about employees and the job position they hold in each department. You will use the Data Model view to create a multiquery data model, and then use the Report Wizard to create the report layout. You will make fairly extensive manual refinements in the Data Model view.

As you build this example report, you will:

- **Define a REF CURSOR Type** by creating package specs that define REF CURSORS.
- **Create a REF CURSOR Query** that will use the REF CURSORS.
- **Refine the Data Model** by renaming objects so that they have more meaningful names.
- **Create Links Between REF CURSOR Queries** to create relationships between them.
- **Add Summary Columns** that better describe the data.
- **Create a Layout** using the Report Wizard.
- **Move the SELECT Statements Into Packages** that define the REF CURSOR types.
- **Move the Packages Into a Library** so that other reports can share the code.
To see a sample report with REF CURSORs, open the examples folder named refcursor, then open ref_emp68.rdf. For details on how to open it, see "Accessing the Example Reports" in the Preface. The example files used in this chapter are listed and described in Table 41–1.

### Table 41–1  Example report files

<table>
<thead>
<tr>
<th>File</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>refcursor/ref_emp*.rdf</td>
<td>The different stages of the RDF. You can refer to these files as you complete each section of this chapter. The file ref_emp68.rdf is the final report.</td>
</tr>
<tr>
<td>refcursor/refcursor_code.txt</td>
<td>The PL/SQL code you will write in this chapter. You can use this file as a reference point to make sure your code is accurate, or you can simply copy and paste from this file into Reports Builder.</td>
</tr>
</tbody>
</table>

#### 41.1 Prerequisites for This Example

To build the example in this chapter, you must have the example files provided, as well as access to the Human Resources sample schema (HR) provided with the Oracle Database. If you do not know if you have access to this sample schema, contact your database administrator.

**Note:** The use of REF CURSOR queries in Oracle Reports 12c (12.2.1.1) requires that your database version is 10.1.0.5 (for 10.1) or 10.2.0.2 (for 10.2) or higher.

Interoperability between a 12c (12.2.1.1) database or Oracle Forms Services client and a 10.1/10.2 database requires a minimum patchset level of 10.1.0.5 (for 10.1) or 10.2.0.2 (for 10.2).

An attempt to reference a 10.1 or 10.2 PL/SQL unit or view under the following circumstances will fail with a PLS-801[55916] error unless the 10.1 or 10.2 environment has been patched to the right level:

- A PL/SQL unit, anonymous block, trigger, call statement, or SQL statement on a 12c (12.2.1.1) database invokes a PL/SQL unit on a 10.1 or 10.2 database across a database link.
- A PL/SQL unit, anonymous block, trigger, or call statement on a 12c (12.2.1.1) database references a view on a 10.1 or 10.2 database across a database link and the view directly or indirectly references a PL/SQL function or an object type.
- An Oracle Forms Services 12c (12.2.1.1) client invokes a PL/SQL unit in a 10.1 or 10.2 database using RPC.

#### 41.2 Define a REF CURSOR Type

To create a REF CURSOR query, you first create a package spec that defines the REF CURSOR. Then you create a query that uses the REF CURSOR. The steps in this section will help you create package specs that define REF CURSORs.

**To define a REF CURSOR type:**

1. Launch Reports Builder (or, if already open, choose File > New > Report).
2. In the Welcome or New Report dialog box, select **Build a new report manually**, then click **OK**.

3. In the Object Navigator, click the **Program Units** node under the new report node (MODULEx).

4. Click the Create button in the toolbar to display the New Program Unit dialog box.

5. In the New Program Unit dialog box, type **concl_cv** in the **Name** field.

6. Select **Package Spec**, then click **OK** to display the PL/SQL Editor.

7. In the PL/SQL Editor, use the template to enter the following PL/SQL code:

   ```plsql
   PACKAGE concl_cv IS
     type conclass_rec is RECORD
       (EMPLOYEE_ID NUMBER(6),
        FIRST_NAME VARCHAR2(20),
        LAST_NAME VARCHAR2(25),
        EMAIL VARCHAR2(25),
        PHONE_NUMBER VARCHAR2(20),
        HIRE_DATE DATE,
        JOB_ID VARCHAR2(10),
        SALARY NUMBER(8,2),
        DEPARTMENT_ID NUMBER(4));
   type conclass_refcur is REF CURSOR return conclass_rec;
   END;
   This package spec does two things:
   ■ defines a record (conclass_rec) that describes the data you want to select from
     the database.
   ■ defines a REF CURSOR that returns the data in the format described by the
     record.
   ```

8. Click **Compile**.

9. If any compilation errors occur, check the code for syntax errors and recompile as
   needed.

10. Click **Close**.

11. Repeat steps 3 through 8 to create two more package specs:

    ■ **Package Spec Name: cont_cv**

     ```plsql
     PACKAGE cont_cv IS
       type container_rec is RECORD
         (EMPLOYEE_ID NUMBER(6),
          START_DATE DATE,
          END_DATE DATE,
          JOB_ID VARCHAR2(10),
          DEPARTMENT_ID NUMBER(4));
     type container_refcur is REF CURSOR return container_rec;
     END;
     ```

    ■ **Package Spec Name: port_cv**

     ```plsql
     PACKAGE port_cv IS
       type portdesc_rec is RECORD
         (DEPARTMENT_ID NUMBER(4),
          ```

---

**Note:** You can open the provided file refcursor_code.txt to copy and paste the code into the PL/SQL Editor.
DEPARTMENT_NAME VARCHAR2(30));
type portdesc_refcur is REF CURSOR return portdesc_rec;
END;

**Note:** You can open the provided file refcursor_code.txt to copy and paste the code into the PL/SQL Editor.

12. Choose File > Save As. Save the report in the directory of your choice, and name the report ref61_your_initials.rdf.

**Note:** It is good practice when you are designing your report to save it frequently under a different file name. If you generate an error or if you do not like some of the changes you made, you easily can go back to the previously saved file and make revisions from that point.

### 41.3 Create a REF CURSOR Query

After creating package specs that define the REF CURSORS, you are ready to define the queries, as described in this section.

**To create a REF CURSOR query:**

1. In the Object Navigator, double-click the view icon next to the Data Model node to display the Data Model view.
2. In the Data Model view, click the Ref Cursor Query tool in the tool palette.
3. Click in an open area of the Data Model view to display the PL/SQL Editor for the new REF CURSOR query.
4. In the PL/SQL Editor, use the template to enter the following PL/SQL code:

```plsql
function q_portdescRefCurDS return port_cv.portdesc_refcur is
temp_portdesc port_cv.portdesc_refcur;
begnin
open temp_portdesc for select department_id, department_name from departments;
return temp_portdesc;
end;
```

**Note:** You can open the provided file refcursor_code.txt to copy and paste the code into the PL/SQL Editor.

5. Click Compile.
6. If any compilation errors occur, check the code for syntax errors and recompile as needed.
7. Click Close.
8. In the Data Model view, double-click the new REF CURSOR query object (QR_1) to display the Property Inspector.
   - Under General Information, set the Name property to q_portdesc.
Tip: It is usually a good idea to give objects meaningful names, particularly when building a report with many objects. Later when building the layout, it is helpful to have queries and groups with meaningful names.

9. Repeat the steps above to create two more queries:

- **Query name: q_container**

  ```sql
  function q_containerRefCurDS return cont_cv.container_refcur is
  temp_container cont_cv.container_refcur;
  begin
    open temp_container for
    select employee_id,
    start_date,
    end_date,
    job_id,
    department_id
    from job_history;
    return temp_container;
  end;
  
  function q_conclassRefCurDS return concl_cv.conclass_refcur is
  temp_concl concl_cv.conclass_refcur;
  begin
    open temp_concl for
    select employee_id,
    first_name,
    last_name,
    email,
    phone_number,
    hire_date,
    job_id,
    salary,
    department_id
    from employees;
    return temp_concl;
  end;
  ```

- **Query name: q_conclass**

**Note:** You can open the provided file refcursor_code.txt to copy and paste the code into Reports Builder.

The Data Model should look similar to the following:
10. Save the report as `ref_62_your_initials.rdf`.

**Note:** You can open the provided file `ref_emp62.rdf` and display the Data Model to compare your results.

### 41.4 Refine the Data Model

In this section, you will rename some of the objects in the data model so that they have more meaningful names. You will also create a break group.

**To refine the data model:**

1. In the Data Model view, drag the title bar of the group `G_EMPLOYEE_ID` down about 4 inches (10 centimeters) to move the entire group.

2. Click and drag the column named `JOB_ID` out of and above `G_EMPLOYEE_ID` to create a new break group, as shown in the following figure:

**Figure 41–4  Query with group**

3. Double-click the title bar of the new group that contains `JOB_ID` to display the Property Inspector, and set the following properties:
Under the **General Information** node, set the Name property to G_conlabel.

4. In the Data Model view, your data model should look similar to the following:

**Figure 41–5  Data model with group**

![Data model with group](image)

**Note:** You can open the provided file `ref_emp63.rdf` and display the Data Model to compare your results.

5. Save the report as `ref_63_yourinitials.rdf`.

### 41.5 Create Links Between REF CURSOR Queries

Currently, the queries that you have created are unrelated. To create relationships between them, you need to create group-to-group data links. The steps in this section will help you create the links.

To create links between **REF CURSOR** queries:

1. In the Data Model view, click the Data Link tool in the tool palette.
2. Click the title bar of G_DEPARTMENT_ID, and drag a link to the title bar of G_EMPLOYEE_ID.
3. Double-click `q_container` to display the PL/SQL Editor.
4. In the PL/SQL Editor, append code to the **WHERE** clause of the **SELECT** statement to specify which columns are being used as primary and foreign keys:

   After from `job_history`, add the following code:

   ```plsql
   where :department_id = department_id;
   ```

   Be sure that the semicolon (;) now follows the **WHERE** clause.

   Notice that :department_id is a bind variable referring to the **DEPARTMENT_ID** in G_DEPARTMENT_ID.

5. Click **Compile**.
6. If any compilation errors occur, check the code for syntax errors and recompile as needed.
7. Click **Close**.
8. In the Data Model view, click the Data Link tool in the tool palette.
9. Click the title bar of G_EMPLOYEE_ID and drag a link to the title bar of G_EMPLOYEE_ID1.
10. Double-click **q_conclass** to display the PL/SQL Editor.

11. In the PL/SQL Editor, add a **WHERE** clause to the **SELECT** statement:

   Insert your cursor between **FROM EMPLOYEES** and the semicolon (**;**), and press **ENTER** or **RETURN** to create a new line, then add the following code:

   ```sql
   where :employee_id = employee_id;
   ```

   Be sure that the semicolon (**;**) now follows the **WHERE** clause.

   Notice that **:employee_id** is a bind variable referring to the **EMPLOYEE_ID** column in **G_EMPLOYEE_ID**.

12. Click **Compile**.

13. If any compilation errors occur, check the code for syntax errors and recompile as needed.

14. Click **Close**.

15. Your data model should look similar to the following:

   **Figure 41–6  Data model with links**

16. Save the report as **ref_64_your_initials.rdf**.

### 41.6 Add Summary Columns

Now that your queries are complete and linked, the steps in this section will help you to create columns to summarize the data.

**To add summary columns:**

1. In the Data Model view, click the Summary Column tool in the tool palette.

2. Click inside the **G_EMPLOYEE_ID** group to create a summary column.

3. Double-click the new summary column object (**CS_1**) to display the Property Inspector, and set the following properties:
   - Under **General Information**, set the Name property to **CS_classcount**.

   **Note:** You can open the provided file **ref_emp64.rdf** and display the Data Model to compare your results.
Under **Summary**, set the Function property to Count, set the Source property to `employee_id`, and set the Reset At property to `G_department_id`.

You have now created a summary that counts up the number of employees. You will not use the summary in this report’s layout, but you will use it as the source for other, more interesting summaries later.

4. Repeat the steps above to create summaries with the following characteristics:

<table>
<thead>
<tr>
<th>Create in Group</th>
<th>Name</th>
<th>Function</th>
<th>Source</th>
<th>Reset At</th>
</tr>
</thead>
<tbody>
<tr>
<td><code>G_conlabel</code></td>
<td><code>CS_conlabel_classcount</code></td>
<td>Sum</td>
<td><code>CS_classcount</code></td>
<td><code>G_conlabel</code></td>
</tr>
<tr>
<td><code>G_department_id</code></td>
<td><code>CS_port_count</code></td>
<td>Sum</td>
<td><code>CS_conlabel_classcount</code></td>
<td><code>G_DEPARTMENT_ID</code></td>
</tr>
</tbody>
</table>

You may not understand these summaries now. Their purpose will become clearer when you create the report layout and preview the live data.

Your data model should look similar to the following:

**Figure 41–7 Data model with summary columns**

---

**Note:** You can also compare your results to the file we have provided, called `ref_emp65.rdf`.

5. Save the report as `ref_65_your_initials.rdf`.

### 41.7 Create a Layout

Now that you have a working data model, the steps in this section will help you to create a layout.

**To create a paper layout:**

1. In the Object Navigator, right-click the report name and choose **Report Wizard**.
2. In the Report Wizard, on the **Report Type** page, select **Create Paper Layout Only**.

3. On the **Style** page, type **My Employees** in the **Title** field, select **Group Above**.

4. On the **Groups** page, click the following fields in the **Available Fields** list and click **Down** to specify the Print Direction and move them to the **Group Fields** list:
   - G_conlabel
   - G_DEPARTMENT_ID
   - G_EMPLOYEE_ID

5. On the **Fields** page, click the following fields and click the right arrow (>) to move them to the **Displayed Fields** list:
   - DEPARTMENT_NAME
   - EMPLOYEE_ID
   - START_DATE
   - END_DATE
   - JOB_ID
   - CS_port_count

6. On the **Labels** page, change the labels and field widths as follows:

<table>
<thead>
<tr>
<th>Fields</th>
<th>Labels</th>
<th>Width</th>
</tr>
</thead>
<tbody>
<tr>
<td>DEPARTMENT_NAME</td>
<td>Department</td>
<td>30</td>
</tr>
<tr>
<td>EMPLOYEE_ID</td>
<td>Employee ID</td>
<td>8</td>
</tr>
<tr>
<td>START_DATE</td>
<td>Start Date</td>
<td>9</td>
</tr>
<tr>
<td>END_DATE</td>
<td>End Date</td>
<td>9</td>
</tr>
<tr>
<td>JOB_ID</td>
<td>Job ID</td>
<td>10</td>
</tr>
<tr>
<td>CS_port_count</td>
<td>Total:</td>
<td>12</td>
</tr>
</tbody>
</table>

7. On the **Template** page, choose **Predefined template** and click **Beige**, then click **Finish** to display your report output in the Paper Design view. It should look something like this:
Move the SELECT Statements Into Packages

In your current report configuration, the SELECT statements used by the REF CURSOR queries reside within the report itself. In many cases, it is advantageous to have SELECT statements reside in the packages that define the REF CURSOR types. Then, you can simply reference the packages, rather than typing the same SELECT statement directly into every report that uses it. If you need to change the SELECT statement (for example, to modify or add clauses), you simply update it once in the package, rather than in every report that uses it.

The steps in this section will help you to move the SELECT statements to the packages that define the REF CURSOR types.

To move SELECT statements into a package:
1. In the Object Navigator, click the Program Units node for your report.
2. Click the Create button in the toolbar to display the New Program Unit dialog box.
3. In the New Program Unit dialog box, type cont_cv in the Name field.
4. Select Package Body, and click OK to display the PL/SQL Editor for the new program unit.
5. In the PL/SQL Editor, use the template to enter the following PL/SQL code:

```plsql
PACKAGE BODY cont_cv IS
    function query_container (p_department_id number) return container_refcur is
        tempcv_container cont_cv.container_refcur;
    begin
        open tempcv_container for
        select employee_id,
```

8. Save the report as ref_66_your_initials.rdf.

41.8 Move the SELECT Statements Into Packages

In your current report configuration, the SELECT statements used by the REF CURSOR queries reside within the report itself. In many cases, it is advantageous to have SELECT statements reside in the packages that define the REF CURSOR types. Then, you can simply reference the packages, rather than typing the same SELECT statement directly into every report that uses it. If you need to change the SELECT statement (for example, to modify or add clauses), you simply update it once in the package, rather than in every report that uses it.

The steps in this section will help you to move the SELECT statements to the packages that define the REF CURSOR types.

To move SELECT statements into a package:
1. In the Object Navigator, click the Program Units node for your report.
2. Click the Create button in the toolbar to display the New Program Unit dialog box.
3. In the New Program Unit dialog box, type cont_cv in the Name field.
4. Select Package Body, and click OK to display the PL/SQL Editor for the new program unit.
5. In the PL/SQL Editor, use the template to enter the following PL/SQL code:

```plsql
PACKAGE BODY cont_cv IS
    function query_container (p_department_id number) return container_refcur is
        tempcv_container cont_cv.container_refcur;
    begin
        open tempcv_container for
        select employee_id,
```
start_date,
end_date,
job_id,
department_id
from job_history
where :department_id=department_id;
return tempcv_container;
end;
END;

Note: You can open the provided file refcursor_code.txt to copy and paste the code into Reports Builder.

6. Click Compile.
7. If any compilation errors occur, check the code for syntax errors and recompile as needed.
8. Click Close.
9. Now that the function is defined, you must add it to the package spec so that it can be referenced. Other program units will know about the function in the package body only if it is described in the package spec.
10. In the Object Navigator, double-click the CONT.CV (Package Spec) object to display the PL/SQL Editor.
11. In the PL/SQL Editor, type the following line above the END; statement:

    function query_container (p_department_id number) return container_refcur;

12. Click Close.
13. Choose Program > Compile > All.
14. Click OK when done.
15. In the Object Navigator, under the Program Units node, double-click Q_ CONTAINERREFERCURDS to display the PL/SQL Editor.
16. In the PL/SQL Editor, edit the code to look as follows:

    function Q_containerRefCurDS return cont_cv.container_refcur is
        temp_container cont_cv.container_refcur;
    begin
        temp_container:=cont_cv.query_container (:department_id);
        return temp_container;
    end;

When you are done, all of the query’s logic will reside in the function named query_container. From now on, when you change query_container, you will change this and any other queries that reference it.

Note: You can open the provided file refcursor_code.txt to copy and paste the code into Reports Builder.

17. Click Compile.
18. If any compilation errors occur, check the code for syntax errors and recompile as needed.

19. Click Close.

20. Click the Paper Design button in the toolbar to view the report in the Paper Design view.

21. Save the report as ref_67_your_initials.rdf.

Optional Exercise:
Repeat the above steps for the other two queries in the report.

41.9 Move the Packages Into a Library

If you have many reports that use these same REF CURSOR types and SELECT statements, you can move the program units that you created into a PL/SQL library stored in a file, so that other reports can easily share the code. The steps in this section will help you to move the program units to a PL/SQL library.

To move the packages into a library:
1. In the Object Navigator, click the PL/SQL Libraries node, then click the Create button in the toolbar to add a new library.

2. Choose File > Save As.

3. Type DEPT_CONTAINER as the Library.

4. Ensure that File System is selected.

5. Click OK.

6. Drag and drop the following program units from your report to the Program Units node under the newly created DEPT_CONTAINER library:
   - CONCL_CV (Package Spec)
   - CONT_CV (Package Spec)
   - CONT_CV (Package Body)
   - PORT_CV (Package Spec)

7. Save DEPT_CONTAINER.

8. If the Paper Design view is open, close it.

9. In the Object Navigator, under the Program Units node for your report, delete CONCL_CV (Package Spec), CONT_CV (Package Spec), CONT_CV (Package Body), and PORT_CV (Package Spec).

   Note: If the Paper Design view is open when you delete the packages from the report, you may get some errors.

10. Click the Attached Libraries node for your report, then click the Create button in the toolbar to add a new attached library.

11. Click Browse to find the DEPT_CONTAINER library. It will have a .PLL file extension. After you have found and selected DEPT_CONTAINER, click Open.

12. Click Attach.
13. Choose Program > Compile > All.

14. Click OK to close the Compile window.

15. Click the Run Paper Layout button in the toolbar to run the report and view it in the Paper Design view.

16. Save the report as ref_68_your_initials.rdf.

41.10 Summary

Congratulations! You have finished the REF CURSOR query sample report. You now know how to:

- create package specs that define REF CURSORs.
- create REF CURSOR queries.
- create data links between REF CURSOR queries.
- create summaries to describe data.
- create a report layout.
- move SELECT statements into packages.
- move packages into a PL/SQL library.

For more information on any of the wizards, views, or properties used in this example, refer to the Oracle Reports online Help, which is available in Oracle Reports Builder or hosted on the Oracle Technology Network (OTN), as described in Section 4.1.1, "Using the Oracle Reports online Help".
Building a Simple Parameter Form for a JSP-based Web Report

In this chapter, you will learn about JSP-based Web reports that include a simple Parameter Form. To build a Parameter Form for a paper report, refer to the Oracle Reports online Help. By following the steps in this chapter, you can generate the report output shown in Figure 42–1 and Figure 42–2.

Figure 42–1  JSP Parameter Form

Parameter Form

Choose a department from the list, then click the Run Report button to show salary details for each employee in that department.

Department: Finance
Login ID: hr/hr@orcl

Note: The JSP Parameter Form in this image enables the user to choose from a list of departments, connect to a database, then run a report based on the selected parameters.
Figure 42–2  JSP-based Web report based on a user parameter

Employee Details

The information below shows your employees' salaries, and will prepare you for the Departmental Review meeting.

The following graph shows your direct reports by salary.

Employees by Salary

<table>
<thead>
<tr>
<th>Employees</th>
<th>Salary</th>
</tr>
</thead>
<tbody>
<tr>
<td>109</td>
<td></td>
</tr>
<tr>
<td>110</td>
<td></td>
</tr>
<tr>
<td>111</td>
<td></td>
</tr>
<tr>
<td>112</td>
<td></td>
</tr>
<tr>
<td>113</td>
<td></td>
</tr>
<tr>
<td>114</td>
<td></td>
</tr>
</tbody>
</table>

The following report provides salary details on your direct reports:

<table>
<thead>
<tr>
<th>Employee Id</th>
<th>Emp Name</th>
<th>Hire Date</th>
<th>Job Id</th>
<th>Salary</th>
<th>Department Id</th>
</tr>
</thead>
<tbody>
<tr>
<td>109</td>
<td>First, David</td>
<td>16-JUN-94</td>
<td>110 account 5000</td>
<td>100</td>
<td></td>
</tr>
</tbody>
</table>

**Note:** The JSP-based Web report in this image displays a graph and a tabular report based on the department selected in the JSP Parameter Form. To see how this report was built, refer to the *Oracle Reports Tutorial*.

**Concepts**

- In this example, you will build an HTML Parameter Form using JavaServer Pages (JSPs) for a JSP-based Web report. For conceptual information about JSPs and Parameter Forms for Web reports, refer to Section 2.2.1, "About JavaServer Pages (JSPs) and servlets" and Section 1.9.4, "About Parameter Forms for Web reports".

- This example shows you how to build a very simple Parameter Form. If this Parameter Form does not suit your needs, refer to a more advanced example on the Oracle Technology Network (OTN): on the Oracle Reports page (http://www.oracle.com/technetwork/middleware/reports/overview/index.html), navigate to Learn More and click Getting Started to display the Getting Started with Oracle Reports home page. In the list of topic sections on the left, click Index. In the Collateral Type list, choose Examples, and click Search. In the list of examples that displays, click Building a JSP-based Web Report with a Parameter Form.

**Example Scenario**

In this example, you have an existing JSP-based Web report that shows a bar graph of employee salaries per department, as well as a tabular report that shows the employee details. Your customers want to see the employee information for a specific
department at runtime, so that they do not have to read the data for all departments. The steps in this example show you how to add a JSP Parameter Form to this JSP-based Web report.

This example uses the resulting report from the Oracle Reports Tutorial. If you want to learn how to build the Web report that we use in this example, follow the steps in the tutorial.

As you build this example report, you will:

- Create a Parameter Form in HTML using a text or HTML editor.
- Modify the HTML Parameter Form in Reports Builder using the Data Model and Web Source views, and save as a JSP.
- Set up the Target Report using the Data Model view to modify the query for the target report to accept user parameters.
- Deploy the JSP Parameter Form and the Target Report.

To see a sample JSP-based Web report that includes a simple Parameter Form, open the examples folder named simplejsppf, then open results\emprev_param.jsp. For details on how to open it, see "Accessing the Example Reports" in the Preface. The example files used in this chapter are listed and described in Table 42–1.

<table>
<thead>
<tr>
<th>File</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>simplejsppf\source\paramform.html</td>
<td>An example HTML Parameter Form, which contains an example List of Values, a field, and a button.</td>
</tr>
<tr>
<td>simplejsppf\results\paramform.jsp</td>
<td>This JSP-based Web report contains the modifications to the Parameter Form you will make in Reports Builder.</td>
</tr>
<tr>
<td>simplejsppf\results\emprev_final.jsp</td>
<td>The source Web report that will become the target report for the Parameter Form.</td>
</tr>
<tr>
<td>simplejsppf\results\emprev_param.jsp</td>
<td>The final JSP-based Web report with a JSP Parameter Form.</td>
</tr>
</tbody>
</table>

Note: If you completed the exercises in the Oracle Reports Tutorial, you can also use the emprevb_your_initials.jsp file you created at the end of Chapter 6.

### 42.1 Prerequisites for This Example

To build the example in this chapter, you must have the example files we have provided (see “Example Scenario”, above), as well as access to the Human Resources sample schema (HR) provided with the Oracle Database. If you do not know if you have access to this sample schema, contact your database administrator.

### 42.2 Create a Parameter Form in HTML

The steps in this section will show you how to build a simple Parameter Form using plain HTML. You will then modify this HTML Parameter Form in Reports Builder so that you can call the Parameter Form from your JSP-based Web report.

If you do not want to create your own HTML file, you can open the sample HTML file we have provided in the Source directory, called paramform.html, then view the source code.
To create a simple Parameter Form in HTML:

1. In a text editor or HTML editor, create an HTML page that contains a form. The form should contain a list of values, a field, and a button. The code for this form can look something like the following:

```html
<form name="form1" method="post" action="">
  <h2>Parameter Form</h2>
  <p>Choose a department from the list, then click the <b>Run Report</b> button to show salary details for each employee in that department.</p>
  <select name="p_department" size="1">
    <option value="1">a</option>
  </select>
  <br>
  <input type="text" name="userid" value="hr/hr@db-connect">
  <br>
  <input type="submit" name="Submit" value="Run Report">
</form>
```

**Note:** Although you can use the above code, you will need to change the userid value to reflect the connection information for your data source. You can also copy and paste the HTML code from the provided file, called `simplejsppf_code.txt` in the `simplejsppf/scripts` directory, then modify it in a text or HTML editor.

2. Save the HTML file as `paramform_your_initials.html`. When you display this HTML file in a Web browser, it should look similar to the following image:

![Sample HTML Parameter Form](image)

**Figure 42–3 Sample HTML Parameter Form**

**Parameter Form**

Choose a department from the list, then click the **Run Report** button to show salary details for each employee in that department.

**Department:** a

**Login ID:** hr/hr@db-connect

**Run Report**

### 42.3 Modify the HTML Parameter Form in Reports Builder

In this section, you will learn how to modify an HTML Parameter Form in Reports Builder to populate the list of values (LOV) you created with values from a data source. You will use JSP tags for Oracle Reports to enable the Parameter Form to access elements from a data model.

#### 42.3.1 Create a data model manually for the Parameter Form

The steps in this section will show you how to create a simple data model for the Parameter Form.
To create a data model:
1. In Reports Builder, open the HTML file you created, paramform_your_initials.html.
2. In the Object Navigator, double-click the icon next to the Data Model node to display the Data Model view.
3. In the Data Model view that displays, click the SQL Query tool in the tool palette, then click in an open area of the Data Model view to display the SQL Query Statement dialog box.
4. In the SQL Query Statement field, enter the following SELECT statement:

   ```sql
   select department_name, department_id
   from departments
   order by department_name
   ```

   **Note:** You can enter this query in any of the following ways:
   - Copy and paste the code from the provided text file called simplejspff_code.txt into the SQL Query Statement field.
   - Click Query Builder to build the query without entering any code manually.
   - Type the code in the SQL Query Statement field.

5. Click Connect, then type the connection information for the Human Resources sample schema (HR).
6. Click OK. Your data model should look like this:

   ![Data Model view of the Parameter Form](image)

   **Figure 42–4  Data Model view of the Parameter Form**

7. Save the report as paramform_your_initials.jsp.

### 42.3.2 Create a dynamic LOV in the Parameter Form

In this section, you will learn how to modify the Web source to pull data into the existing list of values (LOV) in your Parameter Form. This data will rely on the data model you created in the previous section. We will also examine the code to explain how each element operates.

To modify the LOV in the Parameter Form in Reports Builder:
1. Click the Web Source button in the toolbar to display the Web Source view.
2. In the Web Source view, look for the following code:

   ```xml
   <select name="p_department" size="1">
     <option value="1">a</option>
   </select>
   ```

   Note: You can enter this query in any of the following ways:
   - Copy and paste the code from the provided text file called simplejspff_code.txt into the SQL Query Statement field.
   - Click Query Builder to build the query without entering any code manually.
   - Type the code in the SQL Query Statement field.
Since the LOV is currently static, we need to change this HTML element to dynamically retrieve data based on our data model.

3. In the Web Source view, modify the above code so that it looks like the following:

```html
<select name="p_department">
  <rw:foreach id="fn" src="G_department_name">
    <option value="<rw:field id="f_deptId" src="department_id'/>">"<rw:field id="deptname1" src="department_name'"/></option>
  </rw:foreach>
</select>
```

**Note:** You can either type the code manually or copy and paste it from the provided file called `simplejsppf_code.txt`.

4. Save your report.

**Examine the JSP elements in the code:**

By using JSP tags for Oracle Reports in the above code, we retrieve data into the Parameter Form's LOV by basing the parameters on fields in the data model. Let us examine each element:

- `<option>`: The display name of the LOV is replaced by the field `department_name` from the data model. When the user displays the Parameter Form, the department name will display in the list.
- `<rw:field>`: This element accesses each element of the `g_department_name` group.
- `<rw:foreach>`: This element iterates through the results based on the `g_department_name` group in the data model.
- `src`: This parameter is used in both `<rw:foreach>` and `<rw:field>` elements. For the `<rw:foreach>` element, `src` must match the group name of the data model (`G_department_name`). For the `<rw:field>` element, it must match the field that is referred (`department_name`).
- `id`: This parameter can be any value, but it must be unique. This parameter also applies to both `<rw:foreach>` and `<rw:field>` elements.

**Note:** For more information on these JSP elements and their parameters, refer to the Oracle Reports online Help.

By making these modifications to the code, we have replaced the return value attribute of the LOV with the field `department_id`, based on the data model we created in the previous section. If we now choose a department name from the list of values, its related department ID is returned. Notice that the return value is not displayed.
42.3.3 Run the Parameter Form report to the Web

Now that we have modified and examined our Web source, let us view the Parameter Form in a Web browser.

1. Click the Run Web Layout button in the toolbar.

   Note: If Netscape 7.0 is your default browser, and the browser does not display, set the registry key HKEY_CURRENT_USERS\Software\Oracle\Toolkit\Tkbrowser to the default browser location. Ensure that the BrowserName and the BrowserPath keys reflect the correct values. For example: BrowserName=Netscape 7;BrowserPath=C:\Program Files\Netscape\Netscape\Netscp.exe.

2. The Parameter Form displays in your Web browser, and should look like the following:

   ![Parameter form with values](image)

   **Parameter Form**

   Choose a department from the list, then click the Run Report button to show salary details for each employee in that department.

   **Department**: Accounting
   **Login ID**: hr/hr@db-connect
   **Run Report**

   Note: In the modified Parameter Form, notice how the list of values for the Department has changed from "a" to "Accounting."

3. Click the Department list and notice how the list is now populated with department names. Although you can click Run Report, nothing will happen because we have not yet defined an action for it.

42.4 Set up the Target Report

Now that you have set up the parameters, the next step is to set up the target report to accept the parameters. Then, we will define the action for your Parameter Form. When a user clicks Run Report, the target report will be run based on the Department and User ID parameters.

The target report we use in this section is the sample report for the Oracle Reports Tutorial. If you completed the exercises in the Oracle Reports Tutorial and created emprevb.jsp, you can use that report in this section. Otherwise, you can use the example file we have provided, called emprev_final.jsp. We will not show the steps to build this report in this section.
For more information on building the sample JSP-based Web report, refer to the *Oracle Reports Tutorial*.

**To set up the target report:**
1. In Reports Builder, open the file we have provided called `emprev_final.jsp`.
2. In the Object Navigator, double-click the icon next to the Data Model node.
3. In the Data Model view that displays, double-click the query (Q_1) to display the SQL Query Statement dialog box.
4. Find the final line of the code:
   
   ```
   WHERE (EMPLOYEES.MANAGER_ID = EMPLOYEES_A1.EMPLOYEE_ID)
   AND EMPLOYEES.DEPARTMENT_ID = 100
   ```
5. Change the second `WHERE` clause so that the last line looks like this:
   
   ```
   WHERE (EMPLOYEES.MANAGER_ID = EMPLOYEES_A1.EMPLOYEE_ID)
   AND EMPLOYEES.DEPARTMENT_ID = :P_DEPARTMENT
   ```

   **Tip:** The code we have changed is in bold text.
6. Click OK.
7. A note displays that indicates a bind parameter has been created. Click OK.
8. Save your report as `emprev_param_your_initials.jsp`.

### 42.5 Deploy the JSP Parameter Form and the Target Report

To deploy the JSP Parameter Form and the target JSP-based Web report, you must copy `paramform_your_initials.jsp` and `emprev_param_your_initials.jsp` to the deployment directory of your Application Server. Once you have placed the target report in the desired directory, you can then modify the Parameter Form to point to the report location.

For more information on deploying a JSP-based Web report, refer to the *Publishing Reports to the Web with Oracle Reports Services* manual.

**To set up and deploy the JSP Parameter Form and the target report:**
1. Copy the JSP Parameter Form and the Web report (paramform_your_initials.jsp and emprev_param_your_initials.jsp) into the following directory:
   
   ```
   $DOMAIN_HOME\servers\<managed_server_name>\tmp\_WL_user\reports_<version>\<dir_name>\war\paraform_your_initials.jsp
   ```

   **Note:** `dir_name` is a randomly generated directory name for each deployment instance.
2. In Reports Builder, open the file:
   
   ```
   $DOMAIN_HOME\servers\<managed_server_name>\tmp\_WL_user\reports_<version>\<dir_name>\war\paraform_your_initials.jsp
   ```
3. In the Web Source view, modify the action for the form so that when the user clicks Run Report, the `emprev_param_your_initials.jsp` report executes based on the selected parameters. The code should look like this:

```html
<form name="form1" method='post' action="/reports/rwservlet">
  <input type='hidden' name='report' value='reportname.rdf'>
  <input type='hidden' name='destype' value='destype'>
  <input type='hidden' name='desformat' value='desformat'>
  <input type='hidden' name='userid' value='db_connect_string'>
  <input type='submit' name='Submit' value='Submit'>
</form>
```

**Notes:**
- In the above code, the `action` attribute assumes that the report is located in the directory we specified in the above steps.
- The Parameter Form developed in this chapter can also be used to execute a paper report instead of a Web report. To do this, use the following code:

```html
<form name="form1" method="post" action="/reports/rwservlet?report=report_name.jsp&destype=destype&desformat=desformat">
</form>
```
- For more information on deploying JSP-based Web reports and paper reports, refer to the *Publishing Reports to the Web with Oracle Reports Services* manual.

4. Save your report.

5. Start your Oracle WebLogic Server instance.
   - On Windows, Go to the following directory
     `ORACLE_HOME\Middleware_HOME\user_projects\domains\<your_domain>`

     Double-click `startWebLogic.cmd`

     Where, "<your_domain>" is the domain created by you.
   - On UNIX, start the shell script:
     
     `ORACLE_HOME/Middleware_HOME/user_projects/domains/<your_domain>/startWebLogic.sh`

     Where, "<your_domain>" is the domain created by you.

     **Tip:** The Oracle WebLogic Server instance starts once the containers for Java EE have been initialized.

6. In a Web browser, type the URL for the Parameter Form:

   `http://computer name:port/reports/paramform_your_initials.jsp?userid=userid/password@database name`

   In our example, we would use:

   `http://mycomputer-pc:8888/reports/paramform_your_initials.jsp?userid=hr/hr@orcl`
7. If the Single Sign-On login page displays, enter your Single Sign-On user name and password. For more information about OracleAS Single Sign-On, see the "Publishing Reports to the Web with Oracle Reports Services" manual.

8. When the Parameter Form displays, choose a department from the list. For example, choose Finance.

9. In the Login ID field, type the connect string for the database schema that the emprev_param_your_initials.jsp report uses. For example, hr/hr@orcl:

10. Click Run Report.

11. The employee salary report displays with a graph at the top, and should look like this:
Summary

Congratulations! You have created a JSP Parameter Form for an existing Web report.
You now know how to:

■ create a simple Parameter Form in HTML.
■ add a data model to a simple Parameter Form in Reports Builder.
■ modify an existing JSP-based Web report to accept user parameters.
■ test and deploy a JSP-based Web report with a JSP Parameter Form using Oracle WebLogic Server.

For more information on any of the wizards, views, or properties used in this example, refer to the Oracle Reports online Help, which is available in Oracle Reports Builder or hosted on the Oracle Technology Network (OTN), as described in Section 4.1.1, "Using the Oracle Reports online Help".

Note: If you are not sure whether your report appears as it should, try using the files we have provided, paramform.jsp and emprev_param.jsp and follow all the steps in this section to deploy the Parameter Form and the Web report.

42.6 Summary

Figure 42–7  Sample employee report based on user parameters

Employee Details

The information below shows your employees’ salaries, and will prepare you for the Departmental Review meeting.

The following graph shows your direct reports by salary:

Employees by Salary

Note: If you are not sure whether your report appears as it should, try using the files we have provided, paramform.jsp and emprev_param.jsp and follow all the steps in this section to deploy the Parameter Form and the Web report.
In this chapter, you will learn about reports that include a barcode. By following the steps in this chapter, you can generate the report output shown in Figure 43–1.

**Figure 43–1 Barcode JavaBean Web report output**

<table>
<thead>
<tr>
<th>SHIPPING INFORMATION</th>
</tr>
</thead>
<tbody>
<tr>
<td>FROM</td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td>TO</td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td>Package Origin Scan</td>
</tr>
<tr>
<td>Package Destination Scan</td>
</tr>
<tr>
<td>Package Origin Scan</td>
</tr>
<tr>
<td>Package Destination Scan</td>
</tr>
</tbody>
</table>

**Concepts**

- By using a barcode JavaBean, you can build reports that display a barcode to make tasks like tracking shipping orders and employee identification numbers easier.

- You can create a paper or Web report that uses JavaBeans. For a paper report, you must use the Java Importer to create a PL/SQL wrapper so that you can call the JavaBean from your PL/SQL business logic. For a JSP-based Web report, you must call the JavaBean from your report. In Reports Builder, the JavaBean automatically generates the barcode for you.

**Note:** For information about the Java Importer, and the ORA_JAVA built-in package, see Oracle Reports online Help topics under Reference > Java Importer.

- You can learn more about the barcode JavaBean on the Oracle Technology Network (OTN): on the Oracle Reports page (http://www.oracle.com/technetwork/middleware/reports/overview/index.html), navigate to Learn More and click Getting Started to display the Getting
Started with Oracle Reports home page. In the list of topic sections on the left, click Any Format. In the expanded list of sub-topics, click PL/SQL-Java Bridge.

**Example Scenario**

In this example, you will build two reports, one for paper and one for the Web. The paper report shows an invoice for a single customer who has ordered multiple items from a company. The barcode indicates the tracking information for the order.

As you build these example reports, you will:

- **Create a Barcode Report for Paper:**
  - Import the Java classes into Reports Builder using the Java Importer to add the barcode JavaBean.
  - Create a package to store your information using the Program Unit editor.
  - Create a Before Report trigger to set up your barcode JavaBean for the report.
  - Create a query in the Data Model view to retrieve the data from the schema.
  - Create a formula column to retrieve the barcode image.
  - Create a formula column that returns the order total.
  - Create a layout for your report.

- **Create a Barcode Report for the Web:**
  - Create a query in an existing HTML file.
  - Create three formula columns in your data model to call the barcode data for the report.
  - Initialize the barcode JavaBean and set its properties by editing the JSP code in the Web Source view.
  - Run your report to the Web to view the output in a browser.

To see a sample paper report with a barcode, open the examples folder named barcodebeanpaper, then open result\shipping_manifest.pdf. To see a sample Web-based JSP report with a barcode, open the examples folder named barcodebeanweb, then open result\shipping_manifest_web.jsp. For details on how to open these reports, see "Accessing the Example Reports" in the Preface. The example files used in this chapter are listed and described in Table 43–1.

<table>
<thead>
<tr>
<th>File</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>barcodebeanpaper\result\shipping_manifest.pdf</td>
<td>The final PDF version of the paper report, containing the barcode.</td>
</tr>
<tr>
<td>barcodebeanpaper\result\shipping_manifest.rdf</td>
<td>The final RDF version of the paper report, containing the barcode.</td>
</tr>
<tr>
<td>barcodebeanpaper\scripts\oraclebarcode.jar</td>
<td>The barcode JavaBean.</td>
</tr>
<tr>
<td>barcodebeanpaper\scripts\barcode_code.txt</td>
<td>All the code used in this chapter, so you can copy and paste the code from this file instead of typing it manually.</td>
</tr>
<tr>
<td>barcodebeanpaper\source\shipping_manifest.rdf</td>
<td>The source file for the sample paper report. Running this RDF in Reports Builder will display the final result of your paper report in the Paper Design view.</td>
</tr>
</tbody>
</table>
Prerequisites for This Example

43.1 Prerequisites for This Example

To build the example in this chapter, you must have the example files we have provided (see "Example Scenario", above), as well as access to the Order Entry sample schema provided with the. If you do not know if you have access to this sample schema, contact your database administrator.

43.1.1 Update the REPORTS_CLASSPATH environment variable

Before you use a JavaBean (for a paper-based or JSP-based Web report), you need to perform several steps.

In this section, you will update the REPORTS_CLASSPATH environment variable with the location of the JavaBean. When you launch Reports Builder, it will use this new class path to recognize the location of the barcode bean.

Note: You must follow the steps in this section before you can even run the finished report we have provided, called ShippingManifestPaper.rdf and ShippingManifestWeb.rdf.

1. Find the REPORTS_CLASSPATH environment variable:
   - On Windows, open the registry from a command prompt by typing regedit and locate the REPORTS_CLASSPATH environment variable. You may want to make a backup of your registry before modifying it.
   - On UNIX, locate the REPORTS_CLASSPATH environment variable in $DOMAIN_HOME/reports/bin/reports.sh

<table>
<thead>
<tr>
<th>File</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>barcodebeanweb\result\shipping_manifest_web.jsp</td>
<td>The final JSP version of the Web report, containing the barcode.</td>
</tr>
<tr>
<td>barcodebeanweb\result\shipping_manifest_web.rdf</td>
<td>The final RDF version of the Web report, containing the barcode.</td>
</tr>
<tr>
<td>barcodebeanweb\result\assets</td>
<td>The images that Oracle Reports generated when the JSP was run.</td>
</tr>
<tr>
<td>barcodebeanweb\scripts\sql.txt</td>
<td>The SQL for the query you need to enter.</td>
</tr>
<tr>
<td>barcodebeanweb\scripts\barcode_code.txt</td>
<td>All the code used in this chapter, so you can copy and paste the code from this file instead of typing it manually.</td>
</tr>
<tr>
<td>barcodebeanweb\source\shipping_label.html</td>
<td>The HTML page that you will use as a basis for the Web report.</td>
</tr>
<tr>
<td>barcodebeanweb\source\shipping_manifest_web.rdf</td>
<td>The source file for the sample Web report. Running this RDF in Reports Builder to the Web will display the final result of your Web report in your browser.</td>
</tr>
<tr>
<td>barcodebeanweb\source\assets*</td>
<td>The images and other files that your JSP-based Web report will require to display properly on the Web.</td>
</tr>
<tr>
<td>barcodebeanweb\source\assets\blaf_beige_logo.gif</td>
<td>The image you will use in your JSP-based Web report.</td>
</tr>
</tbody>
</table>
2. Append the location of the oraclebarcode.jar file to the existing entries in REPORTS_CLASSPATH, for example:

- On Windows:
  Examples\BarcodeBeanPaper\scripts\oraclebarcode.jar

- On UNIX:
  Examples/barcodebeanpaper/scripts/oraclebarcode.jar

---

**Note:** The path depends on where the files are located. If you downloaded the files from the Oracle Technology Network (http://www.oracle.com/technetwork/middleware/reports/overview/index.html), you may have to further edit this path. Also, when you edit the Windows registry, make sure you separate your entries with a semicolon (;), with no spaces on either side of the semicolon.

---

You are now ready to begin building your report. To learn how to create a paper-based barcode report, refer to Section 43.2, "Create a Barcode Report for Paper". To learn how to create a JSP-based barcode report for the Web, refer to Section 43.3, "Create a Barcode Report for the Web".

### 43.2 Create a Barcode Report for Paper

In this section, you will import the barcode JavaBean, then create a paper-based report that shows the invoice for a particular customer. This invoice will display the address of the customer, his order, and a barcode that represents the tracking number for the order. The company can scan this barcode to find out the status of the order.

#### 43.2.1 Import the Java classes into Reports Builder

To create a paper report using the barcode JavaBean, you must first import two Java classes into Reports Builder. When you import these Java classes, Reports Builder automatically creates the packages you need to build the report.

---

**Note:** You do not need to perform this task if you are creating a Web report, as you will write JSP code that calls the JavaBean.

---

**To import the Java classes:**

1. Launch Reports Builder.

---

**Note:** You must launch Reports Builder now so that the new REPORTS_CLASSPATH is used.

---

2. Close the Welcome dialog box by clicking Cancel.

3. Choose Program > Import Java Classes to display the Import Java Classes dialog box.

4. Under Select Java Classes, navigate to:

   oracle.apps.barcode.util.BarCodeConstants
Create a Barcode Report for Paper

5. Select the class, then click Import.

6. Once the packages have been created, import the second JavaBean: oracle.apps.barcode.BarCodeMaker.

7. Click Close.

8. In the Object Navigator, under the report named MODULE 1, click the Program Units node. You will notice that Reports Builder created two package specifications and two package bodies named BARCODECONSTANTS and BARCODEMAKER.

43.2.2 Create a package to store your information

In this report, you want to create a package where the information will be stored.

To create a package for storing your information:

1. In the Object Navigator, under your new report, click the Program Units node.
2. Click the Create button in the toolbar to display the New Program Unit dialog box.
3. In the New Program Unit dialog box, type globals.
4. Select Package Spec, then click OK to display the PL/SQL Editor:
5. In the PL/SQL Editor, type the following code:

```plsql
PACKAGE globals IS
  bcobj ora_java.jobject;
  barcode_to_use varchar2(256);
  tempdir varchar2(100);
  directory_sep varchar2(2);
END;
```

6. Click Compile to make sure there are no errors in your code.

   **Note:** You can also enter this code by copying and pasting it from the provided text file called barcode_code.txt.

7. Once the code is compiled, click Close.

8. In the Object Navigator, click your report name (for example, MODULE 1).
9. Save the report as shippingmanifest_your_initials.rdf.

You have created a package that will contain the global information for your report.
### 43.2.3 Create a Before Report trigger

You can use a Before Report trigger to perform specific tasks before the report is run. Here, you will define the type of barcode you want to use in your report, as well as the temporary directory where your barcode images will be stored.

**To create a Before Report trigger:**

1. In the Object Navigator, under `SHIPPINGMANIFEST_your_initials`, expand the `Report Triggers` node, then double-click the icon next to `BEFORE REPORT` to display the PL/SQL Editor.

2. In the PL/SQL Editor, use the template to enter the following PL/SQL code:

   ```plsql
   function BeforeReport return boolean is
   begin
     globals.barcode_to_use := BarCodeConstants.BAR_CODE_128;
     globals.bcobj := barcodemaker.new();
     return (TRUE);
   end;
   
   To modify the type of barcode you want to use, you can change the value `BarCodeConstants.BAR_CODE_128` to any other valid value. To determine which values are valid, check the contents of the package by opening the `BarCodeConstants` package spec in the Object Navigator, under the `Program Units` node.

   **Note:** You can enter this code by copying and pasting it from the provided text file called `barcode_code.txt`.

3. Click **Compile** to make sure there are no errors.

   **Note:** If you have errors, make sure you have imported the necessary Java classes and compare your code closely with the code above. If you change the code, be sure to compile it again.

4. When the code is compiled, click **Close**. Notice how the node icon next to the `BEFORE REPORT` trigger has changed.

5. Save your report.

   You have created a trigger that will set up the barcode type for you when you run the report.

### 43.2.4 Create a query in the Data Model view

In this section, you will manually create the query that the report will use to retrieve data from the sample schema.

**To create the query:**

1. In the Object Navigator, under `SHIPPINGMANIFEST_your_initials`, double-click the view icon next to the `Data Model` node to display the Data Model view for your report.
2. In the Data Model view, click the SQL Query tool in the tool palette, then click in an open area of the Data Model view to display the SQL Query Statement dialog box.

3. In the SQL Query Statement field, enter the following SELECT statement:

```
SELECT ALL CUSTOMERS_A1.CUST_FIRST_NAME, 
       CUSTOMERS_A1.CUSTOMER_ID, CUSTOMERS_A1.CUST_LAST_NAME, 
       CUSTOMERS_A1.CUST_ADDRESS.STREET_ADDRESS, 
       CUSTOMERS_A1.CUST_ADDRESS.POSTAL_CODE, 
       CUSTOMERS_A1.CUST_ADDRESS.CITY, 
       CUSTOMERS_A1.CUST_ADDRESS.STATE_PROVINCE, 
       CUSTOMERS_A1.CUST_ADDRESS.COUNTRY_ID, ORDERS.ORDER_ID, 
       ORDERS.ORDER_DATE, 
       ORDERS.ORDER_TOTAL, ORDER_ITEMS.LINE_ITEM_ID, 
       PRODUCTS.PRODUCT_NAME, 
       ORDER_ITEMS.UNIT_PRICE, ORDER_ITEMS.QUANTITY, 
       COUNTRIES.COUNTRY_NAME 
FROM CUSTOMERS CUSTOMERS_A1, ORDER_ITEMS, ORDERS, 
     PRODUCTS, HR.COUNTRIES 
WHERE ((ORDER_ITEMS.ORDER_ID = ORDERS.ORDER_ID) 
     AND (ORDERS.CUSTOMER_ID = CUSTOMERS_A1.CUSTOMER_ID) 
     AND (ORDER_ITEMS.PRODUCT_ID = PRODUCTS.PRODUCT_ID) 
     AND (CUSTOMERS_A1.CUST_ADDRESS.COUNTRY_ID = 
          HR.COUNTRIES.COUNTRY_ID)) 
     AND ORDERS.ORDER_ID = :P_ORDER_ID 
ORDER BY order_ID, line_item_ID
```

---

**Note:** You can enter this query in any of the following ways:

- Copy and paste the code from the provided text file called barcode_code.txt into the SQL Query Statement field.
- Click **Query Builder** to build the query without entering any code manually.
- Type the code in the SQL Query Statement field.

4. Click **OK**.

If you are not connected to a database that contains the sample schema we have provided, you must log in now. If you are not sure what your connection string is, contact your database administrator. Notice that this example uses the Order Entry sample schema.

5. When a message displays indicating that the bind parameter `p_order_id` was created, click **OK**.

6. In the data model you just created, select all of the following columns using Shift-click, then drag them below the current query to create a detail group:

- **LINE_ITEM_ID**
- **PRODUCT_NAME**
- **UNIT_PRICE**
- **QUANTITY**

The resulting data model should look like this:
43.2.5 Create a formula column to retrieve the barcode image

In this section, you will create a formula column that will communicate with the JavaBean to create the barcode, then return the file name of the generated image.

To create a formula column:

1. In the Data Model view, click the Formula Column tool in the tool palette.
2. Click in the master group (**G_CUST_FIRST_NAME**) to create a new formula column.
3. Double-click the new formula column object (**CF_1**) to display the Property Inspector, and set the following properties:
   - Under **General Information**, set the Name property to **ImageFilename**.
   - Under **Column**:
     - Set the Datatype property to Character
     - Set the Width property to 500
     - Set the Read from File property to Yes
     - Set the File Format property to Image
   - Under **Placeholder/Formula**, click the PL/SQL Formula property field to display the PL/SQL Editor.
4. In the PL/SQL Editor, use the template to enter the following PL/SQL code:

   ```plsql
   function ImageFilenameFormula return VarChar2 is
   myFileName varchar2(500);
   result varchar2(500);
   barcodeData VarChar2(50) := :customer_ID || :order_ID;
   begin
   myFileName := srw.create_temporary_filename;
   barcodemaker.setBarWidthInch(globals.bcobj, 0.005);
   barcodemaker.setBaseCodeData(globals.bcobj,barcodeData);
   barcodemaker.setBarCodeType(globals.bcobj,globals.barcode_to_use);
   end;  
   ```
5. Click **Compile** to make sure there are no errors.

**Note:** If you have errors, make sure you have imported the necessary Java classes and compare your code closely with the code above. If you change the code, be sure to compile it again.

6. When the code is compiled, click **Close**.

### 43.2.6 Create a formula column that returns the order total

**To create the second formula column:**

1. In the Data Model view, create a formula column in the detail group `G_LINE_ITEM_ID`.

2. Open the Property Inspector for the formula column, and set the following properties:
   - Under **General Information**, set the Name property to `LineTotal`.
   - Under **Column**, make sure the Datatype property is set to Number.
   - Under **Placeholder/Formula**, click the PL/SQL Formula property field to display the PL/SQL Editor.

3. In the PL/SQL Editor, use the template to enter the following PL/SQL code:

   ```plsql
   function LineTotalFormula return Number is
   begin
       return (:quantity * :unit_price);
   end;
   ```

   **Note:** You can enter this code by copying and pasting it from the provided text file called `barcode_code.txt`.

4. Click **Compile** to make sure there are no errors.

5. When the code is compiled, click **Close**.

6. Save the report.

You have created the data model for your barcode report, which contains a formula column that retrieves the barcode information and displays the barcode image on your report, and another formula column that displays the order total.

Your data model and the PL/SQL for the formula column should look similar to this:
43.2.7 Create a layout for your report

Before you can run your report, you must create a layout.

To create a paper layout:
1. Under your report's node in the Object Navigator, right-click Paper Layout, then choose Report Wizard.
2. In the Report Wizard, on the Report Type page, select Create Paper Layout Only, then click Next.
3. On the Style page, select Group Above, then click Next.
4. On the Data Source page, click Next.
5. On the Data page, click Next.
6. On the Groups page, make sure the following fields are listed in the Group Fields list (if not, use the arrows to move the field to the appropriate list):
   - ORDER_ID
   - ORDER_DATE
   - CUSTOMER_ID
   - CUST_FIRST_NAME
   - CUST_LAST_NAME
   - STREET_ADDRESS
   - POSTAL_CODE
   - CITY
   - STATE_PROVINCE
   - COUNTRY_NAME
   - COUNTRY_ID

---

**Figure 43–3  Data Model with two new formula columns**

![Data Model with two new formula columns](image)
- ORDER_TOTAL
- CF_1

7. On the Fields page, click the double right arrows (>>) to move all of the fields to the Displayed Fields list, then click Finish.

8. In the Paper Layout view, click the Run Paper Layout button in the toolbar to run your report.

9. In the Runtime Parameter Form, next to P_ORDER_ID, type 2354.

10. Once your report displays in the Paper Design view, you can rearrange your layout objects in the Paper Layout view to make your report look something like Figure 43–4. To create this format:

   ■ In the Paper Layout view, remove the surrounding parent frame M_G_CUST_FIRST_NAME_GRPFR, then click the Confine Off button and the Flex Off button in the toolbar.

   ■ Using the shippingmanifest.rdf example report as a guide, add three rectangles and three text objects for:

       - **Shipping Details**: Set text properties to Arial, 16, bold. Create a frame to add the following fields: cust_first_name, cust_last_name, street_address, city, state_province, postal, country_name.

       - **Tracking Details**: Set text properties to Arial, 16, bold. Move the ImageFilename object onto this rectangle.

       - **Order Details**: Set text properties to Arial, 16, bold. Move the labels and fields for Order ID and Order Date onto this rectangle. Move the field F_Order_Total onto this rectangle and set text properties to Courier New, 24, bold.

   ■ Set the text properties for all other field values to Courier New, 10. Additionally, set F_Line_Total to bold.

   ■ Format numeric field values to display currency, decimals, and right align them.

   ■ Set Fill Color for each rectangle, totals field, and table header as desired.
43.3 Create a Barcode Report for the Web

The steps in this section show you how to build a JSP-based Web report, using the barcode JavaBean you imported in Section 43.2.1, "Import the Java classes into Reports Builder". If you want to build a paper report with a barcode, see Section 43.2, "Create a Barcode Report for Paper".

If you are not familiar with creating a JSP-based Web report and would like to learn how to create one, refer to the Oracle Reports Tutorial.

The report you will create in this section is the same as the one you created for paper. You will create a report that displays the invoice for a particular customer. This invoice will display the address of the customer, his order, and a barcode that represents the tracking number for the order. The company can use this barcode to find out the status of the order.

You can run the final version of the JSP report we have provided to see what you will build in these steps, but please notice that you will need to update the location of the images in the source code (see Section 43.3.3, "Initialize the barcode JavaBean and set its properties") before you can run the report to the Web.

Note: Before you begin this section, make sure you have all the necessary files, and that you have imported the Java classes, and set up the class path. See Section 43.1, "Prerequisites for This Example" and Section 43.2.1, "Import the Java classes into Reports Builder".

11. Save the report. You have now finished building a barcode report for paper.
43.3.1 Create a query in an existing HTML file

When you create a JSP-based Web report, you can use an existing HTML file as a template. The steps in this section will show you how to open an HTML file in Reports Builder and add data to it.

To create a query in an existing HTML file:

1. In Reports Builder, choose File > Open and open the file `Examples\barcodebeanweb\source\shipping_label.html`.

2. In the Object Navigator, under SHIPPINGLABEL, double-click the view icon next to the Data Model node to display the Data Model view for the report.

3. In the Data Model view, click the SQL Query tool in the tool palette, then click in an open area of the Data Model view to display the SQL Query Statement dialog box.

4. In the SQL Query Statement field, enter the following SELECT statement:

   ```sql
   SELECT ALL CUSTOMERS_A1.CUST_FIRST_NAME,
   CUSTOMERS_A1.CUSTOMER_ID, CUSTOMERS_A1.CUST_LAST_NAME,
   CUSTOMERS_A1.CUST_ADDRESS.STREET_ADDRESS,
   CUSTOMERS_A1.CUST_ADDRESS.POSTAL_CODE,
   CUSTOMERS_A1.CUST_ADDRESS.CITY,
   CUSTOMERS_A1.CUST_ADDRESS.STATE_PROVINCE,
   CUSTOMERS_A1.CUST_ADDRESS.COUNTRY_ID,
   ORDERS.ORDER_ID, ORDERS.ORDER_DATE, ORDERS.ORDER_TOTAL,
   COUNTRIES.COUNTRY_NAME FROM CUSTOMERS CUSTOMERS_A1, ORDERS,
   HR.COUNTRIES
   WHERE ((ORDERS.CUSTOMER_ID = CUSTOMERS_A1.CUSTOMER_ID)
   AND (CUSTOMERS_A1.CUST_ADDRESS.COUNTRY_ID = HR.COUNTRIES.COUNTRY_ID))
   AND ORDERS.ORDER_ID = :P_ORDER_ID ORDER BY order_ID
   ```

   **Note:** You can enter this query in any of the following ways:

   - Copy and paste the code from the provided text file called `barcode_code.txt` into the SQL Query Statement field.
   - Click Query Builder to build the query without entering any code manually.
   - Type the code in the SQL Query Statement field.

5. Click OK.

If you are not connected to a database that contains the sample schema we have provided, you must log in now. If you are not sure what your connection string is, contact your database administrator. Notice that this example uses the Order Entry sample schema.

6. When a message displays indicating that the bind parameter was created, click OK.

7. In the Data Model view, double-click the group object to display the Property Inspector, and set the following properties:

   - Under General Information, set the Name property to G_SHIPMENT.

Your data model should look something like this:
8. Save your report as ShippingLabel\_your\_initials.jsp to create the JSP-based Web source for this report.

You have now created the query that will pull in the data for your report.

### 43.3.2 Create three formula columns in your data model

You will need to create three formula columns in your report to retrieve the tracking number for the order, the origin of the order, and the destination for the order.

**To create the TrackingNumber formula column:**

1. In the Data Model view, click the Formula Column tool in the tool palette.
2. Click in the G\_SHIPMENT group to create a new formula column.
3. Double-click the new formula column object (CF\_1) to display the Property Inspector, and set the following properties:
   - Under General Information, set the Name property to TrackingNumber.
   - Under Column, set the Datatype property to Character.
   - Under Placeholder/Formula, click the PL/SQL Formula property field to display the PL/SQL Editor.
4. In the PL/SQL Editor, use the template to enter the following PL/SQL code:

   ```plsql
   function TrackingNumberFormula return char is
   begin
       return (:Customer_id||:Order_ID||:country_ID);
   end;
   ```

   **Note:** You can enter this code by copying and pasting it from the provided text file called barcode\_code.txt.

5. Click Compile.

   **Note:** If your code does not compile, make sure you have typed in exactly the code we have provided.

6. When the code is compiled, click Close.
To create the OriginScan formula column:
1. Create another formula column in the G_SHIPMENT group.
2. Double-click the new formula column object (CF_1) to display the Property Inspector, and set the following properties:
   - Under General Information, set the Name property to OriginScan.
   - Under Column, set the Datatype property to Character.
   - Under Placeholder/Formula, click the PL/SQL Formula property field to display the PL/SQL Editor.
3. In the PL/SQL Editor, use the template to enter the following PL/SQL code:
   ```plsql
   function OriginScanFormula return char is
   begin
     return('34324-OH-US');
   end;
   ``
4. Click Compile.
5. When the code is compiled, click Close.

To create the DestinationScan formula column:
1. Create a third formula column in the G_SHIPMENT group.
2. Double-click the new formula column object (CF_1) to display the Property Inspector, and set the following properties:
   - Under General Information, set the Name property to DestinationScan.
   - Under Column, set the Datatype property to Character.
   - Under Placeholder/Formula, click the PL/SQL Formula property field to display the PL/SQL Editor.
3. In the PL/SQL Editor, use the template to enter the following PL/SQL code:
   ```plsql
   function DestinationScanFormula return char is
   begin
     return(:postal_code||'-'||:state_province||'-'||:country_ID);
   end;
   ``
4. Click Compile.
5. When the code is compiled, click Close.

6. Save your report as a JSP.

You have created the three formula columns that will hold the values for the tracking number, the origin, and the destination of the order. Your data model should look something like this:

*Figure 43–6  Data Model with the three formula columns*

---

**Note:** If your code does not compile, make sure you have typed in exactly the code we have provided.

---

43.3.3 Initialize the barcode JavaBean and set its properties

To enable your JSP-based Web report to communicate with the JavaBean, you need to initialize it in the JSP. Unlike using the JavaBean with a paper report, you do not need to use the Java importer to import the Java classes.

In this section, you will also learn how to set the properties for the bean so that the correct data is being used to produce the barcode.

If you do not want to bother with typing the code in yourself, you can always open the source file (`Examples/barcodebeanweb/source/shipping_manifest_web.rdf`) and copy the appropriate pieces of the Web source into your report.

To ensure that the JavaBean references the correct barcode images, you must first update your report with the correct path.

**To update the paths:**

1. In the Object Navigator, double-click the view icon next to the Web Source node for your JSP-based Web report (`ShippingLabel_your_initials`) to display the Web Source view.

2. In the Web Source view, look for the text: Define Path information for your barcode images.

3. Under this text, update the paths to make sure they point to the directories where your images will be generated (for example, `d:\temp\docroot\images\`). Be sure to maintain the integrity of the paths we have provided.
To initialize the JavaBean:
1. In the Web Source view, look for the text:
   initialize the java beans.
2. Under this text, type the following code:
   ```jsp
   <jsp:useBean id="BC" scope="page" class="oracle.apps.barcode.util.BarCodeConstants" />
   <jsp:useBean id="BM" scope="page" class="oracle.apps.barcode.BarCodeMaker" />
   ```

To set the barcode JavaBean properties:
1. In the Web Source view, look for the text: setting the barcodes properties.
2. Under this text, type the following code:
   ```jsp
   <jsp:setProperty name="BM" property="BarCodeType" value="<%= BC.BAR_CODE_128 %>">
   <jsp:setProperty name="BM" property="BarWidthInch" value="0.01"/>
   <jsp:setProperty name="BM" property="Directory" value="<%= BarcodePhysicalPath %>">
   ```

To define the barcode variables:
1. In the Web Source view, look for the text: Define variables to hold the data for the three barcodes.
2. Under this text, type the following code:
   ```
   <%!
   private String BarCodeData1 = "12345-XX-XX";
   %>
   <%!
   private String BarCodeData2 = "12345-XX-XX";
   %>
   <%!
   private String BarCodeData3 = "12345-XX-XX";
   ```

To create a For Each loop:
1. In the Web Source view, look for the text: replace this with your RW:FOREACH open tag.
2. Replace this line with the following code:
   ```
   <rw:foreach id="R_G_SHIPMENT" src="G_SHIPMENT">
   ```
3. Look for the text: replace this with your RW:FOREACH close tag.
4. Replace this line with the following code:
   ```
   </rw:foreach>
   ```

To code the formula columns to render the barcodes:
1. In the Web Source view, look for the text: **BARCODEShippingTrackingNumber**.

---

**Note:** The directory where these files are located must be accessible by the Web server. This directory is typically located somewhere below the directory where you keep your JSPs. Make sure that this directory exists on your computer before you run the report to the Web.

**Note:** You can enter all the code in this section by copying and pasting it from the provided text file called **barcode_code.txt**.
2. Under this text, type the following code:

```html
<!-- Get the value of the TrackingNumber and assign it to the variable -->
<wb:getValue id="BarCodeData1" src="TrackingNumber"/>
<!-- Set the data for the barcode and the filename -->
<jsp:setProperty name="BM" property="BaseCodeData" value="<%= BarCodeData1 %>'/>
<jsp:setProperty name="BM" property="FileName" value="<%= BarCodeData1 %>'/>
<!-- Render the barcode -->
<br />BM.renderBarCode();
<!-- View the image in the page -->
<img src="assets/barcodes/<%= BarCodeData1 %>">
```

**Note:** The lines beginning with "<!--" are comments. If you do not want comments in your code, you do not have to add these lines.

3. In the Web Source view, look for the text: **BARCODEOriginScan**.

4. Under this text, type the following code:

```html
<!-- Get the value of the OriginScan and assign it to the variable -->
<wb:getValue id="BarCodeData2" src="OriginScan"/>
<!-- Set the data for the barcode and the filename -->
<jsp:setProperty name="BM" property="BaseCodeData" value="<%= BarCodeData2 %>'/>
<jsp:setProperty name="BM" property="FileName" value="<%= BarCodeData2 %>'/>
<!-- Render the barcode -->
<br />BM.renderBarCode();
<!-- View the image in the page -->
<img src="assets/barcodes/<%= BarCodeData2 %>">
```

5. In the Web Source view, look for the text: **BARCODEDestinationScan**.

6. Under this text, type the following code:

```html
<!-- Get the value of the DestinationScan and assign it to the variable -->
<wb:getValue id="BarCodeData3" src="DestinationScan"/>
<!-- Set the data for the barcode and the filename -->
<jsp:setProperty name="BM" property="BaseCodeData" value="<%= BarCodeData3 %>'/>
<jsp:setProperty name="BM" property="FileName" value="<%= BarCodeData3 %>'/>
<!-- Render the barcode -->
<br />BM.renderBarCode();
<!-- View the image in the page -->
<img src="assets/barcodes/<%= BarCodeData3 %>">
```

7. Save your report as a JSP.

### 43.3.4 Run your report to the Web

Since you have created a Web report, you must run this report to the Web to see your results.

1. In the Object Navigator, click your report name, `ShippingLabel_your_initials`.
2. Click the Run Web Layout button in the toolbar to run your report to a browser.
Summary

43.4 Summary

Congratulations! You have created a paper report and a JSP-based Web report that use the barcode JavaBean to generate barcode images.

You now know how to:

- use the Java importer to add Java classes to a paper report.
- use JavaServer Pages to call a JavaBean from within a report.
- create a PL/SQL package.
- use a Before Report trigger to tell Reports Builder what type of barcode image to use.
- manually build a data model with a SQL query and formula columns.
- edit the code in the Web Source view for a JSP-based Web report.
- set up a JavaBean in JSP.

For more information on any of the wizards, views, or properties used in this example, refer to the Oracle Reports online Help, which is available in Oracle Reports Builder or
 hosted on the Oracle Technology Network (OTN), as described in Section 4.1.1, "Using the Oracle Reports online Help".
Building an Accessible JSP-based Web Report

Using Oracle Reports and the standards defined in the Web Accessibility Guidelines, you can create a report that produces output that is compatible with assistive technologies such as screen readers. Oracle Reports provides properties and tags to support this effort.

On the Oracle accessibility site (http://www.oracle.com/accessibility), you can learn more about accessibility and find the Creating Accessible Enterprise Reports using Oracle Reports white paper.

To learn more about creating accessible Web reports, refer to the example on the Oracle Technology Network (OTN):

1. On the Oracle Reports 10g page (http://www.oracle.com/technetwork/middleware/reports/overview/index.html), navigate to Learn More and click Getting Started to display the Getting Started with Oracle Reports home page.

2. In the list of topic sections on the left, click Index.

3. In the Topic list, choose Building and Developing Reports.

4. In the Collateral Type list, choose Examples.

5. Click Search.

6. In the list of topics that displays, click Building an Accessible JSP-based Web Report.
This part introduces reports that use data sources other than the SQL data source accessing relational data in an Oracle database. These reports use data sources available with Oracle Reports or combine information from one or more of these data sources to publish meaningful information.

This part contains the following chapters:

- **Chapter 45, "Building a Report with an XML Pluggable Data Source"**
  A report with an XML pluggable data source enables you to connect to any data source that is available with Oracle Reports, for example XML data. Usage of alternate data sources is possible due to the pluggable data source (PDS) architecture of Oracle Reports Builder.

- **Chapter 46, "Building a Report with a Text Pluggable Data Source"**
  A report can contain a text pluggable data source, such as a report that uses character-delimited text as a data source.
Building a Report with an XML Pluggable Data Source

In this chapter, you will learn about reports that include data from an XML pluggable data source (PDS), which is provided with Oracle Reports. By following the steps in this chapter, you can generate the report output shown in Figure 45–1.

Figure 45–1  Report output using an XML PDS

<table>
<thead>
<tr>
<th>Warehouse ID</th>
<th>Warehouse Name</th>
<th>Product Name</th>
<th>City</th>
</tr>
</thead>
<tbody>
<tr>
<td>6</td>
<td>1733</td>
<td>PS 220V AUK</td>
<td>Sydney</td>
</tr>
<tr>
<td>6</td>
<td>1734</td>
<td>CD-ROM 600/16x</td>
<td>City</td>
</tr>
<tr>
<td>6</td>
<td>1737</td>
<td>Cable SC5I 103FW/AC5</td>
<td>Sydney</td>
</tr>
<tr>
<td>6</td>
<td>1738</td>
<td>PS 110V AUS</td>
<td>City</td>
</tr>
<tr>
<td>6</td>
<td>1739</td>
<td>SDRAM - 128 MB</td>
<td>Sydney</td>
</tr>
<tr>
<td>6</td>
<td>1740</td>
<td>TD 12GB/10AT</td>
<td>City</td>
</tr>
<tr>
<td>6</td>
<td>1741</td>
<td>CD-ROM 600/16x</td>
<td>City</td>
</tr>
<tr>
<td>6</td>
<td>1742</td>
<td>SDRAM - 128 MB</td>
<td>Sydney</td>
</tr>
<tr>
<td>6</td>
<td>1743</td>
<td>PS 220V AUK</td>
<td>City</td>
</tr>
<tr>
<td>6</td>
<td>1744</td>
<td>DIMM - 256MB</td>
<td>Sydney</td>
</tr>
<tr>
<td>6</td>
<td>1745</td>
<td>CD-ROM 600/16x</td>
<td>City</td>
</tr>
<tr>
<td>6</td>
<td>1746</td>
<td>DIMM - 256MB</td>
<td>Sydney</td>
</tr>
<tr>
<td>6</td>
<td>1747</td>
<td>DIMM - 256MB</td>
<td>City</td>
</tr>
<tr>
<td>6</td>
<td>1748</td>
<td>32MB Cache AUK</td>
<td>Sydney</td>
</tr>
</tbody>
</table>

Concepts

- The information you must publish is often derived from data in various corporate data sources. These data sources may be SQL-based (relational databases) or non-SQL-based, such as XML. Often, you must combine data from one or more of these data sources to publish meaningful information. For example, you may need to combine data that exists in a relational database with data from a multidimensional database to compare trends and performance.

- Oracle Reports enables you to leverage capabilities, such as aggregation, summarization, formatting, and scheduling, on data from any data source. You can leverage the pluggable data source (PDS) architecture to connect to your own data source, as well as to the data sources available with Oracle Reports (XML, JDBC, and Text).

- Valid XML files have a document type definition (DTD) or XML schema and strictly adhere to it. XML files can come from any source. However, Oracle provides you with a number of utilities and methods to convert different types of data to XML data files and their DTD or schema.
The elements in your XML data file (data source) must follow the same sequence and format of elements specified in the DTD or XML schema file. For example, suppose your DTD or XML schema defines two elements: WAREHOUSE_ID first, and PRODUCT_ID second. In this scenario, WAREHOUSE_ID must come before PRODUCT_ID in your XML data file, too. The names of the elements do not need to match. For example, given the following XML data file:

```xml
<WAREHOUSE>
  <INVENTORY>
    <WAREHOUSE_ID>3</WAREHOUSE_ID>
    <PRODUCT_ID>2340</PRODUCT_ID>
    <QUANTITY_ON_HAND>69</QUANTITY_ON_HAND>
    <PRODUCT_NAME>Chemicals - SW</PRODUCT_NAME>
  </INVENTORY>
  <INVENTORY>
    <WAREHOUSE_ID>3</WAREHOUSE_ID>
    <PRODUCT_ID>2365</PRODUCT_ID>
    <QUANTITY_ON_HAND>73</QUANTITY_ON_HAND>
    <PRODUCT_NAME>Chemicals - TCS</PRODUCT_NAME>
  </INVENTORY>
</WAREHOUSE>
```

A valid XML schema with suffix xsd for the above XML is as follows:

```xml
<xs:schema xmlns:xs="http://www.w3.org/2000/10/XMLSchema">
  <xs:element name="WAREHOUSE" >
    <xs:complexType>
      <xs:sequence>
        <xs:element name="INVENTORY" minOccurs="0" maxOccurs="unbounded" type=""/>
      </xs:sequence>
    </xs:complexType>
  </xs:element>
</xs:schema>
```

The XML PDS implementation supports only two-dimensional listing of records. Oracle Reports expects the XML data file to be in simple table format with rows and columns. Oracle Reports iterates through the XML sequence at one level below the topmost element in the XML. If there are sequences at lower levels (nested elements), they are not handled. Thus, to generate a tabular report, you must "flatten" your XML file into simple row-column format, as shown in the following examples.

Example 45–1 shows an XML data file that includes G_DEPTNO elements with nested G_EMPNO elements. Oracle Reports parses all the departments, but not all the employees within each department. For each department, only one employee record would be shown.

Example 45–2 shows how you can modify this XML data file to "flatten" the data. In the example, you will see that the G_DEPTNO elements include the G_EMPNO data,
without nesting. Now, Oracle Reports parses all the departments, including all the employees within each department.

Example 45–3 and Example 45–4 show the corresponding XML schema files for "nested" and "flattened" XML data, respectively.

**Example 45–1 “Nested” XML Data File**

```xml
<?xml version="1.0" encoding="WINDOWS-1252"?>
<EMP>
  <G_DEPTNO>10</G_DEPTNO>
    <G_EMPNO>7782</G_EMPNO>
      <ENAME>CLARK</ENAME>
      <JOB>MANAGER</JOB>
      <MGR>7839</MGR>
      <HIREDATE>09-JUN-81</HIREDATE>
      <SAL>2450</SAL>
      <COMM></COMM>
    </G_EMPNO>
    <G_EMPNO>7839</G_EMPNO>
      <ENAME>MICKEY</ENAME>
      <JOB>BOSS</JOB>
      <MGR></MGR>
      <HIREDATE></HIREDATE>
      <SAL></SAL>
      <COMM></COMM>
  </G_EMPNO>
  <G_DEPTNO>20</G_DEPTNO>
    <G_EMPNO>7369</G_EMPNO>
      <ENAME>SMITH</ENAME>
      <JOB>CLERK</JOB>
      <MGR>7902</MGR>
      <HIREDATE>17-DEC-80</HIREDATE>
      <SAL>800</SAL>
      <COMM></COMM>
    </G_EMPNO>
    <G_EMPNO>7876</G_EMPNO>
      <ENAME>ADAMS</ENAME>
      <JOB>CLERK</JOB>
      <MGR>7788</MGR>
      <HIREDATE>12-JAN-83</HIREDATE>
      <SAL>1100</SAL>
      <COMM></COMM>
  </G_EMPNO>
</EMP>
```

**Example 45–2 “Flattened” XML Data File**

```xml
<?xml version="1.0" encoding="WINDOWS-1252"?>
<EMP>
  <DEPTNO>10</DEPTNO>
    <EMPNO>7782</EMPNO>
      <ENAME>CLARK</ENAME>
      <JOB>MANAGER</JOB>
      <MGR>7839</MGR>
      <HIREDATE>09-JUN-81</HIREDATE>
      <SAL>2450</SAL>
      <COMM></COMM>
    <EMPNO>7839</EMPNO>
      <ENAME>MICKEY</ENAME>
      <JOB>BOSS</JOB>
      <MGR></MGR>
      <HIREDATE></HIREDATE>
      <SAL></SAL>
      <COMM></COMM>
  <DEPTNO>20</DEPTNO>
    <EMPNO>7369</EMPNO>
      <ENAME>SMITH</ENAME>
      <JOB>CLERK</JOB>
      <MGR>7902</MGR>
      <HIREDATE>17-DEC-80</HIREDATE>
      <SAL>800</SAL>
      <COMM></COMM>
    <EMPNO>7876</EMPNO>
      <ENAME>ADAMS</ENAME>
      <JOB>CLERK</JOB>
      <MGR>7788</MGR>
      <HIREDATE>12-JAN-83</HIREDATE>
      <SAL>1100</SAL>
      <COMM></COMM>
</EMP>
```
Example 45–3  Corresponding "Nested" XML Schema File

```xml
<?xml version="1.0"?>
<xsd:schema xmlns:xsd="http://www.w3.org/2000/10/XMLSchema">
  <xsd:element name="EMP">
    <xsd:complexType>
      <xsd:sequence>
        <xsd:element name="G_DEPTNO" minOccurs="0" maxOccurs="unbounded">
          <xsd:complexType>
            <xsd:sequence>
              <xsd:element name="DEPTNO" type="xsd:string"/>
            </xsd:sequence>
          </xsd:complexType>
        </xsd:element>
        <xsd:element name="G_EMPNO" minOccurs="0" maxOccurs="unbounded">
          <xsd:complexType>
            <xsd:sequence>
              <xsd:element name="EMPNO" type="xsd:string"/>
              <xsd:element name="ENAME" type="xsd:string"/>
              <xsd:element name="JOB" type="xsd:string"/>
              <xsd:element name="MGR" type="xsd:string"/>
              <xsd:element name="HIREDATE" type="xsd:string"/>
              <xsd:element name="SAL" type="xsd:string"/>
            </xsd:sequence>
          </xsd:complexType>
        </xsd:element>
      </xsd:sequence>
    </xsd:complexType>
  </xsd:element>
</xsd:schema>
```
Example 45–4  Corresponding "Flattened" XML Schema File

<?xml version="1.0"?>
<xsd:schema xmlns:xsd="http://www.w3.org/2000/10/XMLSchema">
  <xsd:element name="EMP">
    <xsd:complexType>
      <xsd:sequence>
        <xsd:element name="G_DEPTNO" minOccurs="0" maxOccurs="unbounded">
          <xsd:complexType>
            <xsd:sequence>
              <xsd:element name="DEPTNO" type="xsd:string"/>
              <xsd:element name="EMPNO" type="xsd:string"/>
              <xsd:element name="ENAME" type="xsd:string"/>
              <xsd:element name="JOB" type="xsd:string"/>
              <xsd:element name="MGR" type="xsd:string"/>
              <xsd:element name="HIREDATE" type="xsd:string"/>
              <xsd:element name="SAL" type="xsd:string"/>
              <xsd:element name="COMM" type="xsd:string"/>
            </xsd:sequence>
          </xsd:complexType>
        </xsd:element>
      </xsd:sequence>
    </xsd:complexType>
  </xsd:element>
</xsd:schema>

For more information on pluggable data sources, refer to the Oracle Reports online Help. If your data source cannot use an existing PDS, the PDS API enables you to write your own PDS and incorporate it into Oracle Reports to access your own unique data sources. The API is documented in Oracle Reports Java API Reference on Oracle Technology Network.

Example Scenario
In this example, you have an international business with warehouses in the United States and overseas. These warehouses are running a decentralized management system that stores the operational data locally at each site. The inventory of the warehouses are managed by the local managers. However, for planning purposes, a team at corporate headquarters needs to access the inventory data (in SQL), including the most recent data, of every warehouse. The warehouse data is only available as an XML stream. You will learn how to combine data from a local database (that is, the warehouse data) and data from an XML feed to create a Web report. You will use static XML files that are provided.

As you build this example report, you will:

- Create a Report Manually with SQL and XML Queries:
  - Create a SQL query for your new report.
Prerequisites for This Example

- Create an XML query to access your XML data source using the Data Wizard.
- Create a data link between two queries, a SQL query and an XML query.
- Create a layout for your report using the Report Wizard.
- Apply alternating row colors to your report using format triggers and procedures.
- Filter your XML data using a group filter to sort your XML data.

Run Your Report to Paper.

To see a sample report that uses an XML PDS, open the examples folder named xml_pds, then open inventory_report.rdf. For details on how to open it, see "Accessing the Example Reports" in the Preface. The example files used in this chapter are listed and described in Table 45–1.

<table>
<thead>
<tr>
<th>File</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>xml_pds\inventory_report.pdf</td>
<td>The final PDF version of the paper report.</td>
</tr>
<tr>
<td>xml_pds\inventory_report.rdf</td>
<td>The final RDF version of the paper report.</td>
</tr>
<tr>
<td>xml_pds\xmlpds_sql.txt</td>
<td>The various SQL statements you will use in this report.</td>
</tr>
<tr>
<td>xml_pds\warehouse_inventory.xml</td>
<td>The XML data source for the query in your report.</td>
</tr>
<tr>
<td>xml_pds\warehouse_inventory.xsd</td>
<td>The XML data stream for your report.</td>
</tr>
</tbody>
</table>

45.1 Prerequisites for This Example

To build the example in this chapter, you must have the example files we have provided (see "Example Scenario", above), as well as access to the Order Entry sample schema provided with the Oracle Database. If you do not know if you have access to this sample schema, contact your database administrator.

45.2 Create a Report Manually with SQL and XML Queries

When you create a report, you can either use the Report Wizard to assist you or create the report yourself. To build this report, you will need to create two queries: a SQL query and an XML query.

45.2.1 Create a SQL query for your new report

To create a SQL query:
1. Launch Reports Builder (or, if already open, choose File > New > Report).
2. In the Welcome or New Report dialog box, select Build a new report manually, then click OK.
   
   Your new report displays in the Object Navigator as something like MODULE 2. You will also see the Data Model view of your new report.
3. In the Data Model view, click the SQL Query tool in the tool palette, then click in an open area of the Data Model view to display the SQL Query Statement dialog box.
4. In the SQL Query Statement field, enter the following SELECT statement:
SELECT W.WAREHOUSE_ID,
    W.WAREHOUSE_NAME,
    L.CITY,
    L.STATE_PROVINCE,
    C.COUNTRY_NAME
FROM WAREHOUSES W,
    HR.LOCATIONS L,
    HR.COUNTRIES C
WHERE (W.LOCATION_ID = L.LOCATION_ID(+))
  AND (L.COUNTRY_ID = C.COUNTRY_ID(+))
ORDER BY C.COUNTRY_NAME, W.WAREHOUSE_NAME

Note: You can enter this query in any of the following ways:

- Copy and paste the code from the provided text file called
  xmlpds_sql.txt into the SQL Query Statement field.
- Click Query Builder to build the query without entering any
  code manually.
- Type the code in the SQL Query Statement field.

5. Click OK.

Note: If the Connect dialog box displays, enter the user ID,
password, and name of the database that contains the sample
schema.

The data model displays in the Data Model view, and should look something like
this:

Figure 45–2  Data Model for the XML PDS example SQL query

6. Save your report as inventoryreport_xml_your_initials.rdf.
You have created a SQL query to retrieve the data for your report.

45.2.2 Create an XML query to access your XML data source

In this section, you will create a query to access the XML data source. You can view the
resulting report we have provided to make sure your query is correct. Please notice
that you must update the paths to the Data Definition files with the location of the
example files we provided.

To create an XML query:

1. In the Data Model view, choose Insert > Query to display the Data Wizard.
2. If the Data Wizard Welcome page displays, click Next.
3. On the Query page, click Next.
4. On the Data Source page, click XML Query, then click Next.
5. On the Data page, click Query Definition to display the Define XML Query dialog box.
6. In the Define XML Query dialog box, under Data Definition, click Browse to locate the XSD file we have provided, warehouse_inventory.xsd and open it.
7. Under Data Source, click Browse to locate the XML file we have provided that contains your data, warehouse_inventory.xml and open it.
   If you want to compare your data definition to the one we provided, make sure that you replace the data definition locations with the locations of your files.
8. Click OK.
10. On the Groups page, click Next.
11. Click Finish to display your data model in the Data Model view. It should look something like this:

   ![Data model for the XML PDS example with XML and SQL queries](image)

12. Save your report.
   You have created an XML query to access the XML data source we have provided.

45.2.3 Create a data link between two queries

You will now need to link the SQL query and the XML query so that you can access your corporate data as well as the data for each of the local warehouses.

To create a data link:

1. In the Data Model view, click the Data Link tool in the tool palette.
2. Click the WAREHOUSE_ID column in your first query (Q_1).
3. Drag your cursor until it is over the WAREHOUSE_ID1 column in the second query (Q_2).
   Your data model should now look something like this:
You will notice that the WAREHOUSE_ID column is now highlighted at the bottom of Q_1, with a line pointing to the WAREHOUSE_ID1 column.

4. Save your report.

You have created a data link between the WAREHOUSE_ID columns in the two queries.

45.2.4 Create a layout for your report using the Report Wizard

Before you can run any report, you must define a layout. The easiest way to do this is to use the Report Wizard.

To create a paper layout:

1. In the Data Model view, right-click on the canvas, then choose Report Wizard.
2. In the Report Wizard, on the Report Type page, select Create Paper Layout only, then click Next.
3. On the Style page, select Group Above.
4. On the Groups page, make sure the G_WAREHOUSE_ID and G_WAREHOUSE_ID1 groups are listed in the Group Fields list with a Down Print Direction.
5. On the Fields page, click the double right arrows (>>) to move all of the fields to the Displayed Fields list.
6. On the Labels page, adjust the labels as desired.
7. On the Template page, select Predefined Template and click Beige, then click Finish to display your report output in the Paper Design view. It should look something like this:

---

**Figure 45–4  Data Model with a data link between a SQL query and an XML query**

You will notice that the WAREHOUSE_ID column is now highlighted at the bottom of Q_1, with a line pointing to the WAREHOUSE_ID1 column.

4. Save your report.

You have created a data link between the WAREHOUSE_ID columns in the two queries.

45.2.4 Create a layout for your report using the Report Wizard

Before you can run any report, you must define a layout. The easiest way to do this is to use the Report Wizard.

To create a paper layout:

1. In the Data Model view, right-click on the canvas, then choose Report Wizard.
2. In the Report Wizard, on the Report Type page, select Create Paper Layout only, then click Next.
3. On the Style page, select Group Above.
4. On the Groups page, make sure the G_WAREHOUSE_ID and G_WAREHOUSE_ID1 groups are listed in the Group Fields list with a Down Print Direction.
5. On the Fields page, click the double right arrows (>>) to move all of the fields to the Displayed Fields list.
6. On the Labels page, adjust the labels as desired.
7. On the Template page, select Predefined Template and click Beige, then click Finish to display your report output in the Paper Design view. It should look something like this:
8. Save your report.

You have created the layout for your paper report.

---

**Note:** You can also run the provided report `inventory_report.rdf`. Before you can run the report, double-click the XML query in the Data Model view, and point the XML data source to the appropriate XSD and XML files.

---

### 45.2.5 Apply alternating row colors to your report

Now that you have created the report, you can make it more user-friendly by using a summary column to apply alternating row colors.

**To create a summary column to count the rows:**

1. In the Data Model view, click the Summary Column tool in the tool palette.

   If you are still in the Paper Design view, you can click the Data Model button in the toolbar to display the Data Model view.

2. Click in the XML query group (`G_WAREHOUSE_ID1`) to create a summary column.

3. Double-click the new summary column object (`CS_1`) to display the Property Inspector, and set the following properties:
   - Under **General Information**, set the Name property to LineNo.
   - Under **Column**, make sure the Column Type property is set to Summary, and that the Datatype property is set to Number.
   - Under **Summary**, set the Function property to Count, and set the Source property to `PRODUCT_NAME`.

**To create a procedure that changes the row colors:**

1. In the Object Navigator, click the **Program Units** node for your report.

2. Click the Create button in the toolbar to display the New Program Unit dialog box.

3. In the New Program Unit dialog box, type `linecolors` as in the **Name** field.
4. Select **Procedure**, and click **OK** to display the PL/SQL Editor for the new program unit.

5. In the PL/SQL Editor, enter the following PL/SQL code to change the text color of the alternating rows to blue:

```plsql
PROCEDURE LineColors IS
    BEGIN
        if (:LineNo mod 2=0) then
            srw.set_text_color('blue');
        else
            srw.set_text_color('black');
        end if;
    END;
```

**Note:** You can copy and paste this code from the procedure provided in the xmlpds_code.txt file. Just copy the text under Line Colors Procedure.

6. Click **Compile** to compile the procedure.

   If any errors display, make sure the code is correct, and that you created the summary column in the steps above.

7. Click **Close**.

**Note:** Optionally, you can also change the fill colors of the alternating rows by following the steps in the above section, and using the following PL/SQL code. In this example code, we have changed the fill color of alternating rows to red and blue:

```plsql
PROCEDURE LineColors IS
    BEGIN
        if (:LineNo mod 2=0) then
            srw.set_foreground_fill_color('blue');
            srw.set_fill_pattern('solid');
        else
            srw.set_foreground_fill_color('red');
            srw.set_fill_pattern('solid');
        end if;
    END;
```

**To create a format trigger for each field that calls the procedure:**

1. In the Object Navigator, under your report name, expand the **Paper Layout** node and navigate to **Main Section > Body > M_G_WAREHOUSE_ID_GRPFR > R_G_WAREHOUSE_ID > M_G_WAREHOUSE_ID1_GRPFR > R_G_WAREHOUSE_ID1**.

2. Under **R_G_WAREHOUSE_ID1**, double-click **F_PRODUCT_ID** to display the Property Inspector.

**Note:** If you cannot find a particular field, use the **Find** field at the top of the Object Navigator.
3. In the Property Inspector, under **Advanced Layout**, double-click the Format Trigger property field to display the PL/SQL Editor.

4. In the PL/SQL Editor, use the template to enter the following PL/SQL code:

```plsql
function F_PRODUCT_IDformatTrigger return Boolean is
begin
  LineColors;
  return (TRUE);
end;
```

**Note:** Make sure you do not touch the boldface text. Simply type in the code below this text to create the format trigger. You can copy and paste this code from the procedure provided in the `xmlpds_code.txt` file. Just copy the text under **Format Trigger Code**.

5. Add a format trigger for the following fields, using the same code as in the previous step. Be sure not to delete the first line of the code, where the format trigger name is defined:

- F_PRODUCT_NAME
- F_QUANTITY_ON_HAND
- F_WAREHOUSE_ID1

6. Save your report.

7. Click the Run Paper Layout button in the toolbar to run your report to paper. Your report should look something like this:

![XML PDS Report with Alternating Row Colors](Figure 45–6)

You have now applied alternating row colors to your report.

### 45.2.6 Filter your XML data using a group filter

If you have a lot of data in your XML file, you might want to consider sorting and filtering it. You can do so by creating a group filter and a hierarchy. The steps in this section will show you how to create a filter that will only show the inventory items for a user-defined quantity amount. The filter will be based on a parameter that the user can enter at runtime. You will then create a hierarchy in your data model to group the data in your report.
To create a user parameter and a group filter:

1. In the Object Navigator, under the User Parameters node, create a new user parameter called \texttt{P\_MAXQTY}, with a Datatype of Number, Width of 20, and Initial Value of 50 (see Section 4.11.2, "Creating a user parameter").

2. In the Data Model view, double-click the \texttt{G\_WAREHOUSE\_ID1} group in the XML query to display its Property Inspector.

3. In the Property Inspector, under \texttt{Group}:
   - set the Filter Type property to PL/SQL.
   - click the PL/SQL filter property field to display the PL/SQL Editor.

4. In the PL/SQL Editor, use the template to enter the following PL/SQL code:

   ```plsql
   function \texttt{G\_WAREHOUSE\_ID1}GroupFilter return boolean is
   begin
   if :quantity\_on\_hand < :P\_maxqty then
   return (TRUE);
   else
   return (false);
   end if;
   end;
   ```

   \textbf{Note:} You can also copy and paste this code from the provided file called \texttt{xmlpds\_code.txt}. Copy the code under the heading "Group Filter Code."

5. Click \texttt{Compile}, and fix any errors.

   \textbf{Note:} If you are not familiar with compiling PL/SQL, refer to a PL/SQL reference manual.

6. When the code compiles successfully, click \texttt{Close}.

7. Save your report.

8. Click the Run Paper Layout button in the toolbar to run your report to paper. Notice how a Parameter Form now displays where you can adjust the quantity of items displayed in your report.

   You can also run the provided report \texttt{inventoryreport.rdf} to view the results in Reports Builder.

9. Save your report.

To create a hierarchy for the XML query:

1. In the Data Model view, click the \texttt{PRODUCT\_ID} column in the XML query, then drag it between the query name and the \texttt{G\_WAREHOUSE\_ID1} group. Your data model should look like this:
2. Save your report. You have now created a group hierarchy that sorts the data in your report.

### 45.3 Run Your Report to Paper

#### To run your paper report:

1. In the Object Navigator, make sure your report (inventoryreport_xml_your_initials.rdf) is selected.

2. Click the Run Paper Layout button in the toolbar to run your report to paper. Notice how the Parameter Form now displays, with the initial value of 50.

3. Your report displays in the Paper Design view, and should look something like this:

---

**Note:** Notice in the above image that a green circle displays above G_WAREHOUSE_ID1. This circle indicates that a group filter has been created for the group.
45.4 Summary

Congratulations! You have successfully used an XML data source for a paper report. You now know how to:

- create a SQL query from scratch.
- use the Data Wizard to create an XML query.
- create a data link between a SQL query and an XML query.
- create a layout for your report using the Report Wizard.
- apply alternating row colors to your report using format triggers and procedures.
- filter your XML data using a group filter and hierarchy.

For more information on any of the wizards, views, or properties used in this example, refer to the Oracle Reports online Help, which is available in Oracle Reports Builder or hosted on the Oracle Technology Network (OTN), as described in Section 4.1.1, "Using the Oracle Reports online Help".
In this chapter, you will learn about reports that include data from a Text pluggable data source (PDS), which is provided with Oracle Reports. By following the steps in this chapter, you can generate the report output shown in Figure 46–1.

Figure 46–1  Report output using a Text PDS

<table>
<thead>
<tr>
<th>Subject</th>
<th>Value</th>
<th>Percentage</th>
</tr>
</thead>
<tbody>
<tr>
<td>Total population</td>
<td>33,877,648</td>
<td>100%</td>
</tr>
<tr>
<td>Hispanic or Latino (of any race)</td>
<td>10,988,656</td>
<td>32%</td>
</tr>
<tr>
<td>Mexican</td>
<td>8,456,529</td>
<td>25%</td>
</tr>
<tr>
<td>Puerto Rican</td>
<td>140,570</td>
<td>0%</td>
</tr>
<tr>
<td>Cuban</td>
<td>72,296</td>
<td>0%</td>
</tr>
<tr>
<td>Other Hispanic or Latino</td>
<td>2,297,774</td>
<td>7%</td>
</tr>
<tr>
<td>Not Hispanic or Latino</td>
<td>22,395,027</td>
<td>68%</td>
</tr>
<tr>
<td>White alone</td>
<td>15,815,730</td>
<td>47%</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Subject</th>
<th>Value</th>
<th>Percentage</th>
</tr>
</thead>
<tbody>
<tr>
<td>Total households</td>
<td>11,502,070</td>
<td>100%</td>
</tr>
<tr>
<td>Family households (families)</td>
<td>7,920,049</td>
<td>69%</td>
</tr>
<tr>
<td>With own children</td>
<td>4,117,005</td>
<td>36%</td>
</tr>
<tr>
<td>18 years</td>
<td>6,077,004</td>
<td>51%</td>
</tr>
<tr>
<td>Married-couple family</td>
<td>2,989,997</td>
<td>36%</td>
</tr>
<tr>
<td>Female householder, no husband present</td>
<td>1,448,510</td>
<td>13%</td>
</tr>
<tr>
<td>With own children</td>
<td>6,347,156</td>
<td>7%</td>
</tr>
</tbody>
</table>

Concepts

- The information you must publish is often derived from data in various corporate data sources. These data sources may be SQL-based (relational databases) or non-SQL-based, such as character-delimited text. Often, you must combine data from one or more of these data sources to publish meaningful information. For example, you may need to combine data that exists in a relational database with data from a multidimensional database to compare trends and performance.

- Oracle Reports enables you to leverage capabilities, such as aggregation, summarization, formatting, and scheduling, on data from any data source. You can leverage the pluggable data source (PDS) architecture to connect to your own...
Prerequisites for This Example

Data source, as well as to the data sources available with Oracle Reports (XML, JDBC, and Text).

- For more information on pluggable data sources, refer to the Oracle Reports online Help. If your data source cannot use an existing PDS, the PDS API enables you to write your own PDS and incorporate it into Oracle Reports to access your own unique data sources. The API is documented in Oracle Reports Java API Reference on Oracle Technology Network.

Example Scenario

In this example, you have downloaded the US Census Bureau data in CSV (comma-delimited values) format and want to generate a report. You will learn how to use character-delimited text as a data source to create a paper report.

As you build this example report, you will:

- Set Up the textpds.conf File to Configure Reports Builder to recognize your text file as a pluggable data source.
- Use the Report Wizard to Create a Report based on the text data source.

To see a sample report that uses a Text PDS, open the examples folder named text_pds, then open census_report.rdf. For details on how to open it, see "Accessing the Example Reports" in the Preface. The example files used in this chapter are listed and described in Table 46–1.

Table 46–1  Example report files

<table>
<thead>
<tr>
<th>File</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>text_pds\census_report.rdf</td>
<td>The finished RDF for your report.</td>
</tr>
<tr>
<td>text_pds\census_report.pdf</td>
<td>A PDF version of your finished report.</td>
</tr>
<tr>
<td>text_pds\census_csv.txt</td>
<td>The character-delimited data downloaded from the US Census Bureau website.</td>
</tr>
<tr>
<td>text_pds\config.txt</td>
<td>Code for the textpds.conf file.</td>
</tr>
</tbody>
</table>

46.1 Prerequisites for This Example

To build the example in this chapter, you must have the example files we have provided (see "Example Scenario", above).

46.2 Set Up the textpds.conf File

Before you can use a text file as a data source, you must set up the Text PDS configuration file (textpds.conf) with your text file's format information. With this data definition in the configuration file, Oracle Reports Builder can recognize your text file as a valid data source.

**Note:** You must edit your configuration file before you launch or restart Reports Builder for the changes to take effect.

To set up your textpds.conf:

1. In a text editor, such as Notepad, open the file textpds.conf, located in the $/DOMAIN_

46-2  Publishing Reports to the Web with Oracle Reports Services
Use the Report Wizard to Create a Report

HOME}/config/fmwconfig/components/ReportsToolsComponent/<reports_tools_name> directory.

---

**Note:** ORACLE_HOME is where Reports Builder is installed on your computer.

2. In another text editor window, open the provided file config.txt file.

3. Copy the text we have provided in config.txt and paste it into textpds.conf before the </textPDS> entry, so that the resulting textpds.conf file contains an entry like this:

**Figure 46–2 Snapshot of the textpds.conf entry**

```xml
<data definition for Text PDS example>
<fileFormat name="CensusCSV" comment="#" delimiter=":" type="variable">
  <columnInfo>
    <column name="Category" type="string" cellUpper="aquot;"/>
    <column name="Subject" type="string" cellUpper="aquot;"/>
    <column name="Value" type="number" cellUpper="aquot;"/>
    <column name="Percentage" type="number" cellUpper="aquot;"/>
  </columnInfo>
</fileFormat>
</textPDS>
```

---

**Note:** The fileFormat entry in textpds.conf enables Reports Builder to recognize your text file as a data source. When you choose Text PDS in the Report Wizard, the defined format (CensusCSV, in this example) displays as an option. In the fileFormat entry, you also define the properties of each column in the file.

4. Save the textpds.conf file.

You have set up your textpds.conf file for the character-delimited text data source.

### 46.3 Use the Report Wizard to Create a Report

When you create a report, you can either use the Report Wizard to assist you or create the report yourself. To build the simple report in this example, you can use the Report Wizard.

Before you use a Text pluggable data source, you might want to examine the text file first to see what it looks like. You can open the census_csv.txt file in a text editor, like Notepad or WordPad, to see the data we will be using in this example.

**To create a simple report:**

1. Now that you have updated the textpds.conf file, launch Reports Builder.

   **Tip:** If Reports Builder was already open when you modified the textpds.conf file, you must shut down Reports Builder and restart it for Reports Builder to recognize your text file as a valid data source.

2. In the Welcome dialog box, select Use the Report Wizard, then click OK.
3. If the Welcome page displays, click Next.

4. On the Report Type page, select Create Paper Layout only, then click Next.

5. On the Style page, type a title for your report and select Group Above, then click Next.

6. On the Data Source page, click Text Query, then click Next.

7. On the Data page, click Query Definition to display the Define Text Query dialog box.
   
   If you get an error message and cannot display the Define Text Query dialog box, check your configuration file (textpds.conf) to confirm the code you added.

8. Under Data Definition, click the CensusCSV format in the list.

   **Note:** The CensusCSV format displays in this list because you added it to the textpds.conf file.

9. Under Data Source, click Browse to find the provided file census_csv.txt.
   
   If you do not see the file listed in your directory, make sure you have selected TXT files in the Files of Type list in the Open dialog box.

10. Click the file, then click Open.

11. When the census_csv.txt file displays in the Location field, click OK.
   
   In the Report Wizard, the data source definition displays in the Data Source definition field.

12. Click Next.

13. On the Groups page click CATEGORY in the Available Fields list and click the right arrow (>) to move this field to the Group Fields list, then click Next.

14. On the Fields page, click the double right arrows (>>) to move all available fields to the Displayed Fields list, then click Next.

15. On the Totals page, click Next.


17. On the Template page, select Predefined Template and click Beige, then click Finish to display your report output in the Paper Design view. Make whatever modifications you want. The report should look like the following image:
Congratulations! You have successfully used a Text pluggable data source for a paper report. You now know how to:

- set up your `textpds.conf` file.

**Note:** You can compare your results against the report we have provided in the examples directory. Before you can run the report, however, follow these steps:

- In the Data Model view, right-click the query and choose **Data Wizard**.
- On the Data page, click **Query Definition**.
- Update the location of `census_csv.txt` to its location on your local drive.

**46.4 Summary**

Congratulations! You have successfully used a Text pluggable data source for a paper report. You now know how to:

- set up your `textpds.conf` file.
use the Report Wizard to create a paper report based on the text data source.

For more information on any of the wizards, views, or properties used in this example, refer to the Oracle Reports online Help, which is available in Oracle Reports Builder or hosted on the Oracle Technology Network (OTN), as described in Section 4.1.1, "Using the Oracle Reports online Help".
This appendix describes the buttons and tools in the Reports Builder main toolbar and tool palettes.

A.1 Main Toolbar

The main toolbar is located at the top of the Oracle Reports Builder window, directly beneath the menu bar, as shown in Figure A–1:

**Figure A–1  Main toolbar**

<table>
<thead>
<tr>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="icon" alt="New" /></td>
<td>New button. Displays the New Report dialog box.</td>
</tr>
<tr>
<td><img src="icon" alt="Open" /></td>
<td>Open button. Displays the Open dialog box.</td>
</tr>
<tr>
<td><img src="icon" alt="Save" /></td>
<td>Save button. Saves the report. If you have not saved the report before, the Save As dialog box displays.</td>
</tr>
<tr>
<td><img src="icon" alt="Print" /></td>
<td>Print button. Prints the paper report.</td>
</tr>
<tr>
<td><img src="icon" alt="Mail" /></td>
<td>Mail button. Displays the Mail dialog box.</td>
</tr>
<tr>
<td><img src="icon" alt="Connect" /></td>
<td>Connect button. Displays the Connect dialog box.</td>
</tr>
<tr>
<td><img src="icon" alt="Cut" /></td>
<td>Cut button. Deletes the currently selected item and temporarily places it in the clipboard. Use Paste to paste the selected item.</td>
</tr>
<tr>
<td><img src="icon" alt="Copy" /></td>
<td>Copy button. Temporarily places a copy of the selected item in the clipboard. Click the Paste button to paste the selected item.</td>
</tr>
<tr>
<td><img src="icon" alt="Paste" /></td>
<td>Paste button. Pastes the item in the clipboard in current location of the cursor.</td>
</tr>
<tr>
<td><img src="icon" alt="Undo" /></td>
<td>Undo button. Undoes the last action performed.</td>
</tr>
<tr>
<td><img src="icon" alt="Redo" /></td>
<td>Redo button. Performs the last action again.</td>
</tr>
<tr>
<td><img src="icon" alt="Run Web Layout" /></td>
<td>Run Web Layout button. Runs the current report to your Web browser.</td>
</tr>
</tbody>
</table>
The Data Model view tool palette is a vertical group of tools located on the left-hand side of the Data Model view, as shown in Figure A–2.

The name and purpose of each tool is as follows:

<table>
<thead>
<tr>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="icon.png" alt="Select" /></td>
<td>Select tool. Deselects any selected tool to “turn off” the current tool, and allow you to select any object in the Data Model view.</td>
</tr>
<tr>
<td><img src="icon.png" alt="Magnify" /></td>
<td>Magnify tool. Zooms in the view on the clicked object. Hold down the SHIFT key when you click the Magnify tool to zoom out.</td>
</tr>
<tr>
<td><img src="icon.png" alt="Summary Column" /></td>
<td>Summary Column tool. Creates a summary column in the query.</td>
</tr>
<tr>
<td><img src="icon.png" alt="Data Link" /></td>
<td>Data Link tool. Creates a master-detail relationship between queries when you drag a line to define the relationship between the key columns in the two queries.</td>
</tr>
<tr>
<td><img src="icon.png" alt="Formula Column" /></td>
<td>Formula Column tool. Creates a formula column in the query.</td>
</tr>
<tr>
<td><img src="icon.png" alt="Cross Product" /></td>
<td>Cross Product tool. Creates a matrix (cross-product) group.</td>
</tr>
<tr>
<td><img src="icon.png" alt="Placeholder Column" /></td>
<td>Placeholder Column tool. Creates a placeholder column which you can modify later.</td>
</tr>
<tr>
<td><img src="icon.png" alt="SQL Query" /></td>
<td>SQL Query tool. Displays the SQL Query Statement dialog box where you can enter a SQL query SELECT statement or use Query Builder to create a query.</td>
</tr>
<tr>
<td><img src="icon.png" alt="Ref Cursor Query" /></td>
<td>Ref Cursor Query tool. Displays the PL/SQL Editor where you can type a REF CURSOR query.</td>
</tr>
<tr>
<td><img src="icon.png" alt="XML Query" /></td>
<td>XML Query tool. Displays the Define XML Query dialog box, where you can specify the XML data definition and data source.</td>
</tr>
<tr>
<td><img src="icon.png" alt="JDBC Query" /></td>
<td>JDBC Query tool. Displays the JDBC Query dialog box, where you can define the SQL or stored procedure to define the data for the query.</td>
</tr>
<tr>
<td><img src="icon.png" alt="Text Query" /></td>
<td>Text Query tool. Displays the Text Query dialog box, where you can specify a text data definition and data source.</td>
</tr>
</tbody>
</table>
A.3 Paper Layout View Tool Palette

The Paper Layout view tool palette is a vertical group of tools located on the left-hand side of the Paper Layout view, as shown in Figure A–3.

Figure A–3 Paper Layout view tool palette

![Paper Layout view tool palette](image)

The name and purpose of each tool is as follows:

<table>
<thead>
<tr>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Select" /></td>
<td>Select tool. Deselects any selected tool to &quot;turn off&quot; the current tool, and allow you to select any object in the Paper Layout view.</td>
</tr>
<tr>
<td><img src="image" alt="Magnify" /></td>
<td>Magnify tool. Zooms in the view on the clicked object. Hold down the SHIFT key when you click the Magnify tool to zoom out.</td>
</tr>
<tr>
<td><img src="image" alt="Frame Select" /></td>
<td>Frame Select tool. Selects all objects within the selected frame or repeating frame, depending upon their explicit anchors (first click the tool, then the frame).</td>
</tr>
<tr>
<td><img src="image" alt="Reshape" /></td>
<td>Reshape tool. Enables you to reshape the selected objects.</td>
</tr>
<tr>
<td><img src="image" alt="Text" /></td>
<td>Text tool. Creates a boilerplate text object.</td>
</tr>
<tr>
<td><img src="image" alt="Rotate" /></td>
<td>Rotate tool. Enables you to rotate the direction of the selected boilerplate text and graphic objects.</td>
</tr>
<tr>
<td><img src="image" alt="Line" /></td>
<td>Line tool. Draws a line boilerplate object.</td>
</tr>
<tr>
<td><img src="image" alt="Rectangle" /></td>
<td>Rectangle tool. Draws a rectangle boilerplate object.</td>
</tr>
<tr>
<td><img src="image" alt="Arc" /></td>
<td>Arc tool. Draws an arc boilerplate image.</td>
</tr>
<tr>
<td><img src="image" alt="Rounded Rectangle" /></td>
<td>Rounded Rectangle tool. Draws a rounded rectangle boilerplate object.</td>
</tr>
<tr>
<td><img src="image" alt="Polyline" /></td>
<td>Polyline tool. Draws an open multilined boilerplate object. Use your mouse to create the multiple lines.</td>
</tr>
<tr>
<td><img src="image" alt="Polygon" /></td>
<td>Polygon tool. Draws a multisided boilerplate object. The object must be closed, unlike a polyline object.</td>
</tr>
<tr>
<td>Icon</td>
<td>Description</td>
</tr>
<tr>
<td>------</td>
<td>-------------</td>
</tr>
<tr>
<td><img src="image" alt="Freehand" /></td>
<td><strong>Freehand</strong> tool. Draws a line where you drag your mouse.</td>
</tr>
<tr>
<td><img src="image" alt="Ellipse" /></td>
<td><strong>Ellipse</strong> tool. Draws an ellipse boilerplate object.</td>
</tr>
<tr>
<td><img src="image" alt="Frame" /></td>
<td><strong>Frame</strong> tool. Draws a frame.</td>
</tr>
<tr>
<td><img src="image" alt="Repeating Frame" /></td>
<td><strong>Repeating Frame</strong> tool. Draws a repeating frame.</td>
</tr>
<tr>
<td><img src="image" alt="Graph" /></td>
<td><strong>Graph</strong> tool. Displays the Graph Wizard so that you can define a graph that will be inserted into your layout.</td>
</tr>
<tr>
<td><img src="image" alt="Field" /></td>
<td><strong>Field</strong> tool. Creates a field object.</td>
</tr>
<tr>
<td><img src="image" alt="Anchor" /></td>
<td><strong>Anchor</strong> tool. Creates an anchor between two objects in your layout.</td>
</tr>
<tr>
<td><img src="image" alt="File Link" /></td>
<td><strong>File Link</strong> tool. Creates a link file object that you can use to link an external file to your report.</td>
</tr>
<tr>
<td><img src="image" alt="Report Block" /></td>
<td><strong>Report Block</strong> tool. Displays the Report Block wizard so that you can add a new report block to your layout.</td>
</tr>
</tbody>
</table>