Oracle® Fusion Middleware
Oracle Reports Tutorial
12c (12.2.1.3.0)
E80073-01

August 2017
## Contents

### Preface
- Audience ...................................................................................................................... v
- Documentation Accessibility ...................................................................................... v
- Related Documentation ............................................................................................. v
- Conventions ................................................................................................................ v
- Prerequisites .............................................................................................................. vi

### 1 Tutorial Overview
- 1.1 Tutorial Scenario ................................................................................................. 1-1
- 1.2 Summary .............................................................................................................. 1-3

### 2 Adding Data to a Report
- 2.1 Opening the Web Page .......................................................................................... 2-1
- 2.2 Using the Data Wizard to Add Data to a Sample Web Page ................................. 2-2
- 2.3 Saving your Report as a JSP File .......................................................................... 2-5
- 2.4 Summary .............................................................................................................. 2-6

### 3 Reviewing the Source Code of the Web Report
- 3.1 Viewing the Web Source in Reports Builder ......................................................... 3-1
- 3.2 Verifying Your JSP Code ....................................................................................... 3-2
- 3.3 Summary .............................................................................................................. 3-2

### 4 Reviewing the Source Code for the Report Block
- 4.1 Viewing the Web Source in Reports Builder ......................................................... 4-1
- 4.1.1 Reviewing the Header Tag and Body ................................................................. 4-1
- 4.1.2 Reviewing the rw:foreach Tag and Body ......................................................... 4-1
- 4.2 Verifying Your JSP Code ....................................................................................... 4-2
- 4.3 Summary .............................................................................................................. 4-2
5 Creating a Report Block for the Web Report
   5.1 Adding a Report Block to Your Web Page ................................................................. 5-1
   5.2 Summary .................................................................................................................. 5-3

6 Creating a Graph for the Web Report
   6.1 Opening the Source for the Report in Reports Builder ........................................... 6-1
   6.2 Creating a Graph Using the Graph Wizard ............................................................... 6-2
   6.3 Saving Your Report with the New Graph ................................................................. 6-4
   6.4 Summary .................................................................................................................. 6-4

7 Reviewing the Source Code for the Graph
   7.1 Viewing the Source in Reports Builder ..................................................................... 7-1
   7.2 Reviewing the rw:graph Tag .................................................................................. 7-1
   7.3 Summary .................................................................................................................. 7-3

8 Generating a Paper Report
   8.1 Generate a Paper Report Based on Your Data Model ............................................. 8-1
   8.2 Modifying a Report in the Paper Design View ....................................................... 8-3
   8.3 Summary .................................................................................................................. 8-4

A Quick Reference Guide
   A.1 Entries for the Data Wizard ..................................................................................... A-1
   A.2 Entries for the Report Block .................................................................................... A-1
   A.3 Entries for the Graph Wizard .................................................................................. A-2
   A.5 Reference Material ................................................................................................. A-2

B Tool Palette and Toolbar Reference
   B.1 Main Toolbar ........................................................................................................... B-1
   B.2 Data Model View Tool Palette ................................................................................ B-2
   B.3 Paper Layout View Tool Palette ............................................................................. B-3
Preface

This manual will help you get started using Oracle Reports, and also introduce you to publishing data to the Web and paper.

Audience

This tutorial is intended for users new to Oracle Reports, or for users familiar with Oracle Reports who would like to learn more about building JSP-based Web reports.

Documentation Accessibility

For information about Oracle's commitment to accessibility, visit the Oracle Accessibility Program website at http://www.oracle.com/pls/topic/lookup?ctx=acc&id=docacc.

Access to Oracle Support

Oracle customers that have purchased support have access to electronic support through My Oracle Support. For information, visit http://www.oracle.com/pls/topic/lookup?ctx=acc&id=info or visit http://www.oracle.com/pls/topic/lookup?ctx=acc&id=trs if you are hearing impaired.

Related Documentation

For more information, see the following documents:

- Release Notes for Oracle Forms and Reports
- Installation Guide for Oracle Forms and Reports
- Oracle Fusion Middleware Publishing Reports to the Web with Oracle Reports Services
- Oracle Reports Building Reports
- Oracle Reports online Help

Conventions

The following text conventions are used in this document:

<table>
<thead>
<tr>
<th>Convention</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>boldface</td>
<td>Boldface type indicates graphical user interface elements associated with an action, or terms defined in text or the glossary.</td>
</tr>
</tbody>
</table>
Prerequisites

The exercises in the tutorial use the Human Resources sample schema provided with the Oracle database and an HTML template.

You must download the supporting files for the report that you will build. You can download the sample tutorial zip folder, called tutorial_examples.zip, available on Oracle Technology Network (OTN) located at http://www.oracle.com/technetwork/middleware/reports/tutorial-examples-131273.zip. This zip file contains a text file containing the SQL you will enter, and the JSPs you will create in every chapter. Extract this zip file into ORACLE_HOME\examples (for example, D:\orawin\examples).

Sample Schema

This tutorial relies on the data contained in the Human Resources section of the sample schema. This sample schema is provided with the Oracle database.

Viewing Web Reports

To produce the Web-based report, you must have a Web browser installed on your computer. The minimum and recommended requirements are:

- Microsoft Internet Explorer 6.x or higher

or

- Mozilla Firefox 3.x or higher

Viewing the Web Source

Although you can view the Web source for your JSP report in Reports Builder, this tutorial also shows you how to analyze your Web source in a text editor. It is recommended that you use a text editor such as NotePad or UltraEdit.

<table>
<thead>
<tr>
<th>Convention</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>italic</td>
<td>Italic type indicates book titles, emphasis, or placeholder variables for which you supply particular values.</td>
</tr>
<tr>
<td>monospace</td>
<td>Monospace type indicates commands within a paragraph, URLs, code in examples, text that appears on the screen, or text that you enter.</td>
</tr>
<tr>
<td>monospace italic</td>
<td>Monospace italic type indicates variables or user-supplied names.</td>
</tr>
<tr>
<td>[ ]</td>
<td>Brackets enclose optional clauses from which you can choose one or none.</td>
</tr>
</tbody>
</table>
In this tutorial, it is assumed that you are a developer for a company called My Company. You have been asked to publish some content on the company intranet. Human resource managers for each branch should be able to view this content from any location. You must use the company’s template (which is an HTML file) to make the data look good on the Web. At the same time, managers must be able to print a paper version of the report.

In this tutorial, you will build a report for the Web using JavaServer Pages (JSP) that displays the required information about employee salaries in each department. You will also create a graph so that managers can see an overview of the data. At the end of the tutorial, you will learn to generate a paper report based on the same data model.

Figure 1–1 shows an overview of the first part of the tutorial.

Figure 1–1  Tutorial Overview: Creating the Web Report

1.1 Tutorial Scenario

In the chapters of this tutorial:

1. You will open the Web page that have been provided for you, which contains some simple HTML, then create a data model for the report, which will pull data from a sample data source into the report (Chapter 2, "Adding Data to a Report"). This Web page contains the template for My Company’s look and feel.
2. In Chapter 3, "Reviewing the Source Code of the Web Report", you will review the resulting report to analyze what the steps you completed in Chapter 2, "Adding Data to a Report" did to the sample Web page to help you understand what Reports Builder did to the sample Web page. You can compare the sample Web page that have been provided with the resulting JSP-based Web page. Here, you will be able to examine how the data model looks in Reports Builder, and how it looks in XML.

3. In Chapter 5, "Creating a Report Block for the Web Report", you will use the Report wizard to add a report block to the JSP and generate a simple JSP-based Web report to your Web browser.

4. In Chapter 4, "Reviewing the Source Code for the Report Block", you will analyze the Web source of your report to review how the report block was inserted into your JSP-based Web report. Again, you will examine the XML code to see how the source code has changed.

5. In Chapter 6, "Creating a Graph for the Web Report", you will use the Graph wizard to add a graph to the JSP, then generate the completed JSP report to your Web browser.
Figure 1–4  Adding a Graph to a JSP-based Web Report

6. In Chapter 7, "Reviewing the Source Code for the Graph", you will review the new code that Reports Builder added to your Web source to produce the graph.

7. In Chapter 8, "Generating a Paper Report", you will generate a paper report based on the same data model and layout that you created for the JSP-based Web report.

Figure 1–5  Generating a Paper Report from a JSP-based Web Report Data Model

1.2 Summary

Now that you know what this tutorial covers, you can go on to Chapter 2, "Adding Data to a Report" to learn how to create a data model for your report using the Data Wizard.
Adding Data to a Report

Estimated completion time: 15 minutes

Consider the scenario where you must create a Web report for your company’s human resources managers. This Web report must display salary information about each employee in a department. You already have an HTML page that matches the company’s logo and colors. You need to add the necessary information to this page.

This chapter shows you how to use the Data Wizard in Reports Builder to add data to an existing HTML page as depicted in Figure 2–1. At the end of the chapter, you will have created a data model to make data available for use in a Web report.

Figure 2–1 Adding Data to an HTML Page

2.1 Opening the Web Page

The steps in this section show you how to open the Web page template that have been provided, called emprev.htm. First, you will open the Web page in your Web browser so that you can see what our template looks like.

---

Note: If you do not have this file, refer to the Prerequisites section, in the Preface.

---

To open the sample HTML page in your Web browser

- In your Web browser (for example, Netscape or Internet Explorer), choose File > Open, and navigate to emprev.htm. The emprev.htm file is the sample file that have been provided in this Tutorial.
To open an existing HTML page in Reports Builder

1. Open Reports Builder.

   **Note:** If you are using UNIX, navigate to the directory where Reports Builder is installed, and then execute `rwbuilder.sh`

2. In the Welcome dialog box, click **Open an existing report**, then click **OK**.

3. In the Open dialog box, navigate to the folder where the tutorial sample files are located. For example, `d:\Reports_Tutorial`.

4. Find the `emprev.htm` file and click **Open**.

   The EMPREV report is displayed in the Object Navigator.

---

### 2.2 Using the Data Wizard to Add Data to a Sample Web Page

When building a report, you must first build a data model by selecting the data that you want to use in the report.

The steps in this section describe the procedure to use the Data Wizard to build a data model for your Web report. This data model makes the data from the sample schema available to use in your report.

**To add data to an existing HTML page**

1. Open the Data Wizard to define a layout and add a data model.
   
   a. In the Object Navigator, double-click the **Data Model** node.
   
   b. In the Data Model view, right-click the canvas, then choose **Data Wizard** from the shortcut menu.

2. If the Welcome page displays, click **Next**.

3. On the Query name page, click **Next** to accept the default name.

4. On the Data Source page, make sure **SQL Query** is selected, then click **Next**.

   **Note:** On the Data Source page, you can choose any data source you want to use in your report. For more information about using pluggable data sources, see Oracle Reports online Help.
5. On the Data page, you can do either of the following:
   ■ Open the tutorial_sql.txt file in a text editor, copy the query, and paste it into the SQL Statement box. Then, proceed to Step 16.
   ■ Learn to use the Query Builder. To use Query Builder, follow steps 6 to 15.

6. To use the Query Builder, click **Query Builder**.

   **Note:** If you do not know the connection information for the database that contains the sample schema that have been provided, contact your administrator.

7. In the Query Builder, double-click the **EMPLOYEES** table.

8. Double-click the **EMPLOYEES** table again, then click **Close**.

**Figure 2–3 Employees Tables Displayed in the Query Builder**

The EMPLOYEES table displays in the Query Builder as EMPLOYEES and EMPLOYEES A1. The link between MANAGER ID in EMPLOYEES and EMPLOYEE ID in EMPLOYEES A1 is automatically created because of the constraints that exist in the EMPLOYEES table.

   **Note:** You will notice that some column names are bold, and some are italicized. Column names that are in bold are primary keys and column names that are in italics are foreign keys.

9. In the **EMPLOYEES** table, select the check boxes for the following fields (you must select the fields in the following order):
   ■ **EMPLOYEE_ID**
   ■ **FIRST_NAME**
   ■ **LAST_NAME**
   ■ **HIRE_DATE**
   ■ **JOB_ID**
   ■ **SALARY**
   ■ **DEPARTMENT_ID**

10. In the **EMPLOYEES A1** table, select the check boxes for the following fields:
    ■ **EMPLOYEE_ID**
11. Click OK.

12. The query that Query Builder generates is displayed in the SQL Query Statement text box, and should look like the following:

```
SELECT ALL EMPLOYEES.EMPLOYEE_ID,
       EMPLOYEES.FIRST_NAME,EMPLOYEES.LAST_NAME,
       EMPLOYEES.HIRE_DATE,
       EMPLOYEES.SALARY,
       EMPLOYEES.DEPARTMENT_ID,
       EMPLOYEES_A1.EMPLOYEE_ID,
       EMPLOYEES_A1.FIRST_NAME, EMPLOYEES_A1.LAST_NAME
FROM EMPLOYEES, EMPLOYEES EMPLOYEES_A1
WHERE (EMPLOYEES.MANAGER_ID = EMPLOYEES_A1.EMPLOYEE_ID)
```

13. To restrict the retrieved data to only the employees in Department 100, add an AND clause, so that your query looks like this (new code is in bold text):

```
SELECT ALL EMPLOYEES.EMPLOYEE_ID,
       EMPLOYEES.FIRST_NAME,EMPLOYEES.LAST_NAME,
       EMPLOYEES.HIRE_DATE,
       EMPLOYEES.SALARY,
       EMPLOYEES.DEPARTMENT_ID,
       EMPLOYEES_A1.EMPLOYEE_ID,
       EMPLOYEES_A1.JOB_ID,
       EMPLOYEES_A1.FIRST_NAME, EMPLOYEES_A1.LAST_NAME
FROM EMPLOYEES, EMPLOYEES EMPLOYEES_A1
WHERE (EMPLOYEES.MANAGER_ID = EMPLOYEES_A1.EMPLOYEE_ID)
AND EMPLOYEES.DEPARTMENT_ID=100
```

14. Let us make the report look more organized by displaying the employee names with their last names first.

Concatenate the EMPLOYEES.FIRST_NAME and EMPLOYEES.LAST_NAME fields into an alias called `emp_name`.

The line of the query should now look like this:

```
, EMPLOYEES.LAST_NAME ||', '|| EMPLOYEES.FIRST_NAME emp_name
```

15. Concatenate the EMPLOYEES_A1.FIRST_NAME and EMPLOYEES_A1.LAST_NAME fields into an alias called `mgr_name`.

The line of the query should now look like this:

```
, EMPLOYEES_A1.LAST_NAME ||', '|| EMPLOYEES_A1.FIRST_NAME mgr_name
```

16. Verify that your query is correct. The entire query should now look like this:

```
SELECT ALL EMPLOYEES.EMPLOYEE_ID,
       EMPLOYEES.LAST_NAME ||', '|| EMPLOYEES.FIRST_NAME emp_name,
       EMPLOYEES.HIRE_DATE,
       EMPLOYEES.JOB_ID, EMPLOYEES.SALARY, EMPLOYEES.DEPARTMENT_ID, EMPLOYEES_A1.EMPLOYEE_ID,
       EMPLOYEES_A1.LAST_NAME ||', '|| EMPLOYEES_A1.FIRST_NAME mgr_name
FROM EMPLOYEES, EMPLOYEES EMPLOYEES_A1
WHERE (EMPLOYEES.MANAGER_ID = EMPLOYEES_A1.EMPLOYEE_ID)
AND EMPLOYEES.DEPARTMENT_ID = 100
```
17. Click Next.

18. Now that the raw data have been selected, let us organize this data into groups by department manager name.

On the Groups page, in the left column, click the MGR_NAME field, click the right arrow to move the field to the Group Fields list, then click Next.

19. Now, let us calculate some of our data. The Totals page displays some commonly-used calculations.

On the Totals page, in the left column, click SALARY, then click Sum to display the sum of the Salary column in the Totals list.

20. Click Finish.

Figure 2–4 Data Model View for the Report

Note: A report-level summary displays in the upper left-hand section of the Data Model view, but is not shown in this image.

2.3 Saving your Report as a JSP File

In Reports Builder, you can save your report using several formats. Since a JSP-based Web report is being create, the report must be saved in JSP format.

To save your report as a JSP
1. Select your report in the Object Navigator, then choose File > Save As.
2. In the Save dialog box, change the report name to emprev_your initials, change the type to Reports JSP (.jsp), and then click Save.

2.4 Summary

Congratulations! You have now created a data model that lets you include a report on your Web page. You now know how to:

- Open an existing Web page (HTML file) in Reports Builder
- Use the Data Wizard to specify data for a report
- Use the Query Builder to select data
- Save your report as a JavaServer Page (JSP)

To review your work, continue to Chapter 3, "Reviewing the Source Code of the Web Report". Otherwise, skip to Chapter 5, "Creating a Report Block for the Web Report" to continue building your report.
Reviewing the Source Code of the Web Report

Estimated completion time: 5 minutes

In Chapter 2, "Adding Data to a Report", you added a data model to your Web page. Here, the relationship between the entries you made in the wizard and the data model you created is being showed, and also the JSP and XML code.

You will also examine the custom JSP tags that Reports Builder inserted into your JSP. These custom JSP tags enable Oracle Reports to add the data you have chosen in the Data Wizard to the JSP-based Web report.

3.1 Viewing the Web Source in Reports Builder

To view the Web source of your report in Reports Builder
1. Make sure the report empverv_your_initials.jsp is open in Reports Builder.
2. In the Object Navigator, double-click the Data Model node to display the data model for this report. Your data model should look like this:

Figure 3-1  Data Model View for the Report

3. In the Data Model view, click the Web Source button in the toolbar.

Note: You can also double-click the Web Source icon under the report name in the Object Navigator.
Verifying Your JSP Code

The source code displays in the Web Source view. Scroll through the code and note the following items:

- The `@ taglib` line references the reports JSP library for all tags starting with `rw`. The `<% ... %>` tags mark JSP-relevant tags, and point to the JSP Custom Tag Library.
- Notice the opening `rw:report` tag and the opening and closing `rw:objects` tags.
- The `rw:report` tag appears after the library call. In a report, all Reports Builder JSP tags must appear between an opening and closing `rw:report` tag. If the closing `rw:report` tag comes before the data is used, the report will be empty.
- The `rw:objects` tags appear in the Web Source. Notice that you do not see any text between the opening and closing tags. When you save the report to your file system, Reports Builder encodes the data model and other elements in a language called XML, and places the data model between these tags. Reports Builder hides the XML code between these tags to maintain XML integrity.

**Note:** Unless you are comfortable using XML and JSPs, it is recommended that you do not type anything between the `rw:objects` tags in this view.

3.2 Verifying Your JSP Code

If you have gone through this chapter and are still not sure whether your JSP is correct, open the `emplrev.jsp` file. This file is located in the tutorial examples directory you created.

3.3 Summary

Congratulations! You have finished reviewing the data you added to your Web report in Chapter 2, "Adding Data to a Report". You now know how to view the source code in the Reports Builder Web Source view and have learned about these Oracle Reports custom JSP tags:

- `rw:report`
- `rw:object`

Continue to Chapter 5, "Creating a Report Block for the Web Report" to add a report block and finish your Web report.

For more information on Oracle Reports JSP tags, see the Oracle Reports online Help.
Reviewing the Source Code for the Report Block

Estimated completion time: 5 minutes

In Chapter 5, "Creating a Report Block for the Web Report", you added a report block to a JSP-based Web report. This chapter reviews the source code added for the report block.

4.1 Viewing the Web Source in Reports Builder

To view the Web source

- Open the Web source for the emprev_your initials.jsp report you created in Chapter 5, "Creating a Report Block for the Web Report" by double-clicking the Web Source node in the Object Navigator.

4.1.1 Reviewing the Header Tag and Body

1. In the Web Source view, locate the <!-- Header --> line.

   This HTML code indicates a comment line that helps you locate the report heading information in the file.

2. Locate the <th> and <tr> tags, which should look something like this:

   ```
   <tr>
   <th <rw:id id="HBEMPLOYEEID92" asArray="no" />
   class="OraColumnHeader">Employee Id </th>
   <th <rw:id id="HBempname92" asArray="no" /> class="OraColumnHeader">Emp Name </th>
   ...
   ```

4.1.2 Reviewing the rw:foreach Tag and Body

The rw:foreach tag loops across a group. The layout is repeated for each instance of the specified group.

1. In the Web Source view, locate the <rw:foreach> JSP tag and find this line:

   ```
   <rw:foreach id="R_G_EMPLOYEE_ID921" src="G_EMPLOYEE_ID">
   Here, R_G_EMPLOYEEID is a unique identifier for this loop and G_EMPLOYEE_ID is the data model group on which the loop repeats.

2. Notice that the </tbody> tag that closes the table follows the closing <rw:foreach> tag, as shown here:
4.2 Verifying Your JSP Code

If you have gone through this chapter and are still not sure whether your JSP is correct, open the file that have been provided, called empreva.jsp. This file is located in your examples directory.

4.3 Summary

Congratulations! You have finished reviewing the source code for the report block you added in Chapter 5, "Creating a Report Block for the Web Report". Continue to Chapter 6, "Creating a Graph for the Web Report" to add a graph to your Web report.
Creating a Report Block for the Web Report

Estimated completion time: 15 minutes

Now that you have created your data set, you need to format the data into your report, and thus provide managers with current information about their employees. To do so, you can create a report block and add it to your report. This report block pulls in the data dynamically using the query you specified in Chapter 1 every time you run the report, and format the data in your report.

The steps in this chapter describe the procedure to add a report block to your Web page as shown in Figure 5–1.

Figure 5–1 Creating a Report Block for your JSP-based Web Report

5.1 Adding a Report Block to Your Web Page

If you have performed the steps in Chapter 3, "Reviewing the Source Code of the Web Report", you should already have the source open in Reports Builder. In this case, you can skip Step 1. The steps in this section show you how to use the Report Wizard to format the data you specified in Chapter 1, and dynamically pull in the data into your report.

To add a report block

1. Make sure your report (emprev_your initials.jsp) is open in Reports Builder.

   Note: If you did not create emprev_your initials.jsp in Chapter 1, open the emprev.jsp file.

2. In the Object Navigator, double-click the Web Source node under emprev_your initials.
3. In the Web Source view, choose **Edit > Find and Replace** to find and delete the following text. Notice that this text occurs in two places. Replace this text with the Report block in Chapter 4 of the tutorial.

4. Ensure that your cursor is in the location where you deleted the text, and choose **Insert > Report Block** to display the Report Wizard.

5. On the first page of the wizard, title your report **My Team's Salaries**.

6. Select the **Group Above** radio button, then click **Next**.

7. Format the data so that the employee names list in a downward column, as follows:

   On the Groups page, click **G_EMPLOYEE_ID**, and then click **Down** to move the group to the Displayed Groups list.

   **Note:** If you did not select the fields in the correct order in Section 2.2, "Using the Data Wizard to Add Data to a Sample Web Page", you may not see this group. If this is the case, copy the SQL text from the tutorial_sql.txt file into the Query Statement box.

8. Click **Next**.

9. On the Fields page, click the double arrows (>>) to move all **Available Fields** to the **Displayed Fields** list.

10. In the **Displayed Fields** list, click **EMPLOYEE_ID1**, then click the left arrow (<) to move the field back to the **Available Fields list**, and then click **Next**.

11. On the Labels page, click **Next**.

12. Ensure that **Predefined Templates** is selected on the Templates page.

13. Make sure the **Beige** template is selected, then click **Finish**.
The Report Wizard has now generated the HTML with custom JSP tags to display your formatted data on the Web page.

14. Choose File > Save As.

15. In the Save dialog box, change the name to `emprev_your_initials.jsp`, and click Save.

16. Click the Run Web Layout button in the toolbar to run and view your report in your Web browser.

---

**Note:** If Netscape 7.0 is your default browser, and the browser does not display, set the registry key `HKEY_CURRENT_USERS\Software\Oracle\Toolkit\Tkbrowser` to the default browser location. Ensure that the `BrowserName` and the `BrowserPath` keys reflect the correct values. For example: `BrowserName=Netscape 7;BrowserPath=C:\Program Files\Netscape\Netscape\Netscp.exe`.

Your report should look something like this:

**Figure 5–3  JSP-based Web Report with Report Block**

![JSP-based Web Report with Report Block](image)

**Note:** You can also run the `empreva.jsp` file by opening the JSP in Reports Builder, and running it to the Web.

---

### 5.2 Summary

Congratulations! You have added a report block to a Web report. You now know how to:

- Create a report block
- Add a report block to an HTML page for a JSP-based Web report

To review your results, see Chapter 4, “Reviewing the Source Code for the Report Block”. Otherwise, skip to Chapter 6, "Creating a Graph for the Web Report" to add a graph to your report.
Creating a Graph for the Web Report

Estimated completion time: 15 minutes

This chapter describes how to use the Graph Wizard to create a graph that enables managers to view the salaries of the employees, and where each employee’s compensation rate falls within a specific department, as shown in Figure 6–1.

If you already know how to use the Graph Wizard, refer to Appendix A.3, "Entries for the Graph Wizard" for a quick reference guide.

Figure 6–1 Adding a Graph to a JSP-based Web Report

6.1 Opening the Source for the Report in Reports Builder

To open the Web source in Reports Builder
1. In the Object Navigator, ensure that the emprev_your_initials.jsp file is open.

   Note: If you have not already created your own JSP-based Web report, open the file that have been provided, named empreva.jsp.

2. In the Object Navigator, under the report name, double-click the Web Source icon to display the source code in the Web Source view.

3. In the Web Source view, choose Edit > Find and Replace to find and delete the following text:

Replace this text with the Graph in Chapter 6 of the Tutorial.
6.2 Creating a Graph Using the Graph Wizard

In this section, you will use the Graph Wizard to insert the JSP and XML code for the graph into the Web page for your Web report. The steps show you how to choose the type of graph you want, and the definitions of the X and Y axes. Notice that you will base the graph on the query you created in Section 2.2, "Using the Data Wizard to Add Data to a Sample Web Page".

If you already know how to use the Graph Wizard, refer to Appendix A, "Quick Reference Guide" for the entries in the Graph Wizard.

To create a graph

1. Make sure your cursor is where you deleted the text, and choose Insert > Graph to display the Graph Wizard.

2. If the Welcome page displays, click Next.

3. On the next page of the Graph Wizard, you can choose from a variety of graph styles. For our simple report, let us choose a Bar graph.

In the Graph Wizard, ensure that the default graph type (Bar) is selected, then click Next.

4. Move EMPLOYEE_ID to the X-Axis Categories list, then click Next.

5. Move SALARY to the Y-Axis Data list, then click Next.

6. On the Layout page, click and drag the EMPLOYEE_ID field from the Groups field to the Bars field, then click Next.

7. On the Graph Titles page, select Show Title, and in the first field, type Employees by Salary, then click Next.

8. Ensure that Show Legend is selected.

9. From the Location list, choose Right, then click Next.

10. In the Show X-Axis title field, type Employees, then click Next.

Note: Show X-Axis Title is automatically selected when you type text into the field.
11. In the **Show Y1-Axis title** field, type *Salaries*, then click **Next**.

12. At the bottom of the page in the Graph Wizard, click **Row 1 Color** and choose a different color, for example dark pink.

   Choose other colors for the other rows, if required.

13. Click **Finish**.

---

**Note:** If you click **Next** instead of **Finish**, you will notice that there is another page in the Graph Wizard where you can add hyperlinks to your graph. Since graph hyperlinks is not being used in this tutorial, you can click **Finish**. To learn more about using the Graph Wizard and graph hyperlinks, visit *Getting Started with Oracle Reports* and navigate to the Examples page. Here, you can view an example on using graph hyperlinks.

---

14. Click the Run Web Layout button in the toolbar to preview the report in your Web browser.

---

**Note:** If Netscape 7.0 is your default browser, and the browser does not display, set the registry key `HKEY_CURRENT_USERS\Software\Oracle\Toolkit\Tkbrowser` to the default browser location. Ensure that the `BrowserName` and the `BrowserPath` keys reflect the correct values. For example: `BrowserName=Netscape 7;BrowserPath=C:\Program Files\Netscape\Netscape\Netscp.exe`.

---

The report should look like Figure 6–3.
6.3 Saving Your Report with the New Graph

Saving your report with a different file name enables you to compare your results with the results that have been provided with the tutorial. This way, you can also roll back to the results of a previous chapter, if necessary.

1. Choose File > Save As.
2. In the Save dialog box, change the name to `emprevb_your_initials.jsp` and click Save.

6.4 Summary

Congratulations! You have added a graph to a JSP-based Web report. You now know how to use the Graph Wizard to design and add a graph to a Web report.

To review your results, continue to Chapter 7, "Reviewing the Source Code for the Graph".

For information on adding a JSP parameter form to this Web report, refer to the Oracle Reports Building Reports manual. For information on deploying this report to the Web, refer to the Oracle Fusion Middleware Publishing Reports to the Web with Oracle Reports Services manual.
Estimated completion time: 5 minutes

In Chapter 6, "Creating a Graph for the Web Report", you added a graph to a JSP-based Web report. This chapter reviews the source code added for the graph.

7.1 Viewing the Source in Reports Builder

Open the Web Source view for the report you created in Chapter 6, "Creating a Graph for the Web Report" called emprevb_your initials.jsp.

7.2 Reviewing the rw:graph Tag

The rw:graph tag brackets the graph information and links the graph to the data source. It also identifies the categories and the data fields.

1. In the Web Source view, locate the <rw:graph> JSP tag.

   The code within the rw:graph tag is XML.

   ```xml
   <rw:graph id="graph" src="G_EMPLOYEE_ID" series="EMPLOYEE_ID" dataValues="SALARY">
   The series tag defines the source for the values along the X-axis, and the dataValues tag defines the source for the data along the Y-axis. You defined these parameters in Chapter 6, "Creating a Graph for the Web Report".

2. Locate the SeriesItems tag below the rw:graph tag:

   ```xml
   <SeriesItems>
   <Series id="0" color="#cc66cc"/>
   </SeriesItems>
   ```

   This tag represents the modification to the Row 1 color we made in Chapter 6, "Creating a Graph for the Web Report". If you chose a different color, you will see a different value for the color tag.

3. Here, you can see that the #cc66cc color value is applied to the first bar along the X-axis:
4. Find the `<Title>` tag, located here:

```xml
</SeriesItems>
<Title visible="true" text="Employees by Salary"/>
```

This tag adds the graph title to your Web report, shown here:

**Figure 7–2  Graph with Title**

```xml
<rw:graph>
  <p>
    <p>
      <!-- The XML that produces the graph is closed before the <rw:graph> JSP tag is closed. -->
    </p>
  </p>
</rw:graph>
```

5. Find the `</rw:graph>` JSP tag, located here:

```xml
</Graph>
</rw:graph></p>
<p></p>
```

The XML that produces the graph is closed before the `</rw:graph>` JSP tag is closed.
Note: The Graph Wizard is re-entrant. So, if you want to modify your graph, move your cursor into the XML between the \textit{rw:graph} tags, click \textit{Edit >Settings}. The Graph Wizard displays with the options you chose in Chapter 6, "Creating a Graph for the Web Report".

7.3 Summary

Congratulations! You have finished reviewing the source code for your new graph. For more information on creating Web reports, adding report blocks and data, and creating graphs, see the \textit{Oracle Reports online Help}. 
Estimated Completion Time: 15 minutes

This chapter describes how to create a paper version of the Web report you created, as shown in Figure 8–1. Here, you will use the Report Wizard to create a paper layout using the data model you created in Chapter 2, "Adding Data to a Report".

If you already know how to use the Report Wizard, refer to Appendix A.4, "Entries for the Report Wizard" for a quick reference guide.

Figure 8–1 Generating a Paper Report from a JSP-based Web Report Data Model

8.1 Generate a Paper Report Based on Your Data Model

In this section, you will learn to generate a paper layout based on the data model you created in Chapter 2, "Adding Data to a Report".

**Note:** You must be connected to the same database you used, and access the Human Resources (HR) schema. If you do not know the connection information for the database, contact your database administrator.

**To generate a paper report using the Report Wizard**

1. In the Object Navigator, ensure that the report you created in Chapter 6, "Creating a Graph for the Web Report" called `emprevb_your_initials.jsp` is open.
2. In the Object Navigator, right-click the report name.
3. From the shortcut menu, choose Report Wizard.
4. Let us choose the Paper Layout since a paper report is being generated. Do not select a Web Layout since it has already been done in Chapter 3, "Reviewing the Source Code of the Web Report".
   In the Report Wizard, on the Report Type page, select Create Paper Layout only.
5. On the Style page, ensure that Group Above is selected, and that the title is My Team’s Salaries.
6. Click the Data tab.
   The data model you created in Chapter 2, "Adding Data to a Report" must display in the SQL Query Statement field.
7. On the Fields page, move all the fields back to the Available Fields list, then move the following fields to the Displayed Fields list by selecting the field, then clicking >.
   • emp_name
   • mgr_name
   • SALARY
   • SumSALARYPermgr_name
8. On the Labels page, in the Label field for the emp_name field, type Employee Name.
9. In the Label field for the mgr_name field, type Manager Name.
10. In the Label field for the SumSALARYPermgr_name field, type Total Salary.
11. On the Templates page, ensure that the Beige template is selected.
12. Click Finish.
   The report displays in the Paper Design view, and must look something like this:

Figure 8–2 Final Paper Report

<table>
<thead>
<tr>
<th>Manager Name</th>
<th>Greenberg, Nancy</th>
</tr>
</thead>
<tbody>
<tr>
<td>Employee Name</td>
<td>Salary</td>
</tr>
<tr>
<td>Favai, Daniel</td>
<td>9000</td>
</tr>
<tr>
<td>Chen, John</td>
<td>8200</td>
</tr>
<tr>
<td>Sotira, Jenna</td>
<td>7700</td>
</tr>
<tr>
<td>Popp, Luis</td>
<td>6900</td>
</tr>
<tr>
<td>Lemos, Jose Manuel</td>
<td>7800</td>
</tr>
<tr>
<td><strong>Total Salary</strong></td>
<td><strong>35980</strong></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Manager Name</th>
<th>Kochhar, Neena</th>
</tr>
</thead>
<tbody>
<tr>
<td>Employee Name</td>
<td>Salary</td>
</tr>
<tr>
<td>Greenberg, Nancy</td>
<td>12000</td>
</tr>
<tr>
<td><strong>Total Salary</strong></td>
<td><strong>12000</strong></td>
</tr>
</tbody>
</table>
13. Choose File > Save As.

14. Change the name to `emprev_paper_your_initials.rdf`, and ensure that rdf is selected.

15. Click Save.

### 8.2 Modifying a Report in the Paper Design View

Reports Builder provides you with numerous tools that you can use in the Paper Design view to modify the look and feel of your report. Because you are editing live data, you can see how the final result of your report will appear. This section describes how to enhance your report using some most commonly used formats:

- Aligning columns
- Setting format masks
- Manipulating objects
- Editing text
- Modifying visual attributes
- Highlighting data
- Inserting page numbering
- Inserting current data and time

To modify the appearance of your report in the Paper Design view

1. In the Paper Design view, click Flex Off in the toolbar.

2. Align the title with the logo.
   - Click the My Team’s Salaries report title and drag it 1.5 inches to the left, and 0.25 inches down.

3. While the object is selected, click Format, click Font, and then choose Arial, Bold, 12pt to format the text.
   - Tip: If the text does not fit within the object area, click the text object again, and drag one of the black squares to the right.

4. Your report title should now look like this:

   ![Figure 8–3 Formatted Title of the Paper Report]

5. Click the number column beneath the Salary label. All the number values are selected.

6. In the toolbar, click Currency, click Commas, then click Add Decimal Place twice.

7. While the number values are selected, click Align Right in the toolbar.

8. The Salary column should now look like this:
9. Since the salary numbers are aligned to the right, now align the Salary label to the right.

To do so, click the Salary label, then click **Align Right** in the toolbar.

10. Now, format the Total Salary numbers in the same way you formatted the Salary numbers.

11. Add a space between the Manager label and the manager’s name. To do so, click a manager’s name (for example, Greenberg,Nancy). While the object is selected, use the right arrow on your keyboard to move the field to the right.

Your report should now look something like this:

![Figure 8–5 Final Formatted Paper Report](image)

### 8.3 Summary

Congratulations! You have now generated a paper report based on the data model you created for a JSP-based Web report. You now know how to:

- Open the Report Wizard for an existing JSP-based Web report
- Create a paper layout for your report
- Produce a paper version of your Web report
- Format a paper report to make it more readable

For more information on generating a paper report based on an existing data model, see the *Oracle Reports online Help*. 
This appendix contains tables that describe the entries you make into each wizard in Reports Builder. These tables are meant to be a quick reference guide for you to use later, or for you to use if you are familiar with the wizards in Reports Builder.

### A.1 Entries for the Data Wizard

Table A–1 lists the entries you made in the Data Wizard in Chapter 2, "Adding Data to a Report".

<table>
<thead>
<tr>
<th>Data Wizard Page</th>
<th>Field</th>
<th>Input</th>
</tr>
</thead>
<tbody>
<tr>
<td>Query</td>
<td>Name</td>
<td>Employee Salaries</td>
</tr>
<tr>
<td>Data Source</td>
<td>SQL Query</td>
<td></td>
</tr>
<tr>
<td>Data</td>
<td>Query Statement</td>
<td>Paste in SQL from: &lt;example files&gt;/tutorial_sql.txt.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Connect</td>
</tr>
<tr>
<td>Group</td>
<td>Group Fields</td>
<td>MGR_NAME</td>
</tr>
<tr>
<td>Totals</td>
<td>Total Fields</td>
<td>Sum(SALARY)</td>
</tr>
</tbody>
</table>

### A.2 Entries for the Report Block

Table A–2 lists the entries for the report block in Chapter 5, "Creating a Report Block for the Web Report".

<table>
<thead>
<tr>
<th>Report Block Wizard Page</th>
<th>Field</th>
<th>Input</th>
</tr>
</thead>
<tbody>
<tr>
<td>Title</td>
<td>Title</td>
<td>Direct Reports by Manager</td>
</tr>
<tr>
<td>Type</td>
<td>Group Above</td>
<td>Select</td>
</tr>
<tr>
<td>Groups</td>
<td>Available Groups</td>
<td>G_EMPLOYEE_ID, DOWN</td>
</tr>
<tr>
<td>Displayed Fields</td>
<td>Available Fields</td>
<td>All fields (move all fields to Displayed)</td>
</tr>
<tr>
<td>Totals</td>
<td></td>
<td>None</td>
</tr>
<tr>
<td>Templates</td>
<td>Predefined Templates</td>
<td>Beige</td>
</tr>
</tbody>
</table>
A.3 Entries for the Graph Wizard

Table A–3 lists the entries you made to the Graph Wizard in Chapter 6, "Creating a Graph for the Web Report".

<table>
<thead>
<tr>
<th>Graph Wizard Page</th>
<th>Field</th>
<th>Input</th>
</tr>
</thead>
<tbody>
<tr>
<td>Type</td>
<td>Type</td>
<td>Bar</td>
</tr>
<tr>
<td>X-Axis - Category</td>
<td>Available Columns</td>
<td>Move EMPLOYEE_ID and MGR_NAME to X-Axis Categories</td>
</tr>
<tr>
<td>Y-Axis - Data</td>
<td>Available Columns</td>
<td>Move SALARY to Y-Axis Data</td>
</tr>
<tr>
<td>Layout</td>
<td>Groups field</td>
<td>Drag EMPLOYEE_ID from the Groups field to the Bars field.</td>
</tr>
<tr>
<td>Title</td>
<td>Show Title</td>
<td>Select Show Title and type Salary Comparison</td>
</tr>
<tr>
<td>Legend</td>
<td>Show Legend</td>
<td>Select</td>
</tr>
<tr>
<td>X-Axis</td>
<td>Show X-Axis Title</td>
<td>Select Show X-Axis Title and type Employees</td>
</tr>
<tr>
<td>Y-Axis</td>
<td>Show Y-Axis Title</td>
<td>Select Show Y-Axis Title and type Salaries</td>
</tr>
<tr>
<td>Plot Area Options</td>
<td>Row 1 Color</td>
<td>Select a different color</td>
</tr>
</tbody>
</table>

A.4 Entries for the Report Wizard

Table A–4 lists the entries for the Report Wizard in Chapter 8, "Generating a Paper Report".

<table>
<thead>
<tr>
<th>Report Wizard Page</th>
<th>Field</th>
<th>Input</th>
</tr>
</thead>
<tbody>
<tr>
<td>Layout</td>
<td>Create Paper Layout Only</td>
<td>Select</td>
</tr>
<tr>
<td>Type</td>
<td>Group Above</td>
<td>Select</td>
</tr>
<tr>
<td>Groups</td>
<td>Available Groups</td>
<td>(Do not change)</td>
</tr>
<tr>
<td>Displayed Fields</td>
<td>Available Fields</td>
<td>emp_name, mgr_name, SumSALARYPermgr_name, SALARY</td>
</tr>
<tr>
<td>Totals</td>
<td></td>
<td>(Do not change)</td>
</tr>
<tr>
<td>Labels</td>
<td>All labels</td>
<td>Change labels to be meaningful.</td>
</tr>
<tr>
<td>Templates</td>
<td>Predefined Templates</td>
<td>Beige</td>
</tr>
</tbody>
</table>

A.5 Reference Material

You create a reference-type chapter or appendix by using the following elements inside the RefEntry element within a chapter or appendix template file.

- RefSect1
You do not need the template file ref_chap.fm to create a reference-type chapter or appendix. All elements and formats you need to create reference-type documentation are in the chapter.fm or the appendix.fm template.

You can include Sect\(n\) elements at the beginning of a chapter or appendix that contains reference information. However, once you insert a RefEntry, you can no longer insert Sect\(n\) elements. Therefore, place all narrative or tutorial-type text at the beginning of a chapter or appendix, before reference information.
This appendix contains descriptions of the buttons and tools in the Reports Builder tool palettes and toolbars.

B.1 Main Toolbar

The main toolbar is located at the top of the Reports Builder window, directly beneath the menu bar:

*Figure B–1  Main Toolbar*

- **New** button. Displays the New Report dialog box.
- **Open** button. Displays the Open dialog box.
- **Save** button. Saves the report. If you haven’t saved the report before, the Save As dialog box displays.
- **Print** button. Prints the paper report.
- **Mail** button. Displays the Mail dialog box.
- **Connect** button. Displays the Connect dialog box.
- **Cut** button. Deletes the currently selected item and temporarily places it in the clipboard. Use Paste to paste the selected item.
Copy button. Temporarily places a copy of the selected item in the clipboard. Click the Paste button to paste the selected item.

Paste button. Pastes the item in the clipboard in current location of the cursor.

Undo button. Undoes the last action performed.

Redo button. Performs the last action again.

Run Web Layout button. Runs the current report to your Web browser.

Run Paper Layout button. Runs the current report to the Paper Design view in Reports Builder.

Help button. Displays the Oracle Reports online Help.

B.2 Data Model View Tool Palette

The Data Model view tool palette is a vertical group of tools located on the left-hand side of the Data Model view.

Select tool. Deselects any selected tool to turn off the current tool.

Magnify tool. Zooms in the view on the clicked object. Use SHIFT + Magnify to zoom out.

Summary Column tool. Creates a summary column in the query.

Data Link tool. Creates a link between the columns in the queries.
**Formula Column** tool. Creates a formula column in the query.

**Cross Product** tool. Creates a matrix (cross-product) group.

**Placeholder** tool. Creates a placeholder column which you can modify later.

**SQL Query** tool. Displays the SQL Query Statement dialog box where you can enter a SQL query SELECT statement or use Query Builder to create a query.

**Ref Cursor** tool. Displays the PL/SQL Editor where you can type a ref cursor query.

**XML Query** tool. Displays the Define XML Query dialog box, where you can specify the XML data definition and data source.

**JDBC Query** tool. Displays the JDBC Query dialog box, where you can define the SQL or stored procedure to define the data for the query.

**Text Query** tool. Displays the Text Query dialog box, where you can specify a text data definition and data source.

**Express Server Query** tool. Displays the Express Server Query dialog box, where you can specify an Oracle Express data definition and data source.

### B.3 Paper Layout View Tool Palette

The Paper Layout view tool palette is a vertical group of tools located on the left-hand side of the Paper Layout view.

**Select** tool. Deselects any selected tool to turn off the current tool.
**Magnify** tool. Zooms in the view on the clicked object. Use **SHIFT + Magnify** to zoom out.

**Frame Select** tool. Selects all objects within the selected frame or repeating frame, depending upon their explicit anchors (first click the tool, then the frame).

**Reshape** tool. Enables you to reshape the selected boilerplate object.

**Text** tool. Creates a boilerplate text object.

**Rotate** tool. Enables you to rotate the direction of the selected boilerplate object.

**Line** tool. Draws a line boilerplate object.

**Rectangle** tool. Draws a rectangle boilerplate object.

**Arc** tool. Draws an arc boilerplate image.

**Rounded Rectangle** tool. Draws a rounded rectangle boilerplate object.

**Polyline** tool. Draws an open multilined boilerplate object. Use your mouse to create the multiple lines.

**Polygon** tool. Draws a multisided boilerplate object. The object must be closed, unlike a polyline object.

**Freehand** tool. Draws a line where you drag your mouse.

**Ellipse** tool. Draws an ellipse boilerplate object.

**Frame** tool. Draws a frame.
Repeating Frame tool. Draws a repeating frame.

Graph tool. Displays the Graph Wizard so that you can define a graph that will be inserted into your layout.

Field tool. Creates a field object.

Anchor tool. Creates an anchor between two objects in your layout.

File Link tool. Creates a link file object that you can use to link an external file to your report.

Report Block tool. Displays the Report Block wizard so that you can add a new report block to your layout.