Adicionar Dimensões e Membros a Outlines

Os membros de nível superior de qualquer hierarquia em um outline do Essbase são chamados de dimensões ou nomes de dimensões. Existem dois tipos de dimensões: dimensões padrão e dimensões de atributo.

Você pode adicionar dimensões e membros a um cubo usando qualquer um dos seguintes métodos:

  • Adicione dimensões e membros manualmente com o outline no modo de edição.

  • Importe um arquivo do Excel contendo definições de dimensão (dados tabulares ou uma pasta de trabalho do aplicativo).

  • Crie dimensões usando uma origem de dados e um arquivo de regra.

Neste capítulo, o foco estará nas atualizações manuais do outline.

Adicionar Dimensões a Outlines Manualmente

Nos cubos de armazenamento em blocos ou modo híbrido parcial (que têm uma ou mais dimensões armazenadas), se você adicionar, excluir ou mover membros das dimensões e depois salvar o outline, o cubo será reestruturado.

Depois que a reestruturação for concluída, recalcule os dados. Cubos de armazenamento agregado e totalmente em modo híbrido não precisam ser recalculados porque são dinâmicos (dados de nível superior não são armazenados).

Se você adicionar uma dimensão virtual (cálculo dinâmico ou label somente), quaisquer dados existentes no cubo serão armazenados com o primeiro membro armazenado de nível 0 na nova dimensão. Deve haver pelo menos um membro armazenado na hierarquia.

Os nomes das dimensões sempre devem ser únicos no outline, mesmo que o outline permita nomes de membros duplicados. Para adicionar uma dimensão a um outline:

  1. Na Home page, navegue até o aplicativo e selecione o menu Ações Imagem do ícone do menu Ações na interface do Redwood, na página Aplicativos, ao lado do nome do aplicativo..
  2. Escolha Bancos de Dados > Database Name > Iniciar Estrutura.
  3. Se o outline estiver bloqueado e você tiver sido um administrador, clique em Desbloquear Imagem do ícone de Desbloquear outline no Redwood..

    Antes de forçar o desbloqueio de um outline bloqueado, certifique-se de que ninguém mais esteja trabalhando com ele.

  4. Clique em Editar Imagem do ícone de edição do outline redwood no editor de outlines. e selecione uma dimensão.

    Se o outline não contiver dimensões, a caixa de texto Criar sua primeira dimensão será exibida. Digite um nome de dimensão, clique em Adicionar dimensão e selecione a nova dimensão.

  5. Na barra de ferramentas do outline, no menu Adicionar membro, selecione Adicionar membro irmão abaixo.
    Imagem do outline redwood, menu Adicionar membro, com a opção Adicionar membro irmão abaixo destacada.

  6. Na caixa de diálogo Adicionar Membro(s), em Nome do membro, informe um nome.

    Não use mais de 1024 caracteres ao nomear dimensões, membros ou aliases.

  7. Ainda na caixa de diálogo Adicionar Membro(s), selecione as propriedades do membro que você deseja para a nova dimensão.
  8. Pressione Adicionar.
  9. Pressione Close.
  10. Pressione Validar Imagem do ícone de marca de seleção de verificação do outline..
  11. Pressione Salvar Imagem do ícone para salvar outline do Redwood..
  12. Selecione entre as opções de reestruturação do banco de dados e salve as alterações. Consulte Reestruturar Cubos.
  1. Na página Aplicativos, expanda o aplicativo.
  2. Clique nas Ações à direita do nome do cubo e escolha Estrutura de Tópicos.
  3. Clique em Desbloquear. Isso só será necessário se o outline estiver bloqueado. Caso contrário, prossiga até a etapa 4.
  4. Clique em Editar e, em seguida, selecione uma dimensão.
  5. Na barra de ferramentas do outline, em Ações, selecione Adicionar um irmão abaixo do membro selecionado.
  6. Digite um nome para a nova dimensão e pressione Tab.

    Não use mais de 1024 caracteres ao nomear dimensões, membros ou aliases.

  7. Na Barra de ferramentas do outline, em Ações, selecione Exibir painel de propriedades do membro no lado direito para abrir o painel de propriedades e selecione as propriedades que deseja para a nova dimensão.
  8. Clique em Salvar.

Adicionar Membros a Outlines Manualmente

Você pode adicionar membros manualmente a um outline usando o editor de outline na interface web do Essbase. A menos que o cubo esteja habilitado para nomes de membros duplicados, cada membro terá um nome exclusivo.

  1. Na Home page, navegue até o aplicativo e selecione o menu Ações Imagem do ícone do menu Ações na interface do Redwood, na página Aplicativos, ao lado do nome do aplicativo..
  2. Escolha Bancos de Dados > Database Name > Iniciar Estrutura.
  3. Se o outline estiver bloqueado e você tiver sido um administrador, clique em Desbloquear Imagem do ícone de Desbloquear outline no Redwood..

    Antes de forçar o desbloqueio de um outline bloqueado, certifique-se de que ninguém mais esteja trabalhando com ele.

  4. Clique emEditar Imagem do ícone de edição do outline redwood no editor de outlines..
  5. Para exibir e selecionar membros de nível inferior em uma dimensão, faça drill-down na dimensão expandindo o nome da dimensão e os nomes dos membros subsequentes.
  6. Quando você atingir o membro ao qual deseja adicionar um membro filho ou irmão, selecione-o.
  7. Na barra de ferramentas, no menu Imagem do ícone para adicionar membro no Redwood. Adicionar membro, selecione Adicionar membro irmão acima, Adicionar membro irmão abaixo ou Adicionar filho.
  8. Na caixa de diálogo Adicionar Membro(s), em Nome do membro, informe um nome para o novo membro.

    Não use mais de 1024 caracteres ao nomear dimensões, membros ou aliases.

  9. Ainda na caixa de diálogo Adicionar Membro(s), selecione as propriedades que deseja para o novo membro.
  10. Pressione Adicionar e Fechar.
  11. Pressione Validar Imagem do ícone de validação Redwood..
  12. Pressione Salvar Imagem do ícone para salvar outline do Redwood..
  1. Na página Aplicativos, expanda o aplicativo.
  2. No menu Ações à direita do nome do cubo, selecione Estrutura de Tópicos.
  3. Clique emEditar.
  4. Para exibir e selecionar membros de nível inferior em uma dimensão, faça drill-down na dimensão expandindo o nome da dimensão e os nomes dos membros subsequentes.
  5. Quando você atingir o membro ao qual deseja adicionar um membro filho ou irmão, selecione-o.
  6. Na barra de ferramentas do outline, em Ações, selecione Adicionar um irmão acima do membro selecionado, Adicionar um irmão acima do membro selecionado ou Adicionar um filho ao membro selecionado.
  7. Digite o nome do novo membro e pressione Tab.

    Não use mais de 1024 caracteres ao nomear dimensões, membros ou aliases.

  8. Na barra do outline, em Ações, selecione Exibir painel de propriedades do membro no lado direito para abrir o painel de propriedades e selecione as propriedades que você deseja para o novo membro,
  9. Clique em Salvar.