man pages section 9: DDI and DKI Properties and Data Structures

Exit Print View

Updated: July 2014
 
 

copyresp(9S)

Name

copyresp - STREAMS data structure for the M_IOCDATA message type

Synopsis

#include <sys/stream.h> 

Interface Level

Architecture independent level 1 (DDI/DKI)

Description

The data structure copyresp is used with the M_IOCDATA message type.

Structure Members


int      cp_cmd;       /* ioctl command (from ioc_cmd) */
cred_t   *cp_cr;       /* full credentials */
uint_t   cp_id;        /* ioctl id (from ioc_id) */
uint_t   cp_flag;      /* ioctl flags */
mblk_t   *cp_private;  /* private state information */
caddr_t  cp_rval;      /* status of request: 0 -> success; 
                       /* non-zero -> failure */

See also

STREAMS Programming Guide