Developing and Deploying Siebel Business Applications > Getting Started with Siebel Tools > Other Key Tasks for Managing Object Definitions >

Importing Object Definitions

You can import object definitions from an archive file into your local repository. To import object definitions you need to have access to the archive files (SIF) and the target repository needs to be the active repository on your local machine.

NOTE:  A local or server database can contain more than one repository. However, Siebel Tools only shows information from only one repository at any time. This is the active repository. You can change the active repository by selecting the Repositories object type in the Object Explorer window or by choosing File > Open Repository.

To import archive files

  1. Lock the projects that will contain the objects you are importing.

    NOTE:  If you do not lock the projects affected by the import, the Import Wizard prompts you to lock them in the second dialog box of the wizard.

  2. Choose Tools > Import From Archive.

    The Select Archive File to Import dialog box appears.

  3. Find the object archive file (SIF) to import.
  4. Click open.

    The Import Wizard opens and the object archive file opens.

  5. Select a conflict resolution option.
  6. Click next.

    The Import Wizard checks for differences between the object definitions in the current repository and the object definitions in the archive file.

  7. If there are no differences, the object definition is imported.

    If there are differences, the Import Wizard displays the following:

    • Conflicting Objects. Shows the object types in which differences were found.
    • Object Differences. Shows whether the object exists in the archive file only, in the current repository, or both, and shows the conflict resolution action that has been defined. You can change the action if necessary.
    • Attribute Differences. Shows the object attributes that have different values. If the action for the object difference is merge, you can update the value in the Resolution column by selecting the attribute, right-clicking, and then choosing Repository or File.

Developing and Deploying Siebel Business Applications Copyright © 2006, Oracle. All rights reserved.