Siebel Database Upgrade Guide > Performing the Siebel Repository Merge >

Performing a Siebel Repository Merge

Upgrades from: All Supported Siebel releases.

Environments: Development environment only.

Platforms: Windows and UNIX only. Does not apply to IBM z/OS.

This topic is part of an upgrade process. See How to Perform a Siebel Database Upgrade.

This task merges customizations in the Prior Customer Repository (your current repository) into the New Customer Repository (the repository in the new Siebel release).

The repository merge typically takes five to seven hours to complete.

Prerequisite: The workstation on which the merge will occur must have a minimum of 512 MB of RAM and at least 2 GB of virtual memory or a 2-GB page file. Inadequate system resources is one of the most common causes of repository merge failures. If your repository includes a large amount of customization, additional memory may be required.

To merge the repository

  1. Verify that all Siebel Tools projects are checked in and unlocked.
  2. Close network connections to all repository users and exit Siebel Tools.
  3. Open the tools.cfg file in the new Siebel release. It is located in the following directory:



    Tools_install_dir is the directory in which Siebel Tools is installed, and lang is the language, for example enu.

  4. Locate the SIEBEL section, and verify that the parameters are set as shown in Table 34.
Table 34. Siebel Tools Configuration File Parameters for Upgrade





  1. Save the file and close it.
  2. Navigate to Control Panel > System > Advanced > Performance Settings > Visual Effects.
  3. Click Adjust for best performance.
  4. Start Siebel Tools in the new Siebel release, using the following command line option:

    NOTE:  The current install directory location for Siebel Tools should be Tools_install_dir\bin, as the merge0.txt file will be generated under that path.

  5. Navigate to View > Options > Language Settings.
  6. Verify that the language mode setting is set as desired.

    This will be the user interface language for SRF files compiled from the New Customer Repository. It will also be the language used by the postmerge utilities.

  7. Use the File > Open Repository command to open the Prior Customer Repository.
  8. Choose Tools > Upgrade > Upgrade Application.

    The Merge Repositories dialog box appears.

    Click for full size image

    The Merge Repositories dialog box provides four options:

    • Merge. This button merges the repositories you specify to produce a New Customer Repository.
    • Cancel. This button cancels the repository merge and exits the Merge Repositories dialog box.
    • Advanced. This button opens the Merge Options dialog box.
  9. In the Merge Repositories dialog box, choose the repositories listed in the following table.
    Drop-Down List Item
    Value to Choose

    Prior Standard Repository

    Prior x.x Siebel Repository, as appropriate for the version from which you are upgrading

    Prior Customized Repository

    Prior Customer Repository

    New Standard Repository

    New Siebel Repository

    New Customized Repository

    New Customer Repository

  10. Click Advanced.

    The Merge Options dialog box appears.

  11. In the Merge Options dialog box, click the check boxes to activate or deactivate the merge options:
    • Abort merge if more than x errors occur. Activate this option to abort the repository merge automatically if more than a designated number of errors occur.

      CAUTION:  The typical Repository merge generates many benign errors. If you select this option, set the number of errors to a large value. This will help prevent the Repository merge from aborting due to benign errors.

    • Incorporate Custom Layout. Activate this option to help preserve field and button placement on prior custom or modified forms, views, and screens. Select a prior release and style for label placement.

      The Prior Release is the release you are upgrading from. The placement of Labels controls where labels are placed in forms. As of Siebel 7.7, label alignment of fields changed. Label vertical alignment changed from top to middle, font weight changed from bold to normal, and text alignment changed from left to right. To preserve the look and feel of releases prior to Siebel 7.7, select Label on Top in the Placement of Labels field.

      After you have made your selections, click OK.

      The Upgrade Check List dialog box appears.

  12. In the Upgrade Check List dialog box, verify that each prerequisite has been met. When they have been met, put a check mark in all the boxes and click Continue.

    CAUTION:  The upgrade may fail if all the items in the checklist are not completed.

  13. If the following Warning screen appears, choose No.

    After the merge completes, a dialog displays requesting that you make a backup of the New Customer Repository.

Related Topics

About the Siebel Repository Merge

About the Siebel Incorporate Custom Layout (ICL) Upgrade Option

Siebel Database Upgrade Guide Copyright © 2008, Oracle. All rights reserved.