Siebel Anywhere Administration Guide > Upgrade Planning and Preliminary Tasks > Determining Upgrade Requirements >

Determining Required Upgrade Sequences

You may sometimes need to use more than one upgrade kit to complete an upgrade. For example, client software in a Siebel maintenance release or patch may consist of a base component and a language-specific component. The base component would require a Siebel Client Executable upgrade kit, and the language-specific component would require a Siebel Client Executable_[language-code] upgrade kit.

In cases involving multiple upgrade kits, the kits may need to be installed in a specific sequence. (For Siebel maintenance releases, the base upgrade kit must be installed before any language-specific upgrade kit.) It is possible to automate this process by making one kit dependent on the prior installation of another kit. You can specify this dependency before activating the second kit in the sequence. For instructions on how to do this, see Controlling the Order of Kit Installation.

NOTE:  If you plan to specify a required upgrade sequence, do not use the Upgrade Kit wizard to activate the kits involved.

Siebel Anywhere Administration Guide