Skip Headers
JD Edwards EnterpriseOne Tools Translation Tools Guide
Release 8.98 Update 4

Part Number E14722-02
Go to Documentation Home
Home
Go to Book List
Book List
Go to Table of Contents
Contents
Go to Index
Index
Go to Master Index
Master Index
Go to Feedback page
Contact Us

Go to previous page
Previous
Go to next page
Next
PDF · Mobi · ePub

8 Translating Reports

This chapter contains the following topics:

8.1 Understanding Report Translation

This section discusses:

8.1.1 Report Translation

You create reports using Oracle's JD Edwards EnterpriseOne Report Design Aid (RDA) Translation Tool. Reports are generally referred to as Universal Batch Engines (UBEs) because they not only present data in report form, but they also can be used to create batch programs that perform certain actions.

Reports are used to view trends, outcomes, and information from JD Edwards applications. Reports can be accessed from multiple JD Edwards programs and menus. Generally, a report name begins with the letter R and is followed by the application name; there are exceptions, however.

Use the Report Design Aid (RDA) Translation Tool to translate interface items of JD Edwards reports from the source language into the target language.

8.1.2 The Report Translation Process

You translate reports by selecting untranslated items within the assigned system. To translate report items:

  1. Display the first report in the list.

  2. Translate these items:

    • Report title

    • Page headers

    • Page details

    • Columns

      Note:

      Section titles do not need to be translated.
  3. Save the changes.

When you save a translation, the JD Edwards Translation Tool displays the next item of the chosen status. Continue translating items until no untranslated items remain.

8.1.3 Report Versions

Different versions of the same report often exist. The base report or template is marked with a plus sign (+), and versions are usually named XJDE0001, XJDE0002, ZJDE0001, and so on.

A version is a user-defined set of specifications. These specifications control how applications and reports run. You use versions to group and save a set of user-defined processing option values or data selection and sequencing options. Interactive versions are associated with applications (usually as a task selection). Batch versions are associated with batch jobs or reports. To run a batch process, you must select a version.

8.1.4 The Report Design Aid (RDA) Translation Tool Interface

The Report Design Aid (RDA) Translation Tool consists of these tabs: View, Audit, Tasks, Data Dictionary, Glossary, and Processing Options.

8.1.4.1 Report Design Aid View Tab

On the View tab of the Report Design Aid Text form, you can display all of the items for the selected report in a menu tree view. When you click an item in the tree, the current source term, the target term, and the status appear in the data fields of the common area.

8.1.4.2 Report Design Aid Audit Tab

The Audit tab displays the selected statistics for items that are contained in the report. You cannot enter or change any of the displayed items. The information in the common area remains the same as it appears on the View tab.

8.1.4.3 Report Design Aid Tasks Tab

The Task tab lists the selected report's tasks in a tree format for you to review. All of the entries are derived from the database by the system and cannot be changed.

8.1.4.4 Report Design Aid Data Dictionary Tab

The Data Dictionary tab contains the selected report's data items and user-defined codes (UDCs) in a menu tree view. You cannot enter or change any of the displayed items.

Note:

You can access the data dictionary translation tools to edit data dictionary and user-defined code items from the RDA tools by double-clicking node from the data dictionary folder or by selecting DD from the Form menu.

8.1.4.5 Report Design Aid Glossary Tab

The Glossary tab contains the selected data item's glossary text. The Glossary tab enables you to view the glossary for the source and target language. You cannot edit the glossary from this tab. To edit the glossary, select DD from the Form menu. In addition, the data field information in the common area remains the same as it appears in the View tab.

8.1.4.6 Report Design Aid Processing Options Tab

On the Processing Options tab, you can view all of the selected report's processing options items for translation in the menu tree format.

Note:

You can access the Processing Option text translation tool to edit processing option text from the RDA tools by double-clicking a node from the Processing Options folder.

8.2 Translating Report Information

When you translate reports, you translate all of the items for that report, such as the report title, page headers, page details, and columns.

To translate report information:

  1. From the Translation Applications menu (GH791), select either Senior Translations or Junior Translations, depending on whether you are a senior or junior translator, and then F79760: Report Design Aid (RDA).

  2. On the Work with Report Design Aid Text form, complete these fields and click Find:

    • Status

    • Language

    • (Optional) Program ID

      This field is in the detail area.

  3. Select an item in the detail area and click Select.

  4. On the Report Design Aid Text form, select the View tab, and then click an item in the menu tree.

  5. Enter the translation.

  6. Click OK to save the translation.

    When you click OK, the system saves the translation, updates the status, and displays the next item of the chosen status in the Source data field.

8.3 Using Overrides

This section discusses how to:

8.3.1 Using Overrides

An English override that is applied to an item within an application means that a developer overrode a data dictionary description and entered an alternate description.

When an item does not have an English override, the base data dictionary description automatically appears in the target field. Controls and grids within a form in an application correspond to a data dictionary item. If development has not overridden the text, you should assign the data item the DD Default (status 15 FDA/RDA DD Default) when you translate.

When an English override is applied to an item, the Text Overridden check box in the Text Information group is selected in the Form Design Aid Text form. In these cases, a language override is also applied automatically. You cannot clear the Text Overridden check box when the English description was overridden. The text must be translated because the DD Default cannot be used. Use the Suggestions option to ensure consistent terminology when translating overridden items.

Note:

When you change a default value for a data dictionary item, the change is made dynamically in every instance of the software. Changes to overrides must be made to each individual instance.

8.3.2 Removing Overrides

If the base translation is not appropriate in the context of the application's form, you have these options:

  • Change the item to status 15 (FDA/RDA DD Default) to apply a language override.

    The new translation that you enter applies only to the item for that particular application.

  • Apply an override yourself.

    Use status 11 (Complete) to apply a language override. The new translation that you enter applies only to the item for that particular application.

  • Remove a language override by changing the status to 11 (Complete). When you do this, JD Edwards Translation Tools display the data dictionary translation for you to review and replace as necessary.