Skip Headers

Oracle E-Business Suite User's Guide
Release 12.1
Part Number E12896-04
Go to Table of Contents
Go to previous page
Go to next page

Forms-Based Applications

Using Forms-Based Applications

The Navigator

the picture is described in the document text

From the Navigator you can:

Open Forms

The Functions tab provides links to the forms accessible to your current responsibility.

To open a form, expand the function heading and double-click the form name.

Create a Top Ten List

Add forms that you use frequently to your Top Ten List. Create a different top ten list for each of your responsibilities.

To add a form to the Top Ten List

To remove a form from the Top Ten List

Create Links to Documents

Create links to documents that you are working on for faster access. The Documents tab allows you to save as many links as you want. View the saved links as a list or as icons.

To add a document that is currently open

To rename a link that you have created

  1. Select its name (or icon) and select the Rename button.

  2. Enter the new name in the Rename Label window and click OK.

To remove a document from the Documents tab

Launch Business Processes

The Processes tab contains interactive step-by-step maps of business processes. Each step is a form or report that you can launch directly from the process map.

Each time you launch a business process, you create an instance of that process and assign it a name. As you complete each step in a process, the map is updated accordingly.

To open a process

  1. Select the process, then select the Launch button.

  2. Enter a name for the new instance.

    The instance remains active until you complete or cancel it. The Processes tab lists your active instances.

Working in a Process Instance

The active step has a box drawn around it. More than one step can be active if your process contains multiple paths.

The Forms Toolbar

the picture is described in the document text

The toolbar icons and the actions they perform are as follows:

  1. The New icon opens a new record.

  2. The Find... icon invokes the Find window.

  3. The Show Navigator icon invokes the Navigator window.

  4. The Save icon saves your data.

  5. The Next Step icon advances you to the next step of a process. See Launch Business Processes.

  6. The Switch Responsibilities icon invokes the list of your responsibilities for you to choose another.

  7. The Print... icon prints the current screen. In some cases it may print a report associated with the current data.

  8. The Close Form icon closes all windows of the current form.

  9. The Cut icon cuts the current selection to the clipboard.

  10. The Copy icon copies the current selection to the clipboard.

  11. The Paste icon pastes from the clipboard into the current field.

  12. The Clear Record icon erases the current record from the form.

  13. The Delete icon deletes the current record from the database.

  14. The Edit Field... icon displays the Editor window for the current field.

  15. The Zoom icon invokes customer-defined drill-down behavior.

  16. The Translations... icon invokes the Translations window. See Creating Translations for a Record.

  17. The Attachments icon invokes the Attachments window. If attachments already exist, the icon appears as a paperclip holding paper. See Attachments.

  18. The Folder Tools icon invokes the Folder Tools palette window. See Customizing the Presentation of Data.

  19. The Window Help icon invokes online help for the current window.

Entering Data in Forms

Use the following form components to enter and query data:

the picture is described in the document text

  1. Single-Row Block

  2. Multi-Row Block

  3. Folder Indicator

  4. Current Record Indicator

  5. Record

  6. Field

  7. List of Values Indicator

  8. Descriptive Flexfield

  9. Master-Detail Coordination Box.

Organization of a Form


Use fields to enter, view, update, or delete information.

By default, a required field is displayed in yellow, and a read-only field is displayed in gray. These colors can be changed or turned off using profile options. See Defining Preferences with User Profile Options.

In some cases, the display size of a field is too small to show the entire field contents. Use the Edit Field toolbar icon to view and update these fields.


A record is a logical grouping of fields. A record is also referred to as a row or a transaction, since one record corresponds either to a row in a database table or to a transaction.

You must complete all required fields in a record before moving to the next record.

Tip: If you unintentionally enter a record and cannot advance your cursor, clear the record. From the Edit menu, choose Clear, then Record.


A block displays a set of records either in a single-row format or a multi-row format.

Tip: To clear data at the block level: From the Edit menu, choose Clear, then Block.

Creating and Deleting Records

To create a record

  1. Choose New from the File menu, or use the New toolbar icon.

  2. After entering data for your new record, choose Save or Save and Proceed from the File menu to save the record to the database. Choosing Save and Proceed automatically advances you to the next record.

To delete a record

  1. Choose Delete from the Edit menu.

    This action erases the current record from your screen, and returns your cursor to the first field of the next record.

  2. To delete the record from the database, choose Save or Save and Proceed from the File menu.

Using a List of Values (LOV)

A field that has a predefined list of valid values displays an LOV icon. Select this icon to view the valid field values.

If a list contains more than 100 values, you are prompted to enter a Find string to limit the list.

To choose a value from a list

Select a value, or reduce the list using one of the following methods:

Power List

Power List enables you to enter a search string or partial value in an LOV field without opening the list window.

To use Power List

Enter the initial characters of a value in the field and press the Tab key. Power List completes the entry for you.

Your entry can include wildcard characters.

If more than one value matches the characters you specify, a list window opens containing those values.

Advanced Data Entry Features

Master-Detail Relations

A Master-Detail relation is an association between two records. An example is the relationship between the Batch and Journals records in Oracle General Ledger. Each batch (master record) is associated with a set of journal entries (detail records).

Some master-detail blocks contain a coordination check box that allows you to choose whether detail records are queried. Select the master-detail coordination check box to automatically coordinate the update of records between the master and detail blocks. If you deselect the check box, the detail data is not displayed until you move your cursor into the detail block.

Drill-Down Indicators

Some records provide additional details in separate, drill-down windows.

A wide-width current record indicator designates that a record provides drill-down information. Double-click the indicator to open the detail window.


A flexfield is a flexible data field that can be customized by your enterprise. Oracle E-Business Suite uses two types of flexfields:

Key Flexfields

A key flexfield is composed of segments, where each segment has both a value and a meaning. For example, an Accounting Flexfield can be composed of segments that represent Company, Department, and Account. The segments are delimited by a segment separator (usually a "." or a "-").

A range flexfield is a type of key flexfield in which you can input a low and a high value for each segment to express a range of combinations.

A key flexfield looks like any other field. You can enter the segments directly or use the Flexfield window to enter each segment separately.

To enter data directly into a key flexfield

To enter data using the flexfield window

  1. Select the List of Values icon to open the flexfield window, or select the Edit Field... toolbar icon.

  2. Enter a value for each segment, or use the list of values where available.

  3. Select the Combinations button in the flexfield window to search the list of existing segment combinations.

To enter data in a range flexfield

Descriptive Flexfields

A descriptive flexfield appears as a two-character, unnamed field enclosed in brackets.

Move your cursor into the bracketed field to open the descriptive flexfield window. The window contains segments that make up the descriptive flexfield. Each segment can have a list of values.

To enter data in a descriptive flexfield

  1. Open the descriptive flexfield window. If your profile option Flexfields:Open Descr Window is set to "No", or if you are in a folder, select the Edit Field... toolbar icon to open the flexfield window.

    Note: For more information on profile options, see Defining Preferences with Personal Profile Options.

  2. Enter a value for each segment, or use the list of values where available. Default values can be overwritten.

Creating Translations for a Record

Windows that allow the entry of records in multiple languages display the enabled Translations... toolbar icon.

To enter a translation for a record

  1. Select the record you wish to translate.

  2. Select the Translations... icon from the toolbar.

    The Translations window opens, with translatable fields displayed in columns. The installed languages are displayed in rows.

  3. Enter translations for the displayed fields.

Using Keyboard Help

Use keystroke combinations to perform many menu functions.

To view the list of functions and keystroke combinations

Searching for Data

To query records in your current block or window, use the Find command or Query by Example.

The Find Command

The Find command displays a window in which you can specify search criteria. Depending on the block that you invoke Find from, one of two types of windows appears:

Generally, a find window appears for a multi-record block, while a list window appears for a single-record block.

Using the Find Command

Query by Example

To retrieve a group of records based on more sophisticated search criteria than Find allows, use Query by Example. Query by Example allows you to specify search criteria in any of the queryable fields in the current block. The search criteria can include specific values, phrases containing wildcard characters, or query operators.

If you do not need to retrieve the records, but only want to know how many records match your search criteria, perform a query count.

Using Query by Example

  1. From the View menu, choose Query by Example, then Enter.

    This action switches your window from data entry mode to Enter Query mode. Queryable fields are displayed in blue.

  2. Enter search criteria in the queryable fields. (Fields may be case-sensitive). To reuse criteria from your last search: From the View menu, choose Query by Example, then Show Last Criteria.

    Important: In Enter Query mode, all check boxes are initially in a null state. To use a check box as a search criterion, you must explicitly check or uncheck it.

  3. To perform the search: From the View menu, choose Query by Example, then Run.

  4. To exit Enter Query mode without searching: From the View menu, choose Query by Example, then Cancel.

To perform a query count

  1. Perform steps 1 and 2 from the previous task: "To use Query by Example".

  2. From the View menu, choose Query by Example, then Count Matching Records. The window's message line displays the number of matching records.

Query Operators

The following table shows the query operators for most fields, their meanings, and an example expression:

Query Operators
Operator Meaning Example Expression
= equals = 'Janet', = 107
!= is not != 'Bob', != 109
> greater than > 99.1, > '01-JAN-04'
>= at least >= 55
< less than < 1000.00
<= at most <= 100
#BETWEEN between two values #BETWEEN 1 AND 1000

Customizing the Presentation of Data

Folder blocks allow you to personalize a form. You can define a query, customize the layout of the form columns, and then save the query and layout in a folder definition that can be retrieved later.

Folder blocks display an Open Folder button. When you move the cursor into a folder block, you enable the Folder Tools toolbar icon and the Folder menu.

Important: If your system administrator sets the profile option Folders: Allow Customization to "No", you cannot create or customize folders. The only item available from the Folder menu is Open, to open a predefined folder. For more information about profile options, see Defining Preferences with User Profile Options.

Query Criteria for a Folder

To define query criteria for a folder

  1. Run a query, either by using the Find command or Query By Example.

  2. Save your query criteria by choosing Save As from the Folder menu.

  3. Enter a name for the folder.

  4. Select Always, Never, or Ask Each Time from the Autoquery option group to define how frequently to perform the saved query.

  5. Select the Open as Default check box to set this folder definition as the default every time you navigate to this form.

  6. Select the Public check box to allow other users to access your folder definition. Selecting Public does not enable other users to modify your folder.

  7. Select the Include Query check box to include your query in the folder definition. If you do not select this check box, only the folder layout is saved.

To view the query criteria for a folder

To reset the query criteria for a folder

  1. Choose Reset Query from the Folder menu.

    This clears the query from the current folder, but retains the current folder name and field layout.

  2. Perform another query and choose Save from the Folder menu to save the new query to your current folder.

Customizing the Layout of a Folder

Use the Folder menu or the Folder Tools window to customize the folder layout. Some layout changes can be made using the mouse. For example:

To access the Folder Tools window

Running Reports and Programs

A report or a concurrent program can be scheduled and submitted as a single request, or you can schedule and submit multiple reports and programs together as a request set.

Important: The navigation path you use to schedule and submit requests varies by application. Some of the options mentioned may not be available based on the selected request or your responsibility. Some functions automatically submit a request when you choose a specific button or save your work.

Request Submission

  1. Choose the Program Name from the list of available requests and then enter a Request Name, which can be used later to search and monitor your request.

    Use the Copy... option to choose and submit a request that you have previously submitted from this responsibility.

  2. Define parameters.

    If a request requires parameter values, the Parameters window opens. Enter the values in the required parameter fields.

    Note: Your user profile option Flexfields:Open Descr Window must be set to "Yes". See Defining Preferences with User Profile Options.

  3. Determine the output language.

    If your site supports multiple languages, select the language for your request output.

    Choose the Language Settings... button to open the Languages window. If the language selection is predefined in the report, the Language Settings... button is not enabled.

    In the Languages window select the Language, Territory, and Numeric Character settings appropriate for your report.

    Select the Select All button to produce output in all languages supported at your site or to check individual languages.

    Important: Each language creates its own request, so the number of languages determines the number of requests created and tracked in the Requests window.

  4. Define a schedule.

    Specify when you would like your request to run. You can choose a simple schedule such as, as soon as possible, a specific date and time, or recurring intervals; or you can choose a more advanced schedule such as specific days of the week or specific dates in a month. You can also choose a previously saved schedule.

    Note: If you do not select an end date for the more advanced schedules, the request will continue to run until it is cancelled.

  5. Define the layout.

    Note: Select the Options... button to change the default layout. notification, and output options.

  6. Notify employees.

    Choose the employee name from the list of available employees, and then choose the circumstance of when to notify this employee. This option sends an E-mail notification, with a link to the request, based on if the request ran normally or resulted in a warning or error.

  7. Print the output to:

    For printed output, select the print style, printer, copies, and language.

    To view your output online or to save your output to a file, select the Save all Output Files check box.

    Note: Some requests have a required Style, Printer, or Language value that you cannot change.

  8. Specify delivery options for Internet Printing Protocol (IPP) printer, E-mail, Fax, or FTP.

  9. Review your choices, make any necessary changes, and submit your request.

Multiple Organizations Reporting

Multiple organizations reporting improves reporting capabilities of Oracle E-Business Suite by allowing reporting across operating units.

An operating unit is an organization that uses Oracle Cash Management, Order Management and Shipping Execution, Oracle Payables, Oracle Purchasing, and Oracle Receivables. An operating unit is associated with a legal entity and may be a sales office, a division, or a department. Information is secured by operating unit for these applications, and you see information only for your operating unit.

When multiple organizations reporting is active, a list of available operating units is enabled when you enter the Program Name. Choose the operating unit to run your report against and continue submitting your request.

Request Sets

  1. Choose the Request Set Name from the list of available request sets.

    Use the Copy... option to choose and submit a request set that you have previously submitted from this responsibility.

  2. Define the parameters, layout, notification, and printer output information for each report or program listed in the request set.

  3. Define the schedule.

    Specify when you would like this request set to run. See Request Submission.

  4. Review your choices, make any necessary changes, and submit your request set.

    Note: Each report or program contained in the request set is assigned its own ID so that its status can be monitored individually on the Requests page.

Monitoring Requests

The Requests window allows you to:

Important: You can view only those requests to which you have been granted access by an administrator.

Request Phase and Status

A request has a life cycle consisting of the following phases: pending, running, and completed. If a request is on hold or unable to run, the request is placed in an inactive phase.

During each phase, a request has a specific status. Listed below are the possible statuses for each phase:

For more information about the status of your request, select the Diagnostics button in the Requests window.

Finding Requests

  1. Open the Requests window (navigation varies by application).

    When you open the Requests window, you are directed to the Find Requests window.

  2. Define your search criteria.

    Note: You can use the Specific Requests region to view a list of requests that you did not submit by entering a requestor other than yourself. However, you can only view details, output, and log files for requests submitted by you or your responsibility.

  3. Select Find.

Options for Requests in Progress

Hold or cancel pending requests from the Requests window using the Hold Request or Cancel Request buttons.

View request diagnostics by selecting the Diagnostics button. The Request Diagnostics window displays information about the request run. The window may contain a View XML button to display the generated XML data, if applicable.

You can change completion and scheduling options for requests that meet the following criteria:

To Change Options for a Request in Progress

  1. Select the request from the list.

  2. Select the View Details... button to launch the Request Detail window.

Viewing Request Output

Reports are displayed in a browser, in the Report Viewer, or in another application registered by your system administrator. Reports that produce an output other than a text file, such as HTML or PDF, are displayed in a browser.

Set the profile option Viewer: Text to "Browser" to display your text files in a browser. If your system administrator registered other applications for viewing reports, select your text viewer application using the profile option Viewer: Application for Text. If this profile option is not set, you get a choice of applications when you view the report.

For more information about these profile options, see Defining Preferences with User Profile Options.

To View Request Output

  1. Navigate to the Requests window.

  2. Select the completed request and select the View Output button.

    Tip: To view request log files: Select the View Log button.

To save request output displayed in the Report Viewer

  1. Choose Copy File... from the Tools menu to display the Viewer Option window.

  2. Select an output file format. This action opens your browser window.

  3. From the browser window, use your browser's tools to save your request output to a file.

Republishing or Reprinting Requests

Requests with multiple layout templates can be republished using a different template. If multiple templates are not available, reprint is the only option.

  1. Select the request and choose the Republish button or choose Republish... from the Tools menu.

  2. In the Republish and Reprint Request window, choose one of the following:

    Republish & Print - Allows you to select a new layout template, language, and output format for the data already generated by your request, and print the output.

    Republish & View - Allows you to select a new layout template, language, and output format for the data already generated by your request and simply view the output online.

    Reprint existing output - Reprints the request.

  3. Choose the Layout and Printer options as appropriate for your selection.

Saving Reports from Your Browser

You can use the Save As functionality of your browser to save an HTML report to your desktop. Ask your system administrator for assistance if your browser does not display your language's character set clearly.

Exporting Records to a File

Use the export feature to save the records in a multi-row block to a tab-delimited file. Open the file in the application of your choice.

To start an export

  1. Query the records you want to export.

  2. Place your cursor in the multi-row block that contains the records to be exported.

  3. Choose Export... from the File menu.

Exporting Large Numbers of Records

Export, by default, selects all the records retrieved by the query. If the number of records exceeds 100, you are prompted to:

Stop - Limit the export to those records you have explicitly selected. Alternatively, cancel the export.

Continue to End - Export all records retrieved by the query.

Important: Avoid exporting a very large number of records as system performance can be affected.

Continue - Select the next 100 records for export. You are prompted every 100 records until all records are selected, or you choose Stop or Continue to End.


Use the Attachments feature to link text or other files to a record.

The Attachments... toolbar icon is enabled when the attachments feature is available. If the current record already has an attachment, the icon appears to hold a piece of paper.

To open the Attachments window

To add a new attachment

  1. Select a Category from the list of values. The Category defines the purpose of an attachment and controls which forms or pages can access it.

  2. Select the attachment Data Type from the list of values:

  3. Optionally add a title for your document.

  4. Select the May Be Changed check box to allow changes to the attachment.

To attach a document from the Document Catalog

  1. Choose the Document Catalog... button to open the Document Catalog window.

  2. Use the Find Existing Documents region to query existing documents. Matching documents are returned in the Documents region.

    Note: To copy an attachment from another record, use the Attached To: field to select the application object you want to copy attachments from.

  3. To view a document before attaching it, select it and then choose the Preview button.

  4. Select the document(s) to attach.

  5. Choose the Attach (n) button, where n is the number of documents selected.

To view an attached document

In the Attachments window, select the attachment you want to view. If the attachment does not automatically display in the document block, select the Open Document button to view the document in a browser.

To delete a record's attachment

When you delete an attachment, you can remove the association between the record and the attached document or remove the attached document from the file system or database.

  1. In the Attachments window, select the document to delete.

  2. Choose Delete from the Edit menu.

  3. Select a button in the Decision window to remove either the Document and Attachment or just the Attachment.

Defining Preferences with User Profile Options

Use profile options to modify the way your applications run.

Oracle E-Business Suite supports a set of user profile options that are common to all applications. In addition, each application has its own set of user profile options. See your application's documentation for information on application-specific profile options.

Profile Hierarchy

Profile options can be set at four levels:

A User-level setting overrides a Responsibility-level setting, which overrides an Application-level setting, which overrides a Site-level setting.

Your system administrator sets options at all four levels. You can change options only at the User level.

Setting Profile Options

Use the Profile Values window to display and change your user profile options.

Note: There are some profile options that you can view but not change. For example, you can view the value for Concurrent:Request Priority, which is set at the User level, but only your system administrator can change its value.

If you do not set a user profile option, it assumes a default value set either by your system or your system administrator.

To set a profile option

  1. Navigate to the Profile Values window (navigation varies by application.)

  2. Enter a value in the User Value field or choose a value from the list of values, if available. To accept the default setting, clear the User Value field.

    Important: Number and date values are not validated. Ensure that you enter a valid number or date, or the associated profile option may not work as you expect.

  3. Choose Save from the File menu or select the Save toolbar icon.

    Note: Some profile option changes do not take effect until you change responsibilities or restart your session.

Common Profile Options

Flexfields:Open Descr Window

Controls whether a descriptive flexfield window automatically opens when you navigate to it. Valid values are Yes or No.

FND: Indicator Colors

Valid values are Yes (default), No, or null. When this profile option is set to Yes:

Folders:Allow Customization

Determines whether you can personalize folders. Valid values are:

Note: Only the system administrator can update this profile option.

Indicate Attachments

Turns off the indication of attachments when querying records (for performance).

Note: Only the system administrator can update this option.


Use this option to define your printer.


Valid values are Yes and No. Yes displays a message at login that indicates:

Viewer: Application for Text

If your system administrator has registered other applications for viewing text output, select the application from the list of values. The profile option Viewer: Text must be set to Browser to use this profile option.

Viewer: Text

Sets the display viewer for text report output. Valid values are Browser and Report Viewer.