- set up NIS client
/usr/sbin/ypinit [-c] [-m] [-s master_server]
ypinit can be used to set up an NIS client system. You must be the superuser to run this command. This script need not be used at all if ypbind(1M) is started with the -broadcast option (it is invoked with this option from the svc:/network/nis/client:default service).
Normally, ypinit is run only once after installing the system. It may be run whenever a new NIS server is added to the network or an existing one is decommissioned.
ypinit prompts for a list of NIS servers to bind the client to; this list should be ordered from the closest to the furthest server. Each of these NIS servers must be listed in the /etc/hosts file along with its IP address. ypinit stores the list in file /var/yp/binding/domain/ypservers. This file is used by ypbind when run without the -broadcast option.
Set up a ypclient system.
Build a master ypserver data base.
Slave data base. master_server must be the same master configured in the YP maps and returned by the ypwhich -m command.
See attributes(5) for descriptions of the following attributes:
The NIS client service is managed by the service management facility, smf(5), under the service identifier:
ypinit sets up the list of NIS servers only for the current domain on the system when it is run, that is, the domain returned by the SI_SRPC_DOMAIN command to sysinfo(2). Care should be taken to ensure that this is the same as the desired domain for NIS client processes.