Common Desktop Environment: Application Builder User's Guide

Module Browser

The Module Browser (also called the browser) provides a hierarchical, tree view of a module. Use it to view modules, edit the interface, group or ungroup objects, create connections, and display object property editors for editing. About the only things you can't do in the Browser that you can do in the interface is move or align objects.

To display the Browser, choose Module Browser from the View menu in the App Builder primary window and select a module in the pull-right menu displayed or select an object in the interface and Choose Browse from the pop-up menu (displayed by pressing mouse button 3 in the interface).

Edit menu

Includes the same functions as the Edit menu in the App Builder primary window: Undo, Cut, Copy, Paste, and Delete. If you select an object or objects in the Browser and choose a menu item, the objects selected will be selected in the interface and the function chosen will be performed in the interface.

View menu

Horizontal displays child objects to the right of their parent object. Toggles with Vertical, which displays child objects below their parent object. Vertical is the default view.

Hide Object Glyph hides the icons/glyphs that represent the objects in the interface. Toggles with Show Object Glyph, which is the default.

Show Object Type displays the object types of objects in the interface. Toggles with Hide Object Type, which is the default.

Collapse "undisplays" the children of selected parent objects. This enables you to see more of the interface in a smaller space.

Expand displays the children of selected collapsed parent objects.

Expand All expands all collapsed parent objects.

Module displays the module chosen from the submenu.

Find displays a Find Object dialog box, for finding objects by object name; if the object is found, the object is selected and the canvas scrolls to show the object.

Tearoff Browser displays a new browser, enabling you to view more than one module.

Module name

Indicates the module being viewed. Can be changed through the View menu.

Top-level view

Shows all direct children of the module--windows, menus, and messages. A detailed view of each of the objects selected here is shown in the detailed tree view.

Detailed tree view

Shows a detailed view of the top-level objects selected. All children of the selected top-level objects are shown.

Note -

When you group objects or edit the interface in the Browser, be sure to check the interface to see that you haven't obscured any objects. In particular, if you group objects, the rectangular group created may hide an object behind it.