The halt and poweroff utilities write any pending information to the disks and then stop the processor. The poweroff utility will have the machine remove power, if possible.
The halt and poweroff utilities normally log the system shutdown to the system log daemon, syslogd(1M), and place a shutdown record in the login accounting file /var/adm/wtmpx. These actions are inhibited if the -n or -q options are present.
The following options are supported:
Force a system crash dump before rebooting. See dumpadm(1M) for information on configuring system crash dumps.
Suppress sending a message to the system log daemon, syslogd(1M), about who executed halt.
Prevent the sync(1M) before stopping.
Quick halt. No graceful shutdown is attempted.
Halt the system, even from a dialup terminal.
See attributes(5) for descriptions of the following attributes:
|ATTRIBUTE TYPE||ATTRIBUTE VALUE|
The halt utility does not execute the scripts in /etc/rc<num>.d or execute shutdown actions in inittab(4). To ensure a complete shutdown of system services, use shutdown(1M) or init(1M) to reboot a Solaris system.
The poweroff utility is equivalent to init 5.