The dhcpinfo utility prints the DHCP–supplied value(s) of the parameter requested on the command line. The parameter may be identified either by its numeric code in the DHCP specification, or by its mnemonic identifier, as listed in dhcp_inittab(4). This command is intended to be used in command substitutions in the shell scripts invoked by init(1M) at system boot. It first contacts the DHCP client daemon dhcpagent(1M) to verify that DHCP has successfully completed on the requested interface. If DHCP has successfully completed on the requested interface, dhcpinfo retrieves the values for the requested parameter. Parameter values echoed by dhcpinfo should not be used without checking its exit status. See EXIT STATUS.
See dhcp_inittab(4) for the list of mnemonic identifier codes for all DHCP parameters. See RFC 2132, DHCP Options and BOOTP Vendor Extensions for more detail.
The output from dhcpinfo consists of one or more lines of ASCII text; the format of the output depends upon the requested parameter. The number of values returned per line and the total number of lines output for a given parameter are determined by the parameter's granularity and maximum values, respectively, as defined by dhcp_inittab(4).
The format of each individual value is determined by the data type of the option, as determined by dhcp_inittab(4). The possible data types and their formats are listed below:
|Data Type||Format||dhcp_inittab(4) type|
|Unsigned Number||One or more decimal digits||UNUMBER8, UNUMBER16, UNUMBER32, UNUMBER64|
|Signed Number||One or more decimal digits, optionally preceded by a minus sign||SNUMBER8, SNUMBER16, SNUMBER32, SNUMBER64|
|IP Address||Dotted-decimal notation||IP|
|Octet||The string "0x" followed by a two-digit hexadecimal value||OCTET|
|String||Zero or more ASCII characters||ASCII|
The following options are supported:
Displays the output in a canonical format. This format is identical to the OCTET format with a granularity of 1.
Specifies the interface to retrieve values for DHCP parameters from. If this option is not specified, the primary interface is used.
Limits the list of values displayed to limit lines.
Numeric code for the requested DHCP parameter, as defined by the DHCP specification. Vendor options are specified by adding 256 to the actual vendor code.
Mnemonic symbol for the requested DHCP parameter, as listed in dhcp_inittab(4).
The operation was not successful. The DHCP client daemon may not be running, the interface might have failed to configure, or no satisfactory DHCP responses were received.
The operation timed out.
Some system error (should never occur).
See attributes(5) for descriptions of the following attributes:
|ATTRIBUTE TYPE||ATTRIBUTE VALUE|
Alexander, S., and R. Droms, RFC 2132, DHCP Options and BOOTP Vendor Extensions, Silicon Graphics, Inc., Bucknell University, March 1997.