Sun Java System Connector for Microsoft Outlook 7 2005Q4 User's Guide

Chapter 8 Troubleshooting

This chapter provides troubleshooting tips when using Sun Java System Connector for Microsoft Outlook.

If Microsoft Outlook Is Not Your Default Email Client

The Sun Java System Connector for Microsoft Outlook can be installed only if Microsoft Outlook is set to be your default email client. If Outlook is not set as your default email client, the Setup Wizard will notify you of the problem (in an error message after the Welcome screen), and prompt you to acknowledge the notice and exit the program.

ProcedureTo Set Outlook as Your Default Mail Client

  1. Open your Windows Control Panel. If you are running Windows XP (only): Select “Switch to Classic View.”

  2. Double-click on Internet Options.

  3. Select the Programs tab from the Internet Properties window.

  4. Select Microsoft Outlook from the Email pull-down menu.

  5. Click OK.

Next Steps

You may rerun the Setup Wizard after you set your default email client to Outlook.

If a Sun Synchronization Program Is Installed, and Must Be Removed

The MAPI services for the Sun Java System Connector for Microsoft Outlook are a required component of the Connector installation, but cannot coexist with the Sun Java System Synchronization program (previously known as the ONE Sync program). If one of these Sun synchronization programs is installed on your workstation, the Setup Wizard will notify you of the problem (in an error message after the Welcome screen), and prompt you to acknowledge the notice and exit the program. You may then rerun the Setup Wizard after you remove the synchronization program.

Note –

To synchronize your Palm device, WinCE device or Pocket PC device with Outlook, we strongly recommend that you use the sync software distributed with your device, rather than the Sun synchronization software. Changing to the sync software distributed with your device may require uninstalling and reinstalling the Palm Desktop software.

ProcedureTo Remove the Synchronization Program

  1. From your Start menu: Select the Uninstall... option for the program you want to uninstall.

    Select one of the following:

    • Programs->Sun Java System Synchronization->Uninstall Sun Java System Synchronization

    • Programs->Sun ONE Synchronization->Uninstall Sun ONE Synchronization.

  2. In the Uninstallation window, follow the prompts to uninstall the software.

  3. Click Finish to complete the uninstallation process.


If you want to continue using the Sun synchronization software to sync to the data of your other device: Reinstall the software, but do not select the checkbox for the Microsoft Outlook 98/2000 translator during the installation.

If a Personal Folder (.pst) File Conversion Is Interrupted

Since Personal Folder (.pst) file conversions can run for many minutes or even hours for large files, an interruption of the process— by a power failure, for example— could be especially inconvenient if it meant having to repeat the lengthy process from scratch. The Setup Wizard therefore offers a recovery feature that lets you resume an interrupted conversion from wherever it was interrupted. Note that this recovery feature is available only when an interruption occurs during a “large” Personal Folder conversion— not during a profile conversion or during the conversion of smaller .pst files. (Your network administrator has previously set a size limit to define the difference between “large” and “small” files.)

If the conversion of a large .pst file is interrupted, the Wizard will temporarily add to your desktop an icon for the recovery feature, titled “Finish Aborted Sun Java System Connector Wizard Conversion.” The recovery feature will not work if you simply restart the Setup Wizard as you ran it for your original conversion; you must start it from the desktop “Finish” icon, as shown in Figure 8–1.

Figure 8–1 To Finish an Aborted Conversion: The Desktop “Finish” Icon

Desktop “Finish” icon

To complete an interrupted conversion: Start the recovery mode of the Sun Java System Connector Setup Wizard, by double-clicking the “Finish” desktop icon.

The Wizard then displays its Welcome screen, as shown in Figure 8–2, and notifies you that it has detected an incomplete conversion.

Figure 8–2 Setup Wizard Welcome Screen, to Resume an Interrupted Conversion

Setup Wizard Welcome Screen, to Resume an Interrupted Conversion

This recovery procedure is an abbreviated version of the original Setup procedure, as described in The Setup Procedure. The Wizard remembers, from its interrupted run, which user profile and which Personal Folders (.pst) files you selected for conversion, so it will not prompt you for that information again.

Instead, when you click Next from the Welcome screen shown here, the Wizard skips ahead to step 5 or 6 of the original Setup procedure: to prompt you for your old Exchange login information (step 5) if you previously used Outlook on this computer, or for your new Sun Java System Account login information (step 6) if you will be a new Outlook user. From step 5 or 6 forward, the procedures are identical, so please refer to The Setup Procedure.


This section provides troubleshooting tips for logging and log reports.

Enabling Logging for Troubleshooting

In order to keep track of any problems that may arise with your mail folders or messages, it is recommended to turn on the logging function for debugging purposes.

ProcedureTo Enable Logging

  1. From the Help menu, select About Sun Java System Connector for Microsoft Outlook.

  2. In the About dialog, click Debug Logs.

  3. In the Debug Logs dialog, enable the checkbox next to Turn on debug logging.

    The Log file path indicates the location of the log files.

  4. When you are finished, click OK.

Sending a Log Report

You can send a log report of any problems to your technical support representative.

ProcedureTo Send a Log Report

  1. Turn on logging as indicated in Enabling Logging for Troubleshooting

  2. Return to Outlook and attempt to reproduce the steps the caused the problem.

  3. From the Help menu, select About Sun Java System Connector for Microsoft Outlook.

  4. In the About dialog, click Debug Logs.

  5. In the Debug Logs dialog, enter the email address of your technical support representative.

  6. Click Report.

    A new message appears addressed to technical support. A copy of your log file and your system information is also included in the message.

  7. You may enter any more information, or cc anybody else before sending the message.

Increasing Log Files and Size

Log files are regularly reused and overwritten by new log files. This occurs more frequently for users with large mailboxes. You can increase the size of your log files or increase the number of logs files by resetting three registry keys. The registry keys are:

Assigning Tasks

When assigning tasks to other users, you cannot set different permissions to tasks and your calendar. The permissions assigned to your calendar applies to your tasks, and visa versa.

If you are assigned a task, you cannot read the message in your inbox. Move it to one of your local folders in order to read the task message.

If a Server is Down

If Messaging Server is down, you will be unable to log into Outlook. You can, however, work in offline mode.

If Messaging Server is working, but Calendar Server or Address Book Server is down, you can log in to Outlook, but you will be unable make any changes (for example, create new events, new contacts).

Viewing Message Source

If a message does not display correctly, or if you need a message's header information for debugging purposes, you can view the source information of that message.

ProcedureTo View the Message Source

  1. Double-click on a message from the message list.

    A new window displays containing the message.

  2. In the message window, select View->Message Source.

    The Message Source window displays header and source information for the message.

  3. You can copy the information and send it to support for debugging.

  4. Click Close to close the window.

Viewing Message Source While Composing a Message

You can also view the message source while composing a message by selecting View->Message Source in the Message window.