|Skip Navigation Links|
|Exit Print View|
|man pages section 5: Standards, Environments, and Macros Oracle Solaris 10 8/11 Information Library|
- native branded zone
The native brand uses the branded zones framework described in brands(5) to run zones installed with the same software as is installed in the global zone. The system software must always be in sync with the global zone when using a native brand.
The following native brand-specific subcommand options are supported in zoneadm(1M).
For native zones, zoneadm checks package and patch levels on the machine to which the zone is to be attached. If the packages/patches that the zone depends on from the global zone are different (have different revision numbers) from the dependent packages/patches on the source machine, zoneadm reports these conflicts and does not perform the attach. If the destination system has only newer dependent packages/patches (higher revision numbers) than those on the source system, you can use the -u option to update the attached zone to match the -revision packages and patches that exist on the new system. With -u, as in the default behavior, zoneadm does not perform an attach if outdated packages/patches are found on the target system.
For native zones, one or more -b options can be used to specify a patch ID for a patch installed in the zone. These patches will be backed out before the zone is attached or, if -u was also specified, updated.
The native brand installer supports installing the zone from either the software already installed on the system or from an image of an installed system running the same release. This can be a full flash archive (see flash_archive(4)) or a cpio(1) or pax(1) “xustar” archive. The cpio archive be compressed with gzip or bzip2. The image can also be a level 0 ufsdump(1M), a path to the top-level of a system's root tree, or a pre-existing zone path.
With no options the zone is installed using same software as is running the global zone.
To install the zone from a system image either the -a or -d is required. Either the -u or -p option is also required in this case.
One or more -b options can be used to specify a patch ID for a patch installed in the system image. These patches will be backed out during the installation process.
The path to the root directory of an installed system. If path is a hyphen (-), the zonepath is presumed to be already populated with the system image.
Preserve the system configuration after installing the zone.
Run sys-unconfig(1M) on the zone after installing it.
Verbose output from the install process.
See attributes(5) for a description of the following attributes: