5 Working with the Installation Planner for an Upgrade

This chapter consists of the following topics:

See Also

5.1 Understanding the Planner Process for Upgrades

Installation Planner is an Release 9.1 application that runs on the Deployment Server. It is a system administration tool that guides through the process of configuring the machines on which you will run Release 9.1.

This chapter contains the tasks for defining a custom installation plan. The information you provide on the Installation Planner forms, such as database type and Enterprise Server type, determines the information you see on the remaining forms. The Installation Planner processing options also affect which choices you are given while setting up your plan. For a complete description of the processing options, refer to Section 5.3, "Reviewing Installation Planner Processing Options".

Caution:

To use Installation Planner remove machines from an existing installation plan, see Section 5.5, "Deleting Machines from an Installation Plan"

This chapter contains the following topics:

5.1.1 Assumptions about Mandatory Pre-Upgrade Process

This table outlines the assumptions about the mandatory pre-upgrade process.

Personnel Installer
Logon Status On the Deployment Server, logged on to Release 9.1 as user JDE into either the JDEPLAN or DEP910 environment (each step will tell you which environment to use.)
Prerequisites Verify that the Deployment Server is installed and the latest Tools Release, Tools Release Patch, and Planner Update have been installed, in that order. Verify that the Pristine database is installed and the Pristine Central Objects loaded.
Concurrent Tasks None.

5.1.2 Mandatory Pre-Upgrade Process - Upgrading the Pristine Environment

Due to the hundreds of table conversions, which will run during the upgrade process, the process has changed to run the table conversions on the server. The following process is necessary to run Table Conversions on the server.

Caution:

The Pristine (PS910) environment must be installed prior to running Table Conversions. Each step must be completed and checked off in the exact order listed below.
  • Create an Upgrade Plan for the Pristine (PS910) environment.

  • Follow the steps in the Section 5.4.1, "Starting Installation Planner" section and create a plan for Pristine only.

  • Run the Upgrade Plan just created for the Pristine (PS910) environment.

    Note:

    Table Conversions will not run when upgrading the Pristine (PS910) environment.

    The following steps may be completed while the Installation Workbench is running the Pristine (PS910) upgrade plan.

  • Install the latest Tools Release and Tools Release Patch on the Enterprise server (the Tools Release level must match what was installed on the Deployment Server).

    Note:

    This step may also be performed while the Installation Workbench is running.
  • Ensure that JD Edwards EnterpriseOne services are up and running on the Enterprise server.

    Note:

    Installation Workbench for the Pristine Environment must be completed before proceeding with following steps.
  • Continue upgrading your desired environments.

5.1.3 Running Table Conversions Locally

The functionality to run the Table Conversions locally on the Deployment Server is still available, and works much as it did in previous releases. Run Table Conversions on the Enterprise Server in order to minimize Upgrade time.

If you choose to run your Table Conversions locally instead of on the Enterprise Server, some steps in the Mandatory Pre-Upgrade Procedure must still be completed before running the Installation Workbench. These are:

  • Installing latest Tools Release

  • Loading latest Planner Update

These steps are described in the Section 5.1.2, "Mandatory Pre-Upgrade Process - Upgrading the Pristine Environment".

5.1.4 Deferring Index Builds (Tools Release 9.1 Update 2)

Beginning with JD Edwards Tool Release 9.1 Update 2, if you want to defer index builds during the JD Edwards EnterpriseOne upgrade process, refer to the Chapter of this guide entitled: Chapter 5, "Working with the Installation Planner for an Upgrade" in the section of that chapter entitled: Section 6.13.5, "Deferring Index Builds During Table Conversion Workbench (Tools Release 9.1 Update 2)".

5.2 Working with JD Edwards EnterpriseOne Software Requirements

The goal of the JD Edwards EnterpriseOne Release 9.1 Installation is to include the most current tools releases and updates at the time the installation image is mastered. However, subsequent to that time it is possible that critical fixes may become necessary and available. You should check Section 1.3.1, "Accessing Minimum Technical Requirements (Certifications)" to verify if any such JD Edwards EnterpriseOne Release 9.1 Installation fixes are required.

5.3 Reviewing Installation Planner Processing Options

Processing options control how Installation Planner responds as you set up plans and options you see as you work through the custom planner. If processing options are not set up correctly, you will not see the appropriate options as you work through the planner. You set up these processing options to control replication functions and business functions mapping.

You should review the default processing options for the Installation Planner application prerequisite to create the plan. First-time users can set up the processing options to step through the planner with informational messages. If you do not want to see these messages, you can turn them off.

5.3.1 Assumptions About Reviewing Installation Planner Processing Options

This table lists the assumptions about reviewing the processing options for the installation planner.

Personnel Installer
Logon Status On the Deployment Server, logged on as user JDE with the database password for user JDE, in the Planner environment.
Prerequisites The Deployment Server must be installed.
Concurrent Tasks The Platform Pack installer can be running.

5.3.2 Accessing Processing Options

To access processing options, you must first log on to Release 9.1 and specify your installation plan type.

  1. Log on to Release 9.1 as user JDE with the database password for user JDE.

  2. Access the planner environment (JDEPLAN).

  3. From the System Installation Tools menu (GH961), right-click either Typical Installation Plan or Custom Installation Plan.

  4. Choose Prompt for Values.

    The Processing Options form appears.

5.3.3 Choosing Processing Option Values

Once you have accessed processing options, perform the following tasks to choose the processing option values:

5.3.3.1 Specifying the Prompt Mode

To specify the prompt mode:

  1. Select the Prompt Mode tab.

    Surrounding text describes proc_opts_prompt_mode.gif.
  2. On the Prompt Mode tab, select a prompt mode:

    Value Model Description
    0 Silent Installation Planner displays only the data entry forms.
    1 Additions Prompt Installation Planner prompts you to add servers.
    2 Verbose Installation Planner directs you through creating a plan with a series of prompting forms.

5.3.3.2 Specifying the Process Mode

To specify the process mode:

  1. Select the Process Mode tab.

    Surrounding text describes proc_opts_process_mode.gif.
  2. On the Process Mode tab, select the options for the processes that you want to run when you create your plan:

    • Additional Servers

      Enter 1 to add servers to your existing setup (Deployment Server, Enterprise Server, Database Server, HTML Web Server). Enter 0 or leave blank for regular plans.

      Caution: You should only change this value when running a Server Plan.

    • Installation

      Enter 1 to run the JD Edwards EnterpriseOne installation automatically.

5.3.3.3 Specifying the Default Mode

To specify the default mode:

  1. Select the Default Mode tab.

    Surrounding text describes proc_opts_default_mode.gif.
  2. On the Default Mode tab, enter these values into the processing option fields:

    Value Description
    0 Do not use default values and do not prompt.
    1 Prompt for default options at run-time.
    2 Default mode. Always use defaults without prompting.

    • Default Data Source Information

      Select whether you want the ability to modify data source information or just take the default values.

    • Default Environments

      Select whether you want the ability to select environments or take the default values.

    • Default Data Load

      Select whether you want the ability to modify data load parameters or take the default values.

    • Default Advanced Parameters

      Select whether you want the ability to modify advanced parameters or take the default values.

    • Default Languages

      Select whether you want the ability to select an alternate language or take the default values.

    • Upgrade/Update Plan Generation

      Select whether you want the ability to generate a plan automatically from locations and machines defined in a previous version of the software.

5.3.3.4 Verifying Status Change Values Have Not Changed

On the Status Change tab, this tab form appears.

Note:

Do not make any changes on this tab. These values are hard coded in the application
Surrounding text describes proc_opts_status_change.gif.

5.3.3.5 Specifying Plan Completion Processes

To specify plan completion processes:

  1. Select the Completion tab.

    Surrounding text describes proc_opts_completion.gif.
  2. On the Completion tab, complete the fields using these values:

    After defining the plan, the options on this tab specify which processes are run. one of the following values:

    Value Description
    0 Do not run automatically.
    1 Prompt to be run.
    2 Run automatically.

    • Finalize Plan

      Enter the default option 2 to run automatically.

    • Validate Plan

      Enter the default option 2 to run automatically.

5.3.3.6 Specifying Replication Options

To specify replication options:

  1. Select the Replication tab.

    Surrounding text describes proc_opts_replication.gif.
  2. On the Replication tab, complete the fields using these values:

    Value Description
    0 Do not use and do not prompt.
    1 Prompt for option at run-time.
    2 Always use without prompting .

    • Replicate System Tables

      Select whether you have the option to replicate system tables automatically for remote locations.

    • Replicate Data Dictionary Tables

      Select whether you have the option to replicate data dictionary tables automatically for remote locations.

    • Replicate Control Tables

      Select whether you have the option to replicate control tables, menus, and user defined codes automatically for remote locations.

    • Replicate Constant Tables

      Select whether you have the option to replicate constant tables automatically for remote locations. Business data tables are Object Librarian type 280.

    • Replicate Master Tables

      Select whether you have the option to replicate master tables automatically for remote locations. Business data tables are Object Librarian type 210 and 211.

5.4 Running the Installation Planner for an Upgrade

This section consists of the following tasks:

5.4.1 Starting Installation Planner

To start Installation Planner from within JD Edwards EnterpriseOne:

  1. Go to the System Installation Tools Menu (GH961).

  2. From the System Installation Tools menu, double-click Custom Installation Plan.

  3. On Work with Installation Plans, click Add.

    The Installation Planner form appears. Enter a Plan description.

5.4.2 Entering a Plan Description

To enter a plan description:

Surrounding text describes inst_plan_upgrade_custom.gif.
  1. On Installation Planner, complete the following fields:

    Field Description
    Name Enter the name of your plan.
    Description Enter the description of your plan.
    Status Select 10. This is the default value.
    Install Type Select Upgrade.

    If the Installation Planner detects registry settings indicating a previous installation of JD Edwards EnterpriseOne has been installed on this Deployment Server, it automatically changes the Install Type to Upgrade. You can also manually change the Install Type to Upgrade.

    If the previous installation of the Deployment Server is on a different machine, or if this installation is on a remote Deployment Server, the Install Type will be set to Install. In either of these cases, you must manually change the Install Type to Upgrade and the Installation Planner will prompt you for the data source information in a subsequent screen.

    From Release Enter the number of the release you are upgrading from.

    For example, enter E910 for Release 9.1.

    To Release Verify that the release number is E910 (the default value).
    Table Conversion Properties Check box to run table conversions on the Deployment Server. The default is to run on the Enterprise Server.
    Tracing Turns on debug logging.
    Include Languages This is an optional selection that is only available if you have previously specified this Custom plan to install languages. Select yes if you are installing an alternate language.

  2. Click OK.

    Note:

    If you are installing the Deployment Server on the same machine as a previous release, and the Installation Planner has detected that previous release, you can proceed to the next step.

    However, if you manually changed the Install Type to Upgrade, most likely because the previous release of JD Edwards EnterpriseOne was installed on a different machine, or this installation is on a remote, Deployment Server, you will be presented with the following screen in which you must enter the data source information that will enable the Installation Planner to locate the previous release.

    Surrounding text describes ds_revs_diff_mach_udb_unix.gif.

    On Data Source Revisions, complete the following fields:

    Field Description
    Data Source Name Enter the name of the System data source to be upgraded. For example:

    System - 910

    Data Source Use You can accept the default value of DB.
    Data Source Type Choose the type of data source. Valid value is:

    W - DB2 UDB

    Platform Enter your platform. For example, LINUX.
    Database Server Name Enter the name of your database server on which your previous System data source resides.
     
     
     
     
     
     
    Schema Enter the name of the schema.
    Database Alias Name Enter the name of the database alias.
    ODBC Data Source Name Enter the ODBC data source name.
     
     

  3. Click OK.

    Surrounding text describes previous_jde_configuration.gif.
  4. This form imports information from your previous system data source. The previous system data source you are upgrading from should be prepopulated. Use the Data Sources form exit to verify the data source is set up correctly.

  5. If this is correct, click OK and proceed to step 9. For more control over the process, click the Advanced form exit and continue with the next step. This screen sets up to copy information from the previous system data source into planner while providing some default information for the user. It is also used for spec merge and table conversions to provide access to the previous environments.

    Surrounding text describes custom_prev_config_advanc.gif.

    Note:

    The Release Master checkbox may not be selected, but the release master has already been copied at this point in the process.
  6. Select the objects to be copied from the previous release, then specify the data source where each of the objects reside.

  7. Select the appropriate radio button for your data load:

    Radio Button Description
    Append Adds records to your existing tables. This is the typical selection.
    Replace Clears existing tables prior to loading new data.

  8. Click OK.

  9. Select one of the following options:

    Surrounding text describes plan_generation_dialog.gif.

    Note:

    The above screen may not always appear for upgrades, which is preferable because the recommended method is to step through the planner rather than taking defaults. See "Caution When Choosing Take Defaults" below.
    • From this form, you have the option to automatically enter the locations and machines into the plan that you defined in the previous version of the software.

  10. Choose a method for generating your plan:

    • To manually create your plan, click OK and continue with Section 5.4.3, "Entering Location Information".

    • To enable the system to automatically enter the locations and machines from the previous version, click Take Defaults.

      The machines that were imported from the previous system data source are entered into the current plan. Skip the sections on entering locations, Deployment Servers, Enterprise Servers, and machines or servers, and continue with Section 5.4.9, "Entering Shared Data Source Information".


      Caution When Choosing Take Defaults

      In order to ensure the validity of all subsequent plan information, it is strongly recommended that even advanced users should not choose this Take Defaults option. Instead, you should step through plan and verify that the Planner is populating information exactly as you expect to match your requirements.:

    • To exit the plan, click Cancel.

5.4.3 Entering Location Information

A location groups related Deployment Servers for use in a multi-tier environment.

To enter location information:

Surrounding text describes location_revs_typical.gif.
  1. On Location Revisions, complete these fields:

    Field Description
    Location Enter the location to which this plan applies; the location can be a city, company headquarters, or a division of the company.
    Description Enter a description for this location.
    Location Code If this is the base location, this field is only available when you are adding the base location. If you are editing an existing base location, the field is unavailable.
    Parent Location If this is the base location, this field is only available when you are adding the base location. If you are editing an existing base location, the field is unavailable.

  2. Click OK.

5.4.4 Entering Deployment Server Information

Once a plan location is specified, specify the information for the primary Deployment Server you will use in this plan. While Release 9.1 enables more than one Deployment Server to be defined, only the primary Deployment Server is defined at this time. You can choose a primary Deployment Server from the list of existing servers or you can enter information for a new server.

Note:

If you installed JD EnterpriseOne Files to a remote Deployment Server, you should click the OK button to define a new Deployment Server. The deployment server name is the remote machine name by default.
Surrounding text describes selectdepsvr.gif.
  1. On Deployment Server, click OK to define a new Deployment Server, or click Select to choose from a list of existing Deployment Servers.

    Surrounding text describes selectdepsvr_existing.gif.

    If you choose Select, you are presented with the Machine Search table, from which you can make your selection.

    Surrounding text describes deployment_server_revs_1.gif.
  2. On Deployment Server Revisions, complete or verify these fields:

    Field Description
    Machine Usage Displays the value 15 by default to indicate that this is a Deployment Server.
    Machine Name Displays the name of the Deployment Server appears by default. The name is case sensitive, should not exceed 15 characters, and should not contain any special characters.

    Remote Deployment Server. If you installed JD EnterpriseOne Files to a remote Deployment Server, you should click the OK button to define a new Deployment Server. The deployment server name is the remote machine name by default.

    Description Enter a long description for the machine. This description should include the location with which this Deployment Server is associated and whether or not it is the primary server.
    Release Enter the Release 9.1 release number you are installing or use the visual assist button to choose one from the list. The default value is E910.
    Host Type Displays the value of 50 appears by default to indicate that the server type is Intel NT.
    Location Displays your current location as the default value.
    Primary User Specify the user to whom an email is sent when a package is deployed. The default value for Primary User is jde910.

    This is also the UNIX user ID that is used to install Release 9.1 on the Enterprise Server. For example, jde910.


  3. On the Deployment tab, complete these fields:

    Field Description
    Primary Deployment Server Define the hierarchy of the servers. Values are:

    1- Primary Deployment Server (default value)

    0 - Secondary Deployment Server

    The server share name of the directory to which you installed Release 9.1 on your Deployment Server. Verify that the server share name for Release 9.1 is \E910.


  4. Click OK.

    Tip:

    If you enter invalid information into a tab field, a stop sign symbol appears next to the tab name, such as Deployment Server. For more information about the error, click the stop sign icon in the bottom right-hand corner of the form.

    Release 9.1 asks if you want to add another Deployment Server.

  5. To add another Deployment Server, click Yes and repeat steps 1 through 3.

  6. To continue with Installation Planner setup, click No.

5.4.5 Entering Enterprise Server Information

Note:

During the definition of the Enterprise Server, a port number must be defined. While Enterprise Servers running the same release can use the same port number, an Enterprise Server running two different versions of software must use two different port numbers.

To enter Enterprise Server information:

Surrounding text describes selectentsvr.gif.
  1. On Enterprise Server, click OK to define a new Enterprise Server, or click Select to choose from a list of existing Enterprise Servers.

    Surrounding text describes selectentsvr_existing.gif.

    If you choose Select, you are presented with the Machine Search table, from which you can make your selection.

    Surrounding text describes ent_revs_unix_udb.gif.
  2. On Enterprise Server Revisions, verify or complete these fields:

    Field Description
    Machine Name The name of the primary Enterprise Server. The name is case sensitive and should not contain any special characters.

    Because the machine name is used to create the Server Map datasource name, and because the Platform Pack Installer does not restrict you from entering a machine name that results in a datasource name greater than 30 characters; if the machine name for the Enterprise Server is longer than 13 characters, the resulting datasource name will be longer than the allowed 30 characters. For example, if your machine name is 15 characters (A23456789012345), the base datasource name input into the Planner would be: A23456789012345 - 910 Server Map.

    Note: The field in table F98611 is a hard restriction; the field only allows 30 characters. The actual field size cannot be modified or changed.

    When the Planner runs it truncates the value to 30 characters because that is the restriction in the F98611 table. The Platform Pack does not truncate the value when it builds the jde.ini for the Enterprise Server. Therefore, any value greater than 30 characters will result in a mismatch between the jde.ini and the F98611 table. That is, using the previous example, the jde.ini would have the full length value A23456789012345 - 910 Server Map (which is 32 characters) while the F98611 populated by the Planner would have a value of A23456789012345 - 910 Server M.

    To remedy, you could do any one of the following:

    • Manually modify values in table F98611 to match the truncated value in the jde.ini file.

    • Ensure that the value is not truncated by limiting the datasource name to 30 characters (this would mean limiting the machine name for the Enterprise Server to 13 characters).

    • Manually truncate the value in the F98611 table (for example, A23456789012345 - 910 Svr Map.

    In any case, you must ensure that the values for Server Map datasource names in the F98611 table exactly match those in the jde.ini file on the Enterprise Server.

    This name is not case-sensitive in the Installation Planner. Therefore, regardless of underlying UNIX operating system considerations, you cannot name multiple Enterprise Servers with the same name but with different cases. For example, you cannot name multiple Enterprise Servers ORACLE and oracle.

    Description Enter a description for the machine.
    Release Enter the Release 9.1 release number to which this plan applies, or use the visual assist button to choose one from the list. The default value is E910.
    Host Type Click the visual assist button and select the type of Enterprise Server you are adding to the plan. In this case, a specific UNIX server as listed by the valid Host Type values:
    • 25 — Sun Solaris

    • 30 — RS\6000

    • 35 — Linux

    Location Displays the location chosen for this plan by default.
    Primary User Specify the user to whom an email is sent when a package is deployed. The default value for Primary User is jde910.

    This is also the UNIX user ID that is used to install Release 9.1 on the Enterprise Server. For example, jde910.


    Note:

    The case of machine name must also match the network ID for that machine.

    Caution:

    If you are using clustering with DB2 UDB database servers, use the DB2 UDB Cluster Instance as the machine name when installing Release 9.1, not one of the servers' machine names.

    For information on supported clustering environments, see Release 9.1 on a Cluster in JD Edwards EnterpriseOne Tools Server and Workstation Administration Guide and the clustering vendor's software documentation.

  3. On Enterprise Server Revisions, select the Enterprise tab and complete or verify these fields:

    Field Description
    Port Number The port number value (6016) for this Enterprise Server as supplied from the JDE.INI.
    Logical Machine Name Displays this information by default when the host type is entered. The name is case sensitive, should not exceed 15 characters, and should not contain any special characters.
    Database Type Enter the value for your database:

    W - DB2 UDB

    Server Map Data Source Whenever you enter a host type, the Installation Planner populates this field with a default value:

    machinename - 910 Server Map

    where machinename is the name of your machine.

    Installation Path Verify that the default value is the installation directory path to which you want to install Release 9.1 on the Enterprise Server. Make sure the value is specific to your version of the release. For example, for Release 9.1 the default path is:

    /JDEdwardsPPack/E910

    You might need to prepend the mount point to the path. For example:

    u01/JDEdwardsPPack/E910

    Caution: You must change the value that defaults into the Installation Path field as shown in the screen capture above.

    Deployment Server Name Using the visual assist button, choose the name of the Deployment Server to which this Enterprise Server is attached. A Deployment Server name appears in this field by default, but it can be changed if necessary.

    Note:

    If you change the port number to a value other than 6016, you must also change this setting to be synchronous between both the JDE.INI on the Enterprise Server and workstation.
  4. Click OK.

5.4.6 Enter Data Source Information for Server Map

To enter data source information for Server Map:

Surrounding text describes data_source_machine_name.gif.
  1. On Data Source, you are prompted to enter Data Source Information for the Enterprise Server.

    Choose one of these options:

    • Click OK to continue entering unique data source information. If you choose this option, continue with this task.

    • Click Take Defaults to select the default data. If you choose this option, you can skip to Section 5.4.2, "Caution When Choosing Take Defaults"

      Caution:

      In order to ensure the validity of all subsequent plan information, it is strongly recommended that even advanced users should not choose this Take Defaults option. Instead, you should step through plan and verify that the Planner is populating information exactly as you expect to match your requirements.
    Surrounding text describes data_srce_svr_map_unix_udb.gif.
  2. On Data Source Revisions

    On Data Source Revisions, verify the accuracy of the Server Map data source.

  3. Click OK.

5.4.7 Entering HTML Web Server Information

Note:

For Release 9.1 the current terminology and that used in this guide is to refer to the machine running the JD Edwards EnterpriseOne Java Application Server (JAS) as the HTML Web Server. Functionally, these terms are all synonymous. However, this guide only uses the terms JAS or Java Server when explicitly labeled as such by the software.

Caution:

The HTML Web Server is mandatory for the majority of JD Edwards EnterpriseOne applications because the end-user applications are only accessible through a web interface.

To enter HTML Web Server information:

Surrounding text describes enter_html_server_dialog.gif.
  1. On the HTML Application Server dialog, click OK to continue entering HTML Web Server information, or click Select to select an existing HTML Web Server.

    Surrounding text describes html_svr_unix_hosttype_typ.gif.
  2. On HTML Server Revisions, complete these fields:

    Field Description
    Machine Usage The default value of 30 indicates that this is a HTML Web Server.
    Machine Name Enter the name of your HTML Web Server. The name is case sensitive, should not exceed 15 characters, and should not contain any special characters.

    This name is not case-sensitive in the Installation Planner. Therefore, regardless of underlying UNIX operating system considerations, you cannot name multiple HTML Web Servers with the same name but with different cases. For example, you cannot name multiple HTML Web Servers ORACLE and oracle.

    Description Enter a description of the HTML Web Server machine.
    Release Enter E910 to indicate the release number that you are installing.
    Host Type The default value of 50 specifies the server type as Intel NT. Select the correct server type.
    Location The location chosen for this plan appears in this field by default.
    Primary User The user to whom an email is sent when a package is deployed. The default for Primary User is listed in the JDE.INI.

    This is also the UNIX user ID that is used to install Release 9.1 on the Enterprise Server. For example, jde910.


  3. On the HTML tab, complete these fields:

    Field Description
    Primary HTML Server When the system code generates an email message with a web shortcut pointing to a form, the web shortcut generated points to the "Primary" HTML Web Server. Only one of all the HTML Web Servers defined in installation planner can be defined as primary ("1").
    Protocol This is the protocol used by the HTML Web Server. Valid values are http or https.
    Server URL This is the Domain Name System (DNS) host name of the HTML Web Server.

    For example: www.oracle.com

    HTTP Port This is the port number the HTML Web Server is listening to.

    For HTTP, the typical port number is 80.

    For HTTPS, the typical port number is 443.

    Note: You can choose to implement a HTML Web Server using a different port number.

    JDENET Listen Port This is the port on which the JDENET communications protocol communicates with the JD Edwards EnterpriseOne Enterprise Server. The value is dependent on the release of JD Edwards EnterpriseOne.

    For JD Edwards EnterpriseOne Release 9.1, the value is 6016.

    Default Login Defines how shortcuts to a web form are generated by the system code. Values are either a reserved value or an explicit servlet name. Reserved values are:
    • Standard

      The URL generated will point to a servlet on the Primary HTML Web Server.

    • Redirector

      The URL generated will point to redirector in the Primary HTML Web Server, and redirector will point to a servlet on another HTML Web Server for load balancing. The servlet name to use is generated by the system.

    • Explicit Servlet Name

      The user can specify an explicit servlet name in this field. In this case, the redirector functionality cannot be used. The URL generated will point to the specified servlet in the Primary HTML Web Server.

      Usage of Explicit servlet name is for backward compatibility only. You should not use it unless you have a direct need.

    Installation Path Enter the installation directory path to which you are installing Release 9.1 on your HTML Web Server. Make sure this is specific to your version of the release, and also the platform and application server on which your HTML Web Server is running.

    For default paths, refer to the applicable platform- and application server-dependent version of the JD Edwards EnterpriseOne HTML Web Server Reference Guide (WebLogic for Windows, WebLogic for UNIX, WebSphere for Windows, WebSphere for UNIX, WebSphere for IBM i. Otherwise, you must obtain this value from the HTML Web Server machine itself, or its administrator.


  4. Click OK.

  5. To add another HTML Web Server, click Yes and repeat steps 1 through 4 to define another HTML Web Server.

5.4.8 Entering Data Server Information

Surrounding text describes add_data_server_dialog.gif.
  1. On Data Server, choose one of these options:

    • OK

      If your database resides on a separate server, choose click OK to continue entering unique Data Server information.

    • Select

      Click this option to select an existing Data Server.

    • Skip

      Click this option if you do not want to define a Data Server. Continue with the Planner using the environment selection in step 6 of this task.

    Surrounding text describes data_server_unix_udb.gif.
  2. On Data Server Revisions, complete these fields:

    Field Description
    Machine Usage The default value of 25 indicates that this is a Database Server.
    Machine Name Enter the name of your Database Server. The name is case sensitive, should not exceed 15 characters, and should not contain any special characters.

    This name is not case-sensitive in the Installation Planner. Therefore, regardless of underlying UNIX operating system considerations, you cannot name multiple Database Servers with the same name but with different cases. For example, you cannot name multiple Database Servers ORACLE and oracle.

    Description Enter a description of the Database Server machine.
    Release Enter the release number you are installing, for example, E910.
    Host Type Select the type of Database Server that you are adding to the plan. Values are:
    • 10 — IBM i

    • 25 — Sun Solaris

    • 30 — RS\6000

    • 35 — Linux

    • 50 — Microsoft Windows (Intel)

    • 80— Client - Microsoft Windows

    • 90 — Client - Microsoft Windows

    Location The Installation Planner populates this field by default, based on previous selections.
    Primary User The user to whom an email is sent once a package is deployed. The default for Primary User is jde910.

    This is also the UNIX user ID that is used to install Release 9.1 on the Enterprise Server. For example, jde910.


  3. On the Data tab, complete the following field:

    Field Description
    Data Source Type Choose the type of data source. For example:
    • W - DB2 UDB


  4. Click OK.

  5. To add another Data Server, click Yes and repeat steps 1 through 4 to define another Data Server.

  6. On Data Source, click OK to continue entering unique shared data source information, or click Take Defaults to select the default data for the shared data sources.

  7. On Location, select Yes to add another location, or click No to continue with Installation Planner.

5.4.9 Entering Shared Data Source Information

To enter or confirm information for data sources that are shared across all of your environments, complete the following tasks:

5.4.9.1 Specifying (Custom or Default) Shared Data Source setup information

Release 9.1 prompts you for the data source information for the shared data sources. Choose one of the following options:

  • To use the Release 9.1 data sources, click Take Defaults.

    Continue with Section 5.4.10, "Setting Up Environments".

    Note:

    This option limits your customization choices.
  • Click OK to enter the data sources. Verify the data source information.

5.4.9.2 Verifying the Data Source for Data Dictionary

To verify the data source for Data Dictionary:

Surrounding text describes data_source_ddict_unix_udb.gif.
  1. On Data Source Revisions, verify the accuracy of the settings for the Data Dictionary data source.

  2. Click OK.

5.4.9.3 Verifying the Object Librarian Data Source

To verify the Object Librarian data source:

Surrounding text describes data_source_ol_unix_udb.gif.
  1. On Data Source Revisions, verify the accuracy of the settings for the Object Librarian data source.

  2. Click OK.

5.4.9.4 Verifying the System Data Source

To verify the System data source:

Surrounding text describes data_source_system_unix_udb.gif.
  1. On Data Source Setup, verify the accuracy of the settings for the System data source.

  2. Click OK.

    The Environment Selection screen appears.

5.4.10 Setting Up Environments

By default, Release 9.1 configures your system using values for typical environments. Depending on the options chosen when you set up your plan, Release 9.1 displays one or more of the following parameters, which you can customize in the following tasks:

  • Environments

  • Data Load Options

  • Advanced Parameters

  • Languages

You can customize any of these parameters by turning off the default option on the Environment Selection form. As you move through the plan, Release 9.1 will display a customization form for each parameter that you turn off.

Surrounding text describes environment_select_up.gif.
  1. On Environment Selection, turn off the options for those parameters that you want to customize.

    Note:

    The parameters that display might vary depending on which options you chose at the beginning of the planning process.
  2. Click OK.

    Note:

    If you checked the default option for all parameters, skip to Section 5.4.11, "Setting Up Environment Data Sources".

    Use the following tasks to customize each of the parameters listed above. Release 9.1 displays customization forms only for those parameters for which were turned off the default options. Skip the tasks for those parameters that were left turned on.

  3. Continue with the following relevant tasks:

5.4.10.1 Selecting an Environment

The Select Environment form appears.

Note:

Environments prefixed with Jxx are required for the HTML Web Server.
Surrounding text describes select_environments.gif.
  1. On Select Environments, double-click the environment that you want to define.

  2. To set up multiple environments, choose and define them one at a time. Release 9.1 returns to this screen after the following tasks are completed.

  3. Click the Close button to exit the Select Environments screen.

5.4.10.2 Specifying Environment Data Load Parameters

If you turned off Default Data Load on the Environment Selection form, the Data Load Parameters form appears.

To specify environment data load parameters:

Surrounding text describes data_load_parameters.gif.

5.4.10.3 Verifying Advanced Parameters

If you turned off Default Advanced Parameters on the Environment selection form, the Advanced Parameters form appears.

To verify advanced parameters:

Surrounding text describes custom_advanced_parameters.gif.
  1. On Advanced Parameters, complete the following fields and turn on the following options:

    Field Description
    Logic Data Source The server data source where the table conversions will run
    Table Conversion Throttle The number of table conversions to be run concurrently on the server

    Note:

    The Table Conversion Workbench checks the maximum jobs for the default job queue for the logic server. It will only submit up to the number of maximum jobs on the queue to run at once. If the throttle is set higher than the queue, it uses the queue maximum number of jobs. If the queue is set higher than the throttle, it uses the throttle.
  2. Click OK.

    If you turned off Default Languages on the Select Environments selection form, continue with Section 5.4.10.4, "Selecting Languages (optional)".

5.4.10.4 Selecting Languages (optional)

To select languages:

Surrounding text describes language_select.gif.
  1. On Language Selection, to set up a language for the selected environment, choose the appropriate language.

  2. From the Row menu, click Select.

  3. Repeat the above steps until all your languages have been selected.

  4. Click OK.

    Note:

    Customization Considerations. If you have customizations that you do not want to merge, you can prevent individual conversions and merges from running by changing their status or deleting the appropriate records from the plan before you run the Installation Workbench.

5.4.11 Setting Up Environment Data Sources

Once the Environments have been set up, it is necessary to set up the Data Sources for those Environments. If you created a custom environment, data source information is generated from the data source template provided by JD Edwards EnterpriseOne.

See Also

To modify this template, refer to the JD Edwards EnterpriseOne Configurable Network Computing Implementation Guide.

5.4.11.1 Selecting an Environment Data Source Setup Option

On the Installation Planner prompt that enables you to set up data sources for the environment you just configured:

  • Click OK to manually enter the data sources as described in the remaining tasks in this section.

  • Click Take Defaults to accept the Release 9.1 default data sources.

5.4.11.2 Setting Up the Data Source for Business Data

To set up the Business Data data source:

Surrounding text describes ds_revs_bus_data_unix_udb.gif.
  1. From the Form menu, click Advanced.

    Surrounding text describes custom_plan_adv_parms_typ.png.
  2. On Advanced Parameters, verify the UNICODE flag is off. If your Business Data was not set to Unicode in a previous release and the data source had not yet been converted to Unicode, the Unicode flag must match the contents of the data source.

  3. Click OK.

  4. On Data Source Revisions, verify the data source for your Business Data.

    Be sure this data source points either to the existing production data source you want to upgrade or to a copy of it.

    Note:

    Business Data data sources are specific to the environment and pathcode.
  5. Click OK.

5.4.11.3 Setting Up the Data Source for Central Objects

To set up the Central Objects data source:

Surrounding text describes dsrce_central_objs_unix_udb.gif.
  1. On Data Source Setup, verify the information for your Central Objects data source.

  2. Click OK.

    Verify that your Central Objects data source is Central Objects - <Path Code>.

    Note:

    Central Objects data sources are specific to the pathcode.
    Surrounding text describes advanced_setup.gif.
  3. On Advanced Set-Up, because the central objects data source must be Unicode, verify the Unicode setting is checked.

5.4.11.4 Setting Up the Data Source for Control Tables

To set up the Control Tables data source:

Surrounding text describes dsource_ctrl_tabs_unix_udb.gif.
  1. On Data Source Revisions, verify the accuracy of the Control Tables data source.

    Field Description
    Data Source Name Verify the name of the data source.
    Server Name Verify the name of the Enterprise Server.
    Object Owner ID Enter the name of the owner of this object
     
     

    Note:

    Control Tables data sources are specific to the environment and pathcode.
  2. Click Advanced and verify that UNICODE is off only if the Control Tables are not set to Unicode in a previous release.

    Note:

    If you upgrade from Release 8.9 the Unicode flag is on.
  3. Click OK.

5.4.11.5 Verifying the Data Dictionary Data Source

To verify the Data Dictionary data source:

Surrounding text describes data_source_ddict_unix_udb.gif.
  1. On Data Source Setup, verify the accuracy of the Data Dictionary data source.

  2. Click OK.

5.4.11.6 Verifying the Data Source for Versions

To verify the Versions data source:

Surrounding text describes dsource_versions_unix_udb.gif.
  1. On Data Source Revisions, verify the accuracy of the Versions data source.

  2. Click OK.

    Note:

    Versions data sources are specific to the pathcode, and the Unicode flag on the Advanced Form must be checked.

5.4.12 Adding a Remote Location

To add remote location:

Surrounding text describes add_another_location.gif.

Release 9.1 asks if you want to add another (remote) location.

  1. On Location, choose one of the following options:

    • Click Yes to add a remote location.

    Repeat all processes for adding a location starting with Section 5.4.3, "Entering Location Information". Refer to the Creating a Remote Installation Plan task in the Installation Planner Utilities section for information about adding remote locations to your plan.

    • Click No to conclude the Installation Plan setup.

  2. Continue with Section 5.4.13, "Finalizing the Installation Plan" task.

5.4.13 Finalizing the Installation Plan

To finish the Installation Plan.

  1. A message appears to let you know that the installation plan has been finalized.

    When the plan is finalized:

    • The status is set to 20, which signals that several adjustments to tables were made according to your plan.

    • Create the OCM.

    • Modify the ini file.

    • The following tables are upgraded:

      Release Master table (F00945)

      Path Code Master table (F00942)

      Package Plan table (F98404)

      Machine Detail table (F9651)

      Language table (F984031), if you are installing an alternate language.

  2. Click OK to exit the concluding message box and initiate the Planner Validation Report.

    • If processing option default was chosen, Planner Validation Report automatically prompts you to run this report.

    • If processing option default was not chosen, on the tree view of your plan, click Validate to initiate the Planner Validation Report.

5.4.14 Concluding the Validation Planner Report

To conclude the validation planner report:

  1. On Report Output Destination, choose On Screen or To Printer, and click OK.

  2. Review the report to confirm that all records were validated.

  3. After reviewing the report, on the Batch Versions form, click Close.

    For more information about Section 25.1, "Installation Planner Validation Report (R9840B)", refer to Chapter 25, "Working with Reports".

  4. On Work with Installation Plans, click Expand to review the plan you created.

See Also

5.5 Deleting Machines from an Installation Plan

As you work through the Installation Planner application, you might find that you need to delete a server or machine that you have created. You can use Installation Planner to delete machines as needed; however, doing so can affect related databases, shared Enterprise Servers and Deployment Servers, and associated records.

To delete machines from an installation plan:

  1. In the Release 9.1 planner environment, enter P9654A in the Fast Path field and press Enter.

  2. On Work With Locations and Machines, click Find.

  3. Expand the location.

    A list of your locations, machines, or servers appears for the base location in the tree view.

  4. Select the location, machine, or server that you want to delete.

  5. Click Delete.

  6. To close the application, click Close.

5.6 Verify and Configure Data Source for Previous Release

Note:

This section is only applicable if you installed your E910 deployment server a different machine (as the previous release). If you install the E910 Deployment Server on the same machine (as the previous release), the Installation Planner automatically detects the local System data source and uses it to configure the upgrade.

Before you run the Installation Planner for an upgrade, you must ensure that you have a data source properly configured on the E910 Deployment Server so this machine can access system tables for the previous release residing on a different machine. This is because the installation planner must import information from previous system data source in order to recognize and upgrade your existing environment.

If the Installation Planner cannot detect the System data source on this machine and it is an upgrade plan, it displays this screen prompting you to enter the information about the previous System data source.

Surrounding text describes data_source_revs.gif.
  1. On Custom Installation Plan, Data Source Revisions, select the appropriate tab for your previous database and complete the fields to match your previous data source.

    For example, if your previous data source was Oracle, your previous platform was Linux, and your previous EnterpriseOne applications release was 9.0, a properly completed form would look like this:

    Surrounding text describes data_source_revs_example.gif.
  2. Click the OK button to verify your data source connection information to the System data source on the remote machine.