|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 11.1 Information Library|
- publish or unpublish multiple shares
shareall [-F FSType [,FSType]...] [-| file]
unshareall [-F FSType [,FSType]...]
When used with no arguments, shareall publishes shares from a specified file that contains a list of share command lines. If the operand is a hyphen (-), then the share command lines are obtained from standard input. Otherwise, if neither a file nor a hyphen is specified, then shares are published from the SMF shares repository.
Shares can be specified by identifying the file system type in a comma-separated list as an argument to -F.
The unshareall command unpublishes all published file system shares. Without an -F flag, it unpublishes all distributed file system shares.
Specify file system type. Defaults to the first entry in /etc/dfs/fstypes.
See attributes(5) for descriptions of the following attributes: