|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 10 1/13 Information Library|
- update the home directory copy and link files for the current label
updatehome reads the user's minimum-label copy and link-control files (.copy_files and .link_files). These files contain a list of files to be copied and symbolically linked from the user's minimum-label home directory to the user's home directory at the current label.
The Solaris Trusted Extensions dtsession program performs an updatehome whenever a newly labeled workspace is created so that the user's favorite files are available for use. For example, the user probably wants a symbolic link to such files as .profile, .login, .cshrc, .exrc, .mailrc, and ~/bin. The updatehome command provides a convenient mechanism for accomplishing this symlink. The user can add files to those to be copied (.copy_files) and to those to be symbolically linked (.link_files).
Replace existing home-directory copies at the current label. The default is to skip over existing copies.
Ignore errors encountered. The default aborts on error.
Replace existing home-directory copies or symbolic links at the current label. This option implies options -c and -s. The default is to skip over existing copies or symbolic links.
Replace existing home-directory symbolic links at the current label. The default is to skip over existing symbolic links.
Upon success, updatehome returns 0. Upon failure, updatehome returns 1 and writes diagnostic messages to standard error.
Example 1 A Sample .copy_files File
The files that are listed in .copy_files can be modified at every user's label.
.cshrc .mailrc .mozilla/bookmarks.html
Example 2 A Sample .link_files File
The files that are listed in .link_files can be modified at the lowest label. The changes propagate to the other labels that are available to the user.
~/bin .mozilla/preferences .xrc .rhosts
Example 3 Updating the Linked and Copied Files
The .copy_files and .link_files were updated by the user at the minimum label. At a higher label, the user refreshes the copies and the links. No privileges are required to run the command.
% updatehome -r
List of files to be copied
List of files to be symbolically linked
See attributes(5) for descriptions of the following attributes:
The functionality described on this manual page is available only if the system is configured with Trusted Extensions.