|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 10 1/13 Information Library|
- Volume Management daemon to manage removable media devices
/usr/sbin/vold [-n] [-t] [-v] [-f config-file] [-l log-file] [-d root-dir] [-L debug-level]
The Volume Management daemon, vold, creates and maintains a file system image rooted at root-dir that contains symbolic names for removable media devices. These devices include CD-R, CD-RW, floppies, DVD, and USB and 1394 mass storage devices. The default root-dir is set to /vol if no directory is specified by the -d option.
vold reads the /etc/vold.conf configuration file upon startup. If the configuration file is modified later, vold must be told to reread the /etc/vold.conf file. Accomplish this rereading by entering:
example# svcadm refresh volfs
To tell vold to clean up and exit, enter:
example# svcadm disable volfs
example# svcadm enable volfs
To specify options (see OPTIONS):
example# svccfg svc:> select volfs svc:/system/filesystem/volfs> listprop vold/* vold/config_file astring vold/log_debuglevel count 0 vold/log_file astring vold/log_nfs_trace boolean false vold/log_verbose boolean false vold/never_writeback_label boolean false vold/root_dir astring svc:/system/filesystem/volfs> setprop vold/never_writeback_label=true svc:/system/filesystem/volfs> exit # svcadm disable volfs # svcadm enable volfs
vold is hotplug-aware for USB and 1394 mass storage devices, thus there is no need for stopping and restarting vold. It is recommended to eject(1) the “media” before hot-removing a device. The eject command unmounts any filesystems mounted from the media, making it safe to remove the device. (Note that all USB and 1394 devices, regardless of whether they contain removable media, are treated like removable media devices).
The following options are supported:
Never writeback. Volume Management updates media labels with unique information if labels are not unique. This flag keeps Volume Management from changing your media. The default setting is FALSE.
Dump NFS trace information to the log file. The default setting is FALSE.
Provide lots of status information to the log file. The default setting is FALSE (do not provide status info to log file).
Specify an alternate root directory. The default location is /vol. Setting this will also cause other Volume Management utilities to use this as the default root directory.
Specify an alternate configuration file. The default file is /etc/vold.conf.
Specify an alternate log file. The default log file is /var/adm/vold.log.
Change the level (verbosity) of debug messages sent to the log file. The range is 0 to 99 where 0 is nothing and 99 is everything. The default level is 0.
vold sets the following environment variables to aid programs which are called when events such as insert, notify, and eject occur:
Event that caused this program to be executed.
Pathname of the matched regex from the vold.conf file.
Device (in /vol/dev) that applies to the media.
Name of the volume in question.
User ID of the user causing the event to occur.
Symbolic name of a device containing the volume.
Name of the type of media (CD-ROM, floppy or rmdisk)
Volume Management daemon configuration file. Directs the Volume Management daemon to control certain devices, and causes events to occur when specific criteria are met.
Shared objects called by Volume Management daemon when certain actions occur.
the default log file location (see the -l option for a description).
the default Volume Management root directory.
See attributes(5) for descriptions of the following attributes:
The Volume Management daemon and associated commands might not be included in a future Solaris release.