Skip Headers
Oracle® Fusion Middleware Oracle Reports User's Guide to Building Reports
11g Release 1 (11.1.1)

Part Number B32122-03
Go to Documentation Home
Home
Go to Book List
Book List
Go to Table of Contents
Contents
Go to Index
Index
Go to Master Index
Master Index
Go to Feedback page
Contact Us

Go to previous page
Previous
Go to next page
Next
PDF · Mobi · ePub

1.4 Wizards

Oracle Reports Builder includes wizards to help you quickly and easily define a report and add objects to it. The topics in this section describe each Oracle Reports Builder wizard.

1.4.1 About the Report Wizard

The Report Wizard helps you to quickly and easily define a single-query report for both Web and paper layouts. Oracle Reports Builder uses what you specify on each page of the wizard to create a data model and layout for your report. After the wizard has created the report, you can modify it using the Report Editor views. See Section 1.6.1, "About the Report Editor".

Re-entrancy

To re-enter the Report Wizard for an existing report:

  • Click the report, then choose Tools > Report Wizard.

Using the Report Wizard

For help on the fields on any tab page of the wizard, click Help at the bottom of the tab page.

1.4.2 About the Report Block Wizard

The Report Block Wizard is a version of the Report Wizard. You can open an existing HTML document (Web page) and imbed a report in your Web page using the Report Block Wizard to specify the layout of the data.

Access

To display the Report Block Wizard:

  • In the Paper Layout view or Web Source view, choose Insert > Report Block.

  • In the Paper Layout view, click the Report Block tool in the tool palette, then click in an open area of the Paper Layout view.

Using the Report Block Wizard

For help on the fields on any tab page of the wizard, click Help at the bottom of the tab page.

1.4.3 About the Data Wizard

The Data Wizard helps you to quickly and easily define a query, break groups, and totals for a multiquery report. After the wizard has created the data model, you can:

  • modify the data model in the Data Model view.

  • use the Data Wizard to create additional queries.

  • use the Report Wizard to default the layout.

  • modify the layout in the Paper Layout view, including reordering or adding new layout sections.

Access

To display the Data Wizard:

  • In the Data Model view, choose Insert > Query.

    Note:

    The Data Wizard does not support creating links between queries. To define parent/child query relationships, you can create a data link manually.

Re-entrancy

To re-enter the Data Wizard for an existing query, do either of the following:

  • Right-click the query, and choose Data Wizard.

  • Click the query, then choose Edit > Settings.

Using the Data Wizard

For help on the fields on any tab page of the wizard, click Help at the bottom of the tab page.

1.4.4 About Graphs and the Graph Wizard

The Graph Wizard provides an easy way for you to add a wide variety of graphs to both paper-based and JSP-based Web reports. Oracle Reports Builder uses the information you specify on each page of the wizard to create an XML definition that describes the graph and renders to resulting look-and-feel of the graph at runtime.

For more information, see Chapter 39, "Building a Report with Graphs".