Skip Headers
Oracle® Fusion Middleware Oracle Reports User's Guide to Building Reports
11g Release 1 (11.1.1)

Part Number B32122-03
Go to Documentation Home
Home
Go to Book List
Book List
Go to Table of Contents
Contents
Go to Index
Index
Go to Master Index
Master Index
Go to Feedback page
Contact Us

Go to previous page
Previous
Go to next page
Next
PDF · Mobi · ePub

4.3 Perform Common Tasks

As you work with Oracle Reports Builder, you will become very familiar with the following tasks:

Usage notes

Beginning with Oracle Reports 10g, reports are no longer stored in the database (including the obsolescence of Rename, Grant, and Get Info functionality for reports in the database). Instead, reports are saved to files.

4.3.1 Connecting to a database

To connect to a database when designing a report in Oracle Reports Builder:

  1. Choose File > Connect.

  2. In the Connect dialog box, type the required information in the User Name, Password, and Database fields (click Help for more information), then click Connect.

To connect to a database using the command line:

  • On the rwbuilder or rwrun command line, use the USERID keyword to specify connection information (USERID=username[/password][@database]). For information about USERID, see the Reference > Command Line section of the Oracle Reports online Help.

4.3.2 Opening a report

To open a report:

  1. Choose File > Open.

  2. In the Open dialog box, browse to the report, click its name, then click Open to open the report in Oracle Reports Builder.

4.3.3 Saving a report

To save a report:

  1. Choose File > Save or File > Save As or click the Save button in the toolbar.

  2. In the Save dialog box, browse to the desired location, and type a name for the report, if it has never been saved before. Click Save.

4.3.4 Copying a report

To copy a report:

  1. In the Object Navigator, click the report you want to copy.

  2. Choose File > Save As.

  3. In the Save As dialog box, browse to the desired location, and type a name for the new copy of the report. Click Save.

4.3.5 Renaming a report

To rename a report in the Object Navigator:

  1. In the Object Navigator, double-click the properties icon next to the report name to display the Property Inspector.

  2. In the Property Inspector, under the General Information node, set the Name property by typing a new name.

To rename a report in the file system:

  1. In your operating system's file system (for example, Windows Explorer on Windows), browse to the location of the report.

  2. Click the report name, then click again to make its name active.

  3. Type a new name for the report.

4.3.6 Deleting a report

To delete a report in the Object Navigator:

  1. In the Object Navigator, click the report name, then choose Edit > Delete, or click the Delete button in the toolbar.

  2. In the alert dialog box, click Yes to delete the report. To cancel the delete operation, click No.

To delete a report in the file system:

  1. In your operating system's file system, for example, Windows Explorer on Windows, browse to the location of the report.

  2. Click the report name, then choose File > Delete.

  3. In the alert dialog box, click Yes to delete the report. To cancel the delete operation, click NoS.

4.3.7 Selecting and deselecting objects

To manipulate objects or define their properties, you must first select them.

4.3.7.1 Selecting single objects

To select a single object in the Object Navigator:

  • Click the object. If the object is displayed in one of the Report Editor views, it is also selected in the corresponding view.

To select a single object in the Data Model view, Paper Layout view, Paper Design view, or Parameter Form view:

  1. If a tool in the tool palette is active, first click the Select tool in the tool palette.

  2. Click the object.

4.3.7.2 Selecting multiple objects

To select multiple objects in the Object Navigator:

  • Click the first object, then either:

    • Shift-click another object to select all objects between the first and current object.

    • Or, control-click additional objects to add them to the selection group.

    Objects that are displayed in one of the Report Editor views are also selected in the corresponding view.

To select multiple objects in the Data Model view, Paper Layout view, Paper Design view, or Parameter Form view:

  1. If a tool in the tool palette is active, first click the Select tool in the tool palette.

  2. Do either of the following:

    • Shift-click each object.

    • Or, click and drag a region that includes all of the objects you want to select. (In the Data Model view, note that if the first object you select is a column within a group, everything else you select must be a column within the same group; you cannot select columns within groups at the same time as you select queries, groups, report-level columns, or parameters.)

4.3.7.3 Selecting objects owned by a frame

To select a set of objects owned by a frame or repeating frame:

  1. In the Paper Layout view, either:

    • Click the Confine On button in the toolbar.

    • Or, if you want to explicitly select all objects to set common properties, click the Frame Select button in the toolbar.

  2. Click the frame or repeating fame.

    All objects within the frame or repeating frame are selected, depending upon their explicit anchors.

4.3.7.4 Selecting grouped objects

To select grouped objects (grouped using Layout > Group Operations > Group), click the Select tool in the tool palette and click one of the grouped objects.

4.3.7.5 Selecting all objects in a report region

To select all objects within the region (Body or Margin of the Header Section, Main Section, or Trailer Section) you are currently editing, choose Edit > Select All. (In the Data Model view, note that this does not select any columns within groups.)

4.3.7.6 Selecting overlapped objects

To select any object that is partially or completely overlapped by another object:

  1. Click the object that obscures the object you want to select.

  2. Choose Layout > Send to Back to move the object that you want on top of the object that obscured it.

  3. Click the object.

4.3.7.7 Deselecting single objects

To deselect a single object in the Object Navigator:

  • Control-click the object. If the object is displayed in one of the Report Editor views, it is also deselected in the corresponding view.

To deselect a single object in the Data Model view, Paper Layout view, Paper Design view, or Parameter Form view:

  • Shift-click the object.

4.3.7.8 Deselecting multiple objects

To deselect all selected objects:

  • Click anywhere in a blank area.

4.3.8 Deleting an object

To delete an object:

  1. Click the object(s).

    Tip:

    To select multiple objects, click one object, then Shift-click all other objects. To select all objects, choose Edit > Select All.

  2. Choose Edit > Delete.