Skip Headers
Oracle® Fusion Middleware Oracle Reports User's Guide to Building Reports
11g Release 1 (11.1.1)

Part Number B32122-03
Go to Documentation Home
Home
Go to Book List
Book List
Go to Table of Contents
Contents
Go to Index
Index
Go to Master Index
Master Index
Go to Feedback page
Contact Us

Go to previous page
Previous
Go to next page
Next
PDF · Mobi · ePub

4.5 Work with Reports

This section provides procedures for the following tasks that you may perform as you work with reports (either paper-based or Web-based):

4.5.1 Creating a report

To create a single-query report:

  1. In the Object Navigator, click the Reports node, then click the Create button in the toolbar.

  2. In the New Report dialog box, click Use the Report Wizard, then click OK.

  3. Follow the Report Wizard to create your report, clicking Help for assistance on any tab page.

  4. Modify the resulting report output in the Web Source view or Paper Design view, or choose Tools > Report Wizard to re-enter the wizard.

To build a multiquery report:

  1. Create each query using the Data Wizard, clicking Help for assistance on any tab page (see Section 4.8.1.2, "Creating a query: Data Wizard").

  2. Create a layout for the report (see Section 4.5.4, "Creating a default layout for a report").

See also

Section 1.2.1, "About Reports"

Section 1.2.2, "About Web Reports"

Section 4.5.1, "Creating a report"

Section 1.3.1, "About tabular reports"

Section 1.3.2, "About group above reports"

Section 1.3.3, "About group left reports"

Section 1.3.4, "About form-like reports"

Section 1.3.5, "About form letter reports"

Section 1.3.6, "About mailing label reports"

Section 1.3.7, "About matrix reports"

Section 2.1.7, "About nested matrix reports"

Section 2.1.8, "About matrix with group reports"

4.5.2 Creating a multiquery group above report

See the example report in Chapter 11, "Building a Two-Query Group Report".

4.5.3 Creating a nested matrix report

See the example report in Chapter 26, "Building a Nested Matrix Report".

4.5.4 Creating a default layout for a report

To create a default layout for a report:

  1. To default the layout for the current report (by default, the Main section of the report), choose Tools > Report Wizard, then follow the wizard to create the layout for the report style you choose.

  2. To add another layout section to the current report layout, create an additional report layout, as described below.

  3. Make further modifications to the default layout manually in the Paper Layout view.

    Caution:

    If you re-enter the Report Wizard after making manual adjustments to your layout in the Paper Layout or Paper Design view, you will lose these layout changes when you click Finish in the Report Wizard, which redefaults the layout.

See also

Section 2.4.2, "About layout defaulting"

Section 4.10.2, "Creating a default layout for a section"

Chapter 4, "Changing the default layout spacing"

4.5.5 Creating an additional report layout

To add a new layout section to a report without overriding existing layouts:

  1. In the Paper Layout view, click the Report Block tool in the tool palette.

  2. Drag a rectangular area for the new layout to display the Report Block Wizard.

  3. Follow the wizard to select the data to display in the new layout section.

  4. To reorder the layout sections, click and drag them to new positions in the Paper Layout view.

  5. Modify the report output in the Paper Design view.

    Caution:

    If you re-enter the Report Wizard to make modifications, then click Finish in the Report Wizard, your entire layout will be overwritten with a new default layout. You will lose the additional report layout you have created, and any manual changes made to the layout in the Paper Layout or Paper Design view.

4.5.6 Adding a title to a report

To add a title to a report:

  1. In the Object Navigator, select or open the report.

  2. Choose Tools > Report Wizard.

  3. On the Style page, type a title for the report in the Title field.

  4. If the report title is to be used in a template, see Section 4.12.5, "Formatting the report title in a template".

See also

Section 2.1.1, "About report titles"

Section 2.7.1, "About templates"

4.5.7 Adding a table of contents to a report

To create a table of contents (TOC) for a report, you can use the Format Order property or the SRW.SET_FORMAT_ORDER built-in procedure to format the Main section of the report first and use report triggers to build a table containing the TOC entries. When the first element for the TOC is formatted, a trigger fires and creates a row in the TOC table containing the TOC entry and the page number. After the Main section has completed formatting, the format order setting can define that the Header section is formatted next. The Header section can contain a report block based on the TOC table. After formatting, you can output your report with a TOC (the Header section), followed by the report body (the Main section), followed by the Trailer section.

For two step-by-step examples, see Chapter 35, "Building a Paper Report with a Simple Table of Contents and Index" and Chapter 36, "Building a Paper Report with a Multilevel Table of Contents".

See also

Section 2.8.1, "About format order"

4.5.8 Adding index to a report

To create an index for a report, you can use report triggers to build a table containing the index entries as you format the Main section of your report. When the first element for the index is formatted, a trigger fires and creates a row in the index table containing the index entry and the page number. After the Main section has completed formatting, the Trailer section is formatted next by default. The Trailer section can contain a report block based on the index table. After formatting, you can output your report with the report body (the Main section), followed by an index (the Trailer section).

For a step-by-step example, see Chapter 35, "Building a Paper Report with a Simple Table of Contents and Index".

4.5.9 Creating an ASCII (character-mode) report

To create an ASCII (character-mode) report:

  1. First, create and save a report using the Report Wizard.

  2. In the Object Navigator, under the Reports node, click the report you want to convert to character mode.

  3. Choose Tools > File Conversion.

  4. In the Convert dialog box, on the Conversion tab page:

    • set Document Type to Report.

    • set Source to the name of the existing bit-mapped report.

    • set Destination Type to Report Binary File (RDF).

    • set Destination to the name of the new character-mode report.

  5. On the Options tab page, set Destination Unit to Character.

  6. Click OK.

  7. Set properties for your new character-mode report.

See also

Section 2.8.15, "About creating an ASCII (character-mode) report"

Section 4.2.5, "Setting properties for an ASCII (character-mode) report"

4.5.10 Preparing a multiplatform report

To prepare a report to run on multiple platforms, consider the following GUI differences:

Fonts: A font type, style, or size might not be available in the target GUI. You can handle this in one of two ways:

  • Use a font that you know exists on the target GUI or one that maps well to the default font of the target GUI.

  • Modify the font mapping file, uifont.ali, to ensure that the fonts map correctly.

Colors: A color might not be available in the target GUI. If possible, use a color that you know exists on the target GUI; otherwise, use one that maps well to the default color of the target GUI. The following colors are typically available on many platforms: blue, magenta, red, cyan, green, yellow.

DPI: The dots-per-inch (DPI) that your monitor uses may not be the same as the DPI used by the person who runs the report. The DPI only affects how alpha-numeric characters word-wrap on the screen. If you design a report that may be displayed in the Paper Design view, try to use the same DPI as the people who will run it. Also avoid giving layout objects fixed sizing.

4.5.11 Preparing a report for translation into other languages

For detailed information about National Language Support (NLS), review the topics in the National Language Support section of the Oracle Reports online Help.