Skip Headers
Oracle® Fusion Middleware Oracle Reports User's Guide to Building Reports
11g Release 1 (11.1.1)

Part Number B32122-03
Go to Documentation Home
Home
Go to Book List
Book List
Go to Table of Contents
Contents
Go to Index
Index
Go to Master Index
Master Index
Go to Feedback page
Contact Us

Go to previous page
Previous
Go to next page
Next
PDF · Mobi · ePub

4.7 Run and Dispatch a Report

This section provides procedures for the following tasks that you may perform as you run and dispatch a report:

4.7.1 Running and dispatching a report from the user interface

To run and dispatch a report from the Oracle Reports Builder user interface:

  1. In the Object Navigator, click the report name, or choose File > Open to open it.

  2. If you are not already connected, connect to a database.

  3. Click the Run Paper Layout button in the toolbar.

  4. If the Runtime Parameter Form displays, specify settings for the desired output:

    Note:

    When you create the report, you must use the Parameter Form Builder (choose Tools > Parameter Form Builder) to select the system and user parameters you want to appear in the Runtime Parameter Form.

    • To preview output in the Paper Design view using screen fonts: set Destination Type to Screen.

    • To preview output in the Paper Design view using screen fonts and size the fonts using the printer font metrics: set Destination Type to Preview.

    • To send output to a file: set Destination Type to File, Destination Name to the path and filename, Destination Format to the output format for the report (for example, PDF, HTML, HTMLCSS, RTF, XML, or DELIMITED for bitmapped reports, or the character-mode printer definition file (.prt file) for character-mode reports).

      Note:

      • It is not possible to generate spreadsheet output directly from Oracle Reports Builder. Instead, on the command line, you can run the report using rwrun and Reports Server clients (rwclient, rwservlet), with DESFORMAT=SPREADSHEET or DESFORMAT=ENHANCEDSPREADSHEET.

    • To send output to a printer: set Destination Type to Printer and Destination Name to the printer driver name.

    • To send output through e-mail using your Internet standard protocol SMTP e-mail application: set Destination Type to Mail and leave Destination Name blank. In the Mail dialog box, specify the recipients and subject line for your e-mail report.

      Note:

      The configuration file ORACLE_HOME\reports\conf\rwbuilder.conf must include the plug-in parameter mailServer (for example, <pluginParam name="mailServer">smtp01.mycorp.com</pluginParam>) with the outgoing mail server name. This applies in both the Windows and Solaris environments.

  5. In the Runtime Parameter Form, click the Run Report button in the toolbar.

  6. If a dialog box appears, enter required information.

Usage notes

  • If you want the orientation of the report to be landscape, you must change the orientation for the report (see Section 4.7.14, "Changing orientation"). However, if your printer does not support the specified page size, you may get truncated results. To enable character-mode printers to support landscape (or other page sizes), you can set printer escape sequences in the printer definition files. Refer to your printer documentation for the escape sequences to use.

  • When you view the report output in Microsoft Word, you must choose View > Page Layout to see all the graphics and objects in your report.

See also

Section 4.11.6, "Selecting parameters to include in the Runtime Parameter Form"

4.7.2 Running a report from the command line

To run a runfile (.rep) or a report definition file (.rdf) from the command line on Windows:

  1. Type %ORACLE_HOME%\BIN\rwrun, followed by the report name and desired arguments.

  2. If you sent the output to a file (DESTYPE=FILE DESNAME=filename DESFORMAT=fileformat), open or print the file to verify the output.

See also

Section 1.12, "Oracle Reports Components"

Topic "rwrun" in the Reference section of the Oracle Reports online Help

Section 2.8.2, "About batch reporting"

4.7.3 Running a report using a command file

To run a report using a command file on Windows:

  1. Create a text file using a word processor of your choice.

  2. In the file, type %ORACLE_HOME%\BIN\rwrun, followed by the report name and desired arguments.

  3. Name the file filename.bat.

  4. To run the report, type filename.bat on the command line.

  5. If you sent the output to a file (DESTYPE=FILE DESNAME=filename DESFORMAT=HTML), open or print the file to verify the output.

See also

Section 2.8.2, "About batch reporting"

Section 1.12, "Oracle Reports Components"

Topic "rwrun" in the Reference section of the Oracle Reports online Help.

4.7.4 Running a report to a remote Reports Server

To run a report to a remote Reports Server:

  • Type %ORACLE_HOME%\bin\rwclient, followed by the report name, server name, and desired arguments.

For additional information, see the Oracle Fusion Middleware Publishing Reports to the Web with Oracle Reports Services manual.

4.7.5 Generating HTML or HTMLCSS output

To apply external style sheets and user-defined styles to your report or report objects for HTMLCSS output, you can set the following properties (for information about these properties, see the Reference > Properties section of the Oracle Reports online Help) :

  • Style Sheets property CSS Class Name property CSS ID property

To generate HTML or HTMLCSS output:

  1. In the Object Navigator, select or open the report, then click the Run Paper Layout button in the toolbar to run the report.

  2. In the Paper Design view, specify the scope of output you want to display:

    • To display only the current page of the report, choose File > Preview Format > Current Page.

    • To display all pages, choose File > Preview Format > All Pages.

      Note:

      If you choose to show all pages of your report output, and you have HTML page streaming enabled, the first page will display in your Web browser, and you will be able to quickly navigate to any other page in the rest of the report.

  3. To preview your HTML or HTMLCSS report output in a Web browser, choose File > Preview Format > Paginated HTML or Paginated HTMLCSS (to format with style sheet extensions).

  4. To save your report output as an HTML or HTMLCSS, choose File > Generate to File.

See also

Section 2.8.8, "About HTML and HTMLCSS output"

Section 2.8.8.1, "About HTML page streaming"

Section 2.2.11, "About style sheets"

4.7.6 Generating PDF output

To generate PDF output:

  1. In the Object Navigator, select or open the report, then click the Run Paper Layout button in the toolbar to run the report.

  2. In the Paper Design view, specify the scope of output you want to display:

    • To display only the current page of the report, choose File > Preview Format > Current Page.

    • To display all pages, choose File > Preview Format > All Pages.

  3. To preview your PDF report output in your Web browser, choose File > Preview Format > PDF.

  4. To save your report output as a PDF file, choose File > Generate to File > PDF.

See also

Section 2.8.10, "About PDF output"

4.7.7 Generating XML output

In any Oracle Reports-generated XML file, your output mimics the data model; that is, it is structured by groups and columns. Follow the steps below to do any of the following:

  • Generate an XML output file from your current report.

  • Preview the contents of an XML file in a Web browser in conjunction with command line invocation.

  • Change the XML properties that control XML output for the entire report.

  • Change the XML properties that control XML output for a column or group.

To generate an XML output file from your current report in Oracle Reports Builder:

  1. Optionally, in the Object Navigator, select or open the report, then click the Run Paper Layout button in the toolbar to run the report. Currently, any report style can be generated to XML output, but with limited support for matrix-style reports.

  2. Optionally, in the Paper Design view, choose File > Preview Format > XML to preview XML data in your default XML viewer (for example, your Web browser).

    Tip:

    An .XML extension is required by XML-supporting browsers to recognize the format as XML and display it accordingly.

  3. Click the report in the Object Navigator, and choose File > Generate to File > XML to save the XML output file to the directory of your choice.

To generate an XML output file from the command line, then preview the contents of the XML file in a Web browser:

  1. On the command line, run your report with the arguments DESFORMAT=XML, DESTYPE=FILE, and DESNAME=filename.XML.

  2. Open an XML-supporting Web browser.

  3. Choose File > Open to navigate to the XML file that you just generated, and display it in the browser window.

  4. If you make changes to the XML output or regenerate the XML file with the same name, click the Reload button in your browser to view the updated XML output.

To change the XML properties of the entire report:

  1. In the Object Navigator double-click the properties icon next to the report name to display the Property Inspector.

  2. Under XML Settings, set the XML properties as required for this report.

To change the XML properties of a column or group:

  1. In the Data Model view, double-click the column or the title bar of the group to display the Property Inspector.

  2. Under XML Settings, set the XML properties as required.

Usage notes

  • Oracle Reports Builder creates "well-formed" XML output. This means that there is an XML Declaration present in the prolog of the XML document, but not necessarily a DTD (document type definition). If you wish to create "valid" XML, you must add the DTD in the XML Prolog Value property field at the report level.

  • For a report developed in a release prior to Oracle Reports 10g Release 2 (10.1.2) patch 2, you may encounter the following issue when saving the report in XML format: if the report defines a PL/SQL package, the package specification, and sometimes the body, is not saved in the XML report. To resolve this issue, perform either of the following steps:

    • If the RDF exists, regenerate the XML output file using Oracle Reports 10g Release 2 (10.1.2) patch 2 or later.

    • If the RDF does not exist, edit the XML to manually to add type="packageSpec" and/or type="packageBody" to the function element, as shown in the following example:

      <programUnits>
        <function name="a" type="packageSpec">
          <textSource>
            <![CDATA[
              PACKAGE a IS
                function lire return date ;
              END a;
            ]]>
          </textSource>
        </function>
        <function name="a" type="packageBody">
          <textSource>
            <![CDATA[
              PACKAGE BODY a IS
                function lire return date is
                  c2 date;
                  begin
                    c2 :=sysdate;
                    return c2;
                  end;
              END;
            ]]>
          </textSource>
        </function>
        <function name="cf_1formula" returnType="date">
          <textSource>
            <![CDATA[
              function CF_1Formula return Date is
                aa date;
                begin
                  --aa :=a.lire;
                end;
            ]]>
          </textSource>
        </function>
      </programUnits>
      
  • If your report includes a graph, the graph information will not be saved in the XML file (XML is text-based output, which means images are not included).

See also

Section 2.8.7, "About XML in reports"

Topic "Oracle Reports XML tags" in the Reference section of the Oracle Reports online Help.

Chapters "Creating Advanced Distributions" and "Customizing Reports with XML" in the Oracle Fusion Middleware Publishing Reports to the Web with Oracle Reports Services manual.

4.7.8 Generating RTF output

To generate RTF output:

  1. In the Object Navigator, select or open the report, then click the Run Paper Layout button in the toolbar to run the report.

  2. To preview your report output in a Microsoft Word document, choose File > Preview Format > RTF.

  3. To save your report output as an RTF file, choose File > Generate to File > RTF.

  4. In the Save dialog box, specify a location and file name. Click Save.

See also

Section 2.8.11, "About RTF output"

4.7.9 Generating text output

To generate text output:

  1. To generate pure text output, which can be read by many different applications, set the Initial Value property of the MODE system parameter to Character (see Section 4.11.1, "Using a pre-defined system parameter").

    Note:

    If MODE is set to Bitmap (the default), the result is PostScript output, which can be read and rendered only by PostScript-compatible applications (such as a PostScript printer).

  2. In the Object Navigator, select or open the report, then click the Run Paper Layout button in the toolbar to run the report.

  3. To preview your report output in a text viewer, choose File > Preview Format > Text.

  4. To save your report output as a text file, choose File > Generate to File > Text.

  5. In the Save dialog box, specify a location and file name. Click Save.

See also

Section 2.8.14, "About text output"

4.7.10 Generating delimited output

You can generate a report to delimited output using either of the following methods:

  • From Oracle Reports Builder

  • From the command line

To generate delimited output from Oracle Reports Builder:

  1. In the Object Navigator, select or open the report, then click the Run Paper Layout button in the toolbar to run the report.

  2. To preview your delimited report output in a spreadsheet, choose File > Preview Format > Delimited or File > Preview Format > DelimitedData (for large volume reports).

  3. To save your delimited report output to a file, choose File > Generate to File > Delimited or File > Generate to File > DelimitedData (for large volume reports).

  4. In the Delimited Output dialog box or DelimitedData Output dialog box, choose from the list or type the delimiter that will separate the cells in your report output.

  5. If you want to use formatting options, choose from the list or type a Date Format Mask or a Number Format Mask.

  6. If you want to use a cell wrapper, choose from the list or type the cell wrapper that will be placed around the cell data in your report output.

  7. Click OK.

  8. In the Save dialog box, specify a location and file name. Click Save.

To generate delimited output from the command line:

  • Run a report using Reports Server clients (rwclient, rwservlet) or rwrun, with DESFORMAT=DELIMITED or DELIMITEDDATA.

Note:

  • To run a report through a URL, specify the Excel mimetype so that your browser opens the report output directly in Excel. For example:

    http://hostname:port/reports/rwservlet?report=report_name
      +server=server_name+userid=db_connect_string+destype=cache
      +desformat=delimited+mimetype=application/vnd.ms-excel
    

You can open your delimited output file (.csv) to display it automatically in Microsoft Excel. Or, you can import the output file into an existing Excel worksheet.

Usage notes

  • You can distribute a report in DelimitedData output format, specified either in a distribution XML file or in the Distribution dialog box.

Limitations

  • When generating a report to delimited output, only data (as defined by the report Data Model), no layout information, displays in Microsoft Excel. To generate report output that preserves the layout information in Excel, see Section 2.8.13, "About Enhanced Spreadsheet output".

  • Report distribution does not support Delimited output format. You cannot specify DELIMITED as an output format in a distribution XML file or in the Distribution dialog box.

  • Report bursting does not support Delimited or DelimitedData output format.

See also

Section 2.8.12, "About delimited output"

Section 4.9.7.1, "Specifying date and time format masks"

Section 4.9.7.2, "Specifying number format masks"

4.7.11 Generating Enhanced spreadsheet output

To generate Enhanced spreadsheet output:

  • On the command line, run the report using rwrun or Reports Server clients (rwclient, rwservlet), with DESFORMAT=ENHANCEDSPREADSHEET.

    For example, to use rwservlet to generate Microsoft Excel output from the paper layout of your report, enter a command that includes the following:

    http://hostname:port/reports/rwservlet?report=report_name
      +server=server_name+userid=db_connect_string+destype=file
      +desformat=enhancedspreadsheet+desname=C:\temp\myexcel_output.htm
    

Notes:

  • Microsoft Office 2000/2002/2003 supports Hypertext Markup Language (HTML) as a native file format. Enhanced Spreadsheet output relies on producing HTML output, which can be understood by Excel as a file with valid Excel format.

  • For reliable formatting, enclose the whole layout area in a frame. This prevents the possibility of parallel objects displaying in different vertical positions, one below the other.

See also

Section 2.8.13, "About Enhanced Spreadsheet output"

Chapter 29, "Building a Report for Enhanced Spreadsheet Output"

4.7.12 Distributing a report to multiple destinations

To distribute a report, you first define the distribution, then enable the distribution.

You can define the distribution for a report in any of the following ways:

  • Use XML, as described in the chapter "Creating Advanced Distributions" in the Oracle Fusion Middleware Publishing Reports to the Web with Oracle Reports Services manual.

  • In the Distribution dialog box, define a distribution list for the entire report or any report section.

    Note:

    To display the Distribution dialog box: In the report or section Property Inspector, under the Report node, click the Distribution property value field.

    For an example of using section-level distribution, see Chapter 37, "Bursting and Distributing a Report". This chapter covers defining distribution of a single section to multiple destinations, using the Repeat On property and distribution XML file.

  • On the command line, include the DESTINATION keyword to specify a DST file or XML file.

    Note:

    The DST file method is supported for backward compatibility; the preferred and recommended method of distributing reports is with XML or the Distribution dialog box.

  • To enable the distribution of a report, you can do either of the following:

    • Choose File > Distribute in Oracle Reports Builder.

    • Specify DISTRIBUTE=YES on the command line.

You can also trace the report distribution to verify a successful distribution, as described in Section 4.14.19, "Tracing report distribution".

Usage notes

  • In order to use the same report definition file to burst and distribute to data-driven formats such as XML and DELIMITEDDATA, as well as to layout-driven formats such as PDF and ENHANCEDSPREADSHEET, you must ensure the following requirements are met:

    • The distribution XML file must specify the include element. For example:

      &lt;include src="mainSection"/&gt;
      
    • The Repeat On property must be set appropriately for the section(s) specified in the distribution XML file.

    • The section(s) specified in the distribution XML file in the report paper layout must not be empty.

  • In some cases, Microsoft Internet Explorer ignores the mimetype of a URL's return stream and instead sets the type by looking at the URL. This can be a problem when you are defining the distribution for a report because your URL might end with the DESTINATION keyword. For example:

    ...DISTRIBUTE=yes 
    DESTINATION=c:\oracle\reports\distribution\mydist.xml
    

    In this scenario, the URL ends with the extension xml and Internet Explorer treats the return stream as XML, when in fact it is HTML. As a result, you will receive a browser error. To work around this issue, you should never use recognized file extensions at the end of a URL. In the preceding example, you could switch the positions of the DISTRIBUTE and DESTINATION keywords in your URL.

See also

Section 2.8.3, "About report distribution"

Section 2.1.2, "About report sectioning and sections"

Chapter "Creating Advanced Distributions" in the Oracle Fusion Middleware Publishing Reports to the Web with Oracle Reports Services manual.

4.7.13 Deploying a report

To deploy a report so that end users can view it, refer to the section "Deploying Your Reports" in the chapter "Running Report Requests" in the Oracle Fusion Middleware Publishing Reports to the Web with Oracle Reports Services manual. This section describes how to deploy a report with a paper layout (that is, a REP, RDF, XML, spreadsheet, or JSP report) and how to deploy a report with a Web layout (that is, a JSP report).

4.7.14 Changing orientation

To change the orientation (portrait or landscape) of a report section, follow the steps for the desired output format:

Printer output (DESTYPE=PRINTER) or RTF output (DESFORMAT=RTF)

The orientation of report output is based on the following order of precedence:

  1. ORIENTATION command line keyword.

  2. ORIENTATION system parameter.

  3. Orientation property for the pertinent report section (Header, Main, or Trailer): Portrait or Landscape.

  4. (If the Orientation property is set to Default) Width and Height properties for the pertinent report section:

    • If Width is greater than Height (for example, 11 x 8.5), then orientation is landscape.

    • If Height is greater than Width (for example, 8.5 x 11), then orientation is portrait.

To set the report output orientation, do one of the following:

  • On the command line, specify the ORIENTATION command line keyword. This takes precedence over the ORIENTATION system parameter, the Orientation property, and the Width and Height properties. For information about the ORIENTATION command line keyword, see the appendix "Command Line Keywords" in the Oracle Fusion Middleware Publishing Reports to the Web with Oracle Reports Services manual.

  • Specify the ORIENTATION system parameter. This takes precedence over the Orientation property, and the Width and Height properties. To specify the ORIENTATION system parameter, which allows end users to modify the orientation at runtime:

    • Choose Tools > Parameter Form Builder to display the Parameter Form Builder.

    • Click the ORIENTATION system parameter.

    • Click OK to display the Paper Parameter Form view.

    • Double-click the Orientation value field (PF_ORIENTATION) to display the Property Inspector.

    • Under the Parameter node, set the Initial Value property to Portrait or Landscape.

    • Click the Run Paper Layout button in the toolbar.

    • From the Orientation list, change the orientation if desired.

  • Set the Orientation property and/or the Width and Height properties:

    • In the Object Navigator, under the Paper Layout node, double-click the properties icon for the pertinent report section (Header, Main, or Trailer) to display the Property Inspector (by default, a report is defined in the Main Section).

    • In the Property Inspector, under the Section node, set the Orientation property to the desired value. If set to Portrait or Landscape, this value takes precedence over the Width and Height properties. If set to Default, orientation is based on the values of the Width and Height properties (landscape orientation if Width is greater than Height, and portrait orientation if Height is greater than Width).

PDF output

For PDF output, any values specified for the ORIENTATION command line keyword, ORIENTATION system parameter, and Orientation property are ignored. Orientation of the PDF output is based solely on the values of the Width and Height properties:

  1. In the Object Navigator, under the Paper Layout node, double-click the properties icon for the pertinent report section (Header, Main, or Trailer) to display the Property Inspector (by default, a report is defined in the Main Section).

  2. In the Property Inspector, under the Section node, set the Width and Height properties as desired (for example, 11 (or 15) width x 8.5 height for landscape, or 8.5 width x 11 (or 15) height for portrait). Make sure that you subtract the margin depths (for example, for an 8.5 x 11 page with top, bottom, left, and right margins of .25, set Width to 8 and Height to 10.5).

See also

Section 2.1.2, "About report sectioning and sections"

4.7.15 Suppressing the Parameter Form

If the report is run from another product, you may not want the Parameter Form to appear.

To suppress the Parameter Form and have the report assign a default value to DESTYPE, do either of the following:

  • Create a list parameter to explicitly pass the values of DESTYPE and PARAMFORM.

  • In the Preferences dialog box (Edit > Preferences), on the Runtime Settings page, clear the Parameter Form check box to specify PARAMFORM=NO.

See also

Section 1.6.5, "About the Paper Parameter Form view"

Section 1.11.1, "About the Runtime Parameter Form"

Section 1.9.4, "About Parameter Forms for Web reports"

4.7.16 Viewing report output

This section provides procedures for various ways to view report output:

4.7.16.1 Viewing the printable area

The printable area is the physical region in which your printer can print on a physical page. Most printers usually cannot print up to the edge of a page, leaving a blank "unprintable" area.

To view the printable area of your report:

  1. Choose File > Page Setup to specify your page settings.

  2. In the Paper Layout view, click the Edit Margin button in the toolbar.

    The printable area is displayed as the area within the dotted lines in the margin area.

  3. Choose View > Zoom > Zoom Out to see more.

4.7.16.2 Displaying report output in the Paper Design view

The Paper Design view is displayed whenever you run a report.

To run a report from the Object Navigator or any editor:

  • Click the Run Paper Layout button or choose Program > Run Paper Layout.

To run a report from the Report Wizard:

  • Click Finish.

You can also display the Paper Design view in these ways:

  • Click the Paper Design View button in the toolbar.

  • Choose View > Change View > Paper Design.

  • In the Object Navigator, double-click the view icon next to the Paper Design node.

In the Paper Design view, manipulate the output as desired, and use any of the following features:

See also

Section 4.7.17.1, "Printing a report from the Paper Design or Paper Layout view"

4.7.16.3 Displaying report output in the Previewer

To display your report output in the Previewer:

  1. In the Paper Design view, choose File > Print Preview.

  2. In the Previewer, use any of the following features:

See also

Section 1.11.2, "About the Previewer"

Section 4.7.17.2, "Printing a report from the Previewer"

4.7.16.4 Displaying report output in your Web browser

To display report output in your Web browser:

  1. In the Object Navigator, select or open the report, then click the Run Paper Layout button in the toolbar to run the report.

  2. In the Paper Design view, specify the scope of output you want to display:

    • To display only the current page of the report, choose File > Preview Format > Current Page.

    • To display all pages, choose File > Preview Format > All Pages.

      Note:

      If you choose to show all pages of your report output, and you have HTML page streaming enabled, the first page will display in your Web browser, and you will be able to quickly navigate to any other page in the rest of the report.

  3. To preview your report output in a Web browser, choose File > Preview Format > Paginated HTML, File > Preview Format > Paginated HTMLCSS (to format with style sheet extensions), File > Preview Format > PDF, or File > Preview Format > XML (if you have an XML-supporting browser set as your default XML viewer).

  4. To preview your report output with Web layout in a Web browser, choose Program > Run Web Layout to run the Web Source. If you have made changes to the Web Source view (for JSP-based Web reports), this enables you to immediately see the effect of your changes on the output.

    Note:

    If Netscape 7.0 is your default browser, and the browser does not display, set the registry key HKEY_CURRENT_USERS\Software\Oracle\Toolkit\Tkbrowser to the default browser location. Ensure that the BrowserName and the BrowserPath keys reflect the correct values. For example: BrowserName=Netscape 7; BrowserPath=C:\Program Files\Netscape\Netscape\Netscp.exe.

  5. To save your report output as an HTML, HTMLCSS, PDF, or XML file, choose File > Generate to File.

See also

Section 1.2.2, "About Web Reports"

Section 2.2.2, "About previewing JSP-based Web reports"

Section 2.2.11, "About style sheets"

Section 4.7.17.3, "Printing a report from your Web browser"

4.7.16.5 Displaying individual pages of HTML report output

To paginate the HTML output for a report:

  1. Specify navigation controls for HTML page-streamed output using either of the following methods:

  2. Enable HTML page streaming by running your report from the command line, specifying PAGESTREAM=YES.

See also

Section 1.2.2, "About Web Reports"

Section 2.8.8.1, "About HTML page streaming"

4.7.16.6 Scrolling and paging

To move around pages of the report using the scroll bars and paging buttons:

  • Use the mouse cursor to drag the horizontal and vertical scroll bars to move around the current page.

  • Click the First Page, Previous Page, Next Page, and Last Page buttons in the toolbar to display the indicated pages of the report.

  • To display a specific page, type the page number in the Page field.

4.7.16.7 Splitting the viewing region

To create two views of the report output by splitting the display horizontally or vertically:

  • In the Data Model view, Paper Layout view, Paper Design view, or Paper Parameter Form view, drag the black bar below the vertical scroll bar (to split horizontally), or to the right of the horizontal scroll bar (to split vertically).

  • In the Previewer, drag the grey bar above the vertical scroll bar (to split horizontally), or to the left of the horizontal scroll bar (to split vertically)

You can scroll and page within each view to move the contents of that view while the other view remains unchanged.

4.7.16.8 Magnifying or reducing the output

To magnify a hard-to-see portion of your report:

  • In the Data Model view, Paper Layout view, Paper Design view, or Paper Parameter Form view, click the Magnify tool in the tool palette (or, choose View > Zoom > Zoom In).

  • In the Previewer, click the Zoom In button in the toolbar.

To reduce the image to get a sense of your report's overall layout:

  • In the Data Model view, Paper Layout view, Paper Design view, or Paper Parameter Form view, choose View > Zoom > Zoom Out or Normal Size.

  • In the Previewer, click the Zoom Out button in the toolbar.

4.7.17 Printing a Report

This section provides procedures for the following tasks that you may perform to print a report:

Before printing your report from the Reports Builder,do the following:

  • Configure a valid printer, and enter the value of the printer in the uiprint.txt file which is located at:

    INSTANCE_HOME/config/FRComponent/frcommon/guicommon/tk/admin/uiprint.txt

    OR

  • From the Reports Builder menu, go to Edit > Preferences. Select the Runtime Values tab.

    From the Destination Type drop-down list, select Printer and provide a valid value for printer name, and click OK.

For more information, see "Configuring the Printing Environment" in the Oracle Fusion Middleware Publishing Reports to the Web with Oracle Reports Services manual.

4.7.17.1 Printing a report from the Paper Design or Paper Layout view

To print a report from the Paper Design or Paper Layout view:

  1. In the Paper Design view or Paper Layout view choose File > Print.

  2. In the Print dialog box, type the number of pages and copies you want to print.

  3. Click OK.

See also

Section 4.7.16.2, "Displaying report output in the Paper Design view"

4.7.17.2 Printing a report from the Previewer

To print a report from the Previewer:

  1. In the Previewer, click the Page Setup button in the toolbar to verify your printer setup.

  2. Click the Print button in the toolbar.

  3. In the Print dialog box, specify the pages and copies you want to print.

    If the report has a Destination Type of Screen (set by system parameter DESTYPE), a warning displays to run the report with a Destination Type of Preview before printing. Preview creates PostScript output, which is typically more desirable for printing bit-mapped reports.

  4. Click OK.

See also

Section 4.7.16.3, "Displaying report output in the Previewer"

4.7.17.3 Printing a report from your Web browser

Note:

Formatting with style sheet extensions paginates the HTML document in the same way the report is paginated; formatting without style sheet extensions generates HTML output that does not break between the pages of the report.

To print a report from your Web browser:

  1. If your report is formatted with HTML style sheet extensions (HTMLCSS), set up your browser to print the HTML document in the same way the report is paginated:

    • In your browser, choose File > Page Setup and modify the margin settings as desired.

    • In the Object Navigator, under the Paper Layout node, double-click the Header Section, Main Section, or Trailer Section properties icon for the pertinent report section (Header, Main, or Trailer) to display the Property Inspector (by default, a report is defined in the Main Section).

    • In the Property Inspector, under the Section node, set the Width and Height properties as desired (for example, 11 (or 15) width x 8.5 height for landscape or 8.5 width x 11 (or 15) height for portrait). Make sure that you subtract the margin depths (for example, for an 8.5 x 11 page with top, bottom, left, and right margins of .25, set Width to 8 and Height to 10.5).

  2. Display your report output in your Web browser (see Section 4.7.16.4, "Displaying report output in your Web browser").

  3. Choose File > Print.

See also

Section 1.2.2, "About Web Reports"

Section 2.2.2, "About previewing JSP-based Web reports"

Section 2.2.11, "About style sheets"

4.7.17.4 Printing a report on a preprinted form

See the example report in Chapter 32, "Building a Report Using a Preprinted Form".

4.7.17.5 Switching the printer tray

To switch the printer tray:

  1. Choose File > Page Setup and in the Source list, note the names of the printer trays defined for your printer.

  2. Use SRW.SET_PRINTER_TRAY to define the desired trigger:

See also

Section 2.8.6, "About switching the printer tray"

4.7.17.6 Printing a report on UNIX

Printing on UNIX requires some setup and configuration to create the proper printing environment. For detailed information about printing your reports on UNIX, refer to the chapter "Printing on UNIX with Oracle Reports" in the Oracle Fusion Middleware Publishing Reports to the Web with Oracle Reports Services manual.

Oracle Reports 10g (9.0.4) introduced the following enhancements for printing reports on UNIX:

  • The REPORTS_DEFAULT_DISPLAY environment variable, which provides for the removal of dependency on the DISPLAY environment variable. Prior releases of Oracle Reports required the DISPLAY environment variable to be set to run and print reports on UNIX.

  • The PostScript printer driver screenprinter.ppd, which eliminates the dependency on having a valid printer defined (PRINTER and TK_PRINTER environment variables set to a valid printer, or a valid entry in uiprint.txt) for Reports Runtime on UNIX. This driver provides surface resolution for images and specifies font information. Prior releases of Oracle Reports required a printer to resolve fonts to run and print reports on UNIX.

    This driver is the first entry in uiscreenprint.txt. The file locations (UNIX only) are:

    uiscreenprint.txt: $ORACLE_INSTANCE/config/FRCommon/frcommon/guicommon/tk/admin
    screenprinter.ppd: 
    
      $ORACLE_INSTANCE/config/FRCommon/frcommon/guicommon/tk/admin/PPD
    

Limitations

  • If your report includes an Oracle Graphics 6i graph, a printer is required to generate the graph. However, TK_PRINT_STATUS=echo is set in g90runm.sh. Thus, to run a report with an Oracle Graphics 6i graph without a valid printer, set the PRINTER environment variable to any value.

    Note:

    Oracle Graphics 6i, or Graphics Builder, is obsolete. Instead, use the Graph Wizard, which produces graphs that are automatically translated into JSP tags to enable you to add graphics to Web reports (for additional information, see the Oracle Reports online Help topic "Displaying Oracle Graphics 6i charts in Oracle Reports 11g").

4.7.18 E-mailing a report

To e-mail a report from Oracle Reports Builder:

  1. Log on to your Internet Standard Protocol SMTP mail application.

  2. Select or open the report.

  3. If you are not already connected, connect to a database.

  4. Choose File > Mail.

  5. In the Mail dialog box, specify the recipients and subject line for your e-mail report.

  6. Click OK.

To e-mail a report in batch mode:

  1. Log on to your Internet Standard Protocol SMTP mail application.

  2. Run the report from the command line, specifying DESTYPE=MAIL, and DESNAME=recipient1, recipient2, recipient3, ....

Usage notes

The configuration file $ORACLE_INSTANCE\config\ReportsToolsComponent\
ReportsTools\rwbuilder.conf
must include the plug-in parameter mailServer. For example:

<pluginParam name="mailServer" value="stbeehive.oracle.com">
<property name="enableSSL" value="yes"/>
</pluginParam>

With the outgoing mail server name. This applies in both the Windows and Solaris environments.