Oracle Tuxedo Plug-in for Oracle Solaris Studio User’s Guide

     Previous  Next    Open TOC in new window    View as PDF - New Window  Get Adobe Reader - New Window
Content starts here

Developing an Oracle Tuxedo SCA Application Project

The following sections briefly describe the steps for developing an Oracle Tuxedo SCA application project in the IDE. Details on all of the steps are contained in the Developing Oracle Tuxedo Applications section of the online help in the IDE. To open the online help in the IDE, choose Help > Help Contents.

 


Using the Project Templates

A Tuxedo SCA application consists of a set of servers and the ubbconfig.ubb and root.composite configuration files that describe them. A server consists of a set of components in which services are defined.

With the plug-in installed, the Oracle Solaris Studio IDE includes three project templates for creating the elements of an Oracle Tuxedo SCA application:

To use these templates, choose File > New Project and select the Tuxedo category in the New Project Wizard.

 


Creating an SCA Application Project

The steps for creating an SCA application are:

  1. Create an SCA Application project by choosing File > New Project, and selecting the Tuxedo category and the Tuxedo SCA Application project type. The New Project Wizard guides you through creating the project.
  2. Add SCA servers by creating Tuxedo SCA Server projects.
  3. Add SCA components by creating SCA Component projects.
  4. Add services to the SCA components by doing one of the following:
    • Right-clicking the Service node of the component porject and choosing Add Service
    • Adding a service metadata input (MIF) file to your project.and then generating a new service from the file
    • Adding a web service definition (WSDL) file and then generating a new sercvice from the file
  5. If you want to use a service in other servers in the SCA application than the one in which you created it, promote the service to make it accessible to these servers.
  6. You can also promote an SCA service to use as a web service.

  7. If you want to use an SCA service declared in another server or component, add a reference in the server or component project.
  8. To use your libraries in an SCA component, add the library directories to the linker properties of the project.
  9. Add the client part of the SCA application by adding tests in the Test folders of the server projects.
Note: You can open and edit all of the source code files created in the application, server, and component projects by clicking the Files tab in the IDE and opening the files in the Editor window.

 


Building an SCA Application Project

Build an application, server, or component project by right-clicking the project node and choosing Build.

 


Running an SCA Application Project

To run your SCA application project, right-click the project node and choose Start.

To stop a running SCA application project, right-click the project node and choose Stop.

 


Debugging an SCA Application Project

Debug the server part of the SCA application by setting breakpoints in the source code file of a server project, and right-clicking the server node and choosing Debug.

Debug the client part of the application by debugging the client executable files in the tests in the Test folders of the server projects.

You can use the features of the debugger in the IDE to step through your code, display the call stack, and view the values of variables.

For detailed information on debugging the project, see the Debugging a Project with dbx section of the online help in the IDE.


  Back to Top       Previous  Next